
Workshop Topic 
Creating a Conceptual Model
Vectorworks is extremely good at creating conceptual models, 
especially for urban designs. Vectorworks allows you to import a 
plan of a city (using Shapefiles ) then quickly build the 3D parts of 
the city for you to check your urban design against. You can then add 
a sun to create solar animations, fly around your design, and so on.
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Welcome to this issue of the VectorWorks Short Sharp 
Training (monthly). This manual is designed to work like a 
user group meeting. There is a main workshop topic, then 
extended movies showing tips or techniques and an area 
for beginners. 
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Introduction
3D Modeling in Vectorworks is a lot of fun, and it is extremely productive 
if you apply the basic tools and techniques we covered in February 2012. 
Some people use other software to create conceptual models, but I believe 
that Vectorworks has powerful techniques for this as well. 

In this workshop we will look at applying the techniques we learned to 
a building site. We will be using a city building site for this, but you can 
apply these techniques to landscape, urban design, exhibit design and archi-
tecture.  
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Locate the Site

cadmovie816

You do not have to start with an outline of the site, but it does make it 
much easier to create the conceptual model if you have the context. 

You can locate the site using Google Earth. You can then save this image 
and import it into Vectorworks, but it will not allow you to easily create 3D 
forms for the roads and buildings. 

However, there are websites (e.g. http://koordinates.com/) that offer 
downloads of DWG or Shapefiles  of a chosen site. Koordinates.com 
allows you to locate your site via a map.

http://learn.archoncad.com/?p=1003
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You can then select what additional data you want to overlay the map with. 
Some data is free, others are charged.

Once you have chosen the files you want, you click on the Download or 
Order button.

This website also allows you to choose in what format you want to 
download the information. Shapefiles are geo-referenced, which means 
they know their location in the world.
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 You might be able to select to download the information in DWG format. 
All versions of Vectorworks can import DWG/DXF information.

When you have imported your information, you can then start to convert it 
to a usable format. 
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A Word About Shapefiles 

Shapefiles  are geo-referenced, which means that they know where they are 
in the world. The advantage of Shapefiles is that when you import more 
than one, and they have the same geo-reference, they line up with each 
other. Unlike DWG/DXF files, shapefiles know what size they should be so 
there is no need to check scale or units.

Shapefiles  also carry attached data. This means that when you import 
building outlines for example, you can also find attached information about 
the building. This attached information could be the area of the building or 
could be the height of the building. DWG/DXF files only carry line 
information without any attached data. The data attached to a shape file can 
be used to locate objects,  used in a report, or can be used with a 
Vectorworks command to modify all the objects with the data attached.
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Adding Import Shapefiles... to You Workspace

Shapefiles can only be imported into Vectorworks if you have Vectorworks 
Landmark, or Vectorworks Designer. If you have Vectorworks Architect 
you may not be able to import Shapefiles unless you add the command to 
your workspace. Before you add this command to your workspace, check 
to see if it has already been added. Some users of Vectorworks Architect 
have reported that the command is already there. 

•	 Go to the Menu bar.

•	 Choose Tools > Workspaces > Workspace Editor...

•	 Choose to edit a copy of a standard workspace. If you have already 
edited your workspace, then edit the current workspace. 

•	 Click on the OK button. 
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This is the Workspace Editor Window. 

•	 Use the right side to locate the place on you current workspace where 
you want to add the new command.

•	 On the left side, locate the GIS category. 

•	 Click on the arrow or plus sign to the left of the GIS category. This will 
open the category, showing you all the commands inside.

•	 Click and drag the Import Shapefiles… command.

•	 Drag the command across to the right side of the dialog box.

•	 When you see the black line in the correct location, release your mouse 
button.
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 Check to make sure your command is in the correct location.

•	 Click on the OK button to close the Workspace Editor. All your tools 
and menus will disappear temporarily, and then come back in the correct 
order.

•	  Check to make sure that your new command is in the correct location.
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Creating the Roads

cadmovie817

In this image you can see an imported file. This file is made up of many 
polylines describing the curb lines of the roads. Before we can use this 
information for a model, we will have to fill in the road areas with 
polylines.

When importing files you often end up with complex polygons that have 
thousands of vertices. The large number of vertices makes it difficult for 
Vectorworks to work efficiently. There is a way that you can simplify these 
polygons, and I have written about it in my blog on the subscriber website.

Vectorworks has a tool that will fill in these areas quickly. However, you 
need to limit the areas before we can use the tool.

•	 Use the rectangle or polygon tool to limit the area for your roads.

http://learn.archoncad.com/?p=1001
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Sometimes, complex shapes make it difficult for Vectorworks. If you 
divide your area with lines, it will make it easier for Vectorworks to fill in 
the roads.

•	 Go to the Basic tool palette. 

•	 Click on the Polygon tool. 
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•	 Go to the Tool bar.

•	 Click on the second mode. This mode can be used to flood areas, 
creating polygons or polylines.

•	 Move into an area the road area.

•	 Click once.

•	 Vectorworks will fill the area up to the nearest boundary object. Creating 
the rectangle and the lines will limit the area that Vectorworks has to 
flood, making it easier for this to occur.
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•	 Leave the last area selected.

•	 Move to the next area.

•	 In the image below there is an area of road that stops before the 
boundary rectangle. This will cause the Polygon From Inner Boundary 
Mode to fail

•	 Edit the boundary so that all roads touch it.
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•	 Hold down the shift key and click in the road area. Holding down the 
shift key will join all your flooded areas.

•	 Continue filling in all the required roads using the technique with the 
polygon tool and holding down the shift key.
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•	 Ensure that all the roads are selected.

•	 Go to the Menu bar.

•	 Choose Model >  Extrude…

•	 Do not change the X or Y dimensions.

•	 Enter the extrusion as a negative dimension. Putting in a negative 
extrusion will save you having to move the extrusion down. What you 
really want is the top of the site positioned at zero.
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•	 Go to the Object Info palette.

•	  Change the Bot Z to a suitable height, to place the road below the 
building sites. 
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Creating The Building Sites

cadmovie818

We can use the same technique that we used for the roads to create the 
building sites.

•	 Delete the boundary polygons and guidelines if you added any to make 
it easier to fill the roads. You need to remove these because they will 
slow you down when you try to create your building sites.

•	 Use the polygon tool to fill in each building site.

•	 It will make it easier to see the building sites if you change the color of 
each polygon. If you change the default attributes before you start 
creating the building sites, it will be much quicker.

http://learn.archoncad.com/?p=999
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If you do not keep the new polylines selected, you might find it difficult to 
select the it later, especially if it has no fill. With versions of Vectorworks 
prior to 2012, it is not easy to select objects when they are coincident. You 
can try selecting objects in sending each one to the back until you have the 
object you require.

•	 In Vectorworks 2012, right-click on an object. If there are objects that 
line up (they are coincident) Vectorworks will show an asterisk next to 
the cursor.

•	 Right-click (control+click on a one button mouse).	

•	 From the contextual menu choose Select Coincidence Objects…

The first time you choose select coincident objects, you will see this dialog 
box, telling you about the keyboard shortcut. If you do not want to see this 
dialog box again, click on the option Don’t show this dialog again.

•	  Click on the OK button.
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 Vectorworks will select the uppermost object when you click.

All the objects that are coincident are shown in the Select dialog box. 

•	 Use your up/down arrows to move between the selected objects, or you 
can click on the object that you want to select.

As you choose each object in this dialog box, Vectorworks will highlight it 
on the screen.

•	 In this situation, you want to select the polygon.
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This is a good way to make sure you have the correct object selected. 

•	 Go to the Menu bar.

•	 Choose Model >  Extrude…

•	 Do not change the X or Y dimensions.

•	 Enter the extrusion as a negative dimension. Putting in a negative 
extrusion will save you having to move the extrusion down. What you 
really want is the top of the site positioned at zero.
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•	 Click on the OK button. 

•	 Select and extrude all the buildings sites you require.
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Creating the Contextual Buildings

cadmovie819

If you are going to create an urban design then it is a good idea to create 
the context for your model. The context is the surrounding streets and 
buildings. If you do not create this context, then when you create solar 
studies you will not see the effect of the surrounding buildings on your new 
design.

You can sometimes find websites or local authorities that have GIS 
information you can download. Import this information in the same way 
that you import the site information.

•	 If you import Shapefiles you might find that each object has information 
attached to it. This information has come directly from the GIS database.

•	 When you select a building, and look at the object info palette, you 
might find that the data pane has information about that polygon. This 
information is stored in record format.

http://learn.archoncad.com/?p=997
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You can use this record information to modify the objects. There is a 
command in Vectorworks that will use the record information attached to 
each object and modify that object accordingly.

•	 Go to the Menu bar.

•	 Choose Tools >  Records >  Modify by Record…

This command allows you to change several options using the records 
attached to the objects. This command is ideal for creating colored 
polygons based on the area, or based on some other record.

This command will also extrude objects using the elevation record attached 
to each object.

•	 Choose the correct record format.

•	 Choose the correct field.

•	 Choose the correct option. In this situation choose the Extrude option.
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•	 Click on the OK button. 

Vectorworks will modify each object individually, using the information 
attached to each object and extrude each building to the correct height. 
This command is a very powerful command allowing you to color areas 
based on their size of the area, coloring buildings based on the type of 
building that is attached to the record format, and many other similar 
options. 

When you change to a 3D view you will see all the buildings have been 
extruded to their correct height.
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When you make the other layers visible, and you turn on your unified view 
you will see the buildings sitting perfectly within the sites and the roads 
you created earlier.

When you change to a plan view you will not see the colors of the 
buildings and roads until you render the view.
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 Adding  a Sun and a Camera

cadmovie820

Adding a sun and a camera will allow you to see the influence of the sun 
on your conceptual model on any day at any time of the year.

•	 Go to the Visualization toolset.

•	 Click on the Heliodon tool. 

•	 Move into the drawing area.

•	 Double-click to place the Heliodon. 

•	 The first time that you use the Heliodon tool, the settings dialog box will 

http://learn.archoncad.com/?p=995
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appear.

•	 Choose your country, city and time display.

•	 Click on the OK button.

•	 The heliodon will be displayed. The heliodon assumes that North is 
straight up the page. Double-clicking to insert the heliodon will ensure 
that it is placed with zero rotation.

If you render the view you will notice shadows on the plan. You will need 
Renderworks to see the shadows. 
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The easiest way to set a 3D view is to use the Renderworks Camera tool 
from the Visualization tool set. You can only use the Renderworks Camera 
tool if you have Renderworks. If you do not have Renderworks, use the Set 
3D View command from the View menu.

•	 Go to the Visualization tool set.

•	 Click on the Renderworks Camera tool.

•	 Move into the drawing area.

•	 Click once for the location of the camera object.
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•	 Click once more to determine where the camera is aiming to.

The first time that you use the Renderworks Camera tool you will see this 
dialog box. Choose the options for the camera height, look to height, and 
so on. If the settings do not make sense, do not worry. All of the settings 
can be changed later.
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•	 Click on the OK button. The camera object is now placed in the 
drawing.

•	 To see the camera view, go to the Object Info palette. 

•	 Click on the Display Camera View button.

If you set your view to a rendered view, you will be able to see your 
building site with the sun and shadows.
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If the view is not suitable, you can use the Object Info palette to change the 
camera view. 

•	 Go to the Object Info palette.

•	 Click on the Fine Tune Camera View... button. 

This dialog box allows you to change almost everything about the camera 
view. As you adjust the sliders, the view will update automatically. 

When you have the view you want, click on the OK button. 
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Creating the Conceptual Model

cadmovie821

You need to create a conceptual model, but you also have a lot of 
surrounding buildings that could get in the way. One option is to create a 
new layer for your conceptual model. Another option is to create a group 
for your conceptual model. 

Creating a group allows you to enter the group to edit your model. When 
you enter the group you can choose if you want to see the objects outside 
the group or not. I often use this method.

•	  Draw a polygon for the footprint of your model.

•	 Go to the Menu bar.

•	 Choose Modify > Group.

http://learn.archoncad.com/?p=991
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•	 When you group an object, you will notice the selection box changes. 

•	 In Vectorworks 2011 and above, there is a button that can be accessed 
from the Tool bar. This button turns on/off the objects outside the group. 
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•	 If you are using an older version of Vectorworks, you can access this 
preference on the Vectorworks Preferences dialog box. 

•	 Go to the Menu bar. 

•	 Choose Tools > Options > Vectorworks Preferences...

•	 Click on the Display tab. There is a Vectorworks preference that you can 
activate to show other objects while in editing marks, with the option to 
gray other objects.

•	 If you do not want to see other objects while you are in the group, or 
while you are in editing modes turn this preference off. If you want to 
turn this preference back on you will have to access the preferences 
through the tools menu again. Vectorworks 2011 and above just gives 
you quick access to this preference.
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•	 Double-click on the group to edit it.

•	 Depending on your preferences, when you enter the group you can see 
all the other objects, see all the other objects in gray, or see none of the 
other objects. This view is showing the other objects in gray. 

•	 Go to the 3D Modeling tool set.

•	 Activate the Push/Pull tool.
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•	 Go to the Tool bar.

•	 Click on the first mode (Extrude Face mode).

•	 Move your cursor to the plan of your building. If the object is a polygon, 
rectangle, or other planar object, it will highlight in red.

•	 Click once to start extruding your building plan.

•	 If you can see the adjoining buildings, you can use these to snap onto.

•	 Click once again to confirm the extrusion height.
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At this point it is useful to change your Vectorworks preferences so that 
you do not see other objects while in editing modes. This allows you to 
work on your model without the distraction of all the other information.

•	 If you have access to the quick preference on the Tool bar, use this to 
turn off the preference. Otherwise, use the Tool menu to access the 
Vectorworks preferences and turn off the option to show other objects 
while in editing modes.

From this point, use the 3D modeling techniques to create your conceptual 
model. You can start with the Shell Solid tool to hollow out the entire 
building.
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•	 Go to the 3D Modeling tool set.

•	 Click on the Shell Solid tool. 

•	 Go to the Tool bar. Click on the Preferences button to enter the shell 
thickness. In Vectorworks 2012 and above, you can enter the shell 
thickness directly on the Tool bar.

•	 The shell solid tool always selects the front faces of your model. To 
select bank faces of the model, use the alt or option key.

•	 Hold down the Alt or Option key and click once. This selects the open 
face of the shell solid.
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•	 Click on the green tick on the Tool bar, or hit the Enter key.

If you are using Vectorworks 2012, then from this point on you can use 
planar objects with the instant Push/Pull mode to model your project. 

For example, you can use planar objects with the automatic working plane 
to draw directly onto the face of your model.

With earlier versions of Vectorworks, modeling in 3D is not as quick as 
shown in these images. You have to set working planes manually, you also 
have to look directly at the working plane, and then you have to draw your 
plan objects before extruding them and using solid modeling (add solid and 
subtract solid from the Model menu).
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For example, you could use the Rectangle tool to draw a rectangle for the 
main opening on the model. Depending on the mode that you use for the 
Rectangle tool, you can start in the center of the model and have the center 
of the rectangle line with the center of your model.

The blue face of the model is the automatic working plan detecting the face 
of the model.

•	 When the rectangle is completed, move your cursor back to the center of 
the rectangle.

•	 The rectangle will highlight in red if you have the instant Push/Pull 
mode activated.

•	 Click on the rectangle.
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•	 Move your cursor into the building.

•	 Hold down the alt or option key and click once to finish.

Holding down the alt or option key forces Vectorworks to use the new 3D 
object for solid modeling. When you move into the model, Vectorworks 
uses Subtract Solid. When you move out from the model Vectorworks 
uses Add Solid.
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You can also try changing the shape of the building by using tools like the 
circle or arc tool. Again, the series of images show how you can use the 
automatic working planes, which unfortunately are not available in earlier 
versions of Vectorworks.

 This example shows the Arc tool.

•	 Start at the top center of the building, using this for the center of the arc. 
Notice that the automatic working plane has detected the face of the 
building.
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•	 When the arc is completed, move the cursor back to the edge of the arc. 

•	 The arc will turn red, if you have instant Push/Pull mode activated. 

•	 Click once. 

•	 Move your cursor to the desired location to extrude your arc.

•	 Hold down the alt or option key, and click once.
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If you want to create several windows at once, then the easiest way to do it 
is to use solid modeling (subtract solid). 

If using Vectorworks 2012 or newer, then you can use the automatic 
working plane to draw directly on the face of your model. 

If you are using earlier versions of Vectorworks, create a working plane on 
the face of your building, then draw the shapes you want for the openings 
in the building.
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 You can also use commands like Align/Distribute to line up your shapes 
before you extrude them.

•	 After extruding your window openings, select them and the model. 

•	 Right-click on one of the objects, and choose Subtract Solids… from 
the contextual menu.

If you wanted to make a waving canopy, you can do this with a polyline.  
Draw the polyline on the base of the building using an automatic or 
manually placed working plane.
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•	 Use the extrude command to extrude the polyline to the correct 
dimension. 

To give a thickness to your extrusion, use the Shell Solid tool.

•	 Go to the 3D Modeling tool set.

•	 Click on the Shell Solid tool.

•	 Go to the Tool bar.

•	 Click on the Preferences button, and set the preferences to suit.
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•	 Click on your curving extrusion. You might find that not all of the 
extrusion gets selected. Hold your finger on the Shift key and click on 
the other parts of the extrusion until all of them are highlighted.

•	 When everything is selected click on the green tick on the Tool bar, or 
hit the Enter key.

Complete as much modeling as you require. When you have completed 
your modeling click on the Exit Group button at the top right corner of 
your drawing window. You will be returned your camera view. Render the 
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view to see your conceptual model in its setting.

•	 You can use the Push/Pull tool to extrude the building, then use the 
Automatic Working plane to draw on the top of the building. 

•	 Using the third mode for the Push/Pull tool, you can select the curve, 
then the model, then choose which part of the building you want to push 
or pull. 

•	 In this example, you could cut the building in half by pulling one part of 
the building down.
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•	 If you set your options to see other objects outside the group, you can 
use them to line up with. 

•	 You could create series of holes for windows. These objects are simple 
rectangles that have been extruded. They could be diamonds, circles, or 
any shape you wanted. 

As in the previous example, the building has been created using the Shell 
Solid tool. This creates a hollow building, which is more realistic. 
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•	 If you Subtract Solid, the window objects will create holes in the 
building. 

•	 You can use standard Vectorworks doors and windows to add detail to 
the model. 
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Window and door objects will not automatically create the hole in your 3D 
model the way they do when you place a window or door in a wall. 

You will need to use your automatic working plane and the rectangle tool 
to cut the hole in the 3D model to match the door or window dimensions.

In this view below you can see a balcony halfway up the building. The 
object is a polygon traced around the outside of the building and extruded. 
If you assign a transparent texture to the object it will look like a glass 
balustrade.
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Referencing Information From Other Files

cadmovie822	

If your project is complex, you might have other users completing parts of 
the design. This is called referencing. Referencing allows you to 
dramatically speed up the drawing process by sharing the work load with 
other users.

•	 Go to the Navigation palette.

•	 Click on the last tab, the References tab. In earlier versions of 
Vectorworks, you have to use the Organization dialog box from the 
Tools menu.

•	 Right-click (control+click on a one button mouse) on the Navigation 
palette.

•	 Choose New... from the contextual menu. 

http://learn.archoncad.com/?p=989
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•	 Locate the file you want to reference. 

•	 Double click on the file, or click on it once, then click on the Open 
button. 

•	 You might see this dialog box. 

•	 If this dialog box appears, click on the OK button. 
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With this kind of referencing, you do not see the new layers directly. 
Instead you can create a Design Layer Viewport and use the layers from 
your referenced file. 

•	 Go to the Menu bar.

•	 Choose View > Create Viewport...

•	 Name the Viewport.

•	 Do not worry about the Drawing Title. 

•	 Click on the pop-up menu to chose the design layer.



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1205

Page 60

•	 Click on the Select Source... button.
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•	 Choose External Document.
•	 Choose Existing Reference.

•	 Click on the pop-up menu to choose your referenced file. 

•	 Click on the OK button. 

Your design and layout viewport will be placed in the design layer at the 
same location as the original information. In this situation the center of my 
bus stop has been placed at the center of the drawing. 
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•	 You will find it easier if you zoom out so you can see your design layout 
viewport in relation to your conceptual model.

•	 Use your rotate tool to rotate your design layout viewport to fit the 
conceptual model or the street. Rotating the design layout viewport has 
no effect on the original information.
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•	 Move the design layout viewport to a suitable location.

•	 Activate your camera view and render your view to see the conceptual 
model.
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There are unlimited possibilities and how far you want to develop your 
conceptual model.
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Thank you 
We trust that you have enjoyed working through this manual and that it has 
been informative and constructive.  

For more information, please visit: http://www.archoncad.co.nz/. If you 
just want someone to help you learn Vectorworks, to carry out some Vec-
torworks contract work, or you want someone to make Vectorworks easier, 
contact us, as this is a service that we also offer:
jon@archoncad.co.nz. 

Thank you again,
Jonathan Pickup
March 2012
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