
Framing and Framing Tools
This manual will be looking at the framing tools and commands 
that are available in Vectorworks. If you are going to use Building 
Information techniques in Vectorworks, you would need to frame 
floors, walls and roofs to show the structure of the model. We will be 
looking at the framing tools to learn how to use them, and we will be 
looking at the framing commands that can speed up the creation of 
framing.   
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Introduction
The framing tools and commands have not had a major upgrade for some 
time, but they can be used to create framing for floors, walls and roofs. 
All of the framing uses the same tool, the framing member, but there are 
commands that make it easy to create the framing members for a floor, wall 
or roof. 

The framing member tool is only available if you have Vectorworks 
Architect or Designer. If you have Spotlight or Landmark, you will not 
find the framing member. If you find the framing member useful, consider 
upgrading to Vectorworks Designer. 

For this exercise, I will be using a simple domestic project, but the same 
principles can be applied to larger or commercial projects. 

First, we will look at the framing member, then we will see how 
Vectorworks uses commands to create the members for floors, walls and 
roofs. 
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Framing Member 

The main tool for framing is the framing member tool. This tool has been 
around for some time (since Vectorworks 2008), and it replaces several old 
tools (rafter, beam and so on). The framing member tool can be used to 
create floor structure, rafters, beams, and so on. 

cadmovie706

•	 Go to the Detailing tool set. 

•	 Click on the Framing Member tool.

•	 Go to the Tool bar. 

•	 Click on the Preferences button. 

This will open the preferences so you can type in the sizes of your framing 
member and set the view options.  

http://learn.archoncad.com/?p=4562
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There are several options for the framing member, allowing you to choose 
whether the framing member is a rafter, beam, or a custom profile. The 
changes to the framing member show up in a 3D view. 
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Solid Beam

Any framing member can be set to an angle, using the Pitch option on the 
Preferences, or you can set the Pitch later on the Object Info Palette. 

Rafter
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Wood Floor Truss

Open Web Steel Joist
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Cold Formed Steel Channel

Steel Section

•	 With the steel section, you can use the Object Info Palette to change the 
section. 

•	 Click on the Select Structural Shape... button. 

•	 Choose the structural shape you want from the range of choices. 

•	 Click on the OK button. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 10

Custom Profile

cadmovie707

The custom profile option lets you custom shape any framing member. This 
will allow you to turn your framing members into concrete beams, or into 
custom timber factory-made sections. 

•	 Choose Custom Profile from the Type pop-up menu. 

•	 Click on the Choose Profile Symbol... button on the Object Info Palette. 
This opens a dialog box for you to choose a standard symbol, or you can 
create your own library of symbols. 

http://
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•	 Choose the profile you want. 

•	 Click on the OK button.

If you create your own custom profile symbols for proprietary products like 
HyJoist or Posi-Strut, and you store them in the Framing Member - Custom 
Profile folder (in your default Library), you can access them here.

This makes it easy to create a framing member to suit the structure you 
want to use. This image uses a Posi-Strut symbol. 
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By clicking on the Choose Profile Symbol... button at the bottom of the 
Object Info Palette, I can change the joist to a different type and 
construction. 

Just to recap, all the framing commands make framing members. Framing 
members can be edited with the Object Info Palette. Framing members can 
be one of several pre-made shapes, or you can make your own custom 
profiles.  Framing members can be timber, trusses, steel, steel trusses, 
wood trusses, concrete profiles, or any custom profile you want. 

When you create your custom profile, set the top centre of your custom 
profile to 0,0. You can use closed objects like rectangles, circles, ovals, 
polygons, polylines, and so on. Do not use lines or groups, they don’t 
work.
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Floor Framing

Creating Joists from Polygons

cadmovie708

There is a floor framing command that speeds up the creation of floor 
framing. It will place as many framing members as possible, in the 
direction you choose. The command is only available on the Architect or 
Designer workspace. If you have Vectorworks Landmark, you will not be 
able to use this command, nor will you be able to use the framing member. 

The command is called Create Joists from Poly... but it will work on 
rectangles, polygons, polylines, extrudes, floors, columns or roof faces (if 
you use a roof face, the joists do not follow the slope).

If you try to use any other object you will get an error message. 

 

Vectorworks 2011 has a slab object to create floors. At present you can not 
use a slab with the Create Joists from Poly... command. 

In my example I have two floors at different 3D heights. 

•	 If the floors are at different heights, use two or more floors.

•	 If you want the joists to span in different directions, use two or more 
floors. 

http://learn.archoncad.com/?p=4567
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•	 Select one floor or polygon.

•	 Go to the Menu bar.

•	 Choose AEC > Framing> Create Joists from Poly...
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This opens a dialog box where you enter the desired settings for the joists 
(framing members). 

•	 Check the Elevation. Vectorworks tries to use the elevation of the floor 
object, but it is not correct, so be careful. 

•	 Enter the Center-to-Center Spacing. 

•	 Click on the Set Joist Properties... button. This is where you enter the 
joist sizes and 2D display. 

•	 Enter the width and height of the joists. 
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•	 Click on the Type pop-up menu.

•	 Choose the type of joist that you want. 	

•	 Click on the 2D Display pop-up menu. 

•	 Choose the type of display that you want. I use the Width display, 
because this is similar to drawing rectangles for the joists. If you want a 
line for each joist, use Centerline or Solid.
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•	 Click on the Vertical Reference pop-up. On the main dialog, you set the 
3D height, this pop-up sets joists relative to that height. I use Top. 

•	 Click on the OK button to return to the main dialog.

•	 If you want perimeter joists, then tick Draw Perimeter Framing 
Members.  

•	 Enter the elevation for the perimeter joists. It may be the same height as 
the other joists, but it doesn’t have to be.
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•	 Click on the Set Framing Member Properties... button.

This dialog is identical to the other joists. If you want your perimeter joists 
to look the same as the other joists, enter the same settings.

•	 Click on the OK button to return to the Create Joists from Ploy dialog 
box. 

•	 Check your settings.

•	 Click on the OK button.
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•	 You will get a dialog with instructions.

•	 Read the instructions.

•	 Click on the OK button. 
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•	 Click once for the starting point of the joists. 

•	 Click once for the other end. The framing members will follow the line 
from the first click to the second click. If you want the joists to be 
vertical or horizontal, hold down the shift key to constrain the line. 
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•	 Vectorworks creates all the joists it can, based on the settings you 
entered. 
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•	 If you change to a 3D view, you can see all the joists. If your entered 
settings are correct, the joists should be sitting directly under the floor. 

•	 The image below shows the result when you turn off the perimeter joists. 
Notice that without the perimeter joists, Vectorworks will not place a 
joist at each end of the polygon. You will have to do that yourself.  
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cadmovie709

•	 Use the Move by Points tool, or drag a copy of one joist to the correct 
location. 

•	 Use the Selection tool to change the length of the joist to suit the 
situation. 

•	 Add any other missing joists. 

•	 Select all the joist objects for the floor.

http://learn.archoncad.com/?p=4570
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•	 Go to the Object Info Palette.

•	 Click on the Type pop-up.

•	 Choose Custom Profile.
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•	 Vectorworks uses a default custom profile, and it may not suit you. 

•	 Go to the Object Info Palette. 

•	 Click on the Choose Custom Symbol... button.  

•	 Choose the profile symbol that you want. I am using a set of custom 
symbols that I have created, and they have been created to match hte 
products of a local manufacturer. 
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•	 Click on the OK button.

•	 The joists have changed to the new profile. 

If you have floor areas where you want the joists to span in different 
directions, frame each area separately. If you have floor objects, 
Vectorworks will only frame one floor at a time. 

•	 If you have another floor area to frame, select it. 
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•	 Go to the Menu bar.

•	 Choose AEC > Framing> Create Joists from Poly...
•	 Check the Elevation. Vectorworks tries to use the elevation of the floor 

object, but it is not correct, so be careful. 

•	 Enter the Center-to-Center spacing. 

•	 Click on the Set Joist Properties... button. 

•	 Enter the width and height of the joists. 
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•	 Choose the type of joist that you want. 

•	 Choose the type of display that you want.	
•	 Choose the Vertical Reference.

•	 Click on the OK button to return to the main dialog.

•	 If you want perimeter joists, then tick Draw Perimeter Framing 
Members.  

•	 Enter the elevation for the perimeter joists. It may be the same height as 
the other joists, but it doesn’t have to be.

•	 Check your settings.

•	 Click on the OK button.
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•	 You will get a dialog with instructions.

•	 Read the instructions.

•	 Click on the OK button. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 30

•	 Click the two points to define the direction of the joists, and Vectorworks 
creates the joists. 

•	 You can use the Move by Points tool (from the Basic tool set) to 
duplicate the joists and move them to the correct location. 

•	 Go to the Tool bar. 

•	 Use the first mode. 

•	 Click on the Preferences button to to alter the number of duplicates and 
to select to retain the original object or not. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 31

•	 Select the joist to copy. 

•	 Click once for the start of the duplicate.

•	 Click once for the end point of the duplicate.

•	 This is a quick way to fill in the missing joists. 

•	 You can use this technique to fill in all the additional joists. 
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Vectorworks will not create all the trimming joists and double joists that 
you need. But you can copy, rotate and move joists to create the layout you 
want. Use the Selection tool to move and stretch the joists to suit. 
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Creating Bearers

cadmovie710

You can use the Joists From Poly command to create the bearers, and it 
would be quick, but I also want to highlight the fact that you can create any 
framing member that you require. 

•	 Select the Framing Member tool from the Detailing tool set.

•	 Go to the Tool bar. 

•	 Click on the Preferences button. 

•	 Set the width and height to suit a bearer. 

•	 Click to start a bearer. 

•	 Click to finish the bearer. 

http://learn.archoncad.com/?p=4573
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•	 Create all the bearers you need. 

•	 Select the bearers. 

•	 Change to an elevation view to check the height of the bearers, and use 
the Object Info Palette, or the Move 3D... command from the Modify 
menu to move the bearers to the correct 3D height.  



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 35

If you have an object already drawn, and you want to draw a similar object, 
there is a right-click command you can use, called Create Similar Object. 

This is a really quick way of drawing a similar object. Vectorworks will 
pick up the correct tool and settings. 

•	 Right-click on a bearer.

•	 Choose Create Similar Object.

•	 Vectorworks will tell you about the keyboard shortcut. 
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•	 When you have all the framing, make sure you assign it to classes. I use 
a class for the different parts of the framing: 
Structural-Footings 
Structural-Bearers 
Structural-Floor Joists
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•	 The classes should be used to control the graphic style of the objects. 
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Creating Floor Piles

cadmovie711

•	 Go to the Building tool set. 

•	 Choose the Column tool. 

•	 Edit the column settings to make a pile footing to support the bearers. 

•	 Place one column on the bearer, in the correct location. 

http://learn.archoncad.com/?p=4577
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•	 Use the Move by Points tool, Duplicate Array, or just drag copies of the 
columns to make your sub-floor structure. 

•	 If you are using floors of different heights, remember to change the 
settings on the columns to accommodate the change in floor levels. 
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If you want to frame a floor, but you lack the framing member, you can use 
a floor object. 

cadmovie712

•	 Draw rectangles of the joists.

•	 Select them

•	 Use the Floor... command from the Model > AEC menu. When you 
enter the heights of the joists, remember that the floor object always 
measures to the underside of the floor, which in this case would be the 
underside of the joists. 

http://learn.archoncad.com/?p=4578
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•	 When the floor is created, the joists still look like rectangles, and you 
can still use classes to control the visibility and graphic style of the 
joists. 

•	 If you change to a 3D view, the joists look acceptable. You do not have 
the same control for the joists as you do with the framing member. 
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•	 You can still make a full framing drawing.
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Wall Framing

cadmovie713 

The wall framing does not use framing members to make the wall frames, 
it uses a program to calculate all the parts. The resulting 3D model of the 
wall framing is a combination of extrusions and meshes. 

There are a few things you have to be aware of when using wall framing. 

The wall framer up to Vectorworks 2011 is not aware of the wall 
components. To get the best from the wall framer, create a wall the same 
width as the framed part of the wall. If you try to frame a wall that has 
external cladding (say 40mm [1.6”]) and internal lining (10mm [0.4”]), 
then frame the wall with a 90mm frame, the wall framer will place your 
framed wall in the middle of the entire wall, ignoring core and components.  
The face of the wall framing will be placed 25mm (1”) from the external 
face of the wall. It does not matter if the components are on classes, and 
the classes are tuned off, the frame is still in the center of the overall wall. 

Notice that the framing in this wall is not in line with the hatched 
(structural) part of the wall. The wall framing information is wrong.

 

The wall framer recognises slopes and peaks in the top of the wall, but not 
in the base of the wall. Steps should be avoided in any wall that you want 

http://learn.archoncad.com/?p=4579
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to frame.

The answer is to create two or more walls, breaking the walls where you 
want to have steps. The individual walls will create a reasonable frame.

The wall framer uses classes to pick the walls to be framed. In this 
example, there is a balustrade wall that is on a different class from the 
exterior walls. When the wall framing command is run, it will find all the 
walls on the chosen class (there can only be one class) and it will ignore 
the balustrade wall.  

You do not have to select the walls for the wall framer, the wall framer will 
choose the walls it needs, based on the layers and classes you specify. 
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`

•	 Go to the Menu bar.

•	 Choose AEC > Framing > Wall Framer... 

•	 Name the framing model. This name has to be 8 characters of less. This 
name will be used for the design layers for the model, 2D elevations and 
worksheets. 

•	 Click on the Create button. 
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•	 Choose the parts you want to create on the left-side of the dialog box. 

•	 Choose the layers that you want to frame. Only layers with the tick will 
be framed. 

•	 Click on the Options... button. 
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•	 Click on the New... button. This is where you tell Vectorworks which 
classes you want to use. In the earlier part of this step, you chose the 
layers, now you are choosing the classes. The combination of layers and 
classes will tell Vectorworks which walls you want to frame. Each model 
can frame all the layers, but only one class. 

•	 Choose the class. 

•	 Click on the OK button.

•	 Change the settings to suit the stud spacing and Lumber (timber) size. 

•	 Setting the Sheet Stock Height to your nog or dwang spacing will give 
you all the nogs or dwangs. 
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•	 Click on the OK button. This brings you back to the Wall Framing 
dialog box.

•	 Click on the OK button to finish. 

•	 Vectorworks will create 3D Models, 2D Models, and Worksheets if you 
have ticked them. 

•	 Close the worksheets. 
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•	 Go to the newly created 3D model layer for framing.

•	 If you choose the 2D model layer you will get a plan, with the wall 
frame numbers. 
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•	 And you get an elevation of each wall frame.

 

•	 The wall elevations have basic height dimensions, and running 
dimensions. You can edit the group and add your own dimensions to the 
windows for example. 
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•	 If you create a section viewport, you can turn on the classes for the wall 
frames, then you can start to see the floor and wall structure. 

Without Vectorworks Architect or Designer, there isn’t really any easy way 
to replicate this framing. You would have to draw a rectangle for each stud, 
lintel and nog, then extrude them. 
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Roof Framing

cadmovie714

Roof framing uses the Framing Member tool, but we can get Vectorworks 
to calculate all the rafters, beams and purlins, by using the Roof Framer 
command. In order to use this command, you need to have Vectorworks 
Architect or Designer. 

This model was created with Vectorworks Architect, using the roof framing 
tools and commands. 

This model was created with Vectorworks Fundamentals, using floor for 
the horizontal beams and roof faces for the rafters. This required more 
work, and when the roof gets more complex, it requires a lot more work. 

http://learn.archoncad.com/?p=4580
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The roof framer will not make truss roofs, it will only make traditional 
roofs (rafters, purlins, ridge beams, and so on). If you want to make a roof 
with trusses, you have two options; you can create hybrid symbols for your 
trusses, or you can use the truss plug-in (http://www.vectordepot.com/
older_plug-ins.html) available online. 

You can use the roof framer command to create roof framing from a roof or 
roof face. So, create one of those first. 

When you create the roof, you can use the overall thickness of the roof and 
structure, or you can use the roof cladding material thickness. If you use 
the roofing material only, you have to allow for the structure when you 
enter your bearing height. 

If you use the overall thickness of the roof and structure, you will have 
trouble when it comes to framing the roof. The roof framer can create the 
rafters in line with the top of the roof, or at the bottom of the roof, but not 
somewhere in between.

•	 The roof framing command can cause Vectorworks to crash, so save 
your file before you start.

•	 Select the roof.



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 54

•	 Go to the newly created 3D model layer for framing. Go to the Menu 
bar.

•	 Choose AEC > Framing > Roof Framer...  

This dialog has all the controls for creating roof framing. Each part of the 
roof framing has a tab. 

•	 Click on the Rafters tab. 

•	 If you want to create rafters, click on the Create Rafters option.  Until 
you click on this option, you can not edit the rafter settings. 
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•	 Click on the Rafter Size pop-up. 

•	 Choose your rafter size if it is there. If your preferred rafter size is not 
shown, click on the option to Edit List...

•	 Click on Add... button.

•	 Enter the Width and Height to suit your rafters.  

•	 Click on the OK button to return to the Edit Size List dialog.
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•	 Select your preferred rafter size. 

 

•	 Click on the OK button to return to the Roof Framer dialog box. 

•	 Set the Minimum Spacing and Maximum Spacing. Use maximum and 
minimum spacing if you want the rafters to match across ridges, hips 
and valleys. If you do not want to match the rafters, choose that option 
and enter the min. spacing. 
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•	 Choose the class for the rafters. If you haven’t got a class for the rafters, 
click on the Classes... button and create a class for the rafters. 

•	 Click on the Beams tab. When I was taught, we called these beams 
collar ties. If you want these, click on the Create Beams option. 

•	 Set the Style and choose the Size. If your preferred size is not shown, 
click on the option to Edit List..., and add your referred size. This dialog 
uses a separate list for each framing type, so you might find you have to 
add the same timber size for several parts. But, you only have to add 
them once, Vectorworks will remember the sizes.  
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Click on the Plates tab. This area will create a top plate for your roof. in 
Vectorworks 2011, there seems to be a bug that places the plate in the 
wrong location, so leave this option off. 

•	 Click on the Purlins tab. If you want purlins, click on the option to 
create them, then set the options. In Vectorworks 2011, I have found that 
including prulins can cause Vectorworks to crash, so I don’t use this 
option. 

•	 The image on the dialog box shows what I call under-purlins. There is an 
option to set the purlins to the top of the rafter (my definition of purlins), 
but don’t forget to rotate the purlins to the roof slope. 

•	 Set the Style and choose the Size. If your preferred size is not shown, 
click on the option to Edit List..., and add your preferred size. 
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•	 Click on the Ridges tab. Set the Style and choose the Size. If your 
preferred size is not shown, click on the option to Edit List..., and add 
your preferred size. 

•	 Click on the Trimmers tab. Set the Style and choose the Size. If your 
preferred size is not shown, click on the option to Edit List..., and add 
your referred size. 
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•	 Click on the Hips/Valleys tab. Set the Style and choose the Size. If your 
preferred size is not shown, click on the option to Edit List..., and add 
your referred size. 

•	 When you have checked all your options, click on the OK button. It can 
take some time to do all the calculations, so be patient.  

•	 When the command finishes, all the roof framing will be selected. 

Plan view.
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Isometric view. 

This command is better suited to simple roofs. You can use the command 
on mono-pitch roofs, but you will have to put in some extra effort. 
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Using the Roof Framer command, I have set the rafter options. 

•	 In this example I have asked Vectorworks to create the purlins as well  
as Hips/Valley members. Choose the timber size and other settings.
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•	 When you click on the OK button, you might find that the result is not 
what you wanted. Vectorworks has failed to create any rafters. 

•	 Go to the Menu bar.

•	 Choose Edit > Undo. This will remove all the roof framing. 

•	 Try the roof framer again, without purlins.
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•	 This time you might be successful.

•	 One technique you can try is to make only the purlins.  This sounds 
strange, but it does work more often than getting Vectorworks to make 
all the parts at once. 

•	 In this example, all the other options are turned off. Only the Purlins are 
activated. The Elevation of the first purlin (dimension 2) is not easy to 
calculate. It is the vertical height from the setting out of the rafter. Most 
people want to set the purlin in plan, so that it matches the eaves. 
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Vectorworks creates the purlins.

•	 You might find that the purlins are not sitting on top of the rafters, this 
could be the settings you have chosen in the roof framer. 
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•	 The answer might be to draw the purlins where you want, using the 
Framing Member tool. This might seem very slow, compared to the 
roof framing command, but it does allow you create the correct setting 
out. 

•	 Go to the Detailing tool set. 

•	 Choose the Framing Member tool. 

•	 Go to the Tool bar. 

•	 Click on the Preferences button. 

•	 Set the preferences to suit a purlin. 

•	 Click on the OK button.
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Draw the first purlin in plan. This makes it easy to locate at the eaves. 

•	 I find it easy to group some objects so I can work on them without the 
distraction of other objects. In the example above I would therefore 
select all the left roof elements and group them. 
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When you edit the group, you can choose a Vectorworks preference that 
does not show other object while in a group. 
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•	 When you change to an elevation view, you should notice that the purlin 
is not at the correct elevation.

•	 You can use the Object Info palette to type in the correct height for the 
purlin, you can drag the purlin, or you can use the Move by Points tool.  

•	 If you zoom in, you can see that the purlin is not sitting on the top of the 
rafter. Move the rafter to the correct position. 

•	 Select the Move by Points tool. 

•	 Go to the Tool bar.  

•	 Click on the second mode. You use this to evenly distribute objects.
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•	 Click on the end of the purlin.

•	 Click where you want the last purlin. 
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•	 Vectorworks will evenly distribute the purlins.

•	 When you change back to a plan view, you might find that the Move by 
Points tool has snapped to the last rafter, rather than the first one. 

•	 Use the Selection tool to move and stretch the purlins to suit the plan. 
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•	 Select the purlins.

•	 Chose the Mirror tool. 

•	 Use the center of the valley rafter as the mirror plane. 

•	 This is the quick way to make all the purlins for the other roof. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 73

•	 The purlins are not the correct length. 

•	 Use the Selection tool to move and stretch the purlins to suit the plan. 
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•	 The roof frame for the mono-pitch roof is now complete. 

•	 You can create section viewports that show the framing. 
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Roof Framing without Vectorworks Architect

cadmovie715

The framing tools only work in Vectorworks architect. If you do not have 
Vectorworks Architect, you can still create  kind of roof framing.

You can start with a roof object, but it works better if you use a roof face.

If you have created a roof object, select it.

•	  Go to the Menu bar.

•	 Choose File > Modify > Ungroup. This will break the roof into roof 
faces. 

http://learn.archoncad.com/?p=4581
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•	 You will get an alert asking if this is really want you want to do, click n 
the Yes button. 

Instead of on roof object, you now have several roof face objects. 
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•	 Select one roof face. 
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•	 Right-click on it. 

•	 Choose Edit from the context menu. 

•	 Draw rectangles to represent the rafters for the roof face. 

•	 Select the rectangles and the polygon that represents the outline of the 
roof face. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 79

•	 Right-click on the polygon. 

•	 Choose Intersect Surface from the context menu. 

Vectorworks will duplicate and cut all the rectangles to match the polygon. 
This is just a very quick way to get all the rectangles cut to the correct 
length and angle. 
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•	 Select the parts of the rectangles that are sticking out from the roof face. 

•	 Delete them. 

•	 Select any rafters that could be mirrored to create the rafters for the 
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adjacent roof face. 

•	 Copy them, using copy from the Edit menu, or the keyboard short cut 
(ctrl+c or command+c).

•	 Select the polygon that represents the over roof face. 

•	 Delete it. 

•	 Click on the Exit Roof Face button at the top right of the screen to get 
out of the roof face and return to the design layer. You can also use the 
keyboard shortcut (ctrl+] or comamnd+]).
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•	 Select the next roof face to work on. 

•	 Right-click on it. 

•	 Choose Edit from the context menu. 

•	 A quick way to do this is to use the Selection tool, and double click on 
the roof face. 

•	 Go to the Menu bar.

•	 Choose Edit > Paste in Place. This will ensure that the pasted rafters 
line up with the copied location. 
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•	 Use the mirror to mirror the rafters.

•	 Use the edge of the roof face as the mirror plane, and use the mode to 
mirror the objects, not the mode to mirror and duplicate. 
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•	 Add rectangles complete the framing for this roof face. 

•	 Select all.

•	 Right-click on the polygon. 

•	 Choose Intersect Surface from the context menu. 

•	 Select the parts of the rectangles that are sticking out from the roof face. 

•	 Delete them. 

•	 Select the polygon that represents the over roof face. 

•	 Delete it. 

•	 Click on the Exit Roof Face button at the top right of the screen to get 
out of the roof face and return to the design layer. You can also use the 
keyboard shortcut (ctrl+] or comamnd+]).
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•	 When you change to an isometric view, your roof should look like 
rafters. 

•	 Repeat the instructions for all the other roof faces. 

To create the ridge/hip/valley beams, go back to each roof face and draw 
half of the ridge, hip, or valley beam. Ensure that you trim all the rafters to 
match the new beams, otherwise you will get some strange results.

A quick way to the draw a beam that goes along the ridge and down the 
hip, is to use the Double-Line Polygon tool. Set the width to be half the 
ridge beam width, then draw in the ridge and hip.

Do this for all the roof faces, and you have a framed roof. 
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Truss Roof

cadmovie716

The only truss roof tool available is the one from vectordepot, but it is not 
suitable for mono-pitch roofs, you can only use it on roofs that have equal 
pitches.

Visit vectordepot (http://www.vectordepot.com/older_plug-ins.html) and 
download the plug-in. Unzip the plug-ins and copy them to your Plug-ins 
folder. Then you have to add the tools to your workspace. 

I have added the tools to my Building Shell toolset, although you could 
easily add them to the Detailing tool set, where the Framing Member tool 
is. 

•	 Click on the Truss Standard tool. 

•	 Go to the Tool bar. 

•	 Click on the Preferences button. 

•	 Fill in the preferences to suit. 

•	 Click on the OK button.  

http://learn.archoncad.com/?p=4582


©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 88

This tool was written for Vectorworks version 10.5, so it is quite old. You 
might find it works better if you place the trusses in plan view. 

•	 Click for the start of the truss, ignore the overhang.

•	 Click once for the end of the truss, ignore the overhang.
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Depending on your settings, you should see the truss as a solid object. 

If you change to an isometric view, you can see the truss sitting on the 
wall. This view shows what happens when you try to use the truss object 
with a mono-pitch roof. 
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•	 Copy the trusses, using the Move by Points tool, or Duplicate Array 
command. 

There is a gable end truss that cantilevers the purlins for you.  



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 91



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1108

Page 92

Thank you 
Thank you for subscribing. I trust that you have enjoyed working through 
this manual, and that it has been informative and constructive.  

For more information, please visit this web site: http://www.archoncad.
co.nz/. If you just want someone to help you learn Vectorworks, carry out 
some Vectorworks contract work, or you want someone to make Vector-
works easier, contact me, as this is a service that I offer: jon@archoncad.
co.nz. 

Thank you again,
Jonathan Pickup
August 2011
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