
Workshop Topic 
Modeling and Creating Drawings for a Joinery Unit
This is a case study on making a joinery unit. We will model the join-
ery unit quickly, to create a concept drawing. Then, we will create a 
detailed model that will give use all the parts to make the unit. We 
will use classes to control visibility, and we will use viewports and 
sheet layers to create the panel drawings. 

Extended Podcast 120 - Click here

Space labels in the new Vectorworks 2011 spaces.    

Extended Podcast 121 - Click here

How to draw lines, based on survey data, without using the Property 
Line 

Beginners Corner 27 - Click here

What is a layer plane and screen plane?  
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Welcome to this issue of the Vector-workout CPD 
Manual. This manual is designed to work like a user 
group meeting. There is a main workshop topic, then 
extended movies showing tips or techniques and an 
area for beginners. 
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Creating a  Joiner y Unit  - Introduction

Vectorworks can be used to design your 3D objects. You do need to have a 
small amount of 3D skill for this, but you do not need to be a expert. 
Anyway, I will be showing you some cool 3D tricks. 

It might seem odd to make a complete 3D model for the concept, then 
throw it away to make the final project. This is not a waste. The concept 
model uses several quick and dirty tricks, and these will not give us the 
drawings we need for the manufacture of the unit. So, we will have to 
make some new parts to show the manufacturer the exact parts they need to 
make. 

I will be using Vectorworks 2011 for the images, but you will find that 
almost all of these notes apply from Vectorworks Version 12 to 2011.
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Step 1 - Concept Model

We need a quick conceptual model to test out our ideas. In Vectorworks 
2009 and earlier, I would have used rectangles and extrusions to make this 
model. In Vectorworks 2010, I would try to use the Protrusion/cutout tool, 
and working planes. 

In Vectorworks 2011, it is much easier to draw if you use the Push/Pull 
tool. This allows you to start with a large solid block and cut out the parts 
you want. You can achieve similar methods with earlier versions of 
Vectorworks, but they use view dependent methods, so you have to be very 
careful of the view. 

Building the Main Part

•	 Go to the Basic tool set. 

•	 Double click on the Rectangle tool. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie574.mov
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•	 Enter the size for the base of our unit, 450x450mm (18x18”). 
•	 Turn off Position At Next Click.

•	 Set the X and Y coordinates to 0 and 0.
•	 Set the box position (the grid of 9 dots) to the centre. 

•	 Click on the OK button. 

This will place the rectangle in the middle of the design layer for you. 
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If you are using Vectorworks 12-2009, leave your drawing in a plan view 
and extrude the rectangle using the Extrude... command from the model 
menu. 

If you are using Vectorworks 2010-2011, you can change to an isometric or 
perspective view, and use the Protrusion/Cutout or Push/Pull tool it is now 
called in Vectorworks 2011. 

•	 Go to the 3D Modeling tool set.

•	 Click on the Protrusion/Cutout or Push/Pull tool. 

`

•	 Go to the Tool bar.

•	 Click on the first mode. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie575.mov
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•	 Move your cursor to the rectangle. The rectangle will highlight red. 

•	 Click once. 

•	 Move the cursor up the screen, you will see a wireframe extrusion. 

•	 Use the floating data bar to control the height. Use the tab key and type 
in the distance, or if you have the correct settings, type on the numeric 
keypad and the distance will be entered directly into the floating data 
bar. 
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•	 Click once to confirm, or hit the enter key once. This will complete the 
extrusion .

•	 With pre-2011 Vectorworks, change to a front view and trace a rectangle 
over the front of the unit. 
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•	 Set the box position, the grid of nine dots, to the center. 

•	 Use the Object Info palette to subtract 36mm (1.5”) from the width of 
the rectangle. 

•	 Use the Object Info palette to subtract 36mm (1.5”) from the height of 
the rectangle. 

•	 The rectangle should end up 18mm (3/4”) smaller all round. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie576.mov
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•	 Extrude the rectangle, using the Extrude command from the Model 
menu.

•	 Make sure the new extrusion is bigger than the base object. 

•	 Select both objects.
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•	 Right mouse click on the edge of one of the extrusions, and choose 
Subtract Solids...

•	 Ensure that the base object is the one highlighted.

•	 Click on the OK button.
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•	 Change to a Front view.

•	 Use the rectangle tool to draw the rectangle the shape you 
need. 

•	 Use the Extrude... command from the Model menu to create the correct 
length for the shelf. If you get it wrong, you can edit in the next step, so 
don’t worry.

•	 Click on the OK button.

•	 Change to a Plan or Top/Plan view. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie577.mov
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•	 Check the position of the extrusion in plan. 

•	 Use the 2D Selection tool to move the extrusion to the correct length. 

•	 This is where you can change the length of the extrusion, by using the 
interactive scaling mode.
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•	 Make sure the shelf is still selected. You can skip some of the next steps, 
but you need the instruction on moving and duplicating the shelf. 

If you are using Vectorworks 2011, there is a different and more immediate 
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way to create the hole in the cabinet. This technique might have a lot of 
instructions, but I find it quicker and more fun to model using working 
planes and the Push/Pull tool.

•	 Go to the 3D Modeling tool set.

•	 Click on the Set Working Plane tool. 

Move the cursor to the face of the cabinet. 

•	 You will see faces of the cabinet highlight, make sure you click on the 
correct face. 

•	 Click once. This creates  a working plane on the cabinet. We can use this 
working plane to draw a rectangle for the cutout. 

•	 Go to the Basic tool set. 

•	 Click on the Rectangle tool.

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie578.mov
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•	 Start the rectangle at the top left of the cabinet on the working plane. 

•	 Click once. 

•	 Move to the bottom right of the cabinet on the working plane. 

•	 Click once.

•	 Set the box position, the grid of nine dots, to the center. 
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•	 Use the Object Info palette to subtract 36mm (1.5”) from the width of 
the rectangle. 

•	 Use the Object Info palette to subtract 36mm (1.5”) from the height of 
the rectangle. 

•	 The rectangle should end up 18mm (3/4”) smaller all round. 

•	 Go to the 3D Modeling tool set.

•	 Click on the Push/Pull tool. 

`

•	 Go to the Tool bar.

•	 Click on the third mode. 
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•	 Click once on the rectangle.

•	 Click once on the outside of the cabinet. 

•	 When you move the cursor back to the rectangle, it will highlight in red. 

•	 Click on the rectangle to start the subtraction. 

•	 Move the cursor so the wireframe preview shows the hole going all the 
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way through the cabinet. 

•	 Click to finish. 

•	 Use the same technique of drawing a rectangle on the working plane, to 
create a shelf. Remember that you can use the data bar to control the 
thickness of the shelf, and use the inside of the cabinet to snap to. 
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•	 Go to the 3D Modeling tool set.

•	 Click on the Push/Pull tool. 

`

•	 Go to the Tool bar.

•	 Click on the third mode. 

•	 Click once on the rectangle to start the extrusion.
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•	 Click once on the outside of the cabinet.

•	 This will create the extrusion the correct length.
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Creating the Shelves

If you are using pre-2011 Vectorworks, read on. The instructions here are 
same for all versions of Vectorworks. 

•	 Make sure the first shelf is selected. 

•	 Go to the Menu bar.

•	 Choose Move > Move 3D...
•	 Move the shelf down (the Z Offset) by 150mm (6”).

This will position the top shelf for us. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie579.mov
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•	 Go to the Menu bar.

•	 Choose Edit > Duplicate Array...
•	 Choose Linear Array.

•	 Set the Number of Duplicates to 4.

•	 Set the Z offset to -150mm (-6”).
•	 Click on the OK button.
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Now you have all shelves. If you want move shelves, undo the last com-
mand and use more shelves with less offset.  
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Create The Central Divider

•	 If you are using pre-Vectorworks 2011, change to a front 
view. 

•	 Use the rectangle tool to draw the middle divider. 

•	 Extrude the middle divider 18mm (3/4”).
•	 Change to a plan view to make sure that the divider is in center of the 

cabinet. 

•	 If you are using Vectorworks 2011, use the working plane to draw the 
rectangle in the center of the cabinet.

•	 Use the Push/Pull tool to extrude the divider. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie580.mov
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•	 In all versions of Vectorworks, select all the shelves and the divider.

•	 Right-click on a shelf or a divider. Choose Add Solids. 

•	 If you do not see Add Solids, then go to the menu bar and choose Model 
> Add Solids. 
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This adds all the shelves and divider into one solid object. When you 
texture this object the shelves and divider all have the same texture. If you 
want separate textures in the shelves, or on the shelves and divider, do not 
add them together.

•	 Select the cabinet and the middle parts.
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•	 Go to the Menu bar.

•	 Choose Modify > Move > Move 3D...
•	 Set the Z offset to 150mm (6”). 
•	 Click on the OK button. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie581.mov
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Making The Feet

The instructions here will suit all versions of Vectorworks, but it is not the 
only way to create the feet. With Vectorworks 2011, you use working 
planes to make it easier, or more immediate to create the models, and you 
can carry out all these instructions in perspective. 

•	 Change to a Plan view.

•	 Double click on the Circle tool.

•	 Set the dimensions for the circle. 

•	 Turn on Center at Next Click.
•	 Click on the OK button. 

•	 Move to the top left corner of the cabinet. 

•	 Set a Floating datum (hit the G key). 

•	 Hit the tab key until you get into the floating data bar.

•	 Enter the offsets X and Y. I’ve used 75mm (3”).
•	 Click once to place the circle. 

http://www.archoncad.co.nz/cadsupport/cadmovie582.mov
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•	 Extrude the circle 150mm (6”) to make the foot. 

•	 Go to the Basic tool set.

•	 Click on the Mirror tool.

•	 Go to the Tool bar, ensure you have the mirror and duplicate mode (the 
second mode). 

•	 Use the mid-point on the cabinet at the top and the bottom to define the 
mirror plane.
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•	 Ensure both feet are selected. 

•	 Use the mid-point on the cabinet at the left and right to define the mirror 
plane.

You will end up with 4 feet.  
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Check your design in 3D to ensure all the feet have been correctly located. 
With Vectorworks 2011, you can carry out these steps in 3D, but you have 
to be careful where you snap on the cabinet. Checking your work after 
completion is vital. 

 

If you put more effort into the foot design before you mirror the feet, then 
they all look more complex.
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Step 2 - Drawings and Preparation 

Before we make the drawings, there are objects in the model that would be 
better if we could turn on and off. For example, when we create the plan 
view of the cabinet, we might want to use dashed hidden line rendering, to 
show the dividers in plan. But if we don’t hide the feet, they will show up 
too. 

Create Classes

If you have Vectorworks Architect, Landmark or some other Designer 
version, use the Navigation palette to create a new class. 

•	 Go to the Navigation palette.

•	 Right-click.

•	 Choose New...

If you have Vectorworks Fundaments, then use the Organization... 
command from the Tool menu. 

•	 Right-click.

•	 Choose New...

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie583.mov
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•	 Name the class. Use a name that makes sense, and describes the objects, 
or materials you want to use. 

•	 Click on the OK button.

•	 If you are using the Organization dialog box, you will have to click on 
the OK button to close it. 

•	 Select all the feet.
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•	 Use the Object Info palette to assign the feet to the correct class. 

•	 Create more classes for other object that you want to control. You might 
notice that I have several classes for floors, lights and other information. 
I’ve added these classes because I have also created a floor for the 
display stand, added a light and created an image prop for a graphic on 
the top of the unit. 

•	 Now you can control the visibility of the feet using the Navigation 
palette, and you can use the class settings in viewports to show the feet 
in some viewports, but not in others. 
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Plan Viewport

•	 Change you view to a Top/Plan view. Please don’t use top, Top/Plan will 
remove any perspective. 

•	 Any objects you do not want in the viewport should be assigned to 
classes, and the classes made invisible. 

•	 Go to the Menu bar.

•	 Choose  View > Create Viewport...

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie584.mov
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•	 When the dialog box opens, click on the pop-up menu to create a New 
Sheet Layer...
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•	 Number and Name the sheet layer. 

•	 Click on the OK button.

•	 Enter the viewport name. 

•	 Enter the Drawing Title. Be careful with this one, this is the name that 
the drawing label will use when to annotate the viewport.

•	 Check the scale of the viewport.

•	 Change the Rendering to Dashed Hidden Line. 

•	 Click on the OK button.
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•	 The viewport arrives on the sheet layer, in the middle. 

•	 Use the Selection tool to move the viewport to a better location on the 
page. 
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•	 Right-click on the viewport, make sure you right click on the edge of a 
line in the viewport. 

•	 Choose Edit Annotations.

•	 Annotate and dimension the plan. 

•	 To exit the annotations, click on the Exit Viewport Annotation button at 
the top-right of the drawing area. 
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Front Elevation

•	 Change layers back to the design layer for your cabinet model. If you 
have forgotten how to do this, use the Active Layer button on the View 
bar, or double click on the design layer on the Navigation palette. 

•	 Go to the Menu bar. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie585.mov
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•	 Choose View > Create Viewport...
•	 Enter the name of the viewport. 

•	 Enter the Drawing Title. Be careful with this one, this is the name that 
the drawing label will use when to annotate the viewport.

•	 Check the sheet layer. It should be the same as the last viewport. If not, 
click on the Create on Layer pop-up menu, and choose the correct sheet 
layer. 

•	 Check the scale of the viewport.

•	 Change the Rendering to Dashed Hidden Line. 

•	 Click on the OK button.

The viewport will arrive in the middle of the drawing. We would really like 
to move the viewport to line up with the plan view. 



©Jonathan Pickup - http://www.archoncad.co.nz	
Vector-workout CPD Manual  - Issue 1101

Page 45

•	 Go to the Basic tool set. 

•	 Choose the Selection tool. 

•	 Move the cursor to a corner of the elevation. I always use the top left, 
but any corner will do. 

•	 Click and drag the viewport. 

•	 Move to the plan viewport.

•	 Move the cursor to a corner of the plan. Choose a point that will line up 
with the elevation viewport. 

•	 Don’t let go of the mouse button yet. 



©Jonathan Pickup - http://www.archoncad.co.nz	
Vector-workout CPD Manual  - Issue 1101

Page 46

•	 Move the cursor down, but make sure you keep the elevation viewport 
lined up with the plan. 

•	 Release the mouse button. 

•	 Right click on the viewport.

•	 Choose Edit Annotations...

•	 Add dimensions, notes and a label. If you have the correct Vectorworks 
preference, you can see the other information while you are in the 
annotation area, and use the other label to line up with.
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•	 When you have completed all the annotation, click on the Exit Viewport 
Annotation button at the top-right of the drawing area. 

Side Elevation

•	 Use the Navigation palette or the Active Layer button on the View bar to 
change back to the design layer. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie586.mov
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•	 Change to a Right view.

•	 Remember to turn on all the classes you need. I have classes for the 
dividers, feet, lights and floor. I need to turn off the lights and floor, but I 
need the dividers and feet turned on. 

•	 Go to the Menu bar. 

•	 Choose View > Create Viewport...
•	 Enter the name of the viewport. 

•	 Enter the Drawing Title.

•	 Check the sheet layer. 

•	 Check the scale of the viewport.

•	 Change the Rendering to Dashed Hidden Line. 
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•	 Click on the OK button.

•	 Use the Selection tool to move the viewport to line up with the front 
elevation. 
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If you have Renderworks, you can create a rendered viewport with tex-
tures. If you do not have Renderworks, you can use OpenGL rendering, but 
you can not add textures or an image prop.

If you are a subscriber, we have covered making image props in June 2010 
(issue 1006). If you are not a subscriber, you can find a manual on creating 
textures here (http://www.archoncad.co.nz/manuals/manuals/short.html)
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Edit The Model

One of the great things about using a 3D model with viewports to create 
the drawings, is that you can edit the model, and update the viewports 
easily.

This allows you to create a quick model, see how it looks on the drawings, 
and then update, edit, or re-model the cabinet completely. The you just 
need to go back to the drawings, and update the viewports. You might have 
to edit the annotations, but you do not have to completely re-create the 
viewports. 

Return To The Design Layer

•	 Use the Navigation palette or the Active Layer button on the View bar to 
change back to the design layer. 

•	 Change to a Right Isometric view.

Edit the Model

•	 If you are using Vectorworks 2010 or 2011, go to the 3D Modeling tool 
set. 

•	 Click on the Set Working Plane tool. 

•	 Move to the face of the cabinet, click once. You might notice that in this 
view, there are no dividers shown. I have assigned the dividers to a class, 
and I have made the class invisible. I found that this made it lot easier to 
find the face of the cabinet. 

https://s3.amazonaws.com/vectorworkout/cadmovies/cadmovie587.mov
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•	 If you have Vectorworks 2010, use the NURBS Curve tool to draw a 
curve on the face of the working plane. 

•	 If you have Vectorworks 2011, you can use the Arc tool to draw the 
curve on the face of the working plane. 

•	 Use the Mirror tool to mirror the curve to the other side of the cabinet. 
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•	 If you are using Vectorworks 2010 and 2011, you can use the Protrusion/
Cutout or Push/Pull tool.

•	 Use the third mode (sub-face mode) and on Vectorworks 2010, make 
sure the minus sign is activated. 

•	 Click on the curve.

•	 Click on the cabinet. 
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•	 Move back to the curve. In Vectorworks 2011, the whole curve will 
highlight. In Vectorworks 2010, you will see a small green or red dot in 
the center of the curve, that is what you need to click on. 

•	 Click and drag the curve into the cabinet. 

•	 Make sure you go right through the cabinet.



©Jonathan Pickup - http://www.archoncad.co.nz	
Vector-workout CPD Manual  - Issue 1101

Page 55

•	 Click to finish. 

•	 If you are using Vectorworks 2010 and 2011, you can use the Protrusion/
Cutout or Push/Pull tool.

•	 Use the third mode (sub-face mode) and on Vectorworks 2010, make 
sure the minus sign is activated. 

•	 Click on the curve.

•	 Move back to the curve. In Vectorworks 2011, the whole curve will 
highlight. In Vectorworks 2010, you will see a small green or red dot in 
the center of the curve, that is what you need to click on. 

•	 Click and drag the curve into the cabinet. 

•	 Make sure you go right through the cabinet.
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•	 Click to finish. 

•	 If you are using pre-Vectorworks 2010, you can still edit the cabinet, but 
instead of using the Push/Pull or Protrusion/Cutout tool, you will have to 
use solid modeling.  Create the curves a extrusions. Select the curves 
and cabinet. 

•	 Go to the Menu bar.

•	 Choose Model > Subtract Solids... Make sure you are subtracting the 
curves from the cabinet, not the other way around. 

•	 Edit the dividers if you want. You could use the Split tool to 
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Return to the sheet layer (drawing)

•	 Go to the Menu bar.

•	 Choose View > Update all Viewports. If you have any rendered views, 
it might take a while to update all the rendered views. 
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Thank you 
Thank you for subscribing. I trust that you have enjoyed working through 
this manual, and that it has been informative and constructive. 

For more information, please visit this web site: http://www.archoncad.
co.nz/. If you just want someone to help you learn Vectorworks, carry out 
some Vectorworks contract work, or you want someone to make Vector-
works easier, contact me, as this is a service that I offer: jon@archoncad.
co.nz. 

Thank you again,
Jonathan Pickup
January 2011
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