
Workshop Topic 
Lighting and Rendering
I think rendering is one the really fun parts of Vectorworks. It can really 
look like your building is coming to life, but without good lighting, all your 
work can be wasted. Good lighting can even make a dull model come to 
life.
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Welcome to this issue of the VectorWorks Short 
Sharp Training (monthly). This manual is designed 
to work like a user group meeting. There is a main 
workshop topic, then extended movies showing tips 
or techniques and an area for beginners. 
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Introduction
I think that Rendering is one of the fun parts of VectorWorks, You can see 
you buildings coming to life. Getting the lighting right and setting the 
correct rendering can take you some time. 

I think rendering is one the really fun parts of Vectorworks. It can really 
look like your building is coming to life, but without good lighting, all your 
work can be wasted. Good lighting can even make a dull model come to 
life.

This manual will work though the rendering options and show you when 
each one should be used. Then we will look at the lighting options and see 
when we should be using each type. Finally we will look at a couple 
models and look at applying the lighting and rendering to get the best 
results.

But it can take a long time to get nice results. Some of the renderings can 
take several minutes to render. While RenderWorks can be fun it can also 
be very time consuming. On more than one occasion I have been have 
stopped to look at the time and wondered where the day has gone. 

Obviously you have to create a model to render. Try to plan your views, 
then model all the part of your project you can see from the views. 
Remember that you don;t have to model the parts of your project that you 
can not see. Where will you be standing, what will you be looking at. This 
will help you to decide on what you need to draw and what you can leave 
out. If you don’t know what areas you will be rendering then you will have 
to draw the whole project and assign textures to the all the objects in the 
drawing. If you have used a lot of classes, work out if some of these classes 
can be turned off to speed up the rendering process. 

When you create your model think about texturing the model as you draw. 
Remember that sometimes you do not have to model objects if you can tex-
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ture them. I have created a manual on textures, we covered this in the user 
group not long ago. Go back to those notes for information about textures. 

If you use a lot of classes for materials, then you can you the class set up 
dialog box to assign textures as you draw. Using classes for things like the 
windows and doors is a great way to get the textures on them, and it’s 
really fast as well. Using this method you can set up your file for the 
textures, even without any textures in the file yet. If you are using walls, 
remember to use the wall styles to control the textures. 

Also consider using a lot of symbols. The symbols make it easy to repeat 
objects, and then go back an edit them all. If you do not use symbols, the 
textures would to be assigned to each object individually. If the objects had 
needed changing, you would have to edit all the objects, one at a time. If 
you use symbols, you can assign the texture to one object and they would 
all be the same.

Rendering Preferences

cadmovie503

VectorWorks Preferences

VectorWorks Preferences affect every 
VectorWorks file. 

•	 From the Menu Bar choose Tools > Options > 
VectorWorks Preferences...

http://learn.archoncad.com/?p=3672
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Display Tab

Here are the controls for the 
display of light objects and 3D 
Loci. 
I usually choose the “Only in 
Wireframe” option  so that in 
wireframe I can see the lights and 
3D loci and move them around, but 
when I render the view the lights 
and 3D loci are not displayed, just 
the output from the light source 
is visible. It is really disconcerting 
to see the light appear is a rendered 
view. 

3D Tab

Under the 3D tab are controls 
for the resolution of the conver-
sion resolution (how finely 2D 
shapes are converted to 3D faces), 
and how VectorWorks retains 
the 3D geometry in is memory. 
If you choose “Always” then 
VectorWorks should keep the 
model rendered in OpenGL when 
you walk  through the building.

•	 Click on the OK Button to 
close the preferences. 
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Setting 3D Views

cadmovie504
Quick 3D  Views

For Quick 3D views, use the numeric 
keypad on your keyboard. The numeric 
keypad is on the right side of your key-
board, if you have a full size keyboard. Use 
this for quickly typing in numbers.
VectorWorks has assigned hot keys to 3D views 
that you can change 3D views quickly.

The trick to remembering the order is to 
imagine your model on key 5.

•	 To look at it from the front, 
key 2 is in front of key 5.

•	 To look at the model from the 
right, key 6 is to the right of 
key 5 and so on.

http://learn.archoncad.com/?p=3674


©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1008

Page 6

•	 We want to look at our 3D 
model from the right front 
isometric - key 3 on the 
numeric keypad.

The Flyover Tool

The Flyover tool is used to move your view around the building - over and 
under the building.  But you can’t walk into the building.  That’s what the 
Walkthrough tool is for.  You can use this tool from any view.

cadmovie505

•	 Go to the Visualization Tool set. 

•	 Select the Fly Over Tool.

•	 Go to the Tool bar. 

•	 Click on the first mode.

•	 Move your cursor into the 
drawing window. 

http://learn.archoncad.com/?p=3676
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•	 Click and hold the mouse 
button down.  Slowly move 
the mouse up the screen.  

•	 The further you move the 
mouse from the center of the 
screen the more dramatically 
the view changes.

The best way to use this tool is to move a little bit then let go of the 
mouse button.  Move your cursor back to the middle of the view.  

•	 Move your mouse to a part of 
your model. 

•	 Click and hold the mouse 
button for a small time, then 
release the mouse button. 

•	 This will become the centre 
of the rotation (if you choose 
the first mode on the Mode 
Bar).
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The Walk Through Tool.

The walk through tool is used to walk into and through your model.  You 
can use it from any perspective view but the results are always more 
pleasing if you set your perspective first. 

cadmovie506 

•	 Go to the Visualization Tool set. 

•	 Select the Walk Through Tool .

•	 Go to the Tool bar. These 
buttons can be used to move 
the eye position up, down, or 
title the view. 

•	 Move you cursor to the center 
of the drawing window.  This 
does not always mean the 
center of the model.

•	 Click and hold the mouse 
button down.  Slowly move 
the mouse up the screen.  The 
further you move the mouse 
from the center of the screen 
the faster you walk into the 
model.

http://learn.archoncad.com/?p=3683
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•	 The best way to use this tool 
is to move the mouse up the 
screen a little bit.  With the 
mouse button down move the 
cursor to the right or to the 
left.  

•	 You can walk backwards and 
you can walk both in and to 
the side at the same time if 
you want.

When you get lost, go back to Top/plan view. From the Menu Bar, choose 
View > Standard Views, Top/Plan. 
This always gets back to a plan view and you can start again.  

Set 3D View

We are going to set a perspective view of the object. It helps to be able to 
see the whole scene when you are setting the perspective so check that you 
can see enough of the object. Fit To Window will help out, or zoom out 
until you can see the whole scene and surrounding area.

cadmovie507

•	 Set your view to Top/Plan 

http://learn.archoncad.com/?p=3686
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•	 Go to the Menu Bar.

•	 Choose  View > Set 3D View...  
Look at the Tool bar - it tells you what to do.

•	 The first thing VectorWorks 
asks you to set are the camera 
positions - the view or 
location. So starting away 
from the object, click once. 

•	 Move the cursor into the 
object. This is the centre of 
your view, i.e. what you are 
looking at, click once.
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•	 This gives you a dialog box so that you can set the 
viewer height, what height you are looking at and 
the perspective. The viewer height and the look 
toward height, use actual heights in your current 
layer. If you want to look straight ahead the 
viewer height has to be the same height as the 
look toward height. 

•	 For a Perspective view make sure that you choose 
Narrow, Normal or Wide. Otherwise it won’t be a 
perspective view .

•	 Click on the OK button. 

•	 Now you have a perspective 
view.

•	 Use the saved view menu to 
save this view.

Renderworks Camera

The Renderworks Camera tool is great for setting the view. It is similar to 
the Set 3D command in that you click to locate the camera position and 
look toward position, but unlike the Set 3D View, you end up with an 
object on the screen that you can move and edit. This make the Render-
works Camera more useful. 

cadmovie508

http://learn.archoncad.com/?p=3689
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•	 Go to the Visualization Tool set. 

•	 Select the Renderworks CameraTool .

•	 Go to the Tool bar. 

•	 Click on the Preferences button, the last one 
on the tool bar. 

•	 Fill in the preferences to suit. 

•	 Click on the OK button.

•	 Set your view to Top/Plan 

•	 The first thing VectorWorks 
wants is the camera position. 
Move your cursor to a 
suitable location.

•	 Click once.
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•	 Move the cursor into the 
object. This is the centre of 
your view.

•	 Click once.

The Renderworks camera has a 
plan object that stays on the 
screen. 

•	 Double click on the camera 
to display the view.



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1008

Page 14

•	 Go to the Object Info palette. You can change many 
of the settings in the Object Info palette, and you can 
fine tune the camera as well.

•	 Click on the Fine Tune Camera View... button. 

•	 You can see the camera view and this dialog box. 

•	 Move the sliders to fine tune the camera view. The 
view will update as you move the sliders. 

•	 Click on the OK button.
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•	 You can see the new camera 
view. 

•	 Use the 2D Selection tool to 
edit the the camera position. 
You can move the camera 
location, view angle and the 
look toward location this 
way. 

•	 You can drag a copy of the 
camrea to make a new one, 
then edit the camera location, 
view angle and the look 
toward location. This a quick 
way to add cameras.
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Rendering Types
Rendering is a way of looking at your 3D model with light and shade. 
There are several ways of doing this and each different way has some 
advantages and some disadvantages. 

Line Render 

These options only control the current file. So as you change files, you will 
have to come back to these and check. Of course, if you set these option, 
then save this file as a template, you will not have to check them each time. 
These preferences control the options for hidden line and dashed hidden 
rendering. The line render options also cover the sketch rendering settings.

•	 Go to the Menu Bar. 

•	 Choose View > Rendering > Line Render 
Options...

cadmovie509 

http://learn.archoncad.com/?p=3692
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•	 Click on the tick to Sketch Hidden Line 
Results.

•	 Click on the pop-up menu to choose the 
Document Default Sketch Style. I’ve 
chosen Rough, because that’s the one I like.

•	 Click on the Edit... button. 

•	 Change the smoothing angle to 20º. The 
smoothing angle controls the facets that you 
see on a hidden line rendering for curved 
objects. Setting an angle of 20º will show 
very few of the facets.
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•	 Move the Sliders to see the changes 
in the preview.

•	 You might get some strange results.

•	 Move the sliders until you get nice  
results. 

•	 Click on the OK Button to get back 
to the Line Render Options.

•	 These are the default settings.
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This is the view rendered with 
Hidden Line rendering. 

•	 You can choose a different dash style by 
clicking on the Dash Style pop-up menu. 

•	 You can change how dark the dash lines 
are by sliding the Dash Shade to the 
right. 

•	 Click on the OK Button. 
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•	 You can lighten the dash lines are by 
sliding the Dash Shade to the left. 

This is the view rendered with 
Dashed Hidden Line.
•	 Notice how much lighter the 

lines have become.

This is the view rendered with 
Dashed Hidden Line.
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Open GL

OpenGL rendering is fast and reasonable quality, but is to not the best 
quality. I sometimes call it quick and dirty, because it is one of the fastest 
rendering modes, but it si not the most accurate. 

•	 Go to the Menu bar.

•	 Choose Views > Rendering > OpenGL.

•	 OpenGL rendering is fast but 
not very detailed.

•	 Go to the Menu Bar.

•	 Choose Views > Rendering > OpenGL 
Options.

cadmovie510

http://learn.archoncad.com/?p=3695
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If you set a high level of detail VectorWorks will take 
longer to render the view. Each of these option will 
make the view more detailed and therefore it will take 
longer to render.

The higher level of detail makes 
the model look better.  

Later versions of Vectorworks have the option to Use 
Shadows.
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If you want to use this option, 
you must have a light in the file, 
otherwise you will not see the 
shadows. 

Later versions of Vectorworks have the option to Draw 
Edges.

Some of the complex models 
look worse with this option 
though.
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•	 Choose your options.

•	 Click on the OK button.

OpenGL is the one rendering 
mode that keeps the model 
rendered as you use the flyover 
or walkthrough tools. This 
make this rendering mode 
valuable. 

Fast RenderWorks

I hardly ever use this rendering mode. It is barely a step up from OpenGL, 
and there are no options to choose from. 

•	 Go to the Menu bar Choose  
Views > Rendering > Fast RenderWorks.

cadmovie511

http://learn.archoncad.com/?p=3699
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•	 This is fast but without 
shadows it’s not much better 
than OpenGL.

Fast RenderWorks with shadows

This rendering mode is better, you can see the shadows, but it is barely a 
step up from OpenGL, and there are no options to choose from. 

•	 Go to the Menu bar.

•	 Choose Views > Rendering > Fast 
RenderWorks With Shadows.

This is a reasonable rendering 
mode if you want it quickly. It’s 
a bit crude, but it is FAST!

cadmovie512

http://learn.archoncad.com/?p=3701
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Final quality RenderWorks

This is my usual render choice. It is high quality. 
cadmovie513

•	 Go to the Menu bar.

•	 Choose Views > Rendering > Final Quality 
RenderWorks.

This one of the best rendering 
options available, but it is also 
fairly slow. Some views can 
take several minutes. 

Custom RenderWorks

This rendering method has a lot of flexibility. There are several options you 
can choose from, so you can make Custom Renderworks go from Fast 
Renderworks to Final Quality, and some special options as well.

•	 Go to the Menu bar.

•	 Choose Views > Rendering > Custom 
RenderWorks.

cadmovie514

 

http://learn.archoncad.com/?p=3707
http://learn.archoncad.com/?p=3709
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This method allows you to 
control the quality the best 
rendering available, allowing 
you to balance quality with the 
time you have available.

•	 Go to the Menu bar. 

•	 Choose Views > Rendering > Custom 
RenderWorks Options...

The RenderWorks options control the rendered results if you use Custom 
RenderWorks or if you use the render bitmap tool. Each of these choices 
can dramatically improve the rendered image, but they will also add to the 
time that it takes to render an image. 

•	 Generally you would use textures. 
If you don’t use textures 
VectorWorks will use the color of 
the object as assigned by the 
attributes palette. Glass will not be 
transparent if you do not turn on 
the Use Transparency. 
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•	 You can change the curve quality 
buy clicking on the pop-up menu. 

•	 Ray Traced shadows are crisp but 
slower, shadow mapped shadows 
are not as crisp but they are faster. 

•	 Ray Tracing on reflective objects 
like marble, mirrors and glass looks 
better, the recursion level is how 
many bounces of light VectorWorks 
considers. Use Ray Tracing to see 
though transparent textures. 

•	 Click on the Layer Lighting Options... 
button. We will cover this in more detail 
when we look at lighting. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1008

Page 29

•	 You can choose between Ray 
Traced shadows and mapped 
shadows. 

•	 Go to the pop-up menus to choose 
the quality of the shadows. 

•	 The shows look nice, but I 
notice the glass does not 
render as well as Final 
Quality Renderworks. 

•	 Anti-Aliasing reduces the look of 
jagged pixels on the screen and 
make the printed image look better.

•	 Auto-Adjust Exposure can be used 
to control the lighting. 
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•	 Beware, it can over light the 
scene if you are not careful. 

•	 Notice that I used 73%, not 
100%.

Artistic Renderworks
You can choose Renderworks settings from the menu bar, or from the view 
bar. 

Artistic Renderworks lets you create an artistic rendering that looks like a 
pencil sketch, cartoon and so on. 

•	 Go to the View bar.

•	 Click on the Rendering button, the one that looks like a teapot. 

•	 Choose Artistic RenderWorks.

cadmovie515

http://learn.archoncad.com/?p=3713
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This the Artistic rendering with 
the default values. 

•	 Go to the View bar.

•	 Click on the Rendering button, the one 
that looks like a teapot. 

•	 Choose Artistic RenderWorks 
Options...

•	 Click on the Style pop-up menu. 

•	 Choose your rendering style. 



©Jonathan Pickup - http://www.jonathanpickup.com	
SHORT SHARP TRAINING  - Issue 1008

Page 32

•	 Click on the Options button. 

•	 Set the options. 

•	 You have try these options, 
and see the results. Edit the 
options again until you are 
happy with the results.
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•	 Try another style.

•	 Try several other styles. 
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Lighting
Lighting is a really important part of rendering, without good lighting a rendered 
model can look dull.  Good lighting can save a dull model!

The are two types of lighting:

•	 Ambient Lighting (layer lighting);

•	  Light Sources

Layer Lighting Options

The Layer Lighting Options control the ambient lighting is the lighting all 
around, it has no direction and therefore casts no shadows. The real world 
equivalent is the southern sky, also know as the sky dome.

•	 Go to the Menu Bar.

•	 Choose Views > Lighting > Set Lighting 
Options... 

•	 This opens a dialog box for 
you to set the level of ambient 
lighting. 

cadmovie516

http://learn.archoncad.com/?p=3717
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This is ambient lighting turned 
off. If you are using Radiosity, 
turn off the layer lighting. 

This is ambient lighting at  30% 
Usually 30--40% is about right. 

Ambient lighting on it’s own is 
not good enough. We also need 
to have some light sources. 

Environment Lighting

Environment lighting is the ability to place a kind of background to your model. 
Environment lighting uses something called HDRI (High Dynamic Range Image) 
and uses the light in the HDRI image to calculate the light. the effects can be very 
nice, but very slow. 

cadmovie517
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•	 Go to the Menu Bar.

•	 Choose Views > Lighting > Set 
Lighting Options... 

•	 Change the Environment Lighting 
to From Selected Background.

•	 Click on the Renderworks Back-
ground pop-up and choose the 
source you want. Vectorworks 
comes with some HDRI back-
grounds already made.

•	 Render the view in Final 
Quality Renderworks to see 
the result. 

•	 Go to the Menu Bar.

•	 Choose Views > Lighting > Set 
Lighting Options... 

•	 Turn off the ambient lighting.
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•	 Render the view in Final 
Quality Renderworks to see 
the result. 

Light Sources

The light sources are the lights that make the rendered image come to life. 
If you try to render a file with no lighting, Vectorworks will insert alight 
behind you to light the scene, but you will not see any shadows, the light 
always stays behind you.  

There are 5 types of light sources: 
- Directional 
- Point 
- Spot 
- Line Lights 
- Area Lights

Directional Light

The directional light is like a sun, it’s an outside light. The directional light 
is the type of light that is placed when you use the Set Sun Position from 
the View Menu. 

This light source has a direction and casts shadows but it’s position in the 
file is not critical as it casts a general light from a direction rather than from 
a point. 

cadmovie518
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•	 View > Lighting > Set Sun Position...

To place an accurate sun, you 
need the latitude and longitude 
of your site. If you do not know 
these, use Google earth to find 
the site. At the bottom of the 
Google Earth screen is the 
latitude and longitude. 

•	 On the dialog box that opens we 
can set our latitude, longitude, 
month, day and time. 

This dialog box assumes that the 
model is drawn with north directly up 
the page. 
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•	 If you have not draw the model 
with north directly up the page, use 
the Page North to tell Vectorworks 
where north should be. 

•	 Click on the OK button.

•	 Choose Final Quality 
Renderworks. You can’t see 
the actual light source, but 
you can see the results of the 
light source. Notice that 
when using this light source, 
the light does not fall off as 
you move away from the 
light.

If you have the light selected and you choose Set Sun Position... again, it 
changes the position of the selected sun, it does not place a new sun. 
VectorWorks will insert a directional light with the correct direction and 
angle. 

You may find the scene is too bright. The sun is selected, so you can edit it 
on the Object Info Palette to reduce the brightness, and change the color. 
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•	 The Visualization palette allows you to create, 
edit, duplicate, delete and select lights, by right 
mouse clicking in the palette. 

•	 Lights appear on the Visualization palette. 

•	 Open the Visualization palette form the Window > 
Palettes menu.

If you want to create a solar animation, do not add a directional light. The 
solar animation command will add its own light. Your extra directional 
light will confuse things by adding extra shadows.

Point Light

A point light is like a bare light bulb. The light goes out in all directions. 

cadmovie519

•	 Go to the Visualization Tool Set. 

•	 Click on the Light Tool.

•	 Go to the Tool bar. 

•	 Click on the second mode, 
the Point Light mode. 

http://learn.archoncad.com/?p=3728
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•	 Go to the Tool bar. 

•	 Click on the Preferences button, the 
last mode. 

•	 Check your preferences. You can 
change the color and brightness, 
but beware about putting in too 
many bright lights. 

•	 Click in the drawing area to 
place a light object. You can 
use the model as a guide, and 
line up with it. 

•	 Go to the Visualization palette.

•	 Right mouse click on the light. 

•	 Choose Edit...
•	 You can change any of the settings on the light using 

this palette, or you can use the Object Info palette if 
the light is selected. 

•	 If you change the Dist Fall (distance falloff, the 
amount the light falls off) to Smooth, it will change 
the effect of the light.
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•	 This is the view in Final 
Quality Renderworks

•	 Change the Dist Fall to None. 

•	 This is the view in Final 
Quality Renderworks with no 
layer lighting. You can’t see 
the actual light source, but 
you can see the results of the 
light source. You can see the 
bright spot near the light and 
the light falls off as you 
move away from the light.
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•	 Copy the light to several 
places.

•	 Select the lights.

•	 Go to the Object Info palette.

•	 Change the Brightness by pulling the slider to 
the left, reducing the brightness of all the 
lights. 

•	 If you put too many lights in 
the scene you can over-light 
it. 

•	 This is the view in Final 
Quality Renderworks with no 
layer lighting. 
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•	 This is the view in Final 
Quality Renderworks with 
30% layer lighting. 

•	 Spot Lights

Spot lights are directional lights that point at a particular location, and they 
have a controllable beam and spread. Spot lights are best placed in plan 
and then checked in elevation.

cadmovie520

•	 Change your view to a Top View.

•	 Go to the Visualization Tool Set. 

•	 Click on the Light Tool.

•	 Go to the Tool bar. 

•	 Click on the third mode, the 
Spot Light mode. 

http://learn.archoncad.com/?p=3731
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•	 Click on the screen to place 
the light.

•	 Click on the screen to show 
where the light is pointing. 
This places the spot light in 
plan.

•	 A dialog box will open. This is for 
you to set the attributes of the light. 
Set the brightness, color, beam and 
spread. 

•	 Click on the OK button.
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•	 Go to the Basic Tool palette. 

•	 Select the 3D Selection tool. 

•	 Change views to right view 
to check the position of the 
light in elevation. 

•	 Drag the light up. 

•	 Move your cursor to the end 
of the spotlight. 

•	 The cursor should change to 
an interactive scaling cursor 
(reshape). 

•	 Drag the end of the light 
down.

•	 If you render the view in 
Final Quality RenderWorks 
you can see the result of the 
lighting. 
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•	 With the light selected, go to the Object Info 
palette.

•	 You can use the Object Info Palette to control 
the light. 

•	 Turn on Cast Shadows. 

•	 You can see the shadows on 
the objects.
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•	 Go to the Object Info palette.

•	 Turn on Lit Fog. 

•	 This shows you the beam of 
light. be careful with this 
option. 

•	 Go to the Object Info palette.

•	 Adjust the Beam by dragging the handles. 
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•	 You may not see the differ-
ence. 

•	 Go to the Object Info palette.

•	 Adjust the Spread by dragging the handles.

•	 The difference is dramatic. 

•	 Go to the Object Info palette.

•	 Adjust the Spread and Beam by dragging the 
handles.
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This the view rendered with 
Final Quality Renderworks, 
with no layer lighting.

This the view rendered with 
Final Quality Renderworks, 
with 30% layer lighting. Notice 
how the paving texture looks 
good in the spotlight, not so 
good in the layer lighting. 

Same view with the same 
lighting direction, but using a 
direction light. 
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Line Lights

Lines lights can be used to replicate tube lighting and neon lighting. 
Beware, these line lights take ages to render. There is no tool to use. You 
draw a shape you want and use a command to convert the shape to a line 
light. 

cadmovie521

•	 Draw a shape, or shapes that 
you want. I have used a circle 
and polyline, and created the 
shapes in a front view so they 
will be at the correct height. 

•	 Go to the Menu Bar.

•	 Choose Modify > Convert > Convert to Line 
Light...

http://learn.archoncad.com/?p=3736
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•	 Choose your lighting options. If you 
want neon lighting, choose a suitable 
color. 

•	 Click on the OK button.

•	  If you use more than one 
object like I did, Vector-
works will group the lights 
together. 

•	 Check the lights in plan view, 
and move the lights if neces-
sary. 
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This rendering takes several 
minutes on my computer. If I 
wanted to do a lot of this, I 
would look at updgrading my 
computer to a multi-core model 
(like the new 12 core Mac Pro). 

Area Lights

Area lights can be used to simulate a large area of lighting, like a window. 
Beware, like line lights the area lights take ages to render. There is no tool 
to use. You draw a shape you want and use a command to convert the 
shape to an area light. 

I couldn’t find a good example of using an area light for an external render-
ing, so I will use an interior view. 

cadmovie522

•	 Draw a shape, or shapes that 
you want. I have used a 
rectangle, and created the it 
in a front view so it will be at 
the correct height and width. 

http://learn.archoncad.com/?p=3742
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•	 Go to the Menu Bar.

•	  Choose Modify > Convert > Convert to 
Area Light...

•	 Choose your lighting options. 
Choose a suitable color. Use 
Emitter gives you control over the 
light output using Lux or Lumens, 
rather than just brightness. 

•	 Click on the Area Light Specs... 
button.

•	 Chose the options here. To find the 
solution you light best, try the settings 
shown, and render the view. Use the 
Object Info palette to edit the settings and 
render the view. See what you like. 

•	 Click on the OK button to return to the 
Light Preferences. 

•	 Click on the OK button to finish. 
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•	 Check the lights in plan view.

•	 Change to the 2D Selection 
tool. 

•	 The area light has a direction. 
When I move this light into 
the window, the light will be 
going out of the room, not 
into the room. 

•	 Go to the Object Info palette. 

•	 Click on the button to Flip Direction.  
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•	 The light will be shining the 
right way. 

•	 Move the light into the 
window reveal. 

•	 Ensure you do not place the 
area light behind a solid 
object, like a wall, glass and 
so on.  
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•	 Change to your perspective 
view. 

To improve the scene, I have placed a directional light outside the building. 
The glass doors have a glass texture to left the sun light in. I have placed a 
light symbol on the table, and an uplighter just to the right of the view. you 
can not see the light, but you will see the light shining on the ceiling. 

View rendered with Final 
Quality Renderworks, with out 
any textures. You can see the 
lights, but the scene looks so 
flat. 

View rendered with Final 
Quality Renderworks, this time 
using some textures. I have 
added reflectivity to several of 
the textures to make the scene 
more life-like. 
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Renderworks Background
The Renderworks background allows you to create something behind your model 
to make it look better. 

In the views of the bus stop, you will have noticed the background was a plain 
white. that does not help your clients to visualize the project. 

A simple background can make a big difference. 

cadmovie523

Let’s make a Renderworks 
background. 

•	 Go to the Resource Browser.

•	 Click on the Utility menu. 

•	 Choose Create > Render-
works Background...

•	 This dialog box gives you the 
options to create a back-
ground.  

•	 Name the background. 

•	 Click on the Background 
pop-up menu.

•	 Choose Clouds. 

http://learn.archoncad.com/?p=3745
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•	 Click on the Options... button. 

•	 I always choose a very dark blue 
for the background color. 

•	 Change any of the other settings. 
You will need to play with these 
settings to get the look you are 
happy with. 

•	 Click on the OK button to get back to the Render-
works Background dialog box. 

•	 Click on the OK button to finish creating the 
Renderworks background. 

•	 You will find the new background in the Resource 
Browser. 

•	 Click and drag your new 
background to your view. 
Without a background the 
view looks strange and 
artificial. 

•	 Release the mouse to assign 
the background to the model. 
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The addition of a simple 
background can really 
improve the rendering. 

•	 Use the Resource Browser to 
create a new background. 

•	 Name the Background.

•	 Click on the Background 
pop-up menu.

•	 Choose Two Colors from the 
pop-up. 

•	 Click on the Options... button. 

•	 For a sunset, I choose a dark, dark blue for the 
top color, and a yellow or orange for the 
bottom color. 

•	 Click on the OK button to get 
back to the Renderworks 
Background dialog box. 

•	 Click on the OK button to 
finish creating the Render-
works background. 
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•	 You will find the new background in the 
Resource Browser. 

•	 Click and drag your new 
background to your view.

•	 Release the mouse to assign 
the background to the model. 

•	 Use the Resource Browser to 
create a new background. 

•	 Name the Background.

•	 Click on the Background 
pop-up menu.

•	 Choose Clouds from the 
pop-up and set the options.
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•	 Click on the Weather pop-up menu.

•	 Choose Ground Fog from the pop-up. 

•	 Click on the Options... button.

•	 Try some of the options. 

•	 Click on the OK button to get back to the 
Renderworks Background dialog box. 

•	 Click on the OK button to 
finish creating the Render-
works background. 

•	 Drag your new background to 
your view.

You should try out these options to see which ones you like. I like the 
clouds and two colors. 
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Render Bitmap tool

Adding area lights and line lights makes rendering very slow. I made a 
texture on the ceiling with a blur, which makes the rendering take longer as 
well. This has the effect of locking up your computer for 10 or 20 minutes 
at a time. This is not a great use of your time and it make it hard to make 
decisions about your rendering. If you need help with textures, refer to the 
earlier user group notes on textures (1006). 

You need to bring all these parts 
together, the rendering, lighting, 
textures and modeling. They all 
need to work together to make 
the view come alive.  As you 
add textures, lights, background 
and models to the scene, Vector-
works starts taking longer to 
render the view. 

The answer is to render small areas of your view with the Render Bitmap 
Tool.

cadmovie524

•	 Go to the Visualization Tool Set. 

•	 Click on the Render Bitmap tool. 

•	 Go to the Tool bar.  

•	 Click on the Preferences 
button. 

•	 Most people forget to check 
these, then wonder why the 
rendering is low quality. 

http://learn.archoncad.com/?p=3750
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•	 Choose the Render mode 
from the pop-up. 

•	 Type in the Resolution. the 
higher the number the better 
image will look on the 
screen, but the rendering will 
take longer. 

•	 Click on the OK button.

•	 Click to start. 

•	 Drag a small area. 

•	 Release the mouse button. 

•	 Vectorworks renders on the 
area of the marque. 
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Because you are rendering a 
small area, it doesn’t take as 
long. 

I often use this to render lots of 
small areas of the view to test 
shadows, exposure, reflections, 
and so on.  
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Batch Render

This is the trick to make sure you do not tie up your computer when you 
want to be using it. After you have assigned the light, cameras, models and 
textures, and you have used the render bitmap tool to check everything, 
you can set up batch render jobs for you computer to work on while you 
are on site, at meetings, or asleep.   

There are two parts to batch rendering. First you have to define each batch 
render job, then you have to tell Vectorworks which batch render jobs to 
do. 

cadmovie525

•	 Because you are setting the view first, it 
pays you to set the perspective view 
exactly the way you want first.

•	 Go to the Menu Bar.

•	 Choose View > Rendering > Create 
Batch Render Job...

•	 Click on the pop-up to choose the 
rendering type. 

•	 Click on the Set Export Image File 
Options... button. 

http://learn.archoncad.com/?p=3754
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•	 It is very important to set the 
options, otherwise you will get 
the wrong file size, and quality.

•	 Choose Current View.

•	 Set the Resolution. This works 
with the page size. Set a 
reasonable resolution and page 
size, so when you print you 
have good quality. 

•	 These are the settings I usually 
use. 

•	 Click on the OK button.

•	 Name the view. do not use a name 
that is already used. 

•	 Set up as many views as you want, 
from different places, heights and so 
on. 
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When you have all your batch render jobs, 
you can set Vectorworks to export them all. 

•	 Go to the Menu Bar.

•	 Choose View > Rendering > Start Batch 
Render...

•	 Click on the render you want, 
on the left-hand side. 

•	 Click on the >> button to add 
the view to the chosen jobs. 
Or, you can click on the 
Choose All button to add them 
all quickly. 

•	 Click on the Choose... button 
to choose a destination. 

•	 Click on the OK button. 

•	 Vectorworks tells you the 
progress. When it finishes, the 
exported images will be in the 
chosen folder in the format 
you chose. 
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Tips

Keep the number of lights you use to a minimum. The more lights you add, 
the longer each rendering will take. Do not add every light that would be in 
the scene in real life. Rendering so not replicate real life, you have to show 
your interpretation of it. Often, few lights will give a better result. 

For exterior rendering, Renderworks backgrounds really help. Area lights 
do not. Use a sun and spot lights to fill in details. 

For interior rendering, Area lights really help, but they are very slow. Make 
sure you use reflective textures to reflect the lights around the room. Use 
Transparent glass to let the outside light in. Use a sun .

Look at using Camera Match, it can save you a great deal of modeling and 
the rendering results are fantastic. please look at this site for cameramatch, 
I have written a manual for cameramatch which you can download from 
the website. http://www.panzercad.com/ 

Radiosity is sooo sloooow..... I can’t use it.. If you want to use Radiosity, 
get a super-fast computer with multiple cores. 


