
Workshop Topic 
Irrigation Tools
Vectorworks comes with several irrigation tools. There is a tool for 
placing irrigation pipework, and there are two tools for placing sprin-
klers and drip emitters. When the pipework and emitters are placed, 
you can create a schedule of the parts.     

Extended Podcast 102 - Click here
Editing a property line, it’s easier than you think. 

Extended Podcast 103 - Click here
You can import a PDF File and ungroup it, as long as it has vector 
information.

 

SHORT SHARP TRAINING  
(monthly) issue 1003 

Welcome to this issue of the VectorWorks Short 
Sharp Training (monthly). This manual is designed 
to work like a user group meeting. There is a main 
workshop topic, then extended movies showing tips 
or techniques and an area for beginners. 

http://learn.archoncad.com/?p=3374
http://learn.archoncad.com/?p=3375
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Introduction 
Vectorworks has several irrigation tools. There are tools for placing sprin-
klers, pipes, and drip emitters, and there are worksheets for counting these 
objects. 

The irrigation tools are only available if you have Vectorworks Landmark. 
But what if you have Vectorworks Fundamentals, Architect, or one of the 
other Vectorworks packages? You can’t use the irrigation tools, but you can 
build symbols that replicate the sprinklers and drip emitters. They will not 
be as flexible, but it is a workaround. We will cover these later, after looking 
at the Landmark tools. 

I r r i g a t i o n  T o o l s

Irrigation Heads
The irrigation head tool is used to place your sprinklers. This tool creates 
a  2D object that shows the head and spray pattern. It does not create a 3D 
version, although with Vectorworks 2010 you can see the spray pattern in 
3D, but only if you layer plane. 

Because the object is 2D only, you can’t use the Send to Surface command 
to see the irrigation head on your site model, the planar graphics always 
have the spray pattern on the bottom of the layer. 

In earlier versions of Vectorworks the spray pattern is 2D only, and you can 
not change it. 
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• Go to the Site Planning Tool set. 
• Choose the Irrigation Head tool. 

• Go to the Tool Bar.
• Click on the Preferences... 

button, the last button on the 
tool bar. 

This dialog box controls all the settings for the 
Irrigation Head. 
• Fill  in the dialog box to suit the Irrigation Head 

you want to use.
• Click on the OK button. 

http://learn.archoncad.com/?p=3376
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• Move your cursor into the 
drawing area.  
You should notice a ghost 
image on the cursor. This is 
your  Irrigation Head. 

• Move your cursor to the 
centre position for your first 
Irrigation Head (sprinkler).

• Click once. 

• The next click controls 
rotation. 

• Move along the edge of the 
object you want to use. 
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• Click once. 

This has positioned the Irriga-
tion head (sprinkler). 

• Move to the next location.
• Click once. 

• Move your cursor to set the 
rotation. 

• Click once. 
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• Go to the Tool Bar.
• Click on the Preferences... button, the last 

button on the tool bar. 
• Fill  in the dialog box to suit the Irrigation 

Head you want to use, say 90º.
• Click on the OK button. 
• Move your cursor into the drawing area.  

You should notice a ghost 
image on the cursor. 

• Move your cursor to the 
corner.

• Click once. 
• The next click controls 

rotation. 

• Place the other sprinklers you 
want.

http://learn.archoncad.com/?p=3377
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• Move along the edge of the 
object you want to use. 

• Click once. 

This has positioned the Irriga-
tion head (sprinkler). 
• Move to the next location.
• Click once. 

• Move your cursor to set the 
rotation. 



©Jonathan Pickup - http://www.archoncad.com 
SHORT SHARP TRAINING  - Issue 1003

Page 8

• Click once. 

• Place the other sprinklers you 
want.

• Go to the Tool Bar.

cadmovie449

• Click on the Preferences... button, the last 
button on the tool bar. 

• Fill  in the dialog box to suit the Irrigation 
Head you want to use, say 360º.

• Click on the OK button. 
• Move your cursor to the correct location.

http://learn.archoncad.com/?p=3387
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• Double click to place the 
sprinkler. 

The Irrigation Head doesn’t get 
much more complicated that 
this. You can choose different 
fittings, and head types, but that 
doesn’t change the way the tool 
works. 
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Drip Emitter
This tool is to place the small drip emitters on the plan.

cadmovie450

• Go to the Tool Bar.
• Click on the Preferences... 

button, the last button on the 
tool bar. 

This dialog box controls all the settings for the 
Irrigation Head. 
• Fill  in the dialog box to suit the Drip Emitter 

you want to use.
• Click on the OK button. 

• Go to the Site Planning Tool set. 
• Choose the Drip Emitter tool. 

http://learn.archoncad.com/?p=3388
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• Click once for the centre of 
the Drip emitter. 

• Click once for the rotation of 
the object.

• Object placed.
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• Go to the Tool Bar.
• Click on the Preferences... button, the last 

button on the tool bar. 
• Choose the Sub-Surface Drip.
• Click on the OK button. 

• Move your cursor into the 
drawing area. 

• Click once for the centre of 
the drip emitter. 
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• Move your cursor for the 
rotation. 

• Click once. 

• Notice that this drip emitter 
has a line on it showing the 
rotation. 
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• Go to the Basic toolset.
• Choose the 2D Selection tool. 
• Go to the Tool bar.
• Make sure the second mode 

is active. 
• Move to the handle in the 

middle of the drip emitter. 
• Click once. 

• Move across to the right. 

• Click once. 
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• Move back to the blue handle 
in the middle of the drip 
emitter. 

• Click once.

• Move your cursor across to 
the right and up.

• Click once. 
• The second handle to used to 

control the curve on the drip 
emitter. 
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• Go to the Site Planning toolset
• Select the Irrigation Line tool. 

This dialog box controls all the settings for the 
Irrigation Head. 
• Fill  in the dialog box to suit the Irrigation Line 

you want to use.
• Click on the OK button. 

Irrigation Line
The Irrigation line tool is used for drawing the irrigation supply pipes. It 
only draws straight lines, and it only draws one line each time you use it.

cadmovie451

• Go to the Tool Bar.
• Click on the Preferences... 

button, the last button on the 
tool bar. 

• Click once at the start of the 
Irrigation Line. 

http://learn.archoncad.com/?p=3389
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• Click once.

Remember that this tool creates 
a single line. So, the second 
click finishes the first Irrigation 
Line. To start another Irrigation 
Line, you have to click again. 

• Click to start a new line.
• Click once to finish. 

• Move your cursor to the first 
junction. 
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Scheduling Irrigation Items
Vectorworks has a built-in ability to count and schedule information. So, 
for irrigation, we could count up all the Irrigation Heads, drip emitters and 
pipes. Vectorworks has some pre-made worksheets that will count up 
objects for you. 

You can access the worksheets from the Resource Browser, or though a 
menu command. We’ll look at the Resource Browser method first. 

cadmovie452

• Draw the rest of your Irriga-
tion Lines. Remember to 
click once at the start, and 
once at the end of each Irriga-
tion Line.

• Go to the Resource Browser.
• Click on the arrow next to the Files. We can use 

this to add a favorite file to the Resource Brows-
er. Every time you start Vectorworks, your 
favorite files are added to the Resource Browser. 

• Click on Add New Favorite Files...

http://learn.archoncad.com/?p=3390
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• Navigate to the Vectorworks application folder: 
on a Macintosh 
Applications:Vectorworks :Libraries:Defaults:Reports~Schedules 
on a Windows machine 
Program Files/Vectorworks /Libraries/Defaults/Reports~Schedules

• Locate the Irrigation Reports file in the Landmark Schedules folder.
• Double click on the file to add it to your Resource Browser.

• Go to the Resource Browser.
• Click on the Files pop-up menu.
• Choose Irrigation Reports. 
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• You should see the Irrigation Head Schedule and 
the Irrigation Line Schedule in the Resource 
Browser.

• Click and drag the Irrigation Head Schedule.

• Move your cursor into the 
drawing area.

• Choose a location away from 
the plan.
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• Release the mouse button. 
• The worksheet is placed on 

the drawing. It becomes like 
any other drawing object, and 
you can move with the 2D 
Selection tool. 

• Go to the Resource Browser.
• Click and drag the Irrigation Line Schedule.

• Move your cursor into the 
drawing area.

• Choose a location away from 
the plan.



©Jonathan Pickup - http://www.archoncad.com 
SHORT SHARP TRAINING  - Issue 1003

Page 22

• Release the mouse button. 
• The worksheet is placed on 

the drawing. It becomes like 
any other drawing object, and 
you can move with the 2D 
Selection tool.

There is a another method which places the worksheets on the drawing, but 
this only works if you have Vectorworks Designer or Landmark. There is a 
command to try to automate some of the work, the results are the same. 

cadmovie453

• Go to the Menu Bar.
• Choose Tools > Reports > Choose 

Schedule...

This dialog box lists all the available 
schedules, so you will see several you do 
not want. Clicking on more than one sched-
ule doesn’t work, Vectorworks will import 
just the first schedule. 

• Click on the schedule you want. 
• Click on the OK button.

http://learn.archoncad.com/?p=3392
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• Move your cursor into the 
drawing area.

• Choose a location away from 
the plan.

• Click once. 

The worksheet is placed on the 
drawing. It becomes like any 
other drawing object, and you 
can move with the 2D Selection 
tool.

• Go to the Menu Bar.
• Choose Tools > Reports > Choose 

Schedule...
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• Click on the schedule you want. 
• Click on the OK button.

• Move your cursor into the 
drawing area.

• Choose a location away from 
the plan.

• Click once. 



©Jonathan Pickup - http://www.archoncad.com 
SHORT SHARP TRAINING  - Issue 1003

Page 25

This is the automated way of counting up the sprinklers and pipes. The 
schedules only count the information that Vectorworks has  added to each 
object. If you want to count other information, you can’t with the standard 
schedules but you can if you put some effort into it. 

You might notice that the schedules have not counted the drip emitters. You 
might also have noticed that there are no risers on the sprinklers, and the 
irrigation pipes do not have junctions. 

Vectorworks has a built -in facility to create a database and schedules. If 
you create the database to record the information you want, you can create 
the reports you need. 

Irrigation for non-Landmark Users
The irrigation tools and commands only come with Vectorworks Landmark 
or Designer. So, if you want to do this kind of work, should you bye 
Vectorworks Landmark? 

Not Necessarily. First of all the Landmark tools and schedules have some 
problems. Some things do not total (irrigation lines), some things are not 
counted at all (drip emitters) and some things are just missing (pipe junc-
tions). 

So, what is the answer? Well, with a small amount of effort, you can make 
symbols of the sprinklers, drip emitters and pipe junctions. These object 
can have the information you want attached  and you can create a work-
sheet that will count all the parts. 

If you save the symbols and worksheets in your library, you can use them 
on project after project, saving you a lot of time and providing a new 
service to your clients. 
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If you make a symbol of the 
sprinkler you can create a 2D 
part for the plans, and a 3D part 
for visualization. The 3D part 
can be sent to the surface of 
your site model, so they appear 
at the correct 3D height. This is 
not currently available with the 
Landmark irrigation tools. 

Making a Symbol
The Vectorworks Irrigation Head uses a class for the Spray Pattern. This 
allows you to turn the spray pattern on or off, depending on the drawing. 
We should use this same class name. 

cadmovie454

• Go to the Menu Bar.
• Choose Tools > Organiza-

tion...
• Click on the Class tab.
• Click on the New... button to 

create a new class. Choose 
the option to Edit After 
Creation. 

http://learn.archoncad.com/?p=3393
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• Edit the graphic attributes of the class. 
Set the Fill Style to None and the Pen to 
a blue dashed line. 

• Turn on the option to Use at creation.
• Click on the OK button.

• Draw one circle for the 
sprinkler head. 

• Draw one circle for the spray 
pattern. This circle should be 
selected (highlighted). 

• Go to the Object Info pal-
ette.

• Click on the Class pop-up menu. 
• Choose Irrigation > SprayPat.
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• Notice the change in fill 
pattern and pen color. 

• Duplicate the circle for the 
spray head, or draw another 
circle. 

• Make sure this circle is 
selected (highlighted). 

• Go to the Menu Bar.
• Choose Model > Extrude...

• Do not change the ∆X and the ∆Y sizes.
• Type in the height of the sprinkler in the extru-

sion field. 
• Click on the OK button.
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• Go to the 3D Modeling tool set. 
• Click on the Hemisphere tool. 
• Go to the Tool bar. 
• Click in the second mode, Hemisphere By Diameter.

• Move your cursor to the left 
middle of the circle. 

• Click once. 
• Move to the right middle of 

the circle. 
• Click once. 

• Select all the  2D and 3D 
objects. 

• Check the number of objects 
on the Object Info palette. 
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• Go to the Menu Bar.
• Choose Modify > Create Symbol... 

• You might get this message. 
• Click on the Yes button. 

• Name your symbol. I have used the spray 
radius_angle. That way I can find all the 
same spray radii together. 

• Turn on Leave Instance in Place.
• Use Plan Projection Center for the 

Insertion Point. 
• Click on the OK button.
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The 4 objects have been made 
into a symbol. A symbol in Top/
Plan view will only show the 
2D parts of the symbol. In any 
other view, Vectorworks will 
show only the 3D parts of the 
symbol. 

Making a Database (Record Format)
Vectorworks has a database concept called a record format. This concept 
allows us to attach information to an object. The information has to be an a 
structured form to be useful and that is the job of the record format, to 
structure the information. 

You can make the record format to store any kind of information that want. 
The trick is to figure out what you want to report, and that will tell you 
want you need to record. Don’t worry too much about getting it all sorted 
at the beginning, you can edit the record format later to fix any mistakes, or 
to add any new fields you need. 

cadmovie455

• Go to the Resource Browser.
• Click on the Resources 

Menu, the arrow next to the 
word Resources. 

• Choose New Resource in 
file... > Record Format. 

http://learn.archoncad.com/?p=3394
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This is the control area for the record 
format. 

• Name your record format. Names 
in Vectorworks have to be unique, 
so I often add the name Record, so 
I don’t get any conflicts with other 
objects. 

A record format needs a structure to 
store the information. Fields are used 
to structure this information. 
• Click on the New... button. 
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• Name the field. Use a name that makes sense to 
you. Try to use a name that is self-explanatory. 

• Click on the OK button.

• Click on the New... button to create another 
field. 

• Name the field.  
• Click on the OK button.

• Click on the New... button to create another 
field. 

• Name the field.  
• Click on the OK button.
• Keep make new fields for all the information 

you want to store. 
• Click on the OK button.

Your record format will be in the Resource Browser. 
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• Locate your record format in the Re-
source Browser.

• Right mouse click (control+click) on it.
• Choose Edit...

• The Edit Record Format dialog box 
opens. You can re-order the fields, 
delete or add files. 

• Click on the New... button. 

• Name the field.  
• Click on the OK button to get back to the Edit 

Record Format dialog box.
• Click on the OK button to get back to the 

drawing.
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• Locate your sprinkler symbol 
in the drawing. 

• Double click on it. 

• Normally you will get this 
dialog box. 

• Choose the 2D option. 
• Click on the OK button. 

You are now in the symbol 
editing area. Everything you 
use to create the symbol is 
currently selected. 
• Click once away from every-

thing to deselect it. 
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• Select only the spray pattern 
circle.

• Use the Object Info palette to 
assign this to the correct class 
(Irrigation-Spraypat). 

• Notice the circle changes line 
style and color.

• Click away from everything. 

• Go to the Object Info palette.
• Click on the Data tab.

• Click on the tick box. 
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• Create some text for the ID 
number. 

• Leave it selected. 

• Go to the Menu Bar.
• Choose Modify > Link Text to Record...
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• Select your Record Format at the top part.
• Select the ID field.
• Click on the OK button. 

The record format is connected 
to the text in the symbol. When 
you edit the data in the field on 
the Object Info palette, the text 
on the symbol will change. 
• Click on the Exit Symbol 

button on the top right of the 
screen. 

You back to the drawing area. 
Attach to symbol. 

• Delete this instance of the 
symbol, we want to place the 
sprinklers on the lawn. 
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• Go to the Resource Browser.
• Locate the sprinkler symbol. 
• Double click on the symbol. 

• Move your cursor to the 
position for your first 360º 
sprinkler. 

• Double click to place the 
symbol. 

• Notice that the ID for the 
sprinkler is not filled in. 
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• Go to the Object Info palette.
• Click on the Data tab.
• Click on the ID field.
• Type in the ID number in the bottom area of the 

Object Info palette. 

• Hit the Enter or Return key.
• The data is added to the 

symbol.

Creating Duplicate Symbols

cadmovie456

• Go to the Resource Browser.
• Locate the first sprinkler symbol. 
• Right mouse click (control+click) on the 

symbol. 
• Choose Duplicate...

http://learn.archoncad.com/?p=3395
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• Name your symbol. I have used the spray 
radius_angle. 

• Click on the OK button.

• Go to the Resource Browser.
• Locate the new symbol.
• Right mouse click (control+click) on the 

symbol. 
• Choose Edit...

• Choose the 2D Component.
• Click on the OK button.
This takes you into the symbol editing 
area. 
• Click once away from everything 

to deselect it. 

• Select just the spray pattern. 
• Go to the Basic Tool set. 
• Select the Split Tool.

• Go to the Tool bar.
• Click on the third mode, 

trim by line. 
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• Start outside the circle, lining 
up with the center. 

• Click once.

• Move across the circle, 
keeping the line straight. 

• Click once.
• Move you mouse down. 
• Hold the down the option or 

alt key. This key makes this 
tool split just the selected 
object. 

• Click once. 
• Click on the Exit Symbol 

button on the top right of the 
screen. 
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• Go to the Resource Browser.
• Locate the new symbol.
• Right mouse click (control+click) on the symbol. 
• Choose Edit...

• Choose the 3D Component.
• Click on the OK button.
This takes you into the symbol editing 
area. 

• Click once away from every-
thing to deselect it. 

• Select just the spray pattern. 
• Go to the Basic Tool set. 
• Select the Split Tool.
• Go to the Tool bar.
• Click on the third mode, 

trim by line. 
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• Start outside the circle, lining 
up with the center. 

• Click once.

• Move across the circle, 
keeping the line straight. 

• Click once.

• Move you mouse down. 
• Hold the down the option or 

alt key. This key makes this 
tool split just the selected 
object. 
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• Click once. 
• Click on the Exit Symbol 

button on the top right of the 
screen. 

• Go to the Resource Browser.
• Locate the sprinkler symbol. 
• Double click on the symbol. 

• Move your cursor to the 
position for your sprinkler. 
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• Click to place the symbol. 

• Move the mouse to define the  
rotation of the symbol. 

• Click once. 
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• Place all the symbols you 
want. 

• If you change to a 3D view. 
You can see the irrigation 
symbols, but they are not 
sitting on the site model. 

• Select all the irrigation 
symbols. 
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• Go to the Menu Bar.
• Choose  AEC > Terrain > Send to Surface if you 

have Vectorworks Architect.
• Choose  Landmark > Send to Surface if you have 

Vectorworks Landmark.

All the symbols are sitting on 
the site. 

If you render the view, it looks 
better. 

• Change your view to Top/
Plan.
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• Go to the Resource Browser.
• Locate the last sprinkler symbol. 
• Right mouse click (control+click) on the 

symbol. 
• Choose Duplicate...
• Name your symbol. 
• Click on the OK button.

• Go to the Resource Browser.
• Right mouse click 

(control+click) on the sym-
bol, choose Edit...

• Edit the 2D Component.
• Split the Arc to 90º. Go to the 

Tool bar.
• Click on the Exit Symbol 

button . 

• Edit the 3D Component
• Use the split tool to cut the 

3D shape to 90º.
• Click on the Exit Symbol 

button.
• Go to the Resource Browser.
• Double click on the symbol. 



©Jonathan Pickup - http://www.archoncad.com 
SHORT SHARP TRAINING  - Issue 1003

Page 50

• Place as many symbols as 
you need. 

• Send them to the surface. 

If you have Renderworks, You 
can edit the symbols to assign a 
texture to the 3D parts of the 
spray pattern. I think it looks 
better that way. 

Symbols for Junctions and Connections

If you wanted to count all the elbow joints, pipe connections and junctions, 
all you need to do is to create a small symbol with a database, or record 
format attached. The record format could record the type of connection, the 
make and model, cost and so on. You can even add the ID like we did for 
the sprinkler. 
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The quickest way to make 
symbols for the connectors is to 
duplicate a sprinkler symbol 
and edit it. 

• Place the small symbol at 
each junction. 

The quickest way to create the record for the connec-
tors is to duplicate the Sprinkler record and edit it
• Go to the Object Info palette, fill in the data and it’s 

ready to count. 

The quickest way to make 
symbols for the drip emitters is 
to duplicate a sprinkler symbol 
and edit it. 
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Use the Sprinkler record for the drip emitters, unless 
you really want to have different information. 
• Go to the Object Info palette to fill in the data. 

Think about assigning the text 
in your symbols to a special 
class. This will allow you to 
make the text visible for some 
views or viewports. 

You will also be able to make 
the text invisible for some 
views or viewports. 
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Irrigation Pipe Work
The Landmark tool set has an Irrigation Line tool, but if you do not have 
Landmark, what can you do? The answer is to use a polygon, polyline or 
standard line tool, and assign these to a special class. We can use the class 
to control the graphic style, and we can also use the class to quantify the 
lines to give us overall lengths. If you use a class for each pipe size, you 
can qualify each type of pipe. 

cadmovie457

Here are the main pipes. The 
Line weight and color is con-
trolled by the class settings. 

• Use the Object Info palette to assign the objects to 
the correct class. When we count up the pipes, we 
want to count up the correct objects, and the class 
will control this for us. 

http://learn.archoncad.com/?p=3396
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Here are the secondary pipes. 
The line weight and color are 
controlled by the class settings. 

• Use the Object Info palette to assign the objects to 
the correct class. When we count up the pipes, we 
want to count up the correct objects, and the class 
will control this for us. 

Building the Worksheet to Count Sprinklers
 I mentioned earlier that you can get Vectorworks to count things to suit 
you, a custom way of counting. In Vectorworks we call this a report, and 
the results are shown on a worksheet. We can add reports together to 
collect all the objects we want. 

The technique of adding information to objects, then reporting them is 
useful in several applications, nit just in landscaping. You can use this 
technique for so many things, it makes Vectorworks one of the most pow-
erful CAD programs around. 

cadmovie458

http://learn.archoncad.com/?p=3397
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• Go to the Menu Bar.
• Choose Tools > Reports > Create 

Report...

This dialog box allows you to 
choose how the report will be 
made.  

• Name the Report. This will 
become the name of the 
worksheet. 
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• Click on the Records pop-up 
menu.

• Choose your sprinkler record.

All the fields you created are 
shown on the right side. 

• You can remove fields you do 
not want to report, by click-
ing on the field and Click on 
the Remove button. 

You can re-order the fields. 

• Click on the ID field in the 
number column. 
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• Drag the field to the top of 
the list. 

• Release the mouse button. 
The field is now at the top of 
the list, and will be the first 
column in the worksheet. 

• Click on the OK button. 
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• The worksheet opens. At the 
moment the worksheet shows 
all the sprinklers. You can 
make the worksheet smaller 
by summing all the same 
types of sprinkler. 

• Click on row 2, the one with 
the diamond. 

• You will see three icons 
above column A. 

• Click and drag the SUM icon 
to the column for the spray 
pattern. 

• Release the mouse button. 
You will notice all the same 
spray patterns are summed. 

With all the sprinklers summed 
together, we still want to know 
how many of each sort there 
are. We can count these. 

• Copy and paste the text from 
one cell to the last cell at the 
top. This keeps all the format-
ting consistent. 
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• Change the text to Number. 

• Click on the green tick.

• Click in the next cell down. 
• Type in an = sign.

• Click to the Worksheet menu.
• Choose Paste Function...

• Choose the Count function.
• Click on the OK button.  
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• Click on the Green tick.

• The worksheet will count 
your sprinklers. 

• Go to the Menu Bar.
• Choose Tools > Reports > Create 

Report...

This dialog box allows you to 
choose how the report will be 
made.  
• Name the Report. This will 

become the name of the 
worksheet. 

• Click on the Records pop-up 
menu.

• Choose your connector or 
junction record.
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• Remove fields you do not 
want. 

•  Drag the ID field to the top 
of the list. 

•  Click on the Options... 
button.

• Click on the option to Ap-
pend to Existing worksheet.

• Click on the pop-up menu to choose your 
worksheet. In this case I called my worksheet, 
Schedule of Quantities. 
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• Click on the OK button. 

• Click on the OK button. 

• The report is added to your 
worksheet. 
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• Click on the Database header. 

• Drag the sum icon to the  
column you want to use. 

• The connectors are summed. 

• Copy the Number cell from 
the top of the worksheet.
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• Click in the cell for the 
connectors, where you want 
to place the title for the 
counting. 

• Go to the Menu Bar.
• Choose Click on the OK 

button. , or use the keyboard 
shortcut (command+V or 
control+V). 

• Copy the counting formula 
cell from the top of the 
worksheet.

• Click in the cell for the 
connectors, where you want 
to place the counting formu-
la. 

• Go to the Menu Bar.
• Choose Click on the OK 

button. , or use the keyboard 
shortcut (command+V or 
control+V). 
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• Select two rows at the bot-
tom. You can do this by 
dragging your mouse down 
the two rows you want to 
select. 

• Click on the worksheet menu 
(the down turned arrow).

• Choose Insert > Rows.

•  Type in a title for counting 
up the irrigation pipes. 

• Hit the Return or Enter key.

cadmovie459

• Click on the worksheet menu 
(the down turned arrow).

• Choose Paste Function...

http://learn.archoncad.com/?p=3398
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• Choose Length. This will only count up the 
length of lines or walls. So we will have to make 
a calculator for polylines and polygons as well. 

• Click on the OK button.

• The function is there, and we 
need a criteria to look for 
information. 

• Click on the worksheet menu 
(the down turned arrow).

• Choose Paste Criteria...
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• If you see this dialog box, click on the 
Custom... button. 

• This is where you choose the 
filter for the objects. 

• The layer is fine. 

• Click on the More Choices 
button. 

• This new line allows you to 
refine the filter, or criteria. 

• Click on the last pop-up 
menu.

• Choose Line from the list of 
options. 
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• Click on the More Choices 
button. 

• Click on the first pop-up 
menu.

• Choose Class. 
• Click on the last pop-up 

menu.
• Choose the class for the first 

irrigation pipe. 

•  Click on the OK button.

• In this case, my  lengths are 
reported in mm. You can add 
a calculation to report the 
lengths in any format you 
like. 

• Click on the green tick to 
accept.
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• Move Across to the next field. 
• Click on the worksheet menu (the down turned 

arrow).
• Choose Paste Function...
• Choose Perim. This will find the length of a 

polygon or polyline. 
• Click on the OK button.
• Click on the worksheet menu (the down turned 

arrow).
• Choose Paste Criteria...

• Ensure the correct layer is 
selected.  

• Click on the More Choices 
button. 

• Choose Type is Polygon. 
• Click on the More Choices 

button. 
• Choose Class is.
• Click on the last pop-up menu.
• Choose the class for the first 

irrigation pipe. 
•  Click on the OK button.
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• In this case, my  lengths are 
reported in mm. You can add 
a calculation to report the 
lengths in any format you 
like. 

• Click on the green tick to 
accept.

• Make the same function for 
polylines in the next cell.

• Make a calculation that adds 
up the lines, polygons and 
polylines. 

• Use the same technique to 
calculate the lengths of all 
your pipe work. 


