
Workshop Topic 
 
Creating Construction Details
I have seen many tips and tricks on 
creating drawings, but not many on 
creating construction drawings. 
When I was writing the last manual 
on creating drawings, I wanted to 
cover creating construction details, 
but I felt that would have made the 
manual too long. 

So how do you create details? That is 
what we will be covering. We will 
need components to assemble into 
details. These could be pieces of 
timber, flashings, weatherboards 
(siding), fixings, hatching, and so on. 
Where do you make this stuff and 
where should you store it?

Extended Podcast 082
How to create 3D text for logo, 
animations and presentations. I also 
thought it might be fun to create 3D 
text that follows a curve.

Extended Podcast 083
How to export a site plan to a 
surveyor. I’ve just helped a client a 
client to do this  with a file that had a 
few issues. 

Beginnercast009
There are several ways to change the 
length of a line. We can look at a few 
different, but simple ways to do this. 

S h o r t  S h a r p  T r a i n i n g  0905	

Welcome to this issue of the VectorWorks online user group. This manual is designed to work like a user 
group meeting. There is a main workshop topic, then a page of general questions and answers, extended 
movies showing tips or techniques and an area for beginners. 

http://learn.archoncad.com/?p=2665
http://learn.archoncad.com/?p=2666
http://learn.archoncad.com/?p=2667
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I’ve seen a lot of tutorials about drawings, using viewports and so on, but very 
few tutorials about drawing your construction details. Someone even said it was 
brave of me to attempt this. 

This tutorial is not going to teach you the construction aspects of detailing for 
your part of the world, so I will not be worrying too much about vapor barriers, 
cold bridges, building standards and so on. This tutorial is about how to use 
Vectorworks to assemble your details. 

Detailing in Vectorworks is quicker if you have some symbols already made - 
like flashings, timber objects (lumber), bolts, steel components and so on. I do 
not want to spend a lot of time on making these symbols, because that would take 
the whole manual. And there are other manuals that have covered creating 
symbols and making your library. 

We will look at some of the Vectorworks settings to see how to make Vector-
works easier to detail. 

We will look at a few different techniques for detailing:

•	 Using BIM for detailing, by using section viewports. 
•	 Using 2D sections for creating details.
•	 Drawing 2D details separately.
•	 Importing details from a manufacturer.
•	 Saving details to a library.
•	 Using details from a library. 
We are going to talk about construction detailing. When you create construction 
details, you should look at the layers and classes you need.

You should use a layer of each scale you want. So if you want to have some 
details at 1”:1’ (1:10) and some details at 2”:1’ (1:5), you should use 2 layers. 
There are ways around this with viewports, but it really is easier to use a layer for 
each scale.

C r e a t i n g  C o n s t r u c t i o n  D e t a i l s

Generally, you do not need many classes for details. I always say that you should 
not have classes without a good reason. The two main reasons are visibility an 
graphic control. If you are drawing 2D details, you do not need to control visibility 
in your details very often, but you could easier use classes to control the line 
weight and line style for your details. 

Using BIM For Detailing
If you put a lot of effort into creating a 3D model, you can use your model  to start 
your details. For example, you can use the wall framer to add the timber structure 
to your walls, you can add floors and walls to create the foundations, but Vector-
works will not add the really important stuff like bolts, flashings, vapor barriers, 
notes, and dimensions to your details. 

So the question is, should you bother? The answer depends on what you want to 
achieve. If you want a quick start to a detail, then it might be worth it, and if you 
want reasonable sections through your buildings, it is really worth it. 

cadmovie313

I’m going to show you a simple 
building, but the principles are 
the same for a larger building. If 
you want a section through your 
building, you have to draw the 
3D parts of the building. There is 
no way around this. 

http://learn.archoncad.com/?p=2668
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I have drawn a slab using a Floor 
object.

And finally, I have used the wall 
framer to create the timber 
structure for the walls. I used a 
wall style to start the walls, and 
used a custom offset to get the 
timber walls 1/2” offset from the 
slab.  

•	 Change to a Top/Plan view.

I’ve drawn foundation walls 
using a wall style. This draws the 
walls the correct height and 
width. 

I’ve drawn footings using a wall 
style. This draws the walls the 
correct height and width, but I 
had to manually move the footing 
to the correct height (to get the 
footings below the foundation 
walls. 

When you look at the complete 
building, all the 3D components 
have to join together with the 
correct relationships. In other 
words, you have to invest some 
to time the get the 3D model 
right. You should do this before 
you use the 3D model for 
detailing, but it is not essential. 

cadmovie314

http://learn.archoncad.com/?p=2677
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•	 Go to the Menu Bar.
•	 Choose View > Create Section 

Viewport...

•	 Click just outside the Footing 
to start.

•	 Move your cursor to just 
inside the footing.

•	 Click once.
•	 Move your cursor to the left.
•	 Double click.

•	 The Create Section Viewport 
dialog box will open.

•	 Name the detail.

•	 Choose a sheet layer, or create a 
sheet layer for the detail. 
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•	 Change the Scale to suit. •	 Click on the OK button

•	 Click on the Render Settings... button. 
Make sure you turn off the Sketch Hidden Line 

results, otherwise you will have hand-drawn 
details. Of course, if you want hand-drawn looking 
details, leave this turned on. 

•	 The Smoothing Angle is useful on curved 3D 
objects. Setting a higher smoothing angle will 
remove many of the vertical lines you sometimes 
see on rounded objects.

•	 Click on the OK button

•	 Click on the Advance Section Properties... 
button. This is where you change your section 
from a full section of the building to a detail. 

•	 Set The Length Range to Limited by Section 
Line Length. If you have drawn the section line 
the correct length, we will end up with a small 
detail of the foundation wall. 

•	 Set the Depth Range to Finite, with a depth of 3’ 
(900mm).

•	 Set the Height Range: 
End Height : 6” (150mm). 
Start Height : -3’ (-900mm).

•	 Click on the OK button.

There is the detail on the drawing. 
Notice that it has no detail and no 
notes. You can add the dimen-
sions, missing parts and notes in 
the annotation part of the 
viewport.

•	 Right mouse click on the 
detail.

•	 Choose Edit Annotations.

cadmovie315

http://learn.archoncad.com/?p=2678
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Now you can see the inside of the 
viewport. This is the area for you 
to add notes, dimensions and 
extra information. 

•	 Go to the Resource Browser. 
•	 Make sure your Resource 

Browser is looking at the 
correct file, 0905.

•	 Double click on the timber 
symbol.

If you zoom in you can see what 
Vectorworks has drawn.

•	 Double click to place the 
timber symbol. 

cadmovie316

•	 Go to the Basic toolset.
•	 Choose the Rectangle tool.

•	 Move into the drawing area. 
•	 Move to the bottom left of the 

wall. 

http://learn.archoncad.com/?p=2679
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•	 Use the rectangle tool to draw 
drywall (gib board) wall 
lining. 

cadmovie317

•	 Go to the Detailing toolset.
•	 Choose the Repetitive Unit tool.

•	 The siding (weatherboard) we 
need is in the exercise file. 

•	 Go to the Category pop-up 
menu.

•	 Choose Current Document. 

•	 Choose the Linea w’bd 
symbol.

•	 Click on the OK button to 
return to the Object Properties 
dialog box.

•	 Go to the Tool Bar.
•	 Click on the Preferences 

button, the last button. 
•	 Click on the Choose Symbol... 

button. 

•	 Turn off Use Symbol Pitch.
•	 Enter the symbol pitch 151mm. 

This needs to be exactly 
151mm, otherwise the weather-
boards will not overlap 
correctly. 

•	 Click on the OK button.

http://learn.archoncad.com/?p=2690
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•	 Move to the bottom of the 
timber wall. 

•	 Click once to start.
•	 Move vertically up. 

Using 2D Sections
cadmovie318

•	 Go to the Detailing toolset.
•	 Choose the Batt Insulation 

tool.

•	 Go to the Tool Bar.
•	 Click on the Preferences 

button, the last button. 

•	 Move just above the top of 
the wall. 

•	 Double click to stop.

The Repetitive Unit tool puts in 
as many weatherboard symbols 
as possible. It does not cut the 
symbols. If you want to do that 
you have to ungroup the weather-
boards. 

•	 Fill in the settings to suit the 
wall.

•	 Click on the OK button. 

•	 Click on the inside face of the 
wall. 

http://learn.archoncad.com/?p=2695
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•	 Move to the top of the wall. 

•	 Click once. This will stop the 
Batt Insulation tool. If you 
want to use the Batt insulation 
tool on a curved detail, you 
will have to use several small 
bits of insulation. 

•	 Place a small circle for the 
first reinforcing bar. 

•	 Copy the circle to make the 
second reinforcing bar.

cadmovie319 

•	 Go to the Basic toolset. 
•	 Choose the Circle tool.

•	 Copy the circle to make the 
third reinforcing bar.

•	 Draw a vertical line for the tie 
bar.

http://learn.archoncad.com/?p=2696
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•	 Draw a horizontal line for the 
tie bar. Stop each end in line 
with the center of the 
reinforcing bars.

cadmovie320

•	 Go to the Basic toolset. 
•	 Choose the Circle tool.
•	 Go to the Tool Bar.
•	 Click on the third mode, Arc 

by tangent.

•	 Click on the end of the tie bar 
line to start. 

•	 Move out horizontally.
•	 Click once. This sets the 

tangent line. 

•	 Move above the center of the 
reinforcing bar. 

•	 Click once to stop.

•	 When you draw the other arc, 
use the first one as a guide to 
line them up. 

The detail looks like it is floating 
in space. We can add some 
hatching to make the detail look 
better. 

http://learn.archoncad.com/?p=2697
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•	 Go to the Basic toolset. 
•	 Choose the 2D Polygon tool.
•	 Place an area of polygon. The 

flat top will be the top of the 
soil, the rest will have the 
hatching fade out. 

•	 Go to the Attributes palette. 
•	 Use a heavy line for the outside.
•	 Use a soil hatch for the inside. 
•	 Go to the Basic toolset. 
•	 Choose the 2D Reshape tool.

•	 Go to the Tool Bar.
•	 Click on the fifth mode, hide 

or show edges.

•	 Click on all the sides you 
want to hide. 

•	 Send your hatch to the back. 
•	 Right mouse click on the 

hatch, choose Send > Send to 
Back.

•	 Move to the handle on the 
middle of a side you want to 
hide. 

•	 Click once.

•	 Draw a rectangle for the 
Hardfill under the slab.

•	 Use the Attributes Palette to 
assign the hard fill hatch, and 
remove the line. 

http://learn.archoncad.com/?p=2700
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•	 Go to the Basic toolset. 
•	 Choose the Callout tool.

•	 Go to the Tool Bar.
•	 Click on the last mode, the 

callout preferences. 
•	 Set the callout preferences to 

suit your drawings style. I like 
using Get Text from Database. 
This allows me reuse text 
from project to project.

•	 Click on the OK button.

•	 The next click is the end of 
the shoulder, where the line 
changes direction.

•	 The last click is for the end of 
the arrow, the object on the 
detail.

•	 The Notes Manager : Callout 
dialog box opens. This is 
where you choose your notes 
from the database. 

•	 I have a database with several 
sections (categories) and each 
session has several notes in it. 
As I work from one project to 
the next, I can save the notes 
in the database. 

•	 If you have a database, choose 
the note you want. 

•	 Click on the Update button.
•	 Click on the OK button.

•	 If you have set your callout 
modes the same as me (see 
image above), the first click is 
the start of the note. 

http://learn.archoncad.com/?p=2709
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•	 Vectorworks places your note 
on the drawing. 

•	 Use the Callout tool to place 
another note. 

•	 Notice how quick it is to 
place the notes when they are 
in your database. 

•	 Your finished detail. 
You can add more information to 
the detail. You can could add 
dimensions, notes, and more 
hatching, but I hope you get the 
general idea.

The challenge for me with this detailing is that this is that all the objects are 
touching each other. When I used to draw details before CAD , we would explode 
the details slightly to make the details more readable. So, for me, these details are 
below the standard I want. 

•	 Click on the Exit Viewport 
Annotation button on the top 
right of the drawing area. 

cadmovie323

This method can work well for a 
complete section through a wall. 
But there is a question of drawing 
philosophy. How do you want the 
drawings to look?

http://learn.archoncad.com/?p=2710
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I prefer this look, but not 
everyone does. I have some 
clients that think this drawing is 
too detailed. 

If you edit the annotation of the 
viewport you can add infor-
mation, exactly as we did for the 
other detail. 

•	 Go to the Tool bar. 
•	 Click on the Preferences button. 
•	 Fill in the preferences to suit 

your drawing style. 
•	 Click on the OK button.

•	 Click to start the benchmark. I 
click on the detail first.

•	 Move across to the left.•	 Go to the Dims/Notes Tool set. 
•	 Choose the Elevation 

Benchmark.
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•	 Click once. 
•	 Go to the Object Info palette 

to fill in the name for the 
benchmark.

Notice the height of the 
benchmark. That can’t be right. 
It’s not. There is a control point 
we need to move. 

•	 Zoom out. There is the control 
point, in the middle of the 
wall. 

•	 The benchmark now has the 
correct height. 

•	 Go to the Object Info palette. 
Notice the place where you type 
in the name of the benchmark.

•	 This is where you choose the 
style, and the Automatic 
settings. 

•	 If you turn off the Use Control 
point, Vectorworks can create 
errors when you move the 
section up or down the page.

•	 Use the 2D Selection tool to 
click on the control point.

•	 Move to the top of the slab. 
•	 Click once. 
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•	 But, turning off the control 
point makes it a lot quicker to 
place the benchmarks.

•	 You can place benchmarks 
directly without having to 
adjust the control points.

•	 Just watch out when you 
move a section. Notice the 
benchmarks have changed 
their heights. This could lead 
to some terrible errors.

Using BIM to Create a 2D Section

cadmovie324

•	 Change back to the 3D Model 
for Details layer. 

•	 Change to a 3D View. You 
will see a building with walls, 
foundation and a roof.

We will be using a model command, 
but Vectorworks only have this 
command in the Standard 
Workspace. If you are going to use 
this a lot, add it to your main 
workspace. 

•	 Change to the standard 
workspace.
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•	 Change to a Top/Plan view.

•	 Go to the Menu bar.
•	 Choose Cut 3D Section.

•	 Click to start. You don’t really 
have to be outside your 
model, the cut will go through 
everything. 

•	 Move vertically down the 
screen.

•	 Click once.

•	 Move your mouse to the side 
you want to keep.

•	 Click once.
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•	 There is the 3D section.

•	 Vectorworks cuts your model 
and places it on a new layer. 
The old model is left in tact.  

•	 Go to the Menu Bar.
•	 Choose  Modify > Convert > 

Convert to Lines...

•	 Vectorworks makes the 3D 
model into a group of lines.

•	 Change to a view that looks 
directly into the model.

•	 If you ungroup this, you will 
see there is are several lines. 



©Jonathan Pickup - http://www.archoncad.com	 SST_0905

Page 19

•	 Zoom in and you can see the 
lines.

cadmovie325

You can use the all the 2D 
drawing tools in your arsenal to 
add timber, details, notes and 
dimensions. 

•	 If you draw the slab, or the 
finished  floor at 0, then you 
can use the Elevation 
benchmark tool to add the 
benchmarks. 

•	 Name the benchmarks to 
make them useful.

This is how I like to draw my 
sections.

•	 If you use the auto set 
method, it becomes easier to 
draw the benchmarks.

http://learn.archoncad.com/?p=2720
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•	 If you draw your sections to 
this level of detail, you can 
use a part of the section to 
create a detail viewport. 

•	 Define the Area for the 
viewport with a rectangle. 

•	 Go to the Menu Bar.
•	 Choose  View > Create Viewport...
•	 Name the viewport.
•	 Set the correct scale. 
•	 Choose the Sheet layer.

•	 Click on the OK button. 

•	 Move your detail to the 
correct location. 

•	 Return to the Section layer. 
Zoom into to the sill of the 
door. 

•	 Draw a rectangle to define the 
area for the window detail.

http://learn.archoncad.com/?p=2725
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•	 Go to the Menu Bar.
•	 Choose  View > Create 

Viewport...
•	 Name the viewport.
•	 Set the correct scale. 
•	 Choose the Sheet layer.
•	 Click on the OK button. 

•	 Move your detail to the 
correct location. 

Drawing 2D Details Separately

cadmovie327 

There are times where you don’t have a 3D model of the building, or you complete 
section you can use. Sometimes you just want to draw a detail. 

So, when you draw details, what are the quick ways you can use to speed up the 
process? You can speed up drawing details by using symbols for the detail 
components, import an existing symbol and edit the detail to suit. 

•	 Starting with a blank file, or a 
blank layer, create a rectangle 
for the start of the footing. Like 
a building, I always start the 
detail at the foundation.

This is a detail I want to draw. 

http://learn.archoncad.com/?p=2726
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•	 Create a small rectangle, just 
2” (50mm) high and 7.5” 
(190mm) wide. This will 
create a lip for the blockwork 
(CMU) to sit on.

•	 Create another rectangle for the concrete slab. 

•	 Setting the options on this 
dialog box will make it easier 
to place the rectangle. 

•	 Select  all the rectangles. 
•	 Right mouse click, and 

choose Add Surface. If you 
are using Vectorworks 12, you 
will need to go to the Modify 
menu to find this command. 

•	 For me, this is an easy way to 
create a complex shape. 

•	 If you set the options on the 
create object dialog box 
correctly, you can use the first 
object to place the second 
easily. 
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•	 Use the Attributes Palette to change the 
foundations to a heavy line with  concrete 
hatching. 

•	 The hatching is in this 
exercise file.

cadmovie328 

•	 Create rectangles to create 
enough information for a 
concrete block (CMU). 

•	 Select all the parts.

•	 Go to the Menu Bar.
•	 Choose Modify > Create 

Symbol...

•	 Name the symbol so you can 
find it easily. 

•	 Leave the instance in place. 
This will leave the symbol on 
the drawing. If you don’t turn 
this option on, you will  lose the 
object on the screen.

•	 Set the insertion point to Next 
Mouse Click. This will allow us 
to check select the insertion 
point of the symbol, making it 
easy to place the symbol.  

http://learn.archoncad.com/?p=2727
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•	 Move to the bottom left 
corner of the group. I’ve 
made a small rectangle for the 
mortar, so I would use the 
bottom left of the mortar. This 
will allow me to join the 
blocks, one on top of the 
other. 

•	 Go to the Basic tool set. 
•	 Choose the 2D Insert Symbol 

tool.

•	 Move to the top left corner of 
the existing symbol. 

•	 Place as many as you need to 
make the wall high enough.

cadmovie329

•	 Make sure nothing is selected. 
•	 Change the settings on the 

Attributes Palette. We want to 
place reinforcing steel. A black 
circle will be good for this. 

•	 Double click to place the 
symbol. 

•	 Double click on the circle tool. 
•	 Set the options to make a small 

circle. 
•	 Click on the OK button. 

http://learn.archoncad.com/?p=2728
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•	 Click once.

•	 This places the circle. 

•	 Drag a copy of the circle 
across to the right. You can 
use the option key on the 
Macintosh, or the control key 
on a Windows machine. 

•	 Make 3 circles. You don’t 
have to have them lined up, 
and they don’t have to be 
evenly spaced.

cadmovie330

•	 Select all the circles.

•	 Go to the Menu Bar.
•	 Choose Modify > Align > 

Align/Distribute...
•	 Set the options to align the tops, 

and distribute the centres. 
•	 Click on the OK button. 

http://learn.archoncad.com/?p=2738
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•	 Notice the circles are all lined 
up and evenly spaced. Some 
people think my way of 
drawing looks sloppy until it’s 
finished. I find it easier to 
draw sloppy, then use Vector-
works to fix it. 

cadmovie331

•	 Go to the Detailing toolset. 
•	 Choose the Linear Material tool. 

•	 Click at the bottom of the 
block wall to start.

•	 Move up to the top corner.
•	 Click once. 

•	 Move to each corner and 
click.

•	 Go to the Tool bar. 
•	 Click on the Preferences button. 
•	 Put in the settings you want for the 

plaster finish on the blockwork. 
•	 Click on the OK button. 

http://learn.archoncad.com/?p=2739
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•	 Double click to stop. 

cadmovie332

•	 Draw a heavy line for the 
extent of the seating. I use this 
as a guide line. There a few 
ways to get the line in the 
correct location. You can draw 
it a move it, or you can use 
the floating datum to get it in 
the correct location. 

•	 Draw a rectangle for the front 
piece of timber. The timber 
needs to be 6” (150mm) high 
and 1.5” (35mm) wide. 

•	 Double click on the rectangle 
tool. 

•	 Set the rectangle height and 
width to 1.5” (35mm).

•	 We can use Position at Next 
Click with the floating datum to 
position the rectangle 
accurately. 

•	 Click on the OK button.

•	 Move to the top right of the 
timber at the front edge. 

•	 Hit the G key on your 
keyboard. DO NOT CLICK.

•	 Hit the TAB key until you get 
to the X field on the data 
display bar. Vectorworks 2008 
and 2009 have the data bar 
floating next to the cursor. 
Earlier versions of Vector-
works have the data bar above 
the mode bar. 

•	 Type in the gap we need, 1” 
(25mm).

•	 Hit the Tab Key once. 

•	 Click once to place the 
rectangle. You can leave the 
rectangles as they are, but 
with a little effort you can 
make them look more like 
timber. 

http://learn.archoncad.com/?p=2740
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•	 Cross lines, and rounding the 
edges make a difference. You 
add a wood screw from the 
Detailing tool set (Vector-
works 2009 only).

•	 Rounding the edges of the 
rectangles is easy with the 
fillet tool.

•	 Select the timber, and wood 
screw if you added it. 

•	 Go to the Menu Bar.
•	 Choose  Edit > Duplicate 

Array... 

•	 You should find this a quick 
way of making duplicates. 

•	 Another way to draw the 
timber is to use a symbol. 
Once you have drawn the 
timber and screw, you can 
make them into a symbol. 

•	 You can then use the 
Duplicate Array... command, 
to place the timber objects. 

•	 When you use symbols, you 
can edit the symbol definition 
to change the line weights and 
line colors.

•	 When you exit the symbol, all 
instances of the symbol are 
updated. 

•	 You can even set up the 
symbol with the gap as part of 
the symbol. 

cadmovie333

•	 Fill in the settings. I use the 
linear array in this situation. 

•	 The distance can be typed in 
as a formula, 1”+1.5” 
(25mm+35mm).

•	 Click on the OK button.

http://learn.archoncad.com/?p=2749


©Jonathan Pickup - http://www.archoncad.com	 SST_0905

Page 29

•	 The polygon for the 
foundation shows a closed 
end, it needs to show an open 
end.

•	 Go to the Basic tool set.
•	 Choose the 2D Reshape tool.

•	 Go to the Tool bar.
•	 Choose the fifth mode, to 

hide or show edges. 

•	 Click on the edge of the 
polygon. The line on this side 
will turn off.  

•	 Start on the left hand side and 
below the re-bar. 

•	 Click to form a U shape 
around the top of the re-bar. 

•	 Come down the block wall.
•	 Click at the bottom of the 

reinforcing. 

cadmovie334

•	 Go to the Basic tool set.
•	 Choose the Double Line Polygon tool. 

•	 Go to the Tool bar.
•	 Choose the third mode, to 

hide or show edges. 

•	 Click on the last mode, the preferences. Fill in the separation as 1/2” 
(12mm), the thickness of the reinforcing bar. 

•	 Move across to the left.
•	 Draw a U shape around the 

last re-bar. 

http://learn.archoncad.com/?p=2752
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•	 You should have a complete 
tie bar in elevation.

•	 Zoom in to the top re-bar.
•	 Go to the Basic tool set.
•	 Choose the 2D Reshape tool.
•	 Click on the second mode, 

change vertex type. 
•	 Click on the ninth mode, fillet 

point mode.
•	 Set the Fillet Preferences to 

1/4” (6mm).
•	 Click on the first corner. 

•	 Click on the second corner. 
•	 Change the fillet preferences 

to 3/4” (18mm). 
•	 Click on the outside corners. 

•	 Edit the corners at the other 
end as well. 

•	 If your reinforcing is not long 
enough, you can use the first 
mode on the mode to edit one 
part.

•	 Add a polygon for the soil.
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•	 Assign the hatching for soil. 

•	 Add the dims and notes.

Importing Details From A Manufacturer

cadmovie335

There are several web sites that 
have details you can use. Usually 
you will have to register before 
you can access the details. 

I often find the details are hidden, 
so you have to look for them in 
sections like Technical, speci-
fiers, or details. 

When you finally get to the 
details, you might see something 
like this. It may be obvious, but 
to access these details, you have 
to click on the detail you want.

For this particular web site, you 
get a further window. This 
window is displaying the 
download options. 

http://learn.archoncad.com/?p=2753
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When you click on the drawing 
type you want, they detail will 
start to download. 

This web site has Vectorworks  
drawings, which is handy. You 
don’t have to import them from 
DWG/DXF. 

The details download and are 
stored in the same folder as your 
other downloads. 

Generally the web site will be 
using a old Vectorworks format 
to suit as many Vectorworks 
users as possible.

When you open the file, it might 
have a message about converting 
the file. 

If you do not want the symbols, 
then convert them to groups. This 
will stop you being able to use the 
details directly from the Resource 
Browser, but you can make them 
back into symbols later.  

•	 Edit the details to suit you. 
Add extra cladding, change 
the line weights and so on.

This web site makes the details 
into symbols. This can work really 
well, because you can access the 
details from this file using the 
Resource Browser. 

•	 Select everything for the 
detail.
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•	 Go to the Menu Bar.
•	 Choose  Modify > Create 

Symbol...

•	 Name the symbol. 

Give it a name that makes sense. I 
used to call my foundation details 
Foundation 1, Foundation 2 and so 
on. After seven details, I can’t 
remember which is which. When I 
name them, Slab Edge, Garage 
Door Edge and so on, I can find 
them more easily. 

Now you’ve made it back into a 
symbol you can use it from the 
Resource Browser.

cadmovie336

Sometimes, the files you want to 
download are not in Vectorworks 
format. In this case look for DXF 
or DWG files. 

•	 You can download these files.

•	 Use the Next Mouse Click for 
the insertion point. That way 
you can choose an insertion 
point that suits you. A point 
on the barge board, or the 
wall line can work, but the 
middle of the detail will not 
work.

http://learn.archoncad.com/?p=2765
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•	 Store them all in a new folder, 
so that only these downloaded 
files are in that folder. 

•	 Start a new Vectorworks 
drawing.

•	 Go to the Menu bar.
•	 Choose  File > Import > 

Import DXF/DWG...

•	 Click on the option to Choose 
Folder...

•	 Choose the folder with all your 
downloaded files. 

•	 Set your custom options to suit.
•	 Click on the OK button to start. 

Vectorworks imports one file 
after the other.

When they are completed, you 
get a report on the success.

Normally you will get a series of 
design layers (the ones at the 
bottom) and sheet layers (the 
ones at the top). 

Only the design layers are of 
interest. Each detail will normally 
be on a separate design layer. 

Tidy up the details to sit your 
drafting style. 
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There is one more way to import 
details for your projects, that is to 
import a PDF file. The example I 
will use is a technical manual 
from the manufacturer, James 
Hardie. I’ve downloaded the 
technical manual for Linea 
Weatherboards, you can use any 
PDF file that has technical details.

•	 Open the PDF manual.

•	 Find the pages with the details 
you want. If there are a lot of 
pages, write down the page 
numbers.

•	 Go back to Vectorworks.
•	 Go to the Menu Bar.

•	 Choose  File > Import > 
Import PDF...

•	 Locate your PDF file. 

•	 Enter the page numbers you 
want to import.

•	 Vectorworks will import the 
pages. You should get a 
progress bar showing you 
how the import is working. 

http://learn.archoncad.com/?p=2768
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•	 Vectorworks imports the 
pages as separate objects. 

•	 Move the pages so they line 
up. Don’t worry about staying 
inside the printable area, you 
can make viewports from the 
parts you want. 

•	 Draw a rectangle over the 
area you want to viewport. 

•	 Go to the Menu Bar.
•	 Choose  View > Create 

Viewport...
•	 Fill in the setting to suit. I’ve 

used a 1:1 layer for the 
imported layer. I’m not sure that 
it matters, because the details 
on the pages could be at several 
scales. If you know the scale of 
the details in the technical 
manual, then use that scale. 

•	 Click on the OK button.

•	 Move your viewport on the 
sheet layer to suit your 
drawing.
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Using Details From Your Library
There are at least two ways to use the details from your library. If you make your 
details into symbols, you can use the Resource Browser to import your details 
from your library into your current project. You can use Workgroup Referencing 
to import the complete layer of symbols. 

•	 Go to the Resource Browser.
•	 Locate the symbol you want to use. You must use 

the Resource Browser to add your library as a 
Favorite file, that will give you quick access to 
the details. 

•	 Click and drag the detail you 
want. 

•	 Choose where you want the 
detail to be. 

•	 When you release the mouse 
button, Vectorworks will 
import the symbol. 

•	 Go to the Resource Browser.
•	 Locate the next symbol you 

want.

Using the Resource Browser
cadmovie338

With this method, you MUST make 
your details into symbols, 
otherwise they will not appear in 
the Resource Browser. 

•	 Start with the layer where you 
want the details. 

http://learn.archoncad.com/?p=2769
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•	 Drag the detail into the 
drawing area. I like to make 
sure the details line up, using 
the smart points. 

•	 When you release the mouse 
button, Vectorworks will 
import the symbol. 

Using Workgroup Referencing
This method allows you import a whole layer from your library. You could draw 
all your details on one layer. 

Think about drawing all your foundation details one layer.. If you imported this 
layer into your current drawing, you would be able to choose any of these details 
to place on your foundation drawing. 

cadmovie339

You could draw all your cladding 
details for a cladding type on one 
layer and import that. 

•	 Go to the Menu Bar.
•	 Choose  Tools > Organi-

zation...

•	 Change to the References tab.

This method works well, but you have to make the details into symbols. When 
you make the symbol, you can set the insertion options so that the symbol 
automatically converts to a group. This would allow you edit the detail without 
upsetting any other instances of the same symbol.

The other thing to think about is, when you import a symbol using the Resource 
Browser, it will not update automatically from the library. 

http://learn.archoncad.com/?p=2770
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•	 Click on the Settings... button.
•	 Use Layer Import.
•	 Click on the OK button.

•	 Click on the New... button
•	 Choose the library file. 
•	 Choose the layer you want to 

import, by clicking on the tick 
next to the layer name. 

•	 If you turn on the Automatically 
update out of date references 
during file open, then every 
time you open this file, Vector-
works will automatically update 
your details. If the details get 
updated in the library, you will 
always have the latest version.

•	 This option should be on until 
you get to tender stage 
(pricing). After that, turn this 
off. 

•	 Click on the OK button.

•	 If you have a conflict with 
hatches, you will get this 
message.  

•	 Click on the OK button.

•	 If you have a conflict with 
symbols, you will get this 
message.  

•	 Click on the OK button.

•	 If you have a conflict with 
names of objects, you will get 
this message.  

•	 Edit the name.
•	 Click on the OK button.



©Jonathan Pickup - http://www.archoncad.com	 SST_0905

Page 40

•	 The file is linked.
•	 Click on the OK button.

•	 When you check your list of 
layers, the new layer is shown 
at the bottom. Vectorworks 
shows the name in italics so you 
know the layer is referenced. 

•	 You can see all the details on 
the layer. 

•	 Use the rectangle tool to make 
a crop object, then make a 
viewport for the detail. 

•	 Name the detail, choose the 
layer.

•	 Click on the OK button.
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•	 Move the detail on the sheet 
layer. 


