
Workshop Topic 
 
Creating Drawings for a Building 
Project
In the past the user group has 
covered layers, classes and view-
ports. The feed back I am getting is 
that this is still an area that people 
are confused about. 

When should you use a class, when 
should you use a layer?  How do you 
create drawings from the stuff you 
create on the design layer. 

I have created a drawing with 
enough information to create a set of 
contract documents for a simple 
building project. We will learn how 
to create the drawings from this 
information. We will use viewports 
and sheet layers to create our 
drawings.  

Extended Podcast 080
I was showing one of my clients 
haw they can make plants for 
concept and construction plans, 
without having to re-draw the plants.

Extended Podcast 081
I read of this trick the other day on 
the Vectorworks Community Board. 
It’s a way of renumbering all your 
symbols using a worksheet. 

Beginnercast008
How to use Cut, Paste and Paste in 
Place. 

 

S h o r t  S h a r p  T r a i n i n g 		 0 9 0 4 	 	

Welcome to this issue of the VectorWorks online user group. This manual is designed to work like a user 
group meeting. There is a main workshop topic, then a page of general questions and answers, extended 
movies showing tips or techniques and an area for beginners. 

http://learn.archoncad.com/?p=2608
http://learn.archoncad.com/?p=2609
http://learn.archoncad.com/?p=2610
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It seems that Vectorworks users always have questions about using layers, 
classes, viewports and sheet layers to make drawings. The user group has 
covered this in the past, but as it was 2 years ago, it seems to be a good idea to 
cover this topic again. At last month’s user group meeting several people 
wanted this topic covered again. 

First we should look quickly at layers and classes. Many people struggle with 
these concepts and they often confuse them. Layers and Classes are not inter-
changeable. You can sometimes use layers or classes to create your drawings, 
but it still not make them interchangeable. 

What are layers for?
•	 Used to Control visibility
•	 Used to break the file up into manageable chunks (storeys of the building)
•	 Use to make layers of different scales.
We use layers as an organizational tool to break up the design into usable 
chunks.  Layers are used to control the visibility of parts of the drawing so that 
we can hide or show information for different purposes.

Layers area a horizontal organizing method where you can divide your file up 
into horizontal chunks.  Theses horizontal chunks also have a height and if you 
set the heights up correctly you can easily generate 3D views of the model.

If you were an architect you would tend to break up the design into stories of 
the building.  You would also have several layers that contained 2D drawings 
and details that made up the document set.

If you were a landscape architect then you would tend to break up the design 
into elements based on the type of construction.  You may have the building on 
one layer, the planting on another layer and the groundworks on another layer.  
You would also have several layers that contained 2D drawings and details that 
completed the document set.

C r e a t i n g  D r a w i n g s  f o r  a  B u i l d i n g  P r o j e c t

If you were an engineer then you would tend to break up the design into  a 3D 
model and a series of 2D drawings that showed in detail how the model was 
constructed.

What are classes for?
•	 Used to Control visibility
•	 Used to break the file up into manageable chunks (building elements)
•	 Used to Control graphic quality
•	 Used with Wall Styles to automatically assign walls to a class
•	 Used with Plants to automatically assign part of the plant to different classes. 
•	 Used with symbols to automatically assign symbols to a class
•	 Used with symbols to change the visibility of parts of the symbol
•	 Viewports can be used to overwrite the graphic attributes of classes (look 
different on different viewports)

Classes do not work horizontally as layers do.  When a class is switched to 
invisible every element that is assigned to that class is made invisible, regard-
less of the design layer that it is on or its height in the layer structure, so you 
could say that the classes are a vertical way of controlling information.  

Classes can be switched on or off throughout the design, giving a way of 
controlling the organization vertically.  By using this technique you can easily 
see complex designs in individual parts and create many different views of the 
same design.

If you were an architect you would tend to break up the design into building 
elements, or construction elements, such as furniture, fittings and plumbing 
fixtures.  You would also have several class that controlled information on the 
drawings, such as, foundation details and notes, framing notes and dimensions, 
and so on. 

If you were a landscape architect then you would tend to break up the design 
into elements to control the type of planting, the phase of planting, and so on.  
You may also use classes to control the notes or dimensions so that they appear 
on some drawings and not others. 
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Viewports
A viewport allows you to show a view of design layers. The viewport can be a 
part of the design layer, it doesn’t have to show all the information on the 
design layer (this is called a crop). Each viewport can have a different crop 
shape. 

The view port can be a different scale from the design layer, and you can have 
viewports of different scales on the same drawing (sheet layer). This allows you 
to make complex drawings easily, by combining different parts of the design, 
and having these at different scales. 

When you create a viewport you can choose which layers and classes are visible 
in the viewport. This is a powerful technique and it allows you to create com-
plex drawings. I use this facility a lot, because as well as turning classes on and 
off, you can edit the class settings to change the line weight, line style and so 
on. This lets you create drawings that emphasise certain areas. 

There are two main areas for editing viewports. You can edit the crop object (to 
change the size or shape of the crop), and you can edit annotations. The annota-
tion part of the viewport can be used to add notes and dimensions to the view-
port, and it can be used to add drawn information. For example, if you create a 
section viewport, you can add details of the structure, adding rafter, purlins, 
cladding and window detailing. 

Sheet Layers
A sheet layer is a special layer that is used for printing.  You could think of it as 
a plotting layer.  If you are familiar with AutoCAD you could think of sheet lay-
ers as being like paper space.

I often think of the sheet layer as being like a page layout. You add the view-
ports and title block, moving them around to create the drawing you want. You 
can only view one sheet layer at a time, but you can put as many viewports on 
the sheet layer as you need.

Each sheet layer has its own printable area.  This means that you could set up 
A4 presentation drawings and A1 construction drawings in the same file.

cadmovie304

Open the issue0904 file that 
comes with this manual. If you 
are using Vectorworks 12, 2008 
or 2009, open the file from the 
appropriate folder, and use the 
file with the correct units (metric 
or imperial).

When the file opens you see 
what looks like a very messy 
plan. That is because I have too 
much information shown. Don’t 
worry though, I have used 
classes for each part of the 
building. This allows me to turn 
off parts of the build to make the 
drawings.   

If you zoom out, you will see 
there is  other information on the 
design layer. I often do this, 
where I draw information all 
over the place, then use view-
ports to create drawings from it. 

http://learn.archoncad.com/?p=2620
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If you look at the 3D, you can 
see several parts of the building. 

This project is set up as dis-
cussed, with a layer for each 
floor, and classes for each 
element. 

Site Plan
cadmovie305

We will create a site plan. On the 
site plan we need the site, notes 
and a title block. 

You might be able to see from 
this image, there are several 
parts of the design we do not 
want to see. We can use classes 
for this. 

•	 Make Mod-Level 1 the active 
layer. 

There is too much information. 
We need to turn off some of the 
classes to help us make the site 
plan. 

There is a tool in Vectorworks 2009 that will do this 
easily for you.

•	 Go to the Basic tool set. 
•	 Choose the Visibility tool. 

•	 Go to the Tool bar.
•	 Set your modes to match the 

image. 

When you click on an object 
Vectorworks will turn the class 
of the object invisible. 

Click on all the object you want 
to hide. 

If you have an earlier version of 
Vectorworks, there is a tool you 
can use. I have added the plug-in 
into the exercise folder, but you 
will have to add it to your Vector-
works and add the tool to the 
workspace. 

There are no options with this tool, 
you click on an object and Vector-
works hides the class. 

http://learn.archoncad.com/?p=2623
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•	 Make Mod-Site Plan the active layer.
•	 Turn off all the objects you want to hide.
•	 Go to the Menu bar.

•	 Choose View > Create Viewport...
This dialog box opens. 

•	 Name the Viewport. I always use the 
name that I would put on a drawing 
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label for the viewport. 
•	 Click on the Layers... button. 
•	 Make sure the Mod-Site Plan layer is 

the only one visible.
•	 Click on the OK button. 
•	 Click on the Classes... button. 
•	 All the classes you clicked on are 

invisible. There are other we might 
need to change, but we can change 
them layer. 
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•	 Click on the OK button. 
•	 Click on the Pop-up menu to create a 

New Sheet Layer...

If you have a Class and Layer Standard, 
you can choose the sheet layer from your 
standard. This is a quick way to create 
new sheet layers. Vectorworks will not 
import title blocks, so all you are really 
doing is importing a blank sheet. 

Setting up the class and layer standard is a 
way on ensuring consistency with layer 
and class names. 

•	 Click on the OK button to create the 
new sheet layer.

•	 Click on the OK button to finish 
creating the viewport.

Your viewport is on the sheet 
layer (drawing). 

•	 Zoom into the house plan. 

Notice the things in the drawing, 
like the purlins and rafters. We 
have to edit the classes to turn 
these off. 
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•	 Go to the Object Info palette.
•	 Click on the Classes... button. 

•	 Turn off the classes for the 
rafters and purlins.

•	 Click on the Preview button 
to see the changes. This is 
good technique to make sure 
you are turning off the correct 
parts. 

•	 Look at the Roof classes. The 
roofs are shown solid at present. 
We can edit the class settings.

•	 Choose the two roof classes.
•	 Click on the Edit... button. 
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•	 Edit the class settings so you have none 
for the fill, and a grey, thine line for the 
roof outline. 

•	 Click on the OK button to close the 
Class settings. 

•	 Click on the OK button to get back to 
the drawing. 

Notice how the roof has 
changed. This is a powerful 
technique. You can changed the 
look of the roof in this viewport 
only. The roof still appears solid 
everywhere else. 

•	 Add your title block, using 
the Drawing border tool. 

Demolition Plan
cadmovie306 

On the demolition plan we need the existing house, 
notes and dimensions for the demolition and a title 
block. 

•	 Make Mod-Level 1 the active 
layer. 

•	 Turn all the classes on. You 
can use the Navigation palette 
to do this. 

There is too much information. 
We need to turn off some of the 
classes to help us make the site 
plan. 

•	 We will use a viewport to 
make the demolition plan. All 
the information is drawn, and 
it has classes assigned to the 
parts. 

http://learn.archoncad.com/?p=2628
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•	 Use the visibility tool, or the 
plug-in I have given you to 
turn off the information you 
do not want. 

•	 Do not turn off the notes on 
the right hand side. These are 
the demolition notes. 

•	 Leave the key notes for the 
demolition visible as well. 

•	 Draw a rectangle around the 
plan. This will become our 
crop object, hiding everything 
outside the rectangle. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0 . 

You can not turn the crop object 
off later, unless you assign it to a 
class. Then if you do, it becomes 
really hard to find it for editing. 
The best strategy is to give the 
crop zero line weight, and assign 
the crop to the None class. 

•	 Go to the Menu bar.
•	 Choose View > Create View-

port...

•	 Name the Viewport. 
•	 Click on the Layers... button. 
•	 Make sure the Mod-Level 1 

layer is the only one visible.
•	 Click on the OK button. 

•	 Click on the Pop-up menu to 
create a New Sheet layer...
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If you have a Class and Layer Standard, 
you can choose the sheet layer from your 
standard.  If not you will have to type in 
the name of the sheet layer. 

•	 Click on the OK button to create the 
new sheet layer.

•	 Click on the OK button to finish 
creating the viewport.

•	 Move the viewport the to 
location you want on the 
sheet. 

•	 Make Mod-Level 1 the active 
layer. 

•	 Draw a rectangle around the 
demolition notes. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0 . 

•	 Go to the Menu bar.
•	 Choose View > Create View-

port...
•	 Name the Viewport. 
•	 Click on the OK button to 
finish creating the viewport.

•	 Your notes might arrive 
outside the printing area. 
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•	 Use the 2D Selection tool to 
drag the notes into the print-
ing area. 

Now that I’m looking at the 
drawing, I notice some things 
missing. It looks like I accident-
ly turned off the walls I want. 

•	 Go to the Object Info palette.
•	 Click on the Classes... button. 
•	 Check the classes. I need to turn 

the Walls-Demolished back on. 
•	 Click on the OK button. 

•	 Use the Drawing Border tool to 
place a title block. 

•	 Go to the Object Info palette.
•	 Click on the Edit Title Block... 

button. 
•	 Add the information for the title 

block 

•	 Click on the OK button. 

Foundation Plan
cadmovie307

On the foundation plan we need the existing founda-
tion, the proposed foundation walls, floor framing, 
notes, dimensions, and a title block. 

•	 Make Mod-Level 1 the active 
layer. 

•	 Turn all the classes on. You 
can use the Navigation palette 
to do this. 

http://learn.archoncad.com/?p=2631
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•	 Use the visibility tool, or the 
plug-in I have given you to 
turn off the information you 
do not want.  

•	 Go to the Navigation palette.
•	 Turn off the Joinery-Bathroom 

class.
•	 Grey the Services-Fixtures 

Proposed class. 

•	 Notice how the toilets are 
grey. You can see them, but 
they don’t draw solid. 

•	 Draw a rectangle around the 
plan. This will become our 
crop object, hiding everything 
outside the rectangle. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0.
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•	 Go to the Menu bar.
•	 Choose View > Create View-

port...
•	 Name the Viewport. 
•	 Click on the Layers... button. 
•	 Make sure the Mod-Level 1 

layer is the only one visible.
•	 Click on the OK button. 
•	 Click on the Pop-up menu to 

create a New Sheet layer...
If you have a Class and Layer 
Standard, you can choose the sheet 
layer from your standard.  If not 
you will have to type in the name 
of the sheet layer. 

•	 Click on the OK button to 
finish creating the viewport.

•	 Move the viewport the to 
location you want on the 
sheet. 

•	 Use the Drawing Border tool 
to place a title block. 

•	 Go to the Object Info palette.
•	 Click on the Edit Title 

Block... button. 
•	 Add the information for the 

title block 
•	 Click on the OK button. 

•	 Right mouse on the viewport.
•	 Choose Edit Annotations. 

This takes you inside the view-
port so you can add notes, 
dimensions and labels.

•	 Go to the Annotation or Dims/
Notes toolset. 

•	 Select the Drawing Label tool.
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•	 Go to the Tool bar. 
•	 Click on the Preferences 

button.
•	 Set the preferences to suit your 

drawing style. 
•	 Click on the OK button to close 

the preferences. 

•	 Move your cursor below the 
plan.

•	 Double click to place the 
Drawing Label.

•	 Click on the Exit Viewport 
Annotations button at the top 
right. 



©Jonathan Pickup - http://www.archoncad.com	 SST_ 0904

Page 16

Framing Plan
cadmovie308

On the framing plan we need the 
existing walls, proposed walls, 
notes, dimensions, bracing, and 
a title block. 

•	 Make Mod-Level 1 the active 
layer. 

•	 Turn all the classes on. You 
can use the Navigation palette 
to do this. 

•	 Use the visibility tool, or the 
plug-in I have given you to 
turn off the information you 
do not want.  

•	 Go to the Navigation palette.
•	 Turn off all the WD- classes.

•	 This turns off the main part of 
the door, but leaves the lintel 
shown.

•	 Draw a rectangle around the 
plan. This will become our 
crop object, hiding everything 
outside the rectangle. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0.

http://learn.archoncad.com/?p=2634
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•	 Go to the Menu bar.
•	 Choose View > Create View-

port...
•	 Name the Viewport. 
•	 Click on the Layers... button. 
•	 Make sure the Mod-Level 1 

layer is the only one visible.
•	 Click on the OK button. 
•	 Click on the Pop-up menu to 

create a New Sheet layer...
If you have a Class and Layer 
Standard, you can choose the sheet 
layer from your standard.  If not 
you will have to type in the name 
of the sheet layer. 

•	 Click on the OK button to 
finish creating the viewport.

•	 Move the viewport the to 
location you want on the 
sheet. 

•	 Use the Drawing Border tool 
to place a title block. 

•	 Edit the Title Block.
•	 Add the  Drawing label.

General Plan

cadmovie309

On the general plan we need the 
existing walls, proposed walls, 
joinery, electrical, notes, dimen-
sions, floor finishes, and a title 
block. 

•	 Make Mod-Level 1 the active 
layer. 

•	 Turn all the classes on. You 
can use the Navigation palette 
to do this. 

http://learn.archoncad.com/?p=2639
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•	 Use the visibility tool, or the 
plug-in I have given you to 
turn off the information you 
do not want.  

•	 Draw a rectangle around the 
plan. This will become our 
crop object, hiding everything 
outside the rectangle. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0.

•	 Go to the Menu bar.
•	 Choose View > Create View-

port...
•	 Name the Viewport. 
•	 Click on the Layers... button. 
•	 Make sure the Mod-Level 1 

layer is the only one visible.
•	 Click on the OK button. 
•	 Click on the Pop-up menu to 

create a New Sheet layer...
If you have a Class and Layer 
Standard, you can choose the sheet 
layer from your standard.  If not 
you will have to type in the name 
of the sheet layer. 

•	 Click on the OK button to 
finish creating the viewport.

•	 Move the viewport the to 
location you want on the sheet. 

•	 Use the Drawing Border tool to 
place a title block. 

•	 Edit the Title Block.
•	 Add the  Drawing label.

•	 Go back to Mod-Level 1.
•	 Draw a rectangle around the 
floor finishes legend. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0.

•	 Create a viewport for the floor legend.



©Jonathan Pickup - http://www.archoncad.com	 SST_ 0904

Page 19

•	 Move the floor legend on the 
page. 

•	 Go back to Mod-Level 1.
•	 Draw a rectangle around the 

electrical legend. 
•	 Use the Attributes palette to 

set the line weight of the 
rectangle to 0.

•	 Create a viewport for the 
electrical legend.

•	 Go to the Object Info palette. 
•	 Set the scale of the electrical 

legend to Custom.
•	 Enter a custom scale. I use 

anything I want here so the 
legend fits on the drawing, but 
is not too small. 
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•	 Move the electrical legend so 
it site nicely on the drawing.

•	 Now the drawing is looking 
better. 

Roof Plan and Roof Framing
cadmovie310

On the roof framing plan we 
need the walls, roof structure, 
and a title block. 

•	 Make Mod-Level 1 the active 
layer. 

•	 Turn all the classes on. You 
can use the Navigation palette 
to do this. 

•	 Use the visibility tool, or the 
plug-in I have given you to 
turn off the information you 
do not want. 

•	 Like the framing plan, you 
have to use the Navigation 
palette to turn off the WD- 
classes for the doors. If you 
try to use the visibility tool, it 
will turn off the walls. 

http://learn.archoncad.com/?p=2641
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•	 Make Mod-Roof the active 
layer.

•	 Use the visibility tool, or use 
the Navigation palette to turn 
off the Structural-Roof Demo 
class. 

•	 Now you can see the new 
roof, but you can’t see the 
rafters. 

•	 Use the Navigation palette to 
turn on the Structural-Rafters 
class. 

•	 Now you can see the rafters. 

•	 Draw a rectangle around the 
plan. This will become our 
crop object. 

•	 Use the Attributes palette to 
set the line weight of the 
rectangle to 0.

•	 Go to the Menu bar.
•	 Choose View > Create 

Viewport...
•	 Name the Viewport. 
•	 Click on the Layers... button. 

•	 Make sure the Mod-Roof and 
Mod-Level 1 layer are the only 
visible layers.

•	 Click on the OK button. 
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•	 Click on the Pop-up menu to 
create a New Sheet layer...

If you have a Class and Layer 
Standard, you can choose the sheet 
layer from your standard.  If not 
you will have to type in the name 
of the sheet layer. 

•	 Click on the OK button to 
finish creating the viewport.

We want the roof plan and the 
roof framing on this drawing, 
but the current viewport is too 
big to fit of them on the page. 

•	 Go to the Object Info palette. 

•	 Change the Scale of the 
viewport to 1:100. 

•	 Rotate the viewport 90º. You 
can use the rotate tool, or you 
can use the quick method, 
right mouse click on the view-
port and use Rotate > Rotate 
Left 90º.

•	 Move the viewport the to 
location you want on the 
sheet. 

•	 Drag a copy across the to 
right. Drag a copy is where 
you drag an object with the 
option key (Macintosh) or the 
control key (Windows) held 
down. When you release the 
mouse you have a copy. 
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•	 Make sure the two viewports 
line up. 

•	 Select the left viewport. 

•	 Go to the Object Info palette. 

•	 Change the Object Info palette 
to the Data tab. 

•	 Check the name of the view-
port. Type in the correct name 
for the viewport at the top field 
on the Object Info palette.  

•	 Change the Object Info palette 
to the Shape tab.

•	 Click on the Classes... button. 

•	 Turn off the Structural-Lin-
tels, Purlins and Rafters.
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•	 Click on the Preview button 
to check the viewport. 

•	 Select the Roof Framing 
viewport, the one on the right. 

•	 Go to the Object Info palette.
•	 Change to the Data tab.
•	 Edit the name of the viewport to 
reflect the name you want on 
the drawing label.

•	 Change the Object Info palette 
to the Shape tab.

•	 Click on the Classes... button. 
•	 Select the Structural-Roof 

Existing and Structural-Roof 
Proposed classes. 

•	 Click on the Edit... button.

•	 Edit the classes to change the 
line style, line color, line weight 
and fill style. 
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•	 Click on the Preview button 
to check.

•	 Turn off the classes for 
Wall-Lining and Wall-Struc-
ture classes. 

•	 Select the other visible wall 
classes.

•	 Click on the Edit... button.

•	 Edit the classes to change the 
line style, line color, line weight 
and fill style. 

•	 Click on the OK button to close 
the Edit Classes dialog box .

•	 Click on the OK button to 
rerun to the drawing.  

•	 Use the Drawing Border tool 
to place a title block. 

•	 Edit the Title Block.
•	 Add the Drawing labels.
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Elevations
There are two main ways to create your elevations. You can use the 3D model 
to create your elevations, or you can use your 3D model to create 2D elevations. 

At the concept stage the first method works really well. The live elevations keep 
up to date with your model. As you add or move windows, you only need to 
click on the update button to see the revised elevation.

As you move into contract documents or working drawings, you might have to 
add annotations to your elevations to make them, look better. For example, if 
you want to show weatherboards on the elevations, or sheet cladding, then you 
need to add the lines to the elevations. This can be done in the Annotation part 
of the viewport. But as you move windows, or edit window positions, you will 
have to edit your wall cladding manually. 

At working drawings, I often use my 3D model to create 2D elevations. These 
are line drawings from the 3D model, so they start out up to date. But because 
they elevations are 2D, you can easily change line weights. This method works 
best when your 3D model is not perfect. 

cadmovie311

•	 Make Mod-3D Model the 
active layer.

•	 Go to the Saved Views menu.
•	 Choose 3D View. 

•	 This sets the view, and turns 
off all the classes we do not 
want. 

•	 Change to a top or Top/Plan 
view.

•	 Go to the Menu bar.
•	 Choose View > Create Section 

Viewport...

http://learn.archoncad.com/?p=2646
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•	 Click for the start of the 
viewport. Ensure you start 
outside the building.

•	 Move to the other end of the 
building. Ensure you finish 
outside the building.

•	 Move towards the building, 
so the arrow points to the 
building. 

•	 Double click.

•	 Name the viewport.

•	 Create a new sheet layer for the 
elevations. 

•	 Click on the Advanced Section 
Properties... button. 
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•	 Choose Limited by Section 
Line Length. This will limit the 
elevation to the length of the 
section line.

•	 Click on the OK button.  

•	 Click on the Render Settings... 
button.

•	 If you want to have a hand-
drawn look, you can turn on 
sketch hidden line results. 

•	 Set the smoothing angle to 20.
•	 Click on the OK button.  

•	 Click on the OK button.  

•	 The elevation is on the 
drawing, but the scale is 
wrong. I want to get more 
elevations on the same sheet. 
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•	 Go to the Object Info palette.
•	 Click on the Scale pop-up 

menu. 
•	 Choose 1:100.

•	 The elevation changes scale 
on the sheet layer. 

•	 Zoom into the elevation.

•	 Right mouse click on a edge 
of the elevation.

•	 Choose Edit Annotations. 

This takes you into the viewport 
annotation area where you can 
add notes, dimensions, labels 
and hatching. 

When we are finished, you can 
return to the drawing by clicking 
on the Exit Viewport Annota-
tion button at the top right of the 
screen. 
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•	 Go to the Basic tool set. 
•	 Choose the 2D Polygon tool. 
•	 Set your default attributes to 

the corrugated roof hatching 
with no line. 

•	 Click inside the new roof 
area.

•	 Vectorworks fills in the roof 
with hatching.

•	 It may not do a perfect job, so 
use the 2D Reshape tool. 

•	 Edit the roof area to suit. 
•	 Make sure nothing is selected. 
•	 Set your default attributes to 

the weatherboard hatching 
with no line. 

•	 Click in the wall area for the 
new weatherboards. 

•	 It may not do a perfect job, so 
use the 2D Reshape tool. 

•	 Edit the area to suit. 
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•	 Add the drawing label.

•	 Go to the Basic tool set.
•	 Choose the Callout tool.

•	 Place a callout, using text 
from your database. 

•	 You can quickly add notes 
from your database for the 
roof. 

•	 And you can quickly add 
notes from your database for 
the walls. 

You can see that this method has 
the advantage of keeping up to 
date with the 3D model. As you 
update the 3D model, you only 
need to click on the update 
button to see an updated eleva-
tion. 

The better the model, the better 
the elevations. 
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2D Elevations
There is another way to make elevations. This is the method where you convert 
your 3D model into a 2D line drawing. This method suits a lot of people 
because it is familiar. 

The technique is basic; set you view, select everything, then choose Modify > 
Convert > Convert Copy to Lines... This gets boring very quickly, so I made a 
command that gets the 4 basic elevations from your 3D model. It’s called 
Elevation Maker and it is a plug-in that you have to copy to the plug-ins folder, 
then add it to your workspace. You will find Elevation Maker in the exercise 
folder with this manual. 

cadmovie312

I add Elevation Maker to the 
right mouse click (Document 
Context). 

•	 If you have added Elevation 
to the Document context, 
right click in the drawing 
area. 

•	 Choose Elevation Maker.

•	 Choose the elevations you 
want. You can only create the 
standard four elevations. 

Elevation maker uses a layer 
called Mod-3D Model as the 
source layer. If the layer does 
not exist, Elevation Maker 
creates it for you. Create layer 
links or a design layer viewport 
to make your 3D model. 

Vectorworks shows the first 
view. 

•	 Choose Hidden Line Ren-
dering. 

•	 Click on the OK button.  
Vectorworks creates the hidden 
line view, cuts the elevation and 
pastes the elevation on a layer 
called Mod-Section /Elevation. 
If the layer does not exist, 
Elevation Maker creates it for 
you.

Vectorworks shows the second 
view. 

•	 Choose Hidden Line Ren-
dering. 

•	 Click on the OK button.  

Vectorworks shows the next 
view. 

•	 Choose Hidden Line Ren-
dering. 

•	 Click on the OK button. 
Vectorworks shows the last view. 

•	 Choose Hidden Line Ren-
dering. 

•	 Click on the OK button.  

http://learn.archoncad.com/?p=2649
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•	 When it is finished, Elevation 
Maker makes the elevations 
the active layer. You should 
see all the elevations lined up.

•	 You will need to move the 
elevations to create enough 
room for your notes and anno-
tation. 

•	 Editing the elevations should 
be straight forward. You can 
double click on an elevation 
to edit it. 

•	 Add lines you want. Delete 
lines you don’t. 

•	 Add hatching, dimensions and 
notes. 

•	 Create viewports, and put 
them on a sheet layer in the 
order you want. 
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Sections
Like the elevations, there are two main ways to create your sections. You can 
use the 3D model to create section viewports, or you can use your 3D model to 
create 2D sections. 

At the concept stage the first method works really well. The live sections keep 
up to date with your model. As you add or move windows, you only need to 
click on the update button to see the revised elevation.

As you move into contract documents or working drawings, you might have to 
add annotation and details to your sections. This will make them look better. 
For example, if you want to show weatherboards, or sheet cladding, then you 
need to add them to the section. This can be done in the Annotation part of the 
viewport. But as you move windows, or edit window positions, you will have to 
edit your wall cladding manually. 

At working drawings, I often use my 3D model to create 2D sections. These are 
line drawings from the 3D model, so they start out up to date. But because they 
are 2D, you can easily change line weights. This method works best when your 
3D model is not perfect. 

•	 Make Mod-3D Model the 
active layer.

•	 Go to the Saved Views menu. 
•	 Change to a top or Top/Plan 

view.
•	 Go to the Menu bar.
•	 Choose View > Create 

Section Viewport...

•	 Click for the start of the 
viewport. Ensure you start 
outside the building.

•	 Move to the other end of the 
building. Ensure you finish 
outside the building.
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•	 Move towards the building, so 
the arrow points to the 
building. 

•	 Double click.
•	 Click on the Advanced Section 

Properties... button. 
•	 Choose Limited by Section 

Line Length. This will limit the 
elevation to the length of the 
section line.

•	 Click on the OK button.  

•	 Name the viewport.
•	 Create a new sheet layer for the 

elevations. 
•	 Click on the OK button.  

The Section is on the drawing. I 
often find I get too much infor-
mation.

•	 Use the Object Info palette to 
turn off classes you do not 
want. 
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•	 The other method for drawing sections is to use the 3D model to cut a 2D or 
3D section. 

•	 The command you want is on the standard workspace, so you either have to 
add it to your workspace, or change to the Standard workspace. 

•	 Go to the menu bar. 
•	 Choose Model > Cut 3D Section.
•	 Look into the section.
•	 Go to the Menu bar. 
•	 Choose Modify > Convert > Convert to lines...

•	 This creates a group of lines, 
line the elevation 2D method. 

•	 Add hatching, notes and 
symbols to create your 
section. 

You can create a high level of 
detail with this method. You 
could use this section for the 
roof and gutter details if you 
wanted. 


