
Workshop Topic 
Plants in VW2008 
Wall Style Library in 
VW2008 
3D Modeling

Plants have been substantially 
improved in VW2008. This 
workshop shows you how easy 
they are to use and how easy 
plants are to edit. 

You could re-use your version 12 
wall style library in VW2008, but 
as I show you in this workshop 
would be better to update your 
library to use the new wall style 
capabilities.

These two topics are based on 
VW2008. They will not work on 
older versions. 

The last topic shows you how you 
can create a site and building just 
using the 3D tools in VW. 

Q & A 
Can I print all my drawings at 
one time?  

Read the answer to find out. 

Extended Podcast 050

How can I cut the ends of my 
steel sections. Watch this podcast 
to see. 

Extended Podcast 051

What use are spaces? Should I 
use spaces for domestic projects?

 

c a d s u p p o r t o n l i n e . c o m  issue 0712

This newsletter is designed to work as an on-line user group. It is based on the successful New Zealand VectorWorks User 
Group format, where each month we cover a main topic in a workshop then have a page of general questions and answers. 
In this newsletter you will find a link to the workshop topic, a link to the questions and answers and links to extended 
podcasts (tips and trick movies). 

http://learn.archoncad.com/?p=1565
http://learn.archoncad.com/?p=1568
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•	 This dialog box lets you 
create and edit plants. 

•	 Click on the plant pop-up 
menu and a series of plants 
appears. Choose one of the 
plants. You might not see 
the same plants as I have 
in this picture. The plants 
shown are saved in a file 
in the Libraries folder. 

Placing Plants 

cadmovie105

Plants in VectorWorks 2008 have changed a lot. Placing plants has not 
changed. They are still as easy to place as they always have been. What 
has changed is plants are much easier to create and edit. 

•	 Open a file with plants. 
•	 This image shows 

a drawing with two 
plants on this layer. 
We can use these 
plants as the start of 
your plant library. 

•	 Choose the Place Plant tool from 
the Site Planning Tool set.

•	 Go the Mode Bar. 
•	 Click on the 

Preferences... button. 

P l a n t s  i n  V e c t o r W o r k s  2 0 0 8

http://learn.archoncad.com/?p=1572
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•	 Go to the Mode Bar. 
•	 Choose the first mode. This 

places one plant at a time. 

•	 Click once to place 
a plant. Each click 
will place a plant. 

•	 Go to the Mode Bar. 
•	 Choose the second mode.

•	 This places one plant at 
each click, but the plants 
are grouped together 
as a clump of plants.

•	 Double click to stop 
placing plants.  

•	 This mode is great 
for placing plants at 
varying spacings.

•	 On this dialog box you 
can change the plant 
spacing. We want to change 
the plant definition.

•	 Click on the Edit 
Definition... button. 

•	 This is the part that lets you 
change the plant definition, 
the spacing, size and data 
that is attached to the plant. 
You do not change the 2D 
or 3D part of the plant here. 

•	 Click on the OK button 
to close the dialog box. 

•	 At the moment I 
do not want you to 
change the plant. 

•	 Click on the OK button.
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•	 Go to the Mode Bar. 
•	 Choose the third mode.

•	 This places a clump of 
plants along the sides of 
a line or polygon shape

•	 Each click defines the 
corner of the polygon 
and the spacing between 
the plants is controlled 
by the plant spacing. 

•	 Double click to stop 
placing plants.  

•	 This mode is great 
for placing plants at 
regular spacings.

•	 Go to the Mode Bar. 
•	 Choose the fourth mode.

•	 This places a clump of 
plants inside a polygon.

•	 Each click defines the 
corner of the polygon, 
and the spacing between 
the plants is controlled 
by the plant spacing. 

•	 Double click to stop 
placing plants.  

•	 This mode is great for 
placing plants at regular 
spacings when you want 
the plants in a grid. 
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•	 Go to the Mode Bar. 
•	 Choose the fifth mode.

•	 This places a clump of 
plants inside a polygon.

•	 Each click defines the 
corner of the polygon, 
and the spacing between 
the plants is controlled 
by the plant spacing. 

•	 Double click to stop 
placing plants.  

•	 This mode is great for 
placing plants at regular 
spacings in a tight clump. 

Moving the  Plant Tags

cadmovie106

Once you have the plants in place you can move the tag for the plant. As 
you develop landscape plans you will want to move all the tags so the 
drawing looks nice and the tags can be read easily. 

•	 Select the 2D Selection tool 
from the basic tool palette. 

•	 Go to the mode bar.
•	 Choose the second mode.

•	 The handle controlling 
the plant tag is shown 
with a blue handle. 

•	 Move to this handle. 
•	 Notice the cursor 

has changed to a 
reshape cursor. 

•	 Click once. 

•	 Move to a new location. 
This location will be the 
position of the handle, not 
the position of the text. 

•	 Click once. 

http://learn.archoncad.com/?p=1579
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•	 The plant tag is moved the 
new position. VectorWorks 
then connects the 
plant tag to the nearest 
plant in the group. 

Editing Plants

cadmovie107

Now you can place plants, we should look at editing the plants. I have 
given you some and you can use these as a starting point to create all 
your plants. 

•	 In earlier versions of 
VectorWorks, editing 
plants was a challenge. 
Now it is easier. 

•	 Choose the 2D Selection 
from the basic tool set. 

•	 Double click on a 
group of plants.

•	 This dialog box lets you choose what to edit. 
•	 Choose 2D Graphics.
•	 Click on the OK button. 

•	 VectorWorks takes you 
to the 2D editing area. In 
this area you can draw 
the shape of the plant. 

http://learn.archoncad.com/?p=1582
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•	 Double click on the plants again. 
•	 Choose Definition.
•	 Click on the OK button. 

•	 In the Definition tab 
set the spread, height, 
Common Name and 
other information. 

•	 Click on the Render tab.
•	 Turn on Rendering 

at Creation.
•	 Two Outlines
•	 Mass Overlapping Plants.
•	 Plant Shadows in 

Plan View. 
•	 Choose a nice hatch 

for the shadows. 

•	 Use any of the 2D tools to 
draw the plant you want. 
I have used the Freehand 
tool to draw this shape. 

•	 You can colour the plant, 
use an image or a gradient. 

•	 When you are satisfied, 
click on the Exit Plant 
button at the top right. 

•	 VectorWorks takes 
you back to the same 
view you had before 
you edited the plant.

•	 Notice that all the plants 
have been updated. 
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•	 Click on the Default 
Prefs tab.

•	 Set the options that you 
want. Notice that I assign 
the plant tag to a class. This 
allows you to turn the tag 
on or off using classes. 

•	 Click on the OK button. 

•	 You may not see the change 
to the plant rendering. This 
is because the Object Info 
Palette has a tick box to 
turn on plant rendering. 

•	 Go to the Object Info Palette.
•	 Turn on Enable 2D Plant Rendering.

•	 Now you can see the 
plant rendering. 
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Creating a New Plant

cadmovie108

You should be able to see how easy it is to edit plants. I found that you 
can duplicate plants easily and then edit them to suit the new plant that 
you want. 

•	 Choose the Place Plant tool from 
the Site Planning Tool set.

•	 Go the Mode Bar. 
•	 Click on the 

Preferences... button. 

•	 Click on the Duplicate 
button. Use this to create 
a duplicate your existing 
plant to make a new plant. 

•	 Click on the 
Definition Tab.

•	 Enter the information 
for the plant definition.

•	 Click on the Render Tab.
•	 Choose the Rendering 

options for the plant.

•	 Click on the Default 
Prefs Tab.

•	 Enter the information 
for the plant.

•	 Click on the OK button. 

•	 Check the plant settings.
•	 Click on the OK button. 

http://learn.archoncad.com/?p=1584
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•	 The new tree is selectable 
from the Mode Bar.

•	 Then you can place 
your new tree.
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Wall Styles

In VectorWorks 2008 wall styles are more powerful than before. The new 
wall styles let you have classes assigned to wall components. I’ve been 
looking forward to this ever since we had wall components. 

Because of the classes on wall components you should not reuse your old 
VectorWorks 12 wall style library without updating it. Update your wall 
styles to have components and assign classes to your wall components to 
make your drawings more powerful.

Why should you use wall styles? Well, a well set up wall style will let 
you draw walls quickly, will automatically assign your walls to the 
correct class, will automatically set the wall to the correct height and will 
have the correct graphic style. A well set up wall style library will let you 
change from one wall to another quickly, and it will have all your most 
common walls in it. 

You can store your wall style library in your template file, you can store 
the wall style library on your computer, or you can store your wall style 
library on a network computer. Storing the wall style library on your 
computer or server are the best options. This way if you edit the wall 
styles you can use the revised wall styles on any project. 

•	 Open a file with walls.
•	 This file has one wall 

style on this layer. We 
can use this as the start of 
your wall style library. 

cadmovie109

•	 Choose the Wall tool from the 
Building Tool set.

•	 Go to the Mode Bar.
•	 Click on the Wall 

Preferences button, the last 
button on the Mode Bar.

•	 This opens a dialog 
box where you can 
edit your wall style. 

•	 If you are trying to use your 
existing version 12 Wall 
style library you will notice 
that there are changes to 
this dialog. In particular, 
we now have more control 
over wall components. 

•	 Click on the pop-up 
menu and choose the 
90mm Proposed Wall. 

W a l l  S t y l e s  i n  V e c t o r W o r k s  2 0 0 8

http://learn.archoncad.com/?p=1586
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•	 Here is your start for a 
new wall style. We will 
use wall components 
to build our wall. Each 
component will be on a 
class so when you make 
your drawings you can can 
choose which component 
of the wall will be visible. 

•	 Click on the New 
button to create a new 
wall component. 

•	 This dialog box controls the 
wall component. You can set 
the color, line weight, and so 
on. The best technique is to use 
classes to control the attributes. 

•	 Fill in the thickness of 
the wall component. 

•	 Name the wall component.
•	 Go to the Class pop-up. 
•	 Choose New...

•	 Name the new class with a 
suitable name. If you have 
a layer and class standard 
you could select the class 
from your standard. 

•	 Choose the option at the 
bottom to Edit Properties 
After Creation.

•	 Click on the OK button. 
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•	 Choose the options for your 
wall. Setting the line weight, fill 
and texture will automatically 
assign these to all the walls 
of this style. You could even 
assign the texture at this point 
and set up wall styles for 
each type of wall cladding. 

•	 Click on the OK button. 

•	 Make sure the options to 
use Class Attributes are 
selected for all the parts 
of the wall component. 

•	 Click on the OK button. 

•	 You will be taken back 
to the Wall Preferences 
dialog box. The wall 
looks a little strange. 
That’s because it only has 
one wall component.

•	 Click on the New... button 
again to create a new wall 
component. This wall 
component will be for the 
structure of the wall. 

•	 Fill in the thickness 
of the wall component. 

•	 Name the wall component.
•	 Go to the Class pop-up. 
•	 Choose New...
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•	 Name the new class with a 
suitable name. If you have 
a layer and class standard 
you could select the class 
from your standard. 

•	 Choose the option at the 
bottom to Edit Properties 
After Creation.

•	 Click on the OK button. 

•	 Set up the class attributes 
to suit your work.

•	 Click on the OK button. 

•	 Make sure the options to 
use Class Attributes are 
selected for all the parts 
of the wall component. 

•	 Click on the OK button. 

•	 You will be taken back to 
the Wall Preferences dialog 
box. The wall looks better. 

•	 Click on the New... button again 
to create a new wall component. 
This wall component will be for 
the internal lining of the wall. 

•	 Set up the name, thickness and 
class settings for the lining. 

•	 Click on the Save Settings 
as Wall Style... button. 
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•	 Name the wall style. If you are 
updating your Version 12 wall 
library, then give the wall the 
same nane that you used before.

•	 Click on the OK Button. 

•	 If the name exists, you will 
be asked if you want to 
replace the old wall style.

•	 Click on the Yes button. 

•	 Choose the options for 
the replacement. 

•	 Click on the OK Button. 

•	 Your new wall is now 
a wall style. 

•	 Click on the OK Button. 

cadmovie110

•	 This has created one wall style with all 
the settings you need. The easiest  way to 
create all your wall styles from here on is 
to duplicate your wall style and edit it. 

•	 Find the wall style in the Resource Browser.
•	 Right-mouse (ctrl-click) click on the wall style.
•	 Choose Duplicate...

•	 Name the new wall style.
•	 Locate the new wall style in 

the Resource Broswer. 
•	 Right-mouse (ctrl-click) 

click on the wall style.
•	 Choose Edit...

http://learn.archoncad.com/?p=1589
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•	 Click on the Structure 
component.

•	 Click on the Edit... button. 

•	 Change the thickness of the 
component to 140mm (6”). 

•	 Click on the OK button.

•	 Click on the OK button.

This has updated the wall style in this 
file only. You could make this your 
wall style library. Or, if you already 
have a wall style library you can export 
this wall style to your library and save 
it there. 

It is a good idea to keep your wall style 
up to date, and with VectorWorks 2008 
it has become easier. You can now 
export your wall style from one file to 
another. 

cadmovie111

•	 Locate the new wall style in 
the Resource Broswer. 

•	 Right-mouse (ctrl-click) click 
on the wall style.

•	 Choose Export...

•	 Choose the file from the list if you 
can see it, or click on the Browse... 
button to locate your wall style library. 

•	 When you locate your library, 
click on the Open button. 

http://learn.archoncad.com/?p=1591
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With the Export Resource option you can make your library symbols in 
any file and export them to your library. This will make it easy to keep 
your wall style library, symbol library, or any other VectorWorks library 
current. 

This exercise will show you how to use 3D modeling tools to create a 
quick building. 

cadmovie112

Create the Site

•	 This file has a series 
of polylines.

•	 Select the bottom 
polyline.

•	 Go to the Menu Bar.
•	 Choose 

Modify > Convert > 
Convert to NURBS. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Move > Move 3D...
•	 Move the NURBS curve down  

-1000mm (-3’ 3”).

•	 Select the next 
green contour. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Convert > 
Convert to NURBS. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Move > Move 3D...
•	 Move the NURBS curve down  

-500mm (-20”).

•	 Select the next 
green contour. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Convert > 
Convert to NURBS. 

3 D  M o d e l i n g

http://learn.archoncad.com/?p=1594
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•	 Select the next 
green contour. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Convert > 
Convert to NURBS. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Move > Move 3D...
•	 Move the NURBS curve up  

500mm (20”).

•	 Select the next 
green contour. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Convert > 
Convert to NURBS. 

•	 Go to the Menu Bar.
•	 Choose 

Modify > Move > Move 3D...
•	 Move the NURBS curve up  

1000mm (3’ 3”).

cadmovie113

•	 Select the Loft Surface tool from 
the 3D Modeling Toolset.

•	 Use the Loft With No Rail 
mode (the first mode).

•	 Click on  the end of 
each NURBS curve. 

•	 Click on the green 
tick or hit the Enter 
or Return key. 

•	 Make the Loft surface a solid object. 
Choose the option 
Create Solid. 

•	 Click on the OK button.

http://learn.archoncad.com/?p=1596
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•	 It now looks like a 
3D object. We could 
call this our site....

•	 Select the Project Tool from 
the 3D Modeling Toolset. 

•	 Choose the Project and Split 
mode (the first mode).

•	 Click on the road 
(the grey shape).

•	 Click on the edge 
of the site object.

•	 The carpark and road 
have been projected 
down to the surface.

•	 Go to the Menu Bar.
•	 Choose 

Modify > Ungroup.
•	 This allows you to 

colour the objects 
different colours. 

cadmovie114

•	 In 3D you can 
see it clearly. 

•	 Change back to a 
Top/Plan view.

http://learn.archoncad.com/?p=1598
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•	 Select the outline of the building 
( the heavy rectangle). 

•	 Go to the Menu Bar.
•	 Choose 

Model > Extrude....
•	 Extrude the object 4000mm ( 13’). 

•	 When you change to 
a Right view you’ll 
notice that the building 
is not sitting all the 
way down on the site. 

•	 Select the building.
•	 Move your cursor to 

the handle at the center 
bottom of the extrusion. 
Your cursor will change 
to a reshape cursor.

•	 Click and move the 
mouse so that you 
stretch the building 
down below the site.

•	 Click to stop stretching 
the building.

•	 Duplicate the site 
by option-clicking 
(Machintosh)on the 
site or crtl-clicking 
(Windows).

•	 Select the duplicate site 
the the block (building).

•	 Select the new curve 
and the building. 

•	 Go to the Menu Bar.
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•	 Choose 
Model > Section 
Solids...

•	 Make sure that the 
site is highlighted. 

•	 Click on the OK button.

•	 This cuts away the 
parts of the building 
that you don’t want. 

•	 You might find the 
Section Solid cuts 
off the wrong part 
of the building. 

•	 Go to the Object 
Info Palette. 

•	 Click on the Reverse 
Section Side button.

•	 Select the building if 
it’s not already selected. 

•	 Use the Split Tool 
and choose the 3rd 
mode, Split by line.

•	 Click to start the 
trim line.

•	 Move your mouse to the 
angle that you want.

•	 Click to finish 
the trim line

This is a good start to model-
ing a building. There is more 
that could be done, but we are 
running out of time.

The 3D Modeling tutorial from 
https://secure.vectorworks.
net/estore/training contin-
ues this exercise and has 
exercises on many 3D tools 
and techniques. If you want to 
progress in 3D modeling you 
need to purchase this manual.

https://secure.vectorworks.net/estore/training
https://secure.vectorworks.net/estore/training
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Q u e s t i o n s  a n d  A n s w e r s

Q.  “Can I print all my drawings at one time ?

Yes, you can. There is a Batch Print command that will print all your 
sheet layers or saved views. It is more flexible than just printing ALL 
your drawings, you can choose which drawings to print, which ones print 
in color and which drawings print in black and white only. 

Step 1

You need to set up all your drawings using sheet layers or saved views. 
I recommend using sheet layers. That forces you into using viewports 
for your drawings. Viewports are a powerful drawing organization 
technique.

Step 2

•	 Go to the Menu Bar
•	 Choose 

File > Batch Print...
•	 This dialog box allows 

you to choose the 
sheet layers or saved 
views for printing. 

•	 Select all the drawings 
you want to print. 

•	 Click on the 
Add>> button.

•	 The chosen drawings 
are added to the right 
side of the dialog box. 

•	 You click on the color 
icon next to each 
drawing to change the 
drawing from color 
black and white. 

•	 When you are 
finished, click on 
the Print Button. 

•	 If this is a set of 
drawings you will use 
on a regular basis, 
click on the Save a 
Set... button. You 
can save this set and 
recall the set later. 
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•	 You can also batch export the 
drawings to PDF if you have 
one of the professional series.

•	 Go to the Menu Bar. 
•	 Choose 

File > Export > Export 
PDF (Batch)...

•	 This opens a dialog box 
that looks very similar 
to the batch print dialog 
box. It works the same 
way as the batch print. 

•	 If you set up a saved set 
of drawings for prinitng 
on the batch print dialog 
box you can recall 
the set of drawings 
in this dialog box.

•	 Click on the 
Export button. 

•	 Set the resolution options 
for the PDF file.

•	 Click on the Export button. 
•	 Save the PDF file somewhere 

easy to find. I suggest you save 
the PDF file in the same folder 
as your VectorWorks Drawings. 


