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Introduction

In this manual are going to cover the concept of creating a building takeoff 
report. In order to do that we are going to cover the basics of creating 
worksheets (which is the technique we need to use to create a report). We 
will also look at designing a building takeoff, because while Vectorworks 
has the ability to report all the information you require, it doesn’t know yet 
what information that might be.

It is most important that you understand the concept of using worksheets. 
We have covered worksheets and other manuals, and I will not be repeating 
some of that information, but I will be covering enough for you to 
understand how a worksheet is designed to be used.
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Introduction to Worksheets

a worksheet in Vectorworks is very similar to an Excel spreadsheet. 
Vectorworks has had these worksheets for several years (for as long as I 
can remember using Vectorworks). They are very powerful, and they can 
be used to create reports of objects in the drawings, and they can be used to 
do calculations.

The basic strategy of a worksheet is that each cell has a unique identifier 
which is the column number then the row number. For example, the first 
cell in the worksheet (at the top left corner) is cell A1, because this is 
column A and row 1. the next cell across would be in column B, but still in 
row 1, so  this is cell B1. The cell directly below a one is cell A2, and so 
on.

If you want to use cells for calculations you can tell Vectorworks to add 
one cell to another, multiply one cell by another, subtract divide et cetera.

In the case of the building, we might use the worksheet to look for parts of 
the building, such as the roof. Vectorworks has a search criteria that would 
allow us to find the area of the roof. We could then input the cost of the 
material for this roof and instruct Vectorworks to calculate the area times 
the cost. When the design changes, we would only need to tell Vectorworks 
to update our worksheet, and Vectorworks would find the new roof area 
and multiply it by the cost of the material, to bring you a new total cost.
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When you report information from your objects in Vectorworks,the 
information may be reported as numbers, or as text. The differences are 
because Vectorworks has different types of information that can be 
attached to objects. Some of this information is text based, and some is 
number based. The difference will not be apparent until you start use the 
information for calculations. It is easy to use mathematical formulas on 
numbers, but it is not possible to use these on text based information. 

For example, a common problem might be reporting areas of spaces. The 
space object has the area as  text, and it also has the areas as numbers. In 
the image below I have sketched out the difference between the text and 
numbers. The text actually looks like a number because it has the  area 
units with the number. The number information just displays the area as a 
number. However, the text information cannot be added and so when 
you’re trying to create an overall report of the area of the spaces, your 
calculations will fail.

The other column (with the numbers on their own) is the same information 
but reported as numbers only. Notice how at the head of the column you 
can see  the total (the sum of all the spaces).
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There are two main techniques for getting information into your worksheet. 

1. Criteria - in this technique you would ask me to ask for look for specific 
objects based on some sort of criteria, such as the class, layer, etc. this 
method is ideal for finding objects that do not have data attached to them. 
An example of this would be creating a report that will give you the site 
area, the building area, impermeable surface area, and it will perform 
calculations on these areas.

2. Database - with this technique you ask Vectorworks to look for objects 
that have a database attached. This technique allows you to report the data. 
An example of this technique would be creating a report of all the windows 
in the project. This report could give you the window number, the window 
height, width, sash operation, etc. 



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1602

Page 8

Designing Your Report

It is very important to decide what you want to report. There is an almost 
unlimited choice about what to report, so you have to think carefully about 
what is most important. 

You will find it easier to create your report if you design it first. Sometimes 
the choices you make about the reporting will have an effect on the tools 
you use, or the options you set for the tools.  	

For example, if you look at walls, you might want to report the basic area 
of the wall, as you might do for a foundation wall. In this case there is no 
need to create a wall style that has components. 

You can see from this sketch that there might be a lot of information 
required from each component. Some of this information can be reported 
directly from the wall components, the other parts might be in the 
description of the wall style, while other information might have to be 
added to the wall using Record Formats. 

You can see how important it is to think about all this before you start you 
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report, but it is also important the think about all of this before you start 
your projects.

If you wanted to create a report that calculated the area of the cladding, the 
cladding material, the thickness of the cladding, the colour, and you wanted 
to report similar information about other parts of the wall, then you would 
need to create wall components. The easiest way to create the walls with 
the components is to use a wall style.



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1602

Page 10

Some objects have data attached to them (walls, windows, doors, etc) and 
you can create a report that just counts the number of windows. That might 
be enough for your report, as shown in the image below. 

However, you might require more information about your windows. In the 
image below, you can see the report has a lot more information about each 
window. This report uses a different technique from the report above to 
report the information that is attached to each window. This technique is 
called a database report. 
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Foundations Part 1

Before we create the report, we need to have a look at our options. We have 
the foundations drawn with foundation walls, floor piles, bearers, and 
joists. 

The floor structure has been created with Framing Members. These objects 
use the Object Info palette to control their options and they have a lot of 
information that can be reported in a database report. 

You will have to go back to your report design to see what information you 
need to report. You may not want all the available information, but we can 
sort that out later.  

When you look at the walls, they also show a lot of information on the 
Object Info palette, and wall styles have a lot of information stored in 
them, but the way you report the wall information is not the same as the 
Framing Member. 
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This particular wall style does not have any components, as you can see 
from the Edit Wall Style dialog box. 

Database reports can be created using a menu command:

Tools > Reports > Create Report...

The database report would be ideal for the Framing Member, doors, or 
windows, because it will report all the information that is on the window.

In this image you can see all the available information that you can report. 
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There are several choices, and unless you have designed the report ahead 
of time, you can waste a lot of time deciding what is required.  

This type of report will not work with walls. Instead we have to create a 
report using a more manual method. 

•	 Go to the Resource Browser. 

•	 Click on the option to create New Resource in...

•	 Choose Worksheet...

•	 Enter a name for the worksheet. Use a name that will make sense later 
on. 
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•	 You may not know the exact number of rows and columns that you need,  
so you can guess. If you need more rows or columns, you can add them 
or remove any extras that you do not need later. 

•	 Click on the OK button. 

The worksheet will open in a new window. 

•	 In the first cell (cell A1), type in a title for the report. 

•	 In cell A2 type in the title for the report on the foundation walls. 

•	 Right click on cell A1. 

•	 Choose Format Cells... 

•	 Click on the Font tab. 

•	 Choose the font, size, style, and other settings for the title. 
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•	 Click on the OK button.  

•	 Right click on cell A2. 

•	 Choose Format Cells... 

•	 Click on the Font tab. 

•	 Choose the font, size, style, and other settings. 
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•	 Click on the OK button.  

•	 Click in cell A3. 

•	 Add titles for the portions of the foundation walls that you wish to 
report. In this image you can see that I require each foundation wall, its 
length, and its area.

•	 Click in cell A4.

•	 Now we can start to put in the formulas to report the information about 
the foundation walls.

•	 Before you do anything else, make sure you put in an = in the formula 
bar (the area the top next to the red X and the green tick). If you forget 
to put this equals sign in, Vectorworks will not treat the rest of your 
work as a formula.

•	 Go to the Menu bar on the worksheet window.

•	 Click on Insert > Function…
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•	 This opens a dialog box you can select from any of the inbuilt worksheet 
functions. There are several worksheet functions.

•	 if you scroll down this list, you will see that there is a large number of 
available functions. 

•	 We will not be covering all of these functions, but it is a good idea to 
have a look through them.

•	 If you click on a function the help area at the bottom of this dialog box 
will give you more information about its use. This is a good way to find 
out what that function is used for.

•	 Scroll down to locate the Count function.

•	 Click once on this function.

•	 Click on the OK button to close this dialog box and return to the 
worksheet.
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•	 The function is in place that Vectorworks doesn’t know what this 
function is related to. In other words,Vectorworks needs to know what 
objects we are trying to count. This concept is called the criteria and it 
works like a filter, to choose just the things that we want

•	 Go to the Menu bar on the worksheet window.

•	 Click on Insert > Criteria…

•	 If you have an object selected, you will see this dialog box.

•	 Click on the Custom… button.
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•	 If you do not have any object selected you will be taken straight to the 
Criteria dialog box.

•	 Remember that the criteria is like a filter and this is where we set the 
filter options.

•	 In the first instance we want to limit the counting to objects in the 
Foundation layer.

•	 On the left pop-up menu choose Layer.

•	 On the right-hand pop-up menu choose the Foundation layer

•	 Turn off the options to look for objects in Design Layer Viewports 
(un-tick those options).

•	 When you make changes in this dialog box, Vectorworks will show you 
how many objects meet that criteria. At the moment there are 78 objects 
that meet the criteria of being in the foundation layer.
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•	 At the moment we are looking for any object on the foundation layer and 
we need to add additional filters (where it says more choices).

•	 Click on the More Choices button.

•	 On the left pop-up menu choose Type.

•	 On the right-hand pop-up menu choose Wall.

•	 When we add the filter for wall, there are now only 16 objects that meet 
this criteria.

•	 you could add additional criteria to make sure that you are just getting 
the foundation walls.

•	 For example, you could add another choice, choose Class in the left 
pop-up menu and choose the Wall-Proposed Blockwork class in the 
right-hand pop-up menu.

•	 You might notice that there are still 16 objects selected. You might be 
wondering why I go to the trouble of adding the class as well as adding 
the wall. The answer is I might in the future decide to add more walls 
that are not related to the foundations, I do not want these showing up in 
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my report as foundation walls.

•	 When you have added all the required criteria, click on the OK button.  

•	 The criteria has been added to the worksheet. You can see it in the 
formula bar.

•	 This is not giving the required information yet.

•	 Click on the green tick next to the formula bar. This will tell 
Vectorworks that you are satisfied with the information you have entered 
and you want Vectorworks to use this formula.

•	 If you make a mistake, you can click on the red X next to the formula 
bar and Vectorworks will undo the information you have entered.
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•	 The report currently shows that we have 16 walls that meet our criteria, 
but we also need to find the length and area of those walls.

•	 Click on cell B4.

•	 Type in an =.

•	 Go to the Menu bar on the worksheet window.

•	 Click on Insert > Function…

•	 This opens the function dialog box.

•	 Scroll down until you find the Length function. The description will tell 
you that this function will give you the length of lines or walls that meet 
the criteria. notice that it will only report the lengths of lines or walls. If 
we were looking for the length of a polygon or polyline, this function 
would not be suitable.
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•	 Click on the OK button to return to the worksheet,

•	  

•	 Go to the Menu bar on the worksheet window.

•	 Click on Insert > Criteria…
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•	 If you have an object selected, you will see this dialog box.

•	 Click on the Custom… button.

•	 If you do not have any object selected you will be taken straight to the 
Criteria dialog box.

•	 Remember that the criteria is like a filter and this is where we set the 
filter options.

•	 In the first instance we want to limit the counting to objects in the 
Foundation layer.

•	 On the left pop-up menu choose Layer.

•	 On the right-hand pop-up menu choose the Foundation layer

•	 Turn off the options to look for objects in Design Layer Viewports 
(un-tick those options).

•	 Click on the More Choices button.

•	 On the left pop-up menu choose Type.

•	 On the right-hand pop-up menu choose Wall.

•	 Click on the More Choices button.

•	 On the left pop-up menu choose Class.

•	 On the right-hand pop-up menu choose Wall-Proposed Blockwork.
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•	 When you have added all the required criteria, click on the OK button

•	 The criteria has been added to the worksheet. You can see it in the 
formula bar.

•	 This is not giving the required information yet.

•	 Click on the green tick next to the formula bar. This will tell 
Vectorworks that you are satisfied with the information you have entered 
and you want Vectorworks to use this formula.

•	 If you make a mistake, you can click on the red X next to the formula 
bar and Vectorworks will undo the information you have entered.

•	 We now have the current lengths of all the walls, and that area 
calculation will be very similar to the calculation and the criteria that we 
have used for the lengths.

•	 Right click on the length calculation cell and choose Copy.

•	 Right click on the cell for the area calculation and choose Paste.
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•	 We need to edit the function for the cell.

•	 Go to the formula bar and delete the word Length.

•	 On the worksheet window go to the Menu bar.

•	 Choose Insert > Function…

•	 It is tempting to use the function Area, but this function will not find the 
area of a wall. You will notice this if you click on the area function and 
read the description.
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•	 Scroll down until you find the function WallArea_Net. You will notice 
that there are several walls specific functions. The wall area net function 
will report the area of the wall less any holes (windows or openings). If 
you use the wall area gross function, it will ignore any holes in your wall 
and report the overall area of the wall.

•	 Click on the OK button to return to the worksheet. 

•	 When you insert a function it also inserts brackets behind the function. 
These additional brackets are not required and will cause an error if left.

•	 Delete the extra brackets that are not required.

•	 Click on the green tick to update the calculation
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•	 This gives us the information, but it is in a raw form. My current units 
for dimensions is millimeters, but I want the worksheet to report in 
different units. In this case, I really need the lengths in meters. 

•	 In this case, I need to divide the result by 1000 to give meters. 

•	 After entering the formula, click on the green tick.  

•	 To format the cell, right click on the cell and choose Format Cells...

•	 Change the format to a Decimal with 3 decimal places (Dec. Places)
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•	 Click on the OK button to return to the worksheet 

•	 Notice the length is now shown with the unit mark.

The reason that I had to add the unit mark manually is because my units are 
set to use millimetres, but in this case it makes more sense to show the 
length as metres.

If I was using metres as my units in the file, I would not have to manually 
add the unit mark, I could use the dimension settings for this.

For example, if you are using imperial measurements, you might have set 
your units to be feet and inches. In this case you would probably have the 
unit mark shown, otherwise it’s confusing what the numbers relate to.
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•	 Right click on the cell and choose Format Cells…

•	 This time we can choose the Dimension format.

•	 Click on the OK button to return to the worksheet.

•	 Now you can see the total length of your wall with dimension settings 



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1602

Page 31

that make sense.

•	 Go to the area calculation cell.

•	 Right click on the cell and choose Format Cells…

•	 If you have set the area dimension units, you can choose the option 
Dimension Area, and Vectorworks will add the correct units to the end of 
your dimensions.
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•	 Click on the OK button to return to your worksheet.

The report shows the 16 walls, the total length of the walls, and the total 
area of them. But it doesn’t break down the walls into individual quantities, 
it doesn’t allow us to see the individual length of individual walls.
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Foundations Part 2

The previous report came as the total lengths and the total areas of all the 
foundation walls, but this is not useful if we have different wall styles that 
make up our foundation walls. In the report above if we have different wall 
foundation types, they will be counted together.

We need to have a report that will give us all the same wall types together, 
but we don’t want to create a report the looks for individual classes for 
each wall type. It would be better if we could use the wall style itself 
collect all of our walls together.

There is a technique that we can use for other parts of the building that will 
automatically create a database looking for objects based on the 
information attached to them. We can’t use this for walls, so we need a 
different approach.

In this part of the manual we look at how to create a database report 
manually.

•	 Right click on row 6.

•	 Choose Database. This technique will allow us to count individual 
objects and report individual lengths and areas of those objects.

•	 As soon as you click on the database option, Vectorworks will open the 
criteria dialog box. 



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1602

Page 34

•	 This is the same criteria dialog box that we have previously used, so we 
can set this to look for walls on the foundation layer.

•	 When you have entered the required options, click on the OK button. 

•	 This time Vectorworks is found the same 16 walls.

•	 You might notice that row number 6 now has whole new set of rows 
underneath labelled 6.1 to 6.16.

•	 Each row represents one wall.

•	 Row number 6 is known as the Database Header. This is a special row 
that has all of the formulas entered into it. The rows below it will show 
the information from each wall.

•	 In row A6, type in =.

•	 Go to the Menu bar on the worksheet window.

•	 Click on Insert > Function…
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•	 There is a function that will report the wall style name for all of these 
walls.

•	 Scroll down the list of functions until you find WallStyleName. 

•	 Click on this function once, then click on the OK button.
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•	 Remember to click on the green tick next to the formula bar.

•	 You should now see all of the wall style names of the objects that meet 
your criteria.

•	 When you use a database to find all of the walls, you do not have to type 
a complex formula into the worksheet to find the lengths of all these 
walls.

•	 By inputting a short formula (“= Length”), the worksheet will apply at 
two each object that has been located.

•	 Click on the green tick to complete this formula.
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•	 Click on the next cell for the wall area.

•	 Go to the Menu bar on the worksheet window.

•	 Click on Insert > Function…

•	 There is a function that will report the net wall area for all of these walls.

•	 Scroll down the list of functions until you find WallArea_Net. 

•	 Click on this function once, then click on the OK button.
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•	 Click on the green tick.

•	 The worksheet will now calculate the net wall area for each individual 
wall.

•	 The cells do not have formatting information which can make them hard 
to read.

•	 Right click on the area calculation cell and choose Format Cells…

•	 If you have set up your document units correctly, you can use 
Dimension Area. Using Dimension Area will set the formatting of the 
cell to match the dimension area formatting of the document. so it is 
useful to set your document units correctly.
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•	 Click on the OK button to return to the worksheet.

At the moment, all of our walls are being reported individually. If this is 
what you require, then you have the information. However, this may create 
a very long report, and it is possible to shorten the report if required.

•	 Click on the row that is the database header (the one with the diamond). 
In this case that is row 6.

•	 You should notice three new icons that have appeared just above column 
A. These icons control sorting and summing. It is the Sum icon that we 
need.
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•	 Click and drag the sum icon to the top of column A.

•	 When you sum a column, you are telling Vectorworks to combine all the 
objects that are the same (in this case they have the same wall style 
name).

•	 You will notice that the lengths and areas have now been combined.
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There is a fundamental difference between the style of worksheet (the 
database) and the first worksheet that we made.

In the first worksheet we used the class to find the walls. This is okay 
provided we do not need to have any more information about these walls. 
if we have different wall thicknesses or different wall styles, these will be 
combined together with the original walls that are in the worksheet. This 
might lead to some confusion if we have different wall thicknesses (wall 
styles) that have the same class.

We could add additional rows to look for new foundation wall classes, but 
this is complex and it is also prone to error.

In the second worksheet we have told Vectorworks to find any walls that 
are on the correct class and combine together all the walls that are the same 
style. If we create a new wall style that use the same class, it will be shown 
on the worksheet as a separate row. 

For example, we could have different wall thicknesses for our foundation 
walls depending on the loads that they have to support. Our second 
worksheet would automatically group the different wall styles together so 
you could see the total lengths and areas of each wall style.
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Because the second worksheet would work automatically, it would save us 
a lot of time, and more importantly, it would save us from making errors.
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Floor Framing

Another part of the foundations that we have to report is the timber 
structure that will be supporting the floor. In this case we will be looking 
for objects that do have information attached, such as  joists, bearers, and 
piles (piers). These objects have data attached, so we can use the database 
technique. Because of the type of object, we can use a faster way to create 
the worksheet as well.

•	 Go to the Menu bar

•	 Choose Tools > Reports > Create Report...

•	 Click on the pop-up menu to choose Framing Member. 

This dialog box is very powerful because it allows you to choose from a 
long list of objects to create a report on them. You might notice the not 
every object in Vectorworks is listed here, walls for example are not 
shown. But if an object is shown in this list, you can use this dialog box to 
create a report on those objects and you can choose from any of the 
attached data.

•	 After you have chosen Framing Member, you will notice that the left-
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hand side of the dialog box now displays all the available information. 
The technique to use here is to select the information that you want to 
add to your worksheet,  then click on the Add>> button to add it to the 
right-hand column of the dialog box.

•	 at the top of the list you will find the Width and Height. These two fields 
relate to the width of the framing member and the height of the framing 
member, not the height of the framing member above zero(elevation).

•	 Click on the Add>> button.

•	 Scroll down to the bottom of the dialog box and click on Length. 

•	 Click on the Add>> button.
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•	 Scroll up and down the list carefully to ensure that there is no other 
information that you want to edit your report.

•	 At the bottom of the dialog box click on the Options… button.

•	 Click on the radio button to Append to existing worksheet.

•	 From the pop-up menu choose your building takeoff worksheet.
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•	 Click on the OK button to return to the Create Report dialog box.

•	 Click on the OK button to return to the worksheet.

•	 You should notice that all the framing members have now been added to 
the worksheet.

•	 Select the database header row for the framing members.

•	 Right click on one of the cells and choose Format Cells…

•	 Format the cells for a dimension.
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•	 Click on the OK button to return to the worksheet.

•	 This image shows imperial measurements, which are in both feet and 
inches. 

•	 If you are using a metric file you will need to set the width and height to 
Dimension units, but you might find the length is better if you converted 
to metres first and then add the unit mark to it.
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•	 In this image you can seethat all the framing members have been found 
and they are shown in the report. You might also notice that they are all 
shown as individuals.

•	 If you show each individual framing member, you will end up with a 
very long report. You may want to collect all of the framing members 
together that have the same width.

•	 Ensure that you have clicked on the Database Header row ( the row with 
the diamond). In this case the header row is row number 8.

•	 When you select the database header row, three icons will appear above 
column A.

•	 The first two icons relate to sorting and the third icon is called Sum. This 
icon will gather together all objects that have the same information.
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•	 Drag the Sum icon to column A (this is the width column).

•	 Release the mouse button when your cursor is on column A.

•	 All the framing members that have the same width are now collected 
together.

•	 You will notice that the length column now gives you the total length of 
all of the objects that have the same width. 

•	 You could easily get a situation where framing members have the same 
width but a different height. In the report at the moment all the framing 
members with various heights are collected together because they have 
the same width.
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•	 Ensure that you have clicked on the Database Header row ( the row with 
the diamond). In this case the header row is row number 8.

•	 Drag the Sum icon to column B (this is the height column).

•	 Release the mouse button when your cursor is on column B.although we 
do not have various heights for each width, it is a real possibility that we 
could have in the future. Creating your worksheet in this way will 
protect you from mistakes in the future.

•	 Some people wish to know how many framing members there are of the 
same length. We can apply the same technique to the length column as 
well, but before we do that we need to add a quantity label and a count 
function to a worksheet.
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•	 Ensure that you have clicked on the Database Header row ( the row with 
the diamond). In this case the header row is row number 8.

•	 Drag the Sum icon to column C (this is the height column).

•	 Release the mouse button when your cursor is on column C.
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Flooring

In this project the floors have been created with slab objects. Again I have 
to point back to the idea that you need to design your report before you can 
carry out the steps. In my case I’ve decided that I want to report the total 
area and the thickness of my flooring. However, you may want to report 
different areas that have different floor finishes on them, in that case, you 
may be using polygons for the floor areas or you may be using different 
slabs. In either case, you need a way of picking up the information that 
relates to the floor finishes. It may be that using classes is a suitable way of 
separating the different floor finishes. 

This is where you need to go back to your design of your building takeoff 
report. Then you design do you need to report all of the different floor 
finishes or do you just need to report the overall structural area of the floor. 
This might not seem like a substantial difference, but if you do not report 
the right information your building takeoff is useless.

In this case I will be reporting to different areas, the main floor area and the 
decking area. These two areas have been separated by using different slab 
Styles, but I will be looking for these areas by their class. If you would like 
to report many different areas of different floor finishes but use the same 
slab style, then you should use a similar strategy where you separate the 
floor types by class. Separating your floor finishes by using different 
classes is a good strategy to control the graphic style as well as the building 
takeoff reporting. Using a different slab style for each will finish will make 
it difficult to manage your slab styles.

•	 The first step is to it at your current building takeoff report to add a title 
for the floor reporting.

•	 Add labels for the floor type the floor thickness and the area (or the other 
things that you want to report).

•	 Click once in the required cell for the floor type.
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•	 On the worksheet menu bar click on Insert > Function…

•	 We are looking for objects that have a slab style name, scroll down to 
find the function for SlabStylename. This function will look for all slabs 
that mention a specific criteria (in this case the class) and report the 
name of that slab style. If you are using classes only, then in this cell 
type in the name for that floor finish.

•	 Click on the OK button to return to the worksheet.

•	 The function is incomplete because it needs to know what objects to 
look for (the criteria). Vectorworks knows that it is looking for a slab, 
but it needs to know something about the slab in order to find it. In this 
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case sitting a criteria for a class should find the slab.

•	 On the worksheet menu bar click on Insert > Criteria…

•	 We do not want Vectorworks to find slabs that are in the wrong layer, so 
set criteria that will look for slabs in the correct layer that have the 
appropriate class. In this case I am looking for objects on the Floor-1 
layer, that are slabs , and are in the class Structural Floor.

•	 Click on the OK button to return to the worksheet.

•	 The next step is to find the thickness of the slab.

•	 Go to the Menu bar on the worksheet window.

•	 Choose Insert > Function…

•	 Look for a function that will report the slab fitness. Scroll down towards 
the bottom of the function dialog box, the function is called 
SlabThickness and will report the overall thickness of the slab. If you 
are choosing to report just a component of the slab, then choose the 
appropriate function that will report a component fitness.
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•	 Add the same criteria that you added for the slab name. You can copy 
and paste the criteria from one cell to another. If you do not use exactly 
the same criteria you run the risk of reporting the wrong information.

•	 When you come to measure the area of the slab, you must use the 
CompAreaByName function, but if you are using polygons then you 
must use the Area function. If you look carefully at the function 
description, you will notice that the Area function on the reports the area 
of to the objects, which means that it will not report the area of a slab.

•	 Remember to format the cells so that the numbers make sense.

•	 Right-click on the cell and choose Format Cells…
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•	 For the area calculation you can use the Dimension Area format. This is 
a quick way to add the correct area units to your cell. Other cells may 
need to be formatted as decimals with a trailer that represents the correct 
units.

•	 If you have other areas that you need to report you will need to create 
reporting functions for those areas. The way I have set up my calculation 
of the moment limits my reporting to slabs that have the same class. My 
report will give me the total area of all the slabs that are on the same 
class, but it will not report slabs that are in a different class.

•	 An easy way to get started is to copy the entire run from your first slab 
calculation.

•	 Paste that into the worksheet row below. You need to edit the class and 
the component name in order to report the correct areas.
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•	 Remember correctly the criteria for the thickness calculation.

Remember correctly the criteria for the area calculation.
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Walls

Refer back to your building takeoff report design. If you need to calculate 
the area of the exterior wall component, then you will have to find all of 
the exterior walls and then get Vectorworks to report just the areas of the 
exterior components. This does mean you will have to drill your walls 
using components for the interior, structural, and exterior parts of the wall. 
If you have not created your walls this way then you will not be able to 
find the information you require.

If you are using sheet material to the exterior of your walls, then you might 
want to calculate the number of sheets required. This again comes back to 
the way you have designed your takeoff report.

One possible way of doing this is to have all of the walls on the same class, 
but look for the component for the exterior wall.

In this image you can see that all of the walls have the same class (Wall – 
Proposed). So is there any downside and having all of the walls on the 
same class? If you wanted to separate the structure of the exterior walls and 
the interior walls, and having all the walls on the same class might be 
challenging, because this seems to be nothing to separate the different 
walls. In reality the interior and exterior walls are different wall styles and 
the wall style can be used as a criteria.

•	 We want to be sure that later on when we had the design we don’t lose 
any walls from our report. The easiest way to ensure this is to make your 
report into a database.

•	 Create headings for the walls, wall type, exterior cladding, interior 
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lining, and any of the other parts that you want to report.

•	 Go to the next row down.

•	 Right click.

•	 Choose Database.

•	 if you have anything selected you will get a dialog box with a list of 
options. If this happens click on the Custom... button.

•	 In the Criteria dialog box choose the criteria for selecting the walls on 
the appropriate layer. In this case I have chosen one layer (Floor-1) and 
the type is Wall. This will select all of the walls regardless of their class 
or wall style.

•	 Click on the OK button to return to the worksheet.

•	 In the previous dialog box it showed that 22 objects would meet the 
criteria. The worksheet now shows all of those objects, one for each row.
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•	 If you click on the row, you will see in the formula bar the database and 
the search criteria for your objects. You can edit the search criteria here 
if you need to.

•	 We currently have every wall individually listed. If you have designed 
your report to list each wall individually, then you do not have to follow 
the next step. However, if you want to group all of the same all types 
together then you will need to follow the step.

•	 Make sure your database row is selected.

•	 Drag the sum icon from above column A to column A. 

•	 At the moment this will collect together all of the walls that have the 
same information in column A. We haven’t set the type of information 
we want in column A, so it will just group all the walls together.
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•	 In column A for the database row add an =.

•	 On the worksheet window, go to the Menu bar choose Insert > 
Function…

•	 Scroll down until you find the function, WallStyleName. This function is 
used to report the wall style name for each wall.

•	 Click on the OK button to return to the worksheet.

•	 now that we have added this function to column A, and we have 
previously told Vectorworks to collect together all the items in column A 
that have the same information, Vectorworks will now collect together 
all the walls that have the same wall type.

•	 The advantage of building the worksheet this way is that any new wall 
styles that are added to the project will automatically be added to our 
report whenever we recalculate.
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•	 The wall style names I have created are too long for the cell.

•	 Right click on the cell for column A which lines up with the database 
header row.

•	 Choose Format Cells…

•	 Under the Alignment tab choose the option to Wrap Text. This will 
wrap the text inside the cell so that you can see the entire wall style 
name.

•	 Click on the OK button to return to the worksheet.

•	 Now you will be able to read the entire name of the wall style.
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•	 Now it’s time to put in the formula to calculate the exterior cladding and 
the interior lining. As we saw with the slabs it is not possible to use the 
area function. We will be using the same function that we used for slabs 
which calculates the component area by name.

•	 Go to the cell for the exterior cladding, making sure you’re still on the 
database row.

•	 Add an =.

•	 On the worksheet window, go to the Menu bar choose Insert > 
Function…

•	 Scroll down until you find the function, CompAreaByName. This 
function is used to report the area of one side of the component. 

•	 Click on the OK button to return to the worksheet.

•	 This function will look for walls based on criteria and you will also have 
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to put the name of the component that you want to report. Because we 
have used a database to find the walls, we do not have to specify the 
criteria, but we do have to specify the name of the component.

•	 The name of the component has to be written in brackets and in single 
quote marks. If you do not do this correctly, Vectorworks will not find 
your component.

•	 Because we are looking for components based on their name, it is 
essential that when you build your wall styles use consistent naming 
strategy. If you do not use a consistent naming strategy, Vectorworks 
will not give you a complete report of all of the components you require.

•	 Use the same steps to report the internal lining. Because the the lining 
component of the exterior and the interior walls has the same name, they 
will be reported.
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Doors and Windows

As part of your report you might want to list information about all the 
doors and windows. If you’re using a standard Vectorworks door and 
window object you will find that you have to create two reports: one for the 
doors, and one for the windows. If you are using the Windoor object, you 
can tell the windoor object to assign the windows and doors to the same 
schedule, allowing you to report them together.

The information that you may want to report about your doors and 
windows should be part of your design for your building takeoff report. In 
my case I only want a limited amount of information for doors and 
windows.

Because of the way these objects are created we can use a different 
technique to create a database report. This technique is a very quick way to 
create a report for some objects.

Doors

•	 Go to the Menu bar.

•	 Choose Tools > Reports > Create Report…

•	 This command will open a dialog box making it easy to choose the 
information you want about your doors or windows.

•	 Give your report a title, in this case of chosen the title Doors. We will be 
appending this report to our main building takeoff worksheet and this 
title will be added to the worksheet for us.

•	 Choose the option from the pop-up menu to List all Objects with a 
record.

•	 From the pop-up menu choose to list objects with the record Door. This 
is similar to the technique that we used for the framing member.

•	 On the left side of the dialog box choose the fields that you want to 
report.



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1602

Page 66

•	 Click on the Add>> button to add those fields to the right side of the 
dialog box. These are the fields that will be in your report.

•	 Click on the Options... button.

•	 Choose to Append to existing worksheet and choose your building 
takeoff worksheet from the pop-up list of possible worksheets in the file.

•	 Click on the OK button.

•	 Click on the OK button once more to return to the worksheet.

•	 You can add an additional label to your worksheet to make it easier to 
find the doors and windows.

•	 In this image you can see all the doors have been reported. You might 
notice that the doors are not in order.
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•	 Select the database row for the doors and use your sorting icons from 
above column A to sort the doors by number.
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Windows

•	 Reporting the windows is very similar to reporting the doors.

•	 Go to the Menu bar.

•	 Choose Tools > Reports > Create Report…

•	 This command will open a dialog box making it easy to choose the 
information you want about your doors or windows.

•	 Give your report a title, in this case of chosen the title Windows. We 
will be appending this report to our main building takeoff worksheet and 
this title will be added to the worksheet for us.

•	 Choose the option from the pop-up menu to List all Objects with a 
record.

•	 From the pop-up menu choose to list objects with the record Window. 
This is similar to the technique that we used for the doors.

•	 On the left side of the dialog box choose the fields that you want to 
report.

•	 Click on the Add>> button to add those fields to the right side of the 
dialog box. These are the fields that will be in your report.



©Jonathan Pickup - http://www.archoncad.com	
SHORT SHARP TRAINING  - Issue 1602

Page 69

•	 Click on the Options... button.

•	 Choose to Append to existing worksheet and choose your building 
takeoff worksheet from the pop-up list of possible worksheets in the file.

•	 Click on the OK button.

•	 Click on the OK button once more to return to the worksheet.

•	 Select the database row for the windows and use your sorting icons from 
above column A to sort the doors by number.

•	 In this image you can see all the windows have been reported. 
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•	 As well as using these worksheets to report the information about doors 
and windows, you can also use them to edit the information about the 
doors and windows. For example, this worksheet will easily change sash 
operation for selected windows from awning to fixed glass or any other 
operation. 

•	 This worksheet can also be used to change the width, height, or elevation 
of the windows.
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Roofs and Ceilings

Ceilings

The ceilings should be created from a slab, which means you can use the 
same technique we used for the floor finishes to calculate the areas of the 
ceiling.

•	 Set up a database to look for your slab objects on the ceiling layer.

•	 Use the function to calculate the component area by name. The name 
might relate to the ceiling area, the ceiling joists, or the area of 
insulation. You can also use the same calculation to calculate all three. 
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Roofs

Calculating the area of roofs has a slight variation on the techniques we 
have used so far. Don’t forget that the roof is on a sloping surface.

•	 Set up a database to look for roof objects on the roof layer. You can look 
for objects by their type (Roof) or you could look for objects by their 
class (Structural-Roof).

•	 If you look for objects by the type and you choose to look for Roof 
objects you will not find Roof Face objects. If you never use roof bases 
then this will not be a problem. However, you might think that you will 
never use a roof face object, but then you need to use one in a project, 
and then your report will miss it out.

•	 If you look for objects by their class and you are consistent with the 
class names you give to roofs and roof faces, then your report will 
always work and it will never leave any  objects out.

•	 When you look at the functions for reporting the roof area, you might be 
tempted to use this function RoofAreaTotal.

•	 If you look at the description of this function, it says that it will report 
the total area of the roof along the slope, which sounds ideal.
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•	 The challenge is that this function will do exactly as it says and report 
the total area along the slope of the roof. Because this roof contains 
more than one component Vectorworks is reporting four times as much 
roof area as there should be.

•	 A better solution would be to report the component area by name and 
choose the roof cladding component. If you have created any offsets to 
your roof cladding component, these will be included in the calculation.
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•	 The area of the insulation depends on the construction of the roof. If the 
insulation is the flat area of the ceiling, then you could use the function 
that finds the heated area of the roof projected down onto a plane. 
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Roof Accessories

There are many different roof accessories that you may need to report. 
Vectorworks does not build these objects automatically, so you will have to 
build them using a combination of framing members, extrusions, or 
extrude along the path.

These objects can be counted, but you will have to make sure that you are 
consistent about the classes and techniques that you use to create these 
objects.
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Conclusion

If you want to create a highly accurate building takeoff then you have to 
design the report that you want first, then you have to make sure that when 
you create your objects (such as walls, roofs, ceilings, doors, windows, et 
cetera) they will be consistently created to feed into the report.

In the file that I have used for this manual, I have been consistent about the 
naming conventions I have used for wall components, for classes, and for 
slabs. This has made it easy for me to create my report.

While I was writing the notes I had to go back to some of my wall styles 
and update the names of components to make them consistent, and you will 
probably have to do the same. Your first project will require the worksheet 
to talk to the objects and the objects to feed into the worksheet, so prepare 
yourself for some editing of your objects to make sure that they feed into 
the worksheet correctly.

This may seem like a lot of work. On the other hand, once you’ve done all 
that work, you now have a template that you can use for any project. Any 
project that you start from this template will have the correct components, 
the correct classes, the correct layers, et cetera. So while this seems like a 
lot of work what you have built is an office system that you can use on 
project after project. 

Jonathan Pickup


	Introduction
	Introduction to Worksheets
	Designing Your Report
	Foundations Part 1
	Foundations Part 2
	Floor Framing
	Flooring
	Walls
	Doors and Windows
	Doors
	Windows

	Roofs and Ceilings
	Ceilings
	Roofs
	Roof Accessories

	Conclusion

