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Introduction
If you are an architect it will be unusual to create a building that does not 
have a roof. If you are a landscaper then it is useful to create a simple build-
ing with a simple roof that reflects the building that you working with.

Roofs in Vectorworks can be made from walls or from planar objects 
(rectangles, polygons, etc.). You need to have this shape to define the extent 
the roof.

The roof object in Vectorworks can be used to create complex roofs, 
but sometimes the roof objects is that the shape too complex to create. 
In this case you have to find a way to simplify the outline to a point that 
Vectorworks can create the roof.

When you make a roof in Vectorworks it creates a 2D and a 3D object. This 
means that you can use the roof to help make elevations and sections. 
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Creating a Roof

•	 Use the Wall tool to create a series of walls similar to this image.

•	 Select all the walls.  Make sure that you have only walls selected.  The 
command that we will be using will not work with other objects.

•	 If you are using Vectorworks  Architect, go to the Menu Bar.

•	 Choose AEC > Create Roof...

•	 If you are using Vectorworks  Landmark, go to the Menu Bar.

•	 Choose Landmark > Architectural > Create Roof...
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•	 Fill out the dialog box with the parameters as shown.

•	 Click on the OK Button.

•	 This command will create a hip roof for you and place it on the layer 
specified, in the Layer Name field, in the dialog box.  Make sure that 
you type the name in exactly, including case and spelling. 
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Editingx a Roof
Once the roof is created you can go to the roof layer and you can edit 
parameters of the roof, plane by plane if you want, or the entire roof.

•	 The completed roof has one handle on each plane of the roof.  If you 
move the cursor to one of these handles the selection arrow changes to a 
hand.  

•	 Click on the handle and this opens a dialog box that allows you to edit 
either one roof plane or the entire roof. 

•	 Click on the Gable End radio button.

•	 Click on the OK Button.

•	 The result is a modified roof.
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•	 Do the same for the other end of the roof.

•	 Move the cursor to the end handle of the roof and the selection arrow 
changes to a hand.  

•	 Click on the handle.  This opens a dialog box that allows you to edit 
either one roof plane or the entire roof.

•	 Click on the Dutch Hip radio button.

This wall is controlled by the 
Show Wall check box.



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1505

Page 10

•	 Set the dimensions to suit.

•	 Click on the OK Button.

•	 By default Vectorworks puts a gable end wall under the roof face you’ve 
just edited.  

•	 If you don’t want this gable end wall, go to the Object Info Palette and 
turn off the check boxes for showing walls. 
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Split Gable Roof

Once a roof is created you can edit parameters of the roof, roof plane by 
roof plane if you want, or the entire roof. We are going to create a split 
gable roof using the standard roof command, and some simple editing.	

•	 Select the roof using the Selection tool.  

•	 When you create a roof the result is always a hip roof but we want a split 
gable.  

•	 With the Selection tool move the cursor over the handle at the right hand 
side of the roof.  

•	 When you do, the cursor will change into a hand. 

•	 Click on the handle to open the Edit Roof dialog box.

•	 Click on the Gable radio button.

•	 Click on the OK button.  

•	 The result is a gable end.
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•	 With the Selection tool move the cursor over the handle on the left hand 
side of the roof.

•	 Click on the handle to open the Edit Roof dialog box.

•	 Click on the Gable radio button.

•	 Click on the OK button.  

•	 That is the Split Gable. 
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Offset Gable

•	 So far it’s been straightforward but we haven’t created the offset gable 
yet. 

•	 With the Selection tool move the cursor over the handle on the right 
hand roof face.  When you do this, the cursor will change into a hand.  

•	 Click on the handle to open the Edit Roof dialog box.

•	 Click on the Gable radio button.

•	 Click on the OK button.  

•	 That’s created the required gable end.

The roof can be edited in several places to remove the hip roofs. 
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With the Selection tool move the cursor over the handle on the left hand 
roof face.  When you do this, the cursor will change into a hand.  

•	 Click on the handle to open the Edit Roof dialog box.

•	 Click on the Gable radio button.

•	 Click on the OK button. 

•	 Click on the next roof face to edit the gable.  

•	 Click on the Gable radio button.

•	 Click on the OK button. 
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•	 Click on the next roof face to edit the gable.  

•	 Click on the Gable radio button.

•	 Click on the OK button. 

•	 You may get to a point where Vectorworks tells you that is cannot make 
sense of the roof. Don’t worry about it. 
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•	 Click on the OK button. 

•	 In this situation Vectorworks will not create the roof, you will be left 
with a strange polygon that follows the pitch line of the roof.

In this situation Vectorworks will not create the roof, you will be left with a 
strange polygon that follows the pitch line of the roof.

Do not let this worry you. Carry on to the next part of the roof and edit it.

•	 Click on the Gable radio button.

•	 Click on the OK button. 
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I often get the warning message about the roof not being created, and my 
solution is normally to carry on with my editing. In most cases Vector-
works will create the roof that you want. But there are times Vectorworks 
will not create a roof that suits your design. In these situations try creating 
smaller groups and joining them together, see my example later in this 
manual.
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Cutout in a Standard Roof

If you don’t want to go to the trouble of creating a 3D symbol for the 
skylight, you can punch a simple hole in the roof face.  Vectorworks calls 
these holes a cutout.	

•	 Use the roof from the previous example.

•	 Draw a rectangle to represent the cutout. 

•	 Select the roof and the rectangle using the Selection tool.  

•	 Right click on the roof or rectangle. 

•	 Choose Clip Surface.



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1505

Page 19

•	 The cutout will be formed in the roof and the rectangle will be left 
selected. 

•	 The Rectangle is no longer needed and can be deleted. 

•	 When you change to a 3D view, you can see the cutout in the roof. This 
is a quick way to add a whole for a penetration in the roof. 

•	 The original rectangle has been copied into the roof and can be edited or 
removed. 

•	 Select the roof. 
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•	 Go the to Menu bar. 

•	 Choose Modify > Edit Group... (there is a keyboard shortcut for this 
which is use all the time).

•	 The rectangle should be selected, if not you will find it easier to drag the 
selection marque over the rectangle to select it. 

•	 You can edit the rectangle to change the location or size. In this example 
the rectangle has been re-sized to match the outline of the floor above. 
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•	 To finish the editing, go to the Exit Group button at the top-right of the 
drawing window. 

•	 Click once. 

•	 In a 3D view you can see the roof cutout. 

•	 When you activate the other layers, you can see how the cutout matches 
the upper floor. 

•	 In this example I am also going to create a cutout in the roof, but the 
difference will be instead of forming a hole in the roof, I will be using it 
to change the shape of the end of the roof.

•	 Change back to a plan view of your roof.
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•	 Draw a polygon for the change in the roof. Remember that you only 
need to draw the path that is cut out.

•	 Select both the roof and the polygon.

•	 Right click on the roof or the polygon and choose Clip Surface from the 
contextual menu.

•	 As in the previous example, the polygon will be selected.

•	 Delete the polygon.

•	 The roof is now altered to reflect the polygon. 
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•	 Remember that this polygon still resides inside the group, and you can 
remove it by editing the group and deleting polygon.
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Reshaping a roof

When you start by selecting the walls to create your roof, you can often 
end up with the roof plan outline that you want do not want. There might 
be times when you do not want the roof to exactly follow the walls. In the 
situation you can use the Reshape tool to change the pitch line of the roof.

In this example I will be reusing the roof from the previous exercise.	

•	 Select the roof.

•	 Go to the Basic toolset and click on the Selection tool.

•	 Notice that the blue handles appear at the midpoint of each roof plane. 
These are the handles that you click on to edit the roof plane to change it 
from an eave to a gable.

•	 Select the Reshape tool.  

•	 Notice that the handles on the roof have changed. Instead of the handles 
being at the center of each roof plane, you now have a handle at each 
corner of the roof plane as well as one in the middle. These handles are 
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the vertices for the polygon that controls the roof outline.

•	 Go to the Tool bar.

•	 Click on the first mode, the Move Polygon Handles mode. This mode is 
used to move any of the vertices on the roof outline.

•	 Move your cursor to the midpoint of one of the roof planes.

•	 When your cursor is directly over the handle, the cursor will change 
shape to four arrows.

•	
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•	 Click once and move your cursor. Do not move your cursor outside the 
roof area. If you do, the roof will not be created and you will get the 
error message that we saw earlier.

•	 Click once at the required position for the new roof location.

•	 Vectorworks will update the roof to the new outline.

•	 You can relocate any roof plane that you require.

•	 As well as relocating the midpoints of the roof faces, you can also 
relocate the corner vertices.
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•	 As well as relocating vertices, you can also delete vertices.

•	 Go to the Tool bar.

•	 Click on the Delete Vertex mode. This mode is used to delete any of the 
vertices on the roof outline.

•	 Move to an area of the roof that has a portion that you want to remove.

•	 Move your cursor to the corner vertex.

•	 The cursor will change to a minus arrow.

•	 Click once to remove the vertex. 
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•	 Move to the next corner vertex.

•	 Click once again to remove the vertex. Vectorworks will remove any 
other vertices that are in line.  

•	 As well as moving and deleting vertices, you can also add vertices to 
change the roof layout. 
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Dealing with the Challenging Roof

The standard Vectorworks roof is not able to make every roof construction 
that you would like. But it is a good idea to keep the roof object going as 
long as possible. One of the techniques that I use is to break the roof up 
into smaller chunks that Vectorworks can deal with.

In this exercise I will be using the same house project that we have used 
previously, but I will create two roof objects join them together. Although I 
am using a simple project to demonstrate this, you can use this technique 
on much more complex projects.

This technique uses the cutout concept that was covered earlier in the 
manual along with simple roof objects. The idea is that you can use 
polygons to cutout portions of the roofs where they intersect each other. 

•	 This image shows that the roof can be broken up into two roofs.

•	 Draw a polygon for the first area of the roof. 

•	 Use the Create Roof... command to create the roof. 
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•	 Notice that Retain Original Objects is not ticked. This will remove the 
original polygon. 

•	 Edit the roof to suit the design. 

•	 I usually change the color of the roofs to make them easier to visualize 
the different roofs. 

•	 Draw another polygon for the other portion of the roof. 
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•	 Use the polygon to create a roof.

•	 Edit the roof to suit. 

•	 It is very important to edit the gable end to ensure that this gable passes 
completely through the adjoining roof. 

•	 In this example 2900mm (10’) will be enough.  
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•	 Click on the OK button. 

•	 It is a useful trick to change the colors of the roof faces. I have made one 
red and one blue.

•	 Check the roof to make sure that the two roof faces completely overlap. 

•	 Also check the underside of the roofs. 

•	 Here you can see that the two roofs overlap. The overlapping areas can 
be removed using the roof cutout technique we covered earlier. 

•	 Return to a Top/Plan view.
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•	 Select both roofs. 

•	 Go to the Menu bar.

•	 Choose Modify > Convert > Convert Copy to Lines...

•	 Use Hidden Line Rendering.

•	 Click on the OK button.

•	 The result will be a group of lines.
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•	 Double-click on the group to edit it. 

•	 Select the 2D Polygon tool. 

•	 Go to the Tool bar. 

•	 Click on the second mode, Inner Boundary mode. 



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1505

Page 35

•	 Click in the first roof area. 

•	 This mode will create the required polygon easily. 

•	 Move to the next roof face. This one has two areas.

•	 Click once in the first roof area. 

•	 Hold down the shift key. 

•	 Click once in the second roof face.

•	 Select all the polygons you have drawn.
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•	 Right-click on one of the polygons.

•	 From the Contextual Menu choose Cut, or use the keyboard short cut, 
Apple + X (Macintosh) or Ctrl + X (Windows).

•	 Click on the Exit Group button at the top-right. 

•	 The group has done its job now.

•	 Select it.

•	 Delete it.
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•	 Select the roof over the bedroom extension (top-right). 

•	 Go to the Menu bar.

•	 Choose Modify > Edit Group.

•	 Go to the Menu bar.

•	 Choose Edit > Paste in Place.
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•	 This will past the poly

•	 Select the polygon to the left, it is not needed for this roof. 

•	 Delete it.

•	  Ensure the left polygon is left behind. 

•	 Click on the Exit Group button at the top-right of the drawing area.
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The roof has been updated to remove the part we don’t want. 

•	 Select the other roof, the right-hand roof.

•	 Go to the Menu bar.

•	 Choose Modify > Edit Group.

•	 Go to the Menu bar.

•	 Choose Edit > Paste in Place.

•	 Select the polygon that is not needed.
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•	 Delete it.

•	 Click on the Exit Group button at the top-right of the drawing area.

•	 The roof has now been edited. 

The edited roof is shown in 3D. 

Even if you notice a few little things in the 3D version of the roof that you 
would like to change, you can edit them by double-clicking on the edge of 
the object and then editing the 2D shape.
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Inserting a Dormer Window

To insert a dormer window you need to create the roof first and you need a 
window or door symbol to insert.  

•	 You cannot use a plug-in object like a simple window to create a dormer.  
You can however use the simple window plug-in to create the symbol.  

•	 Create the window object that you want to have in the dormer window.  

•	 Change the parameters until the window is the size and height that you 
want and has the trim and sill options that you want. 

•	 From the Menu Bar choose Modify > Create Symbol... 

•	 Give the window a name then click on the OK button. 

•	 On the Resource Browser you should be able to see your window 
symbol.
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•	 Drag the window symbol from the Resource Browser to the roof where 
you want the dormer window.  

•	 Release the mouse button. 

•	 The dormer window will be installed. 

•	 This will open the Edit Roof Element dialog box.
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•	 Choose the type of dormer that you want to use.  In this case I have 
chosen the gable dormer.

•	 Use the ‘Offset From Top’ radio button to accurately control where you 
want the centre of your window or door symbol to be in the wall.

•	 The building line offset is used to control the position wall containing 
the dormer window in relation to the wall or polygon that you used to 
create the roof.  This should be set to zero or ‘0’ if you want to line up 
with the walls below.

•	 Note that by default the left slope and the right slope of the dormer are at 
45º.

•	 The roof thickness of the dormer window is controlled by the Object 
Info Palette.

•	 When you are happy about the parameters, you can click on the OK 
button to close the dialog box.



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1505

Page 44

•	 To edit a dormer window that has been placed, select the roof using the 
Selection tool.  You will notice that you get selection handles on each 
roof face and at the bottom centre of each dormer.  

•	 Move your cursor over the handle for the dormer that you want to edit 
and click once.  This will open the Edit Roof Element dialog box.

•	 Change the parameters that you want to and then click OK.  
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•	 You will be taken back to your drawing and the changes you made will 
be applied to the dormer and roof.

•	 To delete a dormer window that has been placed, move your cursor on 
top of the handle for the dormer that you want to edit and click once.

•	 This will open the Edit Roof Element dialog box.

•	 Click on the Remove Object check Box.

•	  Click on the OK button.

•	 You are returned to the drawing area and the roof is regenerated, and the 
dormer window is deleted from the roof.
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Inserting a Skylight

Putting in a skylight is similar to putting in a dormer window.  To place a 
skylight you need to create a skylight symbol.  The way that you create the 
skylight is crucial to the way it inserts into the roof.	

When you create a symbol for the skylight the insertion point of the 3D 
Symbol is used to relate the skylight to the face of the roof. The symbol 
cannot be a hybrid symbol.  It must be 3D only.  Create an extruded 
rectangle the size that you want, the actual size of the skylight that you 
want to create.	

•	 The location of the symbol relative to the insertion point controls the 
position of the skylight in the roof plane. 

•	 Go to the Resource Browser.

•	 Locate the skylight symbol.

•	 Drag the skylight to the roof. 

•	 Release the mouse button where you want the skylight to be.  

•	 This will insert a dormer window. 

•	 Click on the dormer window control handle. 
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•	 Click on the button for Edit Skylight.
•	 On this dialog box you can control the position of the skylight on the 

roof.

•	 Click on the OK button. 

•	 Your skylight symbol has been installed.  

•	 To edit a skylight that has been placed, select the roof using the 
Selection tool.  You will notice that you get selection handles on each 
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roof face and at the centre of each skylight.  

•	 Move your cursor over the handle for the dormer that you want to edit 
and click once.  This will open the Edit Roof Element dialog box.

•	 Change the parameters that you want to and then click OK.  

•	 You will be taken back to your drawing and the changes you made will 
be applied to the skylight and roof.
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•	 To delete a skylight that has been placed, move your cursor on top of the 
handle for the skylight that you want to edit and click once.

•	 This will open the Edit Roof Element dialog box.

•	 Click on the Remove Object check Box.

•	  Click on the OK button.

•	 You are returned to the drawing area and the roof is regenerated, and the 
dormer window is deleted from the roof.

•	
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Thank you 
Thank you for subscribing. I trust that you have enjoyed working through 
this manual, and that it has been informative and constructive. 

The other part of visualization is lighting and rendering. That will be cov-
ered soon, so look out for that manual on the subscriber web site. 

For more information, please visit this web site: 
http://learn.archoncad.com

If you just want someone to help you learn Vectorworks, carry out some 
Vectorworks contract work, or you want someone to make Vectorworks 
easier, contact me, as this is a service that I offer: 
jon@archoncad.com

Thank you again,
Jonathan Pickup
May 2015

http://learn.archoncad.com
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