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Introduction 
I think rendering is one the fun parts of Vectorworks. Appropriate rendering 
will bring your buildings and objects to life, but without good lighting, all 
your good work will be wasted. A clever lighting design will even make a 
dull model come to life.

This manual will work through the rendering options and show you when 
each one should be used. Finally we will look at a couple of models and 
look at applying the lighting and rendering to get the best results.

Be aware that in order to get superior results, some rendering styles will 
take several minutes to render. While Renderworks can be fun it can also 
be very time consuming.  

Obviously you have to create a model to render. Try to plan your views, 
then model all the parts of your project that are visible in these planned 
views. Remember that you don’t have to model the parts of your project 
that you can not see. Where will you be standing, what will you be looking 
at? This will help you to decide on what you need to draw and what you 
can leave out. If you don’t know what areas you will be rendering then you 
will have to model the entire project and assign textures to all the objects in 
the drawing. If you have used a lot of classes, work out if some of these 
classes can be turned off to speed up the rendering process. 

When you create your model think about texturing the model as you draw. 
Remember that sometimes you do not have to model objects if you can 
texture them. For more information on textures, refer to the Vector-workout 
manual on textures (SST_1105). 
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Vectorworks and Document Preferences

There is not a set of preferences that just deal with rendering. There are 
Vectorworks preferences (effecting all your files) and Document 
preferences which may have an effect over the look of your rendered 
views. 

cadmovie1504_01

Vectorworks Preferences

The Vectorworks Preferences are preferences that affect every Vectorworks 
file, unlike Document Preferences which are only stored in the current 
document. You might find that these preferences have already been set, but 
it is a good idea to check through these to see if these preferences of the 
way you require. 

•	 Go to the Tool bar.

•	 Click on the Utility menu at the right-hand side.

•	 Choose  Vectorworks Preferences...

Display Tab

There are options on this dialog box that control the display of light objects 
and 3D Loci. 
I usually choose the Only in Wireframe option so that in  a wireframe 
view I can see the lights and 3D Loci, they can be selected so that they 
can be moved, but when I render the view the lights and 3D loci are not 
displayed, just the output from the light source is visible. It is really discon-
certing to see the light appear is a rendered view. 

http://wp.me/p2BFhB-6sq


©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 7

You will notice two options that I have left turned off.

The option to show the internal origin marker might be distracting for 
rendered views, but it will only be important if you have imported DXF/
DWG information that is far from the origin of the file.

Showing the colored axes in Top/Plan view could also be distracting.

Session Tab

There are not many options on the Session tab that will affect rendered 
views, these options tend to affect the way you work with Vectorworks. For 
example, the sound might be distracting while your drawing, the Display 
Default Content option will give you greater access to textures, and the 
maximum number of undo’s has an impact on the memory requirements of 
Vectorworks.
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3D Tab

Under the 3D tab are controls for the resolution of the conversion (how 
finely 2D shapes are converted to 3D faces), and how Vectorworks retains 
the 3D geometry in its memory. If you choose Always then Vectorworks 
should keep the model rendered in OpenGL when you walk  through the 
building.

This tab also has options that will affect the change from Top/Plan view 
to a 3-D view. The default option is to change your rendering to OpenGL. 
This change was introduced in Vectorworks 2015. Vectorworks Updated the 
OpenGL engine to dramatically improve the speed of it, but it does require 
a high quality graphics card. The default projection when changing from a 
Top/Plan view to a 3-D view is Normal Perspective. Previously, the default 
was orthogonal. If you were an earlier use of Vectorworks You might find 
it disconcerting to have your view automatically change to OpenGL with 
a perspective view, but it will not take you long to find the superior to the 
wireframe orthogonal view.

Interactive Tab

On the Interactive Tab is a button to open the Interactive Appearance Set-
tings… dialog box.
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There are two options on the interactive appearance settings that that will 
change the appearance of your renderings in OpenGL. The Perspective 
Horizon Ground and the Perspective Horizon Sky options control the 
colors that you see for the ground and the sky as you walk through, fly 
over, and view your OpenGL renderings.

To change these colors, the required option and then change the foreground 
and background colors. The reason that there are two colors for each of 
these options is that the ForeColor controls the color of the foreground 
(the area closest to you) and the BackColor controls the color of the 
background (the area furthest from you).

•	 Click on the OK button to return to the Vectorworks preferences dialog 
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box. 

User Folder Tab

The user folder tab does not directly affect your rendering, but the location 
of your user folder and workgroup folder can have an effect on the 
resources you have in your Resource Browser.

•	 Click on the OK Button to close the Vectorworks  preferences. 

Document Preferences 

•	 Go to the Tool bar.

•	 Click on the Utility menu at the right-hand side.

•	 Choose  Document Preferences...

The only tab that will have an effect on your rendering is the Display tab. 
The Cropped perspective option will have an effect on your rendered views 
by cropping your perspective view. The size of the crop can be adjusted by 
moving the handles at each corner.
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Prior to Vectorworks 2014 all perspective views were cropped, but the 
default from 2015 onwards is to disable the Cropped perspective option.

•	 Click on the OK Button to close the Document  preferences. 

Grid

•	 Double-click on the grid snap. This will open the SmartCursor Settings 
dialog box. The grid in 3-D can be very useful for modeling but not for 
rendering. Use this dialog box to disable the grid options.

•	 Click on the OK button. 
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Setting 3D Views

Quick 3D  Views

cadmovie1504_02

For Quick 3D views, use the numeric keypad on your keyboard. The 
numeric keypad is on the right side of your keyboard, if you have a full 
size keyboard. Use this for quickly typing in numbers.
Vectorworks has assigned hot keys to 3D views so that you can change 3D 
views quickly.

The trick to remembering the order is to imagine your model positioned 
on key 5.

•	 To look at it from the front, use key 2 is in front of key 5.

•	 To look at the model from the right, key 6 is to the right of key 5 and so 
on.

http://wp.me/p2BFhB-6st
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•	 We want to look at our 3D model from the right front isometric, use key 
3 on the numeric keypad.
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The Flyover Tool

cadmovie1504_03

The Flyover tool is like a helicopter. You use it to rotate around the 
building to obtain different viewing angles, even from underneath or 
above.  But you can’t walk into the building.  That’s what the Walkthrough 
tool is for.  You can use this tool from any view.

•	 Go to the Visualization Tool or Basic tool set. 

•	 Select the Flyover Tool.

•	 Go to the Tool bar. 

•	 Click on the first mode.

•	 Move your cursor into the drawing window. 

•	 Click and hold the mouse button down.  Slowly move the mouse up the 
screen.  

http://wp.me/p2BFhB-6sC
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•	 The further you move the mouse from the center of the screen the more 
dramatically the view changes.

The best way to use this tool is to move a little bit then let go of the 
mouse button.  Move your cursor back to the middle of the view.  

•	 Move your mouse to a part of your model. 

•	 Click and hold the mouse button for a short time, then release the mouse 
button. 

•	 This will become the centre of the rotation (if you choose the first mode 
on the Mode Bar).
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The Walkthrough Tool.

cadmovie1504_04

The walkthrough tool is used to walk into and through your model.  You 
can use it from any perspective view but the results are always more 
pleasing if you set your perspective first.  

•	 Go to the Visualization Tool set. 

•	 Select the Walkthrough Tool. Your view projection will be changed to 
perspective. If you were not in a perspective view, the view will change 
dramatically. 

•	 Go to the Tool bar. These buttons can be used to move the eye position 
up, down, or tilt the viewing angle. 

http://wp.me/p2BFhB-6sE
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•	 Click and hold the mouse button down.  This is the reference point. 

•	 Slowly move the mouse up the screen.  The further you move the mouse 
from the reference point, the faster you walk into the model.

•	 The best way to use this tool is to move the mouse up the screen a little 
bit.  With the mouse button down move the cursor to the right or to the 
left.  

•	 You can walk backwards (moving your mouse down) and you can walk 
both in and to the side (moving your mouse diagonally) at the same time 
if you want.

When you get lost, go back to Top/Plan view. This always brings you back 
to a Top/Plan view and you can start again.  

•	 Remember to use your alt key (Windows) or your option key 
(Macintosh) for turning around and the shift key for moving up and 
down. You will find the walk-through extremely useful for setting up 
your 3-D view.
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Renderworks Camera

cadmovie1504_05

On the view menu is a command called Set 3-D View… This command 
can be used to set up a perspective view, but it does not save the view. In 
order to save the view you have to create a safety review after sitting 
perspective. While you can use this command to set the view, a more 
efficient way to set your view is to use the Renderworks Camera. Not only 
does the Renderworks Camera remember the view, you can use the 
visualization palette to restore the view (much like a saved view) but you 
can also use the Renderworks Camera to create a viewport. My 
recommendation is to use the Renderworks Camera to setup your views.

•	 Go to the Visualization Tool set. 

•	 Select the Renderworks Camera Tool.

•	 Go to the Tool bar. 

•	 Click on the Preferences button, the last one on the Tool bar. 

http://wp.me/p2BFhB-6sH
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•	 Fill in the preferences to suit. You can set the rendering settings here, so 
each time you display the camera view, the scene will render. 

•	 Click on the OK button.

•	 Set your view to Top/Plan 

•	 The first thing Vectorworks wants is the camera position. Move your 
cursor to a suitable location.

•	 Click once.
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•	 Move the cursor into the object. This is the centre of your view.

•	 Click once.

•	 The Renderworks camera has a plan object that stays on the screen. 



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 21

•	 You can double click on the camera to Activate the camera and you can 
also activate it from the Visibility palette.

•	 With the camera selected, go to the Object Info palette. 

•	 You can change many of the settings in the Object Info palette, and you 
can fine tune the camera as well.
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•	 Click on the Fine Tune Camera View... button. 

•	 You can see the camera view and a dialog box. 

•	 Move the sliders to fine tune the camera view. The view will update as 
you move the sliders. 

•	 Click on the OK button.
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•	 Drag the sliders to change the view. As you drag the sliders, the view 
updates. 

•	 Click on the OK button to return to the drawing. 

•	 In Top/Plan, you can use the Selection tool to edit the the camera 
position. You can move the camera location, view angle and the look 
toward location this way. 

•	 You can drag a copy of the camera to make a new one, then edit the 
camera location, view angle and the look toward location. This a quick 
way to add cameras.
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Using Cameras With Viewports

One of the productive techniques with the Renderworks Camera is to use it 
for creating viewports. When you create a viewport from a camera, 
Vectorworks Allows you to go back and find shooting the camera view, 
which will update your viewport. I recommend using the Renderworks 
Camera to create all of my perspective viewports because of the speed at 
which you can create the viewports and the fact that you can go back and 
edit the views easily.

•	 Make sure your Renderworks Camera is selected.

•	 Go to the Menu bar.

•	 Choose View > Create Viewport…

•	 The first time you do this, you will get an alert box telling you that the 
Renderworks Camera object can be used as the viewports view. And 
then asking if you want to do this.

•	 If you do not want to see this alert box again, check the option Always 
do the selected action.

•	 Click on the Yes button.

•	 Fill in the savings for the viewport.
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•	 Click on the OK button to finish creating the viewport.

•	 Vectorworks will place your viewport on the selected sheet layer.

•	 When you need to edit the view in the viewport, right click on it and 
choose Edit Camera.
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•	 This will take you back to your design layer.

•	 Go to the Object Info palette. 

•	 The Renderworks Camera will be selected on the Object Info palette. 

•	 Click on the button to Fine Tune camera view…

•	

•	 Fine tune the camera view to suit your requirements.

•	 Click on the OK button.

•	 Click on the button at the top right hand corner of the drawing window 
to Return to Viewport.



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 27

•	 You will notice that your viewport has now been updated to reflect the 
changes you made to the Renderworks Camera.

Now that you have linked your Renderworks Camera to the viewport it 
will no longer appear in the Visibility palette. The only way you can access 
this Renderworks Camera is to edit it through the viewport. The original 
Renderworks Camera is no longer available on the design layer.
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Rendering Types

Rendering is a way of looking at your 3D model with light and shade, 
hidden line, or even no options at all. There are several ways of doing this 
and each different way has some advantages and some disadvantages. 

These options only control the current file. So as you change files, you will 
have to come back to these and check. Of course, if you set these option, 
then save this file as a template, you will not have to check them each time. 

Wireframe

cadmovie1504_06

This is still a rendering mode, and it is the fastest mode to use. You use this 
mode while modeling, setting up views and so on. 

•	 Go to the Menu bar. 

•	 Choose View > Rendering > Wireframe

•	 Go to the Menu bar. 

•	 Choose View > Rendering > Wireframe Options...

http://wp.me/p2BFhB-6sP
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These options allow you to change the appearance of your objects in 
Wireframe, particularly planar objects.

You can access all the rendering types and options from the Menu bar, but I 
find it easier and quicker to use the Rendering menu on the View bar. 

Line Rendering

cadmovie1504_07

These preferences control the options for Hidden Line and Dashed Hidden 
rendering. The line render options also cover the Sketch Rendering 
settings. 

•	 Go to the Menu bar. 

•	 Choose View > Rendering > Line Render Options...

http://wp.me/p2BFhB-6sQ


©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 30

•	 Change the smoothing angle to 20º. The smoothing angle controls the 
facets that you see on a hidden line rendering for curved objects. Setting 
an angle of 20º will show very few of the facets.

•	 Click on the tick to Sketch Hidden Line Results.

•	 Click on the pop-up menu to choose the Document Default Sketch 
Style. I’ve chosen Rough, because that’s the one I like.

•	 Click on the Edit... button. 

•	 These are the default settings.
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•	 Move the sliders to see the changes in the preview.

•	 You might get some strange results.

•	 Move the sliders until you get nice  results. Some sliders need moving a 
lot (like the Randomness), but other sliders need the smallest change you 
can manage (like Wobble and Stroke). 

•	 Click on the OK button to get back to the Line Render Options.
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•	 Click on the OK button. 

This is the view rendered with Hidden Line rendering. The purpose of 
using ‘sketching with hidden lines’ is not to trick the client into thinking 
that you have drawn this by hand. The purpose is to show the client the 
stage of the project, sketch presentation = concept stage. 

This is the view rendered with Dashed Hidden Line.

Dashed Hidden Line has a few options for you to choose from. 

•	 If you have closed the Line Render Options, open them again from the 
Menu bar, View > Rendering > Line Render Options...

•	 Or, you can choose the line render options from the Render Menu: View 
> Rendering > Line Render Options...
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•	 You can choose a different dash style by clicking on the Dash Style 
pop-up menu. 

•	 You can change how dark the dash lines are by sliding the Dash Shade to 
the right. 

•	 You can lighten the lines are by sliding the Dash Shade to the left. 
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This is the view rendered with Dashed Hidden Line.

•	 Notice how much lighter the lines have become.



©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 35

OpenGL

cadmovie1504_08

OpenGL rendering is fast and of a reasonable quality, but it is to not the 
best quality. I sometimes call it quick and dirty, because it is one of the 
fastest rendering modes, but it is not the most accurate. 

•	 Go to the Menu bar.

•	 Choose View > Rendering > OpenGL, or use the rendering menu from 
the View bar.

•	 OpenGL rendering is fast but not very detailed.

•	 Go to the Menu bar.

•	 Choose View > Rendering > OpenGL Options, or use the rendering 
menu from the View bar.

http://wp.me/p2BFhB-6sR
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If you set a high level of detail Vectorworks will take longer to render the 
view. Each of these option will make the view more detailed and therefore 
it will take longer to render.

A higher level of detail and anti-aliasing makes the model look better. 

The latest versions of Vectorworks have the option to Use Shadows.
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If you want to use this option, you must have a light in the file, otherwise 
you will not see the shadows. 

The latest versions of Vectorworks also have the option to Draw Edges.

Some of the complex models look worse with this option though.

•	 Choose your options.

•	 Click on the OK button.

OpenGL is the one rendering mode that keeps the model rendered as you 
use the Flyover or Walkthrough tools. This makes this rendering mode 
valuable. 

Don’t forget that the Lighting Options have an effect on the rendering. If 
you need more information about the Lighting Options, refer to the 
February 2015 manual.  
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Fast Renderworks

cadmovie1504_09

I hardly ever use this rendering mode. It is a step up from OpenGL, and 
there are no options to choose from, but it offers a shadow option. 
Remember, you have to have a light source to get shadows.  

•	 Go to the Menu bar Choose Views > Rendering > Fast Renderworks, 
or use the rendering menu from the View bar.

•	 This is a fast mode, which makes it useful for a quick look. But it is 
similar to OpenGL.

Just remember that this render mode also uses the Lighting Options. If they 
have bee set up to add lots of bounces and environmental lighting, it will 
make the render mode look better, but it will take longer to render. 

The previous image has no lighting options activated.  

http://wp.me/p2BFhB-6sS


©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 39

The next image has several of the lighting options activated. 
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Final Quality Renderworks

cadmovie1504_10

Some people this that this is the best rendering you can get. It is a high 
quality options, but Custom Renderworks can give better results because it 
has access to more choices. You get great quality, but there are no options 
to play with. 

•	 Go to the Menu bar.

•	 Choose Views > Rendering > Final Quality Renderworks,  or use the 
rendering menu from the View bar.

This one of the best rendering options available, but it is also fairly slow. 
Some views can take several minutes. 

remember that this render mode also uses the Lighting Options. If they 
have bee set up to add lots of bounces and environmental lighting, it will 
make the render mode look better, but it will take longer to render. 

The previous image has no lighting options activated.  

http://wp.me/p2BFhB-6sT
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The next image has several of the lighting options activated. 
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Custom Renderworks

cadmovie1504_11

This is the rendering option you should use if you want to have the highest 
quality. This rendering method offers a lot of flexibility, more than any 
other rendering method. It allows you to control all aspects of the quality 
allowing you to balance quality with the time you have available.

•	 Go to the Menu bar. 

•	 Choose Views > Rendering > Custom Renderworks Options..., or use 
the rendering menu from the View bar. 

The Renderworks options control the rendered results. Each of these 
choices can dramatically improve the rendered image, but they will also 
add to the time that it takes to render an image. 

•	 You can create a rendered view without textures, and without color.

•	 This is great for checking shadows if you are rendering an exhibit or 
stage show. 

•	 If you don’t use textures Vectorworks will use the color of the object as 

http://wp.me/p2BFhB-6sU


©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 43

assigned by the attributes palette. Glass will not be transparent if you do 
not turn on the Use Transparency. 

•	 You can choose to use textures, but no color. This option shows the 
reflections and transparency of the textures, but not the colors of the 
textures. 

 

•	  In this image you can see the textures and colors, but no shadows. 

•	 In this image the shows have been activated along with the textures and 
colors. The lack of environmental lighting shows in the  shadow areas, 
they are very harsh. 
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•	 Adding Anti-Aliasing smooths out the jagged edges of the objects. 

•	 In this image Displacement Mapping has been activated. The concrete 
texture has displacement mapping, which are the hollows in the texture. 

•	 This image shows the same view as the previous one, but the rendering 
quality has been sent to very high. There is a pop-up menu called 
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Quality Levels that can be used to change the quality of the rendering. 
Remember that increasing the quality of the rendering will increase the 
time it takes to complete it.

•	 The Lighting Options… have a large impact on the quality of your 
rendering and also the time it takes to complete the rendering.

•	 Click on the Lighting Options… button to access the lighting options 
dialog box. These lighting options have been covered in detail in the 
lighting manual.

http://learn.archoncad.com/2015/02/21542/sst_1502-lighting/
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Indirect Lighting

Indirect lighting is a very powerful addition to Vectorworks. In basic terms 
indirect lighting bounces the light around the scene. You can choose how 
often the light is calculated to bounce around the model. Each time you add 
bounces, the rendering time will increase.

One bounce of indirect lighting is already a dramatic improvement on the 
rendering of the scene. The trade-off is that it does take substantially longer 
to render, but I think the benefits outweigh the cost. 

You will also notice that as you add extra bounces of indirect lighting, the 
overall lighting in the scene goes up as well. A single light source does not 
show the effect of several bounces of light accurately, but when you place 
several lights in a scene you do have to be careful to make sure you render 
it with all of the bounces turned on before you adjust the light intensity.

Environment Lighting

Environmental lighting is background lighting. The background lighting 
can be an image file (High Dynamic Range Image), many come standard 
with Renderworks, or a physical sun (connected to the Heliodon tool).

Environment Lighting settings have to be chosen  carefully as they can 
change the color of a scene considerably.

In this project, HDRI White environmental lighting has been used. This 
background has a white overall color. Although the environmental lighting 
is called a background, in this case is it not adding a background to the 
scene, it is just adding lighting. In this project a Renderworks  background 
has been added to give the impression of a sky, using the HDRI Mostly 
Sunny image as a background. You can choose to have different images for 
the background and environmental lighting. You can see the sky (back-
ground) reflected in the stainless steel sphere. 
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Renderworks Style

cadmovie1504_12

A Renderworks Style is a way of creating a saved set of rendering 
preferences, in a way that you can recall these we needed or store them in 
the library so that you can access these preferences in any project. A 
Renderworks Style is a resource that is available in the resource browser 
for importing, exporting, and editing. Renderworks Styles a very 
productive way of keeping your rendering settings easily accessible.

The options on the Renderworks Style are very similar to the options on 
custom Renderworks.

•	 To create a Renderworks Style, go to the resource browser and click on 
the utility menu to create a new resource.

•	 Choose Renderworks Style… 

•	 This will open a dialog box with several options on it divided into 
different tabs.

•	 The first thing to look at is the pop-up menu for choosing realistic 
rendering or artistic rendering. 

http://wp.me/p2BFhB-6sV
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•	 If you choose artistic rendering then you will find options that of the 
same as the artistic Renderworks options covered later in the manual.

•	 The first tab is for choosing the rendering options. If you choose realistic 
rendering the options a similar to the options we looked at in custom 
Renderworks.

•	 Choose the required options.
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•	 The next tab covers the quality of the rendering. These options a similar 
to the quality options we looked at in Custom Renderworks.

•	 Set the required quality.

•	 The third tab covers the lighting options. Firstly, you can choose to turn 
all the lighting options off, or you can choose to apply them and then 
make choices about the quality of the lighting. These options are similar 
to the options we looked at in the lighting menu (1502). Remember that 
some options will increase the rendering time as well as increasing the 
quality.
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•	 The fourth tab allows you to apply artistic ages to your interview. Not 
everybody likes these artistic edges, you should try them out and see if 
they are suitable for your renderings.

•	 The last tab since the options for the Renderworks Background. You can 
choose the Renderworks Background you require from the list of default 
content, and you can edit the resource by clicking on the Edit 
Resource… button.
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•	 When you have made or your choices for these options, like on the OK 
button to save this Renderworks Style as a resource.

•	 When you look at the resource browser you will see your Renderworks 
Style listed under Render Styles.

•	 To apply this Renderworks Style to review, double-click on the required 
render style in the resource browser and Vectorworks will apply that 
render style to the view. 

•	 The Renderworks Style that I have used in this example includes 
environmental lighting. Initially, Vectorworks will render the view in 
OpenGL rendering.
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•	 Next, Vectorworks will calculate the environmental lighting.

•	 Finally, Vectorworks Will start to show you the final rendered quality.

•	 The time it takes to finish the rendering depends on the power of the 
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processor in your computer. At this stage, Vectorworks Is not using your 
graphics card Vectorworks is using the CPU. In simple terms the more 
powerful your computer, the quicker it is to create your rendered view.

•	 Once you have created a Renderworks Style, you can apply it from the 
rendering menu. This can be applied not only to a design layer view, but 
also to a viewport.

•	 Because the Renderworks Style is a resource, you can right-click on it 
and choose Export…, and add it to another file or your library.  
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•	 If you export this to your user folder, into the folder called Renderworks 
– Render Styles, you will make us Renderworks Style available on any 
project.
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Artistic Renderworks

cadmovie1504_13

• You can choose Renderworks settings from the menu bar, or from the 
view bar.

Artistic Renderworks lets you create an artistic rendering that looks like a 
pencil sketch, cartoon and so on. There are several Artistic Rendering 
modes to choose from, each option has its own settings.	

•	 Go to the View bar.

•	 Click on the Rendering button. 

•	 Choose Artistic Renderworks Options... 
•	 The first step is to choose the required Renderworks Style.

http://wp.me/p2BFhB-6te
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•	 Then edit the options for that style. You might find that subtle change to 
these options can dramatically improve this artistic Renderworks 
Appearance.
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Render Bitmap tool

cadmovie1504_14

Adding extra lights makes rendering slower. If you add bluriness to a 
texture, it will make the rendering take longer as well. This has the effect 
of locking up your computer for 10 or 20 minutes at a time. This is not a 
great use of your time and it complicates decisions in regard of rendering. 
If you need help with textures, refer to the earlier workshop or kindle notes 
on textures. 

You need to bring all these parts together, the rendering, lighting, textures 
and modeling. They all need to work together to make the view come alive.  
As you add textures, lights, background and models to the scene, 
Vectorworks starts taking longer to render the view. 

The answer is to render small areas of your view with the Render Bitmap 
tool. When you render an area with this tool, the result is a bitmap. You can 
leave the bitmap where it is, or you can move it. Sometimes I have several 
images in the drawing as I try to sort out out the lighting, textures, and 
lighting options. 

•	 Go to the Visualization Tool Set. 

•	 Click on the Render Bitmap tool. 

•	 Go to the Tool bar.  

http://wp.me/p2BFhB-6tf


©Jonathan Pickup - http://learn.archoncad.com	
SHORT SHARP TRAINING  - Issue 1504

Page 59

•	 Click on the Preferences button. 

•	 Most people forget to check these, then wonder why the rendering is low 
quality. 

•	 Choose the Render mode from the pop-up menu. 

•	 Click on the Options... to check the various lighting options.. 

•	 Type in the Resolution. The higher the value, the better the quality, but 
the render time will be longer. 

•	 Click on the OK button.

•	 Click once at the desired location to start drawing a rectangle. 

•	 Drag a small area.
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•	 Release the mouse button. 

•	 Vectorworks renders the area of your drawn rectangle.. 

Because you are rendering a small area, it doesn’t take as long. 

I often use this to render lots of small areas of the view to test shadows, 
exposure, reflections, and so on before committing to rendering the entire 
view.  
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Batch Render

cadmovie1504_15

This is the trick to make sure you do not tie up your computer when you 
want to be using it. After you have assigned the light, cameras, models and 
textures, and you have used the Render Bitmap tool to check everything, 
you can set up batch render jobs for your computer to work on while you 
are out on a building site, at meetings, or asleep.   

There are two parts to batch rendering. First you have to define each batch 
render job, then you have to tell Vectorworks which batch render jobs to 
do. 

Create Batch Render Job

•	 Because you are setting the view first, it pays you to set the desired 
perspective view first.

•	 Go to the Menu bar.

•	 Choose View > Rendering > Create Batch Render Job...

•	 Click on the pop-up menu to choose the rendering type. 

•	 Click on the Options... button. These are the options for Custom 
Renderworks. Other rendering mode have different options. 

http://wp.me/p2BFhB-6ti
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If you are happy with the chosen Custom Renderworks Options, click on 
the Lighting Options... button. 

•	 Click on the OK button to return to the Rendering Options.

•	 Click on the OK button to return to the Create Batch Render Job 
dialog.

•	 Click on the Set Export Image File Options... button. 
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•	 It is very important to set the options, otherwise you will get the wrong 
file size, and quality.

•	 Choose Current View.

•	 Choose the file format. I usually use JPEG, but sometimes I use 
Photoshop format. 

•	 Set the Resolution. This works with the page size. Set a reasonable 
resolution and page size, so when you print you have good quality. 

•	 These are the settings I usually use. 
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•	 Click on the OK button.

•	 Name the view. Do not use a name that is already used. 

•	 Set up as many views as you want, from different places, heights and so 
on. 

Start Batch Render Job

When you have all your batch render jobs, you can set Vectorworks to 
export them all. 

•	 Go to the Menu bar.

•	 Choose View > Rendering > Start Batch Render...

•	 Click on the render you want, on the left-hand side. 
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•	 Click on the >> button to add the view to Chosen Jobs. Or, you can 
click on the Choose All button to add them all quickly. 

•	 Click on the Choose... button to choose a destination. 

•	 Click on the OK button. 

•	 Vectorworks tells you the progress. When it finishes, the exported 
images will be in the chosen folder in the format you have selected. 
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Tips

•	 Keep the number of lights you use to a minimum. The more lights you 
add, the longer each rendering will take. Do not add every light that 
would be in the scene in real life. Rendering does not replicate real life, 
it is your interpretation of it. Often, a few lights will give a better result. 

•	 Use a Renderworks Background to help fill in the background. A simple 
sky background will improve an exterior rendering. If you are rendering 
an internal view with windows, the background will help.

•	 For interior rendering, make sure you use reflective textures to reflect the 
lights around the room. Use transparent glass to let the outside light in. If 
the interior has no doors or windows to the outside, turn off the 
envinronment lighting. 

•	 Use symbols for repeatable objects.

•	 Use textures with a bump for lumpy surfaces. 

•	 Use textures with transparency maps for perforated objects. 

•	 Fill in the scene with image props.

•	 Lights should have a realistic falloff.

•	 Indirect lighting makes the rendering look more realistic. 

•	 Use Custom Renderworks. It is flexible and can be very high quality.

•	 Place a directional light for the sun.

•	 If you want to match your model to an existing scene, look at using 
Camera Match, I highly recommend it. CameraMatch will save you a 
great deal of modeling and the rendering results are fantastic. Please 
look at this site for cameramatch, I have written a manual for 
cameramatch which you can download from the website. http://www.
panzercad.com/ 
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Thank you 
Thank you for subscribing. I trust that you have enjoyed working through 
this manual, and that it has been informative and constructive. 

The other part of visualization is lighting and rendering. That will be cov-
ered soon, so look out for that manual on the subscriber web site. 

For more information, please visit this web site: 
http://learn.archoncad.com

If you just want someone to help you learn Vectorworks, carry out some 
Vectorworks contract work, or you want someone to make Vectorworks 
easier, contact me, as this is a service that I offer: 
jon@archoncad.com

Thank you again,
Jonathan Pickup
April 2015
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