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Introduction

There is a lot of talk about Building Information Modeling. It is going to be 
the big thing when using Vectorworks. There are some countries where all 
jobs will be expected to be delivered using BIM principles.

BIM is not just a new catch phrase, it is also a more efficient way of 
creating drawings in Vectorworks. At first it may not seem faster as it looks 
like you have to create a lot of unnecessary information. But it only feels 
that way because this is a new way of working. When you get more used to 
BIM, Vectorworks is much faster in creating building elements like walls, 
doors, windows, etc. Once you have created elevations and sections from 
your elements, most of the work is done. The model is used to create all the 
drawings. But the most powerful part comes when you have to make a 
change to the building. When you change the design and move walls, 
change the roof, etc. you do not have to redraw the elevations and plans. 
The viewports just need to be updated. This is a great time saver, but more 
importantly, it manages risk. With BIM there is no opportunity to have 
different drawings that have different information, all drawings share the 
same model. If you move a door in the model, every drawing that shows 
that door will update automatically.

Vectorworks has a concept called stories that will help you to set up your 
layers. But more than that, stories are powerful at controlling the building 
elements in the layer. You can make walls, columns, and stairs connect to 
the floor above. When you change the settings on the story, the elements 
update automatically. If you setup the file correctly this becomes a 
powerful workflow. 

Starting to work with BIM in mind means that you will have to change 
some of your working methods so that you will reap the benefits 
Vectorworks has to offer.
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Document Setup

cadmovie1021

Start with a New File

For this manual I am going to start with a new blank file. The reason for 
this is so that I can show you how to create a template that will allow you 
to work faster using new methods.

Go to the Menu bar.

Choose File > New...

Choose Create blank document. 

This will create a completely blank document. If you have recently 
upgraded from an earlier version of Vectorworks, it is a good idea to 
rebuild your template, and starting from a blank document is the best way 
to go about it. Because we have a blank document, we do have to go 
through the document settings to make sure they are suitable.

Document Setup

•	 Go to the Menu bar.

•	 Choose File > Document Settings > Document Setup... 

http://wp.me/p2BFhB-45T
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This dialog box allows you to change the major settings for your document 
in one easy to find place. If you save this file as a template, you will not 
have to access this dialog box very often, so it is worthwhile going through 
all the settings to make sure they suit most of your projects.

•	  Go to the Drawing Units and click on the Change… button.

Start by changing your drawing units to suit. If you are using Imperial 
measurements make sure that you set the correct Rounding Style.
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Make sure that you check your Dual Dimension settings. We will not use 
these settings, but they can be useful if you create your own Dimension 
Standards.

When you have set the required dimension settings, click on the OK button 
to return to the Document Settings dialog box.

•	 Go to the Layer Scale and click on the Change… button.

•	 Set your design layer to the most appropriate scale. I use a scale which is 
similar to the final scale of the printed drawings
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•	 Click on the OK button to return to the Document Settings dialog box.

•	 Go to the Drawing Area and click on the Change… button.

•	 Click on the Printer Setup button.

•	 Choose your printer.

•	 Choose your most common page size. 

•	 Choose the page orientation. 

•	 Click on the OK button to return to the Page Setup dialog box. 

•	 Check the page numbers, 1 Horizontal and 1 Vertical. 

•	 Click on the OK button to return to the Document Setup dialog box. 
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•	 Go to the Drawing Grids and click on the Change… button.

•	 Set the drawing grids to suit your drawing style. 

•	 Click on the OK button to return to the Document Setup dialog box. 

•	 Click on the OK button to close the Document Setup dialog box. 
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Layers and Stories

Layers and stories are the keystones of your BIM workflow. Layers are 
used to divide the project and stories are used to group layers. Stories are 
an organizing concept  that groups design layers to make it easy to adjust 
different levels of the building. They also allow you to control building 
elements such as stairs, walls, and so on.  The story settings control the 
elevation of the story relative to other stories. 

 You will find a detailed explanation of stories in the short manual 1201.

cadmovie1022

•	 Go to the View bar.

•	 Click on the Layers... button.

•	 This will open the Organization dialog box.

•	 Click on the Stories tab. 

•	 Since we are using a blank document, we need to edit the Default Story 
Layers to suit our construction methods.

•	 Click on the Default Story Layers... button. 

http://learn.archoncad.com/2012/01/566/short-sharp-training-monthly-issue-1201-setting-up-layers-in-vectorworks/
http://wp.me/p2BFhB-45X
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•	 Start by editing the Floor layer.

•	 Click once on the Floor layer, then click once on the Edit… button.

•	 Click on the Level Type pop-up menu to choose the appropriate level 
type to relate to a floor layer. Vectorworks uses the Finish Floor layer 
type, but you do not have to use this, you can choose any Level Type 
that you want, or you can create your own level types.

•	  Input the standard Elevation for this default story layer. The elevation is 
the height of this layer above the setting out of the story. Sometimes 
Vectorworks  already has an elevation of 100 mm (4 inches). This has 
the effect of setting your layer 4 inches above the start of the story, 
which might be your finished floor level.

•	 I usually change this to an elevation of zero.
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•	 Input your Layer Wall Height. This is the height of your walls on this 
story of the building. Remember though that we can also tell 
Vectorworks to use the floor to floor height (Story Elevation) for setting 
up the wall heights.

•	 Click on the OK button. 

•	 Click once on the Foundation layer, then click once on the Edit… 
button.

•	 Click on the Level Type pop-up menu to choose the appropriate level 
type to relate to a floor layer. 

•	 Input the standard Elevation for this default story layer. The elevation is 
the height of this layer above the setting out of the story. 

•	 Input your Layer Wall Height. 

•	 Click on the OK button to return to the Default Story Layers dialog 
box. 

•	 Click once again on the OK button to return to the Organization dialog 
box.

If you can create Default Story Layers that suit most of your projects, you 
will not have to edit your defaults again if you use this file as a template to 
start your projects.
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•	 Click on the New... button to create a new story. 

•	 If your first story is a foundation, then choose the Foundation layer 
from the list of available layers in the story. 

•	 Change the Name of the Layer. Vectorworks will not automatically 
create a Story-0 story name. 

•	 Change the suffix to 0.

•	 Edit the Story Elevation to suit the start of the foundations. In this 
project I have the elevation for the start of the foundations at -450mm 
(-18”) and a Layer Wall Height of 350mm (14”), leaving a 100mm 
(4”) gap for the slab. 

•	 Click on the OK button to return to the Organization dialog box.

•	 Click on the New... button to create a new story. 
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•	 Choose the required layers. 

•	 Edit the Story Elevation to suit this project. 

•	 Click on the OK button to return to the Organization dialog box.

•	 Click on the New... button to create a new story. 

•	 Choose the required layers. 

•	 Edit the Story Elevation to suit this project. 
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•	 Click on the OK button to return to the Organization dialog box.

•	 Create the required stories. 

•	 Click on the OK button to finish. 
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Creating Walls and Slabs

After setting up the layers and stories, setting up your wall styles is the 
next most important step. For as long as I can remember, walls have had 
the ability to automatically extrude to the Layer Wall Height (∆Z as it 
used to be called), so they have always been fundamental to BIM. 

When you create your Wall Styles you have to remember that they can 
connect to the Story settings, not just the Layer Wall Height. 

Foundation Walls

cadmovie1023

We can start with these walls, because they are the least complex. The 
foundation walls can use the graphic style of the class they are assigned to 
and they can be set up to link to the finished floor of the story above. 

•	 Go to the Building Shell tool set. 

•	 Click on the Wall tool. 

•	 Go to the Tool bar. 

•	 Click on the Wall Preferences button. 

•	 This opens the Wall Preferences dialog box. This is where you can 
create a Wall Style, set the class options, set the wall heights etc.  

•	 Enter the Overall Thickenss of the wall. This wall is 190mm (8”) 
concrete block. 

http://wp.me/p2BFhB-460
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•	 Click on the Edit Wall Attributes button. 

•	 Set all the options to use Use Class Attributes. This will allow you to 
use class overrides in your viewports to change the graphic style of the 
foundation walls. 
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•	 Click on the OK button to return back to the Wall Preferences. 

•	 Click on the Insertion Options tab. 

•	 Set the Top Bound to use Finished Floor (story Above).
•	 Set the Top Offset to suit the floor slab. 

Setting the Top Bound in this way will allow you to adjust the foundation 
wall height by changing the story settings, the walls will automatically 
adjust.

•	 Create a suitable class for the foundation walls using the Class pop-up 
menu. 

•	 Click on the Data tab

•	 Fill in the information you want to record about these walls. 
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•	 Click on the OK button to close the dialog box and return to the 
drawing. 
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Lower Level Walls

cadmovie1024

These walls can be more complex than the foundation walls, we can add 
components to allow us to see the walls more accurately, in plan, elevation 
and section. 

You might be used to just showing the framing on your plans, so it might 
not make sense to show the cladding, cavities and interior lining. However, 
the components can be assigned to classes so you can choose when to see 
the components. 

For example, for the elevation you would want to see the exterior cladding, 
as that could add 100mm (4”) or more to the elevations. You would also 
want to see where the cladding stopped in relation to the floor slab. When 
you have detailed plans of the kitchen and bathrooms you would want to 
see the lining, so it makes sense to add it to the wall style. 

The wall styles can then be added to your library. That way you only have 
to create the wall styles once, but because of the classes on the 
components, you will be able to use walls in multiple places.

•	 Go to the Tool bar. 

•	 Click on the Wall Preferences button again. 

This opens the Wall Preferences dialog box again.   

•	  Click on the New… button to create a new component. 

http://wp.me/p2BFhB-463
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•	 The wall can be created from several components. Each component can 
have its own graphic style, its own class, and its own 3D settings. This 
makes it very powerful if you use components to create your walls.

•	 Name the component.

•	 Choose a class for the component, or create a new class. You will notice 
in this image below that the class is already created and that it follows a 
strategy (Wall-Component-Component Name).

•	 Input the thickness of the component.

•	 Input the Offset from Wall Top and Wall Bottom. The bottom offset is 
used to create that matches the correct offset a component for this 
cladding. The top of set is the same as the bottom offset so that I can 
reuse the same wall style on the next level above.
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•	 Click on the OK button to return to the Wall Preferences dialog box. 

•	 Click on the New… button to create a new component.

•	 Name the component.

•	 Choose a class for the component, or create a new class. 

•	 Input the thickness of the component.

•	 Input the Offset from Wall Top and Wall Bottom. 
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•	 Click on the OK button to return to the Wall Preferences dialog box. 

•	 Click on the New… button to create a new component.

•	 Name the component.

•	 Choose a class for the component, or create a new class. 

•	 Input the thickness of the component and the Offset from Wall Top and 
Wall Bottom. 
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•	 Click on the OK button to return to the Wall Preferences dialog box. 

•	 Click on the New… button to create a new component.

•	 Name the component.

•	 Choose a class for the component, or create a new class. 

•	 Input the thickness of the component and the Offset from Wall Top and 
Wall Bottom. 

•	 Click on the OK button to return to the Wall Preferences dialog box. 
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This has created the settings on the components, now we need to set the 
overall wall Insertion Options. These control the whole wall. 

•	 Click on the Insertion Option tab. 

•	 Click on the Top Bound pop-up menu. 

•	 Choose Finish Floor [Story Above]. This option sets the top of the wall 
to the same height as the floor above. If you edit the story settings, this 
wall will adjust to suit. 
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•	 Set the Bottom Bound to the Layer Elevation. 

•	 Set the Class to a suitable class. 

•	 Click on Data tab. This can be used to fill in data that you want assigned 
to the wall. When you create a report, this information can be returned to 
the report. 

•	 When you have all the settings, click on the button Save Preferences as 
Wall Style. This will allow you to reuse the wall in this file and in other 
files, or export the wall style to your Wall Style Library. 

•	 Type in a suitable name. 

•	 Click on the OK button to save the Wall Style. 
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•	 Click on the OK button again to close the Wall Preferences dialog box. 
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Top Level Walls

cadmovie1025

The top level walls are similar to the rest of the walls in the file, but they 
need to be set up so that the top bounding is not the Finished Floor (Story 
Above). The top level has no story above, so the walls do not know where 
to stop. Vectorworks creates the wall with no height, as you can see in this 
image. 

•	 Start by duplicating the external wall style, using the Resource 
Browser. 

•	 Assign a name to the new wall style.

http://wp.me/p2BFhB-466
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•	 Click on the OK button. 

•	 You are back the Resource Browser.

•	 Right-click (contol-click with a one-button mouse) on the Wall Style. 

•	 Choose Edit...

•	 Click on the Insertion Option tab. 

•	 Click on the Top Bound pop-up menu. 

•	 Choose Layer Wall Height. Since there is no floor above, you can’t use 
the story above. 

•	 Click on Data tab. This can be used to fill in data that you want assigned 
to the wall. When you create a report, this information can be returned to 
the report. 
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•	 When you have all the settings, click on the button Save Preferences as 
Wall Style. 

•	 Type in a suitable name. 

•	 Click on the OK button to save the Wall Style. 

•	 Click on the OK button again to close the Wall Preferences dialog box.

•	 If you have drawn the walls with the original wall style, you will find 
that they have no height. 

•	 Select all the walls.
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•	 Go to the Object Info palette. 

•	 Click on the Wall Style pop-up menu. 

•	 Choose Replace...

•	 Click on the pop-up menu to choose the new wall style. 

•	 Choose the settings for replacing the wall. 
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•	 Click on the OK button to complete the replacement. 
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Use Walls from Library

cadmovie1026

If you store your wall styles in your user folder or workgroup folder, they 
can be selected directly from the pop-up menu on the Tool bar. 
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Slabs for Slabs and Ceilings

cadmovie1027

Like walls, slabs can have components, so you can make slabs and ceilings 
that have several components. The slabs can link to walls and slab 
components can link to the wall components. So it is really important that 
you create your walls and slabs in relation to each other. 

It also means that you have to be careful about which layer you use for 
your slabs and which walls you bound to. A floor slab on grade could 
bound to the walls in the Floor-1 layer, or they could bound to the 
foundation walls in the Floor-0 layer. 

•	 Go to the Building Shell tool set. 

•	 Click on the Slab tool. 

•	 Go to the Tool bar.

•	 Click on the Slab Preferences button, the last button on the tool bar. 

This opens the Slab Preferences dialog box. This is where you set the slab 
thickness, slab components, and data.

http://wp.me/p2BFhB-46e
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•	 If a component has already created, click once on it, then click on the 
Edit... button. 

•	 If there is not a component already, click on the New... button. 

•	 Name the component. 

•	 Input the thickness for the component. 

•	 Click on the pop-up menu to choose the bounding. The choice here 
really depends on the way you want this slab to relate to the walls. If you 
are bounding to the framed walls, you might choose to bound to the 
outside of the wall core. If you are bounding to the foundation walls, you 
could choose to bound to the outside of the outer face of the wall.  
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•	 Choose a suitable class for the component, or create one. If you create a 
new class, set the attributes to suit. 

•	 Check your settings. 

•	 Click on the OK button to finish editing the slab component. 

•	 Click on the Insertion Options tab. 
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•	 Enter the required settings. 

•	 Assign or create a class for the slab style. 

•	 Click on the Data tab. 

•	 Enter the required data.

•	 Click on the button to Save Preferences as Slab Style... 
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•	 Name the new Slab Style.

•	 Go to the Tool bar.

•	 Chose the required option. 

•	 In the Pick Walls mode, you click on each wall to indicate the extent of 
the slab. The picked walls have to form a closed shape. 
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•	 Go to the Tool bar.

•	 Click on the green tick to create the slab. 

•	 Vectorworks creates the slab. 

•	 Check the slab in 3D to make sure it is at the correct elevation. 
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Doors and Windows

cadmovie1028

It is pretty standard to add doors and windows to your project. For a BIM 
project the doors and windows have to be inserted into the walls. If you 
place them correctly Vectorworks will insert them into the wall and edit the 
wall for you to remove the area of the door or window. 

Door Settings

There are a lot of settings to help you get your doors as accurate as 
possible. We will not be looking at all the settings, that would take another 
manual. 

General settings. This is where you set the Size Reference, Configuration, 
Width, Height, etc. 

2D Visualization tab for setting door in plan view. 

http://wp.me/p2BFhB-46h
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ID Tag settings. If you want the door to be included in the schedule you 
must select that option. Also use this area to set the door number and tag 
settings.

The Data tab allows you to edit the data attached to the door, including any 
additional data you want to add. 

Inserting Doors and Windows in 3D - Standard Insertion

The instructions for inserting doors and windows are the same. I have 
shown the images for doors here, but inserting windows is the same.  

•	 Go to the Tool bar.

•	 Click on the Insertion mode you want to use. 

•	 Click on the Alignment mode you want to use. 
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•	 Click once on the wall to insert the door. 

•	 Click once again to set the flip, or swing, of the door. 

Insert all the doors you need. 

Do the same for all the windows.
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Creating Roofs

Creating a Roof from Walls

cadmovie1029

There is more than one way to create the roof, but an easy way to create the 
roof is to use the walls. 

•	 Select the exterior walls. 

Go to the Menu bar.

Choose AEC > Create Roof... If you are using Vectorworks Landmark, go 
to Landmark > AEC > Create Roof...

•	 Fill in the required settings for the roof. 

http://wp.me/p2BFhB-46l
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•	 Click on the OK button. 
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Creating Drawings

cadmovie1030

The core of BIM is that you can create most of your drawings directly from 
the live model. To do this you need to use Sheet Layers and Viewports. If 
you do not know anything about viewports, please have a look at the 
manual on setting up drawings for building projects. Using this strategy, 
plans, elevations, and sections can quickly be updated when you change 
the model. 

I am going to use a really quick shortcut to create a plan and two 
elevations. 

•	 Use the Navigation palette to turn on the required layers. 

•	 Go to the View bar. 

•	 Activate Unified View. This will allow you to see the entire project. 

•	 Go to the Menu bar.

•	 Choose View > Create Multiple Viewports...

http://wp.me/p2BFhB-46n
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•	 Choose the required viewports. 

•	 Set the required scale. 

•	 Click on the OK button to create the viewports. 
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•	 Move the viewports if required, then use the Object Info palette to 
update the viewports, to add shading, and to edit the classes. 
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Creating Reports

cadmovie1031

Another major benefit of BIM is the ability to create a multitude of reports, 
e.g. about objects, areas, and many other data. Vectorworks has a built-in 
worksheet system that you can use to create these reports. If you have 
never seen the Vectorworks worksheeets before, I recommend you have a 
look at the manual Introduction to Worksheets. 		

Electrical

If you want to create a report listing all of your  electrical objects there a 
couple things you have to do. 

You must create Electrical Objects. The easiest way to create these objects 
is to create them as symbols. This is also the most memory efficient way to 
create them.

The objects must also have a database attached to them. Vectorworks calls 
this database a Record Format. When the record format is attached to the 
symbols it can record information that you require.

 To create the report go to the Menu bar.

Click on Tools > Reports > Create Report...
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•	 Name the worksheet.

•	 Choose the required record format. 

•	 Select the required columns. 

•	 Click on the OK button. 

•	 In this image I have formatted the cells and added an image function to 
show the plan view of each electrical type. 
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Wall Report

You can use the same technique to create a report of all the walls.
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Bracing

A more advanced report would be a bracing report. This report picks up all 
the bracing objects in the file, uses the data attached to them, and then  
carries out calculations on the bracing objects. 

There is also a bracing demand worksheet that is used to calculate the 
required bracing. This worksheet then feeds its information to each bracing 
worksheet to ensure that the required amount of bracing is being supplied.

There is almost no limit to the reports you can create. Anything that you 
draw can be reported, provided that you either attach information to it, or 
Vectorworks automatically attaches information to it. 
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Thank you 

We trust that you have enjoyed working through this manual and that it has 
been informative and constructive. 

For more information, please visit: http://learn.archoncad.com/. If you just 
want someone to help you learn Vectorworks, to carry out some Vector-
works contract work, or you want someone to make Vectorworks easier, 
contact us, as this is a service that we also offer:
jon@archoncad.com. 

Thank you again,
Jonathan Pickup
January  2014
   

http://learn.archoncad.com
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