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Preface
Hiero, in conjunction with HieroPlayer, is designed to provide shot management, conform, and
playback capabilities for people creating visual effects, especially those using Foundry’s Nuke
Compositor. Hiero combines well with Nuke to deliver visual effects sequences without resorting to
other third party applications.

Key Features
The following are key features supported by Hiero and HieroPlayer:
• Conform multi-track timelines from CMX 3600 Edit Decision Lists (EDLs), Final Cut Pro XML, and
AAFs including cuts, transitions and retimes.
• Soft import any image sequence type supported by Nuke, meaning the media is not copied multiple
times saving disk space. In addition, Hiero and HieroPlayer can also ingest audio and multi-channel
images.
• Playback clips and sequences in real-time (dependent on hardware) on 2-up source/record Viewers,
including multi-view or stereo footage.
• Version and snapshot clips and sequences to record progress and manage your creative options.
• Add real-time GPU soft effects directly on the timeline before export.
• Round-trip through Nuke or export general purpose shots using soft exports in most cases - no
bakes are required.
• Accomplish most tasks through Python scripting that you can with the Hiero and HieroPlayer user
interfaces.

About this Guide
Throughout this User Guide, we assume you have a basic knowledge of video and audio theory, as
well as proficiency with the operating system on which the application is installed.
For the most up-to-date information, please see the relevant product page and the latest User Guide
on our website at www.foundry.com.

Getting Help
If you can’t find what you need in this document, there are other sources of help available to you for
all aspects of Hiero and its operation.
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Customer Support
Should questions arise that this help fails to address, you can contact Customer Support by visiting
support.foundry.com.

Online Help
Most controls offer concise instructions in the form of tooltips. To display the tooltips, hover your
mouse pointer over an interface control or parameter.

Hiero’s Help menu includes links to the latest Release Notes and www.nukepedia.com, the online
knowledge base maintained by experienced Nuke users, containing downloads, tutorials, interviews
and more.
There is also a user forum at community.foundry.com/discuss/hiero, set up as a hub for users to ask
questions and share information.
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Installation and Licensing
Installing and licensing new applications can be a boring task that you just want to be done with as
soon as possible. To help you with that, this chapter guides you to the point where you have a default
workspace in front of you and are ready to start viewing and editing your media with the minimum of
effort.

System Requirements
Before you do anything else, ensure that whichever platform you intend to run Hiero or HieroPlayer
on meets the following minimum requirements.

Operating System
The following operating systems are supported:

Mac
• macOS 10.13 (High Sierra)
• macOS 10.14 (Mojave)
See Mac OS X and macOS for a list of recommended hardware.

Linux
• CentOS/RHEL 6 64-bit
• CentOS/RHEL 7 64-bit
See Linux for a list of recommended hardware.

Windows
• Windows 7 64-bit
• Windows 10 64-bit
See Windows for a list of recommended hardware.
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Achieving Real-time Playback
The following is a list of recommended hardware configurations for Windows and Linux that Foundry
have certified for real-time playback in the Nuke Studio and Hiero timeline Viewer (see the note
below). Nuke's compositing Viewer is not designed for real-time playback. Please note that playback
may also work on other machine configurations, but those listed below have been tested.

Note: For realtime playback, clips and sequences should be 16-bit RGBA DPX files, localized
to fast storage. See Localizing Media for more information.
In the case of complex or multi-format timelines, files must be cached to the fast storage
using the Timeline Disk Caching. See Caching Frames in the Disk Cache for more
information.

Windows and Linux Certified Hardware
Nuke Studio is currently tested on the HP Z workstation series. The following are the tested
components for an HP Z840.
Processor

2 x Intel Xeon E5-2687Wv3 CPU

RAM

128 GB DDR4-2133 (8x16 GB) 2 CPU Registered RAM

Internal system drives

1 x HP Z Turbo Drive G2 256 GB PCIe

GPU

NVIDIA Quadro M6000 12 GB

Video monitor output

AJA Kona 4K or BMD DeckLink 4K Extreme 12G

Real-time playback is currently tested with the following internal storage accessories:
Drives

8 x Samsung SM863 960 GB

Dock

2 x HP B8K60AA - 4 Bay SSD carrier

Raid card

LSI Megaraid ROC 9270-8i

Raid cable

2 x Avago 05-26113-00 0.6 Meter internal cable SFF8643 To X4 SATA
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HDD (MINI SAS HD)
Raid type

RAID 5, Always write-through, with a 256k Stripe size

The table below shows guidelines for the data rates required for real-time playback of single track,
16-bit RGBA DPX sequences, with no soft effects in Hiero's timeline Viewer. The Data rate is the
required disk speed needed to achieve real-time streaming playback, for a given format, at a given
playback rate.

Note: The sample rates are taken from the AJA System Test application, with the Settings >
Disk Test set to File per frame, and should be used as guidelines only.
The AJA System Test application is available for download for Mac and Windows from
https://www.aja.com/products/aja-system-test

Frames per second (fps) Format
25 fps

30 fps

60 fps

Data rate MB/s

4K Film (4096x3112)

2431.25

4K UHD (3840x2160)

1582.03

2K Film (2048x1556)

607.81

HD 1080p (1920x1080)

395.51

4K Film (4096x3112)

2917.50

4K UHD (3840x2160)

1898.44

2K Film (2048x1556)

729.38

HD 1080p (1920x1080)

474.61

4K Film (4096x3112)

5835.00

4K UHD (3840x2160)

3796.88

2K Film (2048x1556)

1458.75

HD 1080p (1920x1080)

949.22
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Installing Hiero or HieroPlayer
Hiero and HieroPlayer are included in the Nuke application bundle, so you'll need to download the
required Nuke version from www.foundry.com/products/ by choosing the correct platform from the
list. For example, if you intend to install Hiero on Mac, download the Nuke .dmg file.
Follow the on-screen instructions to download the correct installer.

Mac
1. Double-click on the .dmg archive to extract the installation package.
2. Double-click on the .pkg file.
3. Follow the on-screen instructions to install the application. By default, Hiero (contained within the
Nuke bundle) is installed to /Applications/Nuke11.3v6

Linux
1. Extract the application from the .run archive with the following terminal command:
sudo ./Nuke11.3v6-linux-x86-release-64.run
The installer displays the End User Licensing Agreement (EULA) and prompts you to accept it.
2. If you agree with the EULA, enter y and press Enter to accept the EULA. (If you don’t agree with the
EULA and press n instead, the installation is cancelled.)
The selected application is installed in an appropriately named folder in the current working
directory.
If you leave out sudo from the terminal command, you need to ensure that you have sufficient
permissions to install the application under your current working directory.

Note: After the application files have been installed, the installer also runs a postinstallation script that creates the following directory:
/usr/local/foundry/RLM
If you don’t have sufficient permissions on the /usr/local folder for this directory to be
created, the post-installation script prompts you for your sudo password as necessary.

Windows
1. Double-click on the Nuke .exe file.
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2. Follow the on-screen instructions to install the required application. By default, Hiero (contained
within the Nuke bundle) is installed to <drive letter>:\Program Files\Nuke11.3v6

Launching Hiero or HieroPlayer
Launch Hiero or HieroPlayer using one of the following methods, depending on which platform
you’re using.

Mac
• Click the required dock icon.
• Using the Finder, open the Nuke application directory (by default, /Applications/Nuke11.3v6/ and
double-click the required .app icon (or list item).
• Open a terminal and enter the following command:
/Applications/Nuke11.3v6/Nuke11.3v6.app/Contents/MacOS/Nuke11.3v6 --hiero
OR
/Applications/Nuke11.3v6/Nuke11.3v6.app/Contents/MacOS/Nuke11.3v6 --player

Linux
• Double-click the required icon on the Desktop.
• Open a terminal, navigate to the ~/Nuke11.3v6 directory and enter:
./Nuke11.3 --hiero
OR
./Nuke11.3 --player

Note: The ~/ in the file path indicates the directory from which the installer was executed.

Windows
• Double-click the required icon on the Desktop.
• Using a command prompt, navigate to the application directory (by default, \Program
Files\Nuke11.3v6 or \Program Files (x86)\Nuke11.3v6), and enter:
Nuke11.3exe --hiero
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OR
Nuke11.3.exe --player

Hiero Analytics
In an effort to further improve quality and reliability, we ask you to allow us to collect usage statistics
from the machines on which you license Hiero and HieroPlayer. This usage information also assists
our Support team to resolve issues more quickly.

Note: The port number used to communicate with Foundry is 443, the same one used for
uploading crash reports.
The first time you start an application, and on every major release, a dialog displays asking for
permission for us to collect this information. You can enable or disable collection at any time in the
Preferences under Behaviors > Startup.

Note: This information is only collected for interactive sessions. Running applications in
terminal mode or under render licenses does not upload data to Foundry.
The following list shows the information we'll collect, if you give us permission to do so:
• Unique session ID

• Anonymous user key

• Application version string

• Application name

• Session start time (GMT)

• Session duration (in seconds)

• If the session exited cleanly

• Peak memory usage

• Model

• Operating system

• System OS version

• MAC address

• CPU Name

• CPU Cores

• GPU model name

• Amount of GPU RAM

• OpenGL driver version

• GPU driver version

• Amount of RAM

• Memory speed

Startup Options
If you choose to launch the application from a command line, you can append arguments to the
command as follows:
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Argument

Result

--help (-h)

Displays the available arguments with examples.

--version

Displays version and copyright information.

--script

Opens the specified script. For example:
./Nuke11.3v6 --hiero --script myscript.py
If the script resides in a different directory to the application,
specify the file path as well.

--player (Nuke only)

Launches Nuke in HieroPlayer mode.

--log-file

Sets the location of any logfiles created. For example:
./Nuke11.3v6 --hiero --log-file /Desktop/log.txt
See to specify the logfile using an environment variable.

--log-level

Sets the level of logging produced during operation. For example:
./Nuke11.3v6 --hiero --log-level warning
Log messages are output to screen unless you specify a
--log-file. There are four levels of detail, on a sliding scale from
minimal to verbose:
• error
• warning (default)
• message
• verbose

Note: Setting the logging level to verbose can produce
large log files when --log-file is specified.
See to set the log level using an environment variable.
--quiet (-q)

Launch the application without displaying the splash screen or
startup dialog.

--safe (-s)

Launch the application without loading any plug-ins, Export
presets, and so on.
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Argument

Result

--single-threaded-playback

Launch the application in single-thread mode. This option can
solve playback issues on various Linux Fedora flavors.

On Windows, you can also use the same arguments on executables (or their shortcuts) by adding
them to the program’s Properties. To use a startup argument:
1. Right-click the C:\Program Files\Nuke11.3v6 icon or the equivalent icon on the Desktop.
2. Click Properties.
3. Append the required argument to the Target or .exe field.

Licensing Hiero and HieroPlayer
The following licensing methods are available:
• Activation Keys and Node Locked Licenses - these can be used to license an application on a
single machine. They do not work on different machines and if you need them to, you’ll have to
transfer your license.
Node locked licenses, sometimes called uncounted licenses, do not require additional licensing
software to be installed.
• Floating Licenses - also known as counted licenses, enable applications to work on any networked
client machine. The floating license is put on the server and is locked to a unique number on that
server.
Floating licenses on a server requires additional software to be installed on the server to manage
the licenses and give them out to the client stations that want them. This software is called the
Foundry Licensing Tools (FLT) and can be downloaded at no extra cost from our website.
• Subscription Licenses - subscription licensing differs from traditional node locked or floating
licenses in that a single license, or entitlement, is valid on any authorized device up to the
entitlement's maximum number of activations.
These instructions run through the basic options for the first two licensing methods, but you can find
a more detailed description in the Foundry Licensing Tools (FLT) User Guide available on our website:
https://www.foundry.com/licensing

Obtaining Licenses
To obtain a license, you'll need your machine's System ID (sometimes called Host ID or rlmhostid).
Just so you know what a System ID number looks like, here’s an example: 000ea641d7a1.
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Note: Bear in mind that, for floating licenses, you'll need the System ID of the license
server, not the machines on which you intend to run the application.
There are a number of ways you can find out your machine's System ID:
• Launch the application without a license, click Status, and then scroll down the error report until
you see your System ID.
• Download the Foundry License Utility (FLU) from https://www.foundry.com/licensing and run it.
Your System ID is displayed.
• Download the Foundry Licensing Tools (FLT) free of charge from https://www.foundry.com/licensing
and then run C:\Program Files\TheFoundry\LicensingTools7.0\Foundry License Utility.exe
When you know your System ID, you can request a license for Foundry products:
• from Foundry's Sales Department at sales@foundry.com
• from the product pages on our website, such as https://www.foundry.com/products/nuke
• by launching the application without a license and selecting:
• Buy Nuke - opens a web browser directly to our website to purchase a license.
• Try Nuke - displays the 15-day trial license download screen. Enter your Foundry account details
or create a new account and follow the on-screen instructions to receive a trial license.

Note: By default, if you have installed a temporary license, the application displays a dialog
at start-up alerting you to the number of days remaining. If you want to disable this
behavior, you can set the FN_DISABLE_LICENSE_DIALOG environment variable to 1 to
suppress the warning message about imminent license expiration. See Environment
Variables for more information.

Installing Licenses
When you start the application before installing a license, a Licensing dialog displays an error,
informing you that no license was available. The installation process is dependent on what type of
license you requested:
• License file - if you requested a license file, typically foundry.lic, this option allows you to browse
to the file location and install it automatically. See To install a license from disk for more
information.
• Activation Key or license text - if you requested an Activation Key or license by email, this option
allows you to paste the key or license text into the Licensing dialog, which then installs the license
in the correct directory. See To install an Activation Key or license text for more information.
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• A floating license - if you requested a floating license to supply licenses to multiple client
machines, this option allows you enter the server address that supplies the client licenses.

Note: You must install a floating license and additional software on the license server to use
this option.
See To install a floating license for more information.

To install a license from disk
1. Save the license file to a known location on disk.
2. Launch Nuke.
The Licensing dialog displays.
3. Click Install License to display the available license installation options.
4. Click Install from Disk.
5. Browse to the location of the license file.
6. Click Open to install the license automatically in the correct directory.

To install an Activation Key or license text
1. Launch Nuke.
The Licensing dialog displays.
2. Click Install License to display the available license installation options.
3. Click Activation Key / License Text and then either:
• Enter the Activation Key string in place of Insert Activation Key Here. A license key typically
looks something like this:
hiero-0101-77d3-99bd-a977-93e9-8035
OR
• Copy the license text and paste it over the Copy/Paste license text here string. License text
typically looks something like this:
LICENSE foundry hiero_i 2014.1223 permanent 2 share=h min_timeout=30
start=23-jan-2014 issuer=sf issued=23-jan-2014 replace
_ck=6dd78e4c69 sig="60PG452MPDMMM6MJAMRGKNQAN3PEAK8JYTHN45022M0C98H
XFA9N7SAASMRABT8TUJ6FAMX8TWU0"
4. Click Install.
The license is automatically installed on your machine in the correct directory.
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Note: Activation Keys require an internet connection. If you access the internet through a
proxy server and cannot connect to the activation server, you may get an error dialog
prompting you to either:
Click Use Proxy to enter the proxy server name, port number, username, and password.
This enables the application to connect to the activation server and obtain a license. The
license is then installed automatically, or
Click on the web link in the dialog and use the System ID (also known as hostid) provided to
manually activate and install a license.

To install a floating license
If you requested a floating license from Foundry, you will receive your license key (foundry.lic) in an
email or internet download. You should also receive the Foundry License Utility (FLU) application to
help you install the license key on the license server machine. The server manages licenses for the
client machines on your network.

Note: The FLU is also available to download from https://www.foundry.com/licensing
1. Make sure you have saved both the license key (foundry.lic) and the FLU application in the same
directory.
2. Run the FLU application.
The license key automatically appears in the FLU window if the FLU and foundry.lic are in the
same directory.

Tip: If they are not in the same directory, you can either copy and paste the contents of the
license key or drag-and-drop the file into the FLU window.
3. Click Install.
This checks the license file and, provided that the license is valid, installs it into the correct
directory.
4. In order for the floating license to work, you will need to install the Foundry Licensing Tools (FLT)
on the license server machine.
For more information on how to install floating licenses, refer to the FLT User Guide, which you can
download from our website https://www.foundry.com/licensing
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5. Once your license server is up and running, launch Nuke on the client machine.
The Licensing dialog displays
6. Click Install License to display the available install methods.
7. Click Use Server and enter the server address in the field provided. The format for the server
name is: <port>@<servername>, for example, 30001@red.

Note: You must perform steps 5 through 7 on each client machine that requires a Nuke
license from the server.

Tip: If you later need to display the Licensing dialog again, you can select Help > License.

Further Reading
There is a lot to learn about licenses, much of which is beyond the scope of this manual. For more
information on licensing, displaying the System ID number, setting up a floating license server,
adding new license keys and managing license usage across a network, you should read the Foundry
Licensing Tools (FLT) User Guide, which can be downloaded from our website,
https://www.foundry.com/licensing

Uninstalling Hiero or HieroPlayer
To uninstall Hiero or HieroPlayer, following the instructions below, depending on what platform
you're running.

Mac
1. Navigate to Applications and delete the Nuke 11.3v6 folder.
2. Delete, rename, or move your .nuke folder, if it exists.
The .nuke folder is found in your home directory, by default:
/Users/<login name>/.nuke

Note: The .nuke folder may be a hidden folder on your machine. To allow your Mac to
display hidden files and folders, type the following command in the Terminal application,
press Return, and then relaunch the Finder application:
defaults write com.apple.finder AppleShowAllFiles YES
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3. Delete, rename, or move your cached files, which reside in the following directory by default:
/var/tmp/nuke

Note: If you specified an alternate directory using the NUKE_TEMP_DIR environment
variable, purge those files as well as the default location. See Hiero Environment Variables
for more information.

Linux
1. Navigate to /usr/local/ and delete the Nuke 11.3v6 folder.
2. Delete, rename, or move your .nuke folder, if it exists.
The .nuke folder is found in your home directory, by default:
/home/<login name>/.nuke
3. Delete, rename, or move your cached files, which reside in the following directory by default:
/var/tmp/nuke

Note: If you specified an alternate directory using the NUKE_TEMP_DIR environment
variable, purge those files as well as the default location. See Hiero Environment Variables
for more information.

Windows
1. Navigate to Start > All Programs > The Foundry > Nuke11.3v6 and select Uninstall.
The Nuke Uninstall dialog displays.
2. Click Yes to uninstall Nuke.
3. Delete, rename, or move your .nuke folder, if it exists.
The .nuke folder is usually found under the directory pointed to by the HOME environment
variable. If this variable is not set (which is common), the .nuke directory is under the folder
specified by the USERPROFILE environment variable, which is generally one of the following:
drive letter:\Documents and Settings\login name\
drive letter:\Users\login name\
To find out if the HOME and USERPROFILE environment variables are set and where they are
pointing at, enter %HOME% or %USERPROFILE% into the address bar in Windows Explorer. If the
environment variable is set, the folder it’s pointing at is opened. If it’s not set, you get an error.
4. Delete, rename, or move your cached files, which reside in the following directory by default:
~\AppData\Local\Temp\nuke\
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Where ~ is equal to %HOME% or %USERPROFILE% as detailed above.

Note: If you specified an alternate directory using the NUKE_TEMP_DIR environment
variable, purge those files as well as the default location. See Hiero Environment Variables
for more information.
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Hiero and HieroPlayer Workflow
This section describes the main differences between Hiero and HieroPlayer, and an example
collaborative workflow using Nuke.

Hiero
In a typical collaborative project environment, Hiero sits in between edit and grading, and finishing
and delivery, acting as a hub for visual effects. It is used to locate, preview, and then farm media out
to shot-based effects applications (such as Nuke), and take their results and re-integrate them into
the sequences for review and comment.

HieroPlayer
HieroPlayer sits next to your compositing and other shot creation software, allowing artists to view
their work in the context of a timeline. This collaborative workflow allows multiple artists to work on
the same timeline, viewing colleague’s work as well as their own.
See Collaborative Project Case Study for more information.
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Feature Comparison
Designed to work hand-in-hand in different scenarios, Hiero and HieroPlayer share a number of
features, but as the hub, Hiero has a richer feature set than HieroPlayer.
Feature

Hiero

HieroPlayer

Review and Playback - Robust playback & review engine for post production
Multi-track timeline viewing and editorial workspace, including
industry standard tools
Nuke equivalent format support including OpenColorIO
management
Multi-channel audio import and playback
Extensive review toolset including A/B compare, masks, and
color picker
Realtime image scopes including histogram, waveform, and
vector
Media localization and caching
Standard jog and shuttle controls
Track Blending for merging of tracks on the timeline
Annotations in the Viewer and exports for reviewing work in
collaborative projects
Broadcast Monitor support
Editing - Standard tools and layouts for editorial.
Modal editorial tools including equivalent keyboard hotkey
interface
Source/record 2-up Viewer workspace and 3-point editing

USER GUIDE

33

Feature Comparison |

Feature

Hiero

HieroPlayer

Conform - Simple and flexible ingest of cuts from editorial.
Conform multi-track timelines from CMX 3600 Edit Decision
Lists (EDLs), Final Cut Pro XML, and AAFs including cuts,
transitions and retimes
Session-wide spreadsheet containing all sequence events
Shot Management and Export - Manage, distribute and ingest media with ease
Export sequences, timeline shot structures, clip hierarchies, and
EDL/XMLs
Soft Effects directly on the timeline, such as Crop, LUT, and
Transform.
Transcode, copy, and soft link media
Create template Nuke scripts for easy distribution of work
Automatically update VFX shots in context
Version shots and snapshot timelines for review and editing
Hierarchical project and element library management
Tag shots, frames, and sequences for easy filtering of content
including custom metadata
Open and Scriptable Playback Framework - Flexible enough to fit any pipeline
Extensive Python API to accomplish most tasks through Python
scripting that you can with the Hiero and HieroPlayer user
interfaces
Integrated Pyside enabling fine-grained customization of
interface tasks
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Collaborative Project Case Study
Hiero can work effectively as the hub for managing content in a post pipeline. The diagram below
shows a typical workgroup scenario, with Hiero and Nuke at the top as the hub managing a number
of Nuke workstations employing HieroPlayer as a review tool.
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Preparing a Project in Hiero
The first step in Hiero is to conform the EDL or XML from the editor. The conform process pulls
together the required source clips and matches them to events in the EDL or XML. Hiero displays
these events in a spreadsheet which is linked to a timeline showing the corresponding shots. See
Conforming Using Hiero for more information.
Once the conform is complete, you can view your timeline to confirm that the correct clips are
present, check the content using Hiero’s scopes, add reference tracks, and pass on any pertinent
information to the next step in production using tags and notes. See Ingesting Media for more
information.
The next step is to make any minor edits to the timeline, including transitions and retimes, swap or
rename shots, or examine different versions of clips on the timeline. See Managing Timelines and
Versions and Snapshots for more information.
The final step before HieroPlayer steps in is to export and save your project. Exporting from Hiero
and saving the project creates placemarker shots for VFX work in a read-only Hiero project (.hrox
file), preserving the conform work from Hiero. Multiple artists can then work on shots, creating
versions which are then automatically updated in HieroPlayer. See Round-Tripping Using the Export
Dialog for more information.
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Loading a Hiero Project in
HieroPlayer
HieroPlayer is most commonly used to open Hiero projects as read-only copies to preserve conform
work from Nuke. This way, multiple artists can work on a project without worrying about overwriting
a colleagues work.
To open a Hiero project in read-only form:
1. Launch HieroPlayer and navigate to File > Open.

Tip: You may find that the project you require is displayed in the startup dialog under
Recent Projects.
Select the project and click Open to quickly access the project.
2. Locate the required Hiero project using the browser and click Open.
A warning displays informing you that the project is read-only, as it was created in Hiero.

3. Click OK to dismiss the prompt.
4. Opening a Hiero project in HieroPlayer changes the interface highlight color to light blue to
indicate that the project is read-only.
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You can’t delete bins, clips, or shots, or make edits on the timeline when the highlight is light blue.
You can, however, drag source clips on to new tracks on the timeline.
5. To save your work, navigate to File > Save as Player Project. HieroPlayer cannot overwrite Hiero
projects.

Opening a Writable Hiero Project
If you want to open a writable version of a Hiero project, you can open the project and save it as a
HieroPlayer project. HieroPlayer projects are always readable in Hiero, so don’t worry about backward
compatibility.
To open a Hiero project in writable form:
1. Launch HieroPlayer and navigate to File > Open.

Tip: You may find that the project you require is displayed in the startup dialog under
Recent Projects.
Select the project and click Open to quickly access the project.
2. Locate the required Hiero project using the browser and click Open.
A warning displays informing you that the project is read-only, as it was created in Nuke.

3. Click OK to dismiss the prompt.
4. Opening a Hiero project in HieroPlayer changes the interface highlight color to light blue to
indicate that the project is read-only.
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You can’t delete bins, source clips, or shots or make edits on the timeline when the highlight is
light blue.
5. Navigate to File > Save as Player Project and select a save location.
6. The highlight color changes to orange to indicate that the project is now writable.
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Customizing Your Workspace
The application interfaces are customizable using floating panes and show/hide functionality, but
several default workspaces are supplied for your convenience.

Workspace Overview
Hiero and HieroPlayer ship with a number of different workspaces. These are specific layouts that can
be loaded as the current tasks change.
Hiero ships with the following workspaces:
• Hiero’s Conforming workspace is where the bulk of the work you undertake with Hiero is done. The
linked spreadsheet and timeline panes are where you’ll really see the power of Hiero.
• The Editing workspace provides the tools you’ll need to fine-tune your media in Hiero, including 2up source/record Viewers.
• The Reviewing workspace is shared by both applications and is used to confirm your media intent
is fully realized. You can add tags and notes, mark In and Out points on clips and timelines, and
organize your ingested media into bins as required.
• The Timeline workspace is similar to the Conforming workspace, but doesn't include the
spreadsheet pane.
HieroPlayer ships with the following workspaces:
• The Editing workspace provides the tools you’ll need to fine-tune your media, including 2-up
source/record Viewers.
• The Flipbook workspace consists of a Viewer and Project tab and is used primarily as a review tool
in HieroPlayer.
• The Reviewing workspace is shared by both applications and is used to confirm your media intent
is fully realized. You can add tags and notes, mark In and Out points on clips and timelines, and
organize your ingested media into bins as required.
• The Timeline workspace is similar to the Editing workspace, but only include a single source Viewer.

Note: HieroPlayer doesn’t include any Conform functionality and projects loaded from
Hiero can’t be edited unless they’re resaved using File > Save as Player Project.
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When you launch either application, you’re presented with a startup dialog.

The startup dialog allows you to create a new project, open an existing project, or view the User
Guide and website dedicated to Hiero.

Tip: You can disable this dialog by checking Don’t show this dialog again or by toggling it
off in the dialog.
Select the required option or click Close to access the application. Take a moment to familiarize
yourself with the default workspaces.

Hiero’s default Conforming workspace:

HieroPlayer’s default Timeline workspace:
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Feature

Description

Project Tab

You can manage all aspects of your projects and
bins in the Project tab.

Menu Bar

Use the Menu bar to access Hiero’s dropdown
menus.

Bin View

The Bin displays the contents of any selected
Project tab.

Viewer

You can display and review your media in the
Viewer.

Timeline
Info

The timeline info displays the current timeline’s
sequence, media, and metadata information.

Editing
Tools

There is a comprehensive set of editing tools
provided in Hiero and HieroPlayer. See Timeline
Editing Tools for more information.

Hiero

HieroPlayer

Spreadsheet Use the Spreadsheet tab to display the contents of
Tab
the timeline in spreadsheet form. Note that the
spreadsheet and timeline are linked, mirroring any
selections made.
Timeline

The timeline displays the current track including all
shots and any effects that have been added.

Menu Bar Components
The Menu Bar contains various controls, many of which are available through right-click menus,
keyboard shortcuts, and toolbars.
For a full list of keyboard shortcuts, buttons, and menu functions, seeAppendix B: Keyboard
Shortcuts.
You can switch between workspaces by navigating to Window > Workspace and selecting
Conforming, Editing, Reviewing, Flipbooking, or Timeline. Alternatively, you can toggle between the
default workspaces using Shift+F1, Shift+F2, Shift+F3, and so on.
Any custom workspaces you create are added to the end of the list. You can access the first custom
workspace using Shift+F5, and so on.
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Creating Your Own Workspace
Hiero's interface is comprised of any number of panels. Panels act like containers with different tabs;
you can configure panels to contain specific tools, such as the timeline or a Viewer, depending on the
task you are presently performing. The default panel configurations are saved as Workspaces
(referred to as Layouts in Nuke) and include: Conforming, Editing, Reviewing, Flipbooking, and
Timeline. You can easily create your own custom workspace that suits your needs, and then save it as
a custom Workspace for easy recall.
During the customization process, you can:
• Resize your entire workspace or panes independently.
• Split panes to create new work areas, for example two Viewers side-by-side.
• Add and remove panes and tabs as required.
• Float and nest tabs to group similar functions together, for example Histogram, Vector, and
Waveform in the same pane.
• Maximize the pane under the mouse cursor by pressing ` (back tick). Press ` again to return to the
regular interface.
You can create as many workspaces as you require, one for each project you undertake if necessary.
In practice though, you may find that two or three custom workspaces are sufficient.

Tip: You can return to the saved version of a workspace by navigating to Window >
Workspace > Reset Workspace.

Resizing Your Workspace
Resizing the interface, panes, and tabs works in much the same way as other software applications:
• To resize the entire interface, drag the resize handle at the bottom right of the application to the
required width and height.
• To resize individual panes, hover the mouse over the edges of the required area until the cursor
changes to the resize icon. Click and drag the cursor to resize the pane or tab.

Splitting Panes
Splitting panes allows you to organize your workspace into distinct areas delineated by well-defined
borders.
• To split panes, right-click the required pane and select Split Vertical or Split Horizontal.
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Adding and Removing Panes and Tabs
Adding and removing tabs gives you the freedom to personalize your workspace depending on your
current project.
• Add new tabs by:
• Navigating to Window and selecting the required tab. The tab is embedded in its default
position or added to the interface as a floating window,

OR
• Right-clicking the pane in which you want the tab to appear and selecting it from the Windows
dropdown.

• Close any tab that is not required by:
• Clicking the x on the tab’s right-hand side,
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OR
• Right-clicking the tab name and selecting Close Pane or Close Tab.

Floating and Nesting
You can move existing panes and tabs to new locations in the interface (to help you organize your
project).
• Float a pane or tab by:
• Right-clicking the tab name and selecting Float Pane or Float Tab.

OR
• Dragging the required tab from its current location.
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• Nest any floating pane or tab by dragging it to any existing pane.

Tip: Use the orange highlight
where the tab nests.

around the destination pane to help you determine

Saving Workspaces
Once you’re happy with the changes you’ve made to the workspace, navigate to Window >
Workspace > Save Workspace.
Enter a name for the workspace, then click OK to preserve your workspace as a workspace file
(extension .hws).
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Tip: If you save a workspace called Conforming, Editing, Reviewing, Flipbooking, or
Timeline you can override the defaults supplied with either application by clicking Save in
the dialog box.
Delete the workspace you created to restore the default layout.

Loading Workspaces
To use a previously saved workspace, navigate to Window > Workspace and select the custom
workspace name you require.

Tip: Alternatively, you can use the workspace keyboard shortcut Ctrl/Cmd+n (where n is
equal to the number of the custom workspace).
Your pre-saved workspace is loaded.

Deleting Workspaces
You may find that after using Hiero or HieroPlayer on a number of projects, some of the workspaces
you created earlier have been superceded by more useful entries. Delete Workspace allows you to
clear up your saved files, although you can remove the files manually from the save location.
To delete custom workspaces:
1. Navigate to Window > Workspace > Delete Workspace.
2. Select the required workspace from the dropdown menu.

3. Click OK to delete the selected entry.

Workspace Preferences
The Preferences dialog allows you to make global changes to the way the interface behaves every
time you start Hiero or HieroPlayer. Changes you make in the Preferences override any local
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changes when you restart the application. See Appendix A: Preferences

Note: Workspace Preferences are saved in the ~/.nuke/uistate.ini file.
To access the Preferences dialog, either:
• Navigate to Hiero (HieroPlayer) > Preferences (OS X) or Edit > Preferences (Linux and Windows),
or
• Use the Preferences hotkeys Shift+S.

Once you’ve made your selections in the Preference dialog, click OK to save your changes. Bear in
mind that changing some preferences, for example QuickTime decoders, Scopes, and Use RED
Rocket card, require you to restart Nuke before they’re applied.

Note: Click Restore Defaults to return to the default Preference settings.

Optimizing Read and Decode Performance
The Performance preferences enable you to get the best the results from the hardware you’re using
by specifying the number of “threads” used for reading and decoding media.
A thread is, at its most basic level, a series of operations (in this case reading and decoding frames)
that operates concurrently with other sets of operations. Most media is read intensive, but highly
compressed formats like .jpg are decode intensive. Increasing the number of threads can decrease
the time it takes to perform an instruction. For example, decoding a .dpx file using 2 threads, instead
of 1, decodes 2 frames in parallel.
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Hiero defaults to 4 threads per reader, but as a general rule of thumb, you shouldn’t increase the
number of threads above the number of cores in your machine.
You can override the Default number of threads per reader on a format-by-format basis using the
override table in the Preferences.
1. Click the

icon to add an entry to the table.

2. In the Extension column, click the dropdown to select the file extension to override.

3. Enter the Number of threads to use for the selected format.
For example, .jpg files rely heavily on decoding so an override setting between 6 and 8 is
recommended. Setting the default threads per helper to 6 is not advisable, except on high
specification hardware.
4. Click OK to close the Preferences and apply the setting immediately, there is no need to restart
the application, so feel free to experiment to achieve the best combination for your setup.

Using Helper Threads
Hiero and HieroPlayer also include two additional helper thread settings dedicated to OpenEXR and
ARRI files. These helper threads assist the reader threads to improve performance for .exr and .ari
files.
You can change the number of available helpers using the up and down arrows, or by simply entering
the number of required helpers in the fields provided under Preferences > Performance >
Threads/Processes.
In general, the default setting 0 should automatically assign helper threads correctly. If, however, your
project is .exr/.ari heavy you might consider increasing the number of helper threads.

Note: The application must be restarted to apply changes to the ARRI helper setting.
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Using Downsize Sampling
The Viewer Image Quality dropdown affects the decode rate and resolution of clips displayed in the
Viewer. Lower resolutions decode faster and vice versa.
You can customize this behavior by bit-depth using the Preferences > Performance >
Threads/Processes > Downsize filtering controls.
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Ingesting Media
Hiero handles many file formats, including embedded audio and .wav files. For a full list of
supported file formats , see Appendix C: Supported File Formats.
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About Clips and Shots
The interface sorts your clips into three broad categories: Audio and Video, Audio Only, and Video
Only. Clips are displayed differently depending on their content, location, and in the case of the
Viewer, the current mode.

Note: The timeline Viewer currently treats all alpha channels as premultiplied, which can
result in the Viewer background being "added" to the image. If you’re working with unpremultiplied images, set the Viewer background to Black.

Note: There is currently no QuickTime audio support on Linux. Support for audio is
scheduled for a later release.

Source Clips
Source clips are representations of files on disk. Shots on the timeline refer to source clips, so
making changes to a clip in a bin affects all shots that refer to that source clip.

Note: The colored bars under the thumbnail represent the layers available in the clip, in this
case color. Other layers include alpha, depth, and motion, similar to Nuke.
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Shots
Shots are representations of source clips, they are not saved on disk. Making changes to a shot only
affects that instance. See Managing Timelines for more information.

A Source Clip Opened in the Timeline View
Opening a source clip in the timeline view allows you to control its output and add soft effects to the
source clip. Clips opened as timelines always contain all available frames, but you can adjust their
output using the original range controls in the clip's properties or in and out points. See Using In
and Out Markers and Soft Effects for more information.
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Clip and Shot Properties
The Properties contain standard controls similar to Nuke's Read node Properties and formatspecific controls, depending on the selected source clip or shot. You can also control localization for
individual clips and shots using the localization policy dropdown.
See Localizing Media for more information on localization.
If the clip Properties are not displayed in your workspace, double-click a source clip or shot or
navigate to Window > Properties to open them in a floating window.

Note: The Properties panel allows you to override the Preferences and Project Settings
on a per file basis. See Appendix A: Preferences and Project Settings for more information.
As an example, .mov files allow you to control the decoder and ycbcr Matrix for clips, as well as the
standard controls available for all clips. R3D and ARRIRAW media use their own software
development kits (SDKs) to control the extensive settings usually seen on RED and ARRIRAW Cameras.

Note: The RED Decode Resolution and ARRIRAW Resolution and Proxy dropdowns
control the maximum allowed Viewer resolution, overriding the Viewer Image Quality
setting.
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In addition, source clip properties are accessible through the same Python API as Nuke, improving
scripting capabilities and integration into existing pipelines.
You can also add OCIO context Viewer processes to the Viewer color transform dropdown in the
same way as regular Nuke Read and OCIODisplay nodes. See the Nuke Online Help for more
information.

Setting Source Clip Ranges
The original range controls in the source clip/shot Properties panel allows you to set the output
range for source clips when you add them to a sequence as shots. The entire frame range of the clip
is read on import, but altering the original range changes the output of the shot on the timeline.

Note: You can reset source clip to its original frame range at any time by clicking rescan.
Rescanning also appends new frames as they become available.
Changing the original range affects source clips and shots differently. Opening a source clip in the
Viewer, or in the right-click Timeline View, and adjusting the original range limits or extends the clip
to that range of frames.
Extending the range past the original range adds handles, shown in red.
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Adjusting the original range changes the output of any existing shots, but still allows you to trim and
slip the shot range using the available handles. New shots pick up the new original range specified in
the Properties.

Using Relative Paths to Media
Nuke Studio's timeline Read nodes support relative paths in the file control, allowing you to import
media relative to a specific project directory. The Project Settings control this behavior for the
current project.
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Tip: If you want to set the project path for all new projects, navigate to the Preferences
under Project Defaults > General and set the project directory there.
To set a Read file path to a relative location:
1. Open the Project Settings by clicking Project > Edit Settings.
2. Enter the required file path in the Project Directory field.

Tip: Click Hrox Directory to automatically enter an expression that evaluates to the .hrox
location.
3. Double-click the required source clip or shot to display its Properties.
4. In the file field, adjust the path to the relative location of the .hrox project file. For example, if the
project directory and absolute path to the source clip are:
C:/projects/timeline_read/scripts/
C:/projects/timeline_read/footage/renders/shot110/A009C005_101029_
L1O3.%04d.dpx
Then the relative path to the clip is:
./../footage/renders/shot110/A009C005_101029_L1O3.%04d.dpx
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Ingesting Media
Adding media is as simple as drag-and-drop from a file browser or selecting File > Import File(s) or
Import Folder(s). The application imports your media into the bin view providing you with a
thumbnail of all of your clips and preserving the original folder and file hierarchy.
The media is soft imported, creating symbolic links to locations on disk. See Using the Copy Exporter
for information on how to quickly consolidate your media and projects, or Localizing Media to help
stabilize playback.

Note: Projects containing large amounts of movie files (for example .r3d and .mov) may
exceed the number of available file handles per process, causing problems opening new
files or projects and exporting.
You can increase the default limit of 1024 by entering the following command from the
terminal, then running the application from the same session:
ulimit -Sn 2048

Clips with no inherent frame rate information are assigned a frame rate at ingest as specified in the
Preferences.
1. Open the Preferences dialog by pressing Shift+S.
2. Select Behaviors > Timecode from the sub-menu on the left.

3. Use the RED file timecode dropdown to determine R3D clip behavior:
• Default from File - use the default set by the R3D file in question.
• Absolute Timecode - force the use of the Absolute Timecode as specified in the clip metadata.
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• Edge Timecode - force the use of the Edge Timecode as specified in the clip metadata.
4. Use the other media timecode dropdown to determine clip behavior for all other clips:
• File Header - the file metadata header is used to derive the timecode, if it exists. This option
defaults to Frame Number if the header is missing.
• Frame Number - ignores the metadata header, even when present, and derives the timecode
from the frames in the clip.
5. Set the max valid timebase allowed from the image header, above which the value is clamped.
Image files are often created with application specific timebase values in the header description.
This can lead to reading in spuriously high frame rates, and the clamp aims to prevent this from
happening.
If your clips do have extremely high frame rates, increase this value as necessary to avoid
clamping.
6. Enable or disable EDL style spreadsheet timecodes:
• When disabled, the srcOut and dstOut values use the film convention, representing the last
frame of the cut.
• When enabled, the srcOut and dstOut values use the video convention, representing the frame
directly after the cut.
7. Click OK to save your settings.
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Using Drag-and-Drop
Locate your media in a file browser and drag the frame range, clip, folder, or folders into the Project
tab.

Ingest behavior depends on the target:
• Dragging a folder into the Project tab automatically ingests all the contents of the folder, including
other folders and their contents.
• Dragging a movie file, such as a .mov or .r3d, automatically ingests the entire clip.
• Dragging a single file or file range, that is part of an image sequence, is controlled by the
Preferences > Behaviors > File Handling > Scan for file sequence range checkbox:
• Enabled - the default setting, dragging a single file or file range, that is part of an image
sequence, creates a clip in the bin view containing all available frames.
For example, dragging frames 1-5 and 11-20 ingests the entire frame range.
• Disabled - only the dragged frame or range is imported into the bin.
For example, dragging frames 1-5 and 11-20 ingests two distinct clips, one containing 5 frames
and one containing 10 frames.

USER GUIDE

60

Using the File Browser | Using Relative Paths to Media

Using the File Browser
If you prefer to work with menus, you can also import clips using the file browser. You can import
individual clip files, ranges, or entire folders, depending on the amount of media you intend to use.
Whenever you load or save files, a browser similar to the one shown below is displayed. The directory
navigation buttons let you create or access the directory from which you wish to read or write data.

The navigation controls let you move through the directory structure, bookmark favorite directories,
and create new directory folders.

Note: If you import folders, use the Import Options dialog to filter your ingest using
inclusion and exclusion parameters, separated by spaces. The dialog's Include patterns
field defaults to {supportedfiles}, which resolves to a list of all known supported file
extensions. To add your own custom extensions to this, you can use {supportedfiles} *.ext
(replacing .ext with your custom file extension).
Windows only: You can show/hide the drives that Windows auto creates by right-clicking the required
drive, selecting ShowDefaults, and checking or unchecking the drive.
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To Use the Navigation Controls
• Click the Create New Directory button
file hierarchy.
• Click Up one directory

to go up one directory closer to the root.

• Click Previous directory
• Click Next directory

to create a new directory at your current position in the

to go back one directory.
to go forward one directory.

• Click the + button to add a directory bookmark.
• Click the edit button to edit the name or path name to a bookmark.
• Click the - button to remove a directory bookmark.

Path Name Field
The path name field displays the current directory path, lets you navigate to a new path, and also
enter a file name for scripts and rendered images.

• To navigate to a directory, type the path name in the field.
• To enter a script name, browse to a directory path and enter the file name after the displayed path.
• To limit the file list to specific file types, use the filter dropdown menu and Sequences checkbox.
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To Use the Filter Dropdown Menu and Sequences
Checkbox
• Select *.nk to display only Nuke script files.
• Select * to display all files (except hidden files), regardless of what they’re associated with.
• Select .* * to display all files, including hidden files.
• Select */ to display directory names, but not their contents.
• Check sequences to display image sequences as single titles, as in fgelement.####.cin 1-50 rather
than fgelement.0001.cin, fgelement.0002.cin, fgelement. 0003.cin, and so on.

Note: File sequences with no file extension (for example, fgelement.0001, fgelement.0002,
fgelement.0003, and so on) are not displayed as single titles the first time you view the
directory in the File Browser. However, they are displayed as single titles once you have
navigated to another directory and back again.
• You can also split incomplete sequences into separate Read nodes using the split seq checkbox.

To Preview Files in the File Browser
1. Click the black arrow in the top-right corner of the file browser.

The file browser expands to include a small viewer.
2. Select the file you want to preview in the file browser to view it.
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To Select Multiple Files with the File Browser
1. Browse to the folder where the files are located.
2. Ctrl+click on all the files you want to open to select them (Mac users Cmd+click).
3. You can open files from multiple directories by clicking Next and browsing to the next file
location.
4. Click Open.
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All the selected files open.
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Sorting and Searching Media
Nuke Studio's Project panel includes several sorting and searching methods so you can organize,
manage, and navigate through media more easily. You can sort items alphabetically, by type, or
manually and select the appearance of media within bins. The search functionality allows you to enter
strings and apply searches on all or partial matches. You can control the poster frame displayed by
items in the project, selecting either an absolute or relative frame.
You can also color-code items in the Project panel and timeline to quickly sort and locate media. See
Color-coding Source Clips and Shots for more information.

Sorting the Project Panel
The Project panel can be sorted in the left-hand directory side and right-hand file side independently,
though files have more sorting and display options.

In the left-hand directory pane, items are sorted alphabetically in ascending order by default. To sort
project items manually:
1. Click and hold, or right-click, the sorting dropdown and select Manual.
2. Drag-and-drop items into your preferred order.
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The right-hand bin pane is also sorted alphabetically in ascending order by default, and there are
more options available in the sorting dropdown. Click and hold the dropdown to display the various
options, including Duration, Resolution, and Type.

You can also change the layout and size of items in the right-hand bin pane. Choose a layout from
thumbnails, list, and details and use the slider to determine the size of the items. The slider is
disabled in details mode.
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Searching for Media
Nuke Studio's search functionality allows you to enter strings and apply searches on all or partial
matches with the option to include metadata searches. Nuke Studio searches for items that match
any of the input string and displays only those items by default.

Tip: Nuke Studio also examines file metadata for the search string by default, but you can
disable this behavior by disabling Include Metadata in the search dropdown.

• Match All Criteria - media that matches all the entries in the search string are matched. For
example, entering A01 DPX only matches media containing both A01 and DPX.
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• Match Any Criteria - media that matches any of the entries in the search string are matched. Using
the same example, A01 DPX matches any media containing A01 or DPX.

Tip: This functionality extends to the media spreadsheet if you prefer to search for items
there. See About the Media Spreadsheet for more information.
Filtering and flagging produce the same search results, but they are presented differently. Filtering
only displays files that match some or all of the search string, whereas flagging displays all content
and flags files that don't match some or all of the search string.

Filtering ...

... and Flagging

You can also filter and flag media by tag or metadata. See Filtering and Flagging Media Using Tags
and Filtering and Flagging Media Using Metadata for more information.

Setting Poster Frames
You can assign poster frames to image items in the Project panel so that they represent the frames
you intend to use if your sequences. This is particularly useful if your source clips contain handles of
blank frames at the beginning of the footage.
To set a poster frame for source clips:
1. Select the clip or clips in the Project panel.
2. Right-click the selection, and select Set Poster Frame.
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3. Select a preset frame or click Custom to select an absolute or relative frame as the poster frame
for the source clip:
• Absolute - the poster frame number is derived from the file(s) on disk. For example, a .dpx
sequence myClip.####.dpx 1001-1500 can have an absolute poster frame between 1001 and
1500.
• Relative - the poster frame number is derived from the number of frames in the clip starting at
0. For example, a .dpx sequence myClip.####.dpx 1001-1500 can have a relative poster frame
between 0 and 499.

Note: If you select more than one source clip, you can't set an Absolute frame as the poster
frame.
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Color-coding Source Clips and
Shots
In large projects, the Project bin and timeline can quickly become busy and difficult to manage.
Adding colors to items or file types can help you find what you're looking for in bins and sequences.
You can quickly enable and disable colors in the Project panel and timeline in the Preferences
under Panels > Project Items. See the Appendix A: Preferences page under Panels for more
information.
You can set general defaults for items such as bins, sequences, and source clips as well as for specific
file types such as .exr or .mov files. You can also set custom colors for individual selections or groups
using the right-click menu or color picker button at the top left of the Project panel.

Setting Default Colors
Project items have a default color assigned to them by type, such as orange for sequences and gray
for source clips. You can change these assignments using the Preferences > Panels > Project Items
dialog.

Note: You can disable the color scheme in the Project panel, timeline, and spreadsheet at
any time using the display in controls in the Preferences.
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To change a default color, click a button in the Project Items preferences and use the color wheel to
change the color.

You can also set the label color for the Project panel and timeline or change the color used to
indicate the state of a shot on the timeline, such as offline.

Setting Colors by Selection
You can keep track of particular clips and shots by manually assigning them a color of their own. This
custom color overrides any color you set by type. You can set colors on items individually or by
selecting multiple instances in the Project panel or timeline.
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1. In the Project panel or timeline, select the items you want to color.

Tip: The selection tools can help you make multiple selections quickly in the timeline. See
Using the Selection Tools for more information.
2. Right-click the selection and choose Color > Color Picker or click a color under Recent.

Tip: You can also color selections by clicking the

button and picking the color.

3. Click Clear Color to remove any custom colors applied to the selection. The selection reverts to
the default item color set in the Preferences.

Setting Colors by File Type
Another way to organize your project is to assign colors to items by file extension. This custom color
overrides any color you set by item type.
1. Open the Preferences by pressing Shift+S.
2. Navigate to the Panels > Project Items sub-menu.
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3. Under file types, click the

button.

A new entry is added to the file types table.
4. Click the extension dropdown and select the required file type.
5. Double-click the color swatch and select the new color using the color wheel.

6. Click OK to apply your changes.
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Reconnecting and Refreshing
Clips
During the post process, media inevitably changes location or form. You can reload or replace your
media using the reconnect, refresh, and rescan functions.

Though all three options deal with reloading source clips, each has a particular use dependent on
context:
• Reconnect Media - allows you to redirect the filepath when the source file location changes.
• Refresh Clips (F8) - allows you to reload the clip when the source file location has not changed,
such as when work has been done on the clip offline. Selecting refresh only refreshes the clip’s
current frame range.
• Rescan Clip Range (Alt+F5) - similar to Refresh Clips, above, but rescan also checks for additional
frames that may have been added to the source file and adds them to the source clip’s frame range.
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Localizing Media
Hiero has the facility to cache source clips locally, either individually or by setting an automatically
localized folder (NUKE_TEMP_DIR/localize, by default), to help guarantee playback stability. Local
caching is controlled initially in the Preferences dialog, then on a clip-by-clip basis.

Setting Localization Preferences
The Preferences control how Hiero deals with new source clips as they are ingested, but does not
affect existing source clips in the project. If you plan to localize source clips in your project, it's a good
idea to set the Preferences before ingesting your source clips.
1. Press Shift+S to open the Preferences dialog and navigate to Performance > Localization.

2. Set the required localization mode:
• on - checks for updates to source clips for all localization policies, and localizes those files set to
On or From auto-localize path automatically. On demand source clips must always be
localized manually.
• manual - checks for updates to source clips and prompts you to update them manually. Only
those with the policy set to off are not updated.
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• off - no source clips are localized, regardless of the their localization policy.

Note: The current localization mode is displayed in the status bar at the bottom-right of the
interface.

3. Set the default localization policy for new source clips using the dropdown:

Note: The localization policy for existing source clips in the project must be set
individually. See Managing Localization for more information.
• on - always localize source clips with this policy.
• from auto-localize path - localize these source clips automatically if they reside in the autolocalize from directory.
• on demand - only localize these source clips when you manually update them. See Updating On
Demand Clips for more information.
• off - never localize these source clips.
4. Enter a file path for auto-localize from, if required.
Any files that reside in this directory are automatically cached when ingested into Hiero, providing
that the Localization Policy is set to From auto-localize path.
5. Enter a file path for localize to. Leaving this field as the default creates a sub-directory in the
Temp Directory as the local cache.

Note: On Windows, files saved to the localize to directory replace \\ (double back slashes)
and : (colon drive signifiers) with underscores so that the file path works as expected
between operating systems. For example:
\\windowspath\to\my\network\file.dpx is saved as __
windowspath\to\my\network\file.dpx
t:\my\network\path\file.dpx is saved as t_\my\network\path\file.dpx
6. Enter a value for limit to (GB) to control how much disk space is available in the cache directory.

Note: Negative values in this field reserve the specified amount of space at all times. For
example, -2 stops 2 GB of memory being used for caching.
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7. You can specify the time interval (in minutes) before localized files are checked for updates using
the check for updated files every ## mins control.
The default setting checks for new versions of files every 30 minutes, but you can set this control
to any value. Any files that have changed since the last update check are flagged red in the Project
bin.

Tip: You can change the default localization indicators using the Appearance controls.

If read source files when localized files are out of date is enabled, source clips referencing cached
files that have changed since they were localized revert to reading the source files. Source clips that
are reading from the source files are marked with a striped red bar on the clip.
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Enabling hide out of date progress bar hides the localization state of out of date files so that the
source clip appears the same as regular clips.

Note: The out of date localized files are not discarded, disabling read source files when
localized files are out of date picks up the out of date files instead of reading the source
files.

Managing Localization
As well as the overall Preferences for when new source clips should be localized, you can set
localization on a file-by-file basis. The localization policy for any existing source clips in your project
must be managed individually.

Tip: If you find that localization is slow to copy files, you can increase the number of threads
that Nuke uses to process jobs. Set the NUKE_LOCALIZATION_NUMWATCHERS environment
variable to the number of threads you want to use. See the Nuke Online Help for more
information.
To set the localization policy for source clips:
1. Select the clip(s) in the bin view.
2. Right-click and select Localization Policy to display the available options:
• On - the files are localized, regardless of location, as long as the limit to (GB) limit is not
breached.
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• From auto-localize path - the files are localized if they reside in the auto-localize from
directory, as long as the limit to (GB) limit is not breached.
• On Demand - the files are only localized when you update them manually. See Updating On
Demand Clips for more information.
• Off - the files are never localized, regardless of location.
As clips are localized, an amber progress bar displays in the thumbnail. Fully cached clips are
marked with a green bar at the top of the thumbnail and out-of-date clips are marked in red.

Note: Container formats, such as .mov and .r3d, do not display progress bars during
localization. The source clip only shows the green indicator once the entire file is localized
successfully.

Note: Hiero also features a playback cache and timeline disk cache, allowing frames to be
cached in RAM or disk. See Caching Frames in the Playback Cache and Caching Frames in the
Disk Cache for more information.
3. If you need to pause localization temporarily, navigate to Cache > Localization and select Pause.
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4. If you find that your cache is filling up regularly, you can:
• Increase the amount of available space for localization by raising the limit to (GB) preference,
• Navigate to Cache > Localization > Clear Unused Local Files (see Clearing Localized Files), or
• Manually clear files from the cache directory in NUKE_TEMP_DIR/localize, by default.
5. You can force Hiero to check for updated source files, rather than waiting for the check for
updated files every interval to expire, by selecting Force Update for All files, just Selected
source clips, or On Demand only.

Note: Each file has its own update time, which is reset whenever the source files are
checked.
The following table is a quick reference guide to when and how source clips are localized, where:
• green - clips are localized automatically.
• amber - clips are localized when updated manually.
• red - clips are not localized.
Source Clip Preference
System
Preference

on

auto-path

on demand

off

on
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Source Clip Preference
System
Preference

on

auto-path

on demand

off

manual
off

Updating On Demand Clips
Source clips with their localization policy set to on demand are polled to check for updates at the
interval set in the Preferences. If the file has changed, the source clip is marked with a red bar to
show it is out of date.
To update a single on demand source clip:
1. Double-click the source clip in the Project bin to display its Properties.
2. Click Update.

Note: If a Read node's localization policy is set to on demand and it hasn't been localized
previously, clicking the Update button localizes the file.
The local copy of the source clip is updated from the remote source clip.
To update all on demand source clips:
1. Navigate to Localization > Force Update.
2. Click On demand only.
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The local copy of all on demand source clips is updated from the remote source clip.

Clearing Localized Files
Localizing a large amount of files can fill up the localization cache quite quickly if you leave the limit
to (GB) preference at the default 10 GB. When the cache runs out of space, a Failed to Localize File
dialog displays and localization pauses.

You can delete localized files by clicking Delete Unused Local Files (or by navigating to Cache >
Localization > Clear Unused Local Files). Hiero displays a dialog containing all the files that are
marked for delete.

Tip: You can also open the Preferences from this dialog to adjust the localization behavior,
such as increasing the limit to (GB) preference.
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Click Continue to delete the localized files or Cancel to keep the cached files.
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Using the Viewer
Hiero supports two distinct Viewer types: clip and sequence. This chapter describes the difference
between the two and how to use them.

Clip Viewers, sometimes referred to as source Viewers, are marked with the
icon and deal
exclusively with source clips. You can set In and Out points and apply tags to the Viewer, but the
source clips are unaffected.
Sequence Viewers, also known as record Viewers, are marked with the
icon and deal with
sequences and shots on the timeline. You can set In and Out points and apply tags here too, but you
can also edit the shots on the timeline by trimming, retiming, and so on. See Timeline Editing Tools
for more information.
The Editing workspace combines both clip and sequence Viewers by default, enabling you to add
source clips to the timeline using insert and overwrite functions. See Insert, Overwrite, and 3-Point
Editing for more information.

To view your media in a Viewer, simply drag-and-drop a clip or sequence from the Project tab on to a
Viewer input, or double-click the item to send it to the appropriate Viewer.
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Note: The Viewer currently treats all alpha channels as premultiplied, which can result in
the Viewer background being “added” to the image. If you’re working with un-premultiplied
images, set the Viewer background to Black.
See Appendix A: Preferences for more information.

Deleting Media
To remove media from the bin view, select the clip(s) or bin and press Backspace or Delete.
If any of the media is in use in a sequence, the following warning displays:

Click Yes to delete the media from the bin view, but bear in mind that all instances of the deleted
media are removed from your current sequences.

Viewer Tools
The Viewer has two sets of tools for manipulating your media: the Viewer tools and the playback
tools. The Viewer tools, located at the top of the Viewer, are used to affect the mouse pointer as you
move over the Viewer, and to select Viewer preferences:
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Icon

Function

Description

Layers

Select the layer to output to the Viewer, for example forward
motion vectors or disparityL. Only layers available in the clip
are displayed - check the clip’s thumbnail to see at a glance
which layers are present:

- red color layer.
- green color layer.
- blue color layer.
- alpha layer.
- depth layer.
- forward motion vector layers.
- backward motion vector layers.
- all other custom layers, such as disparity.

Note: You can scroll through available layers using
PgUp or PgDn.
Channels

Select the channel(s) to output to the Viewer, for example
RGB, single channel, Alpha, or Luma.

Viewer color
transform

Set the colorspace used to display images in the Viewer, for
example sRGB and rec709.

Note: If you have specified an OpenColorIO
configuration file in the Preferences, you may have
more colorspace choices available.
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Icon

Function

Description

A/B

Viewer
Output

Click the A or B dropdown and select what you want to view.
This can be selected tracks or tracks with selected tags.
When both Viewer buffers contain an image, enable wipe to
compare the two images. You can also use the center drop
down to set the blend mode between images in the Viewer,
for example Onion Skin or Difference, and the A/B buffer
configuration.

Guides

Enable or disable Viewer overlays:
• title safe - any text intended for the audience should reside
within this zone.
• action safe - any visual elements intended for the audience
should reside within this zone.
• format center - adds a crosshair in the center of the format
currently in the Viewer.
• Format - adds a red, format-dependent box for the clip or
sequence in the Viewer. Sequences support multi-format
clips, see Viewing Multi-Format Timelines for more
information.

Mask

Enable or disable a range of Viewer masks, for example 16:9
or 1.85:1.

Clipping

Enable or disable Viewer warnings:
• No Warnings - all clipping warnings are disabled.
• Exposure - alerts you when the image is under (blue) or over
(red) exposed.

Annotations

Click to enable the Annotations tool bar. Annotations allow
you draw and add text to clips in the Viewer. See Annotations
for more information.

Note: The Annotations button also controls existing
annotation visibility.
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Icon

Function

Description

ROI

Click and drag to define a Region of Interest (ROI) in the
Viewer. The scopes only display information within the ROI,
when active.

Pause
playback caching

Pause or release Viewer playback caching, indicated by the
green bar under the Viewer.

Scale

Set the scale applied to the clip in the Viewer, for example
25%, 75%, or Fit.

Image Quality

Set the Viewer image quality, for example 1:1, 1:4, or 1:16. The
default setting, Auto, resizes the image dependent on the
Viewer zoom level, which may re-cache the image at a higher
resolution.

Note: Image quality, or proxy, for RED clips is
dependent on the clip’s Decode Resolution in the
Media panel.
For example, if you're viewing a 4K file and the
Decode Resolution is set to Half Premium, a 1:1
proxy value is equal to 2K, 1:2 is equal to 1K, and so
on.
Non RT Playback

Sets the Viewer playback mode:
• Play All Frames - the default setting, plays all frames in realtime (dependent on hardware).
• Skip Frames - plays frames in real-time skipping where
necessary to maintain the frame rate.
• Play All Frames, Buffering - plays all frames by buffering
and playing frames back as they become available.

See through missing When disabled, any offline media on a timeline is treated as a
media
blank clip so the Viewer cannot display the track underneath.
This setting also applies to missing frames within a clip.

Note: This control only affects the current Viewer.
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Icon

Function

Description

View

Select the Viewer display mode, for example Audio and Video
or Video Only.

Obey Alpha

Allows you to control the alpha channel independent of the
Viewer Blend Mode.
• Enabled - any alpha channel present in the image is treated
as premultiplied transparency.
• Disabled - the alpha channel is ignored.

Audio latency

Sets the audio latency, in milliseconds, for the current Viewer
only. Audio latency allows you to correct audio and video
synchronization by changing the point at which audio
playback starts.
Positive values cause the audio track to start earlier in relation
to the video track, and vice versa.

Gain

Adjusts the gain applied to the linear input image before
viewing, but doesn’t affect your exported image.

Gamma

Adjusts the gamma applied to the image after the viewing
transform, but doesn’t affect your exported image.

Mute / Audio

Click to mute audio output for the current Viewer or use the
slider to control the audio output level.

Tip: You can also control volume on a per track and
per shot basis. See Audio and the Timeline for more
information.
Color
Sample

Enable or disable the RGBA color information bar in the
Viewer.

Note: The Color Sample tool displays color
information from the source file, not the colorspace
selected in the Viewer color transform dropdown.
See Working with Colorspaces for more information.
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Timeline Playback Tools
There are many useful tools at the top of the Viewer, some of which allow you to select channels,
adjust gain and gamma, and zoom and scale down the image in the Viewer.

For more information about the tools above the Viewer, see Viewer Tools.
The tools at the bottom of the Viewer allow you to adjust the playback settings, including setting the
frame range, selecting the playback mode, and locking the Viewer playback range.
Drag the orange marker along the timeline to quickly cue to a specific frame or timecode. The
number of the current frame or timecode appears below the center of the timeline. You can also cue
to a frame or timecode by typing its number directly into this field.

Tip: The current frame and in an out point fields accept simple mathematical functions,
such as +/-20 to jump forward or backward 20 frames or +/-00002000 to jump forward or
backward 20 seconds.

By default, Hiero automatically adjusts the timeline of every Viewer window to show the frame range
defined in your Project Settings. If no frame range is defined, the frame range of the first image you
read in is used as the global frame range.
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Viewer timeline controls also have a frame range source dropdown menu that you can use to define
where the timeline gets its frame range from. You can set this menu to Global, Input, or Custom.
Global is the default setting described above.
The playback rate field (frames-per-second) initially displays the project’s playback speed. Hiero
attempts to maintain this speed throughout playback, although this adjusts depending on the
resolution of the imagery and your hardware configuration.

Note: The asterisk (*) denotes the Sequence playback speed selected using the Frame
Rate dropdown or, for new projects, the Project Settings > Sequence > Frame Rate
dropdown.

In and Out Points
In and Out markers enable you to alter the duration of a clip to just the portions of the source that
you require.
When a clip containing In and Out points is added to a timeline, you can slip the clip around the
markers to adjust the clip’s output. See Timeline Editing Tools for more information.
You can also use In and Out points to export certain portions of a clip or sequence. See Transcoding
for more information.
To set In and Out markers:
1. Right-click on the required clip or sequence and select Open In > Timeline View.
Clips opened in a timeline have a purple background in the timeline.
2. Move the playhead to the location of the In point and press I on your keyboard.
The In point is marked by the In tab and the time is recorded in the playback controls.
3. Move the playhead to the location of the Out point and press O on your keyboard.
The Out point is marked by the Out tab and the time is recorded in the playback controls.

Note: You can also set markers by navigating to View > Mark In or Mark Out, by using the
Timeline menu to Mark Selection or Mark Clip dependent on clip selections on the
timeline, or by right-clicking a shots and selecting Open In > Viewer.
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Click and drag the markers to adjust their position, or hold Ctrl/Cmd to move both markers at once,
retaining their relative positions. A Viewer preview shows the current frame for the selected marker(s)
and a timecode/frame popup helps to set the new position.

Clear the markers from your clip by navigating to Viewer > ClearIn Point (Alt+I) and Clear OutPoint
(Alt+O). The markers are removed completely, but you can reapply them by repositioning the
playhead and pressing I or O.

Tip: You can also press Alt+U to remove both markers at once.
When the playhead is positioned near In and Out markers, the top half of the timecode scale controls
the playhead and bottom half controls the markers.
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Playback Controls
The playback rate field (frames-per-second) initially displays the project’s playback speed. The Viewer
attempts to maintain this speed throughout playback, although this adjusts depending on the
resolution of the imagery and your hardware configuration.
The following table lists the functions of the playback buttons:
Buttons

Functions
The Play backward and Play forward buttons play the sequence
backward or forward at the script’s frame rate. When you press a play
buttons, it toggles to a stop a button.
The Back 1 Frame and Forward 1 Frame buttons cue the sequence to
the previous or next frame.
The Previous keyframe and Next keyframe buttons cue the sequence
to the script’s previous or next keyframe.
The First frame and Last frame buttons cue the sequence to the first
and last frame.
The Frame Increment field allow you to specify the number of frames
by which the Previous increment/Next increment buttons cue the
sequence. This is set to 10 frames by default.

The J, K, and L keyboard shortcuts also control playback. The K keyboard shortcut is mapped to
Pause/Play. J and L are mapped to backward and forward. Combinations are also supported:
• K+J - frame backward.
• K+L - frame forward.
• K+drag in the top third of the Viewer - standard jog controls. Dragging the cursor left and right
moves the playhead backward and forward, frame-by-frame.
• The jog controls also detect rotary motion to jog through frames. Clockwise motion in the top third
of the Viewer, while holding K, advances the playhead and anti-clockwise reverses the playhead.
• K+drag in the middle third of the Viewer - standard shuttle controls. Dragging the cursor left and
right plays backward and forward, with increased frame rate toward the edges of the Viewer.
• K+drag in the bottom third of the Viewer - skips the playhead to absolute timeline position.
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The Playback Mode button lets you control how many times and in what direction the Viewer plays
back the sequence. Click the button to toggle between the following modes:
Button

Function
Repeatedly plays the sequence in a loop.

Repeatedly plays the image back and forth from head to tail.

Plays once through the section between in and out point and stops at the out
point. If these are not marked, then it plays from the beginning to the end of
the sequence.
Plays once from the beginning to the end of the sequence, ignoring any in and
out points.
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Viewer Tools
The Viewer has two sets of tools for manipulating your media: the Viewer tools and the playback
tools. The Viewer tools, located at the top of the Viewer, are used to affect the mouse pointer as you
move over the Viewer, and to select Viewer preferences:
Icon

Function

Description

Layers

Select the layer to output to the Viewer, for example forward
motion vectors or disparityL. Only layers available in the clip
are displayed - check the clip’s thumbnail to see at a glance
which layers are present:

- red color layer.
- green color layer.
- blue color layer.
- alpha layer.
- depth layer.
- forward motion vector layers.
- backward motion vector layers.
- all other custom layers, such as disparity.

Note: You can scroll through available layers using
PgUp or PgDn.
Channels

Select the channel(s) to output to the Viewer, for example
RGB, single channel, Alpha, or Luma.
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Icon

Function

Description

Viewer color
transform

Set the colorspace used to display images in the Viewer, for
example sRGB and rec709.

Note: If you have specified an OpenColorIO
configuration file in the Preferences, you may have
more colorspace choices available.
A/B

Viewer
Output

Click the A or B dropdown and select what you want to view.
This can be selected tracks or tracks with selected tags.
When both Viewer buffers contain an image, enable wipe to
compare the two images. You can also use the center drop
down to set the blend mode between images in the Viewer,
for example Onion Skin or Difference, and the A/B buffer
configuration.

Guides

Enable or disable Viewer overlays:
• title safe - any text intended for the audience should reside
within this zone.
• action safe - any visual elements intended for the audience
should reside within this zone.
• format center - adds a crosshair in the center of the format
currently in the Viewer.
• Format - adds a red, format-dependent box for the clip or
sequence in the Viewer. Sequences support multi-format
clips, see Viewing Multi-Format Timelines for more
information.

Mask

Enable or disable a range of Viewer masks, for example 16:9
or 1.85:1.

Clipping

Enable or disable Viewer warnings:
• No Warnings - all clipping warnings are disabled.
• Exposure - alerts you when the image is under (blue) or over
(red) exposed.
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Icon

Function

Description

Annotations

Click to enable the Annotations tool bar. Annotations allow
you draw and add text to clips in the Viewer. See Annotations
for more information.

Note: The Annotations button also controls existing
annotation visibility.
ROI

Click and drag to define a Region of Interest (ROI) in the
Viewer. The scopes only display information within the ROI,
when active.

Pause
playback caching

Pause or release Viewer playback caching, indicated by the
green bar under the Viewer.

Scale

Set the scale applied to the clip in the Viewer, for example
25%, 75%, or Fit.

Image Quality

Set the Viewer image quality, for example 1:1, 1:4, or 1:16. The
default setting, Auto, resizes the image dependent on the
Viewer zoom level, which may re-cache the image at a higher
resolution.

Note: Image quality, or proxy, for RED clips is
dependent on the clip’s Decode Resolution in the
Media panel.
For example, if you're viewing a 4K file and the
Decode Resolution is set to Half Premium, a 1:1
proxy value is equal to 2K, 1:2 is equal to 1K, and so
on.
Non RT Playback

Sets the Viewer playback mode:
• Play All Frames - the default setting, plays all frames in realtime (dependent on hardware).
• Skip Frames - plays frames in real-time skipping where
necessary to maintain the frame rate.
• Play All Frames, Buffering - plays all frames by buffering
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Icon

Function

Description
and playing frames back as they become available.

See through missing When disabled, any offline media on a timeline is treated as a
media
blank clip so the Viewer cannot display the track underneath.
This setting also applies to missing frames within a clip.

Note: This control only affects the current Viewer.
View

Select the Viewer display mode, for example Audio and Video
or Video Only.

Obey Alpha

Allows you to control the alpha channel independent of the
Viewer Blend Mode.
• Enabled - any alpha channel present in the image is treated
as premultiplied transparency.
• Disabled - the alpha channel is ignored.

Audio latency

Sets the audio latency, in milliseconds, for the current Viewer
only. Audio latency allows you to correct audio and video
synchronization by changing the point at which audio
playback starts.
Positive values cause the audio track to start earlier in relation
to the video track, and vice versa.

Gain

Adjusts the gain applied to the linear input image before
viewing, but doesn’t affect your exported image.

Gamma

Adjusts the gamma applied to the image after the viewing
transform, but doesn’t affect your exported image.

Mute / Audio

Click to mute audio output for the current Viewer or use the
slider to control the audio output level.

Tip: You can also control volume on a per track and
per shot basis. See Audio and the Timeline for more
information.
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Icon

Function

Description

Color
Sample

Enable or disable the RGBA color information bar in the
Viewer.

Note: The Color Sample tool displays color
information from the source file, not the colorspace
selected in the Viewer color transform dropdown.
See Working with Colorspaces for more information.

Using In and Out Markers
In and Out markers enable you to alter the duration of a clip to just the portions of the source or
sequence that you require.

Tip: You can use the source clip/shot properties original range controls in similar way to In
and Out points. See Setting Source Clip Ranges for more information.
When a clip containing In and Out points is added to a timeline, you can slip the clip around the
markers to adjust the clip’s output. See Timeline Editing Tools for more information. You can also use
In and Out points to export certain portions of a clip or sequence. SeeTranscoding for more
information.
To set In and Out markers:
1. Right-click on the required clip or sequence and select Open In > Timeline View.

Tip: Source clips opened in the timeline view have a purple background in the timeline.
2. Move the playhead to the location of the In point and press I on your keyboard.
The In point is marked by the In tab and the time is recorded in the playback controls.
3. Move the playhead to the location of the Out point and press O on your keyboard.
The Out point is marked by the Out tab and the time is recorded in the playback controls.
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Note: You can also set markers by navigating to View > Mark In or Mark Out, by using the
Timeline menu to Mark Selection or Mark Clip dependent on clip selections on the
timeline, or by right-clicking a shots and selecting Open In > Viewer.
Click and drag the markers to adjust their position, or hold Ctrl/Cmd to move both markers at once,
retaining their relative positions. A Viewer preview shows the current frame for the selected marker(s)
and a timecode/frame popup helps to set the new position.

Clear the markers from your clip by navigating to View > ClearIn Point (Alt+I) and Clear OutPoint
(Alt+O). The markers are removed completely, but you can reapply them by repositioning the
playhead and pressing I or O.

Tip: You can also press Alt+U to remove both markers at once.
When the playhead is positioned near In and Out markers, the top half of the timecode scale controls
the playhead and bottom half controls the markers.
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Using In and Out Markers
In and Out markers enable you to alter the duration of a clip to just the portions of the source or
sequence that you require.

Tip: You can use the source clip/shot properties original range controls in similar way to In
and Out points. See Setting Source Clip Ranges for more information.
When a clip containing In and Out points is added to a timeline, you can slip the clip around the
markers to adjust the clip’s output. See Timeline Editing Tools for more information. You can also use
In and Out points to export certain portions of a clip or sequence. See Transcoding for more
information.
To set In and Out markers:
1. Right-click on the required clip or sequence and select Open In > Timeline View.

Tip: Source clips opened in the timeline view have a purple background in the timeline.
2. Move the playhead to the location of the In point and press I on your keyboard.
The In point is marked by the In tab and the time is recorded in the playback controls.
3. Move the playhead to the location of the Out point and press O on your keyboard.
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The Out point is marked by the Out tab and the time is recorded in the playback controls.

Note: You can also set markers by navigating to View > Mark In or Mark Out, by using the
Timeline menu to Mark Selection or Mark Clip dependent on clip selections on the
timeline, or by right-clicking a shots and selecting Open In > Viewer.
Click and drag the markers to adjust their position, or hold Ctrl/Cmd to move both markers at once,
retaining their relative positions. A Viewer preview shows the current frame for the selected marker(s)
and a timecode/frame popup helps to set the new position.

Clear the markers from your clip by navigating to View > Clear In Point (Alt+I) and Clear Out Point
(Alt+O). The markers are removed completely, but you can reapply them by repositioning the
playhead and pressing I or O.

Tip: You can also press Alt+U to remove both markers at once.
When the playhead is positioned near In and Out markers, the top half of the timecode scale controls
the playhead and bottom half controls the markers.
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Working with Colorspaces
Colorspace changes are applicable to clips in bins and shots, as well as in the Viewer using the Media
tab.
To apply colorspace changes to clips in bins:
1. Select the clip or clips in the bin view.
2. Right-click a selected clip and navigate to Set Media Color Transform.

The current colorspace is highlighted with a tick mark.
3. Select the colorspace to apply to the clip selection.

Note: Only colorspaces applicable to the selection are displayed. For example, REDspace
and LogC - CameraNative are only available for R3D and ARRIRAW clips, respectively.
4. Selecting multiple formats supporting different colorspaces, for example R3Ds and ARRIRAW,
breaks the available LUTs into sub-menus:
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To apply colorspace changes to shots:
1. Select the item(s) on the timeline.
2. Right-click a selected item and navigate to Set Media Color Transform.
3. Select the colorspace to apply to the selection.
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Previewing on a Broadcast
Monitor
The Monitor Out feature allows you to preview Viewer images and audio on an external broadcast
video monitor to check the final result, including the correct colorspace and aspect ratio. This option
requires additional hardware, such as a monitor output card or a FireWire port.

Note: Audio scrubbing is not currently available through monitor output cards. Audio
scrubbing is only supported through internal audio output devices.
Our monitor out architecture interfaces directly with the AJA and BlackMagic device drivers, which are
unified across their respective hardware lines, meaning all current supported cards for the versions
detailed in Appendix D: External Software should work. We've tested the following AJA and
Blackmagic hardware:
AJA Card:

KONA LHi

KONA 3G

KONA 4

KONA iOXT

Formats
SD
HD
2K
UHD
4K
BNC
HDMI
Stereoscopic Support
No

Yes

Yes

No

Platforms
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AJA Card:

KONA LHi
Win, Mac, Linux

KONA 3G
Win, Mac, Linux

KONA 4
Win, Linux

KONA iOXT
Mac 10.9 and
10.10

Drivers
• Windows - 12.5.1 • Windows - 12.5.1 • Windows - 12.5.1 Mac - 12.5.1
• Mac - 12.5.1

• Mac - 12.5.1

• Linux - 12.5.2.7

• Linux - 12.5.2.7

• Linux - 12.5.2.7

Note: The following should be taken into account when using the Monitor Out functionality
with AJA cards:
If you're running AJA cards on Linux, you can contact www.aja.com/support to obtain the
correct drivers.
12-bit monitor output is only supported with dual connection cards, that is cards with two
physical connections, not dual links combining two separate streams of data.
Hiero is unable to send out the right eye separately using the 2nd output cable of KONA 3G
cards. Instead, both views are sent through the 1st output and can be viewed using the sideby-side, anaglyph, and interlacing options.

Blackmagic Card:

DeckLink SDI

DeckLink HD
Extreme 2

DeckLink
Extreme 3D+

Intensity Pro 4K

Formats
SD
HD
2K
UHD
4K
BNC
HDMI
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Blackmagic Card:

DeckLink SDI

DeckLink HD
Extreme 2

DeckLink
Extreme 3D+

Intensity Pro 4K

Stereoscopic Support
No

No

Yes

No

Win, Mac, Linux

Win, Mac, Linux

Win, Mac, Linux

Win, Mac, Linux

Desktop Video
10.7 to 10.8.4

Desktop Video
10.7 to 10.8.4

Desktop Video
10.7 to 10.8.4

Desktop Video
10.7 to 10.8.4

Platforms

Drivers

Blackmagic Card:

DeckLink Studio 4K

DeckLink 4K Extreme

DeckLink 4K Extreme
12G

Yes

Yes

Formats
SD
HD
2K
UHD
4K
BNC
HDMI
Stereoscopic Support
Yes
(Both views through
one output, so the Full
Resolution option is
not available.)
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Blackmagic Card:

DeckLink Studio 4K

DeckLink 4K Extreme

DeckLink 4K Extreme
12G

Win, Mac, Linux

Win, Mac, Linux

Win, Mac, Linux

Desktop Video 10.7 to
10.8.4

Desktop Video 10.7 to
10.8.4

Desktop Video 10.7 to
10.8.4

Platforms

Drivers

Some monitor out cards allow you to extend or mirror your desktop so that Hiero’s user interface is
visible on the monitor. Please refer to your card’s documentation for more information.

To preview output on an external broadcast video monitor:
1. Navigate to Window > Monitor Output.
The Monitor Output toolbar displays in a floating pane.

Note: If you're working with multi-view footage, additional controls display to determine the
stereo mode and view to output.

See Stereoscopic and Multi-View Projects for more information.
2. Select the external device you want to use from the output device dropdown. All available devices
are automatically detected and listed in this menu, along with the following default options:
• None - disables the monitor out feed.
• Floating Window - opens a pseudo output monitor window, without the need for a monitor
device and card. This is intended for full-screen use without displaying any of the interface.
3. Select the Viewer to feed to the output monitor using the source viewer dropdown. Selecting
Active Viewer always displays the current Viewer.
4. Select the view mode using the A/B selection dropdown.
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Note: For multi-view/stereo footage, selecting A/B mode in this dropdown forces the
monitor to output the timeline Viewer settings and the view to output controls are disabled.

5. Click

to apply the active Viewer’s filtering, gamma, and gain to the monitor output.

6. Click

to flip the output vertically.

7. Click
to switch between full-range 0-255 (default) and 16-236 (ITU-R BT.610-4). This button can
correct the image output for certain monitor out cards.
8. Select the colorspace to apply to the image. If you’ve specified an OCIO configuration file in the
preferences, these custom LUTs are also applicable.

Note: If you plan to use the OCIO config file specified during exports, ensure that the
Preferences > Project Defaults > Color Management > Export > use OCIO nodes when
exporting to a Comp checkbox is enabled.
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Using Scopes
Hiero provides scopes to help you evaluate your media. There are a number of global controls
(Preferences > Panels > Scopes) that affect how the Scopes display information:
• black point - sets the black out of range warning level.
• white point - sets the white out of range warning level.
• luma/chroma encoding - sets the video standard to use when converting RGB to luma or chroma
values in the scope displays, either REC601 or REC709.
• Include viewer color transforms - when enabled, scope data includes the applied Viewer color
transforms (gain, gamma, and LUT). When disabled, scope data does not include the applied Viewer
color transforms. This may slow down rendering, as it may require image calculation.
• Force full frame - When enabled, scopes display data for the full frame, regardless of what portion
of that frame is displayed in the Viewer. When disabled, scopes only display data for the current
area requested by the Viewer rather than the full frame.
To open a scope, navigate to Window > New Scope and select the required scope from the list.

Histogram
The Histogram provides three color channel and luma channel information that describes the
distribution of red, green, blue, and luma pixels throughout the current frame.
The Histogram graphs the number of pixels at each brightness level, and from left to right, the areas
of the Histogram represent shadow, mid tones, and highlights.
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Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.
There are also Viewer and Channel selection controls on the Histogram tab:
• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate
Histogram output to the required clip.
The default value, Active Viewer, automatically displays details on the last Viewer you selected.
• Channel selection - select the channels to output. The default setting displays RGB, but you can
also view channels separately.
• Mode selection - select the mode to output. The default setting displays ganged RGB, but you can
also view the channels separately.
• Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.
Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.
For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

The scopes feature global customizable guides to help you view your clips. Navigate to Preferences >
Panels > Scopes and enter values between 0 and 1 for the Black and White points. Note that this
also sets the values for the Waveform display.
The guides at the edges of the Histogram turn red to warn you when the distribution is out of range:
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Waveform
The Waveform scope provides information on clip luminance, or brightness, which you can use to
decide whether the clip is over or under exposed. The white traces represent luminance values from 0
- 100% (black through the spectrum to white). The higher the waveform, the brighter the image in the
Viewer.

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.
The upper white marker is used to measure when over exposure could be a problem. If your
waveform has a lot of traces over the white marker, you should consider reducing the brightness of
the clip. The opposite is true of the lower black marker.
There are also Viewer and Mode selection controls on the Waveform tab:
• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate
Waveform output to the required clip.
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The default value, Active Viewer, automatically displays details on the last Viewer you selected.
• Channel selection - select the channels to output. The default setting displays RGB, but you can
also view channels separately.
• Mode selection - select the mode to output. The default setting displays ganged RGB, but you can
also view the channels separately.
• Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.
Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.
For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

The scopes feature global customizable guides to help you view your clips. Navigate to Preferences >
Panels > Scopes and enter values between 0 and 1 for the Black and White points. Note that this
also sets the values for the Histogram display.
The guides at the top and bottom of the Waveform turn red to warn you when the distribution is out
of range:
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Vector
The Vector scope displays color, saturation, and hue information for the current frame. Similar to
color wheels, Vector scopes display information radially, from the center outward. The farther from
the center the data spans, the more saturation is represented.
In the image on the left, you can see that the frame represented contains mostly yellows and reds,
but the values are not oversaturated. The image on the right represents a badly saturated frame.
Notice the spill of red traces distributed toward the edge of the scope pass the target (the highlighted
square).

Normal saturation.

High Saturation.

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.
There is also a Viewer selection control and Current View label on the Vectorscope tab:
• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Vector
scope output to the required clip.
The default value, Active Viewer, automatically displays details on the last Viewer you selected.
• Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.
Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.
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For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

Waveform
The Waveform scope provides information on clip luminance, or brightness, which you can use to
decide whether the clip is over or under exposed. The white traces represent luminance values from 0
- 100% (black through the spectrum to white). The higher the waveform, the brighter the image in the
Viewer.

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.
The upper white marker is used to measure when over exposure could be a problem. If your
waveform has a lot of traces over the white marker, you should consider reducing the brightness of
the clip. The opposite is true of the lower black marker.
There are also Viewer and Mode selection controls on the Waveform tab:
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• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate
Waveform output to the required clip.
The default value, Active Viewer, automatically displays details on the last Viewer you selected.
• Channel selection - select the channels to output. The default setting displays RGB, but you can
also view channels separately.
• Mode selection - select the mode to output. The default setting displays ganged RGB, but you can
also view the channels separately.
• Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.
Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.
For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

The scopes feature global customizable guides to help you view your clips. Navigate to Preferences >
Panels > Scopes and enter values between 0 and 1 for the Black and White points. Note that this
also sets the values for the Histogram display.
The guides at the top and bottom of the Waveform turn red to warn you when the distribution is out
of range:
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Vector
The Vector scope displays color, saturation, and hue information for the current frame. Similar to
color wheels, Vector scopes display information radially, from the center outward. The farther from
the center the data spans, the more saturation is represented.
In the image on the left, you can see that the frame represented contains mostly yellows and reds,
but the values are not oversaturated. The image on the right represents a badly saturated frame.
Notice the spill of red traces distributed toward the edge of the scope pass the target (the highlighted
square).

Normal saturation.

High Saturation.

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.
There is also a Viewer selection control and Current View label on the Vectorscope tab:
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• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Vector
scope output to the required clip.
The default value, Active Viewer, automatically displays details on the last Viewer you selected.
• Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.
Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.
For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:
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About Anamorphic Media
The Viewer automatically recognizes anamorphic clips and displays them with the correct aspect
ratio.
If for any reason you want to display an anamorphic clip with a 1:1 aspect ratio, right-click in the
Viewer displaying the clip and enable the Ignore Pixel Aspect checkbox, or use the Ctrl/Cmd+Shift+P
keyboard shortcut.

USER GUIDE

121

About QuickTime Media | Vector

About QuickTime Media
Working with .mov files can be unpredictable when compared to other formats, so Hiero gives you a
few QuickTime options when reading and writing .mov files.
Hiero attempts to select the ’best fit’ combination by reading an extended list of metadata key/value
pairs from the QuickTime header, including nclc atom, gama atom, and ProRes codec headers.
If you place a clip in the Viewer, or open a shot in the Viewer, and open the Media tab, you'll see that
Hiero has a number of media-specific controls that you can manually override if the 'best fit' is not
what you're looking for:

• YCbCr Matrix - sets the way Y’CbCr is converted to RGB. You can choose to use the new Rec 601 and
Rec 709 or the Legacy encoding methods, which are the methods used previously in Hiero.
• Codec - sets the codec used to read (write already had a similar control) the QuickTime file.
The codec dropdown defaults to a codec appropriate for the QuickTime in question, where
available, and only lists those that declare themselves able to read the file.
• Pixel Format - sets the read and write pixel format, which includes bit depth, colorspace, pixel
packing, and ranges.
This setting defaults to the best format accepted by the codec, allowing Nuke to perform the
conversion to RGB without the use of an unknown QuickTime transform, where possible. RGB pixel
types rely on QuickTime to do the conversion from Y’CbCr when dealing with a non-RGB codec.
In addition to the nclc, gama, and ProRes data Hiero, and by extension Nuke, also write additional
metadata into the file headers during export, retaining your QuickTime preferences. This combined
metadata represents myriad potential QuickTimes preferences, so Hiero reads the available metadata
in the following order, reverting down each level as the level above is unavailable or set to a reserved
or unknown value:
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• Foundry-specific metadata
• ProRes header data
• nclc atom data
• gama atom data
• The defaults associated with the chosen codec
In this way, the worst case scenario is that you end up with the chosen codec class' default values.
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About RED Media
When working with RED clips, using a RED Rocket card can increase the rendering speed significantly,
especially at higher resolutions.

Note: The RED Rocket icon is only visible if you have a RED Rocket installed.
The RED Rocket icon has three states:
Inactive - the RED Rocket card is inactive.

Firmware error - there is a problem with the card firmware. Hover the mouse over the icon
for more information.
Active - the RED Rocket card is present and active.

To modify the RED Rocket options:
1. Click the

icon in the Viewer.

Note: You must have use RED Rocket enabled in the Preferences > Performance >
Hardware dialog to access these options. See Appendix A: Preferences for more
information.
The RED Rocket Settings dialog displays.

2. Temporarily disable the RED Rocket card by deselecting Use RED Rocket card. Unlike the option
in the Preferences dialog, changing this setting does not affect the application at startup.
3. Click OK to save your settings.
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Note: Projects containing large amounts of movie files (for example .r3d and .mov) may
exceed the number of available file handles per process, causing problems opening new
files or projects and exporting.
You can increase the default limit of 1024 by entering the following command from the
terminal, then running the application from the same session:
ulimit -Sn 2048

Synching to VBlank on Linux
Hiero automatically accounts for tearing that can occur due to NVIDIA and OpenGL issues on Linux,
but with dual screen setups, you need to specify which screen to synchronize. The __GL_SYNC_
DISPLAY_DEVICE environment variable enables you to specify the sync device by appending the
screen device name to the variable.
To determine your screen names:
1. From a command line, enter:
nvidia-settings
The NVIDIA X Server Settings dialog box displays.

2. Open up the GPU dropdown to display the screen device names.

3. Make a note of the device names, for example, DFP-0 or CRT-1.
Set the __GL_SYNC_DISPLAY_DEVICE environment variable value to the device name as described
in Setting Environment Variables.
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Using Tags
Tags are used by Hiero to quickly sort or filter clips and shots for better visibility, organization, and
export. Tags are used to mark shots of a particular type or content as you organize your project. The
default tags supplied include Approved, Note, Reference, and other general purpose tags. You can
also create custom tags by right-clicking in the Tags tab or by pressing Ctrl/Cmd+Y in the Tags tab.
You can apply tags to clips, shots and Comp shots, individual frames, sequences, and tracks.

Clip and shot tags and notes can be added to exports using the burn-in feature. See Adding Burn-in
Text to Exports for more information.
Tags can also be converted to Final Cut Pro or Premiere markers during export to XML. See Exporting
EDLs and XMLs for more information.

Using Quick Tags
Quick tags allow you to add tags, depending on context, by right-clicking a selection and then
choosing the type of tag to apply. If you’re tagging a large amount of media, you might find it more
convenient to use the drag-and-drop methods described later on.
Quick tags are accessible from bins, spreadsheets, Viewers, and timelines for single or multiple
selections.
1. Select the target clips or sequences.
2. Right-click a highlighted selection, go to Tags, and choose the required action, dependent on
context.
For example, bin items only allow you to Tag Selection, whereas shots allow you to Tag Shot
Selection, Tag Tracks, or Tag this Sequence
Once you’ve selected the tag type, the Add Tag dialog displays.

3. Select the icon to represent the tag using the Icon dropdown.
4. Enter a Name and Note as required.
5. Click Add to mark your selections with the chosen tag.
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SeeCreating Custom Tags and Removing Tags for more information.
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Tagging Using the Viewer
To apply a tag using the Viewer:
1. Click the Tags tab, or navigate to Window > Tags.
The Tags panel displays.
2. Drag-and-drop the required tag from the Tags panel to the Viewer.

Depending on whether you’re looking at a clip or sequence, drop the tag on Tag this frame, Tag
whole clip, or Tag whole sequence as required.
Tags applied to frames appear above the playback tools in the Viewer frame slider.

Tip: You can use Alt+Shift+left and right arrows to skip to the previous or next tag on the
current clip. You can also reposition tags by dragging them along the Viewer timeline.
Tags applied to clips are displayed above the Viewer.
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Tagging Shots
To apply a tag to a shot on the timeline:
1. Click the Tags tab, or navigate to Window > Tags.
The Tags panel displays.
2. Drag-and-drop the required tag from the Tags panel to the timeline.
Depending on where the tag is dropped, you’ll mark a shot (or items if you make multiple
selections) or a track.

Tags applied to shots appear on the right of the selected item(s) on the timeline.

Tags applied to tracks appear in the track header on the left of the timeline.
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Adding Notes to Tags
In some cases, a simple tag on a frame or clip may not contain all the information that you wish to
pass on to the next stage of production. Adding notes to a tag can provide that extra detail.

Warning: To delete a note, don’t click the - button because this refers to the tag. Instead,
simply delete the notes in the window and click outside the note dialog.
1. Add notes to tags by clicking on the required tag and entering text or editing the metadata keys
and values.
The example shows a note and metadata key “Artist” added to a clip tag, but you can add notes to
frame and timeline tags in the same way.

2. Click outside the dialog to save the note.
Hiero allows you to “hide” tags using the Python API. Hidden tags are not displayed in the interface,
unless you enable Show Hidden in the Tags popup, but the notes and metadata are still accessible.

Navigate to Help > Documentation > Hiero Python Developer's Guide for more information on
creating hidden tags.
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Filtering and Flagging Media Using Tags
You can search for clips containing certain tags, for example, if you wanted to find all clips that you
tagged as Approved.
There are two types of tag search you can perform: Filter and Flag. Select the desired search type by
clicking the magnifier icon in the Project tab.
• Filter - displays all objects that contain the specified tag. This is the default search method.
• Flag - displays all objects and marks the items that don’t match the search tag.
Drag the required tag from the Tags panel into the search box and select the bin or bins you want to
Filter or Flag.

Tip: If you have more than one search criteria, click the icons in the search box to display a
brief description of the icons.
Filters and flags persist until you change the search criteria or click the x icon in the search
box.
The following examples show Filtering a bin to display only clips with the Notes tag applied and
Flagging all clips that don’t have the Notes tag applied.

Filtering ...

... Flagging.
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Creating Custom Tags
You may find that you require a specific tag or suite of tags that are not provided by default. Creating
custom tags allows you to really control the organization of your media, and you can even create your
own tag icons.

Note: Custom tags can only be created in the Tags panel.
To create a custom tag:
1. Click the Tags tab, or navigate to Window > Tags.
2. Select your project and navigate to Project > New Tag, or press Ctrl/Cmd+Y.
The new tag is placed in the selected project.
3. Double-click the tag to open the Edit Tag dialog box.
4. Click the Icon dropdown menu to select an icon for the custom tag.

Tip: You can import your own image for the tag by selecting Custom to open the browser.
5. Enter a description for the tag in the Name field.
6. Click OK to save your changes.
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Removing Tags
To remove a tag from a frame or shot, click the tag and then click

.

You can remove all tags from a source clip or selection of clips by right-clicking your selections in the
bin and choosing Tags > Clear Tags.

To remove a tag from a track or shot, click on a tag icon and select the required tag to remove.
Click

to remove your selection.
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Viewing Metadata
Metadata is information that describes media content, separate from the clip itself, in the form of a
table on the Metadata tab. Types of metadata include Duration, File Size, and the Path to the
location of the source media.

Source Clip and Shot Metadata
To view metadata for a source clip, right-click the clip and select Open In > Metadata View, or press
Alt+D.
To view metadata for a shot, select the Metadata tab in the timeline panel and click on the item to
examine.

Tip: You may have to add the Metadata tab manually by clicking the
Window > Metadata.

icon and selecting
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Filtering and Flagging Media
Using Metadata
If searching your project using tags has not filtered your media effectively, you can search for clips
containing certain metadata. For example, if you wanted to find all clips that had a particular
resolution or frame rate.
To filter or flag using metadata:
1. Right-click the clip that contains the required metadata key and select Open In > Metadata View,
or press Alt+D.
2. Drag-and-drop the required key from the Metadata panel to the bin view search box.

3. Use the metadata key as a filter or flag as described in Filtering and Flagging Media Using Tags.
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Conforming Using Hiero
Conforming describes the process of matching up the footage from a shoot with the required edit
decisions to create a meaningful timeline. Hiero accepts sequences either from EDLs (edit decision
lists), AAFs (advanced authoring format), or Final Cut Pro XML files from a specified directory
structure containing the source media files. Hiero attempts to conform the media, warning you if
there are missing media.

Hiero conforms EDLs into single tracks, and AAFs and XMLs into multi-track timelines. You can either
conform into a brand new timeline, or into an existing timeline by adding new tracks. For example,
when conforming multiple EDLs into the same timeline, you would add new tracks for each EDL
sequence conformed.
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Project Settings
A good place to start work is by defining default Project Settings before importing sequences,
particularly in the case of EDLs as they may not contain frame rate information. Project Settings only
apply to the current project and override Preferences settings.

Note: You can modify Project Settings later on, for example, when you’re ingesting media.
To define Project Settings:
1. Navigate to Project > Edit Settings.
The Project Settings dialog displays.
2. Click the General sub-menu to set the project Name.
3. Enter a Project Directory if required. This is the location of the .hrox project file and can be used
as the root of the project if you want to use relative paths to source clips. See About Clips and
Shots for more information.
If you want this setting to apply to all new projects, use the Preferences > Project Defaults >
General panel settings.

Tip: Click Hrox Directory to automatically enter an expression that evaluates to the .hrox
location.
4. Set the Poster Frame used by Project bin clips or use the default First frame. See Setting Poster
Frames for more information.
5. Click the Sequence sub-menu to set the default Output Resolution, Frame Rate, and Start
Timecode for new timelines in the current project, and set clip formatting when new clips are
added to the timeline.
6. Click the Views sub-menu to set up multi-view or stereo projects. See Stereoscopic and MultiView Projects for more information.
7. Click the Color Management sub-menu to manage the display and file colorspaces for this
project.
See Color Management Settings for more information.

Tip: Use the options in Preferences > Project Defaults > Color Management to apply
them to all new projects.

USER GUIDE

138

Project Settings | Color Management Settings

8. Click the RED Settings sub-menu to define the Default Video Decode Mode for new R3D files in
the current project. This setting overrides the Preferences > Behaviors > File Handling > default
red clip video decode mode control for existing projects. SeeAppendix A: Preferences for more
information.

Note: Changing this setting does not change the decode setting for R3D media that has
already been imported.
The dropdown contains a sliding resolution scale from FullPremium to SixteenthGood, but bear
in mind that higher resolutions are slower to decode.
9. Lastly, click the Export/Roundtrip sub-menu to select:
• External Media Track Name - sets the default name of the track created when exported media
is brought back into Nuke Studio.
• Export Directory - sets whether the Project Directory, if specified, or a custom directory is
used for exports. If no Project Directory is specified, the project root in the Export dialog is
used.
If you want this setting to apply to all new projects, use the Preferences > Project Defaults >
General panel settings.
• Custom Export Directory - when Export Directory is set to custom, enter the required custom
export directory.
• Shot Preset - sets the default preset to use when exporting.

Color Management Settings
Hiero uses OpenColorIO for color management. All of the colorspaces in Hiero, whether those
shipped with the application or custom colorspaces are defined in OCIO config files.
Depending on the OCIO config file that you are working with, there are a number of colorspace
options and roles (aliases to colorspaces) that you can set in Hiero. There are also default options,
which change depending on what file type you are working with. When the default option is selected,
the colorspace that Hiero has set for it is listed in brackets.

Tip: Use the options in Preferences > Project Defaults > Color Management to apply
them to all new projects.
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1. Set the OpenColorIO Config you want to use for this project.
Hiero ships with a number of default configurations, but you can:
• use a custom OCIO config file by selecting custom from the OpenColorIO Config dropdown
and then entering the file path, or
• add your own config to your .nuke file. See Adding OCIO Configurations for more information.
Changing the configuration updates the Default Color Transforms accordingly. If the selected
configuration is invalid for certain transforms, a warning displays. For example, if you choose the
shipped iff configuration, the 8-bit and 16-bit transforms are not compatible.

In this case, the non-compatible transforms are set to the raw colorspace.
2. The Working Space transform determines what colorspace files should be converted to, on
import, and from, during export - it's the colorspace used by Hiero under the hood.

Note: In earlier releases of Hiero, this colorspace was hidden because linear was always
chosen as the Working Space. You may find that some operations work better in
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colorspaces other than linear. For example, some transforms work better in the CLog
colorspace.

3. You can use Default Color Transforms dropdown menus to override how clips in the Viewer,
thumbnails, and so on are converted to and from the Working Space.
4. The Nuke Script Project Settings dropdown determines whether Hiero uses the LUTs read from
the configuration specified or the Nuke native LUTs during export. Selecting OCIO makes the
relevant OCIO LUTs available to the Read and Write nodes in scripts on a per project basis.
All configurations except nuke-default automatically switch this control to OCIO.
When the Nuke is selected, Reads and Writes work the same as in previous versions of Nuke, with no
integrated OCIO transforms. When OCIO is selected:
• Reads and Writes use OCIO transforms, with no Nuke built-in LUTs applied to the image.
• Read and Write colorspace controls are populated with the list of colorspaces defined in your
currently selected OCIO config.
• The default LUT settings dropdowns are also populated with the list of colorspaces or display
transforms defined in your OCIO config. The default value for each menu match the defaults in a
Hiero project with the same config. These defaults can be overridden using Python callbacks. See
the following path for the default implementation that ships with Nuke:
<install_dir>/plugins/nuke/colorspaces.py
• The working space dropdown allows you to change the colorspace that Nuke uses internally for its
image processing. This automatically sets the in colorspace of Write nodes and Viewer Processes,
and the out colorspace for Read nodes. This defaults to the scene linear role defined in your OCIO
config.
• Hiero-created comps no longer contain automatically injected OCIOColorspace nodes. Instead, OCIO
Color Management is automatically set in the comp’s Project Settings, and the correct OCIO
colorspace is set directly into the Read and Write nodes.

Adding OCIO Configurations
You can add your own OCIO configurations to Hiero as they become available, such as new versions
of ACES. You can also add legacy configs for backward compatibility.
1. Navigate to the location of your .nuke file as shown by platform. You may have to create a .nuke
folder if it doesn't exist.
• Linux: /users/login name/.nuke
• Mac: /Users/login name/.nuke
• Windows: ~\.nuke
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Note: On Windows, the .nuke folder can be found under the directory pointed to by the
HOME environment variable. If this variable is not set (which is common), the .nuke
directory is under the folder specified by the USERPROFILE environment variable - which is
generally of the form drive letter:\Documents and Settings\login name\ or drive
letter:\Users\login name\
To find out if the HOME and USERPROFILE environment variables are set and where they are
pointing at, enter %HOME% or %USERPROFILE% into the address bar in Windows Explorer.
If the environment variable is set, the folder it’s pointing at is opened.
2. Recreate the following structure within your .nuke folder:
~/plugins/OCIOConfigs/configs/<config name>
3. Copy the contents of the config into the config name named folder. There should be a luts folder
and .ocio file at the bare minimum.
4. If Hiero is already running, relaunch the application to apply the change.
5. You can now select your configuration from the Project Settings > Color Management >
OpenColorIO Config dropdown.
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Importing Sequences
Hiero allows you to import your EDL, XML, or AAF sequences in one of two ways, depending on your
preferences. Either:
• Navigate to File > Import EDL/XML/AAF, use the browser to locate the EDL, XML, or AAF, and then
select the file and click Open to import the sequence,
OR
• Drag-and-drop the EDL, XML, or AAF files directly from a file browser into the interface.

If you’re importing an EDL, bear in mind that there is no guaranteed frame rate information included
in the file, so an Import Options dialog displays.

1. Select the correct frame rate and use the following check boxes, if required:
• Drop Frame - when enabled, the EDL is assumed to contain drop file information. SeeTimeline
Playback Tools for more information.
• Assume differences in source/destination durations indicate a retime - when enabled, any
disparity between the source clip (Src) and shot (Dst) duration is treated as a retime.
2. Click OK to import.
XMLs and AAFs imported into Hiero support transform, crop, and retime edit decisions
implemented in third-party applications, such as Adobe Premiere, Apple Final Cut Pro, and Avid
Media Composer. The information in the .xml or .aaf is interpreted using soft effects, such as
Transform and Crop. Non-linear retimes are represented by TimeWarp effects. Constant linear
retimes are handled in the same way as in previous versions of Hiero. See Notes on AAF
Sequences for more information.

USER GUIDE

143

Importing Sequences | Adding OCIO Configurations

Note: Non-linear animation curves from .xml may not appear as expected when imported.
As a result, you may need to adjust the handles on curves to match footage between
keyframes in the Curve Editor or Dope Sheet.
See the Nuke User Guide, Getting Started, Using the Compositing Environment, Animating
Parameter section or the Nuke Online Help for more information.
Additionally, Premiere Pro .xml exports only support constant, linear retimes. As a result,
retimed shots on the Nuke Studio timeline may not match those on the Premier Pro
timeline, because certain non-linear retime data is not written into the exported .xml file.
After importing the EDL, AAF, or XML the Conforming workspace displays and the spreadsheet and
timeline are populated with offline clips - media with an unknown location.

Note: The Event column represents the clip’s position on the timeline, not its event number
from the edit.

Notice that clicking entries in the spreadsheet highlights the corresponding shots on the timeline?
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The spreadsheet, timeline, and Viewer are linked together when viewing sequences. If suitable screen
real estate exists within the current workspace, double-clicking a sequence forces the associated
panel to open automatically. If you want to close a single panel in a linked group, hold the Alt
modifier while closing the linked panel, otherwise all panels in the group are closed.

Note: If you imported an XML sequence, you may find that Hiero has automatically
matched media for you.
Any transform, crop, or retime edit decisions from third-party software .xml and .aaf files are
represented using soft effects. These effects are imported along with the shot to which they're
associated.
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Notes on AAF Sequences
Avid Media Composer supports retimes using curves that map frame to frame or frame to speed.
Nuke Studio handles the import differently depending on the retime method.
• frame to frame - describes the retiming in relative terms, such as 'at frame 100 in the output clip,
display frame 50 of the source clip'.
• frame to speed - describes the retiming in terms of overall output duration. For example, half
speed doubles the duration of the clip.
Nuke Studio's TimeWarp effect only supports frame to frame mapping, which means that frame to
speed retimes from .aaf files requires some curve-fitting to describe the required retime. As a result,
the keyframes generated in Nuke Studio don't match those in Avid, but the resulting curve should
match the original very closely.

Note: Nuke Studio currently only supports Fixed Keyframes from Avid Media Composer.

Tip: If you need to adjust the handles on curves, see
https://learn.foundry.com/nuke/content/getting_started/using_interface/animating_
parameters.html for more information.
Nuke Studio's TimeWarp effect supports the following Spline types when importing .aaf files:
• Shelf
• Linear
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• Spline
• Bezier
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Conforming Sequences
Once your EDL, AAF, or XML sequences are imported, it’s time to begin the conform process to match
the offline shots in your spreadsheet with the source clips on disk. You can conform sequences by
searching on disk or by pre-ingesting the required clips into Hiero.

Note: Projects containing large amounts of movie files (for example .r3d and .mov) may
exceed the number of available file handles per process, causing problems opening new
files or projects and exporting.
You can increase the default limit of 1024 by entering the following command from the
terminal, then running the application from the same session:
ulimit -Sn 2048
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Conforming Using a Browser
To conform a sequence using a browser:
1. After importing a sequence, click Match Media on the spreadsheet and use the browser to locate
the source folder containing the correct media.

Note: Match Media can also be used on selected events in the Spreadsheet view.
2. Click Open to display the Conform Options dialog.

Hiero uses a set of conform Rules and file name Patterns to match candidate media files on disk to
the events, or shots, in a sequence:
• Rules - sets the offline media properties to match to the corresponding spreadsheet entry
during conform.
Rules that rely on information that doesn't exist in the event or candidate clip are ignored, and
some rules compound others to identify a better match.
Rule

Description

Umid

Match a file’s unique material ID (UMID) – that is written into the file's
metadata on creation – to the candidate media’s UMID. If either, or both, lack
a UMID this rule is ignored.

RedTapeName

Match a RED-style camera reel name from the event to the candidate media
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Rule

Description
name.

RedName

Look for a RED-style camera file name in the event that matches the
candidate media name.

ReelName

Look for the event's reel name in the candidate's media name.

FullPath

Match the event's entire filepath to the candidate media’s entire filepath.
The Event is the first field in the Spreadsheet view, the order in which shots
appear on the timeline. Candidate media is the media that Hiero is testing
the conform rules against.

FileName

Match only the event's file name (no path) to the candidate media’s file name.

FileHead

Match the event's file name head (no path, file extension, or padding) to the
candidate media’s file name.

PartialName

Look for the event's name in the candidate media’s name and vice versa.

FolderName

Look for the event's name in the filepath of the candidate media.

All rules are enabled by default, but you may occasionally need to disable rules if they cause
incorrect matches between a particular edit and set of source clips.

Tip: Use the Select/Deselect All buttons to quickly enable or disable rules.
• Patterns - sets the inclusion and exclusion parameters during the conform, separated by
spaces. For example, *mov *dpx would only include or exclude .mov and .dpx files.
You could also conform by name, such as BR_Shot*, which would only include or exclude
source clip names starting with that string.

Tip: It’s always a good idea to be as specific as possible with search locations during
conforms, but if the need arises, conform Rules and Patterns can save time.
3. Enable Accept best timecode match... to use the nearest source timecode match to conform the
event, if no rules are matched.
4. When Ignore clips with non-overlapping timecodes is enabled, any potentially matching source
clip whose timecode doesn't overlap the shot in question at all is ignored.
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Disabling Ignore clips with non-overlapping timecodes causes Hiero to fall back to the other
selected conform rules, even if the timecodes don't overlap.
5. Check Conform shots that already have media if you want to update all timeline shots. By
default, the application doesn’t try to conform events that are not offline.
6. When Split sequences is enabled, any non-contiguous file sequences found by the conform are
split into separate clips, in the same way as when the split seq option is enabled in the file
browser.
7. Click OK to begin the conform process.
Hiero attempts to conform the edits with the selected media.
A dialog box informs you of the success rate once the conform is complete.

Successfully matched media is placed in a new Conform bin in the project.
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Note: You can display the conform Rules matched for each spreadsheet object by hovering
the cursor over the required entry.
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Conforming with Pre-ingested
Media
To conform with pre-ingested media:
1. If your source media has been ingested, you can drag-and-drop media from the bin view onto the
Match Media button.
See Ingesting Media for information on getting media into Hiero.

2. Follow the Conform Options instructions described previously to complete the conform process.
If you want to conform a single entry in the spreadsheet, drag-and-drop the media from the bin
view onto the required entry in the spreadsheet.
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Conforming individual, pre-ingested media doesn’t require Conform Options because Hiero
already knows the exact location of the media and trusts your decision to replace a shot.
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About the Media Spreadsheet
All events in a sequence are displayed in an easy to read format in the spreadsheet including status,
the track it resides on, length, and the source file location.
After conforming, you can use the spreadsheet to locate source clips or replace shots in the timeline,
as well as massage timecodes if they are invalid.
The media spreadsheet displays each entry’s current media state:
•

- the media was successfully conformed and its timecode is correct.

•

- the media was successfully conformed, but the timecode is currently incorrect.

•

- the media could not be conformed.

Note: Any source or destination field highlighted in yellow indicates that the entry has been
rounded down for display purposes.
See Managing Timelines for more information on importing tracks and reference media.

Sorting and Custom Columns
The spreadsheet can be organized in much the same way as accounting spreadsheets:
• Right-click the column headers to display the list of default columns available. Enable or disable
each column using the checkboxes.
• Click the required column to sort the spreadsheet in ascending or descending order, as indicated by
the arrow in the column header.
• Drag-and-drop column headers to reorder the spreadsheet as required.
• Add custom columns, such as Tags, using the Python API. See Help > Documentation for more
information on the Python API.

Tip: Nuke Studio's Project panel search functionality extends to the spreadsheet, allowing
you to enter strings and apply searches on all or partial matches with the option to include
metadata searches. Nuke Studio searches for items that match any of the input string and
displays only those items by default. See Sorting and Searching Media for more information.
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Spreadsheet Controls
There are also a number of controls, accessed by clicking the cog icon, that determine the
spreadsheet’s appearance and behavior.

• Select Matching Name - when enabled, selecting an item in the spreadsheet highlights all items
with the same name.
• Select Linked - when enabled, selecting an item in the spreadsheet highlights other items linked to
it, such as audio tracks ingested with video tracks.
• Display Speed As - sets the unit used in the Speed column of the spreadsheet. Select either fps
(frames per second) or % (the percentage of the media frame rate).
• Retime method - sets the type of Speed retime applied on the timeline.
• Time Edit Behaviors - sets how source and destination In, Out, and Duration are calculated.
SeeRetiming Shots for more information on retime methods and Timeline Editing Tools for
source/destination calculations.
You can locate, display, reconnect, or rename shots directly from the spreadsheet.
• Hold Alt and click an entry to move the playhead to the shot’s In point on the timeline.
• Hold Alt and double-click an entry to move the playhead to the shot’s In point on the timeline and
zoom to fit the timeline view.
• Right-click a spreadsheet entry and select the required option:
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• Open In - the associated source clip opens in the selected location, such as a Viewer.
• Project View - the associated source clip is highlighted in the bin view.
• Reconnect Media - attempt to reconnect the media from a specified location on disk, such as
when the source was originally on a drive that is no longer connected.
• Replace Clip - replaces the selected entry with a specified source clip. Hiero assumes that any
source clip you choose is acceptable, regardless of timecode.
• Delete - deletes the selected entries from the spreadsheet and timeline.
• Tags - allows you to add tags to your selection directly from the spreadsheet view. See Using
Quick Tags for more information.
• Localize - allows you to control the localization of clips, tracks, and sequences from the
spreadsheet. See Localizing Media for more information.
• Effects - provides access to soft effects directly from the spreadsheet. See Soft Effects for more
information.
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Adjusting Timecodes
You can easily adjust single or multiple event timecodes:
1. Select the invalid entry or entries in the spreadsheet.
2. Double-click in the Src In column.
3. Adjust the timecode as required. You can enter absolute or relative timecode values:
• Absolute - absolute timecodes contain eight digits and specify the new timecode for the event,
regardless of the current timecode.
Example

Result

01:05:43:21

Sets the timecode at 1 hour, 05 minutes, 43 seconds, and 21 frames

01054321

• Relative - uses + and - values to alter the timecode relative to its current value. You can also use
h, m, and s to denote hours, minutes, and seconds.
Current Position

Example

Result

01:05:43:21

+1h

02:05:43:21

-110

01:05:42:11

+10000

01:06:43:21

-6m

00:59:43:21

The media changes state to

.

Note: Timelines start at 01:00:00:00 by default, but you can change this to any value using
the Sequence panel.
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If you’re not sure what the timecode should be, you can:
• Hover the mouse over the target entry in the spreadsheet to view a timecode tooltip.

OR
• Examine the source clip’s metadata and calculate the correct Src In:
1. Right-click the required entry and select Project View.
2. Right-click the clip in the bin and select Open In > Metadata View, or press Alt+D.
The selected clip metadata is displayed in a floating pane.
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Renaming Shots on the Timeline
Once you’ve conformed your edit, you may want to rename shots on the timeline sequentially for
clarity.
To rename shots:
1. Select the shots to rename using the timeline or spreadsheet view.
2. Right-click on the timeline and select Editorial > Rename Shots.

Tip: You can also navigate to Timeline > Rename Shots or use the Alt+Shift+/ keyboard
shortcut.
The Rename Shots dialog displays.

3. Select the rename type from the dropdown:
• Simple Rename - all shots are replaced by the New Name specified.
• Find and Replace - a simple find and replace shot name. All selected shots containing the
specified Find pattern are substituted with the Replace pattern.
• Sequential Rename - rename shots sequentially using the Pattern, Start #, and Increment
fields.
• Match Sequence - allows you to select a sequence to copy shot names from, providing that
they use the same shots. For example, renaming shots on a 30 second timeline to mirror the
shot names from a 60 second timeline.

Note: You can only use sequences that reside in the same project and shots that have
overlapping frame ranges.
• Clip Name - all shot names are replaced by the name of the source clip they reference. This
option can be used to revert previous rename operations.
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• Change Case - the case of all shot names is changed, as specified by the Case dropdown. For
example, selecting Title Case capitalizes the first character of each word.
4. Rename operations also accept token substitutions. The following tokens are recognized:
Token

Resolves to

{clip}

The name of the source clip referenced by the target shot.

{event}

The EDL event number associated with the target shot.

{filename}

The file name of the shot's source.

{fps}

The frame rate of the sequence containing the rename target.

{sequence}

The name of the sequence containing the rename target.

{shot}

The name of the shot.

{track}

The name of the track containing the rename target.

5. Enable Include Clips From Audio Tracks to rename audio shots as well as video shots.
6. Click Rename.
The selected shots are renamed as specified.
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Saving and Loading Projects
You can save your work in a project using the .hrox file extension. Projects can contain .nk scripts in
the form of shots added by using Create Comp Clips during round-tripping. See Building VFX Tracks
and Comp Clips for more information.
If you quit the application without saving, you’ll be prompted to save or discard your changes:

Click the required button or press D for Don’t Save or S to Save.

Note: If you have a .nk script open in the same session, a second prompt is displayed so
you can save your script as well.
To save a project:
1. Navigate to File > Save Project or Save Project As...
OR
Use the Ctrl/Cmd+S or Shift+Ctrl/Cmd+S keyboard shortcuts respectively.
The Save Project dialog box displays.
2. Browse to the save location and enter a name for the project.
3. Click Save.
Your project is saved to the location specified and appends the .hrox file extension automatically.
To load a project:
1. Navigate to File > Open Project.

Tip: If you need to open a project that you worked on recently, you can select Open Recent
Project to quickly locate your work.
OR
Use the Ctrl/Cmd+O keyboard shortcut.
The Open Project dialog box displays.
2. Browse to the file location and click Open.
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Your project opens and populates the necessary panel automatically.
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Autosaved Projects
The autosave function creates a temporary project save file at 5 minute intervals, but you can adjust
force project autosave after in the Preferences > General dialog. See Appendix A: Preferences for
more information.
At startup, the application scans for autosaved projects and displays a prompt if autosaves exist.

Click Yes to load the autosave or No to ignore and delete it.
Opening a project also uses the autosave functionality. If the autosave is more recent than the saved
project file, a prompt displays:

Click Yes to load the autosave file or No to load the original project file.

Note: Clicking No does not delete the autosaved project in this case.
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Timelines contain video and audio shots that reference the source clips in your project. Once the
conform process is complete, the timeline displays your clips in context and enables you make finer
edits. Timelines can contain any number of video sequences and audio tracks with each track
containing shots that reference the source clips in your project - making changes to shots in the
timeline does not affect the original source clip.

Hiero also features real-time soft effects on the timeline and the ability to add shots containing .nk
scripts. See Soft Effects and Building VFX Tracks and Comp Clips for more information.

Note: Conformed EDLs only support one video sequence. If you’ve created multiple EDLs
from the same edit, you can add each one into the timeline using the right-click New Track
> New Track(s) from EDL/XML option or the Import Track button in the spreadsheet tab.
See Adding Tracks to the Timeline.

• Video Toggles - quickly turn off and on video tracks during playback. Hold Alt and click to solo the
selected track. You can also enable and disable track blending and masking. See Blending Tracks on
the Timeline for more information.
• Disk Caching Controls - click and hold to display the disk caching options for the current timeline.
See Caching Frames in the Disk Cache for more information.
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• Timecode - displays the timecode or frame number depending on the Time Display mode selected.
You can adjust the scale using the Scale Slider or by using the mouse wheel.
• Playhead Position - displays the playhead location synchronized with the contents of the Viewer.
• Video Tracks - contain all video sequences for the current timeline.
• Audio Tracks - contain all the audio clips for the current timeline.
• Audio Toggles - quickly mute audio or set the track output during playback to left, right, or mono.
• Track Lock - secure the selected track to disable all editing tools.

Tip: Selecting tracks while holding Ctrl/Cmd allows tools to affect multiple tracks at once,
such as locking, disabling, and resizing tracks.
Video tracks in multi-track timelines are read from the highest number track downward, for example
Video 3, Video 2, Video 1. As a result, if video is present on track 3, video on track 2 in the same time
slice is obscured.
In this example, although the playhead crosses clips on two video tracks, only the clip in Video 3 is
displayed in the Viewer.

Audio tracks, on the other hand, play back simultaneously - all the audio tracks crossed by the
playhead in the example play back together, creating a complete audio backing for the video.
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Tip: Enabling Preferences > Panels > Timeline > show frame end marker draws an extra
line on the timeline to the right of the playhead, indicating the end of the current frame.
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Adding Tracks to the Timeline
You can add empty tracks to existing timelines or import other EDL, AAF, or XML edits - effectively
another sequence within the timeline.
To import EDL, AAF, or XML edits:
1. Select the required sequence in the project bin, right-click, and select Import > New Track(s)
from EDL/XML,
OR
2. Click Import Track in the spreadsheet tab.

3. Use the browser to locate the EDL, AAF, or XML files, select the file(s) and click Open to import the
sequence.

Note: If you’re importing EDLs, bear in mind that there is no guaranteed frame rate
information included in the file. Select the correct frame rate then click OK in the dialog
supplied.
4. Conform the new track as described in Conforming Sequences.
To add new tracks:
• Drag-and-drop a clip above or below existing tracks as shown,
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OR
• Right-click in the timeline and select New Track > New Video Track or New Audio Track.
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Note: You can also collapse and expand existing tracks using the right-click Editorial menu,
and resize the track header to accommodate longer track names.
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Adding Clips to the Timeline
The timeline allows you to add clips by simple drag-and-drop from either the Viewer or bins. Using
the Viewer restricts you to a single clip, the current clip, but you can drag as many clips as you like
from bins.

Tip: You can create a new sequence by dragging a clip to an empty timeline pane.
New timelines pick up their frame rate from the Project > Edit Settings > Sequence sub-menu by
default. Dropping a clip with a different frame rate on a new timeline displays a warning:

However, if the timeline is already populated and the clip you’re adding doesn’t have the same frame
rate as the timeline, you’re prompted to choose whether the clip’s duration or frame count is
retained.

Take care not to overwrite existing shots - the most recent clip overlays any existing shot. To avoid
this, do one of the following:
• Move the playhead to the target area of the timeline in the record Viewer

, load the required clip

in a source Viewer
, and then use Insert (N) or Overwrite (M) to place the clip into the timeline
at the playhead position on the lowest, unlocked track available.

Note: You can only Insert or Overwrite using clips from the current project.
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See Insert, Overwrite, and 3-Point Editing for more information on source/record editing.
• Use the Multi or Move/Trim tools to make space for the new clip and then drag-and-drop it in to
the space (see Using the Move/Trim Tool for more information).

• Drag-and-drop the new clip at the end of the sequence, then using the Multi or Move/Trim tools,
drag the new clip to an existing transition, hold down the Alt modifier, and drop the clip to Ripple
all other shots down the timeline.
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Tip: Enabling Preferences > Panels > Timeline > show frame end marker draws an extra
line on the timeline to the right of the playhead, indicating the end of the current frame.
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Audio and the Timeline
Audio tracks on the timeline are handled in much the same way as video tracks. By default, linked
audio and video tracks are edited at the same time, but you can lock either track and move them
independently or hold Alt to select a single track, if required.

Note: Although you can import and edit multi-channel audio, during playback audio is
mixed to 48 KHz stereo output.

Note: Hiero does not currently support any QuickTime audio on Linux. Support for audio
on Linux is scheduled for a later release.
When both Viewer inputs contain clips, the audio output is set by the orange marker in the color
picker information bar, displayed by clicking
audio output:

. In the following example, input A is providing the

The volume slider in the upper-right corner of the Viewer controls the output level for that Viewer
only.

Audio output for shots can be toggled between left, right, and mono using the audio toggles in the
track header. Click on the icon to cycle between outputs:
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You can also control audio on a per track and per shot basis. Audio track headers and shots have
independent volume controls in the timeline and Properties tab.
• Track headers - click and hold the mute icon on the header to display the volume slider.

• Shots - select an audio shot and click on the Properties tab to display the Volume control.

Tip: You can control the volume on multiple shots simultaneously by holding Ctrl/Cmd and
selecting the required items before adjusting the volume slider.
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The Preferences > Panels > Viewer (Sequence) sub-menu contains audio controls allowing you to
control the volume level for all new Viewers. See Appendix A: Preferences for more information.

Note: If the frame rate drops too low, audio is automatically muted and the speaker
changes to the no audio playback icon.
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WAV Shots
Audio can be recorded at the same time as shooting the video or it can be unrelated to the shoot, for
example sound effects or music. You can add .wav clips to the timeline in two ways:
• Drag-and-drop - drag your .wav clip to a timeline audio track and drop it in to place.
• Navigate to File > Import File(s) or Import Folder(s).

Tip: You can also use the Ctrl/Cmd+I and Ctrl/Cmd+Shift+I keyboard shortcuts.
Use theTimeline Editing Tools to move the clip into place and set its output.
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Displaying Audio Waveforms
Visualizing an audio waveform helps synchronization with video events, and Hiero displays
waveforms in the timeline by default.
Audio shots are manipulated in the same way as video shots, so using waveforms in conjunction with
the Timeline Editing Tools on page 264 enables you to quickly synchronize audio and video events.
Audio shots also support Fade In, Fade Out, and Dissolve transitions in the same way as video. See
Adding Transitions for more information.
You can toggle the waveform display on and off by right-clicking in the timeline and selecting View >
Audio Waveforms. You can also control how the waveform appears, when enabled. Open the
Preferences and navigate to Panels > Timeline to toggle between full and half waveforms.

Displaying waveforms in audio-heavy projects can cause significant slow down on the timeline, so
Hiero includes a preference to limit how much system memory is available for waveform display. In
the Preferences, navigate to Performance > Caching > Audio Waveforms and set the waveform
memory control to the required amount.
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Audio Scrubbing
Hiero's timeline supports audio scrubbing, allowing you synchronize audio and video more easily
while scrubbing the playhead. Audio scrubbing is enabled by default, but you can disable it by rightclicking in the timeline tab and clicking Audio > Audio Scrubbing or by pressing Ctrl/Cmd+Alt+S.

Audio shots cache temporarily to increase responsiveness during scrubbing. If you need to clear the
audio cache, navigate to Cache > Clear Audio Cache.

Note: Audio scrubbing is not currently available through monitor output cards. Audio
scrubbing is only supported through internal audio output devices.
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Synchronizing Audio and Video
Hiero allows you to massage the synchronization between audio and video tracks using audio latency
adjustment during playback in the Viewer, or by a default amount in the Preferences > Panels >
Viewer (Sequence) sub-menu.

Note: Latency adjustments can take a few seconds to affect the audio track.
1. Mark a portion of the timeline containing the target audio and video shots using In and Out
markers.
2. Press

or use the L keyboard shortcut to begin playback.

3. Click the Viewer settings icon and increment the latency using the controls in the popup.

4. Adjust the latency until the tracks are in sync.
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PulseAudio on Linux
PulseAudio on Linux distributions has been linked with fluctuating frame rates due to the latency
when retrieving audio samples. If Hiero detects that your setup is running PulseAudio alongside the
application, a warning message displays.

Stopping PulseAudio
You can disable PulseAudio for the current user or all users on a machine. To stop the daemon, do
the following:

Note: PulseAudio restarts automatically when you restart you machine, but you can prevent
this by navigating to System > Preferences > Startup Applications and disabling the
PulseAudio Sound System.
1. Open the ~/.pulse/client.conf file to disable PulseAudio for the current user,
OR
Open the /etc/pulse/client.conf file to disable PulseAudio for all users.
2. Set the following attribute and ensure the line is not commented out:
autospawn = no
3. Call pulseaudio --kill to end the PulseAudio process.
4. Call ps -e | grep pulse to check the process stopped correctly.

Note: Ending PulseAudio while other applications are running may disable audio output.
Stop and start the application to re-enable audio output. Additionally, the desktop audio
slider may be removed.

USER GUIDE

182

PulseAudio on Linux | Restarting PulseAudio

Restarting PulseAudio
To start the PulseAudio daemon, do the following:
1. Open the ~/.pulse/client.conf file to enable PulseAudio for the current user,
OR
Open the /etc/pulse/client.conf file to enable PulseAudio for all users.
2. Set the following attribute and ensure the line is not commented out:
autospawn = yes
3. Call pulseaudio --start to start the PulseAudio daemon.
4. Call ps -e | grep pulse to check the process started correctly.
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Using Reference Media
Importing a reference version of your timeline enables you to compare your current timeline against
the reference media to avoid issues with continuity, missed frames, and so on.
To import reference media, click Set Reference Media and use the browser to locate the required
file.

The reference media is automatically imported into Reference tracks, pushing existing tracks
outward, and marked with the Reference Media tag.
After importing the reference media, use the show/hide icon or A/B input tools to compare the
current timeline against the reference clip. SeeComparing Media for more information.

USER GUIDE

184

Comparing Media | Restarting PulseAudio

Comparing Media
The Viewer A/B tools allow you to quickly compare media using the two Viewer input buffers. Select a
clip, sequence, shot or track and press 1 or 2 to place your selection in the Viewer input buffers. You
can also drag-and-drop items into the input buffers using the Viewer hotspots.

Note: The Viewer currently treats all alpha channels as premultiplied, which can result in
the Viewer background being “added” to the image. If you’re working with un-premultiplied
images, set the Viewer background to Black. See Appendix A: Preferences for more
information.
When the Viewer input buffers contain sequences, the A and B dropdowns control what is displayed
in the Viewer using track names and tags. Selecting a track or tag from the dropdown displays the
selected media in the Viewer.

Use the wipe, stack, horizontal, and vertical modes to control how the buffers are displayed in the
Viewer.

Note: If you're working in a multi-view project, using stereo footage for example, you can
set which view is output in the A and B buffers using the Views buttons over the Viewer. See
Displaying Views in the Viewer for more information.
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The wipe and stack modes also allow you to blend the two buffers together, and in the case of wipe
mode, provides a handle in the Viewer to quickly wipe between the two inputs.

The color picker overlay
displays a description of the contents of the A and B inputs, or No Clip
when there is no clip at the playhead, for instance, when there is a gap in a timeline or if a track is
disabled.

The orange triangle in the overlay denotes the clip currently supplying audio and timecode
information in the Viewer.
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Caching Frames in the Playback
Cache
The playback cache places frames in RAM for rapid retrieval during playback, rather than creating files
locally as with Caching Frames in the Disk Cache orLocalizing Media.
The white bar under the Viewer represents the contents of the playback cache, a full bar indicating
that the entire clip or timeline is currently accessible from RAM, optimizing playback. You can:
• Temporarily disable caching using the pause button above the Viewer, or use the P keyboard
shortcut.
Clicking pause again, resumes caching from the playhead position.
• Flush the cache completely by navigating to Cache > Clear Playback Cache. Caching is
automatically paused after flushing, but clicking the pause button resumes caching from the
playhead position.
There are also a number of Preferences that affect how much RAM is available and when caching
should occur. To set the caching behavior:
1. Navigate to Nuke > Preferences (OS X) or Edit > Preferences (Linux and Windows),
OR
Use the Preferences keyboard shortcut Shift+S.
2. Select Performance > Caching and set the total RAM cache available using the playback cache
size field.

Note: You can't set this to a value higher than 80% of the memory available (rounded down
to the nearest half-GB). For example, if you have 6 GB of memory available, the maximum
cache size available 4.5 GB.
3. You can enable free timeline playback RAM to discard any frames cached to RAM (the white bar
in the timeline Viewer) when you switch to the Node Graph within Nuke Studio, freeing the RAM
for use in Nuke.

Note: When you switch back to the timeline, the cached files are re-cached, which can be
time consuming.
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4. Enable pause caching when the application goes to the background to pause playback
caching when the application loses focus.
When you click back into Nuke, caching picks up from where it stopped.
5. Enable clear cache when the application goes to the background to flush the playback cache
when the application loses focus.
When you click back into Nuke, caching starts again from the position of the playhead.
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Caching Frames in the Disk Cache
Timeline Disk Caching provides reliable playback for more complex timelines by rendering frames to
disk using the GPU. The cache provides persistent frames per edit in the timeline that only needs
updating for full changes on the edit, such as adding a soft effect. For editorial changes, only the new
frames need to be cached.

Note: Frames are always cached at the sequence resolution, regardless of source clip
format and Viewer proxy settings.
You can cache whole sequences, selections of clip ranges, and frame ranges specified using In and
Out points. Files in the disk cache are frames identical to what you see rendered in the timeline
Viewer, written into .exr sequences, and saved in NUKE_TEMP_DIR/TimelineCache by default.

Tip: You can find the location of Nuke's general cache directory from within Nuke by hitting
X on your keyboard, when the focus is on the Node Graph, and then running the following
Tcl command:
getenv NUKE_TEMP_DIR

Cached frames are represented in the timeline by the state of the timeline cache icon:
- None of the frames in the current timeline are cached.
- The current timeline is partially cached.
- The current timeline is fully cached.
Cached frames are represented in the Viewer with an orange bar, under the RAM cache bar, which is
white by default.
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See Caching Sequence Ranges, Caching Selected Shot Ranges, and Caching In/Out Ranges for more
information.
You can set the cache directory location, size of the timeline cache, and type of EXR compression used
by:
• Clicking and holding the timeline cache icon

and selecting Cache Settings, or

• Opening the Preferences and navigating to Performance > Caching.
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Caching Sequence Ranges
Caching a sequence caches exactly what you see when play through the entire timeline. As the
playhead walks the timeline, all tracks are read from the highest track downwards, so what you see in
the Viewer is what Hiero caches to disk.
Hiero can only cache one sequence at a time, either from the timeline itself, the Cache menu, or the
Project bin:

Tip: You can pause caching at any time by navigating to Cache > Disk Cache > Pause in the
menu bar.

• Select the required sequence in the timeline tab, click and hold the
Sequence Range.

icon, and then select Cache

• Select the required sequence in the timeline tab and then select Cache > Disk Cache > Cache
Sequence Range from the menu bar.
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• In the Project bin, right-click the sequence you want to cache, and then select Cache > Cache
Sequence Range.

See Clearing Cached Frames for information on how to clear frames from the disk cache.
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Caching Selected Shot Ranges
Caching shot ranges allows you to be more selective than caching an entire sequence, though it works
in the same way. All tracks are read from the highest track downwards, so what you see in the Viewer
for the shot selection is what Hiero caches to disk.

Tip: You can pause caching at any time by navigating to Cache > Disk Cache > Pause in the
menu bar.
As a result of this, you may not get the frames you expect. For example, caching the shot in the image
produces frames from the three shots on the highest track, including the soft effect, not the selected
reference media.

You can cache clip ranges from the timeline itself or from the Cache menu:
• Select the required clip range in the timeline tab, right-click and then select Disk Cache > Cache
Selected Shot Ranges.
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• Select the required clip range in the timeline tab and then select Cache > Disk Cache > Cache
Selected Shot Ranges from the menu bar.

See Clearing Cached Frames for information on how to clear frames from the disk cache.
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Caching In/Out Ranges
Caching ranges uses In and Out points set on the timeline to determine what Hiero caches to disk. All
tracks are read from the highest track downwards, so what you see in the Viewer between the In and
Out markers is what Hiero caches to disk. See Using In and Out Markers for more information.

Tip: You can pause caching at any time by navigating to Cache > Disk Cache > Pause in the
menu bar.
After setting In and Out points, you can cache that range from the timeline itself or from the Cache
menu:
• Right-click in the timeline tab and then select Disk Cache > Cache In/Out Range.

• Select Cache > Disk Cache > Cache In/Out Range from the menu bar.
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See Clearing Cached Frames for information on how to clear frames from the disk cache.
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Clearing Cached Frames
Frames in the timeline cache can be cleared in a number of ways, including Clear All frames across
all projects and the more selective Clear Range option.

Clearing All Cached Frames
The Clear All option is only available from the Preferences dialog under Performance > Caching,
because it clears all frames from all projects and should be used with care. Clicking Clear All displays
a warning dialog containing all the projects that are affected.

Click OK to proceed or Cancel to retain all the frames in the cache.

Clearing Sequences
Instead of using the Clear All option, you can clear certain sequences within a project. You can clear a
sequence from the timeline itself, the Cache menu, or the Project bin:
• Select the required sequence in the timeline tab, click and hold the
Sequence Range.

icon, and then select Clear
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• Select the required sequence in the timeline tab and then select Cache > Disk Cache > Clear
Sequence Range from the menu bar.

• In the Project bin, right-click the sequence you want to clear, and then select Cache > Clear
Sequence Range.
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Clearing Selected Shot Ranges
You can also clear selected ranges of shots from a sequence, rather than the entire sequence, from
the timeline itself or from the Cache menu:
• Select the required clip range in the timeline tab, right-click and then select Disk Cache > Clear
Selected Shot Ranges.
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• Select the required clip range in the timeline tab and then select Cache > Disk Cache > Clear
Selected Shot Ranges from the menu bar.

Clearing In/Out Ranges
Clearing frames using In and Out markers is the most fine-grained method for removing frames from
the timeline cache. Only the frames bracketed by the markers are removed, regardless of how the
frames were cached originally. See Using In and Out Markers for more information.
After setting In and Out points, you can clear that range from the timeline itself or from the Cache
menu:
• Right-click in the timeline tab and then select Disk Cache > Clear In/Out Range.
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• Select Cache > Disk Cache > Clear In/Out Range from the menu bar.
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Viewing Multi-Format Timelines
All sequences and shots added to them adopt the output resolution and clip reformat settings
from the Preferences dialog under Project Defaults > General. You can override these settings on
a per Project or per Sequence basis.

The Preferences dialog controls the default settings for
new projects. Existing projects are unaffected by changes
to the preferences.

The Project Settings control the default settings for new
sequences and shots in the current project. Existing
sequences and shots are unaffected.
Project Settings override Preference settings.

The Sequence settings control the current sequence.
Sequence settings override Project Settings and
Preference settings for the current timeline.

The Properties settings control shots in the current
sequence.
Properties settings override Sequence settings, Project
Settings, and Preference settings for shots on the
current timeline.

Reformatting applied to shots on a timeline carry over into any export, including Create CompClips.
The reformat options in the Export dialog are applied after the transforms applied here. See
Exporting from Hiero for more information.
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Setting the Sequence Format
The current sequence format is controlled by the Output Resolution dropdown in the timeline
Sequence tab. The selected resolution is applied to all shots on the timeline, but by default, shots
retain their native resolution. For example, setting the Output Resolution to 2k_DCP on a timeline
containing HD_1080 shots results in the output resolution being larger than the shot.

Tip: Enabling the Custom Sequence Format guide at the top of the Viewer makes it easier
to see differences between output resolution and shot format.

A 1920x1080 shot at native
resolution.

The same shot with Output
Resolution set to 2048x1080.

Similarly, setting the Output Resolution to a format smaller than the shot's native resolution results
in the clip resolution being larger than the sequence resolution.

A 1920x1080 shot at native
resolution.

The same shot with Output
Resolution set to 720x486.

Shots with a higher resolution than the sequence format enable you to apply soft effects, such as
Transform, more easily. See Soft Effects for more information.
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Reformatting Shots
Shots on the timeline retain the source clip's resolution by default. You can force shots to the
sequence format using the timeline's Properties tab:
1. Select the target shots on the timeline.
2. Click the Properties tab to display the shot options.

Note: The Volume control is only available when you have an audio shot selected.
3. Click the Clip Reformat dropdown and selected To Sequence Resolution.
4. The shot is reformatted to the Output Resolution specified on the Sequence tab.
5. Depending on the source clip, you may need to change the Resize Type:
• Width - scales the original until its width matches the format’s width. Height is then scaled to
preserve the original aspect ratio.
• Height - scales the original until its height matches the format’s height. Width is then scaled to
preserve the original aspect ratio.
• Fit - scales the original until its smallest side matches the format’s smallest side. The original’s
longer side is then scaled to preserve original aspect ratio.
• Fill - scales the original until its longest side matches the format’s longest side. The input’s
shorter side is then scaled to preserve original aspect ratio.
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• Distort - scales the original until all its sides match the lengths specified by the format. This
option does not preserve the original aspect ratio, so distortions may occur.

Tip: When Clip Reformat is To Sequence Resolution, disabling center places the clip at
the bottom-left of the Output Resolution, rather than the center.
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Refreshing and Replacing Shots
During the post process, media inevitably changes location or form. Hiero can reload or replace your
media using the refresh, rescan, reconnect, and replace functions.

Though all four options deal with reloading shots, each has a particular use dependent on context:
• Reconnect Media - allows you to redirect the file path when the source file location changes.
• Replace Clip - replaces the selected shot with a specified source clip. Hiero assumes that any source
clip you choose is acceptable, regardless of timecode.
• Refresh Clips (F8) - allows you to reload the shot when the source file location has not changed,
such as when work has been done on the clip offline. Selecting refresh only refreshes the clip’s
current frame range.
• Rescan Clip Range (Alt+F5) - similar to Refresh Clips, above, but rescan also checks for additional
frames that may have been added to the source file and adds them to the shot’s frame range.
• Set Soft Trims - sets the files handles on the selected clip(s). SeeSetting Soft Trims for more
information.
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Setting Soft Trims
Soft Trims limit the handles on shots to a pre-defined amount, simulating In and Out points on the
source clips, allowing you to use other timeline tools on the shots such as Slip Clip and Slide Clip.
To set Soft Trims on a shot(s):
1. Select the shot(s) on the timeline.
2. Right-click and select Clip > Set Soft Trims.
The Set Soft Trims dialog displays.
3. Set the number of frames to add to the head and tail of each shot:

• Use full available range - sets the handles to the full extent of the source clip frame range.
• Use Frames - adds the specified number of frames to the head and tail of the shot(s).
4. Click OK to add the specified number of handles.
If the handles requested are not within the available frame range, a warning dialog displays with a
suitable correction for each selected shot.

Click Yes to accept, or No to abort the operation.
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Note: With shots used in multiple sequences, click Yes to All to accept the correction in all
instances.
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Enabling and Disabling Shots
You can temporarily enable or disable tracks and shots on the timeline to selectively view your media
without removing shot(s), for example if you wanted to view to lower level video tracks within a
timeline.
To enable or disable a track or shot(s):
1. Select the item(s) you want to enable or disable.
2. Right-click on a highlighted item and select Editorial > Disable Track or Disable Items to disable
the selection.

Tip: You can also use the D keyboard shortcut to disable or enable your selection.
Disabled items appear gray, and are effectively removed from the timeline.

3. Right-click the item and select Enable Clip, or press D again, to re-enable the clip.
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Adding Transitions
Hiero supports basic video and audio fade transitions as well as dissolves between shots on the same
track. Transitions come in three flavors:
• Fade in - fades in from black on a single shot.
• Fade out - fades out to black on a single shot.
• Dissolve - fades out from one shot and into the next, by merging frames.

Tip: Once a transition is in place, it can be nudged in the same way as an edit using the ,
(comma) and . (period) keyboard shortcuts, providing the required handles exist.
To add a fade transition:
1. Right-click the target shot and select Editorial > Add Transition > Fade In, Fade Out, Audio Fade
In or Audio Fade Out to add the fade icon.
2. Adjust the fade by dragging the fade icon using the Multi Tool or Move/Trim tool.

To add a dissolve transition:
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Note: You can only add dissolves between shots when they're on the same track and have
sufficient handles available on both sides of the transition.
1. Select the Multi Tool or Roll Edit tool and hover the mouse pointer over an edit between two
shots.

Tip: Clicking and holding the edit point displays available handles as a red overlay.
2. Right-click and select Editorial > Add Transition > Dissolve or Audio Crossfade, or use the
Ctrl/Cmd+T keyboard shortcuts, to add the dissolve icon to the edit.
3. Adjust either side of the dissolve by dragging the icon, in a similar way to using the Multi Tool or
Move/Trim tool.
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Invalid Transitions
Transitions are controlled in a similar way to shots, in that you can drag-and-drop them, but with the
following restrictions:
• A fade can not be dragged past the ends of the shot it's attached to, and if the item is deleted, the
fade is deleted with it.
• Dissolve ends can not be dragged past the ends of the shots they are attached to, and if both items
are deleted, then the dissolve is also deleted.
If only one of the shots linked by the dissolve is deleted, the transition remains so that another item
can be placed on the other side.
Invalid transitions are colored red on the timeline. In most cases, adjusting the length of the
transition should be enough to correct the error.
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Retiming Shots
In addition to transitions, Hiero supports constant retimes on shots. Decreasing the speed of a shot
causes frames to play more than once, whereas increasing the speed skips frames.

Note: Audio is not currently supported for retimes and is automatically muted to avoid
playback problems.
To retime shots using the Speed column in the spreadsheet:
1. Select the required event(s) in the spreadsheet view.
2. Click the cog icon and select the required Retime method:
• Keep source duration - the shot length is altered on the timeline depending on the retime
applied.
For example, retiming a shot to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 4, and so on in the Viewer,
and as a result, the item’s length is doubled on the timeline.
Retiming a shot to 200% renders frames 1, 3, 5, 7, and so on in the Viewer, but the item’s length
is halved on the timeline.
• Keep timeline duration - the shot length on the timeline is maintained regardless of the retime
applied.
For example, retiming a shot to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 4, and so on in the Viewer,
but the item’s length on the timeline remains the same, effectively removing the second half of
the item.
Retiming a shot to 200% renders frames 1, 3, 5, 7, and so on in the Viewer, but the item’s length
on the timeline remains the same. If no extra frames are available from the source, the item is
filled with black frames.
3. Double-click the Speed column and enter the retime value.
The following example shows a shot and the results of 50% and 200% retimes with the Keep source
duration and Keep timeline duration methods selected.
Notice that the Keep timeline duration method doesn’t change the length of the shot on the
timeline and inserts blank filler frames on the 200% retime?
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Original clip

50% Source retime

200% Source retime

50% Destination retime

200% Destination retime

You can also retime shots using the Src, Dst, and Duration columns of the spreadsheet, though the
calculation method depends on the Time Edit Behaviors applied.
1. Select the event(s) in the spreadsheet view.
2. Click the cog icon and select the required Time Edit Behaviors:
Modify

Using

Result

Src In

Retime

Adjusts the event’s Src In and retimes the remaining frames to maintain
Dst Duration.
Before and after a 2 second Src In increase:

USER GUIDE

214

Retiming Shots | Reformatting Shots

Modify

Using

Result

Src Out

Retime

Adjusts the event’s Src Out and applies a retime to maintain Dst
Duration.
Before and after a 2 second Src Out increase:

Src Dur

Retime

Adjusts the event’s Src Dur and Src Out, and applies a retime to maintain
Dst Duration.
Before and after a 50 frame Src Dur increase:

Dst In

Retime

Adjusts the event’s Dst In and retimes the remaining frames to maintain
the relationship between Dst In and Out.
Before and after a 2 second Dst In increase:

Dst Out

Retime

Adjusts the event’s Dst Out and retimes the remaining frames to
maintain the relationship between Dst Out and In.
Before and after a 2 second Dst Out increase:
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Modify

Using

Result

Dst Dur

Retime

Adjusts the event’s Dst Dur and Dst Out, and applies a retime to
accommodate the new Dst Duration.
Before and after a 50 frame Dst Dur increase:

3. Adjust the values as required to retime the shot(s) by the specified amount.

Note: Any source or destination field highlighted in yellow indicates that the entry has been
rounded down for display purposes.
To retime a shot using the Timeline menu:
1. Select the required shot(s) on the timeline.
2. Navigate to Timeline > Retime.
The Clip Speed dialog displays.
3. Enter the required retime value as a percentage.
4. Select the required retime method using the dropdown:
• Keep timeline duration - the shot length on the timeline is maintained regardless of the retime
applied. When increasing speed, if no extra frames are available from the source, the shot is
filled with black frames.
• Keep source duration - the shot length is altered on the timeline depending on the retime
applied. For example, a 200% retime halves the length of the item.
• Anchor current frame - the shot length on the timeline and the current frame’s position are
maintained after the retime. When increasing speed, if no extra frames are available from the
source, the shot is filled with black frames.
5. Click OK to retime the shot(s).
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Using Freeze Frames
The freeze frame feature enables you to create shots of any length using a single frame. To achieve
this, the application takes the first frame of the shot and applies a 0% retime, which is reversible by
applying a 100% retime.
To freeze frame shots:
1. Select the target item(s) on the timeline.
2. Right-click the item and select Editorial > Make Freeze Frame,
OR
Navigate to Timeline > Make Freeze Frame.

Note: Freeze Frames can also be created using the spreadsheet retime modes to modify
Src Dur to 0, or make Src In and Src Out equal.
3. The selection is retimed to 0% and colored blue on the timeline for easy identification.

4. Use the Multi Tool or Slip Clip to set the freeze frame from the available range.
5. Drag the item’s edit points, using the Multi Tool or Move/Trim as required, to set the length of
the shot. There’s no upper limit for the length of a freeze frame shot.
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Blending Tracks on the Timeline
Hiero allows you to perform merges between tracks in the timeline, for example overlaying a logo on
a shot without heading into Nuke. Tracks that are designated as blend tracks have a blue header in
the timeline for convenience and are blended using a sub-set of Nuke's Merge node operations.
See the Nuke Online Help for a full description of the available blend modes.

Note: The Viewer currently treats all alpha channels as premultiplied, which can result in
the Viewer background being “added” to the image.
You can add soft effects to blended tracks as normal (see Soft Effects for more information) and
blended tracks are included along with the shot in Export operations. See Exporting from Hiero and
using Create Comp Clips during round-tripping Building VFX Tracks and Comp Clips for more
information.

Adding New Blend Tracks
1. Right-click in the timeline, select New Track > New Video Track Blend, and then choose the
blend mode to apply.
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A new track is added at the top of the track stack, colored blue to indicate that it's going to be
blended over the track below.
2. Add the required shot to the blend track as you would any other shot. See Adding Clips to the
Timeline for more information.
3. Click and hold the Blend

4. Click the Blend

icon to select the blend mode.

icon to toggle blending on and off.

Converting Tracks to Blend Tracks
1. Click the Blend

icon to toggle blending on,

OR
Right-click in the header of the target track and select Editorial > Blend Mode > Enable Track
Blend.
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The selected track is converted into a blend track, colored blue to indicate that it's going to be
blended over the track below.
2. You can add shots to the blend track as you would any other shot. See Adding Clips to the
Timeline for more information.
The Viewer displays the higher track blended with the track below.
3. Click and hold the Blend

icon to select the blend mode.

Masking Blended Tracks
Masking limits the effect of the blend track to just those areas covered by the alpha channel in the
blend image. For example, using the Multiply blend mode with masking disabled multiplies the
background plate in non-alpha areas, which may not be the result you require.
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Background track B.

Blend track A.

A multiplied by B with Masking
disabled.

A multiplied by B with Masking
enabled.

See the Nuke Online Help for a full description of the available blend modes.
Click the Mask
icon to toggle alpha masking on and off. The mask option also carries over into the
Node Graph when you Create Comp for a masked blend operation:

Comp of A over B using the multiply merge
operation with masking disabled.

The same comp using the multiply merge
operation, but with masking enabled.
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Stereoscopic and Multi-View
Projects
Hiero provides multi-view support for as many views as you need. The views do not have to be stereo
pairs, but since that is the most obvious application, these pages mainly deal with stereoscopic
projects. See Creating Views in a Project and Importing Source Clips for more information.
Existing views inside a project are managed in the Viewer, timeline, and in the Properties panel of
most soft effects. In the Viewer, all views in the current project are represented by buttons that allow
you to switch between views with a single click. See Displaying Views in the Viewer for more
information.

The timeline employs a views button
that allows you to switch between views per track. See
Displaying Views in the Timeline for more information.
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The Properties panel includes a split button
for controls that support multiple views. Split
controls only affect individual views. See Applying Changes to Selected Views for more information.

You can create comps or export multi-view shots and effects in a similar way to regular shots. See
Exporting Multi-View Source Clips for more information.
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Creating Views in a Project
Views in Hiero are managed in the Project Settings. Views can be processed separately or together
and you can see the effect of your changes on each view. If you're working with multi-view source
clips, such as .exr and .sxr, Hiero offers to create views for you on import. See Importing Multi-View
Clips for more information.

Creating and Managing Views
If you're working with single-view clips, it's a good idea to create the project views before you import
your footage so that the views are assigned correctly. If you're working with multi-view clips, the views
are set up automatically on import.
1. Select Project > Edit Settings.
2. Go to the Views sub-menu. The available views are listed in the Views panel.

3. If you want to remove the view called main and add views called left and right, click the Set up
views for stereo button. The two views are assigned colors. To change the colors, double-click on
the color field and select another color from the color picker that opens.
4. Enable Use colors in UI to apply the selected color for each view to the associated button above
the Viewer.
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You can add and remove views using the + and - buttons or move views using the up and down
arrows above the views panel.
Each view has its own button above the Viewer controls.

Tip: If you decide that you only need the main view in the project, click Set up Views for
Mono in the Project Settings.
See Importing Multi-View Clips for information on reading source clips in to Hiero.
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Importing Source Clips
Hiero supports multi-view clips in two formats:
• single-view - formats such as .dpx and .jpg, with file names that Hiero can interpret as multi-view
using specific naming conventions. For example:
myStereo_comp1_left.####.dpx and myStereo_comp1_right.####.dpx
See Importing Single-View Clips for more information.
• multi-view - formats such as .exr, .sxr, and .mov, that support multiple views per file. For example:
myStereo_comp1.####.exr containing two layers called left and right.

Note: Hiero can assign any shot on the timeline to any view in the project, but stereo is the
most common use case.
See Importing Multi-View Clips for more information.

Importing Single-View Clips
After setting up views in the Project Settings, Hiero can interpret single-view clips as multi-view using
specific naming conventions. These conventions can be applied to the file names themselves or to the
directories in which they reside.

File Name Variables
If the images you want to read in contain a view name or the initial letter of one (for example, left,
right, l or r) in their file names, replace this with the variable %V or %v in the file name. Use %V to
replace an entire view name (for example, left or right), and %v to replace an initial letter (for
example, l or r). When a variable is used, Hiero reads in the missing inputs and combines all inputs
into a single output.

Note: You can enable detect views in the file browser to automatically substitute the %V or
%v variable where possible.
To use the %V and %v variables manually:
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1. Click File > Import File(s) or press Ctrl/Cmd+I to display the file browser.
2. Locate a single-view file, for example pubstitch.left.####.dpx
3. Replace the view name with the %V variable, continuing the example pubstitch.%V.####.dpx

4. Click Open.
Hiero reads in both pubstitch.left.####.dpx and pubstitch.right.####.dpx with the same Read
node, provided that views called left and right exist in the Project Settings.

Note: Mac and Linux operating systems can be case-sensitive or case-insensitive. If your OS
is case-sensitive, you'll need to make sure you use the correct case when naming your left
and right views, as the %v variable can only retrieve the case used in the view name.

Both input images are combined into a single source clip, marked with a
display any of the combined views.

icon, which can
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See Displaying Views in the Viewer and Displaying Views in the Timeline for more information.

Directory Name Variables
You can also use the %V and %v variables at a directory level. For example, if you have set up views
called cam3, left, and right, and you have the following directories and files:
stereo/pubstitchcam3/pubstitch_cam3.####.dpx
stereo/pubstitchleft/pubstitch_left.####.dpx
stereo/pubstitchright/pubstitch_right.####.dpx
If you read in pubstitch_cam3.####.dpx and change the file path to
stereo/pubstitch%V/pubstitch_%V.####.dpx, all three inputs are read in with the same Read node,
providing that the cam3, left, and right views exist in the Project Settings.
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All three input images are combined into a single source clip, marked with a
display any of the combined views.

icon, which can

See Displaying Views in the Viewer and Displaying Views in the Timeline for more information.
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Importing Multi-View Clips
Nuke offers to automatically create views when you import single files containing multiple views, such
as .exr and .sxr, unless they already exist. For multiple files, views must be created manually. See
Importing Source Clips for more information.
1. Click File > Import File(s) or press Ctrl/Cmd+I to display the file browser.
2. Locate a multi-view file, for example pubstitch_stereo.####.exr
3. Click Open.
The Create missing views? dialog displays.

4. Click Add Views, Replace Views, or No:
• Add Views - add the views in the incoming clip to those that exist in the project.
• Replace Views - replace all existing project views with those in the incoming clip.
• No - import the clip and display only the first view in the file, retaining any existing views in the
project.
You can now access the views in your project. See Displaying Views in the Viewer and Displaying
Views in the Timeline for more information.

Multi-View QuickTime Files
Multi-view .mov files only display one view by default. To enable all views in a multi-view .mov file:
1. Double-click the .mov to display its Properties panel.
2. Disable First track only.
You'll notice that the .mov in the bin is now marked with

to denote multiple views.

You can now access the views in your project. See Displaying Views in the Viewer and Displaying
Views in the Timeline for more information.
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Displaying Views in the Viewer
You can only display the views that exist in your Project Settings. To see a list of these views, or to
add or delete views, select Project > Edit Settings and go to the Views tab. For more information,
see Creating Views in a Project.

Displaying a Particular View
1. Double-click the clip or sequence to load it in the timeline Viewer.
2. On top of the Viewer controls, click the view to display. In the example, main, left or right.

Tip: You can also press the ; (semicolon) and ’ (forward single quote) keys to move between
different views in the Viewer.

Note: Hiero lists the views in .exr files in the order they appear in the clip's header, so a
view named 'left' may not always be the first view displayed above the Viewer.
If your views do not appear in the correct order, you can rearrange them in the Project >
Edit Settings > Views tab. See Creating Views in a Project for more information.

Displaying Two Views Next to Each Other
1. Right-click in the Viewer and select the Stereo Modes menu.
2. Select one of the following options:
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• Side by Side - displays the views side by side at the correct aspect ratio, and adds selection
controls above the Viewer.
• Squeezed Side by Side - displays the views side by side and squeezed to fit the format
horizontally, and adds selection controls above the Viewer.
• Squeezed Above by Below - displays the views above and below each other and squeezed to fit
the format vertically, and adds selection controls above the Viewer.

Displaying a Blend Between Two Views
1. Right-click in the Viewer and select the Stereo Modes menu.
2. Select one of the following options:
• Interlace H - displays the views interlaced horizontally, and adds selection controls above the
Viewer.
• Interlace V - displays the views interlaced vertically, and adds selection controls above the
Viewer.
• Checkerboard - displays the views using an alternating checkerboard pattern (one pixel from
left and one pixel from right), and adds selection controls above the Viewer.
• Anaglyph - displays the views simultaneously using a red hue for left and green hue for right,
and adds selection controls above the Viewer.
• Flicker - displays both views alternately, and adds selection controls above the Viewer.

Displaying OpenGL Stereo in Timeline Viewers
The Viewer OpenGL Stereo mode allows you to see both views at once on a 3D monitor for review
purposes. OpenGL Stereo is only supported on NVIDIA Quadro series GPUs and AMD Radeon Pro
series GPUs on Windows and Linux OS.

Note: OpenGL Stereo mode is not supported on Mac due to limitations in macOS and not
supported with AMD GPUs on Linux.

Enabling OpenGL Stereo Output
Windows
To enable NVIDIA GPU stereo output:
1. Right-click on the desktop and select NVIDIA Control Panel.

USER GUIDE

232

Displaying Views in the Viewer | Displaying OpenGL Stereo in Timeline Viewers

2. Navigate to 3D Settings > Manage 3D Settings > Stereo - Enable.

3. Proceed to Switching to OpenGL Stereo Output.
To enable AMD GPU stereo output:
1. Double-click the AMD taskbar icon and select Advanced Settings.
2. Navigate to the AMD Pro Settings and check Enable Quad Buffer Stereo.

3. Select either Auto-Stereo (Horizontal Interleaved) or Auto-Stereo (Vertical Interleaved) and
click Apply.
4. Proceed to Switching to OpenGL Stereo Output.
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Linux
To enable NVIDIA GPU stereo output:
1. Open a command prompt and enter:
nvidia-xconfig --stereo=3

Tip: For more information on the nvidia-xconfig utility, please see the man page: man
nvidia-xconfig

2. Proceed to Switching to OpenGL Stereo Output.

Note: OpenGL Stereo mode is not supported with AMD GPUs on Linux.

Switching to OpenGL Stereo Output
1. Right-click in the Viewer to display the context-sensitive menu.
2. Navigate to Stereo Modes and select OpenGL Stereo.
If you select OpenGL Stereo mode before enabling your GPU settings, a warning is displayed.

The first time you select OpenGL Stereo, a warning message is displayed.

Tip: You can disable the warning by enabling Don't show again and clicking OK.
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OpenGL Stereo is displayed in the Timeline Viewer.

Note: Switching to and from OpenGL Stereo mode causes playback to pause. Press play to
resume playback.
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Displaying Views in the Timeline
You can only display the views that exist in your Project Settings. To see a list of these views, or to
add or delete views, select Project > Edit Settings and go to the Views tab. For more information,
see Creating Views in a Project.
Adding a multi-view clip to the timeline groups all views into a single track. All the views in the clip are
assigned a Viewer button. Click the assigned view icon
to display the views available in the shot. All
Views are visible by default.

Selecting a particular view for a track in the timeline, such as left, means that only the left view is
visible in the Viewer for that track.

Note: You can also import single-view files manually and then assign them views in the
timeline individually, providing that the views exist in the Project Settings.

Splitting Views to Separate Tracks
Working with all views in a single track is not always convenient, such as when you need to apply
different color corrections to stereo cameras. Hiero includes a Split Views to Tracks option that
quickly separates views into individual tracks. You can use Split Views to Tracks with grouped singleand multi-view shots.
1. Right-click a multi-view shot on the timeline and select Editorial > Split Views to Tracks.

USER GUIDE

236

Displaying Views in the Timeline | Splitting Views to Separate Tracks

A separate track is created for each view in the group or file.

The new track names are suffixed with the view name, for example Video1_left, and the views are
assigned appropriately.

Note: If a view exists in the Project Settings, but there's no corresponding view in the source
files, empty placeholder tracks are added.
2. You can change the view assigned to a track by clicking the
available views.

icon and selecting from the list of

USER GUIDE

237

Displaying Views in the Timeline | Splitting Views to Separate Tracks

See Applying Changes to Selected Views for information on adding soft effects to different views.

Displaying Two Views Next to Each Other
1. Right-click in the Viewer and select the Stereo Modes menu.
2. Select on of the following options:
• Side by Side - displays the views side by side at the correct aspect ratio, and adds selection
controls above the Viewer.
• Squeezed Side by Side - displays the views side by side and squeezed to fit the format
horizontally, and adds selection controls above the Viewer.
• Squeezed Above by Below - displays the views above and below each other and squeezed to fit
the format vertically, and adds selection controls above the Viewer.

Displaying a Blend Between Two Views
1. Right-click in the Viewer and select the Stereo Modes menu.
2. Select on of the following options:
• Interlace H - displays the views interlaced horizontally, and adds selection controls above the
Viewer.
• Interlace V - displays the views interlaced vertically, and adds selection controls above the
Viewer.
• Checkerboard - displays the views using an alternating checkerboard pattern (one pixel from
left and one pixel from right), and adds selection controls above the Viewer.
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• Anaglyph - displays the views simultaneously using a red hue for left and green hue for right,
and adds selection controls above the Viewer.
• Flicker - displays both views alternately, and adds selection controls above the Viewer.
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Applying Changes to Selected
Views
By default, Hiero applies any changes you make to all views. To apply changes to a particular view
only (for example, the left view but not the right), you can:
• Split the views into separate tracks. Separating views allows you to apply effects, such as a
Transform or Timewarp, to individual views without affecting the other views. See Splitting Views to
Tracks for more information.
• Split the view off in the soft effect’s Properties. Splitting properties allows you to perform the same
operation on multiple views, but with different values for each, such as a Grade or ColorCorrect. See
Splitting Views in the Properties Panel for more information.

Splitting Views to Tracks
1. Right-click a multi-view shot on the timeline and select Editorial > Split Views to Tracks.

2. Right-click the track to which you want to add the soft effect, select Effects and then the required
soft effect. For example, adding a Transform to the left view applies the effect to only the left view
track. See Soft Effects for more details on adding effects to shots.
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You can create comps or export multi-view shots and effects in a similar way to regular shots. See
Exporting Multi-View Source Clips for more information.

Splitting Views in the Properties Panel
1. Right-click the track to which you want to add the soft effect, select Effects and then the required
soft effect. For example, adding a ColorCorrect a multi-view shot.
See Soft Effects for more details on adding effects to shots.

2. Select the view you want to make changes to using the buttons above the timeline Viewer.
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3. Open the effect’s Properties and click the view button
want to adjust.

on the right, next to the control you

4. Select Split off [view name]. For example, to apply changes to a view called left, select Split off
left. You can also split all the effect’s controls by selecting Split all knobs from the right-click
menu.

An eye appears on the split view button
. Any changes you make using the control in question
are only applied to the view you chose to split off. Changes to controls that have not been split off
are still applied to all views.
You can create comps or export multi-view shots and effects in a similar way to regular shots. See
Exporting Multi-View Source Clips for more information.

Showing Separate Values for Each View
Once you have split off a view, you can apply changes to the existing views separately. Click on the
arrow on the left side of a split control to divide the control into values for each view.

In the example, the left view is split for the saturation control and left and cam3 views are split for
the contrast control.
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Note: The * (asterisk) denotes there is more than one unsplit view remaining for the
saturation control and ( ) denotes that the right view is the only unsplit view for the
contrast control.

Unsplitting Views
1. In the effect’s controls, click the view button

.

2. Select Unsplit [view]. For example, to unsplit a view called left, you’d select Unsplit left.
The view is unsplit, and all changes you made to individual views are lost.
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You can add soft effects to your timeline in any of the workspaces. A soft effect is a real-time effect,
processed on GPU instead of CPU.

You can add custom plug-in or gizmo soft effects to the Add Effect menu using Python. Valid custom
soft effects must have a GPUEngine implementation using DD::Image::Iop::gpuEngine type
functions. For more information see Nuke's NDK Reference Guide.
Soft Effects must also be registered after creation. An example of how to register a plug-in or gizmo
as a custom soft effect is located in:
<install_directory>/pythonextensions/site-packages/hiero/examples/custom_
soft_effect.py

Available Soft Effects
Below is a brief summary of the available soft effects. These are similar to the tools in Nuke's Node
Graph. See the Nuke Online Help for more information about them.
Soft Effect

Summary

Transform

Allows you to translate, rotate, scale, and skew shots from a single control panel.

Mirror

Allows you to flip the input image around the center of the format area. A flip on
the x axis mirrors the image vertically. A flop on the y axis mirrors the image
horizontally.

Crop

Allows you to cut out the unwanted portions of the image area. You can fill the
cropped portion with black or adjust the image output format to match the
cropped image.

TimeWarp

Allows you to slow down, speed up, or even reverse selected frames in a clip
without necessarily altering its overall length. Sequences imported from .xml
and .aff files also support non-linear retimes.

Warning: TimeWarp effects are only allowed on tracks with clips as
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Summary
they are linked to the clips.

Grade

Allows you to define white and black points by sampling pixels from the Viewer.
For example, you can use this for matching foreground plates to background
plates.

LUT

Allows you to uses the OpenColorIO library to load a colorspace conversion from
a file (usually a 1D or 3D LUT) and apply it. You can also load other file-based
transformations, for example an ASC ColorCorrection XML.

CDL

Allows you to apply an ASC CDL (American Society of Cinematographers Color
Decision List) grade based on the OpenColorIO Library. For more information,
see http://opencolorio.org

Colorspace

Allows you to convert images from one colorspace to another, for example from
Nuke’s native colorspace to other color spaces more appropriate to a given
process or intended display device. This supports RGB, HSV, YUV, CIE, and CMS
formats (and various sub-formats). It can adjust for different primaries, white
point, and different encodings.

ColorCorrect

Allows you to make quick adjustments to saturation, contrast, gamma, gain, and
offset. You can apply these to a clip’s master (entire tonal range), shadows,
midtones, or highlights.
You can control the range of the image that is considered to be in the shadows,
midtones, and highlights using the lookup curves on the Ranges tab. However,
do not adjust the midtone curve - midtones are always equal to 1 minus the
other two curves.

Text

Allows you to add text overlays on your images. You can simply type in the text
you want to have displayed or use Tcl expressions (such as [metadata values])
or Tcl variables to create a text overlay. Text overlays can also be animated using
animation layers in the Groups tab, so that their properties (such as position,
size, and color) change over time.

Burn-In

Allows you to quickly add standard burn-in elements on the timeline. You can
control the color, opacity, font, scale, and so on, as well as use the dropdowns to
determine what element is added from the file or sequence metadata.
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Summary
You can also reference custom metadata from shots. For example:
hiero/tags/Approved
Extracts the Approved tag from the shot. You can also append note to include
any notes associated with the tag:
hiero/tags/Approved/note

Note: You must precede spaces and slashes in the tag name with \\
(backslashes) to enable Hiero to process the tag name correctly. For
example:
hiero/tags/Blue\\ Screen/note
You can also add burn-in through the Export dialog, see Adding Burn-in Text to
Exports for more information.
ChromaKeyer

Allows you to pull a quick chroma key from green or bluescreen areas of your
footage.
Use the screen color selector to choose a color from the Source input to use as
the blue/green screen color. To remove blue/green spill from the foreground
object, use the despill controls to pick skin tones from the source. Use the
matte parameters to improve the matte.

BlinkScript

Allows you to run Foundry's Blink framework on the timeline, enabling you to
write code once and run it on any supported device.

Warning: BlinkScript is very flexible, as there are no restrictions on the
code you can write within a kernel. As a result, code complied from the
Kernel Source can cause Nuke to crash, so please use caution!
The BlinkScript soft effect supports a subset of the functionality available in the
full BlinkScript node:
• You can't publish your kernels to Groups or Gizmos.
• Due to the way stacks of soft effects are processed in Hiero, the BlinkScript soft
effect only contains one input source and produces only one output.
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Soft Effect

Summary
• Currently, the BlinkScript soft effect only supports eAccessPoint data access,
which means that only one point from the input can be accessed at a time, and
only one point from the output can be written, for each iteration position.
• The following functions are not supported by the BlinkScript effect:
• log10
• round
• rsqrt
• abs for integer types
• modf(a, *b)
• sign
• rcp
• max, min, and clamp for integer types
• median, atomicInc and atomicAdd.
• The only data types supported by the BlinkScript effect are int, float, and bool.

Note: The BlinkScript soft effect supports both pixel-wise and
component-wise kernels, but the former is preferred for performance
reasons. For more information about this and a more detailed
description of the language, see
https://learn.foundry.com/nuke/developers/113/BlinkKernels/

Adding Sequence-Level Soft Effects
Warning: Please keep in mind the following:
• Sequence-level soft effects are only permitted on the same track as clips if they're trimmed
to exactly match the in and out points of individual clips. In this case, each effect is linked to
a specific clip.
• Soft effects can be trimmed arbitrarily if they're on tracks with no clips.
As well as adding soft effects using the spreadsheet view (see next section), the timeline provides
some additional ways to add soft effects. You can either:
• Right-click a shot on the timeline, select Effects and then select the soft effect you want to apply, or
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• Select a shot on the timeline, click the Add Effect button to the left of the timeline, and then select
the soft effect you want to apply.

Note: You can add a soft effect to multiple shots by selecting the required shots first and
then right-clicking on one of them and selecting the soft effect you want to add. A soft effect
is added to each of the selected shots. You can also add a single soft effect for the whole
track by right-clicking on the track header and then selecting the soft effect you want to add.

Note: TimeWarp effects are only allowed on tracks with clips (and therefore linked to clips).

Using the Spreadsheet View
You can add soft effects using the spreadsheet view in any workspace by doing the following:
1. To open the spreadsheet view in any workspace, select Window > New Spreadsheet View.
2. Right-click a sequence in the bin view.
This opens a context menu.
3. If the spreadsheet view is not already populated in the context menu, select Open In >
Spreadsheet View.
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This loads the sequence in the spreadsheet view that you previously opened.
4. Right-click an event from the list in the spreadsheet view and select Effects to open a list of all
available soft effects.
5. Select the required soft effect from the Effects list.
The sequence-level soft effect is then displayed above the shot and is color coordinated. For
example, if the effect appears in green on the timeline, the corresponding effect properties are
highlighted in the same color in the Properties pane.

When you insert a soft effect, its properties panel opens automatically. If you have it open, the
effect properties panel displays in the Properties pane. If the Properties pane is not open, the
effect's properties panel appears as a floating dialog.

Adding Shot-Level Soft Effects
Warning: Soft effects added at shot-level, must match the length of the shot on the locked
track. Any soft effect that is trimmed beyond the end of a shot, or a different length from the
shot is marked with red hashing to show that it is invalid.
You can add shot-level soft effects on the timeline, by doing the following:
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1. Right-click the shot that you want to add a soft effect to.
2. Select Open In > Timeline View.
3. Click the Effects menu icon and select the soft effect you want to apply. For example, you can
select Grade.
The soft effect is then displayed above the shot as a colored box.

When you close the timeline view of the shot – as it is a shot-level soft effect – the soft effect is
displayed as a colored line within the top of the shot. The color of the line displayed reflects the
highest soft effect added to the shot.

Soft Effect Controls
Adding an effect displays the associated controls in the Properties panel, similar to Nuke nodes.
Adjusting the controls affects the shots underneath the effect in real-time. For example, adding a
Grade effect at sequence level displays the Grade controls in the Properties panel.
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See the Nuke User Guide > Using the Compositing Environment > Properties Panels section, the Nuke
Reference Guide, or the Online Help for more information on node controls.
If you intend to animate soft effect controls using keyframes, you can use the Curve Editor and Dope
Sheet to fine-tune the output. To add the Curve Editor or Dope Sheet to the interface, navigate to
Window and select the required panel.

See the Nuke User Guide Getting Started > Using the Compositing Environment > Animating Parameters
section or the Online Helpfor more information.
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Editing Sequence-Level Soft Effects
You can copy, move, and cut soft effects just like you can with shots in the timeline. You can perform
these actions by either accessing them from Edit in the right-click menu, or by using the keyboard
shortcuts. You can copy soft effects to different tracks, and different sequences, but not different
projects.

Moving
You can move a sequence-level soft effect by simply clicking and dragging the soft effect to a different
shot, or even onto a different video track.

Copying
Hiero allows you to copy a sequence-level soft effect above the original to create a stack, to a different
track, or to a different sequence. You can also copy a sequence-level soft effect to a shot open in the
timeline view, therefore pasting it as a shot-level soft effect. You can copy a soft effect by doing the
following:
1. Select the soft effect you want to copy by clicking it.
2. Select Edit > Copy (or Ctrl/Cmd+C).
3. Move the playhead to where you want to paste the copy.
4. Select Edit > Paste (or Ctrl/Cmd+V).

Cloning
Hiero allows you to clone a sequence-level soft effect. This copies the soft effect and links it to the
original, which means when one of these is edited, the changes are reflected in the other one. You
can clone a soft effect to a different track or even a different sequence. You cannot clone a soft effect
in different projects.
To clone a soft effect:
1. Select the soft effect you want to clone by clicking on it.
2. Select Edit > Copy (or press Ctrl/Cmd+C).
3. Move the playhead on the timeline to where you want to place the new clone.
4. Select Edit > Clone (or press Alt+K).
The new clone is placed at the current playhead position on the timeline. You can repeat steps 3
and 4 to create multiple clones that are all linked, at different places on the timeline.
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Clones are indicated by a C highlighted in red in the left of the soft effect.

Note: Cloning animation in soft effects is not supported.

Copying as Clone
You can also copy a sequence-level soft effect as a clone. This means, when you paste a new copy of
the soft effect above a selected shot, it is automatically linked to the original soft effect as a clone.
Therefore, any changes made to either of the cloned soft effects, are reflected in the other.
To copy a soft effect as a clone, do the following:
1. Select the soft effect you want to copy as a clone by clicking on it.
2. Select Edit > Copy as Clones (or press Ctrl/Cmd+K).
3. Click on the shot that you want to clone the soft effect to.
4. Select Edit > Paste (or press Ctrl/Cmd+V).
The soft effect is copied as a clone on your selected shot. You can repeat steps 3 and 4 to create
multiple clones that are all linked above different selected shots.
Clones are indicated by a C highlighted in red in the left of the soft effect.

Note: Cloning animation in soft effects is not supported.

Decloning
To declone a soft effect, simply click on the clone you want to declone and select Edit > Declone (or
press Alt+Shift+K).

Note: For more information about copying, moving, and cutting soft effects, see Timeline
Editing Tools .

Deleting
To delete a soft effect, simply right-click on it and select Edit > Delete (or press Backspace).
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Editing Shot-Level Soft Effects
To edit a shot-level soft effect, you first need to open the shot with the applied soft effect, in the
timeline view. You can do this by right-clicking the shot and selecting Open In > Timeline View. You
can then copy, delete or move the shot-level soft effect in exactly the same way as sequence-level soft
effects.
You can copy and paste the shot-level soft effect on top of the original, creating a stack in the timeline
view. When you close the timeline view, stacked shot-level soft effects are displayed as a single line
within the top of the shot. Hiero allows you to copy a shot-level soft effect, return to the full
sequence, and then paste it as a sequence-level soft effect. You can also paste a shot-level soft effect
to another shot open in the timeline view.

Note: You cannot clone shot-level soft effects.

Enabling and Disabling Soft Effects
You can choose to disable and re-enable soft effects from the output. To enable or disable a
sequence-level soft effect, select the soft effect by clicking on the colored box and then pressing D. To
enable or disable a shot-level soft effect, you first need to open the shot – that includes the soft effect
– in the timeline view. Then you can select the soft effect and press D.
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Annotations
Annotations can be used as quick instructions for a compositor to implement in Nuke. You can add
annotations to a clip, a section marked with in and out points, or a whole sequence.

Annotations can be exported with a Nuke Comp and can then be viewed and/or deleted in the
Compositing environment. When all the suggested changes have been made to the script in the
Compositing environment, this can be saved as a new comp version and then rendered back to the
Timeline environment. If you want to add new annotations to the rendered Nuke Comp, you can
choose to re-export annotations only.

Workflow
The following steps show an example of Hiero workflow for annotations:
1. In the Viewer, open the Annotations menu.
See The Annotations Menu for more information for more information about it.
2. Add an annotation to a shot(s) at sequence or shot-level, by using the Annotation menu tools.
See Adding Annotations for more information.
3. You can choose to edit a sequence or shot-level annotation after it has been created. See Editing
Sequence-Level Annotations or Editing Shot-Level Annotations for more information.
4. Create a Nuke Comp of the shot with the annotations, ensuring annotations are enabled in the
export settings.
5. Open the Nuke Comp in an external Nuke application.
See Viewing Annotations in Nuke for more information.
6. After the suggested changes are made in the in the external Nuke, select File > Save New Comp
Version.
7. Return to the timeline, and version up the Nuke Comp by right-clicking it and selecting Versions >
Version Up.
The Nuke Comp is versioned up. Depending on your Preferences > Performance >
Threads/Processes > Rendering > background renders setting, the comp may need rendering
manually.
8. You can add new annotations to the rendered Nuke Comp by ensuring you select the Clip radio
button and then using the Annotations menu tools.
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9. After adding the new annotations, right-click the rendered Nuke Comp and select Export > ReExport Annotations.
10. Open the rendered Nuke Comp in an external Nuke application.
11. Double-click the Precomp node to open its properties and version it up. For example, if the file
path has v01.nk at the end, change it to v02.nk. See Re-Exporting Annotations from the Timeline
for more information.
12. Display the Precomp in the Viewer.
Your new annotations are displayed.

The Annotations Menu
You can open the Annotations menu by selecting the paint brush icon
Viewer.

at the top-right of the

The Annotations menu displays down the left side of the Viewer.

Note: Annotations on sequences and shots are only visible when you have the Annotations
menu open.

Adding Annotations
To add an annotation, do the following:
1. After you have opened the Annotations menu, move the playhead on the timeline to where you
want to add your annotation.
2. Click the + (addition) icon.
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A dialog is displayed containing annotation options.

3. You can choose which level you want to add your annotation to, sequence or shot-level, by
selecting either the Sequence or Clip radio buttons.
When you add an annotation to the clip level, a turquoise line is displayed within the top of the
shot. When you apply an annotation to the sequence level, a turquoise box appears above the
selected section on a separate Annotations track.
4. From the Range dropdown select one of the following:
• Current Item - Applies the annotation to the shot at the current playhead position.
• Current Frame - Applies the annotation to the frame at the current playhead position.
• In/Out Points - Applies the annotation to in and out points that have already been marked on
the timeline.
• All - Applies the annotation to the whole track.
• Custom - When you select this from the Range dropdown, the in and out point fields within the
dialog, become active. You can then use these to set the section that you want your annotation
to appear on.

Note: The timecode displayed in the In and Out fields is derived from the clip's metadata,
not its position in the sequence.
5. When you have set where you want your annotation to appear, click New.
A label is added to the location of your annotations, detailing the clip timecode and name.

You can click and drag this label to place it anywhere in the Viewer.
6. To draw in your annotation, select the paint brush tool from the Annotation menu.
This is highlighted orange when selected.
7. Before drawing in the Viewer, you can set the brush and paint settings:
• Select the brush and/or background color by clicking the paint colors icon

.
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This opens a color wheel that allows you to select the color and brightness, and an opacity slider
underneath that you can use to set the opacity of the paint.

• Select the paint brush size icon
to set the required brush size. You can either use the slider
to drag to your required brush size, or enter it into the brush size field.

Note: You can also edit these settings after drawing by clicking the selection tool in the
Annotations menu, selecting the lines that you've drawn in the Viewer, and then adjusting
the paint brush settings.
8. Click and drag in the Viewer to draw with your selected brush settings.

9. To add text to your annotation, click the text icon in the Annotations menu and then click
anywhere in Viewer to enter your required text.
A text dialog appears allowing you to type your required text, align it horizontally and vertically,
and adjust the text size. You can then click and drag the text box to anywhere in the Viewer.
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Enabling and Disabling Annotations
You can choose to disable and re-enable annotations from the output. To enable or disable a
sequence-level annotation, simply select the annotation by clicking on the turquoise box and then
pressing D. To enable or disable a shot-level annotation, you first need to open the shot – that
includes the annotation – in the timeline view. Then you can select the annotation and press D.

Editing Sequence-Level Annotations
You can choose to edit, copy, move, and delete any annotations that were added on the sequencelevel.
To remove an annotation from the sequence-level, simply select the turquoise box representing the
annotation you want to move from the Annotation track, right-click and select Edit > Delete (or press
Backspace or Delete on the keyboard).
To copy an annotation that was added at sequence level:
1. Select the annotation and then click Edit > Copy (or press Ctrl/Cmd+C). You can also access these
tools in the right-click menu.
2. Move the timeline playhead to the position where you want to paste the annotation.
3. Select Edit > Paste (or press Ctrl/Cmd+V).

Note: You can also copy and paste annotations, that were added at sequence-level, between
different sequences.
To move an annotation that was added at sequence level, you can simply click and drag it to the
required location. You can also drag annotations to different track levels.
You can trim an annotation at either end by hovering the cursor over one end of the annotation until
it changes into the trim icon:

Then click and drag to where you want to trim the annotation to.
To edit the actual annotation, you can use the selection tool in the Annotations menu to select the
annotation in the Viewer and move it, delete it, or replace it.
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Editing Shot-Level Annotations
You can choose to move, trim, and simply delete shot-level annotations.
To edit a shot-level annotation, you first need to open the annotated shot as a timeline. To do this:
1. Right-click the shot with the annotation you want edit.
2. Select Open In > Timeline View.
The shot opens in the Timeline View, and the annotation now appears as on a separate level from
the video. To view the annotation in the Viewer, ensure the Annotation menu is open.

To move a shot-level annotation from the Timeline view, hover the cursor over the annotation until it
changes into a move icon:

Then simply click and drag it to where you want to move it to.
You can trim an annotation at either end by hovering the cursor over one end of the annotation until
it changes into the trim icon:

Then click and drag to where you want to trim the annotation to.
To delete the annotation, click the turquoise box and select Edit > Delete (or press Backspace or
Delete on the keyboard).
To edit the actual annotation, you can use the selection tool in the Annotations menu to select the
annotation in the Viewer and move it, delete it, or replace it.
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Viewing Annotations in Nuke
If you want to view annotations in an external Nuke application, you need to ensure annotations are
enabled when creating a Nuke Comp. You can do this by either opening the Export dialog or the
Project Settings dialog and checking the option Basic Nuke Shot With Annotations is selected. See
using Create Comp Clips during round-tripping under Building VFX Tracks and Comp Clips for more
information.
To create a Nuke Comp with annotations, do the following:
1. Create a Nuke Comp by right-clicking on the shot that you want use to create a Nuke Comp, and
selecting Export.
The Export dialog opens.
2. In the Using Local export preset setting in the middle-top of the dialog, ensure Basic Nuke Shot
With Annotations is selected. Also, in the Tracks For This Export section in the bottom-left of
the dialog, ensure either all tracks is selected, or that the Annotations checkbox is selected with
certain tracks.
3. Click Export.
A message warns that you've changed the export templates and asks whether you want to keep
them.
4. Click Yes or No.
See Building VFX Tracks and Comp Clipsfor more information on bringing Nuke Comps back into
Hiero.

Viewing the Annotation Node Group
If you wish, you can view the annotations in an external Nuke by doing the following:
1. Double-click the Precomp node to open its properties panel, and the click Open.
This opens the contents of the Precomp node as a node tree in a new instance of Nuke.
2. Ensure you have the Node Graph tab selected.
The node tree displays in two parts. The top part represents the shot-level settings and the
bottom part represents the sequence-level settings. Depending on where you set your annotation
to be, an Annotations node group is displayed in the node tree.
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3. Double-click the Annotations node group to open its properties panel.
4. In the top-right of the node properties, click the node structure icon
the node group.

to display the contents of

This displays the contents of the Annotations node group in a new Node Graph tab.

Re-Exporting Annotations from the Timeline
You may want to add new annotations after the Nuke Comp has been edited and rendered. In this
case, you can re-export the annotations only.
To re-export annotations, do the following:
1. Move the playhead to the rendered Nuke Comp.
2. Press the + in the Annotations menu at the side of the Viewer, and select the Clip radio button.

Tip: You cannot add sequence-level annotations to a Nuke Comp.
3. Add an annotation using the brush or text tools in the Annotation menu.
4. Right-click the Nuke Comp, and select Export > Re-Export Annotations.
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5. Return to the Nuke script and double-click the Precomp node to open its properties, and version
it up.
For example, if the file path has v01.nk at the end, change it to v02.nk. You can also version up
the Precomp node by doing one of the following:
• Select the Precomp node and press Alt+Up Arrow.
• Select the Precomp node and click Edit > Node > Filename > Version Up.
6. Ensure the Precomp node is connected to a Viewer node.
Your new annotation is now visible in the Viewer.
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The timeline editing tools allow you to manipulate your shots directly in the timeline, in single- or
multi-view projects, using a series of modal editorial tools that complement the Multi Tool. Select the
tool you need for the job and then select a new tool and continue editing.

The timeline editing tools are grouped for convenience - each tool group contains several tools and
you can cycle between them by clicking the tool or using keyboard shortcuts. The editing tools work
the same way in single- and multi-view timelines.
Icon

Tools

Description

Multi Tool

The Multi Tool’s functionality is equivalent to most of the other tools
combined, but doesn’t require modal tool selection.

Move/Trim

The Move/Trim tool allows you to manipulate the position of a shot or
its output by adding or removing handles.

Select

The marquee Select tool allows you to make multiple selections quickly
by lassoing shots. Hold Shift to add to the selection and Alt to subtract
from the selection.

Selection by
Track

The track selection tools allow you to quickly select multiple items
depending on the initial selection. For example, the Select Track to
Right tool selects all shots to the right of the target shot, within a single
track.

Slip Clip

The Slip Clip tool allows you to shift a shot’s In and Out points by the
same amount and in the same direction, retaining the original duration
but altering the timeline output.

Slide Clip

The Slide Clip tool allows you to move a shot in relation to the item
before and/or after the target item, without changing its length or
timeline output.

Roll Edit

The Roll Edit tool enables you to roll a single edit within the available
handles, shortening one shot while lengthening the other, but keeping
the overall duration the same.
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Icon

Tools

Description

Ripple Edit

The Ripple Edit tool operates similarly to the trim function of the
Move/Trim tool, except that downstream shots are rippled to
automatically close any resulting gaps in the timeline.

Retime Clip

The Retime Clip tool allows you to trim a shot’s In or Out point and
automatically retime the clip to fill the new shot duration.

Razor

The Razor and Razor All tools allow you to cut shots in to separate
parts so you can remove sections or rearrange items on the timeline.

Join

The Join tool can only be used on edit points between two razored
shots, denoted by the yellow arrows at the edit.

Tip: Enabling Preferences > Panels > Timeline > show frame end marker draws an extra
line on the timeline to the right of the playhead, indicating the end of the current frame.
The modal editorial tools are mapped to the Q, W, E, R, and T keyboard shortcuts when the timeline
is the active tab.

Note: For a full list of keyboard shortcuts, please see Appendix B: Keyboard Shortcuts.

Pressing a keyboard shortcut multiple times selects the tools within each mode. For example,
pressing E twice, rapidly in succession activates Slide Clip. Pressing them slowly in succession does
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not achieve the same result, but instead, remains on the first item in the menu. This allows you to
activate a tool without knowing the current state of tool selection.
• mapped to Q, cycles through Multi Tool, Move/Trim, and Select.
• mapped to W, cycles through Track Selection tools.
• mapped to E, cycles through Slip Clip and Slide Clip.
• mapped to R, cycles through Roll Edit, Ripple Edit, and Retime Clip.
• mapped to T, cycles through Razor, Razor All, and Join.
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Using the Multi Tool
Unlike the other editing tools available, the Multi Tool changes function depending on the position of
your pointer in relation to the shot(s) selected.

The Multi Tool’s functionality is equivalent to most of the other tools combined, but doesn’t require
modal tool selection:
• Move - placing the mouse in the center of a shot activates the tool. Drag the selected shot to the
required position on the timeline.
• Trim - placing the mouse at the left or right of the shot activates the tool. Drag the edit point to the
new position and release the mouse to complete the trim.
See Using the Move/Trim Tool for more information.
• Select - click-and-drag to marquee select clips. Hold Shift to add to your selection or Alt to subtract.
See Using the Selection Tools for more information.
• Slip - placing the mouse at the bottom of the shot activates the tool and displays the slip handles.
Drag the shot to the new position and release the mouse to complete the slip.
See Using the Slip Clip Tool for more information.
• Slide - placing the mouse at the top of the shot activates the tool and displays the slide handles.
Drag the shot to the new position and release the mouse to complete the slide.
See Using the Slide Clip Tool for more information.
• Roll - placing the mouse on the edit between shots activates the tool and displays the handles. Drag
the edit to the new position and release the mouse to complete the roll.
See Using the Roll Edit Tool for more information.
• Razor - when using the Multi Tool, Razor cuts are menu driven. Navigate to Timeline > Razor
Selected or Razor All to make cuts at the current playhead position.

USER GUIDE

267

Using the Multi Tool |

See Using the Razor and Join Tools for more information.
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Using the Move/Trim Tool
The Move/Trim tool allows you to manipulate the position of a shot or its output by adding or
removing handles. Activate the Move/Trim tool by clicking the tool or pressing Q twice.

Moving Shots
Click and drag the selected shot(s) to the required position on the timeline. A time count popup, in
conjunction with the snap to edit function, helps you to reposition the shot(s) accurately.

You can also move shots up and down the track hierarchy using drag-and-drop or the Alt+, (comma)
and Alt+. (period) keyboard shortcuts.
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The following table describes the Move/Trim tool’s modifiers and actions:
Mode

Method

Description

Overwrite

drag-and-drop

The default move mode. The dragged shot overwrites
any items that are present in the move location.

Ripple

drag then hold Alt and
drop

Drag-and-drop shots on top of other items without
overwriting content - items are pushed down the
timeline to accommodate the move.

Duplicate

hold Alt and drag then
release Alt and drop

Copy the shot, then drag-and-drop on top of other
items overwriting existing content - items are not
pushed down the timeline to accommodate the move.

Ripple and
Duplicate

hold Alt then drag and
drop while holding Alt

Copy the shot, then drag-and-drop items on top of
others without overwriting content - items are pushed
down the timeline to accommodate the move.

Note: On Linux, hold Ctrl+Alt for Duplicate and RippleDuplicate modifiers.
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Action

Keyboard Shortcut

Description

Delete

Backspace

Delete the selected shot(s) or gap(s).

Ripple
Delete

Shift + Backspace

Remove the selected shot(s) and ripple items down stream to
close gaps in the timeline.

Note: The ripple effect may not close gaps entirely,
because Hiero does not allow linked tracks to
become desynchronized during rippling.

If you need to nudge shots horizontally by just a frame or two, you can select the items on the
timeline and press , (comma) to nudge it left or . (period) to nudge it right. Press Shift+, (comma) or .
(period) to nudge the shot horizontally by the FrameIncrement set under the Viewer.

Note: You cannot overwrite other shots on the timeline horizontally using the nudge keys.
However, vertical nudging (Alt+, and Alt+.) overwrites other tracks.

To Move Shots Using the Spreadsheet View:
1. Select the required events in the spreadsheet view.
2. Click the cog icon and select the required Time Edit Behaviors:
Modify

Using

Result

Dst In

Move
Destination

Adjusts the event’s Dst In and Out by the same amount, moving the
shot’s position on the timeline by the specified amount, while
maintaining Speed.
Before and after a 2 second Dst In increase:

Dst Out

Move

Adjusts the event’s Dst Out and In by the same amount, moving the
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Modify

Using

Result

Destination

shot’s position on the timeline by the specified amount, while
maintaining Speed.
Before and after a 2 second Dst Out increase:

3. Adjust the Dst In or DstOut to move the shot(s) by the specified amount.

Trimming Shots
Click-and-drag the edit point to the new position and release the mouse to complete the trim.

Tip: Use the Ripple Edit tool, activated by pressing R twice, to ripple downstream shots
automatically.

USER GUIDE

272

Using the Move/Trim Tool | Trimming Shots

The Viewer displays the new In or Out point (depending on whether you’re adjusting the beginning or
end of the shot), allowing you to accurately gauge the new output.

Note: Trimming multiple shots simultaneously trims each item by the same amount and in
the same direction.
Alternatively, click an edit point and nudge the edit using the Ctrl/Cmd+ßà (numeric pad) keys or
hold Shift to nudge by the Frame Increment set under the Viewer.

By holding Ctrl/Cmd and dragging an edit, you can add blank frames past the end of the shot’s
handles. Blank frames are colored red on the timeline for clarity:
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To Trim Shots Using the Spreadsheet View:
1. Select the required events in the spreadsheet view.
2. Click the cog icon and select the required Time Edit Behaviors depending on whether you’re
using the In or Out points or duration:
Modify

Using

Result

Src In

Trim In

Trims the event’s Src In, Dst In, and durations while maintaining speed.
Before and after a 2 second Src In increase:

Src Out

Trim Out

Trims the event’s Src Out, Dst Out, and durations while maintaining
speed.
Before and after a 2 second Src Out increase:
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Modify

Using

Result

Src Dur

Trim Out

Trims the event’s Src Dur, Dst Dur, and Src/Dst Out while maintaining
speed.
Before and after a 50 frame Src Dur increase:

Dst In

Trim In

Trims the event’s Dst In, Src In, and durations while maintaining speed.
Before and after a 2 second Dst In increase:

Dst Out

Trim Out

Trims the event’s Dst Out, Src Out, and durations while maintaining
speed.
Before and after a 2 second Dst Out increase:

Dst Dur

Trim Out

Trims the event’s Dst Dur, Src Dur, and Dst/Src Out while maintaining
speed.
Before and after a 50 frame Dst Dur increase:
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3. Adjust the values as required to trim the shot(s) by the specified amount.
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Using the Selection Tools
The timeline editing tools include a marquee selection tool and several context dependent track
selection tools.
The marquee Select tool, activated by clicking the tool or pressing Q three times, allows you to make
multiple selections quickly by lassoing shots.
Hold Shift to add to the selection:

The track selection tools, activated by clicking the tool or by pressing W, selects multiple items
depending on the initial selection:
• Select Track to Right or Left - all shots right or left of the target shot are selected, within a single
track.
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• Select All in Track - all shots on the target track are selected, regardless of the item selected.

• Select All Tracks Right or Left - all shots right or left of the target item are selected, regardless of
which track they occupy.
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Using the Slip Clip Tool
The Slip Clip tool allows you to shift a shot’s In and Out points by the same amount and in the same
direction, retaining the original duration but altering the timeline output. Activate the Slip Clip tool by
clicking the tool or pressing E.

Note: The target shot must have handles to use the Slip tool.
The Slip Clip tool displays different Viewer previews depending on whether the playhead is on the
target shot or not, but the basic principles are the same.
Click the target clip to display the available handles and then drag the shot to the new position.
Release the mouse to complete the slip.

Note: Using the Slip Clip tool does not move the shot on the timeline, only the output is
changed.
Alternatively, nudge the slip using the , (comma) or . (period) keys or hold Shift to nudge by the
Frame Increment set under the Viewer.

Tip: If you’re using the Multi Tool, you can nudge using the “slip bar” by clicking at the
bottom the shot.
The following Viewer previews are displayed, depending on the playhead position:

Note: The Viewer background always displays the playhead’s current position.

USER GUIDE

280

Using the Slip Clip Tool | Slipping Using the Spreadsheet View

• When the playhead is not currently on the target shot, the Viewer displays the In frame (1) and Out
frame (2), allowing you to accurately gauge the new output.

• When the playhead is on the target shot, the Viewer displays the In frame (1), the current frame (2),
and Out frame (3), allowing you to accurately gauge the output of the shot against the current
frame.

• When the playhead is on the target shot and A/B compare is active, the Viewer displays the target
shot (1) and the reference shot (2), allowing you to synchronize your working track against the
reference track.

Slipping Using the Spreadsheet View
You can slip shots using the Src In and Src Out columns of the spreadsheet:
1. Select the required event in the spreadsheet view.
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2. Click the cog icon and select the required Time Edit Behaviors depending on whether you’re
using the In or Out point:
Modify

Using

Result

Src In

Slip
Source

Adjusts the Src In and Src Out by the same amount, slipping the event
while maintaining speed.
Before and after a 2 second Src In increase:

Src Out

Slip
Source

Adjusts the Src Out and Src In by the same amount, slipping the event
while maintaining speed.
Before and after a 2 second Src Out increase:

3. Adjust the Src In or Src Out to slip the shot(s) by the specified amount.
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Using the Slide Clip Tool
The Slide Clip tool allows you to move a shot in relation to the item before and/or after the target
item, without changing its length or timeline output. Activate the Slide Clip tool by clicking the tool or
pressing E twice.
The shot either side of the target are shortened or lengthened within the limits of their handles to
accommodate the slide.

Note: The surrounding shots must have handles to use the Slide tool.
Click the target shot and then drag it to the new position and release the mouse to complete the
slide.
For example, if you slide the target shot (2) five frames to the right, the preceding item (1) ends five
frames later and the next item (3) starts five frames later.
The first image shows a timeline containing three shot, and the second shows the same shots with
the target (2) sliding to the right.
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The Viewer displays the new end point of the previous shot on the left and the new start point of the
next shot on the right, allowing you to accurately gauge the slide.
The two center images (2) represent the start and end frames of the target shot, which don’t change.
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Using the Roll Edit Tool
The Roll Edit tool enables you to roll a single edit within the available handles, shortening one shot
while lengthening the other, but keeping the overall duration the same. Activate the Roll Edit tool by
clicking the tool or pressing R.

Note: At least one of the target items must have handles to use the Roll tool.
1. Click an edit point between two shots to display the available handles as a red overlay.
2. Drag the edit to the new position and release the mouse to complete the roll.
For example, if you roll a number of frames at the end of one shot (1), the next item (2) starts that
number of frames later. The first image shows a timeline containing two shots, and the second
shows the same items with the edit point “rolled” to the right.
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The Viewer displays the pre-edit shot on the left and the post-edit item on the right, allowing you to
accurately gauge the new position of the edit.

Alternatively, click the edit point between the shot and nudge the edit using the , (comma) or . (period)
keys or hold Shift to nudge by the Frame Increment set under the Viewer.
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Using the Retime Clip Tool
The Retime Clip tool allows you to trim a shot’s In or Out point and automatically retime the clip to
fill the new shot duration. Activate the Retime Clip tool by clicking the tool or pressing R three times.
Click-and-drag the edit point to the new position and release to complete the trim and retime. For
example, trimming a 50 frame shot to 25 frames retimes the clip to 200%.

Alternatively, click an edit point and nudge the edit using the , (comma) or . (period) keys or hold Shift
to nudge by the Frame Increment set under the Viewer.
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Tip: By holding Ctrl/Cmd and dragging an edit, you can retime past the end of the shot’s
handles.
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Using the Razor and Join Tools
The Razor tools allow you to cut shots in to separate parts so you can remove sections or rearrange
items on the timeline. Activate Razor and Razor All by clicking the tool or pressing R.
Place the cursor on the target shot, and if the cut is permissible, click to razor the shot or all shots
depending on which tool you have selected.

Tip: The Razor cursor indicates whether a cut is permissible or not, such as on existing
edits.
You can also apply cuts at the playhead position from the menu bar using Timeline > Razor
Selected, or all tracks using Timeline > Razor All.

Tip: Use the C (with the shot under the playhead selected) and Shift+C keyboard shortcut, or
the right-click context menu, to perform the respective cuts.
The Join tool can only be used on edit points between razored shots, denoted by the yellow arrows at
the edit.
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Copying Cuts Between Tracks
The Copy Cuts function allows you to quickly apply cuts from one track to other tracks on the
timeline. For example, in the timeline shown, you could copy the cuts from the second video track to
the Reference audio tracks.

To copy cuts:
1. Select the shots containing the cuts to copy, or if you intend to copy all the cuts from a track you
don’t need to make a selection.
2. Right-click in the timeline and select Editorial > Copy Cuts.
The Copy Cuts dialog displays.
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3. If you made a selection on the timeline, use the dropdown to select Copy All Cuts or Copy
Selected Cuts as required.
This dropdown is not displayed if no shots were selected.
4. Click the From dropdown to select the source track.
5. Check all the destination tracks in the To field to which you want to copy the cuts.
6. Choose whether or not the resulting shots are named identically to the source track.
Selecting None retains the destination clip name.
7. Click OK to copy the cuts to the destination track(s).
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Insert, Overwrite, and 3-Point
Editing
Insert and Overwrite edits are applied at the current playhead position by default, but the use of In
and Out points in the clip Viewer and/or sequence Viewer can give you greater control over the result.
3-point editing, makes use of In and Out points in the clip Viewer and an In or Out in the sequence
Viewer to control where the clip is placed on the timeline.

Inserting Clips
By default, Insert places the entire contents of the clip Viewer into the timeline at the current
playhead position, on the lowest available track. All shots downstream of the playhead are rippled to
make room for the clip. No items are overwritten or removed.

Pre-insert timeline

Post-insert timeline

Note: If the playhead is not positioned at an edit point, or there are shots on other tracks,
the Insert action cuts the shot(s) at the playhead and ripples the cut downstream.
For example, the Post-insert image shows the audio shot being cut and rippled, even though
it doesn’t reside on the same track.
You can select a track before inserting if you don’t want to target the lowest available track. Even if the
target track is empty, shots on all other unlocked tracks are rippled by the same amount.
You can also use In and Out points to control where the clip is inserted and how many frames are
included. See 3-Point Editing for more information.
To insert a clip at the playhead:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
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2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer
3. Double-click the source clip to load it into the left-hand clip Viewer

.

.

4. Place the playhead at the required edit point or timecode and select the target track, if necessary.
5. Navigate to Clip > Insert, or press N, to insert the clip into the timeline.
All shots downstream of the clip are rippled to make room for the duration of the edit.
To insert a clip at an In or Out point:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer
3. Double-click the source clip to load it into the left-hand clip Viewer

.

.

4. Place an In or Out point on the timeline to determine the clip’s position:
• In point - the source clip is inserted so that the first frame is at the In point specified.
• Out point - the source clip is inserted so that the last frame is at the Out point specified.
5. Navigate to Clip > Insert, or press N, to insert the clip into the timeline.
All shots downstream of the In or Out point are rippled to make room for the duration of the edit.

Overwrite Edits
Unlike inserting, Overwrite does not incorporate downstream ripple and doesn’t alter the length of
your sequence. Any shots you overwrite are destroyed, though they can easily be recovered from the
source clips in the bin view.

Pre-overwrite timeline

Post-overwrite timeline

You can select a track before overwriting if you don’t want to target the lowest available track.
You can also use In and Out points to control what the clip overwrites and how many frames are
included. See 3-Point Editing for more information.
To overwrite at the playhead:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer

.
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3. Double-click the source clip to load it into the left-hand clip Viewer

.

4. Place the playhead at the required edit point or timecode and select the target track, if necessary.
5. Navigate to Clip > Overwrite, or press M, to overwrite from the playhead for the duration of the
source clip.
All shots under the source clip are overwritten.
To overwrite from an In or Out point:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer
3. Double-click the source clip to load it into the left-hand clip Viewer

.

.

4. Place an In or Out point on the timeline to determine the clip’s behavior:
• In point - the source clip begins overwriting from its first frame at the In point specified
downstream for the duration of the clip.
• Out point - the source clip begins overwriting from its last frame at the Out point specified
upstream for the duration of the clip.
5. Navigate to Clip > Overwrite, or press M, to overwrite from the In or Out point for the duration of
the source clip.
All shots under the source clip are overwritten.

3-Point Editing
Setting the output of a source clip and then editing the clip into a timeline at a specific point is
sometimes referred to as 3-point editing. Using this method, you can insert and overwrite edits in an
existing timeline or quickly construct scratch timelines from your source clips.
Firstly, set the output of your source clip using In and Out points in a clip Viewer, then set the
reference In or Out point on your timeline to determine the clip’s position. Finally, add the clip to the
timeline using Insert or Overwrite.

Tip: You can set both In and Out points on the timeline, but bear in mind that there may be
insufficient source frames for the range specified. If this is the case, blank frames are added
and highlighted in red.
You can select a track before editing if you don’t want to target the lowest available track. When
inserting, even if the target track is empty, shots on all other unlocked tracks are rippled by the same
amount.
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
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2. Double-click the required source clip to load it into the left-hand clip Viewer

.

3. Set the required frame range using In and Out points.
4. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer

.

5. Set In and/or Out points on the timeline to specify where the clip should be added and use Insert
(N) or Overwrite (M) as required.
As an example, assuming your clip Viewer and timeline are represented by the following image,
and the Overwrite function is used:

• No In or Out points - insert or overwrite at the current playhead position, for the range
currently set in the clip Viewer.
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• In point but no Out point - insert or overwrite from the In point position downstream, for the
range currently set in the clip Viewer.

• Out point but no In point - insert or overwrite from the Out point position upstream, for the
range currently set in the clip Viewer.
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• In and Out points - insert or overwrite at the current In point position, for the duration set by
the timeline's In and Out points. If there are insufficient source frames for the range specified,
blank frames are added highlighted in red.
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Versions and Snapshots
In addition to the regular project save and restore options, Hiero can record the different states of
your workflow as you progress using versions and snapshots.

Versions are children of clips. You can have any number of versions per clip as long as they follow
the correct naming conventions, as shown in Using Versions. Versions can only be applied to source
clips and shots and can be swapped in and out without overwriting existing work.
Snapshots are time-stamped copies of a sequence, allowing you to save its current state without the
inconvenience of saving the entire project. When you restore a snapshot, a warning displays prior to
the restore reminding you that edits since the snapshot was taken are lost. See Using Snapshots for
more information.
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Using Versions
Versions can be added to source clips and shots to allow greater flexibility in your workflow. You can
have as many versions as required and cycle through them quickly using keyboard shortcuts.

Note: You cannot use versions when a clip is opened as a timeline, that is, by using the
right-click Open In > Timeline View option.
The application relies on specific file naming or folder structure conventions to discover versions:
Convention

Description

Example

File name constants
Clip name

The file name base must remain the same.

myClip_v1.0001.dpx
myClip_v2.0001.dpx
myClip_v3.0001.dpx

Version prefix

The delineation between the file name and
version information must be either _
(underscore) or . (period) and remain the
same for all versions.

myClip_v1.0001.dpx

The version number padding in the clip
name can be increased or decreased.

myClip_v1.0001.dpx

myClip_v2.0001.dpx
myClip_v3.0001.dpx

File name variables
Version
padding

myClip_v002.0001.dpx
myClip_v03.0001.dpx

Frame padding

The frame padding in the clip name can be
increased or decreased.

myClip_v1.01.dpx
myClip_v1.1.dpx
myClip_v1.0001.dpx

Extension

The file format is interchangeable. See
Appendix C: Supported File Formats for

myClip_v1.01.png
myClip_v1.0001.dpx
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Convention

Description

Example

more information.

myClip_v1.mov

Note: If the file extension is a movie format, such as .r3d or .mov, the Frame padding
can be omitted.
Folder name constants
Root folder

The root folder name must remain the
same for all folders containing versions.

~/version/v1/myClip_v1.0001.dpx
~/version/v2/myClip_v2.0001.dpx
~/version/v3/myClip_v3.0001.dpx

Folder name variables
Version
padding

The version number padding in the folder
name can be increased or decreased.

09_WF_Shot004_v1
09_WF_Shot004_v002
09_WF_Shot004_v03
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Versions in Bins
Versions behave similarly in both bins and sequences, and in both cases, you first have to ingest an
existing version.
Ingest and locate the versioned clip, then:
1. Right-click and select Version > Scan for Versions to search for available versions.
A dialog box lets you know how many versions were discovered.
2. Use the right-click Version menu to:
• Go to the next Version Up or Version Down.
• Go to the Minimum or Maximum Versions.

Tip: You can also use the Alt+Up/Down Arrow keyboard shortcuts to increment versions or
Alt+Shift+Up/Down Arrow to go to the maximum or minimum.
When you reach the end of the discovered versions, incrementing the version automatically scans
for new versions that may have become available.
3. For source clips only, you can right-click the clip and select Open In > Versions Bin to display all
discovered versions of the target clip.
The versioning conventions may allows clips into the Version Bin that you weren’t expecting. You
can disable versions by selecting them and pressing D or by selecting the Set Active Version of a
clip using the right-click Version menu.
The Active Version is the version displayed when you drag the source clip to the timeline,
denoted by the orange V in the top left-hand corner of the thumbnail.
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4. Once you’ve sorted all the available versions, select a clip in the bin view and press V to display all
versions for that clip in a convenient window. Disabled versions are not displayed.

5. Select the required clip to set the Active Version and apply it to the clip.
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Versions in Sequences
As mentioned previously, versions behave similarly in both bins and sequences, but swapping
versions in sequences allows you to compare results more easily.

Note: You cannot use versions when a clip is opened as a sequence, that is, using the rightclick Open In > Timeline View option.
Locate the ingested version clip and drag it to the timeline, right-click and select the Version menu:
• Scan For Versions to locate new versions of the clip.
• Version Up or Version Down to increment the version by one.
• Go to the Minimum or Maximum Version.

Tip: You can also use the Alt +Up/Down Arrow keyboard shortcuts to increment versions
or Alt+Shift+Up/Down Arrow to go to the maximum or minimum.
Once you’ve scanned for versions, select a shot on the timeline and press V to display all available
versions for that item in a convenient window.

Select the required shot version to set the Active Version.
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Using Snapshots
Within a project you can save the current state of a sequence as a snapshot, including a comment or
tag to describe that snapshot. You can see what snapshots exist for a sequence in the bin view and
flip it back to any previously saved state.
An example workflow might appear as follows:

1. Two snapshots of the sequence (SQ) are recorded after edits. See Creating Snapshots.
2. Snapshot 1 is then restored. See Restoring Snapshots.
3. Further edits are made, then the sequence is recorded as snapshot 3.
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Creating Snapshots
To create a snapshot for a sequence:
1. Locate the sequence in the bin view.
2. Right-click the sequence and select Snapshot > Add Snapshot.

The Add new snapshot dialog box displays.

3. Enter a comment, or use the default date and time supplied.
4. Click Add to create the snapshot.
Snapshots are indicated in the bin view with a camera icon containing the number of snapshots
available.
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Restoring Snapshots
To restore a snapshot:
1. Locate the sequence in the bin view.
2. Right-click the sequence and select Snapshot > Restore Snapshot.
3. Select the required snapshot from the list.
A warning displays reminding you that edits since the snapshot was taken are lost.

4. Click OK to restore the sequence to the point at which the snap was recorded.
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Exporting from Hiero
This section deals primarily with shot management and export functionality when you're farming out
shots or sequences to other artists. It also deals with the presets, which dictate how Create Comp
Clips passes data between Hiero and Nuke.

The export suite can transcode, export clip selections from a timeline or bin, write out EDLs and
XMLs, or bake out an entire timeline as a single clip in your required delivery format. The Export
presets are also used to manage how Create Comp Clips sends clips back and forth between Hiero
and Nuke using Local and Project Presets.
Hiero ships with several context-sensitive and ad hoc export options:
• Exporting Sequences and Shots - the process of preparing a sequence or individual shots for export
and paving the way for VFX work to come back into Hiero.
• Transcoding - converts one file format to another. You can transcode sequences, timeline
selections, and clips from the bin view.
• Ad Hoc Exports - an umbrella covering exports that you might not perform on a per project basis,
such as EDL or XML exports.
With the addition of Python bindings to perform the same functions, this infrastructure provides a
massive amount of flexibility, whether your pipeline is GUI or command line orientated.

Note: Hiero is non-destructive and can slot into your pipeline if you setup your shot
template to mirror the existing file structure.

Round-Tripping Using the Export Dialog
A round-trip describes the process of exporting clips to another application, in this case Nuke, and
then paving the way back into Hiero to conform the new VFX clips.
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Introduction to the Export Dialog
Hiero uses presets and shot templates to perform export operations, including round-tripping and
EDL/XML creation. The Export dialog controls what is exported and where, and whether or not to
expect versioned clips as part of a round-trip from Nuke.
The Export dialog is accessed from the File menu, from the right-click bin and timeline menus, or by
using the keyboard shortcut Ctrl/Cmd+Shift+E.
The Shot Template is also used to create the presets used during Create Comp Clips, passing shots
from Nuke and sending rendered Write nodes from the Node Graph back to Hiero.

Hiero uses Content Presets in all shot templates, enabling you to create commonly used export
conditions, which are then available across all projects. Some presets are only available with certain
exporters, for example, the EDL Exporter preset cannot be used with Process as Shots exports.
You can filter your exports using the Tracks for this Export and Filter by Tag lists, exporting only
certain tracks or shots marked with a particular tag. See Using Tags for more information.
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For your convenience, Hiero ships with a number of ready-made Content Presets, but you can edit
these as required:
• Transcode Images - defines transcode parameters allowing you to save your most-used file type
conversions.
• Nuke Project File - defines the script name and paths used by Nuke Read and Write nodes during a
round-trip or Create Comp Clips.
• Nuke Write Node - defines the render format for Nuke Write nodes. Add multiple Nuke Write Node
presets to create multiple Write nodes in the resulting Nuke script.
• Nuke Annotations File - defines the script name and paths used by Nuke Write nodes and
Precomp group during a round-trip or Create Comp Clips.
• Render with - selects how Hiero renders your export: Single Render Process or Frame Server.
This dropdown defaults to Frame Server using the number of slave processes specified in the
Preferences > Performance > Threads/Processes. If you set this preference to 0, Hiero relies on
external machines set up as render slaves. See Using the Frame Server on External Machines for
more information.
• EDL Exporter - used to export a sequence to the EDL format.
• SymLink Exporter - creates symlinks to the location of the source files, rather than making copies.
• XML Exporter - used to export a sequence to XML format.
• Copy Exporter - creates copies of the source files to a specified location, rather than symlinking.
• Audio Export - copies any audio tracks to .wav files in a specified location.
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Using Local and Project Presets
Presets are containers for export preferences, such as file structure and format, and filters for tracks,
tags, and frame range. Two types of Presets are available to construct commonly used export tasks:
• Local Presets - these presets are used to set up round-trips between artists on different platforms
and also to manage passing files between the Timeline and Nuke. Local Presets are saved in a Task
Presets folder using the XML file format.
• Project Presets - you can drag-and-drop Local Presets into this panel to save the preset within a
project .hrox file. This option is designed for collaborative work, allowing you to quickly share your
export presets.

Using the Shot Template
The shot template sets up the folder hierarchy and naming conventions for export presets such as
Basic Nuke Shot with Annotations and Transcode Clip DPX, and how Create Comp Clips sends
clips back and forth between Hiero and Nuke. Any folders added to the template are created during
export unless they already exist, in which case the export writes to the existing structure.
Nuke Studio ships with default templates for your convenience, but you can quickly create custom
templates using folders and “tokens”, which are replaced with the relevant information during export.

Tip: Clicking an entry in the shot template displays a preview file path with the tokens
resolved under the Version token number field.
Exports can resolve the following tokens:
Token

Resolves to

_nameindex

The index of the shot name in the sequence, preceded by _
(underscore), to avoid clashes with shots of the same name.

{ampm}

The local equivalent of either AM or PM.

{binpath}

The bin structure to preserve. Including this token recreates your bin
structure up to the nearest parent bin.

{clip}

The name of the clip used in the shot processed.
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Token

Resolves to

{day}

The local weekday name, abbreviated to Mon, Tue, and so on.

{DD}

The day of the month as a decimal, 01, 02, and so on.

{event}

The timeline event number associated with the shot to process.

{ext}

The extension of the file to output, such as .dpx or .mov

{filebase}

The base of the clip name to process. For example, the filebase of
Shot01_####.dpx is Shot01_####.

{fileext}

The format of the clip to process, such as .dpx or .mov

{filehead}

The source clip filename not including frame padding or extension.
For example, the filehead of Shot01_####.dpx is Shot01.

{filename}

The source clip name of the media to process.

{filepadding}

The source filename padding, which you might use for formatting
frame indices.

{filepath}

The full file path to the source media referenced in the export.

{fullbinpath}

The full bin structure to preserve. Including this token recreates the
bin structure up to the project level.

{fullday}

The local full weekday name.

{fullmonth}

The local full month name.

{hierotemp}

The temp directory as specified in the Preferences.

{hour12}

The export start time hour component (12-hour clock).

{hour24}

The export start time hour component (24-hour clock).

{MM}

The month of the year as a decimal, 01, 02, and so on.

{minute}

The export start time minute component.

{month}

The local month name, abbreviated to Jan, Feb, and so on.

{project}

The name of the parent project of the export item.

{projectroot}

The root export file path as specified in the Project Settings.
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Token

Resolves to

{second}

The export start time second component.

{sequence}

The sequence name to process.

{shot}

The name of the shot to process.

{timestamp}

The export start time in the 24-hour clock format (HHMM).

{track}

The name of the track to process. Exporting EDLs using this token
generates a separate EDL for each track.

{user}

The current username.

{version}

The string v#, defined by the number (#) set in the Version section of
the export dialog

{YY}

The year of the century as a decimal, 01, 02, and so on.

{YYYY}

The year, including century.

Tip: Double-click the path column, right-click, and then choose Select Keyword to display a
list of available export tokens, though only valid tokens for the current selection are listed.

Token substrings are valid if you need to extract a certain part of an evaluated string. For example, if
{shot} resolves to JB100, then:
• {shot [0:2] } - resolves to JB
• {shot [-3:] } - resolves to 100
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Similarly, anything within the outer brackets is evaluated as a Python string. For example, if {shot}
resolves to JB_10_20, then:
• {shot.split(’_’) [0] } - resolves to JB
• {shot.split(’_’) [2] } - resolves to 20

Custom Shot Templates
The shot template enables you to create as many Nuke Read and Write nodes as required for a
project. A typical use case might be creating .jpg clips for review and .dpx resolution clips for
finishing.

Multi-format Exports
The following example describes how to build a shot template to export a sequence of .mov clips,
create .dpx and .jpg Write nodes in Nuke, and bring the .dpx clips back into the timeline.
1. In the Export dialog, select Basic Nuke Shot in the Local Presets panel to auto-complete the
shot template with the preset values.
2. Click Duplicate selected preset and give the new preset a name.
3. Rename the renders folder renders_dpx.
4. Select the nuke folder and click the folder icon to add a new folder. Name the new folder
renders_jpg.
5. Select the renders_jpg folder and click

to add a new entry.

6. Replace the {filename} token with {shot}_comp{_nameindex}_{version}.####.{ext}, the same as
the existing entry under renders_dpx.

Note: The #### marks represent frame numbers for image sequences. If you were creating
.mov clips, they’d be omitted.
The shot template should look something like this:
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7. Click the Content column and select Nuke Write Node.

Note: When using a third party application to produce the VFX work, select
ExternalRender instead of Nuke Write Node.
8. In the Content settings tab, use the File Type dropdown to select jpeg.
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Notice that the settings available change depending on the File Type selected.
9. Click Nuke Project File in the shot template and check that both Write nodes are enabled.

10. Set up the rest of the export as described in Exporting Sequences and Shots and click Export.
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Adding Burn-in Text to Exports
Hiero can burn-in text during the export process using a simple Nuke gizmo. The gizmo is accessed
from the Nuke Write Node preset's Content panel under Burn-in.
The gizmo contains controls for the font style and fields denoting the position of the text. You can
also add burn-in directly on timeline using the Burn-In soft effect. See Soft Effects for more
information.

Note: The Font field only accepts the full file path and name of the font file to use. For
example, on Mac ~/Library/Fonts/Verdana.ttf
Click Edit to display the available controls.

You can mix-and-match the following methods to create burn-in text:
• Enter text manually, what you see is what you get in the burn-in.
• Use any of the tokens valid in the shot template as burn-in tokens. For example:
{shot}_comp
Extracts the shot nam from the timeline and appends _comp.
See Using Local and Project Presets for more information.
• Use metadata from tags applied to clips and shots. For example:
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[metadata hiero/tags/Approved]
Extracts the Approved tag from the clip or shot. You can also append note to include any notes
associated with the tag:
[metadata hiero/tags/Approved/note]

Note: You must precede spaces and slashes in the tag name with \\ (backslashes) to enable
Hiero to process the tag name correctly. For example: [metadata hiero/tags/Blue\\
Screen/note]

Tip: If you're not sure what metadata keys and values are available on a shot, you can add a
Text soft effect containing the Tcl expression [metadata values] to display all metadata in
the Viewer. See Soft Effects for more information.
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Adding Additional Nodes During
Export
Hiero can include additional nodes, in any Nuke Project File or Transcode export in the Shot
Template, by simply copying and pasting scripts from the Node Graph.
You can add nodes to shots, tracks, or sequences, or include them as unconnected ad hoc nodes in
the script, filtered by tags if necessary.
1. In the Content tab, scroll down to the Additional Nodes control and click Edit.
The Additional Nodes Setup dialog displays.
2. Click

to add an entry.

3. Click the Apply To field and select what the current entry applies to:
• Shot - the additional nodes are added to the script for each shot in the export.
• Track - the additional nodes are added to the script for each track in the export.
• Sequence - the additional nodes are added to the script for the entire sequence.
• Unconnected - the additional nodes are added to the script, but are not connected to the
export node tree.
• None - temporarily disables the current entry.
4. Select the Tags that you intend to use to filter which items receive the additional nodes.
If you want to affect only the Reference track, for example, select the Reference tag. All items
without that tag are ignored.
5. Copy and paste a node from the Node Graph into the Script panel.
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Note: If you need more than one node, you might consider creating a Group in the Node
Graph and pasting that into the Script panel.

6. Click OK to accept the additional nodes.
7. Select the Additional Nodes checkbox and complete the export process as described Exporting
Sequences and Shots.
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Using the Frame Server on
External Machines
Although Hiero is capable of rendering frames internally, running the Frame Server on an external
machine can accelerate the process considerably by sharing work across a network of machines.

Note: The Frame Server requires a Hiero license (nukestudio_i) on the main workstation,
but only a Nuke render license (nuke_r) on the slave machines. Local Frame Server
processes use ports 5558-5662.
If you want to use an interactive license (nuke_i) on the slave machines, add the -useInteractiveLicense argument to the runframeserver.py command described below.

Configuring the Frame Server on External Machines
Hiero's Frame Server can be set up on an external machine (or a number of machines) to render from
your Nuke Studio session. To do this, you need to run the runframeserver.py script on the external
machines, found inside the Python site-packages, with specific command line arguments.

Warning: In order for everything to work smoothly, you need to ensure that both your
external slave machines and main Hiero session can read and write files to a shared
location, such as an NFS share.
Depending on platform this can be done by manipulating your default umask setting, but
be aware that this alters the permissions of the created files.
Additionally, Mac and certain Linux distributions, such as RHEL, can not function as the main
workstation if the firewall is blocking the communication port 5560. You can configure the
firewall to allow certain ports through the firewall using the iptables command, but use
caution when doing so. For example:
sudo iptables -I INPUT -p tcp --dport 5560 --syn -j ACCEPT
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Please refer to the documentation on firewalls for your particular platform for more
information.

The Frame Server uses a number of worker processes on the external machine, each of which
requires allocated resources, such as threads, memory, and so on. There are a number of arguments
that you must pass to runframeserver.py for the server to work correctly:
• --numworkers - this is the number of concurrent Nuke processes that are launched when you run
this server render node.
• --nukeworkerthreads - the number of threads that each worker is allocated. This is similar to
setting the -m argument when running Nuke from the command line.
• --nukeworkermemory - the amount of memory, in MB, allocated to each frame server worker.
• --workerconnecturl - the TCP port address of the main workstation you want to serve. For
example:
tcp://bob:5560
where bob is the resolved hostname of a machine you wish to serve. You can also use an IP address.

Tip: To ensure that you're entering a valid URL, try using the ping command to see if you get
a response.
• --nukepath - the path to the Nuke application on the slave workstation.

Tip: On Windows, if there are spaces in the file path, remember to place the path in quotes.
For example, --nukepath="C:\Program Files\Nuke11.3v6\Nuke11.3.exe"
On a Linux slave machine, an example command prompt entry running from the install directory
might look like this:
./python ./pythonextensions/sitepackages/foundry/frameserver/nuke/runframeserver.py --numworkers=2 -nukeworkerthreads=4 --nukeworkermemory=8096 --workerconnecturl=tcp://bob:5560
--nukepath=./Nuke11.3
On a Windows slave machine, an example command prompt entry running from the install directory
might look like this:
python.exe pythonextensions\sitepackages\foundry\frameserver\nuke\runframeserver.py --numworkers=2 -nukeworkerthreads=4 --nukeworkermemory=8096 --workerconnecturl=tcp://bob:5560
--nukepath=Nuke11.3.exe
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In the examples, we specify that the slave uses two Nuke workers, with four threads and 8 GB RAM
each, and are slaved to the main Hiero workstation running on bob.

Tip: If your slave machines run a different OS than your main Hiero machine, you can use
the --remap command line argument to convert file paths between them. The host file path
is read first followed by the slave file path. Hiero expects all file paths to use / (forward slash)
between directories. For example:
--remap "P:/,/mnt/renders/"
converts host paths beginning with P:/ (Windows style) to slave paths beginning with
/mnt/renders/ (Linux style).
You can check that the Frame Server and workers are connected by running the following lines in the
Script Editor on the main workstation:
from hiero.ui.nuke_bridge.FnNsFrameServer import frameServer
print [worker.address for worker in frameServer.getStatus(1).workerStatus]
Successful connections should report something similar to the following in the output panel:
['Worker 0 - henry.local - 192.168.1.11', 'Worker 0 - bob.local 192.168.1.111', 'Worker 1 - henry.local - 192.168.1.11']
Where henry.local is the name of the remote slave, and bob.local is the name of the main Hiero
session.

Note: If the workers cannot contact the Frame Server, an exception is printed in the Script
Editor's output panel.

Frame Server Logs
Broker and Worker logging can to help diagnose Frame Server issues. The logs are written to NUKE_
TEMP_DIR/logs by default, and take the form:
broker.log
worker-0.log
worker-1.log
worker-2.log
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Note: Running the Frame Server using Python, as described above, always writes log files to
the specific OS temporary directory. For example, on Windows C:\temp is used.

Tip: You can use the FRAMESERVER_LOG_DIR environment variable to force Frame Server
logs into a different location. See Environment Variables in the Nuke Online Help for more
information.
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Exporting Sequences and Shots
1. Select an entire sequence in the bin view, or shots in the timeline, and navigate to File > Export...
The Export dialog displays.
2. Select Process as Shots from the Export dropdown.
3. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
4. Select the Basic Nuke Shot preset under Local Presets to auto-complete the shot template or
build a custom shot template by copying an existing template and editing as required using Path
tokens, the Contents field, and the folder and +/- buttons.
Basic Nuke Shot creates a folder for each clip, or shot, containing nuke, script, and renders
folders.

The tokens in the Basic Nuke Shot template break down as follows:
• {shot} simply extracts the shot names as they appear in the timeline.
• {shot}_comp{_nameindex}_{version}.nk extracts the shot name for each clip and the version
selected in the Tracks and Handles controls. For example, Shot01_comp_v03.nk
• {shot}_comp{_nameindex}_{version}.####.{ext} appends padding and the specified file
extension. For example, Shot01_comp_v03.0001.dpx

Note: The {_nameindex} token is included to avoid conflicts with non-unique shot names.

Tip: Select a file entry in the shot template to display a preview of the file path with all the
tokens resolved.
5. Proceed to Nuke Project File Settings to determine the Nuke script's behavior.
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Nuke Project File Settings
Note: Custom shot presets can only be selected from the Project Settings if they contain a
Nuke Project File and Nuke Write Node Content preset.
1. Click the Nuke Project File Content preset to display the script settings.
2. Select Write Nodes from the dropdown and check which path from the shot template should be
used for the Nuke Write node. For example:
{shot}/nuke/renders/{shot}_comp{_nameindex}_{version}.####.{ext} to resolve the render
path where Hiero expects to find the files when they're rendered.

Note: If you included a Nuke Annotations File Content preset, enable the Annotations
Precomp creator. See Annotations for more information.
3. If you're exporting retimed media, set how you want the Nuke script to handle the retime:
• None - no retime is applied.
• Motion - vector interpolation is used to calculate the in between frames. This is the most
accurate retime method, but takes longer to render.
• Frame - the nearest original frame is displayed.
• Blend - a mix between two frames is used for the in between frames. This is quick to render and
is useful when tweaking the timing in the Curve Editor before setting the method to Motion.
4. Soft Effects added to shots in your export are included in the resulting Nuke script by default. If
you don't need the soft effects, disable Include Effects to omit them from the script. See Soft
Effects for more information.
5. Select the required Reformatting options:
• Plate Resolution - exports at the clip's original resolution, regardless of what is set in the
timeline.
• To Sequence Resolution - exports at the resolution set in the timeline Sequence panel Output
Resolution dropdown.
• Custom - activates the Reformat controls allowing you to customize the export resolution.
6. Enable Collate Shot Timings or Collate Shot Name to create additional Nuke Read nodes in the
same script for clips that would normally be hidden by clips higher up the track hierarchy or clips
on the same track with the same shot name.
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Note: If you have a Read node selected, you can’t enable the Collate functions.
For example:
• Collate Shot Timings - Items on track 1 that would otherwise be hidden by track 2.

Timeline environment

Compositing environment

Note: Shots on different tracks are not connected by default. If you want all the exported
clips to be connected to the Nuke script Write node, enable Connect Tracks.
This applies to stereo and multi-view sequences as well when you use separate files for the
tracks per view. See Stereoscopic and Multi-View Projects for more information.
• Collate Shot Name - Two items on the same track with the same shot name.

Timeline environment

Compositing environment

7. If you want to add additional nodes to the script on export, enable Additional Nodes and click
Edit. See Adding Additional Nodes During Export for more information.
8. Proceed to Nuke Write Node Settings to determine the Write node's behavior.
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Nuke Write Node Settings
Note: Custom shot presets can only be selected from the Project Settings if they contain a
Nuke Project File and Nuke Write Node Content preset.
1. Click the Nuke Write Node Content preset to display the write settings.
2. Set the following controls common to all file types:
• Channels - set the channels to export using the dropdown. If you want to export a non-standard
channel, type the name of the channel into the field manually.
• Write Node Name - if you intend to create more than one Nuke Write node, define the name
here. The default, Write_{ext}, appends the individual Write nodes with the file extension being
written. You can, however, use any of the tokens Hiero recognizes.
• Colorspace - use the dropdown to set the colorspace to render, such as linear, REDLog, or raw.
3. Select the file type to render using the dropdown and complete the relevant fields, dependent on
the file type selected.

Note: Selecting mov from the dropdown provides additional QuickTime specific controls,
allowing you to choose a codec, encoder, and in some cases, YCbCrMatrix. The matrix
control enables you to use the new Rec 601 and Rec 709 or the Legacy encoding methods,
which are the methods used previously in Nuke. There's also an Advanced dropdown
containing mov32 and mov64 encoder specific controls.
Similarly, selecting exr provides an additional metadata dropdown allowing you to export or
round-trip selected metadata along with your .exr output.
4. Create Directories is enabled by default, which enables the corresponding control in the .nk
script's Write node. This control allows Nuke to create the required directories when you render
out a new version from the Write node.
Disabling this control causes versioned renders to fail because the target directories don't exist.
You can manually create the correct directories or enable Create Directories in the script's Write
node if this happens.
5. Use the Reformat controls to determine how the Write node is set up in the Nuke script:
• None - the clip or sequence resolution is used, no additional formatting is applied during
export.
• To Sequence Resolution - exports at the resolution set in the timeline Sequence panel Output
Resolution dropdown. This option also allows you to set the Filter used to resize the output.
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Note: The filters available are generally listed in order of quality and processing time. Cubic
can be faster to render, but Lanczos4 may be produce better results. See the Nuke Online
Help for more information on filters in Nuke.
• To Scale - activates all the Reformat controls, except Format, allowing you to customize the
export resolution.
• Custom - activates all the Reformat controls, except Scale, allowing you to customize the
export resolution.
Reformat Control

To
To
Custom
Sequence Scale
Resolution

Format - sets the format to render out in Nuke, such as 1920x1080
HD 1080.
Scale - sets the proportion by which to scale the output format.
Resize - sets the method by which you want to preserve or override
the original aspect ratio:
• width - scales the original until its width matches the format’s
width. Height is then scaled in such a manner as to preserve the
original aspect ratio.
• height - scales the original until its height matches the format’s
height. Width is then scaled in such a manner as to preserve the
original aspect ratio.
• fit - scales the original until its smallest side matches the format’s
smallest side. The original’s longer side is then scaled in such a
manner as to preserve original aspect ratio.
• fill - scales the original until its longest side matches the format’s
longest side. The input’s shorter side is then scaled in such a
manner as to preserve original aspect ratio.
• distort - scales the original until all its sides match the lengths
specified by the format. This option does not preserve the original
aspect ratio, so distortion may occur.
Center - when enabled, transform image to the center of the output.
When disabled, the image is aligned with the bottom-left corner of
the output.
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Reformat Control

To
To
Custom
Sequence Scale
Resolution

Filter - sets the filtering algorithm used to transform pixels. See the
Nuke Online Help for more information on filters in Nuke.

6. You can apply text burn-in to the media using a Nuke gizmo. Enable Burn-in Gizmo and click Edit
to define the information applied. See Adding Burn-in Text to Exports for more information.
7. Proceed to Tracks, Range, and Handles Settings to select which items are processed during
export.
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Tracks, Range, and Handles
Settings
The tracks, tags, and handles controls in the Export dialog allow you to select the frame range or
shots to export.
1. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
2. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.
3. Enable or disable tags using the Filter by tag panel. Click the checkbox to cycle through the
available tag states.
4. If you're exporting a sequence, set the Range controls as required:
• Select Whole Sequence or In/Out Points to export only the selected frames.
• Set how clip Start Frames are derived using the dropdown menu:
• Sequence - use the sequence’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
5. If you're exporting shots, set the Handles controls as required:
• Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.
• Cut Length - exports only the cuts included on the timeline.

Note: Selecting Cut Length allows you to add handles to each clip, up to the maximum
available source clip length.
• Check Apply Retimes to export any retimes present on the timeline.

Note: When Apply Retimes is disabled, which is the default state for Create Comp Clips,
any TimeWarp soft effects are not included in the resulting Nuke script. When the new shot
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is created through Build Track from Export Tag, TimeWarp soft effects are copied from the
original shot to the new one.

• Set how clip Start Frames are derived using the dropdown menu:
• Source - use the source clip’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
6. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
7. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created. You can
then import the Nuke clips on a separate track when they’re ready.

Tip: Click the magnifying glass icon to reveal the file structure in a browser window.
When clips are exported from Hiero, they are marked with a Nuke tag flagging which clips have an
export history. Clips tagged in this way can be used to build VFX tracks quickly as described in
Building VFX Tracks and Comp Clips.
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Building VFX Tracks and Comp
Clips
When the compositing work is complete, the clips are ready to re-ingest. The shot template defines
where the Nuke files reside, so all you need to do is instruct Hiero to build tracks from previous
exports. See Building Tracks From Export Structure for more information.
Alternatively, if you have a history of rendered VFX clips, different versions and so on, you can also
build tracks from export tags to select from a list of available clips. This method allows you to add
Comp Clips to the timeline, which act as containers for Nuke .nk scripts, or placeholders for Nuke
renders. See Building Comp Clips From Export Tags or Building Render Placeholders From Export
Tags for more information.

Building Tracks From Export Structure
1. Select the required clips on the timeline and right-click to display the context sensitive menu.

Tip: You may find it easier to select clips in the spreadsheet and then right-click on the
timeline.
2. Click Build Track > From Export Structure.
The Build Track From Export Structure dialog displays.

3. Enter a Track Name or use the default VFX.
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4. Select an Export Preset using the dropdown menu. In this case, select the same preset used
during the export.
5. Enter the file path of the Export Root directory or click Choose and browse to the location.

Note: The root directory is the location entered in Export To when exporting the project.
6. Select the Content preset you intend to ingest from the shot template. In this case, the Nuke
Write Node.
7. Click Build to create the VFX track.

Note: Hiero warns you if no selection is made in the Content column.
Hiero automatically creates a new track containing the VFX clips, if they exist, or offline place
holders if the clips are a work in progress.
If a shot already exists in any of the target tracks, a new track is created to hold the new shots.

The clips are automatically updated when work is complete as long as they are saved with the
expected name and location, as specified in the shot template.
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Building Comp Clips From Export Tags
When you build a track from an export tag, Hiero imports Comp Clips containing the Nuke script, by
default. Comp Clips are shots that reference Nuke scripts, rather than being placeholders for offline
clips as in the Building Render Placeholders From Export Tags workflow.
1. Select the required clips on the timeline and right-click to display the context sensitive menu.

Tip: You may find it easier to select clips in the spreadsheet and then right-click on the
timeline.
2. Click Build Track > From Export Tag.
The Build Track From Export Tag dialog displays.
3. Enter a Track Name or use the default VFX.
4. Select the required export tag in the left-hand panel to display tag information in the right-hand
panel.
Hiero imports the .nk Comp Clip by default.

If you just want to import the offline renders when they're finished, disable the Create Comp
Clips checkbox. See Building Render Placeholders From Export Tags for more information.
5. Click Build to create the VFX track.
Hiero automatically creates a new track containing the Comp Clips. If a shot already exists in any
of the target tracks, a new track is created to hold the new shots.
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6. You can Ctrl/Cmd+double-click Comp Clips to open them in an external Nuke to make edits as
required.

Building Render Placeholders From Export Tags
When you build a track from an export tag, you can choose to import the renders from the .nk script,
rather than Comp Clips which contain the Nuke script.
1. Select the required clips on the timeline and right-click to display the context sensitive menu.

Tip: You may find it easier to select clips in the spreadsheet and then right-click on the
timeline.
2. Click Build Track > From Export Tag.
The Build Track From Export Tag dialog displays.
3. Enter a Track Name or use the default VFX.
4. Select the required export tag in the left-hand panel to display tag information in the right-hand
panel.
5. Disable the Create Comp Clips checkbox to import the offline renders when they're finished.
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If you want to import the .nk Comp Clips, enable the Create Comp Clips checkbox. See Building
Comp Clips From Export Tags for more information.
6. Click Build to create the VFX track.
Hiero automatically creates a new track containing the VFX clips, if they exist, or offline place
holders if the clips are a work in progress.
If a shot already exists in any of the target tracks, a new track is created to hold the new shots.
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Exporting Multi-View Source Clips
Multi-view exports are similar to regular exports, but the DPX Multi-View or Multi-View Nuke Shot
templates are used to created the required export tree using %v functionality, just like Nuke's Node
Graph. The DPX Multi-View example preset is designed for exporting sequences and the Multi-View
Nuke Shot preset is designed for shots.
See Stereoscopic and Multi-View Projects for more information on working with multi-view footage.
1. Right-click on the sequence or shot that you want to export.
Sequences are exported from the bin view.

Shots can be a multi-view or single views split into separate tracks. See Displaying Views in the
Timeline for more information.

For separate tracks, you can right-click a single track to export all views or select all the per-track
views and right-click.
2. Select Export.
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The Export dialog is displayed.
3. Select Process as Sequence or Process as Shots from the Export dropdown.
If you're exporting a sequence, select the Log10 Cineon DPX Multi-View example preset. If you're
exporting shots, select the Multi-View Nuke Shot (%v) example preset.
4. Set the Nuke Project File and Nuke Write Node presets as described in Nuke Project File
Settings and Nuke Write Node Settings.
If you're using independent files per track, that is without importing multi-view files or using %V
functionality, the separate tracks in the export script are not connected by default. If you want the
tracks to be connected in the script, enable Connect Tracks in the Nuke Project File preset.

5. Set the track and handle preferences as described in Tracks, Range, and Handles Settings and
then click Export.
Once the export is complete, the file structure specified in the shot template is created. You can
then import the Nuke clips on a separate track when they’re ready.

Tip: Click the magnifying glass icon in the Export Queue to reveal the file structure in a
browser window.
When clips are exported from Hiero, they are marked with a Nuke tag flagging which clips have an
export history. Clips tagged in this way can be used to build VFX tracks quickly as described in
Building VFX Tracks and Comp Clips.
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Transcoding
Transcoding in Hiero uses a background render process to convert one file format to another. You
can transcode sequences, timeline selections, and clips from the bin view.

Transcoding a Sequence
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays.
2. Select Process as Sequence and the preset you intend to use, or use the default dpx preset.
3. Enter the Export To directory or click Choose... and browse to the location.
4. Click the Content column in the shot template to display the transcode options.
5. Set the following controls common to all file types:
• Channels - set the channels to export using the dropdown. If you want to export a non-standard
channel, type the name of the channel into the field manually.
• Colorspace - use the dropdown to set the colorspace to render, such as linear, REDLog, or raw.
6. Select the File Type to render using the dropdown and complete the relevant fields, dependent on
the File Type selected.

Note: Selecting mov from the dropdown provides additional QuickTime specific controls,
allowing you to choose a codec, encoder, and in some cases, YCbCrMatrix. The matrix
control enables you to use the new Rec 601 and Rec 709 or the Legacy encoding methods,
which are the methods used previously in Nuke. There's also an Advanced dropdown
containing mov32 and mov64 encoder specific controls.
Similarly, selecting exr provides an additional metadata dropdown allowing you to export or
round-trip selected metadata along with your .exr output.
7. Use the Reformat controls to determine how the Write node is set up in the Nuke script:
• None - the clip or sequence resolution is used, no additional formatting is applied during
export.
• To Scale - activates all the Reformat controls, except Format, allowing you to customize the
export resolution.
• Custom - activates all the Reformat controls, except Scale, allowing you to customize the
export resolution.
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Reformat Control

To
Custom
Scale

Format - sets the format to render out in Nuke, such as 1920x1080 HD 1080.
Scale - sets the proportion by which to scale the output format.
Resize - sets the method by which you want to preserve or override the original
aspect ratio:
• width - scales the original until its width matches the format’s width. Height is
then scaled in such a manner as to preserve the original aspect ratio.
• height - scales the original until its height matches the format’s height. Width is
then scaled in such a manner as to preserve the original aspect ratio.
• fit - scales the original until its smallest side matches the format’s smallest side.
The original’s longer side is then scaled in such a manner as to preserve original
aspect ratio.
• fill - scales the original until its longest side matches the format’s longest side.
The input’s shorter side is then scaled in such a manner as to preserve original
aspect ratio.
• distort - scales the original until all its sides match the lengths specified by the
format. This option does not preserve the original aspect ratio, so distortion may
occur.
Center - when enabled, transform image to the center of the output. When
disabled, the image is aligned with the bottom-left corner of the output.
Filter - sets the filtering algorithm used to transform pixels. See the Nuke Online
Help for more information on filters in Nuke.

8. Complete the general controls common to all file types:
• Select the Retime Method to apply, if applicable.
• Soft Effects added to shots in your export are included in the resulting Nuke script by default. If
you don't need the soft effects, disable Include Effects to omit them from the script. See Soft
Effects for more information.
• Include Audio - when enabled, any audio tracks are exported alongside the video.
• Delete .WAV File - when disabled, delete the .wav file used to create the export. This control
only applies to formats that support audio, such as .mov files.
9. Enable the Burn-in Gizmo to burn-in text using a Nuke gizmo. Click Edit to define the information
applied during burn-in. See Adding Burn-in Text to Exports for more information.
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10. Specify any Additional Nodes required during export by clicking Edit. See Adding Additional
Nodes During Export for more information.
11. Check Keep Nuke Script if you require the .nk files after the transcode operation.

Note: The following controls may improve render times for certain exports:
• For .dpx exports, you can enable Read All Lines, which can speed up transcode times for
I/O heavy scripts.
• For machines with multiple CPU sockets using a Single Render Process, you may find that
limiting the render with Use Single Socket may improve render times.

Tracks and Range Settings
1. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
2. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.
3. If you set in and out point on the sequence, enable In/Out Points to export only the selected
frames.
4. Set how clip Start Frames are derived using the dropdown menu:
• Sequence - use the sequence’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
5. Set how Hiero should render your export using the Render with dropdown. The following
options are available:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
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6. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created containing
the transcoded files.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Transcoding a Sequence as Shots
1. Select the required sequence in the bin view and navigate to File > Export...
The Export dialog displays.
2. Select Process as Shots and use the default, Transcode Shots DPX, or build a shot template
using the Path and Contents fields and the folder and +/- buttons.
The default:

Creates a folder for each shot, containing a clip with the {shot} name and the required file
padding (####) and extension {ext}.
3. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
4. In the Content tab, complete the File Type specific and general controls common to all file types
as described in Transcoding a Sequence.
5. Click the Tracks and Handles tab, select the Tracks For This Export by enabling or disabling the
tracks in the list. Nuke Studio exports all tracks by default.
6. Enable or disable tags using the Filter by Tag panel. Click the checkbox to cycle through the
available tag states.
7. Set the Range and Handles, as required:
• Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.
• Cut Length - exports only the cuts included on the timeline.

Note: Selecting Cut Length allows you to add handles to each clip, up to the maximum
available source clip length.
8. Check Apply Retimes to export any retimes present on the timeline.

Note: When Apply Retimes is disabled, which is the default state for Create Comp, any
TimeWarp soft effects are not included in the resulting Nuke script. When the new shot is
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created through Create Comp or Build Track from Export Tag, TimeWarp soft effects are
copied from the original shot to the new one.
9. Set how clip Start Frames are derived using the dropdown menu:
• Source - use the source clip’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
10. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: SeeUsing Versions for more information on how versioning works in Hiero.
11. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
12. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created. You can
then import the Nuke clips on a separate track when they’re ready.

Tip: Click the magnifying glass icon to reveal the file structure in a browser window.
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Transcoding from the Bin View
To transcode directly from the bin view:
1. Select the bin(s) to export from the bin view.
2. Right-click a highlighted bin and select Export...

The Export dialog displays.
3. Select Process as Clips and modify the shot template, if required.
4. Follow the steps under Transcoding a Sequence to complete the export.
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Transcoding Timeline Selections
Transcoding an entire timeline can be time consuming, or even unnecessary, if all you’re looking for
is a new version of a selection of shots.
To transcode a selection of clips from a timeline:
1. Select the required shots on the timeline.
2. Right-click a highlighted item and select Export...

The Export dialog displays.
3. Refer to Transcoding a Sequence to complete the export.
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Ad Hoc Exports
This section covers exports that you might not perform on a per project basis, such the EDL or XML
Exporters and Copy Exporter. Exporters are available for sequences, shots, and clips as described in
the following table.
Exporter

Source
Sequences

Shots

Source Clips

EDL Exporter
XML Exporter
Audio Exporter
Copy Exporter
SymLink Exporter
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Exporting EDLs and XMLs
Hiero supports export to EDL and XML using very similar methods, the main difference being that
EDL doesn’t support multiple video tracks in a single file whereas XML does.

Note: Hiero can read AAF files, but not write them out.
To export to EDL or XML:
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays.
2. Select Process as Sequence from the Export dropdown.
3. Select the CMX 3600 EDL or Final Cut Pro XML preset, or duplicate one and create your own
preset.

Note: EDLs only support one video track per file. If you have more than one track, include
the {track} token in the shot template to write out an EDL for each track preset.
For example, {filename}_{track}.{ext} might produce a separate EDL for each track on your
timeline called myTimeline_Video1.edl, myTimeline_Video2.edl, and so on.
4. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
5. If you're exporting to EDL, set the additional EDL Exporter controls in the Content tab, if required:
• Reel Name - define the reel name written into the EDL, independent of the clip's reel name.
Enter text or standard shot-level tokens in this field. See Using the Shot Template for more
information.
If the field is left blank, the reel name from the clip is used or the name of the shot, if no reel
name exists.
• Truncate Reel Name - restricts the Reel name to eight characters.
• Use Absolute Path - adds the full file path for each clip to the EDL comments field.
• From Clip Name - define the text appended to “from” comment fields in EDLs, such as *FROM
CLIP NAME. Text and/or standard shot-level tokens are valid in this field: {shot}, {clip}, {track},
{sequence}, {event}, {fps}, and the default {filename}.
OR
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If you're exporting to XML, you can enable Include Markers to convert any frame tags present
in the sequence to markers in Final Cut Pro or Premiere. See Tagging Using the Viewer for more
information on adding tags to frames.
6. Click the Tracks and Range tab and select the Tracks For This Export by enabling or disabling
the tracks in the list. Hiero exports all tracks by default.
7. If you set in and out point on the sequence, enable In/Out Points to export only the selected
frames.
8. Set how clip Start Frames are derived using the dropdown menu:
• Sequence - use the sequence’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
9. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
10. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
11. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Using the Audio Exporter
The Audio Exporter allows you write audio to separate .wav files. You can extract audio from whole
sequences, shots, and source clips.

Exporting Audio from Sequences
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays.
2. Select Process as Sequence from the Export dropdown.
3. Select the Log10 Cineon DPX preset, duplicate it, and give it a name.
4. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/buttons.
An example shot template is shown below:

6. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
7. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.
8. Set the Range controls as required:
• Select Whole Sequence or In/Out Points to export only the selected frames.
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• Set how clip Start Frames are derived using the dropdown menu:
• Sequence - use the sequence’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
9. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
10. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.

Exporting Audio from Shots
1. Select the required shots in the timeline and navigate to File > Export...
The Export dialog displays.
2. Select Process as Shots from the Export list.
3. Select the Transcode Shots DPX preset, duplicate it, and give it a name.
4. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/buttons.
An example shot template is shown below:
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6. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: SeeUsing Versions for more information on how versioning works in Hiero.
7. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.
8. Enable or disable tags using the Filter by tag panel. Click the checkbox to cycle through the
available tag states.
9. If you're exporting a sequence, set the Range controls as required:
• Select Whole Sequence or In/Out Points to export only the selected frames.
• Set how clip Start Frames are derived using the dropdown menu:
• Sequence - use the sequence’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
10. If you're exporting shots, set the Handles controls as required:
• Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.
• Cut Length - exports only the cuts included on the timeline.

Note: Selecting Cut Length allows you to add handles to each clip, up to the maximum
available source clip length.
11. Set how clip Start Frames are derived using the dropdown menu:
• Source - use the source clip’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
12. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
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• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
13. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.

Exporting Audio from Source Clips
1. Select the required source clips and navigate to File > Export...
The Export dialog displays.
2. Process as Clips is selected automatically from the Export list.
3. Select the Transcode Clips DPX preset, duplicate it, and give it a name.
4. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/buttons.
An example shot template is shown below:
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6. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
7. Set how clip Start Frames are derived using the dropdown menu:
• Source - use the source clip’s start frame.
• Custom - specify a start frame for all clips using the field to the right.
8. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
9. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Using the Copy Exporter
Copying media from various locations is very time consuming and can waste disk space. The Copy
Exporter allows you to consolidate sequences containing only your project media in a named file
structure using the shot template.
To copy media to a named location:
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays.
2. Select Process as Shots from the Export dropdown.
3. Select the Transcode Shots DPX preset, duplicate it, and give it a name.
4. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/buttons.
An example shot template is shown below:

6. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
7. Set how clip Start Frames are derived using the dropdown menu:
• Source - use the source start frame.
• Custom - specify a start frame for all clips using the field to the right.
8. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
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• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
9. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Using the SymLink Generator
The SymLink Generator allows you to create symbolic links to your project media in a named file
structure using the shot template.

Note: Windows only: Symbolic links are only supported by Windows Vista, or later. if you're
linking across file systems, the remote file servers must also be running Windows Vista, or
later. Additionally, you may need administrator privileges and a local NTFS drive to create
symbolic links.
To create symbolic links to a named location:
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays.
2. Select Process as Shots from the Export dropdown.
3. Select the Transcode Shots DPX preset, duplicate it, and give it a name.
4. Enter the Export To directory or click Choose... and browse to the location.
The Export To directory is the starting point from which the shot template builds your shot
hierarchy.
5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/buttons.
An example shot template is shown below:

6. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.
7. Set how clip Start Frames are derived using the dropdown menu:
• Source - use the source start frame.
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• Custom - specify a start frame for all clips using the field to the right.
8. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
• Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
• Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.
• Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.
9. Click Export.
The Export Queue window displays an estimate of how long each component of the export is
expected to take.
Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Customizing Hiero
These pages provide a basic overview and some simple examples to get you started, but more
information is available in the dedicated Python API document included in the Nuke package. See
Help > Python Dev Guide for more information.

Environment Variables
Environment variables are used to store values that influence the behavior of Hiero and HieroPlayer,
such as adding additional file paths to check at startup for plug-in scripts.

Setting Environment Variables
The process of setting environment variables differs depending on the operating system you're using:

On Mac and Linux
1. The first step is to determine the type of the shell you’re using. Launch a terminal and enter:
echo $SHELL
Your shell type is printed to the screen. For example, /bin/bash indicates that your shell is “bash”.
2. Depending on the output of the $SHELL command, do one of the following:
• csh or tcsh - add the following command to the .cshrc or .tcshrc file in your home directory:
setenv VARIABLE value
Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:
setenv HIERO_PLUGIN_PATH /SharedDisk/Hiero
setenv TIMELINE_DISABLE_PBO_UPLOADS 1
• bash or ksh - add the following command to the .bashrc or .kshrc file in your home directory:
export VARIABLE=value
Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:
export HIERO_PLUGIN_PATH=/SharedDisk/Hiero
export TIMELINE_DISABLE_PBO_UPLOADS=1
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Note: These steps set the environment variable until you manually remove it from the file in
your home directory. If you want to set a variable for a single session, you can simply type
the variable in the terminal then run Hiero from the same session.

On Windows
1. Right-click on My Computer and select Properties.
2. Click the Advanced tab.
3. Click the Environment Variables button.
The Environment Variables dialog opens.
4. Click the New button under either User variables or System variables, depending on whether
you want to set the variable for the current user or all users.

Note: You must have administrator privileges to set system-wide variables.
5. In the Variable name field, enter the name of the environment variable you want to set.
6. In the Value field, enter the value for the variable. The value can be a directory path, for example.
You can also disable and enable variables by adding the value 0 or 1, respectively.
7. Click OK to save the variable.

Environment Variables
Environment variables are used to store values that influence the behavior of Hiero and HieroPlayer,
such as adding additional file paths to check at startup for plug-in scripts.

Setting Environment Variables
The process of setting environment variables differs depending on the operating system you're using:

On Mac and Linux
1. The first step is to determine the type of the shell you’re using. Launch a terminal and enter:
echo $SHELL
Your shell type is printed to the screen. For example, /bin/bash indicates that your shell is “bash”.
2. Depending on the output of the $SHELL command, do one of the following:
• csh or tcsh - add the following command to the .cshrc or .tcshrc file in your home directory:
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setenv VARIABLE value
Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:
setenv HIERO_PLUGIN_PATH /SharedDisk/Hiero
setenv TIMELINE_DISABLE_PBO_UPLOADS 1
• bash or ksh - add the following command to the .bashrc or .kshrc file in your home directory:
export VARIABLE=value
Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:
export HIERO_PLUGIN_PATH=/SharedDisk/Hiero
export TIMELINE_DISABLE_PBO_UPLOADS=1

Note: These steps set the environment variable until you manually remove it from the file in
your home directory. If you want to set a variable for a single session, you can simply type
the variable in the terminal then run Hiero from the same session.

On Windows
1. Right-click on My Computer and select Properties.
2. Click the Advanced tab.
3. Click the Environment Variables button.
The Environment Variables dialog opens.
4. Click the New button under either User variables or System variables, depending on whether
you want to set the variable for the current user or all users.

Note: You must have administrator privileges to set system-wide variables.
5. In the Variable name field, enter the name of the environment variable you want to set.
6. In the Value field, enter the value for the variable. The value can be a directory path, for example.
You can also disable and enable variables by adding the value 0 or 1, respectively.
7. Click OK to save the variable.

USER GUIDE

362

Hiero Environment Variables | Environment Variables

Hiero Environment Variables
The following table lists the environment variables Hiero recognizes.
Environment Variable

Description

__GL_SYNC_DISPLAY_
DEVICE

On Linux, set this variable to the name of screen device to synchronize
in dual screen setups. See Synching to VBlank on Linux for more
information.

FN_CRASH_DUMP_PATH

Allows you to specify where Issue Reporter dumps are saved by default.

FN_DISABLE_LICENSE_
DIALOG

By default, if you have installed a temporary license, Hiero displays a
dialog at start-up alerting you to the number of days remaining. If you
want to disable this behavior, you can set either of these environment
variables to 1 to suppress the warning message about imminent license
expiration.

or
FN_NUKE_DISABLE_
TMPLIC_NOTIFY_DIALOG

Note: You still get a warning if no license is found, for
example if you only have a HieroPlayer license but you try to
run Hiero.
FN_LICENSE_DIALOG_
DAYS_LEFT_BEFORE_
PROMPT

By default, if you have installed a temporary license, Hiero displays a
dialog at start-up alerting you to the number of days remaining. If you
want to disable this behavior until a set number of days before expiry,
you can set this environment variables to the required number of days.

Note: You still get a warning if no license is found, for
example if you only have a HieroPlayer license but you try to
run Hiero.
FN_SUBSCRIPTION_
LICENSE_DIR

On Windows, user names containing non-ASCII characters can cause
subscription licensing to fail. If a licensing error similar to the following
displays:
Unable to create subscription license directory: C:\Users\Zoë
Hernández\FoundryLicensing\
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Environment Variable

Description
Try changing the license directory to an alternate location using this
environment variable.

foundry_LICENSE

The location of the Hiero RLM license file, if the following
recommended location is not used:
On Mac and Linux:
/usr/local/foundry/RLM
On Windows:
drive letter:\Program Files\The Foundry\RLM

Note: If you still use FLEXlm licenses and you're interested in
making a move to RLM licensing, please contact
sales@foundry.com to obtain a replacement license.
FOUNDRY_LICENSE_
DEBUG

This variable prints additional licensing information to the command
line or Terminal.

FOUNDRY_LICENSE_FILE

The location of the Hiero FLEXlm license file, if the following
recommended location is not used:
On Mac and Linux:
/usr/local/foundry/FLEXlm
On Windows:
drive letter:\Program Files\The Foundry\FLEXlm

Note: If you still use FLEXlm licenses and you're interested in
making a move to RLM licensing, please contact
sales@foundry.com to obtain a replacement license.
FOUNDRY_LOG_FILE

This variable specifies the location of Hiero’s logfile. If you don’t specify
a logfile, all output is to screen.

FOUNDRY_LOG_LEVEL

This variable sets the level of logging Hiero produces during operation.
There are four levels of detail, on a sliding scale from minimal to
verbose:
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Environment Variable

Description
• error
• warning
• message
• verbose

Note: Setting the logging level to verbose can produce large
log files when FOUNDRY_LOG_FILE is specified.
HIERO_DISABLE_
THUMBNAILS

Set this variable to stop Nuke Studio loading thumbnails.

HIERO_DISABLE_
THUMBNAILS_CACHE

Set this variable to stop Nuke Studio caching thumbnails for improved
access once loaded.

Note: This variable does not clear the cache, you must
remove cached files manually.
HIERO_PLUGIN_PATH

Set this variable to the location of additional scripts to run at startup.
You can use .<folder> to point to hidden folders, for example
.myPlugins.
For example, you could create a facility-wide location to share presets
and use this variable to point multiple Hiero’s to it. See Sharing Presets
for more information.
Use the following method to display set paths:
print hiero.core.pluginPath()

HIERO_SINGLE_
THREADED_PLAYBACK

This variable launches Hiero in single-thread mode, which can solve
playback issues on various Linux Fedora distributions.
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Environment Variable

Description

NUKE_AJA_CHANNEL

AJA cards take 3G level signal (mostly for 12-bit 444 RGB) and combine it
into a single 3G-B (B denotes B level, hence the 3G-B) stream through
SDI1 by default. Use these environment variables to customize this
output behavior:
• NUKE_AJA_CHANNEL - set this variable to 2, 3, or 4 to output a single
stream through SDI2, SDI3, or SDI4.
• NUKE_AJA_DUALOUTPUT - set this environment variable to 1 to force
the card to separate the single 3G stream into two 1.5G streams
through SDI1 and SDI2.

NUKE_AJA_DUALOUTPUT

Combining these two environment variables can force the stream to
split and output through alternate SDI outputs. For example:
• DUALOUTPUT + CHANNEL=1 OR CHANNEL=2 results in two 1.5G
streams coming from SDI1 and SDI2.
• DUALOUTPUT + CHANNEL=3 OR CHANNEL=4 results in two 1.5G
streams coming from SDI3 and SDI4.

Note: Certain modes, such as 12-bit 444, require a 3G stream.
Otherwise, the card uses the single stream on the channel
number specified.
NUKE_ALLOW_GIZMO_
SAVING

Nuke does not allow you to Overwrite and Save as gizmos by default,
without copying the gizmo to a Group. Setting this environment
variable to 1 enables this behavior, so artists don't need to copy a
gizmo before editing it.

NUKE_CRASH_HANDLING

Breakpad crash reporting allows you to submit crash dumps to
Foundry in the unlikely event of a crash. By default, crash reporting is
enabled in GUI mode and disabled in terminal mode.
When NUKE_CRASH_HANDLING is set to 1, crash reporting is enabled in
both GUI and terminal mode.
When NUKE_CRASH_HANDLING is set to 0, crash reporting is disabled
in both GUI and terminal mode.

NUKE_DISK_CACHE

The location where Hiero saves all recent images displayed in the
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Environment Variable

Description
Viewer. Ideally, this should be a local disk with the fastest access time
available.

NUKE_EXR_TEMP_DIR

On Linux, this is the location Nuke uses for temporary files while
reading PIZ-compressed .exr files. This environment variable is only
relevant on Linux.
If this variable is not set, the location is determined by NUKE_TEMP_
DIR.

NUKE_EXR_TEMP_NAME

Changes the naming convention of .exr temporary files during
rendering.
Setting the variable to 1 writes temporary .exr files as
<filename>.exr.tmp, rather than <filehash>.tmp as in previous
releases.

NUKE_FONT_PATH

The location that Nuke checks for available font files when the Text
node properties panel is opened.

NUKE_LEGACY_
CHANNEL_SORTING

This variable disables the new channel sorting behavior, where the
RGBA layer is sorted first. Enabling this variable causes Nuke to sort
channels alphabetically.

NUKE_LOCALIZATION_
NUMWATCHERS

Controls the number of threads available for localization tasks.
Increasing the number of threads can improve localization
performance.

NUKE_MOV64READER_
ENABLE

Set this variable to 0 to disable Nuke's 64-bit mov decoding and fall
back to 32-bit decoding.

NUKE_NO_CRASH_
PROMPT

When crash handling is enabled in GUI mode, this allows you to control
whether reports are automatically submitted or not:
When NUKE_NO_CRASH_PROMPT is set to 1, crash reports are
submitted automatically without displaying a crash reporter dialog.
When NUKE_NO_CRASH_PROMPT is set to 0, Hiero always displays a
crash reporter dialog before submitting a crash report.

NUKE_TEMP_DIR

The location where Hiero saves any temporary files that do not have a
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Environment Variable

Description
particular place defined for them.
You can find the current location of Nuke's temporary directory from
within Nuke by pressing X on your keyboard, when the focus is on the
Node Graph, and then running the following TCL command:
getenv NUKE_TEMP_DIR

NUKE_
WINDOWMANAGER_
DEBUG

When enabled, data from Hiero's window manager is printed to the
command line or Terminal.

OCIO

Set this variable to the location of your OCIO configuration file for color
conversion.

Note: If you plan to use the OCIO config file specified in the
Preferences, ensure that the Preferences > Project Defaults
> Color Management > Export > use OCIO nodes when
exportingto a Comp checkbox is enabled.
QT_COMPRESS_TABLET_
EVENTS

Due to recent updates to Qt, running Nuke on CentOS 7 Linux
distributions with a tablet can cause lag when moving Roto shapes
around the Viewer. Setting this environment variable compresses tablet
events, eliminating the lag.

QT_PLUGIN_PATH

The location where Nuke looks for custom Qt libraries if you don't want
to use those shipped with Nuke. Setting this environment variable adds
the custom path to Nuke's Qt library paths.

TIMELINE_DISABLE_PBO_
UPLOADS

When enabled, the performance benefit from using pixel buffer objects
(PBO) for texture uploads from RAM to the GPU is disabled.
You can try disabling PBOs if you notice playback degradation.

Sharing Presets
Hiero and HieroPlayer support facility-wide preset sharing by pointing multiple seats to a single
network location using the HIERO_PLUGIN_PATH. As long as the folder hierarchy mirrors what the
application expects, you can place this repository anywhere on your network.
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To setup sharing:
1. Create the shared repository directory, for example:
/Volumes/myFacility/Shared/
2. Follow the instructions under Setting Environment Variables to point individual machines to the
shared location. For example, if you’re using a bash shell, you could use:
export HIERO_PLUGIN_PATH=/Volumes/myFacility/Shared/
Any file that can be read locally can be placed in the shared path.

Startup Projects
Hiero and HieroPlayer search <path>/StartupProjects/Hiero, <path>/StartupProjects/HieroPlayer
and <path>/Templates for preset projects saved as .hrox files. See Mac, Linux, and Windows for a
description of the <path> variable by platform.
Projects placed in these folders behave differently, depending on which folder they are read from:
• StartupProjects/Hiero or HieroPlayer - projects in these folders are displayed in the bin view at
startup and are read only. An example project, Tag Presets, is included in the Tags tab.
• Templates - projects in this folder appear in a dropdown menu when you open a new project.
Select the template to use for the new project.

Note: You may need to create the StartupProjects/Hiero, StartupProjects/HieroPlayer,
and Templates folders manually in the chosen path.
To remove a startup project, either:
• Remove it from <path>/StartupProjects/Hiero, <path>/StartupProjects/HieroPlayer or
<path>/Templates, or
• Rename the file extension so the application doesn’t recognize it on startup. For example,
myStartup.hrox_hidden.
To modify a startup project:
1. Load the project using File > Open.
2. Make any required edits and save over the original in the same location.
The edited project loads at startup.
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Using the Python API
Hiero and HieroPlayer ship with a comprehensive Python application programming interface (API)
enabling you to perform most user interface actions using Python scripting.
This section provides a basic overview and some simple examples to get you started, but more
information is available in the dedicated Python API document included in the Hiero package. See
Help > Python Dev Guide for more information.

Running Python During Startup
On startup, Hiero and HieroPlayer scan various directories for Python scripts that customize the
behavior of the application. These scripts can be downloaded from online resources and placed in
specific locations on disk, depending on the platform you’re using.
If you’re familiar with Python scripting, you can place custom startup scripts in the same locations,
though bear in mind that you should take care as mistakes can produce performance issues.
Some example scripts are included in the application package in the following directories:
On Mac:
• /Applications/Nuke11.3v6/Nuke11.3v6.app/Contents/Plugins/site-packages/hiero/examples/
On Linux:
• /usr/local/Nuke11.3v6/Plugins/site-packages/hiero/examples/
On Windows:
• drive letter:\Program Files\Hiero11.3v6\plugins\site-packages\hiero\examples
At startup, Hiero and HieroPlayer search <path>/Python/Startup and <path>/Python/StartupUI for
any Python .py modules or packages containing __init__.py. Scanning is done in two passes - all the
Startup folders are searched and then all the StartupUI folders.
You can also add your own Startup folders, which are scanned after the standard paths, by creating a
Python file pointing to the custom location. For example:
import hiero.core
hiero.core.addPluginPath("/myCustomPlugins")
Searches /myCustomPlugins/Python/Startup after the standard paths.
Each package or module discovered is imported and added to the built-in package hiero.plugins.
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Note: Python startup scripts are imported in alphabetical order so you can force ordering if
necessary.
The <path> varies by platform as follows:

Mac
• /Applications/Nuke11.3v6/Nuke11.3v6.app/Contents/Plugins
• /Library/Application Support/TheFoundry/Nuke
• ~/Library/Application Support/TheFoundry/Nuke
• ~/.nuke

Linux
• /usr/local/Nuke11.3v6/Plugins
• ~/.nuke

Windows
• drive letter:\Program Files\Nuke\plugins\hieroscripts
• drive letter:\Program Files (x86)\Nuke\plugins\hieroscripts
• ~\.nuke

Note: The .nuke folder can be found under the directory pointed to by the HOME
environment variable. If this variable is not set (which is common), the .nuke directory is
under the folder specified by the USERPROFILE environment variable - which is generally of
the form drive letter:\Documents and Settings\login name\ or drive letter:\Users\login name\
To find out if the HOME and USERPROFILE environment variables are set and where they are
pointing at, enter %HOME% or %USERPROFILE% into the address bar in Windows Explorer. If
the environment variable is set, the folder it’s pointing at is opened. If it’s not set, you get an
error.
You can specify any number of user-defined paths using the environment variable HIERO_PLUGIN_
PATH, separating them with : just like the standard unix PATH environment variable and Nuke's
NUKE_PATH. See Setting Environment Variables for more information.
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Using the Script Editor
Hiero and HieroPlayer include a Python Script Editor, accessible from the user interface, allowing you
to enter Python statements directly.
To access the Script Editor:
1. Navigate to Window > Script Editor.
The Script Editor displays.
2. Enter scripts in the lower half of the editor and press Ctrl/Cmd + Enter to execute the script.
The results are displayed at the top of the editor. A simple example might be:
from hiero.core import *
bin = projects()[-1].clipsBin()
bin.addItem(Bin("Plates"))
bin["Plates"].importFolder("/Footage/Hiero/finalshots")
Which imports hiero.core, defines bin in the last project opened, creates a bin called Plates at
root level, and imports the specified folder into Plates.
Script Editor buttons and commands are described below:
Icon

Hotkeys

Description

Ctrl/Cmd+[

Go to the previous script.

Ctrl/Cmd+]

Go to the next script.

n/a

Clear the script history.

n/a

Load and execute a script.

n/a

Load an existing script.

n/a

Save a script as a .py file.

Ctrl/Cmd+ enter

Run the current script.
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Icon

Hotkeys

Description

n/a

Show the input pane only.

n/a

Show the output pane only.

n/a

Show both the input and output panes.

Ctrl/Cmd+
Backspace

Clear the output pane.

The Script Editor also features auto-completion and help for commands. Classes, attributes and so on
are discoverable by:
• Entering the beginning of an object name and pressing the Tab key.
For example, typing Bin and pressing Tab displays a list of objects starting with Bin:

• Using the help command for a known object.
For example, help(Clip) returns a list of useful information on Clip:

Scroll down in the top pane to see more information relating to Clip.
• Using the dir command for a known object.
For example, dir(Project) returns a concise list of useful information on Project:

USER GUIDE

373

Hiero Environment Variables | Using the Script Editor

Note: The last entry in the Script Editor is restored at startup by default, but you can disable
this behavior by navigating to Preferences > Script Editor and deselecting Save and
restore script editor history.
For more information on Python scripting, see Help > Python Dev Guide.
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The Available Preference Settings
The Preferences dialog is divided into the following sections:

General

Settings for auto-saving and path substitutions.

Project Defaults

General project settings, and settings for color management.

Performance

Settings for caching, hardware, localization, and threads/processes.

Behaviors

Settings for start up, file handling, export options, scripting, node
behaviors, and more.

Panels

Settings for the interface appearance, file browser, control panels, nodes,
Viewers, script editors, and scopes.

General
General
Autosave
force project autosave
after <300> seconds

Set the number of seconds after which to automatically save your project.
Disable this by setting it to zero.

Path Substitutions
path substitutions

Allows you to remap file paths in order to easily share projects across
different operating systems. When the application encounters a file path,
any text in the OSX/Linux column is replaced with the text in the Windows
column, or vice versa.
For example, if you enter /Volumes/networkmount in the OSX/Linux
column and Z: in the Windows column:
• On Mac and Linux, any file paths that start with Z: are converted to start
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General
with /Volumes/networkmount.
• On Windows, any file paths that start with /Volumes/networkmount are
converted to start with Z:.
To be able to enter text in either column, you need to click on the + button
below to add a row to the table.
+

Adds a row under path substitutions.

-

Deletes the selected row(s) under path substitutions.

Nuke
Open In > New Nuke
Session launches
NukeX

When enabled, new Nuke sessions are launched as NukeX.

Project Defaults
Note: You must restart the application for changes to Project Defaults preferences to be
applied.

Channel Management
Channel Management
Channel Warning
Threshold

Sets the total number of channels required in a script to trigger the
Channel Warning. Nuke only supports 1023 uniquely named channels per
script.
The Channel Count is displayed in the bottom-right of the interface, next
to the Localization Mode indicator.

Note: Nuke does not remove unused channels until you close
and reopen a script, so the Channel Count does not decrease
when you remove Read nodes from the Node Graph.
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Color Management
OpenColorIO config
OpenColorIO config
file

Sets the OpenColorIO configuration to use, if you don’t intend to use the
nuke-default settings.
If you select custom from the dropdown, enter the file path of the
configuration file or click Choose to use the browser.

Note: Hiero also includes an environment variable method for
setting a config file. See Environment Variables in the Nuke Online
Help for more information.
Default Color Transform
working space

Sets the colorspace files should be converted to, on import, and from,
during render - it's the colorspace used by Hiero under the hood.

viewer

Sets the default LUT applied to Viewers.

thumbnails

Sets the default LUT applied to thumbnails when ever they are generated.

8 bit files

Sets the default LUT applied to the specified ingested file type.

16 bit files
log files
floating point files
Nuke Script Project Settings
color management

Sets whether Hiero uses the LUTs read from the configuration specified or
the Nuke native LUTs during export. Selecting OCIO makes the relevant
OCIO LUTs available to the Read and Write nodes in scripts on a per
project basis.
All configurations except nuke-default automatically switch this control to
OCIO.
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General - these preferences only apply to new scripts and projects. To affect the current project,
use the Project Settings.
Project
project directory

Sets the project directory used by new projects. You can change the project
directory for the current project in the Project Settings.

Hrox Directory

Click to set the project directory to the location of the .hrox file using the
[python {nuke.script_directory()}] expression.

export directory

Sets the directory used by timeline exports:
• Use Project Directory - use the directory specified by the project
directory preference.
• Use Custom Directory - use the directory specified by the custom
export directory control.

custom export
directory

Sets the export directory used by new projects when the export directory
control is set to Use Custom Directory.

Sequence
output resolution

Use this to set the output resolution in the Timeline environment for new
projects. By default, clips in the sequence are not reformatted to fit this
format, they retain the source clip resolution. You can adjust the
reformatting for new clips added to a sequence using the Clip settings
below or by selecting clips in the timeline and adjusting the settings in the
Properties tab.

frame rate

Select the frame rate for new projects in the Timeline environment.

start timecode

Use this to define the start timecode for new projects. For shots, this
overrides the timecode defined in the media.

time display

You can use this to select the display format for times. You can select
either Timecode or Frames.

drop frame

Use this to choose whether timecodes from this sequence are displayed in
drop frame times or not.
Drop Frame is a timecode display option that leaves out two frames from
the 30 fps timecode sequence every minute (except every 10th minute) so
that long running NTSC sequences are accurate to a real-time clock (NTSC

USER GUIDE

378

Appendix A: Preferences | Project Defaults

General - these preferences only apply to new scripts and projects. To affect the current project,
use the Project Settings.
frame rate is 3000/1001, or approximately 0.01% slower than 30fps).

Note: Enabling Drop Frame is a Timecode display feature only the source media remains a continuous stream of frames.
Clip
clip reformat

Sets how new clips added to a sequence are formatted. The default, None,
displays shots at the source clip resolution, whereas To Sequence
Resolution reformats the shot to the output resolution using the resize
type control.

resize type

When clip reformat is To Sequence Resolution, determines how the shot
is resized to fit the output resolution. This control is disabled when clip
reformat is set to None.

center

When clip reformat is To Sequence Resolution, disabling center places
the clip at the bottom-left of the output resolution, rather than the center.

Poster Frame
poster frame

Sets a preset poster frame for all new source clips or select Custom to
select a relative frame offset as the poster frame:
• First - new source clips display the first frame of the file on disk as the
poster frame.
• Middle - new source clips display the middle frame of the file(s) on disk
as the poster frame.
• Last - new source clips display the last frame of the file(s) on disk as the
poster frame.
• Custom - the poster frame number is derived from the number of
frames in the clip starting at 0. Use the frame offset control to set the
relative offset.
For example, a .dpx sequence myClip.####.dpx 1001-1500 can have a
custom poster frame between 0 and 499.

frame offset

When poster frame is set to Custom, enter the relative frame offset from
the first available frame in the file(s) on disk.
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Views - these preferences only apply to new scripts and projects. To affect the current project, use
the Project Settings.
Views
+/-

Click to add and remove views from the views list.

↑↓

Click to move views up and down the views list. Moving a view changes the
position of the corresponding Viewer button.

View

Lists the views in the script or project and the color associated with the
view when Use color in UI is enabled.

hero

Sets the principal view selected on script or project load.

Set up views for stereo

Click to automatically add left and right views to scripts or projects.

Use colors in UI?

When enabled, the colors specified in the views matrix are applied to the
interface. For example, if you click Set up views for stereo and enable
this control, any UI items representing the left and right views are colored
red and green.

Performance
Caching
Timeline Disk Caching
directory path

The directory where all .exr files from timeline disk caching are stored by
default. The caching directory should be on a local disk, preferably with the
fastest access time available. It’s also important to leave enough space for
the maximum disk cache size (defined below).

limit to (GB)

This allows you to set the maximum amount of space (in GB) to use for the
timeline disk cache. Set to zero for unlimited size. Values lower than zero,
leave that amount of space free. The currently in use and currently free
fields display how much free cache remains from the total specified.
If this limit is reached during caching, a dialog displays options to free up
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Caching
disk space.
EXR compression

Sets the type of compression applied when writing files to the disk cache:
• DWAB
• Zip (1 scanline)
DWAB compression produces smaller cache files more quickly, but can be
lossy compared to Zip compression.

clear cache

Clear All removes all cached files from the root directory specified in the
directory path control. A dialog displays a list of files for confirmation
before the files are deleted.

Comp Disk Caching
temp directory

The comp disk cache saves all recent images displayed in the Viewer for
fast playback. Using this control, you can specify where you want Nuke to
save these images. Select a local disk (for example, C:/temp), preferably
with the fastest access time available. It’s also important to leave enough
space for the maximum disk cache size (defined below).

Memory Caching
playback cache size (%
of system RAM)

Specifies the percentage of system RAM used for the timeline Viewer
playback cache. The entire amount is allocated, even if you've only got a
few frames in the Viewer.
Recently used frames are retained in the memory to avoid relying on the
disk buffering system. The cache is freed when you switch to the
compositing Viewer and reallocated when you switch back to the timeline
Viewer.

Tip: On low-end machines, minimizing this may improve
application responsiveness at the expense of smooth playback.
free timeline playback
RAM cache when
switching to the node
graph

When enabled, any frames cached to RAM (the white bar in the timeline
Viewer) are discarded when you switch to the Node Graph within Nuke
Studio, freeing the RAM for use in Nuke.
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Caching
Note: When you switch back to the timeline, the cached files are
re-cached, which can be time consuming.
Audio Waveforms
waveform memory
(MB)

Sets the amount of memory available for storing timeline audio
waveforms.

Application in Background
pause timeline Viewer
when the application
goes to the
background

When enabled, pause timeline Viewer caching when the application is in
the background.

clear timeline Viewer
When enabled, the timeline Viewer cache is cleared when the application
cache when the
goes into the background.
application goes to the
background
Note: This preference is only available when pause timeline
Viewer when the application goes to the background is
enabled.
Undo Caching
undo history size

Allows you to set the amount of RAM, in MB, to use for the undo history. If
this limit is exceeded, older items are discarded.

minimum undo events Use this to set the amount of undo events. This setting always applies,
even if it breaches the undo history size limit.

Hardware
Audio
audio device

The audio device control allows you to select an existing audio device for
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Hardware
playout from a list of automatically detected devices. You can disable
playout on a device by selecting Disabled.
RED Rocket
use red rocket

You can select the use red rocket checkbox to speed up decoding RED
media. If you’re using R3D Rocket graphics card, note that using it is likely
to only be considerably faster when you’re reading in at full resolution. If
you’re reading in at half resolution, for instance, using without the R3D
Rocket card enabled may be faster. This is because the R3D Rocket
graphics card is designed to be fast when reading in multiple frames at the
same time. This is not how it works internally, and therefore reads with the
R3D Rocket card disabled may sometimes be faster when working in lower
resolutions (< 4K widths). Also, note that the R3D Rocket card always
produces better results than when downsampling. Also, the R3D Rocket
card can only be used by one application at a time, so if you are viewing
multiple scripts at once, you may only be able to use the R3D Rocket card
in one.

GPU
expand 3 to 4
channels

You can use this to expand images cached for playback from 3 to 4 color
channels per pixel. Some graphics hardware performs better at loading
images to video memory with 4 channels per pixel, than it does with 3.
Enabling this option improves playback performance on such hardware, at
the expense of reducing the number of frames that it's possible to cache.
If you are seeing poor playback performance, enabling this option may
help. However, if you are seeing acceptable playback performance with this
option disabled, then leaving it disabled increases the number of frames
that may be cached for smooth playback.

Note: You must restart Hiero for this option to take effect.
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Localization
System
mode

Sets the overall localization mode:
• on - checks for updates to source clips and Read nodes with localization
policy set to On or From auto-localize path and localizes those files
automatically.
• manual - checks for updates to source clips and Read nodes with
localization policy set to On Demand and prompts you to update them
manually.
• off - no source clips or Read nodes are localized, regardless of the their
localization policy.

Note: The current localization mode is displayed in the status
bar at the bottom-right of the interface.
read source files when
localized files are out
of date

When enabled, source clips and Read nodes referencing out of date
localized files automatically revert to reading the entire sequence from the
original source files. Source files are read in the following circumstances:
• With Localization mode set to on:
• A localized source clip or Read node with localization policy set to on
demand is detected to be out of date.
• A localized source clip or Read node with localization policy set to on
or from auto-localize path is detected to be out of date and it is
queuing to be automatically localized.
• With Localization mode set to manual:
• A localized source clip or Read node with localization policy set to
on, on demand, or from auto-localize path is detected to be out of
date.
When disabled, the out of date localized files are read until you update
them manually.

hide out of date
progress bar

When read source files when localized files are out of date is enabled,
you can enable this control to hide the progress/status bar on Read nodes
that are reading from the original source files.
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Localization
pause localization on
script/project open

When enabled, localization does not start automatically when you open a
script or project. Enabling this option can help to open scripts and projects
more quickly.

Inputs
localization policy

Sets the localization policy for all new source clips and Read nodes:
• on - always localize source clips and Read nodes with this policy
automatically.
• from auto-localize path - localize these source clips and Read nodes
automatically if they reside in the auto-localize from directory.
• on demand - only localize these source clips and Read nodes when you
manually update them.
• off - never localize these source clips or Read nodes.

Paths
auto-localize from

Enter the location of the files you need automatically localized, unless
otherwise specified in the Read node’s cache locally control or in the bin
right-click, Localization Policy menu. Commonly this would be your
remote working folder. If you leave this field blank, automatic local file
caching doesn’t take place.

localize to

Enter the file path where all the localized files are automatically stored.
Localizing files allows for faster reloading for files that are stored in a
location that is slow to access (such as a network drive).
On Windows, files saved to the localize to directory replace \\ (double back
slashes) and : (colon drive signifiers) with underscores so that the file path
works as expected between operating systems. For example:
\\windowspath\to\my\network\file.dpx is saved as __
windowspath\to\my\network\file.dpx
t:\my\network\path\file.dpx is saved as t_\my\network\path\file.dpx

Storage
limit to (GB)

This allows you to set the maximum amount of space (in GB) to use for
localized files. Set to zero for unlimited size. Values lower than zero, leave
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Localization
that amount of space free. The currently in use and currently free fields
display how much free storage remains from the total specified.
If this limit is reached during localization, a dialog displays options to free
up storage space.
Network
check for updated files When files are localized, specifies the time interval (in minutes) before
every
Nuke checks for updated versions of the files.
Appearance
progress bar

Sets the colors used to represent the localization states of source clips and
Read nodes.

Threads/Processes
Playback
default number of
threads per reader

Sets the number of threads to use per reader. If your source files are
located on high performance local drives, increasing the number threads
can significantly improve read times.
CPU intensive operations, such as .jpg decoding, can also be improved by
increasing the number of threads per reader.

override number of
threads per reader

Allows you to override the default number of decode threads used,
dependent on file format.
Use the plus button to add an entry to the table and then select the file
format using the dropdown menu. Double click the Number of threads
column to set the required number of decode threads for that format.

OpenEXR helper
threads to use

Sets the number of helper threads to use for OpenEXR only. The default,
zero, automatically sets the number of helper threads used.

Arri helper threads to
use

Sets the number of helper threads to use for ARRI only. The default, zero,
automatically sets the number of helper threads used.
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Threads/Processes
Note: The OpenEXR and ARRI helper thread preferences are independent of the threads
per reader and override table per format settings.
QuickTime decoders
to use

Sets the number of background processes available to handle QuickTime
file I/O. You must restart the application for this preference change to take
effect.

Note: Using too many decoders can affect performance,
depending on the available hardware.

Note: You must restart Nuke for this setting to take effect.
Rendering
frame server render
timeout

Allows you to increase the number of minutes a render process can stay
unresponsive before ending. If you're experiencing Render application
timed out messages with process-heavy scripts, you can try increasing this
value.

focus background
renders

When enabled, rendering using the Frame Server automatically opens the
Background Renders panel, or if it is already open, shifts focus to the
panel.

frame server
processes to run

Set the number of slave Nuke processes to run for the frame server.

Note: You must restart Nuke for this setting to take effect.
export renders

You can select from several render options:
• limit renderer (more responsive ui) – Select this option to make the
user interface more responsive during transcodes. It tells Nuke to use 2
threads to transcode and to use 25% of RAM to cache. Using this option is
likely to result in slower transcodes.
• no renderer limits (fastest transcoding) – Select this option to ensure
that transcodes happen as quickly as possible. This option may result in a
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Threads/Processes
less responsive user interface during transcodes.
• customize render limits – Select this option to manually configure the
number of threads used and cache memory available when
transcoding files.

Note: You must restart Nuke for this setting to take effect.
number of threads

Sets the number of threads that Nuke uses when transcoding. Lower
numbers allow the Timeline environment's interface to be more
responsive. Higher numbers allow faster transcodes. This setting is passed
to Nuke using the -m option.

cache memory (GB)

Use this to set the number of gigabytes of RAM that Nuke uses for its cache
settings. Lower numbers may improve the Timeline environment's
interface responsiveness, while higher numbers may improve the speed of
the transcodes. This setting is passed to Nuke with the -c option.

Downsize Filtering
8-bit images
10-, 12- and 16-bit
integer images
16-bit float images
32-bit images

Customizes the downsize filtering behavior by bit-depth. The default (1x)
retains the original image size. You can select 2x to halve the image size, or
4x to quarter the image size.
The Viewer image quality dropdown affects the decode rate and resolution
of clips displayed in the Viewer. Lower resolutions decode faster and vice
versa.

Behaviors
Documentation
documentation source

Sets the help source for the Properties ? button:
• local – use Nuke's built-in HTML help server. Nuke's local help server also
searches the NUKE_PATH, .nuke, and .nuke/Documentation directories
for HTML files with the same name as the requested node, such as
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Documentation
Blur.html.
• foundry – This uses Foundry's Online Help, the most up-to-date version
of the documentation.
• custom – Select this to point to your own help server.
auto port

When enabled, assign a free port automatically.

local port

Specify a local documentation server port manually. This is usually >= 1024.
You can also set this to 0 to automatically assign the port.

range

Specify a range of ports to attempt with the local documentation server.

File Handling
scan for file sequence When enabled, identify and import the file range of media that is dropped
range on drop into Bin into the bin. When disabled, no range is detected and only a single frame
view
is ingested. (This does not affect container formats, such .mov and .r3d.)
automatically rescan
versions when moving
off end of the version
list

When enabled, incrementing a source clip or shot’s version past the end of
the previously discovered versions list, forces a rescan to update the
versions list. See Using Versions for more information.

frame number style

Sets the sequence display mode to be used in the file browser.

assume fixed width
frame numbers in file
sequences

When enabled, assume frames have a fixed width number. With this
selected, frame numbers need to be padded with zeros to a fixed length,
otherwise frame numbers without preceding zeros are assumed to belong
to sequences with no padding. This is important as the sequence identifier
specifies a unique file name for each and every frame. For example:
Files

With fixed frame
width
assumed

With fixed frame
width
NOT assumed
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File Handling
sequence 1.18.exr,
sequence 1.##.exr /
sequence 1.19.exr, and sequence 1.%02d.exr
sequence 1.20.exr
default red clip video
decode mode

sequence 1.#.exr /
sequence 1.%d.exr

Sets the default red clip decode mode for new projects. You can choose
from FullPremium, HalfPremium, HalfGood, QuarterGood, EighthGood,
or SixteenthGood.

Note: Changing this preference does not change the default
decode setting for existing projects.

Positions
show menus with
previous item under
the cursor

When enabled, opening contextual menus positions them with the most
recently used item under the pointer.

Startup
startup workspace

Sets which workspace to display on startup. You can choose from
Compositing, Conforming, Editing, Finishing, Reviewing, and Timeline.
You can also choose to save a customized workspace, which would also be
available from this list.

show splash screen at
startup

When enabled, display the splash screen on startup.

show startup dialog

When enabled, display the dialog on startup.

restore workspace
When enabled, restore the selected saved workspace when opening
when opening projects projects.
Analytics
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Startup
submit usage statistics

When enabled, certain usage statistics are collected from the machine on
which you license Nuke, NukeX, Nuke Studio, Hiero, and HieroPlayer.
When disabled, we don't collect any usage data from your machine.

Note: The port number used to communicate with Foundry is
443, the same one used for uploading crash reports.

Timecode
R3D file timecode

Sets the source timecode for RED files. You can choose from Default From
File, Absolute Timecode, or Edge Timecode.

other media timecode

Sets the timecode source for file-per-frame media (such as .dpx). You can
choose from File Header or Frame Number. If File Header is selected
and a timecode exists, then the timecode is used. Otherwise it defaults
back to using the frame number from the file name.

max valid timebase
(fps)

Sets the maximum image header timebase above which the value is
clamped.
Image files are often created with application specific timebase values in
the header description. This can lead to reading in spuriously high frame
rates and the clamp aims to prevent this from happening.
If your clips do have extremely high frame rates, increase this value as
necessary to avoid clamping.

EDL style spreadsheet
timecodes

When disabled, the srcOut and dstOut values in the spreadsheet use the
film convention, representing the last frame of the cut.
When enabled, the srcOut and dstOut values in the spreadsheet use the
video convention, representing the frame directly after the cut.
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Panels
Appearance
Font

Change the type, weight, angle, and size of the font used on Nuke’s user
interface.

UI Colors - right-click on any color button and select Set color to default to revert changes.
Background

Change the background color of most user interface elements (menus,
toolbars, panes, properties panels, Viewers, and pop-up dialogs).

Base

Change the color of input fields, the input pane of the Script Editor, and
the left side of the Curve Editor.

Highlight

Change the color of the highlighting that appears when you hover the
cursor over a control, select a file or folder in the File Browser, or scrub to
a new frame on the timeline.

Highlighted Text

Change the color of any highlighted text (for example, text you select in
node properties).

Label

Change the color of labels and text on the application interface. Note that
this does not set the color of the labels on nodes in the Node Graph.

Button

Change the color of buttons and dropdown menus.

Animated

Change the color that indicates a control has been animated.

Keyframe

Change the color that indicates a keyframe has been set.

Disk cached frames

Change the color of the disk cached frames on the Viewer timeline.

RAM cached frames

Change the color of the RAM cached frames on the Viewer timeline.

Playhead

Change the color of the frame marker on the Viewer timeline.

In/Out Markers

Change the color of the in and out frame markers on the Viewer timeline.

Curve Editor / Dope Sheet - right-click on any color button and select Set color to default to
revert changes.
no. of curves visible

Sets the maximum number of curves visible in the Curve Editor.
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Appearance
background

Change the background color of the Dope Sheet tab.

unselected key

Change the color used for an unselected key on the Dope Sheet.

part-selected key

Change the color used for a part-selected key on the Dope Sheet.

selected key

Change the color used for a selected key on the Dope Sheet.

timeline

Change the color used for the timeline on the Dope Sheet.

control text

Change the color used for the control text on the Dope Sheet. These
indicate the frame number of a key when you select one.

control text shadow

Change the color used for the shadow of the control text on the Dope
Sheet.

time label

Change the color used for the time labels on the Dope Sheet. These
indicate frame numbers.

current frame

Change the color used for the current frame on the Dope Sheet. This is a
vertical line that indicates the current frame on the timeline.

project frame range

Change the color used for the project frame range on the Dope Sheet.
These are two vertical lines indicate your frame range.

Control Panels
max nodes in
properties bin

Use this to set the maximum number of panels that can be open in the
Properties pane.

reopen acts like new
panel

When this is enabled, double-clicking a node that has been open before,
places the panel in the same place as a new panel. If this is disabled, the
panel appears in its previous position.

expand / collapse
panels in Properties
bin to match selection

If this is enabled, the node selection in the Node Graph determines which
control panels are expanded (all unselected nodes automatically have their
panels collapsed). This does not apply to floating control panels.

Color Panel
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Control Panels
color picker button
opens

Sets the type of color picker displayed when you click a color picker button
in the properties panel:
• in-panel color picker - opens a color wheel and sliders in the properties
panel.
• floating color picker - opens a color wheel and sliders in a floating
panel.

Tip: Holding Ctrl/Cmd and clicking the color picker button opens
the alternate color picker to the one specified in the Preferences.

File Browser
start file browser from
most recently used
directory

When enabled, new file browsers open at the last location used. When
disabled, new file browsers open at the current working directory.

Node Colors
autocolor

Deselect this checkbox to ignore individual soft effect color settings and,
instead always use the All Others color.

<node name or type>

The soft effects listed here have been given a default color. You can change
this by clicking the assigned color to open the color menu, and selecting a
new one.
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Node Colors

All Others

Use this to select the color to use as default for all soft effects not
otherwise specified above, or all soft effects if autocolor is disabled.

Project Items
shade project items

When enabled, additional shading is applied to source clips and shots in
the Project bin and timeline.

Item Labels
project bin
timeline
auto-adjust contrast

Click to change the color of labels in the Project and timeline panels. A
color wheel displays allowing you to select the required color.
When enabled, label colors are automatically adjusted if a potential colorclash is detected.

Item States
offline
error

Click the buttons to change the color of shots and comps in the timeline
panel. A color wheel displays allowing you to select the required color.

freeze
comp not rendered
comp out of date
comp rendered
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Project Items
Item Colors
display in project
panel

When enabled, the specified item colors, or defaults, are displayed in the
Project panel.

display in sequence
panel

When enabled, the specified item colors, or defaults, are displayed in the
timeline panel.

spreadsheet color
rows

When enabled, the specified item colors applied to rows in the
spreadsheet.

project

Click the buttons to change the color of items in the Project and timeline
panels. A color wheel displays allowing you to select the required color.

bin
sequence
source
audio
comp
file types

Allows you to add custom color-coding by file extension. Click the
button and then select a file type from the extension dropdown. Doubleclick the color swatch to display a color wheel allowing you to select the
required color.
Any source clip or shot with that extension is then colored accordingly in
the interface.
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Scopes
black point

Use the slider or the entry box to select the black point value.

white point

Use the slider or the entry box to select the white point value.

luma/chroma
encoding

Use this to select the video standard to use when converting from RGB to
luma and chroma for scope display.

Include viewer color
transforms

Select this checkbox to include applied Viewer color transforms (gain,
gamma, and LUT) in scope data. If this checkbox is disabled, all Viewer
transforms are ignored.

Note: If disabled, rendering may become slow as image
calculation may be needed.
Force full frame

Select this checkbox so that the Viewer always requests full frame data
when a scope is displaying data for that Viewer. If this checkbox is
disabled, the scopes only display data for the current area requested by
the Viewer, rather than the whole image.

Script Editor
font

Use this to select the font to use in the Script Editor.

Note: This control also changes the font in the BlinkScript Kernel
Source field.
indent

You can use this control to set the indent value to use when scripting.

save and restore script
editor history

Disable this checkbox if you prefer that the contents of the Script Editor is
not saved and restored between sessions of Nuke.

clear input window on
successful script
execution

Disable this checkbox if you want the most recent script to remain in the
input window after execution.
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Timeline
show frame end
marker

When enabled, an extra line is drawn on the timeline to the right of the
playhead, indicating the end of the current frame.

visible range follows
playhead

When enabled, the timeline scrolls with the playhead, constantly updating
the view. When disabled, the playhead is allowed to move off screen.

Audio Tracks
half waveforms

When enabled, audio tracks on the timeline display only the rectified
waveform. When disabled, the full waveform is displayed.

Viewer (Monitor Out)
use video legal range
for monitor out

When enabled, automatically limit monitor output to the legal range when
swapping between the Timeline environment and Compositing
environment.

Viewer
playback mode

Use this to set the Viewer playback mode:
• Play All Frames - the default setting, plays all frames in real-time
(dependent on hardware).
• Skip Frames - plays frames in real-time skipping where necessary to
maintain the frame rate.
• Play All Frames, Buffering - plays all frames by buffering and playing
frames back as they become available.

guides

You can use this to choose to show overlays in the image area. You can
choose from:
• Title Safe – Indicates where text should be entered to be visible.
• Action Safe – Indicates the area in which to place actions so that they are
visible.
• Format – Displays the size of the format over the Viewer.
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Viewer
fullscreen display

Use this to select which display to use for fullscreen mode. This setting
takes effect the next time fullscreen mode is entered.

see through missing
media

Select this checkbox to see through missing media in the timeline,
displaying the first displayable media in the underlying tracks.

background

Use this to select the Viewer background. You can select black, or gray
(using the slider to determine the grayscale), or checkerboard (using the
slider to determine the size of the squares).

frame increment

Use this to set the default number of frames skipped by the Viewer skip
controls, and the timeline Nudge More commands.

filtering mode

Use this to determine the filtering used during rendering in the Timeline
environment. You can select Auto, Nearest neighbour, or Linear.
Auto uses ths same automatic selection as in the Compositing
environment. This does not affect exports or rendering in the Compositing
environment.

Audio
default latency
adjustment (ms)

Use this to adjust the default timing offset (in milliseconds) between audio
and video to apply to new Viewers. Positive values make audio play earlier
relative to video; negative values make audio play later. To convert from
video frames to ms, divide 1000 ms by the video frame rate. For example:
• at 25fps, a video frame is 1000/25 = 40ms, or
• a 1.5 video frame delay = 1.5 * 40ms = 60ms.

default volume

Use the slider or numeric field to set the default volume.

Viewer Handles
Controls
2D handle size

Adjust the size of the square control handles that appear on the Viewer for
some operations, such as transformations, warps, and Bezier and B-spline
shapes.
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Viewer Handles

By default, this value is set to 5. You can also set the pickable area size of
the square control handles in the numeric field or slider to the right of the
2D handle size control.
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This page lists the keyboard shortcuts used by Hiero and HieroPlayer, along with their function. In
general, contiguous areas of the keyboard are assigned to related functionality. The left-hand keys on
a QWERTY keyboard are used for tool selection and actions, the right-hand side for playhead
manipulation including source/record and insert/overlay, the arrow keys for selection and nudging,
and the numeric pad for timecode entry.

Hotkeys

Button

Menubar

Function

n/a

Cycles between the available move tools:

Timeline and Editing Controls
Q

• Multi Tool
• Move/Trim
• Select
W

n/a

Cycles between the available selection tools:
• Select Track to Right/Left
• Select All in Track
• Select All Tracks Right/Left

Note: Holding Alt toggles between
track and all tracks behavior.
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Hotkeys

Button

Menubar

Function

E

n/a

Cycles between the Slip Clip and Slide Clip
tools.

R

n/a

Cycles between the available edit tools:
• Roll Edit
• Ripple Edit
• Retime Clip

T

n/a

Cycles between the available razor tools:
• Razor
• Razor All
• Join

left-click

n/a

n/a

Select a clip including any linked tracks.

Alt + left-click

n/a

n/a

Select a clip, ignoring linked tracks (for
example, audio only).

Shift + drag
clip

n/a

n/a

Disable snap to transition when dragging
clips.

left-click then
Shift + left-click

n/a

n/a

Select all clips between the left-clicks (use
Shift + Alt + left-click to ignore linked tracks).

drag then Alt

n/a

n/a

Activate Ripple mode while dragging the shot.

Alt then drag

n/a

n/a

Duplicate the dragged shot.

Alt and drag

n/a

n/a

Ripple and duplicate the dragged shot.

Alt and leftclick

n/a

n/a

Select a clip, ignoring linked tracks.

Ctrl/Cmd + A

n/a

n/a

Select all shots.

Ctrl/Cmd +
Shift + A

n/a

n/a

Deselect all shots.

n/a

File > New Project

Open a new project.

File Menu
Ctrl/Cmd +
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Hotkeys

Button

Menubar

Function

Ctrl/Cmd + O

n/a

File > Open

Open an existing project.

Alt + Shift +
<num>

n/a

File > Open Recent >
Project Name

Open a previously saved project from the list.

Ctrl/Cmd + W

n/a

File > Close

Close the current project.

Ctrl/Cmd + S

n/a

File > Save

Save the current project.

Ctrl/Cmd +
Shift + S

n/a

File > Save As...

Save the current project with a different name.

Ctrl/Cmd + I

n/a

File > Import Clips

Import a clip or clips.

Ctrl/Cmd +
Shift + I

n/a

File > Import Folder

Import a folder or folders.

Ctrl/Cmd + Alt
+ Shift + I

n/a

File > Import
EDL/XML

Import an EDL or XML sequence.

Ctrl/Cmd +
Shift + E

n/a

File > Export

Export the selected sequence.

Ctrl/Cmd + Q

n/a

File > Quit

Close Hiero and display a prompt to save any
unsaved work.

Ctrl/Cmd + Z

n/a

Edit > Undo

Undo the last action.

Ctrl/Cmd +
Shift + Z

n/a

Edit > Redo

Redo the last undo action.

Ctrl/Cmd + X

n/a

Edit > Cut

Cut the selected item(s) and place in the
buffer.

Ctrl/Cmd + C

n/a

Edit > Copy

Copy the selected item(s) to the buffer.

Ctrl/Cmd + V

n/a

Edit > Paste

Paste item(s) from the buffer.

Backspace /

n/a

Edit > Delete

Delete selected item(s).

Shift + N

Edit Menu
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Hotkeys

Button

Menubar

Function

Ctrl/Cmd + A

n/a

Edit > Select All

Select all files in the current bin.

Ctrl/Cmd +
Shift + A

n/a

Edit > Clear
Selection

Deselect all files in the current bin.

Ctrl/Cmd + D

n/a

Edit > Duplicate

Duplicate the selected object(s).

Shift + S

n/a

Edit > Preferences

Open the Preferences dialog.

Ctrl/Cmd +
Shift + 1

n/a

View > Zoom to
Actual Size

Zoom the contents of the Viewer to actual
size.

Ctrl/Cmd +
Shift + 2

n/a

View > Zoom to Half
Size

Zoom the contents of the Viewer to half size.

H

n/a

View > Zoom to Fill

Fit the current clip to the height or width of
the Viewer, depending on the clip's format.

F

n/a

View > Zoom to Fit

Zoom to fit the clip to the Viewer.

+

n/a

View > Zoom In

Zoom in to the Viewer.

- (minus)

n/a

View > Zoom Out

Zoom out of the Viewer.

Ctrl/Cmd + F

n/a

View > Full Screen

Toggle Full Screen mode.

Ctrl/Cmd +
Shift + F

n/a

View > Full Quality
1:1

Toggle Full Screen mode at Full Quality 1:1
zoom.

Esc

n/a

n/a

Exit full screen mode.

E

n/a

View > Clipping
Warning

Toggle the Level Warning tool on and off.

I

View > Mark In

Set the In Point at the current frame.

O

View > Mark Out

Set the Out Point as the current frame.

Delete

View Menu
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Hotkeys

Button

Menubar

Function

Alt + I

n/a

View > Clear In Point

Clear the In point for the current clip or
timeline.

Alt + O

n/a

View > Clear Out
Point

Clear the Out point for the current clip or
timeline.

Alt + U

n/a

View > Clear In and
Out Points

Clear the In and Out points for the current clip
or timeline.

Home

View > Go to Start

Go to the start of all clips.

End

View > Go to End

Go to the end of all clips.

Shift + I

n/a

View > Go to In
Point

Go to the In Point in the current clip.

Shift + O

n/a

View > Go to Out
Point

Go to the Out Point in the current clip.

View > Frame
Backwards

Skip one frame backwards.

View > Frame
Forwards

Skip one frame forwards.

Shift + ,
(comma)

View > Skip
Backwards

Skip backwards by the frame increment value
specified in the Viewer tools.

Shift + .
(period)

View > Skip
Forwards

Skip forwards by the frame increment value
specified in the Viewer tools.

Alt + , (comma)

View > Previous Edit

Go to the previous clip in the Viewer.

Alt + . (period)

View > Next Edit

Go to the next clip in the Viewer.

View > Previous Tag

Go to previous frame tag.

, (comma)
(K + J)
. (period)
(K + L)

Alt + Shift + ,
(comma)

n/a
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Hotkeys

Button

Menubar

Function

Alt + Shift + .
(period)

n/a

View > Next Tag

Go to next frame tag.

Space

View > Play

Play the clip or sequence currently in the
Viewer.

P

n/a

Pause RAM caching in the Viewer.

J

View > Play
Backward

Play clip or sequence currently in the Viewer
backward (click multiple times to increase
playback speed).

K

View > Pause

Pause playback.

L

View > Play Forward

Play clip or sequence currently in the Viewer
forward (click multiple times to increase
playback speed).

Enter (numeric
pad)

n/a

View > Edit Playhead
Time

Shift focus to the timecode field under the
Viewer, allowing you to manually edit the
playhead position.

Ctrl/Cmd +
Shift + P

n/a

View > Ignore Pixel
Aspect

Display the clip in the Viewer with a 1:1 aspect
ratio.

Ctrl/Cmd + /

n/a

Show Timeline
Editor

Display the timeline pane, if it is not already
visible.

Return
(main
keyboard)

n/a

View > Swap Inputs

Controls the AB inputs:
• Stack - swaps which input is visible.
• Horizontal - swaps the inputs horizontally.
• Vertical - swaps the inputs vertically.

R, G, B, A, Y
PgUp

n/a

View > Channels

Set the Viewer output channel.

n/a

Scroll up and down through available layers in
the Viewer.
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Hotkeys

Button

Menubar

Function

PgDn

n/a

PgDn

n/a

\ (back slash)

n/a

View > Show
Overlays

Toggle the HUD overlays.

View > Toggle
SplitWipe

Toggle the SplitWipe compare mode on and
off.

W

Project Menu
Ctrl/Cmd + B

n/a

Project > New Bin

Create a new bin in the current bin.

Ctrl/Cmd + Y

n/a

Project > New Tag

Create a new tag in the current bin (tags can
only be created in the Tags tab).

Ctrl/Cmd + N

n/a

Project > New
Sequence

Create a new sequence in the current bin.

n/a

Clip > Open In >
Viewer

Open the selected clip in the Viewer.

n/a

Clip > Open In >
New Viewer

Open the selected clip a new Viewer.

1

n/a

Clip > Open In >
Viewer Input A

Open the selected clip in Viewer input A.

2

n/a

Clip > Open In >
Viewer Input B

Open the selected clip in Viewer input B.

Alt + D

n/a

Clip > Open In >
Metadata View

Open the metadata view for the selected clip.

D

n/a

Clip > Hide Version

Hide the currently selected version(s) of a clip
in the Versions Bin view.

Clip Menu
Ctrl/Cmd +
Return
(main
keyboard)
Ctrl/Cmd + Alt
+ Return
(main
keyboard)
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Hotkeys

Button

Menubar

Function

Alt + á

n/a

Clip > Version Up

Cycle up through the available clip versions.

Alt + â

n/a

Clip > Version Down

Cycle down through the available clip versions.

Ctrl/Cmd + Alt
+á

n/a

Clip > Max Version

Jump to the maximum known version or scan
for new versions if the max version is already
reached.

Ctrl/Cmd + Alt
+â

n/a

Clip > Min Version

Jump to the minimum known version or scan
for new versions if the min version is already
reached.

V

n/a

Clip > Select Version

Display the available versions of a source clip
or sequence.

F5

n/a

Clip > Refresh Clips

Reload the source clip or shot when the
source file location has not changed, such as
when work has been done on the clip offline.
Selecting refresh only refreshes the source
clip’s current frame range.

Alt + F5

n/a

Clip > Rescan Clip
Range

Similar to Refresh Clips, above, but rescan
also checks for additional frames that may
have been added to the source clip and adds
them to the shot’s frame range.

N

n/a

Clip > Insert

Insert the contents of a source Viewer into the
timeline at the current playhead position and
ripple existing shots downstream to
accommodate the change.

M

n/a

Clip > Overwrite

Insert the contents of a source Viewer into the
timeline at the current playhead position
overwriting existing shots.

Shift + U

n/a

Timeline > Mark
Selection

Place the In and Out markers around the
selected shot or shots on the timeline.

U

n/a

Timeline > Mark Clip

Place the In and Out markers around the

Timeline Menu
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Hotkeys

Button

Menubar

Function
upper-most timeline clip under the current
playhead position.

C

n/a

Timeline > Razor
Selected

Apply the Razor tool to the currently selected
track(s) within the selected clip(s).

Shift + C

n/a

Timeline > Razor All

Apply the Razor tool to all tracks within the
selected clip(s).

Shift +
Backspace

n/a

Timeline > Ripple
Delete

Remove the selected clip(s) and ripple clips
down stream to close gaps in the timeline.

Ctrl/Cmd + T

n/a

Timeline >
Transition >
Dissolve

Add a dissolve between two selected shots.

D

n/a

n/a

Enable or disable the selected clip(s) or track
(s).

Ctrl/Cmd + Alt
+A

n/a

Timeline > Select All
in Track

Select all the shots on the current track.

Ctrl/Cmd + ß

n/a

Timeline > Nudge >
Nudge Left

Trim, roll, or nudge a selected transition or
shot to the left (within the available handles
for trim and roll).

Ctrl/Cmd + à

n/a

Timeline > Nudge >
Nudge Right

Trim, roll, or nudge a selected transition or
shot to the right (within the available handles
for trim and roll).

Ctrl/Cmd +
Shift + ß

n/a

Timeline > Nudge >
Nudge Left More

Trim, roll, or nudge a selected transition or
shot to the left by the frame increment value
specified in the Viewer tools (within the
available handles for trim and roll).

Ctrl/Cmd +
Shift + à

n/a

Timeline > Nudge >
Nudge Right More

Trim, roll, or nudge a selected transition or
shot to the right by the frame increment value
specified in the Viewer tools (within the
available handles for trim and roll).

Ctrl/Cmd + á

n/a

Timeline > Nudge >

Nudge the selected shot(s) up one track.
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Hotkeys

Button

Menubar

Function

Nudge Up
Ctrl/Cmd + â

n/a

Timeline > Nudge >
Nudge Down

Nudge the selected shot(s) down one track,
where possible.

Alt + Shfit + /

n/a

Timeline > Rename
Shots

Display the Rename Shots dialog for the
selected shots.

n/a

Cache > Clear
Playback Cache

Click to clear the frames stored in the
playback cash, represented by the green bar
under the Viewer playhead.

Alt + S

n/a

Window > Toggle
Fullscreen

Expand the interface to fill the available screen
space.

Ctrl/Cmd + Alt
+ Shift + ‘
(backtick)

n/a

n/a

Cycle backwards through all current panes.

Ctrl/Cmd + Alt
+ ‘ (backtick)

n/a

n/a

Cycle forwards through all current panes.

Ctrl/Cmd +
Shift + [

n/a

n/a

Jump between tabs in the current pane.

Ctrl/Cmd +
Shift + ]

n/a

n/a

Shift + F1

n/a

Window >
Workspace >
Conforming/Editing

Switch to Hiero’s Conforming workspace or
HieroPlayer’s Editing workspace.

Shift + F2

n/a

Window >
Workspace >
Editing/Flipbook

Switch to Hiero’s Editing workspace or
HieroPlayer’s Flipbook workspace.

Shift + F3

n/a

Window >
Workspace >

Switch to the Reviewing workspace.

Cache Menu
F12

Window Menu
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Hotkeys

Button

Menubar

Function

Reviewing
Shift + F4

n/a

Window >
Workspace >
Timeline

Switch to the Timeline workspace.

Shift + F<num>

n/a

Window >
Workspace >
Custom Workspace
Name

Switch to the custom workspace associated
with the number selected.

n/a

n/a

Pan the contents of the Viewer.

n/a

n/a

Zoom the Viewer or Viewer timeline.

n/a

n/a

Zoom the Viewer timeline to the indicated
frame range.

n/a

n/a

Zoom the contents of the Viewer or timeline.

Viewer Controls
Alt + left-click +
drag
(middle-click
and drag on
Linux)
Scroll wheel
(over Viewer or
Viewer
timeline)
Scroll wheel
middle-click +
drag
(over Viewer
timeline or
timeline)
Scroll wheel
Alt + middleclick + drag
(over Viewer or
timeline)
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Hotkeys

Button

Menubar

Function

middle-click

n/a

n/a

Zoom to fit the Viewer timeline to Viewer
contents.

(over Viewer
timeline or
timeline)

Note: If your mouse preferences are
not set to Button 3 for the middle
mouse button, you may have to use
Ctrl/Cmd + middle-click.

Alt + close
Viewer

n/a

Close only the selected tab. Clicking close
without holding Alt closes any linked tabs as
well.

Spreadsheet Controls
Alt + left-click

n/a

n/a

Move the playhead to the selected clip’s In
point on the timeline.

Alt + double
left-click

n/a

n/a

Move the playhead to the selected clip’s In
point on the timeline and zoom to fit the clip
in the timeline view.

n/a

Close only the selected tab. Clicking close
without holding Alt closes any linked tabs as
well.

Alt + close
Spreadsheet

Bin View Searchbox Controls
left-click

n/a

n/a

Select a tag search criteria.

Ctrl/Cmd + leftclick

n/a

n/a

Toggle select individual tag search criteria.

Shift + left-click

n/a

n/a

Select a range of tag search criteria.

n/a

Go to the previous script.

Script Editor Controls
Ctrl/Cmd + [
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Hotkeys

Button

Menubar

Function

Ctrl/Cmd + ]

n/a

Go to the next script.

Ctrl/Cmd +
Enter

n/a

Execute current script.

Ctrl/Cmd +
Backspace

n/a

Clear the output pane.
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Supported File Formats
The following table lists the supported file formats. The extensions listed under Extension let you
specify the image format; use these as the actual file name extensions or the prefix to indicate output
format for the image sequences.
Format

Bit
Depths

Read/Write Extension

Notes

Apple
ProRes

8, 10

read and
write

Adds support for Apple ProRes 4444 and
Apple ProRes 422 on Mac, Linux, and
Windows using the mov64 reader.

mov

Apple ProRes 4444 includes the SD, HD, 2K,
UHD, and XQ formats. Apple ProRes 422
includes the HQ, LT, and Proxy formats.
ARRIRAW

12

read only

ari

AVI

n/a

read and
write

avi

AVI files can be supported by default or via
Hiero’s reader/writer that is based on the
FFmpeg open source library. If you get an
error when using AVI files in Read nodes, you
may need to use the prefix mov64: before the
file path and file name, for example:
mov64:z:/job/FILM/IMG/final_comp_
v01.####.avi
When working with Write nodes, you can also
select mov64 from the file type dropdown
menu and use avi as the file extension.
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Format

Bit
Depths

Read/Write Extension

Notes

On Windows, in order to support more
codecs, the AVI reader uses the DirectShow
multimedia architecture. When decoding .avi
files, DirectShow tries to find the appropriate
codec on the system. If the codec is not
available, DirectShow and Hiero are unable to
open the .avi file. Note that the 64-bit version
of Hiero can only use 64-bit DirectShow
codecs. If you only have a 32-bit codec
installed, the 64-bit version of Hiero cannot
use it to open .avi files.
CIN

10 (log)

read and
write

cin

DNG

8, 12

read

dng

Includes RAW 2.5K CinemaDNG

DPX

8, 10, 12,
and 16

read and
write

dpx

YCbCr encoded DPX files are not supported on
the timeline.

GIF

8

read only

gif

Radiance

16

read and
write

hdr, hdri

This format stores an 8-bit mantissa for each
of r, g, and b and an additional 8-bit exponent
that is shared by all three, which packs the
floating point RGB triplet into 32 bits per
pixel.

JPEG

8

read and
write

jpg, jpeg

Adjust compression levels using the quality
slider in the Write node’s properties panel.

MXF

n/a

read only

mxf

Note: Currently, only 'complete' MXF
files are supported.
Supported codecs include:
• Uncompressed 4:2:2 YCbCr 8-/10-bit
• Uncompressed 4:4:4:4 RGBA 8-/10-bit
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Format

Bit
Depths

Read/Write Extension

Notes

• Uncompressed Avid 4:2:2 YCbCr 8-/10-bit
• Uncompressed Avid 4:4:4:4 RGBA 8-/10-bit
• JPEG2000
• Avid DNxHD (1080p and 720p 1920x1080 and
1280x720, 4:4:4:4 and 4:2:2) 36, 115, 120, 145,
175, 185, 220, 220x
• Sony Raw from the F65, F55, F5 and FS700
cameras. All formats that these cameras
provide: 4K, 2K, 1K, 0.5K and 0.25K
• Sony X-OCN from the VENICE, F55, and F5
cameras.
• ARRIRAW from the Alexa Mini.
OpenEXR

16, 32

and

read and
write

exr

OpenEXR
2.2

OpenEXR handles 16- and 32-bit float. This 16
is also called "half float" and is different from
the 16-bit integer that all the other formats
that support 16-bit use.
Hiero supports multi-part OpenEXR files. For
more information, see the Nuke User Guide.

EXR Compression
EXR file metadata contains a compression key/value pair detailing the compression type used to
write the .exr file. The value is expressed as the name of the compression type or an integer
referencing the compression used:
0 - no compression
1 - RLE compression, run length encoding
2 - Zip compression, one scan line at a time
3 - Zip compression, in blocks of 16 scan lines
4 - PIZ-based wavelet compression, in blocks of 32 scan lines
5 - PXR24 compression, lossy 24-bit float
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Format

Bit
Depths

Read/Write Extension

Notes

6 - B44 compression, lossy 4-by-4 pixel block, fixed rate
7 - B44A compression, lossy 4-by-4 pixel block, flat fields are compressed more
8 - DWAA compression, lossy DCT based compression, in blocks of 32 scan lines
9 - DWAB compression, lossy DCT based compression, in blocks of 256 scan lines
PNG

8, 16

read and
write

png (8-bit)
png16 (16bit)

PSD

8, 16

read only

psd

While Hiero reads standard Photoshop®
blend modes, it doesn't read Photoshop layer
comps or recognize group blend modes.
Photoshop layers are read into separate Hiero
layers and anything that doesn't map into that
is ignored.

QuickTime

n/a

read and
write

mov

QuickTime is only supported by default on
Windows and Mac. To use QuickTime files on
Linux, you need to use the prefix mov64:
before the file path and file name, for
example,
mov64:/z:/job/FILM/IMG/final_comp_
v01.####.mov
The mov64 writer supports the following
codecs:
• Apple ProRes 4444
• Apple ProRes 4444 XQ
• Apple ProRes 422 HQ
• Apple ProRes 422
• Apple ProRes 422 LT
• Apple ProRes 422 Proxy
• Avid DNxHD (1080p and 720p 1920x1080 and
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Format

Bit
Depths

Read/Write Extension

Notes

1280x720, 4:4:4:4 and 4:2:2) 36, 115, 120, 145,
175, 185, 220, 220x

Note: Interlaced writing is not
supported. See Avid DNxHD Notes
below.
• Photo - JPEG
• MPEG-1 Video
• MPEG-4 Video
• PNG
• Animation
• Uncompressed 10-bit 4:2:2
Avid DNxHD Notes
The bit rates listed in the codec profile dropdown are the bit rates for 1080p at 29.97 fps EXCEPT for
36 (which is actually 45 Mbps @ 29.97fps). You should look at the codec format (422/444, 8/10-bit).

Note: Nuke only supports 1080p and 720p. Non-HD resolutions are scaled to 1080p
before writing.
This leads to a set of 1080p bit rates:
• 1080p/29.97 440x, 220x, 220, 145, 45
• 1080p/60 N/A, N/A, 440, 290, 90 (same at 59.94)
• 1080p/50 N/A, N/A, 367, 242, 75
• 1080p/25 365x, 185x, 185, 120, 36
• 1080p/24 350x, 175x, 175, 115, 36 (same at 23.976)
At 720p, the codec profile dropdown has a different interpretation. The bit rate is taken as the bit
rate at 720p at 59.94fps. This leads to another set of bit rates:
• 720p/59.94 N/A, 220x, 220, 145, N/A
• 720p/50 N/A, 175x, 175, 115, N/A
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Format

Bit
Depths

Read/Write Extension

Notes

• 720p/29.97 N/A, 110x, 110, 75, N/A
• 720p/25 N/A, 90x, 90, 60, N/A
• 720p/23.976 N/A, 90x, 90, 60, N/A

Note: Since the bit rates are for 1080p at 29.97 fps AND 720p at 59.94 fps (except for 36
Mbit which should read 45 Mbit). It is possible to calculate the bandwidth for all the other
frame rates by:
• BandWidth@1080p = fps/29.97 * NominalBandWidth, or
• BandWidth@720p = fps/59094 * NominalBandWidth
where NominalBandWidth is the bandwidth listed in the codec profile knob OR 45 if the
bandwidth listed is 36 Mbit. (Avid labels the codec profile names by the approximate
bandwidth.)

RAW

n/a

read only

n/a

DSLR raw data files, such as Canon .CR2 files.
These are only supported via the dcraw
command line program, which you can
download from the dcraw website. Bit depth
and other specifications depend on the
device. Some devices may not be supported.

REDCODE

16

read only

r3d

Note that .r3d files may look different in Hiero
compared to various versions of RED
applications, like RED ALERT or REDCINE.
Unlike most other file formats Hiero reads,
the .r3d REDCODE files must be processed to
convert from a raw format to an RGB color
image. From time to time, a new version of
the RED SDK that Hiero uses improves this
processing and due to the timing of release
cycles, Hiero may sometimes be using a
different version than the RED applications.
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Format

Bit
Depths

Read/Write Extension

SGI

8, 16

read and
write

Notes

sgi, rgb,
rgba (8-bit
sequences)
sgi16 (for
16-bit
sequences)

SoftImage

8

read and
write

pic

8, 16, and
32

read and
write

tif, tiff (8If utilized, the compression schema on
bit
imported TIFF sequences must be LZW®.
sequences)

®

PIC
TIFF

tif16, tiff16
(16-bit
sequences)
ftif, ftiff
(32-bit
sequences)
T
ruevision®
TARGA

8

read and
write

tga, targa

Wavefront

8

read only

rla

XPM

8

read and
write

xpm

This is the text-based format in which Hiero’s
interface elements are stored.

YUV

8

read and
write

yuv

This format does not specify resolution, so
Hiero assumes a width of 720 pixels.

®

RLA
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Supported Camera Formats
The following table lists supported ARRI, R3D, and Sony camera/sensor formats.
Camera/Sensor

Nuke 11.1

Nuke 11.2

Nuke 11.3

ARRI (.ari and .mxf)
ALEXA Classic
ALEXA XT
ALEXA SXT(W)
ALEXA LF
ALEXA 65
ALEXA Mini
AMIRA
Note: Nuke, Nuke Studio, and Hiero do not support .mxf from the AMIRA camera.
R3D (.r3d)
MONSTRO 8K VV
HELIUM 8K S35
SCARLET-W 5K
RED RAVEN 4.5K
WEAPON DRAGON 6K
EPIC/SCARLET DRAGON
RED ONE MYSTERIUM 4K
MYSTERIUM-X
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Camera/Sensor

Nuke 11.1

Nuke 11.2

Nuke 11.3

MYSTERIUM-X MONOCHROME
SONY (.mxf)
F5
F55
F65
FS700
VENICE

Reader Fallback Paths
If the application can't find a suitable reader when reading source clips from disk, the following paths
are searched for fallback .dylib, .so, and .dll readers compiled against the comparable Nuke version:

Mac:
• /$HOME/.nuke
• /Library/Application Support/Nuke/x.x/plugins/

Linux:
• /$HOME/.nuke
• /usr/local/Nuke/x.x/plugins/

Windows:
• \$HOME\.nuke
• C:\Program Files\Common Files\Nuke\x.x\plugins\
• C:\Program Files (x86)\Common Files\Nuke\x.x\plugins\
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Note: You can also add your own search paths using the NUKE_PATH environment variable.
See Setting Environment Variables for more information.
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Supported Audio Formats
The following table lists supported audio formats.

Note: Although Nuke supports the import and editing of multi-channel audio, during
playback audio is currently mixed to 48 KHz stereo output.

Format Name

Extension

Audio only formats
All platforms
Wave

wav

Audio interchange format

aiff

Mac and Windows
MPEG 4 Audio

m4a

Integrated audio formats
RED Audio

r3d

QuickTime Audio

mov

Note: QuickTime Audio is not supported on Linux OS.
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Appendix D: External Software
Third-Party Contributions
The following table lists third-party contributions included in Hiero, along with their licenses.

Contributor

Description

License

Pixar

DTEX file
reader

Copyright © Pixar. All rights reserved.
This license governs use of the accompanying software. If you use
the software, you accept this license. If you do not accept the
license, do not use the software.
1. Definitions
The terms "reproduce," "reproduction," "derivative works," and
"distribution" have the same meaning here as under U.S. copyright
law. A "contribution" is the original software, or any additions or
changes to the software.
A "contributor" is any person or entity that distributes its
contribution under this license. "Licensed patents" are a
contributor's patent claims that read directly on its contribution.
2. Grant of Rights
(A) Copyright Grant- Subject to the terms of this license, including
the license conditions and limitations in section 3, each contributor
grants you a non-exclusive, worldwide, royalty-free copyright license
to reproduce its contribution, prepare derivative works of its
contribution, and distribute its contribution or any derivative works
that you create.
(B) Patent Grant- Subject to the terms of this license, including the
license conditions and limitations in section 3, each contributor
grants you a non-exclusive, worldwide, royalty-free license under its
licensed patents to make, have made, use, sell, offer for sale,
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Contributor

Description

License
import, and/or otherwise dispose of its contribution in the software
or derivative works of the contribution in the software.
3. Conditions and Limitations
(A) No Trademark License- This license does not grant you rights to
use any contributor's name, logo, or trademarks.
(B) If you bring a patent claim against any contributor over patents
that you claim are infringed by the software, your patent license
from such contributor to the software ends automatically.
(C) If you distribute any portion of the software, you must retain all
copyright, patent, trademark, and attribution notices that are
present in the software.
(D) If you distribute any portion of the software in source code form,
you may do so only under this license by including a complete copy
of this license with your distribution. If you distribute any portion of
the software in compiled or object code form, you may only do so
under a license that complies with this license.
(E) The software is licensed "as-is." You bear the risk of using it. The
contributors give no express warranties, guarantees or conditions.
You may have additional consumer rights under your local laws
which this license cannot change.
To the extent permitted under your local laws, the contributors
exclude the implied warranties of merchantability, fitness for a
particular purpose and non-infringement.
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Third-Party Libraries and Fonts
Note: If, for any reason, you think Foundry is not entitled to use these libraries and fonts,
please visit support.foundry.com.

Third-Party Library Versions
The following table lists third-party libraries included in Hiero and their current version.
Version
Library

Linux

Mac

Windows

AAF

44m1_v1

44m1_v1

44m1_v1

ACES

1.0.3

1.0.3

1.0.3

AJA

12.5.2.7

12.5.1

12.5.1

Alembic

1.6.1

1.6.1

1.6.1

ARRIRAW SDK

6.0

6.0

6.0

Blackmagic

10.8.3

10.8.3

10.8.3

bmx

20140528

20140528

20140528

Boost

1.61.0

1.61.0

1.61.0

Breakpad

r1338

r1338

r1338

bzip

1.0.6

1.0.6

1.0.6

cIFFT_AMD

20131219

20131219

20131219

cppunit

1.12.1

1.12.1

1.12.1

Ctypes

1.0.2

1.0.2

1.0.2

CUDA

8.0 & 6.5

8.0 & 6.5

8.0 & 6.5
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Version
Library

Linux

Mac

Windows

Curl

7.53.0

7.53.0

7.53.0

DirectX

N/A

N/A

Jun10

DNG SDK

1.3

1.3

1.3

DNxHD and DNxHR

2.3.1

2.3.1

2.3.1

EuCon

N/A

2.5.5

N/A

Expat

2.0.1

2.0.1

2.0.1

FBX

2017.0.1

2017.0.1

2017.0.1

FFmpeg

2.1.4

2.1.4

2.1.4

FFTW

3.1.3

3.1.3

3.1.3

FreeType

2.5.0.1

2.5.0.1

2.5.0.1

FTGL

2.1.3

2.1.3

2.1.3

GCC

4.8.2 - with bugfix

4.8.2 - with bugfix

4.8.2 - with bugfix

GLEW

1.5.8

1.5.8

1.5.8

googletest

1.5.0

1.5.0

1.5.0

gperftools

2.0

2.0

2.0

HDF

5.1.8.7

5.1.8.7

5.1.8.7

Intel Libraries

17.1.143

12.1.0258

17.1.143

Intel MKL

11.3.4

11.3.4

11.3.4

Intel TBB

4.4.6

4.4.6

4.4.6

JPEG

6b

6b

6b

Libexif

0.6.20

0.6.20

0.6.20

Libpng

1.4.8

1.4.8

1.4.8
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Version
Library

Linux

Mac

Windows

libresample

0.1.3

0.1.3

0.1.3

libsndfile

1.0.25

1.0.25

1.0.25

Libtiff

3.9.4

3.9.4

3.9.4

LLVM

3.3

3.3

3.3

Oculus Rift SDK

N/A

N/A

0.4.4

OFX

1.2

1.2

1.2

OfxHostSupport

1.0

1.0

1.0

OpenCL

1.0

N/A

1.0

OpenColorIO

1.0.9

1.0.9

1.0.9

OpenEXR

2.2.0

2.2.0

2.2.0

OpenJPEG

1.5.0

1.5.0

1.5.0

OpenSSL

1.0.2g

1.0.2g

1.0.2g

OpenSubDiv

3.1.0x

3.1.0x

3.1.0x

OpenVDB

4.x

4.x

4.x

PoissonRecon

V2

V2

V2

PortAudio

v19_20111221

v19_20111221

v19_20111221

Primatte

2017.5.0

2017.5.0

2017.5.0

ProRes

2017-04-02

2017-04-02

2017-04-02

protobuf

2.5.0

2.5.0

2.5.0

psutil

2.0.0

2.0.0

2.0.0

Ptex

2.1.28

2.1.28

2.1.28

PySide

2.0

2.0

2.0
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Version
Library

Linux

Mac

Windows

PyString

1.1.0

1.1.0

1.1.0

Python

2.7.13

2.7.13

2.7.13

PyZMQ

13.0.2

13.0.2

13.0.2

QuickTime

N/A

7.3

7.3

QuickTimeHelper

N/A

1.0

1.0

Qt

5.6.1 - modified

5.6.1 - modified

5.6.1 - modified

R3D SDK

7.0.6

7.0.6

7.0.6

RLM

12.2

12.2

12.2

SCons

2.1.0

2.1.0

2.1.0

Skein

1.1

1.1

1.1

sony-ArbitraryOutputAttr

1.0

1.0

1.0

sony-BinaryIO

1.0

1.0

1.0

sony-dirent

N/A

N/A

1.0

sony-dlfcn

N/A

N/A

1.9

sony-expatwrap

N/A

1.0

1.0

sony-mpeg4decodersdk

N/A (header-only)

N/A (header-only)

N/A (header-only)

sony-ptr

N/A (header-only)

N/A (header-only)

N/A (header-only)

sony-pystring

1.0

1.0

1.0

sony-rawsdk

3.1

3.1

3.1

sony-resolutiontable

1.0

1.0

1.0

sony-sceneGraphAttr

1.0

1.0

1.0

sony-smdk

4.16

4.16

4.16
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Version
Library

Linux

Mac

Windows

sony-xmlIO

1.0

1.0

1.0

Tcl

8.4.16

8.4.16

8.4.16

TinyXML

N/A (header-only)

N/A (header-only)

N/A (header-only)

Ultimatte

1.0

1.0

1.0

uriparser

0.8.0

0.8.0

0.8.0

uuid

1.0

N/A

N/A

VXL

1.10.0

1.10.0

1.10.0

xmlrpcpp

N/A

N/A

0.7

ZeroMQ

3.2.5

3.2.5

3.2.5

zlib

1.2.5

1.2.5

1.2.5

For a full list of all third-party licenses and fonts used in Hiero, please see the Nuke Online Help,
Third-Party Libraries and Fonts, or click here.
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