Release Notes for Modo15.1v2

Release Date
16 September 2021

System Requirements

Officially Supported Operating Systems
• macOS 10.14.x, 10.15.x, and 11.x

Note: Testing on Apple Silicon (M1) processors is in progress and this statement will be updated when completed.

• Windows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7.6+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher
• 10 GB available hard disk space (for a full Modo and content installation)
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of GPU memory and drivers that support OpenGL 3.2 or higher.
• AMD AI Denoiser requires a minimum of 4 GB of GPU memory.
Recommended System Requirements

**Note:** This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 4+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions

- NVIDIA: 461.09 or later
- AMD: 8.982.8.1 or later

**Note:** We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 15.1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

**Note:** Hardware marked with * (asterisk) was unavailable for QA testing for Modo 15.1 because of office access limitations due to COVID-19, but has been used to test previous releases.
If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

### Tested Workstation Hardware

| Apple            | Macbook Pro (Retina, 16-inch, 2019)  
|                 | Macbook Pro (Retina, 15-inch, 2018)  
|                 | Macbook Pro (Retina, 15-inch, 2017)  
| Dell             | XPS 15 9560  
|                 | Precision 3520  
| HP               | HP Z600*  
|                 | HP Z640*  
|                 | HP Z800  
| CPU              | AMD Ryzen Threadripper*  
|                 | Intel i7-7700k*  
|                 | Intel i7-8700  
|                 | Intel i9-9900k  
|                 | Intel Core i7 10750H  

### Tested GPU Hardware

| AMD Prosumer Graphics Cards | Radeon Vega RX*  
|----------------------------|------------------  
| AMD Enterprise Graphics Cards | Radeon Pro 5300M  
|                            | Radeon Pro WX 8200  
|                            | Radeon Pro WX 7100  
|                            | Radeon Pro 560X  
| NVIDIA Prosumer Graphics Cards | GeForce GTX 1070 Ti (Linux)  
|                                | GeForce 1080*  
|                                | GeForce 2070 Super  
|                                | GeForce 1080*  
|                                | GeForce 2070 Super  
| NVIDIA Enterprise Graphics Cards | Quadro T1000  
|                                | Quadro M4000*  

---
New Features and Enhancements

FBX I/O Embedded Media Option

A new **Embed Media** option has been added to the **FBX I/O** preferences. When enabled, any media within your scene is included with FBX exports. This option is disabled by default.

![FBX I/O Preferences](image)

Fixes

File I/O

- ID 485867 - FBX: Exporting an animated mesh with a actor and action resulted in an incorrect initial bind pose.

General

- ID 481751 (61462) - Japanese strings were not supported in the Item List, Shader Tree, or Vertex Map List.

MeshFusion

- ID 468417 - Subtractive meshes stacked on top of themselves caused Modo to crash if they included a large number of vertices.
- ID 473369 - Edge Weight Strips disconnected **Skirt Width** values.
- ID 482693 (61497) - Certain MeshFusion items disappeared when selecting and deselecting them in Items mode.
- ID 483814 - The **New Fusion with Selected Meshes** button was occasionally disabled incorrectly.
- ID 484111 - Enabling **Fusion UVs** with **Edge Weight to Strips** occasionally caused Modo to crash.
• ID 486678 - Stored OmniHaul settings did not work in a MeshFusion context.

**Modeling**

• ID 468894 - Canceling Vertex Map tool operations stopped them working until you pressed the **Escape** key.
• ID 484762 (61567) - Shear did not allow the use of the **Ctrl** keyboard shortcut to constrain transforms on an axis as expected.

**Preset Browser**

• ID 486611 - Right-clicking in the Preset Browser caused Modo to crash.
• ID 488123 - Re-loading an image repeatedly in the Shader Tree caused Modo to crash.

**Procedurals**

• ID 482102 (61477) - Curve Sweep Deform Points Edit did not work as expected in the MeshOps stack.
• ID 483263 - Curve Boolean: The calculation of the first character of a text string did not work as expected.
• ID 483870 (61543) - Dragging and dropping meshes between certain scenes caused Modo to crash.

**Rendering**

• ID 483270 (61517) - Saving passes as images from the render viewport incorrectly added a period after the filename.

**Rigging**

• ID 482985 - Opening certain files with Relationship nodes caused Modo to crash.
• ID 484432 - Disabling pause evaluation after closing a scene caused Modo to crash.

**Schematic**

• ID 480243 - Linking channels was imprecise.
• ID 481868 - The output for Locator to Array did not line up correctly if the inputs were expanded.

**Scripting**

• ID 484715 - Calling `scene.removeItem()` removed all references on a texture from other items.
• ID 485637 - Calling `attr.popNumeric()` without arguments and clicking **OK** in the dialog caused Modo to crash.

**Shader Tree**

• ID 422463 (60215) - Shader Tree Group scale ignored distance-based gradients.
• ID 485478 - Opening certain scenes caused all shader groups in the tree to expand unexpectedly.
• ID 48567 - Inverse scale from Gradient Distance was not applied correctly.
• ID 488123 - Reloading an image repeatedly in the Shader Tree caused Modo to crash.

**UI**

• ID 471044 - Menus did not work as expected until artists clicked in the viewport.
• ID 481223 - Assigning MMB as an OmniHaul preset caused the Clone tool to malfunction.
• ID 481926 - The UV Unwrap & Relax tool did not save default hauling.
• ID 482850 (61500) - There was a noticeable delay creating new scenes.
• ID 483001 - Curve Extrude MOP failed to load default hauling for all subtools on initial creation.
• ID 483109 (61511) - Subform **More/Less** buttons did not display as expected.
• ID 483111 (61513) - Some viewports did not open as expected.
• ID 483320 (61521) - Certain mini popovers did not display correctly.
• ID 483631 (61528) - Hauling was allowed incorrectly with **Pattern** channels.
• ID 483652 (61532) - Navigating the Item List using the up and down arrow keys did not work as expected.
• ID 483655 (61534) - Loading default hauling for a tool applied the tool.
• ID 483733 (61541) - Mouse-wheel increment distances were smaller when compared to 15.0v3 builds.
• ID 484382 (61556) - Assigning **item.channelHaul()** to a Locator caused hauling to behave unexpectedly.
• ID 484635 (61560) - OmniHaul defaults for Thicken had **MMB-X** assigned to both **Scale** and **Max Angle**.
• ID 484637 (61561) - The OmniHaul default for Plane Slice, or Polygon Slice, interfered with repeating tool actions.
• ID 485821 - Certain **tool.doApply()** calls were incorrectly included in the **SelectableToolHaulingDefaults.cfg** file.
• ID 486353 - Some popovers did not open as expected.
• ID 486454 - macOS only: More/Less buttons were always present in vtabs.
Viewports

• ID 486667 - The 3D viewport was occasionally out of focus in new sessions.

Known Issues

This section covers some known issues and gives workarounds for them, where appropriate.

Animation

• ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

  **Note:** As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab, then save and reload the scene.

• ID 395357 - Deformer Caching doesn't work.
• ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.

Assemblies

• ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual layout of nodes on import.

  **Note:** As a workaround, you can save assemblies from the Schematic viewport.

Baking

• ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.
• ID 221481 (49437) - The Bake Channel Swizzling option can't bake to texture alpha.

Bucket Render

• ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.
• ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.

**Note:** As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

• ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

**Note:** As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

• ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.
• ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.

**Note:** As a workaround, freeze the transforms in the mesh properties.

### Color Management

• ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

**Note:** As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

### Command Line

• ID 289290 (49514) - macOS only: Running modo_cl before running the UI Modo application breaks code signing.

**Note:** As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.
File and Image I/O

• ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This only affects import using the kit, not direct imports (File > Import).

  Note: As a workaround, before importing a SolidWorks file for the second time, exit and restart Modo.

• ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes and procedural shatter items.
• ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't export instances, unless the original mesh is also exported.

  Note: To resolve this, set the .fbx preference to Export Selection and use Export As....

• ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.
• ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.
• ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.

  Note: As a workaround, use File > Import.

• ID 482247 - Dragging and dropping an image from the OS browser onto a mesh in the 3D viewport causes Modo to crash.

  Note: As a workaround, drag and drop into the Images (Clips) view or load the image into the Shader Tree before dragging it onto the mesh.

Fur

• ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.
**Note:** Use different fur length drivers, such as hair guides or vector vertex maps.

**Input Devices**

- **ID 226536 (51741)** - macOS only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

  **Note:** As a workaround, change to a 3-button mouse (recommended to fully access all of Modo’s features).

- **ID 303287 (35856)** - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

  **Note:** To avoid this, plug in the tablet before application startup or restart.

**MeshFusion**

- **ID 316276 (56973)** - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options will be supported.

**Modeling**

- **ID 226970 (32728)** - Zooming out with a Space Navigator alters the Work Plane position.
- **ID 408278 (60027)** - Linear Falloff snaps to object size.

  **Note:** As a workaround, use the right mouse button for an interactive initial linear handle.
Network Rendering

- ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

  **Note:** As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).

- ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.

  **Note:** As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.

- ID 220955 (30318) - Network Rendering doesn't support Realflow particles.
- ID 226336 (25636) - Frame passes are not supported.

- Several - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

  **Note:** As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.

Nodal Shading

- ID 221393 (50642) - Nodal shading does not support UDIMs.
- ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.

Painting/Sculpting

- ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.
### Note:
You can save and reload the image to force the update.

**Particles**

- ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

**Note:** To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

**Preview Render**

- If a high poly mesh is not visible, the Preview baking output will be incorrect.

**Note:** As a workaround, reset Preview to fix the baking.

**Procedurals**

- ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops list.
- ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation tool.

**Note:** As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

- ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.
**Note:** As a workaround, remove the unwanted additional Merge Mesh Sources (regardless of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge Meshes source.

- ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.

**Note:** As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

- ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

**Note:** You can use Preview or RayGL to visualize the variations from rigging.

- ID 388978 - Paving does not work when a Guide curve runs through a paving hole

**References**

- ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

**Note:** As a workaround, limit scenes with shading to one level of reference.

- ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to crash.
- ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.

**Note:** As a workaround, first close and reopen the scene before attempting to revert the reference.
Rigging

• ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.
• ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.
• ID 483457 - Disabling or hiding connections using the H keyboard shortcut causes the stack order to behave erratically.

Scripting

• ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

Note: As a workaround, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

Shader Tree

• ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

Note: To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer’s Properties tab.

• ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.
• ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.

Unreal and Unity Materials

• ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.
• ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.
• ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced viewport when used with bump maps and shadows.
UI

- ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.
- ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.
- ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some Mac OS/AMD configurations.

**Note:** As a workaround, upgrade Mac OS to 10.13.

- ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

**Note:** This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

- ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn’t work.

**Note:** If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

- ID 288714 (43162) (Windows only) - Setting a custom text size affects Modo’s text drawing.

**Note:** As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

- ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

**Note:** As a workaround, click the alt key.

- ID 388937 - macOS only: UI form field highlights can appear grey.
- ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn’t resize back the popover correctly
Viewports

• ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

> **Note:** As a workaround, enable and then disable the visibility of the Shader Tree textures.

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.
• ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

> **Note:** As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.

• Windows only: Using Raptr can cause GL driver crashes in Modo.
• ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

> **Note:** As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

• ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver and should be fixed by AMD in a future driver release.
• ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.
• ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.

> **Note:** To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

• ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

> **Note:** As a workaround, use Preview.
• ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

**VR**

• ID 218386 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.
Release Notes for Modo15.1v1

Release Date

22 July 2021

System Requirements

Officially Supported Operating Systems

• macOS 10.14.x, 10.15.x, and 11.x

Note: Testing on Apple Silicon (M1) processors is in progress and this statement will be updated when completed.

• Windows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7.6+)

Minimum Hardware Requirements

• Intel processor(s), Core i3 or higher
• 10 GB available hard disk space (for a full Modo and content installation)
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of GPU memory and drivers that support OpenGL 3.2 or higher.
• AMD AI Denoiser requires a minimum of 4 GB of GPU memory.
Recommended System Requirements

**Note:** This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 4+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions

- NVIDIA: 461.09 or later
- AMD: 8.982.8.1 or later

**Note:** We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 15.1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

**Note:** Hardware marked with * (asterisk) was unavailable for QA testing for Modo 15.1 because of office access limitations due to COVID-19, but has been used to test previous releases.
If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

<table>
<thead>
<tr>
<th>Tested Workstation Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apple</td>
</tr>
<tr>
<td>• Macbook Pro (Retina, 16-inch, 2019)</td>
</tr>
<tr>
<td>• Macbook Pro (Retina, 15-inch, 2018)</td>
</tr>
<tr>
<td>• Macbook Pro (Retina, 15-inch, 2017)</td>
</tr>
<tr>
<td>Dell</td>
</tr>
<tr>
<td>• XPS 15 9560</td>
</tr>
<tr>
<td>• Precision 3520</td>
</tr>
<tr>
<td>HP</td>
</tr>
<tr>
<td>• HP Z600*</td>
</tr>
<tr>
<td>• HP Z640*</td>
</tr>
<tr>
<td>• HP Z800</td>
</tr>
<tr>
<td>CPU</td>
</tr>
<tr>
<td>• AMD Ryzen Threadripper*</td>
</tr>
<tr>
<td>• Intel i7-7700k*</td>
</tr>
<tr>
<td>• Intel i7-8700</td>
</tr>
<tr>
<td>• Intel i9-9900k</td>
</tr>
<tr>
<td>• Intel Core i7 10750H</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tested GPU Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMD Prosumer Graphics Cards</td>
</tr>
<tr>
<td>• Radeon Vega RX*</td>
</tr>
<tr>
<td>AMD Enterprise Graphics Cards</td>
</tr>
<tr>
<td>• Radeon Pro 5300M</td>
</tr>
<tr>
<td>• Radeon Pro WX 8200</td>
</tr>
<tr>
<td>• Radeon Pro WX 7100</td>
</tr>
<tr>
<td>• Radeon Pro 560X</td>
</tr>
<tr>
<td>NVIDIA Prosumer Graphics Cards</td>
</tr>
<tr>
<td>• GeForce GTX 1070 Ti (Linux)</td>
</tr>
<tr>
<td>• GeForce 1080*</td>
</tr>
<tr>
<td>• GeForce 2070 Super</td>
</tr>
<tr>
<td>• GeForce 1080*</td>
</tr>
<tr>
<td>• GeForce 2070 Super</td>
</tr>
<tr>
<td>NVIDIA Enterprise Graphics Cards</td>
</tr>
<tr>
<td>• Quadro T1000</td>
</tr>
<tr>
<td>• Quadro M4000*</td>
</tr>
</tbody>
</table>
New Features and Enhancements

User Experience

OmniHaul

One of the greatest strengths of Modo is customization. OmniHaul significantly extends this strength by incorporating gestures to quickly alter properties or channels. Artists can leverage the default settings or define exactly which movements enable the functionality they desire. This is done directly in the UI with easy to understand graphics that appear next to tool properties or channels, creating a consistently in-context experience.

See OmniHaul for more information.

Deferred/Paused Evaluation for MeshOps and Deformers

Procedural Modeling offers tremendous power and flexibility. Some calculations can take a significant amount of time and slow down interaction within a scene. In Modo 15.1, some of these time intensive calculations can be temporarily delayed, allowing for improved interactivity when using tools, modifying channels, or playing an animation.

See Deferring and Pausing Evaluation for more information.

Static Analysis

Sometimes artists need to be able to quickly identify and fix problems in their scene. Static Analysis is a new framework in Modo that will search through a scene to find and fix problems that have been defined in the Static Analysis test. Preset tests are provided while allowing for highly customized tests as well.

See Testing a Scene with Static Analysis for more information.
Direct and Procedural Modeling

Curve Booleans

Curves are an extremely powerful aspect of modeling workflow. Curve Booleans allows curves to be intersected to generate complex shapes and patterns, enabling artists and designers to rapidly create and iterate with curve-based modeling techniques as either direct or procedural modeling operations.

See Curve Booleans for more information.

Curve Winding Aligner MeshOp

Tools like Curve Fill streamline creation of geometry. However, if a curve is inside of another curve, the two curves need to have related directions to fill the shape properly. The Curve Winding Aligner automates this process, ensuring that artists get the result they want without having to troubleshoot a scene.

MeshFusion Edge Weights to Strips

Edge weighting or creasing provides a fast and intuitive modeling workflow. MeshFusion can now leverage edge weights on open ended tube-like meshes to create strips. This provides a slick method to produce reliable, procedural bevels. When combined with procedural tools like Curve Sweep or Extrude it helps produce precise meshes that can easily be altered at any point of the creation process.

See Converting Edge Weights to Strips for more information.

Boolean, Union All

Boolean modeling offers a very intuitive method of creating complex forms. In the past, artists had to add each individual mesh as a separate operation. This significantly slows down the modeling process. The new union all mode lets artists and designers leverage a single mesh layer with overlapping mesh islands in boolean workflows.
Layer selection for the Merge MeshOp

The Merge Mesh MeshOp is an important part of the procedural modeling toolset that passes a mesh from one layer or stack to another. Now artists can choose a layer in a procedural stack to output instead of just the final result of the entire stack. This makes interaction between multiple MeshOp stacks far more flexible and powerful.

Rigging

MeshOp Stack Node

Both node graphs and stack/tree views are great ways to represent item relationships. The new MeshOp Stack Node visualizes the MeshOp order of operations stack within the node-based schematic view. This allows greater visibility to how the MeshOp stack and node graphs interact without having to jump between separate views, while maintaining the inherent advantages of both methods.

Rendering

mPath

mPath is the new physically based, hybrid rendering path tracer. In Modo 15.1 we've extended the QuickCam capabilities to include direct camera rotation enabling the ability to “look around” a scene without orbiting an item. Dispersion has also been added, enabling refractions to be more accurate by allowing the light to be split apart into separate wavelengths or colors. This is a phenomenon frequently seen in nature, further expanding mPaths powerful capabilities.

File Exchange

USD Support for UV tiling and Real World Size

USD continues to be upgraded with support for UV tiling and Real World Size values. USD is an excellent exchange format that is useful in a variety of industries. These additions further cement our commitment to USD and customers who rely on it.
Enhancements

TuneUps

Orient to selection has been added to the dimension tool, improving how designers assess the dimensions of the items they create. This has also been added to the Absolute Scale tool providing thought-free interaction. Finally, Replicators can be frozen through the right click menu in the Item list.

Miscellaneous

- ID 474887 - The switching between source meshes while in component mode functionality using MMB click has been reverted to the legacy behavior.
- ID 477381 - Edge Weights to Strips now supports Sharp Bezier Corners.
- ID 478419 - Fusion Item groups in the Shader Tree are now placed under the base shader and display matcaps correctly in the viewport.
- The default Physical Sun date has been updated to June 21, 2021.
- SDK: The CLxCommandQuery has been extended so that artists can retrieve the stored value directly.

Fixes

Customization

- ID 473299 - Certain configuration files did not support UTF-8 encoding, which caused problems in localized versions of Modo.
- ID 474997 - Certain custom plug-ins did not work with Modo 15, causing the application to crash.

File I/O

- ID 450116 (60829) - SketchFab .usdz files occasionally imported tex_base as Stencil instead of Diffuse Color.
- ID 462509 - USD: The texCoord2f and float2 functions were not handled in the same way on import.
- ID 466604 (61104) - USD: Exporting .usd files produced normals errors.
- ID 467058 - FBX: Certain scenes containing .fbx files did not export as expected.
• ID 470674 - USD: Certain .usda files did not import as expected.
• ID 471814 - USD: Round-tripping .usd files discarded displacement texture effects in the Shader Tree.
• ID 471816 - USD: Disabled Luminous Color items were still exported as the default 1.0 1.0 1.0 value.
• ID 471970 - Modo occasionally failed to load .svg files from InkScape.
• ID 472511 - USD: Textures and locators with the same name did not export correctly.
• ID 472896 - The PBR Loader did not automatically select new items as expected.
• ID 478664 - FBX: Exporting scenes with .fbx MeshOp components produced skeletal meshes.
• ID 480585 - USD: Procedural meshes had to be frozen to export correctly.
• ID 482798 - USD: Exporting a certain scene to .usd caused Modo to crash.

General

• ID 476740 - System names in the Save Logs menu for the Event Log were not sorted alphanumerically.
• ID 477264 - Solidworks: Modo crashed on shutdown in the log system.
• ID 480680 - Closing the render window in -nowin mode caused the Photoview to become unresponsive.
• ID 481580 - Photoview crashed at the end of a render if it was also running a preview.

MeshFusion

• ID 446802 (60727) - Channel Haul remained active after exiting Edit Attribute mode.
• ID 466721 - Sharp points near creased surface intersections resulted in seam bulges.
• ID 470804 - Moving frame geometry in Item Mode incorrectly offset the Fusion surface.
• ID 474427 (61281) - New Mesh Items were automatically parented to Fusion Items in Select Source mode.
• ID 475244 (61316): Selecting a Fusion Item with Select Source enabled did not always work as expected.
• ID 476247 (61318) - MeshFusion Accurate Edge Weighting did not work as expected.
• ID 476663 - Surface: The Place and Place and Align tools did not work as expected.
• ID 477040 - Creased meshes with Edge Weighting applied still appeared smooth.
• ID 477294 - The Duplicate and Convert to Mesh tool caused Modo to become unresponsive.
Release Notes for Modo 15.1v1 | Fixes

Modeling

• ID 400786 (59864) - The soft selection falloff **use connectivity** option did not always work as expected.
• ID 466918 (61128) - Linear Falloff did not work with Symmetry when it was aligned with a Symmetry Axis.
• ID 467315 - Selecting a mesh paint preset caused Modo to crash.
• ID 469081 - ER: There was no information displayed to artists when subdivision wasn't able to reconstruct to the level requested.
• ID 469085 - Edge Chamfer occasionally created broken polygons.
• ID 469489 - Reactivating the Radial Align tool occasionally produced numerical inaccuracies.
• ID 470501 - Splitting polygons in a certain scene caused Modo to crash.
• ID 470871 (61207) - Holding **Ctrl/Cmd** did not constrain movement when dragging action centers.
• ID 471166 (61213) - Vertex Join did not work as expected with Symmetry.
• ID 471909 (61224) - Vertex Merge incorrectly opened closed curves.
• ID 472943 - Windows only: Undoing linear falloff steps caused Modo to crash.
• ID 472957 (61243) - Unbevel occasionally caused Modo to crash.
• ID 472960 (61244) - Using Edge Relax on a polyline did not match the results from edges.
• ID 474184 - Using middle-mouse button lasso selection in certain scenes caused Modo to crash.
• ID 474401 (61279) - Edge Chamfer could not handle certain edge cases.
• ID 474426 (61280) - Edge Chamfer/Bevel Mitering was incorrect when **Mode** was set to **Width**.
• ID 474457 (61286) - Setting **Shape** to **Square** in the Edge Chamfer tool caused Modo to crash.
• ID 474464 - Only one pre-transform could be added from the **Add** menu.
• ID 476935 - Loop Slice did not work as expected in certain situations.
• ID 479159 (61393) The Edge Relax Convergence tool produced unreliable HardEdge data.

Preset Browser

• ID 471168 (61215) - Ratings were not displayed in the **Star Rating** column.

Presets

• ID 470660 - Copying **Material Presets** from one scene to another discarded Schematic settings.

Preview

• ID 474721 - Adjusting the **Spread Angle** in a live Preview caused Modo to crash.
**Procedural Modeling**

- ID 409817 (60048) - Viewing component selections on a MeshOp disabled the **Dimensions** overlay.
- ID 470535 - FBX: Procedural mesh items could not be exported unless they were frozen.
- ID 471936 (61226) - Overlapping booleans failed unless a **Triangulate** MeshOp was added.
- ID 471952 (61228) - Freezing complex splines caused Modo to crash.
- ID 472346 (61226) - Disabling an input node in a certain scene caused Modo to crash.
- ID 472972 (61248) - Using Axis Drill to convert polylines into geometry faces did not work as expected.
- ID 473214 - Mesh constraints did not always constrain curves correctly.
- ID 475859 (61309) - Adding an Unsubdivide MeshOp occasionally caused Modo to crash.
- ID 476246 (61317) - Editing a MeshOp in the middle of certain MeshOp stacks containing multiple ops caused Modo to crash.

**Rendering**

- ID 287481 (20953) - Including and excluding lights from certain surfaces caused performance issues.
- ID 401958 - Path Tracer: Dispersion was not working as expected.
- ID 477271 - Progressive denoising results were obscured by new render buckets.
- ID 477385 - mPath: Albedo render output contained geometric attenuation artifacts.

**Rigging**

- ID 471185 (61219) - Using Array Blend with float values produced unexpected results.
- ID 472963 (61245) - Enabling **Mesh Parts Mode** in a Mesh Data Array incorrectly sorted numbers alphanumerically.
- ID 473988 - Array numbers were ordered incorrectly in the Script Editor viewport.
- ID 480319 (61412) - Rig Clay regions did not work reliably with setups involving multiple meshes.

**Schematic**

- ID 462133 (60999) - The **Select Backdrop** button in the Schematic viewport did not have a tooltip.

**Scripting**

- ID 477291 - Solidworks: Querying part tags failed for some strings in Modo 15.0 builds.
• ID 481316 (61450) - Calling `channel.copy()` multiple times and then undoing the calls caused Modo to crash.

**SDK**

- User idle executed before `SYSTEM_READY` causing Octane to lock up.

**Shader Tree**

- ID 476869 - The Base color was not displayed or displayed black when SSS radius was set to 0.

**UI**

- ID 463854 (61046) - The **One Tab** Preset was not always listed when multiple UI tabs were selected.
- ID 469241 - Double-clicking a gradient user channel in the Schematic viewport did not open its editor as expected.
- ID 478865 (61351) - Scatter replicas were displayed twice in the Item List right-click menu.
- ID 478977 (61379) - The Edit Workbench buttons did not work as expected.
- ID 479279 - The Animate layout was always fully collapsed, even when empty space was available.

**UVing**

- ID 449580 - UV rotation of Normal Maps altered normal information at render time.
- ID 465346 - Using the `select error uvs` command in the UV tools panel caused Modo to crash.

**Viewports**

- ID 345276 (56644) - ER: The `playblast.run` command did not include an optional flag for automatic playback.
- ID 377973 (59343) - There was no checkbox for the `savealpha:true` command in the playblast settings for image stills.
- ID 386268 - There was no option for camera resolution to override Render output.
- ID 414816 - Playblast settings for frame numbers were limited.
- ID 441739 - Frame number output was not optional.
- ID 445254 (60687) - FR: Exporting a playblast ignored the resolution and frame range if the render camera had a different resolution defined in the **Override Render Resolution** control.
- ID 469273 (61176) - Using the viewport pan button caused UI instability.
- ID 473688 - macOS only: Loading an HDR environment image and then switching to AVP caused Modo to crash.
• ID 473844 (61267) - ER: Some `gl.capture` commands did not have equivalent UI functions.
• ID 481834 (61466) - Enabling viewport textures occasionally caused Modo to crash.

Known Issues

This section covers some known issues and gives workarounds for them, where appropriate.

Animation

• ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

  Note: As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab, then save and reload the scene.

• ID 395357 - Deformer Caching doesn't work.
• ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.

Assemblies

• ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual layout of nodes on import.

  Note: As a workaround, you can save assemblies from the Schematic viewport.

Baking

• ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.
• ID 221481 (49437) - The Bake Channel Swizzling option can’t bake to texture alpha.

Bucket Render

• ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.
• ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.
**Note:** As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

- ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

**Note:** As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

- ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.
- ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.

**Note:** As a workaround, freeze the transforms in the mesh properties.

### Color Management

- ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

**Note:** As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

### Command Line

- ID 289290 (49514) - macOS only: Running modo_cl before running the UI Modo application breaks code signing.

**Note:** As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.
File and Image I/O

• ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This only affects import using the kit, not direct imports (File > Import).

  Note: As a workaround, before importing a SolidWorks file for the second time, exit and restart Modo.

• ID 221508 (50198) - Alembic scenes don’t export some surface items, including static meshes and procedural shatter items.
• ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn’t export instances, unless the original mesh is also exported.

  Note: To resolve this, set the .fbx preference to Export Selection and use Export As....

• ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.
• ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.
• ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.

  Note: As a workaround, use File > Import.

• ID 482247 - Dragging and dropping an image from the OS browser onto a mesh in the 3D viewport causes Modo to crash.

  Note: As a workaround, drag and drop into the Images (Clips) view or load the image into the Shader Tree before dragging it onto the mesh.

Fur

• ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.
Note: Use different fur length drivers, such as hair guides or vector vertex maps.

Input Devices

• ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

Note: As a workaround, change to a 3-button mouse (recommended to fully access all of Modo’s features).

• ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

Note: To avoid this, plug in the tablet before application startup or restart.

MeshFusion

• ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options will be supported.

Modeling

• ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.
• ID 408278 (60027) - Linear Falloff snaps to object size.

Note: As a workaround, use the right mouse button for an interactive initial linear handle.
Network Rendering

- ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

  \[\text{Note: As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).}\]

- ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.

  \[\text{Note: As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.}\]

- ID 220955 (30318) - Network Rendering doesn't support Realflow particles.
- ID 226336 (25636) - Frame passes are not supported.

- Several - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

  \[\text{Note: As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.}\]

Nodal Shading

- ID 221393 (50642) - Nodal shading does not support UDIMs.
- ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.

Painting/Sculpting

- ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.
Note: You can save and reload the image to force the update.

Particles

- ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

Note: To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

Preview Render

- If a high poly mesh is not visible, the Preview baking output will be incorrect.

Note: As a workaround, reset Preview to fix the baking.

Procedurals

- ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops list.
- ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation tool.

Note: As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

- ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.
**Note:** As a workaround, remove the unwanted additional Merge Mesh Sources (regardless of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge Meshes source.

- ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.

**Note:** As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

- ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

**Note:** You can use Preview or RayGL to visualize the variations from rigging.

- ID 388978 - Paving does not work when a Guide curve runs through a paving hole

### References

- ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

**Note:** As a workaround, limit scenes with shading to one level of reference.

- ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to crash.
- ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.

**Note:** As a workaround, first close and reopen the scene before attempting to revert the reference.
Rigging

- ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.
- ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.
- ID 483457 - Disabling or hiding connections using the H keyboard shortcut causes the stack order to behave erratically.

Scripting

- ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

Note: As a workaround, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

Shader Tree

- ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

Note: To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer’s Properties tab.

- ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.
- ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.

Unreal and Unity Materials

- ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.
- ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.
- ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced viewport when used with bump maps and shadows.
UI

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.
• ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.
• ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some Mac OS/AMD configurations.

**Note:** As a workaround, upgrade Mac OS to 10.13.

• ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

**Note:** This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

• ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

**Note:** If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

• ID 288714 (43162) (Windows only) - Setting a custom text size affects Modo's text drawing.

**Note:** As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

• ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

**Note:** As a workaround, click the alt key.

• ID 388937 - macOS only: UI form field highlights can appear grey.
• ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn't resize back the popover correctly
**Viewports**

- ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

  **Note:** As a workaround, enable and then disable the visibility of the Shader Tree textures.

- RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.
- ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

  **Note:** As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.

- Windows only: Using Raptr can cause GL driver crashes in Modo.
- ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

  **Note:** As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

- ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver and should be fixed by a AMD in a future driver release.
- ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.
- ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.

  **Note:** To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

- ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

  **Note:** As a workaround, use Preview.
• ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

VR

• ID 218386 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.