Release Notes for Modo15.0v3

Release Date

26 May 2021

**Note:** Modo 15.0v2 was a Japan-only release to accommodate localization of the interface and documentation.

System Requirements

**Officially Supported Operating Systems**

- macOS 10.14.x, 10.15.x, and 11.x

**Note:** Testing on Apple Silicon (M1) processors is in progress and this statement will be updated when completed.

- Windows 10 (64-bit only)
- Linux 64-bit operating system (CentOS/RHEL 7.6+)

**Minimum Hardware Requirements**

- Intel processor(s), Core i3 or higher
- 10 GB available hard disk space (for a full Modo and content installation)
- At least 4 GB RAM
- Display with 1920 x 1080 pixel resolution
- Internet connection for product activation and online videos access
• The **Advanced** viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of GPU memory and drivers that support OpenGL 3.2 or higher.

• AMD AI Denoiser requires a minimum of 4 GB of GPU memory.

**Recommended System Requirements**

**Note:** This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 4+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

**Recommended Graphics Driver Versions**

- NVIDIA: 461.09 or later
- AMD: 8.982.8.1 or later

**Note:** We recommend downloading the latest driver version from the NVIDIA or AMD websites

**Tested Workstation Hardware**

The configurations listed below are those that Foundry have tested with Modo 15.0v1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.
**Note:** Hardware marked with * (asterisk) was unavailable for QA testing for Modo 15.0 because of office access limitations due to COVID-19, but has been used to test previous releases.

If you encounter any issues, please visit the Support Portal at [https://support.foundry.com](https://support.foundry.com).

### Tested Workstation Hardware

| Apple                           | Macbook Pro (Retina, 16-inch, 2019)  
|                                | Macbook Pro (Retina, 15-inch, 2018)  
|                                | Macbook Pro (Retina, 15-inch, 2017)  
| Dell                           | XPS 15 9560  
|                                | Precision 3520  
| HP                             | HP Z600*  
|                                | HP Z640*  
|                                | HP Z800  
| CPU                            | AMD Ryzen Threadripper*  
|                                | Intel i7-7700k*  
|                                | Intel i7-8700  
|                                | Intel i9-9900k  
|                                | Intel Core i7 10750H  

### Tested GPU Hardware

| AMD Prosumer Graphics Cards    | Radeon Vega RX*  
| AMD Enterprise Graphics Cards  | Radeon Pro 5300M  
|                                | Radeon Pro WX 8200  
|                                | Radeon Pro WX 7100  
|                                | Radeon Pro 560X  
| NVIDIA Prosumer Graphics Cards | GeForce GTX 1070 Ti (Linux)  
|                                | GeForce 1080*  

---

**MODO RELEASE NOTES**
Tested GPU Hardware

<table>
<thead>
<tr>
<th>Tested GPU Hardware</th>
<th>NVIDIA Enterprise Graphics Cards</th>
</tr>
</thead>
<tbody>
<tr>
<td>• GeForce 2070 Super</td>
<td>• Quadro T1000</td>
</tr>
<tr>
<td>• GeForce 1080*</td>
<td>• Quadro M4000*</td>
</tr>
<tr>
<td>• GeForce 2070 Super</td>
<td></td>
</tr>
</tbody>
</table>

New Features and Enhancements

- BUG ID 463514 - Windows only: The SolidWorks import plug-in has been updated to support SW 2021.
- BUG ID 472721 - MeshFusion: The viewport presets now include a **Default** option to restore viewport shading to normal.

Bug Fixes

- BUG ID 464945 - mPath: Renders of some glassy materials did not appear as expected.
- BUG ID 466783 - Viewports: A certain project containing normal maps took longer to load than expected.
- BUG ID 467935 (61153) - Viewports: The pre-selection highlight appeared to slow interactions with the viewport.
- BUG ID 469088 - MeshFusion: Making large or multiple edits of the same type caused Strip Previews to behave unexpectedly.
- BUG ID 469723 (61182) - mPath: The alpha from refractive objects caused opaque elements behind the object to render semi-transparent.
- BUG ID 469802 - macOS only: The **In the future** dropdown in the Fusion warning dialog didn't work as expected.
- BUG ID 469938 - UI: Selecting mPath as the renderer incorrectly displayed the **Global Illumination** tab.
- BUG ID 470071 - Rendering: Area light geometry affected shadow catchers incorrectly.
- BUG ID 470484 - Licensing: The first **Licensing** dialog page always displayed **No License found**.
- BUG ID 470485 - Licensing: The **Licensing** dialog did not always auto-detect languages appropriately.
- BUG ID 470662 - MeshFusion: Opening Fusion files across different operating systems displayed the **Missing Image** dialog unexpectedly.
• BUG ID 470684 - macOS only: Copying and pasting Japanese text did not work as expected.
• BUG ID 471167 (61214) - File I/O: Selecting 3D View as Image Source as a thumbnail caused Modo to crash.
• BUG ID 471170 (61217) - Preset Browser: Right-clicking and selecting Edit Markup and then switching to the Shared tab and selecting Favorites caused Modo to crash.
• BUG ID 471415 - Modo crashed on start-up under certain conditions.
• BUG ID 471742 (61223) - Canceling a Scene Cleanup and then closing the application caused Modo to crash on exit.
• BUG ID 471989 (61229) - UI: Browsing through filter lists using the arrow keys and then applying the selection using the Enter key did not work as expected.
• BUG ID 472161 - macOS only: Switching to the Advanced Viewport occasionally redrew text and UI elements incorrectly.
• BUG ID 472223 (61230) - Modeling: The Loop Slice and Slice Selected tools did not work as expected across triangles.
• BUG ID 472499 - mPath: The Refractive Index from the Specular Amount control produced incorrect results.
• BUG ID 472521 - Mesh Ops: Evaluating a certain procedural stack caused Modo to crash.
• BUG ID 472869 - mPath: Setting Final Color > Contours caused Modo to crash.
• BUG ID 473028 - Mesh Ops: The Intersecting Edges > Select by Previous option was missing in certain scenes from earlier versions of Modo.
• BUG ID 473144 - Command-line: Certain scene files created in earlier versions of the application caused Modo 15_CL to crash.
• BUG ID 473418 - UI: Certain custom configuration files did not load correctly.
• BUG ID 473419 - MeshFusion: Select Source for surface strips did not work as expected.
• BUG ID 473593 - macOS only: Saving .lxo files to the Desktop caused missing image errors.
• BUG ID 473706 (61262) - Preset Browser: Pinning the browser and then using the search function caused Modo to crash.
• BUG ID 473991 - MeshFusion: Overlapping meshes occasionally caused Modo to crash on exit.
• BUG ID 474175 - Windows only: The Licensing dialog was incorrectly displayed in Photoview 360.
• BUG ID 474435 - UI: Certain pop-up dialogs did not auto-focus on the search filter as expected.
• BUG ID 475020 - Windows only: Connecting Photoview 360 to Solidworks caused the application to become unresponsive.
• BUG ID 475234 - Windows only: Some 15.0 Solidworks libraries were missing version signature .pyc files.
• BUG ID 475247 - Windows only: The 15.0 gnz* libraries, such as gnzmodel.dll, listed old version numbers.
• BUG ID 475646 - macOS only: Python 3 files were not compiled as expected.
Known Issues

This section covers some known issues and gives workarounds for them, where appropriate.

Animation

- ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

  Note: As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab, then save and reload the scene.

- ID 395357 - Deformer Caching doesn't work.

- ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.

Assemblies

- ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual layout of nodes on import.

  Note: As a workaround, you can save assemblies from the Schematic viewport.

Baking

- ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.

- ID 221481 (49437) - The Bake Channel Swizzling option can’t bake to texture alpha.

Bucket Render

- ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.

- ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.
**Note:** As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

- ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

**Note:** As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

- ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.
- ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.

**Note:** As a workaround, freeze the transforms in the mesh properties.

### Color Management

- ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

**Note:** As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

### Command Line

- ID 289290 (49514) - macOS only: Running modo_cl before running the UI Modo application breaks code signing.

**Note:** As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.
File and Image I/O

• ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct imports (File > Import).

  **Note:** As a workaround, before importing a SolidWorks file for the second time, exit and restart Modo.

• ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes and procedural shatter items.

• ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't export instances, unless the original mesh is also exported.

  **Note:** To resolve this, set the .fbx preference to Export Selection and use Export As.….

• ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.

• ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.

• ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.

  **Note:** As a workaround, use File > Import.

Fur

• ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.

  **Note:** Use different fur length drivers, such as hair guides or vector vertex maps.
Input Devices

• ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

   **Note:** As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).

• ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

   **Note:** To avoid this, plug in the tablet before application startup or restart.

MeshFusion

• ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options will be supported.

Modeling

• ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

• ID 408278 (60027) - Linear Falloff snaps to object size.

   **Note:** As a workaround, use the right mouse button for an interactive initial linear handle.
Network Rendering

- ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

  **Note:** As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).

- ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.

  **Note:** As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.

- ID 220955 (30318) - Network Rendering doesn't support Realflow particles.

- ID 226336 (25636) - Frame passes are not supported.

  - Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

    **Note:** As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.

Nodal Shading

- ID 221393 (50642) - Nodal shading does not support UDIMs.

- ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.
Painting/Sculpting

• ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.

  Note: You can save and reload the image to force the update.

Particles

• ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

  Note: To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

Preview Render

• If a high poly mesh is not visible, the Preview baking output will be incorrect.

  Note: As a workaround, reset Preview to fix the baking.

Procedurals

• ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops list.

• ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation tool.

  Note: As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.
• ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.

**Note:** As a workaround, remove the unwanted additional Merge Mesh Sources (regardless of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge Meshes source.

• ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.

**Note:** As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

• ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

**Note:** You can use Preview or RayGL to visualize the variations from rigging.

• ID 388978 - Paving does not work when a Guide curve runs through a paving hole

References

• ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

**Note:** As a workaround, limit scenes with shading to one level of reference.

• ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to crash.

• ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.
Note: As a workaround, first close and reopen the scene before attempting to revert the reference.

Rigging

• ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.

• ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

Scripting

• ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

Note: As a workaround, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

Shader Tree

• ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

Note: To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer's Properties tab.

• ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.

• ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.

Unreal and Unity Materials

• ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

• ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.
• ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced viewport when used with bump maps and shadows.

**UI**

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

• ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some Mac OS/AMD configurations.

Note: As a workaround, upgrade Mac OS to 10.13.

• ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

Note: This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

• ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

Note: If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

• ID 288714 (43162) (Windows only) - Setting a custom text size affects Modo's text drawing.

Note: As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

• ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

Note: As a workaround, click the alt key.

• ID 388937 - macOS only: UI form field highlights can appear grey.
• ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn’t resize back the popover correctly

**Viewports**

• ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

> **Note:** As a workaround, enable and then disable the visibility of the Shader Tree textures.

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.

• ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

> **Note:** As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.

• Windows only: Using Raptr can cause GL driver crashes in Modo.

• ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

> **Note:** As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

• ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver bug and should be fixed by AMD in a future driver release.

• ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.

• ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.
**Note:** To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

- ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

**Note:** As a workaround, use Preview.

- ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

**VR**

- ID 218386 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.
Release Notes for Modo15.0v1

Release Date
18 March 2021

System Requirements

Officially Supported Operating Systems
• macOS 10.14.x, 10.15.x, and 11.x

Note: Testing on Apple Silicon (M1) processors is in progress and this statement will be updated when completed.

• Windows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7.6+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher
• 10 GB available hard disk space (for a full Modo and content installation)
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of GPU memory and drivers that support OpenGL 3.2 or higher.
• AMD AI Denoiser requires a minimum of 4 GB of GPU memory.
Recommended System Requirements

**Note:** This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 4+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions

- NVIDIA: 461.09 or later
- AMD: 8.982.8.1 or later

**Note:** We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 15.0v1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

**Note:** Hardware marked with * (asterisk) was unavailable for QA testing for Modo 15.0 because of office access limitations due to COVID-19, but has been used to test previous releases.

If you encounter any issues, please visit the Support Portal at [https://support.foundry.com](https://support.foundry.com).
## Tested Workstation Hardware

<table>
<thead>
<tr>
<th>Brand</th>
<th>Models</th>
</tr>
</thead>
</table>
| Apple | • Macbook Pro (Retina, 16-inch, 2019)  
       | • Macbook Pro (Retina, 15-inch, 2018)  
       | • Macbook Pro (Retina, 15-inch, 2017)  |
| Dell  | • XPS 15 9560           
       | • Precision 3520        |
| HP    | • HP Z600*              
       | • HP Z640*              
       | • HP Z800               |
| CPU   | • AMD Ryzen Threadripper*  
       | • Intel i7-7700k*        
       | • Intel i7-8700          
       | • Intel i9-9900k         
       | • Intel Core i7 10750H   |

## Tested GPU Hardware

<table>
<thead>
<tr>
<th>Graphics Cards</th>
<th>Models</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMD Prosumer Graphics Cards</td>
<td>• Radeon Vega RX*</td>
</tr>
</tbody>
</table>
| AMD Enterprise Graphics Cards       | • Radeon Pro 5300M              
       | • Radeon Pro WX 8200            
       | • Radeon Pro WX 7100            
       | • Radeon Pro 560X               |
| NVIDIA Prosumer Graphics Cards      | • GeForce GTX 1070 Ti (Linux)    
       | • GeForce 1080*                 
       | • GeForce 2070 Super            
       | • GeForce 1080*                 
       | • GeForce 2070 Super            |
| NVIDIA Enterprise Graphics Cards    | • Quadro T1000                   
       | • Quadro M4000*                 |
New Features and Enhancements

MeshFusion

MeshFusion has received a major revamp in Modo 15.0, with the UI being simplified and an emphasis being placed on a viewport-centric workflow for editing models. The inclusion of new selection modes such as Auto-Select, Source Select and Edit Attributes also now allows users to directly interact with their models, making it easier than ever to just click on a patch or source mesh to edit Surface Strips and Skirts. MeshFusion's UI has also had a major overhaul, with windows and menus being simplified and compacted, making navigation easy and quicker than ever before.

Select Source Mode

Select source is a new mode in Modo 15.0, that allows you to select your source meshes in the viewport, instead of from the items list. Multiple source meshes can be selected and edited at the same time, making it easier and quicker to use MeshFusion than before.

Edit Attribute Mode

Edit Attribute is another new mode in Modo 15.0 that helps to make usability a breeze. Edit Attribute allows you to isolate and edit single strips, patches and corners, making detailed edits and detailing a much simpler task.

Edge Weighting and Zero SubDivision

MeshFusion also now supports truly accurate Edge Weighting. When used in conjunction with MeshFusion's zero subdivision functionality, this allows for traditional cage-mesh boolean operations without subdivision surfaces while also allowing you to take full advantage of MeshFusion's powerful tools such as Fusion Strips and Patches.

See MeshFusion more information.
Direct Modeling

Chamfer Edit Enhancements

The Chamfer Edit tool has been updated to allow the editing of rounded bevels. By ensuring that source segments are set to the same segment amount used, you are now able to change the offset, segment amount and curvature of a beveled edge with ease, making editing complex models a smoother and speedier process.

See Edge Chamfer for more information.

Cage Mode

Modo 15.0 now allows you to enable cage mode by setting the subdivision level of a mesh to zero. This UX change cuts down on the amount of mouse clicks needed before a tool is ready to use and in turns allows your workflow to become more streamlined and efficient.

UnSubdivide

UnSubdivide is a brand new modeling tool in Modo 15.0 that allows you to reconstruct subdivisions in reverse and output a low density mesh. Perfect for creating low poly meshes for baking and optimization, this tool is available as a traditional tool in the modeling tool box, or as a procedural tool in the Mesh operation window.

See UnSubdivide for more information.

Procedural Modeling

Create Vertex MeshOp

This simple operator creates a single vertex and can be positioned in your scene by inputting coordinates in the X, Y and Z parameters.

Offset Curve by Mesh

Bezier, B-Spline and Polyline curves are now supported by the Offset Curve by Mesh operator.
Procedural Loop Slice

Loop Slice has now been added as a procedural tool, allowing you to create evenly spaced edge loops by a specific count number. Additional parameters such as Preserve Curvature and Split have also been included in the procedural version of this tool, to allow for in depth and advanced editing while using a procedural workflow.

Animation & Rigging

Animation Editor

The animation workspace this release has also had a major overhaul. The lower collapsible Graph Editor viewport layout has been replaced with a new layout that contains the Graph Editor and Dopesheet along with a Channels viewport, allowing for quick and easy navigation that is both beginner and seasoned professional friendly.

See Graph Editor for more information.

Command Regions and Rig Clay Enhancements

This powerful tool allows you to do away with the clutter of controllers on a rigged mesh, and is now supported in the 2D model view; adding more flexibility to the types and complexity of rigs that you can create.

This tool has also had its procedural workflow updated, with Mesh Operation nodes having been added for Polygon, Edge and Vertex Command Regions.

See Command Regions for more information.

Rendering and Shading

Interactive mPath Renders

Modo's mPath renderer has an interactive mode, which allows you to pan, zoom, and rotate the camera in the Render viewport without adjusting the camera in the scene.

See Rendering with mPath for more information.
Viewport

AVP Depth of Field

This new addition to the advanced viewport now allows users to refine camera settings within the 3D viewport properties window, without the need to fire off a render. This powerful new tool is supremely useful for setting up renders or laying out scenes in a higher detail without the hassle of waiting for a test render.

Workflow and User Experience

Licensing Modo

How Foundry products are activated has also had an update, with the introduction of Cloud based licensing in addition to our traditional RLM licensing, making it easier than ever before to activate and manage your products. The activation window has also had a total revamp, making it easier to log into your Foundry account, select products to activate and see the expiry dates of your licenses.

FBX Loader

Modo's FBX importer has been updated to show import progress through sub-monitors. This gives you the ability to view what part of the FBX file is being imported, allowing for a more granular view of the loader.

Quick Command Buttons

The Quick Commands buttons have now been split up, and now sit above their relevant panels instead of being grouped together. This makes the UI easier to navigate, making their respective functions quicker and easier to use.

Python 3 Support

Modo 15.0 also now supports Python 3 as well as Python 2. This can be easily changed in the system dropdown menu, and it's easy to now switch between the two.
Note: Switching to use Python 3 may result in unexpected behavior with older scripts and plug-ins.

SDK Docs update

The Developer wiki has also been updated and is now available here.

Bug Fixes

- BUG ID 294792 (55514) - Performance: Boolean Op with numerous mesh islands did not perform as well as expected.
- BUG ID 301168 (44364) - Modeling: SDS edge weight with falloff created unusable results.
- BUG ID 371560 - Viewports: The wireframe overlay on a selected mesh gradually decreased in opacity when using a Dissolve Constant layer.
- BUG ID 384564 (59506) - Procedurals: Poly Bevel OP thicken created two identical normal direction polygons in a certain scene.
- BUG ID 395893 - Procedurals: Select by Previous Operations with Boolean selected spurious polygons.
- BUG ID 397870 - Modeling: Activating intersection snapping in a certain scene caused Modo to crash.
- BUG ID 404224 (59912) - Render Window: Any event that causes the render window image to redraw did not redraw as expected.
- BUG ID 419234 (60159) - UI: Mesh Subdivision Level refresh did not happen automatically with Mesh Ops.
- BUG ID 424396 (60264) - Modeling: Curve Slice creating extra vertices incorrectly.
- BUG ID 426334 (60311) - Shading: Rendering Tension Textures occasionally caused Modo to crash.
- BUG ID 434280 - Modeling: Using the Join Averaged tool with Symmetry enabled caused Modo to crash.
- BUG ID 437774 (60564) - Shader Tree: The Select Polygons by Material tag name was missing.
- BUG ID 438749 (60595) - UI: The tooltip for the Preview button was generic.
- BUG ID 441529 (60626) - UI: The Item list was occasionally reordered and became disorganized.
- BUG ID 442823 - Schematic: Comment nodes added additional steps to the undo stack.
- BUG ID 443133 - mPath: Shadow Catcher did not catch contact shadows during renders.
- BUG ID 443327 (60637): Render Window - Large image aspect ratio discrepancies caused the Output chooser popup to fail.
• BUG ID 444583/445506 (60657/60697) - UI: The F2, F3, and F4 keyboard shortcuts displayed out of date toolbars.
• BUG ID 445016 (60667) - mPath: Buckets rendered incorrectly in certain scenes.
• BUG ID 445746 - Rendering: Specular values appeared to render incorrectly when using the Principled material.
• BUG ID 446645 (60725) - Modeling: Enabling symmetry occasionally caused vertex join error.
• BUG ID 446905 (60732) - Rigging: The Pose Tool (Shift+click and drag) did not work as expected.
• BUG ID 447627 (60746) - Procedurals: Performing a boolean operation with multiple overlapping mesh islands as cutters did not work as expected.
• BUG ID 447673 (60749) - Procedurals: Pressing Shift+A to autofit selected did not work as expected with Mesh Ops selected.
• BUG ID 449582 (60779) - UI: There was no way to ignore the form presets flag for commands and subforms.
• BUG ID 449584 (60780) - UI: Saving a form preset from the render item > frame vtab displayed an event log error.
• BUG ID 449943 (60809) - UI: Chamfer Edit was missing from the to Polygon Tools section of relevant toolboxes.
• BUG ID 453135 (60854) - UI: Forms were filtered incorrectly when a selection op and mesh were selected at the same time.
• BUG ID 465253 (61069) - Modeling: Pen Extrude did not work as expected on a path consisting of a single edge.
• BUG ID 453440 - Rigging: Rig Clay did not work with curves.
• BUG ID 453692 (60861) - File I/O: Loading certain tiled .exr files caused Modo to crash.
• BUG ID 453998 (60863) - UI: Clicking Preset buttons did not display a popup menu as expected.
• BUG ID 454888 (60874) - UI: Form presets on the mesh assembly vtab utility divider did not work as expected.
• BUG ID 454889 (60875) - UI: Form presets on the mesh assembly vtab drop scripts divider did not work as expected.
• BUG ID 454895 (60878) - UI: Form presets from the 3D viewport Properties popover dividers did not work as expected.
• BUG ID 454896 (60879) - UI: Loading form presets did not always refresh the form.
• BUG ID 454897 (60880) - UI: The form preset saver did not work as expected with multiple tabs selected.
• BUG ID 455094 (60882) - Rigging: Rig Clay Command Regions did not work as expected in the 2D view.
• BUG ID 455150 (60883) - Particles: Normal Map did not work as expected with texture particle generators.
• BUG ID 456477 (60896) - mPath: Area lights were rendered as double-sided in the render preview.
• BUG ID 457420 (60900) - UI: Form presets did not store values with more than four decimal places.
• BUG ID 457421 (60901) - UI: Form presets saved the indent rather than the string used in the form command.
• BUG ID 457439 (60904) - Modeling: Edge Bevel did not produce UVs as well as Chamfer in certain scenes.
• BUG ID 457694 - macOS only: Clicking a scene in the Items List while Preview was running caused Modo to crash.
• BUG ID 457748 (60909) - Modeling: The Select All (Alt+Shift+A) keyboard shortcut did not work as expected on meshes with no base mesh.
• BUG ID 457851 - UI: Swapping tabs in the Preferences occasionally caused Modo to crash.
• BUG ID 457953 (60914) - Modeling: Edge Chamfer produced incorrect results on sharp corner.
• BUG ID 458038 (60919) - UI: Hovering over the Command History viewport occasionally displayed an error.
• BUG ID 458558 - Rendering: Principled material's sheen value did not conform to Disney BRDF specification.
• BUG ID 463148 (61020) - UI: The all tabs preset popup didn't always display as expected.
• BUG ID 468563 - Rendering: Extreme sheen values exponentially increased render times.
• BUG ID 459383 (60939) - Modeling: Polygon Thicken Both Sides affected unselected geometry.
• BUG ID 459664 (60950) - UI: Deleting multiple selected Parts in the Statistics viewport did not work as expected.
• BUG ID 459682 (60951) - mPath: Light Select calculated the shadows from objects that should be excluded.
• BUG ID 459895 - Modeling: The Shift Tool did not work as expected with Noise Falloff.
• BUG ID 461557 - Modeling: Deleting a vertex from a curve deleted the entire curve.
• BUG ID 461694 - UI: Items incorrectly allowed preceding and trailing white space in item names.
• BUG ID 461696 - Rigging: Channel handles did not have tooltips.
• BUG ID 461765 (60989) - Modeling: Edge Relax Convergence on polylines converged to the wrong position.
• BUG ID 462265 - UV: Hiding and reopening the UV window or swapping layouts displayed UV images incorrectly.
• BUG ID 462678 (61006) - UI: Viewing color picker options occasionally caused Modo to crash.
• BUG ID 463276 (61027) - mPath: Shaders using traditional as the shading model did not render reflections correctly.
• BUG ID 463402 - Dynamics: Selecting a curve created with Edges to Curves and then playing the simulation caused Modo to crash.
• BUG ID 465412 (61080) - Procedurals: Vertex Merges discarded Selection Sets, even if all the vertices using the Selection Set were merged.

• BUG ID 463700 - Modeling: Join Averaged with symmetry enabled did not merge edge loop vertices as expected.

• BUG ID 464433 (61062) - Modeling: The Cube Tool's corner tool handles did not vertex snap consistently.

• BUG ID 464525 (61064) - Modeling: Profiles dragged from the browser were incorrectly assumed to be closed.

• BUG ID 464943 - mPath: Shadow catcher did not work as expected.

• BUG ID 465283 (61071) - Modeling: Pen Extrude used edge selection as the path even if a polyline was selected in polygon mode.

• BUG ID 465262 (61070) - Modeling: Pen Extrude did not work as expected if the path did not point along the Y axis.

• BUG ID 465352 - Modeling: Using Edge Chamfer on a certain edge loop and moving it from min to max value caused Modo to crash.

• BUG ID 465912 (61082) - mPath: Setting a shader alpha channel to constant rendered the alpha opaque instead.

• BUG ID 466005 (59912) - Render Window: Aborting a render displayed thumbnail colors incorrectly in the render window.

• BUG ID 460047 (60970) - Performance: Selecting curve vertices made interaction with the UV editor sluggish.

• BUG ID 466773 - UI: Opening and closing file dialogs occasionally caused Modo to crash.

• BUG ID 466912 (61125) - Preset Browser: Clicking Replace Icon with Last Render caused Modo to crash.

• BUG ID 466923 - Rendering: The default file name output pattern did not include separators between elements such as name and frame number.

• BUG ID 466925 - mPath: Environment lighting caused sharp noise discontinuity depending on object facing.

• BUG ID 467256 - Executing Boolean > Subtract > Specific Surface > Mesh on certain objects caused Modo to crash.

• BUG ID 468166 (61159) - Performance: Item selection was occasionally sluggish.

• Rendering - Saving a Cryptomatte file containing surfaces with no material caused Modo to crash.

• Rendering - Saving a Cryptomatte file with more than 16 render outputs caused Modo to crash.

Fixed: Rendering - Updates AMD denoisers to version 1.6.1
Known Issues

This section covers some known issues and gives workarounds for them, where appropriate.

Animation

• ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

  **Note:** As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab, then save and reload the scene.

• ID 395357 - Deformer Caching doesn’t work.

• ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.

Assemblies

• ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual layout of nodes on import.

  **Note:** As a workaround, you can save assemblies from the Schematic viewport.

Baking

• ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.

• ID 221481 (49437) - The Bake Channel Swizzling option can't bake to texture alpha.

Bucket Render

• ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.

• ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.
**Note:** As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

- ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

**Note:** As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

- ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.

- ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.

**Note:** As a workaround, freeze the transforms in the mesh properties.

### Color Management

- ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

**Note:** As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

### Command Line

- ID 289290 (49514) - macOS only: Running modo_cl before running the UI Modo application breaks code signing.

**Note:** As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.
File and Image I/O

• ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct imports (File > Import).

   Note: As a workaround, before importing a SolidWorks file for the second time, exit and restart Modo.

• ID 221508 (50198) - Alembic scenes don’t export some surface items, including static meshes and procedural shatter items.

• ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn’t export instances, unless the original mesh is also exported.

   Note: To resolve this, set the .fbx preference to Export Selection and use Export As....

• ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.

• ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.

• ID 346842 - Alembic import - Drag/drop doesn’t import animation correctly.

   Note: As a workaround, use File > Import.

Fur

• ID 288248 (35731) - Fur length textures can’t be edited with the Stretch tool.

   Note: Use different fur length drivers, such as hair guides or vector vertex maps.
Input Devices

• ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

  Note: As a workaround, change to a 3-button mouse (recommended to fully access all of Modo’s features).

• ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

  Note: To avoid this, plug in the tablet before application startup or restart.

MeshFusion

• ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options will be supported.

Modeling

• ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

• ID 408278 (60027) - Linear Falloff snaps to object size.

  Note: As a workaround, use the right mouse button for an interactive initial linear handle.
Network Rendering

• ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

  **Note:** As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).

• ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.

  **Note:** As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.

• ID 220955 (30318) - Network Rendering doesn't support Realflow particles.

• ID 226336 (25636) - Frame passes are not supported.

• Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

  **Note:** As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.

Nodal Shading

• ID 221393 (50642) - Nodal shading does not support UDIMs.

• ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.
Painting/Sculpting

• ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.

   **Note:** You can save and reload the image to force the update.

Particles

• ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

   **Note:** To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Reallflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

Preview Render

• If a high poly mesh is not visible, the Preview baking output will be incorrect.

   **Note:** As a workaround, reset Preview to fix the baking.

Procedurals

• ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops list.

• ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation tool.

   **Note:** As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.
• ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.

Note: As a workaround, remove the unwanted additional Merge Mesh Sources (regardless of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge Meshes source.

• ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.

Note: As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

• ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

Note: You can use Preview or RayGL to visualize the variations from rigging.

• ID 388978 - Paving does not work when a Guide curve runs through a paving hole

References

• ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

Note: As a workaround, limit scenes with shading to one level of reference.

• ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to crash.

• ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.
**Note:** As a workaround, first close and reopen the scene before attempting to revert the reference.

**Rigging**

- ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.
- ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

**Scripting**

- ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

**Note:** As a workaround, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

**Shader Tree**

- ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

**Note:** To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer’s Properties tab.

- ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.
- ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.

**Unreal and Unity Materials**

- ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.
- ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.
• ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced viewport when used with bump maps and shadows.

UI

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

• ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some Mac OS/AMD configurations.

Note: As a workaround, upgrade Mac OS to 10.13.

• ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

Note: This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

• ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

Note: If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

• ID 288714 (43162) (Windows only) - Setting a custom text size affects Modo’s text drawing.

Note: As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

• ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

Note: As a workaround, click the alt key.

• ID 388937 - macOS only: UI form field highlights can appear grey.
• ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn’t resize back the popover correctly

**Viewports**

• ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

  **Note:** As a workaround, enable and then disable the visibility of the Shader Tree textures.

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.

• ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

  **Note:** As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.

• Windows only: Using Raptr can cause GL driver crashes in Modo.

• ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

  **Note:** As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

• ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver bug and should be fixed by a AMD in a future driver release.

• ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.

• ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.
Note: To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

- ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

Note: As a workaround, use Preview.

- ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

VR

- ID 218386 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.