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Preface
Mari is a creative texture-painting tool that can handle extremely complex or texture heavy projects. It
was developed at Weta Digital and has been used on films such as The Adventures of Tintin: The
Secret of the Unicorn, District 9, The Day the Earth Stood Still, The Lovely Bones, and Avatar. The
name Mari comes from the Swahili 'Maridadi', meaning 'beautiful' and carrying connotations of
'usefulness'.

About this Guide
This guide provides you with the full details of running and using Mari. You should read the Getting
Started Guide first for installation and basic usage instructions.

The first part of the guide walks you through the various Mari functions. The tutorials provide
comprehensive walk-throughs of all Mari's functions, complete with geometries and associated
textures. As you follow the steps in these tutorials, you'll gain a good feel for Mari's user interface and
workflow. This, in turn, provides a good working knowledge for creating more complex production
projects.

For more detailed information on Mari and its functions, see the accompanying Mari Reference Guide.

Contacting Customer Support
Should questions arise that the documentation fails to address, you can contact Customer Support
directly through the Support Portal at the following address: https://supportportal.thefoundry.co.uk.
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Customizing the View
In the Getting Started Guide, you learned how to control the view in Mari (spinning, panning, rotating,
switching to preset views, and so on). You have a choice of how many of these controls work, and
how Mari displays the model on screen.

Display Options
You can set:

• how the model rotation works - the model movement speed, friction, and whether it uses
momentum (see Appendix A: Shortcuts for model rotation shortcuts).

• the background displayed behind the model - either a color, a gradient, or an image.

• the color for the paintable area (when it displays).

• the quality settings for the display (how much detail to show).

• whether to show the wireframe model, and how to display it.

• in the UV view, whether to show gridlines or labels.

You can also adjust the focus of your canvas by hovering your cursor over the point on the model that
you want to focus on and pressing F. The canvas centers on that part of the model at the current view
size and angle. If the cursor is hovering over the canvas where no part of the model is present,
pressing F instead brings the entire model to focus.

Set theMain View Options
You can set the view options separately for the UV and 3D views.

1. Switch to the view you want to set the view options for.

2. Either:

• right-click on the canvas and select Display Properties from the dropdown menu, or

• from the View menu, select Display Properties.

The Display Properties dialog displays.

17
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3. To turn the onscreen display of the project information (Current Tool, Tool Help, Current Channel,
and so on) off, uncheck the HUD box.

4. Under the Background section, set the window background.

To set the background to... do this...

an image enter the path to the image in the Image field.

Use the button next to the field to open a dialog
to find your image.

a single color set the Bottom and Top fields to the same color.

Click on the fields to set the color.

a gradient between two colors set the Bottom field to the color for the bottom
of the window, and the Top field to the color for
the top of the window.

Click on the fields to set the color.

CUSTOMIZING THE VIEW |
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5. To set the global setting for the canvas Environment light background image, set the Show
Environment checkbox. This control allows you to set the canvas background image from the
environment light independent of the display settings within the light.

6. If you want to display a reference grid in a 3D view, set the details under the Grid section.

The Visible switch turns the onscreen grid on and off, while the other fields let you set the Color
and Size of the grid displayed.

7. To show the wireframes on the model, turn the Visible option on under Wireframe.

You can set the wireframe color in the Color field.

TIP: You can turn the wireframe display on/off using the button on the Canvas toolbar,
or using the keyboard shortcut Shift+W.

TIP: If the WireframeColor has a high alpha value, it may be hard to see onscreen. If you
have the wireframe turned on but cannot see it on your model, check that the
WireframeColor isn't too transparent.

8. If you want to adjust the Camera Mask Opacity, use the entry box or the slider to select a value
between 0 and 1.

9. To select the color that you want shown when selecting Linked Patches, click on the color swatch
to select from the color picker. You can also select the Linked Patch color from within the
Patches palette.

10. Under the Rendering section, you can control which additional parts of the scene display
onscreen:

• Checker Color A - changes color A of the transparency checkerboard to the selected swatch
color.

• Checker Color B - changes color B of the transparency checkerboard to the selected swatch
color.

• Checker Size - changes the individual transparency checkerboard squares to the selected size
using either the entry box or the slider. The default value is set to 10.

• Render Camera - shows the camera view onscreen.

• Render Light - shows the lights as globes on the main canvas.

• Render UV Image - if this is off, the UV view shows the patches as they appear as part of the
model. If this is on, the UV view shows the patches as they appear when exported (that is, as
square images, with overpaint areas around the corners of the patches).

TIP: You can also turn Render UV Image on/off using the button on the Canvas
toolbar.

CUSTOMIZING THE VIEW |
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11. If you're setting properties for the UV view, under the UV Label section, set the details for the text
labels shown over the individual patches:

• Text Color - click the swatch to set the color for the text on the labels.

• Visible - uncheck this to stop showing the text labels in the UV view.

12. If you're setting properties for 3D views, under the Selection section, set the details for
highlighting shown on selected areas:

• Fill Render - when to show the highlighting in the middle of the selected areas. One of:

• Always - Mari shows the highlighting the whole time the area is selected.

• Select - Mari only shows the highlighting while you are actually selecting the area.

• Never - Mari does not show the selection highlighting.

• Fill Color - click the swatch to set the highlight color for the middle of the selected areas.

• Outline Render - when to show the highlighting around the outline of the selected area. You
can set this to Always, Select, or Never, as for Fill Render (above).

• Outline Color - click the swatch to set the highlight color for the middle of the selected areas.

13. Click OK to save your settings.

EXPERIMENT: Try changing...

• the project background to a different color, then a gradient, then an image

• whether wireframes display, and their color, and

• the color of your outline highlights.

Configure the Lighting
Mari comes with three default modes for lighting the model, and optional shadow control:

• Flat - a flat, uniform, directionless light.

• Basic - basic diffuse lighting without specular.

• Full - full lighting with diffuse and specular lighting.

• Shadows - toggles whether shadows are displayed or not.

In Basic and Full modes, you can set basic point lights or an environment light. This lets you control
the intensity and direction of the lighting from different directions relative to the model.

Mari only stores custom light settings as part of the project (they cannot be independently saved to a
file).

Toggling Shadows does not enable or disable shadow processing. It simply controls whether the
shadows are displayed on the canvas. To enable shadow processing, enable Depth Projections in the

CUSTOMIZING THE VIEW | CONFIGURE THE LIGHTING
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Preferences. For more information on shadows, please refer to Shadow Settings in the Working with
Objects chapter.

To configure the lighting:

1. Switch between flat, basic, and full lighting, click the toolbar buttons:

(left to right: flat, basic, full).

2. Toggle the Shadows icon in the toolbar:

• (shadows off)

• (shadows on)

NOTE: If the Depth Projections option is turned off in the Preferences, the Shadows icon
cannot be toggled and is turned off in the Lighting toolbar.

3. To set individual lighting directions, make sure you're in full lighting mode. If it's not already
visible, open the Lights palette by clicking View > Palettes > Lights:

The top half displays the lights available, and the bottom shows the details of the selected light.
The lights currently in use have a “lit bulb” icon.

TIP: Mari has four basic point lights and an environment light. You cannot add or delete
these lights. If you don't want a particular light, turn it off.

CUSTOMIZING THE VIEW | CONFIGURE THE LIGHTING
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4. To turn individual lights on and off, click on the light bulb icon next to the light or de-select the
On checkbox under Light > General.

The basic lights work a little differently to the environment light in the Lights palette. To configure the
basic lights, follow the steps below:

1. To change a light, first select it. In the bottom half of the palette, set the light's:

• Color - you can set separate values for the Specular (shiny highlights) of the light and Diffuse
(the color the light shines on surfaces), and change the Intensity value for the light.

• Fixed To location - whether the camera is fixed relative to the Scene or the Camera.

This... means... Example

Scene The light always shines on the same
part of the model, no matter how you
move the view.

If you only have one light on, pointing at
the left side of the model, the right side is
always in darkness, no matter how you
move the view.

Camera The light always shines from the same
direction relative to the camera view.
This means that it illuminates different
parts of the model depending on how
the model appears in the camera.

If you only have one light on, pointing
from the left of the camera, it illuminates
whatever part of the model(s) is visible on
the left side of the current view.

2. To move a light around, either:

Select... then...

The Transform selected object tool click on the light and drag it
around the canvas, or use the
transform handles to adjust it.

The sphere control in the Lights palette click and pull the sphere
around to move the light.

The Move to Camera Position icon the light is repositioned to your
current camera position.

CUSTOMIZING THE VIEW | CONFIGURE THE LIGHTING
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You may need to zoom out from your object in order to see the lights.

NOTE: The Move to Camera Position icon can be used in both perspective and
orthographic view;
however, be aware that this feature does not account for zooming of the camera in the
Ortho view.

3. To toggle cast shadows from the selected light, click on the checkbox to toggle shadows on or off.
This does not impact the light itself, but the model casts shadows depending on the light’s
position.

4. More options for shadows and depth projection settings are located in the Preferences under
GPU > Depth Projection. The settings in the Preferences allows you to trade off the quality of
the rendered shadows and the amount of GPU memory and processing required. Increasing the
resources available for shadow rendering decreases the resources available for other operations,
which may decrease Mari’s performance.

TIP: Mari saves the lights with the project. If you need the same lights in another project,
you'll need to set them up separately.

EXPERIMENT: Switch between the different lighting modes. Then try customizing a preset
light. Play with its color settings and orientation. Try using the position sphere to control the
light position. Notice the effects on your display?

The Environment light, on the other hand, uses an image from the Mari Environment library, the
Image Manager palette, or an imported image file to set environment lighting on the object(s) on the
canvas. To configure the Environment light, follow the steps below:

1. Specify a texture to use for the environment. You can either:

• select an image from the Mari Environment library by clicking the blank image space under
Environment > Texture > Image

• click either of the arrow keys under Environment > Texture > Image,

• select an image in the Open an Image dialog by clicking the load icon under Environment
> Texture > Image,

• drag an image from the Image Manager to the blank image space under Environment >
Texture > Image, or

• drag an image from a system file manager to the blank image space under Environment >
Texture > Image.

2. To adjust the Environment light, set the light's:

• Color - you can set the Intensity value for the light.

• Fixed To location - whether the camera is fixed relative to the Scene or the Camera.

CUSTOMIZING THE VIEW | CONFIGURE THE LIGHTING
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This... means... Example

Scene The light always shines on the same
part of the model, no matter how you
move the view.

If you have an environment image that is
bright on one side, that side of the model
is brightly lit and the other side is dark, no
matter how you move the view.

Camera The light always shines from the same
direction relative to the camera view.
This means that it illuminates different
parts of the model depending on how
the model appears in the camera.

If you have an environment image that is
bright on one side, whatever part of the
model visible on that side in the current
view is illuminated.

• Resolution - this adjusts the resolution of the light to be either 64, 128, or 256. This only applies
to the light and not the background (canvas) image.

3. To move a light around, set the Up Axis to Axis X, Axis Y, or Axis Z, to adjust which part of the
environment image is interpreted as up. This adjusts the background (canvas) image as well. This
is especially useful if the environment image is read into Mari wrong-side up and you want to
adjust the direction of the environment lighting.

4. To specify whether you want the environment light image to show on the canvas click on the
dropdown menu under Environment > Texture > Background and select Show or Hide.

5. To set how the background (canvas) image appears, adjust the following under Environment >
Texture:

• Rotation - rotates the image on a 360 degree scale so that you can adjust how the background
image appears on the canvas against the object(s).

• Cubemap Type - choose from None, LatLong, or Cross to set how 2D image is converted to 3D.
Mari attempts to automatically interpret the Cubemap Type but if the image is a .dds, it isn't
necessary to set this option.

NOTE: When exporting .dds files, they should be encoded as 8.8.8.8 ARGB files to avoid any
complications when bringing them into Mari.

• the Blur - this adjust how much the background (canvas) image is blurred, if at all. For low
resolution textures, the blur may not appear as smoothly as you might like. Try using a higher
resolution texture to improve this.

6. To set the texture animation for the background (canvas) image, adjust the following under
Environment > Texture Animation:

• Animation - whether the background (canvas) image is Static or can Rotate.

• Speed - sets the speed of the animation rotation of the background (canvas) image.
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NOTE: If the Background is set to Hide, or the Speed is set to 0.000, it doesn't matter if the
Animation is set to Rotate, it won't appear to be moving. Ensure that both of these controls
are set correctly in order to see texture animation.

Set the Perspective Camera Details
For the perspective you can set the near and far clipping planes. Anything closer than the near
clipping plane or farther than the far plane is not displayed.

You can also set the field of view. This controls the amount of distortion applied to generate the
perspective.

Field of view set to 20 Field of view set to 120

TIP: You can also have black bars appear in the Canvas to indicate the aspect ratio of the
perspective
camera. Select View > DisplayProperties and set Camera Mask Opacity to anything other
than 0.

To set the perspective camera details:

1. Click on the Perspective tab to switch to the perspective camera.

2. If it's not already visible, open the Canvas toolbar.

To open the toolbar, right-click in the toolbars area at the top of the screen and select Canvas
from the dropdown menu.

3. Enter values for the Near and Far clipping planes.

Mari only displays parts of the scene that fall between these two planes. Anything closer than the
Near plane, or further than the Far plane, is not shown.
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4. Set the value for the field of vision in the FoV field. This controls how much Mari distorts the view
when applying perspective. At 0, the perspective camera gives exactly the same view as the Ortho
camera. As the value increases, the distortion increases.

TIP: You can also change view mode by:

• clicking the Ortho , Perspective , and UV buttons, or

• pressing F10, F11, and F12 respectively.

Configure Navigation
The navigation has preferences that allow you to change, among other aspects:

• momentum

• flick speed

• friction

• rolling

• orbiting

See Appendix A: Shortcuts for model rotation shortcuts. To configure navigation settings:

1. Go to Edit > Preferences, and select the Navigation tab.

2. To set the controls, select one of the options below, from the Control Type dropdown menu:

• Houdini

• Lightwave

• Mari

• Maya

• Nuke

These controls allow you to set what type of control options, shortcuts and preferences you want
to use.

3. To manually change how the model movement and navigation works, set the following:

• Momentum Enabled - if this is enabled, the model has momentum, so when you let go of the
mouse button, the model slowly coasts to a stop. If this is off, the model only moves when you
are holding the mouse button down.

• Minimum Flick Speed - the minimum speed at which you can move your model around. The
lower this is set, the more sensitive the movement controls are.

• Friction - affects the momentum of your model as you move it around the canvas. Decreasing
this value allows movement to retain its momentum for longer. Increasing the value arrests
momentum faster.
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• Lock To World Up - if this is enabled, the navigation is locked with the y axis in place so that the
"world up" view cannot be modified.

• Center Mode - a dropdown menu that allows you to select the orbit view center: Look At,
Objects, Origin, or Selection.

• Circular Motion Enabled - if this is enabled, you can roll by making a circular motion around
the center of the canvas. If disabled, rolling is achieved by simply making a horizontal motion
across the canvas.
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Using Shortcuts
To optimize your workflow, you can set up shortcuts for common actions or settings in Mari.

As you'll realize by now, there are usually two or three ways of performing any Mari function. These
include:

• keyboard shortcuts - pressing one or more keys.

• mouse shortcuts (also called “gestures”) - holding a key and moving the mouse in a particular way.

As well as the default shortcuts that come with Mari, you can customize your own keyboard shortcuts
for any Mari function. Plus, for each project, you can create custom shortcuts for the items and sets
within that project or assign multiple shortcuts for the same action.

TIP: You can also change shortcuts through custom configuration files. See the Extending
Mari chapter for details on how to do this.

Some actions can also be canceled once they have been started. To cancel an action, press Escape or
click the x
button on the status bar. Canceling actions is not immediate and depends on the complexity of the
action. Canceling is limited to:

• applying filters

• ambient occlusion

• autosave

• projecting

• from the paint buffer

• through projectors

• turntable rendering

• paint projection.

View the Default Shortcuts and Gestures
The list of shortcuts and mouse gestures is in Appendix A: Shortcuts.
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The appendix is formatted so you can print out the pages and use them as a reference card. All the
default shortcuts in the Manage Keyboard Shortcuts dialog box are listed in the appendix.

For the keyboard shortcuts, a plus sign (+) means to hold down two keys at the same time. For
example, “Ctrl/Cmd+C” means: press Ctrl (for Windows or Linux) or Cmd (for Mac), and keep holding
it down while you then press C.

For the mouse gestures, press and hold down the backslash key (\), while drawing the shape
illustrated, in the direction indicated - from the ball start point (l) to the arrow.

TIP: The shortcuts for the Color Picker and Select tools work differently from the other
tools. By default, the keyboard shortcuts for these tools only switch to the tool while you
hold down the key, and then switch back to the original tool when you release the key. This is
to make it easier to quickly pick a color or select a patch while painting with another tool.

If you would prefer, you can set Mari so that quickly tapping the shortcut key for these tools
switches “permanently” to the tool, while holding down the shortcut key switches it
temporarily (until you let go of the key). To set this, navigate to the Mari Preferences dialog
box (from the Edit menu, select Preferences), and on the Misc tab, turn off Tool On Key
Held.

EXPERIMENT: Before looking at the mouse gestures, try several of the keyboard shortcuts.
You can look up which controls have assigned shortcuts by searching in the Manage
Keyboard Shortcuts dialog or referring to Appendix A: Shortcuts.

Try theMouse Gestures
To use a mouse gesture, press and hold the backslash key (\), then click and hold the left mouse
button, and move the mouse in the direction indicated.

A red line traces your mouse movement on the canvas.
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When you release the mouse button, the tracing disappears and Mari performs the function you
selected (in the illustration, tracing an “E” to select the Erase tool).

EXPERIMENT: Try several of the mouse gestures. (You may have to paint something before
you can try some of them!) The mouse gesture shortcuts are not shown in the Manage
Keyboard Shortcuts dialog, but can be located in Appendix A: Shortcuts.

Customize General Keyboard Shortcuts
To add and change the general keyboard shortcuts:

1. From the Edit menu, select Shortcuts.

The Manage Keyboard Shortcuts dialog box displays many categories of Mari functions.

2. Click [+] to expand a category.

Entries display in columns for the Name, Description, and Shortcut key for each function in that
category.
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TIP: Drag the edges of column headings to make them wider (so you can see the full
contents of the Description column, for example). Similarly, drag the edges of the entire
dialog box to re-size it as
necessary.

3. To add or change a shortcut key, double-click in the Shortcut column, and type over the new key.
Before you click OK, click somewhere to take the focus outside the Shortcut column you're
editing.

If the new key you entered is already used, a “warning” icon displays. In this case, the newly
entered key doesn’t work. This includes parts of any other shortcut that conflicts with a previously
set shortcut.

For example, a new shortcut Ctrl/Cmd+R+left-click can’t be set if a shortcut already exists with the
definition Ctrl/Cmd+R.

4. If there are no conflicts, press OK (otherwise select a different key).

EXPERIMENT: Expand and browse through the different categories of Mari functions and
their shortcut keys. Try adding shortcuts for functions that don't yet have a key assigned -
and then try the shortcut key you've added.

USING SHORTCUTS | CUSTOMIZE GENERAL KEYBOARD SHORTCUTS



USER GUIDE 32

Set Keyboard Shortcuts for Project Items
To set shortcuts for a project item:

1. In the palette showing the item, right-click on the item and select Assign Shortcut.

The Assign Keyboard Shortcut dialog box displays, with the item selected in the list.

Once you have set a shortcut for a project item, it displays on palettes to the right of the item.

2. To remove the shortcut from the item, right-click on it again and select Assign Shortcut from the
dropdown menu.

The Assign Keyboard Shortcut dialog box opens again, with focus on your item. Double-click on
the shortcut key for the item and delete the key.

Use the Pie Selection Control
Mari includes a configurable on-screen “pie” control menu that allows you to select common brush
tips or color
settings. You can add up to seven brush tips or colors to the “pie” control, as well as being able to
quickly switch between the paint and eraser tools. To use pie selection:

1. With the mouse over the canvas, press and hold F9.

The pie selection menu displays:
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2. To select a setting or tool from the menu, move the mouse over your selection and let go of F9.

You don't need to click – Mari picks up what your mouse is hovering over.

To configure the pie selection control:

1. Add your items (colors and brushes) to the Menu shelf.

2. Rename them as 1 through 7.

Mari ignores any other items on the Menu shelf, and only displays the items named 1-7.

TIP: For details on how to add items to the Menu shelf, see Storing Resources Using
Shelves.

Unassign Shortcuts
You can unassign previously configured shortcuts at any time by following these steps:

1. Go to Edit > Shortcuts.
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2. Double-click on the shortcut you want to unassign and press Backspace to unassign a single
command, or

3. Press Delete to unassign all commands for that shortcut.
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Configuring Brushes
The Mari Brush Editor palette lets you select and customize a wide array of preset brushes, with a
wide variety of brush properties you can edit. You can then drag modified brushes to a shelf for your
ongoing personal use, or for a particular project only. You can also export and import brushes to
share with other Mari users, and you can use keyboard-and-mouse shortcuts to modify your brush
tips “on the fly”.

Brush properties generally apply to a splat (also sometimes called a “stamp”) - one application of the
brush tip onto the canvas. A stroke is one continuous application of splats.

For some properties you can specify jitter - a random variation, to approximate how an actual (as
opposed to digital) paintbrush might work.

Brush Properties
Below are brief explanations and examples of some of the properties Mari lets you modify:

Property Explanation Example

spacing the distance between splats in a
stroke, as a proportion of splat size

a stroke from the same brush with
spacing set to .02, .25, .50, and 1.0:

opacity how dark a stroke can be (maximum
alpha)

a stroke from the same brush with
opacity set to 1.00 and 0.50 with no jitter,
and 1.00 with maximum jitter:
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Property Explanation Example

flow how quickly paint flows out of the
brush, mimicked digitally by how dark
a splat can be (maximum opacity)

a completely hard brush tip, full opacity,
with spacing of 0.15 and flow at 1.00 and
0.30:

radius how big the brush tip is; you can also
specify an innerradius and link
pressure to vary between the two,
and apply jitter to randomly vary
between the two

a stroke with and without radius jitter,
where the jitter is equal to the whole
radius of the brush:

distortions distortions to the shape of the brush
tip:

• rotation - spinning it.

• shear - pulling opposite corners
vertically or horizontally.

• scale - sizing vertically or
horizontally.

• squish - like vertically scaling down,
but affects the radius rather than
brush tip.

a splat squished, rotated, sheared, and
scaled:
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Property Explanation Example

noise how “spiky” the brush is, as measured
in:

• octaves - 1 to 8 applications of
noise.

• frequency - 0 to 100, how many
spikes per octave.

• scale - 0.00 to 1.00, how big the
spikes are, as a proportion of the
radius (1.00 = twice as big as the
radius).

• segments - 4 (a square) to 360 (a
circle) lines making up the brush
outline (to which noise is applied).

Tip: Noise is very hard to explain in
words! (Developers understand it in
mathematical equations.) Your best
bet is to experiment with the settings,
to get the right spikiness for your
purposes!

the same brush with the default and
maximum noise:
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Property Explanation Example

profile opacity from the center to the edge of
a brush, determines whether it is hard
(more opaque throughout) or soft
(fuzzier at the edges)

hard and soft brush tip profiles:

pressure whether pressure when painting on
your graphics tablet increases the
radius, flow or opacity (as calibrated
for your tablet)

Open the Brush Editor
1. Start Mari, and either create a new project or open an existing one.

2. Open the Brush Editor palette:

• from the View menu, select Palettes > Brush Editor, or

• right-click in the toolbar area and select Brush Editor from the dropdown menu.

The Brush Editor palette displays.
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The Brush Editor has three tabs:

• Properties - configurable properties of the selected brush.

• Shelves - the same shelves that display in your Shelf palette.

• Presets - an array of predefined brushes that come with Mari.

The Brush Editor also includes a “scratch pad” at the bottom. The scratch pad shows a squiggle
painted with the selected brush. You can also paint directly in the scratch pad (the default squiggle
disappears while you enter a stroke).

Review the Preset Brushes
Mari comes with a set of preset brushes.

1. Click the Presets tab.

The preset brushes display and are collected into tabs.
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2. Click through each tab and familiarize yourself with the different brushes that are available. Try
selecting some brushes and painting in the scratch pad with them.

Review Properties You Can Change
For each brush, Mari specifies several properties that you can view and change.

1. To view the properties of the selected brush, click the Properties tab.

The following properties display. (Below is an extract from the Mari Reference Guide explaining
each property.)

Property Explanation

GENERAL
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Property Explanation

Noise How much noise to add to each splat, to soften the appearance and reduce
banding. Lower values give a harder brush, higher values a softer brush. (You
can also add noise to the brush tip itself - under the Noise section below.)

Range: 0.00 to 100.00, Reset: 0

Spacing The space between splats, as a proportion of the width of a splat. 1.00 = side-
by-side (so if the tip is a circle, it would look like a string of beads.) .02 = .02 x
the width of a splat.

Range: 0.02 to 5.00, Reset: 0.02

PAINT

Jitter Opacity Max How much to randomly vary the opacity (if Jitter Opacity is enabled).

Range: 0.00 to 1.00, Reset: 0.00

Jitter Opacity Whether to randomly vary the opacity (to the degree specified in Jitter
Opacity Max).

Opacity How dark a stroke can be (maximum alpha).

Range: 0.01 to 1.00, Reset: 1.00

Flow Mimics how quickly paint is applied, by setting the maximum opacity in a
splat.

Range: 0.01 to 1.00, Reset: 1.00

POSITION

Jitter Position Max How many pixels at most to randomly vary displacement from the line of the
brush stroke (if Jitter Position is enabled).

Range: 0 to 1000, Reset: 20

Jitter Position Whether to randomly vary displacement from the line of the brush stroke (to
the degree specified in Jitter Position Max).

PRESSURE

Whether pressure on the graphics tablet affects properties of a splat (as calibrated for your tablet)
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Property Explanation

Colors Whether more pressure increases the color strength.

Radius Whether more pressure increases the radius.

Flow Whether more pressure increases the flow.

Opacity Whether more pressure increases the opacity.

RADIUS

Squish How much to flatten the radius. If the brush tip is a circle, 1.0 is a circle, .5 is
an oval half as tall as it is wide.

Range: 0.05 to 1.00, Reset: 1.00

Jitter Radius Whether to randomly vary the radius (to the degree specified for the Radius
and Inner Radius).

Inner Radius How few pixels the radius of a splat can be (if Jitter Radius and/or Radius
Pressure are enabled).

Range: 1 to 1200, Reset: 1

Radius How many pixels at most the radius of splat can be (if Jitter Radius and/or
Radius Pressure are enabled).

Range: 1 to 1200, Reset: 100

ROTATION

Align to Stroke Whether the brush tip rotates along with the direction you're painting. (With
calligraphy, for example, the tip does not align.)

Jitter Rotation Max How many degrees at most to randomly vary the rotation (if Jitter Rotation
is enabled).

Range: 1 to 360, Reset: 360

Jitter Rotation Whether to randomly vary the rotation.
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Property Explanation

Rotation The degree to which the brush rotates to match the direction you're painting
(if Align to Stroke is enabled).

Range: 0.00 to 360.00, Reset: 0.00

STEADY STROKE

Mode Whether to use the Off, Distance, or Smoothing mode.

Reset: Distance

Delay Defines how much delay is used for the brush stroke.

In Distance mode, the Delay uses the specified amount of screen pixels,
keeping a fixed distance, to define the brush stroke.

In Smoothing mode, the Delay uses the moving average of the cursor
movement to define the brush stroke.

NOTE: When you move the mouse very fast, Mari gets fewer
samples, so the delay looks longer.

Range: 0 to 200. Reset: 0.00

Tail Whether to use the No Tail or Meet options for the finishing strokes.

• Meet - The brush stroke catches up to the cursor's position when releasing
the mouse or pen.

• No Tail - The brush stroke stops as soon as the mouse or pen is released,
with no catch-up.

Reset: No Tail

GENERAL

Type Whether to use a Bitmap image for the brush tip, or Render based on the
qualities specified in these properties

Preview An image of the brush tip, based on the selected properties.

BITMAP
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Property Explanation

Use Painting Click to use the painting in the paint buffer as a brush tip. Mari prompts you
to save it either as an .exr or a .tif file (which file format is used depends on
the support in your graphics card).

Note that .exr files are 16-bit - most other bitmaps are 8-bit.

Path Type the path or click the button to select an existing bitmap to use as the
brush tip.

Note that to use an image as the brush tip, you need to set Type to Bitmap.

GEOMETRY

Vertical Shear How much to distort the brush tip diagonally, top to bottom (as if pulling
opposite corners up and down).

Range: -1.00 to 1.00, Reset: 0.00

Horizontal Shear How much to distort the brush tip diagonally, right to left (as if pulling
opposite corners right and left).

Range: -1.00 to 1.00, Reset: 0.00

Vertical Scale How much to distort the brush tip vertically.

Range: 0.00 to 2.00, Reset: to .50

Horizontal Scale How much to distort the brush tip horizontally.

Range: 0.00 to 2.00, Reset: to .50

NOISE

Noise is very hard to explain in words! (Developers understand it in mathematical equations.) Your
best bet is to experiment with the settings, to get the right spikiness for your purposes!

Octaves Number of applications of noise.

Range: 1 to 8, Reset: 4

Frequency How many spikes per octave.

Range: 0.00 to 100.00, reset to 1.00
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Property Explanation

Scale How big the spikes are, as a proportion of the radius (1.00 = twice as big as
the radius).

Range: 0.00 to 1.00, Reset: 0.00

Segments Lines making up the brush outline, to which noise is applied (4=square,
360=circle).

Range: 4 to 360, Reset: 360

PROFILE

Profile For rendered brushes (see Type above), alpha profile of the brush tip from
center to edge - determines how “hard” or “soft” it is.

Bit Depth Byte (8-bit), Half (16-bit), or Float (32-bit) It is generally a good idea to use a
brush with the same bit depth as the texture you're painting, to avoid
stepping. Note that if you use an 8-bit bitmap, it still paints in 8-bit even if
you set the bit depth to Half.

2. Study the descriptions (above) of the different brush properties.

3. Note the following types of controls used to specify brush properties:

• Entry boxes - to type an entry (usually a number).

• Sliders - to slide between the minimum and maximum allowable entries.

• Reset button - to return to the default setting.

(Often entry boxes, sliders and reset buttons are combined.)

• Checkboxes - to select or deselect a property.

• Dropdown menus - to select from available options.

• Spline Editors - to move values along a curve; you can drag any of the points on the curve in any
direction, and see the effects in the preview bar below the curve. Click to add a new point, and
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right-click to invert, select presets, and export and import settings. To remove a point, click on it
while holding Ctrl/Cmd.

4. Try changing some brush properties, and note the change in the squiggle in the scratch pad (it
updates
dynamically). You can also try painting in the scratch pad, or painting on the canvas (and then
undo-ing) to see the effect of your changes.

TIP: When you hover the mouse over a brush, tooltips display key properties:

EXPERIMENT: Select one of the preset brushes, and play around with the Radius, Opacity,
Profile, and Jitter settings. Notice how each affects your brush strokes on the canvas or in
the Brush Editor scratch pad.

Customize a Brush
Having looked at the available preset brushes, and different properties you can change, let's (finally)
try customizing a brush. This involves three steps: selecting a preset, changing its properties, and
saving it to a shelf.

1. First select a preset to modify: click the Presets tab, then click a tab for a category of preset
brushes, and click to select a brush.

2. Review Properties You Can Change: click the Properties tab, and change the brush properties.

CONFIGURING BRUSHES | CUSTOMIZE A BRUSH



USER GUIDE 47

3. Finally, save it to a shelf: click the Shelf tab; click to select the Personal shelf, Project shelf, or any
other custom shelf you may have created, and click the button.

The modified brush displays in the selected shelf. By default it is named “Brush” (and then
“Brush_1”, “Brush_2”, and so forth, incremented for every tool you add).

4. To rename the brush, double-click its name, type over a new name, and press Enter.

NOTE: Any brush tip that you select is shown as an outline for the brush cursor design with
any tool that allows you to apply paint to the model; for example, Paint, Paint Through, and
Clone Stamp, among others. This cursor outline scales according to the radius of the brush
tip, but does not reflect other options, such as jitter or opacity.

TIP: To a delete a custom brush, select the brush and click .

EXPERIMENT: Try creating three custom brushes you might actually use and test them out
on a model. If it doesn’t turn out as you expected, try customizing it and re-saving it to your
Personal shelf.

Export and Import Brushes
You can also export and import your brushes. This is useful, for example if you want to share brushes
with other users.

1. To export a custom brush, right-click it and select Save Item.

The Save Item dialog box prompts you to save the brush, as an .msi file.

TIP: The first time you save or open items in Mari, it defaults to your home directory.
Thereafter, Mari remembers the last folder you navigated to in that dialog box.
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2. Type a filename, and click Save.

Mari exports the brush.

3. To import a brush, right-click in the Personal, Project or custom shelf and select Load Item.

The Import Item dialog box prompts you to select an .msi file.

4. Navigate to and select the .msi file for the brush you want to import, and click Open.

Mari imports the brush.

TIP: You can also import and export entire shelves (see Storing Resources Using Shelves).

EXPERIMENT: Try creating a custom brush, exporting it, then deleting it from the shelf, and
finally (re)importing it.

Import a CustomPhotoshop Brush

Custom-made Photoshop brushes can be imported into Mari and stored in a custom shelf. These
brushes are "stamp" brushes that do not take into consideration any variable size or spacing. The
shape (or shapes) of the brush are imported into a custom shelf where you can set the preferences
for the brush manually.

To import custom brushes:

1. Navigate to Menubar | Tools > Import Brushes.

This opens an Import Brushes dialog.

2. Select the Photoshop brush (.abr format) from the file location it was saved to, and click Open.

A new shelf is created and populated with the brush or brush parts. If there are multiple "stamp"
images, you may need to set the preferences for the brush.

NOTE: Brushes imported from Photoshop must be custom-made. If you try to import
Photoshop’s default brushes, or any invalid brush, an error message displays and the brush
fails to be imported.

Change Brush Properties “on the Fly”
Mari also includes default keyboard-and-mouse shortcuts to change the relative Radius, Rotation,
Opacity, and Squash of the brush you're using.

1. To change the RADIUS of your brush, press and hold R, and move the mouse right or left to
increase or decrease the outer radius, and up or down to increase or decrease the inner radius.
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2. To change the ROTATION of your brush, press and hold W, and move the mouse right or left to
rotate clockwise or counterclockwise.

3. To change the OPACITY of your brush, press and hold O, and move the mouse right or left to
increase or decrease the opacity.

The alpha slider in the Colors Palette moves along with your mouse.

4. To change the SQUASH of your brush, press Q and move the mouse right or left to squish the
brush tip more or less.

TIP: To save any changes you make on the fly, see the procedure to Customize a Brush.

EXPERIMENT: Play around with the R, O, W, and Q keyboard/mouse shortcuts for changing
your brush tip on the fly.
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Clone Stamping
The clone tools let you copy paint from one image or part of a channel to the surface of your model.
This is a standard feature in painting packages such as Adobe® Photoshop®, GIMP, and so on.

You start clone stamping by setting a source point. This is the point from around which Mari takes the
cloned texture. As you paint, Mari duplicates the area around the origin point you've set.

Mari's Clone Stamp tool lets you clone from:

• the model's surface (baked paint) in the active channel, or in a different channel

• the current (unbaked) paint in the paint buffer

• an external image (selected from the Image Manager, optionally zoomed in or out).

When cloning from the baked paint on a channel, you can select to clone directly from the surface. In
this mode, the tool clones the paint from the channel surface straight up into the paint buffer directly
above that point. This is
basically a way of copying the model's surface into the paint buffer so you can edit it and then re-bake
the paint.

TIP: When you clone from a source on the model (any mode other than using an external
image), the source point you set is based on the view of the model, not the model itself.
Moving the view moves the source point. For instance, you cannot set the source point on
the front of the model, move the view to the rear, and paint the cloned texture from the
front to the rear of the model. (The source point has moved to the same spot in the view, but
on the rear of the model.) Note, however, that you can use a split screen to select a source in
one view and clone it to another.

In these modes, think of the source point as being a position within the window. As you
zoom, pan, and rotate the model, the source point remains in the same position in the
window, but not the same position on the model.

Choosing a Source Point
When cloning from a particular channel, the Clone Stamp tool takes a “snapshot” of that channel as it
appears on screen and uses that as the source. As a result, the resolution of the cloned texture can
depend on the current
display resolution within Mari. Higher display resolutions give better cloning results, but can
dramatically slow Mari's performance.

50



USER GUIDE 51

When cloning from a source point on the model's surface, bear in mind that the shape of the model
determines what gets cloned. For example, if your source point is on a part that sticks out from the
model, the space between that part and the rest of the model does not provide a source texture when
painting.

The original model, with
clone

point set in the paint
on the arm.

See how the cloned texture
comes directly from the

surface as seen in the view.

Setting a Start Point
You can set the start point for each stroke. This can be either:

• Relative to the source point - Your first brush stroke starts from the source point, but for later
strokes the cloned texture starts from a position relative to the source point. For example, if your
second brush stroke starts from 2 cm below the first, the texture cloned there is the texture 2 cm
below the source point in the original image. This is the default setting.

• From the source point - All brush strokes take their cloned texture starting from the source point.
As you finish each stroke, you can see the source area preview snap back to the original source
point.

This example shows the difference between the two modes:

Source texture for
cloning.

Texture cloned
relative to source

point.

Texture cloned not
relative to source

point
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Image Options
When you are painting using an external image, you can choose to have Mari display a preview of the
image, floating over the canvas. This makes it easier to see exactly which parts of the source image
Mari is cloning when you paint. This is very similar to using the Paint Through tool (see Painting
Through an Image or Gradient).

Mari can either scale the external image as you zoom in or out on the model while painting, or keep it
at the same size. You control this with the Scale Lock setting: if on, Mari locks the image size relative
to the model, at the current zoom level. As you zoom in or out, the image that you're cloning from
zooms in or out too, so the cloned texture always stays at the same scale, relative to the surface
you're painting on.

If Scale Lock is off, the image scale does not change when you zoom in or out.

TIP: Mari copies textures you clone from an external image at the resolution of the source.
Mari then paints these into the paint buffer at the buffer's resolution. For example, a 4k
image provides 4k source texture for cloning, which Mari can then paint into the paint buffer
at a maximum of 16k (the maximum size of the paint buffer). See Controlling the Way Mari
Applies Paint to Your Model for details on paint
buffer resolution.

Set the Clone Stamp Options
1. Start Mari and open your project.

2. Click to select the Clone Stamp tool.

3. Open the Tool Properties palette.

The current properties of the selected tool display. Scroll down to view them all.
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4. To customize the brush you're using for your selected tool, set the options under the Tip and
Geometry
sections.

These are the same options available for brushes in general - see Configuring Brushes.

5. To set the brush strokes to start relative to the source point, click the Relative checkbox under
Texture > Image.

If this is not selected, the clone brush strokes always start from the source point (see Setting a
Start Point for examples).

6. To turn the onscreen preview on when cloning from an external image, under Texture > Preview,
click to turn Onscreen Preview on. Set the Preview Alpha to your preferred value (higher makes
the preview clearer, but makes it harder to see the current paint in the channel).
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As you click in the external window to change the source point, the preview moves around on the
main canvas.

7. To set whether Mari zooms images relative to your view, turn Scale Lock on or off, under Texture
>
Transform.

If this is on, Mari locks the image size relative to the model, at the current zoom level. If you zoom
in or out, Mari also zooms in or out the image that you're painting through. If this option is off,
the image scale won't change when you zoom in or out.

8. To set whether Mari resizes source images to fit the paint buffer, change Reset Size setting, under
Texture > Transform:

• ToOriginalSize - Displays and clones the source image in its original size, in screen pixels. For
example, a 1024x1024 image takes up 1024x1024 pixels on screen. This is the default.

• RelativeToPaintBuffer - Displays and clones the source image resized so that one pixel in the
image matches one pixel in the paint buffer. For example, a 1024x1024 image in a 2k
(2048x2048) paint buffer appears onscreen as half the size of the paint buffer.

9. To set whether Mari preserves transformations when you switch source images, change the Auto
Reset setting, under Texture > Transform:
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• DoNotReset - Preserves any transformations (such as moving, resizing, or rotating) you have
made to the source image that you're cloning, if you switch to using another source image. This
is the default.

• Reset - Resets the image to the default size, location, and rotation, each time you switch to
another source image. For example, if you're using a 2k paint buffer and a 4k image, the image
always appears to be twice the size as the paint buffer onscreen.

TIP: Use DoNotReset if you want to clone several images of the same size. This is
specifically useful if you want to switch between using multiple 4k textures, as it saves you
having to resize the source image
preview from the huge default every time you switch.

Now that you've set up how the clone tool works, you can get on and start painting.

Clone stamp
To clone from an existing current layer:

1. If you haven't already, select the Clone Stamp tool.

2. In the Tool Properties toolbar at the top of the screen, select the clone source from the Source
dropdown.

The list includes all channels in your project, plus Painting (clone from the unbaked paint) and
Image (clone from an external image). The default value for Source is Current Paint Target.

TIP: If you can't see the Tool Properties toolbar, open it by right-clicking in the toolbar space
at the top of the window and selecting Tool Properties from the bottom of the dropdown
list.

3. Select Current Paint Target, select the layer you want as a source, then hold down Ctrl/Cmd and
click on the model's surface to set the source point.

Mari highlights the source point with a cross.
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4. Paint normally. As you paint, Mari copies the texture from around your source point in the source
channel:

• The white circle is your brush.

• The black circle is the source area - as you move your brush, this circle shows you the texture
you'll be cloning from.

You can select any preset brush to use with the clone stamp tool, or edit the brush as normal (see
Configuring Brushes).

To clone from the paint buffer:

1. To set the clone source in the unbaked paint (that is, the contents of the paint buffer), from the
Tool Properties toolbar at the top of the screen, select Painting from the Source dropdown.

2. Ctrl/Cmd-click to set the source point. Paint normally:

• As above, the white circle is your brush.

• The black circle is the current source area.

TIP: Bear in mind that if a particular area doesn't have any unbaked paint on it (that is, there
is no data in the paint buffer for that area), no clone data is available from the area. It's as if
you're trying to paint from an area that doesn't have anything on it.

If you're trying to clone and getting nothing, check that there actually is unbaked paint on the
area you're cloning from!

To clone from surface directly into the buffer:

1. To clone from the surface straight up into the paint buffer directly over the clone point, select the
layer to clone from as normal. When you set the source point, hold down Ctrl+ (Windows key),
or Cmd+Ctrl for Mac, and click on the model. Paint normally. As you paint, Mari copies the area
you paint from the layer surface into the paint buffer.
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2. If you are cloning from the current channel and layer, you won't see any visible effects, as Mari is
just copying the paint right on top of itself, but you can then switch tools and edit the paint and
then re-bake. This lets you make fine adjustments to the paint already baked into a layer, or to
clone sections of paint from one layer to another (for example, to clone from a displacement
channel into the diffuse channel to get the basic details of the
surface contours to paint).

To clone from an image:

1. To clone from an external image, drag the image from the Image Manager (or from a shelf) onto
the main canvas.

The image opens up in a separate window. You can zoom the image in and out by holding down
Ctrl/Cmd+Alt, clicking and dragging.This sets the clone source to Image automatically.

2. Click in the separate image window to set the source point. The white circle in this window shows
where the current clone source is, as you move the mouse.

3. Paint in the main Mari window as normal.

TIP: If you paint off the edge of the image, no clone data is available. You can choose to tile
the source image. If this is on, when you paint off the edge, Mari repeats the image (so you
always have source data).

Use the ; (semicolon) key to toggle source image tiling on and off.

EXPERIMENT: Experiment with the various options and modes of clone stamp. Try using a
custom brush, with an unusual texture, lower alpha, and so on to find which settings work
best for you.
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Apply a Color Grade as You Clone
You can apply a color grade to your source image as you paint. You can apply the color grade to any
clone operation, whether from an external image or from a channel's surface. You can:

• Change the color values in the source image, either all at once, or by RGB channel.

• Alter the Contrast or Saturation.

• Use the value curve to apply a specific change to the colors. Mari grades the colors by converting the
input value (on the x axis) to the matching value on the y axis.

For example:

Setting Result

Default settings

Blue component turned down:

Colors at default settings, but contrast turned
down:

CLONE STAMPING | APPLY A COLOR GRADE AS YOU CLONE



USER GUIDE 59

Setting Result

Color and contrast at defaults, but the following
value curve applied:

To color grade the image:

1. Open the Painting palette and scroll down to the Source Grade section.

This section lets you control the color grade for your source image.

2. Click to check the Enabled box.

3. You can use the controls to:

• Change the color values in the source image, either all at once (using the Rgb slider) or one by
one.

• Alter the Contrast or the Saturation.

• Use the value curve to apply a specific change to the colors. Mari grades the colors by converting
the input value (on the x axis) to the matching value on the y axis.

4. Select the clone tool.
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5. Paint some sample strokes, experimenting with the settings in the Source Grade section.

EXPERIMENT: Use the sliders to change the color balance in the red, green, and blue
components. Try altering the contrast. Use the value curve control to change the color values
in the source image. Paint a number of sample strokes to see how the color grading works.
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Painting Through an Image or
Gradient

Paint Through is closely related to clone stamping. The Paint Through tool lets you drag an image
from the Image Manager and hover it over your model. As you paint, Mari applies the area of the
image underneath your brush to the model. It's like clone stamping, except that you're always cloning
directly from the preview onto the model below it.

Unpainted model. Image overlaid,
painting through.

The result.

As you paint, you can move the source image around, rotate it, and resize it.

TIP: If you paint off the edge of the image, no clone data is available. You can choose to tile
the source image. If this is on, when you paint off the edge, Mari repeats the image (so you
always have source data).

Use the ; (semicolon) key to toggle source image tiling on and off.

You can also use the Gradient tool to paint through a linear or radial color gradient instead of an
image. For example, the following illustration shows a radial gradient being stamped onto the model:
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Paint Through
Paint Through has two modes:

• Paint through - you hover the image preview over the model and stamp it down onto the surface.

• Image clone - you hover the image next to the model, set a source point, and clone from that point.

The Image clone mode is like the normal Clone Stamp tool, but you have more control over the
source image (you can resize, stretch, and rotate it).

To lock the model and paint buffer to the source image so that Mari automatically pans or scales the
model relative to the image, check the Lock Object checkbox in the Paint Through toolbar.

You can also lock the source image proportions using the Image Scale button, so that any
changes to scale are applied proportionately to both axes. If Image Scale is off, you can alter the
image by different amounts on the vertical and horizontal axes.

As you paint through, you can switch images. By default, when you switch to another source image,
Mari applies any transformations you've made to the last source image onto the new one. For
example, if you have resized the source image onscreen, moved it around, or rotated it, the next
source image appears the same. You can control this behavior through the Auto Reset option.

TIP: You can change the algorithm Mari uses to clone from a resized texture. Set this on the
Painting palette, under Painter > Filter. Your options are:

• Nearest - preserves edge detail, but gives quite "blocky" textures.
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• Bilinear - gives good results, but can produce square artifacts at extreme zoom. This is the
default setting.

• Bicubic - provides more rounded results, slightly blurrier but without the square artifacts.

As with the Clone Stamp tool, you can adjust the color grade of your source image as you paint.

TIP: See Clone Stamping for details of the Clone Stamp tool and using color grades.

Set the Paint Through Options
1. Start Mari and open your project.

2. Click to select the Paint Through tool.

3. Open the Tool Properties palette.

The current properties for Paint Through display. Scroll down to view them all.

4. To customize the brush you're using for Paint Through, set the options under the Tip and
Geometry sections.

These are the same options available for brushes in general - see Configuring Brushes.

5. To change the prominence of the onscreen image that you're painting through, under Texture >
Preview, set the Preview Alpha.

Higher values make the preview clearer, but make it harder to see the model underneath.
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Preview alpha of 0.35 Preview alpha of 0.75

6. You can lock the source image proportions using the Image Scale button, so that any changes to
scale are applied proportionately to both axes. If Image Scale is off, you can alter the image by
different amounts on the vertical and horizontal axes.

7. Set Mari to automatically pan or scale the source image using the Pan Lock and Scale Lock
settings.

When the locks are enabled, Mari locks the image position and size relative to the model. If you
pan or zoom the model in or out, the image that you're painting through pans or zooms in or out
too.

If Pan Lock and Scale Lock are disabled, the image position and scale does not change when you
change the view of the model.

8. To set whether Mari resizes source images to fit the paint buffer, change Reset Size setting, under
Texture > Transform:

• ToOriginalSize - Displays and paints through the source image in its original size, in screen
pixels. For example, a 1024x1024 image takes up 1024x1024 pixels on screen. This is the default.

• RelativeToPaintBuffer - Displays and paints through the source image resized so that one pixel
in the image matches one pixel in the paint buffer. For example, a 1024x1024 image in a 2k
(2048x2048) paint buffer appears onscreen as half the size of the paint buffer.

9. To set whether Mari preserves transformations when you switch source images, change the Auto
Reset setting, under Texture > Transform:

• DoNotReset - Preserves any transformations (such as moving, resizing, or rotating) you have
made to the source image that you're cloning, if you switch to using another source image. This
is the default.
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• Reset - Resets the image to the default size, location, and rotation, each time you switch to
another source image. For example, if you're using a 2k paint buffer (maximum size) and a 4k
image, the image always appears to be twice the size as the paint buffer onscreen.

TIP: Use DoNotReset if you want to paint through several images of the same size. This is
specifically useful if you want to switch between using multiple 4k textures, as it saves you
having to resize the source image preview from the huge default every time you switch.

Now you've set up how the Paint Through tool works, you can get on and start painting.

Paint Through an External Image
1. Drag your source image from the Image Manager (or from a shelf) onto the canvas.

The image “floats” above the canvas, ready to paint through.

NOTE: If you do not have the Paint Through tool active when trying to drag an image onto
the canvas from the Image Manager, Mari automatically switches you to the Paint Through
tool to continue.

2. Get the image how you want it:

To... You need to...

Move the image around the canvas Hold down Shift, click on the image and drag it.

Or, click on the white square in the middle of the image
and drag it.

Resize the image, preserving the scale Hold down Ctrl/Cmd+Shift, click anywhere on the
canvas and drag.

Or, hold down Shift, click on a side of the image and
drag it.

Resize the image in one direction Click on a side of the image and drag it.

Rotate the image Hold down Ctrl/Cmd, click anywhere on the canvas and
drag.

Or, click outside the image and drag.

3. If you just want to stamp the image straight onto the model, press ' (apostrophe).
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Mari stamps down the image, as it is currently floating over the model, onto the surface.

Model before painting. Texture stamped down.

4. To paint using the brush, just click and drag to paint normally.

As you paint, your brush paints down the texture from the image at the point you're painting.

Model before painting. Texture painted through.

TIP: Painting with the brush lets you more subtlety control how Mari applies the paint - for
example, you can use a brush with a relatively low alpha, and “build up” the paint on the
model using multiple strokes.

You can apply a color grade to the source image as you paint through. Set the color grade
settings in the Source Grade area of the Painting palette. See Clone Stamping for details of
how the color grade settings work and the effects you can achieve.

EXPERIMENT: Experiment with different brush settings and their effect on painting through.
Adjust details such as opacity, alpha, and noise to affect the way the texture is painted onto
the model.

5. You can apply a Tint, which allows you to combine a color with the image to apply a tinted version
of the image using Paint Through.

6. You can also apply a Stencil. The stencil allows you to paint through an image to create a design
of the image on the model.

By default, there is No Stencil applied to the model.
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Clone from a Floating Image
1. In the Tool Properties toolbar at the top of the screen, select Image Clone from the Mode

dropdown:

2. Make any other changes you want to the size, rotation, stretch, or position of the source image.

This is exactly the same as in the normal mode. You'll probably want to move the image next to
where you'll be painting.

3. Ctrl/Cmd-click on the floating image to set the source point.

The clone source preview displays in a red circle, while your brush is the white circle.

4. Paint normally.

Mari clones the texture as you paint, taking the resolution for the cloned texture from the source
image. For example, a 4k image provides cloned texture at 4k resolution.

Using Tint and Stencil Options
1. On the Paint Through toolbar, there are additional buttons to the right of the main options.

These give you Stamp, Repeat, and Tint options for the Paint Through functionality.

2. Stamp is a simple button that works the same as stamping down an image using a shortcut. You
can drag your image around the canvas, resize it, and rotate as usual before using Stamp to apply
the image directly to the model in full.
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3. To repeat the image you wish to apply to the model, first press the Repeat button before painting
on any part of the model. The image repeats across the painted parts of your model. To turn this
off, simply press the button again.

4. To apply a Tint, press the Tint button and select your options from the following dropdown
menu.

This allows you to combine a color with the image to apply a tinted version of the image.

• By default, No Stencil is the selected option, which simply tints the image color and does not
change any other aspect.

• Selecting Stencil allows you to paint through an image to create a design on the model. Stencil
ignores the color on the stencil and follows only the alpha value.

• Selecting Inverted Stencil allows you to color in all parts of the model where the stencil is
transparent, leaving the stencil as the model’s original color.

• Selecting Luminance allows you to paint through an image in much the same way as you would
with a stencil. However, by setting the option to Luminance, this allows you to use an image’s
luminance as the alpha when painting. This works especially well for dirt, noise, blemishes, and
other similar effects.

• Selecting Inverted Luminance allows you to create a similar effect as Luminance but uses the
lighter parts of the image as alpha. This can be used to pick up scratches and fine lines.

Paint Through a Gradient
To paint through a color gradient (instead of through an image):

1. Click to select the Gradient tool.

A gradient displays above the canvas.
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2. To configure the gradient, change the settings on the Tool Properties toolbar at the top of the
window.

You can set:

• The two colors for the gradient - click on the swatch to change the color.

• In Point - select a proportion of the gradient (left-to- right linear, or in-to-out radial) at which the
starting color begins changing to the ending color (at 0.00, the transition begins at the far left
linear or dead center radial; at 0.50 the transition begins halfway; at 1.00 there is no transition,
it's all start color).

• Out Point - select a proportion of the gradient (left-to- right linear, or in-to-out radial) at which
the starting color turns completely into the ending color (at 0.00, there is no transition, it's all
end color; at 0.50 the
transition ends halfway; at 1.00 the transition ends at far right linear, or the outer circumference
radial).

• Type - select from the dropdown menu whether the gradient is Linear (from one side to the
other) or Radial (from the center out).

As you change the properties the gradient shown onscreen updates.

3. Size, move, and rotate the gradient, in the same way as described in Set the Paint Through
Options.

4. Paint through the gradient, in the same way as described in Paint Through an External Image.
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Controlling the Way Mari Applies
Paint to Your Model

When you paint, Mari saves your painting in a buffer, and then bakes it onto the surface of your
model. You can learn About the Paint Buffer and transform paint in the buffer before baking, Mask
What You Can Paint On, and apply Paint Blending Modes to control how paint in the buffer blends
with what's on the surface when it bakes.

About the Paint Buffer
As you paint, Mari saves the painting since your last bake in the paint buffer. Then, when you bake,
Mari saves the paint from the buffer, adds it to the surface underneath, and clears the buffer, ready
for more paint.

While the paint is still in the buffer, you can make changes to it. If you don't like what you've done,
you can erase
sections using the Eraser tool or just blank the entire paint buffer.

Think of the buffer as floating above the canvas. When you bake, Mari adds the paint to the current
layer - but until then you can edit the buffer, move the model around underneath it, or switch to
another layer and bake the paint there instead. After baking, you can set your preferences to keep the
transformations for new paint you add to the buffer, or automatically reset the buffer to the Mari
defaults.

Boundaries

Mari shows the boundaries of the current paint buffer as a white rectangle. By default, the paint
buffer is sized slightly larger than the window (that is, it covers everything you can see), so the
boundaries are not visible. As you
resize it, the boundaries and current details appear.
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Paint buffer resized and rotated - note that depth and resolution details display underneath.

Depth and Resolution

The paint buffer has a specific color depth and resolution, which controls the color and resolution of
the paint as you apply it (rather than that of the patches that you're painting onto). For instance:

• If the paint buffer has a color depth of 8-bit (256 colors), then that's the maximum number of colors
that you can use when painting. Even if you're painting onto a patch with a color depth of 16 or 32
bits (65,536 or 16.7 million colors), the paint you're applying only has 256 colors.

• If the paint buffer has a resolution of 512x512, the total buffer as it appears on-screen has that
resolution. Anything you paint in the buffer is at 512x512. Any patch with a higher resolution still
only receives the paint at 512x512.

On the other hand, it's also true the other way around. If you're painting onto a 512 x 512 patch with
8-bit color, using a buffer at 1024x1024 and 16-bit color, Mari still saves the patch at 512x512 8-bit.
The advantage to using a paint buffer with higher quality than the resulting patches is that you can
“overpaint” and use the higher quality texture and color depth to ensure good results. You can use
this to help smooth out transitions between colors (preventing stepping), or to ensure that your
textures are sharp (that is, at the maximum resolution for the patch).

About Masking
Within the buffer, you can control the paintable area. Mari lets you mask areas on the model. Areas
covered by the mask can't be painted on. It's the electronic equivalent of putting masking tape over
something you don't want to paint when you're repainting a wall.

Mari includes the following mask types:

• ambient occlusion mask

• depth mask
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• backface mask

• fractal noise mask

• a configurable edge mask, which masks the areas on the model that are oblique to the current
view, and

• a channel mask, where you create a channel for masking, paint in it, and use it to control where
you can paint on another channel.

About Blend Modes
When you bake the paint buffer, Mari (by default) adds the contents of the buffer to the surface of the
layer below. If you prefer, you can set the buffer to use any one of a number of other blend modes.
These correspond to the layer blending modes used in 2D graphics programs such as Photoshop® or
GIMP.

The default is for Mari to add the contents of the buffer to the surface. Other blend modes available
include varieties of:

• painting the numeric difference between the buffer and the existing surface

• using the contents of the buffer as input for a dodge or burn on the surface

• using the contents of the buffer as input for a hard-light application on the surface.

For example, here's the same paint splash in different blend modes:

Default (over) mode. Burn Midrange mode.

Screen mode. Difference mode.

CONTROLLING THE WAY MARI APPLIES PAINT TO YOUR MODEL | ABOUT BLEND MODES



USER GUIDE 73

NOTE: See Paint Blending Modes for details of all the blending modes available.

Configure the Paint Buffer
1. Start Mari and open your project.

2. Open the Painting palette, scroll down, and expand the Paint Buffer section.

Mari displays basic properties of the paint buffer.

3. Set paint buffer properties:

• Color Depth - controls how many colors the paint buffer can hold. Uncheck this if you want to
clone from or paint through a source that has values higher than this range.

• Buffer Size - controls the resolution of the buffer itself.

• Clamp - if checked, Mari restricts the range of the paint buffer to values between 0 and 1.

• Transform (Translation, Scale, and Rotation) - used to Move or Transform Paint in the buffer.
But it's easier to use the Transform Paint tool.

• Reset on bake - controls whether Mari resets the buffer to its defaults after baking. If enabled
(the default), any transformations you've made to the paint buffer revert to the defaults. That is,
after baking you get a new paint buffer (once again slightly larger than the visible screen). If you
want to preserve your transformations after baking, change this to disabled.
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TIP: You should always try to set the color depth (and, if possible, buffer size) to at least as
high as the highest values for the patches on your model. Mari supports a maximum Buffer
Size of 16384 x 16384. However, this setting is not available for all graphics cards. The
availability of this setting is determined by the maximum texture size supported by your
graphics card.

Please note that increasing the Buffer Size, even when your graphics card supports large
textures, can slow Mari’s performance. If you are using patch resolutions higher than 4K, we
recommend that you zoom in to the surface when painting, to keep the resolution sharp.

4. Open the Projection palette. This controls how Mari projects paint onto the model when you
bake the paint, and mask settings.

5. Try changing the value for Painting Opacity.

This controls how opaque your paint is in the buffer. At 1.0, you see the paint exactly as you
painted it. At 0.5, the paint is half transparent, and at 0 it's completely transparent.

6. To set properties for baking the buffer, scroll down and expand the Projection section.

The Projection Filter controls how Mari calculates the colors to apply to the surface when you
bake the buffer down:

• Bilinear - gives a smooth projection down onto the surface.

• Nearest - gives a hard-edged projection down onto the surface.

7. The Bake Behavior setting controls whether Mari bakes automatically when you change the view,
and whether the buffer clears automatically once you bake. The options are:

• AutoBakeAndClear - Mari automatically bakes and clears the buffer when you move the model.

• Manual - You have to bake manually; and when you do, the paint stays in the paint buffer until
you manually clear it.

• ClearOnly - You have to bake manually; and when you do, the paint buffer clears automatically.

CONTROLLING THE WAY MARI APPLIES PAINT TO YOUR MODEL | CONFIGURE THE PAINT



USER GUIDE 75

TIP: With Manual or ClearOnly, you can reposition the model underneath the buffer. This is
useful, for example, if you realize that you need to get a better angle on a particular surface
on the model.

8. The Projection setting lets you set whether Mari projects only onto the Front of the model (as
you're seeing it) or whether paint goes straight Through the model (appearing on the back as well
as the front).

The paint stroke,
painted onto the left
side of the face.

The result, projecting
on the Front, rotated
so you can see that
it's only appearing in

the front of the
original view.

When projecting
Through, the paint
stroke appears on
the back as well as

the front.

9. In the Project On settings, select whether to project onto only the selected areas, or all
patches/objects in the project. For example, if you set Project On to Selected Only, you can only
paint on the currently selected areas (whether it's an area, patch, or object, depending on your
selection mode).
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This is useful when, for example, painting a face so you don't have to worry about accidentally
overpainting onto the eyes.

EXPERIMENT: Paint a couple of example strokes onto your model, so you can see the effects
as you work. Try:

• Setting Bake Behavior to Manual or Clear Only, and then moving the model around
underneath the buffer.

• The paint buffer “floats” above the model until you bake it on. For example, you could
move it around to get a better angle on a particular surface that you're painting on, or to
paint on a different section of the model.

• Using the Zoom Paint Buffer tool to zoom in on your model with the paint buffer locked
and without baking the paint down.

• Changing channels (through the Channels menu or palette, or using the Page Up and Page
Down keys). The paint buffer stays in front of the canvas, on the new channel.

• Setting Projection to Through. Paint some strokes on your model and bake them. Now
rotate the model to see how the paint has “penetrated” it.

• Set Project On to Selected. Using the Selection tool, select a patch on your model. Paint a
stroke that goes off the edge of the selected patch, and bake it. See how the paint that goes
off the selection patch disappears when you bake.

Erase Paint
1. To erase a section of paint, click on the Eraser tool.

2. Click and drag to erase paint from the paint buffer.

This does not affect the underlying paint baked onto the model, only the paint in the buffer.
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TIP: You can edit the brush details for the eraser (brush shape, size, and so on) the same as
you would for any other brush.

3. To clear the entire paint buffer, click the Clear the Paint Buffer button.

Mari clears the contents of the paint buffer.

NOTE: You can also clear the paint buffer by pressing Ctrl/Cmd+Shift+C.

Mask What You Can Paint On
1. Scroll to the top of the Projection palette.

Masking options are under the Mask Preview, Channel Mask, Ambient Occlusion Mask,
Backface Mask, Depth Mask, and Edge Mask sections.

2. If you want to change how masking appears on-screen, change the Mask Preview settings.

• You can temporarily set the Masking Disabled feature by selecting the check box, or pressing
Ctrl/Cmd+M. The allows you to see the geometry without any of the current masking channels.
This overrides the Mask
Preview Enabled feature, even if it is already selected.

• You can set the Mask Preview Color - click the swatch to select a color for the mask from a
color picker. The color includes an alpha value, so you can have the mask displayed semi-
transparent.

• To display the masking, click Mask Preview Enabled or press , (comma).

When this is on, Mari shows all the masking you have turned on (including channel, edge, depth,
and so on).
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TIP: Layer masking, projection masks, and masks on projectors are all hardwired to use the
red color
component. If you want to use another color component for your mask value, the Shuffle
adjustment layer allows you to change the RGBA components so that any can be replaced by
another.

Additionally, the Luminosity adjustment layer allows you to convert an RGB input to a
grayscale output.

When the masking is visible, the icon displays in the status bar. Clicking this icon, as well as
the button in the palette, hides the masking.

Other icons show which masking is in use. They are:

for edge masking

for channel masking

for ambient occlusion masking

for depth masking

for backface masking

for masking disabled

Edge Masks

Mari projects paint directly onto the surface of your model based on your view. In other words, it
applies paint to what you can see, from the angle you see it. If you paint something you can see, but
you're not facing it directly, there might be falloff, where what you've painted has “smeared”. For
example, the images below show a spot painted onto a surface of an anvil. From the angle it was
painted, it looks like a circle. But if you rotate it, you can see that it “stretched” over the edge.

Circle painted front on. Rotated, you can see the
falloff.
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To prevent this from happening, you can configure an edge mask, which masks the falloff area so
you can't paint on it (or so that you can, but the falloff is minimized). The following illustration shows
the edge mask tinged in red, and the result of the painting, again baked and rotated.

Circle painted front on,
with

edge mask.

Rotated, you can see the
mask prevented falloff.

Generally, you wouldn't want such a sharp edge to the paintable area, so Mari lets you specify falloff
start and end points to make it fuzzy (unlike the illustration above, where the start and end points are
the same). The falloff start is where the masking begins, a proportion of where the projection
deviates from directly facing the view. From there, the projection fades out as the mask blends to the
falloff end, at which point the projection ends completely (is completely masked) till it hits 90 degrees
from facing. You can control how fast the masking falls off.

To see how this works, the following illustrations show the result of painting a stripe on the model,
like this:
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If we bake it, and then rotate to see how much “smeared” into the falloff area, you can see the results
of using masks at falloff end/start points of 1.00/0.00 and 0.75/0.25:

No mask. Mask Falloff:
End 1.00, Start 0.00.

Mask Falloff:
End 0.75, Start 0.25.

TIP: If you want to, you can set the end to a higher value than the start. This reverses the
masking - the facing surfaces are masked and the oblique surfaces are paintable.

To use edge masks, set the options under Edge Mask:

• Falloff Curve - use the curve control to set how the masking falls off between the Start and End
points. The start point is at the left of the curve, the end is at the right, and the degree of masking is
on the vertical axis.

• Falloff End - where the projection completely fades and the painting is completely masked.

• Falloff Start - is where the masking begins, a proportion of where the projection deviates from
directly facing the view, at which point the projection starts gradually fading as the masks blends to
the falloff end.

Enable the masking by turning on the toggle at the top of the section.
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When enabled, the icon displays in the status bar.

TIP: You can use shortcut keys to enable/disable the edge mask (G) and hide/show the
masking (,).

Channel Masks

You can use a channel mask to manually define your own painting mask. You do this by painting
into a channel and then using it to control where paint applies to the surface.

Channel mask. Paint buffer without
channel mask.

Paint buffer with channel
mask – see the red masked area
where the white is on the mask.

Mari applies the channel mask based on color values on the surface of the channel. This is set up
through a curve
control:
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By default:

• White pixels (value of 1,1,1) are completely masked (totally unpaintable).

• Black pixels (value of 0,0,0) are completely unmasked (totally paintable).

• Other pixels are less masked as their color values approach 0, more masked as they approach 1. For
example, 50% gray (0.5,0.5,0.5) creates a mask with 50% opacity.

Mask channel including
colored

mask data.

The resulting paint mask.

By altering the curve control, you can set how Mari masks different color values. For example, if you
use a displacement map channel as your mask source, you can adjust the mask value to mask out
everything except the darkest areas. This gives you a mask that covers everything except the “cracks”
in your mask texture.

For example, here's the result of different settings using this displacement map as a channel mask:

CONTROLLING THE WAY MARI APPLIES PAINT TO YOUR MODEL | MASK WHAT YOU CAN



USER GUIDE 83

Setting Result Notes

This paints into the dark areas
– the cracks in the texture.

This only unmasks the lightest
(that is, the highest) points in
the map.

You can also set the contrast for the mask. Mari applies this contrast to the mask channel when
producing the final mask.

TIP: Mari expects masks to be black on white. That is, colors are less masked as they
approach 0, more masked as they approach 1. However, if you prefer to paint your masks
white on black, you can invert the mask input.

To use channel masks, set the options under Channel Mask:

• Mask Channel - lets you select a channel to use as a mask (if you are using a channel mask, you'll
want to create and paint a mask in a channel first).
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• Mask Amount - controls the strength of the masked texture coming through, how much unmasked
texture to apply. For example, at 0.5, Mari applies the unmasked paint with alpha of 0.5.

• Mask Contrast - controls the contrast used on the mask texture. This controls how sharply defined
the mask is – at 1.0, this is just the original mask texture, lower values are fuzzier and higher values
are sharper.

• Mask Curve - controls how the input pixel values relate to the degree of masking. The horizontal
axis is the darkness of the input pixel (black to the left, white to the right), the vertical axis is the
degree of visibility. By default, this is a direct line, where white pixels are totally masked, black pixels
are totally unmasked, and 50% gray is 50% masked.

• Invert - applies the mask in reverse. Mari expects masks to be black on white, where the white
areas are masked and black is unmasked. However, if you prefer to paint white on black, you can
invert the mask input.

When enabled, the icon displays in the status bar.

TIP: If you want to turn channel masking off, just select the blank entry from the Mask
Channel list.

Ambient Occlusion Masks

The ambient occlusion mask lets you mask out the parts on your model that are covered by the
ambient occlusion. Ambient occlusion is a way of mimicking the soft shadows produced by natural
ambient light. The ambient occlusion mask lets you mask out the areas that are shadowed according
to this calculation.
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Shader showing the
ambient occlusion on this

part of the model.

Ambient occlusion mask -
the darker the area on the
original, the more it's

masked.

If required, you can invert the mask, so as to mask out all the areas not covered by the ambient
occlusion.

Before you use an ambient occlusion mask, you must calculate the ambient occlusion for the object.
See Calculating Ambient Occlusion for more details.

To use an ambient occlusion mask, set the options under Ambient Occlusion Mask:

• Mask Amount - is the amount of masking to apply. This is from 0 to 1; higher values mask the
areas that are covered by ambient occlusion, while lower values mask everything except the areas
that are covered by the occlusion.

• Mask Contrast - controls how sharply defined the mask is. At 1.0, the mask is precisely the same as
the ambient occlusion. Higher values mask the occluded areas more, lower values mask them less.

• Mask Curve - controls how the ambient occlusion pixel values relate to the degree of masking. The
horizontal axis is the darkness of the occluded pixels (black to the left, white to the right), the
vertical axis is the degree of visibility. By default, this is a direct line, where white pixels are totally
masked, black pixels are totally unmasked, and 50% gray is 50% masked.

• Invert - if this is selected, the mask data is black on white rather than white on black.

When enabled, the icon displays in the status bar.

Depth Masks

The depth mask masks out areas on the model depending on how deep they are in the scene (that is,
how far from the render camera). This lets you set start and end values and quickly mask out the
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region between them.

Using depth mask to mask out the far part of the object.

To turn the depth masking on, set the options under Depth Mask:

• Start - is how far through the scene the masking begins. This is a proportion of the entire scene in
the project, including all objects, lights, and so on.

• End - is how far through the scene the painting is completely masked.

• Falloff - sets how quickly the masking falls off between the start and end points. The interaction
between the three settings can be subtle - you may need to play around with different settings to get
the effect you want.

When enabled, the icon displays in the status bar.

TIP: For details on creating new channels, see Channels.

EXPERIMENT: Experiment with the masking options. Create a channel to use as a mask, then
use it to control where you can paint on the model. Try setting the falloff options for the
edge mask to minimum and maximum values. Try setting the falloff options so that the
forward facing areas are masked and the oblique areas are paintable.
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Backface Masks

Turning this on simply masks out the backfaces on your model – so you can't paint on them. There
are no other
configuration options.

Backface mask off. Backface mask on, masking
the inside of the lens.

To turn the depth mask on, next to Backface Mask, click to turn the toggle on.

When enabled, the icon displays in the status bar.

Fractal Noise Masks

The fractal noise mask is a user-controllable masking tool that uses generated noise to mask areas
on the surface of an object while painting.

Using fractal noise mask to mask where paint is applied to the surface of the object.
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To turn fractal noise masking on, set the options under Fractal Noise Mask:

• Seed - changes the pattern of the fractal noise mask by moving the pattern in 3D space.

• Contrast - controls the level of contrast applied to the fractal noise features to derive the mask.

• Roughness - determines the roughness of the fractal noise features.

• Size - Determines the size of the fractal noise features.

• Mask Amount - the amount that the mask affects the paint buffer. 1.0 means that the mask
absolutely controls where you can paint; the effects of the mask decrease as the value gets lower.

• Mask Curve - controls how the fractal noise relates to the degree of masking, based on the above
fields. This allows you to fine tune the contrast and pattern appearance of the fractal noise mask.

• Invert - if this is selected, the mask data is black on white rather than white on black.

When enabled, the icon displays in the status bar.

Set the Paint Blending Mode
1. In the Projection palette, scroll to the Painting section.

Mari displays the details of the current paint blending mode:

You can also set this in the Tool Properties toolbar.

2. Paint a stroke or two on your model (so you can see the effects of changing the settings).

3. Select a paint blending mode from the Painting Mode dropdown.

CONTROLLING THE WAY MARI APPLIES PAINT TO YOUR MODEL | SET THE PAINT



USER GUIDE 89

The paint blending modes available are similar to many other paint packages. If you aren't
familiar with the various modes, see Paint Blending Modes for descriptions and examples.

As you change modes, the paint in the buffer updates to show the effect.

EXPERIMENT: Play around with the blend modes. As you change them, see how the paint in
your buffer changes. Experiment with the results you can get with different blend modes,
how they work with
different types of brush strokes, paint alpha values, and so on.

Paint Blending Modes
Mari comes with several paint blending modes. The chart below uses the following example surface
and painting to illustrate the effect of applying the different modes:

Unpainted surface. Paint stroke in default
blend mode.

There are a number of shortcuts that can help you switch between Previous Blend, Last Blend, or
Next Blend modes (among others), as well as resetting the paint blend mode. For a list of available
shortcuts, please refer to Keyboard Shortcuts on page 466.

In the application, these effects are grouped by functional area (for example, all the light modes (hard
light, soft light, and so on) are grouped together). This list is alphabetical to make it easier for you to
find a description of a particular effect.
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Blend mode Description Example

Add Adds the values of the colors in the
paint buffer to the values on the layer's
surface.

Add Normal
Maps

Blends two RGB-encoded vector layers
with the Add input by converting the
raw values from the 0.0 to +1.0
colorspace-encoded range to the -1.0 to
+1.0 vector range, applying the blend
factor to the Over input, adding the
values, then normalizing the values
before converting it back to the 0.0 to
+1.0 colorspace-encoded range.

Burn Highlights Burns the layer based on the highlights
in the paint buffer.
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Blend mode Description Example

Burn Midrange Burns the layer based on the middle
range (that is, not the lightest or
darkest pixels) of the paint buffer.

Burn Shadows Burns the layer based on the contents
of the paint buffer, with darker pixels
being burned harder.

Clear Subtracts the opacity of the paint
stroke from the current surface. For
example, an 80% opaque stroke leaves
a surface with 20% opacity.
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Blend mode Description Example

Color Takes the luminance of the layer, and
the color and saturation of the paint
buffer.

Color Burn Burns the layer, using the contents of
the paint buffer as input for the burn
operation.

Color Dodge Dodges the layer surface, using the
contents of the paint buffer to control
the degree of dodging.
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Blend mode Description Example

Contrast The destination color moves away from
the painted color by contrasting around
the painted color. How much it
contrasts depends on the alpha.

Darken Gives each pixel the darker of two
possible values: the current layer
surface or the contents of the paint
buffer (whichever is darker).

Decontrast The destination color moves towards
the painted color by decontrasting
around the painted color. How much is
decontrasts depends on the alpha.

CONTROLLING THE WAY MARI APPLIES PAINT TO YOUR MODEL | PAINT BLENDING MODES



USER GUIDE 94

Blend mode Description Example

Difference Inverts the colors. Mari subtracts the
values in the paint buffer from those
on the layer surface.

Dodge Highlights Dodges the layer based on the
highlights in the paint buffer.

Dodge Midrange Dodges the layer based on the middle
range (that is, not the lightest or
darkest pixels) of the paint buffer.
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Blend mode Description Example

Dodge Shadows Dodges the layer based on the contents
of the paint buffer, with darker pixels
being dodged harder.

Exclusion Inverts the colors, but with a lowered
contrast.

Hard Light Mimics a harsh spotlight. Makes light
areas lighter (using a screen effect), and
dark areas darker (using a multiply
effect).
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Blend mode Description Example

Hard Mix First performs a vivid blend, then
thresholds the colors to their extreme
values. The result is that the pixels can
be one of eight colors - black, white,
red, green, blue, cyan, magenta, or
yellow.

Hue Takes the luminance and saturation
from the layer pixels, with the hue from
the paint buffer.

Inverse
Difference

Subtracts the colors in the paint buffer
from the layer surface, and then inverts
the result.
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Blend mode Description Example

Invert Uses the paint buffer as the input to
invert the pixels on the base layer.

Lighten Gives each pixel the lighter of two
possible values: the current layer
surface or the contents of the paint
buffer (whichever is lighter).

Luminance Takes the hue and saturation of the
layer color, and the luminance of the
paint buffer. (This is the opposite of the
Color blend mode.)
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Blend mode Description Example

Mix Normal Maps Blends two RGB-encoded vector layers
with the Mix input by converting the
raw values from the 0.0 to +1.0
colorspace-encoded range to the -1.0 to
+1.0 vector range, applying the blend
factor to the Over input, adding the
values, then normalizing the values
before converting the value back to the
0.0 to +1.0 colorspace-encoded range.

Mix Reoriented
Normal Maps

Blends two RGB-encoded vector layers
in a way that preserves the strength
and details of both the base and the
overlay inputs.

Multiply Darkens the color. Mari multiplies the
layer color by the color in the paint
buffer.
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Blend mode Description Example

Normal Replace values on the layer's surface
with those from the paint buffer.
(Mari's default mode.)

Nudge Flow
Vectors

Changes the paint buffer to tangent
vector space. Keeps the vectors flat to
the object’s surface in 2D space. The
Nudge Flow Vectors mode adds the
vectors together to get the blend result,
and is best for use with flow maps.

Nudge Normal
Vectors

Changes the paint buffer to tangent
vector space. Allows the z value to face
outward in 3D space, so that vectors
face out from the object’s surface
anywhere on the model. The Nudge
Normal Vectors mode adds the
vectors together to get the blend result,
and is best for use with normal maps.
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Blend mode Description Example

Overlay Uses the patterns and colors from the
paint buffer, but keeps the highlights
and shadows from the layer.

Adjustment stacks always use an
overlay blend mode.

Paint Flow
Vectors

Changes the paint buffer to tangent
vector space. Keeps the vectors flat to
the object’s surface in 2D space. Unlike
Nudge Flow Vectors, the Paint Flow
Vectors mode blends between the
vectors instead of adding them. This
mode is best for use with flow maps.

Paint Normal
Vectors

Changes the paint buffer to tangent
vector space. Allows the z value to face
outward in 3D space, so that vectors
can face out from the object’s surface
anywhere on the object. Unlike Nudge
Normal Vectors, the Paint Normal
Vectors mode blends between the
vectors instead of adding them. This
mode is best for use with normal
maps.
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Blend mode Description Example

Pin Light For light areas in the paint buffer,
replaces pixels on the layer's surface
that are darker than the corresponding
pixels in the paint buffer.

For dark areas in the paint buffer,
replaces pixels on the layer's surface
that are lighter than the corresponding
pixels in the paint buffer.

(Otherwise, leaves the layer surface
unchanged.)

Saturation Takes the luminance and hue of the
layer color, with the saturation from
the paint buffer.

Scale Vectors This is most useful with the basic Paint
tool, while preferably using grayscale
paint. Scale Vectors uses the intensity
of color to control the length of the
normal in 3D space.
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Blend mode Description Example

Screen Lightens the image. Mari divides the
color on the surface of the layer by the
value of the paint. (This is the opposite
of Multiply.)

Soft Light In dark areas on the layer, burns the
paint buffer onto the layer surface. In
lighter areas, dodges it on.

Sponge
Desaturate

Uses the paint buffer as the input to
desaturate the pixels on the base layer.
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Blend mode Description Example

Vivid Light In dark areas on the layer, adds the
paint buffer with more contrast. In light
areas, adds it with less contrast.

Paint Buffer Symmetry
You can mirror paint strokes in the paint buffer. On the Paint Buffer Symmetry toolbar, four
options control whether you want your paint strokes to be mirrored on the paint buffer axis and, if
so, how the paint strokes should be mirrored. The toolbar, shown below, appears in Mari alongside
other toolbars such as Lighting and Navigation.

The four options on the toolbar are included below, with example paint strokes illustrating the
symmetry for each option:
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Symmetry Option Description Example

Mari’s default paint buffer
setting is to have paint buffer
symmetry disabled.

Mirroring left and right divides
the paint buffer vertically. Paint
strokes created on either side of
the buffer mirrors the same
strokes on the other side.

Mirroring top and bottom
divides the paint buffer
horizontally. Paint strokes
created on either side of the
buffer mirrors the same strokes
on the other side.
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Symmetry Option Description Example

Mirroring four ways divides the
paint buffer into quadrants.
Paint strokes created in any of
the four quadrants mirrors in
the other three.

Painting in the paint buffer with symmetry enabled only applies to the actual paint strokes. If
mirroring is used while in Paint Through mode or while using the Clone Stamp tool, only the paint
strokes are mirrored; not the texture being painted through or cloned.

Paint buffer symmetry also mirrors only the paint buffer; it does not project paint onto the opposite
side of the geometry.
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Transforming and Warping Paint

Mari lets you transform and distort paint within the buffer with these four tools:

• Transform Paint

• Warp

• Slerp

• Pinup.

TIP: See Controlling the Way Mari Applies Paint to Your Model for details of how the paint
buffer works.

Move or Transform Paint
You can use the Transform Paint tool to resize and stretch the paint buffer as a whole. This lets you:

• resize the buffer (either proportionally or stretched),

• rotate it,

• or just move it around.

As you transform the paint buffer, its contents - that is, the paint as it appears on your model -
changes too. For example, you can paint a stroke, then stretch it, rotate it, and position it exactly on
your model, before finally baking it onto the layer.

To transform the paint buffer:

1. Start Mari and open your project.

2. Paint a couple of example strokes onto your model, so you can see the effects as you work.
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3. Click to select the Transform Paint tool .

4. To transform the paint, you can do the following:

To... You need to... Example:

Move the paint buffer around Click on the buffer and drag it.

Resize the paint buffer,
preserving the scale

Hold down Ctrl/Cmd+Shift,
click anywhere on the canvas
and drag.

Dragging to the left makes the
buffer smaller, to the right
makes it bigger.

Stretch the buffer (resize
without preserving scale)

Click on a side or corner of the
buffer and drag it.

Rotate the buffer Either:

• click outside the buffer and
drag, or

• hold down Ctrl/Cmd, click
inside the buffer, and drag.
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TIP: You can also make these transformations by manually editing the values under
Transform in the Paint Buffer section of the Painting palette. For example, editing the
Translation values moves the buffer around on screen, changing the Scale resizes the
buffer, and the Rotation control sets the rotation to specific degrees.

EXPERIMENT: Experiment with the various transformations you can make to the paint
buffer. Try stretching, rotating, and moving the buffer, then baking the paint onto the surface
of your model. Use both the Transform Paint tool and the controls under Paint Buffer in
the Painting palette.

Warp Paint Using a Grid

The Warp tool lets you warp a selected area within your paint buffer. You create a warp box - a
rectangle with between 4 and 64 control points.

Warp box with four control
points.

Warp box with 64 control
points.

You can then warp the paint buffer under the box by moving the control points around.

Initial transform box
(16 control points).

After some warping.
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To use the Warp tool:

1. If necessary, paint another couple of strokes on the model to experiment with.

2. Click to select the Warp tool .

3. Click and drag to create a rectangle to warp.

The warp rectangle displays, with nine control points, and a central rotation pivot (the large point
in the center).

TIP: After you draw a warp box, to replace it with another warp box: hold down Shift, click
and drag.

4. To warp your selection, you can do the following.

To... You need to... Example:

Increase or decrease
the number of control
points (up to 64)

press the Up or Down
arrow keys (á â).
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To... You need to... Example:

Move a single control
point

click and drag it.

Move multiple control
points

click and drag out a
rectangle covering the
control points, then click
one of the points and drag it
- the other points follow.

Rotate around the
central pivot

hold down the
(Windows) key, then drag
one or more points.

Move the central pivot
point

click and drag it. Be careful
to click on the pivot point
(the big circle), rather than
the central control point.
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To... You need to... Example:

Remove the current
warp

press ' (apostrophe).

5. To complete the warp, do one of the following:

• draw a new warp box (remember to hold down Shift when dragging to create the new box),

• change to another tool, or

• bake the paint.

TIP: You cannot undo individual stages of a warp. You can only undo the warp as a whole.

EXPERIMENT: Have a play with the warp tool. Try:

• moving one point

• clicking and dragging to select two points, then moving them together

• using the (Windows) key to rotate points.

Pull, Smudge, Grow, and Shrink Paint
The Slerp tool works like the Liquify tool in Photoshop®. It lets you “pull” the contents of the paint
buffer around.
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Initial contents of
paint buffer.

Body pushed in to
give a narrow waist.

Slerped using a big
brush tip in an S

motion.

Slerp uses a standard Mari brush tip, so you can fine-tune how to push things around. As well as
pulling, Slerp lets you grow, shrink, and rotate the paint. You can also use it to selectively erase
distortions you've already applied.

To use the Slerp tool:

1. The effects of the Slerp tool can be quite subtle, so we recommend you use a sample picture to
see them clearly. Use the Paint Through tool to drag a picture over the model, then stamp it
down with the ' (apostrophe) key.

2. Click to select the Slerp tool .

3. If it's not visible, show the Tool Properties toolbar. You can select the tool mode from the Mode
field:

4. Select from the Slerp mode selector to use Slerp as follows:
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To... You need to... Example:

pull paint around select the (default) Pull mode,
click and drag.

make the paint in a specific
area larger

select the Grow mode, click and
drag.

make the paint in a specific
area smaller

select the Shrink mode, click and
drag.
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To... You need to... Example:

rotate your paint around select the Rotate mode, click and
drag.

undo the distortion in a specific
area of the painting

select the Erase mode, click and
drag.

n/a

undo all the distortions you've
applied

press ' (apostrophe). n/a

apply your changes to the paint
buffer (that is, make them so
you can't erase the distortions)

press ; (semicolon). n/a

5. To complete the distortion, do one of the following:

• press ; (semicolon),

• change to another tool, or

• bake the paint.

TIP: As with the Warp tool, you cannot undo individual stages of a Slerp. You can only undo
the Slerp as a whole. Until you have completed the Slerp, using Undo actually undoes the
last completed action.

EXPERIMENT: Try using Slerp's various modes. Each mode has radius and opacity options
that you can change. Try adjusting these to see how dramatically that mode can change the
texture.
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Distort the Paint with Pins
The Pinup tool works like the Warp tool, but lets you set your own control points (pins) wherever you
want. Think of it as turning the paint buffer into a rubber sheet, which you can pull around with the
pins. You can use pins either to pull the paint around, or to hold it in place. So if you get a distortion
that you're happy with in part of the buffer, you can set some pins around it and other distortions
won't affect it.

You can move the pins around (either one by one or in groups), or rotate them around a central
point. You can also move the point of rotation.

Initial contents of
paint buffer, with
pins set. Point of
rotation is the
big white circle.

Pins on the legs
moved to the right,
distorting the buffer

but not around
the head.

The same pins
rotated to the right
instead of moved,

stretching
the buffer up.

You can also change the “strength” of each pin. This sets how much the pin affects the texture around
itself.

TIP: The Transform tool works on the entire paint buffer at once, while the Warp, Slerp,
and Pinup tools let you select which area within the buffer to work on.

To use the Pinup tool:

1. Clear the paint buffer, and use the Paint Through tool to stamp another example texture onto
your model.

2. Select the Pinup tool .

3. Use the Pinup tool as follows:
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To... You need to... Example:

add or remove a pin Shift-click.

select multiple pins click and drag around the
pins.

n/a

move pins around
(distorting the paint)

click on one of the selected
pins and drag.

rotate pins around the
central point of rotation

click on one of the selected
pins, hold down the
(Windows) key and drag.

move the central point of
rotation

click on the point of rotation
(big dot) and drag it.

n/a
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To... You need to... Example:

change the strength of a
pin

click on the pin to select it,
then press the Up or Down
arrow keys. As you increase
the strength of a pin, the
preview circle around the
pin gets bigger (or smaller
as you lower the strength).

n/a

remove all the current
pins

press Ctrl/Cmd+'
(apostrophe).

n/a

undo all the distortions
you've applied, moving
the pins back to their
original positions

press ' (apostrophe). n/a

apply your changes to the
paint buffer and remove
all current pins

press ; (semicolon). n/a

4. To complete the distortion, do one of the following:

• press ; (semicolon),

• change to another tool, or

• bake the paint.

TIP: As with the Warp tool, you cannot undo individual stages of a Pinup. You can only undo
the Pinup as a whole. Until you have completed the Pinup, using Undo actually undoes the
last completed action.

• Using pins is also hard to describe but quite easy to get the hang of. Try doing the
following:

• Create some pins.

• Drag one pin around.

• Select multiple pins and drag them around.

• Rotate pins.

• Move the point of rotation, and rotate pins around the new point of rotation.

• Increase and decrease the strength of individual pins. See how stronger pins affect the
texture more.
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Towing Paint Around
The Towbrush is similar to the Healing Brush and Patch tools in Photoshop®. It lets you select areas
of paint and drag them around the surface of your model. As you tow the paint around, it blends the
edges of your selection with the surrounding paint. It works like the Clone tool, but blends in the
edges of the cloned selection.

Put simply, it lets you grab paint and move it around on the surface, automatically blending in the
edges as you go.

Original surface. Mole cloned and moved,
broken veins moved.

The Towbrush has three modes, allowing you to:

• Clone - clone from the selected region to another part of the surface.

• Heal - overwrite the selected region with another part of the surface.

• Move Feature - swap the contents of the selected region with another area on the surface.

There are limits to the amount of blending the Towbrush can do: as with the Healing Brush in
Photoshop®, it's not magic. But it's very good at working with surfaces with regular textures, such as
skin, rock, stone, and so on.

Select and Tow Paint
1. Start Mari and open your project.

2. If you have any unbaked paint on your model, either bake it or clear the buffer.

The Towbrush only works on baked paint.

3. Click to select the Towbrush tool.

4. If it's not visible, show the Tool Properties toolbar. You can select the tool by clicking the icons:
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Select the mode from:

Clone – clones from the selected region to another part of the surface. This is the default
mode.

Heal – overwrites the selected region with another part of the surface. That is, it clones
the texture under your mouse over the selected area.

Move Feature – swaps the contents of the selected region with another area on the
surface.

5. Click and drag on your model to select the area to tow.

You can drag any
shaped area.

When you release the
mouse,

the selection area
completes.

6. Click on the selection area and drag it around.

As you tow the selection, the edges blend in with the surrounding texture.

7. You can adjust the settings for the Towbrush. You can set the:

• Falloff - controls how the texture blends in from the edges of the patch. Higher values have
sharper transition to the surrounding texture, lower values blend in more smoothly. Use { and }
to lower and raise the falloff.

• Value - how much of the color of the original patch to preserve. Higher values keep more of the
original color, lower values blend the whole patch in with the background as you move it. Use [
and ] to lower and raise the value.

8. To fix any mistakes:

• If you want to clear your current selection, press ' (apostrophe).

• If you want to undo a clone/move, just clear the paint buffer.

9. Bake your changes.

If you want to paint multiple strokes with the Towbrush tool, you must bake between each move.
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EXPERIMENT: As the Towbrush blends its edges dynamically, it's hard to see unless you
actually have a go with it. Experiment with the brush and see what results you can get on a
variety of textures.
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Copying and Pasting Paint

Mari lets you:

• copy and paste single patches quickly, or

• copy multiple patches at once.

In both cases, you can copy between channels. When copying multiple patches, you can copy to other
objects in your project.

Copying and Pasting Single Patches
Mari's quick copy function lets you copy a single patch and then copy it back onto the same object (on
any channel). You can paste the copied patch back onto multiple target patches.

1. Select your source patch.

This only works with single patches. You cannot copy multiple patches at once.

2. From the Patches menu, select Quick Copy.

3. Select your destination patch(es).

This can be on the same layer or a different layer on the same object.

4. From the Patches menu, select Quick Paste.

If you selected multiple patches, you may see a warning. If you choose to go ahead, the source
patch is pasted across each of the target patches.

Mari pastes a copy of the source patch onto the destination.

Depending on how different the shapes of the two patches are, you can probably expect to see
some blank areas or artifacts at the edges of the patch.

TIP: You can also find these options on the right-click dropdown menu on the canvas.
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Copying and Pasting Multiple Patches
Mari's Copy Multiple Textures function lets you copy entire patches between places in your project.
You can copy patches:

• between objects,

• between layers on the same object, or

• between patches on the same layer.

You can only copy textures on a patch-to-patch basis – you cannot copy one patch onto more than
one other patch at once.

You can also use an offset. This is added to the source patch number to determine where to paste the
texture to. For example, if you copied the texture on patch 1001 with an offset of 20, the texture
would copy to patch 1021.

So, for example, if your model has a consistent numbering scheme, you can use this to paste from
one side of the model to another. As you do this, Mari reverses the textures.

Here, we paint a couple of black stripes on the face, and then select patch 1002:

Black stripes painted. Patch 1002 selected.

If we copy patch 1002 back onto the same channel, with an offset of 20, the paint copies to patch 1022
(the corresponding patch on the other side of the model's face). Mari reverses the texture as it pastes.
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To copy and paste multiple patches:

1. From the Patches menu, select Copy Textures.

The Copy Multiple Textures dialog box displays:

2. Set the details of where to take the textures from:

• Source Object and Source Layer set the location of the source patches.

• Set the Select By field to the patch numbering scheme you want to use to select the patches to
copy.

• In the Source Range field, enter the numbers for the patches to copy. You can separate patch
numbers with commas, or use a hyphen to indicate a range. For example, this:

1001, 1003, 1005-1007

selects patches 1001, 1003, 1005, 1006, and 1007.

3. Set the details of where to copy the textures to in the Target Object and Target Layer fields.
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Both these fields can be the same as the source versions.

4. If required, set an Offset. This is added to the patch numbers when copying them. For example:

• With an offset of 0, patch 1001 is copied to patch 1001 in the target layer.

• With an offset of 20, patch 1001 is copied to patch 1021 in the target layer (which can be the
same as the source layer).

5. Click OK to copy the textures.

Mari copies the textures to the designated object, layer, and patches.
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Editing Paint on Layers
When you paint in Mari, you paint into the paint buffer - which floats above the surface of the model.
Only when you bake is the paint actually applied to the model's surface.

Mari's Blur tool lets you edit the baked surface of a layer, while the Clone Stamp tool includes a
mode to clone paint directly up off the surface of the layer into the paint buffer.

Blur Paint on a Layer
The Blur tool lets you apply a blur effect directly to the surface of your channel. You can use the Blur
tool the same way as any other Mari brush, to apply a normal blur effect to any part of the surface.

Texture before blurring. After blurring.

TIP: If you want to blur large areas of the surface, you may want to use the blur filters
instead. These apply a controlled blur to entire patches. Mari includes several blur filters,
including a controllable Gaussian blur. For details, see Filtering Images and Paint.

To use the Blur tool on paint:

1. Start Mari and open your project.

2. Select a layer with some paint on it.

3. Select the Blur tool .

4. Click and drag to blur your paint.
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EXPERIMENT: Experiment with different brush settings to see how this affects the final
result. Particularly, try changing the brush:
-size
-shape
-opacity (affects the strength of the blur).

Pulling Paint into the Buffer
The Clone Stamp tool has a mode that clones the surface of the current layer up into the paint buffer
directly above the surface. This lets you grab the baked paint and make changes.

See Clone stamp for details on using the Clone Stamp tool to clone the layer surface into the paint
buffer.
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Vector Brush
The Vector Paint brush is useful for editing vector maps and painting directional information onto
your models. With the vector-specific paint blends, paint is converted to tangent space. The vectors
are then represented as diffuse RGB values. This results in specifically-colored paint strokes that
represent color-encoded vectors.

In addition to using the Vector Paint brush, the basic Paint brush can be used together with vector-
specific paint blending modes to achieve different effects.

Viewing vectors is especially important for the creation of flow maps and normal maps. Flow maps
can assist in
creating realistic textures or materials that simulate direction-specific patterns, such as feathers,
scales, fur, hair, and water flow (to name a few). These have a pattern that tends toward a particular
direction, or lie against another object in a particular manner, your textures should reflect this. Once
you have identified how you want the effect to appear on your model, you can create flow maps that
provide this information.

Arrows indicate the direction
of the feathers on the swan’s
body, which vectors should

mimic.

Arrows show the direction of
painted vectors, which

indicate the flow of vectors.

For example, in the image on the left, the feathers on the swan are determined to be following the
curve of the neck. This impacts the feather pattern, so that the vectors in the texture curves around to
display the natural flow pattern. In the image on the right, the vectors have been painted on the
image to show how this flow pattern might appear.
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Painting Vectors
Begin by starting Mari and opening your project.

1. Make sure you have a paintable layer selected, then select the Vector Paint tool.

2. In the Shaders palette, ensure that the channel you are using for your vector paint is selected in
the shaders Vector shader component.

3. If you want to see the directional markers while you paint, select the Vector Inspector icon in
the Vector toolbar.

4. Select a brush from the Brush Editor palette. Once you have set up the brush options, paint in a
direction across the surface of the model.

A specific color is selected depending on the direction of your brush stroke.

NOTE: Think of the four main colors as being the four cardinal points on a compass. These
have specific colors to represent their directions. Strokes between these points are blends of
the two colors. The four main colors are:

• Left to Right: (RGB: 1, 0.5, 0.5)

• Right to Left: (RGB: 0, 0.5, 0.5)

• Top to Bottom: (RGB: 0.5, 1, 0.5)

• Bottom to Top: (RGB: 0.5, 0, 0.5)

These colors may vary depending on the lighting model you are using and any adjustments
that are selected, for instance the Tangent to Screen adjustment. You may find it useful to
paint vectors while using a Flat lighting model to make accurate vector painting easier.

Modifying Vectors with Paint Blending Modes
Seven unique paint blending modes allow you to specify how the vectors are baked onto a model.
These paint blending modes are not for exclusive use with the Vector Paint tool, but can also be
used with the basic Paint tool. These modes are available in the paint blending mode dropdown
menu in both the Paint and Vector Paint toolbars and the other paint tools, such as CloneStamp
and Paint Through.

The Paint Flow Vectors and Paint Normal Vectors modes are an alpha blend between the vectors.
The Nudge Flow Vectors and Nudge Normal Vectors modes add the vectors together to get the

VECTOR BRUSH | PAINTING VECTORS



USER GUIDE 130

blend result. The paint flow and paint normal modes convert the painted vectors into the texture’s
tangent space before creating the associated blend. This conversion takes into account the
orientation of the texture on the model’s surface.

NOTE: Due to the fact that surface orientation plays such an important role, vectors baked
down on a model may not be exactly the same as vectors painted. For example, a paint
stroke from left to right on a model with a very high curvature may produce quite large
changes in color when baked.

However, the Scale Vectors mode works differently to the above four modes. This mode uses the
intensity of the color to control the length of the vector, and works best when painting in gray scale,
with black representing short vectors, white representing long vectors, and gray being between the
two. Paint Scale Vectors with the basic Paint tool.

The flow and normal vector modes refer to how the vectors are allowed to act in xyz space. Flow
modes keep the vectors flat against the surface of the model. Normal modes allow the vectors to
protrude outwards from the model in tangent z space. The type of vectors you want to paint may
influence which paint blending modes you use. For example, flow modes are most often going to be
used for flow maps, while you may prefer using normal modes for creating normal maps.

The Add Normal Maps and Mix Normal Maps modes blend two RGB-encoded vector layers with
either the Add or Mix inputs and the Over input. Before the operation is performed the raw values
are converted from the 0.0 to +1.0 colorspace-encoded range to the -1.0 to +1.0 vector range. The
values are then added and normalized before converting back to the 0.0 to +1.0 colorspace-encoded
range.

For more information on how to use these paint blending modes, see Paint Blending Modes on page
89 in the chapter on Controlling the Way Mari Applies Paint to Your Model.

To adjust the paint blending mode, follow these steps:

1. With unbaked paint on your model, select one of the following modes from the Painting Mode
dropdown menu:

• Paint Flow Vectors,

• Paint Normal Vectors,

• Nudge Flow Vectors,

• Nudge Normal Vectors,

• Scale Vectors,

• Add Normal Maps,

• Mix Normal Maps, and

• Mix Reoriented Normal Maps.
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2. Selecting a paint blending mode can be done in either the Paint or Vector Paint toolbars, as the
dropdown menu is in both. Alternatively, select them from the Painting Mode dropdown in the
Projection palette.

NOTE: As with other paint blending modes, the vector modes apply to paint that has not
been baked down yet.

To use a layered workflow, where you paint multiple layers of vectors and blend them together, the
normal painting steps do not produce the results you might have expected, due to Mari's layers using
premultiplied alpha. To blend a vector layer with the vector layer beneath it in the layer stack:

1. Create a new layer.

2. Fill it with a neutral vector color, thus making the layer opaque. A neutral vector color for normals
is 0.5, 0.5, 1.0, and for flow it is 0.5, 0.5, 0.5, as described in more detail in Painting Vectors on
page 129.

3. Paint on the new layer.

To blend with the layer below, add a layer mask and paint into it in order to show or hide the layer
below.

4. Select a blend mode.

A layer's alpha values are no longer affected by premultiplied alpha and the vector blending
results for your layers should now be correct.

Inspecting Your Vector Work
The Vector Inspector tool allows you to see directional markers representing the vectors you are
brushing onto the model. These markers ensure that you can see the effects of the vector brush or
paint blending modes to achieve the effect you want. Vector lines can be turned on or off at any time,
as well as adjusted to change the properties, such as spacing. Like the paint buffer, the Vector
Inspector can be moved around the canvas or rotated using
keyboard shortcuts.
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To inspect your vector brush work, follow these steps:

1. Select the Vector Inspector tool .

The directional markers appear.

NOTE: The Vector Inspector displays the channel that is selected in the Vector shader
component of your current shader. If there is nothing selected in the Vector shader
component, the shader displays the diffuse channel.

2. You can move the buffer around the canvas by simply dragging it around. You can also use the
Tool Help
shortcuts to modify it.

3. The Vector Inspector toolbar includes the following options:

• Enable - selecting this checkbox enables or disables the directional markers of the Vector
Inspector. Note that while in the Vector Inspector tool, this is not the case. The markers
remain on until you change to a

different tool. If you don’t have the tool active and want to enable markers quickly, click the
icon on the Vector Painting toolbar.

• Line spacing - adjusts the space between the directional markers.

• Line length - adjusts the length of the directional markers.
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• Start Color - changes the color at the base of the directional marker.

• End Color - changes the color at the tip of the directional marker.

• Vector Space - sets whether the vector space is converted to either Screen Space, Tangent
Space (no change), or World Space. Screen space is the most useful option for painting flow
and normal maps.

4. In addition to the options on the toolbar, the following options are listed on the Tool Properties
palette when the Vector Inspector tool is active:

• Rotation - lets you adjust the rotation of the inspector buffer by either entering a value in the
entry box or adjusting the slider.

• Translation - adjusts the translation (position) of the inspector buffer.

NOTE: The Rotation and Translation options are both available in the Tool Help shortcuts
whenever the Vector Inspector tool is active.

Adding Vector Shaders
There is a method for quickly setting up default vector shaders and channels, with vector layers in the
Layers palette. This method is accessible from two locations in the UI and is described fully in the
Adding Vector Shaders section.

This shader setup creates two default shaders in the Shaders palette for creating flow maps and
normal maps. The Vector (Screen Space) shader is for viewing vector (colors) in tangent space, while
the Vector (World Space) shader is for viewing vector (colors) in world space. These shaders come
with channels already plugged into the shader component inputs by default to get you started.

To create vector brush default shaders, follow these steps:

1. Open the Shaders palette to manage newly-created shaders.

2. Create a default vector shader by either:

• clicking the icon on the Vector Painting toolbar, or

• navigating to Python | Examples > Setup Vector Brush.

Clicking the icon or script automatically creates two shaders in the Shaders palette, three
channels in the
Channels palette, and the necessary layers for each channel in the Layers palette.

The default created shaders are Vector (World Space) and Vector (Screen Space), and each of
these have the newly-created channels set to the corresponding shader component inputs.

During shader setup, the following three channels are created in the Channels palette:

• Vector (Paint),
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• Vector (World Space), and

• Vector (Screen Space).

NOTE: Running the script changes the Painting Mode to Paint Flow Vectors and switches
the paint tool to Vector Painting, if this is not already selected.

EXPERIMENT: If you prefer, you can create the shaders and channels manually. To do this:

1. Create the channels you want to use for your vector painting and add the Vector,
Tangent To Screen, or Tangent To World adjustments and procedurals in the Layers
palette.

2. Create your shaders and assign your vector channels to the Diffuse Color and Vector
shader inputs. For example, the default vector shaders assign the Vector (Screen Space)
channel to the Diffuse Color input and the Vector (paint) channel to the Vector input.

3. Once you’ve set up the shaders, go back to the Vector (Paint) channel and begin painting
your normal or flow maps in the Vector layer.

Adding Vector Adjustments and Procedurals
There are three adjustments and one procedural in the Layers palette that allow you to set up your
project for vector painting. The adjustments are Tangent To Screen, Tangent to World, and Flow.
These adjustments are where you can paint flow and normal maps within a set channel for your
vector painting. The Flow procedural acts as an adjustment would, and allows you to use your vector
paint as surface flow over time. Input an image, preferably a tileable one, into the Tile Image field to
apply a texture to your model for viewing flow maps. The Time Offset slider represents the flow of
time, while the Speed slider represents the sensitivity of Time Offset.

Adjusting the scale and then dragging on the offset slider, allows you to see the effects your vectors
play on the flow map, and you can enable the Animation attribute to see the flow over time.

There is also the procedural, Vector, that allows you to specify the properties for your vector
visualization. Vector allows you to specify another color using the sliders in the layer properties.

For more information on what these shaders are and how to use them, see Adding Vector Shaders,
and Layer Types and Examples in the Layers section.

Select one of the following default channels created with the setup vector brush script described in
the Adding Vector Shaders instructions:

• Vector (Paint)
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• Vector (World Space)

• Vector (Screen Space)

Notice that the layers created by the setup vector brush script already show Vector, Vector
(Tangent To World Space), or Vector (Tangent To Screen Space) layers in the Layers palette.

If you aren’t using the setup vector brush script, and want to add new adjustments or procedurals,
follow the steps below.

To add vector adjustments to your project:

1. Select the channel from the Channels palette that you are using in the shader component inputs
described in Adding Vector Shaders, and open the Layers palette.

2. Add an adjustment:

• From the Layers menu. Navigate to Add Adjustment Layer.

• By right-clicking on any layer in the Layers palette. Navigate to Add Adjustment Layer.

• From the Layers palette. Click the adjustment icon and select either Tangent To Screen,
Tangent To World, or Flow from the dropdown list.

3. Adjust the properties in the layer attributes pane of the Layers palette.

To add vector procedurals to your project, follow these steps:

1. Select the channel from the Channels palette that you are using in the shader component inputs
described in Adding Vector Shaders, and open the Layers palette.

2. Add a procedural:

• From the Layers menu. Navigate to Add Procedural Layer.

• By right-clicking any layer in the Layers palette. Navigate to Add Procedural Layer.

• From the Layers palette. Click the procedural icon and select Basic > Vector from the
dropdown list.

3. Adjust the properties in the layer attributes pane of the Layers palette.

NOTE: For a full description of the layer properties for both adjustments and procedurals,
see the Layer Types and Examples section in the chapter on Layers on page 222.

Changing the File Space
Though vectors are often measured in the range -1.0 to +1.0 to represent the vectors in xyz space,
Mari operates in the range 0.0 to 1.0. In order to accommodate vector brushing, the -1.0 to +1.0 range
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is converted into 0.0 to 1.0, and the specific RGB values that indicate vector directions are adapted to
reflect this. Thus, -1.0 becomes 0, 0.0 becomes 0.5 and +1.0 stays as it is. The colors are converted to
the corresponding number on the 0 to 1 scale to keep all the vector data the same.

In the Channels and Image Manager palettes, File Space fields allow you to set whether the channel
or image should be exported as a Normal file (in the way Mari stores them), as a Vector file (-1.0 to
+1.0 range), or as a Vector (flipped Y) file, which is the same as the Vector file in terms of range, but
inverts the vectors in the Y direction. This allows you to easily export inverted vectors for use in other
parts of your pipeline. Channel or image files exported in the Vector file space format can later be re-
imported and changed back to the Normal file space format if desired.

NOTE: For Vector (flipped Y) this only inverts the vectors in the Y direction. The vectors in
the X or Z direction are not changed.

Changing the file space before exporting can be done on channels, images and paintable layers. This
converts the file space range from 0 to 1 (the Mari convention), to -1.0 to +1.0 (Vector convention) or -
1.0 to +1.0 with inverted Y
vectors (Vector inverted convention). To change the file space on channels, follow these steps:

1. Open the Channels palette and select the channel you want to change.

2. Under Channel > Format | File Space, click the dropdown menu and select either Normal,
Vector, or Vector (flipped Y).

The file space is changed in all paintable layers in the channel except for shared layers.

To change the file space on images, follow these steps:

1. Open the Image Manager palette and select the image you want to change.

2. Under Image Info > MriImage > Info | File Space, click the field and select either Normal,
Vector, or Vector Y Flip from the dropdown menu.

Creating FlowMaps on Multiple Objects
It may often be necessary to create flow maps for different objects in a project, effectively separating
the vector data into more than one channel. Following the steps below prevents the vector markers
from appearing on multiple objects when attempting to focus on creating flow maps on only a single
object.

1. Set up a basic channel on objects that do not need flow maps, in the Channels palette, by either:

• right-clicking on the palette and selecting Add Channel from the dropdown menu, or

• clicking on the add channel button.

Mari displays an Add Channel dialog box.
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NOTE: Ensure that you have the correct object(s) selected before you begin, to avoid creating
any unnecessary channels on the wrong object.

2. Create a channel, called "gray" or similar, and set the Color to mid-gray (RGB: 0.5, 0.5, 0.5). Create
the channel for only the selected object, for this example, called Object A.

Using the gray Quick Channel can simplify the process, but if you have multiple quick channels
in the
Channels palette, make sure you rename it to avoid any confusion when setting up the shader in
the instructions below.

TIP: Create the channel or quick channel with a 256x256 Size to avoid taking up unnecessary
space.

3. Set up vector default shaders by navigating to Python > Examples > Setup Vector Brush or by

clicking the icon in the Vector Painting toolbar.

The script creates two default shaders, and associated channels and layers in each of the
Shaders, Channels, and Layers palettes. These allow you to quickly set up the shaders for vector
painting and flow maps.

4. With Object A still selected, in the Shaders palette, select the Vector (World Space) shader that
was created by the vector default shader script.

The Diffuse Color shader component should already be filled in.

5. Click on the dropdown menu for the Vector shader component and select the "gray" channel you
created in the Channels palette.

The Vector shader component, when set up this way, blocks out the vector inspector markers on
objects you don’t want to create a flow map for.

6. Lock Object A by clicking on the padlock icon in the Objects palette. Due to the fact that
vector paint can still be applied to the object - even if vector inspector directional markers aren’t
shown - this ensures you don’t paint over your textures.

7. Select a second object for which you want to create a flow map. For this example, the second
object is called Object B. Create default vector shaders, channels, and layers using the script in
step three above.

The Vector (Paint) channel is already set to the Vector shader component in the Vector (World
Space) and Vector (Screen Space) shaders. This allows you to see the flow map channel where
the vector markers are present, without affecting other objects.

8. If you don’t already have them activated, turn on the vector painting directional markers by

clicking on the icon in the Vector Painting toolbar before painting your flow maps.
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If you paint on the model now, paint is applied to all unlocked objects. However, only objects with the
Vector (Paint) channel listed in the shader’s Vector shader component field show the vector
inspector markers.

NOTE: For more information on shaders and shader components, please see the chapter on
Shaders on page 299.
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Exporting and Importing
Textures

Importing is how you can pick up an existing set of textures to work on. Similarly, exporting is how
your work moves on into the next step in the pipeline:

• Importing loads images into the current channel or layer, or as new channels and layers on your
model.

• Exporting saves out the paint on your model as a set of image files (one file per UV patch).

Exporting and importing can be done for both a single channel or layer, as well as multiple channels,
layers, even objects in a project. In essence, you can:

• export or import the entire channel (including all layers),

• export or import selected layers, and

• export all channels or objects in a project, or all layers in a layer stack.

Mari supports standard image formats for export and import (such as .tif, .exr, .psd, .png, .jpg, .tga,
and .dds). You can find a full list of supported file formats in the import and export dialogs.

NOTE: When exporting .dds files, they should be encoded as 8.8.8.8 ARGB files to avoid any
complications when bringing them into Mari.

When you create a set of new channels, either when creating your project or when using the Channel
Presets button, you can import a set of existing textures. See Channels on page 279 for more
information.

Import Existing Textures to Channels
1. Start Mari and open your project.

2. To import, select a channel from the Channels palette and do one of the following:

• from the Channels menu, select Import > Import into Layer Stack to import textures into the
current layer stack of the selected channel, or

• from the Channels menu, select Import > Import into New Channel from the Channels menu
to import textures into a newly created channel.
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If you select Import into Layer Stack the Import dialog displays. If you select Import in New
Channel the Add Channel dialog displays first, allowing you to set the options for the new
channel, before opening the Import dialog.

3. Now you can select Import Individual Files, or Import a Sequence of Files.

NOTE: For more information on setting the options for a newly-created channel, please see
Create and Delete Individual Channels.

TIP: The Import menu options are also available from the right-click dropdown menu on the
main canvas and in the Channels palette.

Import Individual Files

If the object has less than 20 UV patches, the Import dialog box has a Named Files tab. This lets you
individually pick which files to load for each patch.

1. Click on the Named Files tab.

The tab shows all the patches on the object.
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2. For each patch, set the file you wish to import.

You can either:

• type the file path and name directly, or

• use the open button to open a navigation window to find the file.

You can now set resize details and import the textures.

TIP: By default, if your model has more than 20 patches, the Named Files tab does not
display.

To change this, set the Patch Cutoff preference to a number greater than the number of
patches in the file. Alternatively, you can use the MARI_NAMEDFILEIMPORT_
SEQUENCELIMIT environment variable to override the preference setting. Please see the
section on Environment Variables That Mari Recognizes for more information on
environment variables.

Import a Sequence of Files

If your patches have a consistent naming/numbering system, you can import them as a sequence.

1. Click on the Sequence tab.

The tab shows all the patches on the object.
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2. Enter the location of the files to import in the Path field.

NOTE: This isn’t the name of the files themselves. It’s the name of the directory in which the
sequence of files exists.

You can either:

• enter the full path to the directory containing the files (or pick from the dropdown), or

• use the navigation controls to navigate to the directory:

3. When you've selected the path, the file area shows all the existing image sequences under that
path.
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4. You can use the Filter field to narrow down the list of textures shown. Enter filter text, and the
display updates to only show the textures with that text in their name.

5. Set a Template for Mari to use when gathering the names of images in the selected sequence.

You can either:

• Edit this line manually. As you edit, you'll see the File Example update with the name of an
example file in the sequence.

• Click on an existing set of images in the main list. The Template automatically populates with
the
corresponding values.

If you edit the line manually, you can use any of the following variables, which Mari replaces with
the appropriate values when it imports the images:

• $ENTITY - the name of the object.

• $CHANNEL - the name of the channel.

• $LAYER - the name of the layer.

• $UDIM - the UDIM patch value.

• $FRAME - the animation frame number.

• $NUMBER - the number of the file within the batch (for example, “$NUMBER of $COUNT” gives
strings like “22 of 28”).

• $COUNT - the total number of files in the channel.

• $[METADATA VALUE] - any user-defined variables (for example, if a patch has a user attribute
called “PROJECT”, with a value of “Project1”, Mari replaces the variable “$PROJECT” with
“Project1”).

NOTE: For more information on how the UDIM patch values are allocated, please see the
section on Using UDIM Values.

NOTE: If you choose to import a layered .psd file, layers are imported directly into the
selected channel. If attempting to import layers with the same name, Mari asks whether to
update the layers or create new ones. You can now set resize details and import the textures.

6. Set theColorspace in which you want to export the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel.

7. Set howMari handles patch/image sizemismatches in theResize field. You can select either to resize the
Images to match the patches, or to resize the Patches to match the images.

8. In theAlpha Channels field, choose to eitherKeep orRemove the alphawhen importing channels. This can
help decrease the resulting file size when exporting.
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9. Click Import All Patches to import the textures or, if at least once patch is selected, this appears
as Import Selected Patches.

Mari imports the images and loads them into the layer stack of the selected channel.

Import Existing Textures to Layers
1. Start Mari and open your project.

2. To import, select a layer from the Layers palette and do one of the following:

• from the Layers menu, select Import > Import into Layer to import textures into the currently
selected layer, or

• from the Layers menu, select Import > Import into Layer Stack to import textures into the
layer stack as a newly created layer.

The Import dialog displays.

3. Now you can select Import Individual Files, or Import a Sequence of Files, following the steps
described previously in this chapter.

NOTE: The Import into Layer Stack option occurs in both the Channels and Layers
menus, and the right-click menus in either palette. The result of importing textures into the
selected channel’s layer stack occurs regardless of which menu option you use.
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TIP: The Import menu options are also available from the right-click dropdown menu on the
main canvas and in the Layers palette.

Export Textures from Channels
Once you've finished working on your textures, to export the files (for example, for use in the next
stage of the pipeline) select the channel(s) you want to export.

From the Channels menu, select Export or Export Flattened.

1. To export the channels without flattening them, do one of the following:

• from the Channels menu, select Export > Export Current Channel to export the currently-
selected channel, or

• from the Channels menu, select Export > Export All Channels to export all channels in the
Channels palette, or

• from the Channels menu, select Export > Export Everything to export all channels for all
objects in the
project.

2. To flatten the channels before exporting them, do one of the following:

• from the Channels menu, select Export Flattened > Export Current Channel Flattened to
flatten and export the currently-selected channel, or

• from the Channels menu, select Export Flattened > Export All Channels Flattened to flatten
and export all channels in the Channels palette, or

• from the Channels menu, select Export Flattened > Export Everything Flattened to flatten
and export all channels for all objects in the project.

The Export dialog displays.
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3. Now you can select Export Individual Files, or Export a Sequence of Files.

TIP: The Export and Export Flattened menu options are also available from the right-click
dropdown menu on the main canvas and in the Channels palette.

Export Individual Files

If the object has less than 20 UV patches, the Export dialog box has a Named Files tab. This lets you
individually pick the patches to export, and where to export them.

1. Click on the Named Files tab.

The tab shows all the patches on the object.
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2. For each patch, set the file to export it to.

You can either:

• type the file path and name directly, or

• use the open button to open a navigation window to create a new file in a directory, or select
an existing one to overwrite.

You can now Set Small Texture Preferences and Export the textures.

TIP: By default, if your model has more than 20 patches, the Named Files tab does not
display.

To change this, set the Patch Cutoff preference to a number greater than the number of
patches in the file. Alternatively, you can use the MARI_NAMEDFILEIMPORT_
SEQUENCELIMIT environment variable to override the preference setting. Please see the
section on Environment Variables That Mari Recognizes for more information on
environment variables.

Export a Sequence of Files
1. Click on the Sequence tab.

2. Enter the location to export the files to in the Path field. You can either:

• enter the full path to the directory (or pick from the dropdown), or

EXPORTING AND IMPORTING TEXTURES | EXPORT TEXTURES FROM CHANNELS



USER GUIDE 148

• use the navigation controls to navigate to the directory.

3. When you've selected the path, the file area shows all the existing image sequences under that
path.

4. You can use the Filter field to narrow down the list of textures shown. Enter filter text, and the
display updates to only show the textures with that text in their name.

5. Set a Template for Mari to use when generating the names of images in the selected sequence.

You can either:

• Edit this line manually. As you edit, you'll see the File Example update with the name of an
example file in the sequence.

• Click on an existing set of images in the main list. The Template automatically populates with
the
corresponding values.

If you edit the line manually, you can use any of the following variables (which Mari replaces with
the appropriate values when it exports the images):

• $ENTITY - the name of the object exported.

• $CHANNEL - the name of the channel exported.

• $LAYER - the name of the layer exported.

• $UDIM - the UDIM patch value.

• $FRAME - the animation frame number.

• $NUMBER - the number of the file within the batch (for example, “$NUMBER of $COUNT” gives
strings like “22 of 28”).

• $COUNT - the total number of files in the channel.

• $COLORSPACE - the chosen colorspace for the selected images.

• $[METADATA VALUE] - any user-defined variables (for example, if a patch has a user attribute
called “PROJECT”, with a value of “Project1”, Mari replaces the variable “$PROJECT” with
“Project1”).

6. Set the Use Template For field to determine if the template above is used for Only this layer (the
selected layer in the channel’s layer stack) or Everything (to include all layers in the stack).
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7. Set theColorspace in which you want to export the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel.

8. Set the Small Textures field to determinewhether or not Mari exports any patches filled with a constant color
as 8x8 pixel textures, nomatter what resolution the patches are in Mari. Enabling Small Textures saves disk
space if you're exporting a channel that hasn't been fully painted. Disabling Small Textures letsMari always
export patches at their full size (even if they haven't been painted).

9. In theAlpha Channels field, choose to eitherKeep orRemove the alphawhen importing channels. This can
help decrease the resulting file size when exporting.

10. You can now Set Small Texture Preferences and Export the textures.

Exporting to a Layered .psd File

If you want to export the channels in your project to a layered .psd file, simply change the file
extension to .psd in the Export dialog.

NOTE: When exporting multiple channels to a layered .psd file, all channels must have the
same resolution and bit depth. The $CHANNEL Template environment variable does not
work when exporting multiple channels to a layered .psd file. You can now Set Small Texture
Preferences and Export the textures.

EXPERIMENT: Experiment with the different Template variables, and see how the File
Example changes to show how Mari generates exported filenames.

Set Small Texture Preferences and Export
1. Select whether to enable Small Textures.

With the small textures dropdown set to enabled, Mari exports any patches filled with a constant
color as 8x8 pixel textures, no matter what resolution the patches are in Mari.

• Enabling Small Textures saves disk space if you're exporting a channel that hasn't been fully
painted.

• Disabling Small Textures lets Mari always export patches at their full size (even if they haven't
been painted).

2. Click Export All Patches to export the textures.

Mari exports your textures to disk in the background.

3. To check the progress of the export click the icon at the bottom right of the main window.

Mari shows the export progress.
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Export Texture from Layers
Instead of exporting work on whole channels, you may wish to export only a selection of layers by
selecting them from the list in the Layers palette. As with channels, you can export multiple layers as
they are in your layer stack or flattened into a single file.

From the Layers menu, select Export or Export Flattened.

1. To export layers without flattening them:

• from the Layers menu, select Export > Export Selected Layers to export the currently selected
layers, or

• from the Layers menu, select Export > Export All Layers to export all layers in the layer stack.

2. To flatten the layers before exporting them:

• from the Layers menu, select Export Flattened > Export Selected Layers Flattened to flatten
and export the currently selected layers, or

• from the Layers menu, select Export Flattened > Export All Layers Flattened to flatten and
export all layers in the layer stack.

The Export dialog displays.
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3. Now you can select Export Individual Files or Export a Sequence of Files from this chapter.

NOTE: Since exporting all the layers in a layer stack would be the equivalent of exporting an
entire channel, the Export All Layers and Export All Layers Flattened options in the Layers
menu exports the same result as the Export Current Channel and Export Current
Channel Flattened options in the
Channels menu.

TIP: The Export Flattened menu options are also available from the right-click dropdown
menu on the main canvas and in the Layers palette.

Importing and Exporting Ptex Files
As Mari supports .ptx files, it is also possible to import and export Ptex files in Mari. This can only be
done for a Ptex project. However, unlike the steps described in this chapter, importing and exporting
Ptex files behaves a little differently.

For more information on how to import and export Ptex files, see Export a Ptex Channel or Layer or
Import a Ptex Channel or Layer in this guide.
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Export toMaya
Mari can also export data for use in Maya. It does this by exporting textures and creating a custom
.ma file that
references them. All exported files contain UDIM offsets so that Maya can import and read the UV
patches correctly.

To create the .ma file for use in Maya follow the steps below:

1. Navigate to Menubar | Python > Examples > Export for Maya.

The Mari To Maya Export dialog displays.

2. In the Output Folder pane, either enter the filepath or click Browse to find the location to which
you would like the files to be exported.

3. From the list in the left pane, select which channels you want to export.

4. Once you have selected the channel and the filepath, click + (plus).

The selected channel and filepath are added to the For Export pane on the right.

5. If you have added a channel by mistake, or want to edit the filepath, simply select the channel
from the For Export pane and click - (minus).

6. At the bottom of the dialog, the 8-bit Files and 16/32-bit Files dropdown menus list all of the file
formats in which you can export your channels for use in Maya. Before you select OK, make sure
you set your desired file format.

If you have already exported these files to the same file location, you can opt to select the Force
Overwrite checkbox to export over and replace them.

7. Select OK.

Your channel is exported to the selected file location in your choice of file format. The textures,
regardless of whether they are diffuse or displacement, are exported as UV patches.
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Using Your Textures in Maya

Once the .ma file has been created, you can load your textures into Maya. Follow the simple steps
below to set up your textures:

1. In your Maya scene, import the .ma file that was created after export from Mari.

This can be found under the directory you saved the exported file to.

2. Navigate to your Hypershade. You should now see that for each channel you exported out of Mari,
a Lambert shader was created containing the channel.

3. You can hook up the layered texture element to different parts of your other, independent shader
to achieve the desired look.
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Storing Resources Using Shelves
You can store just about anything you can grab from within Mari in Shelves. Most artists like to store
their favorite brushes, colors, and images (for clone stamping or painting through). Power users can
also add any preset Mari function to a shelf.

By default, the Mari Shelf palette comes with six shelves:

• Menu - items that you can select from the F9 pie selection control menu.

• Personal - selected items you use regularly.

• Basic Brushes - a set of predefined basic brushes.

• Hard Surface Brushes - a set of predefined hard surface brushes.

• Organic Brushes - a set of predefined organic brushes.

• Project - items just for the current project.

You can also create any number of customized shelves.

Your shelves display in both the Shelf palette and on the Shelves tab in the Brush Editor (see
Configuring Brushes on page 35). You can also make any shelf into a separate, custom palette. Mari
also lets you export and import entire shelves and items within shelves, for example to share with
other users.

TIP: For details on using the pie selection control menu, see Using Shortcuts.

Open Shelves
1. Start Mari and open your project.

2. If the Shelf palette is not already open:

• from the View menu, select Palettes > Shelf, or

• right-click in the toolbar area and select Shelf from the dropdown menu.

The Shelf palette displays.
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TIP: The default layout in Mari has the Shelf palette already open.

As described above, the Shelf starts with six default shelves: Menu, Personal, Basic
Brushes, Hard Surface Brushes, Organic Brushes, and Project. The Menu and Personal
shelves are empty when you first start Mari. The Project shelf only displays when you have a
project open (and is empty when you start a new project).

Add a Brush to a Shelf
To add a brush to a shelf:

1. Open the Brush Editor palette:

• from the View menu, select Palettes > Brush Editor, or

• right-click in the toolbar area and select Brush Editor from the dropdown menu.

The Brush Editor palette displays.
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2. On the Presets tab, click to display the tab in the Brush Editor with the brush you want to copy.

3. Click the shelf in the Shelf palette you want to copy the brush to (Personal, Project, or Create a
Custom Shelf).

4. Drag and drop the brush from the Brush Editor to the Shelf palette.

You now have easy access to that brush whenever you want to use it.

TIP: You can also change the properties of a preset brush, and then save it to your Personal
shelf, using the BrushEditor - see Configuring Brushes.

Add a Color to a Shelf
To add a color to a shelf:

1. If the Colors palette is not already open:

• from the View menu, select Palettes > Colors, or

• right-click in the toolbar area and select Colors from the dropdown menu.

The Colors palette displays.
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TIP: The default layout in Mari has the Colors palette already open.

2. Click the shelf in the Shelf palette you want to copy the color to (Personal, Project, or Create a
Custom Shelf).

3. When the color you want to copy is in the Foreground or Background color swatch, drag and
drop it from the Colors palette to the shelf where you want to store it.

TIP: The swatch on the shelf only holds the color values, not the alpha. Swatches on shelves
always have an alpha of 1.0. You can also drag and drop color swatches from anywhere else
they appear in Mari (such as the Properties palette or Select Color dialog box).

You can display a large array of color swatches in a shelf by minimizing the icon size: right-
click anywhere in the shelf, and select Toggle Icon Size from the dropdown menu. Icons
switch from large to small (or the other way around).

Add an Image to a Shelf
To add an image to a shelf (for example, for painting through or clone stamping):

1. If the Image Manager palette is not already open:

• from the View menu, select Palettes > Image Manager, or
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• right-click in the toolbar area and select Image Manager from the dropdown menu.

The Image Manager palette displays.

TIP: The default layout in Mari has the Image Manager palette already open. (Click to give it
focus.) See Managing Images for instructions on loading images into the Image Manager.

2. Click the shelf in the Shelf palette you want to copy the color to (Personal, Project, or Create a
Custom Shelf).

3. Drag and drop an image from the Image Manager to the shelf where you want to store it.
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TIP: You cannot copy temporary, cropped images from the Image Manager to a shelf -
unless you save them first.

Below is an example of a color, brush, and image copied to the Personal shelf.

TIP: You can rename an item in a shelf, by double-clicking its name and typing over. You can
also drag any item from any shelf to the Personal, Project, or custom shelves.

Create a Custom Shelf
To create custom shelves (for example particular sets of color swatches, images, or brushes):

1. In the Shelf palette, click at top left.

The Create New Shelf dialog box displays.

2. Type a name for the shelf and click OK.
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The new shelf displays at right in the Shelf palette.

Modify Custom Shelves and Their Contents
The Shelf palette includes a right-click dropdown menu with options to rename, delete items from,
and assign
shortcut keys to items in the Personal, Project, or custom shelves. (It also includes features to
Import and Export Shelves and Items.)

TIP: Some of the customization features are not available for some of the preset brushes
shelves (their name and contents cannot be changed).

1. To rename a shelf, right-click anywhere in the shelf and select Rename Shelf.

The Rename Shelf dialog box displays.

2. Type the new name, and click OK.

Mari renames the shelf.

3. To delete an item from a shelf, right-click it and select Delete Item.

Mari removes that item from the shelf.

4. To assign a shortcut key to an item in a shelf, right-click it and select Assign Shortcut.

The Assign Keyboard Shortcut dialog box displays.
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TIP: Resize columns and the dialog box to better view shelf names and the Shortcut
column.

5. Double-click in the Shortcut column for the selected item, type a shortcut key, and click OK.

You can now use that shortcut to select that item.

6. To delete a shelf, open it, and click at right. Mari asks you to confirm deleting the shelf and all
its contents.

7. Click OK.

Mari deletes the shelf.

EXPERIMENT: As a learning exercise, try this:

• create a custom shelf,

• rename it,

• add an item to it,

• rename the item,

• delete the item, then

• delete the shelf!

Import and Export Shelves and Items
You can import and export shelves, and items in shelves, for example to share with other Mari users.

TIP: You can “Import” or “Load” all items from an exported shelf into a selected shelf.
“Import” means to add the items you're importing to those already there, and “Load” means
to replace all items there with the ones you're loading.

1. To export a shelf, right-click anywhere in the shelf and select Save Shelf.

The Save Shelf dialog box displays.

2. Navigate to where you want to save the shelf, give it a name, and click Save.

Mari saves the shelf as an .msh (Mari shelf) file.

3. To import all items from a shelf that's been exported, into the Personal, Project or a custom
shelf, right-click anywhere in that shelf and select Import Shelf.

The Import Shelf dialog box displays.

4. Navigate to the folder that contains the .msh file you want to import, select it and click Open.

Mari adds that shelf's items to the selected shelf.
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5. To replace all items in the Personal, Project or a custom shelf, with items from a shelf that's
been exported, right-click anywhere in that shelf and select Load Shelf.

Mari warns you that all items in the current shelf will be replaced.

6. Click OK.

The Load Shelf dialog box displays.

7. Navigate to the folder that contains the .msh file you want to load, select it and click Open.

Mari replaces all items in the selected shelf with those from the shelf you loaded.

8. To export an item from a shelf, right-click it and select Save Item.

The Save Item dialog box displays.

9. Navigate to the folder where you want to save the item, give it a name and click Save.

Mari saves the item as an .msi (Mari shelf item) file.

10. To import an item that's been exported, to the Personal, Project or a custom shelf, right-click
anywhere in that shelf, and select Load Item.

The Import Shelf dialog box displays.

11. Navigate to the folder that contains the .msi file you want to import, select it and click Open.

Mari adds that item to the selected shelf.

NOTE: Importing custom Photoshop brushes automatically displays them in Mari in a
custom shelf. For details on importing custom brushes into a new shelf, please refer to
Import a Custom Photoshop Brush on page 48.

EXPERIMENT: Another learning exercise:

• create a custom shelf,

• add an item to it,

• export the item,

• export the shelf,

• create another custom shelf,

• import the item you exported from the first shelf into the second shelf,

• import all items you exported from the first shelf into the second shelf (import shelf),

• replace all items in the second shelf with the items you exported,

• from the first shelf (load shelf), and

• delete both shelves!
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Create a New Shelf Palette
To turn any shelf into a custom palette, select the shelf and click on the left. Mari creates a new
palette for that shelf.

TIP: Mari adds “spawned” palettes to the View > Palettes and the dropdown Palettes
menus. If you rename a palette, Mari renames it in all places (Shelf palette, spawned palette,
and menus).

EXPERIMENT: Spawn a couple of shelves and drag items between them. Try adding an item
to the spawned palette and see how this affects the original shelf.

Add Any Mari Function to a Shelf
To add any Mari function to the Personal, Project or a custom shelf:

1. From the Edit menu, select Shortcuts.

The Manage Keyboard Shortcuts dialog box displays.
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TIP: Resize columns and the dialog box to better view the names and descriptions of Mari
functions.

2. Click to expand the hierarchical list of Mari functions (actions, tools, palettes, and so on.)

3. Click to open the shelf you want to drag a function to.

4. Drag and drop the function from the Manage Keyboard Shortcuts dialog box to the shelf.
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Selecting Items

Mari has two selection tools:

• Select - this lets you select areas on the model(s) in your project. You can select whole objects,
patches, or areas on the surface of the objects.

• Marquee Select - this lets you select areas on the screen.

The Select tool lets you select areas on the objects in your project. Once you have made a selection,
you can choose to show or hide the selected areas, or to lock them for editing.

Area selected on the model

The Marquee Select tool lets you select an area onscreen, to control where you can apply paint.
When you've made a selection with the Marquee Select tool, paint only bakes down within the
selected areas.
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Marquee Select - paint only shows within the selection area.

TIP: This works like the Select tool when ProjectOn is set to Selected, except that you're
selecting areas on the screen rather than on your model.

You can't use the MarqueeSelect tool to select areas to show/hide or to lock.

Selecting Objects, Patches, or Faces
Mari has three selection modes. These control how you select things in your project, from whole
objects to sections of surface.

Mode Description Example

Object lets you select whole objects at a
time. Clicking on an object selects the
whole of that object - every patch,
every point on it.

SELECTING ITEMS | SELECTING OBJECTS, PATCHES, OR FACES



USER GUIDE 167

Mode Description Example

Patch lets you select individual patches on
an object. Clicking on a patch selects
only that patch (and all points within
the patch).

Face lets you select object faces. You can
use standard marquee and loop
select tools to select parts of your
objects.

In all three modes, you can add to, or remove from, the current selection. You also have the option of
selecting all items or none, or invert the current selection.

In Face selection mode, you can grow or shrink the current selection.

Initial selection. Selection grown. Selection shrunk.

The smart selection mode of the Select tool (when in Face selection mode) lets you create selections
based on the surface of the model. Similar to how Photoshop's magic wand tool lets you select areas
of similar color, this lets you select areas that face in the same direction.

You can base your smart selection on:

• Connectedness

• Edge Angles
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• Orientation

You can use the selection to control where paint can bake onto the surface of your model. If Project
On (on the
Projection palette) is set to Selected, then Mari only bakes paint onto selected areas.

To use the Select tool:

1. Start Mari and open your project.

2. Choose the Select tool .

3. You can use the Selection toolbar to switch selection modes.

If you can't see the Selection toolbar, right-click on the toolbar area and choose Selection from
the dropdown menu.

4. Set the selection mode.

In this mode You can...

Object click on an object to select it.

Patch click on a patch to select it, or click and drag a selection to select
all the patches under that selection.

Face click and drag to make the selection.

5. On the Tool Properties toolbar, set the selection details to Facing - selecting the (visible) front of
the model, or to select “through” the model, including the back side - or the selection tool shape.

The tool shape can be either:

• a square selection box,

• a lasso selection (allowing you to draw any shape of selection),

• a polygonal lasso selection (allowing you to draw any shape in the form of a polygon), or

• smart selection (letting you select areas based on the shape of the model).

Smart selection only works in Face selection mode.

6. Click and drag to make your selection.

7. You can use modifier keys to add to, remove from, or invert the selection:
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Hold down... To... Effect

Shift Add to the selection Areas that were unselected become selected,
areas that were already selected stay selected.

Ctrl/Cmd Remove from the selection Areas that were selected become unselected,
areas that were already unselected stay
unselected.

(Windows) Intersect the selection Areas that overlap with the current selection
become unselected, areas that were unselected
become selected.

8. You can select all, none, or invert the current selection. Use the buttons on the Tool Properties
toolbar, the options in the Selection menu, or the right-click menu on the canvas.

9. In the Face selection mode, use the Grow and Shrink buttons to change the size of the current
selection.

You can use the Grow/Shrink by field to set how these work. Edges grows along the edge of the
current
selection, Vertices grows using the vertices as a guide.

TIP: You can only grow the selection up to the edge of the patch(es) that your face selections
cover.

The Smart Selection mode works slightly differently from the other two modes. To use it:

1. In Face Selection mode, click .

2. In the tool properties toolbar, set the Smart Type. This sets how to create the selection area:

• Connectedness - selects the areas on the model connected to the selected face. When you look
at the area in the UV view, this selects the whole connected area within the current UV patch. If
the UV patch holds several different areas, only those areas you click on are selected.

• Edge Angle - selects based on the degree of change between neighboring faces. The selection
goes until it hits an angle higher than the Smart Angle.

• Orientation - selects the area that faces in the same direction as your initial selection.

• Selection Group - selects the whole selection group that the selected face belongs to. If the
selected face does not belong to a selection group, nothing happens. If a face belongs to more
than one selection group, clicking repeatedly cycles through the other selection groups to which
it belongs.

3. Set the Smart Angle - this defines the maximum angle for the smart selection.
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• For Edge Angles, this sets the maximum angle between areas on the model surface. For
example, if the angle is set to 30, this selects areas up to a 30 degree change of facing.

• For Orientation, this sets how far from the facing of your original selection the selection goes
to. For example, if the angle is set to 30, this selects areas up to 30 degrees away from the facing
of your original selection.

4. Click and drag to make the selection.

Mari creates a selection around the area you drag.

Alternatively, if you set Selection Group for the Smart Type, click a face on the canvas repeatedly
to cycle through the selection groups to which it belongs. The selections groups are selected in
the Selection Groups palette and the selection group is highlighted on the model.

Alternatively, you can use the buttons on the Tool Properties toolbar to quickly select patches. To do
this:

1. In Patch Selection mode, click any of the selection modes in the Tool Properties toolbar
(Rectangle, Lasso, Smart).

2. To quickly select all patches, click the button on the Tool Properties toolbar.

All patches on your current object are selected.

3. To quickly clear your selection so that none of your patches are highlighted, click on the

button on the Tool Properties toolbar.

Any patches you have selected are unselected.

Hiding and Locking

You can show or hide things based on whether they are selected. For example, you can select a patch
or area on an item, and then hide everything not selected.

Similarly, you can lock objects and areas based on whether they are selected or not.

1. In either the Patch or Face selection modes, select an area on your model.

2. From the Selection menu, select Hide Unselected.
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Mari hides everything except your selection.

You can clear the selection, and the other areas remain hidden.

3. Conversely, from the Selection menu, select Hide Selected.

Mari hides only the selected areas.

4. To show the hidden patches again, from the Selection menu, select Show Selected, Show All, or
Show Entire Object, to restore visibility of faces.

5. To lock the selection so that you can't paint on the locked areas, from the Selection menu, select
Lock Selected.

Mari locks the selection. Try painting a few strokes over the model - the paint does not “stick” to
the locked areas.
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6. As with hiding, you can also lock the inverse of your selection by selecting Lock Unselected from
the Selection menu, or if you want to lock the whole model in order to work on something else,
you can Lock All.

7. To unlock the selection, from the Selection menu, select Unlock Selected, or unlock the whole
geometry by selecting Unlock All.

8. If you’ve locked multiple patches, faces, and even objects and want to quickly unlock everything in
your project, select Unlock Entire Object from the Selection menu.

TIP: You can also show/hide and lock selections from the right-click menu on the canvas.

Saving Selections on theModel
Mari lets you save selections and come back to them later. Once you've made a selection (in any
mode - objects, patches, or faces), you can create a selection group. Clicking on a selection group
selects the items in that group.

Example of a selection group containing patches
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Example of a selection group containing faces

You can use this to set up face selections of specific areas on your model, and then to reuse these
selections. This lets you define your own selection areas for relevant features that aren't necessarily
reflected in how the patches on the model are put together. For example, you could use this to create
a selection for the blacksmith's deltoid muscle, or his collarbones.

1. With the Select tool, create your selection.

You can select in any mode - object, patch, or face.

2. Right-click on the selection. From the dropdown menu, pick Create Selection Group.

3. Open the Selection Groups palette.

This displays all the selection groups for your project.
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4. Click to select a selection group.

When you click on the selection group, Mari changes to show that selection. You can switch
between selection groups by clicking them in the list, or by selecting a face in the canvas, when
the Smart Type is set to Selection Group, and clicking on it repeatedly to cycle through the
selection groups to which it belongs.

Object groups can be added to selection groups. You can create up to 200 of these groups.

NOTE: If you have Smart Type set to Selection Group, and have clicked on a face but
nothing happened, the face may not belong to any selection groups.

If you have a selection group highlighted in the list, but have used the Select tool to make another

selection, you can reload the selection group by clicking on the button. You can also lock and
unlock selection groups, as well as showing and hiding them.
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To... Click on...

lock the selection group

unlock the selection group

hide the selection group

show the selection group

TIP: You can also create patch selection sets by right-clicking on your selection and selecting
Create Patch Selection Set. This can also be done in the Patches palette by right-clicking
on your selection and selecting Create Set.

You can add selections to or subtract selections from a selection group by using modifier keys to
adjust what selections are visible on the canvas. This allows you to view which faces or patches are
selected, or create a new selection group from existing groups.

1. To add selection groups together, select a selection group from the Selection Groups palette
then Shift+click on another selection group.

The canvas updates to display the two selection groups as they would appear if they were one
group, by adding the first selection in the palette to the second.

2. To subtract a selection group from another, select a selection group from the Selection Groups
palette then Ctrl/Cmd+click another selection group.

The canvas updates to display the first selection group without any of the selections from the
second group.

Selecting Areas Onscreen
There are also quick menu items for selecting large areas on your model at once. In the Selection
menu, you can opt to:

• Select All - to select all of an object, patch or face.

• Select None - to de-select patches and faces.

• Select Invert - to select the inverse of the selected area.

• Select Visible - to select the visible area of a patch, face, or object.
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Alternatively, use the Marquee Select tool to select an area onscreen, rather than on the model. The
Marquee Select tool lets you build up your selection (adding and removing to the selection as
required), then transform it – moving it around, rotating it, or resizing it.

1. Paint a few strokes onto your model, so you can see the effects when you start drawing marquee
selections.

2. Select the Marquee Select tool .

3. In the Tool Properties, select the tool type. You can select a rectangle, lasso, ellipse, or wand.

Tool Lets you

Draw a rectangular selection.

Draw the outline of your selected area. You can draw any shape you
want.

Draw the outline of the selected area by setting points for the polygon
sides and double-clicking or clicking the original point to close. You can
draw any shape you want.

Draw an elliptical selection.

Select by color. When you click, Mari creates a selection around the
point you clicked. The selection is based on color – areas with a similar
color to the original point are selected. You can change the color
threshold for the selection.

TIP: For the Polygonal Lasso mode, you can also close the selection by pressing Enter or
double-clicking on the canvas.

4. Click and drag to create your initial selection.
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Initial buffer, with
unbaked paint.

Marquee select - only the
paint within the selection is

visible.

5. To edit the shape of the selection, change the Mode in the Tool Properties. You can set this to:

Mode Does Notes

Replace the new selection replaces the
existing selection.

In Replace mode (the default), you can:

• hold down Shift, click and drag to add to
the current selection, or

• hold down Ctrl/Cmd, click and drag to
remove from the current selection.

Transform lets you move your selection area
around (move, rotate, or scale the
selection)

In Transform mode, you can:

• hold down Shift, click and drag to move
the current selection,

• hold down Ctrl/Cmd, click and drag to
rotate the current selection, or

• hold down Shift+Ctrl/Cmd, click and drag
to scale the current selection.

6. If you want to soften the edges of the selection, turn up the Feathering. Higher values give the
selection a softer, fuzzier edge. At 0, the selection has a hard edge.

7. In Wand mode, you can change the Color Threshold (how close the colors need to be to be
selected when you click). At 0, only areas of the exact shade as the pixel you click on are be
selected. As the value increases, more
colors are selected when you click.
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Moving and Distorting Marquee Selections

To move or distort the selection, set the Mode to Transform.

To Do this: Example

move the
selection

hold down Shift, click and drag

rotate the
selection

hold down Ctrl/Cmd, click on
your desired point of rotation,
and drag

scale the selection
up or down

old down Shift+Ctrl/Cmd, click
and drag
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Working With Patches
Models that you paint in Mari are divided into patches. You can change the properties of the patches,
such as the patch resolution. You can also edit patches as a whole - by copying and pasting between
patches, filling patches with color, or flipping the paint on them.

Patch Resolution
Each patch on a channel is stored at a particular resolution. Resolution is a determination of how
many pixels are used for an item. For example, a patch may have a resolution of 512 x 512. This patch
is stored as an output file 512 pixels wide by 512 pixels high. Higher resolutions take more memory
and require more storage, but provide more detail.

Resolutions available in Mari range from 256 x 256 to 32k x 32k (32768 x 32768). Resolutions in Mari
are always “square”, with the width equal to the height.

You set the resolution for a channel when you create it. You can however change the resolution later,
for example downsizing if you find the file's getting really big and you don't need so much detail, or
upsizing if the shot focuses on something that you find needs more detail. You can either:

• change the resolution of the entire channel at once (that is, all patches in the channel), or

• resize specific patches within the channel.

Changing the resolution of a patch in one channel does not affect the resolution of the same patch in
another
channel. For example, a particular patch could be at 512 x 512 in the bump channel and 2k x 2k in the
diffuse channel. All layers in a channel or patch are resized when the channel or patch is resized, but
you cannot resize individual layers.

TIP: For more details on working with channels, see Channels.

Patch Limit
Mari has a technical limit of how many patches it can accurately handle, which is primarily based on
the graphics card you are using. For NVIDIA and AMD cards, the limit is 4096 patches, while for Intel
the limit is 1024 patches. The patch limit primarily affects the visibility and locking ability of patches,
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as well as the ability to select through faces. You may be able to work with more patches than the
stated limit, if you are not using this functionality but it isn't recommended and correct behavior
cannot be guaranteed.

Changing Patches as a Whole
Mari lets you change patches as a whole. You can:

• copy textures from one patch to another

• fill patches with a single color

• rotate or flip the paint on a patch

• mirror paint from one side of a patch to the other

• link patches together.

Here's an example.

The original patch Flipped horizontally or rotated 90 degrees
counter-clockwise.

TIP: Edits to patches only apply to baked paint. Unbaked paint in the paint buffer is not
affected.

When you are copying patches onto other patches, unless your patches are identically shaped, you
can see:

• blank areas at the edges, where the texture from the source patch runs out due to the change of
shape, and

• traces of the “overpaint” around the edges of the patch.

You can also see these when transforming paint on patches unless your patches are square.

The overpaint is used to ensure that the patches fit together without visible gaps. You can view the
overpaint for patches in the UV view. Turn the UV paint display on in the Display Properties dialog
box (right-click on the canvas, select Display Properties from the dropdown menu, and turn on
Render UV Image).
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Note the blank patches and “bleed” from the overpaint areas.

The original patch. Rotated 90 degrees.

Paint transforms only apply within each patch. If you have more than one patch selected, each patch
transforms independently. For example, if you flip two side-by-side patches horizontally, each patch
flips separately.

Two patches selected. Flipped horizontally.

View and Resize Patches
1. Start Mari and open your project.

2. To open the UV view, click either the UV or Ortho/UV tab at the top of the canvas.

The UV view displays all individual patches on the model, and labels the patches with the size
format in an abbreviated mode, such as 4K instead of 4096x4096. The label also lists all active
patch sizes in a comma-separated list.
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3. Zoom in to view the details of a specific patch more easily.

Once you zoom in enough, Mari displays the patch details (such as resolution and color depth).

4. If you select one or more patches and you want to switch the view to display all of the selected
patches, press A.

Mari focuses the view on the patches that are selected.

If you don't have any patches selected, the view focuses on the model as a whole (changing to
show the whole model).

TIP: If you find that the view starts cutting through the front clipping plane, try pressing A.

Resize Patches
1. Select the patch(es) to resize.

TIP: You can select the patches in any view - you don't have to be in the UV view to do this.

2. From the Patches menu or the right-click dropdown menu on the canvas, select Resize Selected
and then a resize option. You can select a specific resolution from the list (up to the maximum
resolution for the channel), or choose to halve or double the resolution.

If you try to double the size of a selection already at the channel's maximum resolution or halve
the size of one at 256 x 256, nothing happens.

NOTE: If attempting to resize patches in a channel that contains layers shared from other
sources, the shared layers are not resized; all other layers in the channel are resized.

NOTE: If you don’t select a patch or a layer when resizing, Mari asks if you want to resize all
patches or layers before continuing.
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Using UDIM Values
Each patch represents one square unit in UV space; for instance, a square with dimensions 1x1. UDIM
values are a way of representing the integer coordinates of that square, from the coordinates of its
bottom-left corner in UV space.

Channels can contain up to ten patches across, and any number of patches upwards. This means that
patches can have U indices between 0 and 9 inclusive, and V indices can be zero or any positive
integer. With these values, the UDIM for a patch can be calculated using the formula:

udim = 1001 + u + (10 * v)

NOTE: The U index limit of ten is currently hardwired.

The UDIM value of the bottom-left patch, which represents the UV space region (0,0) to (1,1), is 1001.
The next patch to the right has a UDIM value of 1002, and the patch directly above the bottom-left is
1011. For example, the patch representing the UV space region (2,5) to (3,6) has a U index of 2 and a V
of 5, so replacing the values in the formula, we get:

udim = 1001 + 2 + (10 * 5) = 1053

Copy and Paste Patches
See Copying and Pasting Paint for details on how to copy and paste individual patches.

Extract Patches to the ImageManager
To extract one or more patches to the Image Manager:

1. Select the patches to extract.

2. From the Patches menu, select Extract Selected, or right-click on the canvas and select Patches
> Extract Selected from the dropdown menu.

Mari copies the patches to the Image Manager. See Managing Images.
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TIP: You can only copy patches up to 8K resolution.

Fill Patches with Color
To fill one or more patches with a color:

1. Set either your foreground or background color to the color you want to fill.

See Managing Colors for details on selecting colors.

2. Select the patch(es) to fill.

3. From the Patches > Fill menu, select either:

• Black - to fill the patches with a constant black color.

• Gray - to fill the patches with a constant gray color.

• White - to fill the patches with a constant white color.

• Foreground - to fill the patches with the foreground color.

• Background - to fill the patches with the background color.

• Transparent - to make the patches transparent.

• UV Mask - to make patches a UV mask.

• Wireframe - to fill patches with a wireframe.

Mari fills the patches with the selected color, mask, or wireframe.

Flip and Rotate Painting
1. Select one or more patches with baked paint.

See Selecting Items for details on selecting patches.

2. From the Patches > Transform menu, select the transformation:

• Flip Vertical - to flip the selected patch(es) vertically.

• Flip Horizontal - to flip the selected patch(es) horizontally.

• Rotate 90 CCW - to rotate the selected patch(es) 90 degrees counterclockwise.

• Rotate 90 CW - to rotate the selected patch(es) 90 degrees clockwise.

• Rotate 180 - to rotate the selected patch(es) 180 degrees.

NOTE: The transform functions in the Patches menu are applied to selected patches for the
current and selected layers. If you don’t select a patch or a layer, Mari asks if you want to
apply the transform to all patches or layers before continuing.
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Mirror Painting
1. Select a patch with baked paint.

See Selecting Items for details on selecting patches.

2. From the Patches > Mirror menu, select the mirror operation:

• Mirror Left to Right - to mirror the selected patch from left to right.

• Mirror Right to Left - to mirror the selected patch from right to left.

• Mirror Top to Bottom - to mirror the selected patch from top to bottom.

• Mirror Bottom to Top - to mirror the selected patch from bottom to top.

NOTE: The mirroring functions in the Patches menu are applied to selected patches for the
current and selected layers. If you don’t select a patch or a layer, Mari asks if you want to
mirror to all patches or layers before continuing.

EXPERIMENT: Experiment with flipping, rotating, and mirroring patches. Apply paint first to
see what happens to the paint when the patch is changed.

Save Images of the UVMasks
Mari has a function that allows you to save an image of the outline of a UV mask. You can then save
these images for use as a mask in another program, if required.

Patches selected in UV view. B/W UV masks in the Image
Manager.

1. Select one or more patches.

See Selecting Items for details on selecting patches.

2. From the Patches menu, select UV mask to Image Manager.

Mari takes a snapshot of the UV outlines on the selected patches and puts it into the Image
Manager. It
creates a separate image for each patch selected.

You can now use the images or save them to disk. See Managing Images for details on using the
Image Manager palette.
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Bleeding Across Patch Edges
By default, Mari creates an overspill area at the edge of UV patches to prevent seaming. In some
cases, the overspill may not be large enough to prevent seaming artifacts, or you may get render
artifacts if your renderer expects a
larger bleed area.

For example, from some angles, Mari's blacksmith tutorial asset shows a seaming artifact in the hair
just above the left ear when viewed front on. This is because the bleed for that edge of the UV patch is
slightly too small.

From front on, you can see a
slight line at the patch edge.

This is caused by a too small
overspill edge.

TIP: You can view the overspill bleed by turning on Show UV Patches in the Display
Properties dialog box.

If you are experiencing problems with seaming artifacts (either within Mari or after rendering) try
conducting a full patch bleed. This extends the bleed area across the entire UV patch.
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UV patch after full bleed. And the artifact is
eliminated.

NOTE: Mari does not do a full bleed by default because it takes much longer to calculate.

For performance reasons, Mari divides large patches into smaller, more manageable 256x256 tiles.
When baking paint into a channel, Mari always performs an individual edge bleed for every tile
affected by the paint. The bleed operation fills the tile but does not affect surrounding tiles.

When bleeding is done per tile, some exceptional conditions may occur depending on how the tile
lines up with the geometry shell:

• As bleed width is extended from the shell to the tile boundary, it may vary depending how close the
shell boundary is to the tile boundary.

• Resizing a patch changes the tile grid causing it to line up differently with the geometry shell, which
can affect bleed results.

• Tile corners that just touch the outer shell of the geometry can result in unexpected bleed behavior.

Edge bleeding per patch is different because it renders the entire patch first and then performs a full
bleed on it. This avoids the conditions mentioned previously but requires much more memory and
processor time, especially when bleeding large patches.

The per tile method is the default behavior and ensures that normal paint-bake operations are
performed quickly. Full patch bleeding should only be used in situations where exported tile-bled
patches are causing problems in third party applications.

If you see seaming artifacts at the edge of your patches, try doing a full bleed across the affected
patches.

1. Select the patches to bleed.

See Selecting Items for details on selecting patches.

2. From the Patches menu, select Bleed Patch Edges.
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Mari calculates a full bleed for the selected patches, taking the existing textures next to the patch
on the model into account. This may take a few seconds.

Link or Unlink Patches
Mari has the ability to link patches together to provide a way of sharing the same underlying image
data between multiple patches quickly and easily. A patch is given the same paint as the patch it is
linked to if the linked patch is painted after they have been linked. This function can be found within
the Patches palette. It is best to view the model in UV view when attempting to link or unlink patches.

The linked patches feature works best when the underlying UV maps are identical. If they are not,
then the differing UV maps result in different edge bleeds, which could manifest as bleeding artifacts
on linked patches. If you need to avoid edge bleeding artifacts, you can use the Whole Patch
Projection option in the UV view.

NOTE: Please be aware that if painting on more than one linked patch, any overlap of paint
can cause baking artifacts. If you have trouble painting on linked patches because of these
overlaps, you can lock the patches you don’t want to paint on directly.

TIP: If you notice paint conflicts and you are already taking care to avoid overlapping paint,
try locking neighboring linked patches to the one you are painting on to avoid conflicts.

To link together two or more patches:

1. Within the Patches palette, select the patches you want to link together. You can select the
patches by clicking on them in either the palette or on the canvas.

This is best done in UV view for easier selection visibility.

2. Click the Link Selected Patch Images icon to link the selected patches.

In the UV view, a colored background displays behind the selected patches to denote which
patches have been linked.
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To unlink patches:

1. Within the Patches palette, select the patches that you want to unlink from the linked selections.

2. Either:

• click the Unlink Selected Patch Images icon to unlink the selected patch from any other
patches,

• right-click the Patches palette and select Unlink All Linked Patch Images, or

• right-click on the canvas and select Patches > Link | Unlink All Linked Patch Images.

In UV view, the colored background no longer shows behind the patches.

3. If you want to specify that a particular patch be used as a "master" patch, from which the other
linked patches can be initially copied, you can do this by first selecting the desired "master" patch
on its own and linking it using the Link Selected Patch Images button. You can then select the
master patch and the rest of the patches to re-link them using the Link Selected Patch Images
button again.

NOTE: When linking patches, if any patches have been previously linked, Mari determines
which set of linked patches has the most patches in the selection set and retains those links
while re-linking the other selected patches.

TIP: You can find all of the options discussed in this chapter in the right-click dropdown
menu on the canvas.
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Configuring the User Interface
Mari provides a fully customizable GUI. You can set it up to suit your working style and preferences.

The main GUI elements that you can customize are:

• palettes - areas that contain controls and information, for example to view and configure tool
properties, colors, or project elements. You can select which palettes to display and where to put
them.

• toolbars - panels that contain Mari tools and common functions, for example to paint, erase, open
or close a project. Toolbars contain icons you click to quickly access common tools and functions.
You can create new toolbars, with shortcut buttons to your favorite functions.

• HUD - the heads-up display (HUD) displays information about the current tool and other Mari and
project
information at the top of the canvas.

• status bar - the status bar displays information about current processes, as well as progress bars
and error
warnings.

Palettes and toolbars can be either docked (fixed in one place) or undocked (“floating” above the
canvas). Palettes can be docked to:

• any side (including top or bottom) of the Mari window, or

• each other (in a separate window).

Docked palettes can also be stacked - in the space of a single palette, with tabs to select which palette
appears on top. Similarly, toolbars can be docked on the top, left, or right of the Mari window (but
not the bottom). By default, toolbars appear at the top, but can be moved. Once you have your
workspace laid out properly, you can save the
layout for later use. If you decide that you don't like your custom layout, you can revert to the default
layout.

Choose and Organize Palettes
To select and position palettes:

1. To select which palettes to display:

• from the View menu, select Palettes, and then a palette from the sub-menu, or
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• right-click an empty spot on the toolbar area, and select a palette from the dropdown menu.

The dropdown menu lists palettes at top, and toolbars below.

TIP: When you open a palette, it displays where it was the last time it closed.

2. You can do the following to position a palette:

• move - click in the title bar and drag.

• undock - click in the title bar and drag to the middle of the canvas, or outside the main Mari
window.

• dock - drag to an edge of the canvas (left, right, top, or bottom).

The side of the canvas expands to “grab” the palette

• dock beside another palette - drag onto the side of another undocked palette, between
docked palettes, or between a docked palette and an edge of the canvas.

Palette(s) “shuffle over” to make room for the new palette, if there is enough room, otherwise
they stack (see below).

• dock on top (stack) - drag on top of a docked palette. Palette(s) “shuffle up” slightly, to display
tabs below for selecting which palette displays (on top).

TIP: If you dock two floating palettes together, they appear as a separate palette window.
You can also use the standard controls at the top right of the palette to minimize, maximize,
switch between floating and docked, and close the palette.

Mari also has a show/hide palette function: press the Home key (or select from the View
menu) to toggle between showing and hiding the current palettes.

TIP: Palette behavior is customizable. Experiment with the palettes to see how they can be
docked, undocked, moved, and stacked.

Choose and Organize Toolbars
To select and position toolbars:

1. To select which default toolbars to display, right-click an empty spot on the toolbar area, and
select from the dropdown menu (as for opening palettes, above).

TIP: The default toolbars are:

• Ptex - Ptex settings (changing face resolution, texel density, and so on).
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• Channels - buttons to switch between the four default views for painting (Channel, Stack,
Layer, and Paint).

• Navigation - buttons to set your navigation preferences while moving around the canvas.

• Tool Properties - lets you set the properties for the current tool.

• Project - common project functions (New project, Open, Save, and so on).

• Lighting - buttons to switch between the three lighting modes and to toggle shadows on or
off.

• Painting - buttons to clear the paint buffer or open the Brush Editor.

• Tools - all the painting tools.

• Selection - buttons to switch between three selection modes (objects, patches, and faces)
when using the Select tool.

• Canvas - view options for the UV and 3D views.

• Mirroring - buttons to switch between four paint mirroring settings.

• Vector Painting - enable the vector grid and quickly set up vector shaders.

• Colorspace - lets you specify your colorspace and the settings associated with your choice.

2. To position a toolbar, click the drag control at its left or top edge, and:

• move - drag to another position.

• undock - drag to the middle of the canvas, or outside the main Mari window.

• dock - drag to an edge of the canvas (left, right, or top - not bottom); the side of the canvas
expands to “grab” the toolbar.

• resize - drag left or right, or up or down.

TIP: If the toolbar is too small to fit all of its items, a double chevron appears at the end (»).
Click this to see all the tools in the bar, or resize and position the toolbar to see all items.

Create Custom Toolbars
If you want quick access to functions not included on the default toolbars, you can create as many
additional
toolbars as you need. To create a new toolbar:

1. From the Edit menu, select Toolbars.

The Manage Toolbars dialog box opens.
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2. Click Add to create a new toolbar.

Mari prompts you to name the toolbar.

3. Give your toolbar a name, and click OK.

The new toolbar displays under Custom Toolbars in the Manage Toolbars dialog box, and an
empty toolbar displays for it on the main screen.

TIP: If the empty toolbar does not display, make sure that the Visible checkbox in the
Manage Toolbars dialog box is ticked. Also note that the new toolbar may display at far
right, and you may have to drag its handle to the left to resize it, to make room for new
icons.

4. Add functions to your toolbar by dragging from the list on the left in the Manage Toolbars dialog
box, onto the empty toolbar on the main screen.

TIP: Click + to expand the nodes in the list to see the functions available. At the moment,
items cannot be removed from custom toolbars.

5. Click OK to close the Manage Toolbars dialog box when you're happy with your new toolbar.
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EXPERIMENT: Try this to acquaint yourself with managing toolbars:

• create a new toolbar,

• add a few items to it,

• resize it,

• undock it, move it, and re-dock it somewhere else,

• hide it from the display, then

• remove it.

Configure the HUD
To configure the head-up display (HUD):

1. From the Edit menu, select HUD Manager.

The HUD Manager dialog box opens. The information you're most likely to want to display is
under Tool
Manager and the current project (in the illustration, Example Project).

TIP: Many of the options in the HUD Manager are for debugging purposes only. For an
explanation of the different options, see the Mari Reference Guide.

2. Click the checkboxes for the options you want to include in the heads-up display at the top of the
canvas, then close the HUD Manager dialog box.

CONFIGURING THE USER INTERFACE | CONFIGURE THE HUD



USER GUIDE 195

Mari displays information in the HUD as you select it in the HUD Manager.

Save Your Layout
A layout is a record of how your Mari workspace is set up. Once you have your workspace set up, you
can save the layout so you can easily recall it later. Alternatively, you might want different layouts for
painting different types of objects.

1. From the View menu, select Save Layout.

A standard Save dialog box opens.

2. Enter a filename and select a location for your saved layout.

3. To reload the saved layout at any time: from the View menu, select Open Layout.

TIP: To revert to the default layout: from the View menu, select Default Layout.

EXPERIMENT: Try moving some palettes and toolbars around, then saving the layout. Revert
to the default layout, then re-load your saved layout.

Understanding the Status Bar
The status bar is a fixed panel of icons that appears in the bottom-right corner of the Mari window. It
displays
information about the project as icons, including progress bars for current processes, error warnings,
and features that can be toggled.

All icons display tooltips when the cursor hovers over the icon. Some can be clicked to toggle the
displayed
functionality. Though most icons are unique to a single error warning or feature, there are a few
noted in the list below that are not.
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Status Bar Icons

Icon Description Notes

Displays the UDIM number of the patch you have selected. If
nothing is selected, then there is nothing listed after Udim.

Notifies you that there is unbaked paint in the paint buffer.
Clicking on this icon bakes the current painting.

This icon only displays in
the status bar if there is
paint in the paint buffer.

Notifies you that your painting is hidden.

Notifies you that background jobs are currently running.
Clicking on this icon displays a dialog for the progress bar.

Notifies you that the project has changed and allows you to
click on the icon to save changes.

Notifies you that you are currently projecting on the front of
objects. Clicking on this icon toggles to Project Through
Objects. Clicking on this icon toggles between projecting
through objects and projecting on the front of objects. The

icon takes the default icon’s place when switching to
project through.

More information for projecting on or through objects can
be found under the Projectors on page 403 chapter.

Notifies you that you currently have edge masking enabled.

More information on edge masking and the edge masking
icon can be found under Edge Masks on page 78.

This is not a unique icon. It
also displays to indicate
that fractal noise masking is
enabled. If both masks are
being used, the icons
appear separately on the
status bar.
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Icon Description Notes

Notifies you that you currently have channel masking
enabled.

More information on channel masking and this icon can be
found under Channel Masks on page 81.

Notifies you that you currently have ambient occlusion
masking enabled.

More information on ambient occlusion masking and this
icon can be found under Ambient Occlusion Masks on page
84.

Notifies you that you currently have depth masking enabled.

More information on depth masking and this icon can be
found under Depth Masks on page 85.

Notifies you that you currently have backface masking
enabled.

More information on backface masking and this icon can be
found under Backface Masks on page 87.

Notifies you that you currently have fractal noise masking
enabled.

More information on fractal noise masking and this icon can
be found under Fractal Noise Masks on page 87.

This is not a unique icon. It
also displays to indicate
that edge masking is
enabled.

Notifies you that you currently have the global mask preview
enabled. Clicking this icon disables the global mask preview.

More information on the mask preview and this icon can be
found under Mask What You Can Paint On on page 77.

Notifies you whether you are in LDR (Low Dynamic Range) or
HDR (High Dynamic Range) mode.

Clicking on this icon toggles
between LDR and HDR.
When in HDR mode, the
icon appears as .
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Icon Description Notes

Warns you that a low memory status has been detected. Low
memory affects Mari’s performance and may make it
unstable. Try freeing memory or closing and restarting Mari
to clear this issue.

This is not a unique icon. It
also displays to warn you
that the cache disk is
critically full.

Notifies you that there are warning messages present. Clicking on this icon
displays these warnings.

Warns you that the cache disk is critically full. If you don’t
free space, data loss may occur. To free space, try:

• closing and reopening the project.

• freeing up space on the disk.

• placing your project files on a file system with more free
space.

This is not a unique icon. It
also displays to warn you
that a low memory status
has been detected.

Hovering the cursor over this icon displays the tooltip No
space left for this operation.

There are a few reasons that this might display, including:

• The virtual texture size is set too low in the Preferences.

• There are too many channels in the Channels palette.

• The patch resolution is set too high on some patches.

This is not a unique icon. It
also displays to indicate a
higher bit-depth than what
is configured.

Attempting to click on the
icon for the Overload
warning displays nothing
further.

Hovering the cursor over this icon displays the tooltip
Channels are higher bit-depth than what the virtual
texture is configured for. Clicking on the icon increases the
bit-depth of the
virtual texture to match that of the highest bit-depth and
removes the status bar warning.

This is not a unique icon. It
also displays to indicate
virtual texture overload.
Hovering over the icon for a
tooltip indicates which
warning it is.

Notifies you that Mari is currently loading data from the disk.

Notifies you that Mari is currently loading data from the RAM
to GPU memory.
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Icon Description Notes

Notifies you that Mari is listening for commands on
[COMPUTER NAME] port [PORT NUMBER].

Clicking on this icon shows
you what computer name
and port number Mari is
using to listen for
commands.

Notifies you that there was an error while Mari was listening
for commands.
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Managing Images

Mari lets you use external images as a source for:

• clone stamping

• painting through

• picking colors in the Color Manager.

Mari has a palette - the Image Manager - which stores images in use in the current project. This gives
you quick access to the images, and very basic editing. For each image, the Image Manager shows a
small preview and information such as the location of the image on disk.

When you open a project, the Image Manager loads its images from source files on the disk and
keeps them in memory, ready to use. If any of those source files change after you open a project, the
changes only appear in the Image Manager when you next open the project. If Mari can't find a
source file for an image in the Image Manager, when you open a project, it removes that image from
the Image Manager.

You can also create new images in the Image Manager by:

• cropping them from existing images,

• running a script on an existing image, or

• generating them using a custom Texture Generator.

Mari stores these with the project (rather than loading them from a file on disk - unless you
specifically save them on disk).

TIP: If you need to use a common set of images for multiple projects in Mari, you can drag
them to a personal shelf. See Storing Resources Using Shelves for details.

Open the ImageManager Palette
1. Open the Image Manager palette:

• right-click on the toolbar, and select Image Manager from the dropdown menu, or

• from the View menu, select Palettes > Image Manager.
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The Image Manager palette displays, showing images currently in use in the project.

2. If you want to create custom tabs, click the add tab button at the top of the palette. This allows
you to add your own tabs to the palette so that you can better organize your images without
needing to scroll through a long set of thumbnails to find the one you need.

3. If you then want to delete a tab from the palette, click the delete tab button.

Any images that you have in the tab when you delete it are deleted as well, so if you want to keep
those images in the Image Manager palette, you need to first move them into another tab.

NOTE: You cannot delete the default Project tab that opens as part of the Image Manager
palette.

Load and Select Images
1. To load one or more images, click .

The Open an Image dialog box displays.
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2. Select the image(s) you want to load and set the Advanced Options:

• Colorspace - sets the colorspace to which the image data is converted.

• Alpha - sets how you want the alpha channel to be handled.

3. Click Open once you are ready to load the image(s).

The Image Manager shows a preview of the image(s). The actual image itself may be larger or
smaller than the preview.

NOTE: If you load a layered .psd file into the Image Manager, each layer is imported as a
separate image.

4. Click on the preview to view information about that image.
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Information displayed includes:

• Depth

• Channels

• Colorspace

• the image height and width, in pixels

• the path of the source file (from which Mari loads the image when you open the project).

NOTE: On Windows, file paths have a limit of 32,767 characters in length. If you load an
image into the Image Manager that exceeds this length, the message Invalid Image Path is
displayed in the Path field. This does not affect the image data or its properties, and you
may continue to use it as normal.

5. To remove images from the Image Manager, select the image and click , or right-click on the
selected image(s) and click Close in the dropdown menu.

The image(s) are removed from the Image Manager. This has no effect on the image source files
- it just means you're not using those images in your current Mari project.
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6. To view a larger version of an image, click , or select View from the right-click menu.

The larger preview opens in a separate window. You can change the size of this preview by
changing the size of the window. You can also crop the image from this window.

7. To save an image under a new filename, click , or select Save As from the right-click menu.

The Save As dialog box displays.

8. Enter a new name for the image and click Save.

Mari saves the image. From now on, Mari loads the image from the new filepath when you open
this project.

TIP: Double-clicking on an empty part of the Image Manager opens the Open an Image
dialog. You can either select all the images you want and click Open to load them into the
Image Manager palette, or you can drag-and-drop images into the Image Manager from
your web browser.

Crop and Filter Images
1. To create a new image by cropping an image from the Image Manager, click to open the

image preview window.

TIP: Clicking on the image in this window sets the foreground color to the color at the spot
you clicked.

2. Select the crop mode that you want to use. You can select from the following options:

• Arbitrary - click and drag on an arbitrary area of the image.
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• Fixed - enter a fixed size for the crop box (in pixels) and drag it to the area you want to crop.

• Aspect - enter a fixed aspect ratio for the crop box (in pixels) and drag it over the area you want
to crop.

3. Now click and drag to select the area to crop, select the Output Size and click .

The selected area appears as a new image in the Image Manager.

TIP: Mari saves a cropped image as part of the project, not as a separate file on disk - unless
you specifically save it with a new filename.

4. To apply a filter to an image, click to select it in the Image Manager and, from the Filters menu,
select the filter to apply.

The Apply dialog box displays.

5. Make sure that Apply To is set to Selected Images.

TIP: For details of the filters available and how to apply them, see Available Filters.

6. Set filter options, and click Apply.

Mari applies the filter to the image in the Image Manager.
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TIP: You can filter multiple images at once. Mari applies the same filter to all the selected
images. Filtering an image in the Image Manager breaks the connection between the image
and the original file. If you want a copy of your updated image on disk, save it with a new
filename.

Run Scripts on Images
The Image Manager has a right-click option to run scripts on images. This lets you run custom
scripts (for example, a Nuke or ImageMagick transform) on the images.

To run a script on an image:

1. Right-click on the image and select Run Script from the dropdown menu.

The Run Image Script dialog box displays.

2. Type in the script command or select a script from the dropdown list. The list holds the last 10
scripts that were run.

Use the $FILENAME variable for the name of the image file.

TIP: Mari runs the script command and then loads the $FILENAME file. So all commands
must run in place on $FILENAME.

Mari runs the script, then loads the resulting image into the Image Manager. Initially, the
previous version of the image also appears in the Image Manager.
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The initial image to the left, and the modified image to the right.

TIP: You can run scripts on multiple images at once.

EXPERIMENT: Run some basic scripts on your images. For example, try:

• /usr/bin/convert $FILENAME -flop $FILENAME - to flip the image horizontally.

• /usr/bin/convert $FILENAME -blur 10 $FILENAME - to apply a slight blur.
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Managing Colors
Mari lets you control both how colors display, and how you select them. For channels, you can use
the color management functionality provided by the Color Manager or the Colorspace toolbar to
specify colorspaces for different aspects of your project, apply various color profiles (preset or
custom), and apply LUTs (look-up tables).

Mari comes with a selection of preset color profiles in the Color Manager palette, and you can
configure your own custom profiles too. In this palette, you can have Mari display an onscreen
histogram, showing the color distribution in your painting, or select a “split point” - where to split the
display between corrected and uncorrected colors.

Mari always has a Colors palette that allows you to set the “foreground” and “background” colors that
Mari uses, and the colorspace of the color pickers and swatches displayed in the project. The
foreground and background colors are also displayed in the Tools toolbar. By default, painting tools
use the foreground color.

NOTE: Colorspaces can be configured discretely for the various aspects of Mari. The
colorspace displayed in the Colors palette, only affects color pickers and swatches but you
can change this colorspace and others in the Project Settings dialog, accessible from File >
Settings.

For picking colors, Mari provides:

• a standard “eyedropper” Color Picker tool.

• the Pixel Analyzer palette, which supplements the Color Picker with a range of colors you've
selected, showing their average, minimum, and maximum color values.

• the Colors palette, which lets you pick colors interactively from a selection of pickers (including HSV,
grayscale, blends, HDR, and from images) or just by entering specific color values.

• the ability to select colors from images in the Image Manager or a shelf.

NOTE: Both the Color Picker tool and Pixel Analyzer palette can pick color values from
HDR images, as long as the Paint Buffer hasn't been clamped.

TIP: You can also change the color depth of a channel if you need to. See Channels for
details.
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WARNING: When working on an 8-bit (byte) channel that is in a non-linear colorspace, you
need to set the virtual texture's type and paint buffer's color depth to 16-bit (half) or 32-bit
(float) to minimize quantization errors.
To set the virtual texture's type, refer to the Mari Reference Guide in the Mari Preferences Dialog
section. To set the paint buffer's color depth, refer to the Mari User Guide in the Configure the
Paint Buffer section.

About the Colorspace Toolbar
The Colorspace toolbar is provided as an efficient way to enable or disable color management and
set LUTs to the painting displayed on your screen. While this functionality is also available from
within the Color Manager (under the preset Colorspace color profile) the toolbar is conveniently
placed to make quick adjustments while painting.

The Colorspace toolbar utilizes the OpenColorIO standard originally developed by Sony Pictures
Imageworks. For a more comprehensive explanation of OpenColorIO, including LUT generation and
suggested workflow strategies, please visit http://opencolorio.org/.

You can quickly toggle overall color management, as displayed on the canvas, using the color

management button on the toolbar, as well as conveniently load LUT files using the select LUT

button. There are also dropdown menus, such as View Transform and Component, available for
applying colorspace conversions.

NOTE: To actually turn off color management fully, you need to disable colorspace for each
of the channels individually by going into the Channels palette, clicking on the channel, and
enabling Raw Data.

Pick Colors from Paint on theModel
To pick a single color from the paint already on the model:

1. Select the Color Picker tool and click on the model.

Mari sets the Foreground color to the color at the point you clicked.

TIP: Mari sets the color to what's actually on the model's surface where you clicked. This may
not be exactly the color you see on screen. For example, if you use full lighting and the area
is in shade, it doesn’t appear darker than it actually is.
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2. Open the Pixel Analyzer palette:

• right-click on the toolbar, and select Pixel Analyzer from the dropdown menu, or

• from the View menu, select Palettes > Pixel Analyzer.

The Pixel Analyzer palette displays details of the currently-selected color.

The Values section displays the color's exact numeric value, in the selected Range.

TIP: If you are analyzing pixels from an HDR image and want to maintain the correct color
values, ensure that you have not ticked the Clamp checkbox in the Painting palette, and that
you are painting in a 16- or 32-bit channel.

3. Under Accumulate, click the Enabled checkbox.

With this option enabled, Mari keeps track of the colors you select. As you click on the model, the
Colors fields update to display the Current color selected, plus the Minimum, Average, and
Maximum color values from the tracked series of clicks. (If you drag across the model, Mari still
accumulates colors, as if it were a series of clicks.) You can then click on any of these swatches to
set the foreground color to that value.

4. Click Reset to clear the buffer and start again.

Select Colors from a Picker or Image
1. Open the Colors palette:
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• right-click on the toolbar, and select Colors from dropdown menu, or

• from the View menu, select Palettes > Colors.

The Colors palette displays colors and color pickers.

2. Select a color:

• manually set the numeric values (either type them into the entry boxes or move the sliders) for
the various color attributes - red, green, blue, alpha; or hue, saturation, and value, or

• click a color field in the tabbed area.

The control dynamically updates as you change the settings.

3. Click to navigate through the tabs available for the color pickers. These include:

• HSV - to select hue, saturation, and value settings.
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• Values - to pick from Byte (8-Bit) or Float (32-Bit) color values.

• Image - to pick a color from an image (right-click to load an image, or drag an image from the
Image Manager palette).

• Gray - to select grayscale values (including pre-defined gray settings, at the bottom, in steps
from black to white).
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• Blend - to pick from a field blending four colors (select which colors by clicking the swatches in
the corners to open another color picker control).

TIP: By default, Mari opens with an HSV tab, a Values tab, an Image tab, and a Gray tab.
You can add additional color tabs:

• To open other tabs, including Blend tabs, click .

• To open a tab as a floating window, click .

• You can also pick colors from images by double- clicking on them.

4. To display the color picker menu when painting, press and hold J.

The color picker menu displays under your mouse cursor. The bar at right shows the selected
color (without a border - so you can compare directly with what's already painted). You can also
change the intensity of the color, if you are trying to match the color intensity of an HDR image.
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TIP: If you intend to paint on an HDR texture with a color from the color picker, ensure that
you have not ticked the Clamp checkbox in the Painting palette, and that you are painting in
a 16- or 32-bit channel.

5. To pick colors from an image directly from the Image Manager or a shelf, double-click on the
image. When the image window opens, click within the image to set the foreground color.

TIP: See also Storing Resources Using Shelves for instructions on making a custom shelf
with small icons of selected color swatches.

EXPERIMENT: Try the steps below to select new colors:

• Pick a color from the Colors palette. Notice as you drag the cursor across a field, or slide a
slider, the Foreground swatch changes and the RGB values change.

• Load an image into the Image tab in the Colors palette, and pick a color from it.

• Create a custom, floating Blend window with different colors than the defaults.

Color Management
Mari uses OpenColorIO for color management. All of the colorspaces in Mari, whether those shipped
with the application or custom colorspaces loaded during project creation, are defined in OCIO config
files.

Depending on the OCIO config file that you are working with, there are a number of colorspace
options and roles (aliases to colorspaces) that you can set in Mari. There are also Automatic options,
which change depending on what file type you are working with. When you've selected the Automatic
option the colorspace that Mari has set for it is listed in brackets.
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Changes to a project's colorspace cannot be undone in Mari. You can change the colorspace back to
its previous setting manually or use the reset button to restore it to the default, but you cannot undo
any colorspace changes in the History View palette.

NOTE: Refer to the OpenColorIO website at http://opencolorio.org/ for additional
information on OCIO colorspaces and roles.

Colorspaces

The colorspaces are set in the OCIO config file. Mari looks to this file for the colorspaces that are
listed and provides these options in all the Colorspace dropdowns available. Depending on which of
the default config files that you select for your project, Mari offers a number of default colorspaces.

Mari ships with five config files: aces, iif, nuke-default, spi-anim, and spi-vfx. There is also a
Custom option that allows you to choose your own config file, from a designated place on your
machine or network. If you set up a Custom config, Mari references this for colorspaces and roles,
just as it would a shipped config file. However, these must be set up properly, with colorspaces and
roles defined according to the OCIO standard, in order to work correctly.

Though there are five config files that are shipped with Mari, this section only covers the nuke-
default colorspaces. However, brief descriptions of the other config files are listed below:

• The aces config file is a color profile with a color image encoding system proposed by the Academy
of Motion Picture Arts and Sciences that allows for a fully encompassing color accurate workflow,
with "seamless interchange of high quality motion picture images regardless of source".

• The iif, or image interchange framework, config file is an architecture for placing any and all capture
media into a standardized gamma and colorspace.

• The spi-anim OCIO config file is a color profile that is in use at Sony Pictures Imageworks, and is
suitable for use on animated features.

• The spi-vfx OCIO config file is a color profile that is in use at Sony Pictures Imageworks, and is
suitable for use on visual effects work.

The nuke-default OCIO config file corresponds to the default Nuke color configuration. In this way, if
you are using both Mari and Nuke in your pipeline, you can ensure that the color profiles match
across applications. The default colorspaces that are defined in the config file are:

• linear • sRGB • rec709
• Cineon • Gamma1.8 • Gamma2.2
• Gamma2.4 • Panalog • REDLog
• ViperLog • AlexaV3LogC • PLogLin
• SLog • SLog1 • SLog2
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• SLog3 • CLog • Protune
• raw

Roles

The roles are also set in the OCIO config file. Mari looks to this file for the roles that are listed and
provides these options in all the Colorspace dropdowns available. Roles are used by Mari to perform
a task-specific color transform without requiring you to select a colorspace by name, and they appear
in all of the colorspace-related dropdowns. Depending on which of the default config files that you
select for your project, Mari offers a number of default roles.

Though there are five config files with defined roles that are shipped with Mari, this section only
covers the nuke-default roles.

The nuke-default OCIO config file provides the following default roles:

• color_picking (sRGB) • color_timing (Cineon) • compositing_log (Cineon)
• data (raw) • default (raw) • matte_paint (sRGB)
• reference (linear) • scene_linear (linear) • texture_paint (sRGB)

If you've set a role in a colorspace field during project creation or in the Project Settings dialog, it
also affects anywhere in your project where the colorspace has been set to Automatic. For instance,
if the 8 bit Data colorspace field has been set to the data role, which by default uses the raw
colorspace, then any 8-bit channel with a colorspace set to Automatic, uses a raw colorspace and
appears in the dropdown field as Automatic (raw).

Set How Colors Are Displayed Onscreen
Mari sets how colors are displayed for each project separately. You can set this using either the Color
Manager, the Colorspace toolbar, or adjust the individual colorspaces of the project in the Project
Settings dialog.

Set HowColors are Displayed Using the Color Manager
1. Open the Color Manager palette:

• right-click on the toolbar, and select Color Manager from the dropdown menu, or

• from the View menu, select Palettes > Color Manager.

The Color Manager palette shows color display settings for the current project.
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2. Under Options, select the main display options:

• Enable Color Management - when selected, applies the color profile selected in the Current
Color Profile section (see below).

• Histogram - when selected, a histogram displays in the bottom left of the canvas, showing
details of the color balance in the current channel.

• Split Point - where (and whether) to split the canvas between color-corrected and uncorrected.
The default is with the slider at the far right, at 1.00, showing the entire canvas with color
correction. Moving the slider changes the split. For example, moving it halfway along (to 0.50)
makes Mari display a split halfway across the screen, with color-corrected on the left and
uncorrected on the right.

3. Under Current Color Profile, select a color profile from the list, or click New or Edit to create a
new color profile or edit the current one.

The Edit dialog box displays the filters available for building up a color profile. For the Colorspace
Color Profile, three filters - Gain, LUT, and Display - are selected by default and cannot be
deleted.
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4. Select filters to use from the Available Filters list, and click the right arrow button to move them
to the Selected Filters list. Choose the order in which to apply the filters in the Selected Filters
list, using the up and down arrow buttons. Then click OK.

The Current Color Profile dialog box lists the selected filters.

5. To view and configure how Mari applies a selected filter, click to expand it, then set its properties.

6. You can delete color profiles from the list by selecting a profile and clicking Delete.

TIP: For more details on Mari’s filters, see Filtering Images and Paint.

Set HowColors are Displayed Using the Colorspace Toolbar

1. Click or select Enable Color Management in the Color Manager palette.

2. If you want to set up a LUT, click and choose a file from the Select LUT File dialog.
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3. Set the display device used to view the scene using the Display Device dropdown menu.

4. Select the colorspace transform to apply to the scene using the View Transform dropdown
menu.

5. Specify the individual color components in the scene using the Component dropdown menu.

6. Specify the amount of exposure adjustment applied before the display transform by either
entering a multiplier (exposure value), dragging on the slider, or adjusting the F-Stop value in the
Gain controls.

7. Finally, specify the amount of Gamma correction applied after the display transform by entering a
gamma level or by dragging the gamma slider.

Set HowColors are Displayed Using the Project Settings

During project creation, you can set the colorspace you want to use for different aspects of your
project. However, you might find that after you've created your project, you want to change these
colorspace settings. You can do this in the Project Settings. Follow the steps below to adjust your
settings:

1. Navigate to File > Settings.

The Project Settings dialog displays.

2. Specify the OCIO Config file to use. The options given are shipped OpenColorIO configuration
files that handle colorspace or user-defined configuration files (Custom) that you can set up
yourself.

3. If you chose Custom for the OCIO Config field, you need to specify, or browse to, the
configuration file that you want to use for this project.
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4. Set the Monitor field to specify which is the default colorspace, that applies to thumbnails and UI
elements. Though it can be whatever colorspace you want, it's recommended that this is the same
colorspace as the one that you intend to use for the canvas.

5. Set the Color Picking field to specify which colorspace is used for all the color pickers, swatches,
and image viewers in the project.

6. Set the 8 bit Data field to specify which is the default colorspace for 8-bit (Byte) channels, as well
as for reading and writing image files with 8-bit data.

7. Set the 16 bit Data field to specify which is the default colorspace for 16-bit (Half) channels, as
well as for reading and writing image files with 16-bit data.

8. Set the 8 bit Scalar field to specify which is the default colorspace for masks, heights, normals,
depths and, generally, any non-color image with 8-bit data.

9. Set the 16/32 bit Float Data field to specify which is the default colorspace for 16- and 32-bit
(Float) channels, as well as for reading and writing image files with floating point data.

NOTE: You don't need to specify all of these settings, either on project creation or while
working on the project, as Mari automatically inserts default options for these fields.

NOTE: A 16-bit channel is in half format, which is floating-point and should take the default
from the 16/32 Bit Float Data setting, not the 16 Bit Data option. The 16 Bit Data option is
for 16-bit integer formats and is currently only used in Mari for importing or exporting
images in that format, such as some .tiff files. Mari currently doesn't support 16-bit integer
channels.

Advanced Color Management
In addition to the basic controls for color management, Mari also has an advanced color
management mode. This mode is for those users who feel confident about their color management
abilities, and who know exactly what setting they want to change and why.

WARNING: As changes to a project's colorspace, and color management in general, cannot
be undone in Mari, it's imperative that you first consider whether you strictly need to operate
in the advanced color management mode.

TIP: If you want to work in the advanced color management mode without risking damage
to your project, you can make a copy of the config files to a location on your machine or
network before making any changes to the original file.
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Enable Advanced Color Management

To enable the advanced color management mode:

1. Open your Mari configuration file, named Mari.conf (on Linux) or Mari.ini (on Windows and
Mac).

2. Under the General section (near the top in the config file), place the following environment
variable:

SHOW_FULL_COLORSPACE_OPTIONS=true.

If the environment variable already exists in the file, change it from false to true.

Once the environment variable is set to true, the advanced color management options are active
and exposed within Mari.

NOTE: Any changes you make to colorspace while advanced color management is enabled
persist even after you have reverted back to the basic color management mode.

Advanced Color Management Options

Once you've enabled the advanced color management within Mari, there are a number of controls
that are exposed in the UI, that are not otherwise visible in the basic color management mode. These
controls vary, depending on where they are in the UI, but every place that colorspace is usually visible
has additional options. Some of the options you may find are:

• Working/Working Colorspace - the colorspace for painting, lighting, applying filters, and similar
operations.

• OCIO Config - a list of either user-defined configuration files (Custom) or shipped OpenColorIO
configuration files that handle colorspace.

• Custom OCIO Config - if you chose Custom for the OCIO Config file choice, specify the path to the
configuration file.

• Output Colorspace - the colorspace for the output.

• Raw Data - when enabled, prevents the data from being converted to another colorspace.

Though changes you make to these colorspace options while in the advanced color management
mode persist whatever color management mode Mari is in currently, the options above are no longer
visible when the basic mode is re-enabled.
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Layers
Layers are the primary system for painting in Mari. At its most basic, the layer system can be used to
set up simple stacks for ordering different sets of paint, and to combine effects in a non-destructive
manner. However, the real strength of the layer system lies in the way layers integrate with shaders
and channels.

Layer Integration
Mari’s layer system does not function in isolation; instead, it works together with shaders and
channels to create a cohesive structure for painting. Layers are entirely dependent on channels and
need to have diffuse, specular, or bump channels already set up in order to be created.

As in previous versions of Mari, channels are created with the choice of channel type, size, and depth;
however, instead of painting directly into the channel as before, channels now allow the use of
separate layers within them to create your texture. This gives you more control over how you paint,
and gives you the option of creating non-destructive textures that can be integrated into the rest of
your project. Channels are your foundation for working with layers, but what are these layers capable
of, and what are your options?

Layers can be divided into a few categories: paint layers, layer masks, adjustments, and procedurals.
In turn, these layers can be ordered into groups, as well as shared, merged, or exported, to name
only a few features. Layers can even be converted into new channels with existing paint in the base
layer. Experiment with them more to discover what you can do.

For more information about channels, please see Channels.

Shader Dependence
Shaders are also important in the use of channels and layers, but they have received a makeover
compared to their use in previous versions of Mari. Shaders now allow you to set up lighting and
specify which channels should be used for each channel type in the shader system. Depending on the
lighting system used, you can also control elements that affect your channels, such as bump weight,
reflectiveness, and ambient occlusion.

Shaders also serve the vital purpose of giving you a quick way of comparing your texture under
different conditions. Switching between the pre-existing shaders gives you a fast way of viewing your
textures within the lighting shader you’ve set up, or simply viewing the current channel or layer stack.
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Co-dependence of channels, layers, and shaders.

For more information about shaders, please see Shaders.

Getting Started with Layers
You can find most of the new features regarding layers and masks within the Layers palette or the
Layers menu. The Layers palette is divided into two panes. The top pane displays all the layers for
that channel, and the bottom pane provides information and controls to adjust the selected layer,
when applicable.

All the controls for adding, editing, or deleting layers can be found on the right-click menu or the
buttons on the palette. Adding layers and masks immediately adds the selected component, whereas
adding adjustments and procedurals opens a dropdown menu for further selections.

Blend modes are also found on the Layers palette, as well as advanced blending options. Unlike the
Paint Mode, found on the Paint toolbar, these blend options don’t affect the whole model, but only
the selected layer(s).

Ordering Layers

Mari applies the layers in the order they appear in the palette, from the bottom of the list up (as in
Photoshop®). You can drag and drop them around in the palette to change the order. Every channel
that you’ve created automatically has a base layer in the layer stack. This is the foundation all other
layers are built on. If the base layer is deleted, the object displays the transparency checkerboard
wherever paint from the above layers doesn’t cover the model.
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The following table illustrates a basic layer stack with two layers in a diffuse channel. One layer shows
a red stripe, the other shows a blue stripe. The order of the two layers determines which texture
appears on top. The table shows the results of swapping the order of the layers.

Layer Order Result

The diffuse texture (Base) is on the
bottom, then the Red, then the Blue.

The diffuse texture is on the bottom, but
this time the Red is on top of the Blue.

If you like the look of a layer and want to replicate it elsewhere in your project, you can copy and
paste the layer into the layer stack or another stack. In addition, layers can also be duplicated within
the stack.

NOTE: For those unfamiliar with layers, the nearer the layer is to the bottom of the stack, the
further down it sits in the paint order. Any overlapping paint on layers higher in the stack
covers the original paint lower in the stack.
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Filter and Search for Layers

In the Layers palette, there are four methods for quickly finding individual layers in a large layer
stack: Name, Type, Attribute, and Color Tag. You can choose to filter by name, or to select a layer
type or attribute, such as only
procedurals, or layers that are visible. Alternatively, you can assign layers with one of eight color tags,
and filter according to color.

Locked and Hidden Layers

Layers can be locked to protect them from being mistakenly deleted or edited. If the layer being
locked is part of a group, only that layer is locked; however, if the layer being locked is the parent
layer of the group, then all the child layers are locked too.

Hiding layers, on the other hand, allows you to examine your work in isolation. Hiding a layer non-
destructively removes the texture from the object so that you can see the results of the rest of the
stack without it.

For more information about locking or hiding other selected items, see Hiding and Locking.

Dragging Layers for Moving, Copying, and Sharing

You can move, copy, and share layers between different layer stacks - even between layer stacks of
different channels - by using modifier keys when dragging:

• Shift+drag to share layers.

• Alt+drag (or Ctrl/Cmd+Alt+drag) to copy layers.

• Drag (without any modifiers) to move layers.

Note that the modifier keys need to be held down until the layers are dropped, otherwise they have
no effect.

To drag layers between the layer stacks of different channels, you need to open those stacks in their
own layer stack palettes in advance. Remember to pin the layer stack palettes using the button in the
top-left corner so that they do not automatically disappear. Alternatively, you can drag and hover over
the relevant channel in the Channels palette to activate its layer stack in the Layers palette, and then
continue dragging and drop the layers there.

Sub-stacks, such as adjustment stacks or mask stacks, automatically pop up additional dialogs if you
drag your layers over their icons, so you don't need to open these pop-ups in advance.
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Layer Properties
Any layer in the Layers palette can be inspected to view the layer properties, such as File Space,
Colorspace, and information about the channel to which the layer belongs. To view the layer
properties, right-click on a layer in the Layers palette and select Layer Properties from the
dropdown menu. The Layer Properties dialog appears with the layer format and channel
information for the selected layer.

Open the Layers Palette
1. Start Mari and open your project.

2. Set up the shaders, channels, and layers, as described in Layer Integration.

3. Open the Layers palette:

• right-click on the toolbar and select Layers from the dropdown menu,

• from the View menu, select Palettes > Layers.

The Layers palette displays, with a default base layer in the layer stack.
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Layer Blend Modes
Near the top of the palette there are blend mode options in the dropdown menu. This mode can be
set for each
individual layer, setting it apart from the Painting Mode in the Paint toolbar. The key difference is
that where Painting Mode applies to the paint strokes that are baked down onto the model, the
blend modes on the Layers palette apply to paint in the entire layer; not just what is baked.

NOTE: If the blend mode applied to the layer affects the appearance of the overall stack,
ensure that the layer is placed in the ideal order in the layer stack. If necessary, the layer can
be moved after the blend mode has been set.

Add Layers and Masks
To add a new layer, either:

• from the Layers menu, select Add New Layer,

• right-click any layer in the Layers palette and select Add New Layer, or

• in the Layers palette, click .

The new layer appears in the layer stack, with the paintable layer icon.

Layer masks allow you to mask out the paint you’ve already created in that layer. The mask uses a
simple black and white map, which is visible by clicking on Current Paint Target in the Shaders
palette. The mask uses black to completely mask out the texture, whereas white completely unmasks
the texture.

Creating a mask on a layer (painted in black and white) and deriving alpha values from the mask
(where the alpha on a pixel is controlled by the shade on the original mask), combines the alpha
values with the diffuse color from the layer to create results as shown below:
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Initial B/W mask,
shown in Current

Paint Target

Diffuse layer. Result of creating
a layer mask.

Any other color used only partially masks out the texture, with the intensity of the mask depending
on the amount of black or white in the color.

NOTE: It’s not necessary to switch to Current Paint Target in the Shaders palette when
painting a layer mask. You can still paint in the layer as you would normally, but Current
Paint Target provides you with an easy way to examine your mask in isolation.

TIP: We recommend that you create:

• mask channels with a white background - so you can paint the mask data black.

• displacement channels with a 50% gray background - this corresponds to the default
surface. Mari treats darker colors as negative displacement (going into the surface) and
lighter colors as positive displacement (coming out from the surface).

Alpha and Masks

To make creating masks easier, Mari has another function to easily convert between alpha and mask
values.

Creating a mask FromAlpha does the opposite of a standard mask. It converts a layer with alpha
values to a black and white mask, where the shade on each pixel is controlled by the alpha on the
original layer to give the results shown below:
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Initial channel with
alpha values.

Result of
Alpha to Mask.

To add a layer mask, either:

• from the Layers menu, select Layer Mask > Add Mask > Reveal All or Layer Mask > Add Mask >
From Alpha,

• right-click the desired layer for the mask, and select Layer Mask > Add Mask > Reveal All or Layer
Mask > Add Mask > From Alpha, or

• in the Layers palette, click .

The layer mask is added to the selected layer, with the mask icon next to the paintable icon.

NOTE: You can right-click any of the layers in the Layers palette to access the dropdown
menu for more layer options. Right-clicking an existing layer also selects it.

Add Adjustments and Procedurals
Adjustment layers are filters that can be added to the layer stack to affect certain layers in the stack.
Adjustment layers are location-dependent in the layer stack and affect only the layers below them.

In addition to adding adjustment layers to the layer stack, adjustments can also be added to selected
layers. These adjustments are exclusive to the layer they were added to. Whenever an adjustment is
added to an existing layer, it automatically creates an adjustment stack that can be opened in a
separate palette.

An adjustment layer with a mask on the layer can have a secondary adjustment added to it to apply
another adjustment to masked out areas. Like layer-specific adjustments, these are applied directly to
the selected adjustment layer and can be modified in the lower pane of the palette.
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For a full list of adjustment layers and a more detailed description please refer to Layer Types and
Examples.

Follow these steps for working with adjustment layers:

1. To add an adjustment layer to a layer stack, either:

• from the Layers menu, navigate to Add Adjustment Layer and select the filter from the
dropdown menu,

• right-click any layer in the Layers palette, navigate to Add Adjustment Layer and select the
adjustment filter from the dropdown menu,

• in the Layers palette, click , or

• with the Layers palette open, press Tab and begin typing the adjustment you want to add. The
entry box is populated with the adjustment.

The adjustment layer appears in the layer stack, with the adjustment icon where the paintable
layer icon would normally reside.

2. To add an adjustment to a layer:

• with the layer selected, from the Layers menu, navigate to Adjustment Stack > Add
Adjustment Stack and select the filter from the dropdown menu,

• right-click the desired layer, navigate to Adjustment Stack > Add Adjustment Stack and select
the filter from the dropdown menu, or

• in the Layers palette, click , and select the filter from the dropdown menu.

The adjustment filter is added to the selected layer, with the adjustment stack icon one space
down from where the mask icon would appear.

NOTE: Each filter has adjustment controls located in the bottom pane of the Layers palette.
Use these to modify how strongly the filter affects your texture.

3. When an adjustment or adjustment stack has been added to an existing layer, you can flatten the
adjustment or stack into the layer. To do this:

• with the layer selected, from the Layers menu, select Adjustment Stack > Bake Adjustment
Stack, or

• right-click on the layer and select Adjustment Stack > Bake Adjustment Stack from the
dropdown menu.
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NOTE: The layer blend mode of an adjustment stack is Overlay. Due to the fact that 8-bit
channels are in an Automatic (sRGB) colorspace by default, the base value of 0.5 is
converted to 0.2 when it gets to the rendering stage. Layers are then blended with the
Overlay mode. If an adjustment is then applied to the top layer, it results in other layers
than the adjusted layer appearing as if they've been affected. In actuality, they haven't been
affected but because of the Overlay mode, the final look changes significantly.

EXPERIMENT: In order to see how blend modes can affect a layer stack, try:

1. Fill the bottom layer in a stack with 0.5, 0, 0 values.

2. Fill the middle layer in a stack with 0, 0.5, 0 values.

3. Fill the top layer in a stack with 0, 0, 0.5 values.

4. Change all the layer blend modes to Add.

You see a gray 0.5, 0.5, 0.5 value as the result.

5. Now, change the contrast of the top layer by applying a Contrast adjustment.

Notice that it becomes more bluish as you turn up the contrast. This illustrates how the
contrast is only applied to the top layer.

Procedural layers allow you to add texture patterns, grid patterns, environments, and masks to the
layer stack using a variety of parameter settings. Procedural layers behave similarly to paint layers,
with the exception that their image content cannot be painted on - it can only be modified by
changing the parameters of the layer.

For a full list of procedural layers and a more detailed description please refer to Layer Types and
Examples.

To add a procedural layer, either:

• navigate to Add Procedural Layer, from the Layers menu, and select a procedural from the
dropdown menu,

• right-click any layer in the Layers palette, navigate to Add Procedural Layer and select a
procedural from the dropdown menu,

• click in the Layers palette, or

• with the Layers palette open, press Tab and begin typing the procedural you want to add. The entry
box is populated with the procedural.

The procedural layer appears in the layer stack, with the procedural icon where the paintable layer
icon would normally reside.
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Projection Procedurals

Cubic and spherical projection procedural layers allow you to import a texture into the scene and
project it onto the geometry. Using multiple Cube Map Projector or Sphere Map Projector
procedurals enables you to get the best possible projection from the different camera locations in a
scene. Using multiple camera locations allows you to account for occlusion and perspective when
projecting textures onto the geometry.

There are three projection procedurals:

• Cube Map Projector,

• Sphere Map Projector, and

• Triplanar Projection.

You can also use masks with the projection procedurals to mask out parts of the projection. This is
helpful in eliminating unwanted artifacts, for example, where the projection overlaps with other
projections in the scene.

Each projection procedural allows you to control:

• texture offset and rotation,

• edge and distance falloff start and end points, and

• falloff curve shapes, using the curve editors.

NOTE: Adjusting options such as falloff and texture offset or rotation affects the whole
scene.

Mipmap Behavior

For the Cube Map procedural, .dds files with missing mipmaps or partial mipchains continue to load,
but the behavior for these chains is slightly different. Mari disregards all other mipmaps in the chain;
instead, it regenerates the chain from the top level mip.

In this way, Mari continues to load partial mipmap chains in a workable manner for .dds files.

Add Graph Layers
Mari's Graph Layers are building blocks used in Mari's Node Graph. The Node Graph's Basic mode,
the default mode, only allows you to work with Graph Layers from the Layers palette. Advanced
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mode exposes the entire project in the Node Graph palette, including all layers, channels, and
shaders.

NOTE: You can enable the Advanced Node Graph in the Mari Preferences dialog under
Node Graph > General > Advanced View. See Node Graph for more information on the
Advanced Node Graph.

To add a new Graph Layer, either:

• right-click any layer in the Layers palette and select Add New Graph Layer, or

• in the Layers palette, click .

The new layer appears in the layer stack, with the Node Graph layer icon.

The Node Graph and Node Properties palettes are not displayed in the default layout, so to view the
Node Graph, navigate to View > Palettes > Node Graph.

Graph Layers are actually Groups, in Node Graph terms, containing an Input node and an Output
node. In Basic mode, all you see in the Node Graph are those nodes, but in Advanced mode, any
Graph Layers you add are included in the node tree for the current channel.

A simple Graph Layer in Basic mode. A simple node tree in Advanced mode.

To add nodes to the Graph Layer, either:

• press the Tab key in the Node Graph and start typing the name of the node you want to create, and
then press Return to add the node, or

• right-click in the Node Graph and select the required node from the menu.

NOTE: See Working with Nodes and Layer Types and Examples for more information on the
Node Graph and the nodes available. Graph Layers can be exported and imported in exactly
the same way as other layers. See Export and Import Layers or Masks.
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CubeMapping
Cube maps provide a context for reflecting images of surrounding environments on the model,
similar to the Sphere Map procedural layer. The difference is that the environment is modeled by six
textures mapped on a cube surrounding the object as opposed to a single texture mapped on a
sphere surrounding the object. Cube mapping uses the .dds file format to load files into the Cube
Map procedural layer. As with the sphere map, the cube allows you to modify the falloff starting and
ending points to create the exact level of reflection you want on your model.

NOTE: When exporting .dds files, they should be encoded as 8.8.8.8 ARGB files to avoid any
complications when bringing them into Mari.

Vector Brushing
A Python example script for setting up default vector shaders can be found under Python >

Examples > Setup Vector Brush or by clicking the icon on the Vector Painting toolbar. This
script automatically creates two Vector shaders in the Shaders palette, three channels in the
Channels palette, and layers in each of these channels to get you started. For more information on
using the setup vector brush script and the default vector shaders, refer to the section on Adding
Vector Shaders.

The two vector brush shaders are Vector (World Space) and Vector (Screen Space). The three
channels are Vector (Paint), Vector (World Space), and Vector (Screen Space), and these are
automatically assigned to the shader component inputs for the relevant shaders created by the script.
Each of the channels has layers in the layer stack to get you started. These layers include Vector,
Vector (Tangent To Screen Space), and Vector (Tangent To World Space).

These channels and layers assist in mapping textures according to direction, by converting pixels on
the object’s
surface to RGB values representing -1 to 1 in xyz space. For more information on using the shaders,
channels, and layers together with the Vector Painting Brush, refer to Vector Brush.

Additionally, you can opt to add a Flow adjustment, which allows you to see the effects of your vector
paint over time. The Time Offset slider represents the flow of time, while the Speed slider represents
the sensitivity of Time Offset. Adjusting the sliders allows you to see the effects your vectors play on
the flow map, though animating this also displays the effect continuously. For more information on
the vector adjustments and procedurals, as well as their layer property fields, refer to the section on
Layer Types and Examples.
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Remove and Disable Layers
1. To remove a layer:

• with the layer selected, from the Layers menu, select Remove Layers,

• right-click on the layer and select Remove Layers,

• select the layer and press Delete on the keyboard, or

• in the Layers palette, click .

2. To remove masks from existing layers:

• with the layer selected, from the Layers menu, select Layer Mask > Remove Mask, or

• right-click on the layer and select Layer Mask > Remove Mask from the dropdown menu.

3. To only disable the mask on the layer, so you can compare the results of the layer without the
mask in place:

• with the layer selected, from the Layers menu, select Layer Mask > Disable Mask, or

• right-click on the layer and select Layer Mask > Disable Mask from the dropdown menu.

Once you want to re-enable the mask visibility again, use the same methods above to navigate to
Layer Mask > Enable Mask.

4. To remove the adjustment stack from an existing layer:

• with the layer selected, from the Layers menu, select Adjustment Stack > Remove Adjustment
Stack, or

• right-click on the layer and select Adjustment Stack > Remove Adjustment Stack from the
dropdown menu.

5. To only disable the adjustment stack, so you can compare the results in the layer without the
stack in place:

• with the layer selected, from the Layers menu, select Adjustment Stack > Disable Adjustment
Stack, or

• right-click on the layer and select Adjustment Stack > Disable Adjustment Stack from the
dropdown menu.

Once you want to re-enable the adjustment stack visibility again, use the same methods above to
navigate to Adjustment Stack > Enable Adjustment Stack.

Add or Flatten Groups
Multiple layers can be grouped together either by selecting the existing layers and creating a group
with them, or by creating a new group without any initial layers and moving layers into them later.
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Layers can also be moved out of a layer group by simply dragging them back to the main layer stack
or into another group.

1. To add an empty layer group, either:

• from the Layers menu, select Add Empty Layer Group,

• right-click any layer in the Layers palette and select Add Empty Layer Group from the
dropdown menu, or

• in the Layers palette, click .

2. To create a group from existing layers:

• with layers selected, from the Layers menu, select Group Layers, or

• right-click the selected layers and select Group Layers from the dropdown menu.

Either for organizational or performance reasons, you may decide you want to flatten a group into a
single layer. Layers that were part of a group appear as if they are a single layer once flattened. Once
a group has been flattened, it can be added to other groups or used to create a new group as with
any other layer.

To flatten a layer group into a single layer:

• with the group selected, from the Layers menu, select Flatten Layer Group, or

• right-click on the group and select Flatten Layer Group from the dropdown menu.

You can also create mask stacks by turning an existing mask into a mask stack. You must already
have a mask attached to a layer to create a mask stack, but once you do, you can open a separate
Mask Stack palette to see all the mask layers in the group.

To add a mask stack to a layer, in the Layers palette, click . To create a mask stack from an
existing mask on a layer:

• with the layer selected, from the Layers menu, select Layer Mask > Make Mask Stack, or

• right-click on the layer, and select Layer Mask > Make Mask Stack from the dropdown menu.

The mask stack icon takes the place of the mask icon in the layer list. Click on the icon to open
the mask stack palette.
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Mask Stacks can also be flattened. The only difference between flattening a layer group and flattening
a mask stack is when a mask stack has been flattened, the group icon disappears from the layer and
is replaced with the mask icon again. All the mask layers that were part of the mask stack now exist in
one single mask.

To flatten a mask stack into a single mask:

• with the layer selected, from the Layers menu, select Layer Mask > Flattened Mask Stack, or

• right-click on the layer with the mask stack and select Layer Mask > Flatten Mask Stack from the
dropdown menu.

The mask stack icon reverts back to the normal mask icon and the mask stack is now only a single
mask.

Merging layers is similar to flattening layers, but can be done with any type of layer. Instead of
flattening a group of layers into a single layer, merging allows you to combine the textures from two
or more layers into a single layer, including any masks or adjustments that might have been applied
to them. However, be aware that this is a destructive process, and the results may not be the same as
anticipated in the layer stack.

NOTE: You cannot merge a layer with a layer group that has not been flattened. If you want
to merge a group with another layer or layers, you need to first flatten the group.

1. To duplicate layers, in the Layers palette, click .

The layer is duplicated as a copy.

2. To merge layers, right-click on the selected layers, and select Merge Layers.

The selected layers are merged into a new layer.
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Share Layers
If you want to duplicate a layer as a shared (connected) layer in your layer stack, you can use the
Share Layer option from the context menu. This allows you to link the layers so that any changes
made to the original layer are also produced on the shared layer. Unlike simply duplicating a layer,
sharing a layer lets you make changes to multiple copies by changing only a single linked layer.

If you want to duplicate finished layers as shared layers in a new channel, you can select Share
Layers As Channel from the context menu or Layers menu. As with the shared layer in a layer stack,
any changes made to the original layers are also made to the shared layers in the new channel.

If you want to make changes to the original layers and don’t want them to be copied over to a shared
layer, you can select Unshare Layer from the context menu to stop sharing the layer, before
continuing your work.

1. To share a layer in the same layer stack:

• with the layer selected, from the Layers menu, select Sharing > Share Layer, or

• right-click on the layer and select Sharing > Share Layer from the dropdown menu.

A new channel appears in the channels list. Selecting the channel displays the shared layer in the
layer stack.

2. To share a layer in a different layer stack:

• use Sharing > Share Layer (as outlined above) to create a shared layer, and then drag that to
the stack where you need it, or

• use modifier keys and dragging as outlined in Dragging Layers for Moving, Copying, and
Sharing.

3. To share a layer, or layers, as a new channel:

• with the layer(s) selected, from the Layers menu, select Sharing > Share Layers As Channel, or

• right-click on the layer and select Sharing > Share Layers As Channel from the dropdown
menu.

NOTE: For layers shared as new channels, you can make the new channel your current
channel by selecting Sharing > Make Shared Channel Current from either of the menus
above.

4. To unshare a layer:

• with the shared layer select, from the Layers menu, select Sharing > Unshare Layer, or

• right-click the shared layer and select Sharing > Unshare Layer from the dropdown menu.

NOTE: A shared layer is denoted by the link icon on the layer.
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TIP: With the possibility of multiple shared layers, it can be difficult to keep track of them.
Ensure that you rename any relevant layers or channels in order to limit confusion.

Cache and Uncache Layers
Layers can be cached in order to prevent Mari from slowing down. A large number of layers, or
computationally-expensive layers, can lower performance. Fortunately, caching layers can mitigate
this.

Each layer displays a colored bar to the right of the layer. This tells you how expensive the layer is and
its cached state. Inexpensive layers and cached layers are green, layers cached using Cache Up To
Here are blue, and as the layers become more complex or higher up in the layer stack they progress
to yellow, orange, and red.

When a layer has been cached, that layer is locked. Any change you may wish to make requires you to
unlock the layer. For more information about locking other selected items, see Hiding and Locking.

1. To cache a layer, or layers:

• with the layer(s) selected, from the Layers menu, select Caching > Cache Layers, or

• right-click on the layer and select Caching > Cache Layers from the dropdown menu.

2. To cache all layers up to a point in the layer stack:

• with the layer selected, from the Layers menu, select Caching > Cache Up To Here, or

• right-click on the layer you want to cache up to and select Caching > Cache Up To Here from
the dropdown menu.

Like caching a single layer, all layers cached using Cache Up To Here are locked and cannot be
edited until uncached.
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TIP: You can also combine these two functions in order to work more quickly on your layer
stack.

3. To uncache a layer, or layers:

• with the layer selected, from the Layers menu, select Caching > Uncache Layers,

• right-click on the layer and select Caching > Uncache Layers from the dropdown menu, or

• click the locked padlock icon .

The cached layer is unlocked and uncached.

4. To uncache all layers that have been locked with Cache Up To Here:

• with the layer selected, from the Layers menu, select Uncache Up To Here,

• right-click on the layer you locked with Cache Up To Here, and select Uncache Up To Here
from the dropdown menu, or

• click the locked padlock icon .

The cached layer stack is unlocked and uncached.

NOTE: If you have used the Cache Up To Here option for your caching, you can only right-
click on the top layer in the cached stack to uncache. This layer is indicated by a blue cache
bar.

Alternatively, you can uncache and unlock a layer by clicking on the padlock icon . This
uncaches and unlocks all the cached layers locked by Cache Up To Here.

EXPERIMENT: If you want to try caching and uncaching layers while using both the Cache
Layers and Cache Up To Here options, try the following:

• Cache Up To Here in your layer stack when, for instance, you need to increase the frame
rate while working on a large layer stack.

• If you want to make changes to a layer under the Cache Up to Here layer but want to keep
your frame rate low, Cache Layers on any computationally expensive layers around the
layer you want to edit.

• Uncache Up To Here on your original, top layer in the cached layer stack.

• You can now edit just that one layer, while still having some of the expensive layers around
it cached to prevent your performance suffering.
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Export and Import Layers or Masks
You can choose to either export layers or masks normally or export them in a flattened state. If you
export layers or masks normally, Mari exports the selected layer or mask to an external location, as
one of the supported file formats.

If you export layers or masks flattened, Mari flattens the selected item(s) into a single layer or mask
and exports this to an external location. This does not affect the layers or masks in your current
project, only the exported file.

Importing files into Mari to use in the Layers palette lets you import the file(s) into an existing layer.
This takes the saved texture and imports it over any textures in the existing layer, thus overwriting the
pre-existing textures. Alternatively, you can import the file(s) into the layer stack as a new layer. This
automatically adds the new layer to the top of the stack, but you can move it to anywhere in the stack
that you want.

Export Layers

To export the current selected layer:

1. From the Layers menu, select Export > Export Selected Layers, or right-click the layer(s) in the
Layers palette and select Export > Export Selected Layers from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your textures for the selected layer(s).

To export all the layers in the Layers palette:

1. From the Layers menu, select Export > Export All Layers, or right-click in the Layers palette and
select Export > Export All Layers from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your textures for the layer stack.

Export Masks

To export the mask on the current selected layer:

1. From the Layers menu, select Export > Export Selected Masks, or right-click the layer(s) in the
Layers palette and select Export > Export Selected Masks from the dropdown menu.

The Export dialog displays.
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2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your textures for the selected layer(s).

To export all the masks in the Layers palette:

1. From the Layers menu, select Export > Export All Masks, or right-click in the Layers palette and
select Export > Export All Masks from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your textures for the layer stack.

Export Flattened Layers

To flatten and export the currently selected layers:

1. From the Layers menu, select Export Flattened > Export Selected Layers Flattened, or right-
click the layer(s) in the Layers palette and select Export Flattened > Export Selected Layers
Flattened from the
dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your flattened selected layers.

To flatten and export all the layers in a layer stack:

1. From the Layers menu, select Export Flattened > Export All Layers Flattened, or right-click in
the Layers palette and select Export Flattened > Export All Layers Flattened from the
dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your flattened layer stack.

Export Flattened Masks

To flatten and export the masks of the currently selected layers:

1. From the Layers menu, select Export Flattened > Export Selected Masks Flattened, or right-
click the layer(s) in the Layers palette and select Export Flattened > Export Selected Masks
Flattened from the
dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.
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Mari exports your flattened masks from the selected layers.

To flatten and export all the masks in a layer stack:

1. From the Layers menu, select Export Flattened > Export All Masks Flattened, or right-click in
the Layers palette and select Export Flattened > Export All Masks Flattened from the dropdown
menu.

The Export dialog displays.

2. Follow the steps in Export Texture from Layers before clicking Export All Patches.

Mari exports your flattened masks from the layer stack.

Import Layers

To import textures into the currently selected layer:

1. From the Layers menu, select Import > Import into Layer, or right-click the selected layer in the
Layers palette and select Import > Import into Layer from the dropdown menu.

The Import dialog displays.

2. Follow the steps in Import Existing Textures to Layers before clicking Import All Patches.

Mari imports the textures into the currently selected layer, overwriting any other textures in the
layer.

To import textures into the layer stack:

1. From the Layers menu, select Import > Import into Layer Stack, or right-click in the Layers
palette and select Import > Import into Layer Stack from the dropdown menu.

The Import dialog displays.

2. Follow the steps in Import Existing Textures to Layers before clicking Import All Patches.

Mari imports the textures into the layer stack as a new layer that appears at the top of the stack.

NOTE: Importing a PSD file into a layer stack potentially may display a dialog regarding
layers of the same name. If layers within the .psd have the same name as layers within the
layer stack, Mari asks if you want to Update, Skip, or Create New. These options allow you
to either overwrite the named layer, skip over the layer during import, or create a new layer,
for example New diffuse if the original layer name was diffuse.
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NOTE: Take care when editing an exported Mari .psd file in Photoshop. Due to the way Mari
handles mask stacks and adjustment stacks, a layer’s sub-stack could be affected by where
new layers are inserted in a layer stack.

For instance, mask or adjustment stacks on an existing layer are shown as separate groups
from the layer in Photoshop. Inserting a new layer between the group and the original layer
before importing the file back into Mari confuses the layer stack order, causing the mask or
adjustment stack to be made a component of the new layer and not the original.

Convert Masks
1. Select the layer with the mask you want to convert.

2. Either:

• right-click on the layer in the Layers palette and select Layer Mask > Convert Mask > <texel
size>, or

• with the layer selected, from the Layers menu, select Layer Mask > Convert Mask > <texel
size>.

Mari converts the mask to the texel size that you selected, much as it would if you converted the
texel size of a channel.

NOTE: The options for the texel size conversion are 8bit (Byte), 16bit (Half), and 32bit
(Float).

Convert Alpha Values to a Mask
1. Select the layer on which you want to create a mask.

2. Either:

• right-click on a layer in the Layers palette and select Layer Mask > Add Mask > From Alpha, or

• with the layer selected, from the Layers menu, select Layer Mask > Add Mask > From Alpha.

Mari adds a mask to the layer. The mask is black and white, with the color at each pixel taken
from the alpha value of the corresponding pixel in the original layer (regardless of the actual color
of the original pixel).

TIP: To really see the effects of this, your channel should have some transparent areas. If
your channel is completely painted, the resulting mask is just white. If necessary, use the
Paint tool in Clear mode to erase some of the paint off your channel.
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Transfer Layers
You can transfer existing layers from the layers on one object or object version to another. This is
useful for re-creating work on an object with minimal changes and similar topology or an object with
the same topology but a different UV layout. By using the old textures transferred across onto the
new object, you can save time instead of starting again from scratch. Using the Layer Transfer
dialog, you can specify which object, version, frames, and patches to use as a source, and which of
these to use as a destination. Parameters such as interpolation, range, and bleed options can also be
set, so that the transfer comes as close to the original as possible. In addition, you can select different
source and destination channels where these layers come from and select as many, or all, of the
layers in that channel as you wish.

In some cases, where the topology of the object might have changed between versions, there may be
inconsistencies from the transfer. You can specify a patch Fill Color to highlight where the textures
didn't transfer to a patch, and then fix only these patches separately after the transfer.

To transfer layers from one object or version to another:

1. Select any patches that you want to transfer exclusively. This is required if you want to transfer
only specifically selected patches from the source to the destination.

2. Open the Layer Transfer dialog by selecting Layers > Transfer or by right-clicking on any layer in
the Layers palette and selecting Transfer from the right-click menu.

The Layer Transfer dialog displays.

TIP: You don't need to have a specific layer or layers selected before opening the dialog in
order to have them available in the source list.

| TRANSFER LAYERS



USER GUIDE 246

3. Under Options > Source, select the Object, Version, and Channel that the layer can be found on
currently.

4. Under Options > Destination, select the Object, Version, and Channel that the layer is being
transferred to.

5. Use the arrow buttons to move the selected layer or layers back and forth between the source and
destination layer lists.

The layers in the source list (on the left) are all the layers that are part of the selected channel. The
layers in the destination list (on the right) are those layers that have already been specified as
those to transfer to the destination object.

The double arrow keys, , move all layers from one list to another - not just those that are

selected. Alternatively, the single arrow keys, , move only the selected layer or layers. Once
the layer has been moved, it doesn't disappear from the source list.

6. If you don't want to set any of the advanced options for texture transfer, in the Advanced tab,
click Ok to start the transfer or Cancel to abandon the transfer and close the dialog. If you do
want to set the advanced options, continue with the steps below.

To transfer from one set of layers to another with advanced options for patches or animated objects:

1. In the Layer Transfer dialog, click on the Advanced tab.

2. If the object is animated, select the Frame number that you want to transfer from.
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3. Depending on whether you selected any patches before opening the Layer Transfer dialog, you
can choose the following from the Patches dropdown menu:

• All - transfers all the patches on the selected layers.

• Selected - transfers only the selected patches on the selected layers.

• Range - transfers a range of patches specified in the entry boxes.

NOTE: The Selected option is only available if you have already selected patches on the
model prior to opening the Layer Transfer dialog. Otherwise, only All and Range are
available.

4. If part of the object on the layers is hidden, specify whether to Ignore the visibility settings during
texture transfer or to transfer from only the parts of the object that are visible with the Visible
Only setting.

5. If faces or patches on the layers are selected, specify whether to Ignore the selection settings
during texture transfer or to transfer from only the faces or patches that are selected with the
Selected Only setting.

6. If the object you are transferring to is animated, select the Frame number that you want to
transfer to.

7. As with the patches from the Source, select the patch options from the dropdown menu under
Destination to specify where the designated patches are being transferred to.

8. If you also have hidden parts of an object, or selected faces or patches, on your Destination
layers, specify whether the Visibility and Selection options are set to Ignore these settings.

9. Select a search direction from the Sampling > Search dropdown menu:

• Bidirectional - both forwards and backwards raycasting.

• Forward - forward ray casting only.

• Backward - backward ray casting only.

• Radial - in a sphere outwards from one point.

By default, the search direction is set to Radial.

10. Select one of the following interpolation methods from the Sampling > Interpolation dropdown
menu:

• Nearest-Neighbor - selects the nearest pixel for sampling.

• Inverse Distance Weighted - weights the average on the closest pixels.

• Inverse Distance Weighted (Smoother) - weights the average on the closest pixels with a
priority to providing smoother sampling.

• Inverse Distance Weighted (Sharper) - weights the average on the closest pixels with a priority
to providing sharper sampling.

Interpolation is similar to Photoshop's sampling functionality and specifies how the texture is
sampled before performing the transfer.
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11. Set the Samples amount to specify the number of points to find when searching and that are
combined to produce the final color.

12. If the Object Has Moved, from the source to the destination, specify Yes. This can mean a
difference in the topology, the object being in a different location on the canvas, and navigation,
exclusive of rotation.

13. If you want to flatten the selected layers into one prior to layer transfer, select Yes from the
Flatten dropdown menu. Otherwise, leave it as No.

14. Choose whether or not to Bleed Edges for patches when performing the transfer.

15. The Range field sets how the range for the search distance, when performing the transfer, is
limited. Select one of the following from the dropdown menu:

• Infinite - there is no limit; Mari attempts to find a pixel in the source image data.

• Object Size Percentage - the maximum search distance is expressed as a percentage of the
destination object's size. For example, if the destination object is 10 world-space units and you
set the range value to 10, then the maximum distance becomes 1 world-space unit.

• World Units - the maximum search distance expressed directly in world space. For example, if
you set the range value to 2, then the maximum distance becomes 2 world space units.

16. The Fill Color field sets the fill color for new patches on the object. If an object has extra patches
that aren't covered by the transfer, then the fill color specifies whether these extra patches are
filled with Transparent, Black, White, Mid-gray, Magenta, Foreground, or Background.

17. Once you have set all the advanced options, press Ok to start the transfer or Cancel to abandon
the transfer and close the dialog.

Layer Types and Examples
Below are descriptions and examples of the different adjustments available in the Layers palette.

Examples of each of the filters are applied to the following image, for illustrative purposes:
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NOTE: Be sure to check for out-of-bounds values when adding adjustment layers. Ensure
that your filters are applied correctly by adding a Clamp adjustment to fix any values that
don’t fall between 0 and 1.

Type Description Settings Example

Adjustment Layers - Filters

Brightness Changes the brightness of the
paint on the model. You can
also change the contrast at
the same time.

In a layer stack, the
Brightness filter is always
connected to the hidden
transparency layer at the
bottom of a layer stack if the
filter is also at the bottom of
the layer stack. To prevent
this from disrupting the
transparency layer, avoid
placing Brightness filters at
the bottom of a layer stack.

Adjust the Brightness
using the entry box or
slider.

Brightness
Lookup

Changes the brightness of the
paint on the model. You can
adjust the brightness using
the curve to get a specific
brightness value.

Use the Map curve to
adjust the specific level
of brightness.
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Type Description Settings Example

Clamp Clamps color values to lie
within the specified upper
and lower values.

Set the Min value and
Max value by using the
entry box or adjusting
the sliders.

Select the individual
color component to
clamp in the R, G, B,
and A checkboxes.

Color
Balance

Adjusts the intensities of the
colors on your model in the
highlights, midtones, and
shadows.

Set whether to Preserve
Luminosity, then adjust
the Cyan/Red,
Magenta/Green, and
Yellow/Blue values in
the Highlights,
Shadows, and
Midtones.

Color Lookup Changes the color of the paint
on the model.

Use the curves to set the
individual Red, Green,
and Blue values.

Color Switch Turns individual color
channels on or off, as well as
the alpha channel.

Use the checkboxes to
select which color
channels display. When
Mari applies the filter, it
removes any unchecked
color channel or the
alpha channel from the
painting.

| LAYER TYPES AND EXAMPLES



USER GUIDE 251

Type Description Settings Example

Color to
Mask

Allows a multicolored channel
to be used for multiple masks
by converting a selected color
to a black and white mask.

Select a color using the
color swatch, and set
the error tolerance to
determine how closely
the RGB value has to be
to the selected color in
order to be considered
part of the mask.

Contrast Changes the contrast levels
on the model.

Select the amount of
Contrast and specify a
Contrast Pivot point
that you want to adjust
values around.

Copy
Channel

Copies the value from one
RGB color channel to the
other two. The result is a
grayscale image with the
intensity values from the
selected channel.

Select the source
channel from the list.
When you apply the
filter, Mari copies the
selected channel over
the other two channels.
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Type Description Settings Example

Flow Displays an image onto the
model’s surface and uses
vector data to animate it
flowing.

Note: If painting in the Clear
blending mode, the Speed
attribute is removed in that
area. The vector inspector
directional markers are still
shown on the model. This
concerns how the Flow
procedural handles the alpha
component.

• Tile Image - the image
used on the model for
flow.

• Repeat - sets the
repetition value of the
tiled image.

• Animated - Enables or
disables the
animation.

• Time Offset - controls
the flow over time.

• Speed - controls the
sensitivity of Time
Offset, which affects
the speed of flow.

In the example below,
the Flow procedural
would animate the
molten liquid so that it
appeared to moving
across the surface of the
texture:

Gamma Changes the gamma levels on
the model.

Select a particular
gamma level using
either the entry box or
the sliders.

Invert reverses the
gamma conversion. That
is, a higher setting for
Gamma results in a
more washed-out
looking image.
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Type Description Settings Example

Grade Changes the overall color
grade of the black and white
points, and allows you to
adjust the gain and gamma of
the paint on the model.

Adjust the Blackpoint to
allow you to change the
depth of the darkest
point in the paint. The
Whitepoint allows you
to increase the brightest
point in the paint.

Lift, Gain, Multiply, and
Gamma all modify the
specified aspects of the
paint to change the
overall texture; while,
Offset changes the
black and white points
as one.
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Type Description Settings Example

HSL Changes the hue, saturation,
and lightness of the colors on
the model.

Change the hue of the
colors by setting the
value for Hue. Adjusting
the slider moves the
colors around the color
wheel. The rotation
value is the degree
around the color wheel
that each color shifts,
between 0 and 360
(adjusts the slider
between -180 and 180).

The Saturation slider
adjusts the intensity of
the colors in the image
data. Select a multiplier
from 0 to 1, where .50 is
the original saturation
value.

You can also set the
Lightness value the
same way.
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Type Description Settings Example

HSV Changes the hue, saturation,
and value of the colors on the
model.

Change the hue of the
colors by setting the
value for Hue. Adjusting
the slider moves the
colors around the color
wheel. The rotation
value is the degree
around the color wheel
that each color shifts
(adjusts the slider
between 0 and 1).

The Saturation slider
adjusts the intensity of
the colors in the image
data. Select a multiplier
from 0 to 10, where 1.00
is the original saturation
value.

You can also set the
Value the same way.

Height As
Normal

Interprets the texture as
height data, then computes
the normals from the height
map and converts the
normals to a Diffuse RGB
color. This is useful for baking
normal maps from height
maps.

Bump Weight adjusts
how much bump is
applied. Lower values
are smaller; higher
values produce larger
and more obvious
displacement.
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Type Description Settings Example

Hue Shift Changes the hue of the colors
on the model. Set the value
for Hue by adjusting the
slider. This moves the colors
around the color wheel.

Select the overall hue.
The rotation value for
the color wheel is the
degree around the color
wheel that each color
shifts, between -180 and
180.

Invert Inverts the colors or the alpha
in the layers lower in the layer
stack. Invert replaces colors
with their “opposite” in the
color chart. For example, a
color with a float value of 0.3
is replaced by a color with a
float value 0.7.

Set whether to invert the
R, G, B, or A channels
individually.
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Type Description Settings Example

Levels Changes the color levels in
the paint. You can change the
white, midtone and black
points for each color channel
or all together.

Set the:

• Color Component - to
adjust the specific
color channel (Red,
Green, or Blue).

• WhiteOut - how
strongly to output the
white in the filtered
image. Higher values
show the entire white
output; lower values
show decreasing
amounts.

• BlackOut - how
strongly to output the
black in the filtered
image. Higher values
show the entire black
output; lower values
show decreasing
amounts.

• White - the upper limit
of displayed color
intensity. Areas with a
value higher than this
are mapped to 1
(white).

• Mid - the middle point
between white and
black. Mari remaps the
values so that this is
the middle of the
range between the
white point and black
point. Moving this
pushes the values
towards that end of
the spectrum.

• Black - the lower limit
of displayed color
intensity. Areas with a
value lower than this
are mapped to 0
(black).

| LAYER TYPES AND EXAMPLES



USER GUIDE 258

Type Description Settings Example

Luminosity Outputs just the luminosity
value of each pixel. That is, it
outputs a grayscale image
based on the brightness of
each of the pixels in the
original image.

Layer masking, projection
masks, and masks on
projectors are all hardwired
to use the red color
component. If you want to
use another component for
your mask value, the
Luminosity adjustment layer
allows you to convert an RGB
input to a grayscale output.

None.

Premultiply
Alpha

Either pre- or post-multiplies
the alpha in the selected
image. If you are painting
using an image without
premultiplied alpha onto one
with it, use this filter to
perform the
premultiplication, so the
images match and you avoid
lines around the outside of
the patch. Postmultiply works
the same, but in reverse: it
removes premultiplication to
match images that do not
have premultiplied alpha.

If the Unpremultiply
box is checked, this acts
in reverse (that is,
removes premultiplied
alpha).
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Type Description Settings Example

Saturation Changes the intensity of the
colors in the image data.

The Saturation slider
adjusts the intensity of
the colors in the image
data. Select a multiplier
from 0 to 10, where 1.00
is the original saturation
value.

Scale Directly modifies the overall
scale of the color values for
each channel individually.

Adjusting the sliders for
R, G, B, and A allows
you to specify the exact
level of scale for each
channel, between 0 and
2.

Set Value Changes the values of specific
RGBA channels.

Selecting Red, Green,
Blue, or Alpha from the
Channel dropdown
menu allows you to
adjust the slider (from 0-
1) to change the value of
the specific color
channel.
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Type Description Settings Example

Shuffle Shuffles the RGBA channels
so that any of them can be
replaced by another color
channel.

Layer masking, projection
masks, and masks on
projectors are all hardwired
to use the red color
component. If you want to
use another color component
for your mask value, the
Shuffle adjustment layer
allows you to change the
RGBA components so that
any can be replaced by
another.

Change the channels of
R, G, B, or A to affect
the overall color of the
paint on the model.

Tangent To
Screen

Sets up a Tangent To Screen
adjustment to be used for
Vector Brushing. This
adjustment is automatically
created when creating default
vector shaders.

Suppress the blue value
from the color-encoded
vectors in screen space
by ticking the Suppress
Blue checkbox.

Tangent To
World

Sets up a Tangent To World
adjustment to be used for
Vector Brushing. This
adjustment is automatically
created when creating default
vector shaders.

Suppress the blue value
from the color-encoded
vectors in the world
space by ticking the
Suppress Blue
checkbox.
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Type Description Settings Example

World To
Tangent

Sets up a World To Tangent
adjustment so that you can
convert normals from world
space into tangent space
normals.

Suppress the blue value
from the color-encoded
vectors in the tangent
space by ticking
Suppress Blue
checkbox. Choose
whether to flip the Y axis
or leave the normals as
they are on Flip Y.

sRGB2Linear Applies an sRGB to linear
colorspace conversion.

Checking Invert applies
a linear to sRGB
colorspace conversion.

Below are descriptions and examples of the different procedurals available in the Layers palette.

Examples of each of the procedurals are applied to the following image, for illustrative purposes:

Type Description Settings Example

Procedural Layers - Basic
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Type Description Settings Example

Color Applies the selected
color to the rest of
the paint on the
model.

Changing the Blend Mode and
Amount allows you to adjust
how the color is applied, and
how strongly, to the model.
Color allows you to select the
color from the HSV swatch
palette.

Procedural color set to
burgundy:

Color procedural
(Screen blend):

Constant Generates a constant
number across RGB
or RGBA components
that may be relied
upon for
mathematical
operations.

The Constant slider ranges from
0 to 10,000, and defaults to 1.000
when reset. Components may
be set to either RGB or RGBA.

Constant procedural
(Multiply blend):
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Type Description Settings Example

Vector Applies RGBA values
to a vector (XYZW)
map to produce a
specific diffuse color
that represents a
vector field.

The X, Y, Z, and W fields
correspond to R, G, B, and A
respectively to give a specific
vector in a diffuse image.

Vector procedural with
XYZW values adjusted:

Vector procedural
(Multiply blend):

Procedural Layers - Environment

Cube Map Simulates a shiny
reflective surface
using a cubic
environment map as
the input. This layer
cannot be cached or
baked, and is for
display purposes
only.

• Cubic Image - the location of
the cube map.

• Falloff Start - controls where
the cubic image starts.

• Falloff End - controls where the
cubic image ends.

Cube Map procedural
(Luminance blend):

Cube Map procedural
(Luminance blend) over
layer:
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Type Description Settings Example

Sphere Map Simulates a shiny
reflective surface
using a spherical
environment map as
the input. This layer
cannot be cached or
baked, and is for
display purposes
only.

• Sphere Map - the location of
the environment map.

• Falloff Start - controls where
the spherical image starts.

• Falloff End - controls where the
spherical image ends.

Sphere Map procedural
(Luminance blend):

Sphere Map procedural
(Luminance blend) over
layer:
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Type Description Settings Example

Cube Map
Projector

Uses a cubic image (in
a .dds file format) as a
texture to project
onto the model. This
layer cannot be
cached or baked, and
is for display
purposes only.

Note: When saving
.dds files in other
applications, they
should be encoded as
8.8.8.8 ARGB files to
avoid any
complications when
bringing them into
Mari.

• Cubic Image - the filepath to
the cubic image to use for
projection.

• Cull Backfaces - when the
checkbox is ticked, it ensures
that projection does not affect
areas facing away from the
camera.

• Offset X, Y, and Z - the offset of
the projection image on the X,
Y, and Z axes.

• Rotation X, Y, and Z - the
rotation of the projection
image on the X, Y, and Z axes.

• Edge Falloff Start and End -
modifies how far away the
falloff starts or ends.

• Edge Falloff Curve - allows you
to adjust the otherwise linear
shape of the falloff to your
desired shape.

• Distance Falloff Start and End -
adjust the start and end radial
distance from the camera.

• From 0-100, where 100
represents straight-on
projection.

• Distance Falloff Curve - allows
you to adjust the otherwise
linear shape of the falloff to
your desired shape.
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Type Description Settings Example

Environment
Light

Displays the
environment light
reflection, if the
Image in the
Environment light in
the Lights palette has
been set.

This layer cannot be
cached or baked, and
is for display
purposes only.

• Sharpness - adjusts the
sharpness of the reflections on
the model, with higher values
increasing the sharpness and
lower values decreasing it.

Environment Light
procedural (using one
of the preset
environments shipped
with Mari):
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Type Description Settings Example

Sphere Map
Projector

Uses a spherical
image of any file type
as a texture to project
onto the model. This
layer cannot be
cached or baked, and
is for display
purposes only.

• Cull Backfaces - when the
checkbox is ticked, it ensures
that projection does not affect
areas facing away from the
camera.

• Spherical Image - the filepath to
the spherical image to use for
projection.

• Offset X, Y, and Z - the offset of
the projection image on the X,
Y, and Z axes.

• Rotation X, Y, and Z - the
rotation of the projection
image on the X, Y, and Z axes.

• Edge Falloff Start and End -
modifies how far away the
falloff starts or ends.

• Edge Falloff Curve - allows you
to adjust the otherwise linear
shape of the falloff to your
desired shape.

• Distance Falloff Start and End -
adjust the start and end radial
distance from the camera.

• From 0-100, where 100
represents straight-on
projection.

• Distance Falloff Curve - allows
you to adjust the otherwise
linear shape of the falloff to
your desired shape.
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Type Description Settings Example

Triplanar
Projection

Uses three different
images to project
onto the surface of
your model from
three different
directions (Top, Front,
and Right).

Each of the
parameters listed
(other than World
Scale) are for each of
these three
directions.

• World Scale - overall scale
control for the image
projection.

• Image - the images you want to
project onto each of the three
directions.

• Repeat - frequency that the
image is repeated across your
model.

• Angle - the rotation angle of
the image on your model.

• U Offset - how much the image
on the model is offset by on the
U axis.

• V Offset - how much the image
on the model is offset by on the
V axis.

• U Scale - how much the image
on the model is stretched or
contracted on the U axis.

• V Scale - how much the image
on the model is stretched or
contracted on the V axis.

• Falloff Start - controls where
the image projection starts on
the model.

• Falloff End - controls where the
image projection ends on the
model.

• Falloff - controls the falloff of
the image projection between
the start and end values.

Procedural Layers - Geometry
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Type Description Settings Example

Ambient
Occlusion

Applies an ambient
occlusion shading to
the surface.

This overrides Mari's
default ambient
occlusion shader,
allowing you to
change the details.
For example, you can
edit the channel to
use as an ambient
occlusion map.

If you want to save
the default ambient
occlusion data for the
project as a channel,
you can bake the
ambient occlusion
from the default
shader. You can then
edit this baked
channel as you want.

None.

Note: This overrides the ambient
occlusion shading Mari applies
by default. This means that if you
just bake out the ambient
occlusion and then use this as
the input to this shader, you see
no difference (you're applying
the ambient occlusion that Mari
would apply anyway). Try
changing the ambient occlusion
value under the Lighting
component of the shader, or edit
the ambient occlusion mask
channel.

Ambient Occlusion
procedural:

BiTangent Outputs bitangent
vectors to, along with
tangent and normal
vectors, create a TBN
matrix that can map
from world space to
tangent space (or the
other way around).

None. BiTangent procedural:
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Type Description Settings Example

Position Displays the graphic
representation of the
surface positions (XYZ
as RGB).

None. Position procedural:

Selection
Mask

Outputs white (1.0)
color values for
masked regions and
black (0.0) color
values for unmasked
regions, based on the
current selection in
the selection mode.

It is best to convert
the procedural to a
paintable layer once
you are ready to use
it.

None.

Note: To create a selection mask,
you must be using the Select
tool, not the Marquee Select
tool, in Face mode.

Selection Mask
procedural:

Surface
Normal

Converts the present
surface normals to a
Diffuse RGB color.
This is useful for
baking out normal
maps from the bump
channel.

None. Surface Normal
procedural:

Tangent Outputs tangent
vectors to, along with
bitangent and normal
vectors, create a TBN
matrix that can map
from world space to
tangent space (or the
other way around).

None. Tangent procedural:
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Type Description Settings Example

UDIM Mask Masks out all other
UDIMs on a model,
except for the
selected UDIM.

The UDIM selector allows you to
select which UDIM you can paint
on and masks out all others.

UDIM Mask procedural:

UV Converts the UV to a
color, based on the
UDIM values. Useful
for debugging UV
layouts.

None. UV procedural:

UV procedural in UV
view:

UV Mask Outputs white (1.0)
color values for
regions where there is
some geometry and
black (0.0) for regions
where there is no
geometry.

When baked to a
texture by Convert to
Paintable, the layer
becomes a UV mask
texture.

None. UV Mask procedural:

UV Mask procedural in
UV view:
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Type Description Settings Example

Procedural Layers - Fractal

Cloud Blends seamless 3D
noise in a cloud
pattern with the
shaded surface, using
the specified Blend
Mode.

Note: If you are
accustomed to using
Fractal Noise from
previous versions of
Mari, you can still
affect fractal
properties such as
Contrast by adding a
Contrast adjustment
to the Cloud
procedural.

You can control the look of the
cloud pattern by adjusting the
Size and Roughness of the
pattern, as well as the pattern
offset for the X, Y, and Z values.
Color A and Color B allows you
to set the cloud pattern colors
used on the model.

Cloud procedural:

Cloud procedural over
layer:

Turbulence Blends seamless 3D
noise in a turbulence
pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
turbulence pattern by adjusting
the Size and Roughness. Color A
and Color B allows you to set the
turbulence pattern colors used
on the model.

Turbulence procedural:

Turbulence procedural
over layer:

Procedural Layers - Misc
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Type Description Settings Example

Oil Blends seamless 3D
noise in an oil pattern
with the shaded
surface, using the
specified Blend
Mode.

You can control the look of the
oil pattern by adjusting the Size
and the Organicness or
Roughness qualities. Color A
and Color B allows you to set the
oil pattern colors used on the
model.

Oil procedural:

Oil procedural over
layer:

Procedural Layers - Noise

Cellular Blends seamless 3D
noise in a cellular
pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
cellular pattern by adjusting the
Size and Type of cells to use.
Additionally, you can specify the
Distance method used to
achieve a specific look. Color A
and Color B allows you to set the
cellular pattern colors used on
the model.

Cellular procedural:

Cellular procedural over
layer:
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Type Description Settings Example

Perlin Blends seamless 3D
noise in a perlin
pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
perlin pattern by adjusting the
Size and color. Color A and
Color B allows you to set the
perlin pattern colors used on the
model.

Perlin procedural:

Perlin procedural over
layer:

Squiggle Blends seamless 3D
noise in a squiggle
pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
squiggle pattern by adjusting the
Size and color. Color A and
Color B allows you to set the
squiggle pattern colors used on
the model.

Squiggle procedural:

Squiggle procedural
over layer:

Procedural Layers - Pattern

| LAYER TYPES AND EXAMPLES



USER GUIDE 275

Type Description Settings Example

Cube Blends a seamless
cubic pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
cubes by adjusting the Repeat
pattern and Gap spacing. Falloff
and Roundness give you even
more aspects to fine-tune the
pattern. Color A and Color B
allows you to set the cube
pattern colors used on the
model.

Cube procedural:

Cube procedural over
layer:

Object Space
Linear
Gradient

A procedural version
of the Gradient tool.
This behaves the
same as Gradient
without painting the
gradient onto the
model.

Adjust the gradient Start and
End points to determine where
Color A and Color B are on the
object.

Use the Map to fine-tune the
gradient as a color curve.

Rotation X, Y, and Z points adjust
the gradient along the X, Y, or Z
axes.

Object Space Linear
Gradient procedural:

Object Space Linear
Gradient procedural
over layer:
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Type Description Settings Example

Sphere Blends a seamless
spherical pattern with
the shaded surface,
using the specified
Blend Mode.

You can control the look of the
spheres by adjusting the Size
and Falloff of the pattern. Color
A and Color B allows you to set
the sphere pattern colors used
on the model.

Sphere procedural:

Sphere procedural over
layer:

Tiled Lets you select an
image to tile across
the surface of your
model.

This layer is disabled
for Ptex channels.

• Tile Image - the location of the
image you want to tile across
the surface of your model.

• Rotation Angle (Degrees) - the
angle (in degrees) that the
image is rotated by.

• U Offset - how much the image
is offset by on the U axis.

• V Offset - how much the image
is offset by on the V axis.

• U Repeat - the frequency at
which the image is repeated on
the U axis.

• V Repeat - the frequency at
which the image is repeated on
the V axis.

• Mirror U - check to mirror the
image on the U axis.

• Mirror V - check to mirror the
image on the V axis.

Tiled image:

Tiled Image over layer:
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Type Description Settings Example

UV Grid Blends a seamless UV
grid pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
UV grid by adjusting the Color
and Thickness of the pattern, as
well as the level of Repeat.

UV Grid procedural:

UV Grid procedural over
layer:

UV Linear
Gradient

A procedural version
of the Gradient tool
for use in UV space.
Behaves the same as
Gradient without
painting the gradient
onto the model.

Adjust the gradient Start and
End points to determine where
Color A and Color B are on the
object.

Use the Map to fine-tune the
gradient as a color curve.

Adjust the Angle of the gradient
and how much you want the
gradient to be allowed to
Repeat. Repeating the gradient
does so by tiling.

UV Linear Gradient in
the UV tab (without UV
image rendering):

UV Linear Gradient in
the UV tab (with UV
image rendering):

Procedural Layers - Plant
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Type Description Settings Example

Wood Blends seamless 3D
noise in a wood grain
pattern with the
shaded surface, using
the specified Blend
Mode.

You can control the look of the
wood pattern by adjusting the
Size of the pattern and of the
bands, as well as the Roughness
of the pattern. The offset can be
adjusted in X, Y, and Z space.
Additionally, Color A and Color B
allows you to set the wood
pattern colors used on the
model.

Wood procedural:

Wood procedural over
layer:
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Channels
Mari supports multiple channels. New projects start with a single channel. You can add as many
additional channels as you need. A single project can hold all the channel data required for the model
- diffuse, dirt, specular, luminescence, displacement, and so on. Each object in a Mari project has its
own set of channels. See Working with Objects for details on working with multiple objects.

Different Ways to Create Channels
When you create a channel, you set the color depth and patch size. You can change both of these
after creation. If channels are resized after creation, Mari automatically resizes all the layers in the
channel’s layer stack. Channels are either color or scalar. Channels can be created:

• using the settings for existing or recently-created channels as a template.

• in bulk, using Mari's inbuilt presets, optionally importing textures into the channel at the same time.

• from a preset size, color depth, and type.

• entirely custom and ad hoc.

• by copying a layer to a new channel (see Layers for details).

• by sharing a layer as a new channel (see Layers for details).

HDR Channels
The dynamic range of luminance in the real world is much greater than the range that is usually
displayed on a screen. Low dynamic range (8-bit) color values can represent RGB levels only within
the range of 0 (black) to 1 (white). In Mari, using 16-bit or 32-bit color values, you can clone from, or
paint through, images outside of the 0 to 1 range.

For details on creating and working with channels that support HDR images, see Create and Delete
Individual Channels.

Edit Paint on Your Channels
The paint in your channels can be edited or transformed, much the same as with patches. Where the
transform functions differ is in how they change the paint on the model. Patches are very specific and
only transform paint on the selected UV patch. Channels, on the other hand, can include paint across
many patches and faces in their layer stacks. In this way, transforming a channel can affect a larger
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amount of paint across a greater part of a model, depending on how extensive the paint in the
selected channel is.

Create and Delete Individual Channels
To create a channel:

1. Open the Channels palette by:

• right-clicking on the toolbar, and selecting Channels from the dropdown menu, or

• selecting Palettes > Channels from the View menu.

The Channels palette displays, showing the channels in the current project, a quick channel
creation bar, and channel attributes in the bottom pane.

NOTE: By default, a channel named "diffuse" is created in the Channels palette when you
start up a new project.

2. Add a single channel by:

• right-clicking in the Channels palette, and selecting Add Channel,

CHANNELS | CREATE AND DELETE INDIVIDUAL CHANNELS
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• clicking the button, or

• selecting Add Channel from the Channels menu.

The Add Channel dialog box displays.

3. The dropdown list at the top shows the names of channels that you've created recently. Select one
from the list.

The Name, Size, Depth, File Space, and Colorspace populate automatically.

TIP: If you have never created a channel, the dropdown at the top of the dialog does not
appear, and the Name field is not populated automatically.

4. As needed, you can change:

• Name - the name to identify the channel (which you can change later).

• Size - the patch size for the new channel.

• Depth - the color depth (8-, 16-, or 32-bit).

• File Space - the type of file space used for vector painting: Normal, Vector, Vector (flipped Y),
or Normal (flipped Y).

• Colorspace - the colorspace to which the channel data or mask data is converted.

• Color - the default color of the channel, on creation.

CHANNELS | CREATE AND DELETE INDIVIDUAL CHANNELS
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5. If you intend on cloning from, or painting through, either 16-bit or 32-bit images, the Depth
needs to be set to either 16bit (Half) or 32bit (Float), respectively. In addition, the color depth of
the paint buffer needs to match the depth of the channel.

Furthermore, if you do not want the range of 16-bit or 32-bit images clamped to values between 0
and 1, you need to uncheck the Clamp checkbox under the Paint Buffer settings in the Painting
palette.

6. Set the Colorspace for the channel to which the channel data is converted. Automatic is
determined by the file name, size, and type of data in the channel.

7. Set the Colorspace for the channel's masks to which the mask data is converted. Automatic is
determined by the file name, size, and type of data in the channel.

TIP: If you are not familiar with colorspaces, you may want to keep the default colorspace
that Mari automatically selects for the Colorspace fields.

8. Select the initial Color for the channel. To select a different color, click on the swatch and choose
a color with the color picker.

9. Click Ok to add the channel to the object.

Mari creates your new channel, and displays it in the Channels palette.

NOTE: If you are adding channels in a project with more than one object, instead of the Ok
button, there are two buttons in the Add Channel dialog. You can opt to either add a
channel to only the selected object or to all objects in the project, or cancel.

NOTE: If you have already created a channel with a given name and attempt to create a new
channel with the same name, Mari increments the name to differentiate between the original
and new channel. For instance, if you already have a "diffuse" channel and create another
channel named "diffuse", Mari automatically gives it the name "diffuse1".

To create a copy of a channel, press Alt+drag-and-drop the channel. Mari creates your new channel as
a copy of the original - including the layers, but not all the paint in those layers.

To delete a channel:

• right-click on the channel in the Channels palette, and select Remove Channel,

• with the channel selected, click ,

• select Remove Channel from the Channels menu, or

• with the channel selected, press Delete on the keyboard.

If you have other objects in the project that have a channel with the same name, you have the option
of removing the channels from only the selected object, or all objects in the project.
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Flatten Channels
Channels with large layer stacks or complex groups of layers, adjustments and procedurals can be
flattened into a single base layer to save space and simplify channel organization. Flattening layers
does not affect the final output, as the texture from the accumulated layers is not changed, only
combined into a single layer.

If you are considering flattening the layer stack for a channel so that you can save space when
exporting the channel, please bear in mind that it is possible to flatten channels on export. Flattening
a channel on export does not affect the layer stack in your project, but combines the layers into a
single base layer in the exported file.

To flatten the selected channel, right-click in the Channels palette and select Flatten, or from the
Channels menu, select Flatten. A progress bar displays showing the time left until the channel has
finished being flattened.

CreateMultiple Channels from Presets
Mari includes channel presets. These are sets of the “standard” channels required to paint various
types of assets - for example, the channels required for a vehicle or a digital double. You can use
these presets to create a group of channels at once. If you already have some existing textures for the
new channels, you can automatically load these into the new channels as they are created.

TIP: You can customize the channel presets functions by writing your own channel preset
and channel template files, to create custom presets and templates. For more information,
refer to the steps below and the chapter Extending Mari.

1. To create multiple channels from presets:

• right-click in the Channels palette, and select Channel Presets, or

• from the Channels menu, select Channel Presets.

The Channel Presets dialog opens.
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2. The Root Path is the base directory for your Mari project. Mari looks here for textures to import
when creating the channels. If the textures are in a different directory, change the Root Path to

point to the appropriate directory, or use the button to display an Open dialog to find the
right directory.

3. If you want to import existing textures into the channels as you create them, select whether to
import All Patches or only the Selected Patches.

4. If you want to import existing textures, select in Resize how Mari should deal with patch/image
size mismatches (for example, when trying to import a 2048x2048 image into a 1024x1024 patch).
This can be either:

• Patches to fit images - for example, Mari would automatically resize a 1024x1024 patch to
2048x2048 to fit the image.

• Images to fit patches - for example, Mari would automatically resize a 2048x2048 image to
1024x1024 before importing it onto the patch.

5. Enter in a Prefix to assign a designation to the channels. This allows you to organize them
according to categories in your list.

6. Select the channels to create and import from the list by clicking in the boxes. You can either click
to check the boxes individually, or right-click the list and select Add Custom, Create All, Create
None, Import Existing, or Import None.

7. You can change any selected channel's Size, Colorspace, File Space, Fill, Depth, or Files path.

8. If you want to import textures listed for the channel, check that Mari has found them (as indicated
by a green bar or a number listing the number of textures found for the model). If Mari hasn't

found them (as indicated by a red bar ), you can click to bring up the Open dialog box in
order to manually find the texture files.

9. Once you are happy with the channels and textures selected, click OK.

Mari creates the channels, and imports any selected textures.
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TIP: Depending on the number of channels and the size of the textures, the import could
take a long time. Consider taking a little break!

Navigate Between Channels

There are several ways to navigate between the channels in the Channels palette list:

• To view a particular channel, click on the channel in the Channels palette.

• To move to the next or previous channels, click Channels > Next Channel or Previous Channel, or
use the up and down arrow keys to step through the list.

• Press Page Up to move to the first channel visible in the list and Page Down to move to the last
visible in the list. If you have a long list of channels, you can resize the pane to view more channels
at once. Pressing Page Up and Page Down selects whichever channels are visible at the top and
bottom of the pane.

• Press T to toggle between the last two channels viewed.

NOTE: When using the T shortcut, the mouse focus should not be in the Channels palette,
or the selection doesn't toggle. If you aren't seeing the channel selection toggle, click outside
of the palette, then try again.

Set and Change Channel Properties
1. To change the color depth of an existing channel, either:

• right-click in the Channels palette, and select Convert Channel from the dropdown menu,

• with the channel selected, click , or

• from the Channels menu, select Convert Channel.

The Convert Channel dialog box displays.

2. Select the new Type (color depth) and click OK.
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Take and Manage Channel Snapshots
You can take snapshots of the current channel or all channels in a project.

Snapshot Current Channel
1. To take a snapshot of the current channel:

• select Channels > Snapshots > Snapshot Current Channel, or

• from the Snapshots palette, with Channels set to Current, click , or

• right-click the channel and select Snapshots > Snapshot Current Channel from the dropdown
menu.

The Snapshot Channel dialog box displays.

2. Enter a name for the snapshot and click OK.

Snapshot All Channels
1. To take a snapshot of all channels in the project, either:

• select Channels > Snapshots > Snapshot All Channels, or

• from the Snapshots palette, with Channels set to All, click , or

• right-click the channel and select Snapshots > Snapshot All Channels from the dropdown
menu.

The Snapshot All Channels dialog box displays.

2. Enter a name for the snapshot and click OK.

NOTE: Before a snapshot is taken you need to bake or clear the paint buffer. If you have not
done this already, a dialog displays asking you to do so.
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Use the Snapshots Palette
Once taken, snapshots are added to the Snapshots palette. To open the Snapshots palette:

• right-click on the toolbar, and select Snapshots from the menu,

• from the View menu, select Palettes > Snapshots, or

• from the Channels menus, select Snapshots > Manage Snapshots.

The Snapshots palette displays, showing the existing snapshots for the current channel and for the
entire project. Information about the snapshot, such as when it was taken and by which user, along
with a thumbnail preview, is also displayed.

There are a number of options available for managing existing snapshots. From the Snapshots
palette you can create New snapshots, Extract, Revert, or Delete snapshots.

To Extract a Snapshot into a NewChannel:

1. With the Current button active, select a snapshot and click .

The Extract Snapshot dialog displays.

2. Enter a name for the new channel and click OK.
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Mari creates a new channel with the given name.

To Load an Existing Snapshot:

Select the snapshot and click .

Mari loads the selected snapshot into the current channel.

To Delete a Snapshot:

1. Select a snapshot and click .

The Delete Snapshot dialog displays, asking you to confirm.

2. Click OK.

The snapshot disappears from the Snapshots palette.

Autosnapshots

Mari lets you create incremental copies of your textures as you paint. These copies, or snapshots,
save the current state of either a single channel, or all channels in a project. Snapshots are useful for:

• Keeping multiple versions of a texture while trying out new ideas.

• Maintaining a development history between sessions, and having the option to undo mistakes.

Once a snapshot is taken, it is added to the Snapshots palette where you can see a list of existing
snapshots and options for managing them.

When saving a project, Mari automatically takes a snapshot of all available channels and adds it to the
Snapshots palette. This feature is disabled by default but can be managed in the Mari Preferences
dialog.

To manage autosnapshots:

1. Click Edit > Preferences.

The Mari Preferences dialog displays.

2. From the dropdown menu under Data > Channels > Autosnapshot select whether
autosnapshots are:

• Disabled,

• Enabled with Limit, or

• Enabled - Unlimited.

3. When Enabled with Limit is selected, Mari limits the number of autosnapshots that are stored in
the
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Snapshots palette to the number specified by the Autosnapshot Limit. If the number of
autosnapshots stored exceeds this limit, the oldest autosnapshot is removed from the palette.

NOTE: The Autosnapshot Limit does not affect the number of regular channel snapshots
that can be stored in the Snapshots palette.

Share Channels
Unlike the layer sharing functionality in the Layers menu and palette, channel sharing doesn’t have a
menu option in either the context menu or Channels menu. Sharing channels is different from
sharing layers, in that the functionality is much more limited. Channels can be, however, be shared
into the layer stack of other layers. Follow the steps below to share channels into layers.

To share a channel into the layer stack of another channel in the Channels palette:

1. Select the channel (channel A), press Shift and drag the channel you want to share over another
channel in the Channels palette (channel B).

Channel B becomes highlighted, to show that it is now the current selected channel.

2. Don’t drop channel A on top of channel B. Once channel B becomes highlighted, drag channel A
into the layer stack in the Layers palette.

Channel A is now shared and appears in channel B’s layer stack as a layer of the same name. Both

the shared channel and layer display linked icons in the palette.

TIP: It is much easier to share channels into a layer stack if both the Channels and Layers
palettes are open, not only simultaneously, but side by side or near each other in your
palette configuration.

Lock and Unlock Channels
1. Lock the current channel:

• with the channel selected, from the Channels menu, select Lock Channel,

• from the Channels palette, right-click on the channel and select Lock Channel from the
dropdown menu, or

• from the Channels palette, click on the lock icon next to the channel you want to lock.

The current channel is locked.
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The channel's listing in the Channels palette changes to show the “closed lock” icon .

NOTE: If you attempt to paint on the canvas when a channel is locked, the paint shows up in
the paint buffer. When you attempt to bake, the paint buffer is cleared without baking the
paint down into the locked channel. If you didn’t want the paint buffer to be cleared, simply
undo the bake.

2. Lock all channels:

• from the Channels menu, select Lock All Channels, or

• from the Channels palette, right-click on the channel and select Lock All Channels from the
dropdown menu.

All channels in the Channels palette are locked.

3. Unlock the current channel:

• from the Channels menu, select Unlock Channel,

• from the Channels palette, right-click on the channel and select Unlock Channel from the
dropdown menu, or

• from the Channels palette, click on the lock icon next to the channel you want to unlock.
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Mari unlocks the current channel and changes its listing in the Channels palette back to the “open

lock” icon.

4. Unlock all channels:

• from the Channels menu, select Unlock All Channels, or

• from the Channels palette, select Unlock All Channels.

All channels in the Channels palette are unlocked.

NOTE: Please be aware that if you have used the Lock All or Unlock All functions from the
dropdown menu on the canvas, this does not affect the lock state of the channels. However,
Lock Everything and Unlock Entire Object applies to all objects, patches, and faces, and
channels.

Export Channels
Exporting channels to save work to an external source, or to pass on to the next stage of your
pipeline is possible on both an individual and collective channel basis.

You can export channels with all layers together in a single file, either in a multi-layered file format,
such as .psd or .psb, with each layer separate in a non-layered format, such as .png, or with the layers
all flattened together. You can also export the current channel, all channels, or the channels for all
objects in your project.

To export the currently-selected channel:

1. From the Channels menu, select Export > Export Current Channel, or right-click the channel in
the Channels palette and select Export > Export Current Channel from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Textures from Channels before clicking Export All Patches.

Mari exports your textures for the selected channel.

To export all the channels in the Channels palette:

1. From the Channels menu, select Export > Export All Channels, or right-click in the Channels
palette and select Export > Export All Channels from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Textures from Channels before clicking Export All Patches.

Mari exports your textures for all channels in the Channels palette.

To export all the channels from all the objects of your project:
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1. From the Channels menu, select Export > Export Everything, or right-click in the Channels
palette and select Export > Export Everything from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Textures from Channels before clicking Export All Patches.

Mari exports your textures for all objects.

Export Flattened Channels
For channels with large layer stacks, you can also opt to flatten layers before export to save space and
organize finished work.

NOTE: Exporting channels flattened does not flatten the layer stack in your current project;
only the layer stack in the exported file. For this reason, you won’t need to worry about
changing the work in your current project, but can save time and space when exporting files.

To export the currently selected channel with flattened layers:

1. From the Channels menu, select Export Flattened > Export Current Channel Flattened, or
right-click the channel in the Channels palette and select Export Flattened > Export Current
Channel Flattened from the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Textures from Channels before clicking Export All Patches.

Mari exports your flattened textures for the selected channel.

To export all the channels in the Channels palette with flattened layers:

1. From the Channels menu, select Export Flattened > Export All Channels Flattened, or right-
click in the Channels palette and select Export Flattened > Export All Channels Flattened from
the dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Textures from Channels before clicking Export All Patches.

Mari exports your flattened textures for all channels in the Channels palette.

To export all the channels, from all the objects in your project, with flattened layers:

1. From the Channels menu, select Export Flattened > Export Everything Flattened, or right-click
in the Channels palette and select Export Flattened > Export Everything Flattened from the
dropdown menu.

The Export dialog displays.

2. Follow the steps in Export Textures from Channels before clicking Export All Patches.

Mari exports your flattened textures for all objects.
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Import Channels
Importing channels allows you to import textures that have already been worked on or that come
from another source. Importing channels is done by importing the textures into the layer stack or
into a new channel.

To import textures into the layer stack of the currently selected channel:

1. From the Channels menu, select Import > Import into Layer Stack, or right-click channel in the
Channels palette and select Import > Import into Layer Stack from the dropdown menu.

The Import dialog displays.

2. Follow the steps in Import Existing Textures to Channels before clicking Import All Patches.

Mari imports the textures into the layer stack of your currently selected channel.

To import textures into a new channel:

1. From the Channels menu, select Import > Import into New Channel, or right-click in the
Channels palette and select Import > Import into New Channel from the dropdown menu.

The Add Channel dialog displays.

2. Set the options for your new channel and assign it a name. Click OK.

The Import dialog displays.

3. Follow the steps in Import Existing Textures to Channels before clicking Import All Patches.

Mari imports the textures as a new channel.

Transfer Channels
You can transfer existing channels from one object or version to another. This is useful for re-creating
work on an object with minimal changes and similar topology or an object with the same topology
but a different UV layout. By using the old textures transferred across onto the new object, you can
save time instead of starting again from scratch. Using the Channel Transfer dialog, you can specify
which object, version, frames, and patches to use as a source for the texture, and which of these to
use as a destination. Parameters such as interpolation, range, and bleed options can also be set, so
that the transfer comes as close to the original as possible.

In some cases, where the topology of the object might have changed between versions, there may be
inconsistencies from the texture transfer. You can specify a patch Fill Color to highlight where the
textures didn't transfer to a patch, and then fix only these patches separately after the transfer.

To transfer channels from one object or version to another:
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1. Select any patches that you want to transfer exclusively. This is required if you want to transfer
only specifically selected patches from the source to the destination.

2. Open the Channel Transfer dialog by selecting Channels > Transfer or by right-clicking in the
Channels palette and selecting Transfer from the right-click menu.

The Channel Transfer dialog displays.

TIP: You don't need to have a specific channel or channels selected before opening the
dialog in order to have them available in the source list.

3. Under Options > Source, select the Object and Version that the channel can be found on
currently.

4. Under Options > Destination, select the Object and Version that the channel is being
transferred to.

5. Use the arrow buttons to move the selected channel or channels back and forth between the
source and destination channel lists.

6. Using the Size dropdown, select the texture resolution of the destination channel.

NOTE: The texture resolution can only be set for UV maps.
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The channels in the source list (on the left) are all the channels on the object. The channels in the
destination list (on the right) are those channels that have already been specified as those to
transfer to the destination object.

The double arrow keys, , move all channels from one list to another - not just those that

are selected. Alternatively, the single arrow keys, , move only the selected channel or
channels. Once the channel has been moved, it doesn't disappear from the source list.

7. If you don't want to set any of the advanced options for transfer, in the Advanced tab, click Ok to
start the transfer or Cancel to abandon the transfer and close the dialog. If you do want to set the
advanced options, continue with the steps below.

To transfer from one set of channels to another with advanced options for patches or animated
objects:

1. In the Channel Transfer dialog, click on the Advanced tab.
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2. If the object is animated, select the Frame number that you want to transfer from.

3. Depending on whether you selected any patches before opening the Channel Transfer dialog,
you can choose the following from the Patches dropdown menu:

• All - transfers all the patches on the selected channels.

• Selected - transfers only the selected patches on the selected channels.

• Range - transfers a range of patches specified in the entry boxes.

NOTE: The Selected option is only available if you have already selected patches on the
model prior to opening the Channel Transfer dialog. Otherwise, only All and Range are
available.

4. If part of the object on the channels is hidden, specify whether to Ignore the visibility settings
during texture transfer or to transfer from only the parts of the object that are visible with the
Visible Only setting.

5. If faces or patches on the channels are selected, specify whether to Ignore the selection settings
during texture transfer or to transfer from only the faces or patches that are selected with the
Selected Only setting.

6. If the object you are transferring to is animated, select the Frame number that you want to
transfer to.
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7. As with the patches from the Source, select the patch options from the dropdown menu under
Destination to specify where the designated patches are being transferred to.

8. If you also have hidden parts of an object, or selected faces or patches, on your Destination
channels, specify whether the Visibility and Selection options are set to Ignore these settings.

9. Select a search direction from the Sampling > Search dropdown menu:

• Bidirectional - both forwards and backwards ray casting.

• Forward - forward ray casting only.

• Backward - backward ray casting only.

• Radial - in a sphere outwards from one point.

By default, the search direction is set to Radial.

10. Select one of the following interpolation methods from the Sampling > Interpolation dropdown
menu:

• Nearest-Neighbor - selects the nearest pixel for sampling.

• Inverse Distance Weighted - weights the average on the closest pixels.

• Inverse Distance Weighted (Smoother) - weights the average on the closest pixels with a
priority to providing smoother sampling.

• Inverse Distance Weighted (Sharper) - weights the average on the closest pixels with a priority
to providing sharper sampling.

Interpolation is similar to Photoshop's sampling functionality and specifies how the source image
data is sampled in 3D space.

11. Set the Samples amount to specify the number of points to find when searching and that are
combined to produce the final color.

12. If the Object Has Moved, from the source to the destination, specify Yes. This can mean a
difference in the topology, the object being in a different location on the canvas, and navigation,
exclusive of rotation.

13. If you want to flatten the layers in the selected channels prior to channel transfer, select Yes from
the Flatten dropdown menu. Otherwise, leave it as No.

14. Choose whether or not to Bleed Edges for patches when performing the transfer.

15. Set the Range for the search distance when performing the transfer. Range can be limited by:

• Infinite - there is no limit; Mari attempts to find a pixel in the source image data.

• Object Size Percentage - the maximum search distance is expressed as a percentage of the
destination object's size. For example, if the destination object is 10 world-space units and you
set the range value to 10, then the maximum distance becomes 1 world-space unit.

• World Units - the maximum search distance expressed directly in world space. For example, if
you set the range value to 2, then the maximum distance becomes 2 world space units.
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16. The Fill Color field sets the fill color for new patches on the object. If an object has extra patches
that aren't covered by the texture transfer, then the fill color specifies whether these extra patches
are filled with Transparent, Black, White, Mid-gray, Magenta, Foreground, or Background.

17. Once you have set all the advanced options, press Ok to start the transfer or Cancel to abandon
the transfer and close the dialog.
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Shaders
Shaders control how Mari displays the model under certain, user-specified lighting conditions. Mari
uses shaders to specify how different channels behave in the lighting module and how the paint on
the model reacts to light. Mari always uses a shader to generate the surface displayed on screen.

The shaders are also highly dependent on the channels and layers in a project, and you can view
current paint layers, targets, and channels specifically in the Shaders palette.

For more information on how shaders, channels, and layers integrate with one another, please refer
to the Layers chapter in this guide.

Getting Started with Shaders
There is no default shader for new projects but adding a new shader is quick and simple, and the
default channel can be plugged into the shader immediately to set up your project. Once you create
channels and assign them to the fields in the shader components, you can build up complex textures
on your model.

Color channel, plus... displacement
channel, plus...

specular channel,
equals...

299
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...this. Here the shader is pulling in all three channels to make a surface that gives a preview of what
the final render may look like.

This lets you, for example, build a shader so you can paint onto the displacement or specular
channels while getting a real-time view of how your changes affect the final render.

TIP: Shaders only control how Mari displays the model's surface. They do not affect the
contents of the channels in your project.

Shaders include:

• basic lighting details, including ambient, diffuse, and specular light intensities.

• a method for quickly viewing paint in your current channel, layer, layer stack, or on your current
paint target.

Mari generates the shaded surface by going through the components in the current shader. Each
component takes an input from a channel and is adjusted according to relevant component sliders.
These components are then added to the current surface. The final shaded surface as you see it on
screen is the final result of these components.

For example, you could set up a shader by following the steps below:

1. Create the initial shaded surface from the diffuse channel and set this in your shader’s Diffuse
Color
component.

2. Display specular or displacement previews using designated channels as the inputs, and adjust
the sliders to give the shaded surface the desired look.
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3. Adjust ambient light or apply environment images to further build up the preview of your final
rendered image.

As with channels, you set up shaders individually for Working with Objects.

Shaders and Lights

In Mari, shaders and lights are related - they both control how your project appears on screen, but
neither affects the actual data in the channels.

• Shaders do include some basic lighting information, but mostly they specify what to show on the
surface of the model. For example, shaders may include specular information, which describes how
the surface interacts with the lights in your project.

• Lights provide control on how your project is lit on the canvas. You can set up four individual lights,
each with its own color, intensity, and direction, by adjusting the settings in the Lights palette. You
can also set an environment light that relies on an image for the lighting.

Diffuse and Specular Settings

Shaders are comprised of two categories: Diffuse and Specular. With the exception of Flat and
Standard
Lighting, all shaders consist of components from both these categories. When creating a custom
shader, the Diffuse options are:

• Lambertian, and

• Minnaert.

When creating a custom shader, the Specular options are:

• Phong,

• Cook Torrance,

• Beckman, and

• Blinn.

These options determine the type of diffuse and specular lighting used for the shader, as well as
which set of shader inputs are available to you.

NOTE: By default, the Phong, Cook Torrance, Beckman, and Blinn shaders, listed in the
Add New Shader dropdown menu, use the Lambertian diffuse option. To add a shader with
the Minnaert diffuse option, select Choose Diffuse and Specular from the dropdown menu.

Once you have set up the shader, you can still opt to change the lighting on the model by changing
the lights in the Lighting toolbar, in the Lights palette, or in the Shading menu.
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Shading and Channels

Using too many custom shaders can make it hard to remember which channels are being used in
which shader inputs. Mari has a few default shaders that show the contents of the current channel,
layer, or paint target, you can always switch back to these to check your work in isolation.

TIP: A useful way to keep track of which shader you're editing is to add it to the Heads-Up
Display. From the Edit menu, select HUD Manager. Under Project, put a check in the box
next to Current Shader. Mari now shows the name of the shader you are currently painting
as part of the background information on the canvas. For more information, see the
Configuring the User Interface chapter.

Shaders on Multiple Channels

If you want to copy a shader you’ve created for one object in your project to use on another object,
you can use the keyboard shortcuts or the options in the context menu to cut, copy, and paste
shaders between objects. Shaders are exclusive to each object, as are channels and layers. The only
way to duplicate a shader for use on another object, is to cut or copy and paste it into the Shaders
palette for each object in your project.

Physically Plausible Shaders

Physically plausible shaders differ from traditional shaders, such as the default Mari shaders, by
obeying the law of conservation of energy. Unlike traditional shaders, changing different inputs, such
as Specular or Specular Roughness, does not effect the overall brightness of the point or
environment lights. The distribution of the light might have changed to be concentrated in one
location or spread out across the shaded surface, but the sum total of the pixel values should come
out to the same value.

Ambient Occlusion
Ambient occlusion can be set as a shader component input for all of the custom-created shaders.
Using a component input for the ambient occlusion allows you to create your own occlusion map in a
separate channel and plugging this channel into the shader input.
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If you don’t want to create a channel specifically for ambient occlusion, you can opt to calculate the
ambient occlusion for each individual object in your project. For more information, please refer to
About Masking and Calculating Ambient Occlusion.

Shader Limits
Most shaders do not require texture slots, but if you exceed the amount of texture slots available you
may encounter a rendering error. If this occurs, there are a number of causes that may have
contributed to the error. To free up texture slots, try:

• turning off features that require extra texture units, such as painting masks in the Projection
palette,

• turning off any filter previews that may be active,

• flattening or caching layers in long or complex layer stacks,

• changing the inputs on the current shader to use fewer texture slots.

NOTE: Even if there are remaining texture slots available, active features such as depth
projection, paint masks, and shadows may not respect the texture slot limit if more
expensive shaders components are in use. You can turn off these features to free up more
texture slots. See About Masking and Shadow Settings for more information.

Open the Shaders Palette
1. Start Mari and open your project.

2. Open the Shaders palette:

• right-click on the toolbar, and select Shaders from the dropdown menu, or

• from the View menu, select Palettes > Shaders.

The Shaders palette displays, showing the default shaders and any shaders you’ve already set up
for your current project.
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3. The default shaders in the list are:

• Current Channel,

• Current Layer and Below,

• Current Layer, and

• Current Paint Target.

When you select a shader, the bottom of the palette shows the details, as shown in the example
image below.

4. The shader components that are shown in the bottom pane of the palette differ depending on
what shader is selected.
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Default Shaders
In any project, Mari has four default shaders that you start with before adding any custom shaders.
These default shaders are:

• Current Channel - displays the paint in your selected channel.

• Current Layer and Below - displays the paint in your selected sub-stack (such as a mask or
adjustment stack) up to the selected layer. If you don’t have a sub-stack selected, it shows the parent
stack up to the selected layer.

• Current Layer - displays the paintable paint and masks in your selected layer.

• Current Paint Target - displays the paint in your selected layer, including any mask or mask stack,
adjustment, filter or groups associated with the layer.

These shaders are also found on the Default Shaders toolbar and allow you to switch between each
shader with a single click. If you want to see how your paint looks for a single layer, then compare it
when added to the rest of the layer stack, switching between the Current Layer and Current Layer
and Below views can assist you.

Create a Custom Shader
1. To add a new shader, either:

• right-click on an empty space in the Shaders palette,

• select Add New Shader from the Shading menu, or

• click the icon in the Shaders palette.

2. Select from the shaders listed in the dropdown menu, or select Choose Diffuse and Specular to
manually set the diffuse and specular options for your shader.

The new shader appears in the list.

TIP: You can also duplicate an existing shader by selecting Duplicate Shader from the
Shading menu or the right-click menu in the Shaders palette. The default shaders cannot be
duplicated.

3. To duplicate or copy a shader, either:

• right-click on the shader and select Duplicate Shader from the dropdown menu,

• select Duplicate Shader from the Shading menu,

• click the icon in the Shaders palette, or

• select the shader and use the Ctrl/Cmd+C shortcut to copy and Ctrl/Cmd+V shortcut to paste.
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A copy of the shader appears with the same name as the original but also a number to
differentiate between the original and the copy.

4. You can give the shader a new name by double-clicking it in the list and typing the new name.

TIP: You can set a keyboard shortcut for the shader by right-clicking it and selecting Assign
Shortcut from the dropdown menu. See the chapter on Using Shortcuts on page 28 for
details.

TIP: You can right-click any of the shaders, or within the shader dialog, to access the
dropdown menu for more shader options. Right-clicking an existing shader also selects it.

Create a Layered Shader
Layered shaders create a layer stack that allows multiple shaders to be blended together. When the
layered shader is selected, the layer stack appears as a separate tab on the Shaders palette. This
allows you to create different shaders within a layer stack that you can mask, adjust, and have
independent control over.

For example, you can create a layered shader in order to create a shader for a wood material and
another shader for a metal material on the same object. Each of these shaders can then be modified
to create a specific look that may not be possible to achieve with an overall shader.

1. To add a layered shader, either:

• right-click in the Shaders palette > Add New Shader > Layered

• select Add New Shader > Layered from the Shading menu, or

• click the icon in the Shaders palette and select Layered from the dropdown menu.

The Masks Format dialog appears.

2. Select a Size and Depth for the channel created for the layered shader's layer stack. The options
for the channel size and depth are the same as those found in the section to Create and Delete
Individual Channels on page 280 in the Channels chapter.

The layered shader is created in the Shaders palette, and a Shader Layers tab is visible on the
left side of the palette, when the layered shader is selected.

3. Click on the layered shader to select it and adjust the Inputs and attribute fields in the lower pane
of the Shaders palette. For a full list of the inputs and controls for each shader, including the
Layered shader, refer to the Shaders Palette chapter in the Mari Reference Guide.

4. Once you have made the adjustments you want to make, click on the Shader Layers tab to see
the shader's layer stack in the Shaders palette. This tab looks similar to the Layers palette or a
mask stack palette.
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NOTE: In the event that there are multiple layered shaders in the Shaders palette, there is
still only one Shader Layers tab. Selecting a layered shader ensures it is that layer stack that
is shown in the Shader Layers tab. To see the layer stack of another layered shader, simply
select it before clicking on the tab.

5. Add shaders to the layer stack by clicking the icon and choosing the appropriate shader from
the dropdown menu. As with shaders in the primary tab of the Shaders palette, the shader is
added to the palette and you can adjust the Inputs and Displacement fields for each individual
shader layer in the lower pane of the palette.

6. Similar to the Layers palette, you can add masks and mask stacks to the shaders, so that certain
shaders in the stack only apply to certain areas on your model. For more information about how
to mask layers, refer to Layer Properties on page 226

7. To make it easier to find shaders in a large layer stack, you can assign color tags to individual

shaders. Select a shader from the stack and click the icon to assign a color.

8. If you want to remove a shader from the layer stack, select the shader and click the icon.

The shader is removed from the layer stack.

9. If you right-click on a shader layer, you can do most of the things you can also do with layers in
the Layers palette, for instance, adding adjustments and groups.

TIP: For more information about layer stacks, mask stacks, and similar functionality on the
Layers palette, refer to the Layers chapter for more information.

Set Shader Details
For all of the custom shaders (those not mentioned in the Default Shaders list), the lower pane in the
Shaders palette consists of inputs and sliders for the selected shader. The inputs you have available
depend entirely on which of the shaders you have selected. The input fields allow you to specify which
channel corresponds to which shader component. For example, if you're using the Current Channel
shader, you don't need to specify a channel, because you are viewing only the selected channel on the
model. However, if you have a Phong shader selected, you are viewing whatever channels you have
chosen for each component, such as Diffuse Color or Bump.

Once you've assigned a channel to the shader input, you can adjust the affect of that channel by
adjusting the corresponding slider under the inputs. Following on from the example above, if you
have assigned a channel to the Bump input of the Phong shader, you can then adjust the Bump
Weight slider to control how heavily the bump affects the texture.

1. Select the shader you want to customize from the Inputs list at the top of the Shaders palette.
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The bottom of the palette displays that shader's details.

2. You can build up your shader by assigning channels to the various shader component inputs in
the bottom pane of the palette.

To assign a channel to an input, click on the dropdown menu and select a channel from the list.

3. If you haven’t created a channel for a designated input yet, you can create channels from the
Shaders palette.

To create a new channel, click the icon next to the input for which you want to use the
channel.

The Add Channel dialog box displays.

SHADERS | SET SHADER DETAILS



USER GUIDE 309

4. Enter a Name for the channel (recent names are available in the dropdown list). Select the size,
depth, colorspace, and file space settings for your channel and click OK.

Mari adds the channel to your shader and automatically makes it the active channel for the
designated input.

TIP: To learn more about each of the settings in the Add Channel dialog, refer to the Add
Channel Dialog Box chapter in the Mari Reference Guide.

5. Once you’ve set up the inputs of each of the shader components you want to use, you can fine-
tune these settings using the sliders in the bottom pane of the palette.

If you prefer, you can fine-tune the slider settings using the entry box instead.

EXPERIMENT: Since the shaders don't affect the content of the channels, you can safely play
around without worrying about overwriting anything. Try building the example below.
Download the tutorial assets from The Foundry website, if you haven't already. Try:

• Creating a new shader.

• Setting the Diffuse Color shader component to the Base Skin (Diffuse) channel and
adjusting the Diffuse and Specular sliders.
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• Creating another, different shader and set the Diffuse Color shader component to Base
Skin (Diffuse) again.

• How does changing the Diffuse and Specular sliders affect the model on this shader type.

Remove a Shader
1. To remove a shader:

• right-click on the shader and select Remove Shader from the dropdown menu,

• select Remove Shader from the Shading menu, or

• click the icon in the Shaders palette.

The shader is removed from the Shaders palette.

NOTE: The default shaders cannot be removed from the Shaders palette.

2. You can temporarily see your model as it appears in other shaders by simply selecting one of the
default shaders or custom-created shaders. Selecting the shader displays the model as it appears
with that shader’s specific
settings.

3. In all the custom shaders, controls for Ambient light do not correspond to a particular channel
input, but to the entire model. Ambient Occlusion can also be selected from a channel, or
created based on ambient occlusion calculation.

NOTE: For more information on these shader controls, refer to the Shaders Palette chapter
in the Mari Reference Guide.

Shader Types and Examples
Below are descriptions and examples of the different shaders available in the Shaders palette.

Examples of each of the shaders are applied to the following image, for illustrative purposes:

SHADERS | REMOVE A SHADER



USER GUIDE 311

NOTE: The project the illustrative image is taken from has three channels: diffuse, specular,
and bump. For certain shaders, such as Flat, not all of these channels are hooked up to the
input fields. Other shaders, such as the BRDF shader, have many other inputs that affect the
shader output, but these may not be demonstrated from the three channels that are hooked
into the shader.

EXPERIMENT: The illustrative image displays the Example Project model that's shipped with
Mari. Try adding channels or layers to the Example Project in order to experiment with all
the inputs and controls of the shaders in the table below.

Don't forget to adjust the sliders in the shader controls in order to modify the effect of the
shader on the channel that you are trying out.

WARNING: The example images for each shader are highly dependent on how the controls
have been adjusted for each shader. For the purposes of this table, most of the shaders are
shown with default or near default settings unless otherwise specified.

Shader Description Settings Example
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Shader Description Settings Example

Current Channel A default shader that
displays only the output
of the selected channel.

In the example shader,
the diffuse channel is the
currently selected
channel.

Adjust the sliders for
the:

• Diffuse,

• Specular, and

• Specular Roughness
amounts.

Current Layer and
Below

A default shader that
displays only the output
of your selected sub-
stack (such as a mask or
adjustment stack) up to
the selected layer.

If you don’t have a sub-
stack selected, it shows
the parent stack up to
the selected layer.

Adjust the sliders for
the:

• Diffuse,

• Specular, and

• Specular Roughness
amounts.

Current Layer A default shader that
displays only the output
of the current layer with
the mask of the layer
applied.

Adjust the sliders for
the:

• Diffuse,

• Specular, and

• Specular Roughness
amounts.

Specify whether the
View is set to Primary
or Secondary in the
dropdown menu.
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Shader Description Settings Example

Current Paint Target A default shader that
displays only the
selected component of
the selected layer, for
instance the paint,
procedural, adjustment,
or mask; whichever is
selected on the selected
layer.

In the example shader, a
procedural layer in a
"dirt" mask stack is the
current selected paint
target.

Adjust the sliders for
the:

• Diffuse,

• Specular, and

• Specular Roughness
amounts.

Lambertian

Lambertian shaders represent perfectly diffuse (matte) surfaces without any lighting falloff.
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Shader Description Settings Example

Phong A simple, smooth
specular shader based
on the Phong shading
model.

Set the channel used
for the following
inputs:

• Diffuse Color

• Specular Color

• Specular Shininess

• Normal

• Bump

• Environment Color

• Ambient Occlusion

• Emissive Color

• Vector

• Displacement

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

Cook Torrance A shader that is based
on the Cook-Torrance
shading model, which
simulates specular-
microfacet shading.

Set the channel used
for the following
inputs:

• Diffuse Color

• Specular Color

• Specular Roughness

• Specular IOR

• Environment Color

• Ambient Occlusion

• Emissive Color

• Bump

• Normal

• Vector

• Displacement

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

Beckman A shader where specular
distribution is based on
the Beckman shading
model.

Set the channel used
for the following
inputs:

• Diffuse Color

• Specular Color

• Specular Roughness

• Normal

• Bump

• Environment Color

• Ambient Occlusion

• Emissive Color

• Vector

• Displacement

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

Blinn A simple, smooth
specular shader that is
based on the Blinn-
Phong shading model.

Set the channel used
for the following
inputs:

• Diffuse Color

• Specular Color

• Specular Shininess

• Normal

• Bump

• Environment Color

• Ambient Occlusion

• Emissive Color

• Vector

• Displacement

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.

Flat A shader with the
absence of any shading
model, which only
displays the raw
texture/color values
without the application
of lighting.

Set the channel used
for the following
inputs:

• Color

• Vector

• Displacement

The amount of
displacement can be
adjusted with the
Displacement sliders.
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Shader Description Settings Example

Unreal A physically-based
material shader for
assigning textures and
materials that match
what would be seen in
the Unreal Engine 4.

Set the channel used
for the following
inputs:

• Base Color

• Roughness

• Metallic

• Specular

• Ambient Occlusion

• Normal

• Bump

• Vector

• Displacement

BRDF A physically-based
shading model that
includes Fresnel effects.
The BRDF shader
defines how light is
reflected at an opaque
surface from both direct
and indirect light
sources.

Set the channel used
for the following
inputs:

• Diffuse Color

• Specular Color

• Glossiness

• Reflectance

• Ambient Occlusion

• Emissive Color

• Normal

• Bump

• Vector

• Displacement

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

Standard Lighting A Beckman shader with
a simple, standard
lighting model applied.
This shader represents
the basic shaders used
in 1.x versions of Mari.

Set the channel used
for the following
inputs:

• Diffuse Color

• Vector

• Displacement

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

AiStandard A shader that emulates
the Arnold Standard
shader, a multipurpose
shader that can produce
all types of materials.

Set the channel used
for the following
inputs:

• Diffuse Color

• Diffuse Roughness

• Specular Color

• Specular Roughness

• Anisotropy

• Rotation

• Reflection Color

• Refraction Color

• Refraction
Roughness

• Transmittance

• Opacity

• Sub-Surface
Scattering Color

• Sub-Surface
Scattering Radius

• Emission Color

• Bump Map

• Normal Map

• Displacement Map

• Vector Map

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

RedshiftArchitectural A shader that emulates
the Redshift architectural
material "uber shader"
that covers most
commonly-used material
features.

Set the channel used
for the following
inputs:

• Diffuse Color

• Diffuse Roughness

• Translucency Color

• Reflection Color
(Primary)

• Reflection
Glossiness (Primary)

• Reflection Color
(Secondary)

• Reflection
Glossiness
(Secondary)

• Anisotropy

• Anisotropy Rotation

• Refraction Color

• Refraction
Glossiness

• End Color (Fog)

• Cutout Opacity

• Incandescent Color

• Bump Map

• Normal Map

• Displacement Map

• Vector Map

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

VRayMtl A shader that emulates
the VRayMtl material
shader, which allows
physically-correct
illumination and
convenient reflection
and refraction
parameters.

Set the channel used
for the following
inputs:

• Diffuse Color

• Opacity Map

• Diffuse Roughness

• Self-Illumination

• Reflection Color

• Highlight Glossiness

• Reflection
Glossiness

• Anisotropy

• Anisotropy UV
Coords

• Rotation

• Refraction Color

• Refraction
Glossiness

• Fog Color

• Translucency Color

• Bump Map

• Normal Map

• Displacement Map

The amount of each of
these inputs can be
adjusted in the
respectively named
sliders.
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Shader Description Settings Example

Layered Creates a flat shader
with a special channel
that allows other
shaders to be added as
layers. Shader layers can
be masked, grouped,
and largely treated as
layers in the Layers
palette. The Layered
shader lets you apply
different shading models
to create different
material effects.

Set the channel used
for the following
inputs:

• Vector

• Displacement

The amount of
displacement can be
adjusted with the
Displacement sliders.

Minnaert

Minnaert is the diffuse calculation model that provides the extra control diffuse falloff. The Phong,
Cook Torrance, Beckman, and Blinn specular models can all be created with a Minnaert diffuse
lighting model, instead of a Lambertian diffuse lighting model, as shown above.
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Node Graph
The Node Graph is essentially another way of viewing and managing layers, channels, and shaders.
You can set up a Node Graph for ordering different sets of paint and combine effects in a non-
destructive manner, just like layers, but the Node Graph allows you to micro-manage the various
components as individual nodes.

Getting Started with the Node Graph
Mari's Node Graph has two modes, Basic and Advanced, exposing different levels of detail within the
palette. Basic mode, the default mode, only allows you to work with Graph Layers from the Layers
palette. Advanced mode exposes the channels, layers, and so on, in the Node Graph palette.

NOTE: You can enable the Advanced Node Graph in the Mari Preferences dialog under
Node Graph > General > Advanced View.

The Node Graph and Node Properties palettes are not displayed in the default layout, so to view the
Node Graph, navigate to View > Palettes > Node Graph.

A simple Graph Layer in Basic mode. A simple node tree in Advanced mode.

The Node Graph contains nodes and each node has properties specific to the node's purpose located
in the Node Properties palette. The Node Properties palette is also located in View > Palettes, but
the fastest way to open a node's properties is to double-click it in the Node Graph.

For example, the Oil node has controls for Size and Color to determine the look of the oil effect. See
the Mari Reference Guide under Layers Palette, Layers Palette Fields for more information.
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If you prefer working with layers, you can build a layer stack as normal, using channels and shaders,
and Mari automatically replicates it in the Node Graph. See Layers for more information.

TIP: To avoid confusion we recommend working in one system or the other, at least until
you're familiar with both. If you want to use the power of both layers and nodes, we
recommend working in the layer system and using Graph Layers in Basic mode.

For example, you can create node tree functions that cannot be replicated in the Layers
palette. If this happens, the layer within the Layers palette is shaded dark gray.

Objects, Channels, Layers, and Shaders Within the Node Graph

At first glance, the Node Graph that Mari creates automatically from layers can seem a little chaotic,
but each element corresponds to a familiar concept. For example, importing a simple .obj creates the
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following Node Graph.

Each Node Graph represents a single object and, just like in the layer system, each channel contains
layers, including a Bottom Transparency layer. In the example, a Base layer is also included. If you
add more layers to the channel, they appear under the first layer.

TIP: One thing to note about the Node Graph is that it works in the opposite direction to the
Layers palette - top down rather than bottom up.

If a project contains multiple objects, the Node Graph Root name changes to represent the currently
selected object. For example, selecting an object called cubic, changes the Node Graph label to cubic
- Root.

You can use the Viewer node to examine your node tree at any point to help you get to grips with how
the Node Graph represents the Layers palette. Select the node you want to view and press 1 on the
keyboard to connect the Viewer node.
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In the example, attaching the Viewer to the Bottom Transparency, Base (including paint in the Paint
node), and Cloud nodes in succession produces the following results:

Bottom Transparency Base Layer, with Paint Cloud Procedural

Working with Nodes
Nodes are the basic building blocks used to represent layers, channels, and shaders in Mari. Nodes
can exist individually, within Backdrop nodes, or as part of a Group (including Graph Layers) in the
Node Graph.
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Adding, Deleting, and Bypassing Nodes

You can add nodes using the Tab menu or the right-click menu. When you add a node, Mari
automatically connects it to the currently-selected node.

Adding Using the TabMenu
1. Select the existing node that you want the new node to follow by clicking on it.

TIP: If you don't select an existing node, the new node is added at the cursor location.

2. Press the Tab key and start typing the name of the node you want to create.

This opens a prompt displaying a list of matches.

3. To select the node you want to add from the list, you can either click on it, or scroll to it with the
Up and Down arrow keys and press Return.

TIP: If you decide not to add a node, press Esc to close the node selector.

Adding Using the Right-Click Menu
1. Right-click on an existing node that you want the new node to follow.

2. From the menu that opens, select the node you want to add. For example, Filter > Clamp.

TIP: If you don't select an existing node, the new node is added at the node selector's
location.

Deleting Nodes

To delete a node from the Node Graph, either:

• Select the node and press Delete (Fn+Backspace on Mac keyboards with no dedicated Delete key),
or

• Select the node, right-click in the Node Graph and select Edit > Delete.

Bypassing and Disabling Nodes

Mari allows you to bypass a single node, or its inputs, and disable a selection of nodes to alter the
image output as if the node(s) were removed from the node tree. Bypassing and Disabling are similar,
but work slightly differently.
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To Bypass a single node:

1. Select the target node in the Node Graph.

2. Press Ctrl/Cmd+D on the keyboard or right-click in the Node Graph and then select Bypass.

All inputs but one are disabled in order as you repeat the bypass action, negating their effect on
the node tree without removing them.

For example, cycling through the bypass modes for a Merge node with three inputs results in:

• First bypass - all inputs except Base are disabled.

• Second bypass - all inputs except Over are disabled.

• Third bypass - all inputs except Mask are disabled.

• Fourth bypass - all inputs are disabled, effectively terminating the upstream node tree.

• Fifth bypass - all inputs are re-enabled.

To Disable a node or a selection of nodes:

1. Select the target node or nodes in the Node Graph.

2. Press D on the keyboard or right-click in the Node Graph and then select Disable.

The selected nodes are disabled, negating all but their preferred input's effect on the node tree.
For example, disabling a shader node only passes the diffuse input down the node tree.

NOTE: You can set the preferred input for a node by editing the node's .xml file. For
example, to set Base as the preferred input: <Input Name="Base"
PreferredInput='1'></Input>
Node .xml resides in the following locations, by platform:
• Windows: <install_directory>\Bundle\Media\Nodes\
• Mac OS X: <install_directory>/Content/Media/Nodes/
• Linux: <install_directory>/Media/Nodes/

3. Press D or select Disable again to re-enable the selection.

Selecting Nodes

Mari offers a number of options for selecting nodes. Selected nodes are highlighted in yellow.

Type of Selection How to Make the Selection

Select a single
node

To select a single node, simply click on it.
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Type of Selection How to Make the Selection

Select multiple
nodes

To select multiple nodes, you can either press Ctrl/Cmd while clicking on each
node you want to select, or click and drag in the workspace to draw a marquee
around the nodes you want to select.

Select all nodes Press Ctrl/Cmd+A.

Renaming Nodes

If you need to rename a node, you can:

1. Double-click on the node to open its properties panel.

In the Name field on top of the Node Properties panel, you should see the current name of the
node.

2. Delete that name and enter a new name in its place.

Editing Nodes

To copy, paste, and perform other editing functions in the Node Graph, you can use the standard
editing keys (for example, Ctrl/Cmd+C to copy, and Ctrl/Cmd+V to paste). Copied nodes inherit the
values of their parent, but these values are not actively linked. Copied nodes allow you to assign
different values to the original and the copy.

When you paste nodes, Mari automatically connects them to the node that is selected before the
paste operation. If you don’t want to connect to anything, click on a blank area of the workspace to
deselect any selected nodes before pasting.

Type of Edit How to Preform It

Copy nodes to the
clipboard

To copy nodes to the clipboard:

1. Select the node or nodes you want to copy.

2. Right-click in the Node Graph and select Edit > Copy (or press Ctrl/Cmd+C).
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Type of Edit How to Preform It

Paste nodes from
the clipboard

To paste nodes from the clipboard:

1. Select the node that you want the pasted node(s) to follow.

2. Right-click in the Node Graph and select Edit > Paste (or press
Ctrl/Cmd+V).

Mari adds the nodes to the Node Graph, connecting them to the selected
node.

Exporting and Importing Paint and Nodes

Mari allows you to export and import Paint image data or a selection of nodes for use in other
projects or layers. Paint is saved as named files or sequences and node selections are saved as .mng
files.

Action How to Preform It

Export To export Paint data:

1. Select the Paint node you want to export.

2. Right-click in the Node Graph and select File > Export.

3. See Export Texture from Layers for more information.

Import To import Paint data:

1. Right-click in the Node Graph and select File > Import.

2. See Import Existing Textures to Layers for more information.

Export nodes to
file

To export nodes to file:

1. Select the node or nodes you want to export.

2. Right-click in the Node Graph and select File > Export Nodes.

3. Navigate to the directory where you want to store the node(s).

4. Type a name for the export at the end of the pathway, followed by the
.mng extension.
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Action How to Preform It

Import nodes
from file

To load nodes from file:

1. Select the node that you want the loaded node(s) to follow.

2. Right-click in the Node Graph and select File > Import Nodes.

3. Navigate to the directory that stores the .mng node file.

4. Select the file, and click Open.

Mari adds the node(s) described by the file to the selected node.

Customizing Node Colors and Behavior

You can customize node colors by type, such as all Filter nodes, or make changes to the appearance
of the Node Graph and default node size. In the case of certain nodes, such as Dot and Backdrop, you
can also customize the node's size when added to the Node Graph.

All default node parameters are stored in a file called NodeGraphStyleSheet.ini (on Windows and
Mac OS X) or NodeGraphStyleSheet.conf (on Linux) which resides in your .mari or .config file
depending on your operating system:

• Mac OS X: <home directory>/.config/TheFoundry/NodeGraphStyleSheet.ini

• Linux: <home directory>/.config/TheFoundry/NodeGraphStyleSheet.conf

• Windows: <home directory>\.mari\TheFoundry\NodeGraphStyleSheet.ini

Within this file there are several broad categories, which you can edit to customize the appearance of
the Node Graph and the nodes it contains.

Category Function Example

Scene Sets the Node Graph background color SceneBackgroundColor="
(50,50,50,255)"

NodeStateColors Sets the color used to denote various
node states and the general appearance
of nodes

NodeTextColor="(0,0,0,255)"

Category Colors Sets the color used to denote a particular
category of nodes

FilterNodeColor="(234,234,234,255),
(125,125,125,255)"
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Category Function Example

Edge Sets the appearance and behavior of
node edges when you connect pipes to
nodes

EdgeLabelColor="(234,111,0,255)"

NodeDimensions Sets the size of nodes that don't have
specialized controls of their own, such as
Dot and Backdrop

NodeHeight=20

AutoInsert Sets the size of the activation zone when
you drag a node over an existing pipe to
auto-insert between nodes

AutoInsertItemWidth=4

Backdrops Sets the size and appearance of Backdrop
nodes

MinimumBackdropNodeHeight=150

StickyNoteNode Sets the minimum height of StickyNote
nodes

MinimumStickyNoteNodeHeight=30

DotNode Sets the size of Dot nodes DotNodeSize=16

Connecting Nodes
When you add or paste nodes into the Node Graph, Mari automatically generates pipes between the
currently-selected node and the new nodes. As you build up a node tree, you’ll need to move these
pipes, or run new pipes between nodes. In Mari, you make such modifications by dragging either end
of the pipe to the new location.

Disconnecting and Reconnecting Nodes

You can disconnect nodes by dragging the head or tail of the connecting arrow to an empty area of
the Node Graph. You can reconnect a node by dragging the head or tail of the connecting arrow and
dropping it over the input or output of the node that you want to connect.

NOTE: If the target node has more than one input, you can drag the connecting arrow to the
node itself to display a list of all available inputs. You can then either click the required input
or use the Up and Down arrow keys to select the required input and press Return.
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Nodes in Mari have different inputs depending on their function. Some are simply labeled A and B, as
in the Add and Divide nodes. Some nodes, such as Ambient Occlusion and Color, require no inputs at
all. The following table lists some common inputs and example nodes that employ them:

Input Function Example Nodes

Input A standard input with no particular
requirements.

Brightness

Mask Passes masking information into the
associated node.

Merge

Normal Passes surface normals into the
associated node.

Beckman Specular, Displacement

Position Passes positional coordinates into the
associated node.

Cube Map Projector, Oil

ToView Connect this input to any point in the
node tree to view the output up to that
point.

Viewer

UV Passes UV coordinates into the
associated node.

Tiled Texture

Vector Passes vector information into the
associated node.

Set Vector
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Bending Connecting Arrows

Complex Node Graphs can become difficult to read with pipe overlaps, but Mari allows you to bend
pipes using a specialized node called Dot. The Dot node doesn't have any special controls like regular
nodes, but it can be used to direct pipes away from congested areas of the Node Graph.

To add a Dot node, select the node before the connector you want to bend and then, either:

• press Tab and type Dot to add a Dot node,

• right-click and select Nodes > Misc > Dot, or

• hold Ctrl/Cmd and click the yellow highlight on the required pipe.

A Dot is placed after the selected node, allowing you to bend the pipe as required by dragging the Dot
to a new position in the Node Graph.

Navigating Inside the Node Graph
As node trees grow in complexity, you need to be able to pan to or frame a particular cluster of nodes
quickly. The Node Graph offers a couple of methods for doing so.

Panning with the Mouse

To pan with the mouse, press the middle mouse button and drag the pointer over the Node Graph or
hold Alt and drag. The node tree moves with your pointer.
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Zooming and Fitting in the Node Graph

To zoom with the mouse, either:

• use the mouse scroll wheel, or

• hold Alt and middle-mouse drag left and right.

NOTE: In many Linux windows managers, the Alt key is used by default as a mouse modifier
key. This can cause problems in 3D applications where Alt is used for camera navigation in
3D environments.
You can use key mapping to assign the mouse modifier to another key, such as the
(Super or Meta) key, but the method changes depending on which flavor of Linux you're
using. Please refer to the documentation on key mapping for your particular Linux
distribution for more information.

To center the node tree, press A with the Node Graph in focus. To center certain selected nodes,
press F with the Node Graph in focus.

NOTE: Pressing F without selecting any nodes produces the same result as pressing A.

Cleaning up the Node Graph

Sometimes you may find that your node tree becomes disorganized as you’re creating and removing
nodes. There’s a quick fix you can use to tidy up your tree:

1. Right-click in the Node Graph.

2. Select Autoplace.

The nodes in the tree are re-organized for clarity.

TIP: If you make a selection of nodes before using Autoplace, only the selected nodes are
re-arranged.

Working with Node Properties
Node properties allow you to control how a node affects the node tree. To display a node's
properties, double-click it in the Node Graph. For example, double-clicking a Clamp node in the Node
Graph displays the following controls:
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For a full list of available nodes and controls, see Layer Types and Examples.

In addition to the controls unique to the various nodes, all nodes share certain universal controls
within the Node dropdown:

• Delete Cache - click to delete cached data for the current node or Group.

• Cache - click to cache the current node or Group data to the location specified in the Preferences
under Data > Cache > Project Location.

NOTE: If you modify the controls of a cached node or Group, the cache is deleted.

• Export as Gizmo - for Group nodes only, you can export the Group as a gizmo to share your work
with other artists. See Exporting Groups as Gizmos for more information.

Using Backdrops, StickyNotes, Groups, and Gizmos
You can organize and label nodes in the Node Graph using the Backdrop and StickyNotes nodes or
use the Group node. The Backdrop node adds a background box behind the nodes, separating the
nodes visually from the rest of the node tree. The StickyNote node allows you to add annotations to
the elements in the node tree.

A Group node combines a set of nodes into a single node, acting as a nesting container for them.
Group nodes can be published as gizmos, allowing you to share parts of your node tree that perform
specific functions with other artists.

NOTE: Groups and gizmos support the usual range of Mari metadata types as Name=Value
pairs.
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Adding Backdrops

Backdrop nodes allow you to organize parts of your node tree into named areas performing a
specific function.

To add a Backdrop, do the following:

1. Select the nodes you want to place within the Backdrop node.

2. To add a Backdrop, either:

• press Tab to display the node selector, type Backdrop, and press Return, or

• right-click in the Node Graph and select Node > Misc > Backdrop.

A Backdrop is added containing the selected nodes.

3. Double-click the Backdrop node's header to display its properties.

4. Enter the required Backdrop name in the TitleText field.

5. Click the Background Color and select a new color, if required.

6. Click the Label field to add a text description to the Backdrop's background.

Searching for Nodes

You can quickly search for nodes in complex node trees using Mari's Jump to Node feature.

1. With the Node Graph palette in focus, either:

• press J on the keyboard, or

• right-click and select File > Search Node.

2. Start typing the name of the node you want to locate, or click the dropdown to display a list of
available nodes.
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3. Select the required node and press Return to jump to the node's location in the node tree.

TIP: If you decide not to jump to a node, press Esc to close the node selector.

Adding StickyNotes

StickyNote nodes allow you to add annotations to elements in the node tree. For example, you might
add text describing the function of a certain part of the node tree.

To add a StickyNote:

1. Press Tab to display the node selector, type StickyNote, and press Return, or right-click in the
Node Graph and select Nodes > Misc > StickyNote.

2. Double-click the node to open its properties.

3. Enter the note text in the Label field.

The text is added to the StickyNote in the Node Graph.

Creating Groups

Group nodes allow you to condense parts of your node tree into groups performing a specific
function. Mari creates groups automatically in some cases, such as when you add a new Graph Layer
from the Layers palette, but you can create groups manually from a selection of nodes.

To create a Group:

1. Select the nodes you want to place within the Group node.

2. To create the Group node, do one of the following:

• press Ctrl/Cmd+G, the Group keyboard shortcut,

• press Tab to display the node selector, type Group, and press Return,

• right-click in the Node Graph and select Node > Misc > Group.

A Group node with the required number of Input pipes and on Output pipe is added. For
example, if the Group contains a Displacement node, a Group with at least four inputs is created.

NOTE: Groups only support one Output node. If you attempt to add more Output nodes
within a Group, Mari displays a warning message.

TIP: If you didn't make any node selections, an empty Group is created.

3. Double-click the Group node to display its contents and properties.

4. Click the Name field to give the Group a meaningful name.
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Customizing Group Properties

Group nodes don't display any properties by default, other than those shared by all nodes. See
Working with Node Properties for more information.

To expose controls from nodes within the Group:

1. Double-click the Group node's header to display its properties, if they're not already open.

2. Click the p button at the top-right of the Node Properties panel.

The Group Node Knobs dialog displays.

3. Click Pick to begin exposing controls in the Pick Knobs to Add panel.

4. Select the required control from the list available. You can only select controls that are associated
with nodes contained within the Group.

5. Click OK to expose the control(s) in the Node Properties panel.

You can expose as many controls as you like in a Group's properties by repeating this process.

NODE GRAPH | USING BACKDROPS, STICKYNOTES, GROUPS, AND GIZMOS



USER GUIDE 341

6. The controls editor has some additional functions to help you organize how controls appear in
the Node Properties panel.

• Edit - click to give the selected control a custom name, though the control itself retains its
original function.

• Delete - click to remove the control from the Group's properties.

• Up/Down - click the Up and Down button to re-arrange the order in which controls appear in
the Group's properties.

Exporting Groups as Gizmos

You can export a Group as a gizmo so that other artists can use parts of your node tree to perform
similar tasks. Gizmos are exported using the .mng file extension and can be imported into any
project in Mari 3.0, or above.

To export a gizmo:

1. Double-click the Group node you want to export to open its properties.

2. Click the Node dropdown to expand the view.

3. Click Export as Gizmo.

The Export as Gizmo dialog displays.

4. Navigate to the required directory, enter a File name, and then click Save.

5. Mari saves your gizmo (.mng) to the specified location.

Importing Gizmos

Although you can save gizmos anywhere from Mari, you can only load them back in from a certain
location on disk reserved for this purpose.

To import a gizmo, do the following:
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1. Copy the gizmo to the following location, depending on the platform in use:

• Windows: C:\Users\<username>\Documents\Mari\Gizmos\

• Linux and Mac OS X: /home/<username>/Mari/Gizmos/

TIP: You may need to create the Gizmos directory manually.

2. Restart Mari to make the gizmo available.

3. Right-click inside the Node Graph and select Nodes > <gizmo_name>.

Mari inserts the gizmo into the Node Graph.
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Ptex
Ptex (Per-face Texturing) is a texture mapping system developed by Walt Disney Animation Studios as
an alternative to traditional methods of texture mapping. Ptex addresses various issues associated
with traditional texture mapping by eliminating the need for artists to manually create UV maps.

With Ptex, each face of a geometry has its own unique texture. This allows for the possibility of
dynamically changing the resolution of textures on individual groups of faces.

Ptex files contain the per-face texture and face/edge adjacency data along with the geometry
metadata, which can be useful for previewing textures and checking whether they are valid for a given
geometry.

Ptex Support
UV patches are 2D textures mapped onto regions of 3D geometry according to UV maps created by
the artist. In addition to working with traditional UV maps, Mari also supports Ptex. With Ptex, UV
patches are no longer a valid concept since there are no explicit UVs associated with the model. As a
result, UV patches have been replaced with a UV atlas of Ptex faces.

When a new Mari project loads a UV-less .obj file, or a .ptx (Ptex) file containing geometry, every face
of the geometry has a texture assigned to it, and in turn, every texture is assigned to an unused
region of a UV atlas.

The packing of these face textures occurs in order of descending size, and because of this, adjacent
faces with differing texture resolutions may not be spatially coherent in the UV atlas. Therefore,
painting in the UV view does not make logical sense.

Currently, Ptex support in Mari includes:

• starting a new project with either a UV-less .obj, or a .ptx file (containing geometry metadata)

• optionally assigning each surface defined in the .obj file its own Ptex layout

• polygons of arbitrary size and shape in .obj files

• specifying uniform, or worldspace texel density texture resolutions of faces

• painting onto Ptex geometry in 3D views

• resizing selected Ptex face textures from 1x1 (2x2 for triangles) all the way up to 8192x8192

• creating new channels that share Ptex face texture resolutions
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• exporting a channel to a .ptx file, with the option to include geometry metadata and face/edge
adjacency
information

• importing .ptx files into channels that are topologically equivalent

• preserving paint in multiple Ptex geometries, when creating new geometry versions from .obj files,
provided they are topologically equivalent

• Python bindings for Ptex project creation, per face operations, and import/export functionality.
Refer to the Python HTML documentation within Python > API for further information

• allowing face texture resizing and data format conversion on import.

Limitations of Mari’s GPU Previews with Ptex

Mari’s implementation of Ptex face texture storage is targeted at the flexibility of face resizing and the
rendering preview performance of the GPU. Unlike UV maps, the locality of faces in 3D space is not
necessarily maintained in the Ptex texture storage. As a result of this implementation, when GPU
operations require sampling across faces and adjacent faces reside in texture memory, preview
artifacts may be observed.

For example, shaders that use a relatively large sample kernel may encounter some preview
rendering artifacts when unexpected face textures are sampled.

Artifacts may also be observed when navigating a scene due to the blending of face textures in
generated mip-mapped textures that are used to improve GPU performance. This may be more
apparent when lots of small face textures are used.

NOTE: These artifacts only affect GPU accelerated previews, and do not appear in exported
texture data files.

Ptex Modeling Requirements
Mari supports both quad and triangular face textures, which are exposed by the Ptex file format. All
meshes use quad face textures, including mixed meshes; while wholly triangular meshes use
triangular face textures. Quad textures are natively supported in graphics hardware. However,
triangular textures are not supported in the current generation of graphics hardware. Mari’s canvas
preview of triangular textures uses the system described for GL displays at http://ptex.us/tritex.html.

Though Mari supports both types of face textures, Ptex dictates that the dimensions of a triangular
face must be equal. Due to this restriction to triangular textures, if they are applied to polygons with
an aspect ratio significantly different to one, the texture appears blurred or smeared. When triangular
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textures are stored in packed format, GPU renderers can only display half of the texels, resulting in
Mari filling in the other half of the texture with data that it is not representable in the display.

NOTE: Some renderers, such as RenderMan, read all texels and, thus, can render triangular
texels.

TIP: For more information regarding packed format and triangular textures, please refer to
http://ptex.us/tritex.html.

For low-frequency images, the even and odd texels are very similar in color, and the Ptex packing of
triangular textures suggests that a simple mirror of texels can be used to fill the other half of the
texture when exporting to Ptex. Mari implements this mirroring. For high-frequency images,
however, this mirroring is incorrect and visual artifacts appear in software renderers using the
exported Ptex file.

With the restrictions of triangular textures, we highly recommend not modeling with only triangular
faces. Quad face textures do not have the same triangular face equality restrictions and are a
preferable option for use in Mari.

Create a New Project
Multiple files can be used to create a project in the Ptex workflow. If this is the case, it is recorded in
the dialog’s history as a set of files instead of only one file.

NOTE: These instructions primarily discuss the steps for creating a new project that are
specific to Alembic and FBX files. For more information on creating a new project, from start
to finish, refer to the Mari Getting Starts Guide, in the Managing Projects chapter.

To create a new project, using either one file or a set of files, follow the steps below:

1. Start Mari and select File > New.

The New Project dialog box displays.

2. Enter a name for your project and the location of the geometry you want to work on.

3. You have the option to load either .ptx files or .obj files. If you choose to load an .obj file, the
Mesh Options panel displays with options for setting the Mapping Scheme for the project, using
Selection Sets, and working with Multiple Geometries Per Object.

• Mapping Scheme - if there is a UV map available, and you would like to use it, select UV if
available, Ptex otherwise. If you prefer to use Ptex, select Force Ptex. This option loads the
selected geometry and replaces the existing UV map with a Ptex map.
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• Selection Sets - if you want to select a specific object group in the geometry while you work, this
option allows you to set up selection sets using Create From Face Groups during project
creation.

• Multiple Geometries Per Object - if your .obj consists of multiple geometries, you have the
option to Merge Geometries Into One, which is the default behavior, or Create Separate
Geometries (Ptex Only).

If you select Merge Geometries Into One, Mari combines the individual geometries into a
single geometry, while selecting Create Separate Geometries (Ptex Only) creates individual
geometries.

New Project dialog: .obj mesh options.

New Project dialog: .ptx mesh options.

4. If you choose to load a .ptx file, the Mesh Options only provide the option for selecting Separate
Object or Separate geometry in one Object for the Process each geometry file field.

If you are importing more than one Ptex file, this option allows you to specify whether you prefer
for each separate file to constitute a separate object or separate geometries within a single object.

NOTE: Even if you select Create Separate Geometries (Ptex Only), Mari only displays a
single object on the canvas. However, when you export a channel you have the option to
export individual .ptx files for each geometry.

For Ptex projects, the channel setup and texture import section of the New Project dialog
can be ignored. A single channel named Ptex is created by default, you can create additional
channels once the project has loaded.

5. Continue setting up your new project as you would with any other file type.
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Set the Ptex Face Texture Options
If you use an .obj file to create a new project, and the file does not have a UV map assigned (or you
selected Force Ptex as the Mapping Scheme), the Ptex Import or Creation dialog box displays once
the project is created.

You can also manage Ptex face textures by accessing the Preferences menu.

Import Ptex Options

If you have a topologically matching .ptx file for the .obj, you can import it using the Import Ptex
options field. However, if you don’t have matching texture sizes, it can be resized upon import from
the Ptex Texture Import
dialog.

Create Ptex Options

If you don’t have a matching Ptex file for the .obj:

1. Under Create Ptex options, you can select constant colored textures for each face, whose
resolutions are based on either:

• Uniform Face Size - for face sizes that are equal and determined by the resolution set in the
Per face
texture size dropdown menu, or
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• Worldspace Density - for a given number of texels per unit of world space, where small faces
have smaller
textures and large faces have larger textures. You can set the number of texels in the
Worldspace Texels field.

NOTE: Please note that texture quality may be affected when painting across adjacent faces
if the faces are spatially different in size.

2. Set the bit depth of the Ptex image data by clicking on the Format dropdown menu. You can set
this to Byte, Half or Float.

3. Click OK.

Manage Ptex Faces
Once you have created the project and set the face texture options, a toolbar displays with a number
of options for managing Ptex faces within your project.

NOTE: When managing Ptex faces, please be aware that all image channels in your project
share the same face texture resolutions.

With the Ptex toolbar you can:

• - double the selected face resolution

• - halve the selected face resolution

• - set the world space face resolution for the selected face

• - set the face resolution for the selected face

• - fill the selected faces with the foreground color

• - fill the selected faces with the background color.
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NOTE: When adjusting the resolution of Ptex models, quad faces are limited to resolutions
between 1x1 and 8kx8k, while triangular faces are limited to resolutions between 2x2 and
8kx8k.

You may notice a slight pause after adjusting the resolution of a selected face. This happens
while Mari regenerates the texture’s proxy on the CPU.

TIP: These options are also available in the menu bar under Ptex.

Within Preferences, it is possible to set the Minimum Size for face textures via Ptex > Face
Textures |
Minimum Size. The default quadrangular texture is 1 and the default triangular texture is 2. This
represents the absolute minimum face texture size that Mari can restrict sizing operations to.

Export a Ptex Channel or Layer
1. To export a .ptx channel, select:

• Channels > Export > Export Current Channel, or

• right-click on a channel and select Export > Export Current Channel.

NOTE: If you want to export more than the current channel, select Export > Export All
Channels or Export > Export Everything from the Channels menu or right-click menu.

Alternatively, you can also export channels in a flattened format to save space when
exporting. To export flattened channels, navigate to Export Flattened in the Channels
menu or right-click to find the same three options for flattened channels.

2. To export a .ptx layer, select layers and navigate to:

• Layers > Export > Export Selected Layers, or

• right-click on a layer and select Export > Export Selected Layers.

NOTE: If you want to export more than the selected layers, select Export > Export All Layers
from the Layers menu or right-click menu.

Alternatively, you can also export layers in a flattened format to save space when exporting.
To export flattened layers, navigate to Export Flattened in the Layers menu or right-click to
find the same two options for flattened layers.

The Export dialog displays.
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3. Enter the Ptex export path in the Path field or manually browse to the location.

4. Set the Ptex File Template for Mari to use when generating the Ptex filename. You can edit this
line manually. As you edit, you'll see the Example Path update with an example .ptx filename.
You can use any combination of the following variables (which Mari replaces with the appropriate
values when it exports the files):

• $ENTITY - exports a single .ptx file, where the object name is part of the filename.

• $CHANNEL - exports a single .ptx file, where the channel name is part of the filename.

• $GEO - exports multiple .ptx files, where the individual geometry names is part of the filename

• $LAYER - exports multiple .ptx files, where the layer name is part of the filename.

• $COLORSPACE - exports a single .ptx file, where the colorspace used is part of the filename.

EXPERIMENT: Experiment with the different Ptex File Template variables, and see how the
Example Path changes to show how Mari generates exported filenames.

5. In the Ptex Options panel set whether Mari includes or excludes Face Mipmaps.

6. In the Ptex Metadata panel set whether Mari includes or excludes the following information with
the file when exporting:

• Geometry

• User Attributes
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• Adjacency

7. Set the Use Template For field to determine if the template above is used for Only this layer or
Everything.

8. For the Colorspace field, this is the colorspace to which the output values are converted.
Automatic is determined by the file name, size, and type of data in file.

9. Click Export.

Mari exports your textures to disk in .ptx format.

Import a Ptex Channel or Layer
1. To import a .ptx file to a channel, select:

• Channels > Import > Import into Layer Stack, or

• right-click on a channel and select Import > Import into Layer Stack.

NOTE: If you want to import into a new channel instead of the current layer stack, select
Import > Import into New Channel from the Channels menu or right-click menu.

2. To import a .ptx layer, select layers to import into and navigate to:

• Layers > Import > Import into Layer, or

• right-click on a layer and select Import > Import into Layer.

NOTE: If you want to import into the layer stack as a new layer, select Import > Import into
Layer Stack from the Layers menu or right-click menu.

NOTE: Ensure that you don’t import textures into a layer you want to preserve current
textures on, as importing into a layer updated the previous paint.

The Import dialog displays.
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3. Enter the Ptex import path in the Path field or manually browse to the location.

4. You can manually select the Ptex files to import or you can set the Ptex File Template to
automatically search for Ptex files that match the object, channel, or geometry variables. You can
edit this line manually. As you edit, you'll see the Example Path update with an example .ptx
filename. You can use any combination of the following variables:

• $ENTITY - imports a .ptx file, where the object name is part of the filename.

• $CHANNEL - imports a .ptx file, where the channel name is part of the filename.

• $GEO - imports .ptx files, where the individual geometry names are part of the filename.

• $LAYER - imports .ptx files, where the layer name is part of the filename.

• $COLORSPACE - imports a single .ptx file, where the colorspace used is part of the filename.

5. In the Ptex Metadata field you can set whether Mari should:

• Ignore the geometry metadata, or

• Import as New Version.

6. For the Colorspace field, this is the colorspace to which the input values are converted.
Automatic is determined by the file name, size, and type of data in file.

7. Click Import.

Mari imports the images.
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NOTE: If you are attempting to import geometry with degenerate faces into a Ptex project,
Mari removes these faces on import. A warning dialog displays notifying you of this
occurrence.

NOTE: For more information on importing or exporting channels or layers, refer to the
chapters on Channels and Layers .

To import a texture to a channel from multiple .ptx files, where multiple geometries are in an object,
follow the steps below.

1. Select:

• Channels > Import > Import into Layer Stack,

• Channels > Import > Import into New Channel, or

• Right-click on a layer in the Layers palette and select Import > Import into Layer.

The Import dialog displays.

2. Enter the .ptx file import path in the Path field or manually browse to the location.

The same $ENTITY, $CHANNEL, and $GEO environment variables are displayed, as described
above, and displays an Example Path below the dropdown menu.

3. Click All.

The Ptex Texture Import: Face Texture Resize Options dialog displays.

If the face dimensions of the incoming import match, it displays the information, but no further
action is required.

If the face dimensions of the incoming import do not match, a resize method dropdown menu is
listed. The options available are:

• Resize incoming faces to existing dimensions - the imported texture sizes are changed to
match those of the existing textures.

• Resize existing faces to incoming dimensions - the existing textures are changed to match
those of the incoming import.

• Largest dimensions available per face - whichever texture is the largest, whether existing or
incoming import, this is the texture size used. This is the default option when resizing is
necessary.
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4. Click Ok.

Mari imports the textures and loads them into the selected channel.

NOTE: The resize options are applied per face of the geometry. The Ptex Texture Import:
Face Texture Resize Options dialog is also displayed when importing new geometry
versions from .ptx files.

Paint Preservation with Multiple Ptex Geometries
Geometry versions from .obj files can be added to a Ptex project, provided all the versions are
topologically equivalent, that is, they have the same number of faces with the same shape, so that the
model does not change. This preserves the paint that has already been applied to the existing
version.

Though .obj files can be added to Ptex projects with topologically equivalent versions - that is to say,
versions that have the same number of faces, with the same shapes - there are caveats to the
functionality:

• If the .obj file contains multiple geometry groups within it and the project has been created to
treat these as separate geometries within a file, the .obj file can still be used as a version with
fewer groups. These are matched and the paint preserved.

• If more than one geometry is topologically equivalent, then a match for their .obj file group
names are used to attempt to distinguish between them.

• If an .obj file with a previously unknown group is used as a version, a new Ptex texture space is
allocated to these new geometries.

• If there are fewer geometry groups in the new version than in the existing geometry, the extra
geometries are hidden.

Any topological changes to geometries added as a version, such as a change to the model shape or
size, do not transfer existing paint. If a .ptx file is imported as an object version over .obj geometry,
any paint that has been applied is overwritten by the incoming version. A warning message on the
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Ptex Texture Import: Face Texture Resize Options dialog alerts you to the risk of losing existing
paint on topologically equivalent versions, as shown in the example below.
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Alembic and FBX
An Alembic file can contain several entities, such as geometry (polygon meshes and subdivided
surfaces), cameras, materials, and lights. Alembic files allow different groups of people to work on
the same assets without losing any data.

Mari supports the use of Alembic files, especially when handling multiple geometries within a single
Alembic (.abc) file. On project creation or import, Alembic files can be used in place of .obj or .ptx
files, with their own mesh options and parameters for specifying how Mari treats the different
entities. However, there are differences. Mari only allows geometry and cameras to be loaded or
imported, and there are some considerations that must be made if you're used to working with .obj
or .ptx files.

An FBX file can contain several entities, such as geometry (vertices and patches), materials, texture,
and animation. As opposed to the Alembic format, which is a point cache format that bakes rigs and
constraints to vertices, FBX files export these entities to FBX nodes, which gives you the flexibility to
have the original data, and manipulate it as needed.

Alembic Support
Alembic allows Mari to import hierarchies of objects within a single file. Any Alembic file containing
multiple objects as part of a hierarchy can have these objects merged on project creation or load.
Cameras, also packaged as part of the file, can be imported and treated as Mari would treat other
projectors in the Projectors palette.

Currently, Alembic support in Mari includes:

• starting a new project with either multiple objects or several objects merged into one from the same
.abc file

• optionally choosing to merge geometry as a single mesh or in such a way as to preserve the
geometry and metadata

• working with object hierarchies in order to retain multiple child objects as part of a parent object,
just as you would within your modeling package

• creating a project with, or loading in, projectors from an .abc file to store in the Projectors palette

• loading in animated geometry as a single .abc file as opposed with .obj files, which require a file for
each frame of animation

• loading or importing face sets packaged with the .abc file to store in the Selection Groups palette
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• Python bindings for Alembic project creation, object and camera loading, and import/export
functionality. Refer to the Python HTML documentation within Python > API for further information.

• detecting whether to subdivide each Alembic geometry piece, based on subdivision flags set in the
file.

Limitations to Mari's Support of Alembic

Mari does not support all the functionality that comes along with Alembic files. Some entities that the
file format contains cannot be handled in Mari or are restricted.

Currently, the limitations of Mari's Alembic support include:

• loading or importing only geometry and cameras, not lights or materials, even if the .abc file
contains them

• loading or importing only one .abc file, as one file can contain several objects, unlike .obj or .ptx
files

• creating selection groups from geometry faces cannot be done in the same way as with .obj or .ptx
files; instead face sets are imported from the .abc file and stored in the Selection Groups palette.

FBX Support
Mari supports importing cameras, geometry, and animation from .fbx files, and loads .fbx and .abc
files similarly. Additionally, the scene data from the file is presented in the New Project dialog in the
same tree widget format. As with Alembic files, FBX GeoEntities are created from polymeshes and
sub-divisions, projectors are created from imported cameras, and selection sets are created from
face sets and assigned materials on a polymesh.

Currently, FBX support in Mari includes:

• creating GeoEntities from polymeshes and sub-divisions

• creating Mari selection groups out of FBX face sets and polymesh materials

• creating projectors from imported cameras

• selecting animation takes and applying the animation to a GeoEntity in Mari

• importing keyframe animation from selected geometry and cameras

• importing object hierarchies and transform animation

• loading FBX deformations (mesh skinning and blendshapes) onto a selected geometry

• Python bindings for FBX project creation, object and camera loading, animation take management,
and import/export functionality. Refer to the Python HTML documentation within Python > API for
further information.
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Limitations to Mari's Support of FBX

Mari does not support all the functionality that comes along with FBX files. Some entities that the file
format contains cannot be handled in Mari or are restricted.

Currently, the limitations of Mari's FBX support include:

• only loading polymesh and sub-division geometry, cameras, and any transform or group nodes that
contain geometry. NURBS, patches, markers, locators, lights, and curves are not loaded into Mari.

• only loading the skeleton data for a mesh (that is to say, joints, bones, their transforms, and
keyframe animation). The associated mesh is deformed using the skeleton. Mari does not read in
higher level IK/FK solver systems.

NOTE: If you want to bring any modeler-specific solver animation data into Mari, you need
to bake the IK/FK animation into the skeleton and then export the mesh and skeleton to
Mari.

Alembic and FBXModeling Requirements
With the ability to bring in multiple objects at once from an Alembic or FBX file, you need to make
sure that each of the objects occupies separate sets of UDIMs. You can merge objects together, which
implies that the merged objects all occupy the same shading context. Without each object having its
own set of UDIMs, painting on one object causes paint to be projected on other objects that have
been merged. Separating the UVs is done in the modeling package before the model is exported to
Mari. Separating the UVs cannot be done in Mari, so it's important you ensure this is done prior to
export. When modeling with FBX, please note that patches cannot be touching the edge of the UV,
else it counts the patch as two separate patches.

For more information regarding UDIMs, please refer to Using UDIM Values.

Objects and Object Hierarchies
Alembic and FBX files can contain many objects, both on their own or as part of an object hierarchy.
In the object hierarchy, there are a combination of transform objects, polymeshes, and subdivided
geometries. All of these can be loaded or imported into Mari. These are treated, more or less, as
multiple .obj objects are treated on project creation or import.
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When working with Alembic or FBX files, the first place you encounter these objects and geometries is
the New Project dialog. Once you have input an .abc or .fbx file into the Path field, the objects and
cameras that are contained in the file, are shown in the Object Hierarchy Tree in the dialog.

Due to the hierarchical object structure, child objects inherit properties, such as transforms, from the
parent object. Mari thus must make the distinction between entities and GeoEntities. Entities
represent a transform. A GeoEntity contains all the geometry information, such as faces, vertices,
normals, and the like. A GeoEntity is used to represent geometry in Mari. Only GeoEntities are visible
in the Object Hierarchy Tree.

The entire Alembic or FBX file is loaded by default unless you make a selection. If you make a
selection, Mari assumes that only selected objects are to be loaded. If this is the case, simply having
the Merge checkbox ticked does not tell Mari to load that object; it must be selected as well.

WARNING: If you don't select individual objects in the Object Hierarchy Tree, the entire
Alembic or FBX file is loaded. Depending on the size of the file, this could take longer than
expected to load into Mari.

Animated Geometry

Alembic Animated Geometry

When bringing animated geometry into Mari from an Alembic file, Mari displays start frame and end
frame controls in the New Project dialog. You can set the range you want to load or import or, if you
want to bring in all frames or only a single frame, click on the Single Frame or All Frames buttons.
Some .abc files, exported from older version of the Alembic exporter, do not expose their frame
range when brought into Mari. In this case, Mari displays the notice "All frames from this archive will
be loaded" and loads all frames.
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FBX Animated Geometry

FBX stores animation on geometry in a similar manner to Alembic, and supports the concept of
animation takes on a skeleton, which allows you to use the same skeleton structure on your mesh to
create different animations. Each take is related to the same object, and can have different animation
ranges as well. In Mari, this data is presented in the object loader widget in the New Project dialog.
You can also select the specific takes you want from the Take dropdown under Mesh Options.
However, within Mari, the FBX concept of an animation take is only applicable during geometry load.

WARNING: Once the geometry is imported into Mari, it has the selected animation take
bound to it. You won't be able to access any other animation takes or change the animation
on the fly within Mari.

Deformations

Vertex Cache Deformations

For FBX files with heavy deformations to the mesh, it may be more effective to cache the
deformations to disk. In a big production pipeline, this gives the artists the flexibility to pass the
cache alongside the meshes down the pipeline, and to view the static meshes as well as to bring in
the animation from disk. When you export this mesh and vertex cache to FBX, Mari loads in the
mesh, locates the cache, and loads in the geometry with cached animation.
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Skin Deformations

In cases where the FBX file contains the skeleton deformation of a mesh, where the geometry is
rigged by adding a hierarchy, this is bound to the mesh, and keyframes are animated to deform the
mesh, you need to follow certain binding methods to ensure that the .fbx file is loaded into Mari
correctly. The three binding methods you can use are:

• Linear/classic binding - the default binding method, where the position of a vertex is determined by
linear interpolation of the weights of the surrounding bones.

• Dual quaternion binding - a binding method that provides an improved solution to skinning
geometry, where the volumes are preserved in case of extreme stretching movements.

• Blended binding - a binding method that mixes both linear and dual quaternion methods through
the use of a blend weight.

Using one of these methods, both the mesh and the associated skeleton is exported to the .fbx file
and, when imported into Mari, this information is read and loaded into the final mesh with the
deformation.

NOTE: Mari does not display the skeleton; only the deformed mesh.

Cluster Deformations

Most modeling packages allow you to define extra weights on selected sets of vertices for a mesh,
called a cluster deformation. Cluster deformations are supported by FBX at the point of export.
Adding cluster deformations can work with skinned meshes, but you need to ensure that the order of
input and output is correctly set up before exporting the scene to an .fbx file. Once the file is loaded
into Mari, the mesh is loaded, the associated clusters are gathered, and the weights are applied to the
vertices, before the deformed mesh is then loaded into the project.

Blendshape Deformations

Most modeling packages allow you to create duplicates of original geometry in order to blend
between the original and duplicate using a weight. This allows you to achieve in-between poses, and
is especially useful for altering a character's facial expressions in a production environment. You can
then keyframe animate the blendshapes and export them to FBX. One the file is loaded into Mari, the
mesh is loaded, the associated blendshapes are gathered, and the weights are applied to load in the
final blended geometry.
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Create a New Project
NOTE: These instructions primarily discuss the steps for creating a new project that are
specific to Alembic and FBX files. For more information on creating a new project, from start
to finish, refer to the Mari Getting Starts Guide, in the Managing Projects chapter.

To create a new project, using an Alembic or FBX file, follow the steps below:

1. Start Mari and open a new project.

The New Project dialog box displays.

2. Enter a name for your project and the location of the .abc or .fbx file you want to import from.

3. Once you load an .abc or .fbx file, the Mesh Options panel displays with options for setting the
Mapping Scheme and Merge Type. The Object Hierarchy Tree also displays beneath these
options.

• Mapping Scheme - if there is a UV map available, and you would like to use it, select UV if
available, Ptex otherwise. If you prefer to use Ptex, select Force Ptex. This option loads the
selected geometry (GeoEntity) and replaces the existing UV map with a Ptex map.

• Merge Type - if you want to merge any of the objects (Entities or GeoEntities) on project
creation, the merge type controls how Mari handles the merge operation. When merging as a
Single Mesh, all the various geometries are merged into one geometry inside of a GeoEntity,
and any object data for the merged objects is lost. When merging as Just Merge Nodes, all the
merged objects are merged into one geometry inside a GeoEntity, but they keep their metadata
and object data.

• Take - for FBX only; animation takes exported with the geometry can be selected in the
dropdown menu. Takes can only be chosen at the time of project creation/object load and
cannot be changed once it has been set. In cases where there is only one take from the file, the
default is selected in the mesh options.

• Object Hierarchy Tree - displays all the geometry and meshes, cameras, transforms, and groups
from the Alembic file.
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NOTE: If the Object Hierarchy Tree seems to be taking too long to display objects from an
.fbx file, ensure that the file was saved as binary FBX rather than ASCII FBX.

4. Click on the objects in the Object Hierarchy Tree to select which geometries you want to load into
the project on project creation. You can also select any cameras that you want to load at the same
time.

5. If you want to merge any of the objects, toggle the Merge checkbox to select which objects are
merged together. For more information on how to merge objects, refer to Adding and Merging
Alembic or FBX Geometry.

6. If the objects are animated, select the start and end frames for a specific selection, or click Single
Frame or All Frames. If these options don't appear, you may be given a message that "All frames
from this archive will be loaded."

7. Set a Frame Offset to specify the start position for loading the objects on the Mari timeline.

For example, if you want to import frames 1005 to 1010, with an .obj file, you would select files
xxx.1005.obj, which would populate the start frame field with 1005 and end frame field with
1010.

Whereas with an .abc or .fbx file, you would select the file and that would populate the start
frame field with 1 and the end frame box with 5.

In order to load the frames correctly into Mari's timeline, starting at 1005, you need to set the
offset to 1004, so that it loads the geometry into Mari's timeline at 1005 to 1010. Failure to do this
causes Mari to load the geometries at Mari's frame 1 to 5.

8. Continue setting up your new project as you would with any other file type.

Adding and Merging Alembic or FBX Geometry
Each of the objects or entities, shown in the Object Hierarchy Tree, has a checkbox next to it for
selecting which objects are merged. The Merge Type in the New Project dialog's Mesh Options
determines how the objects are handled on merge: as a Single Mesh or Just Merge Nodes. Toggling
the Merge checkbox of a parent object ticks the checkboxes of all the child objects as well, and
signals that the parent and child objects should be merged into one GeoEntity, or object in Mari. You
can also select a root object and toggle the Merge checkbox to determine if any other objects are
merged into the root. When a camera appears in the Object Hierarchy Tree, the camera is shown with
the Merge checkbox ticked by default. Cameras are not stored in a hierarchy in Mari, thus the state of
the checkbox cannot be changed.

Merging objects can happen in a number of ways, so that different parts of the geometry (child
objects) are merged with the parent object to create one GeoEntity, several child objects are merged
together but not merged with the parent object, or several parent objects in an Alembic or FBX file
are merged together so there are fewer geometries being created on project creation.
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In an example Alembic file, where there are three parent objects (Ground, House, and Person), the
following are examples of common ways to merge objects:

• Everything is merged together - select the merge checkbox for each of the selected parent objects
and the root folder.

• Specific selected objects are merged together - selected objects with the Merge checkbox ticked are
merged together. Any selected objects that do not have the merge checkbox ticked are loaded as
separate objects.

• Selected objects aren't merged but selected cameras are merged by default - none of the selected
objects are merged together but the selected camera has the Merge checkbox ticked by default and
is disabled so that it cannot be changed.

• Selected objects are partially merged - selected child objects are merged into the selected parent
object but the parent object is not merged into the other selected parent objects.
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• Selected frame ranges are merged - selected objects with a frame range specified are merged into a
single geometry.

To merge Alembic or FBX geometry on project creation, refer to the steps in Create a New Project on
page 362 for more information. If you have already created a project and want to load in merged
Alembic or FBX geometry, follow the steps below.

Merging Objects on Object Import

To merge objects that you are importing into an existing Mari project:

1. Open the Objects palette and click the icon, or select Objects > Add Object.

The Add Objects dialog appears.

2. Select the Alembic or FBX file with the objects that you want to import into the project, and click
Open.

The Add Object Settings dialog appears.

3. Set the Mapping Scheme, Merge Type, and Take fields. These are the same as the fields in the
New Project dialog, described in Create a New Project on page 362.
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4. Select the objects that you want to import into the project, and click the Merge checkbox for each
of the objects that should be merged together on import.

5. If all the frames are loaded into the project, the dialog specifies this, and does not show a start
and end frame range.

6. You can also set a Frame Offset for the start position for loading the objects.

For example, if you want to import frames 1005 to 1010, with an .obj file, you would select files
xxx.1005.obj, which would populate the start frame field with 1005 and end frame field with
1010.

Whereas with an .abc or .fbx file, you would select the file and that would populate the start
frame field with 1 and the end frame box with 5.

In order to load the frames correctly into Mari's timeline, starting at 1005, you need to set the
offset to 1004, so that it loads the geometry into Mari's timeline at 1005 to 1010. Failure to do this
causes Mari to load the geometries at Mari's frame 1 to 5.

7. Click Ok to import the objects or Cancel to abandon the import and close the dialog.

Importing Objects
At any time after project creation, you can choose to import objects into the project. These objects
can be GeoEntities from the same or another .abc or .fbx file, from an .obj file, or even from a .ptx
file. To import more objects into the project, add objects as you would through the Objects palette or
the Objects menu. For more information, see Adding Objects

Importing New Versions
As with objects, you can add object versions from an .abc or .fbx file to the Objects palette any time
after project creation. The object versions must be of the same file type and merge structure; thus, if
you already have an object from an .abc file and you loaded it into Mari with merged geometry, the
new version should ideally be an .abc file with the same merged geometry. Just the same, if the
objects were loaded into Mari with unmerged geometry, the versioned file must also be unmerged.

To add new objects to a project, refer to the steps in Adding and Merging Alembic or FBX Geometry
on page 363 for more information. If you have already added objects to your project and want to load
in new versions of them, follow the steps below:

1. Open the Objects palette and right-click on the object for which you want to load a new version.

The Add Version dialog appears. This looks like a Mari-standard file browser.

2. Select an object from the file browser or type in the file path, then click Ok.

The Add Version Settings dialog appears.
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3. Set the Mapping Scheme, Merge Type, and Take options for the new object version. For more
information about these controls, refer to the steps in Create a New Project on page 362.

NOTE: When choosing whether or not to merge geometries, bear in mind that new versions
must have the same merge structure as the original object version. For instance, if you
already have an object from an .abc file and you loaded it into Mari with merged geometry,
the new version must also be an .abc file with the same merged geometry.

4. If the objects are animated, select the start and end frames for a specific selection, or click Single
Frame or All Frames. If these options don't appear, you may be given a message that "All frames
from this archive will be loaded."

5. Set a Frame Offset to specify the start position for loading the objects on the Mari timeline.

6. Click Ok and the new object version is loaded into the Objects palette.

Importing Cameras
As with objects and versions, you can add cameras from an .abc or .fbx file to the Projectors palette
and, similarly to the Objects palette, you can load cameras from different file formats. For this
reason, you can have a mix of .fbx and .abc cameras in the Projectors palette.

To import Alembic or FBX cameras on project creation, refer to the steps in Create a New Project on
page 362 for more information. If you have already created a project and want to load in FBX
cameras, follow the steps below.

To import cameras from an Alembic or FBX file into an existing Mari project:

1. Open the Projectors palette and click the icon, or select Camera > Load Camera.

The Load Camera dialog appears.

2. Select the Alembic or FBX file with the cameras that you want to import into the project, and click
Open.
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If you are importing cameras from an Alembic file, the Add Camera Settings dialog appears.
Otherwise, the Select Entities dialog appears.

The GeoEntities, transforms, and cameras in the file are all shown in the object hierarchy tree, but
only the cameras can be loaded from this dialog. Note that selecting a geometry disables it in the
object tree so that it cannot be selected again.

3. Select the cameras that you want to import into the project.

4. If the objects are animated, select the start and end frames for a specific selection, or click Single
Frame or All Frames. If these options don't appear, you may be given a message that "All frames
from this archive will be loaded."

5. Set a Frame Offset to specify the start position for loading the objects on the Mari timeline.

6. Click Ok to load the cameras into the Projectors palette.

Naming of Objects
Objects are imported with the name of the hierarchy, with / replaced by _ if they are single unmerged
geometries. If the child geometries are merged beneath a parent geometry, the naming changes so
that the object name is the same as the parent geometry. In cases where some of the child
geometries are merged while others are not, the unmerged child geometries take the name from the
parent geometry/shape, and the merged child geometries take the name of the parent geometry.

For example, for the following village example Alembic file:
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• none of the selected geometries are merged, so the imported object is named Person_Hands_
HandLeft_HandLeftShape because the hierarchy path was Person/Hands/HandLeft/HandLeftShape
when importing.

• all of the child geometries are merged together under the Person parent geometry, so the imported
object is named Person.

• some of the child geometries under the Person parent geometry are merged but not all of them, so
two objects are imported. The imported object from the merged geometry is named Person_
PersonShape (it contains merged geometry from the face, hands, feet, and neck) and the imported
object from the unmerged geometry is named Person_Body_BodyShape (it contains the unmerged
body geometry).

Selection Groups and Face Sets

Alembic Selection Groups

Unlike with .obj files, selection groups cannot be created from faces on import. Instead, when loading
an .abc file, Mari searches for whether it contains face sets exported from your modeling package. If
it detects that there are face sets present, these are automatically loaded on project creation or object
import, and added to the Selection Groups palette. Once you've created a project, you can create
your own selection groups, if you wish.
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FBX Selection Groups

Dissimilarly to Alembic files, selection groups can be created from face sets with .fbx files.
Additionally, selection groups can also be created from FBX materials. Mari creates selection sets in
this way by looking at non-default materials and assigning faces with the materials to a specific set.
For example, if a cube has faces 0 and 1 assigned to a material called "grass" and faces 2, 3, 4, and 5
are assigned to a material called "glass", Mari separates these faces into two selection sets. These
selection sets are automatically loaded on project creation or object import, and added to the
Selection Groups palette. Once you've created a project, you can create your own selection groups, if
you wish.
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Working with Objects
Mari allows you to load multiple objects and child objects into a scene, and paint them at the same
time. This lets you paint objects in context - for example, you can paint all the elements of a
character's costume by loading them up onto the character. You can show and hide objects, so you
can easily switch between working only viewing a single object, and seeing how it fits with the other
objects.

You can load multiple copies of a single object into the project. This allows you to, for example, build
up a road scene with twenty sections of pavement, two lamp posts and a fire hydrant from three
basic models (pavement section, lamp post, and hydrant).

When you create a project, you must load in an object. Once you've created the project, you can add
more objects to it.

Initial project, with only the
blacksmith torso model.

With other objects loaded.

If a project has two or more objects, you can remove objects from it. All projects must have at least
one object. Removing an object from a project has no effect on the source file for the object. The
objects within a project are listed in the Objects palette.

Channels and Shaders on Multiple Objects
Each object in the project has its own set of channels. When you add channels, you have the option to
apply the action to all objects in your project.

When you add a new object, Mari creates a single channel, diffuse, to hold the diffuse color. You can
add more channels as you would normally.

Similarly, each object has its own shaders. As with channels, there are default shaders but you must
set up your custom shaders separately for each object. If you want to copy shaders from the Shaders
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palette of another object, use the Ctrl/Cmd+C and Ctrl/Cmd+V shortcuts to copy the shader and paste
it into the Shaders palette for the current object.

Adding Objects
1. Start Mari and open your project.

2. Open the Objects palette.

This displays all the objects in your project.

3. Add a new object by:

• clicking Objects > Add Object from the menubar,

• clicking in the Objects palette,

• right-clicking on the empty space in the Objects palette, and selecting Add Object from the
dropdown menu.

The Add Objects dialog box displays, allowing you to select the new object file to add.
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4. Select the file to add and click OK.

The Add Object Settings dialog displays.

• If the object you are adding is an .obj file, set the Mapping Scheme, Selection Sets, and
Multiple Geometries Per Object fields to specify how you want the object to be treated on
creation in the project.

• If the object you are adding is an .fbx or .abc file, set the Mapping Scheme, Merge Type, and
select the objects to import from the object hierarchy. You also need to select which frames you
want to load and, in the case of Alembic files, a the Frame Offset.

• If the object you are adding is a .ptx file, set the Process each geometry file as a field to
specify how multiple geometries in the object are handled.

Mari adds the new object to your project. Your new object has a single channel, Diffuse (to hold
the diffuse color). You probably want to add additional channels (see Create and Delete Individual
Channels).
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TIP: You can add a file that already exists in your project. In this case, the new object is
added as a second instance of the same file, and is initially on top of the first instance.

NOTE: For more information on how Alembic and FBX objects are handled in Mari, refer to
the Alembic and FBX chapter. For more information on how Ptex objects are handled in
Mari, refer to the Ptex

Adding Child Objects
1. Start Mari and open your project.

2. Open the Objects palette.

This displays all the objects in your project.

3. Add a new child object by right-clicking an object in the Objects palette, and selecting Add Child
Object from the dropdown menu.

The Add Objects dialog box displays, allowing you to select the new object file to add.

4. Follow the rest of the steps from 4 onwards in the 'Adding Objects' steplist above.

The object is added as a child to the selected object.

Adding and Removing Object Versions
Objects within your project are versioned. If the source file for the model changes, you can load a new
version of the file – Mari updates the model in your project, and keeps all the textures you've painted
on it.

When you add a new version of a model, Mari assumes that the patch numbering hasn't changed,
and projects the existing textures over the updated geometry. Whenever you add a new version of an
object, check any textures you've already painted, especially if the patch numbering has changed.

All objects start with an initial version. You can add and remove versions, as long as at least one
version of the object remains. Mari does not enforce any other restrictions - for example, if an object
has three versions, you can delete any of the three versions.

TIP: Mari does not restrict what you can add as a new version (as we have no way of knowing
what kinds of changes to the models you may need to make as you develop the asset!). As a
result, you can add any object file as a new version of an existing file – so be careful that you
don't add the wrong file by mistake.

To add a new version to an existing object:
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1. Right-click on the object in the Objects palette, and select Add Version from the dropdown
menu.

The Add Version dialog box displays.

2. Select the file for the updated object and click Open.

Mari adds the new version to the object's history and updates the display to show the new
version.

TIP: Check any existing paint on the object, as it may have been distorted by the move to the
new mesh.

To remove an object version, right-click on the object in the Objects palette and select Remove
Version from the dropdown menu.

Adding Locators for Objects
You can load locators and child locators in order to transform an object by rotating, scaling, or
moving it. This is especially helpful with spherical projects, where you may want a procedural to have
a 3D world or camera space position that it can use in its calculations.

NOTE: Currently, linking a procedural to a locator is something that can only be done
through the Python Console. There is no GUI option for this functionality at present.

Adding Locators
1. Start Mari and open your project.

2. Open the Objects palette.

This displays all the objects in your project.

3. To add a new locator, right-click in the Objects palette and select Add Locator from the

dropdown menu, or click on the Objects palette.

The locator is added to the bottom of the objects list.
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Adding Child Locators
1. Start Mari and open your project.

2. Open the Objects palette.

This displays all the objects in your project.

3. To add a new child locator, right-click the object in the Objects palette and select Add Child
Locator from the dropdown menu.

The child locator is added beneath the selected object.
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Duplicating Objects
You can duplicate child objects but not parent objects, locators, or child locators. Duplicating an
object creates a copy of it and adds it to the bottom of the object list in the Objects palette. When
duplicating, you can choose to copy just the object or both the object and its associated shader
network.

1. Open the Objects palette and select the object you want to duplicate.

2. Either:

• select Objects > Duplicate > Object Only or Object And Shader Network, or

• right-click on the object and select Duplicate > Object Only or Object And Shader Network
from the dropdown menu.

3. If you chose:

• Object Only - Mari duplicates only the selected object without any of the shader, channel, or
layer data.

• Object And Shader Network - Mari duplicates the selected object, including all associated
shaders, channels, and layers that belong to the object and the data they contain.

The duplicated object is added to the bottom of the object list.

Removing Objects and Locators
1. To remove an existing object, child object, locator, or child locator, select it in the Objects palette

and:

• either click Objects > Remove Object from the menubar,

• right-click the object and select Remove Object from the dropdown menu, or

• click on the Objects palette.

Mari asks you to confirm the deletion.

2. Click Yes to remove the object.

You can remove any object from a project, as long as there is at least one object remaining
afterwards.

Moving, Viewing, and Locking Objects
You can move objects around on your Mari canvas. For example, you might have added an object
which has appeared on top of an existing object (where the objects appear depends on the
configuration of the model file).
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1. To move an object, select the Transform selected object tool.

The transform handles (gimbal) appear at the position of the object's pivot point that was saved in
the original .obj, .fbx, or .abc file.

2. Click and drag to move the object, or use the transform handles to move the object along one of
the handle directions.

Initial state. Apron moved to the left.

Clicking on an object selects it. You can then configure and edit it (for example, to change to paint
on a different channel).

3. The Objects palette lets you show/hide and lock/unlock the object:

• To show or hide an object, click .

• To lock or unlock an object, click .

4. If you move the object accidentally or want to reset the object back to its original position,
Shift+click to reset the object, press the apostrophe key (’) on the keyboard to reset all objects, or
select Objects > Reset Object Transform to return the selected entity in the Objects palette back
to its original coordinates.

TIP: You can also use the Transform selected object tool to move lights around (see
Configure the Lighting).

Using the Gimbal

When you want to move an object using the Transform selected object tool, a gimbal appears at
the selected object's pivot point. A gimbal allows you to drag on transform handles to move, rotate,
or scale the selected object. The colors of the handles correspond to the axes available in 3D space:
red transforms the x-axis, green transforms the y-axis, and blue transforms the z-axis. Mousing over
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individual parts of the gimbal highlights that control, so you know what axis you are about to
transform.

Moving an Object with the TransformHandles

Drag the arrow to move an object on the given axis:

• X translate (red arrow),

• Y translate (green arrow),

• Z translate (blue arrow), or

• Free translate (center of the gimbal widget)

NOTE: Free translation is a 2D (x, y) transformation in the angle of projection of the camera,
and can also be achieved by clicking anywhere on the model.

Rotating an Object with the TransformHandles

Drag a specific axis ring to rotate either:

• X rotation (red circle),

• Y rotation (green circle),

• Z rotation (blue circle), or

• from the camera angle (white circle).
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Scaling an Object with the TransformHandles

Drag a single axis square to scale on that axis:

• X scale (red cube),

• Y scale (green cube), or

• Z scale (blue cube).

NOTE: Mari is currently limited to scaling in a non-uniform manner.

Calculating Ambient Occlusion
Mari does not automatically calculate the ambient occlusion for objects. This is because ambient
occlusion can take a long time to calculate for complex objects, and it is not required unless you are
using ambient occlusion for masking or shading.
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If you need ambient occlusion for an object, you must calculate it separately for each object.

To calculate the ambient occlusion for an object:

1. Select the object in the Objects palette.

2. Either:

• select Objects > Ambient Occlusion from the menubar, or

• right-click an object in the Objects palette, and select Ambient Occlusion from the dropdown
menu.

Mari calculates the ambient occlusion for the object in the current project. Depending on the size
and complexity of your model, this may be a good time to take a break.

Subdividing Objects
Subdividing the surface of an object allows you to smooth the surface of a low polygon mesh to
create a smoother surface with many more faces, and is usually divided into either quadrilaterals
(quads) or triangles. Mari uses OpenSubdiv to create static subdivided surfaces, as well as to load and
work with subdivided geometry. You can determine the Level of subdivision you want to apply from a
choice of levels 1-3. The levels represent the number of quads or triangles into which your mesh is
divided for each level, and the exact number is dependent on the Subdivision Scheme you choose.
For example, a Catmull Clark method at level 1 may produce more quads or triangles after
subdivision than a Bilinear method at level 2.

NOTE: If you instruct Mari to calculate the subdivision using a background process, you need
to manually select the Level to apply once the calculation is complete.

The manner in which the surface is smoothed is calculated based on a subdivision method. Mari
offers three methods: Catmull-Clark, Loop, and Bilinear. What method you choose may be, in part,
determined by whether your mesh is comprised of quads or triangles, as some methods, such as
Loop, only work correctly with meshes comprised of a certain type of polygon. In the instance of the
Loop method, the polygon type is triangle.

Another thing to consider when subdividing the surface of an object is how Mari handles the
interpolation of boundaries for the subdivision. Boundaries can be vertices (the point where edges
meet; a corner) or edges (the connections between vertices). Furthermore, vertices can have multiple
edges coming out of them, and the number of edges dictates whether the vertex is a Pole (three
edges) or an N-Pole (five or more edges).

TIP: The use of N-Poles in your object mesh could make subdivision difficult, or produce
artifacts.
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Mari handles these differently based on what Interpolation Boundary option you set before
performing the subdivision. The calculations for the interpolation primarily revolve around what parts
of the polygon are "sharpened" during subdivision:

• Bilinear (No Smoothing) - no smoothing on interior or boundaries.

• Sharp Edges & Smooth Corners - smooth interior, corners, and corners with more than two edges,
but sharp edges.

• Sharp Edges & Sharp Corners - smooth interior and corners with more than two edges, but sharp
edges and corners.

• Sharp Boundaries & Smooth Interiors - smooth interior, but sharp edges, corners, and corners
with more than two edges.

Interior Edges Corners Corners with more than two
edges

Bilinear (No Smoothing) Sharp Sharp Sharp Sharp

Sharp Edges & Smooth Corners Smooth Sharp Smooth Smooth

Sharp Edges & Sharp Corners Smooth Sharp Sharp Smooth

Sharp Boundaries & Smooth
Interiors

Smooth Sharp Sharp Sharp

WARNING: Subdivision increases the number of polygons exponentially to the subdivision
level, which means that if a geometry is already quite dense and you attempt to subdivide it
to a high level (2 or 3), Mari may become slow or unresponsive.

Below are examples of the subdivision levels on an un-subdivided mesh:
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No subdivision applied (level 0).
Level 1 subdivision applied using the

Catmull-Clark method.

Level 2 subdivision applied using the
Catmull-Clark method.

Level 3 subdivision applied using the
Catmull-Clark method.

Below are examples of the interpolation boundary options, shown after subdivision:

No subdivision (original model). Bilinear boundary interpolation.
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Sharp edge and smooth corner
boundary interpolation.

Sharp edge and sharp corner
boundary interpolation.

Sharp boundary and smooth
interior interpolation.

After subdivided geometry is calculated in Mari, the subdivided data is cached in the project.
Whenever the subdivision level is changed, Mari loads the cached subdivided data and renders it.
When subdivision is re-calculated, the cached data is deleted and the new data, with new subdivision
settings, is cached.

WARNING: If you have already created masks on an un-subdivided model and then choose
any level of subdivision, the masks appear offset from where they did on the un-subdivided
model. This is due to the nature of subdivision and the way it "distorts" the UV layout from
that of the original model because the UV shells are also subdivided with the 3D mesh.

To subdivide an object in your project:

1. Select the object in the Objects palette.

2. Either right-click and select Subdivide from the context menu or select Objects > Subdivide.

The Subdivide dialog displays.

3. Choose the Level of subdivision applied to your object. You can choose from levels 1-3.

4. Choose the Subdivision Scheme to determine how you want the object to be subdivided:
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• Catmull Clark - a subdivision model that creates a new mesh that consists of only
quadrilaterals.

• Loop - a subdivision model that supports meshes consisting of only triangles, and divides each
triangle into four smaller ones.

• Bilinear - a subdivision model that creates quadrilaterals with non-planar vertices.

5. Choose how Mari handles the Interpolation Boundary (for boundary edges and vertices):

• Bilinear (No Smoothing) - neither boundaries or interiors are smoothed.

• Sharp Edges & Smooth Corners - edges are kept sharp while interiors and corners are
smoothed.

• Sharp Edges & Sharp Corners - edges and corners are kept sharp while interiors and corners
with more than two edges are smoothed.

• Sharp Boundaries & Smooth Interiors - all boundaries are kept sharp while interiors are
smoothed.

6. Once you've determined how you want Mari to subdivide the selected object, choose whether
Mari calculates the subdivision in the foreground or background:

• OK - a progress bar displays as Mari calculates the subdivision. Once complete, the level of
subdivision specified is applied to the object immediately.

• In Background - the subdivision calculation is submitted to a background process and no
progress bar is displayed. The subdivision Level must be applied manually in the Objects

palette when the "running man" icon disappears from the Status Bar.
Go back to the Objects palette and, with the subdivided object selected, click Subdivision >
Level in the object properties pane and choose the level of subdivision you want to apply.

NOTE: When the level of subdivision you chose in the Subdivide dialog has completed, it
appears in the Level dropdown and you can select it at any time. If you chose the highest
level of subdivision for the object, you can select any lower level of subdivision from the
dropdown as well.

The object is subdivided and both the object on the canvas and the object properties in the
Objects palette are updated to reflect this.

NOTE: Mari detects whether to subdivide each Alembic geometry piece, based on
subdivision flags set in the file.
You can also force the subdivision of Alembic geometry pieces no matter how the
subdivision flags are set, refer to the Mari Reference Guide in the Subdivide Dialog section.
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Shadow Settings
Each object in your scene casts shadows if depth projection is not disabled under Preferences. To
display shadows, you must enable at least one light to cast shadows by checking the Render
Shadows box in the Lights palette before adjusting the settings in the Objects palette. If this is not
selected, objects with Cast Shadows enabled still don’t appear to be casting shadows.

Shadows can be toggled on or off in the display by selecting the Shadows button in the Lighting
toolbar.

If Depth Projections have been enabled in the Preferences, there are two related options that can
be set to customize the shadow settings. Depth Projection Resolution and Depth Projection
Texture Array Size control the texture resolution and shadow coverage.

Both these options are dependent on the graphics card. Mari automatically attempts to set this
option at the resolution that works best for your setup. If there aren’t sufficient graphics memory
resources, Mari degrades the quality of the shadows so as to use fewer resources until shadows can
be rendered.

To allow your model to cast shadows:

1. Select the object in the Objects palette.

2. Under Rendering, enable Cast Shadows.

Each object in your scene has the setting Cast Shadows.

Selecting this checkbox casts shadows from your models onto other objects in the scene, based
on your current lighting setup.

3. If you want to turn off shadows, toggle the Shadows button in the Lighting toolbar.

NOTE: Using variance maps allow the shadow edges to be smoothed out, but may
sometimes cause
rendering artifacts. To prevent these artifacts from occurring, disable the Use Variance
Maths checkbox under Preferences > GPU > Depth Projection.
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Filtering Images and Paint

Mari includes a set of filters you can use to transform the paint on your model. You can apply filters
to:

• paint in the current channel,

• only the current unbaked paint (the contents of the paint buffer), or

• an image within the Image Manager.

Unlike adjustment filters, the Filters accessed from the menubar apply a transformation to the paint
or image on the paint buffer, the current paint target, or selected patches on the paint target. Though
many of the filters available are the same or similar, those in the Filters menu do not affect the layer
stack beyond what you choose to apply the filter to. In addition, you can preview your changes on the
canvas before applying them.

There are many filters to choose from, and a complete list is provided in Available Filters on page 390,
but a brief example of the filters Mari can apply are:

• Blurs to the painting,

• Inverted colors,

• Changes to hue, saturation, or value,

• Removal of specific color channels,

• Application of color correction, and

• Added noise.

Every filter has the option to use a mask to control what part of the painting it affects. Depending on
what you are applying the filter to, you can mask specific channels or apply an image from the Image
Manager to create a mask.

Some filters do not require any configuration. For example, the Edge Detect filter has no user-
configurable settings. Other filters provide a wide range of configuration options, including the ability
to create, manage and load preset filters. For example, the Color Curves filter gives you very fine
control over the contents of the RGB color components.

As well as using Mari's pre-defined filters to edit the paint on a the paint target or in the paint buffer,
you can use them as part of a custom color profile. These filters only affect how the colors display on-
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screen (rather than actually changing the painting itself). See Managing Colors for details on setting
up custom color profiles.

To make it easier, Mari provides an interactive preview of each filter. As you change the settings for
the filter, the main canvas updates to show a preview of how the filter looks.

TIP: Filter previews are not available for scalar channels.

Mari also offers filters in 3D space, which do not experience artifacts due to boundaries such as patch
edges. These filters behave similarly to traditional filters but are object-based. These filters can be
accessed from the Objects > Generate menu.

Select and Apply Your Filter
1. Start Mari and open your project.

2. For best results from the filter preview, set the lighting to flat, so the effects from the filter aren't
lost in the effects of the lighting.

3. If you plan to apply a filter to the contents of a specific channel, make sure it is selected in the
Channels palette, and that you select the Current Paint Target option.

4. If you plan to apply a filter to an image, open it from the Image Manager by double-clicking on
the image before selecting the filter from the Filters menu.

NOTE: A preview window for the image opens when you double-click it in the Image
Manager.

5. If you plan to mask an area of the Current Paint Target using the Marquee Select tool, draw the
area you want to mask.

NOTE: Using a Marquee Selection as a mask is only possible when applying a filter to the
Current Paint Target.

6. Select the filter you want from the Filters menu (see the table of Available Filters on page 390).

The dialog box for your selected filter displays.

Each filter has a different dialog box, with applicable Options.
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7. Select Options for the filter.

If you’ve already created a preset, select it from the dropdown menu to load it. If you want to save
your current options as a preset, click to enter a preset name. You can always delete this by
selecting .

8. Select whether the filter should be applied to:

• everything on the Current Paint Target (not including any unbaked paint in the buffer),

• only the Current Painting (that is, the unbaked paint in the buffer), or

• the Selected Images (in the Image Manager).

9. Select whether to use a Mask:

• If you’re applying the filter to the Current Paint Target, you can use the any channel in the
project as a mask.

• If you’re applying the filter to the Current Painting, you can use the Marquee Selection tool to
draw an area that you want to mask. This area should be drawn before selecting the filter.

Alternatively, you can use an image from the Image Manager.

• If you’re applying the filter to Selected Images, you can use any image in the Image Manager
as a mask.

NOTE: If you choose to use a channel or an image from the Image Manager as a mask, an
Invert checkbox and a Mask Curve editor displays. For more information on using these,
see the next section on
Available Filters.

10. Toggle the Preview switch to see the filter's effects before applying them.

TIP: Click on the control to toggle the filter on/off while you watch the effects. The preview
always displays on the whole model - even if you have the filter set to apply to the Current
Painting or Selected Images.

11. Click Apply.

NOTE: If you want a filter to apply only to a specific layer or layers of a channel, consider
using the adjustment filters in the Layers palette. For more information on adjustment filters
and how these work on individual layers, see Layer Types and Examples on page 248.

EXPERIMENT: The best way to get a feel for what the individual filters do is to play around
with the options with the filter preview on. Take a few minutes to review details of the
various Available Filters. Try applying some of them to a channel. You don't actually have to
save the filtered effect - turn the Preview option on, see how it looks, and then Cancel to
reject the changes.
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Select and Apply Object-based Filters
1. Start Mari and open your project.

2. Select the filter you want from the Objects > Generate menu (see the table of Available Filters on
page 390).

The dialog box displays for your selected filter.

Each filter has a different dialog box, with applicable options.

3. Once you're happy with the filter settings, click Ok.

The filter is applied to the entire object, not just specific patches.

TIP: For more information about the individual filter settings, refer to the Mari Reference
Guide.

Available Filters
We mentioned previously that an Invert checkbox and a Mask Curve editor displays in certain
situations. These options are universal to all filter operations that use a channel or an image from the
Image Manager as a mask.

The Invert checkbox decides whether Mari inverts the input from the mask. If this is selected, the
mask data is black on white rather than white on black.

The Mask Curve editor sets how the channel masking works. The x axis is the color of the source
pixel (black to the left and white to the right). The y axis is how paintable the target pixel is. By default,
the curve runs from the bottom left up to the top right. This means that black pixels are totally
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masked, white pixels are totally paintable, and there's a constant curve between the two. Use this if
you want to change what pixel values are masked.

The following table describes and shows examples of each of the filters that come with Mari, applied
to the following image:

Filters Menu

Filter Description Options Example

Invert Inverts the colors in
the selection. Replaces
colors with their
“opposite” in the color
chart. For example,
replaces a color with a
float value of 0.3 with
a color with float value
0.7.

You can set whether to invert the
Alpha channel as well as the
colors.

Luminosity Outputs just the
luminosity value of
each pixel in the
selection. That is, it
outputs a grayscale
image based on the
brightness of each of
the pixels in the
original image.

None.
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Filter Description Options Example

Blur Applies a standard
blur to the selection.

You can select the blur radius -
the number of pixels Mari uses
when calculating the blur value
for each pixel. The higher the
radius, the more blurred the
results.

If you use a larger blur radius,
you may get slight lines on the
boundaries between patches.
This is an artifact of the way that
Mari handles the edges of
patches.

Soften Blur Applies a subtle
softening blur.

This is a quick,
predefined blur filter.
If you need more
control over the
degree or type of
blurring, use either
the standard Blur or
Gaussian Blur filters.

None.
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Filter Description Options Example

Gaussian
Blur

Applies a Gaussian
blur. Compared to the
standard Blur filter,
this gives you much
finer control over the
degree of blurring,
and the option of
using much higher
blur values.

You can set both the Radius and
the Amount. The higher the
radius, the more blurred the
results. Amount defines how
much to mix the blurred result
with the original.

If you use a larger blur radius,
you may get slight lines on the
boundaries between patches.
This is an artifact of the way that
Mari handles the edges of
patches.

Gamma Changes the gamma
levels in the selection.

Do Inverse reverses the gamma
conversion. That is, a higher
setting for Gamma results in a
more washed-out looking image.

Selecting Use default gamma
disables the other controls and
uses your default setting for
gamma (as set in the Painting
tab of the Mari Preferences
dialog box, accessible from the
Edit menu). Otherwise, select a
particular gamma level.

sRGB To
Linear

Applies an sRGB to
linear colorspace
conversion.

Checking Invert applies a linear
to sRGB colorspace conversion.
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Filter Description Options Example

Hue Changes the hue,
saturation, and value
of the colors on the
model.

To change the hue of the colors,
set the value for Hue. This
moves the colors around the
color wheel. The rotation value is
the degree around the color
wheel that each color shifts,
between 0 and 360 (which both
correspond to the original
colors).

The options to change the
Saturation are:

• Saturation - how large the
saturation is. Select a multiplier
from 0 to 2, where 1.00 is the
original saturation value.

• Offset - an offset value to add
to the initial saturation value,
before applying the scale.

You can also edit the Saturation
curve. This controls how the
filter translates current
saturation values to new values.
For each input value along the
bottom of the graph, the output
value is set from the position of
the line above that point. Edit the
curve by:

• pulling the anchor points

• clicking between anchor points
to add a new point

• right-clicking to select from a
set of preset values.

You can edit the Scale, Offset
and Value curve for the value of
the colors in the same way.
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Filter Description Options Example

Brightness Changes the
brightness of the paint
on the model, either
overall or for specific
channels. You can also
change the contrast at
the same time.

You can either change the
brightness of all color channels
at once, or one-by-one.

Changing the main Brightness
control changes (overwrites) any
changes you make to brightness
values for individual color
channels.

Contrast Changes the contrast
of the paint.

You can select the amount of
contrast using the slider.

Clamp Clamps color values to
lie within the specified
upper and lower
values.

You can set the Upper Value
and Lower Value by adjusting
the sliders or entering values in
the entry boxes.

Select the individual Color
Component to clamp in the
dropdown menu.
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Filter Description Options Example

Levels Changes the color
levels in the paint. You
can change the white,
midtone and black
points for each color
channel or all
together.

As you change the settings, the
display at the top of the dialog
box updates to show the current
white point, midtone, and black
point.

You can set the:

• Color Component - whether
this is affecting the overall
Value of the color, or the
specific color channel (Red,
Green, or Blue).

• White Point - the upper limit
of displayed color intensity.
Areas with a value higher than
this are mapped to 1 (white).

• Midtone - the middle point
between white and black. Mari
remaps the values so that this
is the middle of the range
between the white point and
black point. Moving this pushes
the values towards that end of
the spectrum.

• Black Point - the lower limit of
displayed color intensity. Areas
with a value lower than this are
mapped to 0 (black).

• White Output Level - how
strongly to output the white in
the filtered image. Higher
values show the entire white
output, lower values show
decreasing amounts.

• Black Output Level - how
strongly to output the black in
the filtered image. Higher
values show the entire black
output, lower values show
decreasing amounts.

FILTERING IMAGES AND PAINT | AVAILABLE FILTERS



USER GUIDE 397

Filter Description Options Example

Color
Curves

Changes the color
curve for each color
channel (RGB) in the
painting.

You can also edit each color
curve, controlling how each color
channel appears on screen. This
controls how the filter translates
current color values to new
values. For each input value
along the bottom of the graph,
the output value is set from the
position of the line above that
point. Edit the curve by:

• pulling the anchor points

• clicking between anchor points
to add a new anchor point

• right-clicking to select from a
set of preset values.

Color
Switches

Turns individual color
channels on or off.

Use the checkboxes to select
which color channels display.
When Mari applies the filter, it
removes any unchecked color
channels from the painting.

Tone
Mapping

Varies the “exposure”
of the painting.

You can set the:

• White Point - the upper limit
of displayed color intensity; any
colors of greater intensity map
to white.

• Exposure - lower exposures
give darker images; higher
exposures give lighter ones.
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Filter Description Options Example

Copy
Channel

Copies the value from
one RGB color
channel to the other
two. The result is a
grayscale image with
the intensity values
from the selected
channel.

Select the source channel from
the list. When you apply the
filter, Mari copies the selected
channel over the other two
channels.

Premultiply
Alpha

Either pre- or post-
multiplies the alpha in
the selected image. If
you are painting using
an image without
premultiplied alpha
onto one with it, use
this filter to perform
the premultiplication,
so the images match
and you avoid lines
around the outside of
the patch.
(Postmultiply works
the same, but in
reverse (removes
premultiplication to
match images that do
not have premultiplied
alpha).

If the Postmultiply box is
checked, this acts in reverse (that
is, removes premultiplied alpha).
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Filter Description Options Example

Edge Detect Finds “edges”
(transitions between
colors) in the image
and heightens them.

None.

Emboss Applies an “emboss”
effect, so that textures
look “raised” on the
surface.

None.

Sharpen Removes 'fuzziness'
and clarifies detail in
the image.

You can set the amount of
sharpening. Higher values mean
more sharpening, while a value
of 0.00 is the picture without the
filter applied.
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Filter Description Options Example

High Pass Removes low
frequency information
from the image while
maintaining higher
frequency detail.

This can be useful for
quickly creating
specular maps where
only the higher
frequency image
highlights are
maintained.

You can set the kernel size (the
amount of filtering) by adjusting
the Radius.

If you use a large radius, you
may get slight lines on the
boundaries between patches.
This is an artifact of the way that
Mari handles patch edges.

This filter is not supported with
Ptex channels.

Color
Correction

Applies a colorspace
correction to the
current channel or
painting.

You have the option to use Mari’s
default Configuration File or a
custom one.

Set the colorspace of the current
channel or painting in the Input
Colorspace dropdown.

Set the colorspace correction to
apply to the current channel or
painting in the Output
Colorspace dropdown.
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Filter Description Options Example

Add Noise Applies noise to the
current channel or
painting.

Use the Amount slider to adjust
how much noise is applied and
select the component you want
to affect from the Color
Component dropdown.

For additive grayscale noise, that
modifies the intensity while
retaining the original color,
check the Grayscale checkbox.

You can regenerate the noise
using different random samples
by dragging on the Seed slider.

Adjust the size of the noise
applied by dragging on the Size
slider.

Objects Menu

Filter Description Options Example

Gaussian
Blur

Applies a Gaussian
blur. Compared to the
Filters menu
Gaussian Blur, this
allows you to apply a
blur effect over whole
objects in 3D space.

Set the Geometry Version so it
knows what object to which the
blur should be applied. For
animated objects, Frame
specifies on which frame the
blur should be applied to the
object.
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Filter Description Options Example

Displacement Allows you to generate
a displacement map,
using a high polygon
source model and a
low polygon
destination model to
calculate the
displacement.

Select the source Object,
Version, Size, and the Frame (if
animated) from the options
provided for the high polygon
model, and specify what
destination version and frame to
which the displacement should
correlate on the low polygon
model.

Adjust the sampling options,
such as Interpolation and
Sample Count to specify how
the displacement map is
generated.

Height Allows you to generate
a height map, using a
high polygon source
model and a low
polygon destination
model to calculate the
height.

Select the source Object,
Version, Size, and the Frame (if
animated) from the options
provided for the high polygon
model, and specify what
destination version and frame to
which the height should
correlate on the low polygon
model.

Adjust the sampling options,
such as Interpolation and
Sample Count to specify how
the height map is generated.
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Projectors
In Mari, projectors store the specific camera details of a particular view - the rotation, zoom, and
orientation of the view, plus the current paintable area, the painting mode, and mask settings. Think
of this as being like a bookmark for the exact view you currently have in Mari.

You can use a projector to take “snapshots” of your paint buffer, work on them externally, and then
project the changes back onto your model. For example, you can use projectors to easily flip back
and forth between Mari and Photoshop®, editing a texture in Photoshop®, then projecting it back
onto your model and checking it in Mari.

Once you have created a projector, you can use it to project and unproject on and off the image:

• Unproject takes everything visible from the paint buffer and saves it as a file.

• Project reads a file and projects it back onto the model.

Unprojecting takes the surface currently visible in Mari and exports it to a file. This includes
everything on the surface, just as it appears onscreen - it's like taking a snapshot of the model as you
can see it right now. So a particular unprojected file could include parts of several meshes. Once you
have unprojected to a file, you can edit the file in your paint editor of choice.

When you're happy with the file, you can then flip back to Mari and project it back onto the view. By
restoring the original projector, you can be sure that you're looking at the exact same view as the
snapshot was originally taken from. When you select the projector and click Import (to the buffer) or
Project (import and bake), Mari projects the file onto the model in the correct place.

So, once you've set up a particular projector, you can quickly flip between Mari and another editor.
You only need to set the target and source files for unproject/project once, and then it's just a click to
move back and forth between Mari and your external editor.

To make it easier when you're working on projects with multiple channels, there is also a batch mode
for unproject. This lets you unproject multiple channels at once.

And to make it even easier to quickly project and unproject, there are Quick modes for both. These
project and unproject from the current view, without you having to create a specific projector.

There is also support for unprojecting to a layered .psd file. As with the standard project and
unproject features, you can quickly unproject to a layered .psd file without having to create a
projector.
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In addition, you can also project on to models using .fbx files created by 3rd party software such as
Maya. Importing the model, cameras, and textures enables you to quickly create textured models
using Mari projectors.

TIP: If you only require a single camera view point, use the Camera > Load Camera option
from the Mari menubar.

Projectors also allow you to export a turntable view of your model. The turntable takes the model as
you can see it through the current shader, and creates a series of images showing the model rotating
through an axis. You can include custom text or thumbnails of reference images in the turntable. You
can create:

• Render turntables - this exports a single channel, and lets you pick the shader and lighting to use.

• Diagnostic turntables - these export a set of channels, using the default shader and flat lighting, to
help you check the current look.

The Projectors palette shows the projectors currently defined for the project.

Set the View
1. Start Mari and open your project.

2. Adjust the view how you'd like it. The projector takes snapshots of the contents of the paint
buffer, exactly as they appear onscreen, so:

• switch to your preferred camera view (UV, orthographic, or perspective)

• rotate, spin, and zoom the model so you can see the area you need to work on

• resize the paint buffer (if necessary) to focus in on the specific area you want to work on

• set the paint blending mode you want

• turn on any masking (edge masking, channel masking, etc.) that you need.
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Create the Projector
1. In the Projectors palette, either:

• right-click and select Create Projector from the dropdown menu, or

• click the button at the bottom of the projectors list.

The new projector displays.

2. To rename the projector, double-click on its name in the list and enter the new name.

3. Click to select your new projector.

The bottom half of the Projectors palette displays details of the projector.
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4. The settings in the Unprojection section control how the projector takes screen snapshots.

• If Clamp is checked, Mari restricts the range of the image to values between 0 and 1.

• The Shader Used defaults to Current Paint Target, but you can change this to determine which
shader you want to unproject.

• The Lighting Mode defaults to Flat, but you can change this.

• You can set the Color Depth and the image Size - these default to the settings of your paint
buffer when you create the projector.

5. Set the Output File Path, to specify where the projector saves the image. You can either:

• type this directly, or

• click the button.

The Save File dialog box opens, allowing you to set the location for the saved files.

6. Navigate to where you want to save the projector, type in the filename, and click Save.

TIP: If you want to take shots of multiple channels using this projector, include $CHANNEL in
the filename. When Mari saves the files the projector produces, it replaces this variable with
the channel name for each.

Mari sets the file type (from the listed possibilities) by the file extension you include.

7. Set the Input File Path, to specify where the projector looks for updated images to load. As with

the output file path, you can type this directly or click to select from the Pick Path dialog box.

You can also include $CHANNEL in the input file path.
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TIP: Decide whether you want to use the same file for output and input, or use separate
files. This depends on how you prefer to work. For example, you may prefer to export to .tif,
edit the file and save the changes as a .png for re-import. Or you may prefer to use the same
.tif file for both output and input.

TIP: Don't change the settings for Transformation or Perspective. These show the details
of the paint buffer and perspective camera settings when the projector was created
(including, for perspective cameras, field of vision and clipping planes).

If absolutely necessary, you can edit these, but it's usually easier to just set the main view to
your desired settings and create a new camera.

8. To switch to the view from another projector, either:

• right-click on the projector in the Projectors palette and select Make Projector Current, or

• double-click on the projector in the Projectors palette.

The view switches back to how it was when you created the projector, including any masking you
had set and the Painting Mode that was in use. The name of the projector in use appears on the
current tab in the canvas.

TIP: You can also adjust projection mask properties in the Projectors palette. Note that if
you adjust these properties, you need to click the Update Only Masks From Projector
button to see the effect of your changes in the canvas. When you do, the equivalent
projection mask properties in the Projection palette are also updated.

Similarly, you can adjust other global properties such as the Painting Mode or Projection
behavior in the Projectors palette. If you do, click Update Global Settings From Projector
to update the equivalent global properties (including masks) in the Projection palette.

TIP: Masks on projectors are hardwired to use the red color component. If you want to use
another color component for your mask value, the Shuffle adjustment layer allows you to
change the RGBA components so that any can be replaced by another. Additionally, the
Luminosity adjustment layer allows you to convert an RGB input to a grayscale output.

Unproject from Your Projector
1. To save a copy of the model as it appears onscreen, either:

• right-click the projector in the Projectors palette, and select Unproject, or

• click the Unproject button in the projector details, or
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• click the button to the right of the projector.

The snapshot saves to the filename specified as the Output File Path. If you have not specified an
output file path, the Pick Path dialog displays, so you can set where the file should go.

2. Mari projects your image in the background. You cannot edit the files until the projection is

complete. While the projection is still taking place, Mari shows a running man icon at the
bottom right of the main window. Click this icon to see a progress box.

Edit the File(s) Externally
In your preferred editor, open the file and edit it as required.

If you edit the whole snapshot and then project it all back onto your model in Mari, you may get some
artifacts.
Typically, you may see a black line at the “edges” where the projected image wraps around the
surface.

The original view in
Mari, as the projector

grabs it.

We edit the whole
snapshot, even

though we only want
to change one small

section.

Projected back onto
the model, and

rotated to show the
blurring where the
projected image

“wraps” around the
surface at the nose

and cheek.

To avoid this:

• Set your projectors up so they face straight onto the area you're working on.

• When editing the projected image, work on a different layer, only using the areas on the snapshot
that you want to change.
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This time, we've
created a new layer in
the snapshot. We're
only making changes
on the new layer.

Now we're happy with
our changes, we
remove the

background layer and
save the file.

Now when we project
it back onto the
model, Mari only
adds the “changes”
layer. There are no
artifacts, and it all

looks good.

Project the File(s) Back onto theModel
Back in Mari, click either:

• Import - to load the image from the projector file and put it into the paint buffer, or

• Project - to load the image and bake it onto the surface.

Mari loads the updated image from the location set in the Input File Path and projects it back onto
the model. If you have not specified an input file path, the Pick Path dialog displays so you can select
the file.

EXPERIMENT: Using a sample project, try creating a projector, unprojecting, editing the
unprojected file in an external program in some obvious way, and then projecting it back
onto your model.

Use the Quick Project Functions
The Quick Project functions provide a fast and simple way to project and unproject from the current
view without having to create a projector first.

TIP: When using quick unproject and quick project, be careful not to change your view! If
you need to change your view, create a projector as normal, so you can go back to the view
and project correctly.
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1. To unproject from the current view (that is, the current camera settings and visible shader), from
the Camera menu, select Quick Unproject.

The Quick Projection dialog box displays, allowing you to set a resolution and file path for the
unprojected image.

2. Set the details:

• Path - sets the filename and type. You set the image type by typing the image extension (for
example, .tif, .exr, .psd, .png, .tga, and so on).

• Lighting - sets whether the lighting information is output along with the paint when you
unproject. If it is, whether it’s stored as a Separate File or - in the case of .psd files - an
individual Layer.

If you have already set the quick projection details, Mari just unprojects and updates the file on
disk.

3. You can now edit the unprojected image as normal (see Edit the File(s) Externally).

NOTE: Due to the nature of .psd files, the lighting displayed in your external image editor is
an approximation of what you see in Mari.

TIP: When unprojecting a separate lighting layer it appears brighter, but when this is
multiplied over an unlit pass in an external application, such as Nuke, the lighting appears as
expected.

When projecting, you can either:

• project the image only onto the front patches visible in the current view, or

• project through all patches in the current view.

1. To project onto the front of the patches, from the Camera menu, select Quick Project Front.

To project... From the Camera menu, select...

onto the front of the patches Quick Project Front

through all the patches Quick Project Through
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Mari loads the updated image from the location set in the Quick Projection dialog box and
projects it back onto the model.

2. If you want to change the quick projection settings, you can open the Quick Projection dialog
box - from the Camera menu, select Quick Projection Settings.

Project onto a Model Using .fbx Files
To project onto a model using an .fbx file, you need the following files created using a 3rd party
application:

• a 3D model (.obj format)

• a camera file (.fbx format)

• texture files (.jpg format for example)

TIP: To make things easier later on, you should use the same naming convention for the
camera and texture files when you create them.

1. Start Mari and import your model file.

2. In the Projectors palette either:

• right-click and select Load Projector, or

• click .

The Load Projector dialog box displays.

3. Locate the .fbx file associated with your model and click Open.

The Select Entity dialog box displays.

4. Click Select All to highlight all the cameras, then click Import.

Mari imports the camera data from the .fbx file and creates a corresponding number of
projectors in the Projectors palette.
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You can click on the individual projectors in the Projectors palette to view the camera angles that
you imported.

5. Select a projector in the Projectors palette and either:

• enter the location of the associated texture file in the Path > Input File Path field, or

• click to browse for the file location.

6. Select the required file and click Open.

You can set the other Projector attributes in the same way as described in Create the Projector on
page 405.
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7. In Projectors > Action, select either:

• Import - to load the texture from the projector into the paint buffer, or

• Project - to load the texture and bake it onto the surface.

Mari projects the texture onto the model as specified.

Once the texture is loaded, you should be able to tell immediately if you’ve loaded the wrong
texture - simply change the file location in Projectors > Input File Path if this is the case.

8. Repeat steps 5 and 6 for all the imported projectors to complete the process.

9. Once you’re happy with the results, you can export your work as described in Export Textures
from Channels, Generate a Turntable from a Projector, or Save, Load, and Delete Projectors in the
same way as regular projectors.

NOTE: It’s worth mentioning that projection using .fbx files is not fool-proof and some extra
texturing inevitably is required. You can reduce the extra work needed by using more
camera angles when creating the .fbx file.

EXPERIMENT: Try:

• Loading some textures through the wrong projector. Can you see that the image is
incorrect?

• Loading textures in a different order. Notice how the textures overlay each other?

Generate a Turntable from a Projector
Mari lets you generate two kinds of turntables:

• Render turntables - this exports the current channel, using a selected shader.

• Diagnostic turntables - these export a set of channels, with flat lighting for each one, using Mari's
default shader.

TIP: Turntables always rotate around the center of your current view. That is, the axis for a
turntable is a line straight up the middle of the screen in the current view. This is in the
center of the visible portion of the model.

You can zoom in on a particular part of a model and create a turntable that focuses on just
that part of the model.
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Generating a Render Turntable
1. Right-click on the projector and select Render Turntable from the dropdown menu.

The Render Turntable dialog box displays.

2. Set the basic image details:

• size of the generated images

• the amount to Antialias the images.

• background for the images - either gray, transparent or the current background in Mari.

• the number of Frames to generate - that is, how many images should be in the sequence.

3. If you are using animated models or textures and want to render the turntable with the
animation, check Play Animation. This disables the Frames control above because the frame
range is taken from the Play Controls palette.

4. If you are combining multiple turntables, select an Offset. This lets you chain together sequences,
by offsetting the image numbers.

For example, with an offset of 0, the first image is MariTurntable_1.jpg. With an offset of 360, the
first image is MariTurntable_361.jpg. You can use this to generate one sequence of frames for one
axis, then move your model around and make another set of frames for another axis.
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5. By default, the turntable images use the Example LUT (and any other visual filters you have
applied to the view). If you want to create the images without a LUT, set the Filters to Off.

6. Pick the Lighting for the turntable images. You can pick Flat, Basic, or Full lighting.

7. You can also include reference images and text in the turntable images. If you want to include any
other information in the turntable files, enter the details:

• You can set a Comment (and change the Text Size) - Mari includes this at the bottom of the
turntable.

• You can also select up to two Reference images - Mari includes these to the left of your model.
Specify the colorspace for each image (sRGB or Linear).

8. Set the Path where Mari should create the images, and set the Template for the filenames.

This must include the $FRAME variable, so Mari assigns the frame numbers correctly to the files.
Mari can export turntables as either .tif, .png, .jpg, or .tga files - change the file extension in the
Template to set the file type.

9. Finally, you can enter any shell Command that you want Mari to run on the files once it finishes
creating them.

10. If you want to check the placement of your reference images and comment text, click Preview.
This generates the first image of the turntable so you can check the appearance.

11. Click OK.

Mari generates a series of images for the turntable.

Generating a Diagnostic Turntable
1. Right-click on the projector and select Diagnostic Turntable from the dropdown menu.

The Diagnostic Turntable dialog box displays.
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2. In the Channel section of the dialog box, click to uncheck any channels you do not want to
generate turntables for.

3. If you are using animated models or textures and want to render the turntable with the
animation, check Play Animation. This disables the Frames control above because the frame
range is taken from the Play Controls palette.

4. Set the other details for the turntable(s) to generate. The properties for diagnostic turntables are
the same as for Generating a Render Turntable, except:

• You cannot set an offset.

• You cannot set the shader or lighting to use – all images use the default shader and flat lighting.

In addition, you should ensure that the Template includes:

• The $FRAME (%FRAME on Windows) variable, so Mari assigns the frame numbers correctly to the
files.

• The $CHANNEL (%CHANNEL on Windows) variable, so Mari includes the channel in the filename.
If this is not present, and you export multiple channels, the later channels overwrite the earlier
ones.

5. Click OK.

Mari generates a series of images for the turntable, once per channel. Generating turntables for a
large number of channels takes a while. Mari shows the progress in the status bar at the bottom
right:
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Save, Load, and Delete Projectors
1. To save a projector to disk, in the Projectors palette, either:

• right-click on an existing projector and select Save Projector from the dropdown menu, or

• click on the button.

Mari displays a Save dialog box, for you to select a location on disk and set the projector's name.

2. To save all the projectors in the project as a single file, right-click in the Projectors palette and
select Save All Projectors.

Mari displays a Save dialog box, for you to select a location on disk and set the file name.

3. To load a saved projector file, in the Projectors palette, either:

• right-click and select Load Projector from the dropdown menu, or

• click on the button.

Mari displays an Open dialog box, for you to find the projector file. This can be for a single or
multiple projectors.

4. To delete a projector, either:

• in the Projectors palette, right-click on the projector and select Remove Projector from the
dropdown menu, or

• click on the button.

Mari removes the selected projector.
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Previewing and Rendering
The Modo Render script provides the ability to retrieve renders of your model from Modo, and to
display them in the Modo Render palette. It also serves as an example for how you can integrate
renderers inside Mari for a look development workflow. The palette enables you to link your Mari
channels to the Modo Effects, and to even bake data from Modo into your channels.

The Modo Render script and the related features that rely on Modo to function do not require you to
previously have Modo installed. A bundled command line version of Modo ships with Mari for the
purposes of these features and is the default version of Modo selected, unless you specify otherwise.

If you do have a copy of Modo already installed, you can tell Mari where to find this copy and specify
whether you want it to use this version or the shipped version of Modo.

WARNING: Both the previewing and rendering functions allowed with the Modo Render
script do not work with Ptex projects. Ensure that you are using Alembic, FBX, or OBJ
geometry with UV coordinates before attempting to use these features.

Rendering with Modo
The Modo render script provides you with options so that you can link Mari channels to specific Modo
Effects, preview the results, and/or render your textures by sending them to Modo in a flattened state
or as a whole.

The preview function sends geometry, textures, and other data to Modo, and tells Modo to preview-
render your Mari scene with channels linked to Modo shader effects. If you've specified a file location,
Modo saves an .lxo file representing the scene. There are two modes for previewing your model:
previewing in a Flattened or Not Flattened state. Previewing, either in a flattened state or as is,
produces a full preview window in the palette, which shows you what the texture looks like in Modo.
At the same time, Modo is opened and the texture is sent to the application.

The render function sends geometry, textures, and other data to Modo, and tells Modo to render
your Mari scene with channels linked to Modo shader effects. If you've specified file locations, Modo
saves the rendered image in a .png or .exr file, and the scene in an .lxo file. There are also two modes
for rendering your model: rendering in a Flattened or Not Flattened state. Rendering, either in a
flattened state or as is, does the same thing as the preview functions do, but also allows you to save
the render to a specific location or save the scene as an .lxo file to a specific location.
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To send your textures and other data to Modo for preview in the Modo Render palette:

1. Open the Modo Render palette and select the Render tab, if it's not already selected.

2. Choose a preset from the Render Preset dropdown. The preset allows you to set the render
settings you wish to use for previewing and rendering.

By default, the Render Preset dropdown is set to Basic, which allows Mari to tell Modo to render
using Modo's default settings. However, you can set this to None, if you prefer not to use a
preset.

3. Under the Channel Assignment section, click the Add button to specify the Mari channels and
Modo effects to link.

The Assign Channel dialog appears.
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TIP: You can only link one channel and one effect at a time, however, you can add as many
channel assignments as you want by repeating step 3.

4. Choose the Mari Channel and Modo Effect you want to link to one another and click OK.

The channel assignment is shown in the table and, if you have multiple channel assignments, you
can scroll though the table to see which assignments are in the list.

5. Specify Flattened or Not Flattened for your preview settings and then click Preview.

If your project has a lot of UDIMs or high-resolution textures, flattening can take longer than
previewing as is. However, previewing Flattened saves time when sending lots of commands to
Modo, so it may be faster for lighter projects.

Either option produces a full preview window in the Modo Render palette and sends the texture
to Modo. Previewing is nearly real-time, so camera movements made on the canvas also occur in
the preview window automatically. If you have clicked Preview already and proceed to make
changes to your channels or channel assignments, you need to click Preview again in order for
Mari to send new channel data and assignments to Modo.

The camera settings and the field of view for the preview are taken from Mari.

6. Click the pause button if you need to stop camera updates being sent to Modo.

When you click this, any camera changes you make in Mari, especially those stemming from
navigation in the canvas, are not automatically updated in the Preview pane. These updates won't
be taken into account and sent for preview until you toggle the pause button again.

NOTE: When a preview is active (not paused) only camera updates are continually sent to
Modo. If you are navigating around the model and continuing to paint, the paint isn't
updated in the preview. To see these changes, you need to Preview the scene again.

Previewing doesn't save out the final rendered image, though it does still send textures and data to
Modo. If you have finished with your channel assignments, and you are ready to render your final
scene:

1. Follow steps 1-4 in the previewing steplist above.

2. Specify the Render Dimensions in pixels.

3. Specify whether you want to render Flattened or Not Flattened, depending on which option is
better for your project. If your project has a lot of UDIMs or high-resolution textures, flattening
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can take longer than rendering as is. However, flattening the channels saves time when sending
lots of commands to Modo, so it may be faster for lighter projects.

4. Specify the location to which the final rendered images is saved on render in the Save Render to
field or browse to it with the file browser button. This is only the rendered image file. Modo saves
the rendered image in a .png or .exr file format.

5. Specify the location to which the Modo scene is saved as an .lxo file on render in the Save LXO to
field or browse to it with the file browser button. This allows you to open the .lxo file in Modo at a
later point after the render has been completed.

6. Once you've set your render settings, click Render.

Both Flattened or Not Flattened options produce a full preview window in the Modo Render
palette and sends the textures and other data to Modo. It also saves the rendered image file and
the Modo scene in the locations specified in Save render to and Save LXO to.

Baking fromModo
Where rendering is producing a final image of the scene you've been working on, baking allows you
to bake data from Modo into your Mari channels. For example, you can bake a specific component,
such as ambient occlusion produced in Modo, into a channel in Mari and continue working with it as
a baked texture.

Before you bake the Modo data, use the preview functionality in the Bake tab of the Modo Render
palette to check your work and ensure you are happy with the results before baking the data.

To bake a texture in Modo and bring it into Mari:

1. Open the Modo Render palette and select the Bake tab, if it's not already selected.
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2. Choose a preset for bake from the options in the Bake Preset dropdown. There are presets
shipped with Mari listed in the dropdown. You can also create your own presets in Modo.

The preset parameters are listed in the table, and you can edit them directly within the palette.
When you edit a parameter, this change is sent back to Modo and is reflected in the preview
shown in the palette as well.

3. Set the Bake Resolution for the texture quality.

4. Set the Bake Depth for the color depth of the channel into which Modo is baking.

5. Click Bake once you are happy with all the parameter settings and have previewed the texture in
the Bake tab.

6. If you have previewed the scene in the Render tab, you can pause the updates in the Bake tab as
well by clicking the pause button. For more information on the pause button, refer to the
Rendering with Modo section.
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Modo Render Settings
In order to perform the previewing, rendering, and baking functionality that relies on Modo, you need
to specify a few settings. You can do this directly within the Modo Render palette, instead of needing
to check the Preference dialog.

To adjust your settings:

1. Open the Modo Render palette and select the Settings tab, if it's not already selected.

2. Set Use to tell Mari whether to use the Default Modo that ships with Mari (the command line
version) or a Locally Installed Modo to which you already have access.

NOTE: If using a locally installed version, Modo 901 is required for rendering and previewing
to work correctly.

3. If you chose to use a locally installed version of Modo, specify where Mari can find the application
by entering the file path into the Modo Bin field.

4. Enter the Command Port, on which Mari sends commands to Modo.

5. Enter the Preview Port, on which Mari receives previews from Modo.

TIP: By default, Mari looks for preset files in Mari3.1v2/Bundle/Media/. You can change the
path where presets are searched by using the MARI_MODO_BAKE_PRESETS and MARI_
MODO_RENDER_PRESETS environment variables. For more information on environment
variables, refer to the Extending Mari section.
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Painting Animated Objects
As well as static model files, Mari can import models that include animation data. This allows you to
create a project based on an animated object, so you can check how your textures work as the model
moves.

This support for animation lets you:

• Paint models in context - you can check how the textures look through the full range of motion.

• Paint specific textures tied into frame ranges. Imagine that in frame 37 of a sequence, a bullet
ricochets off your giant robot. Mari lets you open the model, move to frame 37, and edit the
relevant texture layers to show the chipped paint and the displacement from the impact. You can
adjust and export texture layers frame by frame.

Keyframes
Keyframes define when the texture changes within a sequence. When you create a keyframe, Mari
remembers what textures you've got on your model. Then:

• Any textures you add earlier in the sequence disappear when Mari reaches the keyframe.

• Any textures you add after the keyframe appear once Mari reaches the keyframe.

• When you export your textures, you can export a separate version of each patch for each keyframe.

Keyframes divide the sequence into parts. You can paint in any frame within a part, and that paint
appears from the previous keyframe until the next keyframe.

The first frame of animation is always treated as a keyframe.

Example

For example, we're painting an object with a 12-frame animation. We have some existing paint. Here,
the existing paint shows throughout the entire animation sequence:
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1 - KEYFRAME 2 3 4

5 6 7 8

9 10 11 12

Now we set a keyframe at frame 4, and paint on frame 3 and frame 6. In this case:

• The paint on frame 3 appears from frames 1-3.

• The paint on frame 6 appears from frames 4-12.

1 - KEYFRAME 2 3 4 - KEYFRAME
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5 6 7 8

9 10 11 12

If we add another keyframe at frame 9 and paint on frame 10:

• The existing paint between frames 4 and 12 continues to display in that frame range, as it was in
place before we added the new keyframe.

• The paint on frame 10 appears from frame 9 to 12:

1 - KEYFRAME 2 3 4 - KEYFRAME

5 6 7 8
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9 - KEYFRAME 10 11 12

When we export the layer, each patch has three versions - one per keyframe.

1 - KEYFRAME 4 - KEYFRAME 9 - KEYFRAME

Loading Animated Objects
To load your animated object:

1. Select an animated .obj file sequence, and either:

• create a new project with the file, or

• add the object to an existing project.

2. On the Mesh Options tab, a new section displays, letting you set which frames to import.

In addition to the three mesh options offered when opening a new project, you can select:

• Start Frame - the first frame of the range that you want to import.

• End Frame - the last frame of the range that you want to import.

• Single Frame - set the controls so as to only import the first frame in the animation.

• All Frames - set the controls to import all the frames within the animation.

3. Finish creating the project or adding the new object as normal.
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Playing Animation
To play back animation:

1. If it's not displayed, open the Play Controls palette.

2. Set the desired frame range in the boxes at the top of the palette. This lets you play only a sub-set
of the animation.

3. To skip to a particular frame, type the frame in the frame box.

4. Set the playback mode in the dropdown.

This can be:

• Loop - keep looping through the animation (start to finish).

• Bounce - keep looping back and forth through the animation (start to finish, then backwards
back to the start).

• Stop - play the animation once and stop.

5. Use the play controls to play through the animation:

Button Effect Shortcut key

Move back one frame. Ctrl/Cmd+Left

Move back to the first frame. Ctrl/Cmd+Down

No button Move to the last frame. Ctrl/Cmd+Up

Play forward. None.
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Button Effect Shortcut key

Stop playing. None.

Move forward one frame Ctrl/Cmd+Right

You can also pull the timeline control back and forth to move through frames:

Painting Animated Textures
Before you paint the animated textures, make sure you've painted all the non-animated elements of
your textures. Any paint you add after you've inserted a keyframe only appears in one part of the
animation (see the example above).

Once you've got your initial texture set, you can set keyframes.

Setting Keyframes

To set a keyframe:

1. Move to the frame that you want to set as your keyframe.

2. Click or press Ctrl/Cmd+K to set a keyframe.

The new keyframe displays as a square in the keyframe timeline.

3. You can remove keyframes by selecting the keyframe in the timeline and clicking .

Removing a keyframe also removes any paint for that keyframe. Be careful when removing
keyframes if you've done any painting!

Painting the Textures

To paint a texture within a section of animation:

1. Move to a frame somewhere within the section of animation you want to paint.
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It doesn't matter which frame within the section you move to - the paint displays until the next
keyframe.

2. Paint your textures as normal.

Bear in mind that:

• Any textures you paint within one section disappear when you reach the next keyframe.

• You can paint, then add another keyframe, to “build up” an animated texture (see the Example
in Painting Animated Objects for an explanation).

Exporting Animated Textures
When you export an animated texture, Mari exports a separate file for each patch, for each keyframe.
For example, a model with 20 patches painted as an animation with 3 keyframes gives 60 files when
you export it.

To export an animated texture:

1. Open the Export or Export Flattened dialog box, from the Channels or Layers menu.

2. Set the export details as described in the Exporting and Importing Textures section, except:

• Include the $FRAME keyword in your Template - Mari replaces this with the frame number of
the keyframe for the exported textures, padded out to five digits. For example, if you are
exporting a layer called color, with keyframes at 9 and 6, then using an export Template of
$FRAME_$LAYER.$UDIM.tif gives the following files for patch 0001: 00001_color.0001.tif, 00009_
color.0001.tif, and 00016_color.00001.tif.

• If you want to export only the textures for a particular frame range (which can include multiple
keyframes), enter the range in the Frame Range field at the bottom of the Export Layer dialog
box.

3. Click Export All Patches as usual to start the export.

Mari exports the files, creating a file for each patch/keyframe combination.
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Session Scripts
Session scripts are a light-weight archive of a project. All the data you choose to record is saved in the
.msf (Mari Session File) format, with the necessary files (models, images, projectors, and so on) to
rebuild your project.

The purpose of session scripts is to enable you to share your session (project) with other users and to
allow them to import the data into another session. An example of where this might be useful would
be where two artists are working on a single asset broken into separate models, such as a table and
chairs. If artist A is painting the chair models, and artist B is painting the table model, and artist A is
asked to handover their work in its current form to artist B, it might be faster and easier for artist B to
combine the sessions rather than work on two separate projects. By allowing artist A to export their
current session for artist B to import into their own session, both projects can be worked on
simultaneously.

Additional documentation is located under Python > Documentation.

Limitations to Session Scripts
While session scripts can be incredibly useful when working between multiple projects, there are
some limitations that you should be aware of before continuing.

• If you import a session that includes subdivided geometry, Mari does not retain the subdivision
information during the export/import process.

• If you import a session with transformed geometry (rotated, scaled, panned), Mari only imports the
original geometry, not any transformations that were also applied to it.

• If you import a session that has had any Node Graph organization done, the changes to the Node
graph are not maintained.

• If you import a session with colorspace information, Mari does not retain the colorspace
information during the export/import process and uses default values instead.

Exporting a Session
To export a session, you first need to have a project open. Then follow the steps below:

1. Navigate to File > Session > Export Session.

The Export Mari Data dialog appears.
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2. Select the objects, channels, patches, lights, projectors, and so on that you want to export by
checking the box next to the item in the Mari entity tree.

3. Choose whether or not the Object Files are copied to the export directory specified in the Path
field. If they aren't copied, no additional files are created, other than the project file, at the export
directory location.

TIP: Object files can be .obj, .fbx, or .abc files.

4. Choose whether or not to Export all textures (image data for layers) for the selected items, or to
only create a template. The template can be used to set up projects for artists to work from, so
channels, layers, shader, and so on have the desired settings from the start.

5. Specify the directory to which you want to export the session data in the Path field.

6. Specify the name to give the exported .msf file and project in the File Name field.

7. Once you have set your export options, click OK.

A progress bar displays the status of the export. Once it reaches 100%, another dialog reminds
you not to close the project until all the background jobs have finished. These background jobs

can be seen by clicking on the running man icon in the lower-right hand corner, and comprise
the export of images for layers and the Image Manager.

Once the export is complete you can close the project and open a new one.
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WARNING: Attempting to export a session without geometry selected is only successful
when merging the session into another session with the same geometry. Otherwise, you
must select the geometry before proceeding.

Importing a Session
To import a session, you have two options for handling an exported session: you can either create a
new project from the session data or you can import it into an open project. To import it into an open
project, follow the steps below:

1. Navigate to File > Session > Import Session.

The Import Session dialog appears.

2. Specify the directory where Mari is looking for the .msf file in the Path field.

This is the location where the file was exported to in the Exporting a Session instructions, and the
file has the same name as the project that it was exported from.

3. Choose whether to import All Data from the .msf file, or only import the data Onto Selected
Object.

If you import all data, this imports data, including geometry, as separate objects into the current
project. If you import data onto the selected object, this imports the shader and channel
information in the .msf file onto the currently-selected object.

4. Once you have set your import options, click OK.

A progress bar displays the status of the import.

Once the import has finished, Mari displays the entities that were imported (objects, light, projectors,
and so on) and displays the data you imported.

NOTE: If you are importing a session that includes subdivided geometry, Mari does not
retain the subdivision information during the export/import process.

Importing Channels
To import a channel, you first need to have a project open. Then follow the steps below:
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1. Navigate to File > Session > Import Channels.

The Import Channels dialog appears.

2. Specify, or browse for, the .msf file.

Selecting an appropriate file populates the Geo Entity tree on the left-hand side of the dialog with
the data in the .msf file.

3. The tree on the right-hand side of the dialog is your current, open project. Drag and drop
channels from the tree on the left to any object in the tree on the right.

4. Once you have finished adding the channels you want to create, click Import.

Once the import process has finished, you can continue to add more channels at any time.

Importing Shaders
To import a shader, you first need to have a project open. Then follow the steps below:

1. Navigate to File > Session > Import Shaders.

The Import Shaders dialog appears.
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2. Specify, or browse for, the .msf file.

Selecting an appropriate file populates the Geo Entity tree on the left-hand side of the dialog with
the data in the .msf file.

3. The tree on the right-hand side of the dialog is your current, open project. Drag and drop shaders
from the tree on the left to any object in the tree on the right.

4. Once you have finished adding the shaders you want to create, click Import.

Once the import process has finished, you can continue to add more shaders at any time.
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Extending Mari
You can add your own custom attributes to objects in Mari, as well as edit configuration files.

In particular, you can specify sets of:

• keyboard shortcuts - Using a shortcut configuration file has the same effect as changing each
shortcut individually in the Manage Keyboard Shortcuts dialog box, but lets you change all of
them, as a single, consistent set. You can then also share a set of shortcuts with other users.

• channel presets - Using a channel preset configuration file, you can specify categories of preset
channels (for example, for different types of assets), to display in the Channel Presets dialog box
when you create channels for a project in bulk

• channel templates - Using a channel template configuration file, you can specify the filename
formats to use in the Channel Presets dialog box. These control the filenames that Mari looks for
when importing textures into new channels.

You can also configure Mari using environment variables.

About Custom Attributes
You can attach custom attributes to most objects in Mari (such as channels, models, projectors and
lights). Rather than information that Mari needs, this is information that can be useful for yourself or
other users of the project to know. For example, you can add the assigned owner of the model as a
custom attribute attached to the model.

You can choose to add custom attributes for the current session only or save them as part of the
project so that they persist when you quit and relaunch Mari.

About Custom Shortcuts
Three types of keyboard shortcuts are available in Mari:

• The default set of shortcuts - that come with the application, as listed under Help > Shortcuts.

• A custom set of shortcuts - defined in a shortcut configuration file. This is a text file, called
Shortcuts.conf, containing a list of one or more Mari actions and their shortcuts. Mari looks for
this file in the following sub-directory of your home directory:

• .config/TheFoundry (on Linux),
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• .mari\TheFoundry (on Windows), or

• .config/TheFoundry (on Mac).

NOTE: If there is no custom shortcut file, Mari uses the defaults. Configuration file shortcuts
override default shortcuts.

• GUI shortcut - defined within the GUI, in the Manage Keyboard Shortcuts dialog box, for specific
actions or project items. You do this by selecting Edit > Keyboard Shortcuts, or right clicking on a
project item (channels, patches, shaders, lights, projectors, and things in shelves), or sets of those
items, by selecting Assign Shortcut from the dropdown menu. GUI shortcuts override default and
configuration file shortcuts.

So Mari accepts the default keyboard shortcuts for an action... unless that action is also specified in a
shortcut configuration file, in which case Mari uses your custom shortcuts... unless you've overridden
any of them in the GUI with individual custom shortcuts.

TIP: If you are distributing a custom shortcuts file to multiple users, be aware that any
individual custom shortcuts they apply override your shortcuts file.

The Shortcuts.conf file does not have to list all possible Mari actions. You can set up a
shortcut for any Mari action, but you can only assign shortcuts to project items (channels,
patches, shaders, lights, projectors, and things in shelves), or sets of those items, from
within the Mari GUI (not from within a customization file).

About Custom Channel Presets
You can add channels in bulk to a Mari project, using the Channels > Channel Presets option. This
opens a dialog box, Channel Presets, where you can select to create a set of channels in a project
and optionally to also import existing textures. In the Channel Presets dialog box, you can select a
Category, which represents a preset bundle of channels. For example, if you select the “Vehicles”
category, you get a list of standard channels for painting a vehicle.

Mari comes with several default categories, stored in a channel preset file. If you want, you can
replace the defaults with your own customized channel preset categories. Mari custom channel
presets files are XML files with an .mtd extension. Mari looks for them by default in the following
sub-directory of your home directory:

• .config/TheFoundry (on Linux),

• .mari\TheFoundry (on Windows), or

• .config/TheFoundry (on Mac).
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You can select a different channel presets directory on the Paths tab of the Mari Preferences dialog
box.

TIP: If you use a customized channel preset file, Mari ignores its default channel presets.
Only the channels in your custom preset file are available.

About Custom Channel Templates
When you're adding channels in bulk through the Channel Presets dialog box, you can select to
import existing textures into the channels as Mari creates them. Mari looks for existing textures on
disk. If it finds these textures, you can import them as the channels are created. The channel template
controls the format of the filenames that Mari looks for. For example, one channel template is:

$PATH/$SHOT/color$SHOT_color.$UDIM.tif.

Mari comes with several default channel templates. If you want, you can add your own channel
template files. Channel template files are straight text files, with an .mtt extension. Mari looks for
them in the same directories as channel preset files.

About Environment Variables
Environment variables are named variables used to store a value, such as a specific file path. They are
used to dynamically configure Mari’s behavior when Mari is launched. For example, Mari uses the
information stored in them to define where to place certain files.

You can:

• Set environment variables that Mari recognizes.

• Create your own environment variables that Mari looks for when importing images.

• Use environment variables to override any entry in the Mari.conf or Mari.ini files. These files
contain all user settings that are not project specific.

Add Custom Attributes to Objects
1. Start Mari and open your project.

2. Open a palette where you want to add custom attributes (for example, the Channels, Objects, or
Projectors palette).
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3. Select the object you want to add custom attributes to and click the button. You may need to
scroll right in the palette to see this button.

The Add User Attribute dialog displays.

4. Set the following:

• Type - whether the attribute's value is an on/off setting (Boolean), a date (Date), a floating point
number (Float), an integer number (Integer), or a text string (String).

• Name - the name of the attribute. Unless you uncheck Visible below, this name appears under
User Attributes in the palette (in the below example, the name is MyAttribute). Note that the
name should only include alphanumeric characters and cannot include spaces.

• Description - an optional description of the attribute. This appears in a tooltip if you hover the
mouse over the attribute in the palette.

• Saved - if this is on, the attribute persists when you quit and relaunch Mari. If this is off, the
attribute is only added to the current session of Mari.

• Read Only - if this is on, users cannot modify the attribute's value. If this is off, the value is
shown in the palette where users can adjust it.

• Visible - if this is on, the attribute appears in the palette. If this is off, you cannot see the
attribute.

NOTE: The above settings cannot be edited later. If you want to change them, you need to
remove the attribute and create a new one.
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5. Click Add.

6. If necessary, edit the attribute's value in the palette.

Remove Custom Attributes from Objects
1. Start Mari and open your project.

2. Open a palette where you want to remove a custom attribute from (for example, the Channels,
Objects, or
Projectors palette).

3. To remove the attribute, click the button next to it in the palette.

Mari prompts you to confirm that you want to remove the attribute.

4. Click Remove.

Review the Custom Shortcut File Format
1. Read through the following information about the required format of a Mari custom shortcuts

file.

2. Study the example default shortcuts file.

Text File: <action>=<key(s)>

A default (DefaultShortcuts.conf) or custom (Shortcuts.conf) shortcuts configuration file is a text
file that starts with [Shortcuts] and then lists Mari actions and their shortcut keys, one per line. The
actions are the same as what you find in the Manage Keyboard Shortcuts dialog box in Mari, with
the hierarchies spelled out, separated by a backslash (\), and with “%20” for spaces. After each action
is an equal sign (=) and then the key or key combination. For key combinations, you use one or more
"modifier" keys, like Ctrl/Cmd or Alt with a plus sign (+) between each.

For example, below are some shortcuts in the Manage Keyboard Shortcuts dialog box alongside
their listings in the default shortcuts configuration file.
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GUI dialog box entries Configuration file listings

[Shortcuts]

...

Mari\Tools\Increase%20Radius="="

Mari\Tools\Decrease%20Radius=-

Mari\Tools\Increase%20Opacity=]

Mari\Tools\Descrease%20Opacity=[

Mari\Tools\Increase%20Rotation='

Mari\Tools\Decrease%20Rotation=";"

Mari\Tools\Increase%20Aspect=0

\Mari\Tools\Decrease%20Aspect=9

...

Mari\Tools\Color\Eye%20Dropper=C

Mari\Tools\Color\Color%20Popup=j

...

Mari\Tools\Toggle%20Brushes=N

TIP: Case is not important. The lines Mari\Tools\General\Transform%20Paint=M and
Mari\Tools\General\Transform%20Paint=m have the same meaning. If you want to set a
shortcut key to only the uppercase version of a character, include Shift in the key sequence.
For example:
Mari\Tools\General\Transform%20Paint=Shift+M only invokes the TransformPaint tool
when you hold down both Shift and M at the same time.

Using Modifier Keys
Some modifier keys can only be used as part of key combinations - you cannot assign a shortcut to
the Ctrl/Cmd key by itself, for example. This table lists the special keys available, the text strings to
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use for them in Shortcuts.conf, and whether the key can be used on its own.

Key Text string in file Can be used by itself?

Ctrl/Cmd Ctrl No

Shift Shift No

Alt (not Alt Gr) Alt No

(or Windows key)

Cmd key for Mac

Meta No

Escape Esc Yes

Caps Lock CapsLock Yes

Space Space Yes

F1 – F12 F1 – F12 Yes

Scroll Lock ScrollLock Yes

Pause Pause Yes

Insert Ins Yes

Left Arrow Left Yes

Right Arrow Right Yes

Up Arrow Up Yes

Down Arrow Down Yes

Home Home Yes

End End Yes

Page Up PgUp Yes

Page Down PgDown Yes

Number Lock NumLock Yes

Backslash \\ Yes
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TIP: You can use \ (backslash) as a shortcut, but as it is used as a directory separator in the
action part of the line, you must use a double backslash to make it clear that you are actually
assigning the key rather than indicating a directory.

Example: DefaultShortcuts.conf

The default shortcuts file, DefaultShortcuts.conf, is included in the following sub-directory of the
Mari application directory:

• Media/Settings (on Linux),

• Bundle\Media\Settings (on Windows), or

• Media/Settings (on Mac).

We recommend you create your custom shortcuts by copying this file and editing it, rather than
starting from scratch.

NOTE: If you are using a Mac, you need to replace all references of Ctrl in the table below to
Cmd for it to work correctly in Mari.

[Shortcuts]

Mari\Tools\General\Select=S

Mari\Tools\General\Scrub=Shift+?

Mari\Tools\General\Mouse%20Gestures=\\

Mari\Tools\General\Hide%20Widgets=/

Mari\Tools\General\Transform%20Paint=M

Mari\Tools\Default%20Brushes\Paint=P

Mari\Tools\Default%20Brushes\Paint%20Through=U

Mari\Tools\Default%20Brushes\Eraser=E

Mari\Tools\Image\Marquee=M

Mari\Canvas\Bake=B
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Mari\Tools\Camera\Rotate=Alt+

Mari\Tools\Camera\Zoom=Alt+Ctrl+

Mari\Tools\Camera\Pan=Alt+Shift+

Mari\Tools\Camera\Spin=Ctrl+R

Mari\Canvas\Camera\Focus=F

Mari\Tools\Color\Eye%20Dropper=C

Mari\Tools\Color\Color%20Popup=j

Mari\Tools\General\Shelf%20Popup=k

Mari\Tools\General\Image%20Popup=l

Mari\Tools\General\Pie%20Selector=F9

Mari\Animation\Start%20/%20Stop%20Animation=Space

Mari\Animation\Step%20Forwards=Ctrl+Right

Mari\Animation\Step%20backwards=Ctrl+Left

Mari\Animation\Add%20Keyframe=Ctrl+K

Mari\Animation\Rewind%20Animation=Ctrl+Down

Mari\Animation\Fastforward%20Animation=Ctrl+Up

Mari\Canvas\Camera\Camera%20Left=1

Mari\Canvas\Camera\Camera%20Right=2

Mari\Canvas\Camera\Camera%20Top=3

Mari\Canvas\Camera\Camera%20Bottom=4

Mari\Canvas\Camera\Camera%20Front=5

Mari\Canvas\Camera\Camera%20Rear=6

Mari\Canvas\Bake=B

Mari\Onscreen%20Controls\Adjust%20Radius=R
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Mari\Onscreen%20Controls\Adjust%20Rotation=W

Mari\Onscreen%20Controls\Adjust%20Squish=Q

Mari\Onscreen%20Controls\Adjust%20Opacity=O

Mari\Actions\Quit=Ctrl+Q

Mari\Actions\Undo=Ctrl+Z

Mari\Actions\Redo=Ctrl+Y

Mari\Actions\Previous%20View="Ctrl+,"

Mari\Actions\Next%20View=Ctrl+.

Mari\Actions\Hide%20Palettes=Home

Mari\Project\Open=Ctrl+O

Mari\Project\Save%20As=Ctrl+Shift+S

Mari\Project\Save=Ctrl+S

Mari\Project\New=Ctrl+N

Mari\Project\Close=Ctrl+W

Mari\Project\Lighting\Flat=F1

Mari\Project\Lighting\Basic=F2

Mari\Project\Lighting\Full=F3

Mari\Palettes\Colors=F6

Mari\Palettes\Tools=F7

Mari\Palettes\Brushes=F8

Mari\Canvas\Camera\View All=A

Mari\Painter\Swap%20foreground%20and%20background=X

Mari\Project\Project%20Explorer\Quick%20Paste=Ctrl+V

Mari\Project\Project%20Explorer\Quick%20Copy=Ctrl+C
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Mari\Project\Project%20Explorer\Select Invert=Ctrl+I

Mari\Project\Project%20Explorer\Select All=Ctrl+A

Mari\Project\Project%20Explorer\Select None=Ctrl+E

Mari\Project\Project%20Explorer\Toggle%20Hidden=Ctrl+H

Mari\Project\Project%20Explorer\Hide%20Selected=H

Mari\Project\Project%20Explorer\Hide%20Unselected=Shift+H

Mari\Project\Project%20Explorer\Show%20All=Ctrl+Shift+H

Mari\Painter\Paint%20Mask=Q

Mari\Painter\Toggle%20Edge%20Mask=G

Mari\Painter\Toggle%20Show%20Painting=.

Mari\Painter\Show%20Paintable=

Mari\Projection\Toggle%20Mask%20Preview%20Enabled=","

Mari\Painter\Invert=Shift+I

Mari\Channels\Toggle%20Channels=T

Mari\Channels\Next%20Channel=PgDown

Mari\Channels\Previous%20Channel=PgUp

Mari\Tools\Toggle%20Brushes=N

Mari\Tools\Decrease%20Aspect=9

Mari\Tools\Decrease%20Radius=-

Mari\Tools\Decrease%20Rotation=";"

Mari\Tools\Descrease%20Opacity=[

Mari\Tools\Increase%20Aspect=0

Mari\Tools\Increase%20Opacity=]

Mari\Tools\Increase%20Radius="="
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Mari\Tools\Increase%20Rotation='

Mari\Project\Project%20Explorer\Shader%201=Ctrl+1

Mari\Project\Project%20Explorer\Shader%202=Ctrl+2

Mari\Project\Project%20Explorer\Shader%203=Ctrl+3

Mari\Project\Project%20Explorer\Shader%204=Ctrl+4

Mari\Painter\Set%20Colors%20to%20Black%20And%20White=D

Define Custom Shortcuts
To create a Mari shortcut customization file:

1. Copy the Mari default shortcuts file, DefaultShortcuts.conf, from the following sub-directory of
the Mari application directory:

• Media/Settings (on Linux),

• Bundle\Media\Settings (on Windows), or

• Media/Settings (on Mac).

2. Rename the file as a custom shortcuts file: Shortcuts.conf.

3. Edit the file, replacing the defaults with your custom shortcuts.

4. Save the file in the following sub-directory of your home directory:

• .config/TheFoundry (on Linux),

• .mari\TheFoundry (on Windows), or

• .config/TheFoundry (on Mac).

TIP: If you set an illegal key combination in the Shortcuts.conf file, Mari ignores the line.
For example, the following lines would be ignored:

Mari\Tools\General\Select=Tab (you cannot use tab as part of a shortcut)
Mari\Tools\General\Transform%20Paint=Altw (needs a + between the two characters).

If the same function key is assigned to more than one function, Mari ignores both settings
and uses the defaults. If a function is assigned to more than one key combination, Mari uses
the defaults.
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Review the Custom Channel Preset File Format
1. Read through the following information about the required format of a Mari custom presets file.

2. Study the example default presets file.

NOTE: To know more about the channel presets, see About Custom Channel Presets.

XML File: Header, Details, Closing Blocks

Channel preset files are XML files with an .mtd extension. Each file can hold as many channels as you
want, divided into categories. The files can have any name you want, as long as they have the
extension .mtd. Mari picks up the settings from all .mtd files present, so you can use multiple files.
For example, you could use one local .mtd file for a single artist's specific channel presets and one on
a network drive for multiple artists' presets.

Each file must have a header block, one details block per channel, and a closing block. Below are
examples of each type of block, with values you need to change bolded and explained in a table
below.

Header Block

This must be the first thing in the file.

<!DOCTYPE MariML>

<Mari Version="2" >

<MriSerializableObject Type="MriSerializableObject" >

<objectName Type="QString" ></objectName>

<selected Type="bool" >false</selected>

<m_Channels Size="1" Type="MriChannelInfo"
ContainerType="QVector">

You must set the following values:
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Setting Meaning Example value

m_Channels Size Number of channels in this preset file. 1

Details Blocks

You need one details block for each channel. Separate the blocks with a blank line.

<MriChannelInfo Type="MriChannelInfo" >

<objectName Type="QString" ></objectName>

<selected Type="bool" >false</selected>

<channelName Type="QString" >My Custom
Channel</channelName>

<fileFormat Type="QString" ></fileFormat>

<path Type="QString" ></path>

<scalar Type="bool" >false</scalar>

<width Type="int" >4096</width>

<height Type="int" >4096</height>

<channels Type="QString" >RGB</channels>

<depth Type="QString" >Byte</depth>

<color Type="MriColor" >(0.5,0.5,0.5,1)</color>

<category Type="QString" >Custom</category>

</MriChannelInfo>

You must set the following values:
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Setting Meaning Example value

channelName Name for the channel to create. My Custom Channel

scalar Whether the channel is color or scalar.
This is a Boolean; true means a scalar
channel, false means color.

false

width Width of patches in the channel. This
must match the heightType.

TIP: If the width and height are
greater than a project's
maximum resolution, Mari
creates the channel at the
project's maximum resolution.

4096

height Height of patches in the channel. This
must match the widthType.

TIP: If the width and height are
greater than a project's
maximum resolution, Mari
creates the channel at the
project's maximum resolution.

4096

channels The color channels for the new channel.
Must be one of:

• RGBA

• RGB

• 1

• 2

RGB

depth Color depth for the channel. Must be one
of:

• Byte

• Half

• Float

Byte
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Setting Meaning Example value

color Default color for the new channel. This is
the color that Mari fills the channel with
when created.

This must be entered as a floating value,
with values from 0 to 1 for the Red,
Green, Blue and Alpha.

0.5,0.5,0.5,1

category The category for the channel. When the
artist selects this category in the
Channel Presets dialog, this channel
appears in the list.

Custom

fileSpace Allows you to set whether the channel or
image should be exported as a Normal
file (in the way Mari stores them), as a
Vector file (-1.0 to +1.0 range), or as a
Vector (flipped Y) file, which is the same
as the Vector file in terms of range, but
inverts the vectors in the Y direction.

Vector

colorSpaceConfig Specifies the default advanced
colorspace options, including the
Automatic values for each parameter.

See colorSpaceConfig
Parameter

Closing Block

This must be the last thing in the file.

</m_Channels>

</MriSerializableObject>

</Mari>

EXTENDING MARI | REVIEW THE CUSTOM CHANNEL PRESET FILE FORMAT



USER GUIDE 452

Example: DefaultChannels.mtd

The default channel presets file is included in Mari in the ../Bundle/Media/Settings directory (on
Windows)(DefaultChannels.mtd). We recommend you create your custom channels file by copying
this and editing it, rather than starting from scratch.

NOTE: The fileSpace and colorSpaceConfig parameters are not present in the
DefaultChannels.mtd file, but you can add them to it, see Review the Custom Channel
Preset File Format

NOTE: The example below shows the parameters of the color channel. These parameters
apply to all channels.

<!DOCTYPE MariML>
<Mari Version="2" >
<MriSerializableObject Type="MriSerializableObject" >
<objectName Type="QString" ></objectName>
<selected Type="bool" >false</selected>
<m_Channels Type="MriChannelInfo" ContainerType="QVector" >

<MriChannelInfo Type="MriChannelInfo" >
<objectName Type="QString" ></objectName>
<selected Type="bool" >false</selected>
<channelName Type="QString" >color</channelName>
<fileFormat Type="QString" ></fileFormat>
<path Type="QString" ></path>
<scalar Type="bool" >false</scalar>
<width Type="int" >4096</width>
<height Type="int" >4096</height>
<channels Type="QString" >RGBA</channels>
<depth Type="QString" >Byte</depth>
<color Type="MriColor" >(0.5,0.5,0.5,1)</color>
<category Type="QString" >General</category>
<fileSpace Type="QString" >Vector</fileSpace>
<colorSpaceConfig Type="MriColorSpaceConfig"

>0|1|2|3|4|5|6|7|8|9|10</colorSpaceConfig>
</MriChannelInfo>
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colorSpaceConfig Parameter

As the colorSpaceConfig parameter is a bit more complex than the other parameters, it is explained
in detail below:

NOTE: Automatic is the default value.

Key Description Data type with an example value

0 colorspace
filename

string (for example, nuke-default or Automatic)

1 data
colorspace

string (for example, rec709 or Automatic)

2 output
colorspace

string (for example, rec709 or Automatic)

3 working
colorspace

string (for example, rec709 or Automatic)

4 automatic
colorspace 0

int (for example, 0, 1, 2)
Sets the automatic value for the data colorspace, assigning certain
colorspace values to set integers.

5 automatic
colorspace 1

int (for example, 0, 1, 2)
Sets the automatic value for the output colorspace, assigning certain
colorspace values to set integers.

6 raw mode
enabled

bool (int) Enables (1) or disables (0) raw mode

7 scalar mode
enabled

bool (int) Enables (1) or disables (0) scalar mode

8 automatic
data
colorspace

string (for example, rec709)
Specifies which colorspace is chosen when using Automatic value.

NOTE: Setting this value overwrites 4 automatic colorspace
0.
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9 automatic
output
colorspace

string (for example, rec709)
Specifies which colorspace is chosen when using Automatic value.

NOTE: Setting this value overwrites 5 automatic colorspace
1.

10 automatic
working
colorspace

string (for example, rec709)
Specifies which colorspace is chosen when using Automatic value.

Below is an example of the colorSpaceConfig parameter:
<colorSpaceConfig Type="MriColorSpaceConfig">nuke-
default|rec709|Automatic|Automatic|0|0|0|0|Cineon|Cineon|Cineon</colorSpaceCo
nfig>

This creates a channel with rec709 data colorspace, but Cineon working and output colorspaces.
Raw and Scalar are off.

Define Custom Channel Presets
To create a Mari custom channel presets file:

1. Copy the Mari default channel presets file, DefaultChannels.mtd, from the following sub-
directory of the Mari application directory:

• Media/Settings (on Linux),

• Bundle\Media\Settings (on Windows), or

• Media/Settings (on Mac).

2. Rename the file to something descriptive, but keep the .mtd extension.

3. Edit the file, replacing the key values.

4. Save the file in the following sub-directory of your home directory:

• .config/TheFoundry (on Linux),

• .mari\TheFoundry (on Windows), or

• .config/TheFoundry (on Mac).

This is also the directory specified on the Channels tab of the Mari Preferences dialog box.

Review the Custom Channel Template File Format
1. Read through the following information about the required format of a Mari custom presets file.
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2. Study the example default channel template file.

Text File: <name>="<format>"

A default (DefaultTemplates.mtt) or custom (<filename>.mtt) channel templates file is a text file
that starts with [Templates]] and then lists channel templates and their file formats.

Each line is a channel template. The name is listed on the left, and the format in quotes on the right.
The format can include the following variables, and on Linux they are preceded with the dollar sign ($)
while on Windows they're
preceded with the percent sign (%):

Variable Description

Any of the user's
environment variables
except PATH

These are taken from the shell from which the user opened Mari. Note
that PATH here has a specific meaning - it is not the user's standard
PATH.

PATH The project's root path, as set in the Root Path field of the Channel
Presets dialog box. This overrides the normal PATH variable from the
user's original shell.

PREFIX The filename prefix, as set in the Prefix field of the Channel Presets
dialog box.

CHANNEL Name of the individual channel.

UDIM Udim number for each individual patch.

Example File: DefaultTemplates.mtt

On Linux:

[Templates]

Default="$TEXTURE_HERO_DIR/tif/$SHOT/$CHANNEL/$SHOT_
$CHANNEL_$UDIM.tif"

On Windows:
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[Templates]

Default="%TEXTURE_HERO_
DIR/tif/%SHOT/%CHANNEL/%SHOT_%CHANNEL_&UDIM.tif"

Define Custom Channel Templates
To create a Mari custom channel templates file:

1. Copy the Mari default channel templates file, DefaultTemplates.mtt, from the following sub-
directory of the Mari application directory:

• Media/Settings (on Linux),

• Bundle\Media\Settings (on Windows), or

• Media/Settings (on Mac).

2. Rename the file to something descriptive, but keep the .mtt extension.

3. Edit the file, replacing the key values.

4. Save the file in the following sub-directory of your home directory:

• .config/TheFoundry (on Linux),

• .mari\TheFoundry (on Windows), or

• .config/TheFoundry (on Mac).

This is also the directory specified on the Channels tab of the Mari Preferences dialog box.

Choose an Environment Variable to Set
1. Read through the following information on Mari environment variables and how you can use

them.

2. Select an environment variable you want to set.

Environment Variables That Mari Recognizes
This table lists the environment variables Mari recognizes.
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Environment variable Description Example value

FN_DISABLE_LICENSE_
DIALOG

By default, if you have installed a
temporary license, Mari displays a
dialog at start-up alerting you to
the number of days remaining. If
you want to disable this behavior,
you can set this environment
variable to 1 to suppress the
warning message about imminent
license expiration.

NOTE: When this
environment variable is
set, a warning message is
still displayed if no license
is found.
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Environment variable Description Example value

MARI_CACHE The location(s) of the Mari project
files. This can be just one directory
or several (to make caching faster).
You should separate multiple path
entries by a : (colon) on Linux and
Mac, or a ; (semi-colon) on
Windows.

Project directories must be
permanent directories and not
temporary locations as they
contain important project file
information.

If this variable is not set, Mari
prompts you where to store the
project files when you first launch
it.

Note that when you set this
environment variable, Mari takes
its value and stores it in the
CacheLocations.ini file (by default
found in the .config/TheFoundry
sub-directory of your home
directory on Linux, or the
.mari\TheFoundry sub-directory
on Windows and Mac). Be cautious
of changing this. The set of project
locations must not be changed
after project creation; doing so
results in project corruption. For
more information please read the
chapter on Installation and Launch
in the Getting Started Guide.

• On Linux:

/user/<MyPath>/MariCache

• On Windows:

C:\<MyPath>\MariCache

• On Mac:

/user/<MyPath>]/MariCache

MARI_DEFAULT_ARCHIVE_
PATH

The default path to load and save
project archives.
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Environment variable Description Example value

MARI_DEFAULT_CAMERA_
PATH

The default path to load and save
cameras and projectors.

MARI_DEFAULT_EXPORT_
PATH

The default path to export textures
to.

MARI_DEFAULT_
GEOMETRY_PATH

The default path to load geometry
from.

MARI_DEFAULT_IMAGE
PATH

The default path to load and save
reference images.

MARI_DEFAULT_IMPORT_
PATH

The default path to import textures
from.

MARI_DEFAULT_RENDER_
PATH

The default path to save renders
such as turntables.

MARI_DEFAULT_SHELF_
PATH

The default path to load and save
shelf files.

MARI_LOG_FILE The name and location of the Mari
log file.

If this variable is not set, the log is
saved to:

• MariLog.txt in the
/home/<Username>/Mari/Logs
directory on Linux and Mac, or

• MariLog.txt in the
C:\Users\
<Username>
\Documents\Mari\Logs directory
on Windows.

• On Linux:

/user/Mari/MyLog.txt

• On Windows:

C:\TEMP\MyLog.txt

• On Mac:

/user/Mari/MyLog.txt

MARI_MODO_BAKE_PRESET The path where Mari looks for
baking preset files.

MARI_MODO_RENDER_
PRESET

The path where Mari looks for
rendering preset files.
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Environment variable Description Example value

MARI_NAMEDFILEIMPORT_
SEQUENCELIMIT

The maximum number of patches
objects are allowed to have for the
Named Files tab to appear on the
Import Channel and Export
Channel dialogs.

By default, the Named Files tab
does not appear if you have more
than 20 patches in your object, but
you can change this using the
Patch Cutoff preference.

You can use the Named Files tab
to import or export individual files
rather than a sequence of patches
with the udim number (1001, 1002,
etc.) in the file names.

30

MARI_SCRIPT_PATH A list of paths to run scripts from. ~/Mari/Scripts on Linux and
Mac, or

C:\Users\<username>\
Documents\Mari\Scripts on
Windows

MARI_USER_PATH Root of the default user path. ~/Mari on Linux and Mac, or

C:\Users\<username>\
Documents\Mari on Windows.

MARI_WORKING_DIR The location of temporary Mari
files, such as crash logs.

If this variable is not set, the files
are saved to the same path as the
log file.

• MariLog.txt in the
/home/
<username>/Mari/Logs
directory on Linux and Mac, or

• MariLog.txt in the
C:\Users\
<username>\Documents\
Mari\Logs directory on
Windows.

EXTENDING MARI | ENVIRONMENT VARIABLES THAT MARI RECOGNIZES



USER GUIDE 461

Environment variable Description Example value

SHOW_FULL_
COLORSPACE_OPTIONS

Enables the advanced color
management mode:

1. Open your Mari configuration
file, named Mari.conf (on
Linux) or Mari.ini (on Windows
and Mac).

2. Under the General section
(near the top in the config file),
place the following
environment variable:

SHOW_FULL_COLORSPACE_
OPTIONS=true.

If the environment variable
already exists in the file, change
it from false to true.

Once the environment variable
is set to true, the advanced
color management options are
active and exposed within Mari.

NOTE: Any changes you
make to colorspace while
advanced color
management is enabled
persist even after you have
reverted back to the basic
color management mode.
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Environment variable Description Example value

XDG_CONFIG_HOME The location of the directory where
the Mari configuration files are
stored.

If you're on Windows, you can't
change this directory, and the
Mari.ini file can only be stored in
the default location:

<drive letter>:\Users\<user>

\.mari\TheFoundry.

On Linux and Mac:

/SharedDisk/Mari

Image Importing

You can set environment variables that Mari looks for when importing images. You can call these
variables anything, and as long as you precede the variable name in the image import path with $ on
Linux and Mac, or % on Windows. Mari replaces that part of the path with the value of the
environment variable. For example:

On Linux and Mac, if the import path is $SHOW_BASE_DIR/Images/$SHOT, $SHOW_BASE_DIR and
$SHOT is replaced by the values of the environment variables SHOW_BASE_DIR and SHOT.

On Windows, if the import path is %SHOW_BASE_DIR%/Images/%SHOT%, %SHOW_BASE_DIR and
%SHOT is replaced by the values of the environment variables SHOW_BASE_DIR and SHOT.

Overriding Mari Configuration File

You can also use environment variables to override any setting in the Mari configuration file named
Mari.conf (on Linux) or Mari.ini (on Windows and Mac). This file contains all user settings that are
not project specific. By default, you can find it in the following sub-directory of your home directory:

• .config/TheFoundry (on Linux),

• .mari\TheFoundry (on Windows), or

• .config/TheFoundry (on Mac).

Here's a short example of what you may find the Mari configuration file:
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[HUD]

Canvas_fps_hudVisibility=2

Canvas_triangleCount_hudVisibility=2

Project_currentObjectName_hudVisibility=2

Project_currentChannelName_hudVisibility=2

[Application]

ThreadCount=5

To override a setting in the Mari configuration file, you need to set an environment variable of the
format MARI_<Group>_<Name>. So, for example, if you wanted to override the application thread
count setting in the above example file and set it to two rather than five, you could set MARI_
APPLICATION_THREADCOUNT to 2.

Setting Environment Variables

On Linux
1. The procedure for setting an environment variable depends on what your default shell is. To get

the name of the shell you are using, launch a shell and enter echo $SHELL.

This returns the type of shell you are using.

2. Depending on the output of the previous step, do one of the following:

• If your shell is a csh or tcsh shell, add the following command to the .cshrc or .tcshrc file in
your home directory: setenv VARIABLE value. Replace VARIABLE with the name of the
environment variable and value with the value you want to give it, for example:

setenv MARI_CACHE /User/Temp/Mari

• If your shell is a bash or ksh shell, add the following command to the .bashrc or .kshrc file in
your home directory: export VARIABLE=value. Replace VARIABLE with the name of the
environment variable and value with the value you want to give it, for example:

export MARI_CACHE=/User/Temp/Mari

For a list of the environment variables that Mari understands, see Environment Variables That
Mari Recognizes.
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On Windows
1. Right-click on My Computer and select Properties.

2. In the System window click on Advanced system settings in the left pane.

3. Go to the Advanced tab.

4. Click the Environment Variables button.

The Environment Variables dialog opens.

5. Click the New button under either User variables or System variables, depending on whether
you want to set the variable for the current user or all users. To set environment variables for all
users, you need to have administrator privileges.

6. In the Variable name field, enter the name of the environment variable you want to set. For a list
of the environment variables Mari understands, see Environment Variables That Mari Recognizes.

7. In the Variable value field, enter the value for the variable. The value can be a directory path, for
example.

8. Click OK.

On Mac
1. The procedure for setting an environment variable depends on what your default terminal is. To

get the name of the terminal type you are using, launch the terminal and enter echo $SHELL.

This returns the type of terminal you are using.

2. Depending on the output of the previous step, do one of the following:

• If your terminal is a csh or tcsh terminal, add the following command to the .cshrc or .tcshrc
file in your home directory: setenv VARIABLE value. Replace VARIABLE with the name of the
environment variable and value with the value you want to give it, for example:

setenv MARI_CACHE /User/Temp/Mari

• If your terminal is a bash or ksh terminal, add the following command to the .bashrc or .kshrc
file in your home directory: export VARIABLE=value. Replace VARIABLE with the name of the
environment variable and value with the value you want to give it, for example:

export MARI_CACHE=/User/Temp/Mari

For a list of the environment variables that Mari understands, see Environment Variables That Mari
Recognizes.
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Check That the Variable Now Exists

On Linux
1. Launch a shell, if you don't have one open already.

2. Enter echo $VARIABLE. Replace VARIABLE with the name of the environment variable you set
earlier. For example, to check if MARI_CACHE is set, enter echo $MARI_CACHE.

If the variable is set, its value is displayed in the shell window.

On Windows
1. Select Start > All Programs > Accessories > Command Prompt.

2. In the command window that opens, enter echo %VARIABLE%. Replace VARIABLE with the name
of the environment variable you set earlier. For example, to check if MARI_CACHE is set, enter
echo %MARI_CACHE%.

If the variable is set, its value is displayed in the command window.

On Mac
1. Launch a terminal, if you don't have one open already.

2. Enter echo $VARIABLE. Replace VARIABLE with the name of the environment variable you set
earlier. For example, to check if MARI_CACHE is set, enter echo $MARI_CACHE.

If the variable is set, its value is displayed in the terminal window.
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Appendix A: Shortcuts

Keyboard Shortcuts
NOTE: In many Linux windows managers, the Alt key is used by default as a mouse modifier
key. This can cause problems in 3D applications where Alt is used for camera navigation in
3D environments.

You can use key mapping to assign the mouse modifier to another key, such as the
(Super or Meta) key, but the method changes depending on which flavor of Linux you're
using. Please refer to the documentation on key mapping for your particular Linux
distribution for more information.

Keyboard Shortcuts

Painting Selection

Bake B Quick Copy Ctrl/Cmd+C

Bake and Clear Ctrl/Cmd+Shift+B Quick Paste Ctrl/Cmd+V

Undo Ctrl/Cmd+Z Select S

Redo Ctrl/Cmd+Y Select All Ctrl/Cmd+A

Toggle Painting . Select None Ctrl/Cmd+E

Paint P Hide Selected H

Paint Through U Hide Unselected Shift+H

Eraser E Show All Ctrl/Cmd+Shift+H
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Keyboard Shortcuts

Toggle Mask Preview , Clear Marquee
Selection

Ctrl/Cmd+D

Toggle Edge Mask G Invert Ctrl/Cmd+I

Toggle Masking Ctrl/Cmd+M

Color Picker Menu J

Shelf Menu K

Image Manager Menu L

Pie Menu F9

Zoom Paint Buffer Z

Clear Paint Buffer Ctrl/Cmd+Shift+C

Next Blend Mode Shift+ )

Previous Blend Mode Shift+ (

Last Blend Mode Ctrl/Cmd+9

Reset Blend Mode Ctrl/Cmd+0

Clear Blend Mode Shift+Backspace

Keyboard Shortcuts

Brush Tools

Adjust Radius R Transform M

Rotation W Mouse Gestures \

Squish Q Hide/Show Widgets /

Toggle Brushes N Color Picker and Pixel
Analyzer

C
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Keyboard Shortcuts

Adjust Opacity O Toggle Vector Inspector Shift+I

Increase/Decrease
Aspect Ratio

0 / 9 Modify Vector Inspector V

Increase/Decrease
Opacity

[ / ]

Increase/Decrease
Radius

= / -

Increase/Decrease
Rotation

’ / ;

Keyboard Shortcuts

Camera View

Focus on Cursor
Position

F Go to Next Tab Ctrl/Cmd+Tab

Camera View Presets 1,2,3,4,5,6 Go to Previous Tab Ctrl/Cmd+Shift+Back
Tab

Focus on Selection A Full Screen Ctrl/Cmd+Shift+F

View All Shift+A Previous View Ctrl/Cmd+ ,

Ortho Camera F10 Next View Ctrl/Cmd+ .

Perspective Camera F11 Show Console Alt+Ctrl/Cmd+P

UV Camera F12 Toggle Cursor Type F5

Keyboard Shortcuts

Animation Project
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Keyboard Shortcuts

Move Forward One
Frame

Ctrl/Cmd+Right New Ctrl/Cmd+N

Move Backward One
frame

Ctrl/Cmd+Left Save Ctrl/Cmd+S

Fast Forward Ctrl/Cmd+Up Close Ctrl/Cmd+W

Rewind Ctrl/Cmd+Down

Add keyframe Ctrl/Cmd+K

Scrub Animation Shift+?

Keyboard Shortcuts

General Channels

Quit Ctrl/Cmd+Q Channel Menu I

Toggle Palettes Home Bake on New Layer Ctrl/Cmd+B

Toggle Tool Properties
Palette

F7 Duplicate Alt+drag and drop

Toggle Brush Editor
Palette

F8 Select first channel
visible

Page Up

Toggle Wireframe View Shift+W Select last channel
visible

Page Down

Take Screenshot Ctrl/Cmd+Shift+Print Toggle between last
selected channel

T

Keyboard Shortcuts

Lighting Color
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Keyboard Shortcuts

Flat F1 Swap Foreground and
Background

X

Basic F2 Set to Black & White D

Full F3

Keyboard Shortcuts

Navigation UV View Presets

Orbit Alt+left-click+drag Reset Model to Default 1

Pan Alt+Shift+Left-
click+drag

or Alt+Middle-
click+drag

Rotate 90 degrees
counterclockwise

2

Roll Ctrl/Cmd+R+Left-
click+drag

Rotate 180 degrees
counterclockwise

3

Zoom Alt+Ctrl/Cmd+Left-
click+drag

or Alt+Right-
click+drag

Rotate 270 degrees
counterclockwise

4

Keyboard Shortcuts

Node Graph Python Console

Fit All Nodes in Node
Graph

A Zoom in on text in the
Python Console

Ctrl/Cmd+ +

Focus Selection in
Node Graph

F (If no selection is
made, behaves the
same as Fit All Nodes
in Node Graph.)

Zoom out from the text
in the Python Console

Ctrl/Cmd+ -
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Keyboard Shortcuts

Jump to Backdrop
Node

J Evaluate a script in the
Python Console

Ctrl/Cmd+Return

Create Paint Node P

Create Group Ctrl/Cmd+G

Copy Selection Ctrl/Cmd+C

Paste Selection Ctrl/Cmd+V

Bypass Selected Node Ctrl/Cmd+D

Disable Selection D

Delete Selection Delete

Pan in Node Graph Middle-click+drag,
Alt+middle-click+drag,
or Alt+right-click+drag

Zoom in Node Graph Mouse wheel scroll or
Alt+middle-click+drag

Mouse Gestures

Mouse gestures

Hold down \ and draw...

Undo Redo

Clear Painting Bake
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Mouse gestures

Previous Channel Next Channel

Toggle Last 2 Channels Paint Tool

Paint Through Tool Selection Tool

Erase Tool Show Palettes

Increase Brush Radius Decrease Brush Radius

Hide Unselected Hide Selected

Show All View All

Toggle Brush Tip
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Appendix B: Frequently Asked
Questions and Troubleshooting

Frequently Asked Questions
This appendix lists some of the most common questions about Mari. If your question isn't answered
here, review the documentation and the release notes or contact The Foundry customer support for
help.

I can’t see or bake what I've painted.

There can be several reasons for this:

• Paint Opacity has been set to 0 in the Projection palette.

• A mask is preventing paint from appearing. Check if any of the masks are enabled in the Projection
palette.

• Project On has been set to Selected Only in the Projection palette, but you haven't selected any
objects, patches, or faces. Either select the areas where you want paint to appear or set Project On
to All.

• The paint is on objects, patches or faces that have been locked. To unlock them, click Selection >
Unlock Selected, Unlock All, or Unlock Entire Object.

• The paint blending mode (Painting Mode in the Projection palette) has been set to a mode that
does nothing to your textures. For example, if your texture is white, the paint is red and Painting
Mode has been set to Hue, the paint is not visible.

• Brush Opacity has been set to 0 in the Brush Editor palette.

• Brush Flow has been set to 0 in the Brush Editor palette.

• The paint buffer has been moved off the screen. To reset the buffer to its defaults, click Reset under
Paint Buffer in the Painting palette.

My object has disappeared from the canvas.

The object may have been moved off the screen. Try pressing A or F to bring it back.
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Mari’s bake behavior seems strange.

In the Projection palette, you can set whether Mari bakes automatically when you change the view,
and whether the buffer clears automatically once you bake. Set Bake Behavior to:

• AutoBakeAndClear – Mari automatically bakes and clears the buffer when you move the model.

• Manual – You have to bake manually; and when you do, the paint stays in the paint buffer until you
manually clear it.

• ClearOnly – You have to bake manually; and when you do, the paint buffer clears automatically.

Mari seems slowwhen using the Clone Stamp tool.

When cloning from a particular channel, the Clone Stamp tool takes a “snapshot” of that channel as it
appears on the screen and uses that as the source. As a result, the resolution of the cloned texture
can depend on the current display resolution within Mari. Higher display resolutions produce better
cloning results, but can dramatically slow Mari's performance.

Increasing the Paint Buffer Size or Virtual Texture Size can affect Mari’s performance.

Increasing the Buffer Size or the Virtual Texture Size, even when your graphics card supports large
textures, can slow Mari’s performance. Adjust the Buffer Size under Paint Buffer in the Painting
palette, and the Virtual
Texture Size in the Mari Preferences dialog under Data > Graphics Card.

Displacement preview performance seems slow.

If you have allocated a channel to be used in a Displacement shader component, the Virtual
Texture Type under Edit > Preferences > GPU > Virtual Texture, should be set to at least Half for
more precise displacement. In
addition, the channel containing the displacement map should be set to at least 16-bit. Please note
that using values higher than these may reduce preview performance.

Mari keeps highlighting anything I've selected with a selection color. How can I turn
this off?

You can configure the way Mari highlights selected areas. Right-click on the canvas and select Display
Properties. Under Selection, adjust Fill Render and Outline Render.
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I can’t find a Save As option.

Mari currently has no Save As functionality. You can, however, duplicate your project by right-clicking
on it in the Projects view and selecting Copy.

If you want to pass your project on to another user, you can also select the project in the Projects
view and click Archive. This creates an archive (a .mra file) that contains your project and all the
textures and models associated with it.

If you use . (full stop) to separate parts of the file name (for example, "test.file"), Mari does not add
the file extension .mra automatically. This allows you to use a different extension if desired. However,
in most cases you most likely want to add the .mra extension to ensure the file is clear.

I want to bake what I’ve painted, but I can’t find the bake button.

The bake button sits at the bottom right of the workspace. It only appears when you have unbaked
paint in the paint buffer.

You can also press B to bake.

Clicking on another application caused the floating palettes in Mari to disappear.

This is not a problem in Mari but caused by your Linux window behavior settings. To fix this on KDE 4,
for example, you can:

1. Go to Settings > System Settings > Window Behavior > Advanced.

2. Uncheck Hide utility windows for inactive applications.

I am having problems with my Wacom tablet.

We have found that these links have been useful in solving the problems for some of our users:

https://help.ubuntu.com/community/Wacom

http://linuxwacom.sourceforge.net/

On Linux, pressing the Ctrl/Cmd, Alt, or (Windows) shortcut key doesn’t do what it
should. Instead, it does something else, like moves the entire Mari window.

This is usually caused, not by a problem in Mari, but rather by your Linux window manager, which is
using one of these keys as a global shortcut. Depending on your window manager, you may be able
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to block the global shortcut, or select which of the three keys is used as the global shortcut. For
example, if the Mari shortcuts you often use require you to press the Alt key, you can set the global
shortcut to be the Windows key instead. This way, the Mari shortcuts that don't work are limited to
those that require the Windows key.

To block the global shortcut on a per-application basis (that is, for Mari only) on KDE 4, you can:

1. Right-click on the Mari title bar and select Advanced > Special Window Settings. This may open
an information dialog where you need to click OK.

2. Go to the Window tab.

3. Click the Detect Window Properties button and then click on the Mari window.

4. Make sure that Use whole window class and Match also window title are checked and click
OK.

5. Go to the Workarounds tab.

6. Check Block global shortcuts, select Force from the dropdown menu, and enable the checkbox
on the right. Click OK.

To select which key is used as the global shortcut on KDE 4, you can:

1. Go to Settings > System Settings > Window Behavior > Window Actions.

2. Under Inner Window, set Modifier to the shortcut key you need the least in Mari or other
applications you use (for example, the Windows key).

This allows you to use the other two keys (in this case, Ctrl/Cmd and Alt) in Mari.

OnWindows, pressing theWindows shortcut key should open the Start menu. This
doesn’t happen whenMari has focus. Why is that?

This is because the Windows key is a shortcut key in Mari. Whenever Mari has focus, the Windows
key is reserved for Mari, so that you can use all the Mari shortcuts.

If you need to access the Start menu, you can either click it manually or move focus to another
application and then press the Windows key.

Pressing the Alt Gr key does not trigger the same shortcuts as the Alt key. Why is
that?

The Alt Gr key is defined differently on the Windows and Linux operating systems. Due to this, Mari
cannot determine what the Alt Gr key is intended to be linked to. If a shortcut lists the Alt key as part
of the controls, this does not include Alt Gr as an alternative. For this reason, it is advisable to avoid
using the Alt Gr key in your custom shortcuts.
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OnWindows, I’ve removed a drive fromMari’s file browser bookmarks. How do I get it
back? Is it possible to delete a drive from the bookmarks permanently?

All logical drives that Windows can see are automatically added to Mari’s file browser bookmarks
when you start Mari. You can remove these while Mari is running, but the only way to get them to
reappear is to relaunch Mari. At present, you can’t delete a drive from the bookmarks permanently - it
always reappears when you relaunch Mari.

Mari also automatically adds mapped network drives to its bookmarks. You should not disconnect a
network drive while Mari is running and then attempt to reference files from that drive in Mari, as
that may result in undefined behavior.

Generally, I need the channel to have precision when I paint in a linear colorspace,
and I use 16-bit channels if I apply the gamma after the paint has been applied. Now
that colors are linearized before baking, do I need to use HDRmode formy paint to
be applied without artifacts or can I paint in a linear colorspace but with 8-bit
channels?

When working with 8-bit (byte) channels in a non-linear colorspace, it is recommended that you set
the virtual texture's type and paint buffer's color depth to 16-bit (half) or 32-bit (float). This keeps the
project's data footprint down but the data is still converted to floating point and linearized on upload
to the GPU for painting, this way it keeps the colorspace transform error down to a minimum. When
Mari bakes paint and texture data back into the channel, the inverse is applied, so the floating point
data is color corrected and converted back to 8-bit (byte).

If you want to eliminate errors as much as possible, it is recommended to use floating point channels
and then export to the colorspace and bit-depth of your choosing. However, this means the project is
a lot larger and performance might be an issue on a less capable machine. It is not possible to
eliminate all the errors even if using full 32-bit float everywhere as you still get floating point and
interpolation errors being introduced.

Troubleshooting

Advanced Debugging Methods

If you are launching Mari from the command line or terminal, you can run the application in one of
two safe modes: --safe and --safer. These safe modes run a number of options, described in the
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Installation and Licensing chapter of the Mari Getting Started Guide.

If you prefer, you can choose instead to run individual safe mode options rather than those grouped
under --safe or --safer. To do this, type the given number for the option after the --safe
command. Please be aware that these work on an "up to and including" fashion, so selecting --safe=3
also runs --safe=1 and --safe=2 (effectively, operating the same as running the --safe command).

Safe Mode Corresponding Safe Feature

--safe=1 Disables startup Python scripts.

--safe=2 Disables user custom plug-ins.

--safe=3 Bypasses user Python libraries.

--safe=4 Bypasses user settings.

--safe=5 Bypasses user environment variables.
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Appendix C: External Software
This appendix lists third party libraries and versions used in Mari along with their licenses.

NOTE: This list only details the third party libraries that ship with Mari. For a full list of all
third-party licenses used in Modo, as part of the Modo-related functionality, please see the
Modo Online Help, Appendix D, Third-Party Libraries and Fonts, or refer to Modo Third Party
Libraries.

Third Party Library Versions

Library Version Library Version

Alembic 1.5.0 OpenCV 2.0.0

Autodesk FBX 2012.2 OpenEXR 2.0.1

Boost 1.43.0 (Windows and
Linux)

1.46.0 (Mac OS X)

OpenImageIO 1.0

Curl 7.21.1 OpenSSL 1.0.0a

EdenCGL 0.0.1 OpenSubDiv 2.3.0

Expat 2.0.1 Partio 22-06-2015

FBO (as part of
openMAF)

1.1.2.1 Ptex 2.0

FreeType 2.1.9 PySide 1.0.9

GCC 4.1.2 Python 2.7.3

GLEW 1.5.8 Qt 4.8.5
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Library Version Library Version

GLib 2.24.0 QtSingleApplication QtExtensions 4.7.2

GLSL Cellular Noise 2011-08-22 QuaZip 0.2.3

GLSL Perlin Noise 2011-08-22 Qwt 5.2.1

GLSL Classical (Perlin)
and Simplex Noise

2011-08-22 Skein-Hash 1.1

GTS 0.7.6 TinyXML 2.6.0

IJG JPEG 6b Tri Stripper 2005-06-08

libnoise 1.0 Wild Magic 5.0

MSIntTypes r20 Python 2.7.3

OpenColorIO 1.0.9

Third Party Licenses

Library Description Licence

Autodesk FBX File Format
Support

This software contains Autodesk® FBX® code developed by
Autodesk, Inc. Copyright 2008 Autodesk, Inc. All rights,
reserved. Such code is provided “as is” and Autodesk, Inc.
disclaims any and all warranties, whether express or
implied, including without limitation the implied warranties
of merchantability, fitness for a particular purpose or
non-infringement of third party rights. In no event shall
Autodesk, Inc. be liable for any direct, indirect, incidental,
special, exemplary, or
consequential damages (including, but not limited to,
procurement of substitute goods or services; loss of use,
data, or profits; or business interruption) however caused
and on any theory of liability, whether in contract, strict
liability, or tort (including negligence or otherwise) arising in
any way out of such code.
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Library Description Licence

Curl 7.21.1 URL transfer
library

Copyright (c) 1996 - 2010, Daniel Stenberg,
<daniel@haxx.se>.

All rights reserved.

Permission to use, copy, modify, and distribute this
software for any purpose with or without fee is hereby
granted, provided that the above copyright notice and this
permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY
OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE
FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

Except as contained in this notice, the name of a copyright
holder shall not be used in advertising or otherwise to
promote the sale, use or other dealings in this Software
without prior written authorization of the copyright holder.
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Library Description Licence

EdenCGL Object file
loader

Copyright (c) 2001-2008, Philip Lamb, phil@eden.net.nz.

Licensed under the Apache License, Version 2.0 (the
"License"); you may not use this file except in compliance
with the License.

You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing,
software
distributed under the License is distributed on an "AS IS"
BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
KIND, either express or implied.

See the License for the specific language governing
permissions and
limitations under the License.
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Library Description Licence

Expat XML parser Copyright © 1998, 1999, 2000 Thai Open Source Software
Center Ltd and Clark Cooper

Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat
maintainers.

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the
“Software”), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify,
merge, publish,
distribute, sublicense, and/or sell copies of the Software,
and to permit persons to whom the Software is furnished to
do so, subject to the
following conditions:

The above copyright notice and this permission notice shall
be included in all copies or substantial portions of the
Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY
OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES
OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
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Library Description Licence

FBO Frame buffer
object library

Copyright (c) 2005,

Aaron Lefohn (lefohn@cs.ucdavis.edu)

Adam Moerschell (atmoerschell@ucdavis.edu)

All rights reserved.

This software is licensed under the BSD open-source
license. See http://www.opensource.org/licenses/bsd-
license.php for more detail.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of the University of California, Davis nor
the names of the contributors may be used to endorse or
promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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Library Description Licence

FreeType Font support Portions of this software are copyright © 2008 The FreeType
Project (www.freetype.org). All rights reserved.
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Library Description Licence

GLEW OpenGL
support

The OpenGL Extension Wrangler Library Copyright © 2002-
2008, Milan Ikits <milan ikits@ieee.org>

Copyright © 2002-2008, Marcelo E. Magallon
<mmagallo@debian.org>

Copyright © 2002, Lev Povalahev All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• The name of the author may be used to endorse or
promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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Library Description Licence

GLib 2.24.0 Core
application
building blocks
for applications
written in C;

used under
LGPL v2

GObject - GLib Type, Object, Parameter and Signal Library

Copyright (C) 2000-2001 Red Hat, Inc.

This library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation;
either version 2 of the License, or (at your option) any later
version.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU Lesser General Public
License for more details.

You should have received a copy of the GNU Lesser General
Public License along with this library; if not, write to the
Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307, USA.

To see the GNU Lesser General Public License, go to
http://www.gnu.org/licenses/ or
/Media/Help/CopyrightNotices in the Mari application
directory.
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Library Description Licence

GLSL Cellular Noise 2D and 3D
Cellular Noise

Copyright (c) 2011 by Stefan Gustavson
<stefan.gustavson@liu.se>

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the
"Software"), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify,
merge, publish,
distribute, sublicense, and/or sell copies of the Software,
and to permit persons to whom the Software is furnished to
do so, subject to the
following conditions:

The above copyright notice and this permission notice shall
be included in all copies or substantial portions of the
Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY
OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES
OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
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Library Description Licence

GLSL Perlin Noise Perlin noise
library

2D, 3D and 4D Perlin noise, classic and simplex, in a GLSL
fragment shader.

Classic noise is implemented by the functions:

• float noise(vec2 P)

• float noise(vec3 P)

• float noise(vec4 P)

Simplex noise is implemented by the functions:

• float snoise(vec2 P)

• float snoise(vec3 P)

• float snoise(vec4 P)

Author: Stefan Gustavson ITN-LiTH (stegu@itn.liu.se) 2004-
12-05

You may use, modify and redistribute this code free of
charge, provided that my name and this notice appears
intact.
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Library Description Licence

GLSL Classical
(Perlin) and
Simplex Noise

Perlin and
Simplex noise
library

Copyright (C) 2011 by Ashima Arts (Simplex noise)

Copyright (C) 2011 by Stefan Gustavson (Classic noise)

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the
"Software"), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify,
merge, publish,
distribute, sublicense, and/or sell copies of the Software,
and to permit persons to whom the Software is furnished to
do so, subject to the
following conditions:

The above copyright notice and this permission notice shall
be included in all copies or substantial portions of the
Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY
OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES
OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
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Library Description Licence

GTS Triangulated
surface library

This library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation;
either version 2 of the License, or (at your option) any later
version.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU Lesser General Public
License for more details.

To see the GNU Lesser General Public License, go to
http://www.gnu.org/licenses/ or
/Media/Help/CopyrightNotices in the Mari application
directory.

IJG JPEG File format
support

This software is based in part on the work of the
Independent JPEG Group.
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Library Description Licence

libnoise Perlin noise
library

Copyright (C) 2003, 2004 Jason Bevins

This library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation;
either version 2.1 of the License, or (at your option) any
later version.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU Lesser General Public
License (COPYING.txt) for more details.

You should have received a copy of the GNU Lesser General
Public License along with this library; if not, write to the
Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA

The developer's email is jlbezigvins@gmzigail.com (for great
email, take off every 'zig'.)

To see the GNU Lesser General Public License, go to
http://www.gnu.org/licenses/ or
/Media/Help/CopyrightNotices in the Mari application
directory.
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MD5 MD5 Algorithm Copyright (C) 1999, 2002 Aladdin Enterprises. All rights
reserved.

This software is provided ‘as-is’, without any express or
implied
warranty. In no event will the authors be held liable for any
damages arising from the use of this software.

Permission is granted to anyone to use this software for any
purpose, including commercial applications, and to alter it
and redistribute it freely, subject to the following
restrictions:

The origin of this software must not be misrepresented; you
must not claim that you wrote the original software. If you
use this software in a product, an acknowledgment in the
product documentation would be appreciated but is not
required.

Altered source versions must be plainly marked as such,
and must not be misrepresented as being the original
software.

This notice may not be removed or altered from any source
distribution.

L. Peter Deutsch ghost@aladdin.com
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Mouse
Gesture
Package

Mouse Gesture
Recognition
Package

Copyright (C) 2006 Johan Thelin <e8johan@gmail.com>

All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• The names of its contributors may be used to endorse or
promote products derived from this software without
specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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MSIntTypes r20 C++ Standards
compliant
stdint.h and
inttypes.h for
Microsoft Visual
Studio

ISO C9x compliant stdint.h for Microsoft Visual Studio

Based on ISO/IEC 9899:TC2 Committee draft (May 6, 2005)
WG14/N1124

Copyright (c) 2006 Alexander Chemeris

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

• The name of the author may be used to endorse or
promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS''
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.

APPENDIX C: EXTERNAL SOFTWARE | THIRD PARTY LICENSES



USER GUIDE 496

Library Description Licence

OpenColorIO OpenColorIO
library

Copyright (c) 2003-2010 Sony Pictures Imageworks Inc., et al.
All Rights Reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of Sony Pictures Imageworks nor the
names of its contributors may be used to endorse or
promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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OpenCV 2.0.0 Open Source
Computer
Vision library

IMPORTANT: READ BEFORE DOWNLOADING, COPYING,
INSTALLING OR USING.

By downloading, copying, installing or using the software
you agree to this license. If you do not agree to this license,
do not download, install, copy or use the software.

License Agreement For Open Source Computer Vision
Library

Copyright (C) 2000-2008, Intel Corporation, all rights
reserved.

Copyright (C) 2008-2009, Willow Garage Inc., all rights
reserved.

Third party copyrights are property of their respective
owners.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• The name of the copyright holders may not be used to
endorse or promote products derived from this software
without specific prior written permission.

This software is provided by the copyright holders and
contributors "as is" and any express or implied warranties,
including, but not
limited to, the implied warranties of merchantability and
fitness for a particular purpose are disclaimed. In no event
shall the Intel
Corporation or contributors be liable for any direct,
indirect,
incidental, special, exemplary, or consequential damages
(including, but not limited to, procurement of substitute
goods or services;
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OpenCV 2.0.0
(continued)

loss of use, data, or profits; or business interruption)
however caused and on any theory of liability, whether in
contract, strict liability, or tort (including negligence or
otherwise) arising in any way out of the use of this software,
even if advised of the possibility of such damage.
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OpenEXR File format
support

Copyright © 2002, Industrial Light & Magic, a division of
Lucas Digital Ltd. LLC All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of Industrial Light & Magic nor the
names of its
contributors may be used to endorse or promote
products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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OpenImageIO 1.0 A library for
reading and
writing images

OpenImageIO and all code, documentation, and other
materials
contained therein are:

Copyright 2008 Larry Gritz and the other authors and
contributors. All Rights Reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of the software's owners nor the names
of its
contributors may be used to endorse or promote
products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

(This is the Modified BSD License.)
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OpenSSL 1.0.0a A toolkit
implementing
the Secure
Sockets Layer
(SSL v2/v3) and
Transport Layer
Security (TLS v1)
protocols as
well as a full-
strength
general
purpose
cryptography
library

The OpenSSL toolkit stays under a dual license, i.e. both the
conditions of the OpenSSL License and the original SSLeay
license apply to the toolkit. See below for the actual license
texts. Actually both licenses are BSD-style Open Source
licenses. In case of any license issues related to OpenSSL
please contact
openssl-core@openssl.org.

OpenSSL License

Copyright (c) 1998-2008 The OpenSSL Project. All rights
reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

1. Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

2. Redistributions in binary form must reproduce the
above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other
materialso provided with the distribution.

3. All advertising materials mentioning features or use of
this software must display the following
acknowledgment:

"This product includes software developed by the
OpenSSL Project for use in the OpenSSL Toolkit.
(http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project"
must not be used to endorse or promote products
derived from this software without prior written
permission. For written permission, please contact
openssl-core@openssl.org.

5. Products derived from this software may not be called
"OpenSSL" nor may "OpenSSL" appear in their names
without prior written permission of the OpenSSL
Project.

6. Redistributions of any form whatsoever must retain the
following acknowledgment:

"This product includes software developed by the OpenSSL
Project for use in the OpenSSL Toolkit
(http://www.openssl.org/)"
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OpenSSL 1.0.0a
(continued)

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT
``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

This product includes cryptographic software written by Eric
Young (eay@cryptsoft.com). This product includes software
written by Tim Hudson
(tjh@cryptsoft.com).

Original SSLeay License

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)

All rights reserved.

This package is an SSL implementation written by Eric
Young (eay@cryptsoft.com).

The implementation was written so as to conform with
Netscapes SSL.

This library is free for commercial and non-commercial use
as long as the following conditions are aheared to. The
following conditions apply to all code found in this
distribution, be it the RC4, RSA, lhash, DES, etc., code; not
just the SSL code. The SSL documentation included with this
distribution is covered by the same copyright terms except
that the holder is Tim Hudson (tjh@cryptsoft.com).
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OpenSSL 1.0.0a
(continued)

Copyright remains Eric Young's, and as such any Copyright
notices in the code are not to be removed.

If this package is used in a product, Eric Young should be
given
attribution as the author of the parts of the library used.

This can be in the form of a textual message at program
startup or in documentation (online or textual) provided
with the package.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

1. Redistributions of source code must retain the copyright
notice, this list of conditions and the following
disclaimer.

2. Redistributions in binary form must reproduce the
above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

3. All advertising materials mentioning features or use of
this software must display the following
acknowledgement:

"This product includes cryptographic software written by
Eric Young (eay@cryptsoft.com)"

The word 'cryptographic' can be left out if the routines
from the library being used are not cryptographic
related.

4. If you include any Windows specific code (or a derivative
thereof) from the apps directory (application code) you
must include an acknowledgement:

"This product includes software written by Tim Hudson
(tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.
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OpenSSL 1.0.0a
(continued)

IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

The licence and distribution terms for any publically
available
version or derivative of this code cannot be changed. i.e.
this code cannot simply be copied and put under another
distribution licence [including the GNU Public Licence.]
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Partio C++ (with
Python
bindings) library
for reading,
writing, and
manipulating
common
animation
particle
formats.

PARTIO SOFTWARE

Copyright 2010-2011 Disney Enterprises, Inc. All rights
reserved

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

• The names "Disney", "Walt Disney Pictures", "Walt Disney
Animation Studios" or the names of its contributors may
NOT be used to endorse or promote products derived
from this software without specific prior written
permission from Walt Disney Pictures.

Disclaimer: THIS SOFTWARE IS PROVIDED BY WALT DISNEY
PICTURES AND CONTRIBUTORS "AS IS" AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT
AND TITLE ARE DISCLAIMED. IN NO EVENT SHALL WALT
DISNEY PICTURES, THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND BASED ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
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PSD PSD file
support. Based
on Disney
software.

PSD file support includes Disney technology licensed from
Walt
Disney Animation Studios.
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Ptex Ptex library Copyright 2009 Disney Enterprises, Inc. All rights reserved

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

The names “Disney”, “Walt Disney Pictures”, “Walt Disney
Animation Studios” or the names of its contributors may
NOT be used to endorse or promote products derived from
this software without specific prior written permission from
Walt Disney Pictures.

Disclaimer: THIS SOFTWARE IS PROVIDED BY WALT DISNEY
PICTURES AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT
AND TITLE ARE DISCLAIMED. IN NO EVENT SHALL WALT
DISNEY PICTURES, THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND BASED ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
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PySide Python bindings
library for Qt

This file is part of PySide: Python for Qt

Copyright (C) 2009-2010 Nokia Corporation and/or its
subsidiary(-ies).

Contact: PySide team <contact@pyside.org>

This library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License version 2.1 as published by the Free Software
Foundation.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU Lesser General Public
License for more details.

You should have received a copy of the GNU Lesser General
Public License along with this library; if not, write to the
Free Software Foundation, Inc., 51 Franklin St, Fifth Floor,
Boston, MA 02110-1301 USA

Python 2.7.3 Source code
language

Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008,
2009, 2010 Python Software Foundation; All Rights Reserved
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Pystring Pystring library Copyright (c) 2008-2010, Sony Pictures Imageworks Inc All
rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.
Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the
documentation and/or other materials provided with the
distribution. Neither the name of the organization Sony
Pictures Imageworks nor the names of its contributors may
be used to endorse or promote products derived from this
software without specific prior written permission. THIS
SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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Qt Application and
UI framework

The Qt GUI Toolkit is Copyright (C) 2009 Nokia Corporation
and/or its subsidiary(-ies).

Contact: Qt Software Information (qt-info@nokia.com)

Qt is available under the LGPL.

Nokia Qt LGPL Exception version 1.0:

As a special exception to the GNU Lesser General Public
License
version 2.1, the object code form of a "work that uses the
Library" may incorporate material from a header file that is
part of the Library. You may distribute such object code
under terms of your choice, provided that the incorporated
material (i) does not exceed more than 5% of the total size
of the Library; and (ii) is limited to numerical parameters,
data structure layouts, accessors, macros, inline functions
and templates.

To see the GNU Lesser General Public License, go to
http://www.gnu.org/licenses/ or
/Media/Help/CopyrightNotices in the Mari application
directory.
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QtSingleApplication A QtSolutions
archive
component
which provides
support for
applications
that can be only
started once
per user; used
under LGPL

Copyright (c) 2009 Nokia Corporation and/or its subsidiary(-
ies).

All rights reserved.

Contact: Nokia Corporation (qt-info@nokia.com)

This file is part of a Qt Solutions component.

Commercial Usage

Licensees holding valid Qt Commercial licenses may use
this file in accordance with the Qt Solutions Commercial
License Agreement provided with the Software or,
alternatively, in accordance with the terms contained in a
written agreement between you and Nokia.

GNU Lesser General Public License Usage

Alternatively, this file may be used under the terms of the
GNU Lesser General Public License version 2.1 as published
by the Free Software Foundation and appearing in the file
LICENSE.LGPL included in the packaging of this file. Please
review the following information to ensure the GNU Lesser
General Public License version 2.1 requirements will be
met:
http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.

In addition, as a special exception, Nokia gives you certain
additional rights. These rights are described in the Nokia Qt
LGPL Exception version 1.1, included in the file LGPL_
EXCEPTION.txt in this package.

GNU General Public License Usage

Alternatively, this file may be used under the terms of the
GNU General Public License version 3.0 as published by the
Free Software Foundation and appearing in the file
LICENSE.GPL included in the packaging of this file. Please
review the following information to ensure the GNU
General Public License version 3.0 requirements will be
met: http://www.gnu.org/copyleft/gpl.html.
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QtSingleApplication
(continued)

Please note Third Party Software included with Qt Solutions
may impose additional restrictions and it is the user's
responsibility to ensure that they have met the licensing
requirements of the GPL, LGPL, or Qt Solutions Commercial
license and the relevant license of the Third Party Software
they are using.

If you are unsure which license is appropriate for your use,
please contact Nokia at qt-info@nokia.com.

To see the GNU Lesser General Public License, go to
http://www.gnu.org/licenses/ or
/Media/Help/CopyrightNotices in the Mari application
directory.

QuaZip Qt zip wrapper Copyright (C) 2005 Sergey A. Tachenov

Released under the GNU Lesser General Public License.

Qwt Qt widgets for
technical
applications

Mari is based in part on the work of the Qwt project
(http://qwt.sf.net).
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SGI virtual
trackball

Virtual trackball
for interacting
with 3D objects

(c) Copyright 1993, 1994, Silicon Graphics, Inc.

ALL RIGHTS RESERVED

Permission to use, copy, modify, and distribute this
software for any purpose and without fee is hereby granted,
provided that the above copyright notice appear in all
copies and that both the copyright notice and this
permission notice appear in supporting documentation,
and that the name of Silicon Graphics, Inc. not be used in
advertising or publicity pertaining to distribution of the
software without specific, written prior permission.

THE MATERIAL EMBODIED ON THIS SOFTWARE IS PROVIDED
TO YOU "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT
LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL
SILICON GRAPHICS, INC. BE LIABLE TO YOU OR ANYONE
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SGI virtual
trackball
(continued)

ELSE FOR ANY DIRECT, SPECIAL, INCIDENTAL, INDIRECT OR
CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY
DAMAGES WHATSOEVER, INCLUDING WITHOUT
LIMITATION, LOSS OF PROFIT, LOSS OF USE, SAVINGS OR
REVENUE, OR THE CLAIMS OF THIRD PARTIES, WHETHER OR
NOT SILICON GRAPHICS, INC. HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH LOSS, HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY, ARISING OUT OF OR IN
CONNECTION WITH THE POSSESSION, USE OR
PERFORMANCE OF THIS SOFTWARE.

US Government Users Restricted Rights

Use, duplication, or disclosure by the Government is
subject to restrictions set forth in FAR 52.227.19(c)(2) or
subparagraph (c)(1)(ii) of the Rights in Technical Data and
Computer Software clause at DFARS 252.227-7013 and/or in
similar or successor clauses in the FAR or the DOD or NASA
FAR Supplement. Unpublished-- rights reserved under the
copyright laws of the United States.
Contractor/manufacturer is Silicon Graphics, Inc., 2011 N.
Shoreline Blvd., Mountain View, CA 94039-7311.

OpenGL(TM) is a trademark of Silicon Graphics, Inc.

============

Trackball code:

Implementation of a virtual trackball.

Implemented by Gavin Bell, lots of ideas from Thant
Tessman and the August '88 issue of Siggraph's "Computer
Graphics," pp. 121-129.

Vector manip code:

Original code from: David M. Ciemiewicz, Mark Grossman,
Henry Moreton, and Paul Haeberli

Much mucking with by: Gavin Bell
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Skein-Hash Hashing library Source code author: Doug Whiting, 2008.

This algorithm and source code is released to the public
domain.

Copyright (c) 2003, Dr Brian Gladman, Worcester, UK. All
rights reserved.

LICENSE TERMS

The free distribution and use of this software in both source
and binary form is allowed (with or without changes)
provided that:

1. distributions of this source code include the above
copyright notice, this list of conditions and the following
disclaimer;

2. distributions in binary form include the above copyright
notice, this list of conditions and the following
disclaimer in the documentation and/or other
associated materials;

3. the copyright holder's name is not used to endorse
products built using this software without specific
written permission.

ALTERNATIVELY, provided that this notice is retained in full,
this product may be distributed under the terms of the
GNU General Public License (GPL), in which case the
provisions of the GPL apply INSTEAD OF those given above.

DISCLAIMER

This software is provided 'as is' with no explicit or implied
warranties in respect of its properties, including, but not
limited to, correctness and/or fitness for purpose.
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Library Description Licence

Tri Stripper Geometry
optimisation
library

Copyright (C) 2004 Tanguy Fautrv©.

This software is provided 'as-is', without any express or
implied
warranty. In no event will the authors be held liable for any
damages arising from the use of this software.

Permission is granted to anyone to use this software for any
purpose, including commercial applications, and to alter it
and
redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented;
you must not claim that you wrote the original software.
If you use this software in a product, an
acknowledgment in the product documentation would
be appreciated but is not required.

2. Altered source versions must be plainly marked as such,
and must not be misrepresented as being the original
software.

3. This notice may not be removed or altered from any
source
distribution.

Tanguy Fautrv©

softdev@telenet.be
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Library Description Licence

Wild Magic 5 Math and
computer
graphics library

Geometric Tools, LLC

Copyright (c) 1998-2014

Distributed under the Boost Software License, Version 1.0.

Boost Software License: Version 1.0; August 17th, 2003

Permission is hereby granted, free of charge, to any person
or organization obtaining a copy of the software and
accompanying documentation covered by this license (the
"Software") to use, reproduce, display, distribute, execute,
and transmit the Software, and to prepare derivative works
of the Software, and to permit third-parties to whom the
Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire
statement, including the above license grant, this restriction
and the following disclaimer, must be included in all copies
of the Software, in whole or in part, and all derivative works
of the Software, unless such copies or derivative works are
solely in the form of machine-executable object code
generated by a source language processor.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY
OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-
INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT
HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE
LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER
IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT
OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
OR OTHER DEALINGS IN THE SOFTWARE.

Modo Third Party Libraries
The following are third party libraries for Modo, which are bundled as part of Mari in order for certain
cross-product functionality to behave correctly.
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NOTE: If, for any reason, you think The Foundry is not entitled to use these libraries or fonts,
please contact support@thefoundry.co.uk.

Third Party Libraries

Library Library

Alembic NVIDIA Texture Tools

Boost Open EXR

Bullet openjpeg

Collada OpenNURBS

FBX OpenSSL

HDF5 Perl

libJpeg PySide

libPng Python

libTiff tinyxml

Lua zlib

minizip zlib125

muParser zlibopennurbs

Third Party Library Licenses

The following table lists third party libraries and their licenses.
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Contributor Description License

Alembic File format
support

TM & © 2010-2012 Lucasfilm Entertainment Company Ltd. or
Lucasfilm Ltd. All rights reserved.

Industrial Light & Magic, ILM and the Bulb and Gear design
logo are all registered trademarks or service marks of
Lucasfilm Ltd.

© 2010-2012 Sony Pictures Imageworks Inc. All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

• Neither the name of Industrial Light & Magic nor the names
of its contributors may be used to endorse or promote
products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.
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Contributor Description License

Boost Source code
function /
template library

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or
organization obtaining a copy of the software and
accompanying documentation covered by this license (the
"Software") to use, reproduce, display, distribute, execute, and
transmit the Software, and to prepare derivative works of the
Software, and to permit third-parties to whom the Software is
furnished to do so, all subject to the following:

The copyright notices in the Software and this entire
statement, including the above license grant, this restriction
and the following disclaimer, must be included in all copies of
the Software, in whole or in part, and all derivative works of
the Software, unless such copies or derivative works are solely
in the form of machine-executable object code generated by a
source language processor.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT.
IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE
DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES
OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
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Contributor Description License

Bullet Uses the zlib license.

Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or
implied warranty. In no event will the authors be held liable for
any damages arising from the use of this software.

Permission is granted to anyone to use this software for any
purpose, including commercial applications, and to alter it and
redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented;
you must not claim that you wrote the original software. If
you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is
not required.

2. Altered source versions must be plainly marked as such,
and must not be misrepresented as being the original
software.

3. This notice may not be removed or altered from any
source distribution.

Jean-loup Gailly - jloup@gzip.org

Mark Adler - madler@alumni.caltech.edu
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Contributor Description License

Collada

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software
without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
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Contributor Description License

Autodesk FBX File format
support

This software contains Autodesk® FBX® code developed by
Autodesk, Inc. Copyright 2008 Autodesk, Inc. All rights,
reserved. Such code is provided “as is” and Autodesk, Inc.
disclaims any and all warranties, whether express or implied,
including without limitation the implied warranties of
merchantability, fitness for a particular purpose or non-
infringement of third party rights. In no event shall Autodesk,
Inc. be liable for any direct, indirect, incidental, special,
exemplary, or consequential damages (including, but not
limited to, procurement of substitute goods or services; loss of
use, data, or profits; or business interruption) however caused
and on any theory of liability, whether in contract, strict
liability, or tort (including negligence or otherwise) arising in
any way out of such code.
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Contributor Description License

HDF5 A data model,
library, and file
format for
storing and
managing data

Copyright Notice and License Terms for HDF5 (Hierarchical
Data Format 5) Software Library and Utilities

HDF5 (Hierarchical Data Format 5) Software Library and
Utilities Copyright 2006-2012 by The HDF Group.

NCSA HDF5 (Hierarchical Data Format 5) Software Library and
Utilities Copyright 1998-2006 by the Board of Trustees of the
University of Illinois.

All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted for any purpose (including
commercial purposes) provided that the following conditions
are met:

1. Redistributions of source code must retain the above
copyright notice, this list of conditions, and the following
disclaimer.

2. Redistributions in binary form must reproduce the above
copyright notice, this list of conditions, and the following
disclaimer in the documentation and/or materials provided
with the distribution.

3. In addition, redistributions of modified forms of the source
or binary code must carry prominent notices stating that
the original code was changed and the date of the change.

4. All publications or advertising materials mentioning
features or use of this software are asked, but not
required, to acknowledge that it was developed by The HDF
Group and by the National Center for Supercomputing
Applications at the University of Illinois at Urbana-
Champaign and credit the contributors.

5. Neither the name of The HDF Group, the name of the
University, nor the name of any Contributor may be used
to endorse or promote products derived from this
software without specific prior written permission from
The HDF Group, the University, or the Contributor,
respectively.
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Contributor Description License

HDF5
(continued)

DISCLAIMER:

THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE
CONTRIBUTORS "AS IS" WITH NOWARRANTY OF ANY KIND,
EITHER EXPRESSED OR IMPLIED. In no event shall The HDF
Group or the Contributors be liable for any damages suffered
by the users arising out of the use of this software, even if
advised of the possibility of such damage.

Contributors: National Center for Supercomputing
Applications (NCSA) at the University of Illinois, Fortner
Software, Unidata Program Center (netCDF), The Independent
JPEG Group (JPEG), Jean-loup Gailly and Mark Adler (gzip), and
Digital Equipment Corporation (DEC).

Portions of HDF5 were developed with support from the
Lawrence Berkeley National Laboratory (LBNL) and the United
States Department of Energy under Prime Contract No. DE-
AC02-05CH11231.

Portions of HDF5 were developed with support from the
University of California, Lawrence Livermore National
Laboratory (UC LLNL). The following statement applies to
those portions of the product and must be retained in any
redistribution of source code, binaries, documentation, and/or
accompanying materials:

This work was partially produced at the University of
California, Lawrence Livermore National Laboratory (UC LLNL)
under contract no. W-7405-ENG-48 (Contract 48) between the
U.S. Department of Energy (DOE) and The Regents of the
University of California (University) for the operation of UC
LLNL.

DISCLAIMER:

This work was prepared as an account of work sponsored by
an agency of the United States Government. Neither the
United States Government nor the University of California nor
any of their employees, makes any warranty, express or
implied, or assumes any liability or responsibility for the
accuracy, completeness, or usefulness of any information,
apparatus, product, or process disclosed, or represents that its
use would not infringe privately- owned rights.
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Contributor Description License

HDF5
(continued)

Reference herein to any specific commercial products,
process, or service by trade name, trademark, manufacturer,
or otherwise, does not necessarily constitute or imply its
endorsement, recommendation, or favoring by the United
States Government or the University of California. The views
and opinions of authors expressed herein do not necessarily
state or reflect those of the United States Government or the
University of California, and shall not be used for advertising
or product endorsement purposes.
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Contributor Description License

libJpeg File format
support

This software is the work of Tom Lane, Philip Gladstone, Jim
Boucher, Lee Crocker, Julian Minguillon, Luis Ortiz, George
Phillips, Davide Rossi, Guido Vollbeding, Ge' Weijers, and
other members of the Independent JPEG Group.

IJG is not affiliated with the official ISO JPEG standards
committee.

The authors make NOWARRANTY or representation, either
express or implied, with respect to this software, its quality,
accuracy, merchantability, or fitness for a particular purpose.
This software is provided "AS IS", and you, its user, assume the
entire risk as to its quality and accuracy.

This software is copyright (C) 1991-1998, Thomas G. Lane. All
Rights Reserved except as specified below.

Permission is hereby granted to use, copy, modify, and
distribute this software (or portions thereof) for any purpose,
without fee, subject to these conditions:

(1) If any part of the source code for this software is
distributed, then this README file must be included, with this
copyright and no-warranty notice unaltered; and any additions,
deletions, or changes to the original files must be clearly
indicated in accompanying documentation.

(2) If only executable code is distributed, then the
accompanying documentation must state that "this software is
based in part on the work of the Independent JPEG Group".

(3) Permission for use of this software is granted only if the
user accepts full responsibility for any undesirable
consequences; the authors accept NO LIABILITY for damages
of any kind.
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Contributor Description License

libJpeg
(continued)

These conditions apply to any software derived from or based
on the IJG code, not just to the unmodified library. If you use
our work, you ought to acknowledge us.

Permission is NOT granted for the use of any IJG author's
name or company name in advertising or publicity relating to
this software or products derived from it. This software may be
referred to only as "the Independent JPEG Group's software".

We specifically permit and encourage the use of this software
as the basis of commercial products, provided that all
warranty or liability claims are assumed by the product
vendor.

ansi2knr.c is included in this distribution by permission of L.
Peter Deutsch, sole proprietor of its copyright holder, Aladdin
Enterprises of Menlo Park, CA. ansi2knr.c is NOT covered by
the above copyright and conditions, but instead by the usual
distribution terms of the Free Software Foundation;
principally, that you must include source code if you
redistribute it. (See the file ansi2knr.c for full details.) However,
since ansi2knr.c is not needed as part of any program
generated from the IJG code, this does not limit you more than
the foregoing paragraphs do.

The Unix configuration script "configure" was produced with
GNU Autoconf. It is copyright by the Free Software Foundation
but is freely distributable. The same holds for its supporting
scripts (config.guess, config.sub, ltconfig, ltmain.sh). Another
support script, install-sh, is copyright by M.I.T. but is also freely
distributable.

It appears that the arithmetic coding option of the JPEG spec is
covered by patents owned by IBM, AT&amp;T, and Mitsubishi.
Hence arithmetic coding cannot legally be used without
obtaining one or more licenses. For this reason, support for
arithmetic coding has been removed from the free JPEG
software. (Since arithmetic coding provides only a marginal
gain over the unpatented Huffman mode, it is unlikely that
very many implementations will support it.) So far as we are
aware, there are no patent restrictions on the remaining code.
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Contributor Description License

libJpeg
(continued)

The IJG distribution formerly included code to read and write
GIF files. To avoid entanglement with the Unisys LZW patent,
GIF reading support has been removed altogether, and the GIF
writer has been simplified to produce "uncompressed GIFs".
This technique does not use the LZW algorithm; the resulting
GIF files are larger than usual, but are readable by all standard
GIF decoders.

We are required to state that "The Graphics Interchange
Format(c) is the Copyright property of CompuServe
Incorporated. GIF(sm) is a Service Mark property of
CompuServe Incorporated."
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Contributor Description License

libPng File format
support

If you modify libpng you may insert additional notices
immediately following this sentence.

This code is released under the libpng license.

libpng versions 1.2.6, August 15, 2004, through 1.5.12, July 11,
2012, are Copyright (c) 2004, 2006-2012 Glenn Randers-
Pehrson, and are distributed according to the same disclaimer
and license as libpng-1.2.5 with the following individual added
to the list of Contributing Authors:

• Cosmin Truta

libpng versions 1.0.7, July 1, 2000, through 1.2.5 - October 3,
2002, are Copyright (c) 2000-2002 Glenn Randers-Pehrson, and
are distributed according to the same disclaimer and license
as libpng-1.0.6 with the following individuals added to the list
of Contributing Authors:

• Simon-Pierre Cadieux

• Eric S. Raymond

• Gilles Vollant

and with the following additions to the disclaimer:

There is no warranty against interference with your enjoyment
of the library or against infringement. There is no warranty
that our efforts or the library will fulfill any of your particular
purposes or needs. This library is provided with all faults, and
the entire risk of satisfactory quality, performance, accuracy,
and effort is with the user.
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Contributor Description License

libPng
(continued)

libpng versions 0.97, January 1998, through 1.0.6, March 20,
2000, are Copyright (c) 1998, 1999 Glenn Randers-Pehrson, and
are distributed according to the same disclaimer and license
as libpng-0.96, with the following individuals added to the list
of Contributing Authors:

• Tom Lane

• Glenn Randers-Pehrson

• Willem van Schaik

libpng versions 0.89, June 1996, through 0.96, May 1997, are
Copyright (c) 1996, 1997 Andreas Dilger

Distributed according to the same disclaimer and license as
libpng-0.88, with the following individuals added to the list of
Contributing Authors:

• John Bowler

• Kevin Bracey

• Sam Bushell

• Magnus Holmgren

• Greg Roelofs

• Tom Tanner

libpng versions 0.5, May 1995, through 0.88, January 1996, are
Copyright (c) 1995, 1996 Guy Eric Schalnat, Group 42, Inc.

For the purposes of this copyright and license, "Contributing
Authors" is defined as the following set of individuals:

• Andreas Dilger

• Dave Martindale

• Guy Eric Schalnat

• Paul Schmidt

• Tim Wegner
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Contributor Description License

libPng
(continued)

The PNG Reference Library is supplied "AS IS". The
Contributing Authors and Group 42, Inc. disclaim all
warranties, expressed or implied, including, without limitation,
the warranties of merchantability and of fitness for any
purpose. The Contributing Authors and Group 42, Inc. assume
no liability for direct, indirect, incidental, special, exemplary, or
consequential damages, which may result from the use of the
PNG Reference Library, even if advised of the possibility of
such damage. Permission is hereby granted to use, copy,
modify, and distribute this source code, or portions hereof, for
any purpose, without fee, subject to the following restrictions:

• The origin of this source code must not be misrepresented.

• Altered versions must be plainly marked as such and must
not be misrepresented as being the original source.

• This Copyright notice may not be removed or altered from
any source or altered source distribution.

The Contributing Authors and Group 42, Inc. specifically
permit, without fee, and encourage the use of this source code
as a component to supporting the PNG file format in
commercial products. If you use this source code in a product,
acknowledgment is not required but would be appreciated.

A "png_get_copyright" function is available, for convenient use
in "about" boxes and the like:
printf("%s",png_get_copyright(NULL));

Also, the PNG logo (in PNG format, of course) is supplied in
the files "pngbar.png" and "pngbar.jpg (88x31) and
"pngnow.png" (98x31). Libpng is OSI Certified Open Source
Software. OSI Certified Open Source is a certification mark of
the Open Source Initiative.

Glenn Randers-Pehrson

glennrp at users.sourceforge.net

July 11, 2012
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Contributor Description License

libTiff File format
support

Copyright (c) 1988-1997 Sam Leffler

Copyright (c) 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this
software and its documentation for any purpose is hereby
granted without fee, provided that (i) the above copyright
notices and this permission notice appear in all copies of the
software and related documentation, and (ii) the names of
Sam Leffler and Silicon Graphics may not be used in any
advertising or publicity relating to the software without the
specific, prior written permission of Sam Leffler and Silicon
Graphics.

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT
WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR OTHERWISE,
INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR
CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF
DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF
OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
SOFTWARE.
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Contributor Description License

Lua Source code
language

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software
without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
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Contributor Description License

minizip Library to deflate
compressed files

Uses the zlib license.

Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or
implied warranty. In no event will the authors be held liable for
any damages arising from the use of this software.

Permission is granted to anyone to use this software for any
purpose, including commercial applications, and to alter it and
redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented;
you must not claim that you wrote the original software. If
you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is
not required.

2. Altered source versions must be plainly marked as such,
and must not be misrepresented as being the original
software.

3. This notice may not be removed or altered from any
source distribution.

Jean-loup Gailly - jloup@gzip.org

Mark Adler - madler@alumni.caltech.edu
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Contributor Description License

muParser

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software
without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
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Contributor Description License

NVIDIA Texture
Tools

A collection of
image
processing and
texture
manipulation
tools.

Copyright (c) <year> <copyright holders>

Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software
without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
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Contributor Description License

Open EXR File format
support

Copyright (c) 2002-2011, Industrial Light & Magic, a division of
Lucasfilm Entertainment Company Ltd. All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

• Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

• Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

• Neither the name of Industrial Light & Magic nor the names
of its contributors may be used to endorse or promote
products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.
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Contributor Description License

openjpeg Copyright (c) 1998, Regents of the University of California

All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

1. Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

2. Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.
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Contributor Description License

OpenNURBS Copyright (c) 1993-2006 Robert McNeel & Associates. All Rights
Reserved. Rhinoceros is a registered trademark of Robert
McNeel & Associates.

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR
IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS
FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY
ARE HEREBY DISCLAIMED.

The openNURBS Initiative provides CAD, CAM, CAE, and
computer graphics software developers the tools to accurately
transfer 3-D geometry between applications.

The tools provided by openNURBS include:

• C++ source code libraries to read and write the file format.

• Quality assurance and revision control.

• Various supporting libraries and utilities.

• Technical support.

Unlike other open development initiatives, alliances, or
consortia:

• Commercial use is encouraged.

• The tools, support, and membership are free.

• There are no restrictions. Neither copyright nor copyleft
restrictions apply.

• No contribution of effort or technology is required from the
members, although it is encouraged.

For more information, please see http://www.openNURBS.org.
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Contributor Description License

OpenSSL Socket and
encryption
libraries

Copyright 1998-2011

The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the
following conditions are met:

1. Redistributions of source code must retain the above
copyright notice, this list of conditions and the following
disclaimer.

2. Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials
provided with the distribution.

3. All advertising materials mentioning features or use of this
software must display the following acknowledgment: "This
product includes software developed by the OpenSSL
Project for use in the OpenSSL Toolkit.
(http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must
not be used to endorse or promote products derived from
this software without prior written permission. For written
permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called
"OpenSSL" nor may "OpenSSL" appear in their names
without prior written permission of the OpenSSL Project. 6.
Redistributions of any form whatsoever must retain the
following acknowledgment: "This product includes
software developed by the OpenSSL Project for use in the
OpenSSL Toolkit (http://www.openssl.org/)"
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Contributor Description License

OpenSSL
(continued)

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS
IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL
PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric
Young (eay@cryptsoft.com). This product includes software
written by Tim Hudson (tjh@cryptsoft.com).
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Contributor Description License

Perl Source code
language; used
for an SDK
sample

The "Artistic License"

Preamble

The intent of this document is to state the conditions under
which a Package may be copied, such that the Copyright
Holder maintains some semblance of artistic control over the
development of the package, while giving the users of the
package the right to use and distribute the Package in a more-
or-less customary fashion, plus the right to make reasonable
modifications.

Definitions:

"Package" refers to the collection of files distributed by the
Copyright Holder, and derivatives of that collection of files
created through textual modification.

"Standard Version" refers to such a Package if it has not been
modified, or has been modified in accordance with the wishes
of the Copyright Holder as specified below.

"Copyright Holder" is whoever is named in the copyright or
copyrights for the package.
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Contributor Description License

Perl (continued) "You" is you, if you're thinking about copying or distributing
this Package.

"Reasonable copying fee" is whatever you can justify on the
basis of media cost, duplication charges, time of people
involved, and so on. (You will not be required to justify it to the
Copyright Holder, but only to the computing community at
large as a market that must bear the fee.)

"Freely Available" means that no fee is charged for the item
itself, though there may be fees involved in handling the item.
It also means that recipients of the item may redistribute it
under the same conditions they received it.

1. You may make and give away verbatim copies of the
source form of the Standard Version of this Package
without restriction, provided that you duplicate all of the
original copyright notices and associated disclaimers.

2. You may apply bug fixes, portability fixes and other
modifications derived from the Public Domain or from the
Copyright Holder. A Package modified in such a way shall
still be considered the Standard Version.

3. You may otherwise modify your copy of this Package in any
way, provided that you insert a prominent notice in each
changed file stating how and when you changed that file,
and provided that you do at least ONE of the following:

a) place your modifications in the Public Domain or
otherwise make them Freely Available, such as by posting
said modifications to Usenet or an equivalent medium, or
placing the modifications on a major archive site such as
uunet.uu.net, or by allowing the Copyright Holder to
include your modifications in the Standard Version of the
Package.

b) use the modified Package only within your corporation
or organization.

c) rename any non-standard executables so the names do
not conflict with standard executables, which must also be
provided, and provide a separate manual page for each
non-standard executable that clearly documents how it
differs from the Standard Version.

d) make other distribution arrangements with the
Copyright Holder.
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Contributor Description License

Perl (continued) 4. You may distribute the programs of this Package in object
code or executable form, provided that you do at least ONE
of the following:

a) distribute a Standard Version of the executables and
library files, together with instructions (in the manual page
or equivalent) on where to get the Standard Version.

b) accompany the distribution with the machine-readable
source of the Package with your modifications.

c) give non-standard executables non-standard names, and
clearly document the differences in manual pages (or
equivalent), together with instructions on where to get the
Standard Version.

d) make other distribution arrangements with the
Copyright Holder.

5. You may charge a reasonable copying fee for any
distribution of this Package. You may charge any fee you
choose for support of this Package. You may not charge a
fee for this Package itself. However, you may distribute this
Package in aggregate with other (possibly commercial)
programs as part of a larger (possibly commercial)
software distribution provided that you do not advertise
this Package as a product of your own. You may embed
this Package's interpreter within an executable of yours (by
linking); this shall be construed as a mere form of
aggregation, provided that the complete Standard Version
of the interpreter is so embedded.

6. The scripts and library files supplied as input to or
produced as output from the programs of this Package do
not automatically fall under the copyright of this Package,
but belong to whoever generated them, and may be sold
commercially, and may be aggregated with this Package. If
such scripts or library files are aggregated with this
Package via the so-called "undump" or "unexec" methods
of producing a binary executable image, then distribution
of such an image shall neither be construed as a
distribution of this Package nor shall it fall under the
restrictions of Paragraphs 3 and 4, provided that you do
not represent such an executable image as a Standard
Version of this Package.
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Contributor Description License

Perl (continued) 7. C subroutines (or comparably compiled subroutines in
other languages) supplied by you and linked into this
Package in order to emulate subroutines and variables of
the language defined by this Package shall not be
considered part of this Package, but are the equivalent of
input as in Paragraph 6, provided these subroutines do not
change the language in any way that would cause it to fail
the regression tests for the language.

8. Aggregation of this Package with a commercial distribution
is always permitted provided that the use of this Package is
embedded; that is, when no overt attempt is made to make
this Package's interfaces visible to the end user of the
commercial distribution. Such use shall not be construed
as a distribution of this Package.

9. The name of the Copyright Holder may not be used to
endorse or promote products derived from this software
without specific prior written permission.

THIS PACKAGE IS PROVIDED "AS IS" AND WITHOUT ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, WITHOUT
LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTIBILITY
AND FITNESS FOR A PARTICULAR PURPOSE.

PySide Python bindings
for Qt

PySide is licensed under the terms of the GNU Lesser General
Public License on page 548 (LGPL, version 2.1).

For more info on PySide, please go to the PySide website:
http://www.pyside.org/

Python Source code
language

Copyright © 2001, 2002, 2003, 2004 Python Software
Foundation;

All Rights Reserved.

Licensed under the PSF license for Python 2.6.

For more detail refer to
https://docs.python.org/2.6/license.html.
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Contributor Description License

tinyxml Uses the zlib license.

Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or
implied warranty. In no event will the authors be held liable for
any damages arising from the use of this software.

Permission is granted to anyone to use this software for any
purpose, including commercial applications, and to alter it and
redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented;
you must not claim that you wrote the original software. If
you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is
not required.

2. Altered source versions must be plainly marked as such,
and must not be misrepresented as being the original
software.

3. This notice may not be removed or altered from any
source distribution.

Jean-loup Gailly - jloup@gzip.org

Mark Adler - madler@alumni.caltech.edu
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Contributor Description License

zlib, zlib125,
zlibopennurbs

Compression
library

General purpose compression library version 1.2.8, April 28th,
2013

Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or
implied warranty. In no event will the authors be held liable for
any damages arising from the use of this software.

Permission is granted to anyone to use this software for any
purpose, including commercial applications, and to alter it and
redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented;
you must not claim that you wrote the original software. If
you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is
not required.

2. Altered source versions must be plainly marked as such,
and must not be misrepresented as being the original
software.

3. This notice may not be removed or altered from any
source distribution.

Jean-loup Gailly - jloup@gzip.org

Mark Adler - madler@alumni.caltech.edu

GNU Lesser General Public License

Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA Everyone is permitted to copy and distribute verbatim copies of this license
document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library
Public License, version 2, hence the version number 2.1.]

Preamble
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The licenses for most software are designed to take away your freedom to share and change it. By
contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and
change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially designated software
packages--typically libraries--of the Free Software Foundation and other authors who decide to use it.
You can use it too, but we suggest you first think carefully about whether this license or the ordinary
General Public License is the better strategy to use in any particular case, based on the explanations
below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public
Licenses are designed to make sure that you have the freedom to distribute copies of free software
(and charge for this service if you wish); that you receive source code or can get it if you want it; that
you can change the software and use pieces of it in new free programs; and that you are informed
that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights
or to ask you to surrender these rights. These restrictions translate to certain responsibilities for you
if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the
recipients all the rights that we gave you. You must make sure that they, too, receive or can get the
source code. If you link other code with the library, you must provide complete object files to the
recipients, so that they can relink them with the library after making changes to the library and
recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this
license, which gives you legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library.
Also, if the library is modified by someone else and passed on, the recipients should know that what
they have is not the original version, so that the original author's reputation will not be affected by
problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to
make sure that a company cannot effectively restrict the users of a free program by obtaining a
restrictive license from a patent holder. Therefore, we insist that any patent license obtained for a
version of the library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License.
This license, the GNU Lesser General Public License, applies to certain designated libraries, and is
quite different from the ordinary General Public License. We use this license for certain libraries in
order to permit linking those libraries into non-free programs.
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When a program is linked with a library, whether statically or using a shared library, the combination
of the two is legally speaking a combined work, a derivative of the original library. The ordinary
General Public License therefore permits such linking only if the entire combination fits its criteria of
freedom. The Lesser General Public License permits more lax criteria for linking other code with the
library.

We call this license the "Lesser" General Public License because it does Less to protect the user's
freedom than the ordinary General Public License. It also provides other free software developers
Less of an advantage over competing non-free programs. These disadvantages are the reason we use
the ordinary General Public License for many libraries. However, the Lesser license provides
advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of
a certain library, so that it becomes a de-facto standard. To achieve this, non-free programs must be
allowed to use the library. A more frequent case is that a free library does the same job as widely
used non-free libraries. In this case, there is little to gain by limiting the free library to free software
only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number
of people to use a large body of free software. For example, permission to use the GNU C Library in
non-free programs enables many more people to use the whole GNU operating system, as well as its
variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure
that the user of a program that is linked with the Library has the freedom and the wherewithal to run
that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close
attention to the difference between a "work based on the library" and a "work that uses the library".
The former contains code derived from the library, whereas the latter must be combined with the
library in order to run.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library or other program which contains a notice
placed by the copyright holder or other authorized party saying it may be distributed under the terms
of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently
linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under
these terms. A "work based on the Library" means either the Library or any derivative work under
copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with
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modifications and/or translated straightforwardly into another language. (Hereinafter, translation is
included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a
library, complete source code means all the source code for all modules it contains, plus any
associated interface definition files, plus the scripts used to control compilation and installation of
the library.

Activities other than copying, distribution and modification are not covered by this License; they are
outside its scope. The act of running a program using the Library is not restricted, and output from
such a program is covered only if its contents constitute a work based on the Library (independent of
the use of the Library in a tool for writing it). Whether that is true depends on what the Library does
and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive
it, in any medium, provided that you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this
License and to the absence of any warranty; and distribute a copy of this License along with the
Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer
warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based
on the Library, and copy and distribute such modifications or work under the terms of Section 1
above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and
the date of any change.

c) You must cause the whole of the work to be licensed at no charge to all third parties under the
terms of this License.

d) If a facility in the modified Library refers to a function or a table of data to be supplied by an
application program that uses the facility, other than as an argument passed when the facility is
invoked, then you must make a good faith effort to ensure that, in the event an application does not
supply such function or table, the facility still operates, and performs whatever part of its purpose
remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-
defined independent of the application. Therefore, Subsection 2d requires that any application-
supplied function or table used by this function must be optional: if the application does not supply
it, the square root function must still compute square roots.)
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These requirements apply to the modified work as a whole. If identifiable sections of that work are
not derived from the Library, and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those sections when you distribute them
as separate works. But when you distribute the same sections as part of a whole which is a work
based on the Library, the distribution of the whole must be on the terms of this License, whose
permissions for other licensees extend to the entire whole, and thus to each and every part
regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely
by you; rather, the intent is to exercise the right to control the distribution of derivative or collective
works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a
work based on the Library) on a volume of a storage or distribution medium does not bring the other
work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License
to a given copy of the Library. To do this, you must alter all the notices that refer to this License, so
that they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a
newer version than version 2 of the ordinary GNU General Public License has appeared, then you can
specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General
Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not
a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object
code or executable form under the terms of Sections 1 and 2 above provided that you accompany it
with the complete corresponding machine-readable source code, which must be distributed under
the terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then
offering equivalent access to copy the source code from the same place satisfies the requirement to
distribute the source code, even though third parties are not compelled to copy the source along with
the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with
the Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in
isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a
derivative of the Library (because it contains portions of the Library), rather than a "work that uses the
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library". The executable is therefore covered by this License. Section 6 states terms for distribution of
such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the
object code for the work may be a derivative work of the Library even though the source code is not.
Whether this is true is especially significant if the work can be linked without the Library, or if the
work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small
macros and small inline functions (ten lines or less in length), then the use of the object file is
unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object
code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work
under the terms of Section 6. Any executables containing that work also fall under Section 6, whether
or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also combine or link a "work that uses the Library"
with the Library to produce a work containing portions of the Library, and distribute that work under
terms of your choice, provided that the terms permit modification of the work for the customer's own
use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the
Library and its use are covered by this License. You must supply a copy of this License. If the work
during execution displays copyright notices, you must include the copyright notice for the Library
among them, as well as a reference directing the user to the copy of this License. Also, you must do
one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the
Library including whatever changes were used in the work (which must be distributed under Sections
1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-
readable "work that uses the Library", as object code and/or source code, so that the user can modify
the Library and then relink to produce a modified executable containing the modified Library. (It is
understood that the user who changes the contents of definitions files in the Library will not
necessarily be able to recompile the application to use the modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one
that (1) uses at run time a copy of the library already present on the user's computer system, rather
than copying library functions into the executable, and (2) will operate properly with a modified
version of the library, if the user installs one, as long as the modified version is interface-compatible
with the version that the work was made with.
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c) Accompany the work with a written offer, valid for at least three years, to give the same user the
materials specified in Subsection 6a, above, for a charge no more than the cost of performing this
distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer
equivalent access to copy the above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already sent this
user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and
utility programs needed for reproducing the executable from it. However, as a special exception, the
materials to be distributed need not include anything that is normally distributed (in either source or
binary form) with the major components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries
that do not normally accompany the operating system. Such a contradiction means you cannot use
both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library
together with other library facilities not covered by this License, and distribute such a combined
library, provided that the separate distribution of the work based on the Library and of the other
library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined
with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the
Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly
provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or
distribute the Library is void, and will automatically terminate your rights under this License.
However, parties who have received copies, or rights, from you under this License will not have their
licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else
grants you permission to modify or distribute the Library or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library
(or any work based on the Library), you indicate your acceptance of this License to do so, and all its
terms and conditions for copying, distributing or modifying the Library or works based on it.

10. Each time you redistribute the Library (or any work based on the Library), the recipient
automatically receives a license from the original licensor to copy, distribute, link with or modify the
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Library subject to these terms and conditions. You may not impose any further restrictions on the
recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by
third parties with this License.

11. If, as a consequence of a court judgment or allegation of patent infringement or for any other
reason (not limited to patent issues), conditions are imposed on you (whether by court order,
agreement or otherwise) that contradict the conditions of this License, they do not excuse you from
the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations
under this License and any other pertinent obligations, then as a consequence you may not distribute
the Library at all. For example, if a patent license would not permit royalty-free redistribution of the
Library by all those who receive copies directly or indirectly through you, then the only way you could
satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the
balance of the section is intended to apply, and the section as a whole is intended to apply in other
circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right
claims or to contest validity of any such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system which is implemented by public license practices.
Many people have made generous contributions to the wide range of software distributed through
that system in reliance on consistent application of that system; it is up to the author/donor to decide
if he or she is willing to distribute software through any other system and a licensee cannot impose
that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of
this License.

12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by
copyrighted interfaces, the original copyright holder who places the Library under this License may
add an explicit geographical distribution limitation excluding those countries, so that distribution is
permitted only in or among countries not thus excluded. In such case, this License incorporates the
limitation as if written in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser General
Public License from time to time. Such new versions will be similar in spirit to the present version,
but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this
License which applies to it and "any later version", you have the option of following the terms and
conditions either of that version or of any later version published by the Free Software Foundation. If
the Library does not specify a license version number, you may choose any version ever published by
the Free Software Foundation.
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14. If you wish to incorporate parts of the Library into other free programs whose distribution
conditions are incompatible with these, write to the author to ask for permission. For software which
is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we
sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the
free status of all derivatives of our free software and of promoting the sharing and reuse of software
generally.

NO WARRANTY

15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY
OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE
DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY
COPYRIGHT HOLDER, OR ANY OTHER PARTY WHOMAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY
AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL,
INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE
LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE
OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH
ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we
recommend making it free software that everyone can redistribute and change. You can do so by
permitting redistribution under these terms (or, alternatively, under the terms of the ordinary
General Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start
of each source file to most effectively convey the exclusion of warranty; and each file should have at
least the "copyright" line and a pointer to where the full notice is found.

<one line to give the library's name and a brief idea of what it does.>

Copyright (C) <year> <name of author>
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This library is free software; you can redistribute it and/or modify it under the terms of the GNU
Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the
License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without
even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with this library; if
not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
USA

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a
"copyright disclaimer" for the library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library `Frob' (a library for tweaking
knobs) written by James Random Hacker.

<signature of Ty Coon>, 1 April 1990

Ty Coon, President of Vice

That's all there is to it!
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Appendix D: End User License
Agreement

End User Licensing Agreement (EULA)
PLEASE READ THIS EULA CAREFULLY BEFORE ORDERING OR DOWNLOADING OR USING ANY
SOFTWARE PRODUCTS OF THE FOUNDRY. YOUR ATTENTION IS PARTICULARLY DRAWN TO CLAUSES
12 AND 13 WHERE WE LIMIT OUR LIABILITY TO USERS OF OUR SOFTWARE PRODUCTS.

IMPORTANT NOTICE TO ALL USERS: BY DOWNLOADING AND/OR USING THIS SOFTWARE YOU
ACKNOWLEDGE THAT YOU HAVE READ THIS EULA, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS
TERMS AND CONDITIONS. IF YOU DO NOT AGREE TO THE TERMS OF THIS EULA DO NOT DOWNLOAD,
INSTALL, COPY OR USE THE SOFTWARE.

IMPORTANT NOTICE TO CONSUMERS WHO PURCHASE SOFTWARE PRODUCTS DIRECT FROM THE
FOUNDRY: YOU HAVE THE RIGHT TO WITHDRAW FROM YOUR TRANSACTION WITH THE FOUNDRY
WITHOUT CHARGE AND WITHOUT REASON AT ANY TIME BEFORE DOWNLOADING OUR SOFTWARE
PRODUCT(S). HOWEVER YOU WILL LOSE THIS RIGHT ONCE YOU BEGIN TO DOWNLOAD OUR
SOFTWARE PRODUCT(S). THIS DOES NOT AFFECT YOUR CONSUMER RIGHTS IN RELATION TO
DEFECTIVE PRODUCTS OR SERVICES.

This END USER LICENSE AGREEMENT ("EULA") is, in cases where you purchase our product(s) direct
from The Foundry, incorporated into the agreement between The Foundry Visionmongers Limited, a
company registered in England and Wales, ("The Foundry"), and you, as either an individual or a
single company or other legal entity ("Licensee") on the terms of which you will purchase the
products and services of The Foundry (the “Agreement”). In cases where you purchase our product(s)
from one of our resellers, the use of the term “Agreement” in this EULA refers to the arrangements
between The Foundry and Licensee on which Licensee is permitted to use The Foundry’s product(s),
including this EULA.

The Foundry reserves the right to refuse to grant a License (as defined in clause 1.1) to any Licensee
who has failed to pay any sum due either to The Foundry or to a reseller of The Foundry either in
connection with the Agreement or in connection with any other software license to use any Software
product(s) of The Foundry.
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1. GRANT OF LICENSE

1.1 Subject to the limitations of clause 3 and all the other terms of the Agreement, The Foundry
grants to Licensee a limited, non-transferable (subject to clause 2.1(b) below) and non-exclusive
license to download, install and use a machine readable, object code version (subject to clauses 3 and
4 below) of the software program(s) purchased by Licensee (the "Software") and any accompanying
user guide and other documentation (the "Documentation"), solely for Licensee's own internal
purposes (the "License"); provided, however, that Licensee's right to download, install and use the
Software and the Documentation is limited to those rights expressly set out in this EULA.

1.2 Some types of license models set out in clause 2.1 limit the installation and use of the Software to
the country in which Licensee is based at the date of purchase (the “Home Country”), unless
otherwise agreed in writing. Notwithstanding such limits, Licensee may still use the Software outside
the Home Country if traveling or working outside the Home Country on a temporary basis provided
that such use does not exceed 70 days in aggregate in any rolling twelve month period or, in the case
of any license which lasts for less than twelve months, does not exceed the number of days
representing 20% of the term of the license.

1.3 Only to the extent that is proportionate to, and reasonably necessary to support, Licensee’s
licensed use of the Software in accordance with the Agreement, Licensee may (provided valid license
keys have been obtained) install the Software on more than one computer, provided always that
Licensee’s concurrent use of different installations of the Software does not exceed the number of
valid Licenses that Licensee has paid for or licensed (as applicable).

2. LICENSE MODELS

2.1 For each Software product purchased from The Foundry, the License will be one of the following
types of license, and subject to the following terms and conditions. Please note that some licensing
models set out below do not apply to certain Software products of The Foundry. Whichever licensing
model applies, Licensee shall not at any one time use more copies of the Software than the total
number of valid licenses purchased or licensed by Licensee (as applicable).

(a) “Node Locked License”

If Licensee purchases a Node Locked License, Licensee will install and use only a single copy of the
Software on only one computer at a time, which may be located anywhere in the Home Country.

(b) “Individual License”

If Licensee purchases an Individual License, Licensee warrants and represents that Licensee is a
natural person and that only Licensee will use the Software. Licensee may transfer or assign
(“transfer”) the Individual License to another natural person (“Assignee”) subject to Licensee: (i)
notifying The Foundry of such transfer and obtaining The Foundry’s express written consent, (ii)

APPENDIX D: END USER LICENSE AGREEMENT |



USER GUIDE 560

paying an administrative fee with respect to such transfer as may be required by The Foundry, and (iii)
after transferring a single copy of the Software to the Assignee, deleting any copies of the Software
that Licensee may have in Licensee’s possession, custody or power. An Individual License entitles
Licensee to use the Software on only one computer at a time, which may be located anywhere and is
not restricted to the Home Country.

(c) “Floating License”

If Licensee purchases a Floating License, use of the Software may be at any site in the Home Country.

(d) “Login-Based License”

If Licensee purchases a Login-Based License, Licensee warrants and represents that Licensee is a
natural person and that only Licensee shall use the Software. Licensee will be issued with log in
details and may use the Software on any number of computers (but not simultaneously).

2.2 Some of the Software may be made available at concessionary rates or free of charge (as
applicable) as follows:

(a) “Educational License”

If Licensee has purchased the Software on the discounted terms of The Foundry’s Educational Policy
published on its website (the “Educational Policy”), Licensee warrants and represents to The Foundry
as a condition of the Educational License that: (i) (if Licensee is a natural person) he or she is a part-
time or full-time student at the time of purchase and will not use the Software for any commercial,
professional or for-profit purposes; (ii) (if the Licensee is not a natural person) it is an organization
that will use the Software only for the purpose of training and instruction, and for no other purpose,
and (iii) Licensee will at all times comply with the Educational Policy (as such policy may be amended
from time to time). Unless the Educational License is a Floating License, Licensee shall use the
Software on only one computer at a time.

(b) “Non-Commercial License”

If the License is a Non-Commercial License, Licensee warrants and represents that Licensee is a
natural person, that they will only access and/or use one copy of a Non-Commercial License for
personal, recreational and non-commercial purposes and that only Licensee will use the Software.
Under a Non-Commercial License, Licensee will not use the Software: (a) in conjunction with any
other copies or versions of the Software, under any type of License model; (b) for any commercial,
professional, for-profit and/or on-sale purpose or otherwise to provide any commercial service(s) to a
third party (whether or not for financial or other reward and including for education, instruction of or
demonstration to any third party for commercial purposes); (c) in the course of any employment or
business undertaking of Licensee; (d) on any commercial premises during business hours (except
where use of the Software is solely for a personal, recreational, educational or other non-commercial
purpose); and/or (e) to create any commercial tools or plug ins.
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(c) “MODO Steam Edition”

A version of MODO with limited functionality as described in the Documentation is available to
purchase on discount terms through Valve Corporation’s Steam store. If Licensee has purchased such
version, Licensee warrants and represents to The Foundry as a condition of the Agreement that: (i)
Licensee is a natural person; and (ii) Licensee will use the Software strictly through Steam and only for
personal, recreational and non-commercial use, except only that if Licensee uses the Software to
create assets and content Licensee may sell such assets and content through Valve’s Steam
Workshop.

(d) “MODO indie” and “MARI indie”

Variants of MODO and MARI with limited functionality as described in the Documentation are
available to purchase on discount terms through Valve Corporation’s Steam store. If Licensee has
purchased such a variant, Licensee warrants and represents to The Foundry as a condition of the
Agreement that: (i) Licensee is a natural person; or (ii) Licensee is an entity in the direct ownership of
a single natural person; (iii) Licensee will only access and/or use one copy of either variant; and (iv)
only Licensee will use the Software.

(e) “Trial License”

Licensee may register for a “Trial License” of the Software (not available for all products or in all
regions or markets). A Trial License lasts a limited specified period on the expiry of which the
Software will automatically cease to function. Licensee will use the Software on only one computer at
a time.

(f) “Free License”

Licensee may register for a “Free License” of selected Software from The Foundry (not available for all
Software products or in all regions or markets). A Free License lasts for a limited specified period on
the expiry of which the Software will cease to function. Usually, a replacement License to cover a new,
time limited, period will be issued by The Foundry. Licensee will use the Software under a Free
License on only one computer at a time.

(g) “Personal Learning Edition License”

If the Software is a Personal Learning Edition (“PLE”), it will not require a license key to be issued to
Licensee and will have limited functionality as described in the Documentation. Licensee may use it
only for the purpose of personal or internal training and instruction, and for no other purpose. PLE
versions of the Software may not be used for commercial, professional or for-profit purposes
including, for the avoidance of doubt, the purpose of providing training or instruction to third parties.
Licensee shall use the Software on only one computer at a time.

2.3 If Licensee has purchased a License that permits “non-interactive” use of the Software (“Headless
Rendering”), Licensee is authorized to use a non-interactive version of the Software for rendering
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purposes only (i.e. without a user, in a non-interactive capacity) and shall not use such Software on
workstations or otherwise in a user-interactive capacity. Headless Rendering is not available on all
products. In all cases except MODO (in respect of which there is no limit on the amount of Headless
Rendering allowed), Headless Rendering licenses are limited to one computer such that the number
of computers on which Headless Rendering can be carried out is limited to the number of valid
Licenses that have been purchased.

3. RESTRICTIONS ON USE

Please note that in order to guard against unlicensed use of the Software, a license key is
required to access and enable the Software (other than Software which is licensed under the
Personal Learning Edition model – see clause 2.2 (g) above). Licensee is authorized to use the
Software in machine readable, object code form only (subject to clause 4), and Licensee shall not: (a)
assign, sublicense, sell, distribute, transfer, pledge, lease, rent, lend, share or export the Software, the
Documentation or Licensee's rights under this EULA; (b) alter or circumvent the license keys or other
copy protection mechanisms in the Software or reverse engineer, decompile, disassemble or
otherwise attempt to discover the source code of the Software; (c) (subject to clause 4) modify, adapt,
translate or create derivative works based on the Software or Documentation; (d) use, or allow the
use of, the Software or Documentation on any project other than a project produced by Licensee (an
"Authorized Project") or to provide a service (whether or not any charge is made) to any third party;
(e) allow or permit anyone (other than Licensee and Licensee's authorized employees to the extent
they are working on an Authorized Project) to use or have access to the Software or Documentation;
(f) copy or install the Software or Documentation other than as expressly provided for in this EULA; or
(g) take any action, or fail to take action, that could adversely affect the trademarks, service marks,
patents, trade secrets, copyrights or other intellectual property rights of The Foundry or any third
party with intellectual property rights in the Software (each, a "Third Party Licensor"). For purposes of
this clause 3, the term "Software" shall include any derivatives of the Software.

Unless Licensee has purchased an Individual License or a Login-Based License, if the Software is
moved from one computer to another, the issuing of replacement or substituted license keys is
subject to and strictly in accordance with The Foundry’s License Transfer Policy, which is available on
The Foundry’s website and which requires a fee to be paid in certain circumstances. The Foundry may
from time to time and at its sole discretion vary the terms and conditions of the License Transfer
Policy.

4. SOURCE CODE

Notwithstanding that clause 1 defines “Software” as an object code version and that clause 3 provides
that Licensee may use the Software in object code form only:

4.1 if The Foundry has agreed to license to Licensee (including by way of providing SDKs, upgrades,
updates or enhancements/customization) source code or elements of the source code of the
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Software, the intellectual property rights in which belong either to The Foundry or to a Third Party
Licensor (“Source Code”), Licensee shall be licensed to use the Source Code as Software on the terms
of this EULA and: (a) notwithstanding clause 3 (c), Licensee may use the Source Code at its own risk in
any reasonable way for the limited purpose of enhancing its use of the Software solely for its own
internal business purposes and in all respects in accordance with this EULA; (b) Licensee shall in
respect of the Source Code comply strictly with all other restrictions applying to its use of the
Software under this EULA as well as any other restriction or instruction that is communicated to it by
The Foundry at any time during the Agreement (whether imposed or requested by The Foundry or by
any Third Party Licensor);

4.2 to the extent that the Software links to any open source software libraries (“OSS Libraries”) that
are provided to Licensee with the Software, nothing in the Agreement shall affect Licensee’s rights
under the licenses on which the relevant Third Party Licensor has licensed the OSS Libraries, as stated
in the Documentation. To the extent that Third Party Licensors have licensed OSS Libraries on the
terms of v2.1 of the Lesser General Public License issued by the Free Software Foundation (see
http://www.gnu.org/licenses/lgpl-2.1.html) (the “LGPL”), those OSS Libraries are licensed to Licensee
on the terms of the LGPL and are referred to in this clause 4.2 as the LGPL Libraries. The Foundry will
at any time during the three year period starting on the date of the Agreement, at the request of
Licensee and subject to Licensee paying to The Foundry a charge that does not exceed The Foundry’s
costs of doing so, provide Licensee with the source code of the LGPL Libraries (the “LGPL Source”) in
order that Licensee may modify the LGPL Libraries in accordance with the LGPL, together with certain
object code of the Software necessary to enable Licensee to re-link any modified LGPL Library to the
Software (the “Object”); and

4.3 notwithstanding any other term of the Agreement, The Foundry gives no express or implied
warranty, undertaking or indemnity whatsoever in respect of the Source Code, the OSS Libraries
(including the LGPL Libraries), the LGPL Source or the Object, all of which are licensed on an “as is”
basis, or in respect of any modification of the Source Code, the OSS Libraries (including the LGPL
Libraries) or the LGPL Source made by Licensee (“Modification”). Licensee may not use the Object for
any purpose other than its use of the Software in accordance with this EULA. Notwithstanding any
other term of the Agreement, The Foundry shall have no obligation to provide support, maintenance,
upgrades or updates of or in respect of any of the Source Code, the OSS Libraries (including the LGPL
Libraries), the LGPL Source, the Object or any Modification. Licensee shall indemnify The Foundry
against all liabilities and expenses (including reasonable legal costs) incurred by The Foundry in
relation to any claim asserting that any Modification infringes the intellectual property rights of any
third party.

5. BACK-UP COPY

Licensee may store one copy of the Software and Documentation off-line and off-site in a secured
location within the Home Country that is owned or leased by Licensee in order to provide a back-up
in the event of destruction by fire, flood, acts of war, acts of nature, vandalism or other incident. In no
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event may Licensee use the back-up copy of the Software or Documentation to circumvent the usage
or other limitations set forth in this EULA.

6. OWNERSHIP

Licensee acknowledges that the Software (including, for the avoidance of doubt, any Source Code that
is licensed to Licensee) and Documentation and all related intellectual property rights and other
proprietary rights are and shall remain the sole property of The Foundry and the Third Party
Licensors. Licensee shall not remove, or allow the removal of, any copyright or other proprietary
rights notice included in and on the Software or Documentation or take any other action that could
adversely affect the property rights of The Foundry or any Third Party Licensor. To the extent that
Licensee is authorized to make copies of the Software or Documentation under this EULA, Licensee
shall reproduce in and on all such copies any copyright and/or other proprietary rights notices
provided in and on the materials supplied by The Foundry hereunder. Nothing in the Agreement shall
be deemed to give Licensee any rights in the trademarks, service marks, patents, trade secrets,
confidential information, copyrights or other intellectual property rights of The Foundry or any Third
Party Licensor, and Licensee shall be strictly prohibited from using the name, trademarks or service
marks of The Foundry or any Third Party Licensor in Licensee's promotion or publicity without The
Foundry's prior express written approval.

Subject to clause 4.3, The Foundry undertakes (the “Undertaking”) to defend Licensee or at The
Foundry’s option settle any claim brought against Licensee alleging that Licensee’s possession or use
of the Software or Documentation in accordance with the Agreement infringes the intellectual
property rights of a third party in the same country as Licensee (“Claim”) and shall reimburse all
reasonable losses, damages, costs (including reasonable legal fees) and expenses incurred by or
awarded against Licensee in connection with any such Claim, provided that the Undertaking shall not
apply where the Claim in question is attributable to possession or use of the Software or
Documentation other than in accordance with the Agreement, or in combination with any hardware,
software or service not supplied or specified by The Foundry. The Undertaking is conditional on
Licensee giving written notice of the Claim to The Foundry as soon as reasonably possible,
cooperating in the defence of the Claim and not making any admission of liability or taking any step
prejudicial to the defence of the Claim. If any Claim is made, or in The Foundry's reasonable opinion
is likely to be made, against Licensee, The Foundry may at its sole option and expense (a) procure for
Licensee the right to continue using the Software, (b) modify the Software so that it ceases to be
infringing, (c) replace the Software with non-infringing software, or (d) terminate the Agreement
immediately by notice in writing to Licensee and refund the License Fee (less a reasonable sum in
respect of Licensee's use of the Software to the date of termination) on return of the Software and all
copies by Licensee. The Undertaking constitutes Licensee's exclusive remedy and The Foundry's only
liability in respect of any Claim.
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7. LICENSE FEE

7.1 Licensee acknowledges that (subject to clause 7.2) the rights granted to Licensee under this EULA
are conditional on Licensee's payment in full of the license fee payable in connection with the
Agreement or, as the case may be, payable to The Foundry’s reseller (the "License Fee").

7.2 In the cases of Non-Commercial NUKE, Trial Licenses and Free Licenses, for the avoidance of
doubt, the fact that no License Fee may be payable shall not be construed as a waiver by The Foundry
of any right or remedy available to it in relation to any breach by Licensee of this EULA or the
Agreement, or of any other right or remedy arising under applicable law, all of which are expressly
reserved.

8. UPGRADES/ENHANCEMENTS

If the Licensee has paid an annually renewable fee for access to support, upgrades and updates for
the Software ("Annual Upgrade and Support Programme"), this Agreement is subject to the terms
and conditions for the Annual Upgrade and Support Programme available on The Foundry's website.
The Foundry may from time to time and at its sole discretion vary the terms and conditions of the
Annual Upgrade and Support Programme. The Annual Upgrade and Support Programme is not
available for all Software license types and variations.

9. TAXES AND DUTIES

Licensee agrees to pay, and indemnify The Foundry from claims for, any local, state or national tax
(exclusive of taxes based on net income), duty, tariff or other impost related to or arising from the
transaction contemplated by the Agreement.

10. LIMITED WARRANTY

10.1 Subject to clause 10.3, The Foundry warrants that, for a period of ninety (90) days after Licensee
first downloads the Software (“Warranty Period”): (a) the Software will, when properly used on an
operating system for which it was designed, perform substantially in accordance with the functions
described in the Documentation; and (b) that the Documentation correctly describes the operation of
the Software in all material respects. If, within the Warranty Period, Licensee notifies The Foundry in
writing of any defect or fault in the Software as a result of which it fails to perform substantially in
accordance with the Documentation, The Foundry will, at its sole option, either repair or replace the
Software, provided that Licensee makes available all the information that may be necessary to
identify, recreate and remedy the defect or fault. This warranty will not apply to any defect or fault
caused by unauthorised use of or any amendment made to the Software by any person other than
The Foundry. If Licensee is a consumer, the warranty given in this clause is in addition to Licensee’s
legal rights in relation to any Software or Documentation that is faulty or not as described.
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10.2 The Foundry does not warrant that the Software or Documentation will meet Licensee's
requirements or that Licensee's use of the Software will be uninterrupted or error free.

10.3 If Licensee purchases a license of the Software that is of a fixed term duration, the Warranty
Period in clause 10.1 shall apply only to Licensee’s first purchase of such license and not to any
subsequent renewal(s) even if a renewal involves another download.

11. INDEMNIFICATION

Licensee agrees to indemnify, hold harmless and defend The Foundry, the Third Party Licensors and
The Foundry's and each Third Party Licensor’s respective affiliates, officers, directors, shareholders,
employees, authorized resellers, agents and other representatives from all claims, defence costs
(including, but not limited to, legal fees), judgments, settlements and other expenses arising from or
connected with any claim that any authorised or unauthorised modification of the Software or
Documentation by Licensee or any person connected with Licensee infringes the intellectual property
rights or other proprietary rights of any third party.

12. LIMITATION OF LIABILITY TO BUSINESS USERS

This clause applies where Licensee is a business user. Licensee acknowledges that the Software has
not been developed to meet its individual requirements, and that it is therefore Licensee’s
responsibility to ensure that the facilities and functions of the Software as described in the
Documentation meet such requirements. The Software and Documentation is supplied only for
Licensee’s internal use for its business, and not for any re-sale purposes or for the provision of the
Software (whether directly or indirectly) to third parties. The Foundry shall not under any
circumstances whatever be liable to Licensee, its affiliates, officers, directors, shareholders,
employees, agents or other representatives, whether in contract, tort (including negligence), breach of
statutory duty, or otherwise, arising under or in connection with the Agreement for loss of profits,
sales, business, or revenue, business interruption, loss of anticipated savings, loss or corruption of
data or information, loss of business opportunity, goodwill or reputation or any indirect or
consequential loss or damage. In respect of any other losses, The Foundry’s maximum aggregate
liability under or in connection with the Agreement whether in contract, tort (including negligence) or
otherwise, shall in all circumstances be limited to the greater of US$5,000 (five thousand USD) and a
sum equal to the License Fee. Nothing in the Agreement shall limit or exclude The Foundry’s liability
for death or personal injury resulting from our negligence, fraud or fraudulent misrepresentation or
for any other liability that cannot be excluded or limited by applicable law. This EULA sets out the full
extent of our obligations and liabilities in respect of the supply of the Software and Documentation.
Except as expressly stated in this EULA, there are no conditions, warranties, representations or other
terms, express or implied, that are binding on The Foundry. Any condition, warranty, representation
or other term concerning the supply of the Software and Documentation which might otherwise be
implied into, or incorporated in, the Agreement, whether by statute, common law or otherwise, is
excluded to the fullest extent permitted by law.
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13. LIMITATION OF LIABILITY TO CONSUMERS

This clause applies where Licensee is a consumer. Licensee acknowledges that the Software has not
been developed to meet Licensee’s individual requirements, and that it is therefore Licensee’s
responsibility to ensure that the facilities and functions of the Software as described in the
Documentation meet such requirements. The Software and Documentation are only supplied for
Licensee’s domestic and private use. Licensee agrees not to use the Software and Documentation for
any commercial, business or re-sale purposes, and The Foundry has no liability to Licensee for any
loss of profit, loss of business, business interruption, or loss of business opportunity. The Foundry is
only responsible for loss or damage suffered by Licensee that is a foreseeable result of The Foundry’s
breach of the Agreement or its negligence but The Foundry is not responsible for any loss or damage
that is not foreseeable. Loss or damage is foreseeable if they were an obvious consequence of a
breach or if they were contemplated by Licensee and The Foundry at the time of forming the
Agreement. Our maximum aggregate liability under or in connection with the Agreement, whether in
contract, tort (including negligence) or otherwise, shall in all circumstances be limited to a sum equal
to the greater of US$5,000 (five thousand USD) and a sum equal to the License Fee. Nothing in the
Agreement shall limit or exclude The Foundry’s liability for death or personal injury resulting from
our negligence, fraud or fraudulent misrepresentation or for any other liability that cannot be
excluded or limited by applicable law.

14. TERM; TERMINATION

14.1 The Agreement is effective upon Licensee's download of the Software, and the Agreement will
remain in effect until termination or expiry. Licensee may terminate the Agreement on written notice
to The Foundry if The Foundry is in breach of this Agreement and fails to cure the breach within 10
(ten) working days of receiving notice of such breach. If Licensee breaches the Agreement, The
Foundry may terminate the License immediately by notice to Licensee.

14.2 If the Agreement expires or is terminated, the License will cease immediately and Licensee will
immediately cease use of any Software and Documentation and either return to The Foundry all
copies of the Software and Documentation in Licensee's possession, custody or power or, if The
Foundry directs in writing, destroy all such copies. In the latter case, if requested by The Foundry,
Licensee shall provide The Foundry with a certificate confirming that such destruction has been
completed.

14.3 The Foundry reserves the right to terminate and/or suspend the License as it deems reasonable
in its sole discretion by notice to Licensee if it becomes aware that Licensee has failed to pay any sum
due either to The Foundry or to a reseller of The Foundry either in connection with the Agreement or
in connection with any other Software license to use any product(s) of The Foundry or the Licensee is
otherwise in breach of or fails to comply with any term of the Agreement.
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14.4 The Foundry may also terminate this EULA if Licensee becomes subject to bankruptcy
proceedings, becomes insolvent, or makes an arrangement with Licensee’s creditors. This EULA will
terminate automatically without further notice or action by The Foundry if Licensee goes into
liquidation.

15. CONFIDENTIALITY

Licensee agrees that the Software (including, for the avoidance of doubt, any Source Code that is
licensed to Licensee) and Documentation are proprietary to and the confidential information of The
Foundry or, as the case may be, the Third Party Licensors, and that all such information and any
related communications (collectively, "Confidential Information") are confidential and a
fundamental and important trade secret of The Foundry and/or the Third Party Licensors. If Licensee
is a business user, Licensee shall disclose Confidential Information only to Licensee's employees who
are working on an Authorized Project and have a "need-to-know" such Confidential Information, and
shall advise any recipients of Confidential Information that it is to be used only as expressly
authorized in the Agreement. Licensee shall not disclose Confidential Information or otherwise make
any Confidential Information available to any other of Licensee's employees or to any third parties
without the express written consent of The Foundry. Licensee agrees to segregate, to the extent it can
be reasonably done, the Confidential Information from the confidential information and materials of
others in order to prevent commingling. Licensee shall take reasonable security measures, which
measures shall be at least as great as the measures Licensee uses to keep Licensee's own confidential
information secure (but in any case using no less than a reasonable degree of care), to hold the
Software, Documentation and any other Confidential Information in strict confidence and safe
custody. The Foundry may request, in which case Licensee agrees to comply with, certain reasonable
security measures as part of the use of the Software and Documentation. This clause shall not apply
to any information that is in or comes into the public domain, or was in Licensee’s lawful possession
before receipt or which Licensee develops independently and without breach of this clause. Licensee
acknowledges that monetary damages may not be a sufficient remedy for unauthorized disclosure of
Confidential Information, and that The Foundry shall be entitled, without waiving any other rights or
remedies, to such injunctive or other equitable relief as may be deemed proper by a court of
competent jurisdiction.

16. INSPECTION AND INFORMATION

16.1 Unless Licensee is a consumer, Licensee shall advise The Foundry on demand of all locations
where the Software or Documentation is used or stored. Licensee shall permit The Foundry or its
authorized agents to audit all such locations during normal business hours and on reasonable
advance notice.

16.2 The Software may include mechanisms to collect limited information from Licensee’s computer
(s) and transmit it to The Foundry. Such information (the “Information”) may include details of
Licensee’s hardware, details of the operating system(s) in use on such hardware and the profile and
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extent of Licensee’s use of the different elements of the Software. The Foundry may use the
Information to (a) model the profiles of usage, hardware and operating systems in use collectively
across its customer base in order to focus development and support, (b) to provide targeted support
to individual customers, (c) to ensure that the usage of the Software by Licensee is in accordance with
the Agreement and does not exceed any user number or other limits on its use, and (d) to advise
Licensee about service issues such as available upgrades and maintenance expiry dates. To the extent
that any Information is confidential to Licensee it shall be treated as such by The Foundry when so
notified or identified by Licensee when the Information is first provided to The Foundry (whether
verbally or in written form). To the extent that any Information constitutes personal data for the
purposes of the Data Protection Act 1998 it shall be processed by The Foundry in accordance with
that Act and with The Foundry’s Privacy Policy (see http://www.thefoundry.co.uk/privacy/). Licensee
undertakes to make all of users of the Software aware of the uses which The Foundry will make of the
Information and of the terms of The Foundry’s Privacy Policy.

17. U.S. GOVERNMENT LICENSE RIGHTS

All Software, including all components thereof, and Documentation qualify as “commercial items,” as
that term is defined at Federal Acquisition Regulation (“FAR”) (48 C.F.R.) 2.101, consisting of
“commercial computer software” and “commercial computer software documentation” as such terms
are used in FAR 12.212. Consistent with FAR 12.212 and DoD FAR Supp. 227.7202-1 through 227.7202-
4, and notwithstanding any other FAR or other contractual clause to the contrary in any agreement
into which this Agreement may be incorporated, a government end user will acquire the Software and
Documentation with only those rights set forth in this Agreement. Use of either the Software or
Documentation or both constitutes agreement by the government that all Software and
Documentation are “commercial computer software” and “commercial computer software
documentation,” and constitutes acceptance of the rights and restrictions herein. The Software is the
subject of the following notices:

* Copyright © 2001 - 2016 The Foundry Visionmongers Limited. All Rights Reserved.

* Unpublished-rights reserved under the Copyright Laws of the United Kingdom.

18. SURVIVAL.

Clause 6 and clauses 9 to 20 inclusive shall survive any termination or expiration of the Agreement.

19. IMPORT/EXPORT CONTROLS

To the extent that any Software made available under the Agreement is subject to restrictions upon
export and/or re-export from the United States, Licensee agrees to comply with, and not act or fail to
act in any way that would violate, applicable international, national, state, regional or local laws and
regulations, including, without limitation, the U.S. Export Administration Act and the Export
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Administration Regulations, the regulations of the U.S. Department of Treasury Office of Foreign
Assets Control, and the International Traffic in Arms regulations (collectively, “U.S. Export Laws”), and
the United States Foreign Corrupt Practices Act, as those laws may be amended or otherwise
modified from time to time, and neither The Foundry nor Licensee shall be required under the
Agreement to act or fail to act in any way which it believes in good faith will violate any such laws or
regulations. Without limiting the foregoing, Licensee agrees that it will not export or re-export,
directly or indirectly, The Foundry’s Software or related products and services, or any commodity,
technology, technical data, software or service that incorporates, contains or is a direct product of
The Foundry’s Software, products and/or services, (i) in violation of the U.S. Export Laws; (ii) to any
country for which an export license or other governmental approval is required at the time of export,
without first obtaining all necessary export licenses or other approvals; (iii) to any country, or national
or resident of a country, to which trade is embargoed by the United States; (iv) to any person or firm
on any government agency’s list of blocked, denied or barred persons or entities, including but not
limited to the U.S. Department of Commerce’s Denied Persons List and Entities List,  and the U.S
Treasury Department’s Specially Designated Nationals List; or (v) for use in any nuclear, chemical or
biological weapons, or missile technology end-use unless authorized by the U.S. Government by
regulation or specific license.

20. MISCELLANEOUS

Unless Licensee is a consumer, the Agreement is the exclusive agreement between the parties
concerning its subject matter and supersedes any and all prior oral or written agreements,
negotiations, or other dealings between the parties concerning such subject matter. Licensee
acknowledges that Licensee has not relied upon any representation or collateral warranty not
recorded in the Agreement inducing it to enter into the Agreement. The Agreement may be modified
only in writing, by The Foundry, at any time. The failure of either party to enforce any rights granted
under the Agreement or to take action against the other party in the event of any such breach shall
not be deemed a waiver by that party as to subsequent enforcement of rights or subsequent actions
in the event of future breaches. The Agreement and any dispute or claim arising out of or in
connection with it or its subject matter or formation (including, unless Licensee is a consumer, non-
contractual disputes or claims) shall be governed by, and construed in accordance with English Law
and the parties irrevocably submit to the non-exclusive jurisdiction of the English Courts, subject to
any right that a consumer may have to bring proceedings or to have proceedings brought against
them in a different jurisdiction.

If The Foundry fails to insist that Licensee performs any obligation under the Agreement, or delays in
doing so, that will not mean that The Foundry has waived its rights.

Unless Licensee is a consumer, Licensee agrees that The Foundry may refer to Licensee as a client or
a user of the Software, may display its logo(s) for this purpose and may publish quotations and
testimonials from Licensee, its directors, partners, officers or employees. The Foundry agrees to
promptly cease any such use on Licensee’s written request.

APPENDIX D: END USER LICENSE AGREEMENT |



USER GUIDE 571

The Foundry and Licensee intend that each Third Party Licensor may enforce against Licensee under
the Contracts (Rights of Third Parties) Act 1999 (the “Act") any obligation owed by Licensee to The
Foundry under this EULA that is capable of application to any proprietary or other right of that Third
Party Licensor in or in relation to the Software. The Foundry and Licensee reserve the right under
section 2(3)(a) of the Act to rescind, terminate or vary this EULA without the consent of any Third Party
Licensor.

21. COMPLAINTS & ONLINE DISPUTE RESOLUTION PLATFORM

We hope that you are satisfied with any Software purchase made or service received from The
Foundry, but if you have a complaint, in the first instance, please contact us on
info@thefoundry.co.uk or through our Support Portal: https://supportportal.thefoundry.co.uk/hc/en-
us (for technical support and bug reports), or you can request a call back from the Sales team here:
https://www.thefoundry.co.uk/about-us/contact-us/. We will do our best to resolve the issue but if you
are still not happy with our response, you may seek to resolve it using the Online Dispute Resolution
Platform at www.ec.europa.eu/consumers/odr/.

Last updated March 30, 2016.

Copyright © 2016 The Foundry Visionmongers Limited.

All Rights Reserved. Do not duplicate.
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