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Preface
Mari is a creative texture-painting tool that can handle extremely complex or texture heavy projects. It
was developed at Weta Digital and has been used on films such as The Adventures of Tintin: The
Secret of the Unicorn, District 9, The Day the Earth Stood Still, The Lovely Bones and Avatar. The name
Mari comes from the Swahili 'Maridadi', meaning 'beautiful' and carrying connotations of 'usefulness'.

About This Guide
This guide provides you with the basic information you need to start painting with Mari.

The first part of the manual, Installation and Licensing, describes how to install, license, and launch
Mari.

The rest of the manual consists of a few short chapters describing Mari’s basic functionality and five
tutorials, which teach you the basics of creating a Mari project and painting textures. The tutorials
provide a series of comprehensive walk-throughs, complete with geometries and associated textures.
As you follow the steps in these tutorials, you'll gain a good feel for Mari's user interface and
workflow. This, in turn, provides a good working knowledge for creating more complex production
projects.

For more detailed information on Mari and its functions, see the accompanying Mari User Guide and
Mari Reference Guide.

Contact Customer Support
Should questions arise that this manual fails to address, you can contact Customer Support directly
via e-mail at support@thefoundry.co.uk or via telephone to our London office on +44 (0)20 7479 4350
or to our Los Angeles office on (310) 399-4555 during office hours.
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Installation and Licensing
To make the instructions easier to navigate, specific instructions for how to install, launch, and
license Mari are grouped together by operating system so you can quickly find everything in one
place.

The operating systems supported by Mari are:

• Windows,

• Linux, and

• Mac OS X

but you can find the full system requirements below.

System Requirements
NOTE: Mari increases its level of performance with newer, more advanced hardware
configurations. However, Mari is tested and capable of operating on many older, prior-
generation systems. For this reason we are listing below-minimum requirements,
recommended, and on which tests have been performed. Your particular needs may vary
from that of other users.

Officially Supported Operating Systems
• Mac OS X 10.9.5 (Mavericks) or higher

• Windows 7 64-bit or higher

• Linux 64-bit operating system (CentOS/RHEL 6)

Minimum Hardware Requirements
• Quad-core processor

• 10+GB disk space available for caching and temporary files

• At least 4GB RAM

• Display with 1680 x 1050 pixel resolution

• An NVIDIA or AMD* graphics card with the latest drivers

• 1GB of graphics memory

9
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• OpenGL 3.2* or higher

*Displacement preview is currently only available on the cards and drivers that support OpenGL 4.0
or newer.

Recommended System Requirements
• 2.5+Ghz Quad-core processor

• 250+GB disk space available for caching and temporary files. SSD is preferable.

• 16GB RAM with additional virtual memory*

• Display with 1920 x 1080 pixel resolution

• An NVIDIA or AMD* graphics card with the latest drivers

• 2+GB of graphics memory

• OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended does not guarantee that it meets your particular needs.

Tested Workstation Hardware

The configurations listed below are those that The Foundry have tested with Mari 3.1v1. Due to the
constantly changing nature, and wide variety, of computer hardware available in the market, The
Foundry are unable to officially certify hardware. The below can be used as a recommendation and
does not guarantee that it meets your particular needs.

Please download and install the latest graphics driver for the NVIDIA or AMD websites, and ensure
that you are using 8.982.1 drivers or higher for AMD cards.

If you encounter any issues, please contact support@thefoundry.co.uk.

Tested Workstation Hardware

Apple • MacPro4,1

• MacPro5,1

• MacPro6,1

• iMac13,2

• MacBookPro10,1

INSTALLATION AND LICENSING |
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Tested Workstation Hardware

HP • HP XW6600

• HP Z600

• HP Z620

• HP Z640

• HP Z800

Tested GPU Hardware

AMD Prosumer Graphics Cards • AMD Radeon HD - D500

AMD Enterprise Graphics Cards • AMD FirePro W7000

NVIDIA Prosumer Graphics Cards • NVIDIA Geforce GTX 660TI

• NVIDIA Geforce GTX 680

• NVIDIA Geforce GTX Titan

• NVIDIA Geforce GT 650M

• NVIDIA Geforce GT 675M

NVIDIA Enterprise Graphics Cards • NVIDIA Quadro 4000

• NVIDIA Quadro K4200

• NVIDIA Quadro K5000

• NVIDIA Quadro M6000

• NVIDIA Quadro M6000 24GB

Windows
System requirements for Windows machines can be found in System Requirements and are also
located on The Foundry website.

Installation on Windows

Mari 3.1 is available to download from our web site at www.thefoundry.co.uk/products/mari. The
download is in a compressed .exe format.

1. Download the .exe installation file from our web site.

INSTALLATION AND LICENSING | WINDOWS

http://www.thefoundry.co.uk/products/mari/system-requirements/
http://www.thefoundry.co.uk/products/mari


GETTING STARTED GUIDE 12

2. Double-click on the installation file to start the installation. Follow the on-screen instructions. By default, Mari is
installed to <drive letter>:\Program Files\Mari <version number>.

3. That's it! Proceed with Launching onWindows.

Installing Mari from the Command Line
1. Download the correct .exe installation file fromourweb site at www.thefoundry.co.uk/products/mari.

2. To open a command prompt window, select Start > All Programs > Accessories > Command prompt.

3. Use the cd (change directory) command tomove to the directory where you saved the installation file. For
example, if you saved the installation file in C:\Temp, use the following command and press Return:
cd \Temp

4. To install Mari, do one of the following:

• To install Mari and display the installation dialog, type the name of the install file without the file extension and
press Return:
Mari3.1v1-win-x86-release-64

• To install Mari to a specified directory and display the installation dialog, use the /dir install option:
Mari3.1v1-win-x86-release-64 /dir="E:\Mari"

• To install Mari silently so that the installer does not prompt you for anything but displays a progress bar, enter
/silent after the installation command:
Mari3.1v1-win-x86-release-64 /silent

• To install Mari silently so that nothing is displayed, enter /verysilent after the installation command:
Mari3.1v1-win-x86-release-64 /verysilent

• You can also use a combination of install options:
Mari3.1v1-win-x86-release-64 /silent /dir="E:\Mari"

NOTE: By running a silent install of Mari, you agree to the terms of the EULA. To see this
agreement, please refer to Appendix D: End User Licensing Agreement in the Mari User Guide, or
run the installer in standard non-silent mode.

Launching on Windows
1. Click Start > All Programs > The Foundry >Mari 3.1v1 >Mari 3.1v1.
2. If you haven’t installed a license forMari, you need to choose fromone of the options for Licensing onWindows.

Once you’ve done so, click Launch in theMari Licensing dialog.

3. Mari checks for themost frequently used graphics cards, and if a graphics card configuration is detected that's
not in the tested GPU hardware list, a dialog displays warning you about it. Depending on the configuration
detected, you have the option toQuit or Continue and, in the case of configurations with known issues, also
Ignore Permanently.

INSTALLATION AND LICENSING | WINDOWS
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NOTE: If you ignore the warning and run Mari anyway, you may experience instability or
performance issues. If a tested graphics card configuration is detected, Mari runs as normal.

4. If you are launchingMari for the first time, you are prompted to select a directory for its project files. In the
Please Pick Project Directory dialog, navigate to the directory you want to use and click Choose.

The Mari graphical interface displays.

Please note that the project directory should be:

• empty

• local to the machine (not a network mount)

• as fast as possible

• a location that's not temporary (to avoid the data disappearing)

• a directory that the user has read and write permissions to.

Project cache locations are directories that Mari uses to store project data files. These directories
must be persistent; not in temporary locations. If more than one project location is specified, Mari
spreads each project’s data files across all locations. Once a project has been created for a given set
of project cache locations, that set must not be changed. In order to move a project between different
sets of caches, archive the project.

NOTE: Do not add, remove, or amend project locations once they have been set unless they
are empty. Once projects have been created for a given set of project cache locations, that
set must not be changed or project corruption will occur.

NOTE: If the MARI_CACHE environment variable has been set, its value is used to determine
the location of the project files. In this case, Mari does not prompt you to select the project
directory. For more information on environment variables that Mari understands, please
refer to the Mari User Guide.

NOTE: You can also launch Mari in verbose mode by selecting Start > All Programs >Mari
3.1v1 >Mari 3.1v1 (Verbose Output). This way, Mari provides a running log of each action
that it performs. You can see this log in a command line window.

If you are launching Mari from the command line, you can run the application in one of two safe
modes: --safe and --safer. The --safe mode:

• Disables startup Python scripts

• Disables custom user plug-ins

• Bypasses user Python libraries.

The --safer mode performs all of the above options as well as:

INSTALLATION AND LICENSING | WINDOWS
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• Bypasses user settings.

• Bypasses user environment variables.

These safe modes are primarily used for debugging purposes. For advanced debugging methods,
please see Appendix B: Frequently Asked Questions and Troubleshooting in the Mari User Guide for more
information.

Licensing on Windows

If you simply want to try out Mari, you can obtain a trial license, which allows you to run Mari for free
for 15 days. See Install the License on page 15.

To use Mari after this trial period, you need either a valid activation key, node locked license, or a
floating license and server running the Foundry Licensing Tools (FLT):

• Activation Keys and Node Locked Licenses - these are used to license applications on a single
machine. They do not work on different machines and if you need them to, you’ll have to transfer
your license.

Node locked licenses, sometimes called uncounted licenses, do not require additional licensing
software to be installed. See Licensing Mari on a Single Machine for more information.

• Floating Licenses - these are used to license applications on any networked client machine. The
floating license is put on the server and is locked to a unique number on that server.

Floating licenses, sometimes called counted licenses, require additional software to be installed on
a server to manage the licenses and give them out to the client stations that want them. This
software is called the Foundry Licensing Tools (FLT) and can be downloaded at no extra cost from
our website.

The instructions below run through both licensing methods. You can also find a more detailed
description in the Foundry Licensing Tools User Guide available on our website:
http://www.thefoundry.co.uk/support/licensing/tools/

Licensing Mari on a Single Machine

Obtain an Activation Key

To obtain a license, you'll need your machine's System ID (sometimes called Host ID or rlmhostid).
Just so you know what a System ID number looks like, here’s an example: 000ea641d7a1.

NOTE: Bear in mind that, for floating licenses, you'll need the System ID of the license
server, not the machines on which you intend to run Mari.

There are a number of ways you can find out your machine's System ID:

INSTALLATION AND LICENSING | WINDOWS
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• Launch Mari without a license, click Status, and then scroll down the error report until you see your
System ID.

• Download the Foundry License Utility (FLU) from www.thefoundry.co.uk/support/licensing/ and run
it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from
www.thefoundry.co.uk/support/licensing/ and then run C:\Program
Files\TheFoundry\LicensingTools7.0\ Foundry License Utility.exe

When you know your System ID, you can request a license for The Foundry products:

• from The Foundry's Sales Department at sales@thefoundry.co.uk

• from the product pages on our web site, such as www.thefoundry.co.uk/products/mari/

• by launching Mari without a license and selecting:

• Buy Mari - opens a web browser directly to The Foundry website to purchase a license.

• Try Mari - displays the 15-day trial license download screen. Enter your The Foundry account
details or create a new account and follow the on-screen instructions to receive a trial license.

NOTE: By default, if you have installed a temporary license, Mari displays a dialog at start-up
alerting you to the number of days remaining. If you want to disable this behavior, you can
set the FN_DISABLE_LICENSE_DIALOG environment variable to 1 to suppress the warning
message about imminent license expiration. See Environment Variables That Mari Recognizes in
the Mari User Guide for more information.

Install the License

You are prompted to enter your activation key when you start Mari without a license. Mari skips this
step if you’ve already activated the application.

When you start the application before installing a license, a Licensing dialog displays an error,
informing you that no license was available. The installation process is dependent on what type of
license you requested:

• License file - if you requested a license file, typically foundry.lic, this option allows you to browse
to the file location and install it automatically. See Licensing on Windows for more information.

• Activation Key or license text - if you requested an Activation Key or license by email, this option
allows you to paste the key or license text into the Licensing dialog, which then installs the license
in the correct directory. See To install an Activation Key or license text for more information.

• A floating license - if you requested a floating license to supply licenses to multiple client
machines, this option allows you enter the server address that supplies the client licenses.

INSTALLATION AND LICENSING | WINDOWS
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NOTE: You must install a floating license and additional software on the license server to use
this option.

See Install Floating Licenses for more information.

TIP: If you later want to check the current status of your license (for example, to see if it’s a
node locked license or a floating license), select Tools > License in Mari to display theMari
Licensing dialog.

To install a license fromdisk
1. Save the license file to a known location on disk.

2. Launch Mari.

The Licensing dialog displays.

3. Click Install License to display the available license installation options.

4. Click Install from Disk.

5. Browse to the location of the license file.

6. Click Open to install the license automatically in the correct directory.

To install an Activation Key or license text
1. Launch Mari.

The Licensing dialog displays.

2. Click Install License to display the available license installation options.

3. Click Activation Key / License Text and then either:

• Enter the Activation Key string in place of Insert Activation Key Here. A license key typically
looks something like this:
mari-0101-77d3-99bd-a977-93e9-8035

OR

• Copy the license text and paste it over the Copy/Paste license text here string. License text
typically looks something like this:
LICENSE foundry mari_i 2016.1223 permanent 2 share=h min_timeout=30

start=23-jan-2016 issuer=sf issued=23-jan-2016 replace

_ck=6dd78e4c69 sig="60PG452MPDMMM6MJAMRGKNQAN3PEAK8JYTHN45022M0C98H

XFA9N7SAASMRABT8TUJ6FAMX8TWU0"

4. Click Install.

The license is automatically installed on your machine in the correct directory.

INSTALLATION AND LICENSING | WINDOWS
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NOTE: Activation Keys require an internet connection. If you access the internet through a
proxy server and cannot connect to the activation server, you may get an error dialog
prompting you to either:

-Click Use Proxy to enter the proxy server name, port number, username, and password.
This enables the application to connect to the activation server and obtain a license. The
license is then installed automatically, or
-Click on the web link in the dialog and use the System ID (also known as hostid) provided to
manually activate and install a license.

Licensing Mari over a Network

Obtain Floating Licenses

Alternatively, you can purchase a floating license key from our website.

1. Display your system ID by doing one of the following:

• Launch Mari without a license, click Status, and then scroll down the error report until you see
your System ID.

• Download the Foundry License Utility (FLU) from www.thefoundry.co.uk/support/licensing/ and
run it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from
www.thefoundry.co.uk/support/licensing/ and then run C:\Program
Files\TheFoundry\LicensingTools7.0\ Foundry License Utility.exe

2. Once you have provided us with your System ID number and a license key has been generated for you, you’ll
receive the license key in an e-mail or Internet download. The license key is contained in a text file called
foundry.lic. For information on what to do with the foundry.lic file, see Licensing onWindows.

Install Floating Licenses

If you requested a floating license from The Foundry, you will receive your license key (foundry.lic) in
an email or internet download. You should also receive the Foundry License Utility (FLU) application
to help you install the license key on the license server machine. The server manages licenses for the
client machines on your network.

NOTE: The FLU is also available to download from www.thefoundry.co.uk/support/licensing/

1. Make sure you have saved both the license key (foundry.lic) and the Foundry LicenseUtility application in the
same directory.

2. Run the FLU application.

INSTALLATION AND LICENSING | WINDOWS
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The license key automatically appears in the FLU window if the FLU and foundry.lic are in the
same directory.

TIP: If they are not in the same directory, you can either copy and paste the contents of the
license key or drag-and-drop the file into the FLU window.

3. Click Install.

This checks the license file and, provided that the license is valid, installs it into the correct directory.

4. In order for the floating license to work, you will need to install the Foundry Licensing Tools (FLT)
on the license server machine.

For more information on how to install floating licenses, refer to the FLT User Guide, which you can
download from our website www.thefoundry.co.uk/support/licensing/

5. Once your license server is up and running, launchMari on the client machine.

6. Click Use Server and enter the server address in the field provided. The format for the server
name is: <port>@<servername>, for example, 30001@red.

NOTE: You must perform steps 5 through 7 on each client machine that requires a Mari
license from the server.

TIP: If you later need to display theMari Licensing dialog again, you can select Tools >
License in Mari.

Further Reading
For more information on licensing Mari, displaying the System ID number, setting up a floating
license server, adding new license keys and managing license usage across a network, you should
read the Foundry Licensing Tools User Guide available on our website.

Linux
System requirements for Linux machines can be found in System Requirements and are also located
on The Foundry website.

Installation on Linux

Mari 3.1 is available to download from our website at www.thefoundry.co.uk/products/mari. The
download is in a compressed .run format.

1. Download the .run installation file from our web site.

INSTALLATION AND LICENSING | LINUX
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2. Extract Mari from the .run archivewith the following terminal command, replacing <version number> with the
current version:
sudo ./Mari<version number>-linux-x86-release-64.run

The installer displays the End User Licensing Agreement (EULA) and prompts you to accept it.

3. If you agreewith the EULA, enter y and press Return to accept the EULA. (If you don’t agreewith the EULA and
press n instead, the installation is canceled.)

By default, Mari is installed in an appropriately named folder in the current working directory.

4. That's it! Proceed with Launching on Linux.

NOTE: If you leave out sudo from the terminal command, you need to ensure that you have
sufficient
permissions to install Mari under your current working directory or selected target directory.

After the Mari application files have been installed, the installer also runs a post-installation
script that creates the following directory: /usr/local/foundry/RLM

If you don’t have sufficient permissions on the /usr/local folder for this directory to be
created, the post-installation script prompts you for your sudo password as necessary.

TIP: You can also use the following options after the terminal command when installing
Mari:
--info
This lets you see what the default installation directory is.

-- target MyMariDirectory
This lets you specify a different directory to install Mari to (in this case, MyMariDirectory).

--accept-eula
This lets you automate the installation so that you are not prompted to accept the EULA.
Note that if you use this option, you agree to the terms of the EULA. To see the EULA, please
refer to Appendix D in the Mari User Guide.

-- help
This lets you see additional help and installer options.

Here’s an example of the syntax using the --accept-eula option:
sudo ./Mari<version number>-linux-x86-release-64.run --accept-eula

INSTALLATION AND LICENSING | LINUX
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Launching on Linux
1. Open a terminal.
2. Navigate to the directory you installed Mari to.

3. Enter ./mari

4. If you haven’t installed a license forMari, you need to choose fromone of the options for Licensing on Linux.
Once you’ve done so, click Launch in theMari Licensing dialog.

Mari checks for themost frequently used graphics cards, and if a graphics card configuration is detected that's
not in the tested GPU hardware list, a dialog displays warning you about it. Depending on the configuration
detected, you have the option toQuit or Continue and, in the case of configurations with known issues, also
Ignore Permanently.

NOTE: If you ignore the warning and run Mari anyway, you may experience instability or
performance issues. If a tested graphics card configuration is detected, Mari runs as normal.

5. If you are launchingMari for the first time, you are prompted to select a directory for your project files. In the
Please Pick Project Directory dialog, navigate to the directory you want to use and click Choose.

TheMari graphical interface displays.

Please note that the project directory should be:

• empty

• local to the machine (not a network mount)

• as fast as possible

• a location that's not temporary (to avoid the data disappearing)

• a directory that the user has read and write permissions to.

Project cache locations are directories that Mari uses to store project data files. These directories
must be persistent; not in temporary locations. If more than one project location is specified, Mari
spreads each project’s data files across all locations. Once a project has been created for a given set
of project cache locations, that set must not be changed. In order to move a project between different
sets of project caches, archive the project.

WARNING: Don’t add, remove, or amend project locations once they have been set unless
they are empty. Once projects have been created for a given set of project cache locations,
that set must not be changed or project corruption will occur.

INSTALLATION AND LICENSING | LINUX
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NOTE: If the MARI_CACHE environment variable has been set, its value is used to determine
the location of the project cache files. In this case, Mari does not prompt you to select the
project directory. For more information on environment variables that Mari understands,
please refer to the Mari User Guide.

TIP: You can also launch Mari in verbose mode by using the following command:
./mari --verbose

This way, Mari provides a running log of each action that it performs. You can see this log in
a terminal window.

You can run the application in one of two safe modes: --safe and --safer. The --safe mode:

• Disables startup Python scripts

• Disables custom user plug-ins

• Bypasses user Python libraries.

The --safer mode performs all of the above options as well as:

• Bypasses user settings.

• Bypasses user environment variables.

These safe modes are primarily used for debugging purposes. For advanced debugging methods,
please see Appendix B: Frequently Asked Questions and Troubleshooting in the Mari User Guide for more
information.

Licensing on Linux

If you simply want to try out Mari, you can obtain a trial license, which allows you to run Mari for free
for 15 days. See Install the License on page 23.

To use Mari after this trial period, you need either a valid activation key, node locked license, or a
floating license and server running the Foundry Licensing Tools (FLT):

• Activation Keys and Node Locked Licenses - these are used to license applications on a single
machine. They do not work on different machines and if you need them to, you’ll have to transfer
your license.

Node locked licenses, sometimes called uncounted licenses, do not require additional licensing
software to be installed.

• Floating Licenses - these are used to license applications on any networked client machine. The
floating license is put on the server and is locked to a unique number on that server.
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Floating licenses, sometimes called counted licenses, require additional software to be installed on
a server to manage the licenses and give them out to the client stations that want them. This
software is called the Foundry Licensing Tools (FLT) and can be downloaded at no extra cost from
our website.

The instructions below run through both licensing methods. You can also find a more detailed
description in the Foundry Licensing Tools User Guide available on our website:
http://www.thefoundry.co.uk/support/licensing/tools/

Licensing Mari on a Single Machine

Obtain an Activation Key

To obtain a license, you'll need your machine's System ID (sometimes called Host ID or rlmhostid).
Just so you know what a System ID number looks like, here’s an example: 000ea641d7a1.

NOTE: Bear in mind that, for floating licenses, you'll need the System ID of the license
server, not the machines on which you intend to run Mari.

There are a number of ways you can find out your machine's System ID:

• Launch Mari without a license, click Status, and then scroll down the error report until you see your
System ID.

• Download the Foundry License Utility (FLU) from www.thefoundry.co.uk/support/licensing/ and run
it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from
www.thefoundry.co.uk/support/licensing/ and then run the following command in a terminal shell:
/usr/local/foundry/LicensingTools7.0/bin/systemid

When you know your System ID, you can request a license for The Foundry products:

• from The Foundry's Sales Department at sales@thefoundry.co.uk

• from the product pages on our web site, such as www.thefoundry.co.uk/products/mari/

• by launching Mari without a license and selecting:

• Buy Mari - opens a web browser directly to The Foundry website to purchase a license.

• Try Mari - displays the 15-day trial license download screen. Enter your The Foundry account
details or create a new account and follow the on-screen instructions to receive a trial license.
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NOTE: By default, if you have installed a temporary license, Mari displays a dialog at start-up
alerting you to the number of days remaining. If you want to disable this behavior, you can
set the FN_DISABLE_LICENSE_DIALOG environment variable to 1 to suppress the warning
message about imminent license expiration. See Environment Variables That Mari Recognizes in
the Mari User Guide for more information.

Install the License

You are prompted to enter your activation key when you start Mari without a license. Mari skips this
step if you’ve already activated the application.

When you start the application before installing a license, a Licensing dialog displays an error,
informing you that no license was available. The installation process is dependent on what type of
license you requested:

• License file - if you requested a license file, typically foundry.lic, this option allows you to browse
to the file location and install it automatically. See Licensing on Linux for more information.

• Activation Key or license text - if you requested an Activation Key or license by email, this option
allows you to paste the key or license text into the Licensing dialog, which then installs the license
in the correct directory. See Licensing on Linux for more information.

• A floating license - if you requested a floating license to supply licenses to multiple client
machines, this option allows you enter the server address that supplies the client licenses.

NOTE: You must install a floating license and additional software on the license server to use
this option.

See Licensing on Linux for more information.

TIP: If you later want to check the current status of your license (for example, to see if it’s a
node locked license or a floating license), select Tools > License in Mari to display theMari
Licensing dialog.

To install a license fromdisk
1. Save the license file to a known location on disk.

2. Launch Mari.

The Licensing dialog displays.

3. Click Install License to display the available license installation options.

4. Click Install from Disk.

5. Browse to the location of the license file.
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6. Click Open to install the license automatically in the correct directory.

To install an Activation Key or license text
1. Launch Mari.

The Licensing dialog displays.

2. Click Install License to display the available license installation options.

3. Click Activation Key / License Text and then either:

• Enter the Activation Key string in place of Insert Activation Key Here. A license key typically
looks something like this:
mari-0101-77d3-99bd-a977-93e9-8035

OR

• Copy the license text and paste it over the Copy/Paste license text here string. License text
typically looks something like this:
LICENSE foundry mari_i 2016.1223 permanent 2 share=h min_timeout=30

start=23-jan-2016 issuer=sf issued=23-jan-2016 replace

_ck=6dd78e4c69 sig="60PG452MPDMMM6MJAMRGKNQAN3PEAK8JYTHN45022M0C98H

XFA9N7SAASMRABT8TUJ6FAMX8TWU0"

4. Click Install.

The license is automatically installed on your machine in the correct directory.

NOTE: Activation Keys require an internet connection. If you access the internet through a
proxy server and cannot connect to the activation server, you may get an error dialog
prompting you to either:

-Click Use Proxy to enter the proxy server name, port number, username, and password.
This enables the application to connect to the activation server and obtain a license. The
license is then installed automatically, or
-Click on the web link in the dialog and use the System ID (also known as hostid) provided to
manually activate and install a license.

Licensing Mari over a Network

Obtain Floating Licenses

Alternatively, you can purchase a floating license key from our website.

1. Display your system ID by doing one of the following:
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• Launch Mari without a license, click Status, and then scroll down the error report until you see
your System ID.

• Download the Foundry License Utility (FLU) from www.thefoundry.co.uk/support/licensing/ and
run it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from
www.thefoundry.co.uk/support/licensing/ and then run C:\Program
Files\TheFoundry\LicensingTools7.0\ Foundry License Utility.exe

2. Once you have provided us with your System ID number and a license key has been generated for you, you’ll
receive the license key in an e-mail or Internet download. The license key is contained in a text file called
foundry.lic. For information on what to do with the foundry.lic file, see Licensing on Linux.

Install Floating Licenses

If you requested a floating license from The Foundry, you will receive your license key (foundry.lic) in
an email or internet download. You should also receive the Foundry License Utility (FLU) application
to help you install the license key on the license server machine. The server manages licenses for the
client machines on your network.

NOTE: The FLU is also available to download from www.thefoundry.co.uk/support/licensing/

1. Make sure you have saved both the license key (foundry.lic) and the Foundry LicenseUtility application in the
same directory.

2. Run the FLU application.

The license key automatically appears in the FLU window if the FLU and foundry.lic are in the
same directory.

TIP: If they are not in the same directory, you can either copy and paste the contents of the
license key or drag-and-drop the file into the FLU window.

3. Click Install.

This checks the license file and, provided that the license is valid, installs it into the correct directory.

4. In order for the floating license to work, you will need to install the Foundry Licensing Tools (FLT)
on the license server machine.

For more information on how to install floating licenses, refer to the FLT User Guide, which you can
download from our website www.thefoundry.co.uk/support/licensing/

5. Once your license server is up and running, launchMari on the client machine.

6. Click Use Server and enter the server address in the field provided. The format for the server
name is: <port>@<servername>, for example, 30001@red.
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NOTE: You must perform steps 5 through 7 on each client machine that requires a Mari
license from the server.

TIP: If you later need to display theMari Licensing dialog again, you can select Tools >
License in Mari.

Further Reading
For more information on licensing Mari, displaying the System ID number, setting up a floating
license server, adding new license keys and managing license usage across a network, you should
read the Foundry Licensing Tools User Guide available on our website.

Mac OS X
System requirements for Mac OS X machines can be found in System Requirements and are also
located on The Foundry website.

Installation on Mac

Mari 3.1 is available to download from our web site at www.thefoundry.co.uk/products/mari. The
download is in a compressed .dmg format.

1. Download the .dmg installation file from our web site.
2. Double-click on the installation file and package to start the installation. Follow the on-screen instructions. By

default, Mari is installed to /Applications on the chosen hard disk.

3. That's it! Proceed with Launching onMacOS X.

Installing Mari from the Terminal
1. Download the correct .dmg installation file from our website at www.thefoundry.co.uk.
2. Launch a Terminal window.

3. To mount the .dmg installation file, use thehdiutil attach command with the directory where you saved the
installation file. For example, if you saved the installation file in Builds/Mari, use the following command:
hdiutil attach /Builds/Mari/Mari3.1v1-mac-x86-release-64.dmg

4. Enter the following command:
pushd /Volumes/Mari3.1v1/

This stores the directory path inmemory, so it can be returned to later.

5. To install Mari, use the following command:
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sudo installer -pkg Mari3.1v1-mac-x86-release-64.pkg -target "/"

You are prompted for a password.

6. Enter the following command:
popd

This changes to the directory stored by the pushd command.

7. Finally, use the following command to eject themounted disk image:

hdiutil detach /Volumes/Mari3.1v1

NOTE: By running a silent install of Mari, you agree to the terms of the End User License
Agreement. To see this agreement, please refer to the Appendices in the Mari User Guide, or
run the installer in standard non-silent mode.

Launching on Mac OS X
1. Click Applications >Mari 3.1v1.
2. If you haven’t installed a license forMari, you need to choose fromone of the options for Licensing onMac.

Once you’ve done so, click Launch in theMari Licensing dialog.

Mari checks for themost frequently used graphics cards, and if a graphics card configuration is detected that's
not in the tested GPU hardware list, a dialog displays warning you about it. Depending on the configuration
detected, you have the option toQuit or Continue and, in the case of configurations with known issues, also
Ignore Permanently.

NOTE: If you ignore the warning and run Mari anyway, you may experience instability or
performance issues. If a tested graphics card configuration is detected, Mari runs as normal.

3. If you are launchingMari for the first time, you are prompted to select a directory for its project files. In the
Please Pick Project Directory dialog, navigate to the directory you want to use and click Choose.

TheMari graphical interface displays.

Please note that the project directory should be:

• empty

• local to the machine (not a network mount)

• as fast as possible

• a location that's not temporary (to avoid the data disappearing)

• a directory that the user has read and write permissions to.

Project cache locations are directories that Mari uses to store project data files. These directories
must be persistent; not in temporary locations. If more than one project location is specified, Mari
spreads each project’s data files across all locations. Once a project has been created for a given set
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of project cache locations, that set must not be changed. In order to move a project between different
sets of project caches, archive the project.

WARNING: Do not add, remove, or amend project locations once they have been set unless
they are empty. Once projects have been created for a given set of project cache locations,
that set must not be changed or project corruption will occur.

NOTE: If the MARI_CACHE environment variable has been set, its value is used to determine
the location of the project files. In this case, Mari does not prompt you to select the project
directory. For more information on environment variables that Mari understands, please
refer to the Mari User Guide.

You can run the application in one of two safe modes: --safe and --safer. The --safe mode:

• Disables startup Python scripts

• Disables custom user plug-ins

• Bypasses user Python libraries.

The --safer mode performs all of the above options as well as:

• Bypasses user settings.

• Bypasses user environment variables.

These safe modes are primarily used for debugging purposes. For advanced debugging methods,
please see Appendix B: Frequently Asked Questions and Troubleshooting in the Mari User Guide for more
information.

Licensing on Mac

If you simply want to try out Mari, you can obtain a trial license, which allows you to run Mari for free
for 15 days. See Install the License on page 30.

To use Mari after this trial period, you need either a valid activation key, node locked license, or a
floating license and server running the Foundry Licensing Tools (FLT):

• Activation Keys and Node Locked Licenses - these are used to license applications on a single
machine. They do not work on different machines and if you need them to, you’ll have to transfer
your license.

Node locked licenses, sometimes called uncounted licenses, do not require additional licensing
software to be installed.

• Floating Licenses - these are used to license applications on any networked client machine. The
floating license is put on the server and is locked to a unique number on that server.
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Floating licenses, sometimes called counted licenses, require additional software to be installed on
a server to manage the licenses and give them out to the client stations that want them. This
software is called the Foundry Licensing Tools (FLT) and can be downloaded at no extra cost from
our website.

The instructions below run through both licensing methods. You can also find a more detailed
description in the Foundry Licensing Tools User Guide available on our website:
http://www.thefoundry.co.uk/support/licensing/tools/

Licensing Mari on a Single Machine

Obtain an Activation Key

To obtain a license, you'll need your machine's System ID (sometimes called Host ID or rlmhostid).
Just so you know what a System ID number looks like, here’s an example: 000ea641d7a1.

NOTE: Bear in mind that, for floating licenses, you'll need the System ID of the license
server, not the machines on which you intend to run Mari.

There are a number of ways you can find out your machine's System ID:

• Launch Mari without a license, click Status, and then scroll down the error report until you see your
System ID.

• Download the Foundry License Utility (FLU) from www.thefoundry.co.uk/support/licensing/ and run
it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from
www.thefoundry.co.uk/support/licensing/ and then run
/Applications/TheFoundry/LicensingTools7.0/Foundry Licence Utility.app

When you know your System ID, you can request a license for The Foundry products:

• from The Foundry's Sales Department at sales@thefoundry.co.uk

• from the product pages on our web site, such as www.thefoundry.co.uk/products/mari/

• by launching Mari without a license and selecting:

• Buy Mari - opens a web browser directly to The Foundry website to purchase a license.

• Try Mari - displays the 15-day trial license download screen. Enter your The Foundry account
details or create a new account and follow the on-screen instructions to receive a trial license.
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NOTE: By default, if you have installed a temporary license, Mari displays a dialog at start-up
alerting you to the number of days remaining. If you want to disable this behavior, you can
set the FN_DISABLE_LICENSE_DIALOG environment variable to 1 to suppress the warning
message about imminent license expiration. See Environment Variables That Mari Recognizes in
the Mari User Guide for more information.

Install the License

You are prompted to enter your activation key when you start Mari without a license. Mari skips this
step if you’ve already activated the application.

When you start the application before installing a license, a Licensing dialog displays an error,
informing you that no license was available. The installation process is dependent on what type of
license you requested:

• License file - if you requested a license file, typically foundry.lic, this option allows you to browse
to the file location and install it automatically. See Licensing on Mac for more information.

• Activation Key or license text - if you requested an Activation Key or license by email, this option
allows you to paste the key or license text into the Licensing dialog, which then installs the license
in the correct directory. See Licensing on Mac for more information.

• A floating license - if you requested a floating license to supply licenses to multiple client
machines, this option allows you enter the server address that supplies the client licenses.

NOTE: You must install a floating license and additional software on the license server to use
this option.

See Licensing on Mac for more information.

TIP: If you later want to check the current status of your license (for example, to see if it’s a
node locked license or a floating license), select Tools > License in Mari to display theMari
Licensing dialog.

To install a license fromdisk
1. Save the license file to a known location on disk.

2. Launch Mari.

The Licensing dialog displays.

3. Click Install License to display the available license installation options.

4. Click Install from Disk.

5. Browse to the location of the license file.
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6. Click Open to install the license automatically in the correct directory.

To install an Activation Key or license text
1. Launch Mari.

The Licensing dialog displays.

2. Click Install License to display the available license installation options.

3. Click Activation Key / License Text and then either:

• Enter the Activation Key string in place of Insert Activation Key Here. A license key typically
looks something like this:
mari-0101-77d3-99bd-a977-93e9-8035

OR

• Copy the license text and paste it over the Copy/Paste license text here string. License text
typically looks something like this:
LICENSE foundry mari_i 2016.1223 permanent 2 share=h min_timeout=30

start=23-jan-2016 issuer=sf issued=23-jan-2016 replace

_ck=6dd78e4c69 sig="60PG452MPDMMM6MJAMRGKNQAN3PEAK8JYTHN45022M0C98H

XFA9N7SAASMRABT8TUJ6FAMX8TWU0"

4. Click Install.

The license is automatically installed on your machine in the correct directory.

NOTE: Activation Keys require an internet connection. If you access the internet through a
proxy server and cannot connect to the activation server, you may get an error dialog
prompting you to either:

-Click Use Proxy to enter the proxy server name, port number, username, and password.
This enables the application to connect to the activation server and obtain a license. The
license is then installed automatically, or
-Click on the web link in the dialog and use the System ID (also known as hostid) provided to
manually activate and install a license.

Licensing Mari over a Network

Obtain Floating Licenses

Alternatively, you can purchase a floating license key from our website.

1. Display your system ID by doing one of the following:
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• Launch Mari without a license, click Status, and then scroll down the error report until you see
your System ID.

• Download the Foundry License Utility (FLU) from www.thefoundry.co.uk/support/licensing/ and
run it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from
www.thefoundry.co.uk/support/licensing/ and then run C:\Program
Files\TheFoundry\LicensingTools7.0\ Foundry License Utility.exe

2. Once you have provided us with your System ID number and a license key has been generated for you, you’ll
receive the license key in an e-mail or Internet download. The license key is contained in a text file called
foundry.lic. For information on what to do with the foundry.lic file, see Licensing onMac.

Install Floating Licenses

If you requested a floating license from The Foundry, you will receive your license key (foundry.lic) in
an email or internet download. You should also receive the Foundry License Utility (FLU) application
to help you install the license key on the license server machine. The server manages licenses for the
client machines on your network.

NOTE: The FLU is also available to download from www.thefoundry.co.uk/support/licensing/

1. Make sure you have saved both the license key (foundry.lic) and the Foundry LicenseUtility application in the
same directory.

2. Run the FLU application.

The license key automatically appears in the FLU window if the FLU and foundry.lic are in the
same directory.

TIP: If they are not in the same directory, you can either copy and paste the contents of the
license key or drag-and-drop the file into the FLU window.

3. Click Install.

This checks the license file and, provided that the license is valid, installs it into the correct directory.

4. In order for the floating license to work, you will need to install the Foundry Licensing Tools (FLT)
on the license server machine.

For more information on how to install floating licenses, refer to the FLT User Guide, which you can
download from our website www.thefoundry.co.uk/support/licensing/

5. Once your license server is up and running, launchMari on the client machine.

6. Click Use Server and enter the server address in the field provided. The format for the server
name is: <port>@<servername>, for example, 30001@red.
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NOTE: You must perform steps 5 through 7 on each client machine that requires a Mari
license from the server.

TIP: If you later need to display theMari Licensing dialog again, you can select Tools >
License in Mari.

Further Reading
For more information on licensing Mari, displaying the System ID number, setting up a floating
license server, adding new license keys and managing license usage across a network, you should
read the Foundry Licensing Tools User Guide available on our website.

About Mari Non-commercial
Mari Non-commercial is a free version of Mari that runs outside the regular licensing model. Mari
Non-commercial is meant for personal, educational, and other non-commercial use. It is aimed at
students, industry professionals, and others interested in Mari. It includes most of the features of the
commercial version of Mari, offering you a chance to explore and learn the application fully while
using it from the comfort of your own home.

You can run Mari in non-commercial mode using the --nc command-line argument. For example, to
launch Mari in non-commercial mode on Mac OS X, enter:

/Applications/Mari3.1v1/Mari3.1v1.app/Contents/MacOS/Mari3.1v1 --nc

Mari Non-commercial is designed for non-commercial use only and does differ from the commercial
version in some aspects. Here are the differences:

• Mari Non-commercial projects (.mnc), can only be created and shared in Mari Non-commercial.

• The output formats .tif, .tiff, .hdr, .dds, and .ptx are not available.

• The patch count is limited to 6 patches, with a maximum face size of 4k, but unlimited channels and
layers.

• The object count is limited to 5 objects.

• The export texture resolution size has been limited to 4k.

• The export texture bit-depth is limited to 8- and 16-bit.

• The Custom Shader API has been disabled.

• Session Scripts have been disabled.

• The Nuke<>Mari bridge has been disabled.

• The use of OCIO files is limited to Nuke's default OCIO file.
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• The Advancedmode of the Node Graph has been disabled, only the Graph Layer is allowed.

• The Python Console has been disabled.

• Python user scripts cannot be run at startup.

• Python example scripts are not accessible from Mari Non-commercial.

• Support for user C API plug-ins has been disabled.

In other respects, Mari Non-commercial contains all the functionality of the commercial version of
Mari.

Support
If you experience any problems and need help, the forums are an excellent resource for finding help
and learning tips from other users.

Licensing Mari Non-commercial on Windows

Subscription licensing differs from traditional node locked or floating licenses in that a single license,
or entitlement, is valid on any authorized device up to the entitlement's maximum number of
activations.

• An Entitlement represents the right to run a The Foundry product for a set amount of time on a set
number of devices.

• An Authorized Device is a recognized device, such as a desktop computer, on which entitlements
can be activated.

For example, if an Entitlement for Mari has five activations, you can use Mari on five separate
Authorized Devices simultaneously. If you want to activate another device, you have to deactivate an
existing one, but you can activate and deactivate devices as often as you like.

To get started with Mari Non-commercial, follow these steps:

1. Create a The Foundry account using a valid e-mail address on our website, here.

2. Launch Mari in non-commercial mode as described under Launching on Windows.

A Licensing dialog displays, similar to regular licensing. Mari Non-commercial is free, but your
entitlement only contains two activations.

3. Click Authorise Device.

4. Enter your account e-mail address and password and then click Authorise Device.

5. A subscription license is created in your home directory:
C:\Users\<username>\FoundryLicensing\<SystemID>
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NOTE: Replace <username> and <SystemID> with the current user and the MAC address of
the device, respectively.

The license looks something like this: c58edf7e-17ab-435b-8d8a-b3a9b347ab11.lic

6. Once the license is installed, click Launch to start using Mari.

NOTE: On Windows, there is a known issue with user names containing non-ASCII characters
causing licensing to fail. If a licensing error similar to the following displays:
Unable to create subscription license directory: C:\Users\Zoë
Hernández\FoundryLicensing\
Try changing the license directory to an alternate location using the FN_SUBSCRIPTION_
LICENSE_DIR environment variable. Refer to the Mari User Guide in the Setting Environment
Variables section for more information.

7. If you need to deactivate an entitlement or deauthorize a device, navigate to Help > License and,
click:

• Deactivate Mari to reclaim one of your entitlements,

• Deauthorize Mari to reclaim your existing The Foundry entitlements on this device and stop
additional ones running, or

• Deauthorize All Devices to reclaim your existing The Foundry entitlements on all devices
associated with your account, and stop additional ones running.

Licensing Mari Non-commercial on Mac OS X

Subscription licensing differs from traditional node locked or floating licenses in that a single license,
or entitlement, is valid on any authorized device up to the entitlement's maximum number of
activations.

• An Entitlement represents the right to run a The Foundry product for a set amount of time on a set
number of devices.

• An Authorized Device is a recognized device, such as a desktop computer, on which entitlements
can be activated.

For example, if an Entitlement for Mari has five activations, you can use Mari on five separate
Authorized Devices simultaneously. If you want to activate another device, you have to deactivate an
existing one, but you can activate and deactivate devices as often as you like.

To get started with Mari Non-commercial, follow these steps:

1. Create a The Foundry account using a valid e-mail address on our website, here.

2. Launch Mari in non-commercial mode as described under Launching on Mac OS X.
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A Licensing dialog displays, similar to regular licensing. Mari Non-commercial is free, but your
entitlement only contains two activations.

3. Click Authorise Device.

4. Enter your account e-mail address and password and then click Authorise Device.

5. A subscription license is created in your home directory:
/Users/<username>/FoundryLicensing/<SystemID>

NOTE: Replace <username> and <SystemID> with the current user and the MAC address of
the device, respectively.

The license looks something like this: c58edf7e-17ab-435b-8d8a-b3a9b347ab11.lic

6. Once the license is installed, click Launch to start using Mari.

7. If you need to deactivate an entitlement or deauthorize a device, navigate to Help > License and,
click:

• Deactivate Mari to reclaim one of your entitlements,

• Deauthorize Mari to reclaim your existing The Foundry entitlements on this device and stop
additional ones running, or

• Deauthorize All Devices to reclaim your existing The Foundry entitlements on all devices
associated with your account, and stop additional ones running.

Licensing Mari Non-commercial on Linux

Subscription licensing differs from traditional node locked or floating licenses in that a single license,
or entitlement, is valid on any authorized device up to the entitlement's maximum number of
activations.

• An Entitlement represents the right to run a The Foundry product for a set amount of time on a set
number of devices.

• An Authorized Device is a recognized device, such as a desktop computer, on which entitlements
can be activated.

For example, if an Entitlement for Mari has five activations, you can use Mari on five separate
Authorized Devices simultaneously. If you want to activate another device, you have to deactivate an
existing one, but you can activate and deactivate devices as often as you like.

To get started with Mari Non-commercial, follow these steps:

1. Create a The Foundry account using a valid e-mail address on our website, here.

2. Launch Mari in non-commercial mode as described under Launching on Linux.

A Licensing dialog displays, similar to regular licensing. Mari Non-commercial is free, but your
entitlement only contains two activations.
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3. Click Authorise Device.

4. Enter your account e-mail address and password and then click Authorise Device.

5. A subscription license is created in your home directory:
/home/<username>/FoundryLicensing/<SystemID>

NOTE: Replace <username> and <SystemID> with the current user and the MAC address of
the device, respectively.

The license looks something like this: c58edf7e-17ab-435b-8d8a-b3a9b347ab11.lic

6. Once the license is installed, click Launch to start using Mari.

7. If you need to deactivate an entitlement or deauthorize a device, navigate to Help > License and,
click:

• Deactivate Mari to reclaim one of your entitlements,

• Deauthorize Mari to reclaim your existing The Foundry entitlements on this device and stop
additional ones running, or

• Deauthorize All Devices to reclaim your existing The Foundry entitlements on all devices
associated with your account, and stop additional ones running.

INSTALLATION AND LICENSING | SUPPORT
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Mari Model Requirements
Mari has certain modeling requirements that need to be met in order to use geometry, whether the
format of the geometry is an Object, Ptex, Alembic, or FBX file format.

Model Requirements
Mari requires your model files to be configured in a particular way.

Please bear in mind that Mari allows you to import and paint models with Overlapping UVs, like the
one shown below. However, if you paint on regions in the 3D views (orthographic or perspective),
which also overlap in 2D UV view, then you may encounter painting artifacts, as Mari is forced to
choose which of the conflicting overlapping paint strokes to bake down. To avoid this, you should
only apply paint to one of the overlapped regions at a time in the 3D views.

For example, if you paint a face where the left and right halves have been mirrored with overlapping
UVs, then you should aim to only paint on one half of the face to avoid paint clashes.

NOTE: Paint clashing due to overlapping UVs cannot occur in the UV view, so you can always
paint your model in that view if you find that your model is particularly tricky to paint in 3D
views.

Models to paint in Mari should not have:

• UVs that go over 10 on the U axis - these are ignored.
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• Stacked UVs - these cannot be individually selected in UV view. If you do have stacked UVs and
want to select an individual UV, you need to select it in either Ortho or Perspective view first, and
then switch back to UV view.

• Negative UVs - painting on these is not possible.

Although faces with degenerate UVs (UVs are squashed but their faces remain intact) can be loaded
into Mari, they can cause issues in some cases. They do not occupy any space in UV, so it's impossible
to properly paint on such faces. There is also the risk that some shaders may show undesirable
lighting effects on faces with degenerate UVs.

For Ptex modeling, please see the Ptex Modeling Requirements section in the Mari User Guide for more
information.

For Alembic and FBX modeling, please see the Alembic and FBX Modeling Requirements section in the
Mari User Guide for more information.

MARI MODEL REQUIREMENTS |



GETTING STARTED GUIDE

The Mari Workspace
The Mari workspace consists of a the menubar, a canvas, toolbars, and a status bar. Palettes, for
working with items such as channels or shaders, can be either docked to the application or made to
float wherever you find them most useful.

What It Looks Like
Here is an illustration of the Mari workspace that displays when you first open the program.

Workspace

Menubar To select Mari commands (many of which are also available using shortcut
keys and/or icons).

Toolbars To click icons for common Mari functions or settings.

Canvas Where you view and paint your geometry.

Tabs To switch between views.

Palettes Controls for viewing and changing different aspects of what's on the canvas.

Disk Usage Bar Displays how much of your cache disk has been filled.
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Workspace

Status bar Information about the project generally, progress of long operations (such as
baking), and icons.

THE MARI WORKSPACE |
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Managing Projects
A Mari project stores your work on geometries, and any associated textures. Mari's Project tab holds
all the projects you are working on.

Creating a New Project
1. Do one of the following:

Select from
menubar

or click on
toolbar

or click on the
Project tab

or type
shortcut key

File > New New Ctrl/Cmd+N

The New Project dialog box displays.

2. Set the project'sName (for you to identify it only - this is not a filename).
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3. Select the geometry file for the project in the Path field. The drop-down lists the last 10 files selected, or you can

click to browse to a file.

Variousmesh options display in the dialog directly under Path, depending on whether you open an .obj, .ptx,
.abc, or .fbx file.

• .obj files - you can select options for theMapping Scheme, Selection Sets, andMultiple
Geometries Per Object.

• .ptx files - you can select whether the mesh data in the file represents a single new object or,
when there are multiple input files, if the mesh data in each file represents a separate geometry
in a single new object by setting the Process each geometry file as a field.

For more information on theMesh options, please see Create a New Project in the Ptex chapter
of the Mari User Guide.

• .abc and .fbx files - you can select options for theMapping Scheme andMerge Type, as well as
set the objects that are to be merged in the object hierarchy.

• .fbx files only - you can set the animation Take on project creation/object load. This binds the
animation take to the object and this cannot be changed again once the animation take has
been selected and loaded.

For more information on theMesh options, please see Create a New Project in the Alembic and
FBX chapter of the Mari User Guide.

4. If you are loading an animated sequence,Mesh options displays with the additional options Start Frame, End
Frame, Single Frame, and All Frames. These provide the frame range to view either user-defined start and
end frames, a single frame, or every frame. A Frame Offset also allows you to specify how the Alembic file is
loaded into Mari. This is available for .abc or .fbx files only.

MANAGING PROJECTS |



GETTING STARTED GUIDE 44

5. To create a project frommultiple files, browse to a folder and select multiple files from the directory, before
clickingOpen.

The selected files are all shown in the Path field. These files are stored in the history as a single project under the
assigned name.

NOTE: It's only possible to create a project from multiple files with .obj and .ptx files. You
can only load one .abc or .fbx file when creating a new project.

6. In the Texture section, click to select which of the channels in the list to create. You can select a different
Category from the list – the set of channels updates with channels for your selected category.

TIP: Click Scan to make Mari scan the project's root path for any existing textures. If any
textures exist for your channels, Mari shows a green dot next to the channel. You can select
to import these textures.

7. Click boxes under Create and Import to set the options. You can right-click to get a dropdown
menu allowing you to easily create or import all the channels. As with the project name, the
channel Name is for you to identify it only - when you export you can select a different name.

8. Choose Size, Colorspace, and File Space from the dropdown menus for each channel.

9. Set the Fill to fill a channel with a specified color, by default.

10. If you select a different Depth or resolution, file sizes can vary dramatically (for example, a 2k
RGB “Byte” texture file is 2MB - whereas a 4k “Float” is 172MB).

11. Set your colorspace options for the project in the following fields:

• OCIO Config - user-defined config files or shipped OpenColorIO config files that handle
colorspace.

• Custom OCIO Config - specify the filepath for the custom (non-shipped) config file.

• Monitor - the default colorspace, which applies to thumbnails and UI elements. Typically, this
should be the same colorspace as you intend to use for the canvas.

• Color Picking - the colorspace for all color pickers, swatches, and image viewers.

MANAGING PROJECTS |
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• 8 bit Data - the default colorspace for 8-bit channels, and reading and writing image files with 8-
bit data.

• 16 bit Data - the default colorspace for 16-bit channels, and reading and writing image files with
16-bit data.

• 8 bit Scalar - the default colorspace for masks, heights, normals, depths and, generally, any
non-color image with 8-bit data.

• 16/32 bit Float Data - the default colorspace for 16- or 32-bit (float) channels, and reading and
writing image files with 16- or 32-bit, floating point data.

TIP: If you are just starting out in Mari and aren't familiar with colorspaces, you may want to
leave the colorspace fields at their default.

12. ClickOK.

Mari checks themodel for any errors that might prevent it fromprocessing; for example, touch border edges. A
Mesh Sanity Check dialog displays any warnings or errors. (Errors cancel opening themodel, but you can
continuewithwarnings.)

NOTE: For information on model requirements in Mari, refer to Mari Model Requirements.

13. Click to Continue.

Mari renders your selection and displays it on the canvas.

TIP: Depending on the size and complexity of textures, it can take several minutes the first
time you load them into a Mari project. Once saved, however, the project should open
quickly in future.

Opening Existing Projects
1. Click on the Projects tab.

This shows all the projects you have on your computer.
2. Double-click on the project to open.

NOTE: On project load, Mari looks for metadata that is over 250MB and discards anything
that is over this size. This is intended to strip corrupt and problematic data, and also affects
metadata added via the Python API.

MANAGING PROJECTS | OPENING EXISTING PROJECTS
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Using the Command Line

You can also open Mari and a specific, existing project, as well as archives using the command line.
From the Run dialog on your computer, use a command in the format of:

./mari /tmp/testproject.mra

By specifying the project name, UUID, folder path, or project.mri path, you open Mari and the
designated project.

The command line can also be used to run scripts that contain a Python call to open a project. From
the Run dialog on your computer, use a command in the format of:

./mari example_script.py

The example_script should contain the Python call to open a project.

Saving Your Project
Do one of the following:

Select from menubar or click on toolbar or type shortcut key

File > Save Ctrl/Cmd+S

TIP: Save your project often!
-Note that while your textures remain cached locally, saving does not export them, so export
often too!
-If you don't need to save (no changes since the last save), the toolbar icon is gray.

MANAGING PROJECTS | SAVING YOUR PROJECT
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Configuring Your Workspace
The Mari workspace is completely configurable. As detailed on the pages that follow, you can
customize how palettes display, your own personalized sets of brushes and colors, and shortcut keys.

Palettes
Mari uses a number of palettes - windows that you can move around your workspace, with specific
information and tools for working on your project. For example, the Channels palette shows all the
channels in the project, and has controls for editing the channels.

To open palettes:

Select frommenubar or right-click on the menubar or toolbar and select

View > Palettes > <palette
name>

<palette name>

To move, size and arrange palettes:

To... Do this...

Undock and move a
palette

Grab and drag it by its title bar to anywhere on your screen. (Or
click to undock, and then drag by its title bar).

Dock a palette to the window Move it to one of the edges of the Mari window. A dotted line
displays along the edge where it can dock.

Dock a palette to another
palette

Move it over another undocked palette. A dotted line displays
where it can dock.

Size a docked palette Grab and drag the dotted bar along the bottom or side.

Size a floating palette Drag an edge or corner.

Stack palettes Drag and drop them directly on top of one another.
Tabs appear for selecting which of the stacked palettes to display.
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Shelves
The Shelf palette lets you store customized “shelves” of brushes, colors, and images. You can also
share them with others.

Mari has the following kinds of shelves:

• TheMenu shelf stores seven items available from the F9 on-screen menu. These items must be
numbered from 1-7 to appear.

• The Personal shelf stores items you select and configure for all projects.

• The Basic Brushes shelf stores a set of predefined basic brushes.

• The Hard Surface Brushes shelf stores a set of predefined hard surface brushes.

• The Organic Brushes shelf stores a set of predefined organic brushes.

• Customized shelves you create store items you select and configure for all projects.

Customizing Shelves

To add an item (brush, color, or image) to a shelf, drag it onto the shelf.

CONFIGURING YOUR WORKSPACE | SHELVES
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Channels
Channels hold layers stacks, filled with paint layers, procedurals, and adjustments in your project. For
example, a project might have channels for diffuse color, displacement, or specularity, but each of
those channels contain individual layers for paint, masks, and filters. Channels can then be used in
shader inputs so you can adjust the amount of diffuse or specularity, among other things.

Adding a Channel to a Project
1. Do one of the following:

Select from the Channelsmenu or from the Channels
palette, click

or right-click on the Channels
palette and select

Add Channel Add Channel

The Add Channel dialog box displays, allowing you to set the options for the new channel.
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2. Select a name, size, depth, color and file space, and base color for the channel (as with a new project), and click
Ok.

The new channel displays in the Channels palette.

NOTE: If you are working with a Ptex project, the patch Size option appears grayed out, as
the .ptx format doesn’t work with patches.

TIP: If there are multiple objects in your project, there is no Ok button in the Add Channel
dialog. Instead, you need to choose whether you want to add the channel to only the current
object or All Objects.

Adding a Set of Channels
1. Do one of the following:

Select from the Channelsmenu or right-click on the Channels palette and select

Channel Presets Channel Presets

The Channel Presets dialog box displays.

2. Select the Import and Resize options for the channels you're creating.

The list of channels at the bottomof the dialog box allows you to set whether you want to create the preset
channels from scratch or from an imported file. Set the channel options as you would in theAdd Channel
dialog.

CHANNELS | ADDING A SET OF CHANNELS
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3. If you have existing textures to import into the new channels, set theRoot Path andmake sure that the Files
for each channel show the correct texture files.

4. ClickOK to create and import the new channels.

TIP: To toggle quickly between the last two selected channels (while in the painting canvas),
press T.For other options, such as locking or resizing a channel, right-click in the Channels
palette or click on the Channelsmenu.

CHANNELS | ADDING A SET OF CHANNELS
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Layers
Layers are the source of your paint textures in a project. Layers are created as part of a layer stack,
which is in turn held within a specific channel. Each channel has a different layer stack that contains a
new set of layers. You can create paint layers, layer masks, adjustments, procedurals, and layer
groups within the Layers palette.

Add a Layer to a Layer Stack
1. Do one of the following:

Select from the Layersmenu or from the Layers
palette, click

or right-click on any layer in the
Layers palette and select

Add New Layer Add New Layer

A new layer appears in the Layers palette, above any other layers in the layer stack.

2. The paintable icon appears orangewhen the layer is selected and the paintable component is active.

Add a Mask to a Layer
1. Do one of the following:

Select from the Layersmenu or from the Layers
palette, click

or right-click on any layer in the
Layers palette and select

Layer Mask > Add Mask >
Reveal All or From Alpha

Layer Mask > Add Mask > Reveal
All or From Alpha

A layer mask is added to the selected layer in the Layers palette.

2. Themask icon appears orangewhen the layer is selected and themask component is active.

TIP: To switch back and forth between components on a layer, simply click on the
component icons.
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Add an Adjustment to a Layer Stack
1. Do one of the following:

Select from the Layersmenu or from the Layers
palette, click

or right-click on any layer in the
Layers palette and select

Add Adjustment Layer > any
adjustment from the dropdown
menu

Add Adjustment Layer > any
adjustment from the dropdown
menu

An adjustment layer appears in the Layers palette, above any other layers in the layer stack.

2. The adjustment icon appears orangewhen the layer is selected and the adjustment component is active.

Add a Procedural to a Layer Stack
1. Do one of the following:

Select from the Layersmenu or from the Layers
palette, click

or right-click on any layer in the
Layers palette and select

Add Procedural Layer > any
procedural from the dropdown
menu or sub-menus.

Add Procedural Layer > any
procedural from the dropdown
menu

A procedural layer appears in the Layers palette, above any other layers in the layer stack.

2. The procedural icon appears orangewhen the layer is selected and the procedural component is active.

Group Layers
1. Do one of the following:

LAYERS | ADD AN ADJUSTMENT TO A LAYER STACK
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Select from the Layersmenu or from the Layers
palette, click

or right-click on any layer in the
Layers palette and select

Add Empty Layer Group or
Group Layers

Add Empty Layer Group or Group
Layers

If you chose to add an empty layer group, this group is added as a new layer in the Layers palette,
above any other layers in the layer stack.

If you chose to group existing layers together in the layer stack, you must have one or more layers
selected. This group is created at the point of the top-most selected layer.

2. To add new layers to an empty layer group, simply drag existing layers into the group.

Alternatively, once you’ve added a layer to the group, select any layer within it and Add New Layer.

3. All layers within a groupmaintain any component icons associated with them. The group parent layer has a

folder icon to distinguish it as the group layer.

LAYERS | GROUP LAYERS



GETTING STARTED GUIDE

Shaders
Shaders control how Mari displays the model on the canvas. Mari's default shaders show the paint in
either the Current Channel, Current Layer and Below, Current Layer, or Current Paint Target.
You can also create your own custom shaders by combining diffuse and specular shader types then
setting up channels in the shader component inputs to specify how they appear in the shader.

Create a Shader
1. Do one of the following:

Select from the Shadingmenu or from the Shaders
palette, click

or right-click on the Shaders palette
and select

Add New Shader > any shader
from the dropdown menu

any shader from the dropdown
menu

The new shader displays in the list, with shader components shown at the bottom of the palette.

2. Instead of selecting shader types from themenu (Phong orBlinn, for example) you can specify the diffuse and
specular by selecting Choose Diffuse and Specular from themenu.

TheCreate Shader dialog appears.
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Select your Diffuse and Specular shader options and click OK.
3. All shaders are created with theCurrent Channel in theDiffuse Color shader component. You can change this,

and set the other components by clicking on the dropdownmenu next to the component name and selecting
the channel.

4. If you haven’t yet created a channel to use in a specific shader component, click the add channel icon next
to the shader component.

TheAdd Channel dialog box appears. Select the options for your channel from the dialog and clickOk.

5. Once you’ve set a channel to the shader component, adjust the value or level of the component, using the
sliders.

You can add as many shaders as you need and compare them or switch back to the default shaders
at any time.

TIP: Shaders don’t affect the contents of the channels. For example, if you have a shader
with channels set in both the diffuse and specular color inputs, the model on-screen displays
the effects of both channels. However, the channels are still separate and contain different
data.

TIP: If you build a shader that takes data from multiple channels, it can be hard to
remember which channel you're currently editing. In this case, you can switch back to one of
the default shaders, which just shows the contents of the current channel, layer and below,
layer, or paint target.

SHADERS |
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Changing the View
As described below, Mari includes features for 3D navigation to view your model from various angles
and perspectives, change the lighting on the mesh, and change the resolution of textures.

3D Navigation

To...

Zoom in and out Alt+Ctrl/Cmd-click and drag, OR Right-click and drag

Pan left and right Alt+Shift-click and drag, OR Middle-click and drag

Rotate the model Alt+left-click and drag

Spin the camera Alt+Ctrl/Cmd+R+left-click and drag

NOTE: In many Linux windows managers, the Alt key is used by default as a mouse modifier
key. This can cause problems in 3D applications where Alt is used for camera navigation in
3D environments.

You can use key mapping to assign the mouse modifier to another key, such as the
(Super orMeta) key, but the method changes depending on which flavor of Linux you're
using. Please refer to the documentation on key mapping for your particular Linux
distribution for more information.

TIP: By default, Mari uses momentum when you are moving the view. When you let go of the
mouse button, the model slowly coasts to a stop. You can turn this behavior off so that the
model only moves when you are holding the mouse button down.

To do so, change the settings in the preferences by uncheckingMomentum Enabled via Edit
> Preferences > Navigation.
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The navigation toolbar also provides the ability to control panning, zooming, rolling, and orbiting,
with various settings for each. You can easily access the toolbar, shown below, at any time using the
following buttons:

• Reset navigation settings to default.

• Enable panning to move the model on the screen.

• Enable zooming to zoom in or out on the model.

• Enable rolling to turn on the momentum system.

• Enable orbiting mimics the orbiting system in Maya and allows you to move the camera around the
model.

• Disable rotational snapping gives options to turn on and change the angle at which the camera view
snaps to (45 degrees or 90 degrees).

You can also use the keys 1-6 to switch between preset views (left, right, top, bottom, front, and back).

In the UV view, you can also rotate or reset the model for easier viewing and painting. Press 1 to reset
the model back to its default position. Press 2, 3, and 4 to rotate the model counter-clockwise in 90-
degree increments from the default position.

Press Home to cycle between hiding all palettes, hiding docked palettes and showing hidden palettes.

Use the tabs at the top of the canvas to switch between:

• UV - a grid view showing the UV patches.

• Ortho/UV - a splitscreen showing the UV patches and the orthographic view.

• Perspective - a perspective camera view, or

• Ortho - an orthographic camera view.

TIP: You can also use the , , and toolbar buttons or the F10, F11, and F12
keyboard shortcuts to activate a particular view on any tab.

Lighting
You can change the lighting on the main mesh by clicking on the toolbar:

CHANGING THE VIEW | LIGHTING
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Flat Basic Full

Mari has five lights: four basic point lights, which appear on the drawing canvas, and one
environment light.

You can set the light details in the Lights palette. Mari uses these in the Basic and Full lighting
modes:

• To turn a light on or off, click on the icon in the list, or use the General > On checkbox.

• To change a light, click on it in the Lights list, and then set the color and strength.

• Select whether the light is fixed to the Scene or Camera.

• To move a light around, select the Transform selected object tool , then click and drag the light
around on the canvas, or adjust it with the transform handles.

• To move a light to the camera position, click on the icon on the Lights palette, or right-click on
the light and selectMove to Camera Position.

You can toggle the shadows on and off in the Lighting toolbar:

Shadows on Shadows off

This simply toggles the display of shadows on the canvas, but does not disable shadow processing.

• You can control Shadow Rendering through the option on the Lights palette.

CHANGING THE VIEW | LIGHTING
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• Toggle shadows by clicking on the Shadows icon in the Lighting toolbar or the Shadingmenu.

• If you want to enable shadow processing, you need to enable the Depth Projections checkbox
under Preferences > GPU | Depth Projection. By default, this preference is disabled.

CHANGING THE VIEW | LIGHTING
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Painting
Painting in Mari is similar to other standard paint programs. Paint using the various tools, then bake
it onto your model. Most tools work on unbaked paint, but one or two also work directly on the
baked paint on the surface. Each tool has a set of keys that control how it works. By default, the
option keys for the current tool are shown on-screen at the top of the canvas.

Paint Tools
To select a tool, select from your shelves or the Tools toolbar:

Paint tools

Select Marquee select Transform paint buffer
Zoom paint buffer

Transform selected
object

Vector Inspector Blur Warp

Slerp Pinup Paint Vector Paint

Erase Paint through Paint gradient Clone stamp

Towbrush Color picker/ Pixel
analyzer

Painting a Constant Color
1. Click to select the Paint tool.
2. Click and drag to paint on themodel.

61



GETTING STARTED GUIDE 62

TIP: You can paint a straight line by clicking one end point, moving the cursor, pressing Shift
and clicking the second end point, or pressing Shift and holding down the mouse button
while moving horizontally or vertically.

Customizing Your Brush
1. Open the Brush Editor palette.

The Brush Editor displays.

TIP: Resize the brush editor palette to minimize scrolling. There are many options for
customizing your brush, including setting values for Paint, Pressure, Radius, Rotation,
Bitmaps to use, Geometry and Noise. You can test the brush in the scratch pad at the
bottom of the palette.

2. You can select a brush to modify from those available in your Shelves.

3. When you have finished editing a brush, click to add it to the selected shelf.

“Painting Through” an Image
1. Open the Image Manager palette.

2. To load an image, click , navigate to and select the image file, and clickOpen.

PAINTING | CUSTOMIZING YOUR BRUSH
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A thumbnail of the image displays, along with information about the selected image.

3. In the Tools toolbar, click (the Paint Through tool).

4. Drag and drop the image from the Image Manager to the canvas.

5. Adjust the image size and position:

To... Do this...

Resize Grab and drag its edges or corners, or press Ctrl/Cmd+Shift then click
and drag.

Move Grab the “handle” in the center of the image (or press Shift and click
anywhere on the image), and drag.

Rotate Click and drag outside the image, or press Ctrl/Cmd and drag inside the
image.

Press Shift when dragging outside the image to rotate in increments.

Crop Double-click the image in the Image Manager, drag the area you want

to crop, and click .

Change the opacity In the Tool Properties palette, select Texture > Preview, and change
the Preview Alpha (enter a number or drag the slider). Pre-multiply
alpha if your image has transparency.

Reset the image In the Tool Properties palette, select Texture > Transform > Reset.

6. Paint!

TIP: You can quickly switch between the Paint and Paint Through tools by pressing P andU. To hide the
image, hold the ? key, to paint thewhole image onto themodel in one step, press the ' (apostrophe) key.
Toggle repeat image to paint past the edge of the floating image and have the paint continue, by pressing
the ; (semicolon) key.

Clone Stamping
1. Click to select the clone stamping tool.
2. Use the Sourcemenu on the toolbar to select where to take the clone source from. You can select the current

paint target, an image, or any of the paint layers in the project.

PAINTING | CLONE STAMPING



GETTING STARTED GUIDE 64

3. If you’re using an image as your clone source, hold down theCtrl/Cmd key over the image and click to select the
clone source point.

TIP: When cloning from a paint layer, you can clone directly from the surface. In thismode, the tool clones
the paint from the paint layer surface straight up into the paint buffer directly above that point. This lets
you copy themodel's surface into the paint buffer so you can edit it and then re-bake.

To use thismode, hold down Ctrl+ (orWindows key) when you click to set the origin point. ForMac,
this shortcut is Cmd+Ctrl.

4. Paint to clone your selection on themodel.

Moving and Warping Paint

To move paint on the model before baking:

1. Click to select the transform tool.

2. Left-click anywhere on the paint buffer and drag to move the painting around on themodel.

3. Ctrl/Cmd+left-click and drag to rotate the painting, or left-click and drag outside the paint buffer.

4. Ctrl/Cmd+Shift+left-click and drag to resize the painting, or grab the corners of the paint buffer and drag.

TIP: The paint buffer is visible on-screen as a white box, but it may be larger than the view
window and not visible. It becomes obvious if you move or resize the painting. To reset the
paint buffer to its default values click the Reset button in the Painting palette under Paint
Buffer > Transform.

To warp paint before baking:
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Using this tool... You can...

Warp Shift+click and drag to create a warp grid. Click and drag the
points around to warp the paint. To increase or decrease the grid
resolution, press the up or down arrow keys.

Slerp Use the Slerp Mode menu on the toolbar to set the mode (from
Pull, Grow, Shrink, or Rotate). Click and drag to apply your effect.
Erase distortion by selecting the Erase mode.

Pinup Shift+click to set “pins”. Then click and drag to move the pins. You
can use pins to protect parts of the paint that you don't want
affected by the distortion.

Baking Paint onto theModel
To bake paint onto your model:
1. Make sure all patches you want to bake are selected.

2. Do one of the following:

Type shortcut key or click on status bar icon

B

TIP: Whenever you change your view of the model, it bakes automatically. You can change
this setting in the Projection palette if required.

Blurring Baked Paint
1. Click to select the blur tool.

2. Left-click and drag to blur paint baked on the surface.

TIP: As with the paint tools, you can edit the blur brush tip. When you have finished blurring
the paint, you need to bake.
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Exporting and Importing
You can export and import both channels and layers in your project, both in ’flat’ formats, such as
.png, and in layered formats, such as .psd or .psb. This is especially useful when exporting multiple
layers or channels that you don’t want to take up a lot of space, or when you want to use the final
output of a channel in another application.

Exporting Channels
To export the current channel, select a single channel to export and do one of the following:

Select from the Channelsmenu or right-click on the Channels palette and select

Export > Export Current Channel Export > Export Current Channel

Export Flattened> Export Current Channel
Flattened

Export Flattened> Export Current Channel
Flattened

The Export dialog box displays.
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To export all channels in your project, do one of the following:

Select from the Channelsmenu or right-click in Channels palette and select

Export > Export All Channels Export > Export All Channels

Export Flattened > Export All Channels
Flattened

Export Flattened > Export All Channels
Flattened

The Export dialog box displays.

To export everything in your project, including all layers, channels, and patches, do one of the
following:

Select from the Channelsmenu or right-click in Channels palette and select

Export > Export Everything Export > Export Everything

Export Flattened > Export Everything Flattened Export Flattened > Export Everything
Flattened

The Export All dialog box displays.

NOTE: All of the methods for exporting textures shown above follow the same instructions
once they reach the Export dialog.

1. On the Sequence tab, enter the Path where you want to store the export, or use the browse panes (the
navigation panes below) to browse to it.

TIP: Make sure you check the path and name carefully, especially if you have been swapping
between assets - Mari defaults to the last place you've exported. Don't risk overwriting your
textures!

2. If you are looking for a specific folder or file, you can use the Filter field to specify a name or file format to
search for.

3. For the Template, either use the default filename template or edit it as required. You can also specify whether
to use the template forOnly this layer or Everything.

4. Set theColorspace in which you want to export the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel.

5. Decidewhether Small Textures is enabled or disabled. If enabled, Mari exports any patches that you haven't
painted yet, or have painted as a single color, as 8x8-pixel textures. When you start to paint on a particular
patch, Mari exports it as the correct size.
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6. Choose to eitherKeep orRemove alpha channels when exporting channels. This can help decrease the resulting
file size when exporting.

7. Click Export All Patches (to export all patches in the current channel) to export with the settings you’ve
selected.

NOTE: The steps above assume you are exporting a sequence of patches with the udim
number (1001, 1002, etc.) in the file names. For more information on how UDIM numbers
are allocated to patches, please see the section on Using UDIM Values in the Working with
Patches chapter of the Mari User Guide.

NOTE: If you'd rather assign individual files to each patch, you can do so on the Named Files
tab of the Export Channel dialog. Click the buttons on the right to open a file browser and
pick a file for each patch. Then, click Export All Patches to export the files. Note that by
default the Named Files tab doesn't display if you have more than 20 patches in your object.
To change this number, you can use the Patch Cutoff preference or set the MARI_
NAMEDFILEIMPORT_SEQUENCELIMIT environment variable to a new value.

Exporting Layers
To export selected layers, select any layers you want to export and do one of the following:

Select from the Layersmenu or right-click on the Layers palette and select

Export > Export Selected Layers Export > Export Selected Layers

Export Flattened > Export Selected Layers
Flattened

Export Flattened > Export Selected Layers
Flattened

The Export dialog box displays.

To export all layers in the channel, do one of the following:

Select from the Layersmenu or right-click in Layers palette and select

Export > Export All Layer Export > Export All Layers

Export Flattened > Export All Layers
Flattened

Export Flattened > Export All Layers Flattened

EXPORTING AND IMPORTING | EXPORTING LAYERS



GETTING STARTED GUIDE 69

The Export All dialog box displays.

NOTE: All of the methods for exporting layers shown above follow the same instructions as
for exporting channels once they reach the Export dialog. These instructions begin with step
1 in Exporting Channels.

Importing Channels
To import into your current channel’s layer stack, do one of the following:

Select from the Channelsmenu or right-click in Channels palette and select

Import > Import into Layer Stack Import > Import into Layer Stack

The Import dialog box displays.

1. Enter the Path to the files to import, or use the browse panes (the two left-hand navigation panes)
to browse to them.
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2. If you are looking for a specific folder or file, you can use the Filter field to specify a name or file format to
search for.

3. For the Template, either use the default filename template or edit it as required.

4. Set theColorspace in which you want to export the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel.

5. Set howMari handles patch/image sizemismatches. You can select either to resize the Images to match the
patches, or to resize the Patches to match the images.

6. Choose to eitherKeep orRemove alpha channels when importing channels. This can help decrease the
resulting file size when exporting.

7. To import all patches from theirmatching files, click Import All Patches, or Import Selected Patches when at
least one patch is selected.

NOTE: The steps above assume you are importing a sequence of patches with the UDIM
number (1001, 1002, etc.) in the file names. For more information on how UDIM numbers
are allocated to patches, please see the section on Using UDIM Values in the Working with
Patches chapter of the Mari User Guide.

NOTE: If you'd rather assign individual files to each patch, you can do so on the Named Files
tab of the Import Channel dialog. Click the buttons on the right to open a file browser and
pick a file for each patch. Then, click Import All Patches to import the files. Note that by
default the Named Files tab doesn't display if you have more than 20 patches in your object.
To change this number, you can use the Patch Cutoff preference or set the MARI_
NAMEDFILEIMPORT_SEQUENCELIMIT environment variable to a new value.

To import into a new channel, do one of the following:

Select from the Channelsmenu or right-click in Channels palette and select

Import > Import into New Channel Import > Import into New Channel

The Add Channel dialog box displays.
1. Follow the instructions for setting up a new channel in Adding a Channel to a Project, and when you’ve finished,

clickOk.

The Import dialog box displays.

2. Enter the Path for the files to import, or use the browse panes (the two left-hand navigation panes) to browse to
them.
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NOTE: The steps above assume you are importing a sequence of patches with the UDIM
number (1001, 1002, etc.) in the file names. For more information on how UDIM numbers
are allocated to patches, please see the section on Using UDIM Values in the Working with
Patches chapter of the Mari User Guide.

NOTE: If you'd rather assign individual files to each patch, you can do so on the Named Files
tab of the Import Channel dialog. Click the buttons on the right to open a file browser and
pick a file for each patch. Then, click Import All Patches to import the files. Note that by
default the Named Files tab doesn't display if you have more than 20 patches in your object.
To change this number, you can use the Patch Cutoff preference or set the MARI_
NAMEDFILEIMPORT_SEQUENCELIMIT environment variable to a new value.

Importing Layers
To import into the current layer, do one of the following:

Select from the Layersmenu or right-click in Layers palette and select

Import > Import into Layer Import > Import into Layer

The Import dialog box displays.

To import as a layer in the current layer stack, do one of the following:

Select from the Layersmenu or right-click in Layers palette and select

Import > Import into Layer Stack Import into Layer Stack

The Import dialog box displays.

NOTE: All of the methods for importing layers shown above follow the same instructions as
for importing channels once they reach the Import dialog. These instructions begin with step
1 in Importing Channels.
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About the Tutorials
As part of the Getting Started Guide, there are several tutorials that give you a chance to try your hand
at setting up a project and getting started with the basics. The tutorials are self-paced but designed to
take roughly 10 to 45 minutes each. You might find yourself breezing through one while spending a
lot of time on another to soak up details you're not quite sure about.

The tutorials included in this manual are:

• Tutorial 1: Setting up a Project

• Tutorial 2: Setting the View

• Tutorial 3: Painting!

• Tutorial 4: Painting Through and Clone Stamping

• Tutorial 5: Exporting and Importing

Download Sample Files
Sample files are provided for use with all of the tutorials. You can download these files from The
Foundry support page.

Tutorial Format
Mari tutorials include steps, which are the specific instructions for you to perform. Steps are
organized into major actions. For example, all the steps involved in loading the geometry when
creating a project are grouped on a page with the title “Load geometry”. The individual steps are
numbered, and describe what you should do and what happens in Mari. For example:

1. Next, to bring in the geometry, click .

The Pick Mesh dialog box displays.

Note that the response to each step (what happens when you do it) is in italics, and the name of any
dialog box or UI item that displays as part of that response is bold.
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Tutorial 1: Setting up a Project
This lesson teaches you what Mari projects are, and how to create them.

What You Should Know Before Starting This Lesson

This lesson assumes:

• a basic knowledge of computers and graphics applications

• that you have read the Mari Getting Started Guide up to this point

• that you know how to start Mari (see Launching on Windows, Licensing on Linux, or Launching on
Mac OS X).

Resources You Need to Complete This Lesson

To complete this lesson, you need access to a computer that can run Mari, and the following sample
file:

• blacksmith_body.obj

How Long Should It Take?

Plan on spending about 20 minutes to complete this lesson.

About Mari Projects
A Mari project holds your work on geometries and associated textures. Once you've created a Mari
project, you can work on it, save and close - and then re-open it to continue working on the same
textures later.

Projects also hold other items, such as projectors, shaders, and so on. Mari saves some settings at
the project level. For instance, each project has:

• a project shelf, to hold brushes, colors, and images for you to use specifically in that project, and

• contents of the various palettes - Image Manager, Brush Editor, and so on.
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When you first create a project, you can specify its parameters, including:

• the details (such as resolution and color depth) of the initial channel in the project.

• the range of animation frames to import.

Open a New Project
1. Start Mari.

The Mari workspace displays, showing the Projects tab. This holds all the projects you have been
working on.

2. As withmost commands in Mari, you can select theNew Project option a few different ways:

• from the Filemenu, select New,

• click on the toolbar,

• click the New button,

• right-click in the Projects tab and select New from the dropdown menu, or

• press the Ctrl/Cmd+N shortcut key.

Pick any one of the options above.

The New Project dialog box displays.

The New Project dialog box has four parts:

• Name - a name for your project.
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• Geometry - the model you'll be painting on.

• Texture - parameters for the textures you'll be creating.

• Colorspace - parameters for the colorspace of your project and for the color pickers, swatches,
and images.

Next we'll specify the name and texture options, and then select the geometry.

NOTE: For more information on what kind of models Mari expects, see Mari Model
Requirements.This model displays with no errors. Mari loads the geometry and displays it in
your workspace.

TIP: For more on the different options in the New Project dialog box - and other dialog
boxes illustrated in this tutorial, see the Mari Reference Guide.

Specify Project Options
1. For the project Name, type 1-Blacksmith.
2. For the Texture options, right-click on the list of channels and select Create All.

Load Geometry
1. Next, to bring in the geometry, click .

The Pick Mesh dialog box displays.
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2. Navigate to your tutorial folder, click to highlight blacksmith_body.obj, and clickOpen.

NOTE: When you load geometry,Mesh Options appear for themodel you’ve entered in the Path field.
For this tutorial, leave themesh options as they are, but formore information on theMesh Options refer
to theNew Project Dialog chapter in theMari Reference Guide and the Ptex chapter in theMari User Guide.

3. ClickOk.

Mari conducts a quick “sanity check” on themodel to make sure there are no obvious problems. If there are any
problems, it displayswarnings or errors. If there arewarnings, you can continue. If there are errors, youmust
stop and fix them.

TIP: Depending on the size and complexity of a model, it can take several minutes the first
time you load it into a Mari project. Once saved, however, the project should open quickly in
future.

TUTORIAL 1: SETTING UP A PROJECT | LOAD GEOMETRY



GETTING STARTED GUIDE 77

Save Your Project
Save your project - again you can do this a few ways:

• from the File menu, select Save,

• click on the toolbar, or

• press the shortcut key Ctrl/Cmd+S.

Mari saves the project into its project directory. Now, if you click on the Projects tab at the top of the
screen, you see your new project in the list.

Where Do You Go from Here?
At this point, you should have a basic idea of what a Mari project is and how to create one. You
learned how to:

• Name the project.

• Set texture options.

• Load geometry.

• Save the project.

Next, you'll use this project to practice some basics about setting the camera and lighting on the
geometry in your project, before you begin to paint on it. When you're ready, proceed to Tutorial 2:
Setting the View.
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Tutorial 2: Setting the View
This lesson teaches you how to open a Mari project, and then set the view and lighting on your
geometry (before painting on it).

Setting the view includes:

• rotating

• zooming in or out

• panning

• viewing from six basic directions

• displaying a split view showing a 3D view plus UV patches

Setting the lighting includes:

• picking “flat”, “basic”, or “full” lighting,

• toggling shadows on or off,

• moving lights around and adjusting their properties.

What You Should Know Before Starting This Lesson

This lesson assumes:

• a basic knowledge of computers and graphics applications

• that you have read the Mari Getting Started Guide up to this point

• that you know how to start Mari (see Launching on Windows, Launching on Linux, or Launching on
Mac OS X)

• that you have completed Tutorial 1: Setting up a Project.

Resources You Need to Complete This Lesson

To complete this lesson, you need access to a computer that can run Mari, and the following sample
file:

• 1-Blacksmith - the Mari project file you created in Tutorial 1
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How Long Should It Take?

Plan on spending about 25 minutes to complete this lesson.

About Mari View and Lighting
The view in Mari is a view on the object you are painting. By default, Mari has four types of view:

• UV - this gives you a “flat” view of the patches in the model.

• Perspective - this show the model as a whole in 3D space, through a perspective camera.

• Ortho - this shows the model as a whole in 3D space, through an orthographic camera.

• Ortho/UV - this is a split screen, showing both the UV patches and the orthographic view.

UV View Ortho View

Ortho/UV View

You can move each view separately.

TIP: You can also use the , , and toolbar buttons or the F10, F11, and F12
keyboard shortcuts to activate a particular view on any tab.

Within the views, you can:

• Spin or rotate the model (3D views only). Spinning turns the model on one axis, while rotating lets
you turn the model in all three axes. Think of spinning as like turning the model on a turntable,
while rotate is turning it around in midair.
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• Pan to move the view across the model.

• Zoom in or out.

• Focus on a selected patch.

You separately configure the lighting on the object by selecting preset settings for “flat”, “basic”, or
“full”, or specifying fine details such as shading parameters and separate lighting for each of the four
configurable lights.

Open Your Project
1. Start Mari.

The Mari workspace displays.
2. On the Projects tab, double-click on your 1-Blacksmith project to open it.

Your project opens and switches to theOrtho view.

Adjust the View
To adjust the view on your project, you can zoom, pan, rotate, select one of six preset views, display
your model and patches in a split screen, or use perspective and orthographic views.
1. To zoom out and in, hold down theAlt key, right-click and drag the cursor to the left and right.
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2. To pan, hold down theAlt key andmiddle-click (or hold Alt and Shift and left-click and drag).

3. To rotate, hold down theAlt key, left-click and drag.

TIP: You can also “spin” around a fixed point by pressing Ctrl/Cmd+R, left-clicking, and dragging. When
you rotate or spin, the pivot point is located in the center of the current view.

4. To view from six basic preset angles (camera “left”, “right”, “top”, “bottom”, “front”, and “rear”), press 1, 2, 3, 4, 5,
or 6, or select the angle from theCameramenu.
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5. To see a flat view of theUV patches on themodel, click theUV tab.

To see a split screen showing both theOrtho and UV views, click theOrtho/UV tab.

6. To see a perspective view of yourmodel, click the Perspective tab (or press F11).
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In the Perspective view, you can alter your model’s appearance in the viewer by entering Near,
Far, and FoV values in the Canvas toolbar. See Setting the Perspective Camera Details in the
Customizing the View chapter in the Mari User Guide for more information.

7. To see an orthographic view of yourmodel, click theOrtho tab (or press F10). This is the default viewmode, that
is, the view you seewhen you start Mari.

NOTE: The model is in the same position in steps 6 and 7; only the view mode has changed.
Notice that the model’s arms appear closer to the body due to the application of perspective.

8. To switch the view to display all selected patches, pressA.

If you don't have any patches selected, the view focuses on themodel as awhole (changing to show thewhole
model).

TIP: If you find that the view starts cutting through the front clipping plane, try pressingA.

9. To center the view at a particular place on themodel, move the cursor there and press F.
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At the current size and angle, the view changes to focus on the cursor point. If you hover the cursor over the
canvas where no part of the object is present, pressing F brings the focus on the entire object.

TIP: You can paint in any of the views.

Moving the view bakes the current paint if Bake Behavior is set to AutoBakeAndClear. You
can set this on the Projection palette, under Projection (if you can't see the Projection
palette, select View > Palettes > Projection to display it).

EXPERIMENT: Play around with zooming, panning, and rotating the camera. Try changing
between Ortho and Perspective modes. Notice that objects closer to the camera distort far
more than objects further away?

Adjust the Lighting
Mari comes with three lighting presets: flat, basic, or full. In basic and full modes, you can move the
lights around the model.

1. To change the lighting:

• from the Shadingmenu, select Flat, Basic, or Full, or

• click , , or on the toolbar.
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2. Notice the four lights on the canvas (youmay need to select the Transform selected object tool to see
them).

By default, the lights appear as gray spheres .

TIP: Ensure that the lights are on by clicking any of the light bulbs in the Lights palette, and
the Render Lights option in the Display Properties dialog. You may need to zoom out to
view the lights on the canvas.

3. To move a light around, select the Transform selected object tool (if you didn't already). Click on a light
and drag it around the canvas, or use the transformhandles to adjust it.

As youmove the light, you can see the effect on themodel.

4. You can also make fine adjustments to lighting using the Lights palette. If it's already open, click the Lights tab
to give it focus; or if it's closed, right-click in the toolbar area on top of theMari workspace and select Lights to
open it.

The Lights palette displays details of four basic lights, which you can enable or disable, and
customize by adjusting their Color and Fixed To information, and an environment light, which
you can adjust to add environment lighting from an image. For details, see the Customizing the
View chapter in the Mari User Guide.

5. Lighting can be relative to the Scene or a Camera:

• Scene (default) - the light is fixed to the model, for example if a light is set at the model's back,
it always points at the model's back, no matter how you move the view.
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• Camera - the light is fixed to a camera view, for example you can have a light always shining
from above the camera, allowing you to move the model around and cast light on different
areas.

6. A single light can bemoved to the position of the current camera by right-clicking the light and selectingMove
to Camera Position or clicking on theMove to Camera Position icon when the desired light is selected.

7. Select theRender Shadows checkbox to produce shadows for an individual light.

Shadows render and display immediately for the selected light.

8. Shadows can be enabled or disabled in the display by toggling the Shadows icon in the Lighting toolbar or
the Shadingmenu.

NOTE: Mari saves custom lighting with the project. If you need the same lights in another
project, you need to set them up separately.

Where Do You Go from Here?
At this point, you should have a basic idea of the different options for adjusting the view and lighting
on your model. You learned how to:

• zoom, pan, and rotate

• select one of six preset angles

• toggle split view

• change to flat, basic, or full lighting

• move and configure lights.

Now that you know how to create a project, load geometry, and adjust the position of the view and
lighting, you can (finally) begin to paint! When you're ready, proceed to Tutorial 3: Painting!.
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Tutorial 3: Painting!
This lesson teaches you the basic steps to painting on a model in Mari. This includes, selecting a
brush, selecting a color, and painting with that brush and color.

What You Should Know Before Starting This Lesson

This lesson assumes:

• a basic knowledge of computers and graphics applications

• that you have read the Mari Getting Started Guide up to this point

• that you know how to start Mari (see Launching on Windows, Launching on Linux, or Launching on
Mac OS X)

• that you have completed Tutorial 1: Setting up a Project and Tutorial 2: Setting the View.

Resources You Need to Complete This Lesson

To complete this lesson, you need access to a computer that can run Mari, and the following sample
file:

• 1-Blacksmith - the Mari project file you created in Tutorial 1 and configured in Tutorial 2

How Long Should It Take?

Plan on spending about 25 minutes to complete this lesson.

About Painting in Mari
Painting in Mari is similar to painting in other standard paint programs - you can select and configure
both brushes and colors, and then use them to paint an object. In Mari, you configure brushes
through the Brush Editor and colors through the Colors Palette. You also have the option of saving
colors and brushes to your Shelf for easy access. The Mari Shelf comes with lots of presets, as well as
any items you have created or customized for yourself (and saved there).
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After you paint (also as with other programs), in Mari you need to bake the paint buffer into the
object. Mari includes various ways of baking onto selected patches, including an Autobake option
that bakes by default every time you move the camera.

Open Your Project
1. Start Mari.

The Mari workspace displays.
2. On the Projects tab, double-click on your 1-Blacksmith project to open it.

Your project opens and switches to theOrtho view.

Open the Colors and Shelf Palettes
Basic painting on your model involves selecting a brush, selecting a color, and using them to paint. In
the steps below, you'll select a color from the Colors palette and a brush from your Shelf. To begin,
let's open and arrange those palettes.

TIP: By default, the Colors and Shelf palettes are already open when you start Mari (but
follow the instructions below to see how to open and close palettes).

1. To open the Colors palette:
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• from the View menu, select Palettes > Colors, or

• right-click in the toolbar area and select Colors from the dropdown menu.

The Colors palette displays.

2. To open the Shelf palette:

• from theViewmenu, select Palettes > Shelf, or

• right-click in the toolbar area and select Shelf from the dropdownmenu.

The Shelf palette displays.
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The shelf can hold your customized sets of colors and brushes - but when you first start Mari, the
shelf is empty.

EXPERIMENT: The Mari Reference Guide outlines the different options for arranging palettes.
Take a few minutes to experiment with docking, undocking, sizing, moving, collapsing, and
stacking palettes (including the Colors palette and Shelf). Over time, you'll find a
configuration that works best for you. And when you exit Mari, it remembers that
configuration for the next time you re-start the program.

Select a Color
1. You can select a color from the Colors palette a few different ways:

• click in the color field

• click to select the H, S, or V next to the vertical sliders (to the right of the color field), then click
and drag the sliders up or down to select color and alpha

TUTORIAL 3: PAINTING! | SELECT A COLOR



GETTING STARTED GUIDE 91

• enter an Intensity value or drag the slider to adjust the intensity of the color

• drag the horizontal sliders left or right, or type specific values in the boxes, to specify:

RGB( )or HSV( ), and Alpha( )

The selected color displays in the Foreground swatch (and in the swatch to the right of the
vertical sliders).

TIP: In addition to adjusting the intensity with the Intensity slider, you can also adjust it by
selecting the V component, to the right of the color swatch, and dragging the slider or
dragging the RGB slider.

2. When the color you want is selected in theColors palette, drag the swatch to the Shelf.

You don't have to drag the color to the shelf to use it, but it's useful for storing colors you use
regularly.
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EXPERIMENT: Play around with all the different options for selecting colors. See if you can
get these:

TIP: If you hover the mouse over a swatch, it displays RGB, HSV, and Alpha values:

Select a Brush
1. To select a brush, open the Brush Editor palette:

• from the View menu, select Palettes > Brush Editor, or

• right-click in the toolbar area and select Brush Editor from the dropdown menu.

The Brush Editor palette displays.
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The Brush Editor has three tabs:

• Properties - configurable properties of the selected brush (see the Mari Reference Guide for
details).

• Shelves - the same shelves that display in your Shelf palette.

• Presets - an array of pre-defined brushes that come with Mari.
2. Click the Presets tab.

Three tabs display along the top for different sets of predefined brushes.
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3. Click a brush to select it.

TIP: At the bottom of the Brush Editor is a scratch area for you to test out the selected
brush. You can press N to swap back to the last brush tip you used. This lets you quickly
swap back and forth between two brush tips.

TIP: You can also customize brushes from the Brush Editor, and save them to the Shelf.
This is covered in the Mari User Guide, but basically involves selecting a preset brush from the
Presets tab, custom-configuring that brush by selecting options on the Properties tab, or

saving it by clicking the button on the Shelves tab.

Paint!
1. When you have selected a color and a brush (from the Colors palette, Brush Editor, and/or

Shelf), you can use them to paint on the model. First select the paint tool:

• click on the toolbar, or

• press P.
2. Then paint!
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TIP: You can undo and redo any action by pressing Ctrl/Cmd+Z and Ctrl/Cmd+Y, or clicking

and on the Project toolbar, or selecting Undo and Redo from the Editmenu.
And, you can undo or redo multiple actions at once, by clicking on a specific action in the
History View palette (from the View menu, select Palettes > History View).

The History View palette lists all actions you've performed since opening the project. There
is no limit on the size of the action history, but it clears when you close the project.

Redoing an action in Mari only reverses a previously undone action. You cannot use the Redo
command in Mari to repeat a command - it's reversing an Undo (not a “do that again”).

Bake Your Painting
1. As with other paint programs, what you paint stays in a paint buffer until you “bake” it onto the

model. To bake in Mari, make sure all patches with unbaked painting are selected, and then:

• from the Paintingmenu, select Bake, or

• click on the status bar, or

• press B.
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TIP: The Projection palette also includes aBake Behavior optionthat, by default (AutoBakeAndClear),
automatically bakes every time you adjust the view.

2. When you exit Mari, do not save the project. (We'll start the next lesson with the unpainted blacksmith you
imported in Tutorial 1.)

Where Do You Go from Here?
This lesson covered the most basic options for painting in Mari:

• selecting a color in various ways, and dragging it to the Shelf

• selecting a brush from the Brush Editor

• painting on the model and baking.

The next tutorial, Tutorial 4: Painting Through and Clone Stamping, covers two main options for using
images to create textures in Mari.
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Tutorial 4: Painting Through
and Clone Stamping

This lesson introduces using images to create textures in Mari. This includes “painting through” an
image onto your model and “clone stamping” part of an image onto your model.

What You Should Know Before Starting This Lesson

This lesson assumes:

• a basic knowledge of computers and graphics applications

• that you have read the Mari Getting Started Guide up to this point

• that you know how to start Mari (see Launching on Windows, Launching on Linux, or Launching on
Mac OS X)

• that you have completed Tutorial 1: Setting up a Project, Tutorial 2: Setting the View, and Tutorial 3:
Painting!

Resources You Need to Complete This Lesson

To complete this lesson, you need access to a computer that can run Mari, and the following sample
files:

• 1-Blacksmith - the Mari project file you created in Tutorial 1 and used in Tutorial 2 and Tutorial 3

• Tattoo.png - an image of a tattoo, in your Mari tutorial directory

How Long Should It Take?

Plan on spending about 25 minutes to complete this lesson.

About Painting from Images in Mari
Like with other paint programs, Mari lets you superimpose image files onto the surface of an object.
To manage image files, Mari includes the Image Manager palette. To paint with images you've
loaded into the Image Manager palette, Mari has two main tools: Paint through and Clonestamp:

97



GETTING STARTED GUIDE 98

• The Paint through tool ( ) lets you position an image over an object, and then as you paint, copy
from the image directly onto what's under the brush.

• The Clonestamp tool ( ) lets you position an image alongside an object, with a source point on the
image relative to where the brush is on the object. Then as you paint, the source point on the image
moves in sync with the brush on the object, and Mari copies from the image onto the corresponding
spot under the brush on the object.

You can also clone stamp from painting already on an object, in the paint buffer, or in another
channel.

Open Your Project
1. Start Mari.

The Mari workspace displays.
2. On the Projects tab, double-click on your 1-Blacksmith project to open it.

Your project opens and switches to theOrtho view.

Load an Image
For both painting through and clone stamping, we'll use an image of a tattoo that looks like this:
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We'll start by loading that image in Mari's Image Manager palette.

1. To open the Image Manager:

• click the Image Manager tab if it is already open but hidden (as in the default Mari layout),

• from the View menu, select Palettes > Image Manager, or

• right-click in the toolbar area and select Image Manager from the dropdown menu. The Image
Manager palette displays.

2. To load an image, click .

The Open an Image dialog box displays.
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3. Navigate to your tutorial folder, and select Tattoo.png.

The Tattoo.png image displays in the Image Manager.
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Paint Through
Painting through an image basically involves:

• selecting the Paint Through tool,

• dragging an image onto the canvas, and

• painting.

1. Select the Paint Through tool by:

• clicking on the toolbar, or

• pressingU.

2. Drag the image from the Image Manager and drop it onto themodel.

3. Move and resize the image:

• To resize the image, hold down Ctrl/Cmd+Shift, click and drag.

• To move the image around the canvas, hold down Shift, click and drag.

• To rotate the image, hold down Ctrl/Cmd, click and drag.
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TIP: The Tool Properties palette includes many options for manipulating paint-through
images.

You can also double-click the image in the Image Manager, and crop a smaller portion to
use for painting through and clone stamping.
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EXPERIMENT: Try sizing, moving and rotating the image. See if you can get it to look like this:

4. Paint through the image onto themodel (hold down the left mouse button andmove, as you do in any standard
paint program).

5. When you're done painting through, press P to go to the Painting tool to see just the painted-on object.

TIP: To hide the overlying image, press the ? (question mark) key. To paint the whole image
onto the model in one step, press the ' (apostrophe) key. To repeat the source image (so you
can paint past the edges and have the source image repeat), press the ; (semicolon) key.
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Clone Stamp
Clone stamping is like painting through, but the image does not have to sit directly on top of the
model.
1. First, clear the painted-through textures:

• from the Paintingmenu, select Clear Painting, or

• click on the toolbar.

This removes any unbaked painting on themodel. In this case, themodel re-displays as imported.

2. Select theClone Stamp tool: click on the toolbar.

3. Drag the image from the Image Manager and drop it onto the canvas.

The image displays in a separatewindow.

4. Re-size and position the imagewindow alongside yourmodel. To scale the imagewithin thewindow, hold down
Alt, right-click, and drag. To pan the image, hold down Alt, left-click, and drag.

5. To select the source point for cloning on the image, press Ctrl/Cmd and click.

Once you start painting, amagenta + displays the source point on the image.

6. Once you've selected the source, you can paint. The cursormoves on the image in sync with the cursor on the
model as it clone stamps from the image onto themodel.
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TIP: You can also clone stamp from existing textures - painted on the surface of the object,
in the paint buffer, or painted in another channel. To select a clone source, use the Source
menu in the Project toolbar and select from the origins available.

EXPERIMENT: Change the view (as covered in Tutorial 2: Setting the View), and try both
painting through and clone stamping the image onto another side of the object. Do you like
one method of using images to paint more than the other?

Where Do You Go from Here?
This lesson covered the two main options for painting images onto a model:

• dragging an image and positioning it on top of an object, then Painting through the image onto the
surface of the object, and

• dragging an image and positioning it on the canvas next to an object, then Clone stamping from a
part of the image to the surface of the object.
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The next tutorial, Tutorial 5: Exporting and Importing, covers procedures for saving and re-importing
your work.
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Tutorial 5: Exporting and
Importing

This lesson explains how you can export channels or layers you've painted in Mari as a set of image
files, then re-import them into your project. This familiarizes you with just a few of the methods for
exporting and importing.

What You Should Know Before Starting This Lesson

This lesson assumes:

• a basic knowledge of computers and graphics applications

• that you have read the Mari Getting Started Guide up to this point

• that you know how to start Mari (see Launching on Windows, Launching on Linux, or Launching on
Mac OS X)

• that you have completed tutorials 1 through 4 - so you know the basics of creating a Mari project,
setting up the camera and lighting, and painting textures.

Resources You Need to Complete This Lesson

To complete this lesson, you need access to a computer that can run Mari, and the following sample
files:

• 1-Blacksmith - the Mari project file you created in tutorial 1 and used in tutorial 2, tutorial 3, and
tutorial 4.

How Long Should It Take?

Plan on spending about 25 minutes to complete this lesson.

About Mari Exports
Mari includes the facility to export the painting in a project to a series of image files. You might use
this, for example, to modify part of your work in an external program, and then re-import those
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modifications into the project. Mari lets you select formats and naming conventions for the export.
Each export contains the painting baked in a selected channel, one image file per patch. When you
import a series of previously exported files, Mari lets you know whether it's a complete set.

Open Your Project
1. Start Mari.

The Mari workspace displays.
2. On the Projects tab, double-click on your 1-Blacksmith project to open it.

Your project opens and switches to theOrtho view.

Export a Channel
1. To export the current channel, Diffuse, from the Channelsmenu, select Export > Export

Current Channel.

This exports the currently-selected channel, Diffuse. To export any channel, right-click the
channel you want to export in the Channels palette, and select Export > Export Current Channel
from the dropdown menu.

The Export dialog box displays.
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2. If necessary, use the two left-hand navigation boxes to navigate to the folder you want to export to.

3. In the Template field, Mari names each image file in the export, one per layer and per patch, based on this
template. The default is $CHANNEL.$LAYER.$UDIM.tif

NOTE: Notice the File Example below it, which displays what a filename looks likewith that template. In
the illustration, it's: diffuse.Base.1001.tif

So each filename includes the following (with examples from the illustration):
-$CHANNEL - the name of the channel you’re exporting layers from: Diffuse.
-$LAYER - the name of the layers you’re exporting: Base.
-$UDIM - an incremental number identifying each patch in those layers: 1001 (followed by 1002, 1003,
and so on).
-tif - the extension for the selected file format. You can set the format for the exported files by changing
this extension. Mari supports standard image formats (such as .png, .jpg, .tga, and .dds).

TIP: The formats available to export depend on the color depth of the channel. Channels
with color set to Half-Float or Float can only be exported to .psd, and .psb format. On
Windows, channels with color set to Half-Float or Float also can be exported to .dds format.

4. Set theUse Template For field toOnly this layer in order to only use the template for the layer displayed at
the top of the dialog.

5. Set theColorspace in which you want to export the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel. For this tutorial, keep the default setting.
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6. Enable Small Textures to export any patches that you haven't painted yet, or have painted as a single color, as
8x8-pixel textures at the correct size.

7. Set Alpha Channels to Keep so that alpha channels aren't removed when exporting channels.

8. Click Export All Patches.

This exports all patches. Youmay be notified that the selected directory does not exist, and prompted about
whether you want to create the directory.

TIP: For a complete explanation of export fields, see the Mari Reference Guide and the
Exporting and Importing Textures chapter in the Mari User Guide.

Export a Layer
1. To export selected layers, from the Layersmenu, select Export > Export Selected Layers. This

exports any selected layers in the layer stack (in this case, Base).

The Export dialog box displays.

2. If necessary, use the two left-hand navigation boxes to navigate to your tutorial folder.

3. In the Template field, Mari names each image file in the export, one per channel, layer and patch, based on this
template. The default is $CHANNEL.$LAYER.$UDIM.tif.
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NOTE: Notice the File Example below it, which displays what a filename looks likewith that template. In
the illustration, it's: diffuse.Base.1001.tif

So each filename includes the following (with examples from the illustration):
-$CHANNEL - the name of the channel you’re exporting layers from: Diffuse.
-$LAYER - the name of the layers you’re exporting: Base.
-$UDIM - an incremental number identifying each patch in those layers: 1001 (followed by 1002, 1003,
and so on).
-tif - the extension for the selected file format. You can set the format for the exported files by changing
this extension. Mari supports standard image formats (such as .png, .jpg, .tga, and .dds).

TIP: The formats available to export depend on the color depth of the channel. Channels
with color set to Half-Float or Float can only be exported to .psd, and .psb format. On
Windows, channels with color set to Half-Float or Float also can be exported to .dds format.

4. Set theUse Template For field toOnly this layer in order to use the template for only the layers selected. If
Only this layer is selected when attempting to export, Mari asks you for each individual layer whether you
want to use the template.

5. Set theColorspace in which you want to export the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel. For this tutorial, keep the default setting.

6. Enable Small Textures to export any patches that you haven't painted yet, or have painted as a single color, as
8x8-pixel textures at the correct size.

7. Set Alpha Channels to Keep so that alpha channels aren't removed when exporting channels.

8. Click Export All Patches.

This exports all patches.

TIP: For a complete explanation of export fields, see the Mari Reference Guide and the
Exporting and Importing Textures chapter in the Mari User Guide.

Import a Channel
1. To import a channel (for example if you've tweaked some exported image files in another

application and now want them back in your texture):

• from the Channelsmenu, select Import > Import into Layer Stack for the currently selected
channel, or

• right-click on the channel where you want to import the textures (in this case, Color) in the
Channels palette, and select Import > Import into Layer Stack from the dropdown menu.

The Import dialog box displays.
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2. Select the path for the imported images, by either:

• typing it in the Path field at the top of the dialog,

• clicking on it in your directory bookmarks (to the left), or

• browsing to it in themiddle panes.

If you are using themiddle panes to browse to the directory, you can use the buttons above the view to navigate
back, forward, up one directory level, create a new directory, or switch between icon-only and full-details
directory views.

3. Select the texture set to import.

Mari shows all the texture sets available under the selected directory, arranged by sub-directory.

For each texture set, the Import dialog box includes:

• Full - shows a green bar if the selected image sequence has a full set of images for the current model, a yellow
bar if the selected image sequence has a partial set of images for the current model, or a red bar if the selected
image sequence has no images for the current model.

• Images - the name of each image to import, with theUDIM number represented as@ (in this case,
diffuse.@.tif) and frame number (if present) represented as #.

• Start and End - the first and last UDIM numbers in the image set (in this case, 1001 to 1055).

• Patch Count - the number of images in the set (in this case, 50).

4. In the Template field, Mari names each image file in the import, one per layer and patch, based on this
template. The default is $CHANNEL.$LAYER.$UDIM.tif.
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NOTE: Notice the File Example below the Template field, which displays what a filename looks likewith
that template. In the illustration, it's: diffuse.Base.@.tif

So each filename includes the following (with examples from the illustration):
-$CHANNEL - the name of the channel you’re importing: Diffuse.
-$LAYER - the name of the layers you’re importing: Base.
-$UDIM - an incremental number identifying each patch in those layers: 1001 (followed by 1002, 1003,
and so on).
-tif - the extension for the selected file format. You can set the format for the exported files by changing
this extension. Mari supports standard image formats (such as .tif, .exr, .png, .jpg, .tga, and .dds).

5. Set theColorspace in which you want to import the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel. For this tutorial, keep the default setting.

6. If there are sizemismatches between the patch and image size, set theResize field to resize the Images to
match the patches, or to resize the Patches to match the images.

7. Set Alpha Channels to Keep so that alpha channels aren't removed when exporting channels.

8. Click the Import All Patches to import the files into your project.

Mari imports the textures from the selected files.

Import a Layer
1. To import textures into a layer, from the Layersmenu, select Import > Import into Layer. This

imports all selected textures into the current, selected layer (in this case, Base).

The Import dialog box displays.
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2. Select the path for the imported images, by either:

• typing it in the Path field at the top of the dialog,

• clicking on it in your directory bookmarks (to the left), or

• browsing to it in themiddle panes.

If you are using themiddle panes to browse to the directory, you can use the buttons above the view to navigate
back, forward, up one directory level, create a new directory, or switch between icon-only and full-details
directory views.

3. Select the texture set to import.

Mari shows all the texture sets available under the selected directory, arranged by sub-directory.

For each texture set, the Import dialog box includes:

• Full - shows a green bar if the selected image sequence has a full set of images for the current model, a yellow
bar if the selected image sequence has a partial set of images for the current model, or a red bar if the selected
image sequence has no images for the current model.

• Images - the name of each image to import, with theUDIM number represented as@ (in this case,
diffuse.@.tif) and frame number (if present) represented as #.

• Start and End - the first and last UDIM numbers in the image set (in this case, 1001 to 1055).

• Patch Count - the number of images in the set (in this case, 50).

4. In the Template field, Mari names each image file in the import, one per channel, layer and patch, based on this
template. The default is $CHANNEL.$LAYER.$UDIM.tif.
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NOTE: Notice the FileExample below the Template field, which displays what a filename
looks like with that template. In the illustration, it's: diffuse.Base.@.tif

So each filename includes the following (with examples from the illustration):
-$CHANNEL - the name of the channel you’re importing: Diffuse.
-$LAYER - the name of the layers you’re importing: Base.
-$UDIM - an incremental number identifying each patch in those layers: 1001 (followed by
1002, 1003, and so on).
-tif - the extension for the selected file format. You can set the format for the exported files
by changing this extension. Mari supports standard image formats (such as .tif, .exr, .png,
.jpg, .tga, and .dds).

5. Set theColorspace in which you want to import the data. By default, Mari selectsAutomatic, which is
determined by the file name, size, and type of data in the channel. For this tutorial, keep the default setting.

6. If there are sizemismatches between the patch and image size, set theResize field to resize the Images to
match the patches, or to resize the Patches to match the images.

7. Set Alpha Channels to Keep so that alpha channels aren't removed when exporting channels.

8. Click Import All Patches.

This imports all patches.

TIP: For a complete explanation of export fields, see the Mari Reference Guide and Exporting
and Importing Textures chapter in Mari User Guide.

Where Do You Go from Here?
This lesson showed you how to:

• export a current channel or selected layer in a Mari project to a series of image files.

• import textures into a channel’s layer stack or into a selected layer, for example after having
manipulated the exported textures in another program.

Congratulations! You have now completed all modules in the Mari Tutorials. To better familiarize
yourself with the features you are particularly interested in or to get answers to specific problems that
arise during painting, please refer to the accompanying Mari User Guide and Mari Reference Guide.
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