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Preface
Flix is a collaborative, visual story-development tool. It allows directors, editors, cinematographers,
storyboard artists, and pre-visualization artists to explore ideas quickly, saving valuable time, and to
easily collaborate on the visual story development of a film. Originally developed at Sony Pictures
Animation and Sony Pictures Imageworks, it has been used on projects that include Hotel
Transylvania, The Smurfs 2, and Cloudy with a Chance of Meatballs 2.

Key Features
Flix was designed from the ground up to be a collaborative tool. It introduces automatic organization,
easy access to the latest updates, and allows artists to work faster. It also links to many applications,
such as Photoshop, that artists use.

Key features within Flix include:

• Automation of many complex steps, removing the need to manually name panels or clean up and
manage files.

• Real-time interaction between director and artist to review or edit a sequence using Flix Connect.

• Wider product functionality that allows you to link to other programs, such as Nuke, Maya,
StoryBoard Pro, TVPaint, Shotgun, and Photoshop.

• Dialogue management within Flix.

• Retrievable versioning for all changes made to a sequence, and version comparison that allows you
to review and track new or deleted panels within the sequence.

• Notification e-mails to Editorial teams for tracking recent changes.

• Custom scripts that provide metadata for each shot.

About this Guide
This guide provides you with the basics to get started using Flix. The guide is divided into two
chapters: one for artists and one for editors. If there is anything that is mentioned in the Getting
Started Guide that you want to learn in greater detail, please refer to the Flix User Guide for more
information.
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Introducing Flix to Artists
This introduction to Flix focuses on how artists use the application, and tips to get started quickly and
easily. If you aren't an artist and want to know how to get started with Flix, refer to Introducing Flix to
Editors.

Launching and Logging In
To get started with Flix, follow these steps:

1. Launch Flix using the instructions for your operating system in the Installation and Licensing
chapter in the Flix User Guide.

2. Log in to Flix using the username and password provided by your production team, or using the
Google account credentials associated with your studio-based e-mail account.

Once you are logged in, you can proceed with choosing your project, sequence, and version,
detailed below.

Choosing Projects, Sequences, and Versions
To open a project, sequence, and version, follow the steps below:

1. Open Flix.

The Project Browser dialog opens by default when there isn't a sequence loaded in Flix.

2. Click on a project from the list, or search for a project by typing the name in the search bar.

Once you click on a project, the dialog updates to show you the available sequences for that
project.

3. Click on a sequence from the list, or search for a sequence by typing the name in the search bar.

The dialog updates to show you the available versions for the sequence and any branches, if
applicable.

4. Select a version from the list to continue.

If you clicked on New Sequences, the dialog updates to show you an empty sequence name
space. Type the name of the sequence into the space provided and click Create Sequence. If you
want to create multiple sequences at once, type the name of each new sequence on separate
lines, pressing Enter to create new lines.

5. Select a version of the sequence, by:
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• clicking on the version in the version list to automatically load it,

• clicking on the Load Latest Version button to load whichever version is the latest, regardless of
user, or by

• clicking on Start A Clean Version button to create a new version and open it for editing.

6. Once you select a version, or click on either of the version buttons in the Project Browser dialog,
that version of the sequence is loaded into Flix.

The Flix Workspace
Flix consists of the default Edit workspace, as well as the Dialogue and Pitch workspaces. Edit the
current version of the sequence in the Sequence Editor pane. You can drag and drop to re-arrange
panels or create, delete, cut, copy, paste, duplicate and version up panels using keyboard shortcuts or
theWorkspace toolbar. All actions can be undone or redone at any time, as all changes are local
until saved. The Dialogue workspace allows you to add dialogue to panels in sequential order when
only a thumbnail is needed for reference. The Pitch workspace automatically displays Flix as a full
screen Viewer that allows you to use keyboard shortcuts to step through or play the sequence,
including any dialogue and audio tracks that may be included. You can also edit the duration of each
panel of the sequence by recording a new duration manually while you pitch the sequence.

For more information regarding the Flix workspace and UI controls, refer to the Workspaces chapter
in the Flix User Guide.

Importing and Creating New Artwork
To import panels into the Sequence Editor:

1. Click or Shift+click (to import multiple images as an animated panel) on the Import button in the
Panel Libraries pane of the Edit workspace.

The Choose Files To Import dialog launches a file browser.

2. Select the files you want to import within the file browser and press Open.

The panel is added to the sequence after the current selected panel and is displayed in the Panel
Libraries as well. If you cannot see the panel in the Panel Libraries, switch to All Loaded in the
Display dropdown menu.

3. Select an option from the Display dropdown menu to filter which libraries are shown in the Panel
Libraries pane.

NOTE: If you want to import more than one panel at once, select multiple files in the file
browser before pressing Open. You cannot import more than one animated panel at once,
as selecting multiple files is how Flix knows what to include in the animated panel.
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To add panels to the Sequence Editor pane:

1. Click the New button on theWorkspace toolbar, or drag a panel from the Panel Libraries pane.

Alternatively, you can hover your cursor over the upper-left corner of the Panel Libraries panels
when the display is set to a, p, or All Loaded. Hovering over this location brings up a + button.
Click this to add an existing panel from the library to the Sequence Editor.

NOTE: To add multiple panels to a sequence from the Panel Libraries pane, Shift + select
the panels you want to add and click on the + button.

2. If you created a new, blank panel, it’s inserted into the sequence downstream of the selected
panel in the Sequence Editor pane.

Using Photoshop to Create New Panels for Flix
To create a new, blank panel:

1. Select the panel you want to insert a new panel after.

2. Open Photoshop and navigate to File > Automate > Flix New Template [aspect ratio].

The numbers represent the aspect ratio of each template. For example, the template 177 is
equivalent to an aspect ratio of 1.77.

A blank template opens. Create the new panel, as you want it to appear in Flix.

3. When you are finished drawing the new panel, navigate to File > Automate > Flix Current Image.

The panel is sent to Flix as a new panel added to the sequence.

To edit panels in Photoshop from Flix for editing:

1. Select the panels that you want to export to Photoshop.

2. In the Edit workspace:

• Click the Photoshop button on theWorkspace toolbar, and select either Photoshop (Layer
Comps) or Photoshop (Timeline),

• press Ctrl/Cmd+Enter with the panels selected, or

• right-click the selected panels and select Edit Image (Ctrl+Enter) from the dropdown menu.

The selected panels open in Photoshop automatically. If exporting multiple panels at once, the
selected panels open in a single Photoshop file and are arranged into layer comps.

Once you’ve finished making changes to the panels in Photoshop:

1. Ensure that you have both Photoshop and Flix open.

2. To save your changes as a new version of the panel, either:

• select File > Save within Photoshop, or

• press Ctrl/Cmd+S.
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Once you’ve saved your changes, the updated panels appear in Flix.

To re-import the current image into Flix from Photoshop as a new, separate panel:

1. Within Photoshop, select File > Automate > Flix Current Image from the dropdown menu.

The panel is sent to Flix as a new panel added to the sequence.

2. If you don’t want to save the file, you can close it in Photoshop once you have re-imported the
panel back into Flix.

NOTE: If you choose to save the file in Photoshop, it saves the panel and replaces it in Flix as
a new version. You can go back to any version of the panel within Flix, so none of your
previous changes are ever lost.

3. Add dialogue to panels once they are in Flix by selecting a panel and either pressing Tab, or
clicking on the dialogue entry box directly beneath the displayed panel in the Viewer before
typing.

NOTE: For more information about importing or exporting to/from Photoshop and using
layer comps in Photoshop, refer to the Photoshop Workflow chapter in the Flix User Guide.

Photoshop Keyboard Shortcuts

To create keyboard shortcuts in Photoshop for the functions that you use most frequently:

1. Open Photoshop and navigate to Edit > Keyboard Shortcuts.

2. Expand the File menu, revealing the Flix automate functions, which you can customize with your
preferences.

Saving New Versions
If you want to save changes to a sequence:

1. Navigate to the menu bar and click on the Save button.

You can only click Save if you've made changes since opening or last saving the version.

2. The sequence is saved under your login ID name with an incremented version number, the date,
and the time. The entry also appears in white to denote that the version was created by you.

NOTE: If another user is attempting to save a new version of the same sequence that you are
working on, you may be given a different version number than you expected. Whichever user
saved their work first receives the next incremented version number.
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Publishing to Editorial
As an artist, when you're done working on your sequence, you need to send it to Editorial for them to
review your work. To publish your sequence using Flix, do the following:

1. Click on the Editorial Plug-in button next to the Save button in the menu bar. The button is
dynamic and provides other options for exporting to other editorial applications. If you want to
select another plug-in than the one by default, click the Editorial plug-in Group button until the
list of plug-ins appears in a dropdown menu and select the plug-in you want.

The Publishing to Editorial dialog opens.

2. Select a version for the sequence to be compared to, add a comment in the comment box, and
click Publish.

You are notified in Flix and by e-mail whether or not the publish was successful.
If you are using Premiere, Flix creates two new .xml files - one containing all panels and one with
just the new panels created since the last edit published.

NOTE: By default, when Flix compares two versions, it automatically selects the most recent
version in the Publishing to Editorial dialog.

| INTRODUCING FLIX TO ARTISTS



Introducing Flix to Editors
This introduction to Flix focuses on how editors use the application, and tips to get started quickly
and easily. The instructions are split between the two most common workflows, using either Avid
Media Composer ® or Adobe Premiere ®. If you aren't an editor and want to know how to get started
with Flix, refer to Introducing Flix to Artists.

Launching and Logging In
To get started with Flix, follow these steps:

1. Launch Flix using the instructions for your operating system in the Installation and Licensing
chapter in the Flix User Guide.

2. Log in to Flix using the username and password provided by your production team, or using the
Google account credentials associated with your studio-based e-mail account.

Once you are logged in, you can proceed with choosing your project, sequence, and version.

Importing Publish in Editorial

Importing the AAF Files Using Flix Editorial UI

After the artists published the sequence to Avid using the Flix UI, you need to import the newly
created AAF files to Avid using the Flix Editorial UI.

NOTE: The current Flix Avid launcher you use launches the new Flix Editorial UI.

To import the newly created AAF files to Avid, do the following:

1. Click on Flix Editorial launcher.

The Flix Editorial interface opens.

2. Click on the To Avid tab, and click on the Select Project button to open the sequence you
published from Flix.

The Project Browser dialog opens.

3. Click on a project from the list, or search for a project by typing the name in the search bar.

Once you click on a project, the dialog updates to show you the available sequences for that
project.
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4. Click on a sequence from the list, or search for a sequence by typing the name in the search bar.

The Project Browser dialog closes.

The Flix Editorial interface now shows in the left pane the available versions that have been
published. The right pane displays the panels for which there are new AAF files to import.

The most recent version of the sequence is displayed in the left pane at the top and is selected by
default.

5. Click on To Folder and select the directory where you want to import the AAF files, then click on
Select Folder.

6. Click on Import.

A window opens displaying the selected directory with the following:

• the AAF files imported in a directory called [sequence]_shotEdit_v[version].xml under the
directory you selected in the Flix Editorial UI,

• an ALE file, containing dialogue changes and information on panel order, imported in the
directory you selected in the Flix Editorial UI, and

• amarker.txt file, if you had markers in your Flix sequence, imported in an importExtras
directory under the directory you selected in the Flix Editorial UI.

7. Close the Flix Editorial interface.

8. From the directory, drag the imported AAF files to the Avid bin.

Avid now creates the MXFs based on the AAF files.

In Avid

TIP: We recommend you use two bins for the following steps, one for the sequence (ALE bin)
and one for the media (AAF bin).

1. From the directory, where the AAF, ALE and markers.txt files were imported, drag the imported
ALE file to the ALE bin.

Offline clips (no media) are created in Avid.

2. In the ALE bin, use the Sort column so that the offline clips appear in the same order as in Flix.

3. Select all the offline clips created by the ALE file and Alt+drag them to the Record monitor in the
Composer window.

A sequence is created using all the offline clips.

4. Rename your newly created sequence if necessary.

5. Drag the AAF files to the AAF bin.

The media is created in Avid.

6. Drag your sequence from the ALE bin to the AAF bin.

| INTRODUCING FLIX TO EDITORS
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7. Select all items from the AAF bin, which means the AAF files and the sequence, right-click and
select Relink...

The Relink dialog opens.

8. Set the following parameters:

• Selected items in ALL open bins.

• Source Name set to Name.

9. Click on OK.

The offline media in your sequence is linked to the media created by the AAF files.

If you had markers in your Flix edit, do the following:

1. On the main menu bar, navigate to Tools >Markers.

The Markers dialog opens.

2. Click on the button at the bottom left of the Markers dialog.

3. Click on Import Markers.

The Import Markers dialog opens.

4. Select the markers.txt file and click on Open.

The markers from your Flix sequence are imported in your Avid sequence.

Importing XML in Premiere
1. Launch Adobe Premiere and open your project or create a new project (if this is the first time the

sequence has been sent to Editorial).

2. Drag and drop the .xml file for all panels into the project window in Premiere.

3. Double-click the sequence folder to open the sequence on the timeline.

Publishing Back To Flix
NOTE: The sequence has been published by the artists, so you can edit their work, see
chapter Introducing Flix to Artists, section Publishing to Editorial.

Preparing the MOV and EDL

NOTE: Flix can use FFmpeg or GStreamer to decode movies from Editorial. FFmpeg
supports a much wider range of video and audio codecs than GStreamer. If you are using
GStreamer, you need to use the DNxHD or Photo JPEG video codecs, and the audio needs to
be uncompressed.

| INTRODUCING FLIX TO EDITORS
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Using Avid (8.2 and older) with FilmScribe

Within Media Composer, do the following:

1. Select Output > Filmscribe.

Filmscribe opens.

2. Navigate to File > Open.

The bin containing your sequence opens.

3. Double-click the sequence.

The sequence opens within the Cut List Tool dialog.

4. In the Tracks panel, select the video tracks you want to import in to Flix and make sure the audio
tracks aren’t selected.

5. In the Lists panel, click on Global.

The Global Options appear on the right side of the dialog.

6. Make sure the following Global Options use the following settings:

• Template - Columnar

• Picture Conforming - A Roll (Single Strand)

• Using - KN Start

• Sound Conforming - lnk

• Running Footage as - 35mm 4p

• Master Durations - Frames

• Source Durations - Frames

• Master TC Track - TC1

Make sure the Icons option isn't selected.

NOTE: If you want to use locators with Flix and Avid, make sure the Showevent, show
locators parameter is set.

7. In the Lists panel, select the Assemble option and make sure to only highlight theMaster TC,
Name and Start TC fields.

8. In the Lists panel, select the Optical option. Click on the Same as Assemble List button and make
sure the following options are not checked:

• Key Frames,

• Optical Footage, and

• Page Breaks Between Opticals.

| INTRODUCING FLIX TO EDITORS
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Using Avid (8.3 and newer) with List Tool

Within Media Composer, do the following:

1. Select Output > List Tool.

Avid's List Tool opens.

2. In the Input tab, select your sequence, and click Load…

3. In the Tracks panel, select the video tracks you want to import in Flix, and make sure the audio
tracks aren’t selected.

4. In the Formatting tab, make sure the following options use the listed settings:

• Output Format - Columnar

• Running As Mode - 35mm 4p

• Master Duration - Frames

• Source Duration - Frames

• Master TC Track - TC1

Make sure that the Show Icons option isn’t selected.

NOTE: If you want to import markers from Avid to Flix, make sure the Shot events, show
markers parameter is set.

5. In the List Options tab, make sure the Assemble and Optical options are selected.

6. Select the Assemble option and make sure the Include Opticals option is selected.

7. Make sure to only highlight theMaster TC, Name and Start TC fields.

8. Select the Optical option. Click on the Same as Assemble List button and make sure the
following options are not selected:

• Key Frames,

• Optical Footage, and

• Page Breaks Between Opticals.

Using Premiere

Once you've finished making changes within Premiere and you are ready to publish the version back
to Flix, follow the steps below:

1. In Premiere, with the sequence selected, navigate to File > Export > Final Cut Pro XML.

The Save Converted Project As dialog opens.

2. Save the sequence to a location on your machine or network.

3. In Premiere, with the sequence selected, navigate to File > Export >Media.

The Export Settings dialog opens.

| INTRODUCING FLIX TO EDITORS



15

4. Select the Video tab.

5. Set the Video Codec to Photo - JPEG or Avid DNxHD.

WARNING: The default 1080i/59.94 DNxHD 220 10-bit is not supported. Make sure to select
the codec corresponding to your sequence's resolution and framerate.

NOTE: The only supported video codecs are Photo - JPEG and Avid DNxHD.

6. Select the Audio tab.

7. Set the Audio Codec to Uncompressed.

NOTE: The only supported audio codec is Uncompressed.

8. Once you have set all the options above, click Export.

The Mov is created.

Publishing Back to Flix

Once you've reviewed the artists' work in Avid, Premiere, or Nuke Studio, you need to publish the
sequence back to Flix for them to see the changes and comments you've made.

NOTE: The current Flix_Editorial launcher you use launches the Flix Editorial UI.

To publish back to Flix using the Flix Editorial UI, do the following:

1. Click on Flix_Editorial launcher.

The Flix Editorial interface opens.

2. Click on the To Flix tab and click on the Select Project button to open the sequence you want
to publish your edited sequence back into.

The Project Browser dialog opens.

3. Click on a project from the list, or search for a project by typing the name in the search bar.

Once you click on a project, the dialog updates to show you the available sequences for that
project.

4. Click on a sequence from the list, or search for a sequence by typing the name in the search bar.

The Project Browser dialog closes and the Flix Editorial interface opens.

5. Click onMovie and/or EDL button and select the required MOV and EDL.

The MOV path is populated in the top field and the EDL path is populated in the bottom field.

| INTRODUCING FLIX TO EDITORS



16

NOTE: If the MOV and EDL files are stored in two different locations, click onMovie and/or
EDL button to select the MOV then click again onMovie and/or EDL button and select the
EDL.
If you are using Nuke Studio or Premiere, the EDL is an .xml file. If you are using Avid, the
EDL is a .txt or .ctl file.

6. Use the following parameters if required:

Control Action

Comment Adds a note to the version. ’From Editorial’ is automatically appended to
this by default.

To Branch Selects the branch to publish the sequence into.

Sets the published version to have restricted access. Only users who are
on the list of restricted users are able to see this version within Flix.

As Stills Sets the option for files with no recognizable file extension to be imported
as still images.

Unchecking this option imports all frames of the movie file and convert
them to .jpg files.

To Shotgun Publishes the sequence to Shotgun after it's been imported as a new
version in Flix.

7. Click on the To Flix button to publish the sequence back into Flix.

Once the publish is complete, the message Imported in Flix appears along with the following
information:

• Whether a panel comes in as a ref or relinks to an existing panel.

• In the case of a ref, whether it is a still or animated panel.

• The frame range for each panel.

• In the case of a ref, the existing panels to which the refs are related to.

• In the case of a ref, why it comes in as a ref and not as an existing Flix panel.

The new version of the sequence published from Editorial is displayed in your Project Browser.

NOTE: When an effect is added to a panel in Editorial, sending it back to Flix creates a ref
panel. To find the original panel to which a ref is related, use the Related control pop-up.
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