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What eWhat exxactly is pdfactly is pdfTToolbooolbox?x?
pdfToolbox offers powerful, dynamic and easy ways to integrate PDF processing. It offers capabilities from quick visual inspection and fixing, to
fully unattended processing of thousands of files. Using rock-solid Adobe technology, pdfToolbox provides checking and fixing of even very
complex problems such as: color management, impositioning, conversion to and from PDF and more. pdfToolbox technology is used by small
companies, large publishers and print providers as well as OEMs that integrate the technology in their own solution.

Let's look at this statement in a little more detail, shall we?

PDF prPDF prococessingessing

The pdfToolbox technology focuses on processing PDF files. In most cases, there will be an incoming PDF document that is checked or fixed in
some way, and the result will be another PDF document. pdfToolbox can extend to non-PDF documents as well however; it is capable of
converting to and from multiple different file formats such as Postscript and EPS, image files, as well as office document file formats.

FFrrom manual tom manual to fo fully unattully unattendedended

Callas software developed pdfToolbox as a product family; the same underlying core-technology is used in a number of different products.

• pdfToolbox Desktop allows operators to open PDF documents manually, examine them visually, and run preflight checks and fixes on
them. Read the chapter on manual processing of PDF documents to know more (Working with PDF documents manually).

• pdfToolbox Server performs unattended processing using hot folders. All files placed into a watched folder are picked up and processed
automatically. Read the article on processing PDF documents using hot folders for further information (Working with hot folders in
pdfToolbox Server).
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• Lastly, the pdfToolbox CLI and SDK provide the means to integrate the pdfToolbox engine in web portals or other software products. Read
the article on Integrating pdfToolbox technology using the command-line or the SDK for more information about those tools.

UUsing Adobe tsing Adobe technologechnologyy

The pdfToolbox engine is built upon the Adobe PDF Library technology; this ensures that the PDF documents it processes are handled by the same
rock-solid technology you have in Adobe Acrobat, Adobe Reader and in many of the RIPs available and in-use. pdfToolbox uses the Adobe PDF
Library for transparency flattening, rasterization to images, conversion to and from Postscript and EPS and more.

In the other direction, parts of the pdfToolbox technology have been integrated in Adobe Acrobat. More specifically, the "Preflight" plug-in that can
be found in Adobe Acrobat Pro, was developed by callas software. If you are familiar with it, you will recognise much of the preflight functionality
in pdfToolbox Desktop already.
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Common eCommon exxamples of hoamples of how pdfw pdfTToolbooolbox is usedx is used
pdfToolbox is most commonly associated with preflight (quality control) of PDF documents, but it certainly is not the only way it is used by its
customers. This article provides a number of common examples of how the pdfToolbox technology is used in actual projects.

PrPreflighting custeflighting customer filesomer files

By far the most common reason to implement pdfToolbox technology still is doing quality control on incoming files and fixing common problems
in those files. pdfToolbox supports virtually all preflight standards worldwide (from ISO to Ghent Workgroup, PDF/X-Ready, ...) and can quickly
assess whether incoming files adhere to a given preflight standard.
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Preflight results can be presented in the application itself (1) or can be generated as files to be shared with customers (2) or used in further
automated workflows (such as the XML preflight report format). Preflight reports are flexible, the report shown in (2) can be customized
completely; colors, icons and text can be adjusted to match the knowledge of clients or internal staff.
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Imposing PDF filesImposing PDF files

While pdfToolbox is far from a dedicated imposition tool, it does have an imposition engine on board that can handle common tasks such as
creating a booklet or doing an n-Up, fill page, or Step & Repeat. It can also be configured to handle many more complex tasks, and as an
imposition engine it's really fast.
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The imposition tasks can be done manually, or they can be automated using hot folders, the command line, or the SDK.

PPerferforming corming color managolor managementement

pdfToolbox can handle a lot of color related tasks; its capabilities can largely be divided in three big areas:

1. Color conversions using ICC profiles
2. Color conversions using DeviceLink profiles
3. Changes to spot colors (including converting to CMYK, remapping and changing their names / alternate color space)
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With those core color technologies, pdfToolbox can perform a whole range of very useful tasks:

• Converting to grayscale (including specific types of objects only)
• Converting everything to a specific type of CMYK (possibly treating different input color spaces differently)
• Performing ink-reduction or ink-saving using a proper DeviceLink profile
• Converting to multi-color using an n-channel profile (possibly excluding black text and lineart)
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• Fixing rich-black or four-color black problems
• Fixing RGB colors from office-generated files
• Applying correction curves to CMYK or spot colors

DecDecororating PDF filesating PDF files

Very often, PDF files are 'decorated' (have additional content added) while they are being prepared for production. This can include trim marks,
additional white space, color bars, textual information about the customer or file, bar codes... pdfToolbox has a range of different tools to add this
necessary information to the PDF file.
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1. pdfToolbox can place trim and bleed marks on the trim and bleed box in the PDF document. This can be done manually (interactively)
but of course also as part of a pdfToolbox profile that performs other checks and fixes.

2. Multiple "Place xxx" fixups allow adding information to PDF documents: easy to use fixups for placing text, page numbers and bar
codes, and a more complex "place content" fixup that can be configured using an HTML template and can add virtually anything.
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What is pdfWhat is pdfTToolbooolbox Deskx Deskttopop??
pdfpdfTToolbooolbox Deskx Deskttopop is an interactive application to work with PDF documents. It gives access to all of the pdfToolbox functionality in a non-
automatic mode. The application can be used in two distinct ways (both ways are available when you install and license the software – how you
use it, is up to you).

pdfpdfTToolbooolbox Deskx Deskttop stop standaloneandalone

The ststandaloneandalone version of pdfToolbox Desktop is an application that can run on any computer without having other software from Adobe (or
anyone else) installed. It exists on Mac OS X and Windows and allows you to open PDF files and work with them in a separate application fine-
tuned to be easy to use.
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pdfToolbox Desktop standalone with:

1. The main window where you open PDF documents and work with them.
2. The Switchboard window with easy-to-use tools.
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pdfpdfTToolbooolbox Deskx Deskttop plug-inop plug-in

The plug-inplug-in version of pdfToolbox Desktop gives access to the same functionality of pdfToolbox Desktop standalone, but from within the familiar
environment of Adobe Acrobat Pro.

pdfToolbox Desktop plug-in:
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1. The pdfToolbox functionality is available from the "Plug-Ins" menu item.
2. The Switchboard window with easy-to-use tools inside of Adobe Acrobat Pro.
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Working with PDF documents in pdfWorking with PDF documents in pdfTToolbooolbox Deskx Deskttopop

The main windoThe main windoww

pdfToolbox Desktop standalone has a main window that you can use to open PDF documents. To open documents, you can use the "File" >
"Open" menu or simply drag the PDF document on the main window. When you do so, the PDF file is previewed in the main window. This preview
always:

• uses the fonts embedded in the PDF document (if they are embedded),
• shows transparencies and overprints correctly.
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The main pdfToolbox Desktop window:

1. Each open document is shown using a tab containing the filename of the PDF document.
2. The currently shown PDF document has a highlighted tab.
3. In this example, the page boxes which are defined in the PDF document, are shown as outlines over the preview. This is a preference

setting.
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4. The currently shown page number and the total number of pages in the PDF document.
5. The size (in cm) of the mediabox of the currently displayed PDF document.
6. If the currently displayed PDF document claims to be compliant with an ISO standard (through the use of its metadata), the name of

the standard is displayed here.
7. If the currently displayed PDF document contains an output intent, this area shows the name of the ICC profile defined in this output

intent.

ImportImportant menu itant menu itemsems

The following are the most important menu items in pdfToolbox and where you can learn more about them.
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The "VThe "Vieiew" menuw" menu

Use the "View" menu to:

1. Navigate through the pages of the currently displayed PDF document.
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2. Show or hide the sidebar. This is a narrow area on the left-hand side of the main window that can show additional information about a
document such as bookmarks or embedded files.

3. Access the visualizer technology. Learn more about the visualizer in the article Analysing problem files.
4. Show the output preview. Output preview provides a way to view the currently displayed PDF document using a specific preview ICC

profile.
5. Compare two open PDF documents to see where they differ.
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The "TThe "Tools" menuools" menu

Use the "Tools" menu to:

1. Open the Switchboard window; to know more about the Switchboard, read the article The Switchboard: easy-to-use functionality.
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2. Open the window with profiles, checks and fixups. Read much more about profiles in the article Profiles: the corner stone of
pdfToolbox and following articles.

3. Organize the pages in the currently displayed document or move and copy pages between the open PDF documents.
4. Explore the details of the currently displayed PDF document. Read more about this in the article Analysing problem files.
5. Access the pdfToolbox Server user interface. Read more about processing PDF documents automatically using pdfToolbox Server in

the chapter Working with hot folders in pdfToolbox Server.
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The SwitThe Switchbochboarard: ed: easy-tasy-too-use f-use functionalityunctionality
The Switchboard is the first window you should explore in pdfToolbox Desktop. It provides easy-to-use versions of much of the technology
embedded in pdfToolbox; it doesn't always allow you to do more complex things, but it's a great way to explore what is possible and which things
can be done. This article describes how the Switchboard works and what you do with it.

The SwitThe Switchbochboarard windod windoww

To open the Switchboard if it is not visible, use the "Tools" > "Switchboard" menu item.
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1. Use the "Back" button to go to the previously displayed part of the Switchboard. This functions exactly like the "Back" button in a
standard web browser.

2. Use the "Home" button to go the home screen. The home screen is the screen shown in the above screen grab, which lists all of the
groups of functionality in the Switchboard.

3. Use the pull-down menu at the top of the Switchboard to change to a different library. Libraries make more sense in the contents of
profiles, checks and fixes and are further described there.
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4. The "Search" button opens a search field where you can locate Switchboard items by their name or description.
5. The "Action" button in the top right corner provides a different way to work with libraries.

Drilling doDrilling down twn to a po a particular actionarticular action

To use a particular functionality in the Switchboard, drill-down to it by clicking on the Switchboard buttons.
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1. Click on the "Arrange" button to open the Switchboard pane showing all of the imposition related functionality. Each button here leads
to an action.

2. Click on the "Step & Repeat" button to open the Switchboard pane for the "Step & Repeat" action.
3. Each action pane in the Switchboard features a short description. This is particularly useful when you are browsing the Switchboard as

it can help to quickly understand what each action does.
4. Depending on the action you have selected, options may appear on the Switchboard pane; use those to configure exactly how you

want the action to be performed.
5. Each Switchboard action pane contains an "Action" button. This button contains specific functionality for that specific action.
6. The "Execute" button can be used to run the Switchboard action on the currently displayed PDF document.
7. The "Batch..." button allows you to choose a folder and run the Switchboard action on all PDF files in that folder. This is not the same

as a hot folder scenario as only the files already in the folder will be processed (See the article Working with hot folders in pdfToolbox
Server for more information on actual hot folder functionality).

SwitSwitchbochboarard cd catateeggoriesories

The following is a short overview of what you can find in the Switchboard. Given how accessible the Switchboard is, you are strongly encouraged
to browse through it and try out things.

• ArrArrangangee
Functionality related to impositioning. This group contains both easy to use imposition functionality (n-Up, Step & Repeat, Booklet ...) and
gives access to the "Impose" action which allows using the full imposition engine (using text-based configuration files that control the
imposition).

• PrPresentesent
A number of actions that could be useful when working with (PDF versions of) presentations, adding transitions to slides, creating hand-
outs and more.
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• StStandarandardsds
This group contains the most commonly used preflight profiles (read more about preflight profiles in the article Profiles: the corner stone
of pdfToolbox) from the ISO and the Ghent Workgroup.

• PrPreprepressess
Common prepress fixes such as flattening transparencies, fixing hairlines, adding correct trim marks or page boxes. This group also
contains actions regarding CxF (color exchange format) data in PDF documents.

• DocumentDocument
This group features conversions from other file formats to PDF (office files, PostScript, EPS, images) and from PDF to other file formats
(images, PostScript, EPS). Other actions add information (overlays or letter heads) or work with embedded files.

• PPagageses
The main focus here are actions that change the page format, either by modifying the page boxes (media, trim, bleed...), by modifying the
page content, or both at the same time. Page rotation and mirroring can also be found here.

• FFonts, Imagonts, Images, Colores, Colors, Lays, Layererss
These Switchboard groups focus on working with that particular type of PDF functionality.

• RReportseports
To help with understanding how PDF documents were constructed, pdfToolbox can create reports of fonts, color spaces, images... used in
the PDF document. To learn more about understanding troublesome PDF documents, read the article Analysing problem files.

• LarLargge Fe Format Printingormat Printing
This group contains a number of actions that focus on job finishing for large format printing. Included are adding white space and bleed,
placing grommet marks, adding additional ink layers (such as white or varnish) and creating tiles of large documents such as billboards.

• GeGet in tt in touchouch
The actions in the get in touch group provide links to support and tutorials and provide ways to get in touch with feature requests and
technical questions.

• WorkspWorkspacacee
This is an area of the Switchboard you can customise by including your own actions, profiles, checks or fixups.
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PrProfiles: the cofiles: the cornerornerststone of pdfone of pdfTToolbooolboxx
Profiles (also referred to as preflight profiles) are the corner stone of pdfToolbox. Read this article to understand what they are and what their
possibilities and limitations are.

PrProfiles, checks and fixupsofiles, checks and fixups

When you look in the "Tools" menu in pdfToolbox Desktop, you'll see three menu items that will bring up the same window, albeit a different tab:
"Profiles", "Checks" and "Fixups". The reason for this is that these three items are intimately connected.

• CheckCheck
A check is a single thing you want to check in a PDF document. A check could detect the use of the Courier font, or low-resolution images,
or a specific spot color, but in all cases it is a single thing you want to know about PDF documents. Checks never change your PDF
document, they just look and report.

• FixupFixup
A fixup is a single thing you want to fix (correct, change) in a PDF document. A fixup could do a color conversion, flatten transparencies or
add a QR code, but it's always one thing you want to do to a PDF document. Fixups can change your PDF documents, but they won't
always do. That depends on the fixup and the PDF document.

• PrProfileofile
A profile is a collection of checks and/or fixups. When you want to fix a number of problems in your PDF documents, and you want to check
its quality, you build a profile and run it on your PDF documents. That will cause the fixups to do their work if necessary and it will run all
checks to check the quality of your PDF documents.

Let's look at all of this in a bit more detail.
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ChecksChecks

To see the list of checks in pdfToolbox, use the "Tools" > "Checks" menu item. This will open the profiles window, on the checks tab.

Most of the user interface in this window is shared between the profiles, checks and fixups tabs. These are the main elements in this window:
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1. The libraries pull down window. Open this to select a different library. Each library can contain a completely different set of profiles,
checks and fixups and you can use libraries to separate projects you're working on, or a set of production and set of testing profiles or...

2. The highlighted icon indicates we're looking at the "Checks" portion of the profiles window.
3. The search field allows quickly finding a check. Simply begin typing and the list will be reduced to any check that contains your search

term.
4. The list of checks in this library; checks are always stored as part of a particular group. You can't choose these groups nor where a new

check will appear; this is determined by pdfToolbox.
5. Once you have selected a check, the "Analyze" button allows running that check on the currently displayed PDF document. See more

about running profiles in the article Processing PDF documents with profiles.
6. The action button brings up a menu item with a number of potential actions you can take on a check.
7. There are some filters that can reduce the view on profiles.

You can filter for most recently used, most frequently used, Profile that uses varibles, Profile that doesn't use variables, individual
groups, Favorites, Workspace or Process Plans

Of course it's possible to edit existing checks or create your own. This would lead too far to explain in this introductory manual, please refer to the
other pdfToolbox manuals in this online help.

FixupsFixups

The fixup window can be reached by using the "Tools" > "Fixups" menu item or, if you already have the profile window open, by simply clicking on
the icon on the right to select the list with fixups.

This window is very similar to the previous, with some small differences:

1. The icon highlighted now is that of the fixups.
2. The groups are different. It is still the case that each fixup appears in a particular group and that this is determined by pdfToolbox. You

cannot customize this list.
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3. The button in the lower right corner is now called "Fix" and it will execute the selected fixup on the currently displayed PDF document.

PrProfilesofiles

The profile window can be reached by using the "Tools" > "Profiles" menu item or, if you already have the profile window open, by simply clicking
on the icon on the left to select the list with profiles.
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This window is very similar to the previous, with some small differences:

1. The icon highlighted now is that of the profiles.
2. In this case the list is the list of profiles present in the current library. And unlike for checks or fixups, in the case of profiles you can

indeed modify this list and sort profiles how you want to sort them.
3. When you select a profile, there are two buttons that appear to execute the profile. See the article Processing PDF documents with

profiles for more information on how to run profiles and what the difference is between these buttons.
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PrPrococessing PDF documents with pressing PDF documents with profilesofiles
pdfToolbox uses profiles to perform quality control and/or to fix PDF documents (read more about profiles in this article Profiles: the corner stone
of pdfToolbox). This article explains how you use those profiles and how you can drill-down in the results of using such a profile.

Running a prRunning a profile tofile to analyo analyzze or fix a PDF documente or fix a PDF document

To use a profile, first open the profiles window by using the "Tools" > "Profiles" menu item.

Working with PDF documents manually Processing PDF documents with profiles

37



1. Open the PDF document you want to check or fix.
2. Select the profile you want to use. You might need to open the profile group first (by clicking on the gray triangle in front of its name).
3. Click the "Analyze" or "Analyze and fix" buttons.

When you only want to know whether a PDF document is good or not, click the "Analyze" button; this only does quality control and will never
change the PDF document: in the profile you have selected, it will only execute the checks. If you also want to run the fixups in the profile you have
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selected, click the "Analyze and fix" button; if you do so, pdfToolbox will ask you where to save the resulting file as this time you might change the
document.

ExExamining pramining prococessing ressing resultsesults

While pdfToolbox Desktop is processing the PDF document, you'll see a progress window that informs you of which fixups have been run or what
messages are reported about the PDF document. When processing is done, this progress window becomes the "Result" window you see below.
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The result window shows:

1. The result of processing. In this case a red cross indicating there was at least one error detected.
2. A list of all fixups that were actually performed on the PDF document. The profile may contain many more fixups, only those fixups that

were necessary are listed here.
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3. A list of all warnings issued by preflight checks in the profile. A warning is an item that may be an issue but doesn't have to be. It's
something that needs to be checked.

4. A list of all errors issued by preflight checks in the profile. An error is something that likely will be a problem later on. It's something
that needs to be fixed.

When pdfToolbox processes a PDF document using a profile, it will first run all fixups in the profile and then run the preflight checks. If something
in the PDF document was wrong, but it could be fixed by a fixup, it won't appear in the warnings or errors. If a warning or an error is reported, it's
because they could not be fixed by the profile and they need to be dealt with otherwise.

Drilling doDrilling down twn to what co what causes wauses warnings and errarnings and errororss

It's often helpful to know exactly where on the page a warning or error occurs.
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1. Click on the triangle next to the warning or error message you're interested in. A list of objects that cause that particular warning or
error appears.

2. Double-click on the object you are interested in. You can open the triangle in front of it to open more details about it.
3. A red outline (for errors) or yellow outline (for warnings) appears on the document at the location of the object you have now selected.
4. You can click the "Show in Snap" button to open a separate window where just the object causing the warning or error is shown.
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CrCreeating a prating a preflight reflight reporteport

When you want to create a preflight report of what you see in the "Result" window in pdfToolbox Desktop, click the "Create Report..."button.

Select the type of report you want to create using the popup menu under ??. pdfToolbox Desktop supports:
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• PDF RPDF Reporteport: a simple, non-customizable PDF report. Select the options under ?? to select what details you want to include and how you
want to highlight warnings and errors.

• PDF RPDF Report (custeport (custom)om): a more modern PDF report based on an HTML template you can modify. Use ?? to select the HTML template you want
to use.

• TTeextxt: a textual version of the result information.
• XMLXML: an XML version of the result information.
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When prWhen profiles arofiles are not enough: Pre not enough: Prococess plansess plans
When you look at the profile window, you'll see that the list of profiles contains two different types of items.
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1. Regular profiles, recognizable by their blue icons.
2. Process plans, recognizable by their yellow icons.

Process plans behave like profiles in most ways. They can be run on PDF documents, you can import and export them, they can live anywhere in
the profiles windows (they can be in any group, not just the group named "Process plans" as shown in the example above). But process plans are
built differently and they can be used to solve different problems.

Why prWhy prococess plansess plans??

Process plans were invented to solve two very distinct problems:

• In a profile you can have checks and fixups, but you cannot control the order in which these are executed. For checks that is not a problem,
checks do not change the PDF document they are run on so their order is irrelevant. But for fixups this can be a real problem. Sometimes
you need to do things in a certain order.

• Sometimes you need to be a little careful when you execute a fixup; you really only want to perform a fix if a certain condition is met.

Process plans make both of these things possible; you can control the order of execution and you can do conditional processing based on the
result of a check or profile.

AnatAnatomy of a promy of a prococess planess plan

Process plans are quite simple, below is the process plan editor with its major parts:
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1. Process plans of course have a name and description, just as profiles.
2. This area at the top details what you can use as the steps in a process plans. Profiles, checks and fixups are described in this manual,

actions and variables go beyond the scope of this manual but are described elsewhere in the online help.
3. The first step in this process plan is always executed; in this example that is a profile. Notice the up and down arrows to allow changing

the order of the steps in the process plan. This allows determining what exactly the order is going to be of all of the steps in the process
plan.
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The "On Error", "On Warning", ... options allow you to specify what needs to happen based on the result of this first step. This could
simply be executing the next step, but the options can also be used to jump to a specific step in the process plan or exit the sequence
altogether.

4. This second step is an action, which was created in the Switchboard and which will re-distill the file.
5. The last step in this example is the same as the first step. This is to re-execute the same profile if the first step wasn't successful and

thus the re-distill action was used.
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Analysing prAnalysing problem filesoblem files
So what to do when you have preflighted a file and you have discovered there is or might be a problem with it? pdfToolbox Desktop provides a
number of different tools to help you with the analysis of problematic PDF files; this article gives you an overview of the different possibilities.

CrCreeating a rating a report with the Switeport with the Switchbochboarardd

In the Switchboard, under "Reports", you can find a number of possibilities to create inventory reports from your PDF document. This lists all fonts,
images, colors or layers in the PDF document with their properties.
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1. The "Colors" function in the "Reports" group of the Switchboard. Click "Execute" to generate the report.
2. The generated report: a PDF document where each page details a particular color space that was found in the PDF document.
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UUsing the visualizsing the visualizer ter to inspect the PDF documento inspect the PDF document

Sometimes knowing which objects are in the PDF document isn't sufficient, and in those cases the visualizer technology in pdfToolbox comes to
the rescue. To access it, use one of the "Visualize..." menu items under the "View" menu in pdfToolbox Desktop.
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1. Depending on the menu item you use, a different visualizer "Mode" will be shown. You can use the pull-down menu here to select
different modes without having to go through the menus again.

2. Each visualizer mode has different views. Use this menu item to select a different viewing mode.

Each visualizer mode has different additional information and options shown below. In the example you can see the ink coverage in the displayed
PDF document using a thermometer color overlay. Moving the mouse over the document will list the exact color mix at each point in the
document.

UUsing the object inspectsing the object inspectoror

While technically part of the visualizer functionality, the "Object inspector" deserves its own mention here. Use the "Views" > "Object inspector"
menu item to activate it.
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1. As soon as you move the mouse over the document, you're going to see a list of all objects on the page that are under the mouse. You
can at any time click on the document to "freeze" that list so you can explore it (click on the document again to "unfreeze" the list).

2. For the object that is selected, the object inspector shows a summary of the properties of that object.
3. Also for the selected object, a preview is shown.
4. When examining a document, you can choose to see it in wireframe mode by checking "As wireframe", or you can hide certain object

types by deselecting them in this area.
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Exploring the tExploring the technicechnical deal dettails of the PDF documentails of the PDF document

In case you have still not found what is wrong with the document or an object, pdfToolbox Desktop has a number of much more technical tools
you can use. You can find them under the "Tools" > "Explore ..." menu items but due to their more technical nature they are beyond the scope of
this introductory manual.
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PrPrococessing PDF documents autessing PDF documents automaticomaticallyally
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Working with hot fWorking with hot folderolders in pdfs in pdfTToolbooolbox Serx Servverer
Previous articles of this manual talked about profiles (Profiles: the corner stone of pdfToolbox) and process plans (When profiles are not enough:
Process Plans), but only on how to run those manually on PDF documents you open in pdfToolbox Desktop. Of course there are many times where
it is more efficient to process PDF documents automatically – and this article describes how to do that using hot folders in pdfToolbox Server.

pdfToolbox Server is one of the automatic flavors of the pdfToolbox product family. It is capable of handling any number of jobs; each job is a hot
folder setup with an input folder and one or more output folders. PDF documents dropped into an input folder are picked up and processed
automatically.

Launching the pdfLaunching the pdfTToolbooolbox Serx Servver user inter user interferfacacee

pdfToolbox Server doesn't have its own user interface; instead it can be controlled through pdfToolbox Desktop. To launch it:

1. Launch pdfToolbox Desktop.
2. Click the "Tools" > "Server" menu item.

The pdfToolbox Server control panel appears:
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1. Use "Start a Server" to launch pdfToolbox Server on the same machine as pdfToolbox Desktop.
2. Use "Connect with Remote Server" to connect to a pdfToolbox Server instance that is already running either on the same machine or

on a different machine on the network. This allows remote monitoring and configuration over the network. You will need to know the
IP address of the machine running pdfToolbox Server.

3. "Start a Dispatcher" and "Start a Satellite" are part of the distributed processing system available in pdfToolbox. This is not further
described in this overview manual.
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StStarting a pdfarting a pdfTToolbooolbox Serx Servver inster instancancee

Assuming pdfToolbox Server is installed on the same machine as pdfToolbox Desktop, we can start it locally. To do so, click the "Start a Server"
button in the pdfToolbox Server control panel.

After a few seconds, the pdfToolbox Server control panel changes to show the now running server. Most importantly:
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1. Because this is a local server (on the same machine as our pdfToolbox Desktop), the control panel shows "Local server". If we had
connected to a remote server, the IP address of the remote machine would be shown instead.

2. The server action button gives access to configuration possibilities for the pdfToolbox Server instance (including the ability to start a
new job or to stop the server).

3. Underneath the server row, the different configured jobs are shown. Each job is a hot folder setup that can process files using a specific
profile or process plan.

4. Next to the name of the job, the control panel shows the "Start" / "Stop" button. Clicking the triangle will start processing for this job,
clicking the square will stop the job.

5. Next to that is the job action button. This gives access to the job configuration.

CrCreeating a neating a new jobw job

To create a new job:

1. Click on the action button next to the server you want to create this job in.
2. Click the "Create new job" menu item.
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This will open the job editing window. Start with filling in basic job information:
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1. Each job has a name, which is shown in the server control panel. Choose a unique, descriptive name.
2. Optionally provide a description for the job.
3. Select a profile or process plan for this job to use. The pull-down menu shows all profiles and process plans in the currently active

library in pdfToolbox Desktop. You can search in the list by entering your search terms in the search field at the top of the list.
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This just leaves setting up the different hot folders. To do this you can select each of the folders in the list on the left, or you can use the "Turbo..."
button. When using the turbo button, you have to select a folder and pdfToolbox will automatically create sub folders in that folder for you for all
of the folders it needs.

1. After using the "Turbo..." button, all paths have been set to sub folders of the main folder selected (in this example "/Server hotfolders/
Test").
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2. Click on each item in the list on the left to further setup the job:
- "Overview" is the overview shown in the screengrab above.
- "In folder" lets you define the input folder. This is the actual watched folder where files are going to be picked up from.
- "On success" is the folder processed files are dropped in if there are no info messages, warnings or errors during processing.
- "On info" is the folder processed files are dropped in if there is at least one info message, but no warnings or errors during processing.
- "On warning" is the folder processed files are dropped in if there is at least one warning, but no errors during processing.
- "On error" is the folder processed files are dropped in if there is at least one error during processing.
- "Processed files" is the folder where the original files (the ones dropped in the in folder) are moved to if "Keep original" is checked.

After configuring the hot folder, click "OK" and don't forget to turn it on in the server configuration panel if you want to test it.
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AdvAdvantantagages and limites and limitations of using hot fations of using hot folderolderss
The pdfToolbox product family provides a number of products that can automate a workflow. pdfToolbox Server does that using hot folders, but
what are the advantages and disadvantages of that technique? When should pdfToolbox Server be used and when is it better to use pdfToolbox
CLI or pdfToolbox SDK?

AdvAdvantantagageses

As explained in the previous article (Working with hot folders in pdfToolbox Server), setting up pdfToolbox Server jobs is quick and easy. It's a
matter of selecting which hot folder needs to be watched and what the profile or process plan is that will be used to process files dropped in that
hot folder. At the same time, these hot folder setups have a number of advantages:

• Error handling is done for you. If something is wrong with a PDF document, this will be intercepted for you and the document will
automatically be moved into the error folder with an appropriate log.

• pdfToolbox Server automatically does parallel processing of PDF documents across all of its jobs; the number of parallel processes is
limited by the license and how you configure its preferences.

Of course error-handling and parallel processing are also possible when using the CLI or SDK, but substantially more work is needed to handle this
properly.

LimitLimitationsations

Of course there are a few scenarios where using hot folders isn't the best choice:
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• Using pdfToolbox CLI or pdfToolbox SDK closer integrations are possible. Using hot folders all you can do is drop a PDF document in a
watched folder and wait until it has been processed. With pdfToolbox CLI or pdfToolbox SDK you can get progress information for a file
and you can specify where exactly the output document has to be generated.

• Not everything can be done using pdfToolbox Server and hot folders. Some commands are available only in environments where you use
the CLI version or the SDK version of pdfToolbox.

• In scenarios where variables are used (read more about variables in this manual: Variables and JavaScript: Overview), pdfToolbox Server
can set variables only at the job level (meaning that all PDF documents processed by a particular job will receive the same values for the
variables in the used profile or process plan). Using pdfToolbox CLI or pdfToolbox SDK, variables can be set differently on a file-by-file
basis.

Remark that regardless of these limitations, it might still be possible to use pdfToolbox Server in a test phase before doing the actual
implementation using pdfToolbox CLI or SDK.
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pdfpdfTToolbooolbox intx inteegrgration in autation in automation systomation systems (Switems (Switch, Filech, FileTTrrain)ain)
Instead of using pdfToolbox Server in hot folder mode (Working with hot folders in pdfToolbox Server), it can also be used integrated in Enfocus
Switch or Laidback Solutions FileTrain. This article provides an introduction to how pdfToolbox can be used in such tools.

LaidbLaidback Solutions Fileack Solutions FileTTrrainain

FileTrain from Laidback Solutions is an automation tool that allows automation of manual tasks such as file moving, renaming, moving from and
to FTP servers, database access, etc... It also has a built-in integration of pdfToolbox Server. After installing pdfToolbox Server or CLI on the same
machine as FileTrain, FileTrain's built-in pdfToolbox action allows running preflight profiles or process plans on files in a "station" (the name for
FileTrain automated workflows).
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On the screengrab above, you can see the main FileTrain window and the pdfToolbox action used to run pdfToolbox in a larger automated
workflow:

1. The list of FileTrain "stations" (automated workflows).
2. The pdfToolbox action editing window.
3. The profile used in this particular workflow; all pdfToolbox profiles and process plans can be used.
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4. FileTrain offers a convenient interface to generate multiple preflight reports in different versions.
5. The "Dynamic values" tab allows passing on variables to the selected pdfToolbox preflight profile or process plan. This enables each

file to be treated differently, for example based on information that has been extracted from a database (FileTrain has a built-in action
to do database access).

6. FileTrain allows very fine-grained selection of where the result file will be generated in the "Result file" tab.

EnfEnfocus Switocus Switchch

Switch from Enfocus is a modular automation solution that can automate manual tasks; it includes both built-in tools (for FTP, renaming, grouping
and ungrouping...) and connects to third-party tools. From the start, Switch has had a number of pdfToolbox configurators (the Switch name for
the plug-ins that create a connection to a third-party tool).
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1. The list of flows (the Switch terminology for a workflow that automates a series of tasks).
2. The list of built-in tools and configurators; at the top in the favorites section, three of the pdfToolbox configurators.
3. A workflow featuring two pdfToolbox configurators to automatically merge PDF files into a single file and subsequently impose them

using the imposition engine built into pdfToolbox.

pdfToolbox provides the following configurators for Switch:
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• Actions: runs one of the pdfToolbox actions (roughly equivalent to the functionality available in the Switchboard).
• Profiles: runs a pdfToolbox profile or process plan.
• Compare: compares two incoming PDF files and determines whether they are visually the same or different.
• Impose: runs the pdfToolbox imposition engine.
• ConvertColors: runs a color conversion using pdfToolbox.
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IntInteegrgrating pdfating pdfTToolbooolbox tx technologechnology using the cy using the command-line or the SDKommand-line or the SDK
Sometimes closer integration than simply hot folders is needed. In that case pdfToolbox provides integration through the command-line (with
pdfToolbox CLI) and integration through the SDK (with pdfToolbox SDK).

pdfpdfTToolbooolbox CLIx CLI

pdfToolbox CLI is available on Mac OS X, Windows, Linux, Sun Solaris, and IBM AIX. On all platforms it provides the same functionality; on top of
that, the command-line is very complete, very flexible and extremely fast. To get going with pdfToolbox CLI, install pdfToolbox Server on Mac OS X
or Windows, or install pdfToolbox CLI on the other platforms. The pdfToolbox Server installer will install the following components:
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1. The pdfToolbox Server installation folder on Mac OS X.
2. The pdfToolbox Desktop application installed by the pdfToolbox Server installer.
3. The pdfToolbox CLI application. This is the application that needs to be called on the command-line.
4. The documentation folder for the command-line version. This manual can also be found online: callas pdfToolbox CLI (command line

interface).
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The easiest way to find out what you can do with the command-line, is to run the --help command.

./pdfToolbox --help
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This will provide a long help text with parameters available when working with profiles or process plans (as shown in the screengrab above), and
with the various "commands" usable with pdfToolbox CLI. Once you find the command you want to work with, drill-down in the help for it; for
example, to know how to save images from pdfToolbox, issue the command:

./pdfToolbox --help saveasimg

pdfpdfTToolbooolbox SDKx SDK

callas pdfToolbox SDK offers a comprehensive programming interface and sample code for thorough integration of pdfToolbox technology into
your own solution. It gives in-depth access for analysis and manipulation of the PDF and embedded formats such as fonts, metadata, color
profiles, image compression and more.
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The software development kit for pdfToolbox has C/C++ as its primary development language, but it comes with APIs and example code for other
development environments such as Java or .NET.

When evaluating whether you are going to use the SDK, you should keep in mind that it comes with sample code, but that the code is not
production-ready. You will have to write actual production code to integrate the SDK in your solution.
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Working with the trial vWorking with the trial verersionsion
At the end of this manual, you should have a good idea of what callas pdfToolbox can do for you; but nothing beats trying out the software in your
own workflow of course. Luckily callas provides a trial version that lets you do exactly that.

DoDownlownloading the trial vading the trial verersionsion

Where to go from here Working with the trial version

77



1. Surf to the callassoftware.com web site using your favorite browser.
2. Hover over the "Products" menu.
3. Click on the "pdfToolbox" item that appears.

1. On the pdfToolbox page, scroll down until you see the tabs with the different pdfToolbox flavors.
2. Click on the version of pdfToolbox you want to try (see the next section if you are hesitating which version to try).
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3. Click on the "Download" button to download your trial version.
4. Fill out the form that appears with your details. Remember to enter a valid email address, as a download link will be emailed to that

email address.

Which vWhich verersion tsion to doo downlownloadad

There are four flavors of pdfToolbox you can try; use the following simple guidelines to determine what to download:

• If you are only interested in testing the interactive (or manual) version of pdfToolbox, download pdfToolbox Desktop.
• If you are also or only interested in automation using hot folders or command-line, download pdfToolbox Server (the server flavor includes

both pdfToolbox Desktop and pdfToolbox CLI).
• If you are specifically looking to test on Linux, download pdfToolbox CLI on Linux and optionally download pdfToolbox Desktop for use on

your Mac or Windows machine.
• If you are specifically interested in working with the SDK, download pdfToolbox SDK. Keep in mind that you will not get a direct download

link but you will be contacted by us to help you with evaluating pdfToolbox SDK.

AAftfter doer downlownloadingading

1. Run the installer you just downloaded.
2. Activate your trial following the instructions you find on the callas software support pages; take care to follow the procedure for the

flavor you downloaded. Keep in mind you might have to run though the procedure twice (if you want to test pdfToolbox Desktop and
pdfToolbox Server / CLI for example).
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RRestrictionsestrictions

The trial versions from callas are only restricted in time, not in functionality. Please make sure you have sufficient time allocated to testing before
you activate your trial. In case you find that you need more time in your trial, contact callas through info@callassoftware.com to request a longer
time-limited version.
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An oAn ovverervieview of avw of available documentailable documentationation
callas software is in the process of migrating all of its documentation to an online platform. This allows reading everything in one centralised
location. You can also generate PDF versions of each of the manuals you can read online.

To access this information:

• Visit the help site in English at help.callassoftware.com.
• Visit the help site in German at hilfe.callassoftware.com.
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VVideos and wideos and webinar rebinar rececorordingsdings
In addition to the documentation, you can find a collection of videos about specific product features and recordings from webinars about
pdfToolbox on our web site.
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To find the videos:

1. Go to the callassoftware.com web site.
2. Hover over the "Support" menu on the menu.
3. Click on the "Videos" item in the support menu.

FiltFiltering the cering the contontentent
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To find exactly what you want, use the "Filter" sections on the right hand side of the browser windows.
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TTalking talking to someoneo someone
Sometimes a conversation is much easier than any documentation can be. We always appreciate receiving feedback and if you have questions
about using pdfToolbox in your environment, we encourage you to get in contact.

TTechnicechnical questions or cal questions or commentsomments

To ask a technical question or problem, you can use the "Report a problem" form on the callas software website.
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1. Go to the callas software web site at www.callassoftware.com.
2. Hover over the "Support" item in the menu.
3. Click on the "Report a problem" item in the "Support" menu.

Alternatively, you can also send email to "support@callassoftware.com".
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Please provide as many details as possible when you contact us, so that we can help you as quickly and efficiently as possible.

Other questions or cOther questions or commentsomments

For all other questions or comments about pdfToolbox or any of the other callas software products, please write info@callassoftware.com and we
will help you as quickly as possible.
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