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Chapter 1: Creating a Bike Document  
 

Where We Are Headed: Generating PDF Output 
 
As previously discussed, you will be following the iterative process in creating you documents. 
What this means in Tutorial 1 we want to create the following: 
 

All About Bikes 
  Getting Started 
  Bike People Connections 
  Maintenance 
  Bike Types 
 
All About Bikes will be the title of our document, the items (Getting Started, etc.) will be Header 
Topics in XMetaL. Header Topics are containers (or categories) you create to put your linked files 
in. Your generated final PDF output at the end of this chapter will look like: 
 

 
 
 
When you first start XMetaL, you will be presented with Figure 5. This is the Help file and like 
most applications, you can get it any time by clicking the question mark (?) 
 
Close it by clicking Close in the upper right corner 

 
Figure 1 
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Initial Setup: Creating Six Folders That Will Hold Your Files 
 
Before opening XMetaL, you will want to create a folder to hold all your files, Unlike Word where 
you create a document and save it into one folder, with XMetaL you are creating and saving 
numerous files. 
 
So best practice here is to create one folder to hold all your files and within that folder create 
different folders to hold the different topics. 
 
In this case, we want you to create a folder called All About Bikes and within it create the 
following five folders: Maps, Concepts, Tasks, References, and Images: 
 

 
 

Procedure: Using Windows, create your six folders 

So on your Desktop, go ahead and create these six folders mentioned above.  
 
Note: You can place these anywhere you like but for convenience, we recommend your Desktop. 
 

Creating Your First Map 
 
You are now going to create your first map and you will call it All About Bikes—this will appear as 
the title of your document and, don’t worry, you can always change it later. As we discussed, the 
map is like and outline and will hold all your topics.  
 
Another way to view the map is that it’s a collector of all the links that point to your various files 
(topics) that will make up your document. 

Procedure: Creating your first Map 
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1. Start XMetaL > File > New… 

 

 

2. DITA Map tab > select Map icon > OK 

 

 

3. In Map title, enter All About Bikes > OK 
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4. Your map will appear under Resource Manager.  

The Resource Manager acts as a collector that links all your topics to your map. 
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5. Let’s save your map. 

Under Resource Manager > File > Save Map 

 

 
 

6. You want to save Map in the Maps folder 

Double-click on your Maps folder 

 

 

7. For File name, enter all_about_bikes. We will name our files in lower case and place 

underscores between each name. It’s recommended you place underscores between each 

words in all your file names. 

Save 
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Creating Topic Headings 
 

You are now going to add  

four topic headings to your map.: 

Getting Started 

Bike People Connections 

Maintenance 

Bike Types 

In these headings you will place all your topics: concepts, tasks, and references.  You can create 

topics and place them in the map without topic headings, however, for purposes of learning 

XMetaL Author, we felt this approach would lead to better understanding of the XMetaL 

authoring process. 
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Procedure: Adding topic headings 

1 Under Resource Manager > Insert > Topic Heading… 

 

 

2 In Navtitle, enter Getting Started > OK 
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3 You should see this with the Getting Started topic appearing under your map 

 

 

4 Repeat steps 2 and 3 to add topics three other topics, Bike People Connections, Maintenance, 

and Bike Types. If you make a mistake, you can right-click on any of your topics and select 

Delete Item 

When you are finished creating your topics, you should see this: 

Notice how the four Heading Topic icons appear as folder icons. 

 

5 If you make a mistake, you can delete and of the topic heading by placing your cursor in the 

text of the heading > right-click > Delete 

 

 



9 
 

Adding Concepts 
 
Next you are going to add two concepts to your map, A Little Bike History and Bike Clubs. 
 

Procedure: Adding Concepts 

1. File > New… 

 

 
 

2. DITA Topic tab > select Concept icon > OK 

 

 
 

3. Replace Concept Title with A Little Bike History  

Now let’s save your concepts topic  

File > Save 
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[Note: You can also save your files by using standard keyboard shortcut:  Ctrl + S] 

 

 

4. Double-click on Concepts folder 
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5. For File name, enter a_little_bike_history 

Save 

 

 

 

6. This is what you will see. Notice that your concept does not appear in the Resource Manager, 

to do that you must insert it. 
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7. Resource Manager > Insert > Topic Reference … 

 

 

8. Browse > go to your Concepts folder  

 

 

9. In your Concepts folder > select a_little_bike_history > Open 
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10. OK 

 

 

 

11. You can see that the topic A Little Bike History now appears in the Resource Manager 

Notice topic icon looks like a sheet of paper 
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1. OK, let’s move on to adding a second topic concept, Bike Clubs 

 

 

2. DITA Topic tab > Concept > OK 

 

 

3. Replace Concept Title with Bike Clubs 

File > Save 
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4. In Concepts folder 

For File name, enter bike_clubs 

Save 
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5. As before, you want to insert this topic in the Resource Manage 

Resource Manager > Insert > Topic Reference … 

 

 

6. Browse… 
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7. Select bike_clubs > Open 
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8. OK 

 

 

 

9. In the Resource Manager you should now see: 
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Placing the Concepts Into Your Headings 
 
Now you want to place your concepts into their proper headings. One way of doing this is select 
the topic and drag it into the desired heading. 
 
Let’s place A Little Bike History topic into Getting Started topic header 
 

Procedure: Inserting the Concepts into your Headings 

 
1. Select A Little Bike History and drag it under Getting Started.  

 
You should now see: 
 

 
 

2. Now let’s place it in Getting Started 
 
Click on the right navigation arrow 
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3. You should new see: 
 

 
 

4. Now do the same procedure and place Bike Clubs in Bike People Connections. 
 
You should now see: 
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5. Before leaving, let’s save the map 
 
Resource Manager> File > Save Map 
 

 

 

Adding Tasks 
 

You are now going to create the task How to Change a Flat Tire  
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Procedure: Adding tasks 

1. File > New… 

 

 

2. DITA Topic tab > select Task icon > OK 

 

 

 

3. Replace Task Title with How to change a flat tire 
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4. Let’s save it by doing shortcut Ctrl +S 

Browse to your Tasks folder 

in File name, enter how_to_change_a_flat_tire 

Save 

 

 

 

5. Select Step, enter Remove tire from the wheel 

Hit the enter key twice to go to next step 

Select the step and enter Remove the inner tube from tire 

Hit Enter key twice 

Enter Patch Inner Tube 

Save the topic (Ctrl + S) 
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6. Resource Manager > Insert > File Reference … 

 

 

7. Browse …. 
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8. Double-click on the Tasks folder 

 

 

9. Select how_to_change_a_flat_tire 

Open 
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10. OK 

 

 

 

11. Now select and drag How to change a flat tire and place it in the Maintenance folder. 

When finished, it should look like this: 
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12. Let’s save the map 

Resource Manage > File > Save Map 

 

 

Generating an Output 
 
Let’s talk a look at the document you have created so far. You do this by generating your 
document and the default file is outputted as a PDF. 
 

Procedure: Generating an output PDF 

 
1. Resource Manager > File > Generate Output for DITA Map … 
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2. OK 

 
 
 

3. Open File 
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4. Scroll down to Contents 

 
 
 

5. Close  

 
 
 

Adding References 
 
You have created and added two major DITA topic types, Concepts and Tasks. The third major 
topic type is References.  A Reference is additional or supplementary material that you want to 
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include in your document. In many cases this informational is inserted through the use of a table. 
You are going to create a new reference and call it Bike Types: 
 

Bike Type Ride Type 
 
 

Type of Surface 

Road Go pretty fast and long 
distances 
 

Pavement 

Mountain Go as fast as terrain allows Dirt, sand, rocks 
 

Recumbent Usually slower than road 
bikes 
 

Pavement 

Hybrid Same characteristics as 
road and mountain bikes 

Pavement, dirt, sand, rocks 

 
 

Procedure: Adding References 

 
1. Open XMetaL > File > New … 

Select DITA Topic tab > Reference icon > OK 

 

 

2. Replace Reference Title with Bike Types 

Select (darken) the elements shown > Right-click on them > Cut 
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3. Table > Insert Table 

 

 

4. Enter in information as shown 

Select Insert Header 
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OK 

 

 

5. You should see: 

 

 

6. Enter the information as shown below. 

After you have completed the form, save it > Ctrl + S 
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7. Browse to your References folder > for File name, enter bike_types > Save 

 

 

8. Now let’s link it to the map 

Under Resource Manager > Insert > Topic Reference… >  
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9. Browse... 

 

 

10. Select References > Open 
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11. In your References folder > select bike_types > Open 

 

 

12. Click OK 
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13. You should see: 

 

 

 
14. Let’s put Bike Types topic in the Bike Types category 

Select Bike Types topic 

Drag it into the Bike Types category 

When completed, you should see: 

 

 
 



37 
 

15. Resource Manager > Save Map 

 

 

 

Procedure: Generate output 
 

 
1. Resource Manager > File > Generate Output for DITA Map… 
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2. OK 

 
 
 

3. Yes 

 
 
 

4. Open File 

 
 
 

5. Scroll down 
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6. Close the PDF 

 
 
 
 

 

Opening, Closing and Navigating Through Your Topics 
 
Let’s take some time now to learn about topic navigation, mainly how to close and open topics. 

Procedure: Navigating through your Topics 

1. Across the top for the editor you can see all your topics starting with a_little_bike_history on 

the far left. 
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2. Select it 

 

 

3. You will see its topic 
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4. To close it, right-click on it > Close 

 

 

5. To reopen it, double-click on the text in A Little Bike History 
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6. And it opens 

 

 

 

 

Shortcut Method for Creating Concepts and Tasks 
 
We are going to show you a faster way to add topics. 
 
In this example we are going to create a new concept Bike Web Sites and place it under the Bike 
People Connections heading. 
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Procedure: Shortcut 

1. Under Resource Manager > Insert > Topic Reference 

 

 
 
2. In Navtitle, enter the name of your concept or topic 

We will enter Bike Web Sites > Create 

 

 



45 
 

3. Select Concept icon > OK 

 

 

4. In Save in, browse to your Concepts folder 

Notice that under File name, XMetaL has inserted c_Bike_Web_Site 

In other words, it put a c suffix (for concept) and inserted underscores between your concert 

name. 

Save 
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5. OK 

 

 

6. Notice that XMetaL that it inserted Bike Web Sites in Resource Manager for us—we didn’t 

have manually insert it as we did before 

Drag and put Bike Web Sites under Bike People Connections heading 
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7. You should now see 
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8. As a last step, let’s save our map 

Under Resource Manager > File > Save Map 

 

 

By using this shortcut, you have saved seven steps in creating topics.  

Because we will use this shortcut from this point on the tutorial 

Troubleshooting Your Output 
 
If you repeat generating your output, you will get the message 
Click Yes 
 

 
 
 
If you do not close the file from your previous generation, you will get this unclear message:  
OK 
 

 
 
Click OK 
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Close your previous pdf output and these message will not appear. 
 
Just remember to close your output after every generation and you’ll have no problem. 
 

Best Practices 
 
Before using XMetaL, organize your topics by creating a number of folders to save your files 
(topics) in: 
 
 Concepts 
 Tasks 
 Maps 
 Images 
 References 
 
As soon as you create your map, save it:  Under Resource Manager, File > Save 
 
As soon as you create a concept, task or reference, save it: ctrl + S  
 
To save everything (all maps and all topics): File > Save All 
 

Summary 
 
You are off to a good start so let’s review what you have accomplished so far. 
 
In essence, with XMetaL you are creating a map, then topics (concepts, tasks, references), then 
liking them under your map and finally outputting your map. 
 
To organize your topics, you first created a core folder to hold all of them—in the example, you 
created an All About Bikes folder and within it you created Maps, Concepts, Images, References, 
and Tasks folders. 
 
Next you opened up XMetaL and created a map and named it All about Bikes. This will be the 
title page of your document and you can change it later. 
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And, as a good practice, you should immediately save your map after you create it. 
 
Next you created four headings—Getting Started, Bike People Connections, Maintenance, and 
Bike Types—in which you will place your topics. 
 
You outputted your document to view what you have done so far. 
 
You created your first concept A Little Bike History and saved it, inserted into the Resource 
Manager and then placed it in Getting Started. 
 
You outputted your document and reviewed it. 
 
You created another concept topic Bike Clubs and saved it and placed it in Bike People 
Connections. 
 
Next you created your first task How to Change Tire, saved and inserted it placed it in 
Maintenance. 
 
Finally, you created your first reference All Bike Types saved and inserted it and then placed it in 
Bike Types. 
 
And to finish, to outputted you document a final time and reviewed it. 
 
It’s an iterative process and we recommend you modify your document and review it before 
adding a lot of additional content—we call it “chuck reviewing,” that is, review as you go. 
 

Overview of Document Creation 
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Detailed Document Creation 
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Review Questions 
 
For answers, see page Error! Bookmark not defined.. 
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1. As a best practice before you even start XMetaL, it’s a good idea to create folders entitled 
Maps, Concepts, Tasks, Reference, and Images and keep them all in a folder that has the title 
of your document. 

a. True 
b. False 

 
2. A Map … 

a. Links all your topics 
b. Acts like an organizer for your topics 
c. Is not necessary to produce your output 
d. Is similar to a table of contents 

 
3. Creating Topic Headings in your map is an excellent way to organize your topics into major 

categories 
a. True 
b. False 

 
4. The Resource Manager contains your Maps that link to your topics 

a. True 
b. False 

 
5. Of all three major topics, the References topic is the one used most 

a. True 
b. False 

 
6. Under the Resource Manager, you can reposition your topics using… 

a. Arrows (up, down, left, right) 
b. Drag and Drop 
c. Cut and paste 

Using Insert function 
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