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DS-5 Workshop: Debug, Trace and Performance Analysis on the 
Arrow SoCKit board: 

Copyright 2010-2015 ARM Ltd.  All rights reserved.  Version 1.5 
 
 

 

 
This workshop is an introduction to the features of DS™-5 Debugger. The board has an Altera Cyclone V SoC, 
which has an FPGA as well as a dual core Cortex®-A9 processor. The workshop demonstrates DS-5 features 
including bare metal debug, Linux kernel debug, trace and operating system awareness. In addition it teaches how 
to setup an FPGA adaptive debugging to control registers on the FPGA logic as well as cross triggering between the 
debugger and the Quartus SignalTap® II logic analyser. 

 
The final section of the workshop demonstrates the use of ARM Streamline for performance analyses and source 

code optimisation. 
 
The JTAG connection is established through the on board USB Blaster II. If a JTAG header is soldered onto the 
board, a DStream JTAG probe can also be used to debug the example. 
 
The workshop introduces some of the views in DS-5 Debugger, but is not an extensive demonstration of all the 

functionality contained in the tool. Some of the features are used in explicit instructions that you are expected to 
follow and are marked with this symbol .   Please visit www.arm.com/ds5. 

 
 

 
 

 

 

 

 

 

 

 

(version 1.1; 20 April 2015; v5.21.1; HW; HWCortex-A9; SoCkit; USB Blaster II ) 

The latest version of this document is available here:  

http://rocketboards.org/foswiki/view/Documentation/DS5AlteraEditionSoCKitTutorial 

 

http://www.arm.com/ds5
http://rocketboards.org/foswiki/view/Documentation/DS5AlteraEditionSoCKitTutorial
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Testing Your Software Installations you do on page 5:  Start this tutorial at page 4. 
This section provides some help in confirming various software installation and configuration. 

Connect all the cables as shown on page 5.  The files should be stored in C:\00Linux\. 

 

Linux Image:  NOTE:  You need an 8 GB or more micro SD card.  4 GB is not quite big enough. 

1) http://www.rocketboards.org/foswiki/Documentation/ArrowSoCKITEvaluationBoard141LinuxGettingStarted 

2) Insert the programmed micro SD into the SoCKit board.  Make sure jumpers and switches are correctly set.  

Power the SoCKit board.  Four LEDs blinking in sequence after Linux is booted confirms Linux is operating 

correctly. 

 

USB Blaster II: 

1) Go to page 18 and follow the four instructions under Connect SignalTap II to SoCKit Board:  You should 

see JTAG Ready displayed to indicate the USB Blaster drivers are working correctly. 

2) You can close SignalTap II after this test. 

 

Terminal 1: 

1) Determine the COM port assigned by Windows and configure DS-5 Terminal as described on page 6. 

2) Sign on user root – you can then enter  ls or pwd to get a response from the kernel.  This indicates the serial 

terminal is working correctly. 

3) Leave Terminal 1 working for the next step. 

 

Ethernet: 

 

1) In Terminal 1, type ifconfig and press Enter to find the IP address for inet addr as described on page 21 

under Determining the SoCKit IP Address:  You can also use ifconfig eth0. 

2) See the screen below. You must get a value similar to 169.254.250.201 in order for Linux debugging and 

Streamline with DS-5 to function.  The actual IP address on your system will near certainly be different than 

this one.  If you get an inet addr similar to mine, your Ethernet connection is working. 

TIP:  This IP address will change every time the SoCKit board Linux is rebooted. 

3) If you do not get an inet addr, try several times. Try repowering the SoCKit. 

4) Note:  inet6 addr is not what you want.  You need inet addr. 

5) You might have to give the SoCKit and/or your PC a fixed IP address.  Instructions on doing this to the 

SoCKit are given on page 21. 

General Notes: 

1. Store the examples software in C:\00Linux\ for convenience.  You can store them anywhere you prefer, 

but this will make it easier for this tutorial. 

 

http://www.rocketboards.org/foswiki/Documentation/ArrowSoCKITEvaluationBoard141LinuxGettingStarted
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ARM®DS-5™ Altera Edition Installation and License setup 

DS-5 has a strong online presence to help guide developers through the everyday tasks of software development.   

 DS-5 website –  http://ds.arm.com  

 Developer resources -  http://ds.arm.com/developer-resources/  

 University Program -  http://ds.arm.com/arm-university-program/  

 Community support and forums - http://community.arm.com/groups/tools/content   

SoCKit board: 

An Arrow SoCKIT Cyclone V SoC  board and a suitable power supply for it: 
https://parts.arrow.com/item/detail/arrow-development-tools/sockit    

Preparation 

For this workshop, it is recommended that you use ARM DS-5 AE (Altera Edition) which is bundled with SoC EDS. 
DS-5 Altera Edition is armed with silicon specific optimizations such as FPGA Adaptive Debug using SignalTAP II. 

For the workshop you will also need the kernel sources, debug symbols (vmlinux) and the kernel module example 
for the SoCKIT board (See page 5)  

Host PC Setup  

This section installs DS-5 Altera Edition and Quartus II software.  Setting up the host PC requires following steps: 

1. Downloading SoC EDS: 

a. Download and install the latest SoC EDS: http://dl.altera.com/soceds/?edition=subscription 

2. Starting DS-5 Altera Edition in order to install a license: 

a. Click on Windows Start.  Select All Programs -> ARM DS-5 -> Eclipse for DS-5 
Note: You can also create a Desktop icon for DS-5 in the usual manner if you prefer. 

b. Select the default Workspace. 

c. The first time you start DS-5 you will see the "Welcome to ARM DS-5" home page providing useful 

information. Go to the Workbench by closing this window:  . 

d. Note: You can get the Welcome page back if you want it later by choosing Help -> Welcome.  

3. Obtaining a DS-5 License: To use all features of DS-5 Altera Edition, either the Evaluation or Full license 

must be used. 

a. DS-5 Altera Edition Evaluation Version:  This is the one we will use in this tutorial: 

i. A thirty day evaluation period is offered. All DS-5 Altera Edition features are enabled 
during this period 

ii. After starting DS-5 AE as described above Step a., follow the instructions, step 2 onwards, 
as indicated here:  http://ds.arm.com/altera/altera-eval-edition/ 

b. DS-5 Altera Edition Full License: 

i. If you have purchased a DS-5 AE license and are within the Service and Maintenance 
period, you can follow the instructions below: 

ii. In DS-5 open license manager using ‘Help -> ARM License Manager’ 

iii. Click the ‘Obtain License’ button and following the instructions.  

iv. Ensure a connection the internet exists.  

v. When you receive the license file, add it by using the ‘Add License’ button.  

4. Quartus II Programmer and Tools are installed as a part of the SoC EDS installation as described in 

Step 1. You can obtain them separately at: http://dl.altera.com/?product=qprogrammer#tabs-4  

Getting help   
You can press the F1 key (or Shift+F1 on Linux) at any time to get help about the current view. You can use Help 
-> Help Contents -> ARM DS-5 Documentation to view the documentation. You can access cheat sheets for 

various tasks using Help -> Cheat Sheets -> ARM …, for example importing the example projects. (But we won't 
be following those cheat sheets in this tutorial.)  

http://ds.arm.com/
http://ds.arm.com/developer-resources/
http://ds.arm.com/arm-university-program/
http://community.arm.com/groups/tools/content
https://parts.arrow.com/item/detail/arrow-development-tools/sockit
http://dl.altera.com/soceds/?edition=subscription
http://ds.arm.com/altera/altera-eval-edition/
http://dl.altera.com/?product=qprogrammer#tabs-4
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Installing hardware, examples, Linux and source code: 

See page 2 for hints on testing these installations.  Extract these files into C:\00Linux\.  See the resulting 

folders below.  Use of 7zip is tested and recommended.  The .gz files must be extracted twice with 7zip. 

It is important to get these files in the correct folders to match the tutorial instructions. 

1) 14.1 Arrow SoCKit Linux image for micro SD card (an 8 GB or greater micro SD Card is required).  
Follow the instructions at this website starting with Step 2 to load the Linux files into your micro SD card. 

http://www.rocketboards.org/foswiki/Documentation/ArrowSoCKITEvaluationBoard141LinuxGettingStarted  

Note:  Install 2), 3) and 4) in C:\00Linux\  See below left for the resulting folder listings. 

2) Linux Source Code files:  Extract these files without their folder names into C:\00Linux\linux-socfpga:  
Select skip: for any copying errors. 

https://github.com/altera-opensource/linux-socfpga/archive/ACDS14.1_REL_GSRD_PR.zip 

3) Linux kernel debug symbols (the symbols are contained inside this archive package) 

https://s3.amazonaws.com/rocketboards/releases/2015.02/sockit-gsrd/bin/linux-sockit-gsrd-14.1-bin.tar.gz 

4) gator:  The link below contains three files.  Extract these in C:\00Linux\gator\ as shown bottom left: 

http://rocketboards.org/foswiki/view/Documentation/DS5AlteraEditionSoCKitTutorial 

5) SoC Materials workshop containing the Quartus II project:  Extract into C:\SoCKit\  See below right: 

http://rocketboards.org/foswiki/pub/Documentation/ArrowSoCKitEvaluationBoard/SoCKIT_Materials_14.1.zip 

6) Altera USB Blaster II drivers and FTDI UART driver:  These are installed by Quartus II Programmer and 
Tools installation and SoC EDS software respectively.  These do not need to be installed separately. 

Board setup 

The image provided for this training session will boot Linux by default, and 4 blue LED’s LED0 through LED3 on the 
board will be cycling on and off in a pattern. 

 Connect the board as shown in the picture below:  TCP/IP, UART, USB Blaster and 12 v power. 

 Set the DIP switches and jumpers as shown in the images below (SW6 is on the bottom of the board) 

 





















 

010100 

Ethernet,   UART,      USB Blaster,                            12 v Power 

Jumpers: 

J15 2-3 

J16 2-3 

J17 1-2 

J18 1-2 

J19 2-3 

Resulting C:\00Linux\  

folder contents for 

example and source 

files: 

SoCKit has another 

SoCkit inside it as 

shown on the right: 

Contents of 

C:\00Linux\SoCKit\ 

http://www.rocketboards.org/foswiki/Documentation/ArrowSoCKITEvaluationBoard141LinuxGettingStarted
https://github.com/altera-opensource/linux-socfpga/archive/ACDS14.1_REL_GSRD_PR.zip
https://s3.amazonaws.com/rocketboards/releases/2015.02/sockit-gsrd/bin/linux-sockit-gsrd-14.1-bin.tar.gz
http://rocketboards.org/foswiki/view/Documentation/DS5AlteraEditionSoCKitTutorial
http://rocketboards.org/foswiki/pub/Documentation/ArrowSoCKitEvaluationBoard/SoCKIT_Materials_14.1.zip
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Altera Cyclone V SoC RAM-based Hello World Example - ARM®DS-5™ 

Purpose and scope 

This example is a simple bare-metal semihosted "hello world" example application loaded into on-board RAM. This 

example can be used as a framework on which to build your own basic C/C++ applications. It demonstrates how 

to connect the DS-5 debugger through a JTAG connection, load an application onto the board and perform some 
basic debug commands. It also shows advantages of using semihosting during the stages of early software design. 

 Make sure you have installed the FTDI RS232 USB driver and the USB II Blaster drivers. They should be 

recognized once you power on the board. The red button is power on-off.  To verify that they are recognized, 
open the Windows Device manager and look for the Altera USB-Blaster instances under the JTAG cables entry. 

Find the COM port that Windows has assigned to the UART connection. Look in the Windows Device 

Manager and expand the Ports entry. Make a note of the COM port number.  

Next connect the serial terminal to the device. You can use any number of applications to connect to the serial 
port such as Putty. In this exercise we will use the Terminal plugin in DS-5, but feel free to use whichever 

application you want to use. If you have not yet started up DS-5 Eclipse do it now (instructions are on page 4)   

In Ds-5, Select Window -> Show View -> Other … -> Terminal -> Terminal. Click OK and Terminal 1 

opens. 

Click the Settings button ( ) and select Serial as the Connection Type. 

Enter the COM port number you jotted down earlier, as well as a BAUD rate of 115200. Leave the rest of 

the options at their default settings.  Click OK and the Terminal 1 will connect to the board if it is powered. 

If not, click the Connect button ( ) to connect the terminal connection to your board. 

Once you have connected press Enter inside the terminal box. You should see the Angstrom Distribution 

login appearing as shown here. 

     Use the username “root” to log into the device.  There is no password. 

For this training session we need to stop the target in U-Boot before Linux boots. This is essential since the Linux 
kernel will turn on the MMU and might protect direct access to the memory location we are loading our hello world 
application to. 

Stop Linux boot: In the Terminal 1 view, type reboot and press Enter.  Wait for the target to reboot so 

you can stop the Linux boot process. Once U-boot starts and displays "Hit any key to stop autoboot", you 
will have three seconds to hit any key to stop U-Boot from booting Linux. You should see something similar to 

the screenshot below with the Cyclone5 prompt:  If you miss this step, type reboot again or repower the board 
and try again. 
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Import the example into the DS-5 Eclipse workspace as follows: 

Go to File -> Import...  -> General -> Existing Projects into Workspace -> Next 

Click Select archive file: then press Browse... next to it.   

In the File dialog navigate to C:\altera\15.0\embedded\ds-5\examples\.   

Then select Bare-metal_boards_examples.zip.  Click Open. 

The Projects field populates with the example projects found in the .zip. Bare-metal_boards_examples.zip 
contains a number of different ARMv7-boards examples, including startup code and simple applications for a 
variety of Cortex-A, R and M family platforms.  

For this workbook, we only need the Altera-Cyclone-V_RAM example, so press Deselect All, then select 

just  Altera-Cyclone-V_RAM.  If this entry is greyed out, this means it is already installed. 

 

Press Finish. The Project Explorer view populates with the project. 

Expand the Altera-Cyclone-V_RAM folder  

Ready-made launch configurations Altera-Cyclone-V-(Single_Core)_RAM.launch and Altera-Cyclone-V-
(Dual_Core)_RAM.launch are provided. 

Building the example 

This example can be built with the ARM Compiler 5 using the supplied Eclipse project, or directly on the command 
line with the supplied Makefile. We will use Eclipse to build this project. The Eclipse project is a managed builder 

project, that creates a makefile in the /Debug directory. 

Semihosting enables an ARM Target to use the input and output facilities of the host computer when a debugger is 

connected. Semihosting is very useful for board bring-up before the drivers are written for the device peripherals. 
For example a printf would normally be printed on the UART, but with a semihosting library a SVC call is made and 
the debugger in turn would detect the semihosting call and read the printf directly from memory.  

DS-5 Debugger enables semihosting automatically if either symbols __auto_semihosting or 
__semihosting_library_function are present in an image. The ARM Compiler 5.0 adds 
__semihosting_library_function automatically to an image at link time if that image uses any semihosting-
using functions. If compiling with gcc or an earlier release of armcc, use an alias symbol definition such as void 
__auto_semihosting(void) __attribute__ ((alias("main")));  

The project contains a scatter file to instruct the compiler where in memory to load the code and data sections. 
For the SoCkit board we are loading the example into the internal RAM located at 0xFFFF0000. 

Building from Eclipse 

To build the supplied Eclipse project: 

 In the Project Explorer view, select the project you want to build:  Altera-Cyclone-V_RAM 

 Select Project -> Build Project or Build All (Ctrl+B). 

The Console view will contain results from the Build process.  There will be no errors or warnings. 
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Connecting and running the example 

The SoCKit board should be powered and Autoboot was stopped as described on the bottom of page 6. 

Open the DS-5 Debug perspective: Select Window -> Open Perspective -> DS-5 Debug 

Note:  If DS-5 Debug is not visible here this means you are already in this perspective.  See  

 From the Run menu at the top of DS-5, select Debug Configurations.  Expand DS-5 Debugger. 

 Select Altera-Cyclone-V-(Single_Core)_RAM from the list of DS-5 Debugger configurations. 



 In the Target Connection dropdown menu, select USB-Blaster 

 In the Connection panel beside Bare Metal Debug, click on Browse and the Connection Browser view 

opens. Highlight CV SoCKit on LocalHost [USB-1] and click Select.  It will appear as shown above. 

Note: If nothing appears in this dialog, check that your board is connected and that the drivers are installed 
(See Windows Device Manager) 

 Click on Debug to start debugging. The example image will be downloaded to the target and it will run to 

the start of the main function and halt. See the cyan arrow in the hello.c tab in the Source pane. 

Debugging requires the DS-5 Debug perspective. If the Confirm Perspective Switch dialog box opens, 

click on Yes to switch perspective.  

 

 Open the App Console view. Run the executable (press F8 or  in the Debug Control view).  

       "Hello world" output appears in the App Console view.  Congratulations ! 

 In the Debug Control view, disconnect from the SoCKit target:  . 
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Debug Control view icons: 

Hover your mouse over these icons in the Debug Control view to display their names: 

Connect DS-5 debugger to the target:    Disconnect DS-5 from the target:  

Continue (RUN)  (F8):         Interrupt:  (F9)  (STOP)                

 

This determines if Step and Step Over (below) are step by assembly instruction or C source line:   or  

Step (F5):                Step Over (F6):    

 

Step Out (F7):      

Debug to main():   Debug from entry point:      Run:   

 

Optional exercises 

If you have time, familiarise yourself with the debugging environment. Here’s a couple of ideas for exercises: 

Restart the debug session from the main() function (TIP: there is a button for it in the Debug Control 

view) 

Add a while loop to the outside of the printf statement and recompile the image. 

Reload and debug the example 

Experiment with source level step, instruction step, step over and step into functions.  

Experiment with setting breakpoints (TIP: double click on the left side of the source code view) 

Set a conditional breakpoint on the while loop statement. For example make it hit the breakpoint only if the 

loop has executed a number of times. (TIP: Right click on a breakpoint in the Breakpoints view to edit it) 

Create a small script to reset the while loop counter back to its initial value, add it to the breakpoint so that 

the loop will run forever.  

Known issues and troubleshooting 

 Eclipse reports Unresolved inclusion for system headers such as stdio.h if it cannot locate the header 

files for a project. You can resolve this by right-clicking on the project in the Project Explorer view and 

then selecting Properties... from the context menu. In the dialog box, select: C/C++ General → Paths 

and Symbols → Add... and then add the path to the ARM Compiler 5 headers on your host workstation. 

For example, C:\Program Files\DS-5\include. Select both Add to all configurations and Add to all 

languages, click on Apply so that Eclipse can rebuild the index. 
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DS-5 Linux kernel debug, trace and FPGA SignalTap II cross triggering 

Linux kernel debug, trace and cross trigger configuration  

In this section the goal is to create a SMP Linux kernel and module debug configuration. In addition we will enable 

trace capture and cross-triggering on the core.  Linux must be running.  Cycle the board power if necessary. 

 Confirm the DS-5 Debug perspective is on:  Window -> Open Perspective -> Other… -> DS-5 Debug  

Note: If DS-5 Debug is not listed here, then DS-5 in already in this perspective. 

 Choose Run -> Debug Configurations... then expand DS-5 Debugger 

 Click the New launch configuration button ( ) to create a new debug configuration.  (You can also 

double-click DS-5 Debugger or right-click it and choose New instead.) 

 Give the debug configuration a name in the Name: box, I used Linux Kernel Debug. 

In the Connection tab of the debug configuration we need to specify the platform and choose the USB-Blaster.  
The platforms list contains the large number of platforms that DS-5 supports by default arranged as a tree by 
vendor. 

 Type Altera in the Filter platforms filter box so that the only the matching platforms are shown.  

 in the Platforms list expand: 

 Altera -> Cyclone V (Dual Core) ->Linux Kernel and/or Device Driver Debug  

 Select Debug Cortex-A9x2 SMP 

 Select USB-Blaster in the Target Connections pull-down menu. 

 The SoCKit board must be powered at this time. 

 Select Browse on the Linux Kernel Debug Connection box and Select CV SoCKit on localhost[USB-1]. 

The tracing options are configured in a separate DTSL configuration.  “DTSL” stands for Debug and Trace Services 
Layer. We’ll enable tracing on both cores on the next page. 
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 Click the DTSL Options Edit… button to open the DTSL Configuration Editor dialog box. 

 Click the Add button ( ) to create a new DTSL configuration. 

 Give the new DTSL configuration a name, I used trace-all-cores. Click Apply. 

 In the Cross Trigger tab shown below, enable both Cross trigger options and select Assume the Cross 

Triggers can be accessed.  This will allow the FPGA to create a trigger input to and from the HPS system. 

 
 In the Trace buffer tab shown below left, we will instruct the debug infrastructure to use the block RAM 

created by the hardware designer.  This option uses the System Memory Trace Buffer, via the Embedded 
Trace Router (ETR), so select this as the trace capture method as shown below: 



 In the Cortex-A9 tab, select Enable Cortex-A9 core 

trace as shown to the right here:  

 Check both Enable Cortex-A9 0 and Enable 

Cortex-A9 1 trace to collect trace from both cores. 

 Check Cycle Accurate so that the trace data will 

include cycle count (although this will mean that fewer 
instructions fit into the trace buffer). 

 In this workshop we will not be using STM trace, so 

leave it disabled as shown below: 

 
 

 
Note:  In the Qsys project for the FPGA, the Block RAM to be used was set to offset 0x00000000 of the 
HPS2FPGA Bridge, with a size of 64K.  According to the Cyclone V SoC Documentation this bridge is at offset 
0xC0000000 of the processor address map: 
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 In the ETR pane shown below, select Configure the system memory trace buffer.  Set the system 

memory trace buffer at start address 0xC000 0000. Change the size to 0x4000 Words.  This correlates to the 

64K buffer space available in the on-chip RAM. 
 

 

 Leave the on-chip trace buffer in the ETF pane disabled. 

 

 Click OK to take you back to the Debug Configuration window.

 In the Files tab shown below, we will not ask the debugger to download an application to the target.  We 

want to connect to a running Linux target, rather than downloading new code, so leave this option blank.  

We want to point DS-5 to the peripheral description files that have been generated by the hardware design.  

 In the Files pull down menu shown below:  choose Add peripheral description files from directory.  

 Select File System… and navigate to: 
C:\00Linux\SoCKit\SoCkit\SoCkit_SW_lab_14.1\soc_system\synthesis. 

  Click on OK and this will be added as shown below: 

In the soc system synthesis directory, DS-5 will have named register visibility of the dimmer peripheral that is 

in the FPGA fabric.  
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 In the Debugger tab shown below, we would like to just connect to the target, rather than trying to debug 

from an entry point.  This allows us to interrupt a running Linux target, rather than starting from the entry 

point of a downloaded program.  Click the Connect only radio button. 

Next we need to instruct DS-5 where to find the symbol files to debug the Linux kernel and modules. We can 
also do this from the DS-5 UI at run time. However, instead we’ll setup the debug configuration to load it for 
us automatically during connection time.  We will also load the gpio labels for these functions.

Check the Execute debugger commands and type in the text exactly as listed below with the quotes: 

interrupt 

add-symbol-file "C:\00Linux\linux-socket-gsrd-14.1-bin\vmlinux" 

add-symbol-file "C:\00Linux\gator\gpio-altera.ko" 

1. The Interrupt command stops the processors, and gives control to the debugger 

2. The add-symbol-file command loads the Linux kernel symbols vmlinux from your laptops file 

system.  This must be the same kernel that is running on the target.  This will allow the debugger to 
connect to the kernel running on the board, and be able to perform kernel-level debugging of the 

operating system, including debug of dynamically loaded device drivers.  

At this point you could add any other debug commands or other operations for example using the break 
command to set breakpoints or add-symbol-file to add kernel modules that you would like to debug.  These 

modules do not need to be currently loaded into the kernel at the time of the command.  However if and when 
they are loaded, you will be able to correlate C source code to the loaded kernel driver, and be able to debug 
these drivers at a function and C level. 

TIP:  You might have to scroll down in this pane to see all the options. 

Set the Paths Source search directory to point to the root directory of the kernel source as shown below. 

This is not strictly necessary when debugging on the same machine that you compiled the kernel on.  
However, if you are on a different machine, the debugger will resolve any unfound source code relative to this 
specified path.  

C:\00Linux\linux-socfpga 

For the OS Awareness tab, keep this as the default of “None”.  We are performing Linux kernel aware 

debugging, however this is set in the Connection tab, and not here. 

No settings need to be added for the Arguments or Environment tab, so do not change anything here. 

Click on Apply to save your debug configuration options, and then Debug to start the debug session. If 

you see an error message similar to the following, please rescan the USB Blaster device, as this may have 
changed port compared to an earlier debug session.  Accept changing to the debug perspective if asked. 

If all connects, and control returns to the debugger, congratulations! You have started a Linux kernel aware 
debug session! Don’t disconnect the debug session, we will continue debugging in the next section. 
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FPGA Adaptive debugging – Controlling hardware via the Registers view 

In this section, we will make use of the CMSIS SVD files that have been created for our custom hardware.  This 
allows us to read and write registers for custom peripherals within the FPGA as if they were part of the SoC ASIC. 

 The session continues from the previous kernel debug sessions. 

If you’re not connected, please connect now:   in the Debug Control view. 

If Linux is running (the LEDs are blinking), please stop it:   in the Debug Control view. 

TIP:  If you are unable to connect, repower the SoCKit board and try again. 

 

By default (since we added it to the debug configuration), when connecting to the target, the interrupt command 
is executed. This stops the processors, and gives control of the system to the debugger.  In order to read or write 
system registers with DS-5, the processors need to be stopped.   

 

 In the Registers view of the debugger, expand the Peripherals tree.  

If the Peripherals list of registers is not listed, you will need to add it to the view by clicking the Browse 
button in the bottom right of the view and add the altera_avalon_pio_led peripheral to the view. (This is a 
new feature found only on the new DS-4 5.21 which will be available soon). 

 

 In the list of Peripherals, find the altera_avalon_pio_led_pio_s1 peripheral.  This is our custom 

peripheral generated in the FPGA logic.  Expand the peripheral to see the available registers. 

 The DATA register will show the current value of the LED registers.  This number will be reflected in the 

current state of LED0 through LED3. 

Click on the _DATA value to change it, and enter a number smaller than 0xF.  Take a look at the four FPGA 
LEDs on the target board to confirm that they have changed (0xF = all LED’s off; 0x0 = Four LED’s on).  
You can enter hex (0x0 through 0xF) or decimal numbers (0 through 15). 

 You can also set individual bits using the SET_BIT register. The DATA register will change to yellow if the 

value is changed using the SET_BIT register. 

 

 

You have successfully controlled a custom peripheral via the debugger without needing to write any software!  In 
addition, by using the configuration files compatible with DS-5, there is no need to know the address that the 
custom peripheral lives at, or the offset address of the peripheral registers.  

All of this is abstracted away from the user.  CMSIS can be used to perform very advanced register manipulation, 
including DRC and bitwide manipulation.  This was a very simple example, but you could integrate more advanced 
settings as per your requirements. 
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Kernel, device driver and hardware debug 

In this section, we will test that the kernel driver for our custom hardware is working correctly.  We will observe 
the device driver loading, and interact with the hardware using the Linux command shell. 

First, let’s assume that we do not know much or anything about the LED driver in the Linux kernel. By setting a 
Watchpoint on the FPGA registers we should be able to find out from where the writes to the LED data register are 

occurring.  Note:  A Watchpoint is not the same thing, but is similar to a Breakpoint. 

You should be connected with DS-5 to a kernel stopped on the board from the previous page.  If not, please do so 
now, with the configuration setup specified in the first part of this workshop.  The LEDs should not be blinking. 

 Open the Registers view, right click on the altera_avalon_pio_led_pio_s1_DATA register and select 

Toggle Watchpoint.  Select Write in the Add Watchpoint window that opens and click on OK. 

You should now encounter an error in the Commands view as shown below right:  The debugger cannot set a 
Watchpoint on physical memory (P:) since it is not supported by this target. DS-5 can do this if the MMU is not 
used. Linux uses virtual memory addresses.  

Remember, Linux uses the Cortex-A9 MMU (Memory Management Unit) to translate between virtual and physical 

memory spaces. DS-5 provides you the ability of translating between virtual and physical addresses. 

We can use the DS-5 debugger's MMU view to do a physical to virtual translation lookup, which in turn would then 

allow us to set a breakpoint on the equivalent virtual address. Breakpoints work only on physical addresses. 

In the Registers view right click on any one of the column names at the top of the view (i.e. Name) and 

select Location to add a column to display the physical location. Take a note of the location of the 
altera_avalon_pio_led_pio_s1_DATA register (in this case it was 0xFF210040). 

 

Open the MMU view by selecting Window -> Show View -> MMU. 

Select Physical to Virtual in the pull down menu as shown below. 

Enter the physical address of GPIO port. Click on Translate and three values will appear in the Result box. 

In this case, three virtual memory locations map to the physical address. This could be due to a number of 
reasons for example different processes may have that a particular code sections linked to that location. 

It’s not guaranteed that all the virtual memory locations will be accesses, so we should set Watchpoints on each of 
the three addresses calculated. 

 

 

 In the Commands view, in the DS-5 Command line:  Set a data write Watchpoint on the virtual memory 

location using each of three Virtual addresses previously calculated.  An example is:  watch 0xC08E2040  
You can type each address in or cut and paste from the MMU view. 

TIP: It is also possible to set data read and data access watch points with the commands rwatch and awatch  

 Collapse the Peripherals in the Register view.  Otherwise some Precise Aborts might be displayed.  

 When you are done, set the processors to a running state. Do this by clicking on the  Continue button. 

Note:  It could take 10 or so seconds for the Linux kernel to stop at the Watchpoints you just created. 

ERROR(CMD225-COR274):  

! Unable to set a watchpoint on the expression "*P:0xFF210040". 

! The address space "P:" is not available on this target 

The error caused by attempting to set a 
Watchpoint on a Physical address when it is 
not available because of MMU operation: 
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Since the LED’s are currently toggling on and off, the Watchpoint will be hit fairly soon and you should see the 
processor should be stopped. From this we can tell a few things: 

 The target was stopped because it hit one of our watchpoints (see the command line output for proof) 

 The user space process that is causing the LED’s to toggle is called scroll_server (see Debug Control) 

 We don’t have symbols loaded for the memory location S:0xCF0003DC (S: is the prefix for secure 

memory).  See this in the Commands view and in the Disassembly view where the program is stopped. 

 The debugger has detected that it stopped in the gpio_altera kernel module in the Disassembly view.  

 Open kernel Modules view by selecting Window -> Show View -> Modules  

The function names in the Disassembly view were loaded for the gpio_altera kernel module in the Debug 
Configuration by the line add-symbol-file "C:\00Linux\Gator\gpio-altera.ko". We do not have the debug 
symbols for this module (you’ll need the kernel build tree). 

TIP: You could manually add source files by right clicking on the gpio_kernel entry in the Modules view and 

select Add Symbol File … Browse to the source files and select them (in this case would be  and select 
gpio_kernel.ko). Right click on the gpio_altera entry in the Modules view and select Show in Disassembly. 

 You can see the gpio_altera function names in the Disassembly view, for example, click the Next 

Instruction button ( ) in the Disassembly view to go to the location of the current PC. In the Disassembly 
view you will see the next instruction to be executed indicated by an arrow as shown below. If you scroll 
upwards you will see that we are now in the gpio_altera_set function. In the screenshot below the PC is 
stopped on a STR instruction which is storing the value in r6 (0xF) to the virtual memory location 
0xC08E2040. In this case, the next setting for the LED will be 0xF i.e. LED0 to LED3 will be lit up. 

 Step one assembly instruction by first enabling the Step by 

Instruction   button in the Debug Control view, and then 

clicking the Step button    ( ). You should now see one of the 

LED’s changing its state. 

 

Since the gpio_altera.ko module does not contain any 

debug symbols we cannot trace the origin of the call to 
the LED set function in the call stack shown in the 
Debug Control view. Single stepping through the code 
might take a long time, especially if an interrupt or task 
switch occurs. 

DS-5 does contain some advanced stepping functions 
like step over and step out. Inside the Disassembly 
view we can tell the location where we exit the 
gpio_altera_set function by looking for the LDM 
instruction where the saved registers are popped off 
the stack.  

 Right click on the LDM instruction (probably at 

0x7F00 0424) and select Run to Selection. 

 Now, single step the LDM instruction by typing 

stepi in the Commands view. 
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The Call stack in the Debug Control view now shows a larger call stack since we have stepped back into the 

kernel source code for which we have loaded symbols for. The kernel code is currently running through the Linux 

tracepoint functionality. If you look a little further down the call stack look for the __led_set_brightness 

function. This function is part of the LED kernel driver module built into the kernel.  

Now that we have found the driver that controls the LED hardware, let’s take a closer look at the off chip trace to 

see which parts of the driver is being used. The size of the trace buffer is relatively small (0x4000 = 16kB), so we 
cannot be guaranteed that we have enough space to track down the original call. It is also possible that an IRQ 
might be taken at any time filling up the trace buffer.   A DSTREAM debug adapter will store many more frames. 

 Open the Trace view by selecting Window -> Show View -> Trace 

The trace window is linked to the core that is selected in the Debug Control view. Select the core that is running 
the scroll_server application 

You can see a performance Analysis section and the instruction frames components of the Trace view. 

Instruction trace is invaluable for hard-to-find program flow problems and timing issues. 

Performance Analysis can easily tell you if you are spending too much in certain areas of your program code. 

It is worth your time to learn how to use this important feature.  Streamline shows even more information. 

 

Since the trace buffer is fairly small it may contain limited trace from the LED driver. DS-5 has advanced trace 
capture features setting trace point and ranges. Each of these has their own functionality   

 Trace trigger point: A trigger event is inserted in the trace buffer. It might help to locate the source 
code or do other debugger commands like stopping the trace capture. 

 Trace start / end points: Collect trace between these points and collect trace any functions called from 
within the region 

 Trace ranges: Collect trace between the linear address range, do not collect any trace from function calls 
outside the range 

 

To Finish this section and prepare for the next exercise: 

 Open the Breakpoints view.  Unselect the three watchpoints you created.  You can also Delete them by 

right clicking on each one and select Delete.    

 

 Click Continue (  or press F8).  The LEDs should be blinking 

for the next exercise on the next page. 
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Cross-triggering between SignalTAP II and DS-5 

Altera and ARM have worked to seamlessly integrate cross-triggering between the software debugger and 
hardware target.  We will now demonstrate how easy it is to trigger in either direction (FPGA to HPS and HPS to 

FPGA) using the cross-triggering mechanism.  HPS = Hard Processor System which is the Cortex-A9s. 

Make sure the SoCKit is powered and connected to your PC and running Linux.  The LEDs will be blinking. 

 

Control the LED driver 

In this section we will stop the scroll server application that blinks the LEDs so that we can control our LED’s 
manually from the Command line.  

 In Terminal 1 view, enter pgrep scroll_server  and press Enter to determine the process number ID PID  

(for me it is PID: 164) 

 In the Terminal 1 view, kill the scroll_server application by entering:  kill <PID> 

 root@socfpga_cyclone5:~#  kill 164

The LEDs will stop blinking but the program itself will keep running. 

 You can manually toggle the LED’s from the Terminal 1 view, for example to toggle LED 0 echo the value 0 

or 1 into the register:  echo 0 > /sys/class/leds/fpga_led0/brightness 

In the Command line in the Commands view, set a hardware breakpoint on the led driver on the instruction 

after the STR which toggles the LED with the command hbreak altera_gpio_set + 0x70. You can also use   
hbreak S:0x7F000418 

This will now be visible in the Breakpoints view: 

  

 

Start SignalTap II Logic Analyzer: 

In Windows, select Start -> All Programs 

 From here, select Altera 15.0… -> Quartus II Programmer -> Quartus II 15.0 Signal Tap II. 

The program SignalTAP II Logic Analyser will start. 

Select File -> Open. Navigate to C:\00Linux\SoCKit\SoCKit\SoCKit_SW_lab_14.1 and open file stp1.stp. 

Note, there is no need to configure the FPGA from SignalTAP this time, as the boot loader already performs this 
function. However, you will need to set the Hardware to the USB Blaster II, and the Device back to the FPGA. 

 

Connect SignalTap II to the SoCKit board 

In the Jtag Chain Configuration window, click the Setup… button. The Hardware Setup window opens. 

In Currently selected hardware box, select CV SoCKit [USB-1] and click on Close. 

Select the Device pull-down menu and select the FPGA system. In this case it’s the first entry in the scan 

chain starting with “@1: 5CSEBA6(.|ES)…” 

At the top of the Jtag Chain Configuration window, JTAG ready will be displayed indicating a valid 

connection to the on-board USB Blaster. 

 

At this point, the program is running on SoCKit but the LEDs are not blinking (because we killed that process). You 

have successfully connected SignalTap II to the SoCKit board. 

The steps on the next page will configure cross triggering from the HPS (Hard Processor System) to the FPGA. 
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Cross triggering from HPS to FPGA 

For this first exercise, we will be using cross triggering from the HPS to the FPGA.  That is we would like a DS-5 
debugger breakpoint to a trigger signal acquisition within SignalTAP. 

TIP:  HPS = Hard Processor System which is the Cortex-A9s. 

Select the Setup tab in the Signal Configuration window in the bottom left as shown below: 

In the Trigger Conditions box shown above, all should be set to "Don't Care" as shown above.  

 i.e. XXX  or  .  If necessary, you can modify these by right-clicking on them. 

In the Signal Configuration: window shown above right, scroll down to the Trigger section. 

For the Trigger Position, select Pre trigger position. 

Under Trigger In:, select in the Pattern box, Rising Edge as displayed above and here:  

Arm the SignalTap II, by pressing the Run Analysis button ( ).  

Going back to DS-5, ensure that the kernel is running by clicking on the Continue button ( ). 

In the Terminal 1 view, type one of these commands to invoke the LED set routine and hit the breakpoint 

set in the gpio_altera module:  I does not matter which one you use. 

This turns LED0 on: 

root@socfpga_cyclone5:~#  echo 0 > /sys/class/leds/fpga_led0/brightness 

This turns LED0 off: 

root@socfpga_cyclone5:~#  echo 1 > /sys/class/leds/fpga_led0/brightness 

DS-5 will show that the kernel is stopped by the breakpoint in the altera_gpio_set function, just as 

before.  However, now as we also had cross-triggering enabled, you should see that SignalTAP has triggered, 

and you can see the transactions that occurred on the bus around the breakpoint. 

TIP:  In Terminal 1 view, pressing the UP arrow key returns past entries instead of typing them in again. 

As you can see below, in this case the debugger should be stopped at the breakpoint here! The cross trigger 
causes signal tap to record signals and this is displayed. The trigger was registered around time 0, and 0xC was 
written one cycle forward from the trigger. It may take a little time for the write to complete, as well as there will 
be a little skew between breakpoint being hit trigger condition in SignalTap. 

 

Note:  0xC means the LED0 is off.  0xD means LED0 is on.  In this case, LED2 and LED3 are also on. 

 

 
 

This trigger under software breakpoint control is very powerful, yet simple to use.  It is, for example a great way 

to see the effect of a line of software on a bus, ensuring that the transaction is being seen by the FPGA as 
expected by the software engineer. 
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Cross triggering from the FPGA to HPS 

We shall now perform cross triggering from the FPGA to the HPS.  That is, we will setup a hardware trigger in the 
FPGA that will cause the software to break and return control to the debugger.   

First, in DS-5, disable the breakpoint in altera_gpio_set in the Breakpoints view. You can also remove it 

by double-clicking on the breakpoint in the Source Code or Disassembly view.  

Continue (RUN) the processor with the  Continue button in the Debug Control view. 

In SignalTAP II, select the Setup tab.  

In the Signal Configuration: window, Change Trigger in from the HPS to “Don’t care” as shown below: 

Right click on the Trigger Conditions window led_pio|write_n peripheral register and select Rising Edge.  

Your settings should be the same as the diagram below: 

 

Arm SignalTAP using the Run Analysis button ( ). 

At this stage, the kernel is running, and there are no user breakpoints on the target.  The only action that will 
automatically stop the kernel running is cross-triggering from the FPGA to the HPS (the Cortex-A9s). 

 Action this now, by writing once again to one of the FPGA LEDs in the Terminal 1 view in DS-5: 

root@socfpga_cyclone5:~#  echo 0 > /sys/class/leds/fpga_led0/brightness 

SignalTAP will trigger, and the kernel stops.  In SignalTAP, you should see that the trigger is directly on the Avalon 
clock cycle where the Write signal went low, so we’re sure that the trigger is from the hardware:  

 

Back in DS-5 take a look at the trace buffer.  At the bottom of the trace window, you’ll see exactly where the 
processor stopped.  Taking a look at the history, we can see clearly that we had just run the altera_gpio_set 
routine to toggle the dimmer.  We can see a clear back-history within the driver as to what was running around 
the time of the hardware event. 

This kind of debugging is also very powerful.  For example, a hardware trigger condition can be used to indicate an 
illegal transaction, or faulty write to a peripheral that is out of bounds for your design.  By using FPGA to HPS 
cross-triggering, it can clearly be seen what code was executing around the time of the suspect transaction, which 
can literally save months of debug, clearly defining the region of the software error. 

 

 When you are ready to continue to the next page, close SignalTap II in the usual manner. 

 Disconnect DS-5 from the target:  
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DS-5 Remote Systems Setup  

In this session we will connect the target board to our DS-5 session through a Remote Systems SSH session. 
This will allow us to copy images to and from the target, as well us allow to open an .ssh terminal. 

Booting Linux on target 

In order to connect to the board we need to first determine the IP address.  

 If you have not done so yet, Disconnect from the debug connection we created in the previous session.  

 Connect the Ethernet cable from your board to your PC. (You can also connect to a network if you have 

one available). Reboot the board.  The Terminal 1 view will ask for login.  Use root.  There is no password. 

 

After Reboot, you should see U-Boot starting on the target in Terminal 1, which in turn will automatically load 
Linux after a few seconds. Next, we need to figure out the IP address that has been assigned to the target Linux.  

If you are connected to a network the target will automatically obtain an address from a DHCP server. The target 
also runs an Avahi mDNS service which will register IP addresses and assign one to the target if you connect from 
your host PC. On earlier versions of Windows you may need to set the PC to have a static IP address.  

Determining the SoCKit IP Address: 

 To determine the IP address of the target type ifconfig on the target serial port Terminal 1. Look for 

eth0 and copy the inet addr value as we will use it later.  An example is 169.254.211.199. 

If you don't see a valid IP address for eth0:  You can also manually configure the TCP connection. Set a static 
IP address on the target by running ifconfig eth0 169.254.0.100. Setting your PC IP address in a similar range 
(for example 169.254.0.1) should then do the trick. 

 

The Remote Systems view 

Next, we'll establish a connection to the target using Eclipse's Remote Systems Explorer (RSE) so that we can 

browse its file system and create a terminal connection. The Remote Systems view is part of the DS-5 Debug 
perspective, so we’ll switch to that perspective now if you are not already in it now. 

 Choose Window -> Open Perspective -> DS-5 Debug. If DS-5 Debug isn’t listed then you are already in 

the DS-5 Debug perspective.  You can also switch perspectives by using the buttons on the Perspective 

toolbar ( ). 

 If the Remote Systems view is not open, you can open it by choosing Window -> Show View -> 

Other... -> Remote Systems -> Remote Systems in any perspective. 

 Click on the tab of the Remote Systems view to bring it to the front. 

 We won’t be using the Local connection, so you can collapse it. 

Creating a Target Connection 

We will establish a connection to the Altera target using Eclipse's Remote Systems Explorer (RSE) so that we can 
browse its file system and create a terminal connection. 

 Create a new connection by clicking the New Connection button ( ) 

 

  

 Choose General -> Linux -> Next -> 

 Put the target's IP address in the Host name field and use My Target as the Connection name. 

 Click Next ->.     

   Continue on the next page: 

 

TIP:  Each time the SoCKit is RESET or rebooted, this IP address will change.  This means you must 

re-enter the new IP address into Remote Systems.  See the bottom of page 23 for instructions. 
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 Check ssh.files then click the Finish button.  If you click Next instead of Finish, you want the rest of the 

default settings: processes.shell.linux, ssh.shells, and ssh.terminals. 

 

  

 

 Browse the target's file system; Expand My Target -> Sftp files -> Root.  If the connection has Files 

instead of Sftp Files, then the connection was not created correctly and you should Disconnect it, Delete it 
and recreate it. 

 Enter User ID=root, leave the password blank; check Save user ID and click the OK button. There will be 

a few authentication dialogs; accept them all. 

 

 

You can expand Root/ to see the SoCKit Linux file systema s shown here on the right: 

You can also expand My Home to browse the home directory of the user, which is /home/root for the root user. 

You can copy files to and from the target by dragging them between the Remote Systems view and the Project 
Explorer view or Windows Explorer windows.  You can also use copy and paste (Ctrl-c and Ctrl-v) if you prefer.  
As we'll see below, it's also possible to copy files to the target automatically as part of the debug configuration. 

 

If you want, you can double click a text file on the target, for example /etc/bash.bashrc, and view it or even 
edit it in Eclipse – but it's probably best if you don't save any changes unless you are sure that you know what you 

are doing. 

Continue on the next page: 
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Now we'll create a terminal connection so that we can execute commands easily on the target.  You can Collapse 
the Sftp Files to get them out of the way. 

 Create a Terminal by right-clicking on Ssh Terminals and choosing Launch Terminal. 

 
This will open a Terminals view in Eclipse that can be used to execute commands on the target.  (This is different 

from, but confusingly similar to the Terminal 1 view).  The picture below shows the output from the example 
target image included with DS-5.  If your target is running a different distribution the output will be different. 

 

In the Terminals view type pwd and Enter to test this conenction.  Then type ls /etc and Enter to get these 
responses:  

 

  
You can use Launch Terminal more than once if you want to have multiple terminal sessions to the target. This 
will create extra Terminals views that you can use. 

 

We will use the Remote Systems connection to copy files to and from the target in the Streamline session.  This is 
much easier than using Linux copy, delete, move change and display directories commands. 

 

Notes on using SSH: 

If you Reboot the SoCKit or if Remote System stops working: 

1. Each time you reboot the SoCKit, the IP address is likely to change and Remote System will stop working. 

2. Use Terminal 1 to determine the IP address (inet addr) by typing ifconfig.  Note this address. 

3. Right click on My target in the Remote System view.  Select Properties. 

4. Select Host (located in upper left corner). 

5. Enter the new IP address in the Host name: box as before. Click OK. 

6. Expand Sftp Files and Root.  Enter root as the User ID.  There is no password. 

7. You should now be able to expand the Root and view SoCKit folders and files: 

8. Launching Terminal: You will also need to re-launch the Terminal as described at top of this page: 

If you are using Streamline: 

9. If you are using Streamline and need to change the IP address in the Remote System, you will also have 
to do this in the Streamline configuration view. This situation is identified if you get an error that 

Streamline is unable to connect to gator. 
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Performance Analysis using Streamline  

ARM® Streamline™ is a graphical performance analysis tool. Combining a Linux kernel driver, target daemon, and 

an Eclipse-based user interface, it transforms sampled data and system trace into reports that present the data in 
both visual and statistical forms. ARM Streamline uses hardware performance counters along with kernel metrics 
to provide an accurate representation of system resource use. 

 

Introduction to Streamline 

The ARM Streamline product uses sample based techniques to capture system and application data for analysis. 

The data is then analysed by the DS-5 Eclipse Streamline plug-in and presented as a report. 

  

The kernel driver (called gator.ko) together with a daemon running on the target (called gatord) captures the 
data and sends it over the network to the host PC for analysis. The kernel module must be built against the Linux 
kernel in use on the target. 
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Preparation 

For the purpose of this workshop we are going to use an application called Threads. It is a fairly simple example 
which generates a few threads to run on the target. Import the Threads example now:   

Remote Systems must be operating for this exercise in order to copy files into the Linux filesystem. 

Go to File -> Import...  -> General -> Existing Projects into Workspace -> Next 

Select Select archive file: then press Browse... next to it.   

In the File dialog navigate to C:\altera\15.0\embedded\ds-5\examples\ and select Linux_examples.zip. 

 

The Projects field populates with all the example projects found in the .zip. It contains a number of examples that 

can be used to demonstrate Linux application debug and Streamline performance analyses. Each example is 
supplied with a Readme and demonstration instructions. Some of the examples like Xaos and Gnometris require 
graphics libraries to be installed on the target 

For this part of the workbook, we only need the Threads example, so press Deselect All, then select only  

threads and click Finish.   

 Next rebuild the example by clicking on the name of the project  in the Project Explorer. 

 Select Project -> Build Project. If Build Project is grayed out, then the project is up to date. 

 Click on the Remote Systems tab and drag it to another pane so it and Project Explorer are separated.  

 From the threads folder in the Project Explorer, copy the binary threads_hardfp by dragging it to the 

/home/root folder in the Remote Systems view (center view below).  You can also copy and paste. 

  We also need to copy the gatord binary to the target. Select Help -> ARM Extras , open the folder gator 

and drag the gatord binary into the /home/root folder in the Remote Systems view as shown below: 

 

In the Terminal 1 view: 

 Type ls and press Enter and you must see both gatord and threads_hardfp listed as shown below. 

 Type chmod +x gatord and Enter. 

 Type chmod +x threads_hardfp and Enter. This is to give the execute permission to these files. 

 Type ./gatord &  and Enter to start gatord and send the process to the background. 

 Type ps and Enter and you will see gatord running: all shown below: 

 

 



 

In the next section we will setup the Streamline 

target settings.  
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Setting up Capture Options 

If it’s not already open, open the Streamline Data view: 

 Select Window -> Show View -> Streamline Data. 

Streamline data and reports are shown in the Streamline Data view.  It will be empty, unless a previous profiling 
session has been run, in which case saved captures and reports may be present in the view.  You can select any 

existing captures and reports and click the Delete button ( ) to get rid of them.  You can get help by clicking the 

Show Help button ( ). 

The Streamline Data view has an Address field for specifying the IP address of the target (shown above), a 

Start Capture button ( ), a Counter Configuration button ( ) and a Change Capture Options button ( ) 

 Enter the Altera target IP address as shown above right screen that you obtained with ifconfig before. 

 Click the Capture Options button ( ):  This view opens up: 

    

 The Address field will be set to the IP address of the target.  This must be set to the target IP address. 

 You can select Sampling Rate as Normal (1000 samples per second), Low (100 samples per second) or 

None (no sampling). We’ll use Normal which is the default. 

 You can set Buffer Mode to Streaming, Large, Medium or Small. In Streaming mode the captured 

data is regularly streamed from the target over the network to the host PC. It may skew the performance of 

any network critical applications. If Buffer Mode is Large (16MB), Medium (4MB) or Small (1MB), the data 
will be captured to a buffer allocated on the target. The profile session will be stopped when the buffer is filled 
up. Then data will then be passed to the host in one go. By default buffer mode is set to Streaming. 

You can use the Duration field to a maximum length of time to capture data in seconds or 

minutes:seconds.  By default Streamline will capture data until you click the Stop button which we’ll see later. 

If Call Stack Unwinding is checked and the program has been compiled with frame pointers in ARM state 

then Streamline will be able to capture information about call paths, call graphs and stack usage threads is 
built this way, so leave Call Stack Unwinding checked. 

The Analysis section lets you specify whether Streamline should Process Debug Information. This will allow you to 
use Streamline to view source code. The High Resolution Timeline option enables you to zoom in more levels in 
the timeline (for example context switching).  These checkboxes only control the defaults for the first report; they 
do not change the captured data. 

 In the Program Images section, click the Add ELF image from Workspace... (second) button ( ) and 

choose the threads_hardfp binary with debug information (not from the Stripped folder) in the workspace 

from the /threads project folder. The symbols button ( ) next to the binary name indicates that debug 
symbols will be loaded for that binary.  The screen below: 

 Using Add Elf Image  (first button), navigate to C:\00Linux\linux-sockit-gsrd-14.1-bin\ and open 

vmlinux  to add it to Program Images.  

 Using Add Elf Image  (first button), navigate to 

C:\00Linux\linux\gator\ and add the two .ko files. 

 Click Save to save the capture options.   
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TIP: You can use the Export... and Import... buttons to save and 
load favourite configurations to and from files. 

Configuring the Counters 

Advanced ARM processors have a performance monitor unit (PMU) in 
hardware.  Exactly which events can be counted and how many 

events can be counted at once depends on which ARM processor is 
being used. The operating system allows access the performance 
counters for debug and profiling purposes. The Cortex-A9 in the 

Cyclone V has 6 configurable event counters. 

Streamline defaults to capturing data from various counters in the 
PMU, kernel and L2 cache controller, depending on the target’s 

hardware and kernel. 

 Click the Counter configuration button ( ) to open the 

Counter Configuration dialog where you can examine and 

change the counters that you wish to capture. 

You can hover your mouse over a counter to see a description of the 

event being counted. 

You can add counters by dragging them from the Available Events 
list to the Events to Collect list.  To see the Linux kernel and L2C-310 events you will need to scroll the Available 
Events list down.  You can remove events from the Events to Collect list, so that you can count something else, 

by selecting them and clicking the Delete button ( ).  The order in the Events to Collect list is fixed.  We will 

see later how to reorder the display of the Timeline charts in the report.  

 You can delete the Disk IO: counters since they are not very interesting in this example.  But leaving them 

in the list won’t hurt either. 

 Click Save to save the counter configuration.  The counter configuration is saved on the target. 

You can use the Export ( ) and Import ( ) buttons to save and restore your favorite counter configurations. 

If you have your own hardware or software counters (for example, number of packets processed) you can modify 
the gator software and use Streamline to capture and to display charts of your own custom counters.  The 

counters of the L2C-310 cache controller are a good example to start from. You must create a new Linux kernel. 

 

Capturing profile data 

 Click the start capture button ( ) to collect data from the target. 

You are now prompted to specify the name and location of the capture 
file where the profile data is stored on the host.  By default it will be in 
the directory ...\My Documents\Streamline. 

You can change the file name, for an instance we are profiling the 
Threads application, I used Threads_C01.apc.  The C01 indicates that it is the first capture. When you save 
the file, a new capture session will appear in Streamline Data view. The spinning wheel next to the button 
indicates that data is being captured from the target and the elapsed time of the capture is shown. 

 

Once the capture starts a Live view will appear showing you the activity on the target in real time. This is helpful 

to spot certain behaviour and stop the profile to inspect. The Live view shows activity on the counters that you 
selected as well as a list of currently running processes and their CPU and memory usage. 

IF Get an ERROR:  If you get an error saying gatord cannot be connected, the most usual cause is the wrong IP 
address as described at the top of the previous page. This happens if the SoCKit has been rebooted and the IP 
address is changed. Another cause is gatord is not in the correct folder or the execute permission is not set. 

Next start the threads application on the target. The duration the application executes is rather short, so let’s 
create a loop to run continuously.

 In the Terminal 1 view, start the Threads application, and put it in a loop. You will see this program 

executing in Terminal 1. 

$ root@socfpga_cyclone5:~# while true; do ./threads_hardfp; sleep 0.2; done; 

 After 10 or 15 seconds, Click the stop  button in the Capture view.   

 In Terminal 1, use CTRL+C to break out of the while loop and stop threads_hardfp from running. 

A report will now be generated for you to inspect. 
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Examining the Report 

Timeline view 

When the analysis is finished, the report view will open with a name determined by the capture’s name, for 

example Threads_C01. The report should open by default, but if not double click the report in the  

 The report will be in a tab listed Capture_xx.    Double-click on this tab to maximize it. 

All of the Streamline views can be exported to text files by using the Export button  except for the Code view. 

 

 

The Timeline view in Heat Map mode  is the first view presented when a report is opened. It 
displays information to give an overall view of the system performance. The graphs and percentages in your report 
may be different than the ones shown here depending on how long you captured data for. 

 

The top section of the Timeline view, below the time ruler, shows the system performance charts.  Streamline 
captures performance data from the hardware and operating system, and displays the samples or “snapshots” of 
the chosen counters in the system performance charts.  The order of the charts can be rearranged by dragging 

them by the gray legend area at the left end up or down.  Just to the right of the legend is an indication of the full 
vertical scale of each chart (for example, ).  You can get help on any of the charts by clicking the Help 

button ( ) in the top left of the Timeline view and select Timeline view charts. 

Above the time ruler are the buttons and the Timeline overview.  The Timeline overview shows the current zoom 

level as a drop-down menu ( ).  The large time in the center shows the time of the current mouse position 
as you move the mouse.  The Timeline overview also shows the length of the capture after the L and the number 
of processes after the P.  Along the bottom of the Timeline overview is a bar 
that represents the entire capture.  Clicking on the bottom bar will jump scroll 

the Timeline to that point 

 Click one of the data areas and a cursor with additional information appears as on the screen above right. 

 Click the zoom buttons ( ) to zoom in and out one level at a time (by a factor of 2 or 2.5).  You 

can also use the drop-down menu ( ) in the Timeline overview to change the zoom. 
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By default the finest resolution is 1 ms. If you use the High Resolution Timeline option when doing the analysis 
the finest resolution is 1 µs. You can also zoom in and out by typing I or + and O or -. 

Between the charts and process list is the cross-section thumb bar ( ).  If the cross-section 

thumb bar is at the bottom of the view, you won’t be able to see any processes. 

You can drag the cross-section thumb bar up and down ( ) to adjust how many charts and 
processes are shown.  You can grab the end of the thumb bar to 

change its width. 

By default the process list shows a “heat map” coloured by CPU 
Activity in red, orange and yellow. Red indicates that this is a “hot 
spot” i.e. an area where a lot of time was spent during the execution. 
These are typically the parts of the code which one would inspect and 

look to optimize first. 

If a process has multiple threads it will have an expansion triangle to 
the left of the process name that will toggle between showing the 
individual threads and the aggregate of all the threads.  You can see 

the context switches where one process or thread stops running and 

another starts.  

Process/thread contention is shown by  in the process list.  This is 

when a process or thread is runnable but other threads are using all of 
the cores, Contention is also shown in the CPU Wait/Contention chart. 
You are not likely to see this effect in the threads example program. 

 Click on the legend area of the threads process. 

The process will become selected and the CPU Activity chart will adjust to show the load caused by just the 
threads process.  You can see the original values of the CPU Activity chart as “ghosts”. 

 Click on the legend area of the process again to deselect it. 

If the target has multiple cores, you can click the toggle Map button 

( ) to select on Core mode which changes the colouring of the 

processes and threads to show which core they executed on.  There 
is a legend at the bottom left of the view to show which core is which 

color ( ).  Hovering over a coloured process bar will also 

show which core was active in a tooltip. You can also change the 
mode by pressing H or C or P. 

 

 You can also view the Processes list. This is similar to the list you were shown in the Live view 

Note:  for this exercise we do not have the correct version of gator.ko to show this feature completely. 

Let’s find out more about where the time is being spent: 

 Zoom into an area where you can see switching activity for one of the threads instances 

 Show the Samples HUD (heads up display) by 

clicking the Samples HUD button ( ) or typing S. 

 

The Samples HUD displays a coloured histogram of where 
time was spent in the selected cross-section.  If you have 
supplied debug symbols for the sampled functions then the 

function names will appear in the Samples HUD.  

For samples without symbols then the name of the process 
or shared library will be shown surrounded in square 
brackets [] to indicate that the time was spent inside some 

unknown function. 

 Click on the Timeline anywhere under the ruler and 

to the right of the labels to change the selected cross-
section being inspected. The entries in the Samples HUD 

will change accordingly. 
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The initial width of the cross-section is determined by the current zoom level.  The time of the beginning of the 

cross-section is shown in the “thumb” of the cross-section bar ( ).  You can move the cross-

section by dragging the thumb right and left and by typing the right and left arrow keys.  You can grow the cross-
section by dragging the right or left edge of the cross-section thumb.  The duration of the cross-section is shown 

in square brackets ( ). 

At the top of the Timeline view, above the time ruler, is the caliper range ( ).  You can set the caliper 

range by dragging either end, or by right-clicking and choosing Set left caliper, Set right caliper or Reset 
calipers.  All of the samples outside the caliper range are ignored in all of the other views.  You can also reset the 

calipers to include all of the captured data by clicking the Reset calipers button ( ) at the top of the view. 

Streamline has an Annotate feature that allows the application or kernel to add timestamped text, images and 
bookmarks to the Streamline report at key points in your code.  These annotations are displayed in the Timeline 

and Log views. 

 Click on the accumulate function in the Samples HUD. This will take us into the Call Paths view

Call Paths view 

The Call Paths view displays the call 

paths taken by an application that 
were sampled. They are listed per 
process in the view. If you followed 
the previous steps it should look 
similar to the screenshot below. 
 

There are five columns in the view 
which display the time spent as per 
the total number of the samples taken 
in that function / process. 

 Self  – The sampled time 
spent in that function only and 

not in its children as a total of 
the samples in that process. 

 % Self – The sampled time spent in that function only and not in its children as a percentage of the 

samples in that process. 

 Process – The sampled time spent in that function and its children as a total of the samples in that the 

process.. 

 % Process  – The sampled time spent in that function and its children as a percentage of the samples in 

that the process. 

 Total  – The sampled time spent in that function as a total of the time of all processes. 

The percentages are color-coded based. Functions where a lot of time was spent are highlighted in red. 

For the Call Paths to work the code needs to be built with frame pointers enabled. This allows the Streamline’s 
gator daemon to reconstruct the call path taken by an application. In gcc the build argument is -fno-omit-

frame-pointer. The Call Graph and Stack views also require frame pointers. 

Functions view 

 Select the Functions tab at the top of 

your report. 

The Functions view displays a list of all the 

functions that were sampled during the profile 
session. The functions view is the quickest way 
to find which functions are your hot functions.  
If you’ve set the caliper range in the Timeline 
view then only the samples within the callipers 
will be reflected in the Functions view. 

 You can Shift- or Ctrl-click to select 

multiple functions to see a total count of 
the self time in the Totals panel in the top 

right of the view.  

The Instances column shows the number of times a function appears in separate call paths. 
 

Next let’s go investigate the code inside one of our hot functions; 
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Code view

 Right click on the accumulate 

function in the Functions view and choose 

Select in Code from the context menu. 

Now the accumulate function will be 
highlighted in blue in the Code view. 

(If the source file has not been found by 
default you can set a substitute path by 

pressing the ( ) button to link the file 
system path to the image path. This may 
happen if you used a pre-built copy of 

threads_hardfp instead of building it on your 
host or if the source files are in a different 
location now compared to when you built the 
application.) 

You could also rebuild the project on your 

own host to fix this problem. 

Lines in the source code where many samples 
were taken are highlighted in red. Lines of 
code that don’t have any percentages next to 

were not sampled at all in this profiling run. 
Profiling for longer periods of time or at a 
higher sampling rate may give a better 
resolution in the source code. 

You can also open up the disassembly for the code you are viewing. 

 Click the Toggle Asm button ( ) in the top left hand corner of the report.  

 You can select a line or lines of source code and the corresponding disassembly lines will be highlighted in 

the bottom. Vice versa, you can also make a selection in the disassembly pane and the source above will be 

highlighted, along with the other disassembly lines for that source line. 

Notice the 2 More indicator in the screenshot. It indicates that there are two more disassembly instructions 
highlighted above. It’s useful when compiler has moved the code out of order. You can click on the indicator to 
scroll them into view. 

 
This concludes our quick examination of Streamline.  There are many more features designed to help you optimize 
and debug your code. 
 

For more information please visit:  http://ds.arm.com/ds-5/optimize/ 
 
 
Creating gator files:  Your version of Linux or Android must have the kernel built with various menuconfig 

items configured.  Gator must then be compiled against the particular version of Linux or Android you are using.  
Here are some useful links describing this process: 
 

 

Required kernel configuration menu options: 

http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362176300479.html  

Building the gator daemon: 

http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362178383724.html  

Building the gator driver: 

http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362182605440.html  

Running gator on the target: 

http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362271364312.html  

   

http://ds.arm.com/ds-5/optimize/
http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362176300479.html
http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362178383724.html
http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362182605440.html
http://infocenter.arm.com/help/topic/com.arm.doc.dui0482t/ric1362271364312.html
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Importing Captures (optional exercise) 

Captured data can be copied to a different location or host and imported into Streamline. If you don’t have a 

target, there is a pre-captured report in the Xaos example project /xaos/Streamline that you can use instead of 
capturing your own. 

Import the Xaos project from the Linux_examples.zip archive  

 Click the Edit Locations... button ( ) to add the location ...\My 

Documents\DS-5 Workspace\xaos\Streamline to the Streamline 
Data view. 

 Create a report by double clicking the capture xaos-

multithreaded-VE-A15x2-A7x3-example and clicking Analyze. and 
then OK in the save report dialog. 

This report was generated on a Versatile Express TC2 board, which has a 
big.LITTLE Cortex-A15 Cortex-A7 processor.  

The Timeline view will contain more information than what we have seen today. You will be able to view the 

activity charts by Core as well as by cluster. It also includes 
annotations from the source code which you can see in the process 
list if you fold open the process to see its threads view. The 
annotations are from source code so we can get an idea of when 
certain functions are executed. 

We are also showing the framebuffer in the timeline. A copy of the 
framebuffer was taken every 100ms in this example. 

 

This can be handy to relate what is happening on the screen back 
to your source code. 

 

 



 Annotations are also shown in the Log view. You can double-click an annotation entry and you will be taken to 
the Timeline view and the cross-section marker will be set to the time of that annotation.  You can right-click on 
an entry and choose Select Process/Thread in Timeline or Select in Call Paths, which can be handy if you 
have many processes and threads creating annotations. 

 
 
 
 
 
 
 

 
 
 

 
 
 
 

 
 
 
 
 
 

 
 
In order to create annotations the application, libraries, kernel or kernel module code must be modified.  The 
Annotation features uses standard file IO to write to a virtual annotation file, /dev/gator/annotate.  Header 
files containing C style macros and Java classes are provided to annotate from both Java, C/C++ user space and 

also from kernel space. You can find the annotate header files by going to Help > ARM Extras… > gator > 
annotate.  To find out more about annotation see Help > Help Contents > ARM DS-5 Documentation > ARM 
Streamline > Annotate and the Log View 
 


