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1. Introduction
1.1 Overview
This workbook will introduce you to the template editor, a new feature of Adobe Experience Manager, that will
be introduced with version 6.2.
The template editor has following main capabilities:

•
•
•
•
•

compose templates out of available components
position the components of the template on a responsive grid
define how resultant pages created from the templates can be edited
pre-configure the editable components
manage the lifecycle of the templates

The big change introduced by the template editor is that creating and maintaining templates no longer has to be
a developer task, but a super-author group can have control over them. Developers are still required to setup
the environment and to create the components to be used, but this provides much more flexibility to the author
team in general, as changes to the templates don’t require anymore a development project or iteration.
Also, the template editor gives the super-author group much better control over what page authors are allowed
to edit or not. Typically, it allows them to unlock individual components for page authoring, which will make the
defined components mandatory on the resultant pages, while being editable. Or full freedom can be given to
page authors with an editable paragraph system, where they can then add to the pages any of the allowed
components.

1.2 Prerequisites
This workbook assumes that following software (or newer) has been installed on the machine:

• Java 7 or newer
• Adobe Experience Manager 6.2 or newer
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2. Getting Started
2.1. Hands on Adobe Experience Manager
Adobe Experience Manager can be started very simply by double-clicking on the quickstart JAR file, all that’s
needed is a “license.properties” file placed next to it.
Exercise 2.1.
‣ Double-click the “cq-quickstart-[…].jar” file
‣ Wait for it to start (which should take under a minute)
‣ When completed, a browser window should open with a Sign In screen (as in the screenshot below)
‣ Enter the following credential:
• User name: admin
• Password: admin
If
after
that a dialog prompts to “Configure Analytics & Targeting”, you can hit “Cancel” and “Don’t ask again”
‣

When starting for the first time, it will create a “crx-quickstart" folder to persist it’s storage. The first launch can
take a couple of minutes for everything to be setup, but subsequent launches shouldn’t take over a minute.
Should you inadvertently close the browser, you can always return to Adobe Experience Manger by accessing
following URL: localhost:4502
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2.2. Know your way around
Once signed in, the Adobe Experience Manager user interface is displayed.

1
3

2
5

4

Let’s have a quick look at its main features to be able to use it eﬃciently.
1.

Product Navigation
Click on the Experience Manager logo to access the product navigation.

2. Search
Quickly find and jump to the content and tools you need by typing type the name of the content or product
capability and select from the suggestions.
Pro tip: Use the “/” key to open the search.
3. Left Rail
Access additional product capabilities - such as Timeline and References.
4. Parent Hierarchy
Click on the title to quickly navigate towards the top of the hierarchy.
5. View Switcher
Click here to switch through the diﬀerent views.
Exercise 2.2.
‣ Hit the “/” key to enter the search
‣ Type “sit” and select the first suggestion “Go to Sites”
column view icon and switch to “Card View”
‣ On the top right, click the
With
the
mouse,
hover
the
“We.Retail”
card and click the
pencil icon
‣
to open the page (as shown on the right)
‣ If after loading the page a dialog introduces the concepts of page editing,
close it by clicking “Skip” and “Don’t show again” (it can always be reopened with
the
page information menu on the top left, choosing “Help”)
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2.3. Install the We.Retail reference website
We.Retail is the new reference implementation for Adobe Experience Manager. The “Welcome to We.Retail”
page that you are viewing features a link to download that reference implementation. Once installed, the
download page will be replaced with the actual We.Retail site.

In this lab, the We.Retail package has already been downloaded for you. All that is needed is to install it.
Exercise 2.3.1.
‣ In your first browser tab with the Sites admin, hit the “/” key to open the search
‣ Type “pack” and select the first suggestion: “Go to Tools > Deployment > Packages”
‣ Click the “Upload Package” button (as shown in the screenshot below)
‣ Click “Browse” and select the “we.retail.all-[…].zip” file and then hit “OK”
‣ On the new “we.retail.all[…]” package that appeared, click “Install”
‣ Confirm “Install” in the dialog that opens and wait for it to complete

Page 6 of 20

Adobe Experience Manager Template Editor

Refreshing the “Welcome to We.Retail” page should now show the full website, so let’s do that.
Exercise 2.3.2.
‣ Click the “Package Manager” logo to leave it
‣ Select the second browser tab again (which shows the “Download the package” link)
‣ Hit the refresh button of the browser (fist loading takes a minute as scripts will have to compile)
‣ If everything went well, you should now see the full website (as in the screenshot below)
‣ Optionally, you can browse the We.Retail website to discover some of it’s content
‣ When done, you can close that browser tab

Congratulations, you installed the We.Retail reference site on your instance! This site is a useful tool to
understand the features of Adobe Experience Manager and how they are recommended to be used and
implemented for a typical website.
In this lab, we will edit some templates for that website, using the components that were built for it.
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3. Create a simple template
Let’s start with creating a first template with a page header and footer, a title and a paragraph system where
page authors will be free to drop any allowed components.

3.1. Create an empty template
In this chapter, let’s navigate to the template admin and complete the wizard to create a new template for the
We.Retail website.
Exercise 3.1.
‣ Hit the “/” key to open the search
‣ Type “tem” and select the first suggestion: “Go to Tools > General > Templates”
‣ Open the “We.Retail” folder where you’ll see some existing templates
‣ Click the blue “Create” button (on the top right)
‣ Pick the “We.Retail Empty Page” template and hit “Next”
‣ Enter “Simple Template” as template title and hit “Create”
‣ On the Success message click “Open”
You now see a completely blank template, which we are going to fill to define how the pages created from it
should be composed out of the available components.
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3.2. Add structure components
Let’s start by adding the page header and footer, and a title component.
Exercise 3.2.
toggle side panel icon to show the component and asset finder
‣ Click the
Pull
down
the
drop-down entitled “All” and filter the components by the
‣
“We.Retail.Structure” group (as shown on the right)
‣ Drag a “We.Retail Page Header” component to the “Drag components here”
placeholder on the right
‣ The same way, drag a “We.Retail Page Footer” component below the header
‣ Now change the component group drop-down back to “All”
‣ In the “Filter” search field type “title” and hit enter
‣ Drag the “Title” component between the previously added ones
‣ In search field now type “layout” and hit enter
‣ Drag a “Layout Container” below the title
You should now have a template that looks as below:
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3.3. Make the layout container editable
In the template that we created, we don’t want the header and the footer to be editable on the resultant pages,
because what they display should be determined by their own logic, like building the top-level navigation from
the page tree.
Also the title component doesn’t necessarily need to be editable, as it will by default display the page title.
The layout container however needs to be made editable, or it will be a quite pointless in it’s current state.
To do so, we will have to unlock it and assign a content policy, so that it has a list of allowed components for
the resultant pages.
Exercise 3.3.
‣ Select the layout container by clicking on it’s placeholder which is located below the title component
‣ Click the lock icon of it’s toolbar to unlock it for the resultant pages
policy icon
‣ Still in the toolbar of the layout container, click the
In
the
“New
Policy”
drop-down
select
the
“We.Retail
Default”
policy
‣
‣ Validate by clicking the checkmark (on the top right of the popup dialog)
That’s it for the basics, you just created a new template in just a couple of clicks, which we can now start using.

3.4. Enable and use the template
We’ll have to first enable the template, so that it is made available to create new pages from it.
Exercise 3.4.1.
‣ Go back to the first browser tab, where the list of available templates are displayed
‣ On the “Simple Template” card, click on the three dots and select “Enable”
(as shown on the right)
‣ In the popup dialog, validate “Enable”
Now we can create a page from that template.
Exercise 3.4.2.
‣ Enter the search (hitting the “/” key)
‣ Go to Sites (typing “sit” and selecting the first suggestion)
‣ Navigate to “We.Retail” > “Language Masters” > “English” by clicking on the cards
‣ Click the blue “Create” button and select “Page”
‣ Select the “Simple Template” that we just enabled and hit “Next”
‣ Enter “Summit Lab” as title and hit “Create”
‣ On the Success message click “Open”
The newly created page just opened in a new tab, let’s go ahead and edit it.
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Exercise 3.4.3.
‣ In the toolbar, click on “Edit” (on the top right)
‣ See how none of the components in the template is editable, except for the layout container
plus icon
‣ Select the placeholder of the layout container and click the
edit icon, and type something
‣ Choose a “Text” component, select it, click the
Depending on how creative you were with the text, we should now have something that looks as below:

You just created a fresh new template and a page using it, how easy was that?
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4. Edit the template
Now that we got through the basics, let’s see what else can be done with templates.

4.1. Change the structure
Let’s see how editing the template structure will also be reflected on the pages that resulted from it.
Exercise 4.1.1
‣ Open again the “Simple Template” (which should still be in the third browser tab)
‣ From the component finder on the left, drag and drop a “Button” component between the layout container
and the page footer
configure icon
‣ Select the added button component and click the
Enter
a
button
label,
like
“Become
a
member”
‣
As the modification is done, let’s see how the resultant page now looks.
Exercise 4.1.2.
‣ Open the “Summit Lab” page (which should still be in the second browser tab)
‣ Reload the page in the browser
You can see that changes to the structure of a template aﬀect all pages that use it.

4.2. Add initial content
It is also possible to define initial content for a template, which will be copied over to newly created pages.
Exercise 4.2.1.
‣ Open the “Simple Template” (which should still be in the third browser tab)
‣ Switch to “Initial Content” mode by clicking on the down-arrow next to “Structure” (on the top right)
‣ From the components on the left, drag & drop three instances of “Category Teaser” to the layout container
‣ On the left, click on the assets icon
‣ Drag & drop an image on each of the category teaser component
configure icon
‣ Optionally, edit each category teaser by clicking the
typically, give it a “Button Label” and, in order for the label to appear, set “#” as dummy value for the link
Let’s see how a newly created page would now look.
Exercise 4.2.2.
‣ Open the Sites admin (which should still be in the first browser tab)
‣ Navigate under the “Summit Lab“ page, click “Create” and select “Page”
‣ Select the “Simple Template”, hit “Next” enter “Page One” as title, hit “Create” and “Open”
Notice that what we added to the initial content can be edited on the page.
Page 12 of 20

Adobe Experience Manager Template Editor

4.3. Define responsive layout
That’s all good, but the layout isn’t looking that nice yet, so let’s see how to improve that with the layout editor.
Exercise 4.3.1.
‣ Open the “Simple Template”
‣ Switch to “Layouting” mode by clicking on the down-arrow next to “Structure” (on the top right)
‣ Select each of the category teasers components and drag their side handle to a third of the page (4 columns)
The page should now look something like below (also displaying the columns shown when dragging a handle):

The rulers displayed above the page also allow to preview the layout for diﬀerent devices, and if needed to do
modifications of the layout per breakpoint. Previewing it for iPhone clearly shows that something must be done.
Exercise 4.3.2.
In the ruler of the mobile emulator (on the top), click on “iPhone”
Select each of the category teasers and resize them to take the full width (12 columns)
In the mobile emulator, now click on “iPad”
For that breakpoint, take only the first category teaser and resize it to the full width (12 columns)
Take the next two category teasers and resize them to take the half width (6 columns)

‣
‣
‣
‣
‣

See how switching between diﬀerent devices shows a diﬀerent layout for each of the three breakpoints.
Be benefit of defining the layout on the template is that it then doesn’t require to do that each individual page.
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4.4. Modify content policies
Some components come with a design configuration that allows to pre-configure their behavior on the resultant
pages. The content policies allow to assign such configuration to the selected component.
We already quickly used that feature to define what components the layout container should allow to be used
on the resultant pages. Now, let’s better understand how that works.
In a nutshell, the
content policy allows to link to a
design configuration. This allows to reuse the same
design configurations across diﬀerent templates. It is a powerful concept, but it also implies to take care not to
unintentionally modify content policies that might be used on other templates.
Exercise 4.4.
‣ Switch back to “Structure” mode
policy icon
‣ Select the layout container and click the
‣ Duplicate the current policy by clicking on the duplicate icon
‣ Name it “Summit Lab” and validate by clicking the top-right checkmark
design icon
‣ Select the layout container again and click the
Scroll
to
the
bottom
of
the
list
of
allowed
components
and unfold the “We.Retail” group and uncheck it,
‣
in order to control more precisely which components of this group to allow
‣ Unselect the first three components (“Articles List”, “Button”, “Carousel”) and hit “OK”
‣ Refresh the template
Notice how the list of allowed components on the layout container placeholder changed.
This can also be verified on the existing pages that we re created.
Two additional capabilities to note on that topic:
page information
• A content policy can also be assigned to the page component itself. To do so, open the
menu (on the top left) and select “Page Policy”. Once a content policy is assigned to the page component, a
“Page Design” entry is then available in the same menu. This allows for instance to load additional client-side
libraries on specific templates.
• Components of unlocked layout containers can also have a content policy. To do so, select their name listed
in the placeholder of the layout container. This policy then isn’t specific to a defined instance of the
component anymore, but general for all components of that type that will appear within that layout
container.
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4.5. A word of warning
Special care should be taken when editing templates that have been enabled (meaning that they are not in draft
anymore) as changes can aﬀect existing pages. Some changes can typically hide content on existing pages from
being displayed anymore, like when a an editable component is removed from the template.
So let’s understand the consequence of such changes.
Here’s a list of the diﬀerent operations that are possible on templates, and on how they aﬀect the related pages:
• Changes to the structure: they apply to the pages immediately (of course publication of the changed template
is still needed for visitors to see the changes)
• Changes to content policies and design configurations: they apply to the pages immediately on the pages
(likewise, publication of the changes is needed for visitors to see the changes)
• Changes to the initial content: they only apply to newly created pages
• Changes to the layout: depending on wether the modified component is part of structure or initial content,
they apply immediately, or only on newly created pages
Danger zone:

• Locking or unlocking components of enabled templates: this can have dangerous eﬀects when a template

isn’t a draft anymore, meaning that existing pages can already use it. Typically, newly unlocked components
will be missing on existing pages, and locking components that were editable will hide that content from
being displayed on the pages.

Therefore, Adobe Experience Manager will warn explicitly when changing the lock status of templates that aren't
drafts anymore.
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5. Mandatory editable components
One special capability of the template editor is that individual components can be unlocked, making them
mandatory on the resultant pages, but still editable.
Let’s see how we can use that with our existing template.

5.1. Duplicate template
Since it would be dangerous for the content of the pages we created to modify the lock status of the layout
container on our template, let’s duplicate that template to tweak it.
Exercise 5.1.
‣ Go back to the first browser tab with the site admin
‣ Navigate to Tools > General > Templates (for e.g. using the search)
‣ Open the “We.Retail” folder
‣ Select the “Simple Template” and in the top toolbar choose “Copy”
‣ Still in the upper toolbar, now choose “Paste”
‣ On the newly created “Simple Template” (the second card), click the
‣ As template title enter “Category Teasers”, hit “Save”, and then “Close”
pencil icon
‣ Open the template by clicking on it’s

view properties icon

5.2. Make components mandatory
Now let’s move the components out of the layout container to make them mandatory, then unlocking them
each to still have them editable.
Exercise 5.2.1
‣ Make sure to be in “Structure” mode
open lock icon to lock the component again
‣ Select the layout container and and hit the
‣ Drag and drop each category teaser components out of the layout container, placing them just below the title
‣ Select the layout container and click it’s delete icon
emulator (on the top left)
‣ In the toolbar, open the
Click
on
“iPad”
to
preview
the
page for tablets, and make sure that everything still looks right.
‣
If not, adjust the order by drag & dropping the full-width category teaser to the top again
‣ Go back to the “Desktop” breakpoint and close the emulator again
(If needed, reload the page in the browser for the placeholder to display properly)
‣ Select each of the category teaser components and click the lock icon to unlock them
The images of the category teasers will be hidden, which is normal, their content now belongs to the initial
content, and not to the structure anymore. You can switch to initial content if you wish to verify that everything
looks as expected.
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Now let’s create a page that uses that template.
Exercise 5.2.2
‣ Go back to the first browser tab, where the template admin is opened
‣ Make sure that the “Category Teasers” template is enabled
‣ Go to Sites admin (using the search or the global navigation)
‣ Navigate to the “We.Retail” > “Language Masters” > “English” > “Summit Lab” page
‣ Click “Create” and select “Page”
‣ Choose the new “Category Teasers” template and hit “Next”
‣ Enter “Page Two” as title and hit “Create” and choose “Open”
In “Edit” mode, notice how, each of the category teasers can be edited, but not moved or removed.
This technique allows to create templates with a strong control over the components to be used on the page.
It is of course also possible to combine the two techniques: to have a template with editable components, and
still have one (or multiple) editable layout containers, to allow specific components to be added to defined
places of the template.
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6. Developer topics
6.1. Understand the “conf ” structure
The template editor stores the templates and the content policies under the “conf " root node.
Let’s inspect how the “content” tree in the content repository relates to that “conf " structure.
Exercise 6.1.
‣ In the first tab hit “/”, in the search type “crx” and select the suggestion “Go to Tools > General > CRXDE Lite”
‣ In there, drill down to following path: /content/we-retail/language-masters/en/jcr:content
‣ In the “Properties” tab, double-click the “cq:template” property, select it’s value and copy it
‣ In the path field on the top, paste that value and hit enter
‣ Now inspect that tree and see how things relate as in the diagram shown below

CONTROLLER

CONTENT STRUCTURE

/content/my-site/my-page/
jcr:content/
cq:template = /conf/my-site/setttings/wcm/
templates/my-template

CONFIGURATION

TEMPLATES & CONTENT POLICIES

/conf/my-site/settings/wcm/
templates/
my-template/
structure/

par/my-component/
sling:resourceType =
my-site/components/my-component

jcr:content/
initial/
jcr:content/

VIEW

policies/

COMPONENTS

jcr:content/par/my-component/
cq:policy = my-site/components/
my-component/my-policy

/apps/my-site/components/
my-component/
my-component.html
logic.js

policies/
my-site/components/my-component/
default-policy/
my-policy/
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6.2. Setup the template editor
Certain things have to be prepared by a developer when setting up new site in order to be able to use the
template editor.
This is a list of what has to be prepared:

• The specific users allowed to edit components should be added to the “template-authors” group
• Under the “conf ” structure, a folder should be created that contains following “cq:Page” nodes:
• /conf/PROJECT-NAME/settings/wcm/templates
• /conf/PROJECT-NAME/settings/wcm/policies
• /conf/PROJECT-NAME/settings/wcm/template-types (optional)

• Project-specific template types can be created, which are templates of templates: their structure will be
duplicated to every new template created from them. Template types allow typically to define:
• The resource type of the page component
• The policy of the “root” node, which defines the components allowed in the template editor
• Optionally, the breakpoints for the responsive grid and setup of the mobile emulator
(this is optional, because that configuration could as well be defined on the root page of the site)

• If a custom page component is required, use the same logic as the We.Retail page component to get the page
content merged with the template structure. In particular look at following code:

/apps/we-retail/components/structure/page/partials/body.html

Make sure to look at the We.Retail reference site to understand how all these elements come together.

That’s it in a nutshell, thank you for your interest!
I hope that you enjoyed it, and that you will have the opportunity to use that great feature to make your
projects even more successful.
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