5. More Features

While the previous section covered the operations from loading a model file to basic model exploration, this section introduces some more advanced features.

5.1. Changing the layout

Besides the non-hierarchical layout used in the last section, the Simmune NetworkViewer provides a level and a radial layout of the network once the user has selected a complex species node defining the first level/center of the layout.

After switching to a level layout you may still move the nodes to make the final adjustment and explore the model (e.g. select a species or reaction) in the same way.

To better demonstrate the use of level and radial layout, in the following we show the layout using a much larger model (DictyTest.dbf), which contains 55 species, 193 complexes, and 118 reactions.

  1. Switch to a level layout

    Righ-click the complex species node "Receptor" and select "Put 'Receptor' in the first level" in the context menu to switch to a level layout where "Receptor" is in the first level. The other nodes are rearranged with respect to the their distances to the species node.

    Note

    When there exists multiple layouts, you may switch among them by either clicking the button on the tool bar, or selecting layout in menu [View]->[Switch to layout].

  2. Switch to a radial layout

    Right-click the complex species node "Receptor" and select "Put 'Receptor' at the center" to switch to a radial layout where "Receptor" is at the center of the network panel. The other nodes are rearranged with respect to their distances to the species node.

    After switching to a radial layout, several concentric gray dotted circles will show in the backgound to emphasize the difference in radius (distance from center node) among nodes. You may hide them by unchecking the item "Show circles in the background" in the context menu of the network panel. Species nodes are only allowed to move along the circle they reside to maintain an appropriate distance order among species nodes.

  3. Highlight hierarchy

    When you have a level layout or a radial layout of nodes, select "Highlight hierarchy..." from the context menu of the network panel. After adjusting the distance threshold in the spin box, the nodes with distances larger than the specified threshold will be grayed out.

5.2. Layout file

The Simmune NetworkViewer can save the current layout to a layout file, which can be loaded back later to generate the same layout.

  1. Save current layout as a file

    Click the "File" menu and select the "Save layout as..." menu item. When a file dialog prompts the user to choose a layout file, select a layout file or enter a new file name then click the "Save" button.

  2. Load layout from a file

    Click the "File" menu and select the "Load layout..." menu item. When a file dialog prompts the user to choose a layout file, select a layout file and click the "Open" button. The network panel will switch to the layout stored in the file.

    Note

    An error will occur when loading a layout file in incompatible format or one generated with a different model file.

5.3. Show distances from a node

The level and radial layout mentioned above use the hierarchy of nodes to implicitly show the distances of nodes from a complex species node. The Simmune NetworkViewer offers another way to explicitly show the distances as labels attached to nodes.

  1. Select "Show distances from 'Csk'" from the context menu

    Right-click the comoplex species node "Csk" in the network panel and selecte "Show distances from 'Csk'" from the context menu. A dialog will show up with controls to adjust distance threshold and select a different complex species node. The nodes that are close to "Csk" (e.g. nodes on the left) have red background color. On the other hand, the nodes that are distant from "Csk" (e.g. nodes on the right) have green background color. Click the "Clear" button to remove the distance labels.

  2. Adjust the distance threshold

    Adjust the threshold using the spin box. The number in the parenthesis after "max = " indicates the largest distance from the specified species node to other species nodes.

  3. Show distances from another complex species node

    Select a different complex species node from the combo box to show the distances from the selected complex species node to other complex species node.