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Synergy DBL Integration for Visual Studio (SDI) includes support for traditional Synergy development. 
This means you can use Visual Studio to develop traditional Synergy OLBs, ELBs, and DBRs for Windows, 
Linux, and OpenVMS desktop and server systems. 

For new traditional Synergy development in Visual Studio, you’ll simply start from one of the traditional 
Synergy project templates included with SDI. But what about existing traditional Synergy code? How do 
you move it into Visual Studio? There are two options:

 Use the syn2vs migration utility—You can use the syn2vs utility to move traditional Synergy
code that is in a Workbench project or workspace to Visual Studio. Syn2vs automatically creates a
Visual Studio solution with one or more traditional Synergy projects and adds the Synergy DBL
source files to the projects. See “Migrating your code with syn2vs” on page 3.

 Manually create and populate a Visual Studio solution—You can manually create a Visual Studio 
solution with traditional Synergy projects and then add Synergy code to the projects. See “Manually
creating a solution and projects” on page 5.

To move a traditional Synergy Linux or OpenVMS application to Visual Studio, use the second method 
(don’t use syn2vs). For information on limitations with Linux and OpenVMS development, see 
“Developing a traditional Synergy application” in the Synergy/DE documentation.

Note the following: 

 Strong prototyping takes place automatically at build time for all Synergy projects in Visual Studio.
If you aren’t already using strong prototyping, it may uncover issues with your code. These issues
will be reported as compiler errors in Visual Studio. Because this happens automatically, SYNIMPDIR 
and SYNEXPDIR are ignored in Visual Studio, and there is no way to set the -qimpdir compiler option 
or the -expdir option for dblproto. In Visual Studio, these settings are reserved for internal use by
the build system.

 Visual Studio does not support circular references, so if your code has circular references, you’ll need
to fix them or work around them by adding prototype-only references. This is discussed in “Running
syn2vs” on page 4 and “Manually creating a solution and projects” (step 7 on page 6).

 If you have been using gennet40 to generate Synergy classes, you can continue to use it. Add the
generated source files and the .inc file to a project, and set options that concatenate source files and
compile classes generated by gennet40. See step 4 on page 5 for more information.

 Visual Studio projects are not designed to work over network shares, so keep all files for Visual
Studio projects local. This includes repository and .INCLUDEd files. And because background
compilations occur continually for IntelliSense, IntelliSense is supported only when all project files
are local.

 You can improve performance by excluding certain SDI files and file locations from virus scanning.
See www.synergex.com/synergy-dbl-integration for more information.
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Getting help 
If you have questions or run into issues with a project conversion, contact Synergy/DE Developer 
Support so we can work through the migration process with you. 

Synergy/DE documentation includes information on Synergy development in Visual Studio. See 
“Synergy in Visual Studio” in the Synergy/DE documentation.

Preliminary steps
1. Install the latest versions of Synergy/DE and SDI. On a 64-bit system, you must install the 32-bit and 

64-bit versions of Synergy/DE before installing SDI. See the installation instructions that accompany 
your distribution, and see www.synergex.com/synergy-dbl-integration for information on system 
requirements.

2. Open Visual Studio and set options for Synergy files:

 To change text editor options for Synergy source files (e.g., alignment options that control 
indentation), use the Visual Studio Options dialog box. See “Options for Synergy/DE Projects” in 
the Synergy/DE documentation for more information.

 If your Visual Studio projects will include Synergy files with non-standard Synergy extensions, 
you’ll need to configure Visual Studio to recognize those extensions. (Standard file extensions 
for compiled files are .dbl and .dbc. Standard file extensions for content files are .def and .rec.) 
To configure Visual Studio to recognize a non-standard extension, specify the extension in the 
“Additional Compile File Extensions” field or the “Additional Content File Extensions” field in the 
IntelliSense dialog box in Visual Studio. See “IntelliSense, Text Editor Options” in the Synergy/DE 
documentation for more information.

Once you’ve installed SDI and set Visual Studio options, you’re ready to create a Visual Studio solution 
and projects by doing one of the following: 

 Use syn2vs to generate a Visual Studio solution and projects. See “Migrating your code with syn2vs” 
on page 3.

 Create a solution and projects manually and add traditional Synergy files to the projects. See 
“Manually creating a solution and projects” on page 5.
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Migrating your code with syn2vs
You can use the syn2vs utility to convert a Workbench project or workspace into a Visual Studio solution 
with traditional Synergy projects. The syn2vs utility is included in the SDI distribution; see “Running 
syn2vs” on page 4. Syn2vs accepts a Workbench workspace file (.vpw) or a Workbench project file 
(.vpj), and it generates a Visual Studio solution with one or more traditional Synergy projects that 
include the source files specified by the .vpw or .vpj file. 

If the information in the source (e.g., the Workbench project) is complete, the generated Visual Studio 
solution should be fairly complete. For example, syn2vs configures settings for environment variables 
set with the Workbench syn_set command, and it creates references that reflect Workbench link 
settings. Note, however, that syn2vs does nothing with environment variables set outside of 
Workbench. For example, if you rely on settings in synergy.ini and have a system-wide SFWINIPATH 
setting for it, you’ll need to configure this manually in Visual Studio. (See “Environment variables and 
Visual Studio development” in the Synergy/DE documentation for more information.)

1. Install SDI and set options for Synergy files in Visual Studio as described in “Preliminary steps” on 
page 2.

2. Run the syn2vs utility, specifying a .vpw or .vpj file as input. See “Running syn2vs” on page 4.

3. In Visual Studio, open the solution created by syn2vs, and set project settings for each project in the 
solution. Project settings include settings for building/compiling. See “Common project settings” 
and “Synergy/DE project properties” in the Synergy/DE documentation.

4. Build the Visual Studio solution by selecting Build > Rebuild Solution from the Visual Studio menu. 
(“Rebuild Solution” builds the entire solution even if some projects haven’t changed.) If you get 
errors, fix them and build again. See “Common errors and what to do about them” on page 8, and note 
the following: 

 If the application or library does not need to be built as x64, set the build to x86. If the project 
uses a 32-bit ActiveX control, you must use x86. 

 References can cause false warnings like the following. Ignore these.
C:\Program Files 
(x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1819,5): Warning 
MSB3246: Resolved file has a bad image, no metadata, or is otherwise 
inaccessible. Could not load file or assembly 'TKPDF.DBO' or one of its 
dependencies. An attempt was made to load a program with an incorrect format.

5. When the solution builds cleanly, build the solution in debug mode and debug it. See “Debugging 
traditional Synergy with Visual Studio” in the Synergy/DE documentation for more information.
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Running syn2vs
The syn2vs utility is in the SynergyDBLIntegration directory under the Extensions directory for Visual 
Studio (e.g., C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\
Synergex\ SynergyDBLIntegration). 

Syn2vs generally works best if you run it from the directory that contains the .vpw or .vpj file you are 
passing to syn2vs. (To make this easier, simply include syn2vs in your Windows PATH or set an 
environment variable to the location of syn2vs, and then use the environment variable to run syn2vs.) 
Syn2vs has the following syntax:

syn2vs in_file [-da]

where in_file is the path and filename for a .vpw or .vpj file. The optional -da setting causes syn2vs to 
resolve circular references (which are not supported in Visual Studio) by adding prototype-only 
references. For more information on these references, see “Creating a prototype-only reference” in the 
Synergy/DE documentation. (Circular references are not an issue with single-project solutions, so the 
-da option has no effect if you pass a .vpj file to syn2vs.)

There are two ways to use syn2vs:

 If you have a Workbench project that uses the Workbench build system, pass the workspace file 
(.vpw) to syn2vs. For example:
syn2vs c:\mydir\myworkspace.vpw -da

 If you have a Workbench project that does not use the Workbench build system, pass the project file 
(.vpj) to syn2vs. For example:
syn2vs c:\mydir\mywbproject.vpj

For best performance, all source files and resources should be local. If you use the -da option, the 
process could several minutes. (One large project we tested took 15 minutes.)

The resulting solution is generated to the folder that contains the .vpw or .vpj file used as input.
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Manually creating a solution and projects
To move the code for a traditional Synergy application into Visual Studio without using syn2vs, you will 
need to create and configure a Visual Studio project for each executable, each library, and optionally 
each repository. Once you’ve created a project, you can add code files, .INCLUDEd files, ISAM files, etc., to 
the project.

You’ll start by creating an empty Visual Studio solution for the application. You’ll then add the projects 
for the application to the solution. (All projects for an application should be in one solution.) For more 
information on Synergy projects and solutions in Visual Studio, see “Synergy files, projects, and 
solutions” in the Synergy/DE documentation.

It is important that you create projects in the correct order. Start by creating projects for repositories 
(this is optional; see step 4). Then create projects for the lowest-level libraries, followed by projects for 
higher-level libraries. Finally create a project for the mainline program(s) for the application. Make sure 
each project builds without errors before creating the next project.

The following steps outline the project creation process. See Visual Studio documentation for more 
information on Visual Studio features, and see “Developing a traditional Synergy application” in the 
Synergy/DE documentation for more information on this process, including information on limitations 
and requirements for Linux and OpenVMS development.

1. Install SDI and set options for Synergy files in Visual Studio as described in “Preliminary steps” on 
page 2. 

2. Open Visual Studio, open Solution Explorer in Visual Studio (select View > Solution Explorer from the 
Visual Studio menu), and then do one of the following:

 If you haven’t yet created a project for your application, create a new blank solution by doing the 
following: Make sure no solution is open in the current Visual Studio session, and then select 
File > New > Project from the Visual Studio menu. This opens the New Project dialog. In this 
dialog, select Installed > Other Project Types > Visual Studio Solutions > Blank Solution. Then 
specify a name, location, etc., for the new solution. Make sure “Create new solution” is selected 
for the Solution option, and then click OK. Leave the new solution open for the next step.

 If you have already created a project for your application, make sure the solution with that 
project is open in the current Visual Studio session before continuing (i.e., before creating 
another project in the solution). 

3. Select File > New Project from the Visual Studio menu. 

4. In the New Project dialog, select Installed > Synergy/DE, and then select one of the following project 
templates. For Linux and OpenVMS, use the same templates that you would use for a Windows 
application. (On OpenVMS, these project types emulate the libraries and executables that you will 
have on an OpenVMS system for the final, distributable build.) 

 Synergy/DE Repository. Use this to create a repository project. Repository projects make 
RPSMFIL and RPSTFIL settings unnecessary and enable the build system to know when a project 
should be rebuilt due to a repository change (a change to a schema file). You are not required to 
create projects for repositories, but it is generally recommended. See “Using Synergy/DE 
repositories in Visual Studio” in the Synergy/DE documentation for more information.

 Object Library (OLB). Use this to create a traditional Synergy object library (OLB) project, which 
can be referenced by another library project (ELB or OLB) or by the mainline project. 
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 Executable Library (ELB). Use this to create a collection of traditional Synergy routines that can 
be used in other traditional Synergy ELBs and DBRs. This project type produces an ELB from 
subroutines and functions defined in one or more source files. A project created with this 
template can reference other OLBs, other ELBs, and repository projects.

 Traditional Application (DBR). Use this to create a traditional Synergy program that consists of 
a single DBR. One source file defines the MAIN, others can define subroutines and functions. A 
project created with this template can reference ELBs, OLBs, and repository projects.

 Multiple Mainline (DBR). Use this to create a project that results in multiple traditional Synergy 
mainline programs—i.e., an application that is distributed as a number of DBRs that typically 
reference several common libraries. A project created with this template can reference ELBs, 
OLBs, and repository projects. 

See “Synergy/DE project templates” in the Synergy/DE documentation for more information on 
these project types, and note the following: 

 You can build an ELB directly from an OLB. To do this, open the ELB project and add a reference 
to the OLB project. Then remove any source files from the ELB project. When the ELB project is 
built, it will be built from the OLB project sources.

 When creating a library for shared code, use an ELB rather than an OLB. An OLB project should 
be referenced by only one project in the solution. (Referencing an OLB project from multiple 
projects causes the OLB code to be compiled into multiple files for the application.)

 If your application uses files generated by gennet40, create a separate ELB or OLB project for 
these files, add the source files and the .inc file generated by gennet40 to this project, and 
reference this project from your mainline (DBR) project (in step 7 below). Then, in step 8, set the 
“Concat source files (-qconcat)” option and the :interop option on the Compile page of project 
designer before building the project. See “Compile Page, Project Designer (traditional Synergy)” 
in the Synergy/DE documentation for more information on these options. 

5. Set options for the project (name, location, and so forth) in the New Project dialog, make sure the 
“Solution” option is set to “Add to solution”, and then click OK to create the project. 

6. Add Synergy DBL code files and other items (e.g., .INCLUDEd files and ISAM files) required for the 
project. Note the following:

 To add an item, right-click the project node in Solution Explorer and select Add > Existing Item or 
Add > Reference Existing Item from the context menu, and select the code file in the Add Existing 
Item window. Add > Existing Item copies the file into the Visual Studio project. Add > Reference 
Existing Item adds a relative-path reference to the item.

 By default, files with the .dbl or .dbc extension are compilable Synergy files, and files with the 
.def or .rec extension are Synergy content (non-compilable) files. You can change the behavior 
for a specific file by changing file properties, and you can add more extensions to the list of 
compilable and content files. See “File types and build actions” in the Synergy/DE 
documentation for more information.

 .INCLUDEd files must be content files. 

7. Add references to your project. A reference enables a project to use code in another project (an ELB 
or OLB project), the definitions in a repository project, or an external file. Referencing a library is 
equivalent to linking to a library (i.e., adding a library to a dblink command) when developing 
outside of Visual Studio. You can add a reference by right-clicking the Reference node in Solution 
explorer and selecting Add Reference from the context menu.
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For example, if you’ve created a project for the application’s low-level libraries, and now you’re 
creating a project for a higher-level library that uses routines in the low-level libraries, the 
higher-level library will need to include references to the low-level libraries. 

Note the following: 

 Circular references (two libraries that reference each other) are not supported by Visual Studio. 
If your traditional Synergy code has a circular reference, you will need to either remove it by 
rewriting code or work around it by creating a prototype-only reference. See “Creating a 
prototype-only reference” in the Synergy/DE documentation.

 To reference an ELB or OLB, reference its Visual Studio project when possible, not just the ELB or 
OLB file. (If you reference an ELB or OLB file rather than its project, there will be no IntelliSense or 
prototypes for that ELB or OLB.) If you reference an ELB project, make sure you set the output 
path correctly for the ELB. See “Referencing ELBs and OLBs” in the Synergy/DE documentation 
for more information, and note that the Synergy tab of the Reference Manager dialog enables 
you to easily add a reference to an ELB or OLB in a location specified by an environment variable. 

 If code for OpenVMS includes DBL$ or SYS$ routines, the Visual Studio project with that code 
must reference the VmsCompatibility library to be able to run on Windows. This library enables 
IntelliSense to work for those routines, it will enable the code to be compiled, and it may enable 
the code to run on Windows. You may also be able to do some preliminary debugging on 
Windows. Some routines in this library are stubs, however, so if your code includes one of these 
routines, you will not be able to run or debug the program on Windows.

 If the project uses a repository project, you must add a reference to the repository project. 
(RPSMFIL and RPSTFIL settings do not work for repository projects.) For information on adding 
dependencies or references for Synergy/DE repositories, see “Using Synergy/DE repositories in 
Visual Studio” in the Synergy/DE documentation. 

8. Set project properties, which include settings for building/compiling. See “Common project 
settings” in the Synergy/DE documentation for a summary of commonly-used project properties, 
and note the following:

 For Linux and OpenVMS, you must select a Linux or OpenVMS platform target (select linux32, 
linux64, or vms as the “Platform target” on the Build page of Project Designer), or add a 
configuration that targets Linux or OpenVMS. See “Adding a platform configuration for Linux or 
OpenVMS” in the Synergy/DE documentation for more information. 

 If the application or library does not need to be built as x64, set the build to x86. If the project 
uses UI Toolkit or has a 32-bit ActiveX control, you must use x86. 

9. Set environment variables needed for developing and running. See “Environment variables and 
Visual Studio development” in the Synergy/DE documentation for information on where you can set 
environment variables, when they are used, and precedence for different locations. 

 If your project uses repositories that aren’t in repository projects, you’ll need to set RPSMFIL and 
RPSTFIL. See “Using repositories that don’t have projects” in the Synergy/DE documentation.

 For Linux development, make sure that case is correct for environment variable names and 
settings (paths, etc.).
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10. Build the project by selecting the project in Solution Explorer and selecting Select Build > 
Rebuild project_name from the Visual Studio menu. If you get errors, fix them and build again. See 
“Common errors and what to do about them” below for more information. Note that references 
cause false warnings like the following. Ignore these.

C:\Program Files 
(x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1819,5): Warning 
MSB3246: Resolved file has a bad image, no metadata, or is otherwise inaccessible. 
Could not load file or assembly 'TKPDF.DBO' or one of its dependencies. An attempt 
was made to load a program with an incorrect format.

11. Repeat step 2 through step 10 for each project that will be part of the solution.

12. In Solution Explorer, right-click the node for the mainline project (the project for the DBR), and select 
“Set as StartUp Project” from the context menu.

13. When all the projects have been added to the solution and they all build separately without errors, 
rebuild the entire Visual Studio solution (select Build > Rebuild Solution from the Visual Studio 
menu). If the build results in errors, fix them. See “Common errors and what to do about them” 
below.

14. Build your application in debug mode, and then debug your application by selecting a Visual Studio 
debugging command (e.g., Debug > Start Debugging). 

 For a Linux application, you’ll need to run the application on a Linux machine and then use 
remote debugging to debug the application from Visual Studio or use standard traditional 
Synergy debugging on the Linux machine. 

 For an OpenVMS application, you may be able to do preliminary debugging with files built on 
Windows, but for full debugging you’ll need to run the application on an OpenVMS machine 
and then use remote debugging to debug the application from Visual Studio or use standard 
traditional Synergy debugging on the OpenVMS machine.

For more information on debugging traditional Synergy projects and solutions, see “Debugging 
traditional Synergy with Visual Studio” in the Synergy/DE documentation.

Common errors and what to do about them
It is generally best to fix underlying code issues that cause errors, but the following discuss some 
alternatives. Note that in the following, options preceded by a colon (e.g., :param) are -qrelaxed options 
set on the Compile page of Project designer.

 %DBL-E-TYPPARM (Type mismatch for parameter parameter_name in routine routine_name)

You can use :param to allow an A to be passed to an output N parameter, or use :paramad to 
generate a warning (rather than an error) if an A is passed to input parameter or to a D parameter 
with an unspecified direction. 

 %DBL-E-MOREARGS (More argument values than declared parameters in routine routine_name)

If the mismatch is intentional, add the VARARGS modifier to the routine.

 %DBL-E-PROTOMISMCH (Routine_name does not match prototype)

This typically occurs when a return type isn’t explicitly declared for a function. You can use :extf to 
prevent the compiler from checking external function declarations against function return types. 
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 %DBL-E-TOKUDF (Symbol symbol already uniquely defined) 

This occurs when there are different data structures with the same name in different files, or 
different routines with the same name in different ELBs. You can use :allowdup to allow duplicate 
structures in a namespace and duplicate routines imported from prototypes. See Synergex 
KnowledgeBase article 100002233 for more information.

 %DBL-E-NFND (Identifier not found)
%DBL-E-NVTF (Cannot resolve type for field field) 
%DBL-E-NVTP (Cannot resolve type for parameter parameter)
%DBL-E-NVTPR (Cannot resolve type for property property)

These errors can occur when an import statement is required where it wasn’t with previous versions 
of Synergy/DE. In version 10.3.3, we made a number of improvements to dblproto (which is used 
behind the scenes when a Synergy project is built in Visual Studio). Previously, any namespace 
defined in a compilation unit was available to all source files in that compilation unit. Now, a 
namespace defined in a file is available only to that file unless it is explicitly imported (with IMPORT) 
to other files in the compilation unit. If your code relies on the old behavior, you will now get one or 
more of these compilation errors. To correct this, add IMPORT statements to your code. Visual 
Studio makes it easy to add an IMPORT statement: click the type that caused the error, press 
CTRL + . (period), and then select one of the suggestions offered in the drop-down list. 

See “Understanding Synergy DBL errors” in the Synergy/DE documentation for more information.

Setting link priority
You can control the link order for referenced items for a traditional Synergy program by setting priority 
levels for these items. The higher the setting, the closer the library will be to the end of the link 
command generated behind the scenes for a build—i.e., the higher the priority. If a project has a 
reference to two libraries that have definitions for entities with the same name, the definition in the 
library with the higher priority setting will be used. For example, you can use this feature to patch or 
replace an ELB by including an ELB that contains only stub routines in your build, giving this ELB the 
highest priority level, and then later distributing an ELB with the same name, but with implemented 
routines. See “Setting link priority for traditional Synergy in Visual Studio” in the Synergy/DE 
documentation for more information.
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