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Before attempting to connect, operate or adjust this product,
please save and read the User Manual completely. The style of
the product shown in this User Manual may be different from
the actual unit due to various models.

Safety Instructions

Always read the safety instructions carefully:
e Keep this User Manual for future references.
o Keep this equipment away from humidity.
o If any of the following situation arises, get the
equipment checked by a service technician:
- The equipment has been exposed to moisture.
- The equipment has been dropped and damaged.
- The equipment has obvious sign of breakage.
- The equipment has not been working well or cannot
get it to work according to the User Manual.

Copyright

This document contains proprietary information protected
by copyright. All rights reserved. No part of this manual
may be reproduced by any mechanical, electronic or other

means, in any form, without prior written permission of the
manufacturer.

Trademarks

All trademarks and registered trademarks are the property
of their respective owners or companies.



Regulatory Compliance
FCC Conditions

This equipment has been tested and found to comply with
Part 15 Class B of the FCC Rules. Operation is subject to the
following two conditions: (1) This device may not cause
harmful interference. (2) This device must accept any
interference received and include interference that may
cause undesired operation.

CE

This equipment is in compliance with the requirements of
the following regulations: EN 55 022: CLASS B

WEEE Information

For EU (European Union) member users: According to the
WEEE (Waste electrical and electronic equipment)
Directive, do not dispose of this product as household
waste or commercial waste. Waste electrical and electronic
equipment should be appropriately collected and recycled
as required by practices established for your country. For
information on recycling of this product, please contact
your local authorities, your household waste disposal
service or the shop where you purchased the product.

FECEE



Introduction

The USB-C Docking Station is designed for extra
connectivity demands and supports DP 1.4 output. With
the docking station, you can extend the connection of a
computer to more USB peripherals, Ethernet network, the
combo audio via USB-C interface. Feel free to plug in
upside down for USB-C plug is reversible. Adopting PD
Charging technology, upstream charging function through
USB-C interface, you can charge the host up to 85W with
higher than 100Watts power adapter or automatically
adjust to lower charging power with smaller power
adapter. With the built-in USB 3.1 ports, the docking
station enables you to enjoy the super speed data
transmission between USB peripherals.

. Incorporates HDMI® technology.



Features

e USB-C Input
- USB-C3.1Gen 2 port
- Upstream PD powered, supports up to 85W
- Supports VESA USB Type-C DisplayPort Alt mode
e Downstream Output
- 2xUSB-A 3.1 Gen 2 ports (5V/0.9A)
- 1xUSB-A 3.1 Gen 2 port with BC 1.2 CDP
(5V/1.5A) and DCP and Apple Charge 2.4A
e Video output
- DP 1.4++x 2 and HDMI 2.0 x1
- DP 1.2 HBR2: 1x 4K30, 2x FHD60, 3x FHD30
- DP 1.4 HBR3: 1x 4K60, 2x QHD60, 3x FHD60
- DP 1.4 HBR3 DSC: 1x 5K60, 2x 4K60, 3x 4K30
e Supports audio 2.1 channel
e Supports Gigabit Ethernet



Package Contents

e USB-C Docking Station
e USB-C Cable

e Power Adapter

e User Manual

System Requirements

e Windows 10
e Mac 0S



Product Overview

Front

Item

1. Power Button Switch to power on/off

2. Combo Audio Port  Connect to a headset

3. USB-C Port Connect to USB-C devices

4. USB-A Port Connect to USB-A devices with BC 1.2
charging & Apple Charge

5. Kensington Security Secure your device safely
Slot




Rear

Item Description

5. Power jack Connect to the power adapter
6. USB-C Port Connect to the USB-C port of a
computer

7. DisplayPort (x2) Connect to DP monitors

8. HDMI port Connect to an HDMI monitor

9. RJ-45 port Connect to Ethernet
10. USB-A Port (x2) Connect to USB devices




Connection

To connect the USB peripherals, Ethernet, speaker and
microphone, follow the illustrations below to connect the
corresponding connectors.

8
= Ethemet

HDMI 2.0/

Y o 020

e your lapiop USB-A3.1 Gen 2

Speaker &
Mictoghone
& R

USB-A3.1 Gen 2
Support BC 12&
Apple charge

&

K-Lock secure
USB-C31Gen2 your device safety




How to Enable Dual & Triple Extended
Display?

®

NOTE:

The screenshots might vary slightly with the
operating system.

The NB will keep your previous display settings
every time you power on/off it.

You may reset up the display settings if you
change the monitor.

Always check your NB display settings and set up
in Extended Mode.

Some of 4K monitor will occupy entire 4K
bandwidth and cause 3™ display non-function.




1. How to Enable Dual
Extended Display?

1.1 If monitors are FHD
|_|D
1080p @60

— —
Resolution (Monitor)
= om0

Step
1.  Connect DP+DP or DP+HDMI to the monitor.
2. The monitor shows up connected.
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3.  Setyour NB as Extended Mode

gm Duplicate

AR e

m Second screen only

4.  In desktop mode, right-click the Desktop and
select Graphics Properties.

View >
Sort by 4
Refresh

Paste

Paste shortcut

=] ' Graphics Properties...

%4 Graphics Options »
New »

B8 Screen resolution

& Ppersonalize
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5.  Click Display setting.

Intel® HD Graphics Control Panel

6.  Inthe Multiple Displays, click Identify your
monitors.

) Graphics Control Panel
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7.  Inthe General Settings, adjust the extended
monitor resolution to 1920 x 1080, refresh rate
60Hz, and click Apply to save your settings.

I
\)‘ Note: The Primary Display default is NB screen, 2 & 3
should be extended monitor.
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1.2 If monitors are 4K

A. 4K Monitor: 1080@60 downgradable

Resolution (NB)

bl Se—i 1080p @60

il il
Resolution (Monitor)
F===N o - - - e

Step
1.  Connect DP+DP or DP+HDMI to the monitor.
2. Setyour NB as Extended Mode.

gm Duplicate

ABT s

E Second screen only
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3. The 4K monitor downgrades automatically the
resolution to 1080p@60.

B. 4K Monitor: 4K@30 fixed resolution, not downgradable

Resolution (NB)

b 4 1080p@60

—. Resolution (Monitor)

4K@30 X
b D o0 500x600

1080p@60 1080p@60
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Step
1.  Connect one video port to the monitor.
2. Setyour NB as Extended Mode.

gm Duplicate

AR e

m Second screen only

3. The 4K monitor default resolution has been set as
3840 x 2160, refresh rate 30Hz.

4. Connect your second monitor to the docking
station, it may result to the following situations:

NOTE:

. The second monitor doesn't work.

. The monitor downgrades the resolution to
800 x 600 automatically.
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5.

In desktop mode, right-click the Desktop and
select Graphics Properties.

Be.

B @

View
Sort by
Refresh

Paste
Paste shortcut

[ Graphics Properties...

Graphics Options
New

Screen resolution

Personalize
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6.  Click Display setting.

Intel® HD Graphics Control Panel

7.  Inthe Multiple Displays, click Identify your
monitors.
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8. Inthe General Settings, adjust the extended
monitor resolution to 1920 x 1080, refresh rate
60Hz, and click Apply to save your settings.

Intel® HD Gi
@® Display

o
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2. How to Enable Triple
Extended Display?

2.1 If monitors are FHD

[SIS][8]

—a

Step

1.  Connect all video ports to monitor. Only two of the
three monitors are working.
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2. In desktop mode, right-click the Desktop and
select Graphics Properties.

View >
Sort by »
Refresh

Paste

Paste shortcut

=] . Graphics Properties...
3 Graphics Options »
New >

B8 Screen resolution

& Personalize

3.  Click Display setting.
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4-1. Click Identify your monitors.
4-2. Click the Primary Display drop-down box, and
select the third active monitor, then click Apply
to save your settings.

m NOTE:

. Here are only shown three monitors due to
limited by the Intel Graphic Control Panel.
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5. Now you can see video on the three monitors.

6. Inthe General Settings, adjust the extended
monitor resolution to 1920 x1080p, refresh rate
30Hz, click Apply to save your settings

Color Settings <
Mltiple Dispiays
Custom Resolutions

DisplayPort Topology
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2.2 If monitors are FHD

Follow the same steps as 1.2.
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Display configuration

NOTE: The screenshots might vary slightly with the
operating system.

Multi-monitor configuration

Once the extra monitors are connected, they can be
configured to either Mirror mode, Extended mode or set
the primary display.

Position the mouse anywhere on the Windows Desktop,
Right-click and select Screen Resolution.

hange the appearance

=lo o B

Digplay L0

1920 « 1080 Racommended) v
Onentston Landucape

Mutiple dupleys  Extend desktop to ths dupley v

n display

ox Cancel
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Extended mode

1. Refer to the Multi-monitor configuration section to
bring up the configuration window.

2. Inthe Display drop-down menu, select the preferred
monitor.

Select Multiple Displays > Extend these displays.
4. Click OK to confirm and exit.
.

Resolution: 1024 = 768 (recommended) v

[Multiple displays: | Extend these displays = [

[ Make this my main display Advanced settings

Make text and other items larger or smaller

What display settings should T choose?

4 F|

5. Once the setting is completed, simply drag and drop
the application icons or the opened windows to the
add-on monitor. However, some applications may
not support to display on the extended desktop.

*

NOTE: If the system only supports SST mode, the external
monitors connected will be considered to be the
same output.
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6.

Troubleshooting

a.

Cursor disappeared

If the status remains in the extended mode but
the docking station is disconnected, the desktop
will still be panned to the add-on monitor. The
cursor may not be found on the primary monitor
in such a case. If it happens, connect the add-on
monitor through the docking station again or
keep moving the mouse.

Video playback in extended mode

If the video or DVD playback quality is poor or
low performance in extended mode, please
playback it on the primary monitor instead of the
add-on monitor.

Mirror mode

1.

Refer to the Multi-monitor configuration section to

bring up the configuration window.

In the Display drop-down menu, select the preferred

monitor.

Select Multiple Displays > Duplicate these displays.

Click OK to confirm and exit.
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Set the primary monitor

1. Refer to the Multi-monitor configuration section to
bring up the configuration window.

2. Inthe Display drop-down menu, select the preferred
monitor.

3. Check the box of Make this my main display.

NOTE: For some computers, you may need to disable the
main display by unchecking the box of Extend the
desktop onto this monitor or Extend my Windows
desktop onto this monitor.

4. Click OK to confirm and exit.

SST mode

If the system only supports SST mode, the external
monitors connected will be considered to be the same
output.

MST mode

When using MST mode to connect external monitors,
you can use Mirror mode, Extended mode or set the
primary display.
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Audio configuration

By default, when the docking station is connected to a
computer, the audio configuration may be changed to
USB (Multimedia) Audio Device automatically (this
setting depends on models). If it does not work, follow
the steps below to setup.

1. Open Control Panel and then select the hardware
and sound icon.

2. Click Sound > Manage audio devices and then select
USB Audio Device.

& Sound

Plavback [Reeer

Slow to madity it settings

o6 ] [ cancl
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Specification

User Upstream USB-C female connector
Interface Downstream | DP 1.4 female connector x2
HDMI 2.0 female connector x1
USB 3.1 female connector x4
(3A1C), one port supports BC
1.2/CDP & Apple Charge
RJ-45 connector x1
Combo Audio Jack (IN/OUT) x1
Resolution Single display, either one
- DP: 3840x2160@30Hz
- HDMI: 3840x2160@30Hz
Dual display, either one
- DP: 3840x2160@30Hz
- HDMI: 3840x2160@30Hz
Triple display
- 1920x1080@30Hz
Audio Channel 2.1CH
Ethernet Type 10/100/1000 BASE-T
Power Power Mode | Self-powered
Power Input: AC 100-240V
Adapter Output: DC 20V/5A
Working Operation 0~40 degree
Environment  IEWSEERUGS
Storage -20~70 degree
Temperature

Compliance

CE, FCC
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