Script Debugger Help

Welcome to Script Debugger, from Late Night Software!

Script Debugger is a powerful environment for easy, rapid development of AppleScript solutions.
You’ll discover that Script Debugger is the best way to:
Explore scriptable applications.
Examine, navigate and search an application’s dictionary.
Probe a running application’s scriptable objects and values.
Develop AppleScript code.
Script Debugger helps you edit code and insert boilerplate constructs.
Run your code, examine the result, and view the Apple events that you are sending and
receiving.
Run your code a little at a time to better understand how it works (or to figure out why it
doesn’t).

About This Help Document:
Use the hyperlinks, and the navigation aids at the top and bottom of each page, to learn about Script
Debugger or to reach the information you need.
Or, click the blue arrow in the upper right corner repeatedly, to read sequentially, like a book!
For a complete Table of Contents, click here. A Table of Contents link also appears at the top right of
each page.
This help document is also searchable (using Help Viewer).
Further Details:
Opening and Saving Scripts
Explore
Develop
Reference
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Opening and Saving Scripts

A script is a file consisting of AppleScript code. Scripts are Script Debugger’s native documents. Read on to
learn how Script Debugger opens and saves scripts.
Learn how Script Debugger:
Opens scripts. What file formats can Script Debugger open? What happens if there’s difficulty
opening a file?
Saves scripts. What formats does Script Debugger save in? What additional information does Script
Debugger save?
Also, Script Debugger gives you access to secondary information about a script file. Learn about:
Description. A script’s description can serve as a reminder to the developer, an explanation to
users, and a splash screen in an applet.
Manifest. Script Debugger creates a summary of what externalities are required in order for your
script to be edited and executed.
Bundle contents. If a script is in a bundle format, you can edit the bundle’s settings and contents.
Further Details:
Open
Save
Description
Manifest
Bundle

Explore
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Open

Here’s how to open a file with Script Debugger. The result of opening a script file is either a script window
or a tab within a script window.

New Script Window
To make a new script window, choose File > New Script or, if you’d like to summon the template
chooser, choose File > New Script From Template.
What happens when you choose File > New Script depends on your settings in Script Debugger’s General
preferences, under “For New Documents”:
If you’ve selected “Show Template Chooser”, the template chooser appears. From here, you can
select the kind of script you want to create. In most cases this will be AppleScript > AppleScript (for
a normal compiled script file) or Applications > Applet (for an applet).
If you’ve selected “Use template”, the kind of script you’ve specified as the default is created,
without displaying the template chooser. To specify a kind of script as the default, click the Choose
Template button in the General preferences pane and use the template chooser to specify a
template. In most cases this will be AppleScript > AppleScript.
(Even if you’ve selected “Use template”, you can still summon the template chooser at any time by
choosing File > New Script From Template.)
(Also, there are various ways that you can make a new script targeting a particular application.)
Here’s how to set the size and view configuration that a new script window will adopt.

New Script Tab
To make a new script tab within the frontmost script window, choose File > New Script Tab or, if you’d
like to summon the template chooser, choose File > New Script Tab From Template.
Alternatively, if the window already has a tab, press the “plus” button to the right of the last tab.
What happens when you choose File > New Script Tab (or press the “plus” button) depends on your
settings in Script Debugger’s General preferences, under “For New Documents”, in exactly the same way as
for File > New Script. See the discussion earlier on this page.
Click here to learn all about tabs in a Script Debugger script window.

Open Existing Script
To open an existing script, do any of the following:
To navigate to the file in the standard Open File dialog, choose File > Open.
To search for the file by name or contents, choose File > Open Quickly.
If you’ve recently had this script open, choose it from File > Open Recent.

Drag and drop the script file onto Script Debugger’s icon in the Finder or the Dock.
If Script Debugger is the owner of script file types, double-click the script file in the Finder. (But that
doesn’t work for an applet, since by default when an applet is opened from the Finder, it runs.)
There is also a special way of quickly opening a library script referred to in your code:
Select within a line referring to the script (such as script "MyScript"); then, choose File > Open
Script Library “MyScript”.
(If the library script has a dictionary, a dialog appears, offering you a choice of whether to open the
script or its dictionary.)
Whether an existing script opens as a separate window or as a tab within the frontmost window
depends on a General preference; under Opening Documents, check or uncheck “Open in Tabs”. To reverse
your setting on a particular occasion, hold the Shift key as you open a script.
A General preference lets you tell Script Debugger to warn you if opening an existing script might cause an
application to launch.
Learn what files Script Debugger can open.
Learn how Script Debugger can help when there’s trouble opening a file.
Further Details:
The Template Chooser
Tabs
Compatibility
Opening a Compiled Script as Text

Save
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The Template Chooser

The template chooser lets you open a new script from a stored script file in a special template format.
The template acts as the basis for your work in a new untitled script. When you edit and save the new
untitled script, you’ll save it under a new name and in a new location.

The template scripts displayed by the template chooser fall into categories:
Script Templates. These are template files provided by Script Debugger itself. They are:
AppleScript > AppleScript. A compiled script file with use statements for the AppleScript
version and scripting additions. Options let you specify a script bundle, insert a comment
block giving author and date information, and toggle on or off persistent properties.
AppleScript > AppleScriptObjC. Like the preceding, with a use statement for the
Foundation framework.
AppleScript > Empty AppleScript. An empty script, with no use statements and no
options.
Application > Applet. An applet with use statements similar to the AppleScript >
AppleScript template, containing a run handler. Options let you specify a droplet (an applet
that accepts drag-and-drop of files and folders), insert a comment block giving author and
date information, and toggle on or off persistent properties.
Application > Applet Using AppleScriptObjC. Like the preceding, with a use statement for
the Foundation framework.

Plug-in Scripts. Compiled script files already containing code, structured for use by a
particular application or situation:
Contacts Plugin Script. A script to be triggered in Contacts through a menu item that
will appear in the menu that pops up when you click on a category name (e.g. “work” in
front of an email or phone number). See the Address Book Rollover Suite in the
Contacts dictionary.
Digital Hub Script. A script to be triggered when a CD or DVD is mounted. See Digital
Hub Actions in the Scripting Additions dictionary.
Folder Actions Script. A script to be triggered when an event occurs in a certain
folder, such as a file being added to it. See Folder Actions in the Scripting Additions
dictionary.
Mail Rule Script. A script to be triggered in Mail according to a user-defined rule. See
the perform mail action command in the Mail dictionary.
User Templates. Templates that you create! To make a template:
1. Configure a script the way you want it.
2. Choose File > Save as Template.
3. Save into ~/Library/Application Support/Script Debugger 6/Templates (the Save dialog will
display this folder as your destination automatically). Script Debugger converts your script
into a special template format.
A template that you create (or any template, actually) includes the content of the script that you
save as a template. This includes such features as:
Text of the script
Description
Expressions
But it does not include the size or view state of the script window. Those are window features, not
template features, and come from your new script window appearance defaults.
The content of a template that you create (or any template) can include clipping expansion tags.
You can organize your user templates into categories. To do so, organize them into folders within the
Templates folder. A folder in the Templates folder will appear as a category in the left column of the
template chooser.

Tabs
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Tabs

A script window can contain multiple tabs. Each tab is a separate document.

Thus, a document can appear either in a window by itself or as a tab in a window along with other
documents. Use whichever arrangement you find convenient for navigation and organization as you work;
mix and match!
Whether a document appears in a separate window or as a tab in a script window along with other
documents depends on how you open it.
If you prefer your script windows always to have tabs, even when there’s only one, choose View >
Show Tab Bar at a time when there’s only one tab.

To navigate between tabs within a window, choose Window > Select Next Tab or Window > Select
Previous Tab.
To rearrange tabs within a window, drag a tab sideways.
To turn a tab into a separate window, drag the tab right out of its current window.
(Alternatively, you can open a tab as a separate window without destroying the tab: choose File > Open
in New Window. The result is a document that’s being edited by multiple windows simultaneously.)

To move a document into a tab in a given window, close the document, bring the window to the front,
and open the document as a tab.
To close a tab, choose File > Close Tab, or click the symbol (“x” or dot in a circle) at the left of the tab.
To close all but one tab, hold Option and click the symbol (“x” or dot in a circle) at the left of the tab.
To close a window and all its tabs, choose File > Close Window, or click the red dot at the top left of the
window.

The Template Chooser

Compatibility
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Compatibility

Script Debugger can open any of AppleScript’s native file types:
Compiled script file with the bytecode in the data fork. This is the standard modern format
created by the current version of Apple’s Script Editor.
Script bundle. The compiled script file (with the bytecode in the data fork) is inside the bundle.
Applet bundle. This is the standard modern applet format.
Script Debugger can save in any of the above formats as well.
Script Debugger can also open a file in any of the older historical script formats. It doesn’t save in
these older formats, so to save such a file, you’ll need to select one of the modern formats. The older
formats include:
Compiled script file with the bytecode in the resource fork. This is the oldest format, going
back as far as AppleScript itself.
Nonbundle applet. Script Debugger can open nonbundle applets created on any system, including
a “Classic applet” (Mac OS 9 and earlier).
Script Debugger can also open a text file. The file is assumed to be UTF-8 unless there is a BOM (byte
order mark) indicating otherwise; if there’s an encoding error, the file is assumed to be in the old
MacRoman encoding. Line endings can be Mac or Unix.

Tabs

Opening a Compiled Script as Text
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Opening a Compiled Script as Text

Sometimes, AppleScript prevents Script Debugger from opening a compiled script file, or shows the
file’s contents with raw Apple event codes. This indicates that something has gone wrong with the
decompilation process. For example, an application or scripting addition needed by the script is missing, or
a script’s internal alias to an application has broken.
If the script was originally saved with Script Debugger, you can open the script as text. To do so:
Choose File > Recover Damaged Script.
This feature works because when Script Debugger saves a compiled script, it saves not only the compiled
bytecode but also the uncompiled text. The uncompiled text is placed in the file’s resource fork (or, if the
file is a bundle, in a file within the bundle).
Warning: If you edit a script with some other script editor application, the stored uncompiled text may
no longer match the current state of the bytecode.

Open As Text Instead of Launching an Application
Script Debugger may automatically let you open a script as text, if you attempt to open a compiled script
that targets an application which must be launched in order for AppleScript to decompile it.
For example, suppose Script Editor is not running and you open a compiled script that targets Script Editor.
If Script Editor isn’t already running, AppleScript wants to launch it in order to display the script. Script
Debugger detects this and can optionally intervene:
If your choice in Script Debugger’s General preferences is “Warn when applications may be
launched,” Script Debugger presents this dialog:

You can proceed to open the script (and allow Script Editor to launch) if you wish, but perhaps the
overhead of launching an application just to read a script seems unwarranted. If this script was
saved with Script Debugger, it contains a text version, and you can click Open As Text to open that
instead. Thus you can read the script without launching Script Editor. (But to compile the script you
will have to let AppleScript launch Script Editor.)
If the script does not contain a text version, the Open As Text button will not be present.

If your choice in Script Debugger’s General preferences is “Always open as text without launching
applications,” then, if the script can be opened as text, Script Debugger will open it as text, without
bothering to display the dialog.

Compatibility

Script Debugger Help > Opening and Saving Scripts >

Table of Contents

Save

To save a script with Script Debugger:
Choose File > Save.
Choose File > Save As. This creates a new file or, if you wish, overwrites the original file.
Choose File > Save A Copy As. This creates a new file but the script window continues to show the
original file.
Scripts can be saved in various formats. If you are creating a new file, options for specifying the desired
format appear in the Save dialog (the Format pop-up menu). Alternatively, you can specify format
options by choosing from these hierarchical menus:
File > Script Format
File > Application Options (if it’s an applet)
File > Code Signing (if it’s an applet)
To save a script, the script must be compiled. If you wish to save a script without compiling you can save it
as text.
A compiled script (or application) can also be exported as a run-only script.
Further Details:
Formats
Run-Only Script
What Is Saved
File Owner
Spotlight and Quick Look
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Formats

Script Debugger can save scripts in three basic forms: as a compiled script file, as an applet (application),
or as text.
In each case, you have various options about the resulting format and other details.
A compiled script (or application) can also be exported as a run-only script.
Further Details:
Compiled Script
Application
Text

Run-Only Script
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Compiled Script

Script Debugger can save compiled script files in two formats. You can choose a format either from the File
> Script Format hierarchical menu or in the Save dialog.
Compiled Script. A file with the compiled bytecode in the data fork. This is the default format
created by the current version of Apple’s Script Editor. It is backwards compatible to all versions of
OS X and to very late versions of AppleScript in Mac OS 9.

Compiled Script Bundle. A bundle (package) with the bytecode as a data fork compiled script file
inside the bundle. This format was introduced in Panther (OS X 10.3) and is not backwards
compatible to earlier systems. It has the advantage that you can store ancillary files inside the
bundle.
Use the bundle inspector to configure bundle settings and to manipulate the contents of the bundle’s
Resources folder.

Historical Note: The oldest compiled script format is a file with the compiled bytecode in the resource
fork. Script Debugger can open a script file in this format, but it will save with the bytecode in the data
fork.

Warning: A compiled script saved in debug mode will not run normally in other environments (and will not
even open in Apple’s Script Editor). Unless that’s what you intend, be sure to save the script in normal
mode when you’re finished debugging it!
For a plain compiled script file, Script Debugger stores some secondary information in the file’s resource
fork. In a bundle format file, however, no resource forks are used; secondary information is saved in
separate files. (The description is saved in an .rtfd file, the recovery text is saved in an .rtf file, and the
other secondary information is saved in a .plist file.) For this reason, a bundle format file is the most
compatible with version control systems, non-Mac filesystems, and so on.

Application

Script Debugger Help > Opening and Saving Scripts > Save > Formats >

Table of Contents

Application

A compiled script can be saved as an application, traditionally known as an applet. An applet is a standalone application. When opened in the Finder, the script runs.
An applet’s script can be edited in Script Debugger by opening it in any of the usual ways.
You can save a script as an applet and leave the script open in Script Debugger. This allows you to test the
script from the Finder and then easily edit it in Script Debugger.
Tip: Script Debugger has some further features for helping you test a script that is destined to be saved
as an applet. You can test individual handlers in the applet, and you can debug the applet while it is
running.

To save a script as an application (if it isn’t an application already):
Choose File > Save As and select Application from the Format pop-up menu.
An applet is always saved as a bundle; this has the advantage that you can store ancillary files inside
the bundle.

Besides the format, you can also set further options for the behavior of the resulting application. To do so,
use the checkboxes in the Save dialog, or choose from the hierarchical File > Application Options menu.
(You can also add Stay Open and Show Startup buttons to the script window’s toolbar.)
Show Startup Screen. The script’s description is used as a “splash screen” when the applet starts
up. This splash screen also contains buttons allowing the user to quit or run the applet.
Stay Open:
An applet that does not stay open runs its script when opened and then automatically quits.
An applet that does stay open does not automatically quit after running its script (the user can
choose its Quit menu item to quit it later). This is useful if, for example, the applet runs a
handler periodically at idle time.
Code Signing. If an applet is to be distributed to other users, and if you have a membership in the
Apple Developer Program, you might wish to code sign the applet.
Use the bundle inspector to configure bundle settings and to manipulate the contents of the bundle’s
Resources folder.
Warning: An application saved in debug mode will not run normally (when launched, it will initiate an
external debugging session in Script Debugger). Unless that’s what you intend, be sure to save the

application in normal mode when you’re finished debugging it.

Compiled Script

Text
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Text

You can save a script as text, without compiling. The result is an ordinary text file (in UTF-8 encoding).
To do so, do either of the following:
Choose File > Save, File > Save As, or File > Save A Copy As, and choose Text from the Format popup menu in the Save dialog.
Choose File > Script Format > Text.

You may need to save a script without compiling for a variety of reasons:
You want to save your work, but the script doesn’t compile (and you don’t have time to figure out
why right now).
You want to store the script in a form that’s guaranteed to be readable on another computer. (A
compiled script file might fail to open on another computer for a variety of reasons.)
NOTE: If you attempt to save a script and there’s a compile error, Script Debugger will offer, in the
Compile Error dialog, to save the script as text.

If you wish, you can specify line endings for a text file. To do so, use the Text Line Endings pop-up menu
in the File > Save As dialog. In general you should not have to do this. If you leave the line endings setting
at As Is (the default), line endings will be left alone. Any other setting will force line endings to be set at
some specific value, and this can alter the functionality of your script (as explained here). (To view line
endings as they are now in your script, you can show invisibles.)

Application
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Run-Only Script

A run-only script contains the script’s compiled bytecode but does not contain the further information
needed to decompile and display it. A run-only script is typically used as a way of distributing a script so
that other users can run the script but cannot view or modify the script’s source code.
To save a script as run-only:
Choose File > Export Run-Only Script. (You can also add an Export Run-Only button to the script
window’s toolbar.)
The resulting Save dialog contains the same format options as for an ordinary compiled script or
application.
It also contains a checkbox, “Make bundled scripts & libraries run-only”. This is useful in cases where
you’ve added extra scripts to a script bundle or application bundle. If you don’t check it, the bundle’s
main script will be saved as run-only, but the extra scripts in the bundle will not be.

A run-only script cannot be read or edited ever again, even by you, its creator! This is why Script
Debugger implements this feature as a form of export. After exporting as run-only, your original script is
unaffected (and therefore remains editable). If you edit your original script and you wish to propagate the
changes to the run-only version of the script, export it again.

Formats

What Is Saved
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What Is Saved

Script Debugger saves the following information into a compiled script file:
The compiled script bytecode.
The script’s description, if any.
Persistent information such as the current values of script properties, if the script is configured to do
this.
Script window state (such as its size and position) and view settings, plus:
What panes (such as the result pane) are showing and how they are configured.
Event log pane and window configuration.
Expressions.
Breakpoints, if the script is saved in debug mode.
For a plain compiled script file, Script Debugger stores some secondary information in the file’s resource
fork. In a bundle format file, however, no resource forks are used; secondary information is saved in
separate files. (The description is saved in an .rtfd file, the recovery text is saved in an .rtf file, and the
other secondary information is saved in a .plist file.) For this reason, a bundle format file is the most
compatible with version control systems, non-Mac filesystems, and so on.

Run-Only Script

File Owner
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File Owner

When a file is opened from the Finder, it is opened by the application that owns it. Therefore, since
applications other than Script Debugger (such as Apple’s Script Editor) can claim ownership of script files,
you might want to control the ownership of files created by Script Debugger.
To make Script Debugger the owner of script files:
Go to the General preference pane and check “Default editor for OSA scripts, applets and droplets.”
This is a quick way of setting Script Debugger as the owner for files with the relevant filename extensions
(.scpt for a compiled script file, .scptd for a compiled script bundle, .applescript for a script text file); you
could do the same thing in a script file’s Get Info dialog in the Finder.

What Is Saved

Spotlight and Quick Look
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Spotlight and Quick Look

Script Debugger supports both Spotlight and Quick Look access to saved compiled script files.

Spotlight
Spotlight is an indexing technology, introduced in OS X 10.4 (Tiger). It keeps track of files and their
contents and allows you to search rapidly for a file based on its name or its contents. If you can remember
a word or two used in your file, you can find it quickly, rather than having to remember what folder it’s in.
Script Debugger contains a Spotlight importer for compiled script files. This means that if Script Debugger
is present on your computer, AppleScript compiled scripts are searchable with Spotlight. You can search for
a script file by name or contents (including its description).
Script Debugger provides direct access to search for a file and open it using Spotlight:
Choose File > Open Quickly. In the dialog, type some words or letters to search for; the search
includes the file’s name, contents, and description. Matching script files are listed, along with their
pathname.
To preview the contents of a selected file or files, click the Quick Look button (or press
Spacebar). See the discussion of Quick Look later on this page.
To open a file or files, double-click the file listing (or select, and then click the Open button or
press Return).

Quick Look
Quick Look is a technology, introduced in OS X 10.5 (Leopard), for viewing a preview of the contents of a
file without the overhead of opening that file in the application that owns it. For example, you can Quick
Look a file directly in the Finder.
Script Debugger contains a Quick Look generator for compiled script files and applets. This means that the
system is provided with the information it needs to translate your file into a preview that Quick Look can
present. If a script has been saved with Script Debugger, it will be viewable with Quick Look along with its
AppleScript compiled script text formatting; otherwise, it will appear in Quick Look as plain text.

Because you’re just “peeking” at the script’s text with Quick Look, there is none of the overhead involved
with actually opening the script: there is no decompilation and therefore there is no need to launch any
targeted applications.

File Owner
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Description

A script can have a description. This can serve as a reminder to the developer, an explanation to users, and
as a splash screen in an applet.
To access a script’s description:
Choose View > Resources Tab.
Or, click the second Show button in the script window toolbar.
The description appears in the top pane at the right side of the script window. It consists of styled text.
Text styling will be maintained in an applet’s splash screen.

Save

Manifest
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Manifest

Script Debugger can generate a manifest for your script — a list of its external dependencies.
This can be useful purely as information. It can also have practical implications. For example, suppose you
intend to move the script to another machine or send it to another user. If the script requires a scriptable
application, the script won’t run on a machine that lacks that application. Thanks to the manifest, you’ll be
forewarned about such dependencies.
To see a script’s dependencies in the Manifest dialog:
Choose File > Show Manifest. (You can also add a Manifest button to the script window’s toolbar.)
The script’s dependencies are listed by category:
Application Dependencies. These are applications specified in a use statement or a tell or terms
block.
Script Library Dependencies. These are library scripts specified in a use statement.
Scripting Addition Dependencies. These are scripting additions specified in a use statement or (if
the script contains no use statements) whose terms are used in the script. [Technical note: Rarely,
a scripting addition may provide coercions in addition to terminology; Script Debugger cannot
detect these.]
Framework Dependencies. These are frameworks specified in a use statement.

Buttons allow you to reveal a selected application, library script, scripting addition, or framework in the

Finder.
You can also view the dictionary for a selected application, library script (if it has a dictionary), or
scripting addition.
The Script Debugger 5 feature that exports the Manifest dialog’s contents as a text file is not present in
Script Debugger 6. But you can write your own equivalent by scripting Script Debugger to get a
document’s used applications, used script libraries, used scripting additions, and used
frameworks.

Description

Bundle
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Bundle

If a script’s format is a compiled script bundle or an application bundle, you can work with the bundle
settings and contents using the bundle inspector.
To work with bundle settings and contents:
Choose View > Resources Tab.
Or, click the second Show button in the script window toolbar.
If the script is in a bundle format, the bundle inspector appears at the right of the script window.

The bundle inspector is divided into three sections.

Description
A styled text description of the bundle. In the case of a bundle, you are actually editing the text of
Resources/description.rtfd inside the bundle.

Settings
These settings actually edit the contents of the Info.plist file inside the bundle.
Bundle ID
A unique identifier for the bundle. This is important particularly if the bundle is an applet; every OS
X application should have a unique identifier. By convention, the identifier starts with com. and is
structured like a reverse URL hostname. By default, Script Debugger will combine the Bundle ID
Prefix from your General preferences with the name of the bundle.
Copyright
The copyright string appears in the Finder’s Get Info window for this file. By default, Script
Debugger derives the copyright string for an applet from the Copyright Notice from your General
preferences.

Version
The version string appears in the Finder’s Get Info window for this file. It can also be used to
restrict a use script statement, referring to this script, to a minimum version.
Build #
A number entirely for your use. Check Increment On Save if you would like Script Debugger to
increment this number each time the script is saved.
Scripting Def.
An sdef file in the bundle’s Resources folder. You can use this to define AppleScript English-like
terminology for your script, thus giving your script a dictionary. This is useful particularly if this is a
library script to be used by others, who can consult the script’s dictionary to learn how to use your
script.
Code Signing
A reference to a Developer ID Application certificate in your keychain, if you have one. This is
useful if you want to code sign an applet for public distribution, as it makes it easier for users to
get past Gatekeeper restrictions on opening “strange” applications.

Resources
The Resources pane displays the contents of the Resources folder inside the bundle.
To add an existing file or folder to the bundle:
Click the Plus button at the bottom of the bundle inspector.
Or, choose Add Existing Files from the contextual menu.
Or, drag an item from the Finder into the bundle inspector.
To delete a selected file or folder in the bundle:
Click the Minus button at the bottom of the bundle inspector.
Or, choose Delete from the contextual menu.
To rename a selected file or folder in the bundle:
Press Return to edit its name.
Or, choose Rename from the contextual menu.
To reveal a selected file or folder in the bundle:
Cchoose File > Reveal XXX in Finder.
Or, choose Reveal XXX in Finder from the contextual menu.
To create a new folder in the bundle:
Choose New Folder from the contextual menu.
To open a nonscript file in the bundle:
Double-click the file in the bundle inspector.

Manifest
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Explore

The biggest challenge for the AppleScript programmer is figuring out what to say to a scriptable
application. Script Debugger gives you powerful tools for exploring a scriptable application so that you can
quickly write successful scripts targeting it.
You can explore an application’s dictionary. Script Debugger helps you navigate and search the
dictionary, and lets you view dictionary information fully and clearly.
You can explore a scriptable application’s objects. For example:
If a scriptable application is running, you can explore its entire current set of objects in real
time.
While the application is running, you can see the names and values of the attributes
(elements and properties) that it actually has at that moment — and if those attributes are
objects, you can see their attributes, and so forth. You can copy a reference to an attribute
into your script. You can even change a property value, without writing a script.
If a scriptable application returns an object value as the result of a script or a line of code, you
can explore that result.
Further Details:
Dictionary
Explorer

Opening and Saving Scripts

Develop
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Dictionary

One of Script Debugger’s most helpful features is its display of the dictionary of a scriptable application.
In a dictionary window, Script Debugger makes it very easy for you:
To open the dictionary of a scriptable application or scripting addition.
To navigate the dictionary.
To view the information in the dictionary in a variety of ways.
To explore a scriptable application’s objects in real time.
Further Details:
Open Dictionary Window
Dictionary Window
Application Explorer

Explorer
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Open Dictionary Window

You can open an application’s dictionary window in several different ways, depending on what you’re
doing and what’s convenient. The most common way is:
Choose from the File > Open Dictionary menu.
And there are many other ways:
If an application is running, you can open its dictionary window directly.
If you’re working in an application, you can choose Open XXX Dictionary (where “XXX” is the
frontmost application) from Script Debugger’s Dock menu.
If you’ve already worked with an application, Script Debugger remembers this fact, and you can
open the dictionary window from a list of previously used applications.
If you’re editing a script that targets an application, you can open that application’s dictionary
window directly.
If you’re editing a script that targets a library script with a dictionary, you can open that
script’s dictionary window directly.
If the dictionary you want to open is a scripting addition dictionary, you can open its dictionary
window directly.
There are various general ways to open any application or scripting addition’s dictionary window.
Also, you can switch to the frontmost dictionary window at any time (e.g., while working in a script
window) by choosing Window > Dictionary. If there is no open dictionary window, an empty dictionary
window is created.
Here’s how to open multiple dictionary windows.
In some cases, opening an application’s dictionary will require the application to be running. If this is the
case, and the application is not running, then when you ask to open the application’s dictionary, Script
Debugger will launch the application, which may cause a delay. However, once Script Debugger has opened
an application’s dictionary, it caches the dictionary (provided you have not unchecked “Cache generated
dictionaries” in the Dictionary preferences). Thus, having opened such an application’s dictionary, you can
now close the application and its dictionary and later open its dictionary again and this time Script
Debugger will not have to launch the application.
NOTE: If you target scriptable applications with a plug-in architecture, such as QuarkXPress or
InDesign, read the discussion on this page about regenerating the dictionary cache.

Further Details:
Running Applications
Recent and Favorite Applications
Current Context
Scripting Additions

Open Any Dictionary Window
Open Multiple Dictionary Windows
Dictionaries Inspector

Dictionary Window
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Running Applications

If an application is running right now, you can quickly open its dictionary window.
Choose File > Open Dictionary. In the resulting hierarchical menu, you’ll see a list headed Running.
Choose an application from the menu to open an application’s dictionary window.

In any open dictionary window, locate the application in the dictionaries list at the left side of the
window, under Running. Click the name of the application.
In the dictionaries inspector, locate the application under Running. Double-click its name, or select
its name and click Dictionary, or select its name and choose Open XXX Dictionary from the
contextual menu.
If what you want to open is the dictionary of the frontmost application, use Script Debugger’s
Dock menu. This contains an item, Open XXX Dictionary, where “XXX” is the frontmost application.
Choose it, and Script Debugger will come to the front with that application’s dictionary window open.

Recent and Favorite Applications
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Recent and Favorite Applications

When you ask Script Debugger to work with an application, Script Debugger remembers this fact and puts
the application in its dictionaries list. You can open a recently used application’s dictionary window
quickly:
Choose File > Open Dictionary. In the resulting hierarchical menu, you’ll see a list headed Recent.
Choose an application from the menu to open that application’s dictionary window.

In any open dictionary window, locate the application in the dictionaries list at the left side of the
window, under Recent. Click the name of the application.
In the dictionaries inspector, locate the application under Recent. Double-click its name, or select its
name and click Dictionary, or select its name and choose Open XXX Dictionary from the contextual
menu.
If you frequently use an application, you can designate it a favorite application. To do so:
In any open dictionary window, or in the dictionaries inspector, select the application and choose
Favorite from the contextual menu so that it is checked.
(If you change your mind later and want an application no longer to be designated a favorite
application, select the application and choose Favorite from the contextual menu so that it is
unchecked).
To open a favorite application’s dictionary quickly:
Choose File > Open Dictionary. In the resulting hierarchical menu, you’ll see a list headed Favorites.
Choose an application from the menu.
In any open dictionary window, locate the application in the dictionaries list at the left side of the
window, under Favorites. Click the name of the application.

In the dictionaries inspector, locate the application under Favorites. Double-click its name, or select
its name and click Dictionary, or select its name and choose Open XXX Dictionary from the
contextual menu.
A library script with an sdef also counts as a recently used application and can be made a favorite
application.

Running Applications

Current Context
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Current Context

If you’re editing a script that contains a tell block targeting an application, you can quickly open that
application’s dictionary window.
Select anywhere inside the tell block targeting the application whose dictionary you want to open.
(This is to put your selection into the desired tell context.) Then choose File > Open XXX Dictionary,
where “XXX” will be the name of the application. (The command-key shortcut, Command-D by
default, will come in very handy here, and will rapidly become second nature.)

Alternatively, choose Open XXX Dictionary from the contextual menu.
If you’re editing a script that targets a library script with a dictionary, you can quickly open that
script’s dictionary window.
Select in a line containing the expression script "XXX", where “XXX” is the library script’s name.
Then choose File > Open Script Library “XXX”. A dialog appears, letting you open the script’s
dictionary or the script itself. (Again, the default keyboard shortcut is Command-D.)

Recent and Favorite Applications

Scripting Additions
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Scripting Additions

The dictionary window for any installed scripting additions can be opened directly in Script Debugger.
Choose File > Open Dictionary. In the resulting hierarchical menu, you’ll see a list headed
AppleScript. Choose Scripting Additions.

In any open dictionary window, locate Scripting Additions under the AppleScript heading in the
dictionaries list at the left. Click it.
In the dictionaries inspector, locate Scripting Additions under the AppleScript heading. Double-click
it, or select it and click Dictionary, or select it and choose Open “Scripting Additions” Dictionary from
the contextual menu.

Current Context

Open Any Dictionary Window
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Open Any Dictionary Window

If an application is not running and you haven’t worked with it recently, and if you are not currently
targeting it in a script, you can open its dictionary window in the following ways:
In any open dictionary window, locate the application in the dictionaries list on the left side of the
window under All, and click it.
In the dictionaries inspector, locate the application under All. Double-click its name, or select its
name and click Dictionary, or select its name and choose Open XXX Dictionary from the contextual
menu.
Choose File > Open. This brings up a dialog where you can choose anything. If what you choose is
an application or scripting addition, its dictionary will open. If what you choose is a library script with
a dictionary, a dialog will appear asking whether you want to open the script’s dictionary or the
script itself.
Choose File > Open Dictionary > Application. This brings up a dialog where you can choose an
application, scripting addition, or library script with a dictionary, to open its dictionary.
Locate the application or scripting addition in the Finder and drag its icon onto Script Debugger’s icon
in the Finder or the Dock.
Locate the application or scripting addition in the Finder and drag its icon onto a Script Debugger
script window. Script Debugger will put up a dialog asking what you want to do. One of the options is
to open the application’s dictionary window.
NOTE: Script Debugger can also open an sdef file directly, and will present its dictionary window as if
you had opened a scriptable application. This is intended as an aid if you’re developing or editing an
sdef.

Scripting Additions

Open Multiple Dictionary Windows
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Open Multiple Dictionary Windows

When you open a dictionary window, it normally reuses the frontmost dictionary window if there is
one, and you can switch among applications (and dictionaries) within that dictionary window. However, you
can also open multiple dictionary windows, in order to see dictionary information for two different
applications simultaneously, or work with an application in two simultaneous modes (for example, a
dictionary and an explorer), and so on. To do so:
Bring a dictionary window to the front, and choose File > Open XXX Dictionary in New Window
(where XXX is the application currently being viewed in this dictionary window).
Or, in a dictionary window, Control-click an application’s name in the dictionaries list and choose
Open XXX Dictionary in New Window.
Or, hold the Shift key and choose Window > New Dictionary Window.
Or, hold Option while opening a dictionary window. For example, hold Option while choosing File >
Open Dictionary. Or, hold Option while pressing the Dictionary button in a script window’s
dictionaries inspector or tell context inspector.

Open Any Dictionary Window

Dictionaries Inspector
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Dictionaries Inspector

The dictionaries inspector lists applications that Script Debugger has “met” in various ways — the
dictionaries list. This list appears in several places in the interface — for example, in a dictionary window,
and in shortened form (without the All category) in the File > Open Dictionary menu and the Edit > Paste
Tell menu.
The dictionaries inspector is in the Inspectors tab of a script window. To see the dictionaries inspector:
Choose View > Inspectors Tab.
Or, click the third Show button in the script window toolbar.

To open an application’s dictionary:
Select it and click the Dictionary button.
Or, select it and choose File > Open XXX Dictionary.
Or, Control-click it and choose Open XXX Dictionary from the contextual menu.
Or, double-click the application’s name.
Or, click an application’s triangle to open it, revealing commands for that application:
Select a command. The dictionary info for that command is shown directly, in the dictionaries
inspector.
Select a command, and open the dictionary in any of the preceding ways. The dictionary
window opens, with that command selected in the terminology list.

Hold Option to open the dictionary in a new dictionary window.
To insert a tell block targeting an application:
Select it and click the Paste Tell button.
Or, select it and choose Dictionary > Paste Tell XXX.
Or, Control-click it and choose Paste Tell XXX from the contextual menu.
Or, click an application’s triangle to open it, revealing commands for that application. Select a
command, and Paste Tell in any of the above ways. A tell block containing a template for that
command is pasted.
Hold Option to paste into in a new script window.
Alternatively, drag the name of an application from the dictionaries inspector into a script window.

To insert a using terms from block targeting an application:
Select it and click the Paste Using button.
Or, Control-click it and choose Paste Using Terms From XXX from the contextual menu.
Hold Option to paste into in a new script window.
To learn an application’s location:
Hover the mouse over the application’s name, to see the tooltip.
To show an application in the Finder:
Select it and choose File > Reveal XXX in Finder.
Or, Control-click it and choose Reveal XXX in Finder from the contextual menu.
To bring an application to the front:
Select it and choose Dictionary > Activate XXX.
Or, Control-click it and choose Activate XXX from the contextual menu.
To quit a running application:
Select it and choose Dictionary > Quit XXX.
Or, Control-click it and choose Quit XXX from the contextual menu.
You can also search dictionaries from the dictionaries inspector.
You may be curious about how the All section of the dictionaries list is automatically populated. Basically,
an application is added to the list automatically in the following circumstances:
When Script Debugger is launched. Script Debugger searches your computer for scriptable
applications, and adds them to the list if they have ever run. (A dictionary preference, “Only
search Applications folder for dictionaries”, allows you to limit the scope of this search.)
When an application’s dictionary is explicitly opened.
When an object specifier is explored (so, for example, when you target an application in a script

and it returns an object as the script’s result).
When a tell block targeting that application is detected in your code.
Running a script targeting an application might not add that application automatically to the list. The
reason is that AppleScript and Script Debugger are two different entities, so AppleScript can run a script
without Script Debugger seeing and analyzing the contents of that script.

Open Multiple Dictionary Windows
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Dictionary Window

Meet Script Debugger’s dictionary display!

(The dictionary illustrated here is for a tiny scriptable application called Pairs, especially written for test
purposes. You don’t have this application, so don’t go looking for it on your hard disk!)

Here are the parts of the dictionary window:
1. The toolbar.
2. The dictionaries list. This is the same list that appears in the dictionaries inspector, and in
shortened form (without the All category) in the File > Open Dictionary menu and the Edit > Paste
Tell menu. To work with an application’s dictionary or explorer starting in an existing dictionary
window:
Click the application’s name in the dictionaries list.
Control-click the application’s name and choose Open XXX Dictionary in New Window to create
a separate dictionary window.
To show or hide the dictionaries list:
Choose Dictionary > Show Dictionaries List.
If you hide the dictionaries list (to save screen real estate, perhaps), you might like to
customize the dictionary window’s toolbar to add the Dictionaries button, which summons a

pop-up menu containing the entire dictionaries list.
The application names in the dictionaries list are draggable! Drag one into a script window. The
result is the same as dragging the application from the Finder into the script.
3. The terminology list. It’s a list of all terminology in the current dictionary. Select in the terminology
list to see the corresponding dictionary entry in the info pane.
The terminology list is replaced with search results when you search the dictionary.
The terminology list is replaced with an object model diagram when you display the object
model.
The terminology list is removed completely when you display the explorer.
4. The info pane. It displays an entry or entries from the dictionary. To determine what entry is
displayed here, select in the terminology list (or in the results of a search).
The info pane may be replaced with the explorer.
The dictionary window may appear in any of three modes, according to your choice in the Dictionary
menu (or you can use the View buttons in the toolbar):
Dictionary > Show Dictionary (or the Dictionary button): Displays the dictionaries list (unless
you’ve hidden it), the terminology list (or the results of a search), and the info pane.
Dictionary > Show Object Model (or the Object Model button): Displays the dictionaries list (unless
you’ve hidden it), the object model diagram, and the info pane.
Dictionary > Show Explorer (or the Explorer button): Displays the dictionaries list (unless you’ve
hidden it) and the application explorer.
Which mode the dictionary window is in when it first appears or when you switch to another application’s
dictionary depends on your choice in the Dictionary preferences:
Show Dictionary; Show Object Model; Show Explorer: The dictionary window switches
automatically to that mode.
Remember state: The dictionary window switches to the mode it was last in for that application.
You can save the current dictionary window’s configuration (such as its size) as the default for future new
dictionary windows. To do so:
Choose Window > Set Default Dictionary Window Size & State.
Choose Window > Reset Default Dictionary Window Size & State to revert to the built-in defaults.
NOTE: The scripting additions dictionary can appear only in the first mode, Dictionary. There’s no object
model or explorer for scripting additions, because a scripting addition is not an application so it has no
objects to diagram or explore.

Here’s how to open multiple dictionary windows.
Further Details:
Terminology List

Dictionary Info Pane
Hierarchies and Diagrams
Search in Dictionary
Look Up Definition
Back and Forward
Miscellaneous Dictionary Actions

Open Dictionary Window

Application Explorer
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Terminology List

The terminology list at the left of the dictionary window is the primary way of navigating an
application’s dictionary. Choose Dictionary > Show Dictionary (or click Dictionary in the dictionary
window’s toolbar).

Select in the terminology list to display the corresponding dictionary entry in the info pane.
To select and display info for more than one term in the list, Shift-click to select a range of
entries, or Command-click to select multiple individual entries.
If you select a category name, info is displayed for all terms in that category. For example, if you
select Classes, it’s as if you’d selected all the individual names of classes — info is displayed for all
the classes in the dictionary.
You can use arrow keys to navigate the terminology list, though it is probably more common to
use the mouse.
Another common technique is to search the terminology, thus filtering the terminology list to consist
only of terms that result from the search.
NOTE: The terms in the terminology list are draggable! Drag and drop a term into a script window. The
result is similar to Paste Tell.

Here is a discussion of the various categories and icons you’ll see displayed in the terminology list (and in
search results).
Further Details:
Types of Entities Shown in the Terminology List

Dictionary Info Pane

Script Debugger Help > Explore > Dictionary > Dictionary Window >

Table of Contents

Terminology List >

Types of Entities Shown in the Terminology List

This is a list of the various types of entities shown in the terminology list in the dictionary window, as well
as in results from searching in the dictionary window and the dictionaries inspector.
Suite
A suite (

) is an artificial grouping of entities created by the developer of the application’s scripting

model. A suite can contain any other type of entity (except another suite), and in most
dictionaries, every dictionary entry is part of some suite. The terminology list displays all such
terms twice — first within their suites, and then by category.
Command
A command is a verb, something that you tell an application or one of its objects to do. The icon
distinguishes between a function (

), which returns a result, and a plain command (

does not. Command parameters are marked in a search result by

), which

.

Event
An event (

) is a message sent by an application to your code. Your code can receive this message

through an event handler. For example, Folder Actions are implemented through events; see the
Folder Actions suite in the Scripting Additions dictionary.
Dictionaries do not always distinguish events from commands, so Script Debugger may sometimes
classify events as commands.

Class
A class (

) is a datatype. A class can have attributes — properties (

) and elements (which are

themselves denominated as classes). Most of what you do in scripting an application involves
working with properties and elements. You get and set the values of properties, and you
manipulate elements in various ways (asking for particular elements or lists of elements, creating
new elements, deleting elements, and so forth).
Record
A record (

) is a sort of lightweight class, typically used only in communicating data between an

application and your script. Script Debugger distinguishes records from classes only when the
target application has an sdef-based dictionary (because only an sdef-based dictionary can draw
such a distinction).
Enumeration
An enumeration (

) is a datatype whose value is always one of a predefined list of constants (

).

For example, in some dictionaries the close command has a saving parameter whose value is a
member of the save options enumeration: either the constant yes or the constant no or the
constant ask. An enumeration’s constants are called its enumerators. Enumerations sometimes
have no English name, so in that case Script Debugger names them by their raw Apple event code.
In the dictionary info pane, each enumeration is listed, with its enumerators, on a page of its own. A
value type is shown as a hyperlink with the enumeration name. Click this link to see the enumeration’s
own page, listing its enumerator values. For example, the saving parameter of the close command
might be listed as the save options enumeration; to see the actual values you’re allowed to supply for

this parameter, you’d click save options to see the save options enumeration on its own page, where
the enumerators yes, no, and ask are listed.

Type
A type (

) is a built-in AppleScript datatype, such as boolean or text. It is not always obvious

what the distinction is between a Type and a Class. In some contexts, the difference is that a Class
can have attributes (properties and elements), but some dictionaries fail to draw this distinction
consistently.
Scripting Addition
This category appears only at the start of the Scripting Additions terminology list. Script Debugger
collects the dictionaries of all installed scripting additions into a single dictionary, but this category
lets you browse an individual scripting addition. A scripting addition category lists both suites and
categories, just as at top level, so in the Scripting Additions terminology list, a command (say)
might be shown four times: inside its scripting addition under its suite, inside its scripting addition
under its category (Commands), at top level under its suite, and at top level under its category
(Commands).
Individual scripting additions are marked as to their location, namely the ScriptingAdditions folder
in the Library at the system (

), computer (

), user (

), or network (

Summary of Symbols
# in a folder

Enumeration

# in a circle

Constant (Enumerator)

C in a circle

Class

C in a hexagon

Command

E in a hexagon

Event

F in a hexagon

Function (Command with result)

P in a square

Parameter

Pr in a square

Property

R in a circle

Record

S in a folder

Suite

T in a circle

Type

! in a triangle

PowerPC-only*

OS X-style X

System**

iMac display

Computer**

Person silhouette

User**

Network globe

Network**

) level.

* The PowerPC-only icon appears when Script Debugger is running natively on an Intel-based machine
and a scripting addition is PowerPC only. It alerts you to the fact that Intel-native AppleScript
environments, including Script Debugger, will not load this scripting addition. (But a Carbon applet, or
any application that executes AppleScript scripts and is not a universal binary and therefore runs under
Rosetta, will load such a scripting addition.)
** Scripting Addition icons reflect the location of the Library/ScriptingAdditions folder containing the
marked scripting addition file: /System, top level, the user’s home folder, or the network, respectively.
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Dictionary Info Pane

The info pane of the dictionary window displays the dictionary entry for one or more terms selected in
the terminology list or the object model diagram. Script Debugger’s display of dictionary entries has these
useful features:
Completeness. Script Debugger displays all the information in a dictionary, where other script
editor applications may omit some information.
Hyperlinking. Everything in blue with a dotted underline in a Script Debugger dictionary is a link.
You click this link to follow it. For example, in the first illustration below, every time the person class
is mentioned, it’s a link which you can click to jump to the dictionary’s entry on the person class. If
you’re in doubt about what any linked word means, click on it! (There’s no penalty for doing so, as
you can always come back afterwards.)
Note: links with solid underlines are external (i.e. somewhere on the Internet) and will be displayed in
your web browser.

Cross-Referencing. Script Debugger analyzes the dictionary and displays the resulting information
as cross-references. For example, at the bottom of the first illustration below, Script Debugger tells
you what classes can be the object of the pair command. In the second illustration below, showing
the alias entry from BBEdit’s dictionary, Script Debugger tells you every command that takes an
alias as a parameter, and every class that has a property that’s an alias. Every cross-reference is a
hyperlink.
Extra Information. Script Debugger optionally provides extra information about built-in AppleScript
types. For example, in the second illustration below, alias is a built-in AppleScript type. The
Description section is extra information, coming not from the dictionary of the application (BBEdit)
but from Script Debugger itself. This extra information is instructional and can be especially helpful
to AppleScript beginners.

The above illustration shows the typical features of a command as displayed in Script Debugger. The

command’s syntax is demonstrated by a template (“Function Syntax”), which you can insert into your
script. The result and parameters are clearly shown. (Not illustrated above: optional command parameters
are displayed in grey.) Classes (person) and types (boolean) are hyperlinks. Classes that can be the
object of this command are cross-referenced and hyperlinked.

The above illustration shows the typical features of a class as displayed in Script Debugger. The class’s
properties are clearly listed. Types (file, text) are hyperlinks. Commands where this class is a parameter,
and classes where this class is a property or element, are cross-referenced and hyperlinked. This particular
class is a built-in AppleScript type, so extra information about the type is provided in the Description
section.
The Find command (Search > Find) works within the info pane, and can be a useful way to locate
desired information quickly.

You can tweak several aspects of the info pane display:
You can change the size of the text.
You can set whether a class’s information should include properties and elements inherited from its
superclass.
You can set whether to display extra documentation supplied by dictionary authors, as well as Late
Night Software’s own explanations of AppleScript’s built-in classes.
You can set whether to reveal the raw Apple event codes for dictionary terms.
These settings apply to the dictionary display for one application at a time, and they are persistent (that is,
they are remembered the next time you open the dictionary window for that particular application).
Further Details:
Size

Inheritance
Extra Documentation
Apple Event Codes

Terminology List

Hierarchies and Diagrams
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Size

You can change the size of the text in the dictionary window’s info pane. To do so:
Choose Dictionary > Larger Text or Dictionary > Smaller Text, possibly several times until you get a
suitable text size. (You can also add a Text Size button to the dictionary window’s toolbar.)

Inheritance
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Inheritance

Script Debugger’s dictionary display can flatten the display of inherited attributes in the dictionary window’s
info pane.
So, for example, if inherited attributes are displayed, then the info for the Finder’s folder class shows you
the info for the container class (because folder inherits from container) and the item class as well
(because container inherits from item). In fact, the folder class has no attributes of its own; all its
properties are inherited from item, and all its elements are inherited from container.
To flatten the display of inherited attributes:
Choose Dictionary > Show Inherited Definitions. If this menu item is checked, the display of
inherited attributes is being flattened.
There is a different sort of dictionary flattening, which Script Debugger performs automatically. In some
dictionaries, an entry is repeated multiple times. For example, the information about the application
class might be distributed over two entries, each in a different suite. (So, for example, in TextEdit’s
dictionary, some application class information is in the Standard Suite, some of it is in the TextEdit
Suite.) In this case, Script Debugger will display the entry in its multiple locations, but in both places it
combines the information from both entries. Thus, no matter which instance of the entry you look at,
you will see all the information about that entry.

Size

Extra Documentation
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Extra Documentation

The modern sdef dictionary format allows entries in the dictionary to be more extensive than previously.
Besides a mere comment, dictionary authors can now include multiple formatted paragraphs of
explanation.
You can toggle the display of extended explanatory material in the dictionary window’s info pane. To
do so:
Choose Dictionary > Show Extra Documentation. If the menu item is checked, the extended
explanatory material is being displayed.
Script Debugger itself also provides some supplementary dictionary information that is “injected” into the
dictionary display, such as the Description of the alias datatype shown here. This supplementary
information is instructional and can be especially helpful to AppleScript beginners.

Inheritance

Apple Event Codes
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Apple Event Codes

In place of the English-like terminology in the dictionary window’s info pane, Script Debugger can display
the raw Apple event codes to which they correspond. This can be useful when you want to analyze a raw
Apple event (as displayed in the event log pane, for instance), or when you need to track down a
terminology clash.
To toggle the visibility of raw Apple event codes:
Choose View > Show Raw (Chevron) Syntax. If the menu item is checked, Apple event codes are
showing.
Or, click the Raw Syntax button in the dictionary window’s toolbar so that it is highlighted (white icon
on black background). The button is optional; if you don’t see it, you can add it by customizing the
toolbar.
You can also see raw Apple event codes in scripts, in an outliner, and in the event log window.

Extra Documentation
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Hierarchies and Diagrams

Script Debugger can portray the classes in a dictionary as arranged in two hierarchies — the containment
hierarchy and the inheritance hierarchy. Choose Dictionary > Show Object Model (or click Object Model
in the dictionary window’s toolbar).
To toggle between the two hierarchies, choose Dictionary > Show Containment (or click Contains) or
Dictionary > Show Inheritance (or click Inherits).
The containment hierarchy reflects the fact that an object has attributes (properties and elements),
and an attribute can be another object. Thus, in theory, it should be possible to start at the “top” of
the hierarchy (which is usually the single instance of the application class) and describe the
relationships between classes as a tree. This tree is sometimes referred to as the application’s object
model. The containment hierarchy expresses a “has-a” relationship among classes.
The inheritance hierarchy is an artifice originally introduced as a way of making dictionaries
smaller. For example, in the Finder, folder and disk are two different classes, but they have many
properties and elements in common. For instance, they both have an entire contents property
saying what’s in them, and they can both have folder elements and file elements reflecting the
hierarchy of items on disk. Thus it saves space, and makes conceptual sense as well, to encapsulate
these and all other attributes shared by folders and disks, and to express them as a separate class
(here called container). The folder class and the disk class are then said to inherit from the
container class, so that they share these properties and elements by virtue of this inheritance. The
inheritance hierarchy expresses an “is-a” relationship among classes.
Script Debugger’s dictionary display can flatten the display of inherited attributes in the info
pane. Click here to read more about this feature.

The above illustration (showing Safari’s containment hierarchy) is typical of what you’ll see in the object
model diagram.
Here are some clues about how the object model diagram works:
Click any term in the diagram to see the information for that term displayed in the info pane.
Thus, the diagram is an additional way to navigate the dictionary.
Note: There’s no separate dictionary entry for a property name, so when you select a property
name in the diagram, the info pane shows the info for that property’s class — and that class is
also automatically selected in the diagram.

Click the + or - button at the right end of any class’s name, to expand or collapse the hierarchy
shown in the diagram from that point.
In the containment hierarchy, tick-marks indicate a one-to-one relationship (a property) or a one-to-

many relationship (an element).
In the containment hierarchy, double-click a term in the diagram to dive into the hierarchy (the
term is hoisted to the top of the hierarchy display). The path widget at the top left of the diagram
shows you your place in the hierarchy and lets you navigate back up the hierarchy.
Some dictionaries have multiple separate inheritance hierarchies. In that case, buttons at the top left
of the diagram let you switch between them.
Click here for the meaning of the icons to the left of the attribute names.

Dictionary Info Pane

Search in Dictionary
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Search in Dictionary

You can search a dictionary within a dictionary window. To do so:
Show the toolbar (if it isn’t showing already) and use the Search field. The menu and keyboard
shortcut is Search > Look Up Definition. Type a term to search for in the Search field, and press
Return to initiate the search.
To specify search options:
Click the magnifying glass icon at the left end of the Search field. You can specify two kinds of
option:
Word containment. You can specify Equals, Contains, Begins With, or Ends With.
Where to look. This is divided into two sections.
What part of the info to search in: Names, Descriptions, Synonyms, and/or Apple
event codes. For example, if you’re searching for a term by name, you might want to
disable Description, as enabling it can lead to false positives.
What kinds of term to search in: Commands, Events, Classes, Records, Types,
Enumerations.
Search results are displayed in place of the terminology list at the left of the dictionary window. Results are
grouped alphabetically into relevance rankings. Click a listing to display it in the info pane. Thus, searching
is another way to navigate the dictionary.

To remove search results and restore the terminology list:
Click the X icon at the right end of the Search field (or click in the Search field and press the Esc
key).
Another way to search the dictionary is from a script window, through the dictionaries inspector.

Hierarchies and Diagrams

Look Up Definition
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Look Up Definition

You can search a dictionary from a script window, without having to switch to a dictionary window. To do
so, use the dictionaries inspector.

There are two approaches:
Select a term within the script’s text, and choose Search > Look Up Definition.
Show the dictionaries inspector (choose View > Inspectors Tab, or click the third Show button in the
script window toolbar), enter a term in the search field, and press Return to perform the search.
Search results appear in the dictionaries inspector. The list is similar to the list of search results that would
appear from searching in a dictionary window, and the icons for the kinds of term are the same. The
difference is that you have the ability to search the dictionaries of multiple applications at once!
For search options, click the magnifying glass icon in the dictionaries inspector search field. The options
are like the search options when you’re searching a dictionary in a dictionary window, with the additional
ability to specify what dictionaries to search. You can search in the dictionary of:
The tell target. This is the application targeted at the insertion point in the script.
Any of the categories of application listed in the dictionaries list in the Dictionary window and the
dictionaries inspector: Scripting Additions, Running, Recent, Favorites, and All.
Searching the dictionaries list can be time-consuming the first time you do it, because dictionaries must
be loaded and applications may have to be launched. But it will be fast after that because the dictionary
is cached (unless you’ve turned off that feature in the Dictionary preferences). When you start to search
dictionaries, a dialog will appear warning you of any applications that must be launched in order to load
their dictionaries, giving you a chance to prevent any or all of these applications from launching (in
which case their dictionaries will not be searched or cached).

Having performed a search in the Look Up Definition inspector, and having obtained results, to display a
result in its dictionary:
Select the result. The info for that term is shown in a split pane at the bottom of the Look Up
Definition inspector.
Double-click the result. The info for that term is shown in the frontmost dictionary window.

Search in Dictionary
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Back and Forward

As you work with a dictionary window, the window remembers everything displayed in the info pane. It’s as
if each display in the info pane were a web page. As in a web browser, you can go back to previously
viewed “pages”, and then forward again. To do so:
Choose Dictionary > Go Back or Dictionary > Go Forward (or use the convenient keyboard
shortcuts).
Or, use the Back/Forward buttons in the dictionary window’s toolbar.

Look Up Definition

Miscellaneous Dictionary Actions
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Miscellaneous Dictionary Actions

This page discusses some miscellaneous actions that you can perform in a dictionary window.
Paste Tell. You can insert a tell block into your script (at the current insertion point in the
frontmost script window), targeting the application whose dictionary you are currently looking at. To
do so:
Click the Paste Tell button in the dictionary window toolbar.
Or, choose Dictionary > Paste Tell XXX.
What’s pasted depends on what’s being viewed or selected in the dictionary window:
If what you’re looking at in the dictionary is a command, a template for giving that command
will be inserted.
If what you’re looking at in the dictionary is an event, a template for an event handler for
receiving that event will be inserted.
Otherwise, a simple tell block will be inserted.
Your existing code will not be overwritten. So Paste Tell is always safe (nondestructive).
If you hold down the Option key, or if no script window is open, a new script window is created and
the tell block is inserted.
You can paste a tell block for any application shown in the dictionaries list:
Control-click on it and choose Paste Tell XXX from the contextual menu.
There are other ways to issue a Paste Tell command.

Launch or Activate. You can start up the application whose dictionary you are looking at, or, if it’s
already running, you can bring it to the front. Use the Launch or Activate button in the dictionary
window toolbar (they are the same button), or choose Dictionary > Launch XXX or Dictionary >
Activate XXX (they are the same menu item), where “XXX” is the name of the application.
You can launch or activate any application shown in the dictionaries list:
Control-click on it and choose Launch XXX or Activate XXX from the contextual menu.
Quit. If the application whose dictionary you are looking at is running, you can make it quit. Use the
Quit button in the dictionary window toolbar, or choose Dictionary > Quit XXX, where “XXX” is the
name of the application.
If you do that in the Finder’s dictionary, you’ll get a warning dialog, since quitting the Finder is not
something one usually wants to do. If you do quit the Finder, you can relaunch it by clicking the
Launch button.
You can quit any application shown in the dictionaries list:

Control-click on it and choose Quit XXX from the contextual menu.
Reveal in Finder. To reveal in the Finder the application you’re currently working with in a
dictionary window, choose File > Reveal XXX in Finder, where “XXX” is the name of the application.
You can reveal any application shown in the dictionaries list:
Control-click on it and choose Reveal XXX in Finder from the contextual menu.
Paste Terms Block. You can paste a terms block (using terms from application) for any
application shown in the dictionaries list:
Control-click on it and choose Paste Using Terms From XXX.

Altered Dictionary Warning
If you alter the contents of your ScriptingAdditions folder while you have the Scripting Additions dictionary
window open — or if you’re a developer writing a scriptable application, and you alter that application’s
dictionary while you have the application’s dictionary window open — a Caution icon (

) will appear in the

dictionary window title bar. Click it, and you’ll get a dialog prompting you to reload the application’s
dictionary.

Back and Forward
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Application Explorer

The explorer in the dictionary window lets you probe the actual current objects of a running scriptable
application, in real time. You can easily discover an application’s object model, insert object references into
your scripts, and see the values of object properties — and even change those values.

To see a dictionary window’s explorer:
Open a dictionary window and choose Dictionary > Show Explorer (or click the Explorer button in the
toolbar).
The result is that an object explorer replaces the terminology list (or object model diagram) and info pane
in the dictionary window. The object being explored is the entire running application.
The application explorer in the dictionary window is one of many object explorer views that Script
Debugger provides. Click here to learn about explorers.
The tell context inspector in a script window can function as a miniature version of the application
explorer. It provides a more focussed way to probe an application’s current objects. It watches where
you are working in a script window and probes the attributes of the current tell target.

Further Details:
Tell Context Inspector

Dictionary Window
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Tell Context Inspector

The tell context inspector is a live outliner exploring the currently targeted application or object in your
script. Think of it as an automatically populated dictionary explorer, or as the Best view of the result pane
without your having to run or even compile the script.
The tell context inspector is in the Inspectors tab of a script window. To see the tell context inspector:
Choose View > Inspectors Tab.
Or, click the third Show button in the script window toolbar.

The tell context inspector lists the current elements and properties of the application or object targeted at
the point where you are working in your script (the current tell context). It automatically drills down along
with your script into successively deeper levels of tell context. For example:
tell application "BBEdit"
tell document 1
get word 1
end tell
end tell
In that script:
If you select in the second line, the tell context inspector shows the elements and properties of
BBEdit (the application object).
If you select in the third line, the tell context inspector shows the elements and properties of
document 1 of application "BBEdit".
To paste a tell block into the current script:
Click the Paste Tell button. Hold Option to paste into a new script.
To open a dictionary window for the currently targeted application:

Click the Dictionary button.
The tell context inspector is an outliner, with all that that entails.
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Explorer

An explorer is Script Debugger’s powerful, flexible, interactive way of displaying an AppleScript value.
Explorers appear in many places in Script Debugger’s interface.

A full-fledged explorer can be displayed in any of three views.
Best view. This view is “best” because it is most informative. If a value has properties or elements
(or both), Best view shows an outliner, which is Script Debugger’s powerful interface for interactive
study of a complex value. There can be more than one best view; for example, a date’s Best view
might show both an outliner and a date widget.
Source view. This view shows the value as the AppleScript language describes it.
AEPrint view. This view shows the value as an Apple event describes it.
To switch among views:
Choose View > Best View, View > Source View, or View > AEPrint View.
Or, click the Best, Source, or AEPrint button at the top right of the explorer.
You can show more than one view at once. To do so, hold Shift as you switch views. The result is a splitpane display of multiple views.
Various explorer view options and actions may be available, depending on what view is displayed and what
kind of value is being viewed.
Further Details:
Where Explorers Appear
Explorer Windows
Best
Source
AEPrint

Explorer View Options and Actions

Dictionary
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Where Explorers Appear

Explorers appear, or can be generated, in many parts of the Script Debugger interface. Basically, an
explorer is Script Debugger’s way of letting you understand and work with an AppleScript value, so
wherever a value needs to be shown, an explorer is used.
For example:
The explorer that appears in a dictionary window when you choose Dictionary > Show Explorer (or
click the Explorer button in the dictionary window’s toolbar) is an explorer. The object being explored
is a running scriptable application.

The result pane in a script window is an explorer. The object being explored is the result returned by
executing a script (or, if you’re debugging, the value returned by the most recently executed line of
code).
The event log’s second column (the Log Result column) is an explorer. The object being explored is
the result returned by the Apple event selected in the first column (the event list).
An error dialog may include an explorer. The object being explored is the problematic value.
In other places in the interface, a sort of “partial explorer” appears (the Best view outliner only, with no
choice of views and no path widget):
The tell context inspector in a script window is the outliner of an explorer. The object being explored
is the object being targeted by the innermost tell block surrounding the current selection in the
script.
The variables pane in a script window is the outliner of an explorer. The object being explored is the
top-level script object.
An explorer can also be generated as a separate window — an explorer window.
NOTE: When the value being explored by an explorer has changed, a red bar appears at the top of the
explorer. For example, in a script window, the result pane shows a red bar after each time you run the

script, because a newly generated result is being explored. An explorer window is another common case.

Explorer Windows

Script Debugger Help > Explore > Explorer >

Table of Contents

Explorer Windows

An explorer can be generated as a separate window — an explorer window. For example:
The result associated with script window can appear as a separate explorer window.
You can set an Execution preference so that this happens automatically (“Show result when
scripts pause or end” > “Show Result Explorer Window”).
Or, choose Script > Show Result Explorer Window.
Or, Control-click in the grey bar at the top of the result pane and choose Show Result Explorer
Window from the contextual menu.
The result of an Apple event recorded in the event log can appear as a separate explorer window.
Double-click an event in the log to open its result as an explorer window.
Or, choose Script > Show Result Explorer Window.
Or, Control-click the event and choose Show Event Log Result Explorer.
A value within the outliner of any explorer can appear as a separate explorer window. This includes
an outliner in an explorer window! Thus, it’s possible to generate a series, or cascade, of explorer
windows.
Control-click the value and choose Open Explorer Window from the contextual menu.
Or, select the value and choose File > Open Explorer Window.
In a partial explorer, you can alternatively double-click the value. (In a full-fledged explorer,
double-clicking a value hoists it.)

A separate explorer window, or a cascade of separate explorer windows, can be a way to focus more easily
on the information that interests you. This is demonstrated in the illustration below, which shows three
explorer windows spawned successively from a dictionary explorer (left to right):
1. target of Finder window "sd6"
2. folders of that target
3. folder "sd6docs" of those folders
4. creation date of that folder

NOTE: An explorer window has a toolbar, but the toolbars are hidden in the above screen shot, to save
space.

An explorer window maintains its linkage back to the explorer from which it was spawned. This linkage
expresses the full identity of the value being explored. To see an explorer window’s identity:
Control-click the explorer window’s title.
A pop-up menu appears. Each successive item in the menu is a step up the object model, as if there
were an implicit of between them. For example, in the illustration below, the explorer window is
showing the creation date of folder "sd6docs" of target of Finder window "sd6" (of the
application “Finder”).
Moreover, each menu item itself has a hierarchical menu exploring the entire object model of that
object! This is exactly parallel to the hierarchical menu attached to the Paste Tell menu item.

An explorer window remains “live”: it changes if the value being explored changes, provided Script
Debugger “knows” about the change. For example, an explorer window spawned off from a script window’s
result pane or variables pane may change its value spontaneously, because Script Debugger “knows” when
these values need to be refreshed (e.g., you ran the script again). In other cases, you might need to ask
Script Debugger to reload an explorer: choose Dictionary > Reload.

An explorer window may also close spontaneously if the value being explored ceases to exist. For
instance, an explorer window that is exploring a variable from the variables pane will close when the
variable goes out of scope. Similarly, an explorer window that is exploring an element of a class will
close if that class is refreshed and the element no longer exists.

To set defaults for the size, view, and display options of explorer windows:
Summon an explorer window, set its size and display options as desired, and choose Window > Set
Default Explorer Size & State.

Where Explorers Appear

Best
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Best

Best view in an explorer is Script Debugger’s most powerful way for you to examine, understand, and
interact with a value.
Best view is particularly significant in the following cases:
If the value being viewed is an object reference, the object’s elements and properties are shown as
an interactive outliner. You can discover object attributes and their values, learn how to reference an
object attribute, dive deeper into attributes that are themselves objects, and much more. This is one
of Script Debugger’s key features.
Similarly, if the value is a collection (a list or a record), the items of the collection are displayed in
an outliner.
If the value is a valid alias or file object reference, it is shown as a pathname that can be
displayed in different styles:
HFS (colon-delimited)
POSIX (slash-delimited)
Finder (i.e., as the Finder would refer to it)
You can also get a Quick Look view of the item (choose File > Quick Look, or press the Quick Look
button), or view the item in the Finder (choose File > Reveal XXX in Finder, or press the Finder
button).

If the value is image data, it is shown as an image.
If the value is HTML source, it is optionally rendered as in a browser. This behavior is governed by a
Dictionary preference, “Render HTML string values as HTML page”.
If the value is a date, it is shown as a date chooser, usually along with an outliner showing its
properties.
If the value is a string, it is shown directly as text (as opposed to source view, which shows a
quoted string, possibly containing escaped characters).
Best view also displays many types of Objective-C value coherently, in AppleScriptObjC code, without your
having to coerce them to AppleScript types. For example, here we generate an NSArray of NSStrings:
use framework "Foundation"
set s to current application's NSString's stringWithString:"the cat sat on the mat"
set arr to s's componentsSeparatedByString:" "

The result is an outliner displaying the elements of the array:

Read on to learn about how to use an outliner!
You can show more than one view at once. To do so, hold Shift as you switch views. The result is a
split-pane display of multiple views.

Further Details:
Outliner
Outliner Editing

Explorer Windows

Source
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Outliner

An outliner is an interactive hierarchical display of an object’s properties and elements. An outliner may
appear as Best view of an explorer or by itself as a separate view.
The display is in two columns: the name of an element or property, and the value of that element or
property.

Triangles
Any line in an outliner whose value is itself an object with elements and properties is indicated by a
triangle. Click a triangle to reveal or hide the elements and properties of that object. (Alternatively, select
a line containing a triangle and press Right Arrow or Left Arrow.) The chief cases of values with triangles
are:
An element collection. Element collections are displayed before properties, in boldface with a plural
name. For example, in the Finder, a folder may have items. The value is shown as the element
count (e.g., “8 items”).
An object with properties. For example, a date value has properties. In the Finder, an item’s
container is a folder and has elements and properties. The value is a reference to the object, as
provided by the owning application.
A list or record. The value depends on a Dictionary preference, “Show contents of list and record
values”: if checked, the value is a literal list similar to Source view; if unchecked, the value is shown
as the item count (e.g., “list of 2 items”).
A script object. The most common case is the variables pane, which itself explores a script object
(the script itself) and displays additional script objects such as parent and AppleScript.

Element Collections
When you reveal the elements of a collection, there may be a short delay as Script Debugger gathers
information about them. If there are many elements in a collection, Script Debugger may save time (and
Apple events!) by ceasing to gather information about them beyond a certain number. For example, run
this script and examine the Best outliner in the results pane:
tell application "Finder"
tell home
get folder "Library"
end tell
end tell
If you click the triangle next to items, some items are shown initially, followed by a Show More Items
button. The number of items shown initially in these situations is governed by a Dictionary preference,
“Show n elements at a time.”

Elements of a collection are initially gathered with reference to some particular specifier. The default
specifier is governed by a Dictionary preference, the “Access Elements by” pop-up menu. Your options are
Index, ID, and Name. You can change the reference specifier for an element collection using the pop-up
menu next to the collection’s name in the outliner.
If a reference specifier fails (because the scriptable application doesn’t respond to it), Script Debugger
automatically falls back on a different specifier and displays an exclamation-mark icon (

). For

example, the Finder doesn’t implement gathering a folder’s items by ID and has trouble with item of
list expressions; Script Debugger works around this behind the scenes, and displays the exclamation
mark.

The same pop-up menu next to the collection’s name can also be used to replace the collection displayed
with a single element. Your choices are First, Middle, Last, and Any.

Reloading
Gathering outliner information can be expensive and time-consuming (it involves sending a lot of Apple
events), so Script Debugger gathers information only when it has to:
When an outliner initially appears, only information visible within the pane or window is gathered.
When you scroll an outliner, revealed information is gathered if it hasn’t been gathered already.
When you expand a triangle, revealed information is gathered, up to the limit specified by “Show n
elements at a time,” as described above; when you click the Show More button, more information is
gathered.
Outliners connected with your script, such as the result pane and the variables pane, automatically refresh
their visible contents when you run the script or step while debugging. Otherwise, an outliner is not live. If
the situation in the target application changes, you can manually request that the outliner refresh
itself. To do so:
Select a line within the outliner and choose Dictionary > Reload (or choose Reload from a line’s
contextual menu). The value of that line, and everything exposed that’s hierarchically deeper, will be
gathered afresh.
You can also ask to reload the entire outliner. (But be careful, because this may cause Script Debugger to

send the target application a lot of Apple events!) To do so:
Hold Option and choose Dictionary > Reload (All Items). Or, choose Reload All from the contextual
menu.

Navigating an Outliner
When it appears as the Best view of an explorer, a value outliner has a path widget, along with back and
forth buttons. If you double-click any line within the outline, that line is hoisted so that the explorer is
now exploring that value.
In a “partial explorer” (with no path widget or Best/Source/AEPrint button), double-clicking a line
spawns off a separate explorer window.

The path widget displays a reference to what is being explored. When a value within an explorer is
hoisted, the path widget appends a reference to that value. Thus, the path widget always displays a chain
of references (equivalent to a nest of tell blocks) showing how you arrived at the value now being
explored. The highlighted reference in the path widget is the one currently being explored.

The references in the path widget are buttons. To navigate back up the chain of references:
Click a button to the left of the highlighted button in the path widget.
When you navigate up the chain of references using the path widget, the path widget continues to show
the full chain, in case you want to navigate back down it again. To navigate back down the chain of
references:
Click a button to the right of the highlighted button in the path widget.
Script Debugger also remembers each explored object (the explorer history list). To explore again a
previously explored object:
Click the Back button, or choose Dictionary > Go Back.
After using the Back button, you can use the Forward button, or choose Dictionary > Go Forward, to move
the other way through the history list.

Filtering
You can filter the outline to show only certain attributes. To do so, use the buttons in the scope bar.

Your choices are:
Filled Elements. If highlighted (dark), element collections that actually contain elements are shown
(element count is nonzero).
Empty Elements. If highlighted (dark), element collections that contain no actual elements are
shown (element count is zero).
Properties. If highlighted (dark), properties are shown.
If both Filled Elements and Empty Elements are highlighted, all element collections are shown. If neither

Filled Elements nor Empty Element are highlighted, no element collections are shown. If none of the
above buttons are highlighted, the outliner will be empty!

To highlight all three of the above buttons quickly and show the complete outline, choose Show All
Items, Properties & Elements from the contextual menu.
A second set of buttons lets you choose to show items with respect to recent changes in value:
Changed. If highlighted (dark), recently changed values are displayed (in red).
Unchanged. If highlighted (dark), the inverse set of values from Changed are displayed.
If neither Changed nor Unchanged is highlighted, the outliner will be empty!

The scope bar can be shown or hidden at will. Every explorer has a scope bar, including “partial explorers”
like the variables pane and even the expressions pane; the scope bar is these partial explorers is hidden by
default, to save space, but you can show it. To toggle the visibility of the scope bar:
Choose Show/Hide Scope Bar from the contextual menu.

Dictionary
You can jump from a line of the outline to the dictionary entry for that term. To do so:
Control-click on the line of the outline and choose Show Definition from the contextual menu.
The definition for that class (or, if it’s a property, for the class of which this is a property) will be
displayed in a dictionary window.

Raw (Chevron) Syntax
You can toggle between English terminology and raw Apple event codes in an outliner. To do so:
Choose Show Raw (Chevron) Syntax from the contextual menu.

Badges
Names in an outliner are badged according to their type.
Object values in an outliner are badged with the icon of the owning application.
Read-only scalar values in an outliner are badged with a crossed-out pencil icon (

).

Special Values
Error values (shown in orange, with a stop-sign icon) in an explorer are not problematic. They indicate that
Script Debugger asked for an element or property and the application responded, in good order, with a
runtime error. This is a valid response from the application.
A missing value result is also a valid response from the application.
An «empty» value is supplied by Script Debugger to indicate that the application has failed to return any
value at all. This is useful information, because if you assign such a nonvalue to a variable in a script, that
variable will be undefined.
In certain special cases, such as the entire contents property of the Finder, Script Debugger supplies a
not loaded value so as not to request evaluation of a property whose value could take the application a

very long time to return.

Editing in an Outliner
Read on to learn how you can edit a value or edit your script using an explorer’s outliner!

Outliner Editing

Script Debugger Help > Explore > Explorer > Best >

Table of Contents

Outliner Editing

In addition to viewing values in an outliner, you can edit those values, and use those values to help edit
a script.

Changing a Value
In an outliner, a scalar property value is writeable, and can be changed — unless it is badged with the
crossed-out pencil icon (

) indicating that it is not writeable.

Be careful! When you change the value of a property ultimately belonging to an application, you are
changing real world facts about that application in real time. For example, if you change the value of
the name property of a document file object belonging to the Finder, you change the actual name of
an actual file.
On the other hand, when you’re debugging a script and you use this feature to alter a value belonging to
the script (such as a variable), this feature is harmless and extremely useful.

To edit a simple scalar value (a string or number):
Select the line and press Return. Alternatively, choose Edit Value from the contextual menu.
The entry in the Value column will become editable. When you’re done:
Press Return or click elsewhere to make your change take effect.
If a value is an editable enumeration, it is represented as a pop-up menu listing the possible enumerator
values. To edit the value:
Choose a new value from the pop-up menu.

Editing a Script
A line of an outliner represents a reference to an element or property (or a variable). You can capture this
reference as AppleScript code, to use it in a script. To turn a line of an outliner into a reference:
Control-click a line of the outline, and choose Paste Tell from the contextual menu. A reference to
that object is pasted into the frontmost script. Hold Option to paste into a new script.
Or, drag-and-drop the line from the outliner into a script window.
Or, in a dictionary window, select the line; then press the Paste Tell button in the toolbar, or choose
Dictionary > Paste Tell XXX (where “XXX” is the name of the application). Hold Option to create and
paste into a new script window.
Select the line and choose Edit > Copy. Then paste wherever you want the reference to go.
Or, choose Copy Reference from the contextual menu. Then paste wherever you want the reference
to go.

A line of an outliner also represents the value of whatever it is a reference to. You can capture this value.
To turn a line of an outliner into a value:
Select the line, hold Shift, and choose Edit > Copy Value. Then paste wherever you want the value to
go.
Or, choose Copy Value from the contextual menu. Then paste wherever you want the value to go.

Outliner
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Source

Source view in a value explorer presents the value as the source language (AppleScript) would present it.

For example:
In Best view, an object reference is an outliner. In Source view, an object reference is the reference.
In Best view, a list is shown as an outliner. In Source view, a list is delimited by curly braces.
In Best view, a string is shown as the text of the string. In Source view, a string is delimited by
quotation marks.
When an explorer presents an Objective-C object value returned by AppleScriptObjC, source view becomes
Desc view, where “Desc” refers to Objective-C’s description method. In effect, Script Debugger shows
you the object as NSLog would show it in Xcode’s console. For example:
use framework "Foundation"
set f to current application's NSURLComponents's componentsWithString:"http://www.example.com"
The result, f, is displayed in Desc view as:
(__NSConcreteURLComponents) <NSURLComponents 0x7fb865871470> {
scheme = http, user = (null), password = (null),
host = www.example.com, port = (null), path = ,
query = (null), fragment = (null)
}
You can show more than one view at once. To do so, hold Shift as you switch views. The result is a
split-pane display of multiple views.

Best
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AEPrint

AEPrint view in a value explorer shows the value as it would be communicated through an Apple event.
Here’s the Finder’s desktop in AEPrint view:
'obj '{
'form':'prop',
'want':'prop',
'seld':'desk',
'from':[
0x0,
e00e "Finder"
]
}
In the event log, AEPrint view shows the Apple event messages sent to a scriptable application, as well as
the replies. Here, we’ve asked the Finder for its window 1:
'core'\'getd'{
'----':'obj '{
'form':'indx',
'want':'cwin',
'seld':1,
'from':null()
},
&'csig':65536 }
'obj '{
'want':'brow',
'from':[
0x0,
e00e "Finder"
],
'form':'ID ',
'seld':214
}
If you’re not someone who knows or cares about AEPrint format and raw Apple events, then don’t worry
about AEPrint view.
You can show more than one view at once. To do so, hold Shift as you switch views. The result is a
split-pane display of multiple views.

Source

Explorer View Options and Actions
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Explorer View Options and Actions

There are various options for how material is displayed in an explorer, and various actions you can perform.
What options and actions are available will depend on what view you’re in (Best, Source, or AEPrint) and
what sort of value is being explored.

Pretty-printing
Pretty-printing arranges text in lines, with indentations, to make a value easier to read. For example,
pretty-printing makes the difference between this (no pretty-printing):
{1, 2, 3}
and this (pretty-printing):
{
1,
2,
3
}
To control pretty-printing:
Choose View > Pretty Print.
Or, Control-click and choose Pretty Print from the contextual menu.
Or, click the Pretty Print icon

at the upper right of the view.

If the menu item is checked or the icon is dimmed, pretty-printing is turned on.

Other Display Options
Other display options are analogous to the display options for a script window:
You can toggle line wrapping on or off. Choose View > Wrap Lines or use the contextual menu.
You can show or hide tab stops. Choose View > Show Tab Stops or use the contextual menu.
You can toggle whether invisible characters are shown. Choose View > Show Invisibles or use the
contextual menu.
If invisible characters are shown, you can toggle whether spaces are shown. Choose View > Show
Spaces or use the contextual menu.

AEPrint
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Develop

Script Debugger gives you powerful, unique tools to help you develop your AppleScript code. From a short
one-off script to a complicated program, you’ll easily and quickly create code that works.
You can think of the AppleScript development cycle in three stages:
Edit your code.
Enter code, view it, navigate it, search it.
Run your code.
Compile code, execute it, time it, get the result, and log Apple event communication between your
code and scriptable applications.
Debug your code.
Step through code, set breakpoints, watch values change as your code progresses. Understand
what your code does, line by line!
Further Details:
Edit
Run
Debug

Explore

Reference
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Edit

Script Debugger is a dedicated editor for AppleScript programs. It’s designed to make it as easy as possible
for you to edit your AppleScript code.
Get to know the script window.
Learn about editing and navigating in the script window.
Further Details:
Script Window
Editing and Navigation

Run
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Script Window

Meet Script Debugger’s script window environment! This is where you will view, edit, run, and debug any
scripts that you create or open.

Here are the parts of the script window:
1. The toolbar.
2. The tab bar. Tabs let you work with multiple scripts in one window.
3. The navigation bar and “table of contents” pop-up menu.
The navigation bar describes where the current selection is.
Choose from the pop-up menu (the “table of contents”) to jump the selection to a
handler or other top-level entity.
4. The split and wrap icons.
5. The text area. This is where you edit the script. You can alter your view of the script’s contents.
6. The gutter (the column at the left edge of the window). Information appears in the gutter, such as:
Marker “droplets”
Error marks
Line numbers (optional)

Breakpoints (when debugging)
Code coverage marks (when debugging)
A secondary gutter contains code folding indicators.
7. The panes and inspectors tab. It occupies the right side of the window. What appears here
depends upon your choices in the View menu or the script window’s toolbar. You can see panes and
inspectors one group at a time, or you can remove the panes and inspectors tab entirely:
View > Result & Variables Tab (or the first Show button in the script window toolbar):
The result pane
The variables pane
The expressions pane
The call stack pane (when debugging)
The breakpoints pane (when debugging)
View > Resources Tab (or the second Show button in the script window toolbar):
The script’s description
The bundle inspector (if the script is in a bundle format)
View > Inspectors Tab (or the third Show button in the script window toolbar):
The clippings inspector
The dictionaries inspector
The tell context inspector
None of the above: The panes and inspectors tab is removed from the window. This can be
a way to save space.
8. The event log pane. It occupies the bottom of the window, below the text area. You will see it if
you have chosen View > Show Event Log. Use the event log to receive messages from your script
and to view Apple event messages that pass between your script and scriptable applications.
9. The status bar. It is the bottom border of the window, and displays messages reporting the status
of the most recent compilation attempt, the most recent error, or the paused status during
debugging. To control the visibility of the status bar, choose View > Show/Hide Status Bar.
The script window appearance is configurable, so you might want to save a certain size, shape, position,
and appearance as the default, so that whenever you create a new script, it has the look that you prefer.
If a script is open for editing in a script window or tab, you can open the same script in another window
without destroying the existing window or tab: choose File > Open in New Window. The result is a
document that’s being edited by multiple windows simultaneously. This is a good way to view different tabs
simultaneously (for example, you can see the Result pane in one window and the dictionaries inspector in
another).
Further Details:

View Options in a Script Window
Default Script Window Size and State

Editing and Navigation
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View Options in a Script Window

Script Debugger provides many options for helping you view your script in a script window.
Besides choosing whether to wrap long lines, you can also show or hide invisible characters and spaces, see
line numbers and tab stops, and even view your script’s raw Apple event codes.
Many of these options apply in other contexts as well, such as value explorers.
Further Details:
Line Wrapping
Invisibles
Spaces
Line Numbers
Tab Stops
Raw (Chevron) Syntax

Default Script Window Size and State
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Line Wrapping

How should lines of your script be displayed when they are too long for the width of the text area?
Script Debugger lets you choose to view long lines as wrapped automatically or to let long lines extend to
the right. To toggle line wrapping:
Click the wrap icon (at the upper right of the text area).
Or, choose View > Wrap Lines.
Or, choose Wrap Lines from the contextual menu.
If the menu item is checked (

), line wrapping is turned on.

If the menu item is unchecked ( ), line wrapping is turned off, and long lines will extend to the right and
a horizontal scroll bar will appear if necessary.

Invisibles
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Invisibles

Script Debugger lets you see invisible text characters, such as tabs and return characters. To see invisible
characters:
Choose View > Show Invisibles.
Or, choose Show Invisibles from the contextual menu.
If the menu item is checked, invisibles are showing.
Showing invisibles is especially helpful for viewing string literals. AppleScript compiles whitespace literals
into literal whitespace, which conceals their identity. For example, this script:
set s to "\t\r"
compiles like this:
set s to "
"
Now you’ve no idea what that string consists of. To find out, show invisibles.

This is particularly useful in the case of line endings, which can present a complicating factor in
AppleScript, as explained here.

Line Wrapping

Spaces
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Spaces

Script Debugger can show space characters in text. They are shown as small dots. To show space
characters:
You must first be showing invisible characters. Then:
Choose View > Show Spaces.
Or, choose Show Spaces from the contextual menu.
If the menu item is checked (and invisibles are showing), spaces are showing.

Invisibles

Line Numbers
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Line Numbers

Script Debugger can display your script with line numbers in the gutter. To toggle the visibility of line
numbers:
Choose View > Show Line Numbers.
Or, choose Show Line Numbers from the contextual menu.
If the menu item is checked, line numbers are showing.
The navigation bar also shows line numbers, and you can jump to a line by its number.

Spaces

Tab Stops
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Tab Stops

Script Debugger can display tab stops in text. Tab stops are the horizontal points at which indentation
automatically occurs when a script is compiled or when a value is pretty-printed. The positions of the tab
stops are shown by vertical lines behind the text. To show tab stops:
Choose View > Show Tab Stops.
Or, choose Show Tab Stops from the contextual menu.
If the menu item is checked, tab stops are showing.
The size of tab stops (the number of spaces to which each tab corresponds) is determined by the Editor
preference, “Tab Width.”

Line Numbers

Raw (Chevron) Syntax
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Raw (Chevron) Syntax

Script Debugger lets you view, in a script window, the raw Apple event codes corresponding to dictionary
terminology within a compiled script. This can help explain terminology clashes and other unexpected
AppleScript phenomena, and can give you a deeper understanding of the Apple events that your script is
constructing and sending.
To view raw Apple event codes:
Choose View > Show Raw (Chevron) Syntax.
If the menu item is checked, raw Apple event codes are showing.

You can also see raw Apple event codes in the dictionary, in an outliner, and in the event log.

If you’re seeing raw Apple event codes unexpectedly in a newly opened script, it may be because
something has gone wrong with the decompilation process.

Tab Stops
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Default Script Window Size and State

The appearance of a new empty script window is up to you. To set the appearance of new script
windows:
1. Create a new script window and set it up the way you want it. This might include such features as:
Size
View options
Configuration of panes and inspectors, including the event log
2. Choose Window > Set Default Script Size & State.
From now on, new script windows will have these same characteristics.
Note: Aspects of the content (such as text) of a script are not part of the default script window
appearance. To preserve script content for reuse in new scripts, make a user template.
To revert to Script Debugger’s default appearance for new windows:
Choose Window > Reset Default Script Size & State.

View Options in a Script Window
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Editing and Navigation

Script Debugger provides tools to make editing and navigating your script as fast and effortless as possible.

Editing
Script Debugger helps you create, view, and select block structure and delimiter pairs.
Script Debugger helps you type. It completes AppleScript terms for you, plus you can define your own text
substitutions. And there are other miscellaneous helpful typing and selection features.
You can easily insert a tell block, or any common control structure or other boilerplate, into your script.
You can also insert content from the Finder or a dictionary window or explorer window to save typing.
You can paste a string literal, shift indentation levels, add or remove comments, and interchange tab and
space characters.
If all of that isn’t enough, you can edit your script with an external editor.

Navigation
Script Debugger has powerful find-and-replace features.
You can split a script window’s editing area, so as to view and edit multiple regions of your script
simultaneously.
You can jump to a line by number, or navigate to a section of code within your script by means of the table
of contents menu.
Further Details:
Block Structure
Delimiters
Code Completion
Text Substitution
AppleScriptObjC Refactoring
Miscellaneous Typing and Selection
Tell Blocks and Terms Blocks
Clippings
Inserting Content
Shift
Comment
Tab
Splitting the Editor
Find
Go To Line
Navigate

External Editor

Script Window
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Block Structure

Blocks are a characteristic and pervasive feature of AppleScript: a tell line is balanced by an end tell line
(forming a tell block), a repeat line is balanced by an end repeat line (forming a repeat block), and so
forth, and blocks are nested inside each other to form the logic of your script.
Script Debugger makes it easy to create, select, view, and collapse your code’s block structure.
Creating a block is easy, because Script Debugger provides auto-closing: when you type Return in
the opening line of a block, Script debugger automatically generates the end line of the block for
you.
Selecting a block is easy, thanks to Script Debugger’s balance command.
Viewing a block is easy, thanks to block shading.
To collapse a block, take advantage of Script Debugger’s code folding.
Further Details:
Auto-Closing
Balance Command
Block Shading
Code Folding

Delimiters
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Auto-Closing

Auto-closing is a text entry feature that makes it easy to create a block of AppleScript code. When you
type Return in the opening line of a block, Script Debugger automatically generates the end line of the
block for you.
For example, if you type repeat and press Return with auto-closing turned on, Script Debugger creates a
corresponding end line (which will compile to end repeat), and positions the insertion point in between,
ready for you to enter the content of the block. This works also for lines beginning with tell, on, script, if,
try, using, considering, and ignoring. Script Debugger’s auto-closing feature is intelligent; if there is
already a corresponding end line, Script Debugger won’t create one.
You can turn on auto-closing in general, or use it on single occasions. To pick an auto-closing policy:
In the Editor preferences, check or uncheck “Auto-close AppleScript blocks (end tell, etc.).”
If checked, auto-closing is turned on in general. To turn auto-closing off on a single occasion, hold
Control as you press Return at the end of a block-starting line.
If unchecked, auto-closing is turned off in general. To turn auto-closing on on a single occasion,
hold Control as you press Return at the end of a block-starting line.

Balance Command
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Balance Command

The Balance command makes it easy to select a block:
Choose Edit > Balance.
Or, choose Balance from the contextual menu.
Each time you choose Balance, Script Debugger selects the block enclosing the current selection.
Thus, if you choose Balance repeatedly, you select the block enclosing the selection, then the block
enclosing that block, then the block enclosing that block, and so on.
The Balance command selects other things besides blocks. If the initial selection is between a pair of
delimiters, the delimiters and everything between them will be selected first. If the initial selection is within
a comment, the comment will be selected first.

Auto-Closing

Block Shading
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Block Shading

To clarify the block structure of your script visually, you can hover the mouse in the gutter (the area to the
left of the script text). Script Debugger outlines the nested block structure, starting with the block to the
right of the mouse, in successively darker shades of grey.

To turn on block structure shading:
In the Editor preferences, check or uncheck “Highlight blocks when mouse hovers in gutter.” If
checked, block structure shading is turned on.
When this feature is turned on, you can also select a block. To do so, click the mouse in the gutter when
you see the nested block structure outlined. Click successively to select the next block outwards. This is
similar to choosing Balance repeatedly.
Another way to see block structure is to use code folding.

Balance Command

Code Folding
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Code Folding

Code folding calls attention to the block structure of your code, and also permits you to collapse a block,
hiding everything but its first line — thus saving space and helping you to view and understand the larger
structure of your code.

Code folding is a document-level feature. To toggle code folding on or off for the current script:
Choose View > Show Code Folding so that it is checked or unchecked.
If code folding is off, blocks cannot be collapsed, and code folding commands are disabled. The rest of the
discussion on this page assumes that code folding is on!
A block can be expanded or collapsed:
When a block is expanded, you see all its code. The first line of the block is marked by a downpointing triangle, and the corresponding end line is marked by a matching up-pointing triangle.
When a block is collapsed, you see only the first line of the block, which is marked by a rightpointing triangle. The hidden content is represented by an ellipsis in a cartouche. This cartouche is
selectable; if you copy it and paste it elsewhere, what’s pasted is the content that was hidden
(everything after the first line of the block, up to and including the last line of the block).
To see an expanded block:
Hover the mouse over one of the triangles. Both triangles are highlighted, and you get block
shading.

To collapse an expanded block:
Click the down-pointing triangle.

Or, click the up-pointing triangle.
Or, select anywhere within the block and choose Edit > Code Folding > Fold.
To expand a collapsed block:
Click the right-pointing triangle.
Or, select anywhere in the first line of the block and choose Edit > Code Folding > Unfold.
There are also several global folding commands — they affect the entire script, and the selection doesn’t
matter:
Edit > Code Folding > Unfold All. Expands all collapsed blocks.
Edit > Code Folding > Fold / Unfold Handlers. Collapses or expands all handlers (blocks that start
with on).
Edit > Code Folding > Fold / Unfold Block Comments. Collapses or expands all block comments
(blocks that start with (*).

Block Shading
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Delimiters

You can enter, view, and select delimiters in pairs. Possible delimiter pairs include:
Opening and closing double-quotes "" (some delimiter commands ignore these)
Left and right parentheses ()
Left and right square brackets []
Left and right curly braces {}
Left and right chevrons «» (rarely used)

Delimiter Entry (Auto-Pairing)
Auto-pairing means that when you type the first of a pair of delimiters, the second delimiter is
automatically typed for you.
When you type an opening delimiter with auto-pairing on, the second delimiter appears, and the insertion
point is positioned between them, ready for you to type the delimited contents.
To pick an auto-pairing policy:
In the Editor preferences, check or uncheck “Auto-pair delimiters ([{""}]).”
Auto-pairing is intelligent:
Type closing delimiter to skip closing delimiter: When the insertion point is before a closing
delimiter that was entered automatically through auto-pairing, if you type the closing delimiter,
Script Debugger knows that this is the same closing delimiter that is already present, and skips
past the closing delimiter, positioning the insertion point after it.
Surround the selection: Optionally, when text is selected, if you type an opening delimiter with
auto-pairing on, the selected text is not replaced; instead, the selected text is surrounded with
opening and closing delimiters. This feature is governed by a preference:
In the Editor preferences, check or uncheck “Wrap selection with delimiters.”

Delimiter Checking As You Type (Auto-hilite)
Auto-hilite means that when you type the second of a pair of delimiters, the first delimiter is
momentarily highlighted. This confirms that you’re balancing delimiters as intended.

If there is no prior matching first delimiter, Script Debugger beeps. This alerts you that the closing
delimiter is unbalanced.

To pick an auto-hilite policy:
In the Editor preferences, check or uncheck “Auto-hilite opening ([{ when typing closing }]).”
Use the slider to set how much delay there should be before the opening delimiter is highlighted.
Check “Scroll if necessary” checkbox if you want Script Debugger to scroll backwards
momentarily, if needed, to reveal a balancing opening delimiter that’s not currently visible.

Delimiter Selection (Balance)
Balance means that you select everything within a pair of delimiters. Script Debugger starts with the
current selection or insertion point and looks outward until it reaches a pair of balanced delimiters. To
balance:
Choose Edit > Balance.
Or, choose Balance from the contextual menu.
To determine whether balancing should incorporate the delimiters themselves in the selection:
In the Editor preferences, check or uncheck “Balance includes enclosing ([{ }]) delimiters.”
If checked, Balance selects everything including the surrounding delimiters.
If unchecked, Balance selects everything within the surrounding delimiters.
Balance considers a comment to be a delimited thing. If you choose Balance when the selection is within a
single-line or multi-line comment, the comment will be selected.
Balance considers a block to be a delimited thing. If you choose Balance when the selection is within a
code block, the block will be selected.
Balance repeatedly to keep selecting outwards.
Balance is the same feature used for block selection.

Block Structure

Code Completion
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Code Completion

Code completion means that you type the start of an AppleScript term and the rest of the term is typed
for you.
To summon code completion:
Press Esc. A list of possible completions appears.

This is essentially the same as the Complete or auto-suggestion functionality that appears generally in
Cocoa applications such as TextEdit, Pages, and so on. Script Debugger creates a list of possible
completions, based on:
Identifiers in the script itself (such as handler names)
AppleScript terminology
Scripting addition terminology
Terminology of the application targeted by the current tell context
Terminology imported by a use script statement
Cocoa terms imported by a use framework statement

Certain code completions help you construct a tell or terms target or a use statement:
Code completion after app " or application " produces a list of running, recent, and favorite
applications. Choosing from the list enters the name of the application. (If your text says app id " or
application id ", choosing from the list enters the application’s id.)
Code completion after script " produces a list of available library scripts.
Code completion after framework " produces a list of frameworks commonly targeted by

AppleScriptObjC.
To accept a completion:
Navigate the list with arrow keys to select the completion, and press Return.
Or, double-click the desired completion.
To cancel completion:
Press Esc.
Some completions involve placeholders, similar to clippings. For example, if a code completion is a handler
call, and if that handler takes parameters, the parameters are placeholders.

Code Completion Keyboard Shortcuts
While a term is undergoing code completion, certain special keyboard shortcuts become available. This is
best explained by an example:

In the above screen shot, we have typed stringByA followed by Esc to get code completion. At this
moment:
Pressing left arrow or delete reduces the original typing by one character. If, starting from the
screen shot, we press left arrow, we are now completing stringBy, and lots of additional
completions appear, such as stringByDeletingLastPathComponent.
Pressing right arrow increases the original typing by one character. If, having pressed left arrow,
we press right arrow, we are now completing stringByA once again.
Pressing Tab increases the original typing by one camelCased word or to the next internal
underscore. If, starting from the screen shot, we press Tab, we are now completing
stringByAppending, and our choice of completions is reduced to four.

AppleScriptObjC Completions
AppleScriptObjC completions are offered intelligently, based on:
use framework statements. Completions will be offered only for frameworks actually used.
A use AppleScript version statement. The system implied by the AppleScript version is the latest
version for which completions will be offered.
Context. It helps if you use the possessive syntax illustrated in the examples.
Terminology clash. Pipes are inserted where clash would otherwise occur.
A target, such as current application's or its, is inserted as needed; your settings determine the details.

Each AppleScriptObjC completion offered is accompanied by a notation stating its type. These are:
Types

Delimiters

[class]

A class name

[const]

A constant

[=#]

An enum numerically equivalent to #

[ƒ type]

A function returning type

[+ type]

A class method returning type

[- type]

An instance method returning type

Text Substitution
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Text Substitution

You can define abbreviations with substitutions; you type an abbreviation and it is replaced by the
substitution. Replacement occurs automatically when you type a nonword character (punctuation or lineending) after an abbreviation.
This can be a convenient way to enter boilerplate text, commonly used control structures and commands,
or characters that are difficult to type directly; it can also be a form of automatic spelling correction.

To enable or disable text substitution:
In the Text Substitution preferences, check or uncheck “Enabled”.
To manage the list of abbreviations and substitutions:
Use the Text Substitution preferences:
Click the + button to create a new substitution.
Click the - button to delete a selected substitution.
Double-click in the Replace or With column to edit text.
To disable an individual substitution even if text substitutions are enabled, uncheck the On
checkbox.
Text substitutions use the same expansion tags as clippings. Thus, the text inserted through a text
substitution can contain placeholders, of which one may initially be selected.
You can also export the entire set of text substitutions (in .plist format) or import a previously exported set
of text substitutions.

Code Completion

AppleScriptObjC Refactoring
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AppleScriptObjC Refactoring

Four Edit menu items help keep your AppleScriptObjC code neat.
To understand what they do, let’s take an example. Consider this code:
set ss to current application's NSString's stringWithString:s
set regex to current application's NSRegularExpressionSearch
That code illustrates an essential problem with AppleScriptObjC code: everything must be explicitly
targeted at the current application. AppleScriptObjC refactoring reorganizes that sort of code so that
Cocoa names like NSString and NSRegularExpressionSearch are defined as properties of your script. Your
code can then use the bare property names as a shorthand.
Thus, given the above code, if you choose Edit > AppleScript Objective-C > Migrate to Properties, your
code is refactored into two pieces. First, some property definitions are inserted at the start of the script:
-- classes, constants, and enums used
property NSRegularExpressionSearch : a reference to 1024
property NSString : a reference to current application's NSString
Then, the code itself has current application's stripped out, so that the Cocoa names become the names
of the script properties:
set ss to NSString's stringWithString:s
set regex to NSRegularExpressionSearch
The extra work up front — the use of property declarations early in your code, along with the a reference
to locution — streamlines your use of Cocoa terms later, reduces overhead at runtime, and avoids some
other undesirable side effects.
There are four Edit > AppleScriptObjC hierarchical menu items connected with refactoring:
Edit > AppleScriptObjC > Migrate to Properties
Performs the refactoring described above for the entire script.
Edit > AppleScriptObjC > Migrate to Properties in Selection
Performs the refactoring described above for just the selected code.
Edit > AppleScriptObjC > Use Properties for Cocoa Terms
If checked, then when code completion or a clipping inserts Cocoa terms, it performs refactoring at
the same time. An Editor preference, “Use properties for Cocoa terms in completion, clippings”,
governs this behavior in general; this menu item lets you override that setting for an individual
script.
Edit > AppleScriptObjC > Copy as Standalone Code

Copies the selected material to the clipboard. If that material is refactored as described above, the
clipboard copy is unrefactored. Thus, for example, if you were to copy set ss to NSString's
stringWithString:s as standalone code, it would be copied as set ss to current application's
NSString's stringWithString:s, suitable for pasting into a different script (and then refactoring
there, if desired).
Refactoring requires that the script be compiled, so these menu items (except for Use Properties, which
is a setting) are disabled if the script needs compilation.

Text Substitution

Miscellaneous Typing and Selection
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Miscellaneous Typing and Selection

Here are some miscellaneous typing and selection features of Script Debugger.
To navigate with the keyboard, Script Debugger supports a full repertoire of keyboard navigation
shortcuts:
Right Arrow and Left Arrow navigate by character.
Option-Right Arrow and Option-Left Arrow navigate by word.
Command-Right Arrow and Command-Left Arrow navigate to the two ends of the current line.
Option-Up Arrow and Option-Down Arrow navigate a line at a time.
Command-Up Arrow and Command-Down Arrow navigate to the start and end of the script.
To select with the keyboard:
Add Shift to the above keyboard navigation shortcuts.
To select a line:
Triple-click on the line. You can triple-click-drag to select a stretch of lines.
Click to the left of the line. Just to the right of the gutter is a narrow area where this click works to
select a line. You can click-drag to select a stretch of lines.
Click or select anywhere within the line and then type Shift-Command-Right Arrow, Shift-CommandLeft Arrow. You can then use Shift-Up Arrow or Shift-Down Arrow to select a stretch of lines.
To start a new line:
Press Command-Return. No matter where the insertion point or selection is in the current line, the
current line will be abandoned, and a new line will be inserted below the current line, with the
insertion point at its start, ready to type.
To append an AppleScript line-continuation character to the current line at the same time, press
Command-Option-Return.
This feature may be combined with auto-closing; for example, if you start in the middle of a tell line
and press Command-Return, then if there is no corresponding end line, the end line will be created
if auto-closing is turned on.

AppleScriptObjC Refactoring

Tell Blocks and Terms Blocks
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Tell Blocks and Terms Blocks

There are many ways to create a tell block targeting a particular application. This is valuable because
scripting an application with a tell block is so common when using AppleScript.
Moreover, you can create a tell block containing a reference to an object within the targeted application,
or containing a command or function template.
Some ways of creating a tell block are also ways of creating a using terms from block.

Use code completion, in a script:
Type tell app " or tell application " and press Esc. This produces a list of running, recent,
and favorite applications to choose from.
Use text substitution, in a script:
Type ta (meaning “tell application”) followed by a space. A tell block is created, and the
application name is a selected placeholder, ready for you to type the name of an application —
or press Esc to choose from a pop-up list of running, recent, and favorite applications.
In a script window’s menus:
Choose Edit > Paste Tell.
Or, Control-click and choose Paste Tell from the contextual menu.
The hierarchical Paste Tell menu contains the same shortened version of the dictionaries list (without
the All category) that appears in the File > Open Dictionary menu. In the menu:
Choose an application to insert a tell block targeting that application.
Moreover, for running applications, each application in the Paste Tell menu has its own
hierarchical menu that lets you navigate its object hierarchy, much as if this menu were
the outliner of an explorer. Choose an object to insert a tell block targeting that application
and referring to that object.

Hold Option to insert the tell block into a new script.
In a script window’s dictionaries inspector:
Select an application and click Paste Tell or Paste Using. Alternatively, choose Paste Tell XXX or

Paste Using Terms From XXX from the contextual menu.
Click open the triangle next to an application’s name to see a list of that application’s
commands and functions. Select a command or function and click Paste Tell. You’ll get a tell
block with a command template.
Hold Option to paste into a new script.
In a script window’s tell context inspector:
Select an object reference and click Paste Tell.
You’ll get a tell block referring to that object.
In a dictionary window:
Choose Dictionary > Paste Tell.
Or, click Paste Tell in the dictionary window’s toolbar.
Or, Control-click in the dictionaries list and choose Paste Tell XXX (or Paste Using Terms From
XXX).
Control-click in the terminology list and choose Paste Tell XXX.
If the focus is on a command or event, you’ll get a tell block with a command template. Hold Option
to paste into a new script.
In a dictionary window’s explorer:
Select an object reference and click Paste Tell in the toolbar.
Or, choose Dictionary > Paste Tell XXX.
You’ll get a tell block referring to that object. Hold Option to paste into a new script.
In an outliner (including the result pane, the dictionary window’s explorer, and so on):
Control-click on a line of the outliner and choose Paste Tell from the contextual menu.
Or, drag a line of the outliner into your script.
You’ll get a tell block referring to that object. Hold Option (while choosing from the contextual
menu) to paste into a new script.
In the Finder:
Drag-and-drop an application into your script window. A dialog appears asking what you want
to do. One option is to paste a tell block targeting that application.
(Alternatively, drag-and-drop an application’s name from the dictionaries inspector into your
script window. Or, drag-and-drop from the dictionaries list in a dictionary window into your script
window.)

Miscellaneous Typing and Selection

Clippings
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Clippings

Clippings are bits of boilerplate text that you can insert into your code. Clippings are accessed from
within Script Debugger in two main places:
The Clippings menu (

).

The clippings inspector. It is in the Inspectors tab of a script window. To see the clippings
inspector:
Choose View > Inspectors Tab.
Or, click the the third Show button in the script window toolbar.

You can insert a clipping into your script in any of the following ways:
Choose it from the Clippings menu.
Or, control-click in a script window’s text area and choose Paste Clipping from the contextual menu.
The hierarchical menu contains the same clippings as the Clippings menu.
Or, in the clippings inspector, double-click a clipping.
Or, in the clippings inspector, select a clipping and click Paste Clipping.
Searching in the clippings inspector searches both the titles and the contents of clippings.

Selection Wrapping
A clipping can wrap the current selection. This allows you to incorporate existing text in your script into
the heart of the clipping as the clipping is inserted.
For example, you might realize that part of your script needs to be repeated, so you’d like to wrap it in a
repeat block. Select the text and then choose a repeat block clipping, such as “repeat n times”. A repeat
block is inserted, wrapped around the text that you selected.

Placeholders

A clipping can include placeholders. A placeholder is displayed (in an uncompiled script) as a stretch of
text in a rounded rectangle. The idea is that you can easily select an entire placeholder, and type or paste
to replace it with the desired text.
To select a placeholder:
Press Tab. Each time you press Tab, the selection cycles to the next placeholder. (Alternatively, press
Shift-Tab to cycle in reverse order.)
Or, choose Edit > Go to Next Placeholder or Edit > Go to Previous Placeholder.
Or, click on the placeholder. The entire placeholder is selected.
Placeholders that you don’t edit are replaced by normal text when you compile your script. Or, to accept a
placeholder, replacing it with normal text immediately, select the placeholder and:
Press Return or Esc.
Or, choose Edit > Commit Placeholder.
If you’re interested in creating your own clippings, read on.
Further Details:
How Clippings Work

Tell Blocks and Terms Blocks

Inserting Content

Script Debugger Help > Develop > Edit > Editing and Navigation >
Clippings >

Table of Contents

How Clippings Work

Script Debugger provides clippings corresponding to all commonly used AppleScript control structures, and
you can add your own clippings. Clippings are text files in ~/Library/Application Support/Script Debugger
6/Clippings; you are free to add text files here.

Clipping Names and Menu Order
The name of a clipping file (stripped of its file extension suffix) is the name of the clipping, and clippings
appear in alphabetical order in the Clippings menu and clippings inspector. To allow modification of this
order, the following rules apply:
A file will appear as a menu item. A folder will appear as a hierarchical menu, and the files inside it will be
its menu items. The name of a file (or folder) is the name that will appear in the menu, except that certain
names or part-names are hidden and used for determining the order of the menu, as follows:
If a name starts with the prefix #), where # is a whole number of any length, that number
determines the position of this item in the menu and the prefix does not appear in the menu item’s
name.
A name #)-*** will appear as a menu separator, again with its order determined by the whole
number #.

Clippings Actions
To edit a clipping:
Choose it from the Clippings menu, or double-click it in the clippings inspector, while holding down
the Option key.
Or, select the clipping in the clippings inspector and click Edit Clipping.
To reveal a clipping file in the Finder:
Choose it from the Clippings menu, or double-click it in the clippings inspector, while holding down
the Shift key.
Or, in the clippings inspector, select the clipping and choose Reveal in Finder from the contextual
menu.

Expansion Tags
A clipping’s text is pasted literally into your script, except for the following expansion tags which are
interpreted intelligently:
[[select:text]]
Displays text and also selects it.
[[linked-template:text]]

Displays text as a placeholder. If the same text is used as a placeholder multiple times, the
placeholders are linked — editing one of them edits all of them simultaneously.
[[unique-template:text]] or simply [[template:text]]
Displays text as a placeholder. If the same text is used as a placeholder multiple times, the
placeholders are not linked.
NOTE: The template text application, applicationid, applicationhfs, applicationposix, library, and
framework is interpreted specially: when selected, if the user asks for code completion, a pop-up menu
of applications, library scripts, or frameworks appears. The four application templates differ in what is
entered when the user chooses from the pop-up menu — the application’s name, id, HFS path, or POSIX
path, respectively.

[[user]]
Displays the user’s full name.
[[account]]
Displays the user’s short name (seen when using the users command in the Terminal).
[[copyright]]
Displays the copyright string from the General preference pane.
[[organization]] (or [[org]])
Displays the user’s company name, as shown in the Company field in the user’s Contacts entry. (If
that field is blank, displays “MyCompanyName” as a placeholder.)
[[date]]
Displays the date in the format mm/dd/yy hh:mm:ss. For alternate formats, you can use
[[short-date]], [[long-date]], [[short-time]], and [[long-time]], which are configured in your
System Preferences (Language & Region > Advanced). For the year alone, use [[year]]. For
ultimate flexibility, you can specify a custom date format by saying [[date:format]] where the
format is an unquoted strftime() format string.
[[selected-lines:default text]]
Displays the complete lines containing the script’s current selection. If the current selection is just
an insertion point in an empty line, default text is used, and is displayed as a placeholder.
[[selection:default text]]
Displays the script’s current selection. If the current selection is just an insertion point, default text
is used, and is displayed as a placeholder.
[[VARNAME]]
Displays the value of the VARNAME environment variable. So, for example, [[SHELL]] would be
expanded to something like /bin/bash. Anything in double brackets that doesn’t match one of the
preceding tag types is taken to be the name of an environment variable. If there is no matching
environment variable name, the tag is left unchanged; for example, [[howdy]] becomes [ 
[howdy]].

Applescript Directives
A number of directives devised for use in AppleScriptObjC clippings result in special behavior. You’ll
probably never use these directives, but you might see them in the clippings and wonder what they mean,
so here they are:
[[*framework:frameworkname]]
Ensures that a use statement for this framework is present at the start of the script.
[[template:trueOrFalse]]

Displays a placeholder which, when accepted, presents a choice of true or false.
[[template:missingValueOrReference]]
Displays a placeholder which, when accepted, presents a choice of missing value or reference.
[[*piped:someterm]]
Displays someterm, checking for terminology clash and surrounding someterm with pipes if needed
to avoid the clash.
[[*class:classname]]
Displays classname, checking for terminology clash, and adding code so that it is treated as an
AppleScriptObjC class name. For example: current application's NSString.
[[*constant:constantname]]
Displays constantname, checking for terminology clash, and adding code so that it is treated as an
AppleScriptObjC constant name.
[[*enum:value:enumname]]
Displays enumname, checking for terminology clash, and adding code so that it is treated as an
AppleScriptObjC enum name. The value is optional; if present, it is an integer, and is used as the
value of the enumeration.
The precise behavior of the last three directives depends on the Editor preference setting for “Use
properties for Cocoa terms,” possibly overridden by Edit > AppleScriptObjC > Use properties for Cocoa
terms. If not checked, current application is inserted directly. If checked, a property declaration is
inserted near the start of the script, such that the bare term is sufficient in its context.
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Inserting Content

There are many convenient shortcuts for inserting content into your script from elsewhere. Here’s a
summary.
You can create a tell block in many different ways, including a tell block containing a command
template or an object reference.
You can type an abbreviation corresponding to a text substitution.
You can type the start of an AppleScript term and let be completed automatically.
You can take use auto-closing to enter end lines automatically, and auto-pairing to enter closing
delimiters automatically.
You can paste a clipping to insert boilerplate, such as an AppleScript control structure.
From the Finder, drag-and-drop a file or folder into your script. A dialog appears asking what you want
to do.
If what you dragged is an application, one option is to insert a tell block targeting that application.
You can insert the name, alias, or pathname (POSIX or Macintosh-style) of the dropped items.
Multiple dropped items are combined into a list.
You can insert an object specifier (reference) suitable for use in a tell block targeting the Finder.
If what you dragged is a text file, you can insert its contents.
In a dictionary window, in addition to the various Paste Tell commands, you can also use drag-anddrop:
Drag from the dictionaries list at the left of the dictionary window into a script. The effect is the
same as dragging the application from the Finder.
Drag from the terminology list into a script. The effect is the same as choosing Paste Tell.
In an explorer’s outliner:
Drag-and-drop a line of the outline into your script. You’ll get a paste tell referring to the dragged
object. Alternatively, select the line, choose Edit > Copy, and paste into your script.
If what you want to insert into your script is the value of a property, Control-click on the property
and choose Copy Value (or hold Shift and choose Edit > Copy), and then paste into your script.

Clippings

Shift
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Shift

You can remove or add a level of indentation to the selected lines. To change the indentation level:
Select some text and choose Edit > Shift Left or Edit > Shift Right. (You can also add Shift Left and
Shift Right buttons to the script window’s toolbar.)
The selection will be expanded to consist of complete lines, and a tab character will be removed from or
added to the start of each selected line.
AppleScript will perform its own indentation when the script is compiled, which may alter the number of tab
characters at the start of a line (except inside a multiline string literal).
See also on Show Invisibles, Show Spaces, and Show Tab Stops.

Inserting Content

Comment
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Comment

You can use shortcuts to comment or uncomment a stretch of code.
To comment out a stretch of code:
Select the code and choose Edit > Comment. Or choose Comment from the contextual menu.
Script Debugger will extend the selection to consist of complete lines, and will then insert a singleline comment character at the start of each of those lines.
To uncomment a stretch of comments:
Select some code and choose Edit > Uncomment. Or choose Uncomment from the contextual menu.
Script Debugger will extend the selection to consist of complete lines, and will then remove a singleline comment character from the start of each of those lines, if there is one. (If there isn’t one, that’s
fine. The line is left unaltered.)
(You can also add Comment and Uncomment buttons to the script window’s toolbar.)
Why does Script Debugger use single-line comments rather than surrounding the selected text with
block comment delimiters, (* like this *)? One reason is that block comments are fragile. An
unbalanced double-quote within block comment delimiters will keep your script from compiling. Singleline comments are simpler. In fact, with Script Debugger, multiple single-line comments are easier to
deal with than block comments. To insert block comment delimiters, use the Block Comment clipping.

A single-line comment character can be either “--” (the traditional comment character) or “#” (the new
comment character introduced in OS X 10.5). To determine which is inserted by the Comment command,
and to set the number of spaces that should follow the comment character, use the Editor preference, “Edit
> Comment Inserts.”

Shift

Tab
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Tab

You can convert tabs to spaces and vice versa.
To do so:
Select some text and choose Edit > Entab or Edit > Detab. (You can also add Entab and Detab
buttons to the script window’s toolbar.)
The selection will be expanded to consist of complete lines, and the indentation whitespace at the start of
those lines will be converted to tabs or spaces respectively.
This is useful particularly when a script must be pasted into some other environment, where spaces are
better interpreted than tab characters. For example, before copying and pasting a script into an email
message or a web page, you might Select All and then Detab.
The size of tab stops (the number of spaces to which each tab corresponds) is determined by the Editor
preference, “Tab Width.”
See also on Show Invisibles, Show Spaces, and Show Tab Stops.

Comment

Splitting the Editor
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Splitting the Editor

You can split the script window text area into multiple panes. This can be helpful in a long script, letting
you view and edit more than one area of your script simultaneously.
You can split the text area vertically or horizontally — and you can split each resulting pane vertically or
horizontally. Each pane can be scrolled to display a different region of the script.
(But you’d probably never split a window into panes quite as insanely as in this picture!)

To split a script window or pane vertically:
Click the vertical split icon (

) in the vertical scrollbar.

Or, choose Edit > Split Editor Vertically.
Or, choose Split Editor Vertically from the contextual menu.
To split a script window or pane horizontally:
Click the horizontal split icon (

) in the horizontal scrollbar.

Or, choose Edit > Split Editor Horizontally.
Or, choose Split Editor Horizontally from the contextual menu.
To resize a pane:
Drag the divider line between panes.
To close a pane:
Click its close icon (

) at the lower right corner of the pane.

Or, choose Edit > Close Split View.
Or, choose Close Split View from the contextual menu.
To close all panes:
Option-click any close icon (

).

Or, hold Option and choose Close All Split Views (from the Edit menu or the contextual menu).
What should happen when you change a view setting (such as line wrapping or visibility of tab stops) in a
split pane? Should other split panes change to match, or should their view settings remain independent? To
determine this, use the Editor preference, “Synchronize split-view appearance”:
If checked, then when you change a view setting in one split pane, other split panes of the same
window will change the same setting to match. If unchecked, then a change to a view setting
applies to just one split pane.
Hold Option as you change a view setting to reverse this preference on one occasion.
When you select text in one pane, should the same text be selected in all other panes? To determine this,
use the Editor preference, “Synchronize split-view selection.”

Tab

Find
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Find

To search (and replace) within a script, you’ll use the find bar and the Search menu.
To summon the find bar:
Choose Search > Find.

To dismiss the find bar:
Click Done in the find bar.
Or, press Esc.
To configure a search in the find bar, use the checkboxes:
RegEx. If checked, the search string (and replace string) will be interpreted as a regular expression.
Script Debugger uses the ICU flavor of regular expression syntax.
By default, . doesn’t match the return character at the end of a line; you can reverse this with
the (?s) flag.

Match Words. If checked, the search string is sought between word boundaries.
Ignore Case. If checked, the search is case-insensitive.
Wrap. If checked, successive Find Again commands loop around the document. If unchecked,
Replace All affects text only after the start of the current selection.
To perform a search:
The search is initially performed automatically as you edit the search string.
To search forward or backward, choose Search > Find Again (Backwards), or click the arrow buttons
in the find bar.
The Wrap checkbox affects the behavior of this command.

To perform a search-and-replace:
Click the & Replace button to reveal the replace string and Replace buttons.
Click a Replace button or choose a Replace command from the Search menu.
The Wrap checkbox affects the behavior of Replace All (and Replace & Find).

You can use selected text as the search or replace term; choose Search > Find Selection (Backwards) or
Use Selection for Find/Replace.

To recall a recent search, click the magnifying-glass icon in the search field.

Splitting the Editor
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Go To Line

You can jump to a line by number. To do so:
Choose Edit > Go To Line and enter a line number in the dialog.
(The number that appears when you summon this dialog is the number of the line where you
currently are.)

To work more easily with line numbers, you can elect to show line numbers in your script. Also, the
navigation bar (at the top right, above the text area in the script window) always shows the current line
number. And there’s an Editor preference, “Show navigation bar location when scrolling,” that causes line
numbers to be shown in a tooltip while you scroll.

There’s also a “table of contents” menu for jumping to a handler or other top-level entity.

Find

Navigate

Script Debugger Help > Develop > Edit > Editing and Navigation >

Table of Contents

Navigate

Script Debugger provides convenient ways to view and navigate the structure of your AppleScript code
in a script window.

Jump By Handler
To jump from handler to handler, successively:
Choose Edit > Go to Next Handler or Edit > Go to Previous Handler.
The handler name in the first line of the handler definition is selected. Handlers do not have to be at
top level; for example, a handler inside a script object counts as a handler (and so does a handler
inside a script object inside a handler).

Navigation Bar
The navigation bar (above the text area in a script window) has two functions:
It shows where you are. The current selection is described, in the following format:
lineNumber:characterNumber ∆ length symbolName
For example:

7:3 means the selection starts at character 3 of line 7.
∆ 6 means the selection is 6 characters long (this will be absent if there’s just an insertion
point).
on myScript's pad(s) means the selection is in the handler pad (taking one parameter, s),
which is itself inside the script object myScript.
The Editor preference “Show navigation bar location when scrolling” causes a tooltip, similar to the
navigation bar contents, to appear when you scroll your script. The tooltip shows the location of the top
of the visible portion of the script.

It lets you survey and navigate your script’s structure. Click the navigation bar to summon the
table of contents pop-up menu.

The menu lists top-level entities (script objects, properties, handlers), along with embedded entities
shown hierarchically. There are two possible orders:
Alphabetically by category:
Global variables, in alphabetical order.
Script objects, in alphabetical order.
Properties, in alphabetical order.
Handlers, in alphabetical order.
The order in which they appear in the script.
The order you’ll see depends upon your choice in the Editor preferences checkbox, “Sort table of
contents menu alphabetically.” Hold Shift to display the menu in the other order.
Hold Option to eliminate properties and globals from the display.
You can show and hide the navigation bar, to save space. To do so:
Choose View > Show/Hide Navigation Bar.
The same table of contents menu that pops up in the navigation bar also appears in the contextual menu.
Control-click in the text area and choose Go To. The same modifier keys work (Option and Shift) if you hold
them while summoning the contextual menu.

Markers
A marker is a comment in your script that appears in the table of contents menu so that you can easily
jump to it. Markers always appear first in the table of contents menu.
A marker is an AppleScript comment that starts with -->>.
If text substitution is turned on, -->> may be converted to --» as you enter it, but it’s still a marker.
If line contains a marker, a “droplet” symbol appears in the gutter:

Go To Line

External Editor
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External Editor

You can use an alternative text-editing application to edit a script. Possible choices are:
BBEdit
TextWrangler
This feature works seamlessly:
1. Start with a script window open in Script Debugger.
2. Open the same script in an external editor and edit it there. To do so:
Choose File > Edit With XXX. A temporary text copy of the script is created, and is opened in
the external editor application.
The application name (“XXX”) depends on which applications you have and which ones are
running. Script Debugger will prefer a running application to one that is not running, and among
running applications or non-running applications it will prefer the order BBEdit, TextWrangler,
TextMate.

While the external editor is editing the script, Script Debugger’s version of the script remains open
but locked. You’ll see a dialog advising you that the script is being edited elsewhere, and a “Locked”
watermark at the lower right of the script window.

3. In the external editor application, save and close the document. Script Debugger automatically
adopts the changes you made in the external editor.
Whenever you save the document in the external editing application, the Script Debugger
copy is updated to match.
When you close the document in the external editing application, the warning dialog is
removed from the Script Debugger script window (and Script Debugger comes to the front).
This is the normal way in which an external editing session ends in good order.
Alternatively, you might change your mind and decide to break off the external editing session
prematurely without reflecting the changes from the external editing application back into the Script
Debugger document. To do so:
Switch back to Script Debugger and click Cancel in the warning dialog.

The temporary text copy of the script remains open in the external application, but it no longer
has any connection to Script Debugger.

Navigate
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Run

When you compile and run (or “execute”) your script, Script Debugger gives you tools for understanding
what happened.
You can view the result in powerful ways, find out how long your script took to run, and see the
value of persistent variables afterwards.
If there are errors while compiling or running, they are clearly displayed, with full supplementary
information.
You can use the event log to find out what interapplication communications took place as your script
ran.
If a scriptable application is also recordable, you can record it with Script Debugger.
You can set a script’s target or parent script.
Further Details:
Compile
Execute
Result
Times
Progress Reporting
Variables
Errors
Event Log
Record
Default Target
Parent Script

Edit

Debug
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Compile

Your script needs to be compiled before it can be run or saved if it has been modified since the last time
it was run or saved.
An Editor preference, “Show compiled state in gutter,” causes a script that needs compiling to display a
striped “barberpole” pattern in the gutter.
To compile your script, you can:
Compile your code explicitly. To do so:
Press Enter (different from pressing Return).
Or, choose Script > Compile.
Or, click Compile in the script window toolbar.

Run the script. The script will automatically be compiled first.
A script that cannot be compiled cannot be run.
Save the script. When you save a script that needs compiling to a compiled script file format, the
script will automatically be compiled first.
A script that cannot be compiled cannot be saved as a compiled script file.
If your script can’t be compiled because it isn’t valid AppleScript code, you’ll get an error message.
After a successful compilation, the script window displays the word “Compiled” in the status bar.
To force your script to recompile even if it doesn’t need compiling, hold down the Option key and choose
Script > Recompile (or click Recompile in the toolbar). This will also re-initialize persistent top-level entities
to their base values. An important situation where you will need to do this is when you are editing a main
script and a referenced library script at the same time.

Execute
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Execute

Script Debugger can run (and debug) multiple scripts simultaneously. To execute (run) a script:
Choose Script > Execute.
Or, click the Execute button in the toolbar (the second Action button).

If the script needs compiling, it is automatically compiled first. If there is a compilation error, the script
won’t run.
While a script is running:
A circular progress indicator spins at the right end of the title bar.

Whenever an Apple event has been sent to an application but the application has not yet replied, the
application’s icon appears at the right end of the title bar. If the Apple event is in danger of timing
out, the circular progress indicator changes to a “pie” icon tracking the remaining time.

In the script window toolbar, the Execute button is disabled, while the Stop button (the first Action
button) is enabled.
You can click Stop, or choose Script > Stop, to interrupt execution.
In the Script menu, the Execute menu item changes to Running, is disabled, and has a check mark.
Script > Stop is enabled.
Additionally, if the script is in debug mode, then when the script is executing, the Pause button
replaces the Execute button in the toolbar, and Script > Pause is enabled.
If the script runs to completion with no runtime error, there is usually a result.
You can run the frontmost script even when you’re in a different application:
Use the Mini Debugger floating window. It displays and lets you control the frontmost script.
Script Debugger’s Dock menu (Control-click its Dock icon) contains Execute and Stop menu items
that operate on the frontmost script.
Script Debugger helps you run individual handlers in a script.
Further Details:

Testing Handlers

Compile

Result
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Testing Handlers

Script Debugger lets you run individual handlers in a script. This can be a valuable testing and
debugging technique.

Standard Event Handlers
You can run a standard event handler, such as an idle handler, an open handler, or a Folder Action
handler. To do so, choose from the Event Handler menu:
Choose the handler from the hierarchical Script > Execute submenu.
Or, hold down the mouse down on the Execute button in the toolbar. A pop-up menu appears;
choose the handler in this menu.
When you’re debugging a script, the same pop-up menu is attached to the Trace, Step Over, and Step
Out menu items and toolbar buttons.

For example, consider the applet script in the illustration below. If you simply run this script, you’ll see the
“Howdy!” dialog. That’s because what you’ve just run is the run handler. But what if you want to test the
idle handler? Choose Idle from the Event Handler menu.

A continue statement in an event handler called in this way will generate an error in Script Debugger.
This is deliberate and may be safely ignored. The technical reason is that if, for example, we permitted a
continue quit statement in a script’s quit handler to execute, Script Debugger itself would quit!

The Current Event
When you choose from the Event Handler menu, that event becomes the script’s current event. This
means that the event is now called by default when you run the script.
To alert you to this special situation:
The current event is checked in the menu.

If the current event is not the run handler, a current event indicator appears above the text area
of your script window:

To set the script’s current event back to the run handler:
Click the “x” in the current event indicator.
Or, choose Run from the Event Handler menu.
To set a different current event without also running that event handler:
Hold Shift as you choose from the Event Handler menu.

Parameters and the Event History
The open handler and the event handlers defined in the Folder Actions and Digital Hub Actions suites
expect parameters, which are aliases or files.
For example, an open handler expects a list of aliases to the files and folders. An adding folder items to
handler expects two parameters, an alias to the watched folder and a list of aliases to the added files. And
so forth.
Such a handler is listed in the Event Handler menu with an ellipsis (…) after its name. When you choose it
from the Event Handler menu, Script Debugger presents a dialog where you can select files and folders. An
appropriate parameter or parameters will then be passed to the specified handler.
In the case of adding folder items to and removing folder items from, what you’re supplying in this
dialog is the second parameter, the item(s) that are allegedly being added or removed. Script Debugger
will then use the containing folder of the item(s) as the first parameter, the watched folder.
In the case of just the open handler, there is another alternative. Drag-and-drop files and folders
directly from the Finder into your script. If your script has an open handler, one of the options in the
resulting dialog is to invoke the open handler with these Finder items as parameter.

Script Debugger remembers each alias or list of aliases produced in this way, along with the event handler
it is to be passed to, and adds this information to the bottom of the Event Handler menu. This list of
remembered event handlers and parameters is the event history.
Thus, the next time you want to test this same handler with these same parameters, you can choose
it from the event history (or, if it is the current event, click the Execute button).

The event history is remembered until you close the script window; or you can deliberately remove it by
choosing Clear Menu (which is always the last item in the Event Handler menu if there is an event history).

Other Handlers
If the handler you want to test is not one of the standard event handlers already listed in the Event Handler
menu, you can test it using Script Debugger’s scriptability, which allows one script to call a handler in
another script.
For example, suppose you have opened a script file containing this top-level handler:
on justName(s)
set text item delimiters to ":"
return last text item of s
end justName
-- ... plus a lot of other stuff ...
To test this handler without running the rest of that script, run this script from a second tab or script
window:
tell document 2
justName("this:is:a:test")
end tell
This calls justName in the first script (because it is behind the second script, and thus is document 2).
Moreover, it adds this handler call with this parameter to the event history of the first script. Thus,
having done this once, you no longer need the second script in order to test the first.
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Result

Viewing the result of a script is often a primary reason for running the script; viewing the result of a
particular line of a script is often a primary reason for debugging the script. Script Debugger provides
several ways to view a result:
The result pane. This is part of the script window. It is an explorer, which means you have the
power to see the result value using different views, including Best view, which will be an interactive
outliner if the value is an object or collection.
To see the result pane:
Choose View > Result & Variables Tab.
Or, click the first Show button in the script window toolbar.

The result explorer window. This shows the result in exactly the same way as the result pane; the
difference is that it’s a separate window, not part of the script window. This can be a good choice if
(for example) you want to save space within the script window, or if you want to keep viewing the
result while switching the script window’s tabs to see something else (such as the Inspectors tab).
To see the result explorer window, choose Script > Show Result Explorer Window (or choose
Show Result Explorer Window from the contextual menu that appears when you Control-click on the
grey area at the top of the result pane).

The result bar. It’s just a bar (at the top of the text area), so all there’s room for is the result in
Source view. But that’s the point: this is the most space-saving way to view the result.
To see the result bar, choose View > Show Result Bar. To dismiss the result bar, choose View >
Hide Result Bar or click the “x” in the result bar.

In the Mini Debugger, the result bar is always present and is the only way to see the result
(without switching back to Script Debugger).
NOTE: If the result has changed since the previous execution of the script, the result pane and result
explorer window will display a red bar at the top, and the result bar will display the word “Result:” in
red. This is particularly useful in debug mode, where an individual line of code might or might not
generate a changed result. (After you run a script all the way through in normal mode, if there’s a result,
it is always new, so the red indicator will appear by default.)

Although you can always manually see the result in any of those ways, the result is so important that Script
Debugger would like to show it to you automatically every time there’s a result. An Execution preference,
“Show result when scripts pause or end”, determines which way the result is displayed automatically:
No. No attempt is made to display the result automatically; if it isn’t showing already, you’ll have to
summon it manually if you want to see it.
Show Result Inspector. It’s as if you’d chosen View > Result & Variable Tab. This can be abrupt if
you were looking at a different tab, but it has the advantage of being an excellent view of the result,
right there in the script window, along with additional information such as variable values (and, when
debugging, the call stack).
Show Result Bar. The result bar is shown, as if you’d chosen View > Show Result Bar.
Show Result Explorer Window. A separate explorer window is opened, as if you’d chosen Script >
Show Result Explorer Window.

NOTE: This preference is meaningful only if the result is not already showing. If the result is already
showing — for example, the result bar or the result pane is visible — then the new result is simply
displayed there, as if this preference were set to No.

Execute

Times
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Times

Script Debugger automatically times your script as it runs. This feature is especially useful during
development when you’re trying to make your script as fast and efficient as possible.
To learn how long your script took to run, just run the script. The timer in the script window toolbar
displays the timings.

The timer displays the following values:
The total time. This value is broken down into two components:
The AppleScript time. This is the time spent internally, exclusive of time spent waiting for
Apple events to return from scriptable applications and scripting additions.
The AppleScript time is accompanied by a percentage figure, showing what proportion of the
total time it represents.
The events time. This is the time spent waiting for Apple events to return from scriptable
applications and scripting additions.
The events time is accompanied by a count of the Apple events sent.
The AppleScript time and the events time will sum to the total time.
You can also get a handle on what Apple events are being sent by using the event log.

Result
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Progress Reporting

AppleScript (starting in OS X 10.10 Yosemite) has four properties for reporting progress through a
repetitive or long-running task:
progress description, progress additional description
Text describing this task.
progress completed steps
The number of steps of the task that have been completed so far.
progress total steps
The number of steps needed to complete this task. The percentage of the task that has been
completed so far is the progress completed steps divided by the progress total steps.
Alternatively, use -1 to indicate an ongoing task of indeterminate length (and 0 to indicate that the
task is over).
When progress completed steps and progress total steps are positive, Script Debugger responds in
two ways:
The circular progress indicator changes to the “pie” icon tracking the completed percentage.

If you have checked View > Show Progress, the progress bar appears at the top of the editor,
displaying the “pie” along with the progress description (and the progress additional
description, if any).

To dismiss the progress bar programmatically, while your script is still running, reset the properties as
follows:
set progress total steps to 0
set progress description to ""
set progress additional description to ""

Times

Variables
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Variables

The variables pane displays the values of your script’s variables.
When you simply run a script, the variables pane displays the script’s persistent variables (toplevel entities — script objects, script properties, and globals) after execution. It doesn’t show local
variables, because when the script finishes executing, local variables have gone out of scope.
When you debug a script, the variables pane also displays local variables.
To see the variables pane:
Choose View > Result & Variables Tab.
Or, click the first Show button in the script window toolbar.

Variables are displayed in alphabetical order, grouped into the following categories:
1. Inherited variables (blue background). These are variables acquired through AppleScript’s script
object inheritance mechanism.
By default, a script’s parent is the AppleScript scripting component. Therefore, the variables pane
will usually display this object and its variables twice — once by virtue of being the script’s parent,
and again by virtue of being the global script object AppleScript.
2. Required import items. These are the items configured by use statements, if any.
3. Top-level entities — script objects, script properties, and globals.
The variables pane is an outliner, with all that this entails. For example:
You can double-click a line of the variables pane to see that value displayed in a separate explorer
window.
You can edit the value of persistent top-level entities (such as properties and globals) shown in the
variables pane; you might use this feature to experiment with your script’s behavior under different
initial values of your persistent entities.
You can filter the outline by showing and working with the scope bar.
To show the scope bar, Control-click in the variables pane and choose Show Scope Bar from the
contextual menu.

No variables appearing? Show the scope bar and make sure you’re not filtering them all out.

Recently changed values are displayed in red.
Script Debugger can preserve the value of persistent top-level entities when a script is saved and reopened. You can turn this feature on or off by checking or unchecking Script > Persistent Properties.

Progress Reporting

Errors
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Errors

AppleScript generates two kinds of error — compile errors and runtime errors. Script Debugger displays full
information about where the error occurred and what went wrong.
If your script catches (handles) a runtime error with a try block, the error does not percolate up to
AppleScript and it is not reported back to Script Debugger. In effect, there is no error. In debug mode,
however, you can break on an error even if it is caught.

Error Dialog
Error information is displayed in a dialog. The structure of the dialog reflects the structure of the error
message received from AppleScript.

An error message received from AppleScript can contain up to six parts, corresponding to the five
parameters of the AppleScript error command plus an Application parameter supplied by AppleScript itself.
These are displayed in the dialog as follows:
message string
Shown as text the top of the dialog.
number
Shown at the lower left of the dialog.
partial result
Shown as the Partial Result pane.
from
Shown as the Offending Object pane.
to
Shown as the Expected Type pane.
[application]

Shown as the Application pane.
The panes of the error dialog are explorers. If the value displayed in a pane is an object reference, Best
view is an outliner, and individual lines can be double-clicked to create a separate explorer window.
To show the error message dialog again after dismissing it:
Choose Script > Show Last Error.
Or, click on the error location marker (the arrow in the gutter).

Error Location
After an error dialog is dismissed, the script is marked in three ways:
An arrow in the gutter shows the line in which the error occured.
You can click this arrow to display the error message dialog after dismissing the dialog.
The line is highlighted, and the troublesome words are selected.
The error message string is displayed in the status bar (if no other status message has come along
to replace it).
For information about a special kind of error situation where a file is left open, read on.
Further Details:
Leaks

Variables
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Leaks

If your script terminates with an input-output pipe left open, Script Debugger offers you the chance to
close it. This situation can arise because:
The script has called the open for access Scripting Addition command without calling close access
on the same file.
When the script is terminated in this situation, Script Debugger presents its Leaks dialog. The dialog
contains a list of open files (“Leaked Resources”).

Your options are:
Close All. All open files are closed (and transactions are committed), and the dialog is closed. This
will be your usual choice.
Close. The selected open file is closed (or the transaction is committed).
Abort. The selected transaction is rolled back.
Forget. The selected leak is removed from the list with no action taken. This would be a very
unusual thing to do, as the leak is left open.
If the script terminates because of an error, the error dialog is shown instead of the Leaks dialog. To close a
leak left open by the termination of the script, summon the Leaks dialog manually:
Choose Script > Show Leaks.
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Event Log

The event log lists the communications that pass between your script and target applications — Apple
events and their results. You can also use it to hold messages sent by your script with the AppleScript log
command.
The event log preserves the results of all Apple events performed during the execution of a script, and
lets you explore those results. Thus it operates as a basic debugger, because, very often, what you said to
an application and (especially) what answer that application gave is exactly what you want to know about
your script.
By default, the event log is shown as a pane of the script window — the event log pane. To display the
event log pane:
Choose View > Show Event Log.
Or, click Event Log in the script window toolbar so that it is highlighted (white icon on black
background).

To hide the event log pane:
Chose View > Hide Event Log.
Or, click Event Log in the script window toolbar so that it is unhighlighted (black icon on white
background).

Or, click the X button in the event log pane’s scope bar (see next section).
Instead of the event log pane, you may prefer to see the log in a separate window.
WARNING: If the log is showing while your script runs, your script may run slower (because of the
overhead of displaying the log’s contents in real time). If speed (or accurate timing) is of the essence,
close the log display before you execute your script and open it afterwards.

Scope Bar
At the top of the event log is a scope bar. Use it to filter what kinds of event are displayed in the event log
(described in the next section).
You can show or hide the scope bar:
Control-click in the event log and choose Show/Hide Scope Bar from the contextual menu.

Subpanes
The event log has two subpanes:
The event list. This subpane is always displayed. It lists each Apple event, shown as an AppleScript
command and accompanied by its result, along with its time and duration.
Events can be listed in three “languages”:
Source (AppleScript). Choose View > Log As Source, or click Source in the scope bar.
Raw (four-letter codes). Choose View > Log As Raw (Chevron) Syntax, or click Raw Source in
the scope bar.
AEPrint (the actual Apple event content). Choose View > Log As AEPrint, or click AEPrint in the
scope bar.
Events can also be filtered, using buttons in the scope bar. Choices are:
'log' Commands. Messages sent by the script by calling log.
By Application. All applications with which an Apple event message was exchanged are
listed. If an application isn’t highlighted, its Apple events are not displayed in the log.
If 'log' Commands is not highlighted and no application is highlighted either, the event log will be
empty!

To turn off filtering conveniently so that all events are shown, choose Show All Events from the
contextual menu.
The log result explorer. This subpane is an explorer showing the result of the event selected in the
event list. To display the log result explorer:
Choose View > Show Log Result Explorer.
Or, Control-click in the event list subpane and choose Show Log Result Explorer from the
contextual menu.

An alternate way to see an explorer for an Apple event result, without the overhead of showing two
subpanes in the event log simultaneously, is to double-click the event in the event list. This opens
a separate explorer window on the result.

Miscellaneous
You can copy an Apple event from the log. This is the message sent by your script to a scriptable
application. To do so:
Select a line in the event list, and choose File > Copy.
Or, Control-click and choose Copy Event from the contextual menu.
Or, drag-and-drop a line of the event list into a text environment.
You can copy a result of an Apple event from the log. This is the reply returned by a scriptable application
to your script. To do so:
Control-click and choose Copy Event Result from the contextual menu.
During debugging, a correspondence is maintained between each Apple event and the line of the script
where it was performed. To highlight the corresponding script line:
Select a line in the event list.
By default, events remain in the log until the next execution of the script — that is, the default policy is to
clear the log when execution begins. You can modify this policy. To clear the log immediately:
Choose Script > Clear Event Log.
Or, click the Clear button in the event log’s scope bar.
Just the opposite, to prevent the log from being cleared when the next execution begins:
Choose Script > Append To Event Log (so that it is checked).
Further Details:
Event Log Window

Errors
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Event Log Window

A script can display its event log in a separate window, instead of the event log pane in the script window.
To display the event log window:
Choose Script > Show Event Log in Window.

A script’s event log window has these features:
Its content is the same as the event log pane.
It is tied to the script:
If the script is saved, the size and configuration of its event log window is saved.
If the script is closed, its event log window is closed.
The script can be saved when the event log window is frontmost. The event log window’s
“dirty” status (the Close button) is the same as the script’s “dirty” status.
The event log window’s status bar matches the script’s status bar.
The execution of the script (including debug mode stepping and tracing) can be controlled
from the event log window. Commands such as Script > Compile and Script > Execute work
when an event log window is frontmost, and buttons for them appear in the toolbar, as does
the timer.
In this way, you can work in the event log window and concentrate your attention on it, while
running or debugging the script.
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Record

If a scriptable application is also recordable, it translates user actions into AppleScript code. This is
effectively the same AppleScript code that would be used to perform those same actions programmatically.
Common examples (perhaps the only examples) of recordable applications are BBEdit and the Finder.
To start recording user actions:
Choose Script > Record and switch to the recordable application. (You can also add a Record button
to the script window toolbar; in that case, you can click the Record button to start recording.)
Or, if you’re already in the recordable application, choose Record from Script Debugger’s Dock menu.
Once you’ve started recording user actions, perform actions directly in the recordable application. Script
Debugger will record the AppleScript equivalent of each action. When you’re done recording:
Switch to Script Debugger and choose Script > Stop (or click the Record button in the toolbar again).
Or, choose Stop from Script Debugger’s Dock menu.

Event Log

Default Target

Script Debugger Help > Develop > Run >

Table of Contents

Default Target

Script Debugger lets you set an application as your script’s implicit target. This is the application to
which undirected Apple events should be sent.
To set an implicit target:
Choose Script > Default Target and select the desired target application. All applications in the
dictionaries list appear as choices.
The name of the default target appears as a tell line at the top of the script, reminding you that the
script is now wrapped in a virtual tell block directed at this application.

To remove the implicit target:
Choose Script > Default Target > None.
Or, click the “x” in the tell bar at the top of the script.
This feature is useful for simulating runtime environments where there is an implicit target. For instance, if
your script is to run from BBEdit’s Scripts menu, code that targets BBEdit doesn’t have to appear in a tell
block, because you’re “inside” BBEdit already. To test or run such a script from within Script Debugger, you
need a way to make BBEdit the default target, and that’s what this feature provides.

Record

Parent Script
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Parent Script

Script Debugger lets you set another script as the implicit parent of the current script. The mechanism
involved is AppleScript’s script object inheritance.
To set a parent–child relationship between two scripts:
Both scripts must be open.
Bring the “child” script frontmost. Choose Script > Parent Script and the name of the parent script.
This parent-child relationship persists only while both scripts are open. If you try to close the parent script,
you’ll get a dialog warning that you’re about to break the parent-child relationship.
This feature can be employed to make a set of top-level entities (properties, handlers, etc.) from one script
available in another (for example, you could use it test individual handlers in a script without altering that
script), or for simulating a runtime environment where parent script relationships are used.
Note: Neither the “parent” script nor the “child” script may be in debug mode.

Default Target
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Debug

Meet Script Debugger’s debug mode! Debugging a script is like running it, except that in debug mode your
script can pause in the middle.
Debugging is a separate mode; it’s a feature of your script. A script is either in debug mode or it isn’t.
To turn on debug mode for a script:
Choose Script > Enable Debugging. If the menu item is checked, debug mode is on.
Or, click the Debugging button in the script window toolbar so that it is highlighted (white icon on a
black background).
When your script is in debug mode:
1. In the toolbar, the Step buttons (Trace, Step Over, Step Into, Step Out) are added to the Action
control, and the Breakpoints button appears (by default).
2. The Debugging button in the toolbar has a white icon on a black background.
3. The gutter is wider (in order to accomodate breakpoints and code coverage markers), and displays
pause arrows next to every line of the script where it’s possible to set a breakpoint.
4. In the Result & Variables tab, two additional panes appear: the call stack and the breakpoints
inspector.

To turn off debug mode:
Choose Script > Enable Debugging. If the menu item is unchecked, debug mode is off.
Or, click the Debugging button in the script window toolbar so that it is unhighlighted (black icon on
white background).
NOTE: You might have to stop your script (choose Script > Stop, or click Stop in the toolbar) before
you can turn off debug mode. You can’t turn off debug mode if your script is running or paused.

Debug mode is a script feature; it is saved as part of a script file. It is also unique to Script Debugger. A
script saved in debug mode is unusable except in Script Debugger. Therefore, when you’re finished
debugging, you will probably want to save your script not in debug mode.
There is, however, one good reason for deliberately saving a script in debug mode and running it
elsewhere — so that you can debug externally.

Debug mode gives your script (and you) many new powers.
Your script can pause in the middle of execution.
A major concern during debugging will be: where will your script pause? The answer involves chiefly
the interplay between breakpoints and the stepping commands.
While paused, you can see (and alter) the values of your script’s variables, along with other
AppleScript values, as they change during the course of execution.
You can see what code is executed and what choices your code makes. You can also run your code in
slow motion, watching its path of execution.
You can observe how one handler calls another.

If your script involves driving a scriptable application’s interface, it may help you to work in the Mini
Debugger, where you can interact with breakpoints and pauses in your script while keeping the scriptable
application frontmost.
Further Details:
Pause
Execute When Debugging
Breakpoints
Step
Trace
Call Stack
Variables (Debug Mode)
Expressions
Exceptions
Code Coverage
External Debugging
The Mini Debugger
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Pause

The key feature of debug mode is that your script can pause in the middle of execution. Click here to
learn how to pause your script.
When a script is paused in debug mode:
The Execute command becomes the Resume command. Thus, Script > Execute becomes Script >
Resume, and the Execute button in the toolbar resumes execution.
Script > Pause is disabled and checked.
The “paused” icon appears at the right end of the title bar (and, if this script is in a tab, at the right
side of the tab).

The status bar reports “Paused” and possibly the pause location.
A green arrow in the gutter indicates the line at which your script is paused.

NOTE: The line pointed to by the green arrow has not yet been executed.

Why Pause
The point of pausing (and of debugging) is that while your script is paused, you can examine its state.
For example, you can study the call stack, the values of your variables, the values of expressions, and the
event log.
Then you can make your script proceed again (and possibly pause again).

Pausing vs. Stopping
Distinguish pausing from stopping!
Pausing is possible only in debug mode. It leaves you somewhere in the middle of execution.
From here, you can proceed further, even completing the script normally if you want to.
When paused, you cannot turn off debug mode. You must stop the script in order to turn off debug
mode.
When paused, you cannot edit your script. You must stop the script in order to edit it.
Stopping a script, on the other hand, is possible at any time. Stopping aborts execution
immediately and returns everything to neutral state. If you execute the script from here, you’ll be
starting at the very beginning.

To stop a script:
Choose Script > Stop.
Or, click Stop in the toolbar.
Further Details:
How to Pause

Execute When Debugging

Script Debugger Help > Develop > Debug > Pause >

Table of Contents

How to Pause

The most important thing to understand about debugging is when your script will pause.
Execution will pause automatically if the path of execution comes to an enabled breakpoint.
Execution pauses with the green arrow pointing at the breakpointed line, and before executing the
breakpointed line.
You can suspend this rule by choosing Script > Break on Breakpoints so that it is unchecked.
Otherwise, enabled breakpoints take priority over everything else.
The step commands cause execution to proceed by a limited amount and then pause.
Each step command has its own rule for what “a limited amount” means (discussed here).
But remember, unless you’ve suspended breakpoints, breakpoints take priority. If a step command is
in process and the path of execution hits an enabled breakpoint, the step command is cancelled and
execution pauses at the breakpoint.
If you’ve elected to break on exceptions, encountering a runtime error will pause your script —
even if your script catches and handles the error.
During a lengthy bout of execution (or tracing), you can manually pause the script:
Choose Script > Pause.
Or, click Pause in the toolbar.
If your script is paused but you can’t see where (because you’ve scrolled to examine some other region of
the script), choose Edit > Go to Current Line to bring the line containing the green arrow into view.
What is the path of execution?
As your script runs, one line is executed, then another, then another. There are branches, so some lines
might be skipped. There are loops and handlers, so some lines might be executed several times. Thus,
line by line, like a mouse running in a maze, the computer traces a path of execution through your code.
(You can actually watch this happening in debug mode, by tracing.)
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Execute When Debugging

Here is a summary of the ways you can start or resume execution in debug mode.
Choose Script > Execute or Script > Resume (they are the same menu item).
Or, click the Execute / Resume button in the toolbar (they are the same button).
Choose Script > Trace.
Or, click Trace in the toolbar.
Issue any Step command.
Issue the Execute (or Trace) to Here command. This effectively sets a breakpoint and starts or
resumes execution at the same time.
The ability to test individual handlers (and the event history) applies in debug mode exactly as in
normal mode, only even more so! Not only Execute but also Trace and the Step commands have the Event
Handler menu. (But not Step Out, because it can’t be used to initiate execution from a stopped state; when
the script is stopped, you’re not “in” anything that you can step “out” of.)

Pause

Breakpoints
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Breakpoints

In debug mode, execution of your script will pause if the path of execution encounters an enabled
breakpoint. When a script pauses at a breakpoint, it pauses before executing the breakpointed line.
You can create a breakpoint only in debug mode, but the breakpoint is not lost if you leave debug mode
— it will still be there the next time you switch to debug mode. Breakpoints are saved when you save a
compiled script in debug mode. They are lost when you save a compiled script in normal mode and close
the script.

Places where you can set a breakpoint are shown as “executable” arrows in the gutter of the script
window.

Setting and Removing Breakpoints
To set a breakpoint:
Click an “executable” arrow (or the gutter next to it).
Or, select within the desired line; then choose Script > Set Breakpoint.
Or, Control-click in the desired line (or in the “executable” arrow), and choose Set Breakpoint from
the contextual menu.
A breakpoint marker appears in the gutter.

To move a breakpoint:
Drag the breakpoint up or down the gutter to a different “executable” arrow.
To remove a breakpoint:
Select within the breakpointed line; then choose Script > Remove Breakpoint.
Or, Control-click in the breakpointed line (or in the breakpoint), and choose Remove Breakpoint from
the contextual menu.
Or, Control-click the breakpoint’s listing in the breakpoints inspector and choose Delete from the
contextual menu.
Or, drag the breakpoint right out of the gutter.
To remove all breakpoints:
Choose Script > Remove All Breakpoints (hold Command to see it).
Or, Control-click in the script (or in the gutter) and choose Remove All Breakpoints from the
contextual menu.

Enabling and Disabling Individual Breakpoints
An individual breakpoint can be enabled or disabled. A disabled breakpoint doesn’t act like a breakpoint,
but it’s not removed, either, so you can enable it later if you like. A disabled breakpoint’s marker is
transparent; an enabled breakpoint’s marker is solid.
To disable a breakpoint:
Click the breakpoint marker.
Or, select within the breakpointed line; then choose Script > Disable Breakpoint.
Or, Control-click in the breakpointed line (or in the breakpoint), and choose Disable Breakpoint from
the contextual menu.
Or, uncheck the breakpoint’s listing in the breakpoints inspector.

To enable a breakpoint:
Click the breakpoint marker.
Or, select within the breakpointed line; then choose Script > Enable Breakpoint.
Or, Control-click in the breakpointed line (or in the breakpoint), and choose Enable Breakpoint from
the contextual menu.
Or, check the breakpoint’s listing in the breakpoints inspector.
TIP: You can also enable or disable a breakpoint with a checkbox in its conditions and actions popover.
Double-click the breakpoint to see the popover.

With some breakpoints disabled, you can remove just those breakpoints that are enabled. To do so:
Choose Script > Remove All Disabled Breakpoints (hold Shift and Command to see it).
Or, Control-click in the script (or in the gutter) and choose Remove All Disabled Breakpoints from the
contextual menu.

Enabling and Disabling the Entire Breakpoint Mechanism
You can also disable the entire breakpoint mechanism. If the breakpoint mechanism is disabled,
breakpoint markers are shown in grey. If the breakpoint mechanism is enabled, breakpoint markers are
shown in color.
To disable the entire breakpoint mechanism:
Choose Script > Break on Breakpoints so that it is unchecked.
Or, click Breakpoints in the toolbar so that it is unhighlighted (black icon on white background).

To enable the entire breakpoint mechanism:
Choose Script > Break on Breakpoints so that it is checked.

Or, click Breakpoints in the toolbar so that it is highlighted (white icon on black background).
Or, enable any disabled breakpoint. The breakpoint mechanism is automatically enabled as a
whole when you enable an individual breakpoint.
Further Details:
Temporary Breakpoints
Execute to Here
Breakpoints Inspector
Conditions and Actions

Execute When Debugging

Step
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Temporary Breakpoints

A temporary breakpoint is a breakpoint which automatically removes itself when encountered by the
path of execution.
Thus, we will pause there, but only once; after that, the breakpoint will be gone. This is convenient, for
example, to pause the first time through a certain loop but not on subsequent iterations, or the first time a
certain handler is called.
To set a temporary breakpoint:
Option-click an “executable” arrow (or the gutter next to it).
Or, select within the desired line; then choose Script > Set Temporary Breakpoint (hold Option to see
it).
Or, Control-click in the desired line (on in the “executable” arrow), and choose Set Temporary
Breakpoint.
TIP: You can also toggle the temporary status of a breakpoint with a checkbox in its conditions and
actions popover. Double-click the breakpoint to see the popover.

An enabled temporary breakpoint marker is shown in yellow.

Disabling a temporary breakpoint also turns it into a normal breakpoint. There is no such thing as a
disabled temporary breakpoint.
Option-clicking an existing normal breakpoint turns it into a temporary breakpoint. Option-clicking an
existing temporary breakpoint turns it into a normal breakpoint and also disables it.

Execute to Here
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Execute to Here

You might want execution to proceed to a certain line and pause there, without the overhead of setting a
breakpoint. That’s what “Execute to here” does. It’s a shortcut for setting a temporary breakpoint followed
by executing.
To use “execute to here”:
Shift-click an “executable” arrow (or the gutter next to it, or an existing breakpoint marker).
Or, select within the line you want to execute to, and choose Script > Execute To Here.
Or, Control-click the line you want to execute to (or in the “executable” arrow), and choose Execute
To Here from the contextual menu.
If a breakpoint is encountered before the target line is reached, we will pause at that breakpoint, and
the temporary breakpoint created by “Execute to Here” will remain in place.

A variant of “execute to here” is “trace to here”, which is the same except that we trace instead of
executing at normal speed. To use “trace to here”:
Option-Shift-click an “executable” arrow (or the gutter next to it, or an existing breakpoint marker).
Or, select within the line you want to execute to, and choose Script > Trace To Here.
Or, Control-click the line you want to execute to (or in the “executable” arrow), and choose Trace To
Here from the contextual menu.

Temporary Breakpoints
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Breakpoints Inspector

The breakpoints inspector lists the breakpoints in your scripts. Here, you can manage your breakpoints,
plus you can view and edit a breakpoint’s conditions and actions.
The breakpoints inspector appears in a script window in debug mode in the same tab as the result pane
and the variables pane. To see the breakpoints inspector:
Choose View > Result & Variables Tab.
Or, click the first Show button in the script window toolbar.

The breakpoints inspector functions as a list of breakpoints, through which you can manage a script’s
breakpoints. You can:
See the location of each breakpoint. The line number is given in the Line # column, and you can
select the line:
Double-click the breakpoint listing.
Or, Control-click a breakpoint listing and choose Go To Source Line from the contextual menu.
See how many times a breakpoint has been encountered during this execution of this script. The
number is given in the Hits column.
Enable or disable a breakpoint:
Check or uncheck the box in the first column.
Change the name of a breakpoint:
Click the name, or select a line and press Return, to make the name editable.
The default name of a breakpoint is the text of the breakpointed line.
Delete a breakpoint:
Select a breakpoint listing and choose Edit > Delete.
Or, control-click a breakpoint listing and choose Delete from the contextual menu.
Sort the list:
Click a column header.
Read on to learn about breakpoint conditions and actions.

Execute to Here

Conditions and Actions
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Conditions and Actions

Breakpoint conditions and actions can give a breakpoint tremendous additional power:
A condition means that when the path of execution hits the breakpointed line, we might or might
not pause here.
An action is an extra behavior performed by the breakpoint when the path of execution pauses at
the breakpointed line.
To see and edit conditions and actions attached to a breakpoint:
In the script gutter, double-click the breakpoint; or, select in the line and choose Script > Edit
Breakpoint. The conditions and actions appear in a popover beside the breakpoint.

In the breakpoints inspector, select the breakpoint listing and press Right Arrow (or click the triangle
in the breakpoint listing).

Conditions
There are two kinds of condition. If one condition is checked, we will pause at this breakpoint only if the
checked condition is true. If both conditions are checked, we will pause at this breakpoint only if both
conditions are true.
Hit count. We pause with respect to how many times this breakpoint has been encountered during
this execution. You can set a number of times and a comparison operator.
(Recall that the actual hit count is visible in the last column of the breakpoints inspector.)
Expression. Enter an AppleScript expression in the text field. The expression is evaluated when the
breakpoint is encountered. We will pause or not, based on:

The expression’s truth value. The expression must evaluate to a boolean; it is not implicitly
coerced to a boolean.
Or, the expression’s exception value. You can pause because the expression does or does not
generate an exception (a runtime error).

Actions
There are three kinds of action; you can specify as many as you like. Actions are performed only if we
would pause at this breakpoint (because the breakpoint is encountered by the path of execution and its
conditions, if any, are true).
Post a message to the event log and/or the status bar.
The status bar message appears in brackets after the normal status bar content. A subsequent
status bar message can, of course, replace this one.
Clear the hit count.
If this breakpoint is encountered again during this execution, the hit count will be recorded as 1.
Perform an execution command. What should happen when we hit this breakpoint? The default
command (the thing that usually happens at a breakpoint) is Pause, but you can choose any other
execution command, including Stop, Resume (i.e. proceed without pausing), or any of the step
commands.

Breakpoints Inspector
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Step

There are three Step commands — Step Over, Step Into, and Step Out.
To issue a Step command:
Choose it from the Script menu.
Or, click the button in the toolbar. (The Step commands are the third, fourth, and fifth Action
buttons.)

In the above illustration, the three buttons are Step Over, Step Into, and Step Out, in that order.
The three Step commands differ with respect to where execution will pause afterwards. We’ll use the code
in the illustration below to show what the different Step commands mean. In the illustration, we are initially
paused at a breakpoint at line 9 (without yet having executed line 9).

Step Into is the simplest. It means, “Execute the current line of code, and then, wherever the path
of execution takes you, pause right there, on the next line that would be executed.”
So, in the illustration above, Step Into would cause the script to pause at line 5. Why? Because line
9, where we are paused, calls the pad handler. So when we execute it, we’ll dive into the pad
handler, and the next executable line where we can pause, in that path of execution, is line 5.
Step Over is similar to Step Into, except that it follows an additional rule, “Don’t pause in a deeper
level of the call stack than where you are right now.”
So, in the illustration above, Step Over would cause the script to pause at line 10. Why? Because
that’s the next executable line that isn’t at a deeper level. Line 9, where we are paused, calls the
pad handler, which is a deeper level, so we don’t pause until the next executable line after the path
of execution has returned from the pad handler.
Step Out means, “Execute until you come to the next executable line at a higher level of the call
stack than where you are right now, and then pause.”
So, in the illustration above, Step Out would cause the script to pause at line 13. Why? We are

paused at line 9, in s’s implicit run handler. We execute to the end of the run handler, which is line
10, and return from s’s implicit run handler. Now we are at a high level, so we want to pause. In
fact, we are in line 12, because that is where s’s run handler was called. But we don’t pause in line
12, because if we were going to pause there, it would be before executing line 12 and before telling
s to run. So now we’re at line 13.
All of those details are predicated on the supposition that no breakpoints are encountered. Suppose, for
example, that there were an enabled breakpoint at line 5 (and assume that Script > Break on
Breakpoints is checked, and that this breakpoint has no conditions). The path of execution passes
through line 5, so all three commands would do exactly the same thing — pause at line 5. Breakpoints
take priority!

Both Step Over and Step Into can be used not only to resume but also to start execution of a script. In this
case they both pause before the first executable line of the script.
Both Step Over and Step Into have the same options for executing handlers as the Execute button.

Breakpoints
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Trace

Tracing is like executing, only it’s slower — slow enough that you can actually see the green arrow moving
along the path of execution.
To trace:
Choose Script > Trace.
Or, click Trace in the toolbar. (It is the sixth Action button.)
The speed of tracing is determined by the trace speed slider. To see the trace speed slider:
Choose Script > Trace. The slider is in the hierarchical menu (the Event Handler menu).
Or, having customized the toolbar so that it includes the trace speed slider, use the slider in the
toolbar.
The trace speed slider ranges between “tortoise” at the left and “hare” at the right.

Tracing is in one sense just a slower form of execution, and will pause for the same reasons (e.g., because
a breakpoint is encountered, or because you issue the Pause command). However, what’s really happening
is that Script Debugger is pausing and resuming after every executed line. This means that you can see
more than the green arrow moving — you can also see the call stack growing and shrinking, and the
variable values changing, and successive results appearing, just as you would if you if were repeatedly
issuing the Step Into command.
Trace has the same options for executing handlers as Execute.

Step
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Call Stack

When a script is paused while debugging, you can view the nest of handler calls currently being
executed. This is the call stack (or call chain).
What is the call stack?
Execution typically starts with the script’s run handler (implicit or explicit). Code in this handler can call
another handler, which can call another handler (or the same handler, recursively), and so on. Thus, at
any given moment during the execution of your code, there is a nest or chain of handlers leading
down from top level to the line currently being executed.

The call stack is displayed in a script window in debug mode in the same tab as the result pane and the
variables pane. To see the call stack:
Choose View > Result & Variables Tab.
Or, click the first Show button in the script window toolbar.

Each entry in the call stack is a stack frame. The stack frames are ordered from innermost (the most
recent handler call) to outermost (the oldest handler call, usually the script’s run handler). Thus, in the
above illustration, top-level code has called the rename handler, which in turn has called the pad handler,
in which we are paused.
Stack frames newly added since the last time the script paused are shown in red.
When multiple stack frames exist, the script can, in a sense, be paused at more than one line
simultaneously. (Thus, in the above illustration, we are paused at three places, whose line numbers are
given in the last column.) Therefore, the script is displayed with multiple green arrows. The line where we
are really paused (within the deepest stack frame) has a solid green arrow; the others have
transparent green arrows.
A stack frame, and the place where the script is paused within it, represent an entire environment. One
stack frame is always the selected stack frame; by default, it is the deepest stack frame. The
environment reflected in the script window changes when a different stack frame is selected. When you
select a stack frame:
The line of the script where we’re paused in that stack frame is highlighted.
The variables pane changes to reflect the variable values in scope in that stack frame.
Expressions are re-evaluated against that stack frame.

Trace
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Variables (Debug Mode)

When a script is paused while debugging, the variables pane displays all variables currently in scope in the
selected stack frame.
Important: This includes local variables — but local variables must be explicitly declared local (with
a local statement), or they won’t be shown.
Variables are displayed in alphabetical order, grouped into the following categories:
1. Inherited variables (blue background).
A script’s persistent variables include those acquired through AppleScript’s script object inheritance
mechanism.
By default, a script’s parent is the AppleScript scripting component. Therefore, the variables pane
will usually display this object and its variables twice — once by virtue of being the script’s parent,
and again by virtue of being the global script object AppleScript.
2. Local parameters (green background). These are incoming parameter values, and are shown if the
currently selected stack frame is a handler with parameters.
3. Local variables (yellow background). These are local to the currently selected stack frame. You
probably won’t see these unless you explicitly declare your locals.
4. Top-level entities.

The variables pane is an outliner, with all that this entails.
The ability to edit a variable value is especially useful when paused while debugging, because you can
experimentally alter the behavior of your script as it proceeds to the next line.
Another way to see variable values is through tooltips that appear when you hover the mouse over an
expression in your script. An Execution preference, “Show expression tooltips,” sets the conditions under
which these appear.

Call Stack
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Expressions

An expression is a snippet of AppleScript code that has a value. Expressions are evaluated every time
the script pauses. This includes the point where the script completes. Expressions are likely to be most
useful to you when paused during debugging. However, you can create and edit expressions at any time.
Expressions are a feature of a script, and are saved when you save a compiled script.
Important: An expression may refer to local variables — but local variables must be explicitly
declared local (with a local statement), or the expression won’t be able to “see” them, and will report
that the variable is undefined.
Expressions are created, edited, and displayed in the expressions pane, which is in the same tab as the
result pane and the variables pane. To see the expressions pane:
Choose View > Result & Variables Tab.
Or, click the first Show button in the script window toolbar.

To create an expression:
Click the + button in the expressions pane.
Or, choose Script > New Expression.
Or, select within a script and choose Script > Copy To Expressions.
To edit an expression:
Select it and press Return.
To force re-evaluation of an expression:
Select it and press the Refresh button.
Or, select it and choose Dictionary > Reload (or choose Dictionary > Reload All).
Or, Control-click it and choose Reload (or Reload All) from the contextual menu.
To remove an expression:
Select it and click the - button in the expressions pane.
Or, Control-click it and choose Delete from the contextual menu.
Or, choose Script > Clear All Expressions (removes all expressions).
The expressions pane is similar to the variables pane:

An expression whose value has changed since the last pause is shown in red.
An expression is re-evaluated when you select a different stack frame in the call stack. The
expression might refer to a local variable, and local variable names can have different meanings in
different stack frames.
The expressions pane is an outliner, with all that this entails.
Note: Evaluating an expression is like running a little one-line script, and even a little one-line script can
do powerful things. An expression that changes a variable’s value, or calls a handler in your script, can
be a valid expression and therefore can have side-effects each time it is evaluated.

Variables (Debug Mode)

Exceptions

Script Debugger Help > Develop > Debug >

Table of Contents

Exceptions

A handled runtime error (an exception) can cause a pause when debugging, like a breakpoint.
A handled runtime error is an error that occurs within a try block. It would not normally cause any break
in the action, because AppleScript will continue execution in the on error clause, or (if there is no on error
clause) after the try block. But Script Debugger can optionally pause when it detects a handled runtime
exception.
An unhandled runtime error causes execution to abort entirely, so there is no question about pausing
there — the script will do more than pause, it will stop.

To pause at handled runtime errors:
Choose Script > Break on Exceptions so that it is checked.
Optionally, you can add an Exceptions button to the script window’s toolbar that toggles breaking on
exceptions (and reflects the state of that toggle).

If Break on Exceptions is checked and a handled runtime error is encountered while debugging, execution
pauses much as if this were a breakpoint, just before the exception is actually thrown. Variables and
expressions are evaluated at that point. A red arrow marks the line where the error occurs.

To learn what the error was, while paused at the error:
Look at the status bar; it contains the error message, as is usual for errors.
Choose Script > Show Last Error; or, click the red arrow. This summons the normal error dialog.
Optionally, you can add a Show Last Error button to the script window’s toolbar.

Even if Break on Exceptions is unchecked, and a handled runtime error does not cause a pause, you can
still learn, at the first pause after the error is encountered, where the error was (the red arrow is still
present) and what the error was:
Choose Script > Show Last Error; or click the red arrow.

Once you resume execution of the script, the exception mark is removed (and Show Last Error will no

longer recover it).
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Code Coverage

Code coverage marks show the lines of your script that were actually executed in debug mode. This
can help you survey the path of execution without tracing or stepping. For instance, you can easily see
whether there are areas of the script that are never being executed.
When code coverage is on, circles appear in the gutter marking executable lines that have been
encountered by the path of execution. The size of the circles is relative: smaller circles have been
encountered fewer times. The actual number of hits (the number of times execution has passed through a
line) is shown in a tooltip when you hover the mouse over a circle.

To turn on code coverage:
Choose Script > Show Code Coverage so that it is checked.
To clear code coverage circles without turning code coverage off:
Choose Script > Clear Code Coverage.
Code coverage circles are reset automatically when you execute the script from the start.

Exceptions
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External Debugging

You can initiate a script outside Script Debugger and still debug it in Script Debugger. The script opens
in Script Debugger and you can pause at breakpoints, resume or step through the script, and so forth. This
is called external debugging.
External debugging is probably the only situation where it makes sense to save a script in debug mode
and yet permit it to run in some application other than Script Debugger!

It is often easier to use external debugging and test a script under the conditions in which it will actually
run than to try to simulate those conditions artificially. A good candidate for external debugging is an
applet, a folder action, an Apple Mail rule script, a BBEdit menu item script, or any script that is to be
triggered automatically by some other application. External debugging is especially useful when parameters
are supplied as part of the call that triggers the script, since it shows you what those parameters are.
It often happens that the host application triggers the script by calling into a handler. In that case, this
handler becomes the current event. The current event indicator appears at the top of the script, and the
call is recorded in the event history. You can then subsequently call the same handler again with the same
parameters, directly from within Script Debugger.
To perform external debugging:
1. Save a compiled script in debug mode.
2. Trigger the script in some other application.
The script opens automatically in Script Debugger if it wasn’t open already.
If the script was already open in Script Debugger when it is triggered, it remains open after it
finished. If it wasn’t already open in Script Debugger, then when the script finishes, it closes.
If the script wasn’t already open in Script Debugger beforehand, the name of the script, in the
script window’s title bar, will appear as the name of the host application with “(Debugging)”
appended to it, as a sign that external debugging is proceeding in a temporary window.

Switching the Frontmost Application
Various Execution preferences determine how Script Debugger will behave with regard to pausing, and with
regard to bringing itself and the initiating application to the foreground:
“Pause script when external debugging begins.” If checked, Script Debugger inserts a temporary
breakpoint before the first executable line, and pauses there when the host application initiates the
script. This gives you a chance to configure breakpoints, for example.
“Restore active application when stepping/continuing.” If checked, the host application is brought
back to the front when resuming after a pause.
“Bring Script Debugger to foreground when scripts pause.” If checked, Script Debugger is brought to
the front when the script pauses.

“Bring Script Debugger to foreground when scripts ends.” If checked, Script Debugger is brought to
the front when the script ends.
If you decide that Script Debugger should not bring itself to the foreground, you can still control debugging
from within the host application by using the Mini Debugger.

Hands-On Example
Here’s an example, using an Apple Mail rule script. A rule script is structured like this:
using terms from application "Mail"
on perform mail action with messages theMessages for rule theRule
tell application "Mail"
-- do useful things here
end tell
end perform mail action with messages
end using terms from
Compile that script, put it in debug mode, place a breakpoint on the “tell” line, save it, and then (in Mail)
nominate this script as the Run AppleScript action in a Rule. Trigger the rule by selecting some messages
and choosing Message > Apply Rules. Depending on the choices you made in the preferences, Script
Debugger may now come to the front; in any case, it is paused at the breakpointed line. You can examine
theMessages to see what messages Mail has matched up with your rule’s criteria. Moreover, perform
mail action is the current event, and has been added, with these parameters, to the event history.

Code Coverage
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The Mini Debugger

The Mini Debugger is a floating window that puts Script Debugger’s frontmost script window in front of all
applications on your screen.
Most AppleScript code involves targeting scriptable applications (and some AppleScript code is called by
other applications, as with external debugging). Thus it is often convenient to have some control over
Script Debugger while keeping some other application frontmost, so that you can work in or observe
that application, without changing the layering order among your applications. That’s what the Mini
Debugger lets you do.

To summon the Mini Debugger:
Choose Window > Mini Debugger.
If you’re in another application, choose Mini Debugger from Script Debugger’s Dock menu.
The Mini Debugger window contains:
A reduced version of the script window toolbar, showing only the Action buttons. There is also a
Script Debugger toolbar button; click it to bring Script Debugger frontmost.
The gutter. You can set breakpoints and see code coverage.
The result bar. This gives the latest result at each pause, in source view.
A minimally editable text area. You can edit the script using keystrokes, and the text area
contextual menu works. Full editing features such as code completion, however, are absent.

External Debugging
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This is the reference section.
It surveys Script Debugger’s menus.
It describes Script Debugger’s preferences.
It discusses Script Debugger’s windows.
It provides a brief glossary and answers some frequently asked questions.
Further Details:
Menus
Preferences
Windows
Glossary
Frequently Asked Questions

Develop
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Menus

This is a reference section describing all of Script Debugger’s menus.
You can customize the keyboard shortcut for a menu item:
Open Script Debugger’s Preferences window and go to the Key Bindings pane.
Hint: In some cases where you find yourself using a command often, you may find that a toolbar item is
supplied. Choose View > Customize Toolbar and examine the available toolbar items. If the command
has a toolbar item, you can drag it into the toolbar, and from then on you can use that toolbar item as a
way of issuing the command.

Further Details:
Application Menu
File Menu
Edit Menu
View Menu
Search Menu
Script Menu
Dictionary Menu
Window Menu
Clippings Menu
Scripts Menu

Preferences
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Application Menu

Send Us Email
In your preferred email program, creates a new email message addressed to Late Night Software.
Check For Updates
Goes online to check whether there is a more recent release of Script Debugger. A Software Update
preference allows you to set this action to be performed automatically at fixed intervals.
Purchase Script Debugger
Takes you in your browser to the Late Night Software web site, where you can buy a Script
Debugger license.
Enter / Change License
Presents a dialog where you can enter or re-enter registration information.
Preferences
Summons the Preferences window.
Other menu items in this menu are standard OS X application menu commands.

File Menu
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File Menu

New Script
Creates a new script window, sized and configured according to your saved defaults, if any.
If the General preference “For New Documents” is “Show Template Chooser”, the template chooser
appears instead.
New Script From Template
Shows the template chooser for creation of a new script window.
New Script Tab
Creates a new script as a tab in the frontmost script window.
If the General preference “For New Documents” is “Show Template Chooser”, the template chooser
appears instead.
New Script Tab From Template
Shows the template chooser for creation of a new script tab.
Open
Brings up a file dialog where you can choose a script file (to open it for editing) or an application
(to open its dictionary).
Open Quickly
Brings up a dialog where you can enter part of the name or contents of a script to do a Spotlight
search.
Open Recent
Lists, and lets you open, recently opened scripts.
Open Dictionary
Presents a hierarchical menu where you can open the dictionary of a scripting addition or an
application in the Running, Recent, or Favorites category of the dictionaries list. To open the
dictionary of an application not listed here, choose Application (the first item in this menu).
Open XXX Dictionary
Opens the dictionary for the current tell context.
Open Script Library “XXX”
Opens a library script file (or its dictionary) when the selection is in a line referring to the library
script. (Alternates with the previous menu item.)

Open Explorer Window
Opens the currently selected outliner item in a separate explorer window. (Alternates with the
previous menu item.)
Close Tab
Closes the frontmost window; if the frontmost window is a script window consisting of multiple
tabs, closes the current tab. If closing a “dirty” script, you’ll be offered a chance to save it.
Close Window
Closes the frontmost script window, even if it consists of multiple tabs. If any of the scripts in those
tabs are “dirty”, you’ll be offered a chance to save them.
Close All
Closes all windows. If any scripts are “dirty”, you’ll be offered a chance to save them.
Save
Saves the frontmost script. If the frontmost script has never been saved, works like Save As.
Save As
Brings up a dialog for saving the frontmost script as a new file, possibly in a different format.
Save A Copy As
Similar to Save As, except that afterwards the script window shows the old file, not the newly
created file.
Save All
Performs a Save on every “dirty” script.
Revert To Saved
Reopens the frontmost script from its previously saved state, throwing away any changes made
since the last save.
Recover Damaged Script
Brings up a dialog where you can choose a script file to open as text if possible. The text is pasted
into a new untitled script window or tab.
Export Run-Only Script
Saves a copy of the current script as a run-only script.
Save as Template
Saves a copy of the current script as a user template, to appear in the template chooser as a basis
for future new scripts.
Edit With BBEdit / TextWrangler
Opens a text copy of the current script in the target application, initiating an external editing
session.

Show Manifest
Brings up a dialog listing the current script’s dependencies.
Script Format
Lets you set the format in which the script should be saved. Only formats compatible with the
script’s present format are enabled; to change to another format, choose File > Save As.
Application Options
If the script is an applet (script application), lets you set its applet options.
Code Signing
If the script is an applet, lets you code sign it (or turn off code signing).
Reveal in Finder
Reveals in the Finder the current document (for a saved script), application (for a dictionary), or
reference (for a selected reference to a Finder item in an outliner).
Open in New Window
Opens an additional window on the current script or dictionary.
Quick Look
Displays, using Quick Look, the currently selected reference to a Finder item (alias or file
reference) in an outliner.
Page Setup
Standard OS X page setup command. Brings up the standard dialog for preparing to print.
Print
Standard OS X print command. Brings up the standard dialog for printing the frontmost script or
dictionary.
You can force a page break in the printed output of a script by including the word !pagebreak! in
a comment at the point where you want a new page to start.

Application Menu
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Edit Menu

Undo
Undoes the most recent change to the current script.
Redo
Undoes the most recent undo to the current script.
Cut
Moves selected text from the current script to the clipboard. This includes formatted text suitable
for pasting into a word processor.
Copy
Copies the selected material to the clipboard. The selection might be (for example) text in a script
or a result, text in the info pane of a dictionary window, a term in the terminology list of a
dictionary window, a line of the event log, or a line of an outliner (in which case what is copied is
an AppleScript reference). This includes formatted text suitable for pasting into a word processor.
Copy Value
Copies the value (instead of a reference) of the selected line of an outliner. (Alternates with the
previous menu item; hold Shift to see it.)
Paste
Pastes the clipboard into the current selection in a script.
Paste As String Literal
Pastes the clipboard into the current selection in a script, wrapped in quotation marks (unless the
insertion point is already inside a string literal). Internal quotation marks, tabs, and line-end
characters are escaped.
Paste Tell
Presents a hierarchical menu showing the dictionaries list, from which you can choose an
application. Pastes a tell block into the current selection in a script. If no script window is open, or
if you hold down the Option key, creates a new script window containing the tell block.
For a running application, further hierarchical menus allow you to paste a reference to an object in
the application’s object model.
Delete
Clears the selected text without moving it to the clipboard. Also works on any selectable removable
entity (an expression, a bundle resource, etc.).

Select All
Selects all text in the current selection context.
Balance
Selects surrounding delimiters or block boundaries.
Code Folding > Fold / Unfold
Collapses or expands the block containing the selection.
Code Folding > Unfold All
Expands all collapsed blocks in the script.
Code Folding > Fold / Unfold Handlers
Collapses or expands all handlers in the script.
Code Folding > Fold / Unfold Block Comments
Collapses or expands all block comments in the script.
AppleScriptObjC > …
Click here to read about AppleScriptObjC refactoring.
Go to Line
Presents a dialog allowing you to jump to a line of a script by its line number.
Go to Current Line
Scrolls to the line of a script that has the green arrow in debug mode.
Go to Previous / Next Handler
Selects and scrolls to the start of the next or previous handler in the script.
Go to Previous / Next Placeholder
Selects and scrolls to the next or previous placeholder in the script.
Commit Placeholder
Turns the currently selected placeholder in the script into normal text.
Split Editor Vertically / Horizontally
Splits the script window editing area.
Close Split View
Closes the current split pane in the script window editing area.
Close All Script Views.
Closes all split panes in the script window editing area. (Alternates with the previous menu item;
hold Option to see it.)

Shift Left / Right
Removes or adds a level of indentation to the lines containing the selection.
Comment / Uncomment
Adds or removes a level of comment characters to the start of the lines containing the selection.
Entab / Detab
Changes leading indentation to tabs or spaces in the lines containing the selection.
Start Dictation
Standard OS X dictation command.
Emoji & Symbols
Standard OS X character chooser command.
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Show / Hide Toolbar
Toggles visibility of the toolbar for the current window.
Customize Toolbar
Brings up the dialog for customizing the contents of the toolbar for the current window type.
Show / Hide Tab Bar
Toggles display of the script window tab bar. If the tab bar is showing, it will be present even if the
window contains only a single script.
Show / Hide Navigation Bar
Toggles visibility of the navigation bar in the script window.
Show / Hide Result Bar
Toggles visibility of the result bar in the script window.
Show / Hide Status Bar
Toggles visibility of the status bar in the script window.
Show Progress
If checked, the progress bar will appear in response to progress reporting commands.
Result & Variables Tab
In the script window, toggles visibility of the result pane, the variables pane, the expressions pane,
and the call stack pane and breakpoints pane (when debugging).
Resources Tab
In the script window, toggles visibility of the script’s description and the bundle inspector (if the
script is in a bundle format).
Inspectors Tab
In the script window, toggles visibility of the clippings inspector, the dictionaries inspector, and the
tell context inspector.
Best View
Source View
AEPrint View
Switches between views in the current explorer pane or explorer window. Hold Shift to show
multiple views simultaneously.

Show / Hide Event Log
Toggles display of the event log pane in the script window.
Show / Hide Event Log Result Explorer
Toggles display of the second pane of the event log pane or event log window, consisting of an
explorer on the result of the Apple event selected in the event list.
Log As Source / Raw (Chevron) Syntax / AEPrint
Changes the “language” used to display events in the event list of the event log pane or event log
window.
Show Code Folding
Toggles visiblity of code folding symbols, and enabling of code folding commands, in the current
script.
Show Line Numbers
Toggles visibility of line numbers in the current script.
Show Tab Stops
Toggles visibility of tab stops in the current script or explorer.
Show Invisibles
Toggles visibility of invisible characters in the current script or explorer.
Show Spaces
Toggles visibility of space characters in the current script or explorer.
Wrap Lines
Toggles line wrapping in the current script or explorer.
Pretty Print
Toggles pretty-printing in the current explorer.
Show Raw (Chevron) Syntax
Toggles display of terminology as raw Apple event codes in the current script, explorer, or
dictionary.
Enter / Exit Full Screen
Standard OS X full-screen mode commands.
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Find
In a script window, or in a dictionary window displaying the info pane, summons the find bar.
Find & Replace
In a script window, summons the find bar in Replace mode.
Find Again
Finds the search string, searching forwards, starting at the current selection.
Find Again Backwards
Finds the search string, searching backwards, starting at the current selection.
Find Selection
Copies the current selection as the search string and performs a Find Again.
Find Selection Backwards
Copies the current selection as the search string and performs a Find Again Backwards.
Use Selection for Find
Copies the current selection as the search string.
Use Selection for Replace
Copies the current selection as the replace string.
Replace
Replaces the current selection with the replace string.
Replace & Find Again
Performs a Replace followed by a Find Again.
Replace & Find Again Backwards
Performs a Replace followed by a Find Again Backwards.
Replace All
Replaces all instances of the search string with the replace string. Behavior is affected by the Wrap
checkbox.
Look Up Definition

In a script, copies the current selection into the search field of the dictionaries inspector and
performs the search. In a dictionary window, puts the focus in the search field in the toolbar.
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The Script menu applies to the current script window or tab. If no script window is frontmost, the Script
window menu items are disabled.
Compile
Compiles the script.
Recompile
Forces recompilation even when AppleScript doesn’t think the script needs compiling. (Alternates
with the previous menu item; hold Option to see it.)
Record
Turns on AppleScript recording mode, so that user actions in recordable applications are written
into the script.
Execute
Runs the script, compiling it first if necessary. When paused in debug mode, becomes Resume, and
continues execution from the paused line. Submenus allow standard handlers to be called
individually.
Trace
In debug mode, starts tracing. Submenus display the tracing speed slider and allow standard
handlers to be called individually.
Stop
Aborts the running script.
Pause
In debug mode, pauses the script after the line currently being executed.
Step Over, Step Into, Step Out
The step commands, used in debug mode. Submenus allow standard handlers to be called
individually.
Enable Debugging
Toggles on or off debug mode.
Persistent Properties
Toggles on or off persistence of global variables when a script is closed and later opened.
Show Result Explorer Window

Shows the result as a separate explorer window.
Show Last Error
Shows the error dialog for the most recently encountered error.
Show Leaks
Shows the leaks dialog.
Show Code Coverage
Toggles code coverage display on or off.
Clear Code Coverage
Removes code coverage marks without toggling code coverage off.
Show Event Log in Window
Shows the event log window for the current script.
Clear Event Log
Removes all events from the event log.
Append To Event Log
If checked, the event log is not automatically cleared when beginning a new execution of the
script.
Break on Exceptions
In debug mode, toggles whether or not handled runtime errors cause a pause.
Break on Breakpoints
In debug mode, toggles whether or not breakpoints are enabled globally for this script.
Edit Breakpoint
Summons the conditions and actions popover for the currently selected line’s breakpoint.
Set / Disable / Enable Breakpoint
Creates or toggles the enabled status of a breakpoint at the currently selected line.
Set Temporary Breakpoint
Creates a temporary breakpoint at the currently selected line. (Alternates with the previous menu
item; hold Option to see it.)
Remove Breakpoint
Removes the breakpoint at the currently selected line.
Remove All Breakpoints
Removes all breakpoints. (Alternates with the previous menu item; hold Command to see it.)

Remove All Disabled Breakpoints
Removes all disabled breakpoints. (Alternates with the previous menu item; hold Shift and
Command to see it.)
Execute to Here
Sets a temporary breakpoint at the currently selected line and starts or resumes execution.
Trace to Here
Sets a temporary breakpoint at the currently selected line and starts tracing. (Alternates with the
previous menu item; hold Command to see it.)
New Expression
Creates a new empty expression, ready for editing.
Copy To Expressions
Creates a new expression by copying the current selection.
Clear All Expressions
Deletes every expression.
Default Target
Sets the implicit target for the script.
Parent Script
Sets the parent of the script to another currently open script.
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The Dictionary menu applies to the current dictionary window. If no dictionary window is frontmost, the
Dictionary window menu items are disabled.
Reload
In the current value outliner, reloads information that’s hierarchically dependent on the currently
selected line.
Reload All
In the current value outliner, reloads all information. (Alternates with the previous menu item; hold
Option to see it.)
Paste Tell
Inserts a tell block into the current script.
Launch / Activate XXX
Starts up or brings to the front the application XXX.
Quit XXX
Quits the application XXX.
Show Dictionaries List
Toggles visibility of the dictionaries list in the dictionary window.
Show Dictionary
In the dictionary window, displays the terminology list and the info pane.
Show Object Model
In the dictionary window, displays the object model diagram and the info pane.
Show Containment
In the dictionary window object model diagram, displays the containment hierarchy.
Show Inheritance
In the dictionary window object model diagram, displays the inheritance hierarchy.
Show Explorer
In the dictionary window, displays the application explorer.
Go Back / Forward

Navigates the history in the dictionary info pane or explorer.
Show Inherited Definitions
Toggles whether or not the inherited properties and elements appear in this dictionary’s display.
Show Extra Documentation
Toggles whether or not extended explanatory content appears in this dictionary’s display.
Larger Text / Smaller Text
Increases or decreases the size of information in this dictionary’s display.
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Minimize
Standard OS X window minimization command.
Zoom
Standard OS X window zoom command.
Bring All to Front
Standard OS X command for bringing all the application’s windows forward, out from between
those of other applications.
Select Next / Previous Tab
Navigates between tabs in the current script window.
Set Default Script / Dictionary Window / Explorer Window Size & State
Saves the configuration of the current script window, dictionary window, or explorer window as a
model for future new ones.
Reset Default Script / Dictionary Window / Explorer Window Size & State
Reverts to the default configuration for future new script windows, dictionary windows, or explorer
windows.
Dictionary
Switches to the frontmost dictionary window, or opens a new dictionary window.
New Dictionary Window
Opens a new dictionary window. By default, the same as the previous menu item, plus Shift.
Mini Debugger
Opens the floating Mini Debugger window.
The Window menu also lists all open windows. Tabs are shown hierarchically dependent on their window
title.

Dictionary Menu

Clippings Menu

Script Debugger Help > Reference > Menus >

Table of Contents

Clippings Menu

The Clippings menu (
folder.

) accesses clippings. Each menu item represents a file (or folder) in the Clippings

Text files to go into the Clippings menu should live in ~/Library/Application Support/Script Debugger
6/Clippings.
A file will appear as a menu item. A folder will appear as a hierarchical menu, and the files inside it will be
its menu items. The name of a file (or folder) is the name that will appear in the menu, except that certain
names or part-names are hidden and used for determining the order of the menu, as follows:
If a name starts with the prefix #), where # is a whole number of any length, that number
determines the position of this item in the menu and the prefix does not appear in the menu item’s
name.
A name #)-*** will appear as a menu separator, again with its order determined by the whole
number #.
Here are the actions you can perform with the menu items in the Clippings menu:
Choose a menu item to insert that clipping into the current script window.
Hold down the Option key while choosing a menu item to open that clipping for editing.
Hold down the Shift key while choosing a menu item to reveal the clipping file in the Finder.
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The Scripts menu (
Scripts folder.

) accesses auxiliary scripts. Each menu item represents a file (or folder) in the

Scripts to go in the Scripts menu should live in ~/Library/Application Support/Script Debugger 6/Scripts/.
/Scripts/*.) %>
A file will appear as a menu item. A folder will appear as a hierarchical menu, and the files inside it will be
its menu items. The name of a file (or folder) is the name that will appear in the menu, except that certain
names or part-names are hidden and used for determining the order of the menu, as follows:
If a name starts with the prefix #), where # is a whole number of any length, that number
determines the position of this item in the menu and the prefix does not appear in the menu item’s
name.
A name #)-*** will appear as a menu separator, again with its order determined by the whole
number #.
Here are the actions you can perform with the menu items in the Scripts menu:
Choose a menu item to run that script.
Hold down the Option key while choosing a menu item to open that script file for editing.
Hold down the Shift key while choosing a menu item to reveal the script file in the Finder.
Scripts intended for the Script menu may be AppleScript scripts, shell scripts, Automator workflows, or
applications. A shell script must have an identifying filename extension (this will usually be .sh).
A script in the Scripts menu can drive Script Debugger itself. Such a script does not need to include a tell
block targeting Script Debugger; Script Debugger is implicitly the tell target.
You can debug a script in the Scripts menu by opening it in Script Debugger and putting it into debug
mode. Leave the script open in Script Debugger and choose it from the Scripts menu to run it. It will pause
at a breakpoint if there is one. This is effectively a form of external debugging.
If a script initiated from the Scripts menu takes a long time to execute, a progress dialog appears. This
dialog contains a Stop button that you can use to abort the script if you think something has gone wrong
(or if you just don’t feel like waiting — you cannot do anything else in Script Debugger while a script is
running from the Scripts menu).
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When you choose the Preferences menu item from the application (Script Debugger) menu, you summon
the Preferences window. It has eight preference panes. These pages describe the options on each pane.
The Factory Defaults button on each pane sets the options in that pane to the Late Night Software default
values.
All changes to preference options take effect immediately — except for the AppleScript Formatting settings
in the Fonts & Colors preferences, which have to be set with the Apply button (because in this case, you’re
talking to AppleScript, not to Script Debugger).
Further Details:
Preferences:
Preferences:
Preferences:
Preferences:

General
Editor
Text Substitution
Fonts & Colors

Preferences:
Preferences:
Preferences:
Preferences:

Execution
Dictionary
Key Bindings
Software Update

Menus

Windows
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Preferences: General

The General preferences pane collects a number of options having mostly to do with Script Debugger’s
startup behavior and how Script Debugger opens and saves script files.

On Startup:
Remember open scripts
If checked, then when Script Debugger quits, all open scripts are remembered and will be
reopened automatically the next time Script Debugger starts up.
Create new script if nothing else is open
If checked, then when Script Debugger starts up, if no other window opens, a new script window
will be created.

On Reopen:
Create new script if nothing else is open
If checked, then when Script Debugger gets a Reopen event when no window is open, a new script
window will be created. A Reopen event is sent, for example, when you click on Script Debugger’s
Dock icon (but not when you press Command-Tab to switch to Script Debugger).

For New Documents:
Show Template Chooser
When you choose File > New Script or File > New Script Tab, Script Debugger will behave as if you
had chosen File > New Script From Template or File > New Script Tab From Template, presenting
the template chooser.
Use template
When you choose File > New Script or File > New Script Tab, Script Debugger will use the template
listed here as the default basis for the new script.
Choose Template
This button summons the template chooser so that you can pick a different template to be
the default basis for new scripts.

Opening Documents:
Open in Tabs
If checked, then when an existing script is opened, it will be displayed in a tab in the frontmost
script window if there is one. Otherwise, it will be displayed as a separate script window.

As the note beneath this checkbox explains, you can hold Shift while opening a script to reverse
this behavior on a particular occasion. So, for example, if the checkbox is checked and you open a
script while holding Shift, the script will be displayed as a separate script window.
Warn when applications may be launched
If checked, then when Script Debugger begins opening a script file that might cause AppleScript to
launch an targeted application, it puts up a “Launch Applications?” dialog.
Always open as text without launching applications
If checked, then when Script Debugger begins opening a script file that might cause
AppleScript to launch an targeted application, Script Debugger opens the script as text if
possible — thus bypassing AppleScript altogether and so preventing the targeted
application from launching (and so there is no “Launch Applications?” dialog). AppleScript
may still subsequently launch the targeted application if you later compile the script.

Bundle ID Prefix:
String to be used by default as the start of the bundle ID for script bundles; Script Debugger will combine
this prefix with the script’s name. By convention, the identifier starts with com. and is structured like a
reverse URL hostname. You should set this prefix to something likely to be unique to yourself, so that every
applet you create will have a unique identifier.

Copyright Notice:
Copyright text to appear in the Finder’s Get Info window for script bundles. By default, Script Debugger
derives the copyright string for an applet from this text. You can use expansion tags here; the result is
displayed below the text field.

Mac OS Settings:
Respond to applescript:// URLs in web pages
The applescript: URL scheme permits a hyperlink (in a web browser, a PDF document, and so
forth) to contain AppleScript code, to be displayed by a script editor application when the link is
clicked. (The script editor application does not automatically run the code, as that would be a
security violation.) By default, the protocol sends its messages to Apple’s Script Editor, and Apple
provides no interface for changing this target. This checkbox is provided so that you can switch the
routing of the protocol to Script Debugger.
Default editor for OSA scripts, applets, and droplets
OS X determines from a document’s filename extension what application opens the file. This
checkbox lets you associate the relevant filename extensions (.scpt and so on) with Script
Debugger. (It also causes Script Debugger to be the editor that responds to the Edit button in an
applet’s runtime error dialog.)
In theory, you could accomplish the same thing by choosing Script Debugger in the Default
Script Editor pop-up menu of Apple’s own Script Editor’s preferences.

Restore Suppressed Alerts
Some warning dialogs in Script Debugger, such as the Remove All Breakpoints dialog, contain a “Do not
show this message again” checkbox, which you can check to suppress that warning dialog from then on.

Click Restore Suppressed Alerts to uncheck those checkboxes, so that all warning dialogs appear once
again.
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The Editor preferences pane collects a number of options having mostly to do with Script Debugger’s
behavior as you type, as well as certain appearance settings in script windows and other windows.

Editing Options:
Auto-indent
If checked, then when you create a new line in a script window by typing Return, or paste text into
a script window, its indentation will match the indentation of the preceding line. Otherwise, the
new material will start at the left edge of the window. (AppleScript will indent properly in any case
when the script is compiled.)
Auto-pair delimiters ([{" "}])
If checked, turns on Script Debugger’s auto-pairing feature.
Wrap selection with delimiters
If checked, then when you type a left delimiter when there’s a selection, the paired
delimiters wrap the selection (rather than having the left delimiter replace the selection).
Auto-close AppleScript blocks (end tell, etc.)
If checked, turns on Script Debugger’s auto-closing feature.
Reference applications by ID when pasting Tell blocks
If checked, then when Script Debugger performs its Paste Tell behavior to create a tell block
targeting an application, the application’s bundle id (such as id "com.apple.finder") is used in the
outermost tell block, rather than its name.
This AppleScript feature was introduced in Leopard (OS X 10.5). This way of specifying an
application has the advantage that it doesn’t require the application’s name to remain constant (or
that you state the name correctly), and that it will never generate AppleScript’s dreaded “Where
is…?” dialog.
Paste Object References as nested Tell blocks
If checked, then when pasting an object reference (such as you might obtain by copying from an
outliner), what’s pasted is a nest of tells. If unchecked, what’s pasted is a single line of ofs
(though of course the outermost reference to the application itself will still be a tell block).
Use properties for Cocoa terms in completion, clippings
If checked, AppleScriptObjC code inserted by code completion and clippings is refactored.
Option-click opens terms in Dash

If checked, Option-clicking an AppleScript language term or an Objective-C Cocoa term looks up
that term in Dash, if you have it installed.
Synchronize split-view appearance
If checked, then changing a view setting in a split view pane changes the same setting for the
other panes of the same script. Hold down the Option key as you change a view setting to reverse
the behavior from your preference here.
Synchronize split-view selection
If checked, then selecting in one split view pane selects the same text in the other panes.
Balance includes enclosing ([{ }]) delimiters
If checked, then the balance command selects everything including the delimiters surrounding the
starting selection; otherwise, it selects everything enclosed by the delimiters surrounding the
starting selection.
Auto-hilite opening ([{ when typing closing }])
If checked, then when you type a right delimiter, the corresponding left delimiter is momentarily
highlighted (and if there isn’t one, Script Debugger beeps).
Hilite delay
Sets the length of time during which the momentary highlighting is present.
Scroll if necessary
If checked, Script Debugger will scroll backwards if needed to reveal the highlighted left
delimiter.
Highlight blocks when mouse hovers in gutter
If checked, nested blocks are shaded and selectable by hovering the mouse to the left of a script.
Show compiled state in gutter
If checked, uncompiled scripts display stripes in the gutter.

Table Of Contents Options:
Sort table of contents menu alphabetically
If checked, the table of contents pop-up menu is sorted alphabetically. Otherwise, its order is the
order in which things appear in the script. Hold down the Shift key while summoning the table of
contents menu to see it sorted in the order opposite to your preference here.
Show navigation bar location when scrolling
If checked, then as you scroll a script window, a tooltip appears showing the line number of the
line currently appearing at the top of the window, along with other navigation bar information
about that line.

New Line Character:
Sets the line-end character that is typed in a script when you press the Return key.

Tab Width:
Sets the number of spaces to which a tab character should be equivalent. This is how far a nested block is
indented in a compiled script, how far apart tab stops are, and how many spaces a tab character is
converted to when you choose Edit > Entab.

Edit > Comment Inserts:
Sets the string prefixed to the start of each selected line by the Edit > Comment command. AppleScript
comments can start with -- or #.

Preferences: General
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The Text Substitution preference pane is where you manage text substitutions. If substitution is turned on,
then when you type an enabled “Replace” column entry followed by a non-word character (such as a space
or a Return), the corresponding “With” column entry will be substituted for it.
Text substitutions use the same expansion tags as clippings. Thus, the text inserted through a text
substitution can contain placeholders, of which one may initially be selected.

Text Substitutions:
Enabled
If checked, the substitution feature is turned on.
Import / Export
These buttons permit exchange of text substitutions between this preferences pane and a text file
in .plist format.
On
Whether an individual abbreviation is enabled.
Replace
The abbreviation you enter in your script. Double-click to edit.
With
The substitution that will replace the abbreviation in your script. Double-click to edit.
Plus Button
Add a new abbreviation.
Minus Button
Remove the selected abbreviation.
Search Field
Filter the list of abbreviations. Both the Replace column and the With column are searched.
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The Fonts & Colors preferences pane provides options having mostly to do with script formatting and text
sizes.

Editor Colors
Background
The background color of the text area of script windows, and of text views of explorers (i.e., Source
view and AEPrint view).
Insertion Point
The color of the flashing insertion point cursor in a script.
Selection
The color of the selected stretch of text in the text area of script windows, and of text views of
explorers.
Tab Stops
The color of the vertical lines marking tab stops, if visible.
Insertion Line Highlight
The highlight color of the entire line containing the insertion point in a script. The line is highlighted
as long as the selection does not include any end-of-line characters. The checkbox toggles this
feature off completely.
Current Line Highlight
The highlight color of the entire line that’s about to be executed in debug mode. The checkbox
toggles this feature off completely.
Error Line Highlight
The highlight color of the entire line marked as the location of an error. The checkbox toggles this
feature off completely.
Multiple colors can be overlaid on one another (because a line might be highlighted for multiple reasons,
including being selected); that’s why the highlight colors all have some transparency by default. Feel
free to experiment, but if you accidentally make your scripts illegible, click the Factory Defaults button to
revert them.

AppleScript Formatting:
The pretty-printing of compiled scripts is provided by AppleScript (as part of the decompilation process),
not by Script Debugger. This part of the Fonts & Colors preference pane thus accesses AppleScript’s

preferences.
You can select a single line and summon the Fonts or Colors dialog to change its setting; or, select multiple
lines of the table and summon the Fonts or Colors dialog to change their font or color all at once.
Changes are not sent to AppleScript until you click the Apply button. When you do, any compiled scripts
that are open now, as well as any compiled script files that you open or create in the future, will take on
the formatting you have specified. To cancel (changing your mind without applying your changes), switch
to another pane, or close the window.
Apply color to method and handler names
If checked, Script Debugger will detect intelligently terms that are names of Objective-C methods
and AppleScript handlers, and will apply this color to them (rather than the color that AppleScript
would apply, which fails to distinguish such terms from variables).

Plain Text Formatting:
The font and color of plain text in explorers that is not formatted as decompiled AppleScript. For example,
AEPrint view is just plain text, so this preference applies to it. Similarly, a string in Best view is plain text —
but the same string in Source view is an AppleScript literal.

Font Sizes:
Outliners/Inspectors
The text size in outliners and various script window inspectors and panes such as the clippings
pane.
Event Log
The text size in the event log.
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The Execution preferences pane collects a number of options having to do with Script Debugger’s behavior
when running and debugging scripts.

Execution Options:
Pause script when external debugging begins
If checked, then when external debugging starts (that is, a script saved in debug mode starts to
run in some other context), Script Debugger will pause before the first executable line of the script.
Restore active application when stepping/continuing
If checked, then when you resume execution after a pause, the application that was active before
the pause is brought to the front (unless the script is being controlled from Script Debugger’s Dock
menu).
Show expression tooltips
If checked, then when you hover the mouse over text in a script window, the AppleScript
expression under the mouse will be evaluated and its value shown in a tooltip. In some cases, it
will help to select the desired expression first and then hover the mouse over it.
For your safety, Script Debugger prevents evaluation of an expression if evaluating it takes a long
time or might have major side effects like deleting or altering an object (such an expression will
generate no tooltip).
Tooltip delay
The delay between the time when the mouse hovers over an AppleScript expression and
the time when the expression is evaluated.
Show only while debugging
If checked, then these tooltips appear only when the script is paused in debug mode.
Include tell context
If checked, then if there is a tell context, it is included at the start of the tooltip (as in the
illustration — if this option were not checked, everything up to the colon would be absent).

Bring Script Debugger to foreground when scripts pause
If checked, then when pausing in debug mode, Script Debugger comes to the front.

Bring Script Debugger to foreground when scripts end
If checked, then any time a script finishes executing, Script Debugger comes to the front (unless
the script is being controlled from Script Debugger’s Dock menu).
Show result when scripts pause or end:
The question here is what should happen with regard to the display of the result when a result is
produced (unless the result is already visible).
The choices are:
No
Nothing happens.
Show Result Inspector
The result pane appears (along with the variables pane and so on).
Show Result Bar
The result bar appears.
Show Result Explorer Window
The result is shown as a separate explorer window.
Hide Event Log windows on deactivate
If checked, event log windows are hidden when Script Debugger is in the background.
Hide Explorer windows on deactivate
If checked, explorer windows are hidden when Script Debugger is in the background.

Script Error Actions:
Bring Script Debugger to foreground
If checked, then Script Debugger comes to the front when it puts up a runtime error dialog.
Otherwise, Script Debugger bounces the notification icon in the Dock.
Beep
If checked, then Script Debugger beeps when it puts up a runtime error dialog.
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The Dictionary preferences pane collects a number of options having to do with the appearance and
behavior of dictionary windows and explorers.

Opening:
Governs what should happen when you open a dictionary. The issue here is that a dictionary window has
three possible states, so which one should appear when the window opens? Your choices are:
Show Dictionary
The dictionary window displays the terminology list and the info pane.
Show Object Model
The dictionary window displays the object model diagram and the info pane.
Show Explorer
The dictionary window displays the application explorer.
Remember state
The state that appears is the state that was showing when the dictionary window for this
application was closed previously.

Dictionaries List Options
Large icons indicate running applications
If checked, then in some places where the dictionaries list appears (the dictionary window, the File
> Open Dictionary menu), running application icons and the Scripting Additions icon are large.
Only search Applications folder for dictionaries
If checked, then when Script Debugger populates the All section of its dictionaries list at launch
time, it doesn’t look outside the Applications folder. Applications that Script Debugger subsequently
meets for other reasons (because they are running, or recent, or because you open their
dictionaries) will be added to the list as well. Depending on how your hard disk is organized, this
can reduce the overall size of the dictionaries list.

Explorer Options:
Show contents of list and record values
Controls how outliners display the Value column for lists and records. if checked, the value is a
literal list similar to Source view; if unchecked, the value is shown as the item count (e.g., “list of 2
items”).

Show description tooltips
If checked, a tooltip appears when the mouse is hovered over the Element/Property column of an
outliner, displaying the comment from the corresponding dictionary entry.
Show value tooltips
If checked, a tooltip appears when the mouse is hovered over the Value column of an outliner,
displaying the comment from the corresponding dictionary entry for that value’s class if there is
one.
Render HTML string values as HTML page
If checked, then Best view for an HTML string is rendered as in a Web browser.
Show N elements at a time
The number of elements to be shown initially in an outliner when the elements of an element
collection are displayed. If there are additional elements, a Show More button appears. Limiting the
number of elements displayed at a time reduces the number of Apple events that Script Debugger
must send.
Access Elements by Index / ID / Name
The default specifier for initially accessing elements of an element collection for display in an
outliner. You can change the specifier with the pop-up menu in the outliner. If the requested
specifier fails (because the application doesn’t respond to it), Script Debugger automatically falls
back on a different specifier.

Dictionary Caching:
Cache generated dictionaries
If checked, Script Debugger maintains cached copies of application dictionaries. This makes display
and searching of dictionaries faster, because one an application’s dictionary has been cached, there
is no need to launch that application in order to obtain its dictionary. Most users should not need to
uncheck it.
Clear Cache
Clears Script Debugger’s internal cache of known application dictionaries.
Concerning why you might want to uncheck “Cache generated dictionaries”, or why you might want to
click Clear Cache, read here.
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Preferences: Key Bindings

Script Debugger permits you to customize (change) the keyboard shortcut for any menu item, including
Clippings and Scripts menu items. The Key Bindings preferences pane is where you do that.

Key Bindings:
The table lists all of Script Debugger’s menus and menu items, in hierarchical outline format. By clicking
the disclosure triangles (or by double-clicking a line), drill down to the menu item whose keyboard shortcut
you’d like to alter.
To change a keyboard shortcut:
Click the Set button, or double-click the menu item listing. The Keystroke dialog opens.
With the Keystroke dialog showing, type a keyboard shortcut. It must involve at least the Command
key or the Control key, or be a Function key (F1, F2, etc., plus Home, Page Up, and so on). It may
additionally involve any combination of modifier keys (Shift, Control, Option, Command). Script
Debugger warns you if you type a keyboard shortcut that is already in use by another menu item.
While the Keystroke dialog is showing:
To remove an existing keyboard shortcut:
Click Clear.
To undo your changed keyboard shortcut:
Click Revert.
To adopt your new keyboard shortcut:
Click OK.
To back out of the dialog without making any changes:
Click Cancel.
To remove an existing keyboard shortcut from a menu item, so that that item has no keyboard
shortcut, select it and click Clear. This is the same as opening the Keystroke dialog and clicking Clear and
then OK.
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The Software Update preference pane lets you specify whether Script Debugger should periodically go
online to check for a more recent version of itself, and if so, how often.
Check Automatically
If checked, Software Update will run periodically. Options in the pop-up menu for how often
Software Update should run are Daily, Weekly, and Monthly.
Automatically Download and Install Updates
If checked, then when Software Update detects an update, it will download and install it without
first presenting a dialog.
Check Now
Run Software Update right now. This allows you to check without waiting for, or even enabling,
automatic checking.
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Windows

Script Debugger’s window types may be categorized as follows:
Script windows
Dictionary windows
Explorer windows
Event log windows
The Preferences window
Further Details:
Toolbar

Preferences
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Toolbar

The toolbar at the top of a window contains controls relevant to the functionality of that window.
NOTE: Where two different toolbars are shown in the following illustrations for a kind of window, those
are in fact two different toolbars (corresponding to different states of the associated script), and are
customized separately.

The toolbar at the top of a script window contains controls for running and debugging the script, and
for switching between the sets of panes.

The toolbar at the top of a dictionary window contains controls for switching between views, for
reloading the selected entry, for activating or quitting the target application, and so on.

The toolbar at the top of an event log window contains controls for clearing the log, and for running
and debugging the script.

The toolbar at the top of an explorer window contains controls for reloading, and, if the explorer
window was spawned from a script window, for running and debugging the script:

The important thing to know about toolbars is that they can be hidden and that they can be customized.
To show or hide a toolbar:
Choose View > Show Toolbar or View > Hide Toolbar (it’s the same menu item).
Or, Control-click the title bar and choose Show Toolbar or Hide Toolbar.
In general, the functionality in a toolbar is available also from menus, so feel free to hide the toolbar if you

want to conserve screen space. However, some toolbar controls are not available elsewhere. For example,
the Search field in the dictionary window toolbar, and the timer in the script window and event log window
toolbar, have no alternatives elsewhere in the interface.
To customize a toolbar:
Choose View > Customize Toolbar.
Or, Control-click the title bar and choose Customize Toolbar.
This brings up the Customize Toolbar dialog, where you can determine what controls appear in the toolbar.
Even without the Customize Toolbar dialog, you can Command-drag an icon in a toolbar to change its
position or remove it from the toolbar. Your changes apply (immediately) to the toolbars of all windows of
the same type. Thus, customizing the toolbar of a script window customizes the toolbars of all script
windows, and customizing the toolbar of a dictionary window customizes the toolbars of all dictionary
windows.
You can also set the icon style and size of a toolbar:
Bring up the Customize Toolbar dialog; it contains icon style and size controls.
Or, Control-click in the title bar; the contextual menu gives you the same choices.
Making the icons smaller and choosing the Icon Only style saves a maximum amount of screen real estate
without sacrificing any toolbar functionality.
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Glossary

This section consists of a series of short pages explaining some words and concepts used in this help
document.
Further Details:
Glossary: AppleScriptObjC
Glossary:
Glossary:
Glossary:
Glossary:
Glossary:

Bundle
Bytecode
Code Sign
Compiled Script File
Dictionary

Glossary:
Glossary:
Glossary:
Glossary:
Glossary:

Fork
Library Script
Object Model
Scripting Addition
Sdef

Glossary: Tell Context
Glossary: Use Statement
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Glossary: AppleScriptObjC

AppleScriptObjC (short for “AppleScript / Objective-C”) is a linguistic bridge between AppleScript and any
Objective-C frameworks installed on your computer:
In /System/Library/Frameworks
In /Library/Frameworks
In your user ~/Library/Frameworks
In a script bundle, in Contents/Frameworks
When you say use framework with the name of an installed framework, AppleScript is able to call into
that framework and receive a reply, even though the frameworks expect to be spoken to using Objective-C,
not AppleScript.
IMPORTANT WARNING: Due to an AppleScript bug, Script Debugger cannot support use of
AppleScriptObjC under OS X 10.10 Yosemite. You can try using this configuration, but there is a strong
likelihood that Script Debugger will crash when you run or debug your script. For reliable use of
AppleScriptObjC in Script Debugger, upgrade to OS X 10.11 El Capitan or later.

Frameworks thus provide a way for developers to package Objective-C functionality, and constitute an
alternative to scripting additions. Moreover, there are many Apple frameworks already present on your
computer — most notably, the Cocoa frameworks (in /System/Library/Frameworks).
TIP: Code completion after framework " produces a list of Cocoa frameworks commonly targeted by
AppleScriptObjC.

This magic is made possible through two sorts of bridging:
AppleScript types are bridged to Objective-C types. For example, AppleScript text is bridged to
Objective-C NSString.
AppleScript function calls are munged to become Objective-C method calls (or C function calls). For
example:
set s to current application's NSString's stringWithString:"testing"
is the equivalent of this Objective-C code:
[NSString stringWithString:@"testing"];
Using AppleScriptObjC, you can easily do things that take advantage of Cocoa’s power but that would be
difficult or impossible in “pure” AppleScript. For example, Cocoa has support for regular expressions. In this
example, we use regular expressions to remove from a string everything that isn’t an alphabetical
character or a space:
use framework "Foundation"
set s to "This, truly, is a test!"

set ss to current application's NSString's stringWithString:s
set r to current application's NSMakeRange(0, ss's |length|)
set regex to current application's NSRegularExpressionSearch
set ss to ss's stringByReplacingOccurrencesOfString:¬
"[^\\p{Letter} ]" withString:"" options:regex range:r
set s to ss as text
-- "This truly is a test"
Script Debugger helps you write AppleScriptObjC code in a number of ways:
Objective-C values are displayed coherently in an explorer, such as the result pane. For example, the
final value of ss in the preceding script is shown as NSString "This truly is a test".
This sort of thing works for many Objective-C object types corresponding to AppleScript types that
have a Best view presentation in an explorer.
For other Objective-C object types, Source view provides the optimal presentation: effectively, it
shows the object description as it would be logged to Xcode’s console.
Code completion works.

Numerous clippings are provided, under the hierarchical ASObjC folder. For example, this string is
entered by the clipping ASObjC > Make Objects > make string:
set theString to current application's NSString's stringWithString:theString
where theString is a placeholder both times.
Script Debugger helps you refactor your AppleScriptObjC code to make it neater.
WARNING: As Apple has expressed it in the AppleScript release notes, “Using Objective-C frameworks
from AppleScript provides many new and exciting opportunities to crash the host process.” One very
good way to crash is to ignore issues of thread-safety. Some Cocoa methods must be called on the main
thread. An applet’s code runs on the main thread, but a Script Debugger (or Script Editor) script
document runs on a background thread, in which case maintaining thread safety (by calling
performSelectorOnMainThread where needed) is up to you.
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A bundle (or package) is a file system entity in OS X whose key characteristic is that although it is a
folder, it is portrayed in the Finder as a file. Bundles are useful because they can contain files and folders
inside them which the user doesn’t see or even know about. In fact, the user is generally unconscious of
the fact that a bundle is a bundle. Just to give a simple example, an OS X–native application is a bundle.
Opening a bundle in the Finder by double-clicking it is like opening an application or document — not like
opening a folder. If you want to open a bundle as a folder, Control-click the bundle in the Finder, and
choose Show Package Contents from the contextual menu.
Inside a compiled script bundle or application, when you Show Package Contents, is a Contents folder.
Inside that is a Resources folder. That is where you can keep additional files that need to travel with the
bundle. But you don’t have to do that from the Finder, because Script Debugger’s bundle inspector displays
the contents of the Resources folder, and lets you modify them.
A compiled script bundle or application can refer to a file inside its Resources folder using the path
to resource scripting addition command.
The Resources folder can contain a Script Libraries folder, and any script in that folder is then found
automatically as a library script.
If you put an sdef file inside the Resources folder, you can give your script or applet a dictionary and
make it scriptable by way of AppleScript terminology.
If you don’t know the purpose of a file or folder inside the Resources folder or elsewhere in the bundle,
don’t touch it! Doing so can destroy the viability of the bundle.
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AppleScript code is compiled into bytecode. This means that, roughly speaking, the nouns and verbs of
the original text are translated into a sort of compressed, coded equivalent, called tokens. These tokens are
meaningful to the AppleScript runtime engine (and illegible to everyone else). The runtime engine
interprets the bytecode in real time as the script runs, parsing whatever tokens it meets along its path of
execution, accumulating them into chunks, and translating these chunks further, as necessary, in order to
execute them.
The implication for you, the AppleScript programmer, is that in its compiled form, a script is illegible. So
why are you able to read a compiled script file? It’s because AppleScript decompiles the bytecode,
translating the tokens back into their English-like form. If the script targets an application, this
decompilation requires the application’s dictionary.
This is one reason why things can go wrong when you attempt to open a compiled script. (Script
Debugger may be able to help in such a situation by letting you open the script as text.)
It’s also why, in some cases, AppleScript must launch an application before it can show you a
formatted script.
And it’s why the lineation or exact wording of your AppleScript code is sometimes changed when you
compile it.
Actually, a compiled script file contains not only bytecode but also some further information (such as
variable names) needed to decompile the tokens. In a run-only script, this further information is not
present, which is why the script cannot be decompiled (and therefore cannot be read by a human being).
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OS X comes with Gatekeeper, a mechanism that can alert the user that a strange application is being
launched for the first time. A “strange” application is one that arrives from outside — for example, the user
received it via email or downloaded it with a browser — and that did not come from the Mac App Store.
To make it easier for the user to trust a strange application, the application can be code signed. This
constitutes a guarantee that:
The application was written by a developer registered with Apple.
The contents of the application have not been tampered with; they are identical to what the
developer intended.
An applet is an application. Therefore, it is subject to Gatekeeper’s oversight. If you have a membership
with the Apple Developer Program, you might wish to code sign your applet.
NOTE: The user can launch your applet even if it is not code signed, but the procedure is slightly more
involved and less intuitive than launching an applet that is code signed: the user must Control-click the
applet in the Finder and choose Open from the contextual menu. A dialog then appears, warning that the
applet is not from an identified developer, but permitting the user to proceed to launch the applet. The
user needs to do this only once; thereafter, the application can be launched directly in the normal way.

Before you can code sign an applet, your keychain must contain a Developer ID Application certificate. To
code sign the applet while editing it:
In the bundle inspector, choose your certificate from the pop-up menu.
Or, in the File > Code Signing menu, choose your certificate from the hierarchical menu.
Once you have specified that an applet is to be code signed, Script Debugger will keep it code signed, so
that its integrity remains guaranteed, every time you save it (unless you specify Don’t Code Sign).
WARNING: A code signed applet has its persistent global variables switched off (as if you had
unchecked Script > Persistent Properties). This is because the saved state of the script must not change;
it has to match the code signing checksum that guarantees its integrity. When you turn on code signing
for your applet, Script Debugger will present a dialog warning you about this. If your script depends
upon its properties maintaining state after quitting, it won’t work as a code signed applet.
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Glossary: Compiled Script File

The fundamental AppleScript file format is the compiled script file. It consists of bytecode, not the original
text. It also can maintain other information, such as the persistent values of top-level entities (mostly
properties, globals, and script objects) and certain context information. A compiled script file can be
executed directly, with very little delay, because there is no need to compile beforehand — the script is
already compiled. Many environments that can run scripts expect a compiled script file.
A compiled script can have difficulty opening if a required application or scripting addition is missing. If the
script was saved with Script Debugger, you may still be able to open the script as text.
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AppleScript’s real power and purpose lies in communicating with scriptable applications and scripting
additions. These provide powers that AppleScript itself lacks. In order that you, the AppleScript
programmer, may harness the powers of a scriptable application or scripting addition, a scriptable
application or scripting addition extends the vocabulary of the basic AppleScript language. This extended
vocabulary, belonging to a particular application or scripting addition, is called its terminology. A dictionary
is the means by which a scriptable application or scripting addition lets you (and AppleScript) know about
this terminology.
The dictionary translates between two forms of terminology — the English-like terms, which you use in
your script, and the raw Apple event codes, which AppleScript uses to construct Apple events when
communicating with a scriptable application.
When you write a script using English-like terms, the dictionary is used to translate them into raw Apple
events to be sent to scriptable applications.
In a compiled script file, the raw Apple events are encoded directly into the bytecode. In order to open the
compiled script file and decompile it, the dictionary is used to translate the raw Apple events back into
English-like terms. This is why AppleScript may have trouble opening a script in the absence of a required
dictionary.
At any given moment in a script there are several sets of terminology visible at once — variable names
used in the script, terms from the dictionary of the targeted application, terms from scripting additions,
terms from AppleScript’s own dictionary. If the script chooses its terms unwisely, or if the visible
dictionaries use the same terminology in different ways, terminology clash can occur. Terminology clash can
result in a script that won’t compile or run, or a script that behaves mysteriously.
Script Debugger helps you track down terminology clash by letting you deliberately view raw Apple event
codes in your script, in the event log, in outliners, and in dictionaries.

Also, you can search for terminology in all visible dictionaries at once; this can help track down terminology
clash as well.
Under certain circumstances, a compiled script may open but display some of its raw Apple events instead
of the English-like terminology, even when you have not elected to see the raw codes. This can happen
because a scripting addition couldn’t be found, or because of some problem with an application’s
dictionary; one way or another, the underlying dictionary information needed to convert bytecode back into
English terminology is missing.
If you use an application with an 'aete' dictionary that allows the dictionary to be extended through
plug-ins (such as QuarkXPress or InDesign), read the discussion of Script Debugger’s dictionary caching
mechanism.

Note: An applet, or a script bundle used as a library script, can have a dictionary (by putting an sdef into
the bundle).
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In the earliest days of the Macintosh file system, an architecture was devised whereby a file could have two
pieces, the data fork and the resource fork. The data fork was a single thing, and was just for data (like the
text of a TeachText / SimpleText file). The resource fork was for secondary information, and could contain
many resources, accessible by category and name or number, as in a kind of miniature database (so, for
example, style information in a TeachText / SimpleText file).
When OS X was introduced, Apple undertook a concerted effort to deprecate the resource fork, because it
wasn’t a standard Unix file system thing. As part of this effort, a new format for compiled script files was
devised, where the bytecode was kept in the data fork instead of the resource fork.
Ironically, Apple subsequently realized that resource forks were a good thing (because they provide a place
to put file metadata) and reversed course completely, modifying the file system so that a file can have
multiple extra forks! Forks are now called extended attributes. The ls command-line tool will list a file’s
extended attributes if you include the @ switch, and the xattr command-line tool will display the contents
of a file’s extended attributes.
Not every file system, and not every form of copying, understands extended attributes, so certain rare
actions, such as moving a script to a Windows machine and back again, can strip off the resource fork.
For a plain compiled script file, Script Debugger stores some secondary information in the file’s resource
fork. In a bundle format file, however, no resource forks are used; secondary information is saved in
separate files. (The description is saved in an .rtfd file, the recovery text is saved in an .rtf file, and the
other secondary information is saved in a .plist file.) For this reason, a bundle format file is the most
compatible with version control systems, non-Mac filesystems, and so on.
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Glossary: Library Script

A library script (or simply a library) is a compiled script located in one of these places:
The user’s home ~/Library/Script Libraries folder.
The top level /Library/Script Libraries folder.
In a compiled script bundle or an application bundle, inside the Resources folder (displayed in Script
Debugger’s bundle inspector), in a folder called Script Libraries.
The advantage of placing a script in one of these special locations is that it can be loaded by any other
script using its name alone.
NOTE: This AppleScript feature was introduced in OS X 10.9 (Mavericks). AppleScript actually looks for
library scripts in some additional locations, but you are unlikely to use them, and the list has varied in
each subsequent system.

For example, suppose ~/Library/Script Libraries contains a compiled script file Hello.scpt, like this:
property greeting : "Hello"
property greetee : "World"
on greet()
display dialog greeting & ", " & greetee & "!"
end greet
Then another script can say:
tell script "Hello"
set its greeting to "Howdy"
greet()
end tell
The phrase script "Hello" is a sufficient reference to Hello.scpt, because it is located in one of the Script
Libraries folders.
That, however, is not the canonical way of referring to a library script. Library scripts are most commonly
used in conjunction with AppleScript’s use statement, and Script Debugger expects and recommends that
you use them in that way (and so does Apple). Thus:
use Hello : script "Hello"
tell Hello
set its greeting to "Howdy"
greet()
end tell
TIP: Script Debugger’s code completion feature can help you enter a library script reference. If you type
script " and ask for code completion (press Esc), Script Debugger pops up a list of available library
scripts for you to choose from.

The library script feature essentially supersedes the old load script mechanism. But in a script that runs
on a system earlier than OS X 10.9, you could continue to use load script: you specify a script file by its
pathname, load it with load script, receive a script object, and send messages to that object.

Editing a Script and a Library Script Together
You will often want to edit a library script together with a main script that targets the library script, and
then run the main script to test it. Script Debugger is happy to let you do this, and even helps you by
making it easy to open the library script from within the main script: put the selection into a script
"MyScript" line and chose File > Open Script Library “MyScript”.
However, you are now in a tricky situation because of AppleScript’s internal caching mechanism. If you
make a change in the library script, save the changed library script, and then just run the main script, the
main script will be unaware that the library script has changed — it won’t reload it, because it has cached
it. The solution is to remember to recompile the main script before running it.
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A scriptable application’s world of objects constitutes its object model. Here’s how it works.
A scriptable application’s dictionary defines classes, roughly comparable to the types of “thing” that
constitute its world. For example, iTunes defines a playlist class and a track class; the Finder defines a
folder class and a file class. Classes can have properties and elements, whose value type can be a class.
Thus, in theory, for a given application, there is a hierarchical containment relationship amongst its classes.
For example, in iTunes, a playlist “has” tracks, and in the Finder, a folder “has” files.
In theory, this relationship can be expressed as a “tree”, a hierarchical structure starting with the
application itself, and containing every object in the application. Indeed, this tree is vital to your use of
AppleScript to communicate with a scriptable application, because it is why you are able to refer to an
object in the first place. For example, you can speak to the Finder of file 1 of folder "MyFolder" because
the Finder “has” folders and a folder “has” files.
This tree of the objects that you can refer to is the application’s object model.
Script Debugger exposes an application’s object model in three forms:
In a dictionary window, the object model diagram shows you the application’s containment hierarchy
as a tree.
In an explorer, an application’s actual objects are displayed hierarchically through an outliner.
In the Paste Tell hierarchical menu item, and in an explorer window’s title bar, the object model of a
running application appears as hierarchical submenus.
I say “in theory” because in reality things are not so simple. The containment hierarchy is describing
what’s possible, not what’s real, and therefore infinite recursions and circularities can result when you
try to express it as a simple tree. For example, in the Finder, in real life there could never be an infinite
depth of folder containment. In the containment hierarchy diagram, however, you can keep opening
“folder” entries to get “folder” entries inside them, and so on, forever and ever (or until you get bored),
just because as a theoretical matter, it’s always true that a folder can contain a folder. If this confuses
you, and you’d rather see the object model as it exists in reality, use the application explorer.
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A scripting addition is a compiled-code resource that implements additional AppleScript language
terminology and commands. AppleScript loads any scripting additions that it finds in the ScriptingAdditions
folder (in /System/Library, in /Library, or in your user Library), and the terms and commands implemented
in them become effectively part of the language.
Because of the nature of this mechanism, you don’t have to be in any application’s tell context in order to
use a term defined by a scripting addition. Instead, a scripting addition’s terms are simply “part of the
language”. For example, to learn today’s date, you just say current date, anywhere. You do not — indeed,
you cannot — explicitly target a particular scripting addition.
Nevertheless, everything in AppleScript works through dictionaries, so every scripting addition has a
dictionary. Script Debugger collects all the dictionaries of all loaded scripting additions into a single
dictionary display, called “Scripting Additions”.
Because scripting addition terminology is always available, no matter what application you are talking to
(or even if you are talking to no application), Script Debugger makes scripting addition terms automatically
part of the tell context. For this reason, scripting additions are a notorious source of terminology clash.
However, you can mitigate this issue by a judicious application of use statements. It turns out that if any
use statement appears, scripting additions become unavailable unless:
They are given a use statement of their own:
use scripting additions
Or, they are used within an explicit using terms from scripting additions block.
The latter strategy has the advantage that it avoids making all scripting addition terminology global to the
script.
Running a script in the absence of a scripting addition on which the script depends will probably result in a
mysterious runtime error. Opening such a script will result in the appearance of raw Apple event codes in
the script (Script Debugger tries to help track down the source of the problem, but it isn’t easy because the
name of the missing scripting addition doesn’t appear in the code, since scripting additions are not
explicitly targeted).
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An sdef (pronounced “ess-deaf”, and standing for “scripting definition”) is a dictionary format originally
introduced in Tiger (OS X 10.4). In certain ways, it allows a dictionary to be more expressive, accurate, and
informative than the old format, called an 'aete'.
Regardless of how an application provides its dictionary, Script Debugger translates the dictionary into sdef
format as the basis of its presentation of dictionary information and for caching purposes.
Script Debugger can also open an sdef file directly, and will present its dictionary window as if you had
opened a scriptable application. This is intended as an aid if you’re developing or editing an sdef.
If you use an application with an 'aete' dictionary that allows the dictionary to be extended through
plug-ins (such as QuarkXPress or InDesign), read the discussion of Script Debugger’s dictionary caching
mechanism.

NOTE: A library script saved in bundle format, or an applet (which is always in bundle format), can have an
sdef file in its bundle. This gives the bundle AppleScript terminology — the bundle now has a dictionary!
Explaining how to write an sdef for a bundle is beyond the scope of this documentation; watch WWDC
2013 video 416 to get started.
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The linguistic construction commonly used to perform communication with a scriptable application is the
tell block. For example:
tell application "TextEdit"
activate
set word 1 of document 1 to "Hello"
end tell
In that code, the indented lines are within a tell block targeting TextEdit. Thus, TextEdit is their tell
context.
Nested tell blocks can work their way down the object model hierarchy to narrow the tell context still
further. For example:
tell application "TextEdit"
activate
tell document 1
set word 1 to "Hello"
end
end
In that code, the set line’s tell context is document 1 of TextEdit.
Script Debugger watches as you work, and knows what the tell context of the current selection or insertion
point is. This knowledge is fundamental to certain Script Debugger features. For example:
The tell context inspector explores the elements and properties of the targeted application relative to
the current tell context.
The dictionaries inspector can search in the current tell context. So, if you select “word” in the above
code and choose Search > Look Up Definition, and if the dictionaries inspector search options are set
to Search in Tell Target, Script Debugger will search for the term word in TextEdit’s dictionary.
The File > Open XXX Dictionary menu item knows what dictionary to open based on the tell context.
The tell context itself may depend upon the value of a variable at a given moment. Script Debugger
handles this situation correctly, though the results may surprise you. For example:
on doTell(x)
tell application x
get window 1
end tell
end doTell
doTell("Finder")
Suppose this script is paused (in debug mode) at the line get window 1. What should the tell context be if
we click in that line? Well, there are two stack frames: the doTell handler call, and the top level of the

script (the implicit run handler). In the stack frame of the doTell handler call, x has a value and there is a
tell context (the Finder). But in the stack frame of the top level of the script, x has no value and there is no
tell context (and the tell context inspector will report “no selected tell block”). So the tell context depends
upon the selected stack frame as well as the current selection.
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Glossary: Use Statement

The AppleScript use statement, introduced in OS X 10.9 (Mavericks), has the following uses:

Making an Application’s Terms Global
A use application statement causes that application’s terms to become global. For example, instead of
this:
tell application "Finder"
get desktop
end tell
You can say this:
use application "Finder"
get desktop
But don’t say that! Making an application’s terms global is a really bad idea. There’s a good use for use
application described later on this page.

Linking to a Cocoa Framework
A use framework statement links to a Cocoa framework, thus incorporating Cocoa classes and their
Objective-C commands. Your script can now speak AppleScriptObjC. For example:
use framework "Foundation"
set s to current application's NSString's stringWithString:"the cat sat on the mat"
set arr to s's componentsSeparatedByString:" "

Loading a Library Script
A use script statement loads a library script:
use script "Hello"
However, the top-level entities in the loaded script do not become globally available; you still need a tell
block to access them. Thus, it is more common (and canonical) to provide an identifier, as discussed in the
next section.
But if the script has a dictionary, a use script statement does make its terminology globally available
(like an application).

Providing an Identifier
An identifier followed by a colon in a use statement specifying an application or a script turns the identifier
into a synonym for that application or script. You can then target the identifier with a tell block (or its
equivalent). For example:

use Hello : script "Hello"
tell Hello
set its greeting to "Howdy"
greet()
end tell

Requiring a Version
With a version parameter, use applescript, use application, and use script can force the script to fail if
the version is not at least as high as requested. For example:
use AppleScript version "2.5"
-- won't run on systems earlier than OS X 10.11 (El Capitan)
use application "Finder" version "10.10.5" without importing
-- won't run on systems earlier than OS X 10.10.5 (Yosemite)
-- note the "without importing"! prevents the terminology from becoming global
use Hello : script "Hello" version "1.1"
-- won't run without library script "Hello" version 1.1 or higher
TIP: To give a library script a version number, save it as a compiled script bundle and set its version
number in the bundle inspector.

Loading Scripting Additions
If any use statement appears, scripting additions become unavailable unless:
They are given a use statement of their own:
use scripting additions
Or, they are used within an explicit using terms from scripting additions block.
The latter is to be regarded as preferable, as it avoids making all scripting addition terminology global to
the script.
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Frequently Asked Questions

This section provides answers to some questions that were too technical or too miscellaneous to
incorporate into the main discussion.
Note: By its very nature, information in this section may be volatile. For the latest facts, check at Late
Night Software’s web site.
Further Details:
What’s Installed Where?
What are Persistent Properties?
Where Are the Libraries?
What’s The Big Deal With Line Endings?
Why Do Applications Open Spontaneously?
Hey, Script Debugger Changed My Formatting!
How Do I Script Script Debugger?
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What’s Installed Where?

Script Debugger is a good OS X citizen, and does not heedlessly install files in places where it’s not
supposed to. Still, it does install files in a variety of locations, and you might wish to know where these are
and what the files do. So here’s a list.
~/Library/Components
Script Debugger installs Script Debugger.component here. This file implements debugging, by
means of an OSA language. (In Apple’s Script Editor, you will see this OSA language listed as
AppleScript Debugger.)
~/Library/Caches/Script Debugger
Script Debugger maintains caches of application dictionaries here. These caches mean that Script
Debugger can open and access dictionaries much more quickly.
~/Library/Application Support/Script Debugger 6
Script Debugger keeps various special-purpose folders here:
The Clippings folder is where Script Debugger gets the items to populate the Clippings menu
and the clippings inspector.
The Scripts folder is where Script Debugger gets the items to populate the Scripts menu.
The Templates folder is where Script Debugger looks for user templates to be listed in the
template chooser.
Script Debugger automatically populates these folders to start with, and you are allowed to modify
their contents. If you need Script Debugger to perform its automatic initial population again, move
the ~/Library/Application Support/Script Debugger 6 folder aside (for example, drag it to the
desktop), then quit Script Debugger and start it up again. Now you can move your own materials
back into place if desired.
~/Library/Preferences
Script Debugger keeps one preference file here, com.latenightsw.ScriptDebugger6.plist. This
contains a lot of information, including state information for various windows, so be aware that if
you remove this file, such information will be lost.
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What are Persistent Properties?

When a script is saved with Script Debugger, the current values of top-level properties and globals can be
saved along with it, so that they are still there when the script is opened again later. This feature may be
toggled on or off by checking or unchecking Script > Persistent Properties.
When you open a compiled script with Script Debugger, and if Script > Persistent Properties was checked at
the time script was saved, the values of top-level entities persist from the last time the script was
executed. They are not reinitialized to their base values until the next time the script is compiled. (Merely
running a script, without changing it, does not compile it.)
So, for example, a script’s top-level property greeting might be defined as "howdy", but it might not
actually be "howdy" when you start running the script (unless you compile the script first), because
greeting’s value might have been changed to something else (typically by the script itself as it ran last
time), and the changed value will persist. Script Debugger shows you what the value really is, in the
variables pane.
Note, however, that Apple’s Script Editor strips these values when it opens a script (because it recompiles
the script). Thus, if you so much as open this script with Script Editor, the persistent value is stripped out,
so now when the script is run, greeting is reinitialized to "howdy".
Note: If AppleScript refuses to save your compiled script, generating a “Stack Overflow” error, the cause
might be an AppleScript bug connected with persistent top-level values. Force the script to recompile to
delete the persistent top-level values, and try saving again.

There are certain contexts where persistent properties are a bad idea. That’s why Script Debugger gives
you the ability to toggle this feature off for an individual script. Examples of places where you should
generally not use persistent properties are:
Code signed scripts. To help you with this, Script Debugger will turn off persistent properties as soon
as you code sign a script.
Scripts that use AppleScriptObjC. To help you with this, Script Debugger’s AppleScriptObjC templates
have persistent properties turned off by default.
Scripts that use GUI scripting.
Scripts that involve confidential information, such as passwords.
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Where Are the Libraries?

Script Debugger 5 and earlier provided native libraries as a way of incorporating other scripts into this
script. This feature, however, is now superseded by AppleScript’s own library scripts. Therefore, the native
libraries are not supported in Script Debugger 6.
A Script Debugger 5 script using native libraries, when opened in Script Debugger 6, will appear without
those libraries. The native libraries are preserved, however, and will still be present if the script is opened
again under Script Debugger 5.
You are expected to update your code to use AppleScript library scripts. There are two ways to
proceed:
You can update a script manually. To help with this task, you can use Script Debugger’s
scriptability to get a list of a script’s native libraries (legacy script libraries, legacy script library
files) and relevant features of a script (script properties, script handlers).
You can use Script Debugger’s built-in library converter. When you open a script containing native
libraries, Script Debugger 6 will detect this and will offer to convert them to library scripts for you.
These scripts will be placed in your user ~/Library/Script Libraries folder. If this would result in
duplicates, you’ll be given the choice of overwriting or skipping any duplicate items.
After conversion, the native libraries are stripped from the script. Be sure to examine the newly
created library scripts and make sure you’re happy with them. If you’re not, don’t save the script
or it will lose its native libraries. If you’re in doubt, it might be wise to start with a copy of the
original script and perform the conversion there.

Technical Information About the Built-In Converter
The converter works by looking for all referenced Script Debugger 5 native libraries. If there are broken
aliases, the conversion process will stop and direct you to open the script with Script Debugger 5 and
correct the problem there.
As it creates each library script, the converter adds a corresponding use statement to your script. In
addition, it adds property declarations for any top-level entities (such as properties) in the library script;
thus, those top-level entities become global to this script. The result will therefore match the behavior of
native libraries — except that duplicate entity names are ignored, whereas in Script Debugger 5, you would
have been warned about this issue at compile time.
The converter is not recursive, so if you have any libraries that reference other libraries, you will need to
open and convert them before you convert the main script that uses them.
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What’s The Big Deal With Line Endings?

AppleScript makes line endings a complicated issue. Script Debugger does a lot to make them simple, or at
least transparent. But sooner or later you may run into problems with line endings, so here’s an
explanation.
Imagine that two mighty forces are at work, tussling with line endings:
The AppleScript compiler. AppleScript is a compiled language, and this compilation involves a
transformation performed directly on your code. Your code starts life as ordinary text, but when it is
compiled, your file becomes a compiled script file, and you are shown the decompiled bytecode. The
AppleScript compiler goes back to the early 1990s, a time when Macintosh line endings were all CR
(ASCII 13). So, after compilation, every complete line of code in your compiled script file ends with a
CR.
Unix. OS X is Unix, and the standard Unix line-end character is LF (ASCII 10). For example, a script
written in a Unix scripting language such as Perl or Ruby needs to have LF line endings or it may not
run properly. Many OS X text applications conform to this standard as well. For example, when you
create a new multi-line file in TextEdit and save it as plain text, the line endings are LF. This issue is
particularly acute in AppleScript when you use do shell script, because a multi-line string intended
for the Unix shell will usually expect LF as a line-end character.
So, the AppleScript compiler wants your line endings to be CR, but OS X wants your line endings to be LF.
The conflict between these forces is always going on. Sometimes this conflict works behind the scenes —
for example, the AppleScript compiler will change your line endings to CR, no matter what they were
before, and that’s that. But the conflict also arises up front, every time you press the Return key while
you’re typing in a script file. At that moment, some character needs to be entered, so what should it be?
Script Debugger helps you deal with this conflict, in two main ways:
Visibility. Script Debugger makes it possible for you to see your line endings — you can show
invisibles.
Freedom of Choice. Script Debugger lets you choose what character the Return key enters; it’s an
Editor preference (New Line Character). The factory default for this preference is LF, and if you
create a new multi-line script with the preference set this way, and invisibles showing, you can
actually watch AppleScript change the line endings from LF to CR when you compile.
Script Debugger also lets you choose what line endings should be used when you save a script as text.
This, however, introduces a further complicating factor.
The problem stems from the fact that in AppleScript, a literal string can span multiple lines:
set s to "
"
The integrity of the line-end character within this string (which might be LF or CR) is preserved through
decompilation, because behind the scenes the compiled script is just bytecode (and the byte in question is

part of a literal string). But now suppose you elect to save this script as text. What should Script Debugger
do? The character after the first " is a line ending. If you tell Script Debugger to save with CR line endings
or LF line endings, this character will become CR or LF, respectively, regardless of what it is “really”
supposed to be (thus possibly altering the functionality of your script).
This is why Script Debugger provides the As Is option (the default), which leaves all line endings in the
resulting text file the same as in your compiled script. The totally safe solution, though, is not to use any
literal line endings within quoted strings. Don’t use the “escaped” literals "\r" or "\n", because the
AppleScript decompiler turns these into actual line endings. Instead, construct your strings in code,
generating line endings at runtime (using, for example, the return or linefeed global variable). Of course,
if you never save as text, then the issue doesn’t arise in the first place.
Finally, be aware that pasting (or dragging) from a text file into a script can raise line-end character issues.
What is pasted is text, which can have any kind of line ending. Script Debugger does not magically convert
these as the paste is performed. If there are multi-line string literals in what is pasted, or if the target
script is text, incorrect line endings may now be present in the script. Again, show invisibles will be a great
help here.
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Why Do Applications Open Spontaneously?

Why do applications open spontaneously? The trouble is that certain applications must be running in order
to provide a dictionary. So every time AppleScript needs the dictionary of such an application — not just in
order for a script editor to display a dictionary, but in order to compile or decompile a script that targets
that application — the application must start up if it isn’t running. So this is a problem with the system, and
with how AppleScript works. It has nothing to do with Script Debugger. In fact, Script Debugger does two
things to reduce this behavior.
NOTE: To compile a script, you must let AppleScript launch any needed applications. Compilation is
something that AppleScript does, not something that Script Debugger does; so Script Debugger can’t
prevent this behavior.

Opening and Decompiling a Script
When you open a script that targets an application which must be launched in order for AppleScript to
decompile it, Script Debugger detects this and optionally (if the corresponding General preference is
checked) presents a dialog:

You can proceed to open the script (and allow the application to launch) if you wish, but perhaps the
overhead of launching an application just to read a script seems unwarranted. If this script was saved with
Script Debugger, it contains a text version, and you can click Open As Text to open that instead. Thus you
can read the script without launching the targeted application.
If the script does not contain a text version, the Open As Text button won’t appear; your only choices will
be to open the script and let AppleScript launch BBEdit, or to cancel and not open the script at all.

Opening a Dictionary
Script Debugger makes heavy use of an application’s dictionary. For example, in order to calculate the tell
context, Script Debugger must load the target application’s dictionary. This could cause the target
application to launch if it is not running. And Script Debugger needs the tell context when you start to open
the File menu (because of the Open XXX’s Dictionary menu item), so there may be a delay as you choose
from the File menu, while the target application launches. And then, of course, there’s the whole business
of what happens when you search the dictionaries of multiple applications simultaneously.
The good news, however, is that this should happen only once for each application. Script Debugger caches

an application’s dictionary (in ~/Library/Caches/Script Debugger) when it opens the dictionary, provided
you have not unchecked “Cache generated dictionaries” in the Dictionary preferences. So, as long as the
application’s dictionary and location don’t change, Script Debugger won’t have to launch that application
again in order to access its dictionary.
Note that this has nothing to do with the discussion under “Opening and Decompiling a Script” earlier on
this page. Even when Script Debugger has cached (say) BBEdit’s dictionary, AppleScript has not, so
when you open a script that targets BBEdit, AppleScript will still try to launch BBEdit if it isn’t running.

However, you can uncheck “Cache generated dictionaries”, or clear the cache on demand by clicking the
Clear Cache button, and there are certain specialized circumstances where you might wish to do this. In
particular, some applications with 'aete' dictionaries allow those dictionaries to be extended through plugins (notable examples are QuarkXPress and InDesign). Script Debugger has no way to notice when you add
or remove a plug-in, so the dictionary that it displays, coming from the cached copy, will be out of date.
Applications that do not use this plug-in architecture do not present any difficulties, and are irrelevant
here. If you install a new version of an application, Script Debugger will notice that the dictionary has
changed and will automatically refresh the cached copy.

So, if you use these applications, it is up to you to remember to remove the cached copy of the dictionary
each time you alter the application by adding or removing plug-ins. There are three ways, or levels, for
doing this:
Uncheck “Cache generated dictionaries”. This prevents caching altogether. Applications will open
whenever their dictionaries are needed.
Keep “Cache generated dictionaries” checked, but click the Clear Cache button when needed. You
allow caching to work normally, but every once in a while you throw away the caches. So most of the
time you are getting all the benefits of caching. But you are throwing away the caches for all the
dictionaries, when only one dictionary (Quark or InDesign) is the problem.
Throw away the cache for just the problematic application, manually. This is the best solution. Here’s
how:
1. Quit Script Debugger.
2. Open ~/Library/Caches/Script Debugger.
3. Find the cache for your problem application’s dictionary.
The start of the cache file’s name will be either the application’s name (e.g. “Microsoft Word
7c5d2075.sdef”) or its bundle identifier (e.g. “com.apple.mail b521204d.sdef”).
4. Move it to the Trash.
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Hey, Script Debugger Changed My Formatting!

Sometimes it happens that the appearance of your script is changed in ways you never intended. For
example, you carefully use the line continuation character to break up a long line of code, like this:
set r to display dialog "What is your favorite color?" ¬
default answer "Blue. No, red!" ¬
buttons "Aaaaaaaagh!" ¬
default button "Aaaaaaaagh!" ¬
with title "A Crucial Test"
But suddenly it appears broken up all incorrectly, like this:
set r to display dialog ¬
"What is your favorite color?" default answer ¬
"Blue. No, red!" buttons ¬
"Aaaaaaaagh!" default button ¬
"Aaaaaaaagh!" with title "A Crucial Test"
Why is Script Debugger doing this to you? We’re sorry this is happening, but Script Debugger has nothing
to do with it. It’s a “feature” of AppleScript. It has to do with the fact that a script is compiled into bytecode
and then displayed to you in decompiled form. There are some annoying behaviors deep within that roundtrip process, and this is one of them. There’s nothing Script Debugger can do to prevent it.
A related behavior is that although AppleScript will let you use a term’s synonym, it will also sometimes
replace the synonym in the decompiled script. So, for example, close document 2 saving false is legal,
but it is changed to close document 2 without saving (and you are probably familiar with the expansion
of app to application, ref to a reference to, and so forth).
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How Do I Script Script Debugger?

Script Debugger 6 is scriptable. Moreover, you can script Script Debugger from within Script Debugger
itself, either from a script window or from a script in the Scripts menu. Such a script need not include a tell
block targeting Script Debugger; Script Debugger will implicitly be the tell target.
However, for development and debugging purposes it is better to supply an explicit tell block (tell
application "Script Debugger"), because if you don’t, the returned values in the result could be less
helpful.
Script Debugger will appear among the applications listed under File > Open Dictionary, in the dictionaries
inspector, and in the dictionary window, so you can easily open its dictionary.
The dictionary is fairly self-explanatory, so a detailed discussion of scripting Script Debugger should be
unnecessary. But here are a few points that deserve attention.

Opening Things
Some kinds of Script Debugger window can be opened. Here are some examples:
To create a new empty script window, say make new document.
To open a script from disk, say open alias "vol:folder:file.scpt". The result is a reference to the
document.
To open an application’s dictionary, open the application itself. The simplest approach is to take
advantage of path to application; so, for example, open (path to application "BBedit").
Alternatively, say make new dictionary window. This creates an empty dictionary window, not
displaying any application’s dictionary.
Once you have a dictionary window, you can change what application’s dictionary it displays by
setting its file spec property. For example, set file spec of dictionary window 1 to (path to
application "BBEdit").
To open a script window’s event log window, tell the document to make new event log window.
The event log window and the document have pointers to one another.
To open a script window’s result explorer window, tell the document to open last result.
All open windows are elements of the application object. You can get a complete list by asking for every
window, or you can get a list of windows in a particular category by asking for e.g. every dictionary
window or every script window.
Every script window is associated with exactly one document (it has a document property). The two
classes are not interchangeable, but a script window and its document have the same id. This is fairly
standard Cocoa Scripting stuff.
Documents are numbered front to back, so the numbering is volatile. In other words, document 1 is the

document of whatever script window is frontmost at that moment.

Closing Things
To close a window, use the close command.
However, when your script running within Script Debugger wants to close a script window (or document),
you must provide the full form and you must not use the saving ask option, or Script Debugger will throw
an error. So, for example, you can say close document 2 without saving, and you can say close
document 2 saving yes if the file has been previously saved, but you cannot say simply close document
2, nor can you say close document 2 saving ask.
By the same token, if document 2 has never been saved, you cannot say simply save document 2. You
must supply the full form, with an in parameter specifying where to save.
The reason is that when Script Debugger is scripting itself, we cannot pause the script while the user
interacts with the “Do you want to save changes?” dialog or the Save File dialog. So you must avert such
interaction by stating explicitly what you want done with the document.

Manipulating Things
As you would expect, most interaction with objects occurs by way of their properties. Look, for example, at
the properties of a document or a dictionary window or an event log window to see all the manipulations
you can perform. For example, to switch a script to debug mode, set the document’s debugger enabled
to true.
There are two ways to manipulate the contents of a script. First, you can get or set a script’s entire
contents as text, through the document’s script source property; you can also get and set a script’s entire
contents as a script object, through the document’s script property.
You can also manipulate a script’s selection. If you get selection you are handed mere text, but if you ask
for selection as point or character range of selection, what you get is a list of two integers, the
character offset after the insertion point or the start of the selection (the first character offset is 1) and the
count of characters in the selection. Similarly, you can set selection to alter the selected text, but if what
you set the selection to is a list of two integers, or if you set character range of selection to such a list,
you reposition the selection.
So, for example, here’s a crude but effective utility for selecting a given line of a given script:
on selectLine(num, docnum)
tell application "Script Debugger"
tell document docnum
set L to every paragraph of (get script source)
set offs to 1
repeat with i from 1 to (num - 1)
set aLine to item i of L
set offs to offs + (length of aLine) + 1
end repeat
set selection to {offs, length of item num of L}
end tell
end tell
end selectLine
selectLine(3, 2) -- or whatever

Running Scripts
Script Debugger provides a repertory of specialized commands for making a script (a document) do such
things as compile, execute, step into, and so on. Execution causes compilation, obviously. After calling
any command that causes compilation, you can check whether compilation succeeded by examining the
document’s compiled property.
Some of these commands come with a caveat: execute, pause, step into, step out, and step over all
share the feature that they can return before the script has stopped or paused (and start recording can
return before the script has started recording). This is a consequence of Script Debugger’s multi-threaded
architecture.
The correct approach, therefore, if you wish to proceed after the script has done what you asked it to do, is
to poll the document’s execution state property. So, for example, here’s a script that provides a utility for
waiting until the document is paused or stopped, and shows how to use it in connection with execute.
on waitUntilReady(d)
repeat while execution state of d is not in {stopped, paused}
delay 0.2
end repeat
end waitUntilReady
-- and here's how to use it
tell application "Script Debugger"
set d to document "convertFigures"
tell d
execute
my waitUntilReady(d)
if not compiled then return last error message -- compilation failed, get error
if last error message is not missing value then -- execution failed, get error
return last error message
end if
return last result -- execution succeeded, get result
end tell
end tell

Future Directions
We’d like to provide fuller scriptability, but this takes work, so we would prefer to go in directions that our
users will actually use. If Script Debugger’s scriptability lacks a feature you need, do let us know.
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