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QUICK START GUIDE FOR SEEMIS CLICK + GO 
 

Welcome to the Parents Evening System. This document guides you how to set up the system for your 

first parents’ evening. This does not cover setting up events such as ticket booking for school plays or 

after-school club bookings. Please feel free to contact support if you have any questions by emailing 

support@parentseveningsystem.co.uk or calling 0333 344 3403. 

OVERVIEW 

Parents log into the system by entering their name and their child's details, select a parents’ evening and then 

book appointments with their child’s teachers. Therefore the system needs to know all the students and their 

contacts, the teachers and the class lists. This guide takes you through the following steps: creating the two 

export files from SEEMiS Click + Go, importing both files, adding a parents’ evening, altering the system settings, 

and finally branding the system to your school. 

Step 1: EXPORTING STUDENTS & PARENTS 
When a parent accesses the system, by default they are authenticated based on their title & surname plus their 

child's name and date of birth. This step shows you how to create the export from SEEMiS, ready to be imported 

into the system.  

1.1) Go to Application -> Reports -> Custom Reports. Select the fields as shown in the below screenshot. 

Note: the first SEEMIS reference field is under the Student section on the left and the order doesn't matter. 

 
 

1.2) Click the Conditions tab at the top of the report and add in a condition to include current pupils only by 

dragging the field from the left hand side into the conditions section on the right.  
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1.3) Add in other conditions to decide which parents are exported from SEEMiS and hence able to login and book 

an appointment. We recommend both parents/guardians are included so either the mother or father can 

book an appointment. 

 

Recommended Conditions 

We recommend including any parent, so to exclude other contacts (such as doctors) use a condition on the 

contact relationship similar to the below. Be sure to set the AND/OR drop down menus as shown. 

 
 

Alternative Conditions 

You could include the main contact only, however ensure parents are made aware only the main contact will 

be able to login. 

  
 

1.4) Save the report by clicking on the Save icon and call it something like Parents Evening Students/Contacts  

so you can quickly run the report again without having to create it from scratch. 

 

1.5) Click the View tab on the left hand side. You should now see the data on screen. 

 

1.6) Copy the output and paste into a new Excel spreadsheet. 

If you're not familiar how to do this, then right click on any cell and choose the Copy All option. Open a new 

Excel spreadsheet and right click in cell A1 and choose Paste.  

 

1.7) Save the spreadsheet as a CSV file by going to File -> Save As and in the Save as type drop down choose 

CSV (Comma delimited). Save this in a folder where you can easily find it later and call it something like 

Parents Evening Students and Contacts. 
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Step 2: EXPORTING TEACHERS & CLASSES 
After parents login and pick the parents' evenings, a list of their child's teachers will appear automatically. This 

step shows you how to create the export from SEEMiS which lists the teachers for each student.  

2.1)  Go to Application -> Reports -> Custom Reports (Curriculum). Add the fields to the bottom sections as 

shown in the below screenshot. 

 
 

2.2) Save the report by clicking on the Save button at the bottom left and call it something like Parents Evening 

Classes so you can quickly run the report again without having to create it from scratch. 

 

2.3) Run the report by choosing a Stage at the top which the parents' evening is for and pressing Next at the 

bottom. Copy the output into a new Excel spreadsheet. The process is the same as Step 1– right click and 

choose Copy All, then Paste into cell A1 in Excel.  

 

 
 

You now have an Excel spreadsheet which lists the teachers for each student in the year/stage chosen. 

If your parents' evening is for one year/stage only (for example an S4 parents' evening) then skip the next 

step and move on to Step 2.5. 
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2.4) Follow this step if your parents' evening is for multiple years/stages, such as a whole school primary parents' 

evening or if you have an S5/S6 parents' evening. Otherwise skip to Step 2.5. 

 

So far the teachers & classes for one year/stage have been exported from SEEMiS. Now repeat Step 2.3 with 

a small change - choose a different Stage and append to the Excel spreadsheet. To append to the Excel 

spreadsheet, paste into the row immediately after the last row with data. 

Note: duplicate header rows are ok, however you can remove the duplicate header row if you prefer. 

 

Repeat for all stages to create one large Excel spreadsheet with contains the classes for all year/stages. 

 
 

2.5) Make any adjustments to the class lists if you wish parents to see teachers other than those listed on the 

timetable for students. There's no need to remove a whole subject as when setting up a parents' evening on 

the system you can exclude whole subjects. 

 

It's worth noting SEEMiS only exports one teacher per class, even if the class is shared between two or more 

details. We recommend checking any shared class to check which teacher has been assigned.  

Tip: the Sort & Filter options in Excel make it quick to find and locate classes. 

 

To change the teacher assigned to a student, update the Title, Teacher's first name and Teacher's 

Surname columns. If updating a whole class, repeat for every student in the class.  

Note: the format and spelling of these fields must be the same as the rest of the spreadsheet. SEEMiS tends 

to output the Teacher's first name as their initial and a full stop. 

 

2.6) Save the spreadsheet as a CSV file by going to File -> Save As and in the Save as type drop down choose 

CSV (Comma delimited). Save this in a folder where you can easily find it later and call it something like 

Parents Evening Classes. 
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Step 3: IMPORTING THE STUDENTS & PARENTS FILE 
Now we'll import the files you've created from SEEMiS. It's important we import the Students & Parents first 

before importing Teachers & Classes because class lists can only be added once the students are on the system.  

3.1) Login to the Parents Evening System as an administrator. 

 

If the Getting Started page appears, choose SEEMiS Click+Go from the drop down menu, then the link to 

go to the SEEMiS import page: 
 

 
 

If you see the admin panel, click Student/Parent Import under the Parents & Students section: 

 
 

3.2) Upload the Students & Parents CSV file you saved to your computer in Step 1 by browsing for the file and 

pressing the Upload button. 

 

3.3) If successful you'll see a screen like below: 

 
 

Step 4: IMPORTING THE TEACHERS & CLASSES FILE 
 

4.1) From the admin home page, click Teacher/Class Import under the Parents & Students section: 

 
 

4.2) Upload the Teachers & Classes CSV file you saved to your computer in Step 2 by browsing for the file and 

pressing the Upload button. 

 

4.3) If successful you'll see a screen like below: 
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Step 5: ADD A PARENTS’ EVENING 
Appointments are added for a parents’ evening which is an event run on a specified date. There are a number of 

options available when adding a parents’ evening, which are explained in the on-screen instructions.  

5.1) Click on Manage Evenings & Events from the administrator home page, followed by Add Evening. 

   

 
 

5.2) Fill out the fields of information requested on the Add Evening page. The Title and Information fields are 

displayed to parents on-screen and in print outs. If the parents' evening runs over multiple dates, use the 

Add Another Date button at the top to add a second date/ 

 

If you’d like to enforce parents to leave a gap between their appointments, select the appropriate 

Appointment Gap. Eg if appointments are 5 mins long, an Appointment Gap of 1 will ensure parents wait 

at least 5 mins between appointments. 

 

The Booking Start Date/Time controls when parents are able to see and book appointments for the 

parents’ evening. The Booking Cut-off Date/Time controls when parents are no longer able to make any 

changes to their appointments for the parents’ evening, though administrators can still make changes. 

 

The Parents can only book pre-selected teachers checkbox decides if parents can book only the 

teachers listed in the Teachers & Classes file and we recommend this is checked. If un-checked then parents 

see an Add a new teacher button to book an appointment with any teacher in the school. 

 

The Filter Students section is used to show/hide the parents’ evening to the relevant students. If you aren't 

running the parents' evening for the whole school, choose Year Group or Registration Group  and then 

select the relevant group(s) this parents' evening is for.  

 

Finally the Filter Classes/Teachers section is used to decide which subjects are bookable on this parents' 

evening. Untick any subject which you don't want parents to make bookings for.  

 

Once finished, click Add Evening to save the parents' evening. 

 

The system is now ready for parents to login and start booking appointments. However there 

are a few settings worth visiting first before releasing the system to parents.   



    Page 7 of 11 

 

Step 6: ADVANCED PARENTS' EVENING SETTINGS 
Now that a parents' evening has been added to the system you can set up certain teachers to start earlier or finish 

later than others, add breaks for teachers, have different appointment lengths for certain subjects and create a 

guide to help parents book appointments. 

The admin home page is grouped into sections. To change anything related to a parents' evening, click on the 

relevant icon under the Parents Evenings & Events section.  

 

 

Description of Features 
Shared Classes will show any classes that have multiple teachers imported from SEEMiS. At the time of writing 

SEEMiS only exports one teacher per shared class so it's normal to see no shared classes in this page unless you 

manually edited the file as per Step 2.5. 

 

Start & End Times enables you to easily have a teacher start earlier or finish later than the standard parents' 

evening times set up in the step before. If your parents' evening is over multiple dates then remember to click the 

correct date on the left hand side of the page first. 

 

Teacher Breaks is used to block out times during a parents' evening for a specific teacher or all teachers. For 

example a global 10 minute coffee break, or a staggered break for teachers. If a teacher cannot attend the 

parents' evening (such as they're ill on the day), mark them as on a break for the whole time of the parents' 

evening. If the teacher already has appointments then the system offers you the ability to email parents with a 

message on why the appointment was cancelled. 

 

Appointment Length can be used to have longer appointments for certain teachers or subjects than the 

standard appointment duration specified when creating the parents' evening. For example 5 minutes with class 

teachers and 10 minutes with the Support for Learning teacher.  

 

Use the Template Letters page to download a template parent guide as a Word document. This guide should be 

tailored by you to include the school's unique web address for the Parents Evening System which parents will use 

to access and book appointments. Most schools include this one page guide with the letter home and/or put a 

PDF copy on the school website.  

 

The Text Messages page is not compatible with SEEMiS. 
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Step 7: SYSTEM SETTINGS 
The System Settings section features a range of configuration settings for the general operation of your system. 

There are settings to adjust how parents’ details are authenticated, school contact details at the school that 

parents see when they login, required fields of information for parental logins and controls over which features 

teachers can access on their own accounts. 

7.1) Click on System Settings from the administrator home page. 

 
 

7.2) Enter contact information for the school that parents see when they login on the School Settings section. 

 
 

7.3) The Login Settings section allows you to change the terminology, e.g. Parents' Night Booking System. 

 
 

7.4) Select what features you’d like teachers to have access to on the teacher section of the system using the 

Teacher Permissions section. 

 
 

7.5) Choose how parents are checked against the SEEMiS record in the Parent Authentication section. 

The defaults are recommended which checks the Parent Title & Surname, plus the Student Name & Date of 

Birth against the file imported from SEEMiS. 

 

We do not recommend changing this to Parent First name as often parents will login with an initial or a 

different spelling of their first name. Likewise we do not recommend changing Student Date of Birth to 

Registration Class as the format entered by the parent must match exactly as it appears in SEEMiS and we 

find Date of Birth to be the easiest way for parents to login. 

 

7.6) Click the Update System Settings button to save the changes. 
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Step 8: BRANDING 
The theme of the system can be changed to suit your school’s colours. The school name at the top of each page 

can be altered and the school’s logo can also be displayed at the top of each page.  

8.1)  Click on Theme & Branding from the administrator home page. 

 
 

8.2)  Select a new colour theme by clicking on the colour. Select an image of your logo to upload and click on 

Update Theme Settings. 
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Step 9: FINISHED 
Congratulations, you have set up the Parents Evening System. We suggest that you try adding some 

appointments, print appointment sheets and view the reports on the evening.  

9.1) As an administrator you can add appointments on behalf of parents – click on Add a Booking from the 

admin home page and follow the on screen guide.  

 

9.2) You can also try logging in as a parent – ideal if there is a teacher at the school who is also a parent. Firstly log 

out as an administrator by clicking Log Out at the top right. You’re asked to type out your details (as a 

parent) and your child’s details. Remember the system authenticates against the parent and child details so 

be sure to enter correct information. 

 

Tip: You can always find all student information in the Students page of the administration panel and see 

which parents are linked to each student by clicking the Edit icon (the pencil) and a list of linked parents will 

appear.  

 

9.3) You can also test logging in as a teacher by clicking on Teacher Login from the parent login page. However 

first you'll need to create a login for a teacher. Login as an administrator, click on the Teachers tab and 

then click the edit icon for a teacher. Fill out a username and password and click the Edit Teacher button at 

the bottom of the page. 

 

 

 

Please see the appendix for details on how to keep the system up to date with changes to 

student, parents, teachers or classes from SEEMiS.  

 

Please feel free to contact support if you have any questions by emailing 

support@parentseveningsystem.co.uk or calling 0333 344 3403. 
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APPENDIX 1:  UPDATING THE SYSTEM WITH CHANGES FROM SEEMIS 
When data is changed in SEEMiS and you want this updated data to appear in the Parents Evening System, you 

should re-import the relevant files. This appendix describes which files should be re-imported depending on the 

data changed in SEEMiS and the process for re-importing. 

 

What Data Each File Contains 
The Students & Parents file contains a list of every student in the school and the contacts for each student. If 

anything changes about the students or parents, then you should re-import this file into the system. 

The Teachers & Classes file contains a list of teachers who teach each student. If the class list changes in any 

way, such as a new student joins the class or a change of teacher, then you should re-import this file into the 

system. 

Example Scenarios 
 

Scenario Re-import Students & Parents Re-import Teachers & Classes 

New student joins Yes Yes 

New academic year Yes Yes 

Change of parent details Yes  

Student changes class  Yes 

Change of teacher for a class  Yes 

Parents' evening for new year/stage  Yes 

 

Re-Importing the Students & Parents File 
Create a new Students & Parents file from SEEMiS as per Step 1 of the guide. During Step 1 you saved the report 

definition in SEEMiS so instead of re-creating the report in the Design tab, open the saved report by clicking on 

the Folder icon. Follow the rest of Step 1 and then follow Step 3 to re-import.  

 

Re-Importing the Teachers & Classes File 
Create a new Teachers & Classes file from SEEMiS as per Step 2. Again open the report which you saved in SEEMiS 

rather than re-creating the report from scratch. Follow the rest of Step 2 and then Step 4 to re-import 

Remember you can only export a single year/stage from SEEMiS at a time. If you need to update the classes for 

multiple year groups, either create one large Excel spreadsheet with all the year/stages as per Step 2.4, or create 

separate CSV files for each year/stage and import them separately. The Parents Evening System can accept both 

one large file containing multiple year/stages or multiple files containing one year/stage each. 

 

 


