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Porta 2.0

Overview

Porta is a cloud-native control system for broadcast that unifies the workflow for data-driven graphics in

Unreal Engine that is easy to access, control, and play. Porta can sit across all your broadcast tiered

productions and seamlessly integrates with newsroom systems. It features a simple interface that is

Unreal Engine native and easy to operate.

Any type of playlist mode can be used, enabling multiple rundowns, and a preview mode so you can

seamlessly manage your production from anywhere. Using Porta, you can manage multiple engines

from one point of control. Porta offers the ability to configure projects for specific company needs.

Multiple operators can control graphics from anywhere using any browser while also being adaptable for

use locally. Porta both empowers cloud-based collaboration and on-the-premises studio teams.

Porta is available as a Software as a service (Saas) subscription.
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User Roles

Key Industry Roles

There are three key user roles in the broadcast industry. These are Designers. Operators and IT Admin or

Engineers. In some instances, Operators also do design work and are thus referred to as Technical

Operators, however, we will focus on the three main areas. Workflows and user journeys in Porta have

been configured around each type of user's specific tasks.

Designer

An artist who creates the UE project and builds templates to control UE assets.

Operator

An Operator triggers the controls using templates and playlists built by the Designer.

IT Engineer

An IT Engineer focuses on configuring systems, networks, and company setups.

An Engineer would add the settings and solve any technical issues.
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User Interface

The Porta 2.0 Interface

Porta login page

Main toolbar
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Menu tabs

Project page

Project toolbar: New project + workspace

Manager: Templates view
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Manager: Playlists view

Manager: Project view
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Settings: Keyboard shortcuts

Settings: Channels
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Settings: Integrations

Settings: My Account
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Settings: Preference

Settings: Users
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Keyboard Shortcuts

Default Keyboard Shortcuts

Play page Ctrl + Enter

Play Out Page /

Save Page Ctrl + S

Save Page As Ctrl + Shift + S

Save As Number Ctrl + S

Move To Number Ctrl + V

Read Next Page Ctrl + R

Play current and read next Ctrl + N

Read Previous Page Alt + R

New Template Ctrl + Shift + K

New Page Ctrl + Shift + N

Duplicate Page Ctrl + D

Rename Page Ctrl + Shift + R

Create Group Ctrl + Shift + L

Delete Page Ctrl + Shift + D

Undo Ctrl + Z

Redo Ctrl + Shift + Z

Table: Keyboard Shortcuts in Porta 2.0 (October 2022)

Broadcast operators often need to react quickly in a live production environment, so they like to use

keyboard shortcuts to introduce and switch content. Using a mouse and keyboard combination to

trigger content is much slower than using keyboard shortcuts. With this workflow in mind, many

keyboard shortcuts have been added to Porta. These are continually being updated, and can also be
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customized by users. In a future update, it will be possible to export customized keyboard shortcuts and

import them to a different instance of Porta.

Customize keyboard shortcuts

1. To customize a keyboard shortcut, selec the Key column.

2. Press the new key or key combination you want to add.

3. Confirm the key/ key combination shown by pressing Enter.
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Customising Layouts

Workspaces

The Porta interface can be easily customized by opening, rearranging, and docking widget panels in the

browser so you can organize your screen how you need it. Panels can also be tabbed so that you can

jump between tabs and keep the layout organised. These layouts can be saved as workspaces.

The above example image shows the following docked panels:

Workspace Layout:

1. Top menu

2. Main toolbar

3. Page preview

4. Page

5. Playlist

6. Media manager
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By clicking the Maximise button at the corner of all panels, you can expand the panel which sets it to

Fullscreen. If a panel is fullscreen, you can click on the Minimise button to minimize the panel size.

Add | Maximise | Close

Add | Minimise | Close
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Working with Unreal Engine

Technical requirements

Porta projects are currently built in Unreal Engine 5.0.3.

Review the recommended software and hardware specifications for running Unreal Engine 5 here.

Sample projects

There are two sample projects available that have been specifically configured to use with Porta:

l Demo_Light project

l 3D Text project

Introduction

This guide will help you get started using Porta, it will not teach you how to use Unreal Engine. For Unreal

Engine 5 documentation and learning resources check out their website.

Porta supports the use of vanilla Unreal Engine and controls the Unreal project from a browser. So we will

cover how Unreal project controls can be set up for Porta.

Projects are created by designers ahead of time. Projects include different environments, themes, and

assets over different levels, as well as cameras, visual effects, and animations. Blueprints (Unreal

Engine’s visual scripting language) are used to bring it all together.

These 3D assets are also referred to as graphics in broadcast terms because they are viewed as

graphics onscreen.

Designers expose the parameters of an asset in Unreal Engine and configure them so that they can be

controlled from Porta running in a browser. Porta can remotely change these parameters, switching

items on and off, changing levels (or environments), adjusting lighting, changing an item’s positioning,

switching camera views, or triggering animations. Augmented Reality (AR) assets can be also added to

levels such as sports players, F1cars, and weather elements.

https://docs.unrealengine.com/5.0/en-US/hardware-and-software-specifications-for-unreal-engine/
https://docs.unrealengine.com/5.0/en-US/
https://www.unrealengine.com/en-US/learn
https://www.unrealengine.com/en-US
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Unreal Engine needs to be running in standalone play mode while using Porta. To connect Porta to

Unreal Engine a binding must be added that syncs content between the two.

To begin, the 3D text item (Text3DActor) is relatively simple to add and the most common element Porta

has in Unreal Engine. We will demonstrate an overview of the designer’s workflow by adding a 3D text

asset to our level and exposing a parameter that can be used by Porta.

Unreal Engine Workflow

Ensure that you have Unreal Engine 5.0.3 installed.

To learn this basic workflow, the project does not need to have any sample content. However, the team

has provided a sample project that demonstrates how 3D Text is configured for Porta* which you can

use.

If you are planning to use the project for production purposes, you may wish to build an environment

with content on at least one level.

Enable the following plugins:

l Substance plugin

l 3D Text Plugin

l Remote Control API

l Porta Manager plugin*

* To download the latest Porta plugin select Help > Plugins from the menu and select PortaPlugins_2_0_

1.zip.

https://www.unrealengine.com/marketplace/en-US/product/substance-plugin
https://docs.unrealengine.com/5.0/en-US/3d-text-actor-in-unreal-engine/
https://docs.unrealengine.com/5.0/en-US/remote-control-for-unreal-engine/
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If you have a sample Porta project some of these plugins may already be enabled.

If you are not using a sample project, create a new empty project.

Create a new project

In Epic Games Launcher, launch the Unreal Engine 5.0.3.

1. Create a project by selecing the Games category.

2. Select a Blank template.

3. In Project Defaults, select Blueprint project with the default settings.
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4. Name the project "Porta".

5. Click Create

6. The Epic Games Launcher creates a new project and opens the Unreal Editor.
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Enable the 3D Text plugin

1. Select Edit > Plugins.

2. Type 3D in the search bar.

3. Click on the checkbox to enable it.

4. Click on the Restart Now button.

https://docs.unrealengine.com/5.0/en-US/3d-text-actor-in-unreal-engine/#enablingthe3dtextplugin
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5. Click Save Selected to save all changes.

6. Unreal Editor will automatically reopen. Close the Plugins window.
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Add a 3D text asset to an Unreal project

1. In the Unreal project click + to quickly add an item.

2. Select All Classes.

3. Press CTRL + Spacebar to enable search and type “3D”.

4. Click on Text3D to add it to the level.
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5. In the Text parameter, type "Porta".

6. In the File menu, click Save All.

Expose an asset parameter in Unreal Engine

Ensure that you have enabled the Remote Control API plugin in your project.

Follow the steps above to enable a plugin

If you are using a sample project, this will already be enabled.

https://docs.unrealengine.com/5.0/en-US/remote-control-for-unreal-engine/
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1. Open the Content Drawer and from the Content Browser, click + Add.

2. Select: Miscellaneous > Remote Control Preset.

3. Double-click on the new Remote Control Preset in the Content Browser to open it.

4. Select the Text3D asset in the Outliner.

5. In the Details panel, click on the 3 vertical dots at the edge of the Text parameter to expand the

toolbar.
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6. Click Expose property.
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Using the Demo_Light project

The team has put together the Demo_Light sample project which you can use to connect with Porta. The

project contains all of the configurations and plugins that you need to get started with Porta.

If you are using Unreal Engine by itself, the default location for the project folder is:

C:\ Users\ UserName\ Documents\ Unreal Projects

If you are using Unreal Engine wth Designer, the default location is:

C:\ Users\ UserName\ Documents\ RenderStream Projects

The Demo_Light sample project is configured to run in Standalone game mode.

Click the play button to play in Standalone mode.
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When Standalone mode plays the project the window is black. This is by design.

The next step is to connect the project to Porta.
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Porta Workflow

Binding an Unreal project to Porta allows it to be remotely controlled from the browser. A Porta Config

file enables any machine running an Unreal project to connect to an instance of Porta.

Connect an Unreal Engine project to Porta

Confirm that the Unreal Engine project that you will be using with Porta is in your default Unreal Engine

project folder.

If you are using Unreal Engine by itself, the default location for the project folder is:

C:\ Users\ UserName\ Documents\ Unreal Projects

If you are using Unreal Engine with Designer the default location is:

C:\ Users\ UserName\ Documents\ RenderStream Projects

Next, ensure there is a PortaConfig.ini file in the Config folder inside your project.

[Socket.IO]

SocketURL="[Porta URL]"

PortaChannel="[ComputerName]"

[Media]

AssetCacheFolder="C:\PortaCache"

Edit the PortaConfig.ini file adding the following information:

l [Porta URL]

This is the URL that you will use to access Porta, such as https:/ / [websitename].porta.solutions

l [ComputerName]
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This is the name of your computer and will form the Channel ID in Porta.You can rename your

computer before adding it to the .ini file to give it a uniquely recognizable name. For example:

PortaChannel="WendyA3ro"

l AssetCacheFolder

Create an asset cache folder. For example using, the C:\PortaCache

If your project is on a different drive ensure the AssetCacheFolder in the PortaConfig.ini

points at it.

The next step is to log in to Porta in your browser.

Log in to Porta

1. Open the Porta login page in your browser.

2. Enter your user credentials.

3. Click the Login button.

Over the next few sections, this guide will cover the key features of Porta 2.0.
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Create a project in Porta

All activity in Porta is project-based. The starting point for designers is to create a project.

There are two ways to create a new project:

1. Click on the New Project button in the menu ribbon.

2. Or click on File > New > New Project.

Next, add a name for the new project and click Save.

Note: creating a project will automatically create a playlist.
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Templates

Introduction to Templates

A template allows designers and operators to control the properties in Unreal Engine from Porta. You can

make a template with or without Unreal using the Template Builder. If you make a template without

unreal it is essentially a form. In this way, if an Unreal Engine graphic isn’t ready, the template can still be

made and you can connect that binding between Porta and Unreal Engine at a later time.

Designers will test and revise templates until they are happy with them while setting up a project.

The templates need to be simple and easy to use by the operator. An operator rapidly navigates through

different playlists and pages using keyboard shortcuts to trigger changes in a fast-paced work

environment such as a broadcast studio, control room or newsroom.

Templates can be arranged in a grid, or in columns.

Template Builder

Template Builder is a powerful tool for quickly creating templates. It enables designers to bring together

key assets, sequences and settings in the Unreal Project that they can be triggered from Porta.

Templates create playlists, playlists organise pages, and pages include sequences and graphics that

can be played simply and remotely.
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Open Template Builder

There are three different ways to open Template Builder:

1. Open template builder from the main toolbar.

Create a template from the quick access menu.

2. To open template builder from the main menu

From the main menu, select File > New > Template.

3. To open template builder from any panel

On the top right corner of any panel, select the + icon.

Create an Unreal template using Template Builder

Ensure that the Unreal Engine Project has been made and is open.
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1. Select Unreal Template from Template Builder.

2. Select a row from the list to choose your engine to bind it to Porta and click Next.

3. Select a preset from the list and click Next.

With the current version of Porta, you can only connect to one Preset Template at a time to make

an asset.
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4. Select the components that you need using the checkboxes.

A component is a property that has been exposed in Unreal Engine.

5. A form will load with all the exposed properties and functions in the UE project. This form is

automatically generated to help users get started. Here you can see the Talent Name text field

and the Talent Position text field. There are also two function calls that fade the content in and
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out.

6. Maximise the Template Builder form by clicking the Maximize button positioned between the

Add and Close buttons.

7. Click the |<- button to toggle the left sidebar panel. This panel lists all the available exposed

presets in the Unreal project.

The example in the screenshot above is a Lower Third graphic component. As you can see there is a

Talent Name text field and a Talent Position text field. There are also two function calls that fade the

content in and out.
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Form Components

Components Description

Media File A Media File component allows users to select media from a media

manager or upload it from a local drive.

Text Field A Text Field can be used for short and general text input. There are

options to define input masks and validations, allowing users to hold

information into desired formats.

Text Area A Text Area has the same options as the Text Field form component.

The difference is that it will be a multi-line input field that allows for

longer text.

Color The color component produces a primary color fill.

Number Number fields can be used whenever a field should be limited to a type

of number value. There are options to set Thousands Separator, set

Decimal Places and Require Decimals.

Date/Time Date/Time form components can be used to input dates, times or both

dates and times.

Checkbox A check box can be used for boolean value input field. It can either be

on or off. There are options to set Shortcut and Input Type.

Day The Day component can be used to enter values for the Day, Month,

and Year using a number or select type of field.

Time The Time component can be used to input time using different time wid-

gets you would like to use.

Select Boxes The Select Boxes allows the user to check multiple values from list of

options.

Select The Select displays a list of values in a dropdown list to users. Users

can select one of the values.

Currency The Currency component should be used when a field should display

currency amounts on a form. This component holds a numeric input

mask that allows two decimal values and automatically adds commas

as a user inputs a currency amount.

Radio The Radio allows the user to check only one value from list of options.

File A File component allows users to select media from a media manager

or upload it from a local drive.
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Button Buttons can be added to perform various actions within the form.

Play Sequences A Play Sequences component links to a media sequence and con-

figures a trigger that will play it.

Send to Channel A Send to Channel component…

Load Level A Load Level component allows users to configure Unreal Engine levels

so that they can be loaded on request.

Supported file formats

The file formats currently supported are:

• Image: png, .jpg, .bmp, .webp, .gif

• Video: mp4, .mov, .ts,.avi, .y4m, .mkv

• Audio: .mp3, .wav

• 3D: .glb, .obj, .glTF, .fbx

Metadata tags can also be added.

Template Builder buttons

In template builder, the five buttons are:

l Edit

l Move

l Edit JSON

l Copy

l Remove
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Add a form component

Templates are built using form components and exposed properties.

For example:

1. To create a Text Field, drag the Text Field component from the list of components to the

template.

2. To create a dropdown selection box, drag the Select component from the list of form

components to the template.

Remove a form component

To delete a form component from the template, hover over it. At the end of the input text field, sitting

above it are 5 buttons, select the X to delete the component. When the preset has been disconnected it

is highlighted orange-red.

Add a custom form component

Here is a list of other components that can be added to the template:

https:/ / help.form.io/ userguide/ forms/ form-components.

https://help.form.io/userguide/forms/form-components
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Edit a template component

In this example, we have added a dropdown to the template using the Select component. The

component is not connected to a preset and so it is highlighted orange/ red.

1. Click on the settings edit button at the end of the component details box.

2. In Edit mode, select the Unreal project preset property from the list and click Save.

The Talent Name preset is now connected to the Select component.

Each preset component can be configured using multiple attributes:
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l Display - such as visible/ invisible, positioning

l Data – such as text values
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l Validation

l Conditional
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l Logic

l Layout



Playlists

44

Playlists

Create a new playlist

When a project is created, a playlist will be automatically generated.

If you want to make additional playlists, you can use one of these three ways:

1. Click on the New Playlist button on the menu ribbon.

2. Click File > New > Playlist.

3. Click + to add and select Playlist.

Next, nter the name of the new playlist, select a type from the dropdown menu and click Save.

Playlist type options are:

l Manual - this is the default setting

l Number - this allows operators to type a number to activate a preset.



Playlists

45

l MOS - this integrates with newsroom control systems

Import playlists

Select File > Import Playlist.

Export playlists

Select File > Export Playlist.
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Pages

This workflow allows for templates to be amended, so if a designer wants to make a change to the page,

an amended template, when saved, will automatically update the page.

Create a new page from a playlist

Select a playlist and click the New Page button.
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Duplicate a page

To duplicate a page, select the page you want to duplicate and click the Duplicate button.
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Numeric pages

By default, pages use page names. As an operator, it can be much quicker to work with numbered pages

as it is much quicker to type a number on a keyboard num pad to call up a page.

Enable numeric pages

1. To enable numbered pages click on Window > Manager.

2. Click on Playlists.

3. Click on Rename in the main toolbar.
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4. Under Type, click on Manual and select Numeric from the dropdown list.

5. Return to the playlist. You should find that the page names have been replaced with numbers.

Play a graphic

Play the Unreal project in Standalone mode and click on the play icon in the Actions column.
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Group page items

1. Highlight the items that you want to group.

2. Click the folder+ icon.

3. Enter a name for the new group and click Save.
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Channels

Channels reference the machine that runs the Unreal Engine project.

By assigning channels, users determine where content is played. Different channels can be selected for

certain things based on a company’s requirements.

Assign a channel to a project

Select the output channel in the Channels column of the template. A dropdown lists all the available

channels.

Set a default channel for all projects

1. From the Window menu in Porta, click on Settings.

2. In the Settings panel, select Channels.

3. Here you can set your most frequently used channel as default by editing the Default column.

The default channel will automatically be assigned to new playlists.

If a new channel has been added but does not appear in the list, click on the Refresh button.



Channels

52



Page Preview

53

Page Preview

Designers can choose to expose properties, but they can also load levels. The Unreal level can load into

Page Preview. If you have multiple levels in your Unreal project, the Load Level field will automatically list

all levels in a dropdown field.

In this instance, the lower third will appear as an overlay on top of the level preview.

Loading levels

Select the level from the Load Level dropdown list.
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Camera Switching

l Camera switching relies on exposing parameters on cameras in the Unreal Project.

l A designer would then connect the project presets and add the cameras to a template in

Template Builder as a selection dropdown. It can be previewed here.

l The template is used to make a playlist.

l The camera options must be added to a page and any switching can be done from the page.
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Manager

The Manager shows you everything in Porta. It shows you all the templates, playlists, and pages that you

have in your projects. You can manage them and open them from here, and when you open a template

from the Manager, the Manager moves to a separate tab. The Manager is very useful when you have

hundreds of templates that you need to keep organised.
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Settings

With a few exceptions, settings in Porta are the domain of the engineer. Keyboard settings can be

customised by designers and operators, but many items in the settings menu are managed by someone

in the IT or engineering department. This includes configuring user accounts, adding channels, setting

up any integrations, and connecting to data feeds. Admins also have the functionality to log in as a user

and see Porta as that specific user would.

IT engineers or admins create new users and set user roles and permissions. Among admins, there

might be a user admin who just creates users, while a system admin has greater control privileges and

can determine precisely what the user can do, including which channels the user has access to, and

configuring which API keys are assigned to users. In larger companies, this would include many different

channels for different studios.

IT managers can set controls such as what happens in a preview and how is it previewing the graphics

by type. Most customers use Web RTC for preview and then configure the URL when working locally

within their network, or on their own pc. This uses your local host or your local IP. The demo preview

project uses a public URL created specifically to control things from the cloud.
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Working with Designer

Technical requirements

Designer installed on your machine

Connect a Designer project to Porta

To set up a Channel and a playlist you will need to connect Designer on your machine to Porta.

1. Open the sample project in Designer using d3manager.

2. Open the IO Server application and add the URL of the Socket Server and click Connect.

If a green square appears it has made a connection.

3. Add a Channel Name such as "Porta".
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4. Type your IP address into the D3 IP Address text field and click Add Channel.

5. Log in to Porta in the browser and confirm that your channel has been set up correctly.
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Designer is currently limited in Porta to:

l Timeline controls

l Indirections

l Animation sequences

As new APIs are released, more functionality will become available.
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Troubleshooting

Help Menu

For support and documentation see the Help menu.

Support Contact Form

If you have any issues with Porta that you are unable to resolve contact support.

https://www.disguise.one/en/about/contact/
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