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Proprietary and Restricted Rights Notice 
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About Us 
3D Systems is a leading global provider of 3D content-to-print solutions including 3D printers, print materials and 
on-demand custom parts services for professionals and consumers alike. The company also provides CAD 
modeling, reverse engineering and inspection software tools and consumer 3D printers, apps and services. Its 
expertly integrated solutions replace and complement traditional methods and reduce the time and cost of 
designing and manufacturing new products. 3D Systems’ products and services are used to rapidly design, 
communicate, prototype or produce real functional parts, empowering customers to create and make with 
confidence. 
 
More information on the company is available at www.3DSystems.com 
 
 

Contact Information 
3D Systems - Geomagic Solutions 
1001 Winstead Dr, Suite 400 
Cary, NC 27560, USA 
Phone: +1 (800) 691-1839 or +1 (919) 474-0122 
Fax: +1 (919) 474-0216 
 

Web Sites: 
Geomagic Solutions  http://www.3DSystems.com 

Technical Support  http://support.geomagic.com 
 
Email Addresses: 

Technical Support  geomagic.support.americas@3dsystems.com 
Training  geomagic.training.americas@3dsystems.com 
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Introduction 
Overview 

This guide covers the fundamental commands and workflows utilizing the Geomagic Design X software. 

 The graphical user interface and navigation 

 Data types, processing and usage 

 Standard Geomagic Design X workflows 

 Various modeling workflows 

 

Intended Audience 

This guide is targeted to users of Geomagic Solutions products who require an overall understanding of the 
Geomagic Design X software.  
 

Prerequisites 

None 
 

Guide Length 

3-days 
 

Guide Conventions 

Bold Text 

Indicates  mouse button clicks to locate a command in the user interface in the format of 
Tab > Group > Command, example: 

Model> Create Solid > Extrude 

Model(Tab) > Create Solid (Group) > Extrude (Command) 

Bold text also may be used to draw attention to or create emphasis for key concepts in 
activity steps. 

● A dotted bullet indicates an actionable item in the training activities. 

 
This symbol is used to identify additional information within the context of an activity step. 
Text following this symbol is not actionable within an activity step. 

 A circled bullet is an information item found outside of an activity. 

 This symbol is used to strongly advise or convey important information when used. 
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Graphical User Interface 
Introduction to the Graphical User Interface (GUI).  

ACTIVITY: Getting Started 

Objective 

Locate the primary components of the application user interface. 
 

Training File 

01 – Mouse Control.xrl 
 

 

1. From the Windows Start button, select Start > All Programs > 3D Systems > 

Geomagic Design X to start the application. 

 or 

 
2. From the Desktop, double-click the Geomagic Design X icon to start the application. 

The application will start as shown in Figure 1. 

 Clicking a Tab will change the current ribbon to display different command Tab Groups. 

 The Tree displays the commands used and objects that are opened, imported or created. 

 

Figure 1 – Graphical User Interface 
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File Open 

 
 

1. Click the Open button or select Open from the menu tab. 

 Use the Open Files dialog to navigate to the training files folder. Choose 01 – 

Mouse Control.xrl from the Open Files dialog. 

 Files in Geomagic Design X format have an .XRL extension. 

 Click Open. The file is loaded and displayed in the Model View, see Figure 2. 

 The Open command is for opening native Geomagic Design X files.  Other file types need to be Imported. 

 

Figure 2 

End of Activity 
 
 
 

Ribbon 

All commands used to create models are stored in the tabs at the top of the interface.  Each tab has a different 
category of commands that are classified into groups.  The Model Tab is the default tab, but all tabs can be 
selected with the left-mouse button. 
 

 
Figure 3 
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Tabs 

The layout of the new ribbon user interface is shown in Figure 3.  Each Tab is broken down into Groups, and the 
Commands are located within each Group. 

 
The three tabs where the majority of training tools will be found are the Model, Sketch, and Polygons tab. 

Model – Create and edit solid and surface bodies.  The standard CAD creating tools will be located here. 

 
 

Sketch – Create and edit a 2D or 2D Mesh Sketch using Line, Arc, and other sketching tools. 

 
 

Polygons – Access tools to improve and edit the polygons/mesh. 

         
 

 

Groups 

Each Group within a tab will hold a set of commands that work similarly or have similar objectives. 
 

Commands 

Each Command will have its own properties and dialogs.  Commands that are similar will have a drop down menu 
to toggle between the options and save space on the toolbar.   
All commands not found directly on the Ribbon will be located in the MENU tab.  Commands are categorized and 
stored here.  Selecting a command from the MENU tab is the same as selecting directly from the Ribbon. 

                                        
   Figure 4                                                            Figure 5 
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Upper-Side Toolbar 

This toolbar contains data display modes, view options, and selection tools. 

 
Figure 6 

 

Mesh Display 

 
Point Set - Display the mesh as only the poly-vertices. 

 
Wireframe - Display the mesh as only the poly-edges. 

 
Shaded - Display the mesh as shaded poly-faces. 

 
Shaded with Edges - Display the mesh as shaded poly-faces with poly-edges visible. 

 
Curvature Display Mode - Turn on or off the visibility of the curvature map of the mesh. 

 
Region Display Mode - Turn on or off the visibility of the Regions. 

 

Geometry Type Display Mode - Change the region display to classify all region types as individual 
colors. 

 

Body Display 

 
Wireframe - Display the bodies as only the edges. 

 
Hidden Line – Display the body as edges with the edges in the background displayed as dashed lines. 

 
Shaded - Display the bodies as faces with no drawn edges. 

 
Shaded with Edges - Display the bodies as faces with edges visible. 

Accuracy Analyzer 

 
Deviation for Body – Compare the solid or surface body with the used scan data. 

 
Deviation for Mesh – Compare the mesh to its previous state. 

 
Curvature – Analyze solid or surface for areas of high curvature. 

 
Continuity – Display quality of edge continuity. 
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Iso Line – Display the iso lines that define the surface. 

 
Environment Mapping – Display zebra stripes on the surface to show continuity. 

 

Views 

 
Viewpoint - fly out will display the standard views of the Model View.  All standard views are listed: 
Front, Back, Left, Right, Top, Bottom, and Isometric. 

 
Rotate View Counter-Clockwise – Rotate the Model View 90° to the left. 

 
Rotate View Clockwise – Rotate the Model View 90° to the right. 

 
Flip Viewpoint – Change viewing direction 180°. 

 
Normal To (Ctrl+Shift+A) – Orient the view perpendicular to a clicked surface. 

 

Selection Tools 

Toggle between the different selection shape options. 

 
Line - Select entities on a user drawn line on the screen. 

 
Rectangle - Select entities within a user drawn rectangle on the screen. 

 
Circle - Select entities within a user drawn circle on the screen. 

 
Polyline - Select entities within a user drawn polyline on the screen. 

 Freehand - Select entities within a freehand drawn curve on the screen. 

 
Paint Brush - Select entities on a freehand drawn path on the screen. 

 
Flood Selection - Select all polygons connected to a selected polygon. 

 
Extend to Similar - Select an area of mesh with polygons connected by similar curvature. 

 
Visible Only - Select only visible objects in the current view. Deselect to select through the object. 
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Navigation & Selection 
This section uses a polygon object as an example; all commands in this section work the same for point and CAD 
objects except where noted. 
 

Mouse Commands 

ACTIVITY: Using the Mouse 

Objective 

Learn the mouse operations in the Model View. 
 
In the upper right corner of the screen, an 
arrow can be open or closed to display all 
the functions available with the mouse.  This 
display is dynamic and will only show what is 
available at the moment. Figure 7 displays 
the Default mouse options. 

 
Figure 7 

 
 

Rotate, Pan, and Zoom 

 1. Rotate the view by first placing the cursor in the Model View; press and hold the 

right-mouse button (RMB). 

 Moving the mouse in all directions performs a spherical (3D) rotation pivoting 

around the center of the screen. 

 Moving the mouse vertically performs a planar rotation, parallel to the current view. 

 

 
 

2. Pan the part. Press and hold down the right-mouse button (RMB) and then the 

left-mouse button (LMB). 

 Position the current view by using the Pan command  

 Move the mouse right or left to pan from one side to the other. Move the mouse 

away or towards to pan from top to bottom. 

 Release to stop the pan operation. 
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3. Change the magnification of the object in the Model View by using the Zoom 

command. 

 Place your cursor in the Model View at a location of interest and use the scroll-

wheel to zoom in by rolling the scroll-wheel up. To zoom out, roll the scroll-

wheel down. 

 The Zoom defaults to zooming to the center of the screen. This can be changed in Preferences. 

Using Selection Tools 

 

 
 
 
 

 

1. Select poly-faces of the mesh. 

 Click the Rectangle Selection Mode 

icon. 

 Place the cursor on the object, click 

and hold the left-mouse button 

(LMB). 

 Drag your cursor to define the 

second corner of selection zone. As 

you move the cursor, a rectangle is 

visible in the area to be selected.  

 Release the LMB. The poly-faces in 

the selection zone are highlighted. 

 
Figure 8 

 
2. Deselect portions of the previously 

selected poly-faces. 

 Hold down the CTRL key while 

selecting with the LMB in the same 

area highlighted area. 

 Release the mouse button before 

releasing CTRL. 

 Clicking the LMB in empty space in the Model View 
deselect everything. 

 
Figure 9 

 
3. Add more poly-faces to the previous 

selections. 

 Hold down the SHIFT key while 

selecting other areas of the mesh. 

 
Figure 10 

 The brown surface seen is the back face of the 
mesh.  Blue is the default color of the normal side. 

 
 

 
 

4. Delete selected areas by pressing the 

DEL key  

5. Press CTRL+Z or the undo button on 

the keyboard to undo the last 

command. 

 

 
 
 

6. Select and delete additional areas using the Line, Circle, Polygon, Freehand, and 

Paint Brush Selection Modes. 

 Select the tools from the Upper-Side Toolbar and make selections on the object in 

the Model View. 
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 Press the DEL key to delete selected areas. 

 The Line Selection Tool is active only on polygon objects. 

Remember to hold Shift or Ctrl to add and removed portions of selected data. 

 

 
Figure 11 - Example of selected areas 

 

 7. Press CTRL+Z to recover (undo) the most recently deleted areas of the object. 

 There is one level of undo in the application.  

 
8. Deselect the Visible Only icon on the Upper-Side Toolbar and select an area on the 

object using the Rectangle Selection Tool. 

 Rotate the object around to view the other side of your selection. Notice that turning 

off Visible Only causes the current selection tool to affect all areas within the 

selection boundary, not just those visible on screen, see Figure 12 and Figure 13. 

 Click in empty space to clear all selections. 

 

 
Figure 12 - Initial Selection 

 
Figure 13 - Result of Selection 

 
9. From the Upper-Side Toolbar, select the Polyline Selection Tool to create a 

polygonal selection.  

 Click a set of points as shown in Figure 14. As you click, a boundary line will appear 

from click to click. 

 To define the last point in your Polyline Selection, move your cursor to the last 

location and press the right-mouse button (RMB) or double click the LMB to end 

the process and make your selection. 
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 Rotate the object slightly to review the selected data. 

 Double click in space to clear the selection. 

 
Figure 14 

 
 
 

10. Choose the Extend to Similar Selection Tool to select adjacent triangles that meet 

have a similar curvature. 

 Click on the area as shown in Figure 15. 

 Adjacent triangles in the polygon mesh that have a small degree difference between them will be selected as 
shown in Figure 16. 

 

 
Figure 15 

 
Figure 16 

 11. Press Esc to remove the selection. 

 Certain tools will not clear selections when clicking the mouse in space. 

 The majority of commands in the application operate using the following selection syntax: 

 If nothing is selected when a command is activated; the command will affect the entire 

active object or all active objects. 

 If a selection is present when a command is activated; the command will affect the selected 

area only. 
 

 
End of Activity 
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Docks 
Docks contain the properties for many different application needs.  Important Design X options are contained 
within these docks.  Docks can be positioned anywhere on the screen.  They can also be pinned, hidden, and 
closed completely. 

Tree Dock Group 

ACTIVITY: Tree Management 

Objective 

Explore the different available docks. 

 If a dock is closed, make it visible again with a RMB click on the bottom toolbar and select the dock from the 
list that appears. 

Training File 

02 – User Interface.xrl 

Tree 

The Tree dock on the left side is essential to the modeling process.  The top half is the Feature Tree, and the 
bottom half is the Model Tree.  The Feature Tree can be compared to a history tree since it lists the steps taken to 
create a model.  The Model Tree lists entities that are still present in the model.  The visibility of these objects is 
controlled here as well. 

 

 

1. Click the Open icon on the Quick Access Toolbar. 

 Use the Open Files dialog to navigate to the folder where the training files reside. 

Choose 02 – User Interface.xrl from the Open Files dialog and press Open. 

 This XRL file is a partially modeled scan file. 

 
Figure 17 
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2. The Feature Tree tracks the 

parametric history modeling progress.  

Each step to create an entity is tracked 

in chronological order, and can be 

edited. 

 Find Extrude 1 in the Feature 

Tree. Click on the + sign next to it 

to view the associated entities. 

 RMB click on Extrude 1 to pull up 

the context menu. 

 A right-click context menu is available on entities 
in the tree.  The commands available from the 
context menu change depending on the type of 
object selected. 

 Select Edit from the menu, as seen 

in Figure 19.  

 Press the ESC key to cancel the edit. 

 
Figure 18 –           

Feature and Model Tree 

 
 

Figure 19 

3. Geomagic Design X is a parametric 

history based modeler, meaning steps 

can be edited. Certain points in the 

modeling history can be accessed, and 

the steps in the Feature Tree can be 

reordered. 

 LMB click one time on the Mesh Fit 

1 entity. Then click and hold the 

LMB on Mesh Fit 1 and drag it to be 

above Extrude 1.  

 The Mesh Fit surface can now be used in the 
Extrude step since it comes first in the tree. 

 RMB on Cut 1 in the tree and select 

Rollback.  

 The model can now be viewed as if the Cut 
and all steps after have never been 
performed. 

 RMB on an entity in the tree and 

select Roll to End to go back to last 

step. 

 
Figure 20 
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4. The Model Tree lists all entities existing in the model.  Practice controlling the 

visibility in the part. 

 Click on the + next to Ref. Planes to view all Planes in the Model. 

 Click on the Eye Icon next to the + to turn off visibility for all Planes. 

 Click on the Closed Eye to turn the planes back on. 

 Click on and off the Eyes next to the Front, Top, and Right Planes to hide the 

planes individually. 

 Turn on and off visibility for other entities in the model. 

 

 
Figure 21 

 

Figure 22 

 

Display 

The Display dock is defaulted as a tab next to the Tree.  Display contains display options for the scan data and the 
bodies.  It also contains additional ways to view and display data in the Model View. 

 1. Click on the Display Tab next to Tree.  

2. Place/remove a checkmark next to World 

Axis & Scale, Scene Grid, Gradient 

Background and Label to toggle visibility of 

each item in the Model View. 

 

 

 

 
Figure 23 
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 3. The General group has options for controlling the way the overall data is displayed, 

including Transparency, Lighting, and View settings. 

4. The Mesh/Point Cloud group lists all the different ways to view the scan data. 

5. The Region group gives the option to view the geometry of the selected or all 

regions. 

6. The Body group lists the ways to view a surface or solid body and it allows for 

control of the resolution of the bodies. 

7. The Sketch & 3D Sketch group has specific visibility options for components of 

sketches. 

 Be cautious changing options without changing them back where they started.  The General>Lock option will 
disable all mouse rotation ability. 

 

 

Figure 24 

 
Figure 25 

 
Figure 26  

Figure 27 
 

Figure 28 

 

Help 

The Help Tab contains a list of contents and commands to find additional information about each 

topic.  The Index tab is searchable.  The content of each help will explain what the tool is, the 

benefits of using it, how to use the tool, and then all of the options of the tool in detail. Figure 29 
shows an example of the layout for the Help tab. 

 F1 will access the Content Help menu for the command that is currently being used. 

 
Figure 29 – Help 
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Viewpoint 

The Viewpoint Tab creates and edits capture states of the current view of the model.  The views can be accessed 
later to remember set, non-standard, views of the part. 

 
 
 
 

 

1. Create a Viewpoint of the model. 

 Rotate, Zoom and Turn on/off Visibility of the model to get a view 

approximately like Figure 30. 

 Click on the Add Viewpoint button. 

 Rotate and Zoom the model to a different orientation. 

 Select the Apply Viewpoint button to return to the state of Viewpoint1. 

 

Figure 30 

 
2. Use the Reassign Viewpoint command to change the Viewpoint1. 

 In the Model Tree, turn off visibility of the Solid Bodies. 

 Select Reassign Viewpoint. 

 Viewpoint 1 is now reassigned to the same view but with the Solid Bodies turned off. 

 
End of Activity 
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Accuracy Analyzer™ and Properties 

ACTIVITY: Check accuracy and properties of a model 

Objective 

Explore the different deviation displays for checking accuracy of a model.  Also, explore the different information 
that can be displayed in the Properties dock. 

 Docks can be pinned to the screen using the push pin located in the corner. 

Accuracy Analyzer™ 

The Accuracy Analyzer™ allows the user to check the accuracy of their part throughout the entire process.  The 
CAD body can be compared to the base scan data with its deviations displayed in a color map.  Different ways to 
display the quality and continuity of the surfaces are also found here.  Deviations between meshes can be 
analyzed.  The dock is where calculation options can be set.  Once deviations are applied, a Color Bar will appear 
to control the tolerance values. 

 

 

1. View the deviations between the solid 

body and the mesh. 

 Select the radio button next to 

Deviation for Body. 

2. Adjust the tolerance range of the part 

 Double click on the 0.1 in green, 

as shown in Figure 31, to alter the 

value. 

 Change the value to 0.15.  

 Changing the upper tolerance will automatically 
change the lower value. 

 

Figure 31 

 
Figure 32 

3. Turn the Accuracy Analyzer off by selecting None at the top of the dock. 
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Properties 

The Properties dock displays information about any selected entities.   Some properties can be changed, visibility 
can be turned on or off, and more information can be calculated inside Properties. 

 1. Calculate the Volume of 

the mesh. 

 Select the 3DS 

Partifact mesh from 

the Feature Tree or 

Model Tree. 

 In the Properties 

dock, click Calc. next 

to Volume. 

 If the mesh is not fully closed, 
Design X will calculate the volume 
of the assumed closed shape. 

 

 

Figure 33 

 2. Change the color of the mesh. 

 In the Upper-Side Toolbar, change the Mesh Display Mode to Shaded. 

 In the Model Tree, turn the eye off next to Solid Bodies.  The part should look like 

Figure 34. 

 Select the blue bar next to Material in the Properties dock.  Then select the 

three dots on the right (Figure 35). 

 Change the mesh color by selecting one of the colored circles. 

 Press OK to accept. 

 

 

 
Figure 34 

 
Figure 35  

Figure 36 

 
End of Activity 
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Bottom Toolbar 
This toolbar contains a second location to hide and show entities, filter tools, and measuring tools. 

 
 

Visibility  Filter 

Turn on and off the visibility of groups of entities. Activate selection filters.  User can only select the 

allowed entity types. 
 

 Meshes (Ctrl+1)   
 

Meshes/Point Clouds 

 Regions (Ctrl+2)  
 

Regions 

 Point Clouds (Ctrl+3)   Poly-Faces 

 Surface Bodies (Ctrl+4)  
 

Poly-Vertices 

 Solid Bodies (Ctrl+5)  
 

Mesh Boundaries 

 Sketches (Ctrl+6)  
 

Bodies 

 3D Sketches (Ctrl+7)  
 

Faces 

 Ref. Points (Ctrl+8)  
 

Loops 

 Ref. Vectors (Ctrl+9)  
 

Edges 

 Ref. Planes (Ctrl+0)  
 

Vertices 

 Ref. Polylines  
 

Ref. Geometries 

 Ref. Coordinate  
 

Sketches 

 Measurements  
 

Constraints Dimensions 

   
 

Clear All Filters 

Measure 

Find dimensions between any entities in the Model View. 

 Distance – Measure a linear distance between two entities. 

 Angle – Measure an angular dimension between two entities. 

 Radius – Find a radius using 3 points or a circular entity. 

 Section – Create a dimension on a 2D section of an object. 

 Mesh Deviation – Measure deviations between separate scan data. 
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World Axis and Scale 

 

The World Axis displays the orientation of the global coordinate system.  The Scale below 
shows the size of the part. 

Dialogs 
Geomagic dialogs have several controls in common with each other; this section describes the most commonly 
used controls and conventions. The majority of Geomagic Control commands are dialog based. 

 
OK button – A checkmark that accepts any changes made while in the dialog and exits the dialog.  A 
subset check can also mean Apply. 

 Cancel button - Discards any changes made while in the dialog and exits the dialog. 

 
Don’t Quit Command with OK button – When the option is selected, the user will remain in the 
command after clicking OK to be able to use the command again. 

 Preview button – Allows the user to see what changes will be made after the command is run. 

 
Next Stage button – Only available in some commands, when another stage of options is needed.  
Generally the next stages have calculation options. 

 Previous Stage button – Go back a stage to make changes. 

 User Break – Cancel a command before it finishes. 

 Estimate – Estimate various quantities in options by reading the surrounding mesh. 

 

 

Entity Selection – The yellow box frame around an entity type means the user can select 
objects, such as scan data, ref. geometry, and CAD faces, to complete the command.  Multiple 
selections can be made in one command.  

 If there is a vertical red stripe on the left side, an entity is required for completion. 

  Select None – Remove all entities listed. 

 Deselect Last – Remove the last selected entity. 

Roll-Up Groups - when rolled up, an arrow in the group title points downward. Clicking anywhere on a rolled up 
group title will expand the group and reveal additional dialog. 
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Context Menus 
Geomagic Design X has several context menus activated by right-clicking in one of three locations; at the top of 
the screen on a user interface element, on an object in the Model View tab and in the Tree Dock. 

User Interface Context Menu 

 

 Quickly add and reorder any command to the Ribbon. 

 Hide the ribbon; reappears when a tab is clicked. 

Model View Context Menu 

Right click on any object or blank space in the Model View will activate an action menu.  Different selected 
entities produce different menus. 

 Immediately enter a Sketch mode. 

 Quickly start a Wizard command. 

 Toggle through common sketching tools. 

 Accept and Cancel commands with ease. 

 
Figure 37 

Dynamically changing menu 

 

 

 
Figure 38 

Context Menu – Sketch Mode 
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Tree Context Menu 

Right Click on any entity in the Feature or Model Tree to open a context menu about the entities.  Generally, 
this is the easiest way to find a step to edit or change the visibility state.  

 Edit a command or sketch. 

 Suppress an entity in the modeling history. 

 Rollback and Roll Forward to a certain point of time in the model. 

 Hide and Show object visibility. 

 Export individual entities as a more generic file format. 

 
 

 
Figure 39 

Context Menu – Feature Tree 

 

Figure 40 

Context Menu – Model Tree 
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Data Types 
Meshes, or Polygons, are common data types which consist of thousands of triangles derived from a large point 
cloud. The application can import several hardware device native file formats. Plug-ins are provided for several 
hardware devices, enabling direct input of scan data into the application.  

Point Data 

 Raw point data is a collection of points, each having an X, Y, Z location. When viewed up close, raw point 
data is displayed as simple colored points, as shown in Figure 41.  

 Shading point data enables a better view of the shape. Raw data is unshaded due to its lack of Normal 
Information.  

 Data collected using a scanner in LiveScan is automatically contains the Normal Information. 

 For best use with Design X, Points can be triangulated and merged to generate a Mesh. 

 
Figure 41 - Raw Point Data 

 
Figure 42 - Shaded Point Data with Normal Information 

 
 

Mesh Data 

A Mesh, or polygon, is a group of triangles, formed by triangulating point data to create the appearance of a 
surface for the data. Mesh data can be generated automatically when the option is selected inside of LiveScan in 
Design X.  When a mesh object is generated the normal faces are colored blue by default, the back face or 
opposite side of the normal face is colored brown. The back faces of all meshes are the complementary color of 
the front face. The front and back face are determined by the direction of the normal of the points. 
 

 
Figure 43 – Default mesh appearance 

 
Figure 44 – Back faces of mesh 

Clicking the Display Panel tab and toggling on Edges in the Geometry Display roll-up group will reveal the mesh 
construct of any mesh object.   
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CAD Data 

CAD data is a collection of faces or bounded surfaces created in Design X, or imported in from other software.  

Design X uses two different types of CAD bodies.  Design X designates if a body is a Solid or Surface body.  Solid 
bodies are grey, and surface bodies are yellow. 

 

 

Figure 45 

 

Figure 46 

Solid Bodies – A collection of connected surface 
elements resulting in a manifold body. 

Surface Bodies – A non-manifold area in 2D or 3D space 
with defined boundaries. 

 

CAD data is typically the primary result of using the Geomagic Design X software. It occurs by: 

 Generating sketches, extrudes, revolves, lofts, etc. inside of Design X. 

 Importing external CAD files, IGES, STEP or CAD neutral file exchange formats 

 Directly opening or importing supported native CAD file formats 
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Scan Preparation  
Overview 

On many occasions, the scan data will require post scanning processing.  Design X has the capability to align 
multiple scans, merge scans into one cohesive mesh, and then edit and enhance the mesh.  After a mesh is 
generated, there are many options for output.  A clean mesh can be exported to be 3D Printed, or a CAD body can 
created and sent for other forms of manufacturing. 
 

Mesh Buildup Wizard 

The Mesh Buildup Wizard (MBW) is a collection of tools to quickly create a single mesh.  The scan data can be 
aligned and cleaned up in the MBW. 

ACTIVITY: Mesh Buildup Wizard 

Objective 

Create a single mesh from multiple scans of points. 

Highlighted Commands 

 Mesh Buildup Wizard 

o Align Between Scan Data 

o Merge 

Training File 

03a – Mesh Buildup Wizard.xrl 
 

 

1. Open training file 03a – Mesh Buildup 

Wizard.xrl  

 Click Open icon in the top left corner. 

 Use the Open Files dialog to navigate to the 

folder where the training files reside. Select file 

03a – Mesh Buildup Wizard.xrl in the Open 

Files dialog. 

 Click Open to open selected file. 

 Both scan objects should be visible when the file is opened. If 
they are not turn them on in the Point Clouds group of the 
Model Tree.  

Figure 47 

 
2. Begin the Mesh Buildup Wizard, located in the POINTS Tab>Wizard Group>Mesh 

Buildup Wizard. 

 The first stage of the MBW, 1/5 – Data Preparation, is for selecting the data and 

options for the wizard. If not listed under Select already, select the target scan data. 

 Under Set Scanner Type, choose Unknown. 

 Using Unknown will display all options in each stage. 

 Uncheck any box for Set Data Condition 
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 The data is not aligned already and we want to remove unwanted data. 

The dialog box should now read 1/5 – Data Preparation indicating all 5 stages are used. 

 

 

Figure 48 

 

 

Figure 49 

 This dialog box has the standard set up used in the software. 

o Select entities section 

o Multiple roll-up groups of options 

o Multi-stage command 

 3. The Entity Thumbnails dock, below the Model View, allows for an organized way to 

view and select all the data available at the current stage. 

 Click the checkmark next to Setup1 in the Entity Thumbnails.  The visibility of 

Setup1 is now off. 

 Replace the checkmark to turn the visibility back on. 

 Hover the mouse over the image of Setup1 in the Entity Thumbnails. A small, 

independent, window will pop up.  This view can be rotated separately from the 

other scans to view scan quality and completeness.  
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Figure 50 

 4. Go to the Next Stage of the Mesh Buildup Wizard. 

 
 
 
 
 

 

5. Remove any unwanted points in the 2/5 - Data Editing stage. 

 Set the Max. Poly-Vertices/Faces Count Per Noisy Cluster to 100. 

 Click on Find Noisy Cluster radio button 

 Any groups of points, 100 or less, which are distanced from the main body, will be selected. 

 Inspect which points are selected, then press the Delete key or icon. 

 

 

 

Figure 51 

 

Figure 52 

 6. Click the Next Stage button in the Mesh Buildup Wizard dialog. 



  

 

2016 3D Systems 33 Geomagic Design X 2016 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

7. Use Stage 3/5 – Data Pre-Aligning to align the two scans. 

 Change the Method to Local Based on Picked Point. 

 The Model View will be divided into 3 view ports. The upper left view port is the Fixed view port and the upper 
right view port is the Floating view port. The wide frame at the bottom serves as a preview after registering 
the object in the Floating view port to the object in the Fixed view port. 

 With proper scanning technique, the Auto Guess method should align the scans.  

 With Reference highlighted in yellow, choose one of the scans.  Notice the scan 

now appears in the top right box labeled Reference. 

 Manually select the Moving option and select the other scan. 

 One scan should be set as Reference, and one scan should be set as Moving. 

 Setting one scan as Reference will keep it static.  Scans that are pre-aligned during LiveScan should be set as 
Reference. 

 Orient each scan in the Reference and Moving boxes to have approximately the 

same positioning. 

 Click on a point on the Reference scan that also exists on the Moving scan. A red 

point should appear. 

 Click on the same point on the Moving scan.  The red points should match. 

 Repeat with at least two more points on each scan.   

 The order of points is Red, Green, and Blue.  At least 3 points are needed to align scans. 

 Select the Apply check next to the 3/5 – Data Pre-Aligning line. 

 
 

   

Figure 53 

 

Figure 54 

 8. Go to the Next Stage of the Mesh Buildup Wizard. 

 
 
 

 
 

9. Stage 4/5 – Best-Fit Aligning will refine the alignment between the scans. 

 Use a rectangular selection to highlight both scans for the Moving group. 

 Sampling Ratio controls the percentage of data being used. Press the Estimate 

wand to see the amount used when set to Auto. 
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 Click the Apply check to complete the fine alignment of the scans. 

 

 

 
Figure 55 

 

Figure 56 

 
Figure 57 

 10. The Best-Fit Aligning can be run multiple times at different Sampling Ratios. When 

satisfied with the alignment, press the Next Stage button. 

 
 
 

 

11. Stage 5/5 – Data Merging will combine and triangulate the point clouds.   

 The MBW has two different merging options.  Select Mesh Construction. 

 Place a Check next to Reduce Noise. 

 Click the Apply check to create a single mesh out of the scan data. 

 

 

12. Inspect the mesh, then press the overall OK (Apply All and Finish) check to finish 

the Mesh Buildup Wizard. 

 

 

Figure 58 

 
End of Activity 
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Mesh/Polygon Editing 

Design X now allows for the mesh to be selected and deleted without entering any edit mode.  All of the tools 
used to edit, optimize, enhance, and heal the mesh are in the POLYGONS tab. 

ACTIVITY: Clean up mesh data 

Objective 

Create one clean, watertight, closed mesh using a variety of tools. 

Highlighted Commands 

 Decimate 

 Fill Holes 

 Rewrap 

 Enhance 

 Healing Wizard 

Training File 

Continue from previous or Open 03b – Mesh.xrl 

Reduce Polyface Count 

After the Mesh Buildup Wizard, the resulting mesh may have more polyfaces, or triangles, than needed.  The 
Decimate command can intelligently remove and merge polyfaces to have the lowest amount possible.  This will 
allow for future processing times to be significantly reduced.  Saved file sizes will also be smaller. 

 
 

1. Select the POLYGONS tab to easily access all of the mesh editing tools. 

 

 
 
 
 
 
 
 
 
 
 
 
 

 

2. Click on the Decimate command located 

in POLYGONS>Optimize>Decimate 

and progress through the dialog menu 

from top to bottom. 

 Select the mesh as the Target Mesh. 

 Change the Method to Allowable 

Deviation. 

 This method will remove as many polyfaces as 
possible without allowing the mesh to change at a 
greater distance than the set value. 

 Under Options set the value to 

0.0254 mm. 

 Press the OK check to Decimate the 

scan. 

 The total triangles now should be under 1,000,000. 

 

 

 
Figure 59 
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Create Manifold Mesh 

Downstream applications, such as 3D printing, require a well cleaned mesh.  A watertight mesh will produce best 
results for 3D printing applications.  Geomagic Design X has tools that can fill in individual holes, and it can also 
wrap an entire part to fill in all the holes at once. 

 
1. Navigate and zoom in to approximately the view shown in Figure 60. 

 

 

Figure 60 

Fill Holes 

 
1. Select the Fill Holes command located in POLYGONS>Repair Holes/Boss. 

 

Figure 61 – Fill Holes Dialog Layout 

 
 

 

2. Choose the large boundary shown above in Figure 61.  Once the command is 

accepted, this hole will fill in. 

3. Edit the boundary to make a cleaner perimeter.  Select Fill Gulf from the Editing 

Tools rollup group. 
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 Left click one time on the top, left-most point of the gap shown below in Figure 62. 

 Left click again on the opposite side of the gap to immediately fill in a portion of the 

hole. 

 Before making the second selection, a preview of the area to be filled will be shown. 

                        
Figure 62 – Fill Gulf 

 
4. Use Remove Peninsula to quickly delete excess, indented data. Edit the boundary to 

make a cleaner perimeter. 

 Left click one time on the top, left corner of the area shown in Figure 63. 

 Left click again on the opposite end to instantly delete this portion of data. 

                  
Figure 63 – Remove Peninsula 

 
5. Select the Remove Island Editing Tool to delete floating areas of data. 

 Left click on the boundaries of any islands to delete them. 

Do not click on any boundary of the main mesh. The entire mesh will delete. To Undo any Editing Tools, 
click on the left-pointing arrow at the end of the Editing Tools rollup menu. 



  

 

2016 3D Systems 38 Geomagic Design X 2016 

 

                       

Figure 64 – Remove Island 

 
6. Select Add Bridge to split the boundary into smaller sections. 

 Left click and hold the mouse button down on one edge of one polyface. 

 The polyface edge will highlight when selected. 

 While holding the LMB, select a triangle on the opposite side of the boundary. 

 The original selected boundary is now listed as two boundaries. 

 

Figure 65 

 
 
 

 

7. Adjust the More Options settings to match the previous Figure 66. 

 Add a check next to Smooth Boundary in the More Options rollup group. 

8. Accept the Fill Holes command by pressing the OK check. 

 

 

Figure 66 
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Rewrap 

Instead of having to select every boundary in the part, the Rewrap command can extend all boundaries until there 
are no holes in the scan. 
  

 

 
 
 
 
 
 

 

1. In the dropdown from POLYGONS>Optimize>Global Remesh, select Rewrap. 

 Under Fitting Options, slide the Geometry Capture Accuracy bar over to Tight. 

Move the Overall Smoothness bar to Min. 

 This will preserve the organic shape of the scan as much as possible. 

 Place a check next to Extended Boundaries in the More Options group. 

 Extend Boundaries on will fill in every size hole. If it is deselected, the very large holes will not fill. 

 Click OK to run the command. 

 

  

Figure 67 Figure 68 

 

Optimize Mesh 

For higher quality printing, the scan data should be enhanced and optimized further.  For parametric modeling, 
the following steps are not generally needed.  A higher quality mesh will create higher quality surfaces. 

 
 
 
 

 
 

 

1. In the POLYGONS tab, select the Enhance Shape 

command in the Optimize group.  

 Increase the Sharpness to Max. 

 Decrease Overall Smoothness to Min.  

 The Enhance Level can be set to the halfway point. 

 The Enhance Level can be altered in the second stage. 

 Go to the Next Stage by clicking the arrow. 

 
Figure 69 
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 2. Adjust the Enhance Level to find 

optimal result. 

 Decrease the slide bar to Min.  

 Check the mesh to see the results. 

 Increase the slide bar to Max. 

 View the difference in the mesh. 

 Adjust the slide bar to the third 

mark.  

Figure 70 

 

 
Figure 71 – Min Enhance Level 

 
Figure 72 – Max Enhance Level 

  Accept the Enhance Shape command with the OK check. 

 
 
 

 

3. Select the Healing Wizard in POLYGONS>Wizard>Healing Wizard to remove the 

last erroneous triangles.  This command finds these triangles automatically, and after 

accepting the command, they are removed. 

4. Accept or Cancel the Healing Wizard to exit. 

 The Healing Wizard will find any small groups of floating triangles, small polyfaces, or dangling, folded, or 
crossing poly-faces automatically.  The parameters for each of these categories can be modified as needed. 

 

 



  

 

2016 3D Systems 41 Geomagic Design X 2016 

 

 

 
Figure 73 

 
 The Mesh is now ready for 3D printing, surfacing, or other production methods. 

 Additional mesh editing exercises can be found in the Appendix. Design X also has built in 
Tutorials.     

 
 
 
 

End of Activity 
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Auto Surface 

A quick, easy, non-parametric way to generate an IGES or STEP file from a cleaned Mesh is the Auto Surface.  The 
mesh is analyzed and surface contours are automatically generated to create extremely accurate surfaces to the 
scan. 

ACTIVITY: Generate CAD Body 

Objective 

Create an accurate CAD body to the scan data.  The resulting body can be exported as a STP, IGS, x_t file, or other 
generic file types. 

Highlighted Commands 

 Auto Surface 

Training File 

Continued from previous or Open 03c - AutoSurface.xrl 
 

 
1. Open training file 03c - AutoSurface.xrl or continue from previous exercise. 

 
 
 
 
 

 

2. Enter the Auto Surface command located in the SURFACING tab. 

 Select Organic in the first option for patch structure. 

 The Organic method creates a curve network as evenly distributed as possible, and is good for models that 
have non geometric faces and with few distinct feature shapes. The Mechanical method will create a curve 
network more uniform and grid like. 

 Leave the Patch Count in Patch Network Option at Auto Estimate to let the 

software decide the amount of patches needed for surfacing. 

 Slide the Geometry Capture Accuracy bar one away from Max. 

 Change the Tolerance to 0.1285. 

 Go to the Next Stage in the command. 

 The first stage of the Auto Surface command sets how the software will construct its NURBS network. The Auto 
Surface command applies to the entire mesh. 

 
Figure 74 – First Stage 
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Figure 75 – Second Stage 

 3. The second stage allows for editing of the generated patch network. 

 Select the Deform option. 

 Zoom in to the area shown in Figure 76. 

 Click and drag the center node of multiple patches to manipulate the form of all 5 

quadrilaterals.  

 If a patch is not in a clear enough four-sided shape, the software might not fit a surface.  Occasionally patches 
need to be edited and reshaped in order to build a better surface body. 

  
Figure 76 
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 4. Edit the form of a single edge of a 

patch with the Deform option. 

 Click and drag a node on a single 

spline to adjust the edge of a patch. 

 Straightening out a patch edge can help create 
better quality connections between the patches. 

 
Figure 77 

 
5. Press the OK checkmark to accept the Auto Surface. 

 If the resulting body is a manifold network of surface patches, the body will become a Solid. 

 Editing the network is generally only needed in the Organic method when patches fail.  The Auto Surface can 
be edited after completion to go correct any failed patches. 

 
Figure 78 
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Inspect Accuracy  

The Auto Surface creates an extremely accurate CAD body in relation to the scan data.  Use the Accuracy Analyzer 
to verify the resulting body. 

 

 

 

1. The Accuracy Analyzer is located in an unpinned dock on the right side.  Open the 

Accuracy Analyzer dock. 

 Turn on the radio button for Deviation for Body. 

2. Change the tolerance on the color bar to 0.05mm. The default tolerance is set to 

0.1mm.  

 On the color bar, double click on the green 0.1. 

 Set the value to 0.05.   

3. Hover the mouse over various areas of the mesh to see the deviations. 

 

 
Figure 79 

 
End of Activity 
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Regions 
Regions classify areas of the mesh based on curvature and geometry features.  An automatic segmentation of the 
scan data into regions is one of the first steps in the modeling processes for most standard workflows.  Regions 
can assist with many processes, including: 

 Aligning 

 Quick Selection 

 Wizard Tools 

 
 
 
 
 
 

ACTIVITY: Understanding Regions 

Objective 

Create and edit regions on a mesh to assist in modeling. 

Highlighted Commands 

 Auto Segmentation 

 Merge 

 Split 

Training File 

04 – Regions.xrl 
 

 
1. Open training file 04 – 

Regions.xrl 

 No mesh editing will be necessary for 
the part. 

 

Figure 80 
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2. In the REGION tab, select the Segment>Auto Segment command. 

 Press the F1 key to read more about the Auto Segment 

 Set the Sensitivity to 5. 

 Click the OK button. 

 The sensitivity option classifies a shape as being round or prismatic. To make smoothly connected areas in a 
single region, move the slider to the left. To make strictly separated regions, move the slider to the right. 

 

 

Figure 81 

 

Figure 82 

 

Editing Regions  

 

1. Change the Selection Type to Paint Brush Selection Mode in the Upper-Side 

Toolbar. 

 To resize the paint brush tool, hold down the Alt key while left-clicking and moving the cursor. 

 

 

 

2. Paint across the regions shown below to select many regions with one click. 

3. The REGION>Edit>Merge option will now be active.  Select the Merge to combine 

the painted regions. 

 The Paint Brush can quickly select multiple smaller regions to merge together. 

 

 

Figure 83 

 

Figure 84 

 

4. Change the Selection Type to the Rectangular Selection Mode. 

 The Rectangular Selection will allow for single click selections of entire regions.   

 

 

5. The Merge tool can combine regions that are not physicallly touching. 

 Click on the five top Sphere regions show in Figure 85. 

 Select the Merge command in the REGION tab. 
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Figure 85 

 

Figure 86 

  Non-adjacent, single regions can be separated back apart by selecting the region and then choosing the 
Edit>Separatecommand in the REGION tab. 

 

 
 
 
 

 

6. Select the Edit>Split tool to convert 

single regions into multiple separated 

regions. 

 After selecting Split, the Limit to 

Region is automatically activated.  

Select the region shown in Figure 

87. 

 Switch the Selection Type to the 

Paint Brush again. 

 Paint across multiple regions, 

including the previously selected. 

 Accept the command. 
  

Figure 87 

 

 
 
 

 

7. Use the Insert command to manually create a region. 

 Select the Extend to Similar Selection Mode in the Upper-Side Toolbar. 

 Click on the marked area to select the entire area in a single click. 

 With the command now active, select REGION>Edit>Insert to create a region 

independent of the previously merged regions. 

 

 

Figure 88 

 

Figure 89 

 
End of Activity 
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Align to Coordinate System 
Scan data should be moved and aligned to a more useful position with the general coordinate system.  Geomagic 
Design X has multiple ways to move  

ACTIVITY: 3-2-1 Alignment using Regions 

Objective 

Learn the basics of aligning scans to the coordinate system using the regions of a mechanical part. 

Highlighted Commands 

 Interactive Alignment 

Training File 

05a – Align 321.xrl  

Scan Setup 

 
1. Open training file 05a – 

Align 321.xrl. 

 No mesh editing will be necessary for 
the part. 

 

Figure 90 

 
 

 

2. In the REGION tab, select the Auto Segment command. 

 Set the Sensitivity to 65. 

 Click the OK button. 

 

 

 

Figure 91 
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Interactive Alignment 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Start the Interactive Alignment in the 

Alignment>Scan to Global group. 

 Click the Next Stage button. 

4. Create a 3-2-1 alignment using three 

planar regions. 

 The Plane option will set the Front 

Plane, and therefore the XY Plane and 

the Z Axis direction. Choose the large 

Plane Region on the bottom of the 

part. 

 The Vector will set the Top Plane and 

the Y Axis direction.  Choose the pink 

long thin Plane Region pointed at in 

Figure 93. 

 The Position will set the Right Plane 

and the location along the X Axis.  

Select the Plane Region shown in 

Figure 94. 

 Click OK to accept. 

 The origin will be located at the intersection of the 
three planes selected above. 

 

Figure 92 

 

Figure 93 

 

Figure 94 

 
 
 

 

Figure 95 

 
End of Activity 
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ACTIVITY: 3-2-1 Alignment using Reference Geometry 

Objective 

Learn how to create other types of reference geometry to use for an Interactive Alignment. 

Highlighted Commands 

 Ref. Plane 

 Interactive Alignment 

Training File 

05a – Align 321.xrl 

Scan Setup 

 
1. Open training file 05a – 

Align 321.xrl. 

 No mesh editing will be necessary for 
the part. 

 

Figure 96 

 
 
 

2. In the REGION tab, select the Auto Segment command. 

 Set the Sensitivity to 65. 

 Click the OK button. 

 

 

 

Figure 97 
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Reference Planes 

 

 

 

3. Create a Ref. Geometry>Plane down the center of the part two directions.   

 Select the Lock icon to stay inside the command and make multiple planes. 

 Change the Average. 

 Select two long planes shown to find the mid plane between them. 

 Click the OK button to accept. 

 

Figure 98  

Figure 99 

4. Create a symmetry plane going down the center of the part in the other direction. 

 Change the Method to Draw Line. 

 Draw a line roughly in the orientation shown in Figure 100 to create a plane. 

 Click the OK button to accept. 

 Change the Method to Mirror. 

 In the Model Tree, hold the Ctrl key and select the Mesh (Align1) and Plane2. 

 Click OK to accept. 

 A plane representing the center of the mesh in the direction of the drawn plane will be found. 

 
 
 

 

Figure 100 

 

Figure 101 
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Interactive Alignment 

 
1. Start the Interactive Alignment in the Alignment>Scan to Global group. 

 Click the Next Stage button. 

2. Create a 3-2-1 alignment using the generated reference planes and a region plane. 

 The Plane option will set the Front Plane, and therefore the XY Plane and the Z 

Axis direction. Choose the large Plane Region on the bottom of the part. 

 The Vector will set the Top Plane.  Choose Plane1 to set the Y Direction normal to 

the plane. 

 The Position will set the Right Plane and the location along the X Axis.  Select 

Plane3. 

 Click OK to accept. 

 The origin will now be set to the middle of the part along the bottom face. 

 

Figure 102 

 

Figure 103 

 
End of Activity 
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ACTIVITY: XYZ Alignment  

Objective 

Learn how to create other types of reference geometry to use for an Interactive Alignment. 

Highlighted Commands 

 Ref. Vector 

 Interactive Alignment 

Training File 

05b – Align XYZ.xrl 

Scan Setup 

 
1. Open training file 05b – 

Align XYZ.xrl. 

 No mesh editing will be necessary for 
the part. 

 

Figure 104 

 
 
 

2. In the REGION tab, select the Auto Segment command. 

 Set the Sensitivity to 50. 

 Click the OK button. 

 

 

 

Figure 105 
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3. Create a Ref. Geometry>Vector down 

the center of hub of the fan.   

 Set the Method to Find Cylinder Axis.  

 Choose the two large cylinder regions 

around the central hub. 

 Finish the Vector by right-clicking and 

selecting the checkmark from the 

context menu. 

 Design X version 2016 and newer has many new right-
clicking capabilities. 

 

Figure 106 

 

Interactive Alignment 

 
1. Start the Interactive Alignment in the Alignment>Scan to Global group. 

 Click the Next Stage button. 

2. Create an XYZ alignment using the generated reference planes and a region plane. 

 The Position will set the location of the Origin.  Select the Vector1 and Region 

Plane representing the top of the middle hub. 

 The intersection of a vector and plane represents a point, which can be used for position. 

 To set the directions of the coordinate system, select Axis Z and choose the 

Vector1. 

 Click the Flip Direction arrow to adjust the positive Z in the desired direction. 

 Axis X and Axis Y do not need to be set.  The blue circle can be twisted to manually 

clock the part to any location. 

 Click OK to accept. 

 The origin will now be set to the middle of the hub of the propeller with the Z Axis going through the middle. 

 

 

Figure 107 

End of Activity 
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ACTIVITY: Scan to CAD Alignment  

Objective 

Learn how to import a CAD body and align the scan data to the CAD body. 

Highlighted Commands 

 Quick Align 

 Best Fit Align 

Training File 

05a – Align 321.xrl 
05 – Align CAD.igs 

Scan Setup 

 
1. Open training file 05a – Align 321.xrl. 

2. Import the IGES file, 05 – Align CAD.igs, by selecting 

HOME>Open/Import>Import. 

 Importing a file will place it in the same open file.  

 
 
 

 

Figure 108 

 
3. Choose the ALIGNMENT>Scan to 

CAD>Quick Fit command to align the 

scan data to the CAD data. 

 Set the Target Body to be the CAD 

body.  

 The Align1 scan should be automatically 

set as the Moving Entities. 

 Click the OK button to accept. 

 The Run Best Fit Alignment should be checked under 
More Options. 

 

Figure 109 
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4. The Best Fit Alignment will automatically start and have all of the options populated. 

Press the OK key to accept. 

 The Best Fit Alignment will always need to be run after a Quick Fit.  This will make a much better registration 
between the files. 

 

 

Figure 110 

 Aligning a scan to an already built CAD file can be used for multiple reasons, including: 

 Check the accuracy of the scanned part to the CAD. 

 Add features to a Solid Body that were not in the original file. 

 
End of Activity 
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Parametric Modeling 
The strength of Geomagic Design X is in its sketch based modeling.  Any model can be created regardless of the 
scan quality.  Design X utilizes sketches and standard CAD operations, such as Extrude, Revolve, Sweep, and Loft, 
to generate a parametric model.   
 

ACTIVITY: Introduction to Sketching 

Objective 

Learn how to set up a Sketch and the basic principles of creating sketches.  Creating sketch entities, constraining 
entities, and dimensioning are all introduced in this lesson. 

Highlighted Commands 

 Setup Sketch 

 Rectangle 

 Parallelogram 

 Fillet 

 

Sketch Entities 

 
 

 

1. Create a New File by selecting the icon on the top-most 

toolbar. 

2. Click SKETCH>Setup>Sketch to begin a 2D sketch. 

 Select the Front Plane from the Model View. 

 The sketch will start immediately after selecting the base plane. 

 If a plane is already selected, choosing Sketch would directly start a sketch 
on that plane. 

 The Sketch button has now changed to Exit in order to complete the sketch. 

 

Figure 111 

 
 
 
 
 

 

3. Create a Rectangle using the SKETCH>Draw>Rectangle tool. 

 Left-click in the top-left corner of the origin, as seen in Figure 113, to begin the 

Rectangle. 

 Left-click the bottom-right corner to finish the Rectangle. 

 Finish the Rectangle by right-clicking in the Model View and selecting the 

Checkmark from the context menu. 
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Figure 112 

 

Figure 113 

 4. Drag a Line or a Point of the Rectangle to modify its size until it is roughly centered 

at the Sketch Origin (red U and green V axis). 

 By dragging a Line of the Rectangle you can alter one dimension (Length or Width of the Rectangle) at a time, 
while dragging a Point would let you alter both dimensions at the same time. 

 

Constraints 

 5. Double-click on the top-left Point of the Rectangle.  The 

Constraint and information for that single point is now shown. 

 A Coincidence Constraint is applied on the end point of the two lines forming the 
corner. 

 To see Constraints of another entity, only single left-click on the entity without 
leaving the Properties Dialog.  

Figure 114 

 6. Show and add Common Constraints of multiple sketch entities. 

 LMB Click on the bottom line of the Rectangle to view the 

Constraints. 

 A Horizontal Constraint should be shown. 

 Shift+LMB Click on the other horizontal line of the Rectangle 

(Figure 116). 

 Both lines will be selected to show the Common Constraint between all selected 
entities. 

 Select the Independent Constraint Horizontal and click the 

button Delete Constraint to remove. 

 Select Parallel to set the Common Constraint. 

 Repeat with Vertical lines. 

 

Figure 115 
 

Figure 116 

 

Figure 117 
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 Alternatively, a Parallelogram could have been chosen from the beginning by clicking the small 
triangle next to the “Rectangle” tool in the SKETCH Ribbon and selecting the “Parallelogram” in 
the tools list to produce the same result. 

 The Ribbon always remembers the last method of a tool button, for quicker repeatability. 

 7. Apply a Perpendicular Constraint to the 

lower left corner of the Rectangle. 

 Close the Constraints Dialog Tree with 

a RMB click check or the dialog 

checkmark. 

 LMB click anywhere in the Model View 

background to deselect all entities. 

 After most operations, selections will persist after the 
dialog is closed. 

 

Figure 118 

 

 

 
 

8. Create a pivot point for rotating the sketch by constructing two intersecting 

Centerlines with the SKETCH>Draw>Centerline tool below the Line tool. 

 The Line tool could have been used with the option For Construction selected. 

 Move the cursor over the middle of the left line, and LMB click at the Mid-Point 

Constraint to start the Centerline (Figure 119). 

 After clicking to make the point, move the cursor back over the left line to activate the Parallel and 
Perpendicular assist axes. 

 LMB click to place the Centerline when the yellow Perpendicular and white Vertical 

symbol are visible. 

 Creating the centerline perpendicular to the base will keep it related ta rotatable rectangle. 

 RMB click to finish the line. 

 Move the cursor over the middle of the bottom line, and LMB click at the Mid-Point 

Constraint to start the Centerline.  

 Finish the line at the end point of the first centerline, Perpendicular to the Mid-Point. 

 
 

 

Figure 119 

 

Figure 120 

 

Figure 121 
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 9. LMB Click and Hold on the intersection point of 

the two Centerlines and drag it onto the 

intersection of the red and green Sketch U/V-

Axis to place the Coincident Constraint. 

 The center point should turn black signifying it is fully defined.  

 Click and drag a mid-point of the rectangle lines and the 
rectangle will rotate and resize. 

 

Figure 122 

 

Dimensioning 

 

 
 
 
 
 
 
 
 

 

10. Select the Smart Dimension tool from the SKETCH>Draw ribbon to apply the Linear 

and Angular dimensions as shown. 

 LMB Click one line and then select the parallel entity. LMB Click in space to set the 

linear dimension. 

 Repeat for the other set of parallel lines. 

 Select the inferred horizontal horizon line and one of the created Centerlines. LMB 

Click in space to set the angular dimension. 

 Sketch entities will turn black when they are fully constrained by dimensions and constraints. 

 Click OK to accept the command. 

 
 

 

Figure 123 

 

Figure 124 

 
 
 

 

11. Edit the Dimensions by double-clicking on each value. 

 Set the two linear dimensions to size the box. 

 Change the angular dimension to rotate the box to a specific angle from the horizon. 

12. Click the Exit button to finish the sketch. 
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Figure 125 

 This sketch can be easily controlled and updated for future uses in CAD. 

End of Activity 
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ACTIVITY: Basic Concept 

Objective 

Learn the basics of sketching and extruding to create and cut solid bodies. 

Highlighted Commands 

 Mesh Sketch 

 Extrude 

 Fillet 

Training File 

07 – Basic Concept.stl 

Scan Setup 

 
1. Import training file 07 – Basic 

Concept.stl. 

 Click the Import button on the 

Quick Access Toolbar. 

 Or choose MENU>Insert>Import 

from the dropdown. 

 Navigate to the file then choose 

Import Only. 

 Design X requires importing files that are not 
native Design X file types. 

 No mesh editing will be necessary for the part. 

 

Figure 126 

 
 

 

2. In the REGION tab, select the Auto Segment command. 

 Set the Sensitivity to 50. 

 Click the OK checkmark to accept. 

 
 

 

Figure 127 
 

Figure 128 
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Interactive Alignment 

 
1. Create a Plane through the middle of the part to use for alignment using the 

MODEL>Ref. Geometry>Plane command. 

 Change the Method to Mirror. 

 In the Feature Tree, hold the Ctrl key and select the Right plane and Basic 

Concept mesh. 

 Click OK.  

 The Mirror method will read the selected mesh and find the symmetry plane of the scan based on the given 
direction of the selected plane. 

 

 

Figure 129 
 

Figure 130 

 
 
 

2. Begin the alignment by selecting Interactive Alignment from ALIGNMENT>Scan 

to Global. 

 Go to the Next Stage. 

3. Change the Moving option to X-Y-Z. 

 Set the Position as the region Plane on the bottom of the part and the region 

Cylinder of the central hole. 

 The Origin will now be set to the point where the cylinder axis would intersect the plane. 

 
 

 

Figure 131 
 

Figure 132 

 

Figure 133 
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 Click on Axis Z, and then select the same region Plane as before to set the Z 

direction. 

 Select the Flip button next to Axis Z to point the Z Axis through the part. 

 Click on Axis X, and then select Plane1. 

4. Click OK to accept the alignment based around the central hole. 

 

Figure 134 

Create Main Body 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. In the SKETCH tab, 

choose Setup>Mesh 

Sketch. 

 Select the Front plane 

as the Base Plane. 

 Set the Offset Distance 

From Base Plane to 

5mm. 

 Click the OK button to 

begin sketching. 

 The Offset Distance From Base 
Plane is only to set a cross-section 
distance of the model to be 
projected back to the originally 
selected Base Plane.  All sketches 
will still be created on the Base 
Plane, regardless of the height of 
the Offset Distance. 

 

 

Figure 135 
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2. Use the Model Tree to Hide the Mesh. 

3. Select the Draw>Line tool. 

 Click on the top-most solid pink line.  A line will be best fit to the entire segment. 

 Click the OK button to accept the line. 

4. Select the Draw>CenterPoint Arc command. 

 Click on the left-most solid pink line. An arc will be best fit to the entire segment. 

 Click on the Accept Fitting check. 

 Double click the right-most solid pink line.  This will create and accept the arc while 

still staying inside the command. 

5. Use the Centerpoint Arc to create the lower, segmented arc. 

 Single click on the five segments to create one best fit arc between the segments. 

 Double click anywhere in space to accept the fitting. 

 Click the OK button to accept. 

 
 

 

Figure 136 

 
 
 
 
 

 
 

6. Open the Accuracy Analyzer on the right side toolbar to display all points of an open 

loop. 

 Place a checkmark next to the Disjoined Ends box. 

 Disjoined Ends will add a green end point to any point of opening in a sketch chain. 

 

7. Using commands from the Tools group allows for quick ways to close open sketch 

loops.  Select the Tools>Trim command to close endpoints to a sharp corner. 

 Change the option the Corner Trim. 
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 Locate the two open ends shown in the picture below. 

 Zoom in to one corner.  Left click on one line segment surrounding one corner. 

 Select the other line segment to join the two ends.  

 This command uses the sketch segments, not end points. The Trim will be directed based which side of the 
segment is selected. 

 Repeat on the other corner. 

 Click the OK button to accept. 

 If the OK is greyed out, clicking the Cancel button will keep the Trim and exit the command. 

 

 

Figure 137 

 

Figure 138 

 

8. Use the Tools>Fillet command to close the other two open points with smooth, 

tangent arcs. 

 Left click on one sketch segment near the missing arc segment. 

 Click and HOLD the LMB on the second segment.  

 While still holding the LMB, move the mouse around to adjust the size of the fillet.  

 Release the mouse button when the arc is best fitting the pink polyline. 

 Repeat to create the second arc. 

 Click OK to accept. 

 

 

Figure 139 

 

Figure 140 

 

Figure 141 

 9. Double click on a dimension to edit the value. 

 Using a design intent approach, change each dimension to 88 mm. 
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10. Verify there are no openings in the sketch loop, then press the Exit button in the top 

toolbar. 

 

 

Figure 142 

 
 
 
 

 

11. In the MODEL tab, select the 

Create Solid>Extrude 

command to generate the 

body. 

 Turn on the Mesh and 

Region visibility by pressing 

Ctrl+2. 

 The Base Sketch should 

automatically be selected as 

Sketch1 (Mesh). 

 Change the Method to Up to 

Region. The Sub Method 

should automatically set to 

Trim with Region Fit 

Surface. 

 For the Up To option, select 

the top, Freeform region. 

 Click the OK to accept. 

 The Up to Region>Trim with Region Fit 
Surface method will automatically fit the 
extrusion to the shape of the region.  

 Press F1 to see all the different methods 
of Extruding. 

 

Figure 143 
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Figure 144 

 

12. Turn on Deviation for Body inside of the Accuracy Analyzer dock.  

 Rotate the body to inspect the accuracy of the model. 

 The Bottom View will display the area of high deviation.  This face shows the solid 

body is both too small in areas and too large. 

 Select None to turn the deviations off. 

 

Figure 145 

 13. To fix the inaccuracies of the model, Edit the base sketch. 

 RMB on Sketch1(Mesh) in the Feature Tree. 

 Select Edit from the dropdown menu. 

 
14. Press the Normal To button on the Upper-Side Toolbar, or Ctrl+Shift+A.  This will 

align the sketch back normal to the screen. 

 15. Select the lower sketch arc and press Delete. 
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16. Using the Draw>Line command, reconnect the loop by clicking on one endpoint and 

then the other. 

 Click the OK to accept. 

 A yellow and black concentric circle symbol will appear when selected on the end point. 

 17. Click and HOLD the LMB on the new line and drag it below the pink polyline. 

 

 

Figure 146 

 
18. Click the Exit button to exit and accept. 

 19. Make sure the Regions are still visible, but HIDE the Solid Bodies using the Model 

Tree, or by pressing Ctrl+5. 

 

20. Create an accurate, form-fitting surface along the back face of the mesh with the 

MODEL>Wizard>Mesh Fit command. 

 Select the Revolution region that represents the inaccurate face. 

 With the Resolution set to By Allowable Deviation, limit the Max. No. of 

Control Points to 20. 

 Click OK to accept the Mesh Fit surface. 

 A Mesh Fit surface will be created accurately to any mesh surface.  This surface is not directly editable since it 
is not based off of a sketch.   If changing the Mesh Fit parameters does not create the desired surface, the 
mesh itself can be optimized and editing to make a better fitting surface. 

 

 

Figure 147 
 

Figure 148 

 

21. Turn back on the Solid Body visibility. 

 This surface will be used to cut off the excess solid body. 
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22. Select the MODEL>Edit>Cut command to cut a solid body using a surface body. 

 Select the Mesh Fit1 surface as the Tool Body. 

 Select the Extrude1 solid as the Target Body. 

 Click on the Next Stage arrow. Notice the OK check is not available until the next 

stage is completed. 

 Click on the main portion of the Solid Body to select as the Target Body.  This is 

the portion that will be kept. 

 Select the OK check to accept the cut. 

 

 

Figure 149 

 

Figure 150 

 23. Turn the Deviation for Body back on in the Accuracy Analyzer dock to see the new 

resulting body. 

 

Figure 151 

 It is recommended to turn the deviations back off after viewing.  This will speed up processing time for all 
proceeding steps instead of making the software rerun the analyzer. 

Extrude Cut 

 1. Turn on and off visbility of entities until only the Mesh and Regions are visible. 

 

 

2. Right Click on the Plane region shown below. 

 Select the Mesh Sketch icon to immediately enter the Mesh Sketch Setup up with the 

region as the Base Plane. 
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Figure 152 

 
 
 
 

 

 Set the Offset Distance From Base Plane to 2 mm, or drag the thin, blue arrow up 

until the outline of the cutout shown is visible. 

 Place a Check next to Draft Angle. 

 Select the Measure Angle button then click on the two planar regions shown in 

Figure 154.  

 Set the Draft Angle to 1°. 

 The total angle will be displayed.  This will show if there is any draft from the base plane.  The Mesh Sketch Setup 
can compensate for the draft when projecting the poly-lines back to the base plane. 

 Click the OK check to begin sketching. 

 Hiding the Mesh can make it easier to see the underlying polylines. 

 

 

Figure 153 

 

Figure 154 

 
 
 
 

 

 
 

 

3. Sketch the inner cutout using the Line and 3 Point Arc tools. 

 RMB Click in the Model View. An array of common sketch tools will immediately 

appear. 

 Select the Line icon and sketch the two vertical lines by double clicking the LMB on 

each polyline. 

 Draw a Line between the bottom end points to close the loop. 

 RMB Click and select the Check to accept the line command. 

 RMB Click. Select the 3 Point Arc icon. Click on both end points and then the height 

of the pink polyline radius. 

 RMB Click and select the Check to finish the command. 
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Figure 155 
 

Figure 156 

 

 

 
 

Figure 157 

 

 

Figure 158 

 

 
 
 
 
 
 
 
 
 
 

 

4. Edit and adjust the sketch for a better overall model. 

 Double Click on one of the vertical sketch lines. 

 A dialog box will appear with the editing and constraint options.  Select Vertical from 

the Constraints box. 

 Hold Shift and select the other vertical line.  Select Parallel from the Common 

Constraint options. 

 Double Click on the arc.  Hold Shift and select one of the vertical lines.  Select 

Tangent from the Common Constraint options.  Repeat the process on the other line 

to create tangency with the arc. 

 Adjust the sketch entities until the sketch looks like Figure 160.  

 RMB Click and select the Exit button. 

 
 

 

Figure 159 

 

Figure 160 
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5. RMB Click in space on the Model View and 

select Solid Extrude. 

 Turn on the Mesh and Solid Body visibility. 

 Check Sketch2 (Mesh) is selected as the 

Base Sketch. 

 Change the Method to Through All. 

 Place a Check next to Draft and input the 

1° measured earlier. 

 Check the direction of the draft is correct. Use the Flip 
Direction arrow next to the Draft input. 

 Set the Result Operator options to Cut. 

 Click the OK check to accept. 

 The sketch must still be highlighted, and the RMB click must 
not be on a plane to give the Extrude options. 

 

Figure 161 

 
6. Hide the Solid Bodies, then RMB Click on the 

plane shown and start a Mesh Sketch. 

 Set the Offset Distance From Base Plane 

to 2 mm. 

 Click the OK check to accept. 

 

Figure 162 

 

 

 

7. RMB Click on the Model View and select the Auto Sketch command. 

 With the option set to Make Selected Only, select only the inner loop sketch. 

 Click the OK check to accept. 

 RMB Click and select the Exit button to finish the sketch. 

 

 

Figure 163 

 

Figure 164 
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8. RMB Click in space on the Model View 

and select Solid Extrude. 

 Turn on the Mesh and Solid Body 

visibility. 

 Check Sketch3(Mesh) is selected as 

the Base Sketch. 

 Change the Method to Through All. 

 Set the Result Operator options to 

Cut. 

 Click the OK check to accept. 

 

 

Figure 165 

 

Revolve Cut 

 
 
 
 
 
 

1. Create a Vector in the MODEL>Ref. Geometry group. 

 Select the Right and the Top Planes.  

 If not done automatically, set the Method to Intersect 2 Planes. 

 Click the OK to finish. 

 
2. Right-Click on the Right Plane and select the Mesh Sketch icon to start sketching. 

 The sketch setup will already be located in the correct location. Click the OK to accept 

and begin sketching. 

 

 

Figure 166 

 

Figure 167 
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3. Use the Model Tree to Hide the Mesh and Solid Bodies. 

4. Select the Draw>Line tool. 

 Use a box select method to create the 3 lines from the polylines. 

 Draw a vertical line starting from the vector to create a complete sketch. 

 Right-Click in space to select the Check and accept the command. 

5. Right-Click on the Vector and select Convert Entities. 

6. Select the Draw>Trim command. 

 Check it is set to Corner Trim. 

 Click on all of the lines surrounding each open connection to close. 

 Right-Click in space to select the Check and accept the command. 

7. Set constraints and dimensions then Right-Click in space and Exit the sketch. 

 

 

Figure 168 

 

Figure 169 

 
 

 Only half of the figure needs to be sketched for the Revolve command. 
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8. Choose the MODEL>Create Solid>Revolve command to cut out the section. 

 With the previous sketch populating the Base Sketch and Profiles, chose Axis and 

select Vector1. 

 Under Result Operator, select Cut. 

 Click the OK to cut out the area. 

 

 

Figure 170 

 

Create Fillets 

 

 
 

 
 
 

1. Choose the Fillet command in the MODEL>Edit group. 

 Create a Constant Fillet by selecting the edge shown in Figure 171. 

 The Tangent Propagation option will select all edges of the solid tangent to the first choice, reducing the need to 
manually select all edges. 

 Next to the Radius box, press the Estimate Radius From Mesh magic wand button. 

 Adjust the value to 1.5mm. 

 Click the OK to finish. 

 

 

Figure 171 

 

Figure 172 
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 2. Repeat the process on the fillet around the outside of the mesh. Add all edges belonging 

to the same size fillet. 

 

 

Figure 173 

 
 
 
 
 

 

3. Right-Click the solid edge of the other cut out in 

Figure 174, and choose the Fillet icon. 

 Change the type to Variable Fillet. 

 The Profile View will appear below the Model View.  This will be used 
to figure out the varying radius. 

 Manually select all 3 edges used for the variable 

fillet then click the Estimate Radii From Mesh 

Button. 

 Look at the predicted fillet radius down in the 

Profile View. 

4. Adjust the end points to match the pink polyline.   

 Set the R(adius) value to 4mm at each end point. 

 Click on the middle section to re-zoom around this 

segment. Click again to place a new point in the 

approximate middle of the line. 

 Drag this point up to tallest peak of the pink 

polyline. 

 Click OK to finish. 

 

Figure 174 
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Figure 175  

Figure 176 

 
 

 

Figure 177 

 5. Insert any additional fillets to the model. 

 
End of Activity 
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ACTIVITY: Mechanical Freeform Surface Modeling 

Objective 

Create a surface body using Modeling Wizard and Model Surface Features, and then combine the surfaces using 
3D sketches and surface trimming tools.   Analyze modeling result with Accuracy Analyzer™. 

Highlighted Commands and Concepts 

 Surface Fitting 

 Surface Editing 

 Surface Loft 

 3D Sketching 

Training File 

08-Mech Freeform Surface.xrl 
 

File Open 

 
1. Open training file 08 – Mech 

Freeform Surface.xrl. 

 Navigate to the file from the Open 

Files dialog and press the Open 

button. 

 The data is already aligned and classified with 
regions. 

 

 

 

Figure 178 

 

Upper Surfaces 

 
 
 
 
 
 
 

 

 
 
 

1. Select the Mesh Fit button in the MODEL>Wizard group on the ribbon to create a 

surface on the large, upper face. 

 Select the large, upper target Region shown in Figure 179. 

 Set the Resolution type to By Allowable Deviation, and the Allowable 

Deviation to 0.1mm. 

 Rotate the preview plane with a manipulator node until it is parallel to the x-axis. 

 Click the OK to accept the command. 

 The orientation of the preview plane will be the same as the finished surface.  Having the surface more square 
to the part will allow for higher quality surfaces in the end.  
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Figure 179  

Figure 180 

 

2. Hide only the Mesh Fit(1) surface body using the Model Tree. 

3. Select the Mesh Fit button in the MODEL>Wizard group on the ribbon to create the 

adjoining surface on the upper face. 

 Select the target Region shown in Figure 181. 

 Click the OK to accept the command using the previous options. 

 

 

Figure 181 

 

Figure 182 

 

Join Surfaces 

 

 
 

1. Click the 3D Sketch button in the 3D SKETCH > Setup group on the ribbon. 

2. Select the Spline tool in the Draw group. 

 Draw a Spline from edge to edge of the Mesh Fit(1) surface body, as shown in 

Figure 183. 

 Right-Click to end the first spline. 

3. Repeat Step 2 for drawing a Spline on Mesh Fit(2) as close to parallel as possible to 

the first spline, then Accept the Spline. 
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Figure 183 – Mesh Fit(1) 

 

Figure 184 – Mesh Fit(2) 

 

 
 

4. Click the Split button in the 3D 

SKETCH>Edit group on the ribbon. 

 Split the first curve by clicking on 

two points near the edges of the 

Mesh Fit(2) surface. 

 Accept the command. 

 

Figure 185 

 
5. Click the Exit button in the top left corner to finish the 3D Sketch. 

 

 

 

 

 

 

6. Hide Meshes and Mesh Fit(2), and Show Mesh Fit (1). 

7. Select the MODEL>Edit>Trim Surface command to trim the surfaces with the 3D 

Splines. 

 Select the first Spline in 3D Sketch(1) as the Tool Entities. 

 Select Mesh Fit(1) as the Target Entities. 

 Click the Next Stage button to continue. 

 Chose the correct larger portion of the surface as the Remaining Bodies. 

 Click the OK button to accept. 

 

 

Figure 186 

 

Figure 187 



  

 

2016 3D Systems 83 Geomagic Design X 2016 

 

 

8. Repeat Step 7 using the second drawn 

Spline as the Tool Entities, and the 

Mesh Fit(2) as the Target Entities. 

 

Figure 188 

 

 

Figure 189 

 

Figure 190 

 

 

9. Turn on visibility for both Trim Surface(1) and Trim Surface(2), and turn off 

visibility for 3D Sketch(1). 

10. Select the MODEL>Create Surface>Loft command to join the surfaces.  

 Double check the Surface Loft command has been selected. 

 Select the Edge1 of Trim Surface1, and Edge2 of Trim Surface2 as the Profiles. 

 Set the Start Constraint and End Constraint to Tangency To Face.  This will 

apply tangency to the lofted surface where it connects to the original surfaces. 

 Click the OK button to create the lofted surface. 

 

 

Figure 191 

 

Figure 192 

 

Figure 193 
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11. Finish joining all the surfaces into one 

body with the Sew command, found in 

the MODEL>Edit group.  

 Select all three surfaces as the 

Surface Bodies. 

 Click the Next Stage button. 

 Click the OK button to accept the 

result.  

Figure 194 

  Alternatively, the Sew step can be skipped if the “Merge Tangent Faces” option is selected during the Loft 
command. 

 

Reasoning for splitting the spline 

 
 
 

When trimming a surface by a curve, the split points on the curve will create a separate edge along the 
surface.  Therefore, the surface edge length can be adjusted for lofting by editing the split points.  If the 
edge lengths are of similar size when lofting, the resulting surface will be smoother and of higher 
quality. 

 

 

Figure 195 – 3D Sketch with Split 

 

Figure 196 – 3D Sketch without Split 

 

 

Figure 197 – Loft with Split 

 

Figure 198 – Loft without Split 
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Figure 199 – Deviation with Split 

 

Figure 200 – Deviations without Split 

 

Create Side Surfaces 

 
 
 
 
 

 

 

1. Hide Surface Loft1 to view the Mesh with Regions on. 

2. Choose the Loft Wizard command in the MODEL>Wizard. 

3. In the 1st stage of the Loft Wizard, set the location and orientation of the Loft. 

 Choose the three regions, shown in Figure 202, as the Regions/Poly Faces. 

 Change the Section option to By No. Of Sections, and set the value to 5. 

 Check the options match Figure 201. 

 

 

Figure 201 

 

Figure 202 

 4. Rotate and adjust the 

manipulator to stretch 

the preview planes the 

long way across side 

body. 

 

Figure 203 
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 5. Click the Next Stage button to continue.  A preview of the flow of the fitted surface 

body will be displayed. 

 

 

Figure 204 

 

6. Turn on the Deviation for Body in the Accuracy Analyzer™, and use these 

deviations to add and move sections for a higher quality surface. 

 Sections can be moved by clicking and dragging.  Sections can be added by holding Ctrl and clicking and 
dragging the section planes. 

 These sections cannot be easily added and moved once the Loft Wizard has be completed. 

 

 

Figure 205 

 

Figure 206 

 7. Click the OK button to finish the lofted 

surface. 

 

Figure 207 
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8. Create the adjacent surface with a Mesh Fit surface.  Select MODEL>Wizard>Mesh 

Fit on the ribbon.  

 Select the region shown in Figure 208 as the Target Regions/Poly-Faces. 

 Click the OK button to accept the surface using the previous settings. 

 

 

Figure 208 

 

Figure 209 

 

Join Side Surfaces 

 

 

 
 
 

 

 

1. As done previously, enter into a 3D Sketch to create clean trim lines for lofting 

between surfaces. 

2. Hide Surface Loft1 and Surface Loft2 to only show the new Mesh Fit surface. 

3. Select the Spline tool in the 3D Sketch>Draw group. 

 Draw a Spline on the Mesh Fit3 surface body (Figure 210). 

 Hide the Mesh Fit3 surface and Show Surface Loft2. 

 Draw a second spline on the Surface Loft2 body (Figure 211). 

 

 

Figure 210  

Figure 211 



  

 

2016 3D Systems 88 Geomagic Design X 2016 

 

 

 

 

 

 

 

 

 

4. Select the Split button in the 

3D SKETCH>Edit group on 

the ribbon. 

 Turn on visibility of the 

Mesh Fit3 surface to see 

where the split points 

should be located. 

 Click on two points on the 

second spline to split the 

line. 

5. Click the Exit button in the top 

left corner to finish. 

 

Figure 212 

 6. Turn on the visibility for Mesh Fit3 and Surface Loft2. 

 

7. Select the MODEL>Edit>Trim Surface command on the ribbon. 

 Select the first spline in 3D Sketch3 as the Tool Entities, and Mesh Fit(3) as the 

Target Entities. 

 Click the Next Stage button to continue. 

 Choose the correct Remaining Bodies. 

 Click the OK button. 

 

 

 

Figure 213 

 

Figure 214 

 

8. Repeat Step 7 using the second spline as the Tool Entity and Surface Loft2 as the 

Target Entity to Trim the lofted surface. 
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Figure 215 

 

Figure 216 

 9. Hide 3D Sketch3, and Show Trim Surface3 and Trim Surface4. 

 

10. Create a Surface Loft with the MODEL>Create Surface>Loft command to join the 

surfaces.  

 Select the Edge1 of Trim Surface3, and Edge2 of Trim Surface4 as the Profiles. 

 Set the Start Constraint and End Constraint to Tangency To Face.  This will 

apply tangency to the lofted surface where it connects to the original surfaces. 

 Place a check next to Merge Tangent Faces in the Options rollup.  

 Click the OK button to create the lofted surface. 

 

 

Figure 217 

 

Figure 218 
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Finish Side Surfaces 

 

 
 

1. Create the next with a Mesh Fit surface.  Select MODEL>Wizard>Mesh Fit on the 

ribbon.  

 Select the region shown in Figure 219 as the Target Regions/Poly-Faces. 

 Click the OK button to accept the surface using the previous settings. 

 

 

Figure 219 

 

Figure 220 

 

 

 

2. Enter into a 3D Sketch to create clean trim lines for lofting between surfaces. 

3. Hide all surfaces except the new Mesh Fit surface. 

4. Select the Spline tool in the 3D Sketch>Draw group. 

 Draw a Spline on the Mesh Fit4 surface body (Figure 221). 

 Hide the Mesh Fit4 surface and Show Trimmed Surface3. 

 Draw a second spline on the Trimmed Surface3 body (Figure 222). 

 

 

Figure 221 

 

Figure 222 

 

5. Select the Split button in the 3D 

SKETCH>Edit group on the ribbon. 

 Click on two points on the second 

drawn, and longer, spline at 

approximately the length of the first 

spline. 

 Click OK to accept the Split. 

 

Figure 223 
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6. Exit 3D Sketch with the button in the top left corner. 

 7. Turn on the visibility for necessary surfaces. 

 

8. Select the MODEL>Edit>Trim Surface 

command on the ribbon. 

 Select the split spline in 3D Sketch4 as 

the Tool Entities, and Trim3 as the 

Target Entities. 

 Click the Next Stage button to 

continue. 

 Choose the correct Remaining Bodies. 

 Click the OK button. 

 

 

Figure 224 

 

 

Figure 225 

 

Figure 226 

 

9. Select the MODEL>Edit>Trim Surface 

command on the ribbon. 

 Select the other spline in 3D Sketch4 

as the Tool Entities, and Mesh Fit4 as 

the Target Entities. 

 Click the Next Stage button to 

continue. 

 Choose the correct Remaining Bodies. 

 Click the OK button. 

 
 

Figure 227 
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Figure 228 

 

Figure 229 

 10. Hide 3D Sketch4 and show all the side surfaces. 

 

11. Create a Surface Loft with the MODEL>Create Surface>Loft command to join the 

surfaces.  

 Select the Edge1 of Trim Surface5, and Edge2 of Trim Surface6 as the Profiles. 

 Set the Start Constraint and End Constraint to Tangency To Face.  This will 

apply tangency to the lofted surface where it connects to the original surfaces. 

 Place a check next to Merge Tangent Faces in the Options rollup.  

 Click the OK button to create the lofted surface. 

 

 

Figure 230 

 

Figure 231 

 

 
 

 

 

12. Click the Sew button in the MODEL > 

Edit group on the ribbon. 

 Select all the side surface bodies as 

the target Surface Bodies. 

 Click the Next Stage button to 

continue. 

 Check the previewed result and 

then click the OK button. 

 This step is only necessary if there are multiple side 
surfaces. 

 

 

Figure 232 
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13. Click the Environment Mapping 

button in the Accuracy Analyzer™. 

Check continuity of the surface bodies. 

 

Figure 233 

Combine Upper and Side bodies 

 

 
 
 

1. Turn on the visibility of the upper and side surfaces (Surface Loft1 and Surface Loft4). 

2. Select the MODEL>Edit>Trim Surface command on the ribbon. 

 Select the Loft1 and Loft4 as the Tool Entities. 

 Deselect the Target checkbox. 

 

 

Figure 234 

 

Figure 235 

 
 

 

 Click the Next Stage button to continue. 

 Choose the correct Remaining Bodies, as shown in the image below. 

 Click the OK button. 

 

 

Figure 236 

 

Figure 237 
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Add Fillet 

 

 
 
 

1. Add a rounded, fillet edge to the connection of the two surfaces.  Click the Fillet 

button in the MODEL > Edit group on the ribbon. 

 Change the method to Variable Fillet. 

 Select the edges between the two surfaces for the Entities, as shown in the image 

below. 

 

 

Figure 238 

 

Figure 239 

 
 
 

 

 Set R to 10-11mm for each edge. 

 These values can be directly edited by clicking them in the Profile view or in the graphic window. 

 Click the OK button. 

 

 

Figure 240 

 

Figure 241 
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Finishing Features 

 

 

 
 

1. Begin a 3D Sketch by Right-Clicking in space in the Model View, and select the 3D 

Sketch icon. 

2. Draw a spline along either side of the fillet with the Draw>Spline tool. 

 Draw the first spline at the edge of the Fillet1 surface body to the first seam. 

(Figure 242). 

 Draw a second spline below the crooked fillet (Figure 243). 

 

 

Figure 242 

 

Figure 243 

 

3. Click the Split button in the 3D 

SKETCH > Edit group on the ribbon.  

 Select a point on the top spline 

near where the side surface ends. 

 Click the OK button to accept the 

command. 

 

 

 

Figure 244 

 
4. Right-Click and select the Exit button to finish the 3D Sketch. 

 5. Hide the Mesh.  Show the Surface Body and 3D Sketch 5 only. 

 

6. Click the Split Face button in the MODEL>Body/Face group on the ribbon.  

 Select the split spline as the Tool Entities.   

 Select the upper surface face as the Target Entities, as shown in the image 

below.   

 Click OK button to accept the command. 

7. Repeat Step 6 using the lower spline and the side surface face. (Figure 246). 
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Figure 245 

 

Figure 246 

 

8. Remove the newly split area with the Delete Face command found in the 

MODEL>Body/Face group on the ribbon.  

 Select the Faces, as shown in Figure 247. 

 Click the OK button to remove the area between the splines. (Figure 248) 

 

 

Figure 247 

 

Figure 248 

 9. Hide 3D Sketch5. 

10. Create a Surface Loft with the MODEL>Create Surface>Loft. 

 Select Edge 1 and Edge 2 as the Profiles. 

 Apply the Start and End Constraint as Tangency To Face. 

 Select the small Edge 3 as the Guide Curve to create better connections with the 

surrounding surfaces. 

 Click the OK button and a lofted surface will be created. 
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Figure 249 

 

Figure 250 

 

Figure 251 

 11. Repeat all of the previous steps on the other side where the fillet becomes unsmooth.  

 3D Sketch on either side of the fillet with a spline to connect 

 Split Face of the surface using the 3D Sketch 

 Delete Face 

 Surface Loft 

 

 

Figure 252 – 3D Sketch 

 

Figure 253 – 3 Splines with Split Point 

 

 

Figure 254 – Split Face 

 

Figure 255 – Split Face 
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Figure 256 – Delete Face 

 

Figure 257 – Removed Face 

 

 

Figure 258 – Surface Loft 

 

Figure 259 – Finished Surface 

 

12. Sew the remaining surfaces together with the MODEL>Edit>Sew command. 

 Select all the surface bodies as the target Surface Bodies. 

 Click the Next Stage button to continue. 

 Check the previewed result and then click the OK button to accept. 

  The model has more surfaces created and joined the same way the lesson demonstrated. 

 Continue creating surfaces or move to the Advanced Modeling section. 
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Figure 260 

 

13. Click the Deviation for Body and the Environment Mapping buttons in the 

Accuracy Analyzer™. 

 

 

Figure 261 

 

Figure 262 

 
End of Activity 
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Advanced Modeling 

ACTIVITY: Hybrid modeling 

Objective 

Create a model by combination of automatic and parametric modeling. Hybrid modeling allows for quickly 
creating a model which has accuracy and parametric features. The resulting model is helpful for checking 
assembly and analyzing.   
 

Highlighted Commands 

 Global Remesh 

 Enhance Shape 

 Optimize Mesh 

 Auto Surface 

 Sketch 

 Extrude - Cut 

 

Training File 

09-Knuckle.stl 
 

Scan Setup 

 

1. Import training file 09-Knuckle.stl. 

 Click the Import button or select Import from Menu>Insert. 

 Use the Import Dialog to navigate to the training files folder. Choose Knuckle.stl 

from the Import dialog. 

 Click Import only. The file is loaded and displayed in the Model View. 

 

 

Figure 263 
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1. Select the Auto Segment command located in REGION tab. 

 The Auto Segment command can be activated by RMB context menu after selecting the mesh with a double 
click. 

 Set the Sensitivity to 10. 

 

 

Figure 264 

 
 Press the OK button to finish the Auto Segment. 

 

 

Figure 265 

 2. Click the Knuckle from Feature Tree and select Copy from MENU>Edit (Ctrl+C).  

 Click the OK button to copy the selected mesh data. 

 After editing a mesh to create a better Auto Surface, the original mesh will still be needed to show where cuts 
and features belong. 
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Figure 266 

  Select Paste from MENU>Edit (Ctrl+V) and paste the Copied Mesh in Feature 

Tree. 

 

 

Figure 267 

 

Edit and Optimize Mesh 

 1. Select Knuckle in Feature Tree to edit. 

 For a higher quality Auto Surface, details can be removed from the mesh and smoothed over.  The Copied 
Mesh can still be used to track these features and shapes to use for sketch based modeling. 

 When there are multiple meshes, a mesh needs to be selected before editing with the POLYGONS tab. 

 

2. Select Offset command located in POLYGONS>Edit group on the ribbon.  

 Create thickness beforehand to cut to plane. 

 Select ~8 regions while holding the Shift key (Figure 268). 
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Figure 268 

  Change the Distance to 1mm. 

 

 

Figure 269 

 
 Press the OK to finish the Offset. 

 

 

Figure 270 

 

3. Select Global Remesh command located in POLYGONS tab. 

 Recalculate the entire mesh to make watertight, and improve the mesh quality. 

 Verify the mesh is still selected in the Tree if the command is not available. 

 Change the Target Average Edge Length to 0.5mm. 

 Place a check next to Make Clean And Manifold Solid Mesh. 
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Figure 271 

 
 Press the OK check button and finish Global Remesh. 

 

 

Figure 272 

  It is easier to see the mesh quality without Regions.  Ctrl+2 will toggle Regions on and off. 

 Select Shaded With Edges (F8) from MENU>View>Mesh Display Mode to show the mesh edges. 

 
4. Select Enhance Shape command in POLYGONS>Optimize group on the ribbon. 

 Improve the quality of the mesh by sharpening corners and smoothing flat or rounded areas. 

 Change the options like the figure below. 

 

 

Figure 273 

 
 Press the OK check button and finish Enhance Shape. 
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5. Select Optimize Mesh command located in POLYGONS>Optimize>Global Remesh 

dropdown. 

 Optimizes a mesh based on its feature shapes and improves the quality of the mesh. This command also offers 
advanced options to control the size of poly-faces and the effects of smoothing a model. 

 Change the Method to High Quality Mesh Conversion. 

 

 

Figure 274 

 
 Press the OK check to finish Optimize Mesh. 

 

 

Figure 275 
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Create Solid Body 

 

1. Select the Auto Surface command located in SURFACING tab. 

 Select Knuckle for Mesh and click Organic button. 

 

 

Figure 276 

 
 Press the OK check button and finish Optimize Mesh. 

 

 

Figure 277 

Create Cutting Planes 

Create reference planes which are used as base sketch. These planes should be located at original mesh not on 
offset mesh. 

 1. Click Copied Mesh in Feature Tree. 

 Hide the visibility of the Mesh Knuckle. 

 

 Select the Auto Segment command located in REGION tab. 

 Use the previous settings. 

 
 Press the OK check button and finish Auto Segment. 
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Figure 278 

 

 

2. Select the Plane command located in MODEL>Ref. Geometry tab and group. 

 Select the Don’t Quit Command With OK Lock button to remain in the command 

after accepting. 

 Select both the regions like the figure below.  

 Verify the Method is set to Average. 

 Press the OK check button. 

 

 

Figure 279 

 

Figure 280 

 3. Immediately create a new Plane. 

 Select the region as shown Figure 281 below.  

 Press the OK check button.   

 

 

Figure 281 

 

Figure 282 
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 4. Select the region shown in Figure 283. 

 Press the OK check button. 

 

 

Figure 283 

 

Figure 284 

 5. Select the region like Figure 285. 

  Click the OK check button. 

 

 

Figure 285 

 

Figure 286 

 6. Select the region like Figure 287. 

  Click the OK check button. 

 

 

Figure 287 

 

Figure 288 
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 7. Select the region like Figure 289. 

  Click the OK check button to create the sixth plane. 

 

 

Figure 289 

 

Figure 290 

 
 Press the Cancel button and finish the Plane command. 

 

Create Sketches 

 1. Create sketches to cut off redundant parts from solid model for machining. 

 Click Knuckle in Feature Tree. 

 
 
 
 
 

 

2. Select Mesh Sketch command in 

Setup group located in SKETCH tab. 

 Select Plane1 for Base Plane and 

press the OK check button.  

 Draw a sketch similar to Figure 291. 

 Press the EXIT button and finish the 

Mesh Sketch. 

 

Figure 291 

 
 
 
 
 
 

 
 
 

3. Click Knuckle in Feature Tree and select 

Mesh Sketch in the SKETCH>Setup tab. 

 Select Plane2 for Base Plane and 

press the OK check button. 

 

4. Draw circular sketch line like the figure. 

 Press the Exit button and finish Mesh 

Sketch. 

  

Figure 292 
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5. Click Knuckle in the Feature Tree then 

select Mesh Sketch command in 

SKETCH>Setup group. 

 Select Plane3 for Base Plane and 

press the OK check button. 

 Draw sketch similar to shown in 

Figure 293. 

 

Figure 293 

 
 Press the EXIT button and finish Mesh Sketch. 

 

6. Click Knuckle in the Feature Tree then 

select Mesh Sketch command in 

SKETCH>Setup group. 

 Select Plane4 for Base Plane and 

press the OK check button. 

 Draw sketch line like the figure. 

 

Figure 294 

 
 Press the EXIT button and finish Mesh Sketch. 
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7. Click Knuckle in the Feature Tree then 

select Mesh Sketch command in 

SKETCH>Setup group. 

 Select Plane5 for Base Plane and 

press the OK check button. 

 Draw sketch line like the figure. 

 Press the EXIT button and finish 

Mesh Sketch. 

 

Figure 295 

 
 
 
 
 
 

 

8. Click Knuckle in the Feature Tree then 

select Mesh Sketch command in 

SKETCH>Setup group. 

 Select Plane6 for Base Plane and 

press the OK check button. 

 Draw sketch line like the figure. 

 Press the EXIT button and finish 

Mesh Sketch. 

 

Figure 296 

 9. Show only Solid Bodies and Sketches in the Model View. 

 

 

Figure 297 
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Cut Solid Body by Extruding Sketches 

 

1. Extrude each sketch with the MODEL>Create Solid>Extrude command to cut the 

Solid Body. 

  Select Sketch1 (Mesh) for Base Sketch. 

 Set the Method to Blind with a Length of 20 mm. 

 Place a check in the Cut box in Result Operator. 

 

 

Figure 298 

  Press the OK check button and finish Extrude. 

 

 

Figure 299 

 

Figure 300 

 

 

 Repeat operation to cut the body.  

2. Select the Extrude command. 

 Use Ctrl+Space bar to execute previous command. 

 Select Sketch2 (Mesh) for Base Sketch. 

 Place a check in the Cut box in Result Operator. 

 Press the OK check button.  
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Figure 301 

 

Figure 302 

 

3. Select the Extrude command. 

 Select Sketch3 (Mesh) for Base Sketch. 

 Place a check in the Cut box in Result Operator. 

 Press the OK check button. 

 

 

Figure 303 

 

Figure 304 

 

4. Select Sketch4 (Mesh) in the Feature Tree, then Right-Click in space and select the 

Extrude (Solid) icon. 

 Place a check in the Cut box in Result Operator. 

 Press the OK check button. 

 

 

Figure 305 

 

Figure 306 
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5. Select the Extrude command with any method. 

 Select Sketch5 (Mesh) for Base Sketch. 

 Place a check in the Cut box in Result Operator. 

 Press the OK check button. 

 

 

Figure 307 

 

Figure 308 

 

6. Select the Extrude command with any method. 

 Select Sketch6 (Mesh) for Base Sketch. 

 Place a check in the Cut box in Result Operator. 

 Press the OK check button. 

 

 

Figure 309 

 

Figure 310 

Make a Hole for Assembly 

 
1. Select the Vector command located in MODEL>Ref. Geometry tab. 

 Create the axis of the Cylinder. 

 Select Top plane and Right plane for Entities and create a vector which will 

intersect both Planes. 
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Figure 311 

 

 

 Press the OK check button and finish Vector.  

2. Click Copied Mesh in Feature Tree. 

3. Right-Click in space, then select the Mesh Sketch icon. 

 Select Right plane for Base Plane.  

 Click the Apply check button. 

 Draw sketch line as shown in Figure 312. 

 

 

Figure 312 

 

 

 Press the EXIT button and finish Mesh Sketch. 

4. Select the Revolve command from Create Solid group located in MODEL tab. 

 Select Sketch7 (Mesh) for Base Sketch,  

 Select Vector1 for Axis. 

 Select the Cut check box in Result Operator. 
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Figure 313 

 
 Press the OK check button and finish Revolve. 

 

 

Figure 314 

 

 

End of Activity 

 

 

 
 
 
 
 



  

 

2016 3D Systems 117 Geomagic Design X 2016 

 

ACTIVITY: Impeller Workflow 

Objective 

Create an impeller using surfacing and solid tools.   
 

Highlighted Commands 

 Revolving Silhouette Mesh Sketch Setup 

 Loft Wizard 

 

Training File 

10-Impeller.stl 
 

Scan Preparation 

 

1. Import training file 10-Impeller.stl. 

 Click the Import button or select Import from Menu>Insert. 

 Use the Import Dialog to navigate to the training files folder. Choose Impeller.stl 

from the Import dialog. 

 Click Import only. The file is loaded and displayed in the Model View. 

 

 

Figure 315 

 

 

2. In the POLYGON tab, use the Fill Holes and Smart Brush command to clean and 

smooth a single vane of the impeller. 

 Assuming all blades are the same, only one will need to be edited for the modeling.  The single modeled vane 
can be patterned. 

 With the Repair Holes/Boss>Fill Holes command, select all the holes on one vane 

to fill in with Curvature. 

 Use the Wizard>Smart Brush command and the Smooth option to paint the 

specific areas that are rough. 
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Figure 316 

 

Figure 317 

 
3. In the Tree dock, change the tab to 

Viewpoint. 

 Orient the part to focus on the edited vane. 

 Select the Add Viewpoint button to save 

the view. 

 Toggle back to the Tree dock. 

 The Viewpoint can be saved for later use to be able to 
quickly move back to the edited vane. 

 

Figure 318 

 
4. After editing the mesh, use the Optimize>Decimate command to reduce the triangle 

count. 

 Select the Allowable Deviation method with a value of 0.01 mm in the Options. 

 Accept the command to see the new triangle count. 

 

 

Figure 319 
 

Figure 320 
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5. Select the Auto Segment command 

located in REGION tab. 

 Set the Sensitivity to 5 then accept. 

6. Use the Edit>Merge command to merge 

the the regions on either side of the 

cleaned vane. 

 Hold Shift and select the multiple 

regions on a single face. 

 The Merge button is now active. 

Select. 

 Repeat process on other side face of 

vane. 

 

Figure 321 

 

Align To Coordinate System 

 
1. Create Ref. Geometry>Vector to 

more accurately align the scan. 

 Select the Revolving Axis method. 

 Select all regions where the central 

axis would be the same as the center 

of the impeller. 

 Preview and then Accept the Vector. 

 

Figure 322 

 
2. Align the scan to the coordinate system using ALIGNMENT>Scan to 

Global>Interactive Alignment. 

 Verify the mesh is selected then go to the Next Stage. 

 Change the Method to XYZ. 

 For Position, select the Vector1 and a Plane Region on the bottom of the scan. 

 Set Axis Z to Vector1. If needed, Flip Direction of the positive axis. 

 Use the Blue Circle of the Manipulator to clock the part about the Z Axis.  Rotate 

until the X Axis (Right Plane) is passing through the edited vane. 

 Check the alignment is in position on the right half of the screen then Accept. 



  

 

2016 3D Systems 120 Geomagic Design X 2016 

 

 

 

Figure 323 

 

Figure 324 

 

Main Body 

 
1. Create a Mesh Sketch on the Right Plane. 

 Change the method to Rotational Method. 

 Use the Offset Angle From Base Plane or the Green Circle to rotate the base 

plane to find the best sketch angle for the main body of the impeller. 

 Accept the sketch setup. 

 

 

Figure 325 

 2. Sketch the inner profile shown in Figure 326. 

 Use Arc and Line tools to create a sketch of the inside profile of the impeller. 

 Exit the sketch when finished. 

 The bottom post is not rotational and does not need to be sketched. 



  

 

2016 3D Systems 121 Geomagic Design X 2016 

 

 

 

Figure 326 

 
3. Create the body with Create Solid>Revolve. 

 Set the previous sketch as the Base Sketch and Profile. 

 Select the Centerline of the Sketch as the Axis. 

 Accept the command. 

 

 

Figure 327 

 

Figure 328 

 

Vane 

 
 
 
 

 

1. Create a surface on either side of the cleaned vane with a Loft Wizard or Mesh Fit 

command. 

Option 1 

 RMB on the region of one side of the cleaned vane scan and choose the Loft Wizard 

icon. 

 In Section, select By No. Of Sections, then set the No. Of Sections to 7, and 

increase the smoothness. 

 In Profile Types, select Ref. Planes and Mesh Sketches. 



  

 

2016 3D Systems 122 Geomagic Design X 2016 

 

 Adjust the size of the bounding box of the surface with the red, green, and blue dots 

to be much larger than the mesh, then go to the Next Stage. 

 Turn on the Deviation From Body. 

 LMB and hold on the planes to readjust the position of the planes. 

 Ctrl+LMB on a plane will add a new plane.  Readjust the planes to reach the desired 

accuracy then accept the command. 

 

 

Figure 329 

 

Figure 330 

 
 

 

Option 2 

 RMB on the region of one side of the cleaned vane scan and choose the Mesh Fit 

icon. 

 Make any desired adjustments to the settings, or press the OK button to accept the 

command. 

 

 

Figure 331 

 

Figure 332 
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 2. Repeat either option on the other side of the vane. 

3. Edit any sketches created by the Loft Wizard to smooth and better the surface. 

 RMB on Sketch 5(Mesh), or any other sketch created by the loft wizard, and 

choose Edit. 

 Select the generated spline.   

 In the Rebuild Spline>No. Of Interp. Pts box, enter 20 then press Enter. 

 Look at the spline, then edit the value again but to 10.  

 

 

Figure 333 

 

Figure 334 

  Exit the sketch to see how much smoother the surface is in one spot. 

4. Repeat Step 3 on the other sketches as desired. 

 Reducing the spline points is one way to edit the loft wizard to change the resulting surface. 

 Other ways could be to completely remove the spline and remake the sketch using lines and arcs.  

 

 

Figure 335- Original Surface 

 

Figure 336- Edited Surface 

 
5. Create a Mesh Sketch on the Right Plane to capture the outer profile of the vane. 

 Change the option to Rotational Method for the sketch setup. 

 Pull the Green Arrow or change the Silhouette Range to encompass the entire 

cleaned vane, then accept the command. 

 The Rotational Silhouette Range will create a wedge to contain the desired area, and then project by rotating 
about an axis. 

 The Offset Angle can also be adjusted for a better cross section. 

 Create the sketch of the outside vane profile using Line and Arc tools. 

 Use Figure 338 to create the sketch then Exit. 
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 An open profile sketch can be used only for surfaces.  Close the sketch to create a solid revolve. 

 

 

Figure 337 

 

Figure 338 

 
6. Use the Create Surface>Revolve to revolve the surface the necessary amout to 

enclose the surfaced vane. 

  The Sihlouette command will place 
the sketch near the vane or on the 
opposite side of the impeller. 

 A small rotation in both directions 
could be needed, or a large rotation 
to encompass the entire vane. 

 

Figure 339 

 
7. Create an Edit>Surface Offset of the original rotated body to completely enclose an 

impeller vane. 

 Select all faces along the top of the solid. 

 Change the Offset Distance to 0 mm then accept. 

 An offset at 0 is duplicating and creating a surface on the solid face to use in more commands. 
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Figure 340  

Figure 341– Enclosed Vane 

 
8. Select MENU>Insert>Surface>Solidify to create a solid from the selected surfaces. 

 Select the four surface bodies needed to enclose a vane and accept the command. 

 If an error occurs or a surface does not extend fully through the other surfaces, use the Extend Surface tool to 
lengthen the surface before repeating the Solidify command. 

 Check the Visibility of the Solid Bodies is on to view the main body and single vane. 

 
9. Use the MODEL>Edit>Fillet command to place a small fillet on the top edges of the 

vane. 

 

 

Figure 342 

 

Figure 343 
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10. Select Pattern>Circular Pattern to create 

the remaining vanes. 

 Choose the Vane as the Bodies. 

 Select Vector1 as the Rotation Axis. 

 Set the No. Of Instances to 16. 

 

Figure 344 

 

Edits and Shaft 

 
1. Merge all solid bodies to one body with the Edit>Boolean command. 

 Set the Operation Method to Merge. 

 Select all 17 solid bodies as the Tool Bodies then accept to have a single solid body 

remaining. 

 
2. Create the lower shaft using a Mesh Sketch on the Front Plane or any plane normal 

to the shaft. 

 Offset the Offset Distance From Base Plane to cross through the triangular shaft 

and accept the set up. 

 Use Arc and Fillet tools to create the sketch then Exit when completed. 

 

 

Figure 345 

 

Figure 346 
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3. Create Solid>Extrude the 

sketch to create and merge the 

shaft. 

 Use the Up to Region 

method with the Max 

Position sub method. 

 Select the lower region of the 

scan shaft. 

 Check the Merge option is 

selected under Result 

Operator, then Accept. 

 

Figure 347 

 
4. Create a Mesh Sketch on the top face of the shaft to cut out the top hole. 

 Select the top solid face as the Base Plane. 

 Offset the sketch profile down slightly to see the inside circle then accept the Mesh 

Sketch Setup. 

 Sketch the inside Circle then Exit the sketch to cut out the hole. 

 

 

Figure 348 

 

Figure 349 
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5. Cut out the hole with the Create 

Solid>Extrude command. 

 Set the Method to Blind and cut 

down about 25 mm in to the mesh.  

 Set the Result Operator to Cut. 

 Accept the command. 

 

Figure 350 

 6. Repeat process for lower hole in shaft. 

 

Figure 351 

 
7. Add Fillets where needed on the model. 

 

 

Figure 352 

 

Figure 353 

 
End of Activity 
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Exact Surfacing  
Exact Surfacing is a workflow designated to create a very accurate surface on a complex scan.  The new 
SURFACING toolbar walks through the steps needed to create a good patch network to generate the surfaces. 
 
The Create/Edit Patch Network group in the SURFACING tab has all the tools needed to create the surface. 
 

Step 1: Extract Contour Curves –Detect 
and automatically extract 3D contour 
curves for the area of high curvature on 
a mesh.  
These curves can be edited and adjusted 
manually to create a better Patch 
Layout. 

 

Figure 354 

Step 2: Construct Patch Network – 
Automatically construct the patch network 
within the patch layout. 

 

Figure 355 

Step 3: Shuffle Patch Groups – Reorient 
the patches within the panels in a 3D 
patch network for better continuity. 

 

Figure 356 

Step 4: Fit Surface Patches- Create NURBS 

surfaces inside each patch of the 3D patch 
network.  An accurate freeform surface body 
will be created. 

 

Figure 357 

 
 
 
 
 
 
 
 



  

 

2016 3D Systems 130 Geomagic Design X 2016 

 

ACTIVITY: Exact surface  

Objective 

Learn about exact surfacing. 
This exercise converts a polygon object to an exact surfaces object and activities the remainder of the exact 
surfaces tab. This workflow generates surfaces match the object exactly as it is constructed. 
 

Highlighted Commands 

 Extract Contour curves 

 3D curves 

 Construct Patch Network 

 Shuffle Patch Groups 

 Fit Surface Patches 

 

Training File 

12-Exact Surface.xrl 
 

Import file 

 

1. Open training file 11-Exact Surface.xrl 

 Click the Open button or select Open from Menu>File>Open. 

 Use the Open Dialog to navigate to the training files folder. Choose 11-Exact 

Surface.xrl from the Open dialog. 

 Click Open. The file is loaded and displayed in the Model View. 

 

 

Figure 358 
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Extract counter network 

 1. Go to the SURFACING tab to begin the Exact Surfacing workflow. the Extract Contour 

Curves and set the curvature Sensitivity Potion to 60 and then click to next stage  

 Select the Extract Contour Curves command in the Create/Edit Patch Network 

group. 

 Set the Curvature Sensitivity Position to 60 then select the Next Stage button. 

 The Extract Contour Curves command automatically places red separators between regions of relative 
flatness.  The Next Stage allows adjustment of those region separators and then places 3D contour lines inside 
the regions. 

 

 

Figure 359 

 

Figure 360 

 2. In the Next Stage, click the Enable Real Time Preview option to have live feedback 

of the editing of the separators. 

 Use the Paint Brush Selection Mode to add, remove, and clean regions. 

 Best practice will be to extend all separator regions to a scan boundary, similar to Figure 457. 

 Edit the Contour Curves regions as shown in Figure 362. 

 Hold Ctrl when selecting to remove separator regions. 

 Other selection modes, such as the Line, Rectangle, and Circle can be used to edit separators. 

 

 

Figure 361 - Before Editing 

 

Figure 362 - After Editing 
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Figure 363 – Edited Separators 

 

Edit Contour Curves on a Mesh  

 1. The generated contour curves are now a 3D Sketch. Go to the 3D SKETCH tab to edit. 

 Select all of the Contour Curves by pressing Ctrl+A or box selecting the part. 

 In the ribbon, find the Rebuild Toolbar.  Change the value of No. of Interp. Pts to 

10 then click the OK button. 

 Each curve will now have 10 points; therefore, the contour curves are more easily controlled. 

 

 

Figure 364 

 

Figure 365 

 2. Select a junction point on the contour curves and swing the point back and forth so 

that the connected curves are smoothed. 

3. Adjust all contour curves to be continuous and four sided.  The Edit>Trim tool can 

remove extra segments. 
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Figure 366 - Before Editing 

 

Figure 367 - After Editing 

 4. Select all of the Contour Curves and Rebuild them again. 

 In the ribbon, find the Rebuild Toolbar.  Change the value of No. of Interp. Pts to 

20 then click the OK button. 

5. Verify all lines are straight and the patches seem continous. 

 Each of these four sided figures is a panel.  The panels will dictate the layout of the patch network. 

 

 

Figure 368 

Constructing a 3D Patch Network 

 

1. Allow the software to automatically construct a patch network from the panels created 

previously with the Construct Patch Network step.  This is found in the 

Create/Edit Patch Network group. 

 Note that Construct Patch Network command can be found in the 3D SKETCHING and the SURFACING tabs.  In 
both of these tabs, the command is located within the same group. 

 

Figure 369 

 Choose Auto Estimate option then Accept.  
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Figure 370 

 

Edit 3D Patch Network 

 1. In the 3D SKETCH or SURFACING tab, choose the Create/Edit Patch 

Network>Shuffle Patch Groups command. 

 Click on a panel as shown in the Figure 371. 

2. Select Add/Del 2 Paths in the Action roll up, and select the Auto Fill Neighboring 

Panels option in the More Option roll up. 

 The Auto Fill will match the number of paths in the adjacent panel when paths are added or removed.  

  Select a point along the lower side of the panel to increase the number of paths 

along the edge until the edges match. 

 To decrease the number of paths in a panel, hold Ctrl when clicking on the panel edge. 

 

 

Figure 371 

 

Figure 372 

 3. Click the Deselect Current Planel next to Action in the top roll up to clear the 

previous selection and make choose a new panel to edit. 

 In the More Option roll up, click the Next arrows to navigate through patch panels 

and find the ones needing rearranging. 

4. Select a panel that needs to be shuffled and repeat steps 2 and 3 until all panels have 

equal patch sides. 

 While the define option is selected in Action, check the vertices of each panel is properly placed in each corner 
of the panel.  If not, click the vertex to redefine and Accept. 
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Figure 373 

 

Create a NURBS Surface 

 1. In the SURFACING tab, choose the Fit 

Surface>Fit Surface Patches 

command. 

 Select the 3D Sketch1(Mesh) as 

the Mesh Curves base. 

 Select the Adaptive option as 

Fitting Method. 
  

Figure 374 

  Adjust the slider of the Geometry 

Capture Accuracy option to one 

notch away from Max to improve the 

accuracy of the fitting surface 

patches. 

 

Figure 375 
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Figure 376 

 
End of Activity 
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ACTIVITY: Self Exercise 

Objective 

Create a propeller using the skills learned throughout the training course. 
 

Highlighted Commands 

 Interactive Alignment 

 Mesh Sketch – Silhouette 

 Loft Wizard/Mesh Fit 

 Revolve 

Training File 

12-SelfExercise.stl 
 

 
Figure 377 

 

 
Figure 378 

 
End of Activity 
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Appendix I – Mouse and Keyboard Control 

Mouse Control 

The default Right-Hand Mouse is shown. 

 

LMB 

 Selection Button 

o Change tabs in ribbon 

o Activate commands 

o Select and activate entities 

o Make individual or box selections 

 

MMB 

 Scroll Wheel 

o Zoom in and out of center of screen.  Roll the 
mouse up and away to increase magnification; 
roll the mouse down to decrease magnification. 

 Toggle Button 

o Activate second level of mouse buttons. Most 
buttons will rotate the part. 

 

RMB 

 Rotate Button 

o Hold to rotate the view of the part about the 
center of the screen. 

 Context Menu 

o Activate common commands based on the entity 
selected. 

o Accept and Exit Commands 

 

 

 

LMB and RMB 

 Pan 

o Move the part laterally on the screen. 
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Shortcut Keys 

Listed in the table are the commonly used default Shortcut Keys.  These shortcut keys will allow quicker access to 
certain functions quickly without selecting the function from the Tool Bar. 
 

Command Shortcut Key 
Menu  

New Ctrl+N 

Open Ctrl+O 

Save Ctrl+S 

Select All Ctrl+A, Shift+A 

Select Inverse Shift+I 

Undo Ctrl+Z 

Redo Ctrl+Y 

Repeat Last Command Ctrl+Space 

View  

Zoom Fit Ctrl+F 

Meshes Visibility Ctrl+1 

Regions Visibility Ctrl+2 

Point Cloud Visibility Ctrl+3 

Surface Bodies Visibility Ctrl+4 

Solid Bodies Visibility Ctrl+5 

Sketches Visibility Ctrl+6 

3D Sketches Visibility Ctrl+7 

Ref. Points Visibility Ctrl+8 

Ref. Vectors Visibility Ctrl+9 

Ref. Planes Visibility Ctrl+0 

Normal To Ctrl+Shift+A 
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Appendix II - Mesh Editing 

ACTIVITY: Mirroring scans 

Objective 

This training course is designed to show how to mirror half a scan and edit the mesh of a bottle scan to prepare it 
for either 3D printing or modeling. 

 

Highlighted Commands 

 Mirror 

 Thicken 

Training File 

Bottle.stl 
 

Import Scan Data 

1. Import the Scan Data found at: 

 (~/Appendix/Bottle.stl) 

 

Figure 379 

 

Add a Reference Plane 

1. Hold down the Ctrl button and click-drag the Right plane to the neck of the bottle by 

105mm. 

 

Figure 380 
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2. Click the Visibility icon next to the Top Plane and Right Plane entities in the Model View 

to hide them, leaving on the Front Plane and Plane1 visible. 

                        

                                           Figure 381                                                                             Figure 382 

 
            

 

Splitting the Mesh 

1. Click the POLYGONS>Edit>Split button in the ribbon.  

 Select the By Entity method. 

 Choose Plane1 as the Tool Entity.  

 Do not use the Cap Section Ends option and toggle the Don’t Quit Command With 

OK button to turn it off.  

 

Figure 383 

 

2. Click the Next Stage button. 

 

3. Select the region to remain and click the OK button.  

 Make sure to select the larger section of the bottle and de-select the smaller section.  
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                                                        Figure 384                                                         Figure 385 

 

Mirror and Thicken 

1. Click the Mirror button in the MENU>Tools>Mesh Tools>Mirror option.  

 Select the Front base plane as the Position.  

 Enable the Trim & Merge with the Remesh Poly-Faces Around Mirror Plane option 

enabled. 

       

                                                Figure 386                                                       Figure 387 

 

2. Click the OK button. The mesh will be identically mirrored across the Front base plane. 

         

Figure 388                                                Figure 389 

 

3. Click the POLYGONS >Edit>Thicken button on the ribbon. This command creates a 

constant thickness along the walls of the model.  

 Choose the Surface method, set the Thickness to 2mm and choose the Direction2 

option. 
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                                         Figure 390                                                         Figure 391 

 

4. Click the OK button and the mesh will now have a thickness of 2mm. 

            

Figure 392                                                      Figure 393 

 

5. The mesh of the bottle is now complete and thickened and ready for the modeling process. 

 

Figure 394 

 
End of Activity 
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ACTIVITY: Global Mesh Enhancing 

Objective 

This training course is designed to show how to optimize and enhance messy scan data. 

Highlighted Commands 

 Optimize Group 

 Decimate 

 Enhance Shape 

Training File 

Grasshopper.stl 
 

Import  
1. Import the Scan Data found at: 

 (~/Appendix/Grasshopper.stl) 

 

Figure 395 

Hide Reference Planes 

1. In this training the Ref. Planes will not be utilized, so they can be hidden from the Model 

View by pressing the Ctrl + 0 keyboard shortcut or by clicking the visibility icon next to the 

Ref. Planes entity in the Model Tree. 

                                                                                      

                                                                                            Figure 396 

Change Mesh Color 

1. Click the Right Mouse Button (RMB) on the Grasshopper entity in the Model Tree and 

select Properties from the pop-up menu if it is not already visibile on the right side toolbar. 

                                                               

                                                                                          Figure 397 
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 Click the Material option in the Appearance options.  

 Change the color to the green material.  

    

Figure 398 

 

3. Click the OK button. The color of the mesh material for the model will change to green. 

 

Figure 399 

 

 Changing the color of the mesh is used to help in recognizing the mesh in the application. It does not change the 
color information of the mesh file. 

 

Global Remesh 

1. Click the Global Remesh button in the POLYGONS>Optimize group.  

 Set the Edge Length Multiplier to 1 to create similar edge lengths for the entire 

model.  

 Enable the Make Clean And Manifold Mesh option to generate a clean and closed 

mesh. 

 

Figure 400 
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 Click the OK button.  

 The mesh will now be globally remeshed by regenerating mesh structures and removing defects from the curvature flow 
of the mesh.  All poly-faces will be remeshed to have the same edge length, resulting in a more uniform mesh. 

           

Figure 401 – Before Remesh                            Figure 402 – After Remesh 

Decimating the Mesh 

Show Edge 

1. Enable the Edge option under the Mesh section in the Display tab, or press the F8 key on 

the keyboard. 

 

Figure 403 

Decimate 

1. Click the Decimate button in the POLYGONS>Optimize group.  

 Click the Don’t Quit Command With OK button to continuously use the comm and 

without exiting it.  

 Set the Reduction Ratio to 70%.  

 Click the OK button to apply the command without exiting it. 

 

Figure 404 
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2. Apply the command again by clicking the OK button, then click the Cancel button.  

 The mesh will be reduced by 70% again to further reduce the poly-face count. 

                  

Figure 405                                                   Figure 406 

Optimize Mesh 
1. Click the Optimize Mesh button in the POLYGONS>Optimize>Global Remesh dropdown 

group.  

 Select the High Quality Mesh Conversion Method.  

 Set the Min Edge Length Multiplier to 0.5 and the Max Edge Length Multiplier to 8. 

 

 

Figure 407 

 This method creates regular sized triangles from the original mesh by generating more triangles in high curvature 
regions and fewer triangles in low curvature regions.  

 

2. Click the OK button. The mesh will now be optimized. 

                 

Figure 408                                                               Figure 409 
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Enhance Shape 

1. Click the Enhance Shape button in the POLYGONS>Optimize group.  

 Change the Overall Smoothness to Mid and the Enhance Level setting to Max. 

 

Figure 410 

 

2. Click the OK button. Areas of high curvature will become sharper than the original shape. 

Apply this command again with the same options to emphasis sharper areas even more. 

 

Smooth 

1. Click the Smooth button in the POLYGONS>Optimize group.   

 Change the Smoothness Level to Max.  

 

Figure 411 

 

2. Click the OK button. The mesh will be smoother globally. 

                  

Figure 412                                                   Figure 413 

 

 

End of Activity 

Geomagic Design X 
Training 
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ACTIVITY: Mesh Editing 

Objective 

This training course is designed to show how to edit the mesh of a phone scan to prepare it for the modeling 
process. 
 

Highlighted Commands  

 Defeature 

 Fill Holes 

 Edit Boundaries 

 Healing Wizard 

Training File 

Phone.stl 
 

Import Scan Data 

1. Import the Scan Data found at: 

(~/Appendix/Phone.stl) 

 

Figure 414 

Defeature 

1. Click the Defeature button in the POLYGONS>Repair Holes/Boss group.  

 Click-drag and release around an area near the top of the phone as shown in the image 

below.  

    

Figure 415 

 

 The defeature command is useful for models where small irregular features exist that may hinder the modeling 
process. 
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2. Click the OK button. The feature will be removed. 

 

Figure 416 

Fill Holes 

1. Click the Fill Holes button in the POLYGONS>Repair Holes/Boss group.  

 Toggle on the Don’t Quit Command With OK button to continuously use the 

command without exiting it.  

 Select the microphone hole boundary on the bottom of the phone (Figure 417) using 

the default settings. 

 Click the OK button.  

                     

Figure 417                                                             Figure 418 

 

Add Bridge 

1. Click the Add Bridge button in the Editing Tools. 

 Click on hold the LMB on the edge of one triangle on one side of the gap seen below. 

 Drag the mouse to the other side and release one an edge is highlighted. 

                 

Figure 419 

 

 Adding bridges is useful for filling in complicated holes or boundary areas that are irregular in shape. 
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2. Click the Boundaries button and  

 Select the boundary created by the bridge shown in Figure 420.  

 Toggle off the Don’t Quit Command With OK button to disable it and then click the 

OK button to complete the command. 

                     

Figure 420                                                         Figure 421 

Edit Boundaries 

1. Click the Edit Boundaries button in the POLYGONS>Edit group. This command enhances 

boundary shapes on a mesh.  

 Toggle on the Don’t Quit Command With OK button. 

 Select the Fit method and change the Fit Option to Circle.  

 Select the largest circular boundary in the middle of the model shown in Figure 423. 

 

             Figure 422                                             Figure 423                                                            Figure 424 

 Click the OK button. The boundary will be changed to a circle. 

 

2. Change the Method to Smooth and select the outer boundary of the mesh. Set the Select 

N-Depth Boundary to 3. 
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Figure 425 

 

 Click the OK button. The boundary will be smoothed by 3 poly-faces from the original 

boundary. 

3. Click the Cancel to exit. 

 

                               

Figure 426                                                               Figure 427 

Healing Wizard 

 

The wizard will remove unwanted and irregular poly-faces using an automated wizard process. 
 

Remove Dangling Poly-Faces 

1. To remove any remaining dangling poly-faces on the mesh boundary, click the Healing 

Wizard button in the POLYGONS>Wizard group.  

 De-select all options except for the Dangling Poly-Faces option.  

 

Figure 428 
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Figure 429 

 

2. Click the OK button. The dangling poly faces on the mesh will be removed. 

                 

Figure 430 

 

 

 Dangling Poly-Faces are edges that are not connected to neighboring poly-faces. 

 
                  2 Sides Open                                     3 Sides Open 

 

 

 
End of Activity 
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Appendix III – Additional Models 

ACTIVITY: Iterative modeling 

Objective 

Reinforce common skills, such as importing scan data, region segmentation and editing, and 2D sketching and 
basic modeling concepts to create a parametric model.  Reverse model a casting and iterate the model to the 
desired result by modifying the parametric features. 

Highlighted Commands and Concepts 

 Mesh Sketch Setup (Advanced) 

 Convert Entities 

 Iterative Modeling 

Training File 

A1-Iterative Model.stl 
 

Scan Setup 

 

1. Import training file A1-Iterative 

Model.stl. 

 The model is not a complete scan, but all the 
information required to model is available. 

 

Figure 431 

 

 
 
 

 

2. In the REGION tab, select the Auto 

Segment command. 

 Set the Sensitivity to 65. 

 Click the OK checkmark to accept. 

3. Switch to the Geometry Type Display 

Mode from the Upper-Side Toolbar. 

 Each specific geometry will have a specific assigned 
color. For example, all Planes will be blue. 

 

Figure 432 
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Method 1: Extracting Geometry 

 

 
 

 

1. While still in the REGION tab, 

Hold Ctrl and select all three 

regions of the curved top face. 

 Select the Edit>Merge 

command to merge the 

regions. 

 Certain commands in the extracting 
geometry workflow require the selection of 
a single region. 

 

Figure 433 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Use the Extrusion Wizard to quickly create a base body. 

 RMB click on the recently merged region and select Insert/Merge. 

 Click the Select None next to Sides then Top. 

3. The automatically selected regions were not appropriate for the desired outcome. 

 For Top, select the Freeform, merged region on the mesh, and for the Bottom 

select the Ref. Plane Front plane. 

 For Sides, select the three Plane walls. 

 Set the Custom Extrusion Direction to the Ref. Plane Front to be able to select 

Fix Sketch Plane With Selection. 

 The extracted 2D Sketch for the upcoming Extrusion will be placed on the Front Plane. 

 Uncheck the Draft Angle option. 

 

Figure 434 

 

Figure 435 
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4. Select the Next Stage arrow to view and edit the generated sketch and extrusion. 

 Slide the Resolution slide bar all the way to Min to avoid the noise of the scan data 

in the final sketch.  It should appear as a rectangle. 

 Set the Geometry Capture Accuracy all the way to Loose to allow for constraint 

(Perpendicular, Tangent, etc.) entities to be assigned to the sketch. 

 Accept the Extrusion Wizard as long as the created body is previewed. 

 

Figure 436 

 5. RMB click on the Sketch1(Mesh) that has been created in the Feature Tree, and 

select Edit. 

 Wizard parameterscannot be edited after acceptance because editable, parametric features are created in the 
Feature Tree. 

 Select the Front Viewpoint from the Upper-Side Toolbar. 

 Adjust the right-most line to better fit the model. 

 Exit the sketch to re-extrude the base. 

 

 

Figure 437 

 

Figure 438 
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6. Inspect the quality of the surface by checking different Surface Analyzing Modes. 

 From the Upper-Side Toolbar, or Accuracy Analyzer dock, select Deviation For 

Body. The majority of the surface is green so within our desired tolerance. 

 Change the option to Iso Line.  This will show the curvature of the freeform surface. 

 Although this is a quick way of extracting the actual situation of the scan data, it is not always 
the desired method.  The top, freeform surface is not editable in CAD.  The surface is not easily 
reusable because its flow cannot be controlled by the user. 

 

 

Figure 439 

 

Figure 440 

 

Method 2: Creating Geometry 

 Looking and investigating the nature of the top surface, it is a surface that consists of two differently tilted 
areas that are blended between. 

Do not delete or undo the previous body.  It can still be utilized in the next method. 

 

1. Create a Mesh Sketch on each of the side faces of the solid body. 

 Select the actual face of the side wall shown in the Figure as the Base Plane. 

 Set the Offset Distance From Base Plane to 1 mm inward on the part. 

 Click OK to begin sketching. 

 Tilted surfaces should ideally get a zero offset, but some cases require a slight offset to capture better data.  

 

 

Figure 441 

 

Figure 442 
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2. Set the left and right edges of the base by converting the extracted base. 

 Turn the visibility of the Solid Bodies ON and the visibility of the Meshes OFF. 

 RMB click on the left-most vertical edge and select Convert Entities. 

 Repeat on the right-most vertical edge. 

3. These lines have a Converted Constraint.  Change the lines to Construction Lines. 

 RMB click on each line and select the Make As Construction Line symbol. 

 Hide the Solid Bodies to avoid selecting when finishing the sketch. 

 

Figure 443 

 

Figure 444 

4. Finish the sketch with the Line and Corner Trim tools. 

 With the Line tool, double click on the long diagonal pink profile line. 

 Use the Corner Trim command to connect the diagonal to the vertical lines.  

5. Add Dimensions using the Smart Dimensions command. 

 Select the end point of the diagonal top line, vertically down to the U Axis to define 

the height. 

 Repeat on the other vertical line. 

 Turn on the Deviation from the Upper-Side Toolbar to adjust the best assumed 

heights. 

 In the Accuracy Analyzer dock, increase the Vector Multiplier to view the deviation easier. 

 Change the dimensions to the best fit height, or adjust to match Figure 445. 

 Exit the sketch. 

 

Figure 445 
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6. Repeat the same process for the opposite face. 

 Mesh Sketch on the solid face, offset 1mm inward. 

 Convert the vertical edges and make as construction. 

 Dimension to match Figure 446. 

 

 

Figure 446 

 

 

 

 

 

7. The other two sides needs to be 

created using Mesh Sketches and the 

previous sketches. 

 Set up the Mesh Sketch on a 

remaining face, offset inward 1 mm. 

 Create a Line on a straight stretch of 

the pink profile line by using the 

rectangular selection method of 

drawing a line (Figure 447). 

 Double-click on the end point then 

Shift+LMB on the grey line of the 

previous sketch. 

 Select the Pierce Constraint from 

the Common Constraints List. 

 Repeat on the other side of pink 

profile lines. 
 

Figure 447 

 

 

Figure 448 

 

Figure 449 
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8. Use a Spline tool and only two points to connect the open entities. 

 Add Tangent constraints to the connection of the spline and each line.  This will 

allow the spline to bend and better fit the polylines. 

 Use Smart Dimensions to define the sketch as shown in Figure 450. 

 

 

Figure 450 

 9. Repeat this process on the other side. 

 Mesh Sketch on the face with the profile offset 1mm inward. 

 Create two lines and Pierce them to the previous sketches. 

 Use a spline to connect the two lines. 

 Constrain and Dimension. 

 

 

Figure 451 

 

10. Create the top surface using the MODEL>Create Surface>Loft command. 

 For the Profiles, select both sketch chains with the splines. 

 The Surface Normal depends on the order the profiles are selected.  Choosing the profiles from right bottom to 
left bottom, or left top to right top, will create a surface normal pointed in the desired direction. 

 

 

Figure 452 

 

Figure 453 
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11. Use the MODEL>Body/Face>Replace 

Face command to use the newly lofted 

surface. 

 For Target Faces, choose the extracted, 

curved top face of the solid body. 

 For Tool Entity, select Loft1 from the 

Model Tree. 

 Accept the command to finish the solid. 
 

Figure 454 

 12. Check the changes in the different deviations between the Extracted geometry and the 

geometry created with sketches and dimensions. 

 

 

 

 

  

Figure 455 – Extracted Deviation 

 

Figure 456 – Extracted Iso-Line  
 

Figure 457 – Extracted Design 
Quality 

 

Figure 458 – Created Deviation 

 

Figure 459 – Created Iso-Line 

 

Figure 460 – Created Design 
Quality 
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Casting Body Features 

 

 

 
 
 
 
 
 
 
 
 
 

 

1. Find the position and orientation of 

the rib feature. 

 Method 1: Create Ref. 

Geometry>Vector, and select 

the Cylinder region shown and 

the Front plane.  

 Change the Method to 

Projection then accept the 

command. 

 This method is most accurate to the scan 
data, but unable to change parameters of the 
vector. The created vector will not be used. 

 Method 2: Create a Ref. 

Geometry>Polyline, and select 

the top fillet regions of the rib 

feature. 

 Change the Method to Fillet 

then accept the command. 

 Polylines can be inserted into Mesh Sketches 
and sketch entities will snap to the lines to 
give full control of the shape and form. 

 

Figure 461 

 

Figure 462 

 

 

 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Create a Mesh Sketch on the Front Plane with 0 offset. 

 Bring the Ref. Polyline into this sketch using MENU>Tools>Sketch Tools>Insert 

Polyline. 

 Sketch a Line on the inserted polyline. 

 Convert the intersecting edges of the solid base and Make as Construction 

Geometry. 

 Use the Edit>Extend tool to extend the sketched line to the converted edges. 

 Dimension the endpoints and angle of the line to the vertical V Axis. 

 

Figure 463 
 

Figure 464 
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3. Create a Ref. Geometry>Plane on the sketch line. 

 Choose the Right Plane and Sketch (Curve 1) as the Entities. 

 Change the Method to Projection and accept. 

 A plane, orthogonal to the Front Plane, will now be set on the sketch line to use to create the rib. 

4. Create a Mesh Sketch with the new plane, 

Plane 1, as the Base Plane. 

 To capture the maximum height and 

profile of the rib, set the Silhouette 

Range to be wider than the rib, about 38 

mm and accept the sketch setup. 

 The upper and lower boundaries of a volume around the 
section plane will be projected to the base plane.  

Figure 465 

 

 

5. Sketch the profile of the rib as shown in Figure 466. 

 Use the Auto Sketch tool to quickly extract sketch entities from the poly-lines. 

 Adjust the Resolution slide bar to find the appropriate poly-line segments. 

 With Make Selected Only, choose the top profile of the rib and accept the dialog. 

 

 

Figure 466 

 

 
 
 

 
 

 

6. Use Convert Entities to bring in the 

lower line of the rib sketch profile.  

 Select the line from the previous 

sketch. 

7. Trim the profile to close the sketch 

loop. 

8. Smart Dimension the sketch to 

define the rib, then Exit the sketch. 

 A 4.5° draft between the vertical and side lines 
of the sketch were added for manufacturing 
purposes. 

 For better maintainability, sharp corners were 
created.  Dimensions on the corner points, 
rather than the arc centers, will allow for easier 
radii changes. 

 

Figure 467 



  

 

2016 3D Systems 164 Geomagic Design X 2016 

 

 

9. Select Create Solid>Extrude from the previous sketch to generate a solid model. 

 Select all three closed sketch loops for the Profiles. 

 Set the Method to Mid Plane.  Drag the arrow until it snaps to the upper boundary 

of the planar side region.   

 Change the Length value to a round number. 

 Remove all checks under Result Operator, and then Accept the Extrude. 

 A draft is still needed for the extruded sides, but it will be added at a later step. 

 

 

Figure 468 
 

Figure 469 

 
10. In the MODEL tab, select Edit>Fillet. 

 In Constant Fillet, select the corner 

edge of the extruded rib. 

 Use the small Measure Radius button 

next to the Radius input field. 

 Click on the larger radius sketch entity. 

 Verify the Radius is now set to 75 mm. 

 Accept the command. 

 

Figure 470 

 
11. Apply the Edit>Draft command on the rib. 

 Set the method to Parting Line Draft. 

 Select the planar, top face of the rib as the Pull Direction. 

 For Parting Lines, select 4 planar and 2 round edges along either side of the top rib 

face, with their respective arrows pointed down, in to the part. 

 Adjust the draft Angle to 4° with this arrow pointing up and away from the part. 

 Accept the Draft. 
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Figure 471 

 

 
 
 
 

 

12. Apply a Fillet to the smaller edge 

of the rib, the same was as in 

Step 9. 

 In Constant Fillet, select the 

corner edge of the extruded rib. 

 Use the small Measure Radius 

button next to the Radius input 

field. 

 Click on the larger radius sketch 

entity. 

 Verify the Radius is set to 20 

mm then Accept the command. 

 

Figure 472 

 
13. Press the Ctrl+Space keyboard keys to 

repeat the previous command of Fillet. 

 Change the type to Full Face Fillet to 

round the entire rib face. 

 Select one of the large side faces as the 

Left, and the other large face as Right. 

 Select the top rib face as the Center 

and Accept. 

 

Figure 473 
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Adjustments and Deviation Checking 

 

1. Turn on the Deviation for Body to see how the solid model matches the scan.  Make 

adjustments as needed. 

 The four sketches (Sketch2-5(Mesh)) guiding the lofted face can be edited to 

minimize deviation of the top freeform loft face. 

 To edit the Spline Tangent Lengths, double-click on the Spline inside of the Sketch to 

enter the Properties Dialog Tree.  Click, hold, and drag the Tangent Arrow around to 

create a smoother tangent transition. (Figure 475) 

 Edit the Extrusion width to fit the scan width better. 

 Adjust the position and angles of the rib with Sketch6(Mesh) and Sketch7(Mesh). 

 

 

Figure 474 

 

Figure 475 

 

Figure 476 - Extracted 

 

Figure 477 - Extracted 

 

Figure 478 - Extracted 

 

Figure 479 - Created 

 

Figure 480 - Created 

 

Figure 481 - Created 
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Cone Features 

 
 
 

 

 

 
 

1. Generate an editable axis for one of the cone features by creating a Mesh Sketch. 

 Select the Right Plane as the Base Plane. 

 Offset the Section Poly-line until it is in the cone region (Figure 482), about 60 

mm. 

2. Use the Draw>Circle tool to find a center point of the central cone axis. 

 Double click on the pink arc line to create the circle. 

 Use Smart Dimension to fully define the center point.  

 The Cone could be quickly and easily made with the RMB Insert/Merge command to extract from the scan 
data.  Accurate to the scan geometry would be generated, but it would not be easily editable. 

 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
 

 

 

Figure 482 

 

Figure 483 

3. Create a Ref. Geometry>Vector for the central axis of the cone. 

 Select the Sketch Circle Center and the Right Plane. 

 Change, if not done automatically, the Method to Pick Point and Line. 

4. Quickly generate the cone body with the Revolution Wizard.   

 RMB click on the Cone Region and select the Insert/Merge icon. 

 Add the fillet region and the planar face region to the Target. 

 Place a Check next to Get Partial Shape then go to the Next Stage. 

5. The second stage allows for slight editing of the revolution and base sketch. 

 Modify the angle of revolution with the green and grey arrows. 

 Lower the Resolution slide for clean faces of the cone and no fillet in the sketch. 

 

Figure 484 

 

Figure 485 
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6. After accepting the wizard, investigate the revolved shape by looking from the Front 

Viewpoint. A gap between the cone and the rib is revealed. 

 RMB click on Sketch9(Mesh) in the Feature Tree and select Edit.  

 Click and drag the right edge further in to the rib section, then Exit the sketch. 

 

 

Figure 486 

 

Figure 487 

 

Figure 488 

 

 
 
 
 

 

 
 
 
 
 

 

 

7. The previous cone was perpendicular to the ref. coordinate system.  Create the axis of 

the second cone by again using a Mesh Sketch. 

 Use the Front Plane as the Base Plane, and offset the section until it crosses 

through the entire conical face.  They polylines will look like Figure 489. 

 Accept the sketch setup and create the dimensioned sketch shown in Figure 490. 

 Start with the Parabola tool found under Draw>Ellipse. Four points are needed to 

create the parabola. 

 Use best judgement to choose the center point of the parabola. It should be near the 

apex.  Use Figure 489 to help place the other points of the parabola. 

 Just try to get the parabola close to the pink poly-lines.  Dimensions and constraints will edit and move the 
entity. 

 Use the Centerline tool to draw a line between the center point and the apex point 

of the parabola.  This line will be used to set angles and begin other dimensioning. 

 Use the Smart Dimension to manipulate and find the central axis of the parabola. 

 

 

Figure 489 

 

Figure 490 
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8. Create a Ref. 

Geometry>Plane with this 

center line. 

 Select the Top Plane and 

the Center Line of 

parabola as the Entities. 

 Change the Method to 

Projection if it does not 

change automatically. 

 

Figure 491 

 
9. RMB click and select Insert/Merge on the Cone Region. 

 Change the view to the Bottom Viewpoint. 

 Notice the extracted axis generated by the Revolution Wizard is at about the same 

height as Vector 1. 

 This assumption can be used when manually generating this axis.  The Revolution Wizard can show how the 
cone should be made, but it will be difficult to edit. 

 Cancel the wizard command. 

 
10. Create a new Mesh Sketch on the new Plane 2. 

 RMB click on Vector 1 and select Convert Entities.  

 The center line is constrained to the first cone. Edits to this axis will change the axis of this cone. 

 To edit the center line independently, delete the Converted constraint and add a 

dimension and horizontal constraint. 

 

 

Figure 492 

 
11. Create a Ref. Geometry>Vector on the center line from the previous sketch using 

the Extract Method. 
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12. Right-Click on the Cone Region and select the Insert/Merge icon. 

 Check the Revolution Wizard has automatically found Plane 2 and the Vector 2 

to use for the sketch and the revolution. 

 Adjust the Auto Sketch Options to find the best fitting Cone. 

 Increase the degrees of revolution by pulling on the arrows. 

 Accept the wizard command. 

 

 

Figure 493 

 

Figure 494 

 13. Right-Click on Sketch12 (Mesh) and select Edit. 

 Adjust the length of the sketches to ensure it is long enough and extends in to the 

rib. 

 Dimension the part to constrain the sketch and make it easier to edit in the future. 

 

 

Figure 495  - Example of dimensioning 

 14. If needed, adjust any sketch or center lines of the first cone axis or parabola to fit 

better deviations. 

 Turn on Deviation for Body to check how each edit can affect the overall part. 

 If entities are converted or tied to a previous entity, one edit could change multiple parts. 
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Figure 496 

 

Figure 497 

 

Figure 498 

 

Pin Feature 

 
 

 

1. Investigate the final pin feature. 

 This feature has the least amount of information available from the scan. 

 From the Right Viewpoint, the two different angles of the pin are visible. 

 
2. Create a Mesh Sketch on the Front Plane. 

 Offset the section to about 62.5 mm; above the fillet in an area with the most 

possible amount of data. 

 Create a sketch on the slot cross section. Draw the Center Line of the slot. 

 Exit the sketch. 

 The information of the slot cross section can allow for the assumption that it is perpendicular to the Top plane. 

 

 

Figure 499 

 

Figure 500 
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3. Select the Ref. Geometry>Plane tool to create the sketch plane for the side of the 

pin.  

 Select the Center Line of the slot sketch, and the Right Plane. 

 Change Method to Projection if necessary. 

 Accept the command. 

 
4. Create a Mesh Sketch on this new Plane 3 and begin sketching. 

 Since the left and right sides of the sketch have different draft angles, the best 

approach would be to create half the sketch and then mirror it about a center line. 

 Create half of the sketch with the Line tool, and fully constrain with the Smart 

Dimension. 

 Use the Center Line command and find the center of the feature. 

 This sketch will control the position of the pin, the tilt of the top and side faces, and the draft of the side faces. 

 

 

Figure 501 

 

5. Create the sketching plane for the top shape of the pin by generating a new Ref. 

Geometry>Plane.  

 Turn on the Visibility of Sketch 14(Mesh). 

 Select the Front Plane and the top Line of the last sketch. 

 Change the Method to Projection. 

 

 

Figure 502 
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6. Create a Sketch on the new Plane 4. 

 Use the Circle command to create a circle from the center point of the line from the 

last sketch to the end point of the sketch. 

 Use the Pierce and Converted commands to constrain the sketch and pull in points 

needed for constraining. 

 Use the Center Line and Offset commands to create split points for the circle. 

 The two arcs should be separate so different extrusions can be made to account for different draft angles. 

 Accept the sketch when it looks similar to Figure 503. 

 

 

Figure 503 

 
7. Insert a Create Surface>Extrude to generate one side face of the pin at a time. 

 Sketch 15 will be the Base Sketch, but only have one Sketch Chain as the 

Profile at a time. 

 Select Custom Direction and choose the angled centerline from Sketch 

14(Mesh). 

 Place a check next to Draft and set the angle to 4.5°, as calculated in the sketch, 

so the extrusion will match up with the solid line. 

 Set the Method to Up To Vertex and select the end point of the line used for 

Custom Direction. 

 Accept the Extrude. 

8. Repeat Step 7 to the other profile from Sketch 15. 
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Figure 504 

 

Figure 505 

 
9. To join the two open surfaces, use the 

Create Surface>Loft command. 

 The two facing edges will be the 

Profiles. 

 Apply a Curvature To Face, Start 

and End Constraint. 

 Add a Check to Add Side Curve 

Influence. 

 Accept the Loft. 

 

Figure 506 

 
10. Use the Edit>Fill Face command 

to close the top and bottom faces 

of the pin and create a solid body. 

 Select the four edges of the 

circular opening for Edges. 

 Apply a check next to both 

options in More Options to 

create a closed entity. 

 Accept the command. 

11. Repeat Step 10 to the slot shaped 

opening of the pin. 
 

Figure 507 
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Fillets 

 
1. Use the Edit>Boolean command to create a single solid body. 

 Set the Operation Method to Merge. 

 Select all solid bodies as Tool Bodies then accept the command. 

 In the Model Tree, only one Solid Body should remain. 

 

2. Turn on the Deviation for Body to see 

where all the Fillets are needed.  

 

Figure 508 

 
3. Choose the MODEL>Edit>Fillet command to generate the rounded edges. 

 Use a Constant Fillet on each of the fillets around the cones. 

 Select an edge of the Solid Body, then press the Magic Wand button to Estimate 

the Radius from the Mesh.  This found value can be adjusted to the nearest round 

number. 

 Press the Add Radius plus sign button to insert a different size fillet in the same 

command.  

 Select a different edge and press the Magic Wand button again to read this fillet. 

 Repeat on the other cone fillets then accept the Fillet command. 

4. Create a new Fillet for the fillet where the casting body meets the freeform face. 

 Select an edge then press the Magic Wand to find the value. 

 Since this fillet was done after the cone edge fillets, all the edges should be tangent making only a single click 
to select the edges necessary. Check all needed edges are selected. 

 

 

Figure 509 

 

Figure 510 
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 5. Create one more Fillet 

around the edges of the 

pin. 

 

Figure 511 

 
6. Use a Fillet>Face Fillet to define the 

top edge of the pin feature. 

 A width of the fillet segment would change with the 
angles of the faces of the pin in a constant fillet.  
The Face Fillet would keep a constant width even 
with changes to the face angles. 

 For the first set of Faces, choose 

only the top face of the pin. 

 Select the green based Faces set and 

click on the side faces of the pin. 

 Turn the Deviation for Body on to see 

what Radius would be best. 

 Change the Radius to 5 mm and 

accept the Fillet. 
 

Figure 512 

 7. Check the different Deviations of the finished solid model. 

 

 

Figure 513 

 

Figure 514 
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Figure 515 

 

Figure 516 

 
 

End of Activity 
 
 
 
 
 


