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Connector Housing

Step 1 - Views Generation
Go to the Drafting workbench and define the standard and the sheet 
format.
1. Select Drafting in the Start menu

COPYRIGHT DASSAULT SYSTEMES 2002 3



Generative Drafting (ISO) Detailed Steps

2. In the New Drawing panel select ISO as standard and A3ISO as sheet format, then click on OK.
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Set the angle projection method and create the main views.
3. Select Sheet1 in the tree then open a contextual menu with the third mouse button and select 

Properties.
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4. In the properties panel select Create projection views using first angle standard then click on OK

5. Click on the View Creation Wizard icon. 
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6. Select the first configuration, which creates a layout based on bottom; front and left views then 
click on the Next button.

7. Click on the Isometric View button, then place the view in the top right of the layout, click once to 
accept the place of the view then click on Finish.
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8. Select the part window in the Window menu.

9. Click on a 3D surface as reference to generate the views
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10. Use the view manipulator in order to have the view in the following configuration then click 
anywhere on the sheet to generate the views.
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Set the fillet generation off and save the drawing.
11. Select Options in the Tools menu 

12. Select Drafting Options in the left pane list then select the Generation tab. Deselect the Generate 
Fillet option (boundary) in Geometry generation, then click on OK
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13. Select Save in the File menu 

14. Rename the drawing in the Save As panel then click on the Save button

15. Select OK in the information panel that just informs you that the linked part will not be saved.
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Step 2 - Additional Views
Delete left view
1. Select the left view in the tree, open a contextual menu and choose Delete.
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Generate a section view passing through the middle of the two holes
1. Click on the Section View icon
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2. Click on the upper hole.
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3. Click on the lower hole.

 
4. Double click under the geometry of the view to end the Offset section view profile
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5. Place the view preview on the right of the front view
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6. Click in the sheet to generate the Offset section view

Generate Section view B-B.
1. Click on the Offset Section View icon
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2. Build the following Offset section view profile with the same method described for the section view 
A-A. Double click to end the profile.

3. Click on the sheet where you want to place the view in order to generate it.
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4. Double click on the blue frame of the section view A-A to activate it.
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Generate Detail View C of the Detent.
1. Click on the Detail View icon.

2. Build the Detail view profile by two clicks.

3. Place the Detail View preview to the right of the Section view A-A.
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4. Click once where you want to generate the Detail View 

Generate Detail view D around the Clip.
1. Click on the Detail View Profile icon
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2. Build a Detail View profile around the clip of the Section View A-A

3. Place the view preview on the sheet, then click once to generate the Detail view.
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Generate Detail View E around the Catch.
1. Double click on the blue frame of the section view B-B to activate it

2. Click on the Detail View Profile icon then build the following detail view profile.
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3. Place the Detail Preview under the other detail views then click once to generate the Detail view E.
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Generate an isometric view showing the inside of the connector 
housing.
1. Select Links under the Edit menu

2. Select a view in the list, then click on the Pointed Documents Tab.
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3. Select the Open button to open the linked CATPart.
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4. Return to the drawing window.

5. Click on the Isometric View icon
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6. Go to the CATGDRConnectorhousing.CATPart window.

7. Select a 3D surface as reference plane
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8. With the Dial (the view manipulator) rotate the isometric view in order to obtain a view showing the 
inside of the part.
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9. Click once to generate the isometric view.
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Step 3 - Properties
Remove all unnecessary hidden lines in the front view
1. Open a contextual menu on the front view in the tree

2. In the properties panel, uncheck the Hidden Lines and Axis options, then click on OK.
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Delete name and scale on front view. Change section views name.
1. Click once on the name of the front view, open a contextual menu then choose Delete
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2. Open a contextual menu on the frame of Section view A-A then choose Properties.
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3. In the Properties panel select the Prefix View Name, delete it and click on OK.
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4. Redo the same operation with the section view B-B
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Change scale of all detail views to 6. Change scale of Isometric views 
to ½.
1. Open a contextual menu on Detail C in the tree and choose properties.

2. In the Properties panel change the scale from 2 to 6 and click on OK.
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3. Do the same operation with the other views.
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Modify section B-B.
1. Double click on the section B-B profile in the front view.

2. Click on the Replace Profile icon.
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3. Select the upper hole.

4. Create a first horizontal segment of the profile by clicking once on the right of the hole.
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5. Continue the profile as follows and double click to end the profile modification.
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6. Click on the End Profile Edition icon.
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Change the Detail View C callout.
1. Open a contextual menu on the detail C profile in the section view A-A and choose properties.
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2. In the properties panel, select the Callout tab. Choose the last type of Detail view as shown.
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Put a plastic hatching on all sections
1. Open a contextual menu on the hatching of Detail View C, and choose properties
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2. On the Properties panel, click on the Pattern table button.
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3. In the Pattern Chooser panel select Plastic Type 1 hatching and click on OK.
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4. Click on OK in the Properties panel.
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Rearrange all views.
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Step 4 - Dimensioning & Tolerancing
Generate the 3D constraints in step by step
1. Select Tools àDimension generationàFilters.

2. Check the Generate all dimensions option.
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3. Click on the Generating Dimensions Step by Step icon

4. Click on the blue arrow to begin the dimension generation.

5. Click on Pause (the green double bar) to stop the generation each time you want to transfer the 
dimension to another view or not generate the dimension.
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6. Continue the dimension generation until the end.

7. Reposition the dimensions to obtain what is shown in the course.
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Manually dimension the views
1. Click on the Quick Dimension icon.
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2. In the front view, click on the upper hole
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3. Click on the lower hole.
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4. Drag and drop the created dimension outside the geometry, then click once to end the dimension 
creation.
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5. Click on the Radius Dimension  icon, then select the lower hole of the front view.

6. Click once to end the dimension creation.
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7. Select the created radius and open its properties panel with a contextual menu.

8. In the Dimension Texts tab key in “(2X)” in the before value cell.

9. In the Dimension Line tab choose Two Parts as Representation for the dimension. Click on OK.
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10. Reposition the dimension.

11. Continue to define the other dimensions.
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Add datum and Geometric tolerances
1. Click on the Datum icon.
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2. Select the left edge of the connector in the section view A-A.
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3. Position the Datum outside the geometry, then click on OK to accept the Datum feature.

4. Click on the Geometrical Tolerance icon.
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5. Select the edge in the Detail C as shown below.

6. Position the Geometrical Tolerance symbol outside the geometry, then click once.
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7. In the Spec1 symbol list, choose the Perpendicularity symbol.

8. Complete the Tolerance Value and Datum Elements fields as follows. Click on OK to accept.
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9. Select the arrow of the geometrical tolerance symbol then open a contextual menu; choose Filled 
Circle as Symbol Shape.
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10. Select the dimension between the two holes of the front view then choose +- 0.05 as tolerance 
value in the Dimension Properties toolbar.
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11. Click once to end the creation of the tolerance value.

COPYRIGHT DASSAULT SYSTEMES 2002 67



Generative Drafting (ISO) Detailed Steps

COPYRIGHT DASSAULT SYSTEMES 2002 68



Generative Drafting (ISO) Detailed Steps

Step 5 - Finalizing the drawing
Change the source part
1. Select Links under the Edit menu.
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2. Select a view in the list, then click on the Pointed Documents Tab.
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3. Select the Open button to open the linked CATPart.

4. In the Part Design Workbench double click on the Pad.1 feature in the tree.
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--
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5. Double click on the Sketch.7 in the tree

6. Select the dimension between the hole and the edge.
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7. Change the distance to 12 mm. Click on OK

8. Exit the Sketcher

9. Double click on the RectPattern.2.
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10. Change the Spacing from 40 mm to 30 mm. Click on OK.

11. Double click on the Hole.1 feature in the tree.
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12. Change the hole diameter to 2 mm. Click on OK.

--
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Update the drawing and check the views.
1. Go to the drawing window.

2. Click on the update icon.
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3. Check that all views and dimensions have been correctly updated.
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4. Reposition the detail view profiles and dimensions that have been moved.
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Draw a title block
1. Select Background in the Edit menu.

2. Click on the Frame Creation icon
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3. Change the Margin distance to 10 mm and uncheck the Add title block option.
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4. Select menu Tools and Macro option to create title block.

5. Select External File from the Macro In: drop down list
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6. Select the SELECT button and navigate the file structure to find “CATIA PATH 
(ProgramFiles\DassaultSystemes\B07) \ Platform OS (intel_a) \ 
VBScript\FrameTitleBlock\CATDrwFrame_TitleBlock.CATScript

7. Select the RUN button to run the VBScript macro.
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8. Using the Text icon, edit the XXX placeholder text with the desired information (Connector Housing, 
Sheet Number, Design Name, and Date).

9. Return to the Working Views mode under the Edit menu.
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Remove all frames around views
1. Using the view tree, select the view at the top of the list

2. Hold the SHIFT key and select the view at the bottom of the list to select all of the views.
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3. Open a contextual menu on a view frame and select Properties.
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4. In the View Properties panel uncheck the Display View Frame option then click on OK.
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5. Select Print in the File menu
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6. Select the Fit in Page option and rotate as necessary to fit the print on the page.
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7. Select the Preview button to see the results.
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