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THE PRECISION LEARNING METHODOLOGY

PTC Global Services is dedicated to continually providing the student with an
effective, comprehensive learning experience. Toward this goal, PTC develo
Precision Learning, which matches the right training to the right people a’@ t

time using the right method.
Precision Learning is based on a three-stage, Learn—Assess—Im

methodology. @

Stage 1: LEARN

o
The student attends a PTC trair@rse, including any:

* Instructor-led training cou@ﬁT) at a PTC training center.

* On-site training coys

* Customized t 'n@urse.
* Web-ba @g (WBT) course.
Stage 2: A

The irrrb%tjof a training course is assessed using Pro/FICIENCY. Pro/FICIENCY is a
sexl skills assessment and development-planning tool. It is designed to deliver
nf, on that will help improve the skills and productivity of the student.

ge 3: IMPROVE

Pro/FICIENCY enables customers to identify areas for improvement. The training
wizard will direct customers to the appropriate class based on their job responsibilities.
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Customers have access to a range of resources that include:

e Internal and external user groups.

* PTC technical support resources. \%
* Web-based courses and lessons. @
CONTINUOUS IMPROVEMENT @

The Precision Learning methodology provides a continuous cycle of @Iedge

expansion and improvement. @

Learn - Learn @ PERISCH NG

o —>»| Learn
B <

Project Work Project Work

Q@ Project Work W Project Work
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PRECISION LEARNING IN THE CLASSROOM

The Learn—Assess—Improve Precision Learning methodology is also implementgd
in selected PTC instructor-led courses. Throughout the class, students will t%g
Pro/FICIENCY assessments to evaluate their own comprehension. The g@ ul

are also used to identify areas for the instructor to review with the classassawhole. At
the end of the class, each student will complete an Education CircuT is
Education Circuit is the student's action plan, identifying topics for impravément, as
well as the steps to take in order to enhance the skills in those@s.

The following pages provide a sample Education Ci%@f@)lan, and a blank

action plan. Instructions for using the Education Circtit.actipn plan will be discussed in

the course. @@\
O

N
é@;@@@

&
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EDUCATION CIRCUIT EXAMPLE

The following is an example of a student's Education Circuit at the end of the
Designing Products with Pro/ENGINEER Wildfire training class.

Pro/FICIENCY Assessment Results

After reviewing assessment results for this course, the following lists the
answered incorrectly and need to research further:

@\%

s

@

Question

Improve Action

Weak and strong dimensions

Practice creating s
dimensioning sghem
Web Lesson Di siopjng Scheme

V=
I@j’@res with the desired

Draft Features

See colleague at werkfor advice and product examples.

Configuration file options

Consult company user group for guidelines.

Class Evaluation Form Topics

‘0°

After reviewing the questions on the class Eval@fcrm, the following lists the

topics | need to research further:

XQ)

Objective IX

Improve Action

Setting up the default view of a part W
N

Practice on simple parts using different sketching planes
and reference planes.

N

Creating sweeps

Web Lesson Swept Forms

Vad
\J)

Resolve Mode

Create some simple models and make them fail.

Resolve Mode

Web lesson Resolve Mode

N

Future Courses

After reviewing t e Based Training guidelines, the following lists the courses
recommended to | e my skills and enhance my job performance:
s

Next Courses\ Next Courses

Advance bly Management with

Pro/NG]] Wildfire

Al Surface Modeling with Pro/ENGINEER

wild
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Pro/FICIENCY Assessment Results

After reviewing assessment results for this course, the following lists the questiong\|
answered incorrectly and need to research further: %

Question Improve Action Af\\\ J
(@R
N
(%
o N\

|
Class Evaluation Form Topics : >@
n

/ the following lists the

After reviewing the questions on the class Evaluatio
topics | need to research further: QX

(N
Objective ImMprpve Action
I
o L))
74
(@)

O
Future Courses @U
After reviewing t F@@sed Training guidelines, the following lists the courses
recommended toj my skills and enhance my job performance:

Next Cour§és Next Courses

L
@\
N
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Creating Milling Sequences with Pro/ENGINEER Wildfire

The following software versions were used in developing this course:
Build Code(s) \ 3>

Title/Version Build @
Pro/ENGINEER Wildfire for Windows NT 4.0 2002380

2000 and XP for Intel based systems

Third Party Software

2
Title/ Version Buil &
Vetri:lljt 5(.22s > i \\\%9
N/
Trail File(s) \
Title/ Link @
N
N
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Module

Introduction

\‘
Introduction @

Prior to using Pro/ENGINEER Wildfire to machine onents, it is necessary to
understand the overall manufacturing process, @eps involved in this
process. It is also important to understand d%how to use the basic
elements and tools that make up the Pro/EN R Wildfire interface. You can
achieve this by opening and review% within completed manufacturing

models. This can include reviewing rence models, machine types, tools,

fixtures and completed tool path%

Note: Q

This training&ous een developed using metric units. The
English (or, 19 nit equivalent is shown in parenthesis after
metric diménsjons>in order to put the dimension into context for

student not use metric units.

)
o
C leting this module, you will be able to:

escribe the Pro/ENGINEER Wildfire manufacturing process.

Describe the elements that make up completed manufacturing models.
* Navigate the Pro/ENGINEER Wildfire interface.
@ * Review the elements that make up completed manufacturing models.

» Review completed NC sequences.

Page 1-1



Creating Milling Sequences with Pro/ENGINEER
Wildfire

Module 1: Introduction

The way o Product Fir

©p1Cc CEQ

Instructor Preparation
Before teaching Creating Milling Sequences with Pro/ENGIN@I:;ire, you must have read and

thoroughly understood the following materials:
* General Information
* Review Pro/ENGINEER Wildfire primer site at eb.ptc.com/primer/

* Pro/E Wildfire Documentation
* Review Pro/ENGINEER Wildfire dé> ion in Windmill, located in
/GS Training Materials/Domain Knowled C te/ProENGINEER/Core Concepts

* Pro/E Wildfire Milling

* Review Pro/ENGINEER Mllllng training materials in Windmill, located in
/GS Ed Srvcs Operations tion Library/Instructor Materials/Instructor Kits/EN
[T979-330-Instructor_Kit-

* Required Skills
« Comple of Pro/E Wildfire Foundation or equivalent Pro/E skills
n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E

ility to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day One

¢ " Creating Creating Pro/FICIENCY
reating ; g E=da] Doty
Workpieces Models || Operations |_| |Assessments
T T T
| | |
| | |
L 1 L
Creating Croatin ||
) it 9 Creating
-] the Stock Dialog |- Models with o == cturin
Models Box °G::,",'=| 2 Operations - |
1 Assembly l
Creating I} Creating
using Sketcher Creating. 'g:',':‘::f,',"‘:'_"ﬁ
Models with a
Reference Model
and Workpiece
N
Reviewing Creating Croating Croating
i with it | ”
Manufact the Stock Dialog Models with o n
Models Box [ Genoral [ _Operations -1
T Assembly T
Creating | Creating
Workpieces - rcturin
using Sketcher Creating °('::',:;:I':::e)"
Models with a -
Reference Model
and Workpiece

Duration
* Lecture: 15 mins
* Demos : 25 mins
* Labs : 50 mins
» Total: 1 hr 30 mins

;&\@
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Objectives

After completing this module, you should be able to:
© Describe the Pro/ENGINEER Wildfire manufacturing process.
© Describe the elements that make up completed manufacturing models.
© Navigate the Pro/ENGINEER Wildfire interface.
® Review the elements that make up completed manufacturing models.

® Review completed NC sequences.

QO

Overview
Prior to using Pro/ENGINEER Wildfire to machine components, ity @nant to understand the overall
manufacturing process, and the steps involved in this procesg. Yo achieve this by opening and
reviewing elements within completed manufacturing models. TR include reviewing reference
models, machine types, tools, fixtures and completed tookpaths.

After successfully completing this module, you will @?

* Describe the Pro/ENGINEER Wildfire manufactiing process.

» Describe the elements that make up cq;np @ manufacturing models.
Navigate the Pro/ENGINEER W|Idf|r
Review the elements that make up -*o « ted manufacturlng models.

Review completed NC sequen@

®©

Q)
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Manufacturing Process Overview

1. Manufacturing Model Creation
DESIGN WORKPIECE MODEL
sl
Four Stages MODEL MANUFACTURING { )
MODEL

2. Manufacturing Setup i

MANUFACTURING
GEOMETRY
(OPTIONAL)

SET UP
MANUFACTURING
ENVIRONMENT

WORKCELLS CREATE OPERATION ;';‘;Ig'zii
(Workcell, Machine ( )

Zero)

3. Toolpath Creation CREATE Ne- CREATE IN-
SEQUENCES PROCESS
GEOMETRY
(OPTIONAL)
POST-PROCESS CL @
e <>

ToOLS

'@

Slide 4 ©2002
Manufacturing Process Overview @
The Pro/ENGINEER Wildfire manufacturing process can be bro o/ffour stages:

1. Stage 1 involves creating manufacturing models using a ign Imodel (also known as a reference
model) and a workpiece.

2. Stage 2 involves setting up your manufacturing envir t this can involve configuring tools,
fixtures, machines (known as workcells), and creati facturing reference geometry.

3. The next stage involves creating NC sequence grams). Creating NC Sequences involves
selecting a cutting tool, selecting geometry g eference model to machine, (e.g. surfaces for
milling holes for drilling), and spemfymgom parameters to control how the toolpath is
generated. Once NC sequences are fj u can create Cutter Location (CL) data files, these
are then post-processed to produce code data (MCD files).

4. The final stage involves using the s to drive machine tools.
This course will cover stages 1 @is process, finishing with creating machine code
%fagbl

data. Stage 4 involves dri ine tools and is therefore beyond the scope of this
course.

&
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Manufacturing Model Creation

Reference Model Workpiece Model

Manufacturing Model

Manufacturing Model Creation
Manufacturing models consist of a reference model (representin %I designed component) and a
workpiece assembled together. The workpiece represents thedyun-machined stock material.

Note to Instructor: Ensure the meaning of all key terminols Nis noted by students in this slide.
Key Terminology: (@

* Manufacturing Model @
« Reference Model o @
* Workpiece Model &



e . VrTC

Manufacturing Setup

Main Elements

® Configure before NC Sequences
o Machining Operation
o Workcell
Machine Type
e Machine Zero
® Configure before or during NC Sequences

e Tools

e Retract Surface/Plane _RETRACT OPO1

Fe——— length

gA MACH_CSYS_OP010
TIP e
Reomer_radius

Deutter_diam

@

Manufacturing Setup

The manufacturing environment is made up of a number of elements. So %nts must be configured before
creating NC sequences, other elements can be configured either befare or durig the creation of NC sequences, and
some elements are optional.

» Machining Operations are defined as a series of NC s performed at a particular workcell (machine) and
referencing a particular coordinate system. For ex configuring a machining operation to machine one side
of a component by specifying the machine tool (war
NC sequences are then associated with thg co

% pe of machine tool and numerous machine tool parameters.
l

a 3-axis milling machine with various machine tool parameters
d, and travel limits in the X, Y and Z directions.

osition in x,y and z on the machine tool.

Here are the main elements:
Configured before creating NC Sequences @
qu

» Workcells specify machine tools in term

» For example you could specify a w
such as feed units, maximum spi

» Machine Zero specifies the progr e

Configured either before or during<¢rea NC Sequences
* Tools: a tool must be ¢ ed-for each NC sequence you create.

* Retract Surface (ofPI ecifies the clearance level to which the tool is retracted after completing
an NC sequenc

Optional &
* Fixturgs @ s or assemblies that help orient and hold the workpiece during a manufacturing

1)

surfacedo assist in face milling.

Other optional elements such as parameter files and PPRINT tables will be discussed later.

Note to Instructor: Ensure the meaning of all key terminology is noted by students in this slide.
Key Terminology:

*Machining Operation

*Workecell

*Machine Zero

*Tools

*Retract Surface or Plane
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Manufacturing Setup

Main Elements

® Optional

o Fixtures

o Manufacturing Geometry
Mill Surfaces
Mill Windows
Mill Volumes

Manufacturing Setup
Optional %
» Fixtures are parts or assemblies that help orient and hold workpiece during a manufacturing

operation.

» Manufacturing Geometry is made up of geometry featy hat assist you in creating NC sequences:
» Mill surfaces are surfaces that can be used {b"‘ ences in many NC sequences, for

example a mill surface can be configure, e“surface for machining in a profile or face
milling NC sequence.
* Mill Windows are closed 2-D outline are typically used to specify the volume of material

to be machined when volume

) ﬁ%
* Mill Volumes are closed 3-D%§§3§s that can also be used to specify the volume of material

to be machined when volu g.
Other optional elements such@@eter files and PPRINT tables will be discussed later.

Note to Instructor: Epguare % nieaning of all key terminology is noted by students in this slide.
Key Terminology:
* Fixtures
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Toolpath Creation

® Create NC Sequences
o Specify Tool
« Select/Create Geometry to Machine

o Modify Machining Parameters

MACHIN / UNCX01, 1

$5-> CUTCOM_GEOMETRY_TYPE / OUTEUT_ON_CENTER
1 /

© Create Cutter Location (CL) Data [ /m

« ASCII format 332 Gotsy Laoscusoeto, 0. o

0. , L. , 0.

0. , 0. , L.
SPINDL / REM, 500.000000, CLW
RAPID
GOTO / -25. , =108 , 50.

® Post-Process CL Data 5 671 \
N10( / COVER)

N15 GO0 G17 G99

N20 G90 G9%4

N25 GO G49

N30 TS5 MO6

® Machine Control Data N35 5500 MO3
N40 GO G43 z50. HS

Toolpath Creation @

The next step in this process is to create NC Sequences, this invi :

» Specifying a tool.

» Selecting or creating geometry to machine, (e.g. surfacexto machine or holes to be drilled).

» Specifying how the tool machines the selected geo modifying machining parameters, for
example specifying cutting feed rate and spindle

Each NC sequence is made up of a series of tool @s with the addition of specific post-processor
words that are not motion-related but requw@ e correct NC output).

The next step is to create Cutter Locatio files, these are generated from the cutter paths
specified within NC sequences.

The CL data files can then be post-pr

create Machine Control Data (N@
Finally, MCD files are use td@machine tools.

Note to Instructor: eaning of all key terminology is noted by students in this slide.
Key Terminology:

usmg machine-specific or generic post-processors to

* NC Sequenc%
« Cutter o@l ta (CL data)
. r

» Machige Control Data (MCD)
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Pro/ENGINEER Wildfire Interface

F1 COVER (Active) - Pro/ENGINEER L =afx|
Eile Edit View Insert Analysis Info Applications Tools Window Help

Graphics Window

DS08Ry PR RD-rFARASNESW 0000 Z4Auk S22 %

- v
Navigator e S
. Sovcs
©® Folder Navigator @
o Navigate Folders

« Set Working Directory

=a
=@
© Browser =
=
. =
« Preview Models -an ;
=0 A File types Al Files () o v [
« Open Models -2 i .
3 :
o Web Access “Sa Brwn

BFbm
E

P 3
k o core ne wicor ErCH
] .
“Part COVER_NC'not c since last regen. 9
*5pin Center will not be ed. 8
£ ]

Pro/ENGINEER Wildfire Interface %
n

» The Pro/ENGINEER Wildfire interface consists of a main grap
manufacturing models and NC sequences.

dow, where you can create

* On the left side of the graphics window is a folder navigator that allows navigation of the folder

structure, it is also used to set the working directon@
I

* The integrated web browser enables selection ewing of models within a folder, once a
desired model is located it can be opened dire m within the browser.

» The web browser is also used to access w@e information such as supplier and contactors’ web

sites. \
Koy
W
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Pro/ENGINEER Wildfire Interface

Model Tree

® Features Listed

Analysis Info Applications Tools Window Help
S ArRRAAQS B OO0 2 mrsi

1Mfg Model
Mfg Setup
47 Machining
7 cLpata
" Modify
Regenerate
| Component
= setup
Relations
Program
Inteqra

Pull-Down Menus
Icons
Menu Manager

Message Window

i
DRI

L [0P010)

LLioF010)
7.C_SINK[OF1D]

Selecting Items 1]

hanged since last regen.

© Pre-highlighting s : L @\

® Direct Selection

©® From Model Tree

Pro/ENGINEER Wildfire Interface %@

* When a manufacturing model is open a model tree appears t ft of the graphics window. The
model tree lists all the models and features that make up manufacturing model, this can include
reference models, fixtures, machine operations, and ¢ eq ces.

* Fully integrated pull-down menus are located at t

» Toolbar icons are by default located at the top,
provide access to commonly used functions.

* The menu manager is located by default rf‘i‘ ht of the graphics window and provides access to
most of the manufacturing tools, such :%3 up the manufacturing environment, and creating
NC sequences.

* The message window which by d \ located at the bottom of the graphics window provides
feedback on recent selections and tions.

* Moving the cursor over a mod@e graphics window causes different pieces of geometry and
components to highlight aut lly, this is know as pre-highlighting, and enables easy
selection of objects wi :!' phics window.

* Items such as fea ~Q nodels can be selected directly from the model as they are highlighted.

Alternatively ite b } elected from within the model tree as required.
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

©® Reviewing Completed Manufacturing Models

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Reviewing Completed Manufacturing Models %
Scenario

» Throughout this course, the exercise scenarios are th%ne as the demo scenarios.
» This has been done to build consistency between Q@é nd lab exercises so as to enable “Tell

me—Show me—Let me do.” @
Method o
Use the script in the instructors guide, us&s rie models as in the exercises.

Exercise
Once the demo is complete t%e s should use the steps in the training guide to complete the

Q)
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Summary

After successfully completing this module, you should know how to:
© Describe the Pro/ENGINEER Wildfire manufacturing process.
© Describe the elements that make up completed manufacturing models.
© Navigate the Pro/ENGINEER Wildfire interface.
® Review the elements that make up completed manufacturing models.

©® Review completed NC sequences.

QO

Summary

After successfully completing this module, you should know how %
* Describe the Pro/ENGINEER Wildfire manufacturing proc

Describe the elements that make up completed manufacturing models.

Navigate the Pro/ENGINEER Wildfire interface. @

Review the elements that make up completed uring models.

» Review completed NC sequences. ©j@

1
2
S
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Exercise 1: Reviewing Completed Manufacturing Models

Module 1 Lab Exercises

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \

e Practice running the demo so you can easily complete it.

* Check for and review the errata sheet for this course. @

* Use Pro/ENGINEER Wildfire build code 2003051 or later.

« Download and install the class fileswi | df i re_m | | i n%&a I. 9z as described in

the classroom setup notes.

Introduction

In this demonstration, you review the elements th x%up completed manufacturing models.
This involves opening a completed manufactyri @}gl and identifying the reference model and
the workpiece. You also review other selec @\ents such as the manufacturing operation, the

€
workcell, the machine zero, and theX, tne. You will also review and change some of the
to%p

NC sequences and observe how E{é\% aths update. The ability to review existing
manufacturing models and too@g an important skill, and also provides you with an excellent
overview of the manufactu@ ess.
Business Sc @ackground

c. (PMI) is a supplier of electromechanical components, and tooling to
e manufacturing department needs to generate a number of new milling NC
t customer requests. As a manufacturing engineer, you are tasked with creating

programs to
NC r%ms for a machined aluminum cover, and for a mold cavity. Other tasks may be
as @: 0 you as the training scenario develops.

Precision
many indu

bjectives

After successfully completing this exercise, you will know how to:

* Review the elements that make up completed manufacturing models.

* Review completed NC sequences.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 1-3
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Scenario

In this exercise, you will review a completed manufacturing operation for the aluminum cover,
including the review of existing NC-sequences. This will give you an opportunity to see a
machined version of the aluminum cover, which you will then create stage-by-stage through the
remaining exercises.

Figure 1: The underside vie&é@inum cover.

Step 1. Open the completed manufacturing mo “the aluminum cover; identify the reference
model and the workpiece. ©

Before reviewing the manufacturing mo %aluminum cover, we will preview the
Pro/ENGINEER Wildfire interface s an become more comfortable with it. The benefit in
this task is that becoming famili ith she Pro/ENGINEER Wildfire interface will enable us to

focus more on creating N r
Note the following iteths Wildfire Interface:
|

e Fully integrated

applicatior&
e T Ibtionality with logically arranged icons.

. the tabs on the navigator. These tabs allow us to quickly change between the folders on

n menus, which benefits users that do not prefer icon driven

our computer folder structure, to our favorites directory, to our different Internet connections,

and to our model tree when we have a model.

» Navigator Browser that allows us to see outside of Pro/ENGINEER into supplier websites,

contractors’ websites, and PDM systems.

In order to review the manufacturing model, we first need to locate it and open it using the folder

navigator. Once we have located the folder, we can set this as our working directory, and open

Page 1-4 Introduction
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the manufacturing model of the cover. Notice how the model tree appears on the left of the
screen. The model tree lists components within the manufacturing model, and manufacturing
features such as operations, workcells, and NC sequences. We can identify the reference model

and the workpiece in the model tree and on-screen.
1. Start Pro/ENGINEER Wildfire if it has not already been started for you.
2. In the navigator, select the Folder Browser tab, and browse to
c:\users\student\wildfire_mfg_330\module01, right-click, and select M@ing
re

Directory.

3. Inthe browser, select COVER.MFG to preview it, as shown in the following

4. Drag the COVER.MFG manufacturing model into the graphics windo

Contents of module01 @

\File List A

File ty@u Files (*) ~]  Versions I
Fi?x@s Instances [
% me Size Modified

Z \ﬁﬁfscrew.asm 22 KB 07-Now-02 03:49:14 PM
g/;:lamp_pad.prt 51 KB 07-Now-02 03:49:14 PM

& [ cover.asm 2B 08-Mow-02 09:46:17 Abd
@ E ] 05 Miow-02 09:46:17 A
[ cover.pr 427 KB 30-0ct-02 01:44:54 PM

O cover_nc.asm 21 KB 30-0ct-02 01:44:54 PM

[0 cover_nc_wrk prt 2 KB 30-0ct-02 01:44:54 PM

[0 handle_cap.pt 41 KB 07-Mow-02 03:49:14 PM

(& opO10.ncl 215 KB 08-Mow-02 09:20:13 Al

[0 screw_handle prt 47 KB 07-Mow-02 03:49:14 PM

[ vise.asm 27 KB 07-Mow02 03:49:14 Phd

Figure 2: Selecting the manufacturing model for the cover.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 1-5
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Note:

Notice after the manufacturing model appears, that the model tree replaces the
navigator on the left of the screen. The model tree lists all components within a
manufacturing model, and manufacturing features such as the operations, workcells,
and NC sequences.

5. Using the toolbar icons at the top of the graphics window, turn off the display of datum
planes, axis, co-ordinate systems, and points.

6. Click on the saved view list icon and set the view to the named view OP010.

gure 3: The view set to the named view OP010.
7. Expand COVER N¢/ASM in the model tree to see the models.

8. Selec@/ ence model (COVER.PRT) in the model tree.

9. el orkpiece model (COVER_NC_WRK.PRT) in the model tree. De-select the
highlighted model by clicking in the background of the graphics window.

COVERASM
- [0 COVER_NCASM
COVER.PRT

A ACSD

COWER_MC WRE.PET

Figure 4: View of the expanded model tree.

Page 1-6 Introduction
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Hint:

Notice how selecting models in the model tree highlights them on the screen. You
can also highlight models by selecting them in the graphics window. To de-select a
model you must click in the background of the graphics window.

Step 2. Review the workcell, the manufacturing operation, identify the machine zero, and retract
surface.

The workcell dialog box, accessible from the Mfg Setup menu provides us with more infokgation

about the workcell.

Similarly the operation dialog box, also accessible from the Mfg Setup menu,p

r@@ws with
<; sition and the

more information about the operation. Here, we can preview the machine

retract surface.

1. Using the Menu Manager, select Mfg Setup > Workcell -U-, the contents of the
Workcell Dialog box. Close the Workcell Dialog box.

Machine Tool Setup
Eile

0@ O (f@

AN
Machine Name  |[FaDAL_wMC (| CNC Cantrol| |

tachine Type |Mi|l //\\ |v| Location | |
MNumber Of Axes |3A><|s H\\J) | |

Output | Spindle Travel E;srom Comments
—PustPruce
PP MName Naxm | D01 2| | Reset Defaults | | PPRINT
\deutputOptansi
| Do Mot Output
| Modal

?LNT{OFH Output
PINDL/OFF | Qutput

$141<]<

p Cutter Compensation .

@ Figure 5: The workcell dialog box.

Using the Menu Manager, select Mfg Setup > Operation, and review the Operation dialog
box.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 1-7



Operation Setup -[=]x]
0O X

Dperation Mame |OPD1D |V|
NC hachine | FADAL_VMC [l
o x|

General ‘ From/Hame  Qutput

- Beference

Machine Zero LJEJ

- Retract \
Surface Mﬂ& @
Tolerance |'| | @

Stock Material

O I CanceIJ Close‘ @
Figure 6: The operation dialog bax. %

3. Click on the preview icon for the machine zero, this highlights the-machine zero in the
graphics window. Click on the preview icon for the ret;i ace, this highlights the retract
surface in the graphics window. Close the Operation d :\@, HoX.

4. Turn off the display of datum planes and datil rdinate systems that were turned on

when previewing the machine zero and getrg ace.

Step 3. Identify and review tools used in thé\mé%ining process.

DN
The Tool dialog box is also accessib @Mfg Setup menu. Here we can review the various
tools stored with this workcell.

1. In the Mfg Setup me @ooling > FADAL_VMC, and examine the tools for the
FADAL_VMC wgfkc on each tool name to review the tool parameters.

2. When finished eAhe tool dialog box, and return to the Manufacture menu.

&

Page 1-8 Introduction
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|

Number|Name |Dﬁset |C|:|mments |

1 CTRDRILL_04 1 &
3 DRILL_06_0 3

4 CSIME_12 4

5 FEK_03_0 5

7 FEK_0B_D 7

E FER_12_10 g

1 BER_12_0 1

13 FEM 25 D 13 &

Pressiew I Tool WWind

Name  |FEM_12_0 | [ipale @
Type  |MILLNG |+
haterial |HSS | 18>

LInits |Mi|limeter |V| D l

Y

%;.TE:D
Geametry setftings EESSSS'
Cutter Diameter: 12 C(//\\,y
Length: R0 J(\\‘/
Carner Radius; 7\
Side Angle: N M
Mumber of Teeth; @

@@ure 7: The view of the tool dialog box.

Step 4. Identify and r\eyiémhe fixture used in the machining process.
N

a jgured within the Operation dialog box where we can identify the fixture

Is miachining operation. We can also identify the fixture assembly in the model

tree. l{e thefixture assembly highlights on screen when selected in the model tree.
Fi ups are useful because once configured they can be easily activated and de-activated

j rent operations.

Using the Menu Manager, select Mfg Setup > Operation, and click on the Fixture Setup
icon, this opens the Fixture Setup dialog box.

2. In the Components tab, select the fixture component OP010_INST. Then close the Fixture
Setup dialog box, close the Operation dialog box, and return to the Manufacture menu.

3. In the model tree, select the fixture assembly (OP010_INST.ASM). De-select the highlighted
model by clicking in the background of the graphics window.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 1-9



fF FADAL WMC

e ACSH

£7 ADTHT

S0 OPO010 [FADAL VMC]
e P00 (NS T ASK

8 OP-010

+g¥ 1. FACE_BOTTOM [OPO10]

Figure 8: Fixture assembly selected in model tree.

Note:

Notice how the fixture assembly highlights in the graphics window when selected
the Components tab of the Fixture dialog box or when selected in the mode(@

'
Figure 9: Fixt@?@y highlighted in the graphics window.

Step 5. Open and review a sf{tg \ﬁﬁq\ﬁcturing parameter file.

We can review a manyf: parameter site file by showing the site file used in this operation.

Manufacturing site arepuseful because we can configure and store default sets of
manufactur/ng rametéer values that can be loaded at the beginning of each operation. In

addition, w e them to control parameter visibility and specify maximum and minimum

the Menu Manager, select Mfg Setup > Param Setup > Site, and Show.

2. Select the RGH_3_AXIS_MIL site file, and review the contents of the information window.

Note:

Notice the parameter column lists all the available parameters for a milling site file,
the default column shows the current default values.

3. Close the information window, and return to the Manufacture menu.

Page 1-10 Introduction
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Step 6. Examine the CL data file for the first operation using Vericut.

The first operation is made up of several NC sequences. We can review the cutter location (CL)
data file for the first operation. CL data files are created when an operation is complete and

provide the input to post-processors to enable creation of machine code data (MCD) files.

We already have a CL data file ready to review, so we can review the CL data file using Vericut,
enabling us to review the toolpath and view the machining simulation. Start Vericut and open the
CL file OP0O10.NCL.

Note:

S :
Selecting the NC Check option in the CL Data menu starts Vericut.@ ena

separate Vericut window to perform the machining simulation.

1. Using the Menu Manager, select CL Data > NC Check > CL @nd Open the
op010.ncl file, then select Done to start Vericut. (You may ait a few moments for
Vericut to start).

2. Inthe Vericut window, click on the Setup Motion.icon, the Motion dialog box drag the
animation speed slider to the left (this will redu%speed of the animation). Then close the
Motion dialog box.

3. Click on the View Toolpath File icon to
on the Play to End icon to view<t>he

RS

the,CL data file during the simulation. Then click
simulation.

Figure 10: Playing the CL data file in Vericut.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 1-11



4. Close Vericut when finished, and return to the Manufacture menu.

MACHIN / UNCXO1, 1

§§-» CUTCOM_GEOMETEY_TYFE / OUTPUT_ON_CENTER

UNITS / MH
LOADTL 4/ 15, OSETNO, 15
§§-> CUTTER / 50.000000

(\b PTC

§§-» CHY3 4 1.0000000000, 0.0000000000, O.0000000000, O.0000000000,
0.0000000000, 1.0000000000, O.0000000000, 0.0000000000,
0.0000000000, O.0000000000, 1.0000000000, 0,0000000000

SPINDL 4 RPM, 1165.014183, CLW
COOLNT / ON
RAPID

GOTO / -25.0000000000, 0.0000000000,

RAPID

GOTO / -25.0000000000, 0.0000000000,

FEDRAT / 30Z.9034658, MMPM

GOTO / -Z5.0000000000, 0.0000000000,
GOTO / 158.0000006939, 0.0000000000,

1|

40. 0000000000

3.0000000000

-Z.0000000000
-Z.0000000000

Figure 11: Viewing the CL data file.

QO

Step 7. Review and adjust the face milling NC sequence.

-,
s,
%)

Reviewing and adjusting NC sequences is important because it a

existing tool paths. You will repeat the following method eve

There are several ways we can review NC sequences. In

milling sequence through the Machining menu. All t

a list, and we can select the sequence we M@nt @
Note that we can display the CL data at thg%ﬁe e if desired. We can now adjust some

manufacturing parameters, and review 4w

simulation using Vericut.

1. Using the Menu Man
FACE_BOTTOM N

&

to verify and optimize

ime you want to adjust a tool path.

se, we will access the face

sequences for the first operation appear in

ew. We will play the toolpath on screen.

4
5: C_DRILL, Operation: OP010
6: DRILL, Operation: OP010
7: C_SINK, Operation: OP010

ted tool path. We can also view the machining

erse iIﬁachmmg > NC Sequence and select the
e for review. When prompted Suspend All child features.

1: FACE_BOTTOM, ijeratiun: QPO10

2: PROF_BOTTOM, Operation: OP010
3: RGH_POCKET, Operation: OP010
: FIN_POCKET, Operation: OP010

Figure 12: Selecting the sequence from the NC Sequence list.

2. Review the toolpath by selecting Play Path > Screen Play.

3. In the Play Path dialog box, click on the blue CL data bar, this will make the CL data visible in
the dialog box. Click on the Play Forward button to review the toolpath. To slow down the
toolpath simulation, click and drag the display speed slider to the left.

Page 1-12
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Note:

When the toolpath simulation is finished you can replay the toolpath by clicking the
Rewind button and then clicking the Play Forward button again.

4. Close the Play Path dialog box when finished.

Figure 13: Playing t@\eﬂilling tool path.

5. To modify the manufacturing parameterg§'cli n the Manufacturing Parameter Tree icon at
the top of the graphics window. Thi@n e the parameter window appear.
<&
fythe

6. Inthe Parameter Tree windo@

Parameter Tree window.

CUT_ANGLE value from 0 to [90], then close the

7. Review the toolpath a o} lecting Play Path > Screen Play. Then click the Play

Forward button to e toolpath.
\)
Note: N4
Notj iewing the toolpath the tool cutting angle has changed by ninety
deg g

8. C%n the Manufacturing Parameter Tree icon again, and in the Parameter Tree window
ify the SCAN_TYPE parameter value to TYPE_ONE_DIR, then close the parameter
window.

In the Play Path menu, select NC Check. (You may need to wait a few moments for Vericut
to start). Click on the Play to End icon to view the machining simulation.

Note:

To slow down the simulation you can click on the Setup Motion icon, and in the
motion dialog box drag the animation speed slider to the left.
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Figure 14: The face milling sequence simulationg @

10. When finished close Vericut, then complete the sequence, byselecting Done Seq, and
return to the Manufacture menu.

Step 8. Review and adjust the profile milling NC sequenc{é//\\,;yv
N

We can repeat the process and adjust the profiling u

e.
1. Using the Menu Manager, select Machﬁ%@c Sequence and select the
PROF_BOTTOM NC sequence for hen prompted Suspend All child features.

A =@u OM, Operation: OP010

2: P@F_BORFOM, Operation: OP010
GH_POC T, Operation: OP010
F7FIN_POCKET, Operation: OP010

5: C_DRILL, Operation: OP0O10

6: DRILL, Operation: OP010

7 C_SINK, Operation: OP010

& Figure 15: Selecting the sequence from the NC Sequence list.

2. w the toolpath by selecting Play Path > Screen Play.

3. Click on the Play Forward button to review the toolpath. To slow down the toolpath
simulation, click and drag the display speed slider to the left.

4. Close the Play Path dialog box when finished.

Page 1-14
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Figure 16: Playing the profile milling tool @

To modify the manufacturing parameters, click on the ciyring Parameter Tree icon at
the top of the graphics window. This will make the patametgf window appear.

In the Parameter Tree window, modify the STE%PTH parameter value to [6] (0.24 in.).

Review the toolpath again by selecting PI Screen Play. Then click on the Play
Forward button to review the toolpath.

Note: © @V

Notice how the tool now makes'thwee profile passes around the reference model.

View the machining si@c@king Vericut, by selecting NC Check in the Play Path menu.
fe

(You may need to wai moments for Vericut to start). Click on the Play to End icon to
view the macE ini@ ation.

&

Figure 17: The profile milling sequence simulation in Vericut.
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9. When finished, close Vericut, then complete the sequence by selecting Done Seq, and
return to the Manufacture menu.

10. To save the manufacturing model, click File > Save, and press ENTER on the keyboard.
11. Click Window > Close to close all windows

12. To erase all components from memory, click File > Erase > Not Displayed. Then click
OK in the erase not displayed dialog box.

Note:

Closing windows does not remove components from the current session of
Pro/ENGINEER Wildfire. This is only achieved by erasing components fromm

%@

\
&
O

0
B
S

Q)
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Summary

After successfully completing this module, you should know how to:

Describe the Pro/ENGINEER Wildfire manufacturing process.
Describe the elements that make up completed manufacturing models.

Navigate the Pro/ENGINEER Wildfire interface.
Review the elements that make up completed manufacturing models.
Review completed NC sequences. @\

>
Q
O
N
B
S
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Module

Creating Workpieces

\‘
Introduction @

The first step in the manufacturing process typically Ives creating the stock
material (known as the workpiece) for machinin this process, the size of
the as-designed component is used to det uitable workpiece size. In
this module, you will learn two different gmetho creating workpieces,
providing you with a flexible approach to ce creation. Using workpieces
enables you to create an as-machinsgd,version of the workpiece after the
completion of each NC sequencé; erreviewing NC sequences you can also
view the cutting tool machini rkpiece. When creating workpieces it is
important to know how to m@éte workpiece models and how to select and

modify workpiece ng

Objectives g&\

After com@ S'module, you will be able to:

. @ e purpose of workpieces.

. r NC model assemblies consisting of reference models and
kpieces.

s~/ Create workpieces using the Create Stock dialog box.
» Create workpieces using template parts.

@ « Reorient models and select model geometry.

Page 2-1



Creating Milling Sequences with Pro/ENGINEER
Wildfire

&
) p1C D

The way to Product First™

Instructor Preparation %
Before teaching Creating Milling Sequences with Pro/EN@ Wildfire, you must have read

and thoroughly understood the following materials:

* General Information
* Review Pro/ENGINEER Wildfire primer@ p://rdweb.ptc.com/primer/

+ Pro/E Wildfire Documentation o @
* Review Pro/ENGINEER Wildfi % entation in Windmill, located in
/GS Training Materials/Domain o‘u": reate/ProENGINEER/Core Concepts

* Pro/E Wildfire Milling

* Review Pro/E

/GS Ed Srvcs Operati
/T979-330-Instr

V@Nildfire Milling training materials in Windmill, located in
ducation Library/Instructor Materials/Instructor Kits/EN

* Required&sKkills
. @ yon of Pro/E Wildfire Foundation or equivalent Pro/E skills
e

tion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
ro/E skills

*“Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
* Good understanding of manufacturing processes and terminology
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Lesson Activities: Day One

Reference Model
and Workpiece

p— Croating ProfFICIENCY
Introduction Creating E"S'.".T""'
Lectures Models Operations. v
Assessments
Reviewing Creating Creating
e g eating 9 Creating
[::: Manufacturing the Stock Dialog Models with a -
Models Box General Operatons -1
Assembly 1
" T
Creating 1 Creating
‘ " Manufacturing
using Sketcher Creating Operations - Il
‘ Models with a
| Reference Model
‘ and Workpiece
! )
Reviewing Creating " Creating Creating
p wi A A
Labs Manufacturing the Stock Dialog Models with a Operations - |
Models General
Assembly
Crosting Creating.
Workpieces
using Sketcher Creating O raonesy
Manufacturing L_(Challenge) |
Models with a

\}
D@

- D

Duration
* Lecture: 15 mins
* Demos : 20 mins
* Labs : 40 mins
» Total: 1 hr 15 mins

©©

&

>

&
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Objectives

After completing this module, you should be able to:
Describe the purpose of workpieces.

Create NC model assemblies consisting of reference models and
workpieces.

Create workpieces using the Create Stock dialog box.
Create workpieces using Template Parts.

Reorient models and select model geometry.

\}
D@
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%
Overview @

The first step in the manufacturing process typically involves creatifig the stock material (known
as the workpiece) for machining. During this process the size.of the as-designed component is
used to determine a suitable workpiece size. In this medule, you will learn two different methods
for creating workpieces, providing you with a flexible ach to workpiece creation. Using
workpieces enables you to create an as-machined of the workpiece after the completion
of each NC sequence. When reviewing NC se@ ou can also view the cutting tool

e

machining the workpiece. When creating work it is important know how to manipulate
workpiece models and how to select an<<>j rr@ rkpiece geometry.

After successfully completing this m u will be able to:
* Describe the purpose of work
* Create NC model assembili€s cansisting of reference models and workpieces.

+ Create workpieces usi eate-stock dialog box.
» Create workpieces gsi plate parts.
* Reorient mod ect geometry.

&
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Manufacturing Models — Workpieces

©® Workpieces represent un-machined components
« Stock billet ;
« Castings / / >
~—<\ v,

©® Reference Model + Workpiece = Manufacturing Model

Manufacturing Models — Workpieces %
The workpiece represents the stock material that is going £(Q be ined when creating NC

sequences. The workpiece can be a standard stock billet ort.cati represent a casting.
As stated previously, the reference model and workpieeg are assembled together to form the

manufacturing model. @
&
@\é@
S,
®©
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Manufacturing Models — Workpieces

©® Workpiece
« Optional Component in the Manufacturing Model
©® Workpiece Features
« View the cutting tool machining the workpiece (using Vericut)
« As-machined version of the workpiece after creating each tool path
« No machining outside boundaries of the workpiece (unless specified)

\}
D@

Manufacturing Models — Workpieces %
The workpiece is an optional component within the manufacturi odel.

If you are not concerned with simulating the machining_of th piece or creating an as-
machined version of the workpiece, then you do not n% use a workpiece. (Therefore, the

minimum configuration of a manufacturing assembl
Workpiece features include: @
* Viewing the cutting tool machining the workpieceX(using Vericut).
» After creating each tool path you cag uthe workpiece to show an as-machined version

of the workpiece. \N
* No machining outside boundari orkpiece.

0
* Unless specified gs@?

If a workpiece is not used, equences can still be created using the reference model. Viewing
a simulation of the mac%’ [ cess using Vericut is still possible, but no workpiece is shown.

reference model.)

&
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Creating Workpieces

Two methods

® Create an NC Model Assembly (recommended)
o« Assemble Reference Model

« Create Workpiece
Use the Create Stock dialog box
Specify workpiece size

o Workpiece displayed in green
Semi-transparent

© Create a Workpiece
« Copy a Template Part
« Create the 2-D outline
Use Sketcher
o Extrude the outline
o Workpiece will display in green
Semi-transparent

Creating Workpieces %
There are two methods for creating workpieces: Q ;;
As

* The recommended method is to create an NC Mogdel y:
» The reference model is assembled first.

» The workpiece is created by selecting a def et size and specifying stock
allowances with respect to the reference

» The resultant workpiece is created and o e part of the NC model assembly.
* The NC model assembly can then bé use |rectly when creating the manufacturing model.

* When you assemble or create a % e in a manufacturing model, it is displayed in green.
This helps to see the difference, the reference part and the workpiece geometry.

* The reference part is usuall ed inside the workpiece. If your Display Style
environment is set to Shadi@e workpiece would obscure the reference part. To prevent
this, the workpiece in r@ ring mode is displayed as semi-transparent.

* An alternative t@ to create the workpiece using a template part model.
* First detétpineé 1he size of the reference model.
. Creatgg aw lece by copying a template part.

* Then'create the workpiece geometry by sketching a 2-D outline and extruding an outline
b on the reference model dimensions.

. piece created using this method will display in green when it is assembled into a
manufacturing model.

Advantages of the first method:
* The workpiece size can be determined with direct respect to the reference model
» Changes to the workpiece dimensions update immediately on screen
» The workpiece can be created without knowledge of the Sketcher interface
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Creating Workpieces — Template Parts

Template Parts

® Standard Pro/ENGINEER Parts
o Default Datum Planes
o Default Co-ordinate System
eLayers
o Parameters
o Named Views
o Units

® Common starting point

® Customizable

© Different Templates

o Imperial Units
o Metric Units
« Solid / Sheet-metal

Creating Workpieces — Template Parts %
Template parts are standard Pro/ENGINEER parts that canbe cgpied and used as common
starting point for all parts including workpieces. By default th made up of:

* Three default datum planes X

» Parameters, such as description and dr

* Default co-ordinate system @
« Layers for features @

« A series of named views. <
* Pre-defined units, such as inches iNmetres.
*They provide a common starting p Il designs

*They can be customized to me@gr ers requirements.

*By default different template e available, for example templates with imperial or metric
units and templates for :I egwetry or sheet-metal parts.

&
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Creating Workpieces — Extruded Features

Used to create solid shapes .
'\

Sketching
Plane

Creating Extruded Features

© Determine the reference model size

® Create a part (workpiece) Lo 4—"Crientation

Plane

o Copy Template Part

® Create an Extruded Feature 105100

RONT,

« Select Sketching Plane

210.00
« Select Orientation Plane

TGHT

® Using Sketcher ko500
« Create the outline ]
« Modify the dimensions
« Give the outline depth

AN
B’ o
ﬂ

Creating Workpieces — Extruded Features

Extruded features are used to create solid extruded geometry, a volve sketching and
dimensioning an outline and then extruding the outline to cr lid geometry.

Looking at this method in more detail:
 First determine the reference model size.

» Then create the workpiece by sketching an @@;d on the reference model

dimensions.
This involves: O

» Creating a part, (workpiece), usuaﬂ)%%g)pying a template part.

» Creating an extruded feature wi art.
» An extruded feature is a skefch t thrudes a section perpendicular from a sketching plane

to create a protrusion.

» Here is the process of ¢re the extrude feature:
» Select a sketchj | and a plane to orient the sketch.
» Draw the outli etcher.
* Dimen ill be added automatically.

* Modifyithe dirmensions and complete the sketch.
. D@ the depth, and complete the feature.

You extruded features when you want to create solid shapes within parts.
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Selecting ltems and Editing Dimensions

Pre-selection Highlighting e ®
® Items automatically highlight P //
©® Geometry, Datums, Components EEEE;S
Selection Options H%
© Directly on the model [ — [ = Pick From LiSBE]

® From the model tree 7 ToP FISDRAFT)
£7 FRONT FI4CUT)

i DEFAULT F7(PROTRUSION)
® Querying the model . ig pERAT FRoTRUSOY
. #og? Cutid 40
® Use the query list # @ Promeionid33 3 ok | cancel
)
Editing Dimension 7 BN Dot
diting Dimensions 3 o S T
H “ Round id 470
© Double-click o el Rename
wg? Cutid 529 Edit

® Right-click
«Edit

Selecting and Editing Geometry @ ;;

* Pre-selection highlighting allows you to visually confir % that will be selected
before you select it. As you drag the cursor over the geaphi irdow, selectable items such
as geometry features, datum features, or components ighlighted in cyan. If you leave
the cursor over the item, a ToolTip displays the n&tae of t ighlighted item and it is also
displayed in the Status Bar.

* ltems can be selected directly on the model wh@nlighted, or they can be selected from
the model tree. Alternatively items that ca gsélected directly |.e. hidden items can be

selected by querying the model, this my@! ving the cursor over the required item and

right-clicking the mouse until the degire iS highlighted. A final alternative is to activate
the query list which provides a lis ctable items.

+ Editing items dimensions is possi ouble-clicking the item when highlighted.

* Alternatively when an item is s it turns red by default, any dimensions associated with
the item can then be seen, ight-clicking and selecting edit from the drop down list.
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Orienting Models

Zoom c ® c
e @ -~

Par - [y

Spin J . .

Zoom

Saved Views

Standard Orientation .
View Mode O - \

® Advanced Options

i Top View @
eAnchored
«Delayed Standard Orientation D
« Velocity
Orienting Models Z

* To set the model at the desired orientation, you can spin @he model around the
screen, and zoom in and out using a combination of keyboa d mouse functions.

* You can also save a series of set orientations such.as fr op, and side for later use.

* You can return the model to its default or standa %tation at any time.

* View Mode allows spin/pan/zoom operations i@re-highlighting or selection occurring.
* View Mode also has options such as Anchored, Delayed, and Velocity:

* Anchored: Alternate spin algoritpm g on-screen spin axis.
» Delayed: There is a time delaygt\;ge\S§ en when the spin, pan or zoom is done and the

model orientation updates ‘;- 8 reen, which is useful when working with large
assembly models. @'

* Velocity: You can change the orientation of the model by spinning, panning or zooming at

a controlled speed m reen.
* You can also oyj t reference geometry such as an edges or surfaces with View
Mode.

&
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Managing Pro/ENGINEER Wildfire Files

Files in Memory and Directories
Pro/ENGINEER Wildfire is a memory-based modeling software
Opening files

«Opening CAD models from the hard drive

«Opening CAD models from RAM memory
Setting the working directory

« Saving files to the working directory
Erasing files from RAM memory

eErase - Current

e Erase - Not Displayed
Deleting files from the hard drive

o Delete - All Versions

eDelete - Old Versions

Slide 11 /T B02PTC
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Managing Pro/ENGINEER Wildfire Files

* Pro/ENGINEER Wildfire is a memory-based modeling saoftware, which means that files you
create and edit are stored within RAM memory ww working on them.

* Initially, all files are opened from the computer ./ dfive or network storage area.
* The files are now stored within RAM mem continue to be stored in RAM memory as

you create/edit them, and re-open the
o

« Setting your working directory is i% t because all Pro/ENGINEER Wildfire files are

saved to that location on your e or network storage area.

while you create/edit t

* The files are now storedii@iAM memory and continue to be stored in RAM memory

* Files are not save outr’hard drive or network storage area until you explicitly save them.

» Erasing model&frofm memory is important because they are stored in RAM memory until you

es that have the same name but are in various stages of completion such as in

either er%ihe or exit Pro/ENGINEER Wildfire. This is especially important if you are
fil
e

e

+ Deleting files permanently removes them from the working directory on

workin
this @ ~Erasing models does not delete them from the hard drive or network storage

your hard drive or

network storage area. Be careful when deleting files because you cannot undo deleted files.
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Demonstrations

In this module, you will follow the instructor as they perform the
following demonstrations:

® Creating Workpieces with the Stock Dialog Box
® Creating Workpieces using Sketcher

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercises.

\}
D@
— o~

Demonstrations: %
» Creating Workpieces with the Stock Dialog Box
» Creating Workpieces using Sketcher

Scenario @5\
» Throughout this course, the exercise scen@ he same as the demo scenarios.
n

* This has been done to build consistenc demos and lab exercises so as to enable
“Tell mle—Show me—Let me do.” ¢

Method @
Use the script in the instructors@id se the same models as in the exercises.

Exercise

Once the demo is «1@- {he students should use the steps in the training guide to complete
the exercises.

&
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Summary

After successfully completing this module, you should know how to:
® Describe the purpose of workpieces.

® Create NC model assemblies consisting of reference models and
workpieces.

® Create workpieces using the Create Stock dialog box.
® Create workpieces using Template Parts.

® Reorient models and select model geometry.

AN
SO
- D

Summary %
After successfully completing this module, you should kn :
» Describe the purpose of workpieces.
» Create NC model assemblies consisting of refere N dels and workpieces.
» Create workpieces using the create-stock dlalo
» Create workpieces using template parts.
* Reorient models and select geometry. @

\
Koy
W
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Exercise 1: Creating Workpieces using the Stock Dialog Box

Module 2 Lab Exercises

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \

e Practice running the demo so you can easily complete it. @
» Check for and review the errata sheet for this course. @
» Use Pro/ENGINEER Wildfire build code 2003051 or later.

« Download and install the class fileswi | df i re_m | | i n%&a I. 9z as described in

the classroom setup notes.

Introduction

In this demonstration, you will show the recomm Xyethod for creating workpieces. This

involves creating an NC model assembly an %g a reference model, then creating a
workpiece using the Stock dialog box. ative method will be demonstrated in the next

An 3
exercise. The ability to create work&g different methods provides you with a flexible

approach to workpiece creation.

Using workpieces enables you te an as-machined version of the workpiece after the
completion of each NC sequenge. When reviewing NC sequences, you can also view the cutting

tool machining the warxkpigse.

Objecti @

After succes completing this exercise, you will know how to:

. @ NC model assemblies consisting of reference models and workpieces.

ate workpieces using the Create Stock dialog box.

cenario

You need to create the workpiece before you can machine the aluminum cover; this is typically
the first step in the manufacturing process. The recommended method for creating workpieces
involves creating an NC model assembly, assembling the reference model and creating the
workpiece using the Stock dialog box.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 2-3



Figure 1: The underside view of the aluminum cover. ((\\
(@

Step 1. Create a new NC assembly for the aluminum cover; assemble in
the reference model.

the alum%r as

We need to create the workpiece before we can machine the aluminum cocal/y the

first step in the manufacturing process. We use the recommended metho% reating

workpieces, this involves creating an NC model assembly, assembl|

creating the workpiece using the Create Stock dialog box. Befo
should load a configuration file to ensure that the workpiec%a

models in the exercises have metric units.
1. Inthe navigator, select the Folder Browser tab, @ws’e to

Directory.

erence model and

te any models we

with metric units, as all our

c:\users\student\wiIdfire_mfg_33(2>\m® , right-click, and select Make Working

2. Before creating any models load th@&a@%@tion file, config.pro. Click Tools > Options,

use the Open a Configuration Fi d select the config.pro file from the module02
folder. Then Apply and, Closié the\Options dialog box.

Note: @

configuratio, s workpieces are created with metric units.

By default Pr(o/l@l? creates workpieces with imperial units, loading the
ilegn

3. Create a NC miodel assembly, click File > New, select the Assembly and NC Model
me the assembly [cover nc]. When prompted select the cover.prt model

option
%n t@, (this assembles the reference model).

Step\& Create the workpiece using the Create Stock dialog box.

The Stock dialog box allows us to create bar stock and billet stock. We can create stock using

standard size billets, or we can create our own custom size, alternatively we can add material

allowances to the size of the reference model.

In this case, we create our own custom size; notice the default values for length, width, and

thickness are the dimensions of the reference model, so it is easy to calculate suitable stock

Page 2-4

Creating Workpieces



(Cb PTC

dimensions. Notice also that the workpiece is green and semi-transparent. This helps to see the
difference between the reference model and the workpiece geometry.

1. Using the Menu Manager, select Create Stock. In the Setup Stock dialog box, create the
stock using the Custom stock instance option and enter the following dimensions, length

[133. 0] (5.24 in.), width [38. 0] (1.50 in.), and thickness [108. 0] (4.25in.). Then close
the dialog box.

Setup Stock

Stock Name | COVER_NC_WRK
(+) Default Billet Stock Instance
) Default Bar

| \
() - Custom hd
() Other E | v @@

Length  |133.000000
Width 38000000 \
Thickness [108.000000) (C~
P Allowances... !! !!
P tdodify Qutline...
Undo | g@}}’ Undo All |
(0] Cxticel ‘ Preview]
&

reate Stock Dialog Box

2. Click File > Save to save (e NG odel assembly.

3. Click Window > CIo ose all windows.

4. Click File > @ot Displayed > OK to erase all components from memory.

&

Figure 3: Cover NC Model Assembly

Note:

When you assemble or create workpieces in manufacturing mode, they are
displayed in green and shown as semi-transparent. This helps to see the difference
between the reference model and the workpiece geometry.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 2-5
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Exercise 2: Creating Workpieces using Sketcher

Introduction

In this demonstration, you will demonstrate an alternative method for creating workpieces. This
involves creating a workpiece by sketching an outline based on reference model dimensions. The
ability to create workpieces using different methods provides you with a flexible approach to

workpiece creation.

Objectives @\
After successfully completing this exercise, you will know how to: @

» Create workpieces using Sketcher.

Scenario
You need to create a workpiece for the mold cavity. You will use an a %e method that
involves creating a part and sketching an outline based on the di siops of the reference

model, in this case the mold cavity. \

N@ Figure 4: Mold Cavity

(N
Step 1. Open the yﬁ@gﬁ@é)nd determine its size.

We need to create a biece for the mold cavity. We use an alternative method that involves

creating a pa d sketching an outline based on the dimensions of the reference model, in this

case, the ‘ :a ity.

We first open the mold cavity part.

Determining the dimensions of this model will provide us with an excellent opportunity to learn
how to select geometry on models and manipulate and orient models on screen. These are

essential skills when working with models.
First, we learn how to select geometry.

Notice how different pieces of geometry pre-highlight as we move the cursor over the model. We

can move the cursor over the bottom of the model until the main protrusion highlights in pale blue.

Page 2-6 Creating Workpieces
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We can double-click the geometry to see the dimensions. Having noted the size of the mold

cavity, we can select the background to de-select the highlighted geometry.

An alternative method is to select the geometry from the model tree. This can be achieved by
selecting the first protrusion in the model tree; notice how the same geometry highlights on
screen. We can right-click and select Edit from the drop down list; this will make the dimensions

of the selected piece of geometry display.

A third alternative is to move the cursor over the model again and select the geometry; notice
how the selected geometry changes color to red, and the protrusion is highlighted in mogel
tree. We can right-click and select Edit from the drop down list, this will make tRe.dimgnsions of

the selected piece of geometry display.

You should practice selecting geometry on the model during this exeb@.

1. Click File > Open to open the MOLD_CAVITY.PRT m de%

2. Move the cursor over different pieces of geometry ithe m move the cursor to the bottom
of the model and double-click on the (F5) PRO display the dimensions as shown
in the following figure. Make note of the dlmensm for future reference.

Figure 5: Mold Cavity Dimensions

ote:

< ice how different pieces of geometry highlight as you move the cursor over the
odel. Each piece of geometry corresponds to a different feature in the model.

De-select the highlighted geometry by clicking in the background of the graphics window.

4. Practice showing dimensions of other features by double-clicking on other pieces of geometry
in the model. De-select each piece of highlighted geometry by clicking in the background of
the graphics window.

5. Select the first protrusion listed in the model tree, then right-click and select Edit from the list.
Notice how the protrusion geometry highlights on the model and the protrusion dimensions
are displayed.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 2-7
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6. De-select the highlighted geometry by clicking in the background of the graphics window.

7. Practice this technique by selecting other features in the model tree. De-select each piece of
highlighted geometry by clicking in the background of the graphics window.

8. Move the cursor over the model until the F5 (PROTRUSION) highlights, and then select the
feature. Without moving the cursor, right-click and select Edit from the list. Notice how the
protrusion geometry highlights on the model and the protrusion dimensions are displayed.

9. De-select the highlighted geometry by clicking in the background of the graphics window.

Note:

You have now learned three techniques for selecting geometry and showin de
dimensions. You can select geometry on the model, then double-click, or rig SR
and edit to see dimensions, or you can select features in the model tree an
click and edit to see dimensions.

>
\«J)

Step 2. Learn how to rotate, zoom, and pan a model in the graphics.wi

All view manipulation and orientation can be accomplished by u theymiddle mouse button.

To rotate the model, middle-click and drag the model. The Nwill update as we move the

mouse.

To zoom the model, press CTRL, middle-click and model up and down.

To turn about an axis normal to the graphic@wipress CTRL + middle-drag left or right.

To pan the model, press SHIFT, middle- drag the model.

The benefit of this functionality is t@ now quickly orient models using the middle mouse

button. To return the model to itas orientation we set the view to default using the drop-

down saved view icon at oljthe screen.
You should practice pfie the model on the screen during this exercise.
You should refer to ick reference guide for information on selecting geometry and

orientating moqgls.

1. r ove the cursor over the model and middle-drag.
2. Toxgom, move the cursor over the model, press CTRL + middle-drag up or down.

3. Toturn about an axis normal to the graphics window, move the cursor over the model, press
CTRL + middle-drag left or right.

4. To pan, move the cursor over the model, press SHIFT + middle-drag.

5. To return to the default view click on the Saved View List icon in the toolbar and set the view
to Default.
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6. Practice the rotate, zoom, and pan techniques until you are comfortable with them.

Note:

You can always refer to the printed Quick Reference guide to remind you of the
rotate, zoom and pan techniques.

7. Click Window > Close to close the window when finished.

Step 3. Create a new workpiece part for the mold cavity, by creating an extruded block t
represent the stock material. )

We are ready to create the workpiece by creating a new part; this provides us wij %e nt
opportunity to learn how to sketch shapes using the Sketcher tool. This imgertarixkill'can be
used when creating workpieces and also when creating other types of ge o@. uch as mill

windows and mill surfaces. @

We start by creating a new part. It's a good idea to relate the p the reference model; in
this case we name it ol d_cavi ty _wp. We do not use tRe_default template because this
creates a part with imperial dimensions; instead we choo eate a part with metric units,

achieved by selecting mmns_part_solid as our terplate part.

Template parts are useful because they allow 4s t tomize the content of new parts with items
such as specified units, layers, and named @

Notice how the part appears on scrgx atum planes and a co-ordinate system already
created. We can now sketch our %

block by using the extrude tool. We decide to sketch

our block outline on the front ane.

Working in the Sketche e@ment enables us to sketch the shape we want to extrude. We can

itio symmetrically about the right and front datum planes. At this point

we can modify and position of our rectangle. We need to make the overall width and

ppSitioned about the datum planes. We can complete the sketch and enter a value

symmefrical
of 4i. r the depth of the block. When satisfied with the modifications, we can complete the

e d block.

Click File > New and create a new part called [nmol d_cavi t y_wp]. Clear the Use Default
Template check box, click OK, and use the mmns_part_solid template.

Note:
Using the mmns_part_solid template creates a part based on metric units.

2. Turn on the display of datum planes by toggling the Datum Planes On/Off icon.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 2-9
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3. Create an extruded block larger than the mold cavity. Click the Extrude Tool icon on the right
side of the graphics window. In the dashboard, click the Activate Sketch icon to start the
Sketcher tool. Select the TOP plane as the sketching plane.

Note:

Notice the RIGHT default datum plane is automatically selected as the right
orientation reference. There is no need to select an orientation plane for the sketch.

4. Click the Sketch button to begin sketching.

5. Close the References dialog box and accept that not enough references have been \
specified.

6. Create a rectangular outline approximately symmetrical about the datum planown.
hesketc

Modify the dimensions to the values shown in following figure, and complete t h.
7. Click the Saved View List icon at the top of the graphics window and se@ Default view.

8. In the dashboard, make the depth of the block [45. 0] (1.77 in.)y plete the feature.

e 214,00 S

@ Jan: T
- 105.00

Figure 6: Sketched outline with dimensions.

Q)
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Figure 7: Extruded block to a depth of 45.0 (@.}.

9. Click File > Save to save the model. %

10. Click Window > Close to close all windows

11. Click File > Erase > Not Displayed > OK t%e all components from memory.

&@Q
@@@

Q)
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Summary

After successfully completing this module, you should know how to:

» Describe the purpose of workpieces.
« Create NC model assemblies consisting of reference models and workpieces.

» Create workpieces using the Create Stock dialog box.
» Create workpieces using template parts.
* Reorient models and select model geometry. @\

\
&
O

0
2
S

Q)
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Module

Creating Manufacturing Models

\‘
Introduction @

The next step in the manufacturing process involve ating manufacturing
models. Manufacturing models typically consist a@ence model, and a
workpiece assembled together. You can cr t%.lfacturing models using two
different methods, depending on your requi . Manufacturing models are
essential to the manufacturing process; ¢ ining reference models,

workpieces, and all the other elements that make up the manufacturing process
such as fixtures, operations, an ences.

Objectives @
After completing thf% you will be able to:

ents that make up manufacturing models.

» Describe t
e Createma turing models by assembling an NC model assembly.
e Cr @

kpiece.

ufacturing models by assembling a reference model and

Page 3-1
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Module 3: Creating Manufacturing Models

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

Before teaching Creating Milling Sequences with Pro/E@R Wildfire, you must have read
and thoroughly understood the following materialx

* General Information @
* Review Pro/ENGINEER Wildfire prime@ ttp://rdweb.ptc.com/primer/
* Pro/E Wildfire Documentation < @

* Review Pro/ENGINEER Wildfi ocumentation in Windmill, located in
/GS Training Materials/Domain Kn@dge/Create/ProENGINEER/Core Concepts

@ildfire Milling training materials in Windmill, located in

Education Library/Instructor Materials/Instructor Kits/EN

* Pro/E Wildfire Millin

* Review Pro/EN

/GS Ed Srvcs Operati
/T979-330-Instruct

* Requir %
. oe@on of Pro/E Wildfire Foundation or equivalent Pro/E skills

. pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day One

Creating Creating Pro/FICIENCY
Introduction  [==ms{ | Creating i ey =l Daily
P! Models .| Operations | | |Assessments
T T T
Reviewing Creating Croat " ||
Demos Completed Workpieces with reatng. Creating
Manufacturing -] the Stock Dialog Models with & ng
Models Box Conoral Operations - |
1 Assembly l
Creating -
Creating
Workpieces Manufacturing
using Sketcher Creating Operations -
Models with a
Reference Model
and Workpiece
Reviewing Creating Creatin
) ith g Creating
Labs Manufacturing the Stock Dialog Modolo with o hanufacturing
Models Box General P 1
L Box |
i Assembly i
N N
Creating
Creating
Manufacturing
Workpieces !
using Sketcher Creating Operations - I
Models with a
Reference Model
and Workpiece

Duration
* Lecture: 20 mins
* Demos : 20 mins
 Labs : 30 mins
» Total: 1 hr 15 mins
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Objectives

After completing this module, you should be able to:
Describe the components that make up manufacturing models.
Create manufacturing models by assembling an NC model assembly.

Create manufacturing models by assembling a reference model and
workpiece.

AN
o)

@

Overview %
The next step in the manufacturing process involves creatin facturing models.

Manufacturing models typically consist of a reference model, gnd a workpiece assembled
together. You can create manufacturing models usirg\two different methods depending on
your requirements. Manufacturing models are essenti the manufacturing process,
containing reference models, workpieces, and all er elements that make up the
manufacturing process such as fixtures, oper d NC sequences.

After successfully completing this module, @ be able to:
* Describe the components that make ufacturing models.
 Create manufacturing models b Iing an NC model assembly.

» Create manufacturing models bmbling a reference model and workpiece.

N

Q)
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Manufacturing Models

Simple Configuration

Reference Model + Workpiece = Manufacturing Model

Optional Configurations
Multiple Reference Models and Workpieces

o Workpieces optional

o)

Manufacturing Models @

Manufacturing models typically consist of a reference m\%@%gsenting the final designed

component) and a workpiece assembled together. The pigce represents the un-machined
stock material.

machined version of the workpiece, then you need to use a workpiece. Therefore, the

If you are not concerned with simulating the m@@?ﬁ the workpiece or creating an as-
n
minimum configuration of a manufactu@ng ly is one reference part.

Depending on your machining nee g%;manufacturing model can be an assembly of any
level of complexity, and can cont i@humber of independent reference models and
workpieces. It can also contain @ omponents that may be part of the manufacturing
assembly, but have no direct n the actual machining process (for example, fixtures or
clamps).

Manufacturing m areessential to the manufacturing process, containing reference
models, workpieces all the other elements that make up a manufacturing process such as
fixtures, operations, and NC sequences.

Q®
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Creation Methods

Recommended method
Assemble an NC Model Assembly

e Consists of a Reference Model and Workpiece

eResulting Structure . Example Filenames

o : [ covermre |HTTCOVERASH
Manufacturing Model | anutacturing

i..Model Assembly_ i

COVER_NC.ASM
NC Model Assembly
[ coverpPrT | [ cOVER NG WRKPRT |
Reference Workpiece

Model Model

Slide 5 ©2002

Creating Manufacturing Models %@
There are two methods for creating manufacturing models.
cr@

The recommended method is to assemble a previougly NC model assembly. The NC
model assembly can be retrieved directly into the manufacturing model, there is no need to

position components within the assembly, and the (‘a dels are automatically classified correctly
as a reference model and a workpiece model. @"

When a manufacturing model is created in thi it consists of the following separate files:
* The manufacturing model, often cal{ed terocess file, contains all the manufacturing
process information such as oper ceII and NC sequence information. It has the

format ”manufacturing model

» The manufacturing assembly t@ is created automatically and stores the assembly
information for the manufactigri d
name”.asm

el. It has the format “manufacturing model
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Creation Methods

Alternative method
Assemble a Reference Model and a Workpiece

o Assemble Reference Model
o Assemble (or Create) Workpiece

. Example Filenames

| MOLD_CAVITY.MFG |— MOLD_CAVITY.ASM \
|
| | >

Reference | | Workpiece [ moLp_caviry.prT | [ moLD_caviTy_wp.PRT/ {
Model Model

Slide 6 ©2002

Creating Manufacturing Models %@

An alternative method is to create the manufacturing maodel embling a reference model,
and then assembling (or creating) a workpiece.

The reference model is retrieved first and the workp&Rmodel is positioned relative to the

reference model. @?
The diagrams shows the resulting structure, a ple file names.
When a manufacturing model is created in thi ; it consists of the following separate files:

» The manufacturing model - often callgo process file, contains all the manufacturing
process information such as oper orkcell, and NC sequence information. It has the
format "manufacturing model %.mfg

» The manufacturing assembly~ cfégted automatically and stores the assembly information
for the manufacturing modekult kas the format “manufacturing model name”.asm

* The design model - 4 format “reference model name”.prt.
* The workpiece - it h g format “workpiece model name”.prt.

&
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Assembling the Workpiece

Method Details
® Workpiece positioned relative to the reference model
® Using Assembly Constraints

e Align

Coincident MATE
Offset

o Mate
Coincident @

_’I OFFSET

Offset
o Co-ordinate System

elnsert

e Default 2 ® ¢
aan, =
-~ ® ~

Assembling the Workpiece %
To assemble the workpiece you need to uniquely config@ ition of the workpiece

relative to the reference model.
This is achieved by using a series of assembly cons

+ Align: Used to make two selected surfaces fac
be coincident or offset from each other by

» Mate: Used to make two selected surfaces €’in the opposite direction. The surfaces
can be coincident or offset from each o"@ by a distance.

» Co-ordinate system: make two sefggted.co-ordinate systems coincident.

* Insert: used for shafts and hole . an insert a shaft into a hole. The hole and shaft axis
become co-axial.

* Default: place the work;@ e center (default position) of the manufacturing model.

@6

ints.
same direction. The surfaces can

&
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Demonstrations

In this module, you will follow the instructor as they perform the
following demonstrations:

® Creating Manufacturing Models with NC Model Assemblies.
® Creating Manufacturing Models with a Reference Model and Workpiece.

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercises.

QO

Demonstrations: %
* Creating Manufacturing Models with NC Model Assembli
* Creating Manufacturing Models with a Reference Mo Workpiece.

Scenatrio @‘\

* Throughout this course, the exercise scenafios\are the same as the demo scenarios.

* This has been done to build consistgnc@ en demos and lab exercises so as to enable
“Tell me—Show me—Let me do.” X

Method

Use the script in the instructo&@e, use the same models as in the exercises.

Exercise

Once the demo is¢¢0 the students should use the steps in the training guide to complete

the exercises.

&
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Summary

After successfully completing this module, you should know how to:
© Describe the components that make up manufacturing models.
® Create manufacturing models by assembling an NC model assembly.

® Create manufacturing models by assembling a reference model and
workpiece.

QO

Summary %
After successfully completing this module, you should know :

» Describe the components that make up manufacturin els.
+ Create manufacturing models by assembling an odel assembly.
» Create manufacturing models by assembling a nce model and workpiece.
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Exercise 1: Creating Manufacturing Models with NC Model
Assemblies

Demonstration Instructions
Preparation \ S)
Complete the following tasks before running this demo for customers: @Q

Module 3 Lab Exercises

e Practice running the demo so you can easily complete it.
» Check for and review the errata sheet for this course. @
» Use Pro/ENGINEER Wildfire build code 2002380 or lat %

» Download and install the class files wi | df i re_ni NN ng/) 330. t ar . gz as described in

&

Introduction @
In this demonstration, you will show&he@ ended method for creating manufacturing
n

the classroom setup notes.

models. This involves creating a g model and assembling a previously created NC
model assembly consisting of %e model and a workpiece. As the assembly is retrieved
into the manufacturing mo ?@erence model and workpiece are automatically classified
correctly. An alternativ g@will be demonstrated in the next exercise. The ability to create
manufacturing m different methods provides you with a flexible approach to

machining.

Manufactu mggels are essential to the manufacturing process, containing reference models,

workpﬁs and all the other elements that make up a manufacturing process such as fixtures,
o

bjectives

and NC sequences.

After successfully completing this exercise, you will know how to:

» Create manufacturing models by assembling NC model assemblies.

Scenario

The next step in the manufacturing process typically involves creating manufacturing models. In
this exercise, you create a manufacturing model for the aluminum cover. You use the

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 3-3
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recommended method for creating manufacturing models; this involves creating a manufacturing
model and assembling a previously created NC model assembly consisting of a reference model
and a workpiece.

&

%@

Figure 1: The default view of the NC model assembl inum cover.

Step 1. Create a new manufacturing model for the alumiMer.
U

We can now create the manufacturing model for the ir@)vcover. We use the recommended
method for creating manufacturing models. We s réating a manufacturing NC assembly
for the aluminum cover; a sensible naming 8&

manufacturing model cover . &

1. In the navigator, select the Fol B er tab, and browse to
c:\users\student\wildﬁ@ 30\module03, right-click, and select Make Working

should be used, so name the

Directory.

2. Create anewm f@ g model for the aluminum cover, click File > New, select the
Manufacturi d NC Assembly options, and name it [cover ].

Step 2. Assemple in the aluminum cover NC model assembly as a general assembly.

We ca n@ ble the previously created NC model assembly containing the aluminum cover
andthe ece for the cover. Using the Menu Manager, we can assemble a general

asse , from the list of files select cover_nc.asm. Notice when the assembly is retrieved into
the manufacturing model; the reference model and workpiece are automatically classified

correctly.

1. Using the Menu Manager, select Mfg Model > Assemble > Gen Assem, and assemble
COVER_NC.ASM into the manufacturing model.
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—— COVERASM -—— Manufacturing Model Assembly

e Manufacturing Model

COVER.MFG

L+ COVER_NC.ASM ———— — NC Model Assembly

COVER.PRT |«—— Reference Model

COVER_WRK.PRT -¢—— Workpiece Model

Figure 2: Resulting model structure and filenames. @\
2. Save the manufacturing model. @

3. Close all windows and erase all components from memory. S
(>
\Y%

NZ

Hint:
Click File > Erase > Not Displayed > OK, to era%@ponenm from

‘0
O

0
2
S
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Exercise 2: Creating Manufacturing Models with a Reference
Model and Workpiece

Introduction

In this demonstration, you will use an alternative method for creating manufacturing models. This
involves creating a manufacturing model by assembling a reference model, then assembling a
workpiece. The ability to create workpieces using different methods provides you with a flexibl
approach to workpiece creation. X

Objectives @Q

After successfully completing this exercise, you will know how to:
« Create manufacturing models with a reference model and a workpinz%@

Scenario
You need to create a manufacturing model for the mold ca%u use an alternative method
ONS.

that involves creating a manufacturing model by assembl erence model (the mold cavity),
then assembling a workpiece.

AN

Step 1. Create a manufacturing model for the m/old\(}a\N{ty.

&
We can create the manufacturing model fqr th%wcavity using an alternative method. We start
by creating a manufacturing NC assem ?. mold cavity; a sensible naming convention
should be used so name the manufactti @' odel nol d_cavity.
Using the Menu Manager we @@bm a reference model, from the list of files select

mold_cavity.prt.

We can now assemfile kpiece; from the list of files select mold_cavity _wp.prt. Notice

how the workpiece egrs next to the reference model in the graphics window.

To assemble the\workpiece we need to uniquely configure the position of the workpiece relative

to the ref model. This is achieved by creating positioning constraints.
We e sure co-ordinate systems are visible before configuring any constraints.

To create our first constraint we select the DEFAULT co-ordinate system on the reference model
and the PRT_DEF CSYS co-ordinate system on the workpiece. Pro/ENGINEER Wildfire
automatically assumes these co-ordinate systems will be coincident. This is the only constraint
we need. The workpiece has been positioned correctly and we can complete the assembly

process.
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1. Create a new manufacturing model for the mold cavity, click File > New, select the
Manufacturing and NC Assembly options, and name it [nol d_cavi t y].

2. Turn on the display of datum co-ordinate systems, if not already visible in the graphics
window.

3. Using the Menu Manager, select Mfg Model > Assemble > Ref Model and assemble the
MOLD_CAVITY.PRT as the reference model.

4. Inthe Mfg Model menu, select Assemble > Workpiece and select the
MOLD_CAVITY_WP.PRT as the workpiece.

5. Inthe Component Placement dialog box, change the constraint type from A@c to
CO |

Coord Sys, then select the co-ordinate system on the workpiece an :}- inate system

on the reference model, as shown in the figure below.
6. Complete the component placement, and return to the Manufa enu.

DEF

bl

Figure 3: Referennd workpiece showing co-ordinate systems selected.

@ Figure 4: Reference model and workpiece after assembly.
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MOLD_CAVITY.MFG |- Manufacturing Model

—— MOLD_CAVITY.ASM «¢————— Manufacturing Model Assembly

MOLD_CAVITY.PRT -¢——— Reference Model

MOLD_CAVITY_WP.PRT -—— Workpiece Model

Figure 5: Resulting model structure and filenames.
7. Save the manufacturing model @\
8. Close all windows and erase all components from memory. @

%@

>
Q
O
N
B
S
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Summary

After successfully completing this module, you should know how to:

» Describe the components that make up manufacturing models.
« Create manufacturing models by assembling an NC model assembly.

» Create manufacturing models by assembling a reference model and workpiece.

@Q\%
@
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Module

Creating Manufacturing Operations

\‘
Introduction @

The next step in the manufacturing process involve figuring manufacturing
operations. Manufacturing operations are creat b@iguring a number of
required elements such as the type of macki %workcell), and the machine
zero position. In addition, a series of optiqnal nts can be configured, such
as the retract surface, workpiece materia ixtures. Once an operation is
configured, NC sequences can be created that reference the operation’s specific

machine tool (workcell) and ma position. It is important to understand
why each element in an ope&@ quired and when it is appropriate to

configure optional elements:

ectives O
Objectives \
After completidule, you will be able to:

» Describe the€lements that make up manufacturing operations.

. @ye selected elements of manufacturing operations.

Page 4-1



Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 4: Creating Manufacturing Operations

& PTC@Q
@

Instructor Preparation

Before teaching Creating Milling Sequences with Pro/ENGl@ldﬁre, you must have read and
thoroughly understood the following materials:

* General Information
* Review Pro/ENGINEER Wildfire primer site at @?Meb.ptc.com/primer/

* Pro/E Wildfire Documentation
* Review Pro/ENGINEER Wildfire
/GS Training Materials/Domain Knowledge

‘0°

+ Pro/E Wildfire Milling @
* Review Pro/ENGINEm e Milling training materials in Windmill, located in
/GS Ed Srvcs Operations/ ation Library/Instructor Materials/Instructor Kits/EN
/T979-330-Instructor Kit-

tion in Windmill, located in
te/ProENGINEER/Core Concepts

* Required SKi

» Completion.of Pro/E Wildfire Foundation or equivalent Pro/E skills

* OB n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E
Hjty to install and configure Pro/E Wildfire

+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Creating Creating ProlFICIENCY
oot Introduction === wi:f(“";‘:es ] i | A Ev;::"mr
fos P Models Operations A y
ssessments
T T T
| | |
! ! !
J & N
Reviewing Creating Creatim
‘with 9 Creating
Manufacturing |~ the Stock Dialog |- Mouels with cturin -
| Models | Box °G: :avr'al a Operations - |
i S Assembly
! Creating 1 Creating
} using Sketcher Creating. 'g:’.‘:‘_f:z‘r“‘:'_"ﬁ
‘ Models with a
{ Reference Model
I and Workpiece
L 1
Reviowing Creating Creating Creating
ieces With |--r{ a X
Manufacturing the Stock Dialog Models with o n
Models [~ Box [ il Operations -1 |
T Assembly
Creating | Creating.
Workpieces " oturin
using Sketcher Creating 0(!::":;:;:::9)"
Models with a
Reference Model
and Workpiece

Duration

Lecture: 15 mins

* Demos : 25 mins
Labs : 50 mins
Total: 1 hr 30 mins
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Objectives

After completing this module, you should be able to:
© Describe the elements that make up manufacturing operations.

® Configure selected elements of manufacturing operations.

QO

Overview %
The next step in the manufacturing process involves configuring turing operations.
Manufacturing operations are created by configuring a numb f required elements such as the type of
machine tool (workcell), and the machine zero position. I series of optional elements can
be configured, such as the retract surface, workpiece m and fixtures. Once an operation is
configured, NC sequences can be created that referen peratlon s specific machine tool
stand why each element in an operation is
e em

(workcell) and machine zero position. It is importan
required and when it is appropriate to conflgure o} ents.
, . &
After successfully completing this modul e able to:
* Describe the elements that make u cturing operations.
» Configure selected elements of m uring operations.

@@
©&
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Manufacturing Operations

©® Manufacturing Operations
« Configurable elements
«NC Sequences

©® Example manufacturing operation to machine one side of a component

® Manufacturing Operation contains:
o Machine tool (workcell) configuration
Tools
e Machine zero co-ordinate system
o Retract surface/plane
o Fixture set up
«NC Sequences
Face mill top of component
Profile mill outer walls
Rough out pocket
Finish pocket
Drill holes

Manufacturing Operations %
Manufacturing operations are made up of a number of configurab ents such as machine tools,
machine zero positions, and fixtures.

They also contain NC sequences that reference the configured machine tool (workcell) and the defined
machine zero position.

For example, you can create an operation to machine e of a component.
The operation consists of a number of configured s such as:
* The machine tool (workcell) configuratign. @

» The machine zero position (configure vﬁ&
the x,y and z axis on the machine took
etween NC sequences.

A retract surface which the tool re

-ordinate system) - this also defines the direction of

* A fixture set up - in this case a@ embly.
NC sequences can then be cre t machine the component. These sequences all reference the
machine tool and the machi ergoposition. NC sequences cannot be created until the manufacturing

operation is configured.

In summary, manufastdring operations are defined as a series of NC sequences performed by a
specific machine@nl (Waftkcell) and referencing a specific machine zero position.

Q®
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Manufacturing Operations

Configurable Elements

Required and Optional Elements
@ FADAL_WMC

. 3{« MACH_CSYS_OP010
Required Elements ) OPD10 [FADAL_YMC]

Operation Name
Workcell (Machine Type)
o Workcell Name ‘5 —
Number of Axes

- i
e oo
ACH CSYS OPOT0
o Workcell Parameters

o PPRINT Table
Information in CL Data files .
e Associated Tools Optional
e Associated Site Parameter Files
Machine Zero Position g)
©2002

Manufacturing Operations
The configurable elements within a manufacturing operation, can %ed into required and optional.
Required Elements

» Operation name - when configuring an operation yofk%9 provide a name for identification.

* Workcell (Machine Tool) - You must configure th Il to be used, there are many options,

that can be configured within a workcell
* Workcell Name @
Workcell Type - this can be Mill, L th rn, or Wire EDM.
* Depending on the workcell ty fx ber of axes can be specified
* For Mill—3 Axis (default), 4 A % Axis.
« For Lathe—1 Turret (def @ Turrets.
e For Mill/Turn—2 Axis @ 4 Axis, or 5 Axis (default).
* For Wire EDM--2 AxisX{default) or 4 Axis.
Optional Workce

Workcell P there are numerous parameters such as
» Tool trav

o Workcell Type

Slide 5

T table - enables machining information such as ‘operation name’ to be output into
a files. The table uses yes/no flags to determine if the information is output.

Anys tools created can be associated with a specific workcell (machine tool)

If a global site parameter file has been created it can be associated with the workcell. Site
parameter files control the default manufacturing parameter values used in NC sequences. For
example, you could set the default spindle speed.

* The machine zero position is configured by creating or selecting a co-ordinate system. It acts as
the origin (0,0,0), for CL data output, and defines the direction of the x,y and z axes.

* Maxigrum spihdle speed
. e of the default post-processor associated with the machine.
e

a
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Manufacturing Operations

RETRACT_OPO10.

Key Optional Elements et o

® Retract Surface/Plane
o Retract Height

® Fixtures
o Hold Workpiece

® Stock (Workpiece) Material
o Material Cutting Data

® From and Home Points

Key Optional Elements %
Here are some of the more important optional elements:

* The retract surface (or plane) specifies the level to which\the fool retracts to between machining.
It can be created during the configuration of the oper%r er when creating an NC sequence. It

is created by creating an infinite datum plane in the acturing model.
* Fixtures are parts or assemblies that help orient a@lﬂ the workpiece during a manufacturing
operation. They are useful because they can ily-activated and de-activated.

+ If you specify the stock (workpiece) mat -lm can automatically load in cutting data that will
set default values for spindle speed, cuttin n@o cutting depth, and tool step over.
e%

* If configured, From and Home poin as start and finish positions for NC sequences.

S
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Create a manufacturing operation for the aluminum cover

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

QO

Demonstration: %
+ Create a manufacturing operation for the aluminum cqver.

Scenario X
+ Throughout this course, the exercise scenarios@}g same as the demo scenarios.
e

* This has been done to build consistency b mos and lab exercises so as to enable
“Tell me—Show me—Let me do.”

O
Method Q
Use the script in the instructors guide, ‘r.’: ame models as in the exercises.

Exercise

Once the demo is complet th@g&ents should use the steps in the training guide to complete the
exercises.

Q)
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Daily Skill Checks

Evaluate your progress:
® Achieve the course objectives.
® Use Pro/FICIENCY assessment questions.
® Apply Precision Learning.

QO

Precision Learning %e
* Learn: by listening to lectures, watching demos, and completi Xercises.
» Assess: your progress with Pro/FICIENCY.

* Improve: The next day the instructor reviews the exa esults of the group and reviews those
topics that received the fewest correct answers.

Getting Started @
» Before lunch on the first day of class, S@t customer accounts.

* When the customers are returning fr fer them to the new Appendix.
* Have them take the sample exam
* Review the results of the grou @ p’as an icebreaker.

Daily Tests @
Description: For each 00\.@ w 10 question exams based upon the topics covered each day.

How to use it:

* Use the cust@gmer atcounts already setup for the sample exam.

* Atthe e %@h day the customers take the 10 question exam relating to that days’ topics.
* Theiie @uing, review the results of the group.

* Re those topics with the class that obtained the most incorrect answers.
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Summary

After successfully completing this module, you should know how to:
© Describe the elements that make up manufacturing operations.

© Configure selected elements of manufacturing operations.

Summary

After successfully completing this module, you should know how %
* Describe the elements that make up manufacturing operatiQrs.
» Configure selected elements of manufacturing operatiers.

&
S
@)
W

QO
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Exercise 1: Creating a Manufacturing Operation for the
Aluminum Cover

Module 4 Lab Exercises

Demonstration Instructions

Preparation

Complete the following tasks before running this demo for customers: Q\

e Practice running the demo so you can easily complete it.
* Check for and review the errata sheet for this course.
* Use Pro/ENGINEER Wildfire build code 2003051 or later. % @

« Download and install the class fileswi | df i re_m | | i .tar. gz as described in

the classroom setup notes.

Introduction @\
of a manufacturing operation to enable

In this demonstration, you configure selecte
machining of the aluminum cover. This vescreating a workcell, a machine zero, a retract

i
surface, specifying the workpiece moa%é@eating a PPRINT table, and setting up a fixture. An
b

additional challenge exercise is a for students to configure a manufacturing operation for

the mold cavity.

Manufacturing operatio§ @sential to the manufacturing process. They contain many

elements that m nufacturing process such as workcells, machine zeros, and fixtures.

NC sequences ¢ e created until the manufacturing operation is configured.

Objective
A@ essfully completing this exercise, you will know how to:

figure selected elements of manufacturing operations.

cenario

The next step in the manufacturing process typically involves creating manufacturing operations.
To enable machining of the aluminum cover, you set-up a manufacturing operation in the
previously created manufacturing model of the aluminum cover. This involves creating a workcell,
a machine zero, a retract surface, specifying the workpiece material, creating a PPRINT table,
and setting up a fixture. To assist in viewing the manufacturing model in different positions you
also create a series of named views.
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Step 1. Open the manufacturing model for the aluminum cover

We can locate the folder for this exercise and set this as our working director. We can then open

the manufacturing model of the cover.

1. In the navigator, select the Folder Browser tab, and browse to
c:\users\student\wildfire_mfg_330\module04, right-click, and select Make Working
Directory.

2. Click File > Open to open the manufacturing model for the aluminum cover: COVER.%

Step 2. Create a named view, then create an operation, configure a 3-axis milling workggit;
create a PPRINT table, and configure the stock material.

We can re-orient the model to view the underside; this is the side we intend to ev@

machine. We can also save this view for future reference. Using the Menu M, er, we can open
the Operation dialog box, at this point we can type the name of our machi e@and create a
PPRINT table. PPRINT tables are important because we can outpu %anufacturing

information to CL data files by changing the option flags to yes.

At this point, we can specify the workpiece material for the ope&ration, in this case aluminum.
Configuring the workpiece material at this stage will enab Set default tool feeds, tool
speeds, and cutting depths when creating NC sequ@ ese default values are based on
workpiece material and roughing or ﬁnishingg> cut@o itions.

1. To see the underside of the model, ro kmodel by 180° around the x-axis of the spin
center, click View > Orientation ent. In the Orientation dialog box, change the
Type drop-down list from Orle rence to Dynamic Orient. Then click the Spin
Center Axis icon, and type |, 8 the x-axis rotation angle.

2. Expand the Saved V| v ce, type [bot t om t ri ] in the Name text box, and click the

Save button. ClI s ntat|on dialog box.

&

Figure 1: Model rotated by 180° around the x-axis of the spin center.

3. Using the Menu Manager, select Mfg Setup, and open the Operation Setup dialog box.

4. Click the Machine Tool Dialog icon, and open the NC Machine Tool Setup dialog box, type
[f adal _vnt]in the Machine Name text box.
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5. Create a PPRINT table; click the PPRINT option, then select Create to open the PPRINT
window. Click the DATE_TIME item, and click the Yes option at the bottom of the window.
Change the following items to yes.

Table 1: PPRINT Table Options

Item Option

DATE_TIME Yes

OPERATION_COMMENTS Yes Q
TOOL_TABLE Yes -\
ONLY_OUTPUT_USED_TOOLS | Yes AN\ )
NC_SEQUENCE_NAME Yes

NC_SEQUENCE_COMMENTS | Yes (@D

6. Close the PPRINT window, then Save the PPRINT table (accept the defadlt name), select
Done/Return, and close the Machine Tool Setup dialog box.

7. Inthe Operation Setup dialog box, select aluminum in@ Material drop-down list.

Step 3. Create the machine zero co-ordinate system anﬁ?(h\e |;é)?ract surface.

We can create the machine zero position, ensurinNe create the co-ordinate system in the
cover assembly by selecting it in the model tree. %n g three surfaces on the workpiece, we
can position the co-ordinate system in the fm@- op corner of the workpiece. We can set the
direction of the axes to match our r%qui@t yand rename the co-ordinate system to make it

t surface and position it relative to our machine zero

easier to identify. We can also cr x
position. When the operation d is complete, we can rename the retract surface in the
13/ g

model tree to make it easi y.
The machine zero po% as the origin for CL data output, and defines the direction of the x,

y and z axes. Thexs{r rface specifies the level to which the tool retracts to between cutting.

N

No N

<%\rn ofkie display of the blended background in the graphics window to make

wing of co-ordinate system axes easier.

ick View > Display Settings > System Colors, clear the Blended Background check
box, and click OK to complete the configuration.

2. Turn on the display of co-ordinate systems, if not already visible in the graphics window.

3. Create a machine zero co-ordinate system positioned at the front-left-top corner of the
workpiece. In the Operation Setup dialog box, click the Machine Zero icon, then select
Create in the MACH CSYS menu, when prompted to pick a model to create the coordinate
system in, select the COVER.ASM assembly in the model tree.

4. To refresh the screen, click View > Repaint.
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Note:

To select multiple surfaces you must press and hold the CTRL key when selecting
surfaces. To select hidden surfaces you must move the cursor over the hidden
surface and right-click to highlight the hidden surface.

5. Select surfaces to configure the co-ordinate system origin. Press and hold CTRL, and select
the front and top surfaces on the workpiece as shown in the following figure.

&

%@

@suﬁaces.
6. To select the hidden left surface, move the curs r model as shown in following
figure, then press CTRL + right-click, when the_hiddenleft surface highlights select it.

<N\

Figure 2: Showing selected fron

Surf:F2(PROTRUSION):COVER _NC_WR!

& Figure 3: Showing selected left surface highlighted.

int:)
e co-ordinate system origin will move to the front-top-left corner of the workpiece

n all three surfaces have been selected correctly. (As shown in the following
figure).
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: \
Figure 4: Showing position of co-ordinate system after all three surfacelected.

7. In the Coordinate System dialog box, select the Orientation tab. Use the-rop-down axis
options and the Flip button to modify the orientation of the axes ‘n own in the following

figure. f/z

@@ Showing re-oriented X, Y and Z axes.
ialog box, select the Properties tab, and rename the co-ordinate

8. Inthe Coordinate S
system to [rrai _0p010]. Close the Coordinate System dialog box when finished.
ti e

9. Inthe Gpe tup dialog box, click the Retract Surface icon, select the Along Z Axis
option tyge [40] (1.57 in.) as the z distance. Close the Retract Selection dialog box.

10. Chase the Operation Setup dialog box.

1ct the retract surface in the model tree (ADTM1), then right-click and rename it
retract _op010].

2. Turn on the blended background again. Click View > Display Settings > System
Colors, select the Blended Background check box, and click OK to complete the
configuration.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 4-7



RETRACT QP00

Figure 6: Machine zero co-ordinate system and retract surface. \

Step 4. Create the fixture setup and assemble the vise assembly. ( ( \\

Fixture dialog box and name the fixture setup op_010. We can now add a ¢ ent to the

fixture setup; in this case we can select the VISE.ASM from the i@@ the vise assembly

To clarify the view of the model, we turn off the display of all datum features. g canopen the

jaws are the correct distance apart, we select the OP010_INST ftam the\list of instances. We can

position the vise assembly using two mate constraints and 8@ align straint; we can also

display the vise assembly in a separate window to make t bly process easier to
complete. Alternatively, we can spin the vise assembl, sing CTRL + ALT and middle-click
the mouse and drag the model.

Once assembled, we can close the fixture s%%@)peration dialog boxes.
Fixtures are useful because they show Q%a/nz ined components are held during machining
and they can be easily activated ar@ vated.

1. Turn off the display of.datum Rlanes, datum axes and datum co-ordinate systems.

2. Using the Menu n
dialog box.

elect Mfg Setup > Operation to open the Operation Setup

3. Click the Fkﬁ’e p icon to open the dialog box, type [0p_010] in the Fixture Setup

Name box:
4. ck @d Component icon to add a component to the fixture setup; select VISE.ASM
the list of models, then select the op010_inst from the list of instances.

Tip:

The assembly process is easier if you do not display the vise assembly in the main
graphics window when specifying assembly constraints; instead show the vise
assembly in a separate window.

5. In the Component Placement dialog box, click the Show Component in a Separate Window
icon, then remove the vise assembly from displaying in the graphics window by de-selecting
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the Show Component in Assembly Window icon. Ensure both the manufacturing model and
the vise assembly are clearly visible.

Note:

You need to create two mate constraints and an align constraint to correctly position
the vise assembly.

6. Assemble the vise assembly, as shown in the following figure. In the Component Placement
dialog box, change the first constraint type from Automatic to Mate, then select the hidden
left surface on the workpiece and the small vertical surface on the clamp pad p

7. Change the second constraint type from Automatic to Mate, then selec h@h bottom
D

surface on the workpiece and the small horizontal surface on the cla @ ’

D
8. Change the third constraint type from Automatic to Align, then selec ont surface on the
workpiece and the vertical front surface on the clamp pad part.

Figure7: S the two mate and one align constraints; selected pairs of surfaces are highlighted.

P ment dialog box to check the vise has been positioned correctly. Complete the

9. W%the ee constraints have been created, click the Preview option in the Component
ponent placement when satisfied.
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Figure 8: Final assembled position of the vise assembly :

10. Close the Fixture Setup dialog box.
11. Close the Operation dialog box, and return to the Manufactu&%é@

Step 5. Create a series of named views.

We can create a series of named views to assist in viewi@nufacturing model in different

positions. Starting with our previously defined botto ed view, we can zoom in on the

model and create a named view call op010-trj

top view called op010- t op, and a front v@ op010- f ront.

1. Using the Zoom In icon in the toolkar top of the graphics window, zoom into the
manufacturing model, as showprin t llowing figure.

2. To create a named view glick\Vi > Orientation > Reorient, in the Orientation dialog
box type [0p010- t r hNn ame box, and save the view.

&
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Figure 9: Showing suggested zoom window for @wew op010-tri.

3. To create a top view, select the top surface of the w iecg for Reference 1, then change
the Reference 2 drop-down option to Bottom and sele e front surface of the workpiece
i the following figure.

for Reference 2, this reorients the model as S%;
4. Using the Zoom icon, zoom into the mo p010- t op] in the Name box, and save

the view. @
x2§©
)~

Figure 10: Showing suggested zoom window for named view op010-top.

5. In the Orientation dialog box, select op010-tri from the list of saved views and click Set.

6. To create a front view, click the Select Reference Icon for Reference 1, and select the front
surface of the workpiece. Then change the Reference 2 drop-down option to Right and
select the right surface of the workpiece for Reference 2.
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7. Using the Zoom icon, zoom into the model; type [0p010- f r ont ] in the Name box, and
save the view.

AN
miE @Q

Figure 11: Showing suggested zoom window for named view op@nt.

8. Close the Orientation dialog box. Click the Saved View List icon;sglé e named view
op010-tri from the list of views.

9. Save the manufacturing model.

10. Close all windows and erase all components fro@
O\(: :)
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Exercise 2: Creating a Manufacturing Operation for the Mold
Cavity (Challenge)

Objectives

After successfully completing this exercise, you will know how to:

« Create Manufacturing Models with a Reference Model and a Workpiece.

Scenario

To enable machining of the mold cavity, you set up a manufacturing operatio
manufacturing model for the mold cavity. You do not need to configure th
elements as you did for the aluminum cover. For the mold cavity, you crea
machine zero, and a retract surface (additional items will be configu uring the creation of NC
sequences). @

=
Step 1. Open the manufacturing model for the mold cavity. tedn operation, and configure a
3-axis milling workcell. &

1. Open the manufacturing model for the alumi E:er: MOLD_CAVITY.MFG.

& Figure 12: Mold cavity manufacturing model.

@‘\g the Menu Manager, open the Operation Setup dialog box.

Open the Machine Tool Setup dialog box, retrieve the mazak workcell by selecting
MAZAK.GPH from the list.

Note:
Retrieving the mazak workcell also retrieves and activates a site parameter file.

4. Close the Machine Tool Setup dialog box.

5. Select steel-300-bhn in the Stock Material drop-down list.
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6. Turn on the display of co-ordinate systems, if not already visible in the graphics window.

7. Create a machine zero co-ordinate system positioned at the front-left-top corner of the
workpiece. Set the orientation of the axes as shown in the following figure. Rename the co-
ordinate system to [mach_csys].

Note:

When prompted, create the co-ordinate system in the MOLD_CAVITY.ASM
assembly, and select this assembly from the model tree.

8. Create a retract surface along the Z-axis of the machine zero co-ordinate system, t@

(0.20 in.) as the z distance.

9. Close the Operation dialog box. @

10. Rename the retract surface to [r et ract _op010] in the model tree. @

RETRACT _OPO10
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Summary

After successfully completing this module, you should know how to:

» Describe the elements that make up manufacturing operations.

» Configure selected elements of manufacturing operations.
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Module

Creating

Introduction @

Creating tools is an essential step in the manufactu@ocess, as a tool must

be configured for each NC sequence you creat n be created when the
workcell is created or they can be configur: ed for each NC sequence.

Once a tool is configured the informati red and used again.

id, and sketched. Each type of tool

There are three different tool typesadited,
is created in a different way and - S ed for a specific purpose. It is important
to understand the differences he ach type of tool and when they should
be used.

Objectives O\©

After completi dule, you will be able to:

. Desc@ ferences between the different tool types: edited, solid and
sk

ate different types of edited tools through the configuration of tool
parameters.

-E ¢yige how to specify tool feeds and speeds by configuring stock material.

Page 5-1



Creating Milling Sequences with Pro/ENGINEER
Wildfire

Module 5: Creating Tools

& PTC@Q
@

Instructor Preparation

Before teaching Creating Milling Sequences with Pro/ENGl@ldﬁre, you must have read and
thoroughly understood the following materials:

* General Information
* Review Pro/ENGINEER Wildfire primer site at @?Meb.ptc.com/primer/

* Pro/E Wildfire Documentation
* Review Pro/ENGINEER Wildfire
/GS Training Materials/Domain Knowledge

‘0°

+ Pro/E Wildfire Milling @
* Review Pro/ENGINEm e Milling training materials in Windmill, located in
/GS Ed Srvcs Operations/ ation Library/Instructor Materials/Instructor Kits/EN
/T979-330-Instructor Kit-

tion in Windmill, located in
te/ProENGINEER/Core Concepts

* Required SKi

» Completion.of Pro/E Wildfire Foundation or equivalent Pro/E skills

* OB n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E
Hjty to install and configure Pro/E Wildfire

+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Two

" " " ProfFICIENCY
Using Creating Creating ealintor
Loctures | Creating Tools Manufacturing === Face Milling  ====B  Profile Milling ===} ‘Daily
— — [~ [Assessments

T T T
| | |
! | |
4 & &

Creating Tools |

Creating and Creating Creating
| Activating Site [~ Face Milling  [~"""| Profile Milling [~
Parameter files Seqgeunces Seqeunces
Creating and [~y Creating — Creating =
.| Activatingsite | FaceMilling | | Profile Milling
Parameter files Segeunces Seqeunces

Duration %
¢ Lecture: 15 mins

¢ Demos : 20 mins
e Labs : 40 mins

» Total: 1 hr 15 mins @\
&
O
N
e
W
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Objectives

After completing this module, you should be able to:

® Describe the differences between the different tool types: edited, solid
and sketched.

® Describe how to specify tool feeds and speeds by configuring stock
material.

® Create different types of edited tools through the configuration of tool
parameters.

QO

Overview (%;

Creating tools is an essential step in the manufacturing process a must be configured for each
NC sequence you create. Tools can be created when the workeell ig)created or they can be configured
as needed for each NC sequence. Once a tool is config%] infbrmation can be stored and used
again.

There are three different tool types: edited, solid, and . Each type of tool is created in a
different way and is designed for a specific purpos is ortant to understand the differences
between each type of tool and when they should sax.

&

e able to:
nt tool types: edited, solid and sketched.
« Describe how to specify tool fe 2 peeds by configuring stock material.
+ Create different types of edi ec@ through the configuration of tool parameters.

O

After successfully completing this module
* Describe the differences between ‘ar-

Q)
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Tool Types

EDITED TOOLS

Three Tool Types

© Edited

® Solid

o
=1 5
=3

SKETCHED TOOL

SOLID ToOL H’"

= LS

® Sketched

Reomer_radius h

Deutter_diam

CONTROL PO’

Tool Types
Tools can be created when the workcell is created or they can be ¢anfigdred as needed for each NC
sequence. Once a tool is configured the information can be ed and used again.

There are three different tool types: edited, solid, and sk ed. Each type of tool is created in a
different way and is designed for a specific purpose.

+ Edited tools are used when no special tool represe is required.

+ Solid tools are used when you need to enhance(thexool display and check for interference between
the tool and workpiece when reviewing too

» Sketched tools are typically used wher’an andard tool shape or an alternative tool control
point is required; for example during @ry milling you can create a sketched tool for machining

slots. @
We will review each type in tum®©

©
S
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Edited Tools

® Tools created by configuring parameters CUTTER DiAM

I ] SIDE_ANGLE

® Tool type controls parameters

For example:
o Milling

LENGTH

o Drilling

® Parameter values control shape

BALLEND MILL
e Length
o Cutter_Diam CUTTER_DIAM
o Side_Angle

e Corner_Radius
e Point_Angle

POINT \
ANGLE
® Tool Parameter Libraries '

o Standardize tools

LENGTH

o Available to all users REGULAR DRILL

Edited Tools %

Edited tools are created by configuring tool parameters.

The available tool parameters are based on the type of tool beig cghfigured for example milling or
drilling.

The tool parameter values control the tool shape, a graphis ge of the tool is displayed during
configuration. v @'

You can create your own tool library, where all thedtooNparameter files are stored. This enables access
to a standard set of tools for retrieval into man g processes, for modifying, or for setting up new
tools. ¢

When playing a toolpath the tool is disp sed on parameter values.
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Solid Tools

® Used to enhance tool display
e Interference checking

© Regular Pro/ENGINEER Part or Assembly
o Model dimensions control tool shape

« Dimension symbols correspond to tool
parameters

o Model parameters correspond to tool
parameters

o Datum co-ordinate system specifies control
point
f=—— length

13 . : TIP

TOOL_MATERIAL="CARBIDE" Q\

Recormer radius MNUM_OF_TEETH=2

@ cutter_diam

Solid Tools %
You can enhance the CL data display when checking tool paths, ck for interference by showing
a "real" tool.

Solid tools provide the option to display the default tool sestion or the real tool model.

The tool is created as a regular Pro/ENGINEER model c@ or assembly), a number of items need to
be configured:

* The model’s dimensions are related to<;oo ters, by changing dimension symbols to
correspond to tool parameter names.

+ E.g.: length, corner_radius, cu g&m

* Model parameters are set to cgfréspofid to tool parameters, e.g. tool_material, num_of_teeth.

* The solid model must als datum co-ordinate system named TIP to represent the tool origin
(or control point), and i and holemaking tools the z-axis of the co-ordinate system must

point into the to@
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Sketched Tools

® Used in Trajectory Milling

« Tool swept along trajectory

© Benefits
« Non-standard tool shapes

« Alternative tool control point

® Sketch as a revolved protrusion
« Specify control point in sketch

o Use sketcher co-ordinate system

Sketched Tools @E;
Sketched tools are used in trajectory milling where the tool is swepta a defined trajectory; for
example when machining slots.

Sketched tools are typically used when a non-standard twap or an alternative tool control point is

required.
The tool is sketched as a revolved protrusion: @‘
» The sketch represents half of the tog s-section. The whole sketch must lie on one side
of the axis of symmetry. The ax<i>s o) try must be vertical, with the sketch lying on the

right.

* The section must be cIose@@

For a sketched tool, you can speci rol point other than its tip by adding a coordinate system to
the tool section sketch. The t% n be swept so that its control point follows the specified

trajectory. :



e . VrTC

Tool Cutting Data

For Each Tool
® Configure Optimum Feeds/Speeds/Depth-of-Cut

© Data based on Bull Nose 10.0 mm Diameter
. . CUT_DATR_UNITS METRIC
« Stock material to be machined APPLICATION TYPE ROUGHTNG
« Application TOCL_SPINDLE_RPM 5825
Roughing TOOL_RADIAL DEPTH 4.8
Finishing TOCL_SURFACE_SPEED 183000
TOOL_FEED_RATE 1515
® Directories for each material ToOL FEED PER UNIT 0.26
4 21 tools TOCL_AXIAL_DEPTH 8

APPLICATION TYPE FINISHING
TOOL SEINDLE REM 5825
TOOL_RADIAL DEPTH 1
& 03 materials TOOL SURFACE SPEED 183000

£ ALUMINILM TOCL_FEED_RATE 1515

TOOL FEED PER UNIT 0.26 \
21 AUSTEN TOOL AXTAL DEPTH 0.5 @

=21 Inch_tools
¢ 03 materials
=1 metric_tools

{3 BRASS-HARD
-0 BRASS-MEDIUM

{3 CASTIRON-HARD
-0 CASTIRON-MEDIUM
{0 COBALT

Tool Cutting Data %ﬂ
Tool cutting data can be created for tools, enabling you to configure.optimum feed rates, spindle
speeds, and depth-of-cut.

The data is based on the material to be machined and th&application; either roughing or finishing.
Cutting data files can be created for each tool and for eagh kpiece material. This information is
stored in a directory structure with different directories ’o@" material.

The feed and speed data can be passed irgo t@a facturing parameters of an NC sequence.

* This can be done automatically throug@@g ns in the manufacturing parameters.

» Or manually by choosing to copy t@ga when configuring manufacturing parameters.

Q@
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Configuring tools to machine the aluminum cover.

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

QO

Demonstration:
» Configuring tools to machine the aluminum cover. %

Scenario
* Throughout this course, the exercise scenarios@p same as the demo scenarios.
e

» This has been done to build consistency be mos and lab exercises so as to enable
“Tell me—Show me—Let me do.”

Method O@

Use the script in the instructors guide, us ame models as in the exercises.

Exercise

Once the demo is complete the s s should use the steps in the training guide to complete the
exercises.

Q)
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Summary

After successfully completing this module, you should know how to:

® Describe the differences between the different tool types: edited, solid
and sketched.

® Describe how to specify tool feeds and speeds by configuring stock
material.

® Create different types of edited tools through the configuration of tool
parameters.

QO

Summary

After successfully completing this module, you should know how %
+ Describe the differences between the different tool types: edited,/solid and sketched.
+ Describe how to specify tool feeds and speeds by configuring stock material.
» Create different types of edited tools through the c ion of tool parameters.
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Module 5 Lab Exercises
Exercise 1: Creating Edited Tools

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \

e Practice running the demo so you can easily complete it. @
» Check for and review the errata sheet for this course. @
» Use Pro/ENGINEER Wildfire build code 2003051 or later.

« Download and install the class fileswi | df i re_m | | i n%&a I. 9z as described in

the classroom setup notes.

Introduction
In this demonstration, you configure a number of@? nable machining of the aluminum

cover. For each tool you specify the tool type and igure tool parameters to control the tool

shape. All the tools will be configured within FADAL_VMC workcell. You also configure feed
and speed data for each tool by readi .@ imum tool feeds, spindle speeds and depth of cut
data. Q&K

Creating tools is an essential s e manufacturing process, as a tool must be configured for
each NC sequence you createfTools can be created when the workcell is created or they can be
configured as ne e@gch NC sequence. Once a tool is configured, the information can be

stored and used

Objectiv
After &%essfully completing this exercise, you will know how to:

. ate different types of edited tools through the configuration of tool parameters.

cenario

The next step in the manufacturing process typically involves creating tools. To enable machining
of the aluminum cover, you create a number of different types of edited tools. This is achieved
through the configuration of tool parameters. You also learn how to specify optimum tool feeds
and speeds by configuring stock materials.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 5-3
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Step 1. Open the manufacturing model for the aluminum cover.

To ensure we are using the correct version of the manufacturing model, we close all windows and
erase all components from memory. We can then open the manufacturing model for the cover

from the module05 directory.

1. In the navigator, select the Folder Browser tab, and browse to
c:\users\student\wildfire_mfg_330\module05, right-click, and select Make Working
Directory.

2. Open COVERMFG. &
@\

Step 2. Configure three drilling tools for the FADAL_VMC workcell. f\\

All the tools configured in this exercise are associated with the FADAL VMC worlwer the
tools are saved it is possible to use them again with other workcells.

We can start by configuring a drilling tool. The tool name is a means-of @ymg and describing
a tool as each tool is given a unique name during configuration. &he to e controls the tool
geometry parameters available for configuration. It is impor%s iy the correct tool type to

ensure proper parameters are available for each tool.
‘or

The tool geometry parameters control the shape of t \
pocket number within the workcell, and the tool mber can be used to specify an offset
< 0,

e tool number specifies the tool

value in the gauge length register. Each too?kx to enable it to be used again as required.

1. Using the Menu Manager, select > Tooling > FADAL_VMC to open the Tools

Setup dialog box.
2. Inthe Tools Setup dialog b gg& a center-drill tool. Using the Geometry and Settings
tabs, configure the to: rs as shown in the table below.

&
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Table 1: Tool Parameters

Tool Parameter Parameter Value

Name CTRDRILL_04

Type CENTER-DRILLING

Material -

Units Milimeter

Cutter Diameter 8(0.31in.) QA
Length 54 (2.13in.) %S
Point Angle 118 ~N
Csink Angle 60 N\
Drilling Diameter 4.0 (0.16 in.) (D)

Drill Length 4.0 (0.16in.)

Tool Number 1 (O N

Offset Number 1

3. Apply the changes to the tool definition and save the tooh C/

4. Create two more drilling tools using the followin@%as. ave each tool after configuring the

parameters.

(O

Note: @

Remember to change the tool typm the correct tool parameters.

N
@Table 2: 6.0 mm drill

Tool Parameter "\ -| Parameter Value
Name (C » | DRILL 06 0
Type N4 DRILLING
Material \\\)f HSS
unge \ Op Millimeter
Clttef Digeter 6 (0.24in.)
Length”” 70 (2.76 in.)
oint Angle 118

@ Point Diameter -
Tip Offset -
Tool Number
Offset Number

Creating Milling Sequences with Pro/ENGINEER Wildfire
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Table 3: Countersink tool
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Tool Parameter Parameter Value

Name CSINK_12

Type COUNTERSINK

Material -

Units Milimeter

Cutter Diameter 12 (0.47 in.)

Length 50 (1.97 in.)

Point Diameter -

Point Angle ) N
Gauge Offset - (( ))
Tool Number 5

Offset Number 5 (O N

Step 3. Configure six milling tools for the FADAL_VMC workcel& \))

We can configure the milling tools we need to machine the a
creating NC sequences. It is important to configure the cqfr

is used later when calculating optimum tool feeds a/@ speeds.

1. Create a flat end mill tool with a diameter ofmiIIimeters using the tool parameters as

shown in the table below.

\N

inum cover now or later, when

mber of teeth as this information

Tip:

Change the tool type to milli@

‘o?

N

ore starting to create the tool.

W Table 4: Tool Parameters
(N

Tool Paramiéter\\_)~ Parameter Value

Name FEM_03 0

Type (¢ MILLING

Materiah\, HSS

Units ) Millimeter

Cutter Diameter 3(0.19in.)
N ength 25 (0.98 in.)

Corner Radius -

Side Angle -

Number of Teeth 2

Tool Number 7

Offset Number 7

2. Apply the changes to the tool definition and save the tool.
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3. Create five more milling tools using the following tables. After configuring the parameters
apply the changes and save each tool.

Table 5: 6.0 mm flat end mill

Tool Parameter

Parameter Value

Name FEM_06_0

Type MILLING

Material HSS i\
Units Millimeter

Cutter Diameter 6 (0.24 in.) a N 5
Length 30 (1.18n.) N\
Corner Radius - (& >>

Side Angle -

Number of Teeth 4 <O 1)

Tool Number 9 @\

Offset Number 9 \\\

N

Table 6: 12.@%%(1 mill
O

Tool Parameter Parameter Value
Name FEM_ 12 0

Type MG

Material ¢ [ \zARBIDE

Units @/\?Willimeter

2

Cutter Diameter (7~ & | 12 (0.47in.)
Length % 50 (1.97 in.)
Corner R‘id@s\))b -
Sapodle ) :
N(foler of Teeth 4
Tool\\f\tﬁﬁber 11

ffset Number 11

Creating Milling Sequences with Pro/ENGINEER Wildfire
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Table 7: 12.0 mm ball nosed end mill
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Tool Parameter Parameter Value

Name BEM_12 0

Type MILLING

Material CARBIDE

Units Milimeter

Cutter Diameter 12 (0.47 in.)

Length 50 (1.97 in.)

Corner Radius 6 (0.24 in.)

Side Angle - x
Number of Teeth 2 (( w
Tool Number 13

Offset Number 13 (O N

Table 8: 25.0 mm flat end mil

Tool Parameter

Parameter Value

Name FEM_ 25 0 (O
Type MLLNG AT
Material CARBIDE__ \

Units Millimetek\ )

Cutter Diameter 252!\2\9\8\@3)

Length O3 in.)

Corner Radius f -M

Side Angle \})

Number of Teeth wp 4

Tool Numbeg,> () 15

Offset Nu 15

&
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Table 9: 50.0 mm shell end mill

Tool Parameter Parameter Value

Name SH_MILL_50_0

Type MILLING

Material HSS

Units Milimeter

Cutter Diameter 50 (1.97 in.) QA
Length 35 (1.38in.) 2N
Corner Radius - N S
Side Angle - x\
Number of Teeth 10 (( w

Tool Number 17

Offset Number 17 (O N

S

Step 4. Configure the optimum speed and feed data for@ug tools based on the stock
material.

For the milling tools, we can configure opt/mum t Xc\@spindle speed and depth of cut data

based on the workpiece material. To save ti ta has already been created and stored in

a material folder. We can make use of thi speCIfymg the stock material and reading-in

l‘When creating NC sequences, this data can then
ters of an NC sequence.

the feed and speed information for

be passed into the manufactur/ng

aluminum from th aterial drop down list. Click the Read DB button to read-in the

1. Select the FEMOSO@\A@&CK the Speeds-Feeds tab, and specify the stock material as

C
optimum spe&af\q d data.
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Application: |F’LDughing |v| 1 English Unit Systam
[+ Metric Unit System

Stock :

Material Lot ]

- Cutting Data

Speed: 19417 |revimin [ v] ReadDB |

Fead (5045.42 | mm/min [+]
Axial Depth:  [2.400 | mim |v] \
Riadial Depth: [1.440 || mim v] @@

Figure 1: Speed and feed data for tool FEM_03_0.

changed.

2. Then Apply the changes to the tool definition, and confirm the tool d%@w will be

3. Repeat this process by specifying aluminum as the stock matexjal and reading-in the optimum
speed and feed data for the following milling tools. \

Table 10: Tool na

Tool Name  <{(

FEM_06 0 /\
FEM_127 \/

6. Close all windo nderase all components from memory.

&
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Summary

After successfully completing this module, you should know how to:

» Describe the differences between the different tool types; edited, solid and sketched.
» Describe how to specify tool feeds and speeds by configuring stock material.

» Create different types of edited tools through the configuration of tool parameters.

@Q\%
@
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Module

Manufacturing Parameters

\‘
Introduction @

Manufacturing parameters are the primary means f ntrolling how an NC
sequence is generated. You can specify and edi @ter values as needed.
Manufacturing parameters can be configur %red in global site files, orin
NC specific parameter files. These filescean b ifeved, and enable you to
quickly and easily set suitable para% when creating NC sequences.

Objectives @j
After completing this modulg( yogwill be able to:

e Describe how man ring parameters control NC sequences.

e Describe the different methods used to set and edit parameter values.

e« Editand a@@site parameter files.
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Creating Milling Sequences with Pro/ENGINEER
Wildfire

Module 6: Using Manufacturing Parameters S
The D

way to Product First™

Instructor Preparation %
Before teaching Creating Milling Sequences with @EER Wildfire, you must

ro/|
have read and thoroughly understood the follo&materials:
» General Information

* Review Pro/ENGINEER Wildfire prir@ a at http://rdweb.ptc.com/primer/

* Pro/E Wildfire Documentation \@
Hdfire

* Review Pro/ENGINEER re, ocumentation in Windmill, located in
/GS Training Materials/Domais edge/Create/ProENGINEER/Core Concepts

* Pro/E Wildfire Milli @
* Review Pro/E R Wildfire Milling training materials in Windmill, located in
tions/

/GS Ed Srves Qpe GS Education Library/Instructor Materials/Instructor Kits/EN
/T979-330-Instructey” Kit-EN

. @)3 ills
%o pletion of Pro/E Wildfire Foundation or equivalent Pro/E skills

ompletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or
equivalent Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology



I . e |

Lesson Activities: Day Two

Duration
* Lecture: 15 mins
* Demos : 15 mins
* Labs : 30 mins
* Total: 1 hr 00 mins

Using Creating Creating
;7| Creating Tools == Manufacturing =%{  Face Milling === Profile Milling ==
Creating and Creating Creating
Activating Site [ Face Milling [~ Profile Milling
Parameter files Seqeunces Seqeunces
= Creating Tools [T Creating and —|  Creating [~
.| Activatingsite | | Facemiling | | Profile Milling
Parameter files Seqeunces Seqeunces

Pro/FICIENCY
Evaluator

--------------
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Objectives

After completing this module, you should be able to:
Describe how manufacturing parameters control NC sequences.
Describe the different methods used to set and edit parameter values.

Edit and activate a site parameter file.

et
<
Overview %
» Manufacturing parameters are the primary means@ olling how NC sequences

are generated. It is important that you can specify t rrect parameters and edit
parameter values as needed. Manufacturing p%ia\;?:ters can be configured and
stored in global site files, or in NC specific p r files. These files can be
retrieved, and enable you to quickly anc@ t suitable parameter values when

Slide 3

creating NC sequences.

After successfully completing thi 0% ;you will be able to:

» Describe how manufacturing &e ers control NC sequences.

» Describe the different methed ed to set and edit parameter values.

» Edit and activate a S%g eter file. This is a means of setting default parameter

values for future %C nces.



@l  “Oric
Manufacturing Parameters
General Description
Manufacturing parameters
e Used to control NC sequences
Det ine h toolpath i ted Manufacturing Parameters
e Determine how a toolpa Is generate CUT_FEED 151451
Example Parameters STEP_DEFTH ?
STEP_OWER 24
« CUT_FEED =100 BOTTOM_STOCK_ALLOW  [()
«SPINDLE_SPEED = 500 CUT_ANGLE i
_ SCAM_TVPE TvPE_SPIRAL
«COOLANT_OPTION = FLOOD SPINDLE_SPEED 155 o7
«STEP_DEPTH = 2.5 COOLANT_OFTION FLODD
«SCAN_TYPE = TYPE_SPIRAL CLEAR_DIST 6]
o APPROACH_DISTAMCE 25
Configuring Parameters EXIT_DISTANCE 5
« Before creating an NC sequence
o During the creation of an NC sequence D
Slide 4

~

Manufacturing Parameters

Creating NC sequences involves, selecting or creati e ié%fry to machine, then
determining how the toolpath is generated by modifyin ufacturing parameters.

Manufacturing parameters enable toolpath contr en creating NC Sequences.
* Example Parameters:
* CUT_FEED —controls the feed rate @ equences during cutting motions.
» SPINDLE_SPEED —controls gpi ed in NC Sequences.
*+ COOLANT_OPTION —contr %% olant is used and the specific coolant option to
be output (ON, OFF, MIS D or THRU)
« STEP_DEPTH - contrals cremental depth of each pass when cutting.
+ SCAN_TYPE - contrals the method of scanning the machined area.

ers:
fault parameters before creating NC sequences.
ate site parameter files to control the default values for all

» Configuring Par;
* You carygetip
* You ca

pﬁneters.
uxcan also save parameters from NC Sequences to create a library and
ieve them when required.

When creating NC Sequences you have several options for reusing previously
aved parameters or you can edit the parameters manually.
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Manufacturing Parameters

Parameter Categories #-Names
= CUTDPTION
eNames SCAN_TYPE TYPE_3
. CUT_TYPE CLIME
«Cut Options STEPOVER_ADJUST YES
TRIM_TO_WORKPIECE VES
* Cut Parameters CUSTOMIZE_AUTO_RETRACT  |VES
oFeed = CUT PARAM
i STEP_DEPTH 8
eMachine TOLERANCE 0.01
. STEF_OVER 6
o Entry/Exit TOOL_OVERLAP -
Required Parameters NUMBER_PASSES J

o Values must be set to create an NC sequence
E.g. CUT_FEED/SPINDLE_SPEED

Optional Parameters \
eProvide further control of toolpath
Parameter Lists Vary D

eDepending on type of NC sequence

Slide 5 [/ BRou2PTC
Manufacturing Parameters %

» Parameter Categories:
» Parameters are grouped into six logical caﬁi ~dllowing you to quickly locate

the relevant parameters to set. E

* Required Parameters: @
* These are parameters that yQu r@s in order to create an NC sequence.
* Examples are STEP_D% T _FEED and SPINDLE_SPEED.

‘0

» Optional Parameters:
+ Some parameters are @I and can be set if required and provide additional
control of the toolpat

* They are either n ed’or they can take their values from other parameters.
* One exafiplg i OL_OVERLAP which can be used instead of STEP_OVER.

» Parameters vary depending on the type of NC sequence being created.

parameters such as feed rate and spindle speed will be present in all of the
nce types.

ome parameters are specific to certain types of sequences. When creating NC
sequences, only the relevant parameters are available.
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Setting Parameter Values

Several Options
Site parameter files
Standard default values
NC sequence parameter files
Using previous NC sequence values

Direct editing

o Use model tree

CUT_FEED [STEP_DEPTH [SCAN_TYPE

[ MOLD_CAMITY AShd

[ MOLD_CAVITY PRT \
s 1 MOLD_CAVITY PR

§& FSETFO
POl .5 TOP [OF1 ol B TVYPE_3
# g9 2 RGH_VOL[OPD10]| 3000 5 COMSTANT LOAD 3

+ gV 3 RGH_CAWITY [OPL 3000

sides P
&

Setting Parameter Values %

Several Options

There are several ways to set the parameters fordNC S nces:

+ Site parameter files allow you to set the def; ues for all NC sequence
parameters. When you create an NC Sequ “Ahese default values are read in as
the initial parameter values.

« If you do not use a site file, standar values for all parameters are
automatically set. ©

* When creating NC sequences o have the option to read in parameter values
from a file, or you can copy t meter values from a previous NC sequence in
your model.

* You can also edit para @alues in NC sequences manually.
%\é‘uﬁé

* You can also the model tree to include NC sequence parameters and

set the % rectly in the model tree.

&
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Setting Parameter Values

Default Parameter Values
© Default value: —1 must be set
© Other defaults can be left unchanged

o Default value: “-’ will be ignored

CUT_FEED -1
STEP_DEFTH -1
STEF_OWER -1
BOTTOM_STOCK_ALLOW
CUT_ANGLE ]
SCAN_TYFE TvPE_3
SFIMNDLE_=PEED -1

COOLANT_OPTION OFF \
CLEAR_DIST 4
APPROACH_DISTANCE |- D

EXIT_DISTAMCE

Setting Parameter Values %
Default Parameter Values
* When creating NC sequences, parameters wilkhave either the default values or if a

site file is used, they will have the site file val
« If a parameter has an initial value of —1, @?equired parameter. A value must

be entered before continuing. @
* If a parameter has an initial valu -\t is an optional parameter. No value is
required. ©

\
Koy
W
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Site Parameter Files

Types
o Mill, Turn, Holemaking or WEDM
« General (contains all parameters)

Global Control

o Default parameter values Manufacturing Parametors
+ Names
= CUTOPTION
SCAN_TYPE TYRE_T -
o Parameter visibility OPEN_AREA_SCAN CONSTANT_LOAD -
CLOSED_APEA SCAN  |CONSTANT LOAD -
CUT_TvPE cume -
ALLOW_NEG_Z MOVES |VES
ALTERNATE_CUT DIRECTYES
ISLAND_CLEARANCE | ZONE -
CUT_CONNECTION LINE_CONNECT -
HELICAL FALSE -
CUT_ORDER SWEEP

DEFAULT YALUE _[LOW RANGEHIGH RANGE|

« Range of values

START_EDGE

LEFT
Active Site Files ROUGH_OPTION ROUGH_OMLY

« Default parameter values copied when creating NC sequences

« Modifying NC sequence parameter values breaks the link

Slide 8 PTc
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Site Parameter Files %
» Types: several types of site parameter files can be.con ed: Mill, Turn,
Holemaking, or Wire EDM. Each site type co&ns arameters relevant to its NC
f

sequence types. A general site file contains a the parameters

in Pro/NC.

» Global Control: site files control the def @s used in NC sequences. They also

parameters get their values fronxsite

control the range of values and the v
change will effect all of the seq ﬁ?& f

» Active Site Files: a site fil

of the parameters. NC sequence
es, so if a change is made to a site file, the
at reference it within the Pro/NC model.

activated for it to be used automatically when

creating new NC sequencges.) A site file can be activated manually (or a different site

file selected) when dgfi
 Editing para

C sequence parameters.
es breaks the link to the site file for that

parameter.

Changes sfa at parameter in the site file will no longer be passed to the NC

sequen

be r

. cells & Site files

« Site files ¢ e de-activated in NC sequences. All of the parameter values will
ined, but parameters will no longer inherit their values from the site file.

“®ne of each type of site file can be assigned to a workcell, or a single general site
file can be assigned. Pro/NC will automatically use the site file of the correct type

when creating new NC sequences.
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Common Manufacturing Parameters

Many parameters common to all NC sequences

Key Parameters
«CUT_FEED
« SPINDLE_SPEED
«CLEAR_DIST
« TOLERANCE -

Others discussed in relevant modules
All parameters listed in on-line help

Slide 9 L TmzpTe
&

Common Manufacturing Parameters @;n))

There are a number of manufacturing parameters tha@ mon to all NC sequences.

Some of the key common parameters are:

» CUT_FEED: the feed rate used for cutting i
+ SPINDLE_SPEED: specifies rotation ra@ dle.

Curved
TOLERANCE Geometry

+ CLEAR_DIST: specifies the distance abave the surface to be machined at which

rapid feed ends and cut feed beg;ns
+ TOLERANCE: tool paths approximate-eurved geometry by moving in small straight

line increments. The maximu ce that the straight line path deviates from the
curved geometry is set by T CE.

» Other key parameters wi cussed in the relevant modules.
* All parameters are listethinthe on-line help, together with explanations for all
parameter values,

©

&
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Using Parameters and Setting up Site files

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

\}
SO

Demonstration: Using Parameters and Setting up Si %

Scenatrio
* Throughout this course, the exercise scenar X@ the same as the demo scenarios.
» This has been done to build consistency demos and lab exercises so as to

enable “Tell me—Show me—Let me d

Method

Use the script in the instructors e the same models as in the exercises.

complete the exergis

Exercise @
Once the demo is coii%@ﬁe students should use the steps in the training guide to

&
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Summary

After successfully completing this module, you should know how to:
©® Describe how manufacturing parameters control NC sequences.
© Describe the different methods use to set and edit parameter values.
© Edit and activate a site parameter file.

\}
D@

Summary %

After successfully completing this module, you sheuld kK how to:
» Describe how manufacturing parameters co NC sequences.
+ Describe the different methods use to se r@a parameter values.
» Edit and activate a site parameter file.
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Exercise 1: Creating and Activating Site Parameter Files

Module 6 Lab Exercises

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

* Check for and review the errata sheet for this course.
« Use Pro/ENGINEER Wildfire build code 2002380 or later.

» Download and install the class fileswi | df i re_m | | — .tar. gz as described in

the classroom setup notes.

Introduction @;\

In this demonstration, you create a site file.@ provide default values for the NC

sequences. We will discuss the variou@ ou can enter for parameters and what some of
<

the parameters control. After cre@ file, we will activate it within the workcell.

Objectives @9

After successfully completiqg this exercise, you will know how to:

« Editand actiin i arameter file.
Scenari

In ordegto sp up the creation of NC sequences and to ensure that company standard

paramefer values are used, you will edit and activate a milling site parameter file that will set
de @ pafameter values for milling workcells.

arameters

The following are site parameters modified in this exercise.

Table 1: Parameter Descriptions

Parameter Description

LACE_OPTION For surface milling, specifies the shape of connection between
the endpoints of neighboring cuts

STEP_DEPTH The incremental depth of each pass when cutting.
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Parameter Description

STEP_OVER Distance between passes, within a slice

ROUGH_STOCK_ALLOW | Remaining stock after roughing passes.

CUT_FEED Feed rate when cutting material.

RETRACT_FEED Feed rate when the tool moves away from the workpiece.

FREE_FEED Feed rate used for rapid traverse, default is RAPID.

SPINDLE_SPEED Specifies rotation rate for spindle

COOLANT Determines if coolant is used.

CUTCOM Controls if cutter compensation is on or off.

CLEAR DIST Distance above surface to be machined at which rapid @
ends and cut feed begins.

)

Step 1. Locate and open the cover manufacturing model. @A

Before creating the parameter site file, we first need to locate the m, a@mg model and open
it using the folder navigator. Once we have located the folder forthis Se, we can set this as
our working directory, and open the manufacturing model o%o

1. In the navigator, select the Folder Browser tab, and @@
c:\users\student\wildfire_mfg_330\modu@ -click, and select Make Working

Directory. :

2. Open COVER.MFG. ©
?”(

Step 2. Create a site file.

We can now create a milling site p, flle Site parameter files are useful because they
allow us to set defaults for al nce parameters. We can also enter relations in site files

to automatically transfer p values from our tool feed and speed data.

Notice the headin of the mill site window. The various columns allow us to set the
default value, the uprer gnd lower range, the visibility in the NC Sequence Set Up, the visibility in
the InformatioRQutput, and the inheritance.

Notic -. tructure on the left side, we can expand and collapse the categories as required.

Noticethe various entries in the Default values column. The —1 entries indicate that the
parameter is required and therefore must be specified when creating NC Sequences. The dash

values indicate an optional item, which can be configured if required.
We can now set some new default values

Changing the default LACE_OPTION to LINE_CONNECT specifies that for surface milling
sequences, cut motions will be connected instead of retracting and repositioning between each

pass.
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The STEP_OVER parameter controls the tool step over between passes. Setting it to

TOOL _ROUGH_RADIAL DEPTH will read in the value stored with the tool. The ROUGH in the
parameter name indicates that it will read in the tool information for roughing the current stock
material. We could change the ROUGH to FINISH and read in the corresponding finish

parameter.

The STEP_DEPTH parameter controls the depth in Z of each pass. Setting it to
TOOL _ROUGH_AXIAL_DEPTH will read in the value stored with the tool.

Setting the ROUGH_STOCK value to 0.75 will give us a standard amount of stock%m for
roughing sequences.

Setting the CUT_FEED to TOOL _ROUGH_FEED RATE will automatican the feed data

value stored with the tool.

Setting the RETRACT and FREE_FEED rates to zero will outp eed rates whenever

they are used.

Setting the SPINDLE _SPEED to TOOL_ROUGH_SPIND M will automatically read in the

spindle speed stored with the tool

We can set the default values for COOLANT er compensat/on to on. The CUTCOM will
only be applied when machining with the f tHe tool.

Lastly, we set the default value for 8 IST, this controls the distance above the machined

surface, at which the RAPID matidhends, and the PLUNGE_FEED begins.

1. Using the Menu Mana@ ct Mfg setup > Param Setup > Site > Create, name the
site file [RG%_S_@ d select the Mill option.

2. Reviewthe ¢ the site parameter file window.

3. Inthe N category, enter the following values in the DEFAULT VALUE column:

Table 2: Cut Option Default Values

anufacturing Parameter | Default Value
Q LACE_OPTION LINE_CONNECT

Note:

LINE_CONNECT specifies that for surface milling sequences, cut motions will be
connected instead of retracting and repositioning between each pass.

4. Inthe CUT PARAM category enter the following values in the DEFAULT VALUE column:

Table 3: Cut Parameter Default Values
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Manufacturing Parameter

Default Value

STEP_DEPTH

TOOL_ROUGH_AXIAL_DEPTH

STEP_OVER

TOOL_ROUGH_RADIAL_DEPTH

ROUGH_STOCK_ALLOW

0.75 (0.03 in.)

Note:

TOOL_ROUGH_AXIAL_DEPTH and TOOL_ROUGH_RADIAL_DEPTH will use
calculated values based on workpiece material and tool diameter.

5.

Table 4:Feed Option Default Values

In the FEED category enter the following values in the DEFAULT VALUE colum

@@

Manufacturing Parameter

Default Value

CUT_FEED

)

TOOL_ROUGH_FEED_RATE

RETRACT_FEED

0

FREE_FEED

=
N

0

ANA

Note:

command for that feed rate.

TOOL_ROUGH_FEED_RATE will use a cal
material and tool diameter. Entering zero

c@@ue based on workpiece

{o(\% dfate will output a RAPID

&

6.

In the MACHINE category enter th

i

chine Option Default Values

Manufacturing Parameter]

“Default Value

N

SPINDLE_SPEEDN

TOOL_ROUGH_SPINDLE_RPM

COOLANT OPT(QN)p>

ON

ON

CUTCOMS

N
%chniques

aterigl and tool diameter.

OUGH_SPINDLE_RPM will use a calculated value based on workpiece

7.

In the ENTRY/EXIT category enter the following values in the DEFAULT VALUE column:

Table 6: Entry and Exit Default Values

Manufacturing Parameter

Default Value

CLEAR_DIST

5 (0.20 in.)

8. In the site tree window, click File

> Exit, to close the window.
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values in the DEFAULT VALUE column:
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Note:

Do not select Quit, you will lose all your work, you must select Exit.

9. Save the site parameter file, select RGH_3_AXIS_MIL from the list.

Note:
Notice the site file name is appended with _MIL, to show it is a mill site file.

10. Close all of the open menus. %\

Step 3. Activate the site file within the workcell. Q((\ i
@ e create new

NC sequences. Site files are set using the defaults button in the workcell diglog box. You must

activate the site file by selecting the check box next to its name. Y@ only associate a single

site file of each type to your workcell. This means that you ar% parate site files for milling
and holemaking active in your workcell. If you use a geperal b

Finally, we can activate the site file within the workcell so that it will be us

you can only associate that
one site file to the workcell.

When you are creating an NC Sequence, you hation to deactivate this site file, or to pick

another site file.
If we save this Workcell after we have a @r site file, the site file will be stored with the

workcell. OX

1. Using the Menu Manager, fg Setup > Workcell to open the Workcell dialog box.
Click the Defaults butt@ elect the RGH_3_AXIS_MIL check box. This activates the

site file.
2. Complete the%\@nd close the Workcell dialog box.

Y
You ustactivate the site file by selecting the check box next to its name. You can
@Iy assdciate a single site file of each type to a workcell.

3.@e the manufacturing model.

4. Close all windows and erase all models from memory.
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Summary

After successfully completing this module, you should know how to:

« Describe how manufacturing parameters control NC sequences.
¢ Describe the different methods used to set and edit parameter values.

« Edit and activate site parameter files.
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Module

Creating Face Milling Sequences

\‘
Introduction @

When milling components, one of the first tasks is @o face down the

workpiece. This enables you to define the top s he job and a reference

surface for other NC sequences. When creéti milling sequences it is
important that you use the correct manufactu rameters to ensure the
toolpath is generated efficiently. You can eate mill surfaces and use them

as alternate references when mode
model surfaces need to be mac ne surface. When a face milling
sequence is completed, you te the in-process workpiece geometry.
This is achieved by creatin rial removal feature that removes the

machined volume f&om.’ o piece.

Objectives g&\

After com@ S'module, you will be able to:
face milling process.

ﬁe the key face milling manufacturing parameters.

eate face milling sequences.

rfaces are inappropriate, as when multiple

Create mill surfaces relevant to face milling.

« Create material removal features specific to face milling.

Q)
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Creating Milling Sequences with Pro/ENGINEER
Wildfire

Module 7: Creating Face Milling Sequences

& PTC@Q
@

Instructor Preparation

Before teaching Creating Milling Sequences with Pro/ENGIN@@/dﬁre, you must have read and
thoroughly understood the following materials:

* General Information
* Review Pro/ENGINEER Wildfire primer site at web.ptc.com/primer/

* Pro/E Wildfire Documentation o
* Review Pro/ENGINEER Wildfire do

/GS Training Materials/Domain Knowled o&

‘0°

- Pro/E Wildfire Milling @
* Review Pro/ENGINEE@; e Milling training materials in Windmill, located in
/GS Ed Srvcs Operations/ ation Library/Instructor Materials/Instructor Kits/EN
/T979-330-Instructor Kit-

tion in Windmill, located in
te/ProENGINEER/Core Concepts

* Required Ski

» Completiot.of Pro/E Wildfire Foundation or equivalent Pro/E skills

. 2B (@u of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E
Hjty to install and configure Pro/E Wildfire

+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology




e . e |

Lesson Activities: Day Two

. " " Pro/FICIENCY
Using Creating Creating Evaluator
Creating Tools =% Manufacturing = Face Milling Profile Milling ! Doty
— - =+ | Assessments

Demos | (reating Tools Creating and Creating Creating i
e == Activating Site [ Face Milling Profile Milling [~~~
Parameter files

Creating Tools [77777[ Creating and Creating Creating =
1_':_3_!’_‘ ______ .| Activating Site | Face Milling Profile Milling |}
Parameter files

Duration %

Lecture: 15 mins
Demos (1): 25 mins

Labs (1): 50 mins @\
Total: 1 hr 30 mins @

1
2
S



Overview

el ric

Objectives

After completing this module, you should be able to:
Describe the face milling process.
Describe the key face milling manufacturing parameters.
Create face milling sequences.
Create mill surfaces relevant to face milling.

Create material removal features specific to face milling.

AN
o)

@

When milling components one of the first tasks is often to fac %he workpiece. This enables
you to define the top surface of the job and a reference surface jor other NC sequences. When

creating face milling sequences it is important that yoy use orrect manufacturing parameters to
ensure the toolpath is generated efficiently. You can alsp create mill surfaces and use them as
alternate references when model surfaces are inap iate, as when multiple model surfaces need
to be machined as one surface. Once a face milli Uence is completed you can update the in-

process workpiece geometry. This is achieved!by ¢keating a material removal feature that removes
the machined volume from the workpiece.

o
After successfully completing this mod@ will be able to:

Describe the face milling process.

Describe the key face milling ufacturing parameters.
Create face milling sequen

Create mill surfaces re ace milling.

Create material remo tures specific to face milling.

&



e . VrTC

Face Milling Process

Face down the workpiece

© Select or create a final finishing surface
o Reference model surface
o Mill surface

© Features

e Passes are parallel to the retract plane
eInner contours are ignored

QO

© Material removal after completion of NC sequence

Face Milling Process %
A face milling sequence allows you to face down the workpiege w t or radius end mill. The final
finishing surface is configured by selecting or creating a planarsurface parallel to the retract plane.

 All machining movements are parallel to the retract p&&

* All inner contours in the selected surfaces (holeii S@il| be automatically excluded.

* The toolpath will by default completely machi e'selected surface.

Once the toolpath is completed it is possib1> 0 ve the machined volume from the workpiece by

creating a material removal feature. &
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Mill Surfaces

Alternative Machining References

©® Manufacturing Geometry
© Created before or during NC sequence
© Example surface types
o Flat
o Extrude
« Copy l

Mill Surfaces %
Mill surfaces can be used as alternative machining referenceg, w del surfaces are not
appropriate, for example when face milling multiple model surtaces,

*Mill surfaces are known as manufacturing geometry. \
*They can be created before an NC sequence, or durin reation of an NC sequence.
*The most common surface types used are:
* Flat: create a flat surface by sketchin %\ on a sketching plane.
» Extrude: create an extruded surfac ching an outline on a sketching plane.

» Copy: copy existing model sur@ orm a new mill surface.

@}@
&
©&
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Key Parameters - Lateral Control

SCAN_TYPE TOOL_OVERLAP |__

«TYPE_1

«TYPE_3 ‘ B ‘a
« TYPE_ONE_DIR ‘

« TYPE_SPIRAL i

MACHINED 1

CUT_ANGLE SURTAGE i CUT_ANGLE
STEP_OVER 1

or NUMBER_PASSES

or TOOL_OVERLAP Q- ‘3

STEP_OVER_ADJUST STEP_OVER
NUMBER_PASSES = 3 @\
Slide 6 7 @

Key Parameters - Lateral Control @
SCAN_TYPE:

* TYPE_1 moves back and forth across the surface. 5
e s\eip;

* TYPE_3 if there are separate zones, machines each zon tely. Otherwise the same as
TYPE_1.

* TYPE_ONE_DIR machines in one direction and re@v tween passes.

* TYPE_SPIRAL will create a spiral toolpath.
CUT_ANGLE: The angle between the cut direct%@

he X-axis of the NC Sequence coordinate
system.

<&
These three parameters control the ste g@stance, the final toolpath will use whichever parameter
produces the smallest calculated step

+ STEP_OVER controls the steg@v ithin a slice.
* Or NUMBER_PASSES can d to explicitly set the number of passes to take in each slice.

* Or TOOL_OVERLAP car ed as an alternative method to control the step-over based on the
tool overlap.

If NUMBER_PASSE et to 1 however, step-over is ignored and one pass is created at the center of
the machined suftace for each slice. (see next slide)

The S _ADJUST parameter adjusts the passes in the slice to start and finish near the edges
of the ce you are machining. It only reduces the step over distance, and adds an extra pass if
needed.
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Key Parameters - Lateral Control

® If NUMBER_PASSES = 1
« One pass along surface center
® ONE_PASS_OFFSET
@ INITIAL_EDGE_OFFSET
® FINAL_EDGE_OFFSET

FINAL
EDGE MACHINED SURFACE INITIAL

A EDGE

A

-
+ | - . »

Sl \
FINAL_EDGE_OFFSET INITIAL_EDGE_OFFSET
ONE_ PASS_OFFSET éi\/j

Key Parameters - Lateral Control

If NUMBER _PASSES is set to 1, step-over is ignored and one pas e;ed at the center of the
machined surface for each slice.

The ONE_PASS_OFFSET controls the distance away fr&xthe centerline the single pass is made.

INITIAL_EDGE_OFFSET allows you to offset the fi @Jith respect to the edge of the surface
being milled.

o
FINAL_EDGE_OFFSET allows you to ofé&{@t pass with respect to the edge of the surface being

S,
@@

&
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Key Parameters - Depth Control

STEP_DEPTH
NUMBER_CUTS
BOTTOM_STOCK_ALLOW

TooL,

WORKPIECE MATERIAL N

y

\\\\\Q TBOTTOMisTOCKiALLOW
N
D
Key Parameters - Depth Control % @

When using a workpiece, the starting height for the cuts will be d

A

7

Slide 8

d by the top of the workpiece.

The STEP_DEPTH parameter can be used to specify theNd
NUMBER_CUTS parameter can be used to determine

epth between each slice or the
\nber of slices.

The parameter that creates the most slices will be@

o
If the NUMBER_CUTS =1 and the STE @s greater than the depth to be machined, then one
pass is taken at full depth.

The BOTTOM_STOCK_ALLOW r determines how much stock is left on the machined
surface. The default dash (-) v il leave zero stock.

O
©
K
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Key Parameters - Entry and Exit

1. APPROACH_DISTANCE + START_OVERTRAVEL
2. END_OVERTRAVEL

3. START_OVERTRAVEL

4. EXIT_DISTANCE + END_OVERTRAVEL

ENTRY_EDGE = CENTER
CLEARANCE_EDGE = CENTER

]
************************************ o @Q

Key Parameters %@
The START_OVERTRAVEL adds an offset to the beginning g@e s in a slice. The
slice.

Slide 9

END_OVERTRAVEL adds an offset to the end of each pass

The APPROACH_DISTANCE parameter will add an e Nroach distance to the first pass of each
slice. The EXIT_DISTANCE parameters will add an e tance to the last pass of each slice.

The ENTRY_EDGE parameter can be set to _EDGE (the default), CENTER or HEEL. This
parameter controls which point of the tool i r measuring the approach and over travel motions
when the tool approach the material for SS in a slice.

This parameter controls which poi he tool is used for measuring the exit and over travel motions

0
when the tool leaves the mat@ ach pass in a slice.

The CLEARANCE_EDGE parame@g@@é set to HEEL (the default), CENTER or LEADING_EDGE.

Q)
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Key Parameters

TRIM_TO_WORKPIECE

With a Workpiece
® TRIM_TO_WORKPIECE = NO

® Toolpath extends to boundary of machined
surface

® TRIM_TO_WORKPIECE = YES
® Toolpath adjusts to boundary of workpiece
Without a Workpiece

® Toolpath extends to boundary of machined
surface

Key Parameters

TRIM_TO_WORKPIECE 7?;
Face milling sequences behave differently depending on if a pigce is in the model.

With a workpiece, the starting height for the cuts will e one cut depth below the top of the
workpiece.
If TRIM_TO_WORKPIECE is set to NO, (tgp fi@;
* The toolpath machines the selected out regard to the workpiece outline.
If TRIM_TO_WORKPIECE is setto Y m figure):

machining.

Without a workpiece, th@@eight for the cuts will be determined exclusively by the sequence

* The toolpath extends or trims t@ piece cross-section at the depth of the surface you are

parameters and the toolp pletely machines the selected surface.

&
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating a Face Milling Sequence

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Creating Face Milling Sequences %
Scenario

» Throughout this course, the exercise scenarios are th%ne as the demo scenarios.
» This has been done to build consistency between Q@é nd lab exercises so as to enable “Tell

me—Show me—Let me do.” @
Method o
Use the script in the instructors guide, us&s rie models as in the exercises.

Exercise
Once the demo is complete t%e s should use the steps in the training guide to complete the

Q)
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Summary

After successfully completing this module, you should know how to:
© Describe the face milling process.
© Describe the key face milling manufacturing parameters.
® Create face milling sequences.
® Create mill surfaces relevant to face milling.

© Create material removal features specific to face milling.

QO

Summary %

After successfully completing this module, you should know how to;
* Describe the face milling process. \
Describe the key face milling manufacturing param@v
Create face milling sequences.
Create mill surfaces relevant to face milling

Create material removal features speci@i milling.
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Module 7 Lab Exercises
Exercise 1: Creating Face Milling Sequences

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

» Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2003051 or later.

» Download and install the class fileswi | df i re_mi I | = : t ar . gz as described in

the classroom setup notes.

Introduction @;\
. . ¢

In this demonstration, you create a mill suﬁ@ € facing sequence to create a modified
toolpath that reflects the workpiece sha@o hen create a facing sequence by using the
e to machine. You then reference the mill surface for

reference model surface to specif
the facing sequence to create 3 toolpath that reflects the workpiece shape. Finally, you
mlshed toolpath.

adjust the parameters to C@

Objectives

After succes IIIeting this exercise, you will know how to:

e Creat flling sequences.

. C% mill"surfaces relevant to face milling.
a

O

cenario

material removal features specific to face milling.

You are now ready to begin machining the aluminum cover; you start by creating a face milling
sequence on one side of the component. During the creation of this sequence you adjust
sequence parameters and references to create a more efficient toolpath.

Parameters

The following are key face milling parameters.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 7-3
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Table 1: Parameter Descriptions

Parameter Description

SCAN_TYPE The method of scanning the machined area.

CUT_ANGLE The angle of cuts relative to NC sequence coordinate system.
STEP_OVER Distance between passes.

NUMBER_PASSES

Number of passes per slice.

TOOL_OVERLAP

Tool step over calculated by overlap distance.

STEP_OVER_ADJUST

Adjust STEP_OVER to provide complete coverage of

; g
machined area.

ONE_PASS_OFFSET

For one pass milling offset pass to left or right. {(\

INITIAL_EDGE_OFFSET

Offset the center of the tool from the initial edge. /™

FINAL_EDGE_OFFSET

Offset the center of the tool from the final edge. \K ))

STEP_DEPTH

The incremental depth of each cut.

NUMBER_CUTS

Calculate the step depth using number o/fvctﬂf\s@)

BOTTOM_STOCK_ALLOW

Amount of stock left on final machirgd

APPROACH_DISTANCE

Extra approach distance for theditst pé%s%?each slice.

EXIT_DISTANCE

Extra exit distance for the last paMech slice.

START_OVERTRAVEL

Offset distance at the begiﬁ@%\of each pass.

END_OVERTRAVEL

Offset distance at the eﬁé@ch pass.

TRIM_TO_WORKPIECE

Specifies if the too regyjcted to machining inside the
workpiece. N

Step 1. Locate and open the cover manufactaring-middel.

Before creating the face milling sequeng

it using the folder navigator. Once

reed to locate the manufacturing model and open

NN
cated the folder for this exercise we can set this as

ufacturing model of the cover.

our working directory, and op%
1. In the navigator, sele der Browser tab, and browse to

c:\users\stu t
Directory.

e_mfg_330\module07, right-click, and select Make Working

2. Open COYER.MFG, and turn off any displayed datum features.

Step 27 Cﬁﬁ{até)a mill surface as an alternative reference for the facing sequence.

We create a mill surface to control the extent of the face milling sequence. We can do this if

we are not using a workpiece or if we need to have more control over the toolpath.

Mill surfaces are useful because they can be used as alternative references when model

references are not appropriate.

We need to create a flat rectangular surface that extends to the edges of the workpiece and is

positioned on the top surface of the reference model.

Page 7-4
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To do this, we create a mill surface using the Flat option. We select the top of the reference
model as our sketching plane. In the sketcher environment, we click the Use Edge option and

Loop check box and select the top surface of the workpiece to loop.

When the surface is completed we can select the surface in the model tree, right-click and select

Hide from the drop down list to blank the surface.

1. Using the Menu Manager, select Mfg Setup > Mfg Geometry > Mill Surf > Create, and
name the surface [FACE SURF].

2. Select Add > Flat > Done to create a flat mill surface. §

3. When prompted to, select a sketching plane move the cursor over the 3 surface of
the reference model, right-click until the reference model surface highlig then select it as
the sketching plane, as shown in the following figure.

4. Accept the arrow pointing down into the workpiece as the dj t viewing the sketching

plane. %

owing cursor position and selected sketching surface.

5. When pr select a sketching reference, select the front surface of the workpiece as

the boitom sk view reference, as shown in the following figure.

&

Figure 2: Showing cursor position and selected bottom sketching reference.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 7-5
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Note:

Selecting the sketching reference, enables the sketch to be orientated correctly
when entering the sketcher tool.

6. Close the References dialog box and accept that not enough references have been
specified.

7. Change your view to the named view OP010-TRI.

8. Click the Create an Entity from an Edge icon and select the four edges of the workpiec
create the sketch outline.

©
Figure 3: Showing sele @of the workpiece.

<
9. Complete the sketch and close the SL& g box.
10. Return to the Manufacture menu.

11. Select the surface in the mode@a@ right-click and select Hide from the drop-down list.

Tip: A
Using the mW tr@ can hide and unhide reference geometry as required.

Step 3. Create a faéeim}ﬁﬁ]g NC sequence.

to identify.

We can no e a face milling sequence. We enter a name for the sequence to make it easy
@an select the SH_MILL 50 0 tool. Notice how the site parameter file sets all the

req manufacturing parameters; this includes reading in the speed, feed and depth-of-cut
data for'this tool. Select the top surface of the part to machine. Play the toolpath.

Notice how the toolpath is not square, but follows the outline of the surface we are machining.

We can change the TRIM_TO_WORKPIECE parameter to YES to see the effect on the toolpath.
When we play the toolpath, notice how the toolpath now follows the workpiece shape instead of

the surface we are machining.
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Using the Menu Manager, select Machining > NC Sequence > Face > Done to create a
face milling sequence.

In the Seq Setup menu, select the Name check box, and complete the selection of options.

Note:

The Seq Setup menu provides a list of options that can be configured for each NC
Sequence. Some options are required, others are optional. You can reconfigure
options at any time during the creation of an NC sequence. Notice the Tool,
Parameters and Surfaces options were automatically selected as required. Q
Name the sequence [FACE_BOTTOM. ?)

In the Tools Setup dialog box, select the SH_MILL_50_0 tool, then ‘ select
Select Tool and Return.

Change your view to the named view OP010-TRI. @

In the Mfg Params menu, select Done to accept the de%\ argmeters.

N\

Note:
Notice that you are not required to enter any %eters, the site parameter file
configures all required parameters. %

In the Surf Pick menu, accept the Moii&/@n to choose surfaces from the reference

model. o

Move the cursor over the hid topsurface of the reference model until the surface
highlights, select it as the machine, as shown in the following figure. Then

complete the surface @ct rocess.

Figure 4: Showing cursor position and selected reference model surface.

9. Review the toolpath by selecting Play Path > Screen Play.

10. In the Play Path dialog box, click on the blue CL data bar, this will make the CL data visible in

the dialog box. Click on the Play Forward button to review the toolpath. To slow down the
toolpath simulation, click and drag the display speed slider to the left.
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Note:

Notice that the corners of the toolpath are not straight. The toolpath uses the
reference model surface being machined to determine the limits of the tool travel.

11. Close the Play Path dialog box when finished.

12. To modify the manufacturing parameters, click the Manufacturing Parameter Tree icon at the
top of the graphics window. This will make the parameter window appear.

13. In the Parameter Tree window, click the Advanced button to see all the manufacturing
parameters.

window.

14. Modify the TRIM_TO_WORKPIECE parameter to YES then close the param@@

15. Play the toolpath again by selecting Play Path > Screen Play. Then o@a the Play
Forward button to review the toolpath. Notice how the toolpath adju e/Shape of the

workpiece.

Tip:
To see the CL data when playing the toolpath, click o %CL Data arrow. Notice the
PPRINT entries at the beginning of the CL data file/ /\

A4

$ EATNO 131055

4 FUNCR01, 1
PEXCUTCOM_GEOMETRY_TYPE / OUTPUT_CON_CENT
ITS / Wb
(b PPRINT / DATE TIME : 20-NOY-02 16:25:33
PPRINT/ TOOL TABLE SUMMARY

PPRINT / TOOL NUMBER TOOLID  OFFSET NO TOC
10 PPRINT/ 17 SH_MILL 500 17
11 PPRINT /NG SEQUENCE MAME : FACE_BOTTOM
12 LOADTL/17. OSETHNO, 17
13 $$-> CUTTER,/50.000000
14 $$-> CSYS/1.0000000000. 00000000000, 00000000000, 0.(
15 0.0000000000, 1.0000000000, 0.0000000000, 0.000000
16 0.0000000000, 0.0000000000, 1.0000000000, 0.000000
17 SPINDL/RPM, 1165.010000, CLW
18 COOLNT/ON
19 RAPID

Figure 5: Showing PPRINT statements at beginning of CL data file.
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Figure 6: Toolpath with TRIM_TO_WORKPIECE set t

16. Close the Play Path dialog box when finished. @

17. Open the Parameter Tree Window again and set the TRIN\ T&”WORKPIECE parameter
back to NO, close the parameter tree window to complete fhie modification.

Step 4. Use the mill surface as an alternative mac;njbhg reference.

¢

We can use the previously created mill surface~as @ﬁ%maﬁve reference. Once we select the
surface we can confirm to use the upper si@ surface for machining, and also click to

Select All of this surface for machmin last option lets you select specific patches of

surface quilts if required. Q&\
We can play the toolpath and /@mat the toolpath is square and is relative to the mill surface,
not the top face of the refelfence model.

1. Usingthe M
select Mj > Done > Select Srf.

2. Inthe ch/¥ ool dialog box notice the surface named FACE_SUREF is selected, and click

O&
3. ewprompted, accept the upward facing side of the surface for machining, and use the
ect All option to complete the surface configuration.

Play the toolpath again by selecting Play Path >Screen Play. Notice how the toolpath
adjusts to the outline of the mill surface.

5. Close the Play Path dialog box when finished.

Step 5. Modify the sequence parameters to adjust the approach and exit moves, the step depth
and the cut angle.

We can modify several of the toolpath parameters to see their effect on the toolpath.
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Notice from the top view that the tool plunges close to the workpiece. We can specify an
approach and exit move by setting APPROACH_DIST and EXIT_DIST parameters. We can also
create a relation to the tool diameter, which updates if we change tools.

We can set the STEP_DEPTH to 2 to get several passes. We can also change the CUT_ANGLE

to 90. The CUT_ANGLE is measured relative to the x-axis of the sequence co-ordinate system.

We can set the NUMBER _CUTS parameter to 3. This computes a step depth less than the 2 mm

we entered previously and it will therefore override the STEP_DEPTH parameter and creatg 3
evenly spaced slices. We can also change the CUT_ANGLE back to 0. X

1. Open the Parameter Tree window and set the following parameters in the NC/@@

) N/
Tip: \/
You can adjust parameters by selecting the Parameter Tree icon at t@of the

screen. @\

Table 2: Changed Parameter@

Manufacturing Parameter Value Section

APPROACH_DISTANCE CUTTER_[?@}@\A ENTRY/EXIT
EXIT_DISTANCE CUTTE,?;QIM ENTRY/EXIT
STEP_DEPTH 2 (Q@’:@ CUT PARAM
CUT_ANGLE od( ) CUT PARAM

Notice some of the paramet ve brackets around the values. This means the
parameter is taking its xaltefrom the site parameter file. You can type in values to
break the links to the'si meter file. You can always reestablish the link by

selecting the%i @ e from drop down list.

| o

2. Play the toolpat by selecting Play Path > Screen Play.

&
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Figure 7: Showing the resultant toolpath. @
Tool Path Review:

By setting an APPROACH_DISTANCE and EXIT distance, t}-@? clears the
workpiece at the beginning and end of the toolpath. B sg%} EP_DEPTH of 2

(0.08 in.), we have 3 passes (our stock is 4.4 mm) (0. tice the third pass is
much smaller than the other two. The CUT_ANGKE makes the toolpath rotate 90
degrees relative to the X axis.

3. Open the Parameter Tree window and set thé(T ihg parameters in the sequence:

Table 3: €han Cut Parameters

Manufacturing Parameter (( ) [ Value Section

NUMBER_CUTS N 3 CUT PARAM

CUT ANGLE A\ 0 CUT PARAM
A%

4. Play the toolpath agai

Figure 8: Showing the resultant toolpath.

Tool Path Review:

Setting the NUMBER _CUTS to 3 will compute a smaller step depth than 2 (0.08 in.)
so NUMBER_CUTS will override the STEP_DEPTH parameter and we get 3 evenly
spaced passes.
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Step 6. Modify the sequence parameters to control the over travel on each pass. Check the final
toolpath in Vericut.

We can modify the START_OVERTRAVEL and END_OVERTRAVEL to make the tool cut past

the machined surface at the beginning and end of each pass.

We can also set the ENTRY_EDGE and CLEARANCE_EDGE to use the center of the tool as our

reference point for determining the over travel distances.

We can set the EDGE_OFFSET parameters to move the toolpath toward or away from the jnitjal
and final edges (passes). A positive value moves the toolpath into the machined surface, X

whereas a negative value moves the toolpath away from the machined surface.

We can verify the toolpath in Vericut. We use NC Check to launch Vericut. Whe vg the
toolpath, notice there are no collisions or gouging and we have machined d@ ourfinish
surface.

1. Open the Parameter Tree window and set the following paramete %& sequence:

Table 4: Changed Paranisters

Manufacturing Parameter Value /> ction

START_OVERTRAVEL 25 (0@&@.@ CUT PARAM

END_OVERTRAVEL 25 (098i) | CUT PARAM

ENTRY_EDGE o | CENJER ENTRY/EXIT

CLEARANCE_EDGE NS \Q\EN/TER ENTRY/EXIT
2. Play the toolpath again using the P, > Screen Play options.

Q©& - .J._”. .

Figure 9: Showing the resultant toolpath.

Tool Path Review:

Changing the ENTRY_EDGE and CLEARANCE_EDGE to CENTER, we specify
which part of the tool to measure the over travel from on each pass. Setting
START_OVERTRAVEL and END_OVERTRAVEL to 25 (0.98 in.), the center of the
tool moves 25 mm (0.98 in.) past the machined surface for each approach and 25
mm (0.98 in.) past the machined surface for each exit.
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3. Open the Parameter Tree window and set the following parameters in the sequence:

Table 5: Changed Offset Parameters

Manufacturing Parameter Value Section
INITIAL_EDGE_OFFSET CUTTER_DIAM/4 | CUT PARAM
FINAL_EDGE_OFFSET CUTTER_DIAM/4 | CUT PARAM

4. Play the toolpath again using the Play Path > Screen Play options.

i
kf*asv &

Figure 10: Sultant toolpath.
Tool Path Review:

We can set the EDGE OFFﬁ%§ eters to move the toolpath toward or away

from the initial and final ed ses). A positive value moves the toolpath into the
machined surface, a ne e moves the away from the machined surface.

5. Inthe Play Path me u@t NC Check to start Vericut. (You may need to wait a few
moments for Vericutto.start). Click on the Play to End icon to view the machining simulation.

Figure 11: Showing the resultant toolpath in Vericut.
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Tip:

To slow down the simulation, you can click on the Setup Motion icon, and in the
Motion dialog box drag the animation speed slider to the left. When playing the
toolpath, notice there are no collisions or gouging and we have machined down to
the finish surface.

6. Close Vericut and complete the sequence, and return to the Manufacture menu.

Step 7. Create a material removal feature to cut away the machined volume from the workpiece.\

2\
We can create a material removal feature to cut away the machined volume from the work%
tdée%v

Using the Automatic option means the system automatically determines the materi. e

from the workpiece. You also have the option to create the cut manually.

We can select the AutoAdd option to pick the workpiece automatically. By default, the cut will
only be visible in the assembly, you will not see the cut if you open the wogkon its own.

1. Using the Menu Manager, select Machining > Matrl Remaval
create a material removal feature for the face milling sequenc

E_BOTTOM to

2. Accept the Automatic option, click the Auto Add b select the workpiece to
intersect, and complete the feature.

Note: K
Notice the automatic cut created in the w

Step 8. Modify the face milling sequen;z@q\d\\fgwew the results.
o

We can change the SCAN_TYPE rto TYPE _ONE_DIR, this makes the tool cut in one

direction only, retracting betwee S.

1. Using the Menu elect Machining > NC Sequence > FACE_BOTTOM, to
redefine the fa equence

2. When proggpted pend All child features.

©
In se, suspending child features temporarily removes the material removal cut
ature from the workpiece.

3. Open the Parameter Tree window and set the following parameter in the sequence:

Table 6: New Scan Type Parameter

Manufacturing Parameter Value Section
SCAN_TYPE TYPE_ONE_DIR | CUT OPTION
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Figure 12: Showing the resultant toolpa}>

A

Tool Path Review:

between passes.

The TYPE_ONE_DIR setting will make the tool m@% direction, retracting

C
N

5. If time permits, set other SCAN_TYPE value

view the results. Return the

SCAN_TYPE to TYPE_1 before completing t sequence.
6. Complete the NC sequence. @

7. Save the manufacturing model.<> @

8. Close all windows and era::ponents from memory.

S

Q)
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Summary

After successfully completing this module, you should know how to:

» Describe the face milling process.
e Describe the key face milling manufacturing parameters.

e Create face milling sequences.

»  Create mill surfaces relevant to face milling.
« Create material removal features specific to face milling. \

\
&
O

0
2
S

Q)
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Creating Profile Milling Sequences

Q)

Module

\‘
Introduction @

Profile milling sequences enable you to rough and fj mill both vertical and
slanted surfaces. This is useful for machining t I Is of pockets and for
machining outside profiles of components. {{h ating profile milling

e

sequences, you can create mill surfaceg.and m as alternate references

when model surfaces are inappropriate, a the model surface being
machined has a variable depth. Another important skill with profile milling is the
ability to refine the entry and exit i of the toolpath to enable proper

machined surfaces. When milling sequence is completed, you can
update the in- process geometry. This is achieved by creating a
material removal e removes the machined volume from the workpiece.

0bjectives@§§9

After com@ this module, you will be able to:

. cyibe the profile milling process.
escribe the key profile milling manufacturing parameters.

s~/ Create profile milling sequences.

application of cutter compeg@\e d to eliminate witness lines from the

»  Create mill surfaces relevant to profile milling.

» Create material removal features specific to profile milling.
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Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 8: Creating Profile Milling Sequences

& PTC@Q
@

Instructor Preparation

Before teaching Creating Milling Sequences with Pro/ENGIN@@/dﬁre, you must have read and
thoroughly understood the following materials:

* General Information
* Review Pro/ENGINEER Wildfire primer site at web.ptc.com/primer/

* Pro/E Wildfire Documentation o
* Review Pro/ENGINEER Wildfire do

/GS Training Materials/Domain Knowled o&

‘0°

- Pro/E Wildfire Milling @
* Review Pro/ENGINEE@; e Milling training materials in Windmill, located in
/GS Ed Srvcs Operations/ ation Library/Instructor Materials/Instructor Kits/EN
/T979-330-Instructor Kit-

tion in Windmill, located in
te/ProENGINEER/Core Concepts

* Required Ski

» Completiot.of Pro/E Wildfire Foundation or equivalent Pro/E skills

. 2B (@u of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E
Hjty to install and configure Pro/E Wildfire

+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Two

Pro/FICIENCY
Evaluator
Daily
Assessments

Using Creating
:| Ureq | Creating Tools F==3{ Manufacturing (== Face Milling

\ \ \

Creating
#| Profile Milling i

Demos Creating Tools Creating and Creating Creating
"""""" N [ Activating Site [ Face Milling [ Profile Milling
Parameter files Seqeunces Seqeunces
[labs 7| Creating Tools [T Creating and  [-——— Creating Creating
{Labs | || Activatingsite | | FaceMiling | Profile Milling -
Parameter files Seqeunces Seqeunces

Duration %

* Lecture: 15 mins
* Demos (1): 25 mins \
« Labs (1): 50 mins @

1
2
S

Total: 1 hr 30 mins @
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Objectives

After completing this module, you should be able to:
Describe the profile milling process.
Describe the key profile milling manufacturing parameters.
Create profile milling sequences.
Create mill surfaces relevant to profile milling.

Create material removal features specific to profile milling.

o)
@,

Overview %‘

* Profile milling sequences enable you to rough and finish mill ical and slanted surfaces.
This is useful for machining the sidewalls of pockets and fermaghining outside profiles of
components. When creating profile milling sequenceou C so create mill surfaces and use
them as alternate references when model surfaces are ppropriate, for example when the model

surface being machined has a variable depth. Another.important skill with profile milling is the ability
to refine the entry and exit motions of the toolpa tole proper application of cutter

compensation, and to eliminate witness lines framke machined surfaces. Once a profile milling

sequence is completed, you can update th ess workpiece geometry, this is achieved by
0 :‘. th

creating a material removal feature thatre e machined volume from the workpiece.

After successfully completing this mu will be able to:
S|

* Describe the profile milling pro
* Describe the key profile milli @

+ Create profile milling
» Create mill surfaces ré¢
« Create material

ufacturing parameters.

o profile milling.
Zatures specific to profile milling.
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Profile Milling Process

Mill Vertical or Slanted Surfaces
® Select or create a final finishing surface
« Reference model surface
o Mill surface
Mill Surfaces
©® Manufacturing Geometry
© Created before or during NC sequence
©® Example Surface Types
o Flat
o Extrude

o Copy

Profile Milling Process %;
Profile milling sequences are used to rough or finish mill both ve lanted surfaces. The final
finishing surface is configured by selecting reference model sufacey or creating a mill surface.

*Mill surfaces are known as manufacturing geometry. \
*They can be created before an NC sequence, or durin@%reation of an NC sequence.

*The most common surface types used are: @

@ on a sketching plane.

orm a new mill surface.

* Flat: create a flat surface by sketching

» Extrude: create an extruded surface

» Copy: copy existing model surf@

N

Q)
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Profile Milling Process

© Profile Milling Features
« Selected surfaces must allow for a continuous toolpath
o Final cut depth references depth of surfaces

o Tool approach and exit motions possible

® Customizing the Toolpath
o Modify default cut motions
o Build Cut or Customize

NC SEQUENCE

APPROACH TOOL MOTION

AUTOMATIC CUT MOTION

= N}

©® Material Removal after completion of NC sequence

Profile Milling Features
+ Selected surfaces must allow for a continuous toolpath.

* Final cut depth references depth of surfaces.
» Tool approach and exit motions are possible. \

manufacturing parameters.

* |t is possible to modify these defaug cu@

moves. X
* Two tools are available to do thi
* Build Cut: the Build Cut func ity lets you add or remove slices or cutting passes, and

By default tool-paths are generated based on @@a reference geometry and the
ions

by adding alternative approach and exit

specify approach and m )
» Customize: allows on of the default cut motions, this includes removing default cut-
motions and adli oW own cut-motions including approach and exit tool-motions.

* Both tools proy sséntially the same functionality, but use different interfaces.

Once the toolpath is eted it is possible to remove the machined volume from the workpiece by
creating a mate@em al feature.

Q®
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Key Parameters

Depth Control

® STEP_DEPTH |
- REFERENCE MODEL  |fTOOL
® AXIS_SHIFT

¥
AXIS_SHIFT

A

Lateral Control
©® PROF_INCREMENT
® NUMBER_PROF_PASSES \
® PROF_STOCK_ALLOW -
NUM_PROF_PASSES =2  PROF_INCREMENT ;; zi

Key Parameters @
Depth Control %
+ STEP_DEPTH: the incremental depth of each cut for eac@i Ss.

* AXIS_SHIFT: moves the CL data up or down along t%) ig/

Lateral Control %
* PROF_INCREMENT: horizontal distance betv@ SSes.
* NUM_PROF_PASSES: number of profile p t each depth.
* PROF_STOCK_ALLOW: remaining sf?) rial left on profile milled surfaces.

N
@@@
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Key Parameters

Lead-In and Lead-Out Motions NORMAL LEAD_STEP oo
CUTCOM T N POINT
LEAD_IN | L
LEAD_OUT '

LEAD_RADIUS |

TANGENT_LEAD_STEP
NORMAL_LEAD_STEP
OVERTRAVEL_DISTANCE

BUILD CUT T
¢ APPROACH_DISTANCE OVERTRAVEL_DISTANCE
«EXIT_DISTANCE
LEAD-IN AND LEAD-OUT

TOOL MOTION

)

LEAD_RADIUS

TANGENT_LEAD_STEP

Key Parameters — Lead-In and Lead-Out Motions @
CUTCOM: turns cutter compensation on or off in the CL data file figuring a workcell you can
specify if the cutter compensation is to the tool center (default) or e.

LEAD_IN/LEAD_OUT: set to YES, tool enters and exits the igge along a tangent arc.
LEAD_RADIUS: radius value of the tangent circle move faxlead-in or lead-out.
TANGENT _LEAD_STEP: linear distance of the tange of a lead in or lead out motion.
NORMAL_LEAD_ STEP: linear distance of the no@% of a lead in or lead out motion.

¢

OVERTRAVEL_DISTANCE: for profile milling t ance the tool travels past the start of a profile
pass. o <§ ;\4

BUILD CUT: for profile milling, build cut i % al element. It enables creation of approach and exit
moves, these can be used as an alternat%%g ad-in and lead-out motions.
APPROACH_DISTANCE: used when%g cut motions or using build cut. The distance of an

r

approach move for a tangent or nofmal oach.
EXIT_DISTANCE: used when cut motions or using build cut. The distance of an exit move for
a tangent or normal exit.

S
@@&@
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating a Profile Milling Sequence

Once the demonstration, is complete you should use the steps in the
training guide to complete the exercise.

Demonstration: Creating Profile Milling Sequences %
Scenario

» Throughout this course, the exercise scenarios are th%ne as the demo scenarios.
» This has been done to build consistency between Q@é nd lab exercises so as to enable “Tell

me—Show me—Let me do.” @
Method o
Use the script in the instructors guide, us&s rie models as in the exercises.

Exercise
Once the demo is complete t%e s should use the steps in the training guide to complete the

Q)
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Daily Skill Checks

Evaluate your progress:
® Achieve the course objectives.
® Use Pro/FICIENCY assessment questions.

® Apply Precision Learning.

QO

Precision Learning %e
* Learn: by listening to lectures, watching demos, and completi Xercises.
» Assess: your progress with Pro/FICIENCY.

* Improve: The next day the instructor reviews the exa esults of the group and reviews those
topics that received the fewest correct answers.

Getting Started @
» Before lunch on the first day of class, S@t customer accounts.

* When the customers are returning fr fer them to the new Appendix.
* Have them take the sample exam
* Review the results of the grou @ p’as an icebreaker.

Daily Tests @
Description: For each 00\.@ w 10 question exams based upon the topics covered each day.

How to use it:

* Use the cust@gmer atcounts already setup for the sample exam.

* Atthe e %@h day the customers take the 10 question exam relating to that days’ topics.
* Theiie @uing, review the results of the group.

* Re those topics with the class that obtained the most incorrect answers.
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Summary

After successfully completing this module, you should know how
to:

© Describe the profile milling process.

© Describe the key profile milling manufacturing parameters.
® Create profile milling sequences.

© Create mill surfaces relevant to profile milling.

© Create material removal features specific to profile milling.

QO

Summary %

After successfully completing this module, you should know how to;
* Describe the profile milling process

Describe the key profile milling manufacturing para

Create profile milling sequences

Create mill surfaces relevant to profile millin
Create material removal features speciﬁ@ile milling
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Module 8 Lab Exercises
Exercise 1: Creating Profile Milling Sequences

Demonstration Instructions

Preparation

Complete the following tasks before running this demo for customers:

e Practice running the demo so you can easily complete it. : @

* Check for and review the errata sheet for this course.

. Use Pro/ENGINEER Wildfire build code 2003051 or later. @

» Download and install the class fileswi | dfire m | | i ng% ar . gz [dwllas

described in the classroom setup notes.

Introduction
In this demonstration, you create a profile milling e. You initially use a reference model
e e a mill surface for the profile milling

surface to specify the surface to machine. Y

sequence to create a modified toolpath tha %s the final pass will be at a constant z-depth.
You also adjust the parameters to atoach and exit motions to eliminate witness lines
from the machined surfaces. @61@

Objectives @
After successfully complati is exercise, you will know how to:

e Create prgfil

g sequences.
ces relevant to profile milling.

rial removal features specific to profile milling.

Sr (]

he next step as you continue machining the aluminum cover is to create a profile milling
quence to machine the material around the outside of the component. During the creation of
this sequence, you adjust sequence parameters to create a more efficient toolpath. You then
redefine the sequence to reference a mill surface that ensures the final pass will be at a constant
z-depth. You also create lead-in and lead-out motions to eliminate witness lines from the
machined surfaces.

Parameters

The following are key profile milling parameters.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 8-3
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Table 1: Parameter Descriptions

Parameter Description

STEP_DEPTH The incremental depth of each cut.

AXIS_SHIFT Moves the CL data up or down along the tool axis.

NUM_PROF_PASSES Number of profile passes at each depth.

PROF_INCREMENT Horizontal distance between passes.

PROF_STOCK_ALLOW Remaining stock material left on profile milled surfaces.

CUTCOM Turns cutter compensation on or off in the CL data file. K

LEAD_IN Set to YES, tool enters workpiece along a tangent arc. S

LEAD_OUT Set to YES, tool exits workpiece along a tangent arc. o((\

LEAD_RADIUS Radius value of the tangent circle move for lead-in or Ieaqém

NORMAL_LEAD STEP Linear distance of the normal section of a lead in or lead Qul m(ﬁ)zsn.

TANGENT _LEAD STEP Linear distance of the tangent section of a lead in o;leQd outTmotion.

OVERTRAVEL_DISTANCE For profile milling the distance the tool travels past rt of a profile
pass.

APPROACH_DISTANCE Used when creating cut motions or using b\ﬁg& he distance of an
approach move for a tangent or norm ro

EXIT_DISTANCE Used when creating cut motion usmg\buﬂé cut. The distance of an exit
move for a tangent or normal esx

(s

Step 1. Locate and open the cover manufacturing rmﬁﬁt\

Before creating the profile milling sequence we’ ocate the manufacturing model and
open it using the folder navigator. When cated the folder for this exercise, we can set
this as our working directory, and open ‘;-r~ factur/ng model of the cover.

1. In the navigator, select the Fol@owsertab and browse to

c:\users\student\wildfir 330\module08, right-click, and select Make Working
Directory.

2. Open COVER{@ off any displayed datum features.

Step 2. Create a m|I ace as an alternative reference for the profile milling sequence.

contrgtthe

As an alterpati machining the reference model surfaces, we can create a mill surface to
< > of the final profiling pass.

Mill suxtaces are useful because they can be used as alternative references when model

references are not appropriate.

We need to create an extruded surface from the top of the reference model and with the same
outline as the outer profile of the reference model. The depth should be deep enough to machine

the profile without gouging the vise.
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To do this we create a mill surface using the Extrude option. We select the top of the reference
model as our sketching plane. In the sketcher environment, we click the Use Edge option and

Loop check box and select the top surface of the reference model to get the required edges.

When the surface is completed we can select the surface in the model tree, right-click and select

Hide from the drop down list to blank the surface.

1. Using the Menu Manager, select Mfg Setup > Mfg Geometry > Mill Surf > Create, and
name the surface [PROF_SURF].

2. Select Add > Extruded > Done. Accept the attributes of One Side and @
surface of

3. When prompted to select a sketching plane move the cursor over the
the reference model, right-click until the reference model surface hig en select it as

the sketching plane, as shown in the following figure.

Figure 1: Sho or position and selected sketching surface.

4. Accept the arrow pointi Ei mto the workpiece as the direction for viewing the sketching

plane.

5. When prom @lt a sketching reference, select the front surface of the workpiece as
the bottorn s reference, as shown in the following figure.

&

Figure 2: Showing cursor position and selected bottom sketching reference.

6. Close the references dialog box and accept that not enough references have been specified.

7. Change the view to the named view OP010-TRI.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 8-5
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Note:
Using the named view makes selecting the edges easier.

8. Click the Create an Entity from an Edge icon and using the Loop option, select the top
surface of the reference model as shown in the following figure. Accept the outer loop of
edges.

&
Figure 3: Showing selected loop surface and highlighted t@ of edges

9. Complete the sketch.

10. Specify a Blind surface depth of [16] (0.63 in.). @\

11. Preview and complete the extruded surface. @
12. Return to the Manufacture menu. o
13. Select the surface in the model tree, r@@k and select Hide from the drop-down list.

Tip: @

Using the model tree you ca@ and unhide reference geometry as required.

Step 3. Create a profile rﬁiﬁm\w\éequence.

We can create a ppofile Mequence. We enter a name for the sequence to make it easy to
identify. We can se the’ FEM_25 0 tool. Notice how the site parameter file sets all the
required mand%tf/ring parameters; this includes reading in the speed, feed and depth-of-cut
data fg tf@. owever, we can set the STEP_DEPTH to 10 before proceeding. We need to
select the’s alls of the reference model for machining. We can do this by choosing the loop
option, gglecting the top surface on the reference model, and selecting an outer edge to configure
the surfaces to be machined. When playing the toolpath, notice the tool only makes one complete
pass around the part. In the second cut, the tool cannot make a complete pass because the

model surface is not continuous at that depth.

1. Using the Menu Manager, select Machining > NC Sequence > New Sequence >
Profile > Done, to create a profile milling sequence.
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2. Inthe Seq Setup menu, select the Name, Tool and Parameters check boxes, and
complete the selection of options.

3. Name the sequence [PROF_BOTTOM.
4. Select the FEM_25_0 tool for the sequence.

5. Change the view to the named view OP010-TRI.

Note:
Notice that the site parameter file configures values for all required paramete

</
6. In the Mfg Params menu, select Set. In the Parameter Tree window, ghck ed to see
all the manufacturing parameters, and modify the STEP_DEPTH pari,o 107 (0.39in.)

7. Accept the Model option to choose surfaces from the referenc@el. When prompted to

select surfaces to be machined use the Loop option.

8. Move the cursor over the hidden top surface of the refe el, right-click until the
reference model surface highlights, then select it as loop surface, as shown in the
following figure.

9. When prompted select the edge as shown in
selection process.

’Zwing figure, and complete the surface

Figure 5: Showing highlighted edge and resulting vertical reference model surfaces.

10. Play the tool path using the Play Path > Screen Play options.
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Figure 6: Showing the resultant toolpath. @\

Note: w
Notice the tool only makes one complete pass around the model. In the seco ut,

the tool cannot make a complete pass because the model surface is ntinuous
at that depth.
=)
Step 4. Use the extruded mill surface as an alternative machiniﬁg\refe\r%nce.

N
We can use the previously created mill surface as an altern%ference. Once we select the

surface, we can confirm to use the outward pointing sun‘a@%
Select All of these surfaces for machining. This Ia@ ts you select specific patches of

achining, and also click to

surface quilts if required.

o
We can play the toolpath and notice that f| fo\{z;@now makes two complete passes around
the model and adjusts the depth of the E ilé pass to the depth of the mill surface.

1. Using the Menu Manager, seld¢t SeqSetup, and select the Surfaces check box. Then

select Mill Surface > Don ect Srfs.

2. Inthe Search Tool di 0x; select the surface named PROF_SURF, and click OK.

3. When prompt ceptthe outward facing side of the surface for machining, and use the
Select All optio omplete the surface configuration.

Q)
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Figure 7: Showing the mill surface. @

4. Play the toolpath again by selecting Play Path >Screen Play. Notic he toolpath
adjusts to the outline of the mill surface. @

Figure 8: Showing the resultant toolpath.

5. Close the PI?@OQ box when finished.

Step 5. Nkﬁ(if%é&quence parameters to adjust the entry and exit moves.

Notice owMand lead-out moves already exist, this is because some of the site parameter
file valtres have partially configured lead-in and lead-out moves.

change several of the toolpath parameters to modify the lead-in and lead-out moves on
he toolpath.
We can specify a NORMAL _LEAD STEP and TANGENT _LEAD_STEP of 10. This provides us

with lead-in and lead-out moves where the cutter compensation is applied and removed.

We can also specify the OVERTRAVEL DISTANCE as 5. This creates an over travel at the end

of each pass ensuring that witness lines are removed.
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1. Open the Parameter Tree window and check the values of the following parameters; notice
these values have been set from the site parameter file.

Table 2: Entry/Exit parameters set by the site parameter file.

Manufacturing Parameter Site Parameter Value

CUTCOM ON

LEAD_IN YES

LEAD_OUT YES

LEAD_RADIUS 10 (0.39n.)

2. Set the following parameters in the NC Sequence: @\
Table 3: Changed Parameters @

Manufacturing Parameter Value Section
TANGENT _LEAD_STEP 10 (0.39in.) ENTRY/EXI(I@ q
NORMAL_LEAD_STEP 10 (0.39in.) ENTRY,
OVERTRAVEL_DISTANCE 5 (0.20 in.) ENTRYEXY

3. Play the toolpath again using the Play Path > Screen Play wpti

igure 9: Showing the resultant toolpath.

Tool Path i

Notice ddring thelead-in and lead-out moves the cutter compensation is applied.

Also the aver travel distance on each pass removes any witness lines from the
@o rfaces, however, we want to create a specific approach and exit

( }

Step 6. Create a specific approach and exit position using build cut functionality.

We can create a specific approach and exit position by building a cut motion and creating a user
defined approach and exit axis.

We can create a cut motion using the build cut option by configuring an approach point and
creating an axis positioned 24.5 from the right surface of the workpiece, and 54 from the front

surface of the workpiece. We can use the same axis to configure an exit point.
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We can set the NORMAL_LEAD STEP to zero as this move is now controlled by the position of
the axis. We can also set the TANGENT LEAD STEP to 5.

We can verify the toolpath in Vericut. We use NC Check to launch Vericut. When playing the
toolpath, notice there are no collisions or gouging and we have machined down to our finish
surface.
1. Turn on the display of datum axis.
2. Using the Menu Manager, select Seq Setup > Build Cut > Done to use the
option to create approach and exit moves. @
3. Using the Approach, Point and Each Slice options, Create an a 5pesify the start
point of the approach move.

4. When the Datum Axis dialog box appears, select the top suﬁac@e workpiece to position
the datum axis as shown in the following figure. Click and ((j% sitioning handles to

snap onto the front and right edges of the workpiece

N— .
Figure 10: Showing initial axis position

ions so that the axis is positioned 24.5 (0.96 in.) from the right edge of the
54 (2.13 in.) from the front edge of the workpiece, as shown below. Complete
thg@atum Xis configuration.

<)ou may need to enter negative values for the dimensions to get the axis to move to
the right of the workpiece.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 8-11



Figure 11: Showing axis position.

O

6. Create an Exit position and Select the same axis to configure the exit point, mplete

the build cut.

7. Set the following parameters in the sequence:

Table 4: Changed Parameters&

@

Manufacturing Parameter Value Section
TANGENT _LEAD_STEP 5 (0.20 in.) 5 NENTRY/EXIT
NORMAL_LEAD_STEP 0 (O ENTRYEXIT

8. Play the toolpath again using the Play Path >

g@ Play options.

(\\& Figure 12: Showing the resultant toolpath.

%ﬂ Path Review:
can control the approach and exit position on the profile. Notice the
NORMAL_LEAD_STEP is zero as this move is controlled by the position of the axis.

Step 7. Create an additional profiling pass to reduce the lateral depth of cut.

We can add an additional profiling pass for each slice of the profile; this reduces the lateral depth
of cut. We change the NUM_PROF_PASSES to 2 and the PROF_INCREMENT to 2.5.

Notice how the toolpath now makes two passes at each depth.

Page 8-12
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1. Set the following parameters in the sequence:

Table 5: Changed Parameters

Manufacturing Parameter Value Section
NUM_PROF_PASSES 2 CUT PARAM
PROF_INCREMENT 25(0.10in) | CUT PARAM

2. Play the toolpath again using the Play Path > Screen Play options.

Figure 13: Showm Itant toolpath.

&
Tool Path Review: Q
We can add an additional prcgilm asses for each slice of the profile; this reduces

the lateral depth of cut. We ch Q - : g€ NUM_PROF_PASSES to 2 and the
PROF_INCREMENT to 2. 1 5 ). Notice how the toolpath now makes two
passes at each depth.

3. Inthe Play Path menu\sel tNC Check to start Vericut.
4. Click on the PR @ICOH to view the machining simulation.

&

Figure 14: Showing the resultant toolpath in Vericut.
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Tip:

To slow down the simulation you can click on the Setup Motion icon, and in the
motion dialog box drag the animation speed slider to the left. When playing the
toolpath, notice there are no collisions or gouging and we have machined down to
the finish profile surface.

5. Close Vericut, complete the sequence, and return to the manufacture menu.

Step 8. Create a material removal feature to cut away the machined volume from the workpiece.\

N\
We can create a material removal feature to cut away the machined volume from the workpiegg,
t@éi%v

Using the Automatic option means the system automatically determines the materi. e

from the workpiece. You also have the option to create the cut manually.

We can select the AutoAdd option to pick the workpiece automatically. By default, the cut will
only be visible in the assembly, you will not see the cut if you open the wogkon its own.

1. Using the Menu Manager, select Machining > Matrl Remaoval
create a material removal feature for the profile milling seque

F_BOTTOM to

2. Accept the Automatic option, click the Auto Add b select the workpiece to
intersect, and complete the feature.

~ QO
Note: K
Notice the automatic cut created in the we.
3. Complete the NC sequence. @&9

4. Save the manufacturing mode

5. Close all windows an er@components from memory.

&
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Summary

After successfully completing this module, you should know how to:

Describe the profile milling process.

Describe the key profile milling manufacturing parameters.
Create profile milling sequences.

Create mill surfaces relevant to profile milling.

Create material removal features specific to profile milling.

>
Q
O
N
B
S

Creating Milling Sequences with Pro/ENGINEER Wildfire
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Module

Creating Volume Milling Sequences

\‘
Introduction @

The ability to remove large amounts of workpiece jal is an important
machining skill. Volume milling sequences are t Z@ed for this purpose.
Examples include machining mold cavities; %g pockets and slots, and
facing down a workpiece. The volume mi ss involves specifying the
volume of material to be removed; this is ed by creating either mill

windows or mill volumes. When a v e milling sequence is completed you can
update the in-process workpiece y. This is achieved by creating a

material removal feature the@ the machined volume from the workpiece.

Objectives
After completing % ule, you will be able to:

e Describe @ﬁme milling process.
+ De cr@ill windows and mill volumes.
-E @e the key volume milling manufacturing parameters.

peate volume milling sequences.

> Create mill windows.

* Create material removal features specific to volume milling.
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Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 9: Creating Volume Milling Sequences

& PTC@Q

Instructor Preparation %
Before teaching Creating Milling Sequences with Pro/ENGIN@Idﬁre, you must have read and

thoroughly understood the following materials: \

* General Information

» Review Pro/ENGINEER Wildfire primer sit@@mweb.ptc.comlprimer/

* Pro/E Wildfire Documentation o @
* Review Pro/ENGINEER Wildfire % tion in Windmill, located in

/GS Training Materials/Domain Knowl ate/ProENGINEER/Core Concepts

* Pro/E Wildfire Milling

* Review Pro/ENGI

/GS Ed Srvcs Operations/
/T979-330-Instructop Ki

@@;re Milling training materials in Windmill, located in

ation Library/Instructor Materials/Instructor Kits/EN

* Required Ski
» Comptetionof Pro/E Wildfire Foundation or equivalent Pro/E skills
* K0 n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E

+ Ability to install and configure Pro/E Wildfire
Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Three

Creating Creating Creating Creating Pro/FICIENCY
Volume Milling Local Milling [=%{  Surface Milling  [=#{ Trajectory Milling =  Daily
Sequences Sequences || Sequences ||  Sequences || |Assessments
T T T
| | |
& L &
------------ Creating Straight Cut |~
Creating Creating " Surtace Miling
Volume Milling Local and s 9 Creating
Sequences Volame Milling equences Trajectory Milling
Creating From Surface

Isolines Surface
Milling Sequences

Creating Cut Line
Surface Milling
Sequences
T

Creatin i Creating Straight Cut |1
Sequences Volume Milling Sequences Trljsm:tory Milling
Sequences equences
Creating From Surface

Isolines Surface
Milling Sequences

Creating Cut Line
Surface Milling
Sequences

Duration

Lecture: 20 mins
* Demos : 25 mins
Labs : 45 mins
Total: 1 hr 30mins
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Objectives

After completing this module, you should know how to:

® Describe the volume milling process.

® Describe mill windows and mill volumes.

® Describe the key volume milling manufacturing parameters.
® Create volume milling sequences.

® Create mill windows.

® Create material removal features specific to volume milling.

QO

Overview %

The ability to remove large amounts of workpiece material is an importarit machining skill. Volume
milling sequences are typically used for this purpose. Examples.inclyde machining mold cavities,
machining pockets and slots, and facing down a workpiece. Th me milling process involves
specifying the volume of material to be removed; this is a%d by creating either mill windows or mill
volumes. Once you have completed your NC sequenc n represent the as-machined state of
your workpiece by creating a material removal featyre t moves the machined volume from the
workpiece.

After completing this module, you will be aﬁ@

* Describe the volume milling process.

* Describe mill windows and mill vo%
Describe the key volume miIIir@ acturing parameters.
Create volume milling sequ

Create mill windows. @

Create material remo tures specific to volume milling.

&



A ©ric

Volume Milling Overview

Remove material within a volume
Slices parallel to the retract plane

Roughing and/or Profiling passes

Volume Configuration

Manufacturing Geometry
o Mill Window

i

« Mill Volumes & :
Options

Configure approach walls -

Configure top surfaces for mill volumes \

High speed machining techniques @
Modify default cut motions g)

o202

Volume Milling Process @
Volume milling sequences are typically used to remove large am workpiece material. Examples
include machining mold cavities, and machining pockets and siqts.

Volume milling sequences remove the material inside a cified-vOlume slice-by-slice. All slices are

Slide 4

parallel to the retract plane. Both roughing and profiling passes can be created within the sequence.

«

Volume Definition @
Manufacturing geometry is used to configure t I¥ne of material to machine, a Mill Window or Mill
Volume can be created to represent the VO?R aterial to be removed.

Options &

By default the tool will not machin t the specified volume.

» The tool can violate suﬁac@ﬂ lume if they are specifically selected as approach walls.

» Top surfaces are surfages ill volume that can also be penetrated by the tool when creating
the tool path. This gptj sto be used only if some of the top surfaces of the volume are not
parallel to the retrac " If Mill Window is used, this option is not available. The window start
plane will be us the top surface.

 Various machining pdrameters are available that enable the creation of tool paths based on high
speed machining principles.

ut-motions can be modified by using the build-cut or customize functionality. Options

omatic (default): use all the slices generated by the system.

» Up to Depth: use slices up to a certain depth only.

» From to depth: use slices in a certain range of depths.

» Slice-by-Slice: generate Automatic Cut motions by specifying depth of each slice.
» Approach and Exit motions can also be configured.
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Manufacturing Geometry - Mill Windows

Configured before or during NC sequence creation

® Machines visible geometry within a closed contour

Configure Mill Window

® Select a closed contour

® Sketch a closed contour

® Use reference model silhouette
Options

© Starting plane

® Depth

® Offset contour

® Tool Side

® Inside loops

Mill Windows

Mill Windows are manufacturing geometry features used in creati %ﬂe milling sequences. They
can be created before or during the creation of an NC seque

You create a Mill Window by:
» sketching or selecting a closed contour in an appro ane.

* projecting the silhouette of the reference part o mdow start plane.
All reference model geometry visible WIthIQ>th gow is machined.
Optional Elements
« Starting plane: defaults to retra
* Depth: defaults to reference elfgeometry.
+ Offset contour: enlarge.or: e contour by a constant distance.
* Tool Side: To/On/Pas window outline.
* Inside loops: if fi part used for creating the silhouette contains through cuts or holes, you

can specify if yo nito keep or remove these loops by using the Inside Loops.

&
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Manufacturing Geometry - Mill Volumes

Configured before or during NC sequence creation
® Provides additional control of material to machine
Configure a volume of material to remove
Options
© Sketch a volume

o Draw 2-D outline
o Extrude outline

© Reference model geometry

@we milling sequences. They

is can be done by:

Mill Volumes

Mill Volumes are manufacturing geometry features used in creati
can be created before or during the creation of an NC seque

They are created by configuring a volume of material to ove.
» Sketching and extruding a volume.
» Referencing model geometry, then extruding the res g outline.
o \(: :)
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Mill Volumes - Referencing Model Geometry

Gathering a Mill Volume
Selecting Surfaces

o Surf and Bound
Seed Surface
Boundary Surfaces
Boundary Loops

e Surfaces

«Features RETRACT_PLANE.
o Mill Surfaces ~
q

Excluding

o Exclude Outer Loops

Filling

e Fill Inner Loops
Closing
« Capping Plane

Slide 7

Mill Volumes - Referencing Model Geometry

The gathering technique allows you to create a mill volume t@w@ag model geometry including

surfaces and edges.
The gathering process involves several steps:

» Selecting surfaces to be machined; there are seve
selected surfaces are sewn together to form a sin
retract plane to form a volume alternatively the
if required.

» Surf and Bound: This involves sele of the surfaces for machining (the seed surface),

and then selecting bounding su FAe seed surface and all neighbouring surfaces up to
the boundary surfaces will be s her into a single quilt. Boundary loops enables adding
outer loops of edges to the bo

 Surfaces: Select continuo@ es to be machined.
» Features: Select features\t machined. All the surfaces of selected features will be included.
» Mill Surfaces: Selsg @fined Mill Surfaces.
* Exclude: The Exch -}Q}io is available only if you gather using an option other than Surf & Bnd
(for example, S S

'A\ allows you to:
» Surfaces—E

J some of the chosen surfaces by selecting each of them individually. This is
especial&;nve ient when gathering using Features or Mill Surf.

* Loo % lude outer loops. Use this option to delete unwanted portions of surfaces selected
ga ing.

* Fi en you fill an inner loop of edges on a surface selected for gathering it is equivalent to
"patching" the base quilt of the Mill Volume. The volume will be built as if there was a smooth
surface with no perforations. Options:

+ All—Fill all loops on a selected surface. Select a surface. All inner loops on this surface will be
filled, whether they belong to bounding surfaces or not.

» Loops—Select loops to be filled. For each loop to be filled, you have to select only one edge. If
you gather using Surf & Bnd, the edges must lie on the bounding surfaces. Select additional
bounding surfaces if necessary.

» Close: The system will close the volume automatically, by extruding the boundaries of the selected
surface quilt vertically up to the retract plane. If you want to specify a different way to close the
volume, select Close, and select an alternative capping plane.
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Mill Volumes - Options

Options
® Trim the volume automatically to the part

o Subtract reference model from volume

© Offsetting volumes
o Walls

o Surfaces \
-0 <

Mill Volumes - Options %
Options

+ Trim the volume automatically to the part, this involves subtracting the reference model material
from the mill volume. Usually applied to a sketched v&lume.

* It is possible to off-set selected surfaces or side wa (9!
O

O

volume by a distance.
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Key Parameters

Scanning Parameters

® ROUGH_OPTION

® Controls Roughing and/or Profiling passes
« ROUGH_ONLY
« ROUGH_&_PROFILE
« PROFILE_&_ ROUGH
« PROFILE_ONLY
« ROUGH_&_CLEAN_UP
« POCKETING
« FACES_ONLY

® CUT_ANGLE

Scanning Parameters
ROUGH_OPTION E
v

Controls if a profiling and/or roughing pass is created during illing

* ROUGH_ONLY—no profiling. @‘\

* ROUGH_& PROF—rough then profile. @

* PROF_& ROUGH—profile then rough.

* PROF_ONLY—only profiling. © @

* ROUGH_&_CLEAN_UP—cleans u %% Is of the volume without creating a profiling pass.

* POCKETING—profiles the walls o@o ume and finish mills all the planar surfaces inside the
volume that are parallel to the @ ane (island tops and bottom of the volume).

* FACES_ONLY—finish mills planar surfaces inside the volume that are parallel to the
retract plane (island t @gttom of the volume).

@
* CUT_ANGLE: thg'a tween the cut direction and the X-axis of the NC Sequence coordinate
system.

&
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Key Parameters

Scanning Parameters
SCAN_TYPE

Scanning method and avoiding islands
«TYPE_1
«TYPE_2
«TYPE_3
« TYPE_SPIRAL
« TYPE_ONE_DIR

High Speed Machining Options
« CONSTANT_LOAD
« SPIRAL_MAINTAIN_CUT_DIRECTION

« SPIRAL_MAINTAIN_CUT_TYPE @
« FOLLOW_HARDWALLS g)
©2002

Scanning Parameters %@
*+ SCAN_TYPE: For volume milling, refers to the way a milli@ s the horizontal cross-section

Slide 10

of a milling volume and avoids islands.

(for reference, describe as required) \

The options are:
* TYPE_1—continuously machines the volume, @s upon encountering islands.
* TYPE_2—continuously machines the v@un@h ut retract, moving around the islands.

» TYPE_3—the tool removes material fr uous zones defined by the island geometry,
machining them in turn and moving d.the islands.

* TYPE_SPIRAL—generates a spira path.
* TYPE_ONE_DIR—the tool cutg(n direction only.

« TYPE_1_CONNECT—the to in one direction only. If there is a wall at the start of the cutting
passes, the connection o llows the profile of the wall to avoid gouging.

High Speed Machini s (for reference only will be covered in a later module)
CONSTANT_LOA rf high speed roughing (with ROUGH_OPTION set to ROUGH_ONLY) or
profiling (with RO PTION set to PROF_ONLY).

+ SPIRAL_MAINTAIN_CUT_TYPE—generates a spiral cutter path with reverse arc connections
is is a high speed machining option, which minimizes retracts.

between
+ SPIRAL @ITAIN_CUT_DIRECTION—generates a spiral cutter path with S-shape connections
bet cuts. This is a high speed machining option, which minimizes retracts.

+ FOLLOW_HARDWALLS—the shape of each cut follows the shape of the walls of the volume,
maintaining fixed offset between the respective points of two successive cuts. If the cuts are closed,
there are S-shape connections between the cuts.
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Key Parameters

Lateral Control
STEP_OVER TOOL_OVERLAP
NUMBER_PASSES
TOOL_OVERLAP
BOTTOM_SCALLOP_HEIGHT
STEP_OVER_ADJUST

STEP _OVER

NUMBER_PASSES =3 g)@
Slide 11 ©2002

Lateral Control %
These four parameters control the step-over distance, the final toolpa ill use whichever parameter
produces the smallest calculated step-over.

» STEP_OVER default parameter for controlling the stép.over in a slice.
* Or NUMBER _PASSES can be used to explicitly se mber of passes to take in each slice.
Or TOOL_OVERLAP can be used as an alterr@ od to control the step-over based on the

tool overlap.
BOTTOM_SCALLOP_HEIGHT must be Ie@

calculate step-over. X

The STEP_OVER_ADJUST para Justs the passes in the slice to start and finish near the
edges of the volume you are . It only reduces the step over distance, and adds an extra

pass if needed. @

r equal to cutter radius, can also be used to

@
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Key Parameters

Depth Control
® STEP_DEPTH
® WALL_SCALLOP_HGT

® MIN_STEP_DEPTH WALL_SCALLOP_HGT L TooL

STEP_DEPTH

REFEREN @
MODE

Depth Control

The STEP_DEPTH parameter can be used to specify the depth b % each slice.
WALL_SCALLOP_HGT: controls the step depth for Volume milli
WALL_SCALLOP_HGT (wsh) must be less than or equaNe cutter radius.

The default is 0. @

* IfWALL_SCALLOP_HGT is zero (wsh = 0)|. llop height is calculated using STEP_DEPTH.

» If you specify wsh > 0, a step depth is -o using wsh. This calculated value is compared to
the STEP_DEPTH, and the smallest ed step-depth is used.

MIN_STEP_DEPTH: specifies the mini aIIowabIe distance between slices.

@@
&
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Key Parameters

Stock Allowance
® ROUGH_STOCK_ALLOW
® PROF_STOCK_ALLOW

© BOTTOM_STOCK_ALLOW
ROUGH_STOCK_ALLOW

PROF_STOCK_ALLOW el

VOLUME
OUTLINE

i

o

QO

Stock Allowance %
ROUGH_STOCK_ALLOW - controls stock on walls for roughing passes.
Nﬁ ;P)

PROF_STOCK_ALLOW - controls the stock on the walls for ile/passes. Is also used to calculate
remaining stock when creating material removal features%
O

BOTTOM_STOCK_ALLOW - controls the stock on bo h es for rough and profile passes.
Defaults to PROF_STOCK_ALLOW if set to *-'. 0‘
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating a Volume Milling Sequence

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Using Parameters and Setting up Site Files %
Scenario

» Throughout this course, the exercise scenarios are th%ne as the demo scenarios.
» This has been done to build consistency between Q@é nd lab exercises so as to enable “Tell

me—Show me—Let me do.” @
Method o
Use the script in the instructors guide, us&s rie models as in the exercises.

Exercise
Once the demo is complete t%e s should use the steps in the training guide to complete the

Q)
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Summary

After successfully completing this module, you should know how to:
® Describe the volume milling process.
® Describe mill windows and mill volumes.
© Describe the key volume milling manufacturing parameters.
® Create volume milling sequences.
® Create mill windows.

® Create material removal features specific to volume milling.

QO

Summary %

After successfully completing this module, you should know how to;
* Describe the volume milling process. \

Create volume milling sequences.
Create mill windows.

Create material removal features spe@@volume milling.

‘0
Q@

» Describe mill windows and mill volumes @
Describe the key volume milling manufacturing@ ers.
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Module 9 Lab Exercises
Exercise 1: Creating Volume Milling Sequences

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

» Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2003051 or later.

» Download and install the class fileswi | df i re_mi I | = .tar. gz as described in

the classroom setup notes.

Introduction @p\
In this demonstration, you create a volume wd{lling.sequence to rough out the material from inside

the model, you modify key parameters an efficient tool path. Volume sequences can be
used to rough out material as well 4 0 alls and face floors. Mill windows or mill volumes
can be used to specify the volurp erial to remove. You use a mill window to configure the
volume to remove. @

||Ieting this exercise, you will know how to:

Objectives

After successfull

e Creat milling sequences.

. C% milMwindows.
. @a material removal features specific to volume milling.

cenario

In this exercise, you continue manufacturing the aluminum cover by creating a volume milling
sequence to rough out the material from inside the model. You also create a new mill window
feature and reference it for the volume milling sequence.

Parameters

The following are key volume milling parameters.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 9-3
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Table 1: Parameter Descriptions

Parameter Description

ROUGH_OPTION Controls if a profiling and/or roughing pass is created.

SCAN_TYPE The method of scanning the machined area.

CUT_ANGLE The angle of cuts relative to NC sequence coordinate system.

STEP_OVER Distance between passes.

NUMBER _PASSES Number of passes per slice.

TOOL_OVERLAP Tool step over calculated by overlap distance.

BOTTOM_SCALLOP_HGT | Step over calculated by scallop height.

STEP_OVER_ADJUST Adjust STEP_OVER to provide complete coverage of @
machined area.

STEP_DEPTH The incremental depth of each cut. N

WALL_SCALLOP_HGT Controls the step depth for angled walls. ~ 7~>

MIN_STEP_DEPTH Specifies the minimum allowable distange:befvesn slices.

ROUGH_STOCK_ALLOW | Controls stock remaining on walls foXoughihlg passes.
PROF_STOCK_ALLOW Controls stock remaining on Wa%@r Bﬁfiling passes.
BOTTOM_STOCK_ALLOW | Controls stock remaining ottom fades for rough and profile

passes.
U
ALY

Step 1. Locate and open the cover manufacturiljg;nq\ode\l.

<&
Before creating the volume milling sequence@eg to locate the manufacturing model and
open it using the folder navigator. When ge\l%&

this as our working directory, and opin @v' anufacturing model of the cover.

located the folder for this exercise we can set

1. In the navigator, select th rowser tab, and browse to
c:\users\student\wils fg_330\module09, right-click, and select Make Working
Directory. @

2. Open COVER. . varn off any displayed datum features.

Step 2. Creatéié volume milling NC sequence.

Usingthe Manager, we can create a volume milling sequence. Notice how the site

par: r file sets all the required manufacturing parameters; this includes reading in the
speeds,Yeeds and depth-of-cut data for this tool. We can select the name and window options as
these are the only sequence references we need to change. We can enter a name for the
sequence to make it easy to identify. The FEM_25 0 tool is automatically selected because it

was used in the previous sequence.

We can create a mill window using the select option. Using the tangent option, we can select any
of the inner edges at the top of the pocket.
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Notice the other options in the Mill Window dialog box: Plane, Tool Side, Depth, Offset and Inside
Loops. The Plane option determines the height of the will window. The Mill Window is created

on the Retract Plane by default.

We play the toolpath using the default parameters from the site parameter file. Notice the retracts
in the middle of the slices when the toolpath hits a boundary. Notice also the warning messages
at the bottom of the graphics window; this is because the site parameter file is setting cutter

compensation to on, which is not required. We will correct this in the next step.

1. Using the Menu Manager, create a Volume milling sequence.

2. Inthe Seq Setup menu, select the Name, and Window check boxete the

selection of options.

3. Name the sequence [RGH_BOTTQOM. @f)

Note:

The only option highlighted in the SEQ SETUP mequ is %e. This is because all
of the other required options (Tool, Parameters, Coardinate System and Retract
Plane) are already configured. The FEM_25 ‘2ool was used in the previous NC
sequence, and will be used again by defau ite parameter file configures
values for all the required parameters. @?

A volume sequence can use either a @dow or a mill volume.

4. Select Create Wind to create%@ow, name it \WND_RGH BOT].
™R

Note: V\9
t

You can create mar@@ geometry such as mill windows before creating an NC

sequence or durigg ¢ ¢greation of an NC sequence.

5. Change the @Mnamed view OP010-TRI.
a

6. Usingdte nd Tangent Chain options, select one of the inner chain of edges at the
top of th et, as shown in the following figure. Complete the selection of edges.

&

Figure 1: Showing selected edge and highlighted tangent chain of edges.
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7. Preview the mill window, and complete the mill window configuration.

% PTC
Note:

Select preview and notice that the mill window is created on the retract plane. The
machining will begin at the top of workpiece. You can specify a different starting level
for the machining by changing the plane in the Mill Window dialog box. You can also
control the depth of machining and the offsets from the dialog box.

8. Play the tool path using the Screen Play option. Ensure the CL data is visible. ig

<
Figure 2: S%ﬁ@nted retract moves.

Tool Path Review: @9

Notice the unwanted retract moves;this is controlled by the SCAN_TYPE parameter.
To remove the retract m can set the parameter to TYPE_2 (to go around
islands) or TYPE _ toﬁv@ﬁye region by region). Notice also the warning
messages at the b e graphics window, this is because the site parameter
file is turninwfc pensation which is not required.

Step 3. Modify the Wﬁce parameters to control the scan type, roughing option, and cutter
competjsation.

We ¢ SCAN_TYPE, CUTCOM and ROUGH_OPTION parameters to see the effect
on Ipath.

We can modify the SCAN_TYPE to TYPE 2 to eliminate retract moves, and set the CUTCOM to
OFF to eliminate the warning messages. The TYPE 2 SCAN_TYPE will go around islands
instead of over them. We can modify the ROUGH_OPTION to ROUGH_& PROFILE. We can

see that the tool now roughs each slice and then profiles the wall before moving to the next slice.

This can be seen more easily using NC Check. We can switch the NCCHECK_TYPE
configuration option to NCCHECK. This will start the internal NCCHECK program instead of
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Vericut. Using NCCHECK is generally faster than Vericut, but has fewer checking capabilities.
Notice that the walls are now being machined. This is because the PROF_STOCK_ALLOW
parameter is set to zero in the site parameter file. Also notice that the bottom surfaces are being
machined. This is because the BOTTOM_STOCK_ALLOW parameter uses the
PROF_STOCK_ALLOW setting if it is not configured.

1. Set the following parameters in the sequence:

Table 2: Changed Parameters

Manufacturing Parameter Value Section /AN
SCAN_TYPE TYPE_2 CUT OPHIONN\
CUTCOM OFF MACHINE )
ROUGH_OPTION ROUGH_& PROFILE | CUT OP

2. Play the tool path using the Screen Play option. Ensure the C tais visible.

@ Figure 3: Showing resulting toolpath.

3. Using the To® own menu, click Options. In the Options dialog box, add the
configurgo %o NCCHECK_TYPE, in the Value drop-down list click NCCHECK. Apply
and Cles & ons.

te:
<} itching the NCCHECK_TYPE configuration option to NCCHECK starts the

ternal NCCHECK program instead of Vericut. Using NCCHECK is generally faster
an Vericut, but has fewer checking capabilities.

In the Play Path menu, select NC Check > Run to play the toolpath. Close the NC Check
menu when finished.
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Figure 4: Showing resulting toolpath in NCCHECK. @

Tool Path Review:
Setting the SCAN_TYPE to TYPE_2, makes the tool go around i ds tting the

ROUGH_OPTION to ROUGH_& PROFILE, means the tool

then profiles the walls before going to the next depth. Noti

bottom faces are now machined with zero stock remaining.

PROF_STOCK_ALLOW is set to zero and BOTTO JOC LLOW is setto ‘. In

this case BOTTOM_STOCK_ALLOW uses the PR% CK ALLOW value, which
@

is zero.
(
Step 4. Modify the sequence parameters to con@%tock allowance and change the scanning
method. &

We can set the SCAN_TYPE, to TYPE_S RWe can modify the PROF_STOCK_ALLOW,
ROUGH_STOCK_ALLOW and ROUG! ON parameters to see the effect on the toolpath.

We set the ROUGH_OPTION b, C@OUGH_ONLY. We modify the ROUGH_STOCK_ALLOW
to 0.5. This leaves 0.5 m he sidewalls. We can modify the PROF_STOCK_ALLOW
parameter to 0.5, whigh i§alspused by the BOTTOM_STOCK_ALLOW parameter and leaves

The PROF _ ST CK_AM OW parameter is also used in the calculation for the material removal

feature.
@e toolpath using NCCHECK and see that stock is now left on the walls and the
botto rfaces.

1. Set the following parameters in the sequence:

Table 3: Changed Parameters

Manufacturing Parameter Value Section
SCAN_TYPE TYPE_SPIRAL CUT OPTION
ROUGH_OPTION ROUGH_ONLY CUT OPTION
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Manufacturing Parameter Value Section

ROUGH_STOCK_ALLOW 0.5(0.02in.) CUT PARAM
PROF_STOCK_ALLOW 0.5(0.02in.) CUT PARAM
BOTTOM _STOCK_ALLOW - CUT PARAM

2. Play the tool path using the Screen Play option. Ensure the CL data is visible.

Figure 5: Showing
3. Play the toolpath using the NC Check optio@

& Figure 6: Showing resulting toolpath in NCCHECK.

C ool Path Review:
The ROUGH_STOCK_ALLOW parameter controls the amount of stock remaining on

the walls. The BOTTOM_STOCK_ALLOW is set to (-), so it automatically uses the
PROF_STOCK_ALLOW value of 0.5 (0.02 in.). This leaves stock remaining on all of
the bottom faces. When reviewing the toolpath using NC Check you can see the
effect of these changes. Notice also how the scan type is now spiral.

The PROF_STOCK_ALLOW parameter is used in the next step to calculate the
stock remaining after creating a material removal feature.

4. Complete the NC sequence.
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Step 5. Create a material removal feature.

We can create a material removal feature to cut away the machined volume from the workpiece.
We create a Material Removal feature using the Automatic option. We select the AutoAdd
option to pick the workpiece automatically. The material removal feature takes into account the
amount of stock we leave on the surfaces based on the PROF_STOCK_ALLOW parameter. It

does not currently take into account the size of the tool.

1. Create a material removal feature for the RGH_BOTTOM sequence using the Automx
option.

2. Use the AutoAdd option to select the workpiece to intersect. @@

3. To see the remaining stock, select the OP010-TOP view.

4. Click the No Hidden icon to set the display to no hidden line.

5. Click View > Display Settings > System Colors. Inthe S @rs dialog box, clear
round:

the Blended Background check box to turn off the blended b& k

& Figure 7: Showing stock remaining on vertical walls.

tice the automatic cut made in the workpiece. The PROF_STOCK_ALLOW
parameter was used to leave 0.5 mm (0.02 in.) of stock on the side and bottom
surfaces.

6. Change the view back to the named view OP010-TRI.

7. Select the Blended Background check box to toggle the display of the blended background,
then close the System Colors dialog box.

8. Click the Shading icon to set the display to shaded again.
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10. Using the Tools drop-down menu, click Options, set the configuration option
NCCHECK_TYPE back to Vericut, and Apply the options.

9. Select and hide the mill window in the model tree.

Option: Yalue:

| nccheck_type | |veri|:ut

Figure 8: Setting NCCHECK_TYPE to Vericut.
11. Save the manufacturing model. \
12. Close all windows and erase all components from memory. @@

%@

\
&
O

0
2
S

Q)
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Summary

After successfully completing this module, you should know how to:

Describe the volume milling process.
Describe mill windows and mill volumes.
Describe the key volume milling manufacturing parameters.

Create volume milling sequences.

Create mill windows. \
Create material removal features specific to volume milling. @@

>
Q
O
N
B
S
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Module

10

Creating Local Milling Sequences

\‘
Introduction @

Local milling sequences are typically used to remowv; terial still remaining from
a previous NC sequence. This is possible by usj @Iler tool, and calculating
the remaining material to be removed. The a% types of local milling
sequences, and since each type of sequence e used in different situations,
it is important to know when and how to u h type of sequence.

Objectives @j
After completing this modulg( youwill be able to:

e Describe the differ es of local milling sequences.

e Describe the logal milling manufacturing parameters.
» Createlo ing sequences.

. Creat@rial removal features specific to local milling.

®©

Page 10-1



Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 10: Creating Local Milling Sequences

& PTC@Q

Instructor Preparation %
Before teaching Creating Milling Sequences with Pro/ENGIN@Idﬁre, you must have read and

thoroughly understood the following materials: \

* General Information

» Review Pro/ENGINEER Wildfire primer sit@@mweb.ptc.comlprimer/

* Pro/E Wildfire Documentation o @
* Review Pro/ENGINEER Wildfire % tion in Windmill, located in

/GS Training Materials/Domain Knowl ate/ProENGINEER/Core Concepts

* Pro/E Wildfire Milling

* Review Pro/ENGI

/GS Ed Srvcs Operations/
/T979-330-Instructop Ki

@@;re Milling training materials in Windmill, located in

ation Library/Instructor Materials/Instructor Kits/EN

* Required Ski
» Comptetionof Pro/E Wildfire Foundation or equivalent Pro/E skills
* K0 n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E

+ Ability to install and configure Pro/E Wildfire
Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Three

Creating

[L——u; Volume Milling

Creating

Creating Creating Pro/FICIENCY
| Local Milling [

Surface Milling [ Trajectory Milling [+  Daily

i ‘ :
Creating Straight Cut Il
v Icreat'lzlﬂl Creating Surface Milling Creating
- Volume Milling |-.-.-. Local and Sequences |7
Sequences .

Volume Milling Trajectory Milling

Creating From Surface
Isolines Surface
Milling Sequences

Creating Cut Line
Surface Milling
Sequences

Creating
Labs Volume Milling

Sequences

Creating
Local and
Volume Milling

Creating Straight Cut n
| | surface milling Creating

Sequences Trajectory Milling | |
Sequences

Creating From Surface
Isolines Surface
Milling Sequences

Creating Cut Line
Surface Milling
Sequences
|
Creating Additional
From Surface Isolines
Surface Milling
Sequences

Duration %

Lecture: 15 mins
* Demos : 25 mins

Labs : 50 mins @\

Total: 1 hr 30 mins
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Objectives

After successfully completing this module, you should know how to:
© Describe the different types of local milling sequence.
® Describe the key local milling manufacturing parameters.
® Create local milling sequences.

® Create material removal features specific to local milling.

QO

Overview %

Local milling sequences are typically used to remove material stil ining from a previous NC
sequence. This is possible by using smaller tools, and calculating the remaining material to be
removed. There are four types of local milling sequencescand s each type of sequence can be
used in different situations, it is important to know when s::1%§ow to use each type of sequence.

After completing this module, you will be able to:
* Describe the different types of local milling usyce
* Describe the key local milling manufacﬂ@ameters.

 Create local milling sequences.
» Create material removal features icfo local milling.

©©
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Local Milling Overview

Remove material left by a previous NC Sequence
® Prev NC Seq
©® Corner Edges
® By Prev Tool

® Pencil Tracing

There are 4 types of Local mill sequences.

* Prev NC Seq: remove material left after a Volume, Profile,
usually with a smaller tool. It does not use the workpi
the stock to remove, instead it uses the previous se%?

Corner Edges: specify one or more corners to
By Prev Tool: calculates the remainder ma@ s

larger tool; then removes this material by t

L]
o
0]
>
Q.
—
=
O]
Q.
>

Q@
Q
(]
Y]
>
(2]
c

©
(]
Q

«Q
oD
(2]
o
=

corners.

S

angther Local milling NC sequence,

or material removal features to determine

parameters.

y selecting edges.

pecified surfaces after being machined by a
rent (smaller) tool.

surfaces by creating a single-pass tool path along the
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Previous NC Sequence

Features
© Reference a volume, profile, surface or another local mill sequence
©® Based on sequence parameters
« Not the workpiece or material removal features
® Region-by-region
o For volume and profile sequences
©® Remainder surface calculated for a surface sequence
« Set REMAINDER_SURFACE = YES

QO

Previous NC Sequence
The previous sequence option of local milling allows you to refererse material left by a previously
created volume, profile, surface or another local mill sequenc

The calculated material remaining from the previous seq%%‘?e istbased on the previous sequence

parameters and not the mill volume or material removal es.
If you are using a volume or profile milling sequence a rence, you can control the toolpath region
by region.

surface from the sequence. If you set the RE ER_SURFACE parameter to YES in the surface

If you are using a surface milling sequence as@ nce, the system will calculate the remainder
NC sequence, the remainder surface wiII ted as part of that sequence and it will save you

calculation time in the local milling seq
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Corner Edges

Features
© Specify corners to clean up by selecting edges

© Determine stock on corners
o« CORNER_OFFSET defines remaining material

QO

Corner Edges %/

The corner edges option of local milling allows you to clean up corier: specifying which corners to
machine. You specify the corners by selecting the vertical e of the corner. The amount of material
remaining from the previous tool is determined by the C% NOFFSET parameter.

‘0
O

0
2
S
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By Previous Tool

Features
® Specify either surface or mill window to machine
® Automatically calculates material left by larger tool

® Previous tool must be a ball end mill

Parameters
e Scan is always spiral

o Approach and Exit control
APPROACH_TYPE
EXIT_TYPE

o CUT_TYPE
UPCUT or CLIMB — one-direction milling
NONE - back and forth

z Yl

QO

By Previous Tool

The by previous tool option of the local mill sequence allows you
the material left by a previous tool. You can specify the surfa
of surfaces or by using a mill window. If you use a mill window,
window are selected.

The system automatically calculates the material left b evious tool. The previous tool must be a

ball end mill.
Parameters to control the behavior of the tooIp

* The toolpath will always be spiral.
* You can specify the approach and e

* The CUT_TYPE can be specmed T or CLIMB, in which case the machine will only
machine in one direction to m cut type.

* If you choose none for tEe TYPE, the system will scan back and forth to machine the

machining surfaces based on
to)nachine by either selecting a group
f the surfaces within the mill

surfaces without regar, utting type.

&
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Pencil Traces

Features
® Select surfaces or mill window to define surfaces to machine
® Single pass toolpath created along the corners

® Ball end mills only

Parameters

® SLOPE_ANGLE parameter used to determine vertical walls
o Default = 30

® MACHINING_ORDER
« CORNERS_FIRST
« SURFACES_FIRST
« CORNERS_ONLY
« SURFACES_ONLY

Pencil Traces %

The pencil traces option of the local mill sequence lets you createnasingle pass toolpath along the
corners of a model. You specify the surfaces to check for corners b)) either selecting the surfaces
explicitly or by using a mill window to select the surfaces Th il trace only works with ball end

mills.
There are two parameters to control the toolpath. @p
* The SLOPE_ANGLE parameter determlnest t which a wall is considered vertical.
* The MACHINING_ORDER parameter det which order to machine the corners and
surfaces.

« CORNERS_FIRST: vertical reglo@
+ SURFACES_FIRST: horizont
* CORNERS ONLY: vertlca

« SURFACES_ONLY: I'@ egions
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating Local and Volume Milling Sequences.

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Creating a Local and Volume Milling Sequences %
Scenario

» Throughout this course, the exercise scenarios are th%ne as the demo scenarios.
» This has been done to build consistency between Q@é nd lab exercises so as to enable “Tell

me—Show me—Let me do.” @
Method o
Use the script in the instructors guide, us&s rie models as in the exercises.

Exercise
Once the demo is complete t%e s should use the steps in the training guide to complete the

Q)
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Summary

After successfully completing this module, you should know how to:
© Describe the different types of local milling sequence.
© Describe the key local milling manufacturing parameters.
® Create local milling sequences.

© Create material removal features specific to local milling.

QO

Summary %

After successfully completing this module, you should know how to;
 Describe the different types of local milling sequencex

» Describe the key local milling manufacturing paran‘@

* Create local milling sequences.

» Create material removal features specific to lac ing.
o \
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Exercise 1: Creating Local and Volume Milling Sequences

Module 10 Lab Exercises

Demonstration Instructions

Preparation

Complete the following tasks before running this demo for customers:

e Practice running the demo so you can easily complete it. : @

* Check for and review the errata sheet for this course.

» Use Pro/ENGINEER Wildfire build code 2003051 or later. @
« Download and install the class fileswi | df i re_m | | i nr . gz as described in

the classroom setup notes.

Introduction
In this demonstration, you create a local milling s to remove the remaining material from
make the tool path efficient. Local milling

the inside of the cover. You then modify parapiete
sequences are useful because they can automyatically calculate the tool path required to remove

remaining material based on previols s ce information and model geometry.
You also create a second fixture-sg d operation to machine the opposite side of the cover.
You continue the exercise by c a volume milling sequence to remove most of the material

from the top of the cover. Yau §pmplete the exercise by creating a second volume milling

sequence to machinethe aining material from the vertical walls on the outside of the cover.

Objecti

After succes completing this exercise, you will know how to:

. eate local milling sequences.

. @ate material removal features specific to local milling.
Create volume milling sequences.

Scenario

You are now ready to continue machining the aluminum cover. You create a local milling
sequence to remove the remaining material from the inside of the cover. You also create a
second fixture setup and operation to machine the opposite side of the cover. You continue the
exercise by creating a volume milling sequence to remove most of the material from the top of the
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cover. You complete the exercise by creating a second volume milling sequence to machine the
remaining material from the vertical walls on the outside of the cover.

Step 1. Locate and open the cover manufacturing model.

Before creating the local milling sequence, we first need to locate the manufacturing model and
open it using the folder navigator. Once we have located the folder for this exercise, we can set

this as our working directory, and open the manufacturing model of the cover.

1. In the navigator, select the Folder Browser tab, and browse to

c:\users\student\wildfire_mfg_330\module10, right-click, and select Make V@

Directory.
2. Open COVER.MFG. Turn off any displayed datum features. @

Step 2. Create a local milling NC Sequence. (7 .

Using the Menu Manager, we can create a local milling sequence usi @evious NC
sequence option and reference the previous volume milling sequence. an select the name,
tool, and parameter options. We can enter a name for the s uenc ake it easy to identify,
and change the tool to a smaller diameter end mill. When the manufacturing parameters
we can start by using the previous volume milling pargmete h/ch need to be adjusted. So we
can then read in the tool cutting data parameters to the feed and speed, and depth-of-cut
parameter values. We can also modify the § PTH, STEP_OVER and the
PROF_STOCK ALLOW parameters and olpath Notice how the tool removes the
remaining material on the walls and all ‘@' ntal surfaces.

1. Using the Menu Manager, cie@ocal milling sequence using the Prev NC Seq option.

2. When prompted for a\tef milling sequence, select NC Sequence > RGH_BOTTOM
> CUT MTN #1,

3. Using the Men nager, select Seq Setup, then select the Name, Tool and
Parameteg:he oxes, complete the selection of options.

4. Name ence [FI N_BOTTOM.

5. @tool to the FEM_06_0 tool.

6. Forthe parameters, select the Use Prev option and use the RGH_BOTTOM parameters.
7. In the Mfg Params menu, select Set to modify the parameters.

8. In the Parameter Tree window, click Edit > Copy From Tool > All > Roughing to read
in the roughing cutting data for the current tool.
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Note:

Reading in the cutting data adjusts the CUT_FEED, STEP_DEPTH, STEP_OVER,
and SPINDLE_SPEED parameters, these adjustments are based on workpiece
material and tool parameters.

9. Modify the following parameters:

Table 1: Changed Parameters

Manufacturing Parameter Value Section
STEP_DEPTH 6 (0.24in.) CUT PARAM
STEP_OVER 3(0.12in) | cuT PARAM- S
PROF_STOCK_ALLOW 0 CUT PARAM )
10. Play the tool path using the Screen Play option. Ensure the CL data i le.

11. Using NC Check start Vericut, then click on the Play to End.i o¥iew the machining
simulation. %

ﬂ‘,: Showing the resulting toolpath in Vericut.

Tool Pat R@y
The toqgl r sthe remaining material on the walls and all the horizontal surfaces.

AN/
12. Close icytand complete the sequence.

Step ﬁ\&Create a material removal feature.

V‘:; create a material removal feature to cut away the machined volume from the workpiece.
e create a material removal feature using the Automatic option. We select the AutoAdd

iption to pick the workpiece automatically.

1. Create a Material Removal Feature for the FIN_BOTTOM sequence using the Automatic
option.

2. Use the AutoAdd option to select the workpiece to intersect.
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Note:
Notice the automatic cut made in the workpiece.

3. Save the manufacturing model.

Step 4. Create the second operation to machine the top of the cover.

We can create a second operation to machine the top of the cover. We create a new operation
named OP020. We can create the machine zero position, ensuring that we create the co-
ordinate system in the COVER.ASM assembly by selecting this assembly in the model tree.
Selecting three surfaces on the workpiece, we can position the co-ordinate system in th€ro
left-top corner of the workpiece. We can set the direction of the axes to match ou @ nts,
and rename the co-ordinate system to make it easier to identify. We can also createa ract
surface and position it relative to our machine zero position. When the oper@eﬁniﬁon is

complete we can rename the retract surface in the model tree to make @ 0 identify

At this point, we can again specify the workpiece material for th@n, in this case

aluminum.

We can open the Fixture Dialog box and name the fixtur Xp_OZO. We can now add a
component to the fixture setup; in this case we can s {l ISE.ASM from the list. To ensure
the vise assembly jaws are the correct distance , select the OP020_INST from the list of
instances. We can position the vise assembl) @vo mate constraints and an align constraint.
Once assembled, we can close the Fixturg% and Operation dialog boxes, and rename the

retract plane in the model tree.

and a front view.

We finish the operation setup byxcreating three named views, as we did for operation 010. We
can create a trimetric vie a@w

1. Turn off the dispfa m planes and datum axes. Turn the datum coordinate systems on
if they are not akéadydisplayed.

Note:

ur ) e display of the blended background in the graphics window to make
vigwingeof co-ordinate system axes easier.

2. Click View > Display Settings > System Colors, clear the Blended Background check
box, and click OK to complete the configuration.

3. Using the Menu Manager, open the Operation Setup dialog box, click the Create New
Operation icon and create a new operation named [OP020].

4. Switch the view to the default view and zoom into the model.
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5. Create a machine zero co-ordinate system positioned at the front-top-left corner of the
workpiece. In the Operation Setup dialog box, click the Machine Zero icon, then select
Create in the MACH CSYS menu, when prompted to pick a model to create the coordinate
system in, select the COVER.ASM assembly in the model tree.

6. To refresh the screen click View > Repaint.

Note:

To select multiple surfaces you must press and hold the CTRL key when selecting
surfaces. To select hidden surfaces you must move the cursor over the hid
surface and right-click to highlight the hidden surface. N

7. Select surfaces to configure the co-ordinate system origin. Press and e '%_, and select
the front and top surfaces on the workpiece as shown in the following\figure

X
&
Figur@ g selected front and top surfaces.

8. To select the hidden left s ove the cursor over the model as shown in the following
figure, then press CT'@ ~click, when the hidden left surface highlights select it.

@}@
&
©&

Note:

The co-ordinate system origin will move to the front-top-left corner of the workpiece
when all three surfaces have been selected correctly..

Figure 3: Showing selected left surface and cursor position.
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9. Inthe Coordinate System dialog box, select the Orientation tab. Use the drop-down axis
options and the Flip button to modify the orientation of the axes as shown in the following
figure.

QO

10. In the Coordinate System dialog box, select the Properties tab, and ren@?/e co-ordinate
system to [mach_csys_0p020]. Close the Coordinate System di% hen finished.

Figure 4: Showing re-oriented X, Y and Z axes.

AN

xamed co-ordinate system

11. In the Operation Setup dialog , chigk/the Retract Surface icon, select the Along Z Axis
z distance. Close the Retract Selection dialog box.

option and type [40] (1.57 i
12. Turn on the blended b d. Click View > Display Settings > System Colors,

select the Blendeg B nd check box, and click OK to complete the configuration.

Figure 5: S

13. Select alumin inthe Stock Material drop-down list.
14. Turn off th%play of datum planes, datum axes and datum co-ordinate systems.

15. k ture Setup icon to open the Fixture Set Up dialog box, type [0p_020] in the
e Setup Name box.

16. Click the Add Component icon to add a component to the fixture setup, select VISE.ASM
from the list of models, then select the op020_inst from the list of instances.

Tip:

The assembly process is easier if you do not display the vise assembly in the main
graphics window when specifying assembly constraints; instead show the vise
assembly in a separate window.
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17. In the Component Placement dialog box, click the Show Component in a Separate Window
icon, then remove the vise assembly from displaying in the graphics window by de-selecting
the Show Component in Assembly window icon. Ensure both the manufacturing model and
the vise assembly are clearly visible.

18. Assemble the vise assembly, as shown in the following figure. In the Component Placement
dialog box, change the first constraint type from Automatic to Mate, then select the right
surface on the workpiece and the small vertical surface on the clamp pad part.

19. Change the second constraint type from Automatic to Mate, then select the hi om
surface on the workpiece and the small horizontal surface on the clamp pad part:

20. Change the third constraint type from Automatic to Align, then select surface on the
workpiece and the vertical front surface on the clamp pad part.

Tip:
You can use the spin, zoom, and pan commands on the vj Qﬂ ybly in the sub-

window to make selection of surfaces easier.

Figur 1g the two mate and one align constraints; selected pairs of surfaces are highlighted.

21. ree constraints have been created click the Preview option in the Component

ent dialog box to check the vise has been positioned correctly. Complete the
O ponent placement when satisfied.

2. Close the Fixture Setup dialog box.
23. Close the Operation dialog box.
24. Rename the retract surface from ADTM1 to [r et r act _op020] in the model tree.

25. Click View > Orientation > Reorient, and create a series of named views OP020-TRI,
OP020-TOP, and OP020-FRONT as you did for operation 010.
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Figure 7: Showing named views.

Step 5. Create a mill window as a reference for the volume milling sequence. <((\

We need to create a mill window to specify the volume we want to machine; durin>
configuration we select a number of optional elements to provide us with addition ol over
the machined volume.

We create a mill window and name it. Using the select and surf ch j we select the top of
the workpiece. In the dialog box, we change the Tool Side optio Past, and change the Depth
option and select the bottom surface of the pocket. We canalso ch the Offset option to 20.
These changes provide more space for the tool to machii ‘aﬂ: d the outer edges of the
workpiece. @

1. Using the Menu Manager, select Mfg Setu Geometry > Mill Window > Create

Wind, and name the mill window [V\ND<> .

2. When prompted to select a refererm inate system select the MACH_CSYS_OP020
([

co-ordinate system from the m ¢

3. When prompted to select t plane, select the RETRACT_OP020 datum plane from
the model tree.

4. Change the viewto { ed view OP020-TRI.

5. Using the Selec Surf Chain options select the top surface of the workpiece, as shown

in the folla@ figure. Use the Select All option, and complete the selection.

O

_h

Figure 8: Showing selected top surface of the workpiece.
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6. Click the Tool Side element in the dialog box, and using Define change the tool side to
Past.

7. Click the Depth element in the dialog box, and using Define select the bottom surface of the
pocket (not the bottom of the groove) as shown in the following figure.

Figure 9: Depth surface for the
8. Preview the mill window, and complete the mill wi

r@ ration.
9. Select the mill window in the model tree, right- k and’setect Hide from the drop-down list.

Note:
Setting the offset to 20.0 (0.79 in.) m@ Il window larger, and together with
)

setting the tool side to past provid ace for the tool to machine around the
outer edges of the workp|ece<>

Step 6. Create a mill volume a/&a‘ﬁ\q\lteﬁ%atwe reference for the volume milling sequence.

¢
We can create a mill volu@ Iternative reference to specify the volume we want to

machine; during the jon we select a number of optional elements to provide us with

additional contro e achmed volume.
We create e and name it. Using extrude, solid, and one-side options, we select the
top of the e as the sketching plane; in sketcher we can select the edges of the workpiece

to co ure thé volume boundary. When the sketch is complete we can specify the depth of the
v@ ing the up to surface option and select the surface at the bottom of the pocket.
i

ill volume has been extruded down to the bottom of the pocket in the reference model, to
eate the required volume we need to subtract the reference model geometry from the mill
volume. We select the trim option and subtract the reference model geometry from the mill

volume.

The side walls of the volume need to be off-set to provide enough room for the tool to machine
around the sides of the reference model. We can select the four sidewalls and offset them by 20.
These changes provide more space for the tool to machine around the outer edges of the

workpiece.
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We have now created a mill window and a mill volume which we can use as alternative

references when volume milling the top of the workpiece.

1. Inthe Mfg Geometry menu select Mill Volume > Create, and name it [VOL_RGH _TOP].
2. Select Sketch, and accept the Extrude and Solid, and One Side options.

3. When prompted select the top surface of the workpiece as the sketching plane, and accept
the arrow pointing down into the workpiece as the direction for creating the feature, see the

figure below. \

@the workpiece.

ct the front surface of the workpiece as
following figure.

Figure 10: Showing selected to

4. When prompted to select a sketching r%fer
the bottom sketch view reference, as sh

: Figure 11: Showing selected front surface of the workpiece.

5. Close the references dialog box and accept that not enough references have been specified.
6. Change the view to the named view OP020-TRI.

7. Click the Create an Entity from an Edge icon and using the Loop option, select the top
surface of the workpiece model as shown in the following figure.
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Figure 12: Showing selected loop surface. @@
8. Complete the sketch.

9. Use the Up to Surface depth option, and select the bottom s@of the pocket (not the
bottom of the groove) as shown in the following figure. %

e 13: Depth surface for the Mill Volume.

10. Complete the&)@}y clicking OK in the Protrusion dialog box.

Not @

Thexnijrvolgme has been extruded down to the bottom of the pocket in the
refere odel, to create the required volume we need to subtract the reference
%del geometry from the mill volume.

ubtract the reference model geometry from the mill volume, select Trim in the Create Vol
menu.

12. When prompted to select a part for trimming, move the cursor over the reference model,
right-click until the reference model highlights, then select it as the trimming part, as shown in
the following figure.
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Note:
The side walls of the volume need to be off-set to provide enough o@the tool
to machine around the sides of the reference model. @»

[l

13. Select Offset in the Create Vol menu, then select the Surfa Horizontal options.

14. When prompted select the four vertical sidewalls of t e shown in the following figure,

and enter an offset distance of [20].
AQ

& Figure 15: Showing selected four vertical sidewalls.

15. L6 @e volume and return to the Manufacture menu.
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Note:

We have now created a mill window and a mill volum € can use as
alternative references when volume milling the to@f\the orkpiece.

Step 7. Create a volume milling sequence to mac/hin\\eQQe top of the cover.

We can create a volume milling sequence for, t the cover using a mill window. Using the
menu manager, we can create a volume mi@uence We can select the Name, and
Approach Walls options. We can enter for the sequence to make it easy to identify, and
change the tool to the 25 mm dia@% d mill. When setting the manufacturing parameters we
can start by using the previou ‘milling parameters from operation 010, but these

parameters need to be adjiste

We edit the para et@ set TRIM_TO_WORKPIECE to YES and STEP_DEPTH to 5. This
soRab

provides us with le step depth and ensures the tool does not machine outside the

workpiece ynile ified.
We ce@;le e VOL_RGH_TOP mill volume to specify the volume to be machined.

W
4 to plunge outside of the approach walls and approach safely through the side.

w select the left and right edges of the mill window as Approach Walls. This enables

e play the toolpath to review the result.

As an alternative we can use the mill window to configure the volume of material to be machined,
and review the results. We can select the mill window as an alternative reference, we need to use
new approach walls by selecting the left and right edges of the mill window.

1. Using the Menu Manager, create a Volume milling sequence.

2. Select the Name, and Appr Walls check boxes, and complete the selection of options.
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Note:

Notice when creating volume milling sequences, volume is selected by default.

3. Name the sequence [RGH_TOP].
4. Change the tool to the FEM_25_0 tool.
5. For the parameters, select the Use Prev option and use the RGH_BOTTOM parameters.

6. Modify the following parameters:

Table 2: Changed Parameters @\
Manufacturing Parameter Value Section ( N\

STEP_DEPTH 5 (0.20 in.) CUT PARAM
TRIM_TO_WORKPIECE YES CUT OPTIONS>

\%
7. Select Select Vol, in the Search Tool dialog box select the volum WOL_RGH_TOP,
and click OK, to complete the selection.

8. When prompted to define approach and exit walls belonging t / RGH_TOP, select the
left and right sides of the mill volume, as shown in the f%g figure.

& Figure 17: Mill Volume Approach Walls
@\

Ti MTechniques:

en you specify approach walls with a mill volume, you select the surfaces to
approach through. The toolpath will attempt to plunge outside of the material and
enter through the approach walls.

9. Play the tool path using the Screen Play option. Ensure the CL data is visible.
10. In the Play Path menu, select NC Check to start Vericut.

11. Click on the Play to End icon to view the machining simulation.
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13.

14.

15.

1

7.

<
Figure 18: Showing resulting tool t@ .
NES
Tool Path Review:

The tool creates a roughing toolpath, leaving mm (0.02 in.) of stock on the
vertical and flat surfaces. By using the appr lIs, the tool plunges outside of
the tool material. O

N

Close Vericut. /‘\
(N
N\

Note: 3;%
As an alternative we ca ‘ S ill window to configure the volume of material to

be machined, and re/xig ésults.

Select the mill volu \n\t%z model tree, right-click and select Hide from the drop-down list.

Select the, mj ow in the model tree, right-click and select Unhide from the drop-down
list.

Using th nu Manager, select Seq Setup, and select the Window, and Appr Walls
cﬁ%boxes.

the Select Wind option, then in the Search Tool dialog box click the Find Now button,
and select the window named VOL_RGH_TOP, and click OK.

Accept the removal of the original approach walls, and then configure new approach walls by
selecting the left and right edges of the mill window, as shown in the following figure.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 10-17



Figure 19: Mill Window Approach Walls

&

18. Play the tool path using the Screen Play option. Ensure the CL data is@e.

19. In the Play Path menu, select NC Check to start Vericut. %

20. Click on the Play to End icon to view the machining simulati

Rigurgv20: Showing resulting toolpath in Vericut

21. Close Vericut @@ sequence, and return to the manufacture menu.

Step 8. Create ama removal feature.

We creat

optit pick the workpiece automatically.

We can cre aterial removal feature to cut away the machined volume from the workpiece.
terial removal feature using the Automatic option. We select the AutoAdd

1. Create a material removal feature for the sequence using the Automatic option.
2. Use the AutoAdd option to select the workpiece to intersect.

3. Save the manufacturing model.
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Step 9. Create a volume milling sequence to machine the remaining material on the vertical walls
on the top of the cover.

We can now create a volume milling sequence to machine the remaining material on the vertical
walls of the top of the cover. Using the menu manager, we can create a volume milling sequence.
We can select the Name, Parameters, and Window options. We can enter a name for the
sequence to make it easy to identify. The parameters have been read from the site parameter file,
we can adjust the parameters to machine only the vertical walls with zero stock allowance and
provide a lead-in and lead-out motion. We can set the ROUGH_OPTION to PROF: he
ROUGH_STOCK_ALLOW to 0. We can also set the TANGENT _LEAD_STEP a &
NORMAL_LEAD_STEP to 10, and the OVERTRAVEL DISTANCE to 5. \@@nce the

same mill window from the previous sequence.

We can review the toolpath and see that during the lead-in and lea@oves the cutter

compensation is applied. Also the over travel distance on each % ves any witness lines

from the machined surfaces.

1. Using the Menu Manager, create a Volume midling se ce.

2. Selectthe Name, Parameters, and Wind boxes.

3. Name the sequence [PROF_TOP). @

4. Modify the following parameters:

/@e 3: Changed Parameters

Manufacturing quﬁ%gbef Value Section
ROUGH_OPTIAN 1) PROF_ONLY | CUT OPTION
ROUGH_STOSK ALLOW 0 CUT PARAM
TANGENT, DEAD_STEP 10(0.39in) | ENTRY/EXIT
NORMALEAD_STEP 10(0.39in) | ENTRY/EXIT
"QUERTRAVEL DISTANCE 5(0.20in) | ENTRY/EXIT

5. Usig the\S/eIect Wind option, click the Find Now button in the Search Tool dialog box and
@z WND_RGH_TOP from the list of mill windows.

. ange the view to the named view OP020-TRI.

Play the tool path using the Screen Play option. Ensure the CL data is visible.
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Figure 21: Showing the resulting toolpath.

>

Y%
Tool Path Review: \J
Notice during the lead-in and lead-out moves the cutter comp ons applied.
The over travel distance on each pass removes any witn lines Yrom the machined
surfaces.

8. Inthe Play Path menu, select NC Check to start Ve

9. Click on the Play to End icon to view the machirﬂ@gulation.

10. Close Vericut and complete the sequence. @

11. Select and Hide the WND_RGH_TQO ndow in the model tree.
12. Save the manufacturing model %

13. Close all windows and er@ ponents from memory.

O

&
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Summary

After successfully completing this module, you should know how to:

» Describe the different types of local milling sequences.
» Describe the key local milling manufacturing parameters.
e Create local milling sequences.

* Create material removal features specific to local milling.

>
Q
O
N
we
S

Creating Milling Sequences with Pro/ENGINEER Wildfire
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Module

11

Creating Surface Milling Sequences

\‘
Introduction @

Surface milling sequences enable you to mill conto@nd horizontal surfaces.

This is useful for finish machining contoured su omponents, or mold
cavities. When creating surface milling seq ~Ynill surfaces can be used as
alternate references when model surfacss ar propriate, for example when
the model being machined is made up of surfaces, or if you need to extend
the toolpath beyond the model. Therexare four types of surface milling sequence,
providing you with a flexible appr tdosurface machining. It is an important

skill to understand the differ: S een each type of surface milling

sequence, and when to use@ype of sequence. Once you have completed

your NC sequencebyoe esent the as-machined state of your workpiece
t Chus’z

by creating a ma rié& | feature that removes the machined volume from
the workpiece. &

Objecti@
tercompleting this module, you will be able to:

scribe the different types of surface milling sequence.
. escribe the key surface milling manufacturing parameters.
» Describe methods for creating approach and exit moves.
@ » Create and refine surface milling sequences.
*  Create mill surfaces relevant to surface milling.

» Create material removal features specific to surface milling.
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Creating Milling Sequences with Pro/ENGINEER
Wildfire

Module 11: Creating Surface Milling Sequences

& PTC@Q
@

Instructor Preparation

Before teaching Creating Milling Sequences with Pro/ENGI@Idﬁre, you must have read and
thoroughly understood the following materials:

* General Information
* Review Pro/ENGINEER Wildfire primer site at @?Meb.ptc.com/primer/

* Pro/E Wildfire Documentation o
« Review Pro/ENGINEER Wildfire do

/GS Training Materials/Domain Knowled .’S

‘0°

- Pro/E Wildfire Milling @
* Review Pro/ENGINEm e Milling training materials in Windmill, located in
/GS Ed Srvcs Operations/ ation Library/Instructor Materials/Instructor Kits/EN
/T979-330-Instructor Kit-

tion in Windmill, located in
te/ProENGINEER/Core Concepts

* Required SKi

» Completiohof Pro/E Wildfire Foundation or equivalent Pro/E skills

. OB (@m n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E
Hjty to install and configure Pro/E Wildfire

* Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Three

Duration

Lecture: 20 mins

Demos (3) : 25 mins

Labs (3 +1 challenge) : 45 mins
Total: 1 hr 30mins

Isolines Surface
Milling Sequences

Creating Cut Line
Surface Milling
Sequences

Creating A al
From
Si
nce:

Creating Creating Creating Creating
Tocta Volume Milling [===%{ Local Milling | Surface Milling Trajectory Milling [
reS | Seqeunces Seqeunces Seqeunces Seqeunces
] ] ]
L L !
Creating Creating
Volume Milling  f-..... Local and Creating
Seqeunces Volume Milling Trajectory Milling
Seqeunces Seqeunces
e
Isolines Surface
Milling Sequences
Creating Cut Line
Surface Milling
Sequences
creating [ Croating Creating Straight Cut |
Labs Volume Milling e Surface Milling Creating | |
Segeunces Volume Milling Sequences Trajectory Milling
Seqeunces Seqeunces
Creating From Surface

ProfFICIENCY
Evaluator
Daily
Assessments
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Objectives

After completing this module, you should know how to:
Describe the different types of surface milling sequences.
Describe the key surface milling manufacturing parameters.
Describe methods for creating approach and exit moves.
Create and refine surface milling sequences.

Create mill surfaces relevant to surface milling.

Create material removal features specific to surface milling.

AN
o)

Overview @

Surface milling sequences enable you to mill contoured and hori rfaces. This is useful for finish
machining contoured surfaces of components, or mold cavitigs, When<reating surface milling
sequences, mill surfaces can be used as alternate references odel surfaces are inappropriate,
for example when the model being machined is made up @fmany surfaces, or if you need to extend the
toolpath beyond the model. There are four types of su iling sequence, providing you with a
flexible approach to surface machining. It is an importa to understand the differences between
each type of surface milling sequence, and when ch type of sequence. Once you have
completed your NC sequence, you can represent the.ascmachined state of your workpiece by creating
a material removal feature that removes thg m ed volume from the workpiece.

After completing this module, you will b @:
illing sequences.

« Describe the different types of su
Describe the key surface milli@nufacturing parameters.
Describe methods for greatingtapproach and exit moves.

 Create and refine surf g sequences.
e Create mill surf nt to surface milling.
» Create material re | features specific to surface milling.

Q)
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Surface Milling Overview

Milling of Contoured or Slanted Surfaces

® Surfaces must allow continuous tool path

Four Cut Types:
® Straight Cut
® From Surface Isolines
® Cut Line
® Projected Cuts
Options
® Cut type can be changed

©® Geometry Selection
o Reference model

o Manufacturing Geometry
Mill Surfaces/Mill Windows

continuous tool path. There are several methods of configuri otion and generating the tool

Surface Milling Process
Surface Milling is used to mill horizontal or contoured surfaces. %ted surfaces must allow for a
the m
path:

+ Straight Cut: mill the selected surfaces by a series @Xht cuts.
i

* From Surface Isoline: mill the selected suﬁace@

 Cut Line: mill the selected surfaces by defi
cuts. When the system generates the tﬁx

ng the surface u-v lines.

shape of the first, last, and some intermediate
it gradually changes the shape of the cuts
according to surface topology.

* Projected Cuts: mill the selected s by projecting their contours on the retract plane, creating
a "flat" tool path in this plane ( g appropriate scan type), and then projecting this tool path
back on the original surface(s).
Options
* The cut type can be ¢ d during the configuration of the sequence.
» Selecting geom

* You can selec rence model surfaces for machining

* Or crea anufacturing geometry

V\@ ces can be used.
. rfaces within a mill window will be selected.



e . VrTC

Surface Milling Overview

Manufacturing Geometry

® Alternative machining reference

Configured before or during NC sequence creation
® Mill Surfaces
o Copy
o Extrude
oFlat
® Surface Modifications
o Extend
o Trim

o Merge

® Mill Windows

Surface Milling Process
» Manufacturing geometry, can be used as an alternative machizing reference.

* Manufacturing geometry can be configured before or duri

QO

the dreation of NC sequences.

+ Mill surfaces can be created, the most common o&ns Surface milling are:

» Copy: copy selected reference model surfa
Extrude: sketch a 2-D outline and extrude-th I

Flat: sketch a flat 2-D outline to form the hotidaries of a surface.
It is also possible to extend, trim, a ge surfaces together.

0
©©

ne to create a surface

Mill windows can also be UIS case all surfaces within a mill window will be selected.
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Cut Type - Straight Cut

Straight Cut
® Mill the selected surfaces by a series of straight cuts

® Machine direction
o Controlled by CUT_ANGLE parameter

© Straddles open edges

® Avoid inner walls

® Patch slots

Straight Cut
* Machine direction controlled by cut angle. %

» Completely machine the selected surface(s). If a surface is unded by walls on the outside, the
tool will "straddle", that is, overrun the surface boundary by a half diameter.

* Any inner protrusions, as well as the outer walls ex up from the surface, will be avoided
automatically. The stock allowance, if any, will@ he side walls as well.
e

* If a surface is selected from model, any sl
the tool path will be generated as if the‘?&

N
@@@

s on the surface will be "patched": by default
t there.



Straight Cut - Key Parameters

SCAN_TYPE
o TYPE_1
o TYPE_3
CUT_ANGLE
LACE_OPTION
e Connection moves TOOL_OVERLAP
SCALLOP_HGT TooL 44
STEP_OVER \ i

BB

MACHINED
SURFACE

TOOL_OVERLAP
SCALLOP_HGT

"W

@

PROF_STOCK_ALLOW

PROF_STOCK_ALLOW

Slide 7 o

Straight Cut Parameters
SCAN_TYPE: Refers to the way a milling tool scans the surface @mds islands.
For straight cut surface milling the options are:

* TYPE_1—continuously machines the surface, retrac countering islands.

* TYPE_3—the tool removes material from continuo {-" Q deflned by the island geometry,
machining them in turn and moving around the islar @'

* CUT_ANGLE — the angle between the cuand the X-axis of the NC Sequence coordinate

system
* LACE_OPTION — if set causes the tg%}(sut back and forth, and specifies the shape of
connection between the endpoint boring cuts. There are various connection types.
* LINE_CONNECT

- CURVE_CONNECT §2

* ARC_CONNECT
. LOOP_CONN c@
Lateral control is th 4

« STEP_OVER de arameter for controlling the step over within a pass.

* Or TOOL_O@?LAP can be used as an alternative method to control the step-over based on the
tool ove

i
* Or @_HEIGHT must be less than or equal to cutter radius, can also be used to calculate
st er.

Whichewer parameter produces the smallest step over is used.

* PROF_STOCK_ALLOW - controls the stock remaining on machined surfaces. Is also used to
calculate remaining stock when creating material removal features. For surface milling this can be

negative, allowing marching into the reference model, this can be useful when machining
electrodes.
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Cut Type - From Surface Isolines

From Surface Isolines

® Mill the selected surfaces by following the surface u-v lines (contour
lines)

® Machine direction
« Controlled by natural U-V contour
® Straddles open edges

® Avoid inner walls

® No patching of slots

QO

From Surface Isolines
* Machine direction controlled natural U-V contours of machine %es.

» Completely machine the selected surface(s). If a surface is unded by walls on the outside, the
tool will "straddle", that is, overrun the surface bound by a half diameter.

* Any inner protrusions, as well as the outer walls ex up from the surface, will be avoided
automatically. The stock allowance, if any, will@ he side walls as well.

* Internal holes and slots will not be "patched?~For3-Axis milling, the tool will move over internal
slots or holes at a constant Z level, plufigi ‘\) etracting at the lower edge as necessary. For 4-
and 5-Axis milling, the tool will retrac %‘1

e.

er edges. If you don’t want this to happen, use a mill
surface, or select a surface from a E:



From Surface Isolines - Key Parameters

SCAN_TYPE
«TYPE_1
«TYPE_2
«TYPE_3
« TYPE_ONE_DIR

J . TOOL_OVERLAP
STEP_OVER ( X? )
:

TOOL_OVERLAP

SCALLOP_HGT s |
NUMBER_PASSES j \

o

S @
PROF_STOCK_ALLOW =
_ | STEP_OVER
NUMBER_PASSES =§>
Slide 9 ©2002
From Surface Isolines Parameters @
SCAN_TYPE: Refers to the way a milling tool scans the surface ids islands.

For from surface isolines surface milling the options are:

* TYPE_1—continuously machines the surface, retractS\upon encountering islands.
* TYPE_2—continuously machines the surface witho@? ct, moving around the islands

* TYPE_3—the tool removes material from continuqu nes defined by the island geometry,
machining them in turn and moving around the@gs.
* TYPE_ONE_DIR—the tool cuts in oneodir@ ly.

Lateral control is through: @

« STEP_OVER default parameter fc@ﬁ'olling the step over within a pass.

* Or TOOL_OVERLAP can be uged@san alternative method to control the step-over based on the
tool overlap.

* Or SCALLOP_HEIGH@@ less than or equal to cutter radius, can also be used to calculate

step-over.

* Or NUMBER_P. N be used to explicitly set the number of passes to take in each slice.
Whichever parame duces the smallest step over is used.

v ALLOW — controls the stock remaining on machined surfaces. Is also used to
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Cut Type — Cut Line

Cut Line
® Mill the selected surfaces by specifying

o First cut line

o Last cut line
. Intermediate cut lines optional

© Cut Lines determine the first and last pass

o Gradually change shape of cuts
. Based on surface outline

® Open or closed cut lines

Cut Line
» Mill the selected surfaces by defining the shape of the first, la @ome intermediate cut lines.

* When the system generates the tool path, it gradually chan e shape of the cuts according to
surface outline and geometry.
» Both open and closed cut lines are possible. @

@g@@
é@;@@@



Cut Line - Key Parameters

SCAN_TYPE

« TYPE_1

«TYPE_3

« TYPE_SPIRAL

« TYPE_ONE_DIR

« TYPE_HELICAL
NUMBER_CUTS
OFFSET_INCREMENT

LACE_OPTION

SCALLOP_HGT

\

TOoOL
‘/

STEP_OVER
TOOL_OVERLAP
SCALLOP_HGT

PROF_STOCK_ALLOW

PROF_STOCK_ALLOW

g

Slide 11

Cut Line Parameters

SCAN_TYPE: Refers to the way a milling tool scans the surface

For cut LINE surface milling the options are:

TYPE_3—the tool
machining them in

* TYPE_1—continuously machines the surface, retrac@\\gg.s:

countering isl

removes material from continuo {* Q
turn and moving around the islar @'

TYPE_SPIRAL—generates a spiral cutter pat
TYPE_ONE_DIR—the tool cuts in one&ir@<
* TYPE_HELICAL — the tool moves a

* You can create multiple passes at di

ly.

OFFSET_INCREMENT

* LACE_OPTION — if set caus

connection between the e @ f neighboring cuts.

Lateral control is thr
« STEP_OVERd

+ Or TOOL_OVER
tool overlap

ste
Whi

eter for controlling the step over within a pass.

ids islands.

ands.

defined by the island geometry,

. Valid for Closed Cut Line machining only
-heights, using NUMBER_CUTS and

| to cut back and forth, and specifies the shape of

an be used as an alternative method to control the step-over based on the

r parameter produces the smallest step over is used.

* Or SCA@ EIGHT must be less than or equal to cutter radius, can also be used to calculate

* PROF_STOCK_ALLOW - controls the stock remaining on machined surfaces. Is also used to
calculate remaining stock when creating material removal features. For surface milling this can be
negative, allowing machining into the reference model, this can be useful when machining

electrodes.
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Cut Type - Projected Cut

Projected Cut

© Mill the selected surfaces by
¢ Projecting contours onto retract plane
« Create flat toolpath
« Projecting toolpath back onto original surfaces

® Provides more control over surface scanning

QO

Projected Cut

» Mill the selected surfaces by projecting their contours onto th plane, creating a "flat" tool
path in this plane (using the appropriate scan type), and tRen prgjecting this tool path back on the
original surface(s). This method is available for 3 Axis surfa lling only.

» Use projected cuts surface milling when you need @ntrol over the way you scan the surfaces

Y

(for example, if you need to generate a spiral tool
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Projected Cut - Key Parameters

® SCAN_TYPE
« TYPE_1/2/3
« TYPE_SPIRAL
«TYPE_ONE_DIR

® CUT_ANGLE

® STEP_OVER 7Y m

® TOOL_OVERLAP
® NUMBER_PASSES

© PROF_STOCK_ALLOW :; @

Projected Cut Parameters
SCAN_TYPE: Refers to the way a milling tool scans the surface @mds islands.
For straight cut surface milling the options are:
* TYPE_1—continuously machines the surface, retractS\upon encountering islands.
* TYPE_2—continuously machines the surface with gﬁl%ct, moving around the islands
* TYPE_3—the tool removes material from conti O%&s defined by the island geometry,
machlnlng them in turn and moving around the@g
* TYPE_SPIRAL—generates a spiral cutter@

* TYPE_ONE_DIR—the tool cuts in one

* CUT_ANGLE—the angle between x ;
system.

Lateral control is through: @

* STEP_OVER default %a for controlling the step over within a slice.

only.
rection and the X-axis of the NC Sequence coordinate

* Or TOOL_OVERLAP used as an alternative method to control the step-over based on the
tool overlap.

* Or NUMBER_PA can be used to explicitly set the number of passes to take in each slice.
Whichever pa@eter produces the smallest step over is used.

K_ALLOW - controls the stock remaining on machined surfaces. Is also used to

e remaining stock when creating material removal features. For surface milling this can be
, allowing marching into the reference model, this can be useful when machining
electrodes.
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Approach and Exit Moves

Modify default cut motions

Entry/Exit Moves
® Entry type

o First cut/ each cut
® Exit type
e Each cut/ last cut

® Custom Strategies

Alternative Methods
® Build cut

® Customize cut motion

Approach and Exit Moves

There are many times when additional approach and exit movesz ired to improve a tool path.

When creating NC sequences default cut motions are created\based) on selected geometry and

manufacturing parameters. These default cut motions can.be ed if required.

» The Approach/Exit option in the Sequence Setup m%?owdes access to the Entry/Exit dialog box

» The Entry/Exit Move dialog box enables m@ of the default cut motion and contains two

group boxes.

* You can select standard strategies@@and exit.

* You can specify different entry s for the first cut and the intermediate cuts, as well as
different exit strategies for the | iate cuts and the last cut.

» Custom Strategies—Lets @ ine custom strategies for entry and exit.

Alternative methods f n@wg the default cut motion are:

* Build cut in the e Setup menu

» Customize iRthe NC sequence menu

Both opfj nIe you to modify the existing cut motions and specify approach and exit moves.
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Demonstrations

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating Straight Cut Surface Milling Sequences
® Creating From Surface Isolines Surface Milling Sequences

® Creating Cut Line Surface Milling Sequences

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercises.

Demonstration: Using Parameters and Setting up Site Files %

Scenario
» Throughout this course, the exercise scenarios are t@e the demo scenarios.
SAQ

» This has been done to build consistency between de nd lab exercises so as to enable “Tell
me—Show me—Let me do.”

Method o @@
Use the script in the instructors guide, us&% models as in the exercises.

Exercise @

Once the demo is complete the st@s Should use the steps in the training guide to complete the

exercises. @

Q)
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Summary

After successfully completing this module, you should know how to:
© Describe the different types of surface milling sequences.
® Describe the key surface milling manufacturing parameters.
© Describe methods for creating approach and exit moves.
® Create and refine surface milling sequences.
® Create mill surfaces relevant to surface milling.

® Create material removal features specific to surface milling.

QO

Summary @;

After successfully completing this module, you should know haw to:
 Describe the different types of surface milling sequen%§

Describe the key surface milling manufacturing par@?
Describe methods for creating approach and exi .

Create and refine surface milling sequence

Create mill surfaces relevant to surfac€mi

Create material removal features spe% surface milling.

©©
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Exercise 1: Creating Straight Cut Surface Milling Sequences

Module 11 Lab Exercises

Demonstration Instructions

Preparation

Complete the following tasks before running this demo for customers:

e Practice running the demo so you can easily complete it. : @

* Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2003051 or later.

« Download and install the class fileswi | df i re_m | | i n%&a I. 9z as described in

the classroom setup notes.

Introduction

In this demonstration, you create a mill surface ance for the surface milling sequences.
You then create a semi-finish sequence on p e model by creating a straight cut surface
milling sequence using 25-millimeter bal @efore completing this sequence, you change

the model reference to the mill surf g the tool to overlap the edges of the top surface.
Mill surfaces are useful as they ¢ ed as alternate references when model surfaces are

inappropriate. You also use a g9Ji el tool to enhance the display when reviewing tool paths.

Objectives E@

After successfull ng this exercise, you will know how to:

» Creategupface~milling sequences using the straight cut option.

. Cﬁm rfaces.
S

ou continue manufacturing the aluminum cover by creating a number of surface milling
equences. This enables you to machine all the contoured surfaces on the top of the cover. You
use different surface milling techniques based on the surface finish required on the product.

In this exercise, you create a mill surface as a reference for the surface milling sequences. You
then create a semi-finish sequence on the top of the model by creating a straight cut surface
milling sequence using a 25-millimeter ball end mill. You use a solid model tool to enhance the
display during tool path review.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 11-3
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Parameters

The following are key surface milling parameters.

Table 1: Parameter Descriptions

Parameter Description

SCAN_TYPE The method of scanning the machined area.

CUT_ANGLE The angle of cuts relative to NC sequence coordinate system.

LACE_OPTION Causes the tool to cut back and forth, and specifies the shape «
of connection between the endpoints of neighboring cuts.

STEP_OVER Distance between passes. Q((\

TOOL_OVERLAP Tool step over calculated by overlap distance. //‘\\

SCALLOP_HGT Step over calculated by scallop height. U

NUMBER _PASSES Number of passes per slice. (From surface igofines and
projected cut sequences only) )

STEP_OVER_ADJUST Adjust STEP_OVER to provide co |@erage of
machined area. r&

PROF_STOCK_ALLOW Controls stock remaining on mat}m\\ed//éurfaces.

NUMBER_CUTS For cut line machining ca Ny multiple cuts and different
z-depths. ﬁ/\\ﬁ

OFFSET_INCREMENT For cut line machirﬂ@@éﬁepth for multiple cuts.

Q)

Step 1. Locate and open the cover manuﬁag&iq\g\médel.

Before creating the volume milling seq@v% need to locate the manufacturing model and
open it using the folder navigator. @ have located the folder for this exercise we can set

this as our working directory, a he manufacturing model of the cover.

1. In the navigator, sel Folder Browser tab, and browse to
c:\users\stugdgn re_mfg_330\module11, right-click, and select Make Working
Directory.

2. Open CO@%MFG. Turn off any displayed datum features.

N\
Step//f C\xéa\t/é)a mill surface feature.

As an\diternative to machining the reference model surfaces, we can create a mill surface to
extend the machined surfaces beyond the outer edge of the model.

Mill surfaces are useful because they can be used as alternative references when model

references are not appropriate.

We need to copy the surface from the top of the reference model and extend the outer edges.

Page 11-4 Creating Surface Milling Sequences
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To do this, we create a mill surface using the Copy option. We select the top of the reference
model, this surface is hidden under the workpiece surface so should be selected carefully. When
we have copied the surface we can extend the outer edges by 2.5 mm, again ensure we pick the

correct edge to extend.

1. Using the Menu Manager, select Mfg Setup > Mfg Geometry > Mill Surface > Create
to create a mill surface, name it [f i ni sh_sur f ace].

2. Change the view to the named view OP020-TRI. %
3. Select Add > Copy > Done, and select the hidden surface on the top cove x
reference model. Complete the selection and close the Surface Copy %Is\% X.

Tip: U

Ensure you pick the hidden surface of the reference model, n surface from the
workpiece. Use right-click to highlight the hidden surface.

Figure@gted hidden reference model surface
X

4. In the Surf Define menu s@ tend to extend the outer edges of the surface. Use the
Same Surf > Single(Ds ist On Srf options.

5. Usingthe Ta é@zin option, select one of the outer edges of the surface; again ensure
g

you pick the e, not the workpiece edge. Complete the selection and select the
same € 0 measure the extension distance. Type [2. 5] (0.10 in) as the extend
distan

&

Figure 2: Tangent chain of edges and selected edge.

6. Complete the extension process, and return to the Manufacture menu.
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Figure 3: Showing extended surface.

Note:

Notice there are two new surface features in the model tree; %entmg the
original copied surface, and a second representing the ex@&i

Step 3. Create a semi-finish surface milling NC sequence l}s}m\g the stra|ght cut option.

Using the Menu Manager, we can create a surface milling @ ience. We can select the name,

tool and parameter options as these are the additiong( ssquénce references we need to specify.

We can enter a name for the sequence to rigke@r@

model tool to enhance the display when r

stock material for the tool and read in eed and depth-of-cut data for this tool. Notice

how the site parameter file sets all manufacturmg parameters. We can modify the

PROF_STOCK_ALLOW to leav r@a

finishing tool path. We ca ‘ e SCALLOP_HGT to control the step over between passes.
&

identify. We can retrieve the solid

tool path, and we can also specify the

| on the machined surface, as this is only a semi-

We can select the milks e just created as the surface to be machined, ensuring that the

upward facing sid& Of the surface is machined. We can now specify the cut type, and accept the

straight cut optign.

We play th {%th, and notice how the tool machines past the edges of the model surfaces to

between passes, this is controlled by the LACE_OPTION parameter, and the cut direction is

parallel to the x-axis of the sequence co-ordinate system, controlled by CUT_ANGLE parameter.

1. Using the Menu Manager, create a Surface Mill milling sequence.

2. Selectthe Name, Tool, and Parameters check boxes.
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Note:

Notice Surfaces and Define Cut are already selected, you are only selecting
additional options that you need to change.

3. Name the sequence [FI N_TOP_1].

4. |Inthe Tool Setup Dialog box, select File, and Open Tool Library, use the By Copy
option and retrieve the BEM_25 0_SOLID, solid model tool. Set the tool number and tool
offset number to [19].

5. Selectthe Feeds-Speeds tab, and click Read DB button to read in the cutf ng a
roughing application and aluminum stock material.
6. Apply the changes and Move the tool to the existing pocket, finally ::!e tool for the
sequence.
>

\Y%
Note: @
The solid model tool can be seen when playing the to%

N

7. Modify the following parameters:

Table 2: Ch ameters
Manufacturing Parameter Value Section
PROF_STOCK_ALLOW F8.4519.006 in) CUT PARAM
SCALLOP_HGT N \\Qj/( 0.004 in) CUT PARAM

A

Note: g 1@
Notice how the sﬁ%g eter file sets all the default values.
\\\))v

8. Select Mill @ e > Done > Select Srf, and use the FINISH_SURFACE from the list
of surface
9. Selgct O , to use the upward facing side of the surface. Use the Select All option to

ensyre the entire surface is used for machining, and complete the surface selection.

1 e Cut Definition dialog box, accept the Straight Cut option, and close the dialog box.

1. Play the tool path using the Screen Play option. Ensure the CL data is visible.
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Figure 4: Showing the resulting toolpath.

Toolpath Review:

([
N
Notice how the tool machines past the edges of the model su esy/@/\the edge of
the larger mill surface. The tool also machines over the opexing in the top surface,
this can be changed using the SCAN_TYPE paramexgc: 50 the tool
b

performs a lacing move between passes, this is contro y the LACE_OPTION
parameter, and the cut direction is parallel to the x e sequence co-ordinate
system, which is controlled by CUT_ANGLE

J Y CUT_ANGLE poaq

Step 4. Modify the sequence parameters to co (oK 8can type, the lacing move, and cutting
angle. ©

We can modify the SCAN_TYPE to TYP, §:§@>iminate machining over the opening in the top
surface. We can modify the LACE 0 ARC_CONNECT to connect each pass with a
smooth motion. We can also set;t CUT _ANGLE to 90 degrees.

i t

1. Set the following par he sequence:

Table 3: Changed Parameters

Manufgcturing Parameter Value Section

SCANNTYPE TYPE_3 CUT OPTION

LECEYOPTION ARC_CONNECT CUT OPTION
UTANGLE 90 CUT PARAM

2. Playnthe tool path using the Screen Play option. Ensure the CL data is visible.
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In the Play Path menu, select NC Check to start Vericut.

Figure 5: Showing the resulting toolpath. @@

4. Click on the Play to End icon to view the machining simulation. @

Tool Path Re 'e@
Modifying the @PTYPE to TYPE_3, eliminates machining over the opening in

the top su ifying the LACE_OPTION to ARC_CONNECT connects each

pass with th motion. Modifying the CUT_ANGLE to 90 degrees changes the
dire¢tioof cutting motions.

5. Close Vericut and complete the NC sequence

6.e the manufacturing model.

Creating Milling Sequences with Pro/ENGINEER Wildfire
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Exercise 2: Creating From Surface Isolines Surface Milling
Sequences

Introduction
In this demonstration, you add a finishing sequence to the top surface by creating a from isolines

surface milling sequence. You also add a tangent approach and exit move to the tool path.

Objectives

After successfully completing this exercise, you will know how to:

» Create surface milling sequences using the from surface isolines option. @

e Customize tool path approach and exit motions.

Scenario

You add a finishing sequence to the top surface by creating a fréfn.isolihes surface milling
sequence. You also add a tangent approach and exit move&the t ath.

Step 1. Create a finish surface milling NC sequence usi m surface isolines option.

Using the Menu Manager we can create a surface n@ uence. We can select the name and
parameters options, as these are the add/t/onal re

enter a name for the sequence to make it tify. There is no need to specify the tool as
we are using the solid model tool from t %s sequence. For the parameters we can start
by using the previous sequence par; %’As this is a finishing pass, we can modify the
PROF _STOCK_ALLOW to leav; @aterial on the machined surface. We can also set the

SCALLOP_HGT to provide a step over between passes. We can select the same mill

ferences we need to specify. We can

surface to be machined, ing that the upward facing side of the surface is machined. We can

now specify the ¢ and’select the from surface isolines option, the cut direction can be

changed if required, e can leave it unchanged.

We play thetaolRath, and notice how the cut direction follows the contour of the surface instead
of a trire //ut. Notice also how the tool makes a normal approach move when starting to
mac the inside edge of the machined surface on the first pass, and the tool also makes a
normal exit move on the last pass in that section of the tool path. This can be adjusted by

specifying tangent approach and exit moves.

1. Using the Menu Manager, create a Surface Mill milling sequence.

Note:

Notice Surfaces and Define Cut are already selected, you are only selecting
additional options that you need to change.
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Select the Name and Parameters check boxes.

Name the sequence [FI N_TOP_2].

For parameters select the Use Prev option, and use the FIN_TOP_1 parameters
Modify the following parameters:

Table 4: Changed Parameters

A
Manufacturing Parameter Value Section
PROF_STOCK_ALLOW 0.0 CUT PARAM b
SCALLOP_HGT 0.025 (0.001 in) CUT PARAM Q{(\
Select Mill Surface > Done > Select Srf, and use the FINISH_S \gfrom the list
of surfaces.

Select Okay to use the upward facing side of the surface. Use @Iect All option to
ensure the entire surface is used for machining, and compl% rface selection.

In the Cut Definition dialog box select the From Surface
machining scan. Close the dialog box when fini&ed.

hes option, and Preview the

Note:
You can change the direction of cuttirﬁ?@toggle icon in the dialog box.

Play the tool path using the Scr&er@%tion. Ensure the CL data is visible.

Figure 7: Showing the resulting toolpath.

Tool Path Review:

Notice how the cut direction follows the contour of the surface (u-v vectors) instead
of a true linear cut. Notice also how the tool makes a normal approach move when
starting to machine the inside edge of the machined surface on the first pass, and
the tool also makes a normal exit move on the last pass in that section of the tool
path. This can be adjusted by specifying tangent approach and exit moves.
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Step 2. Create tangent approach and exit moves to remove witness lines from the curved
surfaces on the inside edges of the machined surface.

Create tangent approach and exit moves to remove witness lines from the curved surfaces on the
inside edges of the machined surface. We can modify the APPROACH_DISTANCE and
EXIT_DISTANCE parameters to 10, and using the Approach/Exit option we can specify a
LINE_TANGENT move for the first and last cut.

away from the curved surfaces on the inside edge of the machined surface.

We can play the toolpath and notice the additional tangent moves when approaching and mov%

1. Modify the following parameters:

Table 5: Changed Parameters

A

Manufacturing Parameter Value Section ()
APPROACH_DISTANCE 10 (0.40 in) ENTRY/EXE
EXIT_DISTANCE 10 (0.40 in) ENTRYEXT

2. Select Seq Setup >Approach/Exit > Done. In the Entry/EXit{ Mgye dialog box, specify a
LINE_TANGENT move for the first and last cut, then e the dialog box.

3. Play the tool path using the Screen Play option. En

@CL data is visible.

T

i Q Bhowing additional tangent approach and exit moves.

Notice t

SInERy

Tool P%!hhgﬁ/m/w:

additional tangent moves when approaching and moving away from the
ces on the inside edge of the machined surface.

4, %plete the sequence and return to the Manufacture menu.

5. Save the manufacturing model.

Page 11-12
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Exercise 3: Creating Cut Line Surface Milling Sequences

Introduction
In this demonstration, you add another finishing sequence to the top surface by creating a cut line
surface milling sequence. This surface milling sequence provides a better surface finish than the

previous finishing sequence, so you delete the second surface milling sequence you created.

Objectives

After successfully completing this exercise, you will know how to: Q\

» Create surface milling sequences using the cut line option.

Scenario @
You add another finishing sequence to the top surface by cr; at%g ine surface milling
sequence. This surface milling sequence provides a better suxfac; ish than the previous

finishing sequence, so you delete the second surface mi seguence you created.

Step 1. Create a finish surface milling NC sequenpe\\kmg the cut line option.

Using the Menu Manager, we can create a susac @ ing sequence. We can select the name
and parameters options, as these are the additional sequence references we need to specify. We
can enter a name for the sequenced¢o vA easy to identify. There is no need to specify the tool
as we are using the solid model to fri e previous sequence. For the parameters we can
start by using the previous seq/€ rameters. As this is a finishing pass, we can modify the
PROF_STOCK_ALLOW tgiteavezéro material on the machined surface. We can also set the
SCALLOP_HGT to pro @aﬂer step over between passes. We can select the same mill
Surface to be machi @urmg that the upward facing side of the surface is machined. We can
now specify e , and select the from surface isolines option, the cut direction can be

changed ii ire¢f, but we can leave it unchanged.

We pla%e toolpath, and notice how the cut direction follows the contour of the surface instead
oz@ ear cut. Notice also how the tool makes a normal approach move when starting to
e the inside edge of the machined surface on the first pass, and the tool also makes a
ormal exit move on the last pass in that section of the tool path. This can be adjusted by
specifying tangent approach and exit moves.
1. Using the Menu Manager, create a Surface Mill milling sequence.
2. Selectthe Name and Parameters check boxes.

3. Name the sequence [FI N_TOP_3].

4. For parameters, select the Use Prev option, and use the FIN_TOP_2 parameters.
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5. Select Mill Surface > Done > Select Srf, and use the FINISH_SURFACE from the list
of surfaces.

6. Select Okay to use the upward facing side of the surface. Use the Select All option to
ensure the entire surface is used for machining, and complete the surface selection.

7. In the Cut Definition dialog box, select the Cut Line option, and for the cut line style select
the Closed Loops option.

8. Click the Add a Cut Line icon to add a start cut line, select Accept > Done to use the outer
boundary chain of edges shown in the following figure.

N

Figure 9: Outer cﬁstart point highlighted.
10. Close the Add/Redefine Cut Line d@g\%@&
d

11. Click the Add a Cut Line icon end cut line, select Next > Accept > Done to use
hown in the following figure.

the inner boundary chain%
12. Using the Select St option, select a start point approximately half way along the
i e as shown. Use the Enter option and type in [0. 5], to position
e edge.

13.

Figure 10: Inner cut line and start point highlighted.
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14. Preview the machining scan, and close the Cut Definition dialog box.

Figure 11: Previewed machining scan.

@\%

15. Play the tool path using the Screen Play option. Ensure the CL data le.

Tool Path Review:

Notice how the tool ually changes shape between the start and end cut
lines. It is also passi modify the starting points of the cut lines as you did in this
exercise. x

16. Compl th@ence.

17. Inthe m ee, select FINISH_SURFACE, right-click and Hide the mill surface.

Stgp\i%r\)elete the second surface milling sequence.

ide that this tool path provides a better surface finish than the previous tool path, so we
can delete the from surface isolines sequence. We can select the sequence in the model tree and
delete it. An alternative to deleting the sequence is to suppress the sequence; this enables us to

resume the sequence later if required.

1. In the model tree, select the FIN_TOP_2 sequence and delete it.

2. Save the manufacturing model.
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Exercise 4: Creating Additional From Surface Isolines
Surface Milling Sequences (Challenge)

Objectives

After successfully completing this exercise, you will know how to:

« Create surface milling sequences using the from surface isolines option.

Scenario \

You create two more finish surface milling sequences to machine the left and righ
to machine the rounds on the top of the cover, you use the from surface isolines q

Step 1. Create a surface milling sequence using the from surface isolines optiQr to machine the
left and right cut outs on the top of the model. 7

Using the Menu Manager, create a surface milling sequence. %

-—

2. Selectthe Name, Tool and Parameters check boxe
3. Name the sequence [FI N_CUT_QUTS]. @x

4. Change the tool to the BEM_12_0 tool. @
5. Modify the SCALLOP_HGT parameter £9 0. .001 in).
6.

For the surfaces to be machined, sele@o cut out surfaces on the reference model, as

shown in the following figure. @

Figure 13: Showing left and right cut outs selected.

7. For the cut definition, select the From_Surface_lsolines option.

8. Modify the cut direction for both surfaces to be parallel to the y-axis of the machine co-
ordinate system.
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Figure 14: Showing cut direction. //N@

Note: \\\\//

The direction of cut and the order of machining can be modifi@he Cut Definition

dialog box.
: PN @\

ﬁ@ CL data is visible.

9. Play the tool path using the Screen Play option. E

10. Compl%th%ﬁ.

Step 2. C a gurface milling sequence using the from surface isolines option to machine the
roun the top of the model.

1.®he Menu Manager, create a surface milling sequence.

. lect the Name, and Parameters check boxes.
Name the sequence [FI N_ROUNDS].
4. For parameters select the Use Prev option, and use the FIN_CUT_OUTS parameters.
5. Modify the SCALLOP_HGT parameter to [0.002] (0.00017 in).

6. For the surfaces to be machined, select the two rounded surfaces on the reference model, as
shown in the following figure.

7. For the cut definition select the From_Surface_lsolines option.
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8. Modify the cut direction for both surfaces to be parallel to the x-axis of the machine co-
ordinate system.

Figure 15: Showing selected surfaces and cut ir@

9. Play the tool path using the Screen Play option. Ensure thexGL data is visible.

e

@ Figure 16: Showing the resulting toolpath.

10. Sawg,the manufacturing model.

11. Close all windows and erase all components from memory.
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Summary

After successfully completing this module, you should know how to:

Describe the different types of surface milling sequence.
Describe the key surface milling manufacturing parameters.
Describe methods for creating approach and exit moves.
Create and refine surface milling sequences.

Create mill surfaces relevant to surface milling.

Create material removal features specific to surface milling.

>
Q
O
N
B
S
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Module

Creating

Introduction @

Trajectory milling allows you to sweep a tool along @er-defined trajectory.

During the trajectory milling process, you must he trajectory for the tool

to follow. Trajectory milling sequences can r milling slots where the
shape of the tool corresponds to that of¢he sl hey can also be used to
chamfer edges. You can either use an e ol, or you can sketch your own

tool for the sequence; this enables to specify the tool control point anywhere
on the tool. @
Objectives @
After completing thfg you will be able to:
» Describe ('— §<%g%ry milling process.
« Descrj t methods of creating a trajectory.
@w to create a sketched tool.

« De
-@ e the features of multi-step and multi-pass trajectory milling.

eate trajectory milling sequences by defining cut motions.

Page 1241



Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 12: Creating Trajectory Milling Sequences

!
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The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Objectives

After completing this module, you should know how to:
Describe the trajectory milling process.
Describe different methods of creating a trajectory.
Describe how to create a sketched tool.
Describe the features of multi-step and multi-pass trajectory milling.

Create trajectory milling sequences by defining cut motions.

S

o)
@,

Overview @52
Trajectory milling allows you to sweep a tool along any uyser- d trajectory. During the
trajectory milling process you must configure the trajecto for/the tool to follow. Trajectory

milling sequences can be used for milling slots wh he shape of the tool corresponds to that
of the slot, they can also be used to chamfer edge can either use an edited tool, or you
can sketch your own tool for the sequence; this e you to specify the tool control point

anywhere on the tool. @

After completing this module, you will
» Describe the trajectory milling pro

 Describe different methods of ¢ a trajectory.
» Describe how to create a skigtc tool.
» Describe the features [-step and multi-pass trajectory milling.

 Create trajectory iguences by defining cut motions.
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Trajectory Milling Overview

Tool swept along user-defined trajectory

® Trajectory created by cut motions

z )

® Sketched or Edited Tools

o User defined tool control point for sketched tools

Trajectory Milling Process

Trajectory milling allows you to sweep a tool along any yser- %d trajectory. It can be used
for milling horizontal slots. To configure the tool path, yoomusY specify the trajectory of the
control point of the tool by creating cut motions usingthe customize functionality.

For 3-Axis Trajectory milling, you can either use e ols, or sketch your own tool for the
NC sequence. If you sketch a tool, you can cr@ er defined control point for the tool.

o \©

©©
&@6
Q®
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Creating a Trajectory

Configured using cut motions
® Trajectory Options

o Sketch
«Edge

o Curve

e Surface

® Customize Option
o Low-Level Control
o Add/Remove Cut Motions |
o Modify Feed Rates
o ApproachlExit Motions @

Creating a Trajectory

To configure the tool path, you must specify the trajectory o %ntrol point of the tool by
creating cut motions using the customize functionality.

Trajectory Options \
» Sketch: sketch a trajectory @
* Edge: use model edges @
* Curve: use datum curves

» Surface: use surfaces (at a sp%i%@ght)

the tool path. For example:
* You can add or remove ions.

» Modify feed rates.
* Add user defin ¢ch and exit motions.

&

Within the customize dialog box ti@ many options to provide more low-level control over



Sketched Tools

Sketch Half Cross-Section
Sketcher Co-ordinate System

o Tool Control Point

, i .
Tool Offset %

o LeftIRight/None

LEFT i RIGHT
o Cutter Compensation (CUTCOM) -—
Tool Center (default) !
Tool Edge MODEL 4
| OFFSET = RIGHT
TooL CUTCOM = ON
CUTTER_DIAM /
SELECTED 2
EDGE
© 2002

Slide 6

Sketched Tools

For sketched tools 5
* The tool is sketched as a revolved protrusion.

» The sketch represents half of the tool cross-secii

* The whole sketch must lie on one side of the axi ymmetry.

» The axis of symmetry must be vertical, witk'th etch lying on the right.

« The section must be closed. o Q

* You can specify a control point othe s tip by adding a sketcher coordinate system to

the tool sketch. For edited tools, sketched tools with no control point specified, the

tip of the tool will be used. (@
@ﬂ is offset from the trajectory:

hg cut motion creation.
none.
* The offﬁs CUTTER_DIAM/2.

* You also change cutter compensation from tool center to tool edge when
0 g the workcell.

Tool Offset
Specifies if the tool co
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Multi-Step & Multi-Pass Trajectory Milling

Multi-Step £
o
Final pass along specified trajectory uDJ,
g TOOL,
NUMBER_CUTS NUMBER_CUTS = 4 E AN
STEP_DEPTH R
A
Start Height
Height REFERENCE MODEL\ FINAL
9 TRAJECTORY

Multi-Pass (at same height)

Final pass along specified trajectory

REFERENCE \%
MODEL
NUM_PROF_PASSES FINAL EDGE
PROF_INCREMENT g
}MCR ENT
Slide 7 -

Multi-Step and Mutli-Pass

» Multi-step Trajectory milling can be created by specifying %the desired STEP_DEPTH
or the desired NUMBER_CUTS. If both are specified,Xhe Righer of the two numbers of cuts
will be used. The last pass will coincide with the cifiedtrajectory.

« Start Height: can be used to specify an alterna rt height to the top of workpiece.

* Height: can be used to specify alternative I"Reight of tool path.
o

* Multi-pass Trajectory milling (a XOn of trajectory passes with horizontal offset) can
be performed by using the NU F PASSES and PROF_INCREMENT parameters.
The last pass will coincide pecified trajectory.

N
&@©
Q®
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating Trajectory Milling Sequences

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Creating Trajectory Milling Sequences %

Scenario
* Throughout this course, the exercise scenarios %%e same as the demo scenarios.

» This has been done to build consistency betw os and lab exercises so as to enable
“Tell me—Show me—Let me do.”

Method O@
Use the script in the instructors gui E%%\% e same models as in the exercises.

Exercise

Once the demo is com t@tudents should use the steps in the training guide to complete
the exercises.

Q)
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Daily Skill Checks

Evaluate your progress:
® Achieve the course objectives.
® Use Pro/FICIENCY assessment questions.
® Apply Precision Learning.

Precision Learning %
* Learn: by listening to lectures, watching demos, and,.co g lab exercises.
» Assess: your progress with Pro/FICIENCY.

* Improve: The next day the instructor reviews th m results of the group and reviews
those topics that received the fewest correct a

N

Getting Started
* Before lunch on the first day of clas$ @ the customer accounts.
* When the customers are returni unch refer them to the new Appendix.
* Have them take the sample e @?
* Review the results of th % nd use as an icebreaker.

Daily Tests

Description: For e@ 5 new 10 question exams based upon the topics covered each

day.

How to s
omer accounts already setup for the sample exam.

. At th nd of each day the customers take the 10 question exam relating to that days’
topics.

» The next morning, review the results of the group.
* Review those topics with the class that obtained the most incorrect answers.
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Summary

After successfully completing this module, you should know how to:
® Describe the trajectory milling process.
® Describe different methods of creating a trajectory.
® Describe how to create a sketched tool.
© Describe the features of multi-step and multi-pass trajectory milling.

® Create trajectory milling sequences by defining cut motions.

QO

Summary %

After successfully completing this module, you should kn to:
» Describe the trajectory milling process.

Describe different methods of creating a trajec@
Describe how to create a sketched tool. @
Describe the features of multi-step and i-pass trajectory milling.

Create trajectory milling sequence efining cut motions.

©©
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Exercise 1: Creating Trajectory Milling Sequences

Module 12 Lab Exercises

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

» Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2002380 or later.

» Download and install the class fileswi | df i re_mi I | = .tar. gz as described in

the classroom setup notes.

Introduction @;\
e

In this demonstration, you create a trajector@g quence to machine the groove in the top
portion of the model. You modify the tom adding and removing cut motions to provide a
<&

ramped approach into the slot. Trgj % ing sequences can be used for milling slots where
the shape of the tool correspondégg\&g of the slot, and they can also be used to chamfer edges.
Objectives @

After successfullycofgle this exercise, you will know how to:

* Create {raje illing sequences by defining cut motions.
Scenario
Y ow ready to continue machining the aluminum cover. You create a trajectory milling

e to machine the groove in the top portion of the model. You modify the tool path by
g and removing cut motions to provide a ramped approach into the slot.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 12-3



Figure 1: Showing groove to be machined. @@

Parameters
The following are key trajectory milling parameters. @

Table 1: Parameter Descriptior& Di

Parameter Description

CUTCOM Turns cutter compensation m&t{in the CL data file.
NUMBER_CUTS Calculate the step dept@gs%@fr%ber of cuts.
STEP_DEPTH The incremental deptt&f eagh cut.
NUM_PROF_PASSES Number of profile,Fases &t each depth.
PROF_INCREMENT Horizontal distatcebetiveen passes.

O

Step 1. Locate and open the cove{n?agﬁfé/cturing model.

\)
Before creating the traject ry@?ﬁ%uenca we first need to locate the manufacturing model
and open it using the fold or. Once we have located the folder for this exercise, we can

set this as our workjrig i , and open the manufacturing model of the cover.

In the na tor ct the Folder Browser tab, and browse to
c: \use §&dent\wndflre mfg_330\module12, right-click, and select Make Working

n COVER MFG. Turn off any displayed datum features.

Step 2. Create a trajectory milling NC Sequence to machine the groove in the top of the cover.

Using the Menu Manager, we can create a trajectory milling sequence. Notice how the Customize
dialog box appears immediately. This is because a tool, site parameter file, machine co-ordinate
system, and retract surface have already been specified for this operation. We can cancel out of

the Customize dialog box, so we can specify a tool and name the sequence. We can select the

Page 12-4 Creating Trajectory Milling Sequences
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name, and tool options. We can enter a name for the sequence to make it easy to identify, and

change the tool to a smaller diameter end mill wide enough to machine the slot.

We now need to specify the trajectory we want the tool to follow. Using the Customize dialog box,
we can insert an automatic cut motion, use the edge and tangent chain options and select the
circular edge in the top-left corner of the groove, ensuring we pick the edge at the bottom of the
groove. We can leave the cut direction pointing to the left; we can also specify the tool offset to
the left, completing the cut motion. We can see this creates a toolpath that machines the ‘groove
in an anti-clockwise direction. Notice how the tool makes a plunge move at the sta/%x t

motion. This can be modified by removing and adding specific cut motions.

1.
Y%
Note: @
Notice how the Customize dialog box appears imme %is is because a tool,
site parameter file, machine co-ordinate system, @rd retractSurface have already
been specified for this operation.
2. Select Seq Setup, then select the Name a heck boxes.

3. Name the sequence [FI N_GROOVE].

4. Change the tool to the FEM_03; 0
5. Zoom into the area with the :% ature on the model.

6. To create a cut motion sele¢t Clistomize, and in the Customize dialog box, Insert an
Automatic Cut motign.

7. Select Edge; t Edge Fit options, and using Tangent Chain select the circular
edge at t of the groove, as shown in the following figure.

Figure 2: Showing selected edge and tangent chain of edges highlighted.

8. Leave the cut direction arrow pointing to the left, and select Left for the tool offset.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 12-5



Figure 3: Showing the cut direction arrow pointing to the left. \%
9. Complete the cut motion, and close the Customize dialog box. @

10. Play the tool path using the Screen Play option. Ensure the CL data is visibl

7
Figure 4: h@the plunge move at the start of cut motion.

Tool Path Revi
The tool m @ oove but makes a plunge move at the start of the cut

motion. Thi odified by removing and adding specific cut motions.
Step 3. Delet e auto plunge cut motion and create a ramp approach cut motion and a normal
e)ﬁ@c{t

od/fy the tool path to give the desired motion. Using the Customize dialog box, we
can de the auto plunge cut motion, and then insert a Go to point in front of the automatic cut
motion. To create a ramp move, we need to offset this point by 10 in the X-increment and 5 in the
Z-increment. We can also modify the retract move at the end of the tool path, select end of tool
path in the dialog box, insert a Go delta motion, and specify a distance of 5 in the Z-increment
direction. Completing the customization, we can review the tool path, and notice how the tool

makes a ramp approach move and a normal exit move before moving to the retract plane.
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1. Select Customize to open the Customize dialog box, select the Auto Plunge cut motion,
and Delete it.

2. Select the Automatic Cut motion in the Customize dialog box, and insert a Goto Point
motion from the drop-down list.

3. Inthe Goto Point dialog box, click the Specify Point button, using Create and On
Toolpath options select a point at the start of the toolpath, as shown in the following figure.

Figure 5: Showing selected goto point at pof tool path.

4. Click the Specify Offset button, and type [10k (0.39 the X-increment text box and [5]
(0.20 in) in the Z-increment text box. Close th%o\ t and Goto Point dialog boxes.
¢

Note: @
We have created the first Goto p now need to ramp into the start of the

lo]]
automatic cut motion by creafing @?nd Goto point at the start of the cut motion.

5. Select the Automatic Cut %%Qn}the Customize dialog box, and insert another Goto
Point motion from the dro@m list.

Toolpath o ct the same point at the start of the toolpath, as shown in the previous
figure.

6. In the Goto Point diglog\hoy, click the Specify Point button, using Create and On
rQ s%

> } bltton, and change the feed rate from FREE to CUT, close the Feed

alog box and the Goto Point dialog box.

e
( e now need to create an exit move to move clear of the groove at cutting feed rate.

Select the end of toolpath in the Customize dialog box and insert a Go Delta motion from
the drop-down list, type [5] (0.20 in) in the Z-increment text box. Close the Goto Delta dialog
box.

9. Close the Customize dialog box.

10. Play the tool path using the Screen Play option. Ensure the CL data is visible.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 12-7



Figure 6: Showing ramp approach and normal exit motion.

Tool Path Review:

Notice how the tool makes a ramp approach move and a normal exit move

moving to the retract plane.

11. Save the manufacturing model. @

12. Close all windows and erase all components from memory. é §>

>
Q
O
N
B
S
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Summary

After successfully completing this module, you should know how to:

Describe the trajectory milling process.
Describe different methods of creating a trajectory.

Describe how to create a sketched tool.

Describe the features of multi-step and multi-pass trajectory milling.
Create trajectory milling sequences by defining cut motions. \

%@

>
Q
O
N
B
S
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Module

13

Creating Holemaking Sequences

\‘
Introduction @

Creating holemaking sequences enables you to cr any different types of
drilling cycles for machining. During the holemaki Z@‘ess, you need to select
the appropriate cycle type; these include st %ﬂling, boring, tapping,
reaming and countersink drill cycles. It is.ther important to understand when
each type of drill cycle should be uged. Al important stage in the
holemaking process is creating holexsets that define the holes to be drilled. If you
need to perform a series of hole equences on the same set of holes, you
can configure a drill group thatsi es the selection process. Also any
holemaking sequences tha@wce a drill group will update if a drill group is

modified.

&

Objectives g&\

After com 'module, you will be able to:

« De @e holemaking process.

@ﬁe the key holemaking manufacturing parameters.
e

scribe different drill cycle types, and hole selection methods.

Create and refine holemaking sequences.

e Create drill groups relevant to holemaking.

Q)
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Creating Milling Sequences with Pro/ENGINEER
Wildfire

Module 13: Creating Holemaking Sequences S

to Product First™

&,

Instructor Preparation %
Before teaching Creating Milling Sequences with E@zlEER Wildfire, you must

ro/l
have read and thoroughly understood the folloﬁ%materials:
» General Information
* Review Pro/ENGINEER Wildfire prir@e at http://rdweb.ptc.com/primer/

- O
* Pro/E Wildfire Documentation 3@
* Review Pro/ENGINEER ocumentation in Windmill, located in
/GS Training Materials/Dom@ edge/Create/ProENGINEER/Core Concepts

* Pro/E Wildfire Mil
* Review Pro/E EER Wildfire Milling training materials in Windmill, located in
/GS Ed Srvcs tions/GS Education Library/Instructor Materials/Instructor Kits/EN
/T979-330- I tructor” Kit-EN

Sk|IIs
ompletlon of Pro/E Wildfire Foundation or equivalent Pro/E skills

« ‘Completion of Creating Milling Sequences with Pro/ENGINEER Wildfire or
equivalent Pro/E skills

« Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Four

Correcting

Toolpath Failure

ProfFICIENCY
Evaluator
Daily
Assessments

[

Creating Creating
_| Roughingand |...._| Post-Processing |....._|
';""'“‘k'"“ Re-Roughing CL Data
eqeunces —|_Sequences
Creating Creating Post-Processing ’
Holemaking -~ Roughingand [~  CLData |-
Seqeunces Re-Roughing
Sequences
Creating Creating [T Post-Processing [ 7777
Holemaking | Roughingand ... CL Data
Sequences
Creating Drill
Groups and
Holemaking
Seqeunces
(Challenge)

Correcting

Toolpath Failure |-

Correcting

Toolpath Failure |-

\}
D@

- D

Duration

Lecture: 15 mins
Demos (1) : 20 mins
Labs (2) : 55 mins
Total: 1 hr 30 mins

&

e

©©

®
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Objectives

After completing this module, you should know how to:
Describe the holemaking process.
Describe the key holemaking manufacturing parameters.
Describe different drill cycle types, and hole selection methods.
Create and refine holemaking sequences.

Create drill groups relevant to holemaking.

\%
Slide 3 @Pm

Overview %
Creating holemaking sequences enables you to crea@ ifferent types of drilling

cycle for machining. During the holemaking proce%yi) d to select the appropriate

cycle type; these include standard drilling, boring, tapping, reaming and countersink drill
cycles. It is therefore important to understand ch type of drill cycle should be
used. Another important stage in the holemaki cess is creating hole sets that define
the holes to be drilled. If you need to peﬁor@gries of holemaking sequences on the
same set of holes, you can configure a ;-“l group that simplifies the selection process.
Also any holemaking sequences that ece a drill group will update if a drill group is

modified. &

After completing this module Il be able to:

» Describe the holemaki ess.
» Describe the key hole ng manufacturing parameters.
 Describe diff; encycle types, and hole selection methods.

» Createand r olemaking sequences.
» Create d&groups relevant to holemaking.

Q®
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Holemaking Overview

®Select drill cycle type
ee.g. Drill/Standard
®Set manufacturing parameters
ee.g. SCAN_TYPE
©®Configure hole set
e Holes to be drilled
« Depth options
®Customize hole connections

DQ\%

Holemaking Process %

You can create Holemaking sequences by:

+ Selecting the appropriate holemaking cycle type, e.g. drilling or reaming
 Setting manufacturing parameters for feeds @peeds.

» Configuring the set of holes to be machingd,\by selecting the holes and specifying
depth options.

o
» Specify the method for connec % oles.

©©
&@6
Q®
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Cycle Types
Output different CYCLE/XXXX statements
Dril TOOLS CYCLE TYPES
» Standard DRILL | FACE | BORE | COUNTERSINK | TAP | REAM
*Deep DRILL v v v v v
+ Break Chip COUNTERSINK | v | v | v v v
o« Web
TAP v

e Back
REAM

BORE
Bore CENTER-DRILL
Countersink BACKSPOTTING
END MILL

Face

N/ENEN NN
<
<
<

v

v v v

v

7 \
Tap v v v
o Fixed/Floating

Ream
Custom

Slide 5 [/ BRou2PTC

Drill Cycle Types

Depending on the cycle type selected a different CYGQLE/ statement is output in the
CL data file

For Reference only, describe as required:

Drill — Drill a hole. Depending on the additignal option selected, the following
statement will be output to the CL file: @

Standard (default) - CYCLE/ %K

Deep — CYCLE/DEEP &

Break Chip — CYCLE/B @

Web — CYCLE/THRU_(far multiple plates)

Back — GOTO @DLE statements for back spotting

Face — Drill h%g an optional dwell at final depth to help assure a clean

surface at the bgttg e hole. The CYCLE/FACE statement will be output to the CL

file.

statement will be output to the CL file.

Bore —Bore a’hole to create a finish hole diameter with high precision. The
CYCLE/

- o sink — Drill a chamfer for a countersunk screw. The CYCLE/CSINK
st ntwill be output to the CL file. If the Back option is selected together with
Countersink, the system will perform back countersinking.

Tap — Drill a threaded hole. Pro/NC supports ISO standard thread output. The
CYCLE/TAP statement will be output to the CL file. Two additional options are available:

» Fixed — The feed rate is determined by the combination of thread pitch and spindle
speed.

* Floating — Allows you to modify the feed rate using the parameter
FLOAT_TAP_FACTOR.

Ream — Create a precision finish hole. The CYCLE/REAM statement will be output
to the CL file.

Custom — Create and use your own customized cycles for the current machine tool.
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Key Manufacturing Parameters

SCAN_TYPE
«TYPE_1
« TYPE_SPIRAL
« TYPE_ONE_DIR TooL I
«PICK_ORDER
: o © 9|z
« SHORTEST ¥ 5
BREAKOUT_DISTANCE - 'é
=
2

RAPTO_DIST
PECK_DEPTH
CLEAR_DIST

RAPTO_DIST T \%
PULLOUT_DIST ,

@i DRILL HOLE

Manufacturing Parameters @f?
+ SCAN_TYPE: Calculates the order for drilling sel@y s
(descriptions for reference only)

* TYPE_1—By incrementing the Y coordind going back and forth in the X

CLEAR_DIS

direction.

« TYPE_SPIRAL—Clockwise starting@he hole nearest to the coordinate
system.

* TYPE_ONE_DIR—BYy incre
* PICK_ORDER—The hole
* SHORTEST (default)—T

shortest machine mol@ e.
« BREAKOUT_DiI @Adds the BREAKOUT_DISTANCE value to the Z depth in
the CYCLE e associated with holes drilled Thru All, and with through holes
drilled usin Auto depth option.
T e

« PECK_DEP pth increment for each drilling pass. Default value is 0. If you
select DEEP drilling, you have to specify non-zero PECK_DEPTH.

e ti e X coordinate and decrementing the Y.

drilled in the same order as they are selected.
tem determines which order of holes results in the

GE_FEED ends and the CUT_FEED begins.

* RAPTO_DIST: Allows for further rapid advance from CLEAR_DIST towards the top of
the hole.

« PULLOUT _DIST: Allows for the tool to return to a point other than that defined by
CLEAR_DIST.

%A _DIST: The clearance distance above the top of the hole at which the
PRUN



Configuring Hole Sets

Selecting Holes
o Axes
o Points

o Diameter
o Surfaces

BY
SHOULDER

o Parameters

I
=
o
w
o
o Groups uo_:J
i TOOL
Depth Options T 00 —
«Blind : ; : ;
< Auto 77 Y/ 7
o Thru All /
«By Tip ’| Countersink Diameterl‘_
« By Shoulder |
Countersink Diameter E 3
Slide 7 [/ BRou2PTC

&

Configuring Hole Sets %

Configuring hole sets involves a number of steps Q

Selecting Holes: Specify the holes to be drilledwsing combination of methods
listed below:

* Axes—Specify holes by selecting individu axes.

+ Points—Specify drill locations by sele@atum points or reading in a file with

datum point coordinates. @
* Diameters—Specify holes by e<> ’ iameter value(s).
+ Surfaces—Specify holes by s ig surfaces of the reference part or workpiece.

i

d certain parameter value.

» Parameters—Select holes v
* Groups—Select pred f@drill groups. You can define groups of holes at setup
time for later us r@ king NC sequences. Simplifying later hole selection.

Depth Options

start surface (or Z height) to specified depth. Specify the Start
(by either selecting a surface or entering a Z depth).

. Auto—gepth t drilling is determined automatically, by referencing hole geometry.
I rill a through hole, from the retract surface all the way through the

 Thr
%o@ce(s) or reference part(s) that the hole intersects.

e Tool Depth option buttons, Shoulder and Tip, available for Blind and Auto
Hling, determine if the drilling depth will be with reference to the shoulder or the tip
of the tool.

» Depth for countersink drilling is defined by the start surface and the countersink
diameter value, entered at the time of configuring the Hole Set. Instead of entering
a countersink diameter, you can specify that the system automatically finds all the
applicable chamfers and makes the necessary calculations. Countersink diameter is
the final diameter of the hole after drilling, measured in the start surface.
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

© Creating Holemaking Sequences

Once the demo is complete you should use the steps in the training
guide to complete the exercise.

\}
SO

Demonstration: Creating Holemaking Sequences %

Scenatrio
* Throughout this course, the exercise scenar X@ the same as the demo scenarios.
» This has been done to build consistency demos and lab exercises so as to

enable “Tell me—Show me—Let me d

Method

Use the script in the instructors e the same models as in the exercises.

Exercises (2) g @

Once the demo is cofp e students should use the steps in the training guide to
complete the exer i

&
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Summary

After successfully completing this module, you should know how to:
® Describe the holemaking process.
© Describe the key holemaking manufacturing parameters.
© Describe different drill cycle types, and hole selection methods.
® Create and refine holemaking sequences.

® Create drill groups relevant to holemaking.

\}
D@

Summary %

After successfully completing this module, you shxldk how to:
» Describe the holemaking process.
* Describe the key holemaking manufacturi meters.
» Describe different drill cycle types, and g@election methods.

* Create and refine holemaking s.

* Create drill groups relevant to r%@ king.

©©
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Module 13 Lab Exercises

Exercise 1: Creating Holemaking Sequences

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

* Check for and review the errata sheet for this course.
« Use Pro/ENGINEER Wildfire build code 2002380 or later.

» Download and install the class fileswi | df i re_m | | — .tar. gz as described in

the classroom setup notes.

Introduction @p\
In this demonstration, you create holemaking(s ces to machine the holes in the bottom of

the cover model. You determine the hol enable correct selection of drilling tools. You

<
also insert the holemaking seque@ the operation 020 sequences to ensure they are

created in the correct order. 2\
Objectives @

After successfullycofple this exercise, you will know how to:

e Identify grid odel geometry and dimensions.

« CreateXd@fe ing sequences.

Sc ﬁo

T er model has been completely machined except for the holes in the bottom of the model;
ese should have been drilled during operation 010. To create the holemaking sequences at the
d of operation 010, you insert the sequences before the operation 020 sequences so ensuring
they are created in the correct order. Before machining the holes, you need to identify and check
the hole geometry and dimensions, enabling you to select the correct drilling tools.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 13-3
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Figure 1: Showing holes to be machined.

Y
Parameters @
@@

The following are key holemaking parameters.

Table 1: Parameter Descriptions

—

Parameter Description

SCAN_TYPE Calculates the order for drilling selected hSPE\s‘ i~

BREAKOUT _DISTANCE | Adds the value to the Z depth in the C atements for holes drilled
Thru All, and through holes drille®§ing the Auto depth option.

PECK_DEPTH Depth increment for each drillipgpassyDefault value is 0.

CLEAR_DIST The clearance distance a tﬁé}&) of the hole at which the
PLUNGE_FEED ends annd\the SUT_FEED begins.

RAPTO_DIST Distance of furthgr T @ vance from CLEAR_DIST towards the top of
the hole.

PULLOUT DIST Distance the tdofto ratums to other than that defined by CLEAR_DIST.

Step 1. Locate and open the cover méfwfégﬁjring model.

Before creating the holemakingse es, we need to locate the manufacturing model and open
@eéﬁv

it using the folder naviga e have located the folder for this exercise, we can set this as

Awu the manufacturing model of the cover.

our working directory,

1. In the navigator, $eleet the Folder Browser tab, and browse to
c:\users@en wildfire_mfg_330\module13, right-click, and select Make Working
Direc

R.MFG.

3. Turnvoff any displayed datum features.

Step 2. Activate operation op010, and prepare to insert NC sequences before operation op020.

In the Operation dialog box, we can change the active operation to op010. To see the model
more easily, we can change to the op010-tri view. Notice how the material removal features in
op020 have removed the material from the other side of the cover. We can now activate insert

mode after the last material removal feature for operation op010. Notice the Insert Mode text in

Page 13-4 Creating Holemaking Sequences
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the bottom right corner of the screen, and the operation 020 material removal features have been
suppressed along with all the operation 020 NC sequences. We are now ready to create the

holemaking sequences.

1. Using the Menu Manager, select Mfg setup > Operation, to open the Operation Setup
dialog box. In the Operation Name drop-down list, click op010 to change the active operation
to op010. Close the Operation Setup dialog box, and return to the Manufacture menu.

2. Change the view to the named view OP010-TRI. x
NN

Note:

Notice how the material removal features in op020 have removed t jal ffom
the other side of the cover.

3. Check the model tree and note the position of the OP_020 setu@shown in the following

figure.
4. Using the Menu Manager, select Machining > Utilitie %ert > Activate to activate
insert mode.

5. In the model tree, select the last material remo&%ture for operation op010, as shown.
@1

w¢¥ 3 RGH_BOTT il

a2 Material Femsdal 131529 [3. RGH_BOTTOM]

“WadH Cevs oP0zo
ETRACT OP020
@m "OR020 [FADAL VMO

: Showing insert mode activated after last material removal feature.

Note:

otice the Insert Mode text in the bottom right corner of the screen. Notice also the
ation 020 material removal features have been suppressed along with all the
(}) eration 020 NC sequences.

tep 3. Identify and check the hole dimensions.

Before creating the holemaking sequences, we need to check the hole dimensions. We can
select and activate the cover part in the model tree; we can then select a hole and note its

dimensions.

1. In the model tree, expand the listing for COVER_NC.ASM, then select COVER.PRT, right-
click and Activate the part in the model tree.
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2. Select one of the hole features to display the hole dimensions. Note down the hole
dimensions, and return to the Manufacture menu.

Figure 3: Showing selected hole and dimen@
Note: \\\\}

You should see that the hole diameter is 6.0 (0.24 i depth is 9.65 (0.38 in),
and the countersink diameter is 8.0 (0.317 in) with ee chamfer angle. You
need to center drill, drill and countersink the fgm

Step 4. Create a holemaking NC sequencgyo c{{n%\nd}fll the four holes.
N4

Using the Menu Manager we can create / king sequence. We can specify the drill cycle
type as standard. We can select the n tool options. Enter a name for the sequence to
make it easy to identify, and changeth | to a center drill.

We can specify the CUT. E@/NDLE_SPEED, and CLEAR_DIST parameters. Notice how
the mill site parameter. fil t set default values for a holemaking sequence, even though it

is still active.

Using the Hole Set dialog box, we can use the Diameters tab and select the 6.0 diameter holes,
this automi::' aiixselects all the 6.0 millimeter diameter holes on the model. As this is a center

drilling/se e, we can specify the depth options as blind and tip and specify a depth of 5.0.

By playmg the tool path and making the CL data visible, we can see the tool drills the four holes
to a depth of 5.0 as specified. Notice the CYCLE/DRILL statement in the CL data file. You can
use the SCAN_TYPE parameter to adjust the order and movement between holes; it is not
necessary in this case.

1. Using the Menu Manager, create a Holemaking sequence; use the Drill and Standard
drilling cycle options.
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2. Select the Name and Tool check boxes.

3. Name the sequence [CTR DRI LL].

4. Change the tool to the CTRDRILL_04 drill.

5. Modify the following parameters in the NC sequence:

Table 2: Changed Parameters
Manufacturing Parameter Value
CUT_FEED 130 (5.12in) \
SPINDLE_SPEED 500 @
CLEAR_DIST 3(0.12in) @
Note: %

Notice how the mill site parameter file does not set d a@es for a holemaking
sequence, even though it is still active.
N
6. In the Hole Set dialog box, use the Diameters™ab, and click the Add button, select the 6.0
(0.24 in) diameter holes. Close the Hole Dia &r‘? log box, and Preview the selection.

7. Click the Depth button, then click the d' Tip options. In the Start Surface area, click
the Select button and select the to of the workpiece as the start surface
<&

8. In the End Surface area click
the Hole Set Depth dialog b

e& h option and type a depth of [5. 0] (0.20 in). Close

on.

9. Complete the hole set@
10. Play the tool patr@ Screen Play option. Ensure the CL data is visible.
e

11, Complete th@
)

Figure 4: Showing the center drilling tool path
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Tool Path Review:

The tool drills the four holes to a depth of 5.0 (0.20 in) as specified; notice the
CYCLE /DRILL statement in the CL data file. You can use the SCAN_TYPE
parameter to adjust the order and movement between holes, but it is not necessary
in this case.

Step 5. Create a holemaking NC sequence to drill the four holes with a six-millimeter (0.24 in)
diameter drill.

A\

Using the Menu Manager, we can create a holemaking sequence. We can specify the drill
type as standard, select the name, and tool options. Enter a name for the sequence to ]
easy to identify, and change the tool to a 6 millimeter drill. We can use the previo C

manufacturing parameters.

Using the Hole Set dialog box, we can use the Use Prev option and select t@t hole set. As
this is a standard drilling sequence, we can specify the depth options a t tip, thus
completing the hole set configuration. ? ’2

By playing the tool path and making the CL data visible, we, tool drills the four holes,

automatically calculating the correct depth. Notice the CYCL RILL statement in the CL data
file. @'

1. Using the Menu Manager, create a Holem @ence; use the Drill and Standard,
drilling cycle options. o @
2. Select the Name and Tool check .=

3. Name the sequence [DRI LL
4. Change the tool to the D@@O drill.

5. Use the manufaciyri meters from the previous CTRDRILL_04 sequence.
6. Inthe Hole Setdiatogbox, click the Use Prev button and select Hole Set #1.
7. Clickon t%‘epth button and change the depth options to Auto, and Shoulder.

C o1 ole set configuration.

9. the tool path using the Screen Play option. Ensure the CL data is visible.

®

10. Complete the sequence.
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Figure 5: Showing the resultant tool path. Q®\

Tool Path Review: @
In the CYCLE/DRILL statement the depth is set to drill to the bottom e holes.

(4

Step 6. Create a holemaking NC sequence to drill the four holggwiﬁqu%ountersink drill.

|
Using the Menu Manager, we can create a holemaking sequ ﬁe can specify the drill cycle

type as countersink. We can select the name, and tool op Enter a name for the sequence to

make it easy to identify, and change the tool to a ca sink drill. We can use the previous

sequence manufacturing parameters.

holes on the model to chamfer, and>cals

Using the Hole Set dialog box, we can seleckthe guto chamfer option, this automatically finds the
the countersink diameter. This completes the hole

set configuration.

By playing the tool path and e CL data visible, we can see the tool countersink drills the
four holes. Notice in the Ci\data file the CYCLE/CSINK statement, where the diameter is
automatically calgulated sptrectly at 8.0.

1. Usingt nager, create a Holemaking sequence; use the Countersink drilling
cycle.

2, S@the ame and Tool check boxes.
3.e the sequence [CSI NK].
Change the tool to the CSINK_12 drill.
5. Use the manufacturing parameters from the previous DRILL_06 sequence.

6. Inthe Hole Set dialog box, select the Auto Chamfer check box.

Note:

Selecting Auto Chamfer automatically finds the holes on the model to chamfer, and
calculates the countersink diameter.
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8. Play the tool path using the Screen Play option. Ensure the CL data is visible.

7. Complete the hole set configuration.

9. Complete the sequence, and return to the Manufacture menu.

Figure 6: Showing the resultant tool path. @
Vs

<
Tool Path Review: N4
The tool countersink drills the four holes as specified. Notice) CYCLE/CSINK
statement the diameter is automatically calculated co%kgtly at8.0 (0.31 in).

10. Cancel insert mode; using the Menu Manager, select ining > Utilities > Insert >
Cancel, when prompted, click Yes to resume ope&ration 020 features. Return to the
Manufacture menu.

o O
=~
Note:
Notice all the operation 020 feat esumed in the model tree.
A

11. Save the manufacturing magde
a components from memory.

12. Close all windows an:
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Exercise 2: Creating Drill Groups and Holemaking Sequences
(Challenge)

Objectives

After successfully completing this exercise, you will know how to:

e Create holemaking sequences.

e Create drill groups.

Scenario

In this exercise, you have a special request to machine holes in a new m fixture that is
required for another job. You create drill groups to enable easy selectian of the holes for the
holemaking sequences. You center-drill all the holes in the model. @eate a holemaking
sequence to drill the seven holes on the stepped face of the m then drill and tap the four
holes in the bolt hole pattern on the top face of the model, and\{inis}¥ by drilling and boring the

large hole on the top face.

Step 1. Locate and open the bracket manufacturir,mg\ﬁqdel.

c:\users\student\wildfire_mfg_33 odule13\bracket, right-click, and select Make
Working Directory. o

2. Open BRACKET.MFG. @
3. Turn off any displayed/ﬁgt@ures.

1. In the navigator, select the Folder Browés@é@browse to

Step 2. Identify and chqc\kwe hole dimensions on the bracket part.

1. Selectand a MBRACKET.PRT part in the model tree.

seven holes on the stepped face of the model. Note the hole dimensions.

imensions.

f M18x2.5 150 - H TAP THRU

15.5 DRILL (15.50 ) THRU -(4) HOLE

3. Sﬁone ©of the four holes in the bolt hole pattern on the top face of the model. Note the
|

Figure 7: Showing the bracket part and 3D note.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 13-11



(b PTC
Note:

Note the dimensions of the M18 tapped holes are also displayed in a 3D note.

4. Determine the hole and counter bore diameter of the large hole on the top face of the model.

5. Turn off the display of 3D notes.

Step 3. Create two drill groups, one for the seven holes on the stepped face and the other for the
holes in the bolt hole pattern.

1. Using the Menu Manager, create a drill group of the seven holes on the stepped fa@

model, select the holes by diameter size; name it [gr oup_14 0].

2. Using the Menu Manager, create a drill group of the four holes that make up hole
pattern on the top face of the model, select the holes by diameter size; name i

[gr oup_ni8_0]. @

2
Step 4. Create a holemaking sequence to center drill all the holes. %

Note: \}

An operation has already been setup, this includes a is milling workcell with
tools, a machine zero co-ordinate system, and a ace.

&
1. Using the Menu Manager, create a holemaking uence; use the Standard drilling cycle.
2. Select the Name and Tool check boxe$

3. Name the sequence [CTR_DRI LL@%Q

4. Change the tool to the CTRD drill.

5. Modify the following parame in the NC sequence:

Table 3: Changed Parameters

'Mapufacturing Parameter Value
%T_FEED 130 (6.12in)

SPINDLE_SPEED 500

Q@ CLEAR DIST 3(0.12in)

6. In the Hole Set dialog box, use the Groups tab to add the group_M18_0 holes to the hole
set.

7. Select the axis tab and select the large hole in the center of the top face of the model.

8. Set the depth options to Blind and Tip; select the top surface of the model as the start
surface and specify an end surface Z-depth of [4. 0] (0.16 in). Preview the hole set.
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Figure 8: Showing the first hole set and starting surfa©©

9. Complete the hole set configuration.

10. Create a second hole set. In the Hole Set dialog box, use th tab to add the
group_14_0 holes to the hole set.

11. Set the depth options to Blind and Tip; select the s ed surface of the model as the start
surface and specify an end surface Z-depth of E&(O. in).

0

@ Figure 9: Showing the second hole set and starting surface.
plete the hole set configuration.

12. C%
1t e tool path using the Screen Play option. Ensure the CL data is visible.

14. Complete the NC sequence.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 13-13



PTC

Figure 10: Showing the resulting tool path. @\

Step 5. Create a holemaking sequence to drill the seven holes on the stepped f of \ﬁuodel,
use the fourteen millimeter diameter drill.

1. Using the Menu Manager, create a holemaking sequence; use the Sta@ drilling cycle.
2. Select the Name and Tool check boxes. %

3. Name the sequence [DRI LL_14 0].

4. Change the tool to the DRILL_14_0 drill. \
5. For the manufacturing parameters, select Use P @welect the previous sequence
parameters, then modify the following paramete@

Table @& Parameters
S

Manufacturing Parameter Value
BREAKOUT_DIS7ANCE 2.0 (0.08 in).
@U
6. In the Hole Set dialo o@e Groups tab to add the group_14_0 holes to the hole set.
7. Set the depth opfd u All, and select the bracket as the part to be used for depth
calculations. ew the hole set. Complete the hole set configuration.

8. Play the te§] path using the Screen Play option. Ensure the CL data is visible.

C 01\ NC sequence.

©
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Figure 11: Showing the resulting tool path. @\

Step 6. Create a holemaking sequence using a tapping drill to drill the f@ il the bolt hole
pattern.

1. Using the Menu Manager create a holemaking sequence; use @ndard, drilling cycle.
2. Select the Name and Tool check boxes.

3. Name the sequence [DRI LL_15_5].

4. Change the tool to the DRILL_15_5 drill. @\
e\Pre

5. For the manufacturing parameters, sele
sequence parameters.
&
t

6. In the Hole Set dialog box, USK@S tab to add the group_m18_0 holes to the hole

v, and select the previous drill_14_0

set.

calculations. Complete'thefhole set configuration.

8. Play the tool a t@the Screen Play option. Ensure the CL data is visible.

7. Set the depth option t@ , and select the bracket as the part to be used for depth

Figure 12: Showing the resulting tool path.

9. Complete the NC sequence.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 13-15



% PTC

Step 7. Create a holemaking sequence to tap the four holes in the bolt hole pattern.

1. Using the Menu Manager create a holemaking sequence; use the Tap, Fixed cycle.
2. Select the Name and Tool check boxes.

3. Name the sequence [TAP_18 Q0].

4. Change the tool to the TAP_18_0 tool.

5. For the manufacturing parameters, select Use Prev, and select the previous drill_1
sequence parameters.

6. Modify the following manufacturing parameters: @

Table 5: Changed Parameters

Manufacturing Parameter Value O
THREAD_FEED 2.5(0.10 iy~
THREAD_FEED_UNITS MMPR e
SPINDLE_SPEED 300\ ))

7. Inthe Hole Set dialog box use the groups tab to add @%up_mw_o holes to the hole

set.

8. Set the depth option to Thru All, and S@Ieracket as the part to be used for depth
calculations. Preview the hole set. &%} e hole set configuration.

9. Play the tool path using the Scre option. Ensure the CL data is visible.

10. Complete the NC sequer@@ﬁ

Figure 13: Showing the resulting tool path.

Note:
Notice the CYCLE/TAP statement in the CL data file.
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Step 8. Create two holemaking sequences to drill and counter bore the large hole on the top face

of the model.

10.
1.
12,
13.

14.

15.

@

Using the Menu Manager, create a holemaking sequence; use the Standard drilling cycle.
Select the Name and Tool check boxes.

Name the sequence [DRI LL_24_O0].

Change the tool to the DRILL_24_0 drill.

For the manufacturing parameters, select Use Prev, and select the previous d

sequence parameters. @
In the Hole Set dialog box, use the Axis tab and add the 24.0 (0.94 lr‘ ef hole to the

hole set.

Set the depth option to Thru All, and select the bracket as the@ be used for depth
calculations. Complete the hole set configuration.

Play the tool path using the Screen Play option. ERsure the CL data is visible.
Complete the NC sequence.

Using the Menu Manager, create a holemaki@uence; use the Bore cycle.
Select the Name and Tool check bg

Name the sequence [BORE _ 4é>

driII.

Change the tool to the BO

eters, select Use Prev, and select the previous drill_14_0

For the manufacturing( :r
sequence param@
ia

In the Hole S 0x, use the Axis tab and add the 40.0 (7.57 in) diameter hole to the
hole se
. Set the options to Blind and Tip, select the surface on the top of the model as the

sl&s:m‘ace and the surface at the bottom of the counter bore as the end surface.

the tool path using the Screen Play option. Ensure the CL data is visible.
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Figure 14: Showing the resulting tool path. @

18. Complete the NC sequence. @
19. Save the manufacturing model. %

20. Close all windows and erase all components from mem&

‘0
O

N
@@@
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Summary

After successfully completing this module, you should know how to:

Describe the holemaking process.

Describe the key holemaking manufacturing parameters.

Describe different drill cycle types, and hole selection methods.

Create and refine holemaking sequences.

Create drill groups relevant to holemaking.

>
Q
O
N
we
S
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Module
X

Creating Roughing and Reroughing

\

Sequences

@

Introduction

Roughing sequences are similar to volume %quences, but are intended
specifically for high-speed mold machining, and)especially for machining
imported, non-solid geometry. Rou@%g%se nces have additional capabilities

aimed at producing more efficien ((s oNdaths when machining mold cavities or
pockets. @

Reroughing NC sequenc ates tool paths to machine only the areas where a
previous roughing oy re@n sequence could not reach. Typically they are
performed with a and machine the areas that the larger roughing

cutter could no to its size.
Itis impo t erstand the differences between volume milling and
roughi ughnces and to use each sequence appropriately.

§GS

After’completing this module, you will be able to:

» Describe high speed machining strategies.
» Describe the roughing and reroughing process.
@ » Describe the key roughing and reroughing features.
» Describe the key roughing and reroughing manufacturing parameters.
*  Create mill volumes and mill windows.

e Create volume and roughing sequences.
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Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 14: Creating Roughing and Reroughing

©p1c <>©

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Four

Pro/FICIENCY
| Toolpath Failure T* s Daily

Creating

...... o] POSt-Processing ||  Correcting
CL Data

. L L
Creating Creating Post-Processing Il
| Holemaking [ Roughing and ~=| CLData |- mﬁoﬁcgﬁm )
Sequences Re-Roughing i
Creating [ Creating 77| Post-Processing [T correcting |
_| Holemaking | Roughingand || cLpata | Toolpath Failure |-
Sequences Re-Roughing

&
Creating Drill
Groups and
Holemaking
Sequences
(Challenge)

Duration %

* Lecture: 15 mins
* Demos (1) : 25 mins

* Labs (1) : 50 mins @\
-+ Total: 1 hr 30 mins @

1
2
S
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Objectives

After completing this module, you should know how to:
Describe high speed machining strategies.
Describe the roughing and reroughing process.
Describe the key roughing and reroughing features.
Describe the key roughing and reroughing manufacturing parameters.
Create mill volumes and mill windows.

Create volume and roughing sequences.

AN
o)

@

Overview

Roughing sequences are similar to volume milling sequence are intended specifically for
high-speed mold machining, and especially for machinin rted, non-solid geometry.
Roughing sequences have additional capabilities ai at producing more efficient tool paths

when machining mold cavities or pockets.

Reroughing NC sequences create tool paths to @é only the areas where a previous
roughing or reroughing sequence could not re@ypically they are performed with a smaller
h

tool and machine the areas that the Iarger@
It is important to understand the differ; %
and to use each sequence appropri &

After completing this module, y@l e able to:
» Describe high speed machiting strategies.

g cutter could not enter due to its size.
ween volume milling and roughing sequences

 Describe the roughi eroughing process.
» Describe the g and reroughing features.
» Describe t%%ke ghing and reroughing manufacturing parameters.

» Create mi umes and mill windows.
» Create e and roughing sequences.



High Speed Machining Strategies

High Speed Machining
® Reduces cycle times
® Increases tool life

® Creates better surface finishes

Volume Milling
® High Speed Roughing
«ROUGH_OPTION = ROUGH_ONLY

¢ SCAN_TYPE = CONSTANT_LOAD
Constant cutting condition and chip load
Approach from outside material
Minimize sudden tool direction changes
Reduce repositioning moves

® High Speed Finishing
«ROUGH_OPTION = PROF_ONLY
« SCAN_TYPE = CONSTANT_LOAD

High Speed Machining Strategies %
High Speed Machining provides the following benefits: @
* Reduces cycle times
« Increases tool life \
* Creates better surface finishes @‘
In Volume Milling
* High Speed Roughing conditions can ated by setting

ROUGH_OPTION to ROUGH_O <
SCAN_TYPE to CONSTANT_ sn >
chip load

« This achieves the following:
» Constant cutting conditi
« Approach from o} %&terial
* Minimize su irection changes
* Reduce repQsjtioning moves
High SpeedFinishifig conditions can be created by setting
ROUG QigjON to PROF_ONLY
« S @E to CONSTANT_LOAD
. ieves:
» Constant cutting condition and chip load
» Minimize sudden tool direction changes
* Reduce repositioning moves
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Roughing and Reroughing Sequences

Roughing
® High speed mold machining
® Machining imported geometry
® Roughing removes all material inside a mill window boundary

Reroughing
® Machines where previous roughing could not reach

o Typically uses smaller tool

Q\%

Roughing and Reroughing

These NC sequence types are designed specifically for high» % mold machining, and
especially for machining imported, non-solid geometry.

Roughing removes all material inside a mill windo ary, with additional depth control
based on the depth of the mill window.

Reroughing NC sequences creates too‘l> machlne only the areas where a previous
Roughing sequence could not reach. hey are performed with a smaller tool and
machine the areas that the larger rg ... cutter could not enter due to its size. They do not

attempt to remove scallops left b i he slices of the referenced sequence.

s
Q@&@



Roughing and Reroughing Features

High Speed Roughing Scans
e Open and Closed Areas

¢ OPENICLOSED_AREA_SCAN
CONSTANT_LOAD
SPIRAL_MAINTAIN_CUT_TYPE
SPIRAL_MAINTAIN_CUT_DIRECTION
FOLLOW_CONTOUR

Entry and Exit Methods
e Open and Closed Areas

o CLOSED_AREA_ENTRYIEXIT
TANGENT_HELIX
RAMP

Slide 6

Roughing and Reroughing Features

* High Speed Roughing Scans : 2 5

+ Allows selection of a different high-speed scans fo and closed areas, assessed
on a slice by slice basis. \

« CONSTANT_LOAD (default CL —creates a cutter path that produces an
approximately constant tool 19
* SPIRAL_MAINTAIN_CUT_ %creates a spiral cutter path with reverse arc
connections between cutg_JRis-option minimizes retracts.
* SPIRAL_MAINTAIN \“DIRECTION—creates a spiral cutter path with S-shape
connections betwe . This option minimizes retracts.
FQTU%

» Controlling parameters are: @9
+ OPEN/CLOSED_AREA_SCAN @

« FOLLOW_C (default OPEN)—the shape of each cut follows the shape of
the hard wall intaining fixed offset between the respective points of two

* Entry and %t{ Methods

* Pro ferent entry methods for open and closed areas. The tool enters open areas
(o] side. For closed areas, you can specify either helical or ramp top entry method.

» Sdntrolling parameters are:
« CLOSED_AREA_ENTRY/EXIT
» Approach or Exit move can be TANGENT_HELIX or RAMP



B ric

Roughing and Reroughing Features

. I
Step depth calculations WORKPIECE £
w
e Based on maximum and ‘ — C‘I
minimum z-heights Max Z Height }&
« MAX_STEP_DEPTH &
«MIN_STEP_DEPTH UNIFORM
STEP DEPTH
Min Z Height MODEL | :I IGNORED

Improved tolerance control
« Tolerance Options T Tolerance
Symmetrical Plus
«INSIDE_TOLERANCE Tolerance
«OUTSIDE_TOLERANCE Tolerance
Minus
77777777 § Inside_Tolerance @
Improved
Tolerance * Outside_Tolerance

Slide 7 ©2002

Roughing and Reroughing Features %@
» Additional step depth calculations : E

 Calculates the step depth based on the maxir& inimum Z heights in the mill
e

window and the MAX_STEP_DEPTH param value.
* MAX_STEP_DEPTH

+ Specifies the maximum allowed step d er finding the positions of the highest and
lowest slices, the system calculates tual step depth which is less than or equal to
the specified MAX_STEP_DEPTH @esults in @ minimum number of uniformly
spaced slices.

* MIN_STEP_DEPTH
* Lets you specify the mm@@b depth allowed between the slices.
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Y/ROUGHSCALLOP

— | EXTRA
SLICES

Roughing and Reroughing Features

Scallop Height Control

Optional extra slices

¢ ROUGH_SCALLOP_CONTROL
DURING
DURING_BOTTOM_UP
AFTER

«ROUGH_SCALLOP

step depth

Uniform step depth <=
_ MAX_STEP_DEPTH
Slide 8 ozoag>

Roughing and Reroughing Features

Additional Scallop height control : E D?
g

After a first roughing sequence, the resulting scallop hei s not always leave a constant
thickness of material to remove for any subsequent %ng tool paths. Rough scallop control
enables a semi-finishing toolpath to be generated same tool and during the same NC
sequence, resulting in a smaller scallop height, e uniform thickness of material
remaining for any subsequent finishing tool pa@

ROUGH_SCALLOP_CONTROL

o
Controls if extra slices are created b (@ular roughing slices, and defines the machining
order:

*NO—no extra slices are genera e@ntrol the scallop height.
the extra slices and inserts them between the regular slices.

*DURING—the system generat
*DURING_BOTTOM_U @stem generates the extra slices and inserts them between
the regular slices, perforpai em from the bottom up to optimize the tool load.

AFTER—the sys tes the extra slices. The tool machines all the regular slices first,
and then machinesitfé gxtra slices to reduce the scallop height, where needed.

-ROUGH_@&QP: maximum scallop height for the steps between the regular slices.
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating Volume and Roughing Sequences

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

QO

Demonstration: Creating Volume and Roughing Seque c%

Scenario
* Throughout this course, the exercise scenarios %%e same as the demo scenarios.

» This has been done to build consistency betw os and lab exercises so as to enable
“Tell me—Show me—Let me do.”

Method O@
Use the script in the instructors gui E%%\% e same models as in the exercises.

Exercises (1)

Once the demo is com t@tudents should use the steps in the training guide to complete
the exercises.

Q)
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Summary

After successfully completing this module, you should know how to:
® Describe high speed machining strategies.
® Describe the roughing and reroughing process.
© Describe the key roughing and reroughing features.
© Describe the key roughing and reroughing manufacturing parameters.
® Create mill volumes and mill windows.

® Create volume and roughing sequences.

Summary %

After successfully completing this module, you should kn to:
» Describe high speed machining strategies.

Describe the roughing and reroughing process

Describe the key roughing and reroughlng a

Create mill volumes and mill wind s.

* Create volume and roughing s S.

©©

Describe the key roughing and rerqyg nufacturlng parameters.

QO
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Module 14 Lab Exercises
Exercise 1: Creating Roughing Sequences

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

» Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2002380 or later.

» Download and install the class fileswi | df i re_mi I | = .tar. gz as described in

the classroom setup notes.

Introduction @5\
|

In this demonstration, you machine a mold @ using alternative volume milling and
i

roughing sequences. You apply high sp@
<&
the different resulting tool paths. Youtmo he roughing sequence and create extra slices to

reduce the scallop height on th E%@aiu%s of the cavity. It is important to understand the

differences between volum ahd roughing sequences and to use each sequence
appropriately. ©@
Objectives

leting this exercise, you will know how to:

ning methods to both sequences and compare

. C%: milvolumes and mill windows.
. volume and roughing sequences.

cenario

ou machine a mold tool cavity using alternative volume milling and roughing sequences. You
start by opening an existing manufacturing model containing a mold cavity. You create a volume
milling sequence to create a roughing toolpath in the cavity; you apply high speed machining
methods to improve the efficiency of the tool path. You notice that the scallop height of the
resulting tool path does not leave a uniform thickness of material to remove for any subsequent
finishing tool paths. You create an alternative toolpath using a roughing sequence to machine the
same cavity, again applying high speed machining methods. This toolpath creates roughing and
semi-finish passes in the same NC sequence. You notice the scallop height of the resulting tool
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path is now reduced, leaving a more uniform thickness of material remaining for any subsequent
finishing tool paths. (The next stage in the machining process would be to finish the mold cavity
with a series of surface milling sequences; this is not done in this exercise).

Figure 1: Showing the mold cavity to be machined.

Parameters

The following are key roughing parameters.

Table 1: Parameter De??}rpt\x;s

Parameter

7a
Description N\

OPEN_AREA_SCAN

Specifies the way t todbscans a horizontal machining slice that
contains at le en side. All the options are intended for

high speeﬁ{q g.

CLOSED_AREA SCAN Specifie e\%y the tool scans a horizontal machining slice that
is co ely’gurrounded by hard walls. All the options are
inten high speed machining.

CLOSED_AREA_ENTRY

Qp@g’pies the top entry method for closed areas.

CLOSED_AREA_EXIT

%ecifies the exit method for closed areas.

MAX_STEP_DEPTH  /7\\

/épecifies the maximum allowed step depth.

MIN_STEP_DEPT{ NS’

Optionally specifies the minimum step depth allowed between the
slices.

INSIDE_TOLERANCE

The portion of the tolerance band that falls inside the surface.

OUTSIDE j@lﬁSANCE The portion of the tolerance band that falls outside the surface.

ROU _@OP_CONTROL Controls if extra slices are created between regular roughing
slices. Also defines the machining order.

ROUG\QQSCALLOP Maximum scallop height for the steps between the regular slices.

RETRACT_OPTION

Controls the number and level of retracts.

CORNER_ROUND_RADIUS

Specifies the minimum radius allowed for concave corners in high

speed machining.
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Step 1. Locate and open the cover manufacturing model.

Before creating any milling sequences, we need to locate the manufacturing model and open it
using the folder navigator. When we have located the folder for this exercise, we can set this as

our working directory, and open the manufacturing model of the cover.

1. In the navigator, select the Folder Browser tab, and browse to
c:\users\student\wildfire_mfg_330\module14, right-click, and select Make Working
Directory.

2. Open MOLD_CAVITY.MFG. \
3. Turn off any displayed datum features. ((N@

Step 2. Review the face milling NC sequence.

Before creating any volume or roughing sequences, we need to ch at NC sequences have
already been created. Using the Menu Manager, we can se ct%ce milling sequence, and

play the toolpath. Satisfied with this toolpath, we can maxe on ating more NC sequences.

1. Using the Menu Manager, select Machining > Sequence > FACE_TOP, to select the
face milling sequence for redefining. Suspe aterial removal features.

2. Play the tool path using the Screen PI@@&

3. Complete the sequence.

&@ Figure 2: Showing the previously created face milling toolpath.

Sm Cteate a volume milling NC sequence to rough out the mold cavity.
)

sing the Menu Manager, we can create a volume milling sequence. We can select the name

nd tool options, and notice that parameters and volume are already checked off. We can enter
a name for the sequence to make it easy to identify, and select the FEM_20_0 tool. We also need
to specify parameters. To save time adjusting parameters, we can retrieve a stored set of
roughing parameters that adhere to high speed machining methods. We can set
TRIM_TO_WORKPIECE to YES, to avoid air machining, and set CUTCOM to OFF for this

sequence.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 14-5



(b PTC

We decide to create a mill volume to define the volume of material to be machined. We can name
the mill volume to make it easy to identify. We decide to use the gather and Surf and Bound
options to define the volume. Configuring a mill volume using the surface and boundaries method
involves selecting a seed (or starting surface) and boundary surfaces. All surfaces within the
configured boundary are "sewn" together to form a single quilt, which is then automatically
extruded up to the retract plane to form the mill volume. We select one of the surfaces within the
cavity as our seed surface, and select the top surface of the MOLD_CAVITY.PRT model as our
boundary surface. When the mill volume is complete, we can select it in the model tree anq\bf

it to make the display clearer. K

We can play the tool path and notice that high-speed machining methods have be @n : this
is because the SCAN_TYPE parameter is set to CONSTANT _LOAD. We can mog| ’
SCAN_TYPE to SPIRAL_MAINTAIN_CUT _TYPE this reduces the number @act moves in the

tool path
We can also play the tool path in Vericut. Notice the tool still leayes a W ij@scallop height on the

sidewalls. We need to reduce the scallop height and leave g more™unifgrm thickness of material
remaining; this could be achieved by creating a semi-finishj ol path with a smaller tool.
However, we want to try to use the same tool for the roughy d semi-finishing tool paths,

enabling us to reduce machine cycle times. This cartke ieved by creating a roughing

sequence. @
1. Using the Menu Manager, create a V&@wllmg sequence.

2. Selectthe Name, and Tool ch

3. Name the sequence [RGH
4. Change the tool to th 0_0 end mill.
5. To save time sgle ieve, and Open the ROUGHING_HSM_CAVITY.MIL parameters.

6. Modifythe@RlM_  WORKPIECE parameter to YES.

)
The stored parameter file has optimum feed, speed, and depth-of-cut values to

able high speed machining.

7. Select Create Vol to create a mill volume, name it [VOL__CAVI TY].

8. Select Gather and accept the Gather Steps options, then use Surf & Bnd to configure the
gathering method.
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Note:

Configuring a mill volume using the surface and boundaries method involves
selecting a seed (or starting surface) and boundary surfaces. All surfaces within the
configured boundary are "sewn" together to form a single quilt, which is then
automatically extruded up to the retract plane to form the mill volume.

9. Move the cursor over a surface inside the mold cavity, then right-click, and select a seed
surface inside the cavity as shown in the following figure. Move the cursor over the to
surface of the mold cavity, right-click and select the surface of the mold cavity as
boundary surface as shown. x

Figure 3: Showing s@@daw surfaces selected.

10. Complete the mill volume. @

{( @ Figure 4: Showing the completed mill volume.

e
)/hen the mill volume is configured we can hide it to make the display clearer.

11. Select the mill volume in the model tree, right-click and Hide it.

12. Play the tool path using the Screen Play option. Ensure the CL data is visible.
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Figure 5: Showing the resulting tool path in default view. X ;

13. Reorient the model and create a named front view as shown in the following

h in front view.

Figure 6: Showing the resulm

Tool Path Review: o N
The SCAN_TYPE parameter is set FANT_LOAD, this means the tool path
i

is following high speed machinin gs. This involves reducing machine
direction change, providing con%? during machining, reducing load and
unload effects, and when ne(e{éés(\

sing a helical approach.

N
14. Change the SCAN_T R@peter to SPIRAL_MAINTAIN_CUT_TYPE.

15. Play the tool patiyusi Screen Play option. Ensure the CL data is visible. View the tool
path in the defauli#iewsand the named front view.

Q©&z _____________________

Figure 7: Showing the resulting tool path in front view.
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Tool Path Review:

Notice the reduction in retract moves when setting the SCAN_TYPE to
SPIRAL_MAINTAIN_CUT_TYPE.

16. Change the SCAN_TYPE parameter back to CONSTANT_LOAD.

17. Using NC Check start Vericut, then click on the Play to End icon to view the machining

simulation.

Figure 8: Showing the i0g tool path in Vericut.
YANN

x\s
reduce the scallop height ang |

However, we want to us

paths, enabling ust
a roughing sequ

Tool Path Review
Notice the tool still leaves a m'bl@op height on the side walls. We need to
more uniform thickness of material remaining;
this could be achieved by ereati semi-finishing tool path with a smaller tool.
%ame tool for the roughing and semi-finishing tool
achine cycle times. This can be achieved by creating

18. Close Vericu mmte the sequence.

Step 4. C@(;e% }uﬁhing NC sequence to rough out the mold cavity.

Using {% anager we can create a roughing sequence. We can select the name options

that parameters and window are already checked off. We can enter a name for the

anagho
e to make it easy to identify, and use the same tool as before. We can also use the
arameters from the volume milling sequence, then modify some of the parameters that are only

vailable in roughing and reroughing sequences.

We need to create a mill window to define the volume of material to be machined. We can name

the mill window fo make it easy to identify. We can use the Select, and Tangent Chain options,

and select one of the edges of the cavity geometry. With the mill window configuration complete,

we can play the tool path and notice that high-speed machine methods have been applied.

Creating Milling Sequences with Pro/ENGINEER Wildfire
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However notice the tool is still making passes at approximately five-millimeter depth increments.
We need to modify the ROUGH_SCALLOP_CONTROL parameter to create additional passes
between the roughing passes. We can set the ROUGH_SCALLOP_CONTROL to DURING and
set the ROUGH_SCALLORP to 0.4.

Replaying the tool path, notice the tool has created additional passes between the initial roughing
passes. The ROUGH_SCALLOP_CONTROL parameter enables creation of the passes either
during or after the initial roughing passes. The ROUGH_SCALLOP parameter specifies the
maximum allowable scallop height on the walls of the cavity. The resulting scallop height is

reduced leaving a more uniform thickness of material remaining. Finally, we can also ve@

toolpath in Vericut. @

1. Using the Menu Manager, create a Roughing sequence.

2. Select the Name check box. Notice the parameters and window ch u are already
selected.

3. Name the sequence [RGH_CAVI TY].

sequence.

5. Modify the following parameters. @

Table ?& Parameters
\\74

4. Select Use Prev and use the manufacturing paramet%s m the previous RGH_VOL

Manufacturing Parameter Value Section

MAX_STEP_DEPTH ya0:20in) CUT PARAM
INSIDE_TOLRENACE (T (17004 (0.002 in) CUT PARAM
OUTSIDE_TOLERANCEN 0.08 (0.003 in) CUT PARAM

6. Select Creat reate a mill window, name it VWND_CAVI TY].

7. Using the Select and Tangent Chain options select one of the edges of the cavity
geome§ hown in the following figure. Complete the mill window configuration.

Figure 9: Showing the selected edge and highlighted tangent chain of edges.
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8. Play the tool path using the Screen Play option. Ensure the CL data is visible. View the tool
path in the default view and the named front view.

S

Figure 10: Showing the resultant tool path in default

Figure 11: Showing:?er\@?tool path in front view.
O\

Tool Path Review:

Notice the tool is still makin approximately 5 millimeter (0.20 in) depth
increments. We need to m% ROUGH_SCALLOP_CONTROL parameter to

create additional passesm the roughing passes.

A\
\J
9. Modify the following mgters:
@ Table 3: Changed Parameters
N\

Mapufacturihg Parameter Value Section
R&UGH SCALLOP_CONTROL | DURING CUT OPTION
 ROUSH SCALLOP 0.4 (0.02in) CUT PARAM

@y the tool path using the Screen Play option. Ensure the CL data is visible. View the tool
path in the default view and the named front view.

Figure 12: Showing the resultant tool path in front view.
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11. Using NC Check start Vericut, then click on the Play to End icon to view the machining
simulation.

Figure 13: Showing the resulting tool path in Vericut. O

P

Tool Path Review:

Notice the tool has created additional passes between theNgitial rdughing passes.
The ROUGH_SCALLOP_CONTROL parameter enables creatiof of the passes
either during or after the initial roughing passes. The GH_SCALLOP parameter
specifies the maximum allowable scallop height o of the cavity. The
resulting scallop height is now reduced Ieavin@ niform thickness of material

remaining.

12. Close Vericut, and complete the sequg@

13. Save the manufacturing model.

14. Close all windows and erase a@rﬁ ents from memory.

Note:

The next logical st Qnachining process would be to finish the mold cavity
with a series gt's illing sequences; this is not done in this exercise as we
have cover % milling in an earlier exercise.

&
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Summary

After successfully completing this module, you should know how to:

Describe high speed machining strategies.
Describe the roughing and reroughing process.

Describe the key roughing and reroughing features.
Describe the key roughing and reroughing manufacturing parameters.
Create mill volumes and mill windows. \

Create volume and roughing sequences. @@

%@

>
Q
O
N
B
S
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Module

Post-Processing CL Data

\‘
Introduction @

Post-processing is the final stage in the manufacturi rocess. When operations
have been completed you can create ASCII for! t@ta files for operations.
CL data files can then be post-processed i %ﬁ machine control data
(MCD) files using a post-processor. It iscdinpo 0 understand that changing
NC sequences means you need to&a CL data file for the operation and

post-process this file again to produse.an updated MCD file.

Objectives @

After completing this m @will be able to:
e Describe the O&N@sing method.
+ Create C %@s.

» CreatgMCD-es using a post-processor.

®©

Page 15-1



Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 15: Post-Processing CL Data

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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e B o [P
Lectures | g3 cenees Re-Rouhing Tootpath Falare. |1 50 85 onts
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N N L
creating [T creating i
Holemaking |-~ Roughing and Toglozt‘hc::ﬁnre
Sequences Re-Roughing "
Sequences
Creating [ Creating Post-Processing Correctin
Labs Holemaking [ | Roughing and CL Data Toolpath Fainre [
Sequences Re-Roughing
T Sequences
Creating Drill
Groups and
Holemaking
Sequences
(Challenge)

Duration %

Lecture: 10 mins
Demos (1) : 15 mins

Labs (1) : 35 mins @\
Total: 1 hr 00 mins @
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Objectives

After completing this module, you should know how to:
® Describe the post-processing method.
® Create CL Data files.

® Create MCD files using a post-processor.

@\%

Overview %_‘

Post-processing is the final stage in the manufacturing process. en operations have been
completed you can create ASCII format CL data files forgperdtions. CL data files can then be
post-processed into specific machine control data ( D) files using a post-processor. It is
important to understand that changing NC sequen ans you need to recreate the CL data
file for the operation and post-process this flle@ roduce an updated MCD file.

After completing this module, you will be a

* Describe the post-processing met@

* Create CL Data files.
» Create MCD files using a po SSor.

®>
&@6
Q®
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Post-Processing Method

©® Complete Operation

o Complete NC Sequences

: 2

® Create CL data files

+ ASCII format
MACHIN / UNCX01, 1
o filename.ncl $$-> CUTCOM_GEOMETRY_TYPE / OUTPUT_ON_CENTER
: UNITS / MM
LOADTL / 5, OSETNO, 5
$4-> CUTTER / 50.000000
$§-> cs¥s / 1. , 0. , 0.
® Post-Process CL Data - oL ;8
. SPINDL / REM, 500.000000, CLW
o Create MCD files RRPID
ofilename.tap GoTo / -25. , -108. , 50.
© Changes to NC sequences us 671
N10( / COVER)
e Recreate CL data files and MCD files N15 GO G17 G99
N20 G20 G94
N25 GO G49
N30 TS5 MO6
N35 S500 MO3
N40 GO G43 Z50. H5

Post-Processing Method %
* You first need to complete the operation by creating all n ry NC sequences.

» When the operation is complete you can create CL data-files, these are ASCII format files.
» The default filename format is filename.ncl
machine control data (MCD) files.
» The default filename format is filename:
* You have an option to create th@& MCD files simultaneously.

N

» Any changes to NC sequenc s you must re-create the CL data files and MCD files.

N

* You can then post-process CL data files into

Q)



e . VrTC

Post-Processing Configuration Options

Configuration Options
® ncpost_type

e gpost (default)
Use standard set of post-processors provided by Intercim
Posts-processors can be modified/developed

e ncpost
Use the Pro/NCPOST post-processors

® Other post-processors can be used

® gpostpp_dir
« Specify directory for gpost post-processors @

® pro_mf_cl_dir

« Specify location to store CL data files

Configuration Options %
Each Pro/NC module includes a standard set of NC pgst-p ors that can be used
directly or modified using an optional module. You canxconirol which post-processing
module to use by setting the configuration option\acpost—type. The values are:

* gpost (default)—use the G-Post™ post-proces vided by Intercim Corporation.
* ncpost—use the Pro/NCPOST post-proce@ vided by ICAM.

be used

* gpostpp-_dir @

* Specify the directory f t post-processors

» Other post-processors capable of r@@PT (automatically programmed tools) can also

» pro_mf_cl_dir
» Specify locati store CL data files

&
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating and Post-Processing CL Data Files

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

QO

Demonstration: Creating and Post-Processing CL Data Fi es@

Duration: 15 minutes

Scenatrio @‘\

* Throughout this course, the exercise scenafios\are the same as the demo scenarios.

* This has been done to build consistgnc@ en demos and lab exercises so as to enable
“Tell me—Show me—Let me do.” X

Method
Use the script in the instructo&@e, use the same models as in the exercises.

Exercises (1)
Duration: 35 minutés

Once the demo is ¢ ete the students should use the steps in the training guide to complete
the exercises.

O
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Summary

After successfully completing this module, you should know how to:
© Describe the post-processing method.
® Create CL Data files.

© Create MCD files using a post-processor.

QO

Summary %

After successfully completing this module, you should kn to:
* Describe the post-processing method.
 Create CL Data files.

* Create MCD files using a post-processor. @

@2§©
<
W
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Exercise 1: Creating and Post-Processing CL Data Files

Module 15 Lab Exercises

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

» Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2002380 or later.

» Download and install the class fileswi | df i re_mi I | = .tar. gz as described in

the classroom setup notes.

Introduction @p\
In this demonstration, you open the manufa@% odel for the cover and create CL data files
and MCD files for both operations. You @e ove the trajectory milling NC sequence from

<&

operation 020, and re-create the and MCD file. It is important to understand that
changing NC sequences mean: to recreate the CL data file for the operation and post-
process this file again to p@ pdated MCD file.

Objectives

After succes IIIeting this exercise, you will know how to:

e Creat files.

* Cggate MCD files using a post-processor.

S rio

ou are ready to create MCD files for both operations in the aluminum cover. You open the

anufacturing model for the cover and create CL data files and MCD files for both operations. It
is decided that the last NC sequence in operation op020 is not required, as the grooves in the top
of the model will be machined manually. You remove the trajectory milling NC sequence from
operation op020, and re-create the CL data file and MCD file for operation op020.
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Before creating any CL data files, we need to locate the manufacturing model and open it using

Step 1. Locate and open the cover manufacturing model.

the folder navigator. When we have located the folder for this exercise, we can set this as our
working directory, and open the manufacturing model of the cover. Before post-processing any

files we can load a configuration file to ensure that we use the correct post-processor located in

the posts directory.

1. In the navigator, select the Folder Browser tab, and browse to
c:\users\student\wildfire_mfg_330\module15, right-click, and select Make WON
Directory.

2. Open COVER.MFG. @

3. Turn off any displayed datum features. @

4. Before post-processing any files, load a configuration file. Click To ons, in the
Options dialog box, click the Open icon, select config.pro and g/ Apply and Close
the Options dialog box.

Note:
Loading the configuration file sets the gpostpp_dir @m \posts, this specifies the
directory for post-processors. There is a fadalx processor in this directory.

Step 2. Create a CL data file and MCD file $or @on op010. Review the CL data file in
Vericut. o~

We can create a CL data file for opera@%, at the same time we can create an MCD file,
this enables us to create and post—@ he CL data file at the same time. We can select the

UNCX01.99 post-processor; asthis e fadal-vmc post. We have now created a CL data file
named op010.ncl, and an le)hamed op010.tap.We can open and review these files in a
text editor. Notice th tatements in the CL data file are transferred into the MCD file.

We can now start nd review the CL data file.

1. Using u Manager, select CL Data > Output > Operation > OP010 > File. Select
the’'M le check box, and complete the file output. Click the OK button to create a CL
ile Tor operation OP010.

2. Accept the Verbose and Trace options, and select the UNCX01.P99 post-processor, when
prompted type any number for the program number.

3. Close the information window, and return to the Manufacture menu.

Note:

You have now created a CL data file, named op010.ncl, and an MCD file named
op010.tap.
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4. In the navigator, select the Folder Browser tab, click the module15 folder to view the

contents in the browser.

5. In the Browser, select the op010.tap file, right-click and select Open to view the contents of
the file in the browser, as shown in the following figure.

Figure 1: Showing content

to viewing the files in the module15
01234 > '@Q
Nl {PRO/NC TOO OP010)

6. Click the Back icon at the top of the browser
folder, then minimize the browser window.

%

{PARTNO :

N3 GO0 GE0 "
N4{DATE >| —DEC Oz 14:46:30)
N5 BLE SUMMARY)

QFFSET NO TOOL COMMENT)

N6 (TOO TOOL ID
N CTRDRILL 04 1
N DRILL 06 O 3

N 5 CSINK 12 5
1 9 FEM 06 0
( 15 FEM 25 0

12§ 17 SH | I'-'IILL 50 0

N13 (NC 3EQUENCE NAME

& N14 390 580 G40 G17 <O
N15 T17 Mo

N1la 51185 M3

N17 G0 GO0 X-30. ¥1Z.5

N18 =43 H17 Z240. M8

E‘RCE BOTTCM

O meD.I_st - 262 bytes

[ op010.mbx BG4 hytes

EE;_, op010.ncl 134 KB

” .- ﬁ

[ s::rew_hs \
T vise.asm  OPen in New Window

(1 vise_base oawe Target As..,

[O1 vise_clan  Print Target @
1 vise_clam an

[0 vize_scre &

£ materials 0Py @7

L1 posts Copy Shortou %

f browser.

!

J

]

9}
15;
17)
]

Figure 2: Showing start of op010.tap file.

Note:

Notice the PPRINT statements in the CL data file are transferred into the MCD file.

Creating Milling Sequences with Pro/ENGINEER Wildfire
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7. Using the Menu Manager, select CL Data > NC Check > CL File, and Open the
op010.ncl file, then select Done to start Vericut. (You may need to wait a few moments for
Vericut to start).

Note:

Selecting the NC Check option in the CL Data menu starts Vericut. This will open a
separate Vericut window to perform the machining simulation.

8. In the Vericut window, click on the Setup Motion icon, and in the Motion dialog box drag the
animation speed slider to the left, (this will reduce the speed of the animation). Then clo
Motion dialog box.

9. Click on the View Toolpath File icon to see the CL data file during the simulat@@k

on the Play to End icon to view the machining simulation.

&
Figure 3: Show afile op010.ncl in Vericut.

10. Close Vericut when finished, and r he Manufacture menu.

=~
Step 3. Activate operation op020. K\ 9)

Note: \\\))b

Operation o@s ted to ensure the CL data file is displayed correctly in
Vericut.

1. Using theﬂ%u Manager, select Mfg Setup > Operation, in the Operation dialog box
acliva r ion op020. Close the dialog box, and return to the Manufacture menu.

2. e view to the named view OP020-TRI.

Step 4. Create a CL data file and MCD file for operation op020. Review the CL data file in
Vericut.

We can create a CL data file for operation op020, at the same time we can create an MCD file,
this enables us to create and post-process the CL data file at the same time. We can select the
UNCX01.99 post-processor; as this is the fadal-vmc post. We have now created a CL data file
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named op020.ncl, and an MCD file named op020.tap.We can open and review these files in a

text editor.

We can now start Vericut and review the CL data file.

1. Using the Menu Manager, select CL Data > Output > Operation > OP020 > File. Select
the MCD File check box, and complete the file output. Click the OK button to create a CL
data file for operation OP020.

2. Accept the Verbose and Trace options, and select the UNCX01.P99 post-prec when
prompted type any number for the program number. X

3. Close the information window, and return to the Manufacture menu. f\\

Note: \\\_}

You have now created a CL data file, named op020.ncl, and D file named
op020.tap.

4. Using the Menu Manager, select CL Data > NC Check LE)/gile, and Open the
op020.ncl file, then select Done to start Vericu% eed to wait a few moments for

Vericut to start).
thata file during the simulation. Then click

in S imulation.

5. Click on the View Toolpath File icon to se
on the Play to End icon to view the mac

& Figure 4: Showing CL data file 0op020.ncl in Vericut.

6.e Vericut when finished, and return to the Manufacture menu.

tep 5. Suppress the last NC sequence named FIN_GROOVE, in operation op020. Recreate the
CL data and MCD files, and review the CL data file in Vericut.

We can create a CL data file for operation op020, at the same time we can create an MCD file,
this enables us to create and post-process the CL data file at the same time. We can select the
UNCX01.99 post-processor; as this is the fadal-vmc post. We have now created a CL data file
named op020.ncl, and an MCD file named op020.tap. We can open and review these files in a

text editor.
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We can now start Vericut and review the CL data file. Notice how the CL data file has updated

and no longer machines the groove in the top of the model.

1. In the model tree, select the FIN_GROOVE sequence, right-click and Suppress it, click
OK in the Suppress window.

2. Using the Menu Manager, select CL Data > Output > Operation > OP020 > File. Select
the MCD File check box, and complete the file output. Click the OK button to create a CL
data file for operation OP020.

3. Accept the Verbose and Trace options, and select the UNCX01.P99 post-proces@m

prompted type any number for the program number.

4. Close the information window, and return to the Manufacture menu.

5. Using the Menu Manager, select CL Data > NC Check > CL File, an en the
op020.ncl file, then select Done to start Vericut.

6. Click on the Play to End icon to view the machining simulation.

Note:
Notice how th ata file has updated and no longer machines the groove in the

top of tl@nodel.

7. se t when finished, and return to the Manufacture menu.
8. S the manufacturing model.

9. Close all windows and erase all components from memory.
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Summary

After successfully completing this module, you should know how to:

» Describe the post-processing method.
* Create CL Data files.

e Create MCD files using a post-processor.
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Module

Correcting Toolpath Failure

\‘
Introduction @

NC sequences can sometimes fail after they have created; this is normally
due to sequence references changing or being @For example, a design
engineer may change the diameter of a hol %hape of a pocket on a

design model. In most cases, NC sequences Wil ‘update automatically to reflect
these changes, however if the original de ferences have been removed or

drastically changed in size or shape;
important to understand why NC

correct failed NC sequence@

e associated NC sequence may fail. It is
es fail, and how to investigate and

Objectives

After completing ule, you will be able to:

« Describe @ons for NC sequence failure.

* Desgc w to investigate and correct failed NC sequences.
. @ate and correct failed NC sequences.
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Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 16: Correcting Toolpath Failure

& PTC@Q

Instructor Preparation %
Before teaching Creating Milling Sequences with Pro/ENGIN@Idﬁre, you must have read and

thoroughly understood the following materials: \

* General Information

» Review Pro/ENGINEER Wildfire primer sit@@mweb.ptc.comlprimer/

* Pro/E Wildfire Documentation o @
* Review Pro/ENGINEER Wildfire % tion in Windmill, located in

/GS Training Materials/Domain Knowl ate/ProENGINEER/Core Concepts

* Pro/E Wildfire Milling

* Review Pro/ENGI

/GS Ed Srvcs Operations/
/T979-330-Instructop Ki

@@;re Milling training materials in Windmill, located in

ation Library/Instructor Materials/Instructor Kits/EN

* Required Ski
» Comptetionof Pro/E Wildfire Foundation or equivalent Pro/E skills
* K0 n of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent Pro/E

+ Ability to install and configure Pro/E Wildfire
Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Four
Creating Creating ProlFICIENCY
: Roughing and Post-Processing _|  Correcting Evaluator
Lectures ';‘;";:':;‘f ¥ Re-Roughing = CL Data Toolpath Failure Daily
a |- Sequences [~ Assessments
L L L
Creating Creating Post-Processing .
{ Holemaking [ Roughingand [~  CLData [~ Toz‘"a";c::ﬁm
Seqeunces Re-Roughing P
Sequences
[iabs | uopesting - [ croating - i Correctin
Cabs) Holemaking | ____{ Roughing and Toolpath Faiture
Seqeunces Re-Roughing
T Sequences
M
Creating Drill
Groups and
Holemaking
Seqeunces
(Challenge)

Duration %

Lecture: 15 mins
* Demos : 25 mins

Labs : 50 mins @\

Total: 1 hr 30mins
o\(: :)

o
@@
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Objectives

After completing this module, you should know how to:
® Describe the reasons for NC sequence failure.
® Describe how to investigate and correct failed NC sequences.

© Investigate and correct failed NC sequences.

.'%ormally due to sequence

Overview
NC sequences can sometimes fail after they have been created;
references changing or being removed. For example a desig er may change the diameter of a
hole, or the shape of a pocket on a design model. In mosgcase sequences will update
automatically to reflect these changes, however if the original design references have been removed or
drastically changed in size or shape the associated N ce may fail. It is important to understand

why NC sequences fail, and how to investigate and@ ailed NC sequences.

<
» Describe the reasons for NC sequence %

» Describe how to investigate and cor
* Investigate and correct failed NC ces

Q@

After completing this module, you will be able @

d NC sequences.

Q)
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Reasons for NC Sequence Failure

Changes to Reference Models

® Removed References

©® Examples
e Facing or Profiling Surfaces
e Holes
o Mill Window Outlines

o Mill Volume Surfaces

©® Changed References
« Changes in geometry shape and size @

©® Pro/ENGINEER always attempts to update NC sequences

Reasons for NC Sequence Failure %
a

Changes to reference models can cause NC sequences to falil, in
updates automatically.

If references are completely removed from the model, thé&w erences will need to be specified, for

example:

* Facing or Profiling surfaces @‘
* Holes for drilling @

Mill window outlines @

. O
Mill Volume surfaces

ses the NC sequence

Changed references can sometlm%e NC sequences to fail, but the changes to geometry
shape and size normally need rem

Pro/ENGINEER always atte update NC sequences in these situations. NC sequences will
only fail if updating is Rt fossible

&
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Correcting NC Sequences

Method
Investigate reasons for failure
Update failed references
Check updated NC sequence

Resolve Mode
Entered after regenerating sequence fails
Enables checking and correcting failed sequences

Resolve Mode Tools

e Undo Changes
Not always possible with design changes
o Investigate

Check reasons for failure

o Fix Model

Change any feature in the model

© Quick Fix

Change the failed feature (NC sequence) <>
Select or create new references

Slide 5 ©2002

@

Correcting NC Sequences %
» The method for correcting NC sequences, involves three step

* Investigate the reasons for the NC sequence to fail, detexmine the missing or failed references,

e.g. missing surfaces, holes, or edges.

» Update the failed references, e.g. select new fi ‘;
holemaking.

» Check the updated NC sequence peﬁorm@}c

xtgce for profile milling, or hole axis for

y, usually by playing the toolpath.

&
* When an NC sequence fails you automati @nter resolve mode.
i nd correcting failed sequences, the main tools are:

ges since the last regeneration, not always possible if the
en saved in the changed state.
* Investigate: check the r or the failure, usually missing references

re in the model, for example you may decide to change reference
model features,in to correct the problem.

* Quick Fix: ch@n ailed feature (NC sequence), change any of the references in the failed
sequence, fo le select new geometry references, update NC sequence parameters, or

change tools.

@
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Investigating and Correcting Failed NC Sequences

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Investigating and Correcting Failed NC Sequence%

Duration: 25 minutes

Scenario @\
» Throughout this course, the exercise scenarios tRe’same as the demo scenarios.
» This has been done to build consistency betwesn d€mos and lab exercises so as to enable “Tell

me—Show me—Let me do.” o @
Method 3@
Use the script in the instructors gui ,e same models as in the exercises.
Exercise @
Duration: 50 minutes

Once the demo is cogrip students should use the steps in the training guide to complete the
exercises.

&
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Daily Skill Checks

Evaluate your progress:
® Achieve the course objectives.
® Use Pro/FICIENCY assessment questions.
® Apply Precision Learning.

QO

Precision Learning %e
* Learn: by listening to lectures, watching demos, and completi Xercises.
» Assess: your progress with Pro/FICIENCY.

* Improve: The next day the instructor reviews the exa esults of the group and reviews those
topics that received the fewest correct answers.

Getting Started @
» Before lunch on the first day of class, S@t customer accounts.

* When the customers are returning fr fer them to the new Appendix.
* Have them take the sample exam
* Review the results of the grou @ p’as an icebreaker.

Daily Tests @
Description: For each 00\.@ w 10 question exams based upon the topics covered each day.

How to use it:

* Use the cust@gmer atcounts already setup for the sample exam.

* Atthe e %@h day the customers take the 10 question exam relating to that days’ topics.
* Theiie @uing, review the results of the group.

* Re those topics with the class that obtained the most incorrect answers.
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Summary

After successfully completing this module, you should know how to:
© Describe the reasons for NC sequence failure.
© Describe how to investigate and correct failed NC sequences.

© Investigate and correct failed NC sequences.

QO

Summary %

After successfully completing this module, you should know how to;
» Describe the reasons for NC sequence failure.
» Describe how to investigate and correct failed NC es.

* Investigate and correct failed NC sequences. @
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Exercise 1: Investigating and Correcting Failed NC
Sequences

Module 16 Lab Exercises

Demonstration Instructions

Preparation \
Complete the following tasks before running this demo for customers: @

e Practice running the demo so you can easily complete it. @

* Check for and review the errata sheet for this course.

» Use Pro/ENGINEER Wildfire build code 2003051 or later. @

» Download and install the class fileswi | dfire_m | | i % t ar. gz as described in

the classroom setup notes.

Introduction @\

In this demonstration, you open the updated e model of the cover and review the design

changes. You then open the manufacturi @of the cover, and for each feature that fails you

investigate, identify and then updaté> e@ng references. It is important to understand why NC
- correct failed NC sequences.

sequences fail, and how to investit

Objectives

After successfully.corpl this exercise, you will know how to:
* Investig A, ect failed NC sequences.

Scenario

A nurﬁé%of design changes occur on the aluminum cover, causing NC sequences to fail in the
m ctring model of the cover. You open the updated reference model of the cover and

P he design changes. You then open the manufacturing model of the cover, and for each
eature that fails you investigate, identify and then update the missing references.
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Figure 2: Showing the top view of o@nd modified cover model.
A\

Step 1. Check the design changes in the cg\(e\rw nce model.

Before checking the design changes, wg locate the reference model and open it using
the folder navigator. When we have e folder for this exercise, we can set this as our

working directory, and open the tefexenge model of the cover. Notice on the bottom of the cover

1

can check that the si.

the position of the drilled keleésshasheen changed and the ribs have been removed. However, we
I ed holes has not changed. Notice on the top of the cover the

original cut outs h&¥e peenremoved and replaced by new cut outs. In both cases, the design

engineer has ﬁe original features and replaced them with new features.

1. Inthe ator, select the Folder Browser tab, and browse to
Au udent\wildfire_mfg_330\module16, right-click, and select Make Working
ctory.

2. Open COVER.PRT. Turn off any displayed datum features.

3. Change the view to the named view BOTTOM-TRI. Observe the design changes to the
model. Check the size of the repositioned holes.
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Figure 3: Showing hole size @\
4. Change the view to the default view. Observe the design changes t d .

5. Close the window.
>

([

\/
Note: \g
Notice on the bottom of the cover the position of the d es has been changed
and the ribs have been removed. Notice on the topside 0f the cover the original cut-

outs have been removed and replaced by ney cut-o both cases, the design
engineer has deleted the original features a%{aced them with new features.
N>

Step 2. Open the manufacturing model and @Q&tﬁe failed features in operation op010.

Before opening the cover manufacturin@e should be aware that the model is likely to fail
&
regeneration, and we will need to C ailed features.

Opening the manufacturing m an first add the status column to the model tree. This

provides information on whigh featires have regenerated successfully in the manufacturing
@the mill window feature named WND_RGH_BOT has failed

regeneration; als jluré diagnostics window states that feature references are missing. We

model. Notice in the m

can also hideth ssembly to make the viewing of both sides of the model easier.

We can inv
refere%nformation window. We can unhide the failed mill window feature in the model tree and

e references for the mill window. We can select the inner set of tangent chain edges at

the reasons for the feature failing and list the failed references in the

re
of the pocket, and preview the result. When we complete the mill window configuration,

egeneration of the model continues automatically.

Notice in the model tree the holemaking NC sequence named CTR_DRILL has failed
regeneration; this is the first of three holemaking features. We can use the Resolve Feature menu
options to investigate and correct this problem by redefining the references of the failed feature.
We can also check to see if the correct tool is being used, and then using the Hole Set dialog box
we can use the Diameter tab and select the 6.0 diameter holes, this automatically selects all the

6.0-millimeter diameter holes on the model. As this is a center drilling sequence we can specify
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the depth options as blind and tip and specify a depth of 5.0. By playing the tool path and making
the CL data visible, we can see the tool drills the four holes to a depth of 5.0 as specified. When

we complete the holemaking sequence, regeneration of the model continues automatically.

Notice in the model tree, the holemaking NC sequence named DRILL 06 has now failed
regeneration. We can correct this problem by redefining the references of the failed feature. We
can also check to see if the correct tool is being used, and then using the Hole Set dialog box we
can use the Use Prev option and select the first hole set. As this is a standard drilling sequence
we can specify the depth options as auto and tip, this completes the hole set configuration. K
playing the tool path and making the CL data visible we can see the tool drills the four h

automatically calculating the correct depth. @
Notice the next countersink holemaking sequence does not fail regeneration, this i use the
sequence was configured to automatically drill all chamfered holes on the

1. Open COVER.MFG. %

Note: \\\\}

The manufacturing model has failed regeneration d e design changes. You
have been placed immediately into the Resolve Fel t nu. A Failure Diagnostics
window also provides information about the fa| e.

2. Move the position of the Failure Diagnoglcs@ to make the model tree clearly visible.

3. Inthe model tree, click Settings > T% umns. In the Model Tree Columns dialog box,
select the Status option and mov@? display column. Close the dialog box.
Fegenerated

|d131EIEE [FACE_BO"|Regenerated
CE_BOTTOM [OF010]  |Regenerated

atenal Femowval id 131097 [1| Regenerated
Sun‘au:e id 131135 [FROF_SLI| Regenerated
Fegenerated

@U 2 PRDF BOTTOM [OFDD] |Regenerated
g Material Removal id 131230 [£| Regenerated

©& # InsertHere
B WND_RGH_BOT [window] | Failed
+-g¥ 3 RGH_BOTTOM [OPO10] Unregenerated
g Material Removal id 131529 [2 Unregenerated

Figure 4: Showing the model tree with regeneration status column added.

4. Adjust the width of the model tree columns to make the feature names and regeneration
status clearly visible. Note the failed feature is the mill window named WND_RGH_BOT.
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Note:

Displaying the status column in the model tree provides information on which
features have regenerated successfully in the COVER.MFG manufacturing model.
Notice in the model tree the mill window feature named WND_RGH_BOT has failed
regeneration, also the failure diagnostics window states that feature references are
missing. The Resolve Feature menu options enable investigation and correction of

failed features.

5. Read and minimize the Failure Diagnostics window. Change the view to OP010-TRI

display.

6. In the model tree, select the vise assembly, OP010_INST.ASM, right-click am@ it from

Note:

Hiding the vise assembly makes it easier to view both sides o}/ﬂ;g

7. Using the Menu Manager, €

,
€

anufacturing model in resolve mode.

vestigate > Show Ref to show the references of the

failed feature.
C 4
N/
Note:
Notice in t ,\ ce information window the missing references for the mill

in the COVER.PRT model.

- Current Feature

[WIND_RGH_BOT (COVERASM) [¥]

- 8

& - Current Entity
Q [ Al entities

Parents of Current Feature

Children of Current Festure

2

of) o) o) of ool o) o

- COVERPRT (COVE

<Missing Ref> id £
<Mizsing Ref> id
<Missing Ref> id
<Missing Ref> id

<tissing Fef> id £
<tdissing Fef> id £

<Missing Pef> id £

Children List
- COWVER.ASM
&7 3 RGH_BOTT

Figure 6: Showing a listing of missing references.

Creating Milling Sequences with Pro/ENGINEER Wildfire
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9. Select the WND_RGH_BOT mill window feature in the model tree, right-click and Unhide it.

8. Close the Reference Information window.

10. Using the Menu Manager, select Quick Fix > Redefine, and Suspend All child features.

11. Define the missing window references. Click the Window element and Define in the dialog
box. Using the Select and Tangent Chain options, select the inner chain at the top of the

pocket, then complete the selection.

%@

Figure 7: Showing the selected edge and highlig&an chain of edges.

12. Click the Preview button in the mill window. %,)

Note: @

Notice that the mill window outline hag om%o’ correctly and is created on the
retract plane. Once you complete the il Window configuration regeneration of the
model continues automatically.

oy
13. Complete the mill window conf@aﬂ' /

Step 3. Correct the failed fe%ﬁ%\(ﬁoﬁeration op020.

)
Notice in the model tree, Sequence to fail is the surface milling sequence named
FIN_CUT_OUTS irkoperatich’op020. This is because the reference surfaces for this NC
sequence have bee ved. First we need to change to the op020-tri view. We can correct this

problem by reﬁ%ing the references of the failed feature. Firstly, we can also check to see if the
correg oi g used. Then for the surfaces to be machined, select the two new cut out
nthe reference model, we also need to adjust the cut direction for each surface to

ensureXis pointing in the desired direction. We can play the tool path and notice it has updated
correctly. When we complete this NC sequence, notice that all the features now regenerate

successfully.

You can continue by reviewing the other NC sequences to see if they need any adjustment.
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Note:

Notice in the model tree, the next sequence to fail is the surface milling sequence
named FIN_CUT_OUTS in operation op020. This is because the reference surfaces
for this NC sequence have been removed.

1. Read the information in the Failure Diagnostics window, and then minimize the window.

- Reference surfaces are no longer available.

- Feature references are missing.

Figure 8: Showing information in the Failure Diagnostics wind

2. Change the view to the named view OP020-TRI.

Figure @.fg&mg the new cut outs in the top of the model.
3. Select Quick Fix R@ne, and select the References check box.
c

4. Selectthe To ox; note the surfaces and define cut check box are already selected.

0 tool is being used, and close the Tool Setup dialog box.

6. Acceptt odel option, and for the surfaces to be machined, select the two new cut out
sﬁ%es on the reference model, shown in the following figure.

7.e Cut Definition dialog box, select the first surface in the list and toggle the Direction of
ut icon as shown. Select the second surface in the list and again toggle the Direction of Cut
icon as shown. Complete the cut definition.
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Figure 10: Showing selected surfaces and cut direction. @Q

8. Play the tool path using the Screen Play option. Ensure the CL data is yisj

out surface being machined.

Figure 11: Showing®t

9. Complete the sequence, and se/l%o exit the Resolve Feature menu.
Note: w

Notice all the featug\ enerate successfully.
10. Continue by r checklng the other NC sequences.
11. Save the ufa ing model.

12. Close@ ws and erase all components from memory.

Page 16-10 Correcting Toolpath Failure



Summary

After successfully completing this module, you should know how to:

» Describe the reasons for NC sequence failure.
» Describe how to investigate and correct failed NC sequences.

» Investigate and correct failed NC sequences.

Creating Milling Sequences with Pro/ENGINEER Wildfire
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Module

17

Confiquring the Manufacturing Environment

\‘
Introduction @

There are many manufacturing configuration optio t enable you to
customize your working environment. For exam @an configure tool
libraries and directories for workcells and @ing parameters, this enables
you to store and then easily retrieve andruse items. Understanding
manufacturing configuration option&i s is therefore an essential

element of the manufacturing process, and enables you to create a more efficient

Objectives @
After completing thf% you will be able to:

» Describe J ing configuration options.
+ Creat ’%@tion options to store tools, material files, workcells,

par; erjjiles, and stock billets.

=
©
K

working environment.

taoconfiguration options to enhance your working environment.
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Pro/ENGINEER Wildfire

Module 17: Configuring the Manufacturing Environment

& PTC@Q

Instructor Preparation %
Before teaching Creating Milling Sequences with Pro/ENGIN@Idﬁre, you must have read and

thoroughly understood the following materials: \

* General Information

» Review Pro/ENGINEER Wildfire primer sit@@mweb.ptc.comlprimer/

* Pro/E Wildfire Documentation o @
* Review Pro/ENGINEER Wildfire % tion in Windmill, located in

/GS Training Materials/Domain Knowl ate/ProENGINEER/Core Concepts

* Pro/E Wildfire Milling

* Review Pro/ENGI

/GS Ed Srvcs Operations/
/T979-330-Instructop Ki

@@;re Milling training materials in Windmill, located in

ation Library/Instructor Materials/Instructor Kits/EN

* Required Ski
» Comptetionof Pro/E Wildfire Foundation or equivalent Pro/E skills
* K0 n of Creating Milling Sequences with Pro/ENGINEER Wildfire, or equivalent Pro/E

+ Ability to install and configure Pro/E Wildfire
Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Five

Using Index "
- Automating ProlFICIENCY
M:'::]'::t'g == Du‘[:l::la.(‘ln.;:c- ==  Workflow with  [={-» i
ld Sequences | Mapkeys || | Assessments
T T
N L
Configuring the Checking and Using Index Automating
Manufacturing Measuring [ Tablesand [ | GHEREnS
Environment Geometry Duplicating NC- Mapkeys
Sequences
Manufacturing Model
and Manufacturing
Operation for the Casing
Configuring the Checkingand |77 Using Index [ Automating [
m Manufacturing Measuring Tables and Workflow with
Environment Geometry Duplicating NC- Mapkeys
T

Manufacturing Model
and Manufacturing
Operation for the Casing

T
NG

Machining the
Casing (Challenge)

Duration

Lecture: 10 mins
* Demos : 20 mins
Labs : 45 mins
Total: 1 hr 15mins

@@
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Objectives

After successfully completing this module, you should know how to:
© Describe manufacturing configuration options.
® Create configuration options for:
e Tools
o Material files
o Workcells
o Parameter files
o Stock billets

® Create configuration options to enhance the working environment.

QO

Overview
There are many manufacturing configuration options that enable ustomize your working
environment. For example you can configure tools libraries, and directories for workcells and

manufacturing parameters, this enables you to store andhen easify retrieve and use these items.
Understanding manufacturing configuration options and methods is therefore an essential element of
the manufacturing process, and enables you to create fficient working environment.

After completing this module, you will be able tg: @
» Describe manufacturing configuration @pti

+ Create configuration options to store aterial files, workcells, parameter files, and stock
billets.

» Create configuration options to @@ the working environment.

Q)
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Manufacturing Configuration

Customize Working Environment
® More Efficient

Velue |tatus [Description

Di\Pro_E\ProE_Wildfire\Wildfire_Mig),
Configuration Process 7 dLanow_scale v #  Encblesyouto contol

% opostpp_dir \migdatalgpost_pp *
® Create Configuration File | # nomd_bilet stook e path | yrigst

7

Specifles the direciory
algtock_parsinomdl_hiletprt % Sets path for storage

{_param_ neters |- ISzt the defeult directd
® Read Configuration File % pro_nt_fprm_dit mfstalioolsimetic_ools % Setsthe defeultdiecto
. & pro_mi_warkeel_dir \migiatatworkeells #  Setsthe defaultdirecto
« config.pro
< 23
Optian Waluer
‘pvu,mf,pavam,dn ‘ ‘

o Paths to Directories

® Manufacturing Configuration Options @\

o Working Environment Options

Manufacturing Configuration

» Manufacturing configuration options enable you to create a c %d and more efficient working
environment.

» The configuration process involves creating and re : configuration file named config.pro.

The manufacturing configuration options can be@w into two broad categories:
I

+ Options that specify paths to directories, .@ e a tools directory.

» Options that change the working envi nt-for example to specify the number of decimal places
for X, Y, Z co-ordinates in CL data fj ‘ﬁ&

©©
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Configuration Options

Paths to Directories
® pro_mf_tprm_dir
o Tools and material files
® pro_mf_param_dir
o Parameter files
® pro_mf_workcell_dir
o Workcells
® pro_mf_cl_dir
o CL data
® gpostpp_dir
o Gpost post-processors

® ncmdl_billet_stock_part_path

® ncmdl_bar_stock_part_path
o Billet and bar stock

fgdata

(1 gpost_pp
221 parameters
-0 Jflt_himaking
D Inch
1 mefric
-0 lt_milling
L1 inch
01 metric
20 stock_parts
=7 tools
=00 inch_tools
@01 materials
=21 melric_tools
=03 materials
-0 workeells

QO

Configuration Options

The main set of configuration options relating to paths to directo

provides the most commonly used options.

Pro_mf_tprm_dir: specifies the default directory to st
Pro_mf_param_dir: specifies the default directory t
Pro_mf_workcell_dir: specifies the default direc
Pro_mf _cl_dir: specifies the default directory t

Gpostpp_dir: specifies the directory coptai

%s list is not comprehensive but

m s

anufacturing parameter files

%re workcell files

CL datafiles
post-processor files to be used by GPOST

ncmdl_billet (and bar)_stock_part_pa@ es path to user defined default billet and bar stock

‘0
©©
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Configuration Options

Working Environment Options
©® mfg_workpiece_transparency
« Specifies workpiece transparency

® cl_arrow_scale

« Specifies size of toolpath arrow
® ncpost_type

e gpost/ncpost
® nccheck_type

o Vericut/NCCheck

©® mfg_xyz_num_digits

® mfg_ijk_num_digits
© store_tool_path_file

« Specifies if toolpath information is stored

Configuration Options %
The main set of configuration options relating to the working en nt, this list is not
comprehensive but provides the most commonly used optidas.

. _mfg_workpiece_transparency: specifies workpiece tr%re from 0.1 to 1(transparent), default

is 0.5
 cl_arrow_scale: specifies size of toolpath arrow wh@blaying CL data.
* ncpost_type: specifies which post-processing o use, default is gpost.
* nccheck_type : specifies which toolpath SI module to use, default is Vericut.

* mfg_xyz_num_digits and mfg_ijk_nu eC|f|es the number of digits for xyz and ijk co-
ordinates in cL data files, default is 1%
fo

* store_tool_path_file: specifies if to rmation is stored when creating an NC sequence, if
used reduces time needed to r@ e the toolpath.

@@
©&
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Additional Options

® Model Tree

©® Model Tree Configuration
o Filter information display
o Display parameters

Working Environment Configuration

o Displays model and feature information

COVERASM

+ COVER_MC ASM

FADAL WG
MACH_CES¥S_0P010
RETRACT_OPI10

4) OPO010 [FADAL_WMC]
OPOT0_INST ASH

oP_010

Surface id 131056 [FACE_B(
+¢¥ 1.FACE_BOTTOM[OFOTD]
Material Removal id 131057

= 0¥S0

RO

F

CUT_FEED [SPINDLE_SPEED [SCAN_TYPE |

COVERASM

© [ COVER_NCASM
w T OPOTD_INST ASM

& OP_0T0

w1 FACE_BOTTOM |302.804
w ¥ 2 PROF_BOTTOM)|605 807
w9 3 RGH_BOTTOM [|605.807
w4 FIN_BOTTOM[O| 25242

116501
233003
233003
9708.45

TrPE_ZFIRAL
TYPE_SFIRAL

S

Additional Options

The model tree displays model and feature information. i@

Additional configuration of the working environment is possible by/filtering information displayed in
the model tree, and by displaying parameters for NC séﬁce n the model tree. Displayed
&

parameters can be modified directly in the model tre

D

1
2
S
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Configuring the Manufacturing Environment

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

Demonstration: Configuring the Manufacturing Environment %

Duration: 20 minutes

Scenario @\
» Throughout this course, the exercise scenarios tRe’same as the demo scenarios.
» This has been done to build consistency betwesn d€mos and lab exercises so as to enable “Tell

me—Show me—Let me do.” o @
Method 3@
Use the script in the instructors gui ,e same models as in the exercises.
Exercise @
Duration: 45 minutes

Once the demo is cogrip students should use the steps in the training guide to complete the
exercises.

&
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Summary

After successfully completing this module, you should know how to:
© Describe manufacturing configuration options.
© Create configuration options for:
e Tools
o Material files
o Workcells
o Parameter files
o Stock billets

© Create configuration options to enhance the working environment.

QO

Summary %

After successfully completing this module, you should know how to;
+ Describe manufacturing configuration options. \
» Create configuration options to store tools, materia@& orkcells, parameter files, and stock

billets.
+ Create configuration options to enhance the w@mnvironment.
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Exercise 1: Configuring the Manufacturing Environment

Module 17 Lab Exercises

Demonstration Instructions

Preparation

Complete the following tasks before running this demo for customers:

e Practice running the demo so you can easily complete it. : @

* Check for and review the errata sheet for this course.

» Use Pro/ENGINEER Wildfire build code 2003051 or later. @
« Download and install the class fileswi | df i re_m | | i nr . gz as described in

the classroom setup notes.

Introduction
In this demonstration, you need to setup a manuf ihg environment for a new computer. The
, including tools, material files, workcells,

company already has a set of manufacturing
and parameter files. You need to ensure ese configuration options work correctly on the
new PC. Understanding manufactuﬁh%g uration options and methods is an essential element

of the manufacturing process, an@%

Objectives @
After successfully complati is exercise, you will know how to:

e Create confi noptions to store tools, material files, workcells, parameter files, and stock
billets

s the creation of a more efficient working environment.

« Create configuration options to enhance your working environment.

)

ed to setup a manufacturing environment for a new computer in your manufacturing group.
Your company already has a set of manufacturing standards, including tools, material files,
workcells, and parameter files. You need to ensure that these configuration options work correctly
on the new computer. You check the contents of the folders containing the manufacturing
standards, and then create a configuration file to utilize these standards. You test the
configuration is working correctly by configuring a manufacturing operation, creating a face milling
sequence, and post-processing a CL data file. You then enhance the working environment by
configuring the model tree to display manufacturing parameters. You make the parameters more
easily visible by moving the position of the model tree to the bottom of the graphics window; this
is achieved by customizing the screen layout.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 17-3
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Step 1. Open the example manufacturing model.

Before configuring the manufacturing environment, we need to locate the example manufacturing
model and open it using the folder navigator. Once we have located the folder for this exercise,

we can set this as our working directory, and open the example manufacturing model.

1. In the navigator, select the Folder Browser tab, and browse to
c:\users\student\wildfire_mfg_330\module17, right-click, and select Make Working
Directory.

2. Open EXAMPLE.MFG. Turn off any displayed datum features. Q\

%@

Figure 1: Showing the ex; @xufacturing model.
aN
N\

Note:

Notice the reference model and &?@ have already been assembled into the

manufacturing model.

@

Step 2. Check the contents of tﬁ\@\ﬁ?fgé/ata folder.

We need to check the co he mfg data folder that contains all the manufacturing
configuration files. lay the folder navigator, and select the mfgdata folder. We can
expand all the sub ithin the mfgdata folder, except the two materials folders as the

listings in the Iders is too long. We can also drag the navigator sash to make all the folder

names Vi

We Se;@e company post processors are contained in the gpost_pp folder. We can specify
the location of this folder later with a config.pro option. We can see that all the commonly used
manufacturing parameters are stored within the parameters folder. Notice there are sub-folders
for holemaking and milling parameters, and for imperial (inch) and metric units. There is also a
folder for site parameter files. We can also select and open the face.mil parameter file to view the
contents.
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We can see that the stock_parts folder contains a user defined metric billet stock part, which is

used with the Create Stock dialog box. User defined bar stock can also be configured if required.

We can see that all commonly used tools are stored within the tools folder. Notice there are sub-
folders for imperial (inch_tools) and metric tools. We can also select and open the MMBUL10.tpm

tool file to view the contents.

We can select the materials folder within the metric_tools folder and see within each materials
folder there are sub-folders for different types of material. Each material type folder contais an
equivalent tool file containing feed, speed and depth-of-cut data for each tool. This infQtmatign
can be used when configuring manufacturing parameters. We can open the STEKL-1VQ0BHN

iew the

diameter,

folder within the browser and select and open the MMBUL10.tom materia

contents. Notice the feed, speed, and depth-of cut data, this is based on ths
number of teeth, and the workpiece material, in this case stee/-100@

We can see that the workcells folder contains the workcell @on files.

Finally, we can see that the parameters folder also serves\as the default folder for PPRINT files.

the folder names are clearly visible.

1. Click the Folder Browser tab to the left of the window. Drag the navigator sash until

the mfgdata folder, as shown incthe % ing figure. (Do not expand the two materials
folders). Drag the navigator s@ Tantil the folder names are clearly visible.

‘0
Q@

2. Expand the module17 folder, and th tafolder, and then expand the sub-folders within

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 17-5



SRt Il Tifrycliata
(3 gpost_pp
-1 parameters

-1 dffi_hmaking

1 inch
1 metric
-0 dilt_milling

1 inch
C1 metric
1 site_files \
1 stock_parts @
-1 tools @
--Z1 inch_tools
1 center_drills
[ drills @
+-_1 materials %

-1 metric_tools

1 centecdrills

O drills \

R ma
[

C1 waor

Figure 2: Showing thnts of mfgdata folder.

3. Select the gpost_pp folder and ch/%% tents.

Note:

The gpost_pp folder cont @company post processors. We can specify the
V\@‘ a%@

location of this fold nfig.pro option.

4. Within the par { )'milling folder select the metric folder. Check the contents of the
folder in the br

Note: %
or@y sed manufacturing parameters are stored within the parameters folder.
j re are sub-folders for holemaking and milling parameters, and for imperial

ch) and metric units. There is also a folder for site parameter files.
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File Name Size Modified

i cany sutf. mil 1 KB 05-Jan-02 09:35:02 Akd
1KE  |0B-Jan-02 09:26:0

D ﬂatfan: il 1 kB 05-Jan-02 09:35:18 AM
[ pencil.mil 835 bytes 0B-Jan-02 09:35:30 Ak
[ profilemil ab5 bytes 0B-Jan-02 09:35:42 Ahd
[ reroughing. mil 1 KB 0B-Jan-02 09:30:30 Ak
[ roughing,_cavity. mil 1 kB 10-Jan-02 08:17:40 A
[ roughing,_core. mil 1 KB 0B-Jan-02 09:32:08 A
D surf_cutline.mil 1 kB 05-Jan-02 09:32:42
[ surf_iso.rmil 931 bytes 0B-Jan-02 09:33;
[ surf projected. mil 1 KB 05-Jan-0 %
[ surf_window. il 486 bytes DB-Jan-EmD Al

Figure 3: Showing parameter files in the metr'@s er.

5. Select the face.mil file and then right-click and select @iew the contents of the file.

JCAN TYPE T

CUT TYPE CLIMB

STEPCWVER ADJUST g

CUSTCMIZE AUTO @ZT YE3

3TEP DEPTH CUTTER_DIT-\M!’E
TOLERENCE 0.01

STEP_| O E CUTTER DIAM*.D

I\IUMB o
E‘SE}T a
OCK_ALLOW 0

F@ Showing contents of the face.mil parameter file.

n at the top of the browser to return to the contents of the metric
folder.

7. Select stoek_parts folder, and check the contents of the folder in the browser.

8. S%he ncmdl_billet.prt file in the browser, wait for the part to appear in the preview

Note:

The stock_parts folder contains a user defined metric billet stock part, which is used
with the Create Stock dialog box. User defined bar stock can also be configured if
required.
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[File List

File types IAll Files (*) j Mersions [ Apphy |
| File sub—types Instances I '
File Name

Modified \
7 09-0ct-02 044411 PM

u ncrmdl_billet. prt
Figure 5: Showing the ncmdl_billet part.

9. Within the tools folder select the metric_tools folder. Check the conte@the folder in the
browser.

10. Select the MMBUL10.tpm tool file and then right-click and&elect'Qpen to view the contents
of the tool file.

TOOL,_ 1D 0
TOOL_TYPE ING
LENGTH_UNITS <§§Z§MILLIMETER
CUTTER DIAM 10.00000
CORNER_RADING 2.50000
SIDE_ANG@@§:> 0.0
LENGTH 50.0
NUM_OF V7 2
TOO] ERIAL HS 3
GERNGESY LENGTH -
Q§§§%E_Z_LENGTH -
_OVERSIZE -
OL_COMMENT -
TOCL_LONG FLAG NG

& Figure 6: Showing the contents of MMBUL10.tpm tool file.

11. k ‘!‘ ck arrow icon at the top of the browser to return to the contents of the
€_tools folder.

12. Repeat steps 10 and 11 for the MMFLT10.tpm, and MMSPH10.tpm tool files.

Note:

All commonly used tools are stored within the tools folder. Notice there are sub-
folders for imperial (inch_tools) and metric tools.

13. Within the metric_tools folder select the materials folder. Check the contents of the folder in
the browser.
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Note:

Notice also in each tools folder there is a materials sub-folder, and within each
materials folder there are sub-folders for different types of material. Each material
type folder contains an equivalent tool file containing feed, speed and depth-of-cut
data for each tool based on workpiece material. This information can be used when
configuring manufacturing parameters.

File Name

Size Modified

ALURINILIRA
AUSTEM
BRASS-HARD
BRASS-MEDILIM
CASTIROM-HARD
CASTIROM-MEDILIM
COBALT

COFPER

FERR

MNICKEL
STAINLESS-HARD
STAINLESS-MEDILIM
STEEL-100BHN

) EEP) D { Y| ) P M ) ) P

in'the browser. Check the contents of the folder.

10-Dec-02 00:21:03 Ak

09-Dec-02 02:52:37 Phi \
09-Dec-02 02:52:37 P

~Erec A2 025236 Ph
Dec-02 02:52:36 P
Dec-02 02:52:36 P

\ 09-Dec-02 02:52:36 P
Figure 7: Showing contents' »

ic_tools\materials folder

14. Double-click the STEEL-100BHN fo@ i .
<&
15. Select the MMBUL10.tpm } nd then right-click and select Open to view the

contents of the tool material n&b

Y DRTR_UNITS
PPLICATION_TYPE
OOL_SPINDLE REM

@@
©&

TOOL RADTAL, DEPTH
TOOL SURFACE SPEED
TOOL _FEED RATE
TOOL FEED PER UNIT
TOOL AXIAL DEPTH
APPLICATION TYPE
TOOL SPINDLE REM
TOOL RADIAL DEPTH
TOOL SURFACE SPEED
TOOL FEED RATE
TOOL FEED PER UNIT
TOOL AXIAL DEPTH

METRIC
ROUGHING
255

4.8

8000

51

0.z

8
FINISHING
255

1

8000

51

0.z

0.5

Figure 8: Showing contents of MMBUL.tpm tool material file.

Note:

Notice the feed, speed, and depth-of cut data, this is based on the tool diameter,
number of teeth, and the workpiece material, in this case steel-100bhn.

Creating Milling Sequences with Pro/ENGINEER Wildfire
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16. Click the Back arrow icon at the top of the browser to return to the contents of the STEEL-
100BHN folder.

17. Repeat steps 15 and 16 for the MMFLT10.tpm, and MMSPH10.tpm tool material files.
18. Compress the expanded materials folder in the navigator.

19. Within the navigator select the workcells folder, and check the contents of the folder in the

browser.
%% fadalvme.gph \%
% hurco.gph @
%%  makino.gph
%% mazak.gph
Figure 9: Showing the contents of workcells folder. O
=
Note:

The workcells folder contains the workcell configuration fil

20. Within the navigator select the parameters folder, a : the contents of the folder in

the browser.
File Mame Size Maodified

Ba foprint ppr 2 KB 2 00:23:50 AM
T dfit_hmaking \.'\ 09-Dec-02 02:03:33 Phi

T dfit_milling @ 09-Dec-02 02:08:32 PM
1 site_files @ 10-Dec-02 10:27:45 AM

'Q@Showing the contents of parameters folder.

nd then right-click and select Open to view the contents of the

21. Select the ppri
PPRINT file.

22. Click the ﬁarrow icon at the top of the browser to return to the contents of the parameters
folder.

N
e.
parameters folder also serves as the default folder for PPRINT files.

23. Collapse the browser window so that the model in the graphics window is visible.

Step 3. Create a configuration file with manufacturing options.

We need to create a config.pro file with a number of manufacturing options. Using the tool bar,
we can open the Options dialog box. Notice as we type in each option we are prompted to

complete the option name, always ensure the correct option names are used. For each option,
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we can type in a value, set the cl_arrow_scale to zero, and specify default directories for post-
processors, billet stock parts, manufacturing parameters, tools and workcells. When complete, we
can apply the changes and save the config.pro file for future reference.

1. In the menu bar at the top of the graphics window, click Tools > Options from the drop-
down menu.

2. Inthe Options text box, enter the first option listed in table 1 below (cl_arrow_scale), in the
Value text box enter [0]. Click the Add/Change button to add the option.

Note:

Notice as you type in each option the option name is completed foryﬂ\@

3. Create the remaining options and values listed in table 1.

Table 1: Config.pro options @
ﬁ

Option Value =)
cl_arrow_scale 0 \%
gpostpp_dir \mfgdata\gpQst_pp
ncmdl_billet_stock part_path .\mfgdata\;;aglg&erts\ncmdI_biIIet.prt
pro_mf_param_dir .\mfgd/aiq\kﬁq/é)j%ters
pro_mf_tprm_dir .\mfﬁ%@e“bols\metric_ tools
pro_mf_workcell_dir m&g\workcells

N

X&
Note:

For the purposes of im g this exercise all directory paths are given as relative
to the current dir is recommended that absolute paths are used in a work

situation. &

4. Applyjte gQ}s then click the Save File icon, and name it [conf i g. pr 0]. Close the
options\ihd

Step 4{KTest the new configuration options; create a manufacturing operation.

@ now test the configuration options. We can open the Operation Setup dialog box, and the
achine Tool Setup dialog box; and then retrieve the hurco workcell, and PPRINT file. Notice
ow the system automatically uses the workcells and parameters folders. We can also retrieve
the RGH_3_AXIS_MIL.sit site parameter file from the site_files folder. We can select the
workpiece material from the Stock Material drop-down list; the list of materials corresponds to the
material sub-folders within the tools folder.

We can then configure a program zero co-ordinate system and name it. We can also configure a
retract surface, complete the operation and name the retract surface in the model tree.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 17-11
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1. In the navigator, select the Model Tree tab to make the model tree visible again.

2. Using the Menu Manager, select Mfg Setup > Operation to open the Operation Setup
dialog box.

3. Open the Machine Tool Setup dialog box, click the Retrieve Machine icon and select the
hurco.gph workcell.

4. In the Machine Tool Setup dialog box, select PPRINT and Retrieve the pprint.ppr file.

Note:

The config.pro options pro_mf_workcell_dir and pro_mf_param_dir are specifying
the folders for workcells and PPRINT files. Q

5. In the Machine Tool Setup dialog box, select Defaults. U

6. Using the Current Directory and Mill options, double-click the site_@older, then
select the RGH_3_AXIS_MIL.sit site parameter file. %

7. Close the Machine Tool Setup dialog box.

8. In the Operation dialog box, select STEEL-100BHN in Stock Material drop-down list.

Note: C@j\)

The names of the folders in the metric_tools\r@s folder specifies the list of

materials to choose from.

@
"

9. Turn on the display of co-ordinate sys%,A not already visible in the graphics window.

O

¢
Note:
You can turn off the displ @2{9 blended background in the graphics window to
make viewing of co-or&%ﬁy em axes easier.

10. Click View > Djspl ings > System Colors, clear the Blended Background check
box, and click camplete the configuration.

11. Create a m@chine Zero co-ordinate system positioned at the front-left-top corner of the
the orientation of the axes as shown in the following figure. Rename the co-

workpi
%ﬁna@tem to [mach_csys_010].

When prompted create the co-ordinate system in the EXAMPLE.ASM assembly,
select this assembly in the model tree. Refresh the graphics window before selecting
the surfaces that configure the position of the co-ordinate system.

12. Create a retract surface along the Z-axis of the machine zero co-ordinate system, type [30]
(1.18 in) as the z distance.

13. Close the Operation Setup dialog box.
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14. Rename the retract surface to [r et r act _010] in the model tree.

RETRACT 010

Figure 11: Showing program zero co-ordinate system and r e.

15. Turn on the blended background again. Click View > Display ings > System
Colors, select the Blended Background check box, and cli omplete the
configuration.

Step 5. Create a face milling sequence, retrieve a tool fWool library, and retrieve a set of
standard face milling parameters.

We start by creating a face milling sequence. W@ieve a tool from the metric_tools folder;
notice how by default we start searching for @ ‘e metric_tools folder.
Vi

We can review the manufacturing pgrar@

required manufacturing paramete des reading in the speed, feed and depth-of-cut

es, notice how the site parameter file sets all the

data for this tool. @
We can now select the top@rfj of the part to machine, and play the toolpath. Notice how the

workpiece.

toolpath follows the e@

As an alternative ing Site parameter files we can now retrieve the face.mil parameter file,
located in [ iting\metric folder. We can also change the TRIM_TO_WORKPIECE
parameter b YES to see the effect on the toolpath. Playing the toolpath we notice the dept-

of-cut@nd step-over are different.

ln@ary, we can see that parameter values can be taken from site files, calculated from tool
aterial files, or retrieved from stored parameter files. These options enable us to create NC
‘equences quicker and with less effort. They can also ensure that standard parameter values are

used.

1. Turn off any displayed datum features.

2. Using the Menu Manager, create a Face milling sequence.

3. Select the Parameters check box.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 17-13
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4. Inthe Tools Setup dialog box, click the Retrieve Tools icon and select the MMFLT20.tpm
tool from the metric_tools folder.

Note:

Notice how by default tools are retrieved from the metric_tools folder.

5. Set the parameters, view the parameter values and accept the default values.

Note:

file.

These parameter values are taken from the site parameter file and the tool material

6. In the Surf Pick menu, accept the Mod

model.

CUT_FEED
STEF_DEFTH
STEF_OVER
BOTTOM_STOCK_ALLOW
CUT_AMNGLE
SCAN_TYFE
SPINMDLE_SFEED
COOLANT_OFTIOM
CLEAR_DIZT
APFROACH_DISTANCE
ExIT_DISTANCE

Figure 12: Showing def@

meter values.

selection.

@@
&
©&

Figure 13: Showing the selected reference model surface.

glx choose surfaces from the reference

7. Select the top surface of the refife@%del for the surface to machine, and complete the

8. Play the tool path using the Screen Play option. Ensure the CL data is visible.
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Figure 14: Showing the resulting tool path. \
9. Using the Menu Manager, select Seq Setup, and select the Parameters ckox. Using
Retrieve double-click the dflt_milling and metric folders, then s {‘ - .mil

parameter file.

CUT_FEED @
STEP_DEFTH @
STEP_OVER C)a
BOTTOM STOCK_ALLOW -
CUT_AMGLE 0
SCAN_TYPE TYPE 3
SPINDLE_SPEED 1000
COOLANT_OFTION @ ON
CLEAR_DIST 05
APPROACH_DISTMNG -
EXIT_DI%TAI@ -

Figure @ing the face.mil file parameter values.

¢
Note: O
Notice all the par@@alues are now taken from the face.mil parameter file.

10. Modify the T MORKPIECE parameter to YES.

11. Play tk€ toof path’using the Screen Play option. Ensure the CL data is visible.

Q)

Figure 16: Showing resulting tool path.
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Note:

Parameter values can be taken from site files, calculated from tool material files, or
retrieved from stored parameter files.

12. Complete the NC sequence.

Step 6. Continue testing the new configuration options; create a CL data file and MCD file for
operation op010.

The final test involves creating a CL data file and post-processing this file into an MCD file.
start by creating a CL data file, choose to create an MCD file at the same time, and sel

processor from our gpost_pp folder. Notice only the post-processors located in the mro
folder are listed for selection. Notice also the name of the machine type displays ‘ttom of

the graphics window when you highlight each post-processor in the menu.

1. Using the Menu Manager, select CL Data > Output > Operatio 0 > File. Select
the MCD File check box, and complete the file output. Click the on to create a CL
data file for operation OP010.

2. Accept the Verbose and Trace options, and select the%%xm P03 post-processor, (this
is the hurco post-processor).

Note: @

Notice only the post-processors locatgd i . pp folder are listed for
selection. Notice also the name of t % type displays at the bottom of the
graphics window when you highligh ost-processor in the menu.

§97aN

Step 7. Configure the model tree t;z@iséléﬁ)manufacturing parameters.

We can enhance the working @ ent by configuring the model tree to display manufacturing

parameters. Opening the mns dialog box, we can select the machining parameters

option in the drop dgwn li can then move relevant parameters into the displayed column.
Once the configura mplete, we can adjust the width of the parameter columns, and save
the conﬁgurat%Votice it is not possible to see the parameter names without making the model
tree wider, native approach is to move the position of the model tree by customizing the
screéh | @Ve can open the Customize Screen dialog box and in the navigators tab we can
chan e position of the model tree to below the graphics area. We can then complete the
configuration; the customized window configuration is saved and can be retrieved when required.
Moving the model tree to the bottom of the graphics window provides more space to add

additional parameters to the model tree if desired.

1. Ensure the model tree is displayed in the navigator window.

2. Inthe model tree, click Settings > Tree Columns.
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3. In the Model Tree Columns dialog box, click the Type drop-down list, and select the
Machining Params option.

4. Move the CUT_FEED, SCAN_TYPE, and STEP_DEPTH parameters to the displayed
column. Complete the configuration.

5. Adjust the width of the navigator and displayed parameter columns until they are clearly
visible, as shown in the following figure.

CUT_FEED|SCAN_TYPE |STEP_DEFPTH

[ ExAMPLE ASK
EXAMPLE FE

[
© ) EXAMPLE_Wi {
& FSETPO
7 HURCODT
A MACH_CSYS,
77 ADTMI @
) OPO10 [HURC
+ o9 1.Face Milling|10 TYPES %4

# InsertHere

Figure 17: Showing displayedNeters in the model tree.

6. Click the Settings tab in the model tree, sel Save Settings File option from the
drop-down list. Accept the tree.cfg defadit natae and Save the tree configuration file.

Note: ¢ @

Notice the selected param&%ﬁ displayed in the model tree. Notice also it is not
possible to see the para r es without making the model tree wider. An
alternative approac%t the position of the model tree by customizing the

screen layout.

J)
7. Inthe menu bara p of the graphics window, click Tools > Customize Screen from
the drop- u.

e Screen dialog box, click the Navigator Tabs tab, in the Placement drop-
ctk Below graphics area, and in the Height text box change the height to [5].

down list,
f%ete the configuration.

Shiow ~ I Settings v I

|CUT_FEED |SCAN_TYPE [STEFP_DEPTH
£ RALTTINT
81 OPD10 [HURCOOT]
+g¥ 1. Face Miling [OP010] |10 TYPE_3 4
$ InsertHere

Figure 18: Showing model tree moved to the bottom of the graphics window.
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Note:

This customized window configuration has been saved and can be retrieved when
required. Moving the model tree to the bottom of the graphics window provides more
space to add additional parameters to the model tree if desired.

9. Save the manufacturing model.
10. Close all windows and erase all components from memory.

11. To clear all configuration options, click File > Exit > Yes to exit from Pro/ENGINEER

Note: Q
Exiting Pro/ENGINEER ensures all configuration options are cleared in pre\'

for the next module.

>
Q
O
N
B
S
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Summary

After successfully completing this module, you should know how to:

» Describe manufacturing configuration options.

» Create configuration options to store tools, material files, workcells, parameter files, and stock

&
&

» Create configuration options to enhance your working environment.
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Module

Machinino

\‘
Introduction @

When given a design model to machine, it is neces@o understand how to

odel drawings. This
ining strategy, and enables
manufacturing parameters

provides a means to determine an appropriéate

review and check model geometry and any as%
the correct selection of workcell, fixtureg tool

during the machining process. When the ing process is complete, it is
possible to create useful manufactu information, such as route sheets, for
manufacturing engineers and other stream processes.

Objectives @

After completing thfs, @ you will be able to:

* |dentify an odel geometry and dimensions.

. Open@i w model drawings.
 Create ufacturing models and configure manufacturing operations.
. ete machining operations and post-process CL data.

. eate route sheets and other useful manufacturing information.
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Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 18: Machining Project

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Five

Sptc |

[Lebs |

Configuring the Automating Pro/FICIENCY
Manufacturing Machining publes and  [==sl  Workflow with =t
Environment ol Pl gNC- Mapkeys | | Assessments
Configuring th Checking and Using Index
onfiguring the » | Tablesand | Anmma(ln_g
- Workflow with
Environment Geometry Duplicating NC- Mapkeys
Sequences.
Manufacturing Model
and Manufacturing
Operation for the Casing
Configuring the UsingIndex [  Automating [
| Tablesand | Workflow with
Environment Duplicating NC- Mapkeys

Machining the
Casing (Challenge)

Using Index

Duration

Lecture: 10 mins
Demos : 25 mins
Labs : 70 mins
Total: 1 hr 45mins
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Objectives

After completing this module, you should know how to:
Identify and check model geometry and dimensions.
Open and review model drawings.
Create manufacturing models and configure manufacturing operations.
Complete machining operations and post-process CL data.

Create route sheets and other useful manufacturing information.

AN
o)

@

Overview %2

When given a design model to machine it is necessary tQ undgrstdnd how to review and check
model geometry and any associated model drawings. Thig\proyvides a means to determine an
appropriate machining strategy, and enables the corXect setection of workcell, fixtures, tools,
and manufacturing parameters during the machini%@q ess. When the machining process is

complete, it is possible to create useful manufactu¥i ormation, such as a route sheets, for
manufacturing engineers and other downstre sses.

After completing this module, you will b<> @:
+ Identify and check model geome imensions.
* Open and review model drawi @?
» Create manufacturing mo and configure manufacturing operations.
+ Complete machinin atigns and post-process CL data.
* Create route shegts other useful manufacturing information.

Q)
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Checking Model Geometry

Methods

® Selecting Geometry

o Displaying dimensions

oy

©® Measuring geometry

o Distance

o Curve Length

3
dge:F29(ROUND)

o Diameter
e Angle —

QO

Checking Model Geometry %
There are several methods for checking model geome

» One method is to select model features and display di lons.

* An alternative is the measure tool which provide recise measurement capability. It is
possible to select model geometry and make vgri easurement calculations, such as

distance, curve length diameter and angle.@
o \(: :)
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Checking Model Geometry

Methods
® Curve Analysis

® Surface Analysis
o Many Options

Idin. o
Surface is concave

utsicle radius: 19.0000

Fesults
Min. Curvature : 01760
e Curvature : 0.2201
® Viewing Model Drawings
1an, oo
E | 3,00
i ; :

Rz2. 000 /

Rz 00

0o

so.gn | SECTION A-a

Checking Model Geometry

Other methods for checking model geometry are: ; ; D@
alysi

» Curve Analysis: There are several types of curve. an vailable, the most commonly
used are:

* Curvature — display the curvature of the e
Mathematically, the curvature is equal t

urve at the selected point.

]

» Radius — display the radius of the e %urve at the selected point. The radius is
equal to 1/curvature.

&

» Surface Analysis: Enables anal urface properties, there are fifteen types of surface
analysis tools, such as

» Radius:—calculate th @st positive and negative radii for a surface of a part or
assembly. $

* Slope—displa s@g fs, the slope of a surface relative to a reference plane on a part.

* The most comm

&

eans of checking model geometry are drawings.
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Demonstrations

In this module, you will follow the instructor as they perform the
following demonstrations:

® Checking and Measuring Model Geometry.

® Creating the Manufacturing Model and Manufacturing Operation for the
Casing.

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercises.

QO

Demonstrations (2): %
» Checking and Measuring Model Geometry

* Creating the Manufacturing Model and Manufact% tion for the Casing

Scenario @‘

* Throughout this course, the exercise scenafios\are the same as the demo scenarios.

* This has been done to build consistgnc@ en demos and lab exercises so as to enable
“Tell me—Show me—Let me do.” X

Method
Use the script in the instructo&@e, use the same models as in the exercises.

Exercises (3)
» Checking and fegsu Model Geometry
* Creating the Ma turing Model and Manufacturing Operation for the Casing
* Machinin ‘ﬂ%Casing (Challenge)

Once emo is complete the students should use the steps in the training guide to complete
the exercises.



e . VrTC

Summary

After successfully completing this module, you should know how to:
© ldentify and check model geometry and dimensions.
® Open and review model drawings.
® Create manufacturing models and configure manufacturing operations.
©® Complete machining operations and post-process CL data.

® Create route sheets and other useful manufacturing information.

QO

Summary %

After successfully completing this module, you should kn to:
+ Identify and check model geometry and dimensi
» Open and review model drawings.
 Create manufacturing models and configu ufacturing operations.
» Complete machining operations an%po@;o ess CL data.
* Create route sheets and other US% acturing information.

‘0
©©
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Exercise 1: Checking and Measuring Model Geometry

Module 18 Lab Exercises

Demonstration Instructions

Preparation

Complete the following tasks before running this demo for customers:

e Practice running the demo so you can easily complete it. @@

Check for and review the errata sheet for this course.

Use Pro/ENGINEER Wildfire build code 2002380 or later. @

» Download and install the class fileswi | df i re_mi I | = .tar. gz as described in

the classroom setup notes.

Introduction @p\
In this demonstration, you open the casing r@ n check model dimensions, and measure

model geometry using various tools. Yo eck dimensions in a model drawing,enabling you
O
to determine a machining strateg&c ropriate tools and manufacturing parameters during

the machining process. ?
Objectives @

After successfull F oRple this exercise, you will know how to:
CN I

heok

* Open revjéw model drawings.
Sce Q&o
YI given a casing model to machine. You use different techniques to determine key model
imensions and distances. This enables you to select correct tool sizes, and to determine a
itable machining strategy. You create a workpiece and manufacturing model and configure an
operation. You then create the NC sequences required to machine the bottom of the casing, and
post-process the CL data file for the operation. Finally, you identify the different types of

manufacturing information that can be created, such as: operation, tooling, NC sequence
information, and route sheets.

* |dentify gid odel geometry and dimensions.

In this exercise, you check dimensions on the casing model, measure model geometry using
various tools, and check dimensions in a model drawing. This enables you to determine a
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machining strategy, select appropriate tools and manufacturing parameters during the machining
process.

Figure 1: Showing the casing model. (@Q

Step 1. Open and check the casing model for key dimensions and sizes.

%
We can locate the folder for this exercise and set this as our working dir, og@fore opening
odel tree to its

the casing model, we can retrieve a window configuration file, return

default position.

We can now open the casing model. We need to select varatures on the model to

determine key dimensions. We start by selecting the rou re on the support pin. By

selecting the edit option in the drop-down list, we ca@nme the radius value. We repeat this
a

process for the protrusion feature and for thg h mfer. We can also determine the
radius of the external round feature using

2. Inthe navigator, setect the Folder Browser tab, and browse to
c:\usersi\student\wildfire_mfg_330\module18, right-click, and select Make Working

3. n CASING.PRT.
4. Turn off any displayed datum features.

5. Select the round feature on the pin support, as shown in the figure below. Then right-click and
select Edit from the drop down list. Note the round radius value. Select in the background to
de-select the highlighted geometry.
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Delete
Suppress
Rename

Edit

Edit Definition
Edit References
Setup Note >

Q

Figure 2: Showing the selected round feature.
6. Select the pin support protrusion feature. Then right-click and select the drop down
list. Note the protrusion radius value. Select in the background to de-selectthe highlighted

geometry. @

Figure 3<> Sh » selected protrusion feature.

he following figure. Then right-click and select Edit from

7. Select the hole feature, as sh@%ﬁ
the drop down list. Note th ("’o ediameter and depth. Select in the background to de-select
the highlighted geomet @'

& %
&
®&

8. Select the hole chamfer feature as shown in the following figure. Then right-click and select
Edit from the drop down list. Note the chamfer dimensions. Select in the background to de-
select the highlighted geometry.

Figure 4: Showing the hole dimensions.
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Figure 5: Showing the chamfer dimensions.
9. Select the external round feature. Then right-click and select Edit from the drop do \
Note the round radius value. Select in the background to de-select the highlig effy.

Figuﬁ%@g the round radius.
N\

this may not alway \s with the information we require. For example, we
need to check the .% th.of the steps in the pocket, and the internal radius in the
deeper pocket/ b \W S case we can use the measure tool.

Y
Note: @U
We could continue sel@ res and highlighting model dimensions, however
owide

Step 2. Use thesmeaste tool to determine the depth of the steps in the pocket, and the internal
radius Qf the round in the deeper pocket.

Opening t asure dialog box, we can determine the depth of the shallow pocket by selecting
surf at the top and bottom of the pocket. We can also determine the depth of the deeper
pocket by selecting the bottom surface of this pocket. Notice in the Measure dialog box all
distances are calculated from the first item selected until a new item is configured as the “From”
position. We can also determine the internal round radius in the deeper pocket by selecting the

internal rounded surface at the bottom of this pocket.

1. In the menu bar at the top of the graphics window, click Analysis > Measure. This makes
the Measure dialog box appear.
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3. Select the top surface on the rim of the casing, and then select the surface at the bottom of
the shallower pocket, as shown in the following figure.

2. Inthe Measure dialog box, click Distance from the type drop-down list.

Figure 7: Showing the selecte s@.

4. Note the distance between the two surfaces in the results sgction of the Measure dialog box.

5. Measure the distance from the top of the rim to the\bottom of the deeper pocket by selecting
the surface at the bottom of the deeper pockéf.

%3 Showing the additional surface selected at the bottom of the deeper pocket.

6. @ the calculated distance in the results section of the Measure dialog box.

Note:

In the Measure dialog box, all distances are calculated from the first item selected
until a new item is configured as the “From” position.

7. Measure the diameter of the internal round in the deeper pocket. In the Type drop-down list,
click Diameter and select the internal round surface in the deeper pocket.
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Figure 9: Showing the selected internal round surface. @@

8. Note the calculated diameter in the results section of the Measure dlalog/bs%(

Note
There are six possible measurement types available within th&@e dialog box.

N

9. Close the Measure dialog box.

Step 3. Use the surface analysis tool to measure the rad edwo curved surfaces in the
middle of the pocket.

We can use the Surface Analysis dialog box to the minimum radii on two curved
surfaces. We open the Surface Analysis diale nd using the radius option we can select the
larger curved surface in the middle of the %We can then compute the minimum radius for
the selected surface. We can repeat t ss for the smaller curved surface in the middle of
the pocket. The surface analysis t@/seful for determining minimum and maximum radius

elp

values on curved surfaces; this us select the correct tools for machining.

of the graphics window, click Analysis >Surface Analysis. This
ysis dialog box appear.

1. In the menu bar &t the
makes the Su

2. Inthe Typﬁ;p-d whn list, click Radius, and select the larger curved surface in the middle

of the@ s shown in the following figure.
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Figure 10: Showing the selected larger curved suﬁa@@

3. Click the Compute button to determine the minimum radius for the se d surface.

4. Select the smaller curved surface in the middle of the pock%@vn in the following
figure. \

@ure 11: Showing the selected smaller curved surface.

5. Click t button to determine the minimum radius for the selected surface.

6. Closeth ace Analysis dialog box.

Stgg{t.\e\heck key dimensions in the casing model drawing.

s can also be used to provide us with key information for manufacturing. In this case, we
ave a drawing with the minimum number of dimensions required to complete machining, and the
drawing also enables us to check the component after machining. We can open the drawing and
zoom-in to each view to determine any remaining key dimensions. Note the drawing can be

rechecked during the machining process if required.

1. Open CASING.DRW.
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3.90

106, 60

00

4,00

PTC

Rez. 000

50.00

Figure 12: Showing the sectional view from casing model dr@

2. Zoom-in to each view and determine any remaining key dimens X

X

Note:

The drawing provides a minimum number of dimensio
component, and checking of the component after
rechecked during the machining process if required.

° gt g

N\

0 enable machining of the
. The drawing can be

3. Close the drawing window. o @
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Exercise 2: Creating the Manufacturing Model and
Manufacturing Operation for the Casing

Introduction

In this demonstration, you create a workpiece for the casing model using the Create Stock dialog
box. You create a manufacturing model, and you configure a manufacturing operation consisting
of a workcell, milling site file, program zero co-ordinate system, and retract surfacecY ke

use of the pre-configured manufacturing environment options.

Objectives @Q

After successfully completing this exercise, you will know how to:

« Create workpieces using the Create Stock dialog box. @C @

e Create manufacturing models.

» Configure manufacturing operations.

Scenario \

In this exercise, you create a workpiece for @ing model using the Create Stock dialog box.

You create a manufacturing model, and ¥8Q igure a manufacturing operation consisting of a

workcell, milling site file, program z& nate system, and retract surface. You make use of
the pre-configured manufacturing \%ment options.

Step 1. Create an NC assemb} @ the casing; assemble the casing part as the reference model.
Create the workpigcg usig the Create Stock dialog box.

Before creating a

\)
’@E\% need to load a configuration file, this enables us to access the
cells, parameter files, stock parts and post-processors.

NC model assembly, and assemble the casing part as the reference model.

We can_use

allowanges, and notice the stock outline update. This completes the configuration of the NC

reate Stock dialog box to create our workpiece. We can type in stock

ssembly and workpiece.

Before creating any models load the configuration file config.pro. Click Tools > Options,
use the Open a Configuration File icon and select the config.pro file from the module18
folder. Then Apply and, Close the Options dialog box.

Note:

To access the company standard manufacturing environment, we need to load the
config.pro file which has all the required options and paths specified. This enables
access to the company tools library, workcells, parameter files, stock parts and post-
processors.
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2. Create a new NC model assembly, click File > New, select the Assembly and NC Model
options, and name the assembly [casi hg_nc]. When prompted select the casing.prt
model from the list, (this assembles the reference model).

3. Using the Menu Manager, select Create Stock, in the Create Stock dialog box, click
Allowances and type the following allowances.

Table 1: Stock Allowances

Allowance Allowance values + and -

Length 5.0 (0.20in)

Width 3.0(0.12in) f\
Thickness 5.0 (0.20 in)

Note: @
Notice the stock outline update as you type in the allowances. @b

4. Close the dialog box. @

5. Save the NC model assembly, and close the window./\\
@

Step 2. Create a new manufacturing NC assembly fo;/tkLeV Q{a%g.

sing. When complete, we can save the
and CASING_NC_WRK.PRT file are
automatically classified correctly as the’n ce model and workpiece.

We start by creating a manufacturing NC assem OK¥he casing; a sensible naming convention
should be used, so name the manufacturingf%()39
manufacturing model. Notice the CASINGS

1. Create a manufacturing NC @Iy for the casing; click File > New, select the
Manufacturing an s bly options, and name it [casi ng].
2. Using the Men elect Mfg Model > Assemble > Gen Assem, and assemble

CASING_NC. inte>the manufacturing model.

3. Save the @ufacturing model.

ofe:)
ice the CASING.PRT file and CASING_NC_WRK.PRT file are automatically
ssified correctly as the reference model and workpiece.

Step 3. Configure a manufacturing operation for the casing.

We can open the Operation Setup dialog box, and the Machine Tool Setup dialog box; and then
retrieve the mazak workcell, and PPRINT file. Notice how the system automatically uses the

workcells and parameters folders. We can also retrieve the RGH_3_AXIS MIL.sit site parameter
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file from the site_files folder. We can select the workpiece material from the Stock Material drop-

down list; the list of materials corresponds to the material sub-folders within the tools folder.

We can then configure a program zero co-ordinate system and name it. We can also configure a

retract surface, complete the operation and name the retract surface in the model tree.

Note:

The manufacturing configuration options should be accessible as you configure th
manufacturing operation. &

1. Using the Menu Manager, select Mfg Setup to open the Operation Setup @w
2. Open the Machine Tool Setup dialog box; retrieve the mazak.gph .@

3. In the Machine Tool Setup dialog box, select PPRINT and retrieve-the pprint.ppr file.
4. In the Machine Tool Setup dialog box, select Defaults. %@

5. Using the Current Directory and Mill options, retrigve
RGH_3_AXIS_MIL.sit site parameter file.

6. Close the Machine Tool Setup dialog box. @
7. In the Operation dialog box, select ST N in the Stock Material drop-down list.

E@
8. Turn on the display of co-ordinage S sy not already visible in the graphics window.

e site_files folder the

9. Click View > Display Setti@%é%ystem Colors, clear the Blended Background check
box, and click OK to comp \ onfiguration.

10. Create a machine zer@ ate system positioned at the front-left-top corner of the
workpiece. Set the Qrie n of the axes as shown in the following figure. Rename the co-
h_csys_010].

RETRACT 010

Figure 13: Showing the program zero co-ordinate system and retract plane.
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Tip:
When prompted create the co-ordinate system in the CASING.ASM assembly, select

this assembly in the model tree. Refresh the graphics window before selecting the
surfaces that configure the position of the co-ordinate system.

11. Create a retract surface along the Z-axis of the machine zero co-ordinate system, type [30]
as the z distance.

12. Close the Operation Setup dialog box.
13. Turn on the blended background again. Click View > Display Settings > System \

Colors, select the Blended Background check box, and click OK to complete t @

configuration.
15. Save the manufacturing model. ZC @

>
Q
O
N
B
S

14. Rename the retract surface to [r et r act _010] in the model tree.

Q)
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Exercise 3: Machining the Casing (Challenge)

Objectives

After successfully completing this exercise, you will know how to:

» Create NC sequences to machine the bottom of the casing.
* Create CL data files.

» Create MCD files using a post-processor.

« Create route sheets and other useful manufacturing information. Q\

Scenario

In this exercise, you create a series of NC sequences to machine t tom of the casing model.
The steps in the exercise specify a suggested order for creating h@Equences. You can
machine the casing using different NC sequences and in a i f@mer if desired. When the
operation is complete you post-process a CL data file ofithe o n. You also identify the
different types of manufacturing information that can be ¢ such as operation, tooling, and
NC sequence information, and route sheets.

Step 1. Create a face milling sequence to face dBWthe top of the casing model.

AON
Note:
The objective is to face down<> U of the reference model leaving zero stock on
the model.

¢
1. Turn off any displayed@;2 atures.
2. Using the Menu @ —Create a face milling sequence.
3. Retrieve g sy e ool from the metric_tools folder.

4. Modif Wers as required.

te:

(]
@i{%parameter values are taken from the site parameter file and the tool material file.

Select the top surface of the reference model for the surface to machine.
6. Play the tool path. Ensure the CL data is visible.
7. Modify parameters and replay the tool path until satisfied.

8. Complete the NC sequence.
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Figure 14: Showing the example facing tool path. @@

9. Create a material removal feature.

.

Step 2. Create a profile milling sequence to machine the outside profile gﬁtl\@ing

(S

in).

Note: § 2)
The objective is to profile down the outside of the casxtoa h of 20 mm (079

7>

U
1. Using the Menu Manager, create a profile mﬂlm@
2. Retrieve a suitable tool from the metric tooI@e
3. Modify parameters as required.

4. Create an extruded mill surface as@nﬂlmg surface.
5. Play the tool path. Ensure t a is visible.
6. Modify parameters an e tool path until satisfied.

7. Complete the S e.

&

Figure 15: Showing the example profiling tool path.

8. Create a material removal feature, and hide the profile mill surface in the model tree.
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Step 3. Create a volume milling sequence to rough out the pocket.

Note:

The objective is to rough out the pocket leaving zero stock on the flat horizontal
surfaces and 0.75 mm (0.03 in) on the vertical walls and curved surfaces.

1. Using the Menu Manager, create a volume milling sequence.

2. Retrieve a suitable tool from the metric_tools folder.

3. Modify parameters as required. \
4. Create a mill window to define the volume for machining. @
5. Play the tool path. Ensure the CL data is visible. @

6. Modify parameters and replay the tool path until satisfied. @

F@\G: Showing the example rough volume tool path.

7. Complete the nce, and hide the mill window in the model tree.

Step 4. Cpe//afe/g\@gme milling sequence to finish the vertical walls of the pocket.

te:

( objective is to remove the remaining material from the vertical walls in the
bocket.

Using the Menu Manager, create a volume milling sequence.
2. Retrieve a suitable tool from the metric_tools folder.
3. Modify parameters as required.
4. Create a mill volume to define the volume for machining.

5. Hide the mill volume in the model tree.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 18-17



6. Play the tool path. Ensure the CL data is visible.

7. Modify parameters and replay the tool path until satisfied.

Figure 17: Showing the example finishing volume %}

8. Complete the NC sequence.

9. Create a material removal feature for the first (roughi me milling sequence.
JANN
Step 5. Create a semi-finish surface milling sequenﬁ'&\%achine the curved surfaces in the
middle of the pocket. N\
N
Note:
The objective is to machine the urfaces and leave 0.25 mm (0.010 in) stock
remaining. f
e}

N2
1. Using the Menu Man eﬂ@tﬁ a surface milling sequence.

2. Retrieve a suitabje t the metric_tools folder.
3. Modify parame equired.
4. Select the%aces to be machined.

ig Q, e cut definition of the surface milling sequence.

7. Modify the parameters and cut definition; replay the tool path until satisfied.
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Figure 18: Showing the example semi-finishing surfacing ’@@

8. Complete the NC sequence.

Step 6. Create a finish surface milling sequence to machine the cu@ﬁaces in the middle of
the pocket. Y/
\T))
=

Note:
The objective is to machine the curved surfa%nd ve zero stock remaining.

1. Using the Menu Manager, create a surfac equence.
Gon

2. Retrieve a suitable tool from the metri s folder.
&

3. Modify parameters as required. \

4. Select the surfaces to be

5. Configure the cut defir@?esurface milling sequence.
6. Play the tool t@e the CL data is visible.

7. Modify the p rs and cut definition; replay the tool path until satisfied.

&

Figure 19: Showing the example finishing surfacing tool path.

8. Complete the NC sequence.
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Step 7. Create two holemaking sequences to drill and countersink the four 4-millimeter holes.

1.

10.

1.

12,

13.

14.

15.

16.

17.

Using the Menu Manager, create a holemaking sequence.

Specify the holemaking cycle type.

Retrieve a suitable drill tool from the metric_tools\drills folder.

Retrieve a standard set of drilling parameters from the dflt_hmaking\metric folder.
Configure the hole set.

Play the tool path. Ensure the CL data is visible.

Modify the parameters and hole set configuration; replay the tool path until sa

Complete the NC sequence.

Using the Menu Manager, create a holemaking sequence. @
Specify the holemaking cycle type. %

Retrieve a suitable countersink drill tool from the metricctools\ older.

Retrieve a countersink set of drilling parameters fro > hmaking\metric folder.
Configure the hole set.

Play the tool path. Ensure the CL data is>vis

Modify the parameters and hole set c% ion; replay the tool path until satisfied.

Complete the NC sequence.
Save the manufacturing r@d.@

Figure 20: Showing the example holemaking tool path.
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Step 8. Create a CL data file and MCD file for operation op010.

1. Using the Menu Manager create a CL data file for operation OP010, create an MCD file at
the same time; accept the default filename of op010.ncl.

2. Accept the Verbose and Trace options, and select the UNCX01.P01 post-processor, (the
mazak post-processor).

Note:
You have now created a CL data file, named op010.ncl, and an MCD file nax&
op010.tap.

prTEp AN

NN
Step 9. Check the different types of manufacturing information that can bécre \Qband create a
route sheet.

1. Using the Menu Manager, select Mfg Setup > Tooling > MA@O to open the Tool

dialog box. %
2. Using the drop-down menu, click View > All Tools, not ol information available and
close the information window.

3. Click View > Where Used, note the tool infz?%}gg available and close the information

window.
NN

Note:

The tool information window ved and printed if required.
TOOLS ARE USED %&OLLOWING NC BEQUENCES:

TOOL ID C BEQUENCE FEATURE FEATURE FEATURE
NUMEER NUMEEER ID TYEE

M 1 7 11 MILLING

M 2 12 14 MILLING

3 17 362 MILLING

TO4 4 23 3738 MILLING

MMEPH1O 5 27 6010 MILLING

MMEEPHOG & 30 6013 MILLING
@ CRIMNK 1 0 g 35 a0zl HOLEMAEING
MMDRL_ 04 7 23 a020 HOLEMAKIMNG

Figure 21: Showing tool where used information.

4. Close the Tool Setup dialog box.

5. In the menu bar at the top of the graphics window, click Info > Manufacturing. This makes
the Manufacturing Info dialog box appear.

6. Click Operation and Apply to see the operation information window.
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8. Click NC sequence and Apply to see the NC Sequence information window.

7. Note the operation information available and close the information window.

9. Note the NC sequence information available and close the information window.

10. Click Route and Apply to output information for the route sheet.

Note:

Note the run times for each NC sequence are shown. Fixture setup time can be
specified during fixture configuration if required; alternatively the setup time can be
edited manually in the route sheet.

Aszembly Name : CASING

Author
Seqg. Machine and ZSequence
Ho. Description

o010 MILL
Face Milling

<
0020 MILL N/ A N/ A 26. 428
Profile Milling &
Figur: Z@Qing route sheet information.

11. Note the route sheet info% ilable and close the information window.

12. Close the Manufactuyi ation dialog box.

13. Close all wind

14. To clear a@ﬁg

se all components from memory.

tion options, click File > Exit > Yes to exit from Pro/ENGINEER.
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Summary

After successfully completing this module, you should know how to:

Identify and check model geometry and dimensions.
Open and review model drawings.

Create manufacturing models and configure manufacturing operations.
Complete machining operations and post-process CL data.
Create route sheets and other useful manufacturing information. @\

>
Q
O
N
B
S
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Module

19

Using Index Tables and Duplicating NC

Sequences

@

Introduction

Using indexing tables enables you to rotate %nts on the machine tool.
This enables you to machine at different\angleg)on a single component and to
machine multiple components on different s of an index table. In order to do
this you need to specify one mac %ordinate system, and multiple NC
sequence co-ordinate systems. It efore important to understand the
difference between machin sequence co-ordinate systems. When using
index tables, it is often passibleto save time by patterning sequences or creating
sequence subroutikes, (%. nding on your specific requirements. It is therefore
important to und% the different types of CL data output created by

patterning and subroutines.
Obje ti@:
:ir mpbeting this module, you will be able to:

E'scribe the purpose of machine and NC sequence co-ordinate systems.

Describe the differences between machine and NC sequence co-ordinate
systems.

» Describe the differences between patterning NC sequences and creating NC
sequence subroutines.

» Create NC sequences using different machine and NC sequence co-ordinate
systems.

Create NC sequence subroutines.

» Pattern NC sequences.

Page 19-1



Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 19: Using Index Tables and Duplicating
NC Sequences \

The way to Product First™

&,

Instructor Preparation %
Before teaching Creating Milling Sequences with EQ/EER Wildfire, you must

ro/
have read and thoroughly understood the foIIo%materials:
* General Information
* Review Pro/ENGINEER Wildfire prim@e at http://rdweb.ptc.com/primer/

- O
* Pro/E Wildfire Documentation %
* Review Pro/ENGINEER % ocumentation in Windmill, located in

/GS Training Materials/Dom@ edge/Create/ProENGINEER/Core Concepts

* Pro/E Wildfire Mil @
* Review Py E@NEER Wildfire Milling training materials in Windmill, located in
/GS Ed Srvcs (@ns@s Education Library/Instructor Materials/Instructor Kits/EN
/T979-330—I§ﬂuc " Kit-EN

- R&q SkiIIs

ompletion of Pro/E Wildfire Foundation or equivalent Pro/E skills

« Completion of Creating Milling Sequences with Pro/ENGINEER Wildfire or
equivalent Pro/E skills

* Ability to install and configure Pro/E Wildfire
* Ability to follow general classroom setup procedure
* Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Five

Configuring the N
e Manufacturing M::'o"‘l:';-u
ectures | Environment

Configuring the

Environment

Manufacturing [

Checking and
Measuring
Geometry

Manufacturing Model
and Manufacturing
Operation for the Casing

| Configuring the

_| Manufacturing | |

Environment

""""" Checking and [
Measuring
Geometry

1

Manufacturing Model
and Manufacturing
Operation for the Casing

I

Machining the
Casing (Challenge)

Using Index
Tables and

Duplicating NC-

Sequences

Using Index
Tables and

Duplicating NC-

Sequences

Using Index
Tables and

Duplicating NC-

~|  Workflow with [~

Automating
Workflow with
Mapkeys

Pro/FICIENCY
ail
Assessments

]

Automating

Mapkeys

Automating

| Workflow with |

Mapkeys

\}
D@

- D

Duration

Lecture: 15 mins
Demos : 25 mins
Labs : 50 mins
Total: 1 hr 30mins

&

>

©©

&

D
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Objectives

After completing this module, you should know how to:

Describe the purpose of machine and NC sequence co-ordinate
systems.

Describe the differences between machine and NC sequence co-
ordinate systems.

Describe the differences between patterning NC sequences and creating
NC sequence subroutines.

Create NC sequences using different machine and NC sequence co-
ordinate systems.

Create NC sequence subroutines.

Pattern NC sequences. @\

Slide 3 B02PTC

Overview <%}

Using indexing tables enables you to rotate componegt{s on\the machine tool. This
enables you to machine at different angles on a single onent and to machine
multiple components on different faces of an inde%le. In order to do this, you need to
specify one machine co-ordinate system, and NC sequence co-ordinate
systems. It is therefore important to underst ifference between machine and NC
sequence co-ordinate systems. When using(n tables it is often possible to save time
by patterning sequences or creating se subroutines, depending on your specific
requirements. It is therefore importafikt erstand the different types of CL data output
created by patterning and creating utines.

After completing this modul Il be able to:
* Describe the purpose ine and NC sequence co-ordinate systems.
* Describe the diffe etween machine and NC-sequence co-ordinate systems.

* Describe the diff s between patterning NC sequences and creating NC
sequence tines.

» Create NC sequeénces using different machine and NC-sequence co-ordinate
systems:

. Sequence subroutines.
. rn NC sequences.
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Machine and NC Sequence CSYS

Two Types of Co-ordinate System

Machine co-ordinate system
e Required
o Default origin for all CL data
e Program Zero in Operation Setup
o Modal
NC Sequence co-ordinate system
« Optional
« Specific to NC sequences

« Controls NC sequence data
Retract Plane
Cut Feed Direction

o CL data transformedirotated as required

Slide 4 [/ B02PTC
<

Machine and NC-sequence Co-ordinate systems %
There are two types of co-ordinate system that can be.spexified in manufacturing.

* Machine Co-ordinate system—Acts as the default in for all CL data. This
coordinate system is specified at the time of% tion setup. All NC sequences

created within a certain operation will use th Machine coordinate system. The
co-ordinate system setting is modal; on@ oes not change unless specified.

* NC Sequence—Is optional, and c to NC sequences. This coordinate system

is specified at the time of NC S@% € setup, and controls all the NC sequence data,
such as retract surface and ‘u-- direction.

* If the Machine and NC @nce coordinate systems are different, then, when
creating an NC s§ ceyall CL data will be transformed and output in the

coordinates of th ne coordinate system.

* If the Z axes@f the"NC Sequence and Machine coordinate systems are not parallel,
the tool gpientation vector (i,j,k) or table rotation command will also be created in the
. This depends on the configuration of the workcell and manufacturing
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Subroutines

® Create Subroutines of NC sequences
o Place subroutines at start of CL data files

o Call as required

® Reduces size of CL data file
PROGRAM EXAMPLE
© Easier to read and edit
o DEFSUB/1
® Applications —T--TTg
eIndex tables ! |
:NC-SEQUENCES |

o Tombstone fixtures |
|

CALSUB/1 \
CALSUB/1 D@

C ences, place them as
em from the main body of

o Turbine impellers

Subroutines
» Subroutine programming enables you to creat
macros at the beginning of the CL file, and.then

the CL file as many times as needed.
» This enhancement reduces the size of C{% making them easier for the
. o read and edit.

controller to handle and for the progrz
rk, multiple parts setup on a pallet, and

same.




Patterning NC Sequences

® Duplicates same sequence

® Co-ordinate System Patterns
o Translate/Rotate CL data
«One NC sequence additional CL data

® Reference Patterns
« References existing pattern !
Manufacturing Geometry
Mill Windows
. ——

Mill Volumes

Holemaking hole features
« Separate NC sequence for each instance D

Patterning NC Sequences %
 Patterning an NC sequence enables duplicatir@ C sequence multiple

times.

» There are two types of NC Sequence pat

» Coordinate patterns are created by tra g or rotating CL data with respect to
either the NC Sequence or the Machi dinate system.

* The result of this type of pattern | C sequence but additional CL data
created in the operation. <
e

* Reference patterns can b(@%yf> d only if the NC sequence to be patterned
references a patterned f or example, patterned holes for Holemaking, or
manufacturing geomegg;a as mill volumes or mill windows).

* The result of this ty@ ttern is separate NC sequences for each instance.
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Using Index Tables and Duplicating NC Sequences.

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

\}
D@

Demonstrations (1): %

* Using Index Tables and Duplicating NC Sequenc

Scenario @?X
ri

* Throughout this course, the exercise sc e the same as the demo scenarios.
Qe

* This has been done to build consistenc veen demos and lab exercises so as to
enable “Tell me—Show me—Let<>m N

Method &
Use the script in the instruct(@% use the same models as in the exercises.

Exercise >
Once the demo is;cd @a e the students should use the steps in the training guide to
complete the reises-

&
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Summary

After successfully completing this module, you should know how to:

® Describe the purpose of machine and NC sequence co-ordinate
systems.

® Describe the differences between machine and NC sequence co-
ordinate systems.

® Describe the differences between patterning NC sequences and creating
NC sequence subroutines.

® Create NC sequences using different machine and NC sequence co-
ordinate systems.

® Create NC sequence subroutines.

® Pattern NC sequences. @\

Summary %

After successfully completing this module, you sheuld K how to:
* Describe the purpose of machine and NC se co-ordinate systems.
 Describe the differences between machi C-sequence co-ordinate systems.
 Describe the differences between pattef@\@ sequences and creating NC
sequence subroutines. o
» Create NC sequences using di@ achine and NC-sequence co-ordinate

systems.
» Create NC sequence subr u

» Pattern NC sequences

N

Q)






(b PTC

Exercise 1: Using Index Tables and Duplicating NC
Sequences

Demonstration Instructions
Preparation \ S)
Complete the following tasks before running this demo for customers: @Q

Module 19 Lab Exercises

e Practice running the demo so you can easily complete it.
» Check for and review the errata sheet for this course. @
» Use Pro/ENGINEER Wildfire build code 2002380 or lat %

» Download and install the class files wi | df i re_ni NN ng/) 330. t ar . gz as described in

the classroom setup notes. \

Introduction

In this demonstration, you are give%a S te‘component that requires machining on two faces.
You place the component on a fix¢usetha ocated on a rotary index table. You create NC
sequences to machine the two@ ing one machine co-ordinate system and separate NC

sequence co-ordinate syst ach face. It is therefore important to understand the difference

between machine and nce co-ordinate systems.
To save time, yoyere broutines and patterns of the NC sequences and compare the

)5 therefore important to understand the different types of CL data output

N

created by erping and creating sub-routines, and apply the most appropriate technique based

on ma@ing quirements.

ives
fter successfully completing this exercise, you will know how to:
» Create NC sequences using different machine and NC sequence co-ordinate systems.
e Create NC sequence subroutines.

« Pattern NC sequences.

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 19-3



% PTC

You are given a sub-plate component that requires machining on two faces. You place the
component on a fixture that is located on a rotary index table. You create NC sequences to
machine the two faces using one machine co-ordinate system and separate NC sequence co-
ordinate systems for each face. To save time, you create subroutines and patterns of the NC
sequences and compare the different CL output.

Scenario

» @@\

Figure 1: Showing the sub-plate n& Di

Step 1. Open and check the sub_plate model for key dimef@qns and sizes.

We can locate the folder for this exercise and set this as @ing directory,

We can now open the sub_plate model. We need to@various features on the model to
determine key dimensions. We can start by<§el e of the hole features on the right face,
and by selecting the edit option in the dro % we can determine the hole diameter and
depth. We can repeat this process to the radius of the round features in the pocket on
the right face of the model, and the@ the pocket feature.

i it@gt already been started for you.

older Browser tab, and browse to
ire_mfg_330\module19, right-click, and select Make Working

1. Start Pro/ENGINEE

2. Inthe navigator, sel
c:\users\stu

Directory.
3. Open ~RLATE.PRT.
4. rn @ displayed datum features.
5. Ro the model, notice the pocket and two holes on the right face of the model, and the

identical holes and a pocket on the left face of the model.

6. Select one of the hole features on the right face of the model, as shown in the following
figure. Then right-click and select Edit from the drop down list. Note the hole diameter and
depth. Select in the background to de-select the highlighted geometry.
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Figure 2: Showing the selected hole dimensions. @\
7. Select one of the round features in the pocket on the right face of the<>T en right-click
and select Edit from the drop down list. Note radius size. Select in thebagkground to de-

select the highlighted geometry. @

R6

the selected protrusion feature.

Figur%:}\\;i‘%
8. Select the pocket feature @y t face of the model. Then right-click and select Edit from
e

the drop down list. No ket dimensions. Select in the background to de-select the
highlighted geomet

9. Close the wir@
(N

Step 2. Cyéa/t%a maﬁufacturing model and configure a manufacturing operation for the sub-plate.

We can crea new manufacturing NC assembly, and name it sub_plate; then load a
conf'g%on file to enable the manufacturing configuration options. We can assemble the
ste as a reference model. We decide that a workpiece is not required, because displaying

aterial removal is not critical for this job, so there is no need to assemble a workpiece.

We can then open the Operation Setup dialog box, and the Machine Tool Setup dialog box; and
create a workcell named makino. We can also retrieve the RGH_3_AXIS_MIL.sit site parameter

file from the site_files folder.

We can then open the Fixture dialog box and name the fixture setup op_010. We can now add a
component to the fixture setup; in this case we select the fixture part from the list. We can

position the fixture using one mate constraint and an insert constraint. Notice only two constraints

Creating Milling Sequences with Pro/ENGINEER Wildfire Page 19-5
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are required because assumptions are made that enable the fixture to be placed. You can disable
assumptions and add additional constraints If required. When assembled, we can close the

fixture setup.

In the Operation dialog box, we can select the workpiece material from the Stock Material drop-

down list; the list of materials corresponds to the material sub-folders within the tools folder.

Ensuring that co-ordinate systems are displayed, we configure a program zero co-ordinate
system by selecting the co-ordinate system on the fixture. There is no need to configure the
retract surface because this will be configured individually for each NC sequence. This com%s
the operation configuration.

1. Load the configuration file config.pro from the module19 folder to enable th::) acturing

configuration options.
2. Create a new manufacturing model for the mold cavity, click File > WE, -::‘ the
Manufacturing and NC Assembly options, and name it [SU ]-

odel and assemble

3. Using the Menu Manager, select Mfg Model > Assemble >
SUB_PLATE.PRT as the reference model.

«
Note: O
Workpieces are optional components within tﬁ@ufacturing model, in this case

because material removal is not critical fi opgeration we decide not to use a
workpiece. <

LAY
4. Using the Menu Manager, open th@c\r}ﬁbn Setup dialog box.
o

5. Open the Machine Tool Setup (dial X, and retrieve the makino.gph workcell.

E u@ box, select Defaults.

6. Inthe Machine Tool S¢
%- fory and Mill options, retrieve from the site_files folder the
site parameter file.

7. Using the Curr
RGH_3_AXI

8. Close the Machine“Tool Setup dialog box.

10.

9. O n@x re Set Up dialog box, type [0p_010] as the fixture setup name.
0 @component to the fixture setup; select fixture.prt from the list.

11. Assemble the fixture, as shown in the following figures. Create a mate constraint and an
insert constraint.
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Figure 4: Showing selected surfaces for mate constraint.

Figure 5: Showing selected surfacert constraint.
Note: \
Only two constraints are required be0@p mptions are made that enable the

fixture to be placed. You can disable umptions and add additional constraints If

required.
O
12. Complete the fixture setup. 3@

Figure 6: Showing the completed fixture set up.

13. In the Operation dialog box, select STEEL-100BHN in the Stock Material drop-down list.
14. Turn on the display of co-ordinate systems, if not already visible in the graphics window.

15. Click the Machine Zero icon, using the Select option select the co-ordinate system on the
fixture named MACH_0 as machine zero co-ordinate.

Creating Milling Sequences with Pro/ENGINEER Wildfire

Page 19-7



(b PTC

Note:
The retract surface will be configured individually for each NC sequence.

16. Close the Operation Setup dialog box. Save the manufacturing model.

Step 3. Create a holemaking sequence to drill the two 10-millimeter holes, on the right face.

Using the Menu Manager, we can create a holemaking sequence. We can specify the drill cycle
type as standard. We can select Name, and Coord Sys as additional options to be configured.
Enter a name for the sequence to make it easy to identify, and retrieve the 10-millimeter drill ftam

the drills folder. We can also retrieve drilling parameters to set standard drilling parametek v S.

We need to specify a NC sequence co-ordinate system and retract plane. We can
face_1 coordinate system on the right face of the sub-plate, and specify the rigact ptane as 50-

millimeters along the z-axis.

Using the Hole Set dialog box, we can use the axis tab and select th es on the right face.

We can specify the depth options as auto and tip.

We can play the tool path to check the configuration, and t%%g mplete the sequence.
1. Using the Menu Manager, create a Holemakin@ e.

2. Specify the holemaking cycle type, as D<§ill tandard.

3. Selectthe Name and Coord Sys ch es in the Sequence Setup menu.

4. Name the sequence [dr | _ri ght].

5. Inthe Tools Setup dialog baox, he Retrieve Tools icon and select the mmdrl_10.tpm
tool from the drills fol §>

6. In the Parameterg>m
folders, and seléciftie

lect Retrieve, then double-click the dflt_hmaking and metric
lling.drl parameter file.

7. Forthe NC&:&gue e co-ordinate system, select the FACE_1 coordinate system on the right
-plate.

face ofﬁ
8. th ct Selection dialog box, click the Along Z Axis button and type [50] (7.97 in) as
f distance. Preview the position of the retract plane, and close the dialog box.

9. Inthe Hole Set dialog box, click the Add button, and select the two holes on the right face for
machining,

10. Complete the hole set configuration.
11. Play the tool path. Ensure the CL data is visible.

12. Complete the NC sequence.
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Figure 7: Showing resulting tool path.

Step 4. Create a holemaking sequence to drill the two 10-millimeter holeé&)n tﬂé left face.

We can now repeat the process to drill the two holes on the left fac
as standard. We can

We can create a holemaking sequence, and specify the drill cy@

select Name, and Coord Sys as additional options to be confi “Enter a name for the

sequence to make it easy to identify, and use the previous ence drilling parameters.

We need to specify a NC sequence co-ordinate s, d retract plane. We can select the
face_2 coordinate system on the left face o @ ate, and specify the retract plane as 50-

millimeters along the z-axis.

Using the Hole Set dialog box, we %9?& axis tab and select the two holes on the left face.
apd tip

We specify the depth options as a L
We can play the tool path @e configuration, and then complete the sequence.

An alternative to creatin @dual NC sequences to machine each face is to create subroutines
or pattern NC se e can explore both options. First, we need to remove the second

drilling seq

1. Us'ﬁjvhe nu Manager, create a Holemaking sequence.

the holemaking cycle type, as Drill and Standard.

2 2
. lect the Name and Coord Sys check boxes in the Sequence sSetup menu.

Note:

Notice Retract is automatically selected in the Sequence Setup menu after Coord
Sys is selected. There is no need to select tool as the same tool will be used.

4. Name the sequence [dr| | eft face].

5. Use the previous sequence parameters.
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6. For the NC sequence co-ordinate system select the FACE_2 coordinate system on the left
face of the sub-plate.

7. In the Retract Selection dialog box, click the Along Z Axis button and type [50] (1.97 in) as
the z distance. Preview the position of the retract plane, and close the dialog box.

8. In the Hole Set dialog box, click the Add button, and select the two holes on the left face for
machining.

9. Complete the hole set configuration.

10. Play the tool path. Ensure the CL data is visible.

11. Complete the NC sequence. K/NQ
N/

Note:

An alternative to creating individual NC sequences to machine each f to create
subroutines or pattern NC sequences. We can explore both optio% e need to

remove the second drilling sequence.

12. In the model tree, select the drl_left_face sequence, @tw Delete it.
Step 5. Create a subroutine of the first NC sequence to drj 5% in the left face of the sub plate.
Check the subroutine output by editing the CL d ilg=of the operation.

Using the Menu Manager, we can create a subrouti fan NC sequence and select the
holemaking sequence. In the Subroutine diajog e can configure the subroutine to rotate the
NC sequence about the y-axis of the mac@% -ordinate system by 180 degrees. When the
configuration is complete notice the su@g s not listed in the model tree as an NC sequence,
the only way to check the output o@s outine is to create a CL data file.

Using the Menu Manager, w@g a CL data file for the operation by using the edit option; this
not only creates the CL d le~but also enables us to view the resulting CL data immediately. In
the CL edit menu, © the next option to single step through the tool path. Notice a
subroutine definitiongt the’beginning of the CL data file. The subroutine is called first to drill the
holes on the r@%’jce, then a rotate command is output which (in reality) rotates the index table

by 180 e‘ | e subroutine is then called again to drill the holes on the left face.
An ative is to remove the subroutine definition and call statements from the CL data file; this

can be achieved by selecting the Copy CL option when configuring the subroutine. We can
redefine the subroutine, and select the Copy CL option in the Subroutines dialog box. We can
then re-edit the CL data file for the operation. Notice, there are now no subroutine definitions or
call statements. The tool drills the holes on the right face first then outputs a rotate command that
(in reality) rotates the index table by 180 degrees about the Y-axis. The tool then drills the holes

on the left face.
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The options within the Subroutine dialog box enable modification of CL data output to meet

different requirements.

1. Using the Menu Manager, select Machining > Subroutines to create a subroutine; select
the DRL_RIGHT_FACE sequence check box for the subroutine.

2. In the Subroutines dialog box, select the following options:

Table 1: Subroutine dialog box options “
Option Name Selection Explanation X2\
Pattern Style Individual Each selected sequence is patterned indivi%ﬁﬂy\ 2)
CL Output Style | Absolute CL data output in absolute mode
Pattern Type Rotate Rotating pattern KK ))
Base Coordinate | Machine Rotate about the machine co-ordi ate%m
System fé}n
Number 2 Number of instances, incly{é@g\\fhe{riginal NC sequence
Rotate Angle 180 Angle of rotation, outpat\\lb\\(ijﬁéta file
Rotate Axis Y Rotation axis, can Be\\)gﬁ rz.

3. Close the Subroutine dialog box, and cogg\le@gsubroutine definition.

Note:
The selected dialog box optiohs.c a subroutine definition at the beginning of the
CL data file. This subroutingwil called twice to machine the right and then the left

faces of the sub-plate

Notice the subroutin@}g@ed in the model tree as an NC sequence, the only

way to check the&; ut pf the subroutine is to create a CL data file.

4. Using the Me er, select CL Data > Edit > Operation > OP010, Confirm the
creatio a L data file, and click OK to accept the name of op010.ncl.
5. Inthe itmenu, use the Next option to single step through to the end of the CL data file.

§ DEFSUE / 1
<:::> CYCLE / DRILL, DEPTH, 15.000000, MMPFM, 120.000000, CLEAR, =.000000

10 oTo / 75.0000000000, 20.0000000000, -35.0000000000, &5
11 1.0000000000, O.0000000000, O.0000000000

12 coTo / 75.0000000000, Z20.0000000000, 35.0000000000, &
13 1.0000000000, O.0000000000, O.000O00OO0DOCO
14 CYCLE / OFF
15 RAPID
16 coTo 4/ 125.0000000000, 20.0000000000, 35.0000000000, 5
17 1.0000000000, O.000O0Q00000O0, O.00O0O00OO0ODOCO
18 ENDEUE

Figure 8: Showing the subroutine definition in CL data file.
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Note:

Notice a subroutine definition at the beginning of the CL data file. The subroutine is
called first to drill the holes on the right face, then a rotate command is output which
(in reality) rotates the index table by 180 degrees. The subroutine is then called
again to drill the holes on the left face.

An alternative is to remove the subroutine definition and call statements from the CL
data file. This is achieved by selecting the Copy CL option when configuring the
subroutine.

6. Complete the editing, and return to the Manufacture menu.

menu.

8. In the Subroutines dialog box, click the Copy CL check box, close the @box, and return
to the Manufacture menu.

9. Using the Menu Manager, select CL Data > Edit > Oper n > 010, Confirm the
creation of a new CL data file, and click OK to accept the nam p010.ncl.

10. In the CL Edit menu, use the Next option to single stm h to the end of the CL data file.

NS
Note: @
Notice there are no subroutine definition statements. The tool drills the holes
on the right face first then outputs a rotat and which (in reality) rotates the
index table by 180 degrees about t -axis. The tool then drills the holes on the left
face.

The options within the Subroytine'diglog box enable modification of CL data output
to meet different requiren{g .

11. Quit the CL Edit me

Step 6. Create a @ Mg sequence to machine the pocket on the right face of the sub-
plate.

Using the Me/ﬁ%anager, we create a volume milling sequence, and select Name and Coord Sys
and Wi d@a ditional options in the Sequence Setup menu. We can name the sequence and
retrieye e ~10-millimeter flat end mill from the metric_tools folder. We can modify the

ROU STOCK_ALLOW to zero and set the SCAN_TYPE to TYPE_SPIRAL.

We need to specify a NC sequence co-ordinate system and retract plane. We can select the
face_1 coordinate system on the right face of the sub-plate, and specify the retract plane as 50-

millimeters along the z-axis.

We can create a mill window named wnd_right to define the volume for machining, and select the

chain of edges at the top of the pocket on the right face to configure the mill window. Notice the
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mill window is created at the retract plane height for the NC sequence. To avoid air machining,
we need to redefine the mill window plane. In the Mill Window dialog box, we can select the plane
option to define a new plane position, and select the right surface of the sub-plate, we can
preview the mill window to confirm the change. This completes the mill window configuration. We
can play the toolpath to check the sequence configuration and complete the sequence.

1. Using the Menu Manager, create a Volume milling sequence.

2. Select Name, Coord Sys and Window check boxes. \

3. Name the sequence [vol _ri ght]. @

4. Inthe Tools Setup dialog box, click the Retrieve Tools icon and sele t10.tpm tool
from the metric_tools folder.

5. Modify the following parameters: @

Table 2: Changed Para

Parameter Value ))
ROUGH_STOCK_ALLOW | R\
SCAN_TYPE TYPE\SPIRAL
CUTCOM e’

<&
at

6. For the NC sequence co-ordi select the FACE_1 coordinate system on the right
face of the sub-plate. &

7. In the Retract Selection djal X, click the Along Z Axis button and type [50] (7.97 in) as
the z distance. Preview thg position of the retract plane, and close the dialog box.

8. Create a mill Wi ed [wnd_r i ght ] to define the volume for machining.

9. Using the'Se nd Tangent Chain options, select the chain of edges at the top of the
pocke %ight face. Preview the mill window.

<l%te:
< otice the mill window is created at the retract plane height for the NC sequence. To
void air machining we need to redefine the mill window plane.
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Figure 9: Showing the previewed mill window at height of retract plane. X

10. In the Mill Window dialog box, select the Plane element and Define a new p
Ve 'ﬂ)

11. Select the right surface of the sub-plate, as shown in the following figure. Pre e mill
window, then complete the mill window configuration. @

Figure 10: Showi@lected surface for mill window plane.
12. Play the tool path. Ensuret@@ta is visible.

Figure 11: Showing the resulting tool path.

13. Complete the NC sequence, and hide the mill window in the model tree.

Note:

As an alternative to creating a subroutine, we can pattern the volume milling
sequence to machine the pocket on the left face.
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Step 7. Pattern the volume milling sequence to machine the pocket on the left face.

We can now pattern the volume milling sequence to machine the pocket on the left face. Using
the Menu Manager, we can create a pattern of an NC sequence, and select VOL_RIGHT as the
sequence to pattern. We can configure the pattern to rotate the NC sequence about the y-axis of

the machine co-ordinate system by 180 degrees.

Notice the VOL_RIGHT volume milling sequence is now listed within a pattern in the model tree.

The patterned sequence cannot be accessed directly for checking, the only way to checkthe
output of the pattern is to create a CL data file. If required the pattern can be modiﬂ%

Menu Manager.

1. Using the Menu Manager, select Machining > Utilities > Pattern equence to
create a pattern of an NC sequence, select VOL_RIGHT as th@ence to pattern.

2. Progressively select the following options during the patterr(% tion:

Table 3: Pattern N}%

Menu KQption
Pat Type «Q%Pattem

Pat Type (first direction) v @};?ate
Enter Value (rotation ad&a) Enter, 180

Rot Type ((\\ Mach Csys

Rot Type «, N4 Index Table
Rot Type /\V\Q Y Axis

Rot 'I;xgek)(O)v Done Rot
EQ{e(r\ allje (instances) Enter, 2

@t\%;pe (second direction) | None

w[] Cut botion id 35
<! Customizeid 34

@ S [ Pattern (2. VOL_RIGHT)
& 5 g? 2. VOL_RIGHT [OP010]

Figure 12: Showing pattern in model tree.

Note:

Notice the VOL_RIGHT volume milling sequence is now listed within a pattern in the
model tree. The patterned sequence cannot be accessed directly for checking,
because the only way to check the output of the pattern is to create a CL data file. If
required the pattern can be modified via the Menu Manager.
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Step 8. Edit a CL data file for operation op010.

Using the Menu Manager, we can create a CL data file for the operation using the edit option.
This not only creates the CL data file but enables us to view the resulting CL data immediately. In

the CL Edit menu, we can use the next option to single step through the tool path.

Notice the holes are drilled on the right and left faces using an NC sequence subroutine. Then the
pocket on the right face is machined, and the pocket on the left face is machined using a

patterned NC sequence.

1. Using the Menu Manager, select CL Data > Edit > Operation > OP010, Confir, \
creation of a new CL data file, and click OK to accept the name of op010.ncl.
data file.

2. Inthe CL Edit menu, use the Next option to single step through to the end of

Figure 1@%%@@% resulting operation tool path.

Note @

Notice the holeg a edon the right and left faces using an NC sequence
subroutine. ket on the right face is machined, and the pocket on the left
face is mac jng a patterned NC sequence.

Patterns@nd subroutines provide a comprehensive set of options for duplicating NC
AN

3. ui M Edit menu.

4. Save’the manufacturing model.

5. Close all windows and erase all components from memory.

6. To clear all configuration options, click File > Exit > Yes to exit from Pro/ENGINEER.
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Summary

After successfully completing this module, you should know how to:

Describe the purpose of machine and NC sequence co-ordinate systems.
Describe the differences between machine and NC-sequence co-ordinate systems.

Describe the differences between patterning NC sequences and creating NC sequence
subroutines.

Create NC sequences using different machine and NC-sequence co-ordinate an.
Create NC sequence subroutines. @
Pattern NC sequences. @

>
Q
O
N
B
S
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Module

20

Automating Workflow with Mapk\exs

Introduction @

Mapkeys enable you to save commonly used selecquences into a macro

called a mapkey. Mapkeys can be started via k% fdinput, or they can be

&4

stored in your toolbar or menu bar, you ca mapkeys with a single
mouse click. Mapkeys are useful beca the le you to automate and
speed up your workflow.

Objectives @j\
After completing this modulg( youwill be able to:

e Describe the uges keys.

e Describe the prqocess of creating mapkeys.

* Create an@mapkeys.

Page 20-1



Creating Milling Sequences with
Pro/ENGINEER Wildfire

Module 20: Automating Workflow with Mapkeys

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Lesson Activities: Day Five

Using Index

Configuring the - Automating ProfFICIENCY
Manufacturing === M;::]':c"t‘“ == Du‘["""c'a':";"‘;c_ = Workflow with Daily
| Environment } ] P Gequences Mapkeys Assessments

I

"Bamos | configuring the [T checkingand [ Using Index Automating
Tables and
i Geomet Duplicating NC- Workflow with
Environment ry rdlow w

Manufacturing Model
and Manufacturing
Operation for the Casing

Configuring the |77 Checking and [77777] Using Index Automating
Labs ing || | Tablesand Workflow with
Environment Geometry Duplicating NC- Mapkeys

I

Manufacturing Model
and Manufacturing
Operation for the Casing

Machining the
Casing (Challenge)

Duration

Lecture: 10 mins
* Demos : 20 mins
Labs : 30 mins
Total: 1 hr 0Omins

@@
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Objectives

After completing this module, you should know how to:
© Describe the uses of mapkeys.
© Describe the process of creating mapkeys.

® Create and use mapkeys.

@\%

Overview %

Mapkeys enable you to save commonly used selection sequ into a macro called a
mapkey. Mapkeys can be started via keyboard input, or n be stored in your toolbar or
menu bar, where you can then use mapkeys with a Single mouse click. Mapkeys are useful
because they enable you to automate and speed upy workflow.

‘07
After completing this module, you will be able tQ:

» Describe the uses of mapkeys. o @
* Describe the process of creating r@% S

« Create and use mapkgs@ @@
@@&@
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Mapkeys Overview

Mapkeys
® Automate common actions

® Improve efficiency

Creating Mapkeys
® Configure keys for starting

® Record selections and keyboard input

® Test mapkey
©® Save mapkey
« Stored in configuration file @

Mapkeys Overview %
* Mapkeys enable you to automate combinations of comm ed menu picks. You can
create a mapkey for virtually any task you perform frequently within Pro/ENGINEER.

» Using mapkeys can save you time performing frequent tasks.

 Creating mapkeys involves: @
« Selecting a unique combination of keys\toyun the mapkey.

» Recording the selections and e<> @nput.
 Testing the mapkey, ensurin pkey works as intended.

 Saving the mapkey to a con ion file.
» Mapkeys can be st&@ configuration files for retrieval and future use.

S
@@&@



A WVl

Mapkeys Overview

Features

Pause for user input
o Screen Selections (automatic)
o Keyboard
e Dialog Box

Running mapkeys

o Keyboard [ Manufacturing
« Add to menu bar @PnstRPmcessur N2 vy e
e Add to tool bar ‘Exe(ute mapkey "Post-Processor \
Icons
P_ﬂ P LIy PR T
Nesting mapkeys \Exe(ute mapkey "Post-Processor”. @
Slide 5 ©2002 >

@

Mapkeys Overview %
* When creating mapkeys, you can pause the mapkeydor s selections, this happens
automatically.

* You can also optionally pause for user input from keyboard or dialog box.

» Mapkeys can be run from the keyboard by@ in a unique combination of keys.
rt

* For example ‘md’ may run a mapke the measure dialog box and prompt the
user to measure the distance be \& o entities.
r

* Mapkeys can also be stored in tg %%3 s icons or in menu bars as additional menu
commands.

* You can also nest one ma ithin another, so that one mapkey starts another. To do
S0, you include the map ame in the sequence of commands of the mapkey you are

creating. @

&
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Demonstration

In this module, you will follow the instructor as they perform the
following demonstration:

® Creating and Using Mapkeys

Once the demonstration is complete, you should use the steps in the
training guide to complete the exercise.

QO

Demonstration: Creating and Using Mapkeys %

Scenario
* Throughout this course, the exercise scenarios %%e same as the demo scenarios.

» This has been done to build consistency betw: os and lab exercises so as to enable
“Tell me—Show me—Let me do.”

Method O@
Use the script in the instructors gui E%%\% e same models as in the exercises.

Exercise

Once the demo is com t@tudents should use the steps in the training guide to complete
the exercises.

Q)
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Daily Skill Checks

Evaluate your progress:
® Achieve the course objectives.
® Use Pro/FICIENCY assessment questions.
® Apply Precision Learning.

Precision Learning %
* Learn: by listening to lectures, watching demos, and,.co g lab exercises.
» Assess: your progress with Pro/FICIENCY.

* Improve: The next day the instructor reviews th m results of the group and reviews
those topics that received the fewest correct a

N

Getting Started
* Before lunch on the first day of clas$ @ the customer accounts.
* When the customers are returni unch refer them to the new Appendix.
* Have them take the sample e @?
* Review the results of th % nd use as an icebreaker.

Daily Tests

Description: For e@ 5 new 10 question exams based upon the topics covered each

day.

How to s
omer accounts already setup for the sample exam.

. At th nd of each day the customers take the 10 question exam relating to that days’
topics.

» The next morning, review the results of the group.
* Review those topics with the class that obtained the most incorrect answers.
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Summary

After successfully completing this module, you should know how to:
© Describe the uses of mapkeys.
© Describe the process of creating mapkeys.

© Create and use mapkeys.

QO

Summary %

After successfully completing this module, you should kn to:
* Describe the uses of mapkeys.

 Describe the process of creating mapkeys. @
* Create and use mapkeys.
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Module 20 Lab Exercises
Exercise 1: Automating Workflow with Mapkeys

Demonstration Instructions

Preparation
Complete the following tasks before running this demo for customers: \
e Practice running the demo so you can easily complete it. @@

» Check for and review the errata sheet for this course.
 Use Pro/ENGINEER Wildfire build code 2002380 or later.

» Download and install the class fileswi | df i re_mi I | = .tar. gz as described in

the classroom setup notes.

Introduction @;\
a

In this demonstration, you need to create a @/ t records creating and post-processing a
CL data file. You record the mapkey an@ that the mapkey pauses for user input at the

<
correct time. You verify the mapk \% rectly for all available post-processors. Mapkeys
are useful because they enabl1E omate and speed up your workflow.
Objectives @

After successfullycofgle this exercise, you will know how to:

* Create keys.

Scenario

a st-processing a CL data file. You record the mapkey and ensure that the mapkey pauses
uSEr input at the correct time. You test the mapkey works correctly for all available post-
rocessors.

To l|e up the post-processing procedure, you need to create a mapkey that records creating

Step 1. Open the cover manufacturing model.

We can locate the folder for this exercise and set this as our working directory. We then load a
configuration file to enable the manufacturing configuration options. We can then open the cover

manufacturing model.

1. Start Pro/ENGINEER if it has not already been started for you.
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2. In the navigator, select the Folder Browser tab, and browse to

c:\users\student\wildfire_mfg_330\module20, right-click, and select Make Working
Directory.

3. Load the configuration file to enable the manufacturing configuration options. Click Tools >
Options, use the Open a Configuration File icon and select the config.pro file from the
module20 folder. Then Apply and, Close the Options dialog box.

4. Open COVER.MFG. Turn off any displayed datum features.

Figure 1: Showing the(cgsﬁ anufacturing model.

Step 2. Create and test a mapkey to crea&/)éhqurocess CL data files.

We need to record a mapkey to create@& -process a CL data file. Using the tool bar, we
can open the Mapkeys dialog box gure a key sequence and name for the mapkey. We
can then begin to record the %N ing the Menu Manager, we can step through the

il

commands to create a CI\a 'hen the list of operations displays, we pause the mapkey,

type in a resume pro, @ fthen continue recording the mapkey. When the post-processor list

displays, we paus pe in a resume prompt and then complete the recording of the

mapkey.
We can t &he mapkey, and select an operation and a post-processor when prompted.

Whet' saty the mapkey is running correctly, we can save the mapkey to the config.pro file,

and c the Mapkeys dialog box.

1. In the menu bar at the top of the graphics window, click Tools > Mapkeys, in the Mapkeys
dialog box, click the New button.

2. In the Record Mapkey dialog box, type [pp] in the Key Sequence text box, and type [Post
Pr ocess]in the Name text box, then click Record.
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Note:
Every menu pick is now recorded in the mapkey.

ol

Using the Menu Manager, select CL Data > Output > Operation, when the operation list
displays, click the Pause button in the Record Mapkey dialog box.

4. Type in the resume prompt [Sel ect Oper at i on], and click OK in the resume prompt

window, then select OP010 from the list of operations, and continue the mapkey by clicking
the Resume button.
ne/) and

o

click OK to accept the default name of op010. Accept the Verbose and ptions,
and select Done. When the PP List displays click the Pause option i Mapkey
dialog box.

Continue recording the mapkey, in the Menu Manager select File > MCD I;@
Record

6. Type in the resume prompt [Sel ect a Post - Processor @Iick OK in the resume
prompt window, then select UNCX01.P01 from the list of = ssors, wait for the post-
processor to run, then complete the mapkey by clicking %utton in the Record Mapkey
dialog box.

7. Close the information window created when the t-processor was selected.

¢
Note: @
When you run the mapkey the resum@@ﬂs will suspend the mapkey until you

have made a selection and then @e esume.

<
8. Test the mapkey; click the Rl};@n in the Mapkeys dialog box.

9. When prompted selec@ op010, and then click Resume.

NCX01.P01 post processor.

10. When prompted@
11. Check the m successfully by reading the information window created when the
post-progess selected. Then close the information window.

12. Click Re to complete the mapkey.

o3
QN%e.
() the mapkey has failed for whatever reason delete the mapkey and create it again.

. If the mapkey has failed, delete it and repeat steps 2 to 12 again.

14. When satisfied the mapkey is running correctly, click the Save button, to save the mapkey to
the config.pro file.

15. Close the Mapkeys dialog box, and return to the Manufacture menu.
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Note:

Mapkeys can be saved with other configuration options in the config.pro file, they
can then be re-used when required.

Step 3. Run the mapkey from the keyboard; check it runs correctly for all post-processors.

We can now test the mapkey from the keyboard by typing in pp; this starts the mapkey. We can

select operation op010 when prompted, and select the UNCX01.P01 post-processor when

prompted. We repeat this process and check the mapkey is running correctly for all availa
post-processors.

In summary, the mapkey now runs correctly from the keyboard, and can be used cess

any operation with any post-processor. This completes the mapkey configuration.

1. Run the mapkey from the keyboard by typing [pp]. @

2. When prompted select operation op010, and then click Resu %

3. When prompted select the UNCX01.P01 post processor.

4. Check the mapkey ran successfully by reading the infi n window created when the
post-processor was selected. Then close the informa@mdow.

5. Click Resume to complete the mapkey.
6. Repeat steps 1 to 4, each time select a<>' e@ost—processor during step 3. Ensure the
mapkey runs correctly for all post-processo

Note: 6@

The mapkey now runs corre@jm the keyboard, and can be used to post-process
any operation with any & essor.

AN
7. Close all windowg’a o@ se all components from memory.

&
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Summary

After successfully completing this module, you should know how to:

» Describe the uses of mapkeys.
« Describe the process of creating mapkeys.

« Create and use mapkeys.
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Appendix

Creating Auxiliary Milling Sequences

\‘
Introduction @

Auxiliary NC sequences are created by manually buj a CL data file. They
can be used to specify the connecting tool moti @ange the tool axis
orientation, if needed, between two machint quences. They also allow
you to access the on-machine probe fu inserting CL commands.
Auxiliary NC sequences are available for rkcell type, and can be
performed with any type of tool. Thexcan produce tool paths that cannot be
created with other types of NC s

Objectives @
After completing thfs, you will be able to:

. Describet?z@%&?"@ milling process.

. Crea@ milling sequences by defining tool motions and inserting CL
d

8
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Appendix A: Creating Auxiliary Milling Sequences

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@gl? Wildfire, you must have read

» General Information @9
» Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation
* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
» Review Pro/E ildfire Milling training materials in Windmill, located in

/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN
/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
+C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
* Good understanding of manufacturing processes and terminology
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Objectives

After completing this module, you should know how to:
® Describe the auxiliary milling process.

® Create auxiliary milling sequences by defining tool motions and inserting
CL commands.

@\%

Overview %

Auxiliary NC sequences are created by manually building a a file. They can be used to
specify the connecting tool motions and change the tool axis grientation, if needed, between
two machining NC sequences. They also allow you tG.access the on-machine probe
functionality by inserting CL commands. Auxiliary uences are available for any workcell
type, and can be performed with any type of tool. @‘zan produce tool paths that cannot be
created with other types of NC sequence.

After completing this module, you will b@a\@:

* Describe the auxiliary milling proc
* Create auxiliary milling sequenc@w defining tool motions and inserting CL commands.

N
&@6
Q®
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Auxiliary Milling

Overview
® Manually build CL data file

» Select or sketch tool motions
eInsert CL commands
oE.g.

Feed rate

Spindle speed

Coolant

Probe functionality

® Tool optional

17 SPINDLON, 200.000000,RP, CLYW

18 COOLMT/ON \
19 RAFID
20 GOTO /400000000000, 500000000000, 5 0000000000

21 FEDRAT /300.000000, hMMFM
22 GOTO [ 40.0000000000, 500000000000, 200000000000
23 CUTCOM/OMN

Auxiliary Milling %
* Creating auxiliary NC sequences involves manually build CL data file
* You can configure tool motions by sketching xele g existing geometry for the tool

coolant, and cutter compensation. You€an also insert CL commands that access on-

to follow.
* You can also insert CL commands to c@@example, feed rate, spindle speed,
machine probe functionality

* You do not have to specify a t %Qan Auxiliary NC sequence. You will be able to
create Tool Motions even th tool is specified.

©©
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Exercise

In this module, you complete the following exercise:

© Creating Auxiliary Milling Sequences

Use the steps in the training guide to complete the exercise.

Exercise: Creating Auxiliary Milling Sequences %

Exercise

Use the steps in the training guide to complete the %%ses.
O
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Summary

After successfully completing this module, you should know how to:
® Describe the auxiliary milling process.

© Create auxiliary milling sequences by defining tool motions and inserting
CL commands.

QO

Summary %

After successfully completing this module, you should kn to:
» Describe the auxiliary milling process.

 Create auxiliary milling sequences by definin@@otions and inserting CL commands.
o \(: :)
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Appendix A Lab Exercises

Exercise 1: Creating Auxiliary Milling Sequences

Objectives

After successfully completing this exercise, you will know how to:

* Create auxiliary milling sequences by defining tool motions and inserting CL C(}X .

Scenario @
You need to create an auxiliary milling sequence to profile the sidewalls o‘@ - on the top
face of the sub plate model. You create an auxiliary milling sequence by codfigdring tool motions

and inserting CL commands. You check that the CL data in the tool@s correct.

9

F@%ghlighting pocket in sub plate model

=~

Step 1. Locate and open fﬁq cPver manufacturing model.

1. In the folder
c:\usergist

rowse through the folders and locate the directory:
f\manufacturing_330\moduleA1.

2. Open I Y.MFG.

3. Tﬁ%ﬁ any displayed datum features.

™
Sfép\j) Create an auxiliary milling NC Sequence to profile the pocket in the top of the sub plate.

Using the Menu Manager, create an auxiliary milling sequence.
2. Selectthe FEM_012_0 tool.

3. Accept the default parameter settings.

Note:

Note the reduced list of parameters for auxiliary sequences. This is because the
toolpath is created manually.
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Step 3. Insert CL commands to turn on the spindle and coolant.

1. Using the Customize dialog box, insert a CL Command.
2. Inthe CL Command dialog box, select Menu.

3. To turn the spindle on, complete the following list of selections. Click SELCTL-TMARK >
SPINDL > ON > speed, and type [200]. Click RPM > CLW > QUIT OPTIONS > QUIT
OPTIONS. The command should appear in the Enter Command section.

4. To turn the coolant on, select Menu again and complete the following list of selections. Gl
COOLNT-FROM > COOLNT > ON. The command should appear in the Enter C(@

section.
Setup CL Command @

Enter Commancd Y EG @

SPIMNDLOMN, 200.000000,FFPR.CLW
COOLMNT/OMN

Figure 2: Showing the resulting (@
5. Complete the CL command configuration. %

&
Note:
Notice the CL commands appear in tge @f indow.

o
Step 4. Insert a Goto Point tool motion, /aﬁd\\spg\éfy a feed rate.

¢
1. Before proceeding, turn on the@ f datum points.

2. Using the Customize dial , insert a Goto Point.

Figure 3: Showing point on left side of pocket

4. Inthe Goto Point dialog box, specify a feed rate of [300] (711.87 in), specify the feed units as
MMPM.

5. Complete the Goto Point configuration.
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Note:
Notice the GOTO tool motion appears in the CL Data window.

Step 5. Insert a CL command to turn the cutter compensation on.

1. Using the Customize dialog box, insert a CL Command.
2. Inthe CL Command dialog box, select Menu.

3. To turn the CUTCOM on, complete the following list of selections. Click COOL

M >

CUTCOM > ON > QUIT OPTIONS > QUIT OPTIONS. The command sr@ eat/in

the Enter Command section.
17 SRINDLOMN, 200.000000,RP, CLW @
18 COOLMTAHON

19 RAFID
2l GOTo/4n.0000000000, 50.0000000000, E%D

21 FEDRAT /300.000000, MAPRA
22 GOTO/40.0000000000, 50.000000000D annoo
23 CUTCOROMN

Figure 4: Showing the CL datﬁwth inserted commands.

4. Complete the CL command configuration @
° N\

Note: \
Notice the CUTCOM commaﬁ@@s in the CL Data window.
o

Step 6. Insert a follow sketch @}n@%n to machine the profile of the pocket.

1. Using the Custom|z§ box insert a Follow Sketch tool motion.

og box, select Sketch. Select the bottom surface of the pocket as

the sketc « : and select the right face of the sub plate as the right sketching reference.

of the pocket, type a value of [- 6] (0.24 in) as the offset.

Figure 5: Showing offset loop of edges

ect the Offset Edge icon, and use the Loop option, then select the surface

Creating Milling Sequences with Pro/ENGINEER Wildfire

Page A-5



(Cb PTC

4. Complete the sketch, and complete the follow sketch configuration.

Note:
Notice the follow sketch tool motion appears in the CL Data window.

Step 7. Insert a CL command to turn the cutter compensation off.

1. Using the Customize dialog box, insert a CL Command.

2. Inthe CL Command dialog box, select Menu. \%
3. Toturn the CUTCOM on, complete the following list of selections. Click COOLNT-

CUTCOM > OFF > QUIT OPTIONS > QUIT OPTIONS. The command sh rin
the Enter Command section.

4. Complete the CL command configuration. @
0

N4
Note: %
Notice the CUTCOM command appears in the CL Data w@%

Step 8. Insert a Goto Point tool motion, to move the tool aw%%(rom the profile.

1. Before proceeding turn on the display of datum poi @
t

2. Using the Customize dialog box, insert a Gm@
<

3. In the Goto Point dialog box, specify %
the pocket, as before.

4. Complete the Goto Point configz;'ta
A
=
Note: @
Notice the GOTO % appears in the CL Data window.

N

5. Complete the mjzation.

et Point, Select the point on the left side of

6. Playthe t@%ath using the Screen Play option. Ensure the CL data is visible.

Figure 6: Showing the resulting tool path.
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7. Check the format and position of the inserted CL data commands in the tool path file.
8. Save the manufacturing model.

9. Close all windows and erase all components from memory.
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Summary

After successfully completing this module, you should know how to:

» Describe the auxiliary milling process.

»  Create auxiliary milling sequences by defining tool motions and inserting CL commands.
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Appendix

Creating Pocket Milling Sequences

\‘
Introduction @

Pocket milling sequences are typically used after v milling to finish mill the
ertical, or slanted

surfaces of a pocket. The pocket can include h
surfaces. Surfaces to be machined are sel e% within the pocket geometry.
The pocket walls are profile milled, andthe b of the pocket is machined as

in volume milling.

Objectives @j\
After completing this modul@w | be able to:

e Describe the p@ckg process.

e Create pock il sequences.

S
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Appendix B: Creating Pocket Milling Sequences

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Objectives

After successfully completing this module, you should know how to:
® Describe the pocket milling process.

® Create pocket milling sequences.

Overview

Pocket milling sequences are typically used after volume mi finish mill the surfaces of a
pocket. The pocket can include horizontal, vertical, or slanted gurfaces. Surfaces to be
machined are selected from within the pocket geomé&ixy. Thepocket walls are profile milled,
and the bottom of the pocket is machined as in vol \

After completing this module, you will be able‘t@
 Describe the pocket milling process

* Create pocket milling sequences. &

©©
&@6
Q®
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Pocket Milling

Overview
® Used to finish after roughing pockets.

©® Machine selected surfaces within pockets.
o Profiles walls

o Scans bottom faces

Q\%

Pocket Milling

» Pocket milling sequences machine selected surfaces.wit %kets. The selected surfaces
must allow for a continuous tool path, for instance, yot.cannot leave gaps in the selected

surfaces.
* The tool profile mills the walls, applying leadf d-out and cutter compensation if

required. @
* The tool machines the bottom fages@ ocket in the same way as a volume milling

sequence. g&\

©©
&@6
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Exercise

In this module, you complete the following exercise:

© Creating Pocket Milling Sequences

Use the steps in the training guide to complete the exercise.

Exercise: Creating Pocket Milling Sequences %

Exercise

Use the steps in the training guide to complete the %%ses.
O

QO
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Summary

After successfully completing this module, you should know how to:
© Describe the pocket milling process.

© Create pocket milling sequences.

Summary %

After successfully completing this module, you should kn to:
» Describe the pocket milling process.
 Create pocket milling sequences. @

O
>
©
W

QO
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Appendix B Lab Exercises

Exercise 1: Creating Pocket Milling Sequences

Objectives

After successfully completing this exercise, you will know how to:

» Create pocket milling sequences. \%

Scenario @

You need to create a pocket milling sequence to machine the sidewalls a‘m ace of the
O Eﬁ.ﬂ’

pocket in the base cover model. A volume milling sequence has already r out the pocket
leaving a small amount of material on all pocket faces. You create a@et milling sequence to

remove the remaining material in the pocket. %

& I;gure 1: Highlighting pocket in base cover model

Step 1. Locae d@hﬁen the cover manufacturing model
N

1. Inthe fi rpravigator browse through the folders and locate the directory:
c&:s\ tudent\manufacturing_330\moduleA2.

2.n ASE_COVER.MFG.

Turn off any displayed datum features.

Step 2. Create a pocket milling NC Sequence to machine the pocket surfaces.

1. Using the Menu Manager, create a pocket milling sequence.
2. Select the Name and Tool check boxes.
3. Name the sequence [FI N_POCKET].

4. Selectthe MMFLTO08 tool.
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5. Using the Model option, select all the surfaces within the pocket for machining.

Tip:

To select multiple surfaces press CTRL and select the pocket surfaces.

Figure 2: Showing selected surfaces in the @

6. Complete the surface selection.

7. Play the tool path using the Screen Play option. En \%CL data is visible.

8. Modify the SCAN_TYPE parameter to TYPE S@
9. Play the tool path using the Screen PI%y of sure the CL data is visible.

Figure 3: Showing the resulting tool path.

Toolpath Review:

Notice the tool profiles the walls first, applying cutter compensation and lead-in and
lead-out moves. The tool then machines the bottom face of the pocket, leaving a
small amount of material on the side walls. The tool then returns to profile the walls
at the full depth of the pocket.

10. Complete the NC sequence.
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11. Create a material removal feature for the pocketing sequence.
12. Save the manufacturing model.

13. Close all windows and erase all components from memory.
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Summary

After successfully completing this module, you should know how to:

» Describe the pocket milling process.

»  Create pocket milling sequences.
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Appendix

Extra Models

\‘
Introduction @

This module provides a variety of extra models to p@e manufacturing

techniques. %

Objectives

After completing this module, you be ableto:

e Create manufacturing mode ppropriate operation set-up information.

e Create applicable NC i@;es based on model geometry.
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Appendix C: Extra Models

!
©p1c CDQ

The way o Product Fir

Instructor Preparation

and thoroughly understood the following materials

Before teaching Creating Milling Sequences with Pr@@b? Wildfire, you must have read

* General Information @9
* Review Pro/ENGINEER Wildfire prlmer :/Irdweb.ptc.com/primer/

» Pro/E Wildfire Documentation

* Review Pro/ENGINEER Wildfi mentatlon in Windmill, located in
/GS Training Materials/Domain K e/Create/ProENGINEER/Core Concepts
* Pro/E Wildfire Millin
* Review Pro/E ildfire Milling training materials in Windmill, located in
/GS Ed Srvcs Opeftatj Education Library/Instructor Materials/Instructor Kits/EN

/T979-330- Instructo -EN

% ion of Pro/E Wildfire Foundation or equivalent Pro/E skills
- C

pletion of Creating Milling Sequences with Pro/ENGINEER Wildfire or equivalent
Pro/E skills

+ Ability to install and configure Pro/E Wildfire
+ Ability to follow general classroom setup procedure
» Good understanding of manufacturing processes and terminology
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Objectives

After successfully completing this module, you should know how to:

® Create manufacturing models with appropriate operation set-up
information.

® Create applicable NC Sequences based on model geometry.

QO

Overview %
This module provides a variety of extra models to practice m cturing techniques.

After completing this module, you will be able to:
» Create manufacturing models with appropriate lon set-up information.

 Create applicable NC Sequences based o el geometry.
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Extra Models

Fitting

Handle Cavity
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Exercise

In this module, you complete the following exercise:

® Machining Extra Models.

Use the steps in the training guide to complete the exercise.

Exercise: Machining Extra Models %

Exercise

Use the steps in the training guide to complete the %%ses.
O

QO



e . VrTC

Summary

After successfully completing this module, you should know how to:

© Create manufacturing models with appropriate operation set-up
information.

© Create applicable NC Sequences based on model geometry.

QO

Summary %

After successfully completing this module, you should kn to:
» Create manufacturing models with appropriate o tion set-up information.

* Create applicable NC Sequences based on m ometry.






Appendix C Lab Exercises

Exercise 1: Machining Extra Models

Objectives

After successfully completing this exercise, you will know how to:

» Create manufacturing models with appropriate operation set-up information. %
» Create applicable NC Sequences based on model geometry. @\
Scenario @

Select a model that best resembles the type of parts you machine.

Figure 2: Showing fitting and handle cavity models.

Step 1. Locate the moduleA3 folder and machine a model of your choice.

1. In the folder navigator browse through the folders and locate the directory:
c:\users\student\manufacturing_330\moduleA3.

2. Open a model of your choice and create a manufacturing model.

3. Create NC sequences to machine the model.
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Summary

After successfully completing this module, you should know how to:

» Create manufacturing models with appropriate operation set-up information.

» Create applicable NC Sequences based on model geometry.
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