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Preface
To take full advantage of Building Information Modeling, the Autodesk® Revit® 2024: 
Fundamentals for Structure guide has been designed to teach the concepts and principles of 
creating 3D parametric models of structural buildings from engineering design through 
construction documentation. 

This guide is intended to introduce you to the user interface and the basic building components 
of the software that makes Autodesk® Revit® a powerful and flexible structural modeling tool. 
The goal is to familiarize you with the tools required to create, modify, analyze, and document a 
parametric model. The examples and practices are designed to take you through the basics of 
a full structural project, from linking in an architectural model to construction documents.

Topics Covered

• Introduction to the Autodesk Revit software, including navigating the Revit interface

• Starting a structural project based on a linked architectural model and creating levels and 
grids as datum elements for the model

• Understanding the project browser and working with views

• Understanding Revit families and components

• Working with the basic sketching and modifying tools

• Adding structural columns to a project and copying and monitoring elements from 
linked models

• Adding foundations and footings

• Creating structural framing, including beams, trusses, and framing systems

• Creating slabs for foundations, structural floors, and roofs

• Creating structural reinforcement, including placing rebar and adding fabric reinforcement

• Setting up sheets and placing and modifying views on sheets

• Working with dimensions, text, annotations, and legends

• Adding tags and working with schedules

• Setting up detail views and adding detail components
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Prerequisites

• Access to the 2024.0 version of the software, to ensure compatibility with this guide. Future 
software updates that are released by Autodesk may include changes that are not reflected 
in this guide. The practices and files included with this guide might not be compatible with 
prior versions (e.g., 2023).

• This guide introduces the fundamental skills in learning how to use the Autodesk Revit 
software, with a focus on the structural tools. It is highly recommended that students have 
experience and knowledge in structural engineering and its terminology.

Note on Software Setup
This guide assumes a standard installation of the software using the default preferences during 
installation. This includes the Revit templates and Revit Content (Families) that can be found on 
the Autodesk website at https://knowledge.autodesk.com/ and searching How to download 
Revit Content. Lectures and practices use the standard software templates and default 
options.

Note on Learning Guide Content
ASCENT’s learning guides are intended to teach the technical aspects of using the software 
and do not focus on professional design principles and standards. The exercises aim to 
demonstrate the capabilities and flexibility of the software, rather than following specific 
design codes or standards, which can vary between regions.

Lead Contributor: Cherisse Biddulph
Cherisse is an Autodesk Certified Professional for Revit as well as an Autodesk Certified 
Instructor. She brings over 19 years of industry, teaching, and technical support experience to 
her role as a Learning Content Developer with ASCENT. With a passion for design and 
architecture, she has worked in the industry assisting firms with their CAD management and 
software implementation needs as they modernize to a Building Information Modeling (BIM) 
design environment. Although her main devotion is the Revit design product, she is also 
proficient in AutoCAD, Autodesk BIM 360, and Autodesk Navisworks. Today, Cherisse 
continues to expand her knowledge in the ever-evolving AEC industry and the software used to 
support it.

Cherisse Biddulph has been the Lead Contributor for Autodesk Revit: Fundamentals for 
Structure since 2020.

Sam
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 



© 2023, ASCENT - Center for Technical Knowledge® xiii

In This Guide
The following highlights the key features of this guide.

Feature Description

Practice Files The Practice Files page includes a link to the practice files and instructions on 
how to download and install them. The practice files are required to complete the 
practices in this guide.

Chapters A chapter consists of the following: Learning Objectives, Instructional Content, 
Practices, Chapter Review Questions, and Command Summary. 
• Learning Objectives define the skills you can acquire by learning the content 

provided in the chapter.
• Instructional Content, which begins right after Learning Objectives, refers to the 

descriptive and procedural information related to various topics. Each main 
topic introduces a product feature, discusses various aspects of that feature, 
and provides step-by-step procedures on how to use that feature. Where 
relevant, examples, figures, helpful hints, and notes are provided.

• Practice for a topic follows the instructional content. Practices enable you to 
use the software to perform a hands-on review of a topic. It is required that you 
download the practice files (using the link found on the Practice Files page) 
prior to starting the first practice.

• Chapter Review Questions, located close to the end of a chapter, enable you to 
test your knowledge of the key concepts discussed in the chapter. 

• Command Summary concludes a chapter. It contains a list of the software 
commands that are used throughout the chapter and provides information on 
where the command can be found in the software.

Appendices Appendices provide additional information to the main course content. It could 
be in the form of instructional content, practices, tables, projects, or skills 
assessment.
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This guide is divided into three sections: Introduction to Autodesk Revit and Project Setup, 
Design Development, and Construction Documentation. 

The first section provides an introduction to the Autodesk® Revit® software, including working 
with the software interface, setting up a drawing, incorporating datum elements, adding 
families, and using the basic drawing and modify tools. 

This section includes the following chapters:

• Chapter 1: Introduction to Revit

• Chapter 2: Starting a Structural Project

• Chapter 3: Working with Views

• Chapter 4: Revit Families

• Chapter 5: Basic Sketching and Modify Tools

Introduction to Autodesk
Revit and Project Setup
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Chap ter

1
Introduction to Revit
Building Information Modeling (BIM) and Revit® work hand in hand to help you create smart, 3D 
models that are useful at all stages in the building process. Understanding the software 
interface and terminology enhances your ability to create and navigate around in the various 
views of the model.

Learning Objectives 

• Describe the concept of Building Information Modeling in conjunction with applying Revit.

• Navigate the graphic user interface, including the ribbon (where most of the tools are 
found), Properties (where you make modifications to element information), and the 
Project Browser (where you can open various views of the model).

• Open existing projects and save projects.

• Use viewing commands to navigate around the model in 2D and 3D views. 
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1.1 BIM and Revit
Building Information Modeling (BIM) is an approach to the entire building life cycle, including 
design, construction, and facilities management. The BIM process supports the ability to 
coordinate, update, and share design data with team members across disciplines.

Revit is a model authoring software. It enables you to create complete 3D building models (as 
shown on the left in Figure 1–1) that provide considerable information reported through 
construction documents, and enables you to share these models with other programs for more 
extensive analysis.

Note: The software includes tools for architectural, mechanical, electrical, plumbing, and 
structural design.

Figure 1–1

 Revit is a Parametric Building Modeler software:

• Parametric: A relationship is established between building elements: when one element 
changes, all other related elements and/or geometry is modified as well. For example, when 
you place a door in a wall, the door removes part of the wall and stays inside that wall if it 
moves.

• Building: The software is designed for working with buildings and the surrounding 
landscape, as opposed to gears or highways. 

• Modeler: A project is built in a single file based on the 3D building model, as shown on the 
left in Figure 1–1. All views, such as plans (as shown on the right in Figure 1–1), elevations, 
sections, details, construction documents, and reports are generated based on the model.

• It is important that everyone who is collaborating on a project works in the same version and 
build of the software.
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Workflow and BIM
BIM has changed the process of how a building is planned, budgeted, designed, constructed, 
and (in some cases) operated and maintained. 

In the traditional design process, construction documents are created independently, typically 
including plans, sections, elevations, details, and notes. Sometimes, a separate 3D model is 
created in addition to these documents. Changes made in one document, such as the addition 
of a light fixture in a plan, have to be coordinated with the rest of the documents and schedules 
in the set, as shown in Figure 1–2. 

Figure 1–2

In BIM, the design process revolves around the model, as shown in Figure 1–3. Plans, 
elevations, and sections are simply 2D versions of the 3D model, while schedules are a report of 
the information stored in the model. Changes made in one view automatically update in all 
views and related schedules. Even construction documents update automatically with callout 
tags in sync with the sheet numbers. This is called bidirectional associativity.

By creating complete models and associated views of those models, Revit takes much of the 
tediousness out of producing a building design.

Figure 1–3
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Revit Terms
When working in Revit, it is important to know the typical terms used to describe items. Views 
and reports display information about the elements that form a project. There are three types of 
elements: model, datum, and view-specific, as shown in Figure 1–4 and described below:

Figure 1–4

Views Views enable you to display and manipulate the model. For example, you can 
view and work in floor plans, ceiling plans, elevations, sections, schedules, 
and 3D views. You can change a design from any view. All views are stored in 
the project.

Reports Reports, including schedules, gather information from the building model 
element that can be presented in the construction documents or used for 
analysis.

Model Elements Model elements include all parts of a building, such as walls, floors, ceilings, 
and roofs. 

Component 
Elements

Component elements are placed from inserted families, such as plumbing 
fixtures, light fixtures, mechanical equipment, columns, beams, furniture, and 
plants.
• Host elements, such as walls, support other categories of components like 

doors, windows, and casework.
• Hosted elements must be attached to a host element, such as doors must 

be placed on a (host) wall.
• Stand-alone elements do not require hosts.

Model element: 
host

Model elements: 
hosted 

Datum 
element

View-specific 
elements

Model 
elements: 
stand-alone 

Elevation view
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• Revit elements are “smart”: the software recognizes them as walls, columns, plants, ducts, 
or light fixtures, etc. This means that the information stored in their properties automatically 
updates in schedules, which ensures that views and reports are coordinated across an 
entire project, and are generated from a single model.

Revit and Construction Documents
In the traditional workflow, the most time-consuming part of the project is the construction 
documents. With BIM, the base views of those documents (i.e., plans, elevations, sections, and 
schedules) are produced automatically and update as the model is updated, saving hours of 
work. The views are then placed on sheets that form the construction document set.

For example, a floor plan is duplicated. Then, in the new view, all but the required categories of 
elements are hidden or set to halftone and annotations are added. The plan is then placed on a 
sheet, as shown in Figure 1–5.

Figure 1–5

• Work can continue on a view and is automatically updated on the sheet.

• Annotating views in the preliminary design phase is often not required. You might be able to 
wait until you are further along in the project.

Datum Elements Datum elements define the project context, such as the levels for the floors, 
grids, and reference planes.

View-specific 
Elements

View-specific elements only display in the view in which they are placed. The 
view scale controls their size. These include annotation elements such as 
dimensions, text, tags, and symbols as well as detail elements such as detail 
lines, filled regions, and 2D detail components. 
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1.2 Overview of the Interface
The Revit interface is designed for intuitive and efficient access to commands and views. It 
includes the ribbon, Quick Access Toolbar, Navigation Bar, and Status Bar, which are common 
to most of the Autodesk software. It also includes tools that are specific to Revit, including 
Properties, the Project Browser, and the View Control Bar. Revit includes access to tools for 
architectural, mechanical, electrical, plumbing, and structural design but can be altered by 
setting up a customized workspace that is more tailored to your specific discipline. A 
breakdown of the Revit interface is shown in Figure 1–6.

Figure 1–6

1. Home Screen 7. File Tab

2. Quick Access Toolbar 8. Properties

3. View Tabs 9. Project Browser

4. Options Bar 10. View Control Bar

5. Ribbon 11. Status Bar

6. Navigation Bar

6
3

4

2

7

9

8

10

5

1

11
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1. The Home Screen
When you first open Revit, the Home screen displays with recently used projects and families, 
as shown in Figure 1–7. Click on a tab along the left side of the interface to open or start a new 
model or family. There are other feature tabs you can access, like Autodesk Docs and My 
Insights, as well as links to Whats new, Online help, Community forum, and Customer support.

Figure 1–7

• From the Home screen, you can select the image (displaying the file name) of a recently 
opened project or use one of the options on the left to open or start a new project using the 
default templates.

• In the Quick Access Toolbar, click  (Home) to return to the Home screen. 

• On the Home screen, click  (Back) to return to the active model. 

• Press <Ctrl>+<D> to toggle between the Home screen and the active model.

• To view personalized insights based on your usage data, click on the My Insights tab 
from the Home screen. The Insights cards will display topics such as Revit usage details, 
new commands, and feature recommendations.Sam
ple
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2. Quick Access Toolbar
The Quick Access Toolbar (shown in Figure 1–8) includes commonly used commands, such as 
Home, Open, Save, Undo, Redo, Print, and PDF. It also includes Activate Controls and 
Dimensions to reduce clutter when selecting multiple elements in a view, and frequently used 
annotation tools, including Measuring tools, Aligned Dimension, Tag by Category, and Text. 
Viewing tools, including several different 3D Views and Sections, are also easily accessed here.

Figure 1–8

The top toolbar also hosts the InfoCenter (as shown in Figure 1–9), which includes the 
Autodesk sign-in, access to the Autodesk App Store, and Help options. 

Figure 1–9

A search field, as shown in Figure 1–10, is also available to find help on the web.

Figure 1–10

Click here to expand or collapse the search field
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Hint: Customizing the Quick Access Toolbar
Right-click on the Quick Access Toolbar, as shown in Figure 1–11, to change the docking 
location of the toolbar to be above or below the ribbon, or to add, relocate, or remove tools 
on the toolbar.

Figure 1–11

You can also right-click on a tool in the ribbon (e.g., the Move command) and select Add to 
Quick Access Toolbar, as shown in Figure 1–12.

 
Figure 1–12

If you have added a lot of icons to the Quick Access Toolbar,  (Expand) will display at the 
end of the toolbar. Click  to show the additional tool icons you have added, as shown in 
Figure 1–13.

Figure 1–13
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3. View Tabs
Each view of a project opens in its own tab and can be pulled out of the application window and 
moved to another monitor. Each view displays a Navigation Bar (for quick access to viewing 
tools), the View Control Bar, and elevation markers, as shown in Figure 1–14. 

Note: In 3D views, you can also use the ViewCube to orbit the view.

• To close a tab, click the X that displays when you hover over the tab or the name in the list, 
as shown in Figure 1–14.

Figure 1–14

Hint: Elevation Markers
You can hover your cursor over a marker’s arrowhead to see what the view name is, as 
shown in Figure 1–15. You can also double-click on the arrowhead to open the view. 

Figure 1–15

Navigation 
Bar

View Control 
Bar

View tabs

Elevation 
marker

Click to close the view

ArrowheadSam
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• Click on the tab along the top of the drawing area to switch between views. You can also:

• Press <Ctrl>+<Tab>.

• Select the view in the Project Browser.

• In the Quick Access Toolbar (shown on the left in Figure 1–17) or View tab>Windows 

panel (shown on the right in Figure 1–17), expand  (Switch Windows) and select the 
view from the list.

Figure 1–17

Hint: Using Thin Lines
The software automatically applies line weights to views, as shown for a section on the left 
in Figure 1–16. If a line weight seems heavy or obscures your work on the elements, toggle 
off the line weights. In the Quick Access Toolbar or in the View tab>Graphics panel, click 

(Thin Lines), or type TL. The lines display with the same weight, as shown on the right in 
Figure 1–16.

Figure 1–16

The Thin Line setting is remembered until you change it, even if you shut down and restart 
the software.

Thin Lines off Thin Lines on
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• Expand the drop-down list at the far end of the tabs, as shown in Figure 1–18 to select a 
view from the list.

Figure 1–18

• To close all open views except the current view, in the Quick Access Toolbar or View 

tab>Windows panel, click  (Close Inactive Views). If you have multiple projects open, one 
view of each project remains open. If you have dragged a view to another monitor, that view 
will need to be manually closed by clicking the X in the upper-right corner.

• You can switch between tabbed and tiled views from the View tab>Windows panel or by 

typing shortcuts. For tabbed views (as shown on the left in Figure 1–19), click  (Tab 

Views) or type TW. For tiled views (as shown on the right in Figure 1–19), click  (Tile 
Views) or type WT.

Figure 1–19

• When you are working with tiled views, you can type ZA (Zoom All to Fit) to zoom to fit the 
full model in each of the different views.

• Drag the edge of tiled views to resize them as needed. 

4. Options Bar
The Options Bar displays options that are related to the selected command or element. For 
example, when the Rotate command is active it displays options for rotating the selected 
elements, as shown at the top in Figure 1–20. When the Place Dimensions command is active 
it displays dimension related options, as shown at the bottom in Figure 1–20.
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Figure 1–20

5. Ribbon
The ribbon contains tools in a series of tabs and panels, as shown in Figure 1–21. Selecting a 
tab displays a group of related panels. The panels contain a variety of tools, grouped by task.

Figure 1–21

When you start a command that creates new elements or you select an element, the ribbon 
displays the Modify contextual tab. This contains general editing commands and command-
specific tools, as shown in Figure 1–22.

Figure 1–22

• When a command is toggled on, the icon will be highlighted in blue. When it is toggled off, 
the icon is gray (not highlighted), as shown in Figure 1–23.

Figure 1–23

Options Bar for Rotate command

Options Bar for Dimension command

Contextual tab

Command toggled offCommand toggled on
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• When you hover over a tool on the ribbon, tooltips display the tool’s name and a short 
description. If you continue hovering over the tool, a graphic displays (and sometimes a 
video), as shown in Figure 1–24.

Figure 1–24

• Many commands have shortcut keys. For example, type AL for Align or MV for Move. They 
are listed next to the name of the command in the tooltips. Do not press <Enter> when 
typing shortcuts. A list of shortcuts can be found in the Autodesk Revit Help, which can be 

accessed by clicking (Help) in the upper-right corner of the interface or pressing <F1>.

• For convenience, both the RVTKeyboardShortcuts.xlsx and RVTKeyboardShortcuts.pdf 
files have been downloaded for you and can be found in the practice files Reference 
folder.

• To arrange the order in which the ribbon tabs are displayed, select the tab, hold <Ctrl>, and 
drag it to a new location. The location is remembered when you restart the software.

• Any panel can be dragged by its title into the view window to become a floating panel. Click 
the Return Panels to Ribbon button (as shown in Figure 1–25) to reposition the panel in the 
ribbon.

Figure 1–25
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6. Navigation Bar
The Navigation Bar enables you to access the 2D and Full Navigation (3D views) Wheel to 
navigate the view, as well as the Zoom in Region viewing commands, as shown in Figure 1–26.

Figure 1–26

Hint: Ending a Command
When you are finished working with a tool, you typically default back to the Modify 
command. To end a command, use one of the following methods: 

• In any tab on the ribbon, click  (Modify).

• Type the shortcut MD.

• Press <Esc> once or twice to revert to Modify.

• Right-click and select Cancel... once or twice.

• Start another command.

2D Wheel

Zoom in Region
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7. File Tab
The File tab of the ribbon can be expanded and it provides access to file commands, Options 
settings, and Print, Export, and Save options, as shown in Figure 1–27. Hover the cursor over a 
command to display a list of additional tools.

Note: If you click the primary icon (e.g., New or Open), rather than the arrow, it starts the 
default command (except for Save As and Export, which require an option to be selected).

Figure 1–27
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• To display a list of recently used documents, click (Recent Documents). The documents 

can be reordered as shown in Figure 1–28. You can click  (Pin) next to a document name 
to keep it available.

Figure 1–28

• To display a list of open documents and views, click (Open Documents). The list 
displays the documents and views that are open, as shown in Figure 1–29. You can use the 
Open Documents list to change between views.

Figure 1–29

• Click  (Close) to close the current project.

• At the bottom of the menu, click Options to open the Options dialog box or click Exit Revit to 
exit the software.
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8. Properties
Properties contains several parts, as shown in Figure 1–30. The Type Selector can be found at 
the top, which enables you to choose the size or style of the element you are adding or 
modifying. The options available in Properties enable you to make changes to information 
(parameters). There are two types of properties:

• Instance properties are set for the individual element(s) you are creating or modifying. 

• Type properties control options for all elements of the same type. If you modify these 
parameter values, all elements of the selected type change.

Properties is usually kept open while working on a project to easily permit changes at any time. 

If it does not display, in the Modify tab>Properties panel, click (Properties), or type PP. 
Alternatively, you can right-click in the view and select Properties.

Note: Some parameters are only available when you are editing an element. They are 
grayed out when unavailable.

Figure 1–30

• Options for the current view display if the Modify command is active, but you have not 
selected an element.

• If a command or element is selected, the options for the associated element display.

• You can save the changes either by moving the cursor off of Properties, by pressing 
<Enter>, or by clicking Apply. 

Filter drop-down list Type 
Selector

Access to type 
properties

Instance 
properties
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• When you start a command or select an element, you can set the element type in the Type 
Selector, as shown in Figure 1–31.

Note: You can limit what shows in the drop-down list by typing in the search box.

Figure 1–31

• When multiple elements are selected, you can filter the type of elements that display using 
the drop-down list, as shown in Figure 1–32.

Figure 1–32

• Properties can be placed on a second monitor, or floated, resized, and docked on top of the 
Project Browser, as shown in Figure 1–33. Click a tab to display its associated information.

Figure 1–33

Search box
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9. Project Browser
The Project Browser (shown in Figure 1–34) lists all the views of the model in which you can 
work and any additional views that you create, such as floor plans, ceiling plans, 3D views, 
elevations, sections, etc. It also includes schedules, legends, sheets (for plotting), lists of 
families by category, groups, and Revit links. The name of the active view is bold, and views that 
are placed on sheets will have a status icon next to the level’s name. 

Figure 1–34

• To display the views associated with a view type (e.g., floor plans, ceiling plans, etc.), click 

(Expand) next to the section name. To hide the views in the section, click (Collapse). 
You can also expand and collapse sets using the shortcut menu, as shown in Figure 1–35.

Figure 1–35

• To open a view, double-click on the view name or right-click and select Open.
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• To open a sheet, right-click on the view in the Project Browser and select Open Sheet, as 
shown in Figure 1–36.

Figure 1–36

• To rename a view, slowly click twice on the view name and the text will highlight so it can be 
changed. You can also right-click on a view name and select Rename..., as shown in 
Figure 1–37, or press <F2>.

Figure 1–37
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Setting the Discipline of a View 
You can utilize discipline in a view to display discipline-specific elements and to organize the 
Project Browser. When you duplicate or create a view, if it is not in the expected grouping in the 
Project Browser, you would need to set the Discipline in Properties. The view properties of 
Discipline (shown in Figure 1–38) control the visibility of some elements and applies grouping 
in the Project Browser. For example, you can separate the coordination plans from the 
architectural plans, as shown in Figure 1–39.

10. View Control Bar
The View Control Bar (shown in Figure 1–40) displays at the bottom of each view window. It 
controls aspects of that view, such as the scale and detail level. It also includes tools that 
display parts of the view and hide or isolate elements in the view.

Figure 1–40

• The number of options in the View Control Bar change when you are in a 3D view, as shown 
in Figure 1–41.

Figure 1–41

Figure 1–38 Figure 1–39
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11. Status Bar
The left-hand side of the Status Bar provides information about the current process, such as the 
next step for a command, as shown in Figure 1–42.

Figure 1–42

Tool Tooltip Description

View Scale Set the scale of individual views.

Detail Level  Set the detail level of a view.

Visual Style Various graphic style representations.

Sun Path On/Off Controls the visibility of the sun’s path.

Shadows On/Off Controls elements’ shadow visibility in a view.

Show/Hide Rendering 
Dialog

Available in 3D only. Shows or hides the rendering dialog box.

Crop View Define the crop boundaries for a view.

Show/Hide Crop Region Display the crop region in a view.

Unlocked/Locked 3D 
Views

Lock a 3D view’s orientation.

Temporary Hide/Isolate Temporarily isolate/hide by category or element (view 
specific).

Reveal Hidden Elements View hidden elements or unhide them in the active view.

Worksharing Display Available when worksharing is enabled. Controls display 
settings.

Temporary View 
Properties 

Enable, apply or restore view properties and display recent 
templates and apply them.

Show or Hide the 
Analytical Model

Only used for Structural and MEP to display the analytical 
information.

Highlight Displacement 
Sets

Also known as exploded views.

Reveal Constraints Temporarily view the dimension and alignment constraints in 
the active view.
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The right-hand side of the Status Bar provides selection options that enable you to control how 
the software selects specific elements in a project by toggling selection options on and off. 
When a selection option is toggled off, the icon will have a red X on it, as shown in Figure 1–43.

Figure 1–43

•  Select links: When this option is toggled on, you can select linked CAD drawings or Revit 
models. When it is toggled off, you cannot select them when using Modify or Move.

•  Select underlay elements: When this option is toggled on, you can select underlay 
elements. When it is toggled off, you cannot select them when using Modify or Move.

•  Select pinned elements: When this option is toggled on, you can select pinned elements. 
When it is toggled off, you cannot select them when using Modify or Move.

•  Select elements by face: When this option is toggled on, you can select elements (such 
as the floors or walls in an elevation) by selecting the interior face or selecting an edge. 
When it is toggled off, you can only select elements by selecting an edge.

•  Drag elements on selection: When this option is toggled on, you can hover over an 
element, select it, and drag it to a new location. When it is toggled off, the Crossing or Box 
select mode starts when you press and drag, even if you are on top of an element. Once 
elements have been selected, they can still be dragged to a new location.

You can also set the selection option from the ribbon. Expand the Select panel’s title and select 
the option(s), as shown in Figure 1–44.

Figure 1–44

Other options in the Status Bar are related to worksets and design options (advanced tools).

Off On
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Change Interface to Dark Mode
You can change Revit’s entire interface to a dark mode or you can change just the drawing area 

to dark mode. You can also set the interface to dark mode, then click  (Canvas Theme) to 
change the drawing area back to white.

How To: Change the Entire Interface to Dark Mode

1. From the File tab, click Options.

2. In the Options dialog box, click on the Color tab.

3. Expand UI active theme and select Dark, as shown in Figure 1–46.

Figure 1–46

Hint: Shortcut Menus
Shortcut menus help you to work smoothly and efficiently by enabling you to quickly access 
required commands. These menus provide access to basic viewing commands, recently 
used commands, and the available browsers, as shown in Figure 1–45. Additional options 
vary depending on the element or command that you are using.

Figure 1–45
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4. The entire interface is now in dark mode.

• To return to the interface to the default setting, in the Options dialog box>Colors tab, expand 
the UI active theme drop-down list and select Use system setting.

How To: Change the Drawing Area to Dark Mode

1. In the View tab>Windows panel, click  (Canvas Theme).

2. Just the drawing area will change to dark mode, as shown in Figure 1–47.

• If the interface is set to dark mode, you can use this to set the drawing area to display a 
light background.

Figure 1–47
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1.3 Opening and Saving Projects
File operations to open existing files, create new files from a template, and save files in Revit 
are found in the File tab, as shown in Figure 1–48. 

Figure 1–48

There are three main file formats: 

• Project files (.rvt): These are where you do the majority of your work in the building model 
by adding elements, creating views, annotating views, and setting up printable sheets. They 
are initially based on template files.

• Family files (.rfa): These are separate components that can be inserted in a project. They 
include elements that can stand alone (e.g., a table or piece of mechanical equipment) or 
are items that are hosted in other elements (e.g., a door in a wall or a light fixture in a 
ceiling). Title block and annotation symbol files are special types of family files.

• Template files (.rte and .rft): These are the base files for any new project or family. Project 
templates (.rte) hold standard information and settings for creating new project files. The 
software includes several templates for various types of projects. You can also create 
custom templates. Family templates (.rft) include base information for creating families. 
Template files are usually saved as a new file.
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Opening Projects
To open an existing project, click Open from the Home screen, or in the Quick Access Toolbar 

or File tab, click  (Open). You can also press <Ctrl>+<O>. The Open dialog box opens, and 
you can navigate to the required folder and select a project file. An example of the Open dialog 
box is shown in Figure 1–49.

Figure 1–49

• The software release version of the currently selected project displays below the preview. 
Do not open a drawing that should remain in an earlier version, as you cannot save back to 
previous versions.

Note: It is important that everyone working on a project uses the same software version 
(e.g., 2024) and is on the same updated version (e.g., 2024.1). While your software may be 
able to open files created in its earlier versions, it will not be able to open files created in 
versions newer than the one you are using currently as Revit is not backwards compatible. 
For example, if you are working in Revit 2023, you cannot open a model created in Revit 
2024.

• When you open a file created in an earlier version, the Model Upgrade dialog box indicates 
the release of a file and the release to which it will be upgraded. If needed, you can cancel 
the upgrade before it completes.
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• When you encounter an Unresolved References dialog box upon opening a project, you have 
two options. You can either click Ignore and Continue opening the project to proceed with 
opening the project, or click Open Manage Links to correct the problem to resolve the issue. 
The details of the Manage Links dialog box will be explained in the next chapter.

Saving Projects
It is important to save your projects frequently. In the Quick Access Toolbar or File tab, click 

(Save), or press <Ctrl>+<S> to save your project. If the project has not yet been saved, the 
Save As dialog box opens, where you can specify a file location and name.

• To save an existing project with a new name, in the File tab, expand  (Save As) and click 

(Project). 

• If you have not saved in a certain amount of time, the software will notify you with the 
Project Not Saved Recently alert box, as shown in Figure 1–50. Select Save the project. If 
you want to set reminder intervals or not save at this time, select one of the other two 
options shown in Figure 1–50.

Figure 1–50
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• You can set the Save reminder interval to 15 or 30 minutes, One, Two, or Four hours, or to 
have No reminders display. In the File tab, click Options to open the Options dialog box. 
Select General and set the interval, as shown in Figure 1–51.

Figure 1–51

Saving Backup Copies
By default, the software saves a backup copy of a project file when you save the project. 
Backup copies are numbered incrementally (e.g., My Project.0001.rvt, My Project.0002.rvt, 
etc.) and are saved in the same folder as the original file. In the Save As dialog box, click 
Options... to control how many backup copies are saved. The default number is three backups. 
If you exceed this number, the software deletes the oldest backup file.
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1.4 Viewing Commands
Viewing commands are crucial to working efficiently in most drawing and modeling programs 
and Revit is no exception. Once in a view, you can use the Zoom controls to navigate in it. You 
can zoom in and out and pan in any view. There are also special tools for viewing in 3D.

Zooming and Panning
Use the mouse wheel (shown in Figure 1–52) as the main method of zooming and panning 
around the models.

Figure 1–52

• Scroll the wheel on the mouse up to zoom in and down to zoom out.

• Hold the wheel and move the mouse to pan.

• Double-click on the wheel to zoom to the extents of the view.

• In a 3D view, hold <Shift> and the mouse wheel and move the mouse to orbit around the 
model.

When you save a model and exit the software, the pan and zoom location of each view is 
remembered. This is especially important for complex models.

Mouse 
wheel
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Additional Zoom Controls
A number of additional zoom methods enable you to control the screen display. Zoom and Pan 
can be performed at any time while using other commands.

• You can access the Zoom commands in the Navigation Bar in the upper right corner of the 
view (as shown in Figure 1–53). You can also access them from most shortcut menus and 
by typing the shortcut commands.

Note:  (2D Wheel) provides cursor-specific access to Zoom and Pan.

Figure 1–53

Zoom Commands

Zoom In Region (ZR) Zooms in to a region that you define. Drag the cursor or select 
two points to define the rectangular area you want to zoom in to. 
This is the default command.

Zoom Out(2x) (ZO) Zooms out to half the current magnification around the center of 
the elements.

Zoom to Fit 
(ZF or ZE)

Zooms out so that the entire contents of the project only display 
on the screen in the current view.

Zoom All to Fit (ZA) Zooms out so that the entire contents of the project display on 
the screen in all open views.

Zoom Sheet Size (ZS) Zooms in or out in relation to the sheet size.

N/A Previous Pan/Zoom 
(ZP)

Steps back one Zoom command.

N/A Next Pan/Zoom Steps forward one Zoom command if you have done a Previous 
Pan/Zoom.
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Viewing in 3D
Even if you started a project entirely in plan views, you can quickly create 3D views of the model, 
as shown in Figure 1–54. There are two types of 3D views: isometric views created by the 
Default 3D View command, and perspective and orthographic 3D views created by the Camera 
command.

Figure 1–54

Working in 3D views helps you visualize the project and position some of the elements 
correctly. You can create and modify elements in both isometric and perspective 3D views, just 
as you can in plan views. 

• Once you have created a 3D view, you can save it and easily return to it. 

• Perspective 3D views are visual representations of what the model would look like if you 
were standing in the model.

• Orthographic 3D views can have a scale applied to them so that the entire model’s 
components are at the same size no matter where the camera is positioned or its distance 
from the model.
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How To: Create and Save a 3D Isometric View

1. In the Quick Access Toolbar or View tab>Create panel, click  (Default 3D View). The 
default 3D southeast isometric view opens, as shown in Figure 1–55. 

Figure 1–55

Note: You can spin the view to a different angle using the mouse wheel or the middle 
button of a three-button mouse. Hold <Shift> as you press the wheel or middle button and 
drag the cursor.

2. Modify the view to display the building from other directions. 

3. In the Project Browser, slowly click twice on the {3D} view or right-click on the {3D} view and 
select Rename.... The name is placed in a text box with the original name highlighted, as 
shown in Figure 1–56. 

Figure 1–56

4. Type a new name in the text box, as shown in Figure 1–57.

Figure 1–57

Note: All types of views can be renamed.

• When changes to the default 3D view are saved and you start another default 3D view, it 
displays the southeast isometric view once again. If you modified the default 3D view but 
did not save it to a new name, the Default 3D View command opens the view in the last 
orientation you specified.
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How To: Create a Perspective 3D View

1. Switch to a Floor Plan view.

2. In the Quick Access Toolbar or View tab>Create panel, expand  (Default 3D View) and 

click  (Camera).

3. In the Options Bar, verify Perspective is checked and set the Scale, Offset, and From which 
level the camera will be placed, as shown in Figure 1–58.

Figure 1–58

4. Place the camera on the view.

5. Point the camera in the direction in which you want it to shoot by placing the target on the 
view, as shown in Figure 1–59.

Figure 1–59

Target

Camera
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A new view is displayed, as shown in Figure 1–60.

Figure 1–60

• You can use the round controls to modify the display size of the view and press <Shift> + 
the mouse wheel to change the view.

How To: Create an Orthographic 3D View

1. Switch to a floor plan view.

2. In the Quick Access Toolbar or View tab>Create panel, expand  (Default 3D View) and 

click  (Camera).

3. In the Options Bar, uncheck Perspective and set the Scale, Offset, and From which level.

4. Place the camera on the view.
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5. Point the camera in the direction in which you want it to shoot by placing the target on the 
view, as shown in Figure 1–61.

Figure 1–61

• A new view is displayed, as shown in Figure 1–62. If needed, the Eye Elevation and Target 
Elevation can be adjusted in Properties.

Figure 1–62

6. In Properties, scroll down and adjust the Eye Elevation and Target Elevation as needed. 

Target

Camera
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How To: Modify Camera 3D Views

1. In a plan view, select the camera or target icon and drag it within the view to reposition the 
placement.

2. In Properties, scroll down and adjust the Eye Elevation and Target Elevation as needed. 

• To display the camera and camera controls in a plan view, select the camera’s crop 
boundary in the perspective view, then switch back to the plan view. 

• Alternatively, while in a plan view, you can right-click on the perspective 3D view in the 
Project Browser and select Show Camera, as shown in Figure 1–63. The camera and 
camera crop boundaries will display.

Figure 1–63

• For perspective 3D views, if the view becomes distorted, reset the target so that it is 
centered in the boundary of the view (called the crop region). In the Modify | Cameras tab> 

Camera panel, click  (Reset Target).

ViewCube
The ViewCube provides visual clues as to where you are in a 3D view. It helps you move around 
the model with quick access to specific views (such as top, front, and right), as well as corner 
and directional views, as shown in Figure 1–64.

Figure 1–64

 ViewCube
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Move the cursor over any face of the ViewCube to highlight it. Once a face is highlighted, you 
can select it to reorient the model. You can also click and drag on the ViewCube to orbit the box, 
which rotates the model.

•  (Home) displays when you roll the cursor over the ViewCube. Click it to return to the view 
defined as Home. To change the Home view, set the view as you want it, right-click on the 
ViewCube, and select Set Current View as Home.

• The ViewCube is available in isometric and perspective views.

You can switch between Perspective and Isometric mode by right-clicking on the ViewCube (as 
shown on the left in Figure 1–65) or clicking on  (ViewCube contextual menu) to the lower 
right of the ViewCube (as shown on the right in Figure 1–65) and selecting Perspective or 
Orthographic. 

Figure 1–65

You can create 3D views that are oriented to a specific view. For more information, refer to the 
Working with Views chapter.

Right-click on ViewCube Context menu on ViewCube
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Visual Styles 
Any view can have a visual style applied. The Visual Style options found in the View Control Bar 
(shown in Figure 1–66) specify the shading of the building model. These options apply to plan, 
elevation, section, and 3D views.

Figure 1–66

•  (Wireframe) displays the lines and edges that make up elements, but hides the surfaces. 
This can be useful when you are dealing with complex intersections.

•  (Hidden Line) displays the lines, edges, and surfaces of the elements, but it does not 
display any colors. This is the most common visual style to use while working on a design.

•  (Shaded) and  (Consistent Colors) give you a sense of the materials, including 
transparent glass. An example showing an exterior view using Consistent Colors is shown in 
Figure 1–67. Landscape components will display as gray outlines of the objects until the 
Realistic visual style is used.

Figure 1–67
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•  (Textures) displays the view using Consistent Colors, but if a component has a material 
applied to it, the Textures visual style displays the material’s texture as well. For example, 
Figure 1–68 appears as if it is using Consistent Colors but it is also showing the texture of 
the brick material on the planters.

Figure 1–68

•  (Realistic) displays artificial lights in addition to the material’s appearance (if material 
has been applied to a component), as shown in Figure 1–69. It takes a lot of computer 
power to execute this visual style, so it is better to use the other visual styles most of the 
time as you are working.

Figure 1–69
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Select and Identify Elements in a Project
When selecting an element in the drawing area, the element highlights (as shown on the left in 
Figure 1–70) and information about the element displays in Properties, helping you further 
identify the element. When you position the cursor over or near an element in the drawing area 
(as shown on the right in Figure 1–70), the outline of the element is highlighted with a thicker 
line weight and a tooltip appears. Additionally, the Status Bar at the bottom of the Revit window 
displays a description of the element. 

Figure 1–70

To deselect an element, you can do one of the following:

• In any tab on the ribbon, click  (Modify).

• Type the shortcut MD.

• Click in an empty area in the drawing area to clear the selection.

• Press <Esc> once to revert to Modify.

• Right-click and select Cancel... once or twice.

• Select another element.
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Practice 1a
Open and Review a Project

Practice Objectives 

• Navigate the graphic user interface.

• Manipulate 2D and 3D views by zooming and panning.

• Create 3D isometric and perspective views.

• Set the visual style of a view.

In this practice, you will open a project file and view each of the various areas in the interface. 
You will investigate elements, commands, and their options. You will also open views through 
the Project Browser and view the model in 3D, as shown in Figure 1–71.

Figure 1–71

• This is a version of the main project you will work on throughout this guide. 
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Task 1:  Explore the interface.

1. In the File tab, expand  (Open) and click (Project).

• If you are on the Home page, click Open... in the MODELS area of the sidebar.In the Open 
dialog box, navigate to the practice files folder and select Structural-Suite.rvt.

2. Click Open. The 3D view of the building opens in the view window.

Note: If the Project Browser and Properties palette are docked over each other, use the 
Project Browser tab at the bottom to display it.

3. In the Project Browser, double-click on the Structural Plans: 00 GROUND FLOOR view. It 
opens a plan with the Visual Style set to Wireframe so that the footings and foundation 
walls display, although there is a slab over them.

4. In the View Control Bar, change the Visual Style to Hidden Line. The lines that are hidden in 
the view display as dashed lines, as shown in Figure 1–72. 

Figure 1–72

5. In the Project Browser, double-click on the Structural Plans: 00 T.O. FOOTING view. The 
strip footings and spread footings display as continuous lines because they are not 
obscured by a slab, as shown in Figure 1–73. 

Figure 1–73
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6. Zoom in on one corner of the building. The foundation walls are in-filled with the 
appropriate concrete hatch, as shown in Figure 1–74.

Figure 1–74

7. Double-click the mouse wheel or type ZE to zoom to the extents of the view. (ZA zooms to 
the extents of all of the opened view windows.) Find the section marker that extends 
vertically along the model, as shown in Figure 1–75.

Figure 1–75

8. Double-click on the section head to open the NORTH-SOUTH SECTION view.

9. In the Project Browser, navigate to the Sections (Building Section) category. The NORTH-
SOUTH SECTION view name is bold. You can navigate through your model by double-
clicking on the element in the Project Browser or by using the graphical view elements in 
the model.Sam
ple
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10. In the section view, zoom in on the area in which the callout has been placed, as shown in 
Figure 1–76. Double-click on the callout-head to open the TYPICAL EDGE DETAIL view.

Figure 1–76

11. Toggle on and off  (Thin Lines) to see the different line weights.

12. In the TYPICAL EDGE DETAIL view, select the floor, as shown in Figure 1–77. 

Figure 1–77

13. This is a full 3D floor element. You can edit it using the standard modify tools and the 
concrete floor-specific tools found in the Modify | Floors contextual tab, as shown in 
Figure 1–78.

 

Figure 1–78

14. The Properties palette displays the instance parameters for the element, as shown in 
Figure 1–79.

Note: Any changes made here are applied to the selected element only. 
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Figure 1–79

15. In Properties, click  (Edit Type) to access the Type Parameters in the Type Properties 
dialog box, as shown in Figure 1–80. 

Note: Any changes made to the element here are applied to all of its other instances in the 
project.

Figure 1–80

16. Click Cancel to close the Type Properties dialog box.

17. End the command using one of the following methods: 

• In any tab on the ribbon, click  (Modify).

• Press <Esc> once or twice to revert to Modify.

• Right-click and select Cancel... once or twice.

• Start another command.
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18. Select one of the bolted connections. This is a detail component (2D element). The Modify | 
Detail Items contextual tab displays the modifying options specific to this element, as 
shown in Figure 1–81.

Figure 1–81

19. Click (Modify).

Task 2:  Work with multiple views and 3D views.

1. At the top of the view, click each tab to switch between the open views. 

2. In the View tab>Windows panel, click  (Tile Views). All of the open views are tiled. Type 
ZA (for Zoom All) to zoom out to the extents of each view, as shown in Figure 1–82.

Figure 1–82

3. Click inside the 3D view to make it active.
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4. In the View tab>Windows panel, click  (Tab Views). The views return to the tabs and the 
3D view is first in the group.

5. In the Quick Access Toolbar, click  (Close Inactive Views) so that only the current 
window remains open.

6. Using the mouse wheel, zoom in on the building.

7. Press and hold <Shift> and then press and hold the wheel on the mouse. Move the mouse
to dynamically view the 3D model. You can also navigate in 3D using the ViewCube in the
upper-right corner of the view.

8. Expand the File tab and click  (Close) to exit the project. Do not save changes.

End of practice
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Chapter Review Questions
1. When you create a project in Revit, do you work in 3D or 2D?

a. You work in 2D in plan views and in 3D in non-plan views.

b. You work in 3D almost all of the time, even when you are using what looks like a flat 
view.

c. You work in 2D or 3D depending on how you toggle the 2D/3D control.

d. You work in 2D in plan and section views and in 3D in isometric views.

 

2. What is the purpose of the Project Browser?

a. It enables you to browse through the building project, similar to a walk through.

b. It is the interface for managing all of the files that are required to create the complete 
architectural model of the building.

c. It manages multiple Revit projects as an alternative to using Windows Explorer.

d. It is used to access and manage the views of the project.

 

3. Where do you change the visual style?

a. Ribbon

b. View Control Bar

c. Options Bar

d. Properties

 

4. What is the difference between Type Properties and Properties? 

a. Properties stores parameters that apply to the selected individual element(s). Type 
Properties stores parameters that impact every element of the same type in the project.

b. Properties stores the location parameters of an element. Type Properties stores the size 
and identity parameters of an element.

c. Properties only stores parameters of the view. Type Properties stores parameters of 
model components.
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5. When you start a new project, how do you specify the base information in the new file?

a. Transfer the base information from an existing project.

b. Select the right template for the task.

c. Revit automatically extracts the base information from imported or linked file(s).

 

6. What is the main difference between a view made using (Default 3D View) and a view 

made using  (Camera)?

a. Use Default 3D View for exterior views and Camera for interiors.

b. Default 3D View creates a static image and a Camera view is live and always updated.

c. Default 3D View is isometric and a Camera view is perspective.

d. Default 3D View is used for the overall building and a Camera view is used for looking in 
tight spaces.
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Command Summary
Button Command Location

General Tools

Home • Quick Access Toolbar
• Shortcut: <Ctrl>+<D>

Modify • Ribbon: All tabs>Select panel
• Shortcut: MD

New • File tab
• Shortcut: <Ctrl>+<N>

Open • Quick Access Toolbar 
• File tab
• Shortcut: <Ctrl>+<O>

Open Documents • File tab

Properties • Ribbon: Modify tab>Properties panel
• Shortcut: PP

Recent Documents •  File tab

Save • Quick Access Toolbar 
• File tab
• Shortcut: <Ctrl>+<S>

Type Properties • Ribbon: Modify tab>Properties panel
• Properties>Edit Type

Select Tools

Drag elements on 
selection

• Ribbon: All tabs>expanded Select panel
• Status Bar

Filter • Ribbon: Modify | Multi-Select tab>Filter panel
• Status Bar

Select Elements By Face • Ribbon: All tabs>expanded Select panel
• Status Bar

Select Links • Ribbon: All tabs>expanded Select panel
• Status Bar

Select Pinned Elements • Ribbon: All tabs>expanded Select panel
• Status Bar
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Select Underlay Elements • Ribbon: All tabs>expanded Select panel
• Status Bar

Viewing Tools

Camera • Quick Access Toolbar, expand Default 3D View
• Ribbon: View tab>Create panel, expand Default 3D View

Close Inactive Views • Quick Access Toolbar
• Ribbon: View tab>Windows panel

Default 3D View • Quick Access Toolbar
• Ribbon: View tab>Create panel

N/A Next Pan/Zoom • Navigation Bar
• Shortcut Menu

N/A Previous Pan/Zoom • Navigation Bar
• Shortcut Menu
• Shortcut: ZP

 
Shadows On/Off • View Control Bar

Show Rendering Dialog/ 
Render

• View Control Bar
• Ribbon: View tab>Graphics panel
• Shortcut: RR

Switch Windows • Quick Access Toolbar
• Ribbon: View tab>Windows panel

Tab Views • Ribbon: View tab>Windows panel
• Shortcut: TW

Tile Views • Ribbon: View tab>Windows panel
• Shortcut: WT

ViewCube Home • ViewCube

Zoom All to Fit • Navigation Bar
• Shortcut: ZA

Zoom in Region • Navigation Bar
• Shortcut Menu
• Shortcut: ZR

Zoom Out (2x) • Navigation Bar
• Shortcut Menu
• Shortcut: ZO

Button Command Location
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Zoom Sheet Size • Navigation Bar
• Shortcut: ZS

Zoom to Fit • Navigation Bar
• Shortcut Menu
• Shortcut: ZF, ZE

Visual Styles

Consistent Colors • View Control Bar

Hidden Line • View Control Bar
• Shortcut: HL

Realistic • View Control Bar

Shaded • View Control Bar
• Shortcut: SD

Textures • View Control Bar

Wireframe • View Control Bar
• Shortcut: WF

Button Command Location
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