
SWITCHING FROM GRASSHOPPER 
TO VECTORWORKS





HOW TO PLACE A MARIONETTE NODE

To use the Marionette tool in Vectorworks, you don’t need to load a plug-in or work in a separate 
interface. The Marionette tool looks like this  and is located in the Basic tool palette. To use 
Marionette, click on the tool, and click on the drop-down menu in the Tool bar. The first time the 
Marionette tool is used in a Vectorworks session, the menu will say “Select a Node Definition…” 
and after the first node is selected, this menu will default to the last node used. When you click on 
the menu, the Resource Selector opens. The left pane of the Resource Selector is the File Browser 
pane, and the section of your Vectorworks library that has Marionette nodes is already cued up.

FIGURE 1 - The Marionette tool with the Resource Selector open

Within the folders of the Marionette Default Library are all of the available nodes separated into 
different categories. To choose a node, you can navigate to it through its folder and select it from 
the middle (Resource Viewer) pane; or if you know its name, you can search for it by typing all or 
part of that name into the Search bar at the top of the window and pressing Return/Enter. Once you 
have the node you want to use, double-click on it and then click in the drawing area to place it.

Nodes are connected to each other in the same way as Grasshopper components: when 
you hover over an output, an angled arrow cursor appears. Click on the output to grab 
the wire, then click on the input of another node to attach the wire. Multiple wires can be 
attached to a single input; the node will automatically list the values. In order to perform 
analysis or see the geometry created by the network, you have to run the script, similar to 
“Bake” in Grasshopper. To run a script, you can select any node in the network and either 
right-click and select “Run Marionette Script” or click on the “Run” button in the OIP.
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ADD A CUSTOM MARIONETTE LIBRARY

The Marionette object created in tutorial 2 uses a pre-built wrapper that is located in My Marionette 
Resources, a file that can be downloaded from the same location as this tutorial file. Save My 
Marionette Resources somewhere safe and permanent and then open Vectorworks. Access the 
Resource Manager (Window > Palettes > Resource Manager) and click on the File Options 
menu next to the gear icon in the Tool bar. In the menu, choose “Add New Favorites Files” and 
in the file browser window that opens, navigate to the My Marionette Resources file, select it, 
and click “Open.” The file should now appear in the File Browser pane on the left side of the 
Resource Manager. If it does not, ensure that the yellow star icon is highlighted in the Tool bar 
of the Resource Manager. Click on the arrow to the left of My Marionette Resources and select 
the My Wrappers folder. A wrapper node will appear in the Resource Viewer pane. This wrapper 
is now available to be placed in a drawing with either the Selection tool or the Marionette tool. 
A wrapper is a network of nodes that is “wrapped” up into a package and can be used just like 
any other node as part of a larger network. Wrappers can also be converted to menu commands 
and Marionette objects. As you begin to build your own Marionette networks, you can use 
this file to save your wrappers, menu commands, and Marionette objects as resources.

FIGURE 2: The Resource Manager showing “My Marionette Resources” added as a Favorite
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TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE

For this tutorial, we are going to build a menu command that allows you to change class names 
in bulk, based on what is currently in the class name — basically a find and replace command for 
classes. Since we are going to be dealing with classes, let’s start by getting some nodes from the 
Classes folder. First, select the Marionette tool in the Basic tool palette and ensure that Insertion 
Mode  is highlighted in the Tool bar, then click the Current Node drop-down menu. Within the 
Default Marionette library, there is a folder named “Classes.” These are all nodes that are relevant 
to manipulating classes in Vectorworks. We will need a list of classes in our network, so find the 
Get Class List node in the Classes > Get Operations - Classes folder and place it in the drawing. 

FIGURE 3 - The Get Class List node from the Classes folder

If you look at the node, you can see that the input name is “iIndex” and the output name is 
“sName” meaning that the node is asking for an integer that represents an index number and 
the node is producing a string that represents a name. With the node selected, from the Object 
Info palette (OIP) click the “Description” button. The description of the node reads: “Returns 
the name of a class at a given index in the document class list.” To use this node, we need to 
have a list of index numbers that represent each class in the document. This means we need 
a node that tells us how many classes are in the document, so return to the Marionette tool 
and locate the Get Class Count node in the Classes > Get Operations - Classes folder.

FIGURE 4 - The Get Class Count node from the Classes folder

We can use the number produced by this node to build a series of numbers. 
Next, we will need a Series node from the Data Flow folder. 

FIGURE 5 - The Series node from the Data Flow folder
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TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)

The Series node in Marionette works the same way as the Series component in Grasshopper. If 
we look at the description for the Series node, it says that the default start value is 0, the default 
step value is 1, and the default count value is 1. In the description of the Get Class List node, it 
says that the “iIndex” input takes a number from range 1-n, so our series must start with the 
number 1. Let’s select the Marionette tool and get an Integer node from the Input > Basic folder.

FIGURE 6 - The Integer node from the Input folder

This node produces an integer value that the user types into the appropriate field in the OIP, so 
 with the node selected, access the OIP and type “1” into the field labeled “Integer.” Next, connect 
the Integer node to the “nStart” input of the Series node and connect the Get Class Count node 
 to the “iCount” input of the Series node, then connect the output of the Series node to the 
Get Class List node.

FIGURE 7 - Creating a list of class names 

These four nodes create a list of all the class names in the current document. If you want 
to see if your network is working correctly, select the Marionette tool and get a Dummy 
End node from the Debug folder and connect the output of the Get Class List node to it.

FIGURE 8 - The Dummy End node from the Debug folder
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TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)

The purpose of a Dummy End node is simply to create a wire that can be used for debugging. 
With the Marionette tool selected, select the Debug mode  from the Tool bar. When you 
move your cursor back to the drawing area, a pointing hand cursor should display. Mouse over 
the wire connecting the Get Class List node to the Dummy End node. When the wire highlights 
red, click on it to run the network. The “Marionette Wire Values” dialog box opens to display the 
values running through the wire. In this instance, the values are a list of current classes in the 
document, in the order that they were created. The number in brackets on the left represents 
each value’s place in the list. In other words, the index of each value. If there are more than 
ten values in the list, there will be “Prev” and “Next” buttons that allow you to scroll through 
the list, ten values at a time. When you run a network in Debug mode, a number will appear 
to the right of every output port showing how many values are coming out of the port.

FIGURE 9 - Viewing the values passing through a wire in Debug Mode

To continue, you can disconnect the Dummy End node and move it to the side in case you 
want to use it later, or you can delete it. Next, we need a way to filter our class list to just the 
ones we want to edit. It follows that we will need a Filter node and some sort of “if statement” 
node. The Filter node can be found in the Data Flow folder; place it in the drawing.

FIGURE 10 - The Filter node from the Data Flow folder
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Now we will need an If In String node from the String folder. The If In String node is a conditional 
node that tests whether one string exists within another.  

FIGURE 11 - The If In String node from the String folder

Next, connect the Get Class List output to the “sFull” input of the If In String node as well as the 
“item” input of the Filter node, and connect the “b” output of the If In String node to the “b”  
input of the Filter node.

FIGURE 12 – The network so far

Now we need a string to search for within the class names. We will need a String node from 
the Input > Basic folder and a String Dialog node from the User Interaction folder.

FIGURE 13 - The String node from the Input folder and the String Dialog node from the User Interaction folder

TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)
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Place these nodes on the drawing, and connect the output of the String node to the input 
of the String Dialog node and then connect the output of the String Dialog node to the 
“sSub” input of the If In String node. With the String Dialog node selected, access the OIP 
and where it says, “Enter a string,” delete the text and type in “If the class name contains:” 
instead. You can leave the text box in the String node blank. The String Dialog node allows 
the user to type in string values after the network has been run. This type of node is ideal 
for menu commands. Run the network as is to see the String Dialog node in action.

FIGURE 14 - Running the network at this point results in a dialog box that asks the user to enter a string value

When you run this network, a dialog box opens for you to enter a string value to search for within 
the class name strings. If you do not enter any text into the dialog box, you must click Cancel.

Based on the network we have built so far, the output of the Filter node will be two lists, a 
list of classes that contain the string entered into the dialog box and a list of classes that do 
not contain the string. The list of classes that do contain the string would be represented 
by the “True” Boolean values from the If In String node, so they would come from the 
“listTItems” output. Now return to the String folder and choose the Replace String node.

FIGURE 15 - The Replace String node from the String folder

Once we place that node on the drawing, access the Classes > Set Operations - Classes 
folder and select the Rename Class node and place it on the drawing as well.

FIGURE 16 - The Rename Class node from the Classes folder

TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)
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Connect the “listTItems” output of the Filter node to the “sFull” input of the Replace 
String node as well as to the “sName” input of the Rename Class node. Next, connect the 
Replace String node’s output to the “sNewName” input of the Rename Class node. Now, 
all we need are input values for the other inputs of the Replace String node. The output of 
the String Dialog node can be connected to the “sOld” input of the Replace String node, 
because the string you search for in the class will be the same string that you replace. 

FIGURE 17 - The network with the Replace String node and Rename Class node added

Next, we can copy the String and String Dialog node and paste them directly below the 
originals, and then attach the output of the new String Dialog node to the “sNew” input 
of the Replace String node. Select the new String Dialog node and change the text in 
the text field to “Replace it with this string:” because this will be where you enter the 
replacement text to change the class names. Your network should look like this:

FIGURE 18 - The network is ready to be converted to a Menu Command

Feel free to test the network to ensure that it works. When you run the network, you should be 
prompted to type in text to find within class names and to type in new text to replace the old text.

Now we can convert our network to a menu command. First, we have to wrap the network, 
which we can do by right-clicking on any node in the network and selecting “Wrap Marionette 
Network” from the context menu. We will be prompted to enter a name and description for our 
wrapper. You can name it “Rename Classes” and write a quick description of what it does. 

FIGURE 19 - The Wrap Marionette Network Dialog Box

TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)
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Even though the wrapper information will not be accessible once it is a menu command, the 
wrapper will exist in your User folder and if you ever want to share it with someone else, the name 
and description will be useful. Once it is a wrapper, right-click on it and select “Convert to Menu 
Command.” A dialog box will prompt you to type in the name of the menu command, so name 
it exactly as you would like it to appear in the menu. A popular convention for menu commands 
in Vectorworks that have subsequent steps is for there to be an ellipsis at the end of the name, 
so type the name “Rename Classes…” into the dialog box and click OK. Now you can access the 
menu path Tools > Marionette Commands > and find your newly created menu command.

FIGURE 20 - The path to the new menu command

TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)
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If you want to edit or share the menu command, you can find it in your User folder under 
Libraries > Defaults > Marionette > Marionette Command Library.vwx. To edit a menu 
command, edit the wrapper as you would any other wrapper, then convert it to a menu command 
again, and give it the same name as the old one, forcing it to replace the old with the new.

FIGURE 21 - Location of wrapper after it has been converted into a menu command

TUTORIAL 1: BUILD A MENU COMMAND  
WITH MARIONETTE (CONT’D)
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TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE

For this tutorial, we are going to build a Marionette object that functions as a parametric, 
path-based ramp. We will start with a drawn piece of geometry, so draw a curved 
polyline that is about 50’ long. You can set the scale of your drawing to ¼” = 1’0”. (In 
metric, this would translate to a 15m polyline and a drawing scale of 1:50.)

FIGURE 22 - The starting geometry for the Marionette Object

Marionette nodes are automatically set to page scale, so it will be easy to see the path and 
Marionette nodes at the same time, as long as the scale of your document is appropriate to 
the geometry. To reference a specific piece of existing geometry with Marionette, the geometry 
must be given a name. With the object selected, access the OIP and type a unique name into 
the “Name” field at the bottom of the palette. Now from the Resource Selector select the 
Marionette tool, find the Name node in the Input > Basic folder, then place it in the drawing. 

FIGURE 23 - The Name node from the Input folder
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In the OIP of the Name node, there is a field labeled “Object Name.” Type the unique name you 
gave the polyline into the field, and deselect the checkbox labeled “Create a duplicate object.” 
This checkbox should only remain selected if you plan to delete the object within a network.

Now we have connected geometry to a Marionette node and we can use it in a network. 
The Name node will be necessary to connect the polyline to the network while we build and 
test our network, but when we convert the network to a Marionette object, we will need to 
replace the Name node with a Control Geometry node, so in order to make that transfer 
easier, we can connect the Name node to a Pass node from the Data Flow folder. 

FIGURE 24 - The Name node from the Input folder connected to a Pass node from the Data Flow folder

Since the polyline will be the basis for the network, the Name node will most likely be connected 
to multiple other nodes, and when it is time to be replaced, all of those connections will also 
need to be replaced. The Pass node does not do anything, it simply allows the information 
from wires to pass through it. If we use the output port of the Pass node to connect to the 
rest of the network, replacing the Name node will only involve disconnecting the Name 
node from the Pass node and connecting the Control Geometry node to the Pass node.

The polyline will be the path, or centerline, of our ramp; to gradually incline the curve, we first need 
to locate an array of coordinates along the path. To do this we first need a Get Point On Poly node 
from the folder Objects > Poly > 2D.

FIGURE 25 - The Get Point On Poly node from the 2D folder

As we can see from the description of this node, it gives a point on a poly based on a specified 
distance, as well as a vector tangent to that point. In order to get a series of points equidistant  
along the poly, we will need to create a range of values between 0 and the total length of the  
poly. To do this, we will need a Get Length node from the Object Info folder and a Range node  
from the Data Flow folder.

FIGURE 26 - The Get Length node from the Object Info folder and the Range node from the Data Flow folder

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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Next we will need an Integer node from the Input > Basic folder.

FIGURE 27 - The Integer node from the Input folder

With the Integer node selected, type “20” into the data field in the OIP, then connect the output of 
the Integer node to the “iCount” input of the Range node. The number 20 is an arbitrary value to 
create the number of points along the poly. It is important to remember that the “iCount” input for 
the Range node is actually the number of divisions between values, not the number of values, so a 
range with a count of 20 will yield 21 values. Next, connect the output of the Pass node to the Get 
Length node input, and connect the output of the Get Length node to the “nStop” input of the Range 
node. Next, connect the output of the Range node to the “nDist” input of the Get Point On Poly node. 
Finally, connect the output of the Pass node to the “hPoly” input of the Get Point On Poly node.

FIGURE 28 - Creating a range of values to locate points along a poly

Building a range based on the length of the poly consistently creates a False value for the final 
point, perhaps due to the tolerances of the Get Point On Poly node, so the solution is to remove the 
final value of the list and replace it with the end point of the poly, which we can easily find. To get 
the end point of a poly we will need a Get 2D Vertex node from the Objects > Poly > 2D folder.

FIGURE 29 - The Get 2D Vertex node from the 2D folder

This node gives us a vertex based on its index value, and to get the index value of the last point we 
need to know how many points are in the poly. We will need a Get 2D Vertex Count node from the 
Objects > Poly > 2D folder as well as a User Function node from the Math > Special folder.

FIGURE 30 - The Get 2D Vertex Count node from the 2D folder and the User Function node from the Math folder

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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The Get 2D Vertex Count node will give us the number of vertices in the poly, but since lists 
have a starting index of 0, the index value of the last vertex will always be one less than the total 
number of vertices, so that is where the User Function node comes into play. The User Function 
node allows you to enter a single-variable function into the data field of the OIP. It can be a Python 
function or a mathematical function, but the mathematical functions must use a Python syntax. 
Even if you are unfamiliar with Python, this is simple because it follows the same conventions as 
written functions. The function that we will enter into the OIP of the User Function node is “x – 1.” 

FIGURE 31 - With the User Function node selected, type “x - 1” into the “f(x):” data field in the OIP

Now connect the output of the Pass node to the input of the Get 2D Vertex Count node, connect 
the output of the Get 2D Vertex Count node to the input of the User Function node, and 
connect the output of the User Function node to the “iIndex” input of the Get 2D Vertex node. 
Next, connect the output of the Pass node to the “hPoly” input of the Get 2D Vertex node.

FIGURE 32 - A network that finds a series of points along a poly as well as the final vertex of the poly

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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Now that we have a list of points along a poly as well as its last vertex, we can replace the last value 
in the list of points with the final vertex. To do this, we will need a Pop Back node and an Append 
node. Both of these nodes can be found in the Data Flow folder.

FIGURE 33 - The Pop Back node and the Append node from the Data Flow folder

The Pop Back node removes the last value from the input list and the Append node adds the input 
item to the end of the input list. Connect the “p” output of the Get Point On Poly node to  
the “list” input of the Pop Back node and the “list” output of the Pop Back node to the “list”  
input of the Append node. Finally, connect the output of the Get 2D Vertex node to the “item”  
input of the Append node.

FIGURE 34 - This section of the network removes the last value of the points list and replaces it with the last point of the poly

Now we have points that are equidistant along the poly, we need to offset those points to either 
side of the poly so that our ramp has a width. To do this, we will need an Offset XY Coordinates 
wrapper from the My Marionette Resources file that should be in the Favorites section of the 
Resource Manager. To get this wrapper, go to the Resource Selector in the Tool bar of the 
Marionette tool, just like you would for a node in the default library, but instead of going to the 
folders in the default library, go to the My Wrappers folder in the My Marionette Resources file in 
the Favorites section of the File Browser pane and select the Offset XY Coordinates wrapper.

FIGURE 35 - The Offset XY Coordinates wrapper from the My Wrappers folder in the My Marionette Resources Favorites file

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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A wrapper is a network of nodes that is “wrapped” up into a package that can be used 
just like any other node (similar to a “cluster” in Grasshopper). To create input and output 
ports, you simply name nodes with open ports and those ports will appear on the outside of 
the wrapper. The Offset XY Coordinates wrapper is made up of math and point nodes that 
calculate the offsets of the X and Y values of a point, based on an overall width and a tangent 
vector. To see the network inside the wrapper, simply double-click on it. Wrappers are a 
great way to consolidate networks and save them for use as a part of other networks.

To incorporate the Offset XY Coordinates wrapper into the network, connect the output of 
the Append node to the “p” input of the wrapper and connect the “vTan” output of the Get 
Point On Poly node to the “vTan” input of the wrapper. The other information needed for the 
Offset XY Coordinates wrapper is the total width of the ramp. To supply this information, 
we will need a Dimension node from the Input folder. Place the node in the drawing area 
and give it a value of 4’0” in the “Dim” data field, and name the node “Ramp Width.”

FIGURE 36 - The Dimension node from the Input folder

Connect the output of the Dimension node to the “nWidth” 
input of the Offset XY Coordinates wrapper.

FIGURE 37 - This network creates offset points from the original polyline

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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Now that we have our points, we can use them to build NURBS curves and then loft those curves 
to create a ramp. First, we need to convert our two sets of 2D points to four sets of 3D points 
(two sets of 3D points to follow the rise of the ramp and two sets to stay at a Z height of 0). So 
we will need two Get XY nodes and four Point 3D nodes from the Points folder. Connect the 
“nX” output of the first Get XY node to the “nX” input of the first and second Point 3D nodes and 
connect the “nY” output of the first Get XY node to the “nY” input of the first and second Point 
3D nodes. Repeat this with the second Get XY node and the third and fourth Point 3D nodes. 

FIGURE 38 - The Get XY nodes connected to the Point 3D nodes both from the Points folder

Next connect the “p1” output of the Offset XY Coordinates wrapper to the 
input of the first Get XY node and the “p2” output to the second Get XY 
node. These nodes will allow us to add Z values to our points.

FIGURE 39 - The network so far

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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To create these Z values, we will need two more Dimension nodes from the Input > Basic folder, an 
Add node from the Math > Basic Math folder, and another Range node from the Data flow folder.

FIGURE 40 - Two Dimension nodes from the Input folder, the Add node from the Math folder, and the Range node from the Data Flow folder

These Dimension nodes will represent the height at which the ramp will start and the height that 
the ramp will rise, so name the first Dimension node “Ramp Start Height” and give it value of 0 in 
the “Dim” data field, and then name the second Dimension node “Ramp Rise” and give it a value of 
3’0” in the “Dim” data field.

FIGURE 41 - The OIPs of the two Dimension nodes

Connect “Ramp Start Height” to the “nStart” input of the Range node and to the “n1” input of the 
Add node. Next, connect “Ramp Rise” to the “n2” input of the Add node and connect the output of 
the Add node to the “nStop” input of the Range node.

FIGURE 42 - Creating a range of Z values

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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The “Ramp Start Height” represents the height at which the lower end of the ramp will start 
and will therefore be the lowest value in our range of Z values. The “Ramp Rise” represents 
the difference in height between where the ramp starts and the ramp ends, thus “Ramp 
Rise” + “Ramp Start Height” equals the highest value in our range of Z values. Now we 
need to set the number of divisions of our range, and since we are matching these values 
to the number of divisions of our poly, we will use the same “iCount” value that we applied 
to the first Range node in our network. So connect the Integer node used earlier in the 
network to the “iCount” input of the latest Range node. Next, connect the output of this 
Range node to the “nZ” input of the second and third Point 3D nodes in the network.

FIGURE 43 - A network that creates four lists of 3D points offset from a polyline

Now we will need four Curve nodes from the Objects > NURBS > Curves folder - one for each of 
our Point 3D nodes, as well as a Real node from the Input folder.

FIGURE 44 - The Real node from the Input folder and four Curve nodes from the NURBS folder

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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In the OIP of the Real node, give it a real value of 3, and connect the output to the “nDeg” input 
of each of the four Curve nodes. Next, connect the outputs of each of the Point 3D nodes to 
the “listPoints” inputs of each of the Curve nodes. This will create a NURBS curve for each of 
the lists of 3D points with a degree of 3. The default value of the “bByCtrlPts” input is False, 
meaning that the curves will be drawn with interpolated points instead of control points.

FIGURE 45 - The Point 3D nodes connected to the Curve nodes

Next we will need an Ordered List node from the Data Flow folder, a Group node from the 
Operations folder, and a Loft Surface node from the Objects > NURBS > Surface folder.

FIGURE 46 - The Ordered List node from the Data Flow folder, the Group node from the Operations folder, and the Loft Surface node from the 
NURBS folder

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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The Ordered List node will be used to create a list of curves from the four Curve nodes. If 
we look at the input of the Loft Surface node it says “groupCurves,” not “listCurves” so first 
we will have to convert our list of curves to a group with the Group node. To add these nodes 
to the network, connect the outputs of the four Curve nodes to the first four inputs of the 
Ordered List node, then connect the output of the Ordered List node to the “hObjs” input 
of the Group node and the output of the Group node to the input of the Loft Surface node. 
Finally, in the OIP of the Loft Surface node, ensure that “rule” is selected. This setting means 
that the surface will crease at each curve, not make a curved sweep through all four.

FIGURE 47 - The Curve nodes connected to the Ordered List node in order to build a loft surface

The network we have built at this point will create a lofted surface in the shape of a ramp.

FIGURE 48 - A network that creates a loft surface in the shape of a ramp

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)



 22 Switching from Grasshopper to Vectorworks

To create a ramp, right-click on any node in the network and choose “Run Marionette 
Script.” To see the ramp in a 3D view, turn on multiple view panes by going to the 
menu View > Multiple View Panes > Enable Multiple View Panes, or by clicking the 

 button in the View bar, or by simply pressing the “m” key. Node wires can only 
be attached and detached in Top/Plan view, so it is necessary to work in Top/Plan 
with Marionette, but you can still see the 3D objects with multiple view panes.

FIGURE 49 - A Marionette network that creates a ramp, visible in multiple view panes

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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We now have a lofted ramp that we can use in a larger model. If we wrap the network, the named 
parameters will appear in the OIP as data fields. To wrap a network, right-click on any node and 
select “Wrap Marionette Network.”

FIGURE 50 - The OIP of a wrapper shows named Input nodes as data fields

TUTORIAL 2: BUILD A MARIONETTE OBJECT  
WITH MARIONETTE (CONT’D)
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Now that we have a wrapper, we could go a step further and convert this to a plug-in object, but 
it is important to know that in Vectorworks, plug-in objects with 3D geometry need separate 2D 
geometry to display correctly in a 2D view. This is useful for creating plan drawings where objects 
may have an appearance that follows drawing conventions, not necessarily the top view of a 3D 
object. So before we convert this wrapper to a plug-in object, we must first build a new network that 
creates a 2D version of the ramp and incorporate it into our existing network. We will use the 2D 
coordinates that were created by the Offset XY Coordinates wrapper to create a closed 2D polygon.

First, we can unwrap the network in order to continue working on it. (We could edit it  
within the wrapper, but debug mode does not work within a wrapper, so it is easier in  
this case to simply unwrap it.) To unwrap a network, right-click on the wrapper and  
select “Unwrap Marionette Network.”

FIGURE 51 - The context menu of a Marionette wrapper

To create a new polygon from the coordinates we already have, we need to combine the  
two lists of coordinates into one. We will need a List node and a Reverse List node, both  
from the Data Flow folder.

FIGURE 52 - The Reverse List node and the List node from the Data Flow folder
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To get the coordinates in the correct order for drawing a polygon, we need to flip one of the 
lists. Connect the “p1” output of the Offset XY Coordinates wrapper to the “item1” input 
of the List node and the “p2” output of the wrapper to the input of the Reverse List node. 
Next, connect the output of the Reverse List node to the “item2” input of the List node. 

FIGURE 53 - Creating a list of points from the Offset XY Coordinates outputs

Now that we have the points listed in the proper order, we can get a Polygon 2D node 
from Objects > Poly > 2D folder and connect the output of the List node to it.

FIGURE 54 - The list node connected to the Polygon 2D node
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This will create a poly that has all corner vertices, but we need to convert all but 
the points that make up the ends of the ramp to Bézier vertices. We can do this by 
creating a list of indices that correspond to the vertices we want to convert. To create 
a full list of indices, we will need a Get List Length node and a Series node. 

FIGURE 55 - The Get List Length node and the Series node from the Data Flow folder

Connect the output of the List node to the input of the Get List Length node and connect the output 
of the Get List Length node to the “iCount” input of the Series node. The Series node is similar to 
the Range node in that it creates a sequence of numbers, but instead of asking for a start, stop, 
and count, the Series node asks for a start, step, and count. For this reason, when you give it a 
count of 20, the Series node will produce 20 values, when the Range node produces 21 values. 

With the Get List Length node and the Series node connected to the network, we now have a list 
of indices for each of the vertices in our polygon. Now we need to find the indices for the vertices 
that we don’t want to change, and remove them from this list. We know that the first and last 
coordinates from the “p1” and “p2” outputs will be the vertices that we don’t want to change, so 
we can find those with another Get List Length node and two User Function nodes. Since both 
of these nodes are already in the drawing area, you can simply copy and paste them. In the two 
new User Function nodes, the function will be the same as the original, so there is no need to 
change it. We will also need another Integer node and another Ordered List node, which can be 
copied and pasted as well. Change the value of the new Integer node to 0, and connect it to the 
“item0” input of the Ordered List node. Connect each Get List Length node to the User Function 
nodes and connect these and the second Get List Length node in the order shown in figure 56.

FIGURE 56 - Creating a list of indices to remove
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If you attach a Dummy End node from the Debug folder to the output of the Ordered 
List node and click on that wire in Debug mode, you should see these four values.

FIGURE 57 - The four index values to be removed

If the four values are not in the right order, try reordering the wires, or if the values 
are incorrect, ensure that the value in the data field of both of the User Function nodes 
is “x – 1.” Once you have the correct values, you can remove the Dummy End node 
from the network. Now, we will need a Remove node from the Data Flow folder.

FIGURE 58 - The Remove node from the Data Flow folder

Connect the output of the Series node to the “list” input of the Remove node and connect the output 
of the Ordered List node to the “item” input of the Remove node. Now we have a list of indices 
that we will convert to Bézier vertices. Since we ran our network in Debug mode, in our drawing 
we should have a 2D polygon with all corner vertices. The other thing to notice is that the poly is 
not closed, so we will need to close the poly, as well as convert the vertices. So we will need a 
Set Closed 2D node and a Change Vertex Type node, both from the Objects > Poly > 2D folder.

FIGURE 59 - The Set Closed 2D node and the Change Vertex Type node from the 2D folder
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First, select the Change Vertex Type node and set the dropdown menu in the OIP to “Bézier.” 
This will convert the specified indices to Bézier vertices. Next, connect the output of the 
Polygon 2D node to the input of the Set Closed 2D node, and connect the output of the 
Set Closed 2D node to the “hPoly” input of the Change Vertex Type node. Finally, connect 
the output of the Remove node to the “iIndex” input of the Change Vertex Type node.

FIGURE 60 - This section of the network creates a 2D poly in the shape of the ramp

In figure 60, the numbers to the right of some of the outputs indicate the number of values 
passing through the wires - these are visible because the network was last run in Debug mode.

Because this poly will be the 2D representation of our curved NURBS ramp, we want to be able to 
set its attributes apart from the actual ramp. The easiest way to control 2D attributes is by class, so 
we will need a Set Class node from the Attributes > Set Operations - Attributes folder, as well as 
a String node from the Inputs > Basic folder. The String node can be used to type the name of the 
class you want to choose. Give the text field a default value of “None.” The text field of the String 
node will need to be visible in the OIP of our Marionette object, so name the node “Ramp 2D Class.”

FIGURE 61 - The String node from the Inputs > Basic folder and the Set Class node from the Attributes > Set Operations - Attributes folder
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Connect the output of the Change Vertex Type node to the “hObj” input of 
the Set Class node and connect the output of the String node to the “sClass” 
input of the Set Class node. Our network is almost complete.

FIGURE 62 – A Network that creates a NURBS ramp and a 2D polygon

If we want to set the order of data fields in the OIP of our Marionette object, we 
can do so by numbering them. To number an Input node, simply type a number 
in front of the name of the node. The numbers will not display in the OIP.

FIGURE 63 - Input nodes can be given a number before their name so that they will be ordered in the OIP of the Marionette object

The last thing we need to do before converting the network to a Marionette 
object, is to switch the Name node we used at the beginning of the 
network to a Control Geometry node from the Input folder.

FIGURE 64 - The Control Geometry node from the Input folder

As mentioned before, the Name node is used in networks and wrappers when referring to existing 
geometry, but in a Marionette object, a Control Geometry node is used. To switch the nodes, 
delete or disconnect the Name node and connect the Control Geometry node to the Pass node. 

FIGURE 65 - Replacing the Name node with the Control Geometry node
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Now the network is ready to be converted into a Marionette object. Wrap the network 
by right-clicking on any node in the network. Give it a name and description if you wish, 
but it is not necessary. Once you have done this, select the original polyline path along 
with the wrapper, right-click on the wrapper and select “Convert to Object Node.”

FIGURE 66 - Converting a wrapper and control geometry to a Marionette object

When the dialog box opens, deselect “Reset on Move” and then click OK. You should 
now have a ramp that you can use in a 3D model and portray in a 2D drawing.

FIGURE 67 - Three views of the curved ramp Marionette object
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