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INTRODUCTION

The purpose of this guide is, quite simply, to get you started using the software. Just as landscape design is a huge and varied discipline, Vectorworks 
Landmark is a huge and wonderful tool. Its a wide range of features enable you to produce graphically beautiful, informative, and intelligent documents 
to support your design process. One of the enormous benefits of Vectorworks is that it is not prescriptive and does not force you to design in a particular 
way. This guide will use several short example tutorials to quickly introduce you to the key features of Vectorworks Landmark and get you up and 
running.

When you first open the program, it can seem a little daunting, particularly if you’re making the move from paper. This guide will enable you to 
overcome some of that fear and start making the most of the software.Vectorworks Landmark is so much more than a tool for producing beautiful plans 
and models. Used wisely, it can become the backbone of your design business and help out so many more business-critical tasks such as producing 
specifications and quantities.

Overview of This Guide
Each section of this guide will introduce you to different features that are key to landscape design. The exercises in this guide will familiarize you with 
these tools so that you use them in your own design projects.

It is not necessary for you to complete each section before moving to the section that specifically interests you. Having said that, it will do no harm to 
work through the exercises from start to finish, to get a full overview of the design process. The exercises include images and short movies for you to 
watch to see the exercises in action. The exercises will cover the following topics:

•	 setting up the software and accessing resources
•	 creating the existing site, including importing surveys, drawing buildings, and locating items on site such as existing vegetation
•	 hard landscaping/hardscape plans, including quantity reports
•	 creating planting plans including the plant schedule
•	 creating presentation plans including 3D views, title blocks, and borders.

How to Use This Tutorial
This tutorial is also provided as a series of videos, supported by this guide in a PDF format. You can view the PDF tutorial on-screen for enhanced 
electronic benefits, including navigation links and search features.

1.	 Each section will start with an objective and a list of the stages of the 
design process the section will cover. This overview is hyperlinked, as 
is the table of contents, so that you can quickly navigate to sections 
of interest.

2.	 If you view the tutorial on-screen, look for the Previous View and Next 
View tools at the bottom of the screen (or available in the Page 
Navigation Tool bar in newer versions). These useful tools—available 
in Adobe Reader and Acrobat—enable you revert or repeat 

navigational changes by page controls. bookmarks, and hyperlinks. 
Similar controls are available in Preview on the Macintosh.

3.	 The Adobe Reader Search tool provides more extensive options for 
searching text than the Find command does.
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General Tutorial Tips
As I mentioned earlier, I recommend that you first work through The Basics guide first. This guide provides a good grounding in the basic drawing 
functions. You can then use this guide to put your drawing skills into context for landscape design.

Use the following tips to facilitate working with your exercise drawing files:

•	 Menu commands are written as follows: 
Edit > Copy 
which means click on the Edit menu and then the Copy command on 
that menu.

•	 Read each step carefully and make sure your results match the 
figures. If your results vary from the figures, review the previous steps 
and try to work out which value has led you astray. If you can’t find the 
problem quickly, start the exercise over with the appropriate supplied 
file.

•	 Vectorworks offers many different ways to draw. Some users like to 
complete dialog boxes while some prefer the freedom of drawing with 
the mouse and typing dimensions as they go. Others prefer to draw 
and then refine measurements using the Object Info palette. There is 
no right or wrong method. The correct method is the one that works 
best for you.

•	 When you hover your cursor over objects you have drawn, pause 
briefly over snap points, (corners and midpoints), to display a red snap 
box. A red confirmation dot is displayed temporarily to show that your 
cursor has “snapped” to that point. Moving the cursor away will produce 
guidelines to assist you in aligning objects to others in your design. This 
system is known as SmartCursor cues.

•	 When too many red snap boxes are displayed in congested areas, 
you can press the Esc key once to clear the display, or you can 
temporarily disable all snaps by holding down the backquote key (`).

•	 While drawing, you may need to adjust your view. Press the Z key for 
the Snap Loupe shortcut (a temporary zoom), or use the Zoom, Pan 
(press and hold the Space bar), and Fit to Objects tools as required. If 
you have a mouse wheel, use it to zoom in and out.

•	 To pan across the drawing at any time (even if you are midway 
through drawing something), hold down the Space bar and then click 
and drag with your left mouse button.

•	 If you inadvertently cleared a selection required for an active tool or 
command, press Space bar+X temporarily while you select the 
object(s).

•	 Many tools have different ways of doing things. These are called 
modes, which you can select in the Tool bar (located above the drawing 
window).

•	 Keep the Object Info palette open. To open it, select Window > 
Palettes > Object Info. It displays valuable information and provides 
access to key properties of selected objects.

•	 Press the Esc key to cancel any operation. If you are using a tool, it 
will still be active. You can then start drawing again or choose another 
tool. Sometimes, you must press the Esc key before you use a 
keyboard shortcut to activate another tool.

•	 Use the Edit > Undo command to revert steps as necessary (both 
drawing and view changes are reverted). The shortcut for Edit > Undo 
is Ctrl+Z (Windows) or Command+Z (Macintosh).

•	 For tools that create multiple segments (such as the Polyline tool or 
the Wall tool) press the Delete key once while the tool is active to 
remove the last click without losing the entire object. Press the Delete 
key repeatedly to delete additional segments.

•	 When multiple files are open, you may need to click the Resource 
Browser’s Home button if your landscape file isn’t active.

•	 Object artifacts may remain in the drawing area after some drawing 
and editing operations. To refresh the screen and clear the artifacts, 
double-click the Pan tool (on the Basic palette).

•	 Save your files often to prevent data loss, and employ a backup 
strategy for your computer.

•	 Important: Exercise steps in this tutorial are based on default 
preference settings from a new installation of the Landmark program 
with Renderworks. Results for some steps may vary from the figures if 
your preference settings differ from the defaults.

Metric or Imperial?
•	 All exercise data set files for this tutorial were designed using metric 
values. However, I have included imperial measurements too, so use 
whichever you prefer. As each exercise section is standalone, it is not 
critical that you change your ways and convert to metric or imperial. 
Remember, Vectorworks Landmark is a flexible tool and you can use 
whichever is best for you.

•	 Imperial measurements are shown thus [1' 6"], (square brackets, with 
the unit mark), and Vectorworks will convert the values accordingly.

Keyboard Shortcuts
Although I use an Apple Macintosh, all keyboard shortcuts included in 
this guide will show both Windows and Macintosh. This will be written 
with the Microsoft Windows key first, followed by the Macintosh key. For 
example:

1.	 Press Ctrl+5 (Windows) or Command+5 (Macintosh) to restore Top/
Plan view.

Refer to the Vectorworks 2015 Shortcuts PDF file (available from the 
Help system) to print a complete list of your own keyboard shortcuts.
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SECTION 1: LANDMARK SETUP

Objectives for Section One
After following the exercise steps in this section, and watching the accompanying movies, you will be able to:

•	 Name the different elements of the Landmark workspace and set basic Preferences
•	 Access the libraries of content provided with Vectorworks Landmark from your workspace, while working in any file
•	 Set the page size, set your drawing scale, and use the grid settings to control the size and visibility of the grid.

Example Files Required For This Section:
•	 There are no specific examples required for this exercise, other than the Vectorworks resource files installed with your software.

Navigate the Landmark Workspace
Once your Vectorworks licence is activated, you will be presented with either the Vectorworks Landmark workspace, or the Vectorworks Designer 
workspace (if you have an Evaluation or Educational License). When first confronted with any new software application, it can seem a little terrifying. 
This is perfectly normal, so do not let it overwhelm you.

In this section we’ll take a look at the Landmark workspace, name the different areas, and learn the headline functions of those palettes. Then we will 
customize some preferences, a process that is a little like organizing your desk. You choose how you want things arranged and what things you want to 
have easy access to while working.
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The drawing area has a semi-transparent background color that helps you determine if objects are filled. This background color will not appear on your 
final drawings, and you can change it if you don’t like it. There may be a grid visible on your drawing area. This can be hidden and displayed as 
required. The labelled areas on the workspace are described as follows:

Get to Know the Workspace
1.	 If you are using an evaluation or educational license, choose  

Tools > Workspaces > Landmark and wait a moment for the 
Landmark workspace to load.

2.	 On the left of the workspace you will find two tool palettes. The Basic 
palette contains 2D tools for drawing simple, regular shapes and 
more complex irregular shapes. Many of these objects can quickly be 
converted to 3D using the Push/Pull functionality built into their tools. 
Click on some of the tools. Notice that the Tool bar changes as you 
choose different tools.

3.	 The Tool bar provides different options, known as modes, for each 
tool. For example, click the Rectangle tool, you’ll see the Tool bar 
change to offer you four different ways to draw a rectangle. Click the 
Selection tool again, or press X as a shortcut to return to the 
Selection tool.

4.	 The Tool sets palette, below the Basic palette, contains buttons to 
activate more industry-specific tools for performing more specific 
tasks. Click the Building Shell tool set icon and notice the tools for 
creating walls, doors, and windows. Many of these tools are “hybrid” 
in nature, which means they contain both a 2D and 3D representation 
of the object. These tools also store information about the object—so 
you can produce schedules directly from your design. Click the Wall 
tool. On the Tool bar, click the button with a wrench and pencil icon. 
This will open the Wall Preferences dialog, where you can specify the 
kind of wall you want to draw. Click Cancel. You’ll learn more about 
Walls later. Many of the tools in the Tool Sets will have a Tool 
Preferences button just like this.

5.	 The View bar can be customized to include different elements but is 
used to control the current class, layer, and scale. It has menus for 
saving views and for zooming the view. It has menus for changing to 
preset 3D views and rendering your 3D model. Click on the Utility 
menu and add Layer Scale to your View bar. If you don’t have a 
large screen, you can also remove Zoom long from the View bar.

6.	 The Attributes palette has a menu for assigning different fill colors 
and styles to 2D objects. It has a menu for changing the pen weight, 
color, and style to objects. You can also use it to vary the Opacity/
Transparency of objects on your plan.

7.	 The Snapping palette has controls to help you draw with accuracy 
and precision. For example, the Snap to Object facility will highlight 
the names of points on objects when the mouse is held over them. 
The Smart Points option draws temporary helpful guidelines on the 
screen to assist you in aligning new objects with existing elements in 
the design.

8.	 The Quick Preferences area on the right of the Tool bar is for 
preferences you may wish to change frequently. Click on the arrow to 
the right to access a list of features that can be added to the Quick 
Preferences area. Select Auto Join Walls, Display Light Objects, 
Show Clip Cube, Show Grid, Show Other Objects in Edit Modes, 
Show Page Boundary, and Show Rulers. Note that you can also 
access further Document Preferences and Vectorworks Preferences. 
Document Preferences are specific to the current file, whereas 
Vectorworks Preferences remain active for every Vectorworks 
session.

9.	 The Navigation palette is used to manage and navigate the 
organizational structure of the drawing. More about this later.

10.	The Object Info palette is similar to a properties palette or an 
inspector palette that you may have used in other applications. Click 
the Rectangle tool on the Basic palette and draw a rectangle any 
size, anywhere on the drawing area. The rectangle will remain 
“selected.” Look at the Object Info palette and notice that it displays 
information about the rectangle. Change the values in the Height and 
Width fields. Notice the rectangle changes size. Press Del/Backspace 
on your keyboard to delete the rectangle. Click the Selection tool 
again.

11.	The Resource Browser is used to access and manage libraries of 
objects you can use in your design. There is further information on 
the Resource Browser in the following section.

12.	The Message bar at the bottom of the screen is often overlooked. If 
Vectorworks is unable to complete the task you have requested, it will 
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display helpful information about the failure here to help you 
determine the problem.

Accessing Landmark Resources
In addition to a wide range of drawing features, Vectorworks comes with libraries of ready-made items that you can use in your design. The term 
“resource” in Vectorworks is a collective name for a variety of different elements, including:

•	 Line Types
•	 Symbols
•	 Tiles
•	 Renderworks Textures
•	 And much more...

In this exercise, you’ll add the Landmark specific resources as “favorites” so you can quickly gain access to them from any file.

When you installed Vectorworks, you were offered the opportunity to visit a website and download Vectorworks content. If you chose not to do this, you 
should now visit the Vectorworks Help menu and choose Download Content. Instructions are included on this web page, so follow those, and once you 
have downloaded and installed this content, follow the instructions below, to make this content permanently available on your Vectorworks Landmark 
workspace. This process covered in this video applies equally to libraries downloaded from the Vectorworks Service Select portal, or any other 
Vectorworks files that contain resources you want to use on a regular basis.

Add Favorite Resource Files
1.	 The Resource Browser has its own utility menu system. The top 

menu is for managing resource files (the Files menu), and the lower 
menu is for making changes to specific resources (the Resources 
menu).

2.	 The Resource Browser also has two drop-down menus. The top 
menu is for navigating to different resource files, and the lower menu 
is for navigating the folder structure within a specific resource file.

3.	 On the Files menu, choose Add New Favorite Files.
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4.	 When the Explorer (Windows) or Finder (Macintosh) window opens, 
notice that it has taken you to the location where Vectorworks is 
installed:

•	 C:/Program Files/Vectorworks 2015 (Windows)
•	 /User/Applications/Vectorworks 2015 (Macintosh)

5.	 Double-click the Libraries folder.

6.	 Double-click the Objects-Landscape and Site folder. Highlight all 
the file names in this folder, and click Open.

7.	 Repeat the process until you have added the contents of the following 
folders:

•	 Textures (Renderworks is required to use Textures.)

8.	 On the Resource Browser, click the Files list. You will see a list of 
Favorites. Click on any of the file names to review its contents in the 
window below. Click the Home button on the right of the palette to 
return the Resource Browser to a view of the current file.

Setting Up the Drawing Area
Vectorworks Landmark has some very sophisticated tools for laying out presentation drawings. These tools typically come into play at the end of the 
design project, so setting up a specific page size at the start is not essential. But I generally find that new users, who might be moving from paper-
based design, have a strong desire to see a page on the screen at the beginning of the project. The process is covered here to reassure you! To 
complete this part of the design process on paper, you would need to choose a physical piece of paper for your drawing board, decide on the unit of 
measure you’re going to use, choose the appropriate architectural scale, and place a sheet of graph paper under your design to help you with 
proportions.

This exercise is not a precursor to any of the design exercises. Rather, it is a stand-alone set of instructions to help you set up your new projects.

Setting the Page Size
1.	 Create a new file, using File > New, and then choose Use Document 

Template. Choose one of the Landmark templates and click OK.

To change the size of the Drawing Area, choose File > Page Setup.

•	 If you will be printing on a printer already installed in your office, 
choose Printer Setup and then choose the printer and relevant paper 
size. In the size field, ensure One Printer Page is selected.
•	 If you will be sending the file electronically for printing on an unknown 
printer, check Choose size unavailable in printer setup, and then 
choose a standard paper size to suit your needs. The list includes US 
sizes and international metric standard sizes.

2.	 Click OK. The page will resize. Click Fit to Page on the View bar to 
see the page boundary. Click Show/Hide Page Boundary on the 
Quick Preferences bar to control the visibility of the page boundary.

3.	 Choose File > Page Setup and uncheck Show Page Breaks. Click 
OK.

Setting the Unit of Measure
1.	 Choose File > Document Settings > Units.
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2.	 Choose appropriate Length, Area, Volume and Angle units of 
measure for your geography and the project. Click OK. The ruler 
displays your chosen units.

Setting the Drawing Scale
1.	 Click the Layer Scale button you added to the View bar earlier. 

Choose an appropriate scale for your page setup and project. Click 
OK.

2.	 You will see the scale is displayed on the View bar. The ruler is 
resized to accommodate your scale change.

Showing/Sizing the Grid
1.	 To turn the Grid on or off, use the Show/Hide Grid Quick Preference 

button that you added to the View bar above. You may need to zoom 
closer to the drawing area to see the grid. Use the mouse wheel if 
you have one, or two fingers on your trackpad if you are using a 
Macintosh.

2.	 To change the grid size, double-click the Snap to Grid button on the 
Snapping palette. When Vectorworks offers the handy hint that you 
can disable all snaps using the back quote key, click OK. The Snap 
Grid is always invisible, but when Snap to Grid is on, it forces your 
drawing to fit to the snap grid.

3.	 Set the Snap Grid to something small (for example, 1 mm [1/16”]). 
This ensures that if Snap to Grid is turned on, you will still be able to 
draw small lengths.

4.	 The Reference Grid is the blue grid visible on the screen and does 
not control drawing functions. It is there simply for your reference. 
Change the size to 1000 mm [3’].

5.	 Click OK to close the dialog.

6.	 It’s my recommendation that you work with Snap to Grid turned off 
unless you have a specific need to use it. Click Snap to Grid on the 
Snapping palette, to turn it off.

Turn On Auto-classing
Vectorworks uses Auto-classing to automatically classify certain objects 
you draw to help you distinguish them from other types of objects on the 
screen. You’ll see classes in action later.

1.	 To turn on Auto-classing, choose File > Document Settings > 
Standard Naming.

2.	 On the dialog, check the Enable Auto-classing box. Click OK to 
close the dialog box.

3.	 On the resulting dialog box, click Yes.
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Save These Settings For Future Projects
1.	 To save these settings for use on future projects, choose File > Save 

As Template.

2.	 Name the file “My Template.sta.” Allow Vectorworks to save the file 
where it wants to. Click OK.

Setting Vectorworks Preferences
The changes you have made to this document affect only this document, 
or any new documents that you create from the template. However, there 
are other preferences you can set within Vectorworks which affect how it 
works every time you use it. Before continuing to the rest of the tutorial, 
it’s very important that you make the following changes to your 
Vectorworks Preferences so that they match mine.

1.	 Choose Tools > Options > Vectorworks Preferences.

2.	 Click the 3D tab and make the following changes:

•	 3D conversion resolution: High
•	 Render mode when changing from a Top/Plan to a 3D View: OpenGL
•	 Projection when changing from a Top/Plan to a 3D View: Normal 
Perspective.

These changes will ensure that when you change your view in the files 
provided for the tutorials, you will always see a rendered perspective 
view. For your own projects, of course you can change these 
preferences and use whatever you prefer, but it is important for the 
success of the tutorial for these settings to match mine.

3.	 Click the Autosave tab.

•	 Confirm before save: Uncheck
This change will ensure that Vectorworks does create automatic backups 
of your work, but does not ask for permission each time. It will create the 
backup silently, every 15 minutes. Feel free to adjust the settings to 
create a backup more or less frequently in the future, according to your 
needs. And remember, it’s important to have a system wide backup 
strategy in place when depending on your computer for business.

4.	 Click OK to close the Vectorworks Preferences dialog. You’re now 
ready to proceed with the remaining tutorials.
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SECTION 2: PLOTTING THE EXISTING SITE

Objectives For Section Two
After completing the exercises in this section, you will be able to do the following:

•	 Import both a DWG and a PDF file to use as a base plan
•	 Use triangulation to locate positions on a site
•	 Create a floor and a property line for your model
•	 Use the Wall, Door, and Window tools and the Create Roof command to create a simple building
•	 Document existing trees on the site
•	 Set the position of the sun and create a shadow analysis

Example Files Required For This Section:
•	 1-Sample DWG Import.dwg
•	 2-Locating the Boundary.vwx

•	 3-Create Building.vwx
•	 4-Create Roof.vwx
•	 5-Add Existing Trees.vwx

Exercise 1: Importing Files From External Sources
Even if you measure your own surveys on site, there will also be times when you need to start the design process by importing files from external 
sources. These could be AutoCAD files from a professional surveyor, an architect, or a map provider. Alternatively, you might have a PDF of a site. This 
exercise will take you through the import process and show you how to incorporate a survey file in AutoCAD format.

Importing a DWG file
1.	 Create a new blank file, choosing File > New and check Use 

Document Template. Choose any of the standard Landmark 
templates that came with your software. Click OK.

2.	 Use the previous exercise as a reference to change the settings to 
suit your preferred way of working. My example file already has my 
preferred settings.

3.	 Choose File > Import > Import Single DXF/DWG File.

4.	 Within the sample files, locate the file 1-Sample DWG Import.dwg 
and click Open.

5.	 On the Import dialog, change the following settings:

•	 Unit Settings in File: Meters
•	 This Scale: 1:1
•	 Convert Objects to: 2D and 3D
•	 2D/3D Conversion Resolution: Medium

It is critical that the Unit Settings in File field be set to the Unit 
measurement of the incoming file. 
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6.	 Click the Graphic Attributes tab and change the settings as follows:

•	 Map colors to Line weights: Uncheck
•	 Add Prefix to Imported DXF Layers: Check
•	 Prefix: Enter the word “Survey.”

7.	 Click OK. If the Font mapping dialog appears, click OK to accept the 
default mapping of fonts not present on your machine.

Examine the File Structure
1.	 Turn your attention to the Navigation palette. Click on the Design 

Layers button.

2.	 Design Layers represent the piece of paper on which you are 
drawing. They are usually used to separate items in 3D space (think 
of the floors of a building) or to separate stages of the design 
process. This file contains the original Design Layer-1 and a new 
layer with the same name as the imported DWG file, which is the 
Active Layer.

3.	 Click on the Classes button on the Navigation palette. If you’re 
familiar with AutoCAD®, these classes are the equivalent of DWG 
layers. Classes are a classification system used to distinguish 
different types of objects from each other. There are many classes in 
the file, their names all prefixed with “Survey-” so that you can 
distinguish them from your own classes.

4.	 Press and hold the Alt key (Windows) or Option key (Macintosh) and 
click the “disclosure arrow” to the left of the Survey class. Press and 
hold the Alt key (Windows) or Option key (Macintosh) and click on the 
“disclosure arrow” to open the list of classes.

5.	 Three columns to the left of each class name represent Visible, 
Invisible, and Gray. Locate the class Survey-LEVEL_VALUE, and 
click on the Invisible column to its left. All elements on the drawing 
belonging to this class are now invisible. Restore their visibility by 
clicking on the Visible column.

Both Design Layers and Classes can have their visibility controlled using 
the Navigation palette. However, they have different purposes: Design 
Layers are the physical location of the drawn objects while Classes are 
like a club membership, used for classifying different types of objects. 
You can edit classes to add graphic attributes to them so that all 
members of that class look the same.

Change the Scale
After you import the file at 1:1, you may wish to change the scale. 1:1 is 
a good starting point, as that’s likely the scale at which the file was 
created. But you may wish to work at a different scale.

1.	 Click on the Scale button on the View bar.

2.	 Choose the scale you want to work in and check the All Layers box. 
Also check Scale Text and then click OK.

3.	 Click the Fit to Objects button on the View bar to adjust the plan to 
fit on your screen.

Do not be concerned if the imported site does not fit on the drawing area. 
You can change the scale of your layer at any time, but you will see later 
that you can present the drawing at any scale when your design is 
complete.

Understand the Origin
Notice the coordinates of the site on the ruler. Vectorworks has 
preserved the coordinates of the original file—in other words, the 
geometry is in the same place as the surveyor or architect originally drew 
it. This is important if you will be coordinating drawings at a later stage in 
the project.

Rotate the Plan
The plan has been drawn at an angle. To be able to draw orthogonally 
(square to the page), you can rotate the whole page temporarily, to line 
up with the rulers, as if you were drawing with a parallel motion.

1.	 Click the Rotate Plan button on the Tool bar.
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2.	 Click on the lower left corner of the house, and then click again 
anywhere along the lower edge of the house. The entire drawing will 
rotate to line up the house with the bottom of the drawing area.

3.	 Tools such as the Rectangle tool, Wall tool, and so forth, will now 
easily snap horizontally and vertically and line up with the house, if 
that is desirable for your design.

4.	 To return to a Top/Plan view, use the View menu on the View bar, 
shown in the screenshot after step 1.

5.	 Save your file if you wish, using File > Save. We will not be using it 
again as it is a stand-alone example designed to teach you this 
process alone.

An important part of the import process is to always check the size of the 
imported elements. The use of an incorrect import unit will result in a file 
that is the wrong size.

Note that PDF files or image files (scanned hand-drawings for example), 
can also be imported. Examine the File > Import menu to see the range 
of file types that can be imported.

Exercise 2: Drawing Up The Site
Now we’ll use example files to look at how to locate points on site and to draw simple buildings. The sample file you’ll use contains two simple polylines 
representing the footprint of a building. Later, you’ll turn these into a building. There are also some triangles that represent triangulation points to the 
boundary.  In this exercise, you’ll learn how to use the Triangle tool to locate the final boundary point. In some geographies, triangulation is used with 
the building as a starting point for finding other points on the site. In other geographies, you may start from the boundary and triangulate inward to find 
the buildings. Whatever is the case where you work, the principle of triangulation is the same, and the tools you use are the same.

Triangulate to Locate a Boundary Point
1.	 Open the file 2-Locating the Boundary.vwx.

2.	 On the Navigation palette, click the Design Layers button. There are 
two layers. The active layer is the Boundary layer. The two polylines 
are on the Buildings layer and the Layer Options menu is set to 
Show/Snap Others so that you can see the building shapes but not 
select them.

3.	 Still on the Navigation palette, click on the Classes button. I have 
set up some classes for you to use in this file. Using a system of 
classes is best practice, as it helps to organize the objects you draw 
so that you—and other professionals—can distinguish them from one 
another.

4.	 The active class is Survey-Triangulation. Right-click (Windows) or 
Ctrl+click (Macintosh), and choose Edit. Note that this class has 
been set up with a red dashed line to make these lines distinct from 
others. Click Cancel.

5.	 Look at the Polygon tool on the Basic palette. Click and hold on the 
small triangle in the bottom-right of the tool. A menu will open 
showing another tool hiding behind the Polygon. Click on Triangle. 
On the Tool bar, choose the first mode: Triangle by Three Sides 
Mode.

6.	 Click on Point A on the building and then click on Point B. This sets 
the first side of the triangle. Press Z to help zoom to the points.

7.	 On the dialog, enter the following values and then click OK.

•	 Side 1 (A to B): Do not change
•	 Side 2 (A to BP1): 14804 mm [48’ 6 ⅞”]
•	 Side 3 (B to BP1): 26096 mm [85’ 7 ⅜”]

8.	 Vectorworks offers two triangles either side of the edge A to B. Click 
on the lower triangle. Vectorworks creates a triangle with its apex 
marking the point we were seeking.
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Draw the Boundary
Now that each boundary point is drawn on the plan, you will use the 
Polyline tool to draw the boundary line. When drawing around a shape 
like this, you can use the Space bar to temporarily activate the Pan tool. 
This will enable you to move to drawing around to reach points not on 
the screen. You can also use the Snap Loupe (the Z key), to temporarily 
zoom the area under the cursor, and aid accurate drawing.

1.	 Use the Navigation palette to make Survey-Site Floor the active 
class.

2.	 Choose the Polyline tool in Corner Vertex mode. Click on the new 
point BP1, and then click on BP2. Click on BP3. Now use the U key 
on your keyboard, pressing it four times, to “shortcut” to the Polyline’s 
Point on Arc mode.

3.	 Click on Point BP4 and then on BP5. Press the K key on your 
keyboard to draw the final segment and close the polyline.

4.	 Select the Polyline if it is not already selected. Choose Edit > Copy 
and then Edit > Paste in Place. We will convert one of these objects 
to a floor and the other to a Property Line object.

5.	 Choose Landmark > Architectural > Floor. Click OK to create a 
Floor with a thickness of 0 and a height also of 0. The Floor is a 

“hybrid” object that can display a 2D appearance in Top/Plan view 
and a different appearance in a 3D rendered view.

6.	 Choose Modify > Send > Send to Back to send the Floor object to 
the bottom of the stack of objects.

7.	 Double-click on a blank part of the drawing area to return to the 
Selection tool and click to de-select the Floor object.

Creating the Boundary/Property Line
Property Line is a useful tool for displaying data about the site, 
including its area and the dimensions of the boundaries.

1.	 On the Navigation palette, make Survey-Property Line the active 
class.

2.	 Select the duplicate Polyline. Choose Landmark > Create Objects 
from Shapes. Complete the dialog as follows:

•	 Object Type: Property Line
•	 Show Properties Dialog: Check
•	 Delete Source Shapes: Check
•	 Click OK.

3.	 On the resulting dialog, change the following fields, leaving the others 
unchanged from their defaults:

•	 Name: 6 Woodspeen Drive
•	 Click OK.

4.	 The polyline is replaced with a Property Line in the same shape. 
Examine the Property Line. It shows valuable information about the 
area of the site and the boundary lengths.
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5.	 Click the Classes button on the View bar to open the Organization 
dialog again, this time on the Classes tab.

6.	 Examine the list of classes in this file.

7.	 Select the class called Survey-Property Line and click Edit.

8.	 The graphic attributes of this class are displayed. In this case, the 
Property Line has a Fill Style of None, allowing the Floor color to 
show through it.

9.	 Click OK to close the Edit Class dialog and OK again to close the 
Organization dialog.

10.	On the Navigation palette, click on the Classes button. To the left of 
the name Survey-Triangulation, click in the center column to make 
all members of this class invisible. The objects are still present in the 
file, and can be used for reference at any time, simply by restoring 
the visibility of the class.

11.	Choose File > Close. There is no need to save the file as I have 
provided the file for the following exercise.

Exercise 3: Draw a Building
In this section, you’ll learn two different ways to create a building. The first method uses the Massing Model tool. The Massing Model tool produces a 
simple building mass with a roof. It cannot have doors and windows or other detail, but it is ideal for showing neighboring buildings or garages where 
the simple mass of the building is important for sun studies, but detail is not. Then, I’ll show you how to put together a more detailed building that 
includes walls, doors, windows, and a roof. The Vectorworks Wall object is very powerful. It allows windows and doors to be inserted directly into it. It is 
a hybrid object, containing both a plan and a 3D representation. If you have Renderworks, you’ll see textures applied to these objects.

Draw the Garage
1.	 Open the file 3-Create Building.vwx.

2.	 Ensure that the Unified View button is pressed on the View bar. This 
will ensure that when changing to a 3D view, all design layers will 
move in unison.

3.	 On the Navigation palette, ensure that Buildings is the active layer 
and that Layer Options are set to Show/Snap Others. This means 
you can see objects on other layers but not select or modify them.

4.	 Click the Classes button and make Survey-Garage Walls the active 
class.

5.	 Click the Site Planning tool set, and then click Massing Model.

6.	 On the Tool bar, click Massing Model Tool Preferences.

7.	 Set the following preferences, leaving other settings on their defaults:

•	 Name: Garage
•	 Show in Plan: Roof
•	 Label: No Label
•	 Height: 3000 mm
•	 Floor Count: 1
•	 Wall Class: Survey-Garage Walls
•	 Roof Class: Roof-Main
•	 Pitched Roof: Check
•	 Eave Style: Vertical
•	 Display Shadow in Plan View: Check
•	 Click Shadow Settings to open the Document Preferences dialog
•	 Offset: 0.2 Factor of Object Height
•	 Angle: Use the slider to control the angle of plan shadows
•	 Color: Choose a color for the shadows
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•	 Opacity: 50%
•	 Click OK to return to the Massing Model Object Properties
•	 Use Site Modifiers: Uncheck
•	 Use Grade Limits: Uncheck
•	 Click OK

8.	 Click on the lower left corner of the rectangle labelled Garage. You 
can use the Z key on your keyboard to zoom to the point if necessary.

9.	 Move clockwise to the next corner of the garage rectangle and click 
again. Continue to click on each point of the rectangle up to the 
penultimate point. Press K to draw the final segment and close the 
shape. The shadow displayed by the Massing Model is useful. You’ll 
use these document shadows later on a planting plan.

The massing model is created. If you have Renderworks, the walls and 
roof will be textured differently, because we have applied different 
classes to them. I have previously edited these classes to apply my 
chosen textures. You’ll see this later, when the main building is finished.

Draw the House Walls
1.	 On the Navigation palette, make Survey-House Walls the active 

class.

2.	 Click on the Building Shell icon on the Tool sets palette to open the 
Building Shell tools. Click the Wall tool and then click on the Wall 
Tool Preferences button on the Tool bar.

 

3.	 Set the following preferences:

•	 Overall thickness: 300 mm [11 ¾”]
•	 Click the Insertion Options tab.
•	 Height: 5500 mm [9’ 10”]
•	 Click OK.

This has defined a wall with a thickness of 300 mm and a height of  
5500 mm.

4.	 Click on the lower left corner of the house polyline labeled “House” 
(point B). You can draw in a 2D or 3D view—whichever you prefer. 

You can use the Z key to ensure you are snapping on the correct 
points. Continue in a clockwise direction, and click on all the other 
corners up to the penultimate point. Press K to close the shape. You 
have drawn six walls.

Note: As you draw, notice that the blue Data bar is displayed for each 
wall segment. You can use this to control the length of each segment if 
you are drawing a building from a series of measurements taken on site.

5.	 Using View > Standard Views > Right Isometric, change to a 3D 
view. Note that the walls and massing model also have a 3D 
representation. The building is displayed in a perspective view and is 
rendered using OpenGL mode by default.

Insert Doors
The Door and Window tools, also found in the Building Shell tool set, 
have a Preferences button on the Tool bar that allows you to configure a 
wide variety of door and window styles. These can be inserted into walls 
at the correct position to properly represent access to the landscape and 
to represent the building in 3D.

1.	 On the Resource Browser, click on the Home button to the right of 
the palette to ensure you are looking at the resources of the current 
file.

2.	 Scroll through the Resource Browser window until you see the 
heading Symbols/Plug-in Objects.

3.	 Double-click the “Front Door” symbol to make it the active symbol. 
Notice this has activated the Symbol Insertion tool on the Basic 
palette and that the symbol name is displayed on the bottom of the 
Resource Browser palette.

4.	 Bring the cursor to the center of the front house wall, looking for the 
Midpoint cue. The wall will highlight in red to indicate that you are 
about to insert a symbol into it.
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5.	 Click once to set the position of the door in the wall. Click again on 
the outside of the wall to complete the insertion.

6.	 Click the Selection tool. Select the front door. On the Object Info 
palette, click Settings. The Door Settings dialog opens.

7.	 Click the General tab on the left, and examine the range of settings 
available for doors. In particular, notice that the Size Reference is set 
to Rough Opening, meaning the width of the doorway is being 
measured across the entire opening. This dialog is also displayed 
when clicking the Door Preferences button on the Tool bar. Click 
Cancel to close the dialog without making any changes.

8.	 Choose View > Standard Views > Top Plan to return to Top/Plan 
view bar, (or use the Standard View menu on the View bar.

9.	 Click Flip on the Object Info palette to change the opening direction 
of the door.

Insert Windows
1.	 On the Resource Browser, double-click the symbol named Ground 

Floor House Window. Move your mouse onto the wall. It will 

highlight red. Click anywhere on the front house wall, to the left of the 
front door, and again on the outside (left edge) of the wall.

2.	 The window is inserted into the wall.

3.	 Click on the Settings button on the Object Info palette and note the 
range of settings for windows. Click Cancel.

4.	 On the Object Info palette, click Set Position.

5.	 Click on the lower left corner of the house (B), and then click on the 
left edge of the window. The Enter Offset dialog opens. It shows the 
current distance between the two clicked points. Change the Offset 
value to 1015 mm [3’ 4”].

6.	 Click OK. The window moves to the desired position in the wall.

View Textures On The Rendered Model
Note: You can only apply textures and use Renderworks modes if you 
have Renderworks installed.

1.	 Change to Right Isometric view using the View menu on the View bar. 

The default render mode in any 3D view is OpenGL. If you have 
Renderworks, you’ll see the model with textures including a brick texture, 
with glass in the windows..

2.	 Click the Selection tool. Click on one of the walls.

3.	 On the Object Info palette, click on the Render tab. Change the 
following fields:

•	 Part: Left
•	 Texture: Class Texture

4.	 If you have Renderworks, choose  View > Rendering > Fast 
Renderworks. This will change the model from OpenGL to a 
Renderworks mode. You will see the Brick texture applied to the 
outside of the house, and the quality will be better than the OpenGL 
render. This is the texture I have previously added to the properties of 
the class Survey-House Walls.
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I will complete the remaining windows and doors in this model.

Create a Roof
1.	 Open the file 4-Create Roof.vwx. In this file, the remaining windows 

and doors have been inserted to save you time. The textures have 
been applied and a driveway has been added using the Hardscape 
tool. You’ll learn about the Hardscape tool later. The Roadway 
(Straight) tool was used to create the road.

2.	 Choose the Select Similar tool from the Basic palette. Click Select 
Similar Tool Preferences button on the Tool bar. Check Class and 
Object type and then click OK.

3.	 Click on one of the house walls. All the house walls are selected.

4.	 Choose Landmark > Architectural > Create Roof.

 

5.	 Complete the dialog as follows:

•	 Eave Profile: Vertical
•	 Thickness: 140 mm [5 ½"]
•	 Roof Pitch: 35º
•	 Bearing height: 5500 mm [9' 10"]
•	 Eave overhang: 300 mm [11 ¾"]
•	 Notice that Vectorworks will create the roof on the active design layer, 
and in a class called Roof-Main.
•	 Click OK.

The roof is created and is made of six separate roof faces.

6.	 With the Selection tool, select the roof. Click on the Object Info 
palette’s Render tab.

Notice that the Top part of the Roof is textured with Class Texture. The 
Roof texture is derived from the properties I have set up within the 
Roof-Main class. (Renderworks is required for these steps.

7.	 Click the Shape tab on the Object Info palette.

8.	 Choose File > Close. There is no need to save the file.
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Exercise 4: Existing Trees
Vectorworks Landmark includes a tool for documenting existing vegetation and for documenting the ultimate action for this vegetation. The tool, called 
Existing Tree, is located in the Site Planning tool set. In this exercise, you’ll edit some trees already placed on the plan and place a tree on the plan. 
The file you’ll work in contains extra elements, to give you a sense of completeness when working with the site. These objects were drawn with the 
Landscape Area tool and the Hardscape tool—both found in the Site Planning tool set. You’ll see more about these in future exercises, but feel free to 
select them and examine their settings on the Object Info palette to get a feel for their functionality.

Place an Existing Tree
1.	 Open the file 5-Add Existing Trees.vwx.

2.	 Using the Navigation palette, click the Design Layers button. 
There are many more layers in this file, to allow the easy separation 
of different phases of the design process.

3.	 Ensure Existing Trees is the active layer. Ensure Exist Tree-Retain 
is the active class.

4.	 Click the Site Planning tool set. Click the Existing Tree tool and 
then choose the Existing Tree Tool Preferences button on the Tool 
bar.

5.	 On the Object Properties dialog, define the tree as follows:

•	 Click Get Species Data and then choose Quercus robur from the 
list. Click OK.

•	 Click Tag and Number Options and ensure that Auto-numbering is 
on. This tree will be numbered sequentially with a prefix of E. Click OK.
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•	 Continue working on the Object Info palette completing the following 
fields:
•	 Origin: Native
•	 Height: 12500 mm [41']
•	 Canopy Max. Diam.: 6500 mm [21’ 4"]
•	 First Branch Hgt: 1700 mm [5’ 7"]
•	 DBH: 800 mm [2’ 8”]
•	 Leave all other fields unchanged, but do not yet click OK.

6.	 Click 2D Properties.

•	 Check Use 2D Component Symbols.

•	 Note the different options for displaying trees with different tree 
actions.
•	 Click OK.

7.	 Click 3D Properties.

•	 Check Create 3D Geometry
•	 Under Optional Class Names, choose Exist Tree-3D Canopy and 
Exist Tree-3D Trunk.
•	 Apply Textures to Classes: Check
•	 Click OK.
•	 Click OK again.

8.	 Click once on the drawing and again to place the tree as indicated in 
the plan.

9.	 Press X to return to the Selection tool. The new tree is still selected.

10.	On the Object Info palette, scroll to the bottom and change the 
Action field to Retain.

11.	Notice the tree’s graphic has changed. Change the Action field to 
Remove. The graphic changes again.

12.	Select some of the other trees and examine their properties on the 
Object Info palette. Scroll to the bottom of the list of properties and 
click Additional Fields. Note that you can add fields to record any 
information necessary for your design process and legal 
requirements.

13.	Choose Tools > Reports > Choose Schedule. On the dialog:

•	 Select Existing Tree Schedule w/Images
•	 Check Place worksheet on drawing.
•	 Click OK.
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14.	The cursor changes to a target. Click on the drawing area below the 
road. A report is displayed on the drawing that lists all the trees on the 
site. You can use this report on the drawing or export it to use in other 
project documentation.

15.	Choose File > Close. There is no need to save the file.

Exercise 5: Set the Sun Position
Vectorworks Landmark includes the Light tool that has many modes for providing different lighting effects to your model. For landscape design, the 
most important light source is the sun. The Heliodon tool, provides sunlight based on the location of the site, the date, and the time of day. It can also 
be used to create a solar animation movie.

Add a Heliodon
1.	 Open the file 6-Create Sunlight.vwx.

2.	 On the Visualization tool set, click Heliodon. Click Heliodon Tool 
Preferences on the Tool bar.

3.	 On the dialog, choose the following:

•	 The time format you prefer.
•	 A symbol for your plan that will represent the sun and mark the 
direction of North.
•	 The location of your site by choosing the region and the city. You can 
add other cities using the Edit Cities checkbox.
•	 Click OK.

4.	 Click on the drawing once to position the Heliodon marker. Rotate the 
symbol so that its top points toward   North. Click again to set the 
rotation.

5.	 Press X to return to the Selection tool.

6.	 On the Object Info palette, make the following adjustments:

•	 Daylight Savings: Check (if appropriate)
•	 Change the Time, Day, and Month settings to today’s date.

7.	 Change the view to Right Isometric. Click Fit to Page on the View 
bar to display the entire site on the screen. The scene is 

automatically rendered in OpenGL, in a perspective view, but there 
are no shadows.

8.	 Click the Rendering menu and choose OpenGL Options.

9.	 Change the following:

•	 Detail: Very High
•	 Use Shadows: Check
•	 Quality: High
•	 Click OK.

(Note: You will only be able to use shadows in OpenGL if you have 
Renderworks.)

10.	Select the Heliodon if it is not already selected. 

11.	Click the Flyover tool on either the Basic palette, or the Visualization 
tool set. Click the first mode on the tool bar, and click once on the 
corner of the house to set the center of rotation.

12.	Click and hold with the left mouse button to change the view to a 
pleasing view.

13.	On the Object Info palette, click Solar Animation. On the Solar 
Animation dialog, use the lower slider to change the time of day and 
assess the shadows falling across the site.

14.	Click Cancel.

15.	Choose File > Close. There is no need to save the file.
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SECTION 3: HARD LANDSCAPING

Objectives For This Section
After following the exercise steps in this section, you will be able to:

•	 Use the Hardscape tool to draw hard landscaping/hardscape
•	 Produce a worksheet showing hard landscaping quantities
•	 Create and use symbols within the design
•	 Use the Custom Stair tool to create steps
•	 Create free-standing garden walls
•	 Model a simple 3D structure and add dimensions to it

Example files required for this section:
•	 1-Start Hard Landscaping.vwx

In this section, you’ll use a partly configured file to model some hard landscaping features. The aim of this section is to familiarize you with the 
Hardscape tool and the 3D Modeling tool set so that you can use the Push/Pull facilities within Vectorworks to model something unique such as this 
structure to host a “green roof.” (You’ll learn about planting later.)
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Exercise 1: Explore the Hard Landscaping File
The file has many more layers and classes now. As stated earlier, the more you can structure your design workflow, the more flexible your file will be for 
presenting different aspects of the design.

Examine the Structure of the File
1.	 Using File > Open, open the file 1-Start Hard Landscaping.vwx.

2.	 On the View bar, click the Layers button. Notice the design layers 
Site Survey and Garden Floor have a Z elevation of 0. The layers 
named Hard Landscaping, Planting, and Green Roof Structure 
are at different Z elevations, -650 mm [-2’ 1⅝”]. Design Layers are 
like horizontal planes, that can have their elevation set to different 
heights. Objects drawn on a specific design layer will adopt the 
elevation of the layer on which they are drawn.

3.	 On the Navigation palette, click on the Design Layers tab. The 
active layer is Hard Landscaping. This layer contains some 2D 
shapes that you will use to create a design as well as some 
previously completed objects. It also contains some instructions that 
you will be able to hide when you have completed the steps. 
Additionally, there is a ready-made water feature—which we will 
discuss later.

4.	 The Layer Options menu is set to Active Only so that you can see 
clearly what is on each layer.

5.	 Click on the Site Survey layer to make it active. There is a building 
with a roof and a very simple boundary, created with walls. A 
Heliodon object has been placed, siting this garden in London, UK.

6.	 Click on the Garden Floor layer to make it active. There are two 
Floor objects to act as a base for different levels in our model. Click 
on each in turn and notice the different Z values on the Object Info 
palette.

7.	 Click on the Green Roof Structure layer to make it active. There is 
nothing on this layer yet. You will be modeling something here soon.

8.	 The Planting and Green Roof Planting layers contain partially 
completed planting plans. You’ll work with them fully in Section 4 of 
this guide.

9.	 Make Hard Landscaping the active layer, on the Navigation palette.

There is a terrace already completed in the file so you can examine its settings, before creating your own.
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Examine the Terrace
1.	 The terrace is already completed, so that you can look at the settings 

before creating your own.

2.	 Click the Selection tool, and select the existing terrace. Remember 
at the start of this exercise, we saw that the design layers are at 
different elevations. On the Object Info palette, notice this is a 
Hardscape object, drawn on the layer Hard Landscaping, which is 
positioned at -650 mm [-2’1⅝”]. However, the Z field shows the object 
positioned at 615 mm [2']. This object is therefore positioned 615 mm 
[2’] higher than the layer on which it is drawn. It has a thickness of  
35 mm, so its top surface is at 650 mm. Click OK.

3.	 Click on the Hardscape Settings button on the Object Info palette. 
The Hardscape Object Settings dialog opens. This Hardscape Object 
has been created for you in advance, and certain elements have 
been configured, such as the joint pattern, the thickness in 3D, and 
the Renderworks Texture that will be applied in a rendered view. 
You’ll learn more about these settings in a moment. Click OK to 
dismiss the dialog.

4.	 On the Object Info palette, click the Save Hardscape button. Click 
OK when prompted to name the Hardscape, and use the default 
name that Vectorworks Landmark offers.

5.	 On the Resource Browser, click the Home button to ensure you are 
looking at the contents of the current file. Under the word Resources, 
choose Hardscapes from the folder menu. The Hardscape definition 
has been saved, and you will re-use it later.

6.	 Keep the file open to use in the following exercise.
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Exercise 2: Create Hard Landscaping Areas
Now, you will learn how to create a Hardscape Definition and draw with the Hardscape tool. The Hardscape tool is a very powerful tool for creating 2D 
and 3D representations of Hard Landscaping. You can draw with it, or create Hardscape from existing shapes. It can also keep track of the materials 
used in your design. In this exercise, you’ll use the Hardscape tool to create a lawn. But maybe you are thinking that a lawn is surely a softscape. Well, 
I use Hardscape for lawn, because it’s an easy way to create a 2D/3D lawn, and to quantify the area.

Create Lawns
1.	 Using the Navigation palette, make Site-Hardscape-Main the active 

class.

2.	 On the Site Planning tool set, click the Hardscape tool. Look at the 
Tool bar. There are two modes for drawing Boundary Mode and 
Pathway Mode, for drawing areas and paths, respectively. There are 
also exactly the same modes as you have used with the Polyline tool. 

3.	 Choose Boundary mode, and then Corner Vertex mode, and then 
click on the Hardscape Tool Preferences button.

4.	 Complete the Hardscape Object Settings dialog as follows, leaving all 
other settings unchanged:

•	 Hardscape Name: Lawn
•	 Joint Pattern: None
•	 Main Area Class: Site-Hardscape Comp-Lawn
•	 Draw Border: Check
•	 Width: 15 mm [⅝"]
•	 Joint Pattern: None
•	 Background Color: Choose a pale Gray.
•	 Border Class: Site-Hardscape Comp-Border Joint
•	 3D Type: Slab
•	 Thickness: 35 mm [1⅜”]
•	 Main Texture: Landscape Grass Fairly Green
•	 Border Texture: Metal Chrome Brushed
•	 Click OK to close the dialog.

5.	 As indicated above on the screenshot, click on the top left point on 
the shape. Move the cursor to the right, and click. Move the cursor 
down to the next point and click. Remember you can use the Snap 
Loupe (Z key), to zoom to each point without changing your overall 
view.

6.	 On the Tool bar, change the drawing mode to Point on Arc mode. 
Click anywhere on the arc and again at the end of the arc.

7.	 Change the drawing mode to Corner Vertex mode and click on the 
next point.

8.	 Press K on your Keyboard to close the shape and complete the 
Hardscape object.

9.	 Choose the Mirror tool from the Basic palette. Click once on the 
center point on the two rectangles crossing the site. Move the cursor 
upward, snapping to the vertical cue, and click again. The Hardscape 
object will be mirrored.

10.	Using the Selection tool together with the Shift key, click on the 
original hardscape object so that both are selected.

11.	Use the Mirror tool again, this time drawing a horizontal reflection 
line through the center of the horizontal rectangle.
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Create the Paved Areas
1.	 Click the Selection tool and click on the drawing area to deselect the 

hardscapes. Press the Shift key. Select the two rectangles that cross 
the site horizontally and vertically.

2.	 Choose Modify > Add Surface to add these two shapes together 
and form a single Polygon.

3.	 Choose the Landmark > Create Objects from Shapes command. 
Complete the Create Objects from Shapes dialog as follows:

•	 Object Type: Hardscape
•	 Delete Source Shapes: Check
•	 Click OK to close the dialog and create the Hardscape.

4.	 The resulting Hardscape will have the same settings as the Lawn, but 
we will change that now. Look at the Object Info palette and confirm 
that the object has become a Hardscape.

5.	 On the Resource Browser, locate the Hardscape Limestone-1 
resource that you created earlier. Drag the hardscape resource onto 
the new hardscape to transfer the settings.

6.	 Click the Selection tool and select the Hardscape. Choose Modify > 
Send > Send to Back to place the Hardscape below the water 
feature.

7.	 Keep the file open to continue working with it in the following section.

Exercise 3: A Hardscape Report
As well as producing beautiful plans and 3D models, Vectorworks can count things, so you don’t have to. In this exercise, you’ll learn how to use one of 
the prebuilt worksheets to list the quantity of hardscape materials used in these areas. You will learn how to change the formatting of this worksheet to 
suit your own unit of measure and currency.

1.	 Make Notes-Reports the active class, on the Navigation palette.

2.	 On the Resource Browser, use the Files menu to list the contents of 
the Design-Build Sample.vwx file.

3.	 Scroll down to the Worksheets heading and locate the Worksheet 
called Hardscapes Budget.
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4.	 Drag this worksheet onto your drawing. Notice that it lists by name 
each area created with the Hardscape tool, with its perimeter, area 
(in the current document area unit setting), price (per sq ft), and the 
total cost.

5.	 Double-click the worksheet on the drawing to open it in its own 
window. If you’re a spreadsheet user, many of the functions in 
worksheets are similar, but without as many fancy buttons as a 
modern spreadsheet.

6.	 Choose View > Database Headers. A new row opens that contains 
all the clever calculations needed to read your design and list your 
hardscapes.

7.	 Click in cell B3, just below the word “Perimeter.” Choose View > 
Format Cells.

8.	 If appropriate to your geography, change the Trailer field to “li m” (to 
represent linear meters), and then click OK.

9.	 The new trailer will display on the worksheet.

10.	Click on cell D3, directly below Price/sq ft.

11.	Choose Format > Cells again and change the Leader and Trailer 
fields to appropriate currency symbol and area unit for your 
geography, and then click OK.

12.	Repeat the process for the Price column and cell E4 at the bottom of 
the Price column.

13.	Row 2 contains simple text as headings. Click on each cell that needs 
changing, and then edit the text in the edit box at the top of the 
worksheet window, and then press Enter.

14.	Click on cell D3.1. Enter a price per area measurement—for example 
50. Notice the Total cost for this row increase, and the Total at the 
bottom increase.

This worksheet has been set up to calculate the total price for each area 
based on the cost per square area. The values are correct wherever you 
are working, because of the unit settings in your file.

15.	Choose View > Database Headers again to hide the row with all the 
clever bits (worksheet functions).

16.	Close the worksheet window by clicking on the red button at the top 
left of the window (Macintosh) or clicking the x at the top right of the 
window (Windows). The updated worksheet displays on the drawing. 
For now, select and delete the worksheet. It is now a resource of this 
file, and we will use it later.
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Exercise 4: Create Steps
The Stair tool is new to Vectorworks Landmark. Previously, it was only available to Vectorworks Architect or Vectorwworks Designer users. It is a 
powerful and flexible tool, with many built-in configurations, all of which can all be customized to suit different scenarios. In this exercise, you’ll learn 
how to create a simple, straight flight of stairs.

Create a Straight Run of Steps
1.	 From the Building Shell tool set, choose the Stair tool. On the Tool 

bar, click on Insert Mode and then Stair Tool Preferences.

2.	 Click the General tab. On the right of the dialog, notice that the class 
for this stair is Vert Trans-Main. This class is automatically assigned 
because we have Auto-classing switched on in this file.

3.	 Click Select Stair Configuration.

4.	 The Select a Stair Configuration dialog box opens. Change following:

•	 Click Straight, Single Flight/Run
•	 Under Transfer settings from current stair: Uncheck everything
•	 Click OK

This will ensure that this will be a fresh stair, that we will define from 
scratch.

5.	 On the General tab, set the following:

•	 Use Maximum/Minimum Values: Uncheck
•	 Height: 650 mm [2’ 1⅝”] and click the Lock icon
•	 Tread Depth (G): 500 mm [1’ 7⅝”] and click the Lock icon
•	 Riser Height (R): 130 mm [5⅞”] and click the Lock icon
•	 Stair Width: 2000 mm [6’ 6¾”]

These values set the basic geometry for the stair. In this example, we 
are setting the desired geometry very precisely. Note, however, that you 
can use the Use Minimum/Maximum Values dialog to apply constraints 
to the stair, such as building regulations for your geography, to enable 
Vectorworks to calculate the appropriate size of different parts of the stair 
as required.

6.	 Click the Geometry tab. Most of the desired geometry for our stair is 
already set. However, we will enable the top tread to be drawn and 
set its size. Note that you may not always want a top tread, as the top 
tread will be the surface onto which the stairs lead.

•	 Draw Top Tread: Check
•	 Set the size of the top tread to 500 mm [1’ 7⅝”]

7.	 Click the Construction tab. Make the following choices:

•	 Construction Configuration: Solid Stair
•	 Solid Structure Thickness: 250 mm
•	 Tread Thickness: 35 mm [1¼”]
•	 Riser Thickness: 100 mm
•	 Nosing/Riser Offset: 30 mm [1⅛”]

8.	 Click the Railings tab. Here you can configure a variety of railing and 
panel styles. For this stair however, we wiill not need raillings as the 
stair will be enclosed by walls.

•	 Check Both Sides to ensure your choices apply to both sides of the 
stair.



33 | Vectorworks Site Design Guide

•	 Click Handrail on the left and the uncheck Show Handrail.
•	 Click Guardrail and uncheck Show Guardrail.

9.	 Click the Graphic Atrributes tab. Here you can set the display 
preferences for both the 2D and 3D parts of the stair. In this case, I 
have pre-defined classes that contain the 2D fill (the same as the 
Hardscape), and the Renderworks Textures that represent the 3D 
parts0. Double-click each of the following parts and then set the 
appropriate class:

•	 2D Treads: Class: <Stair Class>, Fill: Class Style. Click OK.

•	 Treads: Class: Vert Trans-Treads: Fill: Class Style, Texture: Class 
Style. Click OK
•	 Risers: Class: Vert Trans-Risers: Fill: Class Style, Texture: Class 
Style. Click OK.

10.	You have now set the preferences for the Stair. The General tab will 
display a preview of the stair, if you wish to look at it. Click OK to 
close the Stair Preferences dialog.

11.	The cursor has a set of steps attached to it, with the insertion point at 
the center of the bottom of the steps.

12.	Click on the drawing to the right of the paving, and click again to 
rotate the steps in a horizontal orientation so that they lead to the 
terrace.

13.	Press X to shortcut to the Selection tool. Choose Modify > Send > 
Send to Back to place the stairs below the wall coping on the plan.

14.	On the View bar, click the Classes button. Highlight the Vert-Trans-
Main class and click Edit.

15.	Review the settings for this class. This class determines the 2D view 
for the stair. Click Cancel.

16.	Highlight the class Vert Trans-Treads and click Edit. Review the 
settings for this class. This is the class that determines the 
Renderworks texture that will be applied to the 3D treads. Click 
Cancel.

17.	On the View menu on the View bar, select Left Isometric. The 
objects you have drawn on this layer all have 3D counterparts and 
you can now view them in an OpenGL rendered mode.
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Exercise 5: Draw and Edit Stepped Walls
In this exercise, you’ll draw the remaining wall to retain the other half of the terrace and the steps. You will also learn how to step the walls so that they 
follow the incline of the steps. Then, you’ll model some coping.

Use the Wall Tool to Draw Walls
1.	 Return to Top/Plan view using either the View menu on the View bar 

or Ctrl+5 (Windows) or Cmd+5 (Macintosh).

2.	 Use the Navigation palette to set the active class to Walls-Brick.

3.	 From the Building Shell tool set, choose Wall. On the Tool bar, click 
Wall Tool Preferences and change the settings as follows:

•	 On the Definition tab, click Standard Wall and set Overall Thickness: 
330 mm [1' 1"]
•	 On the Insertion Options tab, set Height: 1150 mm  [3' 9¼"]
•	 On the Textures tab, click Use Object Textures and then use the 
Part dropdown list to select in turn Overall, Right and Left, then click 
Choose Texture and select Bricks.
•	 Click OK.

4.	 Starting at the lower left corner of the steps, click once to start 
drawing the wall. Click again on the lower right corner of the steps. 
Move the cursor down, and double-click on the end of the terrace to 
complete the walls.

5.	 Check the 3D view again and note that the wall sits on the active 
layer (with a Z value of -650 mm [2’ 1⅝”]) and extends 500 mm [1' 7"] 
above the level of the terrace and the design layer.

Create a Stepped Wall
To match the wall on the other side of the steps, you’ll now learn how to 
create a stepped wall.

1.	 Click the Selection tool and click on the drawing area to deselect the 
walls.

2.	 Select the Wall that sits to the right of the steps.

3.	 On the Object Info palette, change Height to 630 mm [2' 0 ¾"]. This 
will become the starting height for the wall.

4.	 Choose Landmark > Architectural > Create Stepped Wall.

5.	 Change the following settings:

•	 Step Style: Even Steps
•	 Total Rise: Check to have Vectorworks calculate this.
•	 Step Length: 500 mm [1' 7⅝"]
•	 Step Rise: 130 mm [5 ⅛"]
•	 Apply Steps to Top of Wall: Check
•	 Apply Steps to Bottom of Wall: Uncheck
•	 Click OK.
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Model Coping For the Wall
I have created coping on the stepped wall on the left side of the steps. 
You’ll now use a profile shape that I’ve prepared for you and a polyline 
I’ve also prepared, to create coping for the long section of wall. Then, 
you’ll mirror the coping to the other side of the steps.

1.	 Make Walls-Stucco the active class.

2.	 On the Resource Browser, click the Home button to ensure you are 
looking at the resources in the current file.

3.	 Locate the “Wall Coping Profile” symbol.

4.	 Double-click the symbol to make it active. Click twice on a blank 
space on the drawing area to insert a copy of the symbol. You’ll learn 
more about symbols in the next exercise.

5.	 Click the Selection tool. Select the polyline along the top of the wall. 
Press Shift and also select the coping profile.

6.	 Choose Model > Extrude Along Path.

7.	 Press Next and then Previous to ensure that the polyline along the 
top of the wall is highlighted in red. This ensures the polyline will be 
the “path” object. Click OK.

The profile is extruded along the length of the wall to create a coping 
stone. Notice that the coping has sunk into the surface of the wall.

8.	 Double-click the coping. On the Edit Extrude Along Path dialog, click 
Profile and click OK. The Profile editor is displayed.

9.	 Click Fit to Objects if necessary to bring the profile into the center of 
the screen.

Notice that the center of the profile is on 0, 0. This is the part of the 
profile that is currently aligned with the original path polyline, or, in other 
words, the top of the wall.

10.	Click on the bottom center of the profile shape and drag it up to snap 
onto the origin, (0,0).

11.	Click the orange Exit Profile button at the top right of the screen. 
The coping is now positioned correctly on the wall.

12.	Click Select Similar. Click on one of the Extrude Along path objects 
to select them all.

13.	Click the Mirror tool. Draw a horizontal mirror line through the center 
of the steps to mirror the coping to the opposite walls.

14.	Return to Top/Plan view.

Exercise 6: Model Stepping Stones
In this exercise, you’ll model a simple paving stone to use as stepping stones around the garden. You’ll learn how to use the Duplicate Along Path 
command to accurately place and space objects along a curve. The symbol will be both 2D and 3D.

Create a Hybrid Symbol
1.	 Double-click the Rectangle tool on the Basic palette.

2.	 When the Create Object dialog opens, set the following fields, leaving 
all other fields unchanged:

•	 Class: Site-Hardscape Comp-Limestone (to pick up the graphic 
attributes from this class).
•	 Layer: Hard Landscaping
•	 Width: 500 mm [1’ 7⅝”]
•	 Height: 850 mm [2’ 9½”]
•	 Position at Next Click: Check
•	 Click OK.

3.	 Click on the drawing away from the garden area—this is a temporary 
rectangle. The rectangle will be placed on the drawing area where 
you click.



36 | Vectorworks Site Design Guide

4.	 Choose Edit > Copy and then choose Edit > Paste in Place. You 
now have two rectangles, one sitting on top of the other, with the 
most recently drawn rectangle selected.

5.	 On the Navigation palette, click the Classes button and make 
Site-Hardscape Comp-Limestone the active class.

6.	 Choose Model > Extrude. In the Create Extrusion dialog, enter an 
extrusion value of 35 mm [1⅜”], leaving the other fields unchanged. 
Click OK.

7.	 With the extruded rectangle still selected, click on the Object Info 
palette’s Render tab. Notice that the Texture is set to Class Texture, 
which means that the class texture is being picked up from the 
Site-Hardscape Comp-Limestone class. Click the Shape tab.

8.	 Using the Selection tool, click and drag around both the rectangle 
and extrude to ensure they are both selected.

9.	 Choose Modify > Create Symbol. On the Create Symbol dialog, 
complete the fields as follows, leaving all other fields unchanged:

•	 Name: Stepping Stone
•	 Insertion Point: Plan Projection Center
•	 Units: World-based
•	 Leave Instance in Place: Check

•	 Change 2D Objects from Layer Plane to Screen Plane: Check
•	 Assign to Class: Site-Hardscape Comp-Limestone
•	 Click OK

10.	When prompted, choose to place the new symbol in the Hardscapes 
folder on the Resource Browser and click OK again.

This has created a new symbol, with one instance of the symbol still on 
the drawing area, with a definition sitting in the Resource Browser. Each 
time this symbol is used, it will belong to the Site-Hardscape Comp-
Limestone class, and you will not have to remember to classify it.

Next, you will duplicate this symbol. When design elements need to be 
repeated, symbols are an efficient way to keep the file size down. On the 
Object Info palette, the object type has changed from Rectangle and 
Extrude to 2D/3D Symbol.

11.	Make None the active class.

12.	On the Resource Browser, click the Home button on the right of the 
palette to ensure you are looking at the resources of the current file. 
Open the Hardscapes folder and verify that the symbol has been 
created.

13.	From the Basic palette, choose Arc, and then choose Arc by Radius 
mode on the Tool bar.

14.	Click on the point indicated on the screenshot and by the text in the 
file. This is the center of the arc.

15.	Move the cursor to the left, and snap to the top center of the left “arm” 
of the paving, and then click.

16.	Move the cursor upward and to the right to draw an arc that meets 
the vertical path and then click.
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17.	Use the Selection tool + Shift key to select both the symbol and arc.

18.	Choose Edit > Duplicate Along Path.

19.	On the Duplicate Along Path dialog, enter the following information, 
leaving all other fields unchanged:

•	 Number of Duplicates: 7
•	 Center object on path: Check
•	 Tangent to path: Check
•	 Click Preview to see the effec t.
•	 Click OK to complete the operation and close the dialog.

 

20.	Use the Selection tool to select the arc and then delete it using the 
Delete or Backspace key on your keyboard.

21.	Notice that the first and last symbol instances have been centered on 
the start and end of the arc. Use the Selection tool to click on one of 
the end symbols.

22.	From the Basic palette, click the Move by Points tool and then 
choose the first mode, Move mode. Ensure that Object Retention 

mode is not clicked and that only one copy will be made. Move by 
Points can be used to copy objects, but on this occasion you will just 
move objects.

23.	Move the mouse along the top edge of the symbol, looking for the 
Center Left cue, and click (remember, the symbol has been rotated 
when copied, but remembers its original orientation). Move the cursor 
vertically, to the edge of the lawn hardscape, and click again. The 
symbol now fits neatly into the planting border.

24.	Move the cursor to the symbol instance at the other end of the arc. 
Press Ctrl (Windows) or Cmd (Macintosh) to select it (with the Move 
by Points tool still selected). Repeat the move process to move the 
paver horizontally.

25.	From the Basic palette, choose the Select Similar tool (often 
referred to as the “magic wand”). On the Tool bar, click on the Select 
Similar Tool Preferences button (the wrench and pencil icon). 
Check Symbol Name and then click OK.

26.	Click on one of the symbol instances. They will all be selected.

27.	From the Basic palette, choose the Mirror tool. Draw a vertical 
reflection line as you did earlier to mirror the lawn, using the top 
Midpoint cue of the central vertical path to find the center of the 
design. Notice the preview of the mirror operation that is displayed 
before the second click.

28.	Click Select Similar again, with the same settings, and select all of 
the symbols.

29.	Use the Mirror tool again to reflect these through a horizontal 
reflection line, using the Midpoint cue on the horizontal path to find 
the center of the design.

30.	The symbols have been placed on the Hard Landscaping layer, as 
have the lawn hardscapes. Both elements have a thickness of 35 mm 
[1⅜”]. In a 3D view, their surfaces will be level, which makes it hard 
for Vectorworks to determine what to show. Using the View menu on 
the Tool bar, choose Left Isometric. Use the Select Similar tool to 
select all of the paving symbols.

31.	On the Object Info palette change Z to 10 mm [⅜”] to set the pavers 
slightly above the lawn.
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32.	Choose File > Save but keep the file open so you can continue 
working.
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Exercise 7: Add Furniture
To add some interest to the scene, you’ll now add some benches and loungers from the symbol libraries. I have already imported the relevant symbols 
into the file for you to use. The Concrete Straight Bench is from the Objects-Landscape and Site.vwx file that is a favorite file on your Resource 
Browser. The lounger symbol (SiteFurn-Landscape Forms CL350-00) is from a larger library of Landscape Forms furniture, which is available to 
download from the Vectorworks Service Select portal, for Vectorworks Service Select subscribers only. Remember, you learned how to add Resource 
files to your Resource Browser in the Installation and Setup section: Accessing Landmark Resources.

Place Some Library Symbols
1.	 On the Navigation palette, change Layer Options to Show/Snap 

Others.

2.	 On the Render mode menu on the View bar, choose OpenGL 
Options. Change the following settings:

•	 Detail to High.
•	 Use Shadows: Uncheck.
•	 Click OK. 

3.	 Use the mouse or trackpad to zoom and pan the model so that you 
can clearly see the lower area of the space.

4.	 Make Fixtures-Main the active class.

5.	 On the Resource Browser, double-click the Concrete Straight 
Bench symbol to make it the active symbol.

6.	 Move the cursor to the top of the vertical path, and use the 
SmartCursor to obtain a snap on the center of the path. Notice the 
surface of the paving highlights in blue. Vectorworks is using 
Automatic Plane mode to detect the 3D surface of the paving.

7.	 Click once to place the center of the bench. Click again without 
moving the cursor to complete the insertion.

8.	 Move the cursor to the lower part of the vertical path. Note that the 
OpenGL render will prevent you from snapping to surfaces that are 
behind others. Most of the time, this is a very useful feature, but in 
this case, we need to be able to see through the fence to be able to 
snap to the paving. Press and hold the B key on your keyboard. This 
invokes X-Ray mode to make modelling easier. Place a second 
bench at the bottom of the vertical path.

9.	 On the Object Info palette, notice that the Z value is already set to  
35 mm, as Automatic Working Plane mode detected the surface of 
the paving.

10.	On the Resource Browser, locate the symbol SiteFurn-Landscape 
Forms CL350-00, and then double-click it to make it active.

11.	Bring the cursor onto the upper right lawn and click to place the first 
lounger. Move the cursor to rotate the symbol into a position you are 
happy with, and then click again to complete the symbol instance 
insertion.

12.	Repeat to place another lounger on this lawn. Again, these symbols 
will be sitting on the surface of the lawn.

Examine the Water Feature
1.	 Press B again to invoke X Ray mode on the lower left of the garden 

to see through the fence.

2.	 On the left end of the horizontal path is a water feature that has been 
created for you. Select each of the elements in turn with the 
Selection tool and examine its properties on the Object Info palette.

http://serviceselect.vectorworks.net
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3.	 The walls have been drawn with the Wall tool. The coping has also 
been drawn with the Wall tool—but with a greater offset from the layer 
at the bottom—and a different height and thickness. The body of 
water has been created by drawing a rectangle and then extruding it. 
The sphere was created with the Sphere tool in the 3D Modeling 
tool set. You’ll learn more about 3D modeling in the following 
exercise.

4.	 Save the file.

Exercise 8: Draw Pillars, Posts and a Roof Structure
In this exercise, you’ll gain some experience of using the direct modeling facilities within Vectorworks to create a simple structure that is somewhere 
between a pergola and a building. The top section of the structure will form a tray that will later host a green roof, and could perhaps also filter rainwater 
for irrigation.

Extrude the First Pillar and Post
1.	 If your model is not already in a 3D view, change to Left Isometric 

view.

2.	 Make Walls-Brick the active class.

3.	 Locate the small rectangle in the top left quadrant of the garden (the 
one labeled to become a pillar for the green roof).

4.	 Choose the Rectangle tool from the Basic palette, and on the Tool 
bar choose the first mode. Note the Push/Pull mode which displays 
when you use 2D tools in a 3D view. This mode should be on by 
default, but if it is not, turn it on.

5.	 Trace over the existing rectangle by clicking on one corner and then 
on the diagonally opposite corner.

6.	 Immediately, move the cursor onto the face of the rectangle—it will 
highlight in red. Click on the face, and move the cursor up to Push/
Pull the rectangle into an Extrude. Press Tab, and in the Data bar, 
enter 525 mm [1' 8 ⅝"], press Enter on your keyboard, and then click 
to complete the extrude.

7.	 Make Wood the active class, using either the View menu, the Classes 
button on the View menu, or the Navigation palette. On the Tool bar, 
change the mode to Center to Corner mode. Move the cursor onto 
the top of the pillar and watch for the surface plane to be acquired. 
Draw another rectangle in the center with Center to Corner mode, 
slightly smaller than the original. After the second click, on the Object 
Info palette, refine the size: Set Width to 150 mm and Height to 150 
mm.

8.	 Click on the surface and tab into the Data bar. Type 2475 and press 
Enter, then click to complete the extrude.

9.	 Click the Selection tool and hold down the Shift key. Select both the 
brick base and the post.
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Mirror the Pillar and Post
1.	 Choose the Mirror tool, and mirror the pillar through the center of the 

path.

2.	 Using the Selection tool, select both pillars and posts, and then use 
the Mirror tool again to mirror through the center of the path on the 
opposite axis.

3.	 You will now have four pillars around the center of the paving. The 
textures set up in the Walls-Brick and Wood classes have been 
applied because the extrudes have been created in this class.

Extrude the Roof
1.	 Click Rectangle on the Basic palette. On the Tool bar, click  Corner 

to Corner mode.

2.	 Hover the cursor over the top surface of the left-most pillar in the 3D 
view. Notice the automatic plane detection spring into action again, 
coloring the top surface blue. Click on the outer-most corner of the 
rectangle and then draw a rectangle across all four posts to form the 
base of the roof structure.

3.	 Click on the surface of the new rectangle and pull the rectangle up. 
Press Tab and type 300 mm [1’] into the blue Data bar type, press 
Enter on your keyboard and then click the mouse to complete the 
extrude.

Shape the Planting Structure
1.	 Click the 3D Modeling tool set. Click the Deform tool. Click Taper 

Solid mode and then select Symmetric mode. Click on the roof 
structure and then click on the center of the top surface. Click on one 
of the edges and start to move the top surface outward. Move the 
cursor down to the edge of the brick column base to snap to it. Click 
to complete the taper action.

2.	 Now, we’ll hollow out the structure so that our green roof planting can 
sit inside it. On the 3D Modeling tool set, click the Shell Solid tool. 
On the Tool bar click Shell Solid Tool Preferences. Change the 
following:

•	 Shell: Inside
•	 Thickness: 40 mm
•	 Click OK.

3.	 Click on the top surface of the roof structure. It will highlight red. Click 
the green tick tool on the Tool bar, or press Enter to complete the 
Shell Solid operation.
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4.	 With the roof top selected, click on the Object Info palette’s Render 
tab. Scroll down until you find the Rotation field and type 90. Press 
Enter. The wood texture will rotate 90º. Click the Shape tab.

5.	 Change the view to Top/Plan.

Create the 2D Plan View
The structure is complete in a 3D view, but in Top/Plan, it doesn’t display 
any fills, unlike the other objects on this design layer, which are both 2D 
and 3D. Now, you’ll learn how a 2D plan view of a 3D model can be 
generated automatically.

1.	 Make Fixtures-Main the active class.

2.	 Click the Selection tool. Click and drag around the structure to select 
all its elements.

3.	 Choose Landmark > Architectural > Create Auto Hybrid.

4.	 Notice that Vectorworks has created a 2D plan view of the structure. 
Currently, only the pillars of the structure are visible on the plan. 
Notice on the Object Info palette that the cut plane is set at a height 
of 1000 mm.

5.	 On the Object Info palette, change Cut Plane to 3300 mm [10' 10"]—
the overall height of the structure.

6.	 Click 2D Appearance and change the following:

•	 Below Cut Plane tab: Dashed Hidden Line: Check
The 2D display is updated to show the structure as it looks at the new 
cut plane height. Notice that the cut plane displays in the colors of the 
original objects, in this case derived from their classes.

Exercise 9: Add Dimensions to the Structure
Now that the 3D structure is complete, you’ll add dimensions to show you can use the model for construction detailing. You’ll move the entire structure 
to a new layer so it can be isolated easily from the rest of the design. Usually, I’d encourage you to avoid placing dimensions onto your design layers. 
Best practice is to place dimensions and text as annotations on a viewport. You’ll learn more about this later. However, 3D dimensions, such as those 
we’re about to create, need to be created on the design layer.

Use the Linear Dimension Tools in 3D
1.	 Change the view to Left Isometric.

2.	 Click the Layers button on the View bar to open the Organization 
dialog. Highlight the layer Green Roof Structure and then click Edit.

3.	 Note that the Green Roof Structure layer is at the same elevation as 
the Hard Landscaping layer, that is the lower level of the garden. 
Click Cancel and click Cancel again to close the Organization dialog.

4.	 Click the Selection tool and select the structure. As all the elements 
have been enclosed within a single Auto-Hybrid object, one single 
click selects it.

5.	 On the Object Info palette, change the Layer field to Green Roof 
Structure to place the object on that layer. The object will no longer 
display.

6.	 Make Green Roof Structure the active layer. 

7.	 Change Layer Options to Active Only to hide the rest of the design.

8.	 The Auto Hybrid object is still selected after being moved to this layer. 
Click the Selection tool, and click on a blank space on the drawing to 
de-select it.

9.	 On the Dims/Notes tool set, choose Constrained Linear 
Dimension. On the Tool bar, change Dim Std to Arch (there are 
many different dimension styles for you to experiment with).

10.	Choose Text > Format Text. On the Format Text dialog, from the 
Style menu, choose Dimensions, 10 pt. This is a predefined series 
of settings that are displayed in the rest of the dialog.

11.	Click OK.
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12.	Click on two points at the base of one of the pillars. Move the cursor 
away from the base and click to place the dimension on the model.

13.	Place dimensions to show the span of the pillars.

14.	Continue to add dimensions to the pillar and posts. Dimensions can 
be placed on any 3D plane.

Vectorworks includes a wide range of dimensioning tools for different 
types of geometry. It’s not appropriate to place all dimensions for this 
structure as 3D objects. Because of the angled planes of the roof, we’ll 
add further dimensions later when we create presentation sheets for the 
design.

15.	On the Navigation palette, click on the Classes button. In the visibility 
column, to the left of the Dimension class, click in the middle column 
to hide the dimensions. Dimensions are automatically assigned to the 
Dimension class.

16.	On the Navigation palette, click the Layers button and change Layer 
Options to Show/Snap Others. Return to Top/Plan view.

17.	On the Navigation palette, notice the small x beside the Green Roof 
Structure layer. The layer is currently invisible. Click in the left-most 
column under Visibility, to restore the visibility of this layer when you 
work on other layers.

18.	Save your file and enjoy a sense of achievement. Maybe have a cup 
of tea to celebrate.

19.	Alternatively, you can open the file provided for the next section.

Summary
Congratulations! You’ve covered a lot in Section Three. Think back to the objectives we set at the start of the section. Within this sample garden, you 
can now:

•	 Use the Hardscape tool to draw Hard Landscaping/Hardscape areas
•	 Produce a worksheet showing Hard Landscaping quantities
•	 Create symbols and use ready-symbols within the design
•	 Use the Custom Stair tool to create steps
•	 Create free-standing garden walls, stepped and with coping
•	 Model a simple 3D structure
•	 Add Dimensions to the 3D structure.

In the following section, you’ll complete a planting plan for the planting beds and create the planting for the green roof on the structure.
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SECTION 4: PLANTING DESIGN

Objectives For This Section
After following the exercise steps in this section, you will be able to:

•	 Use classes to change the display properties of the planting plan
•	 Use the different modes of the Plant tool, to place plants into a design scheme
•	 Create a new Plant Definition
•	 Create a Landscape Area for calculating plant mixes
•	 Create a Worksheet to list the plants used in the scheme

Example Files Required For This Section:
•	 1-Start Planting.vwx.

Exercise 1: Explore the Planting File and Plant 
Graphics
Examine the Resources
1.	 Open the file 1-Start Planting.vwx.

2.	 Click on the Home button on the right of the Resource Browser, to 
ensure you are looking at the contents of the current file.

3.	 Scroll through the Resource Browser and notice many plant symbols 
already present in the file. I have created these in advance, but you’ll 
learn how to make your own soon.

4.	 Notice that the symbols have their names displayed in red. This 
means they are more “intelligent” than ordinary symbols and have an 
association with a specific tool (in this case, the Plant tool).

Examine the Layers
1.	 On the Navigation palette, click on the Design Layers button. Notice 

that there are two layers you have not worked with yet: Planting and 
Green Roof Planting.

2.	 These layers are currently invisible. Click on the left-most column 
under the Visibility heading next to these layers, to make them 
visible. The planting plan is displayed that you will complete in this 
section.

3.	 Make Planting the active layer.

Examine the Classes

1.	 Click on the Classes button on the Navigation palette. Take a look at 
the classes in a little more detail.

2.	 There is a series of classes called Plants-Component-… You will 
use these to control the way the plant symbols look.

The symbols you see on the drawing are included with Vectorworks, and 
can be customized to look just as you want them. This exercise will take 
you through the different ways you can display these symbols, and the 
part that classes play in this process. For example, plants can display 
shadows, sketchy outlines, and reduced detail. This section will introduce 
you to some of those options before you learn how to create your own 
plant definitions.

Control Plant Tag Visibility
1.	 On the Navigation palette, click on the Classes button. Locate the 

Plants-Component-Tags and make the class invisible. Make them 
visible again. Note that the class enables you to control the tags 
independently of the symbol.

2.	 The plant tags, displayed by the plants can have different 
configurations and you’ll see how to change them soon. I have 
arranged their position previously, and as the planting beds are all the 
same, I have only labelled one bed of each type.
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Control Plant Graphics
1.	 Zoom the view to display the plants in the top left planting area.

2.	 Make the following classes invisible and notice the effect on the 
drawing. The use of classes make things very flexible:

•	 Plants-Component-Bloom
•	 Plants Component-Canopy
•	 Plants-Component-Color Fill
•	 Plants-Component-Interior Linework

3.	 Make the classes visible again. Classes within the plant symbols offer 
control over what displays on the planting plan.

Manage Sketchy Outlines and Shadows
1.	 Make the Plants-Component-Outline class invisible.

2.	 The individual outlines around the plant symbols within groups have 
been hidden. Notice, however, that the groups of plants have a 
sketchy outline around them

3.	 Click Selection. Select one of the plant groups.

4.	 On the Object Info palette, scroll down to the Annotation/Render 
heading. Change Outline to Two Sketch Outlines. Now try Tight 
Outline and notice how the tight outline is more representative of the 
orginal outline of the symbol.

The combination of the sketchy outline render and the hidden Plants-
Component-Outlines class is one way to display groups of plants. Now, 
we’ll explore another.

5.	 Make the Plants-Component-Outline class visible.

6.	 On the Object Info palette, check Mass Plants. This method of 
massing hides everything from the symbol apart from the rear-most 
polyline within the plant graphic, so you may lose background color. If 
you need more control, use the class visibility method.

7.	 Uncheck Mass Plants to restore the graphic.

8.	 Select one of the “Betula lenta” trees on the plan.

9.	 Uncheck Plant Shadows in Plan View. Notice the shadows are no 
longer displayed. Check the box again to restore the shadows.

10.	Choose File > Document Settings > Document Preferences. 
Click Plan Shadows. The plants have been set up to display shadows 
according to this document-wide preference. Change the following:

•	 Offset: 0.2, Factor of object height
•	 Angle: Slide the button to the right to place shadows at around 45º
•	 Fill Style: Solid Color
•	 Color: Choose a Cool Gray from the Standard Vectorworks Colors 
palette
•	 Opacity: 50%
•	 Click OK and wait for a moment while the shadows update. 
(Remember, there are a lot of plants for Vectorworks to update).

The plants now display soft gray shadows, at a 45º angle, but the 
shadows are also sized according to the height of each plant group. 
(Remember—any changes to the plant shadows through Document 
Preferences will also affect any Massing Models you have used in your 
design scheme.)

11.	Save your file before continuing to the following exercise.
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Exercise 2: Placing Plants
Now that you’ve seen how the plant symbols that are included with Vectorworks Landmark are set up to make an attractive and flexible drawing, you’ll 
learn how to place new plants in the scheme using the Plant tool. You are going to plant the empty bed to the right of the bottom right lawn.

Use the Plant Tool
1.	 Choose Text > Format Text. On the Format Text dialog, choose the 

style Plant Tags Arial Narrow 10pt. Click OK.

2.	 On the Site Planning tool set, click on the Plant tool. (The first time 
you click on the tool, the Plant Settings dialog will open automatically. 
After that, you will need to use the Plant Tool Preferences button on 
the tool bar.)

3.	 On the left, click Definition. Select the Betula lenta symbol. (Do not 
change any other fields.) Click OK.

4.	 On the Tool bar, notice the different modes available for placing 
plants.

5.	 Click the first mode: Single Plant Placement Mode.

6.	 Click once on the planting bed to place a single instance of the 
Betula lenta. Notice the tag is produced automatically, on the right of 
the symbol, with an approach angle of 0º.

7.	 On the Tool bar, click on the second mode button: Poly-Vertex 
Placement mode. Click Plant Tool Preferences again and select 
Cornus alba ‘Sibirica.’ Click OK.

8.	 Click on the drawing in the upper right corner of the planting bed to 
place the first plant. Move the cursor to where you would like to place 
the second plant, and click again. Move the cursor to the position of 
the third plant. Double-click to complete the group.

9.	 Still using the Plant tool, select the third mode: Poly-Edge Spaced 
Mode. On the Tool bar, to the right of the Plant Tool Preferences 
button, you will find a menu listing the plants available in this file. 
Select Buxus sempervirens from the list.

10.	To the left of the wall and below the path, notice there is an unplanted 
strip. The Buxus will be planted here. Click at one end of the strip and 
then move the cursor to the other end of the strip. Double-click to 
complete the row of plants. Vectorworks Landmark has spaced the 
plants using the spacing value already set up in this plant. You will 
see how to do this yourself soon.
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11.	On the Object Info palette, change Spacing to 550 mm [1' 10"]. 
Notice the number of plants increases to fill the space.

12.	Choose Plant and then choose Triangular Array mode on the Tool 
bar. Click Plant Tool Preferences and click Definition. Choose 
Ligularia przewalskii. Click Size. Change the following: 

•	 Custom Spacing: check and type 300 mm [1']
•	 Notice that you can also override the Spread and Height values from 
the default for the plant as required for the design.
•	 Click OK.

13.	Click on the planting bed where you would like to place a group of 
Ligularia. With this mode, you draw the outline of the space you want 
to fill with plants. Continue to click around the area you want to plant, 
returning to the start point and double-click to complete.

14.	The plants are drawn automatically within the space and take on the 
spacing set up within the Plant Settings.

Rectangular Array mode works in the same way as the Triangular Array 
mode but places the plants on a rectangular grid instead of triangular.

Complete the Planting Plan
The easiest way to complete the plan, when you have a number of 
plants in the scheme, is to use the Pick-Up Mode of the Plant tool.

1.	 When placing plants, you may find it useful to suspend snapping 
temporarily. Hold down the Back quote key to do this.

2.	 Choose Plant and then choose Pick-Up Mode on the Tool bar. The 
cursor changes to an eyedropper.

3.	 Click on another plant grouping in the scheme and look at the Tool 
bar. The active plant is now the one you clicked on. The mode the 
plant was placed in has also been selected.

4.	 Click on the planting bed to place the plant in the appropriate way.

You can also add plants to the scheme directly from the Resource 
Browser.

5.	 Click the Home button on the Resource Browser. Scroll through the 
resources and locate any of the plants. Double-click the plant symbol 
to make it the active symbol. Click on the plan to place the plant using 
the appropriate mode.

6.	 Continue planting using either method to complete the scheme, and 
although the plant tags look a mess, don’t worry about it.

7.	 Using the Selection tool, click on the tree—the very first tree you 
placed in the scheme. Choose Modify > Send > Send to Front. This 
will bring the tree canopy graphic above the rest of the plants.

Align the Plant Tags
Now that the plants are placed, you will be wondering about the tags. If 
you used the Pick Up mode of the plant tool, the plant tag position (left or 
right) will also be copied. Each tag can be moved individually, with the 
Selection tool. However, we can also use the Align/Distribute Leader 
Lines command to do the bulk of the work.

1.	 Click Selection. Select the row of Buxus sempervirens that you 
placed earlier.

2.	 Click on the blue handle at the plant end of the tag (labeled 1 in the 
image below). Move the cursor onto a different plant within the same 
group and then click to place the handle in its new location.

3.	 Click on the blue handle at the text end, labeled 2 on the image 
below), move the cursor to the right, and click again.

4.	 Click and drag around the lower right planting bed, press Alt and 
while still pressing Alt, release the mouse. All the plants in this bed 
will be selected.

5.	 Choose Modify > Align > Align/Distribute Leader Lines.

6.	 On the Align/Distribute Leader Lines dialog, change the following:

•	 Horizontal Alignment: check both options
•	 Vertical Distribution: None.
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•	 Click OK.

7.	 Zoom so that you can see the tags of the plants in the bed above. 
Click on the left of the lowest bubble of the plants. Move the cursor 
down the page to create a vertical line and click again.

8.	 Vectorworks will take a moment to work out the tags as you’ve given 
it a complex task. When it’s complete, the tags will be aligned to the 
right, but not evenly spaced.

9.	 With the plants still selected, choose Modify > Align > Align/
Distribute Leader Lines. On the Align/Distribute Leader Lines 

dialog, under Vertical Distribution, click Equal distance between 
shoulder lines and click OK.

10.	Draw the alignment line again and wait for the command to complete. 
The plant tags are aligned and evenly spaced. Vectorworks uses the 
spacing between the top two tags as its reference when spacing the 
tags.

To save time, we’ve moved all the tags to the right. However, you could 
have selected only the plants on the left of the planting bed, and used 
the Align/Distribute Leader Lines command. Then, you could have 
repeated the process for the tags on the left.
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Exercise 3: Define a New Plant
Now that you’ve seen many of the different options for displaying and placing plants on the plan, you’ll see how to use the Plant tool to create a new 
plant definition. The process requires you to choose the 2D symbol you would like to use for the plant, add relevant data so that the symbol knows 
which plant it is representing, and, optionally, add your choice of 3D representation.

Choose a 2D Symbol
1.	 Click the Site Planning tool set. Click Plant.

2.	 Click Plant Tool Preferences on the tool bar.

3.	 Click Definition. On the Plant Settings dialog, click the symbol 
selector. Under Additional Content > Non-Species Specific  
select Ornamental.vwx and choose Ornamental Tree 02

4.	 The default plant definition named Ornamental Tree 02 is loaded and 
you can see the 2D plan graphic for the plant and a preview of the 
default 3D representation for this plant.

5.	 Click Duplicate to create a new plant definition based on this generic 
plant.

6.	 Click Insertion Options and change the following fields:

•	 Spread: 7500 mm [25’]
•	 Height: 7500 mm [25’]
•	 Spacing: 7500 mm [25’]

Add the Plant Data
1.	 Click Schedule.

2.	 Click Get Plant Data. The VWPlants database will load. Close this 
window and click Select Plant Data from the dialog box.

3.	 Under Plant List, select Trees. The list of trees from the database is 
loaded.

4.	 In the name box, type “Acer,” to take you directly to the Acers in the 
list. Scroll through the list and locate Acer platanoides ‘Crimson 
King,’ clicking on its name to highlight it.

5.	 The data for this plant are displayed in the pane on the right of the 
dialog box. Review the information, then click OK.

6.	 The plant data have replaced some the generic information that was 
present in the generic plant. You can add information here to show on 
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your Plant Schedule. Only add information if you need to show it at a 
later date:

•	 Plant/Tag ID: ACrim (This can be any code you prefer, but it must be 
unique.)
•	 Scheduled Size: 10L (This can be any text to describe the proposed 
purchase size.)
•	 Schedule Comments: Water well until established.

7.	 Highlight either the Latin Name or the Common Name—whichever is 
most appropriate in your geography—and copy it using Ctrl+C 
(Windows) or Cmd+C (Macintosh).

8.	 Move the cursor onto the Plant Symbol Name field. Click and drag 
the cursor to highlight the contents and then press Ctrl+V (Windows) 
or Cmd+V (Macintosh) to paste the plant’s Latin Name or Common 
Name into the field. This is the name by which the symbol will be 
known on your Resource Browser.

Set Default Outline and Shadow Effects
1.	 Click Render.

2.	 Below Plant Shadows in Plan View, click Use Document 
Preference Settings. By default, this plant will respond to whatever 
document preferences you have set in whichever project you use this 
plant. 

Review the Plant Data
1.	 Click Plant Data. The data you attached earlier, from the plant 

database is displayed.

2.	 Select Floral Color and then click Edit. Change the data to “Bright 
yellow.”

3.	 Click OK. The base definition of the plant has been set and the above 
settings have become the default for each time the plant is used.

4.	 The remaining tabs on the left of the dialog enable changes to the 
default settings, as you’ll see in a moment.

5.	 Click OK. Click Single Plant Placement mode on the Tool bar.

6.	 Click once on the top right corner of the plot, at the front of the house. 
The plant is placed. Press X to return to the Selection tool.

Override Insertion Options and Set Tag Options
Now we’ll look at how the default settings can be overridden whenever 
this plant is placed.

1.	 With the plant selected, click Plant Settings on the Object Info 
palette.

2.	 Click Size. Notice the default Height, Spread and Spacing fields are 
displayed. Each value can be customized so that each instance of the 
plant can differ from the default if required.
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3.	 Click Annotation. Here, you can further customize the plant 
annotation, adding lines to connect plants in a group, and add a cross 
into the center. Plants can also be rotated in groups or rotated along 
a path. They can also be scaled so that each plant appears a slightly 
different size. Leave the settings as they are.

4.	 Click Render. You can change the render settings from the default 
also. Leave the settings as they are.

5.	 Click Tag. Change the following fields, leaving all others unchanged:

•	 Display: Right
•	 Approach Angle: 0º
•	 Tag Bubble: Circle (Quantity Only)
•	 Tag Top: Latin Name
•	 Tag Center: None
•	 Tag Bottom: None
•	 Enable Tag Shoulder Line: Do not check

These settings will create the same style of tags that have been used in 
the remainder of this design. The tag settings are not stored with the 
plant definition. Rather, they are set at the time of using the Plant tool 
and it may be a good idea to set your favorite tag style within your 
template.

6.	 Click Schedule. Here you can override any of the schedule settings 
that are stored within the plant definition.

7.	 Click OK. The design no longer fits on the page. Don’t worry: in 
Section 4, you’ll learn how to present plans at any scale on any sheet 
size.

8.	 Look at the Resource Browser and click on the Home button to 
ensure you are looking at the contents of the current file.

9.	 Under Symbols/Plug-in Objects, locate the Acer symbol. Notice 
also all the other plants we have used in this scheme.

Edit the 3D Plant
The 3D element of the plant can be made from:

•	 Modeled 3D geometry, or
•	 An Image Prop (Renderworks only)

An Image Prop is the most efficient method,  and there are many library 
files of image props for planting. You can also make your own if you have 
an image editing application and the skills to remove the background 
from a plant photograph.

Image Props are flat images, stuck onto two crossed 3D planes. They 
have a “transparent mask” around them so that their background is 
obscured and they cast the correct shadows when rendered.

The following steps are dependent upon Renderworks being part of your 
licensed installation. If you do not have Renderworks, you can skip these 
steps and move to the following exercise.

1.	 Change the view to Left Isometric.  

2.	 As the plants are hybrid (2D and 3D) objects, they are now displaying 
their 3D element.

3.	 Click the Selection tool and select the Acer. On the Object Info 
palette, click Plant Settings.

4.	 On the Plant Settings dialog, click Edit Plant Definition. Notice the 
2D and 3D preview of the plant. Click Copy from Symbol.

5.	 Click the symbol selector. Under 3D Components> Species 
Photorealistic Color select Photo IP Deciduous and Broadleaf A-Ae.
vwx. Then choose Acer Palmatun 4.0i A. Click Use only the 3D 
component of the symbol. Click OK, click OK, and click OK again to 
return to the drawing area.
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6.	 Click on a blank space on the drawing area to ensure nothing is 
selected. On the View bar, click Fit to Objects to center your scene 
on the screen.

7.	 Save your file.

 

Exercise 4: Create a Landscape Area
You’ve now learned how to place individual plants into a scheme, and to place them in groups, using classes and plant styles to change the display 
options. But what if you want to plant a larger area, or a standard mix of plants? The Plant tool is not ideal for this, as it would be very laborious to have 
to place each individual plant. Instead, Vectorworks offers the Landscape Area. The Landscape Area uses the same Plant definitions as the Plant tool, 
so you still need to set up the plants as before, but it enables you to mix them by percentage, at specific planting rates. It’s ideal for larger areas, bulb 
mixes, wildflower mixes, and much more. In this exercise, you’ll see a ready-made Landscape Area, examine its settings, and then learn to create your 
own.

Explore a Landscape Area
1.	 Return to Top/Plan using either the View > Standard Views > Top/

Plan menu command or the Standard Views menu on the View bar.

2.	 On the Navigation palette, make Green Roof Planting the active 
layer. Change Layer Options to Gray/Snap Others.

3.	 On top of the roof structure that you created in the Hard Landscaping 
Section, you will find a green rectangle with a tag on it.

4.	 With the Selection tool, click on the rectangle to select it.

5.	 Look at the Landscape Area tag. This area contains five plant 
species, 20% of each. The name of the area is shown at the top.

6.	 Look at the Object Info palette. This object is a Landscape Area. The 
Landscape Area has a Z elevation (position in 3D space) of 2600 mm 
[8’ 6 ¾”].

7.	 Click on the Layers button. The Green Roof Planting layer has a Z 
elevation of 0. Click OK to dismiss the dialog. The Z elevation of the 
Landscape Area is relative to 0. Elements on the Planting and Hard 
Landscaping layer are relative to their Z elevation of -650 mm [2’ 
1⅝"]. The Landscape Area sits on top of the roof structure.

8.	 On the Object Info palette, click on the Landscape Area Settings 
button to open the Landscape Area Settings dialog.
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9.	 Take a look at the settings. This Landscape Area has a name, that 
appears in its tag. The tag is on, but it needs a separate class so it 
can be controlled independently.

10.	Make the following changes:

•	 Tag Class: Landscape Area-Tags
•	 Tag Header: Name-Area
•	 Tag Body: Percentage-Latin Name
•	 Area Units: Choose the most appropriate for your geography
•	 Border Style: Plant Line
•	 Click OK

11.	The tag now displays the area of the object as well as the name. The 
border is now a pretty, wiggly, plant line.

12.	Look at the Object Info palette. The Landscape Area is a member of 
the Landscape Area-Main class. Click on the Classes button on 
the View bar to open the Organization dialog.

13.	Click in the Landscape Area-Main class and then click Edit. Notice 
the fill style is set to Gradient, and a green gradient has been 
selected. The Pen is a solid pale brown.

14.	Click OK and then OK again to return to the drawing area.

15.	Change your view to Left Isometric. Notice that the plants are 
showing as Image Props, like the other plants in the scheme. (If you 
don’t have Renderworks, there will be no Image Props in the scene.)

16.	On the Object Info palette, click on Landscape Area Settings again. 
Change the following:

•	 3D Display: 3D Poly
•	 Click OK.

17.	The 3D Plants are hidden, and replaced with a flat 3D plane. Click 
Landscape Area Settings again and return the setting to 3D 
Plants. Click OK.

The Texture Bed option is for working with a Site Model, which is beyond 
the scope of this Getting Started Guide.

Create a New Landscape Area
1.	 Return to Top/Plan View.

2.	 Using the Navigation palette, make Landscape Area-Main the 
active class.

3.	 From the Site Planning tool set, click on the Landscape Area tool 
and then click on the Landscape Area Tool Preferences button on 
the Tool bar.

4.	 Adjust the following settings:

•	 Name: Mixed Planting
•	 Tag Display: On
•	 Tag Class: Landscape Area-Tags
•	 Tag Header: Name-Area
•	 Tag Body: Percentage-Latin Name
•	 Area Units: Square Meters/Feet
•	 3D Display: 3D Plants
•	 Border Style: Plant Line
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5.	 Now you will add plants to the area. There are three different ways 
that plant quantities can be calculated. In this case, we will have 
control over the percentage of the area that each plant will cover, and 
the planting rate for each plant. Select:

•	 Plant Information: Distribution Rate (custom coverage 
percentage)

6.	 To add Plants, click Add and complete the Edit Plant Information 
dialog as follows:

•	 Show Plants from following file: Current Document
•	 Plant: Kniphofia uvaria
•	 Rate: 7/sqm
•	 Percentage: 30
•	 Click OK.

7.	 Repeat the process, adding the following plants and settings:

•	 Plant Symbol: Darmera peltata; Rate: 5/sqm; Percentage: 20
•	 Plant Symbol: Cornus alba ‘Sibirica’; Rate: 1/sqm; Percentage: 10
•	 Plant Symbol: Persicaria affinis ‘Superba’; Rate: 5/sqm; 
Percentage: 30
•	 Plant Symbol: Carex elata ‘Aurea’; Rate: 5/sqm; Percentage: 20

8.	 Click OK to close the Landscape Area Settings dialog.

9.	 Note that, like the Hardscape tool, the Landscape Area tool has all 
the same drawing functions as the Polyline tool, which enables you to 
draw complex shapes, by changing modes as you draw.

10.	Move the cursor to the front garden. On the Tool bar, choose Point 
on Arc mode and start to draw an arc around the center of the tree. 

Change to Corner Vertex mode and complete a shape for the front 
planting bed, similar to this one. Remember, you can use the k key 
on your keyboard to close the shape.

The Acer tree symbol is now behind the Landscape Area, because it is 
on the Planting layer, which is below the Green Roof Planting Layer in 
the stack.

11.	Make Planting the active layer using the Navigation palette.

12.	Click the Selection tool. Select the Acer. On the Object Info palette, 
change its Layer to Green Roof Planting. The tree moves to the 
layer and displays above the Landscape Area. It has also associated 
itself with the elevation of the new layer, thus bringing it to the level of 
the house and front landscape area.

13.	Change Layer Options to Show/Snap Others. Change the view to 
Right Isometric and confirm that the tree is at the same level as the 
front garden. 

14.	Return to Top/Plan view.



55 | Vectorworks Site Design Guide

Exercise 5: Create a Plant Report
Remember the Hardscape worksheet that you created earlier? The one that conveniently listed the areas of different materials used? You can do the 
same with your planting plan. Many objects in Vectorworks have a “record” attached to them, and the Plant is a perfect example. Think about the 
information you attached to the Plant symbol. Reports can be created to pull any of this information into a table that can be either placed on the plan, or 
exported to a spreadsheet application or other project documentation. As well as providing excellent reporting, they are also a very efficient way of 
updating information on the plan. In this section, you’ll learn how to generate a simple plant schedule, and use it to update the information attached to 
the plants.

Choose a Schedule
1.	 Make Notes-Reports the active class.

2.	 Choose Tools > Reports > Choose Schedule.

3.	 On the Choose Schedule dialog, choose Plant List-Simple, check 
Place Worksheet on Drawing, and then click OK.

4.	 The cursor changes to a small target. Click on the drawing area 
where you would like to place the schedule.

5.	 This schedule lists all the plants used in the drawing, including those 
within the Landscape Areas.

6.	 Double-click the worksheet to open it in a separate window.

7.	 In the Scheduled Size column, click in the Acer platanoides ‘Crimson 
King’ row. Replace the existing text with “Heavy Standard,” and 
press Enter.

8.	 Close the worksheet window.

9.	 Make Green Roof Planting the active layer.

10.	Select the Acer platanoides ‘Crimson King’ symbol on the plan. 
On the Object Info palette, click Plant Settings.

11.	Click Schedule. Notice Custom Scheduled Size field has been 
checked. The Heavy Standard text is overriding the original schedule 
information from the definition. The worksheet displays the plant 
record, but it can also update it.

12.	Click Cancel. Make Planting the active layer.

13.	Click the Selection tool, select the plant schedule and delete it. We 
will place it on our presentation plans in the following section.

14.	Save the file. Review my file 2-Planting Complete if you wish to 
compare your results with mine.
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Summary
So, that’s another section completed! You’ve covered a lot in this section and have seen how symbols can be used to represent elements of your 
design, but not just visually. Elements of your design can store information, and you can retrieve this information to support your design and build 
process.

As a reminder, here’s what you’ve learned how to do in this section:

•	 Use classes and plant settings to change the display properties of the planting plan
•	 Use the different modes of the Plant tool, to place plants into a design scheme
•	 Create a new Plant Definition
•	 Create a Landscape Area for calculating plant mixes
•	 Create a Worksheet to list the plants used in the scheme

In the next section, you’ll learn how to pull all the different elements together to create presentation plans, technical details, and perspectives. You’ll also 
learn the different options for printing.
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SECTION 5: PRESENTATION AND PUBLISHING

Objectives For This Section
After you complete the exercises in this chapter, you will be able to:

•	 Create Sheet Layers and amend their properties
•	 Add a Title Block to a Sheet Layer
•	 Create Viewports of your design, showing it in different orientations
•	 Render a Viewport using a Renderworks Style
•	 Publish your design in a variety of formats including Print, PDF and DWG 

Until now, you have been working on a series of stacked design layers, used to separate different stages of the process and to provide different 3D 
planes on which to place objects. You have also used Classes to distinguish between different types of objects and to apply different graphics to their 
members. Now, you’ll learn how to make full use of all these elements to prepare all the project drawings you need.

Exercise Files Required For This Section:
•	 1-Start Presentation.vwx

Exercise 1: Create Sheet Layers
Although we set the scale on the layer and set the page size, I’ve mentioned several times that it really doesn’t matter about page size on a Design 
Layer. Ultimately, on a Sheet Layer you can present your model from any angle, at any scale with as much information visible as you choose, on a 
Sheet Layer. A Sheet Layer is much more representative of a physical sheet of paper than a design layer.

Create Sheets
1.	 Open the file 1-Start Presentation.vwx.

2.	 Using the Navigation palette, make sure None is the active class.

3.	 Click the Layers menu on the View bar and notice you can create 
new layers directly from this menu. Choose New Sheet Layer.

4.	 In the New Sheet Layer dialog, complete the fields as follows:

•	 Sheet Number: Sht-1
•	 Sheet Title: Layout
•	 Edit Properties After Creation: Check
•	 Click OK.
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5.	 On the Edit Sheet Layers dialog, note that you can set the DPI (dots 
per inch) for the layer. This setting affects the quality of any rendered 
images. Higher values will produce higher quality images, but they 
will increase rendering time. For now, leave this at 72 DPI, but be 
aware that you may want to increase it later.

6.	 Click Page Setup. You saw this dialog at the start of this guide when 
setting up your Design Layers. Check Use Size Unavailable in 
Printer Setup and then select ISO A1 [US Arch D]. Click OK.

7.	 Click OK again. Return to the layers menu to create two more Sheet 
Layers with the following settings:

•	 Sht-2 Hard Landscaping; Page Size: ISO A1 [US Arch D]
•	 Sht-3 Planting; Page Size: ISO A1 [US Arch D]
•	 Use the Layers menu, or the Navigation palette, to make Sht-1 
Layout the active layer.
•	 Click OK.

8.	 Click Fit to Page. Don’t worry that you can’t see your design 
anymore. It’s all still there, on the Design Layers, and we’ll return to it 
soon.

9.	 Notice that the Sheet Layer looks a little different than a Design 
Layer. It has a more distinct border and looks like a physical page. It 
has a scale of 1:1 that cannot be changed. The Viewports themselves 
(when we’ve created them), will display objects at a chosen 
architectural scale.

Add a Sheet Border
1.	 Open the Dims/Notes tool set. Click on the Sheet Border tool, and 

then click Sheet Border Tool Preferences on the Tool bar.

2.	 When the Sheet Border dialog opens, change the following:

•	 Sheet Size: Fit to Page
•	 Title Block: Click Defaults, then click the symbol preview and choose 
Simple Title Block-1
•	 Click OK, and then click OK again.

3.	 The cursor is now carrying a “ghosted” Sheet Border and Title Block. 
Click once on the center of the page and again to set the rotation.

4.	 Press X on your keyboard to return to the Selection tool and avoid 
placing further Sheet Borders on top of this one.

5.	 On the Object Info palette, click Border Settings and adjust all four 
of the margins of the Sheet Border to 10 mm [⅜]. Click OK. 
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6.	 On the Object Info palette, change the following fields:

•	 Title Block Margin: Vertical
•	 Show Grids: Uncheck

7.	 Choose Text > Format Text and set Style to Plant Tags Arial 
Narrow 10pt. Click OK.

8.	 On the Object Info palette, click Edit Title Block and enter the 
following information into the fields:

•	 Drawing Title: Layout Plan
•	 Drawing Number: GSG-001

•	 Drawn by: Tamsin Slatter (You can add your own name if you 
prefer!)
•	 Date: June 2014
•	 CAD Filename: Getting Started.vwx
•	 Click OK.

9.	 Notice the fields have updated on the Sheet. (Don’t worry about the 
color—the border is only orange because it’s selected!)

10.	Choose Edit > Copy.

11.	On the Navigation palette, click the Sheet Layers button. Make 
Sht-2 the active layer.

12.	Select Edit > Paste in Place. On the Object Info palette, click Edit 
Title Block and change the following details:

•	 Title: Hard Landscaping Plan
•	 Drawing Number: GSG-002
•	 Click OK

13.	Repeat the copy and paste process to place a sheet border on Sht-3. 
Click Edit Title Block and change the following details:

•	 Title: Planting Plan
•	 Drawing Number: GSG-003
•	 Click OK

The sheets are now prepared and ready to display viewports.
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Exercise 2: Create a Plan Viewport
Now you are going to present the Plan in a number of different ways on the same sheet of paper, using Viewports. Viewports are effectively saved 
views of the drawing, with their own class and design layer visibility settings, and render settings. Viewports are a live link to the design. As the design 
is amended, the Viewports will show the updated changes.

Create a Plan Viewport
1.	 Click the Design Layers tab and make Green Roof Planting the 

active layer. The design will be displayed.

2.	 Ensure you are looking at your design in Top/Plan view, using the 
View menu on the View bar. Use the Selection tool to click on a 
blank space to ensure nothing is selected.

3.	 Choose View > Create Viewport.

4.	 On the Create Viewport dialog, complete the following fields, leaving 
all other fields blank:

•	 Viewport Name: 1
•	 Drawing Title: Master Layout
•	 Create on Layer: Choose Sht-1 [Layout]
•	 Notice, but do not change, the Layers and Classes button, the Scale, 
and the View menus. You’ll use these in moment to edit what’s visible in 
the Viewport.
•	 Click OK.

5.	 The Viewport is created and placed on Sht-1 Layout, which is now 
the active layer. The viewport is selected. The viewport scaled at 1:50 
is too large for the sheet.

6.	 On the Object Info palette, change Scale to 1:100. The Viewport 
shrinks to 1:100.

7.	 Using the Selection tool, click and drag on the Viewport to center it 
on the main area of the page.
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8.	 With the Viewport still selected, click Classes on the Object Info 
palette. Turn the Plants-Component-Tags class and the 
Landscape Area-Tags class to Invisible and then click OK.

9.	 The Viewport now shows a beautiful overview plan of the design.

Exercise 3: Create a 3D Rendered View
Set up the View
1.	 Use the Navigation palette to make any design layer the active layer.

2.	 Change the view to Left Isometric.

3.	 Click the Flyover tool on the Basic palette. Click OK to dismiss the 
helpful dialog. On the Tool bar, click Interactive Origin mode.

4.	 Click once somewhere toward the center of the garden to set the 
center of rotation. Click and drag on the left mouse button to change 
the view to something pleasing. Remember you can use Fit to 
Objects to bring the scene back onto your screen and the Pan facility 
(the space bar) to move the model on the screen.

5.	  Choose View > Create Viewport.

6.	 Complete the Create Viewport dialog as follows, leaving other 
settings on their defaults:

•	 Viewport Name: 2
•	 Drawing Title: 3D Perspective View
•	 Create on Layer: Sht-1 [Layout]
•	 Click OK

The perspective viewport is displayed in Wireframe mode, on the same 
sheet as the plan viewport. The Viewport will display a red striped border, 
indicating that it needs updating. Rendering on a Sheet Layer only 
occurs when you update the Viewport. However, we’re now going to 
improve the render before updating the viewport (Renderworks is 
required for this.)

7.	 Click the Selection tool. Click and drag on the Viewports to move 
them and create a pleasing layout on the sheet. 
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Render the 3D View
1.	 Choose File > Document Settings > 

Document Preferences. Click on the Display tab and ensure that 
Save viewport cache is checked. This will ensure that once the 
viewport is rendered, it will be saved in this state so you do not have 
to render each time you open the file. Click OK.

2.	 Select the perspective viewport. On the Object Info palette, change 
the following field:

•	 Background Render: Renderworks Style > Realistic Exterior 
Final.

3.	 On the Object Info palette, click Update. The Viewport will turn black 
and take some time to render (this is dependent on your computer’s 
specification), but the result will be very pretty! If you don’t want to 
wait, you can press Escape the cancel to render process, but you can 
continue to work while the scene renders. Notice the teapot-shaped 
indicator that shows you rendering is processing.

4.	 Click the Home button on the Resource Browser. This built-in 
rendering style contains settings ideal for rendering outdoor scenes 
and uses the new physical sky that links the Heliodon sun object to a 
sunny sky background. Notice the Render style and the Physical Sky 
background have been imported into the file.

Rendered with Renderworks

5.	 You can add more text, directly onto the Sheet layer. You can also 
add supporting images to the Sheet layer using File > Import > 
Import Image File.

Add Drawing Labels
1.	 Double-click on the Plan viewport. When the Edit Viewport dialog 

opens, click Annotations and then click OK.

2.	 Notice that the other viewport’s footprint is visible, but gray. If it is not 
visible, turn on Show Other Objects in Edit Mode, on the right of 
the Tool bar, above the Exit Viewport Annotation button.

3.	 Click the Dims/Notes tool set and click Drawing Label. There is no 
need to change the preferences.

4.	 Click once on the drawing to position the Drawing Label and again to 
set its rotation. Notice that the label automatically picks up the 
Viewport name, number, and scale.

5.	 Click Exit Viewport Annotation at the top right of the screen.

6.	 Repeat the process to add a Drawing Label to the perspective 
viewport. Once inside the Viewport editor, you can continue to use 
the SmartCursor to assist in aligning objects, so that your plan will 
look well laid out. 
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Exercise 4: Create Additional Viewports
In this exercise, you’ll duplicate the plan viewport and change the settings of the copy so that it presents only hard landscaping information. You’ll then 
add the Hardscapes Budget report to the sheet.

Create a Hard Landscaping Plan
1.	 Click on the first viewport—the one showing the Top/Plan view. Select 

Edit > Duplicate.

2.	 Select the copy if it is not already selected. On the Object Info palette, 
change Layer to Sht-2 Hard Landscaping.

3.	 Using the Navigation palette, click the Sheet Layers tab and make 
Sht-2 Hard Landscaping the active layer.

4.	 Select the viewport. On the Object Info palette, change the following 
fields, leaving all other fields unchanged:

•	 Drawing Title: Hard Landscaping Layout
•	 Click the Layers button and make Green Roof Planting and 
Planting invisible. Click OK.
•	 Click the Classes button and make Dimension visible. Click OK.

5.	 The Viewport is now displaying only Hard Landscaping Information, 
and the dimensions created earlier are visible. Double-click the 
viewport and click Annotations. Click OK.

6.	 Select the Drawing Label. On the Object Info palette, change Number 
Style to Drawing and Sheet. 

7.	 From the Dims/Notes Tool set, choose Constrained Linear 
Dimension. Add further dimensions to show the width of the path 
and the tread depths of the steps.

8.	 Click Exit Viewport Annotations.

Create a 3D Construction Drawing
1.	 Duplicate the Hard Landscaping Layout viewport.

2.	 Move the copy downward on the page so it is below the original.

3.	 Using the Object Info palette, change the following:

•	 Drawing Title: Green Roof Structure Detail
•	 Layers: Turn off all layers except Green Roof Structure
•	 Scale: 1:25 

•	 View: Left Isometric
•	 Background Render: Hidden Line

4.	 Double-click the viewport and select Annotations. Click OK.

5.	 Use Select Similar to select the dimensions you placed in the 
viewport above and delete them as they are not appropriate to this 
view. Press X to return to the Selection tool.

6.	 Select the Drawing Label and use the Object Info palette to change 
the Drawing Number to 2. Move the label to a position beneath the 
structure.

7.	 From the Basic palette, choose the Callout tool, next to the Text tool.

8.	 Click on a space to the right of the structure and then click on the top 
of the structure. In the Notes Manager Callout dialog, enter the text 
“Reclaimed timber.” Click OK.

9.	 Place another callout, labeling the Brick pillar with the text “Brick 
pillar.” Click OK.

10.	Click Exit Viewport Annotation again to return to the Sheet Layer. 
Press X to return to the Selection tool.

11.	On the Object Info palette, click Update to render the viewport.

Add Hard Landscaping Worksheet
1.	 On the Resource Browser, click the Home button.

2.	 Scroll to the bottom of the Resource Browser and locate the 
Worksheets heading. Double-click the Hardscapes Budget 
worksheet. It will display on the Sheet Layer.

3.	 Using the Selection tool, click and drag the worksheet to move it 
where you want on the sheet.
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You can add additional text to a Sheet Layer if you wish.

Create a Planting Plan
1.	 Duplicate the Hard Landscaping Layout viewport as you did earlier, 

using Edit > Duplicate.

2.	 On the Object Info palette, change the layer to Sht-3 Planting to 
move the Viewport to this layer.

3.	 Make Sht-3 Planting the active layer. Select the Viewport.

4.	 On the Object Info palette, click the Layers button. Change the 
visibility of all layers except Planting and Green Roof Planting to 
Gray. Click OK.

5.	 On the Object Info palette, click the Classes button to change the 
visibility of the following classes, and then click OK:

•	 Dimension: Invisible
•	 Landscape Area-Tags: Visible

•	 Plants-Component-Bloom: Invisible
•	 Plants-Component-Canopy: Invisible
•	 Plants-Component-Color Fill: Invisible
•	 Plants-Component-Interior Linework: Invisible
•	 Plants-Component-Outline: Invisible
•	 Plants-Component-Tags: Visible

6.	 On the Object Info palette, make the following changes:

•	 Drawing Title: Planting Plan
•	 Scale: 1:50

7.	 The viewport is, once again, too large for the sheet. Double-click the 
viewport and choose Edit Crop. Click OK.

8.	 Choose the Rectangle tool from the Basic palette. Draw a rectangle 
around the rear garden planting area, including the tags. Click Exit 
Viewport Crop at the top-right of the screen.

9.	 The Viewport now displays only the area within the cropping 
rectangle.

10.	Edit the annotations of the viewport and change the Drawing Label 
number if you wish.

Add the Plant Schedule
1.	 On the Resource Browser, click the Home button to ensure you are 

looking at the contents of the current file. Locate the worksheet Plant 
List-Simple, and double-click it. The worksheet will be displayed on 
the Sheet.

2.	 Using the Selection tool, click and drag on the worksheet to move it 
to a position below the Planting Plan.

Exercise 5: Publish the Design
Once a project is completed, or has reached the stage where you need to issue the latest set of revisions, Vectorworks offers a variety of different 
formats for your files. You may wish to print them, or create Portable Document Format (PDF) files. Alternatively, you may need to produce documents 
in DWG format so that they can be imported into AutoCAD®. If you are printing from your own office, using your own printer, the process is simple. Your 
page size for the Sheets will already have been set up correctly during the Page Setup process, and, therefore, the plan will print to scale on the chosen 
media. If you don’t have a large format printer in your office, your best option is to create a PDF of your sheets and then send those to be printed via 
e-mail, or a large-file transfer service. Alternatively, you could consider not printing at all, and instead share documents electronically with your clients 
and project colleagues, using a service such as Vectorworks Cloud Services with the Nomad app.

Print the Plan
With your own printer available, printing is simple, as long as your page 
area matches the page sizes available through your printer driver. It’s 
important to ensure that the printer does not apply any scaling to the 
document, as the drawing is already at the correct scale.

1.	 Choose File > Print to open the Print dialog and set the following 
options:

•	 Printer: Choose your printer
•	 Settings menu: Choose the appropriate settings for your printer. Each 
printer will offer different options.
•	 Click Print.
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Export to PDF
PDF files can be created from either the Design Layer, with the active 
visibility settings, or from a Sheet Layer. You can create a single PDF, or 
create a series of PDF files from selected sheets as a batch process.

1.	 Choose File > Export > Export PDF. The Export PDF dialog opens.

2.	 Check Export Design Layers as PDF Layers. This will allow you to 
create an interactive document, where you can turn elements on and 
off in your PDF, (provided that your PDF viewer application supports 
this).

3.	 Check Open PDF in the default viewer to see the file when it has 
been created.

4.	 Choose the Resolution setting you want for the final image. 
Remember that the higher the DPI setting, the larger the file will be. If 
the PDF DPI setting is higher than the current Sheet Layer, the 
document will render as part of the export process.

5.	 Click Export.

6.	 Choose a file name and location for the PDF file, such as “Planting 
Plan.” Click Save.

7.	 The PDF file will open in your default PDF viewer application.

8.	 Return to the Vectorworks application.

Publish a Set of Sheets in Different Formats
In this case, we have several sheets that make up the project. Using the 
publish facility, you can export your Sheet Layers individually, or as a 
single, multi-page PDF file. You can also choose a mixture of PDF, Print 
and DWG as the export destination for the sheets.

1.	 Choose File > Publish.

2.	 At the bottom of the dialog, choose the default export type. In this 
case, choose PDF.

3.	 Press Shift and select each of the sheets that will be published—in 
this case, all of them, Click the arrow button to move the selected 
sheets to the right side of the dialog.

4.	 At the top of the dialog, click Save a Set. Name the set Publish to 
PDF. Click OK.

5.	 Click Publish. Choose the location for the exported files and click 
OK.

6.	 Once the files are published, they will open in your default PDF 
viewer. Notice that the PDF is a multi-page PDF. By default, the batch 
export process will create a single, multi-page file. However, check 
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Export as Separate Files if you wish to create separate PDF 
documents.

7.	 Return to Vectorworks and click OK to dismiss the Publish dialog.

8.	 Choose FIle > Publish again.

9.	 Select one of the sheets. To publish a black and white copy of a 
sheet, click in the Color column to change the setting for the file.

10.	Select one of the sheets on the right side of the dialog. Change 
Publish To to DWG/DXF. Although the default publish choice on the 
left of the dialog is PDF, it is still possible to override the settings for 
individual sheets in the set.

11.	Click Publish to start the export. As you have changed the settings 
from your original saved set, you will be prompted to save the set so 

that you can recall these new settings later. To save time on this 
occasion, click No, but for future exports, this is something you 
should consider to save time in recalling settings.

12.	Choose a file name and location for the published set of files and 
click Open.

13.	The PDF file will be displayed in the default PDF viewer. The DWG 
file will be in a folder under the save location you specified in 12 
above. To view the DWG file, you would need a copy of AutoCAD® 
software or a DWG viewer.

With this small project, containing only three sheets, individual exports 
will be easy, but with more complex projects, creating files in the desired 
output format can be time consuming. The Publish facility makes it easy 
to create multiple types of output in a single command.

Summary
Well, that’s the final exercise in our quick tour of the Vectorworks Landmark tools. Let’s revisit the objectives of this section. At the end of this section, 
using the exercise files provided, you will be able to:

•	 Create Sheet Layers and amend their properties
•	 Add a Title Block to a Sheet Layer
•	 Create Viewports of your design, that allow you to show it in different orientations
•	 Create a sunny exterior render of a Viewport using a Renderworks Style
•	 Publish a PDF document and a DWG file containing your design
•	 Print your design

You’ve seen the value of creating a structured drawing, and building a 3D model as part of your design process. Sheet Layers and Viewports enable 
you to present that information in a wide variety of formats, without having to redraw anything at all. Sheet layers are used to pull together all the 
aspects of the design that you want to present. Sheet layers can include images, text, and worksheets, as well as the elements designed within 
Vectorworks. Now move onto to final chapter to see an introduction to working with sloping sites.
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SECTION 8: INTRODUCTION TO SLOPING SITES

Objectives For This Section
After following the exercise steps in this section, you will be able to:

•	 Use the Stake tool to mark spot heights / levels on the site
•	 Create a simple slope from Stakes
•	 See how design elements learned about earlier in the Getting Started Guide interact with the surface of a site model

Example Files Required For This Section:
•	 1-Create Simple Site.vwx
•	 2-Sloping Site.vwx

In the main body of the Getting Started Guide, you have learned how to create many different landscape elements, all of which include a 3D 
component. In the example file, we used design layer elevations to create two distinct planes in a simple terraced garden. This was an ideal way to get 
started, so that you could concentrate on learning how the different landscaping element tools work. However, in reality, most landscapes are not flat. 
Nor do they fall neatly into distinct flat planes at different levels. How does Vectorworks handle sites that slope and how can you represent these slopes 
in your model?

Well, Vectorworks includes a very powerful suite of tools for creating and editing site models. You can use a site model to represent the existing site and 
then use a series of site modifier tools to apply your design changes to the site and even calculate the cut and fill volumes resulting from your changes. 
This process is far more detailed than I can cover in this short demonstration, so instead, I’m going to show you how to create a site from your own 
measured levels, and then use a finished model to show you how the landscape elements integrate with the surface of this model.

The key to creating a successful site model is to have accurate height data. This could be information that you derive from your own survey, an 
imported survey, or it could be the spot heights or contours that you have determined as part of your design process.
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Exercise 1: Create a Simple Slope
A site model can be created from stakes or loci that represent individual height measurements. Alternatively, it can be created from 3D polygons that 
represent contours. In this exercise, you will create a simple slope from stakes representing individual level measurements.

Create the Levels
1.	 Choose File > Open and open the file 1-Create Simple Site.vwx. 

The file contains a simple 2D Polyline which represents the plan view 
of the outline of a site. We’ll add some levels to this file and then 
create a 3D representation of the site.

2.	 On the Site Planning tool set, click the Stake tool. On the tool bar, 
click Standard Insertion Mode. Click Stake Tool Preferences. 
Change Mode to Include as Site Model Data and then click OK. On 
the tool bar, change Elevation to 0 mm and press Enter.

3.	 On the left edge of the Polyline, click at the corners and two points in 
between, to create four stakes, that represent the elevation of 0.

4.	 On the tool bar, change elevation to 1000 mm. Roughly one quarter 
along the length of the shape, place a vertical line of four stakes. 
Notice the elevation is displayed by the Stake’s marker.

5.	 On the tool bar, change the elevation to 2500 mm. Roughly half way 
along the shape, place another vertical arrangement of four stakes on 
the polyline.

6.	 On the tool bar, change the elevation to 3000 mm and place a further 
arrangement of four stakes, roughly three quarters along the shape.

7.	 On the Tool bar, change the elevation to 4000 mm and place a final 
set of stakes along the right edge of the shape.

On a real site, you would clearly take more care over the positioning of 
the stake.

8.	 Click the Select Similar tool and click on one of the Stakes to select 
them all.

9.	 Choose Landmark > Create SIte Model or AEC > Terrain > Create 
Site Model.

10.	Leave all the default settings and click OK.

11.	In Top/Plan view, you’ll see a contour plan of the site.

12.	Change the view to Left Isometric. The site still displays as simple 
contours. On the Object Info palette, change 3D Style to Mesh Solid. 
Render the site with OpenGL.

Place Plants on the Model
1.	 Return to Top/Plan view.

2.	 On the Site Planning tool set, click Plant. Choose Poly Edge-
Spaced mode. From the Plants drop down list, choose ‘Cercis 
siliquastrum.’

3.	 Place a row of Cercis siliquastrum on the site, moving up the slope.

4.	 Repeat this on another part of the slope.

5.	 Change the view to Left Isometric again, and notice that the 3D 
elements of the plants are automatically sitting on the surface of the 
site model.

6.	 Return to Top/Plan View and select the Round Wall tool from the 
Building Shell tool set. Choose Radius mode and draw a round wall 
on the site.

7.	 On the Resource Browser, locate the Wicker Table 60x60 symbol. 
Double-click the symbol to make it active.

8.	 Click twice to place an instance of the symbol, perhaps within the arc 
of the round wall. .

9.	 Change the View to Left Isometric again.

10.	Choose Landmark > Send to Surface. Select the round wall and 
run the Landmark > Send to Surface command again. Notice that 
both elements now sit on the surface of the site and the base of the 
wall has been adjusted to suit the site.
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11.	Close the file — save it if you wish, but you won’t need it for the 
following section.

Exercise 2: Explore an Example File
Now you’ve seen how you can use measured levels to create a representation of a sloping site, we’ll take a quick look at a completed design so you 
can see how all the elements fit together.

Examine the Layers
1.	 Open the file 2-Sloping Site.vwx.

2.	 Click the Layers button and look at the list of layers. The layer 
structure is similar to the layers you’ve seen in the other parts of the 
Getting Started Guide, but the file also includes a Site Model layer. 
This time, the design layers don’t have different elevations. They are 
all set at zero. Elements on these layers will sit on the surface of the 
site model. In this case, the site model surface has been created with 
Stakes but has been adjusted to suit the design. This is achieved with 
the use of Site Modifiers, which are beyond the scope of this guide. 
However, note that they enable you to impose your design onto the 
site and determine the changes, including Cut and Fill volumes. Click 
Cancel.

3.	 Make Site Model the active layer.

4.	 Select the Site Model. Where earlier in the tutorial we created Floor 
objects at different elevations to represent the site, here the entire 
site is represented by one single object that sits below all the design 
elements. The surface of this object changes as the levels of the site 
change.

Examine the Source Data for the Site Model
Like the earlier simple slope, this example model was also created from 
a series of “spot heights” measured across the site and entered into 
Vectorworks with the Stake tool.

1.	 Right-click on the model with the Selection tool and choose Edit Site 
Model Source Data.

2.	 The model itself and the design will be hidden, but in its place, you 
will see the data that were used to create the model.

3.	 Change the view to Front and notice that each Stake represents a 
specific point in 3D space. These are the points that Vectorworks has 
connected to create the surface of the model.

4.	 Click Exit Source Data to return to the drawing area. 
 

Explore the Complete Design
1.	 Make Hard Landscaping the active layer. Click the Selection tool and 

click on the elements of this layer. There are Hardscapes, Walls and 
Custom Stair objects. Look at the Object Info palette and notice that 
each object has a Z value and it has been placed on the surface of 
the model. The objects have either been positioned with the Send to 
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Surface command, or they have been placed at the correct elevation 
by typing the elevation into the Z field.

2.	 Select a Hardscape object and click Hardscape Settings on the 
Object Info palette.

3.	 Notice that the 3D Type is Pad Modifier. This is a special kind of 
object that flattens the site beneath the Hardscape, and adjusts the 
contours accordingly to accommodate the new design elements. 
Click Cancel.

4.	 Make Planting the active layer. Notice that each plant is sitting at the 
correct elevation on the site model, but the Z value on the Object Info 
palette remains at 0. Plants automatically sit on the surface and you 
don’t have to do anything special to make this happen.

5.	 Set Layer Options to Active Only. Finally, make Site Modifiers the 
Active Layer. This layer contains a series of other “modifiers,” which 
are objects that can change the surface of the site model. For 
example, the pad toward the bottom of the slope creates a flat area 
on which the raised pool sits.

6.	 Change Layer Options to Show/Snap Others to see the entire site.

7.	 Make the sheet layer Sht-1 [3D Views] active. This sheet contains 4 
viewports of different parts of the site. Creating a site model gives a 
much more accurate depiction of your design intent.

8.	 Make Sht-2 [Plan View] the active layer. The Site Model is a hybrid 
object and in Top/Plan view forms the base for the design drawing. It 
also displays the proposed contours for the scheme.

Summary
That’s the end of this introduction to working with slopes. It really is intended as a starting point only, but you can see from the demonstration file that a 
site model plays host to the design elements, and site modifiers are used to adjust the surface of the model to accommodate the design elements. You 
can find more information about working with tools that can adjust a site model, within the Vectorworks Service Select portal. To summarize, you’ve 
seen:

•	 How to create a Site Model from simple height points
•	 How Landmark design elements such as hardscapes and plants can be set to sit on the surface of the model
•	 An introductory awareness of the concept of site modifiers, which can change the surface of the model to accommodate a design.

I hope you’ve found it useful.

Next Steps
So, you’ve completed this tutorial and have seen some of the wonderful things that Vectorworks Landmark can do to become the backbone of your 
design practice. Of course, as the name of the guide suggests, you’ve only just started! So, what’s out there to help you move forward and look at 
Landmark in a lot more depth?

Vectorworks Help
1.	 Choose Help > Vectorworks Help. It will open in a separate window. 

Here you can search for full details on all the tools and menu 
commands to gain a much more in-depth knowledge of Vectorworks 
Landmark.

The Help menu also provides access to the following services where you 
will find further assistance and functionality to extend your use of 
Vectorworks:
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Vectorworks Service Select
Vectorworks Service Select is a valuable source of information, including 
tech-tips and longer tutorials. There are also many more resources 
available for use in your plans. Vectorworks Service Select is a 
subscription service.

Vectorworks Cloud Services
Vectorworks Cloud Services is available to members of Vectorworks 
Service Select. Store your Vectorworks documents in the Vectorworks 
Cloud Services folder on your computer and they will upload to the 
cloud. Sheet Layers will automatically be exported to PDF and any 
Viewports will be rendered in the cloud, freeing up your own computer 
for design work. Cloud rendering does require a Renderworks licence. 
Once PDF files have been produced in the cloud, you can share with 
your customers and colleagues. You can also view and annotate the 
sheets with the Vectorworks Nomad app which is available for a range of 
tablet devices, including iPad, Android and Kindle Fire HD.

Vectorworks Training Guides
If you like to learn at your own pace, or want a far more detailed guide to 
Vectorworks Landmark, you might find Tamsin Slatter’s  “Residential 
Garden Design with Vectorworks Landmark,” a good read. It’s also a 
great resource to have with you after a training course to give you a 
detailed overview of the landscape design process in Vectorworks 
Landmark. To find out more, please visit: 
www.vectorworks.net/training/guides.php

Further Training
Nemetschek Vectorworks, Inc offers training at its headquarters and at 
other locations. There is a wide range of classroom offerings and 
one-to-one options. There are also many specialist third party trainers to 
help you move forward with Vectorworks.

http://www.nemetschek.net/training/guides.php
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