BIM - ARCHITECTUAL

IMPORTING A SCANNED PLAN

INTRODUCTION

In this section, we will demonstrate importing a plan created in another application. One of the most common starting
points for a project is from a scanned-in, hand-drawn plan or an imported PDF or image. Importing a base plan from a
DWG file is also very common, this will be covered in another section.

The first step is to import the PDF or image. In this example, we will import an image file. There are multiple ways to
import an image file, and one of the easiest is to simply drag and drop the image file into your Vectorworks document.

This will start the Image Import command. The Image Import Options dialog will appear.
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Image Import Options

Image Information
Compression Method

File: Floor Plan Scan.png

Format: 32-bit, 1054 x 943, PNG image JPEG 70 KB

Uncompressed Size: 3883 KB o PNG 100 KB
Edit it Import As Black and White

Compression Method

O JrEG 70 KB
PNG 100 KB

Reference

L)

Reference

Cancel | LS

Cancel  \gCiSN

In this dialog, you will see information about the imported image as well as options for the compression method. JPEG
will reduce the size of the imported image at the cost of quality.

PNG will provide the best quality, but will be larger. In this case, we want the best quality, so we will choose PNG and click
OK. The import image will appear on the design layer as a Bitmap object.
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In this case, the image is rotated. To rotate this image to the desired angle, we can use the Rotate Right 90° command
found under Modify > Rotate.

As you can see, this command rotated the

noum o e image to correct angle. However, if the image
—_— was not exactly 90° off, we could use the
Rotate tool from the Basic palette to rotate the
image to any angle.

With the Rotate tool active and the Bitmap
object selected, you can use any object in the
image to align the base image. In this case,
we will use this wall. Just click once on the
edge of this wall. Then move the cursor down
along the edge of the wall and click a second
time to set the rotation axis. Finally, move the
BT cursor to the left or right to rotate the image
and click a final time to set the rotation.
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You would not want to use the Rotate Plan option
to rotate the image. This option is used to adjust
the rotation of your view to objects drawn at a

Y o
different angle. M| V000 B 20 Pian
When starting with an imported image or PDF, you
normally want to rotate the image to align with the ~ Joam  lo3sm
default plan rotation. ?

The next step is to check the overall size of the import image or PDF. In this case, the imported image is less than 0.25
meters across. This indicates the imported image showing a scaled representation of the plan. We need to scale the
image so the objects measure correctly.
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We will use the Scale Objects command found in the Modify menu increase size of this image. First, we need to find an
object in this image to use as reference when scaling. In this case, the imported image has a scale bar. This makes it very
easy, because we know this distance between the start and end of the scale bar is exactly two meters. If you import a
plan that does not have scale bar or other exact dimension to use as a reference, you can use any object that normally
has a standard length, such as the width of a wall or a door.
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Under the Modify menu, choose Scale Objects. This will bring up the Scale Objects dialog. Here we can use the
Symmetric By Distance option to measure two points on the image. Just click the dimension icon to the left of the Current

Distance field.
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The Scale Object dialog will disappear to allow you to click on the

two points to measure. If we zoom in on the scale bar, we click L "
once at the start and once at the end of the bar. ot

The Scale Objects dialog will reappear. You can see the Current

Distance field now shows a value of 0.024 meters. We know the 0 1 2

length should be two meters, so just enter this in the New Distance

field.
meters

Before clicking OK, notice the two options at the bottom of this dialog: Scale Text and Entire Drawing. The Scale Text
option controls whether this scaling operation will also scale text objects.

If there are existing text objects, this may be desired to maintain the size of the text objects compared to the other objects
that are being scaled. The Entire Drawing option lets you choose to scale all objects in the file, not just the selected Bitmap
image. This will include all resources, as well. Normally, you will have this option disabled. In this case, the only object in
the file is the image, so neither of these options are needed. However, if you did have other objects, you may want to
enable one or both of these options depending on your needs.

Scale text
Entire drawing

Enter a new distance to determine how the objects are scaled.
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After clicking OK, it may appear that the Bitmap image has disappeared. This is not the case. The Bitmap is now much

larger than before. If we zoom out, the image will reappear.
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Now is a good time to check the design layer scale. If you right-click in a blank area and choose Design Layer Scale, you

will see that the scale is currently set to 1:1.

Layer Scale

Imperial Metric/Engineering
132" 12" 1" =10’ 01 110 1:200
116" 3/4" 1" =20 1:2 1:20 1:500
1/8" 1" 1" =30 1:4 1:256 1:1000
316" 1-1/2" 1" = 40' 1:5 1:50 1:5000
14" 2" 1" = 50' 1:8 1:100 1:10000
3/8" Gy 1" = 100"

Enlargement Paper Scale
2x 6x 20x + [
3x 8x 50x
ax 10x 100x All Layers
5x 15x 500x Scale Text

Cancel | (gl

A 1:50 scale will be a better scale for an image of this size.
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Layer Scale

Metric/Engineering

Click OK to accept these value and scale layer.
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Let’s check the size of objects in this image. If we measure the width of this dining room for instance, we can see that it
measures 6.738 meters, but the drawing indicates it should be 6.51 meters. The accuracy of the scaling operation
depends on a few things. First, the quality of the imported image or PDF. The lower quality the image, the less accurate
the measurement will be. Also, when measuring the desired distance during the Symmetric By Distance operation, the
more accurate your clicks are, the better.

Importing a Scanned Plan.vwx
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In this case, let’s try to get the image a little closer to actual size. With the Bitmap selected, we can run the Scale Objects
command again. This time we will measure the width of the dining room and set the New Distance to 6.51 meters.

Scale Objects
Symmetric
X, Y, Z Factor:

° Symmetric By Distance
Current Distance: 6.721m =i

New Distance: 6.51m|
Asymmetric

X Scaling Factor:

Y Scaling Factor:

Scale text
Entire drawing

Press OK to scale the selected objects.
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Now, if we measure this distance again, it is much
closer to the reported width.
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If the imported image or PDF was scanned or exported in way where the resulting file was asymmetrically scaled or
skewed, you may find that measuring objects horizontally is accurate, while measuring vertically is not. This is more
common with scanned-in, hand-drawn plans. In these cases, you may need to use the Asymmetric Scaling option.

INTW LoLalive.

o Asymmetric
X Scaling Factor: 1

Y Scaling Factor: 1

We now have an imported image scaled to actual size. We are ready to start tracing the image to create these objects in
our file. To start, you will normally want to create the walls first. To do this, we can use several methods. We will discuss
the Wall tool and its various modes in more detail in another section. In this section, we are going to show a few
techniques that will speed up the process of tracing walls from an imported plan.
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Initially, you may want to simply use the Wall tool and trace each of the walls individually. We can activate the Wall tool in
the Building Shell tool set, choose the needed mode, and start tracing. In this case we'll use the Left Control Line mode to
trace the exterior walls. Drawing in a clockwise direction, we can align the left line of the wall being drawn with the exterior

line of the wall in the image.
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Tracing each individual wall like this can be time consuming. There are a couple of faster methods. For these interior
walls, they are all basically rectangular in shape.
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We can use the Rectangle tool to trace each of these rooms and then convert the rectangles to walls. Take the family
room for example, if we activate the Rectangle tool in the Basic palette, then we can trace the interior edge of these walls
using the Corner to Corner mode.
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With this rectangle selected, go to AEC > Create Objects from Shapes. Here we can set the Object Type to Walls and the
Offset to Left. The Offset option is the key. This tells the command which direction to offset the created wall. Since we
traced the interior, or right side of the wall, we need to offset to the left.

[ ] Create Objects from Shapes

Object Type: Walls [T
Offset: Left [T
Custom Offset:
Delete Source Shapes
Cancel | (SN

Atter clicking OK, you will see that four walls were created. This does lead to an issue with this method. The Create
Objects from Shapes command simply converts the selected shapes into Wall objects. It does not know we already drew
a wall on one side of this room.
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This extra wall will need to be deleted and the two horizontal walls will need to be joined to the exterior wall. A way to
avoid this issue is to use the Rectangle mode of the Wall tool instead of the Convert Objects to Shapes command.
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This mode will allow you to quickly trace the rectangular interior rooms and create only the needed walls. This mode
works just like the Rectangle tool; the only difference is that the Control Line mode set for the Wall tool determines
whether we trace the exterior or interior wall lines. In this case the Left Control Line mode is still active, so we will trace

the exterior line of these walls.

As we create these walls, they automatically join to existing walls and do not create duplicate, overlapping walls. Using
these methods, you can quickly trace all of the walls in this imported plan.
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There are a few more techniques that will make the process of tracing these walls much easier. First, you will normally
want to place your imported image or PDF on a separate design layer.
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This will allow you to keep the objects you create separate from the imported plan. It also helps avoid accidentally moving
the imported image or PDF while tracing overtop of it. You can set your Layer Option in the View menu to Show/Snap
Others.

® Vectorworks File Edit Modify Model AEC Tools Text Window Cloud Help

2017, Zoom

{ 5

* Importing a ass pons | — —
{ LayerOptons  » [0 —

<t Ug Gray Others <4 D EDQ& Q. B 1

Standard Views
PPy Projection Gray/Snap Others X85
Show Others 386

Rendering
@ |2\ Renderworks Style Show/Snap Others 37 lo Jom
Camera Match + Show/Snap/Modify Others X 369

Project Sharing Options

Vectorworks Designer Importing a Scanned Plan.vwx

&

MYy v

o

YYVYVYYY

gOhOPL

Look at Working Plane

>
=

Tem

Set Lighting Options... o O
Set Renderworks Background...

i OFE D0 %G

J>Grgosne
o)

B YNEO®BO /=7

Set 3D View #0
o Rotate 3D View...
% Attributes Rotate Plan E

G W soid BJ | g

- ~

DINING
Align Layer Views 651x3.75m
v Unified View 8L
Unified View Options...
2 @ None ¢
Create Viewport... o
Create Detail Viewport... LIVING
Create Section Viewport... sanseem | N
= Create Interior Elevation Viewport...
Drop Sha... [Of... Create Multiple Viewports... 0 8M
000 B Update Selected Viewports
: Update All Viewports

100%/100%

5m

- B

- X FAMILY

= Save View... 3.69x5.74m
3;"‘“;'1"9 @< | Next View %

Ll b Previous View 0%,

B | S| O | Q F

Clip Cube

om

* Tool Sets

2 wan Show >
& Round wall

BEDROOM

aeoxe2zm

om



This will allow you to see the imported image or PDF on the other design layer but not select it. You will want the design
layer with the imported plan to be stacked below the Layer you are drawing the walls on. The Stacking Order can be
edited in the Organization dialog, found in the Tools menu.
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You can also lock the Bitmap or PDF by right-clicking on the object and choosing Lock. This will prevent you from moving
the object inadvertently.
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Finally, a great way to still see what you are tracing overtop of is to give the design layer you are drawing the walls on an
opacity. If you right click on the layer in the Navigation palette and choose Edit, you can adjust the Layer Opacity, allowing
you to see through the walls to the plan below. This makes it easy to place doors and windows once the walls are
complete.
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