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GETTING STARTED WITH VECTORWORKS FUNDAMENTALS

Initial Setup
To ensure consistency when doing these exercises, please take a 
moment to set up your Workspace and Vectorworks Preferences. 
This way, we can start with the same base line. 

1. Go to Tools > Workspaces > Fundamentals.

2. Go to tools > Options > Vectorworks Preferences and click 
the Reset button. Accept the “Are you sure…?” dialogue box. 

3. Now we’ll adjust the constraints categories. Go to Tools > 
SmartCursor Settings.

4. Dismiss the “Did you know…?” dialogue box, and click the 
Reset button. Accept the “Are you sure…?” dialogue box, and 
select General in the Category list on the left.

5. Uncheck Snap to Combined Page Area.

6. Click OK to close the SmartCursor setting dialogue box.

Document Setup
1. First, open a new blank document by going to File > New. 

2. Choose Create Blank Document and click OK.

3. Next, go to File > Page Setup, uncheck the option Show Page  
Boundary, and click OK to close the Page Setup dialogue box .

4. Go to File > Document Settings > Units.

5. Choose Meters from the Units pop up menu under Length. 

6. Under Rounding Precision, set the Decimal Precision to .001.

7. Now under Area, choose Square Meters from the Units pop up 
menu.

8. Finally, set the Volume Units to Cubic Meters and click OK.

9. To change the design layer scale, right-click (Windows) or Ctrl-
click (Macintosh), in a blank area of the drawing area.

10. Choose Active Layer Scale from the menu.

11. Set the Scale to 1:100 and click OK.

Concrete base and Bowl
In this guide, will will create a Skatepark. Using various tools and 
commands available with Vectorworks Fundamentals, we will 
create the park, stairs, multiple obstacles, and a gazebo. Then 
we will create viewports and place them on sheet layer to present 
the model.

Creating the Bowl Shape
Now that the file is set up, we will create the shapes for the 
concrete base and bowl of the skatepark. We will use the 
Rectangle and Circle tools to create the Bowl.

1. In the Basic palette, double-click the Rectangle tool. This will 
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open the Create Object dialogue box.

2. In the Create Object dialog, set the Width to 12.5 and the 
Height to 21.65.

3. Make sure Position at Next Click is checked and click OK.

4. Since Position at Next Click was checked, you will need to 
click somewhere near the origin (0,0) to create the rectangle.

5. In the Basic palette, click on the Circle tool.

6. Make sure the 1st mode, Radius mode is enabled in the tool 
bar.

7. Place your cursor over the top left corner of the rectangle. 
When you see the “Top Left” SmartCursor cue, click once and 
move the cursor up and to the left.

8. Press the Tab key to activate the Floating Data bar. Enter 5.75 
for the Length (L) field and press Enter or Return twice to 
place the circle.

9. Now place another circle on the bottom right corner. The 
Circle tool should still be active, so move your cursor over the 
bottom right corner of the rectangle. When the “Bottom Right” 
SmartCursor cue is displayed, click once, then move your 
cursor down and to the right.

10. Press the Tab key to activate the Floating Data bar, enter 
7.375 for the Length (L) field, and press Enter or Return twice 
to place the circle.

Next, using the Add Surface command we will combine these 
objects into one polyline.

11. Press the X key once to activate the Selection tool in the 
Basic palette.

12. Select the rectangle and the two circles by holding the Shift 
key and clicking once on each object. 

Note:  If the last Circle you created is already selected, you do 
not need to click on it again.

13. With all three objects select Right-click (Windows) or Ctrl-click 
(Macintosh) on the selected objects and choose Add Surface. 
The three objects will be combined into a single polyline object.

Now, we will fillet the corners of the bowl. The Fillet tool will allow 
us to reshape this polyline and change the corner vertices to 
curves.

14. In the Basic palette, activate the Fillet tool, in the Tool bar, 
switch to the 3rd mode, Trim mode and enter 1.4 for the Fillet 
Radius.

15. Move your cursor over the top left of the polyline. The curved 
segment of the polyline will highlight in red, click once, and 
move your cursor over the top horizontal segment of the 
polyline. This segment will highlight in red as well, click once 
more to fillet the corner.

16. Repeat this action for the corner of the top left curved 
segment and the left vertical segment, by clicking once on the 
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top left `curved segment and once on the left vertical segment.

17. Finally, click once on the bottom horizontal segment and then 
once on the bottom right curved segment, to fillet this corner as 
well.

18. Next, in the tool bar, change the Fillet Radius to 2.

19. Click once on the left vertical segment and once on the 
bottom horizontal segment to fillet the corner.

20. Now using the same fillet radius, click once on the right 
vertical segment and then once on the bottom curved segment 
to fillet this corner. 

21. Finally, change the Fillet Radius in the tool bar to 2.75, click 
once on the top horizontal segment and then once on the right 
vertical segment to fillet the last corner.

Using the Offset tool, we will create a larger offset polyline.

22. In the Basic palette, activate the Offset tool.

23. In the tool bar, enable the Offset by Distance and Duplicate 
and Offset modes and enter 4 in the Distance field.

24. Click once outside of the polyline. A new offset polyline will be 
created on top of the original polyline.

25. Now, with the new polyline selected, go to Modify > Send > 
Send to Back. The original polyline will now be visible above 
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the new offset polyline.

Next, we will use the Polygon tool to create more of the concrete 
base.

26. Activate the Polygon tool in the Basic palette.

27. In the Tool bar, make sure Vertex mode is enabled.

28. Move your cursor over the midpoint of the top left curved 
segment of the outer polyline and click once the “Midpoint” 
SmartCursor Cue is displayed, to start the polygon.

29. Move your cursor to the left horizontally and press the Tab 
key to activate the Floating Data bar.

30. Enter 21.5 for the Length (L) and press Tab to lock the 
Length field. Move your cursor to the left until the “Horizontal / 
Length” SmartCursor Cue is displayed. Click once to start the 
next segment.

31. Move the cursor down and to the left. Press the Tab key to 
enter the Floating Data bar, enter 9 for the Length (L), press 
Tab again, enter -135º for the Angle (A), and press Tab once 
more to lock the Angle field.

32. When the SmartCursor Cue “Angle / Length “is displayed, 
click once to start the next segment.

33. Press Tab again to activate the Floating Data bar, enter 10.5 
for the Length (L) field, press Tab, enter 135º for the Angle (A) 
field, and press Tab again to lock the Angle field.

34. When the SmartCursor Cue “Angle / Length” is displayed, 
click once to start the next segment.

35. Repeat the same process above for the next segment. For 
this segment enter 27 for the Length (L) field and -135º for the 
Angle (A) field.

36. Repeat the process again, this time enter 50 for the Length 
and -45º for the Angle.

37. For the next segment, enter 22 for the Length and 40º for the 
Angle.

38. Finally to complete the polygon, move the cursor to the right 
horizontally until it intersects the outer polyline. Double-click to 
to complete the polygon when the SmartCursor Cue, “Object / 
Horizontal” is displayed.

39. Select both the new polygon object and the outer polyline 
object by holding the Shift key and clicking on both objects. 
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Right-click (Windows) or Ctrl-click (Macintosh) on the objects 
and choose Add Surface to combine the objects into one 
polyline.

Fillet Corners of Concrete base
Using the same procedure as shown previously, use the Fillet tool 
to adjust the corner vertices of the concrete base polyline.

1. Activate the Fillet tool in the Basic palette.

2. Enable the 3rd mode, Trim mode and set the Fillet Radius to 
6.25.

3. Move your cursor over the top horizontal segment of the 
polyline. When the segment highlights in red, click once.

4. Move the cursor over the left adjacent segment and click once 
more to fillet the corner.

5. Using the image below use the Fillet tool with shown Radius 
settings to fillet 6 more corners. 

Extruding the Concrete base
Using the Push/Pull tool, we will extrude the concrete base 
polygon and then use the Sub Face mode of the Push/Pull tool 
with the Line and Polyline tools, to create stepped surfaces.

1. In the View bar, go to the Standard views menu and choose 
Right Isometric

2. Open the 3D modeling tool set and activate the Push/Pull tool.

3. Enable the 1st mode, Extrude Face mode in the tool bar.

4. Move your cursor inside the larger outer polyline. The face will 
highlight in red. Click once and move the cursor vertically.

5. Press the Tab key to activate the Floating Data bar, enter 3 in 
the Distance field, and press Enter or Return twice.

6. Open the Standard views menu in the View bar and switch to 
Top view.

7. Activate the Polyline tool in the Basic palette and enable the 
1st mode, Corner Vertex mode.

8. Make sure Automatic is set in the Plane menu in the View bar.

9. Move the cursor on top of the extrude. The top surface will 
highlight in blue. Click once on the left corner of the bottom 
horizontal segment to start the polyline.
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10. Move the cursor across the top of the extrude until it 
intersects the opposite side. When the SmartCursor Cue 
“Object / Y” is displayed, double-click to create the polyline.

11. Switch to a Left Isometric view, through the Standard views 
menu in the View bar. You will see the polyline was drawn on 
the top surface of the extrude.

12. Activate the Push/Pull tool in the 3D modeling tool set. 
Enable the 3rd mode, Sub-Face mode.

13. Place the cursor over the polyline you just drew, it will 
highlight in red. Click once.

14. Move the cursor over the extrude, it will also highlight in red. 
Click again.

15. Move the cursor over the left side of the extrude, the left side 
will highlight in red. Click once more and move the cursor 
down.

16. Press the Tab key to activate the Floating Data bar and enter 
-1.5 in the Distance field. Press Enter or Return twice to move 
the face. The object is now a generic solid.

17. Switch back to a Top view using the Standard views menu in 
the View bar.

18. Activate the Polyline tool in the Basic palette and switch to 
the Point on Arc mode in the Tool bar.

19. Draw a curved polyline to the left of the vertical line we drew 
previously. Click once at the top of the concrete base. Move 

the cursor down and slightly to the left, about a one third the 
way across the concrete case. Click once. 

20. Move the cursor about two thirds the way across the concrete 
base and slightly to the right. Click once more. 

21. Move the cursor down about half to the bottom edge of the 
concrete base and little more to the right. Click again.

22. Finally, move the cursor down and to the left, until you 
intersect the bottom edge of the concrete base. Then double-
click to complete the polyline. Your polyline should appear 
similar the image below.
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23. Switch back to the Left Isometric view and activate the Push/
Pull tool, with the Sub-Face mode active.

24. Click once on the curved polyline. Move your cursor to the 
left and click once on the concrete base, and then click on the 
bottom left face of the concrete base.

25. Finally, move the cursor down, press Tab, enter -1.2 in the 
Distance field, and press Enter or Return twice to move the 
face of the concrete base.

Creating Skatepark Levels
We will now use the Taper Face and Fillet Edge tools from the 3D 
Modeling tool set, to create sloped and curved surfaces.

1. In the 3D Modeling tool set activate the Taper Face tool.

First, we need to set the reference plane, this plane will be used 
to determine the pivot point for the Taper operation. 

2. With the 1st mode, Tangent Faces mode enabled in the Tool 
bar, move your cursor over the upper most surface of the 
generic solid, the surface will highlight in red. Click once.

3. Now, let’s select the face to taper, move the cursor over the 
adjacent vertical surface, the surface will highlight in red. Click 
again.

4. Finally, move the cursor out to set the angle of the taper. The 
Taper Angle should be about -66º. Click once more to 

complete the action.

5. Activate the Fillet Edge tool in the 3D modeling tool set. In the 
Tool bar click on the Fillet Edge Tool Preferences button.

6. In the Fillet Edge Preferences dialog, check Select Tangent 
Entities, enable Constant Radius mode, and set the Radius 
to 4. Click OK.

7. Select the edge that intersects the bottom most face with the 
adjacent vertical face, it will highlight in red. Hold the Shift key 
to select both segments. Click the green check mark button in 
the Tool bar to complete the action. The generic solid is now a 
fillet object.

Adjusting Rendering Settings
You may notice that the curved portions of the generic solid 
appear segmented. This is because, by default the detail level for 
the OpenGL render mode is set to low. Next, we will adjust these 
settings.

1. Go to the Render modes menu in the View bar. Make sure 
OpenGL is active and select OpenGL Options at the bottom.

2. In the OpenGL Options dialog, set the Detail to Very High.

3. Click OK and Vectorworks will re-render the object. The curved 
portions are no longer segmented.
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Subtracting the Bowl from the Concrete base
Next, we will use the Extrude and Subtract Solids command to 
carve out the bowl from the concrete base. Then, we will use 
the Fillet Edge tool to curve the inside face. First, we will use the 
original polyline we drew to create an extrude to subtract from the 
concrete base (fillet object).

1. To select the polyline, activate the Selection tool in the Basic 
palette.

2. Press and hold the B key on your keyboard to activate the 
X-Ray Select mode. This mode allows you to see through and 
select object beneath other objects.

3. Move your cursor over the polyline and select it. 

4. With the polyline selected, go to Modify > Move > Move 3D.

5. Set the Z Offset to 3 and click OK. The polyline is now on the 
surface of the concrete base.

6. With the polyline still selected, go to Model > Extrude.

7. Set the Extrusion to -2.5 and click OK.

8. Holding the Shift key, select both the extrude and concrete 
base, go to Model > Subtract Solids. In the Select Object 
dialog, use the Back and Front toggle buttons to highlight the 
concrete base (fillet object) and click OK. 

The extrude is removed from the concrete base. We now has a 
solid subtraction object.

9. Activate the Fillet Edge tool in the 3D Modeling tool set.

10. Click on the bottom edge of the subtracted area, it will 
highlight in red. Set the Constant Radius to 2.5 in the Tool bar 
and click the green check mark button to complete the action.

Applying Attributes
With the concrete base geometry complete, we will now give it 
a fill color using the Attributes palette. Then, we will place it in a 
new class.

1. With the concrete base (fillet object) selected, set the Fill Color 
to Gray 30% from the Standard Vectorworks Colors in the 
Attributes palette.

2. Next, click on the Classes button in the View bar. In the 
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Organization dialog, click New to create a new class.

3. Name the class Concrete base, uncheck Edit Properties After 
Creation, and click OK.

4. Finally, with the concrete base selected, go to the Object Info 
palette, and change the Class drop down menu to Concrete 
base.

Stairs
In this section, we will create a simple stair object and place it 
between the upper and middle levels of the concrete base. First, 
we will create a new class for the stairs.

1. Click on the Classes button in the View bar.

2. In the Organization dialog, click New.

3. Name the class Stairs and click OK.

4. Make the Stairs class the active class, by clicking in the Active 
Class column, to the left of the Class name in the Organization 
dialog. A check mark will appear.

5. Click OK to save the changes and exit the Organization dialog.

6. In the Standard Views menu in the View bar, select Top/Plan.

7. Switch to the Walls tool set and activate the Simple Stair tool.

8. Move your cursor over the concrete base, you will see a 
preview of the simple stair object. Move your cursor to left 
edge of the tapered face between the upper and mid level of 
the concrete base. Click once towards the bottom of the 
concrete base, then move your cursor to the right, and click 
once more to set the rotation.

9. In the Object Properties dialog, set the following values. Leave 
all other values default.

•	 Style: Masonry

•	 Width: 6

•	 Flr-Flr Height: 1.5

•	 Max Riser: 0.2

•	 Tread Depth: 0.45

10. Check Draw Top Tread

11. Click OK to place the simple stair object.

Next, we will use a floating datum to position the simple stair 
object. Then adjust its elevation.

12. Click and hold on the bottom right corner of the simple stair 
object. Drag the object to the intersection of the right edge of 
the tapered face and the bottom of the concrete base. 

13. Continue to hold down left mouse button, when the 
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SmartCursor Cue “Endpoint” is displayed, press the G key on 
the keyboard to place a floating datum. 

14. Press the Tab key to activate the Floating Data bar. You can 
now release the mouse button. Enter 3.5 in the Length (L) 
field.

15. Press Tab once to set the length and then move the cursor up 
vertically until you intersect the length constraint represented 
by the dashed red circle. When the SmartCursor Cue “Vertical / 
Length” is displayed, click once to move the stairs.

16. Now switch to a Left Isometric view, by using the Standard 
views menu in the View bar. You will see the stairs are below 
the surface of the concrete base.

17. With the simple stair still selected, in the Object Info palette, 
change the Z to 1.5. The Stairs will now be partially above the 
surface of the concrete base.

Finally, lets adjust the angle of the tapered face so that it matches 
the angle of the stairs.

18. In the 3D modeling tool set, activate the Taper Face tool.

19. Click on the upper surface of the concrete base to set the 
reference plane, then click on the tapered face to adjust the 
taper angle.

20. Snap the cursor to the bottom edge of the stairs and click 
once to adjust the angle of the face. (Screenshot Needed)

Duplicating the Stairs
Now that these stairs are complete, let’s duplicate and modify the 
stairs for the other side of the concrete base.

1. Switch back to a Top/Plan view

2. Press the X key to activate the Selection tool and select the 
stairs.

3. Click and drag the stairs vertically to the other side of the 
concrete base.

4. While still holding the left mouse button down, press and hold 
the Ctrl key (Windows) or Option key (Macintosh) on your 
keyboard. A small plus sign will be displayed next to your 
cursor.
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5. Keep the Ctrl (Windows) or Option (Macintosh) key pressed 
and release the mouse button to duplicate the stairs.

6. With the duplicated simple stair object selected, change the 
Width to 4.5 in the Object Info palette.

7. Next, click and drag the top right corner of the stairs until the 
cursor intersects the right edge of the tapered face and the top 
of the concrete base. 

8. While still holding down the left mouse button, press the G 
key to place a floating datum. Then press Tab to activate the 
Floating Data bar. You can now release the mouse button.

9. Enter 5 for the Length (L) field, press Tab, and then move 
the down vertically, until you intersect the length constraint 
represented by the dashed red circle. When the SmartCursor 
Cue “Object / Length” is displayed, click once to move the 
stairs.

10. Switch to a left isometric view to confirm the placement of the 
stairs.

We will now added the two stair objects to the concrete base 
object, using the Add Solids command.

11. Select both of the simple stair objects and the concrete base 
(generic solid) by holding the Shift key and clicking on each 
object. 

12. Go to Model > Add Solids. The stairs and the concrete base 
are now one solid addition object.

Creating Curved Stairs
Next, we will create a set of curved stairs, between the middle 
and lower faces of the concrete base.

1. Switch to a Top/Plan view.

2. Activate the Line tool in the Basic palette.

3. Now trace the segment line of the curved face. Click once at 
the intersection of the segment line and the left edge. Then 
click once more at the intersection of the segment and the right 
edge.

4. Switch to the Arc tool in the Basic palette. Enable the 2nd 
mode, Three Points mode.

5. Click once on the start point the line we just drew. Then, move 
the cursor down along the curve. When the SmartCursor Cue 
“Midpoint” is displayed, click again. Continue to move down 
along the curve, and click a final time at the end of the curve.
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6. Repeat this process for the curve on the right.

7. Using the same technique, draw one more arc connecting the 
bottom of the two arcs we just drew.

8. Select the three arcs and in the Attributes palette, set the Fill 
to None. You may need to use the B key to select the arc on 
the left. 

9. Now, to make these objects easier to work with, click on the 
Classes button in the View bar and set the Concrete Base 
class to invisible and click OK.

10. Select the arc on the left, activate the Offset tool in the Basic 
palette, enable the Offset by Distance and Duplicate and 
Offset modes, and set the Distance to 1.43.

11. Click once to the right of the arc on the left, to create an offset 
duplicate.

12. If the offset arc does not extend past the top line and bottom 
arc, switch the Selection tool, select the arc, click and drag the 
top and bottom arc end blue control handles to increase the 

sweep of the arc.

13. Next, activate the Polygon tool in the Basic palette. Enable 
the Inner Boundary mode in the Tool bar.

14. Click once in between the arc on the left and the offset arc. 
Then click once in between the offset arc and the arc on the 
right.

15. Select both of the polylines, we just created, go to Edit > Cut. 
This will remove the polylines temporarily.

16. Activate the Offset tool again and set the Distance to 0.715. 
Hold down the Alt key (Windows) or command key (Macintosh) 
and click the arc in the center.

17. Click once to the left of the selected arc.
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18. Hold down the Alt key (Windows) or command key 
(Macintosh) again to select the arc in the center again.

19. Click once to the right of the selected arc.

20. Now, switch to the Selection tool, select the arc in the center 
and press the Delete key to remove it.

21. Activate the Polygon tool in the Basic palette, with the Inner 
Boundary mode still enabled, click once in between the arcs 
we just created.

22. With only the newly created filled polyline selected, go to Edit 
> Invert Selection. This will select all other visible objects. 
Press the Delete key to removed these objects. Only the filled 
polyline should be be left.

23. Next, go to Edit > Paste in Place. This will paste the two 
filled polylines we used the Cut command to remove earlier. 
They will be placed the same location they were previously.

24. Press and hold the B key to activate the X-Ray Select mode. 
Select the polyline that is underneath the two polylines we just 
placed.

25. Go to Modify > Send > Send to Front.

26. Set the Concrete base class to visible, by going to the 
Classes button in the View bar, switching the Concrete base 
class to Visible in the Visibility column, and clicking OK.

27. Now, select only the left polyline, go to Model > Extrude, set 
the Extrusion to 0.4, and click OK.

28. Select the middle polyline, go to Model > Extrude, set the 
Extrusion to 0.8, and Click OK.

29. Finally, select the right polyline, go to Model > Extrude, set 
the Extrusion to 1.2, and Click OK.

30. Switch to a Left Isometric view, select all three extrudes, and 
go to Model > Add Solids.



18 | Vectorworks Fundamentals 2016 Getting Started Guide

31. Press and hold the B key to activate the X-Ray Select mode. 
Click and drag the top right corner of the stairs so that it 
intersects with the top edge of the curved face, the 
SmartCursor Cue “Object / Z” will be displayed.

32. Switch to a Left Rear Isometric view, activate the Push/Pull 
tool in the 3D Modeling tool set, and enable the 2nd mode, 
Move Face mode.

33. Move your cursor over the left face of the stairs, the face will 
highlight in red. Click once and move the face inward. When 
the Floating Data bar shows approximately -4, click once to 
complete the action.

34. With the stairs still selected, in the Object Info palette, set the 
Class drop down menu to Stairs.

35. Finally, set the Fill Color to the same Gray 30% as the 

concrete base in the Attributes palette.

Rails

Creating a Concrete Rail
In this section we will use the Extract tool to create a 3D path for 
a concrete rail. Then, we will create a profile object and use the 
Extrude Along Path command to create the rail.

1. Let’s start by creating a rails class. Click on the Classes button 
in the View bar and create a new class named Rails. Make the 
new Rails class the active class and click OK.

2. Switch to a Top/Plan view and activate the Extract Surface 
tool in the 3D Modeling tool set. 

3. Enable the Extract Curve mode, and select each edge while 
holding the Shift key as seen in the image below. Once all 
edges are selected, click the  green check mark button in the 
Tool bar to extract the NURBS curves.

4. The NURBS curves are grouped together. Go to Modify > 
Ungroup to ungroup the NURBS curves. 

5. With all of the NURBS curves selected, go to Modify > 
Compose.

6. Double-click on the Rectangle tool in the Basic palette.

7. Set the Width to 0.4 and the Height to 0.6. Make sure 
Position at Next Click is checked, and click OK.

8. Click in a blank area to place the rectangle.
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9. Select both the rectangle and the NURBS curve, go to Model 
> Extrude Along Path.

10. Use the arrows to set the NURBS curve as the path object, 
check the Lock Profile Plane option and click OK.

11. Double-click on the concrete rail (extrude along path) object, 
select to edit the Profile and click OK.

12. Move the rectangle so that the bottom right corner is at X and 
Y equal 0. Click Profile Exit in the top right corner of the 
screen.

Note: Depending on the curve you created, you may find that the 
extrude along path object, hangs over the edge of the slope. If 
this is the case, follow the steps below to adjust the length of the 
path.

13. Double-click on the extrude along path object, select to edit 
the Path and click OK.

14. Activate the Trim tool in the Basic palette and enable the 1st 
mode, Point Split mode.

15. Click along the path to split the NURBS curve. 

16. Switch to the Selection tool, select only the end segment and 
press delete.

17. Click Path Exit.

Now, let’s use the Taper Face tool to reshape the ends of the rail. 
The ends of the concrete rail come to an abrupt end, we will taper 
the ends for a better look.

18. Switch to a Left Isometric view and zoom in on the right end 
of the extrude along path.

19. Activate the Taper Face tool in the 3D Modeling tool set and 
enable the 1st mode, Tangent Face mode.

We need to use the bottom face of the concrete rail (extrude 
along path) object, as the reference face for the taper. 

20. Position the cursor over the end of the concrete rail (extrude 
along path) object. To select the sub face, hold the Alt key 
(Windows) or Option key (Macinstosh). When the bottom 
surface of the concrete rail highlights in red, click once to set 
the reference plane.
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21. Now set the taper face to the end face of the concrete rail. 
Move the to the right and set the Taper Angle to about 80º.

22. Repeat this action for the other end of the concrete rail.

Creating Handrails
We will create 3D handrails for the steps and slopes of the 
skatepark. Using the plane options in Vectorworks we will create 
base 2D objects and then use the Extrude Along Path and 
Extrude commands to convert these objects to 3D.

1. First, we need to change the projection setting. We are going 
to create 2D objects in a 3D view. This can be easier in an 
orthogonal projection. Go to View > Projection > Orthogonal.

2. Before we draw the path for the rail, we need to change the 
plane setting. In the View bar, select Screen from the Plane 
menu. This will draw 2D objects flat on the screen no matter 
what view is set.  

3. Now, switch to a Font view.

4. Set the Rails class to Invisible and make the None class the 
active class.

5. Zoom in on the stairs on the tapered face.

6. Next, let’s draw the path for the rail. Activate the Line tool 
in the Basic palette. Enable the Unconstrained and Vertex 
modes in the Tool bar.

We are going to trace the tapered face below the stairs. Place 
the cursor at the top step, where the top tread intersects with the 
upper level of the concrete base.

7. Click once to start the polygon. Move the cursor down and to 

the left along the tapered face.

8. Click once more at the intersection of the bottom step and the 
concrete base, to complete the line.

9. Now we need to move the line up. With the object selected, in 
the Y field in the Object Info palette, simply type + 1 to the right 
of the current value and press Enter or Return. 

In most numerical fields, you can perform arithmetic. Vectorworks 
will calculate the values automatically. 

10. Next, let’s extend the rail at top of the stairs. With the Line 
tool still active, click once at the top endpoint of the line we just 
moved. 

11. Move the cursor to the right, press the Tab key to enter the 
Floating Data bar, set the Length (L) to 1.25 and press Enter 
or Return twice to complete the operation.

12. Select both line objects and go to Modify > Compose.You 
now have your path (polygon) object.

13. Let’s use the Rectangle tool in the Basic palette to create a 
profile object for the railing. Double-click on the Rectangle tool 
and set the Width and Height to 0.1 and click OK.
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14. Click once below the path object to place the profile 
(rectangle).

Before using the Extrude Along Path command to create the 3D 
rail, we need to change the plane of the path (polygon) object. 

15. In the Object Info palette, change the Plane to Layer. This 
will project the object onto a 3D plane that is aligned with our 
current Front view.

16. Select the both the path object and the profile object and go 
to Model > Extrude Along Path.

17. Use the Next and Previous buttons to make sure the path 
object is highlighted in red. Make sure both Lock Profile Plane 
and Fix Profile are unchecked, and click OK.

18. Now, switch to a Top/Plan view. You will see the rail (extrude 
along path) object is not in the correct position. 

19. Click and drag the rail down over the stairs. As you move the 
rail down, you will see a dotted green extension line appear 
and the “Vertical” SmartCursor cue will be visible. Use this line 
to maintain the X coordinate of the rail.

20.  Move the cursor over the midpoint of the top step. After a few 
seconds a red box will appear indicating that a smart point has 
been set.

21. Move the cursor to right along the horizontal dotted red 
extension line until you intersect the vertical dotted green 
extension line. When SmartCursor Cue “Vertical / Align V” is 
displayed, release the mouse button to place the rail.

Note: The Smart Point used to align the rail in the section is 
controlled by the Smart Points Snap option. This and all other 
Snapping options are controlled through the Snapping palette. If 
this Snap option is disabled, you will not be able to set a Smart 

Point. Also, if you do not see the extension lines mentioned in the 
steps above, go to tools > SmartCursor Settings and ensure that 
both Horizontal/Vertical Extensions and extension lines are 
enabled for the Smart Points.

22. Now we will create posts for the rail. Using the Extrude 
command and snapping functions, we will create and place the 
posts along the rail.

23. First, we will the base shape for the posts. Double-click on the 
Rectangle tool. In the Object Settings dialog, set the control 
point mode to the center point and click OK.

24. Place the cursor over the midpoint of the right end of the rail. 
After a few seconds a red box will appear, indicating that a 
Smart Point has been set.

25. Move the cursor to the left, a marker will appear indicating the 
center of the upper segment of the rail. The SmartCursor Cue 
“Center” will display. After a few seconds a second Smart Point 
will appear.

26. Move the cursor back to the right, a marker indicating the 
midpoint between the two Smart Points will appear. Place the 
cursor over this point, when the SmartCursor Cue “Midpoint” is 
displayed, click once to place the rectangle.



22 | Vectorworks Fundamentals 2016 Getting Started Guide

27. Now let’s extrude the rectangle. With the rectangle selected, 
go to Model > Extrude.

28. Set the Extrusion to 1 and click OK.

29. Switch to a Front view. You will see the extrude is below the 
surface of the concrete base. 

30. Press the B key to activate the X-Ray Select mode. Click and 
drag the bottom of the extrude and snap it to the top of the 
concrete base.

31. The post (extrude) extends slightly inside the rail. Click and 
drag the rail upward and snap the bottom of the rail to the top 
of the post.

32. Move and duplicate the post, so that the midpoint of the base 

of the duplicated post intersects the start of the first step. Hold 
down the Alt key (Windows) or Option key (Macintosh) to 
duplicate the post while moving it.

33. Place two more duplicates on the fourth step down and the 
last step. Snap the base of the posts to the midpoint of the top 
of the steps. 

34. We need to shorten the two posts on the stairs. Select one of 
the posts on the stairs. Place the cursor over the top middle 
blue control handle, and click once and move the cursor down 
vertically until the top of the post is completely within the rail. 
Click once more to move the control point and adjust the height 
of the post.

35. Repeat this action for the other post on the stairs.
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Next, we will use the Add Solids command to combine the rail 
and the posts into a single object and then apply a fill color 
through the Attributes palette.

36. First, switch to a Left Isometric view.

37. Select the four posts and the rail.

38. Go to Model > Add Solids.

39. With the rail (solid addition) selected, in the Attributes palette, 
set the Fill Color to black.

40. Now, let’s place the completed rail in the Rails class. With 
the rail selected, in the Object Info palette, click on the Class 
menu, and choose Rails.

You will notice that the rail disappeared. This is because the rails 
class is currently set to Invisible. 

41. Click on the Classes button in the View bar, set the Rails 
class to Visible, and click OK.

Note:  You can use the same workflow to create other rails in the 
file. If you would like to, use the techniques described above to 
create two more rails. One in the center of the tapered face and 
the other on the curved stairs.

Creating a Long Rail
We will create a long rail using the Extrude command and the 
Push/Pull tool. Also, we will use the Automatic Working Plane 
feature to quickly draw the objects in a 3D view.

1. Make sure you are in a Left Isometric view. Then, activate the 
Rectangle tool in the Basic palette and enable the1st mode, 
Corner to Corner mode.

2. Switch the plane mode back to Automatic in the Plane menu 
in the View bar. This will allow us to draw directly on the plane 
of the concrete base.

3. Click in the center of the middle level of the concrete base, to 
start the rectangle.

4. Tab into the Floating Data bar, set the Delta X (ΔX) to 3.25 and 
the Delta Y (ΔY) to 0.15, press Enter or Return twice to place 
the rectangle.

5. With the rectangle selected, go to Model > Extrude, set the 
Extrusion to 0.05, and click OK.

6. In the Object Info palette, set the Bot Z to 2. This extrude will 
be the top of the long rail.

Using the Automatic Working Plane feature, along with the 
Subtract Solids command, we will create a base for the long rail.

7. Activate the Rectangle tool again and click middle level of the 
concrete base to start drawing another rectangle. In the 
Floating Data bar enter 0.2 for the Delta X (ΔX) and the Delta 
Y (ΔY). Press Enter or Return twice to place the rectangle.
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8. With the rectangle selected, go to Model > Extrude, set the 
Extrusion to 0.05, and press OK. This extrude will become the 
base for the rail posts.

Next, we will use the Circle tool and the Subtract Solids command 
to create bolt holes in the base. 

9. Activate the Circle tool in the Basic palette and enable the 1st 
mode, Radius mode.

10. Place the cursor on the left corner of the base (extrude), 
make sure the top surface of the base is highlighted in blue, 
and press the G key to place a datum

11. Tab into the Floating Data bar. Set the Length (L) to 0.045 
and the Working Plane Angle (WP A) to -45º. Press Enter or 
Return and move the cursor to the right.

12. When the SmartCursor Cue “Object / Angle / Length” is 
displayed, click once to start the circle.

13. Tab into the Floating Data bar, set the Length (L) to 0.01 and 
press Enter or Return twice to place the circle.

14. With the circle selected, activate the Mirror tool in the Basic 
palette. Enable the 2nd mode, Duplicate mode. 

15. We need to draw a mirror Line across the base. Click once at 
the midpoint of the bottom left edge of the base. Move the 
cursor across the base object, a preview of the duplicate circle 

will appear. Make sure the Working Plane Angle (WP A) 
shows 0.00 and click once more to mirror and duplicate the 
circle.

16. Select both circles and repeat the mirror process, by clicking 
once at the midpoint of the top left edge and moving the mouse 
across the base. The Working Plane Angle (WP A) will show 
-90º.

17. Now we will use these circles subtract holes from the base. 
Select all of the circles, go to Modify > Extrude, and set the 
Extrusion to -0.05.

18. Now we will use these circles to subtract holes from the base. 
Select all of the circles, go to Model > Extrude, and set the 
Extrusion to -0.05.

19. Hold Shift and select the base to add it to the selection. The 
four circular extrudes and the base should be selected. Go to 
Model > Subtract Solids.

Next, we will continue to use the Automatic Working Plane and 
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use the Automatic Push/Pull feature to create an extrude for the 
post.

20. Activate the Rectangle tool in the Basic palette, enable the 
2nd mode, Center to Corner mode, click once on the top 
center of the base.

21. Tab into the Floating Data bar, set the Delta X (ΔX) and the 
Delta Y (ΔY) to 0.05. Press Enter or Return twice to place the 
rectangle.

22. Without clicking, move the cursor over the rectangle, it will 
highlight in red. The Red highlight indicates that the Automatic 
Push/Pull mode is activate.

23. Click once and move the cursor up. Tab into the Floating Data 
bar and enter 0.45 for the Distance. Press Enter or Return 
twice to extrude the rectangle.

24. Zoom out to see the whole object.

25. Select both the base and the post (extrude), go to Model > 
Add Solids.

26. Switch to a Top/Plan view.

27. Click and drag the center of the post to the midpoint of the left 
side of the rail. While still holding the mouse button, press the 
G key to place a datum.

28. Press Tab to enter the Floating Data bar. You can now release 
the mouse button. Enter 0.5 for the Length (L). Press Enter or 
Return twice to place the post.

29. Now let’s place two duplicates of the post. With the post still 
selected, activate the Mirror tool in the Basic palette and make 
sure Duplicate mode is enabled.

30. Move your cursor to the center of the rail. When the 
SmartCursor Cue “Center” is displayed, click once and move 
the cursor up vertically. Click once to mirror and duplicate the 
post.

31. Click and drag the center point of the new post to the center 
of the rail. Press and hold the Alt key (Windows) or Option key 
(Macintosh), then release the mouse button to place a 
duplicate post.

Creating a Symbol
For the long rail, we need to apply a separate fill color to the 
rail and the posts. So we will not combine the objects into a 
single object using the Add Solid command. Instead we will use 
the Create Symbol command to group the objects in a symbol 
resource.

1. First, select rail and set the Fill Color to Black in the Attributes 
palette.

2. Now, select the rail and the three posts.

3. Go to Modify > Create Symbol

4. In the Create Symbol dialog, name the symbol Long Rail, 
choose Next Mouse Click under Insertion Point, and click 
OK.

5. Click on the bottom midpoint of the center post to set the 
insertion point. The insertion point controls how the geometry 
will appear in relation to the mouse click. 
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6. In the Create Symbol dialog, click OK to save the symbol in 
this file.

Note:  The long rail is now saved as symbol resource. It can be 
accessed through the Resource Browser and placed multiple 
times.

7. In the Resource Browser, click the Home icon once to confirm 
you are looking at resources in the active document. Open the 
Resources menu under the Home icon and set the View As 
option to Thumbnails.

8. Scroll down in the Resource Display window and locate the 
Long Rail symbol, in the Symbols/Plug-In Objects section.

9. Place another instance of this symbol on the left side of the 
lower level of the skatepark.

10. Finally, select both of the long rail symbols and change their 
class to Rails, in the Object Info palette.

Creating a Curved rail
In this section, we will use the Extrude Along Path command to 
quickly create another rail. Then we will use the Deform tool, to 
reshape the object to create an S shaped curved rail.

1. Switch to a Font view.

2. Activate the Circle tool in the Basic palette.

3. Click once in the drawing area to start the circle and move the 
cursor to the right.

4. Tab into the Floating Databar, enter 0.1 for the Length (L), and 
press Enter or Return twice to create the circle.

5. Next, switch to Screen Plane in the Plane menu in the View 
bar.

6. Activate the Line tool in the Basic palette.

7. Click once in the drawing area to start the line and move the 
cursor to the right.

8. Tab into the Floating Data bar, enter 6.5 for the Length (L). 
When the SmartCursor cue “Horizontal” is displayed press 
Enter or Return twice to complete the Line.

9. Select both the circle and the line, go to Model > Extrude 
Along Path, using the Previous and Next buttons, make sure 
the Line is highlighted in red, and click OK.

Note:  The rail (extrude along path) object will be place on the 
default Layer Plane. This is because the path object was created 
on screen plane.

10. Using the Selection tool, click and drag the rail so that it is 
positioned above the concrete base of the skatepark.

11. Activate the Deform tool in the 3D Modeling tool set.

12. We want to bend a portion of this rail, so we need to enable 
the Bend Solid and Finite Length modes in the Tool bar. This 
will allow us to set the length of the bend spine.

13.  Move the cursor over the rail, the ends will highlight in red. 
Click once to select the object.
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14. Move the cursor over the midpoint of the right end of the rail. 
Wait a few seconds to acquire a Smart Point.

15. Move the cursor to the left along the horizontal extension line 
about a quarter of the way across the rail. Click Once.

16. Then move the cursor back to the right end of the rail. Click 
one more time to set the length of the bend spine.

17. Move the cursor up. You will see a preview of the bend. When 
the Bend Angle is about 30º, click one more time to complete 
the operation.

18. Now, with the Deform tool still active, click on the rail, and 
then acquire a Smart Point at the midpoint of the left end of the 
rail. 

19. Move the cursor to the right along the horizontal extension 
line until it is slightly to the left of the start of the first bend.

20. Click once and move the cursor to the left about halfway to 
the left end. 

21. Click again to set the Bend Spine Length, move the cursor up 
until the Bend Angle is about -40º, and click once to complete 
the operation.

22. Finally, let’s bend the left end of the rail down. With the 
Deform tool still active, click once on the rail.

23. Move the cursor about three quarters across the remaining 
straight segment of the rail, click once.

24. Move the cursor back to the left and click on the midpoint of 
the left end of the rail to set the bend spine.

25. Now, move the cursor down until the the Bend Angle is about 
80º and click once more to complete the operation.

Next, we will now use the Extrude command and the Move By 
Points tool to create three posts for this rail. Then, we will adjust 
the height of the posts and combine the objects using the Add 
Solids command.
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26. Switch to a Top/Plan view.

27. If needed, move the rail overtop of the lower level of the 
skatepark.

28. Activate the Circle tool and draw a circle with a Length (L) 
of 0.1.

29. With the circle selected, extrude the circle by going to Model 
> Extrude.

30. Set the Extrusion to 1.75 and center the extrude under the 
rail.

31. Switch to a Front view and move the post (extrude) up so that 
the bottom of the post is snapped to the concrete base of the 
skatepark and is below the left curve of the rail.

32. Now drag the rail down by the highest part of the curve and 
snap to the top of the post. Switch to a Top/Plan view to 
confirm the post is still under the rail and then switch back to a 

Front view.

33. With the post still selected, move the middle top, blue control 
point up, so that the top of the post is inside the rail.

34. Then activate the Move By Points tool in the Basic palette.

35. Enable the Distribute and Object Retention modes in the 
Tool bar and set the Number of Duplicates to 2.

36. Make sure the post is still selected and click once on the 
center of the base of the post.	

37. Move the cursor to the right, until the Length field in the 
Floating Data bar is about 4 and click once to place the 
duplicates.

38. Now, let’s adjust the height of the other posts. Select the 
middle post.

39. Click the top middle, blue control point of the post and move 
the cursor down.

40. Once the top of the post is within the rail, click again to adjust 
the height.

41. Repeat the action for the other post.

42. Switch to a Top/Plan view and confirm that all posts are under 
the rail. Adjust the position of the posts if needed.

43. Select the rail and the three posts, go to Model > Add Solids 
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to combine the objects into one solid addition.

Finally, using the Set Working Plane tool and the Hemisphere 
tool, we will add rounded ends to the rail.

44. Switch to a Left Isometric view and zoom in on the left end of 
the rail.

45. Activate the Set Working Plane tool in the 3D Modeling tool 
set.

46. Enable the 2nd mode, Planar Face mode.

47. Move the cursor over the end of the rail, it will highlight in blue 
and the working plane preview will align with that plane.

48. Click once to set the working plane.

49. Now, activate the Hemisphere tool in the 3D Modeling tool 
set.

50. Enable the 2nd mode, Diameter mode.

51. Click once on the left edge of the rail and then once on the 
right edge.

52. Repeat this process for the other end of the rail.

53. Next, select the rail and the two Hemispheres and go to 
Model > Add Solids.

54. Finally, give the completed rail a Cool Gray 50% fill color 
from from the Standard Vectorworks color palette through the 
Attributes palette and change its class to Rails in the Object 
Info palette.

Planters

Rectangular planters
Using the Rectangle and Offset tools with the Extrude command 
we will create planter and place them next to the stairs.

1. First, let’s create a new class for the planters. Click on the 
Active Class menu in the View bar and choose New Class.

2. Name the class Planters and click OK.

3. Make the new planters class the active class by selecting it 
through the Active Class menu in the View bar.

4. Switch to a Top/Plan view and double-click on the Rectangle 
tool in the Basic palette.

5. Set the Width 4 and the Height to 2.5. Make sure Position at 
Next Click is checked and click OK.

6. Click once in a blank area above the skatepark, to place the 
rectangle.
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7. Activate the Offset tool in the Basic palette. 

8. In the Tool bar enable the Offset By Distance and Offset and 
Duplicate modes, and set the Distance to 0.15.

9. Click once on the inside of the rectangle to create an offset 
duplicate of the rectangle.

10. With the new rectangle selected, change the Distance field to 
0.3 in the Tool bar and click on the outside of both rectangles.

11.  Go to Modify > Send > Send to Back to move the new 
rectangle behind the other two.

12. Select the inner and outer rectangles, right click on the inner 
rectangle, and choose Clip Surface. We now have a clipped 
polyline.

13. The inner rectangle used to clip the outer rectangle will 
remain selected. We no longer need this rectangle, press the 
Delete key to remove the inner rectangle.

14. Now select the remaining inner rectangle, go to Model > 
Extrude, and set the Extrusion to 2.

15. With the extrude selected, set the Bot Z to 0.15 in the Object 
Info palette.

16.  Now, select the outer clipped polyline. Go to Model > 
Extrude and set the Extrusion to 0.15.

17. In the Object Info palette, set the Bot Z to 3.5.

18. Switch to a Left Isometric view, the planter should look like 
the image below.

19. Switch back to a Left Isometric view, select the two extrudes, 
go to Modify > Create Symbol.

20. Name the symbol Planter Box-1, set the Insertion Point to 
Plan Projection Center, and click OK.

21. Click OK again, to accept the destination folder. The symbol 
will be saved in the active file.

22. Move the Planter Box-1 symbol so that the base aligns with 
the bottom edge of the tapered face of the concrete base and 
the top of the planter box aligns with the concrete rail. 

Note:  In a Top/Plan view the planter Box is represented by three 
offset rectangles. This middle rectangle is the edge of the 
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planter’s base and the outer rectangle is the edge of the planter’s 
top. When moving the planter Box, use these Snap Points to help 
align the planter.

23. Now let’s place another instance of the Planter Box-1 symbol, 
on the left side of the stairs on the tapered face.

24. Locate the Planter Box-1 symbol in the Resource Browser. 
Drag and drop a new instance of the symbol.

25. Using the bottom left corner of the planter’s base, move the 
planter box so that the bottom left corner of the base aligns 
with the bottom edge of the tapered face and the base of the 
stairs. 

26. Switch to a Left Isometric view to confirm the placement of 
the planter Box.

Custom planter Box
Next, we will create another planter box that matches the edge 
of the concrete base on the other side of the stairs. We will use 
the edge of stairs and the concrete base to trace the shape of the 
custom planter using the Polygon tool.

1. First, switch to a Top/Plan view, set the Rails class to invisible 
by clicking on the Classes button in the View bar, and 
selecting Invisible for the Rails class. 

Setting the Rails class to invisible will make it easier to trace the 
edge of the concrete base.

2. Activate the Polygon tool in the Basic palette.

3. With the Vertex mode enabled, trace the shape of the custom 
planter as seen in the image below.

4. Now, set the Rails class back to Visible.

5. With the polygon selected, activate the Reshape tool in the 
Basic palette.

6. Enable the Move Edges Parallel mode, in the Tool bar.

7. Click on the middle blue control point of the angled edge.

8. Move up and snap to the inner edge of the concrete rail. Click 
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once to move the edge.

9. Next, select the middle blue control point of the left edge, move 
the cursor to the left, tab into the Floating Data bar, and offset 
the edge by 0.15.

10. Repeat this action for the top edge as well.

11. Activate the Offset tool in the Basic palette. 

12. In the Tool bar enable the Offset By Distance and Offset 
and Duplicate modes, and set the Distance to 0.15.

13. Click once on the inside of the polygon to create an offset 
duplicate of the polygon.

14. Click once again on the inside of the new polygon, to make 
one more offset duplicate.

15. Select the inner and outer polygons, right click on the inner 
polygon, and choose Clip Surface. We now have a clipped 
polyline.

16. The inner polygon used to clip the outer polygon will remain 
selected. We no longer need this object, press the Delete key 
to remove the inner polygon.

17. Select the remaining polygon object, go to Model > Extrude, 
and set the Extrusion to 2.

18. In the Object Info palette, set the Bot Z to 1.5.

19. Now, select the clipped polyline, go to Model > Extrude, and 
set the Extrusion to 0.15.

20. Then, set the Bot Z to 3.5 in the Object Info palette.

21. Switch to a Left Isometric view to check the shape and 
position of the custom planter. Then, switch back to a Top/Plan 
view.

22. Select both of the extrudes and go to the Modify > Create 
Symbol.



33 | Vectorworks Fundamentals 2016 Getting Started Guide

23. Name the symbol, Planter Box-2, click OK, and then OK 
again.

Tapered Planter Box
Now let us create one more planter cox. We will use the Deform 
tool to give this planter tapered sides.

1. Switch to a Left Isometric view.

2. Center the view over the lower level of the skatepark.

3. Activate the Rectangle tool and enable the Corner to Corner 
mode.

4. In the View bar, choose Automatic from the Plane menu.

5. To the right of the curved rail, draw a rectangle on the top 
surface of the concrete base. Set the Delta X (ΔX) to 4.25 and 
the Delta Y (ΔY) to -2.5.

6. Without clicking, move the cursor over the rectangle. The 
rectangle with highlight in red, indicating the Automatic Push/
Pull mode is active. 

7. Click once and move your cursor up. Tab into the Floating Data 
bar and set the Distance to 1. Press Enter or Return twice to 
extrude the rectangle.

8. Activate the Deform tool in the 3D Modeling tool set. 

9. Enable the Taper Solid and Symmetric modes.

10. Move your cursor over the planter (extrude), it will highlight in 
red. Click once to select the Extrude.

11. A four-way arrow graphic will be displayed move the arrow to 
the center of the top surface of the planter. Click once to set 

the center of the taper.

12. Move the cursor along the red extension line to the edge of 
the planter. When the SmartCursor Cue “Object / X” is 
displayed, click once more to set the taper axis.

13. Move the cursor back in towards the center of the planter. Tab 
into the Floating Data bar and set the Taper Ratio to 0.75.

14. Press Enter or Return twice the taper the planter.

15. Next, activate the Rectangle tool and make sure the Corner 
to Corner mode is enabled.

16. Move the cursor over the top of the planter. When the top of 
the planter highlights in blue, click once on the top left corner of 
the planter.

17. Move the cursor to the bottom right corner and click again to 
place the rectangle.

18. Activate the Offset tool, enable the Offset by Distance and 
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Offset Original Object modes, and set the Distance to 0.3.

19. Click once, inside the rectangle we just created, to offset the 
rectangle.

20. Now, let’s use the Push/Pull tool in the 3D Modeling tool set 
to subtract a portion of the Planter. Make sure the 3rd mode, 
Sub-Face mode is enabled.

21. First, click once on the rectangle. Next click on the planter. 
Now move the cursor over the rectangle, it will highlight in red. 
Click again to select the face to move.

22. Move your cursor down, Tab into the Floating Data bar, set 
the Distance to -0.3, and press Enter or Return twice to move 
the face. 

Ledge Obstacle 
Now we will add a ledge to the tapered planter box, to create a 
new obstacle. Using the Working Plane tool, we will set a working 
plane that is perpendicular to the top of the planter. Then we will 
cut a hole in the planter and place ledge in it.

1. In the View bar, click on the Render menu and choose 
Wireframe. This will allow us to set a working plane on the 
inner face of the planter.

2. Activate the Working Plane tool in the 3D Modeling tool set. 
Make sure the 2nd mode, Planar Face mode is enabled.

3. Move the cursor over the bottom vertical face of the cut out of 
the planter.

4. When the face highlights in blue, click once to set the working 

plane.

5. Press the X key to activate the Selection tool.

6. Click on the outer border of the pink working plane indicator to 
activate the working plane grips.

7. Click the center grip of the working plane. Move it out until it 
snaps to the edge of the top face of the planter. Click once to 
move the working plane. The working plane should now be 
perpendicular to the edge of the top face of the planter. 

8. Activate the Rectangle tool and enable the Center to Corner 
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mode.

9. Move the cursor over on the set working plane. Snap to the 
center of the tapered face. When the SmartCursor Cue “Center 
“is displayed, click once to start the rectangle.

10. Tab into the Floating Data bar, set the Delta X (ΔX) to -0.75 
and the Delta Y (ΔY) to 0.07, and press Enter or Return twice 
to place the rectangle.

11. Without clicking, move the cursor over the rectangle. The 
Automatic Push/Pull mode will activate and the rectangle with 
highlight in red. 

12. Click once and move the cursor out. Tab into the Floating 
Data bar, set the Distance to 1, and press Enter or Return 
twice to extrude the rectangle.

13. Render in OpenGL, by going to the Render menu in the View 
bar and choosing OpenGL.

14. Select both the ledge and the planter and go to Model > 
Subtract Solids. Use the Back and Front buttons to highlight 
the planter and check the Retain Subtracting Objects option. 

This will cut a hole in the planter for the ledge and leave the ledge 
object in place. 

15. If you drag the ledge object out, you will see a hole has been 
cut in the planter. Go to Edit > Undo to undo the move and 
place the ledge back in place.

16. Let’s save this planter as a symbol. Select both the planter 
and the ledge, go to Modify > Create Symbol, name the 
symbol Planter Box-3 and click OK twice.

17. Finally, lets use the Mirror tool to mirror and duplicate the 
planter. Switch to a Top/Plan view, activate the Mirror tool, and 
enable the Duplicate mode.

18. Place the cursor over the center of the bottom edge of the 
ledge. Press the G key to place a datum.

19. Tab into the Floating Data bar and set the Length (L) to 2.5.

20. Move the cursor down until the SmartCursor Cue “Length / 
Align H” is displayed. Click once and move the cursor to the 
right. 

21. Click once more to mirror and duplicate the planter.

22. Now, select both the planters and go to Modify > Group. 
These objects will no move together as a group.

Editing a Symbol
Symbol resources not only allow you to save objects for later 
use, they also allow you to quickly edit and make changes to 
all instances of the symbol. We will edit the planter symbols 
and adjust the fill color of all of the instances, by just editing the 
symbol definition.

1. In the Resource Browser, locate the Planter Box-3 Symbol.

2. Right-click on the symbol and choose Edit 3D Component. 
The Symbol Edit window will open, indicated by the colored 
border around the drawing window and the 3D symbol 
geometry will be displayed.
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3. With all of the objects selected, set a turquoise fill color in the 
Attributes palette using the RGB values shown below.

4. Click the Exit Symbol button in the top right corner of the 
drawing window. To exit the Symbol Edit window and save the 
changes. You will see both instances of the Planter Box-3 
Symbol now show the new fill color.

5. Repeat this process for the Planter Box-1 and Planter Box-2 
Symbols. Give the geometry of both these symbols a Cool 
Gray 50% fill color.

Note:  You can also edit the symbol definition, by double-clicking 
on an instance of the symbol in the drawing. Editing a symbol 
in this way will update the symbol definition in the same way as 
editing the symbol through the Resource Browser. Any changes 
will be applied to all instances of the symbol.

Ramps and Ledges

Curved ramp

First, we will create a curved ramp on the curved face between 
the lower and mid level of the skatepark. Using the Arc tool, we 
will match the curve of the edge. We will also use the Push/Pull 
tool, Loft Surface tool, and Stitch and Trim command, to create 
the slope of the ramp.

1. Let’s start by creating a new class for the ramps. Name the 
class Ramps and make it the active class.

2. Switch to a Top/Plan view and center the drawing over the 
curved face.

3. Activate the Arc tool and enable the Three Points mode.

4. Click once on the upper edge of the curved face to start the 
arc. Move along the edge and click a second time further down 
the edge to set a point for the arc to pass through. Click one 
last time further down along the edge to end the arc.

5. Now, activate the Offset tool and click on the Offset Tool 
Preferences button in the tool bar.

6. Set the Method to Offset by Point, the Duplication to 
Duplicate and Offset, check the Close Open Curves option 
and Click OK.

7. Click once to the left of the arc, move the cursor until you 
intersect the lower edge of the curved face. Click once move to 
complete the operation.

8. Press the X key twice to deselect the closed polyline. Select 
the original arc again.

9. Switch back to the Offset tool and click to the right of the arc. 

10. Move your cursor to the right, tab into the Floating Data bar, 
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set the Distance to -0.75, and press Enter or Return twice to 
create the polyline.

11. With the polyline on the right still selected, go to Model > 
Extrude, and set the Extrusion to 1.

12. In the Object Info palette, set the Bot Z to 1.5.

13. Repeat this process for the polygon on the left.

14. Switch to a Left Isometric view.

15. Press the B key to activate the X-Ray Select mode, and 
select the original arc we created.

16. With the arc selected, go to Modify > Move > Move 3D.

17. Set the Z Offset to 2.5 and click OK. The Arc is now on the 
top surface of the Extrudes.

18. Activate the Push/Pull tool, enable the Move Face mode.

19. Move your cursor over the large extrude, press the Alt key 
(Windows) or Option key (Macintosh) to select the bottom face 

of the extrude. When the bottom face highlights in red, click 
once.

20. Move the cursor down and snap to the bottom edge of the 
curved face. Click once to extend the face of the extrude.

21. Activate the Arc tool and enable the Tangent to Line mode.

22. Select Automatic from the Plane menu in the View bar.

23. Move your cursor over the right side face of the larger 
extrude, it will highlight in blue.

24. Click once on the top right corner of the face to start the arc, 
move your cursor to the center of the face and acquire a Smart 
Point.

25. Press and hold the B key to activate the X-Ray Select mode. 
Move the cursor to the right along the red extension line until 
you intersect the right edge of the extrude. After a few seconds 
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a second Smart Point will appear.

26. Move the cursor to the midpoint indicator between these two 
smart points. Click once to set the tangent line. 

27. Move the cursor to the bottom left corner of the face and click 
once more to create the arc.

Now we need to convert these arcs to NURBS curves, so we can 
use the Loft Surface tool to create a curved NURBS Surface. 

28. Select this arc and the original arc we created. Go to Modify 
> Convert > Convert to NURBS. 

29. The NURBS curves are placed in a group, go to Modify > 
Ungroup to ungroup the Curves.

30. Activate the Loft Surface tool in the 3D Modeling tool set and 
enable the 2nd mode, One Rail mode. This mode allows you 
to select a single rail and profile(s).

31. Move the cursor over the upper NURBS curve, click once to 
set it as the rail. Now move the cursor over the other NURBS 
curve and click once to set it as the profile.

32. Click the green check mark button, the Loft Creation dialog 
will be displayed. Click OK to accept the defaults and create 
the NURBS surface.
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33. Select both the large extrude and the NURBS surface, go to 
Model > 3D Power Pack > Stitch and Trim Surfaces.

34. The Stitch and Trim Surfaces command created two 
generic solids from the extrude. Using the NURBS Surface to 
separate the two objects. Double tap the X key to switch to the 
Selection tool. Select the upper generic solid and press Delete 
to remove it. We now have a curved face for the ramp.

35. Select the curved generic solid and the remaining extrude, go 
to Model > Add Solids to combine the objects and complete 
the Ramp.

36. Finally, let’s give the Ramp a Cool Gary %50 fill color.

Elevated Obstacle 
Using the same techniques covered earlier we will now create an 
elevated obstacle. We will use the Rectangle, Automatic Working 
Plane, Extract, Offset, and Push/Pull tools to create this obstacle.

1. Center the view to the left of the long rail on the middle level of 
the satepark.

2. Activate the Rectangle tool and enable the Center to Corner 
mode.

3. We want to center the obstacle across from the long rail. Move 
the cursor over base of the middle post of the long rail. Use the 
X-Ray Select mode (B Key), to acquire a Smart Point at the 
center of the base.

Note:  If you accidentally set a Smart Point in the wrong location, 
pressing the Escape key once will remove all Smart Points. 

4. Move the cursor to the left along the extension line from the 
Smart Point.

5. Click once to start the rectangle. Move the cursor out, tab 
into the Floating Dat Bar, set the Delta X (ΔX) to 2.25 and the 
Delta Y (ΔY) to 0.25, and press Enter or Return twice to place 
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the rectangle.

6. Without clicking, move the cursor over the rectangle and use 
the Automatic Push Pull mode to extrude the rectangle. Set 
the Distance to 0.75. We now have a base (extrude) for our 
obstacle.

7. Next, we will use the Extract tool in the 3D Modeling tool set, 
to extract a 2D planar object from the top face of the base. This 
will be the top platform of the obstacle. Activate the Extract 
tool.

8. In the Tool bar, enable the Extract Surface mode and click on 
the Extract Tool Preferences button.

9. Check the option for Create Planar Objects. This setting will 
create a 2D polygon, instead of a NURBS surface. Make sure 
all other options are unchecked, and Click OK.

10. Move the cursor over the top of the base, when it highlights in 
red, click once to select the surface.

11. Click the green check mark button to extract a polygon from 
the surface.

12. Now, activate the Offset tool, enable the Offset by Distance 
and Offset Original Object modes, and set the Distance to 
0.075.

13. Click outside of the extracted polygon to offset it.

14. Now activate the Push/Pull tool and enable the 1st mode, 
Extrude Face mode.

15. Move the cursor over the offset polygon, click once to select 
the face. Tab into the Floating Data bar, set the Distance to 
0.1, and press Enter or Return twice to extrude the polygon.

16.  Finally, using the Attributes palette, give the base the same 
turquoise fill color as used previoulsy and the top platform a 
Cool Gray 50% fill color.

Straight Ramp
In this section, we will create a simple straight ramp. Will utilizes 
the Rectangle tool and Automatic Push/Pull mode to quickly 
recreate the ramp. Then, we will use the Rotate tool, to pivot the 
ramp up. Finally, using the Project tool, we will create supports for 
the Ramp.

1. To make it easier to create the ramp, set the Rails class to 
invisible.

2. Activate the Rectangle tool and enable the Corner to Corner 
mode.

3. Move the Cursor over the bottom right corner of the left side of 
the elevated obstacle and acquire a Smart Point.

4. Move the cursor to the right, along the extension line. Click 
once to start the rectangle. 
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5. Move the cursor out, tab into the Floating Dat Bar, set the 
Delta X (ΔX) to 2.75 and the Delta Y (ΔY) to -1.25, and press 
Enter or Return twice to place the rectangle.

6. Without clicking, move the cursor over the rectangle and use 
the Automatic Push Pull mode to extrude the rectangle. Set 
the Distance to 0.15.

7. With the ramp face (extrude) selected, activate the Rotate tool 
in the Basic palette.

8. Enable the 1st mode, Standard mode and the Standard 
Rotation mode in the Tool bar.

9. Move the cursor over the ramp face. A protractor feedback 
graphic displays around the cursor. Align the protractor on the 
bottom right, vertical face of the ramp face.

10. Click once on the bottom left corner of the vertical face to set 
the center point of rotation.

11. Move cursor along the bottom edge of the vertical face and 
click once to define the axis of rotation.

12. Move the cursor up. You will see a preview of the rotated 
object. Tab into the Floating Data bar and set the Working 
Plane Angle (WP A) to 20º. Press Enter or Return twice to 
rotate the ramp face.

13. Now let’s taper the bottom of the ramp. Activate the Taper 

tool in the 3D Modeling tool set and enable the 2nd mode, 
Picked Face mode.

14. Move the cursor over the ramp, hold the Alt key (Windows) or 
Option key (Macintosh) to highlight the bottom face of the 
ramp. Click once to select to set the reference plane for the 
taper.

15. Move the cursor over the side face that intersects the 
concrete base. When it highlights in red click once more to 
select the face to taper.

16. Finally, move your cursor out until it snaps to the concrete 
base. Click one more time to set the taper angle.

Next, we will create supports for the ramp. 
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17. Use the Flyover tool to rotate the view slightly.

18. Move the cursor over the bottom left corner of the elevated 
face. Wait a few seconds until a Smart Point is displayed. 
Move the cursor down along the extension line until you 
intersect the concrete base.

19. When the SmartCursor Cue “Z/Working Plane” is displayed, 
click once to start the rectangle.

20. Acquire a second Smart Point on the bottom right corner of 
the elevated face. Move the cursor down along the extension 
line until you intersect the concrete base.

21. When the SmartCursor Cue “Object / Y / Align Y” is displayed, 
tab into the Floating Data bar and set the Delta X (ΔX) to 
-0.15. Make sure the Delta Y (ΔY) is 1.25, and press Enter or 
Return twice to place the rectangle.

22. Click and drag the bottom midpoint of the rectangle to the left. 
Tab into the Floating Data bar, set the Length (L) to 0.5 and 

the Working Plane Angle (WP A) to 180º, and press Enter or 
Return twice to move the rectangle.

23. Now, let’s duplicate the rectangle. Click and drag the bottom 
right control point to the left. Tab into the Floating Data bar and 
set the Length (L) to 1 and the Working Plane Angle (WP A) 
to 180º. Press and hold the Ctrl key (Windows) or Option key 
(Macintosh) on your keyboard and press Enter or Return twice 
to duplicate and move the rectangle.

Next, let’s use the Project tool from the 3D Modeling tool set to 
create supports for the Ramp. 

24. Activate the Project tool and enable the Add and Add 
Downward modes in the Tool bar.

25. Click once on the 1st rectangle, then click a 2nd time on the 
ramp. The rectangle is projected to the bottom of the ramp.

26. Repeat this action for the other rectangle.
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27. Now, select the ramp and two supports, go to Model > Add 
Solids.

28. Finally, give the ramp a Cool Gray 50% fill color in the 
Attributes palette.

Now let’s mirror the ramp to create a jump and organize the 
nearby obstacles.

29. With the ramp selected, activate the Mirror tool in the Basic 
palette and enable Duplicate mode.

30. Switch to a Top/Plan view.

31. Move the cursor over the midpoint of the right side of the 
Ramp. Press the G key to set a floating datum

32. Tab into the Floating Data bar, set the Length (L) to 1, press 
Tab once to set the length. Click once to start the mirror axis 
line when the SmartCursor cue “Lenght/ Align V” is displayed.

33. Move the cursor up vertically, when the SmartCursor Cue 
“Vertical” is visible, click once to set the mirror axis and 
complete the operation.

34. Now, select both ramps and go to Modify > Group. 

35. Next, let’s turn the Rails class back on. Click on the Classes 
button in the View bar and set the Rails class to Visible.

36. Finally, using Smart Points, arrange the objects so that the 
center of the elevated obstacle, ramps, and long rail align.

Stair ledges
In this sections we will use the Extrude Along Path command to 
quickly create ledges on the sides of the left Stairs.

1. Switch to a Left Rear Isometric view and center the view to the 
left of the stairs.

2. Set the Planters and Rails class to Invisible.

3. Activate the 3D Polygon tool in the 3d Modeling tool set.

4. Move the cursor over the midpoint between the stairs and the 
edge of the concrete base.

5. Press the G key to set a datum. Tab into the Floating Data bar, 
set Length (L) to 1, and press Tab again to set the length 
value.Move the cursor back and click once to start the 3D 
polygon. 

6. Click again at the datum point. 

7. Then move the cursor down the tapered face and click once at 
the base of the face. 

8. Finally, Tab into the Floating Data bar, set the Length (L) to 1, 
press Tab again to set the length, and double-click to complete 
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the 3D polygon.

Now that we have a path that conforms to the tapered surface, 
let’s create a profile and use the Extrude Along Path command.

9. Double-click on the Rectangle tool. Set the Width and Height 
to 0.6 and click OK.

10. Click once to the upper level of the skatepark to place the 
rectangle.

11. Select both the profile (rectangle) and path (3D polygon), go 
to Model > Extrude Along Path, use the Prev and Next 
buttons to highlight the path object, make sure Lock Profile 
Plane and Fix Profile are unchecked, and click OK.

We now have the base for our ledge. However, it is sitting below 
the surface of the concrete base. This is because when you 
create an extrude along path object, the profile is centered on the 
path, which was on the top surface of the concrete base. So, half 
of the extrude is below the surface. Let’s edit the elevation of the 
path to move the base of the ledge up, so it is no longer below 
the surface of the concrete base.

12. Double-click on the ledge base (extrude along path) and 

choose to Edit the Path.

13. Switch to a Back view.

14. With the path objects selected, set the Z to 0.3 in the Object 
Info palette. This is half the height of the Profile and will move 
the ledge base on top of the concrete base.

15. Click the Path Exit button in the top right corner of the 
drawing area to exit the Edit window and save the changes.

16. Next, give the ledge base a turquoise fill color.

17. Now, move the ledge base so that the right side intersects the 
start edge of the stairs. You will need to use the Flyover tool to 
rotate the view and the ledge as shown in the image below.

Next, we will use the same procedure to create a top for the 
ledge. 

18. Switch back to a Left Rear Isometric view.

19. Use the 3D Polygon tool to create a path along the top of the 
ledge base.
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20. Then, use the Rectangle tool to draw a profile that is 0.8 in 
width and 0.15 in height. 

Make sure the rectangle is parallel with the edge of stairs. 

21. If the rectangle is not parallel, adjust the Rotation field to 90° 
in the Object Info palette.

22. Now, use the Extrude Along Path command to extrude the 
profile along the path.

23. Next, edit the extrude along path object and adjust the height 
of the path, so the ledge top is not below the surface of the 
ledge base. You will need to set the Z of the path to half the 
height of the profile, 0.075.

24. Finally, give the ledge top a Cool Gray %50 fill color.

Finally, let’s group the ledge base and top together and mirror the 
ledge to the other side of the Stairs.

25. Select both the top and base of the ledge and go to Modify > 

Group.

26. With the ledge (group) selected, activate the Mirror tool in the 
Basic palette, and enable the Duplicate mode.

27. Find the midpoint of the top stair, when the SmartCursor Cue 
“Midpoint” is displayed, click once.

28. Now move the cursor up and to the left. When the mirror 
preview is displayed in correct location on the other side of the 
stairs and the SmartCursor Cue “X” is displayed, click once to 
set the axis line.

29. Now, set all classes to visible and review the placement of the 
ledges.

Curved ledge
Next, we will create a curved ledge on the lower level of the 
skatepark. Using the Arc and Offset tools, we will create a 
polyline that matches the curve of the concrete base. Then 
we will extrude the polyline to create a base. Finally, using the 
Extract tool we will create the top of the ledge.

1. Switch to a Left Isometric view and center the drawing area 
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over lower level of the skatepark.

2. Use the Arc tool with the 2nd mode, Three Points mode, to 
trace the curve of the upper edge of the concrete base. 

3. Move the cursor along the straight edge of the concrete base. 
When the SmartCursor Cue “Endpoint” is displayed, click once 
to start the arc.

4. Move along the curve until the SmartCursor Cue “Midpoint” is 
displayed. 

5. Move the cursor back along the curve about halfway between 
the start and midpoint. Click a second time to set a point for the 
arc to pass through.

6. Move the cursor back the midpoint and click once more to 
complete the arc.

Next, use the Offset tool to create a closed polyline and then 
Extrude the polyline to create the ledge base.

7. Activate the Offset tool, enable the Offset by Distance and 
Duplicate Offset modes, and click on the Offset Preferences 
button.

8. Set the Offset Distance to 0.6, check the Close Open Curves 
option, and click OK.

9. Click once on the inside of the arc. We now have a closed 
polyline.

10. Activate the Push/Pull tool, enable the 1st mode, Extrude 
Face mode, and select the face of the polyline.

11. Tab into the Floating Data bar and set the Distance to 0.6. 
Press Enter or Return twice to extrude the polyline.

Now let’s create the top of the curved ledge.

12. Activate the Extract tool, enable the 2nd mode, Extract 
Curve mode, click on the Extract Preferences button and 
check the Create Planar Objects option.

13. Move the cursor over the upper, outer edge of the base, when 
the edge highlights in red, click once to select it.

14. Click the green check mark button in the tool bar to extract 
the edge and create an arc.

15. Next, activate the Offset tool and change the Distance to 
0.75 in the Tool bar.

16. Click once on the inside of the arc to create a closed polyline.
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17. Activate the Push/Pull tool and extrude the polyline to a 
Distance of 0.3.

18. Finally, give the base a turquoise fill color, the top a Cool Gray 
%50 fill color, and place the two objects in a group.

Curved Bank
Using the Inner Boundary mode of the Polygon tool, we will 
create a curved bank on the other side of the lower level of the 
skatepark.

1. Switch to a Right Isometric view and center the drawing area 
other curved corner of the lower level.

2. Activate the Line tool and make sure Automatic is set in the 
Plane menu in the View bar.

3. Move the cursor along the straight edge of the concrete base. 
When the SmartCursor Cue “Endpoint” is displayed, click once 
the start the Line.

4. Move the cursor to the right along the green extension line. 
Move past the edge of the concrete base and click once more 
to complete the line. 

5. Activate the Polygon tool and enable the 2nd mode, Inner 
Boundary mode.

6. Click once between the line and the edge of the concrete base 
to create a closed polyline.

7. Select the line and delete it, as it is no longer needed.

8. Activate the Push/Pull tool and extrude the polyline to a 
distance of 1.5.

9. Now, activate the Deform tool and enable the Taper Solid 
mode. Make sure the Symmetric mode is not enabled.

10. Click once on the extrude to select it. Then, click once at 
bottom midpoint, of the vertical face. Make sure the vertical 
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face is highlighted in blue.

11. Now move the cursor up to the center of the face, click once. 

12. Move the cursor down to the bottom midpoint and click once 
more to taper the face.

13. Finally, give the curved bank a turquoise fill color.

Tapered Bank
Let’s create another bank with multiple tapered sides. We will 
start with a simple rectangle and then use the Push/Pull and 
Taper Face tools to create the tapered bank.

1. Switch to a Left Isometric view and center the drawing area 

over the middle level of the skatepark.

2. Activate the Rectangle tool, enable the Corner to Corner 
mode, and make sure Automatic is set in the Plane menu.

3. Move the cursor along the inner, bottom edge of the concrete 
rail. About a quarter of the way along the concrete rail, click 
once to start the rectangle.

4. Move the cursor down and to the right. Tab into the Floating 
Data bar, set the Delta X (ΔX) to 7.25. Make sure the Delta Y 
(ΔY) is -1.5, and press Enter or Return twice to place the 
rectangle.

5. Without clicking, move the cursor over the rectangle. The 
rectangle will highlight in red indicating the Automatic Push/
Pull mode is active. Click once and set the Distance to 1.25.

6. Now, activate the Taper Face tool and enable the Picked Face 
mode.

7. Move the cursor over the extrude, press the Alt key (Windows) 
or the Option key (Macintosh) and when the bottom face of the 
extrude highlights in red, click once to select it.

8. Then, move the cursor over the long vertical face. When it 
highlights in red, click once to select the face.

9. Move the cursor towards the back of the extrude. When the 
Taper Angle is about 40º click one last time to taper the face.
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Note: The are multiple snap points in this area. You may find 
it difficult to set an angle of 40º. However, if you hold the Back 
Quote key (`), you can temporarily suspend snapping. This will 
make it easier to set the angle to 40º. 

10. Next, let’s taper the left side of the bank. With the Taper Face 
tool still active, select the bottom face of the base, by holding 
the Alt key (Windows) or the Option key (Macintosh).

11. Then, select the left side face.

12. Move the cursor in, tab into the Floating Data bar and set the 
Taper Angle to 60º, and press Enter or Return twice to taper 
the face.

13. Repeat this process for the right side of the bank. 

Note: You can use the Alt (Windows) or Option (Macintosh) key to 
select both the bottom and right side face. This will allow you to 
Taper the other side without adjusting your view.

14. Finally, give the tapered bank a turquoise fill color.

Tapered Ramp with a Ledge
Next, we will create a tapered ramp on the lower level of the 
skatepark. Then using the Push/Pull tool, we will create a tapered 
ledge on the ramp.

1. Center the drawing area over the lower level of the skatepark, 
near the curved stairs.

2. Activate the Rectangle tool and enable the 4th mode, Three 
Point Rotated mode.

3. Click once on the top edge of the concrete base between the 
stairs and tapered planter box.

4. Move the cursor along the edge towards the stairs. Tab into the 
Floating Data bar and set the Length (L) to 6.75. Press Enter 
or Return twice to set the second point of the rectangle.

5.  Now, move the cursor up and use the Floating Data bar again 
to set a Length (L) of 3.25.

6. Move the cursor over the rectangle and use Automatic Push/
Pull mode to extrude the rectangle to a distance of 0.85.

7. Activate the Deform tool and enable the Taper Solid mode. 
Make sure the Symmetric mode is not enabled.

8. Click once on the extrude to select it, then click once on the top 
center of the extrude to set the taper center. 

9. Move the cursor to the right, horizontally across the extrude. 
Click once more, to set the direction of the taper.

10. Move the cursor in, tab into the Floating Data bar, and set the 
Taper Ratio to 0.3.

Now, let’s create the ledge.

11. Switch to a Top/Plan view and activate the Rectangle tool.
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12. With the Three Point Rotated mode still enabled, click once 
at the base of the left side of the ramp, about a quarter the way 
across the ramp.

13. Move the cursor across the ramp, acquire a Smart Point on 
the bottom right corner of the ramp. Follow the extension line 
down and to the left.

14. When the SmartCursor Cue “45º / Align” is displayed, click 
once to set the second point of the rectangle.

15. Move down and to the left, tab into the Floating Data bar, set 
the Delta X (ΔX) to -0.15, and press Enter or Return twice to 
complete the rectangle.

16. Go to Model > Extrude and set the Extrusion to 1.5.

17. Switch to a Left Isometric view and activate the Line tool.

18. Move the cursor over the right side of the ledge (extrude). 
When the SmartCursor Cue “Midpoint” is displayed, click once 
to start the line.

19. Move the cursor to the left and acquire a Smart Point at the 
intersection of the ledge and the top edge of the tapered face.

Note: You may need to press the T key to set the Smart Point at 
the top edge of the Tapered 

20. Move the cursor up along the extension line and click once at 
the top of the ledge to complete the Line.

21. Repeat this process on the other side of the ledge.

22. Next, activate the Push/Pull tool and enable the Sub-Face 
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mode.

23. Click the line on the right, next click the ledge, then click the 
face between the line and the upper right corner of the ledge. 

24. Now, move the cursor up until the preview is past the edge of 
the ledge and click one more time to remove the section of the 
ledge.

25. Repeat this procedure for the other side.

26. Finally, give the ramp a Cool Gray %50 fill color, the ledge a 
turquoise Fill Color, and place them in a group.

Bowl Fill Color
To complete the obstacles of the skatepark, let’s extract the 
bottom of the bowl to give it a different fill color.

1. Center the drawing area over the Bowl on the upper level of 

the Skatepark.

2. Activate the Extract tool, enable the Extract Surface mode, 
and click on the Extract Tool Preferences button.

3. Check the option for Select Faces and make sure all other 
options are unchecked.

4. Move the cursor over the bottom of the bowl, it will highlight in 
red. Click once to select the face.

5. Click the green check mark button in the tool bar to extract the 
face and create a NURBS surface.

6. With the NURBS surface selected, give it a turquoise fill color 
in the Attributes palette.

You will notice that the fill color does not appear correctly. This is 
because the NURBS surface intersects the top surface of the 
concrete base. To see the fill color of the NURBS surface above 
the concrete surface, we need to move the object up slightly.

7. With the NURBS surface still selected, switch to a Front view.

8. Hold the Shift key and press the Up Arrow key on your 
keyboard. This will activate the Nudge command and move the 
NURBS surface up slightly.

9. Finally, switch back to a Left Isometric view. You will see the fill 
color of the NURBS surface is now fully visible above the 
concrete base.
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Gazebo

Extend the Concrete base
We will start by creating an extension to the concrete base on 
the lower level of the skatepark. Using the Arc, Rectangle, and 
Split tools, we will create the base shape of the extension. Then 
we will use the Push/Pull and Project tools to complete the 
extension.

1. Let’s start by making the Concrete Base class the active class.

2. Switch to a Top/Plan view and center the drawing over the 
lower level of the skatepark.

3. Activate the Arc tool and enable the Tangent to Line mode.

4. Start the arc by clicking on the right end of the curved bank, 
where it intersects the edge of the concrete base.

5. Move the cursor up at a 30º until the Length (L) field in the 
Floating Data bar is about 4 and click a second time.

6. Move the cursor up and to the left, at a 30º angle until Length 

(L) is about 3.5, click one more time to complete the Arc.

7. Next, place the cursor on the edge of the concrete base, at the 
location shown in the image below. Click once to start another 
arc.

8. Move the cursor up and to the left, at a 45º angle. When the 
the Length (L) is about 4.5, click again.

9. Acquire a Smart Point at the end of the first arc. Move the 
cursor to the right along the extension line. When the 
SmartCursor Cue “30º / Align V” is visible, click once more to 
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complete the arc.

10. Activate the Rectangle tool and enable the Center to Corner 
mode.

11. Acquire Smart Points at the end of each arc. Find the 
midpoint between the two Smart Points. 

12. Press the G key to set a floating datum.

13. Tab into the Floating Data bar, set the Length (L) to 3.5, and 
press Tab to set the length.

14. Move the cursor upward and when the SmartCursor cue 
“Align H”” is displayed click once to start the rectangle. 

15. Move the cursor down and to the right. Acquire a Smart Point 
at the end of the arc on the right. 

16. Move your cursor to the right along the extension line, until it 
is slightly wider than the two arcs. Click once more to complete 
the rectangle.

Now, let’s use the Split tool to split the rectangle into two 
polygons.

17. Activate the Split tool in the Basic palette. Enable the Point 
Split mode.

18. Place your cursor over the end of the left arc, when the 
SmartCursor Cue “Arc End” is displayed, click once.

19. Make sure the rectangle is highlighted in red, use the Prev 
and Next buttons if needed, and click OK.

20. Repeat this action for the intersection of the rectangle and the 
right arc end, to create a separate segment the arc ends.

21. Select all the two arcs outer polygon segment and go to 
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Modify > Compose.

22. Select the middle trimmed segment and delete it.

Next, we will extrude the polyline and use the Project tool to 
connect it with the concrete base.

23. Switch to a Left Isometric view.

24. Select the polyline and check the Closed option in the Object 
Info palette. This will draw the final segment to create a closed 
polyline.

25. Using the Push/Pull tool, extrude the face of the polygon to a 
distance of 0.3.

26. Activate the Extract tool, then using the Extract Surface 
mode and Create Planar Objects option in the Extract Tool 

Preferences, extract the vertical face of the extruded polygon, 
that faces the concrete base.

27. Now, activate the Project tool, then using the Add and Add 
Upwards modes. Project the extracted face to the concrete 
base by clicking the polygon we just extracted and then the 
concrete base.

28. Select the extrude and projected generic solid, and go to 
Model > Add Solids.

29. Finally, give the extension the same Gray %30 fill color as the 
concrete base.

Creating the Gazebo Roof
We will now use the Create Roof command to create a roof for 
the gazebo.

1. First, create a new class named Gazebo and make it the active 
class.

2. Switch to a Top/Plan view.

3.  Activate the Rectangle tool, using the Center to Corner 
mode. Find the center of the rectangular gazebo area using 
Smart Points.
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4. Then create a rectangle with a Delta X (ΔX) and Delta Y (ΔY) 
of 2.75.

5. With the rectangle selected, go to Model > AEC > Create 
Roof.

6. In the Create Roof dialog, set the Thickness to 0.18, the Roof 
Pitch to 20º, uncheck Retain Original Objects, and then click 
OK.

7. Now, switch to a Back view. You will see the roof is laying on 
the ground. Click on the peak of the Roof and drag it up. Tab 
into the Floating Data bar, set the Length (L) to 5, and press 
Enter or Return twice.

8. Switch to a Left Rear Isometric view and give the roof a Cool 
Gray %50 fill color.

9. In the Object Info palette, check the Insert Soffit option and 
then click on the Soffit Settings button. 

10. In the Edit Soffit Settings dialog, set Trim Depth to 0.65, and 
click OK.

Next, we will insert a facia. In order to insert a fascia, we need to 
first adjust the eave setting.

11. In the Object Info palette, choose Square Cut Miter from the 
Eaves menu.

12. Now, check the option for Insert Fascia and click the Fascia 
Settings button.

13. In the Edit Fascia Settings dialog, set the Fascia Width to 

0.15, the Fascia Height to 0.1, and then click OK.

Creating Gazebo posts
We will use the Extrude command, Project tool, and the Duplicate 
Array command to quickly create four posts for the Gazebo.

1. First, let’s create a base for the post. Switch to a Top/Plan view.

2. Activate the Rectangle tool and enable the Corner to Corner 
mode.

3. Click once on the inner top left corner of the gazebo roof.

4. Tab into the Floating Data bar, set the Delta X (ΔX) to 0.6. 
Make sure the Delta Y (ΔY) is -0.6, and press Enter or Return 
twice to place the rectangle.

5. With the rectangle selected, go to Model > Extrude and set 
the Extrusion to 0.15.

6. Switch to a Left Rear Isometric view and in the Object Info 
palette, set the Z of the extrude to 0.3.

7. Draw a rectangle on top of the extrude, using the Center to 
Corner mode and with Automatic Working Plane active. Tab 
into the Floating Data bar, set the Delta X (ΔX) to 0.15. Make 
sure the Delta Y (ΔY) is 0.15, and press Enter or Return twice 
to place the rectangle.
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8. Using the Project tool, with Add and Add Downwards modes 
enabled, click the rectangle first then the roof object to project 
the rectangle.

Note: If you press the B key to activate the X-Ray Select mode, 
you will see the top of the Post conforms to the shape of the 
inside of the Gazebo Roof.

9. Select the post and the base, go to the Model > Add Solids, 
and give the combined object a turquoise fill color.

10. Switch to a Top/Plan view.

11. With the post selected, go to Edit > Duplicate Array.

12. In the Duplicate Array dialog, set the Shape menu to Circular 
Array. 

13. Then the Number of Duplicates to 3 and the Angle 
Between Duplicates to 90º.

14. Choose Next Mouse Click for Circle Center Point, check 
the Rotate Duplicates option, and enable Use Duplication 
Angle.

15. Finally, make sure Retain is checked under Original Object 
and click OK.

16. Click once in the center of the roof to duplicate the posts 
around the gazebo roof.

Adding Benches and Light Posts

Resource Browser
In this section we will use the Resource Browser to import symbol 
resources from another file. 

1. In the Resource Browser, click on the Files menu button above 
the Home button.

2. In the Files menu, choose Browse a Document. This will allow 
you to view resources from other Vectorworks files.

3. Download the Skatepark Symbols.vwx file. This file can be 
found in the Exercise Files section. Navigate to the Skatepark 
Symbols.vwx file and click Open. 

4. This file contains three symbols, a Concrete Bench, Light Post, 
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and Wooden Bench. If you scroll through the Resource Display 
window, you will see these resources.

These symbols are currently saved in the Skatepark Symbols file. 
To import the symbols into our document, you can either drag and 
drop a symbol into the file or use the Import option to move the 
resource into the active document.

5. Select all three symbols in the Resource Browser.

6. Right-click on the first symbol and choose Import from the 
menu.

7. In the Import Symbols dialog, leave Preserve Folder 
Hierarchy enabled and Click OK.

8. Now, click the Home icon in the top right corner of the 
Resource Browser. This will switch the view of the Resource 
Browser back the active document.

9. If you scroll through the Resource Display window, you will see 
the three symbols now show with the other symbols we have 
created in this file.

Adding Benches
Next, we will use the Symbol Insertion tool to add bench symbols 
around the skatepark. The Symbol Insertion tool allows you to 
place a symbol and set it’s rotation.

1. Let’s start by creating a new class for the benches. Name the 
class Benches and make it the active class.

2. Switch to a Left Isometric view.

3. Now, let’s place some wooden benches under the gazebo. 
In the Resource Browser, double-click on the Wooden Bench 
symbol. This will make the Wooden Bench the active symbol 
and activate the Symbol Insertion tool in the Basic palette.

4. When you move the cursor into the drawing area, you will see 
a preview of the Wooden Bench symbol. Move the cursor over 
the right side of the gazebo.

5. Using Smart Points and the X-Ray Select mode, align the 
insertion point of the bench with the center of the right side of 
the gazebo area. Click once to place the bench under the 
gazebo roof.

6. Move the cursor down and to the right along the Y extension 
line. Click once to center the rotation and place the bench.

7. Then, using the Mirror tool, create a duplicate of the bench on 
the other side of the gazebo.

8. Using the same technique, place four more wooden benches 
around the bowl on the upper level of the skatepark. 
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9. Double-click on the Concrete Bench symbol in the Resource 
Browser and place three instances of this symbol around the 
lower level of the skatepark.

Adding Light posts
In this section, we will add a single light post symbol to the 
Skatepark. Then, using the Extract tool, Offset tool, and Duplicate 
Along Path command, we will create 12 light posts around the 
skatepark.

1. First, create a new class named Light Posts and make it the 
active class. Also set Rails class to invisble.

2. Switch to a Top/Plan view and center the drawing area to the 
right of the gazebo.

3. Double-click on the Light Post symbol in the Resource 
Browser.

4. Click once outside of the skatepark, to the right of the gazebo 
to set the insertion point for the light post. 

5. Move the cursor to the left horizontally. Click once to set the 
rotation.

Next, we will need to extract the edge of the concrete base to 
create the path to duplicate the light posts around. 

6. To make it easier to extract the edge, set the Rails class to 
invisible.

7. Activate the Extract tool, enable the Extract Curve mode, and 
click on the Extract Tool Preferences button.

8. Check the Select Tangent Entities option and uncheck all 
other options.

9. Move the cursor over the edge of the concrete base, a portion 
will highlight in red. Click once to select it. 

10. While holding the Shift key, move the cursor around the 
concrete base until the all edges are selected. Do not select 
the edges of the gazebo extension.

11. Click the green check mark button in the tool bar to extract 
the curves.

12. The curves will be created in a group, go to Modify > 
Ungroup, to ungroup the curves.

13. With all of the NURBS curves selected, go to Modify > 
Compose, to create one object.

We need to Offset the path, you cannot use the Offset tool on 
NURBS curve objects, so we need convert the NURBS curve to 
a polygon.

14. Go to Modify > Convert > Convert to Polygons.

15. In the Convert to Polygons dialog, choose Wireframe 
Rendering and click OK.

16. Ungroup the converted polygons and go to Modify > 
Compose to combine the polygons into one object.

17. Activate the Offset tool, enable the Offset by Distance and 
Offset Original Object modes, and set the Distance to 1.5.
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18. Click once on the outside of the polygon.

19. Select the path (polygon) and the light post.

20. Go to Edit > Duplicate Along Path.

21. In the Duplicate Along Path dialog, set the Number of 
Duplicates to 12 and check the options for Center Object 
on Path, Tangent to Path, and make sure Keep Original 
Orientation is unchecked.

22. Now Click OK.

23. Delete the path object, as it is no longer needed.

24. Switch to a Left Isometric view, to see the placement of the 
light posts.

You will see that the bases of the light posts are lower than the 
surface of the Skatepark. 

25. To better visualized the position of the light posts, click on 
the Classes button in the View bar and set the Site Class to 
visible. This will turn on a preconfigured site. (Screenshot)

This object was made using the same techniques we used to 
create the concrete base. Let’s adjust the height of the light posts.

26. First, if any light posts are on the tapered or filleted slopes, 
move them off the slopes.

27. Select all of the light posts around the upper level of the 
skatepark. 

28. To adjust the height of these light posts, simply set the Z to 
2.75 in the Object Info palette.

29. Now, select any light posts on the middle level and set the Z 
to 1.25.

30. Finally, repeat this operation for the light posts on the lower 
level. Setting the Z to 0.15.

Creating Viewports

Cropped viewport
We now have a complete skatepark. Next, we will create a 
cropped viewport and place it on sheet layer. Then, we will adjust 
the sheet layer page setup, set the scale, position, and visibility 
settings of the viewport. 

1. Switch to a Top/Plan view.

2. To create the crop, you can use any 2D shape. For this 
viewport, draw a rectangle over the skatepark.
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3. With the rectangle selected, go to View > Create Viewport.

4. A prompt will appear, asking if you want to use the selected 
object as the crop. Click Yes.

5. In the Create Viewport dialog, choose New Sheet Layer in the 
Create on Layer menu.

6. In the New Sheet Layer dialog, keep the default settings and 
click OK.

7. Set the Scale to 1:100.

8. Do not adjust any other settings in the Create Viewport dialog 
at this time. All of these settings can be adjusted after the 
viewport is created. Click OK.

The viewport is created and placed on the new sheet layer. Next, 
let’s edit the sheet layer page setup.

9. Now let’s edit the page setup of the new Sheet Layer. Go to 
Tools > Organization.

10. Switch to the Sheet Layers tab and click the Edit button.

11. In the Edit Sheet Layers dialog, click Page Setup.

12. Uncheck the Show Page Breaks option under Pages.

13. Under Printable Area, check the Choose size unavailable in 
printer setup option. 

14. Then, select ASME D from the Size menu.

15. Click OK to save the changes, then click OK two more times 
to exit the Edit Sheet Layers and Organization dialogs.

The viewport is still too large to fit on our page. Let’s adjust the 
scale of the viewport and position it on the page.

16. With the viewport selected, in the Object Info palette set a 
Custom Scale to 1:250.

17. Now move the viewport to the upper left corner of the page.

Viewports have independant class and layer visibility settings. 
You can choose which Class or Layers you wish to display per 
viewport. Let’s turn off the Site Class for this viewport.

18. In the Object Info palette, click on the Classes button to edit 
the class settings for this viewport.

19. Set the Site class to Invisible

20. Click OK. 
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21. The Site is no longer visible in the viewport. However, if you 
click on the Classes button in the View bar, you will see the 
Site class is still set to visible in the file.

Custom 3D viewport
Now let’s create a custom 3D viewport. We will setup a custom 
view on the design layer, then create a viewport and apply a 
render mode.

1. In the View bar, click on the Layers menu and choose Design 
Layer-1.

2. Switch to a Left Isometric view.

3. Using the Flyover, Pan, and Zoom tools, adjust the view until 
the skatepark appears similar to the image below.

4. Now, go to View > Create Viewport.

5. Keep the default settings and click OK.

6. The viewport is placed on the center of the sheet layer. Move it 
to the bottom right corner of the page area.

You will notice, the viewport is in Wireframe has a red and white 
border. This is the viewport out-of-date border. It indicates that 
the viewport needs to be updated. We created this viewport in 
an OpenGL Render mode. Viewports with render mode settings 

need to be updated any time you make changes in the file.

7. With the viewport selected, go to the Object Info palette. You 
will see the Update button is red. This indicates the viewport is 
out of date. Click Update to render the viewport.

8. Now, let’s add a crop to this viewport, double-click on the 
viewport, select Crop, and click OK.

9. In the Edit Crop window, draw a rectangle around the 
skatepark.

10. Click the Exit Viewport Crop button in the top right corner of 
the drawing area.

11. Click Update in the Object Info palette to render the viewport.

Viewport of the Gazebo
Next, let’s create a viewport focused on the gazebo. Then, we will 
add a Foreground Render option to give the viewport a different 
style.

1. Using the Layer menu in the View bar, switch back to Design 
Layer-1.

2. Switch to a left Right Isometric view and use the Flyover, Pan, 
and Zoom tools to adjust the view until the gazebo appears 
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similar the image below.

3. Go to View > Create Viewport and Click OK.

4. Move the viewport to the upper right corner of the page area.

5. Add a crop around the gazebo.

6. Now, in the Object Info palette, selected Hidden Line from the 
Foreground Render menu.

7. Click the Update button to render the viewport.

Viewport of the Bowl
Finally, we will create one more viewport centered on the bowl. 
Then, we will add Foreground Hidden Line Render option and 
adjust the settings.

1. Switch back to Design Layer-1.

2. Use the Flyover, Pan, and Zoom tools to adjust the view until 
the bowl appears similar the image below.

3. Go to View > Create Viewport and Click OK.

4. Move the viewport to the lower left corner of the page area.

5. Add a crop around the bowl.

6. Now, in the Object Info palette, selected Hidden Line from the 
Foreground Render menu.

7. Click the Update button to Render the viewport.

You will notice there are a unwanted lines on the sides of the 
Bowl. We can remove these lines, by adjusting the Smoothing 
Angle for the Hidden Line Render mode.

8. In the Object Info palette, click the Foreground Render 
Settings button.

9. Set the Smoothing Angle to 15º and click OK.

10. Click the Update button in the Object Info palette, to Render 
the viewport and see the changes.

Enhanced with Renderworks

Applying and Editing Textures
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In the section we will import a texture and apply it to the concrete 
base. We will then use the Attribute Mapping tool, to adjust the 
scale of the texture. Finally, we will duplicate the texture, edit it’s 
settings and apply it to some of the obstacles in the skatepark.

1. Switch to Design Layer-1.

2. Change the View to Left Isometric.

3. Center the skatepark in the Drawing Area.

4. In the Resource Browser, click on the Files list and select 
Vectorworks Libraries.

5. Navigate to the Textures folder, select Textures_Exterior 
Finishes.vwx, and click Open.

6. In the resource display window, locate the Conc Stained 
Smooth Clear texture.

7. Right-click on the texture and choose Import.

8. Click on the Classes button in the View bar, select the 
Concrete Base class, and click Edit.

9. In the Edit Class dialog, switch to the Other tab, check the 
Texture / Surface Hatch option and choose the Conc Stained 
Smooth Clear texture.

10. Click OK twice to save the changes and exit the Edit Class 
and Organization dialog. 

All of the objects in the Concrete Base class, will now render 
using the Conc Stained Smooth Clear Texture. You will notice 
the texture pattern appears small. Next, we will use the Attribute 
Mapping tool, to adjust the texture mapping.

11. Select the concrete base.

12. Activate the Attribute Mapping tool in the Basic palette. 

13. Choose Plane under New Map Type and click Yes.

14. Click once on the lower level of the skatepark.

15. Enable the Original Repeat mode in the Tool bar.

16. Click and drag the bottom left, blue handle to adjust the scale 
of the texture.

17. When the Scale field is about 2.5, click once to set the scale.

18. Press X once, to switch to the Selection tool.

19. In the Object Info palette, switch to the Render tab and check 
the option for Use World Z For Origin.

20. Now, select the gazebo extension to the concrete base.

21. Activate the Attribute Mapping tool.

22. Choose Plane under New Map Type and click Yes.

23. Click once on the gazebo extension.

24. Adjust the scale of the texture until it is about, 1.5.

25. Switch to the Selection tool and check the Use World Z For 
Origin option in the Object Info palette.

26. Click the Home button in the Resource browser, to view the 
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resources from the current active document.

27. Next, right-click on the Conc Stained Smooth Clear Texture in 
the Resource Browser. 

28. Choose Duplicate.

29. Name the Texture, Conc Stained Smooth Clear-Object Color 
and click OK.

30. Right click on the new Texture in the Resource Browser and 
choose Edit.

31. Under Color, click the Edit button.

32. Under Filter Color, choose Use Object Fill, and click OK

33. Click OK again, to exit the Edit Texture dialog and save the 
changes.

34. Double-click on the ramp group at the bottom of the skate 
park to edit the group.

35. Click and drag the Conc Stained Smooth Clear-Object Color 
from the resource browser to the main body of the ramp.

36. Now, select the ledge and double-click the Conc Stained 
Smooth Clear-Object Color texture from the Resource Browser. 
This is simply an alternate method of applying a texture to a 
selected object.

37. Exit the group.

You will notice the texture appears darker on the tapered ramp. 
This is because the texture is using this object’s current fill color 
with the texture.

38. Double-click on the group of tapered ramp symbols on the 
bottom level of the skatepark. 

39. Then, double-click on one of the symbols within the group. 
Choose to edit the 3D Component of the symbol, and click 
OK.

40. Render in OpenGL if your rendering mode has reverted to 
wireframe.

41. Apply the Conc Stained Smooth Clear-Object Color to all 
objects within this symbol by selecting the texture from the 
Render tab in the Object Info palette.

42. Deselect the objects, then select the small ledge.

43. In the Attributes Palette, set its fill color to Cool Gray 50%. 
You can see that the texture still remains, but takes on the 
objects new fill color automatically.

44. Exit the symbol.

Notice that the mirrored duplicate of this symbol has changed as 
well. This is because any changes made to a symbol, will be 
pushed to all instances of that symbol within a document.
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45. Select the curved ramp between the lower and middle levels, 
and apply the Conc Stained Smooth Clear-Object Color texture 
to is as well.

46. Repeat these steps on the following objects hightlight below 
using the same methods just demonstrated.

You may have noticed the color on the bottom surface of the bowl 
has changed, This occurred when we changes the texture of all 
objects in the Concrete Base class. 

47. To correct this, simply change the texture of the bottom 
surface to the new Conc Stained Smooth Clear-Object Color 
texture from the Texture menu in the Render tab of the Object 
Info palette. The colored fill will now show through again.

48. To adjust the textures size, as we did before, select the 
Attribute Mapping tool.

49. Select Plane, then click OK.

50. Click on the surface of the bottom of the bowl.

51. Scale this texture to around 1.9, then click and switch back to 
the Selection tool.

52. Now let’s apply a new texture to the gazebo roof. Go to the 
Resource Browser and in the File List, choose Vectorworks 
Libraries.

53. Navigate to the Textures folder, select Textures_Exterior 
Finishes.vwx, and click Open.

54. In the Resource Display window, locate the Shingles White 
Texture.

55. Click and drag the texture onto the roof of the gazebo. This 
will import the texture and apply it to the gazebo roof.

56. Click on the Home icon in the Resource Browser, locate the 
Shingles White Texture, right-click, and choose Edit.

57. Under Color, click the Edit button.

58. Under Filter Color, choose Use Object Fill, and click OK

59. Name the texture, Shingles-Object Color.

60. Click OK again, to exit the Edit Texture dialog and save the 
changes.

The Roof now shows the Gray fill color with the texture.
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61. Through the Resource Browser, access the Vectorworks 
Libraries and open the Textures_Metals Plastics and Glass.vwx 
file in the textures folder.

62. Locate the Metal Stainless Steel texture.

63. Apply this texture to the S-shaped rail on the bottom level of 
the skatepark.

64. Double-click one of the Long Rail symbols. Choose to edit the 
3D Component and click Edit.

65. Select the three posts and double-click on the Metal Stainless 
Steel texture to apply it to the posts.

66. Now, select the rail, locate and double-click on the Metal 
Anodized Texture in the Resource Browser to apply it to the 
rail.

67. Click the Exit Symbol button to exit the symbol editing 
window and save the changes.

68. Apply the Metal Anodized texture to the rails on the stairs and 
the tapered surface as shown below.

Creating Textures
Now we will create a new texture resource. Will use a grass 
image for our texture. Then we will adjust the shaders and add a 
displacement mapping.

1. In the Resources Browser, click on the Resources menu and 
choose New Renderworks Texture in…

Note:  If you do not see the New Renderworks Texture in… 
option, choose New Resource in… and select Renderworks 
Texture from the menu.

2. In the Edit Texture dialog, name the texture Grass.

3. Under Color, choose Image.

4. Download the Skatepark Grass.jpg image from the Exercise 
Files section and navigate to the file.

5. Click OK in the Edit Image Color dialog.

6. Set the Reflectivity to Plastic.

7. Under Preview Options, set the Obj Size to 3.

8. Under Size, click the Set By Image button, click and drag the 
sizing marker across the top of the preview image. 

9. Also enter 1.5 for the Feature Size.

10. Under Bump, choose Noise and click Edit.

11. For the Pattern, choose FBM.
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12. Adjust the Strength to 100%.

13. Under Scale, set the Global Percent to 5.

14. Under Options, set Detail to 8.

15. Finally, under Displacement Mapping, set the Height to .025 
and the Detail to High.

16. Click OK and then OK again to create the texture.

17. Now, apply the texture to the site object, by dragging the 
texture from the Resource Browser onto the site.

18. Then adjust the scale using the Attribute Mapping tool. Set 
the scale to about 4.4.

Adding Light Objects
Next, we will add a light object to the Light Post symbol.

1. Double-click the Light Post symbol near the curved stairs in the 
drawing and choose to Edit the 3D Component.

2. Switch to an Orthogonal Projection, by going to View > 
Projection > Orthogonal.

3. Switch to a Left view and render in Wireframe.

4. In the Visualization tool set, activate the Light tool.

5. Enable the third mode, Spot Light mode.

6. Move your cursor over the top of the light post. 

7. Press the Z key to activate the Snap Loupe mode.

8. Click once in the center of the top of the light post. 

9. In the Light Preferences dialog, check the Soft Shadows 
option and click OK.

10. Adjust the angle of the spot light, until the Pan is 90º and the 
Tilt is 45º.

11. Switch to a Top/Plan view.

12. Make sure the Spot Light is pointing in the correct direction. 

13. In the Object Info Palette, set the Spread to 100º, the Beam 
to 50º, the Z to 7.15, and adjust the Tilt to about 37º.
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14. Click the Exit Symbol button to exit the symbol and save the 
changes.

You will see the light object was added to each instance of the 
Light Post Symbol. In this rendered view, you can also still see 
the Wireframe representation of the light objects. 

To disable this, go to Tools > Settings > Vectorworks 
Preferences. In the Display Tab, set Display Light Objects to 
Only in Wireframe. Click OK to return to the drawing. The light 
objects should no longer be visible.

Using Image Props
We will place several image prop objects to represent the plants 
for our planter boxes. Image props are a quick way to represent 
3D objects without having to modeling them.

1. Switch to a Top view and zoom in on the upper planter box.

2. Double-click on the Planter Box symbol and choose to edit the 
3D Component.

3. In the Resource Browser, navigate to the Flower Image Prop, 
in the Symbols/Plugin Objects section. 

Note:  This is a predefined Image Prop object. For more 
information on creating Image Prop objects, please see the 
Further Exploration section.

4. Double click on the Flower Image Prop object.

5. Move your cursor within the planter. Place multiple instances 
on this symbol within the planter. Hold the Back Quote (`) key 
to disable snapping to make it easier to randomly place the 
instances.

6. Select all of the Image Props and set the Z to 3.5 in the Object 
Info Palette.

7. Click the Exit Symbol button.

8. Switch to a Left Isometric view.

9. Zoom out, so you can see both instances of this Planter Box 
symbol.

10. Now, go to View > Rendering > Fast Renderworks.

Fast Renderworks, will render the scene with more detail than 
OpenGL. You will also see shadows. Switch back to an OpenGL 
render mode and repeat this process for the other planters.

Placing Renderworks Cameras
Finally, we will place a Renderworks Camera to quickly define a 
custom view. Then we will render using a Renderworks Style.
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1. Switch to a Top/Plan view and center your view over the lower 
level of the Skatepark.

2. Activate the Renderworks Camera tool in the Visualization 
tool set.

3. Click once in between and to the left of the planter boxes on 
the lower level set the location of the Renderworks Camera.

4. Move the cursor to the right until the Length (L) is about 16. 
click once more to set the direction of the camera.

5. Accept the defaults in the Object Properties dialog and click 
OK.

6. In the Object Info palette, click Display Camera View. The 
view will change to show the view of the Camera.

7. Click the Fine Tune Camera View button in the Object Info 
Palette.

8. Set the Camera Height to 4.25 and click OK.

9. Finally, go to View > Renderworks Styles > Realistic 
Exterior Night Final.

This will render the view using a pre-defined Renderworks Style. 
There are several Renderworks Styles included with 
Renderworks. You can also create your own custom styles for 
your needs. You have now completed the skatepark project.




