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Getting Started with Vectorworks 
Fundamentals

Initial Setup
To ensure consistency when doing these exercises, please take a 
moment to set up your workspace and Vectorworks Preferences. 
This way, we can all start with the same base line. 

First, open a new blank document by going to File > New. 
Choose Create Blank Document and click OK. 

1. Go to Tools > Workspaces > Fundamentals.

2. Go to Tools > Options > Vectorworks Preferences and click 
the Reset button. Accept the “Are you sure…?” dialogue box, 
and select General in the Category list on the left.

3. Next, return to the Vectorworks Preferences (Tools > Options 
> Vectorworks Preferences), and choose the Display tab. 
Then check the option Center on objects after view change.

4. Click OK to close the Vectorworks Preferences.

5. Now we’ll adjust the constraints categories. Go to Tools > 
SmartCursor Settings.

6. Dismiss the “Did you know…?” dialogue box, and click the 
Reset button. Accept the “Are you sure…?” dialogue box, and 
select General in the Category list on the left.

7. Uncheck Snap to Combined Page Area.

8. Click OK to close the SmartCursor setting dialogue box.

9. Last, go to File > Page Setup, uncheck the option Show Page 
Boundary, and click OK to close the Page Setup dialogue box.

10. Next, set the document units. Go to File > Document 
Settings > Units…

11. Set the Units dropdown menu to Inches, and also check the 
Show Unit Mark option.

12. Then tick Fractional for the Rounding Style.

13. Let’s also set the Fractional Display for Dimensions to the 
second style by ticking the second button.

14. Choose 1/16 from the Fraction Precision dropdown menu.

15. Then set the Units dropdown menu under the Area section to 
Square Inches.

16. Last, from the Volume section; set the Unit dropdown menu to 
Cubic Inches and click OK to close the Units dialogue box.

17. Go to File > Save and save this file to your desktop (or 
wherever you would like) with the name “Preferences-file-
setup.”

CPU Case
Now that the file is set up properly, we’ll create the bottom portion 
of the clamshell. From this point forward, we’ll refer to it as the 
CPU case.

1. In the Basic palette, double-click the Rounded Rectangle tool. 
This will open the Create Object dialogue box.

2. Input 15 1/12 for the Width and 10 1/12 for the Height.

3. Be sure Position At Next Click is checked, and choose 
Symmetrical from the Corner dropdown menu. 

4. Also set the Diam X and Diam Y fields to 1” and then click OK.
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5. Since Position at Next Click was checked, you will need to 
click somewhere near the origin (0,0) to create the rounded 
rectangle.

6. This rounded rectangle is the overall size of the CPU case. 
Now lets add some depth.

7. Next, go to the Standard Views menu in the View bar and 
choose Right Isometric.

8. From the 3D Modeling tool set, select the Push/Pull tool. Be 
sure the first mode, Extrude Face, is enabled in the Tool bar.

9. Then move the pointer toward the center of the rounded 
rectangle.

10. Once the rounded rectangle is highlighted, click to begin 
extruding the rounded rectangle face. You should notice the 
pointer has changed to a double-headed arrow.

11. Now press the Tab key to enter the Distance field in the 
Floating Data bar and input 3/8. Press Enter to lock in the 
value.

12. Then click anywhere in the drawing area to create the 
Extrude.

Trackpad
With the overall shape of the CPU case completed, we can now 
add the overall shapes for the trackpad, keyboard, and speakers. 

To do this, we first need to create a working plane on the top face 
of the CPU face.

1. From the 3D Modeling tool set, select the Set Working Plane 
tool. Be sure the second mode, Planar Face mode, is enabled 
in the Tool bar.

2. Then move the pointer to the center of the CPU case. Once 
the cursor cue “Center” is displayed, click once to set the 
working plane. Use the blue highlighting as a visual reference 
so as to not set the working plane to the bottom face of the 

Extrude.

3. To create the trackpad, double-click the Rounded Rectangle 
tool in the Basic palette.

4. In the Create Object dialogue box, set the Width field to 4.5” 
and the Height field to 3”.

5. Next, notice the box position control is rotated to reflect the 
current view (Right Isometric). Choose the bottom center point 
from the box position controls, which is the center point closest 
to the W.

6. Then, choose Symmetrical from the Corner dropdown menu. 
Set the Diam X field to .25”, and the Diam Y value will update 
to match it since the corners are set to be symmetrical.

7.  Check Position At Next Click—if not already selected—and 
click OK.

8. To place the rounded rectangle, move your cursor along the 
bottom left edge on the top surface of the CPU case until you 
see the “Midpoint” cursor cue.

9. Click to set the rounded rectangle. This is the overall shape for 
the trackpad. (Requires Screenshot to clear up any confusion 
about the correct edge)

10. At the moment, the trackpad and the CPU have a common 
edge. Realistically, however, the trackpad bottom edge 
would be offset from the CPU case’s edge. So let’s move the 
trackpad away from the edge some.

11. Switch to the Selection tool in the Basic tool palette, and 
select the trackpad if it is not already selected.

12. Now move the pointer along the common edge of the CPU 
case and trackpad until the pointer changes to a cross and the 
cursor cue “Midpoint” is displayed.

13. Then press and hold your mouse button to pick up and move 
the trackpad based on the selected point.
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14. We are going to move the trackpad one inch away from 
the CPU case edge. To do this (with the mouse button still 
depressed), press the Tab key until your enter the ∆Y field. 
Then enter 1” and hit Enter to lock in the value.

15. Move the pointer along the green dashed axis (Y Axis) until 
the cursor cue “Object / Y / Align Y” is displayed. Then release 
the mouse button to move the trackpad.

Keyboard
The keyboard can be created based on the geometry of the 
trackpad.

1. Move your pointer along the trackpad edge located closest to 
the working plane origin (where the red, blue, and green axes 
meet) until the cursor changes to a cross and the cursor cue 
“Midpoint” is displayed.

2. Then press and hold the mouse button to pick up the rectangle 
by the selected point.

3.  Next, press and hold the Option key (Macintosh) or Alt key 
(Windows), and drag the rectangle along the Y Axis (green 
line). Be sure your cursor stays on the top surface of the CPU 
case.

Notice there is a small plus (+) beside the cursor when you hold 
the Option or Alt key. This indicates that you will be creating a 
duplicate.

4. When you reach the top edge of the CPU case, the cursor cue 
“Midpoint” will be displayed.

5. Release the mouse button to create the duplicate. Then 
release the Option key.

6. In the Object Info palette, choose the top center point from 
the box position controls, which is the center point opposite its 
current point.

7. Now change the Width field to 11 3/8” and the Height field to 4 
3/4”. Then press Enter.

It is important to choose the position point from the box position 
controls before entering the new width and height, as the set 
point will be constrained during the resizing of an object. In this 
case, it keeps the rounded rectangle centered.

8.  Also choose Symmetrical from the Corner dropdown menu 

and set the Diam X field to ¼” and press Enter. Remember, the 
Diam Y will update automatically because all corners are set 
to be symmetrical. This rectangle is the overall shape for the 
keyboard.

9. Just as with the trackpad, realistically the keyboard should be 
offset slightly from the top edge of the CPU case. Let’s do this 
now.

10. With the keyboard selected, go to Modify > Move > Move 
3D. Since we are currently using a working plane, tick the 
Working Plane option.

11. Input a value of -1 ¼” in the Y Offset field, and then press 
OK. The keyboard will be moved from the CPU edge along the 
same green axis as the trackpad.

Speakers
We can now create the speakers.

1. Select the Zoom tool from the Basic tool palette.

2. First, click near the center of the keyboard. Then move your 
cursor downward and to the right until the right side of the 
keyboard and part of the CPU are inside the marquee.

3. Click once to zoom in on the area inside the marquee.

4. Next, select the Rectangle tool from the Basic palette. Be sure 
the first mode, Rectangle mode, is enabled.

5. Now move the cursor upward along the right edge of the 
keyboard until the cursor cue “Arc” is displayed. If you still have 
not zoomed in close enough, press the Z key to evoke the 
Snap Loupe and find the Arc point.

The Snap Loupe feature zooms in temporarily on an area around 
the current mouse position in order to make snapping more 
precise. Regardless of the tool used, once the mouse button is 
depressed, the Snap Loupe will be revoked.

6. Click to set the first point of the rectangle.
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7. Once again, move the mouse cursor along the right edge of 
the keyboard, but this time move downward until you receive 
the “Arc” cursor cue near the bottom right corner. Again, use 
the Snap Loupe if necessary.

8. Do not click on this point, but hold your cursor over the point 
until the smart point is acquired. (Once a small red box 
appears around the point the smart point is acquired. You can 
also manually acquire the smart point by pressing the T key.)

9. Now, move your cursor horizontally away from the smart point 
toward the right edge of the CPU case. You should notice a red 
dashed line extending from the smart point. This is called the 
extension line. 

10. Continue to move along the extension line until you reach the 
CPU edge. Once the cursor cue “Object / Align Y / Align Start 
Z” is displayed, click to set the rectangle.

Next, we need to decrease the size of the speaker slightly and 
also offset it from the CPU edge.

1. Switch to the Offset tool in the Basic tool palette. Be sure the 
first mode, Offset by Distance, and the fourth mode, Offset 
Original Object mode, is enabled in the Tool bar.

2. Also input a value of ¼” in the Distance field located in the 
Tool bar.

3. Then click once inside the selected rectangle to create the 
offset. This is the overall shape of the right speaker.

The left speaker can be created quickly by using the Mirror tool.

4. First tap the X key twice to deselect the right speaker and 
switch to the Selection tool.

5. Next, go to View > Zoom > Fit to Objects or click the Fit 
to Objects shortcut in the View bar. (Or use the Cmd + 6 
[Macintosh] or Ctrl + 6 [Windows] keyboard shortcut.) You 
should now see all of the CPU case in the drawing area.

6. Now reselect the right speaker and then choose the Mirror tool 
from the Basic tool palette. Be sure the second mode, Mirror 
and 

7. Move the cursor to the top edge of the CPU case to the point 
where it intersects with the working plane Y Axis (Green Axis 
line). 

8. When the cursor cue “Midpoint” is displayed, click to set the 
first point of the mirror axis line.

9. Now hold the Shift key and move the cursor along the Y Axis. 

10. Once the cursor cue “Y” is the displayed, click to set the 
mirror axis. The speaker is then mirrored to the left side. Now 
we have our overall shape for the left speaker.

CPU Detailing
The shapes we’ve created to represent the trackpad, keyboard, 
and speakers would not set flush against the CPU top surface. 
On most laptops these objects are indented in the CPU case. So 
we’ll do this now and also create a cutout for the display hinge.

1. First, select the Push/Pull tool from the 3D Modeling tool set. 
Be sure the first mode, Extrude Face mode, is enabled.

2. Click the left speaker to start extruding the object.

3. Press Tab to enter the Distance field in the Floating Data bar.

4. Input -1/16” and press Enter to lock in the value.

5. Click to create the Extrude.

6. Repeat these steps for the right speaker, trackpad, and 
keyboard.

Now we are going to subtract these extrudes from the CPU case.

7. Tap the X key once to switch to the Selection tool.

8. Go to Edit > Select All. Now all of the objects are selected.

9. Next, right-click on the CPU case and choose Subtract Solids.

10. In the Select Object dialogue box, use the arrows to highlight 
the CPU case. Then click OK.
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The other extrudes will be subtracted from the highlighted object. 
After clicking OK, notice the CPU case, which was an extrude, is 
now a solid subtraction.

OK, Let’s cut out a space for the display hinge.

1. Select the Rectangle tool from the Basic palette. Then select 
the third mode, Side Center and Opposite Corner Rectangle 
mode.

2. Now choose Automatic from the Layer Plane dropdown menu 
in the View bar.

3. Move your cursor to the midpoint of the top edge of the CPU 
case.

4. Once the top face of the case is highlighted blue and the 
cursor cue “Midpoint” is displayed, click to start drawing the 
rectangle.

We need the width of the hinge to match the keyboard width, 
which is 11 3/8”. With the current mode we are using to draw the 
rectangle, we need to input half of this width.

5. Press the Tab key to enter the ∆ X field and input (11 3/8)/2.

6. Press the Tab key once more to enter the ∆ Y field, and input 
-1/2 and then press the Enter key.

7. Now click in the drawing to set the rectangle.

8. Next, move your cursor inside the newly created rectangle 
and, once the rectangle is highlighted red, click to start your 
Extrude.

9. We need to subtract this rectangle from the CPU case: Hold 
the Option key (Macintosh) or the Alt key (Windows) and move 
the cursor downward.

10. Be sure the solid is extruded past the bottom surface of the 
CPU case, and while still holding the Option key (Macintosh) 
or Alt key (Windows), click to subtract this solid from the CPU 
case.

CPU Case: Fillets
The CPU case is starting to come together nicely. Let’s add a few 
fillets to the corners to give it a sleeker appearance.

1. Change the view to the Lower Right Isometric by choosing this 
option from the Standard Views dropdown menu in the View 
bar.

2. Choose the Extract tool from the 3D Modeling tool set. Be 
sure the Extract Surface mode is enabled in the Tool bar.

3. Then click the Extract Preferences button in the Tool bar.

4. Check the option Select Faces and click OK to close the 
dialogue box.

5. Now select the bottom face of the CPU case. Use the red 
highlighting as a visual reference to verify that you are 
selecting the bottom face and not the top face.

6. Once the correct face is selected, click the green checkmark 
in the Tool bar to complete the action. There should now be a 
NURBS surface on the bottom of the CPU case.

7. Next, select the Push/Pull tool from the 3D Modeling tool set. 
Make sure the first mode, Extrude Face mode, is enabled.

8. Then move your cursor to the NURBS Curve at the bottom 
of the CPU case and click once it is highlighted to start the 
Extrude.

9. Press the Tab to enter the Distance field and input a value of 
3/16” and then press the Enter key to lock in the value.

10. Now click anywhere in the drawing to complete the Extrude. 
This is the part of the CPU case we are going to fillet.

11. Use the Zoom tool in the Basic tool palette to zoom in on one 
of the corners of the CPU case. 

12. From the 3D Modeling tool set, choose the Fillet Edge tool 
and click the Fillet Edge Preferences button in the Tool bar.
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13. In the Fillet Edge Preferences, check the options Select 
Tangent Entities and Select Faces.

14. Also change the Radius field to 3/16”. Then click OK to close 
the dialogue box.

15. Now select the bottom face of the latest extrude we created.

16. Once the surface is highlighted, click the green checkmark in 
the Tool bar to complete the operation. The Object Info palette 
should now display Fillet.

17. Tap the X key twice to deselect the Fillet.

18. Then click Fit to Objects in the View bar (or use the Cmd + 6 
[Macintosh] or Ctrl + 6 [Windows] keyboard shortcut) to view 
the whole CPU case in the drawing area.

19. Go back to the View bar and select Right Isometric from the 
Standard Views dropdown menu.

20. Again use the Zoom tool in the Basic tool palette to zoom in 
on any corner of the keyboard.

21. Next, select the Fillet Edge tool from the 3D Modeling tool 
set and click the Fillet Edge Preferences button in the Tool 
bar.

22. This time, make sure that Select Faces is unchecked but that 
Selected Tangent Entities is checked.

23. Set the Radius field to 1/8” and then click OK to close the 
Preferences.

24. Select the bottom edge of the keyboard.

25. Now click the green checkmark in the Tool bar to complete 
the operation.

Display Case 2D Geometry
The CPU case is nearly complete, with the exception of the keys, 
which we’ll come back to later. Let’s move on to creating the 
general shapes for the display case.

To keep things organized, we’re going to create the display on a 
separate design layer.

1. Go to Tools > Organization and choose the Design Layers 
tab or select the Layers button from the View bar.

2. To help with organization, let’s name the active layer. Select 
Design Layer-1, and click the Edit button.

3. In the Edit Design Layers dialogue box, type “CPU laptop” in 
the Name field and click OK.

4. Now let’s create a new design layer. To do so, click the New 
button in the Organization dialogue box.

5. Name this layer “Screen laptop,” and click OK once to return to 
the Organization dialog box.

6. Change the visibility of the CPU laptop layer by clicking the 
middle visibility column to the left of the design layer name. 
The icon will change to an X to indicate the layer is invisible.

7. Click OK to close the Organization dialog box.

8. Now go to View > Standard Views > Top/Plan.

9. Select the Rectangle tool and create a rectangle of any size 
anywhere in the current drawing area.

10. Then go to the Object Info palette and input a value of 15 ½” 
in the Width field and 10 ½” in the Height field.

11. Click the Fit to Objects button in the View bar.

12. Next, select the Fillet tool in the Basic tool palette and select 
the third mode, Trim and Fillet mode.

13. Set the Fillet Radius to ½” in the Tool bar.

14. Since all of the corners are to have the same fillet radius, we 
can simply double-click the rectangle to fillet all four corners at 
once. 
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Normally you would need to select the intersecting lines to 
indicate which corner to fillet. Notice in the Object Info palette the 
Rectangle 

1. Now switch to the Offset tool in the Basic tool palette. Be sure 
the first mode, Offset by Distance mode, and the third mode, 
Duplicate and Offset mode, are selected.

2. Additionally, set the Distance field to 1/16”.

3. We need to create two offsets, so move your cursor toward the 
center of the polyline and click twice. You should now see three 
polylines.

4. If the smallest offset polyline is not already selected, press the 
X key to switch to the Selection tool and select it now.

5. In the Object Info palette, select top center point in the box 
position controls.

6. Then change the ∆Y field to 10” and press Enter.

7. Now switch to the Zoom tool and draw a marquee around the 
top left corners of the three polylines.

8. With the smallest offset polyline still selected, choose the 
Offset tool from the Basic tool palette.

9. Set the Distance field to ½” in the Tool bar, and click the area 
inside the selected polyline.

10. With the next offset selected, return to the Distance field in 
the Tool bar and input 1/16”.

11. Click anywhere inside the current offset polyline to create one 
last polyline.

Display Case 3D Geometry
It’s time now to convert the 2D geometry for the display case into 
3D geometry. Before we begin, to make things easier to see, we’ll 
apply some colors to the current 2D geometry.

1. Press the X key to activate the Selection tool and the select 
the smallest polyline, if it is not already highlighted.

2. Next, click the solid fill color box and select any shade of green 
to apply to the polyline.

3. Now select the next closest polyline and apply a shade of blue.

4. Continue in sequential order with the polylines and apply any 
shade of following colors in order: red, dark gray, and then light 
gray.

If this display were to remain in 2D, the visual representation 
seen here would be fine; however in 3D we will need to apply a 
different thickness for each colored polyline. For this reason, we 
cannot have the polylines overlapping each other. So, next we’ll 
clip the polylines to remove any unneeded or hidden geometry.

5. Hold the Shift key and select the two largest polylines (light 
gray and dark gray polylines). Then go to Modify > Clip 
Surface.

The Clip Surface command trims the bottom object in a selection 
so that any areas overlapped by the top object are cut out of it.

To see how the dark gray polyline was clipped from the light gray 
polyline, click and drag the light gray polyline to the left. Then 
press Command + Z (Macintosh) or Control + Z (Windows) to 
undo.

6. Now hold the Shift key and select the dark gray polyline and 
the red polyline.

7. Then go to Modify > Clip Surface.

8. Next, hold Shift and select the red polyline and the blue 
polyline. 

9. Then, instead of using the menu command, right-click on the 
red polyline and choose Clip Surface.

10. One last time, hold Shift and select the blue polyline and the 
green polyline.

11. Right-click on the blue polyline and choose Clip Surface. 
Now each polyline has its own defined space without any 
overlapping.

Now we can begin creating the 3D geometry.

1. Select the light gray polyline and go to Model > Extrude.

2. In the Create Extrude dialog box, set the Extrusion field to 
1/8”, and then click OK.

3. Next, select the green polyline and go to Model > Extrude.



11 | Vectorworks Fundamentals 2014 Getting Started Guide

4. This time, set the Extrusion field to 1 mm and then click OK.

5. Select the blue polyline and use the keyboard shortcut 
Command +E (Macintosh) or Control + E (Windows) to extrude 
the polyline.

6. Input 1.5 mm in the Extrusion field and click OK.

7. Now extrude to two remaining polylines. Extrude the red 
polyline 2 mm and extrude the dark gray polyline 2.5 mm.

Now let’s see the display in a rendered 3D view.

1. Tap the X key twice to deselect all objects. Then press the 
Fit to Objects button in the View bar (or use the Cmd + 6 
[Macintosh] or Ctrl + 6 [Windows] keyboard shortcut) to fit the 
view to the whole screen.

2. Also go to the Standard Views dropdown menu and choose 
Left Isometric.

3. Use the Zoom tool and draw a marquee around one of the 
display corners.

4. To render this view, go to View > Rendering > Open GL.

5. You can also improve the quality of the rendering by going to 
View > Rendering > Open GL Options.

6. Change the Detail dropdown menu to High and the check the 
option Use Anti-Aliasing.

7. Click OK. You should notice the rounded edges appear much 
smoother.

Positioning the Display Case
Since we’ve got the majority of the display case completed, we 
can line up the display case with the CPU case.

1. First, return to a Wireframe rendering by going to View > 
Rendering > Wireframe.

2. Then go to Tools > Organization and select the far-left 
visibility column for design layer CPU laptop to make this layer 
visible again. Click OK to close the dialogue box.

3. Next, go to View > Standard Views > Top/Plan to change the 
view of the active design layer, Screen laptop.

4. Go to View > Align Layer Views to change the CPU laptop 
layer to match the Screen laptop layer.

5. So that we can see the entire CPU case and Display case, 
click the Fit to Objects button in the View bar.

6. You should see that the Display case and CPU case and are 
not lined up properly. To fix this, go to Edit > Select All to 
select all parts of the Display case.

7. Then go to Modify > Group. As a group, all of the parts of the 
display case can be moved much more easily.

8. Switch to the Selection tool in the Basic palette.

9. Move the pointer to the top center of the smallest offset. (See 
video if this is unclear.) When the cursor cue “Midpoint” is 
displayed, click and hold your mouse button to pick up the 
group by this point. You may need to use the Snap Loupe (Z 
key) to acquire this point. 

10. Then drag the group along the top edge of the CPU case that 
is closest to the keyboard.

11. When the cursor cue “Midpoint” is displayed, release the 
mouse button to complete the move.

12. Now we need to line up the CPU case and the Display case 
properly in the Z direction.

13. Choose Right Isometric from the Standard Views dropdown 
menu in the View bar.

14. Then go to View > Align Layer Views to align the CPU case 
layer to the same view.
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15. Again, press Fit to Objects in the View bar.

16. Now use the Zoom tool to zoom in on the laptop corner 
closest to you. 

The CPU case and display case are overlapping. In reality, only 
the top surface of the CPU case and the bottom surface of the 
display case should be touching.

1. To fix this, with the group still selected, go to Modify > Move > 
Move 3D.

2. In the Move dialogue box, set the X and Y fields to 0 and the 
Z field to 3/8”. Remember 3/8” is the thickness the CPU case 
was originally extruded.

3. Click OK to complete the move.

Display Case Fillet
We’re almost done with the display case, but just as we did 
with the CPU case, let’s fillet some of the edges for a sleeker 
appearance.

1. Click the Fit to Objects button in the View bar so that the 
entire laptop is in the drawing area.

2. Then switch to the Zoom tool and draw a marquee around the 
top right corner of the laptop to zoom in on this area.

3. We’ll need to use the existing geometry of the Display case to 
create the fillets. So, press the X key to switch to the Selection 
tool and double-click the display to enter the Edit mode for this 
group.

So that we can see the different display case parts more easily, 
we will now render this view in Open GL.

4. Select Open GL from the Render modes dropdown menu in 
the View bar  (or use the keyboard shortcut Command + Shift 
+ G [Macintosh] or Control + Shift + G [Windows].

5. Now choose the Extract tool from the 3D Modeling tool set.

6. Enable the second mode, Extract Curve mode, in the Tool bar 
and then click the Extract Preferences button.

7. Check the options Select Tangent Entities and Create Planar 
Objects.

8. Also uncheck Select Faces if it is checked, and then click OK 
to close the dialog box.

9. Select the top outermost edge of the dark gray Extrude.

10. Then click the green checkmark in the Tool bar to complete 
the operation. 

The resulting object should be a group. Since Create Planar 
Objects was checked in the Extract Preferences, this group 
consists of objects like lines and arcs to create this one shape. 
We’ll need to compose objects into one polyline.

11. Next go to Modify > Ungroup. Notice the Object Info palette 
shows eight objects are selected.

12. To compose these objects into one polyline, go to Modify > 
Compose.

13. Now switch to the Push/Pull tool in the 3D Modeling tool set. 
Be sure the first mode, Extrude Face mode, is enabled.

14. Then move your cursor over the newly created polyline. Once 
the surface is highlighted, click to start extruding.

15. Press the Tab key to enter the Distance field, and enter a 
value of 1/16”. Then press the Enter key to lock in the value.

16. Click anywhere in the drawing to create the Extrude. This will 
be the top of the display case.

17. To fillet this extrude, from the 3D Modeling tool set select the 
Fillet Edge tool and set the Radius field in the Tool bar to 1/8”.

18. Click the Fillet Preferences button in the Tool bar. Make sure 
Select Tangent Entities is checked. Click OK.

19. Select the top edge of the highlighted extrude.

20. Then click the green checkmark in the Tool bar to complete 
the operation.
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21. To return to the design layer, click the Exit Group button.

 Rotating the Display Case
The display case is completed, so it’s time to rotate it to an open 
position.

1. So that the entire laptop is visible in the drawing area, click the 
Fit to Objects button the View bar.

2. Next, choose Right from the Standard Views dropdown menu 
in the View bar.

3. Go to View > Align Layer Views to align the CPU laptop layer 
to the same view.

4. Select the Zoom tool and draw a marquee around the right 
corner of the laptop.

5. Now switch to the Selection tool and select the Display case if 
it is not already highlighted.

6. Then select the Rotate tool from the Basic tool palette. Be sure 
the first mode, Rotate mode, is enabled in the Tool bar. 

7. Move your cursor to the bottom right corner of the display 
case, and click when the cursor cue “Endpoint” is displayed to 
set the point for the rotation axis.

8. Hold the Shift key and move your cursor upward. Once the 
cursor cue “Y” is displayed, click again to set the rotation axis.

9. To rotate the display to an open position, hold the Shift key and 
move the cursor to the right until you see the cursor cue “X.”

10. Then click once to complete rotating the display case to an 
open position.

The laptop is opened to the correct angle but is sitting above the 
hinge location. The bottom edge of the display needs to be move 
down to match the bottom edge of the hinge.

11. With the display case still selected, go to Modify > Move > 
Move…

12. In the Move Selection dialogue box, set the X Offset to 0 and 
the Y Offset to -3/8” and click OK to move the display case.

Creating the Hinge
The Display case is rotated in reference to the hinge, so we need 
to return to the CPU case to create the hinge quickly.

1. In the View bar click the Layers button to open the 
Organization dialog box.

2. Click in the blank area just to the left of the CPU laptop design 
layer to make the CPU laptop layer the active layer.

3. Also click in the middle visibility column for the Screen laptop 
layer, so that it is invisible. Then click OK to return to the 
drawing area.

4. Now choose Rear Right Isometric from the Standard Views 
dropdown menu on the View bar, and click the Fit to Objects 
button in the View bar as well.  

5. We need to be a little closer to the hinge area, so manually 
input 100% in the Zoom field in the View bar. This will give us 
the best angle of the CPU case to create the hinge.

6. Choose the Rectangle tool from the Basic palette. Be sure the 
second mode, Center and Corner Rectangle mode, is enabled 
in the Tool bar.

7. Next, set the Active Plane dropdown menu to Automatic if it is 
not already set.

8. Click OK to the “Did You Know?” dialog box.

9. Then move your cursor toward the center of the open face for 
the hinge cutout.

10. Click once the face is highlighted blue and the “Center” cursor 
cue is displayed to start the rectangle.

11. Now, move the cursor to the right along the bottom edge 
of the highlighted face until the “Endpoint” cursor cue is 
displayed.

12. Click once to set the rectangle.
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13. Move the cursor toward the center of the newly created 
rectangle and once the face is highlighted, click to begin the 
extrusion.

14. Press the Tab key to enter the Distance field for the Floating 
Data bar and input a value of ½” and then press the Enter key 
to lock in the value.

15. Click once to complete the extrusion.

16. With the hinge still selected, click the Fill Style color box in the 
Attributes palette and apply a medium gray color to the hinge.

17. To see how the hinge looks, choose Open GL from the click 
mode dropdown menu.

Keys 2D Geometry
The laptop is almost completed but we need to add a keyboard 
and speakers to the CPU case.

1. From the View bar choose Top/Plan from the Standard Views 
list.

2. Press the X key twice to deselect all objects. Click the Fit to 
Objects button in the View bar as well.

3. Then click the Layers button in the View bar to access the 
Organization dialog box. 

4. We will be putting the keys on a separate design layer, so click 
the New button.

5. In the New Design Layer dialog box, name the new layer 
“Keys” and click the OK button twice to return on the drawing 
area.

6. Now select the Zoom tool and draw a marquee around the 
cutout for the keyboard on the CPU case.

7. Select the Rectangle tool and be sure the first mode, 
Rectangle mode, is enabled in the Tool bar.

8. Next, move your cursor to the top left corner of the keyboard 
cutout.

9. Press the Z key to evoke the Snap Loupe. Just inside of the 
actual corner of the keyboard cutout should be find an Arc 
Center snapping point.

10. Click once you have located this point to start the rectangle. 
Notice the Snap Loupe is revoked as soon as the mouse 
button is depressed.

11. Now move your cursor to the bottom right corner of the 
keyboard cutout and repeat the last two steps to find the Arc 
Center point. Once you click on the Arc Center point, the 
rectangle is created.

12. Choose the Fill Style color box in the Attributes palette and 
apply any shade of purple to this rectangle.

13. The majority of the keys on a keyboard have the same 
measurements, so we can use the Even Divide command to 
give us a good starting point.

14. Press the X key and select the purple rectangle if it is not 
already selected.

15. Then go to Modify > Drafting Aides > Even Divide.

16. Set the Number of Divisions in the Width field to 14 and the 
Number of Divisions in Height field to 6. Click OK. Notice the 
Object Info palette now displays 84 rectangles.

Now we can start to combine some of these rectangles to create 
the large keys on the keyboard.

17. Tap the X key twice to switch to the Selection tool and 
deselect all the rectangles.

18. On the bottom row of rectangles select the fifth rectangle from 
the left.

19. Next, hold the Shift key and select the next four rectangles to 
the right of the rectangle you just selected.

20. Now go to Modify > Add Surface. This is the Space bar.

21. In the row that is second from the bottom, hold the Shift key 
and select the first two rectangles on the left side.
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22. Go to Modify > Add Surface.

23. Repeat the last two steps for first two rectangles on the right 
side of the same row. These are the Shift keys.

24. Once more, repeat these steps for the first two rectangles on 
the right side in the row above the Shift keys. This is the Enter 
key.

The basic shape of the keys is now defined but we need to add 
some spacing between these keys to make them look more 
realistic.

1. Use the keyboard shortcut Command + A (Macintosh) or 
Control + A (Windows) to select all objects on the active layer.

2. Now hold the Shift key and click the Space bar, Shift key and 
Enter key to deselect these objects. The Object Info palette 
should display 73 rectangles. We are now going to add spaces 
around all 73 rectangles at once.

3. In the Object Info palette, be sure the Center point is the select 
point in the box position controls.

4. Next, input a value of 11/16” in the Width field and value of 
5/8” in the Height field. Then press the Enter key.

The measurements for the Space bar, Shift keys, and Enter keys 
must be set individually. 

5. First select all four of the keys mentioned above, and verify the 
Center point is selected in the box position controls.

6. Then select each key individually and input the following 
values in the Object Info palette: Shift keys and Enter key: ∆X 
= 1 1/2”, ∆Y = 5/8”, Space bar: ∆X = 3 13/16”, ∆Y = 5/8”

Keys 3D Geometry
The 2D geometry for the keys is now completed, so we need to 
create the 3D geometry and position them correctly on the CPU 
case.

1. Press Command + A (Macintosh) or Control + A (Windows) to 
select all of the keys.

2. Now go to Model > Tapered Extrude.

3. In the Create Tapered Extrude dialog box, set the Height field 
to 1/16” and the Taper Angle field to 45 degrees and click OK 

to create the tapered extrude object.

Notice that all of the keys are now one object. This is because 
all of the keys were selected at the time of the operation. That 
quickly we created the 3D geometry for the keys! Now we just 
need to move the keys to the correct Z height.

4. From the Standard Views dropdown menu in the View bar, 
select Right Isometric.

5. Then go to View > Align Layer Views so the CPU laptop layer 
is aligned with the Keys layer.

6. With the keys still selected, go to Modify > Move > Move 3D.

7. Input 0” in the X’ and Y’ Offset fields and ¼” in the Z’ Offset 
field. Then click OK to move the keys into their proper position.

Speaker Detailing
The last thing we need to do to complete this laptop 3D model is 
create the speakers. 

1. First switch to a Top/Plan view by going to View > Standard 
Views > Top/Plan.

2. Now, go to View > Align Layer Views so that the CPU case is 
now in Top/Plan view as well.

3. Press the X key twice to deselect all objects, and then click the 
Fit to Objects button on the View bar.

As we have done throughout this exercise, we will place the 
speakers on their own layer to help with organization.

4. Click the Layer button in the View bar, and then click the New 
button.

5. Name this new design layer, “Speakers.” Then click OK twice 
to return to the drawing area.

6. Next, use the Zoom tool and draw a marquee around the left 
speaker cutout to zoom to this area.
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7. Switch to the Rectangle tool in the Basic tool palette. Be sure 
the first mode, Rectangle mode, is enabled.

8. Click the top left corner of the speaker cutout when the 
“Endpoint” cursor cue appears to start the rectangle.

9. Then click the bottom right corner of the speaker cutout when 
the “Endpoint” cursor appears to complete the rectangle.

10. Now select the Circle tool from the Basic palette, and be sure 
the first mode, Circle by Radius mode, is enabled.

11. Click anywhere inside the newly created rectangle to start 
drawing the circle.

12. Press the Tab key to enter the Length field and input 1/16”. 
Then press the Enter key to lock in the value.

13. Now click anywhere in the drawing to place the circle.

14. With the circle still selected, go to Edit > Duplicate Array.

15. In the Duplicate Array dialog box, set the Shape dropdown 
menu to Rectangular Array.

16. Set the Number of Columns field to 6 and Number of Rows 
field to 15.

17. Then input ¼” for the Distance Between Columns field and 
-1/4” for the Distance Between Rows field. 

18. Make sure Retain and Leave Selected are both checked on 
the bottom right.

19. Then click OK to create the Array.

20. So that these circles are easier to move as a unit, go to 
Modify > Group.

At the moment your group most likely does not sit inside the 
rectangle we drew earlier. It will only take a few steps to align 
these objects exactly.

1. Your group of circles should already be highlighted, so press 
the X key to switch to the Selection tool. Then hold down the 
Shift key and click the rectangle behind the group.

2. Next, go to Modify > Align > Align/ Distribute.

3. To the right of the Preview box, check the Align option and tick 
the option Center.

4. Below the Preview box, you also will want to check the Align 
option and tick the Center option.

5. Then click OK to align the two objects.

6. Now, hold the Shift key and click the rectangle to deselect this 
object.

7. With just the group selected, go to Modify > Ungroup.

8. Then hold the Shift key and re-select the rectangle.

9. Next, right-click on the any of the highlighted objects and 
choose Clip Surface from the context menu. 

10. Press the Delete key to remove the unneeded circles. Now 
we have just one polyline. Select this polyline.

11. Go to Model > Extrude and set the Extrusion field to 1/16” to 
add depth to the speaker.

Now we need to properly position the speakers on the CPU case, 
then mirrored to the other side of the CPU case.

12. Switch to a Right Isometric view by selecting Right Isometric 
from the Standard Views dropdown menu.

13. Then go to View > Align Layer Views so that the other 
visible layers are changed to a Right Isometric view as well.

14. Press the X key to switch to the Selection tool and select the 
speaker if it is not already highlighted.

15. Then go Modify > Move > Move 3D and set the X’ and Y’ 
Offset fields to 0. Set the Z’ Offset field to 5/16” and click OK 
to move the speaker to its correct position.

All we have left to do is mirror the speaker, and our laptop model 
is complete.

1. Choose Top/Plan from the Standard View dropdown menu.

2. Then go to View > Align Layer Views to change the other 
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visible layers as well.

3. Press X twice to deselect the speaker. Additionally, click the Fit 
to Objects button on the View bar.

4. With the speaker once again selected, choose the Mirror tool 
from the Basic tool palette. Be sure the second mode, Mirror 
and Duplicate mode, is enabled in the Tool bar.

5. Now, move your cursor toward the center of the top edge of the 
CPU case.

Click once the cursor cue “Midpoint” is displayed.

Then hold the Shift key and move your cursor downward and 
click again when the cursor cue “Vertical” is shown to place the 
duplicate speaker on the right side of the CPU case.

Viewports
That’s it! Our laptop model is complete. Now let’s change the 
colors to something more appropriate for a laptop and create one 
Open GL viewport and one Hidden Line rendering viewport.

1. Click the Layer button in the View bar.

2. In the Organization dialog box, make the Screen laptop layer 
visible by clicking the far left visibility column for that design 
layer.

3. Next, click the New button and name this model “Laptop 
complete.”

4. Then click OK twice to return to the drawing layer.

5. Now go to View > Layer Options and choose Show/Snap/
Modify Others.

6. Go to Edit > Select All.

7. In the Object Info palette, choose “Laptop complete” from the 
layer dropdown menu.

8. Now switch to a Right Isometric view from the Standard Views 
dropdown menu in the View bar.

Let’s see what our laptop looks like rendered and apply some 
appropriate colors.

1. Click Fit to Objects in the View bar.

2. Select Open GL from the Render modes dropdown menu in 
the View bar.

As you can see, the display still has several colors to it. You can 
choose can keep these colors, or you may change the color of 
any part of the laptop by using the Attributes palette. Remember, 
some of these objects are in groups, so you will need to double-
click the group first to enter the editing mode and then apply 
different colors to different objects within the group once you have 
your colors set. We can create two quick viewports.

3. Go to View > Create Viewport. Select New Sheet Layer from 
the Create On Layer list and name it Sheet Layer 1. 

4. Click OK twice to close the dialog boxes. 

5. You should have one large viewport on a Sheet layer. This 
viewport is too large for the page boundary. So with the 
viewport selected, change the scale in the dropdown menu in 
the Object Info palette to 1:4.

6. Then position the viewport so that it sits within the page 
boundary in the top half of the page.

7. Now let’s duplicate this viewport. Hold the Option key 
(Macintosh) or Alt key (Windows) and click and drag the 
current viewport downward, making sure it’s still within the 
page boundary.

8. When you are happy with the placement, release the mouse 
button.

9. Next, in the Object Info for the duplicate viewport, change the 
View dropdown menu to Left Isometric and the Background 
Render dropdown menu to Hidden Line.

10. Finally, hold the Shift key and select both viewports.

11. Then in the Object Info palette click the Update button.

Here’s the final product:
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Creating a Twist Table

In this addendum, we are going to create a twist table using more 
solid modeling operations. This time, instead of going through 
each document setting we’ll just used the attached exercise file 
(Gsg-2014-f-twisttable-start). 

1. Download or copy this file to your desktop. In Vectorworks, go 
to File > Open. Then select the exercise file from your desktop 
and click the Open button. 

You should notice the page boundary orientation is now set to 
landscape and the units are millimeters.

2. Now that we have the same starting point, double click the 
Rectangle tool in the Basic palette. This will open the Create 
Object dialog box. 

3. In the Width field input a value of 1000mm and do the same 
for the Height field. 

4. Also choose the center mark on the box position matrix. 

5. We want this rectangle to be placed at the center of the 
drawing area, so uncheck the option Position At Next Click. 

6. Now we can input 0 in the X and Y fields to center rectangle. 
To create the rectangle click OK.

7. Next, in the Snapping palette double click the category Snap 
to Distance and verify that the Snap By option is set to 25%. 

This means that we will receive snap points at 25% of the total 
length of an object on a straight or curved line, polygon edges, 
wall edges, and other linear objects. 

8. Also select the Grid category and verify the options Show 
Grid and Show 3d Z Axis are checked. then click OK. 

If you move your cursor to the top right corner of the rectangle 
you will be able to see the distance snap points here. OK.

We’re going to use this rectangle along with the distance 
snapping to create the legs for the twist table. 

9. To begin, click the Fit to Object button in the view bar so that 
you have a good view of the rectangle. 

10. Then, select the 3D Locus tool in the 3D Modeling tool set. 

11. Now hover your cursor over the top left corner of the 
rectangle. You should see that there is a distance snapping 
point just to the right of this corner. 

12. When you move your cursor to this point, the cursor cue, 
Along Line, should be displayed. Click this, snap point to place 
the 3D locus point. 

13. Also click the bottom left corner of the rectangle to place 
another 3d locus point. 

14. Additionally, with the last created 3D locus point still selected, 
set the Z field in the Object Info palette to 500 and press Enter 
to lock in the value. 

15. Next, use the Flyover tool to get a side view of these 2 locus 
points. Notice the lasted created locus point sits 500mm above 
the layer plane. 

16. Let’s connect these 2 locus points, using the NURBS Curve 
tool in the 3D Modeling tool set. 
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17. Once you have the tool activated, click one of the 3D locus 
points. Then double click the other to create the NURBS

18. Next, double click the Circle tool in the Basic palette. 

19. When the Create Object dialog box appears, set the 
Diameter field to 12 and click OK to create the circle. 

20. Now press the X key on your keyboard to switch to the 
Selection tool. Hold the Shift key and click the previously 
draw NURBS curve. You should now have both the NURBS 
curve and the circle selected. 

21. Then, go to Model > Extrude Along Path. Make sure the 
NURBS curve is highlighted as the path object and click OK 
to create the Extrude Along Path. This will serve as one of the 
legs for our twist table.

22. Let’s create the rest of legs by going to Edit > Duplicate 
Array. 

23. Choose Circular Array from the Shape drop down menu. 
Then set the Number of Duplicates field to 11. 

24. Since we want the to be created evenly in a circle set the 
Angle Between Duplicates field to 360/12. This will create the 
appropriate angle for 12 objects evenly spaced in a complete 
circle. 

25. Also make sure the Circle Center Point X and Y fields are 
both set to 0. 

26. Additionally, choose Use Duplication Angle from the Rotate 
Duplicates section. 

27. Last check the options Retain and Leave Selected in the 
Original Object section. Now click OK to create the duplicate 
extrude along path objects. The Object Info Palette should 
show 12 Extrude Along Path objects are selected. 

28. So that we can treat all of these objects as one, go to Model 
> Add Solids to create one large solid addition from the 12 

extrude along path objects. Notice the Object Info palette now 
shows Solid Addition.

At the moment, we have created all of the legs for the table, 
however all of the legs are still straight. 

29. To create a slight curve to these legs, first select the 3D 
Locus tool from the 3D Modeling tool set again. 

30. Then click at the center of the layer plane, where the 3 axis 
lines meet. 

31. After placing the locus point, go to the Object Info palette and 
change the Z height for this locus to 500mm. Press Enter on 
your keyboard to lock in the value. 

32. Now we’ll use the Twist tool in the 3D Modeling tool set to 
add the curve to the table legs. Activate the Twist tool. Make 
sure the first mode Solid mode in selected in the Tool bar. 

33. Next, you must select the solid object to be twisted, which in 
this case is the solid addition. Click the solid addition once. 

34. Now we must choose a fixed point to twist the object around, 
which is the 3d locus point we just created. So click the locus 
point once as well. 

35. Now we need to set the reference line. To do this, move your 
cursor to the right until you snap to the green Y-axis. 

36. When you see the cursor cue Y and the Working Plane 
Angle field in the floating data bar reads -90°, click to set the 
reference line.  

We now can begin twisting the object. If you move your cursor 
you should see a preview for the resulting twist. Since these are 
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table legs, we do not want too drastic of a curve in the legs. 

37. So press the Tab key to enter the Twist Angle field in the 
floating data bar. 

38. Input a value of -15° and press Enter to lock in the value. 
Now click once more to complete the twist. 

39. There. Now take a moment with the Flyover tool to see how 
the solid addition as been twisted. Once you are done, return 
to a Top/Plan view.

The legs of the table are complete. Next, we need to create the 
tabletop. 

40. To do this, select the Circle tool from the Basic palette. Also 
select the 3rd mode in the Tool bar, Circle by Three Points 
mode. 

41. To create the circle, click these 3 endpoints.

Don’t forget you can use the Snap Loupe by pressing the Z key to 
get closer a look as necessary.  

42. We also need to create a smaller circle. So double click the 
Circle tool to access the Create Object dialog box. 

43. Change the Diameter field to 25mm. Then click Ok to create 
the circle, which should be placed at the center of the drawing. 

44. Now, switch to the Selection tool. Hold the Shift key and 
select the large circle. You should now have both circles 
selected.  

45. Next, go to Model > Extrude Along Path. Make sure the 
larger circle is highlighted as the path and click OK to create 
the extrude along path object. 

46. Currently, this object is sitting at 0 on the layer but it needs 
to be elevated 500mm to the top of the table legs. So, in the 
Object Info palette, set the Z field to 500 and press Enter.

47. Ok. Now let’s switch to Front view. 

You can see the extrude along path we’ve just created meets the 
legs of the table legs and will serve as the railing for the glass 
tabletop. Let’s also create the railing around the middle of the 
table legs. 

48. First, using the Selection tool, click the green Y-axis line. 

You should notice there are now additional selection handles 
available on the working plane. This will allow us to move and 
rotate the working plane. 

49. Click the center point on the working plane and move it 
upward, while holding the Shift key. When the Length field in 
the Floating Data bar is around 220mm click again to complete 
the move. 

50. Next, switch to a Top view. Then activate the Circle tool and 
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click these 3 points.  Again, don’t forget you can use the Snap 
Loupe as necessary here.

51. After completing the circle, double click the Circle tool in the 
Basic palette. Change the Diameter field to 12 and click OK. 

52. Now switch to the Selection tool. Hold the Shift key and 
select the larger circle so that both circles are now highlighted. 

53. Then, go to Model > Extrude Along Path. Again, be sure 
that the larger circle is highlighted as the path and click OK to 
create the extrude along path object.

The railings are done. Now we just need to create the glass 
surface for the top of the table. 

54. Once again, select the Circle tool and click these 3 points to 
create the circle.

Just as we did previously press the Z key to use the Snap Loupe 
to get a closer look at the points.

55. Then, go to Model > Extrude. In the Create Extrude dialog 
box, set the Extrusion field to 6 and click OK to create the 
extrude.

56. The glass surface needs to sit at the top of the table, so set 
the Bot Z field in the Object Info palette to 500 and press 
Enter. 

57. Now use the Flyover tool to take a look at this table in 3D. 

58. The extrude should still be selected, but if it is not select it 
and go to the Render tab in the Object Info palette. 

59. Then select Glass Clear from the Texture drop down menu. 

60. Now switch to the Selection tool. 

61. Go through and delete any extraneous objects like the 
rectangle on the ground plane and the 2 locus points. 

Remember if you are unable to select an object because it shares 
an edge with another object, hover your cursor over the object, 
hold the J key and click. Then select your desired object from the 
list

62. The table is complete, so let’s render in OpenGL or Final 
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Quality Renderworks to see the final results.

Last, lets create a few viewports to present this twist table. 

63. Go to the View menu and select Create Viewport. In the 
Create Viewport dialog box, set the Layer Scale to 1:20. 

64. Also, select New Sheet Layer from the Create on Layer drop 
down menu. 

65. In the next dialog box, leave all settings at their default and 
click OK twice to create the viewport. 

66. In the Object Info palette switch back to the Shape tab. 

Notice the View drop down menu is set to Custom. This is 
because the viewport was created using the last view from the 
design layer, which was created using the Flyover tool. 

Next, we’ll create 2 more viewports display different views of the 
table. 

67. With the Selection tool hold the Option key on Macintosh or 
the Alt key on Windows and click the drag the current viewport 
towards the top left of the corner of the drawing area. 

Notice the small plus sign beside the cursor, which indicates a 
duplicate, will be created. 

68. Release the mouse click to create the duplicate. Also in the 

Object info palette change the View drop down menu to Top/
Plan.

69. Additionally, reposition the viewport in the center of the page 
toward the right of the page.

OK we have one more viewport to create. 

70. Again hold the Option key on Macintosh or the Alt key on 
Windows and click and drag from the last create viewport 
downward. 

71. Release your mouse click when you satisfied with the 
viewports placement to create the duplicate. 

72. This time in the Object Info palette change the View drop 
down menu to Front and choose Hidden Line from the 
Background Render drop down menu. 

73. Select the 2 viewports with the red striped borders, which 
indicates they need to be updated. 

74. Then click the Update button in the Object Info palette and 
your twist table project is completed.
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