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The FARO scanner is a seven-axis measurement device from FARO Technolo-
gies, Inc. that offers full scanning or select data-gathering without the user 
having to interchange parts. Plugins > Faro Scanning is an interface to the 
FARO scanner. The purpose of this plug-in is to integrate data capture and 
processing activities into a single user interface. Specifically, the Faro Scan-
ning function in Geomagic products allows data capture and storage to the 
model manager in a single step, and the creation of datums and features on 
the scanned object.

(This menu item in Geomagic products is an optional, separately licensed fea-
ture. If Faro Scan does not already appear on the Plugins menu, download 
the software from support.geomagic.com/downloads, install it according to 
simple instructions on the web site, and re-start this procedure.)

Turn on the FARO scanner before selecting Plug-ins > Faro Scanning.

In This Document:

• For reference information on the controls and indicators of the FARO 
Scanning plug-in, see Controls and Indicators on 1-2.

• Immediatley after activating the Faro Scanning plugin, a popup might 
prompt you to “reference the encoders”. See Referencing the Encoders on 
1-6.

• From time to time, especially after moving the scanner to a new location, 
you will calibrate the hard and laser probes. See Calibrating the Hard and 
Laser Probes on 1-6.

• Reverse engineering with Faro Scanning and Geomagic Studio - see 
FARO Scan -- Step-by-Step on 1-12.

• Datum and feature creation with Faro Scanning and Geomagic Studio or 
Geomagic Qualify - see Datum and Feature Creation -- Step-by-Step on 
1-13.

• Computer-aided inspection with Faro Scanning and Geomagic Qualify - 
see Faro Scanning with Geomagic Qualify on 1-17.
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Controls and Indicators
This section details the controls and indicators on the user interface of the 
FARO Scanning plug-in.

• Alignment icon button - activates controls and indicators for the 

alignment process. Every scan must be performed with respect to a 
known spatial orientation (also called a “coordinate system”, also incor-
rectly called an “alignment”). The spatial orientation remains in effect on 
subseqeunt scans and the next time Geomagic Studio or Qualify is 
started. Define an orientation by one of the following four methods.
• Select Probe group -

• Probe button - presents a popup window in which you specify the 
physical probe that is attached to the FARO arm. In the Select Probe 
window, identify the currently installed hard probe (such as 3mm 
Ball Probe). Optionally, perform calibration of that probe.  Click OK.

• 3-2-1 Alignment button - Allows the user to establish spatial orienta-
tion by defining the position of the X, Y, and Z planes. See 3-2-1 Align-
ment on 1-10.

• Last Test Model Alignment button (selectable only when an object 
has been designated as the test object, or when a Feature/Datum 
object is present in the model manager) - specifies that the spatial ori-
entation be based on the scheme of an existing object. In Geomagic 
Qualify, use the orientation of the currently designated test object. If 
no test object exists, use the spatial orientation of the Feature/Datum 
object. If this is Geomagic Studio, use the spatial orientation of the 
Feature/Datum object.
• Merge Features/Datums to Next Scan checkbox (functional only 

when a Feature/Datum object exists) - causes the features and 
datums that exist in the Feature/Datum object to be replicated into 
the object created during the next scan.

• Load Transform - allows the user to select a .tfm or .xal file that 
defines a spatial orientation.

• Use Arm CSYS - sets the spatial orientation (also called Coordinate 
SYStem) to the arm default, where the arm base is the origin.
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• Laser icon button - activates controls and indicators for the laser 

scanner.
• Object Name field and Reset button - indicates the name of the 

object that will be stored in the Geomagic model manager. Reset does 
something. 

• Laser Scanning group - 

• Calibrate Scanner: Click this if calibration is required for the 

hard probe and laser probe, or just the laser probe. In response to 
the prompt, press a radio button to specify the extent of calibration 
that is required.
• Hard Probe Sphere Calibration - Neither the hard probe nor the 

laser scanner have been calibrated. Press this button to be taken 
to the beginning of the hard probe calibration process, then to the 
laser scanner calibration process.

• Measure Sphere With Current Hard Probe - The hard probe 
has been calibrated, but it is now clamped to the table in a differ-
ent position with respect to the base of the arm. Press this button 
to be taken to the positioning part of the hard probe calibration 
proccess, then to the laser scanner calibration process. This is the 
same as selecting Alignment | Probe button | Sphere Calibration or 
Hard Probe | Probe button | Sphere Calibration.

• Use Previous Values - The hard probe has been calibrated and it 
is still clamped to the table in the same position with respect to the 
base of the arm. Press this button to be taken to the laser scanner 
calibration process.

• Scanner Options: Brings up the Faro dialog that allows spe-

cific adjustment of the laser scanner operations.

• Start Scan button - puts the scanner and software into data 

collection mode.  To return to the application, press the red button 
on the scanner.  To actually begin scanning, press the green button. 
To pause, press the green button again.

• Units - specifies the units of measure on the object that will be 
scanned, such as inches or millimeters.



Raindrop Geomagic, Inc. FARO Plugin Geomagic S6 SR4, Q6 SR2, Q7

page 1-4 October 4, 2004

• Scanning Options - control the operation of the scanner and the 
display of data.
• Shade Points checkbox - By the time a scan is stored in the 

model manager, the plugin will have calculated individual point 
normals based on the scanner direction at time of acquisition. This 
checkbox specifies whether to perform these calculations during 
pauses (in which case you must wait for a calculation to complete 
before resuming a scan) or after you press OK to store the object 
in the model manager (in which case you might have to wait for a 
relatively long time). 

• Virtual Camera checkbox - toggles the Virtual Camera functional-
ity of the laser scanner.

• Highlight Scan Pass checkbox - toggles scan pass hi-lighting.  
When selected, the incoming scan data will appear red, otherwise 
the incoming scan data will match the light green of previously cre-
ated scan passes.

• Display Polygons checkbox - toggles the display between Poly-
gons and Points.  Acts on all scan passes in the current plugin 
instance.

• Edge Ratio slider (five settings from Low to High) - specifies the 
propensity of the software to leave gaps between scan lines in the 
scan image if you are scanning too fast. [A triangle with high edge 
ratio is one that has two relatively long sides caused by rapid scan-
ning, and a relatively short side which is influenced by the scan line 
density setting on the FARO Scanner Settings dialog.]

• When density of scan is more important, such as in a reverse 
engineering scenario, use a lower Edge Ratio. If you scan too 
fast, gaps will appear on the scan image. In that case, slow 
down or make a second pass.

• When density of scan is less important, such as some inspec-
tion scenarios, use a higher Edge Ratio. If you scan relatively 
fast and scan lines are far apart, software will triangulate the 
space between scan lines and thereby suggest that the scan is 
“good”. If you are still scanning too fast and gaps appear, slow 
down or make a second pass.
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• Data Options - affect the appearance of collected data after the plu-
gin is closed.
• Merge Scan Passes checkbox - specifies whether to perform a 

point merge on all individual scan passes created during the cur-
rent session of the plugin.  The result will be one point object in the 
model manager.

• Sampling checkbox - specifies whether to perform uniform sam-
pling (a reduction of point density) on the resulting point cloud at 
the end of a scan pass.

• Spacing - specifies the spacing parameter used by the Uni-
form Sample operation.

• Smoothing slider (None, Min, Med, and Max) - specifies whether 
to perform a smoothing operation on each scan line as it is 
received from the scanner.  The intent is that noisy data can be 
smoothed in real-time to provide better wrapping results.  The val-
ues are: None, Min, Med, Max.

• Filter Angle field (0 to 90 degrees) - offers the ability to ignore 
points collected by the scanner beyond the specified angle.  This 
results in much cleaner data.  The filter angle can be adjusted 
between 0.0 and 90.0 degrees.  This operation, like smoothing, is 
on a per scan line basis.

• Hard Probe icon button - activates controls and indicators for the 

touch probe on the scanner’s nose.
• Object Name field and Reset button - indicates the name of the 

object that will be stored in the Geomagic model manager. Reset does 
something.

• Select Probe group -
• Probe button - presents a popup window in which you specify the 

physical probe that is attached to the FARO arm. In the Select Probe 
window, identify the currently installed hard probe (such as 3mm 
Ball Probe). Optionally, perform calibration of that probe.  Click OK.

• Datum/Feature Type group - specifies the kind of datum or feature 
that will be defined by use of the hard probe. A datum or feature can be 
defined even if no scan data exists yet. If no scan data yet exists, an 
“empty” point object called Datums/Features is created in the model 
manager and the new datum and feature sub-objects are stored under 
it.

• Method Input group - specifies the kind of datum or feature that will 
be defined by use of the hard probe. A datum or feature can be defined 
even if no scan data exists yet. If no scan data yet exists, an “empty” 
point object called Datums/Features is created in the model manager 
and the new datum and feature sub-objects are stored under it.
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• Show Instructions checkbox - specifies whether the user interface 
presents a sentence explaining how to define the datum or feature 
given the Datum/Feature Type and the Method Input that is chosen.
• Instructions (if requested by the Show Instructions checkbox) - 

presents a sentence explaining how to define the datum or feature 
given the Datum/Feature Type and the Method Input that is cho-
sen.

Referencing the Encoders
If a graphical representation of the FARO arm pops up, you must now “refer-
ence the encoders”. Exercise the arm in every direction until the red arrows 
on the graphical display disappear.

Calibrating the Hard and Laser 
Probes
From time to time, especially after moving the scanner to a new location, you 
will calibrate the hard and laser probes. 

1.   Press the large Laser Scanning icon, then the Calibrate 

Scanner icon.
2. Before calibrating the laser scanner, the hard probe must be calibrated 

(or must have been calibrated already). In response to the prompt, select 
one of the following radio buttons based on the “condition” of the hard 
probe.
• Hard Probe Sphere Calibration - Neither the hard probe nor the 

laser scanner have been calibrated. Press this button to be taken to the 
beginning of the hard probe calibration process, then to the laser scan-
ner calibration process. Go to Step 3.

• Measure Sphere With Current Hard Probe - The hard probe has 
been calibrated, but it is now clamped to the table in a different posi-
tion with respect to the base of the arm. Press this button to be taken 
to the positioning part of the hard probe calibration proccess, then to 
the laser scanner calibration process. (This is the same as selecting 
Alignment | Probe button | Sphere Calibration or Hard Probe | Probe button 
| Sphere Calibration.) Go to Step 5.

• Use Previous Values - The hard probe has been calibrated and it is 
still clamped to the table in the same position with respect to the base 
of the arm. Press this button to be taken to the laser scanner calibra-
tion process. Go to Step 8.
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3. In the Current Probe pulldown, identify the currently installed hard 
probe, such as 3mm Ball Probe, then click OK.

4. If a graphical representation of the FARO arm pops up, you must now ref-
erence the encoders. Exercise the arm in every direction until the red 
arrows on the graphical display disappear.

The next three steps refer to Position #1, #2, and #3 as indicated in the following 
diagram. 

5. In the order indicated by the on-screen illustration, digitize five points 
around the top of the sphere in probe position number 1.

6. In the order indicated by the on-screen illustration, digitize five points 
around the front of the sphere in probe position number 2.

Position #1

Position #2

Position #3

1

2

3
4

5
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3
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5
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7. In the order indicated by the on-screen illustration, digitize five points 
around the side of the sphere in probe position number 3.

After five points are digitized on each of three angles, an internal calibra-
tion process begins. 
• If the probe passes the test, the Calibration Status is set to Passed 

and the current date and time appear in the time indicator. Click OK. 
Calibration of the standard (hard) probe is complete.

• If the probe fails the test, the Calibration Status is set to Failed. Click 
Retry and go to Step 5.

8. To calibrate the laser probe, you will digitize eight points from each of the 
three positions, starting with the top view (position 1), a side view (posi-
tion 2), then the front view (position 3).
Use the on-screen range finder or the two LEDs on the back of the scan-
ner to judge the definition of Near range and Far range.Starting at posi-
tion 1, digitize two points in the Near range with the center of the laser 
-- one point on the upper half of the calibration sphere and one point on 
the lower half. The Near range is indicated by the upper green LED on the 
range finder. The Center range is indicated by both green LEDs on the 

1

2

3

4

5
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range finder. The Far range is indicated by the lower green LED on the 
range finder.  

9. Digitize two points in the Far range with the center of the laser -- one 
point on the upper half of the calibration sphere and one point on the 
lower half.

10. Digitize two points in the Center range with the left side of the laser -- 
one point on the upper half of the calibration sphere and one point on the 
lower half.

11. Digitize two points in the Center range with the right side of the laser -- 
one point on the upper half of the calibration sphere and one point on the 
lower half.

12. Move to position two, which is the left or right side of the sphere.
13. Digitize two points in the Near range with the center of the laser ....
14. Digitize two points in the Far range with the center of the laser ....
15. Digitize two points in the Center range with the left side of the laser ....
16. Digitize two points in the Center range with the right side of the laser ....
17. Move to position three, which is the front side of the sphere.
18. Digitize two points in the Near range with the center of the laser ....
19. Digitize two points in the Far range with the center of the laser ....
20. Digitize two points in the Center range with the left side of the laser ....
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21. Digitize two points in the Center range with the right side of the laser ....
After eight points are digitized in each of three positions, an internal cali-
bration process begins. 
• If the probe passes the test, the Calibration Status is set to Passed 

and the current date and time appear in the time indicator. Click OK. 
For details on the calibration of both the hard and laser probes, click 
View Log and see the FaroArm USB manual for details. Calibration of 
the laser probe is complete.

• If the probe fails the test, the Calibration Status is set to Failed. Click 
Retry and go to Step 8.

3-2-1 Alignment
This is a sub-procedure referenced by the Alignment section under Controls 
and Indicators on 1-2.

This describes “3-2-1 Alignment” -- how to specify an object’s coordinate sys-
tem by defining the position of three orthogonal planes. The origin of the 
object’s coordinate system will be the point of intersection of the three 
planes.

1. Click the large Alignment icon, then the 3-2-1 Alignment icon.

Recall that:
The plane orthogonal to the X axis is the YZ plane.
The plane orthogonal to the Y axis is the XZ plane.
The plane orthogonal to the Z axis is the XY plane.
The letter on each of the following icons represents the axis to which a 
plane is orthogonal. The sign on each icon represents a side of the plane. 

          

2. If the purpose of this alignment is to synchronize the coordinates a test 
part with a CAD object, look at the CAD object and ascertain the position 
of the X, Y, and Z axes (the YZ, XZ, and XY planes) with respect to the 
CAD object. (Note that a CAD object’s coordinate system always uses the 
right-hand rule).
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3. Based on information ascertained in the previous step, perform any two 
of the following three actions:
• Click the +X icon or the -X icon.

(+X means that “above” YZ is the positive side of YZ.
-X means that “above” YZ is the negative side of YZ.)

• Click the +Y icon or the -Y icon.
(+Y means that “above” XZ is the positive side of XZ.
-Y means that “above” XZ is the negative side of XZ.)

• Click the +Z icon or the -Z icon.
(+Z means that “above” XY is the positive side of XY.
-Z means that “above” XY is the negative side of XY.)

The first button you press is designated as Plane 1.
The second button you press is designated as Plane 2.
Adhering to the right-hand rule, the software automatically selects a third 
button (either the + or - variant of the plane you didn’t pick), and desig-
nates it as Plane 3. The sign that the software picks is always the sign of 
Plane 1 times the sign of Plane 2. (+ * + = +) ; (+ * - = -) ; (- * - = +)

4. On the physical object, position the hard probe on a point that lies in 
Plane 1, then click the green button on the scanner. Position the probe 
on a second point that lies in Plane 1, then click the green button on the 
scanner. Position the probe on a third point that lies in Plane 1, then click 
the green button on the scanner.
You have just defined the position of Plane 1.

5. Pull the probe out and away from Plane 1, then click the red button on 
the scanner.
If Plane 1 was designated in Step 3 by a + icon, you have established 
the + side of Plane 1.
If Plane 1 was designated in Step 3 by a - icon, you have established the 
- side of Plane 1.

6. On the physical object, position the hard probe on a point that lies in 
Plane 2, then click the green button on the scanner. Position the probe 
on a second point that lies in Plane 2, then click the green button on the 
scanner. There is no need to select a third point on Plane 2.
You have just defined the position of Plane 2.

7. Pull the probe out and away from Plane 2, then click the red button on 
the scanner.
If Plane 2 was designated in Step 3 by a + icon, you have established 
the + side of Plane 2.
If Plane 2 was designated in Step 3 by a - icon, you have established the 
- side of Plane 2.

8. On the physical object, position the hard probe on a point that lies in 
Plane 3, then click the green button on the scanner. There is no need to 
select a second or third point on Plane 3. 
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9. Pull the probe out and away from Plane 3, then click the red button on 
the scanner.
Based on the right-hand rule, the software already knew the + and - side 
of Plane 3, but this was necessary to complete the process.

10. The current coordinates of the probe appear in a coordinate indicator box. 
Move the indicator box by dragging it to any location of the screen, or 
click the red button to close the indicator. Click Show Coordinates to 
re-display the coordinate indicator box.

11. Hover the probe above the YZ plane and verify that the X coordinate in 
the indicator is appropriately positive or negative.
Hover the probe above the XZ plane and verify that the Y coordinate in 
the indicator is appropriately positive or negative.
Hover the probe above the XY plane and verify that the Z coordinate in 
the indicator is appropriately positive or negative.

12. Coordinate system definition is complete. To un-do the coordinate sys-
tem, click Reset and go to Step 2.

Detailed Example

To specify the YZ plane (with a total of four points), then the XZ plane (with a 
total of three points), then the XY plane (with two points): Designate Plane 1 
by clicking the +X icon, then designate Plane 2 by clicking the +Y icon. The 
software automatically designates Plane 3 as +Z. Make nine clicks, some 
green and some red, according to the illustration below.

FARO Scan -- Step-by-Step

1. Click the Laser Scanning icon. 
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Denotes clicking the GREEN button on the Faro Arm

Denotes clicking the RED button on the Faro Arm

XY plane
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2. In the Current Probe pulldown, select Laser Probe then click OK.

3. To configure the scanner, click the Scanner Options  icon  and see 

the FARO documentation. To exit the options window, click OK.
4. Set the controls on the Faro Scanning Dialog.
5. To perform a scan and thus create an object in the Geomagic model man-

ager:

• Click the Start Capture icon .

• Click the green button on the scanner and make scan passes.
• The first scan pass does not appear in the Viewing Area until green is 

pressed a second time.
• During the scanning process, use the on-screen range finder or the 

LEDs on the scanner to keep the scanner at a suitable distance from 
the physical object.

• At any time, click the green button again to pause scanning. The 
scan arm acts as a mouse when scanning is not active. Click the 
green button to resume scanning.

• Click the red button to end scanning. The scan arm behaves like a 
mouse.

Datum and Feature Creation -- 
Step-by-Step
Datums and features can be created by use of this FARO scanner plug-in soft-
ware, or by the use of tools that are native to the Geomagic products. In the-
ory, datums or features can be identified more precisely by touching the 
original object and by use of the FARO plug-in. Depending on the accuracy of 
the scan and the user’s experience, however, it may be advantageous to cre-
ate datums and features using the native Geomagic tools.To create datums 
and features using the FARO scanner software:

1. Click the Hard Probing icon. 

2. In the Current Probe pulldown, identify the currently installed hard 
probe, such as 3mm Ball Probe, then click OK.

3. Click the icon of a datum type or feature type to be created.
4. Check (or uncheck) the Show Instructions box for guidance on how to 

create each datum or feature type. Instructions also appear below. A 
summary of the instructions is:
• Click the green button to make choices. 
• Click the red button to finalize choices and go on to the next step. 
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• When you have finished creating all datums and features, click the red 
button again.

NOTE: When defining several features on the same plane, you do not need to 
define that plane for each feature. To recall the last defined plane, click on the 
plane with a single green click followed by a red click.

Creating a DATUM PLANE

1. Click the datum Plane icon.
2. Define a plane by clicking green on 3 or more points on the surface of 

the object.  
3. Define the offset direction by clicking red on a single point above the 

plane.
4. Repeat steps 2 and 3 to define other planes, or click red to return to the 

dialog.  

Creating a DATUM AXIS Using CYLINDER Method

1. Click the datum Axis icon.

2. Click the Cylinder method icon. 

3. Define a cylinder by clicking green on 6 or more points on the surface of 
the object.  

4. Define the axial direction by clicking red on a single point inside or out-
side the cylinder.

5. Repeat steps 3 and 4 to define other axes, or click red to return to the 
dialog.  

Creating a DATUM AXIS Using CONE method:

1. Click the datum Axis icon.  

2. Click the Cone method icon.  

3. Define a cone by clicking green on 6 or more points on the surface of the 
object.

4. Define the axial direction by clicking red on a single point inside or out-
side the cone.

5. Repeat steps 3 and 4 to define other axes, or click red to return to the 
dialog.  

Creating a DATUM POINT Using SPHERE Method
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1. Click the datum Point icon.

2. Click the Sphere method icon.

3. Define a sphere by clicking green on 4 or more points on the surface of 
the object.

4. Click red on a single point inside or outside of the sphere.
5. Repeat steps 3 and 4 to define other points, or click red to return to the 

dialog.  

Creating a DATUM POINT Using CENTROID Method

1. Click the Datum Point icon.

2. Click the Centroid method icon.  

3. Click green on 3 or more close points on the surface of the object.
4. Define the offset direction by clicking red on a single point above the 

group of points.
5. Repeat steps 3 and 4 to define other points, or click red to return to the 

dialog.  

Creating a FEATURE CIRCLE

1. Click the feature Circle icon.

2. Define a plane by clicking green on 3 or more points on the surface of 
the object.

3. Define the offset direction  by clicking red on a single point above the 
plane.

4. Click green on 3 or more points on the cylindrical wall perpendicular to 
the plane.

5. Define the offset direction by clicking red on a single point inside the cir-
cle (to make a hole) or outside the circle (to make a protrusion).

6. Repeat steps 2 through 5 to define other circles, or click red to return to 
the dialog.  
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Creating a FEATURE SLOT

1. Click the feature Slot icon.

2. Define a plane by clicking green on 3 or more points on the surface of 
the object using the green button.  

3. Define the offset direction by clicking red on a single point above the 
plane.

4. Click green on 3 or more points on the cylindrical wall of one end of the 
slot perpendicular to the plane.

5. Define the offset direction by clicking red on a single point inside the slot 
(to make a hole) or outside the slot (to make a protrusion).

6. Repeat steps 4 and 5 to define the opposite end of the slot.
7. Repeat steps 2 through 6 to define other slots, or click red to return to 

the dialog.  

Creating a FEATURE RECTANGLE

1. Click the feature Rectangle icon.

2. Define a plane by clicking green on on 3 or more points on the surface of 
the object using the green button.  

3. Define the offset direction by clicking red on a single point above the 
plane.

4. Click green on 2 or more points on one of the rectangular walls perpen-
dicular to the plane. 

5. Define the offset direction by clicking red on a single point away from the 
rectangle wall.

6. Repeat steps 4 and 5 for the remaining three walls, working in a counter-
clockwise order.

7. Repeat steps 2 through 6 to define other rectangles, or click red to return 
to the dialog.

Creating a FEATURE LINE

1. Click the feature Line icon (for the intersection of two planes)

2. Click green on 3 or more points on the surface of the object.  
3. Define the offset direction by clicking red on a single point above the 

plane.
4. Click green on 2 or more points on a rectangular wall perpendicular to 

the plane.
5. Define the offset direction by clicking red on a single point away from the 

wall.
6. Repeat steps 2 through 5  to define other lines, or click red to return to 

the dialog.
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Faro Scanning with Geomagic 
Qualify
The fundamental purpose of Geomagic Qualify is computer-aided inspection. 
The Plugins > Faro Scan utility for Geomagic Qualify allows a reference object 
to be scanned, the coordinate system to be saved in the reference object file, 
the coordinate system to be re-loaded before scanning a test object, and the 
test object to be scanned and automatically compared to the reference 
object. This workflow avoids the need to constantly deal with alignment of 
reference and test objects, load data files and designate them as reference or 
test, and perform the analyses - all in separate steps.

This section describes the concepts and a typical workflow for computer-
aided inspection with Geomagic Qualify and FARO scanning equipment. The 
purpose of this procedure is to simplify the alignment of a reference object 
and many test objects by using the hard probe to identify datums and fea-
tures on the reference object and on many test objects and by allowing the 
software to align the objects by hardware-generated datums and features.

1. Start Geomagic Qualify.

The first goal is to open a CAD object that will serve as the reference object.

2. Open a CAD object. It is assumed that the CAD object exists at appropri-
ate coordinates in the world coordinate system. (If the CAD object does 
not automatically become the Reference object in the model manager, 
designate it as the Reference object by right-clicking it and selecting Set 
Reference.)

3. Use Tools > Datums > Create Datums or Tools > Features > Create 
Features to define important areas of comparison on the CAD object.

By using the hard probe on a test part that is mounted on the text fixture, 
you will establish the position of the datums and features with respect to the 
test fixture. You will not scan a test part yet.

4. Start Plugins > Faro Scan.

5. Click the large Hard Probing icon, indicating that you will use the 

touch probe next.
6. Mount a test part on the test fixture. Using the hard probe, define two or 

more features or datums (for details, see Datum and Feature Creation -- 
Step-by-Step on 1-13). Recall that no test object exists in the model 
manager, and you are not laser scanning a test part -- you are creating a 
special “blank” test object named “Features/Datums” that records the 
position of the datums and features with respect to the test fixture.
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7. Exit the plugin by clicking the OK button.  In the model manager, note 
the existence of the CAD object and a new test object called "Features/
Datums". Note the existence of Feature and Datum sub-objects under the 
Features/Datums object.

The next goal is to detect the spatial difference between the reference object 
and the place where an actual test object will rest on the test fixture.

8. Use Tools > Alignment > Datum/Features Alignment on the test 
and reference objects (which aligns the reference object with the special 
test object by aligning their datums and features). The side effect of this 
process is that it creates an internal transformation matrix, which is a 
mapping of the spatial difference between the reference object and the 
place where an actual test object will rest on the test fixture.

The next goal is to prepare for the scanning of an actual test part. You will 
instruct the plugin that the spatial orientation of the real test part will be the 
same as that detected in the alignment process in step 8.

9. Select Plugins > Faro Scan again, and click the large Alignment icon.
10. Click the "Use Last Test Alignment" button. This establishes the orienta-

tion of the next scan to be the same as the existing test object.
11. Click the Merge Features/Datums to Next Scan checkbox. This 

causes the features and datums that exist in the Feature/Datum object to 
be replicated into the object created during the next scan. 

Next, scan a test part.

12. Click the large Laser icon to activate scanning mode. Begin scan-

ning. For details, see FARO Scan -- Step-by-Step on 1-12. Scan data 
appears on the screen in alignment with the CAD reference object.

13. Exit the plugin by clicking the OK button. In the model manager, notice 
that the newly created scan object is now the test object.

Perform repetitive scanning of test parts.

14. To scan and rapidly align another test object, select Plugins > Faro 
Scan again and go to step 12.
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FARO Scanning Plugin
for Geomagic Studio 6 service release 4, Geomagic Qualify 6 service release 2,
and Geomagic Qualify 7

Document version B

Copyright © 2004, Raindrop Geomagic, Inc.

The FARO scanner is a seven-axis measurement device from FARO Technolo-
gies, Inc. that offers full scanning or select data-gathering without the user 
having to interchange parts. Plugins > Faro Scanning is an interface to the 
FARO scanner. The purpose of this plug-in is to integrate data capture and 
processing activities into a single user interface. Specifically, the Faro Scan-
ning function in Geomagic products allows data capture and storage to the 
model manager in a single step, and the creation of datums and features on 
the scanned object.

(This menu item in Geomagic products is an optional, separately licensed fea-
ture. If Faro Scan does not already appear on the Plugins menu, download 
the software from support.geomagic.com/downloads, install it according to 
simple instructions on the web site, and re-start this procedure.)

Turn on the FARO scanner before selecting Plug-ins > Faro Scanning.

In This Document:

• For reference information on the controls and indicators of the FARO 
Scanning plug-in, see Controls and Indicators on 1-2.

• Immediatley after activating the Faro Scanning plugin, a popup might 
prompt you to “reference the encoders”. See Referencing the Encoders on 
1-6.

• From time to time, especially after moving the scanner to a new location, 
you will calibrate the hard and laser probes. See Calibrating the Hard and 
Laser Probes on 1-6.

• Reverse engineering with Faro Scanning and Geomagic Studio - see 
FARO Scan -- Step-by-Step on 1-12.

• Datum and feature creation with Faro Scanning and Geomagic Studio or 
Geomagic Qualify - see Datum and Feature Creation -- Step-by-Step on 
1-13.

• Computer-aided inspection with Faro Scanning and Geomagic Qualify - 
see Faro Scanning with Geomagic Qualify on 1-17.
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Controls and Indicators
This section details the controls and indicators on the user interface of the 
FARO Scanning plug-in.

• Alignment icon button - activates controls and indicators for the 

alignment process. Every scan must be performed with respect to a 
known spatial orientation (also called a “coordinate system”, also incor-
rectly called an “alignment”). The spatial orientation remains in effect on 
subseqeunt scans and the next time Geomagic Studio or Qualify is 
started. Define an orientation by one of the following four methods.
• Select Probe group -

• Probe button - presents a popup window in which you specify the 
physical probe that is attached to the FARO arm. In the Select Probe 
window, identify the currently installed hard probe (such as 3mm 
Ball Probe). Optionally, perform calibration of that probe.  Click OK.

• 3-2-1 Alignment button - Allows the user to establish spatial orienta-
tion by defining the position of the X, Y, and Z planes. See 3-2-1 Align-
ment on 1-10.

• Last Test Model Alignment button (selectable only when an object 
has been designated as the test object, or when a Feature/Datum 
object is present in the model manager) - specifies that the spatial ori-
entation be based on the scheme of an existing object. In Geomagic 
Qualify, use the orientation of the currently designated test object. If 
no test object exists, use the spatial orientation of the Feature/Datum 
object. If this is Geomagic Studio, use the spatial orientation of the 
Feature/Datum object.
• Merge Features/Datums to Next Scan checkbox (functional only 

when a Feature/Datum object exists) - causes the features and 
datums that exist in the Feature/Datum object to be replicated into 
the object created during the next scan.

• Load Transform - allows the user to select a .tfm or .xal file that 
defines a spatial orientation.

• Use Arm CSYS - sets the spatial orientation (also called Coordinate 
SYStem) to the arm default, where the arm base is the origin.
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• Laser icon button - activates controls and indicators for the laser 

scanner.
• Object Name field and Reset button - indicates the name of the 

object that will be stored in the Geomagic model manager. Reset does 
something. 

• Laser Scanning group - 

• Calibrate Scanner: Click this if calibration is required for the 

hard probe and laser probe, or just the laser probe. In response to 
the prompt, press a radio button to specify the extent of calibration 
that is required.
• Hard Probe Sphere Calibration - Neither the hard probe nor the 

laser scanner have been calibrated. Press this button to be taken 
to the beginning of the hard probe calibration process, then to the 
laser scanner calibration process.

• Measure Sphere With Current Hard Probe - The hard probe 
has been calibrated, but it is now clamped to the table in a differ-
ent position with respect to the base of the arm. Press this button 
to be taken to the positioning part of the hard probe calibration 
proccess, then to the laser scanner calibration process. This is the 
same as selecting Alignment | Probe button | Sphere Calibration or 
Hard Probe | Probe button | Sphere Calibration.

• Use Previous Values - The hard probe has been calibrated and it 
is still clamped to the table in the same position with respect to the 
base of the arm. Press this button to be taken to the laser scanner 
calibration process.

• Scanner Options: Brings up the Faro dialog that allows spe-

cific adjustment of the laser scanner operations.

• Start Scan button - puts the scanner and software into data 

collection mode.  To return to the application, press the red button 
on the scanner.  To actually begin scanning, press the green button. 
To pause, press the green button again.

• Units - specifies the units of measure on the object that will be 
scanned, such as inches or millimeters.
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• Scanning Options - control the operation of the scanner and the 
display of data.
• Shade Points checkbox - By the time a scan is stored in the 

model manager, the plugin will have calculated individual point 
normals based on the scanner direction at time of acquisition. This 
checkbox specifies whether to perform these calculations during 
pauses (in which case you must wait for a calculation to complete 
before resuming a scan) or after you press OK to store the object 
in the model manager (in which case you might have to wait for a 
relatively long time). 

• Virtual Camera checkbox - toggles the Virtual Camera functional-
ity of the laser scanner.

• Highlight Scan Pass checkbox - toggles scan pass hi-lighting.  
When selected, the incoming scan data will appear red, otherwise 
the incoming scan data will match the light green of previously cre-
ated scan passes.

• Display Polygons checkbox - toggles the display between Poly-
gons and Points.  Acts on all scan passes in the current plugin 
instance.

• Edge Ratio slider (five settings from Low to High) - specifies the 
propensity of the software to leave gaps between scan lines in the 
scan image if you are scanning too fast. [A triangle with high edge 
ratio is one that has two relatively long sides caused by rapid scan-
ning, and a relatively short side which is influenced by the scan line 
density setting on the FARO Scanner Settings dialog.]

• When density of scan is more important, such as in a reverse 
engineering scenario, use a lower Edge Ratio. If you scan too 
fast, gaps will appear on the scan image. In that case, slow 
down or make a second pass.

• When density of scan is less important, such as some inspec-
tion scenarios, use a higher Edge Ratio. If you scan relatively 
fast and scan lines are far apart, software will triangulate the 
space between scan lines and thereby suggest that the scan is 
“good”. If you are still scanning too fast and gaps appear, slow 
down or make a second pass.
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• Data Options - affect the appearance of collected data after the plu-
gin is closed.
• Merge Scan Passes checkbox - specifies whether to perform a 

point merge on all individual scan passes created during the cur-
rent session of the plugin.  The result will be one point object in the 
model manager.

• Sampling checkbox - specifies whether to perform uniform sam-
pling (a reduction of point density) on the resulting point cloud at 
the end of a scan pass.

• Spacing - specifies the spacing parameter used by the Uni-
form Sample operation.

• Smoothing slider (None, Min, Med, and Max) - specifies whether 
to perform a smoothing operation on each scan line as it is 
received from the scanner.  The intent is that noisy data can be 
smoothed in real-time to provide better wrapping results.  The val-
ues are: None, Min, Med, Max.

• Filter Angle field (0 to 90 degrees) - offers the ability to ignore 
points collected by the scanner beyond the specified angle.  This 
results in much cleaner data.  The filter angle can be adjusted 
between 0.0 and 90.0 degrees.  This operation, like smoothing, is 
on a per scan line basis.

• Hard Probe icon button - activates controls and indicators for the 

touch probe on the scanner’s nose.
• Object Name field and Reset button - indicates the name of the 

object that will be stored in the Geomagic model manager. Reset does 
something.

• Select Probe group -
• Probe button - presents a popup window in which you specify the 

physical probe that is attached to the FARO arm. In the Select Probe 
window, identify the currently installed hard probe (such as 3mm 
Ball Probe). Optionally, perform calibration of that probe.  Click OK.

• Datum/Feature Type group - specifies the kind of datum or feature 
that will be defined by use of the hard probe. A datum or feature can be 
defined even if no scan data exists yet. If no scan data yet exists, an 
“empty” point object called Datums/Features is created in the model 
manager and the new datum and feature sub-objects are stored under 
it.

• Method Input group - specifies the kind of datum or feature that will 
be defined by use of the hard probe. A datum or feature can be defined 
even if no scan data exists yet. If no scan data yet exists, an “empty” 
point object called Datums/Features is created in the model manager 
and the new datum and feature sub-objects are stored under it.
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• Show Instructions checkbox - specifies whether the user interface 
presents a sentence explaining how to define the datum or feature 
given the Datum/Feature Type and the Method Input that is chosen.
• Instructions (if requested by the Show Instructions checkbox) - 

presents a sentence explaining how to define the datum or feature 
given the Datum/Feature Type and the Method Input that is cho-
sen.

Referencing the Encoders
If a graphical representation of the FARO arm pops up, you must now “refer-
ence the encoders”. Exercise the arm in every direction until the red arrows 
on the graphical display disappear.

Calibrating the Hard and Laser 
Probes
From time to time, especially after moving the scanner to a new location, you 
will calibrate the hard and laser probes. 

1.   Press the large Laser Scanning icon, then the Calibrate 

Scanner icon.
2. Before calibrating the laser scanner, the hard probe must be calibrated 

(or must have been calibrated already). In response to the prompt, select 
one of the following radio buttons based on the “condition” of the hard 
probe.
• Hard Probe Sphere Calibration - Neither the hard probe nor the 

laser scanner have been calibrated. Press this button to be taken to the 
beginning of the hard probe calibration process, then to the laser scan-
ner calibration process. Go to Step 3.

• Measure Sphere With Current Hard Probe - The hard probe has 
been calibrated, but it is now clamped to the table in a different posi-
tion with respect to the base of the arm. Press this button to be taken 
to the positioning part of the hard probe calibration proccess, then to 
the laser scanner calibration process. (This is the same as selecting 
Alignment | Probe button | Sphere Calibration or Hard Probe | Probe button 
| Sphere Calibration.) Go to Step 5.

• Use Previous Values - The hard probe has been calibrated and it is 
still clamped to the table in the same position with respect to the base 
of the arm. Press this button to be taken to the laser scanner calibra-
tion process. Go to Step 8.
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3. In the Current Probe pulldown, identify the currently installed hard 
probe, such as 3mm Ball Probe, then click OK.

4. If a graphical representation of the FARO arm pops up, you must now ref-
erence the encoders. Exercise the arm in every direction until the red 
arrows on the graphical display disappear.

The next three steps refer to Position #1, #2, and #3 as indicated in the following 
diagram. 

5. In the order indicated by the on-screen illustration, digitize five points 
around the top of the sphere in probe position number 1.

6. In the order indicated by the on-screen illustration, digitize five points 
around the front of the sphere in probe position number 2.

Position #1

Position #2

Position #3

1

2

3
4

5

1

2

3

4

5
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7. In the order indicated by the on-screen illustration, digitize five points 
around the side of the sphere in probe position number 3.

After five points are digitized on each of three angles, an internal calibra-
tion process begins. 
• If the probe passes the test, the Calibration Status is set to Passed 

and the current date and time appear in the time indicator. Click OK. 
Calibration of the standard (hard) probe is complete.

• If the probe fails the test, the Calibration Status is set to Failed. Click 
Retry and go to Step 5.

8. To calibrate the laser probe, you will digitize eight points from each of the 
three positions, starting with the top view (position 1), a side view (posi-
tion 2), then the front view (position 3).
Use the on-screen range finder or the two LEDs on the back of the scan-
ner to judge the definition of Near range and Far range.Starting at posi-
tion 1, digitize two points in the Near range with the center of the laser 
-- one point on the upper half of the calibration sphere and one point on 
the lower half. The Near range is indicated by the upper green LED on the 
range finder. The Center range is indicated by both green LEDs on the 

1

2

3

4

5
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range finder. The Far range is indicated by the lower green LED on the 
range finder.  

9. Digitize two points in the Far range with the center of the laser -- one 
point on the upper half of the calibration sphere and one point on the 
lower half.

10. Digitize two points in the Center range with the left side of the laser -- 
one point on the upper half of the calibration sphere and one point on the 
lower half.

11. Digitize two points in the Center range with the right side of the laser -- 
one point on the upper half of the calibration sphere and one point on the 
lower half.

12. Move to position two, which is the left or right side of the sphere.
13. Digitize two points in the Near range with the center of the laser ....
14. Digitize two points in the Far range with the center of the laser ....
15. Digitize two points in the Center range with the left side of the laser ....
16. Digitize two points in the Center range with the right side of the laser ....
17. Move to position three, which is the front side of the sphere.
18. Digitize two points in the Near range with the center of the laser ....
19. Digitize two points in the Far range with the center of the laser ....
20. Digitize two points in the Center range with the left side of the laser ....
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21. Digitize two points in the Center range with the right side of the laser ....
After eight points are digitized in each of three positions, an internal cali-
bration process begins. 
• If the probe passes the test, the Calibration Status is set to Passed 

and the current date and time appear in the time indicator. Click OK. 
For details on the calibration of both the hard and laser probes, click 
View Log and see the FaroArm USB manual for details. Calibration of 
the laser probe is complete.

• If the probe fails the test, the Calibration Status is set to Failed. Click 
Retry and go to Step 8.

3-2-1 Alignment
This is a sub-procedure referenced by the Alignment section under Controls 
and Indicators on 1-2.

This describes “3-2-1 Alignment” -- how to specify an object’s coordinate sys-
tem by defining the position of three orthogonal planes. The origin of the 
object’s coordinate system will be the point of intersection of the three 
planes.

1. Click the large Alignment icon, then the 3-2-1 Alignment icon.

Recall that:
The plane orthogonal to the X axis is the YZ plane.
The plane orthogonal to the Y axis is the XZ plane.
The plane orthogonal to the Z axis is the XY plane.
The letter on each of the following icons represents the axis to which a 
plane is orthogonal. The sign on each icon represents a side of the plane. 

          

2. If the purpose of this alignment is to synchronize the coordinates a test 
part with a CAD object, look at the CAD object and ascertain the position 
of the X, Y, and Z axes (the YZ, XZ, and XY planes) with respect to the 
CAD object. (Note that a CAD object’s coordinate system always uses the 
right-hand rule).
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3. Based on information ascertained in the previous step, perform any two 
of the following three actions:
• Click the +X icon or the -X icon.

(+X means that “above” YZ is the positive side of YZ.
-X means that “above” YZ is the negative side of YZ.)

• Click the +Y icon or the -Y icon.
(+Y means that “above” XZ is the positive side of XZ.
-Y means that “above” XZ is the negative side of XZ.)

• Click the +Z icon or the -Z icon.
(+Z means that “above” XY is the positive side of XY.
-Z means that “above” XY is the negative side of XY.)

The first button you press is designated as Plane 1.
The second button you press is designated as Plane 2.
Adhering to the right-hand rule, the software automatically selects a third 
button (either the + or - variant of the plane you didn’t pick), and desig-
nates it as Plane 3. The sign that the software picks is always the sign of 
Plane 1 times the sign of Plane 2. (+ * + = +) ; (+ * - = -) ; (- * - = +)

4. On the physical object, position the hard probe on a point that lies in 
Plane 1, then click the green button on the scanner. Position the probe 
on a second point that lies in Plane 1, then click the green button on the 
scanner. Position the probe on a third point that lies in Plane 1, then click 
the green button on the scanner.
You have just defined the position of Plane 1.

5. Pull the probe out and away from Plane 1, then click the red button on 
the scanner.
If Plane 1 was designated in Step 3 by a + icon, you have established 
the + side of Plane 1.
If Plane 1 was designated in Step 3 by a - icon, you have established the 
- side of Plane 1.

6. On the physical object, position the hard probe on a point that lies in 
Plane 2, then click the green button on the scanner. Position the probe 
on a second point that lies in Plane 2, then click the green button on the 
scanner. There is no need to select a third point on Plane 2.
You have just defined the position of Plane 2.

7. Pull the probe out and away from Plane 2, then click the red button on 
the scanner.
If Plane 2 was designated in Step 3 by a + icon, you have established 
the + side of Plane 2.
If Plane 2 was designated in Step 3 by a - icon, you have established the 
- side of Plane 2.

8. On the physical object, position the hard probe on a point that lies in 
Plane 3, then click the green button on the scanner. There is no need to 
select a second or third point on Plane 3. 
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9. Pull the probe out and away from Plane 3, then click the red button on 
the scanner.
Based on the right-hand rule, the software already knew the + and - side 
of Plane 3, but this was necessary to complete the process.

10. The current coordinates of the probe appear in a coordinate indicator box. 
Move the indicator box by dragging it to any location of the screen, or 
click the red button to close the indicator. Click Show Coordinates to 
re-display the coordinate indicator box.

11. Hover the probe above the YZ plane and verify that the X coordinate in 
the indicator is appropriately positive or negative.
Hover the probe above the XZ plane and verify that the Y coordinate in 
the indicator is appropriately positive or negative.
Hover the probe above the XY plane and verify that the Z coordinate in 
the indicator is appropriately positive or negative.

12. Coordinate system definition is complete. To un-do the coordinate sys-
tem, click Reset and go to Step 2.

Detailed Example

To specify the YZ plane (with a total of four points), then the XZ plane (with a 
total of three points), then the XY plane (with two points): Designate Plane 1 
by clicking the +X icon, then designate Plane 2 by clicking the +Y icon. The 
software automatically designates Plane 3 as +Z. Make nine clicks, some 
green and some red, according to the illustration below.

FARO Scan -- Step-by-Step

1. Click the Laser Scanning icon. 

12

3

4

5

6

7

8

9

+X +Y

+Z

YZ plane XZ
 pla

ne

Denotes clicking the GREEN button on the Faro Arm

Denotes clicking the RED button on the Faro Arm

XY plane
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2. In the Current Probe pulldown, select Laser Probe then click OK.

3. To configure the scanner, click the Scanner Options  icon  and see 

the FARO documentation. To exit the options window, click OK.
4. Set the controls on the Faro Scanning Dialog.
5. To perform a scan and thus create an object in the Geomagic model man-

ager:

• Click the Start Capture icon .

• Click the green button on the scanner and make scan passes.
• The first scan pass does not appear in the Viewing Area until green is 

pressed a second time.
• During the scanning process, use the on-screen range finder or the 

LEDs on the scanner to keep the scanner at a suitable distance from 
the physical object.

• At any time, click the green button again to pause scanning. The 
scan arm acts as a mouse when scanning is not active. Click the 
green button to resume scanning.

• Click the red button to end scanning. The scan arm behaves like a 
mouse.

Datum and Feature Creation -- 
Step-by-Step
Datums and features can be created by use of this FARO scanner plug-in soft-
ware, or by the use of tools that are native to the Geomagic products. In the-
ory, datums or features can be identified more precisely by touching the 
original object and by use of the FARO plug-in. Depending on the accuracy of 
the scan and the user’s experience, however, it may be advantageous to cre-
ate datums and features using the native Geomagic tools.To create datums 
and features using the FARO scanner software:

1. Click the Hard Probing icon. 

2. In the Current Probe pulldown, identify the currently installed hard 
probe, such as 3mm Ball Probe, then click OK.

3. Click the icon of a datum type or feature type to be created.
4. Check (or uncheck) the Show Instructions box for guidance on how to 

create each datum or feature type. Instructions also appear below. A 
summary of the instructions is:
• Click the green button to make choices. 
• Click the red button to finalize choices and go on to the next step. 
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• When you have finished creating all datums and features, click the red 
button again.

NOTE: When defining several features on the same plane, you do not need to 
define that plane for each feature. To recall the last defined plane, click on the 
plane with a single green click followed by a red click.

Creating a DATUM PLANE

1. Click the datum Plane icon.
2. Define a plane by clicking green on 3 or more points on the surface of 

the object.  
3. Define the offset direction by clicking red on a single point above the 

plane.
4. Repeat steps 2 and 3 to define other planes, or click red to return to the 

dialog.  

Creating a DATUM AXIS Using CYLINDER Method

1. Click the datum Axis icon.

2. Click the Cylinder method icon. 

3. Define a cylinder by clicking green on 6 or more points on the surface of 
the object.  

4. Define the axial direction by clicking red on a single point inside or out-
side the cylinder.

5. Repeat steps 3 and 4 to define other axes, or click red to return to the 
dialog.  

Creating a DATUM AXIS Using CONE method:

1. Click the datum Axis icon.  

2. Click the Cone method icon.  

3. Define a cone by clicking green on 6 or more points on the surface of the 
object.

4. Define the axial direction by clicking red on a single point inside or out-
side the cone.

5. Repeat steps 3 and 4 to define other axes, or click red to return to the 
dialog.  

Creating a DATUM POINT Using SPHERE Method
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1. Click the datum Point icon.

2. Click the Sphere method icon.

3. Define a sphere by clicking green on 4 or more points on the surface of 
the object.

4. Click red on a single point inside or outside of the sphere.
5. Repeat steps 3 and 4 to define other points, or click red to return to the 

dialog.  

Creating a DATUM POINT Using CENTROID Method

1. Click the Datum Point icon.

2. Click the Centroid method icon.  

3. Click green on 3 or more close points on the surface of the object.
4. Define the offset direction by clicking red on a single point above the 

group of points.
5. Repeat steps 3 and 4 to define other points, or click red to return to the 

dialog.  

Creating a FEATURE CIRCLE

1. Click the feature Circle icon.

2. Define a plane by clicking green on 3 or more points on the surface of 
the object.

3. Define the offset direction  by clicking red on a single point above the 
plane.

4. Click green on 3 or more points on the cylindrical wall perpendicular to 
the plane.

5. Define the offset direction by clicking red on a single point inside the cir-
cle (to make a hole) or outside the circle (to make a protrusion).

6. Repeat steps 2 through 5 to define other circles, or click red to return to 
the dialog.  
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Creating a FEATURE SLOT

1. Click the feature Slot icon.

2. Define a plane by clicking green on 3 or more points on the surface of 
the object using the green button.  

3. Define the offset direction by clicking red on a single point above the 
plane.

4. Click green on 3 or more points on the cylindrical wall of one end of the 
slot perpendicular to the plane.

5. Define the offset direction by clicking red on a single point inside the slot 
(to make a hole) or outside the slot (to make a protrusion).

6. Repeat steps 4 and 5 to define the opposite end of the slot.
7. Repeat steps 2 through 6 to define other slots, or click red to return to 

the dialog.  

Creating a FEATURE RECTANGLE

1. Click the feature Rectangle icon.

2. Define a plane by clicking green on on 3 or more points on the surface of 
the object using the green button.  

3. Define the offset direction by clicking red on a single point above the 
plane.

4. Click green on 2 or more points on one of the rectangular walls perpen-
dicular to the plane. 

5. Define the offset direction by clicking red on a single point away from the 
rectangle wall.

6. Repeat steps 4 and 5 for the remaining three walls, working in a counter-
clockwise order.

7. Repeat steps 2 through 6 to define other rectangles, or click red to return 
to the dialog.

Creating a FEATURE LINE

1. Click the feature Line icon (for the intersection of two planes)

2. Click green on 3 or more points on the surface of the object.  
3. Define the offset direction by clicking red on a single point above the 

plane.
4. Click green on 2 or more points on a rectangular wall perpendicular to 

the plane.
5. Define the offset direction by clicking red on a single point away from the 

wall.
6. Repeat steps 2 through 5  to define other lines, or click red to return to 

the dialog.
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Faro Scanning with Geomagic 
Qualify
The fundamental purpose of Geomagic Qualify is computer-aided inspection. 
The Plugins > Faro Scan utility for Geomagic Qualify allows a reference object 
to be scanned, the coordinate system to be saved in the reference object file, 
the coordinate system to be re-loaded before scanning a test object, and the 
test object to be scanned and automatically compared to the reference 
object. This workflow avoids the need to constantly deal with alignment of 
reference and test objects, load data files and designate them as reference or 
test, and perform the analyses - all in separate steps.

This section describes the concepts and a typical workflow for computer-
aided inspection with Geomagic Qualify and FARO scanning equipment. The 
purpose of this procedure is to simplify the alignment of a reference object 
and many test objects by using the hard probe to identify datums and fea-
tures on the reference object and on many test objects and by allowing the 
software to align the objects by hardware-generated datums and features.

1. Start Geomagic Qualify.

The first goal is to open a CAD object that will serve as the reference object.

2. Open a CAD object. It is assumed that the CAD object exists at appropri-
ate coordinates in the world coordinate system. (If the CAD object does 
not automatically become the Reference object in the model manager, 
designate it as the Reference object by right-clicking it and selecting Set 
Reference.)

3. Use Tools > Datums > Create Datums or Tools > Features > Create 
Features to define important areas of comparison on the CAD object.

By using the hard probe on a test part that is mounted on the text fixture, 
you will establish the position of the datums and features with respect to the 
test fixture. You will not scan a test part yet.

4. Start Plugins > Faro Scan.

5. Click the large Hard Probing icon, indicating that you will use the 

touch probe next.
6. Mount a test part on the test fixture. Using the hard probe, define two or 

more features or datums (for details, see Datum and Feature Creation -- 
Step-by-Step on 1-13). Recall that no test object exists in the model 
manager, and you are not laser scanning a test part -- you are creating a 
special “blank” test object named “Features/Datums” that records the 
position of the datums and features with respect to the test fixture.
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7. Exit the plugin by clicking the OK button.  In the model manager, note 
the existence of the CAD object and a new test object called "Features/
Datums". Note the existence of Feature and Datum sub-objects under the 
Features/Datums object.

The next goal is to detect the spatial difference between the reference object 
and the place where an actual test object will rest on the test fixture.

8. Use Tools > Alignment > Datum/Features Alignment on the test 
and reference objects (which aligns the reference object with the special 
test object by aligning their datums and features). The side effect of this 
process is that it creates an internal transformation matrix, which is a 
mapping of the spatial difference between the reference object and the 
place where an actual test object will rest on the test fixture.

The next goal is to prepare for the scanning of an actual test part. You will 
instruct the plugin that the spatial orientation of the real test part will be the 
same as that detected in the alignment process in step 8.

9. Select Plugins > Faro Scan again, and click the large Alignment icon.
10. Click the "Use Last Test Alignment" button. This establishes the orienta-

tion of the next scan to be the same as the existing test object.
11. Click the Merge Features/Datums to Next Scan checkbox. This 

causes the features and datums that exist in the Feature/Datum object to 
be replicated into the object created during the next scan. 

Next, scan a test part.

12. Click the large Laser icon to activate scanning mode. Begin scan-

ning. For details, see FARO Scan -- Step-by-Step on 1-12. Scan data 
appears on the screen in alignment with the CAD reference object.

13. Exit the plugin by clicking the OK button. In the model manager, notice 
that the newly created scan object is now the test object.

Perform repetitive scanning of test parts.

14. To scan and rapidly align another test object, select Plugins > Faro 
Scan again and go to step 12.


