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For a list of Minolta devices and Geomagic software products with which this
plugin is compatible, see Release Notes for Geomagic Minolta VIVID Plugin.
The Minolta devices that are compatible with this plugin are non-contact 3D
digitizers that scan an object on or without a turntable. [See Konica Minolta
Photo Imaging U.S.A., Inc. at www.minoltausa.com.]
The purpose of this (or any) scanner plugin is to eliminate the need to import
scan data into Geomagic products. With the plugin, scanned data exists in the
Geomagic Model Manager immediately after the data capture process.
Hardware > Scan > Minolta VIVID integrates data capture and processing
into the Geomagic user interface. (This menu item in Geomagic products is
an optional, separately licensed feature. If Minolta VIVID does not already
appear on the Plugins menu, download the software from support.geomagic.com, install it according to simple instructions on the web site, and restart this procedure.)
Table of Contents
Controls and Indicators

page 2

Scan function
Photogrammetry function
Step-by-Step Procedures

page 8

Simple Scan with Turntable

page 8

Photogrammetry With .CSV File

page 8

Photogrammetry With Target Registration

page 9

Document version H

page 1

Geomagic, Inc.

Minolta VIVID Scanner Plugin

Geomagic Studio and Qualify

Controls and Indicators
The Sample Scan dialog has the following controls and indicators.

•

Scan group - controls the scanner.
• Display Units group • Units dropdown (such as Inches, Millimeters, Centimeters ...)
specifies the units of measure on the object that will be scanned,
such as inches or millimeters.
• Turn Table group - controls the behavior of the turntable
• Turntable dropdown - specifies the model number of the turntable in use.
• Com Port dropdown - specifies the COM port to which the turntable is connected.
• Scan Mode (Single, Multishot, Continuous):
• Single - This mode can be used to take individual shots, and
is the only mode available when the turntable is disabled.
• MultiShot - causes the turntable to rotate by Step degrees
and a new scan to take place every time the user presses
Next. During a MultiShot process, click Next to move on to
the next scan, or adjust the parameters and click Scan to rescan the object at its current position.
• Continuous - is similar to MultiShot mode except that scanning and rotation are non-stop (without pressing Next) until
the Current Position reaches 360 degrees or less (until Step
would cause Current Position to exceed 360 degrees).
• Current Position decimal field - controls rotation of the turntable.
• Step decimal field - specifies the increment of change of the turntable upon each new scan.
• Reset Axis button - declares the current position of the turntable
to be the “home” position. Subsequent movements are relative to
this “home” position.
• Calibrate button - calibrates the turntable (finds the axis of rotation). When prompted, install the calibration plate onto the turntable.
• Camera Control group (when Advanced Options > Configure > Vivid
Model is 9i) • Image Focus button - automatically focuses the camera on the subject.
• Auto Focus checkbox - Specifies whether the camera uses automatic
focusing. When Auto Focus is turned off, use the Distance control
to focus manually.
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• Distance integer field (600 to 3000 millimeters; applicable when
Auto Focus is Off) - specifies the distance between the lens and
the focal point.
• Auto Intensity checkbox (default On) - specifies that the beam
intensity be selected by software based on reflectivity of the object.
When deactivated, set Laser Power and Gain by hand.
• Laser Power integer field (0 to 100; applicable when Auto Intensity is off) - controls the intensity of the laser beam. Higher intensity is suitable for darker colors, lower intensity for lighter colors.
• Gain integer field (0 to 100; applicable when Auto Intensity is off
and Laser Power is at 100) - controls the intensity of the CCD
gain. Use CCD gain only when Laser Power of 100 is insufficient
because the object reflects light, transmits light, or has low reflectance for red and similar colors.
• Auto Brightness radio button and thumbwheel - specifies that
image brightness be set automatically, or allows manual setting.
• Brightness integer field (0 to 14; when Auto Brightness is not
checked) - specifies the brightness.
• Advanced Options checkbox - activates the following advanced settings.
• Advanced Camera Control group - describes the hardware
setup:
• Calibrate New Lens button - Press this after installing a new
lens on the camera. Be sure to install the calibration fixture
before pressing this button.
• Multi Power Setting checkbox and Scans integer field specifies that n varying-intensity passes of the laser beam be
made at every angle to improve color detection. Otherwise,
one scan is performed at each angle.
• Filter dropdown - specifies the type of hardware filter to use:
None, Noise Filter, High Quality Filter, or both.
• Remove dropdown - activates a hardware-based scan angle
filter. A scan angle filter removes data points whose normal
exceeds a given angle away from the camera’s direction of
view.
• Scanning Options group • Name (text field) - is the name assigned to the next scan. By
default, the Name is “Scan” with a suffix assigned by the movement
device (such as a turntable). For example, a turntable device might
append a suffix of “-180”.
• Scan button - initiates a laser scan named in the Name field. To rescan an object from a given angle, press Scan instead of Next.
• Next button - saves the previous scan in the Geomagic Model Manager. The function of Next depends on the Scan Mode in the Turntable group:
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• when Scan Mode is Single, saves the previous scan in the Geomagic Model Manager.
• when Scan Mode is MultiShot, saves the previous scan in the Geomagic Model Manager, increments the degree part of Name by the
amount configured at Rotation Step, and rotates the turntable by
that amount. When you are ready for the next scan, click Scan.
• when Scan Mode is Continuous, saves the first scan in the Geomagic Model Manager, increments the degree part of Name by the
amount configured at Rotation Step, rotates the turntable by that
amount, initiates another laser scan, and continues according to
the description of continuous scan mode below.
• Abort button - aborts any scan that was started when the Scan
Mode in the Turntable group of controls is Continuous.
• Show Current Scan Only checkbox - specifies whether to show only
the most recent scan in the Viewing Area, or a composite of all scans.
This is useful in determining the quality of the most recent scan.
• Scan Angle Filter decimal field (0 to 90 degrees; default 75.0) specifies the “maximum divergence from perpendicular” of surfaces
whose points are to be captured. A point whose surface normal is
more than Angle degrees away from parallel to the beam direction
will be ignored. Example: If you are scanning a ball at an Angle of 75
degrees, scan data would be collected from points whose normal is
up to 75 degrees away from the closest point to the camera (for a
total of 150 degrees across the face of the ball).
• Live Image Display group • Show/Hide Live Image Window button - specifies whether to display a separate Image Viewer window containing a color image of the
object and a color-encoded range map of the object.
• Stream checkbox - specifies whether to update the color image in
real time, useful while the operator positions an object in the scanner’s field of view.
• Update button - updates the color image and the color-encoded
range map immediately.
OK button - saves a scanned object to the Model Manager and closes the
dialog.
Cancel button - terminates the dialog without saving data to the Model
Manager.

•

Photogrammetry group (only for 9i hardware) - controls the
scanner in photogrammetry mode. Photogrammetry is a feature that
assembles multiple scans of a large physical object into a single data
object, based on the registration of target points that are affixed to the
physical object.
• Display Units group -
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• Units dropdown (such as Inches, Millimeters, Centimeters ...)
specifies the units of measure on the object that will be scanned,
such as inches or millimeters.
• Turn Table group - controls the behavior of the turntable
• Turntable dropdown - specifies the model number of the turntable in use.
• Com Port dropdown - specifies the COM port to which the turntable is connected.
• Scan Mode (Single, Multishot, Continuous):
• Single - This mode can be used to take individual shots, and
is the only mode available when the turntable is disabled.
• MultiShot - causes the turntable to rotate by Step degrees
and a new scan to take place every time the user presses
Next. During a MultiShot process, click Next to move on to
the next scan, or adjust the parameters and click Scan to rescan the object at its current position.
• Continuous - is similar to MultiShot mode except that scanning and rotation are non-stop (without pressing Next) until
the Current Position reaches 360 degrees or less (until Step
would cause Current Position to exceed 360 degrees).
• Current Position decimal field - controls rotation of the turntable.
• Step decimal field - specifies the increment of change of the turntable upon each new scan.
• Reset Axis button - declares the current position of the turntable
to be the “home” position. Subsequent movements are relative to
this “home” position.
• Calibrate button - calibrates the turntable (finds the axis of rotation). When prompted, install the calibration plate onto the turntable.
• Camera Control group (when Advanced Options > Configure > Vivid
Model is 9i) • Image Focus button - automatically focuses the camera on the subject.
• Auto Focus checkbox - Specifies whether the camera uses automatic
focusing. When Auto Focus is turned off, use the Distance control
to focus manually.
• Distance integer field (600 to 3000 millimeters; applicable when
Auto Focus is Off) - specifies the distance between the lens and
the focal point.
• Auto Intensity checkbox (default On) - specifies that the beam
intensity be selected by software based on reflectivity of the object.
When deactivated, set Laser Power and Gain by hand.
• Laser Power integer field (0 to 100; applicable when Auto Intensity is off) - controls the intensity of the laser beam. Higher intensity is suitable for darker colors, lower intensity for lighter colors.
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• Gain integer field (0 to 100; applicable when Auto Intensity is off
and Laser Power is at 100) - controls the intensity of the CCD
gain. Use CCD gain only when Laser Power of 100 is insufficient
because the object reflects light, transmits light, or has low reflectance for red and similar colors.
• Auto Brightness radio button and thumbwheel - specifies that
image brightness be set automatically, or allows manual setting.
• Brightness integer field (0 to 14; when Auto Brightness is not
checked) - specifies the brightness.
• Advanced Options checkbox - activates the following advanced settings.
• Advanced Camera Control group - describes the hardware
setup:
• Calibrate New Lens button - Press this after installing a new
lens on the camera. Be sure to install the calibration fixture
before pressing this button.
• Multi Power Setting checkbox and Scans integer field specifies that n varying-intensity passes of the laser beam be
made at every angle to improve color detection. Otherwise,
one scan is performed at each angle.
• Filter dropdown - specifies the type of hardware filter to use:
None, Noise Filter, High Quality Filter, or both.
• Remove dropdown - activates a hardware-based scan angle
filter. A scan angle filter removes data points whose normal
exceeds a given angle away from the camera’s direction of
view.
• Scanning Options group • Name (text field) - is the name assigned to the next scan. By
default, the Name is “Scan” with a suffix assigned by the movement
device (such as a turntable). For example, a turntable device might
append a suffix of “-180”.
• Scan button - initiates a laser scan named in the Name field. To rescan an object from a given angle, press Scan instead of Next.
• Next button - saves the previous scan in the Geomagic Model Manager. The function of Next depends on the Scan Mode in the Turntable group:
• when Scan Mode is Single, saves the previous scan in the Geomagic Model Manager.
• when Scan Mode is MultiShot, saves the previous scan in the Geomagic Model Manager, increments the degree part of Name by the
amount configured at Rotation Step, and rotates the turntable by
that amount. When you are ready for the next scan, click Scan.
• when Scan Mode is Continuous, saves the first scan in the Geomagic Model Manager, increments the degree part of Name by the
amount configured at Rotation Step, rotates the turntable by that
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amount, initiates another laser scan, and continues according to
the description of continuous scan mode below.
• Abort button - aborts any scan that was started when the Scan
Mode in the Turntable group of controls is Continuous.
• Show Current Scan Only checkbox - specifies whether to show only
the most recent scan in the Viewing Area, or a composite of all scans.
This is useful in determining the quality of the most recent scan.
• Scan Angle Filter decimal field (0 to 90 degrees; default 75.0) specifies the “maximum divergence from perpendicular” of surfaces
whose points are to be captured. A point whose surface normal is
more than Angle degrees away from parallel to the beam direction
will be ignored. Example: If you are scanning a ball at an Angle of 75
degrees, scan data would be collected from points whose normal is
up to 75 degrees away from the closest point to the camera (for a
total of 150 degrees across the face of the ball).
• Photogrammetry Options group • Use Target Registration checkbox and Matching Sensitivity
slider - causes every new scan to be registered with the one or
more existing scans. Each new scan must have three or more
stickers in common with an existing scan. The slider controls the
perfectness of the match that must exist between the three (or
more) stickers in common. Typically, leave the slider in the middle.
When Use Target Registration is not checked, the scans do not
register automatically.
• Live Image Display group • Show/Hide Live Image Window button - specifies whether to display a separate Image Viewer window containing a color image of the
object and a color-encoded range map of the object.
• Stream checkbox - specifies whether to update the color image in
real time, useful while the operator positions an object in the scanner’s field of view.
• Update button - updates the color image and the color-encoded
range map immediately.
OK button - saves a scanned object to the Model Manager and closes the
dialog.
Cancel button - terminates the dialog without saving data to the Model
Manager.
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Step-by-Step Procedures
•
•
•

Simple Scan with Turntable on page 8
Photogrammetry With .CSV File on page 8
Photogrammetry With Target Registration on page 9

Simple Scan with Turntable
1. Click the Minolta icon

, or select Hardware > Scan > Minolta

VIVID on the Geomagic ribbon.
2. Perform any necessary calibration of the turntable (if any).
3. Place an object on the turntable.
4. Set the Show/Hide Live Image Window checkbox, and check Stream
in the Live Image Display group. Move the object on the turntable until
the object is well framed in the Image Window.
5. Hide the live image window by clicking Show/Hide Live Image Window.
6. Press the Scan button in the Scanning Options group. See the first scan
in the Viewing Area.
7. Press Next. The turntable moves as configured. A scan is performed, and
the second set of scan data appears in the Viewing Area.
8. Check Show Current Scan Only to see a separation of the first scan and
second scan.
9. Un-check Show Current Scan Only.
10. Perform additional scans at new angles by pressing Next several more
times, allowing time for each scan to complete.
11. The several scans appear in the Viewing Area to be a single merged
object, but they are not. They are simply a set of scans that occupy the
same position in space.
12. Press OK.
13. Click the Model Manager tab to see that each individual scan appears as a
separate object. To create a single merged object, use Points > Merge.

Photogrammetry With .CSV File
This procedure assumes familiarity with photogrammetry, including how to
apply target stickers/magnets to the object.
1. Click the Minolta icon

, or select Hardware > Scan > Minolta

VIVID on the Geomagic ribbon.
2. Place the black and white calibration chart on the turntable, click Calibrate, wait for the center axis to appear in the Viewing Area, and remove
the chart from the turntable.
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3. Using the live image in the Work screen as a guide, place the object on
the turntable in the camera’s field of view. Ensure that three or more targets are visible to the camera.
4. Verify that the Use Target Registration checkbox is not checked
(because this function would override the registration that will be performed by the Minolta scanner).
5. Press the Scan button in the Scanning Options group.
6. At the prompt, click Specify Target Location and click OK. Enter the
name of a .csv file to load. This file contains target information from a
digital camera.
7. See the first scan in the Viewing Area.
8. Press Next. The turntable moves as configured. A scan is performed, and
the second set of scan data appears in the Viewing Area.
9. Check Show Current Scan Only to see a separation of the first scan and
second scan.
10. Un-check Show Current Scan Only.
11. Perform additional scans at new angles by pressing Next several more
times, allowing time for each scan to complete.
12. The several scans appear in the Viewing Area to be a single merged
object, but they are not. They are simply a set of scans that occupy the
same position in space.
13. On the main Minolta Scan dialog, press OK to accept the photogrammetry session and close the plugin. All individual scans are saved to the
Model Manager.
14. To create a single merged object, use Points > Combine > Merge.

Photogrammetry With Target Registration
This procedure assumes familiarity with photogrammetry, including how to
apply target stickers/magnets to the object.
1. Click the Minolta icon

, or select Hardware > Scan > Minolta

VIVID on the Geomagic ribbon.
2. Place the black and white calibration chart on the turntable, click Calibrate, wait for the center axis to appear in the Viewing Area, and remove
the chart from the turntable.
3. If you want the upcoming scans to be registered automatically as the
data is collected, check the Use Target Registration checkbox. If not,
you will register them manually at Step 13. In most cases, check the
checkbox.
4. Press the Scan button in the Scanning Options group.
5. At the prompt, click Detect Targets For Target Registration, then
click OK.
6. See the first scan in the Viewing Area.
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7. Press Next. The turntable moves as configured. A scan is performed, and
the second set of scan data appears in the Viewing Area.
8. Check Show Current Scan Only to see a separation of the first scan and
second scan.
9. Un-check Show Current Scan Only.
10. Perform additional scans at new angles by pressing Next several more
times, allowing time for each scan to complete.
11. The several scans appear in the Viewing Area to be a single merged
object, but they are not. They are simply a set of scans that occupy the
same position in space.
12. On the main Minolta Scan dialog, press OK to accept the photogrammetry session and close the plugin. All individual scans are saved to the
Model Manager.
13. Only if the Use Target Registration checkbox was not checked, register
the Point Datums on the several scans by using Alignment > Scan
Alignment > Target Registration, then create a composite object by
using Points > Combine > Merge.
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