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The Minolta devices that are compatible with this plugin are non-contact 3D
digitizers that scan an object on or without a turntable. [See Konica Minolta
Photo Imaging U.S.A., Inc. at www.minoltausa.com.]
The purpose of this (or any) scanner plugin is to eliminate the need to import
scan data into Geomagic products. With the plugin, scanned data exists in the
Geomagic Model Manager immediately after the data capture process.
In This Chapter
•
•

For reference information on the controls and indicators of the Minolta
Scanning plug-in, see Controls and Indicators on page 1.
For sample scanning procedures, see Step-by-Step Procedures.

Controls and Indicators
The Minolta Scan dialog has the following controls and indicators.
•

Scan group - controls the scanner.
• Name (text field) - is the name assigned to the next scan, in the form
text-degree, where degree is 0 to 360. If a turntable is installed, the
degree part increments by the amount configured at Rotation Step (in
the Turntable group) each time the Next button is pressed.
• Scan button - initiates a laser scan named in the Name field. To rescan an object from a given angle, press Scan instead of Next.
• Next button - saves the previous scan in the Geomagic Model Manager.
If a turntable is installed, the function of Next depends on the Scan
Mode in the Turntable group:
• when Scan Mode is Single, saves the previous scan in the Geomagic
Model Manager.
• when Scan Mode is MultiShot, saves the previous scan in the Geomagic Model Manager, increments the degree part of Name by the
amount configured at Rotation Step, and rotates the turntable by
that amount. When you are ready for the next scan, click Scan.
• when Scan Mode is Continuous, saves the first scan in the Geomagic
Model Manager, increments the degree part of Name by the amount
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configured at Rotation Step, rotates the turntable by that amount,
initiates another laser scan, and continues according to the description of continuous scan mode below.
Abort button - aborts any scan that was started when the Scan Mode
in the Turntable group of controls is Continuous.
Show Current Scan Only checkbox - specifies whether to show only
the most recent scan in the Viewing Area, or a composite of all scans.
This is useful in determining the quality of the most recent scan.
Show Live Image Window checkbox - specifies whether to display a
separate Image Viewer window containing a color image of the object
and a color-encoded range map of the object.
• Color Image panel and Update Color Image button - updates the
color image now.
• Color Image panel and Update Range and Color Image button updates both the color image and the color-encoded range map now.
• Enable Streaming Video checkbox - specifies whether to update
the color image in real time, useful while the operator positions an
object in the scanner’s field of view.
Camera Control group (when Advanced Options > Configure > Vivid
Model is 9i) • Image Focus button - automatically focuses the camera on the subject.
• Auto Focus checkbox - Specifies whether the camera uses automatic
focusing. When Auto Focus is turned off, use the Distance control
to focus manually.
• Distance integer field (600 to 3000 millimeters; applicable when
Auto Focus is Off) - specifies the distance between the lens and
the focal point.
• Auto Intensity checkbox (default On) - specifies that the beam
intensity be selected by software based on reflectivity of the object.
When deactivated, set Laser Power and Gain by hand.
• Laser Power integer field (0 to 100; applicable when Auto Intensity is off) - controls the intensity of the laser beam. Higher intensity is suitable for darker colors, lower intensity for lighter colors.
• Gain integer field (0 to 100; applicable when Auto Intensity is off
and Laser Power is at 100) - controls the intensity of the CCD
gain. Use CCD gain only when Laser Power of 100 is insufficient
because the object reflects light, transmits light, or has low reflectance for red and similar colors.
• Auto Brightness radio button and thumbwheel - specifies that
image brightness be set automatically, or allows manual setting in
the range 0 to 14.
• Photogrammetry group • Photogrammetry button - activates a feature that assembles
multiple scans of a large physical object into a single data object,
based on the registration of target points that are affixed to the
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physical object. The first result of pressing this button is a prompt
that asks how multiple scans should be registered:
• Specify Target Location (.csv file) radio button - The user
browses the file system and loads a .csv file that describes the
locations of registration points that are affixed to the physical
object. By this method, multiple scans will be registered and
created in the Geomagic Model Manager as a single object.
• Detect Targets For Target Registration (no .csv file)
radio button - The user will create multiple scans. Each target
that is affixed to the object will become a Point Target Datum.
The user will use Tools > Registration > Target Registration to
register the multiple scans manually. The advantage of this
technique is that it does not require a .csv file.
When the prompt has been answered, the following dialog
appears. But if the Photogrammetry button is pressed when
Scan Mode is Continuous, the same prompt for automatic or
manual registration appears, the following dialog does not
appear, and the data collection process runs unattended with
default parameters.
• Work screen - presents a real-time streaming image of the
object.
• Mono radio button - presents a monchrome image on the
Work screen.
• Color radio button - presents a color image on the Work
screen.
• Pitch radio button - presents a color-encoded map of distance from the lens.
• Store screen - presents one of many scans that have been
stored by means of the Store button.
• <<Prev button - recalls the previous image from the set.
• Next>> button - recalls the next image from the set.
• Delete button - deletes the current image from the set.
• Other controls • Auto Focus button - automatically focuses the lens.
• Distance checkbox and integer field - overrides automatic
focus by setting the distance to the object.
• Intensity checkbox - activates the following beam settings.
• Laser Power integer field (0 to 100; applicable when
Auto Intensity is off) - controls the intensity of the laser
beam. Higher intensity is suitable for darker colors,
lower intensity for lighter colors.
• Gain integer field (0 to 100; applicable when Auto
Intensity is off and Laser Power is at 100) - controls the
intensity of the CCD gain. Use CCD gain only when Laser
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Power of 100 is insufficient because the object reflects
light, transmits light, or has low reflectance for red and
similar colors.
• Scan button - scans the object and displays it on the Work
screen.
• Store button - transfers the most recent scan from the
Work screen to the Store screen and to the Viewing Area.
• Import button (or Read Next on subsequent use) - presents a dialog for the loading of a Minolta scan file (.cdk)
onto the Work screen. This photogrammetery tool aligns
the multiple imported scans.
• Color Read button (available after Scan and before Store)
- overlays a new color image onto the scan. A scan can be
successful even in darkness, but will not have visible color.
• OK button - transfers stored scans to the Model Manager
and closes the photogrammetry tool.
• Cancel button - closes the photogrammetery tool without
saving images to the Model Manager.
• Export button - saves all stored scans to a single Minolta
Vivid format file (.vvd).
• Options button - opens a page of settings that are downloaded to and retrieved from the camera.
• Calibration button - calibrates the camera, the same function as Calibrate New Lens in the Camera Control group
of the main dialog. Be sure to install the calibration fixture
before pressing this button.
• Use Target Registration checkbox and Matching Sensitivity
slider - causes every new scan to be registered with the one or
more existing scans. Each new scan must have three or more
stickers in common with an existing scan. The slider controls the
perfectness of the match that must exist between the three (or
more) stickers in common. Typically, leave the slider in the middle.
• Camera Control group (when Advanced Options > Configure > Vivid
Model is 700) • Zoom slider (8 degrees from Min to Max) - adjusts the zoom of the
lens on the camera.
• Auto Focus checkbox - Specifies whether the camera uses automatic
focusing. When Auto Focus is turned off, use the Distance control
to focus manually.
• Distance thumbwheel (500 to 3000 millimeters; applicable when
Auto Focus is Off) - specifies the distance between the lens and
the focal point.
• Auto Intensity checkbox (default On) - specifies that the beam
intensity be selected by software based on reflectivity of the object.
When deactivated, set Laser Power and Gain by hand.
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• Laser Power integer field (0 to 100; applicable when Auto Intensity is off) - controls the intensity of the laser beam. Higher intensity is suitable for darker colors, lower intensity for lighter colors.
• Gain integer field (0 to 100; applicable when Auto Intensity is off
and Laser Power is at 100) - controls the intensity of the CCD
gain. Use CCD gain only when Laser Power of 100 is insufficient
because the object reflects light, transmits light, or has low reflectance for red and similar colors.
• Camera Control group (when Advanced Options > Configure > Vivid
Model is 910/900) • Fine Scan and Fast Scan radio buttons - specify a slower, higherresolution scan or a faster, lower resolution scan.
• Dynamic Range Expansion Mode checkbox (applicable with
Fast Scan; default On) - specifies that 3 varying-intensity passes
of the laser beam be made at every angle to improve color detection.
• Auto Focus checkbox - Specifies whether the camera uses automatic
focusing. When Auto Focus is turned off, use the Distance control
to focus manually.
• Distance thumbwheel (500 to 3000 millimeters; applicable when
Auto Focus is Off) - specifies the distance between the lens and
the focal point.
• Auto Intensity checkbox (default On) - specifies that the beam
intensity be selected by software based on reflectivity of the object.
When deactivated, set Laser Power and Gain by hand.
• Laser Power integer field (0 to 100; applicable when Auto Intensity is off) - controls the intensity of the laser beam. Higher intensity is suitable for darker colors, lower intensity for lighter colors.
• Gain integer field (0 to 100; applicable when Auto Intensity is off
and Laser Power is at 100) - controls the intensity of the CCD
gain. Use CCD gain only when Laser Power of 100 is insufficient
because the object reflects light, transmits light, or has low reflectance for red and similar colors.
• Variable Distance Mode checkbox • No. of Scans integer field (2 or 3) • Distance Increment decimal field (0 to 1000 mm) • Turntable group (only when a turntable is installed) • Current Position decimal field (0.0 to 360.0) - is an indicator and
control of the current position of the turntable with respect to the
zero position.
• Rotation Step field (1 to 359; default 45; applicable when Scan
Mode is MultiShot or Continuous) - specifies the number of degrees
of rotation of the turntable per click of the Next button.
• Scan Mode (Single, Multishot, Continuous):
• Single - This mode can be used to take individual shots, and is the
only mode available when the turntable is disabled.
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• MultiShot - causes the turntable to rotate by Rotation Step
degrees and a new scan to take place every time the user presses
Next. During a MultiShot process, click Next to move on to the
next scan, or adjust the parameters and click Scan to re-scan the
object at its current position.
• Continuous - is similar to MultiShot mode except that scanning
and rotation are non-stop (without pressing Next) until the Current Position reaches 360 degrees or less (until Rotation Step
would cause Current Position to exceed 360 degrees).
• Reset Zero button - defines the current position of the turntable as
the home (zero) position.
• Calibrate Axis button - prompts the user to install the black and
white axis calibration “chart” onto the turntable, performs the calibration, and displays the turntable axis in the Viewing Area.
• Advanced Options button - activates the following controls:
• Configure group - describes the hardware setup:
• Vivid Model (900/910 or 700) - specifies the Minolta model in
use.
• SCSI Id field - indicates the address of the Minolta device
detected at system boot. Do not modify.
• Turntable Model - The choices in the pulldown menu correspond
to Minolta-supported model numbers.
• Turntable COM Port (COM1, 2, 3, or 4) - specifies the serial port
to which the turntable is connected.
• Disable Turntable checkbox - specifies whether to disable the
turntable (and the turntable controls and the MultiShot and Continuous Scan Modes in the Minolta Scan dialog).
• Always Prompt User for Axis Calibration checkbox - specifies
whether Studio/Qualify prompts the user to calibrate the turntable
axis every time the Minolta Scan plugin is started. Experienced
users can disable the prompt with this option. To perform the calibration, see the explanation of the Calibrate Axis button.
Scan
Filter Angle group - describes behavior of the scanner:
•
• Angle (degrees) (0 to 90 degrees; default 75) - specifies the
“maximum divergence from perpendicular” of surfaces whose
points are to be captured. A point whose surface normal is more
than Angle degrees away from parallel to the beam direction will
be ignored. Example: If you are scanning a ball at an Angle of 75
degrees, scan data would be collected from points whose normal is
up to 75 degrees away from the closest point to the camera (for a
total of 150 degrees across the face of the ball).
• Advanced Camera Control group (applies only to the Minolta 9i) • Calibrate New Lens button - Press this after installing a new lens
on the camera. Be sure to install the calibration fixture before
pressing this button.
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• Multi Power Setting radio button and integer field - specifies that
n varying-intensity passes of the laser beam be made at every
angle to improve color detection.
• Filter dropdown - specifies the type of hardware filter to use:
None, Noise Filter, High Quality Filter, or both.
• Remove dropdown - activates a hardware-based scan angle filter.
A scan angle filter removes data points whose normal exceeds a
given angle away from the camera’s direction of view.
• Version group - displays the version number of this plugin.
• Version indicator - indicates the version of this Minolta Scan software plugin for this Geomagic product.
• Done button - stores configuration changes and returns to the main
dialog. Most changes on the Advanced Options sub-dialog also
require that the main dialog be closed and restarted.
OK button - saves a scanned object to the Model Manager and closes the
Minolta dialog.
Cancel button - terminates the Minolta dialog without saving data to the
Model Manager.

Step-by-Step Procedures
•
•
•

Simple Scan with Turntable on page 7
Photogrammetry With .CSV File on page 8
Photogrammetry With Manual Registration on page 9

Simple Scan with Turntable
1. Click the Minolta icon
2.
3.
4.
5.
6.
7.
8.

, or select Plugins > Minolta Scan on the

Geomagic toolbar.
Place the black and white calibration chart on the turntable, click Calibrate Axis, wait for the center axis to appear in the Viewing Area, and
remove the chart from the turntable.
Set the values in the Minolta Scan dialog appropriately. Most notably, set
Scan Mode to Multishot and Rotation Step to 45.
Place an object on the turntable.
Set the Show Image Window checkbox, and set Enable Streaming
Video on the Image Window, and move the object on the turntable until
the object is well framed in the Image Window.
Disable Enable Streaming Video and Show Image Window.
Press the Scan button in the dialog. See the first scan in the Viewing
Area.
Press Next. The table rotates 45 degrees, a scan is performed, and the
second set of scan data appears in the Viewing Area.
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9. Set Show Current Scan Only to see a separation of the first scan and
second scan.
10. Un-set Show Current Scan Only.
11. Perform additional scans at new angles by pressing Next several more
times, allowing time for each scan to complete.
12. The several scans appear in the Viewing Area to be a single merged
object, but they are not. They are simply a set of scans that occupy the
same position in space.
13. Press OK. Click the Model Manager tab to see that each individual scan
appears as a separate object. To create a single merged object, use
Points > Merge.

Photogrammetry With .CSV File
This procedure assumes familiarity with photogrammetry, including how to
apply target stickers/magnets to the object.
1. Click the Minolta icon

, or select Plugins > Minolta Scan on the

Geomagic toolbar.
2. Place the black and white calibration chart on the turntable, click Calibrate Axis, wait for the center axis to appear in the Viewing Area, and
remove the chart from the turntable.
3. Verify that the Use Target Registration checkbox is not checked
(because this function would override the registration that will be performed by the Minolta scanner).
4. Press the Photogrammetry button in the Camera Control group.
5. At the prompt, click Specify Target Location and click OK. Enter the
name of a .csv file to load. This file contains target information from a
digital camera.
6. Using the live image in the Work screen as a guide, place the object in the
camera’s field of view. Ensure that three or more targets are visible to the
camera.
7. Focus the camera as necessary.
8. Press Scan.
9. In the Work screen, verify that the three or more targets were identified
and numbered by the software.
10. Press Store to add this scan to the set of stored scans.
11. If necessary, use the <<Prev and Next>> buttons to review the set of
stored scans, and the Delete button to remove a stored scan.
12. Repeat steps 7 through 10 until all needed data has been collected.
13. Press OK. All individual scans are saved to the Model Manager.
14. On the main Minolta Scan dialog, press OK to accept the photogrammetry session and close the plugin.
15. The several already-registered scans appear in the Model Manager and
Viewing Area.
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16. To create a single merged object, use Points > Merge.

Photogrammetry With Manual Registration
This procedure assumes familiarity with photogrammetry, including how to
apply target stickers/magnets to the object.
1. Click the Minolta icon

, or select Plugins > Minolta Scan on the

Geomagic toolbar.
2. Place the black and white calibration chart on the turntable, click Calibrate Axis, wait for the center axis to appear in the Viewing Area, and
remove the chart from the turntable.
3. If you want the upcoming scans to be registered automatically, check the
Use Target Registration checkbox. If not, you will register them manually at Step 16. In most cases, check the checkbox.
4. Press the Photogrammetry button in the Camera Control group.
5. At the prompt, click Detect Targets For Target Registration, then
click OK.
6. Using the live image in the Work screen as a guide, place the object in the
camera’s field of view. Ensure that three or more targets are visible to the
camera.
7. Focus the camera as necessary.
8. Press Scan.
9. In the Work screen, verify that the three or more targets were identified
and numbered by the software.
10. Press Store to add this scan to the set of stored scans.
11. If necessary, use the <<Prev and Next>> buttons to review the set of
stored scans, and the Delete button to remove a stored scan.
12. Repeat steps 7 through 10 until all needed data has been collected.
13. Press OK. All individual scans are saved to the Model Manager.
14. On the main Minolta Scan dialog, press OK to accept the photogrammetry session and close the plugin.
15. The several scans appear in the Model Manager and Viewing Area.
16. Only if the Use Target Registration checkbox was not checked, register
the Point Datums on the several scans by using Tools > Registration >
Target Registration, then create a composite object by using Points >
Merge.
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