Proficy* HMI/SCADA - iFIX
MIGRATION_GUIDE_FIX32_TO_IFIX

Version 5.8
November 2013

Disclaimer of Warranties and Liability
The information contained in this manual is believed to be accurate and reliable. However, GE Intelligent Platforms,
Inc. assumes no responsibilities for any errors, omissions or inaccuracies whatsoever. Without limiting the foregoing,
GE Intelligent Platforms, Inc. disclaims any and all warranties, expressed or implied, including the warranty of
merchantability and fitness for a particular purpose, with respect to the information contained in this manual and the
equipment or software described herein. The entire risk as to the quality and performance of such information,
equipment and software, is upon the buyer or user. GE Intelligent Platforms, Inc. shall not be liable for any damages,
including special or consequential damages, arising out of the user of such information, equipment and software, even
if GE Intelligent Platforms, Inc. has been advised in advance of the possibility of such damages. The user of the
information contained in the manual and the software described herein is subject to the GE Intelligent Platforms, Inc.
standard license agreement, which must be accepted by the buyer or user before the use of such information, equipment
or software.
Trademark Notices
©2013 General Electric Company. All rights reserved.
Proficy is a registered trademark of GE Intelligent Platforms, Inc. a wholly-owned subsidiary of General Electric
Company.
*Trademark of GE Intelligent Platforms, Inc.
All other brands or names are property of their respective owners.
All other product names and marks identified throughout this book are trademarks or registered trademarks of their
respective companies. They are used throughout this book in editorial fashion only. No such use, or the use of any
trade names is intended to convey endorsement or affiliation.
No part of this publication may be reproduced in any form, or stored in a database or retrieval system, or transmitted or
distributed in any form by any means, electronic, mechanical photocopying, recordings or otherwise, without the prior
written permission of GE Intelligent Platforms, Information contained herein is subject to change without notice.

We want to hear from you. If you have comments, questions, or suggestions about our documentation, send them to the
following email address:
doc@ge.com

Table of Contents
About this Guide.......................................................................................................................... 1
Understanding the Migration Process .......................................................................................... 3
Preparation for the Migration ................................................................................................... 3
Migration of the Actual FIX32 Install to iFIX.............................................................................. 6
Project Conversion with the Migration Tools .............................................................................. 15
The Migration Tools Toolbar .................................................................................................. 15
Installation of the Migration Tools........................................................................................... 16
Quick Start for Migration Tools............................................................................................... 17
Tag Group Converter ................................................................................................................ 19
Notes on the Tag Group Converter Source Files.................................................................... 20
Picture Converter ...................................................................................................................... 21
Picture Converter Log File ..................................................................................................... 22
Key Macro Migration Tools ........................................................................................................ 23
Key Macro Export Tool .......................................................................................................... 23
Key Macro Converter............................................................................................................. 24
Key Macro Converter Log Files.............................................................................................. 26
Script Converter ........................................................................................................................ 27
Using the Script Converter..................................................................................................... 27
How the Supported FIX32 Commands Get Converted ....................................................... 30
FIX32 Command Scripts Not Converted ............................................................................ 35
Examples of Unconverted Command Script with Comments .............................................. 35
ZOOM Command .............................................................................................................. 35
Examples of Script Conversions ............................................................................................ 36
Example 1: Open Picture Command Conversion................................................................ 36
Example 2: Replace Picture Command Conversion ........................................................... 37
Script Converter Log Files ..................................................................................................... 38

iii

Migration_Guide_FIX32_to_iFIX

READ_ME_ScriptConvert.csv Log File .............................................................................. 38
MYPIC_READ_ME_ScriptConvert.csv Log File ................................................................. 38
Historical Pen Group Migration Tools......................................................................................... 39
Historical Pen Group Export Tool ........................................................................................... 39
Historical Pen Group Converter ............................................................................................. 40
Recreating Charts with the Chart Group Wizard..................................................................... 41
Troubleshooting Historical Pen Group Migration .................................................................... 42
Testing the Chart Migration Process .................................................................................. 42
Historical Pen Group Converter Log File ................................................................................ 42
Known Issues with Migration Tools ............................................................................................ 43
Script Converter .................................................................................................................... 43
Picture Converter .................................................................................................................. 44
Glossary of Migration Terms...................................................................................................... 45
Index ......................................................................................................................................... 47

iv

About this Guide
This Help file begins by explaining how to upgrade your FIX32 node to iFIX. After you upgrade,
migration tools are provided to help you convert FIX32 or FIX Desktop displays into iFIX pictures.
This Help file also contains information on how to use these tools.
Refer to the following sections for more details:
•

Understanding the Migration Process

•

Project Conversion with the Migration Tools

•

Tag Group Converter

•

Picture Converter

•

Key Macro Migration Tools

•

Script Converter

•

Historical Pen Group Migration Tools

•

Known Issues with Migration Tools

•

Glossary of Migration Terms

NOTE: The migration tools do not install with the default iFIX product install. The install program for
the migration tools (MigrationToolsInstall.exe) is located on your iFIX product DVD in the
Proficy\MigrationTools folder. Once installed, the Migration Tools toolbar can be made available for
you to use in the iFIX WorkSpace. For more information, refer to the Installation of the Migration
Tools section.
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Understanding the Migration Process
The full migration process includes the following steps:
•

Preparation for the Migration

•

Migration of the Actual FIX32 Install to iFIX

•

Project Conversion with the Migration Tools

Refer to the individual sections for more information on each of these steps.

Preparation for the Migration
In order to migrate a FIX32 computer to iFIX, you must first perform the following tasks (in any
order):
•

Convert recipe files to .RCX (Master text) and .RCY (Control text) files. This step is
necessary so that you can later import your recipes into iFIX.

•

Export the I/O driver configuration to a .CSV file, so you can later import the configuration to
your iFIX node.

•

Record the options selected for environmental protection, if it's being used. That way, you can
reenter them into iFIX.

•

Back up all the required files.

•

Export a list of user accounts from the Security Configuration application, if required. This
report includes a list of iFIX users, along with the application features configured for each
user in your FIX applications. It will help you recreate the same security configuration in
iFIX.

•

Add passwords to the file with the security configuration, if you exported it.

•

Generate a system configuration report. This report includes information that you may need
later when you are configuring your SCU. It is also helpful for verifying your system after the
migration.

Once you complete these tasks, you can begin the actual migration.
To convert recipe files to .RCX and .RCY files:
1.

Start FIX32.

2.

If security is enabled, log in with a user account with Administrator rights.

3.

Start the FIX32 Recipe Manager, RCP.EXE.

4.

Save each master recipe as a .RCX file:
a.

Open the master recipe (.RCM file).

b.

On the File menu, click Save As. The Recipe Mod Log dialog box appears.
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5.

6.

c.

Click Save As. The recipe Save As dialog box appears.

d.

In the Save File As Type list, click Master text (*.rcx).

e.

Confirm the location of the RCM folder and that the file name is the same as the
original file.

f.

Click OK.

Save each control recipe as a .RCY file:
a.

Open the control recipe (.RCC file).

b.

On the File menu, click Save As. The Recipe Mod Log dialog box appears.

c.

Click Save As. The recipe Save As dialog box appears.

d.

In the Save File As Type list, click Control text (*.rcy).

e.

Confirm the location of the RCC folder and that the file name is the same as the
original file.

f.

Click OK.

Verify that you saved all recipes by inspecting the FIX32\RCC and FIX32\RCM folders.

To export the driver configuration:
1.

Start the current installation of FIX32 (if it is not already running).

2.

If security is enabled, log in with a user account with Administrator rights.

3.

Start the System Configuration Utility (SCU).

4.

On the Configure menu, click SCADA. The SCADA Configuration dialog box appears.

5.

Select an installed driver (other than SIM), and click the Configure button. The Driver
Configurator program starts.

6.

Select the first channel, CHANNEL1, in the browser on the left side of the window.

7.

On the File menu, click Save. The Save As dialog box appears.

8.

Leave the default location of FIX32\PDB, and enter a name for the file in the File Name field.

9.

In the Save as Type list, click Text Files (*.CSV).

10. Click Save.
11. Repeat steps 6-10 for each channel of the driver that is currently installed. Note the file names
and their location for later use.
12. Repeat steps 5-11 for each I/O driver installed on your system.
13. Exit the SCU.
To record your current environment protection settings:

4

1.

Start the current installation of FIX32 (if it is not already running).

2.

Open the Draw application.

3.

On the Edit menu, click Environment. The Environment Protection dialog box appears.

4.

Inspect and record the enabled options.
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To back up the required files:
1.

Create a new folder on your computer, separate from the FIX32 folder, for the files you want
to save.

2.

Copy the entire PDB folder into this new folder. The PDB folder includes the process
database and driver configuration files (*.PDB, *.CSV, *.GDB, all driver configuration files).

3.

Copy the entire PIC folder, which includes all displays, display templates, tag groups, key
macros, layouts, and custom Dynamos (*.ODF, *.ODT, *.ODT, *.TGE, *.KMX, *.LYT, and
*.SBL files).

4.

Copy the converted master recipe files (*.RCX) in the RCM folder.

5.

Copy the converted control recipe files (*.RCY) in the RCC folder.

6.

Copy the initialization settings for the Draw and View applications and report files (Draw.ini,
View.ini, *.RPT) from the LOCAL folder.

7.

Copy the entire HTRDATA folder, which includes all collected historical data.

8.

Copy the entire HTR folder, which includes your historical collection preferences.

9.

Copy the entire ALM folder, which includes all alarm files and event logs.

10. Copy the entire APP folder, which includes any custom data and configuration files for your
iFIX applications.
11. After you copy all of these files, you may want to back up these files to another location, such
as a network drive or a removable media, as a safeguard until the migration is complete.
To export a list of user accounts from the Security Configuration application:
1.

Start the current installation of FIX32 (if it is not already running).

2.

If security is enabled, log in with a user account with Administrator rights.

3.

Start the System Configuration Utility (SCU).

4.

On the Configure menu, click Security to enter the Security Configuration.

5.

On the File menu, click Export. The Select File dialog box appears.

6.

Browse to the folder that you want to save the file to. By default, this folder is the
FIX32\Local folder. Most likely you will want to save this file to the location where you
backed up the other FIX files.

7.

Use the default name for the .RPT file, which is Security.RPT.

8.

Click Save.

9.

Open this report in a text editor such as Notepad or Wordpad and print a copy.

To add passwords to the exported file with the security configuration:
1.

Open the exported Security.RPT file in a text editor such as Notepad or WordPad.

2.

Search the file for the first instance of the word User: in the report. For example:
User: GUEST
Login-name: GUEST
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Timeout: 00:00:00
Feature: View

3.

Insert the text Password: after the user's login name.

4.

Type the user's password after the colon. An example of what this might look like is as
follows:
User: GUEST
Login-name: GUEST
Password: GUEST
Timeout: 00:00:00
Feature: View

5.

Scroll down through the report and repeat steps 3 and 4 for each user in the report.

To generate a system configuration report:
1.

Start the current installation of FIX32 (if it is not already running).

2.

If security is enabled, log in with a user account with Administrator rights.

3.

Start the System Configuration Utility (SCU).

4.

On the File menu, click Report. The Select Report Name dialog box appears.

5.

Leave the default name in the File Name field. The default name is the node name.

6.

Click Save. A report named NodeName.RPT is saved to the Local folder. A message appears
when the save is complete.
NOTE: NodeName is the name from step 5.
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Click OK to continue.

Migration of the Actual FIX32 Install to iFIX
In order to migrate a FIX32 computer to iFIX, you must first perform these tasks, in the order listed:
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1.

Install iFIX.

2.

Update the Database Dynamos, if you want to use your FIX32 Database Dynamos in the iFIX
WorkSpace.

3.

Install the newest drivers and iFIX product SIMs, if any are available.

4.

Copy the backed up files into the appropriate Proficy iFIX product folders.

5.

Import the FIX I/O driver configuration information.

6.

Verify the I/O driver and database migration.

7.

Import the recipe files.

8.

Import the security configuration, if required.
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9.

Reconfigure the application features and passwords for each user, if you imported the security
configuration.

10. Enable Environmental Protection, if applicable.
The steps that follow explain how to perform each of the above tasks in more detail.
To install iFIX software:
1.

Log in to Windows with Administrator privileges. Ensure that there are no iFIX, FIX, or
Proficy processes running, and close any other programs that are running.
NOTE: If you plan to use the integrated Proficy Historian features in iFIX, you must shut
down Historian services and licensing prior to installing iFIX and Historian.

2.

Insert the iFIX DVD into your DVD drive. The iFIX installation screen appears.
NOTE: If this screen does not automatically appear, double-click the InstallFrontEnd.exe file
on the DVD to display it. A message may appear with a security warning, click Run to
proceed.

3.

Click the "Install iFIX" link. A message box appears asking you to confirm the install.

4.

Click Yes to proceed. The install program starts and the Welcome screen appears.

5.

Click Next to continue. The license agreement screen appears.

6.

Click "I accept the terms of the license agreement" if you want to continue, and then click
Next.
IMPORTANT: If a previous version of iFIX is detected, you can choose to upgrade iFIX. For
iFIX versions before 4.0, you have the choice to upgrade or install iFIX to a completely new
folder, without upgrading. If you want to upgrade, it is suggested that you do so using the
install at this point in time.
The Setup Type screen appears.

7.

Select an option and click Next:
•

Complete – Installs all iFIX components, including options such as FIX Desktop,
the Sample System, the Electronic books (e-books), and the My-T-Soft virtual (on
screen) keyboard.

•

Custom – Installs iFIX and the options that you choose. You are prompted to enter
your options after you select an install path.

•

Typical – Installs iFIX, the Electronic books (e-books), the Sample System, and the
My-T-Soft virtual (on screen) keyboard. FIX Desktop is not installed with this
option.

The Choose Destination Location screen appears.
8.

Leave the default C:\Program Files\Proficy\Proficy iFIX path or click Browse to select a
folder.
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NOTES:

9.

•

If you are upgrading from FIX32, make sure that you choose a location other than
the folder that contains your FIX32 software, if it is installed on the same computer. Do
not install over a current FIX32 installation.

•

If you enter a custom install path, be aware that the path can be no greater than 100
characters long.

•

If you want to use 6.x drivers, the iFIX compressed install path must be no greater than
64 characters long. iFIX uses the Microsoft compression algorithm to try to fit longer
paths within this boundary. Some paths are not compressible to the 64 character
maximum length. Please be aware of this. In addition, make sure that the registry key,
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem\NtfsDisable
8dot3NameCreation, is not enabled (is set to 0) when the install folder is created. When
set to 1, the compression algorithm is disabled. Refer to Microsoft help for more
information on the GetShortPathName() compression algorithm.

•

After installing a 6x driver, the driver is listed in the SCU in the Drivers Available
dialog box (which can be accessed from the I/O Driver Name browse button in the
SCADA Configuration dialog box). You need to manually add the driver to the
Configured I/O Drivers list in the SCADA Configuration dialog box.

Click Next to continue.
NOTE: If you selected a Custom install, instead of Complete, the Select Features screen
appears. Select the features you want to install, and click Next.
The Ready to Install Program screen appears.

10. Click Install. The progress of the installation displays on screen as the files are copied. After a
few minutes, when the install finishes copying the files, the Proficy iFIX Configure Wizard
dialog box appears.
11. Enter the Node Name, Node Type, and Connectivity Type, if applicable, and then click OK.
A message box appears, notifying you that either Proficy Historian is already installed or that
is going to be installed.
12. Click OK. If you chose to install Proficy Historian, the Historian installation screen appears.
Otherwise, proceed to step 15.
13. If you do not want to install Historian click Cancel and skip to step 15. Otherwise, go to step
14.
NOTE: If you choose not to install Historian, the following features will not work:
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•

iFIX database tags from Database Manager will not automatically be added,
updated, or deleted to or from Historian.

•

You will not be able to update the Proficy Historian tab of Database Manager
blocks.

•

Imported or exported database tags will have default values in the Historian field but
will not be used.
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•

The FixtoHIst.exe and Historical Datalink features will be installed, but will not
work without Proficy Historian.

14. Install Historian. To do so:
a.

Click Next. The Select Components screen appears.

b.

Choose the components you want to install and click Next. The Windows Firewall
screen appears.
NOTE: If you only want to install collectors on this node, do not install the
Historian server; clear the Server check box.

c.

Select Yes and click Next. The Select OPC Servers screen appears.

d.

Select the OPC Servers you want to use and click Next. The Choose the Program
Folder screen appears.

e.

Leave the default path or click Browse to select a folder, and then click Next. The
Choose the Archive Folder screen appears.

f.

Leave the default path or click Browse to select a folder, and then click Next. The
Configuration Review screen appears.

g.

Click Next. The progress of the installation displays on screen as the files are copied.
The Setup Complete screen appears.

h.

Click Finish. A message box appears reminding you to manually install the Historian
Service Pack 1 and SIM, located on the installation DVD, after iFIX installation
completes.

i.

Click OK.

15. When a message box appears requesting that you view the release notes, click Yes. Close the
release notes after you finish reviewing them to resume the install. The Setup Complete
screen appears.
16. Click Finish.
17. After the install completes:
•

If you have a new key, power off the computer and insert your USB or parallel port
key into the appropriate port.

•

If you have an older key that you are updating, use the update file and follow the
instructions from GE Intelligent Platforms to update your key.

18. Restart the computer. As the computer restarts, log in to Windows with the same user name
(with Administrator rights).
IMPORTANT: If upgrading from FIX v7 to iFIX with FIX Desktop, do not start iFIX yet.
Refer to the Overview of Steps to Upgrade from FIX 7.x section for information on how to
proceed.
19. If you installed Historian, proceed to install the required Historian Service Pack and SIM. The
SIM provides you with the new version of the Historian toolbar that includes the Configure
Historian Server button and the new VisconX button.
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To update the Database Dynamos:
Obtain the updates from your Database Dynamos vendor or recompile the Dynamos with the
iFIX Database Dynamo Toolkit. For information on the toolkit, contact GE Intelligent
Platforms.
To install the newest drivers and iFIX product SIMs:
IMPORTANT: You must install the most current drivers before you migrate the Process
Database (PDB) files from FIX32 to iFIX. This step is necessary so that your FIX32
applications can migrate properly to iFIX.
1.

Obtain the most current Driver CD or the driver update from the GlobalCare Support web
site, http://www.ge-ip.com/support.

2.

Follow the instructions that came with your driver CD, or the information included with the
driver download.

3.

Check for the latest patches for the iFIX product. Obtain all applicable iFIX SIMs and addons from the GlobalCare Support web site, http://www.ge-ip.com/support.

4.

Install these SIMs on top of the installed iFIX product.

5.

Do not start iFIX.

To copy the backed up files into the appropriate Proficy iFIX product folders:
1.

Copy the *.PDB, *.CSV, and *.GDB files from the FIX32 PDB folder into the iFIX PDB
folder.
NOTE: If you installed iFIX to the default location, the iFIX folders are located in this path:
C:\Program Files\Proficy\Proficy iFIX.

2.

Copy the contents of the FIX32 PIC folder into the iFIX PIC folder.

3.

Copy the *.RCX files into the iFIX RCM folder.

4.

Copy the *.RCY files into the iFIX RCC folder.

5.

Copy the Draw.ini, View.ini, *.RPT files for FI32X into the iFIX Local folder.

6.

Copy the contents of the FIX32 HTRDATA folder into the iFIX HTRDATA folder.

7.

Copy the contents of the FIX32 HTR folder into the iFIX HTR folder.

8.

Copy the contents of the FIX32 ALM folder into the iFIX ALM folder.

9.

Copy the contents of the FIX32 APP folder into the iFIX APP folder.

To import the FIX I/O driver configuration information:
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1.

On the Start menu, point to Programs, Proficy HMI SCADA - iFIX, and then System
Configuration. The SCU application appears.

2.

Verify that the Node name that appears on the main screen is correct. Refer to the
NodeName.RPT report file if you are unsure of the name.

3.

Double-click the Database name to enter the Database Name you want to use. The Database
Definition dialog box appears. Ensure it is the same name as the previous project.
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4.

Click OK. A prompt appears stating that the database does not exist.

5.

Select Yes, and use the database anyway.

6.

On the Configure menu, click SCADA. The SCADA Configuration dialog box appears.

7.

Verify that the required drivers appear in the Configured I/O Drivers list. If required, add the
SIM and any other required drivers to the Configured I/O Drivers list.

8.

Click OK, and then Yes when prompted.

9.

On the File menu, click Save.

10. Close the SCU.
11. On the Start menu, point to Programs, Proficy HMI SCADA - iFIX, and then iFIX. The iFIX
Startup screen appears.
12. Make sure the local node name is correct, and click the Start button in this dialog box to start
iFIX.
13. When iFIX is running, start the SCU again.
14. On the Configure menu, click SCADA. The SCADA Configuration dialog box appears.
15. Verify each driver configuration is correct by selecting the driver and then clicking the
Configure button. The Driver Configurator opens.
If the driver configuration is correct, you can close the Driver Configurator and proceed to
step 24.
If you need to make changes, you can make the necessary changes, save the file, and proceed
to step 24. Otherwise, import the driver configuration by following steps 16-22.
16. Select the first channel, CHANNEL1, in the browser on the left side of the window.
17. On the File menu, click Open. The Open dialog box appears.
18. Select Text Files (*.CSV) from the Save as Type drop-down list.
19. Select the .CSV file for the channel.
20. Click Open.
21. Repeat steps 16-20 for each channel of the driver that is currently displayed.
22. Repeat steps 15-21 for each I/O driver installed on your system.
23. When you finish these tasks for all drivers, click the Save Command on the File menu, and
exit the Driver Configurator.
24. Save and Exit the SCU.
To verify the I/O driver and database migration:
1.

Start iFIX.

2.

Start Mission Control from the iFIX WorkSpace. You can find the button to launch Mission
Control in the WorkSpace tree.

3.

Examine the information on the I/O Control tab. Ensure that data is being polled. If data is
present, advance to step 6.

4.

If there is no data present, ensure that the driver is loaded and is running. Exit Mission
Control and select System Configuration to start the SCU.
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5.

On the Configure menu, click SCADA. The SCADA Configuration dialog box appears.

6.

Select the I/O driver and verify that the Poll Records are present. If they are not present,
repeat the import of the I/O driver configuration files.

7.

Maximize the iFIX WorkSpace and then:

8.

•

Start Database Manager from the WorkSpace System Tree.

•

Verify that the I/O addresses for your data blocks are correct.

Save and exit Database Manager.

Errors that occur during the database conversion are written to the error log file (dbcvt.err). You can
open this file in any text editor. Use this log file to identify the individual tags causing the problems.
Be aware that backups of the converted database files appear in the PDB folder with numbered
extensions.
To import the recipe files:
1.

From the iFIX WorkSpace, select the FIX Recipes folder in the system tree.

2.

Double-click the New Recipe icon. The Recipe Development utility appears.

3.

Open each .RCX file in the iFIX RCM folder and save each file as a .RCM file.

4.

Open each .RCY file in the iFIX RCC folder and save each file as a .RCC file.

5.

When you are finished, exit the Recipe Development utility.

To import the security configuration:
1.

Start iFIX (if it is not already running).

2.

On the Start menu, point to Programs, Proficy HMI SCADA - iFIX, and then System
Configuration. The SCU application appears.

3.

On the Configure menu, click Security. The Security Configuration application appears.

4.

On the File menu, click Import. The Select File dialog box appears.

5.

Browse to the folder to which you copied the backed up .RPT file – the iFIX Local folder.

6.

Select the file and click Open. A message box appears warning you that the imported user
accounts will not contain passwords.

7.

Click Yes to continue. Another message box appears requesting that you replace or add this
file to the existing configuration.

8.

Click Replace.
IMPORTANT: Do not shut down the SCU before moving on to the next set of steps. If you
did not add passwords to the user accounts before you migrated, you could possibly lock
yourself out, if security is enabled.

9.

Reconfigure the application features and passwords for each user.

To reconfigure the application features and passwords for each user:
NOTE: The SCU should still be open from the previous set of steps.
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1.

On the Configure menu, click Security. The Security Configuration application appears.

2.

On the Edit menu, click User Accounts.

3.

Select a user and click Modify. The User Profile dialog box appears.

4.

Enter a new password in the Password field if you want to assign a password.

5.

Click the Modify button beneath the Application feature list (the list on the right-side of the
window). The Application Feature selection dialog box appears.

6.

Add the required features. Click Add All if you want to allow this user to use all application
features.
For information on the names used with each feature and the new features available, refer to
the "Reconfigure the Application Features and Passwords for Each User" section of the
Getting Started with iFIX ebook. This section can be found in the "Upgrading from FIX 7.x"
chapter.

7.

Click OK.

8.

Click OK to exit the User Profile dialog box.

9.

Repeat steps 3-8 for each user listed in the User Accounts dialog box.

10. Click OK to exit the User Accounts dialog box.
11. On the Edit menu, click Group Accounts. The Group Accounts dialog box appears.
12. Select a group and click Modify. The Group Profile dialog box appears.
13. Click Modify in the Application Features section of the dialog box. The Application Feature
selection dialog box appears.
14. Add the required features. Click Add All if you want to allow this group to use all application
features.
15. Click OK.
16. Click OK to exit the Group Profile dialog box.
17. Repeat steps 12-16 for each group listed in the Group Accounts dialog box.
18. On the File menu, click Save to save the security configuration.
19. On the File menu in the Security Configuration program, click Exit to return to the SCU.
20. Save and exit the SCU.
To enable Environmental Protection:
1.

Start iFIX.

2.

Shut down View and the WorkSpace if either is running.

3.

If you want to use the Disable Pop-up Menu option, open the FixUserPreferences.ini file in
the iFIX Local folder. In the [AppRunPreferences] section, make the following change:
PopUpMenu=0

When the PopUpMenu=1, then the right-click pop-up menu is not available. When this value
is set to 0, the pop-up menu is available in View.
4.

To set the other environment settings, open the iFIX WorkSpace.
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5.

In Classic view, on the WorkSpace menu, click User Preferences.
-OrIn Ribbon view, on the Home tab, in the WorkSpace group, click Settings, and then click User
Preferences.

6.

Select the Environment Protection tab.

7.

Select the Enable Run Time Environment Protection check box. After you enable this setting,
the check boxes below become available.

8.

Select the options that you want to enable. For details on each of these options, refer to the
table in the "Understanding Environment Protection" topic in the Getting Started with iFIX
electronic book.
NOTE: After you enable the environment protection feature in WorkSpace, you must
shutdown View (if it is still running) and restart it for the environmental protection settings to
apply.
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Project Conversion with the Migration
Tools
If you created displays in the Draw application, and you want to convert them to pictures you can
display in the iFIX WorkSpace, you will find the migration tools helpful. Each migration tool is
responsible for migrating a particular component of the FIX system to a corresponding component in
iFIX. The migration tools include the following:
•

Tag Group Converter – converts FIX Tag Groups to iFIX Tag Groups

•

Picture Converter – converts FIX screens to iFIX pictures

•

Key Macro Export Tool – Exports FIX Key Macros to a Text file

•

Key Macro Converter – Converts Key Macro CSV files into iFIX Key Macros

•

Script Converter – converts FIX Command Language into iFIX VBA

•

Historical Pen Group Export Tool – Exports FIX Pen Groups into CSV files

•

Historical Pen Group Converter – Converts CSV files into iFIX files

You can obtain the migration tool install program on the iFIX product DVD. You can also obtain this
install program from the GlobalCare support site or on the GlobalCare Knowledge base CD.
NOTE: The migration tools do not install with the default iFIX product install. The install program for
the migration tools (MigrationToolsInstall.exe) is located on your iFIX product DVD in the
Proficy\MigrationTools folder. Once installed, the Migration Tools toolbar can be made available for
you to use in the iFIX WorkSpace. For more information, refer to the Installation of the Migration
Tools section.
For information on how to upgrade your FIX32 software to iFIX, refer to the Understanding the
Migration Process section.

The Migration Tools Toolbar
To use the migration tools, display the Migration Tools toolbar in the iFIX WorkSpace. Be aware that
this toolbar is only available for display if, after you installed iFIX, you also installed the migration
tools.
NOTE: The migration tools do not install with the default iFIX product install. Use the install
program for the migration tools (MigrationToolsInstall.exe) on your iFIX product DVD in the
Proficy\MigrationTools folder. Once installed, the Migration Tools toolbar is available for you to use
in the iFIX WorkSpace. For more information, refer to the Installation of the Migration Tools section.
The Migration Tools toolbar contains seven buttons to assist with the migration of FIX32 applications
to iFIX. The toolbar is intended to facilitate the major elements of migration. Each of the buttons on
the toolbar relates to a specific migration task.
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Migration Tools Toolbar
Start with the first button on the left side of the toolbar, and follow the sequence with the next button to
the right, and so on. Complete the steps associated with each button, in the order that they appear in the
toolbar. If a tool is not required, simply skip the button associated with that function and move on to
the next one.
To view the migration toolbar in the iFIX WorkSpace:
1.

After installing the files, start iFIX.

2.

Open the iFIX Workspace.

3.

In the WorkSpace system tree, double-click the Project Toolbar Files folder, and then the
Toolbars folder.

4.

Double-click the MigrationTools item to display the toolbar. The Migration Tools toolbar
should now display in the WorkSpace.

Installation of the Migration Tools
The installer for the migration tools (MigrationToolsInstall.exe) is located on your iFIX product DVD
in the Proficy\MigrationTools folder. Also located in this folder is a copy of this Help file (MG.chm).
This installer requires that iFIX be installed first. You cannot install the migration tools without iFIX.
To use the migration tools after you install them, you need to display the Migrations Tools toolbar.
There are no other additional steps, as with previous versions of the migration tools.
To install the migration tools:
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1.

Shut down iFIX if it is running.

2.

Insert the iFIX product DVD into your DVD drive, and browse to the Proficy\MigrationTools
folder.

3.

Double-click the MigrationToolsInstall.exe file. The install wizard appears, displaying the
Welcome screen.

4.

Click Next to continue. The License Agreement screen appears.

Project Conversion with the Migration Tools

5.

Accept the terms of the license and click Next to continue. The Ready to Install screen
appears.

6.

Click Install. The install process runs. When it completes, a message appears on screen.

7.

Click Finish.

Quick Start for Migration Tools
There are seven steps in the migration process. To migrate a picture from FIX to iFIX, follow these
steps:
•

Step 1 is to run the Tag Group Converter; this is the first button on the tool bar. This tool
converts FIX32 tag group files (*.tge) into iFIX tag group files (*.tgd).

•

Step 2 is to run the Picture Converter; this is the first red button on the toolbar. This tool
converts FIX32 object data files (*.odf) into iFIX picture files (*.grf).

•

Step 3 is to run the Key Macro Export Tool; this is the second red button on the toolbar. This
tool converts all of the necessary key macro files (*.kmx) into text files (*.txt), so you can
later import them into an iFIX picture, as described in step 4. The view.kmx file does not
require conversion, since the iFIX User Global file replaces it.

•

Step 4 is to run the Key Macro Converter; this is the third red button on the toolbar. This tools
converts the key macro text (.txt) files and then imports them into an iFIX picture.

•

Step 5 is to run the Script Converter; this is the fourth red button on the toolbar. This tool
converts FIX32 command language scripts into VBA so you can use them in iFIX. This
command language code that gets converted includes code from object data files and code
added to key macro files. Using the Script Converter is the only way to convert command
language scripts into VBA.

•

Step 6 is to run the Historical Pen Group Export Tool; this is the first blue button on the
toolbar. This tool exports all the FIX historical trending and graphs into three .csv files: Pen
Groups.csv, Time Groups.csv and Chart Groups.csv, so you can later import them into an
iFIX picture, as described in step 7. These files get copied into the HTR folder, which is by
default: C:\Program Files\Proficy\Proficy iFIX\HTR.

•

Step 7 is to run the Historical Pen Group Converter; this is the second blue button on the
toolbar. This tool converts the .csv files for FIX historical trending and graphs into an iFIX
format, and applies the converted files to the appropriate charts. After doing that, use the
Chart Group Wizard in iFIX to recreate the previous FIX32 reports.

•

Step 8 is to inspect the converted pictures and VBA scripts, and make adjustments, where
necessary, to take advantage of iFIX features that were previously unavailable in FIX32.
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Tag Group Converter
The Tag Group Converter converts FIX32 .TGE files into iFIX compatible .TGD files. To access the
Tag Group Converter, use the first button on the Migration Tools toolbar. The Tag Group Converter is
illustrated in the following graphic.

Tag Group Converter Migration Tool
To convert tag groups with the Tag Group Converter:
, the first button

1.

On the Migration Tools toolbar, click the Tag Group Converter button
on the toolbar. The Tag Group Converter appears.

2.

Browse to the folder where the FIX32 tag groups that you want to convert are located.

3.

Double-click the folder that you browsed to in order open it, or click Refresh, to display the
TGE files in the list that appears in the top half of the window.

4.

Select a TGE file and click Add Selected. If you want to convert more than one TGE file in
the same folder, you can click Select All, and then click Add Selected.

5.

The tag group file should appear in the Files to Convert list in the bottom half of the window.

6.

In the String Replacement Options area, leave the default, with all options selected. In the
Type of Conversion area, select TGE - > TGD.

7.

Click Convert. The tag group file is converted, and the .TGD file is placed in the same folder
as the original .TGE file.
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8.

Copy the .TGD file into the iFIX PIC folder, if it is not already there. If you installed iFIX to
the default location, this folder is C:\Program Files\Proficy\Proficy iFIX\PIC.
The tag group file must be located in the C:\Program Files\Proficy\Proficy iFIX\PIC folder for
tag group substitutions to work correctly.

Notes on the Tag Group Converter Source Files
The source files for the Tag Group Converter are provided on the GlobalCare web site in case you
want to modify this migration tool to do additional tasks. To obtain this source from GlobalCare,
access the Developer Download page: http://www.ge-ip.com/support. On the Tag Group Migration
page, download the following files:
•

TGEFileConvertSource.zip – contains the main Tag Group Converter sources files, in
Visual Basic 6 format.

•

TagGroupMigratorSource.zip – contains additional source files in Visual C++ format.

Be aware that this source code is provided as a convenience. Modifications to this project are not
supported by GE Intelligent Platforms.

20

Picture Converter
The Picture Converter converts FIX32 .ODF files into iFIX compatible .GRF files. To access the
Picture Converter, use the second button on the Migration Tools toolbar. The Picture Converter is
illustrated in the following graphic.

Picture Converter Migration Tool
To convert pictures:
, the second button on

1.

On the Migration Tools toolbar, click the Picture Converter button
the toolbar. The Picture Converter appears.

2.

On the File menu, click Set Destination Directory. Or, you can click the Set Destination
Directory button on the toolbar. The Destination Registry dialog box appears.

3.

Enter or Browse for the iFIX PIC folder. If you installed iFIX to the default location, the path
to this folder is C:\Program Files\Proficy\Proficy iFIX\PIC.

4.

Click OK.

5.

On the File menu, click Open ODF File to Convert. Or, you can click the Select ODF Files
button on the toolbar. The Select Picture Files for Conversion dialog box appears.

6.

Select the ODF file(s) for the FIX picture(s) that you want to convert, and click Open. A
message box appears requesting a color palette selection.
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7.

If you have a custom color palette stored as a .PLT file, click Custom to select it. Otherwise,
click Default. The picture conversion process begins.
The overall progress is tracked in the status bar, and messages appear in the bottom half of the
screen as the conversion completes. Additionally, error and warning information is written to
the PictureName.log file, where PictureName refers to the actual name of the picture file.

Picture Converter Log File
A log file is generated with information about the picture conversion process for each picture that you
convert. The log file name is the same as the picture name, but with a.log file extension. The log file is
located in the same folder as the picture you converted, in the destination folder.
The log information in this file is the same information that appears in the log window of the Script
Converter after it runs.
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Key Macro Migration Tools
If you use key macro files (*.kmx) with your FIX picture files (*.odf) or custom key macros in the
View environment, you can also migrate these to iFIX. There are two tools available for key macro
migration:
•

Key Macro Export Tool – to export a key macro (.kmx) file into a text (.txt) file.

•

Key Macro Converter – to convert a key macro .txt file into the applicable iFIX format. For a
FIX picture, the .txt file is converted into commented FIX32 Command Language script
within the iFIX picture file. For View key macros, the .txt file gets imported into the iFIX
user globals for the run mode operations.

IMPORTANT: Be aware that when you convert a key macro file associated with a picture, the key
macro migration tools assume that the .kmx file that you want to convert has the same file name as the
FIX32 picture, but a different file extension. If the key macro and picture file names do not match, you
will need to rename one of the files, and reassociate the key macro with the FIX32 picture, before you
convert it.
Before using the key macro migration tools, first convert your picture files (*.odf) into iFIX picture
files (*.grf) using the Picture Converter migration tool. For more information, refer to the Picture
Converter section.
After you run both the Key Macro Export Tools and the Key Macro Converter, you must run the Script
Converter migration tool. The Script Converter converts commented FIX32 command language
scripts, which the Key Macro Converter generates, into VBA script. For more information, refer to the
Script Converter section. After the conversion takes place, the key macros appear in the iFIX Key
Macro Editor for each applicable picture.
You should inspect the script behind each of the key macros in the Visual Basic Editor to confirm that
they converted properly. You may need to make minor adjustments to some scripts. The comments in
the key macro VBA script typically indicate if changes are necessary.

Key Macro Export Tool
The Key Macro Export Tool exports FIX key macros into a text file. To access the Key Macro Export
Tool, use the third button on the Migration Tools toolbar. The Key Macro Export Tool is illustrated in
the following graphic.
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Key Macro Export Tool
To export key macros to a text file:
1.

Shut down and restart iFIX.

2.

On the Migration Tools toolbar, click the Key Macro Export Tool button
button on the toolbar. The Key Macro Export Tool appears.

3.

Browse to the folder that contains the key macro file (.kmx) that you want to convert and
select the file so that its name appears in the File Name field.

4.

Click Open. A message box appears when the conversion completes.

5.

Click OK.

, the third

Key Macro Converter
The Key Macro Converter converts a key macro text file into the applicable iFIX format. For a FIX
picture, the text file is converted into commented FIX32 Command Language script within the iFIX
picture file. For key macros used in the View environment, the text file (View.txt) gets imported into
the iFIX user globals for the run mode operations.
NOTE: The default key macros in the View.txt file are replaced with iFIX user globals. If you want to
import custom key macros, you need to import the View.txt file.
To access the Key Macro Converter, use the fourth button on the Migration Tools toolbar. The Key
Macro Converter is illustrated in the following graphic.
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Key Macro Migration Tools

Key Macro Converter Migration Tool
To import a text file containing a picture's key macros:
, the fourth button

1.

On the Migration Tools toolbar, click the Key Macro Converter button
on the toolbar. The Key Macro Converter appears.

2.

Browse to the folder that contains the FIX32 key macros that you want to convert, and select
the .txt file.

3.

Click Open. A message box appears when the conversion completes.

4.

Click OK. A message box appears to indicate the name and location of the log file. The log
file usually exists in the same location as the picture. By default, this path is C:\Program
Files\Proficy\Proficy iFIX\PIC.

5.

Click OK to finish.

To import the key macros from the View environment (View.txt) into the iFIX user
globals:
1.

On the Migration Tools toolbar, click the Key Macro Converter button
on the toolbar. The Key Macro Converter appears.

2.

Browse to the folder that contains the View.kmx file that you want to import into iFIX, and
select the file, so that its name appears in the File Name field.

3.

Click Open. A message box appears indicating that user globals were detected.

4.

Click Yes to continue with the import. A message box appears when the conversion
completes.

5.

Click OK.

, the fourth button
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IMPORTANT: Do not try to import the View.txt file more than once in the iFIX user globals.
This may put the iFIX WorkSpace in an unstable state.

Key Macro Converter Log Files
The Key Macro Converter produces log files in the same folder as the converted pictures. These log
files include:
•

A global file, READ_ME_KeyMacroConvert.csv, is generated with information about the
conversion process and a list of the converted picture files.

•

A .CSV file for each converted picture with the name:
MYPIC_READ_ME_KeyMacroConvert.csv, where MYPIC is the actual name of the picture.
This file contains information on the unconverted script commands and warning messages.

You can usually find these logs in the C:\Program Files\Proficy\Proficy iFIX\PIC folder – the PIC path
for the default iFIX install folder.
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Script Converter
The Script Converter converts FIX32 command language scripts into VBA script format for iFIX. This
includes scripts for key macros and pictures that were placed into an intermediary format (comments in
VBA code) after you ran the key macro and picture migration tools.
Before using the Script Converter, you must first convert your picture files (*.odf) into iFIX picture
files (*.grf) using the Picture Converter migration tool. For more information, refer to the Picture
Converter section. Also, if you have any key macros associated with your picture, you must convert
them using the key macro migration tools. For more information, refer to the Key Macro Migration
Tools section.
The Script Converter scans through the VBA code searching for unconverted FIX command scripts,
which are contained as comments in the VBA code within your iFIX picture. When a supported FIX
command script is found, it is converted to its equivalent VBA code. The original FIX command script
remains as a comment. For a list of supported commands, refer to the How the Supported FIX32
Commands Get Converted section.
The Script Converter currently does not support SQL or WSPROXY commands. For a list of
unsupported commands, refer to the FIX32 Command Scripts Not Converted section. The Script
Converter leaves these commands marked with comments when it runs. You will later need to modify
these scripts manually in the Visual Basic Editor.
Be aware that the Script Converter also does not check for programming errors in the object event
procedure in which the old script was placed. After you finish a script conversion, you should review
all converted scripts. You may decide to do things differently in VBA than you would do with the FIX
command language.

Using the Script Converter
To access the Script Converter, use the fifth button on the Migration Tools toolbar. The Script
Converter is illustrated in the following graphic.

Script Converter Migration Tool
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The Script Converter converts commented FIX32 command language scripts, that the Key Macro
Converter and Picture Converter generates, into VBA script. After the conversion takes place, the key
macros appear in the iFIX Key Macro Editor, for each applicable picture. You additionally may need
to import VBA variable picture and global files.
You should inspect the script behind each of the key macros in the Visual Basic editor to confirm that
they converted properly. You may need to make minor adjustments to some scripts. The comments in
the key macro VBA script indicate if changes are necessary.
To convert the scripts associated with a picture:
1.

Close all open pictures in the iFIX WorkSpace.

2.

On the Migration Tools toolbar, click the Script Converter button
toolbar. The Script Converter appears.

3.

Select the required options. By default, the first two options automatically appear selected.
For details on each of these options, refer to the following table.

, the fifth button on the

Option

Descriptions

Safe GOTO
Conversion

Selecting this option allows the Script Converter to check for GOTO
commands that may cause an infinite loop, which FIX command language
originally allowed.
If the Script Converter encounters such a jump in the VBA code, the GOTO
command is commented out.
This option is selected, by default.

Replace
"RUNTASK HTD"
with:

Selecting this option allows you to define the replacement for Historical
Display application calls within the code.
The Script Converter uses the text entered in the text box as a replacement for
the "RUNTASK HTD" script command.
This option is selected, by default. ReplacePicture "HTD" is the default
replacement. For most applications, the default setting is acceptable.
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Option

Descriptions

Convert Command
Language Variables
to iFIX Variable
Objects

If you have animations that use FIX command language variables, and want
to use these animations in iFIX without any editing, select this option.
With this option selected, FIX Command Language variables are converted
to iFIX variable objects.
After conversion, look for the variables in the iFIX WorkSpace tree:
•

The picture variables appear under the Picture name, in the format
of p_varName.

•

The global variables appear in the Global > User folder, in the
format of g_varName.

If you clear this option, be aware that the VBA variables created by the Script
Converter cannot be used to animate objects. Alternatively, you can rewrite
the VBA scripts to reference the iFIX object properties that replace the
FIX32 global variables in iFIX 4.0. You may want to do this if your scripts
contain a lot of variables, as too many variables can effect performance, in
some instances.
This option is cleared, by default.
4.

Click OK.
If you selected the Convert Command Language to iFIX Variable Objects, a message box
appears. This warning displays because some pictures use a large number of FIX variables
and creating large numbers of iFIX Variable objects (particularly global variable objects) may
affect the system performance.

5.

If this message box appears, click Yes to continue, or click No to return to the Script
Converter dialog box and remove this option.
After you have selected the appropriate options and accepted all warnings, the Select Picture
Files for Script Conversion dialog box appears.

6.

Select the file or files that you want to convert.
By default, the Script Converter looks for pictures in the PIC path, where you installed iFIX.
Typically, this path is C:\Program Files\Proficy\Proficy iFIX\PIC. You can browse to other
folders however, but it is recommended that you keep these files in the iFIX PIC folder.

7.

Click Open. A message box appears indicating whether the Script Converter created
additional modules for script conversion. The files that may be generated include:
•

PictureName_Globals.bas – contains all of the picture variables, where
PictureName refers to the actual picture name.

•

Script_User_Globals.bas– contains any global variables referenced in the pictures.

You can later import these files; see the steps below for details.
8.

Click OK. A message box appears indicating where the Script Converter log file appears.

9.

Click OK. Another message box appears when the conversion completes.

10. Click OK.
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11. Review the converted scripts in the Visual Basic Editor. You may want to make adjustments
to take advantage of VBA features unavailable to the FIX32 command language.
To import VBA picture and global variables after the Script Converter runs:
1.

Confirm whether a ScriptConverter_Globals.bas or any PictureName_Globals.bas files exist,
where PictureName is the name of a picture that requires VBA variables.
These files exist in the folder of the converted pictures. Typically, this path is C:\Program
Files\Proficy\Proficy iFIX\PIC.

2.

If no files exist, stop here. No imports are required. Otherwise, note the location of these files
and continue.

3.

If a Script_User_Globals.bas file exists:
a.

Open the iFIX WorkSpace.

b.

In Classic view, on the Workspace menu, click Visual Basic Editor.
-OrIn Ribbon view, on the Home tab, in the WorkSpace group, click Visual Basic
Editor.

4.

Right-click the Project_User folder in the project explorer, and select Import File. The Import
File dialog box appears.

5.

Browse and select the Script_User_Globals.bas file and click Open.

6.

Save the file when complete.

7.

On the File menu, click Close and return to the WorkSpace application.

8.

If any PictureName_Globals.bas files exist, for each picture listed:
a.

Open the picture in the iFIX WorkSpace.

b.

In Classic view, on the Workspace menu, click Visual Basic Editor.
-OrIn Ribbon view, on the Home tab, in the WorkSpace group, click Visual Basic
Editor.

9.

In the Visual Basic Editor, on the File menu, click Import File. The Import File dialog box
appears.

10. Browse and select the PictureName_Globals.bas file associated with the picture.
11. On the File menu, click Close and return to the WorkSpace application.
12. On the File menu, click Save to save the picture.

How the Supported FIX32 Commands Get Converted
The following table lists each FIX32 command script that is converted, and iFIX global subroutine that
replaces it.
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This FIX32
Command Script...

Is replaced by this iFIX Global Subroutine...

ALARMACK

AcknowledgeAnAlarm([DataPoint As String])

ALARMACKALL

AcknowledgeAllAlarms([Picture As String])

BASEPIC

Application.ActiveDocument.DefaultView

CLOSEDIG

CloseDigitalPoint([DigitalPoint As String])

CLOSEPIC

ClosePicture([Picture As String])

COPY

FileCopy (standard VBA)

DECLARE

Dim (standard VBA)

DELETE

Kill (standard VBA)

DISABLEALARM

DisableAlarm([DataPoint As String])

ENABLEALARM

EnableAlarm([DataPoint As String])

EXIT

Application.Quit

FILEOPEN
FILECLOSE
FILEREAD
FILEWRITE

Open
Close
Input #
Write #
NOTE: These four entries are standard Visual Basic statements, not
iFIX global subroutines. See the Visual Basic Reference Help for
additional information.

GETVAL

ReadValue([DataPoint As String])

GOTO

Goto (standard VBA)

IF, ELSE, ENDIF

If, Then, Else, End If (standard VBA)

LOGIN

LogIn()

LOGOUT

System.FixLogout
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This FIX32
Command Script...

Is replaced by this iFIX Global Subroutine...

MENU

Only some of the menu commands are supported. The supported
commands include:
•

FILE_CLOSE

•

FILE_EXIT

•

FILE_OPEN

•

FILE_PRINT

•

VIEW_FIT_IN_WINDOW

•

VIEW_DEFAULT_VIEW

•

ALARMS_ACKNOWLEDGE_ALL

•

ALARMS_ACKNOWLEDGE_ONE

•

COMMANDS_MANUAL_MODE

•

COMMANDS_AUTO_MODE

•

COMMANDS_ON_SCAN

•

COMMANDS_OFF_SCAN

MESSAGE

System.SendOperatorMessage(Text As String,[Nodename As String])

NOTE

MsgBox (standard VBA)

NUMTOSTR

Format (standard VBA)
NOTE: The Format Parameter is ignored.
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OFFSCAN

OffScan([DataPoint As String])

ONSCAN

OnScan([DataPoint As String])

OPENDIG

OpenDigitalPoint([DigitalPoint As String])

OPENPIC

OpenPicture([Picture As String], [PictureAlias AsString], [TopPosition],
[LeftPosition])

OPENPIC (with tag
group file)

OpenTGDPicture([sPicture As String],[sPicture Alias As String],
[fTop], [fLeft], [sTagGroup As String])

PROMPT

InputBox (standard VBA)

Script Converter

This FIX32
Command Script...

Is replaced by this iFIX Global Subroutine...

RAMP

RampValue(RampValue As Double, ByPercent As Boolean, [DataPoint
As String])

REPLACEPIC

ReplacePicture(NewPicture As String, [OldPicture As String],
[TagGroupFileName As String])

REPLACEPIC (with
tag group file)

ReplaceTGDPicture(sNewPicture As String, sTagGroup As String,
[sOldPicture As String =""])

ROUND

Int, CInt (standard VBA)

RUNTASK

Shell (standard VBA)

SETAUTO

SetAuto([DataPoint As String])

SETMANL

SetManual([DataPoint As String])

SETNICKNAME

PictureAlias(PictureAlias As String)

SETVAL

WriteValue(Value As String, [DataPoint As String])

STRCAT

+ (standard VBA)
NOTE: The padding character is ignored.

STRCMP

StrComp (standard VBA)

STRLEN

Len (standard VBA)

STRSTR

InStr (standard VBA)

STRTOK

Mid (standard VBA)

STRTONUM

Val (standard VBA)

TOGGLEDIG

ToggleDigitalPoint([DigitalPoint As String])

TOGGLEMANL

ToggleManual([DataPoint As String])
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This FIX32
Command Script...

Is replaced by this iFIX Global Subroutine...

TOGGLESCAN

ToggleScan([DataPoint As String])

The following table lists the FIX32 command scripts that are replaced by a subroutine defined in the
ScriptConvertRT.bas file.
This FIX32 Command
Script...

Is replaced by this subroutine defined in
ScriptConvertRT.bas...

ACOS

ConvertRT_ACos(dblArg As Double)

ASIN

ConvertRT_ASin(dblArg As Double)

ATTRIB

ConvertRT_Attrib(strFile As String, strAttrib As String)

CHECKRIGHTS

ConvertRT_CheckRights(strArea As String, iResult As Integer)

CHFILE

ConvertRT_ChFile(strFile As String, iResult As Integer)

FILELIST

ConvertRT_FileList(strPattern$, strResult$, strTitle$, Optional
strShow$)

LOG10

ConvertRT_Log10(dblArg As Double)

PAUSE

ConvertRT_Pause(iPause As Integer)

NOTE: The ScriptConvertRT.bas resides in the iFIX LOCAL folder. If you installed to the default
location, the path is C:\Program Files\Proficy\Proficy iFIX\LOCAL. For more information on the
ScriptConvertRT.bas file, refer to the steps in the Using the Script Converter section.
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FIX32 Command Scripts Not Converted
If a script could not be converted during the conversion process, the script is marked with the comment
"NO CONVERSION CURRENTLY AVAILABLE --->" and the Script Converter logs these
unconverted commands in the relevant picture log file.
The following FIX32 commands are not converted into iFIX VBA commands:
APPEND

OPENLYT

CRITICAL

PAN

DEBUGOFF

PLAYSOUND

DEBUGON

RESOLVEVARS

ENDCRITICAL

SQL

EXECUTE

SWITCHKMX

FILEPRINT

TOGGLEALARM

FINDLINK

VIEW

LOADKMX

WSPROXY

NULL

ZOOM

OPENBDF

NOTE: Commands using the FIX Desktop WSPROXY command may not display a comment. Be sure
to review any commands using WSPROXY, and update them as appropriate.

Examples of Unconverted Command Script with Comments
The two examples of unconverted command scripts are shown below.

ZOOM Command
This example shows the unconverted ZOOM command. The following code shows how an
unconverted FIX32 command script gets commented out in the iFIX VBA.
Public Sub CFixPicture_F3()
On Error GoTo ErrorHandler
'NO CONVERSION CURRENTLY AVAILABLE --->

'ZOOM OVAL MYPIC
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Exit Sub
ErrorHandler:
HandleError
End Sub

Notice the comment in the above code. When you see comments stating, "No conversion currently
available," as in the above example, you should evaluate the code and decide how you want to deal
with it in iFIX. All commands in the list that appears in the FIX32 Command Scripts Not Converted
section, should have comments like this, except for the WSPROXY command.
WSPROXY Command
This next example shows a VBA script that references WSPROXY. In this instance, the line
referencing WSPROXY is red, indicating there is a problem with the code.
Private Sub BUTTON_MouseUp(ByVal Button As Integer, ByVal Shift As Integer, ByVal X As
Single, ByVal Y As Single)
On Error GoTo ErrorHandler
Shell "WSPROXY" + " " + ""REPLACEPIC {C:\Program Files\Proficy\Proficy iFIX\PIC\pic2}
{C:\Program Files\Proficy\Proficy iFIX\PIC\pic1}"", 1 'RUNTASK WSPROXY "REPLACEPIC
{C:\Program Files\Proficy\Proficy iFIX\PIC\pic2} {C:\Program Files\Proficy\Proficy
iFIX\PIC\pic1}"
Exit Sub
ErrorHandler:
HandleError
End Sub

Examples of Script Conversions
The following sections show two examples of command scripts both before and after the Script
Converter runs:
•

Example 1: Open Picture Command Conversion

•

Example 2: Replace Picture Command Conversion

These examples start with code generated after the Picture Converter runs.

Example 1: Open Picture Command Conversion
After you run the Picture Converter, the command script for this Open Picture command displays like
this iFIX VBA code:
Before
Private Sub CFixPicture_Initialize()
' Open Picture Command
' SETVAL DEMO:RATE.F_CV 1500
End Sub
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Script Converter

Run the Script Converter to convert these command scripts to VBA. When complete, the code will
look similar to the following:
After
Private Sub CFixPicture_Initialize()
On Error GoTo ErrorHandler
' Open Picture Command
Call WriteValue(1500, Fix32.DEMO.Rate.F_CV) ' SETVAL DEMO:RATE.F_CV 1500
Exit Sub
ErrorHandler:
HandleError
End Sub

Notice that the old script commands appear commented out, and comments appear to the right of the
new VBA commands. Also, the Script Converter adds the iFIX error handling routine, HandleError.

Example 2: Replace Picture Command Conversion
After you run the Picture Converter, the command script for this bitmap's On Up command displays
like this iFIX VBA code:
Before Script Converter Runs
Private Sub BITMAP9_MouseUp(ByVal Button As Integer, ByVal Shift As Integer, ByVal X As
Double, ByVal Y As Double)
' REPLACEPIC * MAIN
End Sub

Run the Script Converter to convert this command script to VBA. When complete, the code will look
similar to the following:
Example 2: After Script Converter Runs
Private Sub BITMAP9_MouseUp(ByVal Button As Integer, ByVal Shift As Integer, ByVal X As
Double, ByVal Y As Double)
On Error GoTo ErrorHandler
ReplacePicture "MAIN" ' REPLACEPIC * MAIN
Exit Sub
ErrorHandler:
HandleError
End Sub

Notice that the old script commands appear commented out, and comments appear to the right of the
new VBA commands. Also, the Script Converter adds the iFIX error handling routine, HandleError.
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Script Converter Log Files
The Script Converter produces log files in the same folder as the converted pictures. These log files
include:
•

A global file, READ_ME_ScriptConvert.csv, is generated with general information about the
conversion process.

•

A .CSV file for each converted picture with the name:
MYPIC_READ_ME_ScriptConvert.csv, where MYPIC is the actual name of the picture. This
file contains information on the unconverted script commands and warning messages.

READ_ME_ScriptConvert.csv Log File
This log contains the following:
•

A list of the converted picture files.

•

A list of VBA modules created with picture level variable definitions.

•

A list of VBA modules created with global level variable definitions.

The READ_ME_ScriptConvert.csv file is overwritten each time the Script Converter runs.

MYPIC_READ_ME_ScriptConvert.csv Log File
This log contains the following:
•

A list of any created VBA variable modules.

•

A list of warning messages.

•

A list of unconverted script commands.

If you used the default iFIX install path to store your pictures, you can find these logs in the default
PIC path, C:\Program Files\Proficy\Proficy iFIX\PIC.
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Historical Pen Group Migration Tools
If you use historical display files (*.hgp) in your FIX32 displays, you can also migrate these to iFIX.
There are two tools available for historical pen group migration:
•

Historical Pen Group Export Tool – Exports FIX pen groups into .CSV files (Chart
Groups.csv, Pen Groups.csv, Time Groups.csv).

•

Historical Pen Group Converter – Converts the three exported .CSV files into iFIX chart
group file(s) that you can apply with the Chart Group Wizard.

Before using the historical pen group migration tools, be sure that you converted your FIX picture files
(*.odf) into iFIX picture files (*.grf) using the Picture Converter migration tool. For more information,
refer to the Picture Converter section. Additionally, you should run the tag group, key macro and script
converters. Refer to the Tag Group Converter, Key Macro Migration Tools, and Script Converter
sections for more information.
To use the historical pen group migration tools, you first need to copy the CHART.HGP, PEN.HGP,
and TIME.HGP files for your FIX32 displays into the iFIX HTR folder. After you run both historical
pen group migration tools, you then need to apply the converted iFIX chart group files to the
appropriate charts in your converted pictures.
To view the new charts in run mode from the iFIX WorkSpace, copy the folders from the FIX32
HTRDATA folder into the iFIX HTRDATA folder. By default, this path is C:\Program
Files\Proficy\Proficy iFIX\HTRDATA. Do not change the file or folder names.

Historical Pen Group Export Tool
The Historical Pen Group Converter exports FIX pen group information into three .CSV files:
•

Chart Groups.csv

•

Pen Groups.csv

•

Time Groups.csv

These files are copied into the iFIX HTR folder, which by default is the C:\Program
Files\Proficy\Proficy iFIX\HTR folder.
To access the Historical Pen Group Export Tool, use the sixth button on the Migration Tools toolbar.
The Historical Pen Group Export Tool has no user interface. Clicking the toolbar button starts the
export process of FIX32 chart, pen, and time groups. When the conversion is complete, a message box
appears. For example, if the conversion succeeds, the following message appears:
Export to delimited text files succeeded.
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To export historical pen group information:
1.

Copy the CHART.HGP, PEN.HGP, and TIME.HGP files for your FIX32 displays into the
iFIX HTR folder.
If you installed iFIX to the default folder, the path is C:\Program Files\Proficy\Proficy
iFIX\HTR.

2.

On the Migration Tools toolbar, click the Historical Pen Group Export Tool button
sixth button on the toolbar. The Historical Pen Group Export Tool appears.

3.

Wait for the export to complete. After a few moments, a message box appears.

4.

Click OK. The Chart Groups.csv, Pen Groups.csv, and Time Groups.csv files should now
appear in the HTR folder, along with the *.HGP files.

, the

Historical Pen Group Converter
Use the Historical Pen Group Converter after you use the Historical Pen Group Export Tool. The
Historical Pen Group Converter converts the three exported .CSV files (Chart Groups.csv, Pen
Groups.csv, Time Groups.csv).into iFIX chart group file(s) that you can later apply to your converted
iFIX pictures with the Chart Group Wizard.
These converted iFIX chart group files are copied into the iFIX HTR folder, which by default is the
C:\Program Files\Proficy\Proficy iFIX\HTR folder.
To access the Historical Pen Group Converter, use the seventh button on the Migration Tools toolbar.
The Historical Pen Group Converter has no user interface. Clicking the toolbar button starts the
conversion process. When the conversion is complete, a message box appears. For example, if the
conversion succeeds, the following message appears:
Historical Pen Groups Converted

To convert historical pen group information:
, the

1.

On the Migration Tools toolbar, click the Historical Pen Group Converter button
seventh button on the toolbar. The Historical Pen Group Converter appears.

2.

Wait for the conversion to complete. After a few moments, a message box appears.

3.

Click OK. Another message box appears informing you where the log file is located.

4.

Click OK. A file for each pen group/time group combination is copied to the HTR folder.
This path, by default, is C:\Program Files\Proficy\Proficy iFIX\HTR.
The file is named PENGROUP[TIMEGROUP].csv, where PENGROUP and TIMEGROUP
are the actual pen and time group names. For example, if you have a pen group named
HISTORY, and time group also named HISTORY, the file name would be
HISTORY[HISTORY].csv.
NOTE: If a FIX32 pen group name started with a number, the converted file name is prefaced
with HGP_. For example: HGP_1TEST[1TEST].csv. This change occurs because a file name
starting with a number is not a legal name for an iFIX chart group.
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Recreating Charts with the Chart Group Wizard
After you run both historical pen group migration tools, open the iFIX picture, and apply the converted
chart group files to the applicable charts. Use the Chart Group Toolbar in the iFIX WorkSpace to
perform this task.
To view the Chart Group Toolbar:
1.

Start iFIX.

2.

Open the picture that you want apply the converted chart group to.

3.

In Classic view, in the iFIX WorkSpace, on the WorkSpace menu, click Toolbars.
-OrIn Ribbon view, on the Home tab, in the WorkSpace group, click Settings, and then click
Toolbars.

4.

In the Owner area, select Picture.

5.

In the Toolbars area, select the check box next to the ChartGroup Toolbar option.

6.

Click Close.

To apply a converted chart group file:
1.

With the converted picture open in the iFIX WorkSpace, select the chart that you want to
apply the converted chart group to.

2.

In Classic view, on the Chart Group toolbar, click the Apply Chart Group Wizard to Chart
button

, the first button on the toolbar.

-OrIn Ribbon view, on the Tools tab, in the Chart Groups, click Chart Groups, and then click
Apply Chart Group Wizard to Chart.
3.

Click Apply Chart Group Wizard to Chart, and click OK.

4.

In Classic view, on the Chart Group toolbar, click the Apply Chart Group File button
second button on the toolbar.

, the

-OrIn Ribbon view, on the Tools tab, in the Chart Groups, in the Chart Groups list, click Apply
Chart Group File. The Apply Chart Group File dialog box appears.
5.

In the Apply Chart Group File area, select On Picture Open. Otherwise, click On Click of
Selected Object.

6.

Click Get Chart to retrieve the chart name.
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7.

In the Chart Group File area, click the browse (...) button next to the file name field. The
Chart Group File dialog box appears.

8.

Select the appropriate file created when you ran the Historical Pen Group Converter. This file
is in the format of "PEN GROUP [TIME GROUP].csv."

9.

Click OK.

10. Copy the folders from the FIX32 HTRDATA folder into the iFIX HTRDATA folder. By
default, this path is C:\Program Files\Proficy\Proficy iFIX\HTRDATA. Do not change the file
or folder names.
This final step allows you to view the newly converted charts from the iFIX WorkSpace in
run mode.

Troubleshooting Historical Pen Group Migration
If your charts do not work properly after the migration, do the following:
•

Check that you copied the files from the FIX32 HTRDATA folder into the iFIX HTRDATA
folder. By default, this path is C:\Program Files\Proficy\Proficy iFIX\HTRDATA. Do not
change the file or folder names.

•

If your chart uses a fixed start time, make sure that the fixed start time you chose has
historical data. Not all of the .CSV files you create have historical data as permutations
created for all Pen Groups and Time Groups.

Testing the Chart Migration Process
To test that the conversion process is working, create a Pen Group and Time Group both called HGP
TEST in your FIX Historical Display application. Make sure that historical data exists for this group.
Run through the whole history group conversion process again, using both the Historical Pen Group
Export Tool and then the Historical Pen Group Converter.
A file should be created named "HGP TEST [HGP TEST]. CSV." Using the Chart Group Wizard in
the iFIX WorkSpace, recreate this chart in a new picture. If you perform all of these steps and view
data in the chart when you switch the iFIX WorkSpace to run mode, then the conversion process is
working correctly.

Historical Pen Group Converter Log File
A global file, READ_ME_HistoricalPenConvert.csv, is generated with information about the historical
pen group conversion process. The file contains a list of all the converted historical pen files.
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Known Issues with Migration Tools
This section details some known issues with the following migration tools:
•

Script Converter

•

Picture Converter

Script Converter
If a script could not be converted during the conversion process, the script is marked with the comment
"NO CONVERSION CURRENTLY AVAILABLE --->" and the Script Converter logs these
unconverted commands in the relevant picture log file.
The following FIX32 commands are not converted into iFIX VBA commands:
APPEND

OPENBDF

CRITICAL

OPENLYT

DEBUGOFF

PAN

DEBUGON

PLAYSOUND

ENDCRITICAL

RESOLVEVARS

EXECUTE

SQL

FILEPRINT

SWITCHKMX

FINDLINK

TOGGLEALARM

LOADKMX

VIEW

MENU

WSPROXY

NULL

ZOOM

Other notable items include:
•

If you select the Safe GOTO Conversion check box when you run the Script Converter, the
GOTO command is commented when exported.

•

The NUMTOSTR command is exported without the format parameters.

•

The STRCAT command is exported without padding characters.
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Picture Converter
Be aware that "Fill" animations in FIX32 do not display their background color properly in the iFIX
product after you convert the picture. This is because FIX32 objects use the background style and
foreground pattern when filling objects, with the rest of the object being transparent.
iFIX fills objects differently, however. iFIX fills objects with the foreground color; the rest of the
object is drawn in the background color.
As a workaround, you can set the FIX32 object to a transparent background before you convert the
picture. Be aware, however, there is no workaround if you are using FIX32 patterns and fills on your
FIX32 objects.
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Glossary of Migration Terms
Base Path – iFIX install path. Stores the entire iFIX executable files. By default this path is to
C:\Program Files\Proficy\Proficy iFIX.
Chart Group Wizard (CGW) – A utility in iFIX that stores chart group files as CSV files. This
utility is also used to recreate FIX32 charts from the CSV files created by the Historical Pen
Group Converter.
Comma Separated Value (CSV) – A widely used text file format that stores two dimensional
data. Each line representing an individual record and each of the records split into fields by
use of a comma.
GRF – Graphical Resource File used by iFIX to store information about a picture (screen).
Historical Pen Group (HGP) – A series of three files in FIX32 that store the configuration
settings for historical charts. These files being Chart, Pen and Time HGP.
Historical Data Path – Stores historical data files from which the historical collect application
creates a unique subdirectory in this directory for each node data is being collected for, and
names the subdirectory according to the name of the node. By default, for iFIX, the
historical data path is set to C:\Program Files\Proficy\Proficy iFIX\HTRDATA.
Historical Path – Stores the configuration files of the Historical Assign and Historical Collect. By
default, for iFIX, the historical path is set to C:\Program Files\Proficy\Proficy iFIX\HTR.
Key Macro – A file linking keystrokes to commands.
Key Macro File – Key Macros for FIX32 are stored in a KMX file. This key macro file is
associated either with a picture or the View environment.
KME – A transitional text file used to store the exported version of a KMX file. Referred to
throughout this document as the key macro text file.
KMX – FIX32 Key Macro file.
Language Path – Stores the iFIX language files. By default, for iFIX, this path is set to
C:\Program Files\Proficy\Proficy iFIX\NLS.
Object Definition File (ODF) – FIX32 picture file that stores information about a screen.
Pen – A representation of a floating point value or tag that is displayed in a chart link.
Picture – An iFIX screen object.
Picture Path – Stores picture files, tag group files, macro files and other workspace configuration
files. By default, for iFIX, the picture path is set to C:\Program Files\Proficy\Proficy
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iFIX\PIC.
Tag Group – Stores placeholders for data sources or text in a picture, allowing the placeholder
then to be replaced with an alphanumeric value.
TGE – FIX32 tag group file.
TGD – iFIX tag group file.
User Global – A special picture that contains user-defined variables, color threshold tables and
procedures that are globally available to all pictures in iFIX. Stored as a file named
"user.fxg."
Visual Basic for Applications (VBA) – A cut down version of Visual Basic allowing application
software to be programmed with additional business logic.
View environment – A FIX32 environment allowing key macros to be available globally to all
pictures. Stored as the file view.kmx and replaced by the User Global file in iFIX.
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