Mistika workflows for Dolby Vision
Preliminary notes:
This document only explains the technical details in the “Mistika side” of the integration
with Dolby Vision. It does not explain what is Dolby Vision or its components (Please
check Dolby documentation for this)
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Introduction
For a first introduction we recommend watching this video:
https://www.youtube.com/watch?v=ReqMuN4_erU&feature=youtu.be&mc_cid=62726e417b&mc
_eid=b9b0322ec7
Note: This document contain additional details not explained in the video.
The Mistika integration with Dolby Vision is based on these elements:
-

Dolby CMU (Content Mapping Unit): It is a Dolby device that given HDR images graded
for an HDR mastering display it will create automated versions for other target displays
of inferior capabilities. (SDR displays or HDR displays with more limited nits)
Please note that the color grading version for the master monitor does not involve
the usage of any Dolby Vision tools. Dolby Vision is only used to produce the
other versions of inferior nits.
The Dolby CMU was originally based on a dedicated external hardware unit known as
“eCMU”, but it is also available as an internal software tool named “iCMU” integrated
within Mistika. This document mainly describes the workflow for the hardware version, as
the software version can be easily understood as a simplification of this document (if you
plan to use the software version just skip the point about Hardware connections ). The
Dolby software itself comes integrated in Mistika (no additional plugins are required), but
it requires a Dolby license to work. (otherwise some advanced features will not work,
including the TRIM capabilities)

-

Ethernet connection between the Mistika system and the Dolby CMU. This is used
by Mistika to control the CMU behaviour. (Hardware CMU only).

-

SDI video signal from Mistika output to the CMU input. This is the same signal that is
sent to the HDR mastering monitor (that signal needs to be duplicated to give a duplicate
to the CMU). (Hardware CMU only)

-

Mistika->Edit->Setup->Dolby Manager: The Dolby Manager panel, to setup the CMU
parameters (the CMU hardware/software mode, aspect ratio, master display, target
display, etc).

-

Mistika->FX->Dolby Vision: The Dolby Vision effect, containing the analysis tools and
all the TRIM parameters than can be adjusted to produce the target display versions.

-

Mistika->Output->Render->Dolby MXF->Dolby Mezzanine J2K. The official format to
render a Dolby Vision master

-

Mistika->Edit->Macros->Dolby Export: To export a Dolby XML file with all the
necessary metadata of the selected shots

Hardware connections between Mistika and Dolby eCMU
(hardware mode)

Ethernet connection
In the CMU, set an ip address in the same network domain as your Mistika system and
reboot the CMU.
Once this is done, in the Mistika system open an internet browser and put the ip address
of the CMU. This will permit to test that the network connection is working (the CMU GUI
should appear immediately) and the CMU GUI will let you to setup other CMU settings
(check Dolby documentation in case of any doubt).
Note: Mistika will discover the CMU automatically. There is no need to indicate the CMU
ip address in any Mistika setting, just have it in the same network. In case of problems
use fixed addresses rather than DHCP. (If it does not solve the issue at least it will
simplify diagnostics).

SDI connection
Regarding the SDI cabling we will need to create three different paths: one for the HDR
mastering monitor, one for the target display and one between Mistika and the Dolby
CMU.
The connection for the master HDR display needs to be an SDI connection between
Mistika workstation (output 1) and the HDR Mastering display.
At the date of this document the Dolby Vision workflow only supports RGB signals.
Please make sure that the video parameters at mConfig->MasterFormats are set to
RGB
The connection for the target display needs to be an SDI connection from the CMU
output to the target display.
The third one is the SDI connection between Mistika (output-1) and the CMU (input-1)
and this is what can complicate things a little bit. This signal needs to go from the
Mistika system both to the HDR mastering monitor and to the Dolby CMU so it needs to
be duplicated. This depends on the capabilities of your video hardware but typical
methods are:

-

By using and SDI splitter or SDI router
By using the monitor loop through, if available
By using the Mistika dual link output, plus a Stereo3D effect to differentiate both
output paths. (This method is normally possible in HD, as all SDI boards can
provide two outputs, but in the case of UHD you need a video board model with
2 x Quad SDI, like the Aja Corvid88.

Once the SDI connections between Mistika and the CMU are in place, open an internet
browser and put the ip address of the CMU to access its GUI interface. Check that it has
detected a valid video signal and adjust settings as necessary fo your case. If the SDI
signal is not detected then check that the video parameters at
mConfig->MasterFormats are set to RGB and not YUV
Note: Both Mistika and Dolby CMU support HD, 2K, and UHD. The UHD modes require
Quad SDI connections.
Note: The Dolby workflows are always RGB “Full Range” (RGB in data levels, not video
levels). Any element (images or displays) that are not in this format need to be separated
from the Dolby Vision workflow and converted to Data levels first (RGB Levels effect)
Please note that all source images need to be already in RGB data levels before passing
them to Dolby Vision effect, but it is equally wrong to apply a video to data levels
conversion to images that were already in data levels (as that will produce a double
range expansion, sending values below 0% and over 100%). If you are not sure check
where are the black and white points in the Vectorscope tool before applying any
conversion ...)

Mistika operation for Dolby Vision workflows
Dolby Manager settings

Open the Edit->Setup->Dolby Manager window. Here you can select the CMU mode,
aspect ratio and the Dolby process version.
The Process version will determine the metadata controls of the Dolby Vision effect and
the XML fields that will be exported. It is important to check which version is compatible
with the needs of your client (The Dolby Xml files will be different) and also check that
your Dolby CMU supports that version.
At the date of this document, if you are not sure about this parameter we recommend to
use version 2.9, as it should provide maximum compatibility.

The Master Display and Target Display selection lists will also appear after a valid CMU
mode has been selected (Hardware/Software).
Use the Edit->Setup->Dolby Manager window to select the Master Display and Target
Display.
Master Display: Select your reference monitor (the one for which you have color
graded the images).
Target Display: These are the monitors with inferior number of nits for which
you want to produce other versions. Please note that if you plan to make specific
adjustments for several target displays you can choose other displays later. For
the first pass you will need to start with the target display of the lowest number
of nits ( 100 nits). This is necessary for the correct interpolation of intermediate
nit formats. In that way there is a good chance that the automatic interpolation is
already valid for many of the shots when switching to other intermediate displays,
thus avoiding the need for extra manual adjustments.

Footage preparation
Dolby Vision requires to receive the input images in a very specific format:
-

Gamut: P3D65 or Rec 2020.
Gamma: PQ EOTF
RGB Data Levels (also known as “Full Range”)

Then, if your footage is in RGB video levels
Fx->RGBLevels->DataLevels to convert to data levels.

you

will

need

to

apply

Once you are in data levels: If your footage is not P3-PQ you will need to apply
FX->Unicolour to convert it to P3-PQ.
If any of those steps are needed, always do it BEFORE applying the Dolby Vision effect.
Do not apply any subsequent effects or display filters that could alter the image
content after the Dolby Vision effect otherwise the output images, SDI signals and
Xml metadata will be invalid for Dolby Vision workflow. The Dolby Vision effect MUST
always be the LAST colour transformation.

The same can be said about framing effects. The Edit->Setup->Dolby Manager tool
provides its own settings to define the image aspect ratio and no framing operations
should happen after the Dolby Vision effect. Any subsequent cropping of parts of the
image would invalidate important calculations like the Average Brightness and others.
Obviously, all colour grading effects also need to be applied before the Dolby Vision
effect.
Please note that the Dolby Vision effect is only needed to produce alternative versions
for other target displays, not for the HDR mastering display. If you want to colour grade
with the two displays (master and target) at the same time then you will need the Dolby
Vision effect (and CMU) since the beginning. Otherwise you could let the whole Dolby
Vision workflow for a later stage after grading for the HDR mastering display, but only as
long as you have designed your effect stack to accommodate the Dolby Vision effect at
the end of the chain (no display filters in use…).
If there are cross fade effects, make sure that each clip has its own Dolby Vision effect
applied, then just apply the Mix on top as usual, and Mistika will automatically produce
the correct interpolation between both Dolby Vision effects. Do not apply a Dolby Vision
effect to the Mix effect.

When working in software CMU mode you may want to have the two SDI outputs
from the Mistika station (the Master display and the target display). To do this
activate the mConfig->MasterFormats->Stereo3D Dual link and connect one HD/2K
output to each monitor ( or 2 x 4K QuadSDI in the case of Corvid88). Once in
Mistika, make sure that the “eye” used to feed the Master display has the Dolby
Vision effect muted. In this way you do not need a hardware CMU nor any extra
hardware for Dolby Vision workflows, just the Mistika system.

Image analysis with the Dolby Vision effect
Please note that for the next points we will assume you have already finished your HDR
grade for the HDR mastering display.
Now apply a Dolby Vision effect to each shot as the last effect in the stack (upper
track).
Check that the TargetID field is set to the same target display that you have selected in
Edit->Setup->Dolby Manager. (Both are set to 100nit-709 by default, which is the
most typical case. But if you change it you need to change in both places).
In the Dolby Vision effect, set Analysis->Analysis State parameter to Pending. The
image will change to shades of yellow. This is just to warn you that the Dolby Vision
effect is already active, but the shot has not been analysed yet for the whole duration of
the effect. The effect needs to calculate the maximum, minimum and average brightness
of the shot for which it needs to go through all the frames. To do this just press
VisualEditor->Playback. (or if you want to analyce many shots in one go, just press
the Timeline playback and let it go trough all shots one time).

When it finishes the Analysis parameter will automatically change to “Completed” state
and the image output sent to the target display will be already calibrated. The above
picture shows a Before (Analysis pending) / After analysis example.

At this point the output images in the target display should have changed noticeably.
They should already look “technically correct” for that particular target display. They may
still need some manual “trim” adjustments (which will be done in the next section) but the
improvements in brightness should be already very noticeable.
Note: If nothing changes or if the overall brightness has not improved then check the
steps in the previous sections, specifically that the Dolby Manager has the same target
display as the TargetID of the effect.
In all the next steps of the workflow you will not need to repeat the analysis stage,
as long as the input images to the Dolby Vision effect have not changed (otherwise
you will need to repeat the analysis).

Manual adjustments with Dolby Vision effect (trim)
After the automatic analysis is done, now go to the Trim1 parameters layer. With these
parameters you can do additional subjective adjustments. In many shots you probably
will not need to make any further modifications, but when you still appreciate noticeable
differences between the target display and the master HDR display (apart from the
differences purely related to the capabilities of each display) then you can use the trim
parameters for fine tuning or to trade off and prioritize the most important subjective
aspects. The objective here is to match the target display to the mastering display as
much as possible. (Please check the Dolby Vision documentation for more information
about each parameter).

Note: When using the eCMU hardware mode the images in the visual editor will not
change. In this mode the changes are only shown in the target display. This is because
the colour transformations are applied in the eCMU device and then sent to the target
display from there. As a difference, in the software mode the changes are also shown in

the Visual Editor, as in this case the iCMU it is a software device in the local system
receiving the images from Mistika and returning the output images to it.

Adjusting additional target displays
Dolby Vision capable displays provide automatic adjustments for any displays in the
range between the target display and the HDR mastering display (they can read the
Dolby metadata embedded in the images and interpret the images
data accordingly) . However, if you want to make specific adjustments for specific
intermediate displays that are especially important in your workflow then you can add
more adjustment layers as follows:
Connect the target SDI signal to the new target display (if not done so already).
Select Visual Editor->Layer->Add Layer
A new trim layer will appear in the Dolby Vision effect. Set its TargetID to the new target
display and also select it in Edit->Setup->Dolby Manager to switch the CMU to the new
target. Then repeat the trim adjustments as necessary for the new target display.
Please note that even if the effect can store the transformations for multiple target
displays the CMU can only produce one target display at a given time. For that reason,
when the Dolby Vision effect is not set to the same target display as the Dolby
Manager it will not show any changes (it will simply show the input images).
Also note that the Dolby Vision effect does not have any setting to choose which one is
the active layer (active TargetID), because that is precisely what is decided in the
Edit->Setup->Dolby Manager tool as explained.
It is also important to not apply any posterior modification to the image output
(image scalers, LUTS, etc), as the Dolby Vision metadata is encoded embedded within
the image data using proprietary technology, and this metadata can be easily destroyed
if the image is modified by non Dolby Vision aware processes.

Final render and Dolby XML export
Before rendering, make sure that there are no empty areas in the timeline. The Dolby
Xml export does not support this case. To cover an empty area you can use a Solid
effect, then apply a Dolby Vision effect to it and analyze it (or copy it from elsewhere).
When rendering, select Output->Render->Dolby MXF->Dolby Mezzanine J2K as the
render format and render your work. T
 his is the official master format for Dolby Vision.
The render to Dolby Mezzanine already includes all the metadata produced by the Dolby
Vision effect, but in most cases you will also want to export the Dolby Vision metadata to
an XML file, as part of the master and for intermediate purposes. A typical Dolby
Vision master delivery will include both the rendered media and the Dolby XML
file.
You can also render to other formats that do not have embedded metadata and then
deliver an XML file with them. In that way the Dolby Master can be produced later in
other system. But if you use a different format (rather than Dolby Mezzanine J2K )
make sure you select a render format with at least 12 bit per channel (EXR, Tiff16, etc).
Otherwise it will not be Dolby Vision compliant.
To create the XML file, select all the shots that you want to include (all the Dolby Vision
effects) and press Mistika->Edit->Macros->Dolby Export. This will create a Dolby
XML file with the Dolby Vision metadata for all the selected shots. This file is placed in
the OUTPUT folder of the project.

A single Dolby Vision XML file can contain as many shots as you want. In a certain
sense, it is someway similar to an EDL but also containing all the HDR metadata.

Importing a Dolby XML file to Mistika
A Dolby Vision XML file can also be imported in a Mistika Timeline (just drag & drop the
XML file to the timeline). When it is done, a collection of Dolby Vision effects will appear
in the correct positions and durations of the Timeline (similar to an EDL) which can then
be applied to the original shots.
But before importing it, it is recommended to configure the Dolby Manager setup to the
same settings used to create the XML file. For example, using it with a different aspect
ratio can lead to incorrect (variable) black levels in the letterbox area, as it would not be
protected

