AutoEPG
User Manual

Adasme, Francisco        Muñoz, Camila
*Ramirez, Claudio C.

Universidad de Talca, Talca, Chile
*clramirez@utalca.cl
# Contents

1 Getting started ........................................... 3  
  1.1 Overview ........................................... 3  
  1.2 Hardware requirements .............................. 3  
  1.3 Installation and dependencies ...................... 3  
  1.4 Citing AutoEPG in Publications .................... 4  

2 General Interface Design ................................. 5  
  2.1 AutoEPG windows ..................................... 5  
    2.1.1 Mouse functions and keyboard shortcuts ....... 5  
  2.2 AutoEPG workflow .................................... 6  
  2.3 Job Launching and Incorporation .................... 7  

3 The AutoEPG Main Window ................................. 8  
  3.1 The Main window ..................................... 8  
  3.2 The Menu Bar ........................................ 10  
  3.3 The Main Toolbar ..................................... 10  
  3.4 Signal Viewer ........................................ 11  
  3.5 Profile Viewer ....................................... 12  

4 Reading and Saving Recording Data ...................... 14  
  4.1 Reading recordings ................................... 14  
    4.1.1 Data parsing .................................... 15  
    4.1.2 EPS File Format ................................. 16  
  4.2 Saving Recordings .................................... 17  
    4.2.1 Exporting Data to a Spreadsheet ................. 18
5 Viewing a Recording
  5.1 Displaying Recording Data ........................................ 19
    5.1.1 Changing the Active Recording .............................. 19
    5.1.2 Closing a Recording ........................................... 19
  5.2 Changing the View .................................................. 19
    5.2.1 Zooming In and Out ............................................ 19
    5.2.2 Restoring the Default View .................................... 19
  5.3 Navigation .................................................................. 19
    5.3.1 Keyboard Shortcuts ............................................... 20
    5.3.2 Using the Segment Table ....................................... 20
    5.3.3 Panoramic View .................................................... 20
  5.4 Adjusting the Workspace ............................................. 20

6 Analysis ........................................................................... 21
  6.1 Searching process? ..................................................... 21
    6.1.1 Search engines ..................................................... 21
    6.1.2 Validation .......................................................... 21
  6.2 Searching Waveform Patterns ........................................ 21
    6.2.1 Running Calculations ............................................. 21
    6.2.2 Viewing the Results .............................................. 21

7 Editing .............................................................................. 22
  7.1 Labeling and Annotating a Recording .............................. 22
  7.2 Adding Segments ......................................................... 22
    7.2.1 Segment Types ...................................................... 22
  7.3 Modifying Existing EPG Data .......................................... 22
    7.3.1 Changing the Segment’s Ends ................................. 22
    7.3.2 Selecting the Segment’s Type ................................... 22
  7.4 Deleting a record ......................................................... 22

8 Help ................................................................................. 23
  8.1 AutoEPG Web Site ....................................................... 23
  8.2 Technical Support ......................................................... 23

9 Glossary ........................................................................... 24
Chapter 1

Getting started

1.1 Overview

AutoEPG is an electropenetration graph (EPG) waveform recognition software developed by Centre for Bioinformatics and Molecular Simulation (CBSM) in association with Instituto de Biología Vegetal (IBVB), Universidad de Talca, Chile. It provides an automated workflow to analyze EPG data embedded in a custom graphical user interface (GUI), which contains tools for displaying, analyzing and manipulating EPG recordings. It also includes modules for loading and saving this type of recordings along with associated data.

This manual contains an introduction to the AutoEPG graphical user interface and a description of how to use AutoEPG’s analysis capabilities.

1.2 Hardware requirements

AutoEPG is a lightweight software that currently runs on Windows (XP/Vista/7) with a low-memory footprint and it requires around 50 MB of free hard disk space. However, in the near future, it will available for Mac OS X and Linux-like platforms.

1.3 Installation and dependencies

The software it is composed by a single executable (autoepg.exe), which can be placed in any desired location. However, it requires some libraries (.dll) to run that
are delivered along with the executable and they all must be located in the same folder. It is strongly recommended that a shared folder (e.g. not the desktop) it is used as destination so AutoEPG can be available for all users. Since no other dependencies are needed, AutoEPG may be seen as a portable version\(^1\), so you can run it from a removable drive such as a USB flash or any kind of external hard disk drives. Running it from a non-writable drive such an optical disk (Blu-ray disc, DVD or CD) is discouraged because it can produce random crashes.

AutoEPG is hosted in the IBVB server and can be downloaded directly from its download page\(^2\). AutoEPG is distributed as a single-extraction archive file (autoepg-installer.exe) that will uncompress all the files required in the given location. It is recommended that you create a desktop shortcut to autoepg.exe by right-clicking it, then select Send to menu item and choose the desired option such as Desktop (this steps only works on Windows).

### 1.4 Citing AutoEPG in Publications

The use of this product should be acknowledged in publications as:

AutoEPG, version 1.0, Centre for Bioinformatics and Molecular Simulation, Universidad de Talca, Chile, 2012.

---

\(^1\)Keep in mind that the preferences settings will not be saved.

\(^2\)AutoEPG is freely available for academic purposes and it does not require any kind of registration or license agreement for its use. Nonetheless, any non-academic use is discouraged without a formal request.
Chapter 2

General Interface Design

The AutoEPG interface is built on the \textit{Qt toolkit}, so it inherits many standard features from Qt. The design follows most common interface conventions, so every feature is very straightforward to use. The general operation of the AutoEPG interface is described in this section.

2.1 AutoEPG windows

AutoEPG is based on a main window, from which you can open secondary windows for viewing derived data or running analysis tasks. Most of the secondary windows that are opened from AutoEPG are amodal (do not block the main window), and are called \textit{panels}. More than one panel can be open at any given time. Some of the panels are docked by default into the main window. You can undock them and place them wherever you want, and you can redock them, using the docking button.

This make possible the use of a secondary display, by placing the opened panels in it, to maximize the viewing region of the current recording, which greatly improves readability and visual analysis of the results.

2.1.1 Mouse functions and keyboard shortcuts

AutoEPG supports common mouse functions:

- The left button is used for selecting: choosing menu items, clicking buttons and selecting objects. This button is also used for resizing and moving panels. In the description of mouse actions, “click” always means left-click.
• Dragging operations are supported. For instance, in the Profile Viewer, dragging one end of a segment can resize them. In the Segment List, dragging a column heading moves the column; dragging on the boundary of a row or column resizes the row or column.

• The scroll wheel is supported for scrolling vertically in tables, lists, and viewers. In general, scrolling is equivalent to using the Up arrow and Down arrow keys and also Page Up and Page Down keys, for faster navigation.

Many of the actions can be completely done using only the mouse pointer since most GUI components are designed to be intuitive as possible. However, to speed up repetitive tasks, AutoEPG support several common actions that are bound to standard key combinations, so for example you can navigate through the recording using the arrow keys in a much fast and precise way than using the mouse pointer and GUI controls (see Section 5.3 on page 19 for details).

AutoEPG supports the use of shortcut menus as well, meaning that almost every menu item or action has an associated keyboard shortcut. A standard set of menu items, along with the corresponding keyboard shortcuts, is available: Undo (Ctrl+Z), Redo (Ctrl+Shift+Z), Cut (Ctrl+X), Copy (Ctrl+C), Paste (Ctrl+V), Delete, and Select All (Ctrl+A).

2.2 AutoEPG workflow

The AutoEPG workflow involves navigating through the displayed recording, performing analysis tasks and evaluate the results. In many cases, you will want to modify the results, which involves selecting the so-called segments that you want to change. In general, you will do this using the cursor pointer to adjust the ends of each segment, but more accurate adjustment can also be done by writing the start or end time manually.

AutoEPG’s edit tools provide you with a range of options for editing single segments, as well as creating new ones quickly using built-in shortcuts. These tools are described in detail in Chapter 7 on page 22.
2.3 Job Launching and Incorporation

AutoEPG’s job launching and incorporation capabilities are designed to make it easy to manage and customize. AutoEPG has a dedicated panel for preparing and running jobs. To use this panel, you can use both Search menu or the buttons on the toolbar. When running jobs, a dialog box, called Job Monitor, shows up that displays live information of the running processes as well as the overall progress. Any of the processes can be stopped by clicking the Stop button located at the right of the corresponding progress bar. Finally, a summary of the results is displayed, stating the end of the calculation. Keep in mind that all these panels are modal, meaning that they prevent any interaction with the main window in order to avoid manipulation of the recordings while the recognition phase is active.

When the search task ends, the recognized waveform patterns will be added to the recording signal object and displayed in the Profile Viewer, replacing any previous waveform data that has been added or loaded, so be sure to save your changes before running any calculation.

All jobs run synchronously on only one CPU or core, so in most today machines they should not significantly affect the operating system’s (OS) performance. However, in old single-core computers, the calculation can drastically decrease the responsiveness of the OS since each process runs CPU-intensive tasks in the background. So, in these cases, try to be patient while the calculation is running.
Chapter 3

The AutoEPG Main Window

This chapter gives a detailed description of the main window and its functions.

3.1 The Main window

The Maestro main window is shown in Figure 3.1 on the following page. The following main window components are always visible:

- **Title Bar**—displays the active filename.
- **Main menu bar**—provides access to actions and panels.
- **Main tool bar**—contains button for most common actions or tasks.
- **Signal viewer**—displays an individual EPG recording (time vs voltage) and other graphical objects for analysis.
- **Profile viewer**—shows the recognized waveform patterns (segments) in synchronization with Signal viewer. Note that this widget is hidden when there is no profile data in the active recording. See Section 3.5 on page 12 for details.

The following main window components can be displayed or hidden by choosing the component from the View menu. Your choice of which main window components are displayed is not persistent between AutoEPG sessions.

- **Navigation**—displays information about the active signal recording and an interactive table of waveform patterns in the recording. Also, shows a list of loaded
files that allows to load another signal into the viewer. See Section 5.3 on page 19 for details.

- **Panoramic view**—shows a panoramic vista of the entire active recording.

Other components are only shown when certain background tasks are running to give a visual feedback.

- **Status bar**—displays information about background processes such as reading or writing a file.

- **Job Monitor**—shows live data about searching processes.

Some of these components are dockable: they can be moved to any side of the main window or dragged out of the main window entirely into separated panels. This comes
in quite handy when you have a secondary screen available, since you can placed the panels over there avoiding component cluttering in the main window.

The following sections describe some of these main window components in more detail.

### 3.2 The Menu Bar

The menus on the main menu bar provide access to actions, allow you to enter commands, and control the appearance and contents of the main window. The main menus are as follows:

- **File**—open, close, save and export recordings and associated data.
- **Edit**—undo actions, add and remove segments, and **Go To** action.
- **View**—close or reopen panels, toggle mouse tracking and open **Preferences** window.
- **Search**—set up and submit searching jobs. Toggle **Fill Gaps Automatically** option. See Chapter 6 on page 21 for details.
- **Help**—display information about AutoEPG and Qt toolkit.

The functions of the items on the menus are described in detail in later chapters of this manual. Most of them have a corresponding shortcut that can be use instead for a fastest workflow.

### 3.3 The Main Toolbar

The main window has a unique tool bar, shown in Figure 3.2, that contains buttons for the common operations, which allow you to perform these tasks very quickly.

![The AutoEPG main toolbar.](image)

**Figure 3.2:** The AutoEPG main toolbar.
Each button is just as visual shortcut to a menu action, which in turns have an associated keyboard shortcut. So, for most actions, there are three ways of performing or initiating them, giving a great flexibility about how to interact with the application.

A detailed description of all 8 toolbar buttons is as following:

- **Open file**
  - Open a file. Opens the *Open File* panel so you can select a file to open.
  - Menu equivalent: *File → Open*

- **Save**
  - Save the active recording. Opens the *Save File* panel if necessary.
  - Menu equivalent: *File → Save*

- **Close**
  - Close the active recording. Opens the *Save File* panel if unsaved changes exists.
  - Menu equivalent: *File → Close*

- **Undo**
  - Undo the last action. It can be used several times.
  - Menu equivalent: *Edit → Undo*

- **Redo**
  - Redo the last action. It can be used as many times as undo’s were made.
  - Menu equivalent: *Edit → Redo*

- **Add Segment**
  - Starts *Adding Segment* mode. See Chapter 7 on page 22 for details.
  - Menu equivalent: *Edit → Add Segment*

- **Run All**
  - Run all available search engines. See Chapter 6 on page 21 for details.
  - Menu equivalent: *Search → Run All*

- **Run**
  - Run search engines. Opens a dialog box to choose which engines to run.
  - Menu equivalent: *Search → Run*

### 3.4 Signal Viewer

The signal viewer displays a graphical representation of the EPG recording that is currently active (See Section 5.1.1 on page 19 for how to change the active recording). The recording data is represented as a line graph, which is constructed by connecting a series of data points with straight line segments. Each data point corresponds to a voltage value measured in the EPG circuit. It is assumed that a sampling frequency
rate of 100 Hz was used in the data acquisition that translates to 100 measurements per second.

The signal viewer is shown in Figure 3.3. The X axis corresponds to the time in seconds (derived from number of points per second ratio) and the Y axis indicates the measured voltage in mV. A grid is shown in light gray and in every step (automatically calculated based on the current zoom ratio) a darker line is displayed to give a better time context in the visualization.

![AutoEPG Signal Viewer](image)

**Figure 3.3: AutoEPG Signal Viewer**

It is associated with a scroll bar that enables you to navigate across the recording, but it also receives keyboard events to do it faster (See Section 5.3 on page 19 for details). As mentioned before, you can also zoom in and out the recording using the corresponding buttons. For more details and interactions, read the following chapters.

### 3.5 Profile Viewer

The profile viewer displays the sequence of the waveform patterns or segments that are associated with the active recording (Figure 3.4 on the following page for details). Each segment is represented as a rectangle which width corresponds to its duration,
determined by the difference between its ends. It is important to notice that the profile viewer is synchronized with the signal viewer, meaning that both scrolling and zoom in it will affect the content of the profile viewer.

![AutoEPG Profile Viewer](image)

**Figure 3.4: AutoEPG Profile Viewer**

Both the color and the relative vertical position of a segment are related to its type, where each segment type has its own row in the viewer (the number of rows depends on how many segment types has the active recording). You can active a segment in the profile viewer by clicking it, which will mark the selected segment in the signal viewer by displaying the associated color as background color in that region. If you double click it, a Segment Dialog will pop up showing detailed information about the segment, including its duration and related comments. This is one of the ways to edit its data, treated in Section 7.3 on page 22.
Chapter 4

Reading and Saving Recording Data

AutoEPG can read and write recording information from plain text files (.dat), including its own native EPS format (See Section 4.1.2 on page 16), being able to read data generated by a variety of acquisition programs, meaning that you can use AutoEPG whatever equipment or applications you employ as long as a plain text can be obtained. Also, recordings can be saved and associated data may be exported independently.

4.1 Reading recordings

You can read data from files in EPS and plain text (.dat) formats. When importing recordings, AutoEPG places each recording into a new entry in the Signals tab located in the Navigation panel (See Section 5.3 on page 19 for details) and it will be set as the active entry. Be aware that unsaved changes in the previous recording will not be lost, and you can return to it anytime by selecting it in the Signals tab. For EPS files, profile data and other information is imported along with the recording data as well.

To open the Open File panel, do one of the following:

- Choose File → Open in the main window.
- Press Ctrl+O while the main window is active.
- Click the Open file button on the main toolbar in the main window.

When you open or even save a file, its location or containing directory is saved as a working directory, so when you later import or export a file, the corresponding panel
will start at that location. This is especially helpful when you have multiple recording files in the same directory, avoiding to navigate through the file system in order to find the desired file. Moreover, this particular feature is carried out between AutoEPG sessions to quickly return to previous work.

Selecting Files

While the use of the file type filter in the Open File panel is not needed for determine the type of the selected file, however it is important that the extension is correctly defined. Given that, the are two allowed extensions:

- .dat—Represents a plain text file which content is just a list of measured voltages.

- .eps—AutoEPG’s own format. See Section 4.1.2 on the following page for details.

When dealing with acquisition files (.dat), it possible that a single recording is split in several files. In these cases, you can name your files following a certain pattern so AutoEPG reads all of them into one single signal entry automatically. Two conventions exists: 

<filename>.<n>.dat and <filename>_<m>.dat, where <n> and <m> are one-digit (1, 2, etc.) and two-digit (01, 02, etc.) increasing numbers, respectively. AutoEPG will continue to read files until no file that follows the naming convention used is found; these files may use only one convention at a time.

The following filenames are valid and AutoEPG should read them continuously for a file originally named verde-rojo-13-ch1:

- verde-rojo-13-ch1_01.dat, verde-rojo-13-ch1_02.dat, verde-rojo-13-ch1_03.dat.

4.1.1 Data parsing

AutoEPG only reads text plain files with extension .dat as raw data input. This kind of file can be obtained by converting PROBE acquisition files (*.D01, *.D02, etc.) using the ANA34 BIN-ASCII module associated to Probe 3.5, found at EPG
systems webpage (in the Downloads page, go to EPG Data Processing section). This will provide a custom button that allows the user to save the current loaded recording as ASCII text plain data files with .dat extension.

In case you employ different equipments or set of applications, you should check the corresponding user manuals or even contact your supplier to know how export the acquisition data into text plain format.

4.1.2 EPS File Format

As said earlier, AutoEPG has its own native format file called EPS, which stands for Electrical Penetration Signal. It is a plain text file written in XML, which is a markup language that defines a set of rules for encoding data. Please note that a EPS file doesn’t contain the actual recording data, instead it includes the name of the recording file (.dat) that must be placed at the same location of the EPS file.

An example of a typical EPS file is shown in Listing 4.1. It contains information about the recording file under the info section such as filename and number of measurements or points. Then, segments data should be placed in the segments section, where count attribute is just a remainder (i.e. optional). Finally, each segment block should contain start and end properties in seconds and its type name (it doesn’t need to be capitalized). Also, each component can have comments which can be visualized and modified in the AutoEPG graphical user interface.

Listing 4.1: "Example of an EPS file"

```xml
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE epsignal>
<epsignal version="1.0">
  <info>
    <name>3NOVAH-ch1_01</name>
    <comments></comments>
    <datname>3NOVAH-ch1_01.dat</datname>
    <length>1080000</length>
  </info>
  <segments count="63">
    <segment>
      <type>Np</type>
      <start>6</start>
      <end>66211</end>
    </segment>
  </segments>
</epsignal>
```
It is not recommended to alter an existing EPS file by hand since it’s very error-prone, however commenting a segment manually may be useful in some cases. AutoEPG can only manipulate segment data using the EPS file format, since it is incapable to modify directly the .dat file. In this regard, you can think of an EPS file as an improved version of an ANA file (analysis file used by PROBE software which contains the beginning and end of each marked segment).

4.2 Saving Recordings

Using the Save Panel, you can write out recording files and/or associated data in EPG or plain text formats. You can only save the Workspace contents or active recording entry, and each entry will be saved in its own file.

To open the Save File panel, do one of the following:

- Choose File → Save in the main window.
- Choose File → Save As in the main window.
- Press Ctrl+S while the main window is active.
- Click the Save button on the main toolbar in the main window.

The Save File panel is laid out in a similar fashion to the Open File panel, as a standard file selector, with a Save as type drop-down list at the bottom that will primarily indicate the format in which the file will be saved. However, if the filename has an extension, it will override that selected in the Save as type filter and it will be used
to determine in which format the file should be written. When you try to save the active recording, the Save File panel will show up only if there is no associated EPS file. Otherwise, the changes will be saved into the corresponding EPS file immediately.

Unlike the ability to read multiple files into one single recording entry, there is no way to doing something similar when saving the recording, so each entry will be represented by just one data file.

4.2.1 Exporting Data to a Spreadsheet
Chapter 5

Viewing a Recording

5.1 Displaying Recording Data

5.1.1 Changing the Active Recording

5.1.2 Closing a Recording

If there are unsaved changes and no .EPG file exists, Save File panel will show up so you can select a destination to save to.

5.2 Changing the View

5.2.1 Zooming In and Out

5.2.2 Restoring the Default View

5.3 Navigation

Go To action Scrolling on Profile Viewer?
5.3.1 Keyboard Shortcuts

5.3.2 Using the Segment Table

5.3.3 Panoramic View

5.4 Adjusting the Workspace
Chapter 6

Analysis

6.1 Searching process?

6.1.1 Search engines

6.1.2 Validation

Fill Gaps Automatically option

6.2 Searching Waveform Patterns

6.2.1 Running Calculations

6.2.2 Viewing the Results
Chapter 7

Editing

7.1 Labeling and Annotating a Recording

7.2 Adding Segments

"Adding Segment" mode

7.2.1 Segment Types

Creating New Segment Types

Editing Existing Segment Types

7.3 Modifying Existing EPG Data

7.3.1 Changing the Segment’s Ends

Live segment resizing option

7.3.2 Selecting the Segment’s Type

7.4 Deleting a record

Ask when deleting a segment option
Chapter 8

Help

8.1 AutoEPG Web Site

8.2 Technical Support
Chapter 9

Glossary

• **entry**—A recording and associated data. Entries are represented as rows in the Signals tab in the Navigation panel.

• **exporting**—Writing structures and their associated data from AutoEPG to a recording or data file.

• **GUI**—Graphical User Interface.

• **profile**—Series of segments that are associated with a EPG recording.

• **segment**—Represents a waveform pattern found in a EPG recording.

• **importing**—Reading recordings and their associated data from a recording file into a AutoEPG.

• **Workspace**—The open area in the center of the AutoEPG main window in which recordings and their profile are displayed.