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Preface 

 

This section describes the audience for, the organization of, and conventions used in  
this document. It also identifies related documentation and explains how to access 
electronic documentation. 

Audience 

This document is written for technical people who have basic understanding, familiarity 
and experience with network test and measurement equipment.   

Conventions 

The following conventions and notations are used in this document:    

Note: This symbol means take note. Notes contain helpful suggestions or references to 

additional information and material. 

 

Caution: This symbol means be careful. In this situation, you might do something that 

could result in equipment damage or loss of data. 

 

Warning: This symbol means danger. You are in a situation that could cause bodily 
injury. Before you work on any equipment, be aware of the hazards involved with 

electrical circuitry and be familiar with the standard practices for preventing accidents. 

Obtaining the Latest Documentation and Software 

Please visit the ThinkRF website at http://www.thinkrf.com/documentation to obtain 
the latest documentation. Latest software and firmware releases are also available on the 
ThinkRF website at http://www.thinkrf.com/download. 

Document Feedback 

Please send your comments about this document or any ThinkRF documentation to 
support@thinkrf.com. 

We appreciate your feedback. 

http://www.thinkrf.com/documentation
http://www.thinkrf.com/download


Obtaining Technical Assistance 

For all customers who hold a valid end-user license, ThinkRF provides technical 
assistance 9 AM to 5 PM Eastern Standard Time, Monday to Friday. Contact us at 
support@thinkrf.com or by calling +1.613.369.5104. 

Before contacting support, please have the following information available: 

 WSA5000 serial number (located on the identification label on the WSA5000's 
underside, or available from the File → Device Information menu entry of the 
RTSA application). 

 The firmware version running on the WSA5000 (available from the File → 
Device Information menu entry of the RTSA application). 

 Versions of ThinkRF software you are using, including the API libraries to third-
party applications.    

 The operating system and version you are using. 
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Overview of the WSA5000 Real Time  
Spectrum Analyzer 

 
The WSA5000 Real Time Spectrum Analyzer (RTSA) is a full-featured spectrum analysis 
application designed to work with the WSA5000 Wireless Signal Analyzer. The RTSA 
application provides standard spectrum analysis features including frequency controls, 
marker functions, and multi-trace capabilities. 

The WSA5000 Wireless Signal Analyzer is a high-performance software-defined RF 
receiver, digitizer and analyzer. With patent-pending software-defined RF receiver 
technology, the WSA5000 provides industry-leading combined sensitivity, tuning range, 
instantaneous bandwidth (IBW) and scan rate. The WSA5000 has a hybrid RF receiver 
front-end (RFE) that combines super-heterodyne, direct-conversion and direct digitization 
technologies with both wide-band and narrow-band ADCs. In addition, the WSA5000 
provides hardware-based triggering and capture control, thereby enabling sophisticated 
sweeping and real-time capture.   

You can use the WSA5000 RTSA to measure signals such as Wi-Fi, Bluetooth, and LTE, 
and use markers to track specific frequencies. Sophisticated FPGA-based level triggers 
within the WSA5000 Wireless Signal Analyzer enable the capture of elusive, time-varying 
signals across an instantaneous bandwidth of up to 100 MHz. The record-and-playback 
feature allows you to capture signal data, store it, and replay the captured signal at a later 
time. You can also export captured data to a CSV file for further processing. To make 
signal display and capture easier, you can save configuration settings and load the saved 
settings at any time. 

The WSA5000 RTSA application includes an intuitive user interface that incorporates a 
full set of controls for fast and simple control of application features. Fluid mouse 
navigation over the plot area allows you to quickly view the entire spectrum and easily 
zoom into areas of interest. 

The WSA500 RTSA application is built on the PyRF development framework, and is 
open-source under BSD licensing. PyRF handles the low-level details of real-time 
acquisition, signal processing and visualization, and provides feature-rich libraries, 
sample applications and source code, all specific to the requirements of signal analysis. 
For more information, visit the PyRF site at http://www.pyrf.org/. 

 

http://www.pyrf.org/


WSA5000 RTSA User Interface 

The WSA5000 RTSA user interface provides controls to manage the RFE mode of the 
WSA5000 Wireless Signal Analyzer, trace capabilities, the frequency and amplitude 
display, multiple plots such as spectrogram and raw IQ data, as well as  
measurement tools. 

The main area of the RTSA user interface contains the plot display, which shows the 
monitored signal. The plot display also shows current frequency span and amplitude 
settings, as well as the configured resolution bandwidth (and video bandwidth,  
if applicable). 

Configuration controls for modifying RTSA application settings are located on the right 
side of the interface. The Menu buttons on the far-right side provide access to different 
parameters in the Menu Panel. The parameters in the Menu Panel change depending on 
the active Menu Button. 

 
Figure 1: The RTSA User Interface 

Configuration Controls 

The right-most panel of the RTSA user interface contains a list of menu buttons that allow 
you to access different parameters in the menu panel. The following table describes the 
function of each button.  These buttons are shown by default, but they can be hidden by 
unchecking the Show Controls option under the View file menu. 



Note: This section provides an overview of the WSA5000 RTSA user interface.  
Please refer to the Configuring the WSA5000 RTSA Application section for details on how 
to use individual settings and the options for each parameter.   

 

Menu Button Provides access to ... 

Amplitude Parameters to define the amplitude range for signal monitoring 

BW Parameters to specify the resolution bandwidth for signal 
capture and video bandwidth for noise reduction 

Display Parameter to add a horizontal line to the display 

Freq Span Parameters to configure frequency span for signal monitoring 

Marker Parameters for adding markers to signal trace(s) 

Meas Setup Parameter to configure trace averaging for signal capture 

Mode Meas Parameters for setting the application's measurement mode for 
signal capture 

Peak Search Parameters for configuring signal peak detection 

Sweep Parameters for defining the signal acquisition mode 

Trace Parameters for configuring one or more traces on the signal 
display 

Trigger Parameters to define the triggers for signal capture (non-sweep 
modes only) 

System Parameters to configure device control 

Preset Provides access to parameter to restore all configuration 
settings to factory defaults 

 

You can specify a value for each parameter by doing one of the following: 

 Selecting a setting from a pre-populated drop-down list (where applicable). 

 Clicking the field and entering a value in the pop-up window. You can enter  
numbers and letters (for measurement units) from your keyboard, or use the 
keypad to select numbers and units, or use the up/down arrows to specify  
a value. 

 Hovering over the field with the mouse, and using the mouse wheel to increase 
or decrease the existing value, or to toggle between the options in a  
pre-populated list.
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Getting Started with the WSA5000 RTSA 
Software 

 
Before installing the WSA5000 Real Time Spectrum Analyzer software, ensure that your 
PC meets the minimum system requirements: 

 Operating System: 

◦ Windows XP 

◦ Windows 7 (32-bit or 64-bit) 

◦ Windows 8 (32-bit or 64-bit) 

 RAM:  2 gigabytes (GB) 

 Hard Disk: 1 gigabyte (GB) available 

Note: You must have an Internet connection to download the WSA5000 RTSA software 

from the ThinkRF website. 

 

Installing the WSA5000 RTSA Software 

You must download the WSA5000 RTSA installer from the ThinkRF website to install the 
software on your computer. 

1. Open a web browser, and go to http://thinkrf.com/download. 

2. Click the Download button to download the zip file for the latest software and 
firmware release (for example, WSA5000 RTSA Release 140909). 

3. When you have downloaded the zip file, extract the contents to the folder of  
your choice. 

4. Double-click on the pyrf_RTSA_Installer_x.y.z.exe file to launch the Setup 

Wizard, and follow the prompts to select your installation options and install  
the software. 

5. On the Welcome screen, click Next. 

6. On the License Agreement screen, select “I accept the agreement” and  
click Next. 

7. On the Select Destination Location screen, specify a path for software installation 
(or keep the default path) and click Next. 

8. On the Select Component screen, select the software components you want to 
install and click Next. 

9. On the Select Start Menu Folder screen, specify a path for the program shortcut 
in the Start Menu (or keep the default) and click Next. 

10. On the Select Additional Tasks screen, specify whether you want the installer to 
create a desktop shortcut to the WSA5000 RTSA application, and click Next. 

http://thinkrf.com/download/


11. On the Ready to Install screen, review your installation settings. Click Install to 
proceed with the installation, or Back to change your settings. 

12. When the Setup Wizard has completed software installation, click Finish to exit 
the Wizard. 

 

Connecting to a WSA5000 Device 

You must connect to a WSA5000 Wireless Signal Analyzer to view data in the 
WSA5000 RTSA application. The application detects any WSA5000 devices that are on 
the same subnet of your network, but you must explicitly select one to complete the 
connection. 

1. Launch the WSA5000 RTSA application from the Start menu or desktop icon  
(if installed). 

The application displays the “Open Device” window. 

2. Select a device from the list of auto-discovered devices. You can click the 
Refresh button to obtain an updated list of devices. 

Alternatively, you can enter the IP address of the WSA5000 device manually in the 
“Manually Enter Device IP” field. 

3. Click Connect. 

The WSA5000 RTSA application connects to the WSA5000 device and displays the 
user interface. By default, the WSA5000 acquires and measures signals 
automatically.   

4. If you want to connect to a different WSA5000 Wireless Signal Analyzer, open 
the File menu in the WSA5000 RTSA application and select Open Device. 

The application displays the “Open Device” window. Repeat steps 2 and 3 to select a 
new device. 

  



Configuring the WSA5000 RTSA Application 

 
The WSA5000 Real Time Spectrum Analyzer application provides several options for 
controlling and displaying signal capture through the WSA5000 Wireless Signal Analyzer. 
You can set the RFE mode, specify the frequency span and amplitude, and use multiple 
traces and markers on the signal display. 

Configuring the Application for Signal Measurement 

The WSA5000 Real Time Spectrum Analyzer application can capture signals in 
swept-tuned (Spectrum Analyzer) mode or in real-time signal analysis (RTSA) mode. 

When you operate the application in swept-tuned mode, you must also specify a  
sweep type. 

When you operate the application in RTSA mode, you must select the instantaneous 
bandwidth, and optionally, set trigger parameters for signal capture. 

Configuring the Measurement Mode 

You can set the Radio Front End (RFE) mode of the application to ensure that the signal 
is measured and displayed in a manner appropriate to your application. 

1. Click the MODE MEAS menu button to access the Mode Measurement menu. 

2. In the Mode field, select one of the following measurement modes for  
the application: 

 Spectrum Analyzer: the application measures and captures signals in swept-
tuned mode. 

 RTSA: the application measures and captures signals in real-time signal 
analysis mode. 

3. Spectrum Analyzer mode only: You can define a section of the signal being 
monitored and view the channel power of that section on the display. 

 In the Measurement field, select Channel Power from the drop-down list.   

The plot display shows two vertical lines to define the region of interest 
(default is 3500 MHz across the center of current spectrum), and the 
background color between the boundaries changes. The measured channel 
power is displayed below the signal plot.    



 
Figure 2: Channel Power Measurement 

 

 If you want to change the section of the signal whose channel power is being 
measured, click the Meas Setup button and specify the section bandwidth in 
the Integration BW field. 

Note: Enabling the Channel Measurement mode disables the Start Frequency and 
Stop Frequency parameters on the Frequency menu. The frequency span is fixed at the 

last configured Frequency Span value. 

 

Configuring the Sweep Type or Instantaneous Bandwidth 

The available Sweep Mode parameters depend on the measurement mode selected for 
the application, as summarized in the following table. 

Measurement Mode Sweep Type values 

Spectrum Analyzer Sweep Normal 

Sweep Accuracy 

Advanced modes: 0.1 MHz span 

Advanced modes: Baseband 

RTSA 40 MHz span (instantaneous bandwidth) 

10 MHz span 

100 MHz span 

 

 



 

1. Click the SWEEP menu button to access the Sweep menu. 

2. In the Sweep Type field, specify the signal input mode from the drop-down list. 

In Spectrum Analyzer mode, select one of the following values: 

 Sweep Normal: fastest sweep time (but lower amplitude accuracy) 

 Sweep Accuracy: best amplitude accuracy (but slower sweep time) 

 0.1 MHz span: 100 kHz span in fixed mode (non-tunable); expands the 
dynamic range of the spectrum analyzer to 100 dB. Best for low-power signals. 

 Baseband: fixed spectrum from 0 – 62.5 MHz (non-tunable).   

In RTSA mode, select one of the following values: 

 40 MHz span:40 MHz instantaneous bandwidth 

 10 MHz span: 10 MHz instantaneous bandwidth 

 100 MHz span: 100 MHZ instantaneous bandwidth; uses Zero IF (ZIF) signal 
path. Note the DC offset at the center frequency (always on) and the images 
that can be generated in this mode. 

Note: The 100 MHz span utilizes an IQ correction algorithm which can be optimized 
based on signal requirements. If the signal of interest is a wideband signal, click the 
MEAS SETUP menu button, and under IQ Correction Algorithm select Wideband 
Signal, and If the signal of interest is a narrowband signal, click the MEAS SETUP menu 

button, and under IQ Correction Algorithm select Narrowband Signal. 

4. Optionally, check the Continuous box to enable continuous capture of signals. 
The application acquires signals and displays them on a continual basis. 
Unchecking the box pauses signal capture. 

5. If you do not enable continuous capture, you can click the Single button for a 
single capture the signal. The application acquires the signal once and displays it 
immediately. 

Configuring Triggers for Signal Capture (RTSA mode) 

If the application is configured to measure signals in RTSA mode, you can configure a 
trigger for signal capture. 

Note that in Spectrum Analyzer mode, all trigger parameters are disabled. 

1. Click the TRIGGER menu button to access the Trigger menu. 

2. In the Trigger Source field, specify how you want to trigger signal capture by 
selecting one of the following options from the drop-down list: 

 Free Run: there is no explicit signal trigger; the application measures signals 
automatically. 

 Level: the application requires specific conditions to trigger signal capture, 
defined by start and stop frequencies, and power level. 

3. If you selected Level as the trigger source, specify the conditions necessary to 
trigger signal capture:   



 In the Trigger Start Frequency field, specify the minimum frequency required 
for signal capture. When the system detects a signal above this frequency,  
the application begins signal capture. 

 In the Trigger Stop Frequency field, specify the maximum frequency for 
signal capture. When the measured signal exceeds this frequency,  
the application stops signal capture. 

 In the Trigger Level field, specify the minimum power level for signal capture. 
The application only captures signals between the start/stop frequency range 
that are above this power level.   

The plot display shows a rectangle representing default trigger parameters: minimum 
frequency (left boundary), maximum frequency (right boundary), and power level 
(top boundary). 

 
Figure 3: Level Trigger Measurement 

 

You can also set the trigger parameters by clicking and dragging the left, right and 
top boundaries to change the minimum frequency, maximum frequency and power 
level respectively. 

Configuring the Resolution Bandwidth 

In both Spectrum Analyzer (swept-tuned) and RTSA (FFT) measurement modes, you can configure the 
resolution bandwidth to specify the smallest frequency that can be resolved as a separate peak on the 
display.   

In Spectrum Analyzer mode, you can also configure the video bandwidth to reduce noise on the trace and 
make signals that would otherwise be obscured by noise easier to see on the display. 

1. Click on the BW menu button to access the Bandwidth menu.   

2. In the Resolution Bandwidth field, select a value from the drop-down list to specify the 
resolution bandwidth.   



3. Spectrum Analyzer mode only: Specify parameters for the video bandwidth. 

 In the Video Bandwidth field, specify the Video Bandwidth. This field is only enabled if the 
Auto option is not enabled. 

 Optionally, select the Auto box to enable automatic calculation of the video bandwidth based 
on the ratio in the RBW:VBW field. 

 In the RBW:VBW field, set the Resolution Bandwidth-to-Video Bandwidth ratio. The video 
bandwidth is automatically calculated relative to the resolution bandwidth, based on this value. 
The value must be a positive integer. 

 

Configuring the Frequency Span and Amplitude 

You can specify the frequency span and maximum power level for signal capture, and 
enable attenuation on incoming signals. 

Configuring Frequency Settings 

You can set the frequency for the signal to be monitored using the parameters in the 
Frequency configuration panel. You can enter values for these fields manually, or  
click-and-drag the mouse over the plot display area to change the monitored frequency. 

As you specify or change these values, the axes on the signal waveform display adjust 
accordingly. A vertical line on the plot display indicates the center point of the frequency 
band being monitored. 

The frequency parameters you can change depend on the application measurement 
mode (set in the Mode Meas configuration panel). 

1. Click on the FREQ SPAN menu button to access the Frequency menu. 

2. In the Center Frequency field, specify a value for the central point of the 
frequency band you want to monitor. 

3. For Spectrum Analyzer mode only: Set the sweep range for the monitored 
frequency by doing one of the following: 

 Specify a value in the Span field. This value is applied relative to the center 
frequency value. 

 Specify the lower boundary of the sweep range in the Start Frequency field 
and the upper boundary of the sweep range in the Stop Frequency field 

 Click the Full Span button to select the maximum available span (that is, the 
full tuning range, dependent on the model of the WSA5000 Signal Analyzer). 

If the selected measurement mode is RTSA, the Span fields are disabled. The 
frequency span is determined by the instantaneous bandwidth value specified in 
the Sweep Type field. 

 

4. Optionally, specify the interval of frequency control field values by setting the 
CF Step field. 

5. Optionally, check the Zoom Mouse box to manually zooming into the spectral 
plot. 

 



Configuring Zero Span Plot 

Enabling the Zero Span plot forces the spectrum to switch the x-axis to the time-domain, 
while the y-axis remains as the power level (in dBm). The spectrum plot will continuously 
update along the x-axis as each capture is received. The x-axis range can be set using 
the Time Span control under the FREQ SPAN menu. Zero span switches the RTSA to 
use the 10 MHz Span RTSA mode, which provides the most accurate amplitude level. 

1. Click on the FREQ SPAN menu button to access the Frequency menu. 

2. Enable Zero Span plot by clicking on the Zero Span checkbox 

3. The time span can be changed by changing the Time Span value under the 
FREQ SPAN menu. 

 

Configuring Amplitude Settings 

You can set the amplitude range for signal monitoring using the parameters in the 
Amplitude panel.    

1. Click on the AMPLITUDE menu button to access the Amplitude menu.   

2. In the Reference Level field, specify a value for the maximum power level 
permitted for input signals.   

3. In the Scale/Div field, specify the distance between horizontal grid lines in the 
signal display (between 1 and 15 dB). 

4. In the Reference Level Offset field, specify a value for the power offset for the 
signal display. 

Note that the offset is applied in software only and is reflected in the signal display 
including any recorded signals for playback. The input signal itself is  
not affected. 

5. Specify the attenuation setting for the input signal by selecting one of  
the following: 

 Auto Attenuation: enables automatic attenuation of the input signal, based on 
the maximum permitted power level, as specified in the Reference Level field 
(for the WSA5000-108 model).  
 
Note that for the WSA5000-208 and WSA5000-220 models, the attenuation 
range is 0-25 dB, at 1 dB intervals. 

 Attenuation: enables or disables the device's default 20 dB attenuation of the 
incoming signal (set to 0 dB to disable).   

 



Adding a Display Line 

You can add a horizontal line to the plot display of the signal being monitored to mark a 
specific power level.   

1. Click on the DISPLAY menu button to open the Display menu. 

2. Select the Display Line box. 

3. Optionally, change the default power level value to change where the display line 
appears on the graph. 
 
You can also change the position of the horizontal line by clicking and dragging 
the line on the plot display. 

 

 

Adding Markers and Traces to the Signal Display 

The RTSA application supports up to six active traces on the plot display, and up to 
twelve markers. 

Adding Traces 

You can configure up to six active traces in the signal display. By default, the first trace  
is set to display all values captured for the signal. The following procedure applies  
to each trace. 

1. Click on the TRACE menu button to access the Trace menu. 

2. Select a trace by clicking on a number (from one to six) in the grid at the top  
of panel. 

3. In the Trace Type field, select the display mode for the trace from the  
drop-down list: 

Trace Type Description 

Clear/Write Trace plots all values that are captured for the signal.  
Each new set of data overwrites the previous set so that the 
trace is always up to date 

Trace 
Average 

Trace plots the average values captured for the signal over 
the number of samples specified in the Avg/Hold Number 
field (under Measurement Setup) 

Max Hold Trace plots only the maximum values captured for the signal 

Min Hold Trace plots only the minimum values captured for the signal 

 

4. Optionally, in the Trace Color field, select a different color for the trace from  
the palette. 

 

 

 

 



5. In the View/Blank field, select the state of the trace 

Type Description 

Active The trace will always remain active on the spectral plot 

View Hold the current trace in its current state. This is equivalent to 
Trace Hold. 

Blank Turn the trace off 

 

 

6. Click the Clear Trace button to reset the trace display.      

7. Repeat steps 1 - 4 to add new traces (to a maximum of six). 

8. Click the Clear All Traces button to reset all traces on the display. 

Configuring Trace Averaging 

You can specify the number of averages used to calculate the signal and display the trace in the 
plot display. The default value is 100. 

1. Click the MEAS SETUP menu button to access the Measurement Setup menu. 

2. In the Avg/Hold Number field, specify the number of averages used to calculate the 
trace. This value must be a positive integer. 

3.  

Adding Markers 

You can add up to 12 markers to the signal display and associate the markers with any 
trace on the display. You can use delta markers to measure changes in power and 
frequency relative to a reference marker. 

1. Click on the MARKER menu button to access the Marker menu. 

The Marker menu opens on the Mkr tab. Marker 1 is automatically added to the 
signal display (as a diamond icon) at the center frequency, and moves on the 
waveform with the fluctuations in power level. The frequency and power values at 
the marker point are displayed in the top-right corner of the display. 

2. Select a number from the number grid (one to twelve) at the top of the 
configuration panel.   

3. In the Marker Frequency field, specify a frequency value to position the marker. 
You can also click and drag the marker to the desired position on the display. 

Note that the Marker Power field shows the power level of the Marker in  
real-time, and is read-only. 

4. In the Marker Mode field, select a mode from the drop-down list: 

 Normal: the marker's amplitude position changes with the amplitude of the 
signal (but the frequency position remains the same). 

 Fixed: the marker stays at the same frequency and amplitude (power level), 
regardless of changes in the signal's amplitude. 

 Off: the marker is removed from the display. 



 Delta <n>: if there is at least one primary marker on the signal display, the 
marker is set as a delta marker relative to the specified primary marker. For 
example, if there are two primary markers on the signal display, Marker 3 
could be designated as Delta 1 or Delta 2. 

5. In the Marker Trace field, assign the marker to a trace by selecting the trace 
from the drop-down list. The list contains all active traces on the display. 

6. Optionally, click the Marker Delta button to add a secondary marker (relative to 
the current marker). 

The delta marker appears on the signal display (as an inverted triangle icon), with the 
number corresponding to the tab hovering above it. The frequency and power 
values of the delta marker appear on the display above the grid. 

7. Optionally, check the Marker Table On box to display a list of all active markers 
(with their corresponding mode, frequency, power level, and trace assignments) 
below the plot display. 

You can click on an entry in the Marker Table to select it on the plot display.  
The values in the table show measurement fluctuations in real-time. 

 
Figure 4: Marker Table 

 

8. To remove a single marker, change the Marker Mode to Off (in the Marker  
Mode field). 

9. Click the All Markers Off button to remove all markers from the display. 

Configuring Peak Search and Peak Thresholds 

You can set the position of the markers on the display to identify peaks in the captured 
signal. When you activate peak search, the system turns on the first available marker and 
positions it at the highest peak on the signal. 

1. Click on the PEAK SEARCH menu button to open the Marker menu. 



2. On the Pk Search tab, select the marker number from the number grid (one to 
twelve) at the top of the configuration panel.   

3. Click the Peak Search button to position the marker at the highest peak signal. 

4. Click the Next Peak button to position the marker at the next highest peak signal, 
wherever it occurs. 

5. Click the Next Peak Left button to position the marker at the highest peak signal 
to the left of the current marker position. 

6. Click the Next Peak Right button to position the marker at the highest peak 
signal to the right of the current marker position. 

7. Click the Next Point Left button to position the marker on the next (measured) 
display point to the left of the current marker position. You can also use the left 
arrow key on your keyboard to move the marker.   

8. Click the Next Point Right button to position the marker on the next (measured) 
display point to the right of the current marker position. You can also use the right  
arrow key on your keyboard to move the marker. 

9. Click the Marker -> Center button to change the center frequency to match the 
current (primary) marker position. 

10. Check the Continuous Peak box to allow the marker to move to the highest peak 
as it occurs on the display. 

 

You can define criteria for Peak Search so that peak detection occurs within specific 
parameters. 

1. Select the Pk Config tab. 

2. Check the Pk Threshold On box to enable the peak threshold function. 

3. In the Pk Threshold On field, specify the minimum power level for a marker 
position. Markers are not applied to peaks that fall below this power level. 

4. Optionally, check the Pk Threshold Line box to display a horizontal line at the 
power level defined in the Pk Threshold On field.   

5. Check the Pk Excursion On box to enable the peak excursion function. 

6. In the Pk Excursion On field, specify the power range (relative to the peak 
threshold), within which a marker can move when seeking a peak point. This 
value must be a positive number. 

 

Configuring the Device Control Options 

You can configure device control settings to ensure signal information is captured and 
displayed in a manner appropriate to your application. 

1. Click the SYSTEM menu button to access the device control menu. 

2. RTSA mode only: In the Decimation Rate field, set the decimation rate for the 
signal by selecting a value from the drop-down list. (Disabled when the 
application is operating in Spectrum Analyzer mode.). 

3. RTSA mode only: In the Frequency Shift field, set the value of the frequency 
shift. A negative value corresponds to a left shift. (Disabled when the application 
is operating in Spectrum Analyzer mode.). 



4. In the IQ Path field, specify the IQ output path from the drop-down list  
(either Digitizer or Connector). 

5. In the PLL Clock Reference field, specify the synchronization source for the PLL 
reference clock from the drop-down list (either Internal or External). 

Note: If you select the “Connector” option for IQ Path, you are using the device in Down-
Converter mode and bypassing all internal digitizing functions. The signal display area 

disappears from the interface when you select this option. 

 

Restoring System Defaults 

You can return reset all parameter values to system defaults. If you want to save your 
custom settings before restoring the system defaults, see Administration. 

1. Click on the PRESET menu button to access the Preset menu. 

2. Click the Preset All button to restore all settings to the original system settings.   

Configuring DSP Operations 

Configuring IQ Correction 

The RTSA provides a corrective algorithm to reduce the effects of IQ phase and 
amplitude offsets. The algorithm is always turned on, but can be optimized for either 
Wideband or Narrow band signals. This correction algorithm can be changed using the 
following steps: 

1. Click on the MEAS SETUP menu button 

2. Under the IQ Correction label, select the type of correction (either Wideband or 
Narrowband) 

Enabling Spur Mitigation 

Spur mitigation can be enabled to reduce the level of input related spurs. The algorithm 
works by identifying the spur level, and suppressing it using the spur mitigation control. 

1. Click on the MEAS SETUP menu button 

2. Click the Apply Spur Mitigation Checkbox to enable the spur mitigation 

3. Change the Spur mitigation Level to target the specified spur 

 

 



Viewing Signal Data 

 

You can view captured signal data in several modes. The RTSA application supports the 
following displays:   

 I/Q plots 

 Spectrogram 

 Persistence Plot 

Displaying I/Q Plots 

You can view an I/Q plot display of captured signal information (this view is particularly 
useful when using the device in IQIN mode). The I/Q plots appear below the main signal 
display in the interface, and includes two plots: 

 Constellation plot (left side) shows the in-phase (I data) vs quadrature  

(Q data) plot 

 Time domain plot (right side): shows a trace for the In-phase (I data in green) and 
a trace for the quadrature (Q data in red, if available in the mode) 

 

 
Figure 5: IQ Plots 

 

1. Open the View menu, and select I/Q Plots from the drop-down menu. 

The I/Q plots appear below the main signal waveform display.   

2. To hide the I/Q plots, open the View menu and deselect the I/Q Plots option. 

 



Displaying the Spectrogram 

You can view a spectrogram display of captured signal information. The spectrogram 
displays spectrum changes over time in a three-dimensional view. Time is displayed on 
the horizontal axis, and frequency on the vertical axis. The amplitude of the frequency 
components is expressed by color. 

 
Figure 6: Spectrogram Plot 

 

1. Open the View menu, and select Spectrogram from the drop-down menu. 

The spectrogram plot appears below the main signal waveform display.   

2. Optionally, you can enhance the display of the signal(s) of interest by sliding the 
triangles on the color palette (to the left of the display) to adjust the threshold at 
which the signal changes color. This allows the user to specify colors for each 
noise floor level. 

3. To hide the Spectrogram plot, open the View menu and deselect the 
Spectrogram Plot option. 

 

 

 

Displaying the Persistence Plot 

You can view a persistence plot display of captured signal information. The persistence 
plot is a view of how long a signal remains present; as it grows weaker, it fades in color.  
Amplitude is displayed on the horizontal axis, and frequency on the vertical axis. 



 
Figure 7: Persistence 

 

1. Open the View menu, and select Persistence Plot  from the drop-down menu. 

The persistence plot appears below the main signal waveform display.   

2. Optionally, you can enhance the display of the signal(s) of interest by sliding the 
triangles on the color palette (to the left of the display) to adjust the threshold at 
which the signal changes color. This allows the user to choose the colors that the 
persistence plot uses to represent the shades of persistence of the spectrum. 

3. To hide the Persistence plot, open the View menu and deselect the Persistence 
Plot option. 

 

 

 

 

 

 

 

 

 

 



Capturing Data from the WSA5000  
RTSA Application 

 
In addition to viewing signal data in real time on the WSA5000 Real Time Spectrum 
Analyzer application, you can also capture and store signal information for playback, or 
write the data to a CSV file for further processing by another application.   

Caution:  The WSA5000 RTSA application does not impose a limit on the file size for 
signal recording or writing to a CSV file. If recording is not explicitly stopped, the 

application continues to write data to the file until the local hard drive is full. 

Capturing a Screenshot 

The WSA5000 RTSA application allows you to capture a screenshot of the current 
application window. The screenshot is stored in a PNG file format.  

1. To take a screenshot, open the File menu and select the Take Screenshot 
option. 

2. The RTSA application will display a file directory selection window, where you 
can select the directory where the screenshot is to be stored.  

3. Click Save to take the screenshot, the image will be saved 

 

Recording a Signal for Playback 

The WSA5000 RTSA application allows you to record a signal and save the file for future 
playback. All recorded signals are stored on the PC that is hosting the WSA5000 RTSA 
application. 

1. To begin recording the signal data, open the File menu and select the Start 
Recording option. 

The RTSA application begins recording the signal data displayed in the interface. 

2. To stop recording the signal data, open the File menu and select the Stop 
Recording option. 

The WSA5000 RTSA application stops recording the signal data displayed in the 
interface, and stores the recorded file (with .vrt extension) in the 

pyrf/RTSA/Scripts/dist directory.   

Playing Back a Recorded Signal 

Exporting Signal Data to a CSV File 

The WSA5000 RTSA application allows you to capture and export signal data to a CSV 
file for further processing by another application. All recorded data is stored on the PC 
that is hosting the WSA5000 RTSA application. 



The CSV file contains the following information about the captured signal: 

Parameter Description 

mode The RFE mode of the device during signal capture. Possible 
values are: 

• ZIF (100 MHz instantaneous bandwidth) 

• SH (40 MHz instantaneous bandwidth) 

• SHN (10 MHz instantaneous bandwidth 

• HDR (100 kHz instantaneous bandwidth) 

• DD (0-50 MHz instantaneous bandwidth; no tuning) 

• IQIN (100 MHz instantaneous bandwidth; no tuning) 

fstart The start of the frequency range (Hz) 

fstop The end of the frequency range (Hz) 

size Number of data points (power values) captured for the signal in 
the CSV file 

timestamp ISO time stamp representing time at which the data was 
displayed in the RTSA 

<data> A series of integers representing the power value of the 
captured signal for each sample. The number of data samples 

corresponds to the value specified in the size parameter 

 

1. To begin capture and export of the signal data, open the File menu and select 
the Start Exporting CSV option. 

The RTSA application opens an Explorer dialog box to specify the name and location 
of the CSV file. 

2. Specify a name and storage location for the file and click Save. By default, the 

system stores the file (csv-0000.csv) in the the pyrf/RTSA/Scripts/dist 

directory. The system begins writing the signal data to the CSV file at the 
specified location. 

3. To stop writing signal data to the CSV file, open the File menu and select the 
Stop Exporting CSV option. 

The WSA5000 RTSA application stops writing the signal data to the CSV file.   

Administration 

 
In addition to viewing signal capture functionality, the WSA5000 Real Time Spectrum 
Analyzer application provides additional features that allow you to save and store one or 
more configuration profiles and to customize the configuration panel display.   

Saving Configuration Settings 

The WSA5000 RTSA application allows you to save current configuration settings in a file 
that you can reload at a later date. All saved settings files are stored on the PC that is 
hosting the WSA5000 RTSA application. 

You can view the contents of the *.config file in a text editor. 



1. To save the existing WSA5000 RTSA application settings, open the File menu 
and select the Save Settings option. 

The RTSA application opens a Windows Explorer window (PyRF  
Configuration File). 

2. Specify the name and path to store the configuration file. 

3. Click Save. 

The WSA5000 RTSA application saves the current configuration settings file (with 
.config extension) in the specified location.   

Loading Configuration Settings 

You can load WSA5000 RTSA application configuration settings from a saved 
configuration file. The file must exist on the PC  that is hosting the WSA5000 RTSA 
application. 

1. Open the File menu and select the Load Settings option. 

The application opens a Windows Explorer window, defaulting to the last location 
used for saving configuration settings, or saving recorded signal information.  
(Note you can move to another folder destination using the explorer window). 

2. Select the .config file you want to load, and click Open. 

The WSA5000 RTSA application loads the configuration settings from the file and 
updates the application accordingly.    

 

 

 

 

 

 

Viewing Device Information 

You can display information specific to the WSA5000 device you are using to  
capture signals. 

Note: The current date and time, as well as the software version of the WSA5000 RTSA 
application, are displayed in the top toolbar of the  window. 

1. Open the File menu, and select the Device Information entry from the drop 
drop-down menu. 

A dialog window opens showing the following information: 

 Connected to: Shows the source of the displayed signal.  
If the signal comes from a connected device, the name or IP address of the 
device is shown. If the signal comes from a recorded file, the source file 
(name and path) is shown. 

 Serial number: the serial number of the device that captured the signal. 

 Hardware version: the hardware version of the WSA5000 device. 

 Firmware version: the firmware version on the WSA5000 device. 



2. Click OK to close the window. 

  


