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Training Videos Available on our Website 

 

Whether you are a new user or an existing user, please view our training videos available on our website 

(link below). You will find they are very informative and will answer many questions and can show you 

how to get started quickly and efficiently. 

 

https://ezstamp.com/support/softpro-training-videos/

https://ezstamp.com/support/softpro-training-videos/
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About EzImage 
 
The About option in the EzImage Help menu will show a dialog window with some basic information 
about the current version of the application: 
 
The title bar will show the current version number and the latest build date of the application. As changes, 
additions, or corrections are made to EzImage, the information in the title bar will change accordingly 
based on the following: 
 

Minor changes that have very little impact on the operation of EzImage will simply be applied with a 
new revision date. The version number will not change. 

 
Moderate changes that have a noticeable impact, with possible data file changes (in addition to the 
program itself), will be reflected by a change in the minor build number of the version ID. This is the 
number that appears after the decimal point. 

 
Major changes that in effect result in a drastically different application, which may require a 
reinstallation of the software, will have a new major build number, which appears before the decimal 
point. The major build number represents the release version of EzImage. 

 
The about dialog image sample contains a semi-transparent link to our web site that you may click on for 
quick access. 
 
The Total Physical Memory and System Resources indicator provide information about the current 
memory status of your system. 
 
 
Top 
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Channel Adjustment 
 

 
 
A channel adjustment uses percentages of the red, green, and blue channels to generate new RGB 
values based on a simple process. The dropdown list allows you to select the red, green, or blue 
channels for the pixel colors of the original image. Once you select one of these channels, you will apply 
a percentage of that channel’s pixel intensity to each of the red, green, and blue channels in the adjusted 
image. 
 
Consider the default settings as an example, which results in no color adjustment: 
 
For the red channel, the values are 100% red, 0% green, and 0% blue. This means that 100% of the 
current red value for any pixel is added to the new red channel, 0% of the current red value is added to 
the new green channel, and 0% of the current red value is added to the new blue channel. Keep in mind 
that these colors are added for each adjustment channel. The final RGB value is the sum of each channel 
adjustment. 
 
If we have the following pixel color RGB value of (192,128,64), then the result of the default adjustment is: 
 
The new RGB channel values are automatically set to (0, 0, 0), or pure black 
 
New Pixel Color starts at (0, 0, 0) 
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Red 192 * 100% = 192 is added to the new red color 
Red 192 * 0% = 0 is added to the new green color 
Red 192 * 0% = 0 is added to the new blue color 
 
If you examine the default settings for the blue and green channels in the dropdown list, you will see a 
familiar pattern: 
 
Green 128 * 0% = 0 is added to the new red color 
Green 128 * 100% = 128 is added to the new green color 
Green 128 * 0% = 0 is added to the new blue color 
 
Blue 64 * 0% = 0 is added to the new red color 
Blue 64 * 0% = 0 is added to the new green color 
Blue 64 * 100% = 64 is added to the new blue color 
 
The result is that the colors don’t change. 

 
If you were to select the red channel from the dropdown list and adjust the blue slider to 50% and the 
green slider to 25%, then you would get the following: 
 
Red 192 * 100% = 192 is added to the new red channel (same as before) 
Red 192 * 25% = 48 is added to the new green channel 
Red 192 * 50% = 96 is added to the new blue channel 
 
Assuming you did not change the slider default values for the green and blue channels by selecting them 
from the dropdown list, the new RGB pixel color would be: 
 
192 + 0 + 0 = 192 
48 + 128 + 0 = 176 
96 + 0 + 64 = 160 
 
The new color will be (192, 176, 160) 
 
To summarize, each channel from the dropdown list determines what percentage of color from that 
channel is used to generate temporary levels of red, green, and blue which are added to the new red, 
green, and blue channels for the new color value. It is the total sum of these red, green, and blue values 
for each channel in the source color value that creates the final color value in the adjusted image. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
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Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Loading and Saving Settings 
Most adjustment operations in EzImage provide the ability to load and save settings using an adjustment 
file. The adjustment file is specific to each operation, and is identified by a unique file extension. These 
files are by default placed into the User folder of the application path. Adjustment files not only provide a 
convenient method by which to apply the same adjustments repeatedly to several images, but they are 
also used for: 
 

Color adjustments with the File Conversion tool. 
 

Color adjustments applied to printed thumbnail image sheets. 
 

Embedding in script files when writing script files outside of the recording process. 
 
For the channel adjustment process, the adjustment file extension is .CHA. 
 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Resetting Adjustment Values 
For operation windows that have a Reset button, you may use it to restore all settings to default values. 
 
Related topics: 
 
Levels Command 
Hue and Saturation 
Color Balance 
Channel Mixer 
 
 
Top 
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Window Arrangements 
 
The Window menu contains several options that are standard to Windows applications that open multiple 
windows at one time. 
 
Cascading Windows 
This will arrange the image windows from left to right, in a staggered overlapping diagonal pattern. 
 
Vertical and Horizontal Tiling 
These options will automatically change the size of the image windows to occupy the complete space of 
the main application window, without any overlap. 
 
Arrange Icons 
When you minimize an image window, a small “icon” representation will be placed at the bottom of the 

application window. You can drag this minimized window around the screen to any location you wish. The 
Arrange Icon option will simply reorder all minimized image windows so that they are in a non-overlapping 
sequence at the bottom of the screen. 
 
Choosing the Active Image Window 
The Window menu also contains options to selection which image window will be the active one for image 
processing operations. 
 
Up to 9 image windows will be available for direct access from the menu as shortcuts, identified in the 
Window menu by the description that appears in their title bars. 
 
If more than 9 image windows are open at one time, then you will need to use the More Windows option. 
This option will present a dialog with a list of all open image windows. You can scroll through this list to 
find an image, select it, and activate it. 
 
Related topics: 
 
Image Windows 
Setting Magnification Levels 
Fitting a Window to an Image 
Fitting an Image to a Window 
Image Information Overlays 
Window and Cross Hair Rulers 
Close vs. Close All 
Display and Dithering Quality 
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Average Filter 
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This filter works by averaging each pixel within a certain range of its neighboring pixels. As you increase 
the size of the pixel neighborhood, the image will become more blurred. Values range from 0 (no change) 
to 100 (maximum blur). 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
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closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Gaussian Blur 
Median Noise Reduction 
Motion Blur 
Sharpen and Blur 
Unsharp Mask 
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Brush Shape Editor 
 
The brush editor allows you to modify the mask pixels that define a brush in EzImage. A brush is simply a 
256 gray level image that can be up to 256 by 256 pixels in size. Each brush mask is independent in size 
and relationship to all other brushes in a brush file, although you should take advantage of the category-
based rows to organize the brushes. 
 
Monochromatic and Gray Level Files 
Indexed color images that contain a color palette will not be able to use the various gray shades of pixels 
in a brush mask. Since you may be working on both gray scale/RGB and indexed color images at the 
same time, it is necessary to provide you with both black and white and gray level brush files. As such, 
each of the painting tools will have two brush files assigned to it. Depending on what the current active 
image is that you are working on, the brush editor will only allow you to edit one of these two brush file 
formats. 
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Brush Shapes 
A brush shape type can be either a custom shape or one of several geometric shapes. Each shape type 
has an additional set of properties that can further alter its appearance. A custom shape indicates that the 
brush is stored as a simple mask of black and white (monochromatic brushes) or 256 levels of gray. 
Custom brushes can only be altered by replacing them with an image file or by using the Selection to 
Brush option in the application main menu. 
 
Brush Size 
The brush width and height only apply to non-custom brushes. They determine the basic width and height 
of the geometric shape before any rotations, gradients, or softness effects have been applied. Any of 
those adjustments will effect the actual pixel mask area, as indicated below the image preview window. A 
brush can be no smaller than 1 x 1 pixel and no larger than 256 x 256 pixels. 
 
Brush Softness 
The softness value only applies to anti-aliased brushes. By increasing the softness percentage, the edges 
of the brush will blur, allowing for a more natural brush stroke. Since the limit of a brush is 256 pixels 
square, the softening effect can cause very dark pixels in the edge of the brush shape to actually exceed 
the size limits. An indicator named *** EDGE PIXELS *** will appear if any brush data touches the 
extreme edges of the brush area. 
 
Brush Angle 
The angle value determines how to rotate a brush about its center point. The angle can be negative for a 
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counter-clockwise rotation. 
 
Constraints 
You can constrain the height of any shape to be a percentage of its width. Check this option and place 
the percentage amount in the text field below it. For example, a width percent of 50% will make the brush 
twice as wide as it is tall. 
 
Brush Outline Mode 
The outline value is used to create outline brushes, with a transparent center. An outline can range from 1 
pixel to any value that would preserve the original geometry of the shape. For example, if you increase 
the outline of a pentagon shape to the point where the interior transparent shape would no longer be a 
pentagon, the shape will become solid. An outline value of zero will always create a solid brush shape. 
Outlines can not be applied to concave-based triangles or star shapes. 
 
Brush Core Size 
A brush with varying levels of gray shades in its mask, especially ones with high softness values, will 
have a large percentage of dark pixels, which are barely, if at all visible in many cases. The core width 
and height are the values that define brush spacing based on the majority of the bright pixels in a brush. 
For example, a 64 x 64 circular brush with a softness of 65% will have an actual width/height of 135 
pixels, and a core size of 96x96 pixels. The brush editor will estimate the core size based on the pixel 
intensities around the center point. You can override these values before saving the brush. 
 
Brush Spacing 
Spacing determines the retouch distance when you apply color with a painting tool. It is a percentage of 
the core width and height, not the actual width and height. For example, a spacing of  500% applied to a 
brush with a core size of 80 x 80 pixels will result in the brush mask being applied every 400 pixels of 
travel distance on the image. For soft brushes, a spacing of 25% is usually a good value. For hard 
brushes, a value of 10% is a good choice. As you decrease the spacing on large brushes, the overall 
paint speed can decrease. 
 
Gradients 
A gray scale gradient can be applied to antialiased brushes only. You specify a starting shade of gray, an 
ending shade, and a gradient type. The gradient will have the effect of removing white levels from a 
brush. 
 
Actual Brush Pixel Size 
The size caption below the brush mask preview window indicates the actual width and height of the 
brush, based on any pixel with at least 1 level of gray. Since low levels of gray can be very hard to see in 
the preview window, this indicator gives you an idea of how large the brush mask area is for brushes with 
a high softness level. 
 
Brush Descriptions 
You can enter a description up to 64 characters for this brush. The name of this brush will appear in the 
brushes palette when it is selected. 
 
Brush Inversion 
This option does not alter a brush in any way. It simply creates a preview window that is a negative of the 
normal white on black image. This may be more preferable for viewing the brush mask. 
 
Antialiased Brushes 
The antialiased option is used to provide a natural smoothing effect to the edges of any brush. You can 
not apply an antialias option to monochromatic brushes (i.e. the Pencil tool brush file). Since antialiasing 
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and softness settings can impact the speed by which the mask preview image is updated, you can turn 
both off to set the initial brush shape properties, then enable them afterward. 
 
Loading and Saving Brush Masks 
By loading an image into a brush mask, you will replace the Custom brush mask with the file image. Any 
image can be loaded as a brush. The image will be resized to be no larger than the brush limit of 256 by 
256 pixels, while maintaining the original aspect ratio. The image will be converted to gray scale or black 
and white (for monochromatic brush files). Brushes can be saved as Windows bitmap (.BMP) format files 
by using the Save option (uncheck Invert before saving brushes). 
 
Shape Options 
Almost all shapes will have one or more options that define additional geometric properties, such as a 
vertical edge distribution for a pentagon. When you select a shape category, an options window specific 
to that shape will appear in the editor. To obtain more help on what each of those shape properties 
affects, right click on the labels in that window. 
 
Related Topics: 
 
Brush File Properties 
Brush List Editor 
The Brushes Palette 
 

 
Top 
 
 

 
 
 

Blend Modes 
 
Blend modes are used by various tools in EzImage to combine the pixel colors of: 
 

An image and a floating selection 
 

An image and an RGB color value 
 
For the second option, the color source can be a painting tool, another image, or from the Fill Image 
operation. 
 
The filter dialog provides date, size, and pattern-based filters that can be used to restrict the list of images 
that will be converted. 
 
Blend modes do not work on indexed-color images. In addition, the hue, saturation, and luminosity modes 
do not work with gray scale images. 
 
For the purposes of explaining blend modes, assume for any pixel of color in the source image (referred 
to as Color A), a blending will take place with the pixel color from another image or painting tool (referred 
to as Color B). Example images will be used to demonstrate how the blend works when applied between 
a floating image and source image of equal size. All examples used 100% opacity, since a lesser opacity 
affects the blend mode results. 
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For the mathematically inclined, the formulas are given using A and B as the color reference pixels. Each 
color reference is an RGB color triplet with 256 levels of red, green, and blue. 
 
Source Image 
 

 
 
Overlay Image 
 

 
 

Normal Blend Mode 
The overlay image completely replaces the source image (B will replace A).This is under the assumption 
 
New Color = B 
 
Multiply 
The colors A and B are simply multiplied together for each of the red, green, and blue channels. This 
generally results in darker images. White blends do not change. If A or B are black, then the resulting 
color will be black. 
 
New Color = A * B 
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Screen 
This is opposite to multiply mode. Each color is inverted, multiplied together, then inverted once more. 
The result is an image that is generally brighter than the original. 
 
New Color = 255 – (255-A) * (255-B) 
 

 
 
Darken 
The two colors are compared, and the smaller one is taken. Since black = 0 and white = 255 (assuming 
all channels equal), taking the smaller color will darken the image. 
 
New Color = Smaller of A and B 
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Lighten 
The two colors are compared, and the larger one is taken. 
 
New Color = Larger of A and B 
 

 
 
Difference 
One color is subtracted from another, and the result is the absolute value of the difference that results. 
This gives the new color as the distance between the A and B color values. 
 
New Color = |A-B| 
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Negate 
This is the opposite mode to difference, in which the result is obtained by inverting the difference between 
the two colors, and then applying another inversion to this. 
 
New Color = 255 - |255-A-B| 
 

 
 
Exclusion 
This is the average color of Difference and Negate modes applied separately. 
 
New Color = Average of (Difference (A and B), Negate (A and B)) 
 

 
 
Overlay 
This is a combination of Screen and Multiply modes. 
 
New Color = A * B / 128 if A < 128 or 255 – ((255-A) * (255-B) / 128) if A >= 128 
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Hard Light 
This is an alternate combination of Screen and Multiply modes. 
 
New Color = A * B / 128 if A < 128 or 255 – ((255-B) * (255-A) / 128) if A >= 128 

 

 
 
Soft Light 
Darkens or lightens the colors, depending on the blend color. If the blend color lighter than 50% gray, the 
image is lightened. If the blend color is darker than 50% gray, the image is darkened. Applying a pure 
black or pure white color will darken or lighten an image without producing pure black or white. 
 
New Color = C + A * (255-(255-A)*(255-B) / 256)-C) / 256 where C = A * B / 256 
 



EzImage Reference – Version 1.05 

 

 Page 24 

 

 
 
Color Dodge 
Brightens the base color using the blend color. 
 
New Color = 255 if B = 255, else New color = Minimum (255, A * 256 / (255-B)) 
 

 
 
Color Burn 
Darkens the base color using the blend color. 
 
New Color = 0 if B = 0, else New color = Maximum (0, 255 – (((255-A) * 256) / B) 
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Hue 
New Color = Luminance and saturation of A and the hue of the B.  
 

 
 
Saturation 
New Color = Luminance and hue of A and the saturation of B.  
 

 
 
Color 
New Color = Luminance of A and the hue/saturation of B.  
 

 
 
Luminosity 
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New Color = Hue and saturation of A and luminance of B. 
 

 
 
Top 
 
 

 
 
 

Adding a Border 
 

 
 
This method allows for both cropping and expansion of an image, based on the new image dimensions. 
Pixel content is not altered in any way, since the method does not resize the image by stretching or 
shrinking. 
 

If you increase the width or height dimension, then a border will be added to the image, using the 
current background color to fill in the new areas. 

 
If you decrease the width or height, then the image will be cropped. 

 
Setting the Border Anchor Point 
The directional arrow pad determines the anchor point for the border addition or cropping. With the 
anchor set in the middle, the expansion or crop will apply equally to all 4 edges. When you change the 
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anchor point to a corner or edge position, the anchor spot (indicated by the solid white recessed button) 
will cause that corner or edge to be locked. The expansion or crop will be applied to the opposite corner 
or edge of the image. 
 
Setting Width and Height 
You can enter a new width and/or height in pixels, inches, cm., mm., or a percentage of the current image 
size. If the new width or height is smaller than the original image size, a cropping operation will take 
place. If the new image dimensions are larger, a border will be added to the image to make up the extra 
space added, using the current background color. If you wish to only crop or expand one dimension, 
leave the other one at the default value. 
 
The labels at the bottom of the dialog window show the image size before and after the expansion/crop. 
The title bar will indicate the pixel dimensions after the method has been applied. 
 
Original Image: 
 

 
 
After Border Expansion Applied (Using the above settings): 
 

 
 
 
Related topics: 
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Rotating Images 
Shearing Images 
Flipping Images 
Resizing Images 
Cropping Images 
Auto Trim Tool 
Edge Deskew Tool 
 
 
Top 
 
 

 
 
 

Brush File Properties 
 
Brush File Format 
 

Each brush file is arranged by row and column, 11 brushes per row, and up to 9 rows per file. Each row 
can have a named category and ID character code. The ID code is a single character letter or digit that 
will appear as a shorthand identifier in the brush palette beneath the brush image sample. 
 

 
 
In the brush palette example shown above, the category ID code is “S” for Soft Brushes. The categories 

can be selected by clicking on the Category popup menu arrow. 
 



EzImage Reference – Version 1.05 

 

 Page 29 

 

 
 
Each brush category can have a description field up to 31 characters in length. This information is 
embedded in the brush file to identify each row of 11 brushes. Although the intent of the brush file format 
was to categorize brushes by shape and style, you are free to place brushes in the file in any order you 
wish, with or without categorized descriptions. 
 
If you define a brush for a row, at least one character must be provided for a brush row description, so 
that its name will appear in the category popup menu of the brush palette. 
 
Not all brush rows have to contain the same number of brushes. You can leave entire categories blank, 
and have a different number of brushes for each category row. 
 
Brush file properties are purely description in nature. Changing the properties for the file in no way affects 
the individual brushes contained within it. 
 
Related Topics: 
 
Brush List Editor 
Brush Shape Editor 
The Brushes Palette 
 

 
Top 
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Resetting Brushes 
 
This option is available from the menu in the Brush List Editor. It is used to reset the spacing and/or the 
brush mask data for one or more brush files. 
 

 
 
Resetting Spacing 
All brushes are defined with a preferred default spacing, put in placed when the brush was created. Any 
brush can have the spacing changed simply by using the spacing option in the brush palette. If you check 
the Spacing Only option, the spacing of brushes will be reset back to the value they were originally 
created with, without affecting the brush mask information. 
 
Resetting Brushes 
The Brushes and Spacing option will clear all custom brush formats and replace the brush file with the 
default one that was provided with the EzImage installation package. The current brush file will not be 
deleted, and can be reassigned using the Load Brush File option in the brush list editor 
 
Resetting Current or All Brush Files 
Check the Current Tool option to only reset the current painting tool. Each of the painting tools in 
EzImage has two brush files, one for indexed color images and one for gray scale and RGB images. 
When you reset a brush file, you are applying the action to the indexed or RGB/gray brush file, not both. 
 
The All Brush Tools option will reset all brush files for all painting tools back to the original EzImage 
default files that were provided with the installation package.  
 
Related Topics: 
 
Brush File Properties 
Brush Shape Editor 
Brush List Editor 
The Brushes Palette 
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Brush Gradient Mode 
 
This option can be found in the options for the Line, Pencil, and Paint Brush painting tools next to the 
Opacity setting: 
 

 
 
The gradient feature for these three painting tools allow you to set color and transparency fades using 
various methods: 
 

 
 
Gradient Groups 
The line, pencil, and paint brush tools all share a common gradient option. You can define a gradient 
group, which is a series of gradients (from 1 to 8), each with their own independent properties. The brush 
painting will cycle from each gradient in the group as the prior one finishes with its number of painting 
steps. The Number of Gradients option sets the total number in the group. 
 
One Pass Mode 
One pass mode will cause the gradient to paint only the number of steps defined for it. If there are more 
gradients in the group, then the next one will follow when the current one’s step total has been reached. 
 
One Pass, Start to End to Start 
In this mode, the gradient will paint twice the number of steps, from the starting color to the ending color, 
then back to the starting color. 
 
Loop, Start to End 
This is a looping mode, whereby the gradient will paint from the start color to the end color, then loop 
back around to the starting color, continuously. 
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Loop, Start to End to Start 
This looping mode will paint from start color to end color to start color, over and over. 
 
Selecting a Gradient 
Use the dropdown list to select one of eight gradients for the group. You need to define as many 
gradients as you have set in the gradient count. As you change to a new gradient, you will see new 
property values for the start and end colors, the gradient type, and the number of steps. 
 
Transparency Fade 
The transparency fade is independent of the color gradient, and can be used by itself, or in combination 
with the color cycling. A fade can begin transparent and gradually migrate to the ending color, or begin 
with full opacity at the starting color and fade away to transparent. 
 
Gradient Type 
The gradient type determines how to change the colors when transitioning from the start to end color. 
RGB spreads and HSV spreads are quite different and will yield completely different gradients. The 
transparent gradient simply inserts silence (no painting) for the duration of its steps. This allows you to 
create dashed and dotted painting effects by inserting transparency between normal HSV/RGB gradients 
in the group. 
 
Gradient Steps 
You can enter from 2 to 999 steps for each gradient in the group. Each gradient color shift step is equal to 
one retouch of the painting tool on the image. So brush spacing will have an impact on the gradient color 
changes as well. 
 
Start and End Colors 
Each gradient is defined by a start and end color. The gradient will use an RGB or HSV transition from 
the start color to the end color and the number of steps you assign for it. If you are using a transparent 
gradient, no color will appear for the corresponding number of paint steps. Use the BG and FG buttons to 
assign the current foreground/background colors. Right click on either color swatch to set gray level 
gradient colors. 
 
Saving and Loading Gradients 
You can save the brush gradient properties to a file that can be recalled at any time using the load option. 
Brush gradients by default are saved in the User folder of the EzImage installation path with an extension 
of .BGR. 
 
Disabling Gradients 
Click on the Disable button to remove the gradient effect from the pencil, paint brush, and line tools. The 
gradient properties will not be affected by this action. Brush gradients will always be disabled when you 
first start the application, and remain in effect until they are disabled. Clicking on OK will apply the current 
gradient group to the painting tools. 
 
Top 
 
 

 
 
 

Brightness and Contrast 
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This method allows you to adjust the brightness and contrast for an image. Although the Levels method 
provides a more precise adjustment, sometimes a simple brightness or contrast change works with 
images, especially gray scale images or scanned documents where you are trying to eliminate 
background noise. 
 
Brightness and contrast vary from –100 to +100 percent, in .1 percent increments. Values to the left of the 
midpoint on each slider will decrease and values to the right will increase the brightness or contrast. 
 
Check the H-contrast option to use a histogram-based method of setting the contrast. It is slower yet can 
produce better results over the standard contrast method. 
  
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 



EzImage Reference – Version 1.05 

 

 Page 34 

 

Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Levels 
Hue and Saturation 
Color Balance 
Channel Mixer 
Channel Adjustment 
Equalization 
Image Inversion 
Stretch Intensity 
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Brush List Editor 
 
The brush list editor provides a simple grid arrangement of the rows (categories) and columns (brush 
types) in a brush file. 
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Regardless of the number of brushes in a file, the grid will always contain 9 rows of 11 brushes per row. 
Where a brush space in grid is shown without an image, it will define an empty brush position where you 
can create a brush. 
 
Adding and Removing Brush Files 
Choose the New menu option to create a brush file with a name of your choice. Do not include any path 
name or file extension, as these will be added for you. Brushes must always reside in the Brushes folder 
of the EzImage installation path. 
 
The type of brush file created is based on the current active image. If it is an indexed color image, the 
brush file will be monochromatic (black and white). For all other images, the brush file will be a 256 gray 
level format (pencil tool brushes are always black and white). You can’t create a brush file with a name 
that already exists. You can not use any brush file names that are the same as those found in 
Brushes\Default. 
 
There is no option to remove brush files from within the editor. You must manually remove brush files 
from the Brushes folder, and ensure that you don’t remove a brush file that may still be in use by any of 
the painting tools. 
 
Note that the brush file that you are editing is always shown in the title bar of the editor window.  
 
Default Brush Files 
The following are the default brush files for gray-level format: 
 
blur.bru    Blur Tool 
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burn.bru    Burn Tool 

clone.bru   Image Clone Tool 

dodge.bru   Dodge Tool 

eraser.bru  Eraser Tool 

line.bru    Line Tool 

pbrush.bru  Paint Brush Tool 

pencil.bru  Pencil Tool 

sharp.bru   Sharpen Tool 

sponge.bru  Sponge Tool 

 
There is only one common brush file by default for all monochromatic brushes: 
 
common.bru 

 
Blank Brush File Templates 
The following are provided as templates for creating new brush files. 
 
b_gray.bru  Gray-level brush file template 

b_mono.bru  Monochromatic brush file template 

 
Replacing the Current Brush File 
Use the Load menu option to replace a brush file for the current painting tool only. The current painting 
tool is indicated by the caption at the top of the brush palette. There are two brush files per painting tool, 
one for indexed color images, and the other for RGB and gray scale images.  
 
Note that brush files can be shared between painting tools (i.e. the common.bru file for indexed images 
is the default for all painting tools), so it is allowable to assign the same brush file to multiple painting 
tools. 
 
Creating a Brush File Copy 
Use the Save As menu option to make a copy of the current brush file under a new name. The new brush 
file will replace the old one (the original brush file will remain in the Brushes folder). 
 

Resetting a Brush File 
Use the Reset menu option to restore either the brush spacing and/or brush files. Resetting a brush file 
will replace the current file with a copy of the original file that was provided with the EzImage package. 
You will not lose the current brush file - it will simply be left in the Brushes folder without an assignment 
to the current painting tool. 
 
Changing Brush File Properties 
Use the Properties menu option to assign or change a description that identifies the brush file, and to 
change the category ID characters or descriptions for each row of brushes in the file. 
 
Saving Changes 
Use the Save menu option to write all modifications to the current brush file and select the current 
highlighted brush as the new active one. While in the brush selection editor or the brush shape editor, all 
changes are saved in a temporary file until you commit them with the save option. 
 
Changing the Active Brush 
Use the Select and Exit menu option to select the brush that is currently highlighted as the new active 
brush for the current painting tool. The brush selector window will then be closed. You can also double 
click on any brush to select it. 
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Editing a Brush Shape 
The Edit menu option will place the current highlighted brush in to the brush editor, which allows you to 
create or modify brushes using geometric shapes, styles, and gradients. You can also use the editor to 
load a brush from any image file, or save any brush to a Windows bitmap file. 
 
Brush Copy and Paste 
Use the copy and paste options to duplicate one or more brushes to blank positions in the brush file. 
Simply select one or more brushes (use Ctrl or Shift to create multiple selections) then choose Copy 
from the menu. Highlight a blank brush file position, which will be used as the insertion point for the paste. 
Choose Paste from the menu, and all brushes will be copied one after another until the brush file is 
populated. Only blank positions will be filled.  
 
Deleting Brushes 
Use the Delete and Clear menu options to remove brush masks from the file. The clear option will erase 
all brushes except for the first one, whereas the delete option only removes selected brushes. Use the 
Ctrl and Shift keys to create multiple brush selections. The first brush in any file can not be altered or 
deleted. It is always a 1 x 1 pure white pixel brush. 
 
Related Topics: 
 
Brush File Properties 
Brush Shape Editor 
The Brushes Palette 
 

 
Top 
 
 

 
 
 

Batch File Scanning 
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The batch scan option is used to acquire multiple images at one time from your scanning source. The 
images are automatically saved using sequentially numbered files, in a format of your choice. The 
scanning interface will remain active for as long as you wish to save files to disk. It is recommended that 
you monitor the free disk space as you acquire images, as it is very easy to fill up a hard disk with just a 
handful of very large scans. 
 
Output Path 
The output path must be a fully qualified path name with a drive letter or a UNC network path name 

(\\sharename\path name). If the output path does not exist when you begin the scan operation, it will 

be created for you. By default, the output path is the Scans folder of the application installation path. 
 
File Name Prefix 
The file name prefix will appear before the sequence number, which is a 4-digit number that starts at 
0001, and increases by 1 for each scanned image. The extension of the file name is determined by the 
output file format you choose. The prefix will begin at 1 when you first start the application and count 
upwards until you close the application. In this way, you can batch scan some images, close the dialog 
window, then go back and resume without worrying about the sequence number changing back to 1. 
Note: If a file already exists with the same name in the target path, the sequence number will 
automatically be bumped to skip past that file. If the counter reaches 10,000, the sequence number will 
switch to a 5-digit number. 
 
Output Format 
You can save scanned images to one of the following file formats: 
 

TIFF 

BMP 

JPEG 

FPX 

PCX 

PNG 

TGA 

 
If there are additional file save parameters for a particular format, use the Options button to set them 
before you begin scanning. For JPEG images, you may wish to use the Compression Tuning tool to 
ensure you are getting the quality and file compression you are looking for. 
 
Free Disk Space 
This indicates the amount of free disk space on the target path prior to scanning the first image. This 
indicator is updated after each scan.  
 
Scanning Images 
Click the Scan button to begin the batch operation. The scanning interface window assigned by your 
scanner driver will be used to acquire the images and send them back to EzImage, where they will be 
saved to file. EzImage does not support 16-bit gray level or 48/64-bit RGB color images, so you will not 
be able to scan images with that level of resolution. 
 
Related topics: 
 
Selecting a Scanner 
Scanning an Image 
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Image File Browsing 
 
The image browsing options are all grouped under the application Browse menu. There are several 
methods by which you can search for and/or organize image files: 
 

The preview browser is a convenient file/folder window with partial and full-screen image display 
capabilities. 

 
The thumbnail browser uses a database system to store smaller representations of your image files, 
grouped by folder path. 

 
The slide show system provides a method to display images one after another, using either time 
delays or with a manual step-by-step mode. 

 
The image list system organizes files as by groups, which can be stored in a file and used as an 
alternate browsing method to the common preview browser. 

 
Path lists are similar to image lists, but do not contain any files. 

 
Some of these browsing methods interact with each other. For example, you can build slideshow scripts 
from the image list editor, or add files to an image list using the thumbnail browser. The image list and 
path list systems were specifically designed as file sources for the File Conversion tool. 
 
Related topics: 
 
Opening Image Files 
Image Preview Browser 
Image Lists 
Path Lists 
Thumbnail Browser 
Slide Show System 
Image File Properties 
File Operations 
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Opening Image Files 
 
You can open image files using many methods in EzImage including a common open file dialog window, 
the image preview browser, image list editor, path list editor, and thumbnail browsers. This topic 
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considers the first option, the common open file dialog. 
 

 
 
This dialog window is controlled and displayed by the version of Windows that you are running. EzImage 
defines the default path for this window, along with a list of available file formats that you can choose 
from. 
 
You can open up to 50 images at one time with this option, although the dialog window itself may not be 
able to accommodate 50 file names depending on the total number of characters. 
 
Note that the trial version of EzImage will only allow you to open one image at a time. 
 
If you wish to see previews of images before opening them, you can set an option in the general 
preferences to associate the File->Open menu option with the image preview browser. This will allow you 
to see image samples and some basic information such as size and bit depth. 
 
Related topics: 
 
Supported File Formats 
 
Image Preview Browser 
Image Lists 
Path Lists 
Thumbnail Browser 
Slide Show System 
Image File Properties 
File Operations 
 
 
Top 
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Image File Properties 
 

 
 
This window is displayed for any browser/editor in EzImage that has a Properties option for selected 
image files. 
 
The properties dialog contains some basic information about one image: 
 

Path and file name 
The type of compression if applicable 
The size of the image file as stored on disk 
The size of the image file in terms of memory space it would require 
The bit depth of the image 
Width and height 
Number of colors 
The print resolution, in dots per inch, for both horizontal and vertical dimensions 
The number of pages in the file if it contains multiple images 

 
If you have selected more than one image, you wills see directional arrow buttons at the bottom of the 
window for navigating between images. You can also use the Page Up, Page Down, Home, and End 
keys as shortcuts. 
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A comment area is provided for images containing additional information or embedded text identification. 
Not all image formats support this type of information. 
 
Click on Preview to enable a small image sample window in the comment area. This image sample is 
displayed using the same quality setting as the mini-preview settings applied to the thumbnail browser. 
 
Click on Units to change the unit of measurement for the dialog window. This will affect the Width and 
Height values. 
 
Bookmarks 
Certain browsers/editors such as the image list editor allow you to use bookmarks in the properties 
dialog. If the bookmark system is available, you will see additional buttons at the bottom of the window: 
 

 
 
A marked image will be indicated by the red “M” label, appearing between the 4 buttons that make up the 
marking controls. Use the “++” and “--“ buttons to mark or unmark all images at one time. The “+” and “-
“ buttons will mark and unmark the current image only. 
 
Once you close the properties window, all marked images will be used to generate a new image 
selection. 
 
Related topics: 
 
Opening Image Files 
Image Preview Browser 
Image Lists 
Path Lists 
Thumbnail Browser 
Slide Show System 
File Operations 
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Alpha Channels 
 
A 32-bit RGB image (RGBA) appears like a normal 24-bit RGB image at first glance. The only difference 
is that the RGBA image contains a 256-level gray scale alpha channel. In EzImage, this channel is 
generally not affected by most image-processing operations, and as such can be used as temporary work 
area. 
 
Many options in the Floater and Select menus rely on the alpha channel to perform effects or mask-
related processes. To work with an alpha channel, you can use the Image->Channels->View Alpha 
menu option. If an image is in 24-bit RGB format, you can convert it to RGBA format, which results in a 
blank (all black pixels) alpha channel. 
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Consider the following simple example, which uses an alpha channel to create a floater with text and a 
basic shape, rendered using a portion of an image. 
 
Source Image: 
 

 
 
Step 1: Convert the image to RGBA format. 
Step 2: View the alpha channel. 
Step 3: Drop a 32-point star shape and some text onto the alpha channel 
 
Alpha Channel: 
 

 
 
Step 4: Choose Image->Channels->View All from the menu. 
Step 5: Choose Floater->Create from Alpha from the menu. 
Step 6: Choose Floater->Render Floater from the menu using the Image source option. 
Step 7: Convert the image back to RGB format, since we no longer need the alpha channel. 
 
The result is a floating image created from the source image using the alpha channel as a mask. 
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Floating Image Created from Alpha Channel: 
 

 
 
Related topics: 
 
Creating Selections from Alpha Channels 
Creating Floaters from Alpha Channels 
Floater Masks and Alpha Channels 
Alpha Blending 
 
Indexed Color Mode 
RGB Color Mode 
Gray Scale Mode 
Halftone Conversion 
Threshold Conversion 
Channel Separations 
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Image Capture Tool 
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This tool allows you to capture all or part of any visible window, object, or area that is currently within the 
available screen display area. The process of capturing to an image is fairly simple: 
 

Choose a capture type 
Define the hotkey you wish to use for capturing 
Set some additional capture options (optional) 
Start a capture operation 
Use the hotkey to trigger the capture process 

 
The captured image will appear in a new window in the EzImage application. While a capture operation is 
in progress, all floating palettes will be disabled, along with the main menu. You basically are working 
within the capture environment of EzImage exclusively, where no other image processing operations are 
allowed. To cancel the capture mode, choose the Cancel option from the menu in EzImage. 
 
Capture Types 
 

Object: A button, checkbox, toolbar, or any other window-based control 
Window: The window under the mouse cursor 
Screen: The entire screen display 
Area: Drag-select a rectangular area of the screen display 
Wallpaper: Any active Windows wallpaper in use 
Active Client: The complete set of windows for the active application 
Active Window: The window of the application that has keyboard and mouse input focus 
Menu: A menu that is currently being displayed 
Mouse Cursor: The current mouse cursor 

 
Defining a Hotkey 
You can assign any key combination, even if it is already assigned by an application that currently has 
input focus for the keyboard (i.e. it will override any menu shortcut in a window that has a menu with the 
same shortcut as the hotkey). Note that some key combinations may not be allowed with certain 
installations and/or versions of Windows. If you receive an error message about an invalid hot key, 
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choose a different shortcut. 
 
Time Delay 
The delay will cause a brief pause before the actual image capture will be sent to EzImage. The delay 
value is in milliseconds (1000 = 1 second). 
 
Border Width 
For the object capture method, this is the thickness of the border that highlights the current object under 
the mouse cursor before you click to begin a capture. 
 
Show Cross Hair Lines 
For area captures, enable this option to display cross hairs lines at the rectangle corner points. 
 
Show Capture Area Size 
For area captures, enable these options to show size and position information as small tooltip- 
type labels. 
 
Size/Position Text/Background Colors 
For area captures, these colors define the text and background colors for the size and position 
information indicators. 
 
Captured Cursor Transparent Color 
For cursor captures, this is the color that will be assigned for the transparent part of the cursor. 
 
Reshow EzImage after Each Capture 
Check this option to bring the EzImage main window into view after each successful capture. With this 
option unchecked, the application will remain minimized (the window capture options will always bring the 
EzImage main window back into focus after each capture regardless of this setting). 
 
Starting, Restoring and Canceling 
Click on Start Capture to begin. When you start an image capture, EzImage will be minimized to the 
Windows taskbar. In addition, all active palettes and the menu system are temporarily shut down while 
the capture mode is in effect. To cancel the image capture mode, you must choose the Cancel option 
from the single item in the main menu. 
 
To cancel an area or object capture, you can press the Escape key. 
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Clipboard Operations: Cut, Copy, and Paste 
 
EzImage uses the Windows clipboard to store and retrieve image information in two formats: 
 

Windows Device Independent Bitmaps (DIB): These images use a generic format that most 
applications can read, and therefore is ideal when transferring images between applications. 

 
Floater Images: This format is specific to EzImage and therefore can’t be accessed by other 
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applications. A floater contains a mask pixel layer, which is either black and white or gray scale. The 
mask layer defines the non-transparent areas of a floater. The image layer contains the pixels that 
make up the image itself. For text and shape-based floaters, the image layer is absent.  

 
The Cut, Copy, and Paste methods in the Edit menu are shared for both DIB and floater format images.  
 
Copying Images 
The following variations apply to the Edit->Copy method: 
 

If a floater is active in an image, it will be placed in the clipboard and remain in the image. The 
clipboard will contain an image in floater format. 

 
If a region selection is active, the pixels that define the region will be placed a DIB format image in the 
clipboard. The size of the image is equal to the rectangular bounding box of the region. If the region is 
non-rectangular the remaining areas that are not part of the region are filled with the current 
background color. 

 
If a region and floater are active in an image, the floater takes priority, since the region is currently 
hidden from view. 

 
If a floater and region are both absent, the entire image is placed in DIB format in the clipboard. 

 
Cutting Images 
If you choose the Edit->Cut from the menu, the image information stored in the clipboard remains the 
same as that defined for copying. For the original source image, the following will take place: 
 

If a floater is present, it will be placed in the clipboard and be removed from the source image. The 
position of the floater is retained in the clipboard along with a tag that identifies the owner. The tag 
and position are used to restore a floater from the clipboard at the same position it existed where it 
was removed. 

 
If a region is present, the pixels that defined it will be replaced with the current background color. 

 
If the image does not have a region or floater, the cut method will be ignored. 

 
Pasting Images 
The Edit->Paste method generates a floater in the current image. The type of floater generated depends 
on the clipboard contents. For DIB format images, the floater will always be a rectangle with no mask 
layer. DIB-based floaters can not be transformed using operations such as resize and rotate. For floater-
based images in the clipboard, the floater will be pasted with a mask layer and optionally an image-color 
layer (text, alpha channel, and shape floaters have no image color layer). 
 
When both DIB and floater formats exist in the clipboard, EzImage will display a dialog window allowing 
you to choose which format to paste. 
 
When a floater is pasted from the clipboard, its position is determined based on the original source of the 
image. If the image is in floater format and was copied into the clipboard from the same image window, 
then it will be pasted in the position where it was originally located. Otherwise the image is pasted so that 
it will be centered within the image window. 
 
Emptying the Clipboard 
Choose Edit->Empty Clipboard to clear the DIB format image, the floater format image, or both from the 
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clipboard. If only one format is present, you will simply be prompted to clear the clipboard contents. If both 
formats are present, you be asked to choose which one to remove. 
 
Using the New Image Method 
When a DIB format image exists in the clipboard, the File->New method will detect this and make the 
Clipboard source the default for a new image. When you choose this source and leave the Fill type as 
Clipboard Image, the new image window will be set to the size of the image in the clipboard and will 
automatically be pasted with the image data when the window is created. Floater format images in the 
clipboard are recognized for size and bitmap depth, but the image data will not automatically be pasted. 
  
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Temporary Images and Undo 
Filling and Images 
Clearing Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
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Clearing an Image 
 
There are two options available for clearing an image, both of which can be found in the Edit menu. 
 
The Edit->Clear method applies only to region selections. All pixels in the region will be cleared with the 
current background color. If you are working with indexed color images and the background color is not 
available in the color palette for the image, the closest available color will be used. You can’t use the 
Clear method when a floating image is active. 
 
The Edit->Clear All method erases the entire image area using the current background color. You can 
use this method with an active floater. The floater itself is not affected. 
 
You can use the Edit->Fill method to fill floaters, regions, or the entire image with a color, pattern, or 
gradient. 
 
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 



EzImage Reference – Version 1.05 

 

 Page 49 

 

Filling and Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
 

 
Top 
 
 

 
 
 

Close vs. Close All 
 
The Window menu has two options named Close All and Close All (No Save). These options are used 
to close all of the open window images at one time. 
 
Closing only the active image window can be done in any of the following ways: 
 

Choose Close from the File menu. 
 

Click on the close window icon (X) in the upper right corner of the active image window. 
 

Click on the EzImage icon in the upper left corner of the title bar and choose Close from the popup 
menu. 

 
The Close All option will check each window before closing to see if any image modifications have been 
made. If any image has been altered, you will have the option to save changes before the image window 
is closed, or cancel the close process and leave the remaining image windows open. 
 
The Close All (No Save) option will close every image window without prompting to save changes. Any 
modifications or unsaved image windows will be lost. This option is convenient for closing multiple images 
created by the Icon/Cursor Import or Selection Separation tools. 
 
Related topics: 
 
Image Windows 
Setting Magnification Levels 
Window Arrangements 
Fitting a Window to an Image 
Fitting an Image to a Window 
Image Information Overlays 
Window and Cross Hair Rulers 
Display and Dithering Quality 
 
 
Top 
 
 

 
 
 

Color Balance 
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The color balance method works by shifting colors towards one of six primary end points. Each color end 
point is grouped as a pair, as they oppose each other in the color spectrum. As you add more red to the 
image, you subtract cyan. A similar change takes place for the other 2 color pairs. The shift value is a 
percentage from –100 to +100. 
 
Color balance adjustments are applied to highlights, midtones, and shadows separately. There is one set 
of values for each of the three intensity types. 
 
Check the Keep Luminosity option to preserve overall tonal balance in RGB images, at the added cost 
of processing time. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
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on the click point. 
 

You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Loading and Saving Settings 
Most adjustment operations in EzImage provide the ability to load and save settings using an adjustment 
file. The adjustment file is specific to each operation, and is identified by a unique file extension. These 
files are by default placed into the User folder of the application path. Adjustment files not only provide a 
convenient method by which to apply the same adjustments repeatedly to several images, but they are 
also used for: 
 

Color adjustments with the File Conversion tool. 
 

Color adjustments applied to printed thumbnail image sheets. 
 

Embedding in script files when writing script files outside of the recording process. 
 
For the Color Balance adjustment process, the adjustment file extension is .CBA. 
 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Resetting Adjustment Values 
For operation windows that have a Reset button, you may use it to restore all settings to default values. 
 
Related topics: 
 
Levels 
Brightness and Contrast 
Hue and Saturation 
Channel Mixer 
Channel Adjustment 
Equalization 
Image Inversion 
Stretch Intensity 
 

 
Top 
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Image Comparison Tool 
 

 
 
This tool provides a simple method by which to compare one image with another. You will initially load 
one image, which is designated the background image. You will load a second image over top of this, 
which will be designated as the foreground image. The background image will not move, while the 
foreground image can be moved to any position relative to the background. An opacity level is used to 
allows all or part of the background image to appear. The opacity level allows the foreground image to be 
semi-transparent. 
 
Although this type of comparison operation can be accomplished with a floating image selection in a 
regular image window, the comparison tool offers several advantages: 
 

Color and distance measurements tools provide details on both images at the same time. 
 

The opacity setting has 255 levels for more variation in the transparency. 
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Both the foreground and background images can be obtained from files sources, active image 
windows, or the windows clipboard. 

 
The references for comparison maintain path and file name history, so you can easily keep track of 
the image files for both the background and foreground. 

 
All of the basic measurement, selection, and transformation tools are provided in a convenient 
command button cluster. 

 

  Loading Images (Shortcuts: F5 and F6) 
 
Click on the load foreground or background buttons to choose a new image for the comparison tool. 
Images do not have to be the same size or color resolution. All measurement units that are not pixels 
reference the DPI of the background image, not the foreground image. If the DPI values of the foreground 
and background images do not match, the measurement information may not reliable. You can use the 
Resize option to match the DPI values of the foreground and background images if needed. 
 

 
 
The load image dialog provides 3 sources for an image: files, image windows, and the Windows 
clipboard. For image files, you may use any three methods: 
 

Click on Load to open an image using a common file open dialog window. 
 

Click on Browse to use the EzImage preview browser. 
 

Click on Thumbs to use the thumbnail database browser. 
 
All three of these methods retain the prior file and path references, so that you will always know what the 
prior image file and/or folder was that was last accessed. The foreground and background references are 
separate from each other, allowing you to keep track of images from two separate path sources at the 
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time. 
 
Use the Recent Files dropdown list to access images that were recently opened. 
 
The File Name filed will contain the image path and file reference after you have chosen an image using 
Load, Browse, or Thumbs. You can manually enter a file and path name in this field if you wish. This field 
retains its reference between dialog calls, so that the next time you attempt to load a background or 
foreground image, the prior file name reference will automatically be placed. 
 
The Clipboard option is only available if there is valid device independent bitmap (DIB) currently in the 
clipboard. 
 
For Active Windows, choose one from the dropdown list, and it will be used for comparison rather than a 
disk file. 
 
Once you have loaded an image, the thumbnail sample window will contain preview of the image. The top 
sample window refers to the background and the bottom sample window is for the foreground image. 
 

  Making Adjustments 
 
These buttons allow you to make some basic image adjustments to the background or foreground 
images. Note that these adjustments have no undo capability (inversion and channel separations 
excepted). You will have to reload the image to undo changes. When you click on either button, a popup 
menu will appear with the following options: 
 

 
 
The shortcut keys shown in the sample are for the background image. For the foreground image, you 
must also hold down the SHIFT key. Not shown on this menu sample are the shortcut keys for separate 
channels, which are: 
 
View All Channels: Ctrl + 1 
View Red Channel: Ctrl + 2 
View Green Channel: Ctrl + 3 
View Blue Channel: Ctrl + 4 
 
(Hold down SHIFT to view separate channels for the foreground image) 
 
Inversion and Color Matching 
The invert option is provided as a means to check how well two images match one another. It takes 
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advantage of the fact that you can blend one image with an inverse of another one using a 50% opacity 
level. The result of this when used with identical images is a medium gray color for the entire pixel content 
where the images overlap. You can verify this by loading the same image for both foreground and 
background, inverting the foreground image, and setting the opacity slide to 128. The image will be 
neutral gray. 
 

  Magnifying Glass Tool (Ctrl + Plus, Ctrl + Minus) 
 

 
 
Use the magnifying glass to zoom in or out of an image. By drag-selecting a rectangle with the left mouse 
button in the image, you can zoom in a specific section of the image. A standard left click will zoom in the 
image, a right click zooms out. The tool options contain two buttons to reverse the left and right clicks. 
Double click on the magnify icon in the lower left panel to zoom to 100% scale. 
 
Use the Image to Window and Actual Size buttons to scale the image to fit the available window area 
and show the image at 100% magnification respectively. 
 

  Image Grabber (Shortcut: G) 
 
To use the image grabber, simply left click on the image and hold the mouse button down while dragging 
the image around. If the image fits within the current window size, the image grabber will have no effect. 
You may use the cursor keys with a combination of SHIFT or CTRL to pan the image window while the 
grab tool is active. 
 

  Measure Tool (Shortcut: U) 
 

 
 
The Measure tool is used to draw one or two straight lines that overlay the current image. The lines are 
used to measure distance and angle in pixels, inches, centimeters, millimeters, or percent. To add a 
second line connected to the first, hold down CTRL while hovering over an end point of the first line. You 
can remove measure lines by right clicking anywhere in the image. Hold down SHIFT while drawing to 
constrain the lines to 45° angles. 
 
The Measure tool shows coordinate (X, Y) and size (W, H, D1, D2) information in the unit of 
measurement specific to this tool. The width and height values only appear with a single measure line in 
use. They represent the width and height of the rectangle that connects the two end points of the line. 
 
The Measure tool angle (A) is either the angle of a single measure line, or the acute angle between two 
measure lines. This angle value can be plugged into the rotate and shear operations automatically to 
allow for precise image adjustments. 
 
The Measure tool distance (D1, D2) values represent the length of the first and second measure lines 
respectively, in the appropriate measure unit. 
 
Measure lines are visible regardless of which tool you are currently using. However, you may find it useful 
to hide measure lines temporarily. Click on the Show and Hide buttons in the options panel to toggle 
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display of the measure lines. 
 
The Measure tool has its own display units, independent of the ruler or information palette settings. Click 
on the Units button in the options panel set the unit type to one of pixels, inches, centimeters, millimeters, 
or percent of image size. 
 
The Measure tool renders its lines as overlays to the existing image. These lines are not part of the image 
itself and should have a color appropriate to the image for maximum visibility. Click on the Color button in 
the option panel to set a color for the measure lines. 
 

  Cross Hair Tool (Shortcut: H) 
 

 
 
The Cross Hair tool allows you to create one or two cross hair lines (vertical and horizontal lines 
intersecting at the mouse cursor position) as an image overlay. If you use two cross hair lines, the 
bounding box created by them can be used to gauge sizes and create precise selections. Use the SHIFT 
key to add a second cross hair line. Right click on the image to remove the cross hair lines. 
 
Each cross hair line has its own center point (X1, Y1) or (X2, Y2). The first center point can be 
determined by the (X1, Y1) coordinate and by the mouse cursor that appears on screen (it will have a 
number “1” with a 4-way directional symbol next to it). 

 
When you add a second cross hair line (using the SHIFT key), the second line center point can be 
determined by the (X2, Y2) coordinate and by the mouse cursor (the number “2” with a 4-way directional 
symbol next to it). If you see a mouse cursor at an intersection point between two lines and it only has a 
2-way directional symbol, then it is not a cross hair center point. 
 
With two cross hair lines visible, the width and height (W, H) represent the bounding box between the 
intersecting points of each line’s vertical and horizontal axis. This bounding box can be used to set a 
shape or region selection ellipse/rectangle in a precise manner (for a single cross hair line, you can use 
Cross Hair Selection mode to create a one pixel horizontal or vertical region selection if you wish). 
 
Cross hair lines are visible regardless of which tool you are currently using. However, you may find it 
useful to hide cross hair lines temporarily. As with the measure tool, Show and Hide buttons are available 
for this. When you choose the Show cross hair button, you have a choice to display the first cross hair 
with or without a floating ruler guide. 
 
The Cross Hair tool has its own display units, independent of the ruler measure tool units of measure. 
Click on the Units button set the unit type to one of pixels, inches, centimeters, millimeters, or percent of 
image size. 
 
You have the option to set the line color for the cross hair tool using the Color picker button in the options 
panel. 
 

  Eye Dropper Tool (Shortcut: Y) 
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The Eye Dropper tool samples one or more pixels of color in an image. The options allow for single point, 
3 x 3, or 5 x 5 pixel areas. In addition, the Selection option allows you to obtain a color average of any 
selected region, of any size or complexity. For image comparisons, the eye dropper tool will sample the 
foreground and background image at the same time. 
 
When using the Selection option, the color average of the selection area will not be updated until you 
release the mouse button. 
 
The left color swatch in the options panel is the sample color for the background image, and the right 
color swatch is for the background image. You can move the mouse cursor over either color swatch to 
update the RGB and HSV values in the image information panel. 
 

  Move Foreground Tool (Shortcut: F) 
 

 
 
The Move Foreground tool is similar to the Image Grabber, except that only the foreground image is 
dragged around, leaving the background image in place. Use this tool to align specific areas of the 
foreground and background images for comparison matching. Right click on either image to reset the 
position of the foreground to the upper left corner. 
 
The options panel shows some basic information about each image, including image reference name 
(window, file, clipboard), width, height, bit depth, and printing resolution in dots per inch. The top line is for 
the background and the bottom line for the foreground image. 
 

  Rectangle/Ellipse Selection Tools (Shortcuts: M and E) 
 

 
 
Use these selection tools to create new selections or modify existing selections. The image comparison 
tool only uses selections to measure distances and perform color sample averages. When creating 
selections that need to span more than the current visible display area of the screen, use the cursor keys 
to pan the image one window size at a time. Right click anywhere on the image to cancel a region 
selection. 
 
Creating Compound Selections 
The 4 buttons in the options panel to the right of the rectangle and ellipse shape selection buttons are 
used to create complex regions: 
 

Click on the first button to lock the selection creation mode so that any new selection will erase the 
current selection once the mouse button is released. The exception to this rule is if you are holding 
down CTRL, ALT, or a combination of the two, which temporarily overrides the normal mode. 

 
Click on the second button to lock the selection mode so that the new region selection will be added 
to the current selection if one is present. This allows you avoid having to always hold down the CTRL 
key if you are doing many additions. 

 
Click on the third button to lock the selection mode so that the new region will be subtracted from the 
current selection if one is present. 
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Click on fourth button to lock the selection mode so that the new region will be combined with the 
existing region such that only the intersecting areas will generate the resulting region. 

 
The following keyboard shortcuts are available when creating region selections: 
 

Hold down CTRL to add to an existing region selection 
Hold down ALT to subtract from an existing selection 
Hold down CTRL+ALT to create an intersection with the existing selection 
Hold down SHIFT to constrain the selection to a 1:1 ratio. 

 
The crop button in the options panel will create a new foreground or background image that contains only 
the pixel information contained within the current region selection. 
 
Selection Modes 
Region selections are created using a bounding box that will contain the region itself. The bounding box is 
created in one of four ways using this dropdown list: 
 
Normal Mode: Drag-select a rectangular area and when you release the mouse button, the region will 
occupy the area equal to the selection size. Hold down SHIFT while dragging to constrain the selection to 
a square. 
 
Constrained Aspect: Same as normal mode, except that you specify an aspect ratio for the bounding box. 
The ratio values can use fractional numbers. 
 
Fixed Size: The bounding box will be generated for you using the width and height you specify. You must 
also specify the anchor corner for the bounding box. 
 
Cross Hair Mode: The Cross Hair tool can be used to create a region that is equal in size to the bounding 
area between the corner points of two cross hair lines. The selection tools can then use this bounding 
area to create a precise region. 
 
If you are using a single cross hair line, the region created will be equal to the image width or height and 
one pixel in depth. 
 
Anchor Points for Fixed Mode 
With fixed size selection mode, you will not use the drag-select method to generate the bounding box. It 
will be created at the position where you click with the mouse. Since the bounding box has 4 corners, you 
must decide on which corner point is the anchor point. For example, if you use the bottom right corner, 
then the bounding box will extend to the left and upwards from the current mouse cursor position. 
 
Expanding, Contracting, and Moving Regions 
You can use the cursor keys, in combination with SHIFT and CTRL, to move, expand, or contract regions 
by 1 pixel in any direction. With rectangular regions, the cursor keys will apply the expansion or 
contraction to one edge only, based on the cursor key direction. For non-rectangular areas, the expansion 
or contraction will be uniformly applied to the overall shape of the region. 
 

  Freehand/Polygon Selection Tools (Shortcuts: N and P) 
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The freehand and polygon selection tools are similar to the rectangle/ellipse selection tools. For the 
freehand tool, you are not able to pan the image windows using the cursor keys, so you must ensure that 
you draw the selection within the current image display area. For the polygon selection tool, you will 
create each vertex by clicking the releasing the left mouse button. To close the polygon selection, move 
the mouse cursor near the first vertex point and left click, or hold down the CTRL key and click anywhere 
within the image. Right click to cancel the selection. 
 
 
Background Color Setting (Shortcut: Ctrl + B) 
Click on the small color swatch in the tool button cluster to change the color that is used for non-image 
areas of the comparison window. If the background image is smaller than the foreground image, the 
remaining background image space will be filled with this color as well. 
 

  Information Panel Toggle (Shortcut: I) 
 
Click on this button to hide or show the information panel, which contains RGB and HSV color values for 
the foreground and background image areas, selection size, coordinates of the mouse cursor and the 
position of the foreground image relative to the background image. The information panel will overlay the 
display area of the two thumbnail image samples. 
 

 
 
 

  Ruler Units 
 
Click on this button to bring up a menu allowing you to change the unit of measurement for both the rulers 
and the information panel positional information. 
 
Pixels: Ctrl + F1 
Inches: Ctrl + F2 
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Centimeters: Ctrl + F3 
Millimeters: Ctrl + F4 
Percent: Ctrl + F5 
 
Note: Percent is not available on the rulers. It is only for unit display in the information panel. 
 
Setting the Opacity 
The opacity setting applies to the foreground image. A value of 255 (100%) will completely hide the 
background image area with the foreground image, while a value of 0 (0%) will completely hide the 
foreground image. Drag the slider to set the foreground image opacity. Since the slider control only allows 
for coarse settings, click on the Opacity label or the opacity value itself to use a popup menu to choose 
from several opacity percentages or a specific value. 
 

 
 

  Clearing the Foreground Image 
 
Click on this button to remove the current foreground image. 
 
 
Top 
 
 

 
 
 

Contact Information 
 
Sales / Distribution Contacts  
Marios Theodossiou  
E-mail: staff@ezstamp.com  
Phone/FAX: (705) 254-6201 
       
Questions, Comments, and Suggestions  
E-mail: comments@ezstamp.com  
 
Technical Support  
E-mail: techsupport@ezstamp.com  



EzImage Reference – Version 1.05 

 

 Page 61 

 

 
If after reading the online help (F1) and you have read the FAQ page and you still have questions, please 
email a detailed question of what you need help with.  We will need to know what operating system you 
are running (Win 98, ME XP...), and a detailed description of what we can help you with.  
        
E-mail contact is the quickest & most convenient way to reach us. We usually can respond within 24 
hours. 
        
Mailing Address  
118 Palomino Drive 
Sault Ste. Marie, Ontario, Canada 
P6A 6K4 
 
Internet 
Please visit our website at: 
 
http://www.pcvu.com/ezimage/index.html 
 
 
Top 
 
 

 
 
 

Color Picker 
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Master Swatch 
The large color swatch displays 256 possible shades of color that is dependent on the model currently 
selected (red, green, blue, hue, saturation, or value). To select one of these shades of color, simply click 
anywhere in the swatch area, or hold down the left mouse button and drag the cursor around. 
 

Slave Swatch 
The smaller color swatch to the right displays a primary scale of color shades that relate directly to the 
color model. For example, using the Red color model, the smaller swatch will increment red values from 0 
to 255, and display the 65,536 remaining colors for each of these 256 red levels in the master swatch. For 
the Hue model, the 360 degrees of color hues will be condensed to 256 levels, and show the saturation 
and value ranges of that single hue in the master swatch. 
 
VGA Swatch 
Click on any color in the bottom palette to set one of the 16 standard VGA colors. 
 
Before/After 
The small swatch to the right of the slave swatch shows the before and after color values. Click on it to 
reset the color to the previous value when the dialog window first appeared. 
 
Shortcut Buttons 

FG: Click on this button to use the current foreground color. 
 

BG: Click on this button to use the current background color. 
 

GR: Click on this button to use a secondary 256-level gray scale window for setting the color. 
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TC: Click on this button to use the current color assigned for icon/cursor transparency. This is useful 
when exporting ICO/CUR files when not using an alpha channel mask to define the transparent 
areas. 

 
Red Color Model (R) 
The Red color model will show 256 levels of red in the slave swatch and 65,536 variations of each of 
those levels in the master swatch. The red levels range from 0 to 255 in the slave swatch, and vary the 
red and green levels according to the current cursor position in the master swatch. 
 
Green Color Model (G) 
The Green color model will show 256 levels of green in the slave swatch and 65,536 variations of each of 
those levels in the master swatch. 
 
Blue Color Model (B) 
The Blue color model will show 256 levels of blue in the slave swatch and 65,536 variations of each of 
those levels in the master swatch. 
 
Hue Color Model (H) 
The Hue color model will show a condensed set of 256 color hues in the slave swatch and 65,536 
variations of Saturation and Value for each of those hues in the master swatch. For finer control using 
360 hue levels, you can enter a numeric value in the text file to the right of the button choice. Saturation 
will increase left to right, Value (blackness) from top to bottom. 
 
Saturation Color Model (S) 
The Saturation color model will show a saturation level expressed as a percentage in the slave swatch 
and 65,536 variations of hue and value (blackness) in the master swatch. Hue levels will increase from 
left to right and Value (blackness) will increase from top to bottom. 
 
Value Color Model (V) 
The Value color model will show a blackness level expressed as a percentage in the slave swatch and 
65,536 variations of Hue and Saturation (whiteness) in the master swatch. Hue levels will increase from 
left to right and saturation will increase from top to bottom. 
 
Slider, Cursor, Keyboard 
You control the color settings in the slave swatch by dragging on the slider arrow or by clicking directly 
inside the swatch. You control the color value in the master swatch by clicking and optionally dragging the 
circular cursor to a new position. When making changes in the slave swatch, the color will not be updated 
until you release the mouse button or pause movement for a brief moment. For cursor dragging in the 
master swatch, the slave colors will update immediately. 
 
Some of the color models are linked in terms of the master and slave swatches. Change the value in one 
can affect all colors in the other. 
 
You can adjust the color values with greater precision using the numeric entry fields to the right of the 
color model selection buttons. Use the cursor up and cursor down keys to increment and decrement the 
values by one unit. 
 
Related topics: 
 
Foreground/Background Colors 
Color Sample Tool 
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Gray Level Picker 
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Cropping Images 
 
There are 4 methods in EzImage that involves some type of image cropping: 
 

Choose Edit->Crop from the menu to crop the active image so that the only remaining area will be 
the boundaries of the current region selection. The region does not have to be rectangular for the 

image to be cropped. If you are using the rectangular/elliptical selection tool, you can click on the  
button to perform a crop. 

 
Choose Edit->Save Selection->To Image from the menu to create a new window with only the 
portion of the image that was selected. If the image is non-rectangular, the remaining areas will be 
filled with the background color. Once again, you can use the crop button in the options panel if you 
are using the rectangular/elliptical selection tool. Hold down the SHIFT key to crop to a new image. 

 
Choose Image->Add Border from the menu to add borders to the image using the current 
background color. Although this is the normal intent of this method, you can specify width and height 
dimensions that are less than the current image width and height, in which case the image is 
cropped. The advantage of this method is that cropping can be applied based on image edge and 
corner positions. 

 
The Auto Trim tool will isolate the background area of an image and attempt to remove any extra 
border pixels that belong to this background from one or more sides. The trim tool can crop and 
expand an image, and has options to eliminate dust, noise, and scratches, which normally would be 
considered image data. 

 
Related topics: 
 
Rotating Images 
Shearing Images 
Flipping Images 
Resizing Images 
Adding a Border 
Auto Trim Tool 
Edge Deskew Tool 
 
 
Top 
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Channel Separations 
 
The Image->Channels menu contains options for viewing RGB (24-bit) and RGBA (32-bit) images by 
individual channel. When you view a single channel, you will see it displayed in 256-level gray scale 
format. 
 
A separated channel can be manipulated like any other image. There are only a few restrictions when you 
are viewing individual channels: 
 

Transformations that result in a change to the image size are not allowed. This includes rotation, 
shear, and resize. 

 
Indexed color and halftone conversions are not allowed. 

 
You may not convert between 24 and 32-bit RGB formats. 

 
You may not crop an image or perform an auto-trim. 

 
Certain color adjustments are not allowed, since the image is in gray scale format. This includes color 
mixer, gray scale conversion, hue/saturation, color balance, color adjust. 

 
Adding borders is not allowed. 

 
You may not use the selection separation or edge deskew tools. 

 
In addition, it is not possible to save an image while the channels are separated. You can save individual 
channels in gray scale format by duplicating the image into a new window, and then save the image from 
that window. By using duplicate copies of channels in other image windows, you can easily get around 
most of the restrictions in the above list. 
 
Related topics: 
 
Indexed Color Mode 
RGB Color Mode 
Gray Scale Mode 
Halftone Conversion 
Threshold Conversion 
Alpha Channels 
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Adding Images 
 
There are two ways you can add images to a thumbnail database: 
 

Using the Create and Re-create options in the thumbnail browser. 
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Using the Create Thumbnails option in the Image List editor. 
 
In either case, the process of adding images to a database is the same. A list of files is created from one 
or more path sources and added one image at a time. The image creation dialog appears as follows: 
 

 
 
If wish to apply the same comment to all of the selected images, you may enter it in the field provided. 
 
The Preferences button can be used to make any last minute changes to the way thumbnail images will 
be created. 
 
Depending on the creation options you selected, the images can be added in one of four ways: 
 

Creation by selection will only apply to files that currently have no thumbnail image or ones that have 
a date or size value different than what is currently stored in the database. If you select images that 
have valid thumbnails, then they will be ignored. 

 
Creating all images for a folder. The same rule about existing thumbnail images as the selection 
option applies. 

 
Creating images for a folder tree. This applies to the Recursion options in the thumbnail browser. All 
images in the current folder and any subfolders beneath the current folder will be added to the 
database. 

 
Creating images from a file list. This option only results when creating thumbnails from the image list 
editor. 

 
The progress window on the left indicates the total number of files and folder involved for the thumbnail 
creation. The bytes total is the sum of the sizes of all source image files. The Processed indicators in the 
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right will increment as thumbnail images are created. The speed by which the images are generated 
depends on several factors: 
 

Thumbnail image size 
Source image size 
Source image format 
Method of reduction 
Thumbnail storage format 
System speed and memory 

 
The Database Size and Total Thumbnails indicates the current contents of the database. As you add 
new images, these values will also increase. True color storage format results in the highest thumbnail 
quality at the expense of a large thumbnail database size. The JPEG storage formats will create small 
database files, but the thumbnail display speed will be significantly slower, since each image will need to 
be decoded. Indexed color storage format provides good image quality with the fastest display among the 
available formats. 
 
Click on the Create button to begin generating thumbnails. This operation does not run in the 
background. You must wait for all thumbnail images to be created before you can do anything else in 
EzImage. You can stop the operation at any time by clicking on the Cancel button. 
 
Thumbnail Database System 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
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Compression Tuning Tool 
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There are a few formats supported by EzImage that involve some form of compression that results in loss 
of image quality in order to decrease the overall size of the file. These formats include: 
 

JPEG 
Portable Network Graphics (PNG) 
FlashPix (FPX) 

 
Since the level of compression and the resulting image quality can sometimes be unpredictable given the 
source image, this tool provides a visual method to test different compression settings, and see the 
results in a common “Before and After” side-by-side window arrangement. 

 
The top part of the dialog window contains a 50/50 division of the before and after image, always shown 
at 100% magnification. If you resize the window, the 50/50 partitions will remain intact. The images 
themselves are not linked, so that scrolling one image will not automatically scroll the other one. 
 
The current test file format will be shown in the title bar of the window. Use the Settings button to change 
to a different format. 
 
The original and compressed image sizes, along with the compression factor is shown immediately below 
the preview area. 
 
Opening the Test Image 
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Click on Open to open an image using the standard Window open file dialog box. 
 
Using the Image Preview Browser 
Click on Browse to open an image using the image preview browser. 
 
Previewing Compression Settings 
Click on Preview to apply the compression settings and file format to the original source file. The resulting 
file’s image will be displayed on the right. In order to ensure you are seeing the actual pixel quality 
without dithering or scaling artifacts, both images are always displayed at 100% magnification. If the 
image is large, you may have to scroll the display windows. 
 
Applying a Gamma Correction 
Some images may appear darker than others, which can hide the details of images that could be affected 
by compression quality. You can apply a general gamma correction to each image by entering a value 
with this option. The gamma adjustment is temporary and will only remain in effect while the Compression 
Tuning window is open. This setting does not alter the output preview file in any way. 
 
Adjusting Settings 
Click on Settings to change the file output format and the compression properties for each one. 
 
Applying Settings 
Click on this button to apply the compression settings for all of the formats to one or more of the 3 areas 
that EzImage uses them to generate image files: 
 

Save As (From the main menu) 
Batch file scanning 
The File Conversion tool. 

 
The Save main menu option will also use these settings if you save an existing compressed format to 
itself (i.e. load a JPEG, alter it, resave it as JPEG). It is not recommended that you alter a format that is 
already compressed for the purpose of recompressing, unless the source format is loss-less, such as an 
uncompressed TIFF file. 
 
Related topics: 
 
Loading and Saving Images 
Batch File Scanning 
File Conversion Tool 
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Thumbnail Database Open Errors 
 
When you attempt to open any thumbnail database for browsing, some initial content verification is 
performed to ensure that the data files are intact. If data corruption occurs within individual thumbnail 
images or image groups, these error types are only detected when you attempt to access specific 
images. 
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There are several reasons why this error may occur: 
 

One or more of the four data files are missing from the database. The four data files are identified by 
their extension: image data (THD), path groups (PTH), file groups (FIL), and comments (CMT). All 4 
files must be present to open a database. 

 
EzImage tracks the last known location and name of thumbnail database files when you close the 
application. If the files are moved to another location, you will get a database open error. 

 
All files have some basic data integrity features built in. If any of the initial content verification 
procedures fail, then you will see this dialog window. 

 
You may be running an older version of the application against a newer version of the thumbnail 
database. At the time of this documentation, there is only one version of the database file format. 

 
You have three courses of action you may take with a database open error: 
 

Create a new database under a different name. 
 

Open an alternate database, which is what you need to do if the error was a result of the files being 
moved. 

 
Attempt to repair the database using the Repair Database option under Browse->Thumbnails menu 
option. 
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Exporting a Database 
 
This option is available from the database maintenance menu. It allows you to generate text files that 
contain detailed information about the contents of any thumbnail database. 
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General Database Properties 
Check this option to include the general information about the database files. This information is not 
specific to any thumbnail image. 
 
Path Names in Database 
Check this option to include all path name references to the original source images. 
 
File Names in Database 
Check this option to include all file name references to the original source images. 
 
Comments in Database 
If you have attached comments to any thumbnail image and wish to include them in the exported file, then 
check this option. 
 
Thumb Image Details 
Thumb image details include width, height, size, and storage format. 
 
Source Image Size and Date 
This option will include the image file size and date as stored in the thumbnail database. This information 
may be different than the actual file if the image has since been modified. 
 
Source Image Details 
Source image details will include information about the source file itself. Since this requires checking the 
original reference image, the export operation will slow down significantly, especially with formats that 
require a lot of decoding. However, the added information will include actual size, dimensions, DPI, file 
format, bit depth, and date of last modification. 
 
Export Missing Images Only 
If you check this option, then only images that have no source reference to match against the thumbnail 
information will be exported. In the case of a database with all source files intact, the export list will be 
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empty. Use this option to generate missing image lists. 
 
Active/Deleted Entries 
The thumbnail database stores images by adding to the end of the existing database, for speed and 
efficiency reasons. The storage process is actually quite complex, but suffice it to say that if a new image 
will fit into the ‘blank’ areas where old ones used to be, they will occupy all or part of that blank space. 
File and path references on the other hand are never removed until you perform a reclamation operation. 
Up until the time you reclaim inactive areas in a database, you can choose to export both active and 
inactive thumbnail information. 
 
Setting a Delimiter 
You can choose to separate each column of exported data with a tab or comma character. For any fields 
that may contain spaces or commas, the entire entry will be enclosed in double-quotation characters. 
 
 
Click on Export to create a text file in a target location of your choice. By default, the output path will be 
set to the User folder of the application path. Once an export operation has begun, you may click on the 
Cancel button to stop it. 
 
Related topics: 
 
Thumbnail Database System 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Thumbnail General Preferences 
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Thumbnail Database Properties 
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File Location 
The first field in this dialog window is the path and file name reference for the active thumbnail database. 
There are 4 files that make up a single database, identified by their file extension: 
 
THD: This file contains all of the thumbnail image data, color palettes, and dimension information needed 
to display the images. 
 
PTH: This file contains the path groups for the images. Paths are stored separately from the file names to 
conserve space and make the data access more efficient. 
 
FIL: This file contains the links for all image file names, organized by their path name group. The file 
maintains date and size information, references to comments, and references to the image data needed 
to display the thumbnails. 
 
CMT: This file contains comments that can be associated with one or more thumbnail images. Comments 
are an optional feature of the database system. The file must still be present however, even if it contains 
no comment information. 
 
Database Size 
This is the sum total of the physical disk space used by the 4 files for the active database. 
 
Unused Space 
Unused space can be reclaimed using the database maintenance option. When you delete or modify 
thumbnail images, there will be some blank areas that appear, mostly in the image file (THD). 
Fragmentation doesn’t impede the performance of the database, but you may want to periodically reclaim 
the extra space. 
 
Active Images 
Active images are those that still have a valid thumbnail reference in the database. Even if the source 
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image is not currently available (or has been deleted), the thumbnail image will still remain active and be 
available for viewing with the Full Browse option or in Catalog Browse mode. 
 
Deleted Images 
Deleted thumbnails no longer have valid image data, but retain their identity in the database until you 
perform a maintenance operation. When a database has had its free space fully reclaimed, the free 
amount will be zero as will the deleted image count. 
 
Created On 
This is the date that the database was created. This information is embedded in the database itself, and 
unless the file system creation date has been tampered with, is generally the same date. 
 
Last Modified 
This is the last date that any modifications were made to the database (additions, deletions, or general 
maintenance). 
 
Minimum and Maximum Thumbnail Size 
The minimum and maximum sizes apply to all active thumbnail images. A thumbnail image can be a 
minimum of 50 x 50 pixels (smaller images will be framed by border color), up to a maximum of 200 x 200 
pixels. 
 
Encryption 
A password is used to encrypt a database and prevent anyone from altering its contents. Once a 
password is in place, the database maintenance options are unavailable unless the password is provided. 
The password security also blocks addition and deletion of thumbnail images. It does not prevent 
someone from deleting the database files. Make sure you enter the same password in both fields 
provided. 
 
Version Number 
This version identifies the internal storage format for the database. The current version of EzImage will 
always support every version of the database. If in the future changes are made that make a prior 
database version obsolete, appropriate conversion tools will be added to allow older database files to 
migrate to the newer ones. 
 
Database Comment 
Any thumbnail database can be tagged with a comment of up to 128 characters. The comment, 
encryption, password, and view lock options can be changed at any time using the database 
maintenance options. 
 
Top 
 
 

 
 
 

Repairing a Database 
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The repair facility is provided to fix any database with errors that prevent it from being open in the 
browser. In addition, an attempt will be made to repair any database where one or more images in a path 
group can not be viewed for any reason. 
 
The database format used in EzImage uses multiple files organized according to the type of data stored. 
If a database is damaged at one file level, a recovery can usually be made using the information from the 
remaining data files. However, the storage format was chosen for speed and storage space reasons, and 
does have one somewhat weak point: the path groups file (extension .PTH). If this file is corrupted, it is 
possible to lose a significant portion of your image database, simply because the file and image links may 
no longer have a valid path reference. Errors tend to affect the largest files, which would mean the image 
data file would be the most likely cause of an error. When the image data file is affected by an error, only 
the thumbnail images are affected. These images can be re-created from within the image browser. 
 
To begin a database repair, use the Open button to open a thumbnail database. Each file is checked to 
ensure that basic information is intact. Since this basic information has several redundant points of 
reference, a corrupted database will rarely be affected to the extent where it can’t be opened. 

Nevertheless, if all points of database identity have been corrupted, then it will not be possible to apply a 
repair operation. 
 
Click on the Repair to being the operation. A backup copy is always created from the original file set, so 
that any unexpected problem during the repair procedure will not affect the original database files. Once a 
repair procedure has been completed, the original database files are replaced with the repaired ones. 
 
Note that there may be the rare instance where a database’s file integrity has been compromised to the 
point where no form of repair will work. You will be given an appropriate error message dialog if this were 
to happen. 
 
Related topics: 
 
Thumbnail Database System 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
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Edge Deskew Tool 
 

 
 
The deskew tool is used to correct the orientation of rectangular images by applied a clockwise or 
counter-clockwise rotation. It is a common problem when scanning images (especially multiple small 
images at one time) to place the documents on the scanning glass and not have them line up at 90° 
angles. The deskew process looks at the color contrast levels between a common background color and 
edges of valid image area to determine how to rotate the image to align edges to be as close to vertical 
and horizontal as possible. When used with along with the Selection Separation and Auto Trim tools, you 
can easily create separate images from multiple-document scans. 
 
Edge deskew does not work on every possible image. There are certain limitations you should be aware 
of: 
 

The image area must be unbroken. You can’t deskew an image that contains more than one discrete 
color area. For example, if you scanned two separate documents in one image file, it is not possible 
to deskew the image, since there are more than 4 edges (4 for document one and 4 for document 
two). You must separate the image areas and apply the deskew method to each document. 

 
The image area should be a rectangular shape. The edges of the rectangle do not have to be 
straight, since deskew can work on edges that are rough, torn, wavy, etc. The overall shape of the 
image should bear some resemblance to a rectangle. Deskew will not work on triangles, circles, or 
irregular shapes, such as a hexagon or octagon. 

 
The method is in no way similar to the ones found in OCR or text recognition packages. The image 
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content itself will not be used to perform the deskew. It is not intended as a method to straighten 
images that are scanned pages of text. 

 
Since pixel content is not used to correct the image, it is not possible to automatically rotate an image 
180° if it was scanned upside down. Once a deskew has been applied, you can use the flip and fast 
rotate options to correct this. 

 
Minimum Width and Height 
The minimum width and height define the smallest area of the image that will contain the area to deskew. 
The deskew analysis is based on contrasting edges between the image and background areas. The 
minimum size ensures that any areas smaller than this that may be selected based on the tolerance will 
be eliminated. This is similar to the noise areas that are eliminated by the selection separation and auto 
trim methods. 
 
Fill Color 
The deskew method will correct the image by performing a clockwise or counter-clockwise rotation. This 
rotation will almost always result in the image becoming larger. The fill color specifies what will be used 
for the extra background area that will result from the rotation. By default, the upper left pixel in the image 
will be used. 
 
The Hand and Color Sample Icon Buttons 
Use the hand icon button to drag and move the image thumbnail sample around. This allows you to see a 
part of the image at 100% scale. If you right click on the thumbnail sample, the original image will be set 
to 100% scale and auto-center to the same position as the thumbnail. If you right click while holding down 
the SHIFT key, then original image will be scaled to fit the current window size. 
 
Click on the eyedropper icon button to choose a new sample point for the deskew operation. By default, 
the upper left pixel of the image is chosen as the “background reference” point. If an image has edge 

noise that makes using the upper left corner pixel unsuitable, scroll the preview window around and 
locate a suitable background sample color. 
 
Feedback Status 
The indicators below the tolerance slider show how many areas are eliminated as background noise, how 
many areas are counted as valid image data, and the progress of the trim analysis. If more than one 
image area is detected, the deskew method will fail. 
 
Tolerance Setting 
The deskew method relies on a tolerance setting to determine what parts of the overall image are 
background and noise, and what parts are actual image data. A higher tolerance setting will reduce the 
amount of noise that could cause the deskew process to include background areas that are not part of the 
image. However, a higher level can also lead to selections that involve valid parts of the image data that 
could also affect the rotation correction angle. For high contrast images, a higher tolerance will generally 
result in better deskew corrections. 
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Display and Dithering Quality 
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There are two general preference options that control the quality of the images in any window. These 
settings will affect all open windows equally. 
 
Dithering Quality 
EzImage is optimized for video display systems with more than 256 simultaneous colors. However, you 
may use EzImage with a 256-color display, but you will find that the image quality will suffer for RGB and 
Gray Level sources, since these image formats must be adjusted to fit within the 256-color limit. In fact, 
Windows will tend to reserve a portion of the 256-color palette for painting the various Windows objects, 
such as buttons, scroll bars, and window title bars. 
 
The dithering methods available are Ordered (fast, low quality) and Diffusion (slow, better quality). You 
will not see any type of dithering applied if you are running your display with more than 256 colors. 
 
Display (Paint Scaling) Quality 
This option applies to any image that is less than 100% pixel magnification. The paint scaling option 
determines how to blend colors in pixel areas to eliminate noise patterns that will be visible on images 
that are not “clean” such as a scan from a halftone document. Such images have patterns in them that 
will cause distortion of the image when viewed at less than 100% actual pixels. 
 

Nearest Neighbor is fast and generally provides good display quality with most images. 
 

Linear scaling provides a significant increase in display quality, at the expense of increased time 
needed to refresh the image information when it is changed or the image window is scrolled. 

 
Bicubic scaling offers the best quality, but at a high cost in terms of display refresh time. 

 
Keep in mind that when viewing an image at 100% or higher magnification, the nearest neighbor method 
is always applied. 
 
Related topics: 
 
Image Windows 
Setting Magnification Levels 
Window Arrangements 
Fitting a Window to an Image 
Fitting an Image to a Window 
Image Information Overlays 
Window and Cross Hair Rulers 
Close vs. Close All 
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Edit Keyboard Shortcuts 
 



EzImage Reference – Version 1.05 

 

 Page 79 

 

 
 
This option allows you to reconfigure all of the menu accelerator keys for the main EzImage menu. It does 
not allow you to modify any of the built-in shortcut keys that are found in menus belonging to various 
EzImage operations. 
 
There are many operations available in EzImage, in fact too many to properly assign a logical set of 
shortcut keys for every available feature. There may also be a desire to change a keyboard mapping that 
is familiar to other applications that you are currently using or have used in the past. In either case, you 
can change the shortcuts for all options in the main menu of the application using this editor. 
 
All accelerator keys for the main menu are defined based on a template of keyboard shortcuts under 
using a Profile Name. There are 2 profiles that are provided by default: Keyboard Template 1 and 
Keyboard Template 2. Make sure you have tried out both templates to see if either one closely matches 
what you are looking for. You can use either one as the foundation for creating a new template of your 
design. 
 
Custom Templates 
To make a custom template simply save one of the current templates in the drop down list under a new 
profile name. When you have provided a new profile, it will become the default in the drop down list, and 
you may begin your changes to this list of shortcuts. In no way are you permitted to change the default 
template shortcuts. 
 
In Case of Corruption 
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All keyboard templates are stored in a file named ezimage.key, located in the application installation 
path. If for some reason a keyboard template file has been corrupted and refuses to load when you start 
the application, a backup copy is placed in the Backup folder. Simply replace the file with the one in this 
folder. 
 
Clearing Shortcut Keys 
Use the mouse button along with combination of the Shift and Ctrl keys to create a selection of menu 
options in the list you wish to clear then choose the Clear Selected option. To remove all keyboard 
shortcuts in the template, choose the Clear All option. 
 
Entering a New Shortcut 
To enter a new shortcut key for an operation, select that operation in the list and press ENTER or use the 
option in the Edit menu (you may also double-click any entry to edit its shortcut). You will be prompted to 
enter any key combination. You can qualify it with Shift, Alt, and Ctrl as needed. Note that you cannot 
use combinations of keys that would not be allowed as a valid shortcut, nor can you use a shortcut that 
would conflict with a menu hotkey (such as Alt + F = File Menu). Use Escape to cancel the entry. If you 
chose a shortcut that is already assigned you will be given a warning message. 
 
NOTE: Any operation with a shortcut will be shown with a checkbox icon to the left. 
 
Saving Changes 
Use the Resave Current Template option from the Options menu to save without exiting the editor. Use 
the Apply button or menu option to save changes and exit with the new template set as the default. 
 
Deleting a Template 
Use the Delete Template option from the Edit menu to remove the current template from the drop down 
list. You can not edit or delete the 2 pre-made template profiles. 
 
Related Topics: 
 
Keyboard Reference 
Image Tools: Keyboard and Mouse Shortcuts 
Selections: Keyboard Shortcuts 
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Duplicating Images 
 
You can create a copy of an image using the following methods: 
 

Choose Edit->Duplicate Image from the main menu. The general preferences has an option to 
enable automatic naming of the image (it is enabled by default). With automatic naming enabled, 
EzImage will create a name for you, using the format <original name>_<c#>, where # is a 

sequence number that starts at 1. With the automatic naming feature disabled, a dialog will be given 
prompting you for an image name. You may not choose a name for an image that matches one 
present in any open image window. EzImage does not allow the same image name to exist in two 
separate windows. 
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Copy the image to the clipboard by choosing Edit->Copy from the menu. If you haven’t selected a 
region, the entire image will be placed into the clipboard in Device Independent Bitmap (DIB) format. 
You can then use File->New and create a new image with the Clipboard set as the source. This will 
automatically place the image into the new window. 

 
Select the entire image using Select->All and use the Select->Save Selection->To New Image 
menu option. This can also be done using the crop shortcut in the options panel for the 
Rectangular/Elliptical Selection tool. Hold down the SHIFT key when you click on the crop button to 
place the selection into a new image. 

 
Select the entire image and use the Move tool to drag it into another image window. The second 
window must be at least equal in size to the source image or it will be cropped. When you drop the 
image into the window it will create a floater. Position the image and use the Floater->Paste option to 
place the image in the new window. 

 
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 
Filling and Images 
Clearing Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
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Applying an Emboss Effect 
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This filter applies an emboss effect to the bitmap, letting you specify the depth and direction. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
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closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Noise Filter 
Mosaic Filter 
Oilify Filter 
Posterize Filter 
Solarize Filter 
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Recording Script Messages 
 
You can insert a message at any time while a script recording session is in progress. The message must 
contain less than 16,000 characters, and should only contain line breaks at the end of paragraphs (i.e. let 
the text wrap around within the editor window). 
 
When the script is played, a dialog window will appear with the contents of your message. The user can 
choose to cancel a script at the time this window appears, or continue with the next command in the script 
file. 
 
Note that an option in the application preferences is available to disable script messages. 
 
Top 
 
 

 
 
 

Equalization 
 
This method linearizes the number of pixels in an image based on a specific color space. This can be 
used to bring out the detail in dark areas of an image. 
 
There are 3 color space choices available. For best results use the YUV color space option. 
 
Before Equalization: 
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After Equalization: 
 

 
 
 
Related topics: 
 
Levels 
Brightness and Contrast 
Hue and Saturation 
Color Balance 
Channel Mixer 
Channel Adjustment 
Image Inversion 
Stretch Intensity 
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File Conversion Tool 
 
The file conversion tool provides a method to apply several types of image adjustments and file format 
changes against a set of image files in one step. The set of files is created from one of several source 
types, including single folders, folder trees, image lists, or path lists. The conversion method always 
creates a copy of the original image file in another folder path on your system, with the exception of in-
place file renaming (this topic is described in detail later). 
 
The main conversion window contains two basic sections: the path and file format properties, and the 
conversion method categories: 
 

 
 
Conversion Category Status Indicators 
The red/gray indicators to the left of each conversion method category reflect the active state of their 
respective properties. For example, if the Transform indicator is red, then at least one transformation 
property has been changed from its default value. To reset the properties for one category, click on the 
indicator button. To reset all properties for the conversion tool, click on the Reset button. 
 
Setting the Conversion Source 
The source of a file conversion can be one of the following: 
 

A single path name, in which all image files for that path may be involved in the conversion. 
 

A folder tree, which is defined the same as a single path, with the additional requirement that you 
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check the Process Subfolders option. 
 

A path list, whish is a file containing a list of path names that you can create using various options in 
EzImage, such as the thumbnail browser, preview browser, or path list editor. 

 
An image list, which is simply a list of image files stored in a special file. As with path lists, you can 
use various browsing tools in EzImage to build an image list file, including the image list editor. 

 
With any of the source options, you can click on the Browse button to search for the appropriate file or 
path reference, which will appear in the Source Ref field. 
 
Rename Undo 
This source option is used specifically to reverse an in-place file rename job. It will use the successful 
conversion log file to basically undo all of the file renaming that took place. 
 
Setting the Conversion Target 
The target type can be either a path name or a subfolder of the source path. For example, if you specify a 
source path of C:\MyImages and the Subfolder of Source Path option with a name of Convert, the 
converted files will appear in C:\MyImages\Convert. If you apply the subfolder method to an image list 
file source, each unique path reference in the list will generate a subfolder with the converted image file. 
The target path name or the subfolder name will appear in the Target Ref field. 
 
Warning: It is perfectly acceptable to set the source and target path to be equal, in which case a 
converted file will replace itself. It is recommended that you don't do this as a general rule of thumb, since 
there is no way to get back the original image file. 
 
Target Path Name Formats 
Path names can be created for the converted file using one of 3 methods: 
 

Full path name will include all folders in the source path name, not including the drive letter or UNC 
share name. 

 
Include parent folder will only preserve the parent folder name of the source image (i.e. 
C:\MyImages\Set1 converted to D:\Temp\Img will be stored in the folder D:\Temp\Img\Set1, as 
opposed to D:\Temp\Img\MyImages\Set1). 

 
The Collapse folder option will place every image in the target folder without keeping any source path 
folder information at all. 

 
Setting the Output File Format 
You can convert a file from one format to another or keep the existing format while applying other 
changes to the image. To convert to a specific output format type, choose one from the available 
dropdown list, and make sure you verify all settings applicable to that format using the Options button. 
The options will be different for each file format type. If you choose the Keep Same format option, be 
aware that the format options will still apply, and in this case multiple file formats will result in multiple 
format options that need to be set. If you choose to keep the same format, please ensure that the options 
for all possible formats that may exist in the set of source image are verified to be as expected. 
 
Conversion Type Categories 
The following is a brief description of each conversion method category that you can apply to an image. A 
detailed reference can be found using the topic links following the description list. 
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File Types 
This option allows you to filter the set of image file formats that will be read using a simple checklist 
dialog. By default, all supported image formats will be processed for conversion. Please note that some 
file formats may not be available or enabled in the current version of EzImage. 
 
Filters 
The file filter allows you to further restrict the images that will be involved in a conversion. This option 
breaks down into 3 basic areas: pattern filters using wild card characters, file size filters, and file date 
filters. You can apply any or all of these filters that will work in addition to the general image format filter. 
 
Transformations 
The transformation options include resizing (constrained, fixed, or separate), 90° rotations, expansion, 
cropping, mirroring, printer DPI resolution, and auto trim. These are basic transformations that are 
generally quick and easy to setup. You can use scripts to apply any other type of image alteration feature 
supported by EzImage. 
 
Color Adjustments 
Color adjustments include bit depth level changes (1, 2, 4, 8, 24, and 32 bits per pixel), palette 
optimizations, and the basic color adjustment options found in EzImage: Levels, Hue/Saturation, Color 
Balance, Color Mixing, and Channel Adjustment. For the latter adjustment methods, you must provide an 
adjustment file, which can be created by those specific operations. 
 
File Renaming 
The renaming options include case conversion (name and extension), search and replace (several 
varieties), numeric sequencing, and templates using fixed width character definitions. This option also 
includes how to handle collisions with file names that may already exist in the target path. An in-place 
rename option allows you to simply use the conversion tool to rename image files in their source path 
locations without creating converted copies. 
 
Overlays 
The overlay feature allows for simple text and image overlays onto an image using position, rotation, 
scaling, blending, and an opacity level. Only one overlay type of image or text is supported per image. For 
more advanced overlay capabilities, you can use a script file. 
 
Scripts 
Scripts are plain text files that contain a sequence of commands that correspond to menu, mouse, or 
keyboard actions in EzImage. The script file doesn't have any type of formal structure like a programming 
language. It is simply a method of recording multiple actions into a single file, which can be played back in 
a single step. You can choose to run a script file as an alternative solution to making image file 
adjustments. When running a script file, the Transform, Color Adjustment, and Overlay options are 
automatically disabled, since these actions can also be placed in a script file. 
 
Detailed help can be found using the following topic links: 
 
File Types 
File Filters 
Transformations 
Color Adjustments 
File Renaming 
Overlays 
Scripts 
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Log Files 
Log files are created for the following purposes: 
 

Creating the list of image files that will be converted. The conversion process takes place in two 
steps. The first step is to examine all files in the source path, paths, or image list file, and determine 
which files to include. The result is a conversion list log. 

 
Creating a log for successful conversions. This log file shows the names of the image files that were 
converted, and is used as the reference source when you need to resume a conversion job that did 
not complete. 

 
Creating the skip list, the set of images that were not processed due to filtering, invalid file formats, or 
user intervention. 

 
Creating the error log, the set of images that were not processed due to unexpected errors, such as a 
file decoding error when attempting to load an image. 

 
There are four log files that can be identified by their file extension: the list of files to convert (LOG), the 
list of files that were successfully converted (LST), any files that could not be converted due to an error 
(ERR), and any files that were skipped due to filtering or any other reason (SKP). 
 

 
 
These are plain text files that always reside in the Logs folder in the EzImage installation path. When 
defining a log file name, you must omit the file extension and path name, since these are added for you. 
 
Conversion Profiles 
The load and save options allow you to store multiple conversion profiles. There is always a default set of 
conversion properties that is in effect each time you use this tool. If you are using a custom profile other 
than the default for conversions, the file name will appear in the title bar of the conversion tool window. 
Conversion tool settings are stored in the User folder of the EzImage installation path with an extension 
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of .CFS. 
 
Starting a Conversion Job 
Click on Convert once you have configured all of the properties for the conversion job. This is a two step 
process. The first step will be gathering the files that will be involved in the conversion and placing them 
into the conversion log file. Any filters or file type restrictions will be used in this step to remove unwanted 
files from the list. 
 
Resuming a Conversion 
The resume option allows you to restart a prior conversion operation that didn't complete either because it 
was cancelled, or due to an unforeseen error. To resume a conversion, you must have both the 
conversion list and successful conversion log files. These are the first two files that are defined under the 
Log Files option. 
 
Step two of the conversion process is described under a separate help topic. 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Existing Files 
 
When saving a converted image file to the target path, a file with the same name may already be present. 
The course of action you can take with existing files in the target path depends on the settings for the 
Rename category in the conversion tool. There are 4 resolution options available: 
 

Prompt for new name 
Do not convert the file 
Replace the existing file 
Auto-rename the target file 

 
The prompt option is the only one that will result in the display of the following dialog window: 
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Overwrite 
The existing file will be replaced with the converted image. If another occurrence of an existing file takes 
place, you will see this dialog once again. 
 
Overwrite All 
Same as the Overwrite option, except that the dialog window will never appear for the remainder of the 
conversion job. If any subsequent files match on the target path, the converted image will replace the 
existing file. 
 
Autoname 
Choose this option to insert a prefix number before or after the file name. The original existing file on the 
target path will remain as is, but the converted image will have a new file name which includes the 
sequence number. 
 
Skip 
The image will not be converted and a reference to it will be added to the skip list log file. 
 
Rename 
You can enter any file name in the text field provided then click on this button. You will not be allowed to 
choose a file name that already exists in the target folder. 
 
Cancel 
This option will cancel the conversion job without processing any more image files. 
 
Top 
 
 

 
 
 

File Conversion Tool, Filters 
 
The filter dialog provides date, size, and pattern-based filters that can be used to restrict the list of images 
that will be converted. 
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File Patterns 
EzImage file pattern filters are equivalent to the older MS-DOS style wildcard-based file names. The filter 
consists of one or more wildcard strings that match to a single file name. 
 

The asterisk (“*”) character matches zero or more occurrences of any character. 

 
The question mark (“?”) character matches one occurrence of any character. 

 
You must specify a filter string for both the file name and the file extension, separate by the period 
(“.”) character. 

 
To match on multiple patterns, separate them with a semi-colon character (“;”). 

 
This is contrary to Win32 (95,98,NT,XP) based wildcard conventions, so please be aware of the 
difference. If a file contains multiple periods, as in SAMPLE1.23.96.BMP, the file name portion would be 
SAMPLE1.23.96 and the extension would be .BMP. Do not use the asterisk (*) by itself to match all files 
(Use *.*). 
 
Size Filters 
Check the Enabled option to apply a size filter. Enter values in the size fields according to the unit size 
displayed next to each one. Depending on checked status of the Include/Exclude option, files with a 
sizes smaller and/or larger than these values will either be included or excluded from the conversion 
process. 
 
The Include Between option is used to filter all files between the smaller and larger file sizes. When this 
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option is checked, the include/exclude size options are automatically disabled, as you will be defining a 
size range. 
 
If you check the Include/Exclude option, then all files with sizes larger or smaller than the size limits will 
be included in the conversion. With this option unchecked, all files with sizes larger or smaller than the 
size limits will be excluded. If the Include Between option is checked, then this setting is ignored. 
 
Date Filters 
There are two types of date filters that can be applied. You can use recent days or months to include files 
with modification dates that only go back a certain amount of time. The date-based filter uses one or two 
dates specified in YYYY/MM/DD format. 
 
Depending on checked status of the Include/Exclude option, files with a dates older/newer than the date 
limit values will either be included or excluded from the conversion process. You can check one or both of 
the older/newer options. If you check both, then you will define an exclusion or inclusion date range, 
unless the Include Between option is checked. 
 
If you check the Include/Exclude option, then all files with dates newer or older than the date limits will 
be included in the conversion. With this option unchecked, all files with dates newer or older than the date 
limits will be excluded. If the Include Between option is checked, then this setting is ignored. 
 
The Include Between option is used to filter all files between the older and newer dates. When this 
option is checked, the include/exclude date options are automatically disabled, as you will be defining a 
date range. 
 
Click on Reset to restore all settings to default values (no pattern, no size filter, and no date filter). 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Overlays 
Settings: Scripts 
Settings: Log Files 
 

 
Top 
 
 

 
 
 

File Conversion Tool, Transformations 
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Resizing Options 
No Change: No resizing will be applied 
Preserve Aspect – Width: Enter a width value and the height will be adjusted 
Preserve Aspect – Height: Enter a height value and the width will be adjusted 
Preserve Aspect – Fill: The remaining image areas are filled with the border color 

Separate Width and Height: The aspect ratio will not be preserved 
Constrained: The width and height will not exceed the values you specify 
 
Depending on the type of resizing operation, one of the width or height values may be disabled.  
 
When constraining an image to a specific maximum width (or height, but not both), you can place a very 
large value (such as 30000) in the one that you don’t want to limit. For example, use Width = 1024, 
Height = 30000 to limit the width to 1024, and let the height be any value that maintains the aspect ratio. 
 
Rotations 
This option only provided for fast 90° rotation increments. To rotate an image by any other angle, you will 
need to use an EzImage script file. 
 
Image Flipping 
You can mirror the image horizontally or vertically using the corresponding options. 
 
Setting Print Resolution 
Some image formats contain embedded printer resolutions, for which the unit of measure can vary for 
each one. If you wish to change the printer output resolution, you can check the Change Output DPI 
option and then enter a value in dots per inch. For example, if the image is 2400 pixels in width and you 
specify a DPI value of 600, the image would be defined as 4 inches in width. Changing the DPI does not 
resize or alter the pixel image data in any way. 
 
Expanding or Cropping the Image 
Check the All Sides option to expand or crop the image on all sides equally. If you specify a negative 
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amount, the image will be cropped after it has been trimmed. If you specify a positive amount, the image 
will be expanded on all sides and filled using the border color of your choice. 
 
Check any of four edge options to selectively apply an expansion or crop to each side. When you check 
one of these edge options, enter an expansion or crop amount in the field beneath the corresponding 
check box.  
 
Using the Auto Trim Option 
The auto trim option relies on a tolerance setting to determine what parts of the overall image are 
background and noise, and what parts are actual image data. A higher tolerance setting will reduce the 
amount of noise that could cause the trimming process to stop short of its goal. However, a higher level 
can also lead to selections that involve valid parts of the image data that you do not want to eliminate. 
There is a tradeoff that must be made to determine just how much image data becomes background to 
eliminate and how much data is valid image information. Unlike the Image Trim tool found in the EzImage 
main menu, there is no preview option or any method to eliminate background noise (you can use a script 
for this however). 
 
 
Click the Reset button disable the resize options and restore all settings to default values. 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Overlays 
Settings: Scripts 
Settings: Log Files 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Log Files 
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Conversion List 
A conversion list file is created before the actual reading, alteration, and writing of image files begins. The 
conversion tool will build a list of files based on the source of the images, and any filters that may be in 
effect. The list is a plain text file containing the fully qualified path and file name for each image to 
convert. This file can be used to resume conversion job that did not complete. 
 
Successful Conversions 
All image files that are successfully converted will be recorded in this file, two lines per image. The first 
entry is the original source file, and the second entry is the target path and name. Since files can be 
renamed through various means, the source and target image names may not always be the same. This 
file is used to determine the next file to resume a conversion job that did not complete. The resume option 
will not work without this file. 
 
Skipped Files 
Skipped files are those that are not converted, generally due to one of two things: the image file was 
eliminated by a filter restriction, or the image file could not be located (this can happen with image list 
sources). For each file that is skipped, a reason will be included along with the path and file name. 
 
Error Log 
The error log records any unexpected problems when attempting to apply conversion options to an image 
file. The most common source of an error is a decoding error, either because the image file is corrupted, 
or is using a format that is not currently supported by EzImage. Also keep in mind that if you intend to 
write to a specific file format that doesn’t support the color depth of the image, it will be recorded as an 
error (i.e. JPEG files can only be 256 gray scale or RGB color images). 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
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Settings: Filters 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Overlays 
Settings: Scripts 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Overlays 
 

 
 
On overlay is simply another image that is applied over top of each converted image. The image can be 
either any valid image file or an EzImage floating selection, or a text definition that will in turn be 
converted into an image. 
 
Setting the Position 
An overlay can appear at any of the 4 corners of an image, centered along the 4 edges, or be placed 
directly in the middle. 
 
Rotations 
You can rotate the overlay in 90° increments before it is merged with the image. 
 
Offsets 
The X and Y values are pixel offsets relative to one of the 9 positions you can specify. For edge and 
center positions, a negative value moves the overlay up or to the left. For right and bottom corners, a 
positive value will move the image inwards towards the center. 
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Opacity 
The opacity is a percentage that determines how transparent the overlay effect will be. Use a low opacity 
setting to allow more of the original image to appear where the overlay is positioned. 
 
Blend Mode 
You can use any of the standard color blend modes which affect the way the overlay colors will blend with 
the image colors. For more information on blend modes, click on this link. 
 
Defining a Text Overlay 
Click on this button to define the text properties for a text-based overlay. The properties are the same as 
those used by the Text Tool. 
 
Defining an Image Overlay 
Click on this button to define how to load an overlay and place it on the image. This dialog is the same 
one used to load images as floating selections. This allows for scaling and transparency options to be 
used. Note that scaling and transparency can only be applied to RGB or grayscale images (this also 
holds true for blend modes and opacity). 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Scripts 
Settings: Log Files 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Progress Status 
 
Note: This help topic describes the second step of the file conversion process, which involves reading 
and writing image files. The initial setup and configuration for a conversion is described in a separate help 
topic. 
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The conversion progress window has a very simple format, containing the following information: 
 

Number of images that will be converted. 
 

The total size of all images combined. 
 

Three counters, that track successful conversions, bad conversions (these files are rejected), and 
skipped images (these files are also rejected). Each of the three image counters relate directly to their 
corresponding log files. 

 
RGB Conversion for Color Adjustments and Transformations 
This option is not part of any conversion setting file, so when you check it, it will remain checked until you 
decide to uncheck it. When checked, all images will be converted to 24-bit RGB format if their source 
format is indexed color. 
 
This allows you to better perform image transformations, color adjustments, and overlays, since many of 
those options will not work properly on an indexed image. If you wish to save the image back to its 
original indexed format, you will need to apply a color adjustment, or the image will be saved as RGB if 
the output format allows for it. 
 
Click on the Begin Conversion button to start the job. You may click on Cancel at any time to stop the 
conversion. The Cancel option does not remove any images that have already been converted up to the 
point that you cancelled. 
 
Script and Non-Script Conversions 
If you specified a script file to be used in the conversion job, then you should be aware of the following: 
 

Each image is opened in a window in the main EzImage view, adjustments are made, and the image 
is saved. The window will then be closed. Non-scripted conversions never open an image in a 
window. 

 
You can’t have any open image windows when performing a script-based conversion. 

 
The overlay, transformation, and color adjustment options are disabled in the conversion settings, 
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since these options may conflict with equivalent methods in the script file. 
 
Conversion Priorities 
When performing conversions, there is a specific ordering of the method categories, which attempts to 
minimize image degradation. 
 

If in-place file renaming was specified, then the image files are renamed and the conversion job is 
done. If you wish to undo the rename job, use the appropriate selection for the conversion source in 
the settings window. 

 
The directory structure for the conversion job is created in the target path. This ensures that the 
proper folder paths are in place for the converted files before any time commitment is made to the 
actual image reading/alteration/writing steps. 

 
Renaming options are examined to see if it is necessary to create a different file name for the target 
image. 

 
If a script file is enabled, then the image is opened in a window, the script file is applied, the image is 
saved according to the output file format, and the image window is closed. The remaining steps do 
not apply to script-based conversions. 

 
If the image is indexed-color and the RGB pre-conversion option was checked, then the image is 
converted to RGB format. 

 
Color adjustments are applied. 

 
Overlays are applied. 

 
Transformations are applied. 

 
Color resolution changes are applied. 

 
The file is saved according to the output format settings. 

 
The log files are updated for each image in the source list. Make sure you check the counters for 
success, failure, and skips. The conversion tool will not stop if errors are encounter while processing 
images. The log files will contain the reasons as to why files are rejected. 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Overlays 
Settings: Scripts 
Settings: Log Files 
 
 
Top 
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File Conversion Tool, Color Adjustments 
 

 
 
Changing Color Bit Depth 
Specify a color depth from 1 to 8 bits per pixel, RGB (24 or 32 bits per pixel) or 256 level gray scale. Color 
depths of 1 to 6 bits are not supported by the Adaptive color reduction method. As you change bit depth 
in the dropdown list, the color limit value will reset to the maximum color limit available. It is recommended 
that you change color limits only after you have set the bit depth. 
 
Palette Choices 
Use an optimized palette for the best possible color reduction. The fixed, web, and Windows system 
palette apply a predefined set of colors that generally give poor results on any image with many subtle 
shades of different color hues. The external palette option allows you to color-reduce an image by 
applying a color palette file that you specify. 
 
If you specified an external palette for an indexed color reduction, then you need to provide a file 
reference. The conversion process will use the same palette for every image file by attempting to best 
match the colors using the appropriate reduction method. Note that the palette file option is not used for 
Adaptive color reductions. 
 
Adjustment Files 
You can apply color adjustments to all image files using one or more adjustment files. These files are 
created by their corresponding adjustment option in the EzImage main menu. Simply create the settings 
adjustments on any open image file, then save the settings to an adjustment file, which you can then use 
here. 
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Custom Color Limits 
You can set a lesser number of colors for an image reduction if you wish to reserve some color palette 
entries for system-related or other uses. Lesser colors may also result in better file compression for 
formats that support it, at the cost of less display quality. 
 
Related topics: 
 
Levels 
Hue and Saturation 
Color Balance 
Channel Mixer 
Channel Adjustment 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Transformations 
Settings: Renaming 
Settings: Overlays 
Settings: Scripts 
Settings: Log Files 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Renaming 
 
Renaming Collision Options 
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When the converted image file has a name conflict with one that already exists on the target path you can 
choose one of the following actions: 
 

Prompt: You will be given several options at the time the conflict occurs 
 

Don’t Convert: The file will be skipped, and placed in the skip log file if enabled 
 

Replace: The target file will be overwritten with the converted image 
 

Auto Rename: The image file will be renamed using a sequential number 
 
In-Place Renaming 
This option is used to rename image files without any other form of conversion. The rename takes place 
within the source path for each image, so there will not be a copy made of the file. There is an option 
called Rename Undo in the file conversion tool Source dropdown list to undo an in-place rename 
operation. When you choose in-place renaming, all other conversion options, including scripts, are 
disabled. The conversion tool simply becomes a method to rename files. 
 
Text Case Conversions 
 

 
 

The options in tab 2 allow you to change the case of the file name and/or file extension. The cap first 
letter option will capitalize the first letter of each word and make the remaining letters lower case. 
 
Search and Replace Options 
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There are several search and replace options available. All of them apply only to the name portion of a 
file. The file extension is never involved. Some options are purely replace level only, where you are 
adding or removing characters without searching for matching strings in the source file name. When you 
choose an option from the drop down list, the input fields will change accordingly to reflect the replace 
method. 
 
Method 1: Single String Search and Replace 
 
This search is replace method is NOT case sensitive. Two things to note about this operation: 
 

The operation only searches for the first occurrence of the string in the file. 
The operation can remove the search string text from the file name by leaving the replace string field 
blank. 

 
Method 2: Case Sensitive Search and Replace 
 
Same as method #1, but the search string is now case sensitive. 
 
Method 3: Remove Characters from the File Name 
 
Remove all occurrences of the characters you provide. For example, if you enter the string ABC, then all 
occurrences of all 3 characters will be removed. 
 
Method 4: Substituting Characters 
 
This method uses a 1:1 search and match operation. You place a search character in the Match edit field 
and a replacement character in the Substitute field. For every character you add to the match field and 
the substitute field, that pair will count as a second search and replace, third search and replace, etc. For 
example, if the match field contained the string “(_)” and the substitute field contained “[ ]”, then you 
would have: 
 

Left parenthesis replaced by left square bracket 
Underscore replaced by a space character 
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Right parenthesis replaced by right square bracket 
 
Methods 5/6: Insert/Append a String at the Start/End of the File Name 
 
These two methods place the string at the beginning or end of the file name. 
 
Methods 7/8: Preserve Characters at the Start/End of the File Name 
 
These two methods will retain a specified number of characters while removing all others. For example, 
using Preserve at Start with a value of 4 on the string ABCDEF.DAT will result in ABCD.DAT. 
 
Methods 9/10: Remove Characters from the Start/End of the File Name 
 
These two methods will remove the specified number of characters while retaining all others. For 
example, using remove at end with a value of 2 on the string ABCDEF.DAT, the resulting file name would 
be ABCD.DAT. 
 
Method 11: Remove Characters at a Specific Position 
 
For this method, you will specify a starting position from which characters are removed. For example, 
using a position of 3 with a count of 2 on the file ABCDEF.DAT, the result would be ABEF.DAT. 
 
Method 12: Insert a String at a Specific Position 
 
For this method, you will specify a starting position at which a string will be inserted. For example, using a 
position of 3 with a string of 123 on the file ABCDEF.DAT, the result would be ABC123DEF.DAT. 
 
Sequential Numbering 
 

 
 

You can choose this option to rename files using a sequential number and a file name string. The 
sequencing uses a start number and increment value, which are applied to every file involved in the 
conversion. You place # symbols as placeholders for the sequence number in the template string. The 
remaining characters are part of the file name. 
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Using Templates 
 

 
 
Insertion Character 
 
Wherever this character appears in the template, the corresponding character in the original file name will 
be left alone, becoming part of the new file name. It will insert the original file name character into the new 
file name. 
 
Deletion Character 
 
This character will force the corresponding character at that position in the template to be dropped from 
the new file name. It will delete the original file name character from the new file name. 
 
Substitution Character 
 
This character will force a substitution of the character that follows in the template. The original character 
in the file name is replaced by the substitution value. 
 
To add any additional text to the file name, just place any characters in the template which are not one of 
the 3 special characters. The text will be inserted in the new file name based on its position in the 
template mask. Note that file names that don’t have the same number of characters as there are in the 
template mask will not be renamed. 
 
Some examples are shown below, based on a directory of files that contain a date stamp in the name of 

the format TESTYYMMDD.dat, as in TEST991023.dat, TEST991024.dat, TEST991025.dat, 

etc. 
 
Template: ??????_??_??     Result: TEST99_10_23.dat 

 

Template: ????19??_??_??   Result: TEST1999_10_23.dat 

 

Template: IMG\\\\??????    Result: IMG991023.dat 
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Template: *F*I*L*E??????   Result: FILE991023.dat 

 

Template: TEST             Result: Nothing (special characters must total 

file name length, which is 10) 

 

Template: \\\\??*X*X??IMG  Result: 99XX23IMG.dat 

 
 
Click on Reset to disable all rename options and restore settings to default values. 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Overlays 
Settings: Scripts 
Settings: Log Files 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Resuming a Job 
 

 
 
In order to resume a conversion job, you must have the following two log files present: 
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The conversion list log (extension .LOG) contains the set of image files that are involved in the job. It 
is needed to determine how many image files remain that have not been converted. 

 
The successful conversion list (extension .LST) is the set of image files that have already been 
processed. The list is a double-line entry format, with the path and file name for source and target 
(converted) image files. This list is used to determine the last valid image file that was converted. 

 
Click on the Resume button and a check will be made against the current .LOG and .LST files defined 
based on the conversion profile that is in effect. If neither file can be located, you will unable to resume 
the conversion. 
 
Related topics: 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Overlays 
Settings: Scripts 
Settings: Log Files 
 
 
Top 
 
 

 
 
 

File Conversion Tool, Scripts 
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About Scripts 
Script files have an extension of .SCR and appear in subfolders of the Scripts folder, which is located in 
the EzImage installation path. You have to use the Browse button to set the file name, which will 
populate the other fields in this dialog window. 
 
Description 
The description is a short message that identifies what action or actions the script will perform. It will 
appear as a help message on the status bar of the EzImage main window. 
 
Palette Name 
The palette name is what appears in the scripts palette as the label on each button. Scripts are sorted 
alphabetically on the palette according to this name. 
 
Set Name 
The set is the folder name that the script belongs to. All script files must be organized so that they are 
located within subfolders of the Scripts folder. When creating scripts, you can place them into an existing 
set (folder) or create a new one. New sets will of course be created as a folder in the Scripts directory. 
 
Author 
The author field is optional information that can identify who created the script. 
 
You must check the Enable Scripting option to enable the script for playback against the converted files. 
Once a script is active, the transformation, color adjustment, and overlay options will be disabled, since 
they may conflict with similar operations that can be found in a script file.  
 
Related topics: 
 
EzImage Script Files 
 
File Conversion Tool 
Settings: File Types 
Settings: Filters 
Settings: Transformations 
Settings: Color Adjustments 
Settings: Renaming 
Settings: Overlays 
Settings: Log Files 
 
 
Top 
 
 

 
 
 

Image Selection Filter 
 
The slideshow script and image list editors allow you to create a selection of images based on pattern, 
size, and date filters. 
 

The search dialog window contains three tabs of options for pattern, size, and date-based filtering. 
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File Pattern and Comments 
 

 
 
File Patterns 
File pattern filters are equivalent to the older MS-DOS style wildcard-based file names. The filter consists 
of one or more wildcard strings that match to a single file name. The asterisk “*” character matches zero 
or more occurrences of any character, while the question mark “?” character matches one occurrence of 
any character. You must specify a filter string for both the file name and the file extension, separate by 
the period “.” character. To match on multiple patterns, separate them with a semi-colon character. 
 
This is contrary to Win32 (95,98,NT,XP) based wildcard conventions, so please be aware of the 

difference. If a file contains multiple periods, as in SAMPLE1.23.96.BMP, the file name portion would be 

SAMPLE1.23.96 and the extension would be .BMP. Do NOT use the asterisk (*) by itself to match all 

files (Use *.*). 

 
Comment Search 
Check this option to enable a search that includes comments assigned to images in an image list, or the 
text association assigned to images in a slide show script. 
 
Case-Sensitive 
Check this option to make the comment-based searches case-sensitive. 
 
Allow Partial Match 
If this option is checked, the search string can match against any occurrence within the comment. If the 
option is not checked, then the search string must match the comment word-for-word. 
 
Search String 
Enter a comment search string here. Ensure that you use upper and lowercase characters for case-
sensitive searches. 
 
 
File Size Filters 
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Include Files Sizes Smaller Than 
Enter a value according to the unit size displayed next to the input field. Depending on checked status of 
the Include/Exclude option, files with a size smaller than this will either be included or excluded from the 
conversion process. 
 
Include Files Sizes Larger Than 
Enter a value according to the unit size displayed next to the input field. Depending on checked status of 
the Include/Exclude option, files with a size larger than this will either be included or excluded from the 
conversion process. You can check one or both of the smaller and larger options. If you check both, then 
you will define an exclusion or inclusion size range, unless the Include Between option is checked. 
 
Include Between 
The Include Between option is used to filter all files between the smaller and larger file sizes. When this 
option is checked, the include/exclude size options are automatically disabled, as you will be defining a 
size range. 
 
Include/Exclude Sizes 
If you check this option, then all files with sizes larger or smaller than the size limits will be included in the 
conversion. With this option unchecked, all files with sizes larger or smaller than the size limits will be 
excluded. If the Include Between option is checked, then this setting is ignored. 
 
Changing the Unit Size 
Click on the labels to the right of the size input fields to use size units of Bytes, Kilobytes, or Megabytes. 
 
 
Date Filters 
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Date Based, Recent Days, Recent Months 
Date-based filters can be defined as a range of recent days, months, or by one or two specific dates. 
These options determine how to filter the image files by date. Note that time is not available with this filter. 
The smallest range of time supported is 24 hours. The date used is always the file’s last modification 
date. 
 
Recent Days/Months 
For recent days or months, enter the number of days or months that the filter will extend back to. For 
example, a value of 30 days will only include image files that were created/modified within the last 30 
days. 
 
Include Files Older Than 
Depending on checked status of the Include/Exclude option, files with a modification date older than this 
will either be included or excluded from the conversion process. 
 
Include Files Newer Than 
Depending on checked status of the Include/Exclude option, files with a date newer than this will either be 
included or excluded from the conversion process. You can check one or both of the older and newer 
options. If you check both, then you will define an exclusion or inclusion date range, unless the Include 
Between option is checked. 
 
Include Between 
The Include Between option is used to filter all files between the older and newer dates. When this option 
is checked, the include/exclude date options are automatically disabled, as you will be defining a date 
range. 
 
Include/Exclude Dates 
If you check this option, then all files with dates newer or older than the date limits will be included in the 
conversion. With this option unchecked, all files with dates newer or older than the date limits will be 
excluded. If the Include Between option is checked, then this setting is ignored. 
 
Date Input Format 
EzImage only recognizes date input in the format of: 4-digit year, followed by 2-digit month (leading zero 
must be included), follows by 2-digit day (leading zero required). The year, month, and day values must 
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be separated by forward slash characters. 
 
Click on Reset to restore all settings to default values (no pattern, no size filter, and no date filter). 
 
Related topics: 
 
Image List Editor 
Slide Show Script Editor 
 
 
Top 
 
 

 
 
 

Filling an Image 
 

 
 
This method will fill all or part of image with a color, pattern, or gradient. If a region selection is active, only 
the pixels within the region will be affected. If a floater is active, then only the floater itself will be filled. 
Otherwise the entire image is affected. 
 
Fill With 
Specify the color for the fill method using one of the options from this dropdown list. The Other color fill 
uses a color of your choice. The Gradient fill will use a range of colors between the Start color and the 
End color. The Pattern option will tile an image using center or left-alignment. The pattern source can be 
any valid image file. 
 
Blend Mode 
The fill color or pattern can be blended with the current image using a variety of blend modes. Refer to 
this link for more details on how the various blend modes work. Blend modes don’t work with gradient fills 



EzImage Reference – Version 1.05 

 

 Page 113 

 

(you can apply a gradient to a floating selection then blend that with the background image to get around 
this limitation). 
 
Opacity 
You can apply an opacity level to the fill using this option. An opacity level of less than 100 percent will 
blend part of the background image with part of the fill color or pattern. Gradient fills do not use an opacity 
level (you can apply a gradient to a floating selection then use the floater’s opacity to blend with the 
background image). 
 
Gradient Type 
There are several gradient types you can choose from. EzImage gradient fills use only one color range. 
For more complex gradient fills, you can use multiple distribution gradient fills stored as a script file. 
Distributed gradient fills tend to only work well with the Linear fill types. 
 
Gradient Distribution 
A distribution is used to apply a gradient fill to only part of the image, selection, or floating image based 
on a percentage of it’s width and/or height. Offsets are also based in percentage values, so that the 
distribution is independent of the image size. Click on this button to define the distribution and offset 
percentages. Note that this feature was only implemented for linear type gradient fills. 
 
You must check the Enables option to enable the distributed gradient-type fill. 
 
Start and End Colors 
For a gradient fill, click on the color swatches to define the start and end colors. Right click on the 
swatches to choose from 256 levels of gray. 
 
Selecting a Pattern File 
Click on the Pattern button to load a new pattern file. A small preview of the pattern file image is 
displayed in this dialog window. Pattern files can’t be scaled and always tile over the image at 100% size 
(you can convert a pattern file to RGB or gray scale, resize it, and save it as a new pattern fill file). Pattern 
files can be created in EzImage from region selections using the Select->Save Selections->To Pattern 
menu option. Pattern files created with this method create Windows Bitmap files stored in the Patterns 
folder of the application path. 
 
Center Align Pattern 
Check this option to align a pattern file so that the edge tiles of the fill are equally cropped on the 4 edges 
of the image. If this option is not checked, then first tile in the pattern will align with the upper left corner of 
the image. 
 
Distributed Gradients 
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You define the distribution for the gradient using a percentage of the current image (or selection) width 
and height. For example, an image that is 1024 by 768 pixels with a 50% horizontal and 75% vertical 
distribution will have a gradient applied to an area of 512 by 576 pixels. 
 
The offset of the distribution defines the upper left corner of the gradient fill. The offset is based on a 
percentage of the width and height of the current image (or selection). You can record multiple non-
overlapping distribution fills to a script file to achieve more complex gradients than the default single 
range method (this works well with Linear gradients, but not with the other types). 
 
Use the center align options to apply the distributed fill to the center of the image, leaving an equal border 
spacing to the top/bottom and/or left/right sides of the image. 
 
Click on Reset to restore the distribution settings to default values. 
 
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 
Clearing Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
 

 
Top 
 
 

 
 
 

Flipping Images 
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Use the Image->Rotate->Flip Horizontal option to mirror the image about an imaginary vertical line that 
runs through the middle of the image from top to bottom. 
 
Use the Image->Rotate->Flip Vertical option to mirror the image about an imaginary horizontal line that 
runs through the middle of the image from left to right. 
 
The image flip methods do not alter the pixel content in any way. 
 
Related topics: 
 
Rotating Images 
Shearing Images 
Resizing Images 
Cropping Images 
Adding a Border 
Auto Trim Tool 
Edge Deskew Tool 
 
Top 
 
 

 
 
 

File Operations 
 
EzImage provides access to some basic file operations when using any of the following editors/browsers: 
 

Image Preview Browser 
Image List Editor 
Thumbnail Browser 

 
There are 4 basic file operations that can be used: 
 

File copying from one path to another 
File moving from one path to another 
File deletion 
File renaming 

 
The first 3 operations are handled by Windows. Outside of specifying a target path for a copy or move 
operation, EzImage is not responsible for the remainder of the process. For file deletions, the selected 
images are sent to the Recycle Bin. If you accidentally deleted image files, your Recycle Bin properties 
will determine if the deleted files can be recovered. 
 
File renaming is done through EzImage. It uses a simple dialog window that can handle multiple image 
files: 
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You can use the radio button items to choose how to rename the file by extension, name, or both. Click 
on the Rename button to apply the name change to the file, or simply press the ENTER key after you 
have made the changes. 
 
If you have selected multiple files, then the next file in the selection will become available. 
 
Use the Next and Previous buttons to step through the file selection. 
 
Use the Enable Thumbnail option to display a small preview sample of the image. If you wish to see a 
larger version of the image, click on the View button (you can also double click the small sample 
thumbnail as a viewing shortcut). 
 
Related topics: 
 
Opening Image Files 
Image Preview Browser 
Image Lists 
Path Lists 
Thumbnail Browser 
Slide Show System 
Image File Properties 
 

 
Top 
 
 

 
 
 

Foreground and Background Color 
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The foreground and background color tool at the bottom of the Tools palette contains 4 separate click 
points: 
 

Foreground Color: This swatch sits above and slightly overlaps the background color. By left 
clicking on it, you can change the color using the Color Picker dialog window. By right clicking on it, 
you can access the Gray Level Picker dialog. The foreground color is used for most painting tools and 
some image-processing operations as a default fill color. 

 
Background Color: This swatch sits underneath the foreground color. Left and right clicking will 
access the color and gray level picker dialogs respectively. The background color is used for the 
eraser tool, clearing regions and images, and as a fill color for some image-processing operations. 

 
Exchange Colors: The double arrow icon is used to swap the foreground and background colors. 

 
Reset Colors: The small black/white icon in the lower left corner will reset the foreground color to 
black and the background color to white. 

 
Menu Shortcuts 
All 4 of these controls are assigned positions in the application menu, which allows you to bind any 
shortcut key using a custom keyboard template. 
 
Related topics: 
 
Color Sample Tool 
Color Picker 
Gray Level Picker 
 
 
Top 
 
 

 
 
 

Supported File Formats 
 
This topic provides details on the image file formats that are supported by the current version of EzImage. 
Depending on customer demand, more formats may be made available in future versions of the 
application. For each supported format, there may be various encoding formats, which are also described 
here. 
 
Unsupported Bit Depths 
EzImage does not currently support any images that use more than 32 bits of color or 256 levels of gray 
(gray scale format). If you attempt to scan or load an image using 48/64-bit color or 12/16-bit gray scale, 
an appropriate error message will be given. EzImage does not support images larger than 30,000 pixels 
in width or height. 
 
Unsupported Encoding Formats 
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While certain image formats may be supported by the application, there may be some encoding types 
within the format that are not supported. This will be indicated in this topic. 
 
Thumbnail and Image Preview Browser, File Conversion Tool 
These features of EzImage read file system folders to obtain lists of image files that are supported by the 
application. By default, all supported formats will be use to create file lists. The file filter dialog has a very 
simple format: 
 

 
 
For each supported file format there is a check box option. Place a check mark beside every file format 
you wish to include when building file lists for the aforementioned operations. 
 
Bit Depth Conversions 
Some formats store images using certain bit depths that are not directly supported in EzImage without a 
conversion: 
 

2 and 3-bit images are converted to 4 bits. 
5,6, and 7-bit images are converted to 8 bits. 
9-23 bit images are converted to 24 bits. 
25-31 bit images are converted to 32 bits. 
Any images over 32 bits are not supported. 

 
 
JPEG/JPE/JPG (JPEG Interchange Format) 
 
Supported Bit Depths: 
8-bit gray scale and 24-bit RGB 
 
Encoding Formats: 
JFIF (Normal), JTIF, EXIF 1.0, EXIF 2.0 
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Uncompressed, YUV 4:4:4, 4:2:2, 4:1:1 
CieLAB 4:4:4, CieLAB 4:2:2, CieLAB 4:1:1 
Progressive Scanning Supported 
 
 
BMP (Bitmap Format) 
Supported Bit Depths: 
1, 4, 8, 16, 24, 32 
Encoding Formats: 
Windows Bitmap Format (All) 
OS/2 Bitmap Format (1.x and 2.x) 
 
RLE Compression is supported for 4 and 8-bit depths 
 
Note that 16-bit images will be converted to 24-bit when they are loaded. EzImage does not supported 
writing of 16-bit BMP files. 
 
TIFF/TIF/MPT (Tagged Image Format) 
Supported Bit Depths: 
1, 2, 3, 4, 5, 6, 7, 8, 12, 16, 24, 32. 
Encoding Formats: 
RGB, CMYK, or YcbCr 
Uncompressed, EXIF, PackBits, CCITT, LZW 
 
Wavelet, CMP, and JBIG are not currently supported. 
 
PNG (Portable Network Graphics) 
Supported Bit Depths: 
1, 4, 8, 16, 24, 32. 
Encoding Formats: 
EzImage does not supported writing interlaced format 
 
PCD (Kodak Photo CD) 
Supported Bit Depths: 
8 and 24 
Encoding Formats: 
N/A 
 
This is a read-only format. 
 
FPX (FlashPix) 
Supported Bit Depths: 
8 and 24 
Encoding Formats: 
Uncompressed, Single Color, JPEG/JFIF 
 
PSD (Photoshop 3.0) 
Supported Bit Depths: 
1, 8 and 24 
Encoding Formats: 
N/A 
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PCX/DCX (ZSoft PCX) 
Supported Bit Depths: 
1, 4, 8 and 24 
Encoding Formats: 
N/A 
 
TGA (Truevision Targa) 
Supported Bit Depths: 
8, 16, 24, 32 
Encoding Formats: 
Uncompressed and RLE 
 
XPM (X Window PixMap) 
Supported Bit Depths: 
1, 8 and 24 
Encoding Formats: 
N/A 
 
PICT/PIC/PCT (Macintosh Pict) 
Supported Bit Depths: 
1, 4, 8, 16 and 24 
Encoding Formats: 
N/A 
 
SCT (Scitex Continuous Tone Format) 
Supported Bit Depths: 
24 and 32 
Encoding Formats: 
CMY 
 
SGI (Silicon Graphics Image Format) 
Supported Bit Depths: 
8, 24 and 32 
Encoding Formats: 
N/A 
 
IFF (Interchange File Format) 
Supported Bit Depths: 
1-8 and 24 
Encoding Formats: 
Uncompressed and RLE (Write Only) 
 
CUR/ICO (Windows Cursor and Icon Files) 
Supported Bit Depths: 
1, 4, 8, and 24 
Encoding Formats: 
N/A 
 
Note that you must use the Icon/Cursor import facility or the Multi-page extraction tool to access all 
available images that can exist in an icon or cursor file. 
 
GIF (Compuserve Graphics Interchange Format) 
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Supported Bit Depths: 
1 to 8 bits, indexed color or black and white only 
Encoding Formats: 
LZW Compression 
 
Related topics: 
 
Opening Image Files 
Image Preview Browser 
Image Lists 
Path Lists 
Thumbnail Browser 
Slide Show System 
Image File Properties 
File Operations 
 

 
Top 
 
 

 
 
 

Alpha Blending a Floater with an Image 
 
The alpha blend option will take an existing image, floater, and the contents of an alpha channel in a 32-
bit RGBA image and blend them together to generate a new image. The amount of blending is controlled 
by the gray level data in the alpha channel. Where a pure white pixel exists in the alpha channel, the 
floating image will be rendered at 100%. Where a pure black pixel exists, the background image will be 
rendered at 100%. Any level of gray in between will result in a blending between the floating image and 
the background image. 
 
The following steps are used to generate a vertical color fade on an image using the alpha blend method. 
 
Original Source Image: 
 

 
 
Convert the image to 32-bit RGBA format using Image->Color Mode->RGB with Alpha. 
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Choose Image->Channels->View Alpha to view the alpha channel. It will initially be blank. 
 
Choose Edit->Fill and use a Linear Top to Bottom gradient fill, using white as the starting color and black 
as the ending color. The alpha channel will appear as follows: 
 

 
 
Choose Image->Channels->View All. 
 
Select the entire image as a region using Select->All. 
 
Create a floating selection that is equal to the original source image using Floater->Make from 
Selection. 
 
Choose Image->Color Mode->Gray Scale. This will convert the floating image to gray scale format with 
affecting the original background image. 
 
Choose Floater->Alpha Blend to merged the background color image and floater gray scale copy using 
the alpha channel gradient fill as a blend mask. The top of the image will consist of mostly floater pixels 
(gray scale floater) and the bottom of the image will consist of mostly color pixels (background color). 
 
Alpha Blended Image: 
  

 
 
 
Related topics: 
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Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
 

 
Top 
 
 

 
 
 

Creating a Floater from the Alpha Channel 
 
This option is available from the menu as Floater->Create from Alpha. To use it, the image must be in 
32-bit RGBA format with some active pixel data in the alpha channel. If the alpha channel is completely 
blank (all black pixels), then the method will fail. 
 
Creating floaters from alpha channels provides a flexible method to create floater masks using the 
channel as a basic work area. While viewing an alpha channel, you are free to use most image-
processing and painting tools, since the channel is basically a 256-level grayscale image. The 
convenience of this channel is that it maps directly to both the gray-level formats of brushes used for 
painting and the mask layer for floating images. 
 
When using this method, the resulting floater will have the same characteristics as a shape or text floater: 
there will not be any image layer associated with the floater. The floater will contain a grayscale mask, 
with an arbitrary fill color assigned to it. As with text and shape floaters, ones created from an alpha 
channel will use the foreground color as the default fill color. You can change this color by simply 
choosing one from the color picker and the foreground color in the Tools palette. 
 
Original Source Image: 
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Alpha Channel Contents: 
 

 
 
Floater Created from Alpha: 
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Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste, and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 

 
Top 
 
 

 
 
 

Floater Masks and Alpha Channels 
 
Floaters are created with image and mask layers. Mask layers are something that you don’t really see, 
since they only exist to determine transparent area in non-rectangular shapes. Floaters have several 
restrictions imposed on them when using certain image processing operations: 
 

You can’t use a painting tool on a floating image. In fact, you can’t use a painting tool while a floater 
is active. 

 
Because of the mask layer, floaters can’t be placed in the clipboard as a Device Independent Bitmap 
(DIB), accessible to other applications. You must paste a floater into an image, create a region 
selection and choose Edit->Copy to create a DIB image in the clipboard. 

 
The mask layer can’t be affected by any image processing method. For example, if you apply a 
Gaussian blur filter to a floater, the edges of the floater will not be blurred, since the mask determines 
the opacity of all pixels in the floater. To blur a floating image including its edges, you need to create 
a mask in a alpha channel, apply a Gaussian blur, and render the alpha channel as a floater with the 
image pixels. 

 
The outline that makes up a mask in a floater can’t be adjusted. The options to swap floater masks 
with alpha channels allows you to change the gray level for each pixel in the mask, but you will not be 
able to affect any pixels outside the original outline of the floater. In effect, you can use an alpha 
channel to reduce the size of a floater mask, but not increase it. 

 
Mask to Alpha 
The Floater->Mask to Alpha menu option only applies to 32-bit RGBA images with an alpha channel. It 
will copy the mask that is currently being using by the floating image into the alpha channel. You can view 
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the alpha channel and make adjustments to this mask, and then replace the original mask with a modified 
version, or use the mask to generate a new floating image. 
 
Note that if you leave the floater active when viewing an alpha channel, it will be converted to gray level. 
This is normally not a desirable effect. If you wish to edit the mask of a floating image, make sure you 
place it in the clipboard first using Edit->Cut. Make changes to the mask in the alpha channel, then use 
Edit->Paste. The floater will be placed back onto the image in the same position to keep it aligned with 
the mask in the alpha channel.  
 
Alpha to Mask 
This Floater->Mask from Alpha option will transfer the alpha channel contents into the existing mask of 
the floating image. Be aware that the floating image does not have any valid image information beyond 
the boundaries defined by the original mask. For example, an elliptical floater does not have any image 
outside of the elliptical area of its mask. When transferring the alpha channel to the floater mask, any 
alpha channel data that falls outside of the original mask shape will be ignored. You can only alter the 
mask data in the alpha channel as defined by the original mask outline. 
 
Note that the mask for any floater determines the level of transparency as it applied to antialiased edges. 
If you replace a floater mask that has this characteristic, you may lose the antialiased effect, which can 
look unpleasing. The following example shows the effect of altering a floater mask that results in loss of 
the antialias effect. 
 
Original Image and Floater: 
 

 
 
Floater Mask in Alpha Channel: 
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Conical Gradient Fill Applied: 
 

 
 
Result of Replacing Floater Mask with Alpha Channel: 
 

 
 
Floater mask edits in an alpha channel tend to work well with masks that initially are not antialiased (pure 
white).  
  
Related topics: 
 
Text Tool 
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Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Alpha Blending with an Image 
 

 
Top 
 
 

 
 
 

Floaters: Cut, Copy, Paste and Stamp 
 
Floaters and region selections both store image information in the Windows clipboard. In the case of 
regions, the information is stored in generic format called a Device Independent Bitmap (DIB). This format 
is accessible to any Windows application that works with bitmap images. 
 
Floaters are stored in a format that is only accessible to EzImage. This is due to the fact that a floater 
contains two layers of pixel information: The mask layer that defines transparency in non-rectangular 
shapes, and the image layer that contains the color information for the complete bounding rectangle of 
the floater shape. 
 
The Cut, Copy, and Paste methods in the Edit menu are shared for both DIB and floater format images. 
For the Cut and Copy methods, a floater is placed in the clipboard only if it is active in an image. If you 
have created a region selection only, the Cut and Copy methods place a DIB format image in the 
clipboard. 
 
The Paste method generates a floater in the current image. The type of floater generated depends on the 
clipboard contents. For DIB format images, the floater will always be a rectangle with no mask layer. DIB-
based floaters can not be transformed using operations such as resize and rotate. For floater-based 
images in the clipboard, the floater will be pasted with a mask layer and optionally an image-color layer 
(text, alpha channel, and shape floaters have no image color layer). 
 
When both DIB and floater formats exist in the clipboard, EzImage will choose the floater version first, 
since it contains the mask information that a DIB format lacks. However, it may be desirable to paste the 
DIB image, especially if it was placed in the clipboard by another application. You can use the Edit-
>Empty Clipboard menu option to remove the floater from the clipboard and expose the DIB format to 
EzImage. 
 
When a floater is pasted from the clipboard, its position is determined based on the original source of the 
image. If the image is in floater format and was copied into the clipboard from the same image window, 
then it will be pasted in the position where it was originally located. Otherwise the image is pasted so that 
it will be centered within the image window. 
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Floater Paste and Floater Stamp 
If you look at the Floater menu, you will notice two options named Stamp Floater and Paste Floater. 
These methods do not use any images stored in the clipboard. They work with the active floater in the 
image. If a floater is not present, then the methods will have no effect. 
 
The Paste Floater option will paste a floating image at its current position into the background image. The 
floating image will be deleted after the paste has been completed. If you undo the paste using Edit-
>Undo, the image will be restored, but the floater itself will still be unavailable. If you wish to paste a 
floater and keep it available for future use, save it to a file or the clipboard first. 
 
The Stamp Floater option will paste a floater at its current position but leave the floater active. This type of 
operation can’t be undone with the Edit->Undo method. You can use the Edit->Temporary Image 
option to create an image snapshot before stamping floaters if you wish to create specific undo points. 
Workspace files will also save the current state of any image window. 
 
Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
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Creating a Floater from the Clipboard 
 
The Edit->Paste menu option will always generate a floating image from the content of the Windows 
clipboard. If you wish to create an image directly from the clipboard, use the File->New option and 
choose Clipboard as the image source. 
 
Note: You can’t paste a floater into an image that already has an active floater. EzImage uses a single 
floating image layer. 
 
Clipboard Formats 
Two image formats can be stored for copy, cut and paste operations accessible through the Edit menu: 
Windows Device Independent Bitmaps (DIB) and EzImage floaters. The latter image format is only 
accessible within this application. 
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The DIB format is always pasted as a rectangular image in EzImage, with no transparent areas. The 
floater itself will not contain a mask layer, which means that you will not be able to apply image 
transformations such as resize and rotate. If you wish to manipulate a DIB clipboard image as a 
floater with a mask layer, you should paste it into a new image and save it to a file. When loading a 
floating image from a file, mask layers are added automatically. 

 
The floater image format contains both the image and mask layer in the clipboard, accessible only by 
EzImage. The only way to place this format on the clipboard is to use the Edit->Cut or Edit->Copy 
menu options within the application, while a floater is active. If you use these options with just an 
active region selection, then a DIB image will be placed in the clipboard (if no region is selected and 
no floater is active, the entire image is placed in the clipboard). 

 
Clipboard Priority 
Since two formats can exist at the same time, the floating image format takes higher precedence over the 
DIB format. If you need to access the DIB format, use the Edit->Empty Clipboard menu option to 
remove the floater. 
 
Floater Position 
When pasting a floater from the clipboard, it will be positioned in the image based on the owner of the 
original floater. If the floater was created from the same image, then it will be positioned at the exact 
position where it was when you place it on the clipboard, provided that you did not change the dimension 
of the image. Otherwise, the floater will be positioned in the center of the current image window. 
 
Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 

 
Top 
 
 

 
 
 

Regions and Floating Images 
 
Note: This help topic is identical in content to the Region/Floater section in the Getting Started topic. If 
you have read through that topic, you may skip ahead to the related links for other region-specific help. 
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EzImage works with parts of an image using the concept of Regions and Floaters. 
 
Regions 
Regions are selections of an image that do not contain any image data. They contain one or more areas 
that are outline paths that appear as animated black and white dashed lines, and are commonly referred 
to as 'marching ants'. 
 
A region can be a simple rectangle or a shape of any complexity imaginable. Various selection tools allow 
you to create rectangular, elliptical, freehand, polygon and other region types. When working with a 
region, no pixel information is altered. 
 
Paint and Imaging Processes Affected by Regions 
Many image adjustment and painting operations in EzImage will be restricted by the presence of a region. 
For example, applying a color fill on an image with a region will only have the region area affected. All 
painting tools are confined to work within a region selection only. 
 
A Region Selection: 
 

 
 
 
Floaters 
Floaters represent a second image layer which rests on top of the normal background image. A floater 
can be created by any of the following methods:  
 

Pasting an image from the Windows clipboard. 
Dragging a piece of an image using the Move Selection tool. 
Dragging a piece of one image on top of another image. 
Loading a floating image from a file. 
Creating a floating image from the gray level pixel data in an alpha channel. 
The Text Tool creates text as a floating image by default. 
The Shape Tool creates the shapes as floating images.  

 
Floaters can be placed onto the clipboard or saved to a file using a special format. Once a floater is 
active, you are free to drag it around the background image or perform most types of image processing 
operations on it (you may NOT apply a painting tool to a floating image). Modifying a floating image does 
not affect the underlying background image while it is active.  
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While a floating image is active, there are a few things that you can't do:  
 

Save the image to a standard file format (you can only save the image as a Work Space file if a 
floater is active). 

 
Resize, rotate, or perform any type of size adjustment to an image. The shear, rotate, and resize 
options apply to the floater if you choose to apply one of those methods. 

 
Use any of the image painting tools.  

 
There are 3 methods by which to blend a floater with the background image:  
 

To paste a floater into the background image, use the Paste option in the Floater menu. The floater 
will be deleted after you paste it.  

 
To paste a floater without deleting it, choose the Stamp option.  

 
To blend a floater with an image using an alpha channel gray mask, create a gray level mask in a 
RGBA format image's alpha channel, and choose the Alpha Blend option from the Floater menu.  

 
The blend, opacity, and inversion options available in the Move Selection tool control how to blend the 
pixel colors of the floating image with those of the background image.  
 
A Floating Image Selection: 
 

 
 
 
Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
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Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 

 
Top 
 
 

 
 
 

Loading and Saving Floaters 
 
Unlike region selections, which are always saved as rectangular areas with possible background fills 
(irregular shapes), floaters are saved along with their mask information in a special file with an extension 
of .FLT. The default location for these images is the Floaters folder in the application path. 
 
Loading Floater Files 
 

 
 
 
The load option is available from the menu as Floater->Load Floater. If you wish to load a recent floater 
format file (.FLT files only), you can use the Floater->Recent Files list. 
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Floating images can be created from two different sources: 
 

Regular image files of any type supported by EzImage. 
 

Floating image selections that were previously saved to file. These files are generally located in the 
Floaters folder in the EzImage application path with an extension of .FLT. Unlike regular image files, 
this file type contains the mask information used to define transparent areas for non-rectangular 
shapes. 

 
Browsing for a File 
You can type in the path and name for an image to load, or use any of the following alternate methods: 
 

Click on Images to load a regular image file type from the last accessed path name. 
 

Click on Floaters to load a floating image file from the Floaters folder. 
 

Use the dropdown list to choose from recently accessed image files. 
 
Once you select an image, you can click on Preview to load a thumbnail preview sample in the small 
window. The dimensions, bit depth, and file size of the image will be shown below the file dropdown list. If 
you have selected a floating image file format that is non-rectangular, then the transparent areas will 
appear in the preview window with a black background color. 
 
Scaling Images 
Check the Constrained Size option to limit the maximum width and height for the image. The aspect ratio 
of the image will be preserved with the width and height not exceeding the limit values you provide. 
 
Check the Percentage option to scale the image to a smaller version while retaining the original aspect 
ratio. The percentage must fall between 1 and 100 percent. Both scaled and constrained image resizing 
will only work with grayscale or RGB color formats. 
 
Transparency Options 
The transparency options are used to load an image with pixels eliminated that match a color designated 
as the transparent one. With the upper-left and lower-left options, the color will be chosen based on the 
color of the pixel at one of those two locations. The specific color option allows you to set transparency 
based on a color of your choice. 
 
With the edge transparency option, any pixels matching the transparent color that remain enclosed inside 
the image, surrounded by non-transparent pixels, will not be considered transparent. 
 
The Load Mask option bypasses any of the transparent options, and loads the image as a 256 level gray 
scale mask. This is similar to creating a complex shape using the shape tool, except that the shape is 
defined by the intensity levels in the image itself. Once you have loaded an image as a mask, you can fill 
it with any color, or fill it with the pixels of the image the mask resides on top of. An image mask does not 
work on indexed-color images. 
 
File Conversion Overlays 
The image overlay option in the File Conversion tool will also use this dialog to place an image onto each 
converted image. 
 
Saving Floater Images 
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Choose the Floater->Save Floater menu option to store a floater in .FLT format in the Floaters folder of 
the application path. You will be prompted for a name and description for the floater. Once a floater is 
saved, it will be added to the Recent Files list in the Floater menu, or from the Floaters browse button in 
the floater load dialog window. 
 
Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 
 
Top 
 
 

 
 
 

Creating a Floater from a Region 
 
There are three ways you can create a floating image from a region selection: 
 

Create a region using any of the selection tools, choose the Move tool, click anywhere inside the 
region with the mouse, and drag to a new position. The region will remain intact, but hidden from view 
since EzImage does not allow a region and floater to exist at the same time for the purposes of 
manipulation. If the Move option was checked in the optional panel for the Move tool, the pixels within 
the region area will be filled with the background color. 

 
Choose Floater->Make from Selection from the application menu. This will create a floating image 
in place where the region currently resides. The effect of choosing this method is that the region 
selection will disappear and no image pixels will have changed. You will not see the floating image 
since it hasn’t been moved from the position where the region is. 

 
Create a region in one image and use the Move tool to drag the floater on top of a second image and 
release the mouse button. This will transfer the floater from the first image to the second image. The 
drag and drop procedure between images is always to move a floater, not copy it. If you wish to have 
a floater in one image and have a copy in a second image, use the Edit->Copy and Edit->Paste 
options from the menu. 

 
Related topics: 
 
Text Tool 
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Shape Tool 
Move Tool 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 

 
Top 
 
 

 
 
 

Floater Cancel and Undo 
 
Most image-processing operations that apply to an image can also be applied to a floater. As such, the 
basic operation that applies to an image, such as Image->Resize will work with both the floater and the 
image. The Edit->Undo option can be used to undo an operation that was applied to a floater. 
 
However, the Floater->Cancel Floater option can’t be reversed. When you cancel a floater, the memory 
associated with the image and mask layers is discarded. If you wish to reuse a floater in the same image 
or another image, it should be saved to the clipboard or to file. When saving a floater to the clipboard, the 
Edit->Paste option will restore it in the same position within the image when it was saved.  
 
Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 
 
Top 
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Gaussian Blur Filter 
 

 
 
The Gaussian blur filter will blur or smooth an image or image area based on the size of a neighborhood 
around each pixel. As you increase the size of the neighborhood the blurring effect will also increase. If 
you apply this effect to a floating image selection, the image will blur, but not the mask that defines the 
edges of the floater. Values can range from 0.1 to 60.0 in .1 value increments. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
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Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Average Filter 
Median Noise Reduction 
Motion Blur 
Sharpen and Blur 
Unsharp Mask 
 

 
Top 
 
 

 
 
 

Gray Level Picker 
 

 
 
This simple dialog allows you to choose an RGB color that corresponds to one of 256 shades of gray (all 
Red, Green, and Blue values are equal). It is a much easier color picker to work with when processing 
gray scale images. 
 
The gray level swatch contains 256 shades of gray. Click anywhere in the swatch or drag the slider arrow 
to set a new gray level. The small square color swatch on the left is the original color (in gray level), and 
the square on the right is the new gray level. Click on the left square to reset the gray level back to the 
original value. 
 
Use the numeric input field to enter a gray level value. The cursor keys can be used to increment and 
decrement this value. 
 
Related topics: 
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Foreground/Background Colors 
Color Sample Tool 
Color Picker 
 

 
Top 
 
 

 
 
 

Gray Scale Mode 
 
The Image->Color Mode->Gray Scale menu option will convert any image to 256-level gray scale mode. 
 
If the source image is 24 or 32-bit RGB format, the intensity levels of the three channels will be combined 
to make a gray scale image. 
 
If the source image is indexed color, the palette will be remapped to an ordered gray scale format and the 
pixel colors will be adjusted accordingly. 
 
Note that there are three types of gray scale images that can exist: 
 

Ordered gray scale images use a palette that has black as the first color and white as the last color, a 
sequence which appears as (0,0,0   1,1,1  …   255,255,255). The palette still contains RGB color 
values, but the red, green, and blue values are all equal to each other. 

 
Inverted gray scale images use white as the first color and black as the last color, as in (255,255,255   
254,254,254   …   1,1,1  0,0,0). 

 
Unordered gray scale has the 256 gray level RGB values in a random palette pattern. 

 
EzImage only considers an image to be gray scale if the palette is ordered. This is due to the fact that 
images are processed at the pixel level, not at the palette level. For example, if a pixel has an intensity 
value of 34 (there is only one channel in a gray-scale image), then the color value for this pixel is 
(34,34,34), which is a dark gray. If the palette is ordered, then the pixel color would map to palette 
position 34, which would in turn contain the RGB color of (34,34,34). For an inverted or unordered palette, 
the RGB value at position 34 would not correspond to the same gray level. 
 
Re-mapping to an Ordered Palette 
You can convert an inverted or unordered gray scale image to ordered format by simply choosing the 
gray-scale mode menu option. It will always result in an ordered palette being created. 
 
Using the Channel Mixer 
The channel mixer has an option to create custom gray scale images by using different percentages of 
the red, green, and blue channels to form the gray-level pixels. There are many different opinions on the 
choice or color channel ratios that are used to make a gray scale image. With the channel mixer, you can 
basically create a template file and use that as a means to create a gray scale image. 
 
Other Gray Scale Formats 
Any image with less than 8 bits per pixel is not considered to be gray scale, even if the palette is ordered 
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with gray level RGB values. 
 
Images that contain 12 or 16 bits of gray (4096 and 65,536) level information are not supported in this 
version of EzImage. 
 
Related topics: 
 
Indexed Color Mode 
RGB Color Mode 
Halftone Conversion 
Threshold Conversion 
Channel Separations 
Alpha Channels 
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Halftone Conversion 
 

 
 
The halftone method converts an image with any bit depth to halftone format, with a specified pattern 
rotation. A halftone image is a 1-bit black and white format that has been dithered for printing or display. 
 
Halftone Type 
This option determines the dot pattern type used to create the halftone image. 
 
Rotation Angle 
Enter an angle by which to rotate the halftone dot pattern. Use the clockwise or counter-clockwise options 
to change the direction of rotation. 
 
Size of Grain 
This is the size of the pattern that will make up the halftone image. For display and print type halftone 
conversions, this value will be ignored. 
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Previewing Image Adjustments 
Click on the Preview button to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Indexed Color Mode 
RGB Color Mode 
Gray Scale Mode 
Threshold Conversion 
Channel Separations 
Alpha Channels 
 

 
Top 
 
 

 
 
 

The Popup Quick Help System 
 
The popup help system provided very brief descriptions about specific controls that appear on most 
windows. The term ‘control’ refers to almost any component in a window including: 
 

Buttons 
Check Boxes 
Radio Buttons 
Labels 
Drop Down Lists 
Text Edit Fields 
Progress Bars 

 
Popup help is tied to the right click of the mouse button. For any control you see in window, you can 
simply right click and if help is available for it, a small window will appear at the click point with a brief 
description of what the control relates to. Not all controls will return popup help. Some controls, such as 
text input fields, using the right mouse button for Windows-related functions. EzImage provides labels to 
associate with drop down lists, text edit fields and some other basic controls that can’t directly use a right 
click for popup help. Simply right click on the description label. 
 
A simple example of this popup help system can be shown by right clicking on the Text Tool in the Tools 
palette. The popup help window appears below: 
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Popup Help Settings 
The general preferences contain a group labeled as Tooltips. The tool tips refers to the fact that the 
popup help system is based on the general look-and-feel of Windows tool tips that appear when you 
move the mouse over controls on a window. You can set the background color, text color, font and size of 
the popup help text. Note that using a larger point size can cause popup help windows to run off the 
visible screen area on systems using a lower display resolution. If the popup help windows are too large 
for your screen display, reduce the font size. 
 
Related topics: 
 
Menu Help Mode 
Window Level Help 
Key Reference Help 
 
 
Top 
 
 

 
 
 

Menu Help Mode 
 
This help system is provided for any windows that have a menu bar with a Help menu. This includes the 
main EzImage view. To activate this help mode, choose the Menu Help Mode option from the Help 
menu. The example below is from the Thumbnail Browser menu: 
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Once you activate menu help mode, all menu option selections will result in the Popup Context Help 
window being displayed at the mouse cursor position: 
 

 
 
To deactivate menu help mode, simply go back to the Help menu and select the help mode option to 
uncheck it. 
 
Related topics: 
 
Popup Context Help 
Window Level Help 
Key Reference Help 
 

 
Top 
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Window Level Help 
 
Window level help refers to the general help system file based on the current active window. To view the 
help topic for a window, simply press F1. With the exception of the main EzImage view, almost all 
windows will show the appropriate help topic. Pressing F1 from the main EzImage view will show the help 
content window for the entire application. 
 
Related topics: 
 
Popup Context Help 
Menu Help Mode 
Key Reference Help 
 

 
Top 
 
 

 
 
 

Key Reference Help 
 
Key reference help is available from the key reference dialog window. Choose Help->Key Reference 
from the main menu to view this window. 
 
Select any item in the in the reference list and double click on it, or click on the Help button. This will 
show the general help topic associated with the item. The key reference help basically provides a 
convenient method to access the EzImage help system by each item that appears in the main application 
menu. 
 
Note that not items listed in the list will have a help topic associated with it. 
 
Related topics: 
 
Keyboard Reference 
 
Popup Context Help 
Menu Help Mode 
Window Level Help 
 

 
Top 
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Hue and Saturation 
 

 
 
This method allows you to adjust the saturation, hue, and luminosity of an image, using a general 
adjustment that affects all pixel data or a part of an image based on a hue range restriction. 
 
Hue Adjustment 
You can shift the hue values from –180 to +180 degrees in one-degree increments. A value of 0 
represents no change. 
 
Saturation Adjustment 
Saturation ranges from –100 to +100 percent. At –100, the image will be completely absent of all color. 

 
Lightness 
Lightness adjusts the overall luminosity of the image. Drag the slider to the right to increase the overall 
brightness of an image. 
 
Restrict Hues 
Check this option to limit the range that an adjustment will be applied to. Set the hue midpoint for the 
range using the lower slider, or use the button with the eyedropper icon to pick a pixel color from the 
thumbnail preview window. 
 
Left and Right Range Leveling (Restricted Hues Only) 
The Left and Right values determine a range of hues (in degrees) that smooth out the transition for the 
adjustment. Using smaller values will result in more banding of the image hues that border the range 
limits. 
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Range Extent (Restricted Hues Only) 
This is the range of hues that will be affected by the color adjustments. Colors around this range will be 
effected less using a smoothing transition, as determined by the Left and Right values. The range is in 
degrees. 
 
Restricted Hue Midpoint 
The midpoint value determines the hue at which 100% of the color adjustment is applied to. The entire 
range in the restriction around the midpoint will also receive a 100 percent color adjustment, after which 
the image colors will be effected to a lesser degree, based in the Left/Right transition range. You can set 
the midpoint using the button with the eyedropper icon or the lower slider. 
 

Click the  button to set the midpoint for a range restriction to a primary color value. 
 

Click the  button to enable dragging of the thumbnail preview window.  
 

Click the  button to set the midpoint for a hue restriction range based on a sample color point that you 
select with the left mouse button in the thumbnail preview window. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Loading and Saving Settings 
Most adjustment operations in EzImage provide the ability to load and save settings using an adjustment 
file. The adjustment file is specific to each operation, and is identified by a unique file extension. These 
files are by default placed into the User folder of the application path. Adjustment files not only provide a 
convenient method by which to apply the same adjustments repeatedly to several images, but they are 
also used for: 
 

Color adjustments with the File Conversion tool. 
 

Color adjustments applied to printed thumbnail image sheets. 
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Embedding in script files when writing script files outside of the recording process. 

 

For the Hue/aturation adjustment process, the adjustment file extension is .HUE. Use the  and  
buttons to load and save adjustment files. 
 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Resetting Adjustment Values 
For operation windows that have a Reset button, you may use it to restore all settings to default values. 
 
Related topics: 
 
Levels 
Brightness and Contrast 
Color Balance 
Channel Mixer 
Channel Adjustment 
Equalization 
Image Inversion 
Stretch Intensity 
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Using the Preview Browser 
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The preview browser provides an alternate method to view and open image files to the common file open 
dialog. This option is available from the Browse menu and can be used as a substitute for the File-
>Open method by setting the appropriate option in the general preferences. 
 
The browser window is comprised of the following: 
 

The current folder path is shown in the window title bar. EzImage retains the folder and file name 
when you close the application, so that any time you come back to the browser, the folder and file 
name will automatically be re-selected. 

 
A menu bar across the top contains all of the available browser options. 

 
A folder tree occupies the upper left corner of the window. 

 
A file list appears below this. You can drag the divider bar between these two areas to repartition the 
vertical space for the folders and files. 

 
The remainder of the area on the right side of the window is for the image preview. Since the browser 
window is resizable, a larger window will result in more preview area. You can drag the vertical 
divider to repartition the folder/file and preview areas. The quality of the preview image (which also 
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affects the rendering speed) can be adjusted in the application preferences. 
 

The status bar at the bottom contains some basic information: Sort order of the files, total images in 
the current folder, selected images, and a help/hint message area that also shows the file size, 
dimensions, and bit depth for a selected image. 

 
Opening Images 
Use the Open Selected option to open all selected images in their own windows. When all images have 
been opened, you will be returned to the main EzImage view. There is a limit on the maximum number of 
images that can be opened at one time (there is no limit on the number of image windows in EzImage, 
this just applies to the various Open Image methods). 
 
An option in preferences allows you to assign an external application to open an image file. If that option 
is enabled, then only one image can be opened, and will be opened by the application assigned to the 
image file type according to the Windows registry. 
 
You can also double click on any image to open it. 
 
Copying to the Clipboard 
Use this option to copy the selected image to the Windows clipboard as a device independent bitmap 
(DIB), where it will be accessible to other applications. 
 
File Copy, Rename, Move, Delete 
The file delete option will send all selected image files to the Windows Recycle Bin (the actual deletion of 
files is determined by the properties you have set for the recycle bin). 
 
The copy and move options use the services of Windows to perform the actual operations - EzIMage is 
not in control of file copying or moving. 
 
File renaming is done through EzImage using a simple and intuitive dialog that allows for multiple files at 
one time. 
 
File Properties 
The image file properties dialog provides several pieces of useful information about image files, including 
format, compression, dimension, size, printing resolution, and comments. You can select multiple image 
files at one time and step through the properties of each one. A small thumbnail viewer and file marking 
system is also included in this dialog window. 
 
Refresh 
The refresh options depend on the nature of the viewer that is currently displayed. Generally, it indicates 
that the current folder of files should be reread and any image display information updated. 
 
General Preferences 
This option will present the tabbed EzImage preferences window. Depending on the current window being 
displayed the default preference tab will be set according to the properties that relate directly to it. 
 
Thumb Mode 
This option will switch the viewer from its current window to the thumbnail image viewer, while retaining 
the exact same folder and image file that is currently selected. This allows you to easily switch between 
different viewers without losing track of which image file you are currently positioned at. If the thumbnail 
viewer is currently locked in full database browse mode and the preview path contains no thumbnail 
images, then the thumbnail viewer will not use the preview browse folder (it will reset to the desktop path). 
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Gridlines 
This option will toggle the display of dividing lines between image entry rows and columns in the file list 
view. 
 
Reset Area Sizes 
Most viewers in EzImage are sizeable windows containing panes of information that can be resized, such 
as dividing the window between image area and file list area. All of these size and position settings are 
permanently saved when you close the application. In the instance when you change screen resolution to 
a lower dimension, some of the information may be off the screen. Use this option to reset all window 
pane positions to default values. 
 
Show Details 
Select this option to toggle the visibility of file sizes and dates in the file list window. 
 
Hide Selected/Show Hidden 
Use the hide/show selected items option to temporarily hide the selection or redisplay what was 
previously hidden. The image files are not deleted or altered in any way. 
 
Setting a Sort Order 
The sorting options apply to all image browsers. For example, setting a file size sort option in the preview 
browser will apply the same ordering to the thumbnail browser and any of the other ones in EzImage. The 
sort order is saved when the application closes. 
 
Adding to a Slide Show 
Use the Add to Slide Show option to add the selection to the current slideshow list. If no images are in 
the list, one will be created using the current slideshow preferences as the template for the script 
playback. There is a current limit of 10,000 images per slideshow script. Note that duplicate images are 
allowed in a slideshow script (you can remove duplicate entries with the script editor). 
 
The Add Everything option will add every image file in the current subfolder and all subfolders to the 
active slideshow list. The addition process will stop when all files have been accounted for in the folder 
tree, or when the 10,000-image limit has been reached. 
 
Use Clear Slide Show to remove all entries from the active script. 
 
Adding to an Image List 
The options in the Image List menu are identical to the ones in the Slide Show menu. The only 
exception is that an image list has no size limitation other than available memory. 
 
Add to Path List 
This option will add the current folder path name to the active path list. Path lists are used to create a 
Favorites list or an image source for the File Conversion tool. 
 
Favorites List 
Use the options in the Favorites menu to add path names to a list that can be used as a quicker method 
for accessing your favorite image folders. The path list can contain up to 100 entries and be sorted or 
unsorted. By default, path names are added to the end of the list in unsorted order. A general preferences 
option can be enabled to automatically sort the path list when you add new entries. 
 
Related topics: 
 



EzImage Reference – Version 1.05 

 

 Page 151 

 

Supported File Formats 
 
Opening Image Files 
Image Lists 
Path Lists 
Thumbnail Browser 
Slide Show System 
Image File Properties 
File Operations 
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Icon and Cursor Files 
 
As a general image processing application, EzImage does not provide any form of dedicated icon and 
cursor editing methods that you would find in applications that are specifically designed for that purpose. 
However, you can import and export Windows icon and cursor files using special methods in the Tools 
menu, and edit them using standard image windows that have been tagged as icon/cursor export 
capable. 
 
For the purposes of explaining certain methods and procedures in this help topic, you can assume that 
what applies to cursor files equally applies to icon files, with the following exceptions: 
 

Cursor files are limited to images that are exactly 32 by 32 pixels in size. Icon files can be any width 
and height between 1 and 255 pixels. 

 
Cursor files have a hotspot, where the mouse click center-point is defined. The hotspot can be set 
using the Eyedropper imaging tool. 

 
In all other aspects, cursor and icon files are identical. For the remainder of this topic, when an icon file 
reference is made, assume that it also applies to cursor files. 
 
Importing a File 
If you use the standard open methods in EzImage on icon or cursor files, only the first image will be 
loaded. You must use the Import options in the Tools menu to load all available images into separate 
windows. 
 
Each image window is automatically given a name as follows: 
 
Original File Name + Index + Width + Height + Bit Depth 

 
Each of these parts is separated by a lower case “x”, as the following example shows: 
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The index is the position of the image in the source file. It is added to prevent naming conflicts with other 
images that may have the same size and bit depth in the file. 
 
Images are always loaded as 32-bit RGB with an alpha channel. The alpha channel will contain the mask 
that defines the non-transparent areas of the image. Choose Images->Channels->View Alpha to see 
the icon transparency mask: 
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Pure white pixels indicate non-transparent areas, and pure black pixels are transparent areas. 
 
Transparency Colors and Alpha Channels 
You have two basic ways by which you can set the transparent pixels for an icon or cursor: 
 

Ignore the alpha channel and use the transparent color exclusively. This color is defined in the 
general preferences as Transparent Color for Icons/Cursors, and defaults to a dark cyan. 

 
Ignore the transparent color and edit the mask. You can do so by either directly painting in the alpha 
channel or by painting with a specific color in the image itself, which can in turn be used to create a 
selection followed by the Select->To Alpha menu option. 

 
The export facility for icons and cursors lets you choose one of these methods to define the transparent 
areas of the image. For indexed color icons with 256 or less colors, the transparent color option will be 
much easier to work with, since you can easily choose a transparent color that will not conflict with any 
other pixel data in your image. For RGB images, you may have a more difficult time in choosing a 
transparent color that is not currently used in the image itself. 
 
Creating a Transparency Mask from a Transparent Color 
If you wish to make a transparency mask in the alpha channel without directly having to work with that 
channel, you can easily create the transparency mask using the following procedure: 
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Define any arbitrary color and designate it as the transparent color. You should set this color in the 
general preferences, since it will then become available in the color picker window (use the TC button 
in the color picker to choose it). 

 
Paint all of the transparent pixels using this color. 

 
Use the color wand tool in Single Color mode to select all pixels of this color value. This will create a 
selection of the transparent areas. 

 
Choose Select->Inverse from the menu to create a selection of all non-transparent areas. 

 
Choose Select->To Alpha to create a mask of the non-transparent areas. 

 
As you can see from this step, it is a little more work to use an alpha channel over a designated 
transparent color. Use the latter method for setting transparency whenever possible to save time. 
 
The Icon/Cursor Color Palette 
When you import an icon or cursor file, all images are automatically converted to 32-bit RGBA format, so 
that the mask data can be stored in the alpha channel. Since many icon and cursor files use indexed-
color formats, EzImage will associate the original color palette for each image within the image window 
itself. The colors will be showing in the floating color palette window. If this palette window is not visible, 
use the View->Palettes->Show Color menu option. For the above sample image, the palette window 
appears below: 
 

 
 
This is the original color set stored with that one particular image in the source file. Many icon files store 
multiple bit depths, in which case you will see this palette change to reflect the colors available in the 
active image. 
 
It is important that you never choose colors other than the ones stored in the ICO/CUR palette when 
editing an image. The reason for this is simple: when you export the images to a new file, the image is 
converted back into indexed format using the colors that are exclusive to this palette. 
 
Changing Palette Colors 
If you wish to edit or change the colors used to edit an icon or cursor image, you can do so using the 
User Palette feature. You may also load any external palette file as a replacement for the current 
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icon/cursor palette. For more information, refer to the link at the end of this help topic. 
 
Using Gridlines 
When working with very small images, such as icons and cursors, you will tend to view them at maximum 
magnification, since this makes editing the individual pixels easier. You may wish to enable gridlines with 
single pixel spacing to help you differentiate the pixel boundaries. The gridline spacing and color is 
defined in the application general preferences. 
 
Creating Icons and Cursors without Importing 
You can tag any image window for icon/cursor export using the Set Window option in the Tools menu. In 
order to be able to export an image as an icon or cursor, it must be in 32-bit RGBA format. The 
dimensions of the image may not exceed 255 pixels for icons must be 32 by 32 pixels for cursors. 
 

 
 
When you tag an image window for icon or cursor export using this option, the color palette will be preset 
for 1, 4, or 8 bit color depths first. If you are using a custom color palette, you should create it after the 
window has been tagged, since you will lose the current ICO/CUR palette. 
 
The title bar indicates if the current image has been tagged (tagged = Set, not tagged = Unset). Click on 
Set Format to apply an icon/cursor tag to the image. Click on Remove Format to remove the tag. Note 
that when you import an icon or cursor file directly, all images will be automatically tagged, allowing you to 
skip this procedure. 
 
Note: If you convert the bit depth from RGBA to any other value, such as indexed or gray scale, then the 
export tag is removed. 
 
Setting the Cursor Hotspot 
If you are exporting images to a cursor file, you will need to set the mouse hotspot, which is the position 
within the cursor where a mouse click is registered. For example, if you have an arrow shaped cursor, the 
hotspot would generally be the pixel that is at the tip of the arrow shape. 
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EzImage does not preserve the hotspot position when you import a cursor file. All hotspot positions must 
be defined prior to exporting to the cursor file. You set a hotspot using the Eyedropper tool in the image 
tools palette. 
 
Exporting to Icon and Cursor Files 
If there is at least one open image window that has been tagged for export, you will be able create an 
icon or cursor file. Choose one of the Export options from the Tools menu. A sample screen for this 
appears below: 
 

 
 
The list will contain the title bar reference text for all open image windows that have been tagged as 
export-ready. Any image windows that are not in this format will not appear in the list. 
 
You can choose to select as many images from this list as you wish. Only the selected ones will be 
exported to the file. Use the All, None, and Invert buttons as an aid in creating multiple selections. 
 

Choose the Alpha Channel option to export the images based on the mask in the alpha channel. Any 
transparent color in the image itself will be ignored, since the mask itself determines what is 
transparent. 

 
Choose the Transparent Color option to export the images and ignore the alpha channel mask. 
When you choose this option, all pixels that match the transparent color will be replaced with 
transparency in the file. 

 
Click on Export to create the file. All images will be placed into a single file in a multi-page format. 
 
Related topics: 



EzImage Reference – Version 1.05 

 

 Page 157 

 

 
General Preferences 
Eyedropper Tool 
Color Swatch Palette 
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Image Lists 
 
Image lists provide a facility to collect files from several locations and group them into a common area 
where they can be viewed, opened, or stored to a file for reference. 
 
An important thing to remember about image lists is that they are memory-resident. Even when you load 
an image list from file, the complete contents are loaded into memory. Image lists are stored in a compact 
format by grouping related files by path reference. The only limitation on the size of a list is available 
system memory. 
 
You can add files to an image list using any of the following methods: 
 

Add selected images from the thumbnail browser. 
 

Add images from the preview browser. 
 

Use the image list editor to create a list. 
 
The image list editor is also a browser itself, similar to the standard preview browser, except that there is 
no type of folder navigation. There is no other option in EzImage to view an image list or the files that are 
contained within one. All other areas in the application related to image lists simply serve as collection 
points for adding new files. 
 
To access the editor, choose Browse->Image List from the application menu. 
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The editor window is composed of the following sections: 
 

A menu bar across the top contains all of the editing options. 
 

The comment panel below this provides an area to display image comments. Similar to the thumbnail 
system, an image list can contain optional comment text. The comments themselves are not part of 
the source files. They are contained within the image list. 

 
The left side of the window is the file list, with two columns for the file name following by the path 
name.  

 
The right side of the window can have an image preview area assigned to it. This preview option can 
be disabled, which would allow for the list area to extend across the width of the window. 

 
The panel above the status bar at the bottom contains basic information about the selected image: 
Size, width, height, bit depth, printer resolution in dots per inch, and the date that the file was last 
modified. 

 
The status bar at the bottom shows the total number of images in the current list, selected images, 
and a help/hint area that will also show the name and path for the selected file. 
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The title bar will indicate if the image list refers to a file saved on disk. If the image list was created but 
never saved, there will not be a file name reference. 
 
Creating a New List 
This New List option will create a new file with an empty list. Image list files are stored in the Lists folder 
of the application path with an extension of .ILS. The current image list will be replaced with the new one. 
 
Loading a List 
Use the Load List option to load an image list from a file. The current image list will be replaced with the 
new one. 
 
Adding Images to a List 
You can use the options in the Add to List submenu to append images to the current image list. The 
images in the current list will not be affected. 
 

Use the Single Folder option to add images for one folder path (no subfolders). 
 

The Folder Tree option will add all images for a path including ones contained in subfolders. 
 

The Image Files option allows you to selectively add single file names from any path using a common 
open file dialog window. 

 
The List File option will merge the current image list with another one. 

 
Saving Image Lists 
The Save option resaves the current image list to file. If the list was never saved to file, you will be asked 
to provide a new file name for it. 
 
The Save As submenu contains three options for saving an image list to file: 
 

Use New List to create a new image list file using all images. 
 

The Selected Entries option will only create a list based on the current image selection. 
 

The Marked Entries option will only contain images that are in the active marked list. 
 
File Operations 
 

The file Delete option will send all selected image files to the Windows Recycle Bin (the actual 
deletion of files is determined by the properties you have set for the recycle bin). 

 
The Copy and Move options use the services of Windows to perform the actual operations. EzImage 
is not in control of the file copy or move methods with the exception of setting the target path. 

 
File renaming is done through EzImage using a simple and intuitive dialog that allows for multiple files 
at one time. 

 
File Properties 
The image file properties dialog provides several pieces of useful information about image files, including 
format, compression, dimension, size, printing resolution, and comments. You can select multiple image 
files at one time and step through the properties of each one. A small thumbnail viewer and file marking 
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system is also included in this dialog window. When marking images within the properties dialog window, 
the current marked list in the image list editor will be replaced with the one generated by the properties 
window. 
 
Preferences 
This option will present the tabbed EzImage application preferences window. Depending on the current 
window being displayed the default preference tab will be set according to the properties that relate 
directly to it. 
 
Hide Preview Window  
Choose this option to toggle visibility of the image preview area. With the preview window off, then entire 
window space will be occupied by the image list only. 
 
Reset Area Sizes 
Most viewers and editors in EzImage are sizeable windows containing panes of information that can be 
resized, such as dividing the window between image area and file list area. All of these size and position 
settings are permanently saved when you close the application. In the instance when you change screen 
resolution to a lower dimension, some of the information may be off the screen. Use this option to reset all 
window pane positions to default values. 
 
Hide Comment Panel 
Images in a list can have comments of up to 128 characters assigned to them. If you don’t wish to use 

comments with a list file, you can hide the comment panel that appears beneath the menu bar. 
 
Sorting Lists 
Use the sort options to display the list in path name or file name order. Since an image list is completely 
loaded into system memory, EzImage uses a compact method of storing the list by grouping path names 
and file name separately. While this creates a significant saving in memory usage, it does impact the 
sorting time. Lists with several thousand entries can take several seconds to sort on slower systems. 
 
Change Base Path 
You can use this option to change the base path for one selected image. When you change the path 
reference, all images in the list that are linked to the same path will also be changed. This may be 
necessary when an image file has path links referencing images that have moved to another location. 
This option does not rename the files on your system. 
 
Verify Existence 
This option will check every entry in the list to see if the source image file exists. Any entry that refers to a 
non-existent image file will be selected. You can use the Shuffle option to move all of the selected entries 
to the front of the list for easier viewing. 
 
Verify Duplicates 
When adding images to a list, no duplicate file check procedure is made, allowing for the possibility of the 
same image appearing more than once. By not checking against every current file in the list, it ensures 
there will be no speed penalty when several thousand images are present. 
 

The verify option will check every entry for duplicate image files (same name with the same path 
reference). Any duplicate entries will be selected. You can use the Shuffle option to move all of the 
selected entries to the front of the list for easier viewing. 
 
Pack Path Names 
When images are added to a list as a group, each file with the same path reference is grouped with a 
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single path link. Each group of files creates one new path link in the image list. When adding many 
groups with different paths over a period of time, path and file fragmentation in the list can occur. This 
fragmentation has no impact on performance, but does increase the memory footprint of the image list. 
Use the pack option to de-fragment the paths and files if you are managing lists with several thousand 
entries. 
 
Shuffle to Front 
The shuffle option will move all selected images to the front of the list, without affecting the order of the 
non-selected entries. 
 
Filtered Selection 
This option will create an image file selection using pattern, size, and date-based filters. If you have 
comments assigned to the images in a list, you can locate images using a comment search string with 
this option. Only images that match on one or more of the filtering properties will be selected. Click on this 
link for more information on filtered property settings. 
 
Comment Selections 
This option will only select images that currently have assigned comments. 
 
Deleting Images in the List 
Use the Clear and Delete Selected options to delete selected images or all images from the list. They 
only affect the list – image files will not be removed from your system. 

 
Add Images to Marked List 
A marked list is a special list of images that represent a subset of the current image list. The marked list 
provides a method to create a selection of images in multiple steps, and use this list to create new image 
lists from other image lists. Use this option to add all selected images to the marked list. Note that if you 
use the marking option in the file properties window, the current marked list will be replaced with the 
properties window marked list. 
 
Delete from Marked List 
This option will remove all selected images from the marked list. If a selected image is not part of the 
marked list, the entry is ignored. 
 
Recall Marked List 
The recall option will create a new selection that consists of all entries in the marked list. 
 
Mark Everything 
This option adds every image to the marked list. 
 
Clear Marked List 
This option will remove all entries from the marked list. 
 
Open Selected Images 
Use this option to open all selected images in their own windows. When all images have been opened, 
you will be returned to the main EzImage view. There is a limit on the maximum number of images that 
can be opened at one time (there is no limit on the number of image windows in EzImage, this just 
applies to the various image open methods). 
 
An option in preferences allows you to assign an external application to open an image file. If that option 
is enabled, then only one image can be opened, and will be opened by the application assigned to the 
image file type according to the Windows registry. 
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Copying the Image to the Clipboard 
Use this option to copy the selected image to the Windows clipboard as a device independent bitmap 
(DIB), where it will be accessible to other applications. 
 
Full Screen View 
This option will display the selected image using a full screen preview mode. You can also double click on 
the normal preview image to expand it to the full screen size. Only one image at a time may be selected. 
 
Add to Slideshow 
Use this option to add the selection to the current slideshow list. If no images are in the list, one will be 
created using the current slideshow preferences as the template for the script playback. There is a 
current limit of 10,000 images per slideshow script. Note that duplicate images are allowed in a slideshow 
script (you can remove duplicate entries with the slide show script editor). Use the Clear option to start a 
new slideshow script. 
 
Create Thumbnails 
This option will create thumbnail images for all selected entries. The images are created in the current 
thumbnail database. If a thumbnail image already exists, then the entry in the image list will be skipped. 
The thumbnails are creating using the current size and format settings. Use the Preferences option in the 
image list editor menu or in the thumbnail creation dialog window to verify the thumbnail settings before 
you begin generating them. 
 
Add to Path List 
Path lists are similar to image file lists, except that they only contain path names. They are primarily used 
as a source for images in the File Conversion tool. Path lists make it simple to perform file conversions 
from multiple path sources that don’t have to reside on the same drive or computer system. Path lists 
have their own separate editor, which can also be found in the application Browse menu. 
 
Comments 
Any image in the list can have a comment assigned to it. You can also assign the same comment to 
multiple images. Create a selection of images and use the Comments menu option to add new comments 
or edit existing ones. Use the Remove Comments option to delete the comments for all selected images. 
 
Related topics: 
 
File Filtering 
Thumbnail Browser 
Path List Editor 
Image Preview Browser 
File Renaming 
Slide Show System 
Creating Thumbnail Images 
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Fitting an Image to a Window 
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The View->Image to Window menu option will adjust the magnification (zoom) level of an image so that 
it will fit completely within the current window dimensions. Once an image has been fit to the window, the 
window itself will be adjusted to wrap around the image according to its aspect ratio so that no 
background border areas will remain. An image can not be at less than 5% or more than 1600% 
magnification. If an adjustment would cause a level outside this range, the window will be adjusted 
accordingly. 
 
Before Image to Window: 
 

 
 
After Image to Window: 
 

 
 
Related topics: 
 
Image Windows 
Setting Magnification Levels 
Window Arrangements 
Fitting a Window to an Image 
Image Information Overlays 
Window and Cross Hair Rulers 
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Close vs. Close All 
Display and Dithering Quality 
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Image Information 
 

 
 
This window is displayed when you click on the information icon in the status bar of the main view. You 
must have at least one image open in a window. 
 
All of the information is self-explanatory. If the image has not been saved, then the following field will 
either be blank or undefined: 
 

Location 
File Format 
File Size 
Compression 

  
The Modified item indicates if an image has been altered since it was last saved to disk. 
 
Memory indicates both the amount of space needed to store the image itself, plus workspace memory 
needed to store floating images, masks, regions, backup areas, brush buffers, etc. 
 
If a Script is being recorded, the last line indicates the number of lines of text in the file and its total size. 
 
If a region selection is active, its position and dimension will appear in this window. 
 
If a floating image is active, its position and dimension will appear in this window. 
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Related topics: 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Brush Palette 
Information Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
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Indexed Color Mode 
 

 
 
This method allows you to convert an image from any bit depth to one that uses a color palette with 2 to 
256 colors. Although primarily intended to reduce RGB levels to indexed color, you can also convert an 
indexed color image to another variation using a different number of bits per pixel, or with a different color 
palette through a palette re-mapping process. 
 
Color Depth 
Specify a color depth from 1 to 8 bits per pixel. Color depths of 1 to 6 bits are not supported by the 
Adaptive color reduction method. As you change bit depth with this dropdown list, the Color Limit value 
will reset to the maximum color limit available. It is recommended that you change color limits only after 
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you have set the bit depth. 
 
Reduction Method 
There are several reduction methods available. No Dithering is the simplest and generally results in the 
poorest quality. Adaptive is the only other option that does not use a dithering process. Adaptive 
attempts to find the best number of colors and adjust the pixel data to fit the new color palette. All other 
methods use some form of dithering to achieve the color reduction. The Adaptive method can’t be applied 
to anything other than 24 or 32-bit RGB images. 
 
Palette Type 
Note: Palette Type does not appear when Adaptive method is selected. 
 
Use an optimized palette for the best possible color reduction. The fixed, web, and Windows system 
palette apply a predefined set of colors that generally give poor results on any image with many subtle 
shades of different color hues. The User Palette option allows you to re-map an image to use a specific 
color palette. 
 
To load a user palette, you must use the Load option in the Color Swatch Palette window in the main 
EzImage view. 
 
Reduction Quality 
For adaptive color reduction, this slider will set the sampling range for analyzing areas of color in an 
image. A high quality setting can increase processing time significantly, with only marginal improvement 
in the image. A medium setting provides a good balance between speed and quality. Note that adaptive 
color reduction is always done in two passes (analysis followed by pixel re-mapping), as will be indicated 
in the progress status bar. Adaptive reduction does not work well on images that have suffered from color 
information loss due to high compression (i.e. low quality JPEG images). 
 
Color Limit 
You can set a lesser number of colors for an image reduction if you wish to reserve some color palette 
entries for system or other uses. Lesser colors may also result in better file compression for formats that 
support it, at the cost of lower display quality. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 
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You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
RGB Color Mode 
Gray Scale Mode 
Halftone Conversion 
Threshold Conversion 
Channel Separations 
Alpha Channels 
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Installation and Removal 
 
Application Installation 
EzImage is provided in the following ways: 
 

As a self-extracting executable file that can be downloaded from our web site. Double-click on the 
EZIMG.EXE file that you downloaded to install the application. 
On CD-ROM with an appropriate setup program and AutoRun capability. Insert the CD-ROM into 
your CD-ROM drive. If you have AutoRun enabled on the drive, the setup program will run 
automatically. Otherwise, you will have to double click on the SETUP.EXE file that is located in the 
root path of the disc. 

 
Regardless of the type of installation you will be performing, there are two things that you should be 
aware of: 

For a first time installation of EzImage (you did not install a prior version), the application will be 
unregistered. The application will run for a period of 30 days, after which the program will no longer 
operate without a valid registration code. If you purchased the EzImage package as supplied on CD-
ROM media, then the registration code will have been provided to you. If you downloaded the 
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software from our web site, then you must purchase a valid registration code once the time trial 
period has expired. For ordering information, please visit our web site at: 
www.pcvu.com/ezimage/index.html  
If you already have a version of EzImage installed on your system, you should ensure that you install 
the new version to the same location as the old version in order to preserve your current application 
settings. You can choose to install newer versions to another location, but you will need to move any 
of your settings files to the new installation path. 

 
Application Removal 
To remove EzImage from your system, use the Add or Remove Programs option from the Windows 
Control Panel and locate the entry named EzImage, then click on the Change/Remove button. Any new 
files you may have added to the EzImage application folder will not be removed, including the 
EZIMAGE.INI file and any configuration files that were generated after the application was installed. 
 
Single End-User Installation 
The normal single end-user license provided with EzImage allows you to install one copy of the 
application on one PC at a time, to be accessible only to the owner of the licensed registration code. 
  
Network Installation of EzImage 
The EzImage application was not designed to run across a network or be used by more than one person 
at the same time. If you wish to use multiple copies of the EzImage package, you will need to obtain a site 
license and install a copy onto each system. For more information on site licenses, please contact us 
using the information provided on our web site. 
 
Temporary File Usage 
The thumbnail database system and temporary image files both require additional disk space on the drive 
that you installed the application. You should ensure that you install the application on a drive with a 
sufficient amount of free disk space. 
 
Windows XP/NT/2000 Installations 
Unless your network policies dictate otherwise, it is recommended that you install the application at the 
administrative security level. If you install EzImage at the user level, you may not be able to access all 
areas of your system/network that may contain image files. 
 
Extended Features Activation 
The Selection Separate, Edge Deskew, and Image Compare features in the Tools menu require an 
additional activation code. This code must be obtained from SoftPro after the application has been 
installed. Once you have registered the extended features code, it will be valid for the machine that the 
application is installed on and may not be transferred to another system. In the event that you change 
hardware or reinstall the Windows operating system, you may obtain a new activation code free of charge 
by contacting us and providing the new product ID number that identifies your system. 
 
If you purchased the product at the price that includes these extended features, there is no need to 
supply any additional payment information. The activation code will be sent to you when we receive the 
production identification code. If you have purchased EzImage at the standard price, then there will be an 
upgrade fee for the activation code. 
 
Limited Feature Usage 
Some operations in the trial version of the application have a limited number of uses, after which you 
must register the product. 
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Image Inversion 
 
This method simply inverts the colors of an image, creating a negative of the source image. For indexed 
color images, the palette colors are inverted rather than the pixel information. For black and white images, 
the inversion results in the black pixels being exchanged with the white ones. 
 
Related topics: 
 
Levels 
Brightness and Contrast 
Hue and Saturation 
Color Balance 
Channel Mixer 
Channel Adjustment 
Equalization 
Stretch Intensity 
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About Image Windows 
 
Any image you work with in EzImage is opened in its own window in the main view. There is no limit on 
the number of open image windows you can have in the application, however each image will consume a 
portion of available system memory. If you are working on large images that are several megabytes in 
size, it is recommended that you avoid having too many image windows open to avoid application 
performance issues. 
 
An example of an image appears below: 
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The title bar of an image contains several items of information: 
 

The image name with an extension that identifies the file type. EzImage is quite strict on file types and 
file formats, so the file type extension will in fact reflect the image storage format. New images, 
created by scanning, the New Image menu option, Selection Separations, and by duplication (whole 
or parts of an image) will not have a file extension in the title bar, since they have yet to be saved to a 
file. 

 
The magnification level appears next, which can range from 5% to 1600% in fractional amounts. 

 
The type of image, based on color and bit depth, or the channel when viewing separate channels in 
an RGB/RGBA image. 

 
There are several image types that can appear in the title bar: 
 
RGB: True color images with 24-bit depth, using a Red, Green, and Blue channel storage format. This is 
also known as the 16-million color format. 
 
RGBA: Similar to an RGB image, but with a 32-bit depth, to allow for an 8-bit Alpha Channel. The alpha 
channel is used for many operations in EzImage, especially when working with floating image selections. 
 
Gray: This is a 256-level gray scale image. The image still uses a palette, but the ordering is sequential, 
with black as the first color and white as the last color. 
 
B&W: This is a 1-bit black and white image format. Only 2 colors exist, pure white and pure black. 
 
Indexed: The image contains from 1 to 8 bits per pixel, and does not have a color palette that would 
qualify for being identified as B&W or Gray formats. 
 
Channel Separations 
The Image->Channels menu provides the ability to view the individual channels of any RGB or RGBA 
format image. While a channel is being viewed, the remaining ones are kept in memory in a special 
backup area. This allows you to work with each channel as a 256-gray level image separately. The title 
bar will indicate which channel is currently active in the image window: Red, Green, Blue, or Alpha. 
 
Inverted Palettes 



EzImage Reference – Version 1.05 

 

 Page 171 

 

For the B&W and Gray scale images, if the ordering of the gray or black/white values in the color palette 
are reversed, then the Inv indicator will appear in the title bar of the window. These image types are 
classified as indexed color images and will be processed as such. If you see the Inv indicator, you may 
wish to load an ordered palette to correct the image properly to black and white or gray scale. To do so, 
use the Load option in the Color Swatch Palette window and choose one of the provided .PAL files. 
Make sure that the dropdown list in that window is showing the Image Palette item before you do this. 
 
Background Area 
When viewing an image that does not occupy the complete width or height of the window, the remainder 
will be filled with a background color as defined in the application preferences. The default color is 
medium gray, as shown in the following example: 
 

 
 
Scrolling the Image Window 
When the image is larger than the window size, scroll bars will appear on the right and/or bottom edges of 
the window. This allows you to pan the image to a specific area you wish to work with. The Image 
Grabber tool allows you to grab the image and drag it around as well. This grabber tool provides 
keyboard shortcuts for quickly panning an image one window at a time, or to move to the extreme edges 
of an image. 
 
Using the Mouse Wheel 
For images that are larger than the display window, you can use the mouse wheel to scroll both vertically 
and horizontally. To scroll vertically, just use the mouse wheel by itself. Hold down SHIFT when using the 
wheel to scroll the image horizontally. 
 
Zoom Tool 
The Image Zoom Tool provides several options for setting the magnification of an image. Options are also 
provided to fit an image to the current window size, or fit the window size to the current image by 
eliminating scroll bars. 
 
Resizing, Minimizing, Maximizing 
You can resize the image window by clicking on any edge or corner of the window and dragging with the 
mouse. If you make the window smaller than the image area, scroll bars will be added. If you make the 
window larger than the image area, blank borders will be added with a specific color of your choice. The 
image will always remain centered within the window with equal sized borders. You can minimize or 
maximum the window using the appropriate icon in the top right corner of the image window title bar. 
When images are minimized, they will appear as small title bar-only windows at the bottom of the main 
view. When maximized, all image windows will in turn be maximized. Only one image will be visible at a 
time when windows are maximized. To move an image, click on the title bar area and drag with the 
mouse. 
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Related topics: 
 
Setting Magnification Levels 
Window Arrangements 
Fitting a Window to an Image 
Fitting an Image to a Window 
Image Information Overlays 
Window and Cross Hair Rulers 
Close vs. Close All 
Display and Dithering Quality 
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Keyboard Reference 
 

 
 
The EzImage keyboard reference dialog window displays all available keyboard shortcuts and menu 
access keys in a list that can be used to access help topics with a single mouse click. 
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The list allows you to sort the items by operation description, menu name, menu access keys, qualifier 
(Shift, Ctrl, etc.) or shortcut key. Click on the heading caption of the column you wish to sort by. 
 
The icons that appear next to some of the entries correspond to reference images that are placed on the 
scripts palette when you record a menu shortcut. Not every operation will have an icon since many of the 
menu options are not enabled for scripting. 
 
Saving the List 
You can save the reference list to a text file by clicking on the Save button. 
 
Help Topic Quick Access 
You can click on any shortcut in the list to highlight it, then click on the Help button to see the help topic 
for that shortcut. Not all items in the list will have a help topic. You can also double click on any shortcut 
item in the list to obtain help. 
 
Remapped Keyboard Shortcuts and Other Menus 
The keyboard short cut reference is based on the current template that is active, not the default one 
provided with EzImage. If you have created a new keyboard shortcut template, this reference will reflect 
the shortcuts that you have defined. 
  
Keyboard short cuts only apply to the main application menu of EzImage. Some operations within the 
application will use dialog windows that also contain their own window-specific menu bar. You will not be 
able to change the shortcut keys for those menus. 
 
Related topics: 
 
Editing Keyboard Shortcuts 
Image Tools: Keyboard and Mouse Shortcuts 
Selections: Keyboard Shortcuts 
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Legal Information 
 
EzImage - License Agreement 
The use of this package indicates your understanding and acceptance of the following terms and 
conditions. This license shall supersede any verbal or prior verbal or written statement or agreement to 
the contrary. If you do not understand or accept these terms you must remove this software from any 
computer system that it has been installed on and discontinue its use. 
 
Copyright 
This product is Copyright © 2019 SoftPro 2001, all rights reserved. This product is protected by Canadian 
and United States copyright laws, international treaties and all other applicable national or international 
laws. This software application and any accompanying documentation may not be copied, translated, or 
reduced, in whole or part, to any electronic medium or machine readable form, without prior consent in 
writing, from SoftPro 2001 and according to all applicable laws. SoftPro 2001 does not transfer title to the 
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software package to you. You have the non-exclusive, non-commercial use of the software package. 
SoftPro 2001 retains the full and complete title to the software package, and all intellectual property rights 
therein. 
 
Proprietary Rights and Restrictions 
Subject to this Agreement, SoftPro 2001 retains all copyrights, trade secret rights, patents, trademarks, 
and any other proprietary rights covering or relating to this software package. You acknowledge that the 
software package includes or incorporates proprietary and confidential information belonging to SoftPro 
2001. All rights not expressly granted by SoftPro 2001 in this Agreement are reserved. 
 
You may not modify or alter application executable code or associated help files. You may not attempt to 
unlock or bypass any copy protection or registration authentication algorithm incorporated in the program 
executable. You may not remove or modify any copyright notice, nor any dialog screens containing such 
copyright notices. 
 
Liability Disclaimer 
This software package and/or license is provided as is, without any representation or warranty of any 
kind, either express or implied, including without limitation any representations or endorsements 
regarding the use of, the results of, or performance of the product, its appropriateness, accuracy, 
reliability, or correctness. In no event shall SoftPro 2001 be liable for any damages whatsoever (including, 
without limitation, damages for loss of profits, business interruption, loss of information, or other pecuniary 
loss) arising out of the use of or inability to use this Softpro 2001 product, even if SoftPro 2001 has been 
advised of the possibility of such damages. 
 
SoftPro 2001 does not warrant that the operation of the software package will be uninterrupted or error 
free. 
 
Operating License 
SoftPro 2001 grants you a nonexclusive license to use one copy of EzImage on a single computer 
(“Dedicated Computer”). 
 
The EzImage application may not be installed on network server to be accessible to more than one 
person at the same time. 
 
Backup and Transfer of License Rights 
Make one copy of EzImage for archival purposes, or copy the Software onto the hard disk of your 
computer and retain the original for archival purposes, as prescribed by Canadian, United States, and 
international copyright laws. 
 
You may transfer the software package to another party only if the other party agrees to the terms and 
conditions of this license agreement, and proper identification of the other party is provided to SoftPro 
2001 within 30 days of the date of the transfer. If you transfer the software package, you must at the 
same time transfer any documentation and/or backup copy. You may also choose to destroy the backup 
copy. You may not retain any portion of the software package, in any form under any circumstances, 
once the transfer has been completed. 
 
This license is effective until it is terminated. You may terminate the license by destroying the software 
package in its entirety, including any back-up copy you may have made. This license also terminates if 
you fail to comply with any terms or conditions of the license agreement. You agree upon such 
termination to destroy all copies of the software package and any associated documentation, or to return 
them to SoftPro 2001. 
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All other rights and restrictions not specifically granted in this license are reserved by SoftPro 2001. 
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Levels 
 

 
 
The Levels method provided a more precise method of changing the intensity levels of an image over the 
standard brightness and contrast option. Using this method, you will be able to adjust the highlights, 
midtones, and shadows of an image separately. 
 
Setting the Channel 
You can apply levels to all channels at one time (RGB) or to individual channels by selecting from the 
Channel dropdown list. There is one set of values for each of the red, green, and blue channels, plus one 
for the master (RGB) channel. The input, output, and gamma levels are set individually for each channel. 
 
Changing the Input Levels 
Drag the right input slider to the left to map pixels in the reduced color range to brighter values.  For 
example, if the right slider is at 240, all pixels with color levels above 240 will be mapped to pure white, 
and all remaining pixels will have color values shifted upwards towards the maximum white level. The left 
slider performs in a similar fashion by mapping colors towards black, darkening the image. 
 
Changing the Output Levels 
Drag the left output slider to the right to decrease the shadows in an image. Drag the right output slider to 
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the left to decrease the highlights in an image. If you drag both sliders to their opposing ends on the 
scale, the image will be inverted. 
 
Changing the Midtone Level (Gamma) 
You can adjust the midtone levels in an image by performing a gamma adjustment. The gamma 
adjustment will tend to focus on the middle gray levels of an image without severely altering the highlight 
or shadow levels. You should perform a gamma adjustment before making highlight or shadow 
corrections for best results. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Loading and Saving Settings 
Most adjustment operations in EzImage provide the ability to load and save settings using an adjustment 
file. The adjustment file is specific to each operation, and is identified by a unique file extension. These 
files are by default placed into the User folder of the application path. Adjustment files not only provide a 
convenient method by which to apply the same adjustments repeatedly to several images, but they are 
also used for: 
 

Color adjustments with the File Conversion tool. 
 

Color adjustments applied to printed thumbnail image sheets. 
 

Embedding in script files when writing script files outside of the recording process. 
 
For the Levels adjustment process, the adjustment file extension is .LEV. 
 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
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If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Resetting Adjustment Values 
For operation windows that have a Reset button, you may use it to restore all settings to default values. 
 
Related topics: 
 
Brightness and Contrast 
Hue and Saturation 
Color Balance 
Channel Mixer 
Channel Adjustment 
Equalization 
Image Inversion 
Stretch Intensity 
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Loading and Saving Images 
 
Loading Images 
 
There are several ways to load image files into EzImage. The most common method is to choose File-
>Open from the main menu. You will see a dialog that appears similar to the following: 
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You can select one or more images of any format supported by EzImage. The dropdown list contains 
specific file formats. 
 
The Image Preview Browser provides a more flexible method for opening image files, since it shows a 
sample of the selected image. This browser also maintains a reference to the previous path and image 
file name. Each time the browser window is displayed, the path and file will automatically be set to the 
previous image that was opened. 
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The Image List Editor stores image files in lists grouped by path name. You can browse an image list in a 
manner similar to the preview browser. Image lists can be stored in files that can be used to catalog 
image collections or as a source for the File Conversion tool. 
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The Thumbnail Browser presents folders of image files in a grid arrangement. This grid contains 
thumbnail samples of each image, stored in a database. 
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The thumbnail browser, preview browser, and image list editor all have a menu option allowing you to 
open selected images in the main application view. 
 
Open File Limits 
The number of open image windows in the application is only limited by available memory. The number of 
image files that can be opened at one time using any of the above methods is limited to 50. You can have 
more than 50 image windows open at one time in EzImage. The 50-image limit only applies to the open 
methods. 
 
Saving Images 
 
Choose File->Save to resave changes to an image that was previously loaded from file. If you attempt to 
use this method on an image that did not originate from a file, such as one that was scanned, then the 
image will be passed to the Save As method. 
 
When resaving an image that was in compressed format (JPEG, PNG, or FPX), EzImage will use the 
compression settings defined in the application preferences to write the image data back to file. If 
possible, you should only save uncompressed images to compressed format. Saving an image that was 
already compressed will result in a second level of compression being applied, which can result in further 
degradation of the image quality. 
 
Choose File-Save As to save the image to a new file, with a format of your choice. Some formats have 
options that affect the way the image data is written. If there any additional options needed for saving to a 
particular format, an options window will appear after you have entered the file name. 
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The save method will automatically reassign the file extension for you. If you loaded a Windows Bitmap 
(.BMP) format file and saved it as JPEG, the file extension can still remain as .BMP in the file save dialog 
window. EzImage will change it to .JPG when the file is created. 
 
Save Restrictions 
Some file formats may not support an image save operation due to restrictions in bit-depth or the file type 
itself. For example, indexed color images can’t be saved to JPEG format, and Kodak Photo CD format 
can only be read but not written. If you attempt to save a file in a format that does not allow for write 
access or does not support the image bit depth, a warning message will be given. 
 
Common Save Folder 
The general preferences contains an option to save all new images to a common folder. With the 
common folder option enabled, all new images will default to this path when the save dialog window 
appears. 
 
With the option disabled, the saving new images will be done so that the path name will be the same as 
the one used for the file that was saved before the current one. For images that are saved that originated 
from a file, then save path will be the same as the one the image was originally loaded from. 
 
Preserving the File Format 
When saving new images, the file format will also be set the same one as was used for the prior image 
save. 
 
File Type Extension Enforcement 
EzImage does not allow you to load or save image files unless they possess a valid file extension. For 
example, you can’t open a Windows bitmap file unless the file extension is .BMP. You can observe the 
acceptable file extension(s) for each supported format by examining the dropdown list in the open file 
dialog window. When saving image files, the proper default file extension will always be added to the 
image file. 
 
Association EzImage with Image File Types 
It has become common practice in Windows application to take control of specific file types and associate 
with different applications that are installed. Many file types such as Windows Bitmap (.BMP) are fairly 
common and can be opened with several applications that may be installed on your system. EzImage 
does not take control over common image file types unless you make that choice. An option under the 
application Help menu named File Type Associations can be used for the following two purposes: 
 

Assigning EzImage as the default application for all supported image file types (with the exception of 
Photoshop PSD format). 

 
Removing the assignment. This option will restore the association to the application that previously 
controlled the file type. 

 
Related topics: 
 
Association EzImage with Image File Types 
Creating a New Image 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 
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Filling and Images 
Clearing Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
 

 
Top 
 
 

 
 
 

Motion Blur Filter 
 

 
 
The motion blur filter creates the illusion of movement in an image. 
 
You can set a motion blur direction from 0 to 360 degrees in 1/100-degrees increments. Check the 
counter-clockwise button to reverse the direction. Check the Unidirectional option to ensure that the 
motion blur follows the angle of direction. With the option unchecked, the motion falls along a line parallel 
to the direction angle. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
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Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Average Filter 
Gaussian Blur 
Median Noise Reduction 
Sharpen and Blur 
Unsharp Mask 
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Median Noise Reduction Filter 
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This filter changes the color of each pixel in the bitmap to the median color of pixels in its neighborhood. 
This is similar to the Average method, but it is used for noise reduction, rather than a blur effect. You 
control the effect by specifying the size of the neighborhood that is used for calculating the median value. 
For example, use a value of 8 for an 8 x 8 pixel sampling area. The values range from 0 (no change) to 
60. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
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If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Average Filter 
Gaussian Blur 
Motion Blur 
Sharpen and Blur 
Unsharp Mask 
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Menus and Shortcuts 
 
The EzImage main view contains both the main menu and various popup menus. Popup menus are 
available in two forms: 
 
Click on any arrow button of a floating palette window that contains one. For example, clicking on the 
arrow button in the information palette will present a popup menu with the option to change the unit of 
measure. The following palettes contain popup help that use this format: 
 

Brushes 
Information 
Color Swatch 

 
The Scripts palette contains a popup menu that you can access by right clicking on any of the command 
buttons (right clicking on the small icon buttons at the left does not have any effect). 
 
Keyboard Shortcuts 
All main menu options can have an associate keyboard shortcut. EzImage has a default template that can 
be modified using the shortcut editor. This allows you to reassign almost any key combination to any 
menu option. Given the number of menu choices, not all options will contain a suitable shortcut. If you are 
uncomfortable with either of the two built in shortcut templates, it is a fairly trivial process to make a new 
profile with the editor. 
 
Tool Shortcuts 
The Tools->Tool Shortcuts menu contains options for all of the tools available on the Tools palette. By 
providing these shortcuts on the main menu, you can include a different set of keys in a new template 
using the shortcut editor. 
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Alternate Tool Shortcuts 
Many tools in the Tool palette contain more than one painting or image-processing tool that appear in the 
options panel beneath the application menu. For example, the Dodge tool has 3 tools associated with its 
single entry in Tools palette: Dodge, Burn, and Sponge. To select from these 3 tools, you can click on 
them in the options panel or you can use the menu shortcut keys which by default are: 
 

F5 for tool 1 
F6 for tool 2 
F7 for tool 3 

 
The shortcut keys associate left to right in according to their button sequence in the options panel. 
 
Some tools have an option that is used so frequently that it is convenient to bind a menu shortcut key to 
it. For example, the Move checkbox in the Move Tool options is used quite often to toggle between cut 
mode and copy mode. The following tools currently have a Mode shortcut: 
 

Move Tool: Toggles the cut/copy mode for creating floating images from regions. 
 

Region Selection Tools: Resets the combination mode to normal if it was previously locked in add, 
subtract, or intersection. 

 
Shape Tool: Toggles anti-alias mode on and off. 

 
Zoom Tool: View the image at 100% magnification. 

 
Measure Tool: Clear current measure line(s). 

 
Cross Hair Tool: Clear current cross hair line(s). 

 
Image Grabber: Fits the Image to the Window 

 
Numeric Entry Shortcuts 
Almost all text input fields in EzImage windows that accept numeric values can use the cursor keys to 
increment and decrement values. If this shortcut is available in an input field, the cursor up key will 
decrement a numeric value and the cursor down key will increment it. 
 
Related topics: 
 
Tool Palette 
Tool Options Panel 
Brush Palette 
Information Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
 

 
Top 
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Channel Mixer 
 

 
 
The channel mixer uses percentages of the red, green, and blue channels of an image to create new 
combinations of red, green, and blue. An additional constant value can be used to add or subtract from 
the overall intensity of a color channel. 
 
Consider the default settings as an example, which results in no color adjustment: 
 
For the red channel, the values are 100% red, 0% green, and 0% blue. This means that 100% of the 
current red value for any pixel is added to the new red channel, 0% of the current green value is added to 
the new red channel, and 0% of the current blue value is added to the new red channel. 
 
If we have the following pixel color RGB value of (192,128,64), then the result of the default adjustment is: 
 
Red Channel: 
Red * 100% + Blue * 0% + Green * 0%  + Constant% = 192 
 
Green Channel: 
Red * 0% + Green * 100% + Blue * 0% + Constant% = 128 
 
Blue Channel: 
Red * 0% + Green * 0% + Blue * 100% + Constant% = 64 
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If you were to select the green channel from the dropdown list and adjust the blue slider to 50%, the red 
slider to 10%, and the constant slider to –10% then you would get the following: 
 
Green * 100% + Blue * 50% + Red * 10% + Constant 
 
128 * 100% + 64 * 50% + 192 * 10% - 255 * 10% = 153 for the new green value. 
 
The constant is a percentage of full intensity that is added or subtracted from the color channel after the 
initial blend of red, green, and blue values have been made. Therefore the constant value is always a 
percentage of 255, which is full intensity. 
 
To summarize, each channel from the dropdown list determines the new output color channel, based on 
the percentage of red, green, blue in the original color values, plus the constant intensity adjustment. You 
mix red, green, and blue to make a new red value, and perform a similar adjustment to make new green 
and blue values. 
 
The percentage adjustments can range from –200 to +200. 
 
Gray Scale Images 
Check the Grayscale option to create a target gray scale image that is a variable percentage of the 
original red, green, and blue values. This allows you to create a custom gray scale image based on 
different ratios of red, green, and blue color components. Since there are many different standards on the 
ratio of red, green, and blue colors in gray scale conversion, you can use the mixer to create specific gray 
scale template files. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Loading and Saving Settings 
Most adjustment operations in EzImage provide the ability to load and save settings using an adjustment 
file. The adjustment file is specific to each operation, and is identified by a unique file extension. These 
files are by default placed into the User folder of the application path. Adjustment files not only provide a 
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convenient method by which to apply the same adjustments repeatedly to several images, but they are 
also used for: 
 

Color adjustments with the File Conversion tool. 
 

Color adjustments applied to printed thumbnail image sheets. 
 

Embedding in script files when writing script files outside of the recording process. 
 
For the color mixer process, the adjustment file extension is .MIX. 
 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Resetting Adjustment Values 
For operation windows that have a Reset button, you may use it to restore all settings to default values. 
 
Related topics: 
 
Levels 
Brightness and Contrast 
Hue and Saturation 
Color Balance 
Channel Adjustment 
Equalization 
Image Inversion 
Stretch Intensity 
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Applying a Mosaic Effect 
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This filter imposes a mosaic effect on the image by dividing it into tiles of a specified size and changing 
the color of all pixels in each tile to the average color of pixels within the same tile. 
  
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
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Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Noise Filter 
Emboss Filter 
Oilify Filter 
Posterize Filter 
Solarize Filter 
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Multi-page Extraction Tool 
 

 
 
A few of the file formats supported by EzImage can contain multiple images, stored in a multi-page 
format. These formats include: 
 

Kodak Photo CD (PCD) 
FlashPix (FPX) 
Tagged Image Format (TIFF or MPT) 
ZSoft PCX (PCX or DCX) 
Windows Icon and Cursor Files (ICO/CUR) 
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With the exception of Photo CD, EzImage does not provide any ability within the standard open image 
operations to accommodate which image in a multi-page format to choose. The first image (page) will 
always be selected when viewing or opening any of these other file formats.  
 
If you wish to access all the images in a multi-page format file, you can use this tool to extract the images 
into separate files, using the same file format. For FlashPix files, the compression settings applied are the 
ones from the application general preferences. 
 
The extracted files will have the same name as the source file, with a 3-digit sequence number appended 
to it. Files will be extracted to the specified target path. 
 
Note that for icon and cursor files, you can use the Import and Export tools to work with multiple icon 
sizes and color depths at one time, using multiple image windows. The import tool will load all available 
icon and cursor images at one time. 
 
Related topics: 
 
Icon and Cursor Files 
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Creating a New Image 
 

 



EzImage Reference – Version 1.05 

 

 Page 194 

 

 
Image Name 
A new image must use a name that is unique compared to any other open image window. EzImage does 
not allow you to have the same image name open in two separate windows, even if the images reside in 
different paths on your system. In addition, an image name can’t contain any illegal file name characters. 
By default, a new image will be assigned the name of Unititled-#, where # is a sequential number that 
starts at 1 and increases for each new image window created. 
 
Source 
The source for a new image can vary depending on what is available on your system and within the 
application for creating one. 
 

The highest priority will always be the Windows clipboard. If a Device Independent Bitmap (DIB) 
image is present in the clipboard, the new image method allows you to create a new window with the 
DIB automatically placed within it. 

 
A region selection within the active image window will have the next priority. The dimensions of the 
bounding box for the region will be used for the default width and height. 

 
If the active image does not have a region, then the default width and height will match the size of the 
image. 

 
If there are no open image windows or a clipboard image available, then source will default to 
Custom, which is the complete set of parameters for making a new image of a size and format that 
you specify. The custom settings are always saved when you close the application. 

 
Format 
The format for a new image can be 24 or 32-bit RGB (the latter contains a blank alpha channel), 256-level 
gray scale, or indexed color using a 2, 16, or 256-color palette. If the source is not a Custom image, the 
format option is disabled, since it is derived from the active image or Windows clipboard. 
 
Width and Height 
The width and height of the image can be specified in pixels, centimeters, millimeters, or inches. For the 
latter 3 units of measure, the Resolution field is used to determine the total number of pixels based on 
the width and height. If the source is not a custom image, the dimensions are derived from the active 
window, selection size, or size of the image in the Windows clipboard. 
 
Resolution 
The resolution is defined in terms of dots per inch or dots per centimeter. This value determines the print 
size for an image. If you are using dots per centimeter, the value will be converted to dots per inch when 
the image is saved to file. The final image size in terms of memory footprint and pixel size is shown in the 
title bar of the new image window. 
 
Screen Resolution 
Click on the Screen button to set the resolution field to the dots per inch value of your screen display. 
 
Fill With 
You have several color choices that you can fill the image with when it is created. The Other color option 
uses the color shown in the swatch to the right of the dropdown list. The Clipboard fill option will 
automatically fill the image with the pixels of the image in the Windows clipboard. This option is only 
available when the source format is Clipboard Image. If you choose a color for an indexed image that is 
not part of its default palette, then closest approximation will be used. 
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Palette 
When creating indexed-color images, you can specify the palette type from the choices available in this 
dropdown list. The Default option will use a standard built-in fixed color palette. The File option will use 
the palette file shown next to Palette File. Clipboard will use the palette assigned to an image in the 
Windows clipboard. Active Window applies the palette from the active image window if that image is 
indexed-color. 
 
Palette File 
When creating indexed-color images using a palette file, you need to provide a reference to the file in this 
field. The file must be a standard EzImage color palette file, with an extension of .PAL. Palette files are 
generally located in the User folder of the installation path. You can create custom palettes using options 
in the Color Palette floating window, or save the color palette from any indexed-color image to a PAL-
format file. 
 
Limitations 
EzImage does not allow images with a width or height that exceeds 30,000 pixels, or a memory size of 
more than 256 megabytes per image. 
 
Related topics: 
 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 
Filling and Images 
Clearing Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
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Adding Noise 
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This filter works by adding random pixels of noise to individual color planes or to all color channels. The 
noise level can value from 0 to 100 percent in 0.1% increments. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
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click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Emboss Filter 
Mosaic Filter 
Oilify Filter 
Posterize Filter 
Solarize Filter 
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Applying an Oilify Effect 
 

 
 
This filter applies an oil-painting effect to the image. Increasing values will result in a more dramatic effect 
and reduce the amount of image detail. At the highest setting, the amount of processing time can be quite 
significant on large images. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
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By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Noise Filter 
Emboss Filter 
Mosaic Filter 
Posterize Filter 
Solarize Filter 
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Image Information Overlays 
 
Image windows contain two layers of information: 
 

The image pixel data, which can included region selections and floating image selections. 
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An overlay area, which contains the line work for grids, the measure tool, and the cross hair tool. In 
addition, temporary line work, such as drag-selecting a rectangle, is also part of the image overlay 
area. The image rulers, if enabled, sit on the edge of the window and are not actually part of the 
image itself. 

 
The following window sample shows all of these overlay items at one time: 
 

 
 
The measure lines are shown in white, the grid lines appear in black, and the cross hair lines appear in 
yellow, with the Rulers option for the latter tool enabled. The image rulers are enabled as well, in pixel 
units. 
 
Image overlay items are not part of the image itself, and appear with specific colors that are common to 
all images. Depending on the image you are working on, you may wish to change the colors of these 
items for the best possible visibility. Grid lines are enabled with an option in the View menu, and 
configured using the general preferences.  
 
Since there are two separate layers to an image window, you may tend to notice flickering of the overlay 
line work depending on the type of operation you are performing on the image. Bicubic and Linear paint 
scaling modes will impact the speed by which overlay lines are refreshed on the image window. 
 
Related topics: 
 
Image Windows 
Setting Magnification Levels 
Window Arrangements 
Fitting a Window to an Image 
Fitting an Image to a Window 
Window and Cross Hair Rulers 
Close vs. Close All 
Display and Dithering Quality 
 
 
Top 
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Introduction 
 
EzImage is a simple, yet powerful and flexible image processing and image file management application, 
which provides the necessary tools to help you quickly scan, alter, convert, and organize your image file 
library. 
 
EzImage is not a large or complex application that requires you to read one or more books or go through 
lengthy tutorials to understand how to effectively use it. EzImage was designed to cater to the needs of 
the everyday consumer, and provide the features common in most image -processing application, with a 
few extra ones that help automate and decrease specific time-intensive jobs. 
 
This topic only provides a brief overview of some of the features available in EzImage. You can jump to 
the Getting Started topic for a more thorough introduction to the application. 
 
Key Features of EzImage: 
 

Comprehensive set of color adjustment and painting tools for touching up and correcting images. 
Basic painting tools include pencil, erase, paintbrush, dodge, burn, sponge, clone, blur, sharpen, and 
line/polyline. Region and Floater system provides a simple, yet flexible method to work with images 
using temporary image snapshots and alpha channels. 

 
Color, distance, and angle measurement tools for image content verification. 

 
Several browsing options for searching and organizing images, including a flexible preview browser, 
image lists, and path lists. 

 
Thumbnail database system, including security and encryption options. 

 
Slideshow system, which uses scripts to control image playback, image adjustments, and text and 
comment associations. 

 
Selection separation tool for splitting multiple-document scans into separate images. 

 
Edge deskew and auto-trim tools for correcting the orientation of crooked images and removing extra 
border pixel data. 

 
File conversion tool to process batches of image files using lists, paths or folder trees. Conversions 
can be based of file format changes, image color adjustments, transformations, overlays, renaming, 
or most any operation within EzImage. 

 
Scripting system for automating several actions into one easy step. 

 
Image comparison tool for comparing two images by both color and distance measurement. 

 
Image capture tool will capture windows, screens, portions of screens, wallpaper, cursors, or objects 
such as buttons and text fields. 

 
Compression tuning tool to allow you to visually see how different levels of file compression can affect 
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the size and quality of images, and apply settings for optimizing creation of files that use these 
compression methods. 

 
Windows Icon and cursor utilities allow you to import and export multiple icons or cursors using 
separate image windows. 

 
An online help system that includes two levels of help: popup quick help and context-level window 
help. The quick help system allows you get information on almost any item in EzImage using either a 
right click of the mouse button or through easy-to-use menu help mode system. 

 
Printing support for both single images and thumbnail image sheets, using various options to scale 
and fit the images to the printed page. 

 
Batch file scanning is provided in addition to normal single image scanning, in case you wish to scan 
many documents at one time. The batch scan feature allows you to choose one of several formats to 
save to. 
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Script File Maintenance 
 
You can access the scripts palette editor using the Tools->Scripts->Palette menu option or by right 
clicking on the scripts palette and choosing Palette Editor from the popup menu. In either case, you will 
see the palette editor window: 
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The left side of the window contains a list of all the Sets available. Since a set is simply an alias for a 
folder name, this list also represents the folders that sit beneath the Scripts folder in the EzImage 
application path.  
 
The right side of the window contains a list of script files for the current Set that is selected. The Palette 
Name is what appears in the menu for a script shortcut and is the button label for the script entry in the 
palette. Scripts are always sorted by this name in the palette. The File Name is the actual script file name 
stored on disk. Note that scripts that were created using the Menu Record feature will appear with a tilde 
(~) character in front of the file name. 
 
The bottom part of the window contains some basic information for the selected script file. If you have 
selected more than one script file, this area will be blank. 
 
Creating a New Script Set 
Creating a new script Set is simply a matter of providing a new folder name that is meaningful to the type 
of script it will contain. When you create a set with a name of “My Scripts” for example, a folder will be 
created within the Scripts folder, as in Scripts\My Scripts. Since a set is a folder name on your system, 
you can’t use any illegal file name characters. 

 
Set to Palette 
This option will assign the selected set in the list as the default one for the scripts palette window. The 
palette editor window will close after this. 
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Deleting a Set 
Use the Delete Set option to removing the set folder from your system along with any script files that are 
contained within it. Please use caution with this option, since you can’t undo the file deletions. 
 
Deleting Scripts 
The Delete option removes all selected script files belonging to the current set. The files are physically 
removed from your system and this option is not undoable. 
 
Editing Script Base Properties 
Use the edit option to change the properties for the selected script file. Scripts are plain text files that 
contain some key lines of information that identify its format. The edit option doesn’t provide any text 
editing service to alter the actual script commands. You can compose or alter a script file using any text 
editor of your choice, as long as the initial script property lines are not altered. 
 
Copying and Moving Script Files 
You can copy or move script files from one set to another using the appropriate menu options. The 
process is fairly simple, since all that is being done is a physical file copy or rename from one location to 
another. You can perform the exact same method by using Windows Explorer to drag-and-drop files from 
one set’s folder to another one. 
 
Removing Menu Shortcuts 
The menu labeled Menu is used to remove script files from the menu shortcuts found in the Tools-
>Scripts submenu of EzImage. The Clear option will remove all scripts from all menu positions in one 
step. 
 
Resetting Sizes 
Most viewers or editors in EzImage are sizeable windows containing panes of information that can be 
resized, such as dividing the window between image area and file list area. All of these size and position 
settings are permanently saved when you close the application. In the instance when you change screen 
resolution to a lower dimension, some of the information may be off the screen. Use this option to reset all 
window pane positions to default values. 
 
Related Topics: 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Scripts Palette 
Menu Shortcuts 
Writing a Script File 
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Text Associations 
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Text associations are used to attach a description to any image in a slideshow. To take advantage of this 
feature, you should ensure that the images you display are smaller than the window used for script play 
back. If the images occupy too much vertical space in the window, then the text association will not 
appear. The best method controlling the image size to ensure that the text can be displayed is to use the 
vertical positioning attribute and optionally use the constraint feature to keep the image no larger than a 
specific size. 
 
The text properties window displays the font, size, color, and text exactly as it will appear on the slide 
show playback window. You should avoid using hard returns in the text since it will automatically be 
wrapped to fit within the play back window. 
 
Defining a Font 
You can choose the font properties and color for the text association by clicking on the Font button and 
swatch color. Keep in mind that the background color, which appears as the background for the text input 
memo field here, is assigned in the general slide show preferences and applies to all images in the script. 
 
Alignment 
The text can be either left or center-aligned (within the visible screen area) by choosing one of these two 
options. 
 
Width Limiter 
Choose the Percentage option to limit the text width to a percentage of the slideshow window width. For 
example, a value of 50% with a slideshow window of 1024 pixels results in no text line being more than 
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512 pixels in width. This is the recommended choice, as it will work independent of the slideshow window 
size. 
 
The Actual Pixels option will restrict all text lines to be no wider than a value you specify. While this gives 
you more control over the size of the text area, it limits the slideshow display to work on a specific screen 
and slideshow window resolution. 
 
Image and Text Gap 
This value defines an extra amount of blank area that can appear between the bottom of the image and 
the top of the first line of text. The amount is in pixels. 
 
Percentage of Screen Width 
This value is either the percentage of screen width to use for the text, or the maximum pixel width, 
depending on the Width Limiter choice. 
 
Line Spacing Adjustment 
Text will by default use the nominal line spacing as defined by the font. In some cases, the line spacing 
may be smaller or larger than you would prefer. The adjustment here allows you to increase (use positive 
values) or decrease (use negative values) the spacing. The spacing is expressed as a percentage of the 
default distance between successive text lines. 
 
The range is -50 to +500 percent. 
 
Using Text In Place of Thumbnail Comments 
Check this option to bind the text association to the thumbnail comment display area. Thumbnail 
comments are single lines of text that can appear in the slideshow screen above or below the image, and 
differ in the fact that they appear at the edges of the slideshow window. You can choose to display a text 
association as a replacement for thumbnail comments in a slide show, as long as the text is no more than 
one line in length. 
 
Removing Test 
Click on Remove to remove all text associations for the selected slideshow images. 
 
Related topics:  
 
Slide Show System 
Creating Script Files 
Play Back System 
Slide Show Script Editor 
Image Attributes 
General Preferences 
Browsing Slide Show Images 
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Photo CD Format Selection 
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This topic is currently under construction. 
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Path Lists 
 
Path lists in EzImage represent a collection of fully qualified path names. What this means is that any 
path in the list must be begin with a logical drive letter or UNC network system identifier, such as: 
 
C:\My Documents\My Images\Samples1 

 

\\System133\ShareA\Images\Group1  

 
Path lists provide two useful purposes in EzImage: 
 

They are a source for images in the File Conversion tool. By using a path list file, you may convert 
images from several different paths that may reside on multiple systems across a network. 

 
You can bookmark paths to create a Favorites list. The path list editor provides the ability to use any 
path as a starting point for the thumbnail browser, image preview browser, and the standard open file 
dialog. 

 
Adding Paths to the List 
You can add a path to a list using the following: 
 

Image preview browser 
Image list editor 
Thumbnail browser 
Click on the Add button in the path list editor 
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Loading and Saving Lists 
Path lists are stored in the Lists folder of the application path with an extension of .PLF. These are plain 
text files, which contain fully qualified path names. Use the Load and Save buttons to for storing and 
retrieving path lists. 
 
Opening Images and Browsing 
Use the Open option to browse for images using the current selected path (only one path may be 
selected). 
 
If you hold down the SHIFT key while clicking on Open, then you will automatically be placed in the 
preview browser. 
 
If you hold down CTRL, you will be placed into thumbnail browse mode. 
 
Deleting Paths 
The Delete option will remove all selected entries from the path list. The Clear option will remove the 
active path list from memory. The Clear and Delete options are not undoable, so please ensure that you 
save a path list to file if you wish to retain it for future reference. 
 
Related topics: 
 
Image List Editor 
File Conversion Tool 
Thumbnail Browser 
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Image Preview Browser 
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Thumbnail Image Printing 
 
EzImage allows you to print multiple thumbnail images on a single page using a row and column 
arrangement. Thumbnail printing uses the same page setup configuration as normal single image 
printing, with a few added options for the row/column format. 
 
To configure the page output for thumbnail printing, choose Print Setup from the thumbnail browser 
menu. You can view the help topic for general printing options by clicking on this link. 
 
Thumbnails are printed from left to right for each row then wrap around to the next row. Once all rows are 
filled, the page is printed and a new one will be started. The thumbnail images will be scaled to fit within 
the margins of the printed page, using the horizontal and vertical spacing between images defined in the 
printer options. If labels are assigned to the images, then the vertical spacing will be automatically 
adjusted to compensate for the label text. 
 
Each image on the page will have a fixed cell size for the image. When printing a thumbnail, the source 
image must be available, since it is the one that is scaled to the printed page. Thumbnail images as 
stored in the database are never sent to your printer. 
 
For example, if you have defined a 3 row by 3 column thumbnail setup, with .25 inch spacing between 
images (both horizontal and vertical) and 0.5 inch margins, then the image cell size on an 8.5 x 11 inch 
page will be: 
 

(8.5-0.5*2 (Margins) –0.25*2 (Spacing))/3 = 2.33 inches width 

 

(11=0.5*2) – 0.25*2)/3 = 3.17 inches height 

 
All images will be scaled to fit the 2.33 x 3.17-inch area, while preserving the source file aspect ratio. The 
image will be auto-centered within the cell area. 
 
Notes: 
 

No thumbnail images will be printed that would result in a cell size of less than 0.5 by 0.5 inches. 
 

Only selected thumbnail images will be printed. If you wish to print images from more than one file 
folder at the same time, use the Full Browse mode to show all database images at one time. 

 
The source image file must be present on your system, since the thumbnail representations are not 
sent to the printer. 

 
Related topics: 
 
Printing Images 
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Printing Options 
Single Image Printing 
 

Thumbnail Database System 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
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Single Image Printing 
 
Choose File->Print from the menu to send the image in the active window to the printer. Before you print 
any images, you should use the Print Setup menu option to select the printer device, define the page 
size, output quality, margins, headers, footers, and scaling method. 
 
Image Scaling and Print Resolution 
EzImage provides 3 different methods to print an image, using a scaling method that determines how the 
image will fit on the physical page: 
 

Print Size: This method will print an image according to the resolution value defined within the image 
itself. For example, an image that is 600 by 400 pixels with a resolution of 72 dots per inch will be 
printed with a width of 8.33 inches and a height of 5.55 inches. The image will be scaled to match this 
size. If the print size does not fit within the margins of the page, you will be unable to print it with this 
method. 

 
Fit to Page: This method will fit the image exactly within the margins that you specify, while 
preserving the aspect ratio. For example, on an 8.5 by 11-inch paper size with 0.75-inch margins, the 
image will be scaled to fit within an area of 7 by 9.5 inches. 

 
Actual Pixels: This method will print an image with no scaling of any kind. The number of pixels in 
the image will match the number of dots on the printed page, provided that the image will fit on the 
page. For example, a 1200 by 600-pixel image printed at 600 dots per inch will occupy an area of 2 
by 1 inch on the page. 

 
For the Print Size method, you can use Image->Resize with Resample mode disabled to change the DPI 
(printer resolution) of the image to ensure that it will fit within the page margins. 
 
Related topics: 
 
Printing Images 
Printing Options 
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Thumbnail Printing 
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Applying a Posterize Effect 
 

 
 
The posterize effect works by quantizing the image colors to a specified number of color levels per 
channel. For example, a setting of 2 means two of red, two of green, and two of blue. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
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size. 
 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Noise Filter 
Emboss Filter 
Mosaic Filter 
Oilify Filter 
Solarize Filter 
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Preferences (Options I) 
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Paint Dithering 
EzImage is optimized for video display systems with more than 256 simultaneous colors. However, the 
program is fully useable with a 256 color display (16 color display mode is not supported by this 
application). This setting controls the dithering type for images that have more than 256 colors. 
 
Paint Scaling 
Paint scaling only applies to images that are viewed at less than 100% magnification. At 100% or higher 
normal paint scaling is used. The Nearest Neighbor method is fast at the expense of artifact noise on 
some images. Bicubic and linear provide very good display quality, but at a significant increase in 
processing time when viewing large images. Scrolling and overlays, such as gridlines, cross hairs, 
marching-ant marquees, and measure lines will operate much slower when using the latter two modes. 
 
Window Background 
If you are viewing an image such that its display size is less than the size of the window it is contained in, 
the remaining border area will be filled with this color. This area can not be modified by any painting or 
image-processing tool. 
 
Use Preview Browser to Open Files 
When selecting the Open option from the File application menu, you can either choose the standard file 
open file dialog, or check this option to use the EzImage preview browser to open images. 
 
Auto Resize Windows on 100% Magnification 
Check this option to force all operations that auto-set 100% magnification to try and fit the window to the 
image area. For example, a double-click on the Magnify tool sets the image view to 100% scale. If the 
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Auto Resize option is checked, the window will be resized to fit around the entire image, provided that 
window dimensions would fit within the visible screen area. 
 
Mouse Smart Move 
Smart mouse mode causes all mouse cursor positioning to immediately shift to the primary control 
(button, edit field, checkbox, etc.) in a dialog window when it is first displayed. Note that smart mouse 
mode does not work on any dialog windows that are outside control of EzImage (Windows printer setup 
dialog window as an example). 
 
Auto Name Images Created by Duplication 
Two operations in EzImage allow you create a new image window from an existing one: Duplicate Image 
and Save Selection to Image. In either case, you have the choice of having the window automatically 
named for you (Untitled- and a sequence number) or you can specify the name using a popup dialog 
window. 
 
Auto Creating Shape Sizes 
If this open is not checked, then the Shape tool will always create a new shape from the bounding area of 
any existing selection region in the image. Check this option to ensure that all shapes are created using 
the normal selection methods (drag-select, fixed size, or cross hair modes). 
 
Grid Line Color 
Since grid lines are not part of the image itself, you will need to specify a color such that the lines will be 
visible given the color information of each image you are working on. 
 
Grid Line Units 
You can place a gridline overlay on top of each image (the setting applies to all open image windows), 
using a specific color, spacing and measure unit. Gridlines are not part of the original image, and as such 
can flicker briefly when scrolling or moving image selections around.  Units can be pixels, inches, 
centimeters, millimeters or percent of image size. 
 
Grid Line Spacing 
When specifying a grid line measure unit, you need to define the spacing of the actual grid lines. If the 
unit of measure is inches and you set spacing to 2.5, then gridlines will appear every 2.5 inches on the 
image window. Note that gridlines are scaled by zoom level. If a gridline’s physical pixel spacing on the 

image window would be less than 8 pixels in either width or height, the gridline display will be hidden. 
 
Tool Tip Windows 
These windows are displayed when you right click on most controls or buttons in the EzImage application. 
The tool tip window is used to show brief help at the control level on any window in the application. 
 
Font Size 
This is the font height in points for the tool tip help windows. You can use a value from 8-12 points. 
However, unless you are running at high resolutions (1024 x 768 or above), the 12-point font size may 
cause some of the popup help windows to run off the screen edges. 
 
Font Type 
A tool tip popup window can use any font, but one should be chosen for optimal visual clarity with the 
specified point size. Click on Font to set the font type. 
 
Background Color 
Popup help windows will use this color for the background areas. 
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Text Color 
Popup help windows will use this as for the font text color. 
 
Cursor and Icon Transparent Color 
When importing cursors or icons from file, or exporting cursors or icons to file, this color is the 
transparency color for areas that are not part of the cursor/icon mask. Keep in mind that the export option 
has both transparent color and alpha channel mask export facilities. When using the latter method, the 
transparent color is not used at all – the alpha channel mask data determines transparent areas. 
 
Reset Preferences 
Click this option to reset all preferences in EzImage to default values. This involves the deletion of the 
EZIMAGE.INI settings file. When you restart the application, a brand new file will be regenerated using 
default settings. 
 
Reset Palettes 
Click this option to reset the positions of all floating palettes in the application. This can be useful when 
changing display modes from high resolution to one of lower resolution. 
 
Reset Dialogs 
Many dialog windows in EzImage are resizable, and many of these windows contain lists of information 
with resizable columns. This option will reset all of these dialog windows back to initial dimensions and 
positions, and all lists will have their column sizes reset as well. 
 
Related topics: 
 

General Options (2 of 2) 
Thumbnail Options 
Image Browsing Options 
Slide Show Options 
Kodak Photo CD Options 
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Preferences (Options II) 
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File Compression Save Options 
When you save new images to file, you will always be presented with compression options for these there 
file types at the time of the save. However, if you open images that use one of these formats, no save 
dialog is shown when using the File->Save menu option. The options in preferences determine the 
settings that will automatically be applied to a resave. 
 
JPEG 
Click on this button to change the JPEG compression options when resaving files (using the Save menu 
option as opposed to Save As). If you are loading JPEG images for alteration, you will end up losing 
detail on top of what has already been lost on the initial file creation with each new resave. It is 
recommended that you always work with uncompressed image formats, then save one time to JPEG. The 
Compression Tuning tool can help you determine optimal compression settings. 
 
Portable Network Graphics 
Click on this button to change the PNG compression options when resaving files. 
 
FlashPix 
Click on this button to change the FPX compression options when resaving files. 
 
Gray Scale Masks 
Gray scale masks apply to floaters in RGB and gray scale images. Floaters are parts of the same image 
(or another image) that you drag around within the image window. Since they do no disturb the pixel data 
of the underlying image until you perform a paste operation, they will 'float' over the background image. 
EzImage does not use the layering system you see with some of the high-end image processing 
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applications. You may think of a floater as a 1-layer system. A floater is always a rectangular piece of an 
image. A mask is used to define the shape of a floater, allowing it to have any type of irregular shape. 
Gray scale masks provide for special transformation effects, specifically the ability to rotate and resize 
floaters. Unless you have a need to perform these two operations on a floating image, you can save 
memory and improve the rendering speed by leaving this option checked. 
 
Show Outlines When Dragging Large Floaters 
If you have a slow system or one with limited free system memory, you may wish to adjust this value. 
Large floaters that contain several million bytes of pixel information can be quite slow to drag around the 
image window, especially when combined with opacity and blend modes. This value defines a cutoff point 
for a floater size. If the floater is over this pixel memory size, it will be rendered with a simple rectangular 
outline when dragging across the background image.  
 
Script Palette Rows 
The scripts palette has space for a specific number of rows of command buttons. If a script set contains 
more than the number of buttons available in the palette, scroll bars will appear and allow you to move 
the script list vertically. Scripts are always alphabetized by their palette name. You can use between 4 
and 20 command button rows. 
 
Script Palette Button Width 
If you have any scripts with long palette names, they may be truncated when using the default button 
width. Enter a larger value here to increase the width of each button in the scripts palette. You can use a 
width between 16 and 300 pixels for a button. 
 
Script Playback File Changes 
There are several script commands that can alter the contents of one or more files on your system. You 
have the option to filter this process before any file can be altered. Note that the ignore script command 
option may cause the script to fail later on depending on the nature of the command sequence in the file. 
 
Disable Script Playback Messages 
Scripts can be recording will small popup messages of any possible content, which can appear anywhere 
in the script file command list. You can disable these popup messages by checking this option. 
 
Saving New Files to a Common Folder 
The normal method of operation for the “Save As…” menu option is to use the same file path where the 
image was loaded from. If the image was created from an alternate method (scanned, new image, etc.) 
then the default save path is the last valid save file path. With this option checked, all new images are 
saved this folder at any given time. 
 
Related topics: 
 
General Options (1 of 2) 
Thumbnail Options 
Image Browsing Options 
Slide Show Options 
Kodak Photo CD Options 
 

 
Top 
 
 

 



EzImage Reference – Version 1.05 

 

 Page 217 

 

 
 

Preferences (Thumbnail Browser) 
 

 
 

Background Color 
This is the background color for thumbnail images where the image is not occupying the full width and 
height allocated for its thumbnail. 
 
Border Color 
This is the color of the lines that border each thumbnail image in the display. 
 
Selector Color 
Each selected thumbnail image will have a rectangular outline cursor surrounding it. This is the color for 
that cursor. 
 
Font Color 
When using labels, this is the color for the text labels. When labels are off, this is the color for the image 
name that appears on any file entry for which no current thumbnail image exists. 
 
Font Color (Image Changed) 
When images are changed after their thumbnail image has been created, their content may no longer 
match the thumbnail. When this happens, the text label will appear in this color indicating that the image 
has changed (A change is registered when either the file size or date of last modification is different from 
when the thumbnail was created). 
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Label Background 
If you are using labels for thumbnails, this is the background color for the label area only. 
 
Setting the Font 
For both labels and for thumbnails with no labels, click on Font to choose the font properties. 
If you are using small thumbnails, or the file names are lengthy, then larger font choices can cause the 
information to be truncated (you can create smaller thumbnail images, then size lock the thumbnail view 
to a larger format at any time). 
 
Selector Opacity 
This is the opacity level of the outline cursor that appears around selected thumbnails. Values from 1 to 
100% are acceptable. 
 
Thumbnail Width and Height 
Thumbnail width and height can be changed at any time. This does not affect any current thumbnail 
images in any database. It can however cause current thumbnails to be truncated if they are larger than 
the new width or height settings (they are truncated on display only, they are still 100% complete in the 
database). When creating thumbnail images, the current width and height determine the size of any new 
thumbnails you add to the database. 
 
Lock Size 
Size locking is used to force any folder of file images to be locked to a specific thumbnail width and 
height. For example, a folder with 50 x 50 thumbnails can be locked so that when you view that folder 
only, the thumbnail width and height will be set to 50 x 50, independent of the width and height shown in 
the preferences. 
 
Size Reduction 
When creating thumbnails, you can improve the quality of the images by using the bicubic or linear 
reduction methods, albeit at a significant increase in processing time. 
 
Color Reduction 
When creating indexed color thumbnails, you can choose one of these dithering methods for the color 
reduction process. If the image is already in indexed color format, no dithering will take place. The 
adaptive reduction method is slowest, but generally results in the best quality for most images (adaptive 
reduction does not apply any form of dithering). 
 
Selector Outline Size 
This option allows you to set the thickness of the outline area that makes up the cursor around each 
selected thumbnail image. 
 
Labels 
If you specify labels, then each thumbnail image will include text information beneath its image. The 
number of lines of information is determined by the label setting you make. With no labels, the thumbnails 
will pack together side-by-side, top to bottom, with file names only appearing where there is no thumbnail 
image available. 
 
Storage Format 
Thumbnails can be stored in one of 4 different formats. You can mix and match these formats in the same 
thumbnail database freely. 
 

True color format offers the best quality and rendering speed, but at a significant cost in terms of 
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database size. 
 

Indexed color mode is fast, but quality may not always be as good as JPEG or true color. 
 

JPEG high quality is almost as good as true color quality, but rendering speed is much slower.  
 

Low quality JPEG will result in very small database files, but will also result in the same slow 
thumbnail rendering speed found as the high quality JPEG format. 

 
Applying a Sharpen Filter 
When reducing images by more than 800%, they can become fuzzy in appearance. You can check this 
option to apply a baseline unsharpen mask filter to the thumbnail. This will add a little bit of detail back, 
but will also make the thumbnail creation process slower. The sharpen filter will only be applied when the 
thumbnail image is less than 1/8 the size of the original source image. 
 
Exclude File Extensions 
When viewing thumbnails, you can choose to not show file extensions with the file names. 
 
Auto Transparent Bitmaps 
This option does not affect the thumbnail image contents in any way. It is used to apply auto-transparency 
to the display of thumbnails only. If this option is checked, then any pixel of color that matches the upper 
left pixel in the thumbnail image (not the original image) will be replaced with the thumbnail background 
color. 
 
Show File Names as Upper Case 
Check this option to show all file name labels in upper case text. 
 
Auto Size Thumbnail Width and Height 
If this option is checked, then each folder of thumbnails will be adjusted so that the width and height of 
each image in the grid will occupy only as much space as is needed to display the largest thumbnail 
image in that one folder. This option is bypassed for any folder where size locking is enabled, or if you are 
using labels of any kind. 
 

Related topics: 
 
General Options (1 of 2) 
General Options (2 of 2) 
Image Browsing Options 
Slide Show Options 
Kodak Photo CD Options 
 

Thumbnail Database System 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
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Preferences (Image Browsing) 
 

 
 
Preview Browser Background Color 
Both the image list editor and the image preview browsers display images as part of their window design. 
This setting determines the background color of the image display area that is not currently occupied by 
image data. 
 
Preview Browser Display Quality 
For both the image list editor and the image preview browser, this setting determines the quality of the 
images displayed. Higher quality will be significantly slower to render. 
 
Windowed/Full Screen Preview 
These options apply when showing an image using a separated preview window, such as when you 
double click on an image in the preview browser to show it at the maximum visible screen size. 
 
The Background and Quality settings are similar to the ones for the preview browser, as applied to the 
full screen previews. 
 



EzImage Reference – Version 1.05 

 

 Page 221 

 

Show Full Path with Details 
When viewing images in full screen mode with a window frame, this option adds the file path to the image 
information details. 
 
Show File Names with Details 
This option will hide the file path in the title bar and show the file name only. 
 
Full Screen Preview Mode 
Check this option to hide all window areas on the screen including the Windows taskbar. There will be no 
visible title bar. This is similar to viewing the image in a slide show. 
 
Mini Preview Windows 
The thumbnail standard and catalog browse options can have an optional mini-preview window enabled, 
which shows an image sample without the need to create thumbnails. The background and quality 
settings refer to images in those viewers. 
 
Using the Default Application Assigned to File Types 
When opening images from the thumbnail browser, image list browser, or any other file image browser in 
the application, the default choice is to open the selected images (up to a maximum of 50 at one time) in 
EzImage as a new image window. If you check this option, single image loading will be redirected to the 
application that is currently assigned to the file type, based on settings in the Windows registry. 
 
File Filter 
Click this button to call up the file filter dialog window. This option allows you to restrict the files that will 
appear in the image browser operations only (thumbnail and preview). 
 
Related topics: 
 
Supported File Formats 
Image List Editor 
Image Preview Browser 
Thumbnail Image Browser 
 

General Options (1 of 2) 
General Options (2 of 2) 
Thumbnail Options 
Slide Show Options 
Kodak Photo CD Options 
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Preferences (Slide Show) 
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Background Color 
For slideshow mode, this is the background color where the current displayed image does not extend. 
 
Font Color 
This is the font color to use for file and path name information displayed in a slideshow. 
 
Marked Font Color 
Slideshow images can be marked for later viewing using the marked image browser. When an image is 
marked in a slideshow, the file and path name appear in this color. 
 
Font Type 
Click on Font to set the font for file names and paths displayed in the slideshow window. Note that text 
associations are displayed in their own font independent of this setting.  
 
Show File Name 
Check this option to show file names in the slideshow window. 
 
Include File Path 
Check this option to include the path name along with the file name in the slideshow window. 
 
Password Lock 
Check this option to lock the slideshow with a password. When a password is in place, it prevents anyone 
from closing down the slideshow display and from placing the slideshow display into manual control mode 
(where you can make adjustments to the playback script). It does not prevent someone from using the 
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Windows task manager to shut down the application or from switching to alternate applications. 
 
Full Screen Mode 
Check this option to display slideshow images in a window that occupies the entire visible screen display. 
With this option unchecked, images are displayed in a sizeable window, with information appearing in the 
title bar.  
 
Show Thumbnail Comments 
Check this option to allow thumbnail comments to be displayed at the top or bottom of the screen for any 
images that either have a thumbnail database file association (with comment) or any slide image that has 
a text association setting with the thumbnail mapping enabled. 
 
Random Shuffle 
Check this option to randomly shuffle every image in the slideshow script before they are displayed. 
When the list is exhausted, a new random sequence will be created. 
 
Disable Screen Saver 
Check this option to temporarily suspend the Windows screen saver while a slideshow is playing. When 
you close the slideshow window, the screen saver setting will be restored. 
 
Skip Open/Read Errors 
Check this option to skip any file read or format decoding errors. If a file has problems in being displayed, 
it will be skipped and the next file will be shown. When you close the slideshow, the very first file that 
cause a problem will be shown in a dialog window. If you don’t check this option, then the first file 
decode/read error encountered will stop the slideshow playback completely. 
 
Windowed Mode 
Check this option to show slide images in a sizeable window you can move around. File information will 
appear in the title bar area of the window. 
 
Adjust Image for Comments 
If you are displaying thumbnail or text association comments (assigned to the thumbnail area), they are 
normally shown on top of any image area that may extend to the top or bottom of the screen. This may 
cause the text display color to blend in to a close or equal color level in the image data, rendering the 
comment unreadable. This option will ensure a small amount of space is left for one line of comment text. 
 
Seconds Between Images 
This will be the delay between each image displayed. The slideshow playback system reads the next 
image while the current one is being displayed, so that the playback process is as seamless as possible. 
Be aware that large images or ones with complex decoding systems may take longer to load than the 
delay between images. In either case, the delay will be no less than the time it takes to load and decode 
an image file. 
 
Password 
If you password lock a slideshow script, you must enter the password twice. 
 
Display Quality 
Unless you are using a very short delay between slide images, always use the maximum quality setting 
for slideshow playback. 
 
Position of File Name 
You can show the file name and path information in one of several positions on the screen. 



EzImage Reference – Version 1.05 

 

 Page 224 

 

 
Cycling Mode 

Continuous mode will play all images in sequence (random or non-random) then repeat the process. 
 

One time mode will play all images then stop. 
 

Manual stepping mode allows you to use navigation/script control keys. 
 
Position of Comments 
Comments can be positioned at the top center or bottom center of the display. 
 
Related topics: 
 
General Options (1 of 2) 
General Options (2 of 2) 
Thumbnail Options 
Image Browsing Options 
Kodak Photo CD Options 
 

Slide Show System 
Creating Script Files 
Play Back System 
Slide Show Script Editor 
Image Attributes 
Text Associations 
Browsing Slide Show Images 
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Preferences (Photo CD) 
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The Kodak Photo CD format allows for several copies of an image to be stored in multiple sizes. There 
are several areas in EzImage that can access these file types, at which point a decision must be made on 
which size should be selected for opening. If the Always Ask option is available in a dropdown list, then 
you will be prompted for an image size every time you attempt to access a Photo CD file. Otherwise, the 
size you select from the dropdown list will be chosen if it is available. If the preferred size is not available, 
then EzImage will search the file for the next larger or smaller image, based on the Largest/Smallest 
choice you make in the PCD preferences tab. 
 
Full Size Image Previews 
This is the size to use for the full screen image previews with the following browsers: 
 
Thumbnails 
Image List Editor 
Image Preview Browser 
 
Single File Open 
This setting applies to any place in EzImage that opens a single image file in the main application 
window. 
 
Multiple File Open 
This setting applies whenever you open more than one image in the main application window. 
 
Generating Thumbnail Images 
When creating thumbnail images, this size determines the source to generate the thumbnail copy. Since 
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a thumbnail image can never exceed 200 by 200 pixels, you may achieve the best quality using the first 
available size higher than 200 by 200 pixels. 
 
Slide Show System 
When playing a slide show script, this size will be used for the playback window. If the size is largest than 
the slideshow screen, it will be scaled to fit. 
 
Mini-Preview Windows (Thumbnails) 
The thumbnail system provides for an optional mini-preview area of any image, independent of the 
thumbnail row/column image grid. This setting determines what size to use for the image preview. 
 
Related topics: 
 

General Options (1 of 2) 
General Options (2 of 2) 
Thumbnail Options 
Image Browsing Options 
Slide Show Options 
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Positioning Selections 
 

 
 
The position feature applies both to region selections and floating image selections. Since only a floating 
image or region selection can be active at any time for manipulation, the positioning dialog window 
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applies to both types of selections. The label at the top of the window identifies whether it is a floating 
image or region selection that is being moved. 
 
Current Position and Size 
These labels indicate the current upper left corner, width, and height of the region selection or floating 
image. You can change the unit of measure by clicking on the unit values to the right of these labels. 
 
X and Y Offsets 
The offsets are relative to the position origin. For example, an offset of (0, 0) using top-center positioning 
will move the selection to the top of the image and center it within the image width. When using origins 
that are relative to the right or bottom edge of an image, positive offsets move the selection inward. For all 
other origin points, positive offsets move the selection to the right and down. 
 
Units of Measure 
You can move the selection using one of several units of measure. For percentage offsets, the unit of 
measure relates to either the image size or the floater size if the Last Floater Paste option is checked. If 
the offset values are both 0, then the unit of measure will have no effect. 
 
Position Origin 
There are 11 basic origin points/methods for moving a selection. Absolute positioning moves the selection 
to the offset values. Relative positioning moves the selection from its current position by the offset 
amounts. The remaining 9 origin points define the 4 edge, 4 corner, and center position for the image. 
 
Movement by Percentage 
Check the percentage of image option to move a selection using a percentage of the image size. Check 
the selection option to move the selection using a percentage of itself. For example, if the selection is 300 
pixels in width and you move the image 50% using percentage of selection, the selection will shift 150 
pixels to the right. These two options only apply when the position units are in percent of image size. 
 
Confining a Position within the Floater Paste Area 
This option is used to overlay floating images one on top of another for layering effects, such as drop 
shadows and image compositions. When checked, any image positioning will be relative to the last 
floating image that was pasting into the main image. For example, if you paste a floating image that is 300 
x 200 pixels in an image at position (400, 150), then any selection movement will use an image location 
origin of 400, 150 with a width of 300 x 200 as the image reference. 
 
 
Top 
 
 

 
 
 

Printing Options 
 
General Options 
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Paper Size and Print Quality 
The paper size and print quality are defined using the standard Windows printer setup dialog. Click on the 
Setup Printer button for this. EzImage does not support custom paper sizes or quality levels. Printing 
characteristics are determined by the Windows printer driver installed on your system. 
 
Units 
The unit of measure applies to margins, the header and footer adjustments, and to the spacing between 
images on thumbnail print page. 
 
Orientation 
The orientation can be used to override the setting in the Windows printer driver. However, the user has 
the option to also override this setting prior to starting any print job, since the orientation setting is 
available from more than one dialog window. 
 
Print Size Scaling 
Check this option to print an image according to the resolution value within the image itself. For example, 
an image that is 600 by 400 pixels with a resolution of 72 dots per inch will be printed with a width of 8.33 
inches and a height of 5.55 inches. The image will be scaled to match this size if necessary. 
 
Fit to Page Scaling 
Check this option to fit the image exactly within the margins that you specify, while preserving the aspect 
ratio. For example, on an 8.5 by 11-inch paper size with 0.75-inch margins, the image will be scaled to fit 
within an area of 7 by 9.5 inches.  
 
Actual Pixels (No Scaling) 
Check this option to print an image with no scaling of any kind. The number of pixels in the image will 
match the number of dots on the printed page, provided that the image will fit on the page. For example, a 
1200 by 600-pixel image printed at 600 dots per inch will occupy an area of 2 by 1 inch on the page. 
 
Centering 
Use the centering options to position the image with an equal amount of border on each side in the 
horizontal or vertical directions. When centering is disabled, the image will be printed relative to the upper 
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left corner defined by the margin settings. 
 
 
Margins 
 

 
 
Top, Left, Right, and Bottom 
The margins define the borders where no image information will be printed. When using the Print Size or 
Actual Size printing methods, an image will not be allowed to print if it would extend beyond the margins. 
In this case, you can change the image printing resolution using the Image Resize operation, reduce the 
image size, or use the Fit to Page option. 
 
Header and Footer Areas 
The header and footer settings only apply if you are using header and footer text labels. The header 
extends upwards from the top margin, while the footer extends below the bottom margin. For example, a 
0.5-inch header with a 1-inch top margin will result in labels printed 0.5 inches from the top of the page. 
 
Adjusting for Allowable Printing Area 
Many printers have physical borders where no ink can be placed. Unless you are using a printer that has 
edge-to-edge printing capabilities, the actual print area when an image can appear will be smaller than 
the physical page. The page margins you define in most cases will prevent printing into the no-print area. 
Check this option to adjust image output to ensure that an image will never appear in a no-print zone. 
 
 
Headers and Footers 
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Label Positions 
There are 6 available label zones for headers and footers. As you check each of these position buttons, 
the label field will change to reflect the text for the corresponding position on the page. 
 
Text Labels 
Enter a text label for the corresponding header or footer position. Use the Font button to define the font 
name, size, and styles used for the labels. Click on the color swatch to set the text color. Left-aligned 
labels will print from the left margin of the page. Right-aligned labels will print from the right margin. 
Center-aligned labels will print centered between the left and right margins. 
 
Applying Labels for Single Images/Thumbnails 
Header and footer labels can be assigned to normal image printing, thumbnail image printing, or both. 
You can also choose to disable header and footer labels entirely. The absence of labels does not affect 
the margin settings in any way. 
 
Macro Buttons 
You can insert placeholders for macro strings in header and footer labels using these six macro buttons. 
Each one inserts a different macro word, enclosed with the tilde (~) character: 
 
~PAGE~   Current page number 

~PAGES~  Total number of pages 

~DATE~   Date 

~TIME~   Time 

~FILE~   Image file name 

~PATH~   Image file location 

 
For thumbnail printing, the image file name and location refers to the first image in the upper left corner of 
the row/column grid. 
 
 
Thumbnails 
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Columns and Rows 
A thumbnail page can contain a minimum of 2 rows and 2 columns (4 images) to a maximum of 12 rows 
and 12 columns (144 images). The thumbnail print method will not create any pages where a thumbnail 
image would be less than 0.5 by 0.5 inches. The size of each image is determined by dividing the 
available page space (less margins) by the rows and columns of thumbnails. If you add spacing, then the 
images will be adjusted downward in size to account for this. 
 
Horizontal and Vertical Spacing 
The spacing values create gaps between images to allow a small amount of border area around each 
image. If you don’t use spacing, the images may touch on their edges. If you are using thumbnail labels, 
you may wish to increase the horizontal spacing to allow for longer file names. 
 
Labels 
You can include labels beneath each image using one of the choices in the dropdown list. The date, 
name, and size information are all printed on separate lines. When using labels, the thumbnail images 
and vertical spacing will automatically adjust to include the added text beneath the image. Use the Font 
button and color swatch to define the font characteristics for the labels. 
 
Color Adjust 
This option allows you to apply color adjustments to all thumbnail images that are printed. The color 
adjustments include the same set of options as the File Conversion Tool: Levels, Hue/Saturation, Color 
Balance, Color Mix, and Channel Adjust. In addition, you can choose to create a halftone conversion of 
each thumbnail using the current setting of the Halftone method. Color adjustments remain in effect until 
you disable them in the adjustments option window. 
 
 
Color Adjustments (Thumbnails) 
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Adjustment Files 
The 5 input fields can contain links to adjustment files, which are created by the corresponding color 
adjustment method found in the Image->Adjust application menu. If a valid adjustment file is present, it 
will be applied to all thumbnail images for all pages that are printed. Use the Browse button to search for 
an adjustment file. Click on the “X” button to remove an adjustment file link. 
 
Generate Halftone Images 
Check this option to apply a halftone conversion to all thumbnail images before they are sent to the 
printer. This option uses the current settings that are applied using the general Halftone adjustment 
method found in the application menu. You may find that your printer driver will generate better quality 
images in black and white format without having to use a halftone conversion. 
 
Enable Adjustment Settings 
You must check this option to enable any of the color adjustments. Note that color adjustments can 
increase the printing time significantly, depending on the size of the source images and the number of 
thumbnails per page. 
 
Related topics: 
 
Printing Images 
Single Image Printing 
Thumbnail Printing 
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The Brushes Palette 
 
Use the View->Palettes menu option to show or hide the Brushes palette: 
 

 
 
The brushes palette is used to select the brush for one of the available painting tools in EzImage. There 
are 2 brush files for each painting tool. There is no restriction on sharing brush files, so it is possible to 
use the same brush file for every painting tool. By default, EzImage assigns a separate gray-level brush 
file for each painting tool. Gray-level brush files only apply to RGB and gray-scale images. A common 
brush file is assigned for all painting tools when working with indexed-color images. 
 
The process of switching brush files depending on the image and painting tool is automatic, and not 
something that you can control. If you switch from the Pencil tool to the Paintbrush tool, the brush file will 
change. If you have both an indexed-color and RGB image open in separate windows, switching between 
the two image windows will automatically change the brush files between monochromatic and gray level. 
You may not notice any change initially because all brush files use the same set of brush masks by 
default. If you modify the brush files, you will notice that only the file for the current painting tool will be 
affected. 
 
The Brushes palette contains the following information: 
 
Painting Tool: The title bar of the palette identifies the painting tool that the brush file is assigned to. 
 
Category: This is a popup menu that can be activated by clicking on the arrow button. You can select 
brushes from one category by choosing from this list, then selecting the brush type by clicking on the 
Name option. 
 
Spacing: Spacing determines the retouch distance when you apply color with a painting tool. It is a 
percentage of the core width and height, not the actual width and height. For example, a spacing of  
500% applied to a brush with a core size of 80 x 80 pixels will result in the brush mask being applied 
every 400 pixels of travel distance on the image. For soft brushes, a spacing of 25% is usually a good 
value. For hard brushes, a value of 10% is a good choice. As you decrease the spacing on large brushes, 
the overall paint speed can decrease. For more about core width and height, see the help topic under 
Brush Editing. 
 
Name: This is a description of each brush assigned within the current brush category. A brush file is 
arranged in a row (category) and column (name) format. A brush file can contain a maximum of 9 rows 
and 11 brushes per row. The name of the current brush will appear above the mask image preview. 
 
Brushes: Click on this button to access the Brush List Editor. You can also access the editor by left 
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clicking on the brush mask preview area. 
 
Size, Magnification, and Category 
Below the image preview area is a label that has 3 parts to it. The first part is the single character 
category ID code, which is defined using the Brush File Properties editor. The second part is the core 
brush size, as defined using the Brush Editor. The final part is the magnification level of the preview area, 
which is 1:1 for actual pixels, 1:2, or 1:4 for brushes that are at 25% magnification. 
 
Inverting the Mask Preview 
Hold down SHIFT while left clicking on the mask preview area to display the pixels in inverted format 
(black becomes white, white becomes black). This does not affect the brush in any way. The option is for 
those who wish to see the brush pixel mask in an alternate format. 
 
Related Topics: 
 
Brush List Editor 
Brush Shape Editor 
Brush File Properies 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Information Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
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Color Swatch Palette 
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This palette window is used for working with indexed color images. It can also be used as a scratch pad 
for storing up to 256 custom colors in a special palette called a User Palette. You can view the color 
palette window by choosing the View->Palettes->Show Color menu option. 
 
The palette window has a basic format with only 3 components: 
 

The swatch area is divided into a grid of 16 rows by 16 columns, 2 rows by 8 columns, or 1 row by 2 
columns, depending on the type of palette chosen from the dropdown list. 

 
The dropdown list contains the palette type that is displayed. 

 
The right arrow button will show a popup menu of options related to managing the color palette 
window. 

 
Palette Types 
 

Image Palette: For indexed color images, this is the active color palette contained within the image. 
User Palette: This is a custom palette that you can edit, save to file or load from file. 
VGA 16: The standard 16 color VGA palette, useful for creating icons and cursors. 
Gray 16: A basic 16 level gray scale palette. 
Gray 256: 256 level grayscale palette. 
Gray 256 Reversed: A 256 level grayscale palette that has the levels inverted. 
Black and White: 2-color bitmap palette. 
White and Black: 2-color bitmap palette, black and white inverted. 
System Palette: The Windows default system color palette. 
ICO/CUR Palette: When editing icons and cursors, this is the export/import palette. 

 
With the exception of the Image, ICO/CUR, and User palettes, the remaining ones are fixed palettes that 
can be used to access specific reference colors. 
 
Setting Foreground and Background Colors 
You can left click on any color in the swatch to set the foreground color in the Tools palette. Right click to 
set the background color. By moving the mouse cursor over the swatch grid, you will see the color values 
appear in the Information palette. 
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Image Palettes 
The image palette is only valid when the active image is indexed color. If the image contains less than the 
maximum of 256 colors, the remaining palette entries are undefined and can’t be used to edit an image. 
The palette represents the only colors that can be used for color fills and painting tools. If you attempt to 
use any color other than the ones in the image palette, the closest approximation from the palette will be 
selected. In many cases, this will not be what you expected. For example, if the palette contains no white 
colors, and you fill part of an image with pure white, the color chosen will not be pure white, and will likely 
be something less than acceptable. Always check the image palette for color availability when working 
with indexed color images. 
 
User Palettes 
A user palette is an arbitrary set of 256 colors. The convenience of this palette type is that you can edit it, 
using options available within the color palette window. The user palette is always saved when you close 
the application, so that you can make custom color sets and keep them handy in this palette. A user 
palette is also used for the indexed color conversion method, which allows you to map a specific set of 
colors to an image. 
 
ICO/CUR Palettes 
When importing and exporting Windows cursor and icon format files, you will work with RGBA 32-bit 
images that contain a transparency mask in the alpha channel. However, a method is needed to preserve 
a palette for icons and cursor that are less than 24 bits in depth. The ICO/CUR palette is designed for this 
purpose. Each image window that is tagged for icon or cursor export has an internal color palette used for 
painting the image pixels. You edit an image the same way you would use an image palette. Since the 
RGBA format does not have an image palette, you will use the ICO/CUR palette instead. 
 
Saving a Palette to File 
Any of the palettes available in the dropdown list can be saved to a palette file. This file has an extension 
of .PAL and is generally stored in the User folder of the application path. A set of predefined .PAL files 
that correspond to some of these palette types were placed in that folder when you installed the 
application. 
 
Replacing the Image Palette 
You can replace all of the colors in an indexed color image by replacing it with a palette file. Choose the 
Load option from the popup menu while the Image Palette is selected from the drop down list. What 
happens after the load is fairly simple: The image pixels will be remapped to adapt to the new color 
palette without using any form of dithering. In most cases this will probably not give acceptable results. If 
you want to use dithering methods to remap an image to a new color palette, load it into the User Palette, 
then use the indexed color conversion method. 
 
Replacing Other Palettes 
You can replace the User Palette and the ICO/CUR Palette using the Load option as well. When 
exporting an image to an icon or cursor file, make sure you don’t use any colors that are not present in 
the ICO/CUR palette, since the image will be remapped and converted to indexed mode using that 
palette. 
 
Resizing the Palette 
You can change the size of the grid squares in the color swatch to one of 4 levels: Small, Medium, Large 
or Extra Large using the Resize option from the popup menu. 
 
Grid Line Color 
The color of the lines that separate each square of color can be given one of the following colors: White, 
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Black, or Window. The Window color is the same as the background of the palette window itself. Use the 
Grid Color option from the popup menu. 
 
Editing Colors 
Only the User Palette can be edited directly. Choose the Edit option from the popup menu. Once in edit 
mode, there are several editing options available. These are available from a second popup menu. 
 
To edit any one color, simply click on a color square in the grid. This will bring up the color picker and 
allow you to choose a new color. When you click on OK, the color picker will assign the new color to the 
position in the grid. 
 
Copy and Paste 
You can copy a range of colors from one location in the palette to another. To do this you hold down the 
CTRL key and use the mouse to set the range: 
 

Hold down CTRL and left click to set the starting color. 
Hold down CTRL and right click to set the ending color. 
Choose Copy from the popup menu. 
Hold down CTRL and left click to set the starting point for the paste. 
Choose Paste from the popup menu. 

 
Setting a Gradient Spread 
You can define a gradient for a range of colors in the palette. You must choose at least 3 colors for a 
range. The method to set a gradient is similar to the copy and paste process: 
 

Determine the starting position in the grid for the gradient and use the color picker to set the value. 
Repeat this for the ending position. 
Hold down CTRL and left click to set the starting color. 
Hold down CTRL and right click to set the ending color. 
Choose RGB Gradient or HSV Gradient from the popup menu and select one of the available types. 

 
The HSV gradient will perform a transition based on hue, saturation and value. The RGB gradient will use 
the Red, Green, and Blue intensities of the starting and ending colors to create the intermediate colors in 
the range. The resulting gradients will be very different. The All types for RGB and HSV gradients are 
generally the ones you will use most often. The other ones will lock one or more components of the 
gradient in place while applying the gradient transition on the remainder. For example, a Green RGB 
gradient will lock blue and red color intensities and simply create a transition of green levels. 
 
Save, Cancel, Reset 
These options are available from the popup menu. Cancel will undo all edit changes and restore the 
original User Palette before you entered edit mode. Reset will leave you in edit mode but restore the 
original user palette colors. Save will apply all color changes to the User Palette. If you wish to make a 
permanent copy of the new palette, use the Save option and save it to a palette file. 
 
Related topics: 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Brush Palette 
Information Palette 
Scripts Palette 
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Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
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Information Palette 
 

 
 
The information palette shows basic coordinate, distance, and color information for the active image 
window. 
 

X,Y: This is the current mouse cursor position in the window. 
 

R,G,B: This represents the Red, Green, and Blue values of the pixel of the image under the mouse 
cursor.  If you move the mouse over any of the color swatches, the foreground or background color 
picker, or the sample swatch in the sample tool options panel, the color values will change 
accordingly. If you are viewing an indexed color image, the value represents the color of the palette 
entry assigned for the pixel under the mouse cursor. If you move the mouse cursor over any swatch 
in the color palette window, the values will also be shown here. 

 
H,S,V: These values are the Hue, Saturation, and Value for the same color information as the Red, 
Green, and Blue component. Hue values range from 0 to 360°, saturation from 0 (no color) to 100% 
(full color), and value from 0 (black) to 100% (white). Although EzImage supports the HLS (Hue 
Luminosity, Saturation) color space internally, the information palette does not provide a value 
readout for the latter type. 

 
Sx,Sy,Sw,Sh: The selection width, height and position will change depending on whether you have 
an active region selection or an active floating image. For active floating images, the label names will 
begin with the letter “F”. For region selections, the labels will begin with the letter “S”. You can not 
manipulate both a region selection and floating image at the same time, therefore the information in 
this palette is shared between the two. 

 
Changing the Unit of Measure 
Click on the directional arrow button to see a popup menu that allows you to change the display units for 
both the information palette and the rulers if they are currently visible. The allowable unit values are 
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pixels, inches, centimeters, and millimeters. 
 
The current dimensions of the active image are shown in the title bar of the information palette. 
 
Related topics: 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Brush Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
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Printing Images 
 
EzImage provides methods to print single images and multiple images per page, the latter method using 
the thumbnail database to output several images in a row and column grid arrangement. 
 
EzImage does not offer the features that create color separations and output formats/attributes designed 
for commercial printing shops (images can be stored in CMYK TIFF format, but there is no facility in the 
application to directly work with images in CMYK format or print images in CMYK format). 
 
The application works with images in RGB format, and will print images in RGB format and rely on the 
capabilities of the Windows printer driver to perform the necessary color conversions to generate output 
to the printer in CMYK format. 
 
Both single image printing and thumbnail printing share a common set of options for defining the print 
page, including margins, header, footer, and scaling information. The thumbnail option includes some 
extra options for configuring the row/column page format and some global color adjustment options that 
can be applied to all images in one step. 
 
The main application menu provides access to the single image printing method only. To print thumbnail 
image sheets, you must be in the thumbnail browser and choose the print option from its menu. 
 
Related topics: 
 
Printing Options 
Single Image Printing 
Thumbnail Printing 
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Image Nudge Palette 
 

 
 
The nudge palette is used for moving floating images and regions, and for resizing region areas. Since 
you can drag regions and floaters around with a mouse, and resize regions using keyboard shortcuts, the 
nudge palette exists as an alternate method for doing these same operations. 
 
Moving a Floater or Region Selection 
Choose the Move option for moving selections. The directional button pad is used to move the region or 
floater by the number of pixels shown in the white square. You can change the movement amount by 
clicking in the white square and choosing from one of the values listed in the popup menu. You can not 
move a region selection outside the boundaries of the image area. Floaters can be moved off the visible 
image area to the extent that one row or column of pixels in the floater must remain visible. 
 
Expanding a Region 
Choose the Expand option to expand the region selection by the number of pixels indicated in the white 
square. If the region is rectangular, the expansion will be applied to one edge only (the corner directional 
buttons only expand horizontally, not vertically). For non-rectangular regions, the expansion is applied 
uniformly to the entire outline of the region. You may not expand a region that would result in any part of 
the outline extending past one of the edges of the image. 
 
Contracting a Region 
Choose the Contract option to contract the region selection by the number of pixels indicated in the white 
square. The process of contraction is the same as expansion with regard to edge vs. uniform application. 
If you contract a region too much, it will eventually disappear from the image. 
  
Related topics: 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Brush Palette 
Information Palette 
Scripts Palette 
Color Swatch Palette 
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Image Windows 
Status Bar Information 
Image Information Help 
 
 
Top 
 
 

 
 
 

The Options Panel 
 
The options panel appears across the top of the main view, just beneath the menu bar. If it is not visible, 
use the View->Palettes->Show Options menu option. This topic summarizes each option for each 
image tool that appears in the Tools palette window. For a more detailed description of the options and 
tools available with that palette, click on the appropriate topic link. 
 
Create Rectangular/Elliptical Selection 
 

 
 

Create Rectangular Selection 
Create Elliptical Selection 
Normal Selection Mode 
Addition Mode 
Subtraction Mode 
Intersection Mode 
Show/Hide Nudge Palette 
Crop Image/Crop to New Image 
Selection Type 
Fixed Width/Height or Aspect Width/Height 
Fixed Width Mode Anchor Point 

 
Create Freehand/Polygon Selection 
 

 
 

Create Freehand Selection 
Create Polygon Selection 
Normal Selection Mode 
Addition Mode 
Subtraction Mode 
Intersection Mode 
Show/Hide Nudge Palette 

 
0 Magic Wand Selection Tool 
 

1  
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Normal Selection Mode 
Addition Mode 
Subtraction Mode 
Show/Hide Nudge Palette 
Wand Tolerance Level 

 
Move/Create Floating Image 
 

 
 

Blend Mode 
Show/Hide Nudge Palette 
Paste Floater 
Cancel Floater 
Move/Copy Mode 
Opacity Level 
Inversion 
Edge Feather 

 
Image Grabber 
 
This tool has no options. 
 
Magnify Tool 
 

 
 

Zoom In Mode 
Zoom Out Mode 
Set Zoom Level 
Fit Window to Image 
Fit Image to Window 
Show Image at 100% 

 
Text Tool 
 
This tool has no options. 
 
Shape Tool 
 

 
 

Shape Type 
Shape Options 
Anti-alias Mode 
Border Width 
Selection Type 
Fixed Width/Height or Aspect Width/Height 
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Fixed Width Mode Anchor Point 
 
Pencil/Brush/Eraser Tool 
 

 
 

Pencil Tool 
Paintbrush Tool 
Erase Tool 
Blend Mode 
Brush Gradient Options 
Opacity Level 
Block Mode 

 
Line/Polyline Tool 
 

 
 

Blend Mode 
Brush Gradient Options 
Opacity Level 
Block Mode 
Line/Polyline Mode 

 
Blur/Sharpen Tool 
 

 
 
Dodge/Burn/Sponge Tool 
 

 
 

Dodge Tool 
Burn Tool 
Sponge Tool 
Range Type 
Exposure Level 
Block Mode 

 
Paint Bucket Tool 
 

 
 

Blend Mode 
Opacity Level 
Fill Tolerance 
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Clone Tool 
 

 
 

Blend Mode 
Opacity Level 
Block Mode 
Aligned Mode 

 
Measure Tool 
 

 
 

Coordinate of Line Start Point 
Width and Height of Line Bounds 
Angle of Line/Lines 
Distance of Line One 
Distance of Line Two 
Show Measure Lines 
Hide Measure Lines 
Units of Measure 
Line Color 

 
Cross Hair Tool 
 
0
 

 
 

Coordinate of First Cross Hair Intersection 
Coordinate of Second Cross Hair Intersection 
Width and Height of Bounding Box for 2 Lines 
Show Cross Hair Lines/Rulers 
Hide Cross Hair Lines 
Units of Measure 
Line Color 

 
Eyedropper Tool 
 

 
 

Sample Color Tool 
Hotspot Tool 
GIF Transparency Tool 
Clear Transparency 
Point Sample Mode 
3 x 3 Pixel Area Sample Mode 
5 x 5 Pixel Area Sample Mode 
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Region Selection Sample Mode 
Sample Average Color/Transparency Swatch 

 
Color Wand Tool 
 

 
 

Normal Selection Mode 
Addition Mode 
Subtraction Mode 
Show/Hide Nudge Palette 
Wand Mode 
Color Tolerance Level 

 
Related topics: 
 
Menus and Shortcuts 
Tool Palette 
Brush Palette 
Information Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
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The Tool Palette 
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This palette window contains the basic set of image editing tools that fall under one of the following 
categories: 
 

Brush Painting 
Region Selections 
Image Window Manipulation 
Color and Distance Measure 

 
Only one tool can be active at a time, as indicated by the one that is depressed. To activate a tool in the 
palette, simply left click on it. Right click on the tool icon to view a popup help window with a description of 
what it does. The Magnify tool is the only one that has an assigned double click method, which is to view 
an image at 100% actual size. 
 
Options Panel 
For any tool you select, there may be a set of options that alter the way in which it works. If a tool has at 
least one option, it will appear in the options panel that appears across the top of the window, beneath the 
menu bar. 
 
If this palette is not visible, use the View->Palettes->Show Tools menu option. 
 
For help on each imaging tool, click on the associated link below. 
 

  Create Rectangular/Elliptical Selection 

  Create Freehand/Polygon Selection 

  Magic Wand Selection Tool 

  Move/Create Floating Image 

  Image Grabber 

  Magnify Tool 
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  Text Tool 

  Shape Tool 

  Pencil/Brush/Eraser Tool 

  Line/Polyline Tool 

  Blur/Sharpen Tool 

  Dodge/Burn/Sponge Tool 

  Paint Bucket Tool 

  Clone Tool 

  Measure Tool 

  Cross Hair Tool 

  Eyedropper Tool 

  Color Wand Tool 
 
 
Related topics: 
 
Menus and Shortcuts 
Tool Options Panel 
Brush Palette 
Information Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
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Recording a Menu Shortcut 
 
This option is available by clicking on the Menu Record button when recording a normal EzImage script. 
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The menu for this window is a duplicate copy of the EzImage main menu. Some items are grayed out in 
this menu. These are options that can not be added a menu shortcut to the scripts palette. 
 
You can add as many shortcut entries to the list at one time as you wish. Choose any item from the menu 
that is not disabled, and a shortcut will be added to the list. Use the Clear and Delete buttons to remove 
entries. 
 
Once you click on OK shortcut script files for all of the entries in the list will be added to the current Set 
group. 
 
A menu shortcut script in the palette has the following characteristics: 
 

The icon for the entry in the palette is a unique graphic that helps to identify what action the script 
performs. 

 
Popup help is available for this type of script by simply clicking on the icon button. 

 
When you click on the labeled button, the equivalent menu action will be executed, as opposed to 
standard script play mode. 

 
Shortcut script files will automatically be assigned a unique file name that you should not change. The 
contents of this type of script file can not be altered in any way, or the script may fail to run. The palette 



EzImage Reference – Version 1.05 

 

 Page 249 

 

name and description are also automatically defined for you, although you are free to change them using 
the palette editor. 
 
Related topics: 
 
EzImage Script Files 
Recording a Script File 
Playing a Script File 
File Conversions 
Scripts Palette 
Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
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Product Registration 
 
EzImage can be purchased directly from SoftPro 2010 in CD-ROM format or downloaded as a 30-day 
limited trial version from our web site. If you have already purchased the product with an activation code, 
then you may enter it directly into the product registration form by choosing Product Registration from 
the application Help menu. If you wish to purchase a product code to activate your copy of the software, 
please refer to this link for contact information. 
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The registration dialog contains a reference to two activation codes. 
 
Standard Features 
This code enables all features of EzImage with the exception of the following: 
 

Image Comparison Tool 
 

Selection Separation Tool 
 

Edge Deskew Tool 
 
These 3 tools require you to purchase an Extended Features activation code. 
 
To enable the standard features in EzImage, simply enter the 16-character code that was provided to 
you, 4 characters per input field. Then click on the Register button. 
 
Extended Features 
This code will enable the image comparison, selection separation, and edge deskew tools. The activation 
code is machine-specific, meaning that you may not transfer the code to any other PC. If you have 
purchased a multi-user site license for EzImage, you must register one extended features code for each 
site-licensed copy. If you reinstall your operating system, you may request a new extended features code 
free of charge by simply contacting us with the new product ID. 
 
Click on the Request button to obtain a product ID code from your system. This ID code identifies one 
computer system only, and is used to generate the extended features activation code. 
 

 
 
You must contact SoftPro 2010 either by phone or email and provide us with the product ID code. Once 
we have obtained this ID code, we will send you the extended features code, provided that you: 
 

Are a registered user of EzImage with a proper standard features activation code. 
 

Have purchased the extended features code. You may purchase the extended features code at the 
same time as the standard features code, or upgrade at any time. In either case, we will only provide 
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the extended features code when we have verified that you have made the necessary payment to use 
this code. 

 
You can click on the E-Mail button to submit the product ID code using your email messaging software, or 
use the phone number shown in the request window. 
 
When you have the received the extended features code, enter it in the input fields in the product 
registration dialog, and click on the Register button. 
 
Upgrading from Standard to Site License 
If you are currently using the standard single user edition of EzImage, you may upgrade to a multi-user 
site license version at any time. This will require you to remove the standard version of the application 
from your system and install the site license version in the same path. When you remove the standard 
version, all of your settings and work files within the application folder are left intact. You should install the 
site license version in the same location, so that when you run the software, all settings will be retained. 
 
You must enter the site license activation code provided. The site license and single user versions both 
use the same type of standard features activation code. The extended features code is unique to each 
machine, therefore it does NOT need to be reissued or re-entered. The following steps summarize what 
you need to do: 
 

Use the Change/Remove Programs option from the Control Panel to remove the standard version of 
EzImage. 

 
Install the site license version into the same location. 

 
Run EzImage and enter the site license code into the Standard Features Code input fields. 

 
Click on the Register button. 

 
Close the registration window and exit EzImage. 

 
Run the application again, and your extended features code should be activated if it was previously 
registered. 
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Rendering a Floating Image 
 
The render option it used to convert floating text and shapes into floating images. Text and shapes are 
created as a 256-level gray scale mask, which can have any color. For any mask areas that are not pure 
white, the base color will become less opaque, allowing more of the background image to appear. Many 
operations that apply to floaters, such as filling and image color adjustments, can’t be applied to text or 
shape floaters, since the mask itself has no color component that can be modified. Shapes created with 
the shape tool and floaters created from the alpha channel in an RGBA format image also have no color 
layer component. 
 
The render option will create a floating image from the current shape or text floater by adding a color layer 
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to the floater in addition to the existing mask layer. The color layer can be rendered using the current 
foreground color or the image that the floater is positioned over. 
 
The render option is available from the application menu as Floater->Render Floater. 
 
Original Image with Floater: 
 

 
 
Floater Rendered Using the Image: 
 

 
 
Note that the background was cleared with black pixels to highlight the effect of the floater using image 
pixels. 
 
You can render a floating image with a color or image data even if the floater already contains an image 
layer. For example, you can drag the floater from the example above into a new image and render it with 
the pixels from the second image. The existing image layer in the floater will be replaced with the pixels 
from the new image. 
 
Related topics: 
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Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
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Resizing Images 
 
Resizing an image can be applied in one of two ways: 
 
Resizing by Resampling 
 

 
 

Resampling involves adding or removing pixel content from an image in order to increase or decrease 
the pixel dimensions of the image. 
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Resizing by Print Output Resolution 
 

0  
 

Print resolution resizing involves adjustment of the dots per inch (DPI) value of an image, which in 
turn affects the width and height of the image as applied to output on a printer. The image pixel data 
itself is not affected by this method. 

 
For floating images, the print resolution option is not allowed, since the floater and underlying image must 
share the same DPI values. When a floater is active, the resize method applies to it, not the image. 
 
Width and Height (Image Size) 
The width and height values in the Image Size box apply to resizing an image using resampling. You can 
enter image sizes in pixels or percentage of the current image dimensions. When using non-resampled 
(print output DPI) mode, you will only be able to adjust the image in terms of its printing resolution. Image 
data is not affected in any way using the latter method. 
 
Keep Aspect 
Check this option to maintain the original width/height aspect ratio of the image. When you enter a value 
in the Width field, the Height value will adjust accordingly, and vice-versa. 
 
Constrained Limits 
Check this option to limit the maximum width and height of an image. The image will maintain its existing 
aspect ratio, but the width and height values will never exceed the constraint limits. If the image is already 
smaller than the constraint limits, no resize will be applied. 
 
Separate Width/Height 
Since the aspect ratio is not preserved, this option can result in an image distortion, since you are 
specifying separate width and height values. 
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Reshow 100% 
Check this option to auto-zoom the resized image to 100% after the operation has completed. If possible, 
the window will adjust to fit the new level of magnification. 
 
Resample Mode 
With resample mode, you are adding or removing pixel content by altering the dimensions of the image. 
There are 3 methods of resampling that provide different levels of image quality, as selected from the 
dropdown list: 
 

Normal sampling is the fastest but has the poorest quality. 
Bicubic offers the best quality at a cost of increased resizing time. 
Linear offers a compromise between speed and quality. 

 
Linear and Bicubic methods don’t work on indexed-color images. Uncheck resample mode to alter the 
print dimensions without changing the image pixel content. This will place the resize dialog window into 
DPI adjustment mode. 
 
Width and Height (Printing Size) 
The second set of Width and Height values allow you to set dimensions in inches, centimeters, 
millimeters, or a percentage of the current image size. Choose a dimension unit of measure from the 
dropdown list, then enter the size value. If you are not using resample mode (i.e. printer DPI mode), then 
the width, height, and resolution values will become linked. A change in one value will automatically 
adjust the other two in order to preserve the image pixel information. 
 
Resolution 
The resolution value is used to define the print size of the image. It can be expressed in dots per inch or 
dots per centimeter. When using resample mode, a change in resolution will increase or decrease the 
number of total pixels. When resample mode is disabled, a change in resolution will automatically change 
the width and height for the image print size, without changing the total number of image pixels. 
 
Click Reset to restore the image resize settings to neutral values. 
 
Before and After 
These two values indicate the image memory footprint, before and after the resize operation is applied. 
When not in resample mode, the After size will always be the same as the Before size. The title bar of the 
resize window indicates the before and after pixel dimensions of the image. 
 
Related topics: 
 
Rotating Images 
Shearing Images 
Flipping Images 
Cropping Images 
Adding a Border 
Auto Trim Tool 
Edge Deskew Tool 
 

 
Top 
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Reverting to Last Saved Image 
 
The File->Revert menu option will replace the current image in the active window with the last version 
that was saved to file. All changes you may have made to the image between the time of the last save 
and the time you choose to revert to that version will be lost. 
 
The Revert option does not apply to images that were created outside of the standard file open method. 
This includes images created with the following methods: 
 

Scanned images (excluding batch file scan) 
Images create with the File->New command 
Duplicated images or selections saved to new windows 
Images created with the Selection Separation tool 

 
If the original source image file was deleted, moved, renamed, or had the file format changed outside of 
the EzImage application, you will not be able to use the Revert method. 
 
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 
Filling and Images 
Clearing Images 
Thumbnail Preview Windows 
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RGB Color Mode 
 
Choose the Image->Color Mode->RGB or Image->Color Mode->RGB with Alpha menu options to 
convert an image to 24 or 32 bits per pixel respectively. 
 
The 32-bit RGB mode will include an 8-bit alpha channel, which you can view and manipulate just like any 
other image, in this case as a 256-level gray scale format. 
 
When converting an image from 32 bits to 24 bits (RGBA to RGB), you will lose the alpha channel 
contents. 
 
When converting from 24 to 32 bits, the alpha channel will initially be blank (all pixel values will be black). 
 
RGB images have 3 channels, which are comprised of 256 intensity levels of red, green, and blue, for 
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16,777,215 possible colors. You can separate these channels into gray scale images and perform image 
adjustments individually. 
 
Note that EzImage assumes that all RGB format images are stored with pixel color values in blue-green-
red order, as opposed to red-green-blue order. When converting images to RGB format, the pixel storage 
format will always be blue-green-red. 
 
Related topics: 
 
Indexed Color Mode 
Gray Scale Mode 
Halftone Conversion 
Threshold Conversion 
Channel Separations 
Alpha Channels 
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Rotating Images 
 

 
 
EzImage provides both fast 90° rotation options and a slower method in which you can specify any angle 
in 1/100-degree increments. 
 
The 90° clockwise/counterclockwise and 180° rotation options are available directly from the Image-
>Rotate menu – no dialog window is involved, and no pixel information is altered. 
 
If a floating image selection is active, then the floater will be affected by the rotation, not the image itself. 
 
Angle and Direction 
An image rotation angle can be between 0 and 360 degrees in 1/100-degree increments. Use the 
counter-clockwise and clockwise options to set the direction of the rotation. 
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Fill Color 
When rotating an image by an arbitrary number of degrees that are not in whole 90° increments, with 
resizing enabled, the image size will increase and introduce blank areas. Choose a fill color to use for the 
blank areas. By default, the current background color will be assigned. Fill colors do not apply to floater 
rotations. 
 
Resize Image 
Check this option to ensure that images not rotated in 90° increments will be enlarged to avoid clipping. 
Uncheck this option and the image may be clipped in order to preserve the current image size. If you 
rotate an image by 90°, 180°, or 270°, then this option is ignored. The resizing option does not apply to 
floaters (they are always resized). 
 
Using a Measure Tool Angle 
If you have defined one or two measure lines for the current image using the Measure tool, then you can 
click on this button to rotate the image by the measure tool angle. The direction will also be set in a 
manner that will minimize the rotation amount. 
 
Gray Scale Masks and Floating Images 
Arbitrary rotations that are not in 90° increments will have the pixel information sampled to create a 
smooth antialiased appearance. For floating images, this requires the mask that defines an irregular 
shape to have 256 levels of gray, needed for antialiasing the edges of the floater pixels. If you don’t have 

gray level masks enabled in the general preferences, then you will not be able to perform an arbitrary 
image rotation on floaters. 
 
Related topics: 
 
Shearing Images 
Flipping Images 
Resizing Images 
Cropping Images 
Adding a Border 
Auto Trim Tool 
Edge Deskew Tool 
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Recording a Script 
 
You can begin recording a new script file by choosing the Tools->Scripts->Record menu option or by 
right clicking on the scripts palette and choosing the Record option from the popup menu. In either case, 
the properties dialog window for a new script file will appear: 
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File Name 
Script files have an extension of .SCR and appear in subfolders of the Scripts folder, which is a folder 
located in the EzImage installation path. You may search for an existing script file using the Browse 
button, which will populate the other fields in this dialog window. For a new script file, simply enter a new 
file name. 
 
Description 
The description is a short message that identifies what action or actions the script will perform. It will 
appear as a help message on the status bar of the EzImage main window when you move the mouse 
cursor over the script palette entry, or when you select the script as a menu shortcut. 
 
Palette Name 
The palette name is what appears in the scripts palette as the label on each button. Scripts are sorted 
alphabetically on the palette according to this name. This name will also appear as the menu label if you 
have assigned it to a shortcut position in the main menu. 
 
Set Name 
The set is the folder name that the script belongs to. All script files must be organized so that they are 
located within subfolders of the Scripts folder. When creating scripts, you can place them into an existing 
set (folder) or create a new one. New sets will of course be created as a folder in the Scripts directory. 
Click on New Set to make a new folder for this script file. When the script recording session completes, 
the scripts palette with automatically switch to this new set. 
 
Menu Position 
You can record a script so that it will automatically be placed as a shortcut in the EzImage main menu 
under Tools->Scripts. Choose a menu position from this dropdown list. If a script already exists in a 
menu position, it will be replaced with the new one. 
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Create or Append Mode 
You can choose to create a new script file or append to an existing one. Since there is no structure to a 
script file other than a sequence of commands, you are free to add new ones to an existing file at any 
time. 
 
Record File Open, Save, and Close Commands 
If this option is checked, then the script recording session will exclude any commands that involve image 
files that are opened, saved, or closed. Since scripts can perform almost any action available in EzImage, 
you may wish to separate scripts into two distinct types: those that operate on the active image, and 
those that basically can operate on multiple images at one time. This option ensures that if you use the 
former type, no commands will be recorded that refer to another image, or will result in the current image 
window being closed. 
 
Show Dialogs on Playback 
This option controls how a script can be played back. If you enable dialogs, then all script commands that 
would normally involve some type of operation dialog window will have such a window displayed at all 
times. The properties for the operation will automatically be filled in for you, so all you need do is click on 
the OK button to commit the action. Note that when you cancel a dialog-enabled script action, the script 
will stop play back immediately. 
 
Author 
This optional field can contain any text you wish. It was put in place primarily to identify the source or 
creator of a script file. 
 
Menu Record Feature 
The Menu Record feature allows you to create simple script files that are duplicate actions of those found 
in the main menu. You will be given a dialog window with a menu that is a copy of the EzImage main 
menu. Some items will be grayed out – those are actions that can’t be placed on the scripts palette. The 
remaining menu items can be added one at a time or several at once. The description, palette name, file 
name, and other details are filled in for you. Scripts that are created as menu shortcuts have their own 
unique icon on the scripts palette. 
 
Starting a Recording Session 

Click on Record to begin adding actions to the script file. While in record mode, the Information icon  in 

the status bar of the main view will change to  to indicate that a script recording session is in progress. 
You can click on this icon for a popup menu with various options, including the ability to pause/resume, 
rewind, cancel, or stop recording. When you are done recording, choose the Stop option from the Tools 
menu or from the popup menu. You can also control script recording using the Tools->Scripts->Actions 
menu options. 
 
Related topics: 
 
EzImage Script Files 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Scripts Palette 
Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
 



EzImage Reference – Version 1.05 

 

 Page 261 

 

 
Top 
 
 

 
 
 

Window and Cross Hair Rulers 
 
Use the View->Show Rulers menu option to display rulers across the top and left edge of all open image 
windows. You can choose from the following units of measure: 
 

Pixels 
Inches 
Centimeters 
Millimeters 

 
The unit of measure is defined using the popup menu in the information palette window: 
 

 
 
Rulers and the information palette labels will always use the same unit of measure. 
 
The cross hair tool has the option of displayed the same type of rulers that are docked to the first cross 
hair line. This allows the cross hair tool to be used for measuring distances using a ruler that can have 
any point of origin. The Ruler option for the cross hair tool can be enabled using the leftmost button in the 
tool’s option panel area: 
 

 
 
The cross hair ruler has its own units of measure that are associated with the values in the tool options 
panel. Click on the button with the ruler icon to set the unit of measure for the cross hair tool. Note that 
the percentage option only applies to the coordinate values in the tool options panel. If you select the 
percentage unit of measure, the ruler itself will default to pixel coordinates. 
 
Related topics: 
 
Image Windows 
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Setting Magnification Levels 
Window Arrangements 
Fitting a Window to an Image 
Fitting an Image to a Window 
Image Information Overlays 
Close vs. Close All 
Display and Dithering Quality 
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Regions and Alpha Channels 
 
The Select->To Alpha option only applies to 32-bit RGBA images with an alpha channel. A mask 
representing the current region selection will be placed into the image alpha channel. The current alpha 
channel contents are erased. The pixels that make up the region will be replaced with white in the alpha 
channel. The non-region areas will contain black pixels. 
 
The Select->From Alpha option also applies only to 32-bit RGBA images with an alpha channel. Any 
valid pixel data in the alpha channel (any color other than pure black) will be used to create a selection 
region. Any current region selection will be replaced with the region defined by the alpha channel. This 
option is useful to verify the alpha channel mask prior to exporting icon and cursor files. 
  
The Region to Alpha and Alpha to Region options are primarily used to define a transparency mask for 
the icon and cursor editing facility provided within EzImage. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Region Placement Anchors 
 
When recalling a region outline from clipboard or file, they can be placed onto any image at any position 
using a placement anchor. You can set an anchor point while using any of the following tools: 
 

Rectangular Selection 
Elliptical Selection 
Free Hand Selection 
Polygon Selection 
Color Wand 
Magic Wand 

 
The anchor point defines the upper left corner of the region outline. If the region outline is non-
rectangular, then the anchor point is the upper left corner of the bounding rectangle that completely 
encloses the region. 
 
To set the anchor point, use any of the above region creation tools and right-click in the image while 
holding down the SHIFT key. The status bar message area will indicate the pixel coordinate of the 
placement anchor. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Creating Region Selections 
 
You can create a region selection using any of the following methods: 
 

The Rectangle/Ellipse Selection tool allows you to create rectangular or elliptical region selections in 
an image. 
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The Freehand/Polygon Selection tool allows you to create regions using either freehand drawing or 
by connecting of several points that form the vertices of a polygon. Freehand mode is a click-and-
drag style of region creation, whereas polygon mode uses multiple point-and-click sequences. 

 
The Magic Wand tool creates a selection based on the difference in color intensity between a point 
you click on in the image and its neighboring pixels. 

 
The Color Wand tool is similar to the magic wand except that it is based on color ranges, using either 
the HSV or RGB color models. At its simplest level, the color wand will format a region selection from 
a single color. 

 
Regions can be created using 32-bit RGB images with an alpha channel. Any valid pixel data in the 
alpha channel (any gray level other than pure black) will be used to create a selection region. Any 
current region selection will be replaced with the region defined by the alpha channel. This option is 
useful to verify the alpha channel mask prior to exporting icon and cursor files. Icon and cursor 
exporting uses both transparent colors and alpha channel masks to generate the transparent area of 
their respective images. 

 
You can create a region outline of the shape that makes up the current floating image. The floater 
itself will be deleted once the region has been created. You can combine the floater region with an 
existing region. 

 
 
Related topics: 
 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to Another Image 
Saving to a File 
Creating Fill Patterns 
Creating Brushes 
Saving and Loading Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Making a Rectangular Region 
 
Choose Select->Make Rectangular from the menu to convert a non-rectangular region into a rectangular 
one. This option is useful when creating brushes, which require rectangular selections. 
 
Original Selection: 
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After Rectangular Make: 
 

 
 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
 
 
Top 
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Expanding and Contracting Regions 
 
Region selections can be expanded or contracted by an arbitrary number of pixels. Use the Select-
>Expand menu option to increase the region size and Select->Contract to decrease it. 
 
A region can’t be expanded beyond the limits of the image area. 
 
If you shrink a region to smaller than 1 by 1 pixel, it will automatically be removed from the image.  
 
Complex regions (non-rectangular) can take a significant amount of time to adjust using either of these 
options. 
 
Using the Nudge Palette 
 

 
 
You can enable this palette using the nudge button available in the options panel for the region selection 
tools, or choose View->Palettes->Show Nudge from the application menu. The nudge palette provides a 
directional button pad and 3 modes of operations: movement, expansion, and contraction. The numeric 
value in the middle is the number of pixels to move, expand, or contract by. Click on this value to change 
the amount. 
 
When expanding or contracting non-rectangular regions, the pixel increase or decrease is uniform across 
the entire shape of the selection. With rectangular selections, the directional arrow buttons determine a 
single edge (or edge pair) that will be moved inwards or outwards. 
 
Keyboard Shortcuts 
Use the cursor keys in combination with the SHIFT key to expand the region. Hold down CTRL to contract 
the region. As with the nudge palette, rectangular adjustments apply to one or two edges, and non-
rectangular selections are adjusted uniformly. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
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Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
 

 
Top 
 
 

 
 
 

Regions and Floating Images 
 
Note: This help topic is identical in content to the Region/Floater section in the Getting Started topic. If 
you have read through that topic, you may skip ahead to the related links for other region-specific help. 
 
EzImage works with parts of an image using the concept of Regions and Floaters. 
 
Regions 
Regions are selections of an image that do not contain any image data. They contain one or more areas 
that are outline paths that appear as animated black and white dashed lines, and are commonly referred 
to as 'marching ants'. 
 
A region can be a simple rectangle or a shape of any complexity imaginable. Various selection tools allow 
you to create rectangular, elliptical, freehand, polygon and other region types. When working with a 
region, no pixel information is altered. 
 
Paint and Imaging Processes Affected by Regions 
Many image adjustment and painting operations in EzImage will be restricted by the presence of a region. 
For example, applying a color fill on an image with a region will only have the region area affected. All 
painting tools are confined to work within a region selection only. 
 
A Region Selection: 
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Floaters 
Floaters represent a second image layer which rests on top of the normal background image. A floater 
can be created by any of the following methods:  
 

Pasting an image from the Windows clipboard. 
Dragging a piece of an image using the Move Selection tool. 
Dragging a piece of one image on top of another image. 
Loading a floating image from a file. 
Creating a floating image from the gray level pixel data in an alpha channel. 
The Text Tool creates text as a floating image by default. 
The Shape Tool creates the shapes as floating images.  

 
Floaters can be placed onto the clipboard or saved to a file using a special format. Once a floater is 
active, you are free to drag it around the background image or perform most types of image processing 
operations on it (you may NOT apply a painting tool to a floating image). Modifying a floating image does 
not affect the underlying background image while it is active.  
 
While a floating image is active, there are a few things that you can't do:  
 

Save the image to a standard file format (you can only save the image as a Work Space file if a 
floater is active). 

 
Resize, rotate, or perform any type of size adjustment to an image. The shear, rotate, and resize 
options apply to the floater if you choose to apply one of those methods. 

 
Use any of the image painting tools.  

 
There are 3 methods by which to blend a floater with the background image:  
 

To paste a floater into the background image, use the Paste option in the Floater menu. The floater 
will be deleted after you paste it.  

 
To paste a floater without deleting it, choose the Stamp option.  

 
To blend a floater with an image using an alpha channel gray mask, create a gray level mask in a 
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RGBA format image's alpha channel, and choose the Alpha Blend option from the Floater menu.  
 
The blend, opacity, and inversion options available in the Move Selection tool control how to blend the 
pixel colors of the floating image with those of the background image.  
 
A Floating Image Selection: 
 

 
 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
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Region and Floater Keyboard Shortcuts 
 
The following keyboard shortcuts are specific to methods that create and/or affect region and floating 
image selections. 
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Existing Region Selections and Floaters 
Cursor keys move the selection in one of four directions 1 pixel at a time.  
 
Polygon Selection Tool (Create Mode) 
The cursor keys will pan the image window. 
 
Hold down SHIFT to constrain the selection lines to 45 degree angles. 
 
Right click to cancel the polygon selection. Left click with CTRL held down to close the polygon and 
create the selection.  
 
Rectangular and Elliptical Selections (Create Mode) 
The cursor keys will pan the image window. 
 
Hold down SHIFT to constrain the selection to a circle or square.  
 
All Region Selection Creation Tools 
If you hold down SHIFT with a cursor direction key, the selection will expand in one direction (rectangle) 
or uniformly (non-rectangular). 
 
If you hold down CTRL, the selection will contract by one pixel. 
 
Hold down SHIFT while right clicking to set a region placement anchor point. 
 
Right click to cancel the region selection. 
 
Dragging Floaters 
Hold down SHIFT to drag the floater vertically. 
 
Hold down CTRL to drag the floater horizontally.  
 
Creating Region Combinations 
Hold down CTRL to add to the existing region. 
 
Hold down ALT to subtract from the existing region. 
 
Hold down CTRL+ALT to create an intersection of the current region and the one you create. The 
selection tools contain options to lock these modes during region creation to avoid having to always use 
these shortcut keys. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
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Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Regions and Floating Images 
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Creating Regions from Floater Masks 
 
Use the Select->Make from Floater menu option to convert the mask of a floating image into a region. 
This is the opposite effect of the Floater->Make from Selection method. The floating image itself will be 
lost after the conversion to region format. As with most of the region creation options, you will be given a 
dialog from which to choose a combination method with any existing region. Note that the region position 
will coincide with the current position of the floater. 
 
Image with Floater: 
 

 
 
After Conversion to a Region: 
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Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Deselect and Reselect 
 
EzImage will always retain the prior region outline selection when a new one is created, or when an 
existing selection is removed. 
 
For example, if you create a complex selection and accidentally apply Select->Deselect, then you can 
restore the deleted selected using Select->Reselect. 
 
All selection options that modify an existing region selection to create a new one preserve the previous 
version. The Reselect option is particularly useful with the Color and Magic Wand tools, since you can 
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selectively add more areas to a region and step backwards one level if you made a mistake. 
  
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Creating Brushes from a Selection 
 
To create a brush from a region selection, you need to create a rectangular selection on any type of 
image. Even though a brush is stored in 256 levels of gray, the source image can be any bit depth, since 
the selected pixels will be converted to grayscale. 
 
The replacement is done on the current brush file as shown in the title bar of the brush palette window. If 
the brush file is monochromatic format (the brushes contain only black and white pixels), then the source 
image must be in black and white format as well. 
 
Source Image: 
 

 
 
Choose Select->Save Selection->To Brush from the menu. A dialog will appear as follows: 
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Category 
Choose a category for the brush replacement. Categories are the rows in a brush file, of which there can 
be a maximum of nine. Every brush file supplied with EzImage has 4 rows labeled User 1 to User 4 
available for new brushes. 
 
Position 
The position is the column of the brush in the current row (category). Each row can have up to 11 
brushes. You can replace any column position in a brush category, even if a brush already exists in that 
position. 
 
Name 
You can enter a description up to 64 characters for this brush. The name of this brush will appear in the 
Brush palette window when it is selected. 
 
Actual Size and Core Area Size 
A brush with varying levels of gray shades in its mask, especially ones with high softness values, will 
have a large percentage of dark pixels, which are barely, if at all visible in many cases. The core width 
and height are the values that define brush spacing based on the majority of the bright pixels in a brush. 
You can override these values before saving the brush. The core size determines the distance for 
painting retouches based on spacing. For example, if the width of the brush is 120 pixels and the core 
width is 60 pixels, a spacing of 50% would result in paint retouches every 30 pixels of mouse travel. 
 
The Width and Height values are the actual pixel dimensions of the region selection. The core size by 
default is set to the same values. 
 
Spacing 
Spacing determines the retouch distance when you apply color with a painting tool. It is a percentage of 
the core width and height, not the actual width and height. For example, a spacing of  500% applied to a 
brush with a core size of 80 x 80 pixels will result in the brush mask being applied every 400 pixels of 
travel distance on the image. For soft brushes, a spacing of 25% is usually a good value. For hard 
brushes, a value of 10% is a good choice. As you decrease the spacing on large brushes, the overall 
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paint speed can decrease. 
 
Replaced Brush in Palette: 
 

 
 
Once a brush is replaced, it will automatically be set as the new brush for the current painting tool. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Saving a Region to the Clipboard 
 
To save an image region to the clipboard, use the Cut or Paste options from the Edit menu. The Cut 
option will place the image data for the region area into the clipboard and replace the same pixels in the 
image with the current background color. 
 
If the region area is non-rectangular, the remaining pixels that are not part of the selection will be 
replaced with the current background color. All image data saved to the clipboard from a region selection 
is saved in a rectangular format. 
 
Note that floating image selections are also saved using the same Cut and Copy methods in the Edit 
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menu. When you copy a floater to the clipboard, it is stored in a format that is specific to EzImage – other 
applications will not be able to access floaters in the clipboard. In addition, floating images take priority 
over standard region images, which are stored in a generic device-independent bitmap (DIB) format. If 
you have both a floater and DIB format image in the clipboard, the floater will be accessible, but not the 
DIB. You can selectively choose to remove one of these formats from the clipboard using the Edit-
>Empty Clipboard menu option. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Saving a Region to a File 
 
To save an image region to a standard image file format, use the Select->Save Selection->To File menu 
option. 
  
If the region area is non-rectangular, the remaining pixels that are not part of the selection will be 
replaced with the current background color. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to another Image 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
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Regions and Floating Images 
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Saving a Region to Another Image 
 
To save an image region to another window, use the Select->Save Selection->To Image menu option. 
Depending on the general preference settings, you may be asked to provide a name for the new image. 
 
If the region area is non-rectangular, the remaining pixels that are not part of the selection will be 
replaced with the current background color in the new image. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
Saving to the Clipboard 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Saving Region Outlines 
 
You can store the outlines that make up a region selection to either the clipboard or to a file. In either 
case, the format is specific to EzImage and is not accessible by other applications. A region outline does 
not contain any pixel information from the source image. By moving a region outline to a file or the 
clipboard, you can easily transfer it from one image to another. 
 
All options are available in the Select->Region Outline menu. 
 

Use Copy to place a copy of the current region outline in the clipboard. 
 

Use Paste to place a region from the clipboard onto any image. Since a region outline must fit within 
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the pixel dimensions of an image, clipping will occur with any region whose rectangular bounds 
exceed that of the target image. 

 
Use Clear to remove the current region from the clipboard. Since complex regions can consume a 
moderate amount of system memory, you may wish to use this option when a region is no longer 
needed. 

 
Use Save to save the region to a file. The default location for region files is the Regions folder in the 
application path, with a file extension of .EZR. Use Load to load a region file and apply it to an image. 

 
Combining and Placing Regions 
When you Paste or Load a region outline, you will have options to set the position and combination 
method: 
 

 
 
Combination Mode 
When placing a selection region onto an image, you can choose to combine it with an existing selection 
using of these combination methods. The Replace option will simply delete any existing region selection 
in the image. The combination methods are identical to the ones available with the standard region 
selection tools. 
 
Placement Position 
Top Left: Check this option to place the region in the upper left corner of the image. 
 
Saved Position: When regions are saved to clipboard or to a file, they are stored with both size and 
position information. You can place a region at the same position where it was stored from, even if it was 
from a different image. Region selections can not extend beyond the boundaries of the image – if the 
selection is too large based on the saved position, the region will be clipped. 
 
Anchor Point: You can define an anchor point for the top left corner of the new region selection by 
checking one of these options after setting the position in the image. To set the anchor point, use any 
region selection tool and right-click in the image while holding down the SHIFT key. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
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Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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File Save Options 
 
There are several dialog windows for saving images to one of the various files formats supported by 
EzImage. This topic summarizes all of the possible save option dialog window available. 
 
Bitmap Save Options 
 

 
 
Type 
There are 3 types of .BMP files that can be saved. Since EzImage was designed to run only under the 
Windows operating system, you should save the files using that format, unless you need to create images 
for the OS/2 platform. 
 
Depth 
The bit depth will automatically be set for you. For indexed color images, you may be given a choice to 
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save images in 1, 4, or 8 bits per pixel. For RGB or RGBA images, you can not choose any other bit 
depth. The save procedure does not alter the image bit depth when writing to file, so your choices are 
limited to those that do not affect the image. 
 
Run Length Encoding 
For indexed color images, you may check the RLE Compression option to store the image. Note that this 
type of compression is very simple, and will not do a good job of compressing images with diffuse color 
content, such as photographs. 
 
 
JPEG Save Options 
 

 
 
Storage Format 
JPEG files can use any of 4 storage types. The EXIF and JTIF types do not support all of the 
compression options that the standard Normal type does. 
 
Compression Level 
A compression level can range from 2 to 255. This scale is not linear. A value in the middle is actually not 
a good compromise between compression and quality. You can achieve good image quality using 
compression values from 16 to 64. 
 
You can save a file in JPEG format without using any kind of compression. This option is not available for 
the EXIF storage types. 
 
Color Space 
You can save images using YUV or CieLAB color spaces, with an RGB distribution ratio of 4:4:4 (best), 
4:2:2, or 4:1:1 (worst). The CieLAB format is not available with all storage types, and is significantly 
slower to read and write then the common YUV format. 
 
Progressive Scanning 
Check this option to save the JPEG files using progressive scanning. Choose the number of passes for 
this storage format from the dropdown list. 
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Portable Network Graphics Save Options 
 

 
 
The PNG format has a very simply level of compression. Check Default for the standard compression 
method, or uncheck it and use the slider to set a varying compression level. 
 
 
Flashpix Save Options 
 

 
 
Compression 
FPX provides for no compression, single color, JPEG (Default), or JPEG variable. Only Variable JPEG 
uses the slider to set the level of compression. The slider values result in the same level of 
compression/image quality as the one found in the JPEG save options dialog. 
 
 
TIFF Save Options 
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Format Type 
You will choose one format from the set provided when saving to a TIFF file. Note that many of the 
options may be disabled. The CCITT options are only enabled when saving black and white 1-bit images. 
The LZW, CMP, JBIG, and Wavelet options are not enabled in this version of EzImage.  
 
Color Space 
You can save a TIFF image in RGB, CMYK, or YCC color formats. This does not affect image format that 
is currently open in its window. The conversion from RGB to CMYK or YCC formats takes place within the 
file save process only. When you load a CMYK or YCC image, it will be converted to RGB color space at 
the time the image is loaded. 
 
Top 
 
 

 
 
 

Creating Fill Patterns 
 
You can create a fill pattern from any rectangular selection in an image, of any size you wish. Choose 
Select->Save Selection->As Fill Pattern to create a pattern file. 
 
Pattern files are saved as Windows Bitmap (.BMP) format files in the Patterns folder of the application 
path. The pattern file can have any bit depth, since the fill process will convert the color format of the 
pattern to match the source image. 
 
Pattern files can be represented by any support image format, stored in any location. Note that the image 
fill operation does not scale the pattern information. Fills are always done at actual pixels. 
 
Related topics: 
 
Creating Regions 
Making Rectangular Regions 
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Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Status Bar Information 
 

 
 
The status bar appears at the bottom of the main view. It is divided into the following panes (left to right): 
 
Current Cursor Position: This is the current mouse cursor position in the active image, in the unit of 
measure defined by the Information palette. 
 
Information Status Icon: This icon actually has 4 different states depending on script recording and 
playback. 
 

  Information Mode 
 
Click on this icon to see basic information about the current image. See the last link at the end of this help 
topic for details. 
 

  Script Record Mode 
 
When recording a script, clicking on this icon provides a popup menu with some basic recording options 
(a duplicate of the Tools->Scripts->Actions menu): 
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  Pause Mode 
 
When recording scripts, you can pause the session, which blocks any additional script commands from 
being added to the file. 
 

  Playback Mode 
 
When playing a script file, this icon indicates that play mode is active. You can click on it to access a very 
small popup menu with one option: Cancel Playback. 
 
Zoom Level: This indicates the current magnification for the active image. You can click on this pane to 
set a new zoom level from or choose from one of the window fit options using the popup menu. 
 
Help/Progress Message Area: The remainder of the status bar is used to show hints for menu items, 
buttons, and other controls in the main view. It also is used to show progress and operation status 
messages when playing back script files. 
 
Related topics: 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Brush Palette 
Information Palette 
Scripts Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Image Information Help 
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Browsing Slide Show Images 
 
The slide shows script editor doesn’t have any type of image browser feature other than a full screen 
preview, one image at a time. If you wish to view the images in a slide show using the image list editor, 
you have two options, both available from Browse->Slideshow in the application menu. Note that any 
image list currently in memory will be replaced with the images from the slide show. 
 

Choose Image Browse to view all of the images in the slide show. 
 

Choose Marked Browse to view only images that were marked during slide show playback. The 
marking features are only available when playing a slide show script in manual step mode. You can 
switch slide show play mode from automatic to manual step mode by pressing the SPACE bar or 
Escape during playback. 

 
Image List Editor 
 
Slide Show System 
Creating Script Files 
Play Back System 
Slide Show Script Editor 
Image Attributes 
Text Associations 
General Preferences 
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Scanning an Image 
 

 
 
Choose File->Begin Image Scan to acquire one or more images from your scanner. This method will 
scan each image into a new image window. 
 
The scanning process will use the graphical user interface of the scanning device you have assigned as 
the current scan source. In other words, when you purchased your scanner, you should have been 
provided with some software that allows you to scan images. EzImage will in effect link into that software 
and use it to obtain the document images. 
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Although your scanning software may support 16-bit gray scale, and 48/64-bit color image acquisition, 
EzImage does not recognize these bit depths, and will reject the scan. 
 
Image Name/Prefix 
When scanning images using this method, they are placed into a new window when the image transfer 
has been completed. EzImage does not allow the same image name in two different windows. Therefore, 
you have two choices you can make: 
 

Change the image name prior to each scan. 
 

Use the sequence number option. This will add a unique number to the end of the image name. 
 
Only valid file name characters are allowed in an image name. If you attempt to use in invalid file name 
format, or leave the image field blank, then the name of Untitled will be used with a sequence number. If 
you specify an image name that already exists in another open window, a sequence number will 
automatically be appended to the name. 
 
Sequence Number 
Check this option to include a unique number after the image name. Even with this option unchecked, a 
sequence number will be added if you choose a name that conflicts with an existing open window. By 
checking this option, you are forcing a number to be added to all image scans. 
 
Scanning Documents 
Click on Scan to launch the software that will be used to acquire the images. As each image is scanned, 
it will be transferred to EzImage, and then placed into a new image window. When you are done scanning 
documents, close the scanning software to return control to EzImage. 
 
Memory Usage 
Keep in mind that every image scanned will consume system memory as long as the image windows 
remain open. If you intend to scan several large documents at one time, you should consider using the 
batch file scan method, since the images are sent to files rather than placed in open windows. 
 
Related topics: 
 
Selecting a Scanner 
Batch File Scans 
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File Conversions and Scripts 
 
The File Conversion tool allows you to process several images at one time. The basic image alteration 
features provided within that tool allow for the following: 
 

Image transformations including rotations, flips, resizing, cropping, and border expansion. 
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Image and text overlays (either but not both). 
 

Color adjustments and bit depth conversions. 
 
These options represent common image alterations that are generally fast and simple, and as such when 
a non-scripted file conversion takes place, there is no visual reference to the image as it is being 
changed. 
 
There may be a need to use some of the more advanced features in EzImage in a batch file conversion, 
in which case you will need to use a script file. The process of creating a script-based conversion job is 
quite simple. Associate a script file in the conversion properties, and when you run the conversion, the 
script file commands will be applied to every image. 
 
When a script file is attached to a file conversion job, each image is opened in a window, adjustments are 
applied, and the image is resaved to a new location, sometimes under a new name. The image window 
will then be closed. 
 
Image transformations, overlays, color adjustments, and bit depth conversions will be disabled when a 
script file is used. Therefore it is important that any script file that requires such image alterations will 
include the necessary commands, since only one script file may be used in a file conversion job. 
 
Related topics: 
 
File Conversion Tool 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
Scripts Palette 
Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
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EzImage Script Files 
 
Script files are plain text files that contain a sequence of commands that are available within EzImage. 
The script file is not based on a programming language, and has no type of structure that requires you to 
learn how to write them. Scripts are created through a process of recording actions in a specific order. An 
example of a script would be one that corrects the orientation of a scanned image and trims away the 
background color. You can record an Edge Deskew command followed by an Auto Trim command and 
assign that to a script file. 
 
Format of Script Files 
Script files are plain text, which can be viewed with any text editor. Unless you wish to manually write a 
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script file using a text editor, it is best to record the commands with the facility provided within EzImage. 
Scripts have a file extension of .SCR and contain some initial information that identifies the type and 
owner of the script file. Outside of these first few lines in the script file, the remainder is composed of 
commands, one command per line in most cases. Some commands, such as those that record brush 
painting, can contain several dozen lines in the script. 
 
Location of Script Files and Set Groups 
Scripts are located in the Scripts folder within the EzImage application path. Within this folder is a series 
of subfolders, which define a Set for grouping related scripts together. When you first install the 
application, a set named Default will be created for you. When you create a new set for a group of script 
files, you are in effect creating another subfolder beneath Scripts. For example, if you create a script 
called Sample1.scr in the default folder, a typical location for this file would be: 
 
C:\Program Files\SoftPro 2010\EzImage\Scripts\Default\Sample1.scr 

 
Recording and Playback 
Options are available in the Tools->Scripts menu to record and play back script files. When you record a 
script file, almost any action you do in EzImage will be written to the script file. When you stop recording, 
the script file will be closed and added to the scripts palette for the current set. To play back a script file, 
you can choose the Tools->Scripts->Play option or simply click on the entry in the palette. While a script 
play back is in progress, you will not be able to do anything except observe, or cancel the script if you so 
wish. 
 
Scripts Palette 
The scripts palette contains a scrolling list of all script files assigned to one set. You can enable display of 
this palette using the View->Palettes menu option. Each entry in the palette corresponds to one script 
file. This list is always sorted alphabetically. 
 
File Conversions and Scripts 
You can assign a script file to the File Conversion tool, which forms the basis for batch script operations. 
 
Maintenance 
The script system includes a palette editor, which more or less is a file manager that works within the 
confines of the Scripts folder. With the editor, you can copy, move, delete, or change the properties of 
script files and set folders. You may use any file management software, such as Windows Explorer, to 
perform the same type of maintenance, since the whole script system is based around folders and files. 
 
Menu Shortcuts 
Within the Tools->Scripts menu are 10 shortcut menu options for assigning your favorite script files to. 
Unlike the scripts palette which only shows one folder set at a time, the menu shortcuts can be any script 
from any set, and can mix with scripts from other sets. Menu shortcuts can have key assignments as well, 
allowing for quick access to the script. 
 
Recording Menu Action Scripts 
The recording system has a convenient option to allow you to record a single menu action as a script file. 
These types of script files will simply be shortcuts on the scripts palette for a main menu command. 
 
Writing a Script File 
Unless you have a need to write custom script files using a text editor, you should let EzImage record the 
script commands for you. If you wish to bypass the recording system and write script files by hand, you 
should refer to the EzImage Script Command Reference document, which is available as a PDF or RTF 
format file that is separate from this help system. 
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Making Changes to a Script File 
You should not edit the contents of a script file unless you understand how the structure works for the 
various commands that can be recorded. Any errors or omissions you introduce into a script file may 
cause the script to fail to run, or cause an application error. Under no circumstances should you modify 
the contents of a menu shortcut script, or the information lines that appear at the start of a script file. 
 
Script Recording/Play Back Status 

When recording a script, the information icon  will be replaced by the recording icon  in the status bar 
of the main EzImage view. You can click on this icon for a popup menu of options that mirror those found 

in the Tools->Scripts->Actions menu. When playing back a script file, the icon will change to . Script 
recording can be paused, during which no commands will be added. When script recording is paused, the 

icon will change to . 
 
For detailed information on the various aspects of EzImage scripts, click on any of the following links: 
 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Scripts Palette 
Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
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Menu Shortcuts 
 
Script menu shortcuts are accessed through the Tools->Scripts menu: 
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A menu shortcut allows you to assign up to 10 of your favorite scripts, which can be accessed without the 
need to change the current Set defined in the script palette. Since the main menu can be fully 
customized, you can assign keyboard shortcuts of your choosing for these scripts. 
 
Adding a Shortcut 
To define a menu shortcut for a script file, you can do one of the following: 
 

Use the palette editor to locate the script file, then use the Edit menu option to change the properties 
for the script file. Assign a menu position from within the properties dialog window. 

 
Assign a menu position when you create a new script file using the record option. 

 
In either case, any script file reference in that currently occupies a menu position you are assigning to will 
result in a replacement (of the shortcut, not the script file). 
 
Removing a Shortcut 
Use can remove a shortcut using the Menu menu in the palette editor. Choosing the shortcut from that 
menu will erase its equivalent entry in the EzImage main menu. You can use the Clear option in that 
menu to remove all shortcuts in one step. 
 
Related topics: 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Scripts Palette 
Script File Maintenance 
Writing a Script File 
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Scripts Palette 
 

 
 
This palette contains a list of script files that are grouped by a common file folder, referred to as a Set. 
The current Set (folder) is shown in the title bar of this palette. Scripts in this list come in 2 formats: 
recorded scripts and menu shortcut scripts. Use the View->Palettes option in the main menu to display 
this palette. 
 
Menu Shortcut Scripts 
These script files are created based an their equivalent action in the EzImage main menu. You may think 
of these script types as toolbar icons in other applications that are used as menu shortcuts. A menu 
shortcut script has the following characteristics: 
 

The icon for the entry in the palette is a unique graphic that helps to identify what action the script 
performs. 

 
Popup help is available for this type of script by simply clicking on the icon button. 

 
When you click on the labeled button, the equivalent menu action will be executed, as opposed to 
standard script play mode. 

 
These shortcuts script files are automatically created using the Record Menu option facility. There is 
no recording session involved. 

 
Standard Recorded Scripts 
These script files are generated either through the recording system provided by EzImage, or by using a 
text editor to compose a script file. Unless you understand the structure for the various commands that 
may be present in a script file, you should use the recording facility provided. 
 
A recorded script file has the following characteristics: 
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The icon for the script is a small dialog window graphic. When the graphic appears grayed out, the 
script will run in silent mode. This means that no dialog windows will appear while the script is 
running. For example, if you have recording an Indexed Color conversion command, the dialog 
window for that operation will not appear. If the graphic appears in blue and white, then dialog 
windows will appear for all commands that use them, with the various fields preset to the properties in 
the script file. 

 
Clicking on the dialog icon button in the palette will toggle it between show dialog mode, and silent 
mode. 

 
When you click on the labeled button for the script, all windows and palettes in EzImage will be 

disabled while the script is running. You can click on the playback icon  in the status bar to cancel 
the script, or use the equivalent option in Tools->Scripts->Actions. 

 
Popup Menu Options 
Right click on the palette for a popup menu with options to record a new script, edit the palette, or switch 
to a new Set group. 
 
Setting the Palette Size 
The number of button rows and width of each button in the scripts palette can be changed from the 
application general preferences. 
 
Related topics: 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
 
Menus and Shortcuts 
Tool Palette 
Tool Options Panel 
Brush Palette 
Information Palette 
Color Swatch Palette 
Nudge Palette 
Image Windows 
Status Bar Information 
Image Information Help 
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Playing a Script File 
 
A script file can be played back in one of three ways: 
 

Choose the Tools->Scripts->Play menu option. You can choose any script from any Set for play 
back without the need to change the current Set in the scripts palette. 

 
Click on the labeled button for any entry in the scripts palette. 

 
Assign a script file to the File Conversion tool. 

 
When using the Play menu option, you will be given a dialog window from which to search for a script file: 
 

 
 
Use the Browse button to search for a script file. All of the fields are read-only and are there for your 
reference. Click on OK to play the script file. 
 
Script Play Back 
When playing a menu shortcut script (files that begin with the tilde (~) character, created by the Record 
Menu facility), the equivalent menu action is executed without invoking the script play back system. 
 

When playing a standard script file, the information icon  in the status bar of the EzImage main view will 

change to a play back icon . In addition, all windows and menu options will be disabled. Script play 
back is a non-interactive method, where no other image processing operations are allowed. You may not 
pause or alter the sequence of commands that are executed during a script play back session. You can 
however cancel script play back by clicking on the icon in the status bar or choosing the cancel option 
from the main menu. 
 
Is dialogs are enabled for the script, then the appropriate dialog window for each command that uses one 
will appear during play back. All input fields in the dialog windows will be populated with any parameters 
that are contained within the script file. If you cancel any dialog during play back, the script will stop 
immediately. 
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If dialogs are disabled, the script will be running in silent mode. You can monitor the progress for each 
script command by examining the help hint area in the status bar of the EzImage main view. 
 
Multiple Image Scripts 
Script files can refer to images outside of the active one that the script was executed against. Commands 
are available within the script that can refer to an image open in another window. The script system has 
the ability to open multiple images at one time and apply commands against any or all of them in addition 
to the one that the script started with. The script system always refers to image windows by name, and if 
an image reference can not be found in an open window, an error will result and the script play back will 
stop. 
 
Destructive Scripts 
Since almost any command can be recorded into a script file, it is possible to define a sequence of 
commands that would erase the contents of the current image file or perhaps any image file on your 
system. There is no mechanism in a script to delete files from your system, but the pixel contents of 
image files can be altered or erased unexpectedly if you are using script file of unknown origin. 
 
An option in the general preferences allows you control how to handle any script commands that alter 
files on your system, providing the following choices: 
 

Always prompt before modification 
Ignore the script command 
Abort script playback 
Always perform the file change 

 
If you choose to ignore the destructive script command, it may affect the sequence of commands that 
follow it in the file. 
 
Script Play Back Messages 
When recording script files, a feature is provided to embed one or more messages at any point the 
command sequence. When playing back the script file, these messages will appear in the form of popup 
dialog windows. You have the option to stop script play back from this dialog, or continue with the 
remaining commands in the file. An option in the application general preferences is available which will 
disable these messages. 
 
Invalid Script Commands 
Some script commands are very specific about the content of any image you may apply a script to. It is 
possible that a script file that works on an RGB color image of a specific width and height may fail to run 
on an image that is indexed-color of a different size. If a script fails to run because of a command that is 
not applicable to the image workspace, an error message will be given, and the script play back will be 
halted. 
 
Related Topics: 
 
File Conversion Tool 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
File Conversions 
Scripts Palette 
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Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
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Writing a Script File 
 
Note: This topic does not describe in any detail the format for the various commands that can be 
embedded in a script file. This is simply a brief introduction on the format of a script file and how you 
would create or modify one. For information on the structure of the script file commands, you should refer 
to the EzImage Script Command Reference document, which is available as a PDF or RTF format file that 
is separate from this help system. 
 
Basic Content Format 
Script files are plain text files, one line per script command. The file has a basic structure containing two 
parts: Header information, and body content, which is composed of a series of commands and command 
parameters. 
 
There is no wrapping of text lines in a script file. Each line in a script command is terminated by the 
standard carriage return + linefeed character pair. 
 
Comments in a script file can be used on a line-basis only, by placing a pound (#) character in the first 
position of the line. You can not place comments on the same line following any command. 
 
Blank lines are ignored in the file. 
 
Header Section 
The header section of a script file contains exactly 7 lines of information: 
 
Line 1: Script Type Identifier 
Line 2: Version Number 
Line 3: Date of Creation 
Line 4: File Name 
Line 5: Description for hint help 
Line 6: Palette Name 
Line 7: Author 
 
The Author field is the only line that can have a blank parameter string. 
 
Script Identifier: 

This will be EZIMAGE SCRIPT:<Format Tag>, where the tag is a single character that can be one of: 

 
M: Shortcut menu script 
D: Dialogs enabled 
N: Non-dialog (silent) mode 
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You should never alter a shortcut menu script, since they are never really involved in the play back 
system – they are simply shortcut references to a main menu action. 
 
Version Number: 
This is currently 1.01. You should not change this number. 
 
Date: 
This is the date that the file was created, in YYYY/MM/DD HH:MM am/pm format 
 
File: 
This is the name of the script file. It should match the actual name of the script file and is used for cross-
reference integrity. 
 
Description: 
This is the message that appears in the status bar hint message area of the EzImage main view. 
 
Name: 
This is the palette name and the name that will appear in a main menu shortcut. 
 
Author: 
The author field is optional, but can be used to identify the owner of the script. 
 
Example: 
 
# EZIMAGE SCRIPT:D 

# Vers: 1.01 

# Date: 2003/10/20 07:54 pm 

# File: Adaptive.scr 

# Desc: Adaptive Color Reduction (Medium Quality) 

# Name: Adaptive 

# Auth: SoftPro 2001 

# Please do not modify the 7 lines above or the script may fail to run. 

 

2INDEXED 8 ADAPTIVE OPTIMAL 224 16 

 
Command Body Section 
 
This section contains script commands. There is no language syntax for a script. There are no control 
loops, variables, test commands or anything else that you might find in a programming or script language. 
The body content is simply a sequence of actions that correspond to keyboard events, mouse clicks, 
menu, or button commands within the EzImage application. 
 
The format of a script command is quite simple: 
 
COMMAND NAME [Parameter 1] [Param. 2] [Param. 3] … [Param. N] 

 
Some commands require multiple lines of text to be recorded properly, such as a freehand polygon 
selection. For those commands, each additional line will begin with some type of punctuation character, 
such as a colon or > symbol. Refer to the command reference manual for the exact syntax of the multi-
line commands. 
 
Parameters are separated by spaces, and there must be at least one space between a command and the 
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first parameter. Parameters are in many cases optional. For example, the 2INDEXED command is used 
to convert an image to indexed-color mode. If you omit all of the parameters, then the command will still 
run, but will result in the dialog window for indexed-color conversions being displayed. 
 
All parameters are entered in upper case letters unless the parameter is a text string. 
 
Related Topics: 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Scripts Palette 
Script File Maintenance 
Menu Shortcuts 
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Script Editor 
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The slide show script editor is used to modify the image list after it has been created using the options 
available in the thumbnail, image list editor or image preview browsers. You can also build a slideshow 
from the editor by folder, folder tree, or individual files. 
 
Unlike the other image browsers in EzImage, the slide show editor only provides image preview by 
double clicking on an entry in the list or by choosing View from the Options menu. 
 
The columns in the editor window correspond to specific attributes for each image in the list: 
 
File Name: This column can also show the path name for each image file using the Show/Hide Paths 
option in the Options menu. 
 
Rot.: This indicates any type of rotation adjustment made to the image. 
 
Flip: This will indicate a horizontal or vertical image flip. 
 
Time: If you choose to apply a different delay for a one or more images than what is defined in the 
general slide show preferences, it will be indicated here, as a numeric value in seconds. 
 
Gray: This column indicates if gray scale mode applies to the image. 
 
Zoom: If you have applied a magnification level to the image, the zoom factor will be shown here. If you 
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have chosen the bicubic option, the letter B will be appended to the zoom value. 
 
Text: If there is a text association for the image, it will be indicated in this column. 
 
W-H: Any type of width and/or height constraint will be shown in this column. 
 
V.P.: This column indicates if vertical positioning has been applied. By default, all images will auto-center 
within the slide show playback window. Vertical positioning allows you to move an image relative to the 
top edge of the screen, to allow for text placement below it. 
 
G.A.: If a gamma adjustment has been applied to an image, the amount of the correction is shown in this 
column. 
 
For any column that has default settings, a column position will remain blank. 
 
The panel immediately below the image list contains basic information about the selected file including 
size, dimension, bit depth, and last modification date. 
 
The status bar indicates the total image count in the script, the number of selected images, and the file 
and path reference to the current selected image. 
 
Playing a Slide Show 
Once you have added at least 2 images to the image list, you can choose the Play option from the menu 
to close the script editor and begin play back. For more information on controlling the play back of the 
images, refer to the topic list below. 
 
Loading a Script File 
Use the Load option to load a slideshow script file. Slideshow scripts are always stored in the Slides 
folder of the application path with a file extension of .ESS. The current slideshow script will be replaced 
with the new one. 
 
Adding Images to the Script 
You can use the options in the Add to Slideshow submenu to append images to the current script list. 
 

Use the Single Folder option to add images for one folder path (no subfolders). 
 

The Folder Tree option will add all images for a path including ones contained in subfolders. 
 

The Image Files option allows you to selectively add single file names from any path using a 
common open file dialog window. 

 
Images can also be added from the thumbnail browser, image list editor, and image preview browser. 
 
Saving Scripts 
The Save option resaves the current slideshow script to file. If the script was never saved to file, you will 
be asked to provide a new file name for it. 
 
The Save As submenu contains two options for saving a slideshow script: 
 
Use New Script File to create a new slideshow script using all images. 
 
The Image List option will create an image list format file from the slideshow script. This allows you to 
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use the image list editor to manipulate the contents of any slide show. Note that the attributes will not 
transfer to the image list, since the latter format maintains path and file information exclusively. 
 
Preferences 
This option is a shortcut to the application general preferences as it applies to slide show scripts. 
Although the set of options are identical to the general preferences that you would access from the 
EzImage main menu, the way they are applied is not the same. When you accept changes from the 
preferences in this editor, they are saved to the script in memory. When you accept slide show preference 
changes from the main menu in EzImage, they are saved in preparation for the next slideshow script that 
is created. 
 
Properties 
The image file properties dialog provides several pieces of useful information about image files, including 
format, compression, dimension, size, printing resolution, and comments. You can select multiple image 
files at one time and step through the properties of each one. A small thumbnail viewer and file marking 
system is also included in this dialog window. 
 
Filtered Selection 
This option will create an image file selection using pattern, size, and date-based filters. If you have text 
associations assigned to the images in the script, you can locate them using a search string with this 
option. Only images that match on one or more of the filtering properties will be selected. 
 
Shuffle to Front 
The shuffle option will move all selected images to the front of the list, without affecting the order of the 
non-selected entries. 
 
Image Attributes 
A default slideshow script will simply play all images without any special types of attributes. You can 
choose this option to apply additional properties to all of the selected images. Attributes include image 
rotation, mirroring, constrained sizing, zoom levels, gray scale conversion, gamma and position 
adjustments. See the link below for details on the options available. 
 
Text Associations 
You can associate one or more lines of text with any image in a slideshow. The text will appear beneath 
the image if room permits. If the image occupies the majority of the visible screen area, then the text may 
not appear at all. The best solution for this would be to use constrained sizing as an image attribute to 
ensure that there is always enough room to place the text. The text itself will automatically wrap to fit a 
portion of the screen width that you can define. See the link below for details on the options available. 
 
Deleting Entries 
The Delete option will remove all selected images from the slideshow script. The Clear option will remove 
all images. Neither option will result in deletion of the actual image files. 
 
Viewing Images 
This option will display the selected image in a full screen view. You can also view an image by double 
clicking on it in the list. 
 
Show/Hide Paths 
This option will toggle the display of a column for the path names associated with each image file in the 
script. 
 
Reset Columns 
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Most viewers in EzImage are sizeable windows containing panes of information that can be resized, such 
as dividing the window between image area and file list area. All of these size and position settings are 
permanently saved when you close the application. In the instance when you change screen resolution to 
a lower dimension, some of the information may be off the screen. Use this option to reset all window 
pane positions to default values. 
 
Sorting by Path and Name 
Use the sort options to display the list in path name or file name order. Since a slideshow script is 
completely loaded into system memory, EzImage uses a compact method of storing the list by grouping 
path names and file name separately. While this creates a significant saving in memory usage, it does 
impact the sorting time. Lists with several thousand entries can take several seconds to sort on slower 
systems. 
 
Changing the Base Path 
You can use this option to change the base path for one selected image. When you change the path 
reference, all images in the list that are linked to the same path will also be changed. This may be 
necessary when an image file has path links referencing images that have moved to another location. 
This option does not rename the files on your system. 
 
Verify Existence 
This option will check every entry in the list to see if the source image file exists. Any entry that refers to a 
non-existent image file will be selected. You can use the Shuffle option to move all of the selected entries 
to the front of the list for easier viewing. 
 
Verify Duplicates 
This option will check every entry for duplicate image files (same name with the same path reference). 
Any duplicate entries will be selected. You can use the Shuffle option to move all of the selected entries 
to the front of the list for easier viewing. 
 
Pack Path Names 
When images are added to a list as a group, each file with the same path reference is grouped with a 
single path link. Each group of files creates one new path link in the image list. When adding many 
groups with different paths over a period of time, path and file fragmentation in the list can occur. This 
fragmentation has no impact on performance, but does increase the memory footprint of the image list. 
Use the pack option to de-fragment the paths and files if you are managing lists with several thousand 
entries. 
 
Related topics: 
 
Image List Editor 
Image Preview Browser 
Thumbnail Browser 
 
Image Attributes 
Text Associations 
 
Slide Show System 
Creating Script Files 
Play Back System 
General Preferences 
Browsing Slide Show Images 
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Selection Separation Tool 
 

 
 
Selection separation is a process by which distinct image areas are isolated into new images, either 
saved as image windows in the main EzImage view, or as files on disk. The isolation is based on 
contrasting pixel colors between a background color and all other colors that would make up the 
individual image areas. This process is ideally suited for scanned images where you place several small 
documents on the scanner glass at the same time. Selection separations will not work with images that 
have no distinguishable background color, such as a single border-less photograph. 
 
Manual and Automatic Modes 
Manual separation mode requires that you create multiple region selections using the various image 
selection tools available (magic wand, free hand, rectangular, elliptical, etc.). This option is not as flexible 
or efficient as the automatic method, but it is useful when separating image areas that are more or less 
perfect with regards to creating a selection around them. A common approach for this method is to use 
the Magic Wand tool on a background color pixel, and invert the region selection, which will highlight all 
the non-background areas. 
 
Automatic separation mode uses a sample background pixel color and a tolerance level similar to that of 
the Magic Wand tool to create the image area selection boundaries for you. It is more or less performing 
the magic wand step for you. 
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Setting the Target Path 
The default target path for file separations is the Separate folder within the EzImage application 
installation path. You can change this to any folder of your choice. If it does not exist when you being the 
separation process, the folder will be created for you. 
 
Setting a File Name Prefix 
When saving selection separations to file, you must provide a prefix for the file name. A 3-digit number 
will be appended to this prefix. For example, a prefix of “Sep” will result in separation names of 
Sep001.tif, Sep002.tif, etc. Separations are always saved in .TIF format in the target folder assigned for 
the operation. If the file names already exist, they will be overwritten, so please ensure you have moved, 
copied, or otherwise taken care of any existing separation files that may exist in the target path. 
 
Minimum Image Separation Width and Height 
Selection separation works by analyzing a potentially large and complex series of connected and 
unconnected areas in an image, and merges the information into large sections that can be separated. 
Some images may contain numerous spots of random noise, dust, scratches, and so forth. In order to 
eliminate these areas, you need to specify a minimum size for each area that can be separated. The 
minimum size allowed is 16 x 16 pixels. Any image areas that are isolated to be less than this size will be 
considered noise and be eliminated. 
 
Adding a Border 
When separating images, you may wish to have a small border of color added around each image. Enter 
a value in this field, in pixels. The border will use a fill color that you can specify. 
 
Region Expansion Amount 
Depending on the image and the tolerance settings, you may find that the areas that are included in the 
separation process need to be relaxed a little bit to include a little bit of extra space for analysis. If you 
enter an expansion amount (in pixels), the entire region selection will be uniformly expanded. This option 
will not work well if you have a very complex selection region or if the images are tightly packed together. 
Use the Preview option to ensure you have room to expand the region. Please note that region 
expansion can take several seconds when applied to large complex areas. 
 
Image Limit 
You can specify the maximum number of separations that will be created from any one image. Although 
the resulting image separations will not consume any more memory than the original image, the number 
of image windows created can impose a significant strain on system resources. The limit is a number 
from 2 to 500 separations. If you expect an image to have more than 50 separations, you should consider 
separating the selections to file. 
 
Fill Color 
The fill color is used for adding a border to a separated image, and also to fill any area of the image that 
is not part of the region selection that was involved in the separation process. This is an important issue 
for separations, as it is possible for the original region selection to bleed into the interior of an image you 
wish to separate. 
 
High tolerance values and images with very little in the way of contrasting images will result in this type of 
unwanted effect, and care must be taken to ensure you are separating each image in its entirety (use the 
Preview option for this). There will be the occasional image that simply does not have the proper type of 
color detail to separate with any valid settings. 
 
Tolerance Setting 



EzImage Reference – Version 1.05 

 

 Page 304 

 

Automatic selection separations rely on a tolerance setting to determine what parts of the overall image 
are background and noise, and what parts are actual image data. A higher tolerance setting will reduce 
the amount of noise blobs that are selected, but can also lead to selections that involve valid parts of the 
image data that you do not want to eliminate. There is a tradeoff that must be made to determine just how 
much image data becomes background to eliminate and how much data is valid image information. 
 
The Hand and Color Sample Icon Buttons 
Use the hand icon button to drag and move the image thumbnail sample around. This allows you to see a 
part of the image at 100% scale. If you right click on the thumbnail sample, the original image will be set 
to 100% scale and auto-center to the same position as the thumbnail. If you right click while holding down 
the SHIFT key, then original image will be scaled to fit the current window size. 
 
Click on the eyedropper icon button to choose a new sample point for the selection separation. By 
default, the upper left pixel of the image is chosen as the “background reference” point. If an image has 
edge noise that makes using the upper left corner pixel unsuitable, scroll the preview window around and 
locate a suitable background sample color. 
 
Feedback Information 
The separation process can take a significant amount of time to complete if the region selection is very 
complex (it is not uncommon for a large image with background noise to contain 100,000 or more discrete 
selection areas). The Progress, Accepted, and Rejected values provide feedback on analysis 
progression, accepted image areas, and rejected noise areas respectively. 
 
Postview Option 
Check the post view option to stop the separation process before the actual images are created. This 
allows you to view each separation in the original image before they are divided into individual image 
windows or files. You can then choose to reject a bad separation and adjust settings for another try. 
 
Invert Image Option 
Check the invert option to reverse the pixel color data for each selection image in the original as part of 
the post view process (If you don’t have post view enabled, this setting has no effect). Without inversion, 
you will only see the region areas selected using the standard “marching ants” marquee. Inversion works 

as a better visual reference for RGB, grayscale and black and white images, but may look unpleasing on 
indexed color images. 
 
Use Sample Color Option 
Check this option to use the sample color (use the sample icon button to click and pick a color off the 
thumb preview window) as the background reference color. If this option is unchecked, the upper left pixel 
of the image will be used as the background reference color. 
 
Saving Separations to File 
Check this option to save each separation to a file in the current target path assigned as shown at the top 
of the window. Files are saved in TIFF format, using the prefix name, followed by 3-digit separation 
sequence number. Any files that may exist in the target folder with the same name will be overwritten, so 
please ensure you have copied or moved any prior separations to a new folder. 
 
Previewing the Selection Boundaries 
The Preview button is available for automatic separations to view the region selection before the 
separation analysis begins. Because separations can take a significant amount of time to complete, you 
may wish to see what is being used as background image and what is being used as image data. It is 
possible, given an image and an arbitrary tolerance value, that the selection process is including valid 
image data as well. Keep in mind that only image data that you see selected will be included in the 
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separated images. 
 
Starting a Separation 
Click the Begin button to begin the analysis phase of the separation. This process can take a significant 
amount of time to complete on large images that contain background noise. If you have the post view 
option unchecked, then the separation process will commence immediately after the analysis is 
completed. 
 
If you are using the post view option, then you will see the results of the analysis visually on the original 
image before the separation process begins. This allows you to cancel the operation if the results are not 
what you expected. Click on the Separate button to begin the separation into image windows or files. 
 
Canceling 
Click the Cancel button to stop either the analysis or separation phases of the operation. If you cancel the 
separation process, any image windows created can not be automatically closed. Use the Close All (with 
no save) main menu option to quickly remove all of these image windows. 
 
Top 
 
 

 
 
 

Shape Options 
 
Cross Shape: 
 

 
 
The cross shape is defined by a horizontal and vertical “beam” that cross each other at the brush center 
at a perpendicular angle. The beam size for each one can be controlled as a percentage of the overall 
shape size. By using the link option, the height of the horizontal beam will be equal to the width of the 
vertical beam. 
 
Diamond Shape: 
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The diamond shape can have a distribution percentage of the two side points. A smaller distribution will 
move the side points higher. 
 
Hexagon Shape: 
 

 
 
The hexagon shape can be either regular (all sides are equal length) or irregular. For non-regular shapes, 
there is a distribution percentage for the side edges, and a base ratio for the size of the side edges 
relative to the height of the brush. 
 
Line Shape: 
 

 
 
A diagonal line brush can be rendered in two directions, with a line thickness between 1 and 64 pixels. 
Line shapes do not use the outline parameter. For a size larger than 64 pixels, you can create a rectangle 
shape and perform a rotation on the shape floater to achieve the same effect. 
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Octagon Shape: 
 

 
 
The octagon shape can be either regular or non-regular, with both top/bottom and left/right edge size 
ratios, and a single distribution for the side edges. 
 
Parallelogram Shape: 
 

 
 
The parallelogram has four basic shape types, and a shear angle, which are applied to the side edges 
(horizontal shape) or top edges (vertical shape). The shear angle must fall between 0 and 45 degrees. 
The shape size itself may not allow angles as large as 45° since the width and height aspect ratio can 
prevent certain shear angles from working. 
 
Pentagon Shape: 
 

 
 
The pentagon shape can be either regular (all sides are equal length) or irregular. For non-regular 
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shapes, there is a distribution percentage for the side points, and a base ratio for the edge opposite the 
natural peak point for the shape. 
 
Rectangle Shape: 
 

 
 
Squared Corners: A normal rectangle shape 
Rounded % of Width: The roundness of each corner defined by width 
Rounded % of Height: The roundness of each corner defined by height 
Rounded Separate %: The roundness is defined by both width and height 
 
The width and height represent a percentage of the overall shape width and height that is used to define 
the radius of the curves used to create rounded rectangles. 
 
Trapezoid Shape: 
 

 
 
A trapezoid can have one of four shape types, along with two percentage values. The size percentage 
defines the proportion of the smaller base edge to the overall shape size. The distribution percentage will 
shift the smaller edge towards one of the shape’s corners. 
 
Triangle Shape: 
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The triangle shape has one of 8 basic types, along with a concavity percentage. This value is used to 
indent the base edge of the triangle at its midpoint. Outlines are not available with this shape for any 
concavity value other than 0%. 
 
Related topics: 
 
Shape Tool 
 
 
Top 
 
 

 
 
 

Sharpen and Blur Filter 
 

 
 
This filter increases or decreases the sharpness of an image. Positive values will increase the sharpness, 
and negative values will decrease it (blur). The value range is –100 to +100 in 0.1 percent increments. 
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Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Average Filter 
Gaussian Blur 
Median Noise Reduction 
Motion Blur 
Unsharp Mask 
 

 
Top 
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Shearing Images 
 

 
 
The shear option moves the corners of an image in the fashion of a parallelogram. 
 
If a floating image selection is active, then the floater will be affected by the shear, not the image itself. 
 
Angle and Direction 
An image shear angle can be between 0 and 45 degrees in 1/100-degree increments. Use the counter-
clockwise and clockwise options to set the direction of the rotation. 
 
Horizontal Shear 
Check this option to shear the image along the horizontal edges. Uncheck it for a vertical edge shear. 
 
Fill Color 
When shearing an image, its size will increase and introduce blank areas. Choose a fill color to use for 
the blank areas. By default, the current background color will be assigned. For floating images, the fill 
color does not apply. 
 
Using a Measure Tool Angle 
If you have defined one or two measure lines for the current image using the Measure tool, then you can 
click on this button to shear the image by the measure tool angle. The direction will also be set in a 
manner that will minimize the angle. 
 
Related topics: 
 
Rotating Images 
Flipping Images 
Resizing Images 
Cropping Images 
Adding a Border 
Auto Trim Tool 
Edge Deskew Tool 
 
 
Top 
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Applying a Solarize Effect 
 

 
 
This filter applies an effect that mimics the accidental exposure of photographic film to light. It does so by 
inverting all color data with an intensity value greater than or equal to the threshold that you specify. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
 

Hold down SHIFT while dragging to increase the panning rate. 
 

You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
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a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Noise Filter 
Emboss Filter 
Mosaic Filter 
Oilify Filter 
Posterize Filter 
 

 
Top 
 
 

 
 
 

Script Properties 
 

 
 
You can use this dialog to change the base properties for a script. This affects the information that is 
contained within the first 7 lines of any EzImage script file. 
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File Name 
Script files have an extension of .SCR. You can change the name of a script file, as long as the file name 
is not the same as an existing script. Do not use the tilde (~) character as the first character in a script file, 
since EzImage uses it for creating pre-named menu shortcut script files. 
 
Description 
The description is a short message that identifies what action or actions the script will perform. It will 
appear as a help message on the status bar of the EzImage main window. 
 
Palette Name 
The palette name is what appears in the scripts palette as the label on each button. Scripts are sorted 
alphabetically on the palette according to this name. 
 
Menu Position 
You can choose to assign the script as a shortcut in the EzImage main menu under Tools->Scripts. 
Choose a menu position from this dropdown list, or choose None to remove the script from the menu. 
 
Author 
The author field is optional information that can identify who created the script. 
 
Show Dialogs on Play Back 
This option controls how a script can be played back. If you enable dialogs, then all script commands that 
would normally involve some type of operation dialog window will have such a window displayed at all 
times. The properties for the operation will automatically be filled in for you, so all you need do is click on 
the OK button to commit the action. Note that when you cancel a dialog-enabled script action, the script 
will stop playback immediately. 
 
Note that the file name, author name, and dialog play back options are disabled when changing the 
properties for a menu shortcut script. 
 
Related topics: 
 
EzImage Script Files 
Recording a Script File 
Recording a Menu Shortcut 
Playing a Script File 
File Conversions 
Scripts Palette 
Script File Maintenance 
Menu Shortcuts 
Writing a Script File 
 
 
Top 
 
 

 
 
 

Image Attributes 
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Rotation 
Check one of these options to rotate the image in 90° increments. This rotation will only be applied to the 
selected images in the slideshow script. 
 
Image Flipping 
Use these options to mirror the image horizontally of vertically. This will only be applied to the selected 
images in the slideshow script. 
 
Image Dimension Constraints 
Constraints are used to limit the maximum width and height of an image relative to the current screen 
size. To limit only one of the dimensions and let the other one scale using the image aspect ratio, enter 
an arbitrary high value. For example, use a width of 4000 and a height of 400 to limit the height of an 
image to 400 pixels, and let the width dimension scale as needed. The constraints are useful when you 
need to allow some border area for placing text descriptions for images. 
 
Image Delay 
The default delay between image display in a slideshow script is defined in the general application 
preferences. You can choose to use specific delay intervals for any image with this property. This delay 
value will only apply to the selected images in the script. 
 
Gray Scale 
Check this option to show the selected images using 256 levels of gray. 
 
Vertical Positioning 
Slideshow images are generally displayed so that they will auto-center within the visible screen area. 
Since text descriptions can only appear beneath an image, you may wish to position them relative to the 
top of the screen, using this option. The Vertical Step value is the number of pixels to shift the image 
down from the top edge of the screen. 
 
Setting Magnification Levels 
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You can enlarge any image in a slideshow by using the zoom options. Check the image zooming option, 
then enter a magnification level between 1.01 and 16.0 (these are scaling factors, not percentages, so 4.0 
= 400% zoom). Check the Bicubic option to smooth the image quality at the expense of processing time. 
 
Gamma Adjustment 
The gamma adjustment can be used to alter the overall brightness of images before they are displayed. 
Larger values will increase the mid tone levels, making the image brighter. Use a gamma level of 0 to 
disable this option, or else enter a number between 0.1 and 9.99. 
 
Removing all Attributes 
Click on Reset to remove all property modifiers for the selected images in the slideshow script. 
 
Related topics: 
 
Slide Show System 
Creating Script Files 
Play Back System 
Slide Show Script Editor 
Text Associations 
General Preferences 
Browsing Slide Show Images 
 

 
Top 
 
 

 
 
 

Selecting a Scanner 
 

 
 
EzImage requires that you select a scanning device before using the single image scan or the batch file 
scan methods. If you only have one scanning device enabled on your system, then EzImage will select it 
for you automatically. 
 
Note: If you don’t have any valid scanning devices on your system (a valid scanner must be TWAIN-
compliant), then the scanning options in the File menu will be grayed out. 
 
To select the scanner, choose File->Select Scanner from the menu. The dialog window contains a 
dropdown list with all valid TWAIN-compliant scanning devices. 
 
Related topics: 
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Scanning an Image 
Batch File Scans 
 
 
Top 
 
 

 
 
 

Getting Started 
 
Product Registration and Limited Time Trial 
If you downloaded EzImage as a free trial version from our web site, then you may use the application for 
a 30-day period after which you will need to purchase a registration code. In addition, some features of 
EzImage will have a limited number of uses during this trial period.  
 
There are three options in the Tools menu that are classified as Extended Features: Image Compare, 
Edge Deskew, and Selection Separation. These options require a machine-specific activation code, which 
may be purchased for an additional upgrade fee.  
 
Both the standard product activation and extended feature codes can be entered from the Product 
Registration option in the Help menu. If you have not obtained an extended features activation code, then 
you should use the Request option in the product registration form. This will provide you with a product 
identification code, which can be provided to us by either phone or email. Note that you will not be able to 
activate an extended features code until we have verified that you have a valid EzImage standard 
activation code.  
 
EzImage Interface Basics 
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The main EzImage window contains the following key components:  
 

A standard Windows menu bar across the top contains almost all of the available functionality offered 
by the application.  

 
EzImage uses floating palettes to both convey information and provide additional access to methods 
not provided on the main menu. These palettes contain controls that are used frequently enough to 
warrant their own windows. You may move these palettes to any location on your screen, or choose 
to hide one or more from view. Not all palette windows are visible when you first start the application. 
Use the View->Palettes menu option to hide or show the palette windows.  

 
The panel below the menu bar contains options for the various imaging tools located in the tools 
palette. When you select an imaging tool such as the color sample eye dropper, any option related to 
that tool will appear in the options panel.  

 
The status bar at the bottom of the window contains several panes for the following: Mouse cursor 
position in the active image, an icon for image information and script record/playback control, the 
current zoom level of the active image (you may click on this to set a zoom level), and a hint area 
which shows brief descriptions of operations that you access through the menu or the palette 
windows.  

 
You may open several images in their own separate windows at one time. Each image window can be 
resized, positioned, minimized, or maximized. When the application initializes, then will be no active 
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image windows. You may open an image window using several methods within EzImage: standard file 
open dialog windows, the thumbnail browser, the image preview browser, or the image/path list editors.  
 
Regions and Floaters 
EzImage works with parts of an image using the concept of Regions and Floaters. Regions are selections 
of an image that do not contain any image data. They are outlines within an image that appear as 
animated black and white dashed lines, and are commonly referred to as 'marching ants'. A region can be 
a simple rectangle or a shape of any complexity imaginable. Various tools allow you to create rectangular, 
elliptical, freehand, polygon, and other region types. When working with a region, no pixel information is 
altered. Many image adjustment and painting operations in EzImage will be restricted by the presence of 
a region. For example, applying a color fill on an image with a region will only have the region area 
affected. 
 
A Region Selection: 
 

 
 
Floaters represent a second image layer which rests on top of the normal background image. A floater 
can be created by any of the following methods:  
 

Pasting an image from the Windows clipboard. 
Dragging a piece of an image using the Move Selection tool. 
Dragging a piece of one image on top of another image. 
Loading a floating image from a file. 
Creating a floating image from the gray level pixel data in an alpha channel. 
The Text Tool creates text as a floating image by default. 
The Shape Tool creates the shapes as floating images.  

 
Floaters can be placed onto the clipboard or saved to a file using a special format. Once a floater is 
active, you are free to drag it around the background image or perform most types of image processing 
operations on it (you may NOT apply a painting tool to a floating image). Modifying a floating image does 
not affect the underlying background image while it is active.  
 
While a floating image is active, there are a few things that you can't do:  
 

Save the image to a standard file format (you can only save the image as a Work Space file if a 
floater is active). 
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Resize, rotate, or perform any type of size adjustment to an image. The shear, rotate, and resize 
options apply to the floater if you choose to apply one of those methods. 

 
Use any of the image painting tools.  

 
There are 3 methods by which to blend a floater with the background image:  
 

To paste a floater into the background image, use the Paste option in the Floater menu. The floater 
will be deleted after you paste it.  

 
To paste a floater without deleting it, choose the Stamp option.  

 
To blend a floater with an image using an alpha channel gray mask, create a gray level mask in a 
RGBA format image's alpha channel, and choose the Alpha Blend option from the Floater menu.  

 
The blend, opacity, and inversion options available in the Move Selection tool control how to blend the 
pixel colors of the floating image with those of the background image.  
 
A Floating Image Selection: 
 

 
 
 
Online Help Systems 
 
EzImage contains online help in two formats: Popup help and topic level help. Popup help provides a very 
brief description of an EzImage action. The help is at the individual control level, and is accessed by right 
clicking with the mouse on any control. For example, the New Image command has several buttons, 
dropdown lists, and other controls present in its dialog window. Right click on any control to see a popup 
help description. Note that popup help does not work on text input fields (you must click on the text label 
associated with the input field to see the help message).  
 
For any window in EzImage that contains a menu bar across the top, you will find something named 
Menu Help Mode under the Help menu option. When you choose menu help mode, the entire menu bar 
becomes popup help-enabled. By selecting any menu option, a popup help message will appear instead 
of the related action being performed. To disable menu help mode, simply select it a second time from the 
Help menu.  
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Topic-based help is accessible by pressing the F1 key from any window in EzImage. From the main view 
only, the F1 help key will show the help topic index file, from which you can navigate to locate specific 
topics. For all other windows, pressing F1 will bring up a help topic that is specific to the window only.  
 
Setting Basic Application Preferences 
Press F2 or choose Preferences from the Help menu. The preferences are arranged in a tab sheet 
ordered by category. While some of these tabs relate to specific areas of EzImage (i.e. the thumbnail 
database system), several items in Options I and Options II should be configured based on how you wish 
to use the application.  
 
OPTIONS I 
Paint Dithering: The dithering setting is used for when you have a display of 256 colors. Images that 
contain more that 256 colors will be dithered according to this setting. EzImage was designed to work 
with video displays with more than 256 simultaneous colors. Although you can run the application in 256-
color mode, the display quality, painting, and image processing effects will be severely degraded.  
 
Paint Scaling: This option controls the image quality when the magnification level is less than 100%. The 
nearest neighbor option is the default, chosen for speed.  
 
Window Background Color: This color is placed as a border around any image that is smaller than the 
window it is contained in.  
 
Preview Browser Mode: This option allows you to replace the standard open file dialog window with the 
EzImage Preview Browser. The preview browser provides a more flexible way to open image files with full 
preview capabilities.  
 
Mouse Smart Move: Check this option to force the mouse cursor to automatically move to be positioned 
over a specific button or control on most dialog windows in EzImage. This feature will not work on dialog 
windows that are not part of EzImage, such as a printer setup dialog.  
 
Auto-naming Duplicate Images: When creating duplicate images from all or part of another image, this 
option dictates if you will be prompted to provide an image name or if EzImage will choose one for you.  
 
Tooltip Colors and Font: The level one popup help uses windows very similar to Windows tooltips. These 
windows have a background and text color/font that can be adjusted.  
 
OPTIONS II 
File Compression Options: When resaving files (as opposed to saving images as new files), you may 
have be using a format that has a default compression format, which can include JPEG, Portable Network 
Graphics, and FlashPix. Since a resave option does not prompt you for compression settings at the time 
the file is written, the settings in the general preferences determine what level and type of compression to 
use.  
 
Gray Scale Masks: Gray scale masks apply to floaters in RGB and gray scale images. Floaters are parts 
of the same image (or another image) that you drag around within the image window. Since they do no 
disturb the pixel data of the underlying image until you perform a paste operation, they will 'float' over the 
background image. EzImage does not use the layering system you see with some of the high-end image 
processing applications. You may think of a floater as a 1-layer system. A floater is always a rectangular 
piece of an image. A mask is used to define the shape of a floater, allowing it to have any type of irregular 
shape. Gray scale masks provide for special transformation effects, specifically the ability to rotate and 
resize floaters. Unless you have a need to perform these two operations on a floating image, you can 
save memory and improve the rendering speed by leaving this option checked.  
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Showing Outlines with Large Floaters: If you have a slow system or one with limited free system memory, 
you may wish to adjust this value. Large floaters that contain several million bytes of pixel information can 
be quite slow to drag around the image window, especially when combined with opacity and blend 
modes. This value defines a cutoff point for a floater size. If the floater is over this pixel memory size, it 
will be rendered with a simple rectangular outline when dragging across the background image.  
 
THUMBNAILS: This tab defines some basic settings for the thumbnail database system.  
 
BROWSE: This tab contains options for general image browsing. Many operations display images in a full 
screen preview mode, or in part of a dialog window in two sizes: mini-preview and partial window.  
 
File Filters: The Browse tab also contains a button to configure which image files you wish to see when 
using the various browsing methods available in EzImage. By default, all supported file formats will be 
visible.  
 
SLIDE SHOWS: This tab defines basic options for the slideshow playback system.  
 
PHOTO CD: This tab controls how to load Kodak Photo CD images, which is a format that can contain 
multiple images of varying width and height. There are many browsing methods within EzImage that can 
access this file format, and each one has its own choice of image size to load as the default.  
 
Keyboard Shortcuts and The Mouse 
All options available in the EzImage main menu can have a custom keyboard shortcut assignment. The 
shortcut settings are defined as a named profile template, which you can view or modify using the options 
available in the application Help menu. Note that the two standard keyboard profiles may not be altered - 
you edit keyboard shortcuts by saving an existing profile under a new name, which can then be modified.  
 
There are other dialog windows in EzImage that contain menus with keyboard shortcuts. These may not 
be modified.  
 
There are keyboard shortcuts that are specific to the image editing process, which can't be assigned to a 
menu option. This would be the set of 4 cursor keys. The cursor keys, in combination with SHIFT, CTRL, 
and ALT, are used as shortcuts for some of the image editing tools.  
 
Region Selections and Floaters: Cursor keys move the selection in one of four directions 1 pixel at a time.  
 
Image Grabber Tool: The cursor keys pan the image if scroll bars are present. Use SHIFT to pan one 
window at a time, or CTRL to pan to one of the four edges of the image.  
 
Measure Tool: The cursor keys will pan the image window if scroll bars are present. Holding down SHIFT 
while dragging measure lines constrains the lines to 45 degree angles. Holding down CTRL while clicking 
on the end points of a single measure line will add a second measure line.  
 
Cross Hair Tool: The cursor keys will pan the image window.  
 
Line Tool: The cursor keys will pan the image window. Hold down SHIFT to constrain lines to 45 degree 
angles. For the polyline mode, right click to render all lines up to but not including the current one.  
 
Polygon Selection Tool: The cursor keys will pan the image window. Hold down SHIFT to constrain the 
selection lines to 45 degree angles. Right click to cancel the polygon selection. Left click with CTRL held 
down to close the polygon and create the selection.  
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Shape Tool: The cursor keys will pan the image window.  
 
Rectangular and Elliptical Selections: The cursor keys will pan the image window. Hold down SHIFT to 
constrain the selection to a circle or square.  
 
For any selection tool with an active region selection ('marching ants outlines'): The cursor keys will move 
the selection one pixel at a time. If you hold down SHIFT with a cursor key, the selection will expand in 
one direction (rectangle) or uniformly (non-rectangular). If you hold down CTRL, the selection will contract 
by one pixel.  
 
Dragging Floating Selections: Hold down SHIFT to drag the floater vertically. Hold down CTRL to drag the 
floater horizontally.  
 
Creating Region Selections: Hold down CTRL to add to the existing region. Hold down ALT to subtract 
from the existing region. Hold down CTRL+ALT to create an intersection of the current region and the one 
you create. The selection tools contain options to lock these modes during region creation to avoid having 
to always use the shortcut keys.  
 
Palettes 
EzImage has six floating palette windows that appear within the main client area.  
 
Tools Palette: This window contains the basic set of image editing tools. You can right click on any of 
them to view a brief description of what they do. The bottom part of the palette contains controls for the 
foreground and background colors, used for painting and various image processing methods. When you 
choose a tool from this palette, it may have some specific settings that affect how it works. These settings 
will appear in the panel beneath the main menu.  
 
Brushes Palette: This window contains options for changing the brush for one of the painting tools. The 
thumbnail preview sample provides a visual reference to the current brush that is active. The title bar of 
the palette shows which tool the brush is assigned to. Click on the preview window or on the Brushes 
button to view the brush selector dialog. Hold down SHIFT while clicking on the preview window to 
display the brush sample with the pixels inverted.  
 
Information PaletteIDH_P_INFO: This window shows the current mouse cursor position, region selection, 
floating image selection, and pixel color information for the active image. The title bar of the palette 
contains the current dimension of the image. Click on the small right arrow button to change the display 
units for the coordinate and size values.  
 
Color Palette: This window contains color swatches which can be used for image editing and painting 
purposes. There are several default palette types, plus 3 specific ones that can vary:  
 

The user palette can contain up to 256 colors of your choosing. This palette can be edited, saved to 
file, and used in indexed color conversions. 

 
The image palette will only be enabled when the active image window is in an indexed color mode of 
8 bits or less. You can replace an image's color palette by loading a new one from file. 

 
The ICO/CUR palette is used when working with Windows Icon and Cursor format files. It is the 
palette that will be saved along with the icon or cursor pixel data when you use the Export option from 
the Tools menu.  
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Scripts Palette: This window contains the list of script files for a Set group. A Set is a group of related 
script files that are all stored in a common file folder. The palette will only show scripts for one Set at a 
time. Scripts represent a sequence of actions that are creating using the recording system available 
within EzImage. To play back a script file, you can simply click on the labeled buttons in the palette.  
 
Nudge Palette: This palette is used for moving regions and floaters by an arbitrary number of pixels in any 
of 8 directions. It can also be used to resize a region selection by expanding or contracting.  
 
Thumbnail Database System 
EzImage allows you to store small thumbnail representations of your images into a database. This 
database can then be modified or viewed using a flexible browsing system. The thumbnail system 
provides many features such as:  
 

Images can be stored in multiple formats, depending on your decision to maintain thumbnail image 
quality or minimize thumbnail database size. Images can be stored in RGB, Indexed Color, or JPEG 
low/high quality formats. You can mix and match formats at any time. 

 
Thumbnail images can use any size from 50 by 50 to 200 by 200 pixels. You are free to mix multiple 
thumbnail sizes in the same database. 

 
You can have as many database files as you wish, although only one may be open at a time. 

 
Security and encryption can be applied to prevent unauthorized persons from viewing your database. 

 
Comments allow you to add descriptions to your images. 

 
EzImage contains a complete set of maintenance and repair options for the thumbnail database. An 
export feature can be used to generate a text-based listing of your database.  

 
Slide Show System 
Slide shows can be created from your images and played back using either a full screen or windowed 
mode. The slide show system is based on script files, which provide for more options than a simple list of 
image files:  

Scripts allow for custom image adjustments and playback options. 
 

You can associate text descriptions with images that will appear in the slide show play back window. 
 

You can link your thumbnail database images into a slide show script, and display the thumbnail 
comment text along with the images. 

 
Slide shows have both an automated mode that can be protected with a password, and a manual 
mode that has script adjustment shortcut keys. This allows you to modify a script file while it is 
playing. 

 
A bookmark feature allows you to tag specific images in a slideshow for browsing using the Image 
List Editor.  

 
Image Lists and Path Lists 
Image lists represent a flexible method to collect and store references to your image files. The lists are 
created and maintained using various browsing options and the image list editor. Image lists can be used 
to easily collect files to be used with the File Conversion Tool.  
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Path lists are similar to an image list, except that the list contains only a set of path name references. A 
path list can be used with the File Conversion Tool or used as a means to save links to your favorite 
image paths. The path list editor can be used as another method by which you can browse and open 
image files.  
 
File Conversion Tool 
The file conversion tool provides a method to apply several types of image adjustments and file format 
changes against a set of image files in one step. The set of files is created from one of several source 
types, including single folders, folder trees, image lists, or path lists. The conversion method always 
creates a copy of the original image file in another folder path on your system, with the exception of in-
place file renaming, which is a method to rename files without performing a conversion job.  
 
Scripts 
Script files are plain text files that contain a sequence of commands that are available within EzImage. 
The script file is not based on a programming language, and has no type of structure that requires you to 
learn how to write them. Scripts are created through a process of recording actions in a specific order. An 
example of a script would be one that corrects the orientation of a scanned image and trims away the 
background color. You can record an Edge Deskew command followed by an Auto Trim command and 
assign that to a script file.  
 
Selection Separations, Edge Deskew, and Auto-trim 
Selection separation is a process by which distinct image areas are isolated into new images, either 
saved as image windows in the main EzImage view, or as files on disk. The isolation is based on 
contrasting pixel colors between a background color and all other colors that would make up the 
individual image areas. This process is ideally suited for scanned images where you place several small 
documents on the scanner glass at the same time. Selection separations will not work with images that 
have no distinguishable background color, such as a single border-less photograph.  
 
The deskew tool is used to correct the orientation of rectangular images by applied a clockwise or 
counter-clockwise rotation. It is a common problem when scanning images (especially multiple small 
images at one time) to place the documents on the scanning glass and not have them line up at 90° 
angles. The deskew process looks at the color contrast levels between a common background color and 
edges of valid image area to determine how to rotate the image to align edges to be as close to vertical 
and horizontal as possible. When used with along with the Selection Separation and Auto Trim tools, you 
can easily create separate images from multiple-document scans.  
 
The auto-trim tool is used to eliminate borders containing background color information from an image. 
Trimming an image involves examination of the edge colors, and working inwards toward the center until 
a pixel colors are detected that are sufficiently different from the background color. A noise elimination 
option is available that can be used to ignore small random areas of color, such as dust on the scanning 
glass, or scratches and imperfections in the image.  
 
Compression Tuning 
This tool provides a 'before and after' system to help you decide on how to set the compression levels for 
image file formats that use lossy-based methods, including JPEG, Portable Network Graphics, and 
FlashPix. The compression tuning tool will visually show the quality of the image after it has been 
compressed, along with the compression ratio. You can then apply these settings to the various areas in 
EzImage that generate these file formats, such as batch file scanning, file conversions, and general file 
saves.  
 
Image Capture Tool 
This tool allows you to capture parts of your screen display. You can capture menus, windows, cursors, 
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screen areas (using a drag-select method), or controls such as buttons, checkboxes, and edit fields. 
Captured images are dropped directly into EzImage as new windows.  
 
Batch File Scanning 
This tool allows you to capture multiple images from your scanner directly to file, using a format of your 
choice. The single scanning process will capture one image at a time from your scanner directly to an 
image window in the application. The software provided with your scanner will be used to acquire the 
images. Note that EzImage does not support capture of 48/64-bit color or 16-bit gray scale images. 
 
 
Top 
 
 

 
 
 

Stretch Intensity 
 
This method increases the contrast in a bitmap by centering, maximizing, and proportioning the range of 
intensity values. 
 
Before Stretch Intensity: 
 

 
 
After Stretch Intensity: 
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Related topics: 
 
Levels 
Brightness and Contrast 
Hue and Saturation 
Color Balance 
Channel Mixer 
Channel Adjustment 
Equalization 
Image Inversion 
 

 
Top 
 
 

 
 
 

Creating Script Files 
 
Slide show scripts are simply a list of image files grouped by path name. The scripting aspect of this list is 
purely an optional step, which involves making additional property changes to individual images in the 
slide show. The steps taken to create a slide show are always done in the same sequence. 
 
General Settings 
Define the general properties for the script itself. This will affect all images and the way they are played 
back in the slide show image window. The slide show properties can be found as tab 5 in the system 
general preferences (see related topics below). The general properties take effect when you add the first 
image to a blank script. If you wish to change preferences for a script after the first image has been 
added, you must do so from the slide show script editor. Changing the general application preferences 
outside of the editor only affects the properties for newly created slide show scripts. 
 
General settings include: 
 

Font type and color and the window background color 
Path and file information 
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Shuffle mode 
Window type 
Error control 
Screen saver control 
Comment display type 
Passwords 
Time delays 
Cycling mode 
Image display quality 

 
Adding Images 
You may add images to a slide show using any of the following methods: 
 

Use the Add to Slideshow option from the thumbnail browser or catalog browser. 
 

Use the Add to Slideshow option from the image preview browser. 
 

Use the Add to Slideshow option from the image list editor. 
 

Use any of the image addition options in the slide show script editor, including individual files from a 
folder, a single folder, or a folder tree. 

 
Editing the Script 
This last step is optional, but can be used to adjust several additional options for specific images in the 
slide show, including: 
 

Image rotation 
Image flipping 
Constrained image scaling 
Image zoom mode (normal or bicubic) 
Custom time delays 
Gray scale conversion 
Vertical repositioning 
Gamma adjustment 
Text associations 

 
These optional are all accessible from within the slide show script editor. 
 
Saving and Loading Script Files 
You can use the slide show editor to load and save script files. The Browse->Slideshow->Open option 
in the application menu will also load a script file, replacing the current one in memory. The script will then 
be played back once the file has been loaded. 
 
Related topics: 
 
Slide Show System 
Play Back System 
Slide Show Script Editor 
Image Attributes 
Text Associations 
General Preferences 
Browsing Slide Show Images 
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Slide Shows 
 
The slide show system in EzImage is based on scripts that reside in memory. Building a script is a fairly 
simple process: 
 

Define the general preferences to configure the basic properties that affect all images in the script. 
 

Add images to the script using the script editor, thumbnail, or preview browsers. 
 

Use the script editor to make any script property changes to individual images. You may also modify 
scripts directly from the play back window when using manual stepping mode. 

 
Slide shows display images using either a full screen mode (the entire visible screen area on your monitor 
will be used for the slide show display) or partial screen mode, placing each image in a sizable window. 
 
The slide show system offers several convenient features: 
 

Double-buffered system to ensure that while one image is being displayed, the image that follows will 
be loading into a separate off-screen area. This ensures minimal delays between the display of 
images. 

 
Scaling and basic transformation options to define how large the images will appear within the slide 
show window area. 

 
Gamma correction for enhancing the brightness of dark images without making changes to your 
monitor settings or the image files themselves. 

 
Random shuffle mode. 

 
User-defined time delays. 

 
Optional display of file and path name information. 

 
Display of thumbnail comments. 

 
Text associations to display multiple lines of information about each image file. 

 
Password feature to disable the control keys available in play back mode. 

 
Customizable colors and font information for labels and text. 

 
Book marking system allows you to tag individual images within a slide show during play back. These 
images can then be manipulated as a list using the Image List editor. 
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Slide show scripts can be stored in files that can be played back using options within the Browse 
application menu, or from the slide show editor. 
 
Click on any of the following links for specific help topics related to the slide show system: 
 
Creating Script Files 
Play Back System 
Slide Show Script Editor 
Image Attributes 
Text Associations 
General Preferences 
Browsing Slide Show Images 
 
Top 
 
 

 
 
 

Playing a Slide Show 
 
Once you have added images to a slide show, you can play them back in sequence using full screen or 
windowed mode. Choose Browse->Slideshow->Play from the application menu to play the current 
slideshow script in memory, or choose the Open option from the same submenu to open a script file from 
disk. Once loaded, the script will begin play back. 
 
You can also choose to play a script file from the slide show editor. 
 
If you are using windowed mode, the images will appear in a resizable window that you can drag around 
on the screen. The title bar will indicate the path and file name of the current image. 
 
For full screen mode, the complete display area will be used for the slide show window, including the area 
used by the Windows task bar. 
 
There are two automatic cycling modes that can be used for play back. One step mode will display each 
image one time, then stop play back. Continuous mode will display images repeatedly until you manually 
stop play back. A manual stepping mode allows you to view each image, make any type of script 
correction or apply a bookmark, and continue to the next image in the list. 
 
If you are using a screen saver, you may wish to disable it during playback. EzImage has the option to 
temporarily suspend your screen saver. When the play back is stopped, the screen saver will be 
reactivated. 
 
During a timed play back session, there are only a limited number of options for interacting with the slide 
show. The following summarizes all of the keys that can be used to control the play back session. Many 
of these options only apply when the slide show is in manual stepping mode. 
 

If a password is applied to a slide show, a left click with the mouse button will close the play back 
window, provided the correct password is entered. 

 
With no password, a left click will toggle the display of file/path names for the each image. 
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A right click will close the play back window. 
 

Press SPACE to close the slide show only if a password is in effect. 
 

Press Pause to stop play back without closing the window. Press Pause a second time to resume 
play back. 

 
Press SPACE or Escape to place an automated timed slide show into manual stepping mode. 

 
Press Escape to close a slide show that is in manual step mode. 

 
Use Page Down, right or down cursor keys to move to the next image. 

 
Use Page Up, left or up cursor keys to move to the previous image. 

 
Press F1 to access the extended attributes for the current image only. 

 
Press F2 to access the text association editor for the current image only. 

 
Press A to bookmark all images. 

 
Press U to remove bookmarks from all images. 

 
Press M or SPACE to mark/unmark the current image. 

 
Press Home to view the first image in the list (affected by random shuffle). 

 
Press End to view the last image in the list (affected by random shuffle). 

 
When you bookmark images during slide show play back, you can view the marked list using the 
Browse->Slide Show->Marked Images option from the application menu. 
 
Related topics: 
 
Slide Show System 
Creating Script Files 
Slide Show Script Editor 
Image Attributes 
Text Associations 
General Preferences 
Browsing Slide Show Images 
 
 
Top 
 
 

 
 
 

  Rectangular/Elliptical Selection Tool 
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Choose the first button in the options panel to create a rectangular region selection. 
 
Choose the second button to create an elliptical selection. 
 
Creating a Normal Selection 
Click with the left mouse button to set a corner point for the region. Drag in any direction while holding 
down the mouse button to set the dimensions of the region. Release the mouse button when you have 
the selection at the desired size. 
 
Creating Compound Selections 
The 4 buttons in the options panel to the right of the rectangle and ellipse shape selection buttons are 
used to create complex regions: 
 

Click on the first button to lock the selection creation mode so that any new selection will erase the 
current selection once the mouse button is released. The exception to this rule is if you are holding 
down CTRL, ALT, or a combination of the two, which temporarily overrides the normal mode. 

 
Click on the second button to lock the selection mode so that the new region selection will be added 
to the current selection if one is present. This allows you avoid having to always hold down the CTRL 
key if you are doing many additions. 

 
Click on the third button to lock the selection mode so that the new region will be subtracted from the 
current selection if one is present. 

 
Click on fourth button to lock the selection mode so that the new region will be combined with the 
existing region such that only the intersecting areas will generate the resulting region. 

 
The following keyboard shortcuts are available when creating region selections, which do not require you 
to lock the selection mode: 
 

Hold down CTRL to add to an existing region selection 
Hold down ALT to subtract from an existing selection 
Hold down CTRL+ALT to create an intersection with the existing selection 
Hold down SHIFT to constrain the selection to a 1:1 ratio. 

 
Nudge Palette 
Click on the nudge button to show/hide the palette window. The nudge palette allows you to move and 
resize region selections. 
 
Cropping Shortcut 
Click on the crop button in the options panel to remove all pixel information that is not contained within the 
bounding area that makes up the current region selection. The selection does not have to be rectangular. 
 
Hold down SHIFT while clicking on this button to crop to a new image. If the region is non-rectangular 
then the areas outside of the selection will be filled with the current background color. 
 
Selection Modes 
Region selections are created using a bounding box that will contain the region itself. The bounding box is 
created in one of four ways using the dropdown list: 
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Normal Mode: Drag-select a rectangular area and when you release the mouse button, the region will 
occupy the area equal to the selection size. Hold down SHIFT while dragging to constrain the selection to 
a square. 
 
Constrained Aspect: Same as normal mode, except that you specify an aspect ratio for the bounding 
box. The ratio values can use fractional numbers. 
 
Fixed Size: The bounding box will be generated for you using the width and height you specify. You must 
also specify the anchor corner for the bounding box. 
 
Cross Hair Mode: The Cross Hair tool can be used to create a region that is equal in size to the 
bounding area between the corner points of two cross hair lines. The selection tools can then use this 
bounding area to create a precise region. 
 
If you are using a single cross hair line, the region created will be equal to the image width or height and 
one pixel in depth. 
 
Anchor Points for Fixed Mode 
With fixed size selection mode, you don’t use the drag-select method to generate the bounding box. It will 
be created at the position where you click with the mouse. Since the bounding box has 4 corners, you 
must decide on which corner point is the anchor point. For example, if you use the bottom right corner, 
then the bounding box will extend to the left and upwards from the current mouse cursor position. 
 
Related topics: 
 
Creating Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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  Freehand/Polygon Selection Tool 
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Choose the first button in the options panel to create a freehand region selection. 
 
Choose the second button to create a polygon selection. 
 
Creating a Normal Freehand Selection 
Click with the left mouse button and draw the outline of the region. Release the mouse button to close the 
region. This will result in a straight line being drawn from the current mouse cursor position to the initial 
draw point. 
 
Creating a Normal Polygon Selection 
Click with the left mouse button to set the first point in the polygon. Release the mouse button. This will 
create a rubber band line from this point to anywhere on the image where you move the mouse. To 
create a new vertex point for the polygon, click and release the mouse button. Repeat this until you have 
all the points you need for the polygon, then do one of the following to close the shape: 
 

Mouse the mouse cursor within a short distance of the first point in the selection and click. The cursor 
will change to indicate that you are close to the first point. 

 
Hold down the CTRL key and click anywhere. 

 
To cancel the selection, right click at any time. 
 
Creating Compound Selections 
The 4 buttons in the options panel to the right of the freehand and polygon shape selection buttons are 
used to create complex regions: 
 

Click on the first button to lock the selection creation mode so that any new selection will erase the 
current selection once the mouse button is released. The exception to this rule is if you are holding 
down CTRL, ALT, or a combination of the two, which temporarily overrides the normal mode. 

 
Click on the second button to lock the selection mode so that the new region selection will be added 
to the current selection if one is present. This allows you avoid having to always hold down the CTRL 
key if you are doing many additions. 

 
Click on the third button to lock the selection mode so that the new region will be subtracted from the 
current selection if one is present. 

 
Click on fourth button to lock the selection mode so that the new region will be combined with the 
existing region such that only the intersecting areas will generate the resulting region. 

 
The following keyboard shortcuts are available when creating region selections, which do not require you 
to lock the selection mode: 
 

Hold down CTRL to add to an existing region selection 
Hold down ALT to subtract from an existing selection 
Hold down CTRL+ALT to create an intersection with the existing selection 
Hold down SHIFT to constrain the polygon selection lines to 45° angles. 

 
Nudge Palette 
Click on the nudge button to show/hide the palette window. The nudge palette allows you to move and 
resize region selections. 
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Related topics: 
 
Creating Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
 

 
Top 
 
 

 
 
 

  Magic Wand Tool 
 

 
 
The Magic Wand tool measures differences in image pixel information between the pixel that you click on 
with the mouse and the surrounding pixels in a flood fill-type of operation. The result of the magic wand 
click is a selection that can be combined with or replace an existing region. Low tolerance values result in 
small selections, high tolerance values can result in complete image selection. 
 
Creating Compound Selections 
The 3 buttons to the left in the options panel are used to create complex regions: 
 

Click on the first button to lock the selection creation mode so that any new selection will erase the 
current selection once the mouse button is released. The exception to this rule is if you are holding 
down CTRL, ALT, or a combination of the two, which temporarily overrides the normal mode. 

 
Click on the second button to lock the selection mode so that the new region selection will be added 
to the current selection if one is present. This allows you avoid having to always hold down the CTRL 
key if you are doing many additions. 

 
Click on the third button to lock the selection mode so that the new region will be subtracted from the 
current selection if one is present. 

 
The following keyboard shortcuts are available when creating region selections, which do not require you 
to lock the selection mode: 
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Hold down CTRL to add to an existing region selection 
Hold down ALT to subtract from an existing selection 
Hold down CTRL+ALT to create an intersection with the existing selection 

 
Nudge Palette 
Click on the nudge button to show/hide the palette window. The nudge palette allows you to move and 
resize region selections. 
 
Tolerance Setting 
The Magic Wand tool will select regions based on how close the color information matches the pixel you 
click on using a tolerance level. A lower tolerance level will select a smaller region, while a larger 
tolerance level will select significantly more pixel data, sometimes the entire active image. 
 
Related topics: 
 
Creating Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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  Move Tool 
 

 
 
The move tool is designed to work with floating image selections only. Region selections are moved using 
the various region creation tools, such as rectangle, ellipse, or polygon. When you move the mouse 
cursor over a region using one of those tools, the cursor changes to reflect a region move. 
 
When using the move tool, the cursor reflects a floating image move. If you have not created a floater in 
the active image, then one will be created from the existing region selection. If there is no region 
selection, then the move tool will have no effect. 
 
Floating images can also be created with any of the following methods: 
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Pasting an image from the Windows clipboard. 
Dragging a floater from one image to another one. 
Loading a floating image from a file. 
Creating a floating image from the gray level pixel data in an alpha channel. 
The Text Tool creates text as a floating image by default. 
The Shape Tool creates the shapes as floating images.  
Choose Floater->Make from Selection from the application menu. 

 
Setting a Blend Mode 
Floating images can be blended with the current image using a variety of blend modes. Refer to this link 
for more details on how the various blend modes work. 
 
Nudge Palette 
Click on the nudge button in the options panel to toggle display of the nudge palette. This palette provides 
a simple directional keypad for moving and/or altering region and floating image selections. In addition to 
the nudge palette, the keyboard can also be used for moving and/or sizing regions and floating 
selections. 
 
Pasting a Floating Selection 
Click on the checkbox icon in the options panel or choose Floater->Paste Floater from the menu. The 
current floating image, shape, or text selection will be pasted into the active image at the current mouse 
position. Once pasted, the floating image will no longer be available to be used, unless you saved a copy 
to file or to the clipboard. If you need to place multiple copies of the same floating image over and over, 
use the Floater->Stamp Floater menu option. 
 
Shortcut hint: You can right click inside the bounding area of a floating image to paste it. The mouse 
cursor will reflect whether you are inside or outside the bounding area of the floater. 
 
Canceling a Floater 
Click on the “X” icon in the optional panel to cancel a floater. This will delete the current floating image, 
text, or shape without pasting. You can not get this floater back unless you saved a copy to file or to the 
clipboard.  
 
Shortcut hint: You can right click outside the bounding area of a floating image to cancel it. 
 
Move/Copy Mode 
If the Move option is checked, then any floating image you create from a region selection will result in the 
area bounded by the region being ‘lifted’ from the image. The area that once held the active image data 
will be replaced with the current background color. 
 
With this option unchecked, a floating image will be created from the region selection, but the original 
image will remain unaltered. 
 
Opacity Level 
Click in the text-input field or drag the slider to set an opacity level for the floating image, text, or shape. 
Opacity values range from 1 to 100 percent. A value of 50% would combine 50% of the original image 
pixel data and 50% of the floater pixel data. 
 
Invert 
Check this option to invert the pixel data of the floating selection. 
 
Feathering 
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If you enter a value greater than zero, then a feathering effect is added to floating image when it is 
created (feathering does not apply to an existing floating image, only when it is created). Values can 
range from 1 to 32. Note that the feathering is not an antialiasing effect – it is an edge blur effect. 
Feathering large region selections can take a significant amount of time. You can use alpha channel 
rendering techniques to create similar effects with more flexibility than this option. 
 
Related topics: 
 
Text Tool 
Shape Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 

 
Top 
 
 

 
 
 

  Image Grabber Tool 
 
This tool does not contain any additional options. 
 
The image grabber tool allows you to scroll an image around using a simple click and drag method. 
Select this tool, click anywhere on the image and hold down the left mouse button while dragging to scroll 
the image (At least one scroll bar must be present in the window for the grab tool to function). 
 
If you click and drag using the right mouse button then the panning rate will be 10 times faster than 
normal. 
 
The grabber tool can use keyboard shortcuts to scroll the image window as well, using the cursor keys. 
 
Hold down the SHIFT key while using the cursor keys to scroll the image one-half the visible window 
area. 
 
Hold down the CTRL key to scroll the image to one of its four edges. 
 

 
Top 
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  Magnify (Zoom) Tool 
 

 
 
Zoom In Mode 
Click on the first button in the options panel to set the tool for zoom in mode. Left click anywhere on the 
image and release the button to zoom in one level of magnification. There are several fixed levels in the 
range, using the following percentages: 
 

5 
6.25 
8.33 
12.5 
16.7 
25 
33.3 
50 
66.7 
100 
200 
300 
400 
500 
600 
800 
1200 
1600 

 
When zooming an image, the window area will be adjusted so that it is always centered around the click 
point. 
 
Zoom with Drag Select 
Left click and hold down the mouse button while dragging to create a rectangular rubber band selection. 
When you release the mouse button, the image will be zoomed into the selected area. In most cases, the 
image window and the selection rectangle will not have the same aspect ratio. This will result in some 
extra image data to be included in the zoomed in area. 
 
Zooming Out 
If you right click with the mouse button, the image will be zoomed out one level of magnification. 
 
Reversing the Zoom Effect 
Hold down the SHIFT key to reverse the zoom in/zoom out actions. With SHIFT held down a left click = 
zoom out and a right click = zoom in. 
 
Zoom Out Mode 
The second button in the options panel locks the tool into zoom out mode. This effectively reverses the 
left and right mouse buttons, while keeping all other shortcut-related actions the same. 
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Current Zoom Level 
The current zoom level can be changed by clicking in the text edit field and entering any number between 
5 and 1600%. 
 
Window to Image 
This is a shortcut button to the similar option in the View menu. This option will attempt to fit the window 
to the current image without the need for scroll bars. This operation will fail if the resulting window is 
below a predetermined minimum area size, or if the window would exceed the dimensions of one full 
screen at the current display resolution. 
 
Image to Window 
This is also a menu shortcut. This option will adjust the magnification (zoom) level of an image so that it 
will fit completely within the current window dimensions. Once an image has been fit to the window, the 
window itself will be adjusted to wrap around the image according to its aspect ratio so that no 
background border areas will remain. An image can not be at less than 5% or more than 1600% 
magnification. If an adjustment would cause a level outside this range, the window will be adjusted 
accordingly. 
 
Actual Size 
This is also a menu shortcut. This option will change the magnification level to 100% scaling (actual pixel 
size). If you have the preferences option for window auto-fit at 100% zoom checked, then the window will 
be adjusted to fit the image without scrollbars, if possible. 
 
Setting Zoom Levels from the Status Bar 
You can click on the zoom level pane in the status bar at the bottom of the application main view for a 
popup menu with options that mirror those found in the View menu, related to magnification. 
 
Menu Options 
There are several options related to image magnification that are independent of the zoom tool. These 
can be found in View menu. The menu shortcuts will work with any other image tool. 
 
Keyboard Shortcuts 
The zoom tool has the same shortcut keys as the Image Grabber tool, used for panning an image that is 
larger than the window. 
 

Use the cursor keys to scroll the image one pixel at a time. 
 

Hold down the SHIFT key while using the cursor keys to scroll the image one-half the visible window 
area. 

 
Hold down the CTRL key to scroll the image to one of its four edges. 

 
 
Top 
 
 

 
 
 

  Text Tool 
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This tool allows you to place one or more lines of text on an image as a floating selection. To create a text 
selection, choose the text tool from the palette, and click anywhere on the image to set the anchor point 
for the top left pixel. All text will be rendered to the left and downward from that point. 
 
When you click to set the placement point, you will be provided with a dialog window to enter text and 
define the various attributes: 
 

 
 
Setting the Font 
Click on the Font button to choose the font that you want to use for the text. The size is defined by the 
value in the Font Size field, the color using the Text Color swatch, and bold and italic attributes using the 
corresponding checkbox options. 
 
Line Spacing 
Line spacing adjusts the gap between each line of text when entering more than one line of text. Negative 
values will decrease the spacing between lines, and positive values will increase it. Spacing can range 
between –50 and +500 percent, with 0 being the default value. 
 
Alignment 
Check the Center or Right options to change the alignment when entering multiple lines of text. You will 
not see the alignment in effect when the Preview option is checked. This is a horizontal text alignment 
property. 
 
Font Size: Pixels and Points 
The font size can be expressed in terms of pixels or points. The Points option is based on screen display 
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points, which closely match the size in the text entry box when the Preview option is checked. Note that 
the pixel and point values take into account various font characteristics. Therefore the font pixel size does 
not necessarily result in text that is equal in height to the value you enter in the Font Size field. Note that 
if your screen display’s font pixel density is 72 pixels per inch, the font size in points and pixels will closely 
match one another. 
 
Antialised Text 
Check this option to draw text using a smoothing effect. The processing time will be significantly longer 
but will generally result in more natural looking text. This option will not work on indexed color images. 
 
Preview Option 
Check this option to show the text in this dialog window using a close approximation of the size it will be 
on the image itself. 
 
Recalling Prior Text Settings 
When you click on OK to place text as a floating selection on the image, the current properties are stored 
away for future reference. You can recall the previous text placement attributes by clicking on this button. 
 
Estimating Pixel Dimensions 
The Check option is used to provide an approximate estimation of the pixel dimensions of the text lines 
you enter without displaying them on the image. 
 
Changing Text Attributes 
When you place a text as a floating image, you can perform various transformations and other image 
adjustments. Until you decide to paste or render a floating text selection, you can adjust the properties 
using the text tool. Simply click anywhere on the image using the text tool, and the properties dialog will 
reappear. Note that if you performed any transformations or adjustments on the floating image, they will 
be lost. 
 
Once a text selection is placed on the image, the Move Tool will automatically be selected so that you can 
drag the text around for positioning. 
 
Related topics: 
 
Text Tool 
Shape Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 

 
Top 
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  Shape Tool 
 

 
 
Shapes are floating selections that are created using the same method as rectangular region selections 
(drag select an area, fixed size, constrained aspect, or cross hair mode). There are several types of 
shapes that can be generated, organized into categories accessible from the dropdown list in the options 
panel. 
 
Shape Types 
Shapes are grouped by one of the following basic types: 
 

Ellipse 
Rectangle 
Triangle 
Diamond 
Pentagon 
Hexagon 
Octagon 
Star 
Parallelogram 
Trapezoid 
Cross 
Diagonal Line 

 
Shape Subtypes 
For many of these shapes, there are variations that are accessible from the submenus. When you choose 
a basic type and a subtype, it will be set as the default in the dropdown list and abbreviated with a 
shortcut notation. For example a rounded rectangle based on shape width percentage is shown in the 
dropdown text field as: Rectangle-W%. 
 
Shape Options 
Most shapes have options that alter the basic geometry, accessible by clicking on the shape options 
buttons in the panel. For a description of each option for every shape type, refer to the reference at the 
end of this topic. 
 
Anti-Aliasing 
For gray scale, RGB, and RGBA image formats, you can enable antialiasing to improve the quality of 
certain shapes. Note that the rendering time and memory overhead will increase significantly when 
rendering an antialiased shape. Antialiased shapes are not available with indexed color images. Check 
the A.A. option to enable antialiased shapes. 
 
Border Width 
Most shapes can have a border width assigned to them. A border width greater than 0 creates an outline 
shape, with a transparent interior. As with non-outlined shapes, the color for the outline will be the current 
foreground color. If the border width does not apply to a specific shape type, or the border width is too 
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large to maintain the geometry of the shape in outline format, then the shape will be rendered as solid. 
 
Shortcut hint: Click on the ‘BW’ caption in the options panel to toggle between single pixel outline shapes 
and solid shapes. Outline shapes are not available for star shapes or any triangle shapes using concavity. 
 
Creating the Shape 
The shape is created using the same methods that you would for the rectangular region selections. 
 
Normal Mode: Drag-select a rectangular area and when you release the mouse button, the region will 
occupy the area equal to the selection size. Hold down SHIFT while dragging to constrain the selection to 
a square. 
 
Constrained Aspect: Same as normal mode, except that you specify an aspect ratio for the bounding 
box. The ratio values can use fractional numbers. 
 
Fixed Size: The bounding box will be generated for you using the width and height you specify. You must 
also specify the anchor corner for the bounding box. 
 
Cross Hair Mode: The Cross Hair tool can be used to create a shape that is equal in size to the 
bounding area between the corner points of two cross hair lines. The shape tool can then use this 
bounding area to create a precise size. 
 
Anchor Points for Fixed Mode 
With fixed size selection mode, you don’t use the drag-select method to generate the bounding box. It will 

be created at the position where you click with the mouse. Since the bounding box has 4 corners, you 
must decide on which corner point is the anchor point. For example, if you use the bottom right corner, 
then the bounding box will extend to the left and upwards from the current mouse cursor position. 
 
Auto-Creation from Existing Regions 
This is a general preferences option that is enabled by default. If this option is enabled, then the Shape 
tool will always create a new shape from the bounding area of any existing region selection in the image. 
 
Shapes are created as floating image selections. Once created, the Move tool is automatically selected, 
allowing you to set the opacity and blend modes for the floater, and position it within the background 
image. 
  
Last Shape Option 
This option is available from the Floater menu. The last shape option will generate a duplicate copy of the 
last floating shape that was created positioned in its original offset within the image. 
 
Setting the Color 
Shapes are always created using the current foreground color. To change the color of shape after it has 
been created, use the foreground color picker from the Tools palette. 
 
Rendering the Shape 
Until you choose the Floater->Render menu option, the shape is defined as a gray level mask, which can 
be given a color. Other than this, the shape has no image data. The render option will convert a shape 
floater into an image floater by creating an image layer on top of the mask that defines the shape. This 
image layer can be a single color or use the contents of the current image that the floater is positioned on. 
 
Shape Options 
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Rectangles: 
Squared Corners: A normal rectangle shape 
Rounded % of Width: The roundness of each corner defined by width 
Rounded % of Height: The roundness of each corner defined by height 
Rounded Separate %: The roundness is defined by both width and height 
 
The width and height represent a percentage of the overall shape width and height that is used to define 
the radius of the curves used to create rounded rectangles. 
 
Octagons: 
The octagon shape can be either regular or non-regular, with both top/bottom and left/right edge size 
ratios, and a single distribution for the side edges. 
 
Pentagons: 
The pentagon shape can be either regular (all sides are equal length) or irregular. For non-regular 
shapes, there is a distribution percentage for the side points, and a base ratio for the edge opposite the 
natural peak point for the shape. 
 
Diamonds: 
The diamond shape can have a distribution percentage of the two side points. A smaller distribution will 
move the side points higher. 
 
Triangles: 
The triangle shape has one of 8 basic types, along with a concavity percentage. This value is used to 
indent the base edge of the triangle at its midpoint. Outlines are not available with this shape for any 
concavity value other than 0%. 
 
Diagonal Lines: 
A diagonal line brush can be rendered in two directions, with a line thickness between 1 and 64 pixels. 
Line shapes do not use the outline parameter. For a size larger than 64 pixels, you can create a rectangle 
shape and perform a rotation on the shape floater to achieve the same effect. 
 
Trapezoids: 
A trapezoid can have one of four shape types, along with two percentage values. The size percentage 
defines the proportion of the smaller base edge to the overall shape size. The distribution percentage will 
shift the smaller edge towards one of the shape’s corners. 
 
Parallelograms: 
The parallelogram has four basic shape types, and a shear angle, which are applied to the side edges 
(horizontal shape) or top edges (vertical shape). The shear angle must fall between 0 and 45 degrees. 
The shape size itself may not allow angles as large as 45° since the width and height aspect ratio can 
prevent certain shear angles from working. 
 
Hexagons: 
The hexagon shape can be either regular (all sides are equal length) or irregular. For non-regular shapes, 
there is a distribution percentage for the side edges, and a base ratio for the size of the side edges 
relative to the height of the brush. 
 
Cross: 
The cross shape is defined by a horizontal and vertical “beam” that cross each other at the brush center 
at a perpendicular angle. The beam size for each one can be controlled as a percentage of the overall 
shape size. By using the link option, the height of the horizontal beam will be equal to the width of the 
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vertical beam. 
 
Related topics: 
 
Text Tool 
Move Tool 
Floaters from Regions 
Floaters from the Clipboard 
Floaters from the Alpha Channel 
Loading and Saving Floaters 
Rendering a Floater 
Cancel and Undo 
Cut, Copy, Paste and Stamp 
Selection Positioning 
Keyboard Shortcuts 
Floater Masks and Alpha Channels 
Alpha Blending with an Image 
 
 
Top 
 
 

 
 
 

  Pencil / Paintbrush / Eraser Tools 
 

 
 
These are the 3 basic painting tools in EzImage. Since these tools share a common set of options, they 
are grouped together under the one icon in the Tools palette. To choose the painting tool from the group, 
select one of the 3 buttons on the left side of the options panel. 
 

  Pencil Tool 
 
The Pencil tool will paint pixel data using only hard-edged brushes. All brushes are based on a gray scale 
mask, where white is pure application of the paint color, and black is no application of the paint color. 
Anything in between is painted using a blend of the image color and the brush color. For pencil brushes, 
the brush masks can not have any gray level data – it is either black or white. Therefore, the default brush 

set for the pencil tool only includes hard-edged brushes. The pencil tool is ideally suited for indexed color 
images, which do not allow the use of soft brushes with varying levels of opacity. 
 
Then pencil tool uses the current foreground color for painting. 
 

  Paintbrush Tool 
 
The Paintbrush tool is similar to the pencil tool except that it can use a brush with 256 levels of gray in its 
mask data. This allows a brush to have a softness effect, where the edges appear blurred due to the 
varying gray levels in the mask. The default brush set for the Paintbrush tool (and all other non-pencil 
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tools) uses varying levels of brush softness to create different paint stroke effects. 
 
Note: If you are painting to indexed color images, the brush set will revert to hard-edged brushes. Gray 
level brushes can only be used on RGB, RGBA, or gray scale images. 
 
Then paintbrush tool uses the current foreground color for painting. 
 

  Eraser Tool 
 
The Eraser tool is identical to the Paintbrush tool, except that the paint color used is the background 
color, not the foreground color. 
 
Blend Modes 
Most painting tools use a blend mode that determines how the paint color will be combined with the color 
of the image area that falls within the brush radius. The normal blend mode simply replaces the image 
color with the paint color. The amount by which this occurs depends on the softness of the brush and the 
opacity level. Refer to this link for more information on the various blend modes available. 
 
Blend modes to not work on indexed color images. 
 
Brush Gradients 
The Paintbrush, Pencil, and Line tools can all use a gradient brush for painting. The gradient brush alters 
the paint color and/or transparency of the brush while you are creating the brush stroke. The gradient 
brush settings are automatically turned off each time you start the application, and remain in effect until 
you close the application or turn them off in the brush gradient editor. 
 
Gradient brushes do not work on indexed color images. 
 
Refer to this link for instructions on how to set the brush gradient options. 
 
Opacity Level 
For most painting tools, you can set the opacity of the paint color that is applied to the image. 50% 
opacity will paint pixels with 50% of the paint color, which would be blended with 50% of the image color. 
 
Opacity does not apply to indexed color images. 
 
Block Mode 
Some of the painting tools have an option to enable Block Mode. In this mode, the current brush is 
replaced with a solid hard-edged rectangular brush equal in size to the core area of the current brush (the 
core area of a brush represents the area where the majority of paint color is applied to an image). 
 
Current Brush 
The current brush for a painting tool is shown in a small preview window in the Brushes palette: 
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The active tool for a brush is shown in the title bar of the palette window. 
 

The name of the brush is shown below the title bar. 
 

The brush preview is displayed below the brush name. 
 

The brush category ID, size, and magnification scale for the preview window is shown below this. 
 
Monochromatic and Gray Level Brush Files 
There are 2 brush files for each painting tool. There is no restriction on sharing brush files, so it is 
possible to use the same brush file for every painting tool. By default, EzImage assigns a separate gray-
level brush file for each painting tool. Gray-level brush files only apply to RGB and gray-scale images. A 
common brush file is assigned for all painting tools when working with indexed-color images. 
 
The process of switching brush files depending on the image and painting tool is automatic, and not 
something that you can control. If you switch from the Pencil tool to the Paintbrush tool, the brush file will 
change. If you have both an indexed-color and RGB image open in separate windows, switching between 
the two image windows will automatically change the brush files between monochromatic and gray level. 
You may not notice any change initially because all brush files use the same set of brush masks by 
default. If you modify the brush files, you will notice that only the file for the current painting tool will be 
affected. 
 
Locking the Brush Movement 
You can confine the brush movement for the pencil, eraser and paintbrush tools to horizontal or vertical 
movements using keyboard shortcuts. 
 

Hold down the SHIFT key to confine painting to a horizontal line. 
 

Hold down the CTRL key to confine painting to a vertical line. 
 
Make sure you release the mouse button before you release the CTRL or SHIFT keys, or you will end up 
drawing a connecting line between the current mouse cursor position and the confined paint line. 
 
Painting Speed and Accuracy 
Slow systems, limited available memory, brush size, and blend modes all affect the speed by which a 
painting tool can keep up with the mouse movement. You may find it necessary to move the mouse at a 
slower rate if any of these conditions affect the ability to render paint lines with smooth curves. 
 
Related topics: 
 
The Brushes Palette 
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Brush List Editor 
Brush Shape Editor 
Brush File Properies 
 

 
Top 
 
 

 
 
 

  Line Tool 
 

 
 
The line tool is used to paint one or more lines using a rubber band drawing style. By clicking once to set 
the starting point, you hold down the mouse button and drag to a second point. Release the mouse button 
and the line will be drawn between points using the current brush and foreground color. 
 
Constrained Angles 
Hold down the SHIFT key while drawing the connection lines to constrain them to 45° angles. 
 
Polyline Mode 
Check the Polyline option to draw multiple lines at one time. This method is quite similar to the polygon 
selection tool. Click and release the mouse button to set the first vertex point. Then move the mouse to 
the second point, click and release, move to the third point, and so on. To actually paint the lines, right 
click and all lines up to, but not including the last one, will be painted with the current foreground color. 
 
Polyline Cancel 
Right click while holding down the CTRL key to cancel all lines before they are painted. 
 
Brush Styles 
The line tool is similar to the paintbrush tool in that it can use a brush with 256 levels of gray in its mask 
data. This allows a brush to have a softness effect, where the edges appear blurred due to the varying 
gray levels in the mask. If you are painting on indexed color images, the brush set will revert to hard-
edged brushes. Gray level brushes can only be used on RGB, RGBA, or gray scale images. 
 
Blend Modes 
Most painting tools use a blend mode that determines how the paint color will be combined with the color 
of the image area that falls within the brush radius. The normal blend mode simply replaces the image 
color with the paint color. The amount by which this occurs depends on the softness of the brush and the 
opacity level. Refer to this link for more information on the various blend modes available. 
 
Blend modes to not work on indexed color images. 
 
Brush Gradients 
The Paintbrush, Pencil, and Line tools can all use a gradient brush for painting. The gradient brush alters 
the paint color and/or transparency of the brush while you are creating the brush stroke. The gradient 
brush settings are automatically turned off each time you start the application, and remain in effect until 
you close the application or turn them off in the brush gradient editor. 
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Gradient brushes do not work on indexed color images. 
 
Refer to this link for instructions on how to set the brush gradient options. 
 
Opacity Level 
For most painting tools, you can set the opacity of the paint color that is applied to the image. 50% 
opacity will paint pixels with 50% of the paint color, which would be blended with 50% of the image color. 
 
Opacity does not apply to indexed color images. 
 
Block Mode 
Some of the painting tools have an option to enable Block Mode. In this mode, the current brush is 
replaced with a solid hard-edged rectangular brush equal in size to the core area of the current brush (the 
core area of a brush represents the area where the majority of paint color is applied to an image). 
 
Current Brush 
The current brush for a painting tool is shown in a small preview window in the Brushes palette: 
 

 
 

The active tool for a brush is shown in the title bar of the palette window. 
 

The name of the brush is shown below the title bar. 
 

The brush preview is displayed below the brush name. 
 

The brush category ID, size, and magnification scale for the preview window is shown below this. 
 
Monochromatic and Gray Level Brush Files 
There are 2 brush files for each painting tool. There is no restriction on sharing brush files, so it is 
possible to use the same brush file for every painting tool. By default, EzImage assigns a separate gray-
level brush file for each painting tool. Gray-level brush files only apply to RGB and gray-scale images. A 
common brush file is assigned for all painting tools when working with indexed-color images. 
 
The process of switching brush files depending on the image and painting tool is automatic, and not 
something that you can control. If you switch from the Pencil tool to the Paintbrush tool, the brush file will 
change. If you have both an indexed-color and RGB image open in separate windows, switching between 
the two image windows will automatically change the brush files between monochromatic and gray level. 
You may not notice any change initially because all brush files use the same set of brush masks by 
default. If you modify the brush files, you will notice that only the file for the current painting tool will be 
affected. 
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Related topics: 
 
The Brushes Palette 
Brush List Editor 
Brush Shape Editor 
Brush File Properies 
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  Blur / Sharpen Tool 
 

 
 
This painting tool allows you to sharpen or blur an image using a brush. Blur and sharpen are both based 
on analysis of the pixels that make up the brush shape. Each pixel in the brush is sampled and compared 
with its closest neighbors in order to apply the effect. Since a neighborhood pixel sample is required, the 
brushes for blur and sharpen must be a minimum of 5 by 5 pixels in size. 
 
Setting a Pressure Level 
The pressure level is a percentage value. By increasing the pressure value, the blur or sharpen effect will 
be enhanced. Unlike most other painting tools, these ones are cumulative in nature. As you continue to 
sweep the brush over the same area, the blur and sharpen will be applied on top of the previous brush 
stroke(s). 
 
Region Restrictions 
If you have an active region selection, the painting will be confined to the pixels within the region. 
 
Current Brush 
The current brush for a painting tool is shown in a small preview window in the Brushes palette: 
 

 
 

The active tool for a brush is shown in the title bar of the palette window. 
 

The name of the brush is shown below the title bar. 
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The brush preview is displayed below the brush name. 
 

The brush category ID, size, and magnification scale for the preview window is shown below this. 
 
Monochromatic and Gray Level Brush Files 
There are 2 brush files for each painting tool. There is no restriction on sharing brush files, so it is 
possible to use the same brush file for every painting tool. By default, EzImage assigns a separate gray-
level brush file for each painting tool. Gray-level brush files only apply to RGB and gray-scale images. A 
common brush file is assigned for all painting tools when working with indexed-color images. 
 
The process of switching brush files depending on the image and painting tool is automatic, and not 
something that you can control. If you switch from the Pencil tool to the Paintbrush tool, the brush file will 
change. If you have both an indexed-color and RGB image open in separate windows, switching between 
the two image windows will automatically change the brush files between monochromatic and gray level. 
You may not notice any change initially because all brush files use the same set of brush masks by 
default. If you modify the brush files, you will notice that only the file for the current painting tool will be 
affected. 
 
NOTE: The blur and sharpen tools can not be applied to indexed color images. Therefore the 
monochromatic brush file is not used. 
 
Related topics: 
 
The Brushes Palette 
Brush List Editor 
Brush Shape Editor 
Brush File Properies 
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  Dodge / Burn / Sponge Tool 
 

 
 

  Dodge Tool 
 
The dodge tool is used to brighten areas of an image. You specify an exposure level percentage, along 
with the color range you would like to be affected by the process (highlights, midtones, shadows). Higher 
exposure levels will enhance the dodge effect. 
 

  Burn Tool 
 
The burn tool is used to darken areas of an image. 
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  Sponge Tool 
 
The sponge tool allows you to add to or subtract from the overall color intensity of an image. A higher 
exposure level will enhance the saturation or de-saturation effect. A value of 100% de-saturation for 
example will completely remove all color from the areas affected by the sponge brush radius. If you wish 
to affect a large section of an image, you may wish to use the Hue and Saturation operation, which allows 
for a greater degree of flexibility. 
 
These painting tools do not work in indexed color mode. 
 
Highlights, Midtones, Shadows  
The dodge and burn tools can only affect one of these pixel intensity levels at a time. Use the dropdown 
list to select which one to use. 
 
Exposure Level 
Exposure rate for dodge, burn, and sponge varies from 1 to 100%. Use a low value for subtle changes, or 
a high value for a significant change. 
 
Block Mode 
Some of the painting tools have an option to enable Block Mode. In this mode, the current brush is 
replaced with a solid hard-edged rectangular brush equal in size to the core area of the current brush (the 
core area of a brush represents the area where the majority of paint color is applied to an image). 
 
Current Brush 
The current brush for a painting tool is shown in a small preview window in the Brushes palette: 
 

 
 

The active tool for a brush is shown in the title bar of the palette window. 
 

The name of the brush is shown below the title bar. 
 

The brush preview is displayed below the brush name. 
 

The brush category ID, size, and magnification scale for the preview window is shown below this. 
 
Monochromatic and Gray Level Brush Files 
There are 2 brush files for each painting tool. There is no restriction on sharing brush files, so it is 
possible to use the same brush file for every painting tool. By default, EzImage assigns a separate gray-
level brush file for each painting tool. Gray-level brush files only apply to RGB and gray-scale images. A 
common brush file is assigned for all painting tools when working with indexed-color images. 
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The process of switching brush files depending on the image and painting tool is automatic, and not 
something that you can control. If you switch from the Pencil tool to the Paintbrush tool, the brush file will 
change. If you have both an indexed-color and RGB image open in separate windows, switching between 
the two image windows will automatically change the brush files between monochromatic and gray level. 
You may not notice any change initially because all brush files use the same set of brush masks by 
default. If you modify the brush files, you will notice that only the file for the current painting tool will be 
affected. 
 
NOTE: The dodge, burn, and sponge tools can not be applied to indexed color images. Therefore the 
monochromatic brush file is not used. 
 
Locking the Brush Movement 
You can confine the brush movement for the dodge, burn, and sponge paintbrush tools to horizontal or 
vertical movements using keyboard shortcuts. 
 

Hold down the SHIFT key to confine painting to a horizontal line. 
 

Hold down the CTRL key to confine painting to a vertical line. 
 
Make sure you release the mouse button before you release the CTRL or SHIFT keys, or you will end up 
drawing a connecting line between the current mouse cursor position and the confined paint line. 
 
Painting Speed and Accuracy 
Slow systems, limited available memory, and brush size all affect the speed by which a painting tool can 
keep up with the mouse movement. You may find it necessary to move the mouse at a slower rate if any 
of these conditions affect the ability to render paint lines with smooth curves. 
 
Related topics: 
 
The Brushes Palette 
Brush List Editor 
Brush Shape Editor 
Brush File Properies 
 

 
Top 
 
 

 
 
 

  Paint Bucket (Fill) Tool 
 

 
 
This tool will fill an image area using a flood fill style based on a tolerance level identical to that of the 
Magic Wand tool. 
 
The current foreground color is used to fill the image. 
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For more advanced fill operations, you can use the Magic Wand tool in combination with the Image Fill 
method. 
 
Region Restrictions 
If you have an active region selection, the fill method will be confined to the pixels within the region. 
 
Blend Modes 
Most painting tools use a blend mode that determines how the paint color will be combined with the color 
of the image area that falls within the brush radius. The normal blend mode simply replaces the image 
color with the paint color. The amount by which this occurs depends on the softness of the brush and the 
opacity level. Refer to this link for more information on the various blend modes available. 
 
Blend modes to not work on indexed color images. 
 
Opacity Level 
For most painting tools, you can set the opacity of the paint color that is applied to the image. 50% 
opacity will paint pixels with 50% of the paint color, which would be blended with 50% of the image color. 
 
Opacity does not apply to indexed color images. 
 
Tolerance Level 
The Paint Bucket tool uses a tolerance level similar to the Magic Wand tool. A lower tolerance level will 
paint a smaller region, while a larger tolerance level will fill significantly more pixel data. The paint bucket 
tool always fills using the current foreground color. 
 
 
Top 
 
 

 
 
 

  Cloning Tool 
 

 
 
The clone tool allows you to sample a source point in the same image or another image and replicate the 
pixel information using the standard brush painting methods. Cloning can be aligned or non-aligned, 
allowing for distinctly different cloning effects. 
 
Note that cloning must be done between images with identical bitmap depth. If you clone from two 
indexed color images, the results may be unpredictable as the color palettes may not match (convert to 
RGB first and then perform a color reduction after to avoid palette issues). 
 
Brush Styles 
The line tool is similar to the paintbrush tool in that it can use a brush with 256 levels of gray in its mask 
data. This allows a brush to have a softness effect, where the edges appear blurred due to the varying 
gray levels in the mask. If you are painting on indexed color images, the brush set will revert to hard-
edged brushes. Gray level brushes can only be used on RGB, RGBA, or gray scale images. 
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Blend Modes 
Most painting tools use a blend mode that determines how the paint color will be combined with the color 
of the image area that falls within the brush radius. The normal blend mode simply replaces the image 
color with the paint color. The amount by which this occurs depends on the softness of the brush and the 
opacity level. Refer to this link for more information on the various blend modes available. 
 
Blend modes to not work on indexed color images. 
 
Opacity Level 
For most painting tools, you can set the opacity of the paint color that is applied to the image. 50% 
opacity will paint pixels with 50% of the paint color, which would be blended with 50% of the image color. 
 
Opacity does not apply to indexed color images. 
 
Block Mode 
Some of the painting tools have an option to enable Block Mode. In this mode, the current brush is 
replaced with a solid hard-edged rectangular brush equal in size to the core area of the current brush (the 
core area of a brush represents the area where the majority of paint color is applied to an image). 
 
Alignment 
In aligned mode, the source of the clone paint area is kept at a constant distance and direction from the 
position you apply paint to. For example, if you sampled a clone source point at position (800, 600) and 
then painted at position (200,100), then the distance from the clone source for painting will always be 
+600 horizontal pixels and +500 vertical pixels. 
 
In non-aligned mode, the source position will always remain static. Using the above example, the source 
point will always be (800, 600) no matter where you paint on the image. 
 
Note that for cloning from one image to another, the mode is always non-aligned. 
 
Current Brush 
The current brush for a painting tool is shown in a small preview window in the Brushes palette: 
 

 
 

The active tool for a brush is shown in the title bar of the palette window. 
 

The name of the brush is shown below the title bar. 
 

The brush preview is displayed below the brush name. 
 

The brush category ID, size, and magnification scale for the preview window is shown below this. 
 



EzImage Reference – Version 1.05 

 

 Page 357 

 

Monochromatic and Gray Level Brush Files 
There are 2 brush files for each painting tool. There is no restriction on sharing brush files, so it is 
possible to use the same brush file for every painting tool. By default, EzImage assigns a separate gray-
level brush file for each painting tool. Gray-level brush files only apply to RGB and gray-scale images. A 
common brush file is assigned for all painting tools when working with indexed-color images. 
 
The process of switching brush files depending on the image and painting tool is automatic, and not 
something that you can control. If you switch from the Pencil tool to the Paintbrush tool, the brush file will 
change. If you have both an indexed-color and RGB image open in separate windows, switching between 
the two image windows will automatically change the brush files between monochromatic and gray level. 
You may not notice any change initially because all brush files use the same set of brush masks by 
default. If you modify the brush files, you will notice that only the file for the current painting tool will be 
affected. 
 
Related topics: 
 
The Brushes Palette 
Brush List Editor 
Brush Shape Editor 
Brush File Properies 
 

 
Top 
 
 

 
 
 

  Measure Tool 
 

 
 
The measure tool is used to draw one or two straight lines that overlay the current image. The lines are 
used to measure distance and angle in pixels, inches, centimeters, millimeters, or percent. 
 
Drawing a Measure Line 
Click on any position in the image window. Unlike painting tools, the measure tool allows you to draw 
lines outside the boundaries of the image, as long as they remain within the window itself. Hold down the 
mouse button and drag to another point to create a line. As you drag the line, the angle and distance 
values will change in the options panel. When you release the mouse button, the line will remain on top of 
the current image, using a color that you can change. 
 
With one measure line visible, the following information in the options panel is valid: 
 
X,Y: This is the coordinate of the first end point of the line. Since it is possible to draw lines outside the 
image area, the values can be negative or larger than the size of the image. 
 
W,H: This is the distance between the end points of the line, based on the rectangular area that would be 
needed as boundary edges. For example, a diagonal line has three components: The horizontal distance 
between the two points (width), vertical distance (height), and the straight distance along the path of the 
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line (distance). Depending on the drawing direction of the line, one or both of these values can be 
negative. 
 
A: This is the angle of the line relative to the horizontal plane of the image. A perfectly horizontal line will 
have an angle of 0 degrees. 
 
D1: This is the length of the line that connects the two end points. 
 
Creating a Second Line 
Hold down the CTRL key while moving the mouse cursor near one of the end points of the first line. The 
cursor will change to indicate that you may attach a second line to this end point. Click and drag to make 
the second line and release the mouse button to create the other end point of this line. When two lines 
are active, the following information is valid: 
 
X,Y: This is the coordinate of the first end point of the first line. 
 
A: This is the acute angle between the two lines where they are connected. 
 
D1: This is the length of the first line that connects its two end points. 
 
D2: This is the length of the second line that connects its two end points. 
 
Adjusting and Moving Lines 
You can move the end points at any time by simply moving the mouse over one. Click and drag when the 
mouse cursor changes to indicate an end point move is possible. If you move close to a line but not within 
the area of an end point, the cursor will change to indicate that you can move one or both lines without 
affecting the angle or distance. 
 
Constraining Lines 
Hold down SHIFT while drawing to constrain the lines to 45° angles. 
 
Removing Lines 
To remove a measure line, right click anywhere in the image. If two lines are present, the first click 
removes the second line and the second click removes the first line. If you left click anywhere in the 
image that is not close to a measure line, the current line(s) are removed and you create a new line at the 
click point. 
 
Showing/Hiding Measure Lines 
Measure lines are visible regardless of which tool you are currently using. However, you may find it useful 
to hide measure lines temporarily. Click on the Show and Hide buttons in the options panel to toggle 
display of the measure lines. 
 
Units of Measure 
The Measure tool has its own display units, independent of the ruler or information palette settings. Click 
on the Units button in the options panel set the unit type to one of pixels, inches, centimeters, millimeters, 
or percent of image size. 
 
Line Color 
The Measure tool renders its lines as overlays to the existing image. These lines are not part of the image 
itself and should have a color appropriate to the current image for maximum visibility. Click on the Color 
button in the option panel to set a color for the measure lines. 
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Related topics: 
 
Cross Hair Tool 
 
 
Top 
 
 

 
 
 

  Cross Hair Tool 
 

 
 
The Cross Hair tool allows you to create one or two cross hair lines (vertical and horizontal lines 
intersecting at the mouse cursor position) as an image overlay. If you use two cross hair lines, the 
bounding box created by them can be used to gauge sizes and create precise selections. 
  
Drawing a Cross Hair Line 
Click on any position in the image window. As you hold down the mouse button and drag, a cross hair is 
drawn, as two lines extending across the width and height of the image window and intersecting at the 
cursor position. When you release the mouse button, the cross hair lines are drawn in a color of your 
choice. This defines the first cross hair coordinate, as indicated in the (X1, Y1) values in the options 
panel. 
 
Drawing a Second Cross Hair Line 
Hold down the SHIFT key and repeat the click and drag procedure to create the second line. As you drag 
the second line you will notice that the coordinates for this line (X2, Y2) will update, along with the width 
and height values. The width and height represent the rectangular bounding box created by the 4 
intersection points of the lines. 
 
Adjustments and the Cursor Icons 
To adjust cross hair lines, move the mouse cursor close to an intersection point or one of the lines. The 
cursor icon will change to reflect a specific type of adjustment option: 
 

  Move both cross hair lines for line 1. 
 

  Move both cross hair lines for line 2. 
 

  Move horizontal cross hair for line 1. 
 

  Move horizontal cross hair for line 2. 
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  Move vertical cross hair for line 1. 
 

  Move vertical cross hair for line 2. 
 

  Move cross hair lines for both lines. 
 
Setting Region Selections 
The rectangular and elliptical region selection tools have a Cross Hair creation mode. When you have 
cross hair lines active, a region will be created automatically using those tools. 
 
With two lines visible, the region will be equal in size to the bounding box created by the 4 intersection 
points. 
 
With one cross hair line, a region consisting of a single pixel line (vertical or horizontal) will be created. 
 
Removing Lines 
To remove a measure line, right click anywhere in the image. If two lines are present, the first click 
removes the second line and the second click removes the first line. If you left click anywhere in the 
image that is not close to a measure line, the current line(s) are removed and you create a new line at the 
click point. 
 
Showing/Hiding Measure Lines 
Cross hair lines are visible regardless of which tool you are currently using. However, you may find it 
useful to hide cross hair lines temporarily. As with the measure tool, Show and Hide buttons are available 
for this. When you choose the Show cross hair button, you have a choice to display the first cross hair 
with or without a floating ruler guide. 
 
Units of Measure 
The Cross Hair tool has its own display units independent of the ruler measure tool units of measure. 
Click on the Units button set the unit type to one of pixels, inches, centimeters, millimeters, or percent of 
image size. 
 
Line Color 
The Cross Hair tool renders its lines as overlays to the existing image. These lines are not part of the 
image itself and should have a color appropriate to the current image for maximum visibility. Click on the 
Color button in the option panel to set a color for the measure lines. 
 
Related topics: 
 
Rectangular/Ellipse Selection Tool 
Measure Tool 
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  Eyedropper Tool 
 

 
 
 

  Color Sample Tool 
 
This tool samples one or more pixels of color in an image. The options allow for single point, 3 x 3, or 5 x 
5 pixel areas. The 3 x 3 and 5 x 5 pixel areas are sampled around the current (X, Y) coordinate pair as 
indicated in the status bar. If you move the cursor to the extreme edges of the image (or corners), the 
number of available pixels will be less than 9 (3 x 3 mode) and 25 (5 x 5 mode). 
 
The color average will appear in the swatch in the options panel. You can click on this to set the current 
foreground color in the Tools palette. By moving the mouse over this swatch, the RGB and HSV values of 
the sample average color will appear in the Information palette. 
 
Selection Sampling 
The last option allows you to obtain the average color of all pixels for the current region selection. Create 
a selection using any of the region creation tools, and use the color dropper to move the region around. If 
you release the mouse button after clicking anywhere inside the region, the average color will be 
calculated. If click and drag with the mouse, the region will be dragged around the image. When you 
release the mouse button after dragging, the sample color will be calculated based on the new region 
position. Note that the color in the swatch palette will only show the current pixel color under the mouse 
cursor until you actually release the button. 
 
Foreground/Background Updates 
When you sample colors using the left mouse button, the foreground color in the Tools palette will be 
updated. Use the right mouse button to update the background color. 
 

  Hotspot Tool 
 
Many operations in EzImage make use a small thumbnail sample preview image. This image is set at 
100% magnification and therefore only shows a small percentage of most images. By default, this 
thumbnail will show the area relative to the center pixel of the image. You can set a new hot spot center 
point for the thumbnail views with this tool. All thumbnail previews will auto-center to this position the next 
time you run the appropriate image operation. 
 
This tool is also used to set a hot spot for cursor file exporting (Importing a cursor file does not preserve 
its hot spot). If you do not set a hot spot on a cursor file export, then the hot spot will be set to coordinate 
(0, 0). 
 

  Transparency Tool 
 
For GIF images, this tool is used to set or clear the transparent color for an image. If a GIF image has an 
assigned transparent color then a color swatch will appear in the tool options panel on the right side. A 
clear transparency button will also appear. You can use the swatch as a shortcut to choose the 
transparent color for painting. You can click on the remove transparency button to remove all 
transparency from the image. When you do this, the prior transparent color becomes a normal solid color 
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when the GIF is displayed. To set a transparent color, use this tool and click on any color in the GIF 
image. This tool has no effect on images that are not indexed color format and the transparent color is 
ignored for any other image file formats. 
 
 
Top 
 
 

 
 
 

  Color Wand Tool 
 

 
 
The Color Wand tool measures differences in color information between the pixel that you click on with 
the mouse and the surrounding pixels. Unlike the Magic Wand tool, this method selects all pixels that 
match the specified color range in the image. The magic wand tool is based on a flood-fill technique that 
radiates outward from a single click point. 
 
Creating Compound Selections 
The 3 buttons to the left in the options panel are used to create complex regions: 
 

Click on the first button to lock the selection creation mode so that any new selection will erase the 
current selection once the mouse button is released. The exception to this rule is if you are holding 
down CTRL, ALT, or a combination of the two, which temporarily overrides the normal mode. 

 
Click on the second button to lock the selection mode so that the new region selection will be added 
to the current selection if one is present. This allows you avoid having to always hold down the CTRL 
key if you are doing many additions. 

 
Click on the third button to lock the selection mode so that the new region will be subtracted from the 
current selection if one is present. 

 
The following keyboard shortcuts are available when creating region selections, which do not require you 
to lock the selection mode: 
 

Hold down CTRL to add to an existing region selection 
Hold down ALT to subtract from an existing selection 
Hold down CTRL+ALT to create an intersection with the existing selection 

 
Nudge Palette 
Click on the nudge button to show/hide the palette window. The nudge palette allows you to move and 
resize region selections. 
 
Selection Method 
Single Color: Creates a selection where all pixels equal to the RGB value of the pixel you click on will be 
selected. 
 
RGB Range: The selection is based on a range of red, green, and blue values. For example, if you click 
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on a pixel with RGB (64,128,192) with a tolerance of 20, then all pixels will be selected that fall within the 
RGB range of (44, 108, 172) to (84, 148, 212). 
 
HSV Range: The selection uses a range based on hue, saturation and value. This tends to provide better 
results than the RGB range since colors that are close to each other (i.e. several shades of blue) are 
more likely to be selected. 
 
Component/Channel Ranges: The remainder of the selection methods apply the tolerance setting to a 
specific color channel (red, green, blue) or color component (hue, saturation, value). These methods are 
not as useful in most applications and tend to give unpredictable results with images that contain many 
subtle shades of color (i.e. photographs). 
 
Tolerance Setting 
The Color Wand tool will select regions based on how close the color information matches the pixel you 
click on using a tolerance level. A lower tolerance level will select a smaller region, while a larger 
tolerance level will select significantly more pixel data, sometimes the entire active image. The tolerance 
is based on the selection method. If you are using a hue-based method, the tolerance applies to a range 
of hues. For RGB methods, it is based on an RGB color range. For Single Color mode, the tolerance 
setting is ignored. 
 
Related topics: 
 
Creating Regions 
Saving to the Clipboard 
Saving to another Image 
Saving to a file 
Creating Fill Patterns 
Creating Brushes 
Saving Region Outlines 
Deselect and Reselect 
Expanding and Contracting 
Region Placement Anchors 
Selection Positioning 
Keyboard Shortcuts 
Regions and Floating Images 
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Catalog Browse Mode 
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The catalog browser is quite similar to the normal thumbnail browser, with the following differences: 
 

Maintenance options are not available. 
 

You may not add or delete images from the catalog browser. 
 

File operations (copy, delete, rename, and move) are not available, since they are not applicable to 
this view method. 

 
Source images can use relative path name references, as long as the database files reside on the 
same logical drive. This allows you to place the database files onto read-only media such as CD-
ROM or DVD and not have to worry about the drive letter assignment (see below for an example or 
this situation). 

 
The browser window is organized into the following areas: 
 

The menu bar across the top contains all of the options available for the browser. 
 

The panel below this menu is for the display of comment text, which can be assigned to one or more 
thumbnail images. 
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The upper left area is used for the path group list. When you add images to a database, the path 
name for the source file is used to define the group that it will belong to. All images in a database are 
grouped by path name, and this list reflects all of the available paths in the database.  

 
The lower left area is optionally available for a mini-preview image window. By default this window is 
turned off. Use the Mini-preview menu option from Options if you wish to display images in this 
area. Otherwise, the left side of the window will be use by the folder tree. 

 
The remainder of the right side of the window area is used for the thumbnail images. These images 
are arranged in a row and column order. The rows are filled from left to right, then downwards, 
according to a sortation order you can specify. There is no horizontal scrolling of the thumbnail grid. 
Images will wrap around at the right edge and continue to the next row. A vertical scrollbar will appear 
when more images are available than will fit on the screen. 

 
A status bar at the bottom of the window is divided into several panels for the following (from left to 
right): Sortation indicator, total images in the current folder, selected images, and a help hint/message 
area. 

 
Labels and Blank Images 
There are two display options for thumbnail images: with or without labels. Labels appear beneath each 
thumbnail image when enabled, and can included from 1 to 3 lines of information, including the file name, 
size, date and time. Options are available to exclude the file extension and convert all characters to 
uppercase in the file name. The label text can be customized with any font name, size, color, and 
background. If a file name or other information is too lengthy to fit within the width of a thumbnail image, it 
will be cropped. You can address this issue with two possible solutions: 
 

Increase the thumbnail image width (you can do this before or after the thumbnail images are created 
for any folder) to accommodate all long file names. 

 
Use a smaller typeface for the labels. 

 
There will likely be the occasional image that is simply too long to fit within the label area. For this reason, 
the file name and size are always duplicated in the status bar hint area for the image the mouse cursor is 
currently positioned over. 
 
If you disable labels in thumbnail images, then the following display characteristics are used: 
 

If the image file has no current thumbnail assignment, the file name will appear centered within the 
blank thumbnail square. 

 
If a thumbnail image exists, no labels of any type will appear. All images will be tightly packed 
together, separated only by the single-pixel borderlines. 

 
Note: Since thumbnails in catalog mode only come from the database itself, a blank cell in the thumbnail 
grid indicates an error in the image data file. You can re-create the blank positions using the standard 
browser mode. 
 
Date and Size Changes 
Thumbnail images are stored with the size and modification date in the database. When thumbnail 
images are to be displayed, a check is made against the original date and size stored in the database and 
the current size and date of the source image. If either value has changed, the thumbnail image will be 
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marked using a different text color as define in the application preferences. You will need to recreate the 
thumbnails for any images that have size or date changes. 
 
Selecting Images 
You can use the mouse to selection multiple images by holding down the SHIFT and CTRL keys. Use 
SHIFT to select a range of images and CTRL to select or deselect single images without affecting the rest 
of the selection. Each selected image is marked with an outline cursor, which can be customized by 
width, color, and opacity. 
 
Thumbnail Sizes, Auto-sizing and Size Locking 
Thumbnail sizes are defined in the application general preferences. The width and height values 
determine the size of images that will be added to the database, and in some cases, the size of the 
thumbnail image cells in the browsers. There are options that affect the thumbnail size that you can 
choose to use. 
 
Size locking applies to individual folders in the database. When you choose to lock a folder with a 
specific width and height as defined in this dialog, the thumbnail cell size will never change, regardless of 
the thumbnail width and height defined in the application preferences. If size locking is not enabled, then 
the width and height of each cell will change to the values defined in the preferences. 
 
Size locking is not available in catalog browse mode. Any folders that have been locked will remain 
locked while in catalog mode. 
 
Auto-sizing is another option available in the general preferences. When enabled, each folder of 
thumbnail images will be examined to find the largest thumbnail width and height. The cell size will then 
be set to the largest thumbnail dimension, to avoid any image clipping. Note that auto-sizing does not 
apply if labels are in use. 
 
Thumbnail Image Clipping 
Since thumbnail images can be created with any width or height between 50 and 200 pixels, it is possible 
to have multiple groups of images with different width and height values in the same database. In the 
absence of size locking and the auto-size features, the current thumbnail width and height define in the 
preferences may result in some images being cropped. Note that this only affects the display of the 
thumbnail images in the cell grid. The original images stored in the database will not be cropped in any 
way. 
 
Comments 
Any thumbnail image can have a comment assigned to it. You can also assign the same comment to 
multiple images. 
 
Comments can not be deleted, added, or changed in catalog mode. 
 
Database Properties 
This option displays some basic information about the active thumbnail database. If the database 
contains unused space or deleted thumbnail images, you can use the database maintenance utilities to 
reclaim the free space. 
 
Thumb Mode and Full Browse Mode 
The Thumb Mode option and Full Browse Mode option provide two different methods to view a thumbnail 
database. The full browse mode displays all thumbnail images that are currently active in the database, in 
the order that they were added. All of the available window space is used to show the thumbnails. 
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Normal thumb mode displays only the images that reside in a specific file folder, along with a common 
Windows folder tree browser. The full browse mode offers no mini-preview window or path level browsing 
at all. It simply provides a way to see all images in a database at one time. 
 
Note that many options are not available while in Full Browse mode. 
 
Searching a Thumbnail Database 
This option will search a thumbnail database using pattern, size, and date-based filters. If you have 
comments assigned to images, you can locate them using a comment search string with this option. The 
search only works in normal Thumb Browse mode by matching the search criteria against each thumbnail 
image one folder at a time. When a match is found, the folder is set in the browser and only the matching 
images are displayed. Use the Find Next option to continue the search on the next folder in the 
database. For more information on the search facility, click on this link. 
 
Note that paths in the group list window are shown in alphabetical order, but the search process itself will 
look in the database in the order that path names are added. This will generally result in an unordered 
selection of entries in the path group list as each search is performed using the Find Next option. 
 
Switching Database Files 
EzImage can support multiple thumbnail databases, but only one can be active at a time. Use the Switch 
Database option to switch from the current database to a new one. The default location for thumbnail 
database files is the Thumbs folder of the application path. A thumbnail database contains 4 files that 
can be identified by their extensions: path groups (PTH), images (THD), file links (FIL), and comments 
(CMT). 
 
Mini-Preview Window 
Use the Mini-Preview option to toggle the display of a small window for the currently selected image. This 
preview window will appear underneath the folder view in the bottom left corner of the thumb browser 
window. The mini-preview window will not be visible in the Full Browse display mode. The quality of the 
displayed image can be set in the thumbnail preferences. 
 
Printing Thumbnail Images 
The printer setup defines some basic format options for printing images. EzImage can scale images to fit 
the page, print at actual size, or according to the printer resolution embedded in most file formats. 
Margins and header/footer options allow some degree of customization to the printed pages. The 
thumbnail printing options will print images in a row/column grid format, using various options and sizes. 
For more information on printing thumbnail images, click on this link. 
 
Image File Properties 
The image file properties dialog provides several pieces of useful information about image files, including 
format, compression, dimension, size, printing resolution, and comments. You can select multiple image 
files at one time and step through the properties of each one. A small thumbnail viewer and file marking 
system is also included in this dialog window. 
 
Hiding Images 
Use the hide/show selected items menu options to temporarily hide the selection or redisplay what was 
previously hidden. The image files are not deleted or altered in any way. 
 
Slide Shows 
Use the Add to Slide Show option to add the selection to the current slideshow list. If no images are in 
the list, one will be created using the current slideshow preferences as the template for the script 
playback. There is a current limit of 10,000 images per slideshow script. Note that duplicate images are 
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allowed in a slideshow script (you can remove duplicate entries with the script editor). 
 
Use the Clear option to clear the active slideshow list. 
 
Image Lists 
Use the Add to Image List option to add the selection to the current image list. If no images are in the 
list, one will be created. Unlike slide show scripts, an image list is only limited by available memory. You 
can view and modify this list using the image list browser. As with slide show scripts, duplicate entries are 
allowed in an image list. You can use the editor to remove duplicate files, sort the entries, and condense 
the path name references to save memory and file space. 
 
Use the Clear option to clear the active image file list. 
 
Path Lists 
Path lists are similar to image file lists, except that they only contain path names. They are used for one 
purpose in EzImage: an image file source for the File Conversion tool. Path lists make it simple to perform 
file conversions from multiple path sources that don’t have to reside on the same drive or computer 
system. This option will add the browser’s current folder path to the active path list. 
 
Selecting a Sort Order 
The sorting options apply to all image browsers. Setting a file size sort option in the preview browser will 
apply the same ordering to the thumbnail browser and any of the other browsers in EzImage. The sort 
order is saved when the application closes. The indicator in the lower left corner of the status bar will 
contain a 2-character abbreviation for the sort order. 
 
Relative Path Names in Catalog Mode 
Since this mode of thumbnail viewing was designed for placement of the database files on removable 
media such as CD-ROM or DVD, a method was implemented to handle the situations where the path 
name references in the database can be used on drives with any logical drive letter assignment. 
 
Path names are always stored in the database using a fully qualified link, such as: 
 
E:\My Data Files\Images\Samples1 

 
Assuming drive E: referred to a CD-ROM disc, then it is more than likely that the same database viewed 
on another system will use a different drive letter for the CD-ROM device. The normal thumbnail browse 
mode requires that all path names must exist for any image, right down to the drive letter reference. 
Relative path names are never stored in the path groups file. 
 
In catalog browse mode, EzImage will check for an absolute path reference first, followed by a relative 
path reference that is derived from the absolute one. This is under the assumption that the database files 
reside on the same logical drive as the image source files. 
 
Given the example above, if the source image is not found on drive letter E:, then a search for the image 
will be made on the same drive letter of the database files. If the database files are located on drive L:, 
then a second search for the image file would be done using: 
 
L:\My Data Files\Images\Samples1 

 
You can also stored images and database files on a network path, as the relative path reference works on 
UNC share names as well. 
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Related topics: 
 
Image Preview Browser 
Path Lists 
Image Lists 
Slide Shows 
Image File Properties 
 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Thumbnail Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
 

 
Top 
 
 

 
 
 

Temporary Images, Workspace Files and Undo 
 
EzImage provides one level of undo using the Edit->Undo method. 
 
If you need to restore image information with more flexibility than the single level of undo, you can use 
Workspace files or Temporary Images. 
 
Temporary Images 
Temporary images are a snapshot of an active image window. Everything about the image window, 
including the selection region and floating image, is saved in a temporary image file. There can be one 
temporary file per image window, and each one will remain active as long as the window remains open. 
Once the image window is closed, the temporary image is deleted. You can also manually remove a 
temporary image file using the Edit->Temporary Image->Clear menu option. Temporary images are 
always stored in the Temp folder of the application path. 
 
To create a temporary image choose the Edit->Temporay Image->Save option. 
 
To restore a temporary image choose the Edit->Temporary Image>Restore option. The current image 
window contents will be replaced with the temporary image snapshot. 
 
If you need to save the image window contents at multiple steps in your image-editing job, you can use 
Workspace files.  
 
Workspace Files 
Workspace files are custom format files used by EzImage to save and load the complete state of an 
image window. Any active region selections, floaters, and image information is stored in this file. You may 
think of this files as another type of image file format, but since it is not supported by other applications, or 
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by other aspects of EzImage (thumbnail creation for example), it has been given its own private menu 
item area. 
 
Use the File->Workspace->Save menu option to store the image window to workspace file. The file has 
an extension of .EZW, and the default location is Work in the application path. Use File->Workspace-
>Open to open the image in a new window. 
 
Note that the workspace also stores the reference to the original file name and location. The name of the 
workspace file does not have any relationship to the name of the image that was originally stored in it. 
When you open a workspace file, the title bar of the window will show the original file name reference, not 
the name of the workspace file. 
 
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Filling and Images 
Clearing Images 
Reverting to Saved Images 
Thumbnail Preview Windows 
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Searching for Images 
 
The search dialog window contains three tabs of options for pattern, size, and date-based filtering. 
 
File Pattern and Comment Searches 
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File Patterns 
File pattern filters are equivalent to the older MS-DOS style wildcard-based file names. The filter consists 
of one or more wildcard strings that match to a single file name. The asterisk “*” character matches zero 
or more occurrences of any character, while the question mark “?” character matches one occurrence of 
any character. You must specify a filter string for both the file name and the file extension, separate by 
the period “.” character. To match on multiple patterns, separate them with a semi-colon character. 
 
This is contrary to Win32 (95,98,NT,XP) based wildcard conventions, so please be aware of the 

difference. If a file contains multiple periods, as in SAMPLE1.23.96.BMP, the file name portion would be 

SAMPLE1.23.96 and the extension would be .BMP. Do NOT use the asterisk (*) by itself to match all 

files (Use *.*). 

 
Comment Search 
Check this option to enable a search that includes comments assigned to thumbnail images. 
 
Case-Sensitive 
Check this option to make the comment-based searches case-sensitive. 
 
Allow Partial Match 
If this option is checked, the search string can match against any occurrence within the comment. If the 
option is not checked, then the search string must match the comment word-for-word. 
 
Search String 
Enter a comment search string here. Ensure that you use upper and lowercase characters for case-
sensitive searches. 
 
 
File Size Filters 
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Include Files Sizes Smaller Than 
Enter a value according to the unit size displayed next to the input field. Depending on checked status of 
the Include/Exclude option, files with a size smaller than this will either be included or excluded from the 
conversion process. 
 
Include Files Sizes Larger Than 
Enter a value according to the unit size displayed next to the input field. Depending on checked status of 
the Include/Exclude option, files with a size larger than this will either be included or excluded from the 
conversion process. You can check one or both of the smaller and larger options. If you check both, then 
you will define an exclusion or inclusion size range, unless the Include Between option is checked. 
 
Include Between 
The Include Between option is used to filter all files between the smaller and larger file sizes. When this 
option is checked, the include/exclude size options are automatically disabled, as you will be defining a 
size range. 
 
Include/Exclude Sizes 
If you check this option, then all files with sizes larger or smaller than the size limits will be included in the 
conversion. With this option unchecked, all files with sizes larger or smaller than the size limits will be 
excluded. If the Include Between option is checked, then this setting is ignored. 
 
Changing the Unit Size 
Click on the labels to the right of the size input fields to use size units of Bytes, Kilobytes, or Megabytes. 
 
 
Date Filters 
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Date Based, Recent Days, Recent Months 
Date-based filters can be defined as a range of recent days, months, or by one or two specific dates. 
These options determine how to filter the image files by date. Note that time is not available with this filter. 
The smallest range of time supported is 24 hours. The date used is always the file’s last modification 
date. 
 
Recent Days/Months 
For recent days or months, enter the number of days or months that the filter will extend back to. For 
example, a value of 30 days will only include image files that were created/modified within the last 30 
days. 
 
Include Files Older Than 
Depending on checked status of the Include/Exclude option, files with a modification date older than this 
will either be included or excluded from the conversion process. 
 
Include Files Newer Than 
Depending on checked status of the Include/Exclude option, files with a date newer than this will either be 
included or excluded from the conversion process. You can check one or both of the older and newer 
options. If you check both, then you will define an exclusion or inclusion date range, unless the Include 
Between option is checked. 
 
Include Between 
The Include Between option is used to filter all files between the older and newer dates. When this option 
is checked, the include/exclude date options are automatically disabled, as you will be defining a date 
range. 
 
Include/Exclude Dates 
If you check this option, then all files with dates newer or older than the date limits will be included in the 
conversion. With this option unchecked, all files with dates newer or older than the date limits will be 
excluded. If the Include Between option is checked, then this setting is ignored. 
 
Date Input Format 
EzImage only recognizes date input in the format of: 4-digit year, followed by 2-digit month (leading zero 
must be included), follows by 2-digit day (leading zero required). The year, month, and day values must 
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be separated by forward slash characters. 
 
Click on Reset to restore all settings to default values (no pattern, no size filter, and no date filter). 
 
Hiding Non-Matching Files 
If this option is checked, then each folder that is displayed with matching thumbnail images will have any 
thumbnails that don’t match the search criteria hidden. This allows you to only see the images you have 
searched for. 
 
Starting a Search Process 
Click on Find to begin the search. Each path group in the database is searched at one time. When at 
least one matching image is found in the path, the browser will switch to that path and show the matching 
images. By using the Find Next option in the browser menu, the search will resume on the next path 
group in the database. 
 
Related topics: 
 
Thumbnail Database System 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Exporting Database Information 
Thumbnail General Preferences 
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Threshold Conversion 
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This method will convert any image to black and white format using an intensity cutoff value. Any pixels 
with a color intensity level below this value will be converted to black, and any equal to above it will be 
converted to white. The example below shows an image before and after the threshold method has been 
applied. 
 
Before: 
 

 
 
After: 
 

 
 
The graph shows a histogram of the intensity values for the source image, which indicates the pixel 
density at each of 256 levels (peaks in the graph indicate a high density of a particular intensity in the 
overall image). The slider allows you to change the cutoff value to any of the 256 possible intensity 
values. Depending on the intensity map of the source image, a 1-unit change in the cutoff value can 
dramatically alter the resulting image. 
 
Previewing Image Adjustments 
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In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Indexed Color Mode 
RGB Color Mode 
Gray Scale Mode 
Halftone Conversion 
Channel Separations 
Alpha Channels 
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Thumbnail Image Browser 
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The browser window is organized into the following areas: 
 

The menu bar across the top contains all of the options available for the browser. 
 

The panel below this menu is for the display of comment text, which can be assigned to one or more 
thumbnail images. 

 
The upper left area is used for the system folder tree. This is a system-level folder tree that integrates 
with your version of Windows therefore a context-level popup menu is available by right clicking with 
the mouse.  

 
The lower left area is optionally available for a mini-preview image window. By default this window is 
turned off. Use the Mini-preview menu option from Options if you wish to display images in this 
area. Otherwise, the left side of the window will be use by the folder tree. 

 
The remainder of the right side of the window area is used for the thumbnail images. These images 
are arranged in a row and column order. The rows are filled from left to right, then downwards, 
according to a sortation order you can specify. There is no horizontal scrolling of the thumbnail grid. 
Images will wrap around at the right edge and continue to the next row. A vertical scrollbar will appear 
when more images are available than will fit on the screen. 

 
A status bar at the bottom of the window is divided into several panels for the following (from left to 
right): Sortation indicator, total images in the current folder, selected images, and a help hint/message 
area. 
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Labels and Blank Images 
There are two display options for thumbnail images: with or without labels. Labels appear beneath each 
thumbnail image when enabled, and can included from 1 to 3 lines of information, including the file name, 
size, date and time. Options are available to exclude the file extension and convert all characters to 
uppercase in the file name. The label text can be customized with any font name, size, color, and 
background. If a file name or other information is too lengthy to fit within the width of a thumbnail image, it 
will be cropped. You can address this issue with two possible solutions: 
 

Increase the thumbnail image width (you can do this before or after the thumbnail images are created 
for any folder) to accommodate all long file names. 

 
Use a smaller typeface for the labels. 

 
There will likely be the occasional image that is simply too long to fit within the label area. For this reason, 
the file name and size are always duplicated in the status bar hint area for the image the mouse cursor is 
currently positioned over. 
 
If you disable labels in thumbnail images, then the following display characteristics are used: 
 

If the image file has no current thumbnail assignment, the file name will appear centered within the 
blank thumbnail square. 

 
If a thumbnail image exists, no labels of any type will appear. All images will be tightly packed 
together, separated only by the single-pixel borderlines. 

 
Date and Size Changes 
Thumbnail images are stored with the size and modification date in the database. When thumbnail 
images are to be displayed, a check is made against the original date and size stored in the database and 
the current size and date of the source image. If either value has changed, the thumbnail image will be 
marked using a different text color as define in the application preferences. You will need to recreate the 
thumbnails for any images that have size or date changes. 
 
Selecting Images 
You can use the mouse to selection multiple images by holding down the SHIFT and CTRL keys. Use 
SHIFT to select a range of images and CTRL to select or deselect single images without affecting the rest 
of the selection. Each selected image is marked with an outline cursor, which can be customized by 
width, color, and opacity. 
 
Thumbnail Sizes, Auto-sizing and Size Locking 
Thumbnail sizes are defined in the application general preferences. The width and height values 
determine the size of images that will be added to the database, and in some cases, the size of the 
thumbnail image cells in the browsers. There are options that affect the thumbnail size that you can 
choose to use. 
 
Size locking is available in the Thumbnails menu. A sample of the dialog window appears below: 
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Size locking applies to individual folders in the database. When you choose to lock a folder with a 
specific width and height as defined in this dialog, the thumbnail cell size will never change, regardless of 
the thumbnail width and height defined in the application preferences. If size locking is not enabled, then 
the width and height of each cell will change to the values defined in the preferences. Note that a size-
locking feature is available in the general preferences as well. If you enable it in the preferences, then 
each folder of thumbnail images created will automatically be locked with the current thumbnail width and 
height. 
 
Auto-sizing is another option available in the general preferences. When enabled, each folder of 
thumbnail images will be examined to find the largest thumbnail width and height. The cell size will then 
be set to the largest thumbnail dimension, to avoid any image clipping. Note that auto-sizing does not 
apply if labels are in use. 
 
Thumbnail Image Clipping 
Since thumbnail images can be created with any width or height between 50 and 200 pixels, it is possible 
to have multiple groups of images with different width and height values in the same database. In the 
absence of size locking and the auto-size features, the current thumbnail width and height define in the 
preferences may result in some images being cropped. Note that this only affects the display of the 
thumbnail images in the cell grid. The original images stored in the database will not be cropped in any 
way. 
 
Creating Thumbnail Images 
You can create thumbnail images using one of three methods. Use the Create All option to create 
thumbnails for any images that currently don’t have one in the folder path. Thumbnails that are marked as 
having been changed will also be counted. Use Create Selected to create thumbnails only for the 
selected images. Use the Recursive option to create thumbnails for all images in the current folder and 
all subfolders beneath it. If thumbnail images already exist for the latter two methods, they will not be 
overwritten with new ones. 
 
The Re-create methods are similar to the Create ones, with the only difference being that any existing 
thumbnail images will be overwritten with new ones. This has the effect of creating blank areas in the 
image database file. When new images are added to this file, empty space will be filled if room permits. 
You can periodically reclaim free space using the maintenance utilities. 
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Comments 
Any thumbnail image can have a comment assigned to it. You can also assign the same comment to 
multiple images. Create a selection of images and use the Comments menu option to add new 
comments or edit existing ones. Use the Remove Comments option to delete the comments for all 
selected images. 
 
If you don’t wish to use comments with a database, you can hide the comment panel that appears 
beneath the menu bar using the appropriate option in the Options menu. 
 
Deleting Images 
Use the Delete Selection option to delete the thumbnail image from the database. The original source 
file is not affected by this method. Once the images are deleted, they will create free space in database. 
This space will be reused if possible for new images. However, since the image sizes are variable, 
fragmentation will occur over a period of time. You can use the maintenance utilities to reclaim the free 
space. 
 
Database Properties 
This option displays some basic information about the active thumbnail database. If the database 
contains unused space or deleted thumbnail images, you can use the database maintenance utilities to 
reclaim the free space. 
 
Thumb Mode and Full Browse Mode 
The Thumb Mode option and Full Browse Mode option provide two different methods to view a thumbnail 
database. The full browse mode displays all thumbnail images that are currently active in the database, in 
the order that they were added. All of the available window space is used to show the thumbnails. 
 
Normal thumb mode displays only the images that reside in a specific file folder, along with a common 
Windows folder tree browser. The full browse mode offers no mini-preview window or path level browsing 
at all. It simply provides a way to see all images in a database at one time. 
 
Note that many options are not available while in Full Browse mode. 
 
Preview Mode Switch 
The Preview Browser option will switch the viewer from its current thumbnail browser window to the 
image preview browser, while retaining the exact same folder and image file that is currently selected. 
This allows you to easily switch between different viewers without losing track of which image file you are 
currently positioned at. To return back to the thumbnail browser, simply choose the Thumb Mode option 
from the preview browser. 
 
Searching a Thumbnail Database 
This option will search a thumbnail database using pattern, size, and date-based filters. If you have 
comments assigned to images, you can locate them using a comment search string with this option. The 
search only works in normal Thumb Browse mode by matching the search criteria against each thumbnail 
image one folder at a time. When a match is found, the folder is set in the browser and only the matching 
images are displayed. Use the Find Next option to continue the search on the next folder in the 
database. For more information on the search facility, click on this link. 
 
Switching Database Files 
EzImage can support multiple thumbnail databases, but only one can be active at a time. Use the Switch 
Database option to switch from the current database to a new one. The default location for thumbnail 
database files is the Thumbs folder of the application path. A thumbnail database contains 4 files that 
can be identified by their extensions: path groups (PTH), images (THD), file links (FIL), and comments 
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(CMT). 
 
Creating a New Database 
Use this option to create a new thumbnail database. The current one will remain unaltered but the new 
one will become the default until you choose to switch to another. When creating a database, you can 
choose to encrypt it with a password that can prevent someone from viewing or altering the database 
contents. Encryption can always be removed or added at any time using the database maintenance 
utility. For more information on database creation, click on this link. 
 
Deleting a Database 
The Delete Database option will remove all related files for the current database from your system. Once 
deleted, the default database (ThumbDef) will be reassigned as the current one. 
 
Maintenance 
This Maintenance option will display the database maintenance utility window. If the database is 
protected with encryption, a password must be provided to gain access to this feature. Maintenance 
includes options for space reclamation, image deletions, encryption, exporting of information, and several 
other choices. 
 
Mini-Preview Window 
Use the Mini-Preview option to toggle the display of a small window for the currently selected image. This 
preview window will appear underneath the folder view in the bottom left corner of the thumb browser 
window. The mini-preview window will not be visible in the Full Browse display mode. The quality of the 
displayed image can be set in the thumbnail preferences. 
 
Printing Thumbnail Images 
The printer setup defines some basic format options for printing images. EzImage can scale images to fit 
the page, print at actual size, or according to the printer resolution embedded in most file formats. 
Margins and header/footer options allow some degree of customization to the printed pages. The 
thumbnail printing options will print images in a row/column grid format, using various options and sizes. 
For more information on printing thumbnail images, click on this link. 
 
Image File Properties 
The image file properties dialog provides several pieces of useful information about image files, including 
format, compression, dimension, size, printing resolution, and comments. You can select multiple image 
files at one time and step through the properties of each one. A small thumbnail viewer and file marking 
system is also included in this dialog window. 
 
Refreshing the File List 
The refresh options depend on the nature of the viewer that is currently displayed. Generally, it indicates 
that the current folder of files should be reread and any image display information updated. 
 
Hiding Images 
Use the hide/show selected items menu options to temporarily hide the selection or redisplay what was 
previously hidden. The image files are not deleted or altered in any way. 
 
Slide Shows 
Use the Add to Slide Show option to add the selection to the current slideshow list. If no images are in 
the list, one will be created using the current slideshow preferences as the template for the script 
playback. There is a current limit of 10,000 images per slideshow script. Note that duplicate images are 
allowed in a slideshow script (you can remove duplicate entries with the script editor). 
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Use the Clear option to clear the active slideshow list. 
 
Image Lists 
Use the Add to Image List option to add the selection to the current image list. If no images are in the 
list, one will be created. Unlike slide show scripts, an image list is only limited by available memory. You 
can view and modify this list using the image list browser. As with slide show scripts, duplicate entries are 
allowed in an image list. You can use the editor to remove duplicate files, sort the entries, and condense 
the path name references to save memory and file space. 
 
Use the Clear option to clear the active image file list. 
 
Path Lists 
Path lists are similar to image file lists, except that they only contain path names. They are used for one 
purpose in EzImage: an image file source for the File Conversion tool. Path lists make it simple to perform 
file conversions from multiple path sources that don’t have to reside on the same drive or computer 
system. This option will add the browser’s current folder path to the active path list. 
 
Selecting a Sort Order 
The sorting options apply to all image browsers. Setting a file size sort option in the preview browser will 
apply the same ordering to the thumbnail browser and any of the other browsers in EzImage. The sort 
order is saved when the application closes. The indicator in the lower left corner of the status bar will 
contain a 2-character abbreviation for the sort order. 
 
Favorites List 
Use the options in the Favorites menu to add path names to a list that can be used as a quicker method 
for accessing your favorite image folders. The path list can contain up to 100 entries and be sorted or 
unsorted. By default, path names are added to the end of the list in unsorted order. A general preferences 
option can be enabled to automatically sort the path list when you add new entries. 
 
Related topics: 
 
Image Preview Browser 
Path Lists 
Image Lists 
Slide Shows 
Image File Properties 
 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
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Thumbnail Preview Windows 
 
Thumbnail preview windows are using in many image adjustment operations for one of two reasons: 
 

To show a sample of the image before and after an image processing operation has been applied. 
 

To allow one to sample a pixel position to set a color or tolerance reference point needed by certain 
methods. 

 
For example, the Hue and Saturation method shows a dialog window with Before and After thumbnail 
windows: 
 

 
 
Thumbnail windows always display the image information at actual pixels (100% magnification). Since the 
sample can be relatively small compares to the source image, you can pan the window by dragging it with 
the mouse. 
 
Before and After Windows 
The Before thumbnail window shows a sample of the current image without any adjustments. The After 
window shows the image, at the same coordinates, adjusted according to the operation you have 
selected. 
 
Sample Point Windows 
Some operations show only one thumbnail window, such as the Selection Separation tool. The thumbnail 
windows for these methods are used to set sample color points within the source image as a prerequisite 
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to use the method. 
 
Panning the Image Area 
You can a thumb image around to scroll the display area. Hold down SHIFT while dragging to increase 
the panning rate. If both Before and After windows exist, they are linked together. Scrolling either window 
will scroll both of them. 
 
Zooming the Source Image 
You can right click on either image to zoom the original image window to 100% and auto-center it on the 
click point. 
 
Auto Fit Image to Window 
You can right click while holding down SHIFT to zoom the original image to fit the current window size. 
 
Setting the Center Point 
The default position for a thumbnail image in a dialog window is the center pixel of the source image. For 
very large images, you may have specific areas that would consistently provide a good source for the 
sample thumbnails. You can lock the center point for thumbnail previews using the Hotspot Tool. Simply 
click anywhere in the source image with this tool to set the thumbnail center point. 
 
Related topics: 
 
Creating a New Image 
Loading and Saving 
Supported File Formats 
Duplicating Images 
Clipboard Usage (Cut, Copy, Paste) 
Temporary Images and Undo 
Filling and Images 
Clearing Images 
Reverting to Saved Images 
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Auto Trim Tool 
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The auto trim tool is used to eliminate borders containing background color information from an image. 
When used with along with the Selection Separation and Edge Deskew tools, you can easily create 
separate images from multiple-document scans. 
 
Trimming an image involves examination of the edge colors, and working inwards toward the center until 
a pixel colors are detected that are sufficiently different from the background color. A noise elimination 
option is available that can be used to ignore small random areas of color, such as dust on the scanning 
glass, or scratches and imperfections in the image. 
 
Automatic and Point Sampling Modes 
Automatic sampling for the trim tool does not allow for any type of noise elimination. It is a fairly simple 
method based on just a tolerance setting. 
 
The other sample sources use pixel points that represent the background color. The non-automatic 
methods allow you to specify a minimum size for image data. Anything smaller is discarded as noise and 
will become part of the trim area. 
 
Setting the Trim Areas 
Trim areas are only available when using the non-automatic sample source. They allow you to specify 
which edges of the image to actually apply the trim method to. The automatic method will always trim 
from every side of the image. 
 
Expanding and Cropping Edges 
Check the All Sides option to expand or crop the image on all sides equally. If you specify a negative 
amount, the image will be cropped after it has been trimmed. If you specify a positive amount, the image 
will be expanded on all sides and filled using the border color of your choice. 
 
Use the Left, Top, Right, and Bottom options to selectively crop or expand each side of the image. As 
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with the All Sides option, use negative values to crop the image or positive values to apply a border 
expansion. 
 
Image Noise Elimination 
Image noise elimination is only available with the non-automatic sample source methods, which use 
background point samples. If you enable this option, then any image areas that are smaller than or equal 
to the width or height you specify will be ignored and counted as part of the background. 
 
The Hand and Color Sample Icon Buttons 
Use the hand icon button to drag and move the image thumbnail sample around. This allows you to see a 
part of the image at 100% scale. If you right click on the thumbnail sample, the original image will be set 
to 100% scale and auto-center to the same position as the thumbnail. If you right click while holding down 
the SHIFT key, then original image will be scaled to fit the current window size. 
 
Click on the eyedropper icon button to choose a new sample point for the trim operation. By default, the 
upper left pixel of the image is chosen as the “background reference” point. If an image has edge noise 

that makes using the upper left corner pixel unsuitable, scroll the preview window around and locate a 
suitable background sample color. 
 
Feedback Status 
The indicators below the thumbnail preview window show how many areas are eliminated as background 
noise, how many areas are counted as valid image data, and the progress of the trim analysis. For 
automatic image trimming, or when noise eliminate is disabled, these indicators will not be used. 
 
Tolerance Settings 
The auto trim method relies on a tolerance setting to determine what parts of the overall image are 
background and noise, and what parts are actual image data. A higher tolerance setting will reduce the 
amount of noise that could cause the trimming process to stop short of its goal. However, a higher level 
can also lead to selections that involve valid parts of the image data that you do not want to eliminate. 
There is a tradeoff that must be made to determine just how much image data becomes background to 
eliminate and how much data is valid image information. 
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Keyboard and Mouse Shortcuts 
 
This topic summarizes all of the keyboard and mouse shortcuts as applied to the Tool palette imaging 
options. 
 
Note: The references to the mode and alternate tool shortcut keys as shown in the Tools->Shortcuts 
menu assume the default keyboard template keys of F5, F6, F7 (alternate tool modes) and SPACE 
(special mode key). 
 
Rectangular/Elliptical Selection Tool 

F5: Rectangular Selection 
F6: Elliptical Selection 
SPACE: Set combination mode to Normal 
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Cursor Keys: Move the selection 
Cursor Keys + SHIFT: Expand Region 
Cursor Keys + CTRL: Contract Region 
Right Click: Cancel Selection 
Hold SHIFT: Create square/circle regions 
Hold CTRL: Add to region 
Hold ALT: Subtract from region 
Hold CTRL+ALT: Intersect region 
Cursor Keys during creation: Pan image window 

 
Freehand/Polygon Selection Tool 

F5: Freehand Selection 
F6: Polygon Selection 
SPACE: Set combination mode to Normal 
Cursor Keys: Move the selection 
Cursor Keys + SHIFT: Expand Region 
Cursor Keys + CTRL: Contract Region 
Right Click: Cancel Selection 
Hold SHIFT: Constrain polygon lines to 45° angles 
Hold CTRL: Add to region 
Hold ALT: Subtract from region 
Hold CTRL+ALT: Intersect region 
Cursor Keys during creation: Pan image window (polygon only) 
Hold CTRL during polygon creation: Close the polygon 

 
Magic Wand Tool 

SPACE: Set combination mode to Normal 
Cursor Keys: Move the selection 
Cursor Keys + SHIFT: Expand Region 
Cursor Keys + CTRL: Contract Region 
Right Click: Cancel Selection 
Hold CTRL: Add to region 
Hold ALT: Subtract from region 

 
Move/Create Floating Image Tool 

SPACE: Toggle move/copy mode 
Cursor Keys: Move the selection 
SHIFT: Lock move horizontally 
CTRL: Lock move vertically 
Right Click Inside Floater: Paste it 
Right Click Outside Floater: Cancel it 

 
Image Grabber Tool 

Right Click: 10X scroll rate 
Cursor Keys: Scroll 1 pixel 
Cursor Keys + SHIFT: Scroll half window 
Cursor Keys + CTRL: Scroll to edges 
SPACE: Fit image to window 

 
Zoom Tool 

Right Click: Reverse zoom direction 
SHIFT: Reverse zoom mode 
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Cursor Keys: Scroll 1 pixel 
Cursor Keys + SHIFT: Scroll half window 
Cursor Keys + CTRL: Scroll to edges 
SPACE: Fit image to window 

 
Text Tool 

Right Click: Cancel active floater 
 
Shape Tool 

Right Click: Cancel active floater 
SPACE: Toggle antialias mode 
Hold SHIFT: Create square regions for shape size 
Cursor Keys during creation: Pan image window 

 
Pencil/Brush/Eraser Tools 

Hold SHIFT: Lock horizontal movement 
Hold CTRL: Lock vertical movement 

 
Line Tool 

Right Click: Paint polyline lines 
Right Click + CTRL: Cancel polyline lines 
Hold SHIFT: Constrain to 45° angles 
SPACE: Toggle polyline mode 
Cursor Keys during creation: Pan image window 

 
Blur/Sharpen Tool 

Hold SHIFT: Lock horizontal movement 
Hold CTRL: Lock vertical movement 

 
Dodge/Burn/Sponge Tool 

Hold SHIFT: Lock horizontal movement 
Hold CTRL: Lock vertical movement 

 
Paint Bucket Tool 
No shortcuts 
 
Image Cloning Tool 

SHIFT + Left Button: Set the cloning source point 
 
Measure Tool 

Cursor Keys during creation: Pan image window 
CTRL: Add second measure line when near an end point 
SPACE: Cancel measure lines 
Right Click: Cancel a line 

 
Cross Hair Tool 

SHIFT: Add second cross hair line 
Cursor Keys during creation: Pan image window 
SPACE: Cancel measure lines 
Right Click: Cancel a line 

 
Eyedropper Tool 
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F5: Color Sample Tool 
F6: Hotspot Tool 
F7: Transparency Tool 
SPACE: One Pixel Sample Mode 
Click + Drag: Move region in Selection sample mode 
Left Click: Foreground sample mode 
Right Click: Background sample mode 

 
Color Wand Tool 

Cursor Keys: Move the selection 
Cursor Keys + SHIFT: Expand Region 
Cursor Keys + CTRL: Contract Region 
Right Click: Cancel Selection 
SPACE: Set combination mode to Normal 
Hold CTRL: Add to region 
Hold ALT: Subtract from region 
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Creating a Database 
 

 
 
EzImage allows you to use more than one thumbnail database. However only one database may be open 
at a time. When you run the application for the first time, a default database named ThumbDef will be 
created in the Thumbs folder of the application path. If you wish to create a new database in addition to 
the default one, you may choose the database create option from either the application Browser-
>Thumbnails menu or from the thumbnail browser window’s own menu. The active thumbnail database 
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references is preserved when you close the application. Each time you access the thumbnail browser, the 
database will be opened using the last valid reference. If the database was moved or deleted outside of 
EzImage, the reference will be lost. In this case you will an error dialog window: 
 

 
 
You will have the option to create a new database or switch to an alternate one from within the error 
dialog window. 
 
Database Location 
The normal default location for new thumbnail database files is the Thumbs folder in the installation path. 
You can create or place a thumbnail database anyone on your system however, including CD-ROM or 
DVD (as read-only catalogs). 
 
Database Name 
A thumbnail database consists of 4 different files, with the following extensions: THD (image data file), 
PTH (path groups), FIL (file links), and CMT (comments). Comments are optional, but the file still needs 
to be part of the database set. When you create a new database, all of these files will initially contain no 
image references. Enter a file name here, but don’t include any path name or file extension. 

 
Password Encryption 
The encryption option uses a password to prevent anyone from altering your database files. Once a 
password is applied to a thumbnail database, you will not be able to add or remove thumbnail images. In 
addition, the thumbnail maintenance options will be blocked. The image data itself will be encrypted in the 
database as well. If you check the View Lock option, the database will also be blocked from being viewed. 
 
Using a View Lock 
Check this option to put a thumbnail view restriction on your database. You must provide a password and 
the encryption feature will be enabled by default. This will block any user from attempting to either modify 
or view your thumbnail database without providing the proper password. 
 
Specifying a Password 
The password is used to encrypt a database and prevent anyone from altering its contents. Once a 
password is in place, the database maintenance options are unavailable unless the password is provided. 
The password security also blocks addition and deletion of thumbnail images. It does not prevent 
someone from deleting the database files. Make sure you enter the same password in both fields 
provided. 
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Database Comment 
Any thumbnail database can be tagged with a comment of up to 128 characters. The comment, 
encryption, password, and view lock options can be changed at any time using the database 
maintenance options. 
 
Creating the Database File Group 
Click on Create to make the database file group. If you accessed the creation dialog window from the 
browser options, you may begin adding thumbnail images to the database. By default the mini-preview 
window is turned off in the thumbnail and catalog browsers. You should set up any preferences for 
thumbnail viewing if this is your first time using the application general preferences (press F2 to access 
the preferences from within the browser). 
 
Related topics: 
 
Thumbnail Database System 
Adding Images to a Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
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Thumbnail Image System 
 
The thumbnail database system used by EzImage stores smaller copies of your image files into a set of 
database files. The database files store path and file references, the thumbnail image data, and optional 
comment text into separate files, in a format that allows for both speed and flexibility for display and 
maintenance. 
 
When you install EzImage for the first time, there will not be any form of thumbnail database. The first 
time you attempt to use the thumbnail browsing option, a database will automatically be created for you 
with the name of ThumbDef. This database will be placed into the Thumbs folder of the application path. 
 
Browsing and Adding Images 
The basic concept of the thumbnail system is to add images from one or more file folders on your system 
to the database. Thumbnail images are not displayed “on the fly” as you navigate between folders. You 

select one or more images and pass this list to the thumbnail generator, which in turn reads the source 
image files, creates smaller representations of a size you can specify, and stores them into the database. 
When you browse a folder, all images are displayed in a row and column arrangement. If a thumbnail 
exists for the source image, it will be displayed within the thumbnail grid. If a source image does not have 
thumbnail assignment, it will appear as a blank space in the browser window. 
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Catalog Browse Mode 
This is an alternate method to view a thumbnail database. In catalog mode, only the images that are 
currently available in the database are available for viewing. You can’t add new images in catalog mode, 
or examine images in file folders that are not currently part of the database. The normal system folder 
tree that is available in the standard thumbnail browser is replaced by a list of all the folder path names 
contained in the database. This mode was designed for archiving images on read-only media, such as 
CD-ROM or DVD. 
 
Full Browse Mode 
This is a method by which all images in a thumbnail database are displayed at one time. By using full 
browse mode, you can see every available thumbnail image without the need to navigate paths and 
folders. In addition, once you select any image in this mode, you may choose to switch back to the 
standard browse mode. When you do this, the folder that the selected image was in will automatically be 
set. 
 
Basic Thumbnail Options 
The application general preferences contains options for defining various aspects of the thumbnail 
database system: 
 

Colors for the thumbnail background area, borders, the cursor selector, text, and information labels. 
 

The thumbnail width and height used to create new images. 
 

Size and color reduction methods to set the quality and compression levels of the thumbnail images. 
 

Storage formats for the thumbnail images within the database. 
 

Settings for information labels attached to each thumbnail image. 
 
Image Searching 
The thumbnail system provides a facility to search the database using file pattern, date, and size filters. If 
you have attached comments to the thumbnail images, you may also search on the comment text. 
 
Comments 
You can attach comments of up to 128 characters for one or more thumbnail images. You can use these 
comments in the slide show system to be displayed along with the images. 
 
Security and Encryption 
The database system contains a basic password-level encryption system. You can use a password to 
prevent unauthorized persons from viewing, modifying, or adding images to your database. When a 
password is applied to a database, the image data file is encrypted as an added security feature. You can 
add or remove passwords and encryption at any time. 
 
Maintenance and Repair 
There is a simple yet flexible maintenance and repair system for the database. The maintenance facility 
allows you to perform the following actions: 
 

Reclaim free space that arises when thumbnail images are deleted. 
 

Remove images from the database one folder at a time. 
 

Verify for missing image files or folders. 
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Rename the paths for folders that have been moved to another location on your system. 

 
Add or remove passwords and encryption. 

 
Add or remove view locking, which prevents unauthorized persons from viewing the database 
images. 

 
Export facility for the database. 

 
The database repair feature can be used to generate a new database from one that has corrupted data in 
one or more files. The file formats used for the thumbnail system contain several data integrity features 
that ensures if one or more areas of a data file becomes corrupted, the remaining information can be 
recovered into new database files. 
 
Exporting Image Information 
The maintenance options include one to export all thumbnail database information to a comma or tab 
delimited text file. There are many options available to set the level of detail that you wish to export. 
 
Integration with Slide Shows, Path Lists, and Image Lists, and Preview Browser 
The thumbnail system provides options to add files to an image list or slide show script, path names to a 
path list, or to switch from thumbnail view mode to image preview mode directly, while retaining the 
current path and selected file name reference. 
 
For detailed help topics on the various features of the thumbnail database system, click on any of the 
following links: 
 
Thumbnail Browse Mode 
Catalog Browse Mode 
Adding Images 
Creating a Database 
Thumbnail System Preferences 
Searching for Images 
Maintenance 
Repair 
Exporting Database Information 
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Maintenance and Repair 
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Path Groups 
Thumbnail database files are based on Path Groups. For every image you add to the database, the path 
group list is always checked to see if a path references exists for the source file. If it doesn’t, a new path 
is added to the group list. Each path in the group is maintained as a separate area of the database, for 
speed, storage space, and data integrity reasons. 
 
The maintenance screen displays the contents of a database by path reference. When you perform 
maintenance on a database, the path group represents the initial reference point to apply any option. For 
each path in the list, there may be one or more file links assigned to it. For each file link, there will be only 
one thumbnail image link. For each file link, there can optionally be one comment text link. A database 
consists of 4 data files: 
 

Path groups have an extension of .PTH. 
File links have an extension of .FIL. 
Image thumbnails have an extension of .THD. 
Comments have an extension of .CMT. 

 
For options that affect specific paths in the list, simply select the ones you wish to modify. For general 
space reclamation and export options, the path selection is not used. 
 
Database Size, Free Space, and Image Count 
The size indicator is the total size of the 4 thumbnail database files. 
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The free space indicator represents unused areas of the database files, which can be reclaimed.  
 
Active images are those that have valid thumbnail image data. 
 
Deleted thumbnails no longer have valid image data, but retain their identity in the database until you 
perform a maintenance operation. When a database has had its free space fully reclaimed, the free 
amount will be 0 as will the deleted image count. 
 
Comment 
Any thumbnail database can be tagged with a comment of up to 128 characters. 
 
Password and Encryption 
The password is used to encrypt a database and prevent anyone from altering its contents. Once a 
password is in place, the database maintenance options are unavailable unless the password is provided. 
The password security also blocks addition and deletion of thumbnail images. It does not prevent 
someone from deleting the database files. Make sure you enter the same password in both fields 
provided. You must also ensure that the Encryption option is checked. 
 
The encryption status can be changed at any time. You are free to add or remove encryption and the 
password from a database by simply unchecking the Encryption option. 
 
View Locking 
Check this option to put a thumbnail view restriction on your database. You must provide a password and 
the encryption feature will be enabled by default. This will block any user from attempting to either modify 
or view your thumbnail database without providing the proper password. 
 

Leave Paths Intact 
If this option is left checked, then path rename or deletion operations will not be applied to the database 
during a maintenance operation. 
 
Rename Changed Paths 
When you use the change base path option from the menu, the path name is changed in the list, but is 
not applied to the database yet. You must check this option then begin a normal maintenance procedure. 
The Leave Paths Intact option must also be unchecked. 
 
Delete Selected Paths 
Check this option to delete the paths that are currently selected in the list. If you have the Reclaim Free 
Space option checked as well, then all thumbnail images linked to the deleted paths will be removed from 
the database. The Leave Paths Intact option must also be unchecked. 
 
Reclaim Free Space 
Check this option to reclaim all of the free space shown below the path list window (Free: indicator). A 
backup of the existing database is always made before a maintenance procedure, to ensure that if 
anything happens while it is in progress, the original files will remain intact. 
 
Delete for Non-Existent Files 
Check this option to remove all thumbnail image links that point to non-existent source files. Since it is 
possible that thumbnail images can point to removable media such as CD-ROM and DVD, use this option 
with caution, as the files may exist, but simply be offline. 
 
Starting a Maintenance Operation 
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The Begin Maintenance menu option will apply all the necessary database adjustments that appear at 
the bottom of the dialog window. In order to preserve the integrity of the existing database, the 
maintenance procedure will create a new version from the existing one, and only switch to the new 
version if no errors were encountered. 
 
Verify Broken Paths 
This option will check all path references to the source files to ensure that the original images are still 
linked to the thumbnail images. It is not necessarily an error if the path names don’t t link to actual source 
images – for example, catalog-based databases may only maintain a thumbnail list without the original 
source image files. Nevertheless, choose this option to simply verify if any paths do not point to a valid 
system folder. 
 
Verify Missing Files 
This option will scan every file reference in the thumbnail database looking for missing source files. Any 
paths missing at least one image file reference will be marked with an appropriate icon in the list. You can 
use the database export option to determine which files are actually missing. 
 
Change Path 
This option allows you to change the base reference path for any set of thumbnail image files. Since 
thumbnails are grouped in the database by the path reference, changing one path name in the list will 
affect all thumbnails that reference it. 
 
Export Database 
Use the export option to generate a detailed tab or comma-delimited text file of a thumbnail database, 
containing all the basic thumbnail information. 
 

Related topics: 
 
Thumbnail Database System 
Adding Images to a Database 
Creating a New Database 
Database Maintenance 
Database Repair 
Printing Thumbnail Images 
Catalog Browse Mode 
Searching for Images 
Exporting Database Information 
Thumbnail General Preferences 
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Slide Show File Errors 
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When playing a slideshow script, this dialog window will appear when an image file can’t be loaded, 
generally for one of the following reasons: 
 

The file doesn’t exist 
 

The file uses an unsupported encoding method 
 

There was a file decoding error 
 

The file is damaged 
 

The file is not the correct format given the file extension 
 

The file is locked by another application 
 
When an image file can’t be read and displayed, this dialog will appear if you have not enabled the Skip 
Errors option in the slideshow script preferences. With skip errors enabled, the dialog will not appear. 
Instead, when you close the slide show viewer window, a dialog will appear showing the first file that 
encountered a read error, if any.  
 
You can use the Mark button to mark the problematic files in the script. When you close the viewer 
window, use the Browse->Slideshow->Marked Browse option to deal with these images. 
 
Related topics: 
 
Browsing Images 
Slide Show System 
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Unsharp Mask Filter 
 



EzImage Reference – Version 1.05 

 

 Page 398 

 

 
 
This method is used to sharpen the image with a minimum of noise. To reduce the noise, it starts by 
blurring a copy of the original image. The amount of blur depends on the Radius value. The filter then 
determines the difference between each pixel's value of the original image and the corresponding pixel's 
value in the blurred image. If the difference is greater than the Threshold value, then the difference 
between the pixel values is multiplied by the value in the Amount field and added to the original pixel 
value. 
 

To increase the thickness of the sharpened edges, increase the value of Radius. 
 

To increase the amount of sharpness, increase the value of Amount. 
 

To reduce the noise and eliminate the small edges or individual pixels that will produce noise in 
image, increase the value of Threshold. 

 
The Color Space choice affects the quality and speed of the operation. Use YUV color space for faster 
adjustments with a decrease in quality. 
 
Using the Thumbnail Preview Windows 
Many of the image adjustment windows contain either a Before thumbnail sample window and 
sometimes an After sample window as well. These small windows show an area of the active image at 
100% magnification. The Before window always shows the current image without any type of adjustment 
applied. If an After window is present, then it will show the result of the image adjustment. 
 
By default, the sample area in each window will show pixels from the exact center point of the source 
image. The Hotspot tool can be used to lock the sample area to a new position in the image that will be 
used for windows that contain thumbnail previews. 
 
Navigation options: 
 

You can drag either thumb image around to scroll the display area to new areas of the source image.  
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Hold down SHIFT while dragging to increase the panning rate. 

 
You can right click on either thumbnail window to zoom the original image to 100% and auto-center 
on the click point. 

 
You can right click while holding down SHIFT to zoom the original image to fit the current window 
size. 

 
Previewing Image Adjustments 
In some cases, seeing an adjustment applied to the small sample thumbnail windows is not a good 
indication of the overall correct of the entire image. Therefore many operation dialog windows will contain 
a Preview button, which allows you to see the adjustment applied to the entire source image. 
 
Committing and Canceling Changes 
If you click on OK after performing a preview (without any further adjustments to the operation 
preferences), the image will be left as is, since the preview option already made the adjustment. If you 
click on OK without performing a preview first, then the operation will be applied before the dialog window 
closes. 
 
Click on Cancel to close the dialog window if no operation has been performed, or to cancel an operation 
that is currently in progress. You may also click on Cancel to stop a preview adjustment from being 
applied. 
 
Related topics: 
 
Average Filter 
Gaussian Blur 
Median Noise Reduction 
Motion Blur 
Sharpen and Blur 
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Fitting a Window to an Image 
 
The View->Window to Image option will attempt to fit the window to the current image without the need 
for scroll bars. This operation will fail if the resulting window is below a predetermined minimum area size, 
or if the window would exceed the dimensions of one full screen at the current display resolution. 
 
Before Window to Image: 
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After Window to Image: 
 

 
 
Related topics: 
 
Image Windows 
Setting Magnification Levels 
Window Arrangements 
Fitting an Image to a Window 
Image Information Overlays 
Window and Cross Hair Rulers 
Close vs. Close All 
Display and Dithering Quality 
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Setting Magnification Levels 
 
The following options are available from the View menu to adjust the magnification level for the image in 
the active window. 
 
Actual Size 
This option will change the magnification level to 100% scaling (actual pixel size). If you have the general 
preferences option for Auto-resize Window on 100% Zoom enabled, then the window will be adjusted to 
fit the image without scrollbars, if possible. 
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Zoom to Selection 
If you create a selection region, you can use this option to zoom in on just the selected area. If the aspect 
ratio of the image window and that of the region area are different, there will be image areas shown that 
were not part of the original region area. 
 
Zoom In and Zoom Out 
Use these options to zoom in and zoom out one level of magnification. Zoom level increments in EzImage 
are (in percent):  
 

5 
6.25 
8.33 
12.5 
16.7 
25 
33.3 
50 
66.7 
100 
200 
300 
400 
500 
600 
800 
1200 
1600 

 
Zoom To 
You can specify a numeric level of magnification from 5 to 1600 percent, in any fractional amounts. 
EzImage zoom levels are accurate to .01%. 
 
Zoom to Maximum 
When working with very small images, such as icons and cursors, it is convenient to work on these 
images at the maximum level of magnification, which is 1600%. This menu option can be dropped on to 
the script palette or assigned a shortcut key for easier accessibility. 
 
Related topics: 
 
Image Zoom Tool 
 
Image Windows 
Window Arrangements 
Fitting a Window to an Image 
Fitting an Image to a Window 
Image Information Overlays 
Window and Cross Hair Rulers 
Close vs. Close All 
Display and Dithering Quality 
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File Type Associations 
 
A common method for viewing data files in Windows is to double click on a file within an application such 
as Windows Explorer. Windows will then check the system Registry to determine the application that is 
associated with the file type based on its extension. If a valid association is found, Windows will launch 
the application and provide the data file name as a parameter for opening. 
 
EzImage by default does not take control of image file types and create the associations automatically 
when it is installed. Image file formats are very popular and can be opened by several applications, some 
of which may be installed on your system. SoftPro’s stance on file associations is to let you decide about 
associating file formats with EzImage. 
 
The procedure to associate image file formats with EzImage is actually controlled with a small external 
program, which is accessible from the Help menu as File Type Associations. The file itself is called 
EZIMFT.EXE and is located in the application installation path. The early release builds of EzImage did 
not include this file, therefore we have made it freely available on our web site for download. 
 

 
 
The association application has only two options: Associate and Remove. 
 
Creating the Association 
Click on the Associate button. A check will be made for the for the following: 
 

EzImage is currently installed on your system 
 

The associations have not already been assigned 
 
A backup reference to the current application association is always made, so that you can easily remove 
the EzImage link. 
 
You will need to restart your system after creating the EzImage associations since the registry information 
is pre-loaded by Windows when it starts. 
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Removing the Association 
Click on the Remove button. If EzImage is still associated with one or more image file types, the links will 
be restored to use the previous application. 
 
It is recommended that you remove the EzImage association first if you intend to uninstall the application. 
You can always run the EZIMFT program at any time after EzImage has been uninstalled and the links 
will be properly restored. 
 
As with the assignment option, you will need to restart Windows for the restoration to take effect. 
 
Photoshop PSD File Types 
EzImage will not associate itself with this file format. The assumption is that if you are maintaining PSD 
format files on your system, you have Photoshop installed, which can handle the PSD format properly 
(EzImage does not support any internal information in PSD files with the exception of the main image 
data). 
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Image Finder Tool 
 
The Image Finder tool is a basic file searching method that will help you locate images on your system. 
You can search by path, drive, or by multiple paths using path list files. Searching includes image content 
level as well, so that you can look for images with a specific size, resolution or bit depth. 
 
Basic Search Options 
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Scan Level 
 
Specific Path: This will search images within a specific folder. Use the browse button to the right to set 
the path name. It will appear beneath the dropdown list. To search all subfolders within this path, make 
sure you check the Include Subfolders option. 
 
Driver Letter: Select a drive from the dropdown list that appears when you select this option. Drive 
searches apply to fixed disks, removable media, CD/DVD drives and mapped network connections. They 
do not include floppy disk drives or RAM disks. 
 
All Hard Disks: This option searches all fixed disk drive types for images. 
 
Path List: This option will search for images using a path list file. This file is a plain text file with an 
extension of .PLF, and contains one text line per path. The path names are fully qualified and can 
included UNC-based network shares. If you check the Subfolders option, any paths that are subfolders 
within another entry in the list will be eliminated from the search. 
 
File Patterns 
EzImage file pattern filters are equivalent to the older MS-DOS style wildcard-based file names. The filter 
consists of one or more wildcard strings that match to a single file name. 
 

The asterisk (“*”) character matches zero or more occurrences of any character. 
 

The question mark (“?”) character matches one occurrence of any character. 
 

You must specify a filter string for both the file name and the file extension, separate by the period 
(“.”) character. 
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To match on multiple patterns, separate them with a semi-colon character (“;”). 

 
This is contrary to Win32 (95,98,NT,XP) based wildcard conventions, so please be aware of the 
difference. If a file contains multiple periods, as in SAMPLE1.23.96.BMP, the file name portion would be 
SAMPLE1.23.96 and the extension would be .BMP. Do not use the asterisk (*) by itself to match all files 
(Use *.*). 
 
File Types 
This option defines the set of image formats that will be involved in a search. By default, all supported 
formats are checked. The file type filter takes precedence over the regular file pattern, and can be used 
together. 
 
Exclusions 
Exclusions are based on the contents of a second path list file. In this case, any paths encountered in a 
search that match an entry in the exclusion file will be eliminated from consideration. To remove an 
exclusion file, click on the Cancel button within the file open dialog window. 
 
Export Image Details 
Check this option to include image details (width, height, resolution, format, compression type and bit 
depth) in exported text files. Since it requires an examination of the file contents, the search can take 
significantly longer to complete. 
 
Include Subfolders 
Check this option to include subfolder level searches for the Path and Path List-based sources (drive 
level searches always check every folder). For path list searches with this option checked, all path names 
that are subfolders of other paths in the list are eliminated to avoid duplicate searches. 
 
Saving Results 
 
Image List: This option places the search results in a sorted (by path then name) image list. Any current 
image list in memory will be replaced with the search list. The image list editor will be opened 
automatically when the search has completed. 
 
Path List: This option places the folder paths of the search results in new path list in memory. The image 
files themselves are discarded. The path list editor will be displayed with this list when the search has 
completed. 
 
Text File: This option stores the search results in either a comma-delimited or tab-delimited text file. 
Check on the Image Details option to include image information in this file. 
 
Units 
When exporting image details to text files, you can choose the unit type for the width and height. Note 
that if a file contains no print resolution information, values of 72 dots per inch will be used when saving in 
inches, centimeters, or millimeters. 
 
Resetting Options 
Click on Reset to restore all settings (except for file and path related information) to default values. 
 
Size Filters 
 



EzImage Reference – Version 1.05 

 

 Page 406 

 

 
 
Check the Enabled option to apply a size filter. Enter values in the size fields according to the unit size 
displayed next to each one. Depending on checked status of the Include/Exclude option, files with a 
sizes smaller and/or larger than these values will either be included or excluded from the conversion 
process. 
 
The Include Between option is used to filter all files between the smaller and larger file sizes. When this 
option is checked, the include/exclude size options are automatically disabled, as you will be defining a 
size range. 
 
If you check the Include/Exclude option, then all files with sizes larger or smaller than the size limits will 
be included in the conversion. With this option unchecked, all files with sizes larger or smaller than the 
size limits will be excluded. If the Include Between option is checked, then this setting is ignored. 
 
Date Filters 
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There are two types of date filters that can be applied. You can use recent days or months to include files 
with modification dates that only go back a certain amount of time. The date-based filter uses one or two 
dates specified in YYYY/MM/DD format. 
 
Depending on checked status of the Include/Exclude option, files with a dates older/newer than the date 
limit values will either be included or excluded from the conversion process. You can check one or both of 
the older/newer options. If you check both, then you will define an exclusion or inclusion date range, 
unless the Include Between option is checked. 
 
If you check the Include/Exclude option, then all files with dates newer or older than the date limits will 
be included in the conversion. With this option unchecked, all files with dates newer or older than the date 
limits will be excluded. If the Include Between option is checked, then this setting is ignored. 
 
The Include Between option is used to filter all files between the older and newer dates. When this 
option is checked, the include/exclude date options are automatically disabled, as you will be defining a 
date range. 
 
Limits 
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Width, Height, and Resolution 
By checking an option in the Limits tab, you will further restrict the search based on specific image 
information. This involves examining the contents of each file, which will in turn impact the search speed. 
Width and height limits must be specified in pixels, and resolution values must be in dots per inch. 
 
Bit Depths 
Check a bit depth option to only search for images with a specific number of bits per pixel. There is a 
range for each option to handle intermediate bit depths. 
 
1 Bit:       1 Bit 

2-4 Bits:    4 Bit 

5-8 Bits:    8 Bit 

9-24 Bits:  24 Bit 

25-32 Bits: 32 Bit 

32+ Bits:   32 Bit 

 

Maximum Images 
This value indicates when the search should stop if a certain number of image matches are found. By 
default the value is 50,000 images. To disable this value and use an unlimited number of matches, 
uncheck it. 
 
 
Related topics: 
 
Image List Editor 
Path List Editor 
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GIF File Import and Export 
 
EzImage supports GIF files from the standard open dialog and browser windows as a single image 
loading method. That is, if the GIF file contains many images, such as an animated GIF, the normal file 
open methods will only retrieve the first image. To work with a multiple image GIF file and the animation 
options available with this format, you need to use the import and export methods in the EzImage Tools 
menu. 
 
Importing a GIF file is fairly straightforward. Choose the import GIF menu option to load the images using 
the Windows file open dialog. Each image frame will be loaded into EzImage as a separate window, and 
given a file name with a sequence number indicating the order it was stored in the GIF. If any image in 
the GIF file contains a transparency color, it can be accessed with the transparency picker option of the 
Eye Dropper Tool. 
 
Exporting GIF Files and Animations 
 
Choose the export GIF menu option from Tools to see the following dialog window: 
 



EzImage Reference – Version 1.05 

 

 Page 410 

 

 
 
All of the indexed color images that are open in EzImage will appear in the list on the left. The images you 
wish to export are the ones in the list on the right. By default, any GIF images that were imported will 
appear in the list first, sorted by the same order in the GIF file. Any leftover images (ones that were NOT 
imported) will appear after this, in alphabetical order. All images will initially be place into the assigned list. 
 
Click on Select All to select all images in available image list. 
 
Click on Assign to add all selected images from the available list to the assigned list. You can also use 
the mouse to drag the selection from one list to the other and drop them. 
 
Click on Remove to remove any selected images from the assigned list. 
 
Click on Clear to remove all images from the assigned list. 
 
Click on Move Up to shift all selected images in the assigned list upward one position. If the selected 
images are not one continuos group, then they will be adjusted to move as a single condensed set of 
images. You can also use the mouse to drag the selection up or down in the list and drop it into a new 
position. Images will be dropped above the mouse release position. To drop images below the release 
position, hold down the SHIFT key. 
 
Click on Move Down to shift all selected images in the assigned list downward one position. 
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Click on Options to set the general options for GIF animation playback. If you are just exporting GIF 
images as a set of static data, you don’t have to set any of these options. 
 
Click on Frame to set the animation options for the selected images in the assigned list. Each image in 
the list is denoted as 1 frame in an animation loop. When setting frame options, you can select all of the 
images in the assigned list to ensure that one set of values applies equally to all frames. 
 
Click on Preview to preview the frames in an animated loop. Note that limitations in the current GIF 
engine used by EzImage does not allow for animation using the individual color palettes of each image in 
list. Exported GIF files will contain individual palettes for each image, but the animation playback will only 
show images using the global color palette. 
 
Click on Export to export the assigned images to a GIF format file. All animation information will be saved 
with the GIF file. 
 
 
GIF Animation Options 
 
You access this dialog window by clicking on the Options button: 
 

 
 
Width and Height 
The width and height values represent the container size of the image that will be used for GIF animation 
playback. For example, if you have a series of 64 x 64 pixel images in the GIF and use a 256 x 256 pixel 
container size, then you can use offset values in the frame options for each image to move the image 
within the container area. 
 
Background Color 
This is the background color of the container image when animated GIF files are displayed. It should be 
one of the color values available in the global color palette. 
 
Bit Depth 
This is the bit depth of the container image for playback of animated GIF files. It can be the same bit 
depth of the frame images (and usual is), but does not have to be. 
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Loop the Frame Images 
Check this option to continuously play animated the GIF images in an endless loop. With it unchecked, 
the frames will only play one time then stop. 
 
Global Palette 
Check this option to set the global color palette from a specific image or from an external EzImage palette 
file. With the option unchecked, the palette will be assigned by default from the first image in the GIF file. 
EzImage will always record a global color palette and use it for playback. This option is the way to pick a 
specific global color palette. 
 
External Palettes 
Click on the Palette button to load an external EzImage palette file (.PAL) into the global color palette. 
This palette does not affect the individual ones for each image in the GIF, but does determine the colors 
used for playback of an animation loop. 
 
Image Palette 
Click on the Image Palette button to assign the color palette of the selected image in the GIF assigned 
image list dialog as the global color palette. This option is a convention way to synchronize the global 
color palette to images in the GIF export list. 
 
 
GIF Frame Options 
 
You access this dialog window by clicking on the Frame button: 
 

 
 
Bitmap Display Delay 
This sets the delay between the selected frame(s) and the next frame in an animation loop. Typically you 
would set all of the frames to the same delay value unless you are trying to perform an atypical animation. 
 
Disposal Method 
This option determines what to do with the container bitmap image area after the current image frame has 
been played. 
 
Offsets 
You can move an image frame to any position within the container image by changing the offset values 
here. This can give the effect of motion by adjusting the position of the same image in multiple frames. 
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This offset is relative to the upper left corner of the container image. 
 
No Transparency 
Check this option to display the current frame without transparency. 
 
Use Transparent Color 
Check this option to display the current frame using a transparent color. Click on any color in the palette 
grid to set the transparent color. It will appear in the small color swatch to the right of this option label. If 
you click on any color in the palette grid, transparency is turned on by default. 
 
 
Top 
 
 

 
 
 

Image Stitch Tool 
 
This option, available from the Tools menu, allows you to join two open images into a new image that will 
encompass the dimensions of both. The stitch tool allows for both horizontal and vertical joins. 
 

 
 
Available Images 
All of the current open images will be shown in this list. To join images, they must have the same color 
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depth and if they are indexed color images, they must have the same color palette. If you wish to stitch 
indexed color images together that use different color palettes, convert them both RGB format before the 
stitch operation, then reduce the joined image back down to indexed color. 
 
Assigning the Left (or Top) Image 
Click on Assign L/T to assign the selected image in the available list to the left (or top) area for the 
combined image. You can only select one image and it can not be the same as the right (or bottom) 
image. 
 
Assigning the Right (or Bottom) Image 
Click on this button to assign the selected image in the available list to the right (or bottom) area for the 
combined image. If you have the floating selection option checked, then this image will be the floater in 
the combined image that you can position for proper stitching alignment. 
 
The assigned images will appear in the corresponding fields below the available list. 
 
New Image Name 
Enter a name for the combined image here. It can not be the same name as an existing opened image. 
 
Adding a Border 
You can place a border around the new image by entered a non-zero pixel value here. The source 
images will be centered within the new image to allow for an equal sized border on all 4 edges. Both the 
border color and any unused space in the new image will always use the current background paint color. 
 
Stitch Type 
You can choose to join the images horizontally (side by side) or vertically (one under the other). The new 
combined image will be sized so that the two images will butt together on the appropriate edge with no 
intervening pixel space. 
 
Floating Selection 
Check this option to make the second image (right or bottom) a floating selection in the new image. This 
is a very convenient feature of the stitch tool, as it allows you to align the second image to the first one. 
The stitch operation will complete when you paste the floater after it has been positioned. The floating 
selection will be aligned to the right (or bottom) edge of the first image. 
 
Click on the Stitch Button to stitch the 2 images together 
Top 
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De-Activation / Re-Activation 
 
EzImage is licensed per PC. You purchased a Single license for EzImage. 
 
*** Please NOTE: EzImage Licensing is per installation on a SINGLE hard drive & codes will only work 
on ONE machine/PC/Hard Drive. They are machine specific & are not transferable. Additional/New 
installs or installing to a different hard drive or Operating System will require additional licenses. Failure to 
adhere to these policies will invalidate your license & EzImage will fail to run. 
 
To install EzImage on a different PC, You will need to do one of the following two things 
  

Option #1: De-Activate EzImage, using the process described below, from the original PC  on which it 

was installed on. You MUST have internet access to De-Activate. 
Once we have verified the De-activation, you can install EzImage on the second PC and activate on the 
second PC. 
** Note ONLY one PC can be activated at a time, unless you have purchased multiple concurrent 
licenses 

** You may De-Activate / Re-Activate only TWO (2) times per license. 

  

Option #2: OR You can purchase a second license for the NEW PC at a reduced cost of $99.99 

(current regular price is $149.99). You must have already purchased one license to request the second 
license at the reduced cost. 
 

De-Activation Process 
 
To De-activate your copy, go to the Help Menu & click on About 
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Once the About Screen appears, hold down the SHIFT Key & RIGHT click on the EzImage icon. Then, 
type in 

 

REQUEST_DAC   in the field provided. 
 
Then Click OK. A screen will appear similar to the following 

 
 
Click OK to start your email program & fill in the following fields in the email and send it to us at 
staff@ezstamp.com. If you do not have email, then you will need to call us at 705-254-6201 & provide 
us with the information and codes. You MUST keep a record of these codes or you will NOT be able 
to Re-activate. 
 

Your Name: 
Address: 
Email: 
Tel#: 
 
Once we receive the De-Activation request via email, we will send you instructions & codes required to 
De-activate EzImage on this PC.   
 
*** DO NOT ATTEMPT to install EzImage on a second PC until you DE-ACTIVATE or purchase a second 
license. Failure to adhere to these policies will invalidate ALL copies of EzImage. 
 

mailto:staff@ezstamp.com
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Re-Activation 
 
Re-activation is similar to De-Activation. On the De-activated machine, go to the Help Menu & click on 

About. Once the About Screen appears, hold down the SHIFT Key & RIGHT click on the EzImage icon.  
 
Type in 

 

REQUEST_RAC   in the field provided.  

 
Follow instructions as they appear in the screens that will be presented to you. You MUST De-activate 
any other PC running EzImage before we will issue a Re-activation code to you and the required 
instructions. 
 
Top 
 


