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Chapter 1

Introduction

Welcome to EmbroideryStudio e4, the leading design software application for 
decorated goods industry professionals. No other product on the market 
provides the flexibility of EmbroideryStudio in creating designs for both 
embroidery and multi-decoration. It combines the embroidery capabilities of 
Wilcom embroidery software with the graphical capabilities of the CorelDRAW® 
Graphics Suite.

EmbroideryStudio products

The EmbroideryStudio e4 product suite consists of these product models:

Note  To identify sources of information relevant to your model and any 
additional elements you may have activated, see Product differentiation table.

Integration with CorelDRAW®
CorelDRAW® Graphics Suite is bundled as standard with some product models. 
CorelDRAW® and its sister product, Corel PHOTO-PAINT® can also be run as 
standalone applications. CorelDRAW® Graphics Suite features ‘best-of-breed’ 
bitmap-to-vector tracing, enhanced illustration capabilities, photo-editing 
together with a library of professional clipart images. CorelDRAW® needs to be 
registered before it can be used by EmbroideryStudio.
The built-in CorelDRAW Graphics window includes CorelDRAW® drawing tools 
which offer many techniques for drafting outlines and shapes on screen. Vector 
objects can be converted to embroidery designs. For a full description of the 
tools, refer to the onscreen help available from the Graphics mode Help menu.

Model Capabilities Applications

ES Designing ^ Professional digitizing and graphic design, lettering, and 
editing. Includes some e3 Elements as standard. Supports full 
range of optional ES Elements.

Larger logo embroidery 
businesses with digitizing

ES Digitizing * Professional embroidery digitizing. Fashion and textile 
production digitizing

ES Decorating ^ Professional lettering, customization and editing. 
Auto-digitizing and simple manual digitizing. Includes some ES 
Elements.

Small embroidery shops – 
replaces DecoStudio

ES Editing Full lettering, customization, editing, with machine 
connections.

Logos, retail shops, 
production shops

ES Lettering Full lettering, customization, with machine connections. Logos, retail shops

ES Ordering Search on customer designs and order status, add notes for 
production or tracking purposes, minor color editing.

Customer service and sales

^ Includes CorelDRAW® Graphics Suite X8 as standard. * Only available in certain countries.



Chapter 1   Introduction 2

System requirements

Before you install, or if you experience operating problems, make sure that your 
computer meets the system requirements.

PC specifications
Check CPU/RAM as well as hard disk space. The table below provides minimum 
system requirements.

Supported operating systems ‡
Although Windows® 7 (32-bit or 64-bit edition) is supported, we recommend 
updating to Windows® 10 (64-bit edition) or Windows® 8.1 (64-bit edition) with 
latest service packs installed. You will, however, need to uninstall any earlier 
versions of CorelDRAW® Graphics Suite. For latest operating system 
information, visit the Wilcom Support Center at www.wilcom.com.au/support.

Free hard disk space † 
EmbroideryStudio occupies up to 5GB of hard disk space, depending on options 
installed. CorelDRAW® Graphics Suite X8 also takes up an additional 3GB. 
However, you need additional free space for your applications to run smoothly.

Screen resolution ¥

Some controls may be hidden on the user interface if you run your monitor at 
low resolutions. The physical size of your monitor will have a bearing on the 
optimum screen resolution. Larger fonts will exacerbate the problem. If you 
experience visibility issues, try adjusting both screen resolution and font size. 
For example, a resolution of 1600 x 900 with a font size of 100% or 125% should 
be acceptable.

Component Minimum Recommended

CPU Intel® Core i3/5/7 or AMD Athlon™ 64 Latest Intel Core i7 processor

Operating 
system

‡ Microsoft Windows 10, Windows 8.1 or 
Windows 7, in 32-bit or 64-bit, all with latest 
Updates and Service Pack

Microsoft Windows 10 (64-bit Edition) all with 
latest Updates and Service Pack

Browser IE 11.0 or later Microsoft Edge or later

Memory 4 GB 8 GB or more

Hard disk size 80 GB 256 GB or more (Solid State Drive)

Free disk space † 40 GB 60 GB or more

Graphics card Support for Highest Color (32bit) and 
resolution (1600 x 900)

Support for Highest Color (32bit) and 
resolution (1920 x 1080 or higher)

Monitor ¥ 1600 x 900 screen resolution Dual monitors capable of displaying 1920 x 
1080 screen resolution

Mouse USB mouse USB mouse

USB port Required for software installation and security device.

Sound card Required for online video help.

Internet 
connection

Required for product activation and registration. Internet connection may also be required 
during installation in order to download Windows features such as .Net Framework 4.6.

http://www.wilcom.com.au/support
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Product installation & registration

EmbroideryStudio products are supplied both as packaged and downloadable 
products. Packaged software installation is supplied on USB memory stick, not 
DVD.

To install and register the product
1 Close all open programs but leave Windows running. 
2 Insert the EmbroideryStudio installation USB memory stick into the USB port.

The installation will automatically run. If not, manually open the setup.exe 
found in the installation folder.

3 Follow the on-screen instructions and attach the dongle when prompted.
4 Upon successful installation of the software and any additional Windows files, 

the Installation Complete screen appears.
5 Click Finish. The computer will reboot. The software can then be used with 

the security dongle attached.

Note  CorelDRAW® Graphics Suite may be installed together with Windows 
.NET Framework. To ensure that CorelDRAW® Graphics Suite is correctly 
installed with your embroidery software with the correct version of .NET, make 
sure you install it when prompted to do so. It can take up to 20 minutes or more 
to install the .NET Framework on some computers.

Security & registration
Don’t forget to register your copy of EmbroideryStudio. Product registration is 
required to validate the warranty. Also, by registering you will have access to:
 Wilcom support
 Live and recorded online training (as it becomes available)
 Information about product updates, events and special offers.

Note  You are also advised to register your CorelDRAW® Graphics Suite 
installation as this provides CorelDRAW® Standard Membership which gives you 
access to content – clipart, fonts, stock photos, templates – via Corel CONNECT. 
It also gives you access to the latest CorelDRAW® updates.

Software updates
With EmbroideryStudio e4, maintenance updates will be available periodically. 
You have the option of installing immediately or postponing till later.

Choose an update 
option
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Security device
EmbroideryStudio e4 is supplied with a new hardware dongle.

 Software is activated online and requires an occasional Internet refresh.
 End-user registration and details are required.
 Continuous Internet connection is not required for use of the software.

Multi-user network dongle
EmbroideryStudio e4 continues to provide network dongle support. This means:
 Licensed for set number of simultaneous users
 Ideal for educational institutions and corporate users
 Any ES e4 product model, including DesignWorkflow can be run
 All systems on the network are same product and options
 Three models of network dongle to support up to 10, 50, 250 users
 Can also use individual dongles for other products – if a local dongle is 

plugged into the machine, it will be favored over the network dongle.

Uninstalling the software
If for any reason you need to uninstall EmbroideryStudio, make sure you do so 
via the MS Windows® Control Panel > Programs and Features. Select a 
Wilcom program from the list – either EmbroideryStudio (main application), 
Nova PDF Printer, Nova PDF SDK COM, Wilcom PDF Printer, and/or the Wilcom 
Shell Extension.

Choose Wilcom 
application to 
uninstall
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Note, however, the side effects of removing ancillary programs but not the main 
application:
 Nova PDF: No PDF printing from EmbroideryStudio.
 Wilcom Shell Extension: No thumbnails/design info displayed in Windows 

Explorer or Design Library.

Product elements

EmbroideryStudio offers optional ‘Elements’ for Creativity, Production, and 
Speciality processes.

Element 1 2 3 4 5

Creativity

Shading & 
Open Fills

Add depth and dimension to your embroidery 
with powerful shadows, shades and open 
fills.

  – – –

Curved Fills *
Create unique, flowing stitch patterns that 
add motion and dimension to any closed 
object.

  – – –

Motifs
Create motif runs and both single and double 
motif fills. Apply 3D Warp distortion. Create 
and reuse motif patterns.

  – – –

Motif Runs 
Advanced ^

Create advanced motif runs with variable or 
gradient motif size and spacing effects. Motifs 
can also conform to varying size column 
shapes.

 – – – –

String Stitch ^

Create outline or filled shapes with 
overlapping ‘string art’ stitching to hold mirror 
pieces or for decorative effects. Known as 
‘Paghadi’ in India.

 – – – –

Freehand * Create embroidery the most natural way – as 
if you were drawing with pen and paper.   – – –

Spiral Fills ^
Create open stitching that follows the 
contours of a shape for some interesting 
visual effects.

  – – –

Custom Splits Add carving, embossing and other 
dimensional effects to your embroidery.   – – –

Photo Flash * Convert black and white, grayscale and color 
images into embroidery.    – –

Productivity

Team Names 
Advanced *

Save lettering layouts for reuse. With different 
logos and lettering, reuse makes teamname 
design simpler and faster.

    

Offsets 
Advanced

Embolden logos, badges and other designs 
with distinctive, colorful borders.    – –

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
 Included as standard   Modular ‘element’  ^ New Element in ES e4 * Improved Element in ES e4
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Included features
For details of the features included with each Element, click the links in the table 
below.

Auto Shaping
Use auto-shaping tools to weld, flatten, 
intersect, and other shaping operations to 
give you accuracy and speed.

  – – –

Auto 
Arrangements *

Automatically create reflecting borders, and 
wrap reflections around a center point to 
create wreath or kaleidoscope effects.

  – – –

Kiosk Mode ^
Use at retail outlets where fast and simple 
personalization of standard design layouts is 
required in consultation with customers.

    

Specialty

Embroidery 
Connect ^

Configure a wireless WiFI USB Stick network. 
Send designs wirelessly to multiple brands of 
USB capable embroidery machines.

    

Chenille Add chenille embroidery capabilities to a 
lockstitch embroidery digitizing system.   – – –

Schiffli Create and prepare lacework and emblems 
precisely and efficiently.   – – –

Font Creator Match logo type exactly or create unique 
ones all your own.   – – –

Single Sequin ^

Create artistic sequin designs with sequin 
runs and sequin fills for single sequin 
machines using automated predefined fixing 
stitches.

   – –

Sequins 
Advanced * Create embroidery files for single and 

twin-sequin dispensing machines.   – – –

Bling
Use any combination of stones, sizes and 
colors to light up your design. Includes bling 
lettering.

   – –

Virtual 
Decoration

Bring the look of embroidery to your printed 
designs. Includes high resolution TrueView 
images. Print in CorelDRAW Graphics.

   – –

Element 1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
 Included as standard   Modular ‘element’  ^ New Element in ES e4 * Improved Element in ES e4

Element Included features Reference

Creativity

Shading & Open 
Fills

Cross Stitch Fill Creating cross stitch fills

Stipple Fill Creating stippling effects

Accordion Spacing Creating accordion spacing effects

^ New feature in ES e4 * Improved feature in ES e4
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Color Blending Creating color blends

Curved Fills
Liquid Effect Creating curved fills with Liquid Effect

Florentine Effect Creating curved fills

* Contour Stitch Creating contoured fills

Motifs
Full Motif Fill Creating motif fills

Motif Run Creating motif runs

Create Motif Managing motifs

3D Warp Creating enveloped motif fills

Motif Runs 
Advanced

* Motif Run Creating graded motif runs

Motif Column Creating graded motif columns

String Stitch ^ String Creating string stitching

Freehand * Freehand Creating freehand embroidery

Spiral Fills ^ Spiral Fill Creating spiral fills

Custom Splits
Flexi Split Creating flexi-splits

Carving Stamp Making custom splits

User Defined Split

Photo Flash
Photo Flash Auto-digitizing with Photo Flash

^ Color PhotoStitch Auto-digitizing with Color PhotoStitch

Production

Team Names 
Advanced * Save As Teamname 

Template Teamname templates

Offsets Advanced Outlines & Offsets Generating outlines & offsets

Auto Shaping Shaping Tools Shaping objects

Auto 
Arrangements * Mirror Merge Mirroring & reflecting selections

Kiosk Mode Lettering Kiosk Lettering Kiosk

Specialty

Embroidery 
Connect ^ WiFi USB Stick EmbroideryConnect Machine 

Networking

Element Included features Reference

^ New feature in ES e4 * Improved feature in ES e4
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Resources & support

EmbroideryStudio provides various ways to access information about the 
software and how to use it.

Note  Screen illustrations in the documentation are representations, not exact 
duplicates of screen layouts generated by the software. Procedural descriptions 
may vary slightly from actual installations depending on current settings.

Onscreen documentation

Onscreen documentation is provided in two formats – HTML Onscreen Help and 
Adobe Acrobat. Components include release notes, user manual, onscreen help, 
as well as various supplements.

Chenille Chenille Chenille Supplement

Schiffli Schiffli Schiffli Supplement

Font Creator
Create Letter Creating custom fonts

Convert TrueType 
Font Converting TrueType fonts

Single Sequin
Sequin Run Creating sequin runs

Sequin Fill Creating sequin fills

Sequins 
Advanced

Advanced Sequin Sequin Digitizing

Sequin Fill Creating sequin fills

Twin Sequin Creating twin-sequin designs

Bling
Create Bling Bling Digitizing

Bling Lettering Creating bling lettering

Virtual Decoration Capture Virtual 
Decoration Bitmap

Outputting designs as virtual 
decoration

Element Included features Reference

^ New feature in ES e4 * Improved feature in ES e4

Access onscreen 
documentation

Access Wilcom 
online support 

Access information about 
your product configuration 
plus available updates

Access Wilcom 
online registration 
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Release notes
Release notes provide details of new features and major and minor 
improvements in the software, as well as known limitations and ‘workarounds’.

Onscreen help
Onscreen help provides quick access to general information on 
EmbroideryStudio features and step-by-step instructions. There are two types 
available – Wilcom Decoration Help and CorelDRAW Graphics Help.

Tip  Context-Sensitive Help is available for tools and dialogs by pressing the 1 
key.

User manual
Onscreen help provides quick access to general information on 
EmbroideryStudio features and step-by-step instructions. There are two types 
available – Wilcom Decoration Help and CorelDRAW Graphics Help. The 
latter can be accessed from the CorelDRAW Graphics Help menu.
The user manual can be accessed from the EmbroideryStudio Help menu or 
MS Windows® Programs folder. You can read it with Adobe Acrobat™ Reader 
which can be downloaded from the Adobe website.

Manual supplements

The EmbroideryStudio installation also installs a number of onscreen 
supplements depending on your product options. These are generally used in 
conjunction with the User Manual.

Machine Manager
This supplement documents the following product capabilities:
 Machine Manager Direct Connect
 Feedback from machines
 Machine activity reporting 
 Technical details of machine network setup.

Cross Stitch
This supplement is supplied with the ES Cross Stitch Option. It documents:
 Manual and automatic cross stitch digitizing
 Cross stitch editing
 Cross stitch lettering
 Handling cross stitch design files.

Sequin
This supplement is supplied with the ES Sequin Option. It documents:
 Setting up sequin mode
 Creating sequin runs and fills
 Converting objects to sequins
 Setting up twin-sequin designs
 Modifying sequin designs
 Digitizing individual sequins

http://www.adobe.com
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Chenille
This supplement is supplied with the Chenille Option. It documents:
 Chenille features within EmbroideryStudio
 Chenille machines, including chain, moss, needle height
 Chenille stitch types and effects.

Schiffli
The manual is supplied with the Schiffli Option. It documents:
 Schiffli features within EmbroideryStudio
 Read/output to Schiffli files
 Schiffli disk utilities, Fixpat, Defced.

Access online support

You can access online sales and support information easily from the Help menu. 
You will need a correctly configured web browser together with web access.

To access online support
 Wilcom Support gives you access to online support services. You need to be 

a registered user of the product.
 The Wilcom Website provides commercial information about Wilcom products 

and services.
 Wilcom Training gives you details of available product training, both online 

and face-to-face in your area or region.
 The Wilcom Video Gallery provides access to online video demonstrations.

https://wilcom.zendesk.com/hc/en-us
https://www.wilcom.com/
https://www.wilcom.com/en-us/gethelp/learning/classroomtraining.aspx
https://www.wilcom.com/en-us/gethelp/support/trainingvideos.aspx
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Chapter 2

Creating Designs with EmbroideryStudio

Embroidery design with EmbroideryStudio consists of turning basic artwork 
shapes into embroidery designs. EmbroideryStudio gives you the flexibility of 
creating embroidery objects using artwork as backdrops, or of directly 
converting digital artwork. You can take a mixed-mode approach as well, doing 
the bulk of the design by means of automatic conversion, followed by touch-ups 
and edits using the suite of EmbroideryStudio embroidery digitizing tools.

Planning designs

High quality embroidery starts with good design and forward planning.

Artwork
Electronic artwork in both bitmap and vector formats can be inserted, pasted or 
scanned into EmbroideryStudio for use as digitizing templates or ‘backdrops’. 
Likely sources include:
 Internet and CD clipart libraries
 Business cards, post cards and wrapping paper
 Samples in the Design Library
 Books of embroidery patterns
 Children’s story books
 Printed table cloths or tea towels
 Original artwork – e.g. children’s drawings.

Caution  Unless you are an experienced digitizer, do not use complicated 
artwork. Also, be sure to check the copyright of any images you have not created 
yourself. If unsure, contact the relevant supplier to seek their permission.
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Characteristics of good design
Good design is enhanced by the use of correct backing, tension and a good 
quality embroidery machine. Keep the following points in mind when digitizing 
your design and assessing the final output:

The stitched-out design should also have the following characteristics:
 Design looks good – shapes, colors, balance
 Shapes are filled with correct fill and outline stitches
 Details are clearly defined
 Stitches are neat, smooth and even
 Stitches angles follow design shapes
 Lettering is clear and easy to read
 The design stitches out efficiently on the machine
 Shapes are stitched correctly – no unwanted gaps
 The fabric has not puckered around the stitched areas
 The design is free of loose ends.

Embroidery creation techniques

Depending on your level of product, there are two fundamental design modes in 
EmbroideryStudio:
 CorelDRAW Graphics: This mode allows you to create or edit graphic 

designs using the CorelDRAW® Graphics Suite toolset.
Wilcom Decoration: This mode allows you to create and edit embroidery 

designs using an embroidery digitizing toolset.

Note  For a full description of the CorelDRAW® Graphics Suite tools, refer to the 
electronic User Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the onscreen help available from the Help menu.

Details are clearly 
defined

Shapes are filled with
appropriate fill and

outline stitches

Stitches are angled to 
match shapes

Design looks good—
shapes, colors, balance

Lettering is clear and
easy to read
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Using electronic artwork
There are two broad categories of artwork file, both of which can be imported 
into EmbroideryStudio for use as digitizing backdrops – vector and bitmap. 
CorelDRAW Graphics supports the automatic and semi-automatic digitizing of 
both bitmap images and vector graphics. The quality of the resulting embroidery 
greatly depends on the type and quality of the original artwork.

Preparing images for digitizing
Generally speaking, vector graphics preserve the picture quality when resized, 
whereas bitmap images cause problems of pixelation and image degradation 
when enlarged or scaled down. In order to make bitmap images more suitable 
for automatic digitizing, EmbroideryStudio provides image processing 
capabilities. See Digitizing with Bitmaps for details.

Digitizing shapes manually
You trace shapes and lines over electronic artwork using various digitizing on 
‘input’ methods. Using a bitmap image in this way is like using an enlargement 
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drawing on a digitizing tablet, except that everything is done on screen. See 
Embroidery digitizing for details.

Converting artwork to embroidery
EmbroideryStudio lets you convert vector objects directly to embroidery objects. 
In fact, entire vector designs can be converted to embroidery. You can modify 
these designs as you wish. You can also convert embroidery to vector graphics. 
See Converting objects with CorelDRAW Graphics for details.

Tip  CorelDRAW® Graphics Suite lets you trace bitmaps to convert them to fully 
editable and scalable vector graphics. You can trace scanned sketches, artwork, 
digital photos, and logos and easily integrate them into your designs.

Object-based embroidery

In EmbroideryStudio, you build designs from basic shapes or ‘embroidery 
objects’. They are called ‘objects’ because they are discrete entities which can 
be manipulated independently of each other. These are like ordinary vector 
objects in that they have certain defining characteristics or ‘properties’ such as 
color, size, position, and so on. They also have properties unique to embroidery 
such as stitch type and density.

Note  In EmbroideryStudio, vector and embroidery objects are in fact 
inter-convertible since they share many of the same characteristics. See also 
Converting objects with CorelDRAW Graphics.
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Design shapes and stitching sequence
The embroidery objects comprising a design form a stitching sequence. Before 
creating an embroidery design, it is good practice to analyze and plan shapes 
and stitching sequence in advance. Shapes need to be clearly defined to make 
them easy to embroider. The best ones have relatively constant width, with 
smooth edges, no sharp turns and no small, protruding details. Outlines and 
details should always be stitched last.

If you are digitizing manually, objects are stitched out in the order they were 
created. In other words, the digitizing sequence defines the stitching sequence. 
If you have converted an electronic design, EmbroideryStudio uses automatic 
sequencing to create the optimum stitching sequence. Auto-sequencing 
attempts to generate embroidery designs which are economical to produce, with 
minimal down time, and accurate registration of textures and colors.

Mixed-mode approach
If you take a mixed-mode approach, you may do the bulk of the design by 
means of automatic conversion, and touch-ups and edits using the suite of 
EmbroideryStudio embroidery digitizing tools. In addition, you can always 
manually adjust the stitching sequence to improve the stitchout, for example, to 
minimize color changes. See also Automatic digitizing.

Object viewing and selection

EmbroideryStudio provides many viewing modes to make it easier to work with 
your designs. View a design at actual size or zoom in for more detail. Pan a 
design instead of scrolling, or quickly change between one view and the last. 
Show or hide outlines, stitches themselves, or view designs in TrueView™.

Understanding stitching sequence
When working with embroidery designs, you can check the stitching sequence 
by ‘traveling’ through it by means of color blocks, embroidery objects, or even 
stitch-by-stitch. Alternatively, simulate the actual embroidery design stitchout 

1

2

3

4

5
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on screen. You can also preview designs in different colors on different 
backgrounds by selecting from predefined colorways. See Viewing stitching 
sequence for details.

Selecting embroidery objects
EmbroideryStudio provides various ways to select 
embroidery objects. Modify the design as a whole or 
select individual objects for more precise 
modification. The Color-Object List provides an 
easy way to select objects and colors in a design and 
access their properties. Use it also to group and 
ungroup, lock and unlock, and show and hide objects. 
See Selecting objects for details.

Digitizing embroidery shapes

In addition to the automated and semi-automated techniques EmbroideryStudio 
provides for creating embroidery designs, it also contains a suite of manual 
digitizing tools. These are similar to graphics tools except that the end result are 
embroidery rather than vector objects. It is important to be familiar with manual 
digitizing methods in order to fully understand the process, the types of objects 
created, and the problems associated with embroidery digitizing.

Digitizing simple & complex shapes
There are tools for digitizing filled shapes with turning stitches and fixed stitch 
angles, with or without holes. There are also tools for creating columns and 
borders of fixed or varying width. See Embroidery digitizing for details.

Digitizing outlines & details
EmbroideryStudio provides tools for creating outline stitching of varying 
thicknesses and styles. They are typically used to add outlines and details to 
designs. There are tools for creating simple run stitching as well as decorative 
outlines using predefined motifs. Backstitch is an older-style, adaptable stitch 
which can be used for delicate outlines. Stemstitch is thicker and can be used to 
mimic hand-sewn embroidery. Occasionally you may even need to digitize 
individual stitches. See Digitizing outlines & details for details.

Outlines

Details

Columns

Free-form 
shapes
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Stitch types
The most important property of all embroidery objects is their stitch type. The 
software uses object outlines and the associated stitch type to generate stitches. 
Whenever you reshape, transform or scale an object, stitches are automatically 
regenerated. See Stitch Types for details.

Threads & colorways
When digitizing, you select thread colors for objects from the color palette. This 
contains a selection of colors tailored to each design or color scheme. The 
particular ‘colorway’ represents the actual thread colors in which a design will be 
stitched. You can define multiple color schemes and switch between them. See 
Colorways for details. 

For each colorway you define, you can select colors from commercial thread 
charts or define your own. Search for particular threads by specific code. 
Automatic thread color matching helps you locate thread colors based on closest 
match across one or several thread charts. You can also match thread colors 
from imported graphics – vector or bitmap.

Design backgrounds
EmbroideryStudio also lets you set the background color, fabric, or product of 
the current colorway for more realistic previews and presentations. The 
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background is saved with the colorway. See Fabric & product backgrounds for 
details.

Properties, fabrics, styles & templates
Object properties are stored with each object whenever you save a design. 
These properties determine how stitches will be regenerated whenever you 
reshape, transform or scale an object or entire design.

Default properties are stored with the design template and form the basis of all 
new designs. These may be overridden by fabric settings which are 
automatically adjusted to suit different fabric types. These in turn may be 
overridden by individual property settings determined by the digitizer. See 
Object Properties for details.

Underlays & pull compensation
Embroidery stitches pull fabric inward where needles penetrate. This can cause 
fabric to pucker, stitch bunching, and/or unsightly gaps to appear in the 
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embroidery. EmbroideryStudio includes many techniques for achieving smooth, 
even placement of stitches, and the elimination of gaps in designs.

For an object to sew out correctly, it must have correct stitch spacing, sufficient 
pull compensation, together with a suitable underlay for the particular 
combination of cover stitch type, object type, object shape, and fabric. See 
Underlay & Pull Compensation for details.

Embroidery connectors
Connectors link objects in a design. They can 
be run stitches or jumps. Travel runs are 
typically used to connect segments within 
filled objects. You can use automatic settings 
to generate connectors, trims and tie-offs, or 
add them manually. You can change 
connector settings for a whole design or 
selected objects. If you prefer to add tie-offs 
and trims as you digitize, you can turn off 
automatic connectors altogether. See 
Embroidery Connectors for details.
EmbroideryStudio also allows you to 
automatically connect first and last stitches 
of a design. This makes it easy to position the 
needle before stitching, and reduces the chance of it hitting the frame. See 
Setting auto start & end for details.

Automatic digitizing

Depending on your product level, EmbroideryStudio offers a variety of 
complementary tools and techniques for automatically digitizing suitably 
prepared artwork.

Auto-tracing bitmap artwork
Use Auto Trace To Vectors to create vector outlines from bitmap images. You 
can then convert these to embroidery objects using a variety of input methods. 
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Auto Trace To Vectors can find holes in shapes – both inside and outside 
boundaries are detected. See Auto-tracing bitmap artwork for details.

Auto-digitizing image shapes
Auto-Digitizing tools provide everything necessary to digitize shapes in bitmap 
images and vector graphics automatically without using manual digitizing 
methods. See Auto-digitizing image shapes for details.

Auto-digitizing entire images
Smart Design automatically converts whole bitmap images to fully digitized 
embroidery. See Auto-digitizing entire images for details.

Turning satin

Tatami fill

Turning satin
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Auto-digitizing photographs
Use Color PhotoStitch or Photo Flash to create embroidery from photographs 
and other images. While Photo Flash designs consist of rows of single-color 
satin stitching, Color PhotoStitch produces variegated stitching using multiple 
thread colors. The overall effect is like multi-colored stippling. See 
Auto-digitizing photographs for details.

Advanced digitizing

EmbroideryStudio provides specialized productivity features as well as special 
effects and digitizing techniques.

Productivity techniques
Specialized digitizing features help to save digitizing time. EmbroideryStudio 
provides special input tools for circles, stars, and rings, as well as methods for 
creating repeated or ‘backtracked’ outlines. Remove underlying layers of 
stitching in overlapping objects to reduce stitch counts and prevent a build-up 
of stitches.
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EmbroideryStudio also provides tools for quickly creating outlines based on 
existing filled shapes, and vice versa. Add decorative borders such as rectangles, 
ovals, and shields to designs or selected objects using the Borders library. See 
Productivity Tools for details.

Decorative stitch effects
EmbroideryStudio provides many 
artistic effects and stitch types to 
create textured and contoured fill 
stitching. Create designs with a 
hand-drawn appearance, something 
which is difficult to achieve through 
conventional digitizing methods. 
Create rough edges, shading effects, 
or imitate fur and other fluffy textures. 
Stippling provides a method for 
creating textured fills of run stitching 
which meanders more or less 
randomly within a border.
Move underlying travel runs to the edges of an object so that they can’t be seen 
through open stitching. Vary stitch spacing between dense and open fill, 
producing shading and color effects which are difficult to achieve manually. 
Create interesting perspective, shading and color effects by blending two colored 
layers. Add cross stitching to fill large areas with low stitch counts.

Create interesting curved effects by shaping needle penetrations to follow the 
contour of digitized lines. See Specialty Stitching for details.

Textured & patterned fills
EmbroideryStudio provides special tools for creating textured effects from 
needle penetrations. Apply offset fractions and partition lines to tatami fills to 
create split-line patterns. Alternatively, use Program Split or Flexi Split to 
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create decorative fills from predefined patterns of needle penetrations. Select 
from the library or create your own. See Patterned Fills for details.

The Carving Stamp feature allows you to define a pattern of needle 
penetrations using a ‘carving stamp’ as a template. With User-Defined Split, 
create your own split lines when you want to add detail to filled objects. See 
Creating patterns with carving stamps for details.

Curved fills
EmbroideryStudio provides a variety of techniques to create curved fills. 

Contour is a curved fill stitch type – stitches follow the contours of a shape, 
creating a contoured, light and shade effect. Flexi Split is a decorative effect 
where one or more lines of a program split pattern are used in the object fill. 
Radial Fill generates radial turning stitching in several stitch types such as 
Satin and Tatami stitch. Use Florentine Effect or Liquid Effect to create 
interesting curved effects by shaping needle penetrations to follow the contour 
of digitized lines. See Curved Fills for details.

Motif runs & fills
Motifs are predefined design elements, such as hearts, leaves or border 
patterns. They generally consist of one or more simple objects, and are stored 
in a special motif set. The EmbroideryStudio Motif tools allow you to use motifs 
to create ornamental runs and textured fills. Use the ones provided with the 
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software or create your own. Motifs can be scaled, rotated and mirrored in the 
same way as other objects. You can even use them to create interesting three 
dimensional effects. See Motif Runs & Fills for details.

Embroidery lettering

Create top-quality lettering quickly and simply. EmbroideryStudio provides a 
large range of scalable closest-join font styles and multi-color and fancy fonts to 
choose from.

Creating embroidery lettering
Create high-quality embroidery lettering quickly and simply. EmbroideryStudio 
provides a large range of scalable fonts to choose from. Add embroidery 
lettering directly to designs or convert from CorelDRAW Graphics. Apply 
formatting just like a word processor, including italics, bolding, and right/left 
justification. Change values for the whole text or individual letters. See Creating 
Embroidery Lettering for details.

Editing embroidery lettering
EmbroideryStudio gives you interactive and precise numeric control over many 
settings affecting lettering objects. Adjust both individual letters and lettering 
objects as a whole. Apply horizontal, vertical, and curved baselines. Modify 
baseline type, length, radius and angle, as well as position. You can even define 
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the rotation angle of letters relative to the baseline or the design itself. See 
Editing Embroidery Lettering for details.

Advanced lettering techniques
Add special characters and symbols to your 
lettering. By default, lettering objects are filled 
with Satin stitch. Apply other basic fill stitch 
types as with all embroidery objects.
Specify the sequence in which letters are 
stitched to minimize registration problems. The 
automatic kerning feature improves lettering 
appearance and legibility by fine-tuning 
spacings between character pairs.
Alternatively, fine-tune letter spacing 
according to the number of characters per 
object. This is particularly useful with Asian 
fonts. Lettering appearance and quality can be 
improved with the correct underlay. See Advanced Embroidery Lettering for 
details.
Apply Lettering Art effects to make letters bulge or arch, stretch or compress. 
Many styles are available from the Lettering Art gallery. You can fine-tune 
preset shapes as preferred. Edit lettering text in envelopes the same way as 
normal lettering. See Creating special effects with lettering art for details.

Team lettering
The Team Names feature lets you create designs with multiple names. For 
example, you can use the same logo with different names for sports teams or 
corporate uniforms, without having to create multiple copies of the same design. 
Names are stored in lists that can be accessed from any design. You can add to 
these lists, or remove names at any time.
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Depending on how you want to stitch out, you can choose to save and stitch 
names and designs separately, or together. See also Team Names.

Monograms
A monogram is a design composed of one or more 
letters, typically the initials of a name, used as an 
identifying mark. The Monogramming feature 
offers a simple way to create personalized 
monograms using a selection of predefined 
monogram styles, border shapes and ornaments, 
together with a set of tools to help you place these 
elements in creative and decorative ways. See 
Monogramming for details.

Custom fonts
Turn any TrueType font installed on your system 
into an embroidery font. The automatic kerning feature improves lettering 
appearance and legibility by fine-tuning spacings between character pairs. 
Sometimes you find that you want to reshape a letter to improve its appearance, 
perhaps to suit a particular lettering height. EmbroideryStudio lets you save the 
letter as an alternative version. In fact you can save multiple versions of the 
same letter within the same font. You can even create your own custom fonts or 
modify an existing font for special applications. Even merge letters from two or 
more fonts. See Custom Fonts for details.

Mixed decoration

EmbroideryStudio provides support for various multi-decoration techniques, 
including print.

Appliqué digitizing
Automatically create all the stitching you need for 
appliqué using the Auto Appliqué tool. Up to four 
layers of stitching – guide runs, cutting lines, tack 
stitches and cover stitches – can be generated for any 
appliqué object, depending on current settings. You 
can also extract appliqué shapes from a design to 
output to a cutter or separate file. See Appliqué 
Digitizing for details.
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Sequin digitizing
Some embroidery machines are equipped with a sequin 
dispenser that drops sequins onto the garment as it stitches. 
EmbroideryStudio allows you to digitize sequined designs for 
compatible machines. A dedicated set of sequin tools lets you 
digitize sequin fills, outlines, or individual sequin drops.
EmbroideryStudio also supports the creation of twin-sequin 
designs for twin-sequin-capable machines. EmbroideryStudio 
also provides a dedicated tool for automatically converting 
sequin artwork in the form of a vector file to sequin runs. See 
Sequin Digitizing for details.

Bling digitizing
Bling refers to decorative objects placed on garments or 
templates, either on their own or in combination with other 
design elements. Bling is supplied in varying sizes, shapes, 
colors and materials. It goes under various names such as 
diamante, rhinestones, eyelets, ribbons, charms, crystals, 
glitz, nailheads, studs, etc.

EmbroideryStudio lets you create bling and embroidery multi-decoration designs 
with the Bling toolset. This tool lets you create and visualize bling 
embellishments in combination with other decorative elements. See Bling 
Digitizing for details.

Chenille digitizing
EmbroideryStudio provides an option to add special chenille embroidery 
capabilities to a lockstitch embroidery digitizing system. These Chenille 
features include chenille embroidery machine formats, stitch types and effects, 
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as well as chenille-specific object properties. Chenille can be added to all levels 
of product. See separate Chenille Supplement for details.

Files, machines, & design processing

Design processing and encoding involve all the important, back-end operations 
of embroidery design and manufacture. This is where you actually output your 
designs to machine, disk, printer, cutter, and so on. For this, you will need an 
understanding of embroidery file types as well as different machine formats. 
Depending on your setup, you will also need an understanding of traditional 
storage media such as embroidery disks.

Printing designs
From the same design file, you can output a production worksheet for the 
embroidery machine operator. Designers frequently want to distribute their 
designs for viewing in real colors, in TrueView™ or otherwise, with or without 
fabric or product backgrounds. EmbroideryStudio allows you to customize 
information in the format you require for production worksheets and/or approval 
sheets. You can specify the data to print, graphics to include, zoom factor, and 



EmbroideryStudio e4 User Manual 29

general options such as company name. You can use a color printer or plotter to 
produce your worksheets. See Printing Designs for details.

Outputting designs
You can output embroidery designs for actual stitchout in a variety of ways – 
sending directly to machine for stitching, or saving to specific machine formats 
and/or to embroidery disk. See Outputting Designs for Production for details.
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Multi-decoration export
The Multi-Decoration File Export (MDFE) capability allows you to export the 
different file formats involved in a multi-decoration design production with a 
single command option. The system recognizes whether a design element is 
embroidery, graphics, appliqué, or bling. It displays each element in an export 
dialog with a list of corresponding file types to choose from. See Exporting 
multiple decoration files for details.

Reading files of different formats
By default EmbroideryStudio saves to its native file format, EMB. This format 
contains all information necessary both for stitching a design and for later 
modification. When opening designs created or saved in other formats, 
EmbroideryStudio converts them internally to EMB format. They can then be 
modified using the full range of EmbroideryStudio features. Depending on the 
file type, you may need to provide additional information to assist 
EmbroideryStudio in the conversion process. See Working with Machine Files for 
details.

Hooping designs
Devices made from wood, plastic, or steel, hoops are used to tightly grip fabric 
and stabilizer between an inner and outer ring. Designed to hold fabric taut 
against the machine bed for embroidering, they attach to the machine’s frame. 
Fabrics must be hooped before stitching out on the machine. EmbroideryStudio 
allows you to select from a wide range of standard factory-supplied hoops. If you 

Manual objects with no
outlines and manual

stitches only
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are using a hoop which does not appear in the hoop library, you can define your 
own from scratch or based on a standard hoop. See Hooping Designs for details.

Machine formats
Different embroidery machines speak different languages. They have their own 
control commands for the various machine functions. Before you can stitch a 
design, it must be in a format which can be understood by the embroidery 
machine. When you select a machine format, EmbroideryStudio uses it to 
translate digitized designs into a specific machine-readable form. If required, 
you can customize machine formats to meet specific machine requirements. See 
Machine Formats for details.

Hardware & software setup

In order to work with your particular equipment, EmbroideryStudio needs to be 
properly configured. You may also want to configure the software to your 
particular design requirements.
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Setting up hardware
You will need to connect peripheral devices for use with EmbroideryStudio. 
These may include digitizing tablets, plotters, printers, appliqué cutters, 
scanners and embroidery machines. Different devices are set up in different 
ways – some in MS Windows®, via the Control Panel, others within 
EmbroideryStudio itself. See Hardware Settings for details.

Changing system settings
EmbroideryStudio lets you adjust various system settings controlling the 
appearance of designs on screen, display of design information, the behavior of 
the Design Window, and other settings. See System Settings for details.

Design management

EmbroideryStudio comes equipped with its own built-in Design Library for 
managing your embroidery designs across your entire local network. 
CorelDRAW Graphics which comes with some product models provides access 
to an extensive selection of clipart and other assets.

Managing designs with Design Library

Design Library is a design management tool. Use it to browse design and 
artwork files stored on your local PC or company network. Design Library 
capabilities make it fast and practical for daily commercial use, avoiding the 
need to switch to and from Windows Explorer. It recognizes all file formats 
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used by EmbroideryStudio. It also makes it easy to search, sort and browse all 
embroidery designs on your network.

In a nutshell, Design Library lets you:
 Search for designs – including artwork files – anywhere on your local hard 

drive, network drives, or external devices such as USB or ZIP drive.
 Preview design information in the preview pane.
 Search for designs by various means, including known design information.
 Create an organizing structure for easy categorization.
 Batch-convert selected design files to all commercial embroidery formats 

such as DST, EXP, SEW, and others.
 Print selected designs or send them to embroidery machine for stitchout.
 Use Design Library to handle job orders.
Find embroidery designs anywhere on your hard drive or external storage device 
and, optionally, add them to your embroidery library. This section describes how 
to open and view designs in Design Library as well as adjusting viewing 
settings. It also covers browsing for and accessing designs in folders. See 
Managing Designs for details.

Note  Design Library helps you manage designs in folders. It is not a 
multi-user database for company-wide design management. For this type of 
requirement, refer to the DesignWorkflow User Manual.

Browsing artwork with CorelDRAW®

CorelDRAW® Graphics Suite comes with an extensive selection of clipart and 
other assets which can be used as digitizing backdrops or converted directly to 
embroidery.
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To browse artwork with CorelDRAW®
 Access the CorelDRAW® Graphics Suite folder via the Windows Start > 

Programs group.

 Select Corel CONNECT. This utility allows you to view and manage clipart 
and other assets on your PC, local network, or online.

 To open the clipart in EmbroideryStudio, you will need to do so via 
CorelDRAW Graphics.

Note  For a detailed description of the CorelDRAW® Graphics Suite interface, 
refer to the electronic User Guide available via the MS Windows® Start > 
Programs group. Alternatively, use the onscreen help available from the 
CorelDRAW Graphics Help menu.

Related topics
 Converting objects with CorelDRAW Graphics
 Inserting vector graphics

Select Corel 
CONNECT
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PART I

OBJECT-BASED EMBROIDERY

Embroidery design with EmbroideryStudio consists of turning basic artwork 
shapes into embroidery designs. EmbroideryStudio gives you the flexibility of 
creating embroidery objects using artwork as backdrops, or of directly 
converting digital artwork. You can take a mixed mode approach as well, doing 
the bulk of the design by means of automatic conversion, followed by touch-ups 
and edits using the suite of EmbroideryStudio embroidery digitizing tools.

Basic procedures
This section describes how to open EmbroideryStudio and start using the 
commands and tools. It also explains how to open designs as well as create new 
ones. It describes how to display the grid and rulers, and measure distances on 
screen. And it also covers how to select machine formats for different output. 
See Basic Procedures for details.

Viewing designs
This section explains design viewing modes as well as the various design viewing 
settings, including design colorways. Techniques for viewing the stitching 
sequence are described as well as how to selectively view design color blocks. 
Viewing design information, including production worksheets, is also covered. 
See Viewing Designs for details.

Threads & charts
This section describes how to select colors from the Color Palette as well as how 
to assign threads to the colors in your design. How to modify thread charts is 
also covered, as well as creating custom thread charts. See Threads & Charts for 
details.

Managing designs
Design Library is a design management tool. Use it to browse design and 
artwork files stored on your local PC or company network. Design Library 
capabilities make it fast and practical for daily commercial use, avoiding the 
need to switch to and from Windows Explorer. It recognizes all file formats 
used by EmbroideryStudio. It also makes it easy to search, sort and browse all 
embroidery designs on your network. See Managing Designs for details.
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Chapter 3

Basic Procedures

EmbroideryStudio software is an MS Windows®-based product incorporating 
many of the conventions with which most PC users are already familiar. 
EmbroideryStudio integrates with CorelDRAW® Graphics Suite into a single 
application, allowing users to create, not just embroidery, but true, 
multi-decoration designs. 

Operating modes

Open EmbroideryStudio using the desktop icon or the MS Windows® Start 
menu. The application has one workspace or ‘design window’ but you interact 
with it in different operating modes:
Wilcom Decoration: This allows you to create and edit embroidery objects 

using an embroidery digitizing toolset.

Double-click to start EmbroideryStudio.
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 CorelDRAW Graphics: This allows you to create and edit vector objects 
using the CorelDRAW® Graphics Suite toolset.

A third option provides access to Design Library where you manage designs 
and order jobs. You access all modes via the Mode toolbar.

Caution  You need to calibrate your monitor so that designs at 1:1 scale appear 
at real size. Do this when you first install EmbroideryStudio or whenever you 
change your monitor. See Calibrating the monitor for details.

Wilcom Decoration window

When you open EmbroideryStudio, it appears by default in Wilcom Decoration 
window with a new, blank design displayed. This mode allows you to create and 
edit embroidery objects using the embroidery digitizing toolset. The screen 
image below shows the more prominent toolbars in EmbroideryStudio. 
Depending on your product level, you will have access to some or all of these 
options.

Switch between 
operating modes

Use Mode > Switch to Wilcom Decoration to digitize and edit embroidery designs. 
Display embroidery as well as artwork. View designs realistically in 3D simulation.

Menu bar

Status / Prompt bars

Mode toolbar

Standard toolbar

Object properties
docker

Color palette

Docker tabs

Design window

View toolbar

Toolbox

‘Floating’ toolbar

Stitch Effects toolbar

Stitch Types toolbars

Graphic style and
traditional input

methods

Design tabs
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Use this mode when you want to create embroidery from digitizing ‘backdrops’. 
Various types of image file can be loaded in EmbroideryStudio. Wilcom 
Decoration also offers a graphical representation of what the final embroidery 
will look like. Use TrueView™ together with a background fabric to see how 
your design will look when stitched out. Some of the more prominent Wilcom 
Decoration interface elements include:

 Customize the design window by showing or hiding the grid, changing the grid 
dimensions, as well as showing and hiding toolbars. 

 Dock or ‘float’ toolbars and dockers in any configuration that suits. Toolbars 
are dockable left, right, top and bottom, and can be ‘floated’ anywhere in the 
design window.

  EmbroideryStudio allows you the choice of large or small button icons with 
or without text names.

Related topics
 Change backgrounds
 Setting toolbar display options
 Access object properties
 Display grids, rulers & guides
 Quick reference

Element Description

Menu bar This contains the application menus such as File, Edit, View, etc.

Mode toolbar This contains tools and icons which are visible in both Wilcom 
Decoration and CorelDRAW Graphics.

Standard toolbar This contains commonly used tools and commands which are specific 
to and only visible in Wilcom Decoration.

View toolbar This contains commands for viewing embroidery designs – e.g. as 
design outlines, by stitches, by machine functions, as they will stitch 
out on the fabric – either separately or in combination. 

Stitch Types 
toolbars

This contains tools which determine the stitch types which can be 
applied to embroidery objects, including Satin, Tatami, Motif Fill, etc. 

Stitch Effects 
toolbar

This contains tools for modifying or improving stitch quality, including 
applying automatic underlay to selected objects. 

Toolboxes Depending on the product model, there are up to three ‘toolboxes’ – 
Toolbox, Graphics Digitizing, and Traditional Digitizing. Between 
them, toolboxes contain all the embroidery digitizing/editing tools 
specific to and visible only in Wilcom Decoration. 

Color Palette This contains the embroidery color palette which is specific to and 
visible only in Wilcom Decoration. 

Status / Prompt 
bars

These contain current status information and prompts which are 
visible only in Wilcom Decoration. See below.

Docker Wilcom Decoration includes ‘dockers’ Object Properties, 
Color-Object List, Color Palette Editor, and others. These stay open 
as long as you need them. 

Design Window This contains the main work area where you create and edit 
embroidery objects as well as graphics objects when you switch to 
CorelDRAW Graphics.
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Design tabs
EmbroideryStudio allows you to switch between open designs by means of 
design tabs. This also makes it easy to copy/paste between designs, including 
drag and drop operations. 

Related topics
 Set up multiple views
 Quick reference

Status & Prompt bars
The Status and Prompt bars at the bottom of the Wilcom Decoration design 
window provides continuous display of current cursor position status as well as 
instructions for use of selected tools.

Information includes:

Related topics
 Setting pointer position display

Design tabs

Stitch type and 
current settingsStitch count

Coordinates of current
needle position

Status Bar

Prompt Bar

Length and angle of 
current stitch

Current object
Selected auto

fabric

Current machine function Current hoop

Item Details

Prompt Guides you through use of selected functions.

Stitch count Total number of stitches in design.

Design size Width and height.

Coordinates Coordinates of current needle position (X/Y), and length (L) and angle (A) 
of current stitch. 

Current fabric Fabric settings take into account the type of fabric you are stitching on.
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 Changing fabrics

CorelDRAW Graphics window

CorelDRAW Graphics window includes the entire suite of CorelDRAW® 
Graphics Suite drawing tools. This mode allows you to create and edit vector 
graphics using the CorelDRAW Graphics toolset which offers many 
sophisticated techniques for drafting outlines and shapes onscreen.

In addition to the CorelDRAW® Graphics Suite toolset, CorelDRAW Graphics 
provides capabilities to convert vectors and vector text directly to embroidery 
objects. Imported vector graphics or created text can be converted directly to 
embroidery designs. You can use CorelDRAW Graphics to insert or paste 
third-party vector graphics such as clipart for use in embroidery designs. 
Alternatively, insert, paste or scan bitmap artwork for use as digitizing templates 
or ‘backdrops’. Here are some of the prominent CorelDRAW Graphics interface 
elements.

Use Mode > Switch to CorelDRAW Graphics to import, edit or create vector 
artwork as a backdrop for embroidery digitizing, manual or automatic.

In Graphics mode, click Mode > Show Embroidery to show or hide embroidery 
components.

Element Description

Menu bar This contains application menus such as File, Edit, View, etc.

Mode toolbar This contains the universal tools and icons which are visible in both 
Wilcom Decoration and CorelDRAW Graphics windows.

Standard toolbar This contains commonly used tools and commands which are 
specific to and only visible in CorelDRAW Graphics.

Menu bar

Status bar

Toolbox

Mode toolbar

Standard toolbar

Properties bar

Design window

Docker
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Note  For a detailed description of the CorelDRAW® Graphics Suite interface, 
refer to the electronic User Guide available via the MS Windows® Start > 
Programs group. Alternatively, use the onscreen help available from the Help 
menu.

Related topics
 Opening artwork in EmbroideryStudio
 Converting objects with CorelDRAW Graphics

Design library

Design Library is a design or job order management tool. Use it to browse 
design and artwork files stored on your local PC or company network. 
Design Library capabilities make it fast and practical for daily commercial use, 

Properties bar This contains the commands and controls that relate to the active tool 
in the Toolbox or active object in the design window in CorelDRAW 
Graphics.

Toolbox This contains the drawing/editing tools specific to and visible only in 
CorelDRAW Graphics.

Design window This contains the main work area where you create and edit graphics 
objects as well as embroidery objects when you switch to Wilcom 
Decoration.

Color palette This contains the graphics color palette which is specific to and only 
visible in CorelDRAW Graphics.

Docker In CorelDRAW Graphics, this contains graphics-specific dockers.

Status bar This contains current status information visible only in the 
CorelDRAW Graphics.

Element Description

Click Mode > Design Library to open the Design Library window from which to 
search and manage designs and job orders.
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avoiding the need to switch to and from Windows Explorer. It recognizes all 
file formats used by EmbroideryStudio.

Design Library is installed with sample designs in EMB format. These show 
various stitching techniques and effects, including ‘multi-decoration’ and 
multiple colorways. When starting out as a new user, make sure to spend time 
exploring these designs.

Related topics
 Managing Designs
 Opening artwork in EmbroideryStudio

Toolbars & dockers

The EmbroideryStudio design window provides ‘dockers’ for key functions. 
Wilcom Decoration has docking panes for Color-Object List, Object 
Properties, Overview Window, and so on. All panes are dockable on either 
side of the design window.

Access toolbars

Toolbars provide quick and easy access to most EmbroideryStudio commands. 
Show or hide them at your convenience. As you get more familiar with the 
system, you may prefer menu and keyboard commands. 
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To access toolbars
 Select Window > Toolbars or right-click the docking area at the top or left 

of the design window. The Toolbars menu opens.

 Click to activate one or many.

Related topics
 EmbroideryStudio toolbars

Work with dockers

In Wilcom Decoration mode, there are three important dockers:

Select toolbars 
to display

Use Docker > Color-Object List to view and sequence design objects.

Use Docker > Object Properties to preset properties or adjust properties of selected 
objects.

Use Docker > Colorway Editor to assign thread colors to color palette and define 
colorways.

Docker Description

Object 
Properties

The most important is the Object Properties docker. Use it together with the 
Property Bar to access properties of selected embroidery objects. 

Color-Object 
List

The Color-Object List offers an easy way to selectively view and 
resequence color blocks and objects. 

Colorway 
Editor

When you create a new design, it includes a single default colorway called 
‘Colorway 1’. The Colorway Editor allows you to edit default colors, add 
extra color slots as required, and set up additional colorways.
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Access dockers via the Docker toolbar or Window menu. They can be docked 
on either side of the screen.

All dockers can be fixed or minimized. Dockers may also be ‘floated’ by dragging 
the caption bar to the design window or double-clicking it when ‘pinned’ in place. 
Dockers can be ‘nested’ to increase available workspace. When nested, tabs for 
each docker appear down the side. 

Hover docker over 
title bar of another

Click tab to 
view docker

Click and drag tab 
to float docker
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Toggle Auto Hide next to the X close button. Docking panes automatically 
retract when not in use. By hovering the mouse over the tab, a minimized docker 
will ‘fly out’, allowing you to access its functions. 

Related topics
 Access object properties
 Viewing color blocks
 Colorways

Access object properties

The most important docker is Object Properties. Use it together with the 
Property Bar to access the properties of selected embroidery objects.

To access object properties
1 Open the Object Properties docker by any of the following means:
 Click the Object Properties tool.
 Double-click an object in the design window.
 Right-click an object and select from the popup menu.

Enable/disable
auto-hide

Close docker

Double-click title bar to
return to docked state

Use Docker > Object Properties to set properties of selected objects.
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 Right-click an object in the Color-Object List and select from the popup 
menu.

2 Select a tab to access the properties to adjust. 
3 Adjust general properties – width, height, position – by means of the 

Property Bar. Press Enter to apply. Press Esc to discard changes.

Tip  You can specify units of measurement when entering values into a 
measurement control.

Related topics
 Working with object properties
 Set measurement units

Machine formats

Different embroidery machines speak different languages. They have their own 
control commands for the various machine functions. When you create a design, 
you need to select a format corresponding to the embroidery machine you 
intend to use. EmbroideryStudio uses the format to translate digitized designs 
into a specific machine-readable form. You don’t, however, need to change a 
design’s ‘native machine format’ in order to output to a different machine. If a 
selected machine format does not support a particular function in the design, it 
is simply ignored on output.

Object Properties tabs

Adjust settings as 
required

Click to close

Droplist

Adjust position and size settings. 
Press Enter to apply.
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To select a machine format
 Select Design > Select Machine Format. The Select Machine Format 

dialog opens.

 Select the required machine format from the list.

Note  You can change the machine format itself if machine values do not 
correspond precisely to your particular machine. Or you can create a new 
format based on a selected one.

Related topics
 Supported machine types
 Machine Formats
 Setting up sequin mode
 Outputting Designs for Production
 Custom machine formats

Working with design files

EmbroideryStudio handles all commercial and home stitch file formats. In fact 
native EMB files are read and written by leading home embroidery systems. 

Whenever you start EmbroideryStudio, a new file – Design1 – is automatically 
created. By default, Design1 is based on the NORMAL template. Templates 
contain preset styles, default settings or objects, to make digitizing quicker and 
easier. EmbroideryStudio also provides a set of optimized fabric settings so that 
the software will take into account the type of fabric you are stitching on.

Select machine
format

Click to adjust 
settings

Click to create 
new format
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Open designs

EmbroideryStudio opens a comprehensive range of both ‘outline’ and ‘machine’ 
files.

To open a design
 Click the Open Design icon.

 Navigate to the design folder. The dialog filter defaults to ‘Wilcom All-in-One’ 
designs which displays all native EMB design files. Adjust the filter as 
required:
 All-in-one design files: All design files supported by EmbroideryStudio 

including JAN and ART.
 All machine files: Filter by machine file format only. No design files.
 All embroidery files: All supported ‘design’ and ‘machine’ files.

 Select a design or designs.
 To select a range, hold down Shift then select first and last.
 To select multiple items, hold down Ctrl and click.

Tip  For more information about a selected file, right-click and select 
Properties from the popup menu. 

 For file types other than EMB or ESD, click Options and adjust recognition 
options as preferred.

 Click Open.

Use Standard > Open Design to open an existing design.

Use Standard > Open Recent Designs to open a design from a list of recently 
opened designs.

Supported design 
and machine files
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 Optionally, select Design > Auto Fabric to apply preferred fabric settings.

 Whenever you want to work on a recently opened design, use the Open 
Recent Designs for quick access.

 If the the Backup Copy option is active, a backup copy of the current design 
file is automatically created in its previously saved form. Access the backup 
folder via the File > Open Backup Design command.

Tip  You can also open designs from proprietary embroidery disks, or read 
them from paper tape.

Related topics
 Setting automatic save & backup options
 Embroidery file formats
 Viewing design details
 Working with fabrics
 Using embroidery disks
 Supported Machine, File and Disk Types

Create designs from templates

Templates are special files used to store styles, default properties, as well as 
fabric settings. Although the NORMAL template settings are suitable for a range 
of fabrics, selecting an auto fabric further adjusts settings.

Choose a fabric 
type

Tick to activate

Quickly access any 
recently opened 
designs

Use Standard > New to start a blank design based on the currently selected 
template. Hold down Shift and click to open New from Template dialog.
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To create a design based on a template
1 Select File > New from Template or, holding down the Shift key, click 

New. The New from Template dialog opens.

2 Select a template from the droplist. When you create a file based on a 
template, its settings are copied to the new design.

3 If you want, additionally, to use fabric settings, tick the checkbox. From the 
droplist, choose a fabric type nearest the one you intend to work with.

4 Optionally, choose a background to match the selected auto fabric.
5 Choose a target machine from the droplist. You normally decide which 

machine format to use before you start. However, formats can be changed at 
any time.

Tip  You can customize or add formats to suit the target machine.
6 Click OK to accept. A blank design opens in the design window based on the 

selected template. Settings will apply to all newly created embroidery 
objects. Any selected fabric is displayed in the Status Bar. 

Tip  The New from Template option is activated by default. Turn it off if you 
prefer work without predefined fabric settings.

Related topics
 Working with templates
 Working with fabrics
 Machine Formats
 Setting other general options

Save designs

Choose a template

Activate auto fabrics and 
choose a target fabric

Set background color 
and swatch

Choose a target 
machine format

Save as
default

Use Standard > Save Design to save the current design. Right-click to open the 
Save As dialog.
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The Save Design option allows you to save a design to the latest native EMB 
‘all-in-one’ format. To save designs to previous formats, choose File > Save As. 

Native EMB files contain a complete set of design information in a single 
‘all-in-one’ file – object outlines and properties, actual stitches and machine 
functions, thread colors, a picture icon, summary information, and more. Even 
the original design bitmap image can be included in EMB format. Only native 
EMB files provide 100% perfect scaling and transformation. EmbroideryStudio 
lets you save designs in various native EMB formats. This can be important if 
your suppliers or clients use previous versions of Wilcom software. 

Caution  If a design feature is not available in the selected file type, it will be 
converted. For example, Flexi Split stitching may be changed to plain tatami. 
If the design contains a bitmap using a color depth unsupported by the selected 
file type, it will be removed from the resulting file.

Related topics
 Machine Formats
 Exporting designs for machine
 Using embroidery disks
 Supported Machine, File and Disk Types

Send designs as email attachments

You can attach designs to emails from the design window or via the Open 
Design dialog.

To send designs as email attachments
 With the design open in the design window, select File > Send via Email.
 Alternatively, click the Open Design icon. Select the file to send, then 

right-click it. The popup menu appears. Select Send To > Mail Recipient.

Choose an output 
file format

Use Standard > Open Design to send a design as an email attachment.
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Your default email system is launched and a new email created with the 
design file attached.

 Enter mailing details and send.
 Optionally, to output a design as a bitmap, select File > Capture Design 

Bitmap.

Related topics
 Outputting designs as graphics

Selecting objects

EmbroideryStudio provides various ways to select 
embroidery objects. It supports point & click, selection 
marquee and multiple object selection. The 
Color-Object List provides an easy way to select 
objects and colors and access their properties.

Tip  Depending on your background, you can change 
display colors for unsewn stitches, selected objects, 
object outline, grid and guides. See also Change 
display colors.

Select Send To > 
Mail Recipient

Select Output 
option
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Select objects with selection tools

Use selection tools to select individual objects as well as groups or ranges of 
objects.

To select objects
 The simplest way to select an object is to point and click with the Select 

Object tool activated. Selection handles appear around selected objects.

 To select multiple items, hold down Ctrl as you click. To select a range, hold 
down Shift as you click. 

 Alternatively, drag a selection marquee around the objects you want to select.

 Where you have a mixture of objects – outline, closed-fill, open-fill – click 
through holes or gaps to select objects beneath.

Use Select Tools > Select Object to select individual objects as well as groups or 
ranges of objects.

Use Select Tools > Freehand Select to select object at current by drawing a 
freehand line. 

Click Select Tools > Polygon Select to select objects with a selection marquee.

Click Select Tools > Polyline Select to draw a line through the object to select.

Click first object Hold down Ctrl and 
click another object

Ctrl + Hold down Shift and 
click last object

Shift +

OR

Drag a selection marquee 
around objects to select
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 Alternatively, use the Freehand Select tool to draw a freeline around the 
object/s you want to select. Press Enter to close.

 Alternatively, use the Polygon Select tool to mark reference points around 
the object/s you want to select. Press Enter to close.

 Or use Polyline Select to mark two or more reference points to create a line 
touching all objects you want to select.

 To select an object which is sitting behind another filled object, hold down 
the 2 key and click until the underlying object is selected.

 To select all objects, select Edit > Select All or press Ctrl+A. Selection 
handles appear around the entire design.

 Deselect objects by any of the following means:
 To remove an object from a selection, hold down Ctrl and click.
 To deselect all, click an empty area of the background or a different object.
 Alternatively, press Esc or X to deselect all or select Edit > Deselect All.

Tip  EmbroideryStudio also provides a method for you to select individual 
objects within grouped objects. See Selecting objects within groups for 
details.

Select objects with Color-Object List

The Color-Object List offers an easy way to select objects and selectively view 
them. It is synchronized with the design window, dynamically updating 
whenever you edit.

Draw a freeline 
around object/s to 
select

Mark reference 
points around 
object/s to select

Mark two 
reference points

Use Docker > Color-Object List to toggle the Color-Object List on/off. Use it to view 
and sequence objects in a design.
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To select objects by Color-Object List
 Click the Color-Object List icon to open the docker. A separate icon for each 

color block and each object in the design appears in order of stitching.

 Click a ‘node’ to open or close a color block and see its components.

 Click an icon to select a color block and/or individual objects.
 To select a range of items, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you click.
 To select all items, right-click and choose Select All from the popup menu.
 To deselect, click away from the design.

Total objects in design

Total color block count

Object icon

Click to
open/close all

color block nodes

Click to open/close
individual color

block node

Blue border
appears around
selected objects

Right-click any object or 
color block, and Select 
All
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Note  You can also use the Color-Object List to group and lock objects as 
well as cut, copy and paste, resequence, and branch objects. See Combining 
& Sequencing Objects for details.

Measurements

EmbroideryStudio provides a set of grid lines to help accurately align or size 
embroidery objects.

Display grids, rulers & guides

Use grid lines to help accurately align or size embroidery objects. Default grid 
spacing is 10mm x 10mm. Invoke rulers to accurately position and scale objects. 
The unit of measurement – mm or inches – defaults to the regional settings in 
the MS Windows® Control Panel.

To display grids, rulers and guides
 Click the Show Grid icon or press Shift+G. Right-click for settings. You can 

change grid spacing, select a reference point and turn Snap to Grid on or off 
in the Options dialog.

 Click the Show Rulers & Guides icon or press Ctrl+R.

 Reset the ruler zero point by clicking and dragging the button in the top 
left-hand corner of the ruler.

Click View > Show Grid to show or hide the grid. Right-click for settings.

Click View > Show Rulers and Guides to show or hide rulers and guides. Right-click 
for settings.

Drag the Ruler Zero Point to reset a new ruler zero point.

Show Grid

Click-and-drag to
reset ruler zero

point

Click-and-drag to
reposition guides

Click ruler to
create new guide

Drag guide off
ruler to remove
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 To create a guide, click either ruler – horizontal or vertical – and 
click-and-drag it into position. Multiple guides can be created and just as 
easily removed.

 For more accurate positioning of guides, double-click the yellow handle. In 
the Guide Position dialog, enter a precise distance from zero point and click 
OK.

 To remove a guide, drag the yellow guide handle off the design window.
 Optionally, turn on the Snap to ... feature via the Options dialog.

 You can also change the color of grid and guidelines via the Background & 
Display Colors dialog.

Related topics
 Setting grid display options
 Change display colors
 Selecting hoops manually

Set measurement units

The first time you run EmbroideryStudio, the measurement system will default 
to whatever the operating system is using. However, you can change 
measurement units from within EmbroideryStudio. 

Enter precise offset 
from zero point

Select to
display grid

Select to snap
design points

to grid

Show rulers
and guides

Select desired 
measurement unit
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Note  Technically, when you select ‘U.S.’, you will get the imperial measurement 
system – inches, feet, and yards. Inch rulers are displayed in 1/16, 1/8, ¼, ½, 
and 1" divisions. The grid size can be set in decimal inches.

Ripple-on effects
Changing the measurement system will change the units used by most controls.

Relevant fields also appear in the selected unit of measurement – e.g. Design 
Properties docker as well as Production Worksheet.

There are, however, exceptions to this rule: 
 Stitch List: this used to be displayed in inches for U.S. systems. But these are 

stitch lengths, so must always be in mm.
 Stitch length and density controls remain in mm regardless of measurement 

system. These controls reflect the machine functions as industrial machines 
are always in millimeters.

Measurement units 
display

Selected measurement 
unit displayed

Stitch length and 
density controls remain 
in mm
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Specify measurement units on-the-fly
Alternatively, you can specify units of measurement when typing values into a 
measurement control. EmbroideryStudio automatically converts the value. 

For example, if a US customer orders lettering in inches – say ¾" – and the 
digitizing is to be done in metric, you can enter ‘3/4in’ or ‘3/4 in’ into the 
Lettering Height field and it is automatically converted to 19.05mm.

Note  EmbroideryStudio supports both proper and improper fractions – e.g. 
‘1 1/3’ as well as ‘4/3’. It does not, however, support mixed units – e.g. 1'3". Nor 
does it display values as fractions after they are entered, only during.

Supported units
Supported units include:
 millimeters, mm 
 inches, in
 feet, ft
 yards, yd 
 centimeters, cm 
 meters, m 

Tip  EmbroideryStudio also allows entering units in text form, both English and 
the language the software is currently running in.

Related topics
 Setting grid display options
 View design details in EmbroideryStudio
 Selecting stitches with the Stitch List
 Creating lettering with object properties

Measuring distances on screen

Measure the distance between two points on screen using the Measure 
command. View measurements in the Status bar or tooltip.

Tip  For more accurate results, zoom in before you measure. The measurement 
is always the actual size, and is not affected by the zoom factor.
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To measure a distance on screen
1 Select View > Measure or press M and click the start point.
2 Move the pointer to the end point and hold the mouse still. 

If activated, length and angle measurements appear in a tooltip.

The following information displays in the Status Bar:
 Position coordinates of the end point (X=, Y=)
 Length of the measured line (L=)
 Angle of the line relative to the horizontal (A=).

Measurements are shown in millimeters or inches according to selection.
3 Press Esc again to exit the command.

Related topics
 Setting other general options

Measurements 
appear as tooltip
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Chapter 4

Viewing Designs

EmbroideryStudio provides many viewing features to make it easier to work with 
your design. Use zoom and pan functions to study design details. Toggle 
between ‘artistic’ and ‘technical’ views. You can also preview designs in different 
colors on different fabrics by means of ‘colorways’.

EmbroideryStudio provides design information in various forms. Approval and 
production sheets provide essential information such as design previews, size, 
color sequence information and any special instructions.

Viewing design components

EmbroideryStudio provides many viewing modes to make it easier to work with 
your design. View a design at actual size or zoom in for more details. Pan across 
instead of scrolling, or quickly change between current and previous views.

Note  You need to calibrate your monitor so that designs at 1:1 scale appear at 
real size. Do this when you first install EmbroideryStudio or whenever you 
change your monitor. Go to Setup > Calibrate Screen.

View embroidery components

When you open an embroidery design in EmbroideryStudio, toggles on the View 
toolbar allow you to alternate between ‘artistic’ and ‘technical’ views. Use 
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TrueView for presentation purposes. You can include it on approval sheets, or 
capture it as a bitmap to send via email or publish to a website.

Use these toggles, singly or in combination, to focus on design details. For 
example, view design outlines, stitches, needle points, or even machine 
functions such as trims and tie-offs. You can also turn on connectors in stitch 
view. How you use the view options will depend largely on whether you are 
editing a design or checking for production readiness. Shortcut keys are 
available:

Tip  Depending on the design background, change display colors for selected 
objects, unsewn stitches, etc.

Related topics
 Setting view options
 Change display colors

TrueView Toggle between stitch view and TrueView™. T

Show Stitches Toggle embroidery stitching display. S

Show Outlines Toggle object outlines. L

Show Needle Points Toggle needle points to select stitches for 
editing. . (period)

Show Connectors Toggle connecting stitches to help position 
entry and exit points. V+C

Show Functions Toggle display of machine functions such as 
trims and tie-offs. V+F

Design viewing toggles

Hover cursor for 
tooltips
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View graphical components

Apart from embroidery, EMB designs may include other components such as 
bitmap images, vector graphics, appliqué fabrics, product backdrops, and 
rhinestones or ‘bling’. These can also be turned on or off as desired.

 Toggle the Show Bitmaps and/or Show Vectors icons to selectively view 
both vector and bitmap images.

 Click Show Graphics as Dimmed to dim the onscreen image to view 
stitches more clearly when digitizing. The command applies both to bitmap 
and vector graphics.

 To lock an image in place, select and press K.

View graphic elements, 
including product images

Vector graphic together 
with bitmap image
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 Click the Show Appliqué Fabric icon to toggle display of appliqué fabric 
on/off.

 Use Show Functions to visualize any sequin elements which may be 
included in a design.

Tip  Depending on view options set in the Options dialog, images display in 
full color, or dimmed. 

Related topics
 Setting image viewing options
 Locking & unlocking objects
 Setting view options
 Customizing design reports

Zoom & pan designs

Appliqué fabric On Appliqué fabric Off

Show Functions On Show Functions Off

Click Zoom > Zoom to invoke zoom mode. Zoom in or out via left and right mouse 
clicks, or drag a selection marquee to view design detail.

Click Zoom > Zoom 1:1 to display a design at actual size.

Click Zoom > Zoom to Fit to display the whole design in the design window.

Click Zoom > Zoom to Selected to magnify only selected objects.
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Zoom tools allow you to magnify your view of the design by zooming in on 
individual stitches or details. The easiest way to zoom is via the mouse wheel. 
This defaults to 1.25x increments. The zoom factor can be adjusted in the 
Options > Scroll tab. Zoom tools are also available from the View menu and 
Zoom toolbar. Experiment with the available options.

Use shortcuts keys as indicated in the menus. For instance, to zoom in on a 
section of design, select View > Zoom or press B, and drag a marquee around 
the zoom area. To display the whole design, select View > Zoom to Fit or 
press 0.

Select Zoom > Zoom Factor from the droplist or key in a zoom factor and 
press Enter.

Zoom tools available 
from menu and from 
toolbar

Drag selection marquee 
around area to zoom
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 To display stitches at a particular scale, select a zoom scale from the droplist 
or key in a zoom factor and press Enter. Alternatively, select View > Zoom 
Factor (or press F). In the Zoom Factor dialog, enter a scale as a fraction 
of the actual size, where ‘1’ = ‘100%’, ‘1.5’ = ‘150%’, etc.

 To pan across a design, select View > Pan or press P and use the ‘grabbing 
hand’ tool.

Related topics
 Setting scroll options

Set up multiple views

EmbroideryStudio gives you multiple views of the same design. It also allows 
you to switch between open designs by means of design tabs. This also makes 
it easy to copy/paste between designs, including drag and drop operations.

To set up multiple views
 Use the Window menu commands to set up groups of tabs as preferred.

Enter scale as
fraction of actual

size

Click and drag to pan 
across design

Use commands to set 
up tab groups
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 Set up vertical or horizontal tabbed groups.

 To create multiple views of a single window, use the Window > Split 
Window command. Adjust view settings for each pane.

 Use the Remove Tiling command to return the design window to normal 
display mode.

Tip  After certain operations you may need to refresh the screen for a clearer 
display. Select View > Refresh Screen or press R.

Work with the Overview Window

Double-click to 
remove split bars

Use Docker > Overview Window to toggle Overview window display on/off. Use it 
to view a thumbnail of the design.
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Use the Overview Window to view a thumbnail of the design. Use it to pan and 
zoom the design when working at high zoom factors. Set view settings 
independently to the design window.

 To zoom in or out, click the Zoom button at the bottom of the window and 
drag a selection marquee around the area to zoom.

 To pan across the design, click and drag the zoom box.

Click for
zoom box

Drag selection 
marquee around 
area to zoom

Drag zoom box
to pan across

design
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 To change the view settings for the Overview Window, click it to make it 
the active window.

Related topics
 View embroidery components

View selected objects

EmbroideryStudio provides many techniques for hiding or showing selected 
embroidery objects in the design window.

To view selected objects
 Select the objects you want to view.

Click inside window 
to change view 
settings

Use Select Tools > Select Object to select individual objects as well as groups or 
ranges of objects.

Select objects
to view
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 Press Shift+S. All other objects are hidden.

 To display the selected object full-screen, press Shift+0 (zero).
 To return to the previous view, select View > Previous View or press V.
 To re-display the entire design, press Esc followed by Shift+S.
 To redraw the screen, select View > Refresh Screen or press R.
 Optionally, select the Options icon in the Standard toolbar, or select Setup 

> Options > View Design tab, to toggle options for selective display of 
embroidery objects:

Options include:

Related topics
 Selecting objects

Option Description

No change The display remains the same as before.

Show whole design All embroidery objects in the design are visible.

Show selected 
objects

Only objects that are currently selected are visible. This option 
is only available when objects are selected.

Show unselected 
objects

The reverse of the above option. This option is only available 
when objects are selected.

Hide whole design All embroidery objects in the design are hidden.

All other objects are 
hidden

Select viewing 
options
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Viewing stitching sequence

When checking embroidery designs, you will want to understand the stitching 
sequence in order to ensure efficient stitchout on the machine. ‘Travel’ through 
designs by color block, embroidery object, or even stitch-by-stitch. Alternatively, 
simulate the stitchout on screen.

Tip  Depending on your design background, you can change display colors for 
unsewn stitches. See Change display colors for details.

Simulate design stitchouts

Stitch Player is an important tool in EmbroideryStudio. It lets you simulate the 
actual embroidery design stitchout on screen. Because Stitch Player emulates 
the movements of the embroidery machine, you are able to make decisions 
about how to optimize your design in order to lessen the load on the machine. 
This is important if you intend to make multiple stitchouts.

To simulate the design stitchout
 Choose a design view to visualize your design. Stitch Player can be run with 

or without TrueView™.
 Click Stitch Player or press Shift+R. 

 Optionally, use the slider bar to move the starting point.
 Use the controls to stitch forwards or backwards through the design. Typical 

‘media player’ buttons are available for play, pause, rewind operations.
 Use the Auto Pause control to set stop points – by color change, stop, or 

trim.

Use View > Stitch Player to simulate embroidery design stitchout on screen.

Adjust redraw 
speed

Set starting point

Use video controls to
run stitch player

Set design to pause at 
color changes, stops or 
trims
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 To redraw a section of design, specify a start and end stitch using the tabs.

 Use Auto Scroll when running Stitch Player at high zoom factors.

Tip  Depending on your background, you can change display colors for 
unsewn stitches, selected objects, object outline, grid and guides.

Related topics
 Change display colors

Travel through designs

It is useful to be able to view the stitching sequence color-by-color, 
object-by-object, or even stitch-by-stitch. The Travel toolbar provides all tools 
required to do so. Travel forwards or backwards with any button by right or left 
mouse-clicks. Traveling can be initiated from any stitch in the design. The 
current needle position is marked by a white cross or ‘needle position marker’. 
The current stitch number is displayed in the Status Bar.

Set stitch range to redraw section 
of design

Toggle Auto Scroll to view 
at high zoom factors
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To travel through a design
 Turn off TrueView™ and press the Esc to ensure no object is selected. 

 Travel to the start of the design by clicking the Start/End Design icon or 
pressing the Home key.

 Use the Travel by Stitch functions to travel forwards or backwards through 
the stitching sequence. Use left or right mouse-clicks or arrow keys – l or 
r, t or b. Alternatively, to travel by 1000 stitches, press Shift + Num+ or 
Shift + Num-.

 To travel by color, click/right-click Travel by Color. This is useful if you need 
to locate a specific color change in order to insert an object or delete it from 
the stitching sequence.

 To travel by object, click/right-click Travel by Object. Alternatively, press 
Tab or Shift+Tab. 

 To travel by machine function, click/right-click the Travel by Function tool. 
Alternatively, press Ctrl + Page Up or Ctrl + Page Down. The needle point 
will stop at every jump, trim, and color change in the design.

 It is sometimes easier to use Travel by Trim to travel by trim functions alone 
– e.g. when checking for unnecessary trims. Alternatively, press Ctrl + Left 

Use ‘travel’ tools to move through 
every component of a design

Travel to previous stitch Travel to next stitch
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Arrow or Ctrl + Right Arrow. Turn on Show Connectors and Show 
Functions to view while traveling.

Tip  While traveling through a design or editing stitches, click the Select 
Current icon or press Shift+0 to select the object associated with the 
current cursor position. 

Related topics
 Viewing color blocks
 Nesting objects

Select objects while traveling

Traveling is usually associated with checking the stitching sequence. You can 
select objects as you ‘travel’ through a design using the Ctrl key. 

To select objects while traveling
 Click the Select Object icon.
 Use the Travel by Object tool or Tab and Shift+Tab buttons to travel 

forwards or backwards by object. See Travel through designs for details.

 Click the Select Current icon or press Shift+0 to select the object 
associated with the current cursor position.

 Hold down the Ctrl key to select an object as you travel through it.

Travel by trims with 
connectors and functions 
showing

Click Select Tools > Select Object together with the Ctrl key to select objects as you 
travel through a design.

Left/right-click Travel > Travel by Object to travel to previous or next object.

Click Select Tools > Select Current to select the object associated with the current 
cursor position.

Press Shift 
+Tab keys

Press Tab key
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Viewing colorways

A ‘colorway’ is a color scheme or palette of thread colors. It may also include a 
background color, fabric sample, or a product image. In EmbroideryStudio, you 
can define multiple colorways for the one design. This means you can stitch out 
the same design in different colors on different fabrics. You can also print 
multiple colorways, icons of color blocks, and design backgrounds with the 
production worksheet.

Switch colorways

In EmbroideryStudio, you can preview the same design in different colors on 
different fabrics.

To switch colorways
 Open a design with multiple colorways.

Use Color > Current Colorway dropdown to select a new color scheme for 
design.

Use Color > Colorway Editor to assign thread colors to slots in the color palette.
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 Select a colorway from the droplist.

 Alternatively, use the Colorway Editor to toggle between colorways.

Related topics
 Colorways
 Change backgrounds

Change backgrounds

Select colorway

Select colorway

Double-click to edit 
background or 
product image

Click Color > Background & Display Colors split arrow to change the background 
color of the current colorway.

Use Color Palette > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle product image on/off. Right-click to open the 
Product Visualizer docker.
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EmbroideryStudio lets you set the background color, fabric, or product of each 
colorway for more realistic previews and presentations.

To change backgrounds
 Open the design and select a colorway. 

 Use View > Show Product to toggle on or off any product image that may 
be included in the colorway.

 Click the droplist next to the Background & Display Colors icon.
 Change color via the Background Color popout menu.

Select a colorway

Click arrow to invoke popup menu

Select background 
color
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 If your colorway includes a background fabric, change color via the Fabric 
Color popout menu.

 If your colorway includes an article or product, open the Product Visualizer 
droplist and change color via the Product Color popout menu.

Tip  Click Background & Display Colors or Product Visualizer icons to 
preset any of these options.

Related topics
 Adding colorways
 Fabric & product backgrounds

Change display colors

In addition to background color or fabric, display colors for borer holes, unsewn 
and selected stitches, object outlines and grid are part of the colorway definition. 
Change them if the default display color is not visible against the current 
colorway. The Background & Display Colors dialog includes a Display Colors 
panel.

Change fabric 
colors

Change product
color

Use Color Palette > Background & Display Colors (or Colorway Editor docker) to 
change design background presets for the current colorway.

Select display color 
to change
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Adjust colors as required for:

Display colors are saved with the colorway. You can save the colorway as an EMT 
template file for use in future designs.

Related topics
 Adding colorways
 Fabric & product backgrounds
 Working with templates

Viewing color blocks

Display item Description

Selected Selected objects or stitches.

Unsewn Unsewn stitches as they appear when traveling through the design.

Object outline Object outlines as they appear when Show Outlines is activated. See View 
embroidery components for details.

Needle points Change needle point display color according to current background. See 
also View embroidery components.

Grid Depending on the colorway, you may need to adjust grid display colors in 
order to view them against the background color. See also Measurements.

Guides Depending on the colorway, you may need to adjust guide display colors 
in order to view them against the background color. See also 
Measurements.

Borer Borer points. These are machine functions which only appear when Show 
Functions is activated. See View embroidery components for details.

Black needle points against
white background

Use Docker > Color-Object List to toggle the Color-Object List display on and off. 
Use to view and sequence objects in a design.

Use Color > Colorway Editor to assign thread colors to color blocks in the design.
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A color block corresponds to a color stop in the design. It may contain a single 
object or group of like-objects – e.g. ‘ropes’. Or it may be comprised of different 
objects of like-color – e.g. ‘ropes and birds’.

The Color-Object List offers an easy way to selectively view color blocks and 
embroidery objects. This is useful when re-sequencing. The View by Color 
function also lets you view objects by color. The Colorway Editor also provides 
a method for selective viewing of color blocks.

To display selected color blocks
 Click the Color-Object List icon. The Color-Object List can be docked to 

the either side of the design window, or floated in any position.
 Click the switch to view the list by color block.

Total color blocks, 
objects and stitches 
in design

Click to toggle
color blocks



EmbroideryStudio e4 User Manual 81

 Select a color block or blocks and click Locate and hold.

 Selectively hide or ‘unhide’ selected color blocks and embroidery objects 
using popup menu commands.

Select color 
block/s to view

Hold down Locate to
isolate selected blocks

Use commands to 
selectively hide or show 
color blocks and objects
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 Alternatively, select View > View by Color. Select the colors you want to 
view. This function will not work with grouped objects.

 Alternatively, click the Colorway Editor. Select a color block and click 
Locate and hold.

 To reveal all hidden objects press Esc followed by press Shift+S or select 
View > View all Colors.

Related topics
 Combining & Sequencing Objects
 Sequencing by color
 Viewing color blocks
 Naming design elements

Select color 
blocks to view

Select color
block

Click and hold to 
locate selected 
color block



EmbroideryStudio e4 User Manual 83

Viewing design repeats

Many customers make traditional garments such as sarees which employ 
continuous and sometimes overlapping designs. It is important to be able to see 
these designs together with their repeats. The Show Repeats function displays 
repeating designs, including sequins, in both TrueView and stitch view. You can 
view a design, even while digitizing, with any number of repeats. The number 
can be a whole number or fractional.

Note  It is important that the artwork you use is properly sized and in the correct 
horizontal position. Always check the position of your artwork before starting to 
digitize. 

To view design repeats
 Set your units of measurement as required. 

Note  Stitch length and density controls remain in mm regardless of 
measurement system. These controls reflect the machine functions as 
industrial machines are always in millimeters.

 The first time you use the feature, right-click the Show Repeats tool or press 
shortcut W to access the Repeats dialog.

Use View > Show Repeats to toggle design repeats display. Right-click for settings.

Vertical distance,
user-defined

Horizontal distance, user-defined 
or automatically calculated

Enter required number 
of vertical repeats

Enter distance 
between vertical 
repeats

Enter required number
of horizontal repeats

Enter distance
between horizontal

repeats

Select Show Repeats
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 Select the Show Repeats checkbox to activate the feature.
 Set the distance between horizontal repeats. This will always be expressed in 

millimeters. Depending on the template, different options are available:

 Enter the number of horizontal repeats. Repeats are balanced around the 
source design. This means that whole designs are displayed only for odd 
integer (1, 3, 5) numbers of repeats.

 Vertical distance is not constrained by needle or head distance. Vertical 
distance will be a function of design height. Set vertical distance and number 
of repeats as preferred.

 To help distinguish the source design from repeat patterns, Use the Colors 
option to display repeats in different colors. Enter a color offset to indicate 
where you want to start the first repeat color. Let’s say you have a 4-color 
design using palette colors 1, 2, 3, 4. If you set color offset to 5, repeat colors 
will display as 5, 6, 7, 8.

Option Purpose

Design repeat This option is only available with the Schiffli template. Repeat distance 
is fixed. This is typically a factor – x1, x2, x3, etc – of needle distance. 
See Schiffli Supplement for details.

Other When selected, you need to manually enter a repeat distance in mm. 
This is typically used when doing continuous design work on multihead 
machines. The figure will generally correspond to the distance between 
machine heads – e.g. 135 mm – or factors thereof.

Repeat Effect

1.0 The original design only is displayed.

1.2 • The original design is displayed, plus
• 0.1 of the design on either side of the original.

2.0 • The original design is displayed, plus
• 0.5 of the design to either side of the original.
The repeat pattern looks like this: ][][.

2.9 • The original design is displayed, plus
• 0.95 of the design to either side of the original.

3.0 • the original design is displayed, plus
• a complete copy of the design to either side of the original.
The repeat pattern looks like this: [][][].
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 Use the Show Repeats icon to toggle design repeats on or off.

Related topics
 Preparing artwork for continuous embroidery
 Set measurement units

Viewing design details

You can obtain design information in a variety of ways and formats – before 
opening the EMB file via Windows Explorer and from the Design Properties 
docker. See also Preview design reports.

View design details in EmbroideryStudio

You can check design details via the Design Properties docker. This is always 
advisable prior to design approval or stitchout. The opening tab contains 
information about design height, width, stitch count, colors, and so on. On other 
tabs, summary and order information may be provided by the digitizer or sales 

Source design

Use Docker > Design Properties to view and modify design details prior to design 
approval or stitchout.
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team. The information is printed with approval sheets and production 
worksheets. Choose a file and select Design > Design Properties.

Related topics
 Viewing & managing design information
 Managing quotes & orders

View design details in Windows Explorer

Even without opening EMB files, you can check software version number and 
other design details via Windows Explorer. This same dialog can be accessed 
from within the Open dialog in EmbroideryStudio as well as the 
Design Library.

To view design details in Windows Explorer
 In Windows Explorer, right-click an EMB file and select Properties from 

the popup menu. 
The Properties dialog displays with an EMB tab. View general file 
information, such as file size and modification dates, together with design 

Use tabs to view other design 
information, including orders and 
machine runtime estimates

Provide descriptive 
name as preferred



EmbroideryStudio e4 User Manual 87

information such as stitch count, number of stops and color changes, as well 
as machine format. 

 The Custom tab shares information with the Design Properties > 
Summary docker in EmbroideryStudio. 

Related topics
 Viewing & managing design information

Preview design reports

Approval sheets and production worksheets contain all or some of the design 
details contained in the Design Properties docker. Approval sheets are 
intended for customers, not production staff. Customers can see what they are 
ordering and approve accordingly. Production worksheets are intended for 
production staff. All production-related information, such as bobbin length, 
design size, garment fabric, etc, is provided.

Dedicated EMB
properties tab

Use Custom tab to 
provide additional file 
information

Click Standard > Print Preview to preview the production worksheet on screen.
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To preview a design report
 Click the Print Preview icon.

 To change paper orientation, click Landscape or Portrait. Large designs 
may be displayed over a number of pages.

 To change included information and set printing/plotting preferences, click 
Options. Here you can choose the report type – e.g. Approval sheet.

 To print the design, choose an option:
 Print Now: Click to send the design report to your local printer.
 Save as PDF: Click to save the report as a PDF document. You are 

prompted to save to the hard drive or network location.
 Send PDF via Email: Click to send the report – usually an approval sheet 

– as a PDF attachment to your local email client.
 To close the preview, click Close.

Related topics
 Viewing & managing design information
 Printing design reports
 Customizing design reports

Click Close to return to 
design window

Choose a print 
option

Order details

Modify report 
options
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Chapter 5

Threads & Charts

When you digitize, you select thread colors for each object from the Color 
Palette. The palette contains a selection of thread colors tailored to each design. 
This color scheme represents the actual threads in which the design will be 
stitched.

You can select colors from commercial thread charts containing a range of colors 
from different manufacturers. To save time when setting up new color schemes, 
you can create your own thread chart using your favorite or most frequently 
used colors. In EmbroideryStudio you can search for particular threads by 
criteria. Even match threads automatically from selected charts to colors in your 
design.
This section describes how to select colors from the Color Palette as well as how 
to assign threads to the colors in your design. How to modify thread charts is 
also covered, as well as creating custom thread charts.

Choosing thread colors

The color palette contains a selection of colors tailored to each design or color 
scheme. New objects are created using the currently selected color. You can 
change colors at any stage. Machine functions are automatically inserted in the 
stitching sequence whenever you assign a color. Typically you will want to assign 
actual thread colors to the Color Palette in these circumstances...
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 When you create a design, it includes a single default colorway. Using the 
NORMAL template, ‘Colorway 1’ contains default colors, unassigned to any 
thread chart. 

 When you convert vector graphics in CorelDRAW Graphics, colors are 
appended to the color palette as unassigned RGB values (if Match to 
Embroidery Palette is off).

 When you use the Color Wheel to create new color combinations, RGB 
values are added to the color palette.

 When you auto-digitize a bitmap, RGB values can be automatically matched 
to actual threads or simply added to the color palette.

 If you read a machine file, unassigned colors will be appended to the color 
palette.

 If you receive a design which uses colors from a thread chart you don’t have, 
you may want to match them to a preferred thread chart.

In EmbroideryStudio you can search for threads in one or several charts and 
assign them manually or automatically.

Note  Due to the differences in computer monitors and computer video cards, 
the approximate colors displayed should be used only as guides. Threads should 
always be matched to the appropriate physical color card.

Selecting thread colors

New objects are digitized using the current color on the Color Palette. You can 
change colors at any time.

Use Color Palette > Color Picker to pick up a color from an existing object and make 
it current.

Use Color Palette > Current Color to view current color.

Use Color Palette > Apply Current Color to apply the currently selected palette color 
to embroidery objects.

Use Color Palette > Add Color to add a color to the end of the color palette.

Use Color Palette > Remove Color to remove an unused color from the end of the 
color palette.

Use Color Palette > Hide Unused Colors to show or hide all unused colors in the 
color palette.

Use Color Palette > Remove Unused Colors to remove all unused colors from the 
color palette.
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To select thread colors
 Press Esc to deselect all objects. The currently selected (default) color is 

shown on the toolbar.

 Hover the mouse pointer over a color to view the thread code, thread name, 
and thread chart in a tooltip. Used colors are tagged with a blue square.

 Click a color in the Color Palette to make it current. Alternatively, pick a 
color from the design with the Color Picker tool.

Current color

Thread
description
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 Select object/s you want to recolor. Alternatively, select a color block in the 
Color-Object List.

 Select a color from the palette. Alternatively, transfer a used color to other 
objects with the Apply Current Color tool.

 Use the +/- buttons to add or remove color slots as needed.
 Use the Hide or Remove Unused Colors controls as preferred to compact 

the palette.

Related topics
 Changing color schemes

Assigning thread colors

The supplied charts represent the brands of threads that EmbroideryStudio 
supports. Each chart includes a range of thread colors together with code, brand 

Select new
color

Select objects or color
block to recolor

Use Color Palette > My Threads to search for and match threads from different 
charts, and assign for use.

Use Color Palette > Colorway Editor to assign thread colors to slots in the color 
palette.

Use My Threads > My Thread Charts to select the thread chart/s you currently have 
available for use.

Use My Threads > Assign Thread to assign selected thread to the current color slot 
in the color palette.

Use My Threads > Match All to match threads from the current chart/s to all color 
slots in the current colorway.
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and description. You can search for a thread by code or description and assign 
it to a selected design color slot. Alternatively, let the software match design 
colors to threads in the current thread chart/s.

To assign thread colors
 Press Esc to deselect all objects. The currently selected (default) color is 

shown in the toolbar.
 Select a colorway and click the My Threads icon. The docker opens.
 Click the My Thread Charts button to access the thread chart listing.

 Choose the chart/s you prefer or currently have available and click OK.

Click to open
thread charts

Assign preferred 
thread chart/s
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 Click a color in the Color Palette to make it current. The My Threads list 
updates automatically.

 Use the scrollbar to refine your search. Or, in the Search field, enter the first 
few characters of the required code or name. The code is the identification 
number of a thread color in a brand. The system searches for the closest 
match and displays it in the thread color list.

 Use the Assign Thread button, or double-click, to assign a selected thread 
to the current color slot. Alternatively, use Match All to assign threads from 
the current chart/s to all color slots in the current colorway.

 Check the thread assignments in the Color Palette by hovering the pointer 
over the slots.

 Optionally, click Remove Unused Colors to remove unused colors. 

Use scrollbar to
search

Current color

Double-click to assign
thread to current color

Selected thread
assigned
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Note  The Remove Unused Colors tool is disabled for machine formats that 
use needle addressing – i.e. that have Color Change set as Needle No in 
the Machine Format Settings dialog.

Thread usage estimates

In order to obtain more precise thread usage estimates, you can adjust fabric 
thickness to suit the target fabric. This may be necessary if you are planning a 
large production run. Settings are generally fine-tuned on a case-by-case basis. 
However, adjusted settings can also be saved to the current template.

To estimate total thread usage
1 Select Design > Design Properties > Stitching tab.

2 Click Length Calculation.

3 Enter the thickness of the target fabric.
4 Adjust the bobbin thread length according to the mixture of thread types in 

the design.
This factor provides a simple mechanism for a more accurate bobbin thread 
length estimate. The default value (100%) is suitable for a design with a 
mixture of stitch types. If the design is all Run stitches or all Tatami, more 
bobbin thread will be used and the factor can be increased say to 125%. If 
the design is all Satin stitch, the factor can be reduced to say 65%.

5 Click OK.
The Total Thread and Total Bobbin values are adjusted to take into 
account fabric thickness on total thread requirement.

6 Optionally, click Save to save revised settings to the current template.

Related topics
 Working with templates

Click to calculate thread 
and bobbin length

Enter target fabric 
thickness

Enter bobbin thread 
length as a %
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Recoloring consecutive objects

You can change the color of consecutive objects of the same color at the same 
time. 

To recolor consecutive objects
 Select the first object in the sequence to recolor.

 Select Object > Set Color. The Set Color dialog opens.

 Select the All consecutive objects of the same color option.
 Select a color from the list and click OK.

Related topics
 Select objects with Color-Object List

Managing thread charts

Thread charts in EmbroideryStudio represent the many different brands and 
colors of thread available. They may not always be accurate because thread 
manufacturers often change, delete, and add new colors to their lines. For this 
reason, you can update charts as necessary.

Editing thread colors

Blue Blue

Green

Change color of
consecutive objects

Select color

Red

Red

Green

Use Color Palette > Colorway Editor to modify threads in selected colorways.

Use Colorway Editor > Edit Color to modify thread information for the currently 
selected palette color.
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You can always change code, name, chart, thickness or thread colors. For 
example, in Schiffli work, you may want to change text labels to Parts A, B and 
C to reflect the pattern arrangements when printing. These labels appear on the 
production worksheet both in the stop sequence and in Color Film printout. 
Alternatively, you may want to edit colors in a colorway before you assign actual 
threads.

To edit thread colors
 Open the Colorway Editor and select your colorway.

 Select the thread to edit and double-click or click Edit Color.

 Edit thread details as required.

Related topics
 Creating colorways
 Assigning thread colors
 Modifying thread details
 Printing design reports

Select thread 
to edit

Click to view 
thread details

Click to select 
or mix color

Edit thread
details
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Creating & modifying thread charts

EmbroideryStudio lets you define your own charts. When you create a thread 
chart, you are creating a store of colors for future use. Select names that will 
help you remember the charts or help you sort frequently-used charts to the top 
of the list. Rename or remove charts at any time.

To create a new thread chart
 Select Manage Thread Charts via the Setup menu. Alternatively, click the 

My Thread Charts button in the Colorway Editor.

 Click Manage. The Manage Thread Charts dialog opens displaying the 
current thread chart.

 Click Create. The Create Thread Chart dialog opens.

Use Color Palette > Colorway Editor to create new thread charts.

Click to open
thread charts

Click to modify
thread charts

Click to create new chart

Enter new nameMy Thread Chart
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 Enter a name for the chart and click OK. The new chart is created, ready for 
you to add colors.

 Click Delete to remove the entire chart.

 Click Rename to change names.

Caution  Be careful when deleting thread charts. If you delete the wrong 
chart you will need to reinstall EmbroideryStudio to restore it.

Related topics
 Modifying thread details
 Copying colors between charts

Copying colors between charts

Copy colors between charts to create your own charts from existing threads.

Click to add your 
own threads

Click to copy 
threads from other 
chart

Click to rename Click to delete

Enter new thread 
chart name

My Thread Chart

My New Thread Chart

Use Color Palette > Colorway Editor to modify existing charts.
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To copy colors between charts
1 Select Setup > Manage Thread Charts. Alternatively, click the My Thread 

Charts button in the Colorway Editor and click Manage.

2 Create a new chart or open an existing one from the Name list.
3 Click Copy. The Copy Thread Chart dialog opens.

4 Select the source chart from the Name list.
5 Select the color/s you want to copy. Use Ctrl or Shift keys to copy a group 

or range of colors.
6 Click OK. All colors are copied to the new chart.

Modifying thread details

You can copy colors from other charts or mix them yourself. You can also set the 
code, description, brand, and thickness of existing threads. Remove obsolete 
thread colors for good housekeeping.

Select
thread chart

Click to create 
new chart

Click to copy 
threads from 
other charts

Select 
thread chart

Select color 
to copy

Use Color Palette > Colorway Editor to modify existing charts.
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To modify thread details
 Select Setup > Manage Thread Charts. Alternatively, click the My Thread 

Charts button in the Colorway Editor and click Manage.

 Create a new chart or open an existing one from the Name list.
 Click Add to add your own colors or Edit to change selected thread details. 

 Enter code, name, and chart for the thread color.
Code is the identification number of a thread color in a brand.

 Select the appropriate thread thickness. These values are added to or 
subtracted from values used in the Auto Spacing table for specific stitch 
lengths.

Tip  Lighter weight threads do not run so well in a production environment as 
the machines need to be slowed down in order to avoid thread breaks. 
However, lighter weight threads are good for very small lettering and 
fine-detail designs.

 Click More Colors in the droplist to see more colors or to mix your own. 
 Remove threads as required:

Thickness Description Default

A Normal embroidery thread (approx. denier 40) 0.01

B Thicker than normal (approx. denier 30) 0.03

C Finer than normal (approx. denier 80) -0.03

D Very fine (approx. denier 100) -0.06

Select
thread chart

Enter thread
details

Select thread
thickness

Click to select 
or mix color

1234

My Brand

Deep Purple
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 Click Remove to remove individual threads.
 Click Clear All to remove all threads.

Related topics
 Satin auto-spacing

Saving default thread charts to template

You can save your default thread chart by selecting it in the Colorway Editor 
and saving to the NORMAL template. Alternatively you can save a dedicated 
template for the particular thread chart and stitch settings you are using.

Related topics
 Working with templates

Overwrite existing
NORMAL template

or create a new one
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Chapter 6

Managing Designs

Design Library is a design management tool. Use it to browse design and 
artwork files stored on your PC or local network. Design Library capabilities 
make it fast and practical for daily commercial use, avoiding the need to switch 
to and from Windows Explorer. It recognizes all file formats used by 
EmbroideryStudio. It also makes it easy to search, sort and browse all 
embroidery designs on your network.

If you are already familiar with Windows Explorer, the interface will be quite 
intuitive to you. But there are some differences. Design Library is a ‘virtual 
library’ in that any designs on your system can be located and displayed within 
the navigation pane. Any folder containing embroidery designs which resides on 
your hard disk, external storage device, or local network can be included in the 
navigation pane. 
In a nutshell, Design Library lets you:
 Search for designs – including artwork files – anywhere on your local hard 

drive, network drives, or external devices such as USB or ZIP drive.
 Search by various means, including summary information such as design 

title, subject, authors, tags, etc. Order information can also be associated 
with any supported design file.

 Preview design information in the preview pane or Design Properties 
docker.
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 Create an organizing structure for easy categorization. Add to or remove 
design folders from your ‘virtual library’.

 Record and manage quotes, orders, and approvals.
 Batch-convert selected design files to all commercial embroidery formats 

such as DST, EXP, SEW, and others.
 Print selected designs or send them for stitchout to embroidery machine or 

to folders which machines can access for stitching.
 Use Design Library to handle quotes, orders, and approvals.

Design library layout

The Design Library is accessed from the Mode toolbar.

The library has five main components – toolbars, navigation pane, design 
display area, details pane, and Design Properties docker. The appearance will 
differ somewhat depending on your operating system.

Switch between Design Library 
and Wilcom Decoration

Navigation pane

Design display
area

Details pane

View (Manage Designs)

Manage Designs



EmbroideryStudio e4 User Manual 105

Library components are summarized as follows...

Viewing designs in network folders

Navigating to design folders with Design Library is similar to browsing with 
Windows Explorer. Your access to design folders on your local network is only 
limited by access rights determined by your System Administrator. View any 
supported file type residing in design folders. Designs can be searched, sorted, 

Component Function

Navigation pane The navigation pane in the Design Library is not an exact duplicate of 
your Windows Explorer folder structure. It is selective in that it only 
contains folders relevant to embroidery design and multi-decoration. 
Select and add any folder on your PC or network to view supported 
file types.

Design display 
area

The design display area shows any designs in selected folders 
corresponding to the filter selected or search criteria entered in the 
View (Design Library) toolbar. 
• Use the toolbar to filter the design display.
• Right-click selected designs to access a popup menu. Use it to cut, 

copy and delete without leaving the software.
• Use it also to zip designs and folders.

Details pane When a design is selected, summary information is displayed in the 
preview pane.

Design Properties 
docker

Check design details via this docker. This is always advisable prior to 
design approval or stitchout. Summary and order information may be 
provided by the digitizer or sales team. This information can be printed 
with approval sheets and production worksheets.

Toolbars

Mode Switch to Wilcom Decoration to digitize and edit embroidery designs.

Manage designs Open selected or recent designs, cut, copy and paste them, convert 
them, print them, or output them to any connected embroidery 
machine or data media.

View 
(Design Library)

Search or sort the entire embroidery library or any chosen folders on 
any criteria selected. Find and manage folders containing designs.

Click Mode > Design Library to open the Design Library window from which to 
search and catalogue designs as well as quotes, orders, and approvals.

Use View > Layout to toggle navigation pane, details pane, and/or preview pane 
display.
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grouped, and browsed by customer or order. Click the Design Library icon on 
the Mode toolbar. Design Library opens in its own window.

Design Library is ‘virtual’ in the sense that any designs on your system can be 
located and displayed within the library. This folder acts as a container which 
appears in Windows Explorer amongst your other Windows libraries. 

You can add folders both in Windows Explorer and in the Design Library 
itself. The initial folder structure is created by your installation. However, any 

Toggle panels
on/off

Navigation pane

Embroidery library
appears amongst
Windows libraries
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folders on your local network which contain embroidery designs or artwork can 
potentially be included and viewed in Design Library.

Tip  Like Windows Explorer, the Design Library display can be refreshed with a 
simple F5 keypress.

Change design display

Embroidery folder

Add folders

Use View > Change View to select thumbnails only, thumbnails with stitching 
details, or summary information only.
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Use the Manage Designs toolbar to control display of the navigation pane as 
well as thumbnail appearance. Use the Change View droplist to display designs 
in the preferred format.

Tip  The Design Library display can be refreshed with a simple F5 keypress, 
the same as Windows Explorer.

Viewing design details

Default detail columns vary by file type and are controlled by MS Windows®. 
Design Library, however, provides additional columns for data derived from 
embroidery files. These may include design status, customer, order date, etc. 
Such details are primarily intended for use with EMB but can also apply to other 
embroidery formats.

When viewing design lists in Details view, columns can be arranged in any order 
and with a variety of criteria. Sometimes Windows will reset detail columns to 

Display designs as
icons or lists

Use View > Reset Detail Columns to reset the columns displayed in details view to 
the default layout.

Embroidery data
listed by default
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Windows defaults, even for EMB files. To return to the default layout, simply click 
the Reset Detail Columns button. 

Group & sort designs

Various mechanisms are available for you to sort and group design listings...

The Group and Sort by droplists also provide a convenient mechanism for 
managing orders...

View zipped designs

View designs in zipped folders. The limitation is that the contents of zipped 
folders cannot be viewed as thumbnail images.

Click column
headers in list view

Use droplists and
toggles to sort

Group and sort by
same or mixed criteria

Access zipped
folders
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Related topics
 Supported Machine, File and Disk Types

Opening designs from Design Library

Embroidery files fall into two broad categories – ‘design files’ and ‘machine files’. 
Design files are ones you open and modify in Wilcom Decoration. Machine files 
are generally ones you send to machine for production. There is some 
inter-convertibility between the two formats.

Related topics
 Filtering designs
 Opening design files
 Opening new files from existing
 Opening machine files

Filtering designs

You can filter your embroidery library between file categories – design files, 
machine files, or all.

The Design Library can filter:
 All Wilcom-supported design files: EMB, ART, JAN
 All machine formats such as DST, EXP, JEF, etc.
 All artwork files read by EmbroideryStudio, both vector and bitmap

Filter designs 
by file type
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Related topics
 Supported Machine, File and Disk Types
 Working with Machine Files

Opening design files

Design files, also known as ‘all-in-one’ or ‘outline’ files, are high-level formats 
which contain object outlines, object properties and stitch data. When you open 
a design file in the software, corresponding stitch types, digitizing methods and 
effects are applied. Design files can be scaled, transformed and reshaped 
without affecting stitch density or quality. After modification, you can save to any 
supported file format.

Using the Design Library, you have the option of opening one or more selected 
designs in their own design tabs. Simply select a design or designs by holding 
down Ctrl as you click, and then click Open Selected.

Caution  Be careful not to open too many designs simultaneously. Potentially 
you could select all designs in the library and click Open Selected. This 
operation cannot be stopped and may result in the computer running out of 
memory.

Opening machine files

Different embroidery machines speak different languages. Each has its own 
commands for the various machine functions. Machine files, also known as 
‘stitch files’, are low-level formats for direct use by machines. They contain 
information about the position, length and color of each stitch. When they are 

Use Manage Designs > Open Selected to open design(s) selected in the 
embroidery library.

Select single or
multiple designs for

opening
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read into the software, machine files do not contain object information such as 
outlines or stitch types, but present the design as blocks of stitches. 

While machine files are generally not suited to modification, the software can 
‘recognize’ object outlines, stitch types and spacing from stitch data with some 
success. By default, machine files are converted to outlines and objects upon 
opening in the software. These ‘recognized’ designs can be scaled with stitches 
recalculated for the new outlines. Processing is effective for most stitch designs 
but cannot produce the same level of quality as original outlines and may not 
handle some fancy stitches.

Related topics
 Working with Machine Files

Opening graphic files

Artwork can be opened in EmbroideryStudio in both vector and bitmap (raster) 
formats via Design Library. Samples of both file types are installed with 
EmbroideryStudio in the Pictures library as shown below.

Extended support for CDR files
Design Library provides extended support for Corel CDR files. This includes:
 Right-click to access Windows operations – Open, Open With – directly into 

CorelDRAW Graphics. Or double-click to open a selected CDR file using the 
default template.

 Drag-and-drop from Windows Explorer into CorelDRAW Graphics.

Manual objects with no
outlines and manual

stitches only

Filter by 
graphic file
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 Drag-and-drop into Wilcom Decoration.
 Drag-and-drop into standalone CorelDRAW® Graphics Suite.

Note  For a full description of image file formats supported by CorelDRAW® 
Graphics Suite, refer to the CorelDRAW® Graphics Suite electronic User Guide 
available via the MS Windows® Start > Programs group. Alternatively, use the 
onscreen help available from the Help menu.

Related topics
 Digitizing with Bitmaps

Opening new files from existing

Instead of opening the original designs, you can use New from Selected. The 
only difference for practical purposes is that this command creates a copy which 
opens in a new design tab, thus preserving the original design file. Left-clicking 
uses the default template. Right-clicking allows you to select a different 
template from the dialog. Selection is remembered and used the next time the 
command is invoked.

The New from Selected command can also be used to open graphics files, 
including Corel CDR. With CDR, a new file is opened in EmbroideryStudio before 
switching to CorelDRAW Graphics.

Tip  If you want to open one design into another, an Import Embroidery 
function is available in Wilcom Decoration. Combine designs or design 
elements into a single design layout. 

Use Manage Designs > New from Selected to create new designs based on 
designs selected in Design Library.

Choose a 
template

Activate auto 
fabrics and choose 
a target fabric

Set background 
color and swatch

Choose a target 
machine format

Save as
default
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Related topics
 Combining objects & designs
 Working with templates

Inserting designs with Embroidery Clipart

The Embroidery Clipart feature is a powerful productivity tool which allows you 
to recycle commonly used elements. When you install EmbroideryStudio, the 
Embroidery Clipart feature is installed with the Design Library together with 
a sample clipart library.

When you first open EmbroideryStudio, it displays design elements currently 
included in the sample library. Use the Search functionality to filter your list 
according to name, keywords, number of colors, or number of stitches, etc. 
Once a suitable design element is located, simply drag-and-drop it as 
‘embroidery clipart’ into the current project. Scale to suit the design. Stitch 
colors are added to the design Color palette.
Use the Browse button to change to any Design Library folder on your 
system. For example, you may want to put together a design such as a wreath 
with components such as ribbons, leaves, fruit and flowers. With the clipart 
library this becomes a simple task.
Use Design Library to manage design elements in your clipart folders. Use 
Design Properties to assign names and keywords to each design element you 
save. Keywords play an important part in organizing a growing clipart library. 
Finding a suitable element can take time but keywords narrow the selection. Any 
number of keywords can be assigned to the same clipart element. See below.

Use Docker > Embroidery Clipart to toggle the docker display. Use it to record and 
recover re-usable embroidery elements.
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Related topics
 Combining objects & designs
 Inserting designs

Viewing & managing design information

Manage and check design details via the Design Properties docker. This is 
always advisable when receiving orders or prior to design approval or stitchout. 
Summary and order information may be provided by the digitizer or sales team. 
This information can be printed on approval sheets and production worksheets. 
Choose a file and select Design Properties via the View toolbar or Design 
menu.

All designs in Design Library can be tagged for easy search and find. Summary 
information such as design title, subject, authors, tags, is fully customizable. 
Order information can also be associated with any supported design file. All 
additional information is saved with the actual design file and can be viewed in 
any instance of EmbroideryStudio. It is often desirable to edit design details 
within the Design Library without having to open in the design window. This 
also enables customer service staff to enter/change details without modifying 
the embroidery design itself.

Caution  When updating information in the Design Properties docker, it may 
take some time for the index to update before you can search on that data.

Summary tab

Summary information about a design can be viewed and edited in the Summary 
tab. Generally this information is used to improve searchability. Use the 

Use View (Manage Designs) > Design Properties to view and modify design details 
prior to design approval or stitchout.

View file 
information

Add descriptive 
title
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information to search and filter designs by author, title, or subject. Tags can be 
added to improve searchability. Information can be added in the docker itself or 
in the Details pane (if activated). Click Save to save details with the design file.

Click a field and enter any text which will help you or others identify the design 
at a later date. All information on this tab is also included in the production 
worksheet. Information types include:

Related topics
 Preview design reports

Field Description

Title Defaults to filename. Add a more descriptive name for easy searching. 
This name appears on the approval sheet or worksheet.

Subjects This may conform to the primary category by which the design is cataloged 
– e.g. the name of the containing folder.

Authors Name of digitizer and/or designer – appears in production worksheet 
footer.

Tags Keywords for potential Design Library searches.

Comments These comments are included in the production worksheet and are 
intended for production staff. They may include instructions for machine 
operators.

Edit design summary
information for design

reports
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Design tab

Select the Design tab to view design details such as height, width, stitch count 
and colors. The data is extracted from the design file and, apart from design 
title, cannot be modified.

Fields include:

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. 
This name appears on the approval sheet or worksheet.

Height / width Total height and width of design extents. 

Stitches Total stitch count for design.

Colors Number of thread colors involved in the design.

Stops Normally color changes are associated with Stop functions. Depending 
on machine format, however, the design may include an additional last 
stop to ensure the machine returns to the starting needle for the next 
run.

Colorways Number of colorways in the design.

Trims Number of trims in the design. Generally, you will try to minimize the 
number of trims. 

Color changes Number of color changes required to stitch out design.

Appliqués Number of appliqué objects in the design (if any).

Sequins Number of sequins in the design (if any).

Bling Number of bling objects in the design (if any).

EMB grade While embroidery files are broadly classified as ‘outline’ (condensed) or 
‘machine’ (expanded), the software internally tags each as belonging 
to one of four types – native design (A), imported outlines (B), 
processed stitches (C), or imported stitches (D).

Design properties – not 
editable

Provide descriptive 
name as preferred
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Related topics
 Hooping Designs
 Using automatic connectors
 Embroidery file formats
 Machine formats

Order tab

Order information is saved directly with the design file. This allows embroidery 
orders to be managed via the designs they use without the need for a 
commercial database. The information is included on approval sheets.

Note the following:
 All fields in the Design Properties docker can be read and written in 

Design Library.

EMB version The version of EmbroideryStudio the file was created in – e.g. ES e4.

Stitch format The current machine format applying to the file. This generally 
corresponds to the target machine last used to stitch out the design.

Objects Indicates total number of objects in the design.

Field Description

Order information included 
on approval sheets

Date picker controls use regional 
settings for date format

Stores a list of customers 
for use between sessions

Add or delete 
sizes

Add or delete 
colors
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 Use Save and Reset buttons to ensure that updated fields are saved.
 The Color/Size/Qty table is included in the approval and production 

worksheets. 
 Click buttons to add rows and columns. 
 Double-click to edit labels.

 Numeric displays use locale settings.
 Date fields use locale settings.

Related topics
 Managing quotes & orders

Thread Colors tab

The Thread Colors tab displays the color sequence and stitch counts for each 
design ‘element’. Elements equate to color changes. The tab also provides 
thread usage estimates which may be used for costings as well as production 
requirements. This information cannot be viewed in Design Library. The design 
first needs to be opened in Wilcom Decoration.

Related topics
 Design properties thread colors
 Naming design elements
 Assigning thread colors
 Thread usage estimates
 Modifying thread details
 Setting other general options

Stitching tab

The Stitching tab displays technical stitching details mainly of use to machine 
operators. Information includes such details as target fabric, required 
stabilizers, as well as total thread estimates. These may be used for costings as 

Thread color details
not availabe in
Design Library



Chapter 6   Managing Designs 120

well as production requirements. Bobbin length calculation can be further 
refined if you are planning a large production run. 

Data is extracted from the design file and, apart from title and bobbin length 
calculation, cannot be modified. 

Related topics
 Working with fabrics

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. 
This name appears on the approval sheet or worksheet.

Auto fabric Predefined fabric settings used in current design. 

Required 
stabilizer

Indicates recommended stabilizer(s) for selected fabric type. 

Design area Total area covered by design – used for estimating hoop sizes, fabric 
requirements, 3D foam, or whether design will fit target location.

Total thread Indicates total meterage of top thread required to stitch out the design.

Total bobbin Indicates total meterage of bottom (bobbin) thread required to stitch out 
the design. These figures may be required for inventory control 
depending on business practices.

Length 
calculation

Allows you to revise thread usage estimates according to target fabric 
thickness. 

Left / right / up / 
down

Depending on where the design start/end point has been set, these 
figures indicate the distance from that point. 

Max/min stitch / 
jump length

The maximum and minimum stitch lengths, and maximum jump stitch 
length in the design.

Design properties – not 
editable
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 Managing fabrics
 Hooping Designs
 Thread usage estimates

Runtime tab

Once your machines have been defined, running times are displayed in the 
Design > Design Properties dialog Runtime tab. This tab lists available 
machines together with estimated runtimes based on stitch count and machine 
criteria. Runtime estimate, based on selected machine, can also be included in 
the production worksheet. This information cannot be viewed in 
Design Library. The design first needs to be opened in Wilcom Decoration.

Related topics
 Doing runtime estimates
 Managing quotes & orders

Locating designs in the library

Design Library is a ‘virtual library’ in that any designs on your system can be 
located and displayed within the navigation pane. The Design Library doesn’t 
care where they physically reside on your hard disk, local network, or external 
storage devices. Any folder containing embroidery designs can be included in the 
navigation pane.

Runtime details not
availabe in

Design Library
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Searching the library

Design Library allows for fast searching of designs on shared local network 
drives. This is important for businesses with multiple computers and multiple 
users creating and accessing EMB, machine files, or graphic files. 

Use the View toolbar to search for names or keywords or sort designs by name, 
create date, and other criteria. The Search field is very powerful.

Search criteria
In fact you can search on any criterion displayed on the preview pane. To begin 
with, select a file type to search on, and select criteria from the droplists.

Searchable fields include common commercial categories:
 Name
 Title
 Date modified
 Order #
 Order date
 Order due date
 Order notes
 Customer

Enter search 
criteria

Enter search 
stringSelect search

criterion

Clear search
field

Select file type to
search on
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 Contact
 Reference
 Sales rep
 Design status
Once you have selected a search criteria – e.g. ‘Order due’ – select further 
criteria from the second droplist.

Search strings
Optionally, enter search strings directly into the search field – e.g. ‘colors<5’ – 
meaning, ‘fewer than 5 colors’. Search strings default to ‘CONTAINS’ not 
‘EQUALS’ unless you enter a different criteria. 
There is also an ‘All’ criterion which allows you to do perform advanced queries 
using the Windows Search syntax such as:
author:”Wilcom” colors:<5 stitches:<3000
This will narrow the search to only those designs which:
 have been authored by ‘Wilcom’
 have less than 5 colors, and 
 have less than 3000 stitches.
Make sure you use correct syntax. Each field name must include a colon (:) after 
the name. Any names, such as ‘Wilcom’, need to be placed between double 
quotes – “Wilcom”. Use the Clear button to clear the Find field before 
conducting another search.

Reserved terms
Certain terms are ‘hard-coded’ in the design file. When conducting searches in 
languages other than English, you need to make sure that these ‘reserved’ terms 
are entered in English. Note that the following are not natively available in the 
Operating System and will always appear in English:
 Colors
 Height
 Machine
 Objects
 Stitches
 Trims
 Width

Select further
search criterion
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Note  Search criteria with two words needs to be entered without spaces as 
shown:

Note  When searching on non-reserved terms, you can search for two words 
separated by spaces and the search will turn up all designs with either word. If 
you want to find designs with both words, add a + between them – e.g. 
koi+fish. If you want an exact match, you need to include inverted commas in 
the search string – e.g “my design”. 

Adding folders to the library

Remember that the Design Library is a ‘virtual library’ in Windows. When you 
add or remove folders from the navigation pane, this only affects the 
Design Library. It does not affect the folder structure on your hard drive or 
network. To add design folders to your library, use the Manage Embroidery 

Search criteria Enter...

Color changes Colorchanges

Design status Designstatus

Order date Orderdate

Order due date Orderduedate

Order notes Ordernotes

Product colors Productcolors

Product type Producttype

Sales rep Salesrep

Use Manage Designs > Manage Embroidery Library Locations to add or remove 
existing folders from the Embroidery Library, enabling fast searching and filtering.
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Library Locations function to locate folders containing designs anywhere on 
your local network.

Use the Remove button to remove a folder from the Design Library. All 
subordinate folders will disappear from the navigation pane. The same 
functionality is also available via popup menu.

Add design folders from 
the local network

Remove location 
from the library
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Fast searching on shared network drives

For businesses with multiple computers reading and writing EMB or machine 
format designs, there is usually a need to store designs in shared network 
folders. You may want to set up a company server as a central repository for all 
design files. Connect any folders on the server to each client PC via 
Design Library. Design Library relies on Windows indexing to ensure fast 
searching.

To set up fast searching on shared network drives
 For the Windows file server, make sure you have the Windows Search service 

running. You will need a minimum of Windows Server 2008 on the server to 
enable fast-search indexing. You will also need some version of 
EmbroideryStudio installed.

 Add the design folder to be shared with the indexing function. Go to Control 
Panel > Indexing Options > Modify and select the correct path.

 Install EmbroideryStudio so that the Shell Extension is registered. This allows 
the server to index additional embroidery file properties.

 Once the server has finished indexing the folder, then, for every PC using the 
file server, add the design folder to Design Library. See above.

Note  Fast searching will not work with NAS type devices as they are 
non-windows based operating systems.

Managing quotes & orders

The Design Library provides a practical and simple method of recording and 
managing quotes, orders, and approvals. It is oriented mainly to ‘Custom Logo’ 
commercial embroidery, where a design needs to be stitched on a specified 
garment in a defined location. Order information is saved directly with the design 

Select design folder 
to share on the 
network
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file. This allows quotes and orders to be managed via the designs they use 
without the complications of a separate database.

Order details

Basic order details are stored as EMB file properties. Any alphanumeric 
information can be entered. Fields include:

Enter and edit
order details

Field Details

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. 
This name appears on the approval sheet or worksheet.

Design status Use ‘design status’ for digitizing and approvals – e.g. ‘Logged’, 
‘Verified’, ‘In Progress’, ‘For Review’, ‘Approved’.

Print approval 
sheet

Takes you to Approval Sheet print preview directly. You have the option 
of sending to a printer, printing a PDF, or sending by email.

Order details

Order # Embroidery company’s quote/order number

Order date Date the order was placed

Order due date Date the completed order is due

Order notes Internal notes for the sales/order staff. They do not appear anywhere 
other than here. The comments in the summary tab are included in the 
production worksheet and are intended for production staff.

Customer details

Customer Customer name and/or ID

Contact Customer contact person

Reference Customer reference / PO order or similar

Sales rep Name of salesman dealing with the customer
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Tip  Companies can and should establish guidelines for staff to enter consistent 
information. No checking or enforcement is done by EmbroideryStudio.

Related topics
 Printing design reports

Production jobs

A ‘production job’ in EmbroideryStudio is essentially one design on one garment. 
It is defined as:
 A discrete embroidery design
 To be stitched on a specified product in a specified location
 For a specific order number relating to a specific customer on a specific order 

date
 For a specified order quantity, broken down by color / size / quantity.
A customer order might sometimes require multiple production jobs. If so, you 
use separate EMB files for each job in the order. To see all jobs for a specific 
order, list designs by order # or customer, etc.

Multiple production jobs in one order
If a customer order requires multiple production jobs, separate EMB design files 
are created for each one. You can handle this in one of two ways. Either define 
a different internal order number for each job with a common stem. For 
example:

Alternatively, use the same order number and distinguish the job by file name. 
For example:

Product details

Product type Garment or article type – e.g. Polo Shirt

Position Position of design on the product

Quantity Total number of pieces to be stitched with design

Product Brand, style code, product name

Product colors May include product color code or name.

Color / Size / Qty Matrix of product color, size, quantity for the product

Field Details

Job Order # File Name

1 12345-1 DesignFile

2 12345-2 DesignFile

Job Order # File Name

1 12345 DesignFile-1

2 12345 DesignFile-2
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Design status
Design Status is managed by company staff who change the status manually 
when relevant. Designs can be searched, grouped, and managed by status. The 
droplist contains the following default values:

A staff member sets the status to indicate what he has done, not what is to 
happen next. Other staff monitor status via the Design Library in order to 
know when they are supposed to take subsequent action, and update status 
when they have done so.

Grouping & sorting production jobs
Company staff can use Design Library to see all jobs related to one order by 
searching or sorting by order number. You can also:
 Group by: Design Status, Customer, Order, Order Date, Order Due, Product 

Type
 Sort by: Design Status, Customer, Order, Order Date, Order Due, Product 

Type 

Order tracking

Order tracking typically involves some or all of the following steps:
 Staff enter basic order details and status in EmbroideryStudio and save as 

an EMB design file:
 Either a new file which serves as a design request to be digitized, or
 An already digitized EMB design which is to be used for the new order.

 Design Library automatically indexes order and design details for quick 
search and find.

 Staff use Design Library to view and manage designs as well as quotes, 
orders, and approvals. Browse, list, or search for designs by:
 Customer
 Order
 Date
 Size
 Design name
 Description, etc

 Order details are printed on approval sheets and emailed for customer 
approval.

 Order details are printed on production worksheets for production staff.

Status Usage

1-Requested Customer Service or Sales requests a new design to be digitized.

2-Assigned Digitizing manager assigns to an embroidery digitizer.

3-Digitized Digitizer finishes – design is ready for internal review.

4-Not Ok Digitizing was checked and found faulty – needs to be fixed.

5-Ok Digitizing was checked and found ok – Sales rep to send to 
customer for checking and approval.

6-Sent to Customer Sales rep has sent the design to customer for approval.

7-Approved Sales rep records customer approval.

8-In Production Production manager indicates the job is in production.

9-Job Done Production manager signs off when production job is done.
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 Staff use design status to track and manage order workflow, including list of 
designs:
 To be digitized
 Awaiting customer approval
 Ready for production, etc.

Order tracking by job role

Various job roles within the organization may be involved in preparing and 
managing orders.

All staff
All staff who have access to Design Library can:
 Easily search and view designs
 Manage and modify design properties
 Create design requests
 Create or modify actual designs
 Update design status.

Sales & customer service staff
Embroidery sales and customer service staff will use this kind of workflow:
 Create new design requests and enter order details in new or existing 

designs.
 Determine stitch estimates to help determine pricing for quotations.
 Visualize artwork or digitized design on the product to be embroidered.
 Estimate design run-time and job-time.
 Email approval sheets to customers for approval.
 Track status of designs and customer approvals.
 Release approved jobs for digitizing and/or production.

Digitizing managers & staff
Digitizing managers and staff will use this kind of workflow to plan and manage 
the design process:
 Review orders by customer, order, or date.
 Use ‘design status’ for digitizing and approvals. Staff update status manually 

as necessary.
 Designs can be searched, grouped, and managed by status.
 Track and manage internal checking status of newly digitized or modified 

designs.
 Track and manage previous and new designs by customer, order, date and 

other job details.

Production managers & staff
Production managers and staff will use this kind of workflow to plan and manage 
production jobs:
 Review orders which have been approved for production.
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 Check order details including:
 which designs to use for which order
 how many pieces to embroider on what products and in what position
 color/size/quantity details.

 Estimate design run-time and job-time.
 Help plan production schedules from order-due date, design statistics, and 

job quantities.

Converting designs

By default EmbroideryStudio saves designs to its native EMB format. This 
contains all information necessary both for stitching a design and for later 
modification. The Design Library conversion function allows you to 
batch-convert to and from all EMB and other supported design file types. It also 
batch-converts many machine file formats such as DST, EXP, SEW. 

To convert designs
 Select the file(s) to be converted and click the Convert Selected Designs 

icon. The dialog lists all machine file formats supports by the software.

 Select the file types you want to convert to.
 Click Browse to locate a destination folder for the converted designs.
 Click Convert to start the conversion. The converted designs will be stored 

in the nominated folder.

Related topics
 Working with Machine Files
 Sending designs to Connection Manager
 Supported Machine, File and Disk Types

Use Manage Designs > Convert Selected Designs to convert the design selected 
in the embroidery library into different machine file types.

Select machine file 
formats to convert to

Select target 
folder
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Outputting selected designs

Send designs to machine for stitching via Connection Manager. Create hard 
copy reports of a selected designs using a printer or plotter. Report types may 
include production worksheets, appliqué patterns, color films, as well as catalogs 
and lists of selected designs.

Sending designs to machine

EmbroideryStudio supports various machine models. Some can be connected by 
cable directly to your PC via USB port. Others require files to be placed in a 
specific network location or ‘watching folder’. Older-style machines do not 
support direct connection but they do read ATA PC cards and/or USB memory 
sticks. Connection Manager provides a method of connection to machines that 
appear as removable media or make use of third-party connection software. 
Once set up in EmbroideryStudio, a single click is sufficient to send the design 
to machine.

Note  You can only send one design at a time via Connection Manager.

Related topics
 Working with Machine Files
 Setting up machines for Connection Manager
 Machine Formats

Printing selected designs

You can print worksheets for selected designs, and include thumbnails of each 
in the worksheet. Unlike Print Designs, this option can provide design and 
sewing information.

To print selected designs
 Sort the designs to be printed using Sort.
 Select a design and click the Print Selected icon. The Print Design dialog 

opens.

Use Manage Designs > Send to Connection Manager to stitch out the design 
selected in Embroidery Library.

Use Manage Designs > Print Selected to print designs selected in the embroidery 
library.
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 To customize the printout, click Options.

 Set design report options to include the information you want in the format 
you require.

 The Worksheet type panel provides options for further customization. 
 Click OK and ensure correct printer settings in the Windows Print Setup 

dialog. The dialog and the settings available vary from printer to printer. See 
your printer manual for details.

Related topics
 Printing design reports
 Customizing design reports

Printing design catalogs

Report type Purpose

Approval sheet This is intended for the customer, not production staff. Customers can 
see what they are ordering and approve accordingly. 

Production 
worksheet

This is intended for production staff. All production-related 
information, such as bobbin length, design size, garment fabric, etc, 
is provided.

Production 
summary

This provides two summary tables of the design and associated 
colorways – a Colorway Summary together with a Design Summary. 

Appliqué 
patterns

This shows appliqué patterns – cutter information – isolated from the 
design. These can be used as a guide to cutting out fabric pieces. 
They also show which appliqué pieces are to be included.

Color film Provides a list of colors in the design, together with color and stitch 
information for each color layer. This helps the machine operator to 
see each stitch color in order of stitchout.

Use Manage Designs > Print Selected to Catalog to print selected designs to a 
catalog.
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Printed catalogs of your designs contain thumbnails of the designs plus limited 
text details. You can prepare catalogs of all your designs to suit your needs.

To print a design catalog
1 Open Design Library and filter designs as desired.

2 Select the designs you want to include in the catalog.
3 Select Manage Designs > Print Selected to Catalog. The Print Catalog 

Options dialog opens.

4 Adjust settings as preferred:
 Change Scale (%) to adjust thumbnail size.
 Select a catalog format – thumbnails with or without design details.
 Choose output target – PDF file or actual printer.

5 Click Print. The Print Design dialog opens.

Choose thumbnails 
with or without design 
details
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6 Click Preview to view the catalog.

7 To print the design, choose an option:
 Print Now: Click to send the design report to your local printer.
 Save as PDF: Click to save the report as a PDF document. You are 

prompted to save to the hard drive or network location.
 Send PDF via Email: Click to send the report – usually an approval sheet 

– as a PDF attachment to your local email client. The PDF is automatically 
identified by customer name, order number, and current date.

Tip  If the catalog requires more than one page, you can select which page 
to print in the MS Windows® Print Setup dialog.

Related topics
 Group & sort designs
 Printing design reports

Exporting design lists

The Export Design List option can be used to print design lists for selected 
folders. This option allows you to create a simple design report which can easily 
be imported into a spreadsheet. You may want to use this in order to manage 
designs by file name.

To export a design list
 Preset the measurement units you want to use – metric or U.S.

 Open the Design Library and select a design folder.

Use Manage Designs > Export Design List to export selected files to Tab and CSV 
(Comma Separated Value) formats suitable for use by most spreadsheets.



Chapter 6   Managing Designs 136

 Sort and filter the designs to export.

 Select all files to include in the export list.
 Click the Export Design List icon and choose a location to save the list. 

Choose whether to save as a tab-delimited or comma-separated text file.
 Open the text file in a spreadsheet for further sorting and printing.

Tip  Designers frequently want to distribute designs for viewing in real colors, in 
TrueView™ or otherwise, with or without fabric backgrounds. Screen images can 
be captured in PNG format and send as email attachments.
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PART II

HARDWARE & SOFTWARE SETUP

In order to work with your particular equipment, EmbroideryStudio needs to be 
properly configured. You may also want to configure the software to your 
particular design requirements.

Changing system settings
This section describes how to change the TrueView™ display, grid spacing and 
positioning, and Design Window scrolling options. It also describes how to save 
designs automatically as you work. There is also information about how to adjust 
the pointer position display, paste position options, and other general options. 
See System Settings for details.

Setting up hardware
This section describes how to set up digitizing tablets and embroidery machines. 
It also describes how to calibrate the monitor. See Hardware Settings for details.

Machine formats
This section describes how to select a machine format for a design and output it 
using other formats. It also explains how to customize machine formats to meet 
your machine’s specific requirements. See Machine Formats for details.

EmbroideryConnect machine networking
A Wilcom EmbroideryConnect machine network provides for wireless design 
transfer to embroidery machines with a USB port. When activated in the 
EmbroideryStudio software, you can send machine files wirelessly via a standard 
WiFi network to a compatible WiFi USB Stick plugged into the machine. See 
EmbroideryConnect Machine Networking for details.



EmbroideryStudio e4 User Manual 138

Chapter 7

System Settings

EmbroideryStudio lets you adjust various system settings controlling the 
appearance of designs on screen, display of design information, the behavior of 
the design window, and other settings.

Setting view options

You can preset viewing options for embroidery design elements as well as 
graphics.

Setting design viewing options

EmbroideryStudio lets you preset options to show or hide design elements such 
as stitches, outlines, and background fabric. You can also change TrueView™ 
settings for different viewing effects.

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.
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To set design viewing options
 Click the Options icon or select Setup > Options and select the View 

Design tab.

 Select viewing options to display. These control the same toggles as the View 
toolbar. The difference is that the selections you make here affect default 
system settings.

 Click TrueView™ Options to adjust TrueView™ settings.

 Adjust thread thickness and light source for preferred TrueView™ 
appearance. These settings also affect the appearance of printed TrueView™ 
‘virtual decoration’.

Note  This Thread Thickness setting only affects the TrueView™ display, not 
actual thread thickness values. 

Related topics
 View embroidery components
 Viewing design components

Select design 
elements to display

Select thread thickness

Select light source

TrueView™ – thick thread, light above TrueView™ – thin thread, corner light
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 Outputting designs as graphics

Setting image viewing options

You can dim bitmap image backdrops to make it easier to view stitches. You can 
also show colored vector graphics as outlines only.

To set image viewing options
 Right-click either the Show Bitmap or Show Vectors icon. The Options > 

View Graphics dialog opens.

 To dim a bitmap image backdrop, select the Dimmed checkbox.

 To view a colored vector graphic as outlines, select the Show Wireframe 
checkbox.

Use View > Show Bitmaps to show and hide bitmap images. Right-click to set 
image display options.

Use View > Show Vectors to show and hide vector graphics. Right-click to set 
image display options.

Use View > Show Graphics as Dimmed to dim graphic backdrops to show stitches 
more clearly for digitizing.

Show vector outlines

Dim images

Dimmed bitmap 
image

Original bitmap 
image

Vector outlines 
only

Original vector 
graphic
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Setting grid display options

EmbroideryStudio provides a set of grid lines to help accurately align or size 
embroidery objects. The Show Rulers & Guides feature lets you accurately 
place and align objects. When a design is saved, the ruler zero point and guide 
positions are saved with it.

Adjusting grid settings

Adjust grid spacing depending on the size of design you are working with. Use 
the Snap to Grid feature to align objects with the nearest grid lines. 
Checkboxes control the same toggles as the View toolbar. The difference is that 
the selections you make here affect default system settings next time you run 
EmbroideryStudio.

To adjust grid settings
 Right-click Show Grid. The Options > Grid & Guides dialog opens.

Click View > Show Grid to show or hide the grid. Right-click for settings.

Click View > Show Rulers and Guides to show or hide rulers and guides. Right-click 
for settings.

Drag the Ruler Zero Point to reset a new ruler zero point.

Set zero point
of your design

Enter grid
spacings Click to save for 

current template
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 Enter Grid Spacing values for horizontal and vertical grid lines. To save grid 
spacing to the current template, click Save.

 Select the Snap to Grid checkbox as required. Reference points, control 
points or leading edges of objects snap to grid during digitizing, sizing, 
reshaping, or positioning operations.

 Choose a snap method. You can choose whether to activate in X or Y axes or 
both.

 Select the Set Reference Point checkbox to set the zero point of the rule. 
For example, you can set the grid reference point to the design center. This 
is easier and faster than moving the whole design. When you close the dialog, 
you are prompted to mark the zero point of your design.

Tip  To temporarily disable Snap to Grid as you digitize, hold down Alt.

Related topics
 Display grids, rulers & guides

Adjusting rulers & guides

Rulers and guides are activated by the Show Rulers & Guides toggle. The unit 
of measurement – mm or inches – defaults to the regional settings in the 
MS Windows® Control Panel. The ruler scale adjusts with the current zoom 

Snap to Grid
in X only

Snap to Grid
in X and Y

Right-click View > Show Rulers & Guides to set the Snap to Grid and Snap to 
Guides options.
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setting. Guides can be used separately or in addition to grid lines for detailed 
work.

Snap to Guides can be set for guides independently of grid lines. Reference 
points, control points or leading edges of objects snap to guides during 
digitizing, sizing, reshaping, or positioning operations. To temporarily disable 
Snap to Guides as you digitize, hold down Alt.
The Show Column C Width Guide option activates a special cursor with the 
Column C tool. A circle appears at the cursor position corresponding to the 
width setting in the Object Properties docker. This is useful when digitizing a 
border based on a background image. When the offset is biased, two circles are 
shown, one for each side. 

Note  To gain the benefit of the width guide, you must accept the current width 
setting by pressing Enter, rather than digitizing reference points after finishing 
the centerline.

Related topics
 Display grids, rulers & guides
 Set measurement units
 Digitizing regular columns

Setting scroll options

The Options > Scroll tab lets you to control mouse pointer and mouse wheel 
behavior. Use Auto Scroll to scroll automatically while digitizing. This can be 
more convenient than using panning or scroll bars, especially when working on 
large designs. The dialog also lets you set four different mouse wheel behaviors.

Guides can be set 
separately or in 
addition to grid lines

Column C width
guide activated

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.
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To set scroll options
 Click the Options icon or select Setup > Options and select the Scroll tab.

 Adjust Auto Scroll options as needed. The effect only becomes apparent 
when you start to digitize. The design window automatically follows the 
current cursor position. 

Tip  Hold down the Shift key to temporarily deactivate Auto Scroll. Use the 
Ctrl+Shift+A key combination to toggle Auto Scroll on/off.

 Tick Center pointer when zooming to ensure that the pointer stays 
centered on screen at all times.

Setting reshape options

Stitch generation during reshaping operations can slow down your system. 
Reshape options let you choose whether stitches are generated immediately or 
only after Enter is pressed. This tab also controls node dragging behavior in 
Reshape operations as well as resequencing behavior in cutting operations with 
the Knife tool.

Option Purpose

Auto scroll Tick to enable automatic scrolling while digitizing.

Move pointer 
after scroll

Set pointer position afer each scrolling action:

Center: Use this setting for large movements.

Midway: Use this setting for smaller movements – e.g. when zooming 
into a small area of the design.

Corner: Use this setting for slow scrolling.

Response 
time

Adjust scrolling speed.

Adjust auto-scroll speed 
and pointer position

Select desired action for 
your mouse wheel

Right-click Reshape Tools > Reshape Object to set reshaping options.



EmbroideryStudio e4 User Manual 145

To set automatic stitch generation options
 Right-click the Reshape Object icon. The Options > Reshape dialog 

opens.

 Select options for generating stitches immediately after reshaping operations 
– i.e. for lettering objects, motif runs, and/or other objects. If left unchecked, 
any reshaping changes made are not updated until Enter is pressed.

 Select your preferred left mouse drag node behavior – Traditional or Bézier.

Generally, ‘bézier’ node dragging preserves the shape of the curve more 
closely.

 Select your preferred object-cutting reordering behavior.

EmbroideryStudio orders object fragments resulting from cutting operations 
with the Knife tool into a closest-join sequence that preserves the source 
object’s entry and exit points. There are three possible ways of reordering 
fragment objects:
 Reorder and create travel runs between objects separated by gap.
 Reorder, trimming between separated objects where necessary, but 

creating no travel runs.
 Combine fragments into a single branched object corresponding to the 

source object.
The option you choose will affect all Knife tool cutting operations.

Select object types for
immediate stitch

generation

Select preferred drag
node behavior

Original curve Bézier curve Traditional curve

Select preferred
object cutting

reordering behavior
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Tip  The Break Apart tool allows you to split branched objects, including 
objects resulting from cutting operations, into their component parts.

Related topics
 Reshaping objects with Bézier controls
 Cutting shapes manually
 Breaking apart composite objects

Setting general options

The General tab of the Options dialog provides a miscellaneous group of 
system settings including automatic save & backup, pointer position display, 
color handling for inserted files, paste position options, toolbar display, and 
others.

Setting automatic save & backup options

Save your work automatically at regular intervals using Auto Save. This 
protects you in the event of hardware or software failure. Click the Options icon 
or select Setup > Options and select the General tab.

Auto save
The Auto Save function creates a temporary file with the extension EMA in the 
RECOVER folder. This is automatically restored when EmbroideryStudio is 
restarted after a computer crash. You can access these files manually by 
browsing to the folder C:\Program Files 

Set auto-save
options

Set pointer position
display

Set Object Property
‘apply’ options

Set color handling for 
inserted files

Set continuous input 
for Column A digitizing

Set toolbar display 
options

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Select to
auto-save designs

Select to
auto-backup designs
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(x86)\Wilcom\EmbroideryStudio_e4.0\RECOVER and renaming files 
from EMA to EMB.

Backup copy
If the the Backup Copy checkbox is ticked, a backup copy of the current design 
file is automatically created in its previously saved form. This protects you from 
overwriting the design with unintended changes – e.g. using the Save option 
instead of Save As to save a modified design. The backup copy is saved in the 
BACKUP folder with the original file name and native file format. Access backup 
files manually by browsing to the C:\Program Files 
(x86)\Wilcom\EmbroideryStudio_e4.0\BACKUP folder.

Caution  Backup files remain in the BACKUP folder until you delete them. To 
prevent the folder from using too much hard disk space, delete unwanted files 
regularly. Backup files should be kept in a separate physical location, preferably 
off-site. Access the backup folder via the File > Open Backup Design 
command.

Setting pointer position display

When you move the mouse or digitizer puck, the pointer position is displayed in 
the Status bar at the bottom of the screen. You can optionally display the 
pointer position as a relative or absolute value. Click the Options icon or select 
Setup > Options and select the General tab.

Select a Relative or Absolute pointer setting:

The X and Y values show the horizontal and vertical distance of the pointer from 
the relative or absolute point. The L value is the length of the line connecting 
two points, while A is the angle of that line, relative to the horizontal. You can 

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Option Purpose

Relative Shows pointer position relative to the last digitized point or stitch point. 
Useful while digitizing or editing stitches.

Absolute Shows pointer position as an absolute value from the first needle point of 
the design. Useful for checking that the design fits a given area.

 Select relative or absolute
pointer position
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measure onscreen distances using the values in the Status Bar. You can also 
use the Measure function (M).

A negative X value indicates that the second point was placed to the left of the 
first. A negative Y value displays when the second point is below the first. 
Negative angles indicate angles of more than 180º – e.g. an angle of -60º is 
equal to 300º.

Related topics
 Measuring distances on screen

Setting color handling for inserted files

Whenever you copy and paste or insert an embroidery design or element from 
one file to another, the respective color palettes are merged. You have the option 
of adding the source palette to the target palette or of matching the source 
palette to the nearest colors in the target palette. 

X: horizontal Y: vertical L: length A: angle

X = 28.61 mm

Length = 33.47 mm

Status bar

Y = 17.38 mm

X = -28.61 mm

Length = 33.47 mm

Y = -17.38 mm

12

1 2

2

1

90º

-90º

-45º

45º135º

-135º

180º 0º

A=30º

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Colors added 
to palette

Colors matched 
to palette
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Click the Options icon or select Setup > Options and select the General tab.

Select an inserted embroidery file option:

Setting paste & duplicate options

You can control where an object is positioned when pasted. If you are pasting 
within the same design, the default is the same position from which the object 
was copied or cut. Other options are available.

Click the Options icon or select Setup > Options and select the Edit tab.

Set Paste and Duplicate with offset settings independently of each other as 
preferred. Paste options include:

Option Purpose

Add to palette Unique colors in the design are added to the current color palette.

Match to 
palette

When you insert a design, colors are matched to the current color palette. 
The system finds the nearest match based first on RGB values, and then 
on Brand and Code.

Select inserted 
embroidery file option

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Option Purpose

Object property 
position

Objects are pasted according to the coordinates in the Object 
Properties docker.

Shift pasted 
objects

Objects are pasted slightly offset from their original position. Adjust 
offset distance as preferred.

Pasted / duplicated 
objects offset from 
original

Select duplicate 
position setting

Select paste 
position setting
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Duplicate position settings are ‘nominal’ in that they apply to normal 
Ctrl+Shift+D operations. Clone by right-click and drag operations will override 
these settings temporarily.

Note  Paste and duplicate options control the physical position of the object in 
the design, not its position in the stitching sequence.

Related topics
 Copying & pasting objects
 Duplicating & cloning objects

Digitizing tools

The Continuous Input setting provides a simple and efficient way of digitizing 
a single Column A object comprised of separately stitched sections.

When Auto Fabric is turned off and the ‘use preset styles’ option is on, preset 
style are used. See Digitizing tools for details.
The 
Select the preset styles option for traditional digitizing tools as preferred. Preset 
styles use a set of predefined stitch types and underlay parameters for each of 
the traditional digitizing tools. These styles can be changed and saved to the 
normal template as preferred.
If you change underlay values while a digitizing tool is active, the change will be 
saved into the style for the session and the current document only.

3. When auto-fabric is off and "Use preset styles for traditional tools" is on; 
Column A, Column B, Column C, Complex Fill and Complex Turning objects get 
the underlay of the corresponding preset style: <PRESET_COLUMNA>, 
<PRESET_COLUMNB>, <PRESET_COLUMNC>, <PRESET_COMPLEX_FILL> or 
<PRESET_COMPLEX_FILL_TURNING> applied.

Center at current 
stitch

Objects are centered at the current needle position marker.

Start at current 
stitch

Objects are positioned after the current needle position marker.

Option Purpose

Use Standard > Options to access application options for digitizing tools.

Set continuous input 
for Column A digitizing
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When Auto Fabric is turned off, an underlay is still applied but it is based on 
the digitizing method.

Related topics
 Embroidery digitizing
 Creating smooth joins
 Working with styles

Setting toolbar display options

EmbroideryStudio allows you the choice of large or small button icons with or 
without short names. Click the Options icon or select Setup > Options and 
select the General tab.

Setting Object Property apply options

The most important dialog in EmbroideryStudio is the Object Properties 
docker. By default, modified object properties to take effect immediately. 
Alternatively, set the default to apply changes by means of an Apply button at 
the bottom of the docker. Click the Options icon or select Setup > Options and 
select the General tab.

Related topics
 Access object properties

Method Underlay 1 Underlay 2

Column A/B/C Edge run Zigzag

Complex/Turning fill Edge run Tatami

Lettering Center run N/A

Current default parameters used in all cases

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Choose large or small
button icons with or

without names

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Select object
properties default
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Setting other general options

Miscellaneous other system settings available via the Options > General tab:

These options include:

Tip  Use the measure tooltip in combination with the crosshair cursor on for 
more accurate measurements.

Setting warning options

Some warning messages may become distracting. You may want to switch such 
warnings off but still be able to re-activate them at a later time. The Options 

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Option Purpose

Closest join The Closest Join method (the default) automatically calculates closest 
join between objects while digitizing. When deactivated, entry/exit 
points of all newly digitized objects are set manually. See Embroidery 
digitizing for details.

Play button 
sounds

Enables beeping sounds made by the software in response to mouse 
clicks and pressing Enter or Spacebar keys while digitizing.

Cumulative stitch 
count

Displays stitch count as a cumulative total in the Stop Sequence tab of 
the Information docker. See also View design details in 
EmbroideryStudio.

Crosshair cursor Changes the default cursor pointer to crosshairs for more precise 
positioning. It is best used together with the grid.

Show New from 
Template dialog 
on startup

When activated, the New from Template dialog always displays when 
the software starts. See Working with design files for details.

Show measure 
tooltip

Shows length and angle in a tooltip when measuring distances on 
screen. See Measuring distances on screen for details.

Select other
general options

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.
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dialog includes a Warnings tab which allows you to re- or de-activate specific 
warning messages as desired.

Warning messages include:
 Changed Stitches: This appears when sending designs to Stitch Manager, 

depending on whether stitches need to be regenerated to comply with a 
changed machine format.

 Non-Native Design: This appears when opening ‘machine files’ of unknown 
origin. Machine files cannot be scaled by more than approximately ±5% since 
their stitch count does not change. By contrast, ‘outline files’ such as native 
EMB, can be scaled by any factor as stitches are dynamically regenerated.

 Fabric Settings Unchanged: This appears if you have chosen to work with 
an auto-fabric and wish to save changes made to object properties. Any 
changes are saved to the template, not to the fabric itself. Such changes are 
overriden by current fabric settings.

Select warning options 
to include / exclude
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 ZSK File Name: This appears if you try to save a design to ZSK TC format 
with an alphanumeric file name. ZSK machines require 8-digit filenames.

 Design Integrity Alert: This appears if the software detects a problem with 
the design file. If you see an alert, you should use Undo to return the design 
to an error-free state. Save the design. Then save a separate instance of the 
design up to the point the alert is generated. Send both designs to Wilcom 
Support for analysis.

Note  Turning off this message also turns off design integrity checking.

Related topics
 Sending designs to Stitch Manager
 Working with fabrics
 Supported Machine, File and Disk Types
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Chapter 8

Hardware Settings

You will need to connect peripheral devices for use with EmbroideryStudio. 
These may include digitizing tablets, plotters, printers, appliqué cutters, 
scanners and embroidery machines. Different devices are set up in different 
ways – some in MS Windows®, via the Control Panel, others within 
EmbroideryStudio itself.

EmbroideryStudio provides alternate means for sending designs directly to 
machine. Depending on your hardware, you can send designs directly using 
Stitch Manager, Machine Manager, or Connection Manager. Machine 
Manager is described in a separate Machine Manager Supplement.

Tip  The number of available ports limits the number of devices you can connect. 
If additional ports are required, you can add them. Multi-port serial cards can 
also be used. See a PC technician about your requirements.

Calibrating the monitor

You need to calibrate your monitor so that designs at 1:1 scale appear at real 
size. Do this when you first install EmbroideryStudio or whenever you change 
your monitor.
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To calibrate the monitor
1 Select Setup > Calibrate Screen.

2 Measure the height and width of the dialog box.
3 Enter the measurement in the Width and Height fields.
4 Click OK.

Related topics
 Viewing Designs

Peripheral device connections

Peripheral devices can be connected to your computer via USB port, serial port, 
parallel port, specialized network card, or Ethernet network. Local area networks 
(LANs) commonly use Ethernet networks for machine connection.

Note  For instructions on connecting devices to your computer and setting up in 
MS Windows®, see the documentation for the device as well as your 
MS Windows® documentation.

USB ports
Most machines now use USB port connection. They appear just like a disk drive 
on your PC so there is no need to configure communication parameters as for 
serial or parallel port connections. Some machines such as Janome MB-4 and 
Barudan are supplied with propriety connection software. EmbroideryStudio 
supports connection to these machines via the Connection Manager option. 
See Setting up machines for Connection Manager for details.

Serial ports
PC serial COM ports are male connectors, and can be either 9-pin or 25-pin. They 
are named COM1, COM2, COM3, etc. You must be able to identify the ports on 
your computer. (If in doubt, consult a PC technician.) When you set up a device 
that is connected via a serial port, you need to enter the serial port settings in 
EmbroideryStudio as part of the setup procedure. See also Entering serial port 
settings.

Measure width

Measure 
height
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The following table provides standard settings for various devices. They are a 
guide only. Settings for the same device may vary according to manufacturer. 
Check the documentation supplied with the device before setting up.

Tip  The number of available ports limits the number of devices you can connect. 
If additional ports are required, you can add them. Multi-port serial cards can 
also be used. See a PC technician about your requirements.

Setting up machines for Connection Manager

Newer machines use USB port connection. They appear as a disk drive on the 
PC. As such there is no need to set up communication parameters as for serial 
or parallel port connections. Some machines such as Janome MB-4 and Barudan 
LEM, are supplied with propriety connection software. To integrate with 
EmbroideryStudio, the relevant software needs to be installed on the same 
machine. Discuss with your machine supplier for details.

Setting up machines

EmbroideryStudio supports various machine models. Some can be connected by 
cable directly to your PC via USB port. Others require files to be placed in a 
specific network location or ‘watching folder’. Older-style machines do not 
support direct connection but they do read ATA PC cards and/or USB memory 
sticks. Connection Manager provides a method of connection to machines that 
appear as removable media or make use of third-party connection software. 
Once set up in EmbroideryStudio, a single click is sufficient to send the design 
to machine.

Device Port Baud Hand-shaking Data bits Stop bits Parity

Digitizer COM1 9600 None 8 1 None

Plotter COM2 9600 XOn/XOff 8 1 None

Tape Punch COM2 4800 XOn/XOff 8 1 None

Tape Reader COM2 4800 XOn/XOff 8 1 None

Embroidery Machine COM2 9600 Hardware 8 1 None

Use Standard > Send to Connection Manager to connect to supported machines 
via proprietary machine software.
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To set up a machine
1 Select Setup > Connection Manager Setup. Alternatively, click the Send 

to Connection Manager icon on the Standard toolbar. If no connections 
currently exist, a message appears.

2 Click Yes or Create to start setting up your connections. The Connection 
Settings dialog opens.

3 Select the connection type. Choose from:
 Machine folder – e.g. Barudan DFS, HappyLink/LAN, Brother PR series, etc
 Janome MB-4
 CAMS (rhinestone placement machine). 

4 Enter a unique name for the connection. This identifies the quick-access 
button on Standard toolbar and appears in the tooltip.

5 Choose an icon to identify the specific connection.

Enter unique 
connection name

Select connection
type

Set ‘watching
folder’

Select file type
required by machine

Select an icon to 
identify connection

Tick to automatically
rotate designs on

output

Specify file format
options
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6 Select the file type required by the machine. Depending on the chosen file 
type, the Options button may become available. This allows you to set up 
specific file format options from within Connection Manager without having 
to go to the Save As dialog. 

7 Enter or browse to a folder location on the network or PC which has been set 
up for the specific machine.
For example, if you choose to connect to a Barudan LEM design server, this 
allows you to set up a ‘watching folder’ which the server monitors for design 
files (U?? format). It then systematically converts to PRJ for machine 
communication. When you output a design, Connection Manager saves it 
to this folder in the specified format.

8 Optionally, tick the checkbox to rotate designs by 180º on output for cap 
applications. If ticked, all designs sent to that connection will be automatically 
rotated.

9 Click OK when complete. The new connection appears on the Standard 
toolbar.

Locate or create 
machine-specfic 
folder 

Tick for cap
applications

Quick-access button for
machine connection
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10 Repeat steps to set up more machine connections. As more machines are 
created, more quick-access buttons are added to the Standard toolbar. Each 
can be assigned its own identifying color.

All machines connections you define are listed in the Connection Manager 
Setup dialog. From here they can be updated or removed from the system.

Related topics
 Sending bling to CAMS machine
 Save designs
 Sending designs to Connection Manager

Automatic machine file naming

Connection Manager provides an option for automatic machine file naming. 
When enabled, the specified filename format is used for all machine connections 
established in Connection Manager.

Where...

Each connection is 
assigned a unique color

Update or remove as 
required

Setting Details

Filename format Filenames take the format <prefix><number>.<extension>

Prefix ASCII only, no unicode characters. No Windows reserved 
characters. Length limit 8 characters.

Number Numeric only. This sets the starting number. Range 1–99,999,999.

Interval Interval is numeric only and sets the number to increment each 
time a file is generated – e.g. ‘5’, ‘10’, etc. Range is 1–99.
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Note  When enabled, Kiosk also uses this auto-name specification for all 
machine files. If not enabled, it uses the kiosk machine file definition.

Related topics
 Lettering Kiosk

Setting up machines for Stitch Manager

Before sending designs via Stitch Manager, you must first configure the 
machine in EmbroideryStudio. Add machines, change existing machine settings, 
or delete machines no longer in use. Newer machines use USB connection. 
EmbroideryStudio supports connection to these machines via the Connection 
Manager option.

Setting up machines

To set up a machine you need to define a name, the port it is attached to, and 
the protocol it uses. For every machine, you need to select the machine format 
it supports.

To set up machines
1 Connect the embroidery machine using the instructions that came with the 

machine. Carefully note the port settings.
2 Run EmbroideryStudio. The port settings must now be entered in 

EmbroideryStudio Hardware Setup.
3 Select Legacy Features > Hardware Setup.

4 From the Type list, select Direct Machine Connection.
 To add a new machine, click Create.
 To change the settings of an existing machine, select it, then click 

Settings.

Use Legacy Features > Hardware Setup to set up a machine connection with 
name, port, and protocol.

Select Direct
Machine

Connection

Click to add 
machine

Click to access 
machine settings

Select machine
connection to

delete
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The Embroidery Machine Connection dialog opens.

5 Use the Name and Comment fields to uniquely identify the machine 
connection.

6 From the Port list, select the serial (COM) or parallel (LPT) port to which the 
machine is connected. 

7 From the Protocol list, select the protocol for the connection between the 
computer and embroidery machine.
See the documentation supplied with the embroidery machine to determine 
the appropriate connection.

8 Click Setup to access the serial port settings.
These settings must be the same as those set on the embroidery machine, 
or EmbroideryStudio will not be able to communicate with it. 

9 Select Auto Download to directly download designs to the assigned 
machine. Deselect it to confirm before sending.

10 In the Machine Type panel, select the compatible machine formats.
To do this, select compatible machine types in the Available list, and click > 
to move them to the For this machine list.

Note  Machine format values can be added or changed if required. 
11 Click OK to return to the Hardware Setup dialog.
12 Click Close. All machines connections you define are listed in the Hardware 

Setup dialog. From here they can be updated or removed from the system.

Note  Once machine setup is complete, you can stitch out a design via Stitch 
Manager without changing the original design format.

Enter machine
name

Select COM port
and protocol

Click to access 
serial port settings

Machine types 
supported by your 
machine

Click arrow buttons to swap 
machine types between fields

Select
machine type

Select Direct
Machine

Connection

Select machine
to update

Update or remove as 
required
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Related topics
 Peripheral device connections
 Serial ports
 Custom machine formats
 Sending designs to Stitch Manager

Entering serial port settings

PC serial COM ports are male connectors, and can be either 9-pin or 25-pin. They 
are named COM1, COM2, COM3, etc. When you set up a digitizer or machine that 
is connected via a serial port, you need to enter the serial port settings in 
EmbroideryStudio.

Note  You must be able to identify the ports on your computer. If in doubt, 
consult a PC technician.

To enter serial port settings
1 Select Legacy Features > Hardware Setup.

2 Select a device from the Type list and select an item in the Name column, 
then click Settings. The <Device> Setup dialog opens.

3 In the Connected To panel, select a serial port from the Port list. 

Use Legacy Features > Hardware Setup to set up a machine connection with 
name, port, and protocol.

Select device

Click to access 
device settings

Click Setup

Select serial port
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4 Click Setup. The Serial Port Setup dialog opens.

5 Enter the Baud rate, Data Bits, Stop Bits and Parity and Handshaking 
settings for the device. 

6 Click OK.

Note  The port settings must match those of the embroidery machine or 
selected device. The type of handshaking must match the type of cable you 
are using. Check the communications setup section of the documentation 
that came with the device.

Related topics
 Connecting digitizing tablets
 Serial ports

Doing runtime estimates

EmbroideryStudio provides a Runtime Analyst feature for calculating 
estimated running times for embroidery files using specified RPM values and 
other runtime parameters. These are used on a design-by-design basis to 
determine scheduling, running costs, and payments for production staff. Output 
can be used by any third-party software such as ERP or accounting systems.

Typical usage
Information can be made available to various stakeholders for payroll, 
estimations, and scheduling. For instance:
 The designer creates a new design and saves as EMB and/or machine file such 

as U11.
 EmbroideryStudio automatically calculates running time.
 Calculated results are saved to CSV file in a designated file location.
 The payroll department accesses the CSV file and calculates pay rates for the 

design. For example:
 A payroll clerk may need to find out what the runtime will be for a given 

job in order to pay the machine operator.
 A manager may need to provide an accurate runtime estimate for any 

given design so the payroll department is able to process machine operator 
payments.

 The ERP system accesses the CSV file for estimation and scheduling 
purposes.

 Runtime information may be communicated to a machine operator who needs 
to know the runtime estimate for a specific job.

Enter port settings for 
embroidery machine or 
selected device
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Configuring machine runtime settings

You can set up multiple named machines for the purposes of runtime analysis 
with specific parameters such as ’fast speed’, ’slow speed’, ’trim time’, ’color 
change time’, etc.

To configure machine runtime settings
1 Select Setup > Machine Runtime Setup. Or run the command from the 

Design Properties > Runtime tab.
The Machine Runtime Setup dialog opens. The dialog lists all machines 
currently defined for the purposes of runtime analysis.

2 Click Create to set up a new runtime definition. The Machine Runtime 
Settings dialog opens.

3 Use the Name and Comment fields to uniquely identify the machine or 
machine class.
The class may be based on machine model. However different machines of 
the same model may be set up for different purposes – e.g. to run at different 
speeds. If so, you’ll need to set up different classes to suit.

Note  Machine types set up here are independent of machines defined in 
Connection Manager Setup or Embroidery Machine Connection dialogs.

Create a new runtime 
definition

Name the machine

Specify runtime 
parameters
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4 Create a runtime definition for the machine. Parameters are based on 
machine specs, controller feedback, and/or empirical observation:

5 Click OK. All machines or machine classes you define are listed in the 
Machine Runtime Setup dialog. From here they can be updated or removed 
from the system.

Outputting design information to CSV

Design information, including runtime estimates and relevant parameters, can 
be output to CSV file for later use by third-party applications. New data is 
appended to the file. 

Estimated running times
Once your machines or machine classes have been defined, estimated running 
time for a specific embroidery file is displayed in the Design Properties > 

Parameter Description

Normal (high) 
speed

The speed at which the machine normally sews. Normally available 
from machine specs.

Slow speed The slowest speed at which the machine runs. Normally available 
from machine specs.

Slow above The length of stitch above which the machine slows down. This 
value is automatically adjusted according to speed settings, in 
particular slow speed. Should be available from the machine 
specs.

Trim time The time the machine takes to perform a trim. May be available 
from machine specs or empirical observation.

Color change 
time

Same as for trim time.

Stop time Time spent stopping in order to place fabric, foam, etc. This is 
normally determined through empirical observation. The number of 
heads on the machine will be a determining factor – e.g. 16 heads 
x 6 secs each.

Design start time Time the machine takes to go from stop to normal speed – e.g. it 
may stitch a number of slow stitches to start off. May be available 
from machine specs or empirical observation.

Design end time Stopping time – the machine may slow down and then travel to the 
center of the hoop before actually stopping.

Update or remove as 
required

Use Docker > Design Properties to view and modify design details prior to design 
approval or stitchout.
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Runtime tab. This tab lists available machines together with estimated runtimes 
for the current design. 

Related topics
 Runtime tab

Cost of fabric parameters
An Design Area field on the Stitching tab shows the total design area. It is 
calculated by multiplying design width and height, not actual stitched area. This 
figure is used to estimate the cost of fabric or 3D foam that can be used in the 
design.

Estimated runtime per 
machine for current design

Total area used to estimate 
cost of fabric or 3D foam
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Export options
Design information can be written whenever the design is saved or recorded to 
DesignWorkflow database. An Options > Export tab allows you to preset these 
options.

Manual export
The File > Export Design Properties command allows you to output current 
design information and machine runtime settings to CSV file.

The CSV output file includes the following fields. The first group derives from the 
Design Properties > Information tab. The second group derives from 
Machine Runtime Settings.

Field Description

Design properties Data derived from design properties

Date Date and time of exporting properties.

File name Name design saved under.

Machine format Machine format of design.

Stitches Total number of stitches in design.

Colors Total number of thread colors in design.

Color changes Total color changes – may or may not coincide with number of 
colors.

Stops Number of machine stops in design.

Trims Number of trims in design.

Sequins Number of sequins in design.

Blings Number of individual rhinestones in design.

Thread length (m) Total length of thread used in design.

Height (mm) Height of sewing area - derived from design extents.

Width (mm) Width of sewing area - derived from design extents.

Area (mm²) Area covered by design - calculated according to design extents.

Runtime data Data derived from machine runtime settings

Below / Above Number of stitches stitched at slow and high speed according to 
’slow above’ parameter. Combined numbers should equate to 
’Stitches’ value.

Automatically
record runtime data

to CSV file

Manually output design
information, including

runtime data
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Related topics
 Viewing design details

Printing runtime estimates

The Production Worksheet prints runtime information. Three fields pertaining 
to the information appear under the Blocks tab – ’Area’, ’Total thread’ and 
’Machine runtime’.

The Machine runtime checkbox is only available if the feature is available in 
the software. If there are no machines set up, checking ’Machine runtime’ has 
no effect as there is nothing to print. Total thread prints the information of the 
same name in the Design Properties docker. This information is included in 
both Production Worksheet and Production Summary.

Related topics
 Viewing design details
 Customizing design reports
 Printing design reports

Machine Machine as shown on Machine Runtime Setup dialog. If there 
are multiple machines defined, a separate line entry appears for 
each.

Normal (high) speed 
(RPM)

Runtime setting as shown on Machine Runtime Settings dialog.

Slow speed (RPM) Ditto

Slow above (mm) Ditto

Trim time (sec) Ditto

Color change time (sec) Ditto

Stop time (sec) Ditto

Design start time (sec) Ditto

Design end time (sec) Ditto

Runtime (min:sec) Calculated runtime of this design according to particular 
machine as shown on Design Properties > Runtime tab. If there 
are multiple machines defined, a separate line entry appears for 
each.

Field Description

Runtime estimate
settings
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Setting up scanners

EmbroideryStudio supports TWAIN-compatible scanners. Some scanners will 
not work with EmbroideryStudio because they require their own scanner 
software. If this is the case with your scanner, use your scanner software for 
scanning, save the image to your hard drive, then load the image into 
EmbroideryStudio.

To set up scanners
1 Connect the scanner using the accompanying instructions.
2 Set it up in MS Windows® using the accompanying instructions and/or the 

Microsoft MS Windows® documentation.
3 Start EmbroideryStudio.
4 Select Setup > Scanner Setup. The Select Source dialog opens displaying 

a list of scanner drivers loaded on your computer.

5 Select the scanning driver to use, then click Select.

Note  If you have trouble with scanning after re-starting EmbroideryStudio, 
there may be a conflict with previously installed scanner drivers. Re-install 
EmbroideryStudio and test the scanner. If the selected scanner driver does 
not work in EmbroideryStudio, select another scanner driver from the list. 
There are usually two installed for each scanner.

Connecting digitizing tablets

You can use a digitizing tablet and puck with EmbroideryStudio as an alternative 
to digitizing directly on-screen. To use a tablet, you place an enlargement 
drawing on the active area, and use the puck to mark reference points.

Select scanning
driver

WACOM Intuos3 digitizing table 
featuring 1024 levels of pressure 
sensitivity and pen tilt sensitivity. 
Can be used with a normal mouse 
or lens cursor
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Caution  EmbroideryStudio cannot use the MS Windows®-compatible drivers of 
some tablets – e.g. GTCO and Calcomp tablets. Earlier versions of WinTab do not 
free up the COM port, even when it is not in use. This means EmbroideryStudio 
is unable to communicate with the digitizing tablet. Check with the tablet 
manufacturer to obtain a version of tablet software which will free the port when 
not in use. Alternatively, the software may disable or uninstall WinTab, or use 
another COM port when working with EmbroideryStudio.

Setting up digitizing tablets

EmbroideryStudio can only support one tablet at a time. The format and the 
preferred pointer display mode must be specified. 

To set up a digitizing tablet
1 Connect the digitizing tablet and puck using the accompanying instructions, 

and run EmbroideryStudio.
2 Select Legacy Features > Hardware Setup.

3 From the Type list, select Digitizer.
4 Click Settings. The Digitizer Setup dialog opens.

5 Use the Name and Comment fields to uniquely identify the digitizing tablet.
6 In the Format panel, select a digitizer format.

Use Legacy Features > Hardware Setup to set up a machine connection with 
name, port, and protocol.

Select Digitizer

Click to access 
digitizer settings

Enter name

Select digitizer
format

Select input mode

Select COM port Click to access 
serial port settings
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Select from standard digitizer formats or select Auto Detect to automatically 
match the format to the connected digitizer. Not all digitizers can be 
automatically detected by EmbroideryStudio. For these tablets, you can 
define a new format or modify existing format settings.

7 From the Input Mode list, select Point or Stream.
This setting must be the same as the one you specified on the digitizing 
tablet:

8 From the Port list, select the COM port to which the digitizer is connected.
Digitizing tablets generally connect to COM1 but can connect to any available 
serial COM port. 

9 Click Setup to access the serial port settings.
These settings must be the same as those set on the digitizing tablet, or 
EmbroideryStudio will not be able to communicate with it. 

Note  If you use Stream mode, you need to set the digitizer to transmit at 
20 data packets per second or less. The baud rate for the digitizing tablet and 
serial port must both be set to 9600 baud. 

Caution  To avoid loss of data at high speed, it is important to set up the 
tablet correctly. If it can only transmit at greater than 20 data packets per 
second, reduce the baud rate of the tablet from 9600 baud to 2400 baud.

10 Click OK then Close.

Related topics
 Customizing digitizing tablet formats
 Serial ports

Customizing digitizing tablet formats

If the digitizing tablet format you require is not preset in EmbroideryStudio, you 
can create a new format, or modify an existing format to match the output of 
your tablet. Before starting, review the digitizing tablet documentation.

Caution  This functionality is provided for advanced users with knowledge of the 
data protocols supported by their digitizing tablet. Only use it if your digitizing 
tablet does not work with any existing formats.

Mode Description

Point In this mode, the pointer position on screen is only updated when you 
click a button on the puck.

Stream In this mode, the pointer position is continuously updated. When you 
move the digitizer puck on the tablet, the pointer moves on screen.
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To customize a digitizing tablet format
1 Access the Digitizer Setup dialog. 

2 In the Format panel:
 To modify an existing format, select the format and click Modify.
 To define a new format, click Create.
The Custom Digitizer Setup dialog opens.

3 In the Format Name field, enter a name for the new or modified format.
4 In the Format String field, enter the format string your digitizing tablet 

outputs.
Obtain this information from the digitizing tablet documentation.

5 In the Scale field, enter the scale at which you are digitizing.
For example, a scale of 3.0 means your on-screen design will be one third the 
size you digitize on the tablet.

6 Click OK.

Related topics
 Setting up digitizing tablets

Preparing enlargement drawings

When you digitize with a tablet, you use an enlargement drawing to trace the 
shapes and outlines of the design in the same way you use backdrops on-screen. 
Before you start, you need to prepare the enlargement drawing.

To prepare an enlargement drawing
1 Convert the artwork to a technical drawing.

Generally the drawing will be three times larger than the final embroidery.

Tip  If the drawing is in hard copy, scale it using a transparency projector or 
photocopier. If you used a graphics application to create the artwork, scale it 
before you print it out.

Select digitizer
format

Modify existing 
format

Create new format

Enter format
name

Enter format
string for tablet

Enter digitizing
scale
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2 Modify the drawing to make it suitable for embroidery:
 Define shapes that can be easily filled with stitches.
 Overlap and distort shapes to compensate for push-pull.
 Draw digitizing guidelines – e.g. stitch angle lines.

3 Draw origin and rotation reference points.
These points set the position and orientation of the enlargement drawing on 
the digitizing tablet. 

Tip  If the drawing is bigger than the digitizing tablet, enter additional points 
to help you shift the drawing as you digitize.

4 Write the name and scale of the enlargement drawing for future reference.

Related topics
 Shifting enlargement drawings

Registering enlargement drawings

When you place an enlargement drawing on the digitizing tablet, you need to 
register it so EmbroideryStudio can interpret the design. To register an 
enlargement drawing, enter the scale, and digitize the origin and rotation points 
on the tablet. The origin and rotation points should be marked on the 
enlargement drawing. If they are not, you need to draw them in.

Origin

Rotation reference 
point

Scale

Name flower

3:1
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To register an enlargement drawing
1 Select Setup > Tablet Setup.

2 In the Drawing Scale panel, enter the scale of the enlargement drawing.
To calculate the scale, divide the height the enlargement drawing by the 
required height of the final embroidery. Enlargement drawings are generally 
prepared at a scale of 3.00.

3 Tick the Save as defaults checkbox. This saves the registration information 
for this drawing so you do not have to re-register each time you resume 
digitizing. 

4 Click OK and place the enlargement drawing on the digitizing tablet.
5 Click the origin and rotation points of the drawing with Button 1 of the 

digitizing puck. This completes the registration.

Changing drawing scales

You can change drawing scale during digitizing. When you change scale, 
EmbroideryStudio automatically resizes object outlines and regenerates the 
stitches.

Enter drawing
scale

Select Save as
defaults

Origin

Rotation reference 
point

flower

3:1
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To change the drawing scale
1 Select Setup > Tablet Setup.

2 Enter the new drawing scale. To calculate the scale, divide the height the 
enlargement drawing by the required height of the final embroidery. 
Enlargement drawings are generally prepared at a scale of 3.00.

3 Tick the Resize Design to Match Drawing checkbox.
4 Tick the Register Drawing checkbox.
5 Click OK.
6 Digitize the origin and the rotation reference points to re-register at the new 

size.
The design is resized to the new scale.

Shifting enlargement drawings

If the drawing is bigger than the digitizing tablet, you can move it across the 
tablet and continue digitizing. To move a drawing you need to draw, and digitize, 
two additional reference points.

To shift an enlargement drawing
1 Draw additional reference points on the enlargement drawing. 

Position the points so that they will be on the active part of the digitizing 
tablet both before and after the move.

Tip  If you are shifting the drawing up or down, draw the additional reference 
points horizontally. If you are shifting left or right, draw them vertically.

2 Select Setup > Tablet Setup.

3 Tick the Shift Drawing checkbox.
4 Untick the Register Drawing checkbox and click OK.

Enter new
drawing scale

Tick to resize design to
drawing size

Deselect

Select
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5 Click the additional reference points with Button 1 on the digitizing puck.

6 Move the drawing so that the part you want to digitize next is over the active 
area of the digitizing tablet, and click the additional reference points again. 
The drawing is re-registered in the new position.

Using digitizing pucks

With a digitizing tablet, you generally use a puck instead of a mouse to mark 
reference points.

To use a digitizing puck
 Position the cross-hairs of the puck over a point on the enlargement drawing 

then press one of the four buttons.

Function Button
Mouse or keyb’d 

equivalent
Description

Digitize corner 
point

1 [ Digitize corner reference point when digitizing outlines.

Digitize curve 
point

2 ] Digitize curve reference point when digitizing outlines.

Terminate 
omitting last 
stitch

3 M • Terminate input omitting last stitch – i.e. the fill is terminated on 
the opposite side as the last input point.

• Toggle between selected fill stitch type and input method, and 
the Run input tool.

Terminate 
including last 
stitch

4 R • Terminate input including last stitch – i.e. the fill is terminated 
on the same side as the last input point.

• Toggle between selected fill stitch type and input method, and 
the Manual input tool.
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Chapter 9

Machine Formats

Different embroidery machines speak different languages. They have their own 
control commands for machine functions. Before you can stitch a design, it must 
be in a format which can be understood by the machine. When you select a 
machine format, EmbroideryStudio uses it to translate digitized designs into a 
specific machine-readable form. If required, you can customize machine formats 
to meet specific machine requirements.

Standard machine formats

Different machines require different settings. When you select a machine 
format, EmbroideryStudio uses it to translate digitized designs into a specific 
machine-readable form. Common formats include Barudan, Brother, Happy, 
Marco, Meistergram, Melco, Pfaff, Stellar, Tajima, Toyota, Ultramatic and ZSK. 
Typical modifiable values include stitch and jump length, trim functions and color 
change functions.

Note  Not all values described here are available for all machine formats. See 
your embroidery machine manual for details.

Setting stitch & jump length

With most machines you can set maximum frame movement, minimum stitch 
length to recognize, and automatic jump length.
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To set stitch and jump length
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Maximum Stitch field, enter the maximum stitch length to allow.
The value you enter depends on the tape code used by your machine:
 Binary coding system: 12.7 mm – e.g. Barudan machines
 Ternary coding system: 12.1 mm – e.g. Tajima machines.

4 In the Minimum Stitch field, enter the minimum stitch length to allow.
This sets the default Small Stitches value. Generally the minimum stitch 
length is increased for dense materials and thick threads to prevent thread 
breakage.

5 In the Maximum Jump field, enter the maximum jump length to allow.
This sets the default Auto Jump value. Shorter jump values generally improve 
stitch quality and reduce wear on the machine but may increase stitch-out 
time.

6 Click Save then Close.

Related topics
 Machine formats
 Eliminating small stitches

Setting trim functions

With some machine formats you can specify how to format and interpret trim 
functions. Some machines understand specific trim codes. Others interpret 
multiple jumps as a trim function. Machines without an automatic trimmer may 
not know how to interpret trim functions, and may even shift the design when a 
trim code is encountered. For these machines you need to deselect the Output 
Trims checkbox so that trim functions are ignored when the design is stitched.

To set trim functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Trim panel, select the Output Trims checkbox to include trim 
functions when outputting to the selected machine.

Adjust stitch and 
jump settings

Select to output 
trim functions

Select trim 
function format
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If you deselect the checkbox, trim functions are not removed from the design 
but simply ignored during output.

4 Specify the trim format to use:

5 Click Save then Close.

Related topics
 Machine formats

Setting color-change functions

Machines interpret Color Change functions differently – either as a Needle 
Number or Stop function. Basically, the following rules apply:
 Single-needle machines simply stop when a Color Change or Stop function is 

encountered.
 Some multi-needle machines default to the next color without stopping.
 Some multi-needle machines support direct needle addressing.

Stop functions
Stop functions allow the operator to manually change threads. They are 
generally used with machines that only have one needle. Stop functions are 
sometimes combined with Jump functions to indicate color changes.

Color-change functions
For those machines that support them, Color Change functions tell the machine 
to move to the next needle whenever a CC function is encountered. The machine 
must have the correct thread colors loaded according to the production 
worksheet.

Needle-number functions
For needle addressing machines, each color ‘slot’ on the color palette 
corresponds to a needle number. Needle Number functions are sometimes 
combined with Jump functions to indicate color changes.

Trim format Purpose

Jumps Use for machines that interpret multiple jumps as trims. Enter the 
required number of jumps.

Trim code For machines that interpret explicit trim commands.

Thread chart

Thread list

Color/needle sequence
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For needle addressing machines, you need to specify how many needles are on 
the machine. This tells the machine how often it needs to stop for the operator 
to change threads. For example, for a design with 15 colors to be stitched out 
on a machine with five needles, it must stop after every three color changes in 
order for the operator to change threads.

To set color change functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Color Change panel, select a method for interpreting color-change 
functions:

4 For needle-addressing machines, enter the number of needles on the 
machine in the No of Needles field. 

5 Optionally, select the Use Group Addressing checkbox.
Some machines can group two heads together so you can stitch a design 
using needles from both heads. For example, if a machine has two heads and 
nine needles per head, the machine moves the hoop from the first head under 
the second head, which allows you to stitch 18 colors without a manual 
change. 

Note  If this is the case, enter the combined number of needles on the 
machine in the No of Needles field.

6 Optionally, select the First CC required checkbox.
Some machines require a First CC code to initialize the machine and bring 
the head back to the first color change needle position.

7 Optionally, select the Return to Start checkbox.
This returns the needle to the start of design, preparing the machine for the 
repeat run.

8 Click Save then Close.

Related topics
 Machine formats

Method Converts color-change functions to ...

Needle no Needle Number functions

Stops Stop functions

Stop & jump Stop and Jump functions

Needle no & 
jumps

Needle Number and Jump functions

Select method to interpret 
color change functions

Select optional 
functions as required

Enter number of 
needles
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Setting borer functions

Some embroidery machines are equipped with a borer. The borer often replaces 
one of the needles. You need to specify the needle position of the borer and its 
offset value. Borers are often ‘knife’ attachments where the cutting position is 
offset ±12 mm from the main needle. Before the machine starts, the frame 
moves so that the borer is in the correct position. This extra frame movement 
compensates for the borer offset. Some machines automatically adjust for this 
offset when a Borer In function is encountered. These machines should have an 
offset value of 0. Similarly, if you are using a boring needle (instead of a knife), 
you do not need an offset value. See your machine manual for details.

To set borer functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Boring panel, enter the required borer offset.
 If your machine automatically inserts an offset when a Borer In function is 

encountered, enter an offset of 0 mm.
 If your machine requires an offset value, enter an offset of ±12.0 mm.

4 Enter the needle number to which the borer is attached.
5 Click Save then Close.

Related topics
 Machine formats

Setting end-of-design functions

Some machines require an explicit End of Design function code in order to 
recognize when the end of the design has been reached. Some machines do not 
understand the End of Design function code, requiring a Stop code instead. 
For example, Tajima machines recognize the explicit End of Design function 
code while Happy machines require a simple Stop. 

To set end-of-design functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

Enter borer offset

Enter needle number of borer

Select end-of-design 
option
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3 In the End of Design panel, select the appropriate option for your machine:

4 Click Save then Close.

Related topics
 Machine formats
 Setting start/end-of-design sequence

Advanced machine formats

The Advanced tab provides access to additional machine format options. Again, 
the available settings depend on the selected machine format. You can set the 
color change sequence, insert special codes for start or end of a design, and 
enter speed settings. There are also miscellaneous settings, including whether 
to change fabric tension during boring, and whether to rewind tape when 
stitching is complete. Use the Machine Format Settings dialog to define 
values to allow when outputting to a specific machine format.

Note  Not all values described here are available for all machine formats. Use 
these instructions to enter values that apply to your selected format. Only 
change Advanced values if you are familiar with the codes used by your 
embroidery machine. See your embroidery machine manual for more 
information. 

Setting color-change sequence

Some machines cannot interpret color-change functions unless they form part 
of a ‘color change sequence’ made up of empty stitches and empty jumps before 
and after each color change. Check your machine requirements to determine 
whether you need to enter color-change sequence values. 

In the Advanced tab, the Color Change Sequence panel reads from top to 
bottom, in the order the codes appear in the sequence. The first two fields show 
the number of empty stitches and empty jumps to insert before the color 

Option Purpose

End of design Some machines require an explicit End of Design function code – 
e.g. some Tajima machines.

Stop Some machines require a Stop code instead – e.g. Happy 
machines.

Color Change Sequence in Stitch List 
matches sequence defined in Machine 
Format Settings Advanced tab
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change. The other fields show the empty jumps and empty stitches to insert 
after the function.

Related topics
 Machine formats

Setting start/end-of-design sequence

In addition to an End of Design function, some machines require extra empty 
stitches and empty jumps in order to stitch the start and end of a design. Other 
machines require a Stop function. Depending on the machine type, you may also 
require functions to initialize the machine or trigger a frame-out after stitching.

Where available, the Set Needle Number option initializes the machine and 
brings the head back to the first color change needle position.

Where available, the Frame Out option triggers the frame to exit after stitching 
the design.

Note  Remember that these fields show the number of extra codes you want to 
insert in addition to default settings.

Related topics
 Machine formats

Setting speed options

Some machines can stitch at different speeds. Depending on your machine, you 
may then be able to select different speeds to use when you start stitching or 
for when the borer is engaged.

Enter number of Empty 
Stitches and Jumps to insert 
at end of design

Enter number of Empty 
Jumps and Stitches to insert 
at start of design

Select to initialize machine
and bring head back to first

needle position

Select to trigger frame
to exit after stitch out

Select and adjust 
speed options
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Where available, the Boring Auto Speed Changes option in the Advanced tab 
slows the machine automatically whenever the borer is engaged. From the Start 
list, select the preferred starting speed – Fast or Slow. From the Fast list, 
select the faster setting on your machine – Speed 1 or Speed 2. Check your 
machine manual for details.

Related topics
 Machine formats

Setting miscellaneous advanced options

Depending on the machine format, you may also be able to select whether to 
reduce the tension on the fabric while boring, and indicate whether to rewind the 
tape when stitching is complete.

Where available, set the following as needed:
 Tension control for boring: This option reduces the fabric tension when the 

borer is engaged.
 Stop before rewind at end: This option stops the machine at the end of the 

design and rewinds the tape. 
 Rewind with Jump at end: This option inserts a jump at the end of the 

design and rewinds the tape.

Related topics
 Machine formats

Custom machine formats

EmbroideryStudio provides standard formats for most machines. However, if 
your machine is different, you may need to customize the machine format 
settings. For example, if you have different models of the same type of 
embroidery machine, different functions may require different values.

Click to create 
custom format

Click to create 
design format
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Creating custom formats
You can create a new machine format based on a standard machine format, and 
make it available to all designs.

 In the Format Name field, enter a name for the new format – e.g. Melco-1.
 In the Comment field, enter any information that will help you identify the 

machine format – e.g. No Trim.
 Adjust Standard and Advanced machine format settings as needed. 

Creating design-specific formats
You can create a custom machine format for use with the current design. You 
cannot change the Name or Comment fields. The custom machine format is 
automatically named using the original machine format and design name – e.g. 
Melco-Design1.

Note  If necessary, you can update the standard machine format itself. However, 
you should only do this if the original values are no longer used.

Related topics
 Machine formats
 Standard machine formats
 Advanced machine formats

Enter new 
format name
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Chapter 10

EmbroideryConnect Machine Networking

A Wilcom EmbroideryConnect machine network provides for wireless design 
transfer to embroidery machines with a USB port. When activated in the 
EmbroideryStudio software, you can send machine files wirelessly via a standard 
WiFi network to a compatible WiFi USB Stick plugged into the machine. 

Most modern commercial embroidery machines like Tajima, Barudan, Happy, 
ZSK, Ricoma and SWF, can read files from a standard USB memory stick. There 
is no need for serial ports, different interface methods, or wiring for different 
machines.

Machine network configurations

The simplest type of configuration is shown below for one PC and one machine.

You can also configure multiple embroidery machines and multiple PCs on the 
same network.

Network PC

WiFi router

WiFi USB Stick

Embroidery machine with 
native USB port
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 Send designs from one PC to many different embroidery machines, via 
separate shared folders 

 Send designs from many PCs to the same embroidery machine via the shared 
folder.

What you will need
To set up an EmbroideryConnect machine network, you need to have:
 A USB-capable embroidery machine which can read designs from USB 

memory sticks:
 Preferably with the USB port built into the control panel by the 

manufacturer.
 Add-on USB converters in old machines may not be compatible.

 An EmbroideryConnect-compatible system:
 Designing, Decorating, Editing, Lettering, or Digitizing
 EmbroideryConnect element enabled in at least one ES e4 system
 A Wilcom-supplied WiFi USB Stick – one per embroidery machine requiring 

connection.
 A compatible WiFi router
 Windows shared folders accessible from the WiFi network and by 

EmbroideryStudio users
 Windows Administrator privileges. Access must be configured by a user who 

has full administrator privileges and is part of a Windows ‘Workgroup’ or 
‘Domain’ network.

WiFi router compatibility requirements
Note the following WiFi router requirements to be compatible with the 
WiFi USB Stick.
 The WiFi router must use one of the standard security protocols: 
 WEP, WPA/WPA2 Personal, or WPA-Enterprise. 
 Caution: Security type of ’None’ or ’unsecured’ is not supported at 

present. i.e. one that does not require a WiFi password. 
 The WiFi router needs to support WLAN Protocol is 802.11 G compatible, in 

the 2.4 Ghz band. 
 Caution: The WiFi USB Stick will not connect to a WiFi router using the 5 

Ghz band. 
 If unsure, consult the documentation provided with your router. 

 You must know the WiFi network name (SSID) and WiFi router password 
(key).
 Caution: We recommend using a SSID (network name) that contains only 

alphanumeric characters – letters and numbers.
 Make sure WiFi coverage is sufficient to serve the entire production area.

How does an EmbroideryConnect machine network work?

The WiFi USB Stick is configured to access a specific shared folder on a Windows 
network accessible via a WiFi router. The WiFi USB Stick automatically 
downloads a copy of all design files placed in the shared folder. Using the 
machine control panel, the operator can then read the designs from the local 
memory of the WiFi USB Stick.
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Overview of how to configure and work with an EmbroideryConnect 
machine network

You configure the system as follows:
 Set up a shared folder on the Windows network computer for each 

WiFi USB Stick, 
 Note the network location Windows creates – it includes the computer 

name and folder name
 Note that an additional sub-folder is required for Barudan machines. 

See Create your shared Windows folders for details.
 Configure each WiFi USB Stick on your PC
 Use the Connection Manager Setup command.
 Configure it to connect to your WiFi router.
 Configure it to connect to the specific shared folder for each embroidery 

machine.
 Configure the desired embroidery settings such as machine file format and 

options.
 Label the WiFi USB Stick with the name of the Machine Connection you 

setup
 Plug the WiFi USB Stick into the embroidery machine USB port
 Leave the stick always plugged into the machine - no need to plug/unplug 

it.
 WiFi USB Stick automatically monitors and mirrors the contents of its 

shared folder.
 Designs written to the shared folder by ES are automatically copied to 

the WiFi USB Stick
 Designs deleted from the shared folder are automatically deleted from 

the WiFi USB Stick.
 Send designs to the desired machine using Connection Manager. 
 ES converts from EMB to the selected machine file format, and writes it 

into the shared folder.
 WiFi USB Stick automatically detects this and copies the machine file into 

its local memory
 Operator selects which design to read into the embroidery machine
 The machine operator instructs the machine to read designs from 

WiFi USB Stick
 The machine then shows a list of designs in the WiFi USB Stick local 

memory.
 Operator chooses which designs to stitch
 Embroidery machine reads it into machine memory so it is available to 

stitch.
 You must remove designs from the shared folder, to remove designs 

from the WiFi USB Stick
 When a production job is complete
 Remove the design from the shared folder using either Design Library 

or Windows Explorer.
 By using Design Library, the Job Status can be used to indicate which 

designs can be removed
 Do this regularly - e.g. daily
 To make design download times quick (especially when the machine is 

first powered on) 
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 Avoid exceeding the WiFi USB Stick memory capacity. See section 
below about memory capacity and download times.

Extra notes about WiFi USB sticks

Note: The WiFi USB Stick memory is temporary. The memory contents are 
only maintained while it is powered on.
 The WiFi USB Stick is intended for production use, not general storage.
 If you unplug the stick from the machine, its memory is cleared. No files are 

saved.
 This keeps your production files SECURE. No one can copy a design from the 

WiFi USB Stick.
 The WiFi USB Stick will automatically download a fresh copy of designs 

from the shared network folder each time it powers on again and re-connects 
with the WiFi router.

Note: The WiFi USB Stick memory size can be configured for compatibility with 
different machines.
 Each WiFi USB Stick can hold a maximum of 16MB of memory. (15.5 MB 

available)
 You can configure it for less memory (if needed) for compatibility with older 

machines
 E.g. 16, 8, 4, 2, or 1.44 MB (floppy disk size)
Note: The WiFi USB Stick is physically larger than a normal USB memory stick. 
 You need about 30 x 15 mm (1¼ x 0.6 inch) around the USB port
 If it is too big, simply use a male-to-female USB extension cable.

WiFi USB Stick capacities and download times

The capacities and download times shown below are approximate based on 
typical logo type designs in the order of 10,000 stitches.
The WiFi USB Stick memory capacity in Megabytes (Mb) is configurable. For 
example:
 16 Mb stick memory holds about
 3 to 5 million stitches, depending on the machine format. 
 350 to 500 designs of 10,000 stitches

 4 Mb stick memory holds about
 800 thousand to 1 million stitches depending on the machine format
 80 to 100 designs of 10,000 stitches

The approximate time for a WiFi USB Stick to download designs from a shared 
folder is the combination of:
 10 seconds to initially connect to the network
 1 minute per megabyte of data
 a few seconds per design

The data size of designs depends on the machine file format being used:

Other machine file formats are similar to these numbers. 

Type Format Stitches per Mb Designs per Mb Download time

Barudan .U03 format stitch data 330,000 stitches 33 designs 1 minute per Mb

Tajima .TBF stitch data + 3 files 230,000 stitches 23 designs 1 minute per Mb



EmbroideryStudio e4 User Manual 191

Configuring an EmbroideryConnect machine network

Follow the below instructions to correctly configure an EmbroideryConnect 
machine network.

Create your shared Windows folders

Select the PC that will act as the network file server, one that will always be on 
during your production hours, and is accessible via the WiFi network.
 Requires a user login with Windows administrator privileges and
 Access to the Windows Workgroup or network domain

Create shared folders using Windows Explorer
1 Create a dedicated root folder on the hard drive to hold the shared folders for 

all your machines. E.g. C:\WiFiUSB
Then create a separate folder under this for each WiFi machine. For example:
C:\WiFiUSB\Machine1, 
C:\WiFiUSB\Machine2, …
Note: If using Barudan machines, a special sub-folder is required, this can 
be created later when you configure the WiFi USB Stick in Connection 
Manager.

2 Make each of the machine folders a separate shared folder.
 Right-click the folder and select Share with > Specific people. By 

default the current user will be the owner. Share with Everyone.
 Set Permission Level to Read/Write

3 Once done, click Share.
4 Note down the network folder location as you will need this later when setting 

up other EmbroideryStudio systems that will be sending designs to this 
machine. It is made up of \\YourComputerName\YourFolderName

5 You should also label the WiFi USB Stick to identify the specific machine to 
which it will be connected. Write the machine name or number on the 
WiFi USB Stick.

Provide users with 
full read/write access
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Tip  If you are setting up multiple folders for multiple devices, maintain a 
table of device names and corresponding folder names. 

Configuring the WiFi USB Stick connection

The initial setup must be done with the WiFi USB Stick plugged into PC and 
configured using the Connection Manager Setup. Before starting to configure 
the device, make sure of the correct password for the WiFi router as it will be 
needed during the setup process. Also check that the WiFi router satisfies the 
router requirements.

To configure WiFi USB Stick connection
1 Attach the WiFi USB Stick to the PC which has the EmbroideryConnect 

element enabled in the EmbroideryStudio software.

2 Run EmbroideryStudio and right click the Connection Manager command 
on the Standard toolbar. Click Create. The Connection Settings dialog 
opens.

3 Select WiFi USB Stick from the connection type droplist. If this is not visible, 
check that you have ES version e4.1G or later, and have the 
EmbroideryConnect element enabled.

Use Standard > Send to Connection Manager to connect to supported machines 
via proprietary machine software.

Select
WiFi USB Stick
connection type

Enter name and select 
icon to identify the 
connection
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4 Enter a name for the connection – e.g. ‘WiFi USB Stick #1’ or ’Machine 1’ to 
match your shared folder name and select an icon. This icon will appear on 
the Standard toolbar.

5 Click the Setup button. The WiFi USB Setup dialog opens.

6 Click the Scan button to scan for local WiFi networks. Wait a minute or so 
until the droplist prompt message clears, then open the Router droplist to 
see the detected WiFi routers.

Tip  If you already know the WiFi network, you can specify it manually by 
selecting ‘Other’ without first having to click the Scan button. Note that the 
SSID or WiFi name is case sensitive.

7 Select your WiFi router from the list, and enter the WiFi security protocol and 
password. 

Note  Unsecured WiFi routers with no password are not compatible with the 
WiFi USB Stick.

Connect to
selected router

Click to search for 
local WiFi routers

Select the
desired router

Select ‘Other’ if 
router not showing

Enter password for
selected router

Check security 
protocol
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8 Click Connect. This may take a little while. Once complete, a confirmation 
message will appear. Your WiFi USB Stick is now connected to the wireless 
network.

Caution  During setup, Windows Explorer may produce some warning 
messages. Ignore these as the device will disconnect and reconnect several 
times during the procedure. If asked to scan, click No.

To configure the WiFi USB Stick shared folder
1 In the USB WiFi shared folder panel, enter the login details of the user with 

full read/write access to the folder. This is usually the username and password 
used to log onto the PC. If the PC uses a Microsoft account, the account email 
address will need to be used.

2 Enter the workgroup name if different to the default. The Windows default 
is ’WORKGROUP’ and is probably correct for you if you use Windows Home 
Edition. 
If using Windows Professional or Enterprise with a specific ‘Domain’ network, 
enter the domain name instead of the workgroup name.

3 Click Scan to obtain a list of shared folders. After a minute or so, click to 
open the Folder Name droplist to see the detected shared folders – using 
their ‘Network Path’. Recall that the network path is in the form of 
\\ComputerName\FolderName.

4 From the droplist, select the shared folder network path that you created 
earlier which is to be used by the attached WiFi USB Stick.

Enter shared folder
user credentials

Select WiFi USB
Stick shared folder

Select the
folder
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5 Click Connect to apply the settings. Once complete, you will receive a 
confirmation message will appear that the device has successfully logged in 
to the Windows network and connected to the shared folder.

6 Click Close to close the dialog. The shared folder is automatically entered in 
the Folder location field of the Connection Settings dialog.

7 In the File type field, select the file type to be sent to the machine.
8 Click the Options button to check settings for the selected file type. For 

example, with DST file type, choose whether to include TBF/DST file icons in 
the output.

9 If the machine being used is NOT a Barudan machine, click OK now to 
complete the setup. The WiFi USB Stick can now be disconnected from the PC 
and connect it to the machine.
If the machine used IS a Barudan machine, do not click OK and configure a 
sub-folder first.

Important: Configure a sub-folder for Barudan machines

If the WiFi USB Stick will be used with a Barudan machine, a special sub-folder 
must be configured. Barudan machines will not read designs from the root folder 
of any USB stick. First, set up a shared folder in the normal way, one for each 
WiFi USB Stick being used. Then, set up a sub-folder to the machine’s shared 
folder to match the type of stitch files being sent.

Choose machine
file type

Folder location 
automatically 
entered

\\D7R21TF2\Machine1

File type Folder

U01, U03, etc <Subfolder_Name>.fdr
DST, DSB, etc <Subfolder_Name>.tfd
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For example, normally using Barudan FDR U01, U03 files:

Or, if using Tajima format DST or DSB format files:

The sub-folder is added to the folder location in the Connection Setting 
dialog so that designs are placed in the special sub-folder of the WiFi USB Stick.

 If already created select the sub-folder:
 Click Browse…
 Select the sub-folder and click OK.

 If not created in an earlier step, create a new sub-folder now under the 
shared folder for this machine:
 Click Browse…
 Select the machine folder.
 Click Make New Folder.
 Enter the folder name.
 Click OK.

Optionally configure the WiFi USB Stick memory size

The default capacity of the WiFi USB Stick is 16MB and most machines accept 
this size of USB memory stick. Some older machines require smaller sizes such 
as 4MB or Floppy disk size (1.44 Mb).

Add the sub-folder to 
the shared folder

\\D7R21TF2\Machine1\Designs.tfd
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To configure the WiFi USB Stick memory size
1 If the memory size of the WiFi USB Stick must be reconfigured to be 

compatible with specific embroidery machines, now is the time to do it. Click 
the Memory Size button to access settings.

2 Select the memory size required for the machine.
3 Click OK to close and save the setup. It can take up to 30 seconds for changes 

to be made.
4 Confirm the change to the WiFi USB Stick Memory size while the device is still 

connected to the PC.

Tip  Label your WiFi USB Stick with the connection name you used Step 4 
above – e.g. ‘WiFi USB Stick #1’.

Related topics
 Sending designs to Connection Manager
 Sending a design to WiFi USB Stick

Connecting to WiFi USB Stick from another ES computer

Once the WiFi USB Stick and shared folder are properly configured, connection 
can be made from any PC running EmbroideryStudio. Additional systems only 
need the folder location and shared folder permissions. There is no need to 

Click button to
adjust memory size

Select option 
corresponding to machine 
capacity

Default RAM disk 
size
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reconfigure the setup unless something has changed with the WiFi router or 
shared folder.

To connect to WiFi USB Stick from another ES computer
1 Click (or right-click, if a machine setup already exists) the Connection 

Manager icon on the Standard toolbar. The Connection Settings dialog is 
displayed.

2 Select ‘Machine Folder’ from the droplist.
3 Enter the name used to identify the connection when the WiFi USB Stick was 

initially configured.
4 Select an icon for the connection.
5 Select the file type you want to send to machine. This must be the same as 

the file type selected during the initial setup.
6 Click Options to check settings for the selected file type.
7 Key in the folder location if you know it. Or click Browse to search the 

network location of the shared folder that was configured for this 
WiFi USB Stick. This was noted down during the initial setup.

Related topics
 Sending designs to Connection Manager
 Sending a design to WiFi USB Stick

Managing designs for production

Each WiFi USB Stick in the EmbroideryConnect machine network, is only 
intended for production, not general storage. Once the EmbroideryConnect 
machine network is set up, the production process must be managed. For 
instance:
 Prior to each shift, add the production files to each of the shared machine 

folders.
 Optionally set the job status for each of the EMB files to be produced in that 

shift to ‘8 - In Production’.
 At the end of each shift, reconcile the jobs completed and delete those files 

from the shared machine folder.
 Optionally find the original EMB file and set the job status to ‘9 - Job Done’.

Select WiFi USB
Stick connection

type

\\D7R21TF2\Machine1
Key in folder

location
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Sending designs to machine

In order to send designs to machines and manage the files on the WiFi USB 
Stick, it is recommended to use Design Library. Once configured, use the 
Send to Connection Manager command to send individual designs to shared 
folders.

Sending multiple designs

In order to send multiple designs to enable a full day’s production on a specific 
machine, use the Convert Selected Designs command to send selected 

Use Manage Designs > Send to Connection Manager to stitch out the design 
selected in Embroidery Library.

Use Manage Designs > Convert Selected Designs to convert the design selected 
in the embroidery library into different machine file types.
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designs to the shared folder as shown. Use the Browse function to locate the 
shared folder on the network.

Manage designs in shared folders

The best way to manage the contents of shared folders and, by extension, the 
designs that can be seen on each machine, is to add them to Design Library. 
Filtering by machine file, everything currently residing on any given machine’s 

Use Manage Designs > Manage Embroidery Library Locations to add or remove 
existing folders from the Embroidery Library, enabling fast searching and filtering.
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WiFi USB Stick can be seen in a single Design Library view. Remove unwanted 
files and they will in turn be removed from the WiFi USB Stick on the machine.

Related topics
 Outputting selected designs
 Converting designs
 Adding folders to the library

Troubleshooting the WiFi USB Stick

If experiencing problems using the WiFi USB Stick, double check that it connects 
to the WiFi and the shared folder correctly.
 The two LED lights on the stick will be both ON and SOLID if connected.
 If the two lights flash on briefly and then slowly fade out, it is NOT connected. 
If a mistake was made in the configuration settings, simply start again and 
re-configure it, double-checking the settings.
A radical step would be to try resetting it by inserting a hairpin into the ‘Reset’ 
aperture on the side of the device. The device must be connected to the PC 
during this operation. This restores the device to its original factory settings. The 
WiFi USB Stick must then be reconfigured using Connection Manager.

If this doesn’t solve the problem, go to Wilcom Support site and check for 
updates. If available, download the latest WiFi USB Stick ‘patch’. To patch the 
device follow these simple steps:

Use ‘Reset’ to return 
the device to factory 
settings
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 Connect the WiFi USB Stick to the PC.
 Copy the patch file into the USBWIFI folder on the actual device.
After a few seconds the device will disappear from the PC and then return. It is 
now patched.

Caution  If the WiFi USB Stick is subsequently reset, any modifications to 
settings are lost and any patches will need to be reapplied.
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PART III

EMBROIDERY DIGITIZING

In EmbroideryStudio, you build designs from basic shapes or ‘embroidery 
objects’. These are like ordinary vector objects in that they have certain defining 
characteristics or ‘properties’ such as color, size, position, and so on. They also 
have properties unique to embroidery such as stitch type and density.

Stitch types
This section explains how to select stitch types for your various fills, including 
how to create Satin fills, Tatami, Motif, and Contour fills, and how to adjust stitch 
settings for best results. It also describes how to create Zigzag and E Stitch fills 
and borders. See Stitch Types for details.

Digitizing shapes
This section discusses the automatic conversion of vector to embroidery objects. 
It also deals with manual digitizing methods, including digitizing free shapes, 
simple borders, and complex column shapes. See Digitizing Shapes for details.

Object properties
This section explains how to change property settings in a design, as well as how 
to apply and adjust fabric settings. It also explains how to create and maintain 
styles and templates in EmbroideryStudio. See Object Properties for details.

Productivity tools
This section describes how to digitize circles, stars and rings as well as how to 
reinforce outlines. It also describes removing underlying stitching from 
overlapping objects. Creating outlines and filling holes is covered as well as 
adding decorative borders to whole designs. See Productivity Tools for details.
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Chapter 11

Stitch Types

All embroidery objects in EmbroideryStudio contain defining settings or 
properties. Some, such as size and position, are common to all objects, while 
others are specific to object type. The most important property of all is stitch 
type. The software uses object outlines and the associated stitch type to 
generate stitches. Whenever you reshape, transform or scale an object, stitches 
are regenerated according to current settings.

Stitch types divide broadly into two categories – outlines and fills. Different 
stitch types suit different shapes. Some stitch types are suitable for both 
outlines or fills. Others are dedicated to one or other purpose. A stitch type can 
be selected together with a digitizing method or applied afterwards. Whenever 
you create an object from scratch, it takes the currently selected stitch type.

Simple outline stitching

EmbroideryStudio provides tools for creating outline stitching of varying 
thicknesses and styles. They are typically used to add borders and pickout runs. 
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There are tools for creating simple run stitching as well as a wide variety of 
decorative outlines. Outline stitch types can be interchanged. 

Simple run stitching

Use Run to digitize lines of simple run stitching. Use Triple Run for emphasis. 
This stitch type is typically used for thicker borders and outlines. Sculpture Run 
creates thick-thin alternating single and triple stitching for a hand-stitched look. 
Adjust stitch length, chord gap, stitch repetitions, and other settings via the 
Object Properties docker.

Notes:
 Both Traditional Digitizing and Graphics Digitizing toolbars contain tools 

for digitizing outlines. These tools place a row of stitching along a digitized 
line.

 EmbroideryStudio provides tools for automatically generating outlines. 
 Use Backtrack and Repeat to reinforce outlines while specifying the 

direction of the stitching. 

Use Outline Stitch Types > Run to place a row of single run stitches along a 
digitized line. Right-click for settings.

Use Outline Stitch Types > Triple Run to place a triple row of run stitches along a 
digitized line. Right-click for settings.

Use Outline Stitch Types > Sculpture Run to create a thick-thin outline alternating 
single and triple stitches for a hand-stitched look.
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 Swap outline types at any time, including vector outlines. Vector objects of 
course have no stitch properties. Satin outline width can be controlled via 
object properties or using the Reshape tool. 

Related topics
 Digitizing outlines & details
 Creating vector shapes in EmbroideryStudio
 Generating outlines & offsets
 Reinforcing outlines
 Reshaping Column C objects

Stitch length

For run stitch and other outline stitches, stitch length can be adjusted to suit the 
shape.

To adjust stitch length
 Right-click the icon to access object properties.

 To set a fixed stitch length, adjust the Length field. For sharp curves, reduce 
length – e.g. 1.8 mm – so that the stitches follow the line more closely. Mimic 
hand-made embroidery by increasing length to, say, 4.0 mm.

 Alternatively, automatically shorten stitches to follow tight curves with the 
Variable Run Length option.

Use Outline Stitch Types > Run to place a row of single run stitches along a 
digitized line. Right-click for settings.

Adjust nominal 
stitch length

Adjust variable run 
length values

Change stitch type

Turn on/off variable
run length

Too few stitches to follow 
tight curve

Stitches follow the curve 
more closely

Run length Run length
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 In the Chord Gap field, enter the maximum distance to allow between the 
digitized outline and the stitches.

 In the Min Len field, enter the minimum stitch length to allow. Stitch length 
will not reduce to less than this value, even if the chord gap is exceeded.

Run count

By default, Triple Run repeats each stitch three times. You can change the 
number of repetitions by adjusting the Run Count value.

Tip  Use Backtrack and Repeat to reinforce outlines while specifying the 
direction of the stitching. See Reinforcing outlines for details.

Sculpture run settings

Sculpture Run provides independent stitch length parameters for alternating 
stitches. This is handy for creating a hand-stitched look. Apply to open or closed 
shapes. Default alternating values are equal but can be independently set – e.g. 

Run
length

Chord 
gap

Fixed Run Length Variable Run Length:
0.07 mm (default)

Variable Run Length:
2 mm

Use Outline Stitch Types > Triple Run to place a triple row of run stitches along a 
digitized line. Right-click for settings.

Single Run

Stitch length

Triple Run

1 2 3 4 5 6

1

2

3

5

6

4

Select run count

Use Outline Stitch Types > Sculpture Run to create a thick-thin outline alternating 
single and triple stitches for a hand-stitched look.
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A=2.5 mm and B=1.5 mm. Also, the number of A/B repeats can be 
independently set. The default setting is #A=3, #B=1.

Decorative outlines

While simple run stitching is typically used to add borders and pickout runs, 
there are stitch types for creating decorative outlines. Backstitch is an 
older-style, adaptable stitch which can be used for delicate outlines. Stemstitch 
is thicker and can be used to mimic hand-sewn embroidery. Digitize decorative 
outlines as you would a Run stitch outline. 

To create decorative runs
 For more delicate outlines, use Backstitch. Backstitch is an older-style, 

adaptable stitch which follows intricate curves well.

B B

AA

Length A can be 
different to B

Run count A can 
be different to B

Use Outline Stitch Types > Backstitch to place a row of backstitches along a 
digitized line. Right-click for settings.

Use Outline Stitch Types > Stemstitch to place a row of stemstitches along a 
digitized line. Right-click for settings.
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 Backstitch settings allow you to specify exact stitch length, chord gap, 
thickness and overlap values as well as number of strokes. Length, Min 
Length, and Chord Gap values work like the Variable Run Length option.

 For thicker, decorative lines, use Stemstitch. Stemstitch can be used to 
mimic hand-sewn embroidery. It is used for stems and vines with other 
decorative stitches, or as an outline for satin or motif fills.

Run length: 1.5 mm

Stitch thickness: 
0.25 mm

Strokes: 5
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 Stemstitch settings allow you to specify exact stitch and line thickness, 
spacing and overlap values as well as thickness (number of strokes).

Note  For Triple stitching, you can also adjust Stitch Thickness.

Related topics
 Embroidery digitizing
 Digitizing outlines & details
 Converting objects

Satin stitching

Satin is one of those stitch types which can be used for thicker borders or for 
fills. It is well-suited to narrow shapes where each stitch spans the width of the 
column. Because there are generally no needle penetrations breaking up the fill, 
satin stitch gives a glossy, high-quality appearance.

Tip  The Auto Split and Auto Jump features help you to control long satin 
stitches. See Optimizing long satin stitches for details.

Line thickness: 1.5 mm

Spacing: 1.2 mm

Angle: 90°
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Applying satin stitch

In EmbroideryStudio, the Auto Spacing option is turned on by default. For most 
purposes, this option avoids thread breaks and creates visually appealing 
columns of satin stitches.

If a column is too wide, stitches may be loose and not cover the fabric properly. 
Conversely, in very narrow columns, stitch density may be too high and needle 
penetrations damage the fabric. Adjust stitch density by setting a fixed spacing, 
or let Auto Spacing calculate spacings wherever column width changes.

To apply satin stitch with auto-spacing
1 Select the digitizing method you want to use – e.g. Column C. 
2 Select Satin and create an embroidery object. Alternatively, select an 

existing embroidery object and click Satin.

3 Right-click the Satin icon to access object properties.

4 Tick Auto Spacing if not already checked.

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow columns 
and shapes. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of even 
thickness. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be applied to 
lettering or used with trapunto for quilting effects. Right-click for settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – can be 
used with outlines for quilting effects. Right-click for settings.

Adjust density
percentage

Select Auto Spacing
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5 Adjust Stitch Density for more or less open fills.

Density is given as a percentage of preset values:
 To decrease, increase the percentage – e.g. to 110-115%.
 To increase, decrease the percentage – e.g. to 90-85%.
75% generally produces high quality embroidery. An increased stitch count 
means the design will take longer and be more expensive to stitch.

6 Press Enter or click Apply. 

Note  For even more precise results, you can adjust Auto Spacing settings. 

Related topics
 Embroidery digitizing
 Satin auto-spacing

Satin auto-spacing

Adjust Auto Spacing to specify how rapidly spacing changes and by how much. 
You can also specify spacing offsets to adjust for different thread types. These 
settings are intended for digitizing experts. You will usually want to save 
modified settings to a template. 

100% – no adjustment <100% – more stitches>100% – fewer stitches

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow columns 
and shapes. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of even 
thickness. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be applied to 
lettering or used with trapunto for quilting effects. Right-click for settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – can be 
used with outlines for quilting effects. Right-click for settings.

Length 1

Spacing 1

Spacing 2

Length 2

Auto spacingFixed spacing
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To adjust auto-spacing settings
1 Right-click the Satin icon to access object properties.

2 Click Settings. The Auto Spacing Settings dialog opens. 

3 Adjust stitch settings in the Stitch panel:

4 Adjust spacing offsets for different thread types.

Setting Purpose

Length These values define the increments by which spacing is adjusted. The 
smaller the distance between each length, the more rapidly stitching 
changes from open to dense. Each length must be greater than the 
preceding.

Spacing These values define the spacing corresponding to each stitch length. See 
below.

Click to adjust Auto
Spacing values

Select Auto Spacing

Adjust stitch
length values

Adjust spacing
values

Enter spacing 
offsets for each 
thread type

Default spacing values Custom spacing values
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The offset determines the amount by which stitch settings will be adjusted for 
different thread thicknesses.

Note  You assign the thread type in the Add Thread dialog. Stitch spacing 
of the assigned thread type is automatically adjusted according to the values 
set there. 

5 Click OK.

Related topics
 Working with templates
 Modifying thread details

Satin fixed spacing

In EmbroideryStudio, the Auto Spacing option is turned on by default. 
Sometimes, however, you may want to control the exact spacing of satin 
columns. Fixed spacing is sometimes used, for example, for decorative effects – 
e.g. very open spacing over, say, a tatami background. These effects cannot be 
achieved with Auto Spacing.

Tip  If you are using a digitizing tablet, you can quickly switch between preset 
styles with different spacing settings. Each button on the puck accesses the next 
preset style. For example, clicking button 1 accesses <PRESET_SATIN_1>.

To apply satin stitch with fixed spacing
1 Select the digitizing method you want to use – e.g. Column C. 

Thickness Description Default

A Normal embroidery thread (approx. denier 40) 0.01

B Thicker than normal (approx. denier 30) 0.03

C Finer than normal (approx. denier 80) -0.03

D Very fine (approx. denier 100) -0.06

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow columns 
and shapes. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of even 
thickness. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be applied to 
lettering or used with trapunto for quilting effects. Right-click for settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – can be 
used with outlines for quilting effects. Right-click for settings.
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2 Select Satin and create an embroidery object. Alternatively, select an 
existing embroidery object and click Satin.

3 Right-click the Satin icon to access object properties.

4 Untick Auto Spacing.
5 In the Spacing field, enter a fixed spacing:
 To increase density, enter a smaller value.
 To reduce density, enter a larger value.

6 Press Enter or click Apply. 

Related topics
 Embroidery digitizing

Satin stitch count

Triple Satin is often used for folk designs to mimic handmade embroidery that 
uses thicker thread. If you require thicker stitches, set the satin stitch to repeat 
itself multiple times. Use Satin Raised to create raised surfaces consisting of 

Adjust stitch 
spacing

Deselect Auto
Spacing

Stitch Spacing 0.5 mm Stitch Spacing 0.7 mm Stitch Spacing 0.9 mm

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow columns 
and shapes. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be applied to 
lettering or used with trapunto for quilting effects. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of even 
thickness. Right-click for settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – can be 
used with outlines for quilting effects. Right-click for settings.
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multiple layers of satin stitching. This can also be applied successfully to some 
styles of font for a raised embroidery surface.

To adjust satin stitch count
 Right-click the Satin icon to access object properties.

 Enter the number of repetitions in the Satin Count field.

Caution  Using a value higher than 10 may cause thread breaks, depending 
on the design, fabric, or thread tension.

Adjust satin
count

Adjust satin
layers
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 With Satin Raised you can also adjust the number of layers of stitching.

 Press Enter or click Apply.

Tip  When you increase satin stitch count, you should also increase the 
spacing to avoid bunching and thread breaks. 

Related topics
 Satin fixed spacing
 Optimizing long satin stitches
 Applying stitch types & effects to lettering

Tatami stitching

Tatami stitch consists of rows of run stitches and is suitable for filling large 
shapes. Stitch offsets in each row are used to eliminate horizontal split lines.

Tatami density

Increase satin 
count for more 
layers

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. Right-click 
for settings.

Use Outline Stitch Types > Tatami to create borders or columns of even width for 
different needle penetration patterns.
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Tatami stitch density is determined by the distance between each row of 
stitches. Sometimes row spacing is increased to create more open stitching for 
backgrounds and special effects.

Tip  When you increase stitch spacing, Auto Underlay should be turned off. If 
too open, you may also find that travel runs and overlapping segments spoil the 
effect. The Trapunto effect automatically moves underlying travel runs to the 
edges of an object so that they can’t be seen. 

To set tatami density
1 Select the digitizing method you want to use – e.g. Complex Turning. 
2 Select Tatami and create an embroidery object. Alternatively, select an 

existing embroidery object and click Tatami.

3 Right-click the Tatami icon to access object properties.

4 Adjust Spacing as required. For increased density, enter a smaller value. For 
more open stitching, enter a larger value.

Row spacing

Row direction

Stitch length

Offset fraction

Adjust stitch spacing

Adjust stitch length

Spacing: 0.4 mm Spacing: 0.6 mm Spacing: 0.8 mm
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5 Adjust Length as required.

6 In the Min Stitch Length field, enter the length of the shortest stitch to be 
generated.

7 Adjust other settings as desired. 
8 Press Enter or click Apply.

Related topics
 Creating open stitching with trapunto
 Embroidery digitizing
 Setting Object Property apply options

Other tatami settings

Tatami settings also allow you to control needle offsets for more even 
distribution of needle points or for patterned effects. Choose a different 
backstitch type to control edge stitching.

Length: 4.5 mm Length: 2 mm Length: 1 mm

Length: 4 mm
Minimum Stitch: 0.4 mm

Length: 4 mm
Minimum Stitch: 0.8 mm

Length: 4 mm
Minimum Stitch: 1.2 mm
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Offsets
With tatami fills you can specify how each row is offset in order to create 
patterns formed by needle penetrations. You do this by adjusting either offset 
fractions or partition lines. 

Tip  Using a Random factor you can eliminate the split line patterns formed by 
regular needle penetrations and distribute stitches randomly inside a shape. 

Backstitch
Tatami backstitch is the term used for every second row of stitches in a tatami 
fill. There are three types available – Standard, Borderline, and Diagonal.

The table below describes the differences:

Type Notes

Standard 
backstitch

Because the rows are different lengths, there are fewer small stitches at 
the edge of the shape, reducing possible damage to the fabric. Standard 
backstitch is suitable for high density fills.

Borderline 
backstitch

With lower density fills, borderline backstitch creates a smooth, 
well-defined edge. Borderline backstitch is also called Trapunto style. 

Diagonal 
backstitch

The backward rows are diagonal, directly connecting the forward rows. 
Diagonal backstitch is suitable for turning shapes, and gives good results 
with Jagged Edge. 

Adjust offsets to 
create patterned 
effects

Adjust backstitch to 
control appearance 
of borders

Standard backstitch Borderline backstitch Diagonal backstitch
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Related topics
 Creating textures with tatami offsets
 Creating random patterns
 Creating open stitching with trapunto

 Creating furry or fluffy edges

Open fills & borders

The Stitch Types toolbars include Zigzag and E Stitch. Both can be used to 
create borders around appliqués and other embroidery objects. They can also 
be used for decorative effects or open fills where fewer stitches are required. 
Zigzag and double zigzag stitches are also frequently used as underlays.

To create open fills or borders
 Select the digitizing method you want to use – open or closed. 

Click Outline Stitch Types > Zigzag to create open borders or columns of even width 
for an open ‘sawtooth’ effect. Right-click for settings.

Use Fill Stitch Types > Zigzag to create fills with an open ‘sawtooth’ effect. 
Right-click for settings.

Use Outline Stitch Types > E Stitch to create open borders or columns of even width 
for an open ‘comb’ effect. Right-click for settings.

Use Fill Stitch Types > E Stitch to create fills with an open ‘comb’ effect. Right-click 
for settings.
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 Select an outline or fill stitch type and create the embroidery object. 
Alternatively, select an existing object and apply a stitch type.

 Double-click the object or right-click the icon to access object properties. 
These give you control over stitch spacing, length, and run count values.

 Adjust Spacing for more or less dense outlines.

 Create parallel stitching and control the angle relative to the horizontal. Use 
it to create calligraphy-like stitching.

Adjust stitch 
spacing
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 E Stitch also lets you set the Number of Runs:

Related topics
 Zigzag underlay settings
 Creating open stitching with trapunto
 Appliqué Digitizing
 Embroidery digitizing
 Digitizing regular columns

Motif fills & borders

Motifs are predefined design elements, such as hearts, leaves or border 
patterns. They generally consist of one or more simple objects, and are stored 
in a special motif set. Motifs can be used for ornamental outlines and patterned 
fills. Use the ones provided with the software or create your own. Motifs can be 
scaled, rotated and mirrored in the same way as other objects. You can even use 
them to create interesting three dimensional effects.

Note  Auto Underlay is deactivated with this feature and stitch angle has no 
effect.

Related topics
 Selecting & placing motifs
 Creating motif runs
 Creating motif fills

E Stitch spacing1 run E Stitch spacing

3 runs

Use Outline Stitch Types > Motif Run to create a string of motifs along a digitized 
line.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery motifs to 
form repeating patterns. Right-click for settings.
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Patterned fills & borders

Program Split is a decorative fill stitch where needle penetrations form a tiled 
pattern. Select a pre-defined pattern or create your own. You can apply 
Program Split to a wide variety of objects. You can adjust these either before 
or after applying the effect. Choose from a library of split patterns.

Related topics
 Creating textures with program splits
 Making custom splits

Use Fill Stitch Types > Program Split to create decorative fill stitches where needle 
penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of even 
width for decorative needle penetration patterns. Right-click for settings. 

Choose from the 
pattern library
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Curved fills

EmbroideryStudio provides a variety of stitch types and techniques fore creating 
curved stitching. 

Contoured fills & borders

Contour is a curved fill stitch type which can be applied to Column A/B or 
Circle/Ring objects. It can also be used for outline stitching. Stitches follow the 
contours of a shape, creating a contoured, light and shade effect. Use it to create 
a sense of movement in contrast to flatter fills created by tatami stitching.

Use Outline Stitch Types > Contour to create outlines which follow object contours, 
creating a curved, light-and-shade effect. Right-click for settings.

Use Fill Stitch Types > Contour to create fills which follow object contours, creating 
a curved, light-and-shade effect. Right-click for settings.
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Related topics
 Digitizing methods
 Specialty Stitching
 Creating contoured fills

Offset fills

Offset Fill is similar to Contour in that it produces a curved fill stitch type which 
follows the contours of the shape. However, it can be applied to complex fill 
objects as well as turning stitch objects. Stitch angles, however, have no effect 
on the fill pattern. Like Contour, it is best used for open fills with low stitch 
counts.

Related topics
 Creating offset fills

Spiral fills

Use Spiral Fill to create open stitching that follows the contours of a shape. It 
works best with simple shapes that can be stitched in a single segment without 
holes or islands. Use it with either fixed or variable length run stitching. With 

Use Fill Stitch Types > Offset Fill to create offset fill stitching in any closed shape.

Use Fills Stitch Types > Spiral Fill to create spiral stitching from the center of any filled object.
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longer shapes, it may generate stitches that go outside the perimeter of the 
object, but this can provide for some interesting visual effects.

Related topics
 Creating spiral fills

Specialty stitching

EmbroideryStudio provides many artistic effects and stitch types to create 
special fills.

Stippled fills

Stippling is a method for creating textured fills of run stitching which meanders 
more or less randomly within a border. It can be applied to any closed objects. 
Stitch angle has no effect.

Related topics
 Creating stippling effects

Use Fill Stitch Types > Stipple Fill to create stippled fills of run stitching which 
meanders more or less randomly within a border. Right-click for settings.

Use Fill Stitch Types > Stipple Backstitch to create a backstitch fill which meanders 
randomly within a border. Right-click for settings.

Use Fill Stitch Types > Stipple Stemstitch to create a stemstitch fill which meanders 
randomly within a border. Right-click for settings.



Chapter 11   St itch Types 228

String fills & borders

String stitch type is ideally suited creating craftstitch fills as well as delicate 
borders. It can, for instance, be used as a border for fixing ornamental mirrors 
and sequins. Apply to open or closed shapes.

Related topics
 Creating string stitching

Chenille-type patterns

EmbroideryStudio provides a number of stitch patterns traditionally associated 
with chenille work – Square, Double Square, Coil, and Island Coil. The 
pattern you use depends on input tool used as well as object shape, size and the 
effect you want to achieve. While these patterns are normally used with chenille 
designs, they can also be used as decorative lockstitch pattern types. Of course 
lockstitch machines can’t produce actual chenille chain or moss stitching, except 
with the aid of a ‘Simple Chenille’ device. However, the patterns themselves can 
create other forms of decorative, open stitching using run stitches.

Square stitching
Square stitching is similar to Tatami and is suitable for use with most 
closed-object input methods. Square can fill areas diagonally, or on the 
horizontal and vertical. Double Square is suitable for larger closed areas. You 
could obtain a similar effect using open tatami with borderline backstitch, but 

Use Fill Stitch Types > String to create string craftstitch fills. Apply to closed shapes.

Use Fill Stitch Types > String to create string craftstitch outlines for delicate borders. 
Apply to open or closed shapes.

Use Fill Stitch Types > Square to create open straight parallel fills. Right-click for 
settings.

Use Fill Stitch Types > Double Square to create grid fills. Apply closed shapes. 
Right-click for settings.

Use Fill Stitch Types > Coil to stitch narrow shapes or columns where each stitch 
traverses the column width. Right-click to adjust settings.

Use Fill Stitch Types > Island Coil to fill large Complex Fill objects with concentric 
rows of coil stitching, simulating the circular motion of hand-chenille embroidery. 
Right-click to adjust settings.
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Square stitch makes it simpler to achieve. Stitch angles have no effect on this 
stitch type.

Coil stitching
Coil stitching is more similar to Satin and is suitable for use with most 
closed-object input methods. Stitches are generated in spirals. Coil is generally 
suited to narrow shapes or columns where each stitch traverses the width of the 
column. Island Coil is used to fill larger closed areas. This technique allows 
complex shapes to be filled with concentric rows of coil stitching.

Related topics
 Creating chenille-type patterns

Cross stitch fills

Cross stitching is a popular technique for filling large areas with low stitch 
counts. Cross stitch is also sometimes combined with appliqué. Cross Stitch fill 
is something like Motif Fill but is generated differently. 

Use Fill Stitch Types > Cross Stitch to fill large areas with low stitch count 
cross-stitch fills.
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Crosses in different objects line up precisely if using the same fabric count. This 
is because cross stitch fills are generated on a universal grid, not just referenced 
to the individual object. Fractional crosses are generated at object boundaries in 
order to avoid gaps forming. Cross Stitch fill uses travel runs under and along 
the cross stitching.

Note  Cross Stitch fill is a stitch type in its own right but does not replace the 
ES Cross Stitch application available via the File menu. See also 
EmbroideryStudio Cross Stitch Supplement.

Related topics
 Creating cross stitch fills
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Chapter 12

Digitizing Shapes

In EmbroideryStudio, you build designs 
from basic shapes or embroidery 
objects. These are like ordinary vector 
graphics in that they have defining 
characteristics or ‘properties’ such as 
color, size, position, and so on. They also 
have properties unique to embroidery 
such as stitch type and density. The 
most important property of an 
embroidery object is its stitch type. 
Different stitch types are suited to 
different shapes.

Tip  EmbroideryStudio also lets you convert vector objects directly to 
embroidery objects. In fact, entire vector designs can be converted to 
embroidery. See also Converting objects with CorelDRAW Graphics.

Embroidery digitizing

The process of creating embroidery objects on screen is called ‘digitizing’. Like 
design creation in CorelDRAW Graphics, this involves the use of ‘input’ or 
‘digitizing’ methods. In fact, digitizing tools in EmbroideryStudio can be used to 
generate both embroidery objects and vector objects.

Tip  The CorelDRAW® Graphics Suite of curve-line digitizing tools such as 
B-Spline Curve, Freehand, Bezier, Pen, etc, are very useful. Objects created 
with these tools can be converted directly to embroidery. See also Converting 
objects with CorelDRAW Graphics.

Digitizing methods

EmbroideryStudio provides an outline/fill digitizing paradigm similar to 
CorelDRAW® Graphics Suite and other graphics applications. This makes 
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embroidery digitizing easy for those coming from a graphic design background. 
It also makes it easy to convert between outlines and fills generally. For those 
coming from an embroidery background, the toolset also provides traditional 
‘power digitizing’ methods professional digitizers are familiar with.

Digitizing toolset
The toolset you will typically use for digitizing work includes some or all of the 
following:

Graphics digitizing
The graphics approach to digitizing is similar to CorelDRAW® Graphics Suite 
or other graphics applications. It provides one set of tools to create shapes which 
can be stitched as outlines or fills. You assign a stitch type to a shape by 
selecting from the Stitch Types toolbars.

Toolbar Purpose

Graphics Digitizing Select a digitizing method – either graphical or traditional, open or 
closed.Traditional Digitizing

Outlines Select a stitch type – either outline or fill. Both open and closed 
shapes may be treated as outlines. Only closed shapes can be 
used in conjunction with fill stitching.

Fills

Stitch Effects Select a stitch effect to apply as you digitize – e.g. smart corners. 
These can be modified at any time.

Color Select a thread color to apply as you digitize. Colors in the palette 
may or may not be assigned to actual threads. It makes no 
difference when you digitize.

Graphical and 
traditional digitizing 
tools

Fill and outline
stitch types

Stitch effects applied in 
addition to stitch types

Thread colors applied in 
addition to stitch types
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Traditional digitizing
Traditional digitizing methods divide into three main categories – ‘free shapes’, 
‘column shapes’, and ‘outlines’.

Tip  Traditional methods also include ‘manual’ digitizing tools. Use these to add 
individual stitches, either singly or three stitch layers at a time. See also 
Digitizing manual stitches.
EmbroideryStudio also provides special time-saving input tools for creating stars 
and rings. See also Digitizing stars & rings.

Digitizing methods
Different digitizing tools are suited to different shapes or design elements. 
Whichever approach you take – graphical or traditional – methods divide broadly 
into two categories – open or closed – and two types – outline or fill. No stitch 
type, effect, or thread color is set in stone. Object properties can be modified at 
any time.

Whenever you select a traditional digitizing tool, instructions in the Prompt Bar 
guide you through the process. Because these tools use an embroidery digitizing 
paradigm, you may be prompted to add multiple boundaries for holes, stitch 
angles, and/or start and end points. Refer to the prompts until the tool becomes 
familiar to you.

Outlines

Details

Columns

Free-form 
shapes

Stitch count

Status Bar

Prompt Bar
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Underlays
Embroidery appearance and quality depends a lot on underlay which serves as 
a foundation for cover stitching. Underlay settings are stored with each object 
in the same way as other object properties. They are regenerated whenever the 
object is scaled or transformed. When Auto Fabric is turned on, a default 
underlay is applied, based on fabric settings. When Auto Fabric is turned off, 
an underlay is still appled but it is based on the digitizing method.

General notes
 Change settings of most tools by right-clicking and adjusting values in the 

Object Properties docker.
 Use the Prompt Bar to help you digitize.
 If you make a mistake, press Backspace to delete the last point.
 Press Esc to undo all new points. Press Esc again to exit digitizing mode.
 Use Auto Scroll to scroll automatically within the design window while 

digitizing.
 Hold down the Shift key to temporarily deactivate Auto Scroll. 
 Use the Ctrl+Shift+A key combination to quickly toggle Auto Scroll on/off.

Tip  The Show Repeats function displays repeating designs, including sequins, 
in both TrueView and stitch view. You can view an existing design, even while 
digitizing, with any number of repeats.

Switching between fill & outline
You can switch between a fill stitch input method and Digitize Run or Manual 
by means of shortcut keys.
 Press Enter to switch between a fill stitch digitizing method and Manual.
 Press Spacebar to switch between a fill stitch digitizing method and Digitize 

Run.

Tip  After digitizing, most object types can be easily inter-converted. 

Related topics
 Setting scroll options
 Viewing design repeats
 Creating free-form shapes
 Digitizing regular columns
 Simple outline stitching
 Digitizing stars & rings
 Creating freehand embroidery
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 Digitizing individual stitches
 Stabilizing with automatic underlay
 Keyboard shortcuts

Reference points & reshape nodes

Once you have selected a digitizing method, you create shapes by marking 
points along an outline.

Use the left mouse button for corner points and right mouse button for curve 
points. Bézier control handles are available when you come to modify a shape.

A few general rules apply:
 To constrain the line to 15° increments, hold down Ctrl as you digitize.
 For a perfect circular arc, mark three points with a right-click, and press 

Enter.

The reference points you mark when digitizing a shape become its ‘control 
points’. These vary slightly with the object type. Most points can be added, 
deleted, or moved. Corner and curve points can be interchanged. Some control 
points such as entry and exit points cannot be deleted. 

Related topics
 Reshaping Objects
 Reshaping embroidery objects

Join methods

When you are digitizing closed objects, the Closest Join method automatically 
calculates connector points. When deactivated, all newly digitized objects are 

Right-click for 
curve points

Click for 
corner points
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joined by the As Digitized method. This means that you manually specify entry 
and exit points while digitizing. 

Tip  The Apply Closest Join feature allows you to (re-)apply closest join to 
objects after editing.

Related topics
 Setting other general options
 Applying closest join

Generating stitches

With Generate Stitches on (the default), stitches are calculated for new 
objects whenever you press Enter. They are also updated whenever you scale, 
transform or move the object. If speed is an issue, you can digitize objects with 
Generate Stitches off.

To generate stitches
 To generate stitches for new or selected objects, select Stitch > Generate 

Stitches or press G.

 To remove stitches, or digitize without generating stitches, deselect Stitch > 
Generate Stitches or press G again.

Closest Join onClosest Join off

Use Stitch > Generate Stitches to generate stitches for selected objects.
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Tip  Make sure Show Outlines is selected, otherwise stitchless objects will 
not be visible.

Related topics
 Setting reshape options
 Change backgrounds

Digitizing with graphical tools

The graphics approach to digitizing is similar to CorelDRAW® Graphics Suite 
or other graphics applications. Assign a stitch type to shapes from the Stitch 
Types toolbars. Graphics digitizing tools are set to default values. To adjust the 
resulting objects, use the stitch angle, reshape, and hole tools.

Note  The Graphics Digitizing toolbar also contains ‘freehand’ tools to create 
‘drawing’ embroidery outlines and fills directly on screen. See also Creating 
freehand embroidery.

Digitizing regular shapes

EmbroideryStudio provides digitizing tools for quickly creating regular shapes 
such as circles and squares, ovals and rectangles.

Squares & rectangles
Digitize squares and rectangles with a few clicks of the Rectangle tool. Use any 
fill or outline stitch type.

Click to mark a corner. Drag the pointer and click to define the opposite corner. 
To create a square, hold the Ctrl key down whilst dragging the pointer.

Use Graphics Digitizing > Rectangle to digitize rectangle or square objects. Press 
<Ctrl> for a square.

Use Graphics Digitizing > Ellipse to digitize ellipse or circle objects.

SatinSingle SplitsMotif RunTatami

1

2
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Circles & ovals
Digitize filled circles and ellipses with a few clicks with the Ellipse tool. You can 
use any stitch type, including outlines. Contour stitch looks most effective with 
long, narrow ovals.

To digitize circles or ellipses, click to mark the center and click again to set the 
radius, and press Enter. This point becomes the entry point. To create an oval, 
click a third time to mark the second radius point, and press Enter.

Related topics
 Selecting & editing stitches

Digitizing open & closed shapes

Use the Digitize Open Shape tool to digitize open shapes with any kind of 
outline stitch. Digitize Open Shape places a row of stitches along a digitized 
line. This tool is typically used to add borders or details to designs. Digitize 
free-form closed shapes with the Digitize Closed Shape tool. This tool can be 
used with either outline or fill stitch types. 

Press 
Enter

Press Enter
center

center

1

2

1

2

3

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes. Press 
<Ctrl> to constrain.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. Press 
<Ctrl> to create a square.
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Tip  To create both an outline and a fill, create the fill first, then select and 
duplicate the object and convert the duplicate to an outline, which is stitched 
after the fill.

To digitize an open or closed shape
 Select a tool – open or closed shape – together with a suitable stitch type – 

outline for open, outline or fill for closed.
 Choose a color from the Color Palette toolbar. The color palette contains a 

selection of colors which can be tailored to each design or color scheme.
 Digitize the shape by marking reference points:
 Click to enter corner points.
 Right-click to enter curve points.

Tip  Follow the prompts in the Prompt Bar to help you digitize. If you make 
a mistake, press Backspace to delete the last reference point, then continue 
adding reference points or press Esc to delete all the points so you can start 
again.

 Press Enter to complete a shape. With the Digitize Closed Shape tool, the 
shape will be closed with the same type of reference point as the last you 
digitized – i.e. corner or curve. To close with a different type of reference 
point, mark the last on top of the first and press Enter.

 If you decide to close an open object, use Edit > Close Curve ... commands 
to close using straight or curved points.

 Press Esc to deselect the tool.

Note  By default, objects are joined by the Closest Join method. If 
deactivated, all newly digitized objects are joined by the As Digitized 
method. This means you need to specify entry and exit points, following 
prompts in the Prompt Bar. 

Related topics
 Selecting & editing stitches
 Choosing thread colors
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 Setting other general options
 Minimizing connectors

Digitizing outlines & details

EmbroideryStudio provides tools for creating outline stitching of varying 
thickness and styles. These tools place a row of stitching along a digitized line. 
They are typically used for adding outlines and details. They can also be used 
for decorative effect.

To digitize outlines and details
 Select a suitable input tool together with an outline stitch type.

 Alternatively, choose a traditional outline input method from the Outline 
Tools.

 In addition to Run and Triple Run, traditional methods include:

Use Outline Tools > Digitize Run to place a row of single or triple run stitches along 
a digitized line.

Choose input method 
and outline stitch type

Choose outline 
input method

Use Motif Run to place a row of motifs along a digitized line. 
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 Choose a color from the Color Palette toolbar. You can change colors at any 
time.

 Digitize the shape by marking reference points:
 Left-click for corner points.
 Right-click for curve points.
 To constrain the line to 15° increments, hold down Ctrl as you digitize.
 For a perfect circular arc, mark three points with a right-click. 
 Where curves connect – either to a straight line or another curve – click to 

mark the connection point.

Tip  If you make a mistake, press Backspace to delete the last point. Press 
Esc to undo all new points. Press Esc again to exit digitizing mode. 

 Press Enter to finish.
 To view stitches better, use the View toolbar toggles to turn on or off 

backdrops.
 Optionally, use Edit > Close Curve ... commands to close an object using 

straight or curved points.
 Optionally, double-click the object to access object properties.

 To set a fixed stitch length, adjust the Length field. For sharp curves, reduce 
length – e.g. 1.8 mm – so that the stitches follow the line more closely. 
Alternatively, automatically shorten stitches to follow tight curves with the 
Variable Run Length option.

Tip  Use Auto Scroll to scroll automatically within the design window while 
digitizing. Hold down the Shift key to temporarily deactivate Auto Scroll. 
Use the Ctrl+Shift+A key combination to quickly toggle Auto Scroll on/off.

Use Backstitch to place a row of backstitches along a digitized line. 

Use Stemstitch to place a row of stemstitches along a digitized line. 

Adjust nominal 
stitch length

Adjust variable run 
length values

Change stitch type

Turn on/off variable
run length

Too few stitches to follow 
tight curve

Stitches follow the curve 
more closely

Run length Run length
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Related topics
 Simple outline stitching
 Choosing thread colors
 Setting other general options
 View graphical components
 Minimizing connectors
 Setting scroll options

Digitizing regular columns

Use Column C to digitize columns and borders of fixed width. Column C is 
usually used with satin stitch but other outline stitch types are available for use. 
See also Satin stitching.

Tip  You can toggle between Column C and Digitize Run by pressing the 
Spacebar. See also Converting objects with CorelDRAW Graphics.

Creating columns & borders

Digitize columns and borders of fixed width with the Column C tool.

To create columns and borders
1 Insert some artwork to use as a digitizing backdrop.
2 Select a color and stitch type – e.g. Satin.
3 Select Column C and mark corner or curve points around the outline of the 

shape.
 Click to enter corner points.
 Right-click to enter curve points.

Use Traditional Digitizing > Column C to digitize columns or borders of fixed width. 
Right-click for settings.
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2
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Tip  The Show Column C width guide setting in the Options dialog 
activates a special cursor. This is useful when digitizing a border based on a 
background image.

4 To close the shape, enter the last point on top of the first.
5 Press Enter.
6 Specify column width:
 To use the default width – as set in the Object Properties > Special > 

Column C docker – press Enter.
 To specify a width, mark two additional points. By default, stitches are 

positioned around the center of the digitized line.

 To specify an offset, right-click reference points instead of left-clicking. 

7 Press Enter to finish.

Related topics
 Stitch Types
 Adjusting rulers & guides
 Reshaping Column C objects

Adjusting column width & offset

By default, stitches are positioned around the center of an Column C object. Set 
an exact offset via Object Properties. You can also set an exact width.

Digitize column width 
anywhere in design 
window

8

9

Left-click
reference points

Right-click
reference points

Use Traditional Digitizing > Column C to digitize columns or borders of fixed width. 
Right-click for settings.
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To adjust column width and offset
 Double-click an Column C object or right-click the tool to access object 

properties.

 Enter a Column Width.

 In the Input Side panel, select Offset.

 Set an offset in either Side 1 or Side 2 field.

Tip  You can also change the width of Column C objects by adjusting control 
points with the Reshape tool.

Related topics
 Adjusting rulers & guides

Adjust column 
width

Set offsets either 
side

Select offset

Offset: 75% Offset: 25% 
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 Reshaping embroidery objects

Setting corner fractions

With sharp curves, spacing which provides adequate coverage on the outside 
edge may cause bunching along the inside edge. This may cause thread 
breakage when stitching out. You can control the way stitches turn in Column C 
objects by adjusting the ‘corner fraction’.

To set corner fractions
 Double-click a Column C object or right-click the tool to access object 

properties.

 Enter a new corner fraction in the Corner Fraction field. 
 Increasing the fraction spreads the turn over more stitches.
 Decreasing the fraction reduces the number of stitches that turn.

Tip  Round Sharp Corners is also available for Column C objects to give you 
the option of sharp or round points. 

Related topics
 Rounding sharp corners

Setting angles & orientation

Use Traditional Digitizing > Column C to digitize columns or borders of fixed width. 
Right-click for settings.

Adjust corner 
fraction

Corner
fraction 0.5

Corner
fraction 0.8

Corner
fraction 0.25

Use Traditional Digitizing > Column C to digitize columns or borders of fixed width. 
Right-click for settings.
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The Column C tool provides control of stitching angle and orientation.

Angle and Orientation controls allow you to:
 Control the angle of stitches relative to baseline.
 Create parallel stitching and control the angle relative to the horizontal. Use 

it to create calligraphy-like stitching in conjunction with Freehand.

 Control orientation to set which side to start stitching on. This is most useful 
for E Stitch.

Related topics
 Creating freehand embroidery
 Reshaping Column C objects

Default Column C 
stitch angles

Column C parallel 
stitching

Column C stitch 
angle and 
orientation controls

Slanted Column C 
stitch angles
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Digitizing irregular columns

In addition to Column C, both Traditional Digitizing and Graphics 
Digitizing toolbars provide tools for creating column shapes and borders of 
varying width.

Note  EmbroideryStudio lets you convert between Complex Fill and 
Column A or Column B objects. See Converting objects for details.

Digitizing columns of varying width

Use the Column A or Digitize Column tools to digitize 
columns of varying width and stitch angle.

To digitize columns of varying width
1 Click the Column A or Digitize Column icon.
2 Select a color and stitch type – e.g. Satin.
3 Digitize the column by marking points on alternate 

sides of the column.
 Click to enter corner points.
 Right-click to enter curve points.
The control points in a pair do not have to be the same 
type. For example, one can be a corner point, the other a curve.

Tip  If you make a mistake, press Backspace to delete the last point. Press 
Esc to undo all new points. Press Esc again to exit digitizing mode.

4 When you have finished digitizing, either:
 Press Enter to keep the last stitch and place the exit point at the last point 

you digitized, or
 Press Spacebar to omit the last stitch and place the exit point on the 

opposite side of the column.

Use Traditional Digitizing > Column A to create columns of varying width and stitch 
angle. Right-click for settings.

Use Graphics Digitizing > Digitize Column to create columns of varying width and 
stitch angle. Right-click for settings.

Stitches change angle 
through the entire 
shape

Stitches remain parallel 
between parallel stitch 
angles

Press Enter Press Spacebar

Finish

OR

FinishStart Start
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Related topics
 Stitch Types

Creating smooth joins

The ‘continuous input’ option provides a simple and efficient way of digitizing a 
single Column A object comprised of separately stitched sections. The objects so 
created can be deleted or edited using standard reshape tools.

To create smooth joins
1 Click the Options icon or select Setup > Options and click the General tab.

2 Select a continuous input method:
 Normal: Use this for non-continuous input.
 Continuous replace: Use this to continue digitizing the same object after 

each Enter keypress. Any properties you change during digitizing will 
affect the entire object, not just the section you are working on.

 Continuous add: Use this to join objects of different size where different 
stitch types are used – e.g. a narrow section of satin stitch joining to a 
larger section of tatami.

3 Click OK.
4 Digitize the Column A object. When you press Enter, the digitized object fills 

with stitches. The input tool is still active.
5 If you are using Continuous Add mode, you can select another stitch type 

at this point.

Use Traditional Digitizing > Column A together with ‘continuous input’ to create 
single objects comprising separately stitched sections.

Use Standard > Options to access application options for design view, grid & 
guides, and other settings.

Select continuous 
input method

Second section 
‘smooth joined’ to first 
as a single object

First section created

First section created

Second section 
‘smooth joined’ to first 
– two sections become 
separate objects
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Tip  To stop the screen scrolling while moving the mouse, hold down Shift 
and click the stitch type button you require.

6 Recommence digitizing where you left off and press Enter when you have 
finished.
If you are using Continuous Add mode, the new section is a new object. This 
means that, while the two sections are smoothly joined, they can have 
different properties, including stitch type.

Tip  To start a new object without joining to the previous object, click the 
Column A icon again.

Related topics
 Digitizing columns of varying width

Digitizing columns of turning stitches

Use the Column B tool to digitize shapes where one side is different to the other, 
especially where one side requires more points than the other. Stitches turn 
evenly throughout the entire shape.

To digitize asymmetric columns
1 Click the Column B icon.
2 Select a color and stitch type – e.g. Satin.
3 Digitize the first side of the shape – i.e. top or left – by marking points.
 Click to enter corner points.
 Right-click to enter curve points.

Tip  If you make a mistake, press Backspace to delete the last point. Press 
Esc to undo all new points. Press Esc again to exit digitizing mode.

4 Press Enter. 
An elastic line attaches to the pointer, ready for you to digitize the second side 
of the shape.

Use Traditional Digitizing > Column B to create asymmetrical columns of turning 
stitches, where opposite sides are different shapes. Right-click for settings.
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5 Digitize the second – i.e. bottom or right – side of the object.

Tip  Stitch angles vary from tightly turning fills to parallel fills, depending on 
the ends of the shape – the more ‘pointy’, the tighter the stitch angles.

6 When you have finished digitizing the shape, either:
 Press Enter to keep the last stitch and place the exit point at the last point 

you digitized, or
 Press Spacebar to omit the last stitch and place the exit point on the 

opposite side of the column.

Related topics
 Stitch Types

Creating free-form shapes

In EmbroideryStudio, you digitize free shapes with turning stitches with the 
all-purpose Complex Turning tool. Use the Complex Fill tool for free shapes 
with fixed stitch angles. By digitizing further internal boundaries, you can create 
shapes with holes in them.

Boundaries in complex shapes should not overlap or intersect. The shapes 
below, for example, cannot be successfully digitized.

Press Enter or 
Spacebar

Stitches turn 
evenly

109

90°

Parallel fillSloping fillTurning fill

Boundaries overlap Boundary overlaps itself Hole within hole
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Tip  You can create new objects from existing boundaries using the Fill Holes 
feature. Alternatively, you can use other objects to cut holes. See Removing 
underlying stitching and Filling holes for details.

Digitizing free-form shapes

Digitize free-form shapes with Complex Fill or with Complex Turning. The 
method is essentially the same:
 Digitize the shape
 Define entry and exit points
 Define stitch angle/s. Complex Turning lets you create multiple stitch 

angles.

To digitize a free-form shape
1 Insert artwork to use as a digitizing backdrop. Make sure Show Bitmaps or 

Show Vectors are toggled on or press 0 (zero) to see artwork on screen. 
2 Select a color and stitch type.
3 Select a tool and mark corner or curve points around the outline of the shape. 
 Click to enter corner points.
 Right-click to enter curve points.

Tip  If you make a mistake, press Backspace to delete the last point. Press 
Esc to undo all new points. Press Esc again to exit digitizing mode.

4 Close the shape:
 To close with the same type of point as the last entered – i.e. corner or 

curve – press Enter.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with turning 
stitch angles. Right-click for settings.
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 To close using a different type of point, mark the last on top of the first and 
press Enter.

5 Optionally, digitize additional (internal) boundaries in the same way and press 
Enter. 

6 Define entry and exit points by marking two points outside the object 
boundary and press Enter.
The Closest Join method (the default) automatically calculates closest join 
between objects while digitizing. When deactivated, entry and exit points 
need to be set manually. 

Tip  If you choose to digitize entry/exit points manually, place them opposite 
each other on the boundary in order to minimize travel stitching. Then define 
the stitch angle to be perpendicular to the line between entry and exit points.

7 Mark stitch angles:

Last point marked on top of 
first with right button
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 If you are using Complex Fill, mark two points.

 If you are using Complex Turning, add more stitch angles as desired. 
Stitch angles may intersect over any holes you have digitized.

 Alternatively, press Enter to accept calculated stitch angles. Or press 
Spacebar to discard calculated stitch angles and accept a single default 
stitch angle.

Tip  You can adjust and/or add stitch angles using the Reshape Object tool. 
8 Press Enter. Free shapes generally stitch out in several segments, joined by 

travel runs. However, all segments and boundaries are part of the same 
object. 

Tip  To view stitches better, toggle off Show Graphics.

Related topics
 View graphical components
 Stitch Types
 Choosing thread colorsAdding holes to free-form shapes
 Setting other general options

Stitch angle 1

Press Enter to accept 
stitch angles

Press Spacebar to accept 
single default angle

Stitch angle

Stitch 
angle 2
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 Adjusting stitch angles
 Stabilizing with automatic underlay

Adding holes to free-form shapes

While EmbroideryStudio provides dedicated tools for cutting and filling holes in 
existing objects, it also lets you add holes to closed shapes as you digitize. 

To add holes to free-form shapes
 Use one of the free-form digitizing tools to create your shape. Simply follow 

the prompts to add holes as you digitize. Alternatively, select the final object 
and click the associated free-shape tool. Points display around the object 
outline.

 Digitize additional holes making sure they do not overlap. Press Enter each 
time.

 If you make a mistake, press Backspace to delete the last point. Press Esc 
to undo all new points.

 When you have digitized all additional holes, press Enter again.

Tip  To remove unwanted holes, select the object and use the Reshape 
Object tool to delete control points around the hole.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with turning 
stitch angles. Right-click for settings.
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Related topics
 Adding & filling holes
 Reshaping embroidery objects
 Removing underlying stitching

Setting nominal angles

You can change the stitch angle of Complex Fill objects using object properties. 
By definition, Complex Turning objects contain multiple stitch angles. However, 
they also have a property called the ‘nominal angle’.

To set the nominal angle
 Double-click a free-shape object to access object properties.

 In the Angle or Nominal Angle field, enter a stitch angle.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with turning 
stitch angles. Right-click for settings.

Adjust nominal 
angle

Angle: 90° Angle: 0°
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Note  The ‘nominal angle’ in a Complex Turning object only takes effect if 
multiple stitch angles are irreconcilable – it then reverts to parallel stitching 
in the direction of the nominal angle. The nominal angle also affects certain 
underlay styles.

Tip  You can adjust stitch angles of free-form objects interactively using the 
Stitch Angles tool. 

Related topics
 Stabilizing with automatic underlay
 Adjusting stitch angles

Adjusting segment overlaps

Free shapes generally stitch out in several segments, joined by travel runs. 
Where segments within an object meet, the push-pull effect on the fabric during 
stitching may cause gaps to appear. These gaps can be prevented by adding 
overlapping rows. 

To adjust segment overlaps
 Double-click a free-shape object to access object properties.

 Adjust the number of overlapping rows where segments join. An overlap of 
‘1 row’ means no overlap between segments. An overlap of ‘2 rows’ means 
that the segment is extended by one extra row of stitches.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with turning 
stitch angles. Right-click for settings.

Enter required 
overlap

Overlap rows 5No overlap row
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 With Complex Turning objects, you can also adjust the taper angle. This value 
limits the width of overlaps. It defaults to 22.5° with a range of 15° to 90°. 

Adjusting travel margins

When dealing with complex shapes with multiple segments, you may want to 
keep travel runs away from the boundary for various reasons. If, for instance, 
you are using Jagged Edge effect, the travel might become visible through 
shortened stitches. For this reason, you can specify a margin.

To adjust travel margins
 Select an object.

 Right-click the Complex Turning icon to access object properties.

 Adjust the travel margin in the Distance field.

Taper angle: 90°Taper angle: 22.5°

Use Traditional Digitizing > Complex Turning to digitize filled shapes with turning 
stitch angles. Right-click for settings.

Travel run too 
close to edge

Adjust travel 
margin

Travel run closer to 
center of shape
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Chapter 13

Object Properties

Every object you create in EmbroideryStudio has a unique set of properties that 
are stored with it whenever you save the design. These properties define general 
characteristics such as size and position, as well as embroidery-specific 
characteristics such as stitch type and density. The stitch properties determine 
how stitches will be regenerated when you reshape, transform or scale the 
object.

This section explains how to change property settings in a design, as well as how 
to apply and adjust fabric settings. It also explains how to create and maintain 
styles and templates in EmbroideryStudio.

Basic concepts

Base properties or ‘defaults’ are stored with the design template and form the 
basis of all new designs. These may be overridden by fabric settings which are 
adjusted to suit different fabric types. These in turn may be overridden by 
individual property settings.

Actual settings
Each object has its own unique set of properties. Actual object properties are 
those settings stored with each object in the design. These may or may not be 
the same as the defaults.

Default settings
Default or starting property settings are the ones stored with the design 
template and/or selected fabric (if activated). These are automatically applied 
to any newly created objects in the design.

Current settings
You can define ‘current’ settings to influence all the objects you create in the 
current design. Simply change property settings in the Object Properties 
docker with no objects selected. These settings then apply to all new objects. 
You generally change them to save time when digitizing. For example, you may 
preset Tatami stitch spacing to use a specific density for all new Tatami objects 
you create. Alternatively, you can make a selected object’s ‘actual’ properties 



EmbroideryStudio e4 User Manual 259

‘current’ for all new objects. You can also apply current settings to existing 
objects.
When you close a design, current settings are not automatically saved to the 
template. You can save them as the new default settings of the current template 
or to another template altogether. Or you may be able to save them as a custom 
fabric.

Fabric settings
Matching object properties to the intended fabric is critical for good quality 
designs. Fabric settings are a subset of settings stored in the template which are 
fine-tuned to different fabric types. Although the NORMAL template settings are 
suitable for a range of fabrics, selecting a matching fabric automatically 
customizes object properties to the intended fabric. 

Styles
A style is a group of property settings stored under a unique name. You can save 
any combination of settings to a style. This makes it easy to apply these settings 
to selected embroidery and lettering objects. When you apply a style to an 
object, style settings replace current properties. Any properties not specified by 
the style, retain their current settings.

Templates
Templates are special files used to store styles, default properties, as well as 
default fabric settings. Use templates when digitizing frequently-used design 
types to save time re-adjusting current property settings. 

Working with object properties

When you start a new design, EmbroideryStudio uses the default settings 
associated with the chosen fabric (if activated). Other property settings are 
stored with the design template. You can override most settings on an 
object-by-object basis. For this reason, EmbroideryStudio distinguishes three 
sets of object properties – default, actual and current.

Changing current settings

Whenever you change current settings, these automatically apply to any new 
objects you create. If you know which settings you require before digitizing, you 
can preset them.

Use Docker > Object Properties to preset properties or adjust properties of selected 
objects.
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To change current settings
 With no objects selected, click the Object Properties icon.

 Select a tab to view current settings – e.g. Fills.
 Select an item from the droplist – e.g. Fills > Satin – to access those 

properties.
 Use droplists, radio buttons and checkboxes to choose options. Key in precise 

values or use the popup slider.

Tip  The slider has two operating modes – Normal and Accelerated. Holding 
down the Ctrl key puts it in Accelerated mode.

Object Properties tabs

Select stitch type

Click to close

Click to save modified settings 
to the current template

Click to access
another set of tabs

Modify settings as 
required

After clicking
‘swivel’ button, drag

popup slider to set

‘Radio’ buttons are
mutually exclusive

Click ‘swivel’ button 
to invoke slider 
control
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 Click the FX button to access a further set of tabs and modify settings as 
required.

 Press Enter to confirm changes. Modified settings are now current for all new 
objects. You can apply them to existing objects by means of the Apply 
Current Properties tool. 

 Optionally, click Save. The object properties are saved to the current 
template. These will apply to any new objects in any design based on this 
template.

Changing object properties

You can change an object’s properties at any time without affecting those of any 
other object not currently selected. Some properties can be modified on screen 
– for example, you can change size by scaling an object with selection handles. 
Other properties, such as stitch spacing or length, are modified via the Object 
Properties docker. 

To change object properties
 Select the object/s whose properties you want to change.

 Use any of the interactive techniques for scaling, transforming, or reshaping 
selected object/s. 

 Adjust general properties – width, height, position – by means of the 
Property Bar. Press Enter to confirm or Esc to discard.

Use Docker > Object Properties to preset properties or adjust properties of selected 
objects.

Adjust properties and 
press Enter
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 Double-click an object to access object properties.

 Select a tab and to access available properties. 
If you select more than one object, the Object Properties docker only 
displays settings relevant to all. If selected objects have different values for 
the same setting – e.g. stitch length – the field will be blank. If you enter a 
new value, it applies to all selected objects.

 Click the FX button to access a further set of tabs.
 Press Enter to apply changes to selected object/s.

 Some properties, such as Auto Underlay, are applied by means of toolbar 
buttons. When the button is selected, that tool’s settings are current.

 Optionally, click Save. The object properties are saved to the current 
template. These will apply to any new objects in any design based on this 
template.

Related topics
 Access object properties
 Modifying Objects
 Reshaping Objects
 Working with templates

Object Properties tabs

Droplist

Click to close

Click to save modified settings 
to the current template

Click to access
another set of tabs

Modify settings as 
preferred
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Copying properties

You can make a selected object’s ‘actual’ properties ‘current’ for all new objects 
or apply them to existing objects.

To copy properties
 Select the object whose properties you want to make current.
 Click the Make Properties Current icon. Alternatively, right-click the 

selected object and choose the Make Properties Current command in the 
popup menu. 

 Select the object/s whose properties you want to change.
 Click the Apply Current Properties icon. Alternatively, right-click the 

selected object and choose the Apply Current Properties command in the 
popup menu. 

Click Styles > Make Properties Current to make the properties of a selected object 
current for the design.

Use Styles > Apply Current Properties to apply current settings to selected objects.

Copy properties from 
one object to another 
using these commands
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Working with fabrics

Embroidery stitches pull fabric inward where the needle penetrates. This can 
cause fabric to pucker and gaps to appear. For an object to sew out correctly, it 
must have correct stitch spacing, sufficient pull compensation together with a 
suitable underlay for the combination of cover stitch type, object type, object 
shape and fabric.

EmbroideryStudio provides a set of customized fabric settings so the software 
will take into account the type of fabric you are stitching on. Fabrics are a critical 
element of designs and are controlled separately from template values. Fabric 
settings are fewer in number than those contained in templates.

Changing fabrics

Normally you choose a fabric when you start a design although you can change 
it at any stage. Fabric settings affect all object types other than motif fills, 
appliqué, and run stitches.

To change fabrics
1 Select Design > Auto Fabric.

2 Tick the Apply Auto Fabric checkbox to activate the feature. Conversely, 
you can turn off auto fabrics at any stage. You are prompted to confirm the 
decision.

3 From the list, choose a fabric type matching or nearest to the fabric you 
intend to work with. 

4 Click OK.

Choose a
fabric type

Activate
auto-fabrics
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The selected fabric is displayed in the Status bar. If you choose to apply an 
auto fabric to a design with no previous fabric, you are prompted to apply it 
to new objects only or to existing objects as well.

Note  Changing the current Auto Fabric will affect all colorways in the 
design. However, the converse is not the case. While colorways allow you to 
select different fabric swatches for different colorways, these have no bearing 
on Auto Fabric settings. However, the background Fabric option is ‘aware’ 
of Auto Fabric selection. Consequently, the Browse button takes you to an 
assortment of swatches relevant to your current fabric selection. 

Related topics
 Create designs from templates
 Compensating for fabric stretch

Managing fabrics

In addition to pre-defined fabric settings, you can create your own custom fabric 
settings to suit particular needs. You can also modify, rename or delete custom 
fabrics.

To create a new fabric
1 Select Setup > Manage Auto Fabrics.

If you already have custom fabrics defined, you have the option of editing, 
renaming, or deleting.

2 To create a new fabric type, click Create.

3 Enter a new fabric name. If you want to base the new fabric on default 
settings, select blank.

4 Click OK.

Choose how to
apply auto

fabric

Create new 
fabric type

Enter fabric
name
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The Auto Fabric Settings dialog opens. This dialog allows you to set the 
fabric values for four object groups – Tatami/Program Split, Wide Satin, 
Narrow Satin, and Lettering – as well as enter details of any recommended 
stabilizers.

To set tatami/program split values
 Click the tab to access Tatami/Program Split Fill settings. These will 

become the defaults for Tatami and Program Split objects.

 Adjust Length and Spacing settings for your Tatami / Program Split Fill 
objects as required:
 Tatami stitch consists of rows of run stitches and is suitable for filling 

large, irregular shapes. See Tatami stitching for details.
 Program Split is a decorative stitch type. Use it to fill wide and large areas 

with artistic effects while keeping the appearance of a solid field of 
stitching. See Creating textures with program splits for details.

 Set a suitable underlay type for Tatami/Program Split objects. See Stabilizing 
with automatic underlay for details.

 Set a pull compensation allowance for these objects. See Compensating for 
fabric stretch for details.

To set satin object values
 Click the tab to access Wide Satin settings.

Adjust Tatami/Prog 
Split values for new 
fabric

Fabric: Denim
Pull Comp: Low

Fabric: Silk
Pull Comp: Medium

Fabric: Terry Toweling
Pull Comp: High
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These settings will become the defaults for larger Satin objects.

 Adjust the Wide Satin settings as you did for Tatami / Program Split objects. 
See Satin stitching for details.
Instead of Stitch Length and Stitch Spacing settings, you have a single 
density setting which is controlled by a slider bar.

 Click the tab to access the Narrow Satin settings and adjust as you did for 
Wide Satin objects. Generally, narrow objects will require a different underlay 
type. See Satin stitching for details.

To set lettering object values
 Click the tab to access Lettering settings.

 Adjust settings as you did for Satin objects. See Applying stitch types & 
effects to lettering for details.

Adjust Wide Satin 
values for new 
fabric

Adjust Narrow Satin 
values for new 
fabric

Adjust Lettering 
values for new fabric
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To set stabilizer settings
 Click the tab to access Stabilizer settings.

 Key in one or more recommended stabilizer(s) together with a description or 
any other relevant information for the custom fabric. This information will be 
displayed in the Choose Fabric dialog. See Changing fabrics for details.

Working with styles

A style is a group of property settings stored under a unique name. This makes 
it easy to apply them to selected embroidery and lettering objects. Use the 
Styles toolbar to apply styles to selected objects. The tools also allow you to set 
and apply current settings. Styles you tag as ‘favorites’ are each assigned an 
icon on the toolbar.

Styles are stored with the design template. The NORMAL template provides a 
selection of preset styles for you to use. Each template may contain specific 
styles for different types of embroidery. See also Working with templates.

Applying styles

When you apply a style, the settings overwrite current settings. Any properties 
not specified in the style, retain their current settings.

To apply styles
 If available, click the Favorite Style icon assigned to the style you want to 

use. 
 If an object is selected, the style settings are applied to it alone.

Adjust stabilizer values 
for new fabric

Use Styles > Apply Style to apply a style from the template to new or selected 
objects.

Use Styles > Favorite Styles to apply preferred styles to new or selected objects.
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 If no object is selected, the style settings become current and apply to 
any new objects you create.

 Alternatively, click the Apply Style icon.

 Select a style from the droplist and click OK.

Tip  If you are using a digitizing tablet, you can quickly switch between preset 
styles. Each button on the puck accesses the next preset style with different 
spacing settings. For example, clicking Button 1 accesses 
<PRESET_SATIN_1>.

Related topics
 Working with object properties
 Assigning favorites

Defining styles

Define new styles for a template, either from scratch or based on an existing 
style or object. New styles are saved to the current template.

To define a style
1 To base the new style on an existing object, select it now. To base it on 

current settings, make sure no objects are selected.
2 Select Setup > Manage Styles.

3 Click Create.

Style 1, E stitch spacing 
0.75 mm

Style 2, E stitch spacing 
1.25 mm

Style 3, E stitch spacing 
1.75 mm

Select styleMy Style

Click to define 
new style

Enter name for
new style

Select style to
base it on

My Old Style

My New Style
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4 Enter a new style name. Choose how you want to base your style:
 If you want to base the new style on default settings – current or selected 

object – select blank.
 If you want to base it on an existing style, select from the droplist.

5 If you want the new style to be added to the Style toolbar, tick the Favorites 
checkbox.

6 Click OK. The Object Properties docker opens.
7 Update properties as required.
 If you want to apply current settings, click Apply. 
 Otherwise, update those settings you want to change. You don’t have to 

enter values in all fields, only those you specifically wish to store.
8 Press Enter.

The new style is saved to the current template.

Modifying styles

The Setup > Manage Styles function allows you to modify styles, including the 
factory presets in the NORMAL template. You can merge settings from one style 
to another. You can rename a style without affecting its settings. You can also 
remove any unwanted styles from a template.

Select a style from the list and modify using the available buttons:

Tip  At some stage, you may want to revert to the original style settings in the 
NORMAL template. See Reverting to the NORMAL template for details.

Function Description

Edit Edit styles as you would a selected object. See Changing current settings 
for details.

Rename Rename a style at any time. Select names that will help you remember the 
style or help you sort frequently-used styles to the top of the list. 

Remove / All Remove unwanted styles from the current template. The style is removed 
from the list of style names. To remove all styles from a template click 
Remove All.

Merge Copy settings from one style to another via the Merge With Style dialog. 
When you merge, settings from the second style overwrite the first. 

Favorites You can assign up to ten favorite styles to tool icons on the Styles toolbar. 
See Assigning favorites for details.

Edit style properties

Select a style to
modify
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Assigning favorites

You can assign up to ten favorite styles to tool icons on the Styles toolbar. To 
apply the style, you then simply select the tool.

To assign a favorite style
1 Select Setup > Manage Styles.

2 Click Favorites. The Manage Favorites dialog opens.

3 Click Add. The Add To Favorites dialog opens.

4 Select a style from the droplist and click OK.
5 Change the order in which the favorites will appear on the Styles toolbar 

using Move Up and Move Down.
6 Close out the dialogs. Styles are assigned in the order they appear in the 

Manage Favorites dialog. The tool tip for each button shows the style name.

Working with templates

Templates are special files used to store fabrics, styles and default settings. Use 
templates when digitizing frequently-used design types so that you do not have 
to set the current settings every time. For example, a template may include 
standard objects and sample lettering. It may simply have preferred stitch 
settings, lettering font and size, and colors set as current settings. Or it may 
have special density, pull compensation or underlay settings to suit different 
fabrics.

Organize favorite styles

Click Add

My New Style

Select style
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The NORMAL template
The NORMAL template is the default template supplied with the software. It 
contains current property settings as well as a selection of preset styles. These 
styles include variations on the current property settings. For example, 
<PRESET_SATIN_1> and <PRESET_SATIN_2> contains different stitch spacing 
settings for Satin stitches. You can view and modify the settings for these styles 
at any time. See Modifying styles for details.

Note  If necessary, you can revert to the original NORMAL template after 
modifying it. See Reverting to the NORMAL template for details.

Using design templates
When you start a new design from the File > New menu, a list of the available 
templates appears in the New dialog. If you select the New tool on the 
Standard toolbar, the NORMAL template is applied by default. See also Create 
designs from templates.

Saving current properties to a template

You can easily save current settings to the current template. 

To save current properties to a template
 To use the current property settings, deselect all objects, then click the 

Object Properties icon. 
 To use the settings of a favorite style, click the button with no objects 

selected.
 Open the Object Properties docker.

 Make any further adjustments as required.

Use Docker > Object Properties to preset properties or adjust properties of selected 
objects.

Object Properties tabs

Droplist

Click to close

Click to save modified settings 
to the current template

Click to access
another set of tabs

Modify settings as 
preferred
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 Click Save. Current settings are saved to the template as the new defaults.

Tip  To save more than one set of property settings to the template, save 
them as styles. 

Related topics
 Working with object properties
 Defining styles

Creating design templates

You create templates from designs containing the required objects and property 
settings. Simply save the design, or elements of it, as a template. Templates 
look the same as design files, but use the file extension EMT.

To create a design template
1 Start a new design or open an existing one.
2 Adjust the property settings, styles, and effects as required.
3 Add the objects and lettering to be included in the template. For instance, you 

may want to include sample lettering using different baselines. Simply 
overtype the sample text when using the template. 

4 Select File > Save As. The Save as Template dialog opens onto the 
Template folder.

5 Select Design Templates (EMT) from Save as type list.
EmbroideryStudio automatically opens the C:\Program Files 
(x86)\Wilcom\EmbroideryStudio_e4.0\Template folder. Design 
templates must be saved here or they will not appear in the template list 
when you start a new design.

6 Enter a name and click Save. The template is ready for use.

Tip  The File menu provides separate commands for saving monogram and 
team name templates. See related topics below.

Enter a name for 
your custom 
template

MY TEMPLATE
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Related topics
 Working with baselines
 Monogram designs

Modifying design templates

You can modify templates in the same way as a normal design. Changes apply 
only to future uses of the template. Existing designs based on the template are 
not affected.

To modify design templates
1 Select File > Open. The Open dialog opens. 
2 Navigate to the C:\Program Files 

(x86)\Wilcom\EmbroideryStudio_e4.0\Template folder.
3 Select Templates (EMT) from the Files of type list. The available template 

files display.
4 Select the template you want to modify and click Open.
5 Modify property settings, styles and other settings as required.
6 Select File > Save As. The Save As dialog opens.
7 From the Save as type list, select Templates (EMT).
8 Enter a name and click Save. The modified template is ready for use.

Note  Delete templates in the same way as you would any other 
MS Windows® file, using Windows Explorer.

Reverting to the NORMAL template

If you modify the NORMAL template supplied with EmbroideryStudio, you can 
revert to the original version. A factory copy is always maintained so that the 
NORMAL template can be restored.

To revert to the NORMAL template
1 Close EmbroideryStudio.
2 Click the MS Windows® Start button and navigate to the Wilcom 

EmbroideryStudio group.
3 Select Revert. The Revert to Factory Settings dialog opens.

4 Select the Templates checkbox and click OK. The original settings for the 
NORMAL template are restored.

Select Templates

Click OK
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Chapter 14

Colorways

When digitizing, you select colors from the color palette. The particular 
‘colorway’ represents the actual thread colors in which a design will be stitched. 
You can define multiple color schemes and switch between them. 

For each colorway you define, you can select colors from commercial thread 
charts or define your own. Search for particular threads by specific code. Locate 
thread colors based on closest match across one or several thread charts. You 
can also match thread colors from imported graphics – vector or bitmap.
EmbroideryStudio also lets you set the background color, fabric, or product of 
the current colorway for more realistic previews and presentations. The 
background and product are saved with the colorway.

Note  You can also print multiple colorways, design background and product, 
and icons of color blocks in the production worksheet. See also Printing design 
reports.

Creating colorways

EmbroideryStudio provides various techniques to selecting and changing 
colorways manually or generating colorways automatically.

Caution  Due to differences in computer monitors and video cards, onscreen 
colors should only be used as guides. Always check thread colors against the 
actual thread chart you intend to use.

Adding colorways

Use Color Palette > Colorway Editor to add or edit colorways.
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When you create a new design, it contains a single default colorway called 
‘Colorway 1’. You can add a virtually unlimited number of colorways to the 
design using the same or different thread sets. Preview designs in different 
colors on different fabrics. Colorways are saved with the design in EMB format. 
They can also be saved to an EMT template file for use in future designs. They 
cannot, however, be saved with machine files. 

Tip  Other settings are included as part of the colorway definition – background 
color, fabric, or product, as well as display colors for borer symbols, unsewn 
stitches, selected objects, object outlines and the grid. See Viewing colorways 
for details.

To add a colorway
 Open the design and click the Colorway Editor icon.

Use Colorway Editor > Create Colorway to add a new colorway to the design.

Click to create
new colorway

Click to toggle single 
or multiple colorway 
display
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 Click the Create Colorway icon.

 Enter a new colorway name. The new colorway will use the current colorway 
as a starting point.

 Assign colors from available threads to selected color slots. See Assigning 
thread colors for details.

Note  As dark-colored threads cover light-colored fabrics better than vice 
versa, different densities may be required when changing from one colorway 
to another. Colorways do not automatically compensate for different 
densities. These have to be adjusted manually. 

 Use the internal toolbar to edit:

Give the colorway a unique name for easy identification in the droplist and 
production worksheet – e.g. a name which reflects the background fabric.

Enter new colorway 
name

Colorway 2

New colorway added 
based on current 
colorway

Assign threads to 
new colorway
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Tip  If you change the background in Colorway 1 and save it to your 
template, it will display like this at start up. See also Working with templates.

Changing color schemes

The color tools allow you to quickly re-color entire designs. Their main purpose 
is to create new ‘colorways’ quickly and easily in order to ‘spice up’ old designs 
or place them on a different fabric.

To change color schemes
 Optionally, add a new colorway for your new color scheme. See Adding 

colorways for details.

Remove a colorway from the design.

Change the colorway background fabric and/or color. See also Setting fabric 
backgrounds.

Use Color Palette > Cycle Used Colors to cycle through combinations of used 
colors. Right- or left-click.

Use Color Palette > Color Wheel to access Color Wheel to test combinations of 
related colors.

New colorway
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 Use the Cycle Used Colors tool to try out different combinations using 
threads already in the design.

 Alternatively, select Color Wheel. This allows you to cycle through many 
color combinations using preset color schemes including Analogous, 
Complementary, Harmonious, etc.

 Click and drag the ‘base color’ node to try out different combinations of the 
same color scheme to suit different background colors. You can make any 
color the base color just by selecting it in the palette.

Cycle through 
used colors

Click and drag base color 
node to adjust all

Choose a color scheme Click any slot to set base color
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 Each color node can be further individually adjusted.

 To adjust the brightness of the entire design, select the base color node and 
adjust the Brightness control.

 Click OK to apply changes. New colors are added to the palette and design 
colors update accordingly.

 Match and assign thread colors manually or use the Match & Assign All 
function. See below.

Related topics
 Assigning thread colors

Adjust individual 
nodes as required

New colors
added to palette
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Color blocks & stop sequence

A color block corresponds to a color change in the design. It may be comprised 
of one or more same-color objects. These may form a single group – e.g. ‘ropes’ 
– or more – e.g. ‘ropes and birds’. Each color block, or ‘element’, can be given a 
descriptive name for easy identification. These can be included on the 
production worksheet. Together this information is known as the ‘stop 
sequence’. The operator generally uses it to ensure that correct colors are used 
in the correct sequence during production.

Note  The Color-Object List shows the same sequential list of objects, grouped 
by ‘color block’.

Design properties thread colors

The Thread Colors tab displays the color sequence and stitch counts for each 
design ‘element’. Elements equate to color changes. The tab also provides 

Stop sequence

Use Docker > Design Properties to view and modify design details prior to design 
approval or stitchout.
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thread usage estimates which may be used for costings as well as production 
requirements.

Data is extracted from the design file and, apart from the Element column, 
cannot be modified. 

The table at the bottom lists all color changes in the design as they will appear 
on the production worksheet. It provides the following details:

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. 
This name appears on the approval sheet or worksheet.

Stitches Indicates total stitch count for design.

Colors Indicates number of thread colors involved in the design.

Colorways Number of colorways in the design.

Colorway Use the droplist to change colorways, if available. When choosing a 
different colorway, the thumbnail and stop sequence list are updated.

Field Description

Stop # The machine stop corresponding to the color change. 

Color Indicates color slot number of the color in color palette.

Edit element names
for each color block

as necessary
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Related topics
 Naming design elements
 Assigning thread colors
 Thread usage estimates
 Modifying thread details
 Setting other general options

Naming design elements

You can view color blocks in the Colorway Editor. Named color blocks are 
known as design ‘elements’. This information is saved with the design and 
printed on production worksheets as an aid for machine operators.

Element User-defined name to identify each color block.

Stitches There is a stitch count for each element in the design. You can show 
this as a discrete stitch count or a cumulative stitch count.

Length Meterage of thread required per color.

Code Color code as registered in the thread chart. 

Name Color name appearing in thread chart.

Chart Brand name of thread chart used.

Thickness A: Normal embroidery thread (approx. denier 40)
B: Thicker than normal (approx. denier 30)
C: Finer than normal (approx. denier 80)
D: Very fine (approx. denier 100)

Field Description

Use Color Palette > Colorway Editor to add or edit colorways.

Use Docker > Design Properties to view and modify design details prior to design 
approval or stitchout.
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To name design elements
 Click the Colorway Editor icon to access the Colorway Editor.

 Select a color and click and hold Locate to view in isolation. Elements 
corresponding to the color are listed below. If there is more than one, select 
and click Locate.

 Double-click the Element field and enter a descriptive name – e.g. ‘Stems’. 
 To check design elements, select Design > Design Properties > Thread 

Colors.

 In the Element fields, edit names for each color block as desired. This 
information can be included on the production worksheet. 

Related topics
 Assigning thread colors
 Viewing color blocks
 Printing design reports
 Customizing design reports

Select color
block

Click and hold to locate 
selected color block

Enter descriptive
name for selected

color block

Edit element
names for each

color block
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Splitting color blocks

A color block corresponds to a color stop in the design. It may comprise a single 
object or group of like-color objects – e.g. ‘ropes and birds’. In one colorway you 
may want to assign the same thread to all items in the color block, while in 
another you may want to assign different colors. The Split Palette Color tool 
makes this possible.

To split a color block
1 Open the design and select a colorway.
2 Open the Colorway Editor.

3 Create a new colorway or select one to edit.
4 Select the object/s you want to split. The Split Palette Color button is 

activated.

Use Color Palette > Colorway Editor to assign thread colors to slots in the color 
palette.

Use Color Palette > Split Palette Color to create a new color slot with the same 
thread specification as the selected slot.

Select colorway 
to edit

Selected object/s 
split to a separate 
color block
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5 Click the Split Palette Color icon. A new color slot of the same color is added 
to the color palette. Selected objects are assigned to the new palette position.

6 Assign a new color to the slot. The colors of other colorways remain 
unaffected. By default, the new color slot is placed at the end of the palette. 
This, however, does not affect the stitching sequence.

Related topics
 Assigning thread colors

Assign a color to 
new color block

Stitching sequence 
unchanged
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Fabric & product backgrounds

EmbroideryStudio lets you set background color, fabric, or product backdrop for 
more realistic previews and presentations. The background is saved with the 
colorway.

Tip  While you can change background colors, fabrics, and even products, this 
does not automatically affect current fabric settings. See Working with fabrics 
for details.

Setting fabric backgrounds

EmbroideryStudio lets you set the colorway background for more realistic 
previews and presentations. These can be included on approval or production 
sheets. Choose from an assortment of swatches, or if you have your own, import 
them into your design. Almost any artwork can be used – photos, magazine 
pictures, clipart images, and even fabric samples. The background is saved with 
the colorway.

Use Color Palette > Background & Display Colors (or Colorway Editor docker) to 
change design background presets for the current colorway.
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To set the background
 Open the design and select a colorway.

 Click Background & Display Colors icon.

 To set a background color, select from the palette in the droplist.
 You can, if you prefer, color only the background inside the hoop, leaving the 

rest of the design window a neutral color.

Preset background
color
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 To set a background fabric, select Factory Fabric.

 Click the Fabric droplist for more options.

Choose fabric
color

Choose a 
background fabric

Select background fabric 
and color as desired
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 Alternatively, to choose a custom swatch, select Custom Fabric and click 
Browse.

 Click OK.

Note  If you change the background in Colorway 1 and save your template, 
it will always display like this at start up.

Related topics
 Adding colorways
 Working with fabrics
 Visualizing products
 Preparing artwork for scanning

Tick Custom to
choose your own

fabric swatch

Click Browse to locate 
custom fabric swatch
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Visualizing products

EmbroideryStudio lets you choose a garment or product backdrop on which to 
position your decoration. Use it to display location, size and overall appearance 
for visualization and approval purposes. These can be included on approval or 
production sheets.

To visualize a product
 Open the design and select a colorway.

Use Color Palette > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle current product display. Right-click for 
Product Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design window.
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 Click the Product Visualizer icon. The docker appears.

 Select a category and click a garment or product to select. The product image 
is centered in the design window at the default scale.

 Optionally, a Custom option allows you to import custom product images. 
These need to be prepared as grayscale images. They need to be correctly 
sized.

 Switch to the Settings tab. This lets you color, size, and position the product 
in the design window.

 Scale the product image as necessary. Scale should be adjusted according to 
actual garment size – XS, S, M, L, XL, or XXL. 

 Optionally, use the Smart Tape function to measure, say, shoulder size 
against the ruler. Adjust the Length field and press Apply to resize the 

Select a 
product folder

Select 
product

Optionally toggle 
product image on/off

If a multi-layer product 
image is selected, 
customize colors for each 
layer

Click to apply 
color
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product image accordingly. Use the Keep proportions setting as 
appropriate.

 Finally, position the design on the product image. Press Ctrl+A to select and 
drag or use arrow keys to nudge.

 Alternatively, position the product image in relation to the design. By default, 
the center is placed at the design origin. The ‘X’ and ‘Y’ fields display 0,0.
 Enter values directly into the ‘X’ and ‘Y’ fields to move the image center to 

the new location.
 Use the nudge control buttons to move the image incrementally.

 To toggle the product background on/off, click the Show Product icon.

Alternatively, enter known 
dimension and click Apply 
to resize product image

Measure garment to
determine real-world size

Scale product image 
as necessary

Position product image 
within the design 
window

Position design
on product image
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 To change colors ‘on-the-fly’, use the Product Visualizer droplist and 
change fabric colors via the Product Color popout menu.

Related topics
 Printing design reports

Change product
color
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Chapter 15

Productivity Tools

Specialized digitizing features help to save digitizing time. EmbroideryStudio 
provides input tools for stars and rings, as well as methods for creating repeated 
or ‘backtracked’ outlines. There are tools for generating outlines based on 
existing shapes. Add decorative borders to designs from a Borders library. 

Adding preset shapes

EmbroideryStudio provides a number of productivity tools for quickly creating 
predefined shapes for use as borders and design objects, both embroidered and 
vector. These tools can be particularly useful for logo design and embroidered 
badge work. 

Adding design borders

Use Toolbox > Add Borders to add borders to designs (or selected objects) with or 
without lettering.
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Add decorative borders such as rectangles, ovals, and shields to designs or 
selected objects using the Borders library.

To add decorative borders to designs
1 Open a design and click the Add Borders icon.

Tip  By selecting individual objects, you can add borders to these rather than 
the entire design.

2 Select a border and adjust Border Width as required. The default is 
3.00 mm.

3 Click OK.
4 Edit borders in the normal way – change thread color, adjust border size, etc.

Tip  By default, borders scale proportionally. To resize proportionally around 
a central anchor point, hold down Shift as you drag. To scale freely in vertical 
and horizontal planes, hold down Ctrl as you drag.

Select border

Click to insert

Adjust border
width



EmbroideryStudio e4 User Manual 297

Digitizing stars & rings

The Traditional Digitizing toolbar provides special time-saving tools for 
creating embroidered rings and stars or ‘French dots’. 

Stars
Digitize circles and ovals which use turning zigzag stitches to create a ‘Star’ or 
‘French dot’ using the Star tool.

To digitize stars, click to mark the center and click again to set the radius. This 
point becomes the entry point. To create an oval star, mark a second radius 
point, then press Enter.

Rings
Create rings by digitizing circles and ovals within each other using the Ring tool. 
Use different combinations of inner and outer boundary shapes to create 
different effects.

Use Traditional Digitizing > Star to digitize star shapes filled with Zigzag stitching.

Use Traditional Digitizing > Ring to digitize circle and oval-shaped rings.

Center

Reference point

1

2
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To digitize rings, digitize the inner boundary of the ring first either as a circle or 
an oval. Digitize the outer boundary of the ring in the same way and press Enter.

You can digitize rings with a variety of fill stitch types. Contour stitch is well 
suited to rings, as it runs stitches around the ring in a spiral pattern.

Related topics
 Reshaping stars & rings

Digitizing basic shapes

The Graphics Digitizing toolbar provides a dedicated Basic Shapes tool which 
allows you to quickly create design objects from a library of preset shapes. 
These can be created as vector objects, or you can apply the full range of outline 
and fill stitch types. These can be useful when creating logo designs or 
embroidered badges. Available shapes are exactly the same as for preset 

center

Reference point

Reference 
point

Reference point

1

2

3

4

Use Graphics Digitizing > Basic Shapes to digitize basic shapes. Press <Ctrl> to 
maintain aspect ratio. Press <Shift> to center at the first point.
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borders. Use Ctrl and Shift keys, alone or in combination, to maintain aspect 
ratio and center point.

Related topics
 Reshaping embroidery objects

Removing underlying stitching

Use the Remove Overlaps command to remove underlying stitching in 
overlapping objects. This helps to reduce stitch count and prevent a build-up of 
stitches.

Click to insert

Use Appliqué > Remove Overlaps to remove underlying layer of stitching in 
overlapping objects using the selected object as a ‘cutter’. Right-click for settings.
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To remove underlying stitching
 Select one or more ‘cutters’.

 Click the Remove Overlaps icon. Underlying stitching is removed using 
default settings. Alternatively, select Arrange > Remove Overlaps to 
access settings or right-click the tool.

 In the Cutters panel, adjust minimum object width and maximum stitch 
spacing as desired.
These settings are useful if, for example, you choose an entire design as a 
cutter and wish to exclude objects, such as borders or details, less than a 
certain width. The Maximum Stitch Spacing setting allows you to exclude 
background stitches of a certain density.

 Select Accordion Allowed to include Accordion Spacing objects. By default, 
the software treats these objects as backgrounds and excludes them from the 
cutting operation.

 Enter the amount of overlap required in the Cutting Overlaps field.

Select cutters

Set ‘cutter’ values

Enter amount of overlap

Enter size of smallest 
permissible object

Specify cutting overlap 
– e.g. 2.0mm
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 In the Minimum Fragments field, enter the size of the smallest object that 
will be produced after cutting. This eliminates the generation of small objects 
and unnecessary color changes.

 Click OK. Underlaying stitching is removed.

Tip  You can use an entire design as a cutter excluding objects, such as 
borders or details, less than a certain width.

Related topics
 Creating partial cover appliqué

Adding & filling holes

EmbroideryStudio provides special tools for cutting holes in objects as well as 
filling holes in objects.

Adding & removing holes

With EmbroideryStudio you can cut holes in selected closed objects with a single 
stitch angle using the Add Holes tool. The complementary No Holes tool allows 
you to remove unwanted holes in closed objects.

To add or remove holes
 Select the object to modify.
 Click the Add Holes icon. Reference points display around the object outline.

Use Graphics Digitizing > Hole Tools > Add Holes to cut holes in filled objects.

Use Graphics Digitizing > Hole Tools > No Holes to remove holes from selected 
objects.
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 Digitize additional boundaries for the object. Press Enter after each 
boundary.

 Press Enter.
 Optionally, add turning stitch angles to the object.

Note  To remove all internal boundaries from a closed object, select it and 
click No Holes.

Related topics
 Adding holes to free-form shapes
 Removing underlying stitching
 Adjusting stitch angles

Filling holes

Create new objects with the Fill Holes feature. This lets you fill holes formed by 
existing boundaries, without having to re-digitize the shape.

Use Graphics Digitizing > Hole Tools > Fill Holes to fill holes formed by existing 
boundaries, without having to re-digitize the shape – choose to fill the hole exactly 
or offset it.
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To fill holes
1 Select a source object and click the Fill Holes icon.

2 Enter an underlap value.

 To cover holes exactly, accept the default value of 0.00.
 To leave a gap between the filled holes and the original object, enter a 

negative underlap – e.g. -1.00.
 To overlap the filled holes and the original object, enter a positive underlap 

– e.g. 1.00.
3 Click OK. All newly created objects are filled with the current fill stitch 

settings, stitch angle and thread color. Each new object is an independent 
object and is placed immediately after the source object in the stitch 
sequence.

Generating outlines & offsets

EmbroideryStudio provides tools for quickly generating outlines and filled areas 
based on existing boundaries. The Outlines & Offsets feature creates outlines 
and offset objects from closed objects with both fixed and variable spacings.

Simple offsets

Enter required 
underlap

Underlap: 0.00 Underlap: 1.00Underlap: -1.00Source object

Use Toolbox > Simple Offsets to create simple outlines for any filled embroidery or 
closed vector object.
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When available, the Simple Offsets feature allows you to quickly create outline 
stitching around selected objects or entire designs with a variety of outline 
styles.

To create outlines and borders
1 Select a source object/s and click the Simple Offsets icon.

2 Adjust the settings as required:

3 Click OK to apply settings. The design outline is stitched in the current palette 
color using current properties. Change settings as required.

Field Description

Spacing Set an outline offset in mm. This may be zero or even a negative 
value.

Number of offsets Specify multiple outlines – up to 99.

Object type Choice of outline object types: Run, Triple Run or Column C.

Offsets for holes Option to exclude or include outlines for any holes in the selected 
object.

Choose offset object 
type
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Tip  You can use Simple Offsets to create outlines around entire designs, 
including lettering.

Creating outlines & offsets

Use the Outlines & Offsets tool to add outline stitching to selected objects or 
entire designs with a complete range of outline styles. Any closed shape can be 
used, including vector objects, runs, or any filled shapes.

Outlines
The Outlines & Offsets dialog divides into two panels for outlines and offsets. 
Use the outlines panel to generate outlines around single or multiple selected 
objects. The droplist includes the full range of outline stitch types. For each 
selected object, the software generates outlines and inserts them immediately 
after in the stitching sequence.

The Overlapping Method determines how outlines will overlap:

Use Toolbox > Outlines & Offsets to create outlines and offsets of any type for any 
filled embroidery or closed vector object.

Overlap method

Individual All generated outlines are full outlines.

Generate outline objects
around single or multiple

selects
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Offsets
The offsets panel allows you to generate single or multiple offsets in any 
combination of styles, colors, and spacings. Any closed shapes can be used, 
including vector objects, runs, or any filled shapes. You have the option of 
preserving source objects.

 Tick Create offsets and define an offset pattern in the Offset Pattern 
panel. Each row defines a single offset. For each, specify an object type – e.g. 
Run – a spacing in millimeters – e.g. 1mm – and a color. Remember that each 
spacing is calculated from the previous object.

 Use the + buttons to add offsets to a pattern. Use the Lock icons to lock 
settings in place. 

Common Intersecting outlines are combined into a single outline.

Trimmed Overlapped portions are trimmed by overlapping objects.

Overlap method

Define offset
pattern

Specify number of
patterns

Use icons to lock 
settings in place
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 Specify pattern repeats in the Number of patterns field. Adjust spacing 
between pattern repeats in the Pattern spacing field.

 Tick the Create offsets for holes checkbox as appropriate.

 Use the Overlapping method options to determine offsets for multiple 
selections.
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 Tick the Join offsets into spiral checkbox to create a continuous spiral 
around the source object.

 Select rounded or squared corners as preferred. The squared option allows 
you to adjust the angle limit – first select Cut Sharp Corners and set 
required angle value.

 Adjust the Approximation setting as required. This controls the smoothness 
of the generated object outline – the larger the value, the more approximate 
the curve. If the value is set to zero, the generated outline is unsmoothed. 
This is suitable for use with cutting machines.

Note  By default, source objects are preserved. If you choose not to, the offset 
object replaces the original in the same position in the stitching order. Start and 
end points of the resultant object will be as close as possible to those of the 
source object.

Creating negative offsets

Squared
Angle limit: 30°

RoundedSquared
Angle limit: 20°

Squared

Approximation: 0.3 mmApproximation: 0 mm Approximation: 0.6 mm

Use Toolbox > Outlines & Offsets to create outlines and offsets of any type for any 
filled embroidery or closed vector object.
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The Outlines & Offsets tool allows you to specify both negative and positive 
offsets.

To create negative offsets
1 Select a source object/s and click the Outlines & Offsets icon.

 Tick Create offsets and define a simple offset object in the Offset Pattern 
panel.

 Set the required offset in millimeters:
 To center the offset object over the original, enter a value of 0.00.
 To position the offset object outside the original, enter a positive offset – 

e.g. 1.00.
 To position the offset object inside the original, enter a negative offset – 

e.g. -1.00.

 If you want multiple offsets, enter a value in the Number of patterns field.

Set negative
spacing

Specify number of
patterns

Zero Offset Negative Offset Positive Offset 
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 Select Pattern spacing and enter the required offset in millimeters. Offsets 
are always offset in a positive direction, even if you have entered a negative 
number. Spacing is calculated from the previous object, not the source object.

Note  As an alternative to the above technique, you can define your negative 
offsets entirely as a single offset pattern. Note how you set up the spacings.

Creating offsets with open objects

Offset spacing: -1.5mm
Number of patterns: 3
Pattern spacing: 3mm

Offset spacing: 0mm
Number of patterns: 3
Pattern spacing: 1.5mm

Offset spacing: 1.5mm
Number of patterns: 3
Pattern spacing: 0mm

Define offset
pattern

Set number
patterns to 1

Use Toolbox > Open Offsets to create precise offsets for any open embroidery or 
vector object.

Use Toolbox > Outlines & Offsets to create closed offsets for open embroidery or 
vector objects.
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The Open Offsets tool allows you to generate parallel offsets from any open 
shape. Offset lines are calculated at a specified distance for a specified number, 
one side or other side, or both sides.

You can use the Outlines & Offsets tool with open objects to create closed 
offsets as shown. Select rounded or squared corners as preferred. The squared 
option allows you to adjust the angle limit – first select Cut Sharp Corners and 
set required angle value.

Define offset
pattern
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Mirroring & reflecting selections

The Mirror Merge tools allow you to duplicate and transform selected objects, 
as well as merge them into a single object. Use them to create wreaths or 
decorative borders. Or use them to create perfectly symmetrical objects. 

Mirroring selections horizontally & vertically

Use the Mirror Copy Horizontal and Vertical tools to duplicate and mirror 
selections simultaneously. Simply select objects and click a tool to duplicate and 
mirror in any plane. Click to mark the reflection point and press Enter to 
confirm.

The Mirror Merge tools can also be used, as the name suggests, to merge 
mirrored objects into a single object. If duplicates overlap the original, you are 

Use Mirror Merge Tools > Mirror Copy Horizontal to duplicate and mirror objects or 
designs in the horizontal plane.

Use Mirror Merge Tools > Mirror Copy Vertical to duplicate and mirror objects or 
designs in the vertical plane.

Use Mirror Merge Tools > Mirror Copy Horizontal & Vertical to duplicate and mirror 
objects or designs simultaneously in both planes.
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prompted to merge objects. Use this feature to merge duplicates into a perfectly 
symmetrical object such as a face or heart.

Creating multiple reflections

Use the Reflect tool to duplicate and mirror designs simultaneously. Set any 
number of rows or columns. The feature is often used in making fashion or 
textile designs. The limit for allowable wreath points is 100.

To create reflected objects
1 Select the object or design.
2 Click the Reflect icon. The ancillary Mirror Merge Settings toolbar appears.
3 Move the pointer to position duplicates.

Tip  Press Shift to disable Auto-Scroll while using Mirror Merge.
4 Adjust the number of columns and rows required in the settings toolbar. Tab 

from field to field to enter values. 
5 For more precise positioning, adjust spacing settings. Press Enter to confirm.

Reflected objects mergedObject reflected Source object 

Use Mirror Merge Tools > Reflect to duplicate and mirror objects or designs.

Set no. of columns Set no. of rows

Set precise column and row spacings
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6 Click to mark the reflection point and press Enter to confirm.

Related topics
 Duplicating & cloning objects

Creating wreaths

Use the Wreath tool to duplicate objects around a center point. The 
Kaleidoscope toggle mirrors the selection as well.

Use Mirror Merge Tools > Wreath to duplicate objects around a center point.

Use Mirror Merge Tools > Kaleidoscope to mirror paired objects in a wreath.
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To create wreaths
1 Select the object or design.
2 Click the Wreath icon. The ancillary Mirror Merge Settings toolbar 

appears.
3 Move the pointer. Optionally, click the Kaleidoscope toggle to mirror 

duplicates.
4 Enter the number of wreath points. Because objects are mirrored, 

Kaleidoscope works best with an even number.

5 Move the pointer to position duplicates. Hold down Ctrl to constrain the 
reference line to 45° increments.

6 For more precise positioning, adjust Distance and Angle settings. Tab from 
field to field to enter values. Press Enter to confirm.

Note  Distance and angle are measured from the center of the source to the 
center of the wreath or kaleidoscope. 

7 Click to mark the reflection point and press Enter to confirm. The selection 
is duplicated and distributed around the center point.

Note  If the duplicates overlap the original, you are prompted to merge 
objects.

Enter no. of wreath points

Click toggle to
mirror duplicates

Set precise angleSet precise distance

Five-point wreath 

Six-point kaleidoscope
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Creating design arrays

Use the Array tool to create multiple copies of designs, such as badges, spaced 
in rows and columns for faster stitchouts. Color blocks are resequenced to 
eliminate unnecessary color changes.

To create design arrays
1 Select the object or design.
2 Click the Array icon. The ancillary Mirror Merge Settings toolbar appears. 

As you move the pointer, duplicate outlines move accordingly. Press Shift to 
disable Auto-Scroll while using Mirror Merge.

3 Set the number of columns and rows. Tab from field to field to enter values.

4 Move the pointer to position duplicates.

Use Mirror Merge Tools > Array to duplicate designs, such as badges, 
re-sequencing color blocks for efficient multiple design stitchouts.

Set no. of columns Set no. of rows

Set precise column and row spacings
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5 Click to mark the anchor point or press Enter to confirm.

6 Optionally, for more precise positioning, adjust spacing settings. Press Enter 
to confirm.

Color blocks resequenced
to eliminate unnecessary

color changes
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PART IV

STITCH QUALITY

EmbroideryStudio provides many settings to ensure high quality stitchout on 
any fabric. For instance, to sew out correctly, an object must have correct stitch 
spacing, sufficient pull compensation together with a suitable underlay for the 
combination of cover stitch type, object type, object shape and fabric. Auto 
Fabric provides a set of customized fabric settings so the software will take into 
account the type of fabric you are stitching on. However, you can override these 
on an object-by-object basis as necessary. See also Working with fabrics.

Underlays & pull compensation
This section describes how to set and adjust automatic underlays. It also deals 
compensating for fabric stretch with automatic pull compensation. See Underlay 
& Pull Compensation for details.

Optimizing stitch quality
This section describes how to adjust stitch density as well as eliminate small 
stitches. It also explains controlling corner stitching and reducing stitch 
bunching. Optimizing long satin stitches is also covered. See Optimizing Stitch 
Quality for details.

Embroidery connectors
This section describes how to add connectors, tie-offs and trims to your designs. 
It also describes adjusting settings for automatic connectors, including the stitch 
length for travel runs. It also deals with setting automatic start and end points. 
See Embroidery Connectors for details.
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Chapter 16

Underlay & Pull Compensation

Embroidery stitches pull fabric inward where needles penetrate. This can cause 
fabric to pucker, stitch bunching, and/or unsightly gaps to appear in the 
embroidery. EmbroideryStudio includes many techniques for achieving smooth, 
even placement of stitches, and the elimination of gaps in designs.

For an object to sew out correctly, it must have correct stitch spacing, sufficient 
pull compensation, together with a suitable underlay for the particular 
combination of cover stitch type, object type, object shape, and fabric. 

Note  EmbroideryStudio provides a set of optimized fabric settings that take into 
account the type of fabric you are stitching on. These settings are all object 
properties, some of which are entirely automated and some which you have 
control over. See Object Properties for details.

Stabilizing with automatic underlay

Embroidery appearance and quality depends a lot on underlay which serves as 
a foundation for the cover stitching. Without an underlay, embroidery lies flat on 
the underlying fabric which can often show through. New digitizers might be 
tempted to increase stitch density but it is much more effective to apply an 
automatic underlay. Although it increases the stitch count, underlay helps to 
stabilize fabrics and reduce puckering and pulling especially on larger designs. 
It also provides ‘loft’, raising cover stitches and preventing them from sinking 
into soft fabrics. It can also prepare a napped fabric by flattening it.

Underlay types

Different underlays suit different shapes and different fabrics. Larger areas and 
stretchy fabrics such as knits and pique generally need more underlay than 
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smaller areas and firm fabrics such as drill or leather. Smaller objects may use 
a single layer of underlay. Larger objects may combine two layers.

Underlay settings are stored with each object the same way as other object 
properties. They are regenerated whenever the object is scaled or transformed. 
They are stored separately from, and do not affect, cover stitch settings.

Default underlay values
Default underlay values are derived from three possible sources:
 When Auto Fabric is turned on, a default underlay is applied, based on 

current fabric settings.
 When Auto Fabric is turned off and the ‘use preset styles’ option is turned 

on, style definitions are used. See Digitizing tools for details.
 When Auto Fabric is turned off and the ‘use preset styles’ option is turned 

off, template values are used. See Working with templates for details.

Related topics
 Digitizing tools
 Working with fabrics
 Working with object properties
 Setting lettering underlay

Applying automatic underlay

EmbroideryStudio provides a wide selection of underlay types to choose from. 
Use a single layer of underlay, or for more support, combine two underlay types. 
The underlay you choose is determined by the shape and size of object, fabric 
type, and purpose it is to serve. EmbroideryStudio lets you set values to suit 
different fabrics, lettering appearance and size.

To apply automatic underlay
 Toggle automatic underlay on/off via the Auto Underlay button.
 Without objects selected, right-click the Auto Underlay icon to change 

current settings.

Use Stitch Effects > Auto Underlay to strengthen and stabilize embroidery designs 
with automatic underlays. Right-click for settings.
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 With objects selected, right-click the Auto Underlay icon to change settings 
for those objects.

 For a single underlay, tick the First Underlay checkbox and choose an 
underlay type from the droplist.

 For a double-underlay, tick the Second Underlay checkbox and choose a 
second underlay type.

Related topics
 Working with fabrics
 Working with object properties
 Setting lettering underlay

Select 1st
underlay

Select 1st
underlay type

Adjust 1st
underlay settings

Select 2nd
underlay type

Adjust 2nd
underlay settings

Adjust 2nd
underlay marginsAdjust 1st

underlay margins

Select 2nd
underlay

First underlay: Edge Run
(Column B object)

First underlay: Edge Run
(Complex Fill object)

First underlay: Edge Run
(Complex Turning object)

2nd underlay: Zigzag 2nd underlay: Tatami 2nd underlay: Double Zigzag
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Underlay by segment or by shape

Free shapes generally stitch out in several segments, joined by travel runs. 
However, all segments and boundaries are part of the same object. With the 
exception of lettering objects, underlay is normally applied 
segment-by-segment before any cover stitches are sewn. 

‘By shape’ underlay is applied to lettering objects by default. However, it can also 
be applied to objects such as Complex Turning as well as branched objects. This 
has the effect of calculating an underlay for the whole shape rather than each 
segment. This in turn reduces bunching, travel runs, and overall stitch count. 
Depending on the size of object, however, registration issues may come into 
play.

Underlay margins

The underlay margin is the distance between an object outline and the edge of 
the underlay. Increase this margin to prevent underlay stitches from extending 
outside the cover stitches.

 For Column A, Column B, Column C and Lettering objects, enter margins in 
the 1:, 2: and 3: fields, using the diagram as a guide.

Branched Complex
Turning with Edge +

Center Run underlay ‘by
shape’

Branched Complex 
Turning with Edge + 
Center Run underlay ‘by 
segment’

Stitch count: 1060

Stitch count: 957

Right-click Stitch Effects > Auto Underlay to adjust underlay margins.

Adjust margins to prevent 
underlay stitches from 
extending to far
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 For Complex Fill objects, enter a margin in the 1: field only. Values in the 
other fields will be ignored.

 If you are joining two columns, use a negative value at the joining end. The 
underlay will extend outside the cover stitching, allowing for smooth joining 
of the columns.

Run stitch underlay settings

Center Run places a row of stitches along the center of a column. It is used to 
stabilize narrow columns – e.g. 2-3 mm wide. Edge Run places stitches around 
the edge of an object. Use Edge Run together with the zigzag or tatami 
underlays when digitizing large shapes.

 Enter a stitch length for each underlay type. The samples below show the 
difference between fixed and variable run lengths.

Mgn 1: 0.8 mm, Mgn 2: 0.2 mm,
Mgn 3: 0.4 mm

All margins: 0.1 mm

Two columns joined

Right-click Stitch Effects > Auto Underlay to adjust Center Run and Edge Run 
underlay settings.

Center Run and Edge Run
underlays used together

Edge Run and Center Run underlay 
with 2.5 mm stitch length

Edge Run and Center Run underlay 
with variable run length
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 Adjust stitch length to ensure underlay stitches follow curves and are not 
visible in the final embroidery.

Related topics
 Adjusting column width

Tatami underlay settings

Tatami underlay is used to stabilize large, filled shapes. It resembles an 
extremely open tatami fill stitch, where rows of stitches are placed across the 
object to create the underlay. Tatami underlay is often used together with Edge 
Run, especially for Complex Fill objects under tatami cover stitching.

 Adjust stitch spacing and length settings for tatami underlay in the same way 
as for tatami fill stitches.

Field Purpose

Length Sets the maximum length of each stitch.

Vary run length If enabled, specify minimum stitch length and chord gap values. The 
chord gap is the distance between digitized curve and underlay 
stitch. This determines how closely stitches follow digitized lines.

Right-click Stitch Effects > Auto Underlay to adjust tatami underlay settings.

Tatami stitch with Edge Run
& Tatami underlay

Direction of cover 
stitching

Direction of 
underlay

Spacing: 2mm

Spacing: 3mm
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 Select the backstitch type you require and, for Complex Fill objects, set the 
stitch angle of the underlay stitches. Underlay stitch angle should run counter 
to cover stitching.

 For extra support with very soft or elastic fabrics, try using Double Tatami 
in combination with Edge Run. Adjust stitch angle so that Double Tatami 
provides symmetrical slanting in forward and backward directions. This 
should result in a ‘cross-hatch’ effect. In addition, it can give a raised surface 
similar to ‘puff embroidery’.

Tip  Increase the margin as necessary to prevent underlay stitches from 
extending outside the cover stitches. 

Related topics
 Tatami density
 Other tatami settings
 Setting Object Property apply options
 Underlay margins

Zigzag underlay settings

Use Zigzag and Double Zigzag underlay stitching to support wide columns. 
You can combine Zigzag or Double Zigzag with Center Run or Edge Run 
underlays. These underlays are best used under Satin cover stitching.

Angle: 135º 

Angle: 45º

Tatami stitch with Edge Run
& Double Tatami underlay

Adjust angle for slanted 
double tatami underlay

Right-click Stitch Effects > Auto Underlay to adjust Zigzag and Double Zigzag 
underlay settings. 
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Adjust the required spacing and length for each underlay type.

EmbroideryStudio allows you to slant Zigzag underlay to create what is 
sometimes called ‘stemstitch underlay’. This can be applied to Column A, B, C, 
and lettering objects.

Normal zigzag underlay runs in a similar direction to satin cover stitching 
causing it to ‘sink’. Double Zigzag provides symmetrical slanting in forward and 
backward directions resulting in a ‘cross-hatch’ effect. This may provide more 
support than single zigzag. In addition, it can give a raised effect similar to ‘puff 
embroidery’.

Double Zigzag too can be slanted to create even more loft.

Caution  When using very small angles for slanted underlays, they can extend 
outside object boundaries.

Related topics
 Adjusting column width
 Underlay margins
 Setting lettering underlay

Spacing: 3.0 mm Spacing: 4.0 mm

Zigzag underlay

Slanted zigzag 
underlay

Adjust angle for slanted 
zigzag underlay

Zigzag underlay
Angle: 45°

Spacing: 3mm

Zigzag underlay
Angle: 45°

Spacing: 1mm

Double-zigzag 
underlay

Slanted double-zigzag 
underlay
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 Open fills & borders

Compensating for fabric stretch

Embroidery stitches tend to pull fabric inwards where the needle penetrates. 
This can cause fabric to pucker and gaps to appear in the embroidery. 
Experienced digitizers can manually compensate for pull by overlapping objects 
as they digitize. Automatic pull compensation, however, counters the pull effect 
by ‘overstitching’ outlines of filled shapes on the sides where the needle 
penetrates.

Adjust overstitching by varying pull compensation in the Object Properties 
docker. This is handy if you want to stitch a design on fabrics with varying 
degrees of stretch. 

Tip  Applying underlay stitching, and using appropriate backing and topping 
when stitching out can also reduce the push-pull effect.

Applying automatic pull compensation

Apply automatic pull compensation to objects in your design and adjust as part 
of your quality checks prior to stitchout.

To apply automatic pull compensation
 Toggle automatic pull compensation on/off via the Pull Compensation 

button.
 Without objects selected, right-click the Pull Compensation icon to change 

current settings.
 With objects selected, right-click the Pull Compensation icon to change 

settings for those objects.

Pull compensation

Digitized outline

Calculated outline

Use Stitch Effects > Pull Compensation to automatically compensate for fabric 
stretch. Right-click for settings.

Select Pull Compensation 
and enter an overstitch 
allowance
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 Enter an overstitch allowance (in millimeters).

Appropriate pull compensation settings vary with the type of fabric – stretchy, 
pile, etc – hooping method – tight or loosely hooped – and size of embroidery 
object – wide or narrow columns. Use the following table as a guideline.

Related topics
 Working with fabrics
 Working with object properties

Adjusting column width

The Column Width setting adjusts the width of columnar shapes, allowing you 
to change the column width at every point by a constant amount in the direction 
of stitching. The purpose is to ‘fatten’ or ‘thin’ a column, for example, in order 
to create ‘bold’ lettering. See also Formatting lettering.

Tip  Reduce column width if you need to allow the underlay to extend outside 
the object boundary.

To adjust column width
 Right-click the Pull Compensation icon to access object properties.

Pull Compensation: 0.3 mm Pull Compensation: 0.6 mmPull Compensation: 0.0 mm

Fabric Pull compensation (mm)

drills, cotton 0.20

T-shirt 0.35

fleece, jumper 0.40

lettering 0.2 - 0.3

Right-click Stitch Effects > Pull Compensation to adjust column width setting.

Select Column Width and 
enter column width 
adjustment
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 Select the Column Width checkbox and adjust as necessary.

Column width: -1 No adjustment Column width: +1
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Chapter 17

Optimizing Stitch Quality

When it comes to embroidery production, the current stitch density may not be 
perfect for certain fabrics or threads. Or you may want to make production 
cheaper by reducing overall stitch count. After scaling operations, for example, 
designs may contain small stitches which can damage fabric and cause thread 
or needle breakage. Sharp corners may cause stitch bunching which can create 
hard spots in the embroidery and damage fabric or needle.

Embroidery machines have a maximum possible stitch length which is 
determined by the physical frame movement. If long satin stitches exceed this, 
they are broken into smaller stitches.
EmbroideryStudio helps you resolve all these issues with a number of specialized 
techniques for optimizing stitching quality for different design types and 
production requirements.

Controlling stitch direction

Sometimes you need to control stitching direction in order to minimize trims, 
push-pull effect, improve stitching efficiency, and/or reinforce outlines. 
Backtrack and Repeat allow you to reinforce outlines while specifying stitching 
direction. The Reverse Curves command allows you to reverse stitching 
direction without duplication.

Reversing stitch direction

Stitching direction can affect embroidery quality because of the push-pull effect. 
The Reverse Curves command lets you control the push-pull effect by 
reversing stitch direction. It can be applied to open as well as closed outline 

Use Edit > Reverse Curves to reverse stitch direction in vector or closed embroidery 
objects.
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objects. To reverse stitch direction, select an object and apply Edit > Reverse 
Curves. The command is also available from the popup (right-click) menu.

Reverse Curves can be applied to Run, E Stitch, Column C, Motif Run, and 
Sequin Run. It can also affect the stitching direction of Jagged Edge, Contour 
Stitch, Tatami offsets, and Flexi Split patterns.

Tip  Vector objects too can be reversed. The effect on vector objects is only 
visible when they are converted to embroidery.

Reinforcing outlines

Use Backtrack and Repeat to reinforce outlines. Backtrack stitches in reverse 
direction to the original. It is typically used to make run stitch outlines thicker 
without creating unwanted connecting stitches. Repeat duplicates the original 
stitching direction and is typically used with closed shapes.

To reinforce outlines
1 Select the outline (or outlines) to reinforce.
2 Click the Backtrack or Repeat icon as required:
 Backtrack for open shapes
 Repeat for closed shapes.
The object is duplicated and placed over the original. It is positioned after the 
original in the stitching sequence.

3 Check that the object has been duplicated by using one of the following 
methods:
 Check the stitch count in the Status Bar.
 Use Stitch Player. 
 Travel through the stitches. 

Reverse Curve
applied

Column C object with 
Jagged Edge

Use Traditional Digitizing > Backtrack to reinforce an outline, stitching it in the 
reverse direction to the original.

Use Traditional Digitizing > Repeat to duplicate an outline in the same direction – 
typically used with closed shapes.

Backtrack for open 
shapes

Repeat for closed 
shapes
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Note  If you use Repeat for open shapes, a connecting stitch is inserted from 
the end to the start of the next object which will require trimming.

Related topics
 Simulate design stitchouts
 Viewing stitching sequence

Adjusting stitch angles

Stitch angle adjustments depend on object type. With Complex Fill objects you 
can set a single stitch angle for the entire object. You can add multiple stitch 
angles with the Stitch Angles tool. You can also adjust stitch angles with the 
Reshape Object tool.

Adding stitch angles in Stitch Angles mode

Add stitch angles to most embroidery objects interactively using the Stitch 
Angles tool. Create embroidery objects by adding stitch angles directly to 
vector objects.

Use Graphics Digitizing > Stitch Angles to add stitch angles to selected objects.

Use Graphics Digitizing > Remove Stitch Angles to remove stitch angles from 
closed objects with turning stitches.

Complex Fill object – one 
stitch angle

Complex Fill converted
to Complex Turning
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To add stitch angles in Stitch Angles mode
1 Select an object and click Stitch Angles.

2 Digitize stitch angles so that they intersect two sides of the object. 
3 Press Enter. The object is displayed in Reshape mode. 
4 Holding down the Ctrl key, click the outline wherever you want to place an 

additional stitch angle.

Note  To remove all except the default stitch angle, select the object and click 
Remove Stitch Angles.

Adding stitch angles in Reshape mode

Adjust or add stitch angles to embroidery objects interactively using the 
Reshape Object tool.

To add stitch angles in Reshape mode
1 Select the object.

Complex Fill object Stitch angles added

Column A object Column B object

Use Reshape Tools > Reshape Object to add stitch angles to selected objects.

Use Reshape Views > Show Stitch Angles to toggle stitch angle display when using 
the Reshape Object tool.
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2 Click the Reshape Object icon and click Show Stitch Angles to view only 
these control points.

3 Click-and-drag stitch angle points to adjust.

Tip  Column A objects automatically convert to Column B as soon as you add 
or adjust a stitch angle. You cannot add stitch angles to Complex Fill objects 
in Reshape mode.

4 Holding down the Ctrl key, click the outline wherever you want to place an 
additional stitch angle.

5 Press Enter.

Related topics
 Converting objects

Adjusting stitch densities

You may need to change stitch density in order to stitch on a different fabric or 
with a different thread. Or you may want to make production cheaper by 
reducing the overall stitch count. The Process Stitches feature lets you change 
the density of all stitch types (except manual stitch) across the whole or selected 
parts of a design. It also lets you adjust the density of selected stitch types. You 
can even use the feature to scale a design.

To adjust overall stitch density
 Select the design or objects you want to process.

Column A object Column B object

Column A object Column B object

Use Stitch > Process Stitches to adjust stitch density of and/or scale the whole or 
selected parts of a design.
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 Click Process Stitches icon.

 In the Stitch Values panel:
 Enter Target Stitches either as a percentage or absolute value. This 

automatically adjusts density of each stitch type required to achieve the 
target stitch count.

 Optionally, adjust density for each stitch type. You can select spacing or 
length as a percentage of the original – from 10% to 1000% – or as an 
absolute value – e.g. in millimeters. If you do not want to change the 
density of a certain stitch type, leave it as 100%.

 Select the checkbox if you want to use Auto Spacing for satin stitching. If 
the checkbox is cleared, Auto Spacing will be removed from all selected 
satin objects and will change to fixed spacing. If the checkbox is dimmed, 
original Auto Spacing values are retained. 

 In the Pull Compensation field, enter an amount by which to overstitch (or 
understitch) in order to compensate for fabric pull.

 In the Dimensions panel, adjust Width and Height values to scale selected 
objects.

 Click OK to apply. Stitches for Tatami, Satin, Run, Zigzag, and Program Split 
objects are regenerated.

Note  If a design was originally created in EmbroideryStudio, or was 
converted into objects, changes you make through the Process Stitches 

Adjust Pull
Compensation

Adjust stitch
densities

Select Auto
Spacing

Enter target
stitch count

Adjust width and
height settings to

scale

100%: 5195 stitches 20%: 987 stitches

Program Split
Tatami stitches

Tatami stitch spacing reduced 
(density increased)
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dialog will change properties of selected objects. You can check changes via 
the Object Properties docker.

Related topics
 Satin stitching
 Working with fabrics
 Compensating for fabric stretch
 Scaling objects numerically

Eliminating small stitches

Small stitches can damage fabric and cause thread or needle breakage. Before 
you stitch out, unwanted small stitches can be automatically removed. The filter 
can be applied continuously, on output only, or never.

To eliminate small stitches
 Select Design > Remove Small Stitches.

 Choose your preferred option:
 When set to ‘Always’, the filter will be automatically applied in the 

background whenever objects are edited or digitized. 
 When set to ‘On Output’, the filter is only applied when printing or 

outputting  files.
 Enter the minimum stitch length you want to preserve.
 Click OK to confirm.
 Check the Status Bar for the new stitch count.

Related topics
 Setting other general options

Controlling corner stitching

The quality and style of corners is important in borders and appliqué, and satin 
column sewing in general. Sharp corners may cause stitch bunching which can 
create hard spots in the embroidery and may damage fabric or needle. The 
Smart Corners feature helps you control sharp corners in Column A and 
Column C objects.

Enter minimum stitch 
length to keep
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Corner handling methods

The following approaches can apply to both appliqué and standard satin 
(Column C) columns.

Corner rounding
A Round Sharp Corners option is available for Column C objects which can 
also be applied to sharp corners. The option is only available in conjunction with 
the Smart Corners effect. It is typically used with the Cap Corner option.

Method Sample Outline Description

No corner Stitches curve around 
corners – standard 
Column C corner 
handling.

Mitre 
corner

Corners are formed by 
two segments that join 
in a sharp point.

Cap 
corner

Corner is capped by an 
extra segment – cap 
stitching remains 
parallel to the column.

Lap corner Corner broken into two 
segments.

Method Sample Outline Description

Rounded 
corner

Corner is sewn in one 
segment, with turning 
stitching, forming a 
round corner on the 
outer boundary.
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Applying Smart Corners

Use the Smart Corners feature to reduce the number of stitches and risk of 
bunched, distorted embroidery in sharp corners. Mitre Corners creates a sharp 
line at the intersection of two columns. Use it primarily for corner angles of 20° 
to 45°. Cap Corners is suitable for very sharp corners as it generates fewer 
stitches. Lap Corners is suitable for ‘Tidori’ style stitching. It can be applied to 
Column C and appliqué objects. 

To apply Smart Corners
 Click a Smart Corners icon with or without objects selected. With no objects 

selected, smart corners are automatically generated for all new objects. 
Corners are based on current properties. 

 Click again to turn off the effect.

Note  You can also combine Smart Corners in Column C objects with sharp 
corner rounding. 

Related topics
 Appliqué Digitizing
 Adjusting smart corner settings
 Rounding sharp corners

Rounded 
cap corner

The corner is sewn in 
three segments forming 
a round corner on the 
outside boundary.

Method Sample Outline Description

Use Stitch Effects > Mitre Corners to create sharp lines at intersections of two 
columns. Right-click to adjust settings.

Use Stitch Effects > Cap Corners with very sharp corners to generate fewer 
stitches. Right-click to adjust settings.

Use Stitch Effects > Lap Corners for ‘Tidori’ style stitching. Right-click to adjust 
settings.

Mitre corners Cap cornersLap corners
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Adjusting smart corner settings

You can set different angles at which Smart Corners will be applied, and specify 
overlap and stitch length allowances. Right-click a Smart Corners icon to 
access object properties.

Cap corners
Cap provides the following settings:
 Cap below: angle below which to apply capped corners – any corners greater 

than this are not capped. The default is cap below 20°.

Tip  If Mitre Corners is also selected, the cap angle is usually smaller than 
the mitre angle.

Use Stitch Effects > Mitre Corners to create sharp lines at intersections of two 
columns. Right-click to adjust settings.

Use Stitch Effects > Cap Corners with very sharp corners to generate fewer 
stitches. Right-click to adjust settings.

Use Stitch Effects > Lap Corners for ‘Tidori’ style stitching. Right-click to adjust 
settings.

Apply mitre corner
and adjust settings

Apply cap corner and
adjust settings

Apply lap corner and
adjust settings

Angle > 30° Angle < 30° 

Cap below 
angle: 30° 
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 Overlap: number of overlapping rows to allow where the sections of the cap 
join.

 Max length: maximum length of cap stitches. Cap Corners with stitches 
exceeding this length will become Mitre Corners. This prevents long and 
short stitches appearing next to each other.

Mitre corners
Mitre provides the following settings:
 Mitre below: angle below which to apply Mitre Corner – any corners 

greater than this are not mitred. The default is lap below 45°.

 Overlap: distance by which stitches are allowed to overlap in the center of 
the corner.

Tip  You can use Mitre Corner and Cap Corner options together. For 
example, you may wish a corner with an angle less than 75° to be mitred, but 
sharp corners of less than 45° to be capped. 

Lap corners
The Lap Corners feature provides good technical stitching in tight corners, as 
well as creative stitching effects. You have a choice of full overlap or split overlap 
methods, object-by-object. The split overlap method provides a variable amount 
of overlap at the corner. The Lap Below setting applies to either method and 

Capping 
overlap: 1

Capping 
overlap: 8

Capping overlap

Mitre below 
angle: 40° 

Angle > 40° Angle < 40° 

Mitre overlap: 
0.5 mm 

Mitre overlap: 
1.5 mm
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defines the angle below which Lap Corner will take effect. Any corners greater 
than this are not lapped. The default is lap below 110°.

With scalloped shapes, lap corners will always be applied since the corner angle 
approaches zero. 

Full overlap
Full Overlap provides a Max Extension setting. Technically, this is the 
extension of the corner point from the curve as a percentage of width. When set 
to zero, this setting achieves a blunting effect.

Split overlap
When enabled, Split Overlap provides the following settings:

Full overlap,
Angle < 45° 

Angle > 45° Split overlap,
Angle < 45° 

Lap below: 45° Not lapped

Lap corners
always applied

Extension = 0

Extension > 0
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 Overlap: This setting provides a selectable amount of overlap between the 
two parts of a lapped corner. The effect is similar to a mitre corner but with 
different stitching.

 Max curve extension: extension of corner point from curve as a percentage 
of width. Curve shapes can have flat full or selectable pointed split overlaps. 
This parameter achieves a blunting effect, with similar practical application as 
round sharp corners.

Note  The Lap Corners effect is incompatible with mitre or cap corners. 
Turning it on will switch off the other two.

Related topics
 Setting corner fractions

Rounding sharp corners

A Round Sharp Corners option is available for Column C objects and can be 
applied to sharp corners. The option is only available in conjunction with the 
Smart Corners effect. It is typically used with the Cap Corner option. 

Overlap: 0.5mm

Lap below: 45° 

Overlap: 2mm Overlap: 3mm

Extension = 0

Extension > 0

Right-click Traditional Digitizing > Column C to set sharp corner rounding.
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To round sharp corners
1 Double-click a Column C object or right-click the tool to access object 

properties.

2 Select the Round Sharp Corners checkbox.
3 Press Enter or click Apply.

Reducing stitch bunching

Standard stitch spacing is calculated at the outside edge of a shape. With sharp 
curves, spacing which provides adequate coverage on the outside edge may 
cause bunching along the inside edge. This may cause thread breakage when 
stitching out. The longer the stitches, the worse the problem. 
With Fractional Spacing, EmbroideryStudio calculates spacing settings from a 
specified point called the ‘offset fraction’. Changing it adjusts stitch spacing at 
inside and outside edges.

Stitch Shortening reduces the length of some stitches in sharp turns so that 
needle penetrations are distributed evenly, creating smoother stitching.

Select Round 
Sharp Corners

Sharp corner Rounded corners

0.00

0.66

0.33

1.00

Offset fraction:

Outside edge

Stitch bunching 
reduced on curves
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Applying fractional spacing

Apply fractional spacing to curved shapes to even out stitch density along 
outside and inside edges. Fractional spacing is particularly useful for columns of 
satin stitches with sharp turns. For best results, combine stitch shortening and 
fractional spacing effects. 

To apply fractional spacing
 Right-click the Fractional Spacing icon with or without objects selected to 

access object properties.

 Select the Fractional Spacing checkbox.
 In the Offset Fraction field, enter an offset as a fraction of column width, 

where the outside edge is 0.00 and inside edge 1.00.

Tip  An offset fraction of 0.33 generates fewer stitches than standard spacing, 
reducing bunching along the inside edge. An offset fraction of 0.66 eliminates 
bunching on the inside edge, but may produce insufficient stitches to cover 
the fabric.

Applying stitch shortening

Use Stitch Effects > Fractional Spacing to even out stitch density along outside and 
inside edges. Right-click to adjust fractional spacing settings.

Select fractional 
spacing and enter an 
offset fraction

Offset fraction 0.00 Offset fraction 0.33 Offset fraction 0.66

49 stitches59 stitches 43 stitches

Use Stitch Effects > Shortening to reduce stitch bunching in tight curves by 
shortening some stitches on the inside edge. Right-click to adjust stitch shortening 
settings.
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Apply stitch shortening to sharp corners to decrease density on the inside edge. 
Default settings suit most designs. Advanced users can override with custom 
settings.

To apply stitch shortening
 Right-click the Shortening icon with or without objects selected to access 

object properties.

 In the If spacing < field, enter the minimum spacing permitted between 
stitches (as % of nominal spacing) before automatic shortening takes effect.

 Enter the maximum number of consecutive short stitches to allow, up to a 
limit of five.
A higher number allows smoother distribution of needle penetrations in tight 
curves and reduces stitch bunching.

 Click the Settings button.

Select shortening

Access further settings

Adjust shortening settings

 If spacing < 90%  If spacing < 40%

Max no. of short 
stitches: 1

Max no. of short 
stitches: 5
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The Stitch Shortening Settings dialog opens. Here you can define 
individual lengths of consecutive short stitches as a percentage of the 
original.

 A value of 80% means that stitches are shortened to 80% of the original 
length, not by 80%. The smaller the percentage, the shorter the stitch.

 If you allow three short stitches, you need only fill in the first three rows. 
If you allow five short stitches, fill in all five rows. If only one short stitch 
is generated between normal stitches, the value in Row 1 will apply. If two 
consecutive short stitches are generated, the values in Row 2 will apply to 
1st and 2nd stitch respectively. And so on up the scale.

Tip  For best results use a jagged pattern between consecutive stitches.

Define length of short
stitches relative to

original stitch length

Randomize
shortening pattern

Max no. of short stitches: 1
Shorten stitch length to: 80%

Max no. of short stitches: 1
Shorten stitch length to: 50%

Max no. of short stitches: 5
Shorten stitch length to: 50%
Row 1: 80
Row 2: 85 70
Row 3: 70 90 70
Row 4: 70 90 80 70 
Row 5: 70 85 65 85 70

Max no. of short stitches: 5
Shorten stitch length to: 50%
Row 1: 90
Row 2: 70 60
Row 3: 55 85 55
Row 4: 55 85 75 55 
Row 5: 55 70 45 70 55
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 Select the Randomize checkbox to randomize the shortening pattern 
values. This will eliminate unwanted lines appearing in regular curves.

Optimizing long satin stitches

Embroidery machines have a maximum possible stitch length which is 
determined by the physical frame movement. If a stitch exceeds this, it is 
generally broken into smaller stitches of equal length. The line formed by needle 
penetrations can affect the appearance of the embroidery, especially satin fills. 
Auto Split breaks long satin stitches into shorter ones. It also distributes needle 
penetrations in a random pattern so that they do not form a line down the middle 
of the shape.

If you want to preserve the satin effect – for example, if only a few stitches are 
too long – you can use Auto Jump instead. This preserves long stitches in an 
object by turning them into a series of jumps. Auto Split must be turned off for 
Auto Jump to take effect. Auto Jump is applied by default to connectors. 

Note  The maximum frame movement is defined in the software by the  format 
values. See Standard machine formats for details.

Splitting satin stitches

While Auto Split is used primarily to prevent long stitches in wide columns, it 
can also be used as an alternative to tatami fill. Auto Split looks more satin-like 

Randomize ON Randomize OFF

Right-click Fill Stitch Types > Satin to apply Auto Split to new or selected satin 
objects.
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and works well with turning stitches, creating soft lines and a little more depth. 
By contrast, tatami is flat and can show unwanted patterns with tight curves. 

To split satin stitches
1 Click the Satin icon with or without objects selected to access object 

properties.

2 Select the Auto Split checkbox.
3 Enter a maximum satin stitch length to allow before Auto Split is applied.

Stitches that exceed this value will be split into smaller stitches. This value 
can be smaller than the maximum stitch generally used in the design.

Tip  Use a length of 7.00 mm to preserve the satin effect.
4 In the Min length field, enter the shortest stitch that can be generated when 

using Auto Split.

5 Press Enter or click Apply.

Tip  As an alternative to Auto Split, try a textured tatami fill or Program 
Split. Or, use User Defined Split to manage split lines in satin fills.

Related topics
 Using jumps as connectors

Select Auto Split

Adjust max and min stitch lengths

Length: 5 mm
Min length: 0.4 mm

Length: 4 mm
Min length: 0.4 mm

Length: 3 mm
Min length: 0.4 mm

Length: 4 mm
Min length: 5 mm

Length: 4 mm
Min length: 3 mm

Length: 4 mm
Min length: 1 mm

With User Defined Split With Tatami With Program Split
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 Patterned Fills

Preserving long stitches

Apply Auto Jump to satin objects with stitches that exceed the maximum stitch 
length. If the cover stitches are short, extending them with a jump makes them 
looser and thus more effectively raised off the fabric. Auto Jump can be used, 
for example, with manually digitized underlays. It can also be used to create 
quilted effects, for example, by applying it to satin areas that are over-stitched 
with Run stitch or Motif Fill.

To preserve long stitches
1 Right-click the Auto Jump icon with or without objects selected to access 

object properties.

2 Select the Auto Jump checkbox.
3 In the Max length field, enter the maximum stitch length to allow. Stitches 

exceeding this value will have Auto Jump applied. 

Note  This value must be smaller than or equal to the maximum stitch length 
possible for the selected  format. 

4 Adjust Jump length as required. 
Smaller jumps increase the time required to stitch out, but move the frame 
more smoothly across the design.

Use Stitch Effects > Auto Jump to preserve long stitches in new and selected 
objects. Right-click to adjust settings.

Select Auto Jump

Select calculation 
method

Enter maximum stitch 
and jump length settings
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5 Choose a Length calculation method:

The option you select depends on the way your machine measures stitch 
length. See your machine documentation for details.

6 Press Enter or click Apply.

Caution  Many machines trim by jumps. Thus, to prevent the trimmers being 
activated, usually only one or two jumps between needle penetrations may 
be used. 

Related topics
 Stabilizing with automatic underlay
 Setting trim functions
 Standard machine formats

Method Purpose

Along radius Measures the distance between two consecutive needle penetrations.

Along axis Measures either the horizontal or vertical movement required for the 
stitch.

Measured along 
radius

Measured along 
axis

Y

X

Maximum
stitch

Maximum stitch

Maximum 
stitch

Jump stitches –
not trimmed

NO jump stitches –
additional needle

penetrations
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Chapter 18

Embroidery Connectors

Connectors link objects in a design. 
They can be run stitches or jumps. 
Travel runs are also used to connect 
segments within filled objects. 
You can use automatic settings to 
generate connectors, trims and 
tie-offs, or add them manually. You 
can change connector settings for a 
whole design or selected objects. If 
you prefer to add tie-offs and trims as 
you digitize, you can turn off automatic 
connectors altogether. For Schiffli 
work, for example, you are advised to 
add connectors manually rather than 
rely on automatic settings.
EmbroideryStudio also allows you to 
create ‘branched objects’. Like-objects are thereby resequenced, connectors 
minimized, components grouped, and stitches regenerated. Underlay can be 
applied to all.
You can also set first and last stitches of a design. This makes it easy to position 
the needle before stitching, and reduces the chance of it hitting the frame.
This section describes how to add connectors, tie-offs and trims to your designs. 
It also describes adjusting settings for automatic connectors, including the stitch 
length for travel runs. It also deals with setting automatic start and end points.

Types of connectors

The type of connector you use depends on whether you want it to be visible in 
the final design. The default connector setting in EmbroideryStudio is for jumps.

Jumps
Jumps move the frame from one part of the design to another without needle 
penetrations. You can use automatic jumps as connectors between embroidery 
objects. The connecting thread generally needs to be tied-off and trimmed. The 
default connector jump length is the same as that set for Auto Jump.

Tip  You can also digitize jumps manually using the Penetrations function or 
with Manual stitch. 

Runs
Travel runs are typically used to connect segments of complex shapes. They can 
also connect adjacent objects. Because runs are not trimmed, they may be 
visible in the final embroidery. If objects are adjacent and connectors will be 
hidden, they can be used. You can change the stitch length of travel runs to 
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ensure they do not protrude from the cover stitching. You may also adjust the 
travel run length to reduce the stitch count. 

Note  While you can control the properties of run connectors between objects, 
you generally cannot control connectors within objects. Lettering and motif run 
objects are the exception.

Tie-ins
Tie-in stitches are inserted at the start of objects to prevent stitches from 
unraveling. They are inserted inside the shape on the second stitch. You 
generally use them when the previous connector is trimmed.

Tie-offs
Tie-offs are generally placed before trims to prevent stitches from unraveling. 
You can adjust connector settings to automatically add tie-offs under certain 
conditions, or add them manually. You can also include trim functions so 
machines with trimmers cut the thread automatically.

Trims
If you are using a machine with an automatic trimmer, the trim function causes 
the thread to be cut after a tie-off. In the software, trims are represented by a 
triangle with a small circle at the point where stitching starts again. The trimmed 
connector appears as a dotted line. You can adjust connector settings to 
automatically add trims, or add them yourself.

Related topics
 Adding jumps with penetrations off
 Digitizing individual stitches
 Adjusting travel run stitch length

Using automatic connectors

EmbroideryStudio lets you generate automatic connectors based on settings in 
the Object Properties > Connectors docker. You can change connector 
settings for a whole design or selected objects. If you prefer to add tie-offs and 
trims as you digitize, you can turn off automatic connectors altogether. For 
Schiffli work, you are advised to add connectors manually rather than rely on 
the automatic settings. Automatic connectors are turned off in the Schiffli 
template. See Adding connectors manually for details.

Tip  The Branching feature lets you digitize like-objects – e.g. the fingers of a 
hand – without having to think about the most efficient stitching sequence and 
joins. See Minimizing connectors with automatic branching for details.

 Trim
Stitching starts

Connector
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Using jumps as connectors

You can use automatic jumps as connectors between embroidery objects. Jumps 
move the frame from one part of the design to another without needle 
penetrations. You generally need to tie-off and trim the connecting thread.

To use jumps as connectors
1 Click the Object Properties icon and select the Connectors tab.

2 Select a connector method:

3 Select Jump and enter a distance for each frame movement. Shorter jump 
values generally improve stitch quality and reduce wear on the machine but 
may increase stitch-out time.

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set jumps as connectors.

Connection Description

After object Adjust connectors immediately following the current object.

Inside object Adjust connectors joining components of lettering objects or motif runs. 
This setting also applies to disconnected parts of branched objects. It 
does not apply to segments within an object.

Select ‘Jump’ and 
enter distance

Select connector 
method

Adjust ‘trim 
after’ settings

Adjust ‘tie-in’ and 
‘tie-off’ settings
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4 Adjust trims and ties as required:

Tip  You can also digitize jumps manually using the Penetrations function.

Related topics
 Adjusting travel run stitch length
 Setting stitch & jump length
 Adding jumps with penetrations off

Using runs as connectors

You can use runs of single stitches to connect objects in a design. Because runs 
cannot be trimmed, they are visible on the final embroidery, unless another 
object is digitized to cover them.

Function Notes

Trim after You can choose to turn off automatic trimming, to always trim 
connecting stitches, or to trim only when the connecting stitch is longer 
than a specified value. 

Tie in Tie-in stitches are inserted at the start of objects to prevent stitches 
from unraveling. You generally use them when the previous connector 
is trimmed. 

Tie off With trims, stitches need to be tied off so the thread can be trimmed 
without unraveling. Select between automatic tie-off methods to set 
preferred default. 

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set runs as connectors.
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To use runs as connectors
1 Click the Object Properties icon and select the Connectors tab.

2 Select a connector method:

3 Select Run and enter a length for the connecting run stitches.
4 Adjust Tie In settings as required. The Tie Off and Trim After options are 

disabled as they do not apply to travel runs.

Related topics
 Adjusting travel run stitch length

Adjusting automatic tie-in settings

Tie-in stitches are inserted at the start of 
objects to prevent stitches from unraveling. 
They are inserted inside the shape on the 
second stitch. You generally use them when 
the previous connector is trimmed.

To adjust tie-in settings
1 Click the Object Properties icon.

Connection Description

After object Allows you to adjust settings of connectors immediately following 
the current object.

Inside object Allows you to adjust settings of connectors joining letters within a 
lettering object, and motifs within motif runs. This setting also 
applies to disconnected parts of branched objects. It does not apply 
to segments within an object. 

Select Run and 
adjust stitch length

Adjust tie-in 
settings

Select connector 
method

Use Docker > Object Properties to toggle the Object Properties docker on/off.

Tie-in with 
four stitches
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2 Select the Connectors tab.

3 Select Tie In from the list and select a tie-in option:

4 Set tie-in values:

Adjusting automatic tie-off settings

With trims, stitches need to be tied off so the thread can be trimmed without 
unraveling. Select between automatic tie-off methods to set preferred default.

Method 2 is generally more visually pleasing on smaller objects and satin 
columns. With this method, however, stitches sew on top of each other with the 
consequent risk of thread breakage. On larger areas, the safer alternative is 
Method 1. Method 3 provides an alternative method for hiding tie-offs along 
existing stitch lines.

Tip  For narrow shapes or columns – e.g. small lettering – use only one tie-off 
stitch. You may also decrease the stitch length.

Tie-in option Description

Off No tie-ins are inserted.

Always tie in Tie-ins are inserted before the object.

After Trim/CC Tie-ins are inserted after trims and color changes.

Previous 
connector

Tie-ins are inserted when the previous connector exceeds the 
length you specify.

Tie-in Value Description

Length Determines length of tie-in stitches.

Number Determines number of tie-in stitches to generate.

Adjust tie-in 
settings

Use Docker > Object Properties to toggle the Object Properties docker on/off.

Method 2 with four 
stitchesMethod 1 with 

two stitches

Method 1 with four
stitches

Method 3 with 2
stitches
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To adjust tie-off settings
1 Click the Object Properties icon and select the Connectors tab.

2 In the Tie Off panel, select a tie-off option:

3 Select a default tie-off method. The system will apply this method where it 
can but switch where necessary, depending on stitch spacing and type.

4 Set the tie-off values:

Adjusting automatic trim settings

Tie-off option Description

Off No tie-off is inserted. By selecting this option, you need to add 
tie-off functions manually. See Adding tie-offs for details.

Always tie off A tie-off is inserted after the object.

Before trim / color 
change

A tie-off is inserted before a trim or color change.

Always tie off last A tie-off is inserted if the object is the last one in the design.

Next connector 
longer than

A tie-off is inserted if the next connector exceeds the specified 
length.

Method Description

1 Adds a specified number of small stitches between the last two stitching 
lines. Generally used with dense fills.

2 Adds a specified number of small stitches up and back down the last 
stitching line. Generally used with open fills where it is less visible.

3 Splits the second-last stitching line into three equal stitches. Also adds a 
specified number of small stitches back up the last stitching line.

Tie-in value Description

Length Determines length of tie-off stitches.

Number Determines number of tie-off stitches to generate.

Adjust tie-off 
settings

Select a tie-off 
method

Use Docker > Object Properties to toggle the Object Properties docker on/off.
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You can choose to turn off automatic trimming, to always trim connecting 
stitches, or to trim only when the connecting stitch is longer than a specified 
value.

To adjust automatic trim settings
1 Click the Object Properties icon and select the Connectors tab.

2 In the Trim After panel, select a trim option:

Tip  Usually, connectors shorter than 3 mm are not visible on the final 
embroidery. You may sometimes require a smaller value – e.g. if the thread 
color contrasts with the background color.

Adding connectors manually

You can add tie-offs and trims to a design manually using the Tie Off, Trim and 
Empty Stitch tools. While generally not recommended and less efficient than 
using automatic connectors, this method does give you more control over the 
final design. For example, some machine formats are unable to read functions 
that appear on a normal stitch. For these machines, you need to add trim, tie-off 
and other machine functions to an Empty Stitch or Empty Jump. You may also 
need to add one or more empty stitches or empty jumps to either side of a 
function for the machine to read it correctly.

Note  For Schiffli work, you are advised to add connectors manually rather than 
rely on the automatic settings. Automatic connectors are turned off by default 
in the Schiffli template.

Adding tie-offs

You can add tie-offs in your design using the Tie-Off tool. This provides a 
semi-automated technique for adding tie-offs as an alternative to digitizing them 
with manual stitches. Tie-offs are usually added before a trim at the end of an 
object. Generally you will follow a tie-off with a trim. 

Trim option Description

Off No trims are inserted. This feature is useful if trimming causes 
your machine to slow down, or the needle to lose the thread. 
You can either add trim functions yourself, or trim the final 
embroidery by hand.

Always trim Trims are inserted after the object.

Trim if next connector 
is longer than

Trims are inserted if the next connector exceeds the length you 
specify.

Adjust ‘trim after’ 
settings

Click Function > Insert Tie-Off to insert a tie-off.
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To add a tie-off
1 Travel to the object you want to tie-off.
2 Click the Insert Tie-off icon. A Tie-off function is inserted.

The default number of tie-off stitches is two. This means the needle 
backtracks twice and returns to the insertion point. Adjust this value in the 
Object Properties > Connectors docker. 

Tip  You can also insert machine functions manually using the Insert 
Machine Function dialog. 

Related topics
 Viewing stitching sequence
 Adding trims
 Inserting machine functions manually
 Adjusting automatic tie-off settings

Adding trims

You can add trims in your design using the Trim tool. When you add a trim in 
this way, the trim function is added to the current stitch. Some machines require 
empty stitches or empty jumps on either side of the trim. If this is the case for 
the machine you want to stitch to, you will need to insert them. 

Tip  Make sure that all stitches you trim have been tied in and off, otherwise 
stitches will not be secured.

To add a trim
1 Travel to the needle position where you want to trim the thread.

Tie-off
function start

Tie-off
function end

Click Function > Insert Trim to insert a trim.
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2 Click the Insert Trim icon. A trim function is inserted at the current needle 
position. 

Tip  You can also insert machine functions manually using the Insert 
Machine Function dialog. 

Related topics
 Travel through designs
 Inserting machine functions manually

Adding empty stitches & jumps

Empty stitch is a tight (zero length) lockstitch used together with, or as an 
alternative to, tie-in and tie-off stitches. Use empty stitches instead of tie-ins or 
tie-offs for objects filled with light density stitching where standard tie-ins and 
tie-offs may be visible. Also, use empty stitches or empty jumps when required 
by the selected machine format. 

To add empty stitches and jumps
1 Travel to the needle position where you want to trim the thread.
2 Click the Insert Empty Stitch icon to insert an empty stitch.
3 Click the Insert Empty Jump icon to insert an empty jump.

Trim symbol

Tie-in symbol

Click Function > Insert Empty Stitch to insert an empty stitch.

Click Function > Insert Empty Jump to insert an empty jump.

Empty functions added to 
stitching sequence
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Tip  You can also insert machine functions manually using the Insert 
Machine Function dialog. 

Related topics
 Travel through designs
 Inserting machine functions manually

Adding jumps with penetrations off

You can create jump connectors manually in a design by digitizing with 
penetrations off. The Penetrations tool prevents the needle from penetrating 
the fabric, forcing the machine to move across the design in a series of jumps. 
You can use Penetrations with any input method.

To add a jump with penetrations off
1 Select an input method – e.g. Run.
2 Deselect Penetrations. 
3 Digitize the connector in the usual way for the selected input method.

The jumps are saved together as an embroidery object.

Adjusting travel run stitch length

Travel runs are usually used to connect segments within filled objects. They are 
usually covered by fill stitches when the object is stitched out. You can adjust 
the travel run length to reduce the stitch count.

To adjust travel run stitch length
1 Click the Object Properties icon.

Deselect Function > Penetrations to create jumps with needles or borers out.

Penetrations off – jump stitches Satin Jumps Tatami

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set the travel run stitch length.
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2 Select the Special tab and Travel Run from the list.

3 Enter a value in the Length field as required.

Tip  Increase stitch length to reduce the stitch count. Travel Run 
automatically varies the stitch length on tight curves.

Keeping or omitting last stitches

If you are digitizing adjoining columns, you can keep or omit the last stitch in 
the first column to achieve a smoother join or shorter connecting stitches.

Note  This feature only applies when the exit point is at the end of the column 
– i.e. the default exit point. Moving the exit point using the Reshape Object 
tool overrides the Keep Last Stitch/Omit Last Stitch command.

To keep or omit the last stitch
 To keep the last stitch, select the object and click the Keep Last Stitch icon.

Adjust travel run 
length

Travel Run length: 1 mm Travel Run length: 3 mm

Click Reshape Tools > Keep Last Stitch to keep the last stitch in a column.

Click Reshape Tools > Omit Last Stitch to omit the last stitch in a column.

Columns smoothly 
joined

Columns with 
unwanted space
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 To omit the last stitch, select the object and right-click the Omit Last Stitch 
icon.

Tip  Alternatively press Spacebar to omit the last stitch or Enter keep it.

Related topics
 Applying closest join

Minimizing connectors

Designs stitch out more efficiently when the connectors between objects are 
short. This also reduces the number of trims in a design. EmbroideryStudio has 
a Closest Join method which is set via the Setup (or Standard toolbar) > 
Options > General tab. When activated (the default), entry and exit points of 
objects are automatically placed when the user digitizes new objects.

However, closest joins are not automatically maintained when objects are 
moved, re-sequenced, or edited. The Apply Closest Join feature allows you to 
(re-)apply closest joins to objects after editing. EmbroideryStudio also allows 
you to manually change entry and exit points of individual objects. 

Adjusting entry/exit points

Press Enter – last stitch kept

Press Spacebar – last 
stitch omitted

Use Reshape Object to adjust the entry and exit points of selected objects.

Use Reshape Views > Show Entry/Exit Points to toggle entry/exit point display 
when using the Reshape Object tool.
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EmbroideryStudio allows you to manually change entry and exit points of 
individual objects. Entry and exit points should always be checked if you are 
resequencing objects in a design. 

Tip  Closest joins are not automatically maintained when objects are moved, 
re-sequenced, or edited. The Apply Closest Join feature allows you to 
automatically re-apply closest joins to objects after editing. 

To adjust entry/exit points
 Select an object and click Reshape Object.
 Click Show Entry/Exit to view only entry and exit points.
 To view next or previous objects, press Tab or Shift+Tab keys. Any changes 

to objects are confirmed.
 Select entry or exit points of adjoining objects and drag into close proximity.

 Press Enter.

Tip  If you are digitizing adjoining columns, optionally keep or omit the last 
stitch in the first column to achieve a smoother join or shorter connecting 
stitches.

Related topics
 Sequencing embroidery objects
 Keeping or omitting last stitches
 Setting other general options

Applying closest join

When you are digitizing closed objects, the Closest Join method automatically 
calculates the closest join between them, saving you having to think about entry 

Exit point

Entry point Exit point

Entry point Exit point

Entry point

Use Arrange > Apply Closest Join to (re-)apply closest join to objects after editing.
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and exit points. The Apply Closest Join feature allows you to (re-)apply closest 
join to objects after editing. The command may be accessed via:
 Toolbar button on the Arrange toolbar
 Arrange menu
 Design Window popup menu
 Color-Object List popup menu
 Shortcut key (J)

Note  The Apply Closest Join command is only enabled when two or more 
embroidery objects are selected.

To apply closest join
 Digitize embroidery objects as required.

If the Closest Join method has been activated via the Setup (or Standard 
toolbar) > Options > General docker, entry and exit points of objects are 
automatically joined at the closest point.

 Move, reshape, and/or resequence objects in the design as required.
Closest join is not recalculated automatically – long connectors may result.

 Select all objects in the sequence and reapply closest join – click Apply 
Closest Join or choose the command from the popup menu.

Objects joined at 
closest point

Long connectors 
may result after 
resequencing
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Selected embroidery objects are regenerated and Closest Join applied.

Caution  Any non-sequential embroidery objects in the selection will cause a 
message to be displayed:

Tip  Apply Closest Join also to generated offset objects.

Related topics
 Setting other general options
 Generating outlines & offsets

Closest joins 
recalculated

Closest joins 
recalculated
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Closest join limitations

The Apply Closest Join feature is not applicable to all objects in all 
circumstances. Note the following limitations.

Stitch regeneration
Closest Join requires the complete stitch regeneration of the objects – the 
whole object, not just connectors. Stitch regeneration has its limitations:
 Recognized objects – i.e. opened from machine files – may generate poor or 

incorrect embroidery.
 Manual (unrecognized) objects cannot be changed by stitch regeneration. 

Thus Closest Join will not work properly for them.
 Manual stitch edits to objects will be lost.
 Inserted and recognized machine functions may be mistakenly regenerated 

on the underlay.
 Nested objects are not supported. They will become un-nested and placed 

after the object in which they were originally nested. This may not produce 
ideal sequence.

Run objects
The Closest Join technique is not as powerful as Branching for run objects. 
Closest Join will not produce a nicely-merged double-run, so connectors are 
only possible at the ends of the run, not in the middle. The best it can do is swap 
the ends of the runs.

Minimizing connectors with automatic branching

The Branching feature lets you digitize like objects – e.g. the fingers of a hand, 
sections of a custom letter – without having to think about the most efficient 
stitching sequence and joins. Branching is designed for use with shapes made 
up of objects that overlap – e.g. complicated letters, Asian characters, etc. Apply 
Branching to join selected objects to form a single ‘branched object’. Objects 
are resequenced, connectors minimized, component objects grouped, and 
stitches regenerated. All component objects are grouped and selectable as one.

Properties of branched objects
Branching works with any combination of the following object types – Run, 
Column A, Column B, Column C, Complex Fill and Complex Turning. Objects 

Branched run objects

Closest-join run objects
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with Motif Run and Motif Fill cannot be used. Branched objects preserve their 
original properties while sharing the color of the first object in the sequence.

Note  When dissimilar objects are selected and branched, any which cannot be 
branched are omitted.

Connections between branched objects
The components of a branched object are connected by the Closest Join 
method used with custom fonts. All objects are resequenced both externally (in 
relation to each other) and internally (by automatic segmentation).

Editing branched objects
Branched objects remain editable. They can be reshaped. There is only one 
entry and one exit point, but all component objects have individual reshape 
points. The object properties of a branched object can be accessed via the 
Object Properties docker. Stitch types can also be re-assigned via the toolbar.

Applying automatic branching

Apply Branching to selected objects. These become a single branched object.

Click Arrange > Branching to automatically sequence and group like embroidery 
objects.
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To apply automatic branching
1 Select the objects.

Note  The function is only available if more than one object of any suitable 
type is selected.

2 Click the Branching icon. EmbroideryStudio will prompt you to digitize entry 
and exit points.

3 Digitize entry and exit points, or press Enter twice to accept the defaults.
Component objects are grouped and share the color of the first branched 
object. Objects are resequenced, connectors minimized, and stitches 
regenerated. 

4 Travel through the branched object to check stitching.

Related topics
 Travel through designs

Branching objects with the Color-Object List

The Color-Object List provides an easy way to select objects in designs and 
access their properties. You can use it to branch like objects in a design.

To apply branching with the Color-Object List
1 Click the Color-Object List icon.
2 Select objects in the Color-Object List.

Long connectors 
between separate objects

Objects resequenced, 
connectors minimized

Use Docker > Color-Object List to branch selected objects in a design.
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3 Right-click and select Branching from the popup menu.

Note  The function is only available if more than one object of any suitable 
type is selected.

4 Digitize entry and exit points, or press Enter twice to accept the defaults.
Component objects are grouped and share the color of the first branched 
object. Objects are resequenced, connectors minimized, and stitches 
regenerated. 

Tip  Use the Color-Object List also to cut, copy and paste, group and 
ungroup, lock and unlock, and show and hide objects, as well as resequence 
objects.

Related topics
 Combining & Sequencing Objects

Applying automatic underlay to branched objects

Because Branching combines objects to form a single branched object, you can 
apply an underlay (single or double) to all.

Branch selected 
objects

Long connectors 
join objects

Selected objects 
grouped into single 
branched objectLong connectors 

eliminated

Right-click Stitch Effects > Auto Underlay to select an underlay type to apply to 
branched objects.
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To apply automatic underlay to branched objects
1 Select the branched object and right-click Auto Underlay.

2 Select the First Underlay checkbox and select an underlay type.
3 Press Enter or click Apply. Underlay stitches are automatically generated for 

the branched object. 

Note  If component objects are touching or overlapping, the underlay is first 
stitched out for the whole branched object followed by the cover stitch.

Related topics
 Viewing stitching sequence

Select underlay type

Select First Underlay

Whole underlay 
stitched first

Cover stitched after 
underlay
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PART V

MODIFYING DESIGNS

After digitizing a design, you can modify it as a whole, edit individual objects or 
even individual stitches.

Combining & sequencing objects
This section describes how to combine objects and designs by copying and 
pasting, duplicating, and inserting techniques. It also describes how to 
resequence objects by cut-and-paste, by color, and with the Color-Object List. 
Automatic branching of grouped objects is also covered. See Combining & 
Sequencing Objects for details.

Modifying objects
This section describes how to position objects, how to lock and group, align and 
space objects, as well as how to scale, rotate, skew, and mirror objects in a 
design. See Modifying Objects for details.

Reshaping objects
This section describes how to reshape objects with control points, how to break 
up objects, how to adjust and add stitch angles, as well as how to change entry 
and exit points of objects in a stitching sequence. It also covers conversion of 
one embroidery object to another. See Reshaping Objects for details.

Stitches & machine functions
This section deals with selecting and editing stitches, and converting selected 
stitches to objects. It also includes instructions for inserting, checking, editing 
and clearing manually-inserted functions. How to edit stitches and functions 
using the Stitch List is also covered. It also explains manual digitizing 
techniques. See Stitches & Machine Functions for details.
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Chapter 19

Combining & Sequencing Objects

EmbroideryStudio provides various techniques for combining and sequencing 
objects. You can add to designs by duplicating and copying objects. Resequence 
objects in designs to minimize color changes and optimize production.

The stitching sequence naturally occurs in the order in which an embroidery 
design is digitized or assembled. When converting a graphic design to an 
embroidery design, EmbroideryStudio decides the stitching sequence according 
to its own internal logic. Either way, you may, for reasons of aesthetics or 
production efficiency, want to adjust it. 
The Color-Object List displays a sequential list of objects grouped by object 
and color. It provides an easy way to group, cut, copy and paste, and resequence 
selected objects and color blocks.
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Combining objects & designs

Objects can be combined to create composite designs. They can be inserted 
from disk, copied and pasted via the MS Windows® clipboard for, or duplicated 
within the same design.

Inserting designs

EmbroideryStudio lets you insert one design into another. The two (or more) 
designs can then be saved as a combined design. When you insert a design into 
another, the two color palettes are combined. Colors with the same RGB values 
are automatically identified as having the same thread color. If you want to 
preserve them as separate colors, you need to change one or other before 
importing.

To insert designs
1 Open the source design.
2 Optionally, travel to the position in the stitching sequence where you want to 

insert the design. Otherwise, the inserted design will be placed at the end of 
the stitching sequence.

Click Standard > Import Embroidery to import embroidery design file into current 
design.
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3 Select Standard > Import Embroidery. File type defaults to the native 
‘all-in-one’ EMB format but any supported embroidery file can be used.

4 Select the design file to insert, and click Open. The design is inserted at the 
current needle position. By default, colors are added to the palette. 

5 Scale and position the inserted design as required. To ensure that all the 
objects in the inserted design stay together, group it first.

6 Sequence colors for efficient stitchout.
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Note  The Options > General tab provides another setting – ‘Match to 
palette’ – which matches inserted design colors to the current palette.

Related topics
 Inserting designs with Embroidery Clipart
 Setting color handling for inserted files
 Sequencing embroidery objects
 Modifying Objects

Copying & pasting objects

You can copy objects to create multiple, identical objects, or to insert objects 
from other designs. Cut-and-paste action changes the stitching sequence in the 
design.

To copy and paste objects
 Select the object (or objects) and click Copy or press Ctrl+C. The selected 

object is copied to the clipboard.
 Optionally, change Insert Embroidery File options via the Options > 

General dialog. By default, when you insert a design, colors are added to the 
color palette.

 Optionally, change Paste options via the Options > Edit dialog.
 Optionally, travel to the position in the stitching sequence where you want to 

insert the object/s. Otherwise, it will be placed at the end of the stitching 
sequence.

 Click the Paste icon. The object is pasted according to current settings.

Click Standard > Cut to remove selected objects to the clipboard.

Click Standard > Copy to copy selected objects to the clipboard.

Click Standard > Paste to paste copied objects to a design.

Colors added 
to palette

Colors matched 
to palette



EmbroideryStudio e4 User Manual 377

 Alternatively, use the Paste After Selected command to override current 
defaults and paste directly after the selected object in the stitching sequence.

 Alternatively, use the Paste Special flyout to override current paste position 
settings. Shortcut keys are available. Make sure there is only one copy of an 
object at any one position. If an object is pasted twice in the same position, 
it will be stitched twice.

Related topics
 Setting paste & duplicate options
 Setting color handling for inserted files
 Sequencing embroidery objects
 Modifying Objects

Duplicating & cloning objects

Objects can be duplicated rather than copied. When duplicated, the object is not 
copied to the clipboard. This preserves the current contents of the clipboard. 
They can also be ‘cloned’.

To duplicate or clone objects
 Select an object or objects.
 Optionally, travel to the point in the stitching sequence where you want to 

place the duplicate. Otherwise, the duplicate object will be included at the end 
of the stitching sequence.

 Select Edit > Duplicate or press Ctrl+D. The duplicate is placed directly on 
top of the source object.

 Optionally, press Ctrl+Shift+D to duplicate with an offset. This means you 
can step-repeat objects. Adjust the setting via the Options > Edit dialog. 

Override current 
settings

Override current
default settings

o

Use Select Tools > Select Object to select and clone objects.

Set duplicate
offsets



Chapter 19   Combining & Sequencing Objects 378

 Alternatively, it is handy to be able to right-click and drag an object to ‘quick 
clone’. Holding down the right mouse button, simply drag to a new position. 
Hold down Ctrl in order to constrain movement to horizontal or vertical 
planes.

 Optionally, press Ctrl+Shift+D to keeping duplicating the last cloned object. 
‘Quick duplicate’ temporarily overrides the ‘Duplicate with offset’ setting in 
the Options dialog.

Tip  Clone objects to another window by the same method. To temporarily 
deactivate automatic scrolling, hold down the Shift key while dragging. Use 
the Window > New Tab Group commands to view multiple design tabs at 
the same time.

Related topics
 Setting paste & duplicate options
 Travel through designs
 Set up multiple views

Nesting objects

EmbroideryStudio lets you ‘nest’ one object inside another at an exact point of 
the stitching sequence. This feature is useful with motifs and other designs 
where long connectors may be generated. It also helps reduce overall numbers 
of objects, minimizing trims and tie-offs.

Right-click object

Drag-and-drop

Object duplicated
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To nest objects
1 Travel through the object until the needle position marker is positioned where 

you want to insert the new object.

2 Either digitize the new object or copy and paste. The object is ‘nested’ inside 
the stitching sequence. All required functions are automatically added.

3 Use arrow keys to fine-tune placement of the new object.

Related topics
 Setting paste & duplicate options

Grouping & locking objects

EmbroideryStudio lets you group objects together for group modifications. 
Ungroup whenever you need to work with the component objects. You can also 
lock objects to prevent them from being moved or modified by accident.

Grouping & ungrouping objects

Group objects, or an entire design, to keep them together for moving, scaling 
and transforming actions. With grouped objects you can also apply global 
changes, saving time and ensuring consistency. When you have finished making 
changes to a group, you can ungroup and work with the component objects.

To group or ungroup objects
 Select objects and click the Group icon or press Ctrl+G.

Selected objects are combined. This group can be selected, moved, resized 
and transformed as a single object.

Travel to insertion 
point and paste object

o

Use Arrange Tools > Group to group selected objects.

Use Arrange Tools > Ungroup to ungroup selected objects.

Select, move, resize, or 
transform grouped objects 
as single object
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 To ungroup, select and click Ungroup or press Ctrl+U.

Tip  The Color-Object List provides an easy way to select objects in designs 
and access their properties. Use it to group, lock, and hide objects.

Related topics
 Select objects with selection tools
 Sequencing with the Color-Object List

Locking & unlocking objects

Lock objects to prevent them from being moved or modified by accident. For 
example, locking backdrop images holds them in place as you digitize, transform 
or reshape the embroidery objects near them.

To lock or unlock objects
 Select objects and click the Lock icon or press K.

Selection handles disappear, indicating that the object can no longer be 
selected or modified.

 To unlock objects, click the Unlock All icon or press Shift+K.

Objects ungrouped
and deselected

Click to open
or close node

Group/ungroup 
objects

Use Arrange Tools > Lock to lock selected objects.

Use Arrange Tools > Unlock All to unlock all locked objects in a design.
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Tip  The Color-Object List provides an easy way to select objects in designs 
and access their properties. Use it to group, lock, and hide objects.

Related topics
 Select objects with selection tools
 Sequencing with the Color-Object List

Selecting objects within groups

EmbroideryStudio provides a method for selecting individual objects within 
object groupings. This is handy if you want to make changes ‘on-the-fly’ without 
first having to ungroup and then regroup objects. 

To select objects within groups
 Click the Select Object icon or press 0.

 Use Alt + Click to select a single object within a group.

Click to open
or close node

Lock/unlock 
objects

Use Select Tools > Select Object to select individual objects as well as groups or 
ranges of objects.

Entire design 
grouped
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 Use Ctrl or Shift keys in combination with Alt to select multiple objects or a 
range of objects within a group.

 Use Alt + Drag to select by ‘selection marquee’.
 Use Alt + Polygon/Polyline to isolate objects as you select.
 Within the Color-Object List, use the same techniques to:
 Select a single object/color within a group (Alt+Click).
 Add/remove a single object/color within a group (Alt+Ctrl+Click).
 Select a range of objects/colors within a group (Alt+Shift+Click).

Note  Once an object (or more) is selected, all properties, stitching and 
otherwise, can be changed ‘inside’ the group without the need to 
ungroup/regroup.

Related topics
 Select objects with selection tools

Selecting objects by color or stitch type

You can select embroidery objects of the same color or stitch type with a single 
command.

Selecting objects by color

You can select embroidery objects of the same color with a single command.

Individual objects 
selected within a 
group
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To select objects by color
 Select Edit > Select by Color.

 Select color blocks from the list and click OK. All objects using the selected 
colors are selected in the design.

Related topics
 Viewing color blocks
 Sequencing with the Color-Object List

Selecting objects by stitch type

You can select embroidery objects of the same stitch type with a single 
command.

To select objects by stitch type
1 Select Edit > Select by Stitch Type. The Select by Stitch Type dialog 

opens.

2 Select a stitch type from the list.
 To select a range of stitch types, hold down Shift as you click.
 To select multiple stitch types, hold down Ctrl as you click.

3 Click OK.

Choose color 
blocks

Select stitch type
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Objects using the selected stitch types are selected in the design.

Sequencing embroidery objects

The embroidery objects comprising a design form a ‘stitching sequence’. It is 
good practice to analyze and plan design shapes and stitching sequence in 
advance. Shapes need to be clearly defined to make them easy to embroider. 
The best shapes have relatively constant width, with smooth edges, no sharp 
turns and no small, protruding details. Details should always be stitched last.

If you are digitizing manually in Wilcom Decoration, objects are stitched in the 
order in which they were created. If you have converted a design directly from 
CorelDRAW Graphics to Wilcom Decoration, EmbroideryStudio uses 
automatic sequencing to determine the stitching sequence. You can always 
manually adjust the sequence to improve the stitchout – e.g. to minimize color 
changes.

Tip  Entry and exit points should also be checked when resequencing objects in 
a design. See also Adjusting entry/exit points. See also Minimizing connectors.

Sequencing by cut-and-paste

You can resequence objects by cutting an object from the design and pasting it 
back at a different point in the sequence. This does not change its physical 
location.

To sequence objects by cut-and-paste
1 Select the object (or objects) to resequence.
2 Click the Cut icon.

1

2

3

4

5

Click Standard > Cut to cut a selected object or objects and place them on the 
clipboard.

Click Standard > Paste to paste copied objects in the design.
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The selected object is removed to the clipboard.

3 Travel to the point in the stitching sequence where you want to to paste the 
object. 
You can place it between other objects or ‘nest’ it within another object.

4 Click the Paste icon.
The object is pasted according to current settings.

 Alternatively, use the Paste After Selected command to override current 
defaults and paste directly after the selected object in the stitching sequence.

Note  Make sure there is only one copy of an object at any one position.
If an object is pasted twice in the same position, it will be stitched twice.

Related topics
 Viewing stitching sequence
 Nesting objects
 Setting paste & duplicate options

Sequencing with the Color-Object List

The Color-Object List provides an easy way to select objects in designs and 
access their properties.

Completed design – 
center stitched first

Object cut to 
clipboard

Object pastedCursor inserted at 
end of design

Override current 
settings

Override current
default settings

Use Docker > Color-Object List to resequence objects.
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To sequence with the Color-Object List
1 Click the Color-Object List icon.

2 Select the color block or object to resequence.
 To select a range of items, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you click.

3 Click-and-drag selected objects to reposition them.

Tip  You can also use the Color-Object List to group, lock, and hide objects.

Related topics
 Grouping & locking objects
 Copying & pasting objects
 Adjusting entry/exit points
 Minimizing connectors

Sequencing selected objects

Click-and-drag 
object to new 
position

Drop object into new 
position

Use Sequence > Back 1 Object to move a selection back one object in the stitching 
sequence.
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The Sequence toolbar provides a convenient means for sequencing selected 
objects. Use it in conjunction with the Color-Object List. Alternatively, use the 
popup menu Sequence option to resequence objects ‘on-the-fly’. The same 
options can be accessed from the Color-Object List popup menu.

Tip  Entry and exit points should also be checked when you are resequencing 
objects in a design.

Related topics
 Adjusting entry/exit points
 Minimizing connectors

Use Sequence > Forward 1 Object to move a selection forward one object in the 
stitching sequence.

Use Sequence > Back 1 Color to move a selection back one color in the stitching 
sequence.

Use Sequence > Forward 1 Color to move a selection forward one color in the 
stitching sequence.

Use Sequence > Move to Start to move a selection to start of stitching sequence.

Use Sequence > Move to End to move a selection to end of stitching sequence.

Sequence selected
objects via the toolbar

or popup menu
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Auto-sequencing entire designs

The Optimize Color Changes feature improves the quality and efficiency of the 
stitchout by minimizing the number of color changes and trims. All existing 
overlaps are preserved by the operation. Grouped objects are not ungrouped but 
different colored objects are optimally sequenced regardless of grouping.

To auto-sequence an entire design
 Open or create a design and select objects to resequence.

 Select Arrange > Sequence > Optimize Color Changes or use the popup 
menu in the Color-Object List. 

 Click OK to confirm. The system analyzes all selected objects and calculates 
optimal color changes and trims.

Tip  The Undo command will reverse the effect of any sequencing changes.
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Related topics
 Adjusting entry/exit points
 Minimizing connectors

Sequencing by color

The Sequence by Color feature lets you resequence all objects in a design by 
color. This technique resequences all color blocks of the same color.

To sequence by color
 Select the objects to resequence or press Ctrl+A to select the entire design.
 Click the Sequence by Color icon or select Arrange > Sequence > By 

Color. The Sequence by Color dialog opens listing colors in the selected 
objects.

 Select a color and click Move Up or Move Down to change its position in the 
sequence.

Note  If you need to maintain separate color blocks, use the Color-Object 
List.

Sequencing by selection order

You can resequence objects by selecting them in the required stitching order.

Use Sequence > Sequence by Color to resequence all blocks of like color.

Select color 
block

Use buttons to 
resequence

Use Sequence > Sequence by Selects to resequence objects in the order selected. 
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To sequence objects by selection order
 Select the first object you want to resequence.

 Holding down Ctrl, select subsequent objects. Select each object in the order 
you want it to stitch out. Do this directly on-screen or via the Color-Object 
List.

 With objects still selected, select Arrange > Sequence > By Selects or click 
the Sequence by Selects icon. The objects are resequenced in the selection 
order. 

Tip  Entry and exit points should also be checked when you are resequencing 
objects in a design.

Related topics
 Adjusting entry/exit points
 Minimizing connectors

Sequencing by number

Select objects in 
order to be stitched

Objects resequenced 
in order selected

Use Docker > Color-Object List to resequence objects.
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You can resequence objects numerically in the Color-Object List. Use it to 
move an object to a position between consecutive members of a color block. This 
technique is used primarily with designs containing many objects where precise 
object sequencing is important. 

To sequence objects by number
1 Click the Color-Object List icon.
2 Right-click an object in the list.
3 Select Sequence > By Number from the popup menu. The Resequence by 

Number dialog opens.

4 Enter the number of the object before which you want to position your 
selected object.

Note  If you prefer to position the selected object after a selected number – 
e.g. to make it the last object in the list – select After Position.

5 Click OK. The selected object will be placed in the new position and all other 
objects resequenced accordingly.

Sequence selected
object by number

Enter number of 
target object
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Chapter 20

Modifying Objects

Change position, size and orientation of objects by moving, scaling and 
transforming them. Modify objects directly on screen or via their object 
properties. Mirror objects or entire designs. Create design ‘wreathes’ or borders. 
Create design arrays for efficient stitchout.

Note  The scalability and stitching quality of a design ultimately depend on its 
original source – Native Design, Imported Outlines, Processed Stitches, 
or Imported Stitches. Only EMB designs contain the complete set of design 
information required for 100% perfect scaling and transformation. See also 
Embroidery file formats.

Arranging objects

Position objects using the mouse to drag and drop, or ‘nudge’ them with arrow 
keys. Alternatively, specify X:Y coordinates in the Property bar. 
EmbroideryStudio also provides tools to align objects relative to each other, or 
distribute them evenly within the design.

Positioning objects

The simplest way to move an object is to drag-and-drop to a new position.
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To position objects
 Select the objects to move and click-and-drag to a new position.

 For more accurate positioning, use the arrow keys to ‘nudge’ selected objects.

Tip  With no objects selected, using arrow keys will travel through the design.
 For even more accurate positioning, enter X:Y coordinates in the Property 

Bar. The selection is centered over the coordinates you set.

Tip  Zoom in to make small adjustments. The distance the object moves 
depends on the current zoom factor.

Related topics
 Select objects with selection tools

Aligning objects

You can align selected objects to the left, right, top, bottom or center of a 
specified object.

Use cross-hair cursor 
to center object

Enter exact
coordinates

Use Arrange Tools > Align Left to left-align selected objects.

Use Arrange Tools > Align Centers Vertically to align the centers of selected objects 
vertically.

Use Arrange Tools > Align Right to right-align selected objects.

Use Arrange Tools > Align Top to top-align selected objects.

Use Arrange Tools > Align Centers Horizontally to align the centers of selected 
objects horizontally.

Use Arrange Tools > Align Bottom to bottom-align selected objects.

Use Arrange Tools > Align Centers to align selected objects through their centers.
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To align objects
 Select the objects you want to align. 
 Select the object you want to align with.
 Click an alignment tool or select Arrange > Align > ...

Note  Objects are aligned with the last object selected. When all objects are 
selected using Ctrl+A or a selection marquee, they are aligned with the last 
object in the sequence.

Related topics
 Select objects with selection tools

Distributing objects evenly

You can automatically distribute selected objects with even spacing between 
them, both vertically or horizontally.

To distribute objects evenly
 Select the objects you want to distribute.
 Click a spacing tool or select Arrange > Space Evenly > ...

Note  The tools all become enabled when three or more objects are selected.

Related topics
 Select objects with selection tools

Align center

Align left

Align bottom

2 1

3

Use Arrange Tools > Space Evenly Across to distribute selected objects evenly 
across the screen.

Use Arrange Tools > Space Evenly Down to distribute selected objects evenly down 
the screen.
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Scaling objects

You can scale objects by dragging selection handles, specifying exact dimensions 
in the Property bar, or by setting a distance between reference points on the 
design. As an object is scaled, the stitch count changes to preserve the current 
spacing.

Note  Only EMB designs contain the complete set of design information for 
100% perfect scaling and transformation. 

Scaling objects interactively

You can change height and width of an object, or scale it proportionally using 
selection handles. Scale objects individually, or select multiple objects and scale 
them together. Use the tooltips as a guide.

To scale objects interactively
 Select the objects to scale.

 To scale height and width proportionally, use a corner handle.

Tip  By default, objects scale proportionally. To scale freely in vertical and 
horizontal planes, hold down Ctrl as you drag.

 To change the height or width, use the center handles.

Scale proportionally Scale freely in both 
directions

Ctrl + drag
Drag

Scale 
vertically

Drag

Scale 
horizontally

Drag
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 To scale proportionally around an anchor point, hold down Shift as you drag.

Scaling objects numerically

You can scale artwork, selected objects or a whole design by means of object 
properties. With outline files (EMB), this allows stitches to be regenerated while 
preserving the original stitch density. An exact size may not be achieved due to 
pull compensation being added to stitches after scaling operations.

Caution  If you scale a machine file by more than ±10%, however, changes to 
stitch density will affect the design quality.

To scale objects numerically
1 Select the objects or design to scale.
2 In the Property Bar, either:
 Enter an exact height and width, or
 Enter the new height and width as a percentage of current dimensions.

Tip  Toggle Lock Aspect Ratio to preserve aspect ratio.
3 Press Enter to apply.

Note  After scaling, the new object size is reset to 100%.

Related topics
 Embroidery file formats

Scale proportionally 
about center

Shift + dragScale horizontally in 
both directions

Shift + drag

Enter dimensions as exact 
values or as a percentage

Lock aspect ratio 
toggle

Vase scaled
Width: 120% Height: 140%

Shadow scaled
Width: 140% Height: 120%



EmbroideryStudio e4 User Manual 397

Scaling objects by reference line

You can scale an object or design by marking reference points and specifying a 
line length.

To scale an object by reference line
1 Select the objects or design to scale.
2 Select Transform > Transform by Reference Line Numerically. 

You are prompted to enter start and end points. You will have already decided 
which two points in the object or design will form the reference line.

3 Click to mark the reference points. Press Ctrl to constrain the angle of the 
axis to 15° increments. 

4 Alternatively, press Enter twice to use the default reference line.
The Transform by Reference Line dialog opens.

5 Select the Resize to checkbox, and enter the required distance between 
reference points.

6 Click OK.

Making objects the same size

You can scale objects to the same size as a reference object. Resize height or 
width or both.

To make objects the same size
1 Select the objects to resize.
2 Select the object that is the size you require.

Use Transform > Transform by Reference Line Numerically to transform selected 
objects using a combination of reference points and numeric values.

Click to mark the 
reference points

Select Resize
to checkbox

Specify size

Click Arrange Tools > Make Same Width to scale an object or design to the same 
width as a reference object.

Click Arrange Tools > Make Same Height to scale an object or design to the same 
height as a reference object.

Click Arrange Tools > Make Same Width and Height to scale an object or design to 
the same size as a reference object.



Chapter 20   Modifying Objects 398

3 Click a sizing tool or select Arrange > Make Same Size > ...

Note  Objects are resized with reference to the last object selected. If all 
objects are selected by using Ctrl+A or a selection marquee, they are resized 
with reference to the last object in the sequence.

Rotating objects

You can rotate objects directly on screen or by setting an exact rotation angle.

Rotating objects interactively

When you select an object, selection handles display at its extremities. When 
you click the object again, the handles change to rotation handles. Use the 
tooltips as a guide.

To rotate objects interactively
1 Select the objects to rotate.
2 Click a second time.

Make same width

Make same height

Make same width and height
2

3 1
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Rotation handles appear at the corners and an anchor point at the center.

3 Optionally, drag the anchor point to any position.

4 Click-and-drag a rotation handle in either direction.

Rotating objects numerically

You can rotate selected objects in 45° increments or by entering an exact value 
using the Transform toolbar.

To rotate an object numerically
 Select objects to rotate.
 To rotate in 45° increments, click one of the Rotate 45 icons.

 To rotate by an exact amount, enter an exact angle in the Rotate field and 
press Enter.

Rotating objects by reference line

Click second 
time

Anchor point

Skew handle

Rotation handle

Drag corner point to rotate 
about the anchor point

Anchor point
repositioned

Drag corner point to rotate 
about the anchor point

Click Transform > Rotate Right 45° to rotate selected objects by 45° in a clockwise 
direction.

Click Transform > Rotate Left 45° to rotate selected objects by 45° in a 
counter-clockwise direction.

Use Transform > Rotate to rotate selected objects by an exact amount (in 
degrees).

Use Transform > Transform by Reference Line Freely to rotate selected objects 
with the aid of reference points alone.
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The Transform by Reference Line Freely tool lets you rotate selected objects 
with the aid of reference points alone. This technique is useful if you want to 
duplicate and rotate objects around an anchor point – e.g. the petals of a flower.

To rotate an object by reference line
1 Select objects to rotate.
2 Select Transform > Transform by Reference Line Freely.
3 Follow the prompt line:
 Click the first reference point. This becomes the anchor point for the 

rotation.
 Click a second reference point. An outline attaches to the pointer.

 Optionally, press Ctrl to constrain the angle of the axis to 15° increments.
 Click the anchor point. The pointer then aligns itself with the second 

reference point.
 Click a guide point for the required rotation position. Use coordinates on 

the Status bar for exact alignment.

Rotating objects by reference line and angle

The Transform tool provides another method for transforming selected objects 
using a combination of reference points and numeric values. This provides a very 
accurate technique for rotating selected objects.

To rotate objects by reference line and angle
1 Select the objects to rotate.
2 Decide which two points in the object or design will form the reference line. 

This should be a significant line – e.g. one which must be perfectly horizontal 
or vertical in the final design.

3 Select Transform > Transform by Reference Line Numerically.

4 Select the Rotate to checkbox, and enter the rotation angle of the reference 
line.

Move the pointer

Use Transform > Transform by Reference Line Numerically to transform selected 
objects using a combination of reference points and numeric values.

Select Rotate to Enter absolute rotation 
angle in degrees
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For example, to rotate the image so it aligns with the horizontal axis, enter a 
value of 0°. The Angle field accepts angles from 0 to ±180 degrees.

5 Click OK.
6 Click to mark the start and end points of the reference line.

Press Ctrl to constrain the angle of the axis to 15° increments. Alternatively, 
press Enter twice to use a horizontal reference line by default.

Skewing objects

You can skew objects directly on screen or by setting an exact skew angle.

To skew objects
1 Select the objects to skew.
2 Click the object a second time. Skew handles are diamond-shaped and 

appear at the center-top and bottom of the object.

3 Drag handles left or right. 

Select rotation angle – 
e.g. 0°

Reference line set to angle 
specified in dialog

Digitize reference line – align 
with base of object

Use Transform > Skew to skew selected objects by an exact amount (in 
degrees).

Click second 
time

Anchor point

Skew handle

Rotation handle

Drag skew handle 
left or right
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Tip  Alternatively, to skew by an exact amount, enter an exact angle in the 
Skew field on the Transform toolbar and press Enter. 

Mirroring objects

Fashion and textile designs often use copied and mirrored design elements. In 
EmbroideryStudio you can mirror objects horizontally or vertically by means of 
the Transform toolbar. You can also mirror around a defined axis using a 
reference line.

Tip  The Mirror Merge tools allow you to duplicate and transform selected 
embroidery objects, as well as merge them into a single object. This feature is 
often used in making fashion or textile designs. See Mirroring & reflecting 
selections for details.

Flipping objects horizontally & vertically

You can mirror selected objects horizontally or vertically using the Mirror tools. 
Select objects to mirror and click a Mirror icon. For productivity, shortcut keys 
are available for mirror operations.

Related topics
 Creating multiple reflections

Mirroring objects around an axis

Use Mirror by Reference Line to mirror objects around a reference line.

Click Transform > Mirror Horizontal to flip selected objects in the horizontal plane.

Click Transform > Mirror Vertical to flip selected objects in the vertical plane.

Mirrored verticallyMirrored in both axes

Starting objectMirrored horizontally

Use Transform > Mirror by Reference Line to mirror objects around a defined axis 
using a reference line.



EmbroideryStudio e4 User Manual 403

To mirror objects around an axis
1 Select the objects to mirror.
2 Select the Mirror by Reference Line icon or select Edit > Transform > 

Mirror by Reference Line.

3 Click to mark two reference points of the mirror axis.

Tip  Press Ctrl to constrain the angle of the axis to 15° increments.

Mirrored

Starting object
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Chapter 21

Reshaping Objects

EmbroideryStudio offers a number of techniques for reshaping embroidery 
objects, all with the one tool. Sometimes you may need to cut, split or break up 
complex or compound objects in order to fine-tune them. Various tools are 
available for this purpose. As well as reshaping object outlines, you can add and 
adjust stitch angles, a property unique to embroidery objects. You can also 
change the entry and exit points of individual objects which is important if you 
are digitizing manually or resequencing embroidery objects.

Reshaping embroidery objects

The reference points you mark when digitizing a shape become its ‘control 
points’. Most control points can be added, deleted, or moved. Corner and curve 
points can be swapped. Some, such as entry and exit points, cannot be deleted.

Viewing control points

Corner reshape-node

Exit point

Curve reshape-node

Entry point

Stitch angle points

Control handle

Use Reshape Tools > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Use Reshape Views > Show Reshape Nodes to toggle on/off reshape nodes for 
selected objects.

Use Reshape Views > Show Bézier Handles to toggle on/off Bézier handles for 
selected objects.
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The Reshape Object tool is important in EmbroideryStudio. Use it whenever 
you want to change object shapes. Use it also to edit stitch angles as well as 
entry and exit points.

To view control points
 Select an object and click Reshape Object. Control points appear together 

with Reshape Views toolbar.

Tip  Most control points can be added, deleted, or moved. Corner and curve 
points can be swapped. Entry/exit points, however, cannot be deleted.

 Use the Reshape Views toolbar to selectively display control points.

 Show Reshape Nodes: Use hotkey combination Alt+N to toggle. See 
Reshaping objects with reshape-nodes for details.

 Show Bézier Handles: See Reshaping objects with Bézier controls for 
details. See also Setting reshape options.

 Show Stitch Angles: Use hotkey combination Alt+A to toggle. See 
Adjusting stitch angles for details.

 Show Entry/Exit: See Adjusting entry/exit points for details.

Use Reshape Views > Show Stitch Angles to toggle on/off stitch angles for selected 
objects.

Use Reshape Views > Show Entry/Exit Points to toggle on/off entry/exit points for 
selected objects – respectively, green diamond and red cross markers.

Bézier control handle

Curve reshape-node

Entry point

Stitch angle point

Stitch angle line

Corner reshape-node

Exit point

Show Reshape Nodes Show Stitch Angles Show Entry/ExitShow Bézier Handles
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 To view next or previous objects, press Tab or Shift+Tab keys. Any changes 
to objects are confirmed.

Related topics
 Reshaping objects with reshape-nodes
 Reshaping objects with Bézier controls
 Setting reshape options
 Adjusting stitch angles
 Smoothing curves

Reshaping objects with reshape-nodes

Change object shapes with the Reshape Object tool. 

To reshape objects with reshape-nodes
 Select an object and click Reshape Object. Control points appear together 

with Reshape Views toolbar.
 Toggle on Show Reshape Nodes and toggle off other icons.
 Add nodes as required:
 Left-click to add a corner node.
 Right-click to add a curve node.

 Select reshape-nodes as follows:

Shift + Tab Tab

Use Reshape Tools > Reshape Object to reshape selected objects by means of 
control points.

Use Reshape Views > Show Reshape Nodes to toggle reshape-node display when 
using the Reshape Object tool.

Right-click

Left-click
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 Click a single node.
 Click-and-drag a selection marquee around a group of nodes.
 Use Ctrl or Shift keys to select multiple nodes. Left-clicking or 

right-clicking in closed shapes reverses the direction of the selection.

 Adjust reshape-node position by dragging along the outline. 

Tip  Use the arrow keys to ‘nudge’ selected nodes.
 Press Delete to remove unwanted nodes.

 Press Spacebar to toggle between corner and curve nodes.
 Press Esc to cancel changes. Press Esc again to exit Reshape mode.

Note  You can also adjust stitch angles as well as change entry and exit 
points. 

Click to select – hold 
down Ctrl to select 

multiple nodes

Drag selection marquee 
around reshape-nodes 

to select

OR

Hold down Shift and right 
or left-click to select range 

of nodes

Drag 
reshape-nodes

Delete reshape-nodes 
and toggle between 
corners and curves
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Related topics
 Reshaping objects with Bézier controls
 Setting reshape options
 Adjusting stitch angles

Reshaping objects with Bézier controls

When EmbroideryStudio converts a vector graphic, it preserves nodes and 
control points. CorelDRAW® Graphics Suite uses Bézier curves. In Wilcom 
Decoration you can work with reshape-nodes or Bézier control points.

To reshape objects with Bézier controls
1 Select an object and click Reshape Object. Control points appear together 

with Reshape Views toolbar.
2 Toggle on Show Reshape Nodes together with Show Bézier Handles.
3 Reshape objects in one of two ways:
 Drag the control handle to reshape the curve around reshape-nodes.

 Adjust reshape-node position by dragging along the outline. 

Note  Generally, bézier node dragging preserves the shape of the curve more 
accurately. 

Use Reshape Tools > Reshape Object to reshape selected objects by means of 
control points.

Use Reshape Views > Show Reshape Nodes to toggle reshape-node display when 
using the Reshape Object tool.

Use Reshape Views > Show Bézier Handles to toggle Bézier control handle display 
when using the Reshape Object tool.

Bézier control 
handle

Drag control handle 
to reshape curve

Curve point

Original curve Bézier curve Traditional curve
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4 Release the mouse and/or press Enter to finish. Again depending on system 
settings, stitches are generated as soon as the reshape-nodes are moved or 
after Enter is pressed. 

Tip  Press Spacebar to toggle between corner and curve reshape-nodes.

Related topics
 Setting reshape options

Reshaping Column C objects

Reshaping operations for Column C objects are handled a little differently to 
other embroidery objects.

 With the Reshape tool activated, drag reshape handles to control object 
width.

 Hold down Alt and drag to adjust offsets.
 Hold down Shift and drag to adjust angles.

Related topics
 Digitizing regular columns
 Setting angles & orientation
 Adjusting rulers & guides

Reshaping stars & rings

For objects created with the Star or Ring tools, reshape using default control 
points only.

Reshaping star objects

Use Reshape Tools > Reshape Object to add stitch angles to selected objects.

Hold down Shift and Alt
keypress combinations to

control Column C reshaping
operations

Use Reshape Tools > Reshape Object to reshape circle and star objects.
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Change circle/star objects from circles to ovals using the Reshape Object tool.

To reshape star objects
 Select an object and click Reshape Object. Circle/star objects have two 

reshape-nodes (for radius and orientation), a center point (to reposition), and 
an entry point.

 Use reshape nodes to change object radius, orientation, and position.

Tip  Change the stitch angle of circle objects by moving the entry point.
 Press Enter.

Tip  To scale a circle without changing it to an oval, select it with the Select 
Object tool, and use selection handles.

Related topics
 Digitizing stars & rings

Reshaping ring objects

Entry point

Reshape-nodeCenter point

Stitch angle

90°

Click-and-drag 
reshape-node

Press Enter

Use Reshape Tools > Reshape Object to reshape ring objects.
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You can reshape the inner and outer boundaries of ring objects with the 
Reshape Object tool.

To reshape ring objects
 Select an object and click Reshape Object.

 Use reshape nodes to change object radius, orientation, and position.

 Use reshape nodes to offset boundaries. Center points are generally on top 
of each other to begin with, and may not be visible.

Related topics
 Digitizing stars & rings

Applying envelopes

Entry point

Reshape-nodeCenter point may
not be visible

Press EnterClick-and-drag 
reshape-node

Press Enter
Click-and-drag 

center point

Apply Envelope Tools > Bridge Envelope to make objects bulge or arch.
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Four types of Envelope effect are available – Bridge, Pennant, Perspective 
and Diamond. Envelopes are typically applied to lettering objects, but they can 
also be applied to other types of embroidery object.

To apply an envelope
1 Select the lettering object you want to distort. To apply an envelope to several 

objects, group them first, then apply the envelope.
2 Select Edit > Envelope.

3 Select an envelope type from among the following alternatives:

Shaping handles display around the envelope outline.

4 Drag handles up or down to shape the object.

Apply Envelope Tools > Penant Envelope to make objects compress.

Apply Envelope Tools > Perspective Envelope to make objects stretch.

Apply Envelope Tools > Diamond Envelope to make objects bulge or compress.

Choose an envelope

Bridge Pennant Perspective Diamond

Bridge reshape 
handles
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 To move two handles in opposite directions, hold the Shift key down while 
dragging.

 To move handles in the same direction, hold down the Ctrl key while 
dragging.

5 Press Esc to finish.

Related topics
 Creating special effects with lettering art

Shift + drag

Ctrl + drag
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Cutting, splitting & breaking objects

EmbroideryStudio lets you split branched objects – monograms, appliqués, 
lettering, etc – into their components. You can even split manual objects with 
Process Stitches in order to convert sections to outline objects.

Breaking apart composite objects

The Break Apart tool allows you to break up composite objects – monograms, 
appliqués, lettering, etc. The effect on these objects is similar to ungrouping.

Note  When saved into earlier versions of the software, monograms, appliqués, 
lettering, and blackwork runs may be subjected to the Break Apart procedure 
by default.

To break apart a composite object
1 Select the object you want to break apart – e.g. branched object, appliqué, 

monogram, lettering, etc.

2 Click the Break Apart icon or select Arrange > Break Apart.

Use Edit Tools > Break Apart to split composite objects – monograms, appliqués, 
lettering, etc – into component objects.
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The branched object is split into component objects.

Tip  To modify individual objects – e.g. to change the stitching sequence of 
monogram borders – use the Color-Object List to ungroup and resequence.

Tip  Applying the Break Apart function to a lettering object breaks it into a 
logical stitching sequence while maintaining lettering object characteristics.

Related topics
 Splitting objects
 Breaking apart lettering

Cutting shapes manually

The Knife tool is used to manually cut filled shapes into smaller fragments. It 
has the advantage over Split Object and Divide tools of allowing you to digitize 
temporary cut lines. Cut objects are generated with stitching – parallel or turning 
– appropriate to their shape. The tool cuts both filled and ‘fillable’ vector objects 
as well as embroidery objects. Run objects can also be cut with the Knife tool.

The Knife tool has two modes of operation:
 With nothing selected, it will cut all objects under the knife.
 With selected objects, it will only cut those within the selection.

Use Edit Tools > Knife to cut objects along a digitized line, preserving stitch settings 
and colors in resulting objects.
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To cut shapes manually
1 Select one or more suitable objects for cutting.

2 Click the Knife tool. The cursor changes to a knife icon.
3 Digitize a cutting line – left-click for corner points, right-click for curve points 

– and press Enter.

4 Manually adjust object overlaps using the Reshape Object tool.

Note  By default EmbroideryStudio orders fragments into a closest-join 
sequence that preserves the source object’s entry and exit points. The 
Options > Reshape dialog offers other ways of managing cut fragments.

Note  When you select a lettering object to cut, the object is highlighted with 
a thick magenta outline. See also Converting TrueType fonts to embroidery.

Object needs cutting at 
this point to avoid 
awkward stitch angles

Source object 
separated into two 
adjoining objects

Adjust Knife tool 
behavior

Lettering object 
highlighted for cutting
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Related topics
 Splitting vector & embroidery objects 
 Shaping objects
 Setting reshape options
 Reshaping objects with reshape-nodes

Cutting shapes automatically

The Automatic Knife tool assists semi-automated digitizing of vector artwork. 
When objects have clean boundaries, EmbroideryStudio fragments them 
automatically and generates good quality stitching in most cases. It also 
operates on Complex Fill and Complex Turning embroidery objects.

To cut shapes automatically
1 Select one or more suitable objects for cutting.

2 Click the Automatic Knife icon.

Use Edit Tools > Automatic Knife to automatically slice Complex Fill and Complex 
Turning embroidery objects into smaller turning stitch and single angle objects with 
automatic overlaps.

Object needs cutting at this point 
to avoid awkward stitch angles
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EmbroideryStudio cuts the selected object automatically, discarding any 
unwanted fragments.

For each source object, EmbroideryStudio:
 Creates turning-stitch objects as well as single-angle objects where 

appropriate.
 Creates overlaps at junctions between objects.
 Branches adjoining objects. 

Related topics
 Minimizing connectors with automatic branching
 Breaking apart composite objects

Shaping objects

When working with overlapping vector or embroidery objects, you can merge, 
trim or split them using the Shaping tools. All ‘shaped’ embroidery objects 
convert to Complex Fill or Complex Turning. Vector objects remain as vector 
objects unless combined with embroidery objects. You have the option of 
preserving source objects. You also have the option of adding overlaps to objects 
resulting from Flatten or Divide operations.

Overlaps created 
between fragment 
objects at junctions
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Shaping tools summary table

Merging vector & embroidery objects

Source Apply Tool Result Description

Weld

Selected objects are combined into a 
single object. The resulting object 
takes the properties – stitch color and 
type, etc – of the topmost object.

Flatten
Only areas unique to each selected 
object are retained. All overlapping 
areas are removed.

Intersect
Only areas common to all selected 
objects are retained. All 
non-overlapping areas are removed.

Exclude
Areas where pairs of selected objects 
overlap are removed, starting from 
the topmost object.

Front-Back
The topmost object is retained, but all 
of the areas overlapping with other 
selected objects are removed.

Back-Front
The bottommost object is retained, 
but all of the areas overlapping with 
other selected objects are removed.

Divide
The objects are split wherever 
overlaps occur and all hidden areas 
are removed.

Combine

Areas where pairs of selected objects 
overlap are removed, starting from 
the topmost object. All resulting 
objects share the properties – stitch 
color and type, etc – of the topmost 
object.

Use Shaping Tools > Weld to merge overlapping objects into a single ‘flattened’ 
object.

Use Shaping Tools > Combine to merge the properties of overlapping objects and 
trim overlapping areas.
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Merge selected objects using the Weld or Combine tools.

To merge vector and embroidery objects
 Select vector or embroidery objects to shape.
 Use Weld to merge overlapping objects into a single ‘flattened’ object.

 Make symmetrical shapes by digitizing one half, duplicating and reflecting, 
then welding the duplicate shapes.

 Use Combine to convert embroidery objects into multiple objects sharing the 
properties – stitch color and type, etc – of the topmost object.

 Weld applied to 
petals

Weld 
applied

Combine applied 
to petals
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If drawing tools are used as the input method, Combine converts vector 
objects to a single complex shape.

Tip  Cut objects in half by drawing a line through them and applying Divide. 
Apply Combine to create closed objects or Weld to fuse two objects.

Trimming vector & embroidery objects

Trim selected objects using the Intersect, Exclude, Front-Back or 
Back-Front tools.

To trim vector and embroidery objects
 Select vector or embroidery objects to shape.

Combine applied 
to petals

Weld + Run + 
Combine applied to 
resulting objects

Weld + Run 
applied to 
resulting objects

Divide 
applied

Use Shaping Tools > Intersect to trim overlapping areas so that only those 
intersected by all selected objects remain.

Use Shaping Tools > Exclude to trim overlapping objects and preserve their 
individual properties.

Use Shaping Tools > Front-Back to trim overlapping objects so that only 
non-overlapped areas of the topmost object remain.

Use Shaping Tools > Back-Front to trim overlapping objects so that only 
non-overlapped areas of the bottommost object remain.
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 Use Intersect to trim overlapping areas so that only those intersected by all 
selected objects remain.

 Use Exclude to trim overlapping objects and preserve their individual 
properties. The result is similar to Combine except that object properties are 
not merged.

Tip  Use Exclude to cut holes in Complex Fill objects.
 Use Front-Back to trim overlapping objects so that only non-overlapped 

areas of the topmost object remain.

 Use Back-Front to trim overlapping objects so that only non-overlapped 
areas of the bottommost object remain.

Tip  Use the Remove Overlaps feature to maintain shapes but remove the 
underlying layer of stitching.

Related topics
 Removing underlying stitching

Intersect 
applied

Exclude applied to 
petals

Front-Back 
applied

Back-Front 
applied
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Splitting vector & embroidery objects

Split selected objects using the Flatten or Divide tools. These tools preserve 
the outlines of the original shapes. The Overlap setting allows you to add 
overlaps to objects resulting from Flatten or Divide shaping operations.

To split vector and embroidery objects
 Select the vector or embroidery objects to shape.
 Click Flatten to trim all overlaps while retaining the original objects.

 Click Divide to split selected objects into separate adjoining objects. All 
overlapped areas become discrete objects.

Use Shaping Tools > Overlap to adjust the overlaps of objects resulting from 
Flatten or Divide shaping operations.

Use Shaping Tools > Flatten to trim all overlaps while retaining the original objects.

Use Shaping Tools > Divide to split selected objects into separate adjoining objects 
wherever they intersect with other selected objects.

Flatten 
applied

Divide applied 
(petals only)
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 Use the Overlap feature to add overlaps to the objects resulting from 
Flatten or Divide shaping operations.

The Overlap range is from 0.00 to 5.00 mm with increments of 0.01 mm. 
The default overlap is 0.50 mm.

The border of a third object in the stitching order is extended where it touches 
the other two layers of objects. And so on.

Preserving original objects

The Keep Source Objects is a toggle which affects the behavior of all the other 
shaping tools. While it is active, all selected source objects of all shaping 
operations are preserved. The resultant objects are inserted after the last 
source object in the stitching sequence.

Flatten: 0.00 mm Flatten: 2.00 mmSource objects

Flatten: 2.00 mmFlatten: 0.00 mmSource objects

Use Shaping Tools > Keep Original Objects to keep the source objects after 
shaping.
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Chapter 22

Stitches & Machine Functions

EmbroideryStudio automatically generates stitches 
from design outlines and properties. This means you 
can scale, transform, and reshape native designs 
without compromising stitch density or quality. 
However, EmbroideryStudio also lets you edit 
individual stitches. You may need to do this, for 
example, when working with ‘stitch’ files which do not 
contain outline data.
Like stitches, machine functions are inserted 
automatically whenever you digitize objects and 
specify object properties. They are stored with the 
embroidery object and updated whenever it is modified. However, 
EmbroideryStudio also lets you manually insert machine functions. This 
flexibility allows you to adapt designs to almost any machine requirement. See 
Working with Machine Files for details.
Occasionally you may need to digitize individual stitches. Use these sparingly. 
You can also use manual stitching together with machine functions to create 
boring holes. Holes are cut in the fabric, producing an effect similar to lace.

Selecting & editing stitches

The Stitch Edit tool lets you select individual stitches or groups of stitches 
directly or via the Stitch List.

Caution  When you insert stitches manually, you must maintain them manually. 
For this reason, only insert stitches if they cannot be added automatically.

Selecting stitches by needle point

Select individual stitches in Stitch Edit mode.

To select stitches by needle point
 Click the Stitch Edit icon and zoom into the area you want to edit.
 Click Show Needle Points for easier selection. 

Use Stitch > Stitch Edit to select individual stitches for editing.

Click View > Show Needle Points to show or hide the needle points in a design.
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 Click a needle point.

 Use keyboard shortcuts to aid selection:
 To select a range, hold down Shift as you select.
 To select multiple stitches, hold down Ctrl as you select.

 Alternatively, drag a selection marquee around stitches.

 Deselect by either means:
 Press Esc.
 Select Edit > Deselect All.

Tip  While editing stitches, use the Selects On/Off command to select 
stitches while traveling. 

Related topics
 Selecting stitches while traveling

Selecting stitches with the Stitch List

You can view and select individual stitches by means of the Stitch List.

To select stitches with the Stitch List
 Click the Stitch List icon.

Selected
stitch

Hold down Shift
to select a range

of stitches

Selection 
marquee

Stitches selected

Use Docker > Stitch List to toggle Stitch List display on and off. Use it to select 
individual stitches.



EmbroideryStudio e4 User Manual 427

The Stitch List opens. It shows stitch position coordinates and function 
information – e.g. whether the stitch is a jump. It also shows the length of 
every stitch in the design.

 Right-click to access popup menu options. For example, display text in black 
by selecting Black Text or in the associated stitch color by selecting Colored 
Text.

 Click a stitch to select it. Stitches selected in the Stitch List are also selected 
in the design, and vice versa.

 Use keyboard shortcuts to aid selection:
 To select a range, hold down Shift as you select.
 To select multiple stitches, hold down Ctrl as you select.

Related topics
 Filtering stitches & functions

Selecting stitches while traveling

Stitch List shows position 
coordinates, function information, 
and individual stitch lengths

Change Stitch List text and 
background colors

Selected
stitches

Use Stitch > Stitch Edit to select individual stitches for editing.
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Select a range of stitches by traveling by stitch with Selects On/Off activated. 
This command adds stitches to the selection as you travel through the stitching 
sequence.

To select stitches while traveling
 Click the Stitch Edit icon.
 Zoom into the area you want to edit and click a needle point.

 Select Stitch > Selects On/Off or press Q.
 Travel through the design using arrow keys or Travel tools. As you travel, 

stitches are added to the selection.

 Press Q again to toggle off stitch selection.

Related topics
 Travel through designs

Inserting stitches

You can insert stitches in an object to fill gaps. Inserted stitches are considered 
part of the object. They will, however, be lost if the object’s stitches are 
regenerated. Where possible, edit object properties rather than individual 
stitches. For example, to increase stitch density, reduce spacing rather than 
insert stitches.

To insert stitches
1 Click the Stitch Edit icon and zoom into the area you want to edit.
2 Select a needlepoint.

Select Stitch > Selects On/Off to select a range of stitches as you travel through the 
design.

Travel to the first stitch

Travel 10 Stitches tool used

Use Stitch > Stitch Edit to insert stitches in an object.

Right-click
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3 Move the mouse pointer where you want to insert the new stitch, and 
right-click.

Note  Inserting stitches is different from creating stitches using the Manual 
input method. With this tool you create a separate object, with its own 
properties and connectors. 

Related topics
 Digitizing individual stitches

Editing stitches

You can move or delete individual or groups of selected stitches.

To edit stitches
 Click the Stitch Edit icon and zoom into the area you want to edit.
 Select stitches and drag them to a new position.

 Select a stitch or stitches and press Delete.

Use Stitch > Stitch Edit to select individual stitches for moving.

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to edit coordinates 
of individual stitches.

Drag selected
stitch to new

position

Shadow outline

 Select
stitches

Press 
Delete
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 Open the Stitch List and double-click the stitch coordinate you want to edit.

 Enter new coordinates in the X and Y fields and press Enter. The new 
coordinates will change the location of the stitch end point.

Caution  If an object’s stitches are regenerated for any reason, all stitch 
editing functions are lost. Where possible, reshape the object rather than 
move individual stitches.

Related topics
 Reshaping Objects
 Selecting stitches with the Stitch List

Splitting objects

Use the Split Object command to split most embroidery objects. Run objects 
may also be split but Complex Fill and Complex Turning objects may not.

To split objects
 Use the Travel by Segment or Travel by Stitch functions to move to the stitch 

where you want to split the object. See also Travel through designs.

Enter new stitch 
coordinates as 
required

Use Travel > Travel by Segment to move stitch cursor to the next/previous 
segment. Left/right click.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 stitch at a 
time. Left/right click.

Use Stitch > Split Object to split object in two at current needle position. Use with 
Travel by Stitch functions.
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 Select Stitch > Split Object.

Tip  You can convert any split manual objects to outline objects with Process 
Stitches. 

Related topics
 Adjusting stitch densities
 Travel through designs
 Converting stitches to objects

Editing machine functions

Most machine functions are inserted automatically whenever you select 
commands or specify object properties. They are stored with the embroidery 
object and updated whenever it is modified. However, EmbroideryStudio lets you 
insert machine functions manually. Depending on the current machine format, 
different functions are available. The most common types are described below. 
See your machine manual for further details. See also Machine formats.

Caution  Machine functions which are manually inserted into non-manual 
objects – e.g. Column A, Complex Fill, etc – need to be maintained manually. If 
an object’s stitches are regenerated for any reason, manually inserted machine 
functions may be moved to another point in the stitch sequence. For this reason, 
only insert functions manually if they cannot be added automatically.

Machine function types

EmbroideryStudio lets you manually insert color changes, thread trims, jumps, 
machine stops, needles in and out, and boring functions, depending on the 
selected machine format.

Color Change functions
Color Change functions tell the machine to use the next thread color in the 
design. They are automatically inserted when you select a new color from the 
color palette. See Assigning thread colors for details.

Note  You only need to insert manual color change functions if you cannot 
recolor using standard methods – for example, when using multiple colors within 
a single object.

Trim functions
Trim functions instruct machines with trimmers to cut connecting threads before 
moving to the next object. You insert trims automatically by setting connector 
values or using the Trim tool. See Adjusting automatic trim settings and Adding 
trims for details.

Split object 

Split object
deleted
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If you need additional trims, you can insert the functions manually.

Note  If a machine does not have a trimmer, the Trim function is ignored. 
Depending on the machine format, the Trim function may be a code or a 
sequence of jumps. See Setting trim functions for details.

Stop functions
If you want the embroidery machine to stop for any reason during stitching, you 
need to manually insert a Stop function in the stitching sequence.

Tip  Because a Stop function may be inserted for various reasons, you should 
record the purpose of the stop on the production worksheet to assist the 
machine operator.

Jump functions
Jump functions cause frame movements without needle penetrations and are 
used to move smoothly from one part of a design to another. There are various 
methods for automatically entering Jump functions.
 Apply Auto Jump to preserve long stitches. See Preserving long stitches for 

details.
 Digitize individual jumps by right-clicking the Manual icon. See Digitizing 

individual stitches for details.
 Select jumps as connectors. See Using jumps as connectors for details.
 Create jump connectors manually by digitizing with Penetrations 

deselected. See Adding jumps with penetrations off for details.
If you need additional jumps, you can insert the functions manually.

Begin/End Jump functions
The Begin/End Jump functions (formerly known as Needle Out/In) instruct the 
machine whether or not to use needle penetrations. You insert these functions 
automatically using the Penetrations tool (formerly known as Needles In). See 
Adding jumps with penetrations off for details.
If you need additional Begin/End Jump functions, you can insert them manually.

Note  Remember to insert a End Jump function to instruct the machine to 
resume normal stitching.

Borer In/Out functions
Borer In/Out functions are available for embroidery machines equipped with a 
borer. They instruct the machine when to use the boring knife or tool instead of 
a needle. You insert these functions automatically using the Borers tool 
(formerly known as Borers In). See Digitizing boring holes for details.
If you need additional Borer In or Out functions, you can insert them manually.

Sequin On/Off functions
Sequin On and Sequin Off functions are available for embroidery machines that 
are equipped with a sequin dispenser. The Sequin On function generally instructs 
the machine to physically lower the sequin dispenser into position for sequins to 
be placed (fed and cut). These functions are automatically inserted when using 
the Sequin tools. See Sequin Digitizing for details.
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If you need additional Sequin On or Sequin Off functions, you can insert them 
manually.
Some machines, notably Schiffli, use only explicit Drop Sequin functions. These 
instruct the machine to drop a sequin on the fabric for stitching. Schiffli 
machines, for example, do not require Sequin On/Off functions. See the ES 
Schiffli User Manual Supplement for details.

Inserting machine functions manually

You can insert machine functions manually by means of the Insert Function 
dialog. Depending on your machine’s requirements, you will either add the 
function to the current stitch, or insert it on an empty stitch or empty jump. For 
some machines you will also need to add empty stitches or empty jumps on 
either side of some functions. See your machine manual for details.

Caution  When you insert machine functions manually, you must maintain them 
manually. For this reason, only insert manual functions if they cannot be added 
automatically.

To insert machine functions manually
 Open the Stitch List and locate the position in the stitching sequence where 

you want to insert the machine function. Alternatively, use the travel 
functions to locate the insertion point. The function name appears in the 
Prompt Bar.

 Right-click the stitch and select Insert Function from the popup menu.

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to insert machine 
functions directly into the stitching sequence.

Click Function > Insert Function to insert machine function at current stitch cursor 
position. 

Select Insert 
Function
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Alternatively, click the Insert Function icon or select Function > Insert 
Function.

 From the Available Functions list, select the function you want to insert. 
Available functions and their options depend on the current machine format. 

Tip  It is faster to digitize individual jumps – Jump(M) – by right-clicking with 
the Manual input method selected. If you want the whole object to consist 
of jumps, deselect the Penetrations icon. 

 If available, choose an insertion method. With some functions you can choose 
whether to insert on the current stitch or on an empty stitch.

 To insert additional empty stitches or empty jumps, select one or other in the 
Component field.
Depending on your machine, you may need to insert additional empty 
stitches or empty jumps before or after the selected function. For example, 
before a particular Stop function, you may need to insert a number of empty 
jumps. See your machine manual for details.

 Use the buttons to insert additional components before or after the selected 
function.
Click Insert Before if you  need the empty stitch/jump to precede the 
selected function.

 To insert multiple empty stitches or jumps, click Add. The selected function, 
together with any additional empty stitches or jumps, appears in the 
Sequence panel.

Select from functions
available for selected

machine format

Additional empty stitches 
inserted before and after 
selected function
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 Click OK to insert. The selected function, together with any additional empty 
stitches or jumps, is added at the current needle position. The name of the 
inserted function appears in the Prompt Bar.

Related topics
 Create designs from templates
 Travel through designs
 Selecting stitches with the Stitch List
 Adding jumps with penetrations off

Editing machine functions manually

You can edit the encoding of machine functions by changing the number or 
sequence of empty stitches or empty jumps that appear around them. Some 
machines require a specific number of empty stitches or empty jumps in 
combination with a function in order to interpret it correctly. You may need to 
edit functions if they were inserted incorrectly or the machine format has 
changed.

Note  Both automatic and manually-inserted functions can be removed. 
Functions added by EmbroideryStudio are automatically updated if an object is 
modified or the machine format changes. Manually inserted machine functions 
are not automatically removed or updated. You generally only need to edit 
manually inserted machine functions. If a function is no longer required, it must 
be manually cleared from the design. 

To edit machine functions manually
 Open the Stitch List and locate the position in the stitching sequence where 

you want to insert the machine function. Alternatively, use the travel 

Additional empty jumps 
inserted before and after 
selected function

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to edit machine 
function encoding and to clear machine functions.

Click Function > Clear Function to remove machine functions at current stitch 
cursor position. 

Click Function > Edit Function to edit machine function at current stitch cursor 
position. 
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functions to locate the insertion point. The function name appears in the 
Prompt Bar.

 To remove the function altogether, select Clear Function from the popup 
menu. If a stitch includes more than one machine function – e.g. Trim and 
Tie-off – the Clear Function command will invoke the Clear Function 
dialog. This allows you to selectively clear functions as desired.

 Right-click the function and select Edit Function from the popup menu. 
Alternatively, click the Edit Function icon or select Function > Edit 
Function. The Sequence panel shows the current format of the selected 
function.

 To insert additional empty stitches or empty jumps, select one or other in the 
Component field.

 Use the buttons to insert additional components before or after the selected 
function. Click Insert Before if you  need the empty stitch/jump to precede 
the selected function.

 To insert multiple empty stitches or jumps, click Add.

Edit selected 
machine function

Select functions 
to clear

Select empty stitch or 
empty jump

Insert empty stitch/jump 
before or after the machine 
function
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 To delete an empty stitch or empty jump from the sequence, select and click 
Remove.

Related topics
 Travel through designs

Filtering stitches & functions

You can use the Stitch List to help locate stitches and machine functions for 
editing. The Stitch List displays stitch number, stitch coordinates, stitch length, 
stitch function, stitch color. When you select a stitch in the list, it is 
simultaneously selected in your design.

Filtering stitches by function

You can apply a filter to the Stitch List so that only stitches associated with 
specific functions appear in the list.

To filter stitches by function
1 Open the Stitch List. 

2 Right-click a stitch and select Show Functions from the popup menu.

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to display stitches 
associated with specific functions.

Show functions

Select functions 
to show 
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3 Select the functions you want to show.

Tip  To select multiple functions, use Ctrl or Shift keys as you click. Click 
Select All to show all function types.

4 Click OK. Selected functions are displayed in the list.

Tip  To display the text in the associated stitch color, select Colored Text 
from the popup menu.

5 To show all stitches again, right-click in the Stitch List and select Show All 
from the popup menu.

Related topics
 Selecting stitches with the Stitch List

Filtering stitches by stitch length

You can apply a filter to the Stitch List so that only stitches of a certain length 
appear in the list. The main use of this feature is to find stitches which cause 
production problems, such as short stitches (e.g. < 1.0 mm).

To filter stitches by stitch length
1 Open the Stitch List.

Only selected functions 
are displayed

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to display only 
stitches of a certain length.

Show stitches
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2 Right-click a stitch and select Show Stitches from the popup menu. The 
Show Stitches dialog opens.

3 Select the range of stitch lengths you want to show:

4 Click OK. Only the selected stitches are displayed in the list.

Tip  To display the text in the associated stitch color, select Colored Text 
from the popup menu.

5 To show all stitches again, right-click in the Stitch List and select Show All 
from the popup menu.

Related topics
 Selecting stitches with the Stitch List
 Eliminating small stitches
 Preserving long stitches

Digitizing manual stitches

Occasionally you may need to digitize individual stitches. Use these sparingly, 
for example, to add a few details to a finished design. You can also use manual 
stitching together with machine functions to create boring holes. If your 
embroidery machine is equipped with a boring knife or needle, you can use the 
Borers tool to turn needle penetrations into borer holes, regardless of selected 
stitch type. Holes are cut in the fabric, producing an effect similar to lace.

Caution  Manual stitches are not well suited to scaling and transforming actions 
as the stitches have no associated properties. Use them sparingly.

Range Description

Radial Corresponds to the actual stitch length.

Axial X,Y Corresponds to the horizontal and vertical frame movements. 

Select stitch 
range to show 

Only selected stitches 
are displayed
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Digitizing individual stitches

Digitize individual stitches with the Manual method. You can enter single 
manual stitches, or enter three stitch layers at a time with the Triple Manual 
tool. Manual stitches digitized together form a single embroidery object. The 
only properties of manual objects are general and connector properties. They 
are not well suited to scaling and transforming actions. Use them sparingly, for 
example to add a few stitches to a finished design.

To digitize individual stitches
1 Click the Manual or Triple Manual icon.
2 Click to mark the start of the stitch and again to mark its end.

The end-point becomes the beginning of the next stitch.
3 Continue marking stitch points until the manual stitch object is complete.

Tip  Stitches that are too long will automatically become jump stitches, but 
you can also create jumps manually by right-clicking as you digitize.

Related topics
 Using jumps as connectors

Digitizing boring holes

Use Traditional Digitizing > Manual to digitize individual ‘manual’ stitches.

Use Traditional Digitizing > Triple Manual to digitize triple ‘manual’ stitches.

Use the left 
mouse button

1

2

3

4

5

6

7

8

9
11

10

Click for manual 
stitches

Right-click for 
jumps

Use Function > Penetrations together with Borers to digitize boring holes.

Use Traditional Digitizing > Run to digitize an outline around the shape you want to 
bore.

Use Function > Borers to activate the boring function.

Use Traditional Digitizing > Manual to digitize boring holes.
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If your embroidery machine is equipped 
with a boring knife or needle, you can use 
the Borers tool to cut holes in the fabric, 
producing an effect similar to lace. With 
Borers selected, each needle penetration 
becomes a borer hole, regardless of 
selected stitch type. Borer holes are 
generally stabilized with zigzag to prevent 
fraying and movement, and bordered with 
satin stitches.
Boring is a difficult digitizing skill to 
master. You may need to experiment with 
your machine and stitch width and spacing 
settings to achieve the effect you require.
With Tajima and Barudan machines Borers inserts a Stop function which allows 
the machine to change to the needle position that uses the boring attachment. 
The machine must be correctly programmed to use the correct needle position.

Note  The default setting for multihead borers is for a ‘knife’ attachment, where 
the cutting position is offset ±12 mm from the main needle line. This offset is 
only expressed when you save your design to a stitch format like DST. If you are 
using a boring needle, you need to change the offset value to 0.

To digitize boring holes
1 Ensure Penetrations is on.
2 Click the Run icon and digitize an outline around the shape you want to bore. 

This helps prevent the fabric from tearing.

3 Click the Borers icon. A machine function is inserted to indicate the change 
from stitching to boring. 

Tip  Use the Stitch List to visualize what is happening at the stitch level.
4 Click the Manual icon and digitize individual stitches where you want a boring 

knife to cut. 

Use Traditional Digitizing > Column A to digitize border stitching around the holes.

Digitize outline 
with Run stitch
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Each stitch you digitize becomes a boring hole. The borer penetration points 
appear as diamonds, connected by dotted lines. These do not appear in 
TrueView™.

Alternatively use Run to digitize lines for boring holes.
 For a round hole, digitize two intersecting lines. 
 For an oval hole, digitize one line.

Tip  Reduce the Run stitch length – e.g. 1.0-1.5 mm – to place borer 
penetrations closer together, thereby ensuring the fabric will be cut right 
through. 

5 Because the boring knife does not require tie-in and tie-off stitches, 
deactivate these functions via Object Properties > Connectors.

6 Click Borers again to deselect it. This returns you to normal stitching. You 
now need to stabilize the fabric and create borders by stitching around them 
with zigzag and satin cover stitches.

7 Digitize around the hole with Column A together with zigzag stitch.
Place the inside edge close to the center of the hole so it ‘wraps’ the fabric. 

8 Digitize border stitching with Column A together with satin stitch.
Place the inside edge of the object close to the center of the hole. If you have 
used zigzag stitches for reinforcement, ensure they are covered.

Tip  As an alternative to Column A, use the Ring tool if available.

Digitize boring holes with 
Manual or Run stitch

Digitize borders with
Column A and Satin

Digitize reinforcement
with Column A and

Zigzag
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Caution  You should not use satin with a zigzag underlay because a run stitch 
is also generated (to return to the entry point). This can cause thread 
breakage.

Related topics
 Setting borer functions
 Filtering stitches & functions
 Digitizing individual stitches
 Digitizing outlines & details
 Adjusting automatic tie-in settings
 Stitch length
 Adjusting automatic tie-off settings
 Digitizing regular columns

Converting stitches to objects

By default, machine files are converted to outlines and objects upon opening. If 
you only want to convert selected parts of a design, you can open the file without 
object/outline recognition and process only the required stitch blocks. If you 
want to scale a design, edit an outline or change a stitch type, then the design 
or selected elements must be first converted into ‘objects’. 

Tip  To ensure object outlines, stitch types, stitch density and colors are correct, 
it is always a good idea to check and edit designs after conversion. To improve 
the quality of a machine file, it is often better to edit stitches before conversion. 
See also Opening machine files in EmbroideryStudio.

Recognizing object outlines

New or revised object outlines can be recognized after stitch edits have been 
made. This is useful with machine files which have been opened without 
Object/Outline recognition. You may do this to preserve the original stitching 
in most of the design, while modifying a single section of it. You may also want 
to turn edited stitches into an embroidery object in order to preserve the edits.

To recognize object outlines
1 Click the Stitch Edit icon and select the individual stitches you want to 

process.

Use Stitch > Stitch Edit together with Recognize Object/Outline to turn selected 
stitches into an embroidery object.

Stitches selected
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2 Select Stitch > Recognize Object/Outline. The selected stitches are 
converted to objects.

Related topics
 Opening machine files in EmbroideryStudio
 Selecting & editing stitches

Processing manual stitches

You can process manual stitches to recognize outlines or adjust size and stitch 
density. You can also use the Process Stitches feature to change stitch count 
and density for the whole design, or for objects of a particular stitch type only. 

Tip  You can also split larger manual objects into smaller objects, and process 
them individually.

To process manual stitches
1 Open a machine file without object/outline recognition.
2 Edit parts of the design as required.
3 Select the part of the design you want to process. You can select the whole 

design or individual manual objects.

Objects and
outlines created

Use Stitch > Process Stitches to adjust stitch density of and/or scale whole or 
selected parts.

Manual object
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4 Select Stitch > Process Stitches. The Process Stitches dialog opens.

5 In the Stitch Values panel, enter the number of Target Stitches as either 
a percentage or absolute value (in millimeters).

6 Adjust the density for each stitch type as required. You can change the 
density for selected objects and/or for specific stitch types only. 

7 Click Recognition to set advanced recognition options as required.
8 Click OK. Selected objects are processed and converted to Column A or Run 

objects with fill or outline stitch properties as well as general and connector 
properties. If an object is not recognized, it remains a manual object with 
general and connector properties only. In this case, the target stitch count 
may not be reached.

Note  Process Stitches adds the missing information to the file, but does 
not change the stitches.

Related topics
 Adjusting stitch densities
 Cutting, splitting & breaking objects
 Adjusting advanced recognition settings

Adjust stitch
densities

Enter target
stitch count

Adjust Pull
Compensation

Click to access 
advanced 
recognition 
options

Manual object converted to
Column A and Run

objects, or left as Manual
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PART VI

DECORATIVE EMBROIDERY

EmbroideryStudio provides many features for the creation of motif runs and fills, 
textured and patterned fills, open stitching, and curved fills.

Decorative stitching
This section describes how to create jagged or fluffy edges as well as open 
stitching with trapunto effect. It also describes how to create stippling and cross 
stitching, as well as accordion spacing, and color blending effects. Creating 
curved fills with ‘florentine’ and ‘liquid’ effects is also covered. See Specialty 
Stitching for details.

Patterned fills
This section explains how to create textures with tatami offsets and program 
splits. Create your own and add them to a custom library. Creating stitch 
patterns with carving stamps is covered as well as adding details with 
user-defined splits. See Patterned Fills for details.

Curved fills
This section covers contoured fills and flexi-splits. It also covers the creation of 
radial fill effects and curved fills. See Curved Fills for details.

Motif runs & fills
This section describes how to insert motifs into your design, and how to rotate, 
mirror and scale them. It explains how to manage motifs, including how to 
create your own motifs and motif sets. It also describes how to create both motif 
runs and motif fills, as well as how to apply 3D effects to motif fills. See Motif 
Runs & Fills for details.
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Chapter 23

Specialty Stitching

EmbroideryStudio provides many artistic effects and stitch types to create 
special fills. Create designs with a hand-drawn appearance, something which is 
difficult to achieve through conventional digitizing methods.

Create rough edges, shading effects, or imitate fur and other fluffy textures. 
Stippling provides a method for creating textured fills of run stitching which 
meanders more or less randomly within a border.
Create interesting perspective, shading and color effects by blending two colored 
layers. Move underlying travel runs to the edges of an object so that they can’t 
be seen through open stitching. Add cross stitching to fill large areas with low 
stitch counts. 

Creating freehand embroidery

The Freehand feature provides functionality similar to CorelDRAW® 
Graphics Suite Freehand and Polyline tools. Freehand has many benefits. It 
lets you create designs with a hand-drawn appearance, something which is 
difficult to achieve through conventional digitizing methods. The aim is to mimic 
the fluid and free-flowing effects formed by means of freehand stitching 
techniques.

Freehand stitching techniques

Use Graphics Digitizing > Freehand Open Shape to draw ‘freehand’ outlines on 
screen.

Use Graphics Digitizing > Freehand Closed Shape to draw ‘freehand’ closed 
objects on screen.
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Any of the outline stitch types can be used with Freehand open and closed 
curves. When Open Shape is selected, the Stitch Types toolbars offer a choice 
of Run, Triple Run, and other outline stitch types. When the Closed Shape tool 
is selected, the toolbar offers the full range of stitch types, both outline and fill. 
In addition, an ancillary Freehand Smoothing toolbar gives you control over 
freehand lines.

The possibilities offered by these options for creative, artistic expression are 
limitless. Especially when used with stylus pen tablets. Techniques include 
stitching on top of photographic images or detailed line drawings.

Alternatively, designs resembling pencil or charcoal sketches can be digitized. 
Use the tools to create ‘doodle’ type drawing effects without following detailed 
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artwork – for example, adding to a basic clipart design or decorative text and so 
on.

Related topics
 Setting angles & orientation

Creating freehand lines

Accessed from the Graphics Digitizing toolbar, the freehand feature is 
deployed in two forms: ‘Open Shape’ and ‘Closed Shape’. As with other digitizing 
tools, freehand tools can be used in conjunction with all stitch types. With these 
tools, however, you draw objects directly onscreen. It is thus possible to produce 
artistic effects similar to free-motion machine embroidery or ‘thread painting’.

Tip  The Embroidery tools can be operated with a mouse or WACOM pen.

To create freehand lines
 When digitizing with the Freehand tools, the Auto Scroll option needs to be 

turned off. Use the Ctrl+Shift+A key combination to toggle on/off.

Use Graphics Digitizing > Freehand Open Shape to draw ‘freehand’ outlines on 
screen.

Use Graphics Digitizing > Freehand Closed Shape to draw ‘freehand’ closed 
objects on screen.
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 Create open outlines with the Freehand Open Shape tool. Select any 
outline stitch and click and drag to draw. Release to finish.

 Try creating embroidered calligraphy by combining the Freehand Open 
Shape tool with Column C angle and orientation controls.

 To create closed outlines, use the Freehand Closed Shape tool in 
conjunction with an outline stitch.

 To create closed fills, use the Freehand Closed Shape tool in conjunction 
with a fill stitch.
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 If you want to close an open object, use the Edit > Close Curve with... 
command with the option of using straight or curved points.

Related topics
 Setting scroll options
 Setting angles & orientation

Adjusting freehand line smoothness

The Freehand tools have a special cursor. Adjust settings via the Freehand 
Smoothing toolbar. Also adjust curve ‘smoothing’ as you digitize.

To adjust freehand line smoothness
 Create a freehand design using outline and/or filled objects. The Freehand 

Smoothing toolbar opens.

 Adjust the freehand cursor as required:

 Adjust freehand line ‘smoothness’ by means of the slider bar. This determines 
how closely the outline follows the original. Adjust percentage to increase or 
decrease the number of control points generated.

Open object Close Curve with 
Curve Line

Close Curve with 
Straight Line

Use Graphics Digitizing > Freehand Open Shape to draw ‘freehand’ outlines on 
screen.

Use Graphics Digitizing > Freehand Closed Shape to draw ‘freehand’ closed 
objects on screen.

Tool Note

Use to toggle on/off freehand guide cursor.

Use to set the size of the inner circle in millimeters.

Use to set the number of circles in the cursor. If the inner circle radius is 
2mm, each additional guide circle is offset by 2mm.

No smoothing With smoothing
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 View and edit Freehand control points in Reshape mode.

 If you want to erase a portion of a line, press and hold the Shift key while 
dragging backward over the line before releasing the mouse.

 Alternatively, press the Backspace key. The last point digitized is removed.
 Release the mouse to finish the outline at the last point digitized. Or press 

Esc to cancel input of the object.

Note  Objects created using the Freehand tools can be reshaped in the same 
way as objects created via conventional methods.

Related topics
 Creating freehand lines
 Reshaping embroidery objects

Creating furry or fluffy edges

Use Jagged Edge to create rough edges, shading effects, or imitate fur and 
other fluffy textures. It can be applied to satin or tatami fills with or without 
patterns. It doesn’t work with Contour stitch.

No smoothing With smoothing

Hold the Shift key 
and drag back

Use Stitch Effects > Jagged Edge to create rough edges, shading effects, or imitate 
fur and other fluffy textures along one or more sides of selected objects.
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To apply Jagged Edge
 Click the Jagged Edge icon. The effect is applied to new or selected objects, 

based on current Jagged Edge settings.

Tip  For objects filled with tatami, use diagonal backstitch for best results. 
 Right-click the Jagged Edge icon to access object properties.

 Select a side – Side 1, Side 2, or Both Sides.

 In the Roughness field, enter a value between 1 and 10 to set the degree of 
jaggedness.

Side 2 jaggedSide 1 jagged Both sides jagged

Adjust 
roughness

Select Jagged 
Edge

Side 2 Side 1Both Sides

Roughness: 1
Range: 5

Roughness: 5
Range: 5

Roughness: 10
Range: 5
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 In the Range field, enter the margin within which you want stitches to fall.

Related topics
 Other tatami settings

Creating stippling effects

Stippling is a method for creating textured fills of run stitching which meanders 
more or less randomly within a border. It can be applied to any closed objects. 
Stitch angle has no effect.

To create a stippling effect
 To apply a stipple fills after digitizing, select any closed object.

Range: 1.5
Range: 4

Use Fill Stitch Types > Stipple Fill to create stippled fills of run stitching which 
meanders more or less randomly within a border. Right-click for settings.

Use Fill Stitch Types > Stipple Backstitch to create a backstitch fill which meanders 
randomly within a border. Right-click for settings.

Use Fill Stitch Types > Stipple Stemstitch to create a stemstitch fill which meanders 
randomly within a border. Right-click for settings.
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 Click the Stipple Fill icon. Stipple fill is applied and the Object Properties 
docker opens.

 Adjust Run Length as required.

 Adjust Min Length (minimum stitch length) and Chord Gap as required.

 Adjust Run Count setting for a thicker line.
 Adjust Loop Spacing as required.

Adjust stipple 
settings

Stitch length: 0.25 mm Stitch Length: 0.75 mm Stitch Length: 1.5 mm

Min length: 0.1 mm
Chord Gap: 0.01 mm

Min length: 0.4 mm
Chord Gap: 0.03 mm

Min length: 0.7 mm
Chord Gap: 0.05 mm

Loop Spacing: 1.0 mm Loop Spacing: 2.0 mm Loop Spacing: 3.0 mm
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 Set a margin from the object outline by adjusting the Inset value.

 Use Stipple Stemstitch and Stipple Backstitch as preferred.

Related topics
 Breaking apart composite objects

Creating open stitching with trapunto

The Trapunto effect automatically moves underlying travel runs to the edges of 
an object so they can’t be seen. It is available with complex fill objects using 
tatami stitching. In EmbroideryStudio, the effect is typically used in combination 
with open stitching to fill backgrounds or for shading effects. Without it, travel 

Inset: 1.0 mm Inset: 3.0 mm Inset: 5.0 mm

Stipple Stemstitch Stipple with SatinStipple Backstitch

Use Stitch Effects > Trapunto to force underlying travel runs to the edges of a 
selected object. Right-click to adjust Trapunto settings.
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runs, spacing variations and overlapping rows between segments are visible and 
can spoil the effect.

Accordion Spacing extends the usefulness of Trapunto by providing a simple way 
to produce variation in a filled pattern and the illusion of depth. Trapunto and 
Accordion Spacing can also be combined with Liquid and Florentine effects to 
produce curved color blending.

To create open stitching with trapunto
1 With or without a complex fill object selected, right-click the Tatami icon to 

access object properties.

2 In the Spacing field, enter the required stitch spacing. The larger the value, 
the more open the spacing.

3 Press Enter.
4 With the complex fill object selected, click the Trapunto icon.

Adjust stitch 
spacing

Spacing: 3 mmSpacing: 5 mm
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Travel runs and overlapping rows are removed and consistent row spacing 
applied.

Note  Trapunto effect overrides whatever tatami backstitch settings currently 
apply.

Related topics
 Other tatami settings
 Creating color blends
 Creating curved fills

Creating accordion spacing effects

The Accordion Spacing feature varies stitch spacing between dense and open 
fill, producing gradient and shading effects which are difficult to achieve 
manually. It provides a simple way to produce variation in a filled pattern and 
the illusion of depth. It is best used with tatami fill. When applied, current 
settings – including Auto Spacing and Fractional Spacing – are ignored. 
However, other settings still apply, including stitch angle.

To apply Accordion Spacing
 Click the Accordion Spacing icon. The effect is applied to new or selected 

objects, based on the current Accordion Spacing settings.

Tip  Because of the open stitch, Accordion Spacing is best used without 
Auto Underlay.

Click Stitch Effects > Accordion Spacing to create perspective and shading effects. 
Right-click to adjust settings.
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 Right-click the Accordion Spacing icon to access object properties.

 In the Profile panel, select a spacing effect.

 In the Spacing panel, adjust spacing values:

 Use the Reshape tool to adjust the angle of the gradient fill. See also 
Adjusting stitch angles.

Tip  Apply Trapunto effect to force underlying travel runs to the edges of an 
object so that they can’t be seen through open stitching. It’s also a good idea 
to turn off Auto Underlay.

Select spacing 
effect

Adjust spacing 
settings

Maximum 
spacing

Minimum
spacing
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Related topics
 Applying automatic underlay
 Creating open stitching with trapunto 

Creating color blends

From sunsets to wood grains, Color Blending creates interesting color blends. 
Use it with standard tatami to create depth and shading. Two colors are merged 
smoothly from one to another using a mixture of dense and open fill. The effect 
is generally applied to Complex Fill objects. Curved color blends can be created 
with Column A or Column B objects

Objects with Color Blending can be resized, rotated and skewed without losing 
the color blending effect. However, editing a color-blended object is limited. The 
two components must first be ungrouped and separate objects edited according 
to Accordion Spacing settings such as color, profile, and spacing.

Use Toolbox > Color Blending to generate color blends, perspective effects and 
shading in selected objects.
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To create a color blend
 Select your tatami object and click the Color Blending icon. The Color 

Blending dialog opens.

 Select complementary profiles for top and bottom layers. Generally you will 
want to use opposites but you can also mix and match completely different 
profiles.

 Choose complementary colors for each layer and adjust spacing settings.
Generally, you will want to use the same values so that rows blend into one 
another.

 Click OK to generate.

Note  To prevent underlay stitching from showing through, Auto Underlay 
is deselected by default and Trapunto effect applied.

To adjust settings
 Select the blended object and press Ctrl+U to ungroup. 
 Select a component object and change color as required.
 Double-click the object to open Object Properties.

Select first
Spacing effect

Select first color

Select second color

Select second
Spacing effect

Select first
spacing

Select second
spacing

Maximum 
spacing

Minimum
spacing
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 Click the FX button and select the Accordion tab.

 Select a profile and adjust spacing as preferred.

 Repeat the process for the second object and re-group both.

Related topics
 Stabilizing with automatic underlay
 Creating open stitching with trapunto
 Creating accordion spacing effects

Creating string stitching

Select spacing 
effect

Adjust spacing 
settings

Linear Profile Exponential Profile Convex Profile Wave Profile

Use Fill Stitch Types > String to create string craftstitch fills. Apply to closed shapes.

Use Outline Stitch Types > String to create string craftstitch outlines for delicate 
borders. Apply to open or closed shapes.

Use Traditional Digitizing > Digitize Run to create row of single stitches along a 
digitized line.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Traditional Digitizing > Ring to digitize circle and oval-shaped rings.
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String stitch type is ideally suited to creating craftstitch fills as well as delicate 
borders. It can, for instance, be used as a border for fixing ornamental mirrors 
and sequins. Apply to open or closed shapes.

Most String stitch effects can be achieved by quite simple means. Since stitch 
angles have no effect, you can digitize most shapes with simple tools such as 
Run or Complex Fill. String outline provides spacing and chord length settings 
for control of outline thickness and density. Reversing entry and exit points will 
also affect the direction of stitch overlaps.

String fill provides a spacing setting for control of stitch density. Thickness is 
determined by the shape. Try using it with both closed objects and objects with 
holes such as Ring objects. Direction of stitch overlaps is controlled by the 
Direction setting.
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The Coverage setting can be used create partial covers such as the ones below. 
Control orientation either via the Direction setting or by changing entry/exit 
points.

Related topics
 Digitizing outlines & details
 Creating free-form shapes
 Digitizing stars & rings

Creating chenille-type patterns

EmbroideryStudio provides a number of stitch patterns traditionally associated 
with chenille work – Square, Double Square, Coil, and Island Coil. The 
pattern you use depends on input tool used as well as object shape, size and the 
effect you want to achieve.

While these patterns are normally used with chenille designs, they can also be 
used as decorative lockstitch pattern types. Of course lockstitch machines can’t 
produce actual chenille chain or moss stitching, except with the aid of a ‘Simple 
Chenille’ device. However, the patterns themselves can create other forms of 
decorative, open stitching using run stitches.

Square stitching

Square stitching is similar to Tatami and is suitable for use with most 
closed-object input methods. 

Coil stitching for 
perspective and depth

Island Coil for 
texture



EmbroideryStudio e4 User Manual 465

Square stitch

Square is suitable for narrow objects digitized with most closed-object input 
methods. You can fill areas diagonally, or on the horizontal and vertical. All 
stitches generated along a row are of same length. However, some shorter 
stitches are generated where the shape is narrow and between rows of stitching. 
You could obtain a similar effect using open tatami with borderline backstitch, 
but Square stitch makes it simpler to achieve. Use it to create a ‘chenille look’ 
using cord and adjusting the presser foot height to create loops.

You can set the Square stitch values for stitch length and spacing as well as 
stitch angle for the second layer of Double Square stitching.

Tip  Limit travel runs showing through the stitching by changing entry and exit 
points to reduce segmentation within the shape.

Double Square stitch

Use Outline Stitch Types > Square to create open borders or columns of even width 
for an open ‘toothed’ effect. Right-click for settings.

Use Fill Stitch Types > Square to create open straight parallel fills. Right-click for 
settings.

Use Fill Stitch Types > Double Square to create grid fills. Apply closed shapes. 
Right-click for settings.

Column C + Square

Column B + 
Square

Column A + Square

Stitch spacing

Stitch
length Stitch angle
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Double Square is the most common fill stitch used in chenille work. It is 
suitable for large closed areas. Stitch angles have no effect on this stitch type. 
It is made up of two layers of Square stitch. Typically, the second layer of fill is 
perpendicular to the original fill with 45° and 135° used. Like Square stitch, you 
can use Double Square to create a ‘chenille look’ using cord and adjusting the 
presser foot height to create loops. Double square creates a denser fill.

Coil stitching

Coil stitching is more similar to Satin and is suitable for use with most 
closed-object input methods. Stitches are generated in spirals. 

Coil stitch

Coil fill is suited to narrow shapes or columns where each stitch traverses the 
width of the column. It provides a convenient way to fill an area with open 
stitching. Stitches are generated along curved lines and coils generate 
consistent stitch length even over different widths. This produces a smooth 
finish which does not unravel easily. Coil is generally applied to objects created 
with Column A, Column B and Column C. 

Use Outline Stitch Types > Coil to create borders or columns of even width for an 
open ‘coil’ effect. Right-click to adjust settings.

Use Fill Stitch Types > Coil to stitch narrow shapes or columns where each stitch 
traverses the column width. Right-click to adjust settings.

Column C + Coil

Column B + 
Coil

Column A + Coil
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You can adjust Coil settings for stitch length, coil spacing and width.

Column A/B objects can be used with variable width Coil stitching, while 
complex fill objects will default to Island Coil.

Similarly, Column C objects can be used with variable width stitching.

Island Coil fill stitch

Island Coil is used to fill larger closed areas. This technique allows complex 
shapes to be filled with concentric rows of coil stitching, simulating the circular 

Use Fill Stitch Types > Island Coil to fill large Complex Fill objects with concentric 
rows of coil stitching, simulating the circular motion of hand-chenille embroidery. 
Right-click to adjust settings.

Coil spacing

Stitch
length

Coil width

Column A/B with coil

Complex fill with island coil

Column C with coil
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motion of hand-chenille embroidery. Stitch angles have no effect on this stitch 
type. 

Coil direction
For some machines, best results with Coil are achieved by sewing in a 
counterclockwise direction because when you sew in a clockwise direction, you 
are adding more twist to the yarn causing it to become tighter, distorting the 
moss stitch loops. Refer to your machine handbook for details.

Creating cross stitch fills

Cross stitching is a popular technique for filling large areas with low stitch 
counts. Cross stitch is also sometimes combined with appliqué. Cross Stitch fill 
is something like Motif Fill but is generated differently. 

Crosses in different objects line up precisely if using the same fabric count. This 
is because cross stitch fills are generated on a universal grid, not just referenced 
to the individual object. Fractional crosses are generated at object boundaries in 
order to avoid gaps forming. Cross Stitch fill uses travel runs under and along 
the cross stitching.

Note  Cross Stitch fill is a stitch type in its own right but does not replace the 
ES Cross Stitch application available via the File menu. See also 
EmbroideryStudio Cross Stitch Supplement.

Ideal loop Extra-twisted yarn loop

Use Fill Stitch Types > Cross Stitch to fill large areas with low stitch count 
cross-stitch fills.



EmbroideryStudio e4 User Manual 469

To create a cross stitch fill
 Create or select a closed-object and click the Cross Stitch icon.

Current Cross Stitch settings are applied. Auto Underlay and Pull 
Compensation are automatically deactivated. Stitch angle has no effect on 
the pattern layout.

 To change settings, double-click or right-click the object/s to access object 
properties.

 Adjust Fabric Count settings to match the fabric size you are working with.

 Choose a stitch style.

Cross Stitch 
settings

Fabric Count: 
10.0 stitches/inch

Fabric Count: 
14.0 stitches/inch

Fabric Count: 
6.0 stitches/inch

Stitch Style: Upright Cross Stitch Style: Full Cross
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 Adjust other cross stitch settings as desired:

Tip  The cross stitch grid is not displayed but you can set the background grid 
to the cross size to get a better idea. Use Snap to Grid to ensure that your 
object outlines line up with the cross stitch grid.

Related topics
 Creating motif fills
 Embroidery digitizing
 Setting grid display options

Field Description

Fabric count Controls the size of cross specified as a counted fabric rather than 
an actual cross size.

Threads Sets thread count – e.g. 2, 4 or 6 – which determined number of 
times thread passes over the same cross in order to make it bulkier.

Stitch style Full cross (X), diagonal (\), or upright (+).

Floss direction Controls direction of top leg of the cross – forward or backward for 
diagonal full crosses, horizontal or vertical for upright full crosses.
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Chapter 24

Patterned Fills

EmbroideryStudio provides tools 
for creating patterns with needle 
penetrations. 
Apply offset fractions or partition 
lines to tatami fills for a variety of 
split-line patterns. Alternatively, 
use Program Split or Flexi Split 
to create decorative fills from 
pre-defined patterns. Select from 
the library or create your own. 
The Carving Stamp feature 
allows you to define patterns using 
a ‘carving stamp’ as a template. 
Use it also to create your own split 
lines when you want to add detail 
to filled objects.
This section explains how to create 
textures with tatami offsets and 
program splits. Create your own 
and add them to a custom library. 
Creating stitch patterns with carving stamps is covered as well as adding details 
with user-defined splits.

Creating textures with tatami offsets

With tatami fills you can create patterns of needle penetrations. With only two 
offsets available, the number of patterns is limited, but even with small offsets, 
visible lines are produced. Partition lines, with up to eight offsets, can create 
more patterns. Using a random factor you can distribute needle penetrations 
randomly.

Tip  Auto Split can be used to create special textures in satin stitches as an 
alternative to tatami fill. See Splitting satin stitches for details.
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Creating offset patterns

The tatami offset default settings are designed to create a uniformly flat and 
smooth surface. The texture is like a woven tatami mat without obvious split 
lines. By manipulating offset fractions, you can create stitch penetrations which 
are more clearly visible.

Tip  By adjusting offsets, you can also improve the quality of turning tatami 
where the pattern may be disturbed by non-parallel stitches. Changing the 
offsets can reduce this interference.

To create offset patterns
1 Right-click the Tatami icon to access object properties.

2 Select the Offset Fraction option. To control needle penetrations you set 
offset fractions for both forward and backward rows. 

3 In A and B fields, experiment with offset fraction values. Offsets are defined 
as fractions of stitch length – e.g. 0.3 = 30%.

 Even stitching: set both fields to 0.25.

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. Right-click 
for settings.

Specify offset fractions 
for alternate rows

A=0.00, B=0.00 A=0.50, B=0.50 A=0.25, B=0.25

A=0.50, B=0.25 A=0.30, B=0.60 A=0.40, B=0.00
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 Strong horizontal lines: set both fields to 0.00 or 1.00. The distance 
between each line of needle penetrations is the stitch length.

 Light horizontal lines: set both fields to 0.5. Lines are produced at half 
stitch-length intervals.

 Diagonal lines: set both fields to any value other than 0.00, 0.50 and 
1.00. Diagonal lines are less noticeable than horizontal or vertical lines. 
Vary both values to change the angle of the lines and the distance between 
them.

 Other: set one field to 0.00, and experiment with the other values to 
place the needle penetrations on the forward and backward rows close to 
each other, but with different effects.

Note  If A-B offsets add up to 1.0, lines will be horizontal. If the sum is less 
than 1.0, lines will slope down, more and they slope up. The mirror image of 
‘A=0.3 and B=0.6’ is ‘A=0.7 and B=0.4’.

Tip  Tatami patterns can be combined with curved fills for interesting effects.

Related topics
 Creating curved fills

Creating partition line patterns

The Partition Line feature provides an alternative method for offsetting needle 
penetrations in tatami fills. The Object Properties > Fills > Tatami docker 

Offset: A=0.3, B=0.6
Stitch length: 4 mm

Offset: A=0.3, B=0.6
Stitch length: 3 mm

Offset: A=0.3, B=0.6
Stitch length: 2 mm

A=0.30, B=0.60 A=0.50, B=0.50 A=0.70, B=0.40

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. Right-click 
for settings.
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allows you to set partition lines. Two parameters can be set – Sequence and 
Angle.

Sequence
Partition Line allows you to specify up to eight tatami offsets. In any pattern, 
number of rows is determined by number of digits in the sequence. 

Each stitch length is split into ‘knots’ numbered anywhere from 0 to 7. A partition 
sequence number of ‘20163’ would translate to the following pattern:

Angle
You can skew the grid formed by the partition knots to further vary the needle 
penetrations. In the Angle field, specify a grid angle.

Tip  Tatami patterns can be combined with curved fills for interesting effects.

Related topics
 Creating curved fills

Select Partition Line

Enter partition sequence 
and grid angle

Sequence: 11 Sequence: 012 Sequence: 01

Stitch length

Row 1

Row 2

Row 3

Row 4

Row 5

Knot 2

Knot 0

Knot 1

Knot 6

Knot 3

Sequence: 11
Angle: 0

Sequence: 11
Angle: 45

Sequence: 11
Angle: 90
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Creating random patterns

Using a random factor you can eliminate the split line patterns formed by regular 
needle penetrations and distribute the stitches randomly inside the shape. This 
can create interesting mottled effects.

To create random patterns
1 Right-click the Tatami icon to access object properties.

2 In the Random field, specify a random factor between 0% and 100%. 

Tip  A value of around 50% generally gives good results.

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. Right-click 
for settings.

Enter a random factor

Random factor: 10%
Offset fraction A: 0.25, B: 0.25

Random factor: 50%
Offset fraction A: 0.25, B: 0.25

Random factor: 100%
Offset fraction A: 0.25, B: 0.25
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Creating textures with program splits

Program Split is a decorative fill stitch where needle penetrations form a tiled 
pattern. Select a pre-defined pattern or create your own.

Applying program splits

You can apply Program Split to a wide variety of objects. You can adjust these 
either before or after applying the effect. Choose from a library of split patterns. 

Note  Digitize the stitch angle carefully when creating objects with program 
splits. If rows are parallel with pattern lines, they will rarely intersect and the 
pattern may not be visible. A 45° stitch angle is suitable for most patterns.

To apply program splits
 Click the Program Split icon. Program Split stitching is applied to new or 

selected objects, based on current settings.
 Right-click the Program Split icon to access object properties.

Use Fill Stitch Types > Program Split to create decorative fill stitches where needle 
penetrations form a tiled pattern. Right-click for settings. 

Use Outline Stitch Types > Program Split to create borders or columns of even 
width for decorative needle penetration patterns. Right-click for settings. 
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 Select a pattern from the droplist. Alternatively, click the arrow button to 
access the pattern library.

 Adjust pattern size via Size X/Y fields. The scaling lock maintains aspect 
ratio. Use the Angle setting to orientate the pattern within the shape.

Tip  Tatami patterns can be combined with curved fills for interesting effects.

Related topics
 Creating curved fills
 Program Split Samples

Applying combination splits

Standard program split consists of a satin foreground and background – i.e. 
Satin-in-Satin. If patterns do not overlap you may get jump stitches or gaps 

Pattern preview

Choose from
the pattern

library

Select a pattern

Enter pattern width 
and height

Default values Size X and Size Y 
increased

Angle adjusted

Use Fill Stitch Types > Program Split to create decorative fill stitches where needle 
penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of even 
width for decorative needle penetration patterns. Right-click for settings. 
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occurring in the background. In this case, you can select from different 
combinations of satin and tatami stitches.

To apply combination splits
1 Right-click the Program Split icon to access object properties.

2 In the Combination Split panel, click the desired option:

Options include:

Program split settings

You can adjust program splits both interactively on screen and via object 
properties.

Combination 
Split

Description

Satin-in-Satin This is the standard program split stitch type, which produces the 
smallest number of stitches.

Satin-in-Tatami Use this option to avoid long stitches when the patterns are small 
but column and row spacings are wide.

Tatami-in-Tatami Both foreground and background use tatami. Select this option for 
large objects and patterns to avoid long stitches.

Satin-in-Tatami

Tatami-in-TatamiSatin-in-Satin

Satin-in-Satin Satin-in-Tatami Tatami-in-Tatami

Use Fill Stitch Types > Program Split to create decorative fill stitches where needle 
penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of even 
width for decorative needle penetration patterns. Right-click for settings. 
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Column & row spacing
Column and row spacing settings determine distance between grid lines. 
Patterns are placed at intersection points – the center of each pattern coincides 
with an intersection.

The initial settings define a simple grid, where the spacing equals the dimensions 
of the pattern. The row offset is set to 0.00 mm so columns and rows are 
perpendicular.

Column & row offsets
With all three program split combinations – Satin-in-Satin, Satin-in-Tatami 
and Tatami-in-Tatami – you can vary the pattern by applying offset settings 
to rows and/or columns. You can also provide background texture with tatami 
stitch offsets. 

If both offsets are set to ‘0’, grid lines are perfectly vertical and horizontal. As a 
rule, it only makes sense to use values between 0 and half the pattern size. For 
example, if the pattern is 8 mm, select row and column offsets between 0 mm 
and 4 mm.

Column spacing increased Row spacing decreasedDefault spacing values

Set column spacing 
and offset values

Set row spacing 
and offset values

Column offset: 0.00  Column offset: 1.00  Column offset: 2.50

Row offset: 0.00  Row offset: 1.00  Row offset: 2.50
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Stitch settings
Specify stitch length, minimum stitch length and spacing settings for program 
split objects, in the same way as for other fill stitch types. You can eliminate 
unwanted patterns and distribute stitches evenly within a shape using a random 
factor.

In the Stitch Spacing field, enter the required spacing. For tatami this is the 
distance between two forward rows of stitches, for satin, the distance between 
each forward stitch.

Enter a value in the Random field – specify a factor between 0% and 100%. 
The random factor does not affect the deliberate needle penetrations that form 
the pattern. Values of around 50% generally give good results.

Tatami stitch offsets
When using Satin-in-Tatami or Tatami-in-Tatami, you can also control tatami 
stitch offsets.

Adjust stitch spacing, length 
and minimum length

Enter random factor

Stitch spacing increased Stitch spacing decreasedDefault spacing values

Random factor: 25%  Random factor: 90%Random factor: 0%
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Tatami is mainly used to avoid long stitches, so it should not have a distinct 
appearance which may obscure the program split pattern. Therefore, typical 
offsets are in the range 0.2 mm to 0.4 mm.

Enter a stitch offset in the Stitch > Offset A field. This offset controls where 
the needle penetrations line up for each row of stitching. 

Related topics
 Creating textures with tatami offsets

Laying out program splits on-screen

You lay out program splits on-screen in a similar way to Motif Fills by using ‘guide 
patterns’ to scale, space, transform and offset the entire pattern fill.

To lay out program splits on-screen
1 Right-click the Program Split icon to access object properties.

2 Select a pattern from the droplist. Alternatively, click the arrow button to 
access the pattern library.

Enter stitch 
offset

 Offset A: 0.00  Offset A: 0.25  Offset A: 0.50

Use Fill Stitch Types > Program Split to create decorative fill stitches where needle 
penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of even 
width for decorative needle penetration patterns. Right-click for settings. 

Select pattern

Click to change
pattern layout



Chapter 24   Patterned Fi l ls 482

3 Click Layout. Three blue guide patterns allow you to change the layout.

4 Adjust the guide patterns to achieve the desired effect:
 Move patterns by selecting the middle guide pattern and dragging.
 Scale patterns by selecting a guide pattern and dragging selection handles.

 Rotate patterns by clicking the middle guide twice to display the rotation 
handles. Click a corner handle and drag to rotate. 

 Skew patterns by clicking the middle guide twice, then dragging the skew 
handles. 

 Change column spacing by selecting the side guide and dragging it left or 
right.

 Change column offset by selecting the side guide and dragging it up or 
down.

Use top guide pattern to change row 
spacing, row offset, and to scale patterns

Use side guide pattern to change 
column spacing, and to scale 
patterns

Use middle guide pattern to
move, rotate, skew, and

scale patterns

Drag the 
pattern

Scale
proportionally

Scale 
horizontally

Scale 
vertically

Rotate

Skew

Anchor

Change column 
spacing

Change offset
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 Change row spacing and offsets in the same way as columns.

5 Press Enter to apply.

Related topics
 Program Split Samples
 Laying out motif fills on-screen

Making custom splits

Make your own patterns to use in Program Split fills. The same patterns can 
also be used with Flexi Split effects.

Making split patterns

Make your own patterns to use in program split fills. Create patterns from the 
outlines of embroidery objects or from drawing objects. Patterns you create can 
also be used for Flexi Split effects. 

To make a split pattern
1 Select the object (or objects) you want to use for the pattern.

Change row 
spacing

Change offset
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2 Select Object > Create Program Split.

3 Enter a name in the Create Program Split dialog.
4 Click OK. 

The new pattern is automatically selected in the Pattern list.

Related topics
 Creating textures with program splits
 Creating flexi-splits

Editing split patterns

Editing a pattern changes the actual pattern, not just the object layout.

To edit a split pattern
1 Right-click the Program Split icon to access object properties.

2 Select a pattern and click Edit.

3 Press Shift+0 to zoom in on the pattern.
4 Scale, transform or reshape the pattern as required.
5 Select Object > Create Program Split with the pattern selected.

6 Enter a name for the pattern in the Create Program Split dialog.
 To create a pattern based on the old one, enter a new name.
 To overwrite the original pattern, enter the name of the original.

7 Click OK. The pattern is automatically selected in the Pattern list.

Enter pattern
name

A-My Program Split

Select pattern

Click to edit pattern 

Edit pattern

Enter pattern
name

A-My New Program Split
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Related topics
 Creating textures with program splits
 Creating flexi-splits

Creating user-defined splits

The User-Defined Split function lets you add detail to filled objects by digitizing 
lines of needle penetrations called ‘split lines’. Split lines are stored as object 
properties. They are preserved when stitches are regenerated even if you apply 
a different stitch type. Satin is the most suitable stitch type for User-Defined 
Split.

To create new objects with User-Defined Split
1 Select a fill input method and stitch type.
2 Click the User-Defined Split icon.
3 Digitize the object boundaries, entry and exit points and stitch angle as you 

normally would, following the prompts in the Prompt Line.
4 Digitize a split line over the object when prompted, then press Enter. Repeat 

this step for additional split lines.

Use Stitch Effects > User-Defined Split to create your own split line effects. 
Right-click to adjust settings.

Digitize object outline Digitize split line Generate stitches
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Tip  For best results, digitize split lines approximately perpendicular to the 
stitch angle.

5 Press Enter.

Related topics
 Digitizing custom splits

Creating patterns with carving stamps

The Carving Stamp feature allows you to define a pattern of needle 
penetrations using a ‘carving stamp’ as a template. A carving stamp can be any 
vector or embroidery shape.

Carving Stamp docker
The Carving Stamp docker contains four tabs: Use Pattern, Use Object, 
Digitize, and Appearance.

 The Use Pattern tab lets you select and apply pre-defined stamp patterns to 
selected objects. 

 The Use Object tab allows you to select object outlines in the design window 
for use as a temporary stamp. Selectable objects can include vector graphics. 

 The Digitize tab allows you to digitize custom splits ‘on the fly’. 
 The Appearance tab allows you to soften or intensify the effect.

Select a tab
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Applying pre-defined patterns

The Use Pattern tab lets you select and apply pre-defined stamp patterns. You 
can start with or without embroidery objects selected. If one or more objects is 
selected, stamps are only applied to selected objects. If no object is 
pre-selected, stamps can be applied to any objects.

To apply pre-defined patterns
1 Select an embroidery object or not as required.
2 Click the Carving Stamp icon. The Use Pattern tab is open by default.

3 Select a pattern set from the Set list. The droplist contains pre-defined 
pattern sets as well as custom sets. Many are shared with other features such 
as Monogramming.

4 Select a pre-defined stamp pattern. A thumbnail appears in the preview panel 
and the Use Stamp button is enabled.

5 Click the Use Stamp button and move the mouse pointer to the design 
window. 

6 Move the mouse pointer to the desired position over the target object/s.
 Right-click to mirror the stamp.
 Press Shift to prevent Auto Scroll.

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.

Select a pattern 
set

Select a stamp 
to use
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7 Click the mouse button to fix the anchor point.

8 Swivel the pattern about the anchor point to the desired guide point position.
9 Optionally, with the Shift key pressed, resize the stamp while moving the 

mouse pointer. 
10 Click the mouse button.
 If you have pre-selected an object or objects, the stamp pattern is applied 

only to those objects.
 If no objects are pre-selected, the stamp pattern is applied to any 

underlying objects.
11 Press Esc to exit the feature.

Note  The Rename and Delete buttons are enabled whenever a custom 
stamp is selected. When the Rename button is clicked, the Rename Split 
Pattern dialog opens. 

Tip  Use the Softened Stamp and Raised Stamp options on the 
Appearance tab to soften or accentuate the effect. 

Related topics
 Adding stamps to a library
 Carving stamp appearance

Using objects as carving stamps

The Use Object tab allows you to select object outlines from the design window 
and apply them directly as stamps or save them to a library for future reference. 
You can use vector or embroidery objects as a basis for stamps.

Enter name for
new library set

My new pattern

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.
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To use an object as a carving stamp
1 Choose an embroidery object or vector object to serve as your stamp.

2 Click the Carving Stamp icon and select the Use Object tab.

3 Click the Start Selecting button. Any pre-selected objects remain selected.
4 Hover the mouse over any object in the design window.
5 Click the Use Stamp button to apply the selection as a carving stamp.

6 Optionally, click the Add to Library button to add the selection to the library 
for future reference.

Select ‘Use 
Object’ tab
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Tip  You can also use lettering, embroidery or TrueType, as an input to stamp 
creation. 

Tip  If you want to use a bitmap image, you can convert to vector format in 
CorelDRAW Graphics using the Bitmaps > Outline Trace command set.

Related topics
 Adding stamps to a library

Digitizing custom splits

The Digitize tab allows you to digitize split lines and directly apply in situ or to 
any applicable objects in the design window.

Select character to 
use as stamp

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.
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To digitize custom splits
1 Select an embroidery object or not as required. If embroidery objects are 

pre-selected, digitized stamps will apply only to these objects.

2 Click the Carving Stamp icon and select the Digitize tab of the dialog.

3 Click the Start Digitizing button. You are prompted to enter a starting point 
for the stamp outline.

4 Digitize split lines:
 Press Enter once to complete a boundary.
 Press Enter again to finish stamp digitizing.

5 Click the enabled Stamp button.

Click to start 
digitizing
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 Click the Stamp button to apply the stamp to selected applicable objects 
only.

 Alternatively, use Stamp to apply the stamp to applicable objects with no 
object/s selected. Every object beneath the stamp is affected.

 Click the Use Stamp button to position the stamp. You are prompted to 
enter an anchor point as with pre-defined patterns. 

6 Optionally, click the Add to Library button to add the selection to the library 
for future reference. 

Related topics
 Applying pre-defined patterns
 Adding stamps to a library

Adding stamps to a library

This procedure starts when you click the enabled Add to Library button either 
on the Use Object tab or Digitize tab in the Carving Stamp docker.

Stamp applied with 
object/s selected

Stamp applied with no 
object/s selected

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.
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Tip  The Carving Stamp feature can only use vector or embroidery objects as 
a basis for stamps. If you want to use a bitmap image, you can convert to vector 
format in CorelDRAW Graphics using the Bitmaps > Outline Trace 
command set.

To add a stamp to a library
1 Select an object which you want to add to the library as a custom stamp.
 Digitize carving stamps on the spot using the Carving Stamp > Digitize 

tab.
 Define carving stamps using the Carving Stamp > Use Object tab. 

2 On either of these tabs, click the enabled Add to Library button. The Create 
Split Pattern dialog opens.

3 Select a set from the droplist or click the Create button to create a new 
library.
If you chose to create a new library set, use the New Pattern Set dialog to 
create a new stamp set. The newly created stamp set is displayed in the Set 
list when the Use Pattern tab is selected. 

4 Enter a new stamp name and click OK. You are prompted to digitize the first 
reference point in the design window.

5 Enter the first reference point:
 Press Enter to have the reference point created automatically.

Click to add
to library

Bitmap converted using 
Graphic mode Bitmaps > 
Outline Trace command

Select library set
from droplist

Enter name for
new stamp

My special pattern

Enter name for
new library set

My custom pattern set
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 Move the mouse pointer to the position you want to use as the anchor 
point during manual stamp placement, and left-click.

6 Enter the second reference point:
 Press Enter to have the reference point created automatically.
 Move the mouse pointer to the position you want to use as the guide 

point during manual stamp placement and left-click.

7 Click OK. The newly created stamp is displayed in the stamp list when the 
Use Pattern tab is selected.

Note  The Rename and Delete buttons are enabled in the Use Patterns tab 
whenever a custom stamp is selected. 

Related topics
 Digitizing custom splits
 Using objects as carving stamps
 Applying pre-defined patterns

Carving stamp appearance

The Appearance tab of the Carving Stamp docker provides settings which can 
help to soften or intensify the effect. 

Enter first 
reference point

Enter second 
reference point

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.

Appearance 
options
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 Checking the Softened Stamp checkbox causes any existing stamp/s to be 
softened.

 Checking the Raised Stamp checkbox cause any splits within the combined 
closed boundaries of a carving stamp to be removed.

Note  Clicking the Clear All Stamps button will cause all existing stamps to 
be removed from selected objects.

Reshaping carving stamps

Carving stamps can be moved, rotated, scaled, reshaped, and deleted 
individually in Reshape mode. As you transform carving stamps, needle 
penetrations in the underlying object are automatically updated. 

To reshape a carving stamp
 Select an embroidery object in Reshape mode with carving stamps applied. 

A diamond selection handle is displayed at the center of each stamp.

Unadjusted appearance Softened appearance Raised appearance

Use Reshape Tools > Reshape Object to reshape selected objects by means of 
control points.

Use Reshape Views > Show Reshape Nodes to toggle reshape-node display when 
using the Reshape Object tool.

Click a diamond 
selection handle
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 Select the diamond selection handle. Another set of sizing, stretching and 
rotation handles appears.

 Drag the diamond to move the stamp. Holding down the Ctrl key will 
constrain the movement to the horizontal or vertical axis.

 Drag a corner sizing handle to scale the stamp.

 Hold down the Shift key to scale stamp from the center.
 Hold down the Ctrl key to scale stamp proportionally. 
 Hold down both Ctrl and Shift keys while dragging a corner sizing handle 

to scale stamp proportionally about the center.

Drag diamond

Drag corner 
sizing handle
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 Drag a stretching handle to stretch the stamp. Hold down the Shift key to 
stretch from the center.

 Drag the rotation handle to rotate the stamp.

 Click the stamp outline to display control points. Use these to reshape the 
stamp.

Drag stretching 
handle

Drag rotation 
handle
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Chapter 25

Curved Fills

EmbroideryStudio provides a variety of stitch types and techniques fore creating 
curved stitching. 

Contour is a curved fill stitch type – stitches follow the contours of a shape, 
creating a contoured, light and shade effect. Flexi Split is a decorative effect 
where one or more lines of a program split pattern are used in the object fill. 
Radial Fill generates radial turning stitching in several stitch types such as 
Satin, Tatami and Program Split stitch. Use Florentine Effect or Liquid 
Effect to create interesting curved effects by shaping needle penetrations to 
follow the contour of digitized lines.

Creating contoured fills

Contour is a curved fill stitch type which can be applied to Column A/B or 
Circle/Ring objects. It can also be used for outline stitching. Stitches follow the 
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contours of a shape, creating a contoured, light and shade effect. Use it to create 
a sense of movement in contrast to flatter fills created by tatami stitching.

Digitizing contours

The Object Properties > Fills > Contour tab offers the following contour 
stitch options. There are three types of contour stitching which can be applied 
to Column A/B or Circle/Ring objects – Standard, Spiral and Even Density.

Use Outline Stitch Types > Contour to create outlines which follow object contours, 
creating a curved, light-and-shade effect. Right-click for settings.

Use Fill Stitch Types > Contour to create fills which follow object contours, creating 
a curved, light-and-shade effect. Right-click for settings.

Use Traditional Digitizing > Column A to create columns of varying width and stitch 
angle. Right-click for settings.

Use Traditional Digitizing > Column B to create asymmetrical columns of turning 
stitches, where opposite sides are different shapes. Right-click for settings.

Use Graphics Digitizing > Ellipse to digitize ellipse or circle embroidery objects.

Select contour 
type

Select backstitch 
type
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Standard contour

The number of stitch lines is constant, so stitching is denser where the shape 
narrows, and more open where the shape widens.

Spiral contour

Spiral is typically used for rings and borders, it is also suitable for other closed 
shapes.

Spiral Contour can only be used with closed shapes with two outlines such as 
rings. If a shape is not properly closed, it will be filled with Standard Contour 
instead.

Tip  To fill a solid shape with Spiral Contour, create a closed object with a very 
small hole at the center. For example, to create a circle filled with Spiral 
Contour, digitize a thick ring with a very small inner boundary.

Even density contour

Standard Lays rows of stitches back and forth along a shape, perpendicular to 
the digitized stitch angle. 

Spiral Creates a single, continuous line of stitching that spirals around to fill 
the shape.

Even 
Density Maintains even density across shapes which vary in width. 
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Even Density is ideally suited to shapes of variable width. Contour stitching 
follows the shape with uniform stitch density.

Caution  EmbroideryStudio may not generate even-density contour stitching in 
certain shapes. Stitching will revert to standard contour stitching.

Backstitch
The Backstitch panel offers a choice of two backstitch styles – Standard and 
Borderline.

The term ‘backstitch’ refers to every second row of stitches in the fill. The choice 
depends on style – dense or less dense.

If spacing is small, Borderline backstitch will not be applied. This prevents 
damage to the fabric from too many small stitches.

Backstitch Purpose

Standard Creates backstitch rows that are slightly shorter than the forward 
rows, reducing small stitches. Suitable for high density fills.

Borderline Creates parallel backstitch rows to give a smooth, well-defined edge. 
Suitable for lower density fills.

Standard Even density

Standard

Borderline
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Tip  When you digitize shapes with pointed ends – e.g. leaves, diamonds, stars 
– cut the ends to prevent the stitches from bunching.

Contour stitch settings

Adjust stitch length, spacing and offset fraction for Contour fills.

To adjust contour stitch settings
 Right-click the Contour icon to access object properties.

Stitch bunching at 
sharp ends

Column B

Column B
1

2
3

4

8

7
6

5

1

2
3

4
5

10

98
7

6

Use Stitch Types > Outlines > Contour to create outlines which follow object 
contours, creating a curved, light-and-shade effect. Right-click for settings.

Use Stitch Types > Fills > Contour to create fills which follow object contours, 
creating a curved, light-and-shade effect. Right-click for settings.

Adjust stitch 
values

Adjust offset 
fraction

Adjust variable stitch 
settings
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 The Spacing setting has the most conspicuous effect on contour fills. Use it 
to adjust between dense and more open fills. The spacing value sets the 
widest part of the shape. As the shape narrows, spacing decreases.

 While it has no conspicuous effect on fill appearance, the Length setting 
helps to distribute stitches evenly throughout the shape.

 The Offset Fraction controls the pattern of needle penetrations to achieve 
even distribution of stitches and prevent needle penetrations from forming 
unwanted lines. Try different settings to find the optimal distribution of needle 
points.

Optimal distribution
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 Activate Vary Stitch Length as preferred. Stitch length is automatically 
adjusted on corners for more even curves. Settings are the same as simple 
run stitching.

Related topics
 Digitizing methods
 Simple run stitching
 Tatami density
 Stitch length

Creating offset fills

Offset Fill is similar to Contour in that it produces a curved fill stitch type which 
follows the contours of the shape. However, it can be applied to complex fill 
objects as well as turning stitch objects. Stitch angles, however, have no effect 
on the fill pattern. Like Contour, it is best used for open fills with low stitch 
counts.

Variable ON Variable OFF

Use Fill Stitch Types > Offset Fill to create offset fill stitching in any closed shape.
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When applied to shapes of varying width, Offset fill is similar to Contour > 
Even Density in producing an even distribution of needle penetrations, avoiding 
stitch bunching in narrower sections.

Offset fill settings are similar to Contour fill. The Spacing setting has the most 
conspicuous effect for creating less or more open fills.

Related topics
 Digitizing methods
 Simple run stitching
 Tatami density
 Stitch length

Creating spiral fills

Use Spiral Fill to create open stitching that follows the contours of a shape. It 
works best with simple shapes that can be stitched in a single segment without 
holes or islands. Use it with either fixed or variable length run stitching. With 
longer shapes, it may generate stitches that go outside the perimeter of the 
object, but this can provide for some interesting visual effects. Different stitch 
types can be used – sculpture, backstitch, stemstitch, or run stitch. Similarly, 

Offset fill Contour even 
density fill

Adjust stitch
values

Adjust variable
stitch settings

Use Fills Stitch Types > Spiral Fill to create spiral stitching from the center of any closed 
object.
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basic spiral fills can be converted to outlines such as motif run, satin outline, 
sequin run, and bling run.

To create a spiral fill
 Create or select a closed shape and click Spiral Fill.

 To change settings, double-click or right-click the object to access object 
properties.

Note  Stitch angle has no effect on the pattern layout.
 Adjust spiral Stitch settings as desired:

Select stitch
type

Adjust spacing
and length

values
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 Adjust Stitch length for smoother or sharper curves.

 Adjust Stitch spacing for denser or more open stitching.

Note  If the object already has a hole, this is ignored when spiral is applied. It returns 
when other stitch types are applied.

Tip  The center of the spiral can be reshaped or moved with the Reshape 
Object tool. Some interesting visual effects can be achieved. You can even move it 
outside the object outline.

Stitch length: 2.0 mm Stitch Length: 1.0 mm
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Related topics
 Digitizing methods 

Creating radial fills

Radial Fill creates radial turning stitching in either Satin, Tatami or Program 
Split objects. Stitches are generated from the outside edge to the geometric 
center. The center can be shifted. The effect may be on or off while digitizing. 
Operations such as Mirror Merge or Remove Overlaps preserve the effect.

To create a radial fill
 Select a closed-object and click the Radial Fill icon.

 To modify, select and click Reshape Object. In Reshape mode, you can:
 Move the center point of the radial stitching.
 Set the size of the center hole.

Use Stitch Effects > Radial Fill to create radial turning stitching with available stitch types.

Click Reshape > Reshape Object to view the reshape nodes of a selected object.
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 Edit the hole shape for circle/ellipse.

 Alternatively, hole properties can be changed via Object Properties.

Tip  Like Spiral Fill stitch, the center of Radial Fill effect can be moved 
outside the shape or into an included hole to achieve a different effect, 
without losing the original shape.

 Optionally, apply Satin, Program Split and/or Jagged Edge together with 
Radial Fill.

 Press Enter to apply, Esc to finish.

Adjust hole 
dimensions
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Note  You are not able to directly edit stitch angles generated by Radial Fill. 
But you can apply Break Apart and edit the resulting turning angle closed 
object. See also Breaking apart composite objects.

Tips for use
Not all patterns and stitch settings or objects (size specific) are suitable for 
Radial Fill. In particular, if you are using it with larger objects, use one or a 
combination of the following to avoid bunching at the center:
 Increase the size of the hole, move the center into an existing hole in the 

object, or move it outside the object altogether.
 Add Jagged Edge to the inside.
 Use larger stitch spacing – increase by about 20%.
 Avoid patterns which add needle penetrations close to the center of the 

object.
 Use Edge Run underlay with smaller objects, to help reduce the number of 

stitches at the object center.
 Radial Fill can be applied to ring shapes. The center of the radial effect will 

lie within the hole of the ring. Use Reshape to adjust as necessary.

Creating curved fills

To create a flowing stitch effect, apply Florentine Effect. Stitches follow a 
digitized line but maintain uniform density and needle penetrations. Liquid 
Effect is similar to Florentine Effect except that you enter twin guidelines for 
stitches to follow.

Creating curved fills with Florentine Effect

While you can apply Florentine Effect to any closed shape, it is generally used 
in conjunction with Complex Fill or Close Shape input methods. This is 

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. Press 
<Ctrl> to create a square.

Use Stitch Effects > Florentine Effect to create custom curved stitching.
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because Florentine Effect overrides any stitch angles already applying. You 
can apply the effect while digitizing or to existing objects.

To create a curved fill with Florentine Effect
 Choose a suitable input method and select tatami or program split stitch. For 

best results, use smaller stitch lengths – e.g. 4.00 mm or less.
 Click the Florentine Effect icon.
 Digitize boundaries and entry and exit points of the complex fill object 

following the prompts.
 Digitize the guideline you want stitches to follow and press Enter. The 

guideline must intersect both sides of the object, have at least three points, 
and must not overlap itself. Curves generally give better results than sharp 
corners.

 Use the Reshape Object tool to modify the guideline.
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Related topics
 Creating contoured fills
 Applying curved fills to existing objects

Creating curved fills with Liquid Effect

Liquid Effect is similar to Florentine Effect except that you enter twin 
guidelines for stitches to follow. The change between guidelines is distributed 
evenly to produce smooth stitching. Unlike Florentine Effect, Liquid Effect 
guidelines are digitized outside the object, rather than over. While you can 
apply the effect to any closed shape, it overrides any existing stitch angles.

To create a curved fill with Liquid Effect
1 Choose a suitable input method, select tatami or program split stitch, and 

click Liquid Effect.
2 Digitize outline, entry and exit points and stitch angle of the complex fill 

object following the prompts. You are not prompted to digitize a stitch angle.
3 Digitize the first guideline around the outside of the object. You must enter at 

least three reference points.

4 Press Enter. You are prompted to enter a second guideline. Elastic lines 
appear joining the two guidelines.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. Press 
<Ctrl> to create a square.

Use Stitch Effects > Liquid Effect to create curved stitch effects with two guidelines.

Guideline 1
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5 Digitize the second in the same direction as the first, marking at least three 
reference points.

Note  The two guidelines must not overlap or intersect the object outline. If 
any part of a guideline crosses the object boundary, an error message 
appears.

6 Press Enter to apply.

Tip  Use the Reshape Object tool to modify guidelines.

Adjusting curved fill settings

In a curved fill, stitch lengths vary to map the needle point pattern to the curve. 
You choose between Nominal and Maximum stitch length calculation.

Guideline 1

Guideline 2

Right-click Stitch Effects > Florentine Effect to adjust settings.

Right-click Stitch Effects > Liquid Effect to adjust settings.

Nominal

Maximum
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To adjust curved fill settings
 Right-click a Florentine Effect or Liquid Effect icon to access object 

properties.

 Select a preferred stitch length calculation:

Applying curved fills to existing objects

Apply Florentine Effect to existing complex fill objects. The effect can also be 
applied to Column A/B objects. You can also apply Liquid Effect to existing 
objects.

To apply a curved fill to an existing object
1 Select an object and select a curve fill method.
2 With the object still selected, click the Reshape Object icon. A default 

guideline with three corner control points appears.

Option Purpose

Nominal Average length of fill stitches matches the current Stitch Length 
setting. This generates roughly the same number of fill stitches as with 
normal stitching. 

Max Longest stitch matches the Stitch Length setting. This generally 
produces smoother curves than Nominal, but the stitch count is higher. 
Use Max when the curve is tight with respect to the stitch length.

Select Florentine 
Effect

Use Stitch Effects > Florentine Effect to apply curve stitching to existing objects.

Use Stitch Effects > Liquid Effect to apply curve stitching to existing objects.

Use Reshape Tools > Reshape Object to adjust control points of the guideline.
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3 Reshape guidelines in the normal way by moving, adding, changing or 
deleting reference points.

4 Press Enter. EmbroideryStudio regenerates stitches along the new curve. 
5 Turn on TrueView™ or click the Show Needle Points icon to view the results.

Creating flexi-splits

Flexi Split is a decorative effect where one or more lines of a program split 
pattern are used in the object fill. The pattern follows the stitch angle and may 
be scaled to fit the width of the object. It is intended for use with objects with 
turning stitches or varying column width. You can apply Flexi Split to a wide 
variety of object and stitch types. Use existing patterns or create your own.

To apply the Flexi Split
 Select an object and click the Flexi Split icon. 

Use Stitch Effects > Flexi Split to create decorative split patterns following stitch 
angles and scaled according to object width. Right-click for settings.
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 Right-click to access properties.

 Select a pattern from the droplist. Alternatively, click the arrow button to 
access the pattern library.

 Select one of four options.

 Adjust Flexi Split settings to vary size, shape indent, spacing and pattern 
offsets.

 In the Size X and Size Y fields, enter dimensions of the largest pattern in the 
effect. The scaling lock maintains aspect ratio.

Pattern preview

Click to expand
pattern list

Select Flexi Split

Click to select 
pattern

Select pattern

Select Flexi Split 
option

Enter distance between 
first pattern and first 
stitch line

Enter dimensions of
largest pattern

Enter spacing
and offsets
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 In the Indent field, enter the distance between the first pattern and the first 
stitch line.

 In the Column panel, enter spacing and offset settings as required:

 If you selected an option that uses more than one row of patterns, the fields 
in the Row panel are available.

Related topics
 Making split patterns

Indent: 2 mmDefault indent values Indent: 4 mm

Default column values  Column spacing decreased Column offset value changed

Default column and 
row values

Column and row 
spacing decreased

Row offset value 
changed
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Chapter 26

Motif Runs & Fills

Motifs are predefined design elements, such 
as hearts, leaves or border patterns. They 
generally consist of one or more simple 
objects, and are stored in special motif sets. 
Motifs can be used for ornamental outlines 
and patterned fills or even on their own. 
Motifs can be scaled, rotated and mirrored 
in the same way as other objects. You can 
even use them to create interesting three 
dimensional effects.
Whether using them in runs, fills, or 
individually, motifs can be selected from 
predefined motif sets. Other ornament 
types can be used as motifs. You can even 
define your own, including motifs derived 
from cross stitching.

Selecting & placing motifs

You select motifs for use in runs, fills, or individually, via the Object Properties 
docker.

Motifs are commonly used in decorative outlines or open fills. However, you can 
add them to your design one-by-one. Rotate, scale, or mirror them as you add 
or edit them like any other object.

Use Outline Stitch Types > Motif Run to create a string of motifs along a digitized 
line.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery motifs to 
form repeating patterns. Right-click for settings.

Use Traditional Digitizing > Use Motif to add motifs to design one-by-one. Rotate, 
scale, or mirror as you add.
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To select a motif
 Right-click the Motif Run or Motif Fill icon to access object properties.

 Select a motif set from the droplist. There are two sets specific to motifs – 
single or two-part. However, you can use any other available set.

 Select a pattern from the droplist. Alternatively, click the arrow button to 
access the motif library.

 Select Use Motif. A motif outline appears attached to the mouse pointer.
 Click to mark an anchor point.

Select motif set

Single or two-part 
sets

Select motif from
library

Motif preview

Select motif from 
droplist or click arrow to 
open library

Click to mark
anchor point



Chapter 26   Motif  Runs & Fi l ls 520

 Drag the mouse to rotate, scale, or mirror:
 To rotate, move the pointer then click again.

 To mirror the motif, right-click.

 To scale the motif, press Shift, move the pointer, then click again.

 Repeat as required. Stitches are generated automatically.

 Alternatively, press Enter to accept default position and settings.
 Press Esc to finish.

Tip  You can create motifs from patterns made in ES Cross Stitch and use 
them to create a cross stitch sampler. See Cross Stitch Supplement for 
details.

Related topics
 Creating motif runs
 Creating motif fills
 Motif Samples

Click to mark 
guide point

Motif rotated

Motif rotated and 
mirrored

Right-click to mark 
guide point and 
mirror motif

Hold down Ctrl to constrain 
rotation angles

Motif rotated and 
scaled

Hold down Shift to 
resize the motif

Insert anchor 
point

Insert guide 
point

Repeat as 
required

Motifs created from 
cross stitching
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Creating motif runs

Motif Run is a stitch type that forms repeated motifs along a digitized line. It is 
typically used for decorative borders or special effects.

Related topics
 Digitizing motif runs
 Reshaping motif runs
 Motif Samples

Digitizing motif runs

Motif runs can be digitized as open or closed objects with graphical or traditional 
digitizing tools. Pretty much any digitizing tool can be used, including 
Freehand. Motif runs have some different properties to other decorative outline 
stitches. You can modify rotation angle, orientation and scale, and vary motif 
spacing.

To digitize motif runs
 Double-click or right-click the Motif Run icon to access object properties and 

select the motif you require.

Use Outline Stitch Types > Motif Run to create a string of motifs along a digitized 
line.

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes.

Use Outline Tools > Motif Run to place a row of motifs along a digitized line.
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 Select a motif set and the motif you want to use.

Tip  Select a motif with no object selected and click Apply to make the 
selection current. Use it with the Use Motif tool.

 Select a digitizing tool such as Digitize Open Shape or Digitize Closed 
Shape to create a string of motifs along a digitized line:

 To use default size and orientation, press Enter.
 Use the Size fields to adjust motif dimensions. The scaling lock maintains 

aspect ratio.

 Use the Spacing field to control repeat distance.

Select motif

Motif run
preview

Enter motif 
dimensions

Enter spacing 
between repeats

Choose whether to keep 
or omit first and last 
motifs

Original outline Scaled in X Scaled in Y

SpacingInitial spacing
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 Optionally, use the Reverse Curves command in the popup menu to change 
motif orientation.

 Choose whether to keep or omit first and last motifs to avoid overlaps.

 Press Enter or click Apply.

Creating graded motif runs

In some products, size and spacing settings allow you to automatically grade 
motif size and spacing in motif runs from a specified starting size to finishing 
size.

Options include:

First and last 
motifs kept

First motif kept, 
last motif omitted

Select grading
option

Set starting
size
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 Grade motif size proportionally or maintain constant size.
 Grade motif spacing proportionally or maintain constant spacing.
 Vary motif size and spacing on tight curves. This option automatically reduces 

motif size and spacing in proportion to the sharpness of the curve, similar to 
variable run stitch length. Also similar, the ‘chord length’ setting controls how 
closely motifs follow the curve.

Reshaping motif runs

Motif runs can be reshaped like other embroidery object, but special control 
points are provided.

To reshape a motif run
 Select a motif run object and click the Reshape Object icon. Control points 

appear around the motifs.

Vary motif size and
spacing on tight

curves

Use Reshape Tools > Reshape Object to reshape selected motif run objects.
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 Adjust object size like any other object using sizing handles.

 Click the diamond control point of a motif to activate reshape nodes. Use 
these to fine-tune individual motifs. Each one can be rotated, skewed, or 
resized respectively.

Note  A ‘Regenerate motif run’ checkbox forces the system to regenerate 
motif runs based on current settings whenever an object is scaled or skewed. 
When left unchecked, the system will not re-generate and the number of 
motifs will remain unchanged after the transformation.

 Press Esc to finish.

Click and drag handles
to resize and reshape

whole object

Click and drag 
sizing handle

Click to activate 
reshape nodes

Click and drag control 
handles to reshape individual 
motifs

Regenerate after
transformation

Motif run regenerated 
– motif size and 
spacing maintained
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Related topics
 Reshaping Objects

Creating motif fills

Motif Fill is a decorative stitch used for filling closed objects. This feature 
repeats motifs in parallel rows to fill the shape. It is generally used for open 
stitching and special effects. Alternatively, it can be layered over top of solid 
stitching backgrounds. You can select different motifs for forward and backward 
rows. You can create motif layouts onscreen or via object properties. Auto 
Underlay is deactivated with motif fills and stitch angle has no effect.

Digitizing motif fills

Digitize closed objects with Motif Fill or apply it to existing objects. Pretty much 
any closed digitizing tool can be used, including Freehand Closed Shape. 
Stitch angles are ignored. Select from a wide range of motifs. Mix and match 
different motifs for forward and backward rows, or use the same motif for each. 
There is a special Two-Part Motifs set which contains complementary paired 
motifs.

To digitize a motif fill
 Click Motif Fill and select a closed digitizing tool.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery motifs to 
form repeating patterns. Right-click for settings.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a single stitch 
angle. Right-click for settings.
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 Double-click the object or right-click the Motif Fill icon to access object 
properties.

 In the Motif 1 panel, select a motif set and pattern from the library. For single 
rows, use the Single Motifs set. You can also use monogram ornaments or 
even define your own sets. 

 If you want different motifs for forward and backward rows, select the 
Motif 2 checkbox. For best results, use the Two-Part Motifs set for both.

 In the Motif 2 panel, select a complementary motif. The predefined two-part 
motif set is specially designed to provide complementary motifs for forward 
and backward rows – e.g. ‘Duet01a’ and ‘Duet01b’.

Select motif set to select 
from for forward row

Select motif set to select 
from for backward row

Select motif for
forward row

Select motif for
backward row
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Tip  As an alternative, you can generate layers of colored motifs by 
duplicating an object and selecting a different color and/or motif.

Related topics
 Motif scaling
 Motif Samples

Motif fill settings

You can adjust motif fills both interactively on screen and via object properties.

Spacing & offsets
You can adjust the exact row, column and spacing settings for motif fills. The 
default settings define a simple grid where the spacing equals the motif 
dimensions. The row offset is set to 0.00 mm so columns and rows are 
perpendicular.

 To adjust spacing and offset settings, open the Object Properties > Fills > 
Motif Fill dialog.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery motifs to 
form repeating patterns. Right-click for settings.

Scale and clip motifs 
to fit shape

Enter column 
spacing

Enter row spacing 
and offset 
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 Adjust column and row spacing as well as row offsets.

 Select the Scale to fit grid checkbox to scale motifs to exactly fit the grid 
squares.

 Select the Clip to fit shape checkbox to clip motifs that do not fit the shape.

Motif scaling
You can set the exact size of motifs in a fill. You can also scale Motif 1 and 
Motif 2 motifs independently. Adjust Size controls in the Object Properties > 
Fills > Motif Fill dialog.

Motif rotation

The rotation angle defines the orientation of the entire motif fill pattern. It 
overrides the stitch angle you set when digitizing the shape with Complex Fill. 
Enter a rotation angle in the Object Properties docker.
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Laying out motif fills on-screen

Lay out motif fills on-screen in a similar way to program splits by using ‘guide 
motifs’ to scale, space, transform and offset the entire fill. There are three blue 
guide motifs. Each guide motif lets you change a different element of the layout. 
Stitch angle has no effect on motif layouts.

Generally you define a layout before digitizing. If it is important to align motifs 
with the object boundary, digitize the object using current settings, and change 
the layout afterwards.

To lay out motif fills on-screen
1 Right-click the Motif Fill icon to access object properties.

2 Select a motif set and motif and click Layout. Sample and guide motifs 
appear in the design window. Zoom in to select the correct guide motif.

3 Adjust the guide motifs to achieve the effect you require:
 Move motifs by selecting the middle guide motif and dragging it to a new 

position.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery motifs to 
form repeating patterns. Right-click for settings.

Click to lay out 
selected motif

Use top guide motif to change row 
spacing, row offset, and to scale motifs

Use side guide motif to change 
column spacing, and to scale motifs

Use middle guide motif to
move, rotate, skew, and

scale motifs
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 Scale motifs by selecting a guide motif and resizing it using the selection 
handles.

 Rotate motifs by clicking the middle guide twice to display the rotation 
handles. Click a corner handle and drag to rotate. 

 Skew motifs by clicking the middle guide twice, then dragging the skew 
handles. 

 Change column spacing by selecting the side guide and dragging it left or 
right.

 Change row spacing by selecting the top guide and dragging it up or down.

Scale
proportionally

Scale 
horizontally

Scale 
vertically

Rotate

Skew

Anchor

Change column 
spacing
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 Change row offset by selecting the top guide and dragging it left or right.

Note  Motif Fill does not have a column offset since motifs are connected 
along each row. Instead you can rotate the layout to achieve a similar effect. 

4 Press Esc to finish. The size and layout settings you select become current 
settings.

Tip  To revert to the original factory settings, run the Revert utility. 
Alternatively, enter the values manually in the Object Properties > Fills > 
Motif Fill and click Save.

Related topics
 Laying out program splits on-screen
 Motif Samples

Creating enveloped motif fills

EmbroideryStudio provides techniques for ‘sculpting’ motif fills to create three 
dimensional effects. Create graded columns of motif stitching. Or make motif 
fills appear concave or convex. You can also create perspective effects.

Tip  Small stitches may be generated along the edge of objects employing these 
effects. You can remove these automatically. See Eliminating small stitches for 
details.

Creating graded motif columns

Change row 
spacing

Change 
offset

Use Fill Stitch Types > Motif Column to place motifs along the center line of a 
column shape and resize to fit the shape. Right-clicking for settings.
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The Motif Column feature allows you to create graded columns of motif 
stitching. Motifs dynamically resize to fit varying widths. Similar in concept to 
flexi-split with turning satin, you digitize a tapering shape using, for example, 
Column A. Apply Motif Column and select a motif. Motifs are automatically 
‘enveloped’ to fit to the shape.

Right-clicking the Motif Column tool opens the Object Properties docker with 
its dedicated Motif Column fill stitch settings. Choose motifs from any one of 
the available libraries. Mirror motifs around their own axis internal to the shape.

Choose between proportional or fixed spacings. Fixed spacing maintains 
constant motif width throughout the shape.

Motif Column settings for 
proportional or fixed 
spacings

Mirror motifs 
internal to the 
shape

Fixed spacing locks width
(size x) throughout

Proportional spacing scales
entire motif throughout
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Caution  Stitches are ungenerated when branching two Column A objects 
together with Motif Column.

Creating convex & concave effects

Using Globe In with 3D Warp gives a concave effect by increasing motif size 
and spacing around a center point. Globe Out gives a convex effect by 
decreasing motif size and spacing. You can apply the effect to an entire object, 
or to a specified part of the fill.

To create convex and concave effects
 Select a motif fill object and right-click the 3D Warp icon. The Object 

Properties > Curve docker opens.

 Select the 3D Warp checkbox, and select Globe In or Globe Out from the 
list.

 Press Enter or click Apply. The Globe In or Out effect is applied to the 
selected object.

Click Stitch Effects > 3D Warp to apply 3D effects to selected motif fills. Right-click 
to change settings.

Use Reshape Tools > Reshape Object to reshape selected 3D Warp objects.

Select 3D Warp

Select Globe In or 
Globe Out

Globe In appliedComplex FIll object 
with Motif Fill

Globe Out applied

OR
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 To make further adjustments, click Reshape Object with the object selected. 
A guide frame appears with three control points.

 Adjust the control points to:
 Change frame height 
 Change frame width
 Reposition frame.

Tip  You can generate layers of colored motifs by duplicating an object and 
selecting a different color. For example, after filling a shape with circles, you 
can create a second layer, offset it, and apply a different color. You can then 
apply effects such as Globe Out to the whole motif fill.

Creating perspective effects

Use Perspective with 3D Warp to create a perspective effect by exaggerating 
relative sizes.

Click-and-drag to 
reposition frame

Click-and-drag 
control point

Click Stitch Effects > 3D Warp to apply 3D effects to selected motif fills. Right-click 
to change settings.

Use Reshape Tools > Reshape Object to reshape selected 3D Warp objects.
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To create perspective effects
 Select a motif fill object and right-click the 3D Warp icon. The Object 

Properties > Curve docker opens.

 Select the 3D Warp checkbox, and select Perspective from the list.
 Press Enter or click Apply.
 Click the Reshape icon. A guide frame appears around the object.

 Adjust the frame to move the guidelines closer together or further apart.
 Press Enter or click Apply.

Note  The guide frame must not cross the outer boundary of the shape, and 
cannot be inside the shape.

Managing motifs

EmbroideryStudio provides various ways to manage your motifs including 
making motif sets, saving motifs, copying motifs between sets, and deleting 
motifs.

Creating motifs

The Create Motif function lets you save your own motifs for future use. Motifs 
may be saved to different files or ‘motif sets’.

Select 3D Warp

Select Perspective

Select object and 
click Reshape

Adjust frame and 
Press Enter
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To create a motif
1 Select the object you want to save as a motif.

2 Select Object > Create Motif.

3 Select a Motif Set from the droplist and enter a name in the Motif Name 
field.
 Optionally, click Create. The Create Motif Set dialog opens.

 Enter a name for the new motif set and click OK. The Motif Set is ready 
for use. Motif sets are stored in the program folder ...\Userletw. You can 
delete or rename them as required.

4 If you want to preserve machine functions – e.g. color changes – leave the 
Remove Functions checkbox unticked. Otherwise, if you want to remove 
machine functions from the motif, select the checkbox.

5 Click OK.
6 Click to mark two reference points for the motif. These determine default 

motif orientation. Reference point 1 becomes the anchor point. Reference 
point 2 becomes the rotation point.

Select motif set

Enter motif name

Select to remove unwanted
machine functions

Enter name for 
motif set

My New Motif Set

Rotation direction
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Reference points also determine spacing between motifs.

7 Click OK. The motif is ready for use.

Tip  When creating the motif, duplicate, and align objects as you want your 
motif run to appear. Use Alignment and Closest Join tools for precise 
arrangement. Use the middle motif to define reference points.

Managing motif sets

Manage your custom motif sets via the Manage Motifs command.

To manage motif sets
 Select the Setup > Manage Motifs command. The Manage Motifs dialog 

opens.

 Select the motif set you want to modify from the droplist.
 Select a motif from the Motif group.
 Use the Rename and Delete buttons to modify as required.

Reference point 1

Reference point 2Reference point 1

Reference point 2

Reference point 1

Reference point 2

Apply Closest Join 
used

Align and Space 
Evenly tools used

Modify motif set

Modify selected 
motif

My Motif Set

My Motif
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Tip  Alternatively, you can delete custom motifs directly from the Object 
Properties docker. Access the dialog by right-clicking either Motif Run or 
Motif Fill icon.

Select motif

Click to expand
motif list

Delete selected
motif
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PART VII

EMBROIDERY LETTERING

Create top-quality lettering quickly and simply. EmbroideryStudio provides a 
large range of scalable closest-join font styles and multi-color and fancy 
embroidery fonts to choose from.

Creating embroidery lettering
This section describes how to add lettering, apply lettering baselines, change 
letter formatting, and adjust letter size and spacing. See Creating Embroidery 
Lettering for details.

Editing embroidery lettering
This section describes how to edit lettering text. It also explains how to scale 
and transform lettering objects. It also covers adjusting individual letters as well 
as reshaping baselines on screen. See Editing Embroidery Lettering for details.

Advanced embroidery lettering
This section shows you how to add special characters and symbols. It describes 
changing lettering stitch types in lettering objects, and adjusting lettering stitch 
angles. It also explains how to adjust the lettering stitching sequence as well as 
lettering join method. Automatic letter kerning and letter spacing are discussed. 
Lettering underlay is also discussed. It also describes how to create special 
effects with envelopes. See Advanced Embroidery Lettering for details.

Team names
This section shows you how to set up name groups and create team name 
designs. It also describes how to modify team name designs and output them in 
a variety of ways. See Team Names for details.

Monogramming
This section details the creation of monogram lettering with initials or with a 
name, how to add ornaments to monograms, and how to create ornament 
layouts. See Monogramming for details.

Custom fonts
This section describes how to create embroidery fonts from TrueType fonts. 
Automatic letter kerning and user-refined fonts are explained. The section also 
describes how to create and modify your own custom fonts and letters. Font 
merging is also explained. See Custom Fonts for details.

Lettering kiosk
The lettering kiosk provides a set of pre-defined design layouts and the ability 
to easily personalize them by modifying text and color. You can create your own 
layouts as well. Designs can be sent to machine from the kiosk via a single 
button press. See Lettering Kiosk for details.
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Chapter 27

Creating Embroidery Lettering

Create high-quality embroidery lettering 
quickly and simply. EmbroideryStudio 
provides a large range of scalable fonts to 
choose from. Add embroidery lettering 
directly to designs or convert from 
CorelDRAW Graphics. Apply formatting 
just like a word processor, including 
italics, bolding, and right/left justification. 
Change values for the whole text or 
individual letters.
This section describes how to add 
lettering, apply lettering baselines, 
change letter formatting, and adjust letter 
size and spacing.

Creating lettering with CorelDRAW Graphics

Some EmbroideryStudio product levels include CorelDRAW® Graphics Suite as 
standard. This allows you to add and format TrueType lettering in CorelDRAW 
Graphics. This can then be converted to either embroidery lettering or 
embroidery objects.

Note  For a detailed description of the CorelDRAW® Graphics Suite interface, 
access the Help menu in CorelDRAW Graphics mode.

To create lettering with CorelDRAW Graphics
1 Switch to CorelDRAW Graphics.
2 Create a CorelDRAW® Graphics Suite text object and select it.

Use Mode > Tag Fill as Turning Satin to tag narrow shapes for conversion to 
turning stitching.

Use Mode > Convert Graphics to Embroidery to convert selected graphics to 
embroidery and switch to Wilcom Decoration.
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3 Click Convert Graphics to Embroidery. Wilcom Decoration opens in a 
few moments and the converted embroidery lettering displays. Change to a 
native embroidery font and adjust settings as desired.

 You can create lettering along any shape of baseline in CorelDRAW 
Graphics and convert to embroidery lettering.

 You can also convert multi-line paragraph text with left, center, or right 
justification.

Tip  If you are not satisfied with the results of lettering conversion and want 
to preserve the precise appearance of the original text, try converting to 
curves first and then to plain embroidery. Right-click and select Convert to 
Curve. Optionally, use Tag Fill as Turning Satin to tag letters for 
conversion to turning stitching. 

Convert to curves 
first
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Related topics
 Operating modes
 Editing text
 Adjusting baselines

Creating embroidery lettering

You can add lettering to a design by typing it directly on-screen or entering it via 
the Object Properties docker.

Embroidery fonts

EmbroideryStudio offers a range of purpose-built embroidery fonts optimized for 
embroidery design work.

Recommended sizes
For best results when stitching, do not exceed the recommended maximum or 
minimum sizes. Note, however, that recommended heights refer to UPPER CASE 
letters. Most embroidery fonts are digitized from an original TrueType Font (TTF), 
some of which have lower-case letters – e.g. ‘a’ and ‘c’ – which are about 70% 
the height of a capital letter. As a result, these letters may be too small to 
embroider neatly. You may need to increase the size of lower-case characters to 
suit the embroidery.

Special characters
You can create special characters in each font by holding down the Alt key on 
your keyboard and typing 0 (zero), its code, using the numbers on the keypad. 
For example, to type ê with the code 234, type Alt+0234. The accented letter 
will appear when you release the Alt key. Not all characters are available in all 
fonts.

Conversion of TrueType and OpenType fonts
In addition to dedicated embroidery fonts, EmbroideryStudio also converts any 
TrueType or OpenType font on your system on-the-fly into an embroidery font. 

Scroll to preview 
available fonts
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This is an important feature for Asian fonts which may contain several thousand 
characters.

The process is automatic. The result is similar to manually digitized fonts 
although the quality may not be quite as high. It depends on the original shapes. 
Narrower serif type fonts produce better results than blocked fonts.

It is also possible to select TrueType fonts in CorelDRAW® Graphics Suite and 
convert them on-the-fly via Convert tool. 

Bling lettering
EmbroideryStudio also provides dedicated Bling Lettering.

Related topics
 Adjusting dimensions
 Creating lettering with CorelDRAW Graphics
 Adding special characters
 Creating bling lettering
 Embroidery Fonts

Scroll to preview 
available TrueType 
fonts

Bling-specific 
fonts
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Adding embroidery lettering on-screen

If it is not essential to fit letters precisely to a certain area, you can type them 
directly on-screen as with a word processor. Current settings are used. You can 
also modify lettering objects directly on-screen to achieve various artistic 
effects.

To add embroidery lettering on-screen
 Click the Lettering icon.
 Select a color from the color palette.
 Click an insertion point and start typing. To start a new line, press 

Shift+Enter.

 Press Enter to complete.

Note  Baselines determine the shape of lettering objects in a design. You can 
place lettering on a straight horizontal or vertical line, curve lettering around 
a circle or arc, or digitize your own baseline.

Related topics
 Working with baselines

Creating lettering with object properties

Using the Object Properties docker, you can specify letter formatting before 
adding it to the design. This is the more traditional method and is useful with 
more complex designs. EmbroideryStudio provides a font range suitable for 
many applications. Select from the supplied embroidery fonts or convert 
TrueType or OpenType fonts installed on your system.

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Right-click Toolbox > Lettering to enter text in the docker and adjust settings for 
embroidery lettering.
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To create lettering with object properties
1 Right-click the Lettering icon to access object properties.

2 Enter the text you want to embroider in the text entry panel. To start a new 
line, press Enter.

3 Select a font from the Font droplist. To filter the list:
 Choose a font type: Embroidery, TrueType, or All.
 Choose a TrueType font style: Block, Serif, Script, Decorative, or All. These 

only apply to TrueType fonts.
 Type two (or more) characters of the font name to further filter the list.

Tip  Check min/max recommendations for each font and stay within them for best 
results. See also Embroidery Fonts.

Adjust formatting

Select font

Enter text

Click to create text

Choose baseline

Filter font list

Scroll to preview 
available fonts
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4 Select a baseline from the droplist. Baselines determine the shape of lettering 
objects in a design.

5 Click Create Text in the docker.
6 Click on screen to place the lettering, or mark reference points for the 

selected baseline.
7 Press Enter to generate. Letters are filled with stitches according to current 

settings in the Object Properties docker. Change these at any time.

Tip  Lettering appearance and quality depends a lot on underlay which serves 
as a foundation for cover stitching.

Related topics
 Embroidery fonts
 Embroidery Fonts
 Converting TrueType fonts to embroidery
 Working with baselines 
 Formatting lettering
 Setting lettering underlay

Adjusting lettering properties

Letter height, width, italic and justification can all be conrolled via object 
properties. Letter, word and line spacings can also be controlled via properties. 
Letter spacing is calculated automatically according to justification – left, right, 
center, or fully justified.

Select baseline 
style
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Formatting lettering

Change current formatting settings before or after adding lettering. You can 
slant letters to left or right for an italic effect. Use the justification setting – left, 
right, center, or fully justified – to align lettering along the baseline.

To format lettering
1 Create a new lettering object and select it.

2 If not already open, double-click to open the Object Properties > Special 
> Lettering dialog.

3 Adjust lettering height and width using the slider controls.

Tip  Say, for example, you are using the metric measurement system so your 
lettering heights are in mm. And say you get an order for ¾" lettering. Simply 
enter ‘3/4in’ or ‘3/4 in’ into the Lettering Height field and it is automatically 
converted to 19.05mm.

4 Enter an angle, ±45°, in the Italic field to create slanted lettering – 0° is 
equivalent to no italics.

Adjust lettering width 
as percentage

Adjust lettering height

Adjust letter slant angle

Italic angle 25° Italic angle 0° Italic angle -10°
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5 Select a justification setting as required – Left, Right, Center, or Full.

Tip  When the justification setting is Full, letters are evenly distributed along 
the baseline. To change spacing for fully justified lettering, simply change 
baseline length.

6 To make bold lettering, select the Pull Comp tab.

7 Select column width or pull comp options as required.

Related topics
 Creating lettering with object properties
 Creating special effects with lettering art
 Set measurement units
 Compensating for fabric stretch

Adjusting spacing settings

You can adjust letter, word and line spacings via object properties.

RightCenterLeft

Select Pull Comp tab

Increase pull comp or 
column width
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To adjust spacing settings
 Double-click a selected lettering object or right-click the Lettering icon to 

access object properties.

 Enter Spacing values as absolute values (mm) or percentages of the height.
 Letter Spacing: the space between letters.

Word Spacing: the space between words.

 Line Spacing: the space between lines.

Tip  If you want to remove spacing between words, set Word Spacing to 
0%.

Adjusting letter spacings on-screen

Spacing between letters is calculated automatically as a percentage of letter 
height. In most cases the default spacing is adequate. Sometimes you may want 
to control the overall letter spread to fit a particular location. Similarly, you can 
change the space between lines in a multiple-line lettering object using the 
Reshape Object tool. Sometimes spacing between certain letters may appear 
too large or too small, depending on the shape of neighboring letters. To 
compensate for this visual effect, you can move one or several selected letters 
closer or further apart along the baseline to improve spacing. 

Enter values as absolutes 
(mm) or percentages

Use Reshape Tools > Reshape Object to change letter spacing.
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To adjust letter spacings on-screen
 Select the lettering object and click the Reshape Object icon.

 Drag the letter spacing control point left or right to adjust the spacing of all 
letters along the baseline.

 Release the mouse button to complete and press Esc.

Tip  When the justification setting is Full, letters are evenly distributed along 
the baseline. To change the spacing for fully justified lettering, simply change 
the length of the baseline.

 Drag the line spacing control point up or down to change line spacing.

 Release the mouse button to complete and press Esc.
 Click the diamond control point in the center of the letter. To select multiple 

letters or a range of letters, hold down Ctrl or Shift as you select.

Drag letter spacing
control point

Drag line spacing 
control point

Hold down Ctrl and click diamond 
points to select multiples
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 Drag selected letter/s along the baseline or use arrow keys to adjust the 
spacing.

Tip  Alternatively, to move multiple letters, right-click the diamond control 
point of the first letter and drag. All letters to the end of the line move as one.

 Release the mouse button to complete and press Esc.

Related topics
 Setting automatic letter kerning
 Setting automatic letter spacing
 Adjusting individual letters

Working with baselines

Baselines determine the shape of lettering objects. You can place lettering on a 
straight horizontal or vertical line, curve lettering around a circle or arc, or 
digitize your own baseline. You can digitize baselines on-screen or, if you are 
working from an enlargement drawing, on a digitizing tablet.

Applying baselines

With the exception of Free Line and Free Line Vertical, baselines allow you to 
set the final length of the finished lettering. Once you have placed a baseline, 
EmbroideryStudio attempts to fit all the letters without altering baseline length. 
EmbroideryStudio gives you interactive and numeric control over many baseline 
settings.

Drag or use arrow keys to 
fine-tune kerning

Right-click Toolbox > Lettering to select baselines and adjust baseline settings.
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To apply a baseline
 Double-click a selected lettering object or right-click the Lettering icon to 

access object properties.

 Select a baseline from the list. Options include:
 Horizontal (Free Line and Fixed Line) or vertical (Free Line Vertical and 

Fixed Line Vertical)
Fixed Line baselines allow you to set the final length of the finished lettering. 
Free Line baselines expand to fit the letters you enter.

With vertical baselines, line spacing is calculated horizontally while letter 
spacing is calculated vertically. Letters, by default, are centered along vertical 
lines. New lines are placed by default from right to left to suit Asian 
languages. For Western languages, vertical lettering is best suited to 
uppercase because descenders in lowercase letters are not accommodated in 
the letter spacing.

Select baseline 
style
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 Arc (Arc CW and Arc CCW): By default, letters are positioned above the Arc 
CW and below the Arc CCW baseline. They are also centered by default. 
Hold down the Ctrl key to constrain the line to 15° increments.

Depending on the order in which you mark the reference points, the text will 
be placed left to right, or right to left.

 Circle (Circle CW and Circle CCW): Place letters around a full circle or oval. 
Mark a point on the circumference to define the radius. Mark a third point to 
define an ellipse or press Enter directly for a perfect circle. Hold down the 
Ctrl key to constrain the line to 15° increments.

Tip  Adjust circle and arc baseline settings for more precise numeric control 
over radius (X and Y), as well as tilt, justification, and arc angles.

 Custom (Any Shape): Digitize Any Shape baselines by marking reference 
points to form the required line. The number of reference points and length 
of baseline are practically unlimited.

Tip  If the baseline has tight curves, or sharp corners, letters may overlap. 
For best results, only mark curve points and digitize lines which have shallow, 
gentle curves.

Arc clockwise

Arc anti-clockwise

1

1

2

2

3

3

4

3

21
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 Predefined: This technique is typically used for creating logos.

 Adjust baseline settings in the Baseline Settings dialog.

Related topics
 Adjusting fixed-width baseline settings
 Adjusting curved baseline settings
 Using predefined baselines
 Adjusting baselines

Using predefined baselines

Use Predefined baselines to quickly create three rows of lettering, or two rows 
surrounding a design object. This technique is typically used for creating logos.
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To use a predefined baseline
1 With no objects selected, right-click the Lettering icon to access object 

properties.

2 Enter two or three lines of text in the text entry panel. To start a new line of 
lettering, press Enter.

Tip  If you want to insert a logo or design between the top and bottom lines, 
leave the middle line of text blank.

3 Select the font and adjust other settings you require.
4 Select Predefined from the baseline list and click OK.

5 Click where you want to place the lettering and drag the cursor downward.

Tip  Hold down the Ctrl key to constrain the line to 15° increments.
6 Click to enter a point on the circumference of the circle.

Select options and
adjust settings

Enter two or three
lines of text

Select ‘Predefined’
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7 Mark another point if you want to create an oval, or press Enter for a circular 
baseline. The lines of text are generated and dispersed around the baseline 
you have defined. Each line of text becomes a separate lettering object.

Related topics
 Embroidery fonts
 Formatting lettering
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Chapter 28

Editing Embroidery Lettering

EmbroideryStudio gives you interactive and precise numeric control over many 
settings affecting lettering objects. Adjust both individual letters and lettering 
objects as a whole. Apply horizontal, vertical, and curved baselines. Modify 
baseline type, length, radius and angle, as well as position. You can even define 
the rotation angle of letters relative to the baseline or the design itself.

This section describes how to edit lettering text. It also explains how to scale 
and transform lettering objects. It also covers adjusting individual letters as well 
as reshaping baselines on screen.

Editing text

When you have created a lettering object, you can select it and make changes 
to it interactively or by adjusting object properties.

To edit text
 Click Lettering and then click inside the lettering object. An I-beam appears.

 Edit the text as required. The lettering shows its wireframe.
 Press Shift+Enter to start a new line. Press Enter to complete.

Use Toolbox > Lettering to edit lettering on screen.
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 Alternatively, double-click the lettering object. The Object Properties > 
Special > Lettering docker opens.

 Edit the text in the text entry panel and make any other adjustments you 
require.

 Click the Update Text button.

Related topics
 Formatting lettering
 Applying stitch types & effects to lettering

Adjust formatting

Change font

Edit text

Click to update
text

Change baseline
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Modifying lettering

When you first create lettering, it may be too big or too small. Size can be 
adjusted interactively or by adjusting object properties. Lettering objects can 
also be skewed and rotated.

Tip  The size of lettering will determine the type of underlay you need to apply. 
Lettering with heights under 5 mm should not have underlay. Letters 6 mm to 
10 mm can have a center-run underlay applied. Lettering larger than 10 mm is 
large enough for edge-run underlay. See Setting lettering underlay for details.

Adjusting dimensions

You can scale lettering objects vertically, horizontally and proportionally using 
the general properties or via the Special tab of the Object Properties docker.

To adjust dimensions
 Select the lettering object. The current dimensions appear in the Property 

Bar.

 Adjust width and height settings either as absolute values (mm) or as a 
percentage of current settings.

 Press Enter.

Use Toolbox > Lettering to adjust letter height and width.

Adjust width and
height settings

Lock to resize 
proportionately

Original

Width and
height 125%
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 Alternatively, double-click the lettering object to access object properties.

 In the Height field enter the height of your lettering object in millimeters.
 Enter the width of your lettering object in the Width field as a percentage of 

the height.
 For wide letters, increase the percentage – e.g. 140%.
 For narrow letters, decrease the percentage – e.g. 70%.

Note  Letter height can vary between roughly 5mm and 200mm. For 
recommended sizes, see Embroidery Fonts.

Related topics
 Modifying Objects
 Reshaping Objects

Scaling lettering

You can scale your lettering objects vertically, horizontally and proportionally 
with the Select Object tool. You can scale your lettering objects vertically, 
horizontally and proportionally with the Reshape Object tool. 

To scale lettering
 Click Select Object and select the lettering object.

Adjust lettering width 
as percentage

Adjust lettering height 
in millimeters

Width 100% Width 70% Width 140%

Use Select Tools > Select Object to scale lettering objects on screen.

Use Reshape Tools > Reshape Object to scale lettering objects on screen.

Drag to resize 
horizontally

Drag to resize 
proportionally

Drag to resize vertically
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 Click-and-drag one of the selection handles to resize the object horizontally, 
vertically or proportionally.

 Alternatively, click Reshape Object.

 Click-and-drag one of the dark triangular control points to resize the object 
horizontally, vertically or proportionally.

 Release the mouse to complete and press Esc.

Related topics
 Modifying Objects
 Reshaping Objects

Transforming lettering

Apart from scaling, you can use the Select Object and Reshape Object tools 
to skew and rotate lettering objects.

To transform lettering
 Click Select Object and select the lettering object.

Drag

Drag to resize horizontally

Drag to resize proportionally

Drag to resize vertically

Drag

Use Select Tools > Select Object to transform lettering objects on screen.

Use Reshape Tools > Reshape Object to rotate lettering objects on screen.
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 Click the lettering object again. Another set of control points appears. These 
let you rotate and skew the lettering object.

 Click-and-drag diamond-shaped control points to skew the lettering object.

 Click-and-drag hollow square control points to rotate the lettering object.

 Click-and-drag the rotation point itself to a new position before rotating.

 Alternatively, click Reshape Object.

 Click-and-drag up or down one of the solid square control points on the 
baseline to slant the lettering object.

 Release the mouse to complete and press Esc.

Drag to rotate

Drag to skewRotation point

Drag

Drag
Rotation

point

Drag
Rotation 
point

Click and drag up or down
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Related topics
 Modifying Objects
 Reshaping Objects

Adjusting individual letters

As well as scaling and rotating lettering objects, the Reshape Object tool is 
used to manipulate individual letters. You can reposition letters in relation to 
each other, scale, rotate and skew them, as well as reshape them. You can also 
recolor letters individually.

Repositioning letters

You can reposition individual letters in a lettering object using the Reshape 
Object tool.

To reposition letters
1 Select the lettering object and click Reshape Object.
2 Click the diamond control point.

To select multiple letters, hold down Ctrl or Shift as you select.

3 Click-and-drag the letter/s to the new position:
 To move horizontally, drag along the baseline.
 To move vertically, hold down Shift as you drag.

Use Reshape Tools > Reshape Object to reposition individual letters on screen.

Click diamond control points
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 To move the letter freely, hold down Ctrl as you drag.

4 Release the mouse to complete and press Esc.

Related topics
 Adjusting letter spacings on-screen

Transforming letters

You can transform individual letters by manipulating control points on screen 
with the Reshape Object tool.

To transform letters
1 Select the lettering object and click Reshape Object.

2 Click the diamond control point. Another set of reshape nodes appear around 
the letter.

Use Reshape Tools > Reshape Object to transform individual letters on screen.

Drag to scale letter width

Drag to scale letter proportionally
Drag to scale

letter height

Drag to rotate 

Drag to skew
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3 Click-and-drag a reshape node around the letter to transform it.

4 Press Esc to finish.

Reshaping letters

Create special lettering effects by reshaping letter outlines with the Reshape 
Object tool.

To reshape letters
1 Select the lettering object and click Reshape Object.
2 Click the letter outline. Control points appear around the outline. Selectively 

turn off control points as required.

3 Select reshape nodes by any of the following means:
 Drag a selection marquee around the reshape nodes you require.
 To select multiple nodes, hold down Ctrl or Shift as you select.

Drag to
skew

Use Reshape Tools > Reshape Object to reshape individual letters on screen.

Click letter outline

Hold down Shift and left- or 
right-click to select range

Hold down Ctrl and click to 
select individual nodes

Draw selection marquee 
to select group of nodes



EmbroideryStudio e4 User Manual 567

4 Reshape the letter like any other object and press Enter.

Tip  Press Spacebar to toggle between selected corner and curve 
reshape-nodes.

5 Adjust stitch angles as required and press Enter.

Tip  Holding down the Ctrl key, click the outline wherever you want to place 
an additional stitch angle.

6 Adjust entry/exit points as required and press Enter.

7 Press Esc to finish.

Related topics
 Reshaping embroidery objects
 Adjusting stitch angles
 Smoothing curves

Reshape by adding, 
deleting and dragging 
reshape nodes

Adjust entry/exit
points
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Recoloring letters

EmbroideryStudio lets you change the color of individual letters.

To recolor individual letters
1 Click Lettering then click the lettering object.
2 Select a letter (or letters) by dragging the cursor over the letter.

3 Click a color on the color palette.
4 Press Enter.

Tip  You can also insert a color change between two letters by keying a caret 
(^) symbol. Subsequent letters default to the next color in the palette.

Related topics
 Creating lettering with object properties

Adjusting baselines

Baselines can be modified after placement either directly on-screen or via the 
Object Properties > Special > Lettering docker. With the exception of Free 
Line and Free Line Vertical, baselines allow you to set the final length of the 
finished lettering. Once you have placed a baseline, EmbroideryStudio attempts 
to fit all the letters without altering the baseline length.

Tip  As a baseline is filled with letters, letter spacing decreases. Eventually, 
letters may overlap. If so, you can adjust the baseline length to accommodate 
them, or change the lettering width in the Object Properties > Special > 
Lettering docker.

Reshaping baselines interactively

Use Toolbox > Lettering to recolor letters on screen.

Drag cursor over 
letter to select

Use Reshape Tools > Reshape Object to reshape lettering baselines.
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Baselines can be adjusted with the Reshape Object tool. Depending on 
baseline type, you can adjust angles, lengths, and sizes. You can change curve 
radii and justification points. You can completely reshape Any Shape baselines.

To reshape a baseline interactively
 Select the lettering object and click the Reshape Object icon.

Tip  The large diamond and cross represent start and end points. Toggle them 
off to access baseline controls.

 Change angles of straight baselines by dragging square control points at 
either end.

Drag up/down to change
baseline angle
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 Create an arc baseline from a circular one by dragging the hollow square 
control point.

 Change lettering orientation of arc baselines by dragging the solid square 
control points at either end.

Tip  Letter positions depend on justification – left, center, right or justified. If 
the baseline becomes too short, letters may overlap.

 Change the radius by dragging the solid square control point in the center of 
the circle.

Drag left or right to change circle 
baseline to arc

Drag along circumference to 
change baseline length

Drag up or down to 
change radius of curve
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 Alternatively, change the radius by dragging the control point in the center of 
the baseline.

 Adjust Any Shape baselines by adding, deleting, changing or moving 
reference points like any embroidery object.

 To reshape, left-click to bend the line at an angle, right-click to bend into 
a curve.

 To re-position, drag any one of the baseline control points up or down.

 To delete, select a control point and press Delete.
 To change straight to curve, or curve to straight, select the control point 

and press Spacebar.
 Press Esc to finish.

Related topics
 Adjusting fixed-width baseline settings
 Adjusting curved baseline settings
 Reshaping letters
 Reshaping embroidery objects

Drag up or down to 
change radius of curve

Left or right-click on the
baseline to add

Drag to change curvature
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Adjusting fixed-width baseline settings

A free-line baseline does not have a fixed or pre-determined length – the 
baseline extends as long as you keep adding letters. A fixed-line baseline has a 
fixed length which you can digitize or specify numerically. Various options are 
available to handle text that extends beyond the baseline. 

Tip  Precise control over baseline width is important when combined with Team 
Names when you want to ensure all names fit within the same area such as a 
pocket.

To adjust fixed-width baseline settings
1 Double-click a selected lettering object/s to access object properties.

2 Click Settings. The Baseline Settings dialog opens. Options depend on 
baseline type.

3 Select a horizontal, vertical, or arc baseline from the list.

Use Toolbox > Lettering to adjust baseline settings.

Click to lay out
baseline

Adjust length and
angle values

Select auto
frame style

Select baseline
position
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4 Adjust the Length value as required.
Fixed-line baselines allow control over line length as well as options for 
handling text which does not fit the baseline. This is particularly useful for 
multiple ‘team’ names. Free-line baselines only allow you to adjust the Line 
Angle value. 

5 For fixed-line baselines, select an ‘auto-frame’ style:
 Spacing: Letter size and width stays the same and letters are spaced 

evenly along the baseline. Letters may overlap if the text is too wide.

Width: The width of each letter is reduced and the original spacing kept.

 Size (Keep Proportions): Letter width and height is reduced 
proportionally but the original spacing remains.

 Spacing and Width: Letter width and spacing is reduced.

 Spacing and Size (Keep Proportions): Letter width, height and spacing 
is reduced proportionally.

6 Adjust the Line Angle as required.
Enter the exact angle of baseline to the horizontal axis.

7 Select a baseline position.

When creating lettering for a badge, for example:
 For lettering above the badge, select a baseline below.
 For lettering below the badge, select a baseline above.
 For horizontal lettering through the middle of the badge, select a centered 

baseline.
8 Specify the letter, word and line spacing as required.
9 Select a letter orientation.
10 Click OK to return to Object Properties > Special.

Baseline 
below

Baseline 
centered

Baseline 
above
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Related topics
 Applying baselines
 Creating simple teamname designs
 Adjusting spacing settings
 Adjusting baselines

Adjusting curved baseline settings

Adjust baseline settings for more precise numeric control over radius (X and Y), 
as well as tilt, justification, and arc angles.

To adjust curved baseline settings
1 Double-click a selected lettering object/s to access object properties.

2 Click Settings. The Baseline Settings dialog opens. Options depend on 
baseline type.

3 Select a circle or arc baseline type from the list. The Tilt, Radius X, Radius 
Y, Justification Angle and Arc Angle fields are activated.

4 Adjust these values as required:
 Radius X: default radius of the baseline arc (X-axis).

Use Toolbox > Lettering to adjust baseline settings.

Click to lay out
baseline

Adjust Tilt, Radius X, 
Radius Y, Justification and 
Arc Angle values
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 Radius Y: default radius of the baseline arc (Y-axis).

 Tilt: angle of the baseline relative to the horizontal axis.

Note  The Tilt field is activated when Radius X and Radius Y values are 
different.
 Justification Angle: angle of the vertical axis through the lettering object 

relative to the horizontal axis.

 Arc Angle: angle between radii connecting ends of baseline to center of 
arc. This constrains the baseline so the text falls within the arc specified.

Tip  Precise control over baseline width is important when combined with 
Team Names when you want to ensure all names fit within the same area 

Radius X: 50
Radius Y: 50

Radius X: 50
Radius Y: 100

Radius X: 100
Radius Y: 50

Tilt angle 45°

Tilt angle 0°

Justification 
angle 90°

Justification
angle 45°

Arc angle 70°Arc angle 100°
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such as a pocket. A fixed width on arch baselines can be set by adjusting Arch 
Angle value in the Baseline panel.

5 Select a baseline position.

When digitizing lettering for a badge, for example:
 For lettering above, select a clockwise circle or arc with baseline below.
 For lettering below, select a counterclockwise circle or arc with baseline 

above.
 For horizontal lettering through the middle of the badge, select a fixed line 

with baseline centered.
6 For fixed-line baselines, select an ‘auto-frame’ style.
7 Specify the letter, word and line spacing as required.
8 Select a letter orientation. 
9 Click OK to return to Object Properties > Special > Lettering docker.

Related topics
 Creating simple teamname designs
 Adjusting fixed-width baseline settings
 Adjusting letter spacings on-screen
 Adjusting baselines

Changing letter orientation

You can define the rotation angle of letters relative to the baseline or the design 
itself. The latter lets you keep letters vertical regardless of baseline angle in 
order to achieve a ‘staircase effect’.

To change letter orientation
1 Right-click the Lettering icon or double-click selected lettering object/s to 

access object properties.

2 Click Settings to open the Baseline Settings dialog.

Baseline 
below

Baseline 
centered

Baseline 
above

Click to lay out
baseline
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3 Select an Orientation setting.

 Baseline: orients letters relative to the lettering baseline.
 Design: orients letters relative to the horizontal.

4 Enter an orientation angle.

5 Click OK to return to Object Properties > Special > Lettering docker.

Breaking apart lettering

Applying the Break Apart function to a lettering object breaks it into a logical 
stitching sequence while maintaining lettering object characteristics. Object 
properties can be edited separately for single lines, single words, or even single 
characters. Stitching sequence is maintained.

Sequence logic is as follows:
 Multi-line lettering can be broken into separate objects per line
 Individual lines can be broken into separate objects per word
 Words can be broken into separate objects per letter

Set orientation 
angle

Select orientation
relative to baseline

or design

Baseline angle: 0º 
Orientation: 60º to design

Baseline angle: 0º 
Orientation: 10º to baseline

Use Edit Tools > Break Apart to split composite objects – monograms, appliqués, 
lettering, etc – into component objects.

Lettering broken apart into
logical stitching sequence
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 Letters can be broken into their individual embroidery patches. Lettering 
properties are lost. Only general embroidery object properties remain.

Tip  An exception for single-line (multi-word) objects is the case of the 
center-out stitching sequence. Such objects are broken apart directly into 
single-letter objects. The stitching sequence is thereby preserved.

Related topics
 Breaking apart composite objects

Individual letter with full 
lettering object properties

Individual letter broken 
into separate embroidery 
patches

Properties of each patch 
can be separately edited
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Chapter 29

Advanced Embroidery Lettering

EmbroideryStudio provides a variety of 
advanced editing techniques for 
fine-tuning lettering designs. Add 
special characters and symbols as 
desired. By default, lettering objects 
are filled with Satin. Apply other basic 
fill stitch types as with all embroidery 
objects.
Specify the sequence in which letters 
are stitched to minimize registration 
problems. The automatic kerning 
feature improves lettering appearance 
and legibility by fine-tuning spacings 
between character pairs. Alternatively, 
fine-tune letter spacing according to 
the number of characters per lettering 
object. This is particularly useful with Asian fonts. Lettering appearance and 
quality can be improved by the correct selection of underlay. Apply Envelope 
effects to lettering objects to make them bulge or arch, stretch or compress.
This section shows you how to add special characters and symbols. It describes 
changing lettering stitch types in lettering objects, and adjusting lettering stitch 
angles. It also explains how to adjust the lettering stitching sequence as well as 
lettering join method. Automatic letter kerning and letter spacing are discussed. 
Lettering underlay is also discussed. It also describes how to create special 
effects with envelopes. 

Adding special characters

Embroidery and TrueType fonts generally contain many more characters than 
are available via keyboard. In EmbroideryStudio, you can add special characters 
and symbols directly through the Select Symbols dialog or by means of the 
MS Windows® Character Map.

Inserting symbols

Add special characters and symbols to your lettering designs.

Use Toolbox > Lettering to add special characters and symbols. Right-click to select 
lettering options.
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To insert symbols
1 Right-click the Lettering icon to access object properties.

Tip  If you already know the keyboard shortcut for a symbol, you can add it 
by entering the combination on screen or in the docker.

2 Click Insert Symbol.

3 Select a font or symbol set from the Symbol set list.
4 Select the symbols you want to use. Selected symbols are displayed in the 

Selection field.
5 Click OK. The selected symbols are displayed in the text entry panel of the 

Object Properties > Special > Lettering docker.

Creating flair script designs

Click to insert
symbols

Toggle display 
settings

Select font or
symbol set

Select
symbols

Selected symbols

Click to add

Use Toolbox > Lettering to add special characters and symbols. Right-click to select 
lettering options.
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Flair script is a special font which allows you to add decorative flairs to the end 
of text objects, mimicking flamboyant handwriting flourishes.

To create a flair script design
1 Right-click the Lettering icon to access object properties.

2 Select Flair Script from the Font list.
3 Enter the text you want to embroider in the text entry panel.
4 Click Insert Symbol.

5 Select the flourish you want to use. Scroll down for more options.

Select Flair Script
font

Enter text

Click to select special
characters

Select flourish

Corresponding
keystrokes
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6 Click OK to close the dialog. The selected characters are displayed in the text 
entry panel.

7 Adjust lettering settings as required and click OK.
8 Click an insertion point or mark reference points for the selected baseline.
9 Press Enter.

Tip  Experiment with different flourishes to obtain the look you want.

Adding monogram lettering

In addition to the dedicated Monogramming feature, EmbroideryStudio allows 
you to create monogramming designs using special monogram fonts. See also 
Monogramming.

To add monogram lettering
1 Right-click the Lettering icon to access object properties.

2 Select a suitable monogram font such as Octagon Monogram. See Embroidery 
Fonts for details.

$

Flourish added

Click to select fancy
lettering characters

Select monogram
font
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3 Click Insert Symbol. The Insert Symbol dialog opens.

Tip  When you select a character, a keystroke appears in the Selection field. 
This indicates the key combination required to type the character directly 
on-screen.

4 Select a left-facing letter. Octagon Monogram, for example, has three sets of 
each letter, one for the left side, one for the middle and one for the right side. 
When selecting letters, you need to ensure letter orientation is correct. 

5 Select a middle letter and then a right-facing letter.

6 Select a border if required.

7 Click OK. The selected characters are displayed in the text entry panel.
8 Click Create Text.

Select character

Corresponding
keystrokes

Select viewing 
mode

Select border
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Tip  If you want the letters in your monogram to be different colors, select 
and recolor one-by-one.

Using the Character Map

Use the MS Windows® Character Map to provide quick access to common 
symbols and letters. The Character Map is usually installed as part of the 
MS Windows® setup. See your MS Windows® documentation for more details.

To use the Character Map
1 Open the MS Windows® Character Map. By default, you will find it under 

Start > Programs > Accessories > System Tools > Character Map.

2 Select a font from droplist.
3 Double-click a character, or select it and press Select. The character/s appear 

in the Characters to copy field.
4 Click Copy to copy the character to the clipboard.
5 Paste it into the text entry panel of the Object Properties > Special > 

Lettering docker. To do this, click inside the text entry panel and press 
Ctrl+V or right-click to open the popup menu. 

Tip  You can also paste characters and symbols into an external graphics 
program to use as the basis for creating your own custom characters.

Select font

Select symbols
or double-click

Selected symbols
displayed Click to select

Click to copy
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Applying stitch types & effects to lettering

By default, lettering objects are filled with Satin stitch. You can apply other fill 
stitch types such as Tatami or Program Split as well as stitch effects such as 
Jagged Edge. See Stitch Types for details.

Note  Lettering values are stored in the <PRESET_LETTERING> style in the 
Normal template. Changing these does not affect the values of other objects. Do 
not delete or rename this style. See Working with styles for details. 

Satin lettering

By default, lettering objects are filled with Satin stitch. Because there are 
generally no needle penetrations breaking up the fill, satin stitch creates a 
glossy, high-quality effect suitable for most lettering.

Satin Raised can be applied successfully to some styles of font for a raised 
embroidery surface. Outlines can be added with the Outlines & Offsets tool for 
use with quilted designs. Traditionally, trapunto utilizes two or more layers, the 
underside of which is slit and padded, producing a raised surface on the quilt. 

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow columns 
and shapes. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be applied to 
lettering or used with trapunto for quilting effects. Right-click for settings.

Auto Spacing OFF
Stitch Spacing 0.6 mm

Auto Spacing ON
Stitch Density 60 %

Auto Spacing ON
Stitch Density 100 %
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Lay the second layer over Satin Raised lettering and stitch down with trapunto 
outlines.

Note  EmbroideryStudio also includes as standard a number of dedicated 3D 
fonts.

Related topics
 Satin stitching
 Embroidery Fonts
 Generating outlines & offsets

Tatami lettering

You can fill lettering shapes with Tatami stitching. This may be suitable for filling 
larger lettering shapes.

Zigzag lettering

Zigzag stitch can be applied to lettering for any open stitching effect.

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. Right-click 
for settings.

Use Fill Stitch Types > Zigzag to create fills with an open ‘sawtooth’ effect. 
Right-click for settings.

Stitch Spacing 0.4 mm
Stitch Length 2 mm

Stitch Spacing 0.6 mm
Stitch Length 3 mm

Stitch Spacing 0.4 mm
Stitch Length 5 mm
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Related topics
 Open fills & borders
 Embroidery Fonts

Patterned lettering

Try applying Program Split to lettering. This too may be suitable for filling 
larger lettering shapes or for special effects. Density is determined by stitch 
spacing.

Related topics
 Creating textures with program splits

Jagged edge lettering

Jagged Edge can be used with lettering objects for special ‘spooky’ effects or 
fluffy textures.

Related topics
 Creating furry or fluffy edges

Use Fill Stitch Types > Program Split to create decorative fill stitches where needle 
penetrations form a tiled pattern.

Use Stitch Effects > Jagged Edge to create rough edges, shading effects, or imitate 
fur and other fluffy textures along one or more sides of selected objects.
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Creating special effects with lettering art

Apply Lettering Art effects to make letters bulge or arch, stretch or compress. 
Many styles are available from the Lettering Art gallery. You can fine-tune 
preset shapes as preferred. Edit lettering text in envelopes the same way as 
normal lettering. Return lettering to its original shape by removing the envelope 
altogether.

To create lettering art effects
 Create a lettering object.

 Double-click the object to access its properties.
 Scroll through the Lettering Art list or click More to access the gallery. You 

can tear it off for easy access.

Use Toolbox > Lettering to edit letters on-screen.

Use Reshape Tools > Reshape Object to reshape selected objects by means of 
control points.

Click to apply a 
predefined shape

Scroll or click More button 
to access gallery
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 Select a shape from the gallery.

 Click again to access rotation control handles.

 Use Reshape Object to fine-tune the envelope shape.

 Drag control handles to adjust:
 To move two handles in opposite directions, hold Shift while dragging.
 To move handles in the same direction, hold Ctrl while dragging.

 Press Esc to finish.

Drag nodes to 
reshape
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 To edit, click the Lettering icon with the object selected. Duplicate letters 
appear below.

 Click inside the duplicate and edit text as desired. Press Enter to confirm.

 To return an object to its original shape, click Remove Art.

Related topics
 Applying envelopes

Setting stitching sequence & join method

You can specify the sequence in which letters are stitched to minimize 
registration problems such as on caps or difficult fabrics. While the Closest Join 
method is recommended in most cases to minimize trims, you may sometimes 
want to use the As Digitized setting with fonts which include multiple colors, 
multiple stitch types, or special effects.

Adjusting letter sequencing

You can specify the sequence in which letters are stitched to minimize 
registration problems such as on caps or difficult fabrics. For example, the 

Edit duplicate letters and 
press Enter

Click to remove 
effect

Click Toolbox > Lettering to adjust the lettering stitching sequence.
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Center Out option is especially useful when stitching on caps. There are also 
options for multiple lines of lettering which are useful for machines without 
trimmers.

To adjust letter sequencing
1 Right-click the Lettering icon or double-click selected lettering object/s to 

access object properties.

2 Click Sequence. The Letter Sequence dialog opens.

3 Select a stitching sequence. Options include:
 In-line: Select whether you want the lettering to be stitched left-to-right 

or right-to-left in each line.

 Center-out: Select this checkbox if you want the lettering stitched from 
center out.

 Line-by-line: Choose whether you want multiple lines to stitch 
top-to-bottom or bottom-to-top.

Click Sequence

Adjust single line
stitching sequence

Adjust multiple line
stitching sequence

 Stitched left-to-right Stitched right-to-left

 Left side stitched first Right side stitched first

Stitched 
bottom-to-top 

Stitched
top-to-bottom
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Note  You can combine both In-line and Line-by-line sequencing options.
4 Click OK to return to the Special tab.

Tip  Travel through your design to check the stitching sequence. See Travel 
through designs for details.

Changing lettering join method

The lettering stitch method is preset to give the best results for each font. In 
most cases, Closest Join is recommended in order to minimize trims.

Lettering objects normally consist of one stitch type and one color only. However, 
the As Digitized join method together with Original Stitch Values setting can 
be used with special fonts which combine several stitch types – e.g. Satin with 
Run, or Tatami, or Motifs. The As Digitized setting can also be used with 
fonts which include multiple colors or special effects. Such fonts may include 
machine functions, as for two-color fonts, or run stitches as part of the cover 
stitching.

To change the lettering join method
1 Right-click the Lettering icon or double-click selected lettering object/s to 

access object properties.
2 Click Sequence. The Letter Sequence dialog opens.

Use Toolbox > Lettering to change the lettering join stitch method.

Select join method

Select Original Stitch 
Values
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3 Select a stitch method from the droplist:

Options include:

4 Select the Original stitch values checkbox as required.
This setting is only available if the As Digitized join type is selected. Use it 
with special fonts which combine several stitch types. If not selected, these 
letters will be stitched with a single stitch type.

5 Click OK to return to the Special tab.

Related topics
 For recommended stitch and join methods, see Embroidery Fonts.

Setting automatic letter kerning

The automatic kerning feature improves lettering appearance and legibility by 
fine-tuning spacings between character pairs. Typically, spacing between certain 
pairs looks uneven due to the optical illusion formed by mixing straight lines with 
curves. Automatic kerning optimizes spacing between lettering pairs according 
to preset values. While it works very well without customization, advanced users 

Join Purpose

Bottom join Letters are joined along the baseline. Use it when stitching on 
towelling – joins are hidden in the pile.

Closest join Letters are joined at the closest point. Use it to minimize trims.

As digitized Letters are joined the same way they were originally digitized. Use 
it with fonts combining different fill stitch types or special effects.

Closest join As digitizedBottom join

As digitized – original 
stitch values selected

As digitized – original stitch 
values not selected

Closest join
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can customize these values as they wish. Kerning tables can even be copied from 
similar MS Windows® fonts.

Tip  For more information about kerning, see the Windows Dev Center topic on 
Justification, Kerning, and Spacing.

Applying automatic kerning

The automatic kerning option is accessed by means of the Object Properties 
docker.

To apply automatic kerning
1 Double-click a lettering object to access object properties.

2 Scroll down to the Spacing panel. If a kerning table exists for the selected 
embroidery font or TrueType font, the Auto Kerning checkbox is enabled and 
selected by default.

3 Select Auto Kerning as required and click Apply.

Related topics
 Setting automatic letter spacing

Managing kerning tables

A kerning table is an array of kerning values for every possible pair of letters in 
the font. The Kerning Table command accesses a dialog used to manage 
kerning tables. You can copy tables from one font – embroidery or TrueType – to 
another or remove its kerning table altogether.

Right-click Toolbox > Lettering to adjust automatic kerning for selected lettering 
objects.

Click auto
kerning

Use Docker > Object Properties to access kerning tables.

https://msdn.microsoft.com/en-us/library/windows/desktop/hh994452%28v=vs.85%29.aspx


EmbroideryStudio e4 User Manual 595

Note  TrueType kerning tables cannot be replaced, added to, or modified in any 
way. You can, however, convert a TrueType font to an embroidery font and add 
or modify a kerning table as required.

To manage kerning tables
1 Open the Object Properties > Special > Lettering docker.
2 Select a font from the droplist.

3 Scroll down and click the Kerning Table button. The Kerning Table dialog 
opens with the current (target) embroidery font displayed. The droplist 
displays all fonts that contain kerning tables.

4 Choose a suitable font or TrueType font from the list and click Copy Source 
to Table to load its kerning table to the current embroidery font.
The Zero Table command is enabled if the current (target) font already has 
a kerning table.

Editing kerning values

You have created a lettering object which has Automatic Kerning toggled on. 
Use this procedure to update kerning settings for contiguous pairs of letters.

To edit kerning values
1 Select a lettering object with automatic kerning and click the Reshape icon.

Click to access
kerning table

Choose similar 
font

Current (target)
font

Copy kerning table
to current font

Use Reshape Tools > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust start/end points.
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2 Click the diamond control point in the center of the letter.
3 Drag selected letter/s along the baseline or use arrow keys to adjust the 

spacing. Alternatively, to move multiple letters, right-click the diamond 
control point of the first letter and drag. All letters to the end of the line move 
as one.

4 Repeat as many times as necessary to fine-tune all letter spacings in the 
object.

5 Select one or more blocks of contiguous letters by Ctrl-clicking their diamond 
control points or dragging a selection box around them.

6 Select Object > Update Kerning Settings. The operation will affect letter 
spacing of all new lettering objects.

7 Click OK.
A new kerning value is generated for each contiguous pair of letters, and 
written to the associated kerning table.

Related topics
 Adjusting letter spacings on-screen

Setting automatic letter spacing

The Auto Letter Spacing feature allows you to fine-tune letter spacing 
according to the number of characters per lettering object. When activated, 
EmbroideryStudio automatically spaces letters according to a predefined 
spacing table. For example, in a five-character lettering object, spacing may be 
set to 2mm, while in a three-character lettering object, it may be increased to, 
say, 3mm.

Without auto letter 
spacing

With auto letter 
spacing
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To apply automatic letter spacing
1 Create or select a lettering object and double-click to access object 

properties.

2 Select a baseline for use with Auto Letter Spacing. Automatic letter spacing 
is available for all baselines. However, with fixed-line and arc baselines, 
automatic spacing only works with Width and Size options selected.

3 Tick the Auto Letter Spacing checkbox.
4 Click the Letter Spacing Table button. The Letter Spacing Table dialog 

contains a matrix of settings for lettering objects of two to six or more 
characters.

5 Adjust spacings for each character grouping. The topmost field for two 
characters has a range of 0.10mm to 100.00mm.

6 Click OK. With the Auto Letter Spacing checkbox checked:
 For a lettering object with more than one line of text, the system will use 

the longest line of text for the letter spacing. 

Auto letter spacing
unticked by default

Single line of text – uses predefined 
character length for letter spacing

Multiple lines of text – uses character length of 
longest line for letter spacing – in this case, 3 
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 The letter spacing table will not change even if individual letters are resized 
in Reshape mode.

Tip  The Auto Letter Spacing feature also works with the Team Names 
feature. Any ‘name frame’ can have a specified letter spacing just as it can 
assume any other lettering property.

Related topics
 Setting automatic letter kerning
 Adjusting baselines
 Creating simple teamname designs

Setting lettering underlay

Lettering appearance and quality depends a lot on underlay which serves as a 
foundation for cover stitching. As well as stabilizing, underlay also provides ‘loft’, 
raising cover stitches and preventing them from sinking into soft fabrics. It can 
also prepare a napped fabric by flattening it. 

Most lettering used in designs is 15 mm high or less. The columns at such sizes 
are less than 3 mm wide for normal – not heavy or block – fonts. Such objects 
are best served with a single Center Run or Edge Run underlay. Here are a few 
rules of thumb:
 Lettering with heights under 5 mm should not have underlay. 
 Letters 6 mm to 10 mm can have a center-run underlay applied. 
 Lettering larger than 10 mm is large enough for edge-run underlay. 
 Large letters for jacket backs and so on can use a second layer of underlay. 

Double-zigzag is sometimes used to give added loft.

To set lettering underlay
1 Select a lettering object.

Letter resized - spacing 
stays the same

Right-click Stitch Effects > Auto Underlay to adjust lettering underlay settings.
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2 Right-click the Auto Underlay icon to access object properties.

3 Select the First Underlay checkbox and select Center Run or Edge Run as 
the First underlay type. If you select Edge Run, a further By Shape option 
becomes available. When activated, underlay is applied to the lettering object 
as a whole.

4 Select the By Segment or By Shape option as required.

Note  With most embroidery objects, underlay is stitched 
segment-by-segment before cover stitches are sewn. Lettering underlay, 
however, defaults to a single By Shape > Edge Run underlay, except ‘As 
Digitized’ lettering. This has the effect of calculating an underlay for the entire 
shape rather than each segment comprising it. This in turn reduces bunching, 
travel runs, and overall stitch count.

5 Enter the required length values for each underlay type. 
6 If you are using zigzag underlay, adjust stitch angles to create a ‘cross-hatch’ 

effect. This may provide more support than single zigzag.

7 Press Enter or click Apply.

Tip  Run Stitch Player to see how the underlay will stitch out.

Adjust fixed or 
variable run length

Select Edge Run 
(or Center Run)

Select 1st underlay and 
optionally select ‘by shape’

Segments comprising letter Underlay ‘by segment’ Underlay ‘by shape’

Default Zigzag Slanted Zigzag Slanted Double Zigzag
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Related topics
 Run stitch underlay settings
 Zigzag underlay settings
 Simulate design stitchouts
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Chapter 30

Team Names

The Team Names feature lets you create designs with multiple names. For 
example, you can use the same logo with different names for sports teams or 
corporate uniforms, without having to create multiple copies of the same design. 
Depending on how you want to stitch out, you can choose to save and stitch 
names and designs separately, or together.

This section shows you how to set up teams and create teamname designs. It 
also describes how to modify teamname designs and output them in a variety of 
ways.

Creating simple teamname designs

Create simple teamname designs by keying names directly into the Team 
Names docker. Alternatively, import names from a tab-delimited text file. By 
default, teamname objects consist of a single baseline with three names. Add or 
remove name columns as desired.

Creating teamname objects

To associate team members with a design, you create a variable ‘teamname 
object’. Either key in the names of the team members directly, or import from a 
list provided by the customer.

Use Toolbox or Docker > Team Names to associate multiple names with a design.
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To create a teamname object
 Open the design you want to use.

 Click the Team Names icon to access the docker. By default, the teamname 
object will consist of a single baseline with three names.

 If you are happy with the default layout, simply click a cell and start typing. 
Press Tab or Shift+Tab to move back and forth through name fields.

 Alternatively, use the Teamname List tools to add names, delete names, 
etc:

Tool Description

Manage Teams Manage teams and team members for future use. See 
below.

Import Team 
Members Import or export a list of team members in either TXT or CSV 

format. Names must be comma delimited.Export Team 
Members

Name Order Change default naming order or include/exclude names as 
required.

Remove Selected Delete selected rows or the entire member list.

Select All Select all list members for modification or positioning.

Click a cell and 
start typing
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 Optionally, click the Import Team Members button to import team 
members from a list possibly provided by the customer. The list must be 
comma delimited.

Tip  When you import a teamname list you can import it from anywhere. 
However, you cannot use the Manage Teams dialog effectively with it unless 
it is saved in the ‘Teamname Teams’ system folder. See Managing teams for 
details.

 Click the Name Order button if you want to change the default naming order. 
Use it, for example, to put surnames first or limit which names are included 
– e.g first and third.

Sort Ascending

Sort a selected column in ascending or descending order.

Sort Descending

Tool Description

Import names 
as TXT or CSV

Change name order
as desired
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 Click OK and enter reference points as prompted.

 Select all names and select Stitch > Generate Stitches or press G.
 Select names one-by-one to view them in the design.

Related topics
 Managing teams 
 Teamname templates
 Applying baselines

Importing teamname lists with additional fields

A ‘size’ field is often added to teamname lists even though it does not form part 
of the design. While the size field doesn’t appear in the design, it is added to 

Choose a name to 
view on-screen

Use Team Names > Import Team Members to import a list of team members in 
either TXT or CSV format. Names must be comma delimited.

Use Team Names > Manage Teams to manage teams and team members for 
future use.
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each design name when generated. This allows machinists to ensure they are 
using the right size garment for the specified name.

To view size fields in the Manage Teams dialog, first save the teamname file in 
CSV or TXT format to the Teamname Teams folder as shown. Don’t use 
subfolders.

Navigate to Public 
Embroidery

Save to Teamname 
Teams folder
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Open the Manage Teams dialog and select the file name from the Teams 
droplist. All fields will be imported...

Teamname templates

The Team Names feature allows you to use pre-defined layouts or create your 
own. These layouts may consist of single or multiple baselines, each with one or 
more names.

Using templates with teamname designs

When creating teamname designs, you can use a preset layout or a custom 
layout based on artwork you may have received.

To use a template with a teamname design
 Open the design you want to use.

Use Toolbox or Docker > Team Names to select a layout for your teamname design.
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 Click the Team Names icon to access the docker and choose the Designs 
tab. This tab includes template samples as well as any custom designs saved 
as teamname templates. These may contain more than one baseline.

 Choose a template on which to base your intended layout. 
 If you haven’t already entered the names, switch to the Teamname List and 

key in or import the names to use. The sample below uses two sets of names 
on separate baselines.

 Press G to generate stitching and use arrow keys to ‘nudge’ the lettering into 
position.

 Use the Teamname List to select and view individual team members.

Select a design category 
and choose a template

Choose a name to 
view on-screen
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 To reposition or modify a lettering object within a teamname object, first hold 
down the Alt key and click to select it.

 Edit lettering object properties as desired. 

Related topics
 Selecting objects within groups
 Modifying teamname designs

Creating custom templates

Typically, you will receive a brief and possibly artwork from a customer. Before 
you even import the names, you may prefer to mock up the design for approval 
purposes. This same design can then be saved as a teamname template.

Hold down Alt key to 
select and reposition

Edit properties and 
apply to all as desired
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To create a custom template
1 Import any artwork needed for your template.

2 Add any lettering elements you want to use. Include any ‘static’ elements 
which won’t change in the eventual teamname design.

3 Optionally, give generic names to any text which will form part of the eventual 
teamname design – ‘TEAM NAME’.

Key in generic names 
for eventual teamname 
objects
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4 Select any lettering that is to remain static – e.g. ‘Zetland Highshool’ – and 
lock by pressing the K shortcut. When the template is opened, the locked text 
will be excluded from the teamname object.

5 Select File > Save As Teamname Template, enter a name for the layout 
– e.g. ‘Zetland High’ – and click OK. The dialog opens onto the Custom 
teamname templates folder. When you save here, the design will appear in 
the Designs tab under the Custom folder.

Select static text 
and press K to 
lock

Save to custom 
templates folder

Enter template 
name

Navigate to Public 
Embroidery
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6 To test your template, open a new design tab and click the Team Names icon 
to access the docker. Go to Designs > Custom to locate your template. Once 
opened, the unlocked text will be interpreted as a teamname object.

7 Edit the text as you would any other teamname template.

Related topics
 Creating simple teamname designs
 Using templates with teamname designs

Modifying teamname designs

You can preview individual team names as they will be stitched out. Add or 
delete names, sort teamname lists, and change properties of team members. 
Set properties such as font, size or color for each name. You can also set 
properties for an entire column of names.

Choose a name to 
view on-screen

Use Toolbox > Team Names to add/remove team members and edit individual 
names.

Right-click Toolbox > Lettering to edit lettering on-screen.
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To modify a teamname design
 Open a teamname design and click the Team Names icon. By default all 

names are selected.

 Adjust positioning of the teamname group as desired.

 View team names in any of the following ways:
 Select a name.

Select all team 
members
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 Use arrows keys to scroll up and down the list to view each name in turn.

 Click list header to select a column of names – use Sort buttons to sort lists 
in ascending or descending alphabetical order.

 Click a cell to select an individual name in the Teamname List.

Select name to
view on-screen

Click to select
column

Click again to sort 
column alphabetically

Select and edit 
individual name
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 Edit selected names on-screen as you would any other lettering object – e.g. 
adjust letter kerning.

 Adjust lettering baselines as you would any other lettering object. For 
example, select an ‘auto-frame’ style for fixed line baselines.

 Use the Teamname List tools to add names, delete names, change 
properties, as required:

 To view and/or edit member properties, click Object Properties.

Tip  By default a space is inserted between names. To remove this space, set 
the Word Spacing value in the Layout dialog to 0%. 

Tool Description

Manage Teams Manage teams and team members for future use.

Remove Delete selected rows or the entire member list.

Select All Select all list members for modification or positioning.

Sort Ascending

Sort a selected column in ascending or descending order.

Sort Descending

Object Properties Edit properties of selected rows, columns or all list members.

Apply to All Copy one team member’s properties to all members.

Create Designs Create individual designs for each member.

Teamname 
Matrix

Create a matrix of all teamname designs, sequenced for 
efficient stitchout. See below.

Ben Waburton

Adjust name
settings

Edit text for
individual name

Change font
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Related topics
 Creating simple teamname designs
 Adjusting spacing settings
 Editing Embroidery Lettering
 Adjusting fixed-width baseline settings

Managing teams

A teamname object may contain all names in a given team, or a subset of those 
names. You can even combine members from different teams.

To manage teams
 Open a teamname design and click the Team Names icon. By default all 

names are selected.
 To save a team for future use, click the Export Team Members icon in the 

Teamname List. The dialog will open onto a public folder containing all your 
teams – a single file, either TXT or CSV, for each team.

Use Toolbox or Docker > Team Names to associate multiple names with a design.

Use Team Names > Export Team Members to export a list of team members in 
either TXT or CSV format.

Use Team Names > Manage Teams to manage teams and team members for 
future use.

Enter team 
name

Dialog opens to 
Public Embroidery

Save to Teamname 
Teams folder
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 Click the Manage Teams icon to access the dialog. The Team Members 
panel will default to the last opened team.

 To view the team you have just exported, select from the Teams droplist.

 Use the +Column or -Column buttons to establish the number of names for 
each team member – the default is three (3).

 Select names to associate with the design. To select multiple names, hold 
down Ctrl or Shift as you select.

 Edit the list as necessary by means of Delete and Edit buttons.
 Add team members one-by-one or as a group:

Manage teams Manage current 
teamname list

Select team

Edit names as
required

Use controls to add,
delete or edit team

members
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 To add a single name, click Add in the Team Members panel.

 To add a group of names, click Quick Names. Enter names in the format 
Name 1, Name 2, Name 3.

Tip  You can type in the names, or paste them in from a text file. Each name 
must be separated by a comma. There is no need for a space.

 Click OK. The new names are added to the Team Members list. 
 Transfer names, selectively or all together, to the Teamname list using the 

arrow buttons. You can even transfer names from different teams to the same 
list.

 Edit the list as desired:
 Sort names alphabetically by column.
 Sequence names – this will determine their stitching order.
 Remove names from the list.

Add nameBen

John

Warburton

Prasanna,E,Nanaya

Ben,John,Warburton

Petar,Michael,Pavlovic

Ichiro,Roy,Suzuki

Khieng,,King

Sam,,Kong

Enter names

Adjust name order
for current design

Use controls to
transfer names

between lists

Move selected
names

List of names used 
in current design
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 Click the Name Order button if you want to change the default naming order. 
Use it, for example, to put surnames first or limit which names are included 
– e.g first and third.

Outputting teamname designs

You can create individual designs from each name in a teamname design. 
Alternatively, you can create a matrix of names optimized for batch stitching. 

For output, you can generate machine files consisting of:
 Both design and names
 Design in one file and names in another, or 
 Design and names in individual files.

Creating separate designs

You can create individual designs from each name in a teamname design.

Change name order
as desired

Use Toolbox or Docker > Team Names to add/remove team members and edit 
individual names.
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To create separate designs
1 Open a design and click the Team Names icon. By default all member names 

are selected.

2 Select names to output – click Select All or use Ctrl and Shift keys to 
selectively choose.

3 To create individual embroidery designs for each team member, click Create 
Designs. Designs are generated for each name. The name is now a normal 
lettering object.

4 Save each design out individually.

Creating a matrix of designs

The Teamname Matrix function allows you to create a matrix of names 
optimized for batch stitching. Minimize the number of color changes created by 
the matrix operation.

Select names to
output

Click to create 
individual designs 

Use Team Names docker > Teamname Matrix to automatically create a matrix of 
all names in a teamname object together with their corresponding design.



Chapter 30   Team Names 620

To create a matrix of designs
1 Open a teamname design.

2 Select everything you want to include and click the Teamname Matrix icon 
in the Teamname List tools.
The number of rows and columns in the matrix are automatically calculated 
according to number of team names, row and column height settings, and the 
physical area of the hoop. More than one hooping may be calculated.

3 Adjust height and width settings to match the intended hoop.
4 Adjust row height and column width to set the gap for most efficient stitchout.

Increase settings if you want to enlarge the gap between designs. Calculated 
fields are updated, including number of rows/columns and output files.

5 Select a Sequence option. Each option indicates a possible stitching 
sequence for the entire matrix.

Adjust row and 
column settings

Adjust hoop width
and height

Select stitching
sequence

Select to minimize 
color changes

Calculated rows and 
columns
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6 Optionally, select the Minimize Color Changes checkbox. When selected, 
the entire matrix is resequenced by color.

7 Click OK. A new file is created containing the number of team names that will 
fit into the specified hoop – i.e. number of rows multiplied by number of 
columns. If needed, another file is created to accommodate additional names. 
The Output Files field indicates the total number of files.

Outputting teamname designs 

When you output a teamname design, you need to define how it is to be 
generated as a machine file. You can generate files that include:
 Both design and names in a single file
 Design in one file and names in another, or
 Individual files for each name plus design.
You set these options whenever you save the file in machine format or output 
directly to machine.

Accessing output options
You access the Save Options > Team Names dialog in any of these ways:
 Select File > Export Machine File, choose a machine file format – e.g. DST 

– from the Save as type droplist, and click Options.
 Select File > Record in Database, choose a machine file format – e.g. DST 

– from the Save as type droplist, and click Options.
 Select Legacy Features > Disk > Save As > Options.
 Select Legacy Features > Send to Machine Manager > Options.
 Select Legacy Features > Send to Stitch Manager > Options.
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 Select File > Send to Connection Manager > Options.

Output options
The following output options are available to you:

Available centering methods
The Auto Start and End feature is available to specify first and last stitches in 
a design. This makes it easy to position the needle before stitching, and reduces 
the chance of the needle hitting the side of the frame.

Option Purpose

Design and team 
names, with 
Stops

Creates a single machine file including one copy of the design and all 
names. Stops are inserted after the design, and between the names – 
i.e. Design Stop TeamMember1 Stop TeamMember2 Stop, etc.

Repeated design 
and team names, 
with Stops

Creates a single machine file with multiple copies of the design, and all 
names. Stops are inserted after each static design/name combination 
– e.g. Design + TeamMember1 Stop Design + TeamMember2 Stop.

Create multiple 
output files

Creates separate files for each name, each of which includes a copy of 
the static part of the design. When stitching to ES Machine Manager, 
each file is queued separately.

Design part only Creates a file containing only the static part of the design.

Team names only, 
with Stops

Creates a single file containing only the names, separated by stops. 
This means that after each machine stop, you can change frames.

Method Description

Auto Start and 
End

Auto Start and End is automatically turned on during Team Names 
output, defaulting to Center-Center. Select one of the nine preset end 
points. 

Return to Start 
Point

Creates a connecting stitch from the end point to the start point.

Use Digitized 
Auto Start/End 
Point

This option is primarily used with multi-decoration designs where you 
want to strictly define the start/end point of the embroidery component. 
It is only available if there are already digitized start and end points in 
the design.

Auto start/end method 
options enabled for all 
output options
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The trouble comes when you try to set a common start and end point for team 
names. 

Teamname designs, however, can be stitched in a consistent location on the 
garment irrespective of name length. Select either output option:
 ‘Repeated design and team names, with Stops’, or
 ‘Team names only, with Stops’.
And select one of the nine Auto Start and End preset end points. 
The purpose of auto-alignment is to allow ‘name frame’ layouts and optional 
repeated designs to be stitched in a consistent location on the garment where 
names are of varying lengths.

Related topics
 Sending designs to Stitch Manager
 Setting auto start & end

Auto alignment off Auto alignment on
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Chapter 31

Monogramming

A monogram is a design composed of one 
or more letters, typically the initials of a 
name, used as an identifying mark. The 
Monogramming feature offers a simple way 
to create personalized monograms using a 
selection of pre-defined monogramming 
styles, border shapes and ornaments, 
together with a set of tools to help you 
place these elements in creative and 
decorative ways.
This section details the creation of 
monogram lettering with initials or with a 
name, how to add ornaments to 
monograms, and how to create ornament 
layouts.

Monogram designs

You build monograms using the Monogramming docker. The simplest way to 
get started is to select a base design from the Designs tab. This tab gives you 
a selection of design templates ranging from lettering only, with borders or with 
ornaments. The Custom folder contains your own custom designs. Select a 

Use Toolbox > Monogramming to create personalized monograms using a 
selection of pre-defined monogramming styles, border shapes and ornaments.
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design template from the display panel and modify as required via the other 
tabs.

Note that the monogramming design is grouped in the Color-Object List 
docker. It is treated as a single, composite object. It can only be edited via the 
Monogramming docker. It cannot be ungrouped but it can be broken apart into 
its components. See also Breaking apart lettering.

Select monogram type and
choose a design template Use Custom folder 

for custom designs

Monogram grouped as
composite object

Break apart composite 
objects
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However, if all you want to do is recolor monogram elements, you can select 
them individually without breaking apart the monogram. Simply hold down Alt 
and click the object.

If you want to save a design as a template for future use, use the File > Save 
as Monogram Template command. The dialog opens onto the Custom 
monogram designs folder. When you save here, the design will appear in the 
Designs tab under the Custom folder.

Monogram lettering

Use Alt key to
select and recolor

Enter a name for your
custom template

Use Toolbox > Monogramming to create personalized monograms using a 
selection of pre-defined monogramming styles, border shapes and ornaments.
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The Letters tab of the Monogramming docker allows you to create 
personalized monograms with initials, including special characters and symbols, 
or unlimited lines of characters.

The Letters tab provides similar options to the Lettering tab of the Object 
Properties docker. If you are using one of the template designs, the easiest way 
to adapt it is to apply a different style. Change initials as required and choose 
from any number of native embroidery fonts or any TrueType font installed on 
your system. In addition, this tab provides a selection of styles to choose from.

Choose lettering 
style

Choose lettering 
font
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In place of single letters, the same tab allows you to enter multiple lines.

If a selected style doesn’t quite give you what you are looking for, open the 
Advanced panel to access more settings. Use these to adjust letter width, 
spacing, etc. Adjust letter rotation and baseline angle. These allow you rotate 
individual letters or the entire baseline.

Click Properties to make any further adjustments – e.g. stitch type. The default 
values for monogram lettering are different from those for conventional 
lettering. All settings can, however, be controlled via the Object Properties 
docker. See also Creating lettering with object properties.

Monogram ornaments

Ornaments can be added to a monogram either from motif patterns or from any 
design file. You have a choice of:
 Adding ornament motif patterns or designs
 Creating single ornament layouts

Enter multiple 
lines of text

Access advanced 
settings

Access full set of 
object properties

Use Digitize > Monogramming to create personalized monograms using a selection 
of pre-defined monogramming styles, border shapes and ornaments.
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 Creating multi-ornament layouts.

Modifying ornaments

If you are using a template design or adapting another monogram, it is a simple 
matter to change the ornament to a different type or configuration. Use the 
buttons at the top of the Ornaments tab to add, delete, or change ornaments.

Choose from a range of preset placement patterns, including Mirrors, 
Duplicates, and Cycle. Note that the pyramid icon indicates not only the 
placement but also the orientation of the pattern in both horizontal and vertical 
planes.

Add, delete, or change 
ornaments

Choose preset 
placement pattern
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If the preset pattern gallery doesn’t quite give you what you are looking for, open 
the Advanced panel. These settings give you precise control over ornament 
placement, size, rotation, orientation, and margin.

Adding ornaments

You can add up to ten ornament sets to a monogram design and change them 
at any time. Any available motif set can be used. 

Access advanced 
settings

Fine-tune ornament 
placement, size, rotation, 
orientation, and margin

Choose ornaments from
any available motif set
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A set of ornamental designs is also available. These are stored in their own 
Ornaments folder.

Use the checkboxes to add up to eight instances of a selected ornament. These 
are arranged according to ornament placements relative to the lettering.

The first selected serves as the ‘anchor’ position (highlighted in red). All other 
ornaments are sized, rotated and mirrored in relation to it. Use the Width and 
Height fields to change ornament dimensions. The Lock Aspect Ratio toggle 
forces width and height to maintain their proportions. Use the Margin setting to 
offset ornaments from the lettering.

Creating single ornament layouts

Use Position #5 to insert an ornament as a standalone component within a set. 
All other checkboxes are unchecked automatically. Width, Height, and Rotate 

Access advanced 
settings

Anchor position 
highlighted in red
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By fields and Mirror checkboxes remain available, and Offset controls replace 
the Margin control.

Use the X and Y fields in the Offset panel to position the ornament horizontally 
or vertically relative to the lettering object. These settings specify the position 
of the ornament center relative to the center of the lettering object.

Multi-ornament layouts

You can add up to eight instances of a selected ornament to your monogram. 
Any combination of ornaments and ornament positions can be used. Add the 
ornament sets you want and assign placements to each one.

Remember, if you want to recolor monogram components, you can select them 
individually without breaking apart the monogram. Simply hold down Alt and 
click the object.

Monogram borders

Position ornament relative
to lettering object

Use Toolbox > Monogramming to create personalized monograms using a 
selection of pre-defined monogramming styles, border shapes and ornaments.
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You can add up to four borders of the same shape to a monogram design.

Changing borders

If you are using one of the template designs, it is a simple matter to change 
borders. Use the Change button on the Borders tab to select from one of the 
many available.
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Adjusting border shape & offset

Use the Aspect Ratio settings to adjust height and width proportions.

Use the Offset field to fine-tune margins between lettering and border, and 
between border and border.

Adjust aspect ratio to
change border

proportions
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Use the Rotate field to re-orientate the border as desired.

Adding multiple borders

Add up to four borders to the selected monogram. Use the Offset field to adjust 
margins between multiple borders. The software lets you enter a negative offset. 
This allows you to create multiple overlapping borders.

Use the Stitch Type buttons to change to line or fill stitch type for selected 
borders. Satin Line is the default stitch type. All line and fill stitch types available 
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in the software can be used as borders. Click the Properties button to make 
further adjustments.

Remember, if you want to recolor monogram elements, you can select them 
individually without breaking apart the monogram. Simply hold down Alt and 
click the object.
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Chapter 32

Custom Fonts

Turn any TrueType font installed on your system into an embroidery font. 
Sometimes you find that you want to reshape a letter to improve its appearance, 
perhaps to suit a particular lettering height. EmbroideryStudio lets you save the 
letter as an alternative version. You can even create custom fonts or modify an 
existing font for special applications. Even merge letters from two or more fonts.

This section describes how to create new embroidery fonts from TrueType fonts. 
Automatic letter kerning and user-refined fonts are explained. It also describes 
how to create, modify, and merge your custom fonts and letters.

Converting TrueType fonts to embroidery

The Convert TrueType Font feature lets you convert any TrueType font 
installed on your system to an embroidery font. You can do this ‘on-the-fly’ or 
convert entire fonts for later use. This is an important feature for Asian fonts 
which may contain several thousands of characters.

The process is fully automatic. Lettering shapes are ‘cut’ into Column A or 
Column B embroidery objects. Overlaps and stroke order are detected and stitch 
angles defined. The result is similar to manually digitized fonts although the 
quality may not be quite as high. The quality greatly depends on the original 
shapes, narrower serif type fonts producing better results than blocked fonts.
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Converting letters on-the-fly

You can convert individual TrueType letters ‘on-the-fly’ and add them directly to 
a design through the Object Properties docker.

Tip  If your product level allows it, you can add and format TrueType lettering in 
CorelDRAW Graphics. This can then be converted to either embroidery 
lettering or embroidery objects.

To convert TrueType letters on-the-fly
1 Right-click the Lettering icon to access object properties.

2 Select a TrueType font from the droplist.
3 Enter the text you want to embroider.
4 Optionally, click TTF Conversion to adjust conversion settings. Whenever 

you choose a TrueType font in the Object Properties docker, calculated 
settings are used by default. As always, conversion settings can be further 
refined by the user.

5 Click OK to return to the Object Properties > Special > Lettering docker.
6 Select a baseline, adjust letter height and spacings, and click Create Text.
7 Click an insertion point to create text on-screen.
8 Optionally, edit generated letters with the Reshape Object and Knife tools.

Related topics
 Creating lettering with CorelDRAW Graphics
 Conversion settings
 Reshaping Objects

Converting TrueType fonts

Use Toolbox > Lettering to add TrueType lettering directly on-screen. Right-click to 
set the formatting values for new or selected lettering objects.

Select TT font

Set conversion values

Enter text

Use Setup > Convert TrueType Font to convert a TrueType font to an embroidery font.
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The Convert TrueType Font feature lets you convert any suitable TrueType 
font installed on your system into an embroidery font. Converted letters can be 
filled with parallel or turning stitches. Conversion usually only takes a few 
minutes, although Asian fonts may take longer.

To convert a TrueType font
1 Select Setup > Convert TrueType Font. The Convert TrueType Font 

dialog opens.

2 Select the font to be converted and font style. The entire embroidery font will 
be created in the selected style.

3 Enter a Font Name if you want to override the default.
4 Choose whether to convert All Characters or Extended ASCII character 

sets.
The standard character set contains alphanumeric characters only. It 
excludes punctuation marks and other special characters.

5 Optionally, click Conversion Settings to adjust conversion settings.
Whenever you choose a TrueType font in the Object Properties docker, 
calculated settings are used by default. As always, conversion settings can be 
further refined by the user.

6 Click OK.
7 To check, right-click the Lettering icon to open the Object Properties > 

Special > Lettering docker. The newly converted font will be selected by 
default and available for use.

8 Optionally, edit generated letters with the Reshape Object and Knife tools.

Related topics
 Conversion settings
 Reshaping Objects

Select font
Select font style

Set values

Enter font
name

Choose 
character set
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Conversion settings

Whenever you choose a TrueType font as opposed to native embroidery font, 
calculated settings are used by default. These are based on the font 
characteristics – e.g. whether serif or sans serif. As always, conversion settings 
can be further refined by the user.

Style
Select a lettering style, if available, from the Style list – Regular, Bold, Bold Italic 
or Italic. The entire embroidery font will be created in the selected style. This 
option may not be available for all fonts.

Turning stroke vs complex fill conversions
If you want the stitching to follow letter contours, select Turning Strokes. The 
Turning Strokes option has preset values adjusted for the particular font style. 
The Complex Fill option lets you adjust the stitch angle.

If you choose the Turning Strokes option, you have many more options 
available. If unsatisfied with the calculated settings, try adjusting the following:

Select lettering
style

Select Complex Fill
for fixed stitch angle

Select Turning
Strokes for variable

stitch angle

Arial BoldArial Regular Arial Italic

Complex Fill
stitch angle 0º

Turning Strokes Complex Fill
stitch angle 30º
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Match ends
Select the Match Ends checkbox to keep stitch angles parallel to the end of the 
stroke. This option will override any corner detection and corner fraction where 
parallel stitching applies.

Stitch angles in strokes should normally be perpendicular to the stroke, but the 
exceptions are letters like K, X, Y with short slanted strokes. In these cases it 
is better to keep the stitch angle parallel to the end of the stroke.

Break angle
Select the Break Angle checkbox to apply a cap to sharp angles. This effect is 
similar to Smart Corners – if the stroke bends sharply, like the letter A or V, it 
will be split or capped.

Create overlaps
Select the Create Overlaps checkbox to prevent gaps forming between 
segments. You can fine-tune the overlaps by setting values in the ‘T’ junctions 
and ‘O’ junctions fields.

Match Ends ON – stitches 
parallel to baselineMatch Ends OFF 

Break Angle 87º
Break Angle OFF – 
no split

Create Overlaps 
OFF

Create Overlaps 
ON
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Separate serifs
Select the Separate Serifs checkbox if you are converting a serif font.

As the serifs are made into separate strokes, this option is better used with 
larger lettering where serifs are greater than 0.8 mm in breadth.

Corner detection
Fine-tune processing of corners with these settings:
 Corner Detection Angle specifies the angle which will identify a corner in 

the letter. This is more important for getting well-defined small letters. Note, 
however, that EmbroideryStudio automatically inserts stitch angles where 
needed in order to obtain smooth turning stitches. These generally occur at 
locations where the shape changes significantly in direction or width.

 Corner Fraction specifies fractional spacing at corners. It is used to create 
smooth transitions of stitch angle at corners, shape ends, or where a shape 
changes in width or curvature significantly.

Converting between complex fill and turning strokes

When you convert TrueType fonts to embroidery lettering, the letters can be 
filled with parallel or turning stitches. You can convert between Complex Fill 
and Turning Strokes at any stage.

To convert between complex fill and turning strokes
1 Digitize a lettering object using Convert TrueType Font.

Separate Serifs 
ON

Separate Serifs 
OFF

Corner Detection Angle 150º
Corner Fraction 0.6 mm

Corner Detection Angle 30º
Corner Fraction 1.0 mm

Right-click Toolbox > Lettering to convert between Complex Fill and Turning 
Strokes.



EmbroideryStudio e4 User Manual 643

2 Select the lettering object.

3 Right-click the Lettering icon to access object properties.

4 Click TTF Conversion. The Conversion Settings dialog opens.

5 Specify whether to convert as Turning Strokes or Complex Fill.
6 Click OK to return to the Object Properties > Special > Lettering docker.
7 Press Enter or click Apply.

Related topics
 Conversion settings

Complex Fill with 
stitch angle of 0º

TrueType font 
appears in droplist

Set conversion
values

Filter TrueType 
font list

Select Complex Fill
for fixed stitch angle

Select Turning
Strokes for variable

stitch angle

Letters converted to 
turning strokes
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User-refined letters

Sometimes you find that you want to reshape a letter to improve its appearance, 
perhaps to suit a particular lettering height. EmbroideryStudio lets you save the 
letter as an alternative version. In fact you can save multiple versions of the 
same letter within the same font. Each version can have a unique height range. 
When using the letter in a design, the height setting will automatically determine 
which version is used. The feature thereby allows you to permanently record 
fixes to particular lettering problems and thereafter automatically apply them.

Note  The software preserves all user-refined letters when a new version is 
installed. Only factory default letters are overwritten.

Saving user-refined letters

User-refined letters are saved via the Create User-Refined Letter option. This 
is enabled only if a native letter or converted TrueType font letter is currently 
highlighted in the design window or selected in Reshape mode. One and only 
one letter may be saved at a time.

To save a user-refined letter
1 Create a lettering object with an embroidery font. 
2 Size the object and reshape the letter as required. The Stitch Angle and 

Reshape Object tools let you add, delete, or adjust stitch angles.
In the example below, the letter ‘a’ tends to close over at reduced sizes. You 
may want to open it up. By saving it as a user-refined letter, any changes 
made will be automatically applied to new lettering objects using the font in 
the specified size range.

Use Reshape Tools > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust start/end points.

Letter ‘a’ opened up at 
smaller size

Default ‘a’ too narrow at smaller size
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3 Still in Reshape mode, select the modified letter by clicking the diamond 
control point.

4 Select Object > Create User-Refined Letter.

5 Set a height range for the letter:

6 Give the new letter a unique name that you can easily identify – by default, 
the new version is given the name ‘User 1’.

7 Click OK.

8 To apply changes to all the same letters in the selected object, select the Use 
saved version checkbox in the Object Properties > Special > Lettering 
docker.

Range Description

All The letter will be used at all letter heights (effectively replacing the 
factory default).

Greater than The letter will only be at heights greater than that specified.

Less than The letter will only be at heights less than that specified.

Select modified letter

Name the new 
version

Specify the 
height range

Modified
letter ‘a’

Default letter ‘a’

Changes applied to 
both letters

Select to use 
user-refined letters
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Related topics
 Creating Embroidery Lettering
 Reshaping letters
 Adjusting stitch angles
 Embroidery fonts

Managing user-refined letters

User-refined letters are managed via the Manage User-Refined Letters 
option. This menu item is only enabled when a lettering object with a font 
containing user-refined letters is currently selected.

To manage user-refined letters
 While the letter is selected, select Setup > Manage User-Refined Letters.

The original factory default letter is identified by the name ‘Factory’. For 
converted TrueType font letters, the word ‘Convert’ appears instead of 
‘Factory’.

 Use left/right arrow buttons or droplist to select a user-refined letter.
 Click and rename any version except ‘Factory’ or ‘Convert’.
 Delete any selected version name except ‘Factory’.
 Untick the Use checkbox if you want to temporarily exclude a letter.
 Swap height ranges with the Move Up/Down buttons and adjust them by 

means of slider bars.

Creating custom fonts

EmbroideryStudio provides methods for defining custom embroidery fonts. You 
can digitize letters from backdrop images, convert vector objects, or digitize 
freehand using any of the input method tools. You can use artwork from sources 
such as calligraphy books. You can also copy characters and symbols from the 
MS Windows® Character Map into an external graphics program. Here you can 
modify them as you like, save them to a graphics file, and use it as a design 
backdrop. See also Using the Character Map.

Swap height ranges 
by moving selected 
version up or down

Adjust height range for the 
selected letter version 

Select letter version to
include in font

Scroll to next or 
previous letter

Click and
rename version

as required
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Note  You can also create new embroidery fonts by converting TrueType fonts. 
See also Converting TrueType fonts to embroidery.

Custom font considerations

You can use artwork to create letters in the same way you do other objects. 
Before digitizing, however, establish whether the letter shapes are suitable for 
embroidery, and determine reference height and baseline for the font. Letters 
are generally 20 to 40 mm in height.

Caution  Because of copyright laws, you cannot simply select letters from an 
existing embroidery font and save them to another font.

Letter shapes
For best results, letter columns should be of similar width, without tight curves 
or sharp corners, or very fine, very wide, or curved serifs.

Reference height and baseline
Reference height is the maximum height of capital letters. Although there may 
be subtle differences between upper and lower case letters, it is a useful guide 
for digitizing. Place letters along a standard baseline to help digitize at a 
standard height. Draw in the baseline if you are digitizing from artwork, or use 
a grid line as your guide. Descenders in letters such as y or g generally fall below 
the baseline.

Tip  Use E or H as reference letters to determine the height and baseline for the 
font. These letters work well because they sit on the baseline and do not extend 
above the standard cap-height.

Corners too sharp

Differences in column
width too great

Serifs too long and fine

Letter height

Baseline
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Letter spacing and width
Letter width varies with letter shape and spacing. When you digitize letters, you 
enter two reference points to mark the width, and a third to mark height.

Default spacing affects ‘kerning’ or spacing across all letters. Additional width 
can be added as spacing around individual letters.

Tip  For italic styles, you may need some overlap between letter extents.

Letter sequencing
Letter stitching sequence is based on the join type you select when saving the 
font. If you use the Closest Join or Bottom Join methods, EmbroideryStudio 
applies automatic branching to letters. In this case, you don’t need to worry 
about the direction individual letter strokes will stitch in. When branching is 
applied, EmbroideryStudio determines where each stroke starts and ends, 
adding travel runs as necessary. 
However, it is good practice to digitize strokes in the direction they are most 
likely to be stitched in. It is also important to specify the stroke order as this is 
maintained when sequencing is calculated.
If you want to specify the stitching sequence and connectors yourself, digitize 
the letter exactly as you want it stitched. You then need to select As Digitized 
as the join method.
The lettering stitch method should be preset to give the best results for each 
font. In most cases, Closest Join is recommended in order to minimize trims. 
Bear in mind though that the join method can be changed by the end user.

Related topics
 Changing lettering join method

Creating custom letters

You digitize letters for a custom font just like other embroidery objects. Custom 
letters can be made up of multiple objects, and may be letters, numbers, 
symbols or even pictures. 

To create a custom letter
1 Import and size the backdrop to use. Letters are generally 20 to 40 mm in 

height. 
2 Select an input method.
 If you are digitizing the sequence and connectors manually, use any input 

method.

Letter width

Letter width

Spacing 
increased
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 If you want the letter to be automatically resequenced with Closest Join 
or Bottom Join, use Column A, Column B, Column C and Complex Fill 
objects.

3 Select the stitch type. Most letters use Satin or Tatami.
4 Digitize each section of the letter.
 Create an ‘underlap’ to bind two strokes together. Underlaps should be 

about a third of the stroke width or less, but may be half for thin strokes.

 Try to avoid having more than two strokes on top of each other as this 
causes thread buildup and can lead to thread breaks. Sometimes 
modifying the shape can improve it.

 Sometimes it is helpful to angle the ends of underlaps so that a few 
stitches are ‘caught’ by the overlapping stroke.

 Where a stroke crosses another stroke, such as in the letter t, one stroke 
is commonly broken into two parts. For thin objects, you may digitize the 
above stroke in one piece, crossing over or under the other.

5 Adjust outlines using the Reshape Object tool if necessary. When the letter 
is the correct shape, save it as a custom letter.

Related topics
 Importing graphics
 Saving custom letters

Saving custom letters

When you create a new letter, you need to select a font for it, give it a name, 
specify its height, and indicate whether to preserve any machine functions. You 
also need to indicate its spacing settings by digitizing reference points 
on-screen.

Caution  Do not use the tilde (~) symbol when naming letters. This is a special 
character for entering letters with multiple-character names.

Underlaps

Overlap / underlap
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To save custom letters
1 Digitize the objects that make up the new letter, and select them.

2 Select Object > Create Letter.

3 Select a font from the droplist.
4 Enter a name for the letter in the Letter field.

For example, if you digitized the letter H, enter ‘H’ in the Letter field.

Tip  You can create names with multiple characters to identify special letters 
– e.g. ‘Star’ for a star symbol, or ‘e-acute’ for é.

5 In the Reference Height field, enter a height for the letter.
The letter is recorded at this height regardless of its original size. You can also 
set height on-screen by selecting the Digitize Reference Height checkbox. 
When you return to the design window, you are prompted to digitize the 
height. If you select Digitize Reference Height, the value in the Reference 
Height field is ignored. Letters are generally 20 to 40 mm in height.

6 Deselect Remove Functions only if you want to keep any machine functions 
in the object.
The letter may, for example, include deliberate color changes or other 
machine functions. Such letters require the As Digitized join type.

7 Click OK.
8 Click to mark two reference points for letter width and baseline.

The distance between reference points determines the letter width, including 
any spacing either side of the letter. This then determines ‘standard spacing’ 
between letters. 

Select whole 
character

Enter reference height

Enter letter name

Select font

Select to set height on-screen

Deselect to include functions

1 2

1 2 1 2
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Note  The reference points you digitize also determine where the letter sits 
on the baseline.

9 If you selected Digitize Reference Height in the Create Letter dialog, you 
are prompted to digitize a third reference point to mark letter height. 
A message confirms that the letter has been saved to current font.

Related topics
 Selecting custom fonts
 Creating custom letters
 Saving custom fonts
 Selecting custom fonts
 Changing lettering join method
 Letter spacing and width
 Reference height and baseline

Saving custom fonts

Use custom fonts to store any letters you create. To make a new font, you name 
it and set the default spacing and join type for adjacent letters. You also specify 
the file type.

To save custom fonts
1 Digitize the objects that make up the new letter, and select them.

2 Select Object > Create Letter.

3 Click Create. The Create Alphabet dialog opens.

Select whole letter

Click to create 
new font

Enter font name

Enter default spacing

Select join method
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4 Enter a name for your new font.
5 Enter spacing in the Default Letter Spacing field. As a rule of thumb:
 Use 8-10% for standard fonts such as block and serif styles.
 Use 0% for script-style fonts.

6 Select a method of joining adjacent letters in the Default Join Type list. 

Note  The lettering stitch method should be preset to give the best results. 
In most cases, Closest Join is recommended in order to minimize trims. 
Bear in mind though that the join method can be changed by the end user. 

7 Click OK.
8 Enter additional values for the selected letter in the Create Letter dialog.

Related topics
 Creating custom letters
 Changing lettering join method
 Saving custom letters

Selecting custom fonts

To use a custom font, select it like any other font. If a letter has a multi-character 
name, you can only access it from the Lettering dialog using the special tilde 
(~) symbol.

Join Method Description

As digitized Preserves the original stitching sequence of each letter as it was 
digitized, as well as any stitch types and machine functions used in 
its creation.

Closest join Resequences entry and exit points in adjacent letters to join them 
at the closest point.

Bottom join Resequences entry and exit points in adjacent letters to create a 
connector along the lettering baseline.

Right-click Toolbox > Lettering to select a custom font.
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To select custom fonts
1 Right-click the Lettering icon to access object properties.

2 Select a custom font from the droplist.
3 Enter the names of the letters you want to use in the text box.
 If the letter name is a single character – e.g. ‘A’ – enter that character.
 If the letter name consists of more than one character – e.g. ‘Star’ – enter 

a tilde (~) followed by the letter name.

Tip  Combine letters that use single or multiple characters in their name by 
prefacing the single character with two tildes – e.g. ~Star~~A~Star. 

4 Set the formatting values as you would for other lettering objects. 

Related topics
 Saving custom letters
 Formatting lettering
 Adding embroidery lettering on-screen

Modifying custom fonts

You can modify custom fonts by changing names, default letter spacings and join 
types. If a font is no longer required you can delete it. You can also rename, 
delete or reshape letters within custom fonts.

Managing fonts

Modify custom fonts by changing names, default letter spacings and join types. 
If a font is no longer required, delete it. To modify fonts, select Setup > 
Manage Alphabets. 

Use this dialog to:

My FontSelect custom
font

Select font Click to rename 
font

My Font

Select letter
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 Rename a custom font.

 Delete a font.
 Change default letter spacing. 
 Change the default join type.
 Delete or rename selected letters. You can use names with more than one 

character.

Related topics
 Adjusting spacing settings
 Setting stitching sequence & join method

Reshaping custom letters

To change the shape of letters in custom fonts, ungroup them and change their 
outlines and stitch angles using the Reshape Object tool. When you ungroup, 
the letter reverts to normal embroidery objects, and letter properties such as 
font type and baseline are lost. When you have finished reshaping, you have to 
enter these details again.

To reshape custom letters
1 Select a letter and ungroup.

Enter new nameNew Font Name

Enter new nameMy New Letter

Use Arrange > Ungroup to ungroup a letter into its component objects.

Use Reshape Tools > Reshape Object to reshape custom letters.

Use Object > Create Letter to create a new letter.
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2 Click the Reshape Object icon and reshape the objects as required.

3 When you have finished reshaping, select the objects.
4 Select Object > Create Letter.

5 Select the font to which the letter belongs from the Font Name list. 
6 Select the letter name from the Name list or enter a new name.
7 Click OK.

Merging fonts 

You can merge letters from two or more fonts with the stand-alone font merging 
utility. Files to be merged must be placed in the EmbroideryStudio userletw 
folder of your installation.

To merge fonts
1 Select Start > Programs > MS-DOS Prompt.
2 When the command prompt appears, change to the BIN directory of your 

EmbroideryStudio installation. This is usually:
C:\Program Files (x86)\Wilcom\EmbroideryStudio_e4.0\BIN

3 Choose whether to automatically overwrite or receive prompt.
 To automatically overwrite the letters in the first file with letters of the 

same name from the other file(s), type: 
alphcat.exe file1.ESA file2.ESA file3.ESA.

 To receive a prompt message before a letter is overwritten, type:
alphcat.exe file1.ESA file2.ESA file3.ESA /Y. 
Press Y or N to confirm whether to overwrite.

4 Click Yes to merge.

Reshape objects

Select font

Select letter name
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Chapter 33

Lettering Kiosk

EmbroideryStudio provides an easy-to-use Kiosk capability for cap and other 
embroidery. The lettering kiosk is primarily intended for use at retail outlets 
where fast and simple personalization of standard design layouts is required in 
consultation with customers. The benefits to retail staff are:
 Minimal training time
 Minimal production errors
 Improved customer satisfaction
 Increased productivity
 Easy configuration for changing requirements
 Support for several brands of machine
 Simplicity of kiosk mode together with full embroidery lettering capabilities 

for supervisors.
The lettering kiosk provides a set of pre-defined design layouts and the ability 
to easily personalize them by modifying text and color. You can create your own 
layouts as well. Designs can be sent to machine from the kiosk via a single 
button press.

Operations summary

Here are some steps to get you up-and-running quickly with the lettering kiosk.

Configure the kiosk settings
1 Run the EmbroideryStudio software:
 You need the Kiosk Element enabled.
 There is no special setting required for kiosk mode.
 Check the About Box for the correct version: e3.0M of 12 Dec 2013 or 

later.
2 Configure the kiosk design layouts:
 Located under C:\Program 

Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
 Set palette colors in the design layouts to match the thread colors and 

needle assignments used on your machines. See Setting up thread colors 
for details.

 Check the fonts and stitch settings being used.
3 Configure the machine connections for this kiosk:
 Select Setup > Connection Manager Setup.

4 Configure the kiosk password:
 Select Setup > Options > Kiosk.
 Enable ‘Lock Kiosk’.
 Set a password.
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5 Configure character count parameters. See Configuring kiosk character count 
limits for details.

Switch to and from kiosk mode
1 To switch to kiosk mode, select menu command Window > Kiosk…
2 Type the kiosk password to enter into kiosk mode.
3 To close the application while in kiosk mode, click on the red X button in upper 

right corner.
When you restart EmbroideryStudio, it will automatically re-start in kiosk 
mode directly.

4 To return to the EmbroideryStudio screen, click Exit Kiosk and key in the 
password if prompted.

Operate the software in kiosk mode
1 Click on a design layout at the left side of screen to start with.
2 Type the text names you want to use:
 Lettering is automatically updated
 Lettering will auto-reduce in size to fit the allowed space
 By default, a maximum of 16 characters is allowed. See Configuring kiosk 

character count limits for details.
3 Change the font if you wish by clicking a design layout.
4 Click a color to set thread color.
5 When finished, click a machine button to send the design to the machine:
 Design stitching auto starts and ends at the bottom center of the allowable 

embroidery area.
 Design is auto-rotated 180° for the machine, subject to connection 

settings. See Setting up machine connections for details.
 A machine file is created and sent to the machine connection folder also 

set in the Connection Settings dialog.
 The name of the machine file is the same as the text to be embroidered.

6 Click Start Again for the next name.

Operating modes

The Lettering Kiosk has all the capabilities and functionality of a commercial 
kiosk system together with EmbroideryStudio embroidery functionality.

Screen modes

In Wilcom Decoration mode, supervisors can use the full range of software 
capabilities to fine-tune settings. All adjustments can be saved to a template 
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ready for use when the software is run in kiosk mode. Onscreen help is available 
via the Help menu.

Kiosk screen mode
A password configuration setting allows supervisors to bypass the 
EmbroideryStudio screen and run the software in kiosk mode by default. 
Operators normally work in this screen and never need to leave it. In fact, they 
cannot exit without, optionally, a supervisor password.

Kiosk mode includes a 56-color default palette together with a number of 
packaged designs. However, in practice you will want to limit the palette to the 
colors available on your machines. The screen is divided into three functional 
areas apart from the banner at the top.

Design chooser
panel

EmbroideryStudio
Kiosk title banner

Design work
area

Customization
panel
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Choose design panel
The Choose Design panel is positioned on the left side. It contains a set of 
pre-defined design layouts to choose from. It is easily extensible with other 
supervisor-created designs.

Working design area
A working design area in the middle is optimized for 1366 x 768 resolution. It 
includes a dotted line indicating the maximum stitching boundary.

Customization panel
The customization panel on the right allows the operator to easily customize 
designs by changing color and text of the selected layout. The supervisor can 
pre-configure the number and values of standard colors to match the thread 
color setup on the machines. Custom designs can be sent to one of several 
attached embroidery machines.

Send to machine
Machines are pre-configured by the supervisor – typically up to 6. Color-coded 
buttons easily identify machine by number and machine name. The supervisor 
can set color-coded icons for each machine brand. For example:
 Brother - Cyan
 Barudan - Navy Blue
 SWF - Red

Normal Kiosk operation

Once in kiosk mode, typical operation will flow as follows.

Selected design shown
within allowable stitching

boundary
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To operate the kiosk
 Choose a design layout from pre-prepared templates in the left panel.

 Enter a new name in the text field and press Enter.

This text automatically replaces default text. By default, a maximum of 16 
characters is allowed.

 Click in design window and zoom in / out by the following means:
 Press 1 for actual size.
 Press 0 to show all.
 Use the mouse scroll wheel to zoom.
 Click Start Again to return to default view.

 Choose a thread color from the list of available colors.

Choose a design
layout

Default 9-color
design palette

Enter new
name

Send design to
a machine

Input text
replaces default

text
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You can switch layouts and colors as desired and text will be preserved.

 When you are satisfied with the design, press a Send to Machine button. A 
separate button is present for each machine configured on the system.

 Press Start Again to create another design. The current design is 
automatically saved to the watching folder with a filename equal to text 
name. 

Note  If the operator does not press Start Again but instead selects a new 
design layout, the new design overrides the current one, preserving any 
typed text.

 To exit kiosk mode altogether, press the lock icon. Normally you are prompted 
for a supervisor password. 

Related topics
 Setting up machine connections
 Configuration options for supervisors

Troubleshooting long descenders

Some characters may extend slightly beyond the allowable stitching area. This 
usually happens with script fonts or characters with long descenders or 
ascenders such as the ‘k’ in this example. This problem is easily fixed by adding 
a space after the final character.

Creating two-line lettering

Kiosk mode allows two-lines of text to be entered and edited. The text box in the 
control panel supports single- or multi-lines depending on the selected layout. 

Template
switched

Add space after 
final character

Long descender 
extends beyond 
stitching area
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Two-line layouts need to be pre-defined and saved to the designs folder. When 
using a multi-line layout, the first Enter keypress will create another line. The 
next will confirm text entry as for a single-line layout.

Note  If you switch design layouts, the system will attempt to preserve 
user-entered text between single- and multi- line designs. For example, 
switching from single to double, the original line of text will be copied to the first 
line. The second will be empty.

Personalizing monograms

The lettering kiosk also supports customization of monogram objects. Only text 
can be changed in Kiosk mode. Monogram templates can be created and added 
to the kiosk.

Configuration options for supervisors

When first running EmbroideryStudio e4, supervisors have access to 
EmbroideryStudio operations. In this mode, they can use the full range of 
software capabilities to fine-tune settings. Primarily, supervisors are concerned 
with:
 Creating a password for the kiosk
 Setting up machine connections

Edit two-line 
design layout

Personalize 
mogogram text
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 Setting up thread colors
 Configure kiosk character count limits

Creating kiosk passwords

Supervisors can lock the kiosk to protect against unauthorized use. They can 
later temporarily unlock the kiosk in order to edit designs or change other 
settings.

To create a password for the kiosk
1 Click the Options icon or select Setup > Options. Click the Kiosk tab.

2 Enter a secure password and click OK.
3 Select Window > Kiosk start the kiosk. You will be prompted to enter the 

password.

Note  You can return to Options dialog at any time to change or remove 
password protection. If you forget the password, you will need to run the 
Revert program from the EmbroideryStudio program group to restore factory 
defaults.

Use Standard > Options to access application options for kiosk and other settings.

Tick to lock kiosk
and activate

password
Enter password 
for kiosk access

Enter password
for kiosk access

Run Revert to 
restore defaults
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Setting up machine connections

Connection Manager allows you to connect to most later model machines. 
These machines often require files to be placed in a specific network location or 
‘watching folder’. Once set up in EmbroideryStudio, a single click from the kiosk 
is sufficient to send the design to machine. Each configured machine:
 has a unique name and assigned button
 has a unique folder to which designs can be sent so they can be accessed 

from the machine control panel or third-party connection software.

To set up machine connections
1 Select Setup > Connection Manager Setup.

2 Click Create to set up a connection. The Connection Settings dialog opens.

3 Make sure the connection type is set to ‘Machine Folder’. Watching folders 
should already have been set up for each machine on the network.

4 Enter a unique machine name – e.g. ‘Brother PR600 Mach 1’.
5 Choose a colored icon from the droplist to identify the machine in kiosk mode.
6 Select the file type required by the machine. Each machine type uses a 

different file format:

7 If the file type requires it – e.g. PES – click the Options button to preset file 
options such as version type.

8 Enter or browse to a folder location on the network or PC which has been set 
up for the specific machine. When you output a design, Connection 
Manager saves it to this folder in the specified file format.

Machine Format

Brother PES

SWF DST

Barudan U??

Click to create a 
new connection

Enter unique 
machine name

Select connection
type

Select file type 
required by machine

Set ‘watching
folder’

Choose a color to 
identify the machine

Tick if the machine is 
to be used for cap 
production



EmbroideryStudio e4 User Manual 665

9 If the machine is intended for cap designs, tick the Rotate design by 180° 
option.

10 Click OK when complete.
11 Repeat as many times as you have machines to connect. Connections can be 

edited or removed at any time.

New machine connections appear as prominent buttons in the customization 
panel of the kiosk.

Setting up thread colors

Thread colors are set up for each design layout. All three sample designs need 
to be edited according to the requirements of your machine setups.

To set up thread colors
1 Click the Open icon.

The Open dialog opens.

Delete or edit 
connections as required

Color-coded
machine buttons

Use Standard > Open to open an existing design.

Use Standard > Save Design to save the current design. Right-click to open the 
Save As dialog.

Navigate to Design
folder
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2 Navigate to the Designs folder of your EmbroideryStudio e4 installation:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, specify your own folder.

3 Select a design to edit and click Open.
4 Use the Color Palette tools to add or remove colors according to the thread 

setup on your machine/s.

5 Open the My Threads docker and select your thread chart.

6 Assign threads to the palette with the Assign button. Alternatively, select 
threads corresponding to the thread setup on your machine, and assign 

Add or remove colors

Open Editor

Access thread
charts

Choose a thread
chart

Assign threads from
chart to color palette
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these. The design layout defaults to the first color in the palette. The tooltip 
tells you the corresponding thread of each color.

7 Click Save to save the file in the design folder. The modified palette for this 
design will appear in the kiosk when you next run it.

Related topics
 Changing design location

Configuring kiosk character count limits

Different scenarios may lead to variations in the number of characters allowed. 
The commercial requirement is for 16 characters per line, but the software 
allows you to change that limit. For example, maximum characters when buying 
online may be limited to 10, while baby-size caps may be less than 16. 
Optionally, the supervisor can limit the number of characters allowed in kiosk 
mode.

Note  Spaces between words count as characters. However, extra spaces are 
allowed at the start and end of a line without compromising the character count.

Default color

Use Standard > Options to access application options for kiosk and other settings.
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To configure the kiosk character count limit
 Click the Options icon or select Setup > Options. Click the Kiosk tab.

 Tick the Restrict number of characters option and set the maximum 
number of characters – e.g. 16.
When the number of characters is limited by this option, the kiosk shows the 
number used vs the number available – e.g. ‘5 / 16’. Where a two-line design 
is selected, the limit is shown for each line.

Related topics
 Troubleshooting long descenders

Changing design location

The default kiosk design folder is located within the EmbroideryStudio e4 folder 
structure. This may not be convenient for you if you are dealing with numbers 
of custom designs. You can easily change the folder location to any on your kiosk 
hard drive or network. If you have more than one kiosk set up, they can all 
reference the same design folder.

Tick to restrict text
length

Set character 
limit

Kiosk shows number 
used vs number 
available per line

Use Standard > Options to access application options for kiosk and other settings.
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To change the design location
 Click the Options icon or select Setup > Options. Click the Kiosk tab.

 Tick the Custom kiosk design folder option and browse for the folder on 
your local drive or network. This then becomes the default kiosk design folder. 
Any EMB designs kept in this location will appear in the kiosk design chooser.

Customizing kiosk banners

Like the kiosk Design folder, the default kiosk banner is located within the 
EmbroideryStudio folder structure. If you want to modify the banner in any way 
– e.g. with a specific location name – it is a simple matter to access the banner 
and update it. Alternatively, you can copy the modified banner to a separate 
location on your kiosk hard disk or network location and reference it there. If 
you have more than one kiosk set up, they can all reference the same banner.

To customize the kiosk banner
1 Navigate to the ‘Kiosk’ folder of your EmbroideryStudio e4 installation:

C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\
Here you will find the default kiosk banner – dimensions 1200 x 100 pixels.

2 Customize the banner as required:
 Either replace the current image with one of the same dimensions.
 Edit the current banner in any graphics or paint program and save to the 

same location.
 Copy the banner to the same or another location and edit as desired.
If you move the banner to another location, you need to update the software 
settings as follows:

C:\My Kiosk DesignsTick to activate
custom Design

folder

Browse for folder 
location

Use Standard > Options to access application options for kiosk and other settings.



Chapter 33   Lettering Kiosk 670

3 Click the Options icon or select Setup > Options. Click the Kiosk tab.

4 Tick the Custom kiosk banner option and browse to the folder on your local 
drive or network.

5 Select the custom banner file and click Open. This then becomes the default 
banner which the kiosk will reference.

Creating custom design layouts

Various techniques are available to add your own design layouts to 
EmbroideryStudio.

Creating new layouts from old

To create custom design layouts is not very different to setting up thread colors. 
The simplest approach is to base a new design on an existing one in order to 
preserve stitch settings and design scale. You can change colors, fonts and stitch 
settings as required.

To create a new layout from an old one
1 Click the Open icon.

Tick to activate
custom banner Browse for folder 

location

Navigate to
folder location

Select custom 
banner

Use Standard > Open to open an existing design.

Use Standard > Save Design to save the current design. Right-click to open the 
Save As dialog.
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The Open dialog opens.

2 Navigate to the Designs folder of your EmbroideryStudio e4 installation:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, specify your own folder. 

3 Select a design to edit and click Open.
4 Before you do anything else, select File > Save As and save the design under 

a different name.
5 Double-click the design to open its properties.

6 Edit the default text and select an alternative font from the droplist as 
desired.

Navigate to Design
folder

Choose font from
droplist

Edit default text
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7 Click the Update Text button to view the result on screen.

8 Change default thread color as desired. The design will appear in the kiosk 
design chooser when you next run it.

Related topics
 Changing design location

Creating layouts based on templates

Alternatively, you have access to complete EmbroideryStudio capabilities to 
create designs from scratch. Onscreen help is provided via the Help menu.

To create a layout based on a template
 If you are creating a design from scratch, use the File > New from 

Template command.

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Use View > Auto Start & End to toggle function on/off according to the current 
settings. Right-click to open the Auto Start & End dialog.

Select template
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 Select a kiosk template if you have set one up. For example, you may set up 
your template to include a stitching boundary defining the area to work 
within, say, for cap designs. This can be drawn in CorelDRAW Graphics. You 
might also want to include a product image.

 Select the Lettering tool and create the text you require. Adjust settings 
such as font, dimensions, etc.

Note  To ensure that text remains within the allowable boundary, it is safest 
to use the Fixed Line baseline.

Kiosk stitching 
boundary

Use ‘Fixed Line’
baseline
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 Change thread color as desired. 

 Set the selected lettering object to position to zero (0,0) as shown. This will 
ensure that the lettering layout automatically centers itself in the allowable 
stitching area.

 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, set your own designs folder. 

 The design will appear in the kiosk design chooser when you next run it.

Related topics
 Setting up thread colors
 Changing design location

Creating layouts with included design motifs

For special occasions, you may want to create a kiosk layout which includes a 
special motif – for instance, St Patrick’s Day, with a Shamrock at the start of the 
lettering. These motifs need to be about the size of a capital letter. Together with 
the lettering, they need to fit within the allowable stitching boundary.

To create a layout with an included design motif
1 Create a layout from scratch or based on an existing layout. See above.
2 Import a suitable design motif using the Import Embroidery command. See 

main help system for details.

Set X/Y position of selected
lettering to zero

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Click Standard > Import Embroidery to import embroidery design file into current 
design.
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3 Place the motif and key in the default lettering.

4 Double-click the lettering and set left justification in Object Properties.
Alternatively, if you place the motif on the right, set justification to right.

5 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, set your own designs folder. 

6 The design will appear in the kiosk design chooser when you next run it.
The whole design, including motif and lettering, is auto-centered immediately 
after text is updated in kiosk mode.

Related topics
 Changing design location

Including design backdrops

It’s a simple matter to include a design backdrop to your design layout – e.g. a 
cap.

Select left
justification

Use Color Palette > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle current product display. Right-click for Product 
Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design window.
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To include a design backdrop
 Click the Product Visualizer icon. The docker appears.

 Select a product image – e.g. cap – and set color as desired.
 Set the selected lettering object to position to zero (0,0) as shown.

 As the lettering object and stitching boundary may not be in the correct 
position for the backdrops, click the Auto Start & End icon and digitize a 
start and end point as shown.

Note  The stitching boundary is locked in the template. It has to be unlocked 
to be moved.

 When you are happy with the result, click Save.

Select a 
product folder

Select 
product

Digitize start and end
point at base of design

Set X/Y position of
selected lettering to zero
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The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, set your own designs folder.

 The design will appear in the kiosk design chooser when you next run it.

Related topics
 Changing design location
 Visualizing products

New design listed
in kiosk chooser
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PART VIII

ELECTRONIC ARTWORK

There are two broad categories of artwork file, both of which can be imported 
into EmbroideryStudio for use as digitizing backdrops – vector and bitmap. To 
create good quality embroidery, you need to choose or create suitable artwork 
of either format.

Digitizing with bitmaps
This section describes how to prepare images for automatic digitizing. It explains 
how to insert bitmap images as well as how to edit them, including cropping, 
editing in third-party applications, and smoothing. It also explains how to 
prepare both outlined and non-outlined images. See Digitizing with Bitmaps for 
details.

Digitizing with vectors
This section describes how to create drawing objects using the drawing tools as 
well as how to import them from third-party applications. It also explains how 
to merge, trim and split overlapping drawing or embroidery objects using the 
shaping tools. See Digitizing with Vectors for details.

Automatic digitizing
This section describes how to automatically convert bitmap images to 
embroidery objects and complete designs, as well as how to create embroidery 
from grayscale images. See Automatic Digitizing for details.
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Chapter 34

Digitizing with Bitmaps

EmbroideryStudio supports the automatic and semi-automatic digitizing of both 
bitmap images and vector graphics. The quality of the resulting designs greatly 
depends on the type and quality of the original artwork. Generally speaking, 
vector graphics preserve the picture quality when resized, whereas bitmap 
images cause problems of pixelation and image degradation when enlarged or 
scaled down. You can insert or paste third-party vector graphics such as clipart 
for use in embroidery designs. Alternatively, insert, paste or scan bitmap 
artwork for use as digitizing templates or ‘backdrops’. In order to make bitmap 
images more suitable for automatic digitizing, EmbroideryStudio provides image 
processing capabilities.

Note  CorelDRAW Graphics includes the latest CorelDRAW® Graphics Suite 
drawing tools. These offer many sophisticated techniques for drafting outlines 
and shapes on screen. Vector graphics so created can be directly converted to 
embroidery objects or even entire designs. For a full description of the 
CorelDRAW® tools, refer to the electronic User Guide available via the 
MS Windows® Start > Programs group. Alternatively, use the onscreen help 
available from the Help menu.

Choosing suitable artwork

For both manual and automatic embroidery digitizing purposes, ‘clean’ images, 
sometimes referred to as ‘cartoons’, work best. Such images have a limited 
number of solid colors which in turn have well-defined outlines. Ideally, they are:
 Well defined, where each shape is made up of pixels of the same color.
 Clearly ‘blocked’, where each shape is a stitchable size, at least 1 sq mm.
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 Saved at a color depth of at least 256 colors (8 bit), or preferably millions of 
colors (16 bit).

Best results are produced with images of the type found in clipart libraries or 
created from scratch in CorelDRAW®. EmbroideryStudio can work with images 
from other sources but they require some preparation. This is because most 
commonly available images are not made up of solid colors. Scanners introduce 
noise, while graphics packages perform ‘dithering’ and ‘anti-aliasing’ to improve 
image print quality.

Photographic images
Embroidery digitizing works least effectively with photographic images which 
may contain many dithered colors and complex forms. With photographs, 
however, you can pick out shapes that you want to embroider, leaving out 
unnecessary detail. For best results, use sharp images with well-defined 
subjects and contrasting shades.
You can also use Photo Flash to create embroidery from photographs or other 
images, color or grayscale. Photo Flash designs consist of rows of stitches of 
varying spacing settings. The effect resembles the output of a line printer. See 
also Auto-digitizing with Photo Flash.
An extension of Photo Flash, you can also use Color PhotoStitch to create 
embroidery from photos. While Photo Flash designs consist of rows of 
single-color satin stitching, Color PhotoStitch produces variegated stitching 
using multiple thread colors. The overall effect is like multi-colored stippling. See 
also Auto-digitizing with Color PhotoStitch.

Scanned images
Images scanned from hardcopy drawings or existing 
embroidery typically contain a lot of introduced ‘noise’. 
While they can be used as input to embroidery 
digitizing, once again, best results are achieved with 
relatively clean images consisting of solid color blocks. 
Typically, logos and simple drawings scanned from 
business cards, letterheads, books, magazines, cards 
all fall into this category.
Noisy images typically need to be prepared by reducing 
the color count and sharpening the outlines. See also 
Preparing artwork for scanning.

Clean image with 
well-defined outlines

Clean image with 
well-defined color blocks

Complex image, needs editing to 
remove background and 

improve outlines

Image containing a lot of 
scanner ‘noise’
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Dithered images
Dithering is a software technique which combines existing colors in a 
checkerboard arrangement of pixels. It is typically used to simulate colors that 
are missing from an image palette.

Like noisy images, dithered images need to be color-reduced before use. Be 
aware, however, that while EmbroideryStudio can process dithered colors within 
a defined outline, it does not work so well with non-outlined images.

Anti-aliased images
Anti-aliasing is a software technique similar to 
dithering which is used to soften hard outlines where 
color blocks intersect. It produces smoother outlines 
by ‘blurring’ the pixels where colors join.
Where anti-aliasing is deliberately used to blur 
outlines, these need to be ‘sharpened’ before use 
with automatic digitizing.

Color depth
When loaded into EmbroideryStudio, images are automatically reduced to 256 
colors or less. The main reason is to provide acceptable performance for 
automatic digitizing. 
256 colors sounds a lot for embroidery needs and, in practice, a 256 color image 
may look quite similar to a 24-bit RGB image. The appearance and quality 
differences can only be observed by zooming in. The 256-image will be dithered 
to improve its appearance at a distance. However, this feature is also responsible 
for single color pixels and small areas, which effectively create image noise. This 
in turn can affect the quality of automatically generated embroidery.

Guidelines
Bear in mind the following key points when selecting artwork for auto-digitizing:
 Use 300 DPI high-resolution images, NOT low-res 96 DPI.
 Do not use anti-aliasing.
 Do use PNG format, not JPG.
 Do use transparent backgrounds.
 If the image does not conform to these settings, go back to the original vector 

artwork and generate a bitmap that includes them.

Image preparation techniques

Before converting artwork to vector graphics, you frequently need to clean it up. 
To work effectively, the Convert function requires solid color images as input. 
You can improve artwork with the bitmap editing tools.

Dithered color blocks
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Note  For a full description of the editing tools in CorelDRAW Graphics, refer 
to the electronic User Guide available via the MS Windows® Start > Programs 
group. Alternatively, use the onscreen help available from the Help menu.

Outlined vs non-outlined images
Before preparing your image you need to know what type you are using. For the 
purposes of automatic digitizing, there are two categories – outlined and 
non-outlined. Outlined images ideally have a solid black outline around each 
colored area. Non-outlined images ideally consist of solid areas of color. Outlined 
and non-outlined images require different methods of preparation.

Image cleanup
In practice, cleaning up scanned images may involve any one or a combination 
of the following techniques:
 Reducing the number of colors
 Adding or emphasizing outlines
 Removing noise, dithering or anti-aliasing
 Eliminating unnecessary detail
 Cropping sections
 Eliminating backgrounds.

Color reduction
Sometimes an image looks clean but extra colors have been introduced during 
scanning or processing. Color reduction means reducing the actual number of 
image colors in order to eliminate unnecessary detail and reduce each block to 
a single color. Color reduction also cleans the image, removing any noise and 
anti-aliasing present. This in turn helps minimize the number of trims and color 
changes required in the resulting embroidery design. Color reduction should only 
be applied if the loss of detail does not affect the image shapes. Before 
reduction, the colored areas in the image below include many colors. After 
reduction, each area is reduced to a single color. The detail is preserved.

Image with outlines Image without outlines

Before color reduction After color reduction
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If you are scanning images, make sure you scan them correctly for best results. 
See also Preparing artwork for scanning.

Be aware that some techniques are better for removing noise and anti-aliasing 
but not so good for processing dithering in non-outlined images. See also 
Choosing suitable artwork.

Outline sharpening
Outline sharpening means emphasizing outlines bordering distinct color blocks. 
These may have been indistinct in the original or made so by the scanning 
process. Outline sharpening is important for vectorizing because it makes it 
easier for EmbroideryStudio to identify areas for conversion to embroidery.

Some images have solid outlines but they may be indistinct or incomplete. These 
need to be rectified with the CorelDRAW Graphics bitmap editing tools prior 
to vector tracing. Refer to the electronic User Guide available via the 
MS Windows® Start > Programs group. Alternatively, use the onscreen help 
available from the Help menu.

Noise filtering
Noise filtering means restoring the solid color blocks of the original artwork in 
scanned images. This is achieved by merging different shades into one solid 
color. Noise filtering is important for vectorization because it makes it easier for 

Image scanned in 
RGB color mode, then 
colors reduced to 6

Image scanned in 256
color mode, then

colors reduced to 6

Outlined image – dithered 
color blocks cleaned, edges 
sharp

Non-outlined image – dithered 
color blocks not completely 
cleaned, edges fuzzy

Before outline 
sharpening 

After outline 
sharpening
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EmbroideryStudio to identify solid color blocks to become embroidery objects in 
the resulting design. It also cleans up blurred or mottled areas of color.

Image preparation summary

Preparing artwork for scanning

If you have existing artwork, you can scan it in CorelDRAW Graphics with a 
TWAIN-compatible scanner using the scanning function. It is important to scan 
your artwork properly if you intend to use one of the automatic digitizing 

Image before noise 
filtering, mottled color

Image after noise
filtering, single colors

Action Outlined image Non-outlined image Photograph

Scan artwork • Scan in RGB mode
• Use sharpening

• Scan in RGB mode
• No sharpening

Scan in RGB mode

Scan line drawing Scan in two color mode - -

Touch up graphics • Crop
• Add or edit outlines
• Edit colors
• Remove noise

• Crop
• Edit image shapes
• Edit colors
• Remove noise

• Crop
• Convert to grayscale
• Remove background
• Lighten or darken
• Adjust contrast

Adjust bitmap • Adjust lightness or 
darkness of outlines 
manually.

• Adjust lightness or 
darkness of outlines 
manually.

• Adjust lightness or 
darkness of outlines 
manually.

Prepare bitmaps Adjust lightness or 
darkness of outlines. 
Automatically:
• blend each outlined 

block into a single color
• remove anti-aliasing, 

noise and dithering
• sharpen outlines.

Reduce colors to a 
specified number. 
Automatically:
• reduce each block to a 

single color
• remove anti-aliasing, 

noise and dithering
• remove colors less than 

specified area.

-

Vectorize bitmaps CorelDRAW Graphics provides the latest CorelDRAW® drawing tools. These offer 
many sophisticated techniques for drafting outlines and shapes on screen. Refer to 
the electronic User Guide available via the Windows Start > Programs group. 
Alternatively, use the onscreen help available from the Help menu.

Convert vectors directly EmbroideryStudio provides techniques for both converting vectors directly to 
embroidery as well as manual digitizing of prepared artwork. See Digitizing Shapes 
for details.

Digitize automatically • Manual
• Auto-Digitizing
• Instant Smart Design 
• Smart Design

• Manual
• Auto-Digitizing
• Instant Smart Design
• Smart Design

• Photo Flash
• Color PhotoStitch
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techniques – the scanned image quality will affect the quality of the final 
embroidered design.
With embroidery design, less is more. You don’t need every detail in an image 
to create a design. You use the ‘structure’ of the image rather than the fine 
details of texture and color. To simplify artwork, you can cover it with tracing 
paper and draw only the essential shapes and lines which will be filled with 
stitches. When scanning, take away the original artwork and put white paper 
behind the tracing paper. Shiny surfaces, such as glossy photographs, may not 
scan well. Cover them with tracing paper. If the artwork has very light colors, 
highlight outlines with a fine black felt-tip pen.

Note  For a full description of how to scan images into CorelDRAW® 
Graphics Suite, refer to the electronic User Guide available via the 
MS Windows® Start > Programs group. Alternatively, use the onscreen help 
available from the Help menu.

Scanning resolution
Most scanners require you to enter scanning resolution information. Resolution 
determines the number of dots per inch (DPI) used to create an image. 
Generally speaking, the smaller the source image and/or more detail it contains, 
the higher the resolution needs to be. Use the following table as a guide.

Color mode
Most scanners also require you to enter color mode information. First decide 
whether your image is line art (black and white drawing), sketch, color picture, 
or black and white or color photograph, then choose an appropriate mode. Black 
and white mode produces the smallest files. Color photograph and grayscale 
modes generate 256 color images and produce similar sized files. ‘RGB’, ‘True 
Color’ or ‘millions of colors’ modes generate 16.7 million colors and produce the 
biggest files. Use the table below to decide which mode is suitable for use with 
your image.

Type of artwork Scanning resolution

Business cards, letter heads 150 - 300 dpi

Hand sketches 150 - 300 dpi

Photos and images 150 - 300 dpi

Commercial art, line drawing 72 - 150 dpi

Source image Example Description
Recommended 
color mode *

No. of colors in 
scanned image

Line art Two colors – 
usually black and 
white

Black/white 
drawing
Line art

2
2

Drawing/sketch Sketch or 
drawing with 
shades of gray

Grayscale 
Line art

256
2

* Different scanning software uses different terms for the equivalent mode.
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Scanning tips
 Do not scan line art images in grayscale mode – grayscale scanning produces 

fuzzy edges.
 Scan color images in RGB mode (millions of colors) rather than 256 color 

mode. The color count can be reduced once the image is loaded into the 
software. EmbroideryStudio can use the extra information to produce a better 
image than one scanned at 256 colors.

 Do not scan color images in CMYK (Cyan, Magenta, Yellow, and Black) mode 
as this is only used for images that will be printed – colors may be different 
to RGB colors.

 If the image needs to be rotated, do so while scanning. Rotating afterwards 
may distort the image.

Sharpening
Some scanning software lets you apply what is called ‘sharpening’ as you scan. 
Sharpening compensates for the slight blurring in a scanned image by looking 
for any differences between colors. Sharpening accentuates these differences 
which makes the image edges more defined. It does not increase image details 

Black & white 
photograph

Shades of gray Black/white photo
Grayscale

256
256

Color photograph Many colors Color RGB 
Color photo

16 million
256

Color picture Two colors or 
more

Color RGB
Millions of colors
Color drawing

16 million
16 million
2 - 256

Source image Example Description
Recommended 
color mode *

No. of colors in 
scanned image

* Different scanning software uses different terms for the equivalent mode.

Scanned in 256 
color mode

Scanned in RGB color
mode (millions of

colors)
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but makes them more obvious. In general, use sharpening with well-defined 
outlines. Don’t use it with non-outlined images.

Opening artwork in EmbroideryStudio

Bitmap images of different formats can be scanned or ‘loaded’ into 
EmbroideryStudio for use as digitizing backdrops. You can scale and transform 
them after importing but it is generally better to do so during scanning. Scaling 
afterwards may distort the image.

Caution  Included artwork (clipart) and embroidery designs can only be used 
for personal use – i.e. they cannot be commercially sold in any form. Changing 
the medium – i.e. clipart to embroidery or embroidery to clipart – does not 
remove copyright protection.

Scanning images

You can scan images directly into EmbroideryStudio for use as digitizing 
backdrops. The scanning feature in EmbroideryStudio allows you to use most 
TWAIN-compatible scanners. You can use any scanning software provided that 
it can save the image in one of the compatible formats.

Tip  You can also scan in your own textured backgrounds to see what a design 
will look like on real fabric. Fabrics can be scanned to provide full, centered, 
backgrounds to your design, or as small samples which can be tiled to fill the 
screen. 

To scan an image
1 Set up your scanner. 
2 Prepare the artwork for scanning. 
3 Select File > Scan Graphic.
4 Choose a scanning mode and resolution. If you are scanning a fabric 

background, set the scan to 256 colors, 100% and 72 dpi (dots per inch). 
These settings will give a small file which will display well on your screen 
without taking up too much disk space or memory.

5 Preview the image in the scanning program.
6 Select the area to be scanned and scan the image.
7 Save the scanned picture in a compatible format picture file to your My 

Designs folder.

Note  Scanned drawings are bitmaps and must be saved separately from the 
design file or they will be lost when you close the design. 

Scanned with 
sharpening

Scanned without
sharpening
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Related topics
 Preparing artwork for scanning
 Fabric & product backgrounds
 Setting up scanners
 Saving artwork

Importing graphics

Bitmap images of various formats can be imported or pasted into 
EmbroideryStudio for use as digitizing backdrops.

Tip  If you are editing images in a third-party graphics application, you can copy 
and paste into EmbroideryStudio via the Windows clipboard.

To import a graphic image
1 Click the Import Graphic icon or select File > Import Graphic.

2 Navigate to the graphics folder. The dialog defaults to ‘All graphic files’ which 
displays all supported file types – BMP, PNG, EPS, etc.

3 Filter the Files of Type list as required – e.g. ‘BMP’.

Note  While ‘All graphic files’ includes both vector and bitmap formats, for 
native CDR and other vector file types, use the CorelDRAW® Graphics Suite 
import function.

Use Standard > Import Graphic to import artwork into current design as a backdrop 
for manual or automatic digitizing.

Use View > Show Bitmaps to toggle bitmap images on or off. Right-click for 
settings.

All supported graphic file types
are displayed using this option
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4 Select a file and click Open.

Tip  Use Auto Trace To Vectors to create vector outlines from bitmap 
images. You can then convert these to embroidery objects using a variety of 
input methods. Auto Trace To Vectors can find holes in shapes – both 
inside and outside boundaries are detected.

Related topics
 Supported graphics and multi-decoration file formats
 Operating modes
 Auto-tracing bitmap artwork

Opening graphic files directly

Artwork can be opened in EmbroideryStudio in both vector and bitmap (raster) 
formats via Design Library. Samples of both file types are installed with 
EmbroideryStudio in the Pictures library as shown below.

The New from Selected command can also be used to open graphics files, 
including Corel CDR. With CDR, a new file is opened in EmbroideryStudio before 
switching to CorelDRAW Graphics.

Related topics
 Combining objects & designs
 Opening designs from Design Library
 Working with templates

Preparing artwork for digitizing

EmbroideryStudio allows you to crop bitmap images prior to use. You can also 
open images directly in third-party bitmap editing packages or use in-built 

Click Mode > Design Library to open the Design Library window from which to 
search and manage designs and job orders.

Use Manage Designs > New From Selected to create new designs based on 
designs selected in Design Library.

Filter by 
graphic file
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CorelDRAW® Graphics Suite. Within EmbroideryStudio you can set general 
properties such as size and position. You can also scale and transform bitmap 
images although it may be best to do this during scanning.

Note  CorelDRAW Graphics provides the latest CorelDRAW® Graphics Suite 
drawing tools. These offer techniques for inserting and manipulating bitmap 
images, including vector tracing. Vector objects can then be converted to 
embroidery designs. See also Operating modes.

Image transparencies

Support is provided for transparent backgrounds in 24 bit and 32 bit images.

If an image contains a transparent background:
 The background is automatically excluded from auto-digitizing.
 The image is automatically cropped to its visible extents.

Caution  Avoid using images that contain semi-transparent or transparent 
pixels within image color areas as these cause poor results when reducing the 
color count. The resulting pixels may end up as holes inside the image or 
significantly reduce color areas to the point where they are unnecessarily 
removed from the embroidery results.

Cropping bitmap images

Before using bitmap images for design purposes, crop them to remove 
unnecessary detail and save processing time. EmbroideryStudio allows you to 
‘soft crop’ images which means that you can redefine or remove the cropping 
area at any stage.

Imported into
EmbroideryStudio

Source bitmap with 
transparent 
background

Use Auto-Digitizing Tools > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.

Click Auto-Digitizing Tools > Remove Crop to remove any crop areas applying to 
selected artwork.
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To crop a bitmap image
 Scan or import the image to use.
 Select the image and choose a cropping tool from the Crop Bitmap droplist. 

The same options are available under the Graphic menu.

 Click and drag the selected shape around the area to be cropped. 
Alternatively, use the Any Shape method to digitize a cropping shape.

Select cropping 
method



Chapter 34   Digit iz ing with Bitmaps 692

 Reshape or transform the cropping shape with the Reshape tool.

 Click Select Object or press Esc to close. 
 To remove a cropping area, select all reshape nodes and press Delete.
 Use the Graphics > Finalize Crop command to crop an image to its new 

visible extents. When you create a cropped area, it is considered ‘temporary’ 
and can be reshaped at will. By using the Finalize Crop command, you make 
the crop permanent. The only way to go back is via the Undo command or 
by reinserting the original bitmap.

Related topics
 Importing graphics
 Reshaping embroidery objects

Touching up bitmaps

Sometimes you need to edit bitmap images directly in a third-party graphics 
package. You would normally do this in order to eliminate backgrounds, flood-fill 
solid areas with color, add or reinforce outlines, or close gaps. From within 
EmbroideryStudio you can open images directly in MS Paint, Corel 
PHOTO-PAINT®, or Paint Shop Pro™. Images updated in this way are 
automatically re-imported into EmbroideryStudio.

To touch up a bitmap
1 Select the image.

2 Select Graphics > Edit Using >.... The image opens in the select graphics 
package.

Background may be 
cleaned and eyes 
added
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3 Edit the image and save.

Note  If you return to EmbroideryStudio before closing the image in the 
graphics package, it is overlaid with stripes.

4 Return to the graphics package and select either File > Close or File > Exit 
& Return <Filename>. In EmbroideryStudio, the stripes will disappear.

Related topics
 Importing graphics

Smoothing bitmap images

When you scale or transform backdrops, the quality is sometimes reduced – e.g. 
thin straight lines become jagged or distorted. EmbroideryStudio allows you to 
smooth an image before and after scaling or transforming, making it easy to 
digitize.

To smooth a bitmap image
 Select the image and double-click to access object properties.

Background cleaned 
and eyes added

File still open in the 
graphics package

Select required 
smoothing option
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 Select the desired smoothing option, depending on whether the majority of 
lines in the image are light or dark.

 Optionally, scale and transform the image on-screen or via the Property and 
Transform toolbars.

Related topics
 Importing graphics
 Modifying Objects

Saving artwork

All images placed in the design window, whether by scanning, pasting or 
inserting from hard disk, are saved together with the embroidery design in the 
EMB file. After editing in EmbroideryStudio or third-party graphics application, 
you may want to save the image out as a separate file.

To save artwork
1 Scan or load the image you want to use.
2 Still in CorelDRAW Graphics mode, select the image.

Light lines smoothed Dark lines smoothedNo smoothing

Scale and transform images 
like embroidery objects
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3 Select File > Export. The Export dialog opens.

4 Choose a suitable file format from the droplist – e.g. BMP or PNG.
5 Select an export folder, then select a format from the Save as type droplist.
6 Enter a file name and click Export.

Note  This file is not referenced by the EMB file. Any further changes to it are not 
reflected in the embedded image.

Related topics
 Opening artwork in EmbroideryStudio

Preparing artwork for continuous embroidery

Many customers make traditional garments such as sarees which employ 
continuous and sometimes overlapping designs. It is important that artwork 
used for continous embroidery is properly sized and orientated. When doing 
continuous designs on multihead systems, horizontal distance will generally be 
a function of the gap between machine heads – e.g. 135 mm.

There are two main sources of artwork for continuous embroidery:
 Enlargement drawings. These are typically used with a digitizing tablet. See 

the Schiffli Supplement for details.
 Scanned images or graphics files from third-party software. These are used 

for on-screen digitizing.

Select file 
format

Vertical distance

Horizontal distance
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The same considerations apply for both types of artwork. However, while with 
enlargement drawings you adjust drawing scale, with electronic artwork, you 
adjust on-screen image size and rotation. Generally electronic artwork will be 
prepared to exact dimensions. To check a design repeat, you need to measure 
the distance between two repeat points. You will need to choose clearly 
identifiable points on the design which are easy to identify.

To adjust an image to repeat
 Scan or insert your artwork as you would a normal digitizing backdrop. If you 

have prepared your artwork in CorelDRAW Graphics, switch to Wilcom 
Decoration.

 Select View > Measure. Click the first (left) repeat reference point, then 
place the cursor over the second point.

 Check the X and Y values and the angle. If the angle is not zero the image 
may need to be rotated. You can decide the acceptable tolerance. Small 
errors are usually acceptable. Usually 0.3mm in real size is the smallest error 
the human eye can discern.

 If you need to rotate it, select the image and enter the exact rotation setting 
in the Transform toolbar.

Caution  Rotation of bitmap images can reduce definition. For better quality, 
go back to the source application and adjust artwork there. Or, in the case of 
scanned artwork, adjust it on the scanner and re-scan.

 Once rotation is fixed, measure the two points again and compare the X value 
with the Design Repeat value. Again you need to decide what tolerance is 
acceptable. First you need to calculate the necessary scale factor, which is:
Scale Factor = (Measured Repeat (X) ÷ Design Repeat) × 100%
If the image needs to be enlarged by 10%, you will get 110% or a similar 
value; if it needs to be reduced by 5%, you will get 95% or similar.

 If necessary, adjust dimensions by a percentage in Property Bar.

Repeat
reference point

Repeat 
reference point

5°

Enter exact rotation 
value – e.g. -5°

Adjust overall design 
dimensions
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Tip  The Show Repeats function displays repeating designs, including 
sequins, in both TrueView and stitch view. You can view a design, even while 
digitizing, with any number of repeats. See also Viewing design repeats.

Preparing artwork for auto-digitizing

The Auto-Digitizing tools provide everything necessary to automatically 
digitize shapes in electronic artwork without using manual input methods. Even 
if your artwork looks ready to stitch when inserted into the software, however, 
it will need to be image-processed before conversion.

Use the Prepare Bitmap Colors tool to prepare images for automatic digitizing. 
This function automatically flattens colors, sharpens outlines, and reduces 
‘noise’. Areas enclosed by a black outline are reduced to a single color. This 
makes it easier for the software to recognize distinct areas in the artwork. These 
areas then become the embroidery objects of the finished design.

To prepare artwork
 Scan or import the image to use. Depending on the quality of the scanned 

image, you may need to touch it up manually before processing in 
EmbroideryStudio. You would normally do this in order to eliminate 
backgrounds, flood-fill solid areas with color, add or reinforce outlines, or 
close gaps.

Use Auto-Digitizing Tools > Prepare Bitmap Colors to reduce the number of colors 
and remove image ‘noise’ in non-outlined images.
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 Depending on the source, you may find dithering, anti-aliasing, or other 
sources of ‘noise’ in the image. If it contains outlines, these will generally be 
blurred by anti-aliasing.

 Select the image and click the Prepare Bitmap Colors icon. The image 
appears in both ‘before’ and ‘after’ preview panels. Note the number of colors 
in the original. The software automatically detects the main color blocks and 
reduces colors accordingly.

 If there appear to be too few colors to provide the detail you want, use 
Processing options to increase the color count.

 Manually locate and merge like-colors as necessary:
 Holding the Ctrl key, click like-colors to select.
 Click and hold Locate to preview.

Outlines blurred by 
anti-aliasing

Set desired 
color count

Set ‘granularity’ of 
source image for 
processing



EmbroideryStudio e4 User Manual 699

 Click Merge to merge like-colors into a single color.

 Use the scroll button on your mouse to zoom in and inspect details.

 The Embroidery Detail setting affects the area used to generate embroidery 
objects. While it doesn’t affect the image, it does affect the embroidery result 
by filtering out smaller areas of color. ‘Fine’ tolerance generally results in 
more detail and a greater number of embroidery objects. ‘Coarse’ generally 
results in slightly less detail but reduces the number of embroidery objects. 
It is useful for ‘noisy’ images with lots of small areas. It works especially well 
with JPG files which are inherently more noisy.

 Click OK to process the image. Image colors should be reduced as per the 
preview. The artwork can now be auto-digitized.

Related topics
 Touching up bitmaps
 Importing graphics
 Supported graphics and multi-decoration file formats

Click to merge 
selected colors

Ctrl + click to 
select multiples

Scroll to zoom in and 
inspect detail

Outlines sharpened and 
noise reduced
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Adding & matching image colors

You can manually match colors from an inserted bitmap or vector graphic to 
thread colors in selected chart/s. But the quicker way is by using automatic color 
matching.

To add and match image colors
1 Insert a bitmap image for use as a digitizing backdrop.

2 Prepare the image to remove unwanted colors.
3 Select Graphics > Add Bitmap Colors. All colors used in the image appear 

in the Add Bitmap Colors dialog.

4 Select the thread chart/s to include in the search from the Thread Charts 
list. To automatically match the image colors to available threads, simply click 
OK. The system assigns thread colors from the selected chart/s to the current 
colorway.

5 To make your own color selections, first select the color to match.
6 Click Match. The system searches for the closest match across all selected 

charts and displays them in the thread color list below.
7 Select a thread and assign to the color palette by double-clicking or clicking 

Assign.
8 Repeat until all the colors you intend to use in the design have been matched. 

Each search negates the previous results.
9 Click OK. The selected thread colors are assigned to the current colorway.

Select thread 
chart/s

Select color
to match

Matched
colors listed

Click to
assign

Click to
match
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Note  The maximum number of new thread colors which can be added to the 
color palette from a bitmap is 128.

Related topics
 Auto-digitizing image shapes
 Importing graphics
 Preparing artwork for auto-digitizing
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Chapter 35

Digitizing with Vectors

There are two fundamental design modes in EmbroideryStudio:
Wilcom Decoration: This mode allows you to create and edit embroidery 

objects using an embroidery digitizing toolset.
 CorelDRAW Graphics: This mode allows you to create and edit vector 

objects using the CorelDRAW® Graphics Suite toolset.

Wilcom Decoration also provides tools for drawing shapes and outlines directly 
on screen. In this mode, you can also import or paste third-party vector graphics 
such as clipart for use as digitizing backdrops. Scale and transform them in the 
same way as embroidery objects. You can also select colors for vector object 
outlines and fills.
The Auto Trace To Vectors feature lets you convert scanned artwork to vector 
objects. You can then convert these to embroidery objects using a variety of 
input methods.
When working with overlapping vector or embroidery objects, merge, trim or 
split them using Shaping tools.
CorelDRAW Graphics includes the entire suite of CorelDRAW® Graphics Suite 
drawing tools which offer many sophisticated techniques for drafting outlines 
and shapes on screen. Vector graphics so created can be directly converted to 
embroidery objects or even entire designs. Alternatively, you can insert or paste 
third-party vector graphics such as clipart for use in embroidery designs. Or, 
insert, paste or scan bitmap artwork for use as digitizing templates or 
‘backdrops’.

Tip  For a full description of the CorelDRAW® Graphics Suite tools, refer to the 
electronic User Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the onscreen help available from the Help menu.
This section describes how to create vector objects using the digitizing tools as 
well as how to import them from third-party applications. It also explains how 
to merge, trim and split overlapping vector or embroidery objects using the 
shaping tools.
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Creating vector shapes in EmbroideryStudio

EmbroideryStudio lets you ‘draft’ shapes and outlines on screen. You can set 
colors for outlines as well as fills. Vector objects can be converted to embroidery 
objects with the application of manual input methods and stitch types. See also 
Converting objects with CorelDRAW Graphics.

Note  Depending on your product level, EmbroideryStudio includes the 
CorelDRAW® Graphics Suite drawing tools which offer many techniques for 
drafting outlines and shapes on screen. See also Operating modes.

Creating vectors

Use the Graphics Digitizing tools to create vector objects directly in 
EmbroideryStudio. Digitizing vector outlines and fills is like digitizing any other 
objects except that they have no stitch properties applying.

To create vectors
 Select Vector Outline or Vector Fill as your stitch type.
 Draw straight lines in your design using either Digitize Open Shape or 

Digitize Closed Shape digitizing tools. Enter start and end points. To 
constrain the line vertically, horizontally or in 15° angles, press Ctrl as you 
mark the end point.

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes. Press 
<Ctrl> to constrain.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. Press 
<Ctrl> to constrain.

Use Graphics Digitizing > Ellipse to digitize ellipse or circle embroidery objects.

Use Graphics Digitizing > Rectangle to digitize rectangle or square embroidery 
objects. Press <Ctrl> to constrain.

Use Outline Stitch Types > Vector Outline to create vector outlines with no stitch 
properties applying.

Use Fill Stitch Types > Vector Fill to create vector fills with no stitch properties 
applying.
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 Draw lines of any shape using the same tools. Enter reference points to create 
the shape you want – left-click for corner points, right-click for curve points.

 When you create closed shapes with the Digitize Closed Shape drawing 
tool, press Enter to close the shape.

 Draw rectangles and squares using the Rectangle tool. To draw a square, 
hold down Ctrl as you move the pointer.

 Draw circles and ellipses using the Ellipse tool.
 To draw a perfect circle, press Enter.
 To draw an ellipse, move the pointer again, then mark a second radius 

point when the outline is the required size. Press Enter.

 Press Enter to close a shape.

Coloring vectors

EmbroideryStudio lets you set colors for vector outlines as well as fills. Coloring 
makes vector objects easier to interpret. For example, a solid fill color might 
suggest Satin or Tatami, while a fill pattern may be interpreted as Motif Fill or 
Program Split.

Corner point

Curve point

Corner point

Curve point

Press Enter to 
close the shape

Click to enter
corner point

Drag pointer, 
click again

Click to enter
center point

Press Enter for circle or 
mark a point for ellipse

Drag pointer

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to select colors for vector outlines and fills.
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To color vectors
1 Create or insert a vector graphic.

2 Ungroup the vector objects as necessary.
3 Select a vector object, right-click and select Properties from the popup 

menu. The Object Properties docker opens. 
4 To change the outline color of the selected object, adjust the settings in the 

Line panel:
 Select an outline style from the Style list.
 Select an outline width from the Width field.
 Click Color and select an outline color from the Color dialog.

5 To fill the selected object with a solid color, select the Solid Fill icon and click 
the Color droplist to access the colors.

6 To fill the selected object with a pattern fill, select the Pattern Fill icon and 
adjust the settings:
 Select a pattern style from the droplist.
 Select a foreground color via the Front button.

Vector graphic

Select outline style

Select outline width

Select outline color

No fill currently
selected

Select solid fill

Click to
choose color
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 Make the background transparent as required or choose a color via the 
Back button.

7 To fill the selected object with a bitmap – e.g. a fabric texture – select the 
Bitmap Fill icon and click the Load button to insert an image file via the 
Open dialog.

Note  To view the changes in the production worksheet, select File > Print 
Preview. In the Options > Design tab select the Vectors checkbox.

Related topics
 Inserting vector graphics
 Customizing design reports
 Design options

Importing vector artwork

Vector graphics of different formats can be inserted or ‘loaded’ into 
EmbroideryStudio for use as digitizing backdrops or for conversion to 
embroidery. Vectors can be inserted directly into Wilcom Decoration or via 
CorelDRAW Graphics.

Select pattern fill

Select pattern style

Select colors for pattern
foreground and

background

Select bitmap fill

Click to load
image file
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Caution  Included artwork (clipart) and embroidery designs can only be used 
for personal use – i.e. they cannot be commercially sold in any form. Changing 
the medium – i.e. clipart to embroidery or embroidery to clipart – does not 
remove copyright protection.

Inserting vector graphics

Vector graphics from third-party applications can be inserted into 
EmbroideryStudio in a variety of native and interchange vector formats. You can 
also import vector graphics (not DXF) as bitmaps. You can convert vector 
graphics to embroidery objects using a variety of input methods or with the 
Auto-Digitizing tools.

Note  CorelDRAW Graphics includes the entire suite of CorelDRAW® 
Graphics Suite drawing tools which offer techniques for inserting and 
manipulating vector graphics. 

To insert a vector graphic
1 Create a new file in EmbroideryStudio or open the design file into which you 

want to insert the vector graphic.
2 Click the Import Graphic icon or select File > Import Graphic.

3 Navigate to the graphics folder. The dialog defaults to ‘All graphic files’ which 
displays all supported file types – BMP, PNG, EPS, etc. You don’t need to 
change the Files of type setting unless you want to filter on a specific file 
type – e.g. DXF.

Use Standard > Import Graphic to import vector graphic or bitmap image into 
current design

Use View > Show Vectors to show or hide any vector artwork included in the design. 
Right-click for settings.

Select to remove 
overlapping objects

Select to insert as bitmap 
rather than vector
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Note  While ‘All Graphic Files’ includes both vector and bitmap formats, for 
native CDR and other vector file types, use the CorelDRAW® Graphics Suite 
import function.

4 If you are working with DXF files:
 Click Options. The DXF File Options dialog opens.

 Select Inches or Millimeters from the Units of Measurement list and 
click OK. If this information is not specified, the vector graphic may not 
display at the correct size.

5 Select the As Bitmap checkbox to insert the vector graphic as a bitmap 
image. 

Note  DXF files cannot be imported as bitmaps.
6 Select the Flatten checkbox to remove any overlapping areas from the vector 

graphic.

7 Select the Preview checkbox to see a preview of the vector graphic.
8 Click Open to insert the vector graphic into the design window.

Tip  You can also paste vectors directly into EmbroideryStudio through the 
MS Windows® clipboard.

Select unit of 
measurement

 Imported as bitmap image – 
individual objects cannot be 

selected

Imported as vector graphic – 
individual objects can be selected

Vector objects not ‘flattened’Vector objects ‘flattened’

Hidden areas 
removed

Hidden areas 
preserved
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Related topics
 Operating modes
 Converting objects 
 Auto-digitizing image shapes

Loading vector artwork

You can load vector artwork of various formats via CorelDRAW Graphics for 
use as digitizing backdrops for manual or automatic digitizing. You can also use 
this technique to insert bitmaps.

Note  CorelDRAW® Graphics Suite is packaged with a selection of clipart which 
can be used as digitizing backdrops or converted directly into embroidery.

To load vector artwork
1 Switch to CorelDRAW Graphics and click Import on the Standard 

toolbar.

2 Select a folder and select a file type from the Files of Type list – e.g. EPS.

Use Mode > Switch to CorelDRAW Graphics to import, edit or create vector 
artwork as a backdrop for embroidery digitizing, manual or automatic.

Use Standard > Import to import a file to the active document in CorelDRAW 
Graphics.

Use View > Show Vectors to show or hide any vector artwork included in the 
design such as CorelDRAW® clipart. Right-click for settings.

Select format
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3 Select a file and click Import. The Import EPS dialog opens. You are 
prompted to import text as pure text or as vector curves.

4 Position the cursor in the design window and press Enter.
5 Choose a digitizing technique:
 Convert vectors to embroidery: See Converting objects with CorelDRAW 

Graphics for details.
 Switch to Wilcom Decoration and use the artwork as a digitizing 

backdrop: See Digitizing methods for details.

Note  If you cannot see the image you loaded in Wilcom Decoration, make 
sure Show Vectors icon is toggled on. 

Tip  Locking backdrop images holds them in place as you digitize, transform 
or reshape the embroidery objects near them. Locked objects can be 
unlocked for modification at any time. 

Related topics
 Operating modes
 Browsing artwork with CorelDRAW®
 Change backgrounds
 Grouping & locking objects
 Converting objects 
 Auto-digitizing image shapes

Select required
format

Import text as
text or curves
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Auto-tracing bitmap artwork

Use Auto Trace To Vectors to create vector outlines from bitmap images. You 
can then convert these to embroidery objects using a variety of input methods. 
Auto Trace To Vectors can find holes in shapes – both inside and outside 
boundaries are detected.

To auto-trace bitmap artwork
1 Scan or insert a bitmap image. 
2 Select the image and process it using the Prepare Bitmap Colors tool.

3 Click the Auto Trace To Vectors icon. The design is automatically traced 
into vectors, both outlines and filled shapes.

Note  If the bitmap needs preliminary color reduction, clicking Auto Trace 
To Vectors takes you directly to the Prepare Bitmap Colors dialog.

Use Auto-Digitizing Tools > Auto Trace To Vectors to convert artwork to vector 
objects for conversion to embroidery objects.

Bitmap converted to 
vector outlines and 
filled shapes
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4 Select the shape/s you want to convert to embroidery and convert using any 
of the available techniques.

Related topics
 Converting objects
 Importing graphics
 Preparing artwork for auto-digitizing

Smoothing curves

Both vector and embroidery objects contain reshape-nodes on their outlines. On 
shapes where the angle changes constantly, the software may insert hundreds 
of reshape-nodes, making reshaping difficult. The Smooth Curves command 
applies curve ‘smoothing’ to embroidery as well as vector objects.

To smooth curves
1 Select the object (or objects) to smooth.

Note  You can only smooth objects that have been ungrouped and selected. 
However, you can select multiple objects.

2 Optionally, click Reshape Object to view reshape-nodes around the outline.

Convert vectors to 
embroidery

Use Reshape Tools > Reshape Object in combination with Edit > Smooth Curves 
to remove unnecessary reshape-nodes from vector graphic objects.

Reshape-nodes 
reduced to minimum 
necessary
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3 Select Edit > Smooth Curves.

4 Adjust the Precision field. This value controls how closely the smoothed 
outline follows the original. The larger the precision value, the fewer the 
reshape-nodes.

5 Click OK.

Visualizing vector graphics

Vectors can be viewed in a variety of ways in Wilcom Decoration. Toggle 
vectors on or off with the Show Vectors icon. View vectors in the Color-Object 
List. Click Locate to isolate selected vector objects on-screen.

Enter smoothing 
precision value

Use View > Show Vectors to show or hide any vector artwork included in the design 
such as CorelDRAW® clipart. Right-click for settings.

Use View > Show Repeats to toggle design repeats display. Right-click for settings.

Click to view selected 
vector object

Vector drawing 
objects
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Vector graphics can also be visualized using Show Repeats. This can be useful 
when digitizing continuous embroidery designs. 

Related topics
 Viewing design repeats

Show repeats for more 
accurate digitizing
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Chapter 36

Automatic Digitizing

EmbroideryStudio provides a variety of 
complementary tools and techniques for 
semi-automatically digitizing suitably 
prepared artwork.
 The Convert feature lets you convert 

vector objects directly to embroidery 
objects. And vice versa. Entire designs 
can be converted in either direction.

 The Auto-Digitizing tools provide 
everything necessary to digitize shapes 
in graphics automatically without using 
manual digitizing methods.

 The Smart Design feature 
automatically converts bitmap images to 
embroidery.

 The Photo Flash feature creates 
embroidery designs from photographs 
and other grayscale bitmap images. The 
effect resembles the output of a line 
printer.

 The Color PhotoStitch feature creates embroidery from photographs and 
other images. It produces variegated stitching using multiple thread colors. 

This section describes how to automatically convert graphics to embroidery 
objects and complete designs using a variety of techniques, as well as how to 
create embroidery from grayscale images and photographs.

Converting objects

EmbroideryStudio lets you convert vector graphics directly to embroidery 
objects using a variety of techniques. Similarly, you can convert embroidery 
designs or objects to vector graphics. You can also convert between different 
Run and Column C objects. This is useful when scaling designs – e.g. for creating 
thicker or thinner columns and borders.

Converting objects with CorelDRAW Graphics

Use Mode > Tag Fill as Turning Satin to tag narrow shapes for conversion to turning 
stitching. 

Use Mode > Match to Embroidery Palette to toggle on/off thread color matching for 
converted vector objects.

Use Mode > Tag as Photo Flash to convert photos to Photo Flash embroidery from 
CorelDRAW Graphics.
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Some EmbroideryStudio product levels include CorelDRAW® Graphics Suite as 
standard. This lets you convert vector objects directly to embroidery objects via 
CorelDRAW Graphics. You can also convert embroidery to vector objects. 
Individual objects or whole designs can be converted. Bitmaps can also be used.

To convert graphic and embroidery objects
 Open a vector or embroidery design, depending on which mode you are 

working in – CorelDRAW Graphics or Wilcom Decoration.

The Convert function is located on the Mode toolbar. Behavior depends on 
the operating mode:
 In CorelDRAW Graphics, selected vector objects are converted to 

embroidery and displayed in Wilcom Decoration.

 In Wilcom Decoration, selected embroidery objects are converted to 
vector objects and displayed in CorelDRAW Graphics.

 If you want to keep a copy of the original vector objects, click the Keep 
Original Objects toggle in CorelDRAW Graphics.

 Use the Match to Embroidery Palette tool to toggle on/off thread color 
matching.
 When turned on, converted vector objects are assigned the nearest 

matching thread color in the current color palette. 

Use Mode > Convert Embroidery to Graphics to convert selected embroidery to 
graphics and switch to CorelDRAW Graphics.

Use Mode > Convert Graphics to Embroidery to convert selected graphics to 
embroidery and switch to Wilcom Decoration.

Use Mode > Keep Original Objects to retain the original graphics during conversion.

Convert in both 
directions
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 When turned off, a new thread color is added to the palette based on the 
vector color.

 Optionally, activate Tag Fill as Turning Satin. This produces a branched 
object as shown below. 

Tip  Vectors can also be converted to appliqué as well as to lettering. See also 
Creating lettering with CorelDRAW Graphics.

Related topics
 Working with design files
 Converting vector graphics to appliqué 
 Creating lettering with CorelDRAW Graphics

Converting objects with Wilcom Decoration

You can convert vector objects to embroidery objects by right-clicking a selected 
object and select Convert > ... from the popup menu.

The resulting object takes the current stitch type, color and object properties set 
for that digitizing method. Vector objects can be converted to appliqué. You can 

Without turning satin With turning satin

Vectors converted to lettering

Choose a 
conversion target
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also create objects with turning stitches by adding stitch angles directly to vector 
objects.

You can easily convert objects from Column A/B to Complex Fill or Complex 
Turning. This is useful for editing. For example, as curved fill effects can only be 
used with Complex Fill objects, you can add them to Column A/B shapes by first 
converting to Complex Fill. Also when scaling designs, an Column A/B shape 
may become too big for Turning Satin. By converting to Complex Fill or Complex 
Turning, you can apply fixed or turning Tatami or some other fill stitch type. 

You can change an Auto Appliqué or vector object to a Complex Fill object in the 
same way. You can also convert Complex Fill to Complex Turning. If you 
convert to Complex Turning, you are prompted to enter more than one stitch 
angle line and press Enter.

Note  If a current stitch type is not applicable to the target object – e.g. 
Contour stitch – Satin will be substituted. If the underlay type is not applicable 
– e.g. Center Run – Zigzag will be used.

Related topics
 Adjusting stitch angles
 Converting objects to appliqué

Auto-digitizing entire images

Enter angle points

Press Enter

Use Auto-Digitizing Tools > Smart Design to create embroidery designs directly 
from imported artwork.

Use Auto-Digitizing Tools > Instant Smart Design to automatically create 
embroidery from imported artwork instantly.
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In essence, creating an embroidery design with Smart Design tools is simply a 
matter of selecting a graphic – bitmap or vector – and converting it to 
embroidery. An extension of Auto-Digitizing technology, Smart Design 
recognizes shapes and makes decisions about the most suitable object types 
and stitch types to use. It also determines stitching sequence based on closest 
join. Artwork is effectively ‘batch processed’ to create the many embroidery 
objects that make up a design. 
Even if an image has not been preprocessed, Instant Smart Design will 
automatically process and convert it using default settings. This is very useful 
for stitch estimates. For more control over object conversion, use the Smart 
Design method. This can also be used as a starting point for embroidery 
digitizing. Once created, edit final results using available digitizing and editing 
techniques. Always remember to apply underlays. You may also need to reshape 
and resequence some objects.

To auto-digitize an entire image
 Scan or insert the artwork. Whether you’re working with bitmap or vector 

graphics, you need to prepare them first:
 Scan or insert a bitmap image. If you are using a bitmap image as input, 

it will need to be image-processed before conversion. 
 Insert or create a vector graphic. If you are using a vector graphic as input, 

you can remove overlapping objects by ‘merging’ them. This eliminates 
overlapping stitching when vector objects are converted.

 Optionally, pre-process the image with the image preparation tool. Even if 
your artwork looks ready to stitch, it needs to be image-processed before 
conversion. However, you will be prompted as necessary.

 Size the image to the preferred dimensions for your target article.

Use Auto-Digitizing Tools > Keep Original Objects to retain the original artwork 
during conversion.

Enter dimensions as exact 
values or as a percentage

Lock aspect 
ratio toggle
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 Optionally, select Design > Auto Fabric to apply preferred fabric settings.

 Crop the image as desired using the Bitmap > Crop tools. 
 Choose a Smart Design method:
 For an instant sample of your artwork, click Instant Smart Design. With 

simple designs, the results my be sufficient to work with.
 For more control, select the image and click Smart Design. The software 

displays the Bitmap Artwork Preparation dialog if the image needs 
preprocessing.

If you are using the Smart Design method, the dialog opens. Image colors 
are automatically sequenced and backgrounds omitted altogether.

Choose a fabric 
type

Tick to activate

Choose whether to 
include or omit 
colors
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 Use the Color Allocation panel to omit unwanted colors. Use the Locate 
button to isolate selected colors. Use the checkbox to omit them.

 Select a conversion method for color processing. By default, bitmap colors are 
added to the current colorway. Optionally, select a specific thread chart to 
match to or match colors to the current palette.

 Optionally, add outlines to all detected shapes. Tick Outlines and select a 
palette color from the droplist. This has the effect of reinforcing all color 
blocks with continuous, branched running stitches.

White background 
color omitted

All colors omitted 
except black

Specify preferred 
color handling 

Image colors added 
to palette

Image colors matched to 
nearest thread colors

Include outlines
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 Click OK to process the image.

Note  All editing techniques are available to further refine the auto-digitized 
image.

Related topics
 Preparing artwork for scanning
 Cropping bitmap images
 Preparing artwork for auto-digitizing
 Modifying Designs
 Eliminating small stitches

Auto-digitizing image shapes

The Auto-Digitizing tools provide everything necessary to automatically 
digitize shapes in electronic artwork – both bitmap and vector – without using 
manual digitizing methods. These tools are useful for turning scanned images 
into embroidery designs that do not require particular artistic effects or 
embroidery-specific knowledge. If you are using a vector graphic, it must include 
a fill color. Auto-Digitizing can be used to create tatami fills as well as objects 

Outlines added to 
all color blocks

Colors omitted and 
outlines only generated

Use Auto-Digitizing Tools > Color Matching Method to select a matching method.

Use Auto-Digitizing Tools > Turning Satin Object to fill narrow column shapes with 
turning stitch angles.

Use Auto-Digitizing Tools > Tatami Fill Object with Holes to fill large areas with 
tatami stitching, preserving any holes.

Use Auto-Digitizing Tools > Tatami Fill Object to fill large areas with tatami stitching, 
ignoring any holes.

Use Auto-Digitizing Tools > Centerline Run Object to create centerlines in narrow 
shapes with run stitching.

Use Auto-Digitizing Tools > Outline Run Object to create outlines of run stitching.
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with turning satin. Use it also to digitize outlines and details with run stitching. 
Current properties are applied.

To auto-digitize image shapes
 Scan or insert the artwork. Whether you’re working with bitmap or vector 

graphics as input, you need to prepare them first:
 Scan or insert a bitmap image. If you are using a bitmap image as input, 

it will need to be image-processed before conversion. 
 Insert or create a vector graphic. If you are using a vector graphic as input, 

you can remove overlapping objects by ‘merging’ them. This eliminates 
overlapping stitching when vector objects are converted.

 Size the image to the preferred dimensions for your target article.

 Optionally, select Design > Auto Fabric to apply preferred fabric settings.

 Click Color Matching Method and decide how you want to handle color 
matching. Add image colors to the palette, choose closest matches from 
selected thread chart/s, or match image colors to the current palette (the 
default).

 Select an auto-digitizing fill method:
 Use Tatami Fill Object with Holes for large areas, preserving any holes 

within them. 
 If you want holes ignored, use Tatami Fill Object.
 Use Turning Satin Object to digitize narrow turning shapes with satin 

stitch.

Enter dimensions as exact 
values or as a percentage

Lock aspect ratio 
toggle

Choose a fabric 
type

Tick to activate

Choose a thread 
matching method

Select one or more thread 
charts to match to
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 Click the shapes you want to digitize. Stitches are generated according to 
current settings.

 Optionally, edit object properties, including colors, stitch angles, entry/exit 
points and so on.

 Select an auto-digitizing outline method:
 Use Centerline Run Object to create centerlines in narrow shapes with 

run stitching.
 Use Outline Run Object to create outlines of run stitching.

Turning satin

Tatami fill

Edit object properties 
as preferred



EmbroideryStudio e4 User Manual 725

 Again click the shapes you want to digitize. Stitches are generated according 
to current stitch settings.

 Again, edit object properties as preferred, including colors, stitch types, and 
so on. Even convert run outlines to satin borders.

 Use the Color-Object List and/or Sequence toolbar to optimize the stitch 
sequence of your auto-digitized objects.

 Use the Closest Join and/or the Reshape tool to minimize connectors.

Related topics
 Importing graphics
 Inserting vector graphics
 Merging vector & embroidery objects
 Sequencing embroidery objects
 Reshaping embroidery objects
 Minimizing connectors
 Converting objects

Auto-digitizing photographs

EmbroideryStudio provides dedicated techniques for auto-digitizing 
photographs. Both colored and grayscale photos can be used as input. The 
Photo Flash effect resembles the output of a line printer. Color PhotoStitch 
produces variegated stitching using multiple thread colors.

Auto-digitizing with Photo Flash

Use Photo Flash to create embroidery from photographs or other images, color 
or grayscale. Color images are automatically converted to grayscale. Photo 

Auto-digitize
center lines

Auto-digitize 
outlines

Use Auto-Digitizing Tools > Photo Flash to create embroidery designs directly from 
photographs.

Use Mode > Tag as Photo Flash to convert photos to Photo Flash embroidery from 
CorelDRAW Graphics.
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Flash designs consist of rows of stitches of varying spacing settings. The effect 
resembles the output of a line printer. 

Tip  For best results, use images with well-defined subjects or constantly 
varying shades.

To create embroidery with Photo Flash
1 Insert the bitmap image in your design and scale it to the required size. 
2 Crop the image as desired using the Bitmap > Crop tools.
3 With the bitmap still selected, click the Photo Flash icon to access object 

properties.

Select resolution 
(row spacing)

Select positive or 
negative image

Enter row angle
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4 In the Resolution panel, select a resolution option – Coarse, Medium, or 
Fine.

Note  The coarser the resolution the more spacing between rows.
5 In the Row panel, enter a new angle as required.

6 In the Background panel, select a background option:

Option Description

Light Applies the maximum row width value to the lightest part of the 
image.

Dark Applies the maximum row width to the darkest part of the image.

Medium resolution Coarse resolutionFine resolution

Row Angle: 90°Row Angle: 0°
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Tip  The option you select usually depends on whether the fabric is light or 
dark. The Dark option produces a negative of the image.

7 Select the Fills tab and adjust the stitch spacing and skew angle as required.

The Skew Angle determines the angle of the stitches.

Dark backgroundLight background

Adjust stitch 
values

Adjust skew 
angle

Skew angle: 0° Skew angle: 45°
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Tip  Use TrueView™ for a more accurate representation of the stitching.
8 Fine-tune Auto Spacing and Auto Split settings as required.
 The Auto Spacing option automatically adjusts stitch spacing according 

to column width. For columns of varying width, Auto Spacing 
automatically adjusts the stitch spacing wherever the column changes 
width.

 Auto Split breaks long Satin stitches into shorter ones. It also distributes 
needle penetrations in a random pattern so that they do not form a line 
down the middle of the shape. 

9 Press Enter or click Apply. 
If you have defined a ‘soft crop’ for your bitmap, EmbroideryStudio generates 
stitches for that area. Otherwise stitches are generated for the entire bitmap.

Note  In CorelDRAW Graphics, the Mode toolbar also includes a Tag as 
Photo Flash icon which allows you to convert photos to Photo Flash 
embroidery.

Related topics
 Importing graphics
 Cropping bitmap images
 Satin fixed spacing
 Applying satin stitch
 Splitting satin stitches

Auto-digitizing with Color PhotoStitch

Use Color PhotoStitch to create embroidery from photographs and other 
images. While Photo Flash designs consist of rows of single-color satin 
stitching, Color PhotoStitch produces variegated stitching using multiple 

[

Use Standard > Import Graphic to import artwork into current design as a backdrop 
for manual or automatic digitizing.

Use View > Show Bitmaps to toggle bitmap images on or off. Right-click for 
settings.

Use Auto-Digitizing Tools > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.

Use Auto-Digitizing Tools > Adjust Bitmap to adjust image lightness and contrast in 
preparation for auto-digitizing.

Use Auto-Digitizing Tools > Color PhotoStitch to automatically turn photographs 
and other bitmap artwork into multi-colored embroidery. 
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thread colors. The overall effect is like multi-colored stippling. For best results, 
use crisp images with well-defined subjects and constantly varying shades.

To prepare the image
 Scan or insert the image you want to use. For best stitching results, images 

are better imported via the CorelDRAW Graphics than Wilcom 
Decoration.

 If you cannot see the image, turn on Show Bitmap Artwork.
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 Size the image for its intended purpose. Optimal size is 150mm x 150mm or 
about 6" x 6". 210mm is the limit. Alternatively, you will be prompted to 
resize when you run Color PhotoStitch.

 Optionally, touch up using Corel PHOTO-PAINT® or similar program.
 Optionally, crop the image.
 Optionally, use Adjust Bitmap to adjust basic lightness and contrast. For the 

full range of image adjustment techniques, use a dedicated graphics program 
like PHOTO-PAINT.

Related topics
 Importing graphics
 Cropping bitmap images
 Touching up bitmaps
 View graphical components

To process the image
 With the image selected, click Color PhotoStitch.

 Set the number of thread colors. There will be a point a diminishing returns 
where more colors do not always result in greater design clarity or 
stitchability. Usually 7 to 10 colors produce the best results.

 Use the zoom buttons to examine the previews in detail. You can also zoom 
in and out with the mouse wheel.

Set required number of 
thread colors

Choose a color 
matching method
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 Optionally, adjust stitching resolution to high, medium, or low. High 
resolution allows greater detail but with a higher stitch count. 

 Click Adjust Bitmap for further options. Choose between several image 
variations:

 Optionally, adjust basic lightness and contrast if you haven’t already done so.
 Use Color Matching to assign image colors to the color palette for manual 

thread matching. This ensures the best representation. Alternatively, 
automatically match them to the current color palette or current thread chart. 
Select one or more available thread charts to match to.

 Click OK to process the image.

To edit the results
 Check the results with TrueView™ on and off. Turn connector stitching on 

and off. For better visualization, set TrueView™ viewing options to thin 
thread.

Effect Notes

Sepia In photographic terms, ‘sepia’ refers to the dark-brown color of old-fashioned prints. 
Originally the process involved adding a pigment made from cuttlefish ink during 
development.

Gray Grayscale or grayscale images are ones composed exclusively of shades of gray, 
varying from black at the weakest intensity to white at the strongest.

Choose a thread
matching method Choose thread chart 

to match with
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If you are unsatisfied with the results, click Undo and try again. Try different 
settings and check the previews. You may need to touch up the image in 
PHOTO-PAINT if none of the results is good enough.

 Edit the results and manually merge thread colors as desired using the 
Color-Object List.

 If you have added RGB colors to the color palette, open the Color-Object 
List and My Threads dockers side-by-side, and select the thread charts you 
have available from the Thread Charts dialog.
Select each color block in turn, check the closest match in My Threads 
docker, and manually choose a thread. Sometimes the closest match may not 
be the best or be unavailable. Choosing the correct thread is key to getting a 
good result.

Related topics
 Viewing design components
 Setting design viewing options
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PART IX

MIXED DECORATION

EmbroideryStudio provides support for various multi-decoration techniques, 
including print.

Appliqué digitizing
This section describes different techniques for creating appliqué including how 
to convert vector graphics to appliqué, how to digitize appliqué objects from 
scratch, as well as how to convert Complex Turning objects to appliqué. It also 
covers creating partial cover appliqué for overlapping objects as well as how to 
break up multiple appliqué and recombine components for efficient stitchout. 
See Appliqué Digitizing for details.

Sequin digitizing
This section describes how to set up custom sequin palettes for the creation of 
sequin designs. It also describes how to create sequin runs and fills. It covers 
the conversion of artwork and other objects to sequins. It also covers setting up 
twin-sequin designs. Sequin reshaping and editing is described as well as 
techniques for digitizing individual sequins. See Sequin Digitizing for details.

Bling digitizing
This section describes how to digitize with rhinestones. It covers setting up bling 
palettes and describes creating bling runs and fills. It also deals with modifying 
bling objects and bling text. See Bling Digitizing for details.
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Chapter 37

Appliqué Digitizing

Automatically create all the stitching you need for appliqué using the Auto 
Appliqué tool. Up to four layers of stitching – guide runs, cutting lines, tack 
stitches and cover stitches – can be generated for any appliqué object.

Print a copy of appliqué patterns to use in cutting out fabric pieces. Each piece 
is numbered according to the stitching sequence. You can also output appliqué 
shapes to cutter or separate file.

Creating appliqué embroidery

Use Auto Appliqué to produce the stitching you require for appliqué objects. 

Tip  If you want to pre-set appliqué settings, right-click the Auto Appliqué icon 
with no objects selected. When property values are changed, settings will apply 
to all newly created appliqué objects in the current session. See Working with 
object properties for details.

Converting vector graphics to appliqué

Use Mode > Tag as Appliqué to tag a vector object for conversion to appliqué.

Use Mode > Convert Graphics to Embroidery to convert selected graphics to 
embroidery and switch to Wilcom Decoration.
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In CorelDRAW Graphics, the Tag as Appliqué button allows you to tag 
selected vector objects for conversion to appliqué. 

To convert a vector graphic to an appliqué object
1 Create or open a vector graphic in CorelDRAW Graphics and select it.
2 Click Tag As Appliqué. The object is tagged for conversion with a thick 

dotted outline. The CorelDRAW® Graphics Suite Object Manager also 
indicates which objects have been tagged as appliqué.

3 Click Convert Graphics to Embroidery. EmbroideryStudio automatically 
converts the vector object to appliqué and switches to Wilcom Decoration. 

Note  When present, vector fill properties are maintained in Wilcom 
Decoration to give the appearance of a fabric patch. Otherwise, fills are 
rendered in grey.

Object appears with 
thick dotted outline

Red appliqué cover 
stitch generated

Fill color remains the 
same

Pattern fill Texture fillGrey fill
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Note  The success of the conversion can be affected by font size as a 
proportion of cover stitch width. Where the cover stitch is too thick for the 
resulting object, it may be ignored.

Related topics
 Adjusting appliqué settings
 Cutting appliqué shapes

Digitizing appliqué objects

Use Auto Appliqué to produce the stitching you 
require for appliqué objects. Up to four layers of 
stitching – guide runs, cutting lines, tack stitches 
and cover stitches – can be generated. When you 
stitch out an appliqué object, the machine stops 
between layers. Auto Appliqué also allows you 
to set a frame-out position which shifts the hoop 
from under the needle, making it easier to place 
and trim appliqué patches.

To digitize appliqué objects
1 Click the Auto Appliqué icon and digitize the boundary of the shape.

Follow the prompts. If you make a mistake, press Backspace to delete the 
last reference point.

2 Press Enter to close the shape.
You can create another appliqué object at this stage.

3 Press Enter again.
4 Click the outline to set entry and exit points or press Enter to accept defaults.
5 If prompted to do so, mark the frame-out position or press Enter to accept 

the default.

Use Appliqué Tools > Auto Appliqué to digitize appliqué objects with up to four 
layers of stitching – guide runs, cutting lines, tack stitches, and cover stitches.
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Frame-out commands are specified as a Stop function or Color Change 
respectively. They can be set after guide run and/or tack stitch.

6 Press Enter. Up to four layers of stitching – guide run, cutting line, tack and 
cover – are generated, depending on current settings.

Mark frame-out 
position

Satin cover stitch

Zigzag tack stitch

Guide run and cutting line
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7 Double-click the appliqué object to check the settings.

8 Adjust settings as required:
 Fabric swatch: See Adding fabric swatches to appliqué for details.
 Guide run: See Adjusting guide run settings for details.
 Tack stitch: See Adjusting tack stitch settings for details.
 Cover stitch: See Adjusting cover stitch settings for details.

9 Optionally, apply Smart Corners to appliqué objects.
10 Optionally, run Stitch Player or use the travel tools to check the appliqué 

stitching sequence.

Related topics
 Embroidery digitizing
 Adjusting frame-out positions
 Controlling corner stitching
 Viewing stitching sequence
 Cutting appliqué shapes

Converting objects to appliqué

Adjust fabric 
swatch settings

Adjust tack stitch 
settings

Adjust cover stitch 
settings

Adjust guide run 
settings

Use popup menu > Auto Appliqué to convert objects to Auto Appliqué.
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You can convert Complex Fill and other objects to appliqué by adding entry, exit 
points and frame-out position. 

To convert objects to appliqué
1 Right-click an object and select Convert and the icon from the popup menu.

2 Click the outline to set the stitch entry and exit points or press Enter to 
accept the defaults. 

3 Mark a frame out position or press Enter to accept the default.
The object is converted and stitches regenerated.

Related topics
 Cutting appliqué shapes

Adjusting appliqué settings

Whether you create appliqué from scratch using the Auto Appliqué tool, or 
convert existing vector graphics or Complex Turning objects, EmbroideryStudio 
produces all the stitching you need. Up to four layers – guide runs, cutting lines, 

Select to convert to 
appliqué object

Frame-out position

Entry and exit 
points

Complex Turning 
object
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tack stitches and cover stitches – can be generated. Each of these layers can be 
adjusted via Object Properties. 

When you stitch out an appliqué object, the machine stops between layers. 
EmbroideryStudio also allows you to pre-set a frame-out movement which shifts 
the hoop from under the needle, making it easier to place and trim appliqué 
shapes.

Tip  If you want to pre-set appliqué settings, right-click the Auto Appliqué icon 
with no objects selected. When property values are changed, settings will apply 
to all newly created appliqué objects in the current session. See Working with 
object properties for details.

Adding fabric swatches to appliqué

EmbroideryStudio lets you select a fabric swatch for appliqué objects. The 
swatch becomes a property of the object. Choose from amongst the included 
‘factory’ swatches or choose a scanned sample of the fabric you want to use. Use 
the Show Appliqué Fabric toggle to turn it on or off.

Satin cover stitch

Zigzag tack stitch

Guide run and cutting line

Right-click Appliqué Tools > Auto Appliqué to choose fabric swatch for selected 
appliqué objects.

Use View > Show Appliqué Fabric to toggle the appliqué fabric display on/off.

Click to choose fabric 
swatch for selected 
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Adjusting guide run settings

The guide run is the first layer to be stitched and is used to position appliqué 
fabric on the background material. An extra cutting line can be added if the 
fabric is to be trimmed in position. You can also specify a frame-out movement 
in order to place the appliqué patch.

To adjust guide run settings
 Double-click the appliqué object to access object properties.

 Select a cutting method:

Right-click Appliqué Tools > Auto Appliqué to adjust guide run settings.

Option Purpose

Pre-cut No cutting line is generated. This assumes you have a pre-cut 
appliqué patch ready to be placed in position.

Trim-in-place An additional cutting line is generated.

Select cutting 
method
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A cutting line allows trim the fabric after the cutting line has been stitched.

 Optionally, adjust Stitch length and Offset values in the Guide Run panel. 
A negative offset moves the guide run within the outline, a positive value 
moves it outside.

 Optionally, set a Frame Out after the guide run in order to place the appliqué 
patch. Depending on the machine you are working with – multi-head or 
single-head – the frame-out command must be specified as a Stop function 
or Color Change respectively.

Related topics
 Adjusting frame-out positions
 Digitizing appliqué objects

Adjusting tack stitch settings

Tacking is used to fix appliqué shapes to a background fabric before cover 
stitching is applied. You can adjust settings or omit this layer altogether. You can 
also specify a frame-out movement in order to trim the appliqué patch.

Guide run 

Cutting line

Tack stitches

Cover stitches

Offset: 1 mm Offset: -1 mm Offset: 0 mm

Right-click Appliqué Tools > Auto Appliqué to adjust tack stitch settings.
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To adjust tack stitch settings
 Double-click an appliqué object to access object properties.

 In the Tack panel, select a tack stitch type from the droplist. Alternatively, 
select None.

 Adjust tack stitch settings according to selected stitch type:

 Optionally, adjust Offset values. A negative offset moves the tack stitch 
inwards relative to the guide run. A positive value moves it outwards.

Option Purpose

Length Stitch length value for Run stitch.

Runs E Stitch only. Number of runs between stitches.

Spacing Stitch spacing value for E Stitch and Zigzag.

Count Number of stitch repetitions for Zigzag only.

Width Column width value for Zigzag and E Stitch.

Offset Run stitch only. Negative offset value moves the tack stitching within 
the outline, a positive value moves it outside.

Select tack stitch type

Adjust tack stitch 
spacing

Run tacking Zigzag tackingE Stitch tacking

Zigzag spacing: 3mm Zigzag spacing: 1.5mm

Negative offset Positive offsetNo offset
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 Optionally, set a Frame Out after the tack stitching in order to trim the 
appliqué patch. Depending on the machine you are working with – multi-head 
or single-head – the frame-out command must be specified as a Stop 
function or Color Change respectively.

Adjusting cover stitch settings

The cover stitch is generally the satin border around the appliqué shape. 
However, you don’t have to include it. Optionally, you can change the cover 
stitch type to zigzag, E stitch or raised satin. You can also adjust width and offset 
relative to other appliqué components.

To adjust cover stitch settings
 Double-click an appliqué object to access object properties.
 Optionally, turn off cover stitching via the checkbox.

 Adjust cover stitch Width as preferred.

 Optionally, adjust Offset values. A negative offset moves the border inwards 
relative to the tack stitch. A positive value moves it outwards.

Right-click Appliqué Tools > Auto Appliqué to adjust cover stitch settings.

Adjust cover stitch 
settings

Cover stitch width:
1.5mm

Cover stitch width: 
3.0mm

Positive offset

Negative offset



Chapter 37   Appl iqué Digit iz ing 746

 For more or less dense cover stitching, change stitch types via the Object 
Properties > Fill tab. Adjust Spacing values accordingly.

Adjusting frame-out positions

When stitching out appliqué objects, you can set a frame-out position after the 
guide run and/or tack stitch. This shifts the hoop out from under the needle, 
making it easier to place and trim the appliqué. Depending on the machine you 
are working with – multi-head or single-head – the frame-out command must 
be specified as a Stop function or Color Change respectively. 

To adjust the frame-out position
 Select the object and click the Reshape Object icon.

Control points appear along with the Reshape Views toolbar. Appliqué 
objects include a frame-out position marker. Show Entry/Exit Points must 
be activated to view it.

Change cover 
stitch type

Right-click Appliqué Tools > Auto Appliqué to adjust frame-out settings.

Use Reshape Tools > Reshape Object to reposition frame-out marker.

Frame-out zero 
point

Frame-out position 
marker
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 Click and drag the frame-out marker to the required position.

 If you are using Object Properties, the Frame Out panel lets you specify 
frame-out coordinates in relation to the top center of the design, which is the 
zero point.

Related topics
 Reshaping embroidery objects

Combining appliqué

When you come to combine more than one appliqué object in the one design, 
you will encounter issues to do with overlapping objects and appliqué 
sequencing. EmbroideryStudio provides tools to help.

Creating partial cover appliqué

Click and drag frame-out 
position marker

Use Appliqué Tools > Auto Appliqué to digitize partial cover appliqué objects.

Use Appliqué Tools > Partial Appliqué to create partial cover stitching for 
overlapping appliqué objects.

Use Appliqué > Remove Overlaps to remove underlying layer of stitching in 
overlapping objects using the selected object as a ‘cutter’. Right-click for settings.



Chapter 37   Appl iqué Digit iz ing 748

You can create appliqué objects with partial cover stitching without doubling-up 
borders with Partial Appliqué. In combination with the Remove Overlaps 
tool, you can remove all underlying stitching.

To create partial cover appliqué
 Digitize appliqué shapes with Auto Appliqué.

 If you only want to remove underlying cover stitching, select both objects 
and click Partial Appliqué. Cover stitches are generated in a clockwise 
direction between start and end points, leaving the rest of the boundary 
unstitched.

 If you want to remove all underlying stitching, first select the ‘cutter’ object 
and select Arrange > Remove Overlaps or right-click the tool.

Appliqué objects 
overlap

Underlaying cover 
stitching removed

Set the overlap to half the 
width of the cover stitching
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 Set the cutting overlap to half the width of the cover stitching – e.g. 2mm – 
and click OK.

 Select all objects and click Partial Appliqué to remove underlapping cover 
stitching.

 Remove any unwanted fragments and zoom in to check the overlaps.

Related topics
 Digitizing appliqué objects
 Removing underlying stitching

Resequencing appliqué components

Underlying stitching 
removed

Unwanted cover 
stitching removed

Cover stitching 
removed at overlaps

Use Appliqué Tools > Combine Appliqué Components to break apart multiple 
appliqué objects into component objects and combine and resequence them for 
efficient stitchout.
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The Combine Appliqué Components tool breaks multiple appliqué objects 
into their components – guide runs, cutting lines, tack stitches and cover 
stitches – and combines and resequences them for efficient stitchout. The end 
result is that the guide run of all appliqué objects is stitched in one pass, followed 
by the tack stitch and then cover stitch. A single frame-out movement occurs 
after guide run and tack stitch components.

To resequence appliqué components
1 Select a group of appliqué objects. The Combine Appliqué Components 

tool is activated.

2 Click Combine Appliqué Components. A message box warns that the 
appliqué objects will be broken apart and recommends that you save the 
design before proceeding.

3 Click OK to confirm. The selected appliqué objects are broken apart and same 
components – guide runs, cutting lines, tack stitches and cover stitches – 
combined and resequenced.

Outputting appliqué

Print a copy of appliqué patterns to use in cutting out fabric pieces. Alternatively, 
use Send to Appliqué Cutter to send appliqué shapes from a design file to a 
laser cutter. 

Each appliqué object 
digitized and stitched out 
in its entirety

Thread colors of each 
appliqué object recombined 
and resequenced for 
efficient stitchout
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Tip  CorelDRAW Graphics also lets you output objects as a vector file. This can 
then be downloaded to a laser cutter using CorelDRAW® Graphics Suite. For a 
full description of the CorelDRAW® Graphics Suite tools, refer to the electronic 
User Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the onscreen help available from the Help menu.

Printing appliqué patterns

Print appliqué patterns for use in cutting out fabric pieces. Each piece is 
numbered according to stitching sequence. One copy of placement outlines is 
printed at 100% scaling, with each outline separated for use in cutting the fabric.

To print an appliqué pattern
1 Create or open an appliqué design.

2 Select File > Print Preview and click the Options icon.

3 Select Appliqué Patterns report type.

Select appliqué
patterns report
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4 Set General options and click OK. Each appliqué pattern is numbered 
according to the stitching sequence. Stitch count and colors are displayed.

5 Click Print Now to output appliqué shapes to printer.

Related topics
 Customizing design reports

Cutting appliqué shapes

EmbroideryStudio can extract outlines from a design and send them to a laser 
cutter. This procedure is employed when the cutter is supported directly by a 
MS Windows® driver. Only shapes defining the actual appliqué fabric are sent. 

Note  Before you send appliqué shapes to a cutter, make sure it is set up on your 
system with the correct MS Windows® (printer) driver. Some cutters – e.g. 
Ioline – use a standard driver for HP-7475 plotters. Once the driver is installed 
in MS Windows®, there is no need for a separate hardware setup in 
EmbroideryStudio.

Use Standard > Send to Appliqué Cutter to send appliqué shapes from design file 
to laser cutter.
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To output appliqué shapes
1 Create or open an appliqué design.

2 Click Send to Appliqué Cutter or select File > Send to Appliqué Cutter.

3 From the Name list, select the appliqué cutter. For more information, refer to 
the User Manual of the particular cutter you are using.

4 Click Preview to preview the pattern. The Print Preview dialog opens 
showing every appliqué shape in the order of the stitching sequence.

5 Click Print Now to output appliqué shapes to cutter.

Click to preview
worksheet
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Adding cording

Cording refers to the technique of fixing a thick cord or yarn onto a fabric, 
usually for decorative purposes. Digitizers frequently want to see the cord line 
so that while they digitize, they don’t overstitch on sharp turns. The Cording 
function allows you to designate the run stitching which is to form the cording. 

Designing for cording

Cording designs are made up of running stitch outlines. Bear in mind:
 Create the design with run stitching to define the cording pattern.
 Run stitching may cross over itself or other objects in a continuous fashion.
 It is best to avoid long runs of overlapping cord.
 However, cording should be, as much as possible, continuous, as the cord 

cannot be trimmed by machine trimmer, only by hand.
 Consequently, any disconnected cording sections must be digitized in 

different colors so the machine will stop to allow for manual trimming.
 It is ok to have sharp corners but avoid extremes.
 It is possible to combine normal embroidery and cording in the same design.
 Conversely, it is possible to create cording-only designs with no other 

embroidery stitching.

Producing cording on the machine
To perform cording in combination with embroidery...
 Stitch data from the design file stops the machine as required. On the 

production worksheet, a ‘Stop’ is displayed with an additional color swatch 
indicating ‘CORD’. This prompts the machine operator to switch to cording.

 Choose an embroidery thread to stitch the cord to the fabric – either a 
matching color, contrasting color, or see-through thread.

 The machine stitches the design automatically, with the cord being fed 
through the cording device, in shapes defined by the stitch data.
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 At the end of a section of cording, the machine stops so that you can trim the 
cord.

 When Cording is applied, a Cord In/Out function is inserted into the stitch 
sequence. Some machines have a specific cording function which is output 
when saving to machine file – e.g. Barudan FDR-3 file format or Schiffli 
machines that support cording. For machines that don’t have an explicit 
cording function, the software outputs a Stop code. 

 During production, the needle penetrates either side of the cord, not through 
the center. As a consequence, the cord is pushed one way or the other.

 Relevant production information is also recorded on the design worksheet:
 Cord size and color
 Length of cord required
 The stop sequence shows when to start cording, trim cording, and end 

cording.

Creating cording designs

To create a cording design in EmbroideryStudio, follow this process:
 Digitize a cording design by digitizing a run with Cording turned on. Any 

suitable input method can be used together with Run stitch.

 Alternatively, select a run stitch object and apply the Cording effect. The 
cord is displayed as a graphic line. It takes the color of the run stitching. This 
allows designers to check technical correctness and better visualize a corded 
design look.

Use Outline Stitch Types > Run to place a row of single run stitches along a digitized 
line. Right-click for settings.

Use Effects > Cording to apply or execute cording effect to new or selected objects 
with run stitching.

Click View > Show Needle Points to show or hide the needle points in embroidery 
stitching.
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 Turn on needle points. Adjust display colors as necessary. 

 Avoid or minimize jumps/connectors between different cording objects in the 
design. Don’t use jumps for automatic connectors.

 Avoid or minimize cording crossing over itself.
 It is possible to use some fill stitch methods for cording if you set object 

properties for open density with no underlay. You can then break apart the 
object and apply Run together with Cording.

Tip  Some machines have a specific cording function which is output when 
saving to machine file – e.g. Barudan FDR-3 file format or Schiffli machines 
that support cording. For machines that don’t have an explicit cording 
function, the software outputs a Stop code. 
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Related topics
 Viewing design components
 Change display colors
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Chapter 38

Sequin Digitizing

Some embroidery machines are equipped with a sequin dispenser that drops 
sequins onto the garment as it stitches. EmbroideryStudio allows you to digitize 
sequined designs for compatible machines.

EmbroideryStudio also supports the creation of twin-sequin designs for 
twin-sequin-capable machines. There is also a dedicated tool for automatically 
converting sequin artwork in the form of a vector file to sequin runs.

Setting up sequin mode

Before you can use Sequin mode, you must select a machine format that 
supports it. You can then set up a dedicated sequin palette for your design from 
a list of predefined shapes and sizes. 

Barudan BEVY-Z1506C 
twin-sequin machine – devices 
are mounted on right and left 
sides of the heads
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Note  If you have selected Dahao as your machine type, Dahao twin-sequin DST 
file format is available on output. The Drop Sequin functions are inserted 
according to Dahao twin-sequin requirements.

Selecting a sequin-capable machine

Before you can use Sequin mode, you must select a suitable machine format 
via the Select Machine Format dialog. Sequin mode is supported in Schiffli, 
Tajima, Barudan, SWF, and ZSK embroidery machine formats. Support is also 
provided for the Tajima TBF and Barudan FDR-II twin-sequin machines to enable 
digitizing of twin-sequin designs. EmbroideryStudio also supports the Dahao 
controller used by many Chinese machines. One of these machine formats must 
be selected before twin-sequin runs can be created in EmbroideryStudio.

To select a sequin-capable machine
1 Select Design > Select Machine Format.

2 From the Available Machine Formats list, select a sequin-capable machine 
format – e.g. Schiffli, Tajima, Barudan, SWF, or ZSK.

3 Click OK. Sequin shapes are now available for selection from the Sequin 
Palette. If you have selected a twin-sequin-capable machine, sequin shapes 
and sizes are displayed in pairs.

Note  Different machines require different presets. Typical modifiable values 
include stitch and jump length, trim functions and color change functions. Use 

Select
sequin-capable
machine format

Click to adjust 
format

Twin-sequin palette Single-sequin palette
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the Machine Format Settings dialog to customize values if outputting to a 
specific machine format. 

Related topics
 Machine formats
 Exporting designs for machine
 Creating twin-sequin designs

Setting up sequin palettes

The Sequin Palette Editor lets you prepare a palette of sequins to use in your 
design. Set color and size for each sequin, as well as sequin hole size. Once set 
up, the palette is available for use from the Sequin Palette droplist.

To set up a sequin palette
1 Click the Sequin Palette Editor icon. Fields are arranged in tabular form so 

that parameters for each sequin type can be viewed at once.

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.

Use Sequin > Sequin Palette Editor to select shapes from a sequin library. 

Click to add 
sequin types
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2 Click the More button to create a new entry. Depending on the selected 
machine type – single or twin – a single or double column will be added to the 
Sequin Palette Editor. 

Tip  Click the X in the column header to remove any unwanted sequins.
3 Select a sequin type from the Sequin droplist.
4 Edit sequin colors and sizes as required. Size, Hole and Comment fields are 

all editable.

5 Repeat as many times as required and click OK. Sequin shapes are now 
available for selection from the Sequin Palette. If you have selected a 
twin-sequin-capable machine, sequin shapes and sizes are displayed in pairs.

Related topics
 Selecting a sequin-capable machine
 Creating twin-sequin designs

Visualizing sequin designs

Select sequin type 
from the droplist

Click to
select color

More colors available

Twin-sequin palette Single-sequin palette

Use View > Show Functions to toggle display of machine function symbols. 
Right-click for settings.

Use View > Show Stitches to toggle embroidery stitching display. Right-click for 
settings.
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Sequins can be viewed in TrueView™ or stitch view. 

Both sequins and fixing stitches appear in their selected colors and can be turned 
on or off via Show Functions and Show Stitches toggles.

When traveling through a sequin design, ‘undropped’ sequins appear in the 
‘unsewn’ color defined in the Background & Display Colors dialog. See 
Change display colors for details. 

Creating sequin runs

EmbroideryStudio provides tools to create a string of sequins along a digitized 
line according to preset spacings or as marked by the digitizer. You can preset 
sequin type or change it at any stage. Similarly, you can preset fixing stitches or 
change them after digitizing.

Tip  The Show Repeats function displays repeating designs, including sequins, 
in both TrueView and stitch view. You can view a design, even while digitizing, 
with any number of repeats. See also Viewing design repeats.

Digitizing sequin runs

Use Sequin > Sequin Run Auto to create a string of sequins along a digitized line 
according to current settings.

Use Sequin > Sequin Run Manual to manually digitize sequin-drops along a 
digitized line.
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With Sequin Run you have the option of digitizing individual sequin drops or 
letting the system automatically generate them for you. Digitize lines as you 
would motif runs.

To digitize a sequin run
1 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. 
2 Select the sequin type you want from the Sequin Palette.
 If you have selected a twin-sequin-capable machine, sequin shapes and 

sizes are displayed in pairs.

 Otherwise you have access to single sequins.

3 Click the Sequin Run Auto icon.
4 Digitize the sequin by entering reference points – left-click for corner points, 

right-click for curve points.

5 Press Enter to complete. Sequin drops are automatically generated along 
with their fixing stitches. Spacings can be individually adjusted.

6 To add details or create special spacings, click the Sequin Run Manual icon.

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.

Select sequin pair

Select single sequin

Press Enter

Digitize outline – left-click 
corner points, right-click 
curve points
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7 Digitize individual sequins – again, left-click for corner points, right-click for 
curve points. Connecting and fixing stitches are automatically generated.

Tip  Digitizers sometimes want to generate a sequin run and overlay it with 
a plain run so that sequins are more securely fixed. Another reason for 
backtracking is to avoid jump stitches between objects. The 
Backtrack/Repeat tool is enabled for sequin-run objects. When applied, 
EmbroideryStudio generates manual stitches but leaves other functions 
unaffected.

Related topics
 Selecting a sequin-capable machine
 Creating twin-sequin designs
 Reshaping & editing sequin runs
 Changing sequins & fixing stitches
 Reinforcing outlines
 Adjusting entry/exit points

Changing sequins & fixing stitches

You can select sequins before or after digitizing. Similarly, you can preset fixing 
stitches or change them at any stage.

Press Enter

Digitize individual sequins – 
left-click corner points, 
right-click curve points

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.
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To change sequins and fixing stitches
 To change sequins, select the object and select a different sequin type from 

the Sequin Palette on the Sequin toolbar.

 To change fixing stitches, double-click the object.

 Click the Chooser button in the Fixing field. The docker expands to reveal a 
library containing all the available fixing types.

 Select a fixing stitch type.

Click to open 
Fixing Type 
Chooser

Click to change 
fixing stitch

Choose method for 
setting fixing size

 Fixing stitch
preview

Select fixing
stitch type
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 Press Enter or click Apply.

 To adjust the fixing stitch size, select a method:

 If you have chosen an eccentric sequin type such as ‘ellipse’, fixing stitches 
automatically adapt to fit.

 If you have chosen the manual option, specify a value in the Size field. Size 
is measured from the center of the sequin. Enter a value from 2.50mm to 
30.00mm. 

 If you have chosen automatic matching, specify a margin for the fixing stitch 
in the Margin field. Enter a value from 0.20mm to 2.00mm. This ensures that 
the fixing stitch does not punch too close to the sequin. 

Tip  Sequin Run has potential as a decorative stitch in its own right. For this 
purpose you can select None in the Sequin Palette. This option is best used 
with the Sequin Drop Direction set to Any.

Related topics
 Setting drop-stitch direction

Method Purpose

Match sequin Sets a margin around the sequin so that fixing stitches don’t punch too 
close.

Set manually Allows you to set fixing stitch size regardless of sequin size. The Size 
field is enabled when this option is selected.

Sequin size: 7 mm
Auto margin: 0.50 mm

Sequin size: 7 mm
Manual size: 5.00 mm

Sequin size: 7 mm
Manual size: 10.00 mm
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Adjusting sequin spacing & fixing orientation

You can change sequin spacing at any stage. If you use the manual method, you 
define spacings between sequin-drops with every click you make. If you use the 
automatic method, sequin-drops are calculated according to current settings. 
Fixing stitch orientation can take one of four preset directions – left/right, 
up/down.

To adjust sequin spacing and fixing orientation
1 Select a sequin-run object – manual or automatic.

2 Double-click the object to access object properties.

3 In the Spacing field, enter a nominal spacing. Spacing is measured from the 
center of one sequin to the center of the next.
Enter a value from 1.5mm to 200mm. EmbroideryStudio automatically 
calculates the minimum spacing.

Note  The field is only enabled only if ‘Base’ is selected in the Layer field of 
the same column and the Sequin Run Auto tool selected.

Manual sequin 
run

Automatic 
sequin run

Select positioning 
method

Enter nominal 
spacing
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4 Select a spacing method using the Positioning droplist:

Tip  If you want irregular sequin spacings, digitize with the Sequin Run 
Manual tool. Fine-tune with the Sequin Edit tool.

5 To adjust fixing stitch orientation, place the first stroke in one of the preset 
directions – left/right, up/down:

Related topics
 Reshaping & editing sequin runs

Setting drop-stitch direction

There is an option to ensure that the initial fixing stitch before the sequin drop 
is placed opposite the feeding direction, as recommended by the machine 
manufacturer. Otherwise, the sequin may be deflected by the thread. If the 
needle then misses the center of the sequin because of incorrect placement, the 

Option Purpose

Exact Uses specified spacing. This may result in uneven spacing at the 
end of the path.

Expand to fit Increases nominal spacing to include a sequin at the end of the 
path.

Contract to fit Decreases nominal spacing to include a sequin at the end of the 
path.

Manual Turns the sequin run into a manual object. Performing manual edits 
to sequin-run objects automatically deselects all options. If you 
reset to Exact, Contract to fit, or Expand to fit, all manual edits are 
lost. See also Reshaping & editing sequin runs.

Exact Expand to fit Contract to fit

Choose fixing 
stitch orientation

Orientation: Left Orientation: Right

Orientation: Vertical 
(Up)

Orientation: Vertical 
(Down)
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embroidery material, needle or needle plates may be damaged. In multihead 
machines, sequins are fed from the front or ‘south’ which means that the initial 
fixing stitch or ‘drop stitch’ should be placed on the ‘north’ side (the default). In 
Schiffli machines, the opposite is the case.

To set the drop-stitch direction
1 Select a sequin-run object and double-click to access object properties.

2 Select the drop-stitch direction to ensure that the initial fixing stitch is 
opposite the feeding direction:

Caution  With the Any option, direction is not important. This option 
generates the least number of fixing stitches but may not be suitable for your 
sequin device. Check your machine documentation.

Drop-stitch 
direction

Feeding direction

From north Front or ‘south’ – which is the case in multihead machines.

From south The top or ‘north’ – which is the case in Schiffli machines.

Feeding directionDrop-stitch direction

Select to prevent 
multiple penetrations

Select drop-stitch 
direction

Drop direction ‘From 
South’: initial fixing stitch 
always placed below, and 
sequin fed from ‘north’

Drop direction ‘From
North’: initial fixing stitch

always placed above, and
sequin fed from ‘south’
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3 Enter a Max Angle to specify an angular range within which drop-stitch will 
fall.
You can set the value for either north or south fixing stitches. The default is 
90° but this can be increased or decreased depending on the capabilities of 
your machine.

4 Select the Prevent multiple penetrations option as required.
This option is used to minimize penetrations at the same point, and to 
generate Schiffli-compatible fixing stitching. If you select the Schiffli 
template, the option is ‘on’ by default. When set to ‘off’, some fixing stitches 
will have multiple penetrations at the same point, both at the sequin center 
and outer edge.

5 Select the Closest point join option as required.
By default, this option is off, meaning that the system connects the exit leg 
of the fixing stitch motif, wherever it happens to be, to the entry leg of the 
next fixing stitch motif, again wherever it happens to be. That is, unless the 
connector exceeds the maximum sequin stitch. Choose the Closest point 
join option if you want to always connect fixing stitch motifs from the leg 
closest to the nearest leg of the next fixing stitch motif.

Creating sequin fills

The Sequin Fill feature provides a means of filling complex shapes with sequins 
arranged in columns. The fill can also include a border, with or without a margin. 

Set maximum allowable 
angle for placement of 
fixing stitch

Drop stitch direction 
set to North or South

Prevent Multiple Penetrations on Prevent Multiple Penetrations off
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This can be made from the same or a different sequin and is a property of the 
object.

Sequin fills are tied together by run stitches and travel runs. Travels are placed 
along the object outline. Sequins centers never fall outside the object outline. 
Sequin fixing stitches, however, can lie outside the outline depending on current 
settings.

Tip  The Show Repeats function displays repeating designs, including sequins, 
in both TrueView and stitch view. You can view a design, even while digitizing, 
with any number of repeats. See also Viewing design repeats.

Digitizing sequin fills

Digitizing sequin-fill objects is essentially the same as digitizing complex fill 
objects.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.
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Double-clicking a sequin-fill object will invoke these Object Properties.

Controls available on the Fills > Sequin Column Fill tab for patterns and fixing 
stitches are summarized below.

Control Description

Sequin line 
settings

Use these settings to control the overall layout of the fill grid, including 
angle, sequin spacings, and offsets within the grid. See Adjusting sequin 
lines for details.

Fill margin Include a fill margin or not as required. No sequin will have its center 
placed outside the fill margin. Usually used with a border but not 
necessarily. See Adjusting sequin lines for details.

Add border Sequin fills can include a border, with or without a margin. The border is a 
property of the object. See Adding sequin borders for details.

Select Determines what patterns are displayed:
• Sequin Fill: displays the fill pattern
• Sequin Run: displays the border pattern.
All other controls work the same as for Sequin Run. See Creating sequin 
runs for details.

Sequin line settings
control overall layout of

sequin fills

Control fill margin with or
without border

Add a border as
preferred

Control sequin settings
for both fills and borders

Control fixings for both
fills and borders
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Fixing stitches are selected in the same way as for sequin runs. For sequin fills, 
we recommend the simplest fixing stitch available – C01-1. See also Changing 
sequins & fixing stitches.

If you have a twin-sequin capable machine, use the Pattern control to create 
patterned fills. See Creating twin-sequin run patterns for details.

Related topics
 Creating free-form shapes
 Creating twin-sequin designs

Adding sequin borders

Sequin fills can include a border, with or without a margin. The border is a 
property of the object. If a twin-sequin capable machine is selected, the border 
and fill can differ. They can be comprised of single sequins or sequin patterns.

Use the simplest 
fixing stitch
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To add a sequin border
 Select a sequin-fill object and double-click to access object properties.

 Tick the Add Border checkbox and select Sequin Border from the droplist.
 Adjust sequin type as shown. This can be the same or different to the sequin 

fill if you have a twin-sequin capable machine.

 Adjust the fill margin and border spacing as shown.

 Adjust border fixing stitches as for sequin runs. This can be the same or 
different to sequin fills.

Enter nominal
spacing

Click to change
fixing stitch

Adjust fixing stitch size
manually or automatically

Select Sequin Border

Tick border
option

Adjust fill margin

Sequin fill with 
same type border

Sequin fill with 
different type border
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 Set sequin border fixing stitch direction as shown.

Related topics
 Creating twin-sequin run patterns

Adjusting sequin lines

Use sequin line settings to control the overall layout of the fill grid, including 
angle, sequin spacings, and offsets within the grid. 

 Adjust Angle as shown:

Fixing stitch direction: clockwise Fixing stitch direction: counter clockwise

Adjust fixing
stitch direction

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.

Set margin

Adjust sequin
lines

Independent control of 
column and row spacings

Angle: 45° Angle: 180°
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 Adjust Spacing as shown. This spacing setting controls column spacing, not 
sequin spacing.

 Adjust columns and rows as shown. Sequin Fill provides independent control 
of column and row spacings. Set the nominal spacing in the Spacing field. 
Choose whether you want the fill to fit the grid exactly or to be adjusted 
line-by-line to fit the shape. You have the option of expanding or contracting 
spacings in either or both rows and columns. Each line is adjusted separately. 
The aim is to make sequins follow to the edge of the shape for all lines in the 
fill. This is less important if you add a border to the fill.

 Adjust Offset as shown:

Spacing: 3 mm Spacing: 5 mm

Exact grid 
spacing

Spacing adjusted 
to fit

Offset: 0 mm Offset: 2.5 mm



EmbroideryStudio e4 User Manual 777

 Adjust Direction setting as shown. Sequin lines will run either left-to-right 
(left button) or right-to-left (right button). 

 Activate Add Fill Margin and adjust margin setting as shown. No sequin will 
have its center placed outside the fill margin.

Smoothing edges in sequin fills

Sequin Fill provides independent control of column and row spacings. Set the 
nominal spacing in the Spacing field. Choose whether you want the fill to fit the 
grid exactly or to be adjusted line-by-line to fit the shape. You have the option 
of expanding or contracting spacings in either or both rows and columns. Each 

Layout: 
left-to-right

Layout: right-to-left

Sequin fill with fill 
margin

Sequin fill with hole 
and fill margin

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.
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line is adjusted separately. The aim is to make sequins follow to the edge of the 
shape for all lines in the fill. This is less important if you add a border to the fill.

Adjusting patterns & fixing orientation

If you have a twin-sequin capable machine, you can use the Pattern control to 
create patterned borders and/or fills. Use it also to control sequin spacing 
independently of line spacing. If you use the manual method, you define 
spacings between sequin-drops with every click you make. If you use the 
automatic method, sequin-drops are calculated according to current settings. 
Fixing stitch orientation can take one of four preset directions – left/right, 
up/down. Most controls work the same as for Sequin Run.

Independent control of 
column and row spacings

Exact grid 
spacing

Spacing adjusted 
to fit
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To adjust patterns and fixing orientation
1 Select a sequin-fill object and double-click to access object properties.

2 In the Patterns pane, adjust spacings for fill and/or border as required.
Spacing is measured from the center of one sequin stack to the center of the 
next.

Note  When the field is enabled, you can enter a value from 1.5mm to 
200mm, but EmbroideryStudio automatically calculates the minimum spacing 
allowed. 

3 To adjust fixing stitch orientation, place the first stroke in one of the preset 
directions – left/right, up/down:

Set up sequin
patterns for fills
and/or borders

Adjust sequin
fixing stitching

Enter nominal 
spacing

Fill spacing: 4
Border spacing: 6

Fill spacing: 5.5
Border spacing: 4.5

Fill spacing: 7
Border spacing: 3

Choose fixing 
stitch orientation

Orientation: vertical (up) Orientation: vertical (down)
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Tip  If you have a twin-sequin capable machine, you can use the Patterns 
control to create patterned fills.

Related topics
 Creating twin-sequin designs

Creating twin-sequin designs

EmbroideryStudio supports the creation of twin-sequin designs for 
twin-sequin-capable machines. Twin-sequin mode has several advantages over 
the standard single-sequin mode. It allows you to create and visualize 
predefined patterns of sequin runs comprising pairs of sequins of different size, 
color, and shape. This in turn allows you to create twin-sequin designs and 
output machine files to twin-sequin-capable machines.

Tip  Twin-sequin mode also allows you to convert vector objects to twin-sequin 
outlines. See also Converting sequin artwork.

Setting up twin-sequin palettes

Use Sequin > Sequin Palette Editor to select shapes from a sequin library. 
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The Sequin Palette Editor lets you prepare a palette of sequins to use in your 
design. Once set up, the palette is available for use from the Sequin Palette 
droplist.

To set up a twin-sequin palette
1 Select a machine format that supports twin-sequin mode via the Select 

Machine Format dialog.

2 Open the Sequin Palette Editor and create the palette you want to use. 
Default sequin pairs appear in Columns #1 and #2. The only difference when 
you set up a palette in twin-sequin mode is that you set up sequin pairs rather 
than single sequins.

 Sequin shapes are now available for selection from the Sequin Palette. 
Sequin shapes and sizes are displayed in pairs.

Related topics
 Selecting a sequin-capable machine

Choosing twin-sequin patterns

Select
twin-sequin-capable

machine format

Click to add 
sequin pairs

Twin sequin pairs
added by default

Twin-sequin palette

Use Sequin > Sequin Palette Editor to select shapes from a sequin library.

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set properties for the current design.
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EmbroideryStudio allows you to select twin-sequin patterns from a pattern 
library. These can be applied to existing twin-sequin objects or newly created 
objects.

To choose a twin-sequin pattern
1 Open Object Properties and go to the Outlines > Sequin Run tab. A 

Pattern table allows you to set a pattern of sequin drops for the currently 
selected pair.

2 Click the Patterns button to select a preset pattern from the library. The 
Sequin Pattern dialog opens.

3 Choose from the Sequin Pattern droplist. A preview is displayed.
4 Click Apply Pattern to make the selected pattern current. The pattern is also 

immediately applied to any selected sequin-run objects.

PeackockPattern3

Alternate Twin Overlap

Group of 3 + Single

Twin Lace

PeackockPattern1

PeackockPattern2

Select preset
patterns from a

pattern library

Click to select pattern
from droplist

Preview of
selected pattern

Make selected 
pattern current
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5 Using the Sequin Run Auto or Sequin Run Manual tools, create your 
twin-sequin runs.

6 Select another sequin pair and continue digitizing. The same pattern will 
apply until you change it.

Related topics
 Selecting a sequin-capable machine
 Setting up sequin mode
 Digitizing sequin runs

Adjusting twin-sequin runs

Change patterns applying to twin-sequin runs like any other object properties. 
You can apply current properties to selected objects, apply other sequin pairs, 
and/or different patterns. You can even define you own patterns.

To adjust twin-sequin runs
 Create or select a twin sequin-run object.

Tip  You can convert a normal run to sequin run by selecting and clicking the 
Sequin Run Auto tool.

Use Sequin > Sequin Run Auto to create a string of sequins along a digitized line 
according to current settings.

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.
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 To change sequin shapes, select another pair from the Sequin Palette.

 To change twin-sequin patterns, double-click the object to open Object 
Properties.

 Click the Patterns button.

 Choose from the Sequin Pattern droplist. A preview is displayed.
 Click Apply Pattern to apply the selected pattern.

The pattern is immediately applied to the selected sequin-run object.

Select a pattern

Click to select
pattern from

droplist

Preview of
selected pattern

Click to apply 
selected 
sequin pair

Select alternative
sequin pair
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 Optionally, select a different sequin pair from the Preview Panel droplist and 
click Apply Sequin. The selected sequin pair, using the same pattern, is 
applied.

 Optionally, use the Pattern table in the Object Properties docker to define 
your own twin-sequin pattern. This allows you to set a pattern of sequin drops 
for the currently selected sequin pair.

 Optionally, make a selected object’s properties current, including twin-sequin 
patterns, and apply them to existing objects.

Related topics
 Digitizing sequin runs
 Creating twin-sequin designs
 Copying properties

Creating twin-sequin run patterns

EmbroideryStudio lets you create custom twin-sequin run patterns and, 
optionally, save them to a pattern library for later use.

To create a twin-sequin run pattern
1 Select a machine format that supports twin-sequin mode via the Select 

Machine Format dialog.
2 Create a twin-sequin-run object with the Sequin Run Auto tool or Sequin 

Run Manual tool.

Change sequin pairs

Copy and paste 
twin-sequin patterns from 
one object to another

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set properties for the current design.
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Alternatively, select an existing twin-sequin-run object so that you can 
preview your pattern as you create it.

3 Select the pair you want to use for your twin-sequin pattern.

4 Open Object Properties.
By default, the left sequin of the topmost pair in the sequin palette list is 
displayed in column #1 of the table.

5 Add more sequins to the pattern via the Add Sequin (+) button.
A new column is added to the table. Delete any unwanted sequins in the 
pattern by clicking the X at the right of the column header.

6 Select a sequin from the droplist.
7 In the Layer field, specify whether the sequin is to be stacked (‘on top’) or 

to form a new element (‘base’).

Select sequin pair

Add sequins to pattern

Click to change 
fixing stitch

Click to change sequin

Define parameters
for each sequin in

the pattern

Set sequin 
placement – ‘base’ 
or ‘on top’
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Tip  Click the Apply button or press Enter to preview your settings with the 
selected twin-sequin-run object.

8 In the Spacing field, enter a nominal spacing.
Spacing is measured from the center of one sequin to the center of the next.

9 In the Fixing field, select the type of fixing you want.
To adjust fixing stitch orientation, place the first stroke in one of the preset 
directions – left/right, up/down.

10 When satisfied with the twin-sequin run pattern you have defined, click the 
Save icon next to the Patterns button.

11 Enter a name for the new pattern and click OK. The pattern is now available 
for use in the Sequin Pattern dialog.

Related topics
 Selecting a sequin-capable machine
 Digitizing sequin runs
 Changing sequins & fixing stitches
 Adjusting sequin spacing & fixing orientation
 Choosing twin-sequin patterns

Creating twin-sequin fill patterns

EmbroideryStudio lets you create custom twin-sequin fill patterns. The process 
is essentially the same as creating a custom twin-sequin run pattern, except you 
can’t save it for later use.

Enter nominal spacing

Adjust fixing stitch

Enter pattern
name

My Pattern

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set properties for the current design.
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Open Object Properties and define a fill pattern as you would for a sequin run.

Change sequin pairs as desired.

Pattern stamp re-coloring of twin-sequin fills

Sequin Fill can be used in combination with Carving Stamp to digitize sequin 
fills with predefined twin sequin assignments. The stamp pattern takes the color 
of the other sequin in the currently selected pair.

Define fill 
pattern

Select sequin pair

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.

Select sequin pair
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Related topics
 Creating patterns with carving stamps

Converting objects to sequins

Most objects in EmbroideryStudio are inter-convertible. Open and closed sequin 
objects are no exception. Any open object – Run, Stemstitch, Motif Run, 
Freehand, Column C, Vector – can be quickly converted to sequin run. Similarly, 
any closed object – Column A/B, Complex Turning, or Complex – can be 
converted to sequin fill. EmbroideryStudio also provides a dedicated tool for 
automatically converting sequin artwork in the form of a vector file to sequin 
runs. 

Converting embroidery objects to sequins

Convert any open object – Run, Stemstitch, Motif Run, Freehand, Column C, 
Vector – to sequin run.

Use Sequin > Sequin Run Auto to create a string of sequins along a digitized line 
according to current settings.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.
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Right-click and select Convert > Convert to Sequin Run. Alternatively, click 
the Sequin Run Auto icon.

Similarly, convert any closed object – Column A/B, Complex Turning, or Complex 
– to sequin fill.

Right-click and select Convert > Convert to Sequin Fill. Or click the Sequin 
Fill icon.

Converting sequin artwork

Frequently, artwork for sequin designs is independently created by a specialist 
designer and supplied to the embroidery digitizer as a vector file. The Vectors 
to Sequins tool is available for just this purpose. A sequin run is automatically 
created from a set of vector objects representing sequins. Fixing stitches are 
generated automatically according to current settings. If you are digitizing 
twin-sequin runs, EmbroideryStudio will generate sequin drops according to the 
currently selected sequin run pattern.

Use Sequin > Vectors to Sequins to create a sequin run from a set of sequin vector 
objects selected by intersecting line.
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To convert sequin artwork
1 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. 
2 Insert the sequin artwork into the design.

Properly designed artwork will contain vector objects centered on the exact 
locations required for sequins in the design.

3 Select the sequin type you want to use from the droplist in the Sequin 
Palette.

4 Select the Vectors to Sequins icon.
5 Click the sequin graphic which will start the sequin run.

6 Digitize a line connecting all sequins to be included in the sequin run.
The line only needs to touch the sequin object somewhere within its 
boundary. Left-click for corner points, right-click for curve points.

7 Press Enter.
A sequin run is generated along a curve that passes through the center of 
each sequin graphic with sequin objects positioned at these centers. Current 
properties are applied and the object is set to ‘manual’ by default. The 
generated curve contains a reshape node at each sequin position.

Select single sequin

Digitize connecting
line passing through

all sequin graphics

Sequin Run
automatically generated

Reshape nodes generated
at each sequin drop
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Tip  If you are running twin-sequin mode and preset a sequin pattern in 
Object Properties, this pattern is applied to the converted sequin objects 
while sequin spacing is preserved as per the artwork.

Related topics
 Choosing twin-sequin patterns
 Selecting a sequin-capable machine
 Creating twin-sequin designs

Modifying sequin designs

Sequin-fill objects can be reshaped like any other embroidery object. Adjustable 
column layout parameters include column spacing, angle, and offset.

Reshaping & editing sequin runs

You have complete control over scaling and reshaping sequin-run objects. Scale 
and reshape sequin run lines, as well as remove or add individual sequins. You 

Pattern applied

Use Select Tools > Select Object to resize objects using selection handles.

Use Reshape Tools > Reshape Object to reshape selected sequin-run objects.

Use Sequin > Sequin Edit to fine-tune placement of individual sequins.
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can also manually fine-tune sequin spacings. You can even edit individual fixing 
stitches.

Note  Performing manual edits to sequin-run objects automatically deselects all 
options. If you reset to Exact, Contract to fit, or Expand to fit, all manual 
edits are lost.

To reshape and edit a sequin run
 Scale sequin-run objects by clicking and dragging selection handles, or by 

adjusting general properties. 
 If the object is created with the Sequin Run Auto tool, the sequin drops 

are automatically recalculated.

 If the object is created with the Sequin Run Manual tool, the original 
number of sequin drops is preserved.

 Reshape sequin run lines with the Reshape tool. Add reshape nodes by left- 
or right-clicking the outline.

Sequin drops
regenerated according

to current settings

Original number of
sequin drops

preserved
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 Fine-tune individual sequin spacings with the Sequin Edit tool – 
click-and-drag a diamond control point. Hold down Shift or Ctrl keys to select 
a range or multiple control points. 

 Delete selected sequins by pressing Delete.

 Add sequins by holding down the Alt key and clicking the sequin run line.
If you are running twin-sequin mode, you have the option of selecting 
alternative sequins from the droplist.

 If you are running twin-sequin mode, right-click a diamond control point while 
modifying a particular sequin. Options include: removing the sequin, 
replacing it, adding another sequin on top or underneath it:

Related topics
 Scaling objects
 Reshaping embroidery objects

Click-and-drag
spacing handle

Click a diamond control 
point and press Delete

Hold down Alt key
and click Select a sequin type 

from the popup menu

Replace sequin with 
selection from menu
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Reshaping & editing sequin fills

Either by means of object properties or the Reshape Object tool, you can 
control the overall shape of sequin fills as well as their layout. You can also set 
entry and exit points to avoid excessive needle penetrations.

To reshape and edit a sequin fill
 Select a sequin-fill object and click the Reshape icon.

 Adjust overall shape like any embroidery object.

Use Reshape Tools > Reshape Object to reshape selected objects by means of 
control points.

Use Sequin > Sequin Edit to fine-tune placement of individual sequins.

Use reshape nodes 
to reshape outline
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 Use the three central control points to adjust sequin line settings interactively. 
These control Direction Angle, Spacing, and Offset settings. Pattern 
spacing is also influenced.

Pattern spacing is also controlled numerically via the Patterns panel.

 Adjustments can cause needle penetrations to occur within sequins. Affected 
sequins are highlighted in pink. Adjust layout and/or entry/exit points to 
minimize unwanted needle penetrations.

 Fine-tune individual sequin spacings with the Sequin Edit tool – 
click-and-drag a diamond control point.

Adjust sequin line settings 
interactively

Needle 
penetrations

Line Spacing: 3mm
Offset: 1mm

Line Spacing: 5mm
Offset: 4mm

Line Angle: 125°
Pattern Spacing: 8mm

Set entry and exit points to 
minimize excessive 
needle penetrations
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 Holes can be digitized in sequin-fill objects in the same way as any free shape.

Related topics
 Reshaping embroidery objects
 Adjusting patterns & fixing orientation
 Reshaping & editing sequin runs
 Creating free-form shapes

Creating custom sequins

EmbroideryStudio supports sequin shapes with offset holes. Such sequin shapes 
can be utilized for flipping sequins on the fabric to form two different sequin fill 
patterns. 

Custom sequin shapes & hole positions
The software allows you to define your own shapes with their own hole position 
and size. Create you own sequin shapes with vectors. The Ring tool is useful for 
this.

Sequin fills can 
contain holes

Position hole as 
required
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Position the hole. Size the sequin to a nominal size. Select and choose Object 
> Create Sequin Shape. Overlap allowance is automatically adjusted to 
accommodate different hole positions.

Saving custom sequins involves the same steps as saving custom motifs. Choose 
a sequin set or create a new one. Give your sequin a name and click OK to save. 
The custom sequin is available from the sequin droplist for use in sequin 
palettes.

Custom sequin fixings
Similarly, there is a capability to define custom fixing stitches to support 
multi-head sequin devices. Some limitations might exist for older more 
complicated sequin devices. Access the dialog via the Object menu.

Benefits of user-defined sequin fixings include:
 Create multiple layers of stitching for decorative effects, sometimes in 

different thread colors (Barudan).
 Reduce stitch counts in large sequin designs.
 Accommodate specific fixing requirements.
 Accommodate new capabilities – e.g. offset holes.

Save your own
sequin shapes

Follow
instructions

Name your
fixing stitch

Set angle to define
snap lines

Custom fixing stitch
added to library
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Tip  If you have chosen an eccentric sequin type such as ‘ellipse’, fixing stitches 
automatically adapt to fit.

Related topics
 Digitizing stars & rings

Digitizing individual sequin drops

If you require precise control over the positioning and encoding of your sequin 
drops, EmbroideryStudio provides manual techniques for this purpose.

Digitize sequin drops with fixings

The Manual Sequin input method allows you individual 
control over sequin placement and fixing stitches. 
Create decorative outlines and patterns manually using 
sequins from the selection list. To add a sequin to the 
stitching sequence, simply drop it onto the design and 
secure it with manual stitches. Manual sequin stitching 
is a difficult digitizing skill to master and you need to 
plan the stitching sequence carefully in order to 
minimize unnecessary stitches. Experiment with your 
machine and stitch width and spacing settings to achieve 
the desired result.

Note  Sequin mode is supported in Schiffli, Tajima, 
Barudan and ZSK embroidery machine formats. Before 
you can use Sequin mode, you must select a machine 
format that supports it. Similarly, before you can use 
Twin-Sequin mode, you must select a suitable machine 
format. See Selecting a sequin-capable machine for details. See Creating 
twin-sequin designs for details.

Use Sequin > Manual Sequin to digitize individual sequins.

Use Sequin > Left Sequin to switch to left sequin when digitizing twin-sequin 
designs.

Use Sequin > Right Sequin to switch to right sequin when digitizing twin-sequin 
designs.
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To digitize a sequin drop with fixing stitches
 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. See Selecting a sequin-capable machine for details.
 Click the Manual Sequin icon.
 If you have activated Twin-Sequin mode, sequin shapes are displayed in 

pairs. Left and Right Sequin icons are both available.

 Otherwise, you will have access to single sequins. Only the Left icon is 
available.

 Left-click to begin your manual sequin run. It must start with at least one 
stitch.

 Right-click to drop a sequin. A sequin outline appears.
 Left-click to digitize fixing stitches around the sequin to secure it.

Three stitches in the shape of a ‘Y’ are generally used. The needle points of 
each stitch must be placed precisely to ensure that sequins are not pierced 
by the needle when stitching.

Tip  Zoom in for more accurate digitizing.

Select sequin pair

Select sequin to use

Left-click to digitize fixing stitches

Right-click to ‘drop’ sequin

Continue digitizing – right-click for 
sequin drops, left-click for fixing 
stitches
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 If you have activated Twin-Sequin mode, click the Right Sequin button to 
switch sequins. Alternatively, press the Tab key to switch between left and 
right sequins while digitizing.

 Continue digitizing manually in the same way – right-click to add a sequin, 
left-click to digitize fixing stitches. Press Enter to finish.

Related topics
 Selecting a sequin-capable machine
 Setting up sequin mode

Digitize sequin drops while traveling

In preference to the Manual Sequin tool, some users prefer to flesh out a 
design using Run or Triple Run stitching and then travel through it, dropping 
sequins manually as and where required. This technique can be used with single 
or twin sequins.

To digitize sequin drops while traveling
 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. See Selecting a sequin-capable machine for details.

Use Traditional Digitizing > Run to place a row of single run stitches along a 
digitized line. Right-click for settings.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 stitch at a 
time. Left/right click.

Use Sequin > Drop Sequin to drop a sequin at the current needle position. For 
twin-sequin machines, left-click to drop a left-sequin, right-click to drop a 
right-sequin.

Use Sequin > Clear Function to remove any sequin functions from the current 
needle position.

Use Traditional Digitizing > Backtrack to reinforce an outline, stitching it in the 
reverse direction to the original.
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 Set a fixed run length to suit the type of sequin/s you are using.

 Choose a digitizing method to create the design or pattern you want.
 Press the Home button and travel through the design using arrow keys or 

Travel tools.
 Press the ‘hotkey’ 5 to drop a sequin at a particular stitch. Alternatively, click 

the Drop Sequin button.

 If you are using twin sequins, press the hotkey 6 to drop the other sequin. 
Alternatively, right-click the Drop Sequin button.

 If you want to delete a sequin drop, travel to the location and press 4 to 
delete the sequin from current stitch. Alternatively, click the Clear Sequin 
button.

Tip  If you are using Triple Run, the repeat stitch will tack down your sequin 
drop. If you are using Single Run, you can use the Backtrack tool to tack 
down the sequin drops.

Insert sequin drop functions

You can insert machine functions manually by means of the Insert Function 
dialog. Depending on your machine’s requirements, you will either add the 
function to the current stitch, or insert it on an empty stitch or empty jump.

To insert sequin drop functions
1 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. See Selecting a sequin-capable machine for details.
2 Travel to the position in the design where you want to insert a machine 

function.

Set run length to suit 
sequins

Press hotkey to
‘drop’ a sequin
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3 Select Function > Insert Function. The Insert Function dialog opens.

Tip  Depending on your machine, you may need to insert additional empty 
stitches or empty jumps before or after the selected function. For example, 
before a particular Stop function, you may want to insert a number of empty 
jumps. See your machine manual for details.

4 From the Available Functions list, select the Drop Sequin function.
5 Choose the insertion method – Insert on Empty Stitch or Add to Current 

Stitch. 
6 To insert additional empty stitches or empty jumps, select one or other in the 

Component field and click Insert Before or Insert After as required. 
7 When your Drop Sequin function has been correctly defined, click OK. The 

Twin Device - Select Sequin dialog is displayed.

8 Click Left or Right buttons to activate left or right sequins on the sequin 
dispenser. The Sequin Drop function, together with any additional empty 
stitches or jumps, is added at the current needle position.

Tip  The Stitch List provides an alternative means for inserting machine 
functions manually. 

Related topics
 Inserting machine functions manually
 Travel through designs
 Selecting & editing stitches

Select Drop
Sequin function

Choose left or right 
sequin on sequin 
dispenser
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Chapter 39

Bling Digitizing

Bling refers to decorative objects placed on garments or templates, either on 
their own or in combination with other design elements. Bling is supplied in 
varying sizes, shapes, colors and materials. It goes under names such as 
diamante, rhinestones, eyelets, ribbons, charms, crystals, glitz, nailheads, 
studs, etc. EmbroideryStudio lets you add bling to multi-decoration designs with 
the Bling toolset. This allows you to create and visualize bling embellishments 
in combination with other decorative elements.

Bling production processes

The Bling feature allows digitizers to create patterns of bling runs or fills with 
editing capabilities similar to those of the Sequin toolset. The single biggest 
difference between Sequin and Bling is that individual rhinestones are not 
allowed to overlap or be too close together. Another difference is that there is no 
stitching associated with bling. 
Bling, rhinestones, crystals, and glitz are interchangeable terms referring to 
decorative objects placed on garments or templates. They are supplied in 
various sizes, shapes, colors and materials. 

There are two basic processes for creating bling designs:
 Hot-fix template production
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 Direct-to-garment production

Hot-fix template production
Hot-fix templates can be produced in two ways:
 Bling transfer: In a semi-automatic process, bling is placed directly onto 

transfer tape (or sheet) by machine. Examples are IOline CrystalPress and 
CAMS machines. The bling design is ready for heat transfer to the final 
product – e.g. a T-shirt.

 Bling template: This is the design layout on which rhinestones are initially 
placed prior to transfer. The template is created by cutters or engravers. 
Rhinestones are placed onto the template by a manual flood-fill process and 
then manually transferred to transfer tape.

Direct-to-garment production
Direct-to-garment production is supported by various machines such as the 
RhinestoneMachine.com Libero, Hirsch GemFix, Dairo Machine Company DK 
series (in particular the DK2400Auto) and others.

Cutting data
Cutting data sent to machine consists solely of vectors which describe the 
location, size, and shape of the bling in the template. There are no connecting 
lines or data that do not relate directly to the placement of the bling. For 
example:

Bling templates
Bling templates must have holes cut to suit the bling size to be used. Below is a 
table of stone size to hole size. ‘SS’ stands for ‘Stone Size’. 

Stone size Hole size (mm)

SS04 1.7

SS05 1.9

SS06 2

SS07 2.3

SS08 2.5

SS09 2.7

SS10 2.9

SS12 3.2

Original Bling Fill Result in CorelDRAW Graphics 
after conversion
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Bling toolset
The Bling toolbar contains the following tools:

Bling objects have properties like normal embroidery objects. The Object 
Properties docker contains two tabs called Bling Fill and Bling Run to handle 
these properties. Editable properties include bling type – size, shape color, facets 
– patterns, fill density, angle and layout. Bling features include:
 Similar functionality to the Sequin tool.
 Pre-defined library of rhinestone shapes.
 Tools to create outline and fill patterns.
 Controls to adjust placement of stones to avoid overlaps.
 Tools to convert vector outlines to bling patterns.
 Commands to create cut files to send to cutting machine – similar to appliqué.
 Inclusion of bling count by size and color on production worksheet.

Setting up bling palettes

The Bling Palette Editor lets you prepare a palette of rhinestones for use in 
the current design. Once set up, the palette is available for use in Object 
Properties or from the Bling toolbar.

To define a bling palette
 Click the Bling Palette Editor icon.

SS16 4

SS20 5

SS30 6.5

SS34 7.3

SS40 8.7

SS48 11.4

SS60 14.3

Stone size Hole size (mm)

Use Bling > Bling Palette Editor to select and configure rhinestone shapes from a 
pattern library.
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Fields are arranged in tabular form so that parameters for each rhinestone 
type can be viewed at once.

Note  The controls available in the Bling Palette Editor are similar to those 
available in the Sequin Palette Editor.

 Click the More button to add new entries as required.
 Use the Bling droplist to select rhinestone type and size – e.g. ‘Round ss12’.

The droplist displays rhinestones available for use in both runs and fills. The 
code specifies a size range displayed at the bottom of the popup – e.g. ‘ss12’ 
falls within a size range of 3.00-3.20 mm.

 Edit bling colors and sizes as required. The controls are summarized below.

Control Description

Color Change colors by clicking the drop-arrow and accessing the color 
selection palette. Choose from a range of both standard and 
non-standard colors, or mix your own.

Size1/Size2 These are editable fields which control bling dimensions. Circles, 
squares, stars, flowers and triangles (equilateral) have editable width. 
All other shapes have both editable width and height. The units of 
measurement are determined by the user. See also Set measurement 
units.

Comment Comment is a free text field limited to a maximum of 128 characters.

Click to add 
rhinestone types

Adjust bling 
dimensions

Select rhinestone 
shape and size

Indicates size range 
for selected bling
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 Define a Production Type for the bling palette:
 Placement: If you have an automatic or semi-automatic machine, choose 

this option.
 Cutting: If you have a cutting machine, you will need to cut holes in the 

template material a little bigger than the rhinestone size you intend to use. 
You can set an Allowance value, say 0.04mm, for rhinestones to easily fit 
within the cut holes of the stencil.

 Set an Overcut allowance (as a percentage) as necessary. This 
determines extra distance the knife needs to travel to ensure a clean cut. 
You may need to experiment with this setting depending on the cutting 
machine you are using.

Production 
type

If you are using a cutting machine, you can adjust the ‘cutting 
allowance’ for rhinestones to easily fit the cut holes in the stencil. See 
below.

Overlap 
tolerance

Set the minimum allowable distance between stones. Once set, the 
software controls placement so that no stones are placed closer than 
this value. See also Editing bling-fill objects.

Save Save the palette to the file system for use in another session.

Control Description

Adjust cutting 
allowance – e.g. 
0.04mm

Set overcut
percentage

Overcut 
allowance
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Note  Bling objects exported to a cutter retain color information, and cutting 
outlines have hairline width.

 Click OK to confirm. Rhinestone shapes are now available for use in Object 
Properties or from the Bling Manual palette.

Tip  Click Save to save bling palette to the current template. You might 
consider setting up a dedicated bling template. 

Related topics
 Setting up sequin palettes
 Bling production processes
 Creating bling fills
 Working with templates

Rhinestone shapes 
available for Bling Manual
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Creating bling runs & fills

The Bling feature provides tools for creating bling runs as well as fills. The fill 
can include a border, with or without a margin. You have the option of digitizing 
individual rhinestone ‘drops’ with the manual method.

Digitizing bling runs

Use the Bling Run Auto method to create a string of rhinestones along a 
digitized line. There are two available types – Simple Run (same size stones) 
and Pattern Run (different sizes following a regular pattern). The system 
automatically generates drops according to current settings.

To digitize a bling run
1 Set up the bling palette if you haven’t already done so. 
2 Optionally, toggle on Show Bling Work Area to visualize the design within 

the work area of the selected machine model. 
3 Click the Bling Run Auto icon.

Use Bling > Bling Run Auto to create a string of rhinestones along a digitized line 
according to current settings.

Use View > Show Bling to toggle bling display on/off.

Use Bling > Show Bling Work Area to visualize the design within the work area of 
the selected machine model.

Bling outline

Simple bling run

Bling pattern run
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4 Digitize the line as you would for a normal run object – left-click for corner 
points, right-click for curve points. 

5 Press Enter to finish.
Rhinestones are automatically generated. Spacings can be individually 
adjusted.

6 Double-click the object to view properties.
The Object Properties docker opens at the Bling Run tab.

Available controls are summarized below.

Control Description

Pattern 
Editor

Use to create bling run patterns. Click ‘+’ in the pattern editor and select 
the desired rhinestone shape from the droplist.

Positioning Place rhinestones along the curve and adjust placement to meet selected 
criteria:

Exact: places bling along curve according to specified spacing.

Expand to fit: places as many bling as possible along each curve segment 
where spacing is never less than specified. With this option, there are 
always rhinestones at each cusp point.

Compact: non-circular rhinestones are placed such that minimal distance 
between is equal to specified spacing.

Press Enter

Digitize outline – left-click corner 
points, right-click curve points

Select run type

Hover over bling row to display 
summary information – type, SS 
(stone size) or actual size, color 
name, shape and facet

Position bling along
curve according to

selected option Orientate bling to 
object outline

Summary of bling
used in selected

object
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7 Use pattern settings as for sequin runs to create simple or variegated bling 
runs.

8 Set bling orientation to baseline or fixed angle.

Tip  The Backtrack/Repeat tool is enabled for bling-run objects.

Related topics
 Setting up bling palettes
 Sending bling to CAMS machine
 Creating sequin runs
 Digitizing outlines & details
 Reinforcing outlines

Placing rhinestones manually

You have the option of digitizing individual rhinestone ‘drops’ with the manual 
method.

Manual: allows manual distribution of rhinestones along curve.

Orientation Place rhinestones either relative to object baseline or absolute (fixed 
‘north’) orientation.

Statistics Summary information: type, SS (stone size), color, shape, count (for the 
selected object). If multiple objects are selected, bling information for all 
selected objects is displayed.

Control Description

Angle to baseline Angle to horizontal line

Use Bling > Bling Manual to digitize individual bling drops. Select from a 
user-defined palette of rhinestone shapes.
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To place rhinestones manually
 Click Bling Manual and select the bling type you want from the droplist. 

 Digitize individual rhinestones by left-clicking. If you make a mistake, press 
Backspace.

 Holding down the Shift key, use the handle to adjust rhinestone orientation 
as you digitize.

 Press Enter to finish.

Creating bling fills

Select rhinestone

Click Bling Manual

Use handle to 
adjust angle Press Enter

Use Bling > Bling Fill to digitize complex shapes (with or without holes) filled with 
bling.

Activate Bling > Automatic Overlap Removal if you want to automatically remove 
unwanted overlapping bling items from a bling object.

Activate Bling > No Automatic Overlap Removal if you don’t want to automatically 
remove overlapping bling items from a bling object.

Activate Bling > Highlight Bling Overlaps if you want to highlight overlapping bling 
items in a bling object – i.e. if you want to edit manually.

Use View > Show Bling to toggle bling display on/off.

Use Bling > Show Bling Work Area to visualize the design within the work area of 
the selected machine model.
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The Bling Fill feature provides a means of filling complex shapes with bling 
arranged in columns. Bling fill types include Column Fill (straight grid, angled 
grid) and Contour Fill.

Tip  You can create offset objects from bling-fill objects. All the same options 
are available as are available for embroidery objects, plus the ability to create 
bling fills and runs.

To create a bling fill
1 Optionally, toggle on Show Bling Work Area to visualize the design within 

the work area of the selected machine model.
2 Click the Bling Fill button.
3 Digitize control points for a closed object in the same way as Complex Fill.

4 Press Enter to close the shape. You are prompted to create another 
boundary.

5 Press Enter twice to finish the object.
6 Double-click the object to view properties.

Bling-fill object with Column Fill 
type and Follow Outlines 
enabled



EmbroideryStudio e4 User Manual 815

The Object Properties docker opens at the Bling Fill tab.

7 Select a fill type – Column Fill or Contour Fill.

Select fill type

Adjust fill angle
Shift fill in relation to

object outline Force fill to follow 
object outlines

Select fill pattern type

Bling fill editor: Hover over 
bling row to display summary 
information – type, SS (stone 
size) or actual size, color 
name, shape and facet

Add border to
selected bling-fill

object

Set margin between bling 
border and fill

Border pattern editor: Hover 
over bling row to display 
summary information – type, SS 
(stone size) or actual size, color 
name, shape and facetOrientate bling to

object outline

Summary of bling
used in selected

object

Column Fill type Contour Fill type
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8 Adjust angles and shift as required – these settings are only available with 
Column Fill.

9 Use pattern settings as for sequin fills to create simple or multiline bling fills:
 For a simple fill, set the fill type to Simple and adjust pattern as desired.

 For a more complex, variegated fill, set the fill type to Multiline and adjust 
pattern for each line as desired.

Angle: 0°, Shift: 0.00 Angle: 45°, Shift: 0.00

Simple fill – 1 shape Simple fill – 2 shapes Simple fill – 3 shapes

Set required number of 
pattern lines

Edit line pattern as 
desired

Scroll between lines
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10 Adjust line spacing settings as required.

11 Add borders as required. See below

Tip  By default, Automatic Overlap Removal is selected in order to 
automatically remove unwanted items from overlapping bling objects. 
Choose another option if you want to manually edit rhinestone overlaps.

Note  Bling overlaps are determined by the Overlap Tolerance setting. This 
defines the minimum allowable distance between stones. 

Bling fill summary
Controls available on the Bling Fill tab are summarized below.

Control Description

Fill type Available fill types include: Column Fill, Contour Fill. Respectively, these fill a 
shape with columns along which patterns are repeated, or contours where 
patterns are repeated along a contoured path.

Layout Bling-fill objects exist in one of two ‘layout’ states: Auto and Manual. In the 
Auto state, bling fills are automatically re-generated whenever an object is 
scaled or reshaped. In the Manual state, the bling count does not change 
during transformations. See also Modifying bling objects.

Angle Changes the angle of the column fill. This is only applicable to Column Fill.

Shift Moves the entire fill pattern in relation to the object outline. This can be used 
to achieve a more even fill placement. Acceptable values are between ±0.5.

Contour Fill
Line Spacing: 1mm

Contour Fill
Line Spacing: 3mm

Contour Fill
Line Spacing: 5mm

No automatic overlap removal Automatic overlap removalHighlight bling overlaps
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Related topics
 Sending bling to CAMS machine
 Setting up bling palettes
 Creating sequin fills
 Creating twin-sequin designs

Adding bling borders

Like sequin fills, bling fills can also include a border, with or without a margin. 
The border can be made from different or same rhinestones and is a property of 
the bling-fill object.

Follow 
outlines

Expands the space between bling in each line of fill in order to follow the 
object outline. This results in a stronger outline demarcation. It is only 
applicable to Column Fill and works in conjunction with borders. See Adding 
bling borders for details.

Pattern 
editor

Use to create bling patterns as either single-line or multi-line patterns. Create 
patterns by clicking ‘+’ in the pattern editor and selecting bling from the 
palette. Multi-line patterns are created similarly, but each time the number of 
lines increases, a new tab is added to the pattern editor. This allows a new 
pattern to be added. See also Creating sequin fills.

Line 
spacing

Set the distance between the currently active line tab and the next line in the 
pattern. This can be the same or different for each and every line. By default, 
this value is the same for each.

Border When checked, this adds a border to any selected bling-fill object. You can 
also create a pattern for the border similarly to single-line patterns for bling 
fills.

Margin Add a margin to rhinestones forming the border. Smaller border margins 
result in a larger number of rhinestones in the fill.

Orientation Place bling in the border either relative to the object baseline or at an 
absolute (fixed ‘north’) orientation.

Statistics View the following information: type, SS (stone size), color, shape, count (for 
the selected object). If multiple objects are selected, then bling information 
will be displayed for all selected objects. You can re-order the columns as 
needed.

Control Description
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To add a border or changing border properties
1 Select the bling-fill object and tick the Border checkbox.

2 Use pattern settings to create simple or variegated bling borders.
3 Select the bling margin as required.

A border margin is created by adding an ‘offset’ to each individual bling item 
in the border. Smaller border margins result in a larger number of rhinestones 
in the fill as shown.

Related topics
 Adding sequin borders

Modifying bling objects

Bling-fill objects can be scaled and reshaped like any embroidery object. When 
reshaping, resizing or editing an object/design, the software automatically 
recalculates the number of stones but does not resize them. The Bling toolset 
also provides tools for editing rhinestones individually.

Add border to
selected bling-fill

object

Edit border
pattern as desired
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Tip  Object properties for bling-run and bling-fill objects can be copied and 
applied to other objects. This is done via the Make Properties Current and 
Apply Current Properties commands.

Transforming bling-fill objects

Bling-fill objects can be scaled and transformed like any embroidery object with 
one difference. Bling-fill objects exist in one of two ‘layout’ states: Auto and 
Manual. In the Auto state, bling fills are automatically re-generated whenever 
an object is scaled or reshaped. In the Manual state, the bling count does not 
change during transformations.

To transform a bling-fill object
 Select the bling-fill object and check the Layout setting.

 Scale as desired.

 Similarly, skew as desired.

Related topics
 Modifying Objects

Use Select Tools > Select Object to resize objects using selection handles.

Check layout 
state

Layout: Manual
Bling count unchanged

Layout: Auto
Bling fill regenerated

Layout: Manual
Bling count unchanged

Layout: Auto
Bling fill regenerated
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Reshaping bling-fill objects

When reshaping a bling-fill object you can reshape object outlines in the normal 
way. When Column Fill is applied, you can graphically change the fill angle and 
curve line as well.

To reshape a bling-fill object
 Select the bling-fill object.

 Click the Reshape icon or press the H key.
Control points appear around the object outline. If column fill is selected, two 
other control bars appear – one (orange handles) to control fill angle, and the 
other (yellow handles) to control curve lines.

 Reshape the outline in the normal way.
In this case, we adjust the outline only slightly to improve the bling fill 
coverage.

Use Select Tools > Select Object to resize objects using selection handles.

Use Reshape Tools > Reshape Object to reshape selected bling run objects.

Curve line control bar

Fill angle control bar

Reshape control points

Adjust outline to 
improve fill coverage
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 Adjust fill angle control as desired.

 Adjust curve line control as desired.
Right or left-click anywhere along the line to add curve or angle points. Curve 
line adjustments have no effect on object properties.

Editing bling-fill objects

The Bling toolset provides tools for editing rhinestones individually. The 
following operations are applicable to bling run, bling fill, and bling manual 
objects.

Drag orange bar to 
adjust fill angle

Click to create curve or 
angle point

Use Bling > Bling Edit to edit bling items individually.

Activate Bling > Automatic Overlap Removal if you want to automatically remove 
unwanted overlapping bling items from a bling object.

Activate Bling > No Automatic Overlap Removal if you don’t want to automatically 
remove overlapping bling items from a bling object.

Activate Bling > Highlight Bling Overlaps if you want to highlight overlapping bling 
items in a bling object – i.e. if you want to edit manually.
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To edit a bling-fill object
 Select the bling-fill object and click the Bling Edit icon. Selection handles 

change.

 Select rhinestones individually within the object.
Use the Ctrl key to select multiples.

 Delete or reposition selected rhinestones as desired.
 Select rhinestones and right-click to replace by means of the popup menu.

 Use the same popup menu to delete or add rhinestones.
These operations are treated as manual edits. The object’s layout status is 
automatically changed to Manual. This means that bling count does not 
change during object transformations.
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Tip  By default, Automatic Overlap Removal is selected in order to 
automatically remove unwanted items from overlapping bling objects. 
Choose another option if you want to manually edit rhinestone overlaps.

Note  Bling overlaps are determined by the Overlap Tolerance setting. This 
defines the minimum allowable distance between stones.

Converting objects to bling

Any closed object can be converted to a bling-fill object. Similarly, any outline 
object – closed or open – can be converted to bling-run.

To convert an object to bling
 Right-click a fill object and select Convert > Convert to Bling Fill.

 Alternatively, click the Bling Fill button on the Bling toolbar.

No Automatic Overlap Removal Automatic Overlap RemovalHighlight Bling Overlaps



EmbroideryStudio e4 User Manual 825

 Similarly right-click a run object and select Convert > Convert to Bling 
Run.

Tip  You can also create objects with the Freehand Embroidery tools which 
can be converted to bling-fill objects. 

Creating bling lettering

Use the dedicated Bling Lettering tool to create lettering in the same way as 
embroidery lettering. Use the same properties as embroidery lettering. 
Depending on the font, you also have access to Bling Run or Bling Fill 
properties. Alternatively, various techniques exist to create bling text without 
lettering properties.

To create bling lettering
 Select the Bling Lettering tool and select a font from the Special > 

Lettering tab. For best results, use native bling fonts.

Use Bling > Bling Lettering to create bling lettering onscreen using native bling 
fonts, embroidery fonts, or TrueType fonts. Right-click for settings.

Bling-specific 
fonts
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 Digitize bling lettering as you would embroidery lettering.

 Adjust properties as for embroidery lettering including size, slant, etc.
 Change font type. Use embroidery fonts or TrueType fonts with bling as 

desired. 
 Alternatively, select an existing embroidery lettering object and convert to 

Bling Run or Bling Fill.

 Create a TrueType object and convert to Bling Run or Bling Fill.

 Create a lettering object in CorelDRAW Graphics, change to Wilcom 
Decoration, use Centerline Run Object to trace the letters, and convert to 
Bling Run.

 Depending on the font type you are using, adjust bling automatic fills or 
outlines for Bling Fill or Bling Run.

Select all objects and apply 
Centerline Run Object
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Related topics
 Creating embroidery lettering
 Editing text
 Creating bling runs & fills

Outputting bling

EmbroideryStudio supports direct connection to CAMS automatic rhinestone 
placement machines. Alternatively, a dedicated Send to Bling Cutter command 
sends vectors for any bling in a multi-decoration design to a supported cutting 
machine.

Outputting bling templates

The Send to Bling Cutter function sends vectors for any bling in a 
multi-decoration design directly to a cutting machine. Use it with any bling 
template cutter supported by MS Windows®.

To output bling templates
1 Open or create a multi-decoration design.

A cutting or engraving machine must be connected to the PC and configured 
to receive data.

2 Click the Send to Bling Cutter icon or select File > Send to Bling Cutter.

Use Standard > Send to Bling Cutter to send vectors for any bling in a 
multi-decoration design to a supported cutting machine.
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The Send to Bling Cutter dialog opens.

3 Select your bling cutter from the droplist or select a suitable printer.
4 Select the Print to file option if you want to print the design to file.
5 Click Properties and check your output settings.
6 For a realistic view click the Preview button.

Note  In multi-bling designs, each color is separated into different templates 
for flood-filling.

7 Click OK to send the bling templates to bling cutter or to file.

Select bling cutter
or suitable printer

Click to preview
printable parts of

design

Select if you want 
to print to file
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The bling cutting/engraving information is sent to machine in the required 
format. The machine cuts the desired template/s. The cutting data consists 
solely of vectors which describe the location, size, and shape of the bling in 
the template. There are no connecting lines or data that do not relate directly 
to bling placement.

Tip  A bling production summary shows stone colors, sizes, and quantities as 
well as a summary on the first page.

Related topics
 Setting up machines
 Printing reports
 Customizing design reports

Sending bling to CAMS machine

EmbroideryStudio supports direct connection to CAMS automatic rhinestone 
placement machines. A general procedure is outlined below.

Note  Before executing the procedure, it is important that the machine drivers 
for your CAMS machine be properly installed. They need to be installed and the 
machine connected before setting up the COM port. Refer to your machine 
documentation.

To select bling machine
1 Select the machine you want to connect to via the Setup > Bling Machine 

Setup command.

2 In the Model panel, select the machine model you are using.
3 Activate the Bling Work Area to visualize the design within the work area of 

the selected machine model.

Use Bling > Show Bling Work Area to visualize the design within the work area of 
the selected machine model.

Use Standard > Send to Connection Manager to connect to supported machines 
via proprietary machine software.

Select your 
machine model
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4 Set the color of the work area as desired.

To send to Connection Manager
1 From the Standard toolbar, click the Send to Connection Manager button.

2 From the Connection Manager droplist, select ‘CAMS’.
3 Click the Setup button.

The CAMS Setup dialog opens.

4 Check the communications port and baud rate settings. 
If you are using an ‘old school’ serial connection, the COM port in the software 
should match the port to which the cable is connected. If you are using a USB 
connection, the COM port in EmbroideryStudio must match the ‘virtual’ COM 

Select ‘CAMS’

Check communications 
port and baud rate 
settings
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port assigned to it. You can find this in Windows Control Panel > Device 
Manager.

If you are using a USB connection and the COM port is not available for 
selection in EmbroideryStudio, you need to verify that your hardware drivers 
have been correctly installed and are up-to-date. Check your machine 
documentation for details.
The baud rate in EmbroideryStudio must match the baud rate at which the 
machine was configured to read the data. This is normally 57600 (the system 
default). However, you can confirm the value when you prepare the machine 
to receive data. The baud rate will be displayed on the machine console.
The model will default to the machine selected via the Setup > Bling 
Machine Setup function. You can change it here if required.

5 Click OK.
The Send to CAMS Machine dialog opens.

6 Use this dialog to assign bling in the design to the available feeders on the 
CAMS machine.

7 Prepare the machine to receive data and click the Send button.

Caution  If you try to send something before the machine is ‘Ready’, it may 
fail to read the next design.

If using a USB connection, 
COM port setting must match 
‘virtual’ COM port assigned to it

Assign bling to available 
feeders on CAMS 
machine
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Suggested workflow
The precise workflow you follow will depend on the number of feeders available 
on the selected machine. For example, if you have a machine with two feeders 
which is currently set up to feed SS6 on Feeder #1 and SS10 on Feeder #2, and 
wish to output a design which contains SS6, SS8, SS10, you may do so like this:
 Drag SS6 to Feeder #1.
 Drag SS10 to Feeder #2.
 Prepare the machine for download.
 When the machine is ‘Ready’ for download, click Send.
 When the machine has finished receiving the file, run the machine to place all 

the SS6 and SS10 stones.
 Once the run is completed on the machine, replace the SS6 feeder on the 

machine with the SS8 feeder.
 In the software, drag SS8 to Feeder #1 (where you had previously dragged 

the SS6).
 Prepare the machine for download again.
 When the machine is again ‘Ready’, click Send.
 When the machine has finished receiving the file, run it in order to add the 

SS8 stones to the design already containing the stones from the previous run.
Depending on the number of bling types used in the design and number of 
available feeders, you may need to send bling more than once. You will be 
prompted if you exit before all bling has been sent to machine.

Related topics
 Sending designs to Connection Manager
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PART X

DESIGN PROCESSING &
PRODUCTION

Design processing and encoding involve all the important, back-end operations 
of embroidery design and manufacture. This is where you actually output your 
designs to machine, disk, printer, cutter, and so on. For this, you will need an 
understanding of embroidery file types as well as different machine formats. 
Depending on your setup, you will also need an understanding of traditional 
storage media such as embroidery disks.

Printing designs
This section describes how to print designs in CorelDRAW Graphics as well as 
how to create production worksheets and approval sheets. It also explains how 
to send designs as email attachments, as well as how to output designs as 
images. Sending appliqué shapes to printer and cutter are also covered. See 
Printing Designs for details.

Working with machine files
This section describes the different conversion options for opening and saving 
stitch and outline design formats. It also provides details about the processing 
of Melco CND outline files, including color merging, as well as reassigning colors 
to both stitch and Melco CND files. See Working with Machine Files for details.

Outputting designs for production
This section describes how to stitch designs out with the Stitch Manager and with 
Connection Manager utilities. It also explains how to save designs for machine, 
how to read and write to embroidery disk. It also deals with exporting 
multi-decoration files. See Outputting Designs for Production for details.

Hooping designs
This section deals with selecting and centering hoops, both manually and 
automatically. It also covers defining and editing custom hoops. See Hooping 
Designs for details.
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Chapter 40

Printing Designs

From the same EMB design file, you can output production worksheets or 
approval sheets for machine operators or customers respectively. Screen images 
may be captured in PNG format to distribute designs for viewing in real colors. 
EmbroideryStudio also provides high resolution digital print TrueView for 
‘virtual embroidery’.

EmbroideryStudio allows you to customize information in the format you 
require. The printing capability also allows you to:
 Personalize worksheets with company name and logo
 Print approval sheets with or without design details
 Display the assigned hoop
 Visualize on selected fabric/garment
 Include selected colorways.
Optionally, email production worksheets in PDF format with the embroidery file 
as an attachment in a specified format – e.g. EMB or DST, etc.

Printing design reports

EmbroideryStudio allows you to print designs in various pre-defined formats. 
The most common are the approval sheet and the production worksheet. 
Approval sheets are usually sent to the client for confirmation prior to 
production. The production worksheet is the link between designer and 
embroidery machine operator. It contains a design preview as well as essential 
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production information, including design size, color sequence and special 
instructions. Reports can be output as hard copy or in electronic (PDF) format.

Caution  If certain thread colors are not available on your printer, they may be 
mapped to a different color, including white. Print the design in TrueView™ color, 
or black and white, or turn off color mapping. See your printer manual for more 
information.

Printing reports

Create a hard copy of your design report using a printer or plotter. Alternatively 
create soft copy in PDF format. Optionally, send it directly as an email 
attachment. Preview the report prior to printing. 

To print a report
1 Before printing, it’s a good idea to check design properties to make sure all 

design information is up-to-date.
2 Click the Print icon or select File > Print.

3 Select the printer or plotter you want to use and required number of copies.

Use Docker > Design Properties to view and modify design details prior to design 
approval or stitchout.

Use Standard > Print to print production worksheets for the current design using the 
current settings.

Click to preview 
worksheet

Click to select /
customize report
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4 To select a report type, click the Options button. The Print Options dialog 
opens.

5 Select a report type in the Print panel. Multiple reports can be batched as 
part of the same print run. Tick the checkbox next to each. 

6 Select tabs to customize report details as required. Tabs vary with the report 
type.

7 Click OK to close Print Options.
8 If you are using a plotter, click Properties, and set pen colors to correspond 

with the thread colors in the design.

Note  Refer to your plotter manual for information on setting up pen colors.
9 Click Preview to inspect the report before sending to print.

10 To print the design, choose an option:

Select tabs to 
customize report 
details

Select report
type/s

Click Close to return to 
design window

Choose a print 
option

Production 
information and 
threadup details

Modify report 
options
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 Print Now: Click to send the design report to your local printer.
 Save as PDF: Click to save the report as a PDF document. You are 

prompted to save to the hard drive or network location.
 Send PDF via Email: Click to send the report – usually an approval sheet 

– as a PDF attachment to your local email client. The PDF is automatically 
identified by customer name, order number, and current date.

Related topics
 Viewing & managing design information
 Customizing design reports

Report types

In addition to production worksheets, EmbroideryStudio provides a number of 
pre-defined report types including approval sheets, product summaries, color 
films, and appliqué patterns.

Report types include:

Color films
This report type lets you print color blocks in the design as they appear in the 
Color-Object List. It provides color block information so that production staff 

Approval sheet 
attached to email for 
customer review

Report type Purpose

Approval 
sheet

This is intended for the customer, not production staff. Customers can see 
what they are ordering and approve accordingly. 

Production 
worksheet

This is intended for production staff. All production-related information, 
such as bobbin length, design size, garment fabric, etc, is provided.

Production 
summary

This provides two summary tables of the design and associated colorways 
– a Colorway Summary together with a Design Summary. 

Appliqué 
patterns

This shows appliqué patterns – cutter information – isolated from the 
design. This tells the operator which appliqué pieces are to be included.

Select report 
type
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can see each stitch color in order of stitchout. Separate color films are printed 
for selected colorways on the last page of the worksheet.

Related topics
 Customizing design reports
 Printing appliqué patterns

Customizing design reports

For each report type you select, tabs allow you to further customize report 
details. Tabs vary with the report type. The Production Worksheet actually 
provides a superset of all available options.

Report tabs

Below is a superset of all tabs available for different report types. The 
Production Worksheet includes all tabs. Other reports contain a subset.

Select tab to 
customize report 
details

Select report
type/s

Include order 
information on 
approval sheets
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General options
Reports generally have the following customizable layout:
 Standard header/footer, incorporating company name/logo, customer name, 

colorway name, user-specified fonts, margin control, etc
 Company name/logo
 Page numbers
 Barcode in header – available for all report types
 Multiple vertical ‘full info’ strips allocated on a single page if zoom parameters 

allow. Alternatively, there is a Start New Page option on Info tab to force 
the layout to start vertical info strips on a separate page.

The General tab includes the following layout settings:

Terms & conditions
Terms and conditions text is stored in an internal defaults file. The only way to 
update the text and save it for later use it to do the following:
1 Open a new design sheet and digitize a simple object.
2 Open Print Preview and click Options.
3 Select the Approval Sheet report type.
4 Key in your own Terms & Conditions and close print preview.
5 Close the software – don’t save the temporary design.
After restart, each time the approval sheet is used, it contains the updated 
Terms & Conditions.

Barcode options
Some machines read barcodes in order to load designs. Typically, the digitizer 
will send the design to machine memory or database, then print out a 
worksheet. The operator will take the worksheet, scan the barcode, and the 

Option Purpose

Text / heading 
font

Set parameters for all text and headings appearing in the report – e.g. Arial 
for print, Verdana for online reports.

Print in 
English

Useful when printing to plotters where the device driver does not support 
the character set you require. Deselecting the checkbox prints the report 
in the language of the operating system. 

Print design 
filename

Include the filename of the current design in the header of the product 
report.

Margins Add a margin between the edge of the page and the content of the report. 
The page size itself is set via the Print dialog.

Company Include your company name on the report. Enter a name and/or attach a 
company logo. If you have already entered one or more company names 
into the system, select from the droplist. Optionally, print the logo on the 
first page only.

Order 
information

Include customer name and order details.

Terms and 
Conditions

Include terms and conditions of use relating to your company designs. See 
below.
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machine will load the associated file. The Barcode tab allows you to specify a 
standard format based on design name or a custom format.

Many companies are switching to barcode readers on embroidery machines to 
‘pull’ designs from Windows network locations rather than having the computer 
‘push’ them to the machine. In addition to design name, some machines require 
the file extension. Amongst the barcode options, you can choose to include the 
current file extension or nominate one of your choice – e.g. ‘DST’. 
The ‘custom’ option is provided in case you have other barcode requirements – 
e.g. for pricing purposes.

Colorway options
The Colorways tab allows you to include or exclude selected colorways for the 
current design.

Specify preferred 
barcode format

Select Selected

Hold down <Ctrl> to
select multiple items

Select colorway 
display for printout
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Separate sheets are generated for each selected colorway.

If the Production Summary report type is selected, the Colorway Summary 
table is printed together with the Design Summary table. You can also print 
color blocks in the Colorway Summary table by selecting the Show Colors in 
Summary option in the Stop Sequence tab.

Design summary 
table

Colorway summary 
table
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If you want to include the background or fabric color with the colorway, select 
Background in the Design tab.

Tip  Select Crop to Design to crop the empty space around the design.

Zoom options
The Zoom tab lets you set a zoom factor for the design preview and physical 
printout.

Customizable options include:

Related topics
 Visualizing products

Design options

The Design tab allows you to toggle on/off the same options available on the 
View toolbar. Print designs in TrueView™ or stitch only, with needle points, 
connectors, etc, or without. Include background fabric or color as preferred.

Include the hoop with or without the template. Templates include alignment and 
registration guide markings. These can help production staff align the design in 

Option Purpose

Zoom 1.1 Shows design at actual size.

Zoom to fit Scales design to fill available space on the printout.

Zoom to product Scales whole product to fill available space on the printout. 

Custom Sets a specific zoom factor.

Select to include 
background on worksheet

Set design zoom factor 
for current printout
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the hoop. You can also include the product backdrop which can guide staff in 
correct placement.

Print all types of multi-decoration supported by EmbroideryStudio, either 
separately or in combination. Click the Repeats button to access the dialog and 
set repeating design options. 

Related topics
 Viewing design components
 Viewing design repeats
 Hoops & templates

Embroidery components
To display embroidery components, select from amongst Outlines, Stitches, 
Needle Points, Connectors, TrueView in the Design tab. For TrueView to 
display, you must also have Stitches selected.

Select embroidery
components to

display

Tick to display sequins
(and other machine

functions)

Tick to include bling
components

Click to access 
design repeats
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Print only
To display print components only, select between Bitmaps and Vectors.

Sequin components
To display sequin components, select Functions in the Design tab. A sequin 
production summary shows color, size and quantities by sequin device as well as 
a summary on the first page.
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Bling components
To display bling components, select Bling in the Design tab. The bling 
production summary shows stone colors, sizes, and quantities as well as a 
summary on the first page. 

Note  When bling is output as multiple files, each color is separated into different 
templates for flood-filling with selected rhinestones. 

Related topics
 Outputting bling templates

Design backgrounds
The Design tab also provides options to display design backgrounds – e.g. 
fabric, product, and/or hoop. 
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Amongst background options, you can set:

Related topics
 Fabric & product backgrounds
 Hoops & templates
 Setting auto start & end

Information options

The Info tab lets you filter information to include on production worksheets.

Customizable options include:

Option Purpose

Hoop Include the selected hoop, whether or not currently displayed on 
screen.

Hoop template Templates include alignment and registration guide markings. These 
help align the design in the hoop.

Background Include any background currently displayed – color or fabric.

Crop to design Crop any background to the extends of the design, rather than the full 
page.

Product Included selecte garment or product backdrop on which to position 
the design. Use it to display location, size and overall appearance for 
visualization or approval purposes. 

Extents box Place an outline around the design to delineate its full extents.

Start/end crosshair Print a cross hair across the design indicating design start and end 
points.

Guides When contrasting colors are used in the colorway for guide and 
background colors, guides can be turned off.

Standard Reset printing options to default values.

As Window Set printing options as per current settings in the design window.

Option Purpose

Full Includes all design and production information included in the Design 
Properties docker. This information can be further filtered via the Blocks 
tab.

Short Includes only default header and footer information. Usually used in 
conjunction with full size design in order to visualize on garment. See also 
Zoom tab.

Stop 
sequence

Includes only stop sequence information on the worksheet. This 
information can be further filtered via the Stop Sequence tab.

Set information to 
include on production 
worksheets
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Tip  Worksheets include information entered into the Design Properties > 
Summary tab, including comments but excluding keywords. See also Viewing 
& managing design information.

Blocks options

The Blocks tab lets you further filter production information available on the 
Design Properties > Information tab for inclusion in the printout.

Select design statistics to include on the worksheet:

Design name / 
filename only

Includes the design filename as the printout information without any other 
text.

None Eliminates design details altogether and suppresses display of default 
header and footer information – again, can be used in conjunction with full 
size design in order to visualize on garment. See also Zoom tab.

Start new 
page

Prints design details on a separate sheet.

Use left side Displays the information column on the left side of the page (rather than 
the default right-hand side).

Option Purpose

Option Purpose

Left / right / up 
/ down

Depending on where the design start/end point has been set, these figures 
indicate the distance from that point. 

End X / Y The coordinates of the last stitch. 

Area Total area covered by design – used for estimating hoop sizes, fabric 
requirements, 3D foam, or whether design will fit target location.

Max / min 
stitch

The maximum and minimum stitch lengths, and maximum jump stitch 
length in the design.

Thread chart 
type

The name of the thread chart used in the design. All required brands for 
used threads are displayed in a comma-separated list. 

Thread usage Meterage of thread required per color.

Total thread Indicates total meterage of top thread required to stitch out the design.

Total bobbin Total meterage of bottom (bobbin) thread required to stitch out the design.

Machine 
runtime

This checkbox is only available if the feature is available in the software. If 
there are no machines set up, checking ’Machine runtime’ has no effect as 
there is nothing to print. 

Set detailed production 
information for inclusion
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Here is a sample production worksheet with all options selected:

Related topics
 Viewing & managing design information
 Hooping Designs
 Setting auto start & end
 Assigning thread colors
 Doing runtime estimates

Stop sequence options

The Stop Sequence tab lets you further filter production information available 
on the Design Properties > Stop Sequence tab for inclusion in the printout.

Left / right / up / down

End X / Y

Max / min stitch

Thread chart type

Thread usage

Total bobbin

Choose stop sequence 
information for inclusion
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Select the statistics for each color block:

Here is a sample production worksheet with all options selected:

If the Production Summary report type is selected, the Colorway Summary 
table is printed together with the Design Summary table. You can also print 
color blocks in the Colorway Summary table by selecting the Show Colors in 
Summary option in the Stop Sequence tab.

Related topics
 Viewing & managing design information
 Naming design elements
 Colorway options

Outputting designs as graphics

Once digitized in EmbroideryStudio, you can output a design as a vector file. This 
can be downloaded to a laser cutter in CorelDRAW Graphics. This can serve 

Option Purpose

Stitch count Include number of stitches per color.

Needle number Include needle number corresponding to each color change. This is only 
really relevant to needle-addressing machines.

Chart Brand name of thread chart used.

Element name User-defined name to identify each color block. 

Show colors in 
summary

Include color samples in a colorway summary table. 

Stitch count

Needle number

Chart

Element name

Colors displayed in 
colorway summary table
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various purposes such as appliqué cutting, multimedia, screen printing, and so 
on. Screen images may be captured in PNG format to distribute designs for 
viewing in real colors. EmbroideryStudio also provides high resolution digital 
print TrueView for ‘virtual embroidery’. 

Printing designs in CorelDRAW Graphics

To send a multi-decoration design to production, you generally print the digital 
art design before stitching the embroidery. To do this, you first need to hide the 
embroidery because you don’t want it printing on the digital art printer.

Note  EmbroideryStudio includes as standard the entire suite of CorelDRAW® 
Graphics Suite drawing tools which offer many techniques for drafting outlines 
and shapes on screen. Refer to the electronic User Guide available via the 
MS Windows® Start > Programs group. Alternatively, use onscreen help 
available from the Help menu.

To print a design in CorelDRAW Graphics
1 Switch to CorelDRAW Graphics. 
2 Toggle off Show Embroidery to hide any embroidery objects. 
3 Click the Print icon on the Standard toolbar. The Print dialog opens.
4 Adjust print settings as required and click Print Preview button to preview. 

Otherwise click Print button to print.
The design is printed with or without embroidery objects showing depending 
on whether the Show Embroidery button is toggled on or off.

5 To sew embroidery over top of the printed design, switch to Wilcom 
Decoration and toggle off Show Graphics. 

Tip  Make sure you align the needle with a manually digitized start and end 
point to ensure that stitching aligns with the digitally printed part of the 
design. 

Related topics
 Operating modes
 Viewing design components

Stitching should align on 
garment with digitally 
printed part of design
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 Setting auto start & end
 Sending designs to Stitch Manager

Outputting designs as bitmaps

Designers frequently want to distribute their designs for viewing in real colors, 
in TrueView™ or otherwise, with or without fabric backgrounds. This might be 
for stock design sales purposes, for approval of digitized designs, or for 
presentation on the web or in catalogs. Screen images are captured in PNG 
format because it supports transparency.

To output a design as a bitmap
1 Open the embroidery design.
2 Select File > Capture Design Bitmap.

3 Select a Selection option:

Option Purpose

Whole design 
(1:1)

Captures the screen image in a ratio of 1:1.

Current design 
window

Captures the screen image at the currently selected zoom factor.

Custom Lets you specify a capture area. You are prompted to define the area 
to capture.

Select Output 
option

Check bitmap 
resolution

Select image
selection option

Select to include
background color or

fabric

Draw marquee
around selection

area
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4 Select an Output option:

5 Select Include background/fabric to include the background color or 
fabric with the screen capture.

Note  Bitmap resolution defaults to current screen resolution. Properly 
calibrated, this figure should default to approximately 96 DPI. See also 
Outputting designs as virtual decoration.

Virtual decoration

EmbroideryStudio provides high resolution digital print TrueView for ‘virtual 
embroidery’. This is a technique that can provide commercial flexibility for 
embroiderers and direct-to-garment printers. Screen images are captured in 
PNG format because it supports transparency. Also all DTG printers use RIP 
(Raster Image Preparation) software which uses PNG format. 

Option Purpose

Save to disk Save screen capture to disk. The Save Capture Screen dialog allows 
you to select a location, name and format for the captured design 
image.

Send via email Lets you send the screen capture as email. A new email message 
opens with the image attached.

Save & send Lets you both save to hard disk and send as an email attachment.

Image captured as 
Whole Design (1:1) with 
background fabric
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Outputting designs as virtual decoration

High resolution TrueView is accessed via File > Capture Virtual Decoration 
Bitmap.

Bitmap resolution defaults to current screen resolution. If properly calibrated, 
this will be 96 DPI. Because calibration is never exact, most screens will provide 
lower resolutions than this, even when calibrated.

Maximum DPI for DTG printers can vary between 600 and 2880 DPI. However, 
image quality for printing does not need to match printer DPI to produce good 
output. For general purposes such as printing on T shirts, good results can be 
obtained within a range of 120 to 300 DPI. Higher resolutions are suitable for 
printing on paper, normal or photographic.

Tip  The Options > View Design settings also affect the final appearance of 
the TrueView print. See Setting view options for details.

Embroidery-only virtual decoration

If you only require the embroidery portion of a design to be output as a virtual 
decoration, the process is a simple one.

Select required
resolution

Physical dimensions of 
printed file
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To create an embroidery-only virtual decoration
1 Open your EMB design and select File > Capture Virtual Decoration 

Bitmap.

2 Select a suitable bitmap resolution – e.g. 300 DPI.
3 Click OK to save a PNG file of the design.

Only the embroidery portion of the design is output to PNG file. The image 
produced is always in TrueView even if the TrueView setting is off. This file 
can now be printed to garment.

Tip  The Options > View Design settings also affect the final appearance 
of the TrueView print. See Setting view options for details.

Select a suitable
bitmap resolution
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Combined embroidery & graphic virtual decoration

To produce a combined embroidery plus graphics as a printable virtual 
decoration, use the following procedure.

Tip  Don’t use the Export Multi-Decoration File command for this scenario as 
it doesn’t handle virtual embroidery as a print.

To combine embroidery with graphic virtual decoration
1 Open your EMB design and switch to CorelDRAW Graphics.

2 Select a suitable bitmap resolution – e.g. 300 DPI. This setting determines 
the detail at which the TrueView image will be rendered.

3 Select File > Export > PNG.

Use Mode > Virtual Decoration Quality to set the rendering quality of 
embroidery TrueView for a virtual decoration. 

Select a suitable
bitmap resolution

Select PNG file 
format
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4 Click OK. The Export to PNG dialog opens.

5 Adjust transparency, anti-aliasing, and DPI settings as required.
The DPI setting in this dialog does not affect the DPI resolution of the 
TrueView rendering. It only affects the DPI of the actual output file.

6 Click OK to export.

Tip  To produce a design as real embroidery plus print, you have two options: 
export both files together or export files separately. 

Related topics
 Exporting multiple decoration files

Actual embroidery plus print

To produce a design as a real embroidery plus print, you have two options.

Adjust 
transparency and 
other settings as 
required



EmbroideryStudio e4 User Manual 857

Option 1: Export both files together
 Select the File > Export Multi-Decoration Files command.

 Split out the embroidery production and graphics print files and select the 
formats to export – e.g. DST and PNG.

Note  If you choose PNG here, it defaults to the CorelDRAW default setting 
of 300 DPI. This can be changed via the CorelDRAW Options dialog.

Option 2: Export files separately
 To obtain the embroidery production file, select File > Save As from Wilcom 

screen and choose a suitable machine file format – e.g. DST.
 To obtain the graphics production file, switch to CorelDRAW® Graphics Suite:
 Turn embroidery display off.
 Select File > Export > PNG to export the PNG DTG print file for the 

graphics only.

Select embroidery and 
print file formats to 
export

Change bitmap file 
export resolution as 
required
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Chapter 41

Working with Machine Files

By default EmbroideryStudio saves to its native file format, EMB. This format 
contains all information necessary both for stitching a design and for later 
modification. When opening designs created or saved in other formats, 
EmbroideryStudio converts them internally to EMB format. They can then be 
modified using the full range of EmbroideryStudio features. Depending on the 
file type, you may need to provide additional information to assist 
EmbroideryStudio in the conversion process.

Embroidery file formats

Embroidery designs are saved in one of two formats – ‘design’ (outline) or 
‘machine’ (stitch) file format.

Note  For details of specific formats supported by EmbroideryStudio, see 
Supported embroidery file formats.

Design files

Design files, also known as ‘all-in-one’ files, are high-level formats which contain 
object outlines, object properties and stitch data. When you open a design file 
in the software, corresponding stitch types, digitizing methods and effects are 
applied.

Design files can be scaled, transformed and reshaped without affecting stitch 
density or quality. After modification, you can choose to save your design to EMB 
format, or to a different format altogether.

Note  Some design files, such as Wilcom INP and Gunold PCH, contain 
incomplete information. Old format ESD designs are somewhere between an 

Embroidery objects with
outlines and stitch

properties
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design file and a machine file. They contain stitch data, information about 
selected stitch types, densities, and machine functions. They do not, however, 
contain information about shapes and lines. ESD files require object/outline 
recognition if you want to perform object editing in EmbroideryStudio.

Machine files

Different embroidery machines understand different languages. Each has its 
own control commands for the various machine functions. Before you can stitch 
a design, it must be in a format which can be interpreted by the machine. 
Machine or ‘stitch’ files are low-level formats for direct use by embroidery 
machines. They contain only stitch coordinates and machine functions. They are 
generally created on-the-fly when sending designs to machine. Or they are 
converted when saving to disk or memory stick.

Manual objects
When they are read into EmbroideryStudio, machine files do not contain object 
information such as outlines or stitch types, but present the design as a 
collection of stitch blocks called ‘manual objects’. Manual objects are created 
wherever machine functions – e.g. color changes or trims – are detected in the 
design. They have only general and connector properties. Manual objects, in 
turn, consist of individual stitches, called ‘manual stitches’.

Object recognition
Machine files are generally not suited to modification because stitches are not 
regenerated. However, EmbroideryStudio can interpret object outlines, stitch 
types and spacing from stitch data with some success. In this way, you can 
re-constitute old tape format files and other machine file formats for 
modification in EmbroideryStudio. These ‘recognized’ designs can be scaled with 
stitches recalculated for the new outlines. Processing is effective for most 
machine files but cannot produce the same level of quality as original outlines 
and may not handle some fancy stitches.
When you convert a machine file to design file format, EmbroideryStudio reads 
stitch data stitch-by-stitch according to the needle penetration points. It 
recognizes stitch types, spacing and length values, stitch effects, and can 
determine object outlines. Stitch types are assigned as Satin, Tatami, or 
Program Split depending on the pattern of needle penetrations.
With Tatami, EmbroideryStudio recognizes stitch spacing and length, and applies 
a random factor. If a design is converted from ESD format, Zigzag and Triple Run 
objects are also recognized. If an object is not recognized, it becomes (or 
remains) a manual object with general and connector properties only. As such, 
it will not scale well.

Manual objects with no
outlines and manual

stitches only
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Recognized object outlines and stitch values are stored as object properties in 
EmbroideryStudio. This means you can scale and transform recognized designs 
in the usual way. You can also change the stitch density of the whole or selected 
parts of a design, and/or of certain stitch types.

Opening without recognition
By default, machine files are converted to outlines and objects upon opening but 
you can also choose to open them without recognition. Designs opened in this 
way can be output for stitching in another format. Or you can edit stitches and 
add new elements. For such purposes, you do not need to retrieve information 
about how the design was created. 
You can scale machine files which have been opened without object/outline 
recognition. However, because the stitch count does not change, the density 
increases or decreases with the design size. Thus you should not scale machine 
files by more than ±10% or some areas may be too thickly or too thinly covered.

Note  With or without object/outline recognition, machine files can be saved in 
EMB format once they are opened in EmbroideryStudio.

Related topics
 Opening machine files in EmbroideryStudio
 Using embroidery disks 
 Supported Machine, File and Disk Types

File sources

While embroidery files are broadly classified as ‘design’ (outline) or ‘machine’ 
(stitch), EmbroideryStudio internally tags files as belonging to one of four types 
– native design (A), imported outlines (B), processed stitches (C), or imported 
stitches (D).

Native EMB designs as well as ART and JAN files are all ‘Grade A’ embroidery 
formats read and written by EmbroideryStudio. They are called ‘Grade A’ 
because they contain a complete set of design information in a single file – 

Original stitch design Scaled stitch design opened 
without object/outline recognition

Grade Description

 A Pure embroidery file created in EmbroideryStudio or similar software. These files 
contain objects, outlines and stitches.

 B Designs read from an outline format such as GNC and saved in ART / EMB / JAN 
format. Such designs cannot be read directly by EmbroideryStudio but once 
converted, they are treated as Grade B designs.

C Designs read from machine files – EXP, DST, PES, etc – where stitches have 
been converted to objects.

D Designs read from machine files where stitches have NOT been converted to 
objects.
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object outlines, properties, stitches, thread colors, thumbnail image, and 
comments. There are three other grades of embroidery file. It goes without 
saying that only Grade A files provide 100% perfect scaling and transformation. 

Note  For information about the source of a design file, refer to the Design 
Properties docker.

Related topics
 View design details in EmbroideryStudio

Opening machine files in EmbroideryStudio

If you want to scale a design, edit an outline or change a stitch type, then the 
design or selected elements must be first converted into ‘objects’. By default, 
machine files are converted to outlines and objects upon opening. Open options 
should reflect how the design was originally digitized, not how you want it now. 
Experiment with the settings to get the best results. 

Tip  To ensure object outlines, stitch types, stitch density and colors are correct, 
it is always a good idea to check and edit designs after conversion. To improve 
the quality of a machine file, it is sometimes better to edit stitches before 
conversion.

Opening machine files with or without object recognition

When you open machine files with object/outline recognition, you can set open 
options to determine how the design will convert. Options vary with the file type. 
Alternatively, by opening a machine file without object/outline recognition, you 
can output the design without change, edit individual stitches, and perform 
minor scaling and transforming actions without losing the original stitch 
information. Alternatively, you can process the whole or selected parts of a 
design after opening and editing. 

To open machine files with or without object recognition
1 Open a file from hard disk or read it from embroidery disk.

2 Select a machine file format from the Files of Type list and select the file to 
open.

Select format
Click 
Options

Select file
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3 Click Options. Depending on the file type selected, different options are 
available.

4 Select or deselect the Objects/Outlines checkbox.
Remember, when you open machine files without object/outline recognition, 
‘manual objects’ are created wherever machine functions – e.g. color changes 
or trims – are detected in the design. They have only general and connector 
properties. 

5 Select a different machine format from the Machine Type list as required.
The machine type will default to one suggested by the file format – e.g. DST 
will be interpreted as Tajima. However, you can choose to convert the file to 
a different machine format – e.g. Barudan.

6 Enter the number of jumps to recognize as trims.
When EmbroideryStudio encounters this number of consecutive jumps, it will 
convert them to a Trim function. If this value is different from the original 
design, Trim functions will be not be inserted correctly.

7 Use the Stop Code as panel to select the output type for stop codes:

8 Toggle the Automatic Connectors checkbox as required.

9 Check the status of your embroidery machine. Then select the correct setting 
– Speed1 or Speed2 – from the list (if available).
On some Barudan machines there is a speed switch. Depending on its 
position, fast is assigned as either Speed1 or Speed2. For example, if you 

Option Purpose

Color change Stop codes are interpreted as ‘Next Color’ commands. The next color 
is selected from the default color palette.

Stops Stop codes are interpreted as ‘Explicit Stop’ commands. The machine 
stops stitching.

Custom Lets you map thread colors to every stop code in the file. This means 
you can color code machine files which do not contain needle 
addressing information. See Reassigning colors to machine files for 
details.

Option Purpose

On Open appropriate designs with automatic connectors without having to 
use object/outline recognition.

Off Open designs with connectors recognized as manual objects. This 
avoids stitch editing problems caused by automatic connectors – 
recommended for open fills.

Choose whether to recognize
objects/outlines in the design

Select machine
format

Select output type
for stop codes

Enter number of 
jumps as trims
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select Speed1, each fast speed function will be translated into a Speed1 
command.

10 Click Advanced to set advanced recognition options.
11 Click OK and then Open.

If you have ticked the Objects/Outlines checkbox, the design is processed 
and converted to embroidery objects with fill or outline stitch properties as 
well as general and connector properties. If an object is not recognized, it 
becomes a manual object with general and connector properties only.

If you have opened without recognition, you can output the design without 
change or perform minor scaling and transforming actions without losing the 
original stitch information. Alternatively, you can process the whole or 
selected parts of a design after editing.

Related topics
 Machine Formats
 Recognizing object outlines
 Adjusting stitch densities
 Using embroidery disks
 Conversion of Gunold PCH format to Wilcom EMB
 Conversion of Wilcom INP format to Wilcom EMB

Adjusting advanced recognition settings

You can fine-tune how EmbroideryStudio converts machine files using advanced 
recognition options. By default, EmbroideryStudio converts stitches as Tatami, 
Satin, or Run stitches according to the settings in the Recognition - Advanced 
Options dialog. You can change these values, or choose not to convert certain 
stitch types at all. Generally, the default settings provide the best results for the 
most frequently used fill styles – Tatami and Satin – their properties – stitch 
length and spacing – and edge effects, such as stitch shortening. Default 

Select required speed

Design opened without recognition – 
manual objects only

Design opened with recognition – mixed 
embroidery and manual objects
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settings, however, cannot always guarantee the best results as the variety of 
embroidery designs is virtually unlimited.

To adjust advanced recognition settings
1 Access the Open Options dialog and click Advanced.

The Recognition - Advanced Options dialog opens.

Original design opened 
without stitch recognition

Opened with stitch recognition –
pattern splits recognized as

Tatami

Select to
recognize Tatami

stitches

Select to
recognize Satin

stitches

Select to
recognize Run

stitches

Select to 
recognize Jagged 
Edges

Select to 
recognize Splits

Set space and
stitch length

rounding

Select Segments 
Resolution and 
Merging Factors

Select to recognize
random needle

penetrations
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To adjust Tatami recognition settings
 In the Tatami panel, select Recognize Tatami in order to process tatami 

fills, and adjust conversion options:

To adjust Satin recognition settings
 In the Satin panel, select Recognize Satin in order to process satin 

stitching, and adjust stitch spacings as required. If the row spacing falls 
outside the specified range it will not be converted to satin.

Option Purpose

Stitch spacing Enter spacing range to recognize. If the row spacing falls outside this 
range it will not be converted to tatami.

Min stitch 
length

Enter minimum stitch length to recognize as tatami.

Random factor Select to allow for random needle penetrations. Tip: Deselect the 
Recognize Splits checkbox to detect Random Factor more 
accurately.

Tatami Spacing range 0.4 mm 
to 1.5 mm, Random Factor not 
selected

Tatami Spacing range
0.4 mm to 1.5 mm,

Random Factor selected

Spacing range 0.5 mm 
to 5.0 mm

Spacing range 0.1 mm
to 2.0 mm
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To adjust Run recognition settings
 In the Run panel, select Recognize Run in order to process run stitching, 

and adjust conversion options as required:

To adjust Complex Fill recognition settings
 In the Parameter Consistency panel, set options for Complex Fill segment 

recognition:

For example, if the Tatami minimum stitch length is 4 mm, and the Stitch 
Length Rounding is 0.4 mm, stitches from 3.80 to 4.20 mm are ‘snapped’ 
to 4.0 mm, and recognized as Tatami.

Option Purpose

Max stitch length Enter maximum stitch length to recognize.

Length variation Enter percentage by which stitch length can vary in run objects.

Option Purpose

Spacing rounding Enter rounding value for stitch spacings – ‘snaps’ spacing values in 
Tatami and Satin fills to specified increments.

Stitch length 
rounding

Enter rounding value for stitch lengths – ‘snaps’ stitch length values 
in Tatami fills to specified increments.

Max stitch length: 4 mm
Length variation: 10%

Max stitch length: 4 mm
Length variation: 90%

Tatami Spacing range: 0.4 mm to 1.5 mm, 
Spacing Rounding: 0.01 mm, 
Stitch Length Rounding: 0.2 mm

Tatami Spacing range: 0.4 mm to 1.5 mm,
Spacing Rounding: 0.05 mm,

Stitch Length Rounding:0.5 mm
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To adjust stitch effects recognition settings
 In the Effects panel, select Jagged in order to recognize the Jagged Edge 

effect. Specify a minimum range in millimeters – anything variation greater 
than this value will be recognized as Jagged Edge.

 In the Splits panel, select Recognize Splits to recognize splits in tatami fills, 
and adjust conversion options as required:

Tip  Program splits are reliably recognized when patterns are not overlapping. 
Split patterns can be complex, so the recognition process can take up to five 
times longer with this option.

Option Purpose

Program splits as 
user defined splits

Recognize split patterns as user-defined splits. Note, however, that 
user-defined splits are scaled when the design is scaled. This 
results in stitch lengths getting longer as the design is enlarged, 
thus limiting scaling. With native program splits, on the other hand, 
patterns – shape, size and spacing – remain the same after objects 
are scaled.

Recognize auto 
splits

Recognize Auto Splits in Satin objects. Otherwise, patterns created 
with Auto Split will be recognized as Tatami.

Recognition level Restrict recognition of Program Splits by increasing percentage. 
Decrease to increase recognition. A low percentage number will 
detect more areas as Satin with User Defined Split than Tatami.

Jagged selected, border object
recognized as jagged edge

Jagged not selected, border 
object recognized as manual

User Defined Split

Auto Split
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To adjust segment recognition settings
 In the Segments Resolution/Merging Factors panel, enter values to 

fine-tune the recognition of segments and objects:

Tip  Generally, the lower these values, the larger the number of 
segments/objects likely to be identified. Normally you want to obtain design 
information with a minimum number of identified segments/objects. In 
practice there is always a compromise between design recognition quality and 
the minimum number of correctly identified segments/objects.

 Click OK.

Tip  To revert to the original conversion settings, click Reset.

Related topics
 Opening machine files with or without object recognition

Reassigning colors to machine files

When you open a machine file or CND file, a design without color code 
assignment automatically uses the default color palette. You can, however, map 
thread colors to every Color Stop code in the file. This means that before 

Option Purpose

Spacing This value expresses the ratio between stitch spacings in adjacent stitch 
blocks – e.g. adjacent spacings of 0.6 mm and 1.0 mm gives a ratio of 
1.67. A value of 2.0 in the Spacing field means that these stitch blocks will 
be recognized as one segment or object. A value of 1.5 means that they 
will not. The default value is 3.0. Normal Satin and Tatami stitching ranges 
in spacing from 0.3 to 0.6 mm, so most continuous sections of stitching of 
the same type will not be split. To preserve spacing variations for 
color-blended designs and more artistic designs, you may need to reduce 
the spacing factor. In manually punched designs which include stitching 
with irregular spacing, segment breaks can be reduced by increasing the 
factor.

Height This value expresses the ratio between heights of stitch blocks. It is 
important in recognizing Complex Fill shapes, particularly with holes.

Recognized objects 
shown in different colors

Spacing: 0.5 mm, 
Height: 2 mm

Spacing: 3 mm,
Height: 4 mm
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opening the file you can color-code designs which do not contain needle 
addressing information.

Note  In order to assign colors correctly, you need to consult a production 
worksheet for the necessary color sequence information.

To reassign colors to a machine file
1 Select File > Open. The Open dialog opens.
2 Select a machine file or CND design and click Options.

If you’ve selected a machine file, the Open Options dialog opens. If CND, 
the Condensed File Input Settings dialog opens. This procedure is the 
same.

3 Select Custom and click Define Stop Sequence.

Without color code 
assignment

With color code 
assignment

Select Define Stop 
Sequence

CND file

Machine file

Select Define Stop 
Sequence
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The Define Stop Sequence dialog opens. Initially the Building Stop 
Sequence grid is empty.

4 Select a thread chart and first color.

5 Click Assign Color. The color and the description are entered at the current 
Stop in the Building Stop Sequence grid.

Note  The selection moves to the next color in the thread chart. Two 
consecutive same colors are not allowed and Assign Color is disabled.

6 Click Assign Stop to enter an explicit Stop code.
Stop is entered in the Description field.

Select thread
chart

Select color

Click to
assign color

Click to
assign stop
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Note  A Stop Sequence Warning message displays if a redundant color 
function is assigned. Press Delete to delete a selected entry in the stop 
sequence. Click Reset to delete all the entries.

7 Use the Extra Stop codes as panel to select the output type for extra stop 
codes:

8 Repeat the operation as many times as indicated in the production worksheet.
9 Click OK. The design will have the desired colors and the correct number of 

Color Changes.

Note  You can convert color changes to an explicit Stop Code. You can also 
remove Color Stops by assigning the same color number to consecutive color 
blocks.

Related topics
 Reading CND files with color-merge TXT file

Reading Melco CND design files

Melco Condensed (CND) is the native file format of Melco embroidery digitizing 
software. CND files store only digitized outlines and stitch values. When you 
open CND designs in EmbroideryStudio, these outlines are scaled and stitches 
recalculated to preserve density. EmbroideryStudio recognizes all Melco 
machine functions and stitch types, including Partition Lines and Complex Fill, 
and automatically converts them to EMB format. However, CND files do not 
contain specialty features such as Pull Compensation or Auto Spacing, nor do 
they include actual stitches, thread colors, or design icons.

Converting CND files to EMB

There are several versions of CND, all of which can be read by EmbroideryStudio. 
While these designs scale accurately, the number and placement of stitches may 
differ somewhat from the original design. You may notice some difference 
(±10%) in the stitch counts between original and converted files. This is because 

Option Purpose

Color changes Extra Stop codes are interpreted as ‘Next Color’ commands. The next 
color is selected from the default color palette.

Stops Extra Stop codes are interpreted as ‘Explicit Stop’ commands. The 
machine stops stitching.

Repeat 
sequence

If you select fewer colors than the design requires, the selected colors 
are repeated. For example, if your design requires four colors and 
you’ve only selected two in the Building Stop Sequence list, colors 3 & 
4 will be the same as original colors 1 & 2.

Choose how 
extra stops are 
to be interpreted
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of differences in the software methods used to calculate stitches. 
EmbroideryStudio cannot interpret certain specialty features of CND design 
objects because there is no direct equivalent. However, stock designs do not 
normally use these features and will generally convert without problem.
When you open Melco CND files, the Melco stitch types used in the design are 
converted to EmbroideryStudio stitch types – satin, run, tatami, etc. You can 
change conversion settings to adjust spacing, stitch length, effects and defaults 
applied to EmbroideryStudio stitch types. You can also set scaling values to open 
the design at a different size to the original.

To convert a CND file to EMB
1 Open the file from your hard disk, or read it from tape or embroidery disk.

2 Select the Melco (CND) file to open and click Options. The Condensed File 
Input Settings dialog opens.

3 In the Scale Factor panel, enter the scale at which you want to open the 
design.

Select CND
format

Select file

Select Auto
Color Merge

option

Enter scale
values

Adjust stitch
values

Select effects 
to apply

Adjust default 
values
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New dimensions are expressed as a ratio of the original design size. For 
example, to scale to 120% of the original, enter a scale factor of 1.2 in each 
field.

4 In the Adjust panel, enter spacing and length values to apply to the design 
as a percentage of original values. You can adjust satin spacing, run stitch 
length as well as tatami spacing and length.

5 In the Auto Color Merge panel, choose whether you want to read thread 
color information from CND files. This ensures that stitches are displayed in 
the correct colors when converted to EMB. 

6 In the Effects panel, select the effects you want to apply to the design. 
For information about these, see the relevant sections of the manual:

7 In the Default Values panel, adjust the default values for Satin Spacing, 
Stitch Length and Maximum Stitch Length as required.
If the CND design was created with values different to the factory settings, 
you can override them in these fields.
 To save new settings as defaults, click Save.
 To revert to the Melco factory settings, click Reset.

8 Click OK and then Open.
The selected design opens in the design window. You can scale the design 
directly on screen or via the Object Properties docker. You can also rotate, 
mirror and skew the design.

Option Purpose

Auto spacing Auto Spacing automatically adjusts stitch spacing wherever a column 
changes width. See Applying satin stitch for details..

Short stitches Standard stitch spacing is calculated at the outside edge of a shape. 
With sharp curves, spacing which provides adequate coverage on the 
outside edge may cause bunching along the inside edge. Stitch 
shortening reduces the length of some stitches in sharp turns so that 
the needle penetrations are distributed evenly, creating smoother 
stitching. See Applying stitch shortening for details.

Fractional 
spacing

With Fractional Spacing, EmbroideryStudio calculates spacing 
settings from a specified point called the offset fraction. This lies 
between the outside and inside edges of the shape. You can change 
the offset fraction to adjust stitch spacing at inside and outside edges. 
See Applying fractional spacing for details.

Scale Factor 
X: 1.00
Y: 1.00

Scale Factor 
X: 0.50
Y: 1.00
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Tip  Before CND designs are stitched out, an EXP format file is created. The 
EXP stores the actual stitches and can be stitched directly. This file too can be 
opened in EmbroideryStudio.

Related topics
 Conversion of Melco CND format to Wilcom EMB
 Saving designs in Melco CND format
 Reassigning colors to machine files
 Opening machine files in EmbroideryStudio
 Saving designs in Melco CND format

Reading CND files with color-merge TXT file

While CND files contain no thread color information themselves, the Auto Color 
Merge feature can read thread colors for CND files from an associated TXT file. 
Thus stitches are displayed in the correct colors when they are converted to 
EMB. Auto Color Merge reads and interprets a TXT file containing colors from 
a named thread chart. You must specify the thread chart used when the design 
was originally created in EDS (or other design software). 

To read CND files with color-merge TXT file
1 Select File > Open. The Open dialog opens.
2 Select a CND design and click Options. The Condensed File Input 

Settings dialog opens.

3 Select From File in the Auto Color Merge panel, and select a corresponding 
thread chart from the Auto Color Merge droplist.
Any thread color named in the text file must correspond to a color in the 
selected thread chart. If not, it will default to black.

4 Click OK.

Select thread
chart
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The design opens, the stitches appear in the correct thread colors, and the 
color palette displays the selected thread chart.

Related topics
 Reassigning colors to machine files
 Creating a color-merge TXT file

Creating a color-merge TXT file

Auto Color Merge reads and interprets a TXT file containing colors from a 
named thread chart. You can create this text file manually with a text editor such 
as MS Notepad. The text file must have the same file name as the CND file – e.g. 
Fish.TXT and Fish.CND. Both files must reside in the same folder. For the Auto 
Color Merge function to work correctly, information in the text file must be 
entered in a certain format. A typical text file might look like this:
Fish
Uses curve effects
File: Fish
55.9mmW X 74.5mmH
ST: 6,780
Colors: 8
1. Tropical Sunset
2. Saffron
3. Pale powder Blue
4. Tropical Sunset
5. Pale powder Blue
Curve effect
6. Tropical White
7. Tropical Sunset
8. Pale powder Blue

Text file structure
All text files contain some or all of the following elements.

No chart selected – default 
colors assigned

Original colors correctly 
assigned from text file

One color not correctly matched – 
defaults to black

Txt file item Mandatory Description Example

Design name This is the name of the design as it 
appears in File > Information > Design 
Properties > Subject.

Fish

Comments Lines inserted here appear under File > 
Information > Design Properties > 
Comments.

Uses curve effects

File name


This is the file name of the CND design 
file. The file extension should not be 
included.

File: Fish

Design size Enter the expected design size for the 
design. The actual design size is 
derived from the software.

55.9mmW X 
74.5mmH
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Stitch count Enter the expected stitch count for the 
design. The actual stitch count is 
derived from the software.

ST: 6,780

Number of colors


States the total number of colors in the 
design.

Colors: 8

Thread name 1



Enter the first thread name. The name of 
the thread is searched against the 
Thread Chart. The thread name is 
shown in the File > Design Properties > 
Stop Sequence tab.

1. Tropical Sunset

Thread name 2  Enter the second thread name. 2. Saffron

Thread name 3  Enter the third thread name. 3. Pale Powder Blue

Thread name 4  Enter the fourth thread name. 4. Tropical Sunset

Thread name 5  Add any extra threads to this list. 5. Pale Powder Blue

Thread 
comments

Place comments below the relevant 
thread number.

Curve effect

Thread name 6  6. Tropical White

Thread name 7  7. Tropical Sunset

Thread name 8  8. Pale Powder Blue

Txt file item Mandatory Description Example
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Chapter 42

Outputting Designs for Production

Once an embroidery design is complete, you can output for actual stitchout in a 
variety of ways – sending directly to machine for stitching, or saving to specific 
machine formats and/or to embroidery disk.

EmbroideryStudio provides alternative means for sending designs directly to 
machine. Depending on your software options, you can stitch to machine using 
Stitch Manager, Machine Manager, or Connection Manager. Machine 
Manager is described in a separate Machine Manager Supplement.

Tip  From the same design file, you can also output a production worksheet for 
the embroidery machine operator. See Printing design reports for details.

Sending designs to machine

Newer machines use USB or Wired-Wireless network connections. 
EmbroideryStudio supports these connections via the Connection Manager. 
Older-style machines generally use serial port connections. EmbroideryStudio 
supports connection to these machines via the Stitch Manager. 

Note  Machine Manager and its operations are described in a separate 
Machine Manager Supplement.
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Sending designs to Connection Manager

Newer machines use USB or Wired-Wireless network connections. They can 
appear as a disk drive or be setup to read designs from a folder on the PC. Some 
machines such as Janome MB-4 and Barudan LEM are supplied with propriety 
connection software. EmbroideryStudio supports connection to these machines 
via Connection Manager. Each machine connection:
 Has a unique name and ‘quick-access’ button
 May have a unique folder to which designs can be sent. From here they can 

be accessed from the machine control panel or third-party connection 
software.

To send a design to Connection Manager
 Ensure that the target machine is correctly connected to your PC. See your 

machine documentation for details.
 If a connection already exists, click the quick-access button to send the 

design to a predefined location.

 Alternatively, click the Send to Connection Manager icon. If a connection 
already exists, the Send to Connection Manager dialog opens. If no 
connections currently exist, you will be prompted to set one up. See Setting 
up machines for Connection Manager for details.

 Select a connection from the droplist and click Send.
 Using the machine controller or third-party connection software, access the 

design from the network or PC folder.
 Load or send the design and stitch it on the machine.

Related topics
 Setting up machines for Connection Manager

Use Standard > Send to Connection Manager to connect to supported machines 
via proprietary machine software.

Quick access button
for existing machine

connecton

Click to set up another 
connection

Select a
connection

Click to send
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 Supported Machine, File and Disk Types

Sending a design to WiFi USB Stick

Once configured, the device can then be connected to machine where it will 
monitor the shared folder and transfer designs via wireless network to machine 
memory.

Sending a design is as simple as clicking the associated machine icon on the 
Standard toolbar. This can also be done directly from Design Library by 
selecting single or multiple designs and clicking the icon.

When designs are sent to a shared folder, the associated WiFi USB Stick on the 
machine detects and uploads the designs. These are then visible on the machine 
control panel and are accessed the same way as a normal USB stick.

Note  The WiFi USB Stick can hold up to 16MB of stitch data. It is only intended 
for production, not general storage. You will need to clean out the associated 
shared folder periodically to stop the WiFi USB Stick filling up with unwanted 
files.

Related topics
 EmbroideryConnect Machine Networking

Sending designs to Stitch Manager

Once a design is complete, you can stitch it out to any supported embroidery 
machine without changing design format. If a selected machine does not 

Connect device to 
machine

Click to send 
design to machine

Use Legacy Features > Send to Stitch Manager to send a design to any supported 
embroidery machine without changing the original design format.
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support a particular function included in the design, it is simply ignored. When 
you send several designs in a row, they are automatically queued and stitched 
out one at a time. 

To send a design to Stitch Manager
1 Ensure that the target machine is correctly connected to your PC. See your 

machine documentation for details.

Note  Before you can send designs for stitching, you must also configure the 
machine in EmbroideryStudio.

2 Open a design.
3 Click the Send to Stitch Manager icon. The Send to Stitch Manager 

dialog opens.

4 From the Machine Identification list, select an embroidery machine. Click 
Setup to modify machine settings as required.

5 From the Output as Machine format list, select the correct machine format. 
Click Values to modify the machine format settings as required.

Note  This field is automatically updated if the target machine format is 
different to the current format. Select the Prompt Changing Machine 
Format checkbox if you want to be prompted when the Output as Machine 
Format field updates.

6 Click OK to return to the Send to Stitch Manager dialog.
7 Click OK. The Stitch Manager dialog opens listing the files to be stitched 

out.

Tip  To delete a design from the queue, select it and click Cancel.

Related topics
 Hardware Settings
 Setting up machines for Stitch Manager
 Machine formats
 Standard machine formats
 Supported Machine, File and Disk Types

Select embroidery
machine

Select machine
format
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Exporting designs for machine

Different embroidery machines understand different languages. Each has its 
own control commands. Before you can stitch out a design, it must be in a 
format which can be interpreted by the machine. Machine or ‘stitch’ designs are 
low-level formats for direct use by embroidery machines. They contain only 
stitch coordinates and machine functions. They are generally created on-the-fly 
when sending designs to machine. Or they are converted when saving to disk or 
memory stick.

Note  The Design Library conversion function allows you to batch-convert to 
and from all EMB and other supported design file types. It also batch-converts 
many machine file formats such as DST, EXP, SEW. See also Converting designs.

Exporting designs to machine file

Converting an open design to machine file format is as simple as choosing File 
> Export Machine File. EmbroideryStudio reads and converts all popular 
formats. Designs originally created in EmbroideryStudio generally give the best 
results. Other file types may not have all the data necessary for successful 
conversion.

For older machines, you can also save designs to proprietary embroidery disk. 
See Using embroidery disks for details.

Caution  If a design feature is not available in the file type you select, it will be 
converted – e.g. Flexi Split stitching may be changed to plain Tatami.

Related topics
 Machine Formats
 Converting designs
 Sending designs to Connection Manager
 Using embroidery disks
 Supported Machine, File and Disk Types

Use Standard > Export Machine File to export the current design to a machine file 
for stitching.

Choose a machine 
file format
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Saving designs in Melco CND format

You can save files to Melco CND format from EmbroideryStudio. Some stitch 
quality features, stitch types, and decorative fills and effects do not convert well. 
If you intend to save a file in CND format, you should only use input methods, 
stitch types and effects that are compatible with Melco EDS-III software.

Trim functions
Superstar-compatible machines do not have trimmers. If you want to stitch a 
design to a machine without trimmers, set machine values to not output Trim 
codes. Then digitize the design for manual trimming. Early versions of CND do 
not support Melco Trim codes. In this case, set the machine format values to 
output Trims as Jumps. 

Turning Tatami fills
When you save to CND format, you need to specify how to convert turning 
tatami stitches. Objects with curving tatami stitches – e.g. Column A objects – 
are not supported by early versions of CND format. For Superstar-compatible 
machines, turning tatami stitches are simply converted to Walk stitches, the 
EDS equivalent of Manual. For earlier machines, turning tatami fills need to be 
converted to normal tatami – i.e. with a single stitch angle – then to Normal Fill, 
the EDS equivalent of normal tatami.

To save designs in Melco CND format
1 Select File > Export Machine File. The Export Design dialog opens.

2 Choose Melco CND from the Files of Type list.
3 In the File name field, enter a name for the design.
4 Click Options. The Save Options dialog opens.

Choose Melco CND 
file format

Select required 
option
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5 Select the required option for converting Turning Tatami fills:

Note  These functions are also available when you send a CND design for 
stitching.

6 Click OK and then Save.

Related topics
 Standard machine formats
 Melco CND format
 Conversion of Melco CND format to Wilcom EMB.

Saving designs in Singer CSD format

The CSD Save Options allows you to select between CSD Type I and Type II.

To save designs in Singer CSD format
1 Select File > Export Machine File. The Export Design dialog opens.

2 Select CSD from the Files of Type list.
3 In the File name field, enter a name for the design.
4 Click Options. The Save Options dialog opens.

5 Select the required CSD file type option.

Option Purpose

Superstar 
Compatible

Converts turning tatami to Walk (EDS equivalent of Manual). 
Complex Fill tatami is output as Normal Fill (EDS equivalent of 
tatami). Superstar-compatible machines do not have trimmers. 

Output Tatami as 
Complex Fill

Converts turning tatami fills to normal tatami – i.e. with a single 
stitch angle – then to EDS Normal Fill.

Choose Singer CSD 
file format

Select CSD file 
type option
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 Type II was introduced in CS 1.2B software for the POEM machine. 
 Type II is also used by the Singer EU software for the POEM machine. 
 Type II files also store thread color RGB values and an icon of the design.

6 Click OK and then Save.

Related topics
 Opening machine files in EmbroideryStudio

Using embroidery disks

Paper tape is the traditional medium for storing designs in stitch data format. 
Embroidery disks, which largely replaced paper tape, are specially formatted 
floppy disks used to transfer designs from computer to older embroidery 
machines. You can format embroidery disks and save designs to them from 
within EmbroideryStudio. The format you use will depend on the machine. 
Designs are generally stored in stitch data format, although Melco CND, for 
example, is a ‘condensed’ file format. 

You can also open designs from embroidery disks of various formats directly into 
EmbroideryStudio. Once read, you can output them without change, modify 
them and output them in the original format, or save them as EMB file. You can 
optionally convert them into objects. After conversion, a design can be scaled 
and changed. See also Opening machine files in EmbroideryStudio.

Reading designs from embroidery disk

You can open designs of other formats from specially formatted 1.44 Mb DS/HD 
(Double-Sided High-Density) embroidery disks.

To read designs from embroidery disk
1 Insert the embroidery disk in your computer’s floppy disk drive.
2 Select Embroidery Disk > Open. 

Use Legacy Features > Embroidery Disk to open designs from or save to 
proprietary embroidery disk formats.

Select ‘Open’
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The Open Embroidery Disk dialog opens.

3 From the Look In list, select the floppy disk drive.
4 Select the disk format. Either:
 Select the format from the Diskette Format list.
 Select the Auto Detect checkbox and let EmbroideryStudio automatically 

determine the format. This generally takes longer.
5 Click OK. The Open From Embroidery Disk dialog opens.

6 From the Designs of Type list, select a design type. Any designs saved on 
disk are listed in the panel. If no designs are listed, make sure that the correct 
drive and disk format are selected.

Note  If the Options button is available, you can set recognition options for 
the design.

7 Click Open.

Related topics
 Supported embroidery file formats
 Melco CND format
 Conversion of Gunold PCH format to Wilcom EMB
 Opening machine files with or without object recognition

Formatting embroidery disks

Embroidery disks must be formatted to suit the embroidery machine you intend 
to use or it will not be able to read the design. Older computers generally have 
a High Density 1.44 Mb drive. Most embroidery machines use High Density disks 

Select drive

Select format

Select design 
type 

Use Legacy Features > Embroidery Disk to format proprietary embroidery disks.
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so there is usually no problem with transferring designs. See your machine 
manual for details.

To format embroidery disks
1 Insert a 3.5" floppy disk of the correct density in your computer’s floppy disk 

drive. 

Note  Use the disk type required by the embroidery machine, not the 
computer.

2 Select Embroidery Disk > Format. 

The Format Embroidery Disk dialog opens.

3 From the Drive list, select the floppy disk drive. 
4 From the Diskette Format list, select the required disk format.
5 Click OK to confirm. The Format dialog opens. This is a MS Windows® 

system dialog and may vary with the particular operating system you are 
using.

6 From the Capacity list, select the disk storage capacity.
7 In the Format Options panel, select the ‘full format’ option. Quick Format 

erases all data from the disk but does not reformat it. Uncheck the option to 
reformat a blank disk. See your MS Windows® manual for details.

8 Click Start. A progress bar appears. You are prompted when formatting is 
complete.

Select ‘Format’

Select drive

Select format

Select storage capacity

Uncheck quick format
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Note  If you have trouble with formatting a Melco embroidery disk, check if 
your floppy disk drive can read and write single density floppy disks.

Writing designs to embroidery disk

Save designs to embroidery disk to stitch out on a specific machine. When you 
save to a new format, the design is converted to encode the machine functions 
and commands supported by the particular machine.

To write designs to embroidery disk
1 Insert the embroidery disk in your computer’s floppy disk drive.
2 Select Embroidery Disk > Save As. 

The Save to Embroidery Disk dialog opens.

3 From the Look In list, select the floppy disk drive.
4 Select the disk format. Either:
 Select the format from the Diskette Format list.
 Select the Auto Detect checkbox and let EmbroideryStudio automatically 

determine the format.
Any designs already saved on disk are listed in the panel.

Note  If the disk is not formatted, or its format is not correct, click Format. 
5 In the Design Name field, enter a name for the design.
6 In the Filename field, enter a name for the design file.

7 If the Number field is enabled, enter a file number.
Not all machine formats require this information. This option is greyed out if 
the file naming mechanism is not supported by the particular embroidery disk 
type. Tajima uses a free-form file name, so both a numbering system and a 
text file name system are supported, as seen in the dialog.

Use Legacy Features > Embroidery Disk to open designs from or save to 
proprietary embroidery disk formats.

Select ‘Save As’

Select drive

Select format

Enter file number
if required

Enter design name

Enter file name

Click to view or 
modify settings

Enter machine
format and

design file type
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8 From the Machine Format list, select a machine format.
Some machines can read different formats. For example, some Tajima 
machines can read Barudan as well as Tajima. 

Tip  To view or modify machine format settings, click Values. 
9 From the Design Type list, select the file type to save to embroidery disk. 

Only one file type is generally available.
10 If available, select the Save Icon checkbox to include a thumbnail image of 

the design with the design file.
This icon appears in the machine control panel during stitch-out.

11 Click Save.

Caution  Wait until the light on the floppy disk drive stops flashing before 
removing the disk.

Related topics
 Standard machine formats

Exporting multiple decoration files

EmbroideryStudio allows all multi-decoration components to be exported as file 
formats suitable for the particular process or machine. Apart from embroidery, 
EmbroideryStudio supports design output for a number of related and 
sometimes complementary decoration processes. Namely, bling (rhinestone) 
designs, printed designs, as well as appliqué designs.

The Export Multi-Decoration Files capability allows you to output 
multi-decoration components for the various processes needed. It can provide:
 Direct input to required machines – the most efficient method – or
 A file format which can be used by the machine’s supporting software.
This feature is accessed via a menu command in both Wilcom Decoration and 
CorelDRAW Graphics:
 File > Export Multi-Decoration Files
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For machines that are supported via direct connection, there are two 
commands:
 File > Send to Appliqué Cutter
 File > Send to Bling Cutter
In order to output all components of a multi-decoration design, it may be 
necessary to use more than one of these commands.

Print designs

In the context of multi-decoration design, a portion may need to be output to a 
printing process for inclusion on the article. This component may be referred to 
as ‘print’ or ‘graphics’. The most commonly used commercial printing processes 
are:
 Direct-to-garment (DTG)
 Sublimation
 Screen printing
 Heat-transfer printing

Direct-to-garment
Direct-to-garment printing is handled like most other printing from a PC: The 
print image is sent to the DTG printer through the MS Windows® print manager 
via a print driver. The image must have a transparent background for DTG 
printing. DTG printing requires heat fixing to make the images washable.

Sublimation
Sublimation printing is similar to DTG printing but the process uses solid inks 
which give a more even gradation of color compared to the liquid inks used in 
DTG printing. With sublimation printing, inks are printed onto a release paper 
and then transferred to fabric or other surface.
Sublimation means a change from a solid to gaseous state and back to a solid 
without becoming liquid. Thus dye particles migrate from the paper as a gas, to 
bond with a polymer – fabric or other material – and become solid again. The 
transfer is effected using high heat (205°C) and pressure, thus guaranteeing 
that the image penetrates and becomes an integral part of the substrate.

Screen printing
Screen printing is a more complex process, requiring the creation of a screen for 
each of the spot colors (Pantone) that make up the design. There may be 
multiple screens for each spot color, depending on how the design is layered.

Heat-transfer printing
A fourth process, which is less likely to be used in the production of a printed 
design for commercial use, employs heat transfer paper to which graphics are 
printed. This is then heat-fixed to a garment using an iron or heat-press. The 
process falls into the same category as printing. Printers that support heat 
transfer media in most cases provide an automatic mirror function in the printer 
driver as the image must be printed in reverse in order to be heat-transferred 
to a garment.

Related topics
 Outputting designs as graphics
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Appliqué designs

Appliqué is a decoration or ornament made from cut pieces of one material 
applied to the surface of another. Pieces may be fixed to one another using an 
embroidered border of satin, raised satin, or none. Appliqué cutting is supported 
in EmbroideryStudio by outputting vectors that describe the appliqué material. 
The information can be sent directly to a supported MS Windows® cutter or 
output to printed templates for manual cutting of appliqué shapes.

Related topics
 Appliqué Digitizing

Bling designs

Bling, rhinestones, crystals, and glitz are interchangeable terms referring to 
decorative objects placed on garments or templates. They are supplied in 
various sizes, shapes, colors and materials. There are two basic processes for 
creating bling designs:
 Hot-fix template production
 Direct-to-garment production

Hot-fix template production
Hot-fix templates can be produced in two ways:
 Bling transfer: In a semi-automatic process, bling is placed directly onto 

transfer tape (or sheet) by machine. Examples are IOline CrystalPress and 
CAMS machines. The bling design is ready for heat transfer to the final 
product – e.g. a T-shirt.

 Bling template: This is the design layout on which rhinestones are initially 
placed prior to transfer. The template is created by cutters or engravers. 
Rhinestones are placed onto the template by a manual flood-fill process and 
then manually transferred to transfer tape.

Direct-to-garment production
Direct-to-garment production is supported by various machines such as the 
RhinestoneMachine.com Libero, Hirsch GemFix, Dairo Machine Company DK 
series (in particular the DK2400Auto) and others.

Tip  Bling designs can be saved to earlier versions of EMB. However, bling 
objects will convert to vector objects.

Related topics
 Bling Digitizing
 Sending bling to CAMS machine

Exporting design components

The Export Multi-Decoration Files capability allows you to efficiently produce 
output files for multi-decoration designs. The system recognizes whether a 

Use Standard > Export Multi-Decoration Files to export all design components 
requiring different production processes.
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component is embroidery, graphic, appliqué, or bling. This, in turn, helps to 
increase the profitability of ‘quantity 1’ articles. It can provide:
 Direct input to supported machines, as this is the most efficient method, or
 A file format which can be used directly by the machine’s supporting software.

Note  If the printer, appliqué, or bling machine is directly supported, this 
procedure is not required. For example, cutting appliqués or outputting bling 
templates have their own procedures.

To export design components
1 Open the multi-decoration design you want to output.
2 Click the Export Multi-Decoration Files icon.

3 Select Export Current Design if you want to output all design objects.
This is the default option and, unless you have pre-selected certain objects 
for inclusion, the only option.

4 Optionally, select the multi-decoration components you want to export by 
ticking the relevant checkbox in the Elements pane.

5 If you have selected Bling as one of your export components, optionally 
select Multiple Files or Single File.

Output all available
design objects

Optionally, select
specific design

components

Adjust export location
as necessary

Name export files if
different to design file

name
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When Multiple Files is selected, different bling types – i.e. by size, color, 
and/or shape – will be output to separate files. Multiple file output is 
important for the manual flood-fill method of creating rhinestone templates.

Tip  Depending on your cutting machine, you may choose to export cutting 
outlines only. Preset in the Bling Palette Editor. Bling objects exported this 
way retain color information, and cutting outlines have hairline width.

6 For each component, select required file types from the droplist. 
If you select an embroidery format, an associated Options button may be 
enabled. For bling, you can choose AI format for semi-automatic machines. 
For any other cutting machines, you can save directly to CDR format.

7 Optionally, click the Options button if available.
If no options are set, the system uses default options for each file format. If 
a selected file type is PNG, design components are exported with 
transparency on. Defaults are as follows:
 Color mode: RGB color (24Bit)
 Transparency: On
 Anti-alias: On
 Maintain aspect ratio: On
 Resolution: 300 DPI

1

2

3
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The default DPI setting can be changed via the CorelDRAW Options dialog.

8 Select an export location:
 Export to set locations (the default): preset locations for different files. 

In some production environments, each file is placed in a network location 
where it can be used by the operator of that process.

 Export to: specfiy a location for all files – e.g. external USB stick. Folders 
are rarely changed once established, but occasionally they may need to be 
adjusted or temporarily overridden. 

9 Optionally, enter a filename to be used by all selected multi-decoration 
components.
If no filename is entered, the system will use the design filename by default.

10 Click Export.
The system writes the all selected components to their selected location/s.
 If no file types have been selected, the Locations dialog will display. You 

can set default file types at this stage or cancel out.
 If files have the same file extension and location, filenames will be created 

with a component suffix.
 If a file/s already exists in target folder/s, the system will give you the 

option to overwrite, skip, or cancel the process.

 If the embroidery file output contains team names, the system will display 
the team names Output Option dialog.

Related topics
 Supported file formats
 Supported graphics and multi-decoration file formats

Change bitmap file 
export resolution as 
required
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 Outputting bling templates
 Cutting appliqué shapes
 Exporting multiple decoration files
 Setting export locations
 File naming conventions
 Setting up bling palettes
 Outputting teamname designs

Setting export locations

In some production environments, each file is placed in a specific location where 
it can be used by the operator of that process. For example, the Tajima Machine 
Network requires all files to be placed in a specific folder so they can be seen 
directly by the machine. Similarly, file formats used in any given process do not 
change unless the process changes – for example, if a machine is replaced. Use 
the following procedure when you want to set export defaults for the Export 
Multi-Decoration Files process.

To set export locations
1 Run the Export Multi-Decoration Files procedure.

2 To set or change the default multi-decoration file export settings, click the 
Locations button.

3 Select file locations via the browse (...) button for each design component.
4 Click OK to finish.

Once set, your settings are remembered for each successive session. 

Use Standard > Export Multi-Decoration Files to export all design components 
requiring different production processes.

Set default file export 
locations

Default file 
export locations
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Tip  Preset locations can be overriden for one-off exports – e.g. to USB stick 
– by means of the Export to option.

Related topics
 Exporting design components

Exporting selected objects

On occasion, you may want to export only selected objects from your 
multi-decoration design. The Export Multi-Decoration Files capability allows 
you to pre-select objects in the design window.

To export selected objects
1 Open or create a multi-decoration design.
2 Select the individual objects you want to export. In the example below, we 

will export only the word ‘DANCE’ without the underlying text.

3 Click the Export Multi-Decoration Files icon.

4 Select the Export Selected Objects Only option.

Override preset 
locations

Use Standard > Export Multi-Decoration Files to export all design components 
requiring different production processes.

Select ‘Export
Selected Objects Only’
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This checkbox will appear only if you have selected objects in the design 
window.

5 Make location adjustments as necessary and click Export.
Only selected objects are exported to file.

Related topics
 Exporting design components

File naming conventions

By default, the Design name field will take the current design name – e.g. 
‘Design1’. You can change it if you wish. This name is applied to all files exported 
with the Export Multi-Decoration Files dialog.

If exported files for any components have the same selected file extension and 
location, the file name will be automatically suffixed as follows:

Example
The single multi-decoration file – ‘Design1.EMB’ – contains embroidery, graphic, 
appliqué, and bling components. Depending on chosen file types, you will see 
file names of the following kind:

Bling multi-file output
When bling objects in a design contain rhinestones of different size, shape, 
and/or color, and the Multiple Files output option is selected in the Settings 
dialog, files will take a suffix of the following form:
 <filename>_SSx_<color>

Design Element Suffix

Embroidery _EMB

Graphics _GFX

Appliqué _APQ

Bling _BLG (for a single file)

Design Element File Type File Name

Embroidery Wilcom EMB Design1_EMB.EMB

Graphic CorelDRAW Design1_GFX.CDR

Appliqué AutoCAD Design1_APQ.DXF

Bling Adobe Illustrator Design1_BLG.AI

Default file name
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 <filename>_SSx_<color>_<shape_name>
 <filename>_<color>_<shape_name>_<XxY>
For example, consider a design with the following bling types:

Tip  The print preview shows which rhinestones are in which file.

Related topics
 Supported file formats
 Outputting bling templates

Bling type Output filename

Navette 8 x 4mm with color Emerald Design1_Emerald_Navette_8x4.PLT

Flower SS16 with color Crystal Design1_SS16_Crystal_Flower.PLT

SS04 with color Aquamarine Design1_SS04_Aquamarine.PLT
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Chapter 43

Hooping Designs

Devices made from wood, plastic, or steel, hoops are used to tightly grip fabric 
and stabilizer between an inner and outer ring. Designed to hold fabric taut 
against the machine bed for embroidering, they attach to the machine’s frame. 
Fabrics must be hooped before stitching out. EmbroideryStudio allows you to 
select from a wide range of standard factory-supplied hoops. You can also define 
your own from scratch or based on a standard hoop.

The Auto Hoop feature allows you to:
 Prompt EmbroideryStudio to select a hoop from a hoop library.
 Show/hide the selected hoop in the design window and design preview area 

of the production worksheet. See also Printing reports.
 Create/edit/delete user-defined hoops with circle, oval, rectangle, round 

rectangle, or square shapes.
 Zoom-to-hoop in the design window and print preview.

Hoops & templates

When it comes to stitching out, it is important to align the fabric squarely in the 
hoop, with even pressure on all sides, and fabric patterns and weaves running 
perpendicular to the hoop. Otherwise, fabric bias allows stretch. This can distort 
stitching and result in puckering. Each hoop contains vertical and horizontal 
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centering marks on the frames. These help with aligning both the fabric and the 
design.

Many hoops also come with a clear plastic template overlay. These include 
alignment lines, with tiny holes which allow you to create positioning marks. 
Hoop template display can be toggled on or off independently of the hoop itself.

Uses in the software...
 Templates include alignment and registration guide markings. These can help 

production staff align the design in the hoop.
 Templates can also be printed with alignment and registration markings. This 

allows you to cut out the printed design and align it in the hoop with the 
physical template.

Setting up hoop lists

A range of commercial brands is available for a wide variety of design types. 
Configure the My Hoops list to include only those hoops you currently have 
available for use. If you are using a hoop that is not in the hoops list, you can 
define your own and save it for later use.

Click View > Show Hoop to turn hoop display on or off. Right-click to change hoop 
settings.
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Note  The Auto Hoop feature only selects hoops from the My Hoops list. Thus 
you need to set up this list before Auto Hoop is available for use. 

To set up a hoop list
 Right-click the Show Hoop icon. The first time you run it, the Options dialog 

will open with the My Hoops dialog already opened. Otherwise, click the My 
Hoops button.

 Use the My Hoops dialog to set up your own list of available hoops. Select 
from the listed hoops and use the arrow buttons to assign.

 Click OK to confirm. Only selected hoops will be available for manual or 
automatic selection.

Tip  You may be working with hoops which don’t appear in the standard hoop 
list. Define your own hoops using circle, oval, rectangle, and other shapes. 

Click to set up your 
own hoop list

Add available hoops 
to your custom list
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Related topics
 Selecting hoops automatically
 Creating custom hoops

Setting auto start & end

Before stitchout, some embroidery machines require you to position the hoop 
precisely in relation to the needle. The Auto Start & End feature is available to 
connect first and last stitches in a design. This makes it easy to position the 
needle before stitching, and reduces the chance of the needle hitting the side of 
the frame.

Note  Machines which auto-center designs around design extents will ignore the 
Auto Start & End setting.

To set automatic start & end points
 Right-click Auto Start & End.

 Select the Apply checkbox to connect first and last stitches in the design.
 Select Maintain automatically to maintain the design center after 

modifying the design.
 Select a centering method:

Use View > Auto Start & End to toggle the Auto Start & End function on/off 
according to the current settings. Right-click to adjust settings.

Select ‘Apply auto
start & end’

Select centering
method

Specify how to
match connecting

stitches

Select preset end 
point

Click to enter
separate start and

end points

Specify the
connector type

Method Description

Auto start and 
end

By default, connecting stitches are created from the start and end 
points to the center of the design. Select one of the nine preset end 
points.

Return to start 
point

Creates a connecting stitch from the end point to the start point.
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 Select to match connecting stitches on the Horizontal plane, Vertical plane 
or both in the Match On panel.

 Select the type and length of the connecting stitches in the Connectors 
panel. 

 Click OK to confirm. Connectors – travel runs or jumps – are inserted as 
specified, before first and after last stitches of the design.

Caution  Problems may occur when you try to set a common start and end 
point for team names. 

Related topics
 Types of connectors
 Outputting teamname designs

Selecting hoops automatically

The simplest way to hoop a design is to prompt the system to select a hoop for 
you. Auto Hoop finds the smallest hoop which can accommodate the entire 
design. Auto Hoop only selects hoops from the My Hoops list thus only ever 
suggesting a hoop you have pre-selected as available for use. 

Digitize start/end 
point

Primarily used with multi-decoration designs where you want to 
strictly define the start/end point of the embroidery component. If 
you select this, you are prompted to select the point after clicking 
OK. Tick the ‘Separately’ checkbox to create separate start and 
end points.

Method Description

Match on bothMatch on vertical Match on horizontal

Click View > Auto Hoop to prompt the system to select a suitable hoop 
automatically.
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To select a hoop automatically
 Open your design and click the Auto Hoop icon or access the command from 

Design > Auto Hoop menu. From amongst its library of pre-defined hoops, 
EmbroideryStudio looks for a suitable hoop.

 If the My Hoops list is empty, the system prompts you to create a custom 
list. 

 If the system cannot find a suitable hoop with a stitching area adapted to the 
current embroidery design, it displays a message with the option to create a 
new hoop, either automatically or manually.
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 Click Auto Create if you want the system to generate a suitable hoop. 
EmbroideryStudio will create either a circular or rectangular hoop to best suit 
design dimensions. It will also name it accordingly – e.g. ‘Circle 100mm’.

 Click Manual Create/Select if you want to define your own hoop template 
to suit a specific hoop type you may have. 

 Optionally, select View > Zoom > Zoom to Hoop or press Alt+0 to view 
the entire hoop in the design window.

 Optionally, turn on the Hoop Template display via the View menu. 
Templates can be used instead of grids. The template, especially when 
printed in the worksheet, provides a means for aligning the design in the hoop 
at the correct location and orientation.
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Tip  The current hoop name is displayed in the Prompt Line.

Related topics
 Setting up hoop lists
 Defining custom hoops

Selecting hoops manually

From your My Hoops list, you can manually select your preferred hoop. 
Generally you will want to select the smallest hoop which will accommodate your 
design. This will hold the fabric tight while stitching. When you output your 
design, most machines will automatically center the design within the hoop 
according to its geometric extents. Some machines will center designs in the 
hoop at the start needle position. For these machines, you can set a starting 
point using Auto Start & End settings.
For display purposes, EmbroideryStudio will generally ensure that the design is 
centered in the hoop. However, you can use the manual option to lock the hoop 
position onscreen. This means it won’t automatically center while you are 
digitizing. It’s always a good idea, however, to turn auto-centering back on to 
check that the design will fit within the selected hoop.

To change hoops
 Open your design and click the Show Hoop icon. The current hoop is 

displayed. It may be too big or too small for your design.

Click View > Show Hoop to turn hoop display on or off. Right-click to change hoop 
settings.

Click Zoom > Zoom To Hoop to view entire hoop in the design window. 
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 Right-click the icon. The Options > Hoop dialog opens.

 Select a hoop from the My Hoops list. Configure the list to include only those 
hoops you currently have available for use via the My Hoops function.

 In the Position panel, choose how you want the hoop to be positioned on the 
machine:
 Automatic centering: Ensure that design is always centered onscreen 

within the hoop.

Normally the hoop will center itself around the geometric center of the 
design. However, you have the option of centering around the start needle 
position. This option is usually used on conjunction with Auto Start & End 
settings.

 Manual: Use the manual option to make sure the hoop display does not 
move from its original position. This means it won’t automatically center 
while you’re digitizing. This may be important if you are combining 

Choose 
preferred hoop

Design automatically
centered after editing
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embroidery with print or if you want to stitch out in certain locations like 
chest pockets.

 Manual > Set hoop center: Digitize a point on the design that the hoop 
will center around. 

 Click OK. If you selected Set Hoop Center, click a point where you want to 
center the hoop.

 Use the View toolbar to turn on/off hoop. 
 Optionally, click the Zoom to Hoop icon, select View > Zoom > Zoom to 

Hoop or press Alt+0 to view the entire hoop in the design window.
 Optionally, turn on the Hoop Template display via the Options dialog or 

View menu. The template may be used to help position your design within 
the hoop.

Tip  You can include the hoop template in the production worksheet, together 
with alignment and registration guide markings. This allows you to cut out the 
printed design and align it within the hoop. Use the template markings to 
align it to physical hoop template.

Related topics
 Display grids, rulers & guides
 Setting scroll options

Design remains in
same position

Show the hoop
template
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Creating custom hoops

You may be working with hoops which don’t appear in the standard hoop list. 
Define your own hoops using circle, oval, rectangle, and other shapes.

Defining custom hoops

If you are using a hoop size that is not in the hoop list, you can define a custom 
hoop to conform to the dimensions of any physically existing hoops you may be 
using. Various formats are available to define anything from rectangular, oval, 
circle, to square hoops.

To define a custom hoop
1 Right-click the Show Hoop. The Options > Hoop dialog opens.

2 Click Create. The Create Hoop dialog opens.

3 Select the required format for your hoop from the droplist – e.g. rectangle, 
circle, etc.

Click View > Show Hoop to turn hoop display on or off. Right-click to change hoop 
settings.

Create new 
hoop

Select required
format
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4 In the Stitching Area Dimensions panel, enter the dimensional 
characteristics of the stitching area:
 Circle: Circle stitching areas only require a Diameter to be specified.

 Square: Square stitching areas only require a Width to be specified.

 Rectangle: Rectangular stitching areas require Height and Width 
dimensions.

Enter required
diameter

Enter required
width

Enter required
dimensions
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 Oval: Oval stitching areas require three dimensions – Total Height, 
Rectangle Height, and Width.

 Round Rectangle: Similar to oval stitching areas, round rectangles 
require three dimensions – Height, Width, and Corner Radius. The 
greater the radius, the rounder the corner.

5 Click Save Hoop or Save Hoop As. The Save Hoop As dialog opens.

6 Give your hoop a meaningful name – e.g. ‘Rectangle 180x120’.
7 Click Save. Your user-defined hoop is now available for use along with the 

system-defined hoops.

Editing custom hoops

Enter required
dimensions

Enter required
dimensions

Rectangle 180x120

Click View > Show Hoop to turn hoop display on or off. Right-click to change hoop 
settings.
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You can edit and delete custom hoops as required – both those you have defined 
yourself and those created by the system. Only custom hoops can be modified 
or removed, not those from the existing library.

To edit a hoop
 Right-click the Show Hoop icon. The Options > Hoop dialog opens.

 Select the hoop you want to edit or delete from the My Hoops list.
 Click Delete then OK to confirm. The hoop is permanently removed.
 Click Edit. The Create Hoop dialog opens. The same dialog is used for 

editing as for defining hoops. 

 Enter new dimensions and click the Save Hoop button.

Related topics
 Defining custom hoops

Edit or delete 
custom hoops

Edit dimensions
as required

Click to save
hoop
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PART XI

PRODUCT DIFFERENTIATION

TABLE
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Product differentiation table

Capability Feature Products Reference

1 2 3 4 5 6

Basics Basic Procedures

Switch design modes CorelDRAW Graphics *   Operating modes
Access Design Library Design Library ^       Design library
View object properties Object Properties     L L Access object properties
Select machine format *       Machine formats
Open embroidery design file *       Open designs
Create design based on template New from Template       Create designs from templates
Save embroidery design file Save Design *       Save designs
Send design as email attachment       Send designs as email attachments
Select design objects *     L L Selecting objects
Display grids, rulers and guides Show Rulers & Guides *       Display grids, rulers & guides
Set measurement units       Set measurement units
Measure distances on screen       Measuring distances on screen

View designs Viewing Designs

View embroidery components       View embroidery components
View graphical components *       View graphical components
Zoom and pan across designs Zoom *       Zoom & pan designs
View multiple designs *       Set up multiple views
Show design in Overview window Overview Window      Work with the Overview Window
Simulate design stitchouts Stitch Player *       Simulate design stitchouts
Travel through designs Travel Tools       Travel through designs
Show multiple colorways Current Colorway       Switch colorways
Change backgrounds and display colors Background & Display 

Colors
*       Change backgrounds

View color blocks and design objects Color-Object List     Viewing color blocks
View design repeats Show Repeats       Viewing design repeats
View design details Design Properties *       Viewing design details
View design report Print Preview *       Preview design reports

Manage threads Threads & Charts

Select thread colors Color palette *       Selecting thread colors

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Assign thread colors *       Assigning thread colors
Edit thread colors       Editing thread colors
Create & modify thread charts       Managing thread charts

Design management Managing Designs

View designs in network folders ^       Viewing designs in network folders
Open designs from Design Library Design Library ^       Opening designs from Design Library
Insert designs with Embroidery Clipart Embroidery Clipart ^   Inserting designs with Embroidery Clipart
Search for designs ^       Searching the library
Manage folders ^       Adding folders to the library
Manage design information ^       Viewing & managing design information
Manage job orders ^       Managing quotes & orders
Convert designs ^       Converting designs
Output selected designs ^       Outputting selected designs

System settings System Settings

Set view options       Setting view options
Set grid options       Setting grid display options
Mouse scroll/zoom control       Setting scroll options
Set reshape options       Setting reshape options
Set automatic save and backup options       Setting automatic save & backup options
Set pointer position display       Setting pointer position display
Set inserted embroidery file options       Setting color handling for inserted files
Set paste & duplicate options *       Setting paste & duplicate options
Set digitizing tool options *       Digitizing tools
Set toolbar display options ^       Setting toolbar display options
Set Object Property ‘apply’ options       Setting Object Property apply options
Set other general options       Setting other general options
Set warning options       Setting warning options

Hardware Hardware Settings

Connect to machine via Connection ManagerConnection Manager      Setting up machines for Connection Manager
Connect to machine via Stitch Manager Stitch Manager      Setting up machines for Stitch Manager
WiFi USB machine networking WiFi USB Stick ^      EmbroideryConnect Machine Networking
Perform runtime estimates Runtime Analyst       Doing runtime estimates

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4



E
m

b
ro

id
e

ry
S

tu
d

io
e

4
 U

se
r M

a
n

u
a

l
9

1
5

Connect to scanner    Setting up scanners
Connect to digitizing tablet   Connecting digitizing tablets

Machine formats Machine Formats

Modify standard machine formats      Standard machine formats
Adjust advanced machine format settings 
(color change sequence, start/end design, 
speed)

     Advanced machine formats

Create custom machine formats      Custom machine formats

Stitch types Stitch Types

Create simple outline stitching Run, etc *     L Simple outline stitching
Create ‘sculpture’ runs (bead stitching) Sculpture Run *   Sculpture run settings
Create decorative outlines Backstitch, Stemstitch *   Decorative outlines
Create satin borders and fills Satin, Raised Satin *   L L L Satin stitching
Create tatami borders and fills Tatami *    L L Tatami stitching
Create zigzag and E-stitch borders and fills Zigzag, E Stitch *    Open fills & borders

Digitize shapes Digitizing Shapes

Digitize with graphical tools Graphics Digitizing *    Digitizing with graphical tools
Digitize outlines and details Digitize Run, etc *      Digitizing outlines & details
Digitize regular columns Column C *   Digitizing regular columns
Digitize irregular columns Column A/B *   Digitizing irregular columns
Create free-form shapes Complex Turning / 

Complex Fill
*   Creating free-form shapes

Object properties Object Properties

Modify current property settings      Changing current settings
Change object properties      Changing object properties
Make selected object properties current Make Properties 

Current 
   Copying properties

Change & manage fabrics Auto Fabric      Working with fabrics
Define & apply styles Styles   Working with styles
Create design templates Save as Template *      Creating design templates

Colorways Colorways

Add colorways Colorway Editor *      Adding colorways

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Change color schemes Color Wheel ^   Changing color schemes
Name design elements      Naming design elements
Split color blocks Split Palette Color      Splitting color blocks
Set backgrounds Background & Display 

Colors
*       Setting fabric backgrounds

Visualize products Product Visualizer *       Visualizing products

Underlays & pull compensation Underlay & Pull Compensation

Apply automatic underlay Auto Underlay *      Stabilizing with automatic underlay
Apply underlay by shape Auto Underlay      Underlay by segment or by shape
Create slanted zigzag & double zigzag 
underlay

     Zigzag underlay settings

Apply pull compensation Pull Compensation      Compensating for fabric stretch

Stitch quality Optimizing Stitch Quality

Reverse stitch direction Reverse Curves   Reversing stitch direction
Reinforce outlines Backtrack / Repeat *   Reinforcing outlines
Adjust stitch angles Stitch Angles *    Adjusting stitch angles
Adjust stitch density Process Stitches   Adjusting stitch densities
Remove small stitches automatically Small Stitches      Eliminating small stitches
Control corner stitching Smart Corners *   L L L Controlling corner stitching
Reduce stitch bunching Shortening      Reducing stitch bunching
Split long stitches Auto Split      Splitting satin stitches
Preserve long stitches Auto Jump      Preserving long stitches

Embroidery connectors Embroidery Connectors

Apply automatic connectors Connectors      Using automatic connectors
Add tie-offs & trims manually Tie Off *      Adding connectors manually
Keep/omit last stitches Keep/Omit Last Stitch   Keeping or omitting last stitches
Adjust entry/exit points Show Entry/Exit     L Adjusting entry/exit points
Apply closest join Closest Join     L Applying closest join
Automatic object sequencing Branching   Minimizing connectors with automatic 

branching

Productivity tools Productivity Tools

Add decorative borders to designs Add Borders *      Adding design borders

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Create embroidered stars & rings Star/Ring   Digitizing stars & rings
Digitize basic shapes Basic Shapes ^   Digitizing basic shapes
Remove underlying stitching Remove Overlaps *    Removing underlying stitching
Add or remove holes in objects Add Holes ^    Adding & removing holes
Fill holes in objects Fill Holes    Filling holes
Create simple offsets Simple Offsets    Simple offsets
Create multiple offset outlines & offsets Outlines & Offsets *    Creating outlines & offsets
Create offsets with open objects Open Offsets ^   Creating offsets with open objects
Create automatic wreaths Mirror-Merge *   Mirroring & reflecting selections
Create design arrays Mirror-Merge Array *   Creating design arrays

Combine & sequence objects Combining & Sequencing Objects

Combine objects and designs – copy, paste, 
clone, etc

*      Combining objects & designs

Group & lock objects Group/Lock     Grouping & locking objects
Select objects by color or stitch type *     Selecting objects by color or stitch type
Resequence embroidery objects     Sequencing embroidery objects
Auto-sequence entire design Optimize Color 

Changes
^     Auto-sequencing entire designs

Object editing Modifying Objects

Position, align & distribute objects      Arranging objects
Scale objects      Scaling objects
Rotate objects Rotate      Rotating objects
Skew objects Skew      Skewing objects
Mirror objects Mirror      Mirroring objects

Reshaping operations Reshaping Objects

Reshape embroidery objects Reshape Object     L Reshaping embroidery objects
Reshape star & ring objects Reshape Object     Reshaping stars & rings
Apply envelopes to embroidery objects Envelopes *      Applying envelopes
Break apart branched objects Break Apart     Breaking apart composite objects
Cut shapes manually Knife    Cutting shapes manually

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Cut shapes automatically Automatic Knife    Cutting shapes automatically
Shape vector / embroidery objects – merging, 
splitting, trimming, etc

Shaping Tools   Shaping objects

Stitches & machine functions Stitches & Machine Functions

Insert, move or delete individual stitches Stitch Edit      Selecting & editing stitches
Split embroidery objects Split Object     Splitting objects
Insert/edit/clear machine functions Insert Function      Editing machine functions
Edit stitches and functions with Stitch List Stitch List     Editing machine functions manually
Digitize individual stitches Manual   Digitizing individual stitches
Digitize boring holes Manual   Digitizing boring holes
Convert selected stitches to objects Process Stitches   Converting stitches to objects

Decorative fills Specialty Stitching

Create freehand embroidery Freehand Embroidery *   Creating freehand embroidery
Create jagged edges Jagged Edge   Creating furry or fluffy edges
Create textures with stippling Stipple   Creating stippling effects
Create open stitching with trapunto Trapunto    Creating open stitching with trapunto
Create accordion spacing effects Accordion Spacing   Creating accordion spacing effects
Create color blending effects Color Blending   Creating color blends
Create string stitching String ^   Creating string stitching
Create chenille-type patterns Square, Coil *   Creating chenille-type patterns
Create cross stitch fills Cross Stitch   Creating cross stitch fills

Patterned fills Patterned Fills

Create textures with Tatami offsets Tatami Offset     L Creating textures with tatami offsets
Create textures with program splits Program Split   Creating textures with program splits
Create custom splits User-Defined Split   Creating user-defined splits
Create custom stitch patterns Carving Stamp   Creating patterns with carving stamps

Curved fills Curved Fills

Create contoured stitching Contour *   Creating contoured fills
Create offset fills Offset Fill ^   Creating offset fills
Create spiral fills Spiral Fill ^   Creating spiral fills
Create radial fills Radial Fill ^   Creating radial fills
Create textures with flexi-splits Flexi Split   Creating flexi-splits

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Create curved fills Florentine Effect / 
Liquid Effect   Creating curved fills

Motif runs & fills Motif Runs & Fills

Place single motifs Use Motif   Selecting & placing motifs
Create motif runs Motif Run   Creating motif runs
Create graded motif runs Motif Run ^   Creating graded motif runs
Create motif fills Motif Fill L L L Creating motif fills
Create 3D effects with motif fills 3D Warp   Creating enveloped motif fills
Create graded motif columns Motif Column ^   Creating graded motif columns
Create motifs & motif sets   Managing motifs

Embroidery lettering Embroidery Lettering

Create lettering in CorelDRAW Graphics CorelDRAW Graphics   Creating lettering with CorelDRAW Graphics
Create lettering in Wilcom Decoration Lettering *      Creating embroidery lettering
Format lettering – italic, bold, justified, etc      Adjusting lettering properties
Add baselines – horizontal, vertical, arc, 
circle, custom

     Working with baselines

Edit lettering text Lettering      Editing text
Scale and transform lettering objects      Modifying lettering
Adjust individual letters – reposition, 
transform, reshape, recolor

     Adjusting individual letters

Adjust and reshape baselines      Adjusting baselines
Break apart lettering Break Apart     Breaking apart lettering
Add special characters Insert Symbol      Adding special characters
Set lettering stitch types – Satin, Tatami, etc Stitch Types      Applying stitch types & effects to lettering
Create special effects with lettering art Lettering Art ^      Creating special effects with lettering art
Adjust lettering stitching sequence Letter Sequence      Adjusting letter sequencing
Change lettering join method Letter Sequence      Changing lettering join method
Automatic letter kerning Auto Kerning      Setting automatic letter kerning
Apply automatic letter spacing Auto Letter Spacing      Setting automatic letter spacing
Apply lettering underlay Auto Underlay      Setting lettering underlay

Team names & monograms Team Names & Monogramming

Add multiple names to designs Team Names *      Creating simple teamname designs
Create teamname templates Team Names *    Teamname templates

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Output team-name designs Team Names      Outputting teamname designs
Create monogram designs Monogramming *      Monogramming

Custom fonts Custom Fonts

Convert TrueType fonts to embroidery fonts Convert TTF *   Converting TrueType fonts to embroidery
User-refined letters      User-refined letters
Create custom fonts   Creating custom fonts
Merge fonts      Merging fonts

Lettering kiosk Lettering Kiosk

Configuration options for supervisors      Configuration options for supervisors
Create custom design layouts      Creating custom design layouts

Digitize with bitmaps Digitizing with Bitmaps

Insert / paste bitmap images Import Graphic       Importing graphics
Crop bitmap images Crop Bitmap *    L Cropping bitmap images
Edit bitmap images in third-party applications    Touching up bitmaps
Smooth bitmap images       Smoothing bitmap images
Save artwork CorelDRAW Graphics   Saving artwork
Prepare artwork for auto-digitizing Prepare Bitmap 

Colors
*    Preparing artwork for auto-digitizing

Add and match image colors Add Bitmap Colors      Adding & matching image colors

Digitize with vectors Digitizing with Vectors

Create vector outlines and fills Drawing Tools *    Creating vector shapes in EmbroideryStudio
Color vector objects    Coloring vectors
Insert / paste vector graphics Import Graphic    L L L Importing vector artwork
Convert artwork to vector graphic Auto Trace To Vectors    Auto-tracing bitmap artwork
Smooth curves Smooth Curves   Smoothing curves
Show/hide vector graphics       Visualizing vector graphics

Automatic digitizing Automatic Digitizing

Inter-convert graphics and embroidery 
objects

CorelDRAW Graphics   Converting objects with CorelDRAW 
Graphics

Convert between embroidery objects – Run, 
Column C, etc.

Convert    Converting objects

Digitize shapes with Auto-Digitizing Auto-Digitizing    Auto-digitizing image shapes

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Match palette colors to an image Color Matching 
Method

*    Auto-digitizing image shapes

Convert bitmaps with Smart Design Smart Design *    Auto-digitizing entire images
Create embroidery from photos Photo Flash    Auto-digitizing with Photo Flash
Create embroidery from color photos Color PhotoStitch ^    Auto-digitizing with Color PhotoStitch

Appliqué Appliqué Digitizing

Convert vector graphics to appliqué Convert Graphics to 
Embroidery

  Converting vector graphics to appliqué

Create appliqué designs Auto Appliqué *    Creating appliqué embroidery
Add fabric swatches to appliqué objects Auto Appliqué    Adding fabric swatches to appliqué
Create partial appliqué shapes Partial Appliqué    Creating partial cover appliqué
Recombine and resequences multiple 
appliqué for efficient stitchout

Combine Appliqué 
Components

   Combining appliqué

Print / cut appliqué patterns    Outputting appliqué
Create cording designs Cording ^   Adding cording

Sequins Sequin Digitizing

Set up custom sequin palette   Setting up sequin mode
Create sequin runs Sequin Run   Digitizing sequin runs
Convert sequin artwork to Sequin Run   Converting sequin artwork
Create sequin fills Sequin Fill *   Creating sequin fills
Digitize twin-sequin designs   Creating twin-sequin designs
Pattern stamp re-coloring of twin-sequin fills ^   Pattern stamp re-coloring of twin-sequin fills
Scale & reshape sequin runs   Reshaping & editing sequin runs
Create custom sequins ^   Creating custom sequins
Digitize individual sequins Sequin Manual   Digitizing individual sequin drops

Bling Bling Digitizing

Set up bling palettes Bling    Setting up bling palettes
Create bling runs and fills Bling    Creating bling runs & fills
Add bling borders Bling    Adding bling borders
Place rhinestones manually Bling    Placing rhinestones manually
Modify bling objects Bling    Modifying bling objects
Create bling lettering Bling    Creating bling lettering
Output bling templates Bling    Outputting bling templates

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4



P
ro

d
u

c
t d

iffe
re

n
tia

tio
n

 ta
b

le
9

2
2

Send bling to CAMS machine Bling    Sending bling to CAMS machine

Print designs Printing Designs

Print/plot design reports *       Printing design reports
Save or send design as PDF ^       Printing design reports
Customize report information *       Customizing design reports
Print multiple colorways       Colorway options
Print color blocks       Stop sequence options
Print designs in CorelDRAW Graphics   Printing designs in CorelDRAW Graphics
Save designs as bitmap images      Outputting designs as graphics
Save designs as ‘virtual decoration’    Virtual decoration

Output designs Outputting Designs for Production

Send designs to Connection Manager Connection Manager      Sending designs to Connection Manager
Send designs to Stitch Manager Stitch Manager      Sending designs to Stitch Manager
Export designs for machine *      Exporting designs for machine
Read/write embroidery disk      Using embroidery disks
Export multi-decoration files CorelDRAW Graphics  Exporting multiple decoration files
Send designs to Machine Manager      Machine Manager Supplement

Read designs Working with Machine Files

Convert machine files to EMB format      Opening machine files in EmbroideryStudio
Open/save designs in Melco CND format      Reading Melco CND design files
Color merge Melco CND files      Creating a color-merge TXT file
Reassign colors to stitch / CND files      Reassigning colors to machine files

Design hooping Hooping Designs

Set up custom hoop lists      Setting up hoop lists
Set auto start & end      Setting auto start & end
Select hoops automatically Auto Hoop      Selecting hoops automatically
Select hoops manually Show Hoop *      Selecting hoops manually
Create custom hoops      Creating custom hoops

Capability Feature Products Reference

1 2 3 4 5 6

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering 6 ES Ordering
 Included as standard   Modular ‘element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Quick reference

There are two fundamental design modes in 
EmbroideryStudio:

Wilcom Decoration
This mode allows you to create and edit 
embroidery objects using the embroidery 
digitizing toolset.

CorelDRAW Graphics
This mode allows you to create and edit vector 
objects using the CorelDRAW® Graphics Suite 
toolset. For a detailed description of the 
CorelDRAW Graphics interface, refer to the 
electronic User Guide available via the 
MS Windows® Start > Programs group. 
Alternatively, use the onscreen help available 
from the Help menu.

EmbroideryStudio menus

The EmbroideryStudio design window menu bar 
contains the pulldown menus described below. 
Some commands are also available as toolbar 
buttons.

Note  Standard MS Windows® Alt key shortcuts 
apply. Use the Alt key with the letter underlined 
in the menu. To cancel an operation, press Esc 
twice.

File menu

Menu bar

Status / Prompt bars

Mode toolbar

Standard toolbar

Object properties
docker

Color palette

Docker tabs

Design window

View toolbar

Toolbox

‘Floating’ toolbar

Stitch Effects toolbar

Stitch Types toolbars

Graphic style and
traditional input

methods

Design tabs

New Create new blank design based on a 
fabric or template.

New from 
Template

Create new design from a template. 

Open Open existing design. 

Open Recent Most recently used files listed – select to 
open file.

Open Backup 
Design

Opens directly onto the backup folder for 
quick access to backup files in case of 
software failure.

Close Close current design window.

Save Save current design.

Save As Save current design with a different 
name, location or design file format.

Save As 
Template

Save current design as a design 
template for future use.

Save As 
Monogram 
Template

Save current design as a monogram 
template for future use with the 
Monogramming tool.
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Edit menu

View menu

Save As 
Teamname 
Template

Save current design as a teamname 
template for future use with the Team 
Names tool.

Export 
Machine File

Convert current design to a machine 
format other than your selected machine.

Print Print the current design.

Print Preview Display design worksheet/approval 
sheet – print from preview window.

Import 
Embroidery

Insert one design into another to create 
combined design. Color palettes are also 
combined. Colors with same RGB values 
are automatically identified as having the 
same thread color.

Import 
Graphic

Import artwork into current design as a 
backdrop for manual or automatic 
digitizing.

Scan Graphic Scan images directly into 
EmbroideryStudio.

Export Design 
as Vector

Save design as vectors in EMF or WMF 
format.

Export 
Multi-decorati
on Files

Export mixed decoration design 
components as file formats for use by 
control software or machine.

Record in 
Database

If you have DesignWorkflow installed, 
record an open design to the database.

Capture 
Design 
Bitmap

Save design image as bitmap exactly as 
it appears on screen.

Capture 
Virtual 
Decoration 
Bitmap

Output high resolution digital print 
TrueView for ‘virtual embroidery’.

Send via 
Email

Send design as email attachment.

Export Design 
Properties

Output current design information and 
machine runtime settings to CSV file.

Send to 
Connection 
Manager

Connect to supported machines via 
proprietary machine software.

Send to 
Appliqué 
Cutter

Send appliqué shapes from design file to 
laser cutter.

Send to Bling 
Cutter

Send vectors for any bling in any 
multi-decoration design to a supported 
cutting machine. Configure the machine 
via Setup.

Cross Stitch Access Cross Stitch application.

Exit Close all open designs and exit program.

Undo Undo previous action.

Redo Redo previously undone action.

Cut Cut selection and place on Clipboard.

Copy Copy selection and place on Clipboard.

Paste Paste contents of Clipboard. Options 
available in Options > Edit tab.

Paste After 
Selected

Override current defaults and paste 
directly after selected object in the 
stitching sequence.

Paste Special 
>

Override current Paste setting and select 
from paste options available in Options > 
Edit tab.

Duplicate Duplicate selected objects within the 
design (rather than copy to clipboard).

Duplicate 
with Offset

Duplicate an object with an offset. Adjust 
settings via the Options > Edit dialog. 

Delete Delete selected objects.

Select All Select all objects in the design.

Deselect All Deselect all objects in the design.

Select by 
Color

Select all objects of same color.

Select by 
Stitch Type

Select all objects of same stitch type.

Close Curve 
with Straight 
Line

Close an open outline with a straight line.

Close Curve 
with Curve 
Line

Close an open outline with a curved line.

Reverse Control push-pull effect by reversing 
stitch direction – affects stitching direction 
of Jagged Edge, Contour Stitch and E 
Stitch objects. Can also affect Tatami 
offsets, as well as Flexi Split and Motif 
Run orientation.

Smooth 
Curves

Apply curve ‘smoothing’ to both 
embroidery and vector objects.

Transform > Transform selected objects using 
combination of reference points and 
numeric values. Rotate selected objects 
with aid of reference points alone.

Envelope > Apply Bridge, Pennant, Perspective, and 
Diamond effects to lettering objects.

TrueView Toggle between normal (stitch) view and 
TrueView™.

Show > Access same design viewing commands 
as available on View toolbar.

Hoop Show / hide hoop display. Right-click for 
settings. 

Hoop 
Template

Show hoop template as an alternative to 
grid lines, in order to align design at 
correct location and orientation.

Show Grid Toggle on/off grid display.

Show Rulers 
& Guides

Toggle on/off rulers and guides. 
Right-click for settings.
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Design menu

Object menu

Arrange menu

Zoom Zoom in to selected area of the design.

Zoom 1:1 Display design at actual size.

Zoom Factor Set precise viewing scale.

Zoom In/Out 
1.25X

Zoom in and out in smaller increments to 
‘slow down’ mouse-wheel scrolling.

Zoom In/Out 
2X Display design at twice/half current size.

Zoom to Fit Display whole design or only selected 
embroidery objects in design window.

Zoom to 
Selected

View selected objects in the design 
window.

Zoom to 
Product View entire product in the design window.

Zoom to Hoop View entire hoop in the design window. 

Pan Pan across the current design.

Previous 
View Return to previous view.

Center 
Current Stitch

Center design in design window around 
current stitch.

Measure Measure distance between two points on 
screen.

Stitch Player Simulate embroidery design stitchout on 
screen.

View by Color View embroidery objects by color – e.g. 
when resequencing objects.

View all 
Colors

Show all colors after activating View by 
Color.

View By 
Machine 
Function >

View machine Chenille and Schiffli 
functions – Chain/Moss, Stepp/Blatt, etc.

Refresh 
Screen Refresh screen display.

Design 
Properties

Display design information such as size 
and number of stitches, and add 
comments to print to worksheet.

Select 
Machine 
Format

Select machine format corresponding to 
embroidery machine you intend to use.

Machine 
Format 
Settings

Define values to encode when outputting 
to a specific machine format.

Auto Fabric Change current fabric.

Auto Hoop Prompt system to select a suitable hoop 
from My Hoops list.

Background 
& Display 
Colors

Access Background & Display Colors 
dialog for background colors, swatches, 
and product templates.

Auto Start & 
End

Access automatic design start/end 
settings.

Remove 
Small 
Stitches

Automatically remove unwanted small 
stitches.

Repeats

Use in combination with the Show 
Repeats tool to access settings for use 
with continuous and overlapping 
designs.

Design 
Repeats

Same as Repeats command but only 
works for Schiffli machines.

Make 
Properties 
Current

Make properties of a selected object 
current for the design.

Apply 
Current 
Properties

Apply current settings to selected 
objects.

Apply 
Favorite Style

Assign up to 10 favorite styles via 
Manage Styles. Select object and click 
button to apply.

Apply Style Apply pre-defined style to selected 
objects.

Use for 
Florentine 
Effect

Make guideline for Florentine Effect.

Use for Liquid 
Effect Make guidelines for Liquid Effect.

Create Motif Add individual motifs to a design. Save 
own motifs for future use.

Create 
Program Split

Turn embroidery or drawing objects into 
patterns for use in Program Split fills.

Create Letter Access command used in custom fonts. 
See Custom Fonts for details.

Create 
User-Refined 
Letter

Save a reshaped letter as a ‘user-refined 
letter’. Only available when selected in 
Reshape mode.

Update 
Kerning 
Settings

Update kerning settings for contiguous 
pairs of selected letters of the same font. 
Only available when Automatic Kerning 
is in use. 

Set Color Change color of consecutive objects of 
same color.

Group Group selected objects.

Ungroup Ungroup selected grouped objects.

Lock Lock selected objects.

Unlock All Unlock all locked objects in design.

Branching Automatically sequence and group like 
embroidery objects. 

Apply 
Closest Join

Join selected objects at the closest point. 
Re-apply closest join after editing.
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Function menu

Stitch menu

Graphics menu

Break Apart

Split branched objects – monograms, 
appliqués, lettering, etc – into 
components. Allows each to be edited 
individually.

Sequence > Resequence selected objects in order 
selected, or resequence objects by color 
to reduce color changes.

Align >

Same functions as the Arrange toolbar.
Space Evenly 
>

Make Same 
Size >

Shaping > Same functions as the Shaping toolbar.

Remove 
Overlaps

Remove the underlying layer of stitching 
in overlapping objects. 

Penetrations Toggle Penetrations function on/off. 
Engage needles or borers, or disengage 
to create jumps.

Borers Toggle Borers function on/off.

Insert Stop Insert Stop function at current stitch 
cursor position.

Insert Tie-off Insert a tie-off.

Insert Trim Insert a trim.

Insert Empty 
Stitch Insert an empty stitch.

Insert Empty 
Jump Insert an empty jump.

Insert 
Function

Insert machine function at current stitch 
cursor position.

Clear 
Function

Remove machine functions from the 
current sttich cursor position.

Edit Function Edit machine function at current stitch 
cursor position.

Generate 
Stitches Generate stitches for selected objects.

Stitch Edit 
Selection

Select a range of objects as you travel 
through the design.

Process 
Stitches

Adjust stitch density of and/or scale 
whole or selected parts.

Recognize 
Objects / 
Outlines

Recognize new or revised object outlines 
after stitch editing – use with machine 
files opened without object/outline 
recognition. 

Split Object Split object in two at current needle 
position. Use with Travel by Stitch 
functions.

Import 
Graphic

Import artwork into current design as a 
backdrop for manual or automatic 
digitizing.

Instant Smart 
Design

Automatically create embroidery from 
imported artwork instantly.

Smart Design Create whole embroidery designs 
directly from imported artwork.

Keep 
Graphic 
Objects

Keep original objects after shaping 
operations.

Color 
Matching 
Method

Match colors from inserted bitmap or 
vector graphic to thread colors in 
selected chart/s

Crop Bitmap Crop bitmap images to remove 
unnecessary detail and save processing 
time.

Remove 
Crop Remove crop. 

Finalize Crop Turns a ‘virtual crop’ into a ‘hard crop’ by 
reducing an image to its new
visible extents.

Prepare 
Bitmap 
Colors

Prepare bitmap images for automatic 
digitizing.

Edit Using > Edit bitmaps using Paint, Corel 
PHOTO-PAINT, or Paint Shop Pro.

Turning Satin 
Object

Fill narrow column shapes with turning 
stitching.

Tatami Fill 
Object with 
Holes

Fill large shapes with tatami stitching, 
preserving any holes

Tatami Fill 
Object

Fill large shapes with tatami stitching, 
ignoring any holes.

Centerline 
Run Object

Create centerlines in narrow shapes with 
Run stitching.

Outline Run 
Object

Create outlines around shapes with Run 
stitching.

Auto Trace to 
Vectors

Convert artwork to vector objects. These 
can be converted to embroidery objects.

Adjust 
Bitmap Adjust image lightness and contrast.

Photo Flash Create whole embroidery designs 
directly from photographs.

Color 
PhotoStitch

Automatically turn photographs and 
other bitmap artwork into multi-colored 
embroidery.

Add Bitmap 
Colors

Assign matching thread colors from 
selected chart/s to the current colorway.
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Setup menu

Window menu

Help menu
EmbroideryStudio provides various ways to 
access information about the software and how 
to use it via the Help menu. See Resources & 
support for details.

EmbroideryStudio toolbars

The ES Decorating window contains the 
toolbars described below. Some tools are 
shortcuts to pulldown menu commands. Details 
of optional toolbars are provided in the onscreen 
documentation.

Note  Only the most commonly used toolbars are 
on by default.

Standard toolbar
The Standard toolbar contains commonly used 
tools and commands which are specific to and 
only visible in Wilcom Decoration.

General 
Options

Access current settings for design 
window object display.

Manage 
Thread 
Charts

Define your own thread charts. When 
you create a thread chart, you are 
creating a store of colors for future use.

Manage Auto 
Fabrics

Modify existing fabric definitions and 
create new ones. 

Manage 
Styles

Define new styles for a template, either 
from scratch or based on an existing 
style or object.

My Hoops Configure My Hoop list to include only 
hoops available for use.

Manage 
Motifs

Manage your custom motif sets.

Manage 
User-Refined 
Letters

Adjust height range and other settings for 
custom ‘user-refined’ letters.

Manage 
Alphabets

Modify custom alphabets by changing 
names, default letter spacings and join 
types.

Convert 
TrueType 
Font

Convert a TrueType font to an 
embroidery font.

Calibrate 
Screen

Set up your monitor. 

Connection 
Manager 
Setup

Connect to machines that appear as 
removable media or make use of 
third-party connection software.

Tablet Setup Set up digitizing tablet.

Scanner 
Setup Set up Scanner.

Bling 
Machine 
Setup

Set up direct connection to CAMS 
automatic rhinestone placement 
machine.

Machine 
Runtime 
Setup

Set up multiple named machines for the 
purposes of runtime analysis.

Security 
Device Setup

Show/set security device.

New ... Tab 
Group

Split the design window into a second tab 
group, either vertical or horiztonal. Each 
tab group can contain multiple designs.

Move to ... 
Tab Group

Move a current design to the other 
design tab. Can also be dragged to the 
other design group.

Remove 
Tiling

Remove tab groups and split windows 
and return to a single design window.

Split Window Split design tab into multiple views of the 
same design.

Dockers > Show/hide dockers to optimize working 
area.

Toolbars > Show/hide toolbars to optimize working 
area.

Kiosk Lettering kiosk capability for cap and 
other embroidery for use at retail outlets 
where simple personalization of standard 
design layouts is required.

More 
Windows

View more open windows.

New Create a new design file.

Open 
Design Open an existing embroidery design.

Open 
Recent 
Designs

Open a design from a list of recently 
opened designs.

Save 
Design Save the current design file.

Export 
Machine 
File

Export the current design to a 
machine file for stitching.

Print Print the current design file.

Print 
Preview

Preview design worksheet/approval 
sheet. Print from preview window.

Cut Cut selection and place on Clipboard.

Copy Copy selection and place on 
Clipboard.

Paste Paste contents of Clipboard. Options 
available in Options > Edit tab.
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Mode toolbar
This toolbar contains tools pertaining to 
interactions between Wilcom Decoration and 
CorelDRAW Graphics.

Docker toolbar
Docker tools allow you to toggle modeless 
dialogs (dockers) on or off. See also Work with 
dockers.

Undo Undo previous action.

Redo Redo previously undone action.

Import 
Embroidery

Import embroidery design file into 
current design. 

Import 
Graphic

Import artwork into current design as 
a backdrop for manual or automatic 
digitizing.

Export 
Multi- 
Decoration 
Files

Export mixed decoration design 
components as file formats for use by 
control software or machine. 

Send to 
Connection 
Manager

Send current design to machine via 
proprietary machine software.

Send to 
Appliqué 
Cutter

Send appliqué shapes from design file 
to laser cutter. 

Send to 
Bling Cutter

Send vectors for any bling in a 
multi-decoration design to a 
supported cutting machine. Configure 
the machine via Setup. 

Zoom Scale: Select zoom scale from 
droplist

Options
Access application options for design 
view, grid & guides, and other 
settings.

Switch to 
CorelDRAW 
Graphics

Access full graphic creation and 
editing toolset.

Switch to 
Wilcom 
Decoration

Access full embroidery creation 
and editing toolset.

Design Library

Open the Design Library window 
from which to search and 
catalogue designs as well as 
quotes, orders, and approvals.

Convert 
Embroidery to 
Graphics

Convert selected embroidery to 
vector graphics and switch to 
CorelDRAW Graphics.

Convert 
Graphics to 
Embroidery

Convert selected graphics to 
embroidery and switch to Wilcom 
Decoration.

Tag as Appliqué Tag vector lettering for 
conversion to appliqué 
embroidery lettering with turning 
stitching.

Tag Fill as 
Turning Satin

Use this tag only for narrow 
vector objects, such as 
lettering-like vectors.

Tag as Photo 
Flash

Convert photos to Photo Flash 
embroidery. 

Keep Original 
Objects

Keep original objects after 
conversion.

Match to 
Embroidery 
Palette

Toggle thread-color matching for 
converted vector objects. 

Show 
Embroidery Toggle embroidery object display.

Virtual Decoration Quality: set the 
rendering quality of embroidery 
TrueView for a virtual decoration.

Design 
Properties

Access design properties including 
job order details.

Overview 
Window

Toggle Overview Window display. 
Use to view and pan thumbnail of 
current design. 

Object 
Properties

Toggle Object Properties display. 
Use it to preset properties or adjust 
for selected objects.

Color-Object 
List

Toggle Color-Object List display. 
Use to view and sequence design 
objects.

Colorway 
Editor

Toggle Colorway Editor display. Use 
it to assign thread colors to color 
palette and define colorways.

My Threads
Show or hide the My Threads docker 
to find threads from different charts 
and change design colors.

Stitch List Toggle Stitch List display. Use it to 
view, filter and select stitches.

Team Names
Toggle Teamname List display. Use 
it to view and edit individual team 
names. 

Carving 
Stamp

Toggle Carving Stamp display. Use 
to create needle penetrations using 
a ‘carving stamp’ as template.

Embroidery 
Clipart

Toggle the docker display. Use it to 
record and recover re-usable 
embroidery elements.
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Color Palette
The Color Palette contains a palette specific to 
and only visible in Wilcom Decoration. See 
Choosing thread colors for details.

Colorway Editor
The Colorway Editor contains tools for editing 
colorways.

Property bar
Adjust general object properties – width, height, 
position – by means of the Property Bar. 
Changes to the values are applied by pressing 
Enter on the keyboard. They are discarded when 
you press Esc or click anywhere outside the 
fields. See Access object properties for details.

Status & Prompt bars
The Status and Prompt bars provide continuous 
display of current cursor position status as well 
as instructions for use of selected tools. See 
Operating modes for details.

Toolbox toolbar
The Toolbox contains the embroidery 
digitizing/editing tools specific to and visible only 
in Wilcom Decoration. By default, the Toolbox 
docks vertically to the left of screen but can be 
floated, re-configured, and docked like any other 
toolbar.

Current Colorway: switch between 
pre-defined colorways. Define via 
Colorway Editor.

Colorway 
Editor

Toggle Colorway Editor display. Use 
it to assign thread colors to color 
palette and define colorways.

Background 
& Display 
Colors

Change design background and 
display color presets for the current 
colorway. 

Product 
Visualizer

Toggle Product Visualizer docker 
display. Use it to edit the current 
product in the design window.

Current 
Color Shows the current color.

Pick Color Pick up a color from the design 
window and make it current.

Apply 
Current 
Color

Apply the current color to embroidery 
objects. 

Add Color Add color slot to palette. Edit via the 
Colorway Editor.

Remove 
Color 

Remove unused last color slot from 
color palette.

Hide 
Unused 
Colors

Show or hide all unused colors in the 
color palette.

Remove 
Unused 
Colors

Remove unused colors from the 
palette.

Split Palette 
Color

Split selected color into two color 
slots. Normally used with multiple 
colorways.

Cycle Used 
Colors

Cycle through combinations of used 
colors. Left- or right-click. 

Color Wheel Access Color Wheel to test 
combinations of related colors. 

My Threads
Show or hide the My Threads docker 
to find threads from different charts 
and change design colors. 

Create 
Colorway Add a new colorway to the design. 

Delete 
Colorway Delete selected colorway. 

Rename 
Colorway

Rename selected colorway. 

Move 
Colorway 
Left Move selected colorway in Colorway 

Editor to right or left.Move 
Colorway 
Right

Background 
& Display 
Colors

Change design background and 
display color presets for the current 
colorway. 

Edit Color Edit specification and color of the 
selected color slot.

Show 
Colorway 
Details

Toggle display between current 
colorway and all colorways.

Hide 
Unused 
Colors

Show or hide all unused colors in the 
color palette.

Select See Select tools for details.

Reshape See Reshape tools for details.

Edit See Edit tools for details.

Lettering
Create embroidery lettering onscreen 
using native embroidery fonts or 
TrueType fonts. Right-click for settings.

Team 
Names

Toggle Teamname List display. Use it 
to view and edit individual team names. 
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Select tools
The Select tools let you to select all embroidery 
objects in a design, cancel all selections, or 
remove individual objects from a selected group. 
See Selecting objects for details.

Reshape tools 
The Reshape tools let you reshape objects with 
control points as well as edit individual stitches. 

See Reshaping embroidery objects for details. 
See also Stitches & Machine Functions.

Edit tools
The Edit tools contains tools for object editing 
operations. See Reshaping Objects for details.

Auto-Digitizing tools
The Auto-Digitizing tools provide everything 
necessary to automatically digitize shapes in 
electronic artwork, both bitmap and vector, 
without using manual input methods. Vedi 
Auto-digitizing image shapes nel Manuale 
d’Istruzioni.

Monogram
- ming

Create monograms using a selection 
of predefined monogramming styles, 
border shapes and ornaments.

Simple 
Offsets

Create simple outlines for any filled 
embroidery or closed vector object.

Outlines & 
Offsets

Create outlines and offsets of any type 
for any filled embroidery or closed 
vector object.

Open 
Offsets

Create precise offsets for any open 
embroidery or vector object.

Add 
Border

Add borders to designs (or selected 
objects) from a border library.

Color 
Blending

Generate color blends, perspective 
effects and shading in selected 
objects.

Auto-
Digitizing See Auto-Digitizing tools for details.

Envelope See Envelope tools for details.

Arrange See Arrange tools for details.

Mirror 
Merge See Mirror Merge toolbar for details.

Shaping See Shaping toolbar for details.

Select 
Object

Click to select individual objects. Use 
with Ctrl or Shift keys to select groups 
or ranges of objects. Drag a selection 
marquee to select multiple objects. 

Freehand 
Select

Select object by drawing a freehand 
line around it.

Select 
Current Select object at current cursor position.

Polygon 
Select

Select objects by digitizing a selection 
marquee around them.

Polyline 
Select

Select objects by digitizing a line 
through them.

Reshape 
Object

Reshape selected objects, edit stitch 
angles, and adjust entry/exit points. 
Right-click for settings.

Show 
Reshape 
Nodes

Toggle reshape nodes for selected 
objects.

Show 
Bézier 
Handles

Toggle Bézier handles for selected 
objects. (Only available when the 
Bézier reshape option is selected in the 
Options > Reshape tab.)

Show 
Stitch 
Angles

Toggle stitch angles for selected 
objects.

Show 
Entry/Exit

Toggle entry (green diamond) and exit 
(red cross) points for selected objects.

Stitch Edit Select individual stitches for editing.

Keep Last 
Stitch Keep last stitch in a column. 

Omit Last 
Stitch Omit last stitch in a column. 

Break 
Apart

Split branched objects – monograms, 
appliqués, lettering, etc – into 
components. Allows each to be edited 
individually.

Knife Cut objects along a digitized line, 
preserving stitch settings and colors.

Automatic 
Knife

Slice large objects into smaller ones 
with automatic overlaps.

Instant 
Smart 
Design

Automatically create embroidery from 
imported artwork instantly.

Smart 
Design

Create whole embroidery designs 
directly from imported artwork.

Keep 
Original 
Objects

Retain the original artwork during 
conversion.

Color 
Matching 
Method

Toggle thread color matching for auto 
digitizing.
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Envelope tools
Envelopes are typically applied to lettering 
objects, but they can also be applied to other 
types of embroidery object. See Applying 
envelopes for details.

Arrange tools
The Arrange toolbar contains tools for moving, 
aligning and distributing objects, including 

grouping and locking tools. See Modifying 
Objects for details.

Mirror Merge toolbar
Mirror Merge tools allow you to duplicate and 
transform selected embroidery objects, as well 

Crop 
Bitmap

Crop bitmap artwork for use with 
auto-digitizing tools.

Remove 
Crop

Click to remove crop. 

Prepare 
Bitmap 
Colors

Prepare bitmap images for automatic 
digitizing.

Turning 
Satin 
Object

Fill narrow column shapes with 
turning stitching.

Tatami Fill 
Object with 
Holes

Fill large areas with tatami stitching, 
preserving any holes.

Tatami Fill 
Object

Fill large areas with tatami stitching, 
ignoring any holes.

Centerline 
Run Object

Create centerlines in narrow shapes 
with Run stitching.

Outline Run 
Object

Create outlines around shapes with 
Run stitching.

Auto Trace 
To Vectors

Convert artwork to vector objects. 
These can be converted to 
embroidery objects.

Adjust 
Bitmap

Adjust image lightness and contrast in 
preparation for auto-digitizing.

Photo Flash Create whole embroidery designs 
directly from photographs.

Color 
PhotoStitch

Automatically turn grayscale or color 
photograph into embroidery. 

Bridge 
Envelope

Make lettering object to make it 
bulge or arch.

Penant 
Envelope Make objects compress.

Perspective 
Envelope Make objects bulge or stretch.

Diamond 
Envelope Make objects bulge or compress.

Delete 
Envelope

Delete envelopes from selected 
objects.

Group Group selected objects.

Ungroup Ungroup selected grouped objects.

Lock Lock selected objects.

Unlock All Unlock all locked objects in design.

Branching Automatically sequence and group 
like embroidery objects. 

Apply 
Closest Join

Join selected objects at the closest 
point. Re-apply closest join after 
editing. 

Break Apart

Split branched objects – monograms, 
appliqués, lettering, etc – into 
components. Allows each to be 
edited individually.

Align Left Left-align selected objects.

Align 
Centers 
Vertically

Align centers of selected objects 
vertically.

Align Right Right-align selected objects.

Align Top Align tops of selected objects.

Align 
Centers 
Horizontally

Align centers of selected objects 
horizontally.

Align 
Centers

Align selected objects through their 
centers. 

Align Bottom Align bottoms of selected objects.

Space 
Evenly 
Across

Distribute selected objects evenly 
across design window.

Space 
Evenly 
Down

Distribute selected objects evenly 
down design window.

Make Same 
Width

Scale selected object/s to same 
width as last-selected reference 
object.

Make Same 
Height

Scale selected object/s to same 
height as last-selected reference 
object.

Make Same 
Width & 
Height

Scale selected object/s to same size 
as last-selected reference object.
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as merge them into a single object. See Mirroring 
objects for details.

Shaping toolbar
When working with overlapping vector or 
embroidery objects, you can merge, trim or split 
them using the Shaping tools. See Shaping 
objects for details.

Graphics Digitizing tools
The Graphics Digitizing toolbar contains 
digitizing tools that operate in a similar way to 
CorelDRAW® Graphics Suite or other 
graphics applications. Assign a stitch type to a 
shape by selecting from the Outline Stitch 
Types or Fill Stitch Types toolbar. See also 
Digitizing with graphical tools. See also Appliqué 
Digitizing.

Mirror Copy 
Horizontal

Duplicate and mirror horizontally 
and merge overlapping objects 
(optional). 

Mirror Copy 
Vertical

Duplicate and mirror vertically and 
merge overlapping objects 
(optional). 

Mirror Copy 
Horizontal & 
Vertical

Duplicate and mirror selected 
objects around a center point.

Array

Duplicate designs, such as badges, 
automatically re-sequencing color 
blocks for efficient multiple design 
stitchouts.

Reflect
Duplicate and mirror objects or 
designs. Use to create decorative 
borders.

Wreath Duplicate objects around a center 
point. Use to create wreath designs.

Kaleidoscope Mirror paired objects in a wreath.

Mirror Merge Settings

Rows: Set number of rows in the 
array.

Row Spacing: Set spacing between 
rows in the array.

Columns: Set number of columns in 
the array.

Column Spacing: Set spacing 
between column in the array.

Wreath Points: Set number of 
duplicates (including source). 
Kaleidoscope works best with an 
even number.

Set precise distance and angle – 
measured from center of source 
object to center of wreath or 
kaleidoscope.

Weld Merge selected overlapping objects 
into a single ‘flattened’ object.

Intersect Trim selected overlapping objects so 
that only intersected areas remain.

Exclude Trim selected overlapping objects and 
preserve individual properties.

Front-Back
Trim selected overlapping objects so 
that only non-overlapping areas of the 
topmost object remain.

Back-Front
Trim selected overlapping objects so 
that only non-overlapping areas of the 
bottommost object remain.

Flatten Trim all overlaps in selected 
overlapping objects.

Divide
Split selected objects into separate 
adjoining objects wherever they 
intersect.

Combine
Merge properties of selected 
overlapping objects and trim 
overlapping areas.

Keep 
Original 
Objects

Keep original objects after shaping 
operations.

Overlap: Adjust object overlaps 
resulting from Flatten or Divide 
shaping operations.

Digitize 
Open 
Shape

Digitize open object in the current stitch 
type – outline only.

Digitize 
Closed 
Shape

Digitize closed object in the current 
stitch type – outline or fill.

Digitize 
Column

Digitize column of varying width in the 
current stitch type – outline or fill.

Rectangle
Digitize rectangle or square in the 
current stitch type – outline or fill. Press 
<Ctrl> to constrain.

Ellipse Digitize ellipse or circle in the current 
stitch type – outline or fill.

Basic 
Shapes

Digitize basic shapes. Press <Ctrl>to 
keep the proportion of the shape. 
Press <Shift> to center at the first point 
entered.

Freehand 
Open 
Shape

Draw open freehand object in the 
current stitch type – outline only.

Freehand 
Closed 
Shape

Draw closed freehand object in the 
current stitch type – outline or fill.

Stitch 
Angles See Stitch Angle tools for details.
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Stitch Angle tools
Stitch angle adjustments depend on object type. 
With Complex Fill objects you can set a single 
stitch angle for the entire object. You can add 
multiple stitch angles with the Stitch Angles 
tool. See Adjusting stitch angles for details.

Hole tools
EmbroideryStudio provides special tools for 
cutting holes in objects as well as filling holes in 
objects. See Adding & filling holes for details.

Appliqué tools
The Appliqué toolbar contains tools specific to 
appliqué work. These include tools for creating 
appliqué objects, resequencing them for efficient 
stitchout, as well as generating partial cover 
stitching for overlapping appliqué objects. See 
Appliqué Digitizing for details.

Traditional Digitizing tools
The Traditional Digitizing tools provide all the 
input methods embroidery digitizers are familiar 
with. Traditional digitizing methods divide into 
three main categories – ‘free shapes’, ‘column 

shapes’, and ‘outlines’. See also Embroidery 
digitizing.

Manual tools
The Manual Tools provides tools for digitizing 
individual stitches with the Manual method. 
Enter single manual stitches or three stitch layers 
at a time. See Digitizing manual stitches for 
details.

Stitch Types toolbar
The Stitch Types toolbar provides a range of 
basic outline and fill stitch types as well as those 
of a more artistic or decorative kind. Left-click 

Add Holes See Hole tools for details.

Auto 
Appliqué See Appliqué tools for details.

Stitch 
Angles Add stitch angles to selected objects. 

Remove 
Stitch 
Angles

Remove stitch angles from closed 
objects with turning stitches.

Add Holes Add hole/s to selected filled object.

Fill Holes Fill hole/s in selected object. Choose 
an exact fit or offset the edges.

Remove 
Holes Remove hole/s from selected object.

Auto 
Appliqué

Digitize appliqué object with up to four 
layers of stitching - guide run, cutting 
line, tack stitches, and cover stitches. 

Combine 
Appliqué

Combine and sequence components 
of selected appliqué objects for 
efficient stitchout.

Partial 
Appliqué

Create partial cover stitching for 
overlapping appliqué objects.

Remove 
Overlaps

Remove underlying layer of stitching in 
overlapping objects using the selected 
object as a ‘cutter’. Right-click for 
settings.

Digitize 
Run

Create row of single stitches along a 
digitized line.

Backtrack Reinforce an outline, stitching it in the 
reverse direction to the original.

Repeat
Duplicate an outline in the same 
direction – typically used with closed 
shapes.

Column A Digitize column of of turning stitches of 
varying width.

Column B Digitize column of turning stitches, 
where opposite sides are different.

Column C Digitize column or border of fixed 
width.

Complex 
Fill

Digitize filled shape with a single stitch 
angle in the current stitch type – outline 
only.

Complex 
Turning

Digitize filled shape with turning 
stitches in the current stitch type – 
outline only.

Star Digitize star shape filled with zigzag 
stitching.

Ring Digitize circle and oval-shaped ring.

Manual See Manual tools for details.

Use Motif Add motifs to design one-by-one. 
Rotate, scale, or mirror as you add. 

Branching Automatically sequence and group like 
embroidery objects. 

Manual

Digitize individual ‘manual’ stitches. 
Manual objects have no outlines, only 
stitches. Stitch density does not 
change. 

Triple 
Manual

Digitize triple ‘manual’ stitches. Manual 
objects have no outlines, only stitches. 
Stitch density does not change. 
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icons to select stitch type. Right-click to access 
stitch settings. See also Stitch Types.

Stitch Effects toolbar
The Stitch Effects toolbar contains tools for 
modifying or improving stitch quality, including 

Outlines

Run
Use for single stitch run outlines and 
details. Apply to open or closed 
shapes.

Sculpture 
Run

Use for alternating triple-single stitch 
run for a hand-stitched look. Apply to 
open or closed shapes.

Triple Run
Use for heavier triple stitch outlines 
and details. Apply to open or closed 
shapes.

Backstitch
Use to create traditional backstitch 
outlines for delicate borders. Apply to 
open or closed shapes.

Stemstitch

Use to create traditional stemstitch 
outlines for decorative details such 
as stems and vines. Apply to open or 
closed shapes.

Motif Run
Use for ornamental craftstitch 
outlines. Choose from a motif library. 
Apply to open or closed shapes.

Satin
Use for glossy satin borders or 
columns of even width. Apply to open 
or closed shapes.

Satin Raised

Use to create layered satin borders 
or columns of even width for a raised 
surface. Apply to open or closed 
shapes.

Zigzag
Use to create borders or columns of 
even width for an open 'sawtooth' 
effect.

E Stitch Use to create borders or columns of 
even width for an open 'comb' effect.

Tatami
Use to create borders or columns of 
even width for different needle 
penetration patterns.

Program 
Split

Use to create borders or columns of 
even width for decorative needle 
penetration patterns.

Square
Use to create borders or columns of 
even width for an open 'toothed' 
effect.

Contour Use for contoured stitching following 
borders or columns of even width. 

Coil Use to create borders or columns of 
even width for an open ‘coil’ effect. 

Vector 
Outline

Use to create vector outlines. Apply 
to open or closed shapes.

Fills

Satin
Use to create glossy satin fills for 
narrow shapes. Apply to closed 
shapes.

Satin Raised
Use to create layered satin fills for a 
raised surface. Apply to closed 
shapes.

Zigzag
Use to create zigzag fills for an open 
'sawtooth' effect. Apply to closed 
shapes.

E Stitch
Use to create  E stitches for an open 
'comb' effect. Apply to closed 
shapes.

Tatami

Use to create solid stitching for large 
shapes with different needle 
penetration patterns. Apply to closed 
shapes.

Coil Use to create open coil fills. Apply to 
closed shapes.

Square Use to create open straight parallel 
fills. Apply to closed shapes. 

Double 
Square

Use to create grid fills. Apply closed 
shapes. 

Island Coil Use to create concentric rows of coil 
fills. Apply closed shapes. 

Program 
Split

Use to create solid decorative fills 
using needle penetrations to form 
tiled patterns. Apply to closed 
shapes.

Motif Fill

Use to create decorative fills using 
embroidery motifs to form repeating 
patterns. Choose from a motif library. 
Apply to closed shapes.

Cross Stitch
Use to fill large areas with low stitch 
count cross-stitch fills. Apply to 
closed shapes.

Contour
Use to create curved fills where 
stitches follow contours of a shape. 
Apply to closed shapes.

Spiral
Use to create spiral stitching 
radiating from the center of the 
object. Apply to closed shapes.

Stipple Fill
Use to create a stipple fill which 
meanders randomly within a shape. 
Apply to closed shapes.

Stipple 
Backstitch

Use to create a stipple backstitch fill 
which meanders randomly within a 
shape. Apply to closed shapes.

Stipple 
Stemstitch

Use to create a stipple stemstitch fill 
which meanders randomly within a 
shape. Apply to closed shapes.

Vector Fill Use to create a vector fill. Apply to 
closed shapes.
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applying automatic underlay to selected objects. 
Right-click for settings.

View toolbar
The View toolbar commands for viewing 
embroidery designs – e.g. as design outlines, by 
stitches, by machine functions, as they will stitch 
out on the fabric – either separately or in 
combination. Right-click to access settings. See 
also Viewing Designs.

Auto Underlay
Generate automatic underlay for 
selected objects. Right-click for 
settings.

Pull 
Compensation

Apply to selected objects to 
compensate for fabric stretch. 
Right-click for settings.

Auto Jump
Preserve long stitches in new and 
selected objects. Right-click for 
settings.

Shortening

Reduce stitch bunching in tight 
curves by shortening stitches 
along inside edge. Right-click for 
settings.

Fractional 
Spacing 

Even out stitch density along inside 
and outside edges. Right-click for 
settings.

Mitre Corners
Create sharp mitre corners at 
intersections. Right-click for 
settings.

Cap Corners Create capped corners for fewer 
stitches. Right-click for settings.

Lap Corners Create ‘Tidori’ style corner 
stitching. Right-click for settings.

Jagged Edge

Create rough edges, shading 
effects, or imitate fur and other 
fluffy textures in selected objects. 
Right-click for settings.

Trapunto
Force underlying travel runs to the 
edges of selected objects. Use with 
open stitching. 

User-Defined 
Split

Create custom split-line effects. 
Right-click for settings.

Accordion 
Spacing

Create perspective and shading 
effects with stitch spacing varying 
between dense and open fill. 
Right-click for settings.

Flexi Split

Create decorative split patterns 
following stitch angles and scaled 
according to object width. 
Right-click for settings.

Radial Fill
Apply or exclude Radial Fill effect 
to new or selected objects. 
Right-click for settings.

Florentine 
Effect

Create custom curve-line stitching 
with a single guideline. Right-click 
for settings.

Liquid Effect
Create custom curve-line stitching 
with twin guidelines. Right-click for 
settings.

3D Warp Create 3D effects in selected motif 
fills. Right-click for settings.

TrueView Toggle between stitch view and 
TrueView™.

Show 
Stitches Toggle embroidery stitching display.

Show 
Outlines Toggle object outlines display.

Show 
Needle 
Points

Toggle needle point display.

Show 
Connectors Toggle connecting stitch display.

Show 
Functions

Toggle display of machine function 
symbols.

Show 
Repeats Toggle design repeats display.

Show 
Bitmaps Toggle bitmap images on or off.

Show 
Vectors Toggle vector graphic display.

Show 
Graphics as 
Dimmed

Dim graphic backdrops to show 
stitches more clearly for digitizing.

Show 
Appliqué 
Fabric

Toggle appliqué fabric display.

Show 
Product

Toggle current product display. 
Right-click for Product Visualizer 
settings.

Show Hoop Toggle hoop display.

Show Bling Toggle rhinestone (bling) display.

Show Grid Toggle grid display.

Show 
Rulers & 
Guides

Toggle rulers & guides display.

Design Measurement system: 
Change measurement units within 
software without changing system 
settings. 

Auto Hoop
Prompt system to select a hoop from 
My Hoops list. Right-click Show 
Hoops for settings.
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Zoom toolbar
Zoom tools allow you to magnify your view of the 
design by zooming in on individual stitches or 
details, or zoom out to view more of the design. 
See Zoom & pan designs for details.

Sequence toolbar
The Sequence toolbar provides a convenient 
means for sequencing selected objects. Use it in 
conjunction with the Color-Object List. See 
Sequencing embroidery objects for details.

Transform toolbar
The Transform toolbar contains tools for 
mirroring, rotating and skewing objects. See 
Modifying Objects for details.

Styles toolbar
Use the Styles toolbar to apply pre-defined 
styles to a design. The tools let you:
 Apply current settings to selected objects
 Change current settings, and
 Apply styles to selected objects.
The styles you select as ‘favorites’ are each 
assigned a tool icon on the toolbar. See Working 
with styles for details.

Stitch toolbar
The Stitch toolbar contains a group of tools 
concerning with stitch level editing and 

Auto Start & 
End

Set auto start and end points for 
entire design.

Stitch 
Player

Simulate embroidery design stitchout 
on screen.

Zoom
Zoom in or out via left and right mouse 
clicks, or drag a selection marquee to 
view design detail.

Zoom 
1:1 Display design at actual size.

Zoom Factor: Select zoom scale from 
the droplist or key in a zoom factor and 
press Enter.

Zoom to 
Fit Display whole design in design window.

Zoom to 
Selected Magnify only selected objects.

Zoom to 
Product

View entire product in the design 
window.

Zoom to 
Hoop

Display entire hoop in the design 
window. 

Back 1 
Object

Move a selection back one object in the 
stitching sequence. 

Forward 1 
Object

Move a selection forward one object in 
the stitching sequence. 

Back 1 
Color

Move a selection back one color in the 
stitching sequence. 

Forward 1 
Color

Move a selection forward one color in 
the stitching sequence. 

Move to 
Start

Move a selection to start of stitching 
sequence. 

Move to 
End

Move a selection to end of stitching 
sequence. 

Sequence 
by Selects

Resequence objects in the order 
selected.

Sequence 
by Color

Resequence all blocks of like color. (To 
maintain separate color blocks, use the 
Color-Object List.)

Mirror X Flip selected objects horizontally.

Mirror Y Flip selected objects vertically.

Mirror by 
Reference 
Line

Mirror objects around a defined axis 
using a reference line.

Rotate Left 
45°

Rotate selected objects by 45° in 
counter-clockwise direction.

Rotate Right 
45°

Rotate selected objects by 45° in 
clockwise direction.

Rotate: Rotate selected objects by 
specified amount - positive or 
negative - in degrees.

Skew: Skew selected objects by 
specified amount - positive or 
negative - in degrees.

Transform by 
Reference 
Line 
Numerically

Transform selected objects using a 
combination of reference points and 
numeric values.

Transform by 
Reference 
Line Freely

Rotate selected objects with the aid 
of reference points alone.

Make 
Properties 
Current

Make properties of a selected object 
current for the design.

Apply 
Current 
Properties

Apply current settings to selected 
objects.

Favorite 
Style

Assign up to 10 favorite styles via 
Manage Styles. Select object and click 
button to apply.

Apply Style Apply pre-defined style to selected 
objects.
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processing. See also Stitches & Machine 
Functions.

Function toolbar
Function tools allow you to insert machine 
functions manually. See Stitches & Machine 
Functions for details.

Caution  When you insert stitches or machine 
functions manually, you must maintain them 
manually. If an object’s stitches are regenerated 
for any reason, all stitch editing and machine 
functions are lost.

Legacy Features toolbar
Newer machines use USB or Wired-Wireless 
network connections. They can appear as a disk 
drive or be setup to read designs from a folder on 
the PC. Older machines use serial ports or even 
proprietary embroidery disks. The Legacy 
Features toolbar contains functions for 
connecting to older styles machines. See 
Outputting Designs for Production for details.

Travel toolbar
The Travel toolbar contains tools for viewing the 
stitching sequence of a design color-by-color, 
object-by-object, or stitch-by-stitch. Traveling 
can be initiated from any stitch in a design. See 
Viewing stitching sequence for details.

Generate 
Stitches Generate stitches for selected objects.

Stitch Edit Select individual stitches for editing.

Selects 
On/Off

Select a range of objects as you travel 
through the design.

Process 
Stitches

Adjust stitch density of and/or scale 
whole or selected parts.

Split 
Object

Split object in two at current needle 
position. Use with Travel by Stitch 
functions.

Penetrations
Toggle Penetrations function. Use to 
engage needles or borers, or 
disengage to create jumps. 

Borers Toggle Borers function. Use for 
cutting holes in fabric.

Insert Stop Insert Stop function at current stitch 
cursor position. 

Insert Tie-off Insert Tie-off function at current 
stitch cursor position. 

Insert Trim Insert Trim function at current stitch 
cursor position.

Insert Empty 
Stitch 

Insert Empty stitch function at 
current stitch cursor position.

Insert Empty 
Jump

Insert Empty jump function at current 
stitch cursor position.

Insert 
Function

Insert machine function at current 
stitch cursor position.

Clear 
Function

Remove machine functions from 
current stitch cursor position. 

Edit Function Edit machine function at current 
stitch cursor position.

Slow Insert Slow function to decrease 
machine speed.

Fast Insert Fast function to increase 
machine speed.

Send to 
Machine 
Manager

Send multiple designs to machine 
from EmbroideryStudio or 
DesignWorkflow and view or manage 
job queues. 

Send to 
Stitch 
Manager

Send current design direct to 
embroidery machine for production.

Embroidery 
Disk

Open designs from or save to 
proprietary embroidery disk formats.

Hardware 
Setup

Set up a machine connection with 
name, port, and protocol.

Start/End 
Design

Move stitch cursor to the start/end of 
design. Left/right-click.

Travel by 
Object

Move stitch cursor to the next/previous 
object. Left/right-click.

Travel by 
Segment

Move stitch cursor to the next/previous 
segment. Left/right click.

Travel by 
Color

Move stitch cursor to the next/previous 
color change. Left/right click.

Travel by 
Function

Move stitch cursor to the next/previous 
machine function. Left/right click.

Travel by 
Trim

Move stitch cursor to the next/previous 
Trim function. Left/right click.

Travel 
1000 
Stitches

Move stitch cursor 
forwards/backwards 1000 stitches at a 
time. Left/right click.

Travel 100 
Stitches

Move stitch cursor 
forwards/backwards 100 stitches at a 
time. Left/right click.

Travel 10 
Stitches

Move stitch cursor 
forwards/backwards 10 stitches at a 
time. Left/right click.

Travel 1 
Stitch

Move stitch cursor 
forwards/backwards 1 stitch at a time. 
Left/right click.
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Sequin toolbar
The Sequin toolbar provides a dedicated set of 
sequin tools which allow you to digitize sequined 
designs for compatible machines. There are also 
tools for creating boring holes. See Sequin 
Digitizing for details. 

Bling toolbar
The Bling toolbar contains tools for creating 
bling runs as well as fills. There are two available 
types of bling run: Simple Run (same size 
stones) and Pattern Run (different sizes 
following a regular pattern).

Chenille toolbar
If you have a Chenille option installed with your 
EmbroideryStudio system, the design window 
will include a Chenille toolbar containing specific 
Chenille stitch types and machine functions. See 
Chenille User Manual Supplement for details.

Schiffli toolbar
If you have a Schiffli option installed with your 
EmbroideryStudio system, the design window 
will include a Schiffli toolbar which contains 
specific Schiffli functions. See Schiffli User 
Manual Supplement for details.

Sequin 
Palette 
Editor

Select sequins for the design from a 
sequin library.

Sequin Palette: Select sequin shapes 
for the current design.

Manual 
Sequin

Digitize individual sequin drops. 
Right-click for settings.

Left 
Sequin

Switch to left sequin when digitizing 
twin-sequin designs.

Right 
Sequin

Switch to right sequin when digitizing 
twin-sequin designs.

Sequin 
Run Auto

Create a string of sequins along a 
digitized line. Right-click for settings.

Sequin 
Run 
Manual

Digitize sequin-drops along a digitized 
line. Right-click for settings.

Sequin Fill Digitize and fill larger shapes with 
sequins. Right-click for settings.

Sequin 
Edit

Fine-tune placement of individual 
sequins within selected sequin objects. 

Vectors to 
Sequins

Create sequin runs from sequin 
artwork. Digitize a guideline 
connecting the sequins to include 
within a run.

Drop 
Sequin

Drop a sequin at the current needle 
position. For twin-sequin machines, 
left-click to drop a left-sequin, 
right-click to drop a right-sequin.

Clear 
Function

Remove any sequin functions from the 
current needle position.

Bling 
Palette 
Editor

Select rhinestones for the design from 
a bling library.

Bling 
Manual Digitize individual bling drops.

Bling Run 
Auto

Create a string of rhinestones along a 
digitized line. Right-click for settings.

Bling Fill Digitize and fill larger shapes with 
rhinestones. Right-click for settings. 

Bling 
Lettering

Create bling lettering onscreen using 
native embroidery fonts or TrueType 
fonts. Right-click for settings.

Automatic 
Overlap 
Removal

Toggle on to remove excess 
rhinestones in overlapping Bling 
objects.

No 
Automatic 
Overlap 
Removal

Toggle on to preserve rhinestones in 
overlapping Bling objects.

Highlight 
Bling 
Overlaps

Toggle on to highlight overlapping 
rhinestones. Use with manual edits.

Bling Edit
Fine-tune placement of individual 
rhinestones within selected Bling 
objects.

Show 
Bling Work 
Area

Visualize design within the work area of 
the selected machine model. 
Right-click for settings.

Chain

Create decorative stitching 
resembling links of a chain – used for 
outlines and borders as well as 
monograms. 

Moss
Create dense cover using looped 
stitch typical of Chenille raised 
stitching – best with simple shapes.

Needle 
Height

Control height of loop formed when 
sewing Moss stitch as well as width of 
Chain stitch.

Compound 
Chenille

Use with Complex Fill to 
automatically generate Moss or 
Chain stitch run-arounds for complex 
shapes. Right-click to adjust offsets.

View by 
Chain / 
Moss

View Chenille objects to allow easy 
identification of Chain and Moss 
elements – lockstitch in green, Chain 
in blue, Moss in red.

Blatt Reduce thread tension.

Stepp Increase thread tension.
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Manage Designs toolbar
Manage Designs tools allows for fast searching 
of designs on shared network drives. This is 
important for businesses with multiple 
computers and multiple users creating and 
accessing EMB or machine format designs. See 
Managing Designs for details.

View (Design Library) toolbar
Design Library allows for fast searching of 
designs on shared network drives. This is 
important for businesses with multiple 
computers and multiple users creating and 
accessing EMB or machine format designs. The 
View (Design Library) toolbar contains functions 
for quick search, sort, and location of designs on 
your company network. See Managing Designs 
for details.

End Jump Insert End Jump function to engage 
needles or borers.

Begin Jump Insert Begin Jump function to 
disengage needles or borers.

Slow Insert Slow function to decrease 
machine speed.

Fast Insert Fast function to increase 
machine speed.

Borer In Insert Borer In function to engage 
borer.

Borer Out Insert Borer Out function to 
disengage borer.

Borer Depth: Set cutting depth to 
determine borer hole size – valid 
depths are 1-13 for Plauen and 0-12 
for Saurer.

RPM- Insert RPM- function to decrease 
turning speed of machine.

RPM+ Insert RPM+ function to increase 
turning speed of machine.

Fadenleiter-
Insert Fadenleiter- function to 
decrease Fadenleiter stroke by one 
increment.

Fadenleiter+
Insert Fadenleiter+ function to 
increase Fadenleiter stroke by one 
increment.

Thread 
Brake-

Insert Thread Brake- function to 
decrease thread brake pressure.

Thread 
Brake+

Insert Thread Brake+ function to 
increase thread brake pressure.

Drop Sequin Insert Drop Sequin function to 
trigger a sequin drop.

Schiffli 
Arrangement

Split designs into color blocks which 
are then arranged into logical parts.

New from 
Selected

Create new design(s) based on the 
design(s) selected in the My Designs 
window. 

Open 
Selected

Open the design(s) selected in the My 
Designs window. 

Open 
Recent 
Designs

Open a design from a list of recently 
opened designs.

Cut Cut selection and place it on the 
clipboard. 

Copy Copy selection and place it on the 
clipboard. 

Paste Paste contents of the clipboard.

Convert 
Selected 
Designs

Convert the design selected in the My 
Designs window into different file 
types. 

Send to 
Connection 
Manager

Stitch the design selected in the 
Embroidery Library. 

Print 
Selected

Print the design selected in the My 
Designs window. 

Print 
Selected to 
Catalog

Print the selected designs set in to a 
catalog. 

Export 
Design List

Export a text or CSV file containing a 
list of the visible design files and their 
properties. 

Manage 
Embroidery 
Library 
Locations

Add or remove existing folders from 
the Embroidery Library, enabling fast 
searching and filtering.

Layout Toggle the navigation pane, details 
pane, and/or preview pane display.

Design 
Properties

Toggle the Design information 
docker display. 

Change 
View Change your view of design lists.

Reset Detail 
Columns

Reset the columns displayed in 
details view to the default layout. 

Group Designs By: Group the current 
list of designs by the selected 
property. 

Ascending 
Order Group designs in ascending order. 

Descending 
Order Group designs in descending order. 

Sort Designs By: Sort the current list 
of designs by the selected property.

Show Showing: Filter the current list of 
designs by file type. 

Find Designs: Filter designs based 
on the given search criteria. 
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Keyboard shortcuts

In addition to shortcut keys, standard 
MS Windows® Alt key shortcuts apply in some 
cases. Use the Alt key with the letter underlined 
in the menu. To cancel an operation, press Esc 
twice.
General functions

To .. Press

start new design C+N 
open design C+O or 

A+F+O

close design A+F+C

save design C+S

export machine file V+E

save as A+f+A

print design C+P or 
A+f+p

show/hide Grid V+G

show/hide Overview window V+V

show/hide Color-Object List V+L

show Stitch List V+J

open Lettering dialog A

measure distance on-screen M

show measure tooltip C+i

undo command C+Z

redo command C+Y 
cancel command E 
open online help 1

exit application A+4 

Digitizing functions 

To .. Press or

activate Complex Turning 2

activate Complex Fill 3

activate Column A 4 V+A

activate Column B 5

activate Column C 6

activate Backtrack V+X

activate Appliqué 7

activate Single Run 8 V+N

activate Triple Run 9

activate Motif Run 0

activate Backstitch !

activate Stemstitch @

apply Satin stitch V+I

apply Tatami stitch V+M

finish digitizing object (keep last 
stitch)

R

finish digitizing object (omit last stitch) s

finish digitizing free shape boundary R

delete last input point B

generate stitches G

switch between fill and run stitch s

switch between fill and manual stitch R

toggle Auto Underlay on/off u

activate Auto Trace To Vectors for 
selected artwork

C+M

activate Branching I

make combined vector object V+H 

Selecting objects

To .. Press

select all objects C+A 
deselect all objects E or X 
select by color C+A+a

activate Select Object tool o 
deactivate Select Object tool E

select object at current needle position V+O 
select multiple objects C+[ 
select range of objects V+[

select next object T 
select previous object V+T 
select object beneath 2+[ 
add next object to selection C+T 
add previous object to selection C+V+

T 
activate Polygon Select tool C+L 
toggle stitch selection in Stitch Edit 
mode

Q 

group selected objects C+G 
ungroup selected objects C+U 
lock selected object K 
unlock all locked objects V+K 
select/deselect stitches * T 

* Stitch Edit tool selected

Viewing designs

To .. Press

toggle TrueView™ on/off T 
show/hide stitches S

show/hide outlines L

show/hide needle points † .

show/hide connectors V+C

show/hide function symbols V+F

view by color A+c

hide others V+s

show bitmaps D

show vectors V+D

zoom (marquee) B 
zoom to 1:1 scale (100%) 1 
specify zoom factor F 

† Period * Zero ^ Hold down

Digitizing functions  (cont)

To .. Press or
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zoom in 2X Z 
zoom out 2X V+Z 
zoom to all design * 0

zoom to selected objects * V+0

zoom to product * C+0

zoom to hoop * A+0

zoom box in Overview window V+B

activate panning P 
deactivate (temporarily) Auto Scroll ^ V

toggle Auto Scroll on/off C+V+A

center current stitch in Design Window C 
return to previous view V 
redraw (refresh) screen r

activate Stitch Player V+R

Viewing stitching sequence

To travel .. Press

to start of design h

to end of design e

to next color x

to previous color z

to next object C+T

to previous object V+T

to next segment ^ C+r

to previous segment ^ C+l

to next function ^ C+x

to previous function ^ C+z

to next trim ^ C+r

to previous trim ^ C+l

1 stitch forward ^ r

1 stitch backward ^ l

10 stitches forward ^ b

10 stitches backward ^ t

100 stitches forward † +

100 stitches backward † -

1000 stitches forward † V++

1000 stitches backward † V+-

^ No object selected † Numeric keypad only, no object selected

Cutting & pasting objects

To .. Press or

cut object C+X V+D

copy object C+C C+Z

paste object C+V V+Z

duplicate object C+D 
duplicate with offset C+V+D

paste special > object property 
position

V+Z

paste special > shift pasted objects C+V+V

Viewing designs (cont)

To .. Press

† Period * Zero ^ Hold down

paste special > center at current 
stitich

C+A+V

paste special > start at current stitch V+A+V

delete selected objects or last 
object

D

Modifying objects & stitches

To .. Press or click

move selected object horizontally or 
vertically

* C+:

mirror horizontally C+1

mirror vertically A+1

nudge selected object [+t b l r 
maintain proportions while resizing † V+:

activate Reshape Object tool H 
activate Show Stitch Angles tool A+a

activate Show Reshape Nodes tool A+N

change reshape node type ^ [+M

activate Stitch Angles tool C+H

activate Stitch Edit tool E 
add stitch angles (Complex Turning) C+H

remove overlaps C+V+E

check design integrity !

* Drag object † Drag handle ^ Select control point

Schiffli functions

To .. Press

insert Blatt/Stepp function [ ]

insert Fadenleiter Plus/Minus < >

insert Boring Tension Start/End / \

insert RPM Plus/Minus : "

change Schiffli borer depth ;

show Schiffli repeats W

Cutting & pasting objects (cont)

To .. Press or
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Appendix A

Supported Machine, File and Disk Types

This section provides details of the file and disk types supported by 
EmbroideryStudio. Details are also provided about the conversion of Melco CND, 
Wilcom INP, and Gunold PCH design formats to and from EMB. The section also 
provides details of vector and bitmap (raster) formats.

Note  There are many additional Schiffli file formats to suit specific Schiffli 
machines. EmbroideryStudio supports the most important of these. See the ES 
Schiffli User Manual Supplement for details.

Supported machine types

The table shows the machine types supported by EmbroideryStudio. Make sure 
you first check the recommended connection settings for your particular 
machine. If you don’t have a record of the connection settings required to set 
up your embroidery machine, a list can be found at the Wilcom Support Center. 
This provides connection information for all the machines listed in this table. See 
Hardware Settings for details.

Machine format Description

Barudan This format is used for many Barudan machines. It supports up to 9 
needles. The Barudan format is suitable for paper tape, FMC disks, 
and the DSB file format.

Barudan Chenille This format is used only for the older BELM - A3C series of Barudan 
Chenille Machines with 5 Chenille colors. Newer models use 
Barudan FDR-II Chenille Combination.

Barudan FDR-II 
Chenille 
Combination

This format is used for newer models of Barudan Chenille machines 
supporting 6 chenille colors such as the BEDYH and BEDSH. Using 
this format, you can digitize pure Chenille or even a combination of 
Chenille and Lockstitch in the one design.

Barudan FDR-II 
Lockstitch

This format is currently used for BED* series lockstitch machines and 
is the standard for all new Barudan lockstitch machine models. It 
supports up to 15 needles and optional sequin attachments.

Barudan FDR-II 
Twin Sequin

This is a Barudan twin sequin machine. The design needs to be 
digitized using this machine format for it to run on Barudan machine 
with a twin-sequin attachment.

Barudan FDR-II 
Twin Sequin 
Chenille 
Combination

This is a Barudan twin sequin and Chenille combination machine. 
The design needs to be digitized using this machine format for it to 
run on Barudan machine with a twin-sequin and chenille attachment.

Barudan FDR-II 
Lockstitch and SWF 
Twin Sequin

Barudan Z Series This format is used for Barudan Z series machines with 10 or more 
needles.
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Note  If not already a member of the WSC, you will need to register as a licensed 
user of Wilcom software. See www.wilcom.com/support for details.

Supported file formats

In conjunction with CorelDRAW® Graphics Suite, EmbroideryStudio reads and 
writes a wide variety of related and sometimes complementary decoration 
processes or techniques. See also Exporting multiple decoration files.

Supported embroidery file formats

There are two types of embroidery file format:

Brother / Babylock

Happy

Inbro This format is used for main types of Inbro machines.

Melco This format is used for main types of Melco machines.

Melco Chenille This format is used for Melco-enabled Chenille machines.

Pfaff This format is used for main types of Pfaff machines.

Schiffli This format is used for Schiffli machines.

SWF This format is used for main types of SWF machines.

Tajima This format is used for main types of Tajima machines.

Tajima TBF This is used for Tajima needle addressing capable machines. TBF 
(Tajima Binary Format) file format is a more intelligent machine 
format which holds needle addressing information. The design needs 
to be digitized using this machine format for it to run on Tajima 
machines with a twin-sequin attachment.

Tajima TMCE-100 This format is used for Chenille-enabled Tajima machines.

Tajima TMCE-600 This format is used for Chenille-enabled Tajima machines.

Toyota This format is used for main types of Toyota machines.

Zangs This is the format for Zangs and Marco brand machines and pre-1988 
ZSK machines without trimmers.

ZSK 1 This format is for ZSK machines that have 7 or fewer needles – 
generally those older than 1991.

ZSK 2 This format is for ZSK machines that have more than 7 needles and 
those characterized by a single-top thread trimmer.

ZSK TC This format is for ZSK machines that accept Transport Code Disks 
(DOS format disks).

Machine format Description

File type Description

Design Design files usually contain digitized shapes and lines, selected stitch types 
and stitch values and effects.

Machine Machine files generally contain stitches and machine functions and are only 
suited to specific embroidery machines.

http://www.wilcom.com/support


EmbroideryStudio e4 User Manual 947

Wilcom file formats
EmbroideryStudio uses its own native EMB embroidery file format which 
combines the advantages of design files and machine files. Outlines, stitches, 
thread colors, and other data are stored together. Outlines mean the file can be 
scaled and manipulated on an object basis while the stitch data preserves 
manual stitch-by-stitch edits and touchups. Features of most third-party formats 
are supported. Variants and precursors of the EMB file format are also shown in 
the table below.

Note  
 ^ Can only be written by ES Cross Stitch application. 
 † ESD is the native file format of DOS ES, the precursor to the current 

EmbroideryStudio. It is actually a machine file format with stitch blocks, stitch 
types and parameters, and an icon. It has few of the advantages of the 
current EMB file format.

 ‡ Wilcom INP is the native file format of Wilcom Computer Embroidery Design 
software. It is a design file format but it contains no stitch data. Wilcom INP 
designs can be directly converted to EMB files although EmbroideryStudio 
interprets some of the stitch types differently. See Conversion of Wilcom INP 
format to Wilcom EMB for details.

 * T0? formats contain stitch data that can be used to create paper tapes. This 
is the purpose for which they were originally created.

Extension Format Read Write

EMB EmbroideryStudio design file (up to & including 
ES e4)

 

EMB DecoStudio design file (up to & including e1)  

EMC Clipart files  

EMX ^ Wilcom Cross Stitch 

ESD † Wilcom DOS format 

ESL Wilcom ESL  

ESS Wilcom ESS  

INP ‡ Wilcom condensed format 

Legacy formats *

T01 Tajima – Wilcom DST format  

T03 Barudan – Wilcom DSB format  

T04 Zangs  

T05 ZSK – Wilcom DSZ format  

T09 Pfaff – Wilcom KSM format  

T10 Wilcom Plauen  

T15 Wilcom Saurer  
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Supported design file formats
EmbroideryStudio supports the following design file (condensed) formats:

Note  See below for conversion details when reading these files into EMB format 
or writing to CND format. See Melco CND format and Conversion of Gunold PCH 
format to Wilcom EMB.

Supported machine file formats
EmbroideryStudio supports the following machine file (expanded) formats:

Extension Format Read Write

ART artista V4.0 design files 

ART42 Explorations project file 

ART?0 BERNINA Embroidery Software file 

CND Melco condensed file  

GNC Great Notions 

JAN Janome Embroidery Software file 

PCH Gunold APS design format 

Extension Format Read Write

10O Toyota  

ARX artista cross stitch files 

BRO Bits & Volts 

CSD Singer / Poem / Huskygram  

DAT Hiraoka DAT  

DSB † Barudan  

DSN Nova 

DST Tajima  

DSZ ¥ ZSK – Tajima machine format  

EMD Elna  

EXP Melco  

HUS Husqvarna / Viking / Pfaff  

INB Inbro Files  

JEF Janome / Elna / Kenmore format (V1.0)  

KSM Pfaff  

MJD Time & Space MJD  

PCD Pfaff  

PCM Pfaff  

PCQ Pfaff  

PCS Pfaff  

† includes needle addressing data ¥ Two options – ZSK1 and ZSK2 (see note) § TAP and MON 
files are written together – TAP is the machine file, MON the header file.£ Used with Transport 
Code Disks (see note)
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Note  ZSK1 format is used with older ZSK machines, generally those older than 
1991 which have no more than 7 needles. ZSK2 is for newer ZSK machines, 
those characterized by a single top thread trimmer. The trim is the most 
significant differentiating factor between the two types. If the ZSK machine 
accepts Transport Code Disks, then ZSK TC Machine Format must be used.

Supported design template formats
EmbroideryStudio supports the following design template formats:

Supported graphics and multi-decoration file formats

Artwork can be imported into EmbroideryStudio in both vector and bitmap 
(raster) formats. See Digitizing with Bitmaps for details.

PEC Deco, Brother, Babylock  

PES Deco, Brother, Babylock  

PMU Proel Win 

PUM Proel DOS 

SAS Saurer SLC  

SEW Janome / Elna / Kenmore  

SHV Husqvarna / Viking / Pfaff  

STC Gunold APS stitch format 

STX Datastitch 

TAP / MON § Happy  

TBF Tajima  

U?? † Barudan (TBD)  

VEP Hiraoka VEP 

VIP Husqvarna / Viking / Pfaff  

VP3 Husqvarna / Viking / Pfaff  

XXX † Singer  

Z?? £ ZSK TC machine format  

Extension Format Read Write

EMT Wilcom ES templates  

AMT artista V4.0 template 

AMT42 Explorations template 

JMT Janome Embroidery Software template 

Extension Format Read Write

† includes needle addressing data ¥ Two options – ZSK1 and ZSK2 (see note) § TAP and MON 
files are written together – TAP is the machine file, MON the header file.£ Used with Transport 
Code Disks (see note)
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Supported vector file formats
EmbroideryStudio supports the following vector graphic formats:

Supported bitmap file formats
EmbroideryStudio supports the following bitmap image formats:

Note  For a full description of image file formats supported by CorelDRAW® 
Graphics Suite, refer to the CorelDRAW® Graphics Suite electronic User Guide 
available via the MS Windows® Start > Programs group. Alternatively, use the 
onscreen help available from the Help menu. See Digitizing with Bitmaps for 
details.

Extension Format Read Write

AI Adobe Illustrator  

CDR CorelDRAW  

CDT CorelDRAW Template  

CGM Computer Graphics Metafile  

CLK Corel R.A.V.E.  

CMX Corel Presentation Exchange 5.0  

CSL Corel Symbol Library  

DES Corel Designer  

DWG AutoCAD  

DXF AutoCAD  

EMF Enhanced Metafile  

EPS Encapsulated Postscript  

FMV Frame Vector Metafile  

PLT HPGL Plotter File  

PS Postscript 

SVG Scalable Vector Graphics  

WMF Windows Metafile  

Extension Format Read Write

BMP Windows Bitmap  

GEM GEM file  

JPEG JPEG Group  

JPG JPEG File Interchange  

PAT Pattern File  

PCT Macintosh PICT  

PCX PC Paintbrush  

PNG Portable Network Graphics  

SVGZ Compressed SVG  

TIFF Tagged Image Format  

WMF Windows Metafile  

WPG Corel WordPerfect Graphic  



EmbroideryStudio e4 User Manual 951

Supported rhinestone file formats
EmbroideryStudio supports the following rhinestone file formats:

Note  The YNG file format can be read by EmbroideryStudio and sent directly to 
CAMS machine. See Sending bling to CAMS machine for details.

Melco CND format

Melco Condensed (CND) is the native file format of the Melco embroidery 
digitizing software. CND files store only digitized outlines and stitch values. See 
also Reading Melco CND design files.

Conversion of Melco CND format to Wilcom EMB

When you open CND designs in EmbroideryStudio, outlines are scaled and 
stitches recalculated to preserve density. EmbroideryStudio recognizes all Melco 
machine functions and stitch types, including Partition Lines and Complex Fill, 
and automatically converts them to EMB format. This table details how Melco 
features are converted.

Extension Format Read Write

YNG Yongnam GemMaster v2.9  

Melco CND EMB Notes

Stitch Types

Column Stitches Column A, Satin 
stitch

Simple Fill Complex Fill, 
Tatami

The stitch angle is determined by the 
longest stitchline.

Complex Fill Complex Fill Melco EDS Complex Fill are 
recognized and converted to 
EmbroideryStudio Complex Fill.

Column Fill Column A, Tatami 
fill

Walk Run

Bean Stitch Triple Run

Singleline Column Input, 
Centerline

Column C

Singleline Column Input, Left 
Line / Right Line

Column C Side 1 / 
Side 2

Partition Lines Tatami partition 
lines

Underlays

Complex Underlay Tatami underlay in 
Complex Fill object

Edge Walk Edge Run

Column stitches onlyCenter Walk Center Run

Narrow Column Zigzag
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Conversion of Wilcom EMB format to Melco CND

You can save files to Melco CND format from EmbroideryStudio. Designs 
originally created in EmbroideryStudio generally give the best results. Other file 
types may not have all the data necessary for successful conversion. This table 
details how EmbroideryStudio stitch types and effects are converted to CND 
format. 

Tip  When you convert to CND, many EmbroideryStudio effects will be lost. If it 
is important to preserve the effects, save in Melco EXP machine format instead. 
Alternatively, turn off all effects before saving to CND format. See also Best 
EmbroideryStudio input methods for Melco CND output.

Machine functions

Needle Up Jump, Begin Jump

Reset Stitch End Jump

Manual Lock Stitch Added in Tie Off

Automatic Lock Stitch Tie In, Tie Off If Automatic Lock Stitch is set for 
every Color Change, and at the start 
and end of the design, tie off and tie 
in stitches are inserted in the EMB 
design. 

Chain Chain

Moss Moss

Needle Height Needle Height

Slow Slow

Fast Fast

Borer In/Out Borer In/Out

Sequin On/Off Sequin On/Off

Melco CND EMB Notes

EMB Melco CND Notes

Stitch types

Manual Walk

Run Walk

Triple Run Bean Stitch Only if the design is an original Wilcom 
EMB design

Triple Run 
(run count > 3)

Bean Stitch Reverts to Triple Run (run count = 3).

Satin stitch Column Fill

Tatami - standard Fill Stitch Use Complex Fill to make sure that the 
stitch lines are parallel.

Tatami - with random factor 
applied

Walk

Tatami - with sharply turning 
stitches 

Walk or Complex 
Fill

Changes to Walk if Superstar 
compatible, otherwise Complex Fill with 
a fixed angle.
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Tatami - with slightly turning 
stitches

Fill Stitch, several 
sections

The shape is divided into several 
sections, filled with parallel Fill Stitch. 
There may be small gaps between 
these sections. 

Zigzag Walk Density is not preserved when the 
design is scaled.

E Stitch (Inputs A, B & C) Column Stitches

E Stitch (Complex Fill) Walk

Stitch settings

Run length Set length CND Walk stitch length is the same as 
EMB Run stitch length.

Tatami length and spacing Fill or Complex Fill 
settings

The length and density of Fill Stitches 
will be the same as EMB Tatami length 
and spacing.

Underlays

Center Run

Walk Uses CND Auto Underlay.
Edge Run

Zigzag

Double Zigzag

Zigzag (for objects with 
Satin cover only)

Narrow Column

Effects

Accordion Spacing Not preserved The effect is lost.

Motif Fill Not preserved The effect is lost.

Contour Stitch Not preserved The effect is lost.

Flexi Split Not preserved The effect is lost.

Auto Split Not preserved The effect is lost.

Jagged Edge Not preserved The effect is lost.

Trapunto style Not preserved The effect is lost.

Program Split Not preserved The effect is lost.

User Defined Split Not preserved The effect is lost.

Photo Flash Walk Density is not preserved when the 
design is scaled.

Quality features

Pull Compensation Not preserved The original shape is preserved. The 
effect is lost.

Fractional Spacing Not preserved In EmbroideryStudio, turn on Fractional 
Spacing and set it to 0.5mm. Although 
there is no direct equivalent in CND, 
effectively it uses a fixed fractional 
spacing with a value equal to 0.5.

Stitch Shortening Not preserved Outlines are more accurately 
recognized if Stitch Shortening is 
turned off.

EMB Melco CND Notes
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Best EmbroideryStudio input methods for Melco CND output

This table details which input methods give the best results when digitizing a 
design for Melco EDS-III CND output.

Auto Spacing Not preserved Auto Spacing is converted to fixed 
spacing, based on the average space 
value. It is best to turn off Auto Spacing 
when digitizing a design for CND. 

Smart Corners Not preserved Avoid digitizing pointed ends.

Machine functions

Color Change / Stop 
functions

Color Change / 
Stop

Functions inserted on stitches inside 
objects are not converted.

Empty Walk Two MK1 points are repeated at the 
current position.

Jump Needle Up

Needle Up Needle Up

Tie In (Lettering) Walk

Tie Off Walk

End Jump Reset Stitch

Begin Jump Needle Up

Needle Height Needle Height

Moss Moss

Chain Chain

Trim Trim The ability to output without Trim 
function does not apply to this version.

EMB Melco CND Notes

Input method Compatibility Notes

Column A, B, C OK Use with Satin only.

Complex Fill OK Only use with Tatami fill. Do not digitize pointed 
ends as they will be ‘squared off’ during 
conversion. Cut off pointed ends with a straight 
line, parallel to the stitch angle, to avoid conversion 
problems.

Complex Turning Not 
recommended

Complex Turning objects are separated into a 
single object per segment. Conversions may 
produce undesired results.

Circle OK

Ring Not 
recommended

The exit point will be on the wrong side of the 
shape.

Star Not 
recommended

The stitches are output as Walk.

End - Keep Last 
Stitch

OK The exit point should always be on the opposite 
side to the entry point.

End - Omit Last 
Stitch

Do not use Start digitizing the next shape on the opposite side 
instead.
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Conversion of Gunold PCH format to Wilcom EMB

PCH ‘Punch and Stitch’ is the native file format of the Gunold Embroidery Design 
software. Gunold PCH designs can be directly converted to EMB files although 
EmbroideryStudio interprets some of the stitch types differently. This table 
details how Gunold PCH features are converted to EMB format.

Gunold PCH EMB

Outline types

Parallel Column A

Serial Column C

Block Outline Complex Fill

Run Run

Incline Run

Manual Manual

Stitch types

Satin Satin

Ceding Tatami

Random Ceding Tatami with random factor applied

Step Tatami

Piping Contour

OBI Tatami

Zigzag Zigzag

Cross not supported

Photo not supported

Satin underlays

none none

Single Center Run

Edge Edge Run

Zigzag Zigzag

Cross Zigzag

Edge Zigzag Edge Run + Zigzag

Edge Cross Edge Run + Zigzag

Netting Double Zigzag

Double Zigzag Double Zigzag

Triple Zigzag Double Zigzag

Step / block fill levels

Complex Fill Holes in Complex Fill

Form Fill User Defined Split in Complex Fill

Vector Fill User Defined Split in Complex Fill

Block Fill Program Split in Complex Fill
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Conversion of Wilcom INP format to Wilcom EMB

Wilcom INP is the native file format of Wilcom Computer Embroidery Design 
software. Wilcom INP designs can be directly converted to EMB files although 
EmbroideryStudio interprets some of the stitch types differently. This table 
details how Wilcom INP features are converted to EMB format.

Miscellaneous

Branches Grouped object (uses lettering 
sequence algorithm)

Random - side 1 / side 2 Jagged Edge effect

Pitch Stitch Spacing

Length Stitch length

Stitch angle Complex Fill stitch angle

U turn Backtrack

Compensation Pull Compensation

Corner mode Smart Corners

Short / Long Stitch Shortening

Square backstitch
Satin
Step

Straight stitch 
Trapunto

Styles Motifs

Patterns none

Gunold PCH EMB

Wilcom INP EMB Notes

Auto Spacing Auto Spacing Values are different. Can be changed 
before stitching.

Backtrack/Repeat 
section/marked

Separate objects are 
added.

Functions are supported correctly.

Backup Lock Satin tie off

Borderline Tatami Borderline Tatami

Borer In/Out Borer In/Out

CED Block lettering Block2 font Font can be changed after conversion.

CED Block, Jump out Block2 font Manual edits and trimming

Circle Circle

ES Cross Stitch Paths imported as 
Run objects only

Change the stitch type to Motif Run to 
generate cross stitch.

Delete Stitch Manual only, ignored 
for other stitch types

Can be edited

Family of Curves Split Satin, single curve as 
split line 

Noticeably different from Satin. You can 
copy imported curve to get multiple 
curves.
Alternating number is ignored.

Geflecht Standard Tatami Can be edited
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Supported embroidery disk formats

You can write designs to disks which are formatted for a specific embroidery 
machine. The disk can then be read through the machine’s Floppy Disk Reader. 
The following formats are supported:

Matching Tatami Non-matching 
Tatami 

Complex Fill will have matching Tatami.

Motifs Patches Normal objects

Needle In/Out End/Begin Jump

Other Multihead Machine 
Functions

Stop (with info label) For example, Insert Appliqué is 
converted to Stop.

Program Stitch Manual stitch

Ring Ring

Scattered Tatami Tatami with random 
factor applied

Will look slightly different

Schiffli Functions Stepp/Blatt only, 
others are ignored

Slow/Fast Slow/Fast

Split Alternate Tatami

Split Stitch Standard Tatami Looks different but can be edited

Tajima style Lock Tajima tie off OK most of the time

Tourenblat E Stitch Looks different, so that it is easy to locate 
and edit

Trim/Tie In/Tie Off Connector properties

Turn fill (spacing 
measured along shape 
boundary)

Turning fill (generally 
fewer stitches)

Will look different but can be re-digitized 
in smaller sections

Underlays – slant Zigzag underlay Can be added manually

Underlays, 3 or 4 layers Two underlays only Can be edited

Wilcom INP EMB Notes

Format Density Read Write

Barudan 2HD DS/HD  

Barudan S-FMC DS/HD  

DOS DS/HD  

Happy DS/HD  

Tajima DS/HD  

Toyota DS/HD  

ZSK TC DS/HD  
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Appendix B

Embroidery Fonts

The table below includes all fonts that are standard with your EmbroideryStudio. 
Categories include:
 3D fonts
 Appliqué fonts
 Bling fonts
 Block fonts
 Chenille fonts
 Fancy fonts
 Monogram fonts
 Outline fonts
 Script fonts
 Serif fonts
 Small fonts
 Small run fonts
 Special fonts
 Two-color fonts
Non-Roman character fonts include:
 Cyrillic fonts
 Hebrew fonts
 Japanese fonts

Minimum & maximum sizes
For best results when stitching, do not exceed the recommended maximum or 
minimum sizes. Note, however, that recommended maximum and minimum 
heights refer to UPPER CASE letters. Most embroidery fonts are digitized from 
an original TrueType Font (TTF), some of which have lower-case letters – e.g. ‘a’ 
and ‘c’ – which are about 70% the height of a capital letter. As a result, these 
letters may be too small to embroider neatly. You may need to increase the size 
of the lower-case characters to suit the embroidery.

Special characters
You can create special characters in each font by holding down the Alt key on 
your keyboard and typing 0 (zero), its code, using the numbers on the keypad. 

TrueType Font

Embroidery Letters
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For example, to type ê with the code 234, type Alt+0234. The accented letter 
will appear when you release the Alt key. See also Adding special characters.

Note  Not all characters are available in all fonts.

Join method
The lettering join method is preset to give the best results for each font. Options 
include:

Roman fonts

Join Purpose

Bottom join BJ Letters are joined along the baseline. Use it when stitching on towelling 
– joins are hidden in the pile.

Closest join CJ Letters are joined at the closest point. Use it to minimize trims.

As digitized AD Letters are joined as they were digitized. Use it with fonts combining 
different fill stitch types or special effects.

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

3D fonts

3D Block2 ^ 0.6 15 1.2 30 AD

3D Brush Script ^ 0.8 20 1.6 40 AD

3D Emphatic ^ 0.8 20 2.4 60 AD

3D Futuro ^ 0.8 20 1.0 25 AD

3D London ^ 0.8 20 1.2 30 AD

^ New to ES e4
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3D Monoglyceride ^ 0.8 20 1.2 30 AD

3D Sofachrome ^ 0.55 15 0.8 20 AD

Appliqué fonts

College Appliqué 1.0 25 3.2 80 AD

Crest Appliqué - - - - AD

Glory Appliqué 1.2 30 4.0 100 AD

Bling fonts

Bling Block - - - - AD

Bling Hollow - - - - AD

Bling Script - - - - AD

Block fonts

Advent ^ 0.4 10 2.0 50 CJ

Angle Block 0.4 10 4.0 100 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Architect 0.4 10 2.0 50 CJ

Arial Rounded 0.3 7 1.8 45 CJ

Art Block 0.4 10 3.0 75 CJ

Avant Garde 0.2 5 2.4 60 CJ

Bauhaus 0.4 10 2.0 50 CJ

Block1 0.25 6 2.4 60 CJ

Block2 0.25 6 2.4 60 CJ

Block2-Auto 0.2 4 2.2 55 CJ

Block Caps 0.2 5 2.0 50 CJ

Bravo ^ 0.32 8 3.0 75 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Castle 0.25 6 2.0 50 CJ

Folio Condensed 0.3 7 2.0 50 CJ

Futura 0.25 6 2.4 60 CJ

Goudy Sans 0.25 6 1.6 40 CJ

Handel Gothic 0.3 8 2.0 50 CJ

Helvetica 0.25 6 2.4 60 CJ

Hobo 0.25 6 1.6 40 CJ

Impress 0.3 7 1.6 40 CJ

Informal 0.25 6 1.2 30 CJ

Kabel 0.25 6 2.4 60 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Lazer 0.24 6 2.0 50 CJ

Legal Block 0.24 6 2.0 50 CJ

Lydian 0.3 7 2.0 50 CJ

Meister Block 0.4 10 2.2 55 CJ

Microgramma 0.25 6 2.4 60 CJ

Microscan 0.3 7 1.6 40 CJ

Monoglyceride ^ 0.4 10 2.4 60 CJ

Monoglyceride Bold ^ 0.4 10 2.4 60 CJ

Narrow Block 0.6 15 4.0 100 CJ

Round Block 0.8 20 1.4 35 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Slim Block 0.8 20 8.0 200 CJ

Sofachrome
^

0.4 10 2.0 50 CJ

Square Block ^ 0.4 10 2.7 70 CJ

Stencil Block 0.4 10 3.0 75 CJ

Super Block 0.4 10 2.0 50 CJ

Swiss 0.4 10 2.0 50 CJ

Tahoma 0.25 6 1.6 40 CJ

Text Block 0.3 7 1.8 45 CJ

Urbane 0.25 6 1.6 40 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Utility Block 0.3 7 4.0 100 CJ

Veranda 0.25 6 2.4 60 CJ

Chenille fonts

CH 2Color Numbers 2.0 50 5 125 AD

CH 2inch Pennant 
Script 2.0 50 2 50

AD

CH 3inch Pennant 
Script 3 75 3 75 AD

CH 3.5inch Shadow 
Nos 3.5 87 3.5 87 AD

CH 6inch 3D-Block 6 150 6 150 AD

CH Chenille Block 2 50 6 150 AD

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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CH Playbill 4 100 6 150 AD

CH Prince Athletic 2 50 6 150 AD

CH Square Block 2 50 6 150 AD

CH Tall Pennant 
Script 3 75 4 100 AD

Fancy fonts

Agatha 0.3 8 2.0 50 CJ

Anaconda 0.3 8 2.0 50 CJ

Arnold 0.4 10 2.0 50 CJ

Blacklight 0.25 6 2.4 60 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4



EmbroideryStudio e4 User Manual 967

Carla 0.4 10 2.0 50 CJ

Charcuterie ^ 0.8 20 2.5 60 CJ

Cheshire 0.4 10 2.0 50 CJ

Columbo 0.3 8 1.2 30 CJ

Comics 0.4 10 2.0 50 CJ

Crayfish ^ 0.4 10 2.0 50 CJ

Crevasse ^ 0.4 10 2.0 50 CJ

Croissant 0.25 6 2.0 50 CJ

Curly 0.4 10 2.0 50 CJ

Dotti ^ 0.4 10 2.0 50 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Dr Zeus ^ 0.4 10 2.0 50 CJ

Enchantment 0.4 10 1.6 40 CJ

Energy 0.3 8 2.4 60 CJ

Enviro 0.5 13 3.0 75 CJ

Felt Tip 0.4 10 2.0 50 CJ

Flash 0.25 6 2.4 60 CJ

Flourish Light ^ 0.6 15 2.0 50 AD

Free Style 0.4 10 1.6 40 CJ

Gaelic 0.44 11 2.0 50 CJ

Hana 0.5 13 2.0 50 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Handicraft 0.3 8 2.5 65 CJ

Kids 0.5 12 1.2 30 CJ

Kindergarten Block 0.4 10 3.6 90 CJ

Lariat 0.48 12 1.2 30 CJ

Locker ^ 0.6 15 2.7 70 CJ

Lublik 0.4 10 3.0 75 CJ

Mandarin 0.3 8 2.0 50 CJ

Market 0.4 10 1.2 30 CJ

Matisse 0.4 10 1.6 40 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Old English 0.4 10 2.0 50 CJ

Olivia 0.3 7 1.6 40 CJ

Orient Express 0.4 10 3.0 75 CJ

Pacific North West ^ 0.32 8 2.4 60 CJ

Pixie 0.5 13 1.2 30 CJ

Racer 0.3 8 1.4 35 CJ

Speedy 0.3 8 1.2 30 CJ

Sports ^ 0.4 10 2.7 70 CJ

Thriller 0.4 10 2.0 50 CJ

Toon 0.4 10 2.0 50 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Victorian 0.3 7 1.0 25 CJ

Viking 0.35 9 2.0 50 CJ

Western 0.4 10 1.4 35 CJ

Western Serif 0.3 7 2.0 50 CJ

Westminster 0.25 6 2.4 60 CJ

Woodstock 0.3 8 2.0 50 CJ

Monogram fonts

Fancy Monogram 1.0 25 5.0 125 CJ

Octagon Monogram 0.7 18 6.0 150 CJ

Point Monogram 0.7 18 6.0 150 CJ

Seal Monogram 0.7 18 6.0 150 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Outline fonts

Detex Normal 0.4 9 2.0 50 CJ

Discoteque 0.4 10 2.0 50 CJ

Futura Outline 0.6 16 2.0 50 CJ

News Outline 1.2 30 3.0 75 CJ

Outline Block 0.75 18 4.0 100 CJ

Swiss Run Hollow 0.6 15 4.0 100 AD

Swiss Run Satin 1.0 25 3.0 75 AD

Turncoat ^ 0.8 20 3.1 80 BJ

Script fonts

Ballantines Script 0.5 12 2.0 50 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Book Script 1.0 25 2.2 55 CJ

Cayman 0.4 10 2.0 50 CJ

Chancery 0.3 8 2.4 60 CJ

City Script 0.3 8 2.4 60 CJ

Easy Script 0.3 7 2.4 60 CJ

Edwardian Script 0.6 15 3.0 75 CJ

Flair Script 0.75 10 3.2 80 CJ

Formal Script 0.3 7 1.4 35 CJ

Handy Script 0.5 13 3.0 75 CJ

Italian Script 0.4 10 4.0 100 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Karin Script 0.5 12 2.0 50 CJ

Memo Script 0.24 6 1.0 25 CJ

Moly ^ 0.4 10 2.0 50 CJ

Poetic Script 0.6 15 3.1 80 CJ

Pomander ^ 0.35 8 2.4 60 CJ

Royale 0.5 13 2.4 60 CJ

Script1 0.5 12 3.0 75 CJ

Script2 0.3 8 2.0 50 CJ

Script3 0.5 12 4.0 100 CJ

Script4

[

0.8 20 3.2 80 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Script5 ^ 0.4 10 2.0 50 CJ

Script6 ^ 0.4 10 2.0 50 CJ

Script7 ^ 0.6 15 2.7 70 CJ

Script8 ^ 0.6 15 2.7 70 CJ

Staccato 0.4 10 0.6 15 CJ

Upright Script 0.5 13 2.0 50 CJ

Serif fonts

Adelle 0.4 10 2.0 50 CJ

Algerian 0.3 8 1.2 30 CJ

Athletica 0.4 10 3.0 75 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Bodoni 0.3 7 2.0 50 CJ

Casual Serif 0.5 13 2.2 55 CJ

Centurion 0.5 13 2.4 60 CJ

Cheltenham Tall 0.3 7 2.0 50 CJ

City Medium 0.25 6 3.0 75 CJ

Civic 0.3 8 2.0 50 CJ

College 0.25 6 1.4 35 CJ

Copperplate 0.25 6 1.6 40 CJ

Dauphin 0.3 8 2.4 60 CJ

Flares

o

0.3 7 1.6 40 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Garamond 0.3 7 2.0 50 CJ

Krone 0.3 8 1.6 40 CJ

Matrix 0.4 10 1.6 40 CJ

Museo 0.4 10 1.2 30 CJ

Schoolbook 0.3 8 2.0 50 CJ

Seagull 0.3 7 1.8 45 CJ

Serif1 0.25 6 1.2 30 CJ

Serif2 0.3 8 1.2 30 CJ

Serif3 0.25 6 2.4 60 CJ

Souvenir 0.25 6 1.6 40 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Times Roman 0.25 6 1.6 40 CJ

Typewriter 0.5 13 2.0 50 CJ

Small fonts

Helvetica Small 0.2 4 0.3 7 CJ

Micro Block 0.2 4 0.3 8 CJ

Minature Block 0.2 4 0.25 6 CJ

Sm Cooper 2.4 6 2.0 50 CJ

Sm HighTower 0.2 4 0.25 6 CJ

Sm Script 0.2 4 0.25 6 CJ

Small Block1 0.2 4 0.25 6 CJ

Small Block2 0.2 4 0.25 6 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Small Serif 1 0.2 4 0.25 6 CJ

Times Small 0.2 4 0.25 6 CJ

Small run fonts

Run Block 0.2 4 0.25 6 AD

Run Cardigan 0.2 5 0.5 12 AD

Run Freehand 0.2 5 0.5 12 AD

Run Liberty 0.2 5 0.5 12 AD

Run Murray Hill 0.2 5 0.5 12 AD

Run Script 0.2 4 0.25 6 AD

Special fonts

Antique Rose ^ 1.2 30 4.0 100 AD

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4



Appendix B   Embroidery Fonts 980

Crests - - - - AD

Tusj 0.8 20 4.0 100 AD

Two-color fonts

2 Col Arial Shadow 0.6 15 2.0 50 AD

2 Col Plain Script 0.5 13 2.0 50 AD

Border Block 2 0.5 13 1.6 40 AD

Dextor 0.5 13 2.0 50 AD

English Village ^ 0.6 15 4.0 100 AD

Futura Border 2 C 0.65 16 2.0 50 AD

Shadow Street ^ 0.6 15 4.0 100 AD

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

^ New to ES e4
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Other fonts

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

Cyrillic fonts

Greek 0.3 8 2.0 50 CJ

Greek Script 0.48 12 4.0 100 CJ

Greek Spionic 0.4 10 2.4 60 CJ

Jikharev 0.4 10 1.8 45 CJ

Russian Textbook 0.3 8 1.8 45 CJ

Hebrew fonts

Hebrew Chaya 0.3 8 1.6 40 CJ

Japanese fonts

Japanese Kaisho 0.32 8 2.7 70 CJ

Heisei Gosic 0.4 10 2.7 70 CJ

Heisei Gyosho 0.32 8 2.7 70 CJ
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Note  Japanese fonts (3000 characters each) are available for download from 
www.wilcom.com for customers who wish to access them.

Heisei Kaisho 0.32 8 2.7 70 CJ

Heisei Kantei 0.4 10 2.7 70 CJ

Heisei Maru Gosic 0.4 10 2.7 70 CJ

Heisei Mincho 0.4 10 2.7 70 CJ

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

http://www.wilcom.com
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Appendix C

Motif Samples

Motifs available in EmbroideryStudio can be one of two types – single or 
two-part. Single motifs can be used on their own in a Motif Run or Motif Fill. 
Two-part motifs consist of two separate motifs combined to form a single pattern 
for Motif Fills.
This section contains samples of the motifs available in EmbroideryStudio. Use 
these tables to see what a particular motif looks like. The table also includes 
recommended size and layout specifications. If they have changed for any 
reason, revert to the settings using the values in these tables. See Creating 
motif runs and Creating motif fills for details.

Single motifs

The following table shows single motifs available in EmbroideryStudio together 
with their size values. It also shows the spacing values for Motif Runs, and 
column, row and offset recommended values for Motif Fills.

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset

Arrow01 3.9 3.1 3.9 3.9 3.1 0.0

Arrow02 4.4 3.3 4.4 4.4 3.3 0.0

Arrow03 4.0 3.0 4.0 4.0 3.0 0.0

Arrow04 4.0 3.0 4.0 4.0 3.0 0.0

Arrow05 4.0 2.5 4.0 4.0 3.5 0.0

Arrow06 10.1 10.0 10.6 10.1 10.0 0.0

Arrow07 5.0 4.0 5.2 5.0 4.0 0.0
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Arrow08 5.0 4.0 5.0 5.0 4.0 0.0

Block01 3.0 5.0 2.0 2.0 5.0 1.0

Block02 3.2 5.0 2.3 2.3 6.0 0.0

Blockk03 2.0 3.0 2.0 2.0 3.0 0.0

Block04 2.0 3.0 2.0 2.0 3.0 0.0

Block05 4.0 5.5 3.0 3.0 6.0 0.0

Block06 2.6 2.4 2.4 2.4 1.8 1.2

Block07 6.0 4.0 6.0 6.0 4.0 0.0

Block08 6.0 4.0 6.0 6.0 4.0 0.0

Block09 6.0 6.0 6.0 6.0 6.0 0.0

Block10 6.0 6.0 6.0 6.0 6.0 0.0

Block11 8.0 8.0 8.0 8.0 8.0 0.0

Block12 8.0 8.0 8.0 8.0 8.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Block13 5.6 5.6 5.6 5.6 5.6 5.6

Block14 8.0 8.0 8.0 8.0 8.0 0.0

Block15 3.8 5.0 3.8 3.8 5.0 0.0

Block16 3.0 4.0 3.0 3.0 4.0 0.0

Block17 10.1 10.0 10.2 10.1 10.0 0.0

Block18 10.0 10.0 10.0 10.0 10.0 0.0

Block19 12.0 3.0 12.1 12.0 3.0 0.0

Block20 3.0 6.0 3.0 3.0 6.0 0.0

Block21 8.9 3.6 9.0 8.9 3.6 0.0

Block22 6.0 5.0 6.0 6.0 5.0 0.0

Block23 4.0 6.5 4.0 4.0 6.5 0.0

Block24 6.0 6.0 6.1 6.0 6.0 0.0

Block25 6.8 8.9 6.8 6.8 8.9 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Block26 7.5 8.5 7.5 7.5 8.5 0.0

Block27 4.0 8.0 4.0 4.0 8.0 0.0

Block28 6.0 8.0 6.0 6.0 8.0 0.0

Block29 8.0 8.0 8.0 8.0 8.0 0.0

Block30 8.0 10.0 8.0 8.0 10.0 0.0

Block31 9.0 8.0 9.0 9.0 8.0 0.0

Block32 8.0 8.0 8.0 8.0 8.0 0.0

Bow01 10.0 3.1 10.0 10.0 3.1 0.0

Bow02 8.0 4.0 8.0 8.0 4.0 0.0

Circle01 4.2 4.0 5.0 5.0 4.0 2.5

Circle02 9.6 13.1 9.1 9.6 13.1 0.0

Circle03 10.7 9.1 10.7 10.7 9.1 0.0

Cloud01 7.2 6.1 7.2 7.2 6.1 0.0

Cloud02 8.3 5.7 8.2 8.3 5.7 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Cross01 4.0 4.0 4.0 4.0 4.0 0.0

Cross02 5.7 5.7 5.8 5.7 5.7 0.0

Cross03 4.0 4.0 4.0 5.0 5.0 0.0

Cross04 8.0 8.0 8.0 10.0 8.0.0 5.0

Cross05 6.0 8.0 6.0 6.0 8.0 0.0

Cross06 10.0 10.0 10.0 10.0 10.0 0.0

Cross07 6.0 6.0 6.0 6.0 6.0 0.0

Cross08 8.0 8.0 8.1 8.0 8.0 0.0

Cross09 6.0 6.0 6.1 6.0 6.0 0.0

Cross10 6.7 6.7 6.7 6.7 6.7 0.0

Cross11 8.0 8.0 8.0 8.0 8.0 0.0

Cross12 8.0 8.0 8.0 8.0 8.0 0.0

Cross13 8.0 8.0 8.0 8.0 8.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Cross14 8.0 8.0 8.0 8.0 8.0 0.0

Cross15 8.0 7.0 8.0 8.0 7.0 0.0

Curve01 8.0 4.0 8.0 8.0 5.0 4.0

Curve02 15.0 6.9 15.0 15.0 6.8 0.0

Curve03 7.5 5.0 3.9 3.9 5.0 0.0

Curve04 7.5 3.8 7.5 7.5 4.1 2.5

Curve05 14.0 10.0 14.7 14.0 10.0 0.0

Curve06 19.1 20.5 19.4 19.1 20.5 0.0

Curve07 10.0 5.0 10mm 10.0 5.0 0.0

Curve08 9.1 5.1 9.1 9.1 5.1 0.0

Curve09 3.4 6.6 2.9 3.4 6.6 0.0

Curve10 10.3 10.0 10.2 10.3 10.0 0.0

Curve11 10.0 5.6 9.9 10.0 5.6 0.0

Curve12 5.3 4.0 5.3 5.3 4.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Curve13 8.2 5.9 7.8 8.2 5.9 0.0

Curve14 9.0 7.0 9.0 9.0 7.0 0.0

Curve15 10.0 9.0 10.0 10.0 9.0 0.0

Curve16 8.0 28.0 8.0 8.0 28.0 0.0

Curve17 8.0 6.0 8.0 8.0 6.0 0.0

Curve18 9.0 10.0 9.0 9.0 10.0 0.0

Curve19 10.0 10.0 10.0 10.0 10.0 0.0

Heart01 6.0 6.0 6.0 6.0 6.0 0.0

Kite01 4.0 4.0 4.0 4.0 4.0 0.0

Kite02 4.0 4.0 4.0 4.0 4.0 0.0

Kite03 4.0 4.0 4.0 4.0 4.0 0.0

Kite04 4.0 4.0 4.0 4.0 4.0 0.0

Kite05 4.0 4.0 4.0 4.0 4.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Kite06 4.0 4.0 4.0 4.0 4.0 0.0

Kite07 4.0 4.0 4.0 4.0 4.0 0.0

Kite08 4.0 4.0 4.0 4.0 4.0 0.0

Kite09 4.0 4.0 4.0 4.0 4.0 0.0

Kite10 4.0 4.0 4.0 4.0 4.0 2.0

Kite11 8.0 10.0 8.0 8.0 8.0 4.0

Kite12 10.0 10.0 10.1 10.0 10.0 0.0

Kite13 4.7 5.0 4.8 4.7 5.0 0.0

Kite14 9.0 10.0 9.0 9.0 10.0 0.0

Kite15 8.0 8.0 8.0 8.0 8.0 0.0

Kite16 7.0 7.0 7.0 7.0 7.0 0.0

Leaf01 8.6 6.8 6.0 6.0 6.7 1.8

Leaf02 8.7 7.2 6.2 6.2 7.3 0.0

Leaf03 6.5 3.0 6.6 6.5 3.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Lines01 3.8 5.6 2.8 2.8 6.5 0.0

Lines02 2.2 3.6 1.3 1.2 3.6 0.0

Lines03 6.8 2.0 6.8 6.8 2.0 3.4

Lines04 6.0 5.0 6.0 6.0 5.0 0.0

Lines05 19.9 20.3 20.0 19.9 20.3 0.0

Lines06 20.3 20.5 21.0 20.3 20.5 0.0

Lines07 5.0 4.0 5.1 5.0 4.0 0.0

Lines08 10.0 8.0 9.9 10.0 8.0 0.0

Lines09 6.0 1.4 6.0 6.0 1.4 0.0

Lines10 8.6 7.7 8.6 8.6 7.7 0.0

Lines11 10.0 12.0 10.0 10.0 12.0 0.0

Lines12 9.0 10.0 9.0 10.0 10.0 0.0

Lines13 8.0 9.0 8.0 8.0 9.0 0.0

Lines14 10.0 12.5 10.0 12.5 12.5 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Lines15 8.0 9.0 8.0 8.0 9.0 0.0

Lines16 4.0 10.0 4.0 10.0 10.0 0.0

Music01 6.1 9.8 3.9 6.1 9.8 0.0

Scroll01 6.0 4.8 6.0 6.0 6.0 0.0

Scroll02 6.5 5.6 6.5 6.5 4.3 2.8

Scroll03 10.0 5.0 10.0 10.0 6.3 0.0

Scroll04 10.0 5.0 10.0 10.0 6.3 0.0

Scroll05 9.5 9.0 9.5 9.5 9.0 0.0

Scroll06 9.0 9.0 9.0 9.0 9.0 0.0

Shapes01 9.5 9.0 9.5 9.5 9.0 0.0

Shapes02 10.0 9.0 10.0 10.0 9.0 0.0

Shapes03 10.0 10.0 10.0 10.0 10.0 0.0

Shapes04 9.0 9.0 9.0 9.0 9.0 0.0

Shapes05 10.0 9.0 10.0 10.0 9.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Shapes06 8.0 9.0 8.0 8.0 9.0 0.0

Shapes07 8.5 8.0 8.5 8.5 8.0 0.0

Shapes08 9.0 8.5 9.0 9.0 8.5 0.0

Shapes09 7.0 8.0 7.0 7.0 8.0 0.0

Shapes10 7.0 9.0 7.0 7.0 9.0 0.0

Shapes11 8.0 8.0 8.0 8.0 8.0 0.0

Shapes12 10.0 8.5 10.0 10.0 8.5 0.0

Shapes13 9.0 9.0 9.0 9.0 9.0 0.0

Shapes14 9.0 10.0 9.0 9.0 10.0 0.0

Shapes15 7.5 9.0 7.5 7.5 9.0 0.0

Shapes16 10.0 10.0 10.0 10.0 10.0 0.0

Shapes17 10.4 9.5 10.4 10.4 9.5 0.0

Shapes18 10.0 10.0 10.0 10.0 10.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Shapes19 10.0 12.0 10.0 10.0 12.0 0.0

Shapes20 9.0 9.5 9.0 9.0 9.5 0.0

Shapes21 8.0 8.0 8.0 8.0 8.0 0.0

Shapes22 9.0 9.0 9.0 9.0 9.0 0.0

Shapes23

  

9.5 9.0 9.5 9.5 9.0 0.0

Shapes24 9.0 9.0 9.0 9.0 9.0 0.0

Shapes25 12.0 10.0 12.0 12.0 10.0 0.0

Shapes26 8.0 9.0 8.0 9.0 9.0 0.0

Shapes27 9.0 8.0 9.0 9.0 8.0 0.0

Shapes28 10.0 12.0 10.0 10.0 12.0 0.0

Shapes29 8.5 9.0 8.5 8.5 9.0 0.0

Shapes30 10.0 12.0 10.0 10.0 12.0 0.0

Shapes31 12.0 10.0 12.0 12.0 10.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Shapes32 8.5 9.0 8.5 8.5 9.0 0.0

Shapes33 8.0 9.0 8.0 9.0 9.0 0.0

Shapes34 9.0 10.5 9.0 9.0 10.5 0.0

Shapes35 4.0 7.5 4.0 4.0 7.5 0.0

Shapes36 8.0 8.5 8.0 8.0 8.5 0.0

Shapes37 9.0 9.0 9.0 9.0 9.0 0.0

Shapes38 7.0 4.0 7.0 7.0 4.0 0.0

Shapes39 8.0 9.5 8.0 8.0 9.5 0.0

Shapes40 9.0 8.0 9.0 9.0 8.0 0.0

Shapes41 12.0 12.0 12.0 12.0 12.0 0.0

Shapes42 7.5 7.0 7.5 7.5 7.0 0.0

Shapes43 10.0 9.0 10.0 10.0 9.0 0.0

Shapes44 9.0 10.0 9.0 9.0 10.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset



Appendix C   Motif  Samples 996

Square01 4.0 4.0 4.0 4.0 4.0 0.0

Square02 4.0 4.0 4.0 4.0 4.0 0.0

Square03 4.0 4.0 4.0 4.0 4.0 0.0

Square04 4.0 4.0 4.0 4.0 4.0 0.0

Square05 4.0 4.1 4.0 4.0 4.1 0.0

Square06 4.0 4.0 8.0 8.0 4.0 4.0

Star01 4.0 4.0 4.0 4.0 4.0 0.0

Star02 4.0 4.0 4.0 4.0 4.0 0.0

Star03 6.0 4.0 7.0 7.0 4.0 3.5

Star04 6.0 6.0 6.0 6.0 6.0 0.0

Star05 6mm 8.0 6.0 6.0 8.0 3.0

Star06 6.0 8.0 6.0 6.0 6.0 0.0

Star07 5.0 4.4 5.3 5.0 4.4 0.0

Star08 10.0 10.0 10.1 10.0 10.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Star09 20.1 20.6 20.6 20.1 20.6 0.0

Star10 8.7 10.0 8.7 8.7 10.0 0.0

Star11 6.0 6.0 6.0 6.0 6.0 0.0

Star12 8.0 7.8 8.0 8.0 7.8 0.0

Star13 8.0 9.0 8.0 8.0 9.0 0.0

Star14 9.6 9.0 9.6 9.6 9.0 0.0

Star15 8.0 8.0 8.0 8.0 8.0 0.0

Star16 10.0 9.0 10.0 10.0 9.0 0.0

Star17 8.0 9.0 8.0 8.0 9.0 0.0

Star18 10.0 9.0 10.0 10.0 9.0 0.0

Star19 10.0 10.0 10.0 10.0 10.0 0.0

Star20 8.0 9.0 8.0 8.0 9.0 0.0

Star21 9.5 9.0 9.5 9.5 9.0 0.0

Star22 8.0 9.5 8.0 8.0 9.5 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Star23 8.0 11.0 8.0 8.0 11.0 0.0

Star24 9.0 10.0 9.0 9.0 10.0 0.0

Wave01 10.0 7.0 8.0 8.7 7.0 0.0

Wave02 15.0 10.0 15.8 15.0 10.0 0.0

Wave03 10.9 7.8 10.9 10.9 7.8 0.0

Wave04 8.0 8.0 8.0 8.0 8.0 0.0

Xmas01 7.3 8.8 7.4 7.3 8.8 0.0

ZigZag01 4.0 4.0 4.0 4.0 4.0 0.0

ZigZag02 8.0 4.0 8.0 8.0 5.0 0.0

ZigZag03 4.6 4 4.6 4.6 5.0 0.0

ZigZag04 7.0 4.0 7.0 7.6 3.0 0.0

ZigZag05 4.0 4.0 4.0 2.0 5.0 1.0

ZigZag06 4.0 4.1 4.2 4.0 4.1 0.0

ZigZag07 10.0 10.0 10.2 10.0 10.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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ZigZag08 10.0 10.0 10.7 10.0 10.0 0.0

ZigZag09 12.0 12.0 12.3 12.0 12.0 0.0

ZigZag10 9.9 10.0 10.3 9.9 10.0 0.0

ZigZag11 18.5 19.1 19.2 18.5 19.1 0.0

ZigZag12 20.2 20.1 20.4 20.2 20.1 0.0

ZigZag13 19.5 8.1 19.8 19.5 8.1 0.0

ZigZag14 18.0 9.1 18.4 18.0 9.1 0.0

ZigZag15 12.1 11.1 12.4 12.1 11.1 0.0

ZigZag17 8.0 8.0 8.0 8.0 8.0 0.0

ZigZag18 14.0 7.0 14.0 14.0 7.0 0.0

ZigZag19 9.0 9.0 9.0 9.0 9.0 0.0

ZigZag20 8.0 8.0 8.0 8.0 8.0 0.0

ZigZag21 8.0 8.0 8.0 8.0 8.0 0.0

ZigZag22 8.0 8.0 8.0 8.0 8.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset
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Two-part motifs

The following table lists the two-part motifs that are available in 
EmbroideryStudio, and the resulting pattern. It also shows the size, column, row 
and offset values for Motif Fills.

ZigZag23 9.0 10.0 9.0 9.0 10.0 0.0

ZigZag24 8.0 9.0 8.0 8.0 9.0 0.0

ZigZag25 10.0 7.5 10.0 10.0 7.5 0.0

ZigZag26 8.0 8.0 8.0 8.0 8.0 0.0

ZigZag27 12.0 8.0 12.0 12.0 8.0 0.0

ZigZag28 8.0 9.0 8.0 8.0 9.0 0.0

ZigZag29 12.0 12.0 12.0 12.0 12.0 0.0

Name Motif Sample
Size in mm Motif 

Run
Spacing

Motif Fill

X Y Column Row Offset

Motif A Motif B Sample
Size in mm Motif Fill

X Y Col Row Offset

Duet01a Duet01b a=7.0
b=7.0

a=5.0
b=3.0

7.0 3.5 0.0

Duet02a Duet02b a=12.0
b=12.0

a=6.0
b=9.0

12.0 6.0 0.0

Duet03a Duet03b a=12.0
b=12.0

a=6.0
b=9.0

12.0 6.0 0.0
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Duet04a Duet04b a=9.0
b=9.0

a=8.0
b=3.0

9.0 4.5 0.0

Duet05a Duet05b a=6.4
b=6.4

a=4.8
b=3.2

6.4 3.2 0.0

Duet06a Duet06b a=4.4
b=4.4

a=2.2
b=2.4

4.4 1.9 1.1

Duet07a Duet07b a=4.8
b=4.8

a=4.4
b=4.2

4.8 2.2 1.3

Duet08a Duet08b a=11.6
b=11.6

a=4.4
b=4.4

11.2 2.9 0.0

Duet09a Duet09b a=6.5
b=6.5

a=5.0
b=5.0

6.5 3.4 3.3

Duet10a Duet10b a=8.0
b=8.0

a=4.0
b=4.0

8.0 4.0 0.0

Duet11a Duet11b a=5.2
b=12.0

a=3.8
b=9.0

5.2 3.8 0.0

Duet12a Duet12b a=15.0
b=13.5

a=8.4
b=7.8

13.5 3.9 0.0

Motif A Motif B Sample
Size in mm Motif Fill

X Y Col Row Offset
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Appendix D

Program Split Samples

This section contains samples of the program split patterns available in 
EmbroideryStudio. Use the table to see what a particular program split looks 
like. The table also includes the recommended size, column, row and offset 
settings. If they have changed for any reason, revert to the settings using the 
values in this table. See Patterned Fills for details.

Name Pattern Sample
Size in mm Column Row

X Y Spacing Offset Spacing Offset

Arrowhd 6.0 6.0 4.5 0.0 6.0 0.0

Bars 8.0 8.0 8.0 0.0 8.0 0.0

Basket

[

9.0 7.5 9.0 0.0 4.5 4.5

Basket2 9.0 9.0 6.0 0.0 6.0 0.0

Bird 6.0 4.9 6.0 0.0 4.9 0.0

Blocks1 12.0 12.0 12.0 0.0 8.0 8.0

Blocks2 12.0 12.0 8.0 0.0 8.0 8.0

Breaker 10.0 6.0 10.0 0.0 6.0 0.0

Brick 6.0 3.0 6.0 0.0 3.0 3.0

Brick2 6.0 6.0 4.0 0.0 4.0 4.0
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Chain 10.0 6.0 6.7 0.0 7.0 3.3

Chevron 6.0 3.0 6.0 0.0 6.0 3.0

Chevron2 2.5 6.0 2.5 0.0 6.0 0.0

Chevron3 7.0 3.0 7.0 0.0 3.0 0.0

Crosstile 7.0 7.0 5.5 -5.5 5.5 5.5

Cube 6.0 6.0 6.0 1.5 6.0 1.4

Diadem 10.0 6.7 10.0 0.0 6.7 5.0

Diamond2 4.0 8.0 4.0 4.0 8.0 0.0

Diamond 6.0 6.0 6.0 0.0 6.0 0.0

Driver 8.0 4.0 8.0 0.0 4.0 1.5

Ellipse 4.0 6.0 4.6 0.0 5.0 2.3

Flame 6.0 3.7 6.0 0.0 3.6 3.0

Greekey 6.0 4.0 6.0 0.0 6.0 2.0

Heart 6.0 6.5 6.0 0.0 6.4 3.0

Name Pattern Sample
Size in mm Column Row

X Y Spacing Offset Spacing Offset
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Herring-
bone

8.0 4.0 8.0 0.0 4.0 0.0

Hexagon 6.0 7.0 6.0 0.0 5.2 3.0

Hexagon2 7.0 6.0 7.0 0.0 6.0 0.0

Jem 10.0 10.0 10.0 0.0 9.5 5.0

Keyhole 4.0 2.7 5.3 0.0 2.7 2.7

Leaf 10.0fr 5.0 10.0 0.0 5.0 5.0

Melody 10.0 6.0 10.0 0.0 5.0 5.0

Metal 5.0 9.4 5.0 0.0 8.5 2.5

Passage 10.0 10.0 10.0 0.0 10.0 0.0

Piccolo 8.0 8.0 8.0 0.0 8.0 0.0

Roma 10.0 5.5 10.0 0.0 6.0 5.0

Rope 7.5 5.0 3.8 0.0 5.5 1.9

Scale 6.4 3.5 6.4 0.0 3.5 3.2

Scale2 3.5 6.4 3.5 3.2 6.4 0.0

Seville 6.7 5.6 6.7 0.0 4.5 4.5

Name Pattern Sample
Size in mm Column Row

X Y Spacing Offset Spacing Offset
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Star5 6.0 5.7 6.0 0.0 5.7 3.0

Steps 8.0 8.0 6.0 -6.0 6.0 6.0

Suncross 10.0 10.0 4.0 -6.0 4.0 6.0

Suncross2 11.0 11.0 6.8 -1.3 6.8 1.3

Swing 6.0 8.2 4.5 0.0 8.2 0.0

Tick 6.8 7.9 6.8 0.1 6.0 6.0

Tile1 8.0 8.0 8.0 0.0 8.0 0.0

Tile2 12.0 12.0 12.0 0.0 12.0 0.0

Tile3 10.1 10.0 10.0 0.0 10.0 0.0

Tile4 6.0 6.0 6.0 0.0 6.0 0.0

Triangle 6.0 5.2 6.0 0.0 5.2 3.0

Triangle3 7.5 6.5 7.5 0.0 6.5 0.0

Vine 8.5 2.8 8.5 0.0 3.5 2.0

Name Pattern Sample
Size in mm Column Row

X Y Spacing Offset Spacing Offset
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Wave

[

6.0 1.3 6.0 0.0 4.0 3.0

Wave2 9.9 3.2 9.9 2.9 3.2 0.0

Wave3 10.0 4.5 10.0 0.0 4.5 0.0

Whirl 7.5 7.5 7.5 0.0 7.5 0.0

Wild 8.5 8.0 8.5 0.0 7.5 4.5

Xmastree 16.0 16.0 13.3 8.0 16.0 0.0

Ziggy 5.0 8.0 4.0 0.0 8.0 0.0

Name Pattern Sample
Size in mm Column Row

X Y Spacing Offset Spacing Offset
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Glossary

10O:  Machine file format native to 
Toyota machines.
3D Warp:  3D Warp is used with 
Motif Fill to create three 
dimensional effects. You can make 
shapes appear concave or convex 
using Globe In or Globe Out. You 
can also create distance effects 
using Perspective.
ABC Pattern Arrangements:  See 
Pattern Arrangements (ABC).
Accordion spacing:  artistic stitch 
effect that gradually varies stitch 
spacing between dense and open fill 
along an embroidery object, 
producing shading and color effects 
which are difficult to achieve 
manually.Accordion Spacing
Acetate:  A salt or ester of acetic 
acid of cellulose made into a 
synthetic filament, yarn, or fabric.
Active window:  The active window 
is one to which the next command 
or action will apply. If a window is 
‘active’, its title bar changes color to 
differentiate it visually from other 
open windows.
Aetze:  The breaking down or 
dissolving of a base fabric on which 
a lace pattern has been stitched, 
leaving only the stitched threads. 2) 
Lace processing; may be 'wet aetze' 
involving a caustic soda bath or 'dry 
aetze' involving heat.
Aetzing:  The process of eliminating 
the base fabric to make Schiffli 
laces, leaving only the threads 
remaining.
Allover:  Continuous embroidery 
which covers all of the goods from 
selvage to selvage.
Anchor point:  A fixed point used 
when rotating, scaling, skewing or 
mirroring a design.
Anti-aliasing:  A software technique 
similar to dithering which is used to 
soften hard outlines where color 
blocks intersect. It produces 
smoother outlines by ‘blurring’ the 
pixels where colors join.
Appliqué:  Decoration or trimming 
cut from one piece of fabric and 
stitched to another to add 
dimension and texture. Designs 
with appliqué can be more 
economical than embroidery alone, 
if appliqué occupies a significant 
amount of the design, thereby 
lowering stitch count. In Schiffli 

embroidery, appliqué refers to an 
embroidered motif, hand-cut or 
aetzed away from base fabric.
Appliqué cutter:  A device that can 
cut fabric along a line, somewhat 
like old pen plotters. It requires a 
vector file as input. In 
MS Windows® they can be set up 
as a type of printer device.
ARQ:  BERNINA Quilter format.
ART:  BERNINA format.
Artwork:  Bitmap image or vector 
graphic used as a digitizing 
template. See also Bitmap image 
and Vector graphic.
Artwork preparation:  See Image 
preparation.
Aufsatz:  The last stitch of a design 
before it repeats itself.
ARX:  ES Cross Stitch format.
Auto appliqué:  Auto Appliqué is an 
embroidery object associated with 
an appliqué which provides 
automatic stitching to place it, tack 
it down, and cover its edges.
Auto center:  Auto Center 
automatically centers the start and 
end points of a design.
Auto-digitizing:  Toolset used to 
create embroidery designs by 
automatically digitizing blocks of 
color in electronic images, or 
converting vector outlines directly 
to embroidery objects. See also 
Smart Design.
Auto kerning:  For lettering objects, 
auto-kerning involves looking up in 
a ‘kerning table’. This specifies the 
spacing adjustments for each 
pairwise combination of letters so 
that whenever a predefined pair 
occurs, the letter spacing is 
automatically adjusted.
Auto scroll:  The Auto Scroll feature 
automatically scrolls the screen 
while you are digitizing.
Auto-sequencing:  The 
Auto-sequencing feature lets you 
digitize like objects – e.g. the 
fingers of a hand – without having 
to think about the most efficient 
stitching sequence and joins. 
Auto spacing:  Auto Spacing only 
affects Satin stitch. It adjusts stitch 
spacing according to column width.
Auto split:  Auto Split only affects 
Satin stitch. When applied, it 

breaks any long Satin stitches into 
shorter ones. It also distributes 
needle penetrations in a random 
pattern so that they do not form a 
line in the middle of the shape. 
Used primarily to prevent long 
stitches in wide columns, it can also 
be used as an alternative to Tatami 
fill. Auto Split looks more Satin-like 
and works well with turning 
stitches, creating soft lines and a 
little more depth.
Auto start and end:  Before 
stitching, some embroidery 
machines require you to position 
the starting needle exactly above 
the first needle penetration point. 
Use Auto Start and End to connect 
the first and last stitches in the 
design. This makes it easy to 
position the needle before stitching, 
and reduces the chance of the 
needle hitting the side of the frame.
Automatic color change:  Ability of 
multi-needle embroidery machine 
to follow a command to change to a 
specified needle with a different 
thread color.
Automatic pull compensation:  
Embroidery stitches pull the fabric 
inwards where the needle 
penetrates. This can cause the 
fabric to pucker, and gaps to appear 
in the embroidery. Automatic pull 
compensation counters this effect 
by ‘overstitching’ outlines of filled 
shapes on the sides where the 
needle penetrates. This means the 
design can be optimized for 
different fabrics. See also Pull 
compensation.
Automatic stitch shortening:  
Reduces stitch bunching at sharp 
corners. See also Stitch 
shortening.
Auto Trace:  Auto Trace is used to 
convert bitmap images to vector 
drawings.
Back appliqué:  A fabric piece used 
behind a design where the front 
fabric will be cut away to reveal the 
fabric beneath it.
Backdrop:  An electronic image 
used as a guide for digitizing 
designs on screen. Two types are 
used – vector or bitmap. Insert 
them from various file sources, or 
copy and paste them via the 
MS Windows® clipboard.
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Background:  EmbroideryStudio 
lets you change the background 
color of the design window to match 
the color of your fabric. Or you can 
select a background fabric for more 
realistic previews and 
presentations. The background is 
saved with the colorway.
Backing:  Also known as 
‘stabilizers’, backings are woven or 
non-woven materials placed 
beneath the item or fabric being 
embroidered for stability and 
support. A backing can be hooped 
with the item or placed between the 
machine throat plate and hooped 
garment. The more stitches a 
design has, the heavier the backing 
required. Backings are available in 
various weights and types such as 
cut-away, tear-away and 
wash-away (soluble). Professional 
embroiderers use tear-away 
stabilizers for woven fabrics and 
cut-away stabilizers for knits. See 
also Topping.
Backstitch:  Backstitch is an input 
method which can be used for 
delicate outlines. This stitch follows 
intricate curves well. It is also is the 
term used for every second row of 
stitches in a Tatami fill. See also 
Standard backstitch, Borderline 
backstitch, and Diagonal 
backstitch.
Backtrack:  Use Backtrack and 
Repeat to reinforce outlines while 
specifying the direction of the 
stitching. Backtrack stitches in 
reverse direction to the original. It 
is typically used to make run stitch 
outlines thicker without creating 
unwanted connecting stitches. 
Repeat duplicates the original stitch 
direction and is typically used with 
closed shapes.
Backup:  The copying of files onto 
floppy disk or other storage media 
in order to duplicate and secure 
data. Usually two copies are made 
and kept separately.
Batting:  A layer of padded material 
between the front and back fabric 
to add thickness and substance.
Begin jump function:  Begin Jump 
functions instruct the machine not 
to use needle penetrations. When 
encoded in an output file, it 
normally converts to a Needle In 
function. See also End Jump 
function.
Bézier curve:  Vector shape 
produced according to principles 
invented by French engineer, Pierre 
Bézier. A Bézier curve consists of a 
series of segments with shapes 
generated by cubic functions. Each 
segment is bounded by nodes, and 
its curvature is affected by a control 
point associated with the node at 
each end. The displacement and 

direction of the control point from 
the node are parameters from 
which the cubic curve shape is 
derived.
Bitmap:  Also known as raster 
images, bitmaps are electronic 
images made up of dots or ‘pixels’, 
in contrast to vector ‘outlines’. Each 
pixel is mapped to a location in an 
image and has numerical color 
values. Typically created in paint 
programs, bitmaps have file 
extensions such as BMP, JPG, GIF, 
TIF and PCX. When enlarged or 
scaled down, vector drawings 
preserve image quality while 
bitmap images generally cause 
problems of pixelation and image 
degradation. See also Pixels.
Blackwork:  Blackwork gets its 
name from the black silk thread 
traditionally used in this form of 
embroidery. It can be used to 
decorate articles such as hankies, 
table napkins, table clothes, and 
doilies.
Blatt stitch:  Schiffli term meaning 
‘to feed the yarn’, thereby 
producing a long zigzag stitch with 
threads lying close together. 
Adapted for Multihead use. See also 
Satin stitch.
Blending:  See Color Blending.
Bling:  Refers to decorative objects 
placed on a garment or template. 
They are supplied in various sizes, 
shapes, colors and materials. Often 
referred to as rhinestones.
Block:  The basic unit of a quilt top.
BMP:  MS Windows® bitmap image 
format. See also Bitmap.
Bobbin:  Spool or reel that holds the 
bobbin thread, which helps form 
stitches on the underside of the 
fabric.
Bobbin thread length:  This factor 
provides a simple mechanism for a 
more accurate bobbin thread length 
estimate. The default value (100%) 
is suitable for a design with a 
mixture of stitch types. If the 
design is all run stitches or all 
tatami, more bobbin thread will be 
used and the factor can be 
increased say to 125%. If the 
design is all satin stitch, the factor 
can be reduced to say 65%.
Bonding:  Permanently joining two 
fabrics together with a bonding 
agent. Heat sealing.
Border:  Single closed-curve object 
which can be optionally added to a 
monogram. Also, a strip of fabric 
that is joined to an inner quilt to 
enhance it.
Borderline backstitch:  The rows 
are approximately parallel. With 
lower density fills, borderline 

backstitch creates a smooth, 
well-defined edge. Borderline 
backstitch is also called Trapunto 
style. See also Backstitch.
Borer:  Borer is a sharp instrument 
attached to embroidery machines 
to puncture fabrics. Schiffli 
machines have built-in borer knives 
under the needle line which can cut 
different sized holes in fabric.
Borer depth:  You can choose the 
numbering system for specifying 
the Borer depth: Plauen where one 
is the base and seven (7) the 
normal middle position and Saurer 
where the base is zero and the 
normal middle position is six (6).
Borer depth function:  The Borer 
Depth function controls the size of 
the boring hole. The deeper the 
borer cuts, the larger the hole. The 
borer depth on Schiffli machines is 
changed one value at a time. Thus 
a change in depth of three (3) units 
will be automatically distributed by 
Schiffli to three (3) stitches.
Borer functions:  Borer In/Out 
functions are available for 
embroidery machines equipped 
with a borer. They instruct the 
machine when to use the boring 
knife or tool instead of a needle.
Boring:  ‘Open-work’ incorporated 
into embroidered designs. A 
sharp-pointed instrument 
punctures, or bores, the fabric, and 
stitches are made around the 
opening to enclose the raw edges.
Boring tension functions:  
Start/End Boring Tension functions 
instruct servo thread machines to 
feed less thread for stitching in 
boring holes. For Hiraoka TNS Ein, it 
overrides/restores Stepp/Blatt 
tension.
Bounding box:  The dotted 
rectangle that appears when you 
select a range of items.
Branching:  The Branching feature 
lets you digitize like objects – e.g. 
the fingers of a hand – without 
having to think about the most 
efficient stitching sequence and 
joins.
BRO:  Bits & Volts file format.
Candlewicking:  A traditional 
white-on-white embroidery 
technique, usually done on white 
linen or cotton fabric with heavy 
cotton threads.
Card:  A paper tape to control the 
frame. Various sizes for Schiffli 
machines, 7 channel for multihead. 
See also Jacquard card.
Cap Corner:  A type of Smart 
Corner. Cap corners are used for 
very sharp corners as they produce 
fewer stitches.
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Cascade:  A way of arranging open 
windows on the desktop so that 
they overlap each other, with the 
title bar of each window remaining 
visible.
CED:  A data condensed file format. 
Center at current stitch:  The object 
will be placed with its center at the 
needle position marker.
Center run underlay:  Center Run 
underlay places a row of stitches 
along the center of a column. It is 
used to stabilize narrow columns 
(e.g. 2-3 mm wide).
Chain stitch:  Stitch that resembles 
a chain link, formed with one thread 
fed from the bottom side of the 
fabric. Done on a manual or 
computerized machine with a hook 
that functions like a needle.
Checkbox:  A small square box that 
appears in a dialog box and that can 
be selected or cleared. When 
selected, a tick or a cross appears. 
A checkbox represents an option 
that you can set.
Chenille:  Form of embroidery in 
which a loop (moss) stitch is formed 
on the top side of the fabric. Uses 
heavy yarns of wool, cotton or 
acrylic. Created by a chain stitch 
machine that has been adjusted to 
form this stitch type. Also known as 
‘loop piling’.
Click:  Press and release the left 
mouse button. See also 
Right-click.
Click-and-drag:  Click to select, 
hold down the left mouse button, 
move the cursor and release.
Clipboard:  A temporary storage 
area in PC memory for what was 
last cut or copied. Images on the 
clipboard can be pasted into 
designs any number of times.
Close button:  Used to close a 
window or an application. In 
MS Windows®, it appears as a 
small box with an ‘X’ in it at the 
top-right of the title bar.
CND:  Melco Condensed (CND) is 
the native file format of the Melco 
embroidery digitizing software. 
CND files store only digitized 
outlines and stitch values.
Color blending:  Digitizing 
technique which creates interesting 
perspective, shading and color 
effects by blending colored layers. 
Two colors are merged smoothly 
from one to another using a mixture 
of dense and open fill.
Color block:  A color block or 
‘element’ corresponds to a color 
change in the design. It may be 
comprised of one or more 
same-color objects. These may 
form a single group – e.g. ‘ropes’ – 

or more – e.g. ‘ropes and birds’. 
Each color block, or element, can be 
given a descriptive name for easy 
identification. These then appear on 
the production worksheet. The 
operator generally uses them to 
ensure correct colors are used 
during production. The 
Color-Object List provides a 
sequential list of objects as 
digitized, grouped by ‘color block’. 
This list shows a separate icon for 
all color blocks and objects used in 
the design. The Color Palette Editor 
also shows a list of color blocks. 
Color-change function:  
Color-change functions tell the 
Schiffli machine to change thread 
color. In RCC/INC machines, the 
command also moves the frame 
under the next selected needle. 
They are automatically inserted 
when you select a new color from 
the color palette.
Color depth:  Color depth, also 
called ‘pixel depth’, refers to the 
amount of color information 
available to each pixel in an image. 
An image with a color depth of 1-bit 
can display only two colors. As the 
color depth increases, more colors 
are available – 16 Colors (4 bit), 
256 Colors (8 bit), High Color (16 
bit), True Color (24 bit).
Color palette:  The color palette 
contains a selection of thread colors 
tailored for each design. This color 
scheme, or ‘colorway’, represents 
the actual thread colors in which a 
design will be stitched. See also 
Thread chart.
Color Reduction:  See Image 
Preparation.
Colorways:  Colorways are multiple 
color schemes for the same design. 
They are made up of colors defined 
in ‘color books’ which may be 
created in Wilcom 
EmbroideryStudio or similar design 
program, or may be selected from a 
patent color system such as 
Chromatone or Pantone.
Column:  Narrow, long, curving 
shape.
Column A:  An input method used 
to digitize columns of varying width 
and stitch angle. Digitized pairs of 
reference points define the outline, 
while lines connecting the pairs 
define the stitch angles.
Column B:  An input method used 
to digitize shapes where one side is 
different to the other, especially 
where one side requires more 
reference points than the other. 
Stitches turn evenly throughout the 
entire shape. You can use any fill 
stitch type except Motif Fill.
Column C:  An input method used 
to digitize columns of fixed width. It 

is typically used for digitizing 
borders and outlines of larger 
shapes. You can digitize columns to 
create thick lines or borders. 
Column C is typically used with 
Satin stitch.
COM port:  A standard serial port 
used as a connection point for 
peripherals. Other ports may be 
present if the appropriate internal 
option cards have been installed. 
The computer must be informed 
which port is being used by which 
peripheral – e.g. COM1, COM2, etc.
Combination Split:  Use of different 
combinations of Satin and Tatami 
stitches in Program Split to create 
various effects with the same 
pattern. There are three 
Combination Split options – Satin in 
Satin, Satin in Tatami and Tatami in 
Tatami.
Command:  An instruction issued to 
the software in order to carry out an 
action. It may be as simple as 
‘paste an object’ or as complex as 
‘regenerate stitches’. It is usually 
activated via a menu item, toolbar 
icon, or command button in a 
dialog.
Command button:  A button in a 
dialog which executes or cancels 
the selected action. Two common 
command buttons are Cancel and 
OK.
Complex Fill:  Input method, used 
to digitize large and complex 
shapes. Allows holes to be 
designated at the same time the 
object outline is digitized. The 
object is thus digitized as one fill 
area, instead of being broken down 
into multiple sections. Objects so 
created are known as Complex Fill 
objects.
Complex Turning:  This is an input 
method used to digitize complex 
shapes with turning stitches. Many 
shapes can be digitized with this 
tool. Create objects using left and 
right clicks to mark reference points 
to form the boundary outlines. By 
digitizing boundaries within shapes, 
you can create filled objects with 
holes.
Complex Turning trapunto:  This is 
open fill stitching that turns 
according to user-defined stitch 
angles. As with Complex Fill, 
Trapunto effect forces travel runs to 
the edges of objects so they do not 
show through open or loose 
stitching.
Condensed file:  See Design file.
Configuration:  The size and type of 
computer hardware. Can also be 
used to mean the options provided 
with your software.
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Confirmation message:  A message 
displayed by the software asking 
you if you are sure you want to 
proceed – e.g. when you want to 
delete a design.
Connection Manager:  A software 
feature to allow the sending of files 
to shared folders.
Connector stitches:  Connector 
stitches link objects in a design. 
They can be run stitches or jumps. 
You can use automatic settings to 
generate connectors, trims and 
tie-offs, or add them manually. 
However, automatic connectors are 
not recommended for Schiffli 
designs because machine functions 
cannot be placed on connector 
stitches (stitches in the Needle Out 
position).
Connectors:  Hardware devices to 
connect cables to ports. If the 
connection is male, the port is 
female, and vice versa. The wiring 
configuration of each device is 
determined by its function.
Copy:  To place a copy of a selection 
onto the clipboard. See also 
Duplicate.
Control panel:  The panel on an 
embroidery machine by which the 
operator sets up the machine for 
embroidery production.
Control points:  Control points are 
used to modify object shapes, stitch 
angles and entry and exit points. 
You can change the shape of an 
object by moving, adding or 
deleting control points on the 
outline. For most objects, you can 
also change control points from 
corner points to curves.
Contour stitch:  Contour is a curved 
fill stitch type – stitches follow the 
contours of a shape, creating a 
curved, light and shade effect. It 
only works on columnar shapes. 
There are two types – Standard and 
Spiral – both of which can be 
applied to Column A, Column B, 
Column C or Ring objects. Standard 
Contour can also be applied to 
Circle objects.
Copyright:  A right granted by the 
government or by international 
agreement giving the owner the 
exclusive privilege to publish and 
sell artistic work during the life of 
the creator plus 50 years.
Cord functions:  Cord In/Out 
functions tell the machine to 
engage or disengage the cord 
device.
Cording:  Cording is a technique 
which employs a single decorative 
cord laid on fabric and attached 
with transparent zigzag stitches. It 
forms relatively simple, 
low-stitch-count designs featuring 

lots of swirls and curves. Raised 
cording is achieved by sewing the 
garment around the cord from the 
wrong side. The result is a 
self-fabric raised effect. Different 
widths of cording are available to 
provide a wide range of looks. A 
special attachment is required for 
the embroidery machine.
Cord-in-lay:  A special apparatus to 
automatically lay on cord or ribbons 
on a Schiffli machine.
Cover stitch:  Cover stitch is the 
border around an appliqué shape. 
You can control various settings 
including cover stitch type – Satin 
or E Stitch – width, stitch spacing, 
as well as the offset.
Conversion software:  Programs 
that read information, other than 
from a card, and translate it from 
one sewing machine format to 
another. 
Converter box:  A converter box 
acts like a translator from one 
memory card format to another, via 
computer. Various companies offer 
this technology under names like 
the Magic Box™ from Oklahoma 
Embroidery. They translate designs 
from memory cards in other 
formats or from a hard drive, disk, 
or CD and write the design to a 
blank card. 
Crest:  An embroidered motif like an 
emblem, an insignia or a Coat of 
Arms.
Crystals:  See Bling.
CPU:  Central Processing Unit.
CSD:  POEM/Singer/Huskygram file 
format
Current settings:  Current property 
settings override the template 
defaults. Unless you deliberately 
change them, these take the 
default values. You generally 
change them to save time when 
digitizing. For example, you may 
preset Tatami stitch spacing to use 
a specific density for all new Tatami 
objects you create. See also Object 
properties.
Custom:  Lets you map thread 
colors to every stop code in the file. 
This means you can color-code 
machine file designs which do not 
contain needle addressing 
information, before opening the 
file.
Custom fonts:  Custom fonts are 
made up of letters, numbers or 
symbols you digitize.
Custom designs:  Designs created 
by digitizing artwork or 
manipulating existing patterns.
Cut:  An editing function. To remove 
a selection from a design. The cut 
selection is stored in memory (on 

the ‘clipboard’) and can be pasted 
into the same or different design.
Cut appliqué:  See Back appliqué.
Cutter:  See Appliqué cutter.
Cutting lines:  A second line of run 
stitches that forms a guide when 
trimming the fabric of an appliqué 
patch.
DAT:  DAT is the machine file 
extension used with Hiraoka, 
Laesser, and Wilcom SPES formats.
Default object properties:  See 
Default values.
Default values:  predefined settings 
which determine object properties 
such as stitch spacing, as well as 
certain system settings. These are 
stored in the design template. They 
are automatically applied to any 
newly created objects. They remain 
‘current’ unless you override them 
with new settings. See also Current 
property settings.
Defects:  See Stitching defects.
Density:  See Stitch density or 
Thread density.
Design:  A ‘design’ is a file in the 
native embroidery format – e.g. 
EMB, JAN, ART – of embroidery 
digitizing software. The design 
source may be a stitch format 
design. The design contains 
stitching information such as fabric 
type in addition to stitched shapes.
Design card:  Disk containing 
computerized embroidery designs 
read by the embroidery machine’s 
computer.
Design elements:  The decorative 
design components that make up a 
monogram (including ornaments 
and borders).
Design file:  Design files, also 
known as ‘outline’ or ‘condensed’ 
files, are high-level formats which 
contain object outlines, object 
properties and stitch data. 
Examples include CND, GNC, INP 
and PCH. When you open an outline 
file in EmbroideryStudio, 
corresponding stitch types, input 
methods and effects are applied. 
Design files can be scaled, 
transformed and reshaped without 
affecting stitch density or quality. 
See also Machine file.
Design object:  See Objects.
Design properties:  Designs 
themselves have properties, some 
of which can be modified, others 
not. The most important design 
property is its source – Native 
Design, Imported Outlines, 
Processed Stitches, or Imported 
Stitches. Other properties include 
the software version number, stitch 
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count, and so on. Colorways too are 
properties of the whole design.
Design repeat:  A Schiffli design is 
repeated horizontally as many 
times as it fits across the frame. 
Repeat values increment in 
multiples of 4 to a maximum of 96. 
For example, the design can be 
stitched by every needle 
(Repeat=4/4), every second needle 
(Repeat=8/4), or every third needle 
(Repeat=12/4), and so on.
Design source:  While embroidery 
files are broadly classified as 
‘design’ (outline) or ‘machine’ 
(stitch), EmbroideryStudio 
internally tags files as belonging to 
one of four types–Native Design, 
Imported Outlines, Processed 
Stitches, or Imported Stitches. See 
also Design properties.
Design template:  See Template.
Design window:  The design 
window is where designs are 
displayed for viewing and 
modification.
DW Administrator:  It is the DW 
Administrator who is generally 
responsible for the high-level setup 
of DesignWorkflow databases. The 
DW Administrator determines who 
gets access to databases, what 
users can see and do, and who 
defines the categories under which 
information will be stored. The DW 
Administrator is generally the 
manager of the company’s design 
section. This person has the 
necessary background knowledge 
and authority to control what goes 
into databases and how the 
information is to be used.
Desktop:  MS Windows® 
terminology for the screen 
background on which program 
icons are displayed.
Destination folder:  The folder 
(directory) where you intend to 
copy or move one or more files.
Detail:  An outline, a border, a 
pickout run, or a small area of the 
design you want to be stitched out 
last when using Smart Design.
Diagonal backstitch:  The backward 
rows are diagonal, directly 
connecting the forward rows. 
Diagonal backstitch is suitable for 
turning shapes, and gives good 
results with Jagged Edge. See also 
Backstitch.
Dialog:  An onscreen box that either 
requests or provides information. 
Many dialogs present options to 
choose among before a command is 
carried out. Some dialogs present 
warnings or explain why a 
command cannot be completed.
Digitizer:  Usually refers to the 
person punching or digitizing the 

design. Digitizer can also refer to 
the digitizing tablet used by the 
digitizer. See also Digitizing 
tablet.
Digitizing:  Process of encoding a 
design. Artwork is converted into a 
series of ‘embroidery objects’ to be 
read and manipulated by a 
specialist CAD/CAM application. 
Before outputting to embroidery 
machine, it is converted into ‘stitch 
data’. See also Punching.
Digitizing puck:  With a digitizing 
tablet, you generally use a puck 
instead of a mouse to mark 
reference points and select 
commands from the menu chart.
Digitizing tablet:  Design device 
used by digitizers to plot needle 
penetrations for embroidery 
designs. Sometimes used as an 
alternative to digitizing directly 
on-screen. Typically, a pencil 
drawing of the design is enlarged 
and then taped to this tablet. The 
digitizer then uses a device known 
as a puck to indicate stitch types, 
shapes, underlay and actual needle 
penetrations.
Digitizing tool:  Digitizing tools, 
sometimes referred to as ‘input 
methods’, are similar to drawing 
tools except that the end result is 
an embroidery object rather than a 
vector object. Different digitizing 
tools are suited to creating different 
shapes or design elements.
Direct-to-garment printing:  DTG is 
performed like most other printing 
from a PC. The print image is sent 
to the DTG printer through the 
MS Windows® print manager using 
a print driver. The image must have 
a transparent background for DTG 
printing. DTG printing requires heat 
fixing to make the images 
washable.
Disk:  See Floppy disk.
Disk drive:  Computers usually have 
three types of disk drive: a hard 
disk (or fixed disk) which usually 
supports the mass storage of 
information and applications, a 
floppy disk drive, and a CD ROM 
drive.
Display:  A screen used to display 
the output of a computer. Also 
known as the monitor.
Dithering:  A software technique 
which combines existing colors in a 
checkerboard arrangement of 
pixels. It is typically used to 
simulate colors that are missing 
from an image palette. A type of 
optical illusion created by placing 
two pixels of different color next to 
each other. The human eye 
automatically resolves the two 
colors into a third color.

Docker:  A dialog which, while open, 
allows the user to select objects 
freely. Controls in the dialog change 
to conform to the values of selected 
objects, or show relevant system 
information when no object is 
selected. Changes made to settings 
in the dialog may be applied while it 
remains open. Other dialogs and 
commands may be opened and 
used while the modeless dialog 
remains open.
Dongle:  A security hardware device 
required to run protected software. 
Some are attached to a parallel 
port, others to a USB port.
Dots per inch (DPI):  A 
measurement of screen or printer 
resolution; the number of dots in a 
line of 1".
Double split alternate:  A variant of 
Tatami split. See User Defined 
Split.
Double-click:  Click the left mouse 
button twice without moving the 
mouse. Double-clicking carries out 
actions such as opening a program 
from an icon.
Download:  The process of 
transferring a copy of a file from a 
remote computer or the internet to 
a computer or other device such as 
an embroidery machine.
Drag:  An operation of the mouse. 
Holding the (left) mouse button 
while moving the mouse. Typically 
used for moving something on the 
screen.
Drawing object:  See Vector 
object.
Drawing package:  Software 
application that creates or allows 
you to edit vector graphics made up 
of separate individual vector 
objects. Vector graphics can be 
scaled with no loss of sharpness. 
Examples of vector editing 
programs are Adobe Illustrator, 
MacroMedia Freehand and Corel 
Draw. See also Graphics 
application.
Droplist :  A single-line dialog box 
control that opens to display a list of 
choices.
Drop sequin function:  The Drop 
Sequin function is available for 
embroidery machines equipped 
with a sequin dispenser. It instructs 
the machine when to drop a sequin 
on the fabric for stitching.
DSB:  Barudan file format. Basically 
the same as the T03 tape file but 
wit a ‘header’ in front so that it can 
be written to floppy disk – i.e. it is 
the floppy disk version of the T03 
file.
DST:  Machine file format native to 
Tajima machines.
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DSZ:  ZSK stitch or ‘expanded’ file 
format.
Duplicate:  When an object is 
duplicated, it is not copied to the 
clipboard. This leaves the clipboard 
free for you to cut or copy other 
objects.
DXF:  AutoCAD vector graphic 
format.
E Stitch:  Widely used for tacking 
down appliqués as a decorative 
border. The stitches form a comb 
pattern.
Editing:  Changing aspects of a 
design via a computerized editing 
program. Most programs allow you 
to scale designs up or down, edit 
stitch-by-stitch or block-by-block, 
merge lettering with the design, 
move aspects of the design around, 
combine designs and insert or edit 
machine commands.
Elastic lettering:  Special effects 
applied to lettering objects to make 
them bulge, stretch or compress. 
Electronic artwork:  There are two 
broad categories of artwork file, 
both of which can be imported into 
EmbroideryStudio for use as 
digitizing backdrops – vector and 
bitmap. To create good quality 
embroidery, you need to choose or 
create suitable artwork of either 
format.
Element:  An element, in software 
terms, is a color block consisting of 
sequential, same-color objects. You 
can assign names to elements 
which then appear on the 
production worksheet. The operator 
generally uses these to make sure 
colors are correct during 
production. See also Production 
worksheet.
EMB:  Design file format native to 
Wilcom ES. EMB designs contain a 
complete set of design information 
in a single ‘all-in-one’ file – object 
outlines and properties, actual 
stitches and machine functions, 
thread colors, a picture icon, 
summary information, and more. 
Even the original design bitmap 
image can be included in EMB 
format. Only native EMB files 
provide 100% perfect scaling and 
transformation.
Emblem:  Embroidered design with 
a finished edge, applied to a 
garment after stitching, commonly 
an insignia of identification. Also 
known as a ‘crest’ or ‘patch’.
Emblem work:  Many Schiffli 
machines are used for creating 
emblems or logos. This work, 
however, uses only a small subset 
of the available functions of the 
Schiffli machine. Typically, for 
example, emblem work does not 

contain the bored holes or long 
Satin stitches which occur in lace 
designs. Emblem work is also 
stitched on Multihead machines.
Embroidery:  Decorative stitching 
on fabric. Generally involves 
non-lettering designs, but can also 
include lettering and/or 
monograms. Evidence of 
embroidery exists during the reign 
on Egyptian pharaohs, in the 
writings of Homer and from the 
Crusaders of the 12th century. Has 
evolved from hand-work to manual 
sewing machines and from 
hand-looms and Schiffli machines 
with hundreds of needles to 
high-speed, computerized 
multihead machines.
EmbroideryConnect:  Optional 
element for EmbroideryStudio 
needed to configure an 
EmbroideryConnect machine 
network.
Embroidery disk:  Embroidery disks 
are specially formatted floppy disks 
used to transfer designs from 
computer to embroidery machine. 
You can format embroidery disks 
and save designs to them from 
within EmbroideryStudio. The 
format you use will depend on the 
selected embroidery machine. You 
can also open designs from 
embroidery disk directly into 
EmbroideryStudio. 
Embroidery objects:  In embroidery 
design, you build designs from 
basic shapes or ‘embroidery 
objects’. They are called ‘objects’ 
because they are discrete entities 
which can be selected and 
manipulated independently of each 
other. They are like ordinary vector 
objects in that they have certain 
characteristics or ‘properties’ such 
as color, size, position, and so on. 
They also have properties unique to 
embroidery such as stitch type and 
density. See also Vector objects.
Embroidery thread:  See Thread.
Emery roller:  The Schiffli roller on 
which threads are twisted and 
tensioned.
Empty function:  An ‘empty stitch’, 
or non-data stitch, is an industry 
term for any stitch with a zero 
movement (0, 0). However, 
EmbroideryStudio distinguishes 
between intentional empty stitches 
related to the machine functioning, 
and unintentional empty stitches, 
which can occur in small or pointed 
parts of shapes. An empty function 
is an empty stitch that the system 
processes as a machine function. It 
is not removed by the small stitch 
filter and is preserved when stitches 
are regenerated or the design is 
resized. See also Empty stitch.

Empty jump:  You create empty 
jumps (0,0) manually in 
EmbroideryStudio by digitizing with 
Penetrations Out. This prevents the 
needle from penetrating the fabric, 
forcing the machine to move across 
the design in a series of jumps. 
Also, use empty stitches or empty 
jumps when required by the 
selected machine format. See also 
Empty stitch.
End Jump function:  End Jump 
functions instruct the machine to 
use needle penetrations. When 
encoded in an output file, it 
normally converts to a Needle In 
function. See also Begin Jump 
function.
Empty stitch:  Empty stitch is a 
tight (zero length) lockstitch, used 
together with, or as an alternative 
to, tie-in and tie-off stitches, 
particularly in objects filled with 
light density stitching where 
standard tie-ins and tie-offs may be 
visible. Also, use empty stitches or 
empty jumps when required by the 
selected machine format. See also 
Empty jump and Empty function.
EMX:  Wilcom cross stitch file 
format.
End X/Y:   The coordinates of the 
last stitch.
Enlargement drawing:  The 
technical drawing, usually six times 
larger than the original design, 
indicating the stitches to be 
digitized. When you digitize with a 
tablet, you use an enlargement 
drawing to trace the shapes and 
outlines of the design in the same 
way you use backdrops on-screen. 
Before you start, you need to 
prepare the enlargement drawing. 
See also Digitizing tablet.
Enlarger:  The draftsman or 
designer who draws the technical 
drawing for the puncher to follow.
Entry point:  The entry point is the 
point where the thread enters the 
embroidery object. This should 
coincide with the exit point of the 
preceding object.
Envelope:  Special effect which 
makes objects bulge or arch, 
stretch or compress. Envelope is 
typically applied to lettering 
objects, but can also be applied to 
other types of embroidery object.
EPS (Encapsulated PostScript):  A 
standard file format for importing 
and exporting PostScript language 
files among applications in a variety 
of environments. An ESP file is a 
PostScript file which describes a 
single page, usually an illustration. 
In general, the purpose of the EPS 
file is to be included (encapsulated) 
in another PostScript file and can 
contain any combination of text, 
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graphics and images. EPS files 
normally include a small, 
low-resolution TIFF, or 
vector-based MS Windows® 
metafile image preview, as it will 
appear on a printed page.
ESD:  Native DOS format of Wilcom 
DOS ES – contains stitch data, like 
stitch types and densities, which 
permits better processing. ESD in 
later versions contains lettering 
objects with outlines.
ESL:  ESL is a file used to produce 
any Wilcom Schiffli Tnn file from 
EmbroideryStudio. It is read but not 
written by the Schiffli Converter to 
produce RCC Tnn files.
ESS:  ESS is the primary machine 
file format for Wilcom-developed 
Schiffli servo control systems. 
When the ESS file is read directly by 
a Wilcom Electronic Servo System 
(WESS), high data resolution and 
stitch accuracy are possible.
Exit:  To leave a current window or 
application.
Exit point:  The exit point is the 
point where thread leaves the 
embroidery object. This should 
coincide with the entry point of the 
next object.
EXP:  Stitch or ‘expanded’ file 
format native to Melco machines.
Expanded file format:  See 
Machine file.
Expanded tape:  An expanded tape 
which has every stitch of the design 
punched.
Extension:  See File extension.
Fabrics:  Fabrics have many 
properties, the main one being 
elasticity or ‘fabric stretch’. Surface 
texture, if present, is another 
property that requires different 
underlay types. When you choose a 
fabric for use with a particular 
design, the system pre-loads 
settings optimized for that fabric. 
These can be overridden on an 
object-by-object basis. See also 
Fabric settings.
Fabric settings:  predefined fabric 
settings include settings for all 
full-coverage stitch types. For each 
stitch type, spacing is preset. 
Additionally, the quality effects of 
pull compensation and underlay are 
also preset for each stitch type. 
Push, warping, and shearing are 
reduced by suitable underlay for the 
stitch type and fabric. Decorative 
effects such as Motif Fill are not 
affected when fabric settings are 
changed.
Fabric stretch:  Embroidery stitches 
pull the fabric inwards where the 
needle penetrates. This can cause 
the fabric to pucker, and gaps to 

appear in the embroidery. Use 
automatic pull compensation to 
counter this effect by ‘overstitching’ 
outlines of filled shapes.
Facing:  See Topping.
Factory settings:  These are the 
initial system settings as installed. 
They are a standard known setting 
that you can return to. Some 
customers want to create custom 
settings tailored to the exact fabric 
they are using most frequently. The 
‘My Fabric’ settings are those 
retained in the design and can be 
saved to the template file.
Fadenleiter:  Fadenleiter is a 
mechanism on some Schiffli 
machines for controlling the feed 
and tension of yarns.
Fadenleiter functions:  Fadenleiter 
+/- functions instruct the machine 
to increase or decrease Fadenleiter 
stroke one increment. This means 
increasing or decreasing thread 
feed because the section is getting 
wider/narrower.
FDR:  An embroidery disk format 
native to Barudan machines.
Festoon:  Festoon is a mechanism 
on some Schiffli machines for 
reinforcing edges on scallops, etc, 
for a strong cutting edge. It is also 
the name of a stitch type.
Festoon functions:  Festoon In/Out 
functions instruct the machine to 
engage or disengage the festoon 
device.
File:  A named collection of 
specifically related information 
stored on a disk. Designs that have 
been saved are stored as files.
File extension:  The dot and three 
letters at the end of a filename such 
as ‘.BMP’. The extension identifies 
the file as a certain type, readable 
by certain applications.
Filename:  The name of a file, 
including the extension, e.g. 
Cat.BMP.
Fill stitch:  Series of running 
stitches commonly used to cover 
large areas. Different fill patterns 
can be created by altering the 
angle, length and repeat sequence 
of the stitches. Also known as 
Geflect stitch.
Finishing:  Processes done after 
embroidery is completed. Includes 
trimming loose threads, cutting or 
tearing away excess backing, 
removing facing or topping, 
cleaning any stains, pressing or 
steaming to remove wrinkles or 
hoop marks and packaging for sale 
or shipment.
FIXPAT:  The FIXPAT (Fix Pattern) 
utility is a conventional Schiffli 
visual-editing program which 

displays the tape file in the 
Jacquard card format with holes. 
The program is good for 
safety-checking designs and can be 
useful as a fast editor for known 
problem patterns as well as direct 
function editing.
Flagging:  Up and down motion of 
fabric under action of the needle, so 
named because of its resemblance 
to a waving flag. Often caused by 
improper framing of goods. 
Flagging may result in poor 
registration, unsatisfactory stitch 
formation and birdnesting.
Float:  Longer-than-normal Satin 
stitches that lay on top of a design, 
or the stitches made when the 
needle is disconnecting from the 
design; later removed.
Floppy disk:  A flexible disk 
permanently sealed in a square 
plastic jacket – e.g. HD/DD 3.5" 
floppy disk. Used for information 
storage ‘off-line’ for security and/or 
infrequently used data. Also used 
for transferring punched 
embroidery design (machine file) 
data from computer to embroidery 
machine.
Florentine effect:  With Florentine 
Effect you can curve Complex Fill 
along a digitized line to create 
flowing stitch effects. The stitches 
follow the digitized line but 
maintain uniform density and 
needle penetration patterns.
FMC:  An embroidery disk format 
native to Barudan machines.
Folder:  A collection of files and 
subfolders that are stored together 
on a disk. Part of structure for 
organizing files on a disk.
Font:  A set of characters, including 
letters, numbers and other 
typographic symbols, of the same 
design and style. Sometimes called 
‘alphabet’, even if it includes 
non-letter characters. See also 
Lettering.
Following:  The directions drawn on 
the enlargement by the designer as 
a guide for the puncher's 
advancement and sequence in 
punching.
Fox test:  Method of testing thread 
tension and soundness of timing. 
Sew the word FOX in one-inch Satin 
stitch block letters with each needle 
bar, then examine the reverse side 
for skipped stitches and correctly 
balanced ratio of top thread to 
bobbin thread. The correct balance 
is generally considered to be a 
one-third ratio of bobbin thread to 
two-thirds top thread. These letters 
are used because they require the 
movement of the pantograph in all 
directions, increasing the likelihood 
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that the beginnings of timing 
irregularities will be discovered.
Fractional spacing:  Fractional 
spacing is used to place stitches 
more evenly in curved shapes, 
producing better quality 
embroidery with fewer stitches. 
Fractional spacing is particularly 
useful for columns of Satin stitches 
with sharp turns.
Frame:  Holding device to secure 
fabric under an embroidery head for 
stitching. May employ a number of 
means to maintain stability during 
the embroidery process, including 
clamps, vacuum devices, magnets, 
or springs. See also Hoop.
Frame-out position:  When you 
stitch out appliqué objects, you can 
set a frame-out position. This shifts 
the hoop out from under the 
needle, making it easier to place 
and trim the appliqué shapes. The 
frame out settings determine the 
distance and direction of the hoop 
movement.
Free Line baseline:  Free Line is the 
only type of baseline which does not 
have a fixed or pre-determined 
length. When you choose Free Line, 
the baseline will extend as long as 
you keep adding letters. You only 
need to mark its start point. See 
also Baseline.
French inch:  The French inch is a 
measurement used for spacing 
needles on the Schiffli machines (c. 
27mm). See also Needle spacing.
Fringe:  Threads that are cut and 
hang loosely from the edge of a 
design.
Function:  See Machine Function.
Geflect stitch:  Geflect refers to 
light or heavy stitching used to fill in 
an area of a design with run 
stitches. It is also known as 
Ceeding or Tatami. See also Fill 
stitch.
Generic Shiffli machine format:  
Because there are many types of 
Schiffli machine, individual settings 
can be quite different even though 
the capabilities are the same. To 
deal with this, Schiffli uses the 
concept of the ‘Generic Schiffli 
Machine’. The Schiffli generic 
machine format supports functions 
required for a wide range of 
machine types.
Glitz:  See Bling.
Graphics application:  Software 
application that creates or allows 
you to edit bitmap images and/or 
vector graphics. See also Paint 
package and Drawing package.
CorelDRAW Graphics:  An operating 
mode in which the CorelDRAW® 
Graphics Suite application is active.

Gradient Fill:  An artistic stitch 
effect that gradually varies stitch 
spacing between dense and open fill 
along an embroidery object, 
producing shading and color effects 
which are difficult to achieve 
manually.
Grayscale:  A grayscale picture is 
made up of 254 different shades of 
gray, plus solid black and solid 
white for a total of 256 different 
tones. Black and white photographs 
are grayscale.
Grid:  Grid lines provide visual cues 
to help you accurately place a 
design. When you start the 
software for the first time, grid lines 
appear by default.
Guide runs:  Series of stitches used 
to align embroideries in 
multi-hooping situations or to assist 
in fabric placement for appliqué. It 
is the first appliqué layer stitched 
and is used to position the pre-cut 
appliqué patches on the 
background material. See also 
Appliqué.
Hard disk:  A device for mass 
information storage. Usually the 
disk is fixed inside the system unit, 
and a second hard disk can be 
added. When you store information 
on the hard disk it will remain there 
until you delete it. As it has a finite 
capacity, file management is 
required.
Hardware:  Computer componentry, 
including monitor, keyboard, 
digitizing tablet, printer, scanner, 
sewing machine, etc.
Heat transfer printing:  A process 
which is sometimes used in the 
production of a printed design for 
commercial use employs heat 
transfer paper to which graphics are 
printed. This is then heat-fixed to a 
garment using an iron or 
heat-press. The process falls into 
the same category as printing. 
Printers that support heat transfer 
media in most cases provide an 
automatic mirror function in the 
printer driver as the image must be 
printed in reverse in order to be 
heat-transferred to a garment. See 
also Direct-to-garment printing.
Heinzle:  Heinzle is a Schiffli disk 
format.
Heirloom embroidery:  
Embroidered goods designed to be 
passed down from generation to 
generation.
Hiraoka DAT:  Hiraoka DAT is a 
Schiffli disk version of the Plauen 
card format for Hiraoka machine.
Hoop:  Device made from wood, 
plastic or steel used to tightly grip 
fabric and stabilizer between an 
inner and outer ring. Designed to 

hold fabric taut against the machine 
bed for embroidering, it attaches to 
machine’s frame.
Hooping:  The process of placing 
the fabric and/or stabilizer into the 
embroidery hoop. One of the most 
common reasons for a poorly 
stitched design is improper 
hooping. 
I-beam:  One shape taken by the PC 
pointer, it indicates that text can be 
input at the point selected. The 
shape is like the capital letter ‘I’.
Icon:  Miniature picture used in the 
screen display instead of, or as well 
as, text. The file list can be 
displayed as icons with the 
filenames underneath; the 
toolboxes which appear in the left of 
the screen are composed of icons.
Image editing program:  See 
Graphics application.
Image preparation:  Cleaning up 
scanned images as input to 
embroidery digitizing. This may 
involve any one or a combination of 
the following techniques: reducing 
the number of colors, adding or 
emphasizing outlines, removing 
noise, dithering or anti-aliasing, 
eliminating unnecessary detail, 
cropping sections or eliminating 
backgrounds.
Imported outlines:  Designs read 
from non-EMB outline – CND or PCH 
– where stitches have been 
generated in EmbroideryStudio (or 
equivalent) from original outlines 
and stitching data.
Imported stitches:  Designs read 
from stitch or ‘expanded’ files, with 
or without outline recognition, but 
stitches have not been regenerated 
through stitch processing. Note that 
if you change a stitch design – e.g. 
add a lettering object – the status 
changes to ‘Processed Stitches’ 
even though the imported stitches 
may not have been regenerated.
INC:  Individual Needle Control 
(INC) was a mechanism originally 
developed for Saurer Pentamat 
machines whereby each 
needle/borer position across the 
whole machine could be activated 
or de-activated individually, either 
under program or manual control. 
INP:  Wilcom condensed file format.
Input method:  See Digitizing tool.
Jacquard card:  Historically Schiffli 
designs were stored on Jacquard 
cards of which there are two types 
– Plauen and Saurer. Named after 
Joseph M Jacquard, inventor of the 
Jacquard loom, Jacquard cards 
contain a stitch-by-stitch 
interpretation of the design 
together with machine functions, 
exactly as the embroidery machine 
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will read it, encoded as a series of 
holes. Later applied to 68 mm tape 
used to program automated 
embroidery machines. See also 
Tape code.
Jagged edge:  Technique for 
creating rough edges, to create 
shading effects, or to imitate fur or 
other fluffy textures in your design.
JPG:  JPEG file interchange bitmap 
image format.
Jump:  A frame or hoop movement 
without a needle penetration, 
commonly used to get from one 
point in a design to another.
Jump:  A frame or hoop movement 
without a needle penetration, 
commonly used to get from one 
point in a design to another. In 
Schiffli terms a Jump stitch means a 
frame movement in Needle Out 
mode.
Jump function:  Jump(M) functions 
cause frame movements without 
needle penetrations and are used to 
move smoothly from one part of a 
design to another.
Justification:  The position of 
lettering on the embroidery 
baseline.
Lacework:  Lacework involves the 
use of threads to produce overall 
embroidery of full-length fabrics. 
Most often used to embellish 
women's apparel and home 
fashions. Such work typically uses 
boring. It is the most widely used 
application for Schiffli machines.
LAN:  Local Area Network – a wired 
network of interconnected PCs and 
other network enabled devices such 
as printers.
Letter spacing:  The space between 
adjacent letters.
Letters:  Initials or name making up 
a monogram. Letters of a font.
Lettering:  Embroidery using letters 
or words. Lettering commonly 
called ‘keyboard lettering’ may be 
created from predefined font styles 
or fonts, allowing variance of size, 
height, spacing, density and other 
characteristics.
Line art:  A drawing with only two 
colors – usually black and white.
List box:  A single-line dialog that 
opens to display a list of choices.
Lockstitch:  Commonly referred to 
as a lock-down or tack-down stitch, 
a lockstitch is formed by three or 
four consecutive stitches of at least 
a 10-point movement. It should be 
used at the end of all columns, fills 
and at the end of any element in 
your design where jump stitches 
will follow, such as color changes or 
the end of a design. May be stitched 

in a triangle, star or in a straight 
line. Lock stitch is also the name of 
the type of stitch formed by the 
hook and needle of home sewing 
machines, as well as computerized 
embroidery machines.
Lockstitch machines:  Both Schiffli 
and Multihead machines are 
lockstitch machines, forming 
stitches in the same way as a home 
sewing machine. Lockstitch 
operations involve two threads – 
top and bottom. The top thread is 
driven by a needle, the bottom by a 
shuttle. The bottom thread ‘locks’ 
the top thread in place, hence the 
name ‘lockstitch’. See also 
Multihead lockstitch machine.
Logical machine functions:  Schiffli 
makes a distinction between 
‘logical’ and ‘physical’ machine 
functions. The logical machine 
function is what you, the digitizer, 
want to perform – for example, 
start or stop boring. Logical 
functions are saved as ‘object 
properties’ in the native Wilcom 
EMB design file.
Logo:  Name, symbol or trademark 
of a company or organization. Short 
for logotype.
Looms:  See Schiffli.
Loom run:  The stitching of one 
complete pattern in one row on a 
Schiffli machine.
Looping:  Loops on the surface of 
embroidery generally caused by 
poor top tension or tension 
problems. Typically occurs when 
polyester top thread has been 
improperly tensioned.
Machine file:  Machine or ‘stitch’ 
files are low-level formats for direct 
use by embroidery machines. They 
contain only stitch coordinates and 
machine functions. Machine files 
are generally not suited to scaling 
because stitches are not 
regenerated during rescaling. See 
also Design file.
Machine format:  Different 
embroidery machines understand 
different languages. They have 
their own control commands for the 
various machine functions. Before 
you can stitch a design, it must be 
in a format which can be 
understood by the target machine. 
Common formats include Barudan, 
Brother, Fortran, Happy, Marco, 
Meistergram, Melco, Pfaff, Stellar, 
Tajima, Toyota, Ultramatic and ZSK.
Machine function:  Machine 
functions are commands for a 
specific embroidery machine. These 
include color changes, thread trims, 
jumps, machine stops, needles 
in/out, and boring begin/end. 
Schiffli makes a distinction between 
‘logical’ and ‘physical’ machine 

functions. See also Logical 
machine functions and Physical 
machine functions.
Machine unit:  The ‘machine unit’ is 
the smallest frame movement 
which the embroidery machine can 
perform. In Schiffli machines there 
are three types – Plauen (1/6 mm 
or 0.1667mm), Saurer (0.1mm), 
and hi-resolution WESS.
Machine setup:  Before you can 
send designs for stitching, you must 
configure the machine in 
EmbroideryStudio. You can add 
machines, change settings for 
machines already set up, or delete 
machines that are no longer 
required.
Magic wand:  Technique for 
creating embroidery designs by 
automatically digitizing color blocks 
in electronic images.
Manual object:  When you open a 
stitch format file without outline 
recognition, it becomes a single 
‘manual’ object. This object 
consists of individual needle 
penetration points and has only 
general and connector properties. 
When you transform (scale, rotate, 
mirror) a manual object, the 
original stitch density does not 
change.
Max/Min stitch length:   The 
minimum and maximum stitch 
lengths allowable in a design 
determine the outside limits as 
measured between needle 
penetration points. They are 
governed by the minimum and 
maximum frame movements that 
the machine can make.
Maximize button:  For windows, the 
small box in the center of the group 
of three at the right of the title bar. 
Click the Maximize button to 
enlarge a window to its maximum 
size.
Memory:  The place in the 
computer’s system unit that stores 
information while you are working 
with it. If you exit without saving 
information in memory, it will be 
lost.
Menu bar:  The menu bar contains 
dropdown menus of commands. 
Some of the same commands are 
available on the toolbar.
Menu chart:  The menu chart 
provided with the software lets you 
select commands directly from the 
digitizing tablet using the puck. You 
need to ‘register’ it before use.
Minimize button:  For windows, the 
small box to the left of the group of 
three at the right of the title bar. 
Click the Minimize button to reduce 
a window to its minimum size.
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Minimum stitch length:  The 
minimum movement of the hoop. It 
is measured between needle 
penetration points. See also 
Max/Min stitch.
Mirror:  Duplication of an object in 
the Y and/or X axis. The location 
and orientation of the mirrored 
stitches are determined by location 
and angle of the axis of reflection 
relative to the position of the 
original stitches.
Mirror-merge:  Mirror-Merge Array 
can create multiple copies of 
designs, such as badges, spaced in 
rows and columns for faster 
stitchouts. Mirror-Merge Reflect can 
duplicate and mirror designs 
simultaneously. You can use it to 
quickly create borders or merge 
duplicates into a symmetrical object 
such as a heart. Mirror-Merge 
Wreath can duplicate objects 
around a center point. The 
Kaleidoscope tool works like Wreath 
but mirrors objects as well.
Mitre corner:  A type of Smart 
Corner. Mitre Corners create a 
sharp line at the intersection of the 
two columns. They are designed 
primarily for corners between 75° 
and 90°. See also Smart Corners.
Modal dialog:  A dialog which, while 
open, prevents the user from 
selecting any control or object 
outside it. Changes made to 
settings inside the dialog are not 
effective until it is closed.
Modem:  Unit to telegraphically 
send computer information from 
one computer to another.
Monitor:  In computer terms, a 
device that accepts video signals 
from a computer and displays 
information. Monitors generally 
employ cathode-ray tubes or 
flat-panel displays to project 
images. In practice, the terms 
monitor and display are used 
interchangably. In digitizing terms, 
the monitor is where digitizing or 
stitching progress can be followed, 
stitch-by-stitch.
Monogram:  Embroidered design 
composed of one or more letters, 
usually the initials of a name. Can 
also consist of borders or designs to 
mark ownership of items such as 
clothing, caps, handkerchiefs, etc.
Moss stitch:  Chenille-type stitch. 
See Chenille.
Motif:  predefined design elements, 
such as hearts, leaves or border 
patterns, that can be quickly 
inserted into a design. Motifs 
generally consist of one or more 
simple objects, and are stored in a 
special motif set.

Motif Fill:  Motif Fill is a decorative 
fill stitch with which you can fill 
larger shapes. Depending on your 
software’s capabilities, you can also 
create special or three dimensional 
effects.
Motif run:  Motifs which are linked 
together along a digitized line. You 
can create decorative outlines using 
any motif from the list. 
Motif set:  Motifs are stored in 
‘motif sets’ similar to fonts. There 
are two predefined motif sets. One 
contains single motifs for fills which 
use the same pattern in both 
forward and backward rows. The 
other set is intended for use with 
two-part motifs which use 
complementary patterns for 
forward and backward rows. You 
can also define your own ‘motif 
sets’ to organize and classify motifs 
of your own creation.
Mouse:  A device, equipped with 
control buttons and designed to roll 
about on the table next to the 
keyboard. As the mouse moves, its 
circuits relay signals that move a 
pointer on the screen.
MST:  MST is a Laesser file type. It 
includes same stitch data as 
Laesser DAT. (Not supported in 
Schiffli ES e4.)
Multicolored designs:  Multicolored 
designs contain more than one 
color. Most Schiffli machines do not 
support automatic color change. 
That is, there is no mechanism to 
activate individual or groups of 
needles. Thus multicolored designs 
are expensive to produce because 
operators need to manually trim the 
threads and re-thread the needles.
Multihead lockstitch machine:  
Multihead lockstitch machines have 
a horizontal frame. The needles are 
vertical, and are grouped in heads. 
They are mainly used for stitching 
individual items – e.g. badges, 
garments, which are stretched in 
separate hoops attached to the 
frame under each head. A 
multihead machine can have up to 
24 heads, and each head can have 
up to 20 or more needles. Thread 
change and trims can be done 
automatically. See also Lockstitch 
machine.
Multi-appliqué:   A type of appliqué 
object composed of more than one 
piece of fabric and bordered by 
various types of embroidery 
objects.
Native designs:  Native designs 
refer to designs created in 
EmbroideryStudio software (or 
equivalent).
Native file format:  A design saved 
in the original format of the 
application you are working with is 

said to be the ‘native’ file format. It 
can also refer to the machine file 
format required by a specific 
embroidery machine. When saved 
to another format, it is known as a 
non-native format.
Needle:  Small, slender piece of 
steel with a hole for thread and a 
point for piercing fabric. A machine 
needle differs from a handwork 
needle; the machine needle’s eye is 
found at its pointed end. Machine 
embroidery needles come with 
sharp points for piercing heavy, 
tightly woven fabric; ball points 
which glide between fibers of knit; 
and variety of specialty points, such 
as wedge points, which are used for 
leather.
Needle addressing:  Some 
machines support ‘needle 
addressing’. Needle numbers 
correspond to slots in the color 
palette. Each color in the design 
corresponds to a needle number. 
Older multi-needle machines simply 
move to the next needle whenever 
a color-change function is 
encountered. In either case, the 
machine must have the correct 
thread colors loaded for each 
needle to stitch out correctly.
Needle in/needle out function:  The 
Needle In and Needle Out functions 
instruct the machine whether or not 
to use needle penetrations. You can 
enter these functions automatically 
using the Penetrations tool.
Needle points:  You can view needle 
points in a design to check density 
or, for instance, to select stitches 
for editing.
Needle spacing:  Needle spacing is 
the distance between adjacent 
needles of a Schiffli embroidery 
machine. Typical values are 27.07 
mm and 27.04mm. The software 
lets you set up and adjust this value 
to suit the type of machine which 
will stitch the design.
Nesting:  Nesting lets you create or 
insert an object at an exact point of 
the stitching sequence. You can 
‘nest’ an object in the middle of 
another object’s stitching sequence 
to prevent long connectors being 
generated.
Network:  To link embroidery 
machines via a central computer 
and disk-drive system, usually via a 
modem or network card. A group of 
machines linked via a central 
computer.
Network folder location:  The 
logical location of a folder on a 
network. Contains the PC name 
together with the folder name – e.g. 
\\My PC\EmbroideryMachine1.
Noise filtering:  Noise filtering 
means restoring the solid color 
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blocks of original artwork in 
scanned images. This is achieved 
by merging different shades into 
one solid color. Noise filtering is 
important for automatic digitizing 
because it makes it easier for the 
software to identify solid color 
blocks which become embroidery 
objects in the resulting design. It 
also cleans up blurred or mottled 
areas of color.
NORMAL template:  The NORMAL 
template is the default template 
supplied with the software. It 
contains current property settings 
as well as a selection of preset 
styles. These styles include 
variations on the current property 
settings. For example, 
<PRESET_SATIN_1> and 
<PRESET_SATIN_2> contains 
different stitch spacing settings for 
Satin stitches. You can view and 
modify the settings for these styles 
at any time. See also Templates.
Objects:  In computer science, 
‘objects’ are regarded as any 
discrete item that can be selected 
and manipulated, such as an 
onscreen graphic. In 
object-oriented programming, 
objects include data and the 
procedures necessary to operate on 
that data. See also Embroidery 
objects.
Object outline:  See Design file.
Object properties:  All embroidery 
objects in EmbroideryStudio 
contain defining settings or ‘values’. 
The values stored with an object 
become its ‘properties’. All objects 
have certain properties in common 
such as size and position. There are 
other, more specific properties of 
objects which depend on the object 
type. The most important property 
of all embroidery objects is stitch 
type.
Object recognition:  See Outline 
recognition.
Object type:  An object has a type, 
shape, thread type and color, 
stitching settings and a position in 
the stitching order. The object type 
may or may not determine the 
intended final appearance of the 
stitching.
Offset Object:  Software function 
used to create new outlines from 
the outlines of selected objects.
Ornament:  A grouped embroidery 
design which may consist of one or 
more objects of any type and one or 
more colors. Ornaments may be 
placed in up to eight positions 
around letters, or centered behind 
letters.
Options:  Options provide software 
with extra functionality that can be 

purchased by registered owners of 
the product.
Outline file:  See Design file.
Outline recognition:  When you 
convert a machine file to outline 
format, EmbroideryStudio reads 
the data stitch-by-stitch according 
to the needle penetration points. 
The software then ‘recognizes’ 
stitch types, spacing and length 
values, stitch effects, and can 
determine object outlines.
Outline stitch:  Stitch such as Run 
or Satin used to outline an 
embroidery object.
Overall embroidery:  Overall 
embroidery is embroidery which 
covers the entire fabric. This 
includes lacework where the 
backing fabric is actually removed 
after manufacture. Overall 
embroidery is typical of Schiffli 
manufacture, less common with 
Multihead.
Overshoot:  Overshooting is a 
technique used by Schiffli punchers 
to reduce distortion of fabric by 
pulling more thread from the cone 
and reducing the pulling force of the 
thread.
Overview window:  Use the 
Overview window to view a 
thumbnail of the design. The 
window is updated whenever you 
make a change, and can be used to 
zoom in or pan across the design 
window. 
Paint package:  Software 
application that creates or allows 
you to edit image files. You can 
create lines and filled areas as well 
as edit the image pixel-by-pixel 
using paintbrushes, erasers and 
spraypaint tools. Examples of 
image editing programs are Adobe 
Photoshop, Jasc PaintShop Pro and 
Corel PHOTO-PAINT®. See also 
Graphics application.
Pan:  Use Pan to view parts of a 
design which are not currently 
visible in the design window. 
Paper tape:  Traditional recording 
media used in the embroidery 
industry is the paper tape. The tape 
coding process produces the final 
design in stitch format – a 
stitch-by-stitch interpretation of the 
design – exactly as the embroidery 
machine will read it. Now largely 
replaced by floppy disk, tapes are 
still used by older machines. More 
specifically, stitch data paper tapes 
are eight-channel paper tapes 
which, in effect, are hard copies of 
8 bit binary code.
Parallel port:  A connection on a 
computer, usually LPT1, where you 
plug in the cable for a parallel 
printer and/or a dongle. Parallel 

ports are used to connect some 
embroidery machines. They are 
named LPT1, LPT2, etc. When you 
set up a parallel machine 
connection, select the parallel port 
and the required protocol, and 
complete the machine setup 
procedure.
Partial appliqué:  Technique to 
create appliqué objects with partial 
cover stitching to create an 
overlapping effect without 
doubling-up borders.
Partition lines:  Partition Lines is a 
method for offsetting needle 
penetrations in Tatami fills, used, 
like Tatami Offset Fractions, to 
create needle penetration patterns 
or textures in stitched embroidery.
Paste:  To insert an object, which 
has previously been placed on the 
clipboard by cutting or copying 
selected objects, into a design. You 
can paste from the clipboard as 
many times as you like.
PAT:  PAT is a Saurer SHC file type.
Patch:  The fabric piece use in 
appliqué.
Pattern:  The design, card, 
punching, tape, disc, or 
enlargement.
PCH:  Gunold design or ‘outline’ file 
format.
PCX:  PC Paintbrush bitmap image 
format.
PDF:  Portable Document Format. 
Used to view the Online Manual in 
Acrobat Reader.
Patchwork:  The composite of 
pieces sewn together to form a 
large piece, such as a quilt.
Patchwork block:  A collection of 
patches sewn together, usually 
forming a regular shape such as a 
rectangle. These are then sewn 
together to make a quilt.
Pattern Arrangement (ABC):  Some 
Schiffli embroidery machines can 
read designs in which repeated 
parts are stored only once in the 
design file and only the repeat 
instructions are given to the 
machine. EmbroideryStudio 
provides tools to define pattern 
arrangements and output to 
specific formats which support the 
feature.
Pattern outline:  See Motif Run.
Pause function:  The Pause function 
is a conditional Stop, always on an 
empty stitch. It is interpreted by 
the machine according to the 
machine operator preferences.
PEN:  PEN is a Saurer Pentamat 
Station file type. (Not supported in 
Schiffli e3.0.)
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Pencil rub:  Low-cost way of 
producing an embroidery design 
sample. Consists literally of a piece 
of tracing paper placed over a 
stitchout and rubbed lightly with a 
pencil to produce an impression of 
the embroidery.
Penetrations:  The Needle In and 
Needle Out functions instruct the 
machine whether or not to use 
needle penetrations. You can enter 
these functions automatically using 
the Penetrations tool.
Pentamat:  An advanced Schiffli 
individual needle and borer 
switching system available on 
Saurer and Laesser Machines.
Peripheral:  Any device connected 
to a computer which is to some 
degree controlled by the computer 
– e.g. an embroidery machine or 
printer.
Physical machine functions:  When 
outputting designs, Schiffli 
translates design data into stitches 
and machine functions that the 
target machine will understand. The 
functions that the machine 
understands are called ‘physical’ 
machine functions.
Piecing:  The business of sewing 
patches together into patchwork 
blocks.
Pixel:  A dot. For example, dots of 
light that make up the image on a 
computer screen. The more pixels 
in a given area – that is, the smaller 
and closer together they are – the 
higher the resolution.
Pixelation:  An effect which occurs 
when a bitmap image is enlarged so 
that the individual pixels are 
obvious to the eye.
Placement lines:  See Guide 
runs.
Plauen:  Plauen is the area in 
Germany where Schiffli machines 
originated. It now identifies a type 
of Schiffli machine and Jacquard 
punched card encoding. It is also 
known by the names of other 
manufacturers such as Hiraoka, 
Comerio, Zangs, etc, who copied 
and modified the original design. 
The Plauen machine requires the 
hook to be held in the right hand for 
threading.
PLS:  PLS is a Saurer SLC file type.
PMU:  PMU is a Proel stitch or 
‘expanded’ file format.
PNG:  Portable Network Graphics 
vector graphic format.
PNN:  PNN is a Plot file used in 
SPES. (Not supported in Schiffli 
e3.0.)
Pointer:  A part of the screen 
display, the pointer can take various 

shapes. It is moved by moving the 
mouse and can be used to point to 
anything on the screen to make 
selections and indicate points for 
input. It also indicates when the 
computer is working and no input is 
possible.
Point:  Unit of measurement, with 
10 points equal to 1 mm.
Port:  A connection on a computer 
where you plug in the cable that 
carries data to another device. 
Ports which are used to attach 
peripherals have names like COM1 
or LPT1 so that you can specify 
where the peripherals are attached.
Position:  The Position indicator 
shows position of the design (X, Y) 
in the design window.
Print preview:  Use to preview 
design and design information 
before printing a Production 
Worksheet. The design is displayed 
as it will be printed.
Process:  The Process feature lets 
you adjust the density of one or 
more stitch types across the whole 
or selected parts of a design. 
Change stitch density in order to 
stitch on a different fabric or with a 
different thread. Alternatively, you 
may want to make production 
cheaper by reducing the overall 
stitch count. Processing a machine 
file is similar to converting it to a 
design file when opening except 
that you can process only selected 
objects or stitches. 
Processed stitches:  Designs read 
from stitch or ‘expanded’ files 
where stitches have been 
regenerated by processing.
Production worksheet:  The 
production worksheet is the link 
between the designer and the 
embroidery machine operator. It 
contains a design preview as well as 
essential production information, 
including the design size, the color 
sequence and any special 
instructions.
Program:  A computer program or 
‘application’ is generally used for a 
particular kind of work, such as 
word processing or database 
management.
Program split:  A decorative fill 
stitch which can be applied to 
various object types where needle 
penetrations form a tiled pattern. 
Different preset patterns are 
available for use.
Properties:  See Object 
properties.
Protocol:  The communications 
protocol depends on the connection 
type between the computer and the 
embroidery machine. This will be 
one of: standard serial, parallel, 

serial to parallel converted (DCi), or 
interface card.
PS:  Postscript vector format.
Puck:  See Digitizing puck.
Puckering:  Result of the fabric 
being gathered by the stitches. 
Many possible causes include 
incorrect density, loose hooping, 
lack of backing, incorrect tension or 
dull needle.
Pull compensation:  Digitizing 
technique that takes into account 
the distortion of a design that will 
occur because of the interaction of 
thread with fabric. ‘Push and pull’ 
will cause a circle digitized perfectly 
round to sew with the sides pushed 
out, resulting in an egg shape. 
Generally, it is necessary to extend 
horizontal elements and reduce 
vertical elements. See also 
Automatic pull compensation.
Punching:  Conversion of artwork 
into a series of commands to be 
read by an embroidery machine’s 
computer or controller. The term 
refers to an earlier method of 
machine embroidery whereby 
designs are ‘punched’ to paper 
tape. A part of the machine, called 
an automat, reads the paper tape 
or Jacquards punched with holes 
representing stitches, pantograph 
movements and other commands. 
While still capable of producing 
paper tape, many digitizing 
systems now store this information 
on disk formats. See also 
Digitizing.
Push-pull:  When any stitch is sewn 
into fabric, the tension in the thread 
between needle penetrations can 
build up and result in a ‘push-pull’ 
effect. This can cause distortions in 
your sewn designs, poor stitch 
registration and even the bunching 
of the fabric. The degree of 
distortion can be affected by the 
following factors: stitch density, 
fabric type, underlay, backing type, 
thread type and garment 
orientation. See also Stitch-Pull.
Quilting:  In general, the process of 
making a quilt; in specific, the 
stitching of patterns into the quilt 
layers to add strength and 
decoration to the quilt - top, batting 
and backing -- to form decorative 
patterns on the surface of the quilt 
and to hold the layers together. 
RAM:  Random Access Memory, 
computer chip maintaining 
memory.
Random factor:  You can eliminate 
unwanted patterns and distribute 
stitches evenly within a shape using 
a random factor. Apply random 
factors to Tatami Partition lines or 
Program Splits. You can use this 
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effect to imitate different textures 
such as fur, grass, leaves, etc.
Raster image:  See Bitmap image.
Read:  To open a design which has 
been written on a design card or to 
an embroidery machine.
Reader/writer:  A device that allows 
you to download/upload designs to 
and from a design card. Cards can 
be purchased from your dealer or 
from designers on the net. Cards 
can have designs on them or are 
blank for you to read/write from/to. 
The cards are inserted into the 
embroidery module attached to a 
sewing machine. The R/W will allow 
you to have the PC and sewing 
machine quite separate from one 
another.
Recognition:  See Outline 
recognition.
Redraw:  The screen display is 
refreshed. This is useful when parts 
of the display have become 
obscured in the course of editing. 
See also Slow Redraw.
Reduce colors:  See Image 
preparation.
Reference point:  A point that can 
be aligned with the grid. For 
example, you can set the grid 
reference point to the design 
center. This is easier and faster than 
moving the whole design. 
Refresh:  See Redraw.
Registration:  Correct registration is 
achieved when all stitches and 
design elements line up correctly.
Relative Pointer Setting:  This 
setting shows the pointer position 
as an absolute value from the first 
needle point of the design. Useful 
for checking that the design fits a 
given area.
Relative:  The distance the pointer 
is from a previously marked point, 
or from the previous stitch point.
Repeat:  Layout used for making 
emblems or designs on a fabric 
span that are repeated at regular 
intervals. The design repeat is 
defined by the distance between 
needles – the point at which the 
design repeats itself.
Repeat color change (RCC):  A 
Repeat Color Change (RCC) is a 
mechanism on some Schiffli 
machines to change the pattern of 
active needles in order to modify 
the repeat pattern and/or thread 
color.
Repeat sequence:  If you select 
fewer colors than the design 
requires, the selected colors are 
repeated. For example, if your 
design requires four colors and 
you’ve only selected two in the 

Building Stop Sequence list, colors 
3 and 4 will be the same as original 
colors 1 and 2.
Resequence:  You can change the 
position of a selected object by 
cutting it, then pasting it 
somewhere else in the stitching 
sequence, or by using the 
Resequence command. You can 
also resequence objects by color or 
using the Color-Object List. 
Resizing:   See Scaling.
Resolution:  Resolution determines 
the number of dots per inch (dpi) 
used to create an image. The higher 
the value, the clearer the image, 
but the more storage space 
required. A resolution of 75 dpi 
generally produces good results.
RGB:  RGB stands for red, green, 
and blue. It is the system used by 
computer monitors to create color.
Rhinestones:  See Bling.
Rhinestone template:  This is the 
design layout on which rhinestones 
are initially placed for creation of a 
‘rhinestone transfer’. This is what is 
created from the cutters or 
engravers.
Rhinestone transfer:  This is the 
rhinestone design ready for heat 
transfer to the final product – e.g. a 
T-shirt.
RPM functions:  RPM +/- functions 
instruct the machine to increase or 
decrease machine speed in 
increments from current or normal.
Right-click:  To press and release 
the right mouse button. See also 
Click.
Rollover:  The point at which the 
fabric is shifted – loosened and 
reset – vertically to continue 
stitching. Common on long fabric 
Schiffli machines.
Rotation handles:  When you select 
an object, selection handles display 
at its extremities. If you click the 
object again, rotation and skew 
handles appear around the object. 
Rotation handles appear at the 
corners of the object and an anchor 
point displays at the object’s center. 
Skew handles are diamond-shaped 
and appear at the center-top and 
bottom of the object. See also 
Selection handles.
Run stitch:  Run stitch, also known 
as ‘Walk stitch’, places a single row 
of stitches along a digitized line. 
The needle penetrations are placed 
in consecutive order. Run is 
generally used for stitching outlines 
and connector stitches. Run stitch 
length can be set to automatically 
vary in order to follow tight curves.

SAS:  SAS is a Saurer SLC, Saurer 
SLC RCC, Saurer SLC Standard or 
Saurer Pentamat file format.
Sash:  A fabric strip that separates 
blocks in a setting, framing them 
and making the quilt larger.
Satin stitch:  Type of fill stitch. 
Formed by closely arranged zigzag 
stitches, it can be stitched at any 
angle and with varying lengths. The 
thread is laid across a shape with a 
zigzag sewing action where two 
stitches form a column. Hence it is 
only suitable for small or narrow 
shapes. As the stitches are almost 
parallel, Satin provides good 
coverage. It is often used for 
lettering, outlining, and details. 
Because there are generally no 
needle penetrations breaking up 
the fill, Satin stitch creates a glossy 
effect.
Saurer:  Saurer is a Schiffli machine 
brand and type as well as a 
Jacquard card encoding format. The 
format has three variants with 
support added for more modern 
RCC and Pentamat machines. 
Sometimes it is referred to as the 
‘left hand machine’ because the 
threading requires the hook to be 
held in the left hand.
Saurer SHC:  SHC is a high level 
code format which is designed to be 
machine independent in order to 
control both Saurer and Plauen type 
mechanisms. The format supports 
thread trimming.
Saurer SLC:  SLC is a Saurer low 
level code format for Schiffli 
designs.
Save:  To store (design) information 
in a file. Each time you save a 
design, you replace the previous 
version using the filename. You 
should save your design frequently.
Scalability:  Ability to enlarge or 
reduce a design. In expanded 
format, most scaling is limited to 10 
to 20%, because the stitch count 
remains constant despite final 
design size. In condensed formats, 
on the other hand, scale changes 
may be more dramatic, because 
stitch count and density may be 
varied.
Scale factor:  This option allows you 
to automatically scale CND designs 
as you load them. For example, to 
scale the imported design to 120% 
of the original, you would enter a 
scale factor of 1.2.
Scaling:  Ability to enlarge or 
reduce a design in size. In stitch or 
‘expanded’ format, most scaling is 
limited to ±5% because the stitch 
count remains constant despite 
final design size. In design or 
‘outline’ formats, scale changes 
may be more dramatic because 
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stitch count and density are 
recalculated.
Scanner:  A device that converts 
physical images into digital form so 
that they can be stored and 
manipulated by computer. Scanning 
allows you to take scanned images 
as a basis for embroidery design.
Scanning resolution:  Most 
scanners require you to enter 
scanning resolution information. 
Resolution determines the number 
of dots per inch (dpi) used to create 
a drawing. The higher the value, the 
clearer the image but larger the file. 
For digitizing purposes, use a 
maximum resolution of 300 dpi 
(dots per inch). A resolution of 72 
dpi (screen resolution) will usually 
be sufficient. Generally speaking, 
the smaller the source image 
and/or more detail it contains, the 
higher the resolution needs to be.
Schiffli card:  Plauen or Saurer type 
Jacquard card.
Schiffli card image:  Jacquard card 
electronic encoding produces a 
‘tape file’ which is essentially an 
electronic ‘image’ of the card. 
Schiffli outputs two tape file 
formats – T10 (for Plauen) and T15 
(for Saurer). See also Tape code.
Schiffli disk:  Schiffli disks include 
Saurer SLC/SHC, Heinzle, Hiraoka, 
and Laesser.
Schiffli machine:  Commercial 
embroidery machine that utilizes 
the combination of needle and 
shuttle to form a stitch. Massive in 
size. Some schiffli machines – also 
known as looms – weigh 10 tons 
and have up to 1024 needles. Most 
Schiffli machines do not have 
automatic thread trim or automatic 
color change. Excellent for emblem 
production, the creation of lace, 
embroidery production on oversized 
items and production orders of very 
large quantities.
Screen calibration:  You need to 
calibrate your monitor so that 
designs at 1:1 scale appear at real 
size. Do this when you first install 
EmbroideryStudio, whenever you 
change your monitor, or adjust your 
monitor’s horizontal or vertical 
controls.
Screen printing:  Screen printing is 
a more complex process than 
direct-to-garment, requiring the 
creation of a screen for each of the 
spot colors (Pantone) that make up 
the design. There may be multiple 
screens for each spot color, 
depending on how the design is 
layered. See also Direct-to-garment 
printing.
Screen resolution:  See Pixels.

Scroll bar:  The bar at the bottom 
and right edge of a window whose 
contents are not entirely visible. 
Each scroll bar contains a small box, 
called a scroll box, and two scroll 
arrows to allow different types of 
scrolling.
Security code:  Options in 
EmbroideryStudio are controlled by 
a security device installed on the 
computer. Security access codes 
entered into the software are sent 
to this security device. Each 
security device has a unique serial 
number and identity code.
Security device:  See Dongle.
Segments:  Filled embroidery 
objects are generally built as 
several discrete ‘segments’. Travel 
runs are typically used to connect 
them. All segments, however, form 
part of the same object. Where they 
meet, the push-pull effect on the 
fabric during stitchout may cause 
gaps to appear.
Select:  To highlight an object or 
group of objects for the purpose of 
editing. Only selected items can be 
edited.
Selection handles:  Eight small 
squares that appear symmetrically 
at the corners and edges of a 
selected object. Use them to 
position and resize objects. See 
also Rotation handles.
Selection marquee:  The dotted 
rectangle that appears when you 
select a range of items. See also 
Bounding box.
Sequence:  See Stitching 
Sequence.
Sequins:  Sequins are small plastic 
disks with a hole usually in the 
center. They are stored on reels 
joined one-to-another by a weak 
link. They are stitched onto fabric 
by mechanical placement in the 
path of the sewing needle.
Sequin attachment:  Sequin 
attachments are computerized or 
manual machine devices which 
apply sequins by stitching, glue or 
heat.
Sequin mode:  Sequin mode 
enables quick digitizing of Drop 
Sequin functions. See also Drop 
Sequin functions.
Serial port:  A connection point on a 
computer where you plug a serial 
communications device such as a 
modem. PC serial COM ports are 
male connectors, and can be either 
9-pin or 25-pin. They are named 
COM1, COM2, COM3, etc. The 
number of available ports limits the 
number of devices you can connect. 
If additional ports are required, you 
can add them. Multi-port serial 
cards can also be used.

Serial port setup:  Here you can 
adjust Baud, Data Bits, Stop Bits, 
Parity values. These settings must 
be identical to those of the 
embroidery machine. The type of 
handshaking must match the type 
of cable you are using.
Serif:  In typography, serifs are 
semi-structural elements on the 
ends of strokes that make up letters 
and symbols. A typeface that has 
serifs is called a serif typeface. A 
typeface without serifs is called 
sans-serif.
Sharpen edges:  Tool used to 
prepare outlined images for 
automatic digitizing. Sharpen 
Edges automatically sharpens 
outlines and reduces noise. Areas 
enclosed by a black outline are 
reduced to a single color. Outline 
sharpening makes it easier for the 
software to recognize distinct areas 
in the artwork. These areas then 
become the embroidery objects of 
the finished design. Use it 
particularly if the outlines are 
blurry, fuzzy or indistinct.
Short stitch:  Digitizing technique 
that places shorter stitches in 
curves and corners to avoid an 
unnecessarily bulky build-up of 
stitches.
Shortcut key:  A key stroke or a 
series of keystrokes you can use to 
perform a task instead of using the 
mouse. For example, Ctrl+C actions 
the Copy command.
Side movement:  The distance the 
frame can move horizontally on a 
Schiffli machine, measured in 
quarters.
Side stick:  Adjustable bars with 
pins on each end of the Schiffli 
frame to hang or pin the ends of the 
goods being spanned.
Sizing handles:  See Selection 
handles.
Skew handles:  See Rotation 
handles.
Slow Redraw:  Use to redraw your 
design slowly. Slow Redraw lets you 
view the stitching and color 
sequence of a design in slow 
motion.
Small stitches:  Use the Small Stitch 
Filter to remove unwanted small 
stitches from a design 
automatically.
Smart corners:  Sharp points in a 
shape may cause a bunching of 
stitches and needle penetrations 
which can create a hard spot in the 
embroidery and may damage the 
fabric or needle. Smart Corners 
helps you control sharp corners in 
Column A and Column C objects. 
See also Mitre Corner and Cap 
Corner.
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Smart design:  Toolset used to 
create embroidery designs by 
automatically digitizing electronic 
images. Smart Design 
automatically converts bitmap 
images to fully digitized embroidery 
with little or no intervention. See 
also Auto-Digitizing.
Software:  Programs, such as 
MS Windows® and 
EmbroideryStudio, which run your 
computer.
Span:  The prepared goods ready to 
load the Schiffli machine. It may 
contain many yards of goods.
Span cloth:  Fabric attached 
permanently to the roller of the 
Schiffli machine with pins onto 
which the fabrics are attached.
Spangles:  See Sequins.
Spanning:  The loading of the goods 
on the frame, placing it under 
tension preparatory for embroidery.
Specialty fill:  A fill stitch capability 
that produces a fill with a ‘relief’ or 
motif design within the fill-stitch 
area, e.g. Pattern Fill.
Specialty threads:  Threads 
designed for effects such as shine, 
glitter, iridescence or thickness. The 
threads often are made from 
synthetic materials including rayon, 
mercerized cotton, metallics and 
textured nylon.
Spiral contour:  Spiral Contour 
creates a single, continuous line of 
stitching that spirals around to fill 
the shape. Typically, it is used for 
rings and borders, but it is also 
suitable for other closed shapes. 
See also Contour stitch.
Split alternate:  Split Alternate is a 
variation of Tatami split. See also 
User Defined Split.
Split object:  You can split 
embroidery objects that were 
created with the Column A, 
Column B, and Column C tools, if 
Satin or Tatami, or Program Split is 
the selected stitch type.
SPI:  Stitches per inch; system for 
measuring density or the number of 
Satin stitches in an inch of 
embroidery.
SPM:  Stitches per minute; system 
for measuring the running speed of 
an embroidery machine.
SR/SD:  Melco Star format. ‘Star’ 
and ‘Superstar’ are types of Melco 
machine (quite old now).
Stabilizer:  See Backing.
Standard backstitch:  The rows are 
approximately parallel, with every 
backstitch row slightly shorter than 
the forward row. Because the rows 
are different lengths, there are 
fewer small stitches at the edge of 

the shape, reducing possible 
damage to the fabric. Standard 
backstitch is suitable for high 
density fills. See also Backstitch.
Standard Contour:  Standard 
Contour creates rows of stitches 
across the shape, perpendicular to 
the digitized stitch angle. The 
number of stitch lines is constant, 
so the stitching is denser where the 
shape is narrower, and more open 
where the shape is wider. See also 
Contour stitch.
Start/End Boring Tension 
functions:  See Boring Tension 
functions.
Station:  See Repeat Color 
Change (RCC).
Status bar:  Provides information 
about the whole design: number of 
stitches, position of the design (X, 
Y), number of colors (C), number of 
stops (S), etc.
STC:  Gunold stitch or ‘expanded’ 
file format.
Stemstitch:  A detail stitch that can 
be used to outline items or fill in 
areas. It is used for stems and vines 
with other decorative stitches, or as 
an outline for Satin or Motif fills.
Step stitch:  Series of parallel 
stitches commonly used to cover 
large areas. Different step patterns 
can be created by altering the 
angle, the length and repeat 
sequence of the stitches.
Stippling:  A method of creating a 
fill made of run stitches which 
meander around within a border. 
Often used in quilting.
Stitch:  A stitch is one needle 
penetration; also used to refer to 
the thread laid down from one 
needle penetration to the next.
Stitch angle:  The stitch angle is the 
angle the overall stitching follows 
within a shape. The shape may 
have a fixed stitch angle – e.g. 45° 
to the horizontal – or multiple stitch 
angles.
Stitch bunching:  Standard stitch 
spacing is calculated at the outside 
edge of a shape. With sharp curves, 
spacing which provides adequate 
coverage on the outside edge may 
cause bunching along the inside 
edge. This may cause thread 
breakage when stitching out.
Stitch count:  Stitch count refers to 
the number of stitches in a design. 
In EmbroideryStudio one stitch is 
considered one machine revolution. 
See also Design properties.
Stitch density:  The number of 
stitches per given area (or stitch 
lines per distance in a fill).

Stitch editing:  Digitizing feature 
that allows one or more stitches in 
a pattern to be deleted or altered.
Stitch file:  See Machine file.
Stitch length:  The distance 
between two needle penetration 
points. For maximum stitch length, 
the length is measured according to 
the X and Y co-ordinates, whichever 
is greater. Run stitch length can be 
set to automatically vary in order to 
follow tight curves. See also 
Max/Min stitch length.
Stitch List:  The Stitch List displays 
stitch number, stitch coordinates, 
stitch length, stitch function, stitch 
color. When you select a stitch in 
the list, it is simultaneously 
selected in your design. 
Stitch processing:  The calculation 
of stitch information by means of 
specialized software, allowing 
scaling of expanded format designs 
with density compensation.
Stitch processor:  A patented 
software feature developed by 
Wilcom International P/L. Stitch 
Processor is a function of the 
software which interprets ‘raw’ 
stitch data and converts it into 
objects that the software can 
recognize.
Stitch-pull:  See Push-Pull.
Stitch type:  Three basic stitch 
types are available with lockstitch 
machines – Run, Satin and Tatami 
(Weave). EmbroideryStudio 
provides many variants of these.
Stitch shortening:  When a shape 
takes a sharp turn, the spacing of 
stitches on the inside of the shape 
decreases rapidly. This results in 
bunching on the inside and gaps on 
the outside of the shape; the longer 
the stitch, the worse the problem. 
Automatic Stitch Shortening solves 
this problem by eliminating thread 
bunching. The embroidery has 
smooth, even stitch spacing 
throughout. It also reduces thread 
breakages during production.
Stitch spacing:  Spacing between 
two consecutive needle 
penetrations on the same side of a 
column. The smaller the value, the 
greater the stitch density. For more 
open stitching, use larger values.
Stitching defects:  Stitching defects 
may appear in the form of gaps 
between filled areas, fabric 
show-through and thread breaks. 
These are often caused by incorrect 
stitching settings – e.g. setting pull 
compensation too small for the 
fabric stretchiness.
Stitch-to-machine:  The software 
lets you send a design directly to 
the embroidery machine for 
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stitching if it is connected to your 
computer.
Stitching direction:  Stitching 
direction can affect embroidery 
quality because of the Push-Pull 
effect. Only closed embroidery 
objects can be reversed.
Stitching sequence:  The 
embroidery objects in a design form 
a stitching sequence. Initially, 
objects are stitched in the order in 
which they were created or the 
design assembled. You can change 
the position of a selected object by 
cutting it, then pasting it 
somewhere else in the sequence, or 
by using the Resequence command. 
You can also resequence objects by 
color or with the Color-Object List.
Stock designs:  Embroidery designs 
readily available on disk or 
proprietary embroidery card. 
Digitized embroidery designs that 
are commercially available for 
general use by embroiderers.
Stop code:  Stop codes are 
interpreted as ‘explicit stops’. The 
machine stops stitching.
Stop function:  If you want the 
embroidery machine to stop for any 
special reason while stitching a 
design, you need to insert a Stop 
function in the stitching sequence. 
If there are Stops in a design, these 
can be read into EmbroideryStudio 
as either a Color-change function or 
a Stop function.
Straight stitch machine:  Machine, 
which features needles that move 
up and down in one spot. The 
pantograph pushes the design 
along. The majority of commercial 
embroidery machines use this type 
of needle movement.
STX:  Datastitch stitch or 
‘expanded’ file format.
Stuepfel:  Stuepfel is a Schiffli 
machine attachment for cleaning 
out holes after boring.
Stuepfel functions:  Stuepfel In/Out 
functions instruct the machine 
when to switch to the Stuepfel 
device from the borer. Borer In 
engages both the borer and the 
Stuepfel.
Styles:  A style is a group of 
property settings stored under a 
unique name. You can save any 
combination of settings to a style. 
This makes it easy to apply these 
settings to selected embroidery and 
lettering objects. When you apply a 
style to an object, the style settings 
replace its current properties. Any 
properties not specified in the style, 
retain their current settings.
Sublimation:  Sublimation means a 
change from a solid to gaseous 
state and back to a solid without 

becoming liquid. Thus dye particles 
migrate from the paper as a gas, to 
bond with a polymer – fabric or 
other material – and become solid 
again. The transfer is effected using 
high heat (205°C) and pressure, 
thus guaranteeing that the image 
penetrates and becomes an integral 
part of the substrate.
Sublimation printing:  Sublimation 
is similar to DTG printing but the 
process uses solid inks which give a 
more even gradation of color rather 
than the liquid inks in DTG printing. 
With sublimation printing, inks are 
printed onto a release paper and 
then transferred onto a fabric or 
other surface.
Supported machine type:  A 
machine is ‘supported’ by the 
software either via a direct 
implementation in the software for 
a specific machine or via the 
MS Windows® operating system – 
e.g. a MS Windows® supported 
printer or MS Windows® supported 
cutter.
Swiss embroidery:  Satin stitch 
embroidery. Also recalls the origins 
of automated embroidery in 
Switzerland, where the Schiffli 
embroidery machine was developed 
in the 1800s by Isaak Groebli. 
Embroidery remains a 
government-supported industry in 
Switzerland today.
System administrator:  The System 
Administrator is responsible for the 
entire Enterprise Network and 
security. In smaller enterprises, the 
System Administrator is also 
usually responsible for database 
administrations.
System requirements:  What your 
computer’s hardware and software, 
operating together, can support. 
System requirements are printed 
on software packages, design disk 
cards and packs, CDs and other 
computer accessories. You need to 
know what your system can and 
cannot support, as sometimes a 
system is not capable of handling 
new software without adding 
memory or disk space. 
T03:  T03 is an old paper tape 
version of Barudan file.
T10:  T10 is a Wilcom Plauen Schiffli 
format used to punch cards or as 
input to Electrocard or converted to 
floppy disk formats. 
T11:  T11 is a Wilcom Plauen RCC 
Zangs Schiffli format.
T12:  T12 is a Wilcom Plauen - RCC 
Hiraoka Schiffli format.
T13:  T13 is a Wilcom Plauen - RCC 
Comerio Schiffli format.
T15:  T15 is a Wilcom Saurer Schiffli 
format used to punch cards or as 

input to Electrocard or converted to 
floppy disk formats. 
T16:  T16 is a Saurer B Schiffli 
format.
T18:  T18 is a Wilcom Saurer RCC 
Schiffli format.
T19:  T19 is a Wilcom Saurer B - 
RCC Schiffli format.
T20:  T20 is a Wilcom Saurer 
Pentamat Schiffli format.
T21:  T21 is a Wilcom Saurer B 
Pentamat Schiffli format.
T22:  T22 is a Wilcom Plauen 
Pentamat Schiffli format.
Tablet:  See Digitizing tablet.
Tackdown:  Zigzag stitch, placed 
after placement and cutting lines, 
and used to fix appliqué patches to 
the background fabric before cover 
stitching is applied.
Tape:  See Paper tape.
Tape code:  More recently, the 
recording media used in the 
embroidery industry has been the 
paper tape. Jacquard card 
electronic encoding produces a 
‘tape file’ which is essentially an 
electronic ‘image’ of the card. 
Schiffli outputs two tape file 
formats – T10 (for Plauen) and T15 
(for Saurer). As the newer Schiffli 
machines can read floppy disks, 
there are various Schiffli machine 
floppy disk formats. You therefore 
need to convert the basic tape file 
to the required disk format.
Tatami stitch:  Series of run 
stitches, commonly used to cover 
large, irregular shapes. Stitches are 
laid in rows traversing back and 
forth across the shape. These can 
be parallel or slightly turning. 
Different fill patterns can be created 
by varying the stitch length, angle 
or sequence. Also known as Weave 
stitch.
Tatami offset fractions:  With 
Tatami fills you can specify how 
each row is offset in order to create 
patterns formed by needle 
penetrations. You do this by 
adjusting either offset fractions or 
partition lines. By adjusting offset 
fractions, you can create textured 
fills where the stitch penetrations 
are more clearly visible. 
Tatami partition lines:  With Tatami 
fills you can specify how each row is 
offset in order to create patterns 
formed by needle penetrations. 
Partition lines, with up to eight 
offsets, can create more patterns. 
Tatami underlay:  Tatami underlay 
is used to stabilize large, filled 
shapes. It resembles an extremely 
open Tatami fill stitch, where rows 
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of stitches are placed across the 
object to create the underlay.
Team Names:  The Team Names 
feature lets you create designs with 
multiple names. For example, you 
can use the same logo with 
different names for sports teams or 
corporate uniforms without having 
to create multiple copies of the 
same design. 
Templates:  Templates are special 
files used for storing styles and 
default property settings. The 
NORMAL template packaged with 
the software provides a selection of 
preset styles. You can modify these 
as required and save them back to 
the NORMAL template or to your 
own custom templates. Use these 
when digitizing frequently-used 
design types to save time 
re-adjusting the current property 
settings. For example, a custom 
template may include standard 
objects and sample lettering. It 
may simply have preferred stitch 
settings, lettering font and size, and 
colors set as current settings. Or it 
may have special density, pull 
compensation or underlay settings 
to suit different fabrics.
Tension:  Tautness of thread when 
forming stitches. Top thread 
tension, as well as bobbin thread 
tension, need to be correctly set. 
Proper thread tension is achieved 
when about one third of the thread 
showing on the underside of the 
fabric on a column stitch is bobbin 
thread.
Textured edge:  Use Textured Edge 
to create rough edges, to create 
shading effects, or to imitate fur or 
other fluffy textures in your design.
Thread:  Fine cord or natural or 
synthetic material made from two 
or more filaments twisted together 
and used for stitching. Machine 
embroidery threads come in rayon 
(high sheen), cotton (duller finish), 
polyester (strong and colorfast), 
metallics (synthetic core wrapped 
with metal foil or thin slivers of 
metal foil) and acrylic (sheen 
similar to rayon).
Thread Brake functions:  Thread 
Brake +/- functions instruct the 
machine when to increase or 
decrease tension one increment by 
Thread Brake.
Thread chart:  Thread charts are 
lists of predefined thread colors. 
They may be based on 
commercially available thread 
charts, or charts you define 
yourself. You can copy colors 
between different thread charts to 
create your own charts from 
existing colors. See also Color 
palette.

Thread code:  Code is the 
identification number of a thread 
color in a brand.
Thread roller functions:  Thread 
Roller +/- functions instruct the 
machine when to increase or 
decrease tension one increment by 
Thread Roller Feed (2S-55 RCC).
Thread cutting:  The removal of 
‘floats’, by hand or by machine.
Thread density:  Different thread 
density systems are used by 
different thread manufacturers. 
Density A is normal embroidery 
thread (density 120/2, or 40). 
Density B is thicker, Density C is 
finer, and Density D is very fine.
Thread thickness:  See Thread 
density.
Thread type:  Embroidery thread 
varies in thickness. Types are A, B, 
C and D. Stitch density should be 
set according to the thread type. 
See also Thread thickness.
Tie-ins:  Tie-in stitches are inserted 
at the start of objects to prevent 
stitches from unraveling. They are 
inserted inside the shape on the 
second stitch. You generally use 
them when the previous connector 
is trimmed.
Tie-offs:  Tie-offs are generally 
placed before trims to prevent 
stitches from unraveling. You can 
adjust connector settings to 
automatically add tie-offs under 
certain conditions, or add them 
manually. You can also include trim 
functions so machines with 
trimmers cut the thread 
automatically.
Title bar:  The horizontal bar 
located at the top of a window and 
containing the title of the window. 
On many windows, the title bar also 
contains the Control menu box and 
Maximize and Minimize buttons.
Toolbar:  Toolbars provide quick 
and easy access to 
EmbroideryStudio commands. Click 
a toolbar button to activate a 
command or, where applicable, 
right-click to view and adjust its 
settings.
Topping:  Material hooped or placed 
on top of fabrics that have definable 
nap or surface texture, such as 
corduroy and terry cloth, prior to 
embroidery. The topping compacts 
the wale or nap and holds the 
stitches above it. It includes a 
variety of substances, such as 
plastic wrap, water-soluble plastic 
‘foil’ and open-weave fabric that 
has been chemically treated to 
disintegrate with the application of 
heat. Also known as ‘facing’. See 
also Stabilizer.

Trapunto:  Trapunto is a general 
term for very open fill stitching, 
often used as a background or for 
filling large shapes. In 
EmbroideryStudio, Trapunto effect 
forces travel runs to the edges of 
objects so they do not show 
through open or loose stitching.
Travel runs:  Travel runs are 
typically used to connect segments 
of complex shapes. They can also 
connect adjacent objects. Because 
runs are not trimmed, they may be 
visible in the final embroidery. For 
this reason, they are less commonly 
used as connectors between 
objects than jumps. If objects are 
adjacent and connectors will be 
hidden, they can be used.
Traveling:  You generally check a 
design’s stitching sequence by 
‘traveling’ through it by stitches, 
segments, functions or objects.
Trim function:  If you are using a 
machine with an automatic 
trimmer, the trim code causes the 
thread to be cut after a tie-off. In 
the software, trims are represented 
by a triangle with a small circle at 
the point where stitching starts 
again. The trimmed connector 
appears as a dotted line. You can 
adjust connector settings to 
automatically add trims, or add 
them yourself.
Trimmers:  Devices built into an 
embroidery machine to 
automatically trim or cut remaining 
thread when the design jumps from 
one area to another or performs a 
color change.
Trimming:  Action of cutting loose 
thread, removing backing, etc, 
from the final embroidered product.
Triple Run stitch:  Triple Run 
repeats each Run stitch three (or 
more) times for a thick line. 
Typically used to add borders and 
pickout runs to designs.
Triple Satin:  Triple Satin is often 
used for folk designs to mimic 
handmade embroidery that uses 
thicker thread. If you require 
thicker stitches, set the Satin stitch 
to repeat itself multiple times. 
TrueType font:  Digital font 
technology designed by Apple 
Computer and now used by both 
Apple and Microsoft in their 
operating systems.
TrueView™:  TrueView™ provides 
you with a preview of how your 
embroidery will look when stitched 
out. It gives the screen image a 
three dimensional look.
Turning stitches:  Embroidery 
objects can be filled with parallel or 
turning stitching. Turning stitches 
are columns of stitches which turn 
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to follow the path defined by the 
object outline. By contrast, parallel 
stitching traverses the shape in one 
direction only – e.g. at 90° to the 
horizontal, 45°, or whatever is set. 
Objects can be created with turning 
stitching already applying, or 
multiple stitch angles can be added 
later. Turning stitches are best used 
with designs containing 
complicated, turning shapes such 
as trees, animals, or large filled 
areas. Turns generally occur at 
points where a shape changes 
significantly in direction or width.
TWAIN:  Industry standard which 
allows devices (such as scanners) 
to communicate directly with 
design and layout programs. Both 
device and program must be 
TWAIN-compliant. This lets you use 
any TWAIN-compliant scanner with 
your software.
U??  Machine file format native to 
Barudan machines.
UDL file:  DesignWorkflow uses the 
Microsoft Data Link (UDL) format to 
link to its databases. UDL files are 
similar to MS Windows® shortcuts, 
but they contain more information 
about where the actual database 
and all of its attendant files are 
located. Copies of UDL files can be 
shared, renamed and relocated so 
that many people can use the 
information. In effect, every user 
with DesignWorkflow can have their 
own UDL link to the same database.
Underlay:  Stitches sewn before 
other design elements to help 
stabilize fabrics. The stitching 
action that will attach the backing 
to the fabric being embroidered. It 
also supports the top embroidery 
for a more lofty, dimensional look. 
Underlay stitches are made up of a 
series of single run stitches, usually 
with a very short stitch length, and 
are digitized manually or placed 
automatically under the column 
(satin) or fill stitch areas of your 
embroidery design.
Underlay margin:  The distance 
between an object outline and the 
edge of the underlay. Increase this 
margin to prevent underlay stitches 
from extending outside the cover 
stitches.
USB-capable embroidery machine:  
An embroidery machine which has a 
standard USB port built into the 
machine or machine control panel.
USB converter:  A device which 
converts a standard serial 
connection port to a USB type A 
connection.
USB memory stick:  Standard USB 
memory stick or simply ‘USB stick’ 
used for storing and transporting 
files.

USB port:  Universal Serial Bus 
Connector – a connection on a 
computer where you plug in the 
dongle. 
User-defined split:  User-defined 
splits add details to filled objects via 
digitized lines of needle 
penetrations called ‘split lines’. Split 
lines are stored as object 
properties. They are preserved 
when stitches are regenerated even 
if you apply a different stitch type.
Values:  The actual settings – 
letters and numbers – that you 
enter into dialogs. See also Object 
Properties.
Variable sizing:  Ability to scale a 
design to different sizes.
Variable stitch length:  The 
software can automatically 
calculate the best length for each 
stitch with the Variable Run Length 
option. A chord gap value controls 
how closely the stitches follow the 
digitized lines.
VDT:  VDT is a Hiraoka Schiffli 
format.
Vector graphic:  Unlike raster 
images, vector graphics contain 
vector data. This is a collection of 
geometric shapes and lines that 
combine to make an image. Rather 
than pixels, such data is recorded 
as a set of mathematical formulas 
defining shapes such as rectangles, 
ellipses, curves, polygon stars, etc. 
These are created using vector 
graphics programs such as 
CorelDRAW® Graphics Suite. 
Vector graphics are scalable without 
distortion, and are usually much 
smaller than bitmap images. See 
also Bitmap image.
Vector object:  Vector objects are 
derived from vector graphics and 
can be created in EmbroideryStudio 
or imported. In EmbroideryStudio 
they can be converted to and from 
embroidery objects. You can set 
general properties such as size and 
position, and arrange and 
transform them in the same way as 
other objects. See also Vector 
graphics.
Vector text:  A text object created 
using the CorelDRAW® 
Graphics Suite Text tool.
VEP:  Hiraoka VEP file format is 
used extensively for Pattern 
Arrangements (ABC) on existing 
machines. VEP uses a small 
arrangement file which splits the 
different design parts – A is one file, 
B is a second file, C is a third file.
Watcher:  The operator of the 
Schiffli machine who sets the 
pattern, twists the yarns, maintains 
the shuttles, loads and unloads the 
machines, performs the rollovers 

and watches for thread and needle 
breakage. The machine operator.
Wave Effect:  With Wave Effect you 
can curve Closed Fill stitches along 
a digitized line to create flowing 
stitch effects. The stitches follow 
the digitized line but maintain 
uniform density and needle 
penetration patterns.
Weave stitch:  See Tatami stitch.
WECS:  WECS (Wilcom ElectroCard 
System) eliminates the need for 
Jacquard cards. WECS reads 
Wilcom machine files T10 and T15 
and runs the Schiffli Automat 
directly. You therefore only need to 
save the design as a machine file to 
floppy disk.
Weight:  When referring to T-shirts, 
the three standard weight divisions 
are mid-weight/value, 
heavyweight/premium, and super 
heavyweight.
WESS:  WESS (Wilcom Electronic 
Servo System) replaces the Schiffli 
Automat and controls the frame 
movements directly by servo 
motors. It requires Wilcom ESS, 
Hiraoka DAT, Saurer SAS, T10 or 
T15 files on floppy disk as input and 
its method of operation is similar to 
WECS.
WiFi device:  Device capable of 
connecting to a WiFi Router or 
wireless access point.
WiFi network name (SSID):  Service 
Set Identifier (SSID) – the unique 
identifier attached to the 
information which is sent over a 
wireless local area network.
WiFi password (key):  Password, 
passphrase or key (depending on 
the WiFi security type) that allows 
connection to the WiFi router or 
access point.
WiFi router:  Device that provides 
basic network infrastructure for a 
home or small office network. 
Provides a wireless access point for 
many wireless devices to connect to 
each other for access to the 
Internet as well as for file sharing 
and printing. Sometimes referred to 
simply as a Wireless Router.
WiFi USB machine network:  A 
network of wirelessly connected, 
USB enabled embroidery machines 
and PCs.
WiFi USB Stick:  Wilcom-supplied 
device to enable connection of 
USB-enabled embroidery machines 
to an EmbroideryConnect machine 
network via a WiFi router.
Windows domain:  a network of 
Windows PCs, also known as 
‘network domain’, in which 
computers rely on a centralized 
authentication database. Users log 
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into the domain and the access 
privileges are served from the 
central database which is controlled 
by a network administrator.
Windows workgroup:  ‘Workgroup’ 
is Microsoft’s term for a 
peer-to-peer local area network. 
Computers running Microsoft 
operating systems in the same 
workgroup may share files, 
printers, or Internet connection.
Wireless Access Point (WAP):  A 
wireless access point or ‘WAP’ is a 
hardware device on a local area 
network (LAN) that allows wireless 
capable devices and wired networks 
to connect.
WLAN:  Wireless Local Area 
Network or WiFi network.
WMF:  MS Windows® Metafile 
vector format.
Write:  To send design information 
to an embroidery disk, design card 
or embroidery machine for 
immediate stitchout or storage.
X/Y coordinates:  The horizontal (X) 
and vertical (Y) distances on a 
graph or computer screen. Use X 
values to measure width, and Y 
values to measure height.
XXX:  Compucon stitch or 
‘expanded’ file format in the 
professional market.
Zigzag stitch:  Zigzag stitch is 
similar to Satin but is generally 
used where fewer stitches are 
required. The needle penetrates 
each side of the column, laying the 
thread across in an open zigzag 
pattern. The density is determined 
by the stitch spacing setting. The 
settings for Zigzag fill stitches are 
stored separately from Zigzag and 
Double Zigzag underlay settings.
Zigzag underlay:  Zigzag and 
Double Zigzag underlay stitching is 
used to support wide columns.
Zoom factor:  The scale at which 
the design is currently displayed.
ZSK:  ZSK1 format is for older ZSK 
machines, generally those older 
than 1991. ZSK2 is for newer ZSK 
machines, those characterized by a 
single top thread trimmer. The trim 
is the most significant 
differentiating factor between the 
two types.
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Index

Numerics
3D Warp tool 534–535

A
Accordion Spacing

tool 458
overview 458

Add
Border dialog 296
Color tool 90
Holes tool 301
Team dialog 615
Thread dialog 101

Add Bitmap Colors dialog 700
Add to Favorites dialog 271
adding

colorways 275
Empty Stitch/Empty Jump 360
stitch angles to Complex/Fusion 

Fill 332
tie-offs 358
trims 359

Adjust
Bitmap tool 729
dialog 731

adjusting
column width 243
Motif fill width and height 223
Satin stitch spacing with 

auto-spacing 211
Satin stitch spacing with fixed 

spacing 214
stitch angles 333
Tatami stitch length 217
Tatami stitch spacing 217

administrator privileges 188
Align

Bottom tool 393
Centers Horizontally tool 393
Centers tool 393
Centers Vertically tool 393
Left tool 393
Right tool 393
Top tool 393

alphabets 592
converting TrueType 638
converting TrueType fonts 637
converting TrueType to embroidery 

fonts 637
creating new 651
digitizing from artwork 647
letter kerning 593
merging files 655
modifying 653
modifying custom letter 654
preparing drawings 648
user-refined 644
See also lettering

anchor points, rotation 398
angles

rotating by exact angle 399
rounding sharp corners, Input C 342
skewing by exact angle 401
See also stitch angle

anti-aliasing 681
appliqué

adjusting settings 740
converting Fusion Fill objects 739
converting vector graphics 735
cover stitch values 745
cutting shapes 752
digitizing 737
guide run values 742
outputting 751
partial cover 747, 748
printing patterns 751
splitting 414
tacking values 743

Appliqué Fabric dialog 741
Appliqué Tools

Auto Appliqué 737–747
Combine Appliqué Components 749
Partial Appliqué 747

Apply
Closest Join tool 364
Current Color tool 90
Current Properties tool 263

Apply Style
dialog 268
tool 268

Arrange toolbar
Align Bottom 393
Align Centers 393
Align Centers Horizontally 393
Align Centers Vertically 393
Align Left 393
Align Right 393
Align Top 393
Apply Closest Join 364
Branching 368
Group 379
Lock 380
Make Same Height 397
Make Same Width 397
Make Same Width and Height 397
Space Evenly Across 394
Space Evenly Down 394
Ungroup 379, 654
Unlock All 380

arranging objects
grouping 379
locking 379

arrays
Array tool 316
creating 316

artwork
anti-aliased images 681
choosing 679
converting to vector drawings 711
dithered images 681
enlargement drawings 173
loading 709
scanned images 680
sequins 790
vector drawings 702

Assign Thread tool 92
Auto Appliqué tool 737–747
Auto Fabric dialog 48, 264, 719, 723
Auto Fabric Settings dialog

Lettering 267

Narrow Satin 266
Stabilizer 268
Tatami/Program Split Fill 266
Wide Satin 266

Auto Hoop tool 902
Auto Jump

tool 349
overview 349

Auto scroll 143
Auto Spacing

setting values 211
Settings dialog 213
spacing offset 212
stitch length 212
stitch spacing 212

Auto Split 347
Auto Start & End

dialog 676, 901
tool 672, 901

auto start/end method, team 
names 621

Auto Trace To Vectors tool 711
Auto Underlay

dialog 320–325
tool 320–325, 370, 598

Auto-Digitizing Tools
Adjust Bitmap 729
Auto Trace To Vectors 711
Centerline Run Object 722
Color Matching Method 722
Color PhotoStitch 729
Crop Bitmap 690, 729
Instant Smart Design 718
Keep Original Objects 719
Outline Run Object 722
Photo Flash 725
Prepare Bitmap Colors 697
Smart Design 718
Tatami Fill Object 722
Tatami Fill Object with Holes 722
Turning Satin Object 722

automatic
Automatic Knife tool 417
Automatic Resize dialog 730
backup 146
borders 295
branching 367
centering 901
connectors, see connectors
jumps, see Auto Jump
letter kerning 593
pull compensation 327
save 146
sequencing 388
spacing, see Auto Spacing
split, see Auto Split
trims 357
underlay 319
borders, see also lettering

automatic digitizing 715
Auto Trace To Vectors 715
converting grayscale images 725
creating embroidery designs 718
cropping images 690
Photo Flash 715
Smart Design 715
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B
Back 1

Color tool 387
Object tool 386

backdrops 11
dimming 140
inserting bitmap images 709
loading 709
scanning 687
smoothing bitmap images 693
smoothing vector drawings 712
using bitmap images 688

Back-Front tool 421
background

colors, changing 76
fabrics, changing 76
image, toggle on/off 291
images, changing 287
images, scanning 687
products, changing 76

Background & Display Colors
dialog 288–291, 676
tool 76, 78, 278, 287

backgrounds, transparent 690
backstitch

Backstitch tool 208
borderline 220
diagonal 220
selecting for Tatami 219
standard 220
types 219

Backtrack tool 331, 801
backtracking objects 331
Barcode 839
Barudan twin-sequin-capable 

machine 780
baselines

adjusting 568
Baseline Settings dialog 572
changing 552
reshaping 568

Basic Shapes tool 298
basic shapes, digitizing 298
bitmap images

anti-aliasing 681
dimming 140
dithered 681
file types 709
inserting 709
output designs as 849
scanned 680
scanning 687
smoothing 693
using as backdrops 688

Blackwork runs, splitting 414
Bling

Automatic Overlap Removal tool 813, 
822

Edit tool 822
Fill tool 813
Highlight Bling Overlaps tool 813, 

822
Lettering tool 825
Machine Setup dialog 829
Manual tool 812
No Automatic Overlap Removal 

tool 813, 822
Bling Fills

Bling Column Fill 814–820
Bling Contour Fill 814–820

Bling Palette Editor
dialog 806
tool 806

bling palettes
setting up 806

bling runs

automatic 810
Bling Run Auto tool 810
manual 810

Bling toolbar
Automatic Overlap Removal 813, 822
Bling Edit 822
Bling Fill 813
Bling Lettering 825
Bling Manual 812
Bling Palette Editor 806
Bling Run Auto 810
Highlight Bling Overlaps 813, 822
No Automatic Overlap Removal 813, 

822
Show Bling Work Area 810, 813, 829

block digitizing 249
with Block Digitizing tool 249
with multiple angles 249

Borderline backstitch 220
borders

Add Borders tool 295
digitizing with Input C 242, 247
offset objects 305
setting width 243

boring
Borers tool 440
changing borer display color 78
digitizing boring holes 440
oval holes 441
round holes 441

boundaries, digitizing for appliqué 735
branching 367

Branching tool 368
using auto underlay 370
using Color-Object List 369

brands, thread 101
Break Apart tool 414, 577
bunching, reducing with stitch 

shortening 343

C
Calibrate Screen dialog 156
CAMS machine, direct output 829
CAMS Setup dialog 830
Cap Corners tool 338–339
Capture Design Bitmap dialog 51, 851
Capture Virtual Decoration Bitmap 

dialog 853–854
Carving Stamp docker

Digitize 491
Use Object 489, 493
Use Pattern 487

carving stamps
adding to library 492
Carving Stamp tool 487–494
changing appearance 494
creating stitch patterns 486
digitizing 490
pre-defined 487
reshaping 495
using objects 488

Center Out, letter sequencing 590
centering object, with cross-hair 

cursor 392
Centerline Run Object

digitizing artwork 722
tool 722

Change View tool 107
Changed Stitches dialog 152
Character Map dialog 584
charts, see thread charts
check stitching sequence 71
Chenille fill stitch 467, 468
circle objects

moving 409

reshaping 409
Clear Function tool 801
cloning objects 377
Close Curve with Curve Line 

command 240
Close Curve with Straight Line 

command 240
CND

compatible input methods 954
conversion tables 951
saving as 882
saving to 952

codes, thread 101
Coil

Coil tool 228, 466
Color Blending

dialog 461
tool 460

color blocks, split 285
color change functions 180
color matching, automatic 700
Color PhotoStitch

dialog 731
tool 729

Color Picker tool 90
color reduction 682
Color toolbar

Add Color 90
Apply Current Color 90
Background & Display Colors 76, 78, 

287
Color Picker 90
Color Wheel 278
Colorway Editor 75, 79, 92, 275–285
Current Color 90
Current Colorway 75
Cycle Used Colors 278
Hide Unused Colors 90
My Threads 92
Product Visualizer 76, 291, 675
Remove Color 90
Remove Unused Colors 90
Split Palette Color 285

Color Wheel
dialog 278
tool 278

Color-Object List
tool 43, 54, 79, 369, 385, 390
docker 55, 80, 91, 285, 386, 713
resequencing objects 385–390
resequencing objects by number 390
selecting objects 54

colors
changing 278
changing backgrounds 76
changing borer display 78
changing grid display 78
changing object outlines 78
changing stitch display 78
changing thread colors 89, 275
copying across thread charts 99
creating thread charts 98
display colors 78
matching images to threads 700
modifying thread values 96, 100
removing from thread charts 96, 100
resequencing by 389
selecting for an object 89
selecting objects by color 382
setting for consecutive objects 96
thread colors 275
traveling by 72

Colorway Editor
tool 43, 75, 79, 92, 275–285
docker 75, 80, 97, 276–285

Colorway Editor tools
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Background & Display Colors 278
Create Colorway 276
Delete Colorway 278
Edit Color 96
Rename Colorway 277

colorways 275
changing display colors 78
changing display settings 75
Current Colorway 75
viewing 75

Column A
tool 247–248, 441, 499
creating borders 305
digitizing columns 247
offset objects 305

Column B
tool 249
creating borders 305
offset objects 305

Column C
tool 242–245, 342
corner fractions 245
creating offset objects 305
digitizing columns and borders 242
reversing stitch direction 330
round sharp corners 342

columns
digitizing with Column A 247
digitizing with Input C 242, 247
setting width 243
turning stitching 249
width, adjusting 328
width, Pull Compensation tool 328

combination splits
Satin in Satin 478
Satin in Tatami 478
selecting 477
Tatami in Tatami 478
types 477

combining objects
and designs 374
Combine Appliqué Components 

tool 749
Combine tool 419
nesting 378

commands
Close Curve with Curve Line 240
Close Curve with Straight Line 240
Reverse Curves 521
Save as Monogram Template 273, 

624
Save as Teamname Template 273, 

604
undo/redo 155
Update Kerning Settings 594, 595

compensating for stretch, see pull 
compensation

Complex Fill
tool 251–256, 462, 510–512, 526
adding stitch angles 332
creating borders 305
digitizing objects 254
digitizing the stitch angle 251
filling holes 299
offset objects 305
open stitching 456
stitch angle 255
Trapunto 456

complex shapes
adding holes 254
digitizing 250

Complex Turning
tool 251–257
adding stitch angles 332
converting to appliqué 739
nominal stitch angle 255
offset objects 305

composite objects, splitting 414
condensed files

Condensed File Input Settings 
dialog 869–874

Confirm File Replace dialog 891
Connection Manager Setup dialog 158, 

664
connection settings

Connection Manager 878
peripheral devices 156
serial ports 156, 163

Connection Settings dialog 158, 192, 
198, 664

connectors
add Empty Stitch/Empty Jump 360
adding tie-offs and trims 358
after object 353
automatic 352
digitizing with Needles Out 361
inside objects 354
jumps 351
jumps (automatic) 353
Runs 351
runs (automatic) 354
setting automatic tie-in values 355
setting automatic tie-off values 356
setting automatic trim values 357
tie-ins 352, 355
tie-offs 352, 357
travel runs 361
Trim after 358
trims 352
types 351

consecutive objects, setting colors 96
Contour

tool 225, 498, 499–502
Contour stitch overview 498
offset fraction 502
setting stitch values 502
Spiral 500
Standard 500

control points 235
reshape objects 404
viewing 404

conversion tables
digitizing for CND format 954
opening CND files 951
opening Gunold PCH files 955
saving to CND format 952
supported machine file formats 946

Convert Designs dialog 131
Convert Embroidery to Graphics 

tool 716
Convert Graphics to Embroidery 

tool 541, 716, 735
Convert Selected Designs tool 131, 199
Convert TrueType Font

command 638
dialog 639

converting
Conversion Settings dialog 638–642
photos to designs 725
vector objects to embroidery 715, 

717
See also conversion tables
See also converting file formats

converting objects 715
sequin artwork 790

converting outline designs
CND conversion tables 951
EMB conversion limitations 882
EMB to CND 882
EMB to CSD 883
PCH conversion table 955

converting stitch designs
recognize Jumps as Trim 862
recognize Objects/Outlines 861

coordinates
length 59
setting for objects 392

copying
cloning objects 377
colors across thread charts 99
Copy Thread Chart dialog 100
Copy tool 376
duplicating objects 377
object properties 263
objects 376

cording 754
CorelDRAW Graphics

creating lettering 541
design window 40
Options dialog 857, 891

corners
cap 336
corner fraction value 245
corner fractions, Column C 245
fraction value 245
mitre 336
rounding, Column C 342
smart corners 336

Couching tool 755
cover stitches

digitizing appliqué 737
setting values 745

craft stitches
ripple fills 505
spiral fills 226

Create
Colorway tool 276
Alphabet dialog 651
Auto Fabric dialog 265
Colorway dialog 276
Hoop dialog 908–911
Letter dialog 654
Program Split dialog 483–484
Split Pattern dialog 493
Style dialog 269
Thread Chart dialog 98
User-Refined Letter dialog 644

Create Letter
command 654
dialog 650–651

create lettering
letter height 647
letter shapes 647
letter width 648
monograms 582

Create Motif
dialog 537

Create Motif Set dialog 537
Crop Bitmap tool 690, 729
Cross Stitch tool 229, 468
cross-hair cursor 392
CSD format, saving as 883
CSV output file 168
current

needle position marker 72
object properties, changing 259
object properties, make current 263

Current Color tool 90
curved fills

adjusting settings 513
applying to existing objects 514
Contour 498
creating 510
creating fills with two curves 512
creating new objects 510
Curve tab 514

curved lines, making 235
custom alphabets

saving 651
selecting 652
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custom hoops
rectangular 908

custom letters
reshaping 654
saving 649

cut and paste
objects 376
resequencing 384

cut holes in objects 301
Cut tool 376, 384
cutting

cutting lines, digitizing appliqué 737
threads 359

Cycle Used Colors tool 278

D
Define Stop Sequence dialog 869
Delete Colorway tool 278
deleting

colors from thread charts 96, 100
templates 274

density, applying fractional spacing 344
deselecting objects 52
design colors, changing 278
design formats

Gunold PCH 858
old format ESD 858
Wilcom INP 858

Design Integrity Alert dialog 152
Design Library

toolbar, layout 105
Design Library window 41, 105
design properties

tool 85, 115, 166, 281, 835, 283
Design Properties docker

Design 117
Information 57
Order 118
Runtime 121, 166
Stitching 95, 119, 167
Summary 115
Thread Colors 119, 284

design runtime estimates 164
designs

Auto Start and End 901
combining 374
components, exporting 893, 895, 

896, 897
converting formats 30
converting formats (tables) 945
export machine files 881
information 85
naming elements 283
opening 48
opening multiple 48
opening stitch designs 861
outputting 877
planning a design 11
redrawing slowly 71
resequencing 384
saving 50
templates, see templates

Diagonal backstitch 220
dialogs

Add Bitmap Colors 700
Add Border 296
Add Thread 101
Add to Favorites 271
Adjust 731
Appliqué Fabric 741
Apply Style 268
Auto Fabric 48, 264, 719, 723
Auto Fabric Settings > Lettering 267
Auto Fabric Settings > Narrow 

Satin 266

Auto Fabric Settings > Stabilizer 268
Auto Fabric Settings > 

Tatami/Program Split Fill 266
Auto Fabric Settings > Wide 

Satin 266
Auto Spacing Settings 213
Auto Start & End 676
Auto Start and End 901
Automatic Resize 730
Background & Display Colors 288–

291, 676
Baseline Settings 572
Bling Machine Setup 829
Bling Palette Editor 806
Calibrate Screen 156
CAMS Setup 830
Capture Design Bitmap 51, 851
Capture Virtual Decoration 

Bitmap 853–854
Changed Stitches 152
Character Map 584
Color Blending 461
Color PhotoStitch 731
Color Wheel 278
Color-Object List 55, 91
Condensed File Input Settings 869–

874
Confirm File Replace 891
Connection Manager Setup 158, 664
Connection Settings 158, 192, 198, 

664
Conversion Settings 638–642
Convert Designs 131
Convert TrueType Font 639
Copy Thread Chart 100
CorelDRAW Options 857, 891
Create Alphabet 651
Create Auto Fabric 265
Create Colorway 276
Create Hoop 908–911
Create Layout Set 609
Create Letter 650–651, 654
Create Motif 537
Create Motif Set 537
Create Program Split 483–484
Create Split Pattern 493
Create Style 269
Create Teamname Layout 609
Create Thread Chart 98
Create User-Refined Letter 644
Custom Digitizer Setup 173
Define Stop Sequence 869
Design Integrity Alert 152
Digitizer Setup 163–173
DXF File Options 707
Edit Color 97
Edit Function 435
Effects > Curve 508
Embroidery Machine Connection 161
Export 694, 855
Export Design 882–883
Export Multi-Decoration Files 857, 

891–896
Export to PNG 855
Fabric Settings Unchanged 152
File Locations 894
Fill Holes 303
Format Embroidery Disk 886
Format Floppy Disk Drive 886
Guide Position 56
Hardware Setup 161, 163–171
Hoop Not Found 903
Import 709
Import Embroidery 374
Import EPS 709

Import Graphic 688, 707
Info 903
Insert Function 433, 802
Insert Symbol 580–582
Kerning Table 595
Kiosk 663
Length Calculation 95
Letter Sequence 591–592
Letter Spacing Table 597
Machine Format Settings 759
Machine Format Settings > 

Advanced 183–185
Machine Format Settings > 

Standard 179–182, 186
Machine Runtime Settings 165
Machine Runtime Setup 165
Manage Alphabets 653
Manage Auto Fabrics 265
Manage Favorites 271
Manage Motifs 538
Manage Styles 269–271
Manage Teams 615
Manage Thread Charts 98–101
Manage User-Refined Lettering 646
Matching Method 731
Move Stitch 429
My Hoops 900
My Thread Chart 98
My Thread Charts 93
Name Order 602
New from Template 50, 672
New Pattern Set 493
Non-Native Design 152
Open 861, 872
Open Custom Kiosk Banner 669
Open Design 48, 51, 670
Open Embroidery Disk 884
Open From Embroidery Disk 884
Open Options 861–869
Optimize Color Changes 388
Options 69
Options > Edit 149, 377
Options > Export 168
Options > General 148, 151, 248
Options > Grid & Guides 56, 141, 905
Options > Hoop 900, 905–911
Options > Kiosk 663, 668–669
Options > Reshape 145, 416
Options > Scrolling 144
Options > View Design 139
Options > View Graphics 140
Options > Warnings 152
Outlines & Offsets 305
Print 835
Print Catalog Options 134
Print Design 132, 134
Print Options 132, 751, 835
Print Options > Barcode 839
Print Options > Blocks 169, 847
Print Options > Colorways 840
Print Options > Design 842
Print Options > General 839
Print Options > Info 846
Print Options > Stop Sequence 848
Print Options > Zoom 842
Process Stitches 334, 444
Properties (Windows Explorer) 86
Pull Comp 328
Recognition - Advanced Options 864–

868
Remove Overlaps 300
Remove Small Stitches 336
Rename Alphabet 653
Rename Letter 653
Rename Split Pattern 487, 493
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Rename Thread Chart 98
Repeats 83, 842
Resequence By Number 391
Revert to Factory Settings 274
Save As 273
Save As Template 102
Save Hoop As 908
Save Options 882–883
Save Pattern 785
Save to Embroidery Disk 887
Select By Color 383
Select By Stitch Type 383
Select Fabric Pattern 288
Select Machine Format 47, 185, 759, 

782
Select Source 170
Send to Appliqué Cutter 753
Send to Bling Cutter 827
Send to CAMS Machine 830
Send to Connection Manager 830, 

878
Send to Stitch Manager 880
Sequence By Color 389
Sequin Palette Editor 760–782
Sequin Pattern 783, 791
Serial Port Setup 163
Set Color 96
Show Functions 437
Show Stitches 438
Simple Offsets 304
Smart Design 719
Smooth Curves 712
Some Bling Remaining 832
Special 343, 591, 614
Stitch Manager 880
Stitch Player 71
Stitch Shortening Settings 345
Tablet Setup 175–176
Team Names 602
Team Names Matrix 620
Teamname Layouts 606
Teamname List 606, 612–619
Transform by Reference Line 397, 

400
TrueView Options 139
Turning Auto Fabric Off 264
Turning Auto Fabric On 264
Twin Device - Select Sequin 802
View by Color 80
Warning 365
WiFi USB Disk Management 196
WiFi USB Setup 192
Zoom Factor 65
ZSK File Name 152

Digitize Closed Shape tool 238, 510, 
512, 521, 703

Digitize Column tool 247
Digitize Open Shape tool 238, 521, 703
Digitize Run tool 240, 462
Digitizer Setup dialog 163–173
digitizer tablets

changing drawing scale 175
Custom Digitizer Setup dialog 173
Digitizer Setup dialog 163, 173
Point mode 172
puck actions 177
registering enlargement 

drawings 173
shifting the drawing 176
Stream mode 172
using 177

digitizing
appliqué objects 737
boring holes 440
closed shapes using Digitize Closed 

Shape tool 238

columns 249
columns and borders 242, 247
columns with Column A 247
complex shapes 250
individual stitches 440
input methods 231
lines with Open Shape 238
methods, Open Shape tool 238
new motifs 536
shapes with Auto Trace To 

Vectors 711
split lines 485
turning stitches 510
using a digitizer tablet 177
with Needles Out 361

digitizing artwork
Centerline Run Object 722
Outline Run Object 722
Tatami Fill 722
Tatami Fill without Holes 722
Turning Satin 722

digitizing methods
Input C 242, 247
selecting 231

dimming backdrops 140
direct-to-garment production 804
display

changing display colors 78
changing display settings 75
grid 56
setting display options 69

distances, measuring on-screen 59
dithering 681
Divide tool 423
Docker toolbar

Carving Stamp 487–494
Color-Object List 43, 54, 79, 369, 385, 

390
Colorway Editor 43
Design Properties 85, 166, 281, 283, 

835
Embroidery Clipart 114
Object Properties 43–45, 259–272, 

353–361, 594, 704, 781, 785, 787
Overview Window 67
Stitch List 426–438

dockers
Carving Stamp > Digitize 491
Carving Stamp > Use Object 489, 

493
Carving Stamp > Use Pattern 487
Color-Object List 80, 285, 386, 713
Colorway Editor 75, 80, 97, 276–285
Design Properties > Design 117
Design Properties > Information 57
Design Properties > Order 118
Design Properties > Runtime 121, 

166
Design Properties > Stitching 95, 

119, 167
Design Properties > Summary 115
Design Properties > Thread 

Colors 119, 284
Monogramming > Borders 633
Monogramming > Designs 624
Monogramming > Letters 627
Monogramming > Ornaments 629
My Threads 93, 98
Object Properties > Accordion 458–

461
Object Properties > Auto Jump 349
Object Properties > Bling Fills 814–

820
Object Properties > Bling Run 810
Object Properties > Connectors 353–

358

Object Properties > Curves 534–536
Object Properties > Decorative > 

Jagged edge 453
Object Properties > Decorative > 

Trapunto 457
Object Properties > Fill Stitch > 

Stipple Fill 454
Object Properties > Fills 260–261, 

272
Object Properties > Fills > Cross 

Stitch 469
Object Properties > Fills > E 

Stitch 221
Object Properties > Fills > Motif 

Fill 519, 526–530
Object Properties > Fills > Photo 

Satin 726
Object Properties > Fills > Raised 

Satin 216
Object Properties > Fills > 

Ripple 506
Object Properties > Fills > 

Satin 211–216, 348
Object Properties > Fills > Sequin 

Column Fill 771–779, 787, 795
Object Properties > Fills > 

Tatami 218–220, 457, 472–475
Object Properties > Outlines 57
Object Properties > Outlines > 

Backstitch 208
Object Properties > Outlines > Motif 

Run 519–521
Object Properties > Outlines > 

Run 206, 801
Object Properties > Outlines > 

Sequin Run 765–769, 782–785
Object Properties > Outlines > 

Square 221
Object Properties > Outlines > 

Stemstitch 208
Object Properties > Outlines > Triple 

Run 207
Object Properties > Program 

Split 476–484
Object Properties > Pull Comp 327–

328, 548
Object Properties > Shortening 345
Object Properties > Smart 

Corners 339, 344
Object Properties > Special > 

Appliqué 260, 746
Object Properties > Special > 

Bitmap 693
Object Properties > Special > Column 

C 244–246
Object Properties > Special > 

Complex Fill 255–256
Object Properties > Special > Fusion 

Fill 255–257
Object Properties > Special > 

Lettering 558–576, 580–582, 588–
597, 638–653

Object Properties > Special > Photo 
Flash 726

Object Properties > Special > 
Vector 705

Object Properties > Underlay 320–
325, 371

Object Properties >Special > 
Lettering 546–550, 556

Object Properties >Special > Travel 
Run 361

Product Visualizer 291
Stitch List 360, 426–438

DOS disks, opening designs 884
Double Square

stitch 468
drawing objects

coloring 704
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coloring fills 704
coloring outlines 704
creating complex shapes 418
creating enlargement drawing 173
drawings creating 703
enlargement drawings 173
scaling, changing 175
See vector objects 703
smoothing vectors 712

Drop Sequin
functions, inserting 802
tool 801

drop-stitch direction, sequin runs 768
duplicate options

object property position 149
shift duplicated objects 149

duplicating
cloning objects 377
objects 377

DXF File Options dialog 707

E
E Stitch tool 221
Edit Color

dialog 97
tool 96

Edit Function dialog 435
Edit menu

Reverse Curves 330
Wilcom Decoration 925

Edit Tools
Automatic Knife 417
Break Apart 414, 577
Knife 415

editing objects 404
editing stitches 429

inserting stitches 428
machine functions 431
moving stitches 429
removing small stitches 336
using Stitch List 437

EDS-III
conversion table 951
digitizing for 954
saving to CND format 952

effects
3D warp 534–536
Accordion 458–461
Accordion Spacing 458
Auto Jump 349
Auto Underlay 319
Color Blending 460
Curve 508, 514
Jagged Edge 452
pull compensation 327
Shortening 344
smart corners 336
stitch shortening 343
Trapunto 456

Effects toolbar
Couching 755

elements, naming 85, 283
Ellipse tool 237, 703
email attachments 51
Embroidery Clipart docker 114
Embroidery Disk tool 884–887
embroidery disks

formats 885
formatting 885
opening designs 884

embroidery machine automatic 
download 157, 161

Embroidery Machine Connection 
dialog 161

embroidery objects

convert to vector 715, 717
creating complex shapes 418
inter-converting 715

Embroidery Studio, starting 36
EMT files 273
End of Design functions 182
enlargement drawings

changing scale 175
creating 173
preparing 173
registering 174
shifting 176

entry/exit points
adjusting 363
changing 712

Envelope effect
Bridge Envelope 411
Diamond Envelop 412
Penant Envelope 412
Perspective Envelope 412

Envelope Tools
Bridge Envelope 411
Diamond Envelope 412
Penant Envelope 412
Perspective Envelope 412

envelopes
distorting lettering objects 411
types 411

Exclude tool 421
export

designs 881
Export Design

dialog 882–883
List tool 135
Properties command 168

Export dialog 694, 855
Export Machine File tool 881
Export Multi-Decoration Files

dialog 857, 891–896
tool 890–895

Export to PNG dialog 855

F
Fabric Settings Unchanged dialog 152
fabrics

changing backgrounds 76
changing colors 76
fabric stretch, see pull compensation
managing 265
selecting 49
show/hide 138

fancy fill stitches, Program Split 476
favorites, assigning favorite styles 271
File Locations dialog 894
File menu, Wilcom Decoration 924
file types

EMT 273
machine files 946

Fill Holes
dialog 303
tool 302

Fill Stitch Types
Contour 225
String 228, 462

Fill Stitch Types toolbar
Coil 228, 466
Contour 499–502
Cross Stitch 229, 468
Double Square 228, 465
E Stitch 221
Island Coil 228, 467
Motif Fill 223, 518, 526, 528, 530, 532
Program Split 224, 476–481, 587
Satin 211–215, 347, 585
Satin Raised 211–215, 585

Square 228, 465
Stipple Backstitch 227, 454
Stipple Fill 227, 454
Stipple Stemstitch 227, 454
Tatami 217, 472, 475, 586
Vector Fill 703

fill stitching 467, 468
Fills

Contour 225, 499–502
Cross Stitch 229, 468, 469
Double Square 228, 465
E Stitch 221
Motif Fill 223, 518, 526, 528, 530, 532
Motif Fills 526–528
Photo Satin 726
Program Split 224, 476–481, 587
Raised Satin 216
Satin 211–215, 260–261, 348, 585
Satin Raised 211–215, 585
Sequin Column Fill 771–779, 787, 

795
Spiral Fill 226, 504, 505
Square 228, 465
Stipple Backstitch 227, 454
Stipple Fill 227, 454
Stipple Stemstitch 227, 454
Tatami 217, 218–220, 457, 472–475, 

586
Vector Fill 703
Zigzag 221, 586

fills
adjusting curved fill settings 513
applying curved fills 514
block digitizing 249
creating curved fills 510
creating fills with two curves 512
cross stitch 229, 468
ripple 505
spiral 226
switching between fill and 

outline 234
Tatami 217
with sequins 770

Fills Stitch Types toolbar
Spiral Fill 226, 504, 505
Zigzag 221, 586

filtering stitches
by function 437
by stitch length 438

Finalize Crop command 690
find threads 96
fixing stitches

orientation 767
sequins 764

Flatten tool 423
Flexi Split tool 515
Florentine Effect tool 510–513
Format

Embroidery Disk dialog 886
Floppy Disk Drive dialog 886

formats, machine types 945
Forward

1 Color tool 387
1 Object tool 387

Fractional Spacing tool 344
frame movement, Auto Jump 349
Freehand

Select tool 53
Closed Shape tool 447–451
creating lines 449
Open Shape tool 447–451
smoothing lines 451

Freehand Embroidery Smoothing 
toolbar
Guide Inner Circle Radius 451
Number of Guide Circles 451
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Show Guide 451
Front-Back tool 421
Function toolbar

Borers 440
Insert Empty Jump 360
Insert Empty Stitch 360
Insert Function 433
Insert Tie Off 358
Insert Trim 359
Penetrations 361, 440

functions
Drop Sequin 802
End of Design 182
Stop 182

G
gaps, offsetting filled holes 299
General Properties

dimensions 396
positioning using coordinates 392

Generate Stitches tool 236
graded motif columns 532
graded motif runs 523
graphics

converting to appliqué 735
grayscale images, converting 725
packages, linking 692

Graphics Digitizing toolbar
Basic Shapes 298
Digitize Closed Shape 238, 510, 512, 

521, 703
Digitize Column 247
Digitize Open Shape 238, 521, 703
Ellipse 237, 703
Fill Holes 302
Freehand Closed Shape 447–451
Freehand Open Shape 447–451
Rectangle 237, 703
Remove Stitch Angles 332
Stitch Angles 332

grid
changing display color 78
display 56
setting options 141
snap to 142

Group tool 379
grouped objects 379

selecting components 381
Guide Inner Circle Radius tool 451
guide patterns

Motif Fill 530
Program Split 481

Guide Position dialog 56
guide runs

digitizing appliqué 737
offsetting 742
setting values 742

Gunold, opening PCH files 955

H
handles, see selection handles
hardware

peripheral device settings 156
setting up display monitor 155
setting up scanner 170

Hardware Setup
dialog 161–163, 171
tool 161, 163, 171

height, make objects same size 397
hidden objects, display 54
Hide Unused Colors tool 90
Hole Tools

Add Holes 301

Fill Holes 302
No Holes 301

holes
add holes 301
adding to complex shapes 254
digitizing boring holes 440
filling holes 299

Hoop Not Found dialog 903
hoops

custom lists 899
frame out (Auto Appliqué) 746
selecting 905

hot-fix template production 804

I
images

bitmaps 688
changing backgrounds 287
cleaning up 682
color reduction 682
cropping 690
dimming bitmaps 140
editing 692
image preparation 681
inserting bitmaps 709
loading 709
matching thread colors 700
noise filtering 683
outline sharpening 683
outlined vs non-outlined 682
output designs as 849
preparation 681
scanning bitmaps 687
sharpening 686
smoothing bitmaps 693

Import Embroidery
dialog 374
tool 374, 674

Import EPS dialog 709
Import Graphic

dialog 688, 707, 709
tool 688, 709, 729

Import Team Members tool 604
Info dialog 903
input methods

Column A 247
digitizing 231
Motif Run 521
selecting 231

Insert Empty
Jump tool 360
Stitch tool 360

Insert Function
dialog 433, 802
tool 433

Insert Symbol dialog 580–582
Insert Tie-Off tool 358
Insert Trim tool 359
inserting

bitmap images 709
one design into another 374
one object inside another 378
stitches 428

installing, printers 170
inter-converting objects 715
Intersect tool 421
Island Coil

fill stitch 467
tool 228, 467

italics, lettering 548

J
Jagged Edge tool 452, 587

joining
creating smooth joins 248
objects, see connectors

jumps
adding 361
adding Empty Jumps Empty 

Stitches 360
Auto Jump 349
automatic connectors 353
digitizing with Needles Out 361
overview 351
using 432

justification, lettering 548

K
kaleidoscope

Kaleidoscope tool 314
using with wreath 314

Keep Original Objects tool 424, 716
keep/omit last stitch

Column A 247
Column B 249
Keep Last Stitch tool 362
Omit Last Stitch tool 362

Kerning Table dialog 595
Kiosk

dialog 663
Choose Design Panel 660
customization panel 660, 661
Monograms 662

Knife tool 415

L
Lap Corners tool 338–339
last stitch, keep or omit 247–249
layers, removing excess stitching 299
layout

Motif Fills 530
Program Split patterns 481

Layout tool 105
Legacy Features toolbar

Embroidery Disk 884–887
Hardware Setup 161, 163, 171
Send to Stitch Manager 879

length
automatic split 347
Contour stitch 502
Length Calculation dialog 95
nominal 513
preserving long stitches 349
travel runs 361

Letter Sequence dialog 591–592
letter spacing

adjusting 550
automatic 596
changing 549

lettering
Lettering tool 545–552, 558–560, 

568–574, 579–580, 588–594, 611, 
638–652, 672, 674

2-color alphabets 592
Lettering tool 590–592
adding to designs 24
adjusting individual letters 564
adjusting Satin stitch settings 585
applying lettering art 411
art, applying 411
As Digitized join method 593, 959
automatic borders 295
Bottom Join method 593, 959
Closest Join method 593, 959
coloring 568
coloring on-screen 568
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converting TrueType letters 638
creating embroidery fonts from 

TrueType 637
creating in CorelDRAW Graphics 541
creating in Wilcom Decoration 543
creating monograms 582
editing 558
formatting 548
generating stitches 236
I-beam 568
join methods 592
keeping original stitch values 592
kerning 593
letter spacing 549
Letter Spacing Table dialog 597
line spacing 549
names, see names
reshaping baseline 568
reshaping curved baselines 568
reshaping on screen 566
selecting symbols 579
special characters and symbols 579
splitting 414
stitching sequence 590
transforming with Reshape Object 

tool 565
word spacing 549
See also alphabets
See also baselines

lines
digitizing with Open Object 238
split lines 485

Liquid Effect tool 512–514
Lock tool 380
locking objects 379
lockstitches, see Empty Stitch

M
machine connections

Machine Format Settings > 
Advanced 183–185

Machine Format Settings > 
Standard 179–182, 186

Machine Manager 877
sequin-capable 759
supported formats 945

machine files
conversion options 861
opening 861
overview 859
processing into objects 861
reassigning colors 868
stitch recognition 861
supported formats 946

Machine Format Settings dialog
Advance 759
Standard 759

machine formats
advanced values 183
changing 877
color change sequence 183
creating custom 186
modifying values 182
selecting 46, 49
start of design/end of design 184

machine functions
borers in/out 431
boring 432
color change 431
inserting manually 433
jumps 431–432
sequins on/off 431
speed 184
Stops 432
thread trim 431

trims 431
types 431
using 433

machine network, WiFi 187
machine networking

configuring the device 192
sending designs 879

Machine Runtime
Settings dialog 165
Setup dialog 165

Make Properties Current tool 263
Make Same

Height tool 397
Width and Height tool 397
Width tool 397

Manage
Alphabets dialog 653
Auto Fabrics dialog 265
Favorites dialog 271
Motifs dialog 538
Styles dialog 269–271
Thread Charts dialog 98–101
User-Refined Lettering dialog 646

Manage Designs toolbar
Convert Selected Designs 131, 199
Export Design List 135
Manage Embroidery Library 

Locations 124, 200
New From Selected 113, 689
Open Selected 111
Print Selected 132
Print Selected to Catalog 133
Send to Connection Manager 132, 

199
Manage Embroidery Library Locations 

tool 124, 200
Manage Teams dialog 615
Manage Teams tool 604
manual

Left Sequin tool 799
Manual Sequin tool 799
Manual tool 440
Right Sequin tool 799
digitizing sequins 799
manual objects splitting 430
right-clicking 440

Manual Tools
Manual 440
Triple Manual 440

Match All tool 92
Match to Embroidery Palette tool 715
Matching Method dialog 723, 731
matrix of team names 619
maximum stitch length 513
measurements

measurement units, setting 57
measuring distances on screen 59

Melco
CND conversion tables 951
CND format, saving as 882
digitizing for CND (tables) 954

minimum stitch, Tatami 217
Mirror

Horizontal tool 402
Vertical tool 402

Mirror by Reference Line tool 402
Mirror Copy

Horizontal & Vertical tool 312
Horizontal tool 312
Vertical tool 312

Mirror Merge Settings toolbar 313–316
Mirror Merge tools

Array 316
Kaleidoscope 314
Mirror Copy Horizontal 312
Mirror Copy Horizontal & Vertical 312
Mirror Copy Vertical 312

Reflect 313
Wreath 314

mirroring objects
around a specified axis 402
around X or Y axis 402
creating wreaths 314
horizontally 402
vertically 402
with kaleidoscope 314

mitre corners 336
Mitre Corners tool 338–339

Mode toolbar
Convert Embroidery to Graphics 716
Convert Graphics to Embroidery 541, 

716, 735
Design Library 41, 105, 689
Keep Original Objects 716
Match to Embroidery Palette 715
Show Embroidery 40
Switch to CorelDRAW Graphics 40, 

709
Switch to Wilcom Decoration 37
Tag as Appliqué 735
Tag as Photo Flash 715, 725
Tag Fill as Turning Satin 541, 715
Virtual Decoration Quality 855

modifying designs
moving objects 392
with the Color-Object List 54

modifying objects
aligning 393
changing entry point 712
changing exit point 712
changing radius of Circle 409
changing size of Ring 410
grouping 379
locking 379
mirroring 402
moving Ring object boundary 410
resequencing objects by number 390
resequencing with Color-Object 

List 390
reshaping Circle objects 409
reshaping Ring objects 410
reshaping Star objects 409
rotating 398
scaling 395
skewing
spacing evenly 394
using envelopes 411

monitor, setting up 155
Monogramming docker

Borders 633
Designs 624
Letters 627
Ornaments 629

Monogramming tool 624–632
monograms

creating 582
splitting 414

motif fill
Motif Fill tool 223, 518, 526, 528, 530, 

532
applying 223, 526
filling shapes with 223, 526
layout 530
layout motifs 530
modifying layouts on-screen 530
motif size 529
offsets 528
rotating 529
spacing 528
Two-part motifs 526
values 528

motif run
Motif Run tool 223, 518–521
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creating offset objects 305
overview 521
reshaping 524

Motif Run tool 521
motif runs, graded 523
motifs

adjusting offsetting on-screen 532
adjusting spacing on-screen 531
creating new 536
graded columns 532
laying out on-screen (Motif Fill) 530
motif sets 538
overview 518
reference points 536
remove functions 536
rotating patterns on-screen 531
saving 536
scaling (Motif Fill) 529
scaling patterns on-screen 531
single 983
skewing patterns on-screen 531
two-part 1000
See also Motif Fill
See also Motif Run

mouse wheel, preset behavior 143
Move Stitch dialog 429
Move to End tool 387
Move to Start tool 387
moving objects

moving circles 409
nudging 392
positioning with X:Y coordinates 392
with click-and-drag 392

multi-colorways 275
multiple stitch angles 249
My Hoops dialog 900
My Thread Charts

dialog 93, 98
tool 92

My Threads
docker 93, 98
tool 92

My Threads toolbar
Assign Thread 92
Match All 92
My Thread Charts 92

N
names, outputting designs 618
needle penetrations

applying partition lines 473
decorative (Program Split) 476
digitizing split lines 485
digitizing with Needles Out 361
offsetting (Tatami) 472
offsetting for Contour 502
random factor 475

needle position marker 72
new

New Pattern Set dialog 493
New tool 49
starting new design 11

New from
Selected tool 113, 689
Template dialog 50, 672

No Holes tool 301
noise filtering, images 683
nominal stitch length 513
Non-Native Design dialog 152
NORMAL template

overview 272
reverting 274
use 49

nudging objects into position 392
Number of Guide Circles tool 451

O
Object menu

Create Letter 654
Create Motif command 537

object outlines, changing display 
color 78

object properties
Object Properties tool 43–45, 259–

261, 272, 353–357, 361, 594, 704, 
781, 785, 787

accessing 45
applying/managing 268
changing 261
connectors 351
current 259
default 259
lettering 545
make current 263
presetting 259
saving current 259
saving to a template 272
styles 268
templates 271

Object Properties docker 45
Accordion 458–461
Auto Jump 349
Auto Underlay 371
Bling Fills 814–820
Bling Run 810
Connectors 353–358
Curves 514, 534–536
Decorative > Jagged edge 453
Fills 260–261, 272
Fills > Appliqué 746
Fills > Cross Stitch 469
Fills > Decorative > Trapunto 457
Fills > E Stitch 221
Fills > Motif Fill 519, 526–530
Fills > Photo Satin 726
Fills > Program Split 476–484
Fills > Raised Satin 216
Fills > Ripple 506
Fills > Satin 211–216, 348
Fills > Sequin Column Fill 771–779, 

787, 795
Fills > Stipple Fill 454
Fills > Tatami 218–220, 457, 472–475
Outlines > Backstitch 208
Outlines > Motif Run 519–521
Outlines > Run 206, 801
Outlines > Sequin Run 765–769, 

782–785
Outlines > Square 221
Outlines > Stemstitch 208
Outlines > Triple Run 207
Pull Comp 327–328, 548
Shortening 345
Smart Corners 339
Smart Corners > Fractional 

spacing 344
Special 361, 591, 614–748
Special > Appliqué 260, 737–746
Special > Bitmap 693
Special > Column C 244–246, 343
Special > Complex Fill 255–256
Special > Fusion Fill 255–257
Special > Lettering 546–550, 556, 

558–576, 580–582, 588–597, 638–
653

Special > Photo Flash 726
Special > Vector 705
Underlay 320–325, 598

objects
applying underlay 320
backtracking 331

circles 297
cloning 377
connecting 351
converting 715
copying and pasting 376
creating duplicates 331
deselecting 52
duplicating 377
editing 404
French dots 297
locking and unlocking 380
mirror-merging 402
moving 392
nesting 378
ovals 298
positioning 392
reflecting 313
repeating 331
resequencing 384
reshaping 404
rings 297
rotating 398
selecting 16
selecting colors 89
shaping 418
skewing 401
splitting 414, 430
vector 703
See also modifying objects

offsetting
Auto Spacing (Satin) 212
Contour needle points 502
creating offset objects 305
filled holes (Complex Fill) 299
Motif Fill patterns 528
objects 305
offset fractions (Tatami) 472
Program Split patterns 

on-screen 482
random factor (Tatami) 475
using partition lines 473

omit/keep last stitch
Column A 247
Column B 249

online help 8
open

Open Design tool 48, 51
Open Recent tool 48
Open tool 665, 670
Open Custom Kiosk Banner 

dialog 669
Open Design dialog 48, 51
Open dialog 861, 872
Open Embroidery Disk dialog 884
Open From Embroidery Disk 

dialog 884
Open Options dialog 861, 869
Open Selected tool 111
stitching, see also color blending

Open Offsets tool 310
open stitching, Trapunto 456
open-ended shapes, digitizing 238
opening designs

converting stitch designs 861
from DOS disk 884
other formats 884
preview window 48
scaling 861

OpenType fonts, converting to 
embroidery 543

Optimize Color Changes dialog 388
Options dialog 69

Edit 149, 377
Export 168
General 148, 151, 248
Grid & Guides 56, 141–142, 905
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Hoop 900, 905–911
Kiosk 663, 668–669
Reshape 145, 416
Scrolling 144
View Design 139
Warnings 152

Options tool 138–152, 248, 663–669
outline files 858
outline run

Outline Run Object tool 722
digitizing artwork 722

Outline Stitch Types toolbar
Backstitch 208
Contour 225, 499–502
E Stitch 221
Motif Run 223, 518–521
Program Split 224, 476–481
Run 205, 206, 755
Satin 211–215
Satin Raised 211–215
Sculpture Run 205, 207
Square 465
Stemstitch 208
Tatami 217
Triple Run 205, 207
Vector Outline 703
Zigzag 221

Outline tools
Motif Run 521

Outline Tools toolbar
Digitize Run 240

outlines
Backstitch 208
changing display color 78
Contour 225, 499–502
control points 235
creating borders around objects 305
E Stitch 221
Motif Run 223, 518–521
Program Split 224, 476–481
Run 205, 206, 755, 801
Satin 211–215
Satin Raised 211–215
Sculpture Run 205, 207
Sequin Run 765–769, 782–785
show/hide 138
Square 465
Stemstitch 208
stitches, Motif Run 521
switching between fill and 

outline 234
Tatami 217
Triple Run 205, 207
Vector Outline 703
Zigzag 221

Outlines & Offsets 305
outputting designs

to different formats 877
ovals

boring oval holes 441
reshaping circles to ovals 409

overlapping
color blending 460
stabilizing segments 256

overlaps
Overlap tool 423
removing stitching 299
tolerance between rhinestones 806

overstitching, pull compensation 327
Overview Window tool 67

P
Partial Appliqué tool 747
partition lines 473
paste options

center at current stitch 149
object property position 149
shift pasted objects 149
start at current stitch 149

Paste tool 376, 384
patterns

creating patterns 483
editing 484
laying out on-screen (Motif Fill) 530
laying out on-screen (Program 

Split) 481
pre-defined 487
Program Split 476
scaling for Motif Fill 529
setting up twin-sequins 781
using objects 488

Penetrations tool 361, 440
peripheral devices

connection settings 156
Photo Flash tool 725
photos, converting to embroidery 725
planning

design shapes 15
stitching sequence 15

PNG format 893, 895, 896, 897
Point mode, digitizer tablets 172
pointer position display 147
Polygon Select tool 53
Polyline Select tool 53
ports, serial 156, 163
position coordinates 59
Prepare Bitmap Colors tool 697
preserving long stitches 349
preset styles, NORMAL template 272
Print Catalog Options dialog 134
print design

save as PDF 88, 135, 837
Send design as PDF attachment 88, 

135, 837
send to printer 88, 135, 837

Print Design dialog 132, 134
Print now command 88, 135, 837
Print Options dialog 132, 835

Barcode 839
Blocks 169, 847
Colorway 840
Design 842
General 839
Info 846
Stop Sequence 848
Zoom 842

Print Selected to Catalog tool 133
Print Selected tool 132
printers 170

installing 170
parallel port 170
setting up 170

printing
Print dialog 835
Print Options dialog 751
Print Preview tool 87
Print tool 835

Process Stitches
dialog 334, 444
tool 334, 444

Product Visualizer
docker 291
tool 76, 291, 675

production worksheets
information 87
printing 834, 835, 850
viewing 87

production, managing designs 198
products

changing backgrounds 76
templates, selecting 291

Program Split
Program Split tool 587
adjusting spacing on-screen 482
applying 476
combination splits 477
creating patterns 483
editing patterns 484
filling shapes with 476
layout patterns 481
modifying layouts on-screen 481
offsetting patterns on-screen 482
Program Split tool 224, 476–481
rotating patterns on-screen 482
scaling patterns on-screen 482
skewing patterns on-screen 482

properties
lettering 545
Properties dialog, Windows 

Explorer 86
vector objects 704

Property bar 45
accurate positioning 392
scaling objects 396

puck, digitizer 177
pull compensation

Pull Compensation tool 327–328
applying 327
overview 327
reversing stitch direction 330

push-pull effect, compensating for 256

R
Radial Fill tool 508
Raised Satin tool 211
reassigning colors, to machine files 868
recognition

Advanced Options dialog 864–868
Recognize Object/Outline 

command 443
Rectangle tool 237, 703
rectangular hoops, creating 908
redrawing designs slowly 71
reference lines

mirroring objects 402
rotating by specified angle 400
rotating relative to 399

reference points 235
motifs 536
origin 173–174
rotating using 399
rotating using (exact angle) 400
rotation point 173–175
scaling objects with 397
See also control points

Reflect tool 313
reflecting objects, using 

Mirror-Merge 313
registering enlargement drawings 174
Remove

Overlaps dialog 300
Overlaps tool 299, 747
Small Stitches dialog 336
Unused Colors tool 90

Rename
Colorway tool 277
Alphabet dialog 653
Letter dialog 653
Split Pattern dialog 487, 493
Thread Chart dialog 98

Repeat tool 331
repeating

motifs (Motif Run) 532
objects 331

Repeats dialog 83, 842
resequencing
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by color 389
by selection 389
objects 384
objects by Color-Object List 390
objects by number 390
Resequence By Number dialog 391
using cut and paste 384
using the Color-Object List 385

Reset Detail Columns tool 108
Reshape Object tool 144, 333, 363, 

404–410, 495, 508, 514, 524, 534–
535, 550, 561–568, 588, 595, 644, 
654, 712, 746, 792–795, 821

Reshape Tools
Keep Last Stitch 362
Reshape Object 144, 333, 363, 404–

410, 495, 508, 514, 524, 534–535, 
550, 561–568, 588, 595, 644, 654, 
712, 746, 792–795, 821

Reshape Views toolbar
Show Bézier Handles 404, 408
Show Entry/Exit Points 363, 405
Show Reshape Nodes 404–408, 495
Show Stitch Angles 333, 405

reshaping objects 404
bézier control handles 408
circles 409
lettering 568
Motif Run 524
reshape nodes 406
Reshape Options 145
reshape options 144
Ring 410
Sequin Run 792
Star 409

Reverse Curves command 330, 521
reverse stitching

Backtrack and Repeat 331
direction 330

Revert
Revert to Factory Settings dialog 274
Revert to NORMAL template 274

rhinestones
digitizing 804
placement machines 829
production type 806

Ring objects
changing size 410
moving boundary 410
reshaping objects 410

Ring tool 297, 462
Rotate

tool 399
Left 45° tool 399
Right 45° tool 399

rotating objects 398
by an exact amount 399
by click-and-drag 398
motifs in Motif Fills 529
on screen 398
patterns on-screen 531
Program Split patterns 

on-screen 482
using a reference line 399
using a reference line and angle 400

rounding corners, Column C 342
runs

Run tool 205, 206, 440, 755, 801
automatic connectors 354
Backtrack and Repeat 331
creating offset objects 305
overview 351
sequins 762
travel runs 361

runtime analysis 164
configuring 165

printing 169

S
same size, objects 397
sample

motifs, Motif Fill 530
patterns, Program Split 481

satin
Satin tool 211–215, 347, 585
appliqué cover stitch 745
applying Auto Split 347
automatic spacing 211
Satin Raised tool 585
setting stitch count 215
splitting long stitches 347

Save
Design tool 50, 665, 670
Hoop As dialog 908
Options dialog 882–883
Pattern dialog 785

Save As
dialog 273
Monogram Template command 273, 

624
PDF command 88, 135, 837
Teamname Template command 273, 

604
Template dialog 102

Save to Embroidery Disk dialog 887
saving

CSD format 883
designs 50
Melco CND format 882
object properties to a template 272

scale factor 696
scaling objects

by click-and-drag 395
enlargement drawing scale 175
make same size 397
on screen 395
to an exact size 396
using Object Properties panel 396
using reference points 397

scanning
artwork 687
color mode 685
resolution 685
setting up scanners 170
sharpening 686
tips 686

scrolling, set automatic scrolling 143
Sculpture Run tool 205, 207
searching, for threads 96
segments

adjusting overlap 256
Complex Fill objects 254

Select
Select Current tool 74
Select Object tool 377, 381, 792, 820, 

821
Select By Color dialog 383
Select By Stitch Type dialog 383
Select Fabric Pattern dialog 288
Select Machine Format dialog 47, 

185, 759, 782
Select Object tool 53, 69, 74, 562

Select Source dialog 170
Select Tools

Freehand Select 53
Polygon Select 53
Polyline Select 53
Select Current 74
Select Object 53, 69, 74, 377, 381, 

562, 792, 820–821
selecting objects

by color 382
by stitch type 383
current object 74
grouping 379
resequencing by selection 389
while traveling 74
with Polygon Select 53
with the Color-Object List 54
within groups 381

selecting stitches 425
by needle point 425
several stitches 425
single stitch 425
while traveling through a design 427
with the Stitch List 426

selection handles, scaling 392
Selects On/Off tool 428
Send PDF via Email command 88, 135, 

837
Send to

CAMS Machine dialog 830
Connection Manager dialog 830
Stitch Manager tool 879

Send to Appliqué Cutter
dialog 753
tool 752

Send to Bling Cutter
dialog 827
tool 827

Send to Connection Manager
dialog 830, 878
tool 132, 199, 829

Sequence
by Color command 389
by Color tool 389
by Number command 391
by Selects tool 389

sequence
automatic 388
checking 71
resequencing 384
Sequence By Color dialog 389
traveling 71

Sequence toolbar
Back 1 Color 387
Back 1 Object 386
Forward 1 Color 387
Foward 1 Object 387
Move to End 387
Move to Start 387
Sequence by Color 389
Sequence by Selects 389

sequin fills
adding borders 773
adjusting line settings 775
adjusting pattern settings 778
converting to sequin fill 789
creating 770
digitizing 771
reshaping 795

sequin palettes
Sequin Palette Editor dialog 760, 781, 

782
Sequin Palette Editor tool 760, 780
Sequin Palette tool 760–764
setting up 760, 780

sequin runs
adjusting spacing and fixing 

orientation 767
automatic 762
changing sequins and fixing 

stitches 764
creating 762
drop-stitch direction 768
manual 762
scale/reshape 792
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Sequin Run Auto tool 762, 783, 789
Sequin Run Manual tool 762
twin-sequin runs 783
twin-sequins 780

Sequin toolbar
Clear Function 801
Drop Sequin 801
Left Sequin 799
Manual Sequin 799
Right Sequin 799
Sequin Edit 792–795
Sequin Fill 771–789
Sequin Palette 760–764
Sequin Palette Editor 760, 780, 781
Sequin Run Auto 762, 783, 789
Sequin Run Manual 762
Vectors to Sequins 790

sequins
changing 764
converting artwork 790
digitizing individual 799
functions, inserting 802
sequin drops, digitizing manually 799
Sequin Edit tool 792–795
Sequin Fill tool 771–789
sequin mode 758
Sequin Pattern dialog 783, 791
sequin-capable machine, 

selecting 759
serial devices, recommended 

settings 163
serial devices. recommended 

settings 156
Serial Port Setup dialog 163
Set Color dialog 96
sets

motif, modifying 538
settings

Always Check Design Integrity 152
changing display 75
Cross Hair Cursor 151–152
Cumulative Stitch Count 152
other options 152
pointer position display 147
Run Small Stitch Filter on Output 152
Show Design Source 152

Setup menu
Convert TrueType Font 638

shapes
baselines, reshaping 568
block digitizing 249
digitizing 238
digitizing using block digitizing 249

Shaping Tools
Back-Front 421
Combine 419
Divide 423
Exclude 421
Flatten 423
Front-Back 421
Intersect 421
Keep Original Objects 424
Overlap 423
Weld 419

shared folder 188
shared folders 191
shortening

Shortening tool 344
See also stitch shortening

Show
Appliqué Fabric tool 741
Background Image toggle 291
Bézier Handles tool 404, 408
Bitmaps tool 140, 688, 729
Drawing tool 418
Embroidery tool 40

Entry/Exit Points tool 363, 405
Functions dialog 437
Functions tool 761
Graphics as Dimmed tool 140
Grid tool 56, 141
Guide tool 451
Needle Points tool 425
Product tool 76, 291, 675
Repeats tool 83, 713
Reshape Nodes tool 404–408, 495
Rulers and Guides tool 56, 141, 142
Stitch Angles tool 333, 405
Vectors tool 140

Show Bling
tool 810, 813
Work Area tool 810, 813, 829

Show Hoop tool 899, 905–910
Show Needle Points tool 755
Show Stitches

dialog 438
toolbar 761

Show Vectors tool 707, 709, 713
Simple Offsets

dialog 304
tool 303

simple offsets 303
skewing objects

by click-and-drag 401
by exact angle 401
patterns on-screen 531
Program Split patterns 

on-screen 482
Skew tool 401
with rotation handles 401

smart corners
cap corners 339
Cap Corners tool 338–339
Lap corners 340
Lap Corners tool 338–339
mitre corners 340
Mitre Corners tool 338–339
round corners, Column C 342
setting values 339

Smart Design
Smart Design tool 718
Instant Smart Design tool 718
Keep Original Objects tool 719
Smart Design dialog 719

smooth
Smooth Curves command 712
Smooth Curves dialog 712
joins, creating 248
smoothing freehand lines 451

snap to grid 142
Some Bling Remaining dialog 832
spacing

Accordion Spacing 458
objects evenly 394
offset, Auto Spacing 212
open spacing (color blending) 460
open spacing (Trapunto) 456
Space Evenly Across tool 394
Space Evenly Down tool 394
using Auto Spacing 211

Special
Appliqué 737–746
Bitmap 693
Column C 244–246, 343
Complex Fill 255–256
Fusion Fill 255–257
Lettering 546–550, 556, 558–576, 

580–582, 591–597, 614, 638–653
Photo Flash 726
Travel Run 361
Vector 705

Spiral Contour 500

Spiral Fill tool 226, 504, 505
Split

Object command 430
Object tool 430
Palette Color tool 285

splitting
combination splits 477
lines 485
objects 430
using Auto Split 347
using split lines 485

Square tool 465
stabilizing, with auto underlay 319
Standard

Export Machine File 881
Standard contour 500
Standard toolbar

Copy 376
Cut 376, 384
Export Multi-Decoration Files 890–

895
Import 709
Import Embroidery 374, 674
Import Graphic 688, 707, 729
New 49
Open 665, 670
Open Design 48, 51
Open Recent 48
Options 138–152, 248, 663–669
Paste 376, 384
Print 835
Print Preview 87
quick reference 932
Save Design 50, 665, 670
Send to Appliqué Cutter 752
Send to Bling Cutter 827
Send to Connection Manager 157, 

192, 829, 878
Show Drawing 418

Star objects, reshaping 409
Star tool 297
starting

the software 36
Status Line, measurements 59
stemstitch

Stemstitch tool 208
settings 208

stipple
Stipple Backstitch tool 227, 454
Stipple Fill tool 227, 454
Stipple Stemstitch tool 227, 454
creating textures 227, 454

stitch angles
Remove Stitch Angles tool 332
Stitch Angles tool 332
adding 333
adding to Complex/Fusion Fill 332
adjusting 333
Complex Fill/Fusion Fill 255
defining for Complex Fill 251
turning stitches, Column A 247

Stitch Edit tool 425–443
Stitch Effects toolbar

3D Warp 534–535
Accordion Spacing 458
Auto Jump 349
Auto Underlay 320–325, 370, 598
Cap Corners 338–339
Flexi Split 515
Florentine Effect 510–513
Fractional Spacing 344
Jagged Edge 452, 587
Lap Corners 338–339
Liquid Effect 512–514
Mitre Corners 338–339
Pull Compensation 327–328
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Radial Fill 508
Shortening 344
Trapunto 456
User Defined Split 485

Stitch List
Stitch List tool 426–438
filtering by function 437
Stitch List docker 360, 426–438
using 437

Stitch Manager
Stitch Manage dialog 880
Send to Stitch Manager tool 879

stitch patterns, with carving 
stamps 486

Stitch Player
dialog 71
tool 71

stitch recognition 861
advanced options 863

stitch shortening
applying 344
overview 343

Stitch Shortening Settings dialog 345
Stitch toolbar

Generate Stitches 236
Process Stitches 334, 444
Selects On/Off 428
Split Object 430
Stitch Edit 425–443

stitch types
Backstitch 208
Contour 225, 498, 499–502
Cross Stitch 229, 468
Double Square 468
E Stitch 221
E stitch 221
Island Coil Fill 467
Motif Fill 223, 526, 528, 530, 532
Motif Run 223, 518–521
Program Split 224, 476, 476–481, 

587
Run 204, 205, 206, 755
Satin 210, 211–215, 347, 585
Satin Raised 210–215
Sculpture Run 205, 207
Spiral Fill 226, 504, 505
Square 221, 465
Stemstitch 208
Stipple 227, 454
Stipple Backstitch 227, 454
Stipple Stemstitch 227, 454
Tatami 217
Triple Run 205, 207
Triple Satin 215
Zigzag 221

stitch values
Auto Spacing (Satin) 211
backstitch 219
guide runs (appliqué) 742
length (Tatami) 217
setting Tatami offsets 471
setting Tatami values 217
tacking (appliqué) 743

stitches
appliqué cover 745
appliqué tacking 743
changing display color 78
Contour stitch values 502
digitizing run stitches 238
editing 429
estimating total 95
generating 236
keep/omit last stitch 247–249
Manual 440
multiple run counts (Triple Run) 207
preserving with Auto Jump 349

reversing direction 330
reversing stitch direction 330
selecting 425
shortening 343
show/hide 138
travel runs 361
traveling by 72
See also editing stitches
See also selecting stitches

stitching
removing layers 299
sequence 71
sequence, see also sequence

stitching designs
Send to Connection Manager 

tool 157, 192, 829, 878
Send to Stitch Manager dialog 880
Send to Stitch Manager tool 879
using Connection Manager 878
using Stitch Manager 879
See also Stitch Manager

Stream mode, digitizer tablets 172
strengthening auto underlays 319
String stitch 228, 462
styles

applying 268
applying favorites 268
assigning favorites 271
creating new style 269
make object properties current 263
modifying 270
overview 268

Styles toolbar
Apply Current Properties 263
Apply Style 268
favorite styles 268
Make Properties Current 263

Switch to CorelDRAW Graphics tool 40, 
709

Switch to Wilcom Decoration tool 37
switching

between fill and outline 234
system preferences

automatic backup 146
automatic save 146
setting 138

T
Tablet Setup dialog 175–176
tacking

digitizing appliqué 737
setting values 743

Tag
Tag as Appliqué tool 735
Tag as Photo Flash tool 715, 725
Tag Fill as Turning Satin tool 541, 715

Tajima twin-sequin-capable 
machine 780

tatami
Tatami Fill Object tool 722
Tatami Fill Object with Holes tool 722
Tatami stitch type 475
Tatami tool 217, 472, 475, 586
backstitch 219
Borderline backstitch 220
density 217
diagonal backstitch 220
offset fractions 472
offsets 471
partition lines 473
random factor 475
random patterns 475
stitch length 217
stitch spacing, length and minimum 

length 217

values 217
Team Names

dialog 602
Import Team Members 604
Manage Teams 604
Matrix 619
tool 606–611, 615–618

team names 601
Create Layout Set dialog 609
Create Teamname Layout dialog 609
creating 601
creating separate designs 618
designs, saving 621
Name Order dialog 602
outputting designs 618
See also names
Teamname Layouts dialog 606
Teamname List dialog 619

Team Names docker
Teamname Matrix 619

Teamname List
dialog 612–619
docker 606

Teamname List tool
Apply To All 614
Create Designs 614
Object Properties 614
Remove 602, 614
Select All 602, 614
Sort Ascending 603, 614
Sort Descending 603, 614
Teamname Matrix 614

Teamname Matrix
dialog 620
tool 619

templates
creating 273
deleting 274
modifying 274
NORMAL 272
reverting to original 274
saving object properties 272
selecting products 291
using the NORMAL template 49

text, editing lettering 558
textured fills

creating 515
stippling 227, 454

third-party applications 692
thread charts

copying colors 99
creating 98
modifying threads 96, 100

thread charts, manage 96
thread colors 275

assigning 92
copying across thread charts 99
creating thread charts 98
matching 700
matching to image 700
modifying threads 96, 100

threads
brands 101
code 101
color matching 700
density 101
finding 96
searching for 96
thickness 212
type 101
types 212

tie-ins
overview 352
setting automatic tie-ins values 355

tie-offs
adding 358
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methods 356
overview 352
setting automatic tie-off values 356
setting automatic trim values 357
Tie Off tool 358

toolbars
Toolbars menu 43
showing/hiding 42

Toolbox
Add Borders 295
Color Blending 460
Lettering 545–552, 558, 568–574, 

579, 580, 588–594, 611, 638–652, 
672, 674

Monogramming 624–632
Open Offsets tool 310
Outlines & Offsets 305
Select Object 74
Simple Offsets 303
Team Names 615

total stitch count, estimating 95
Traditional Digitizing

Backtrack 801
Column A 499
Column B 499
Complex Fill 510–512
Complex Turning 251–257

Traditional Digitizing toolbar
Backtrack 331
Column A 247–248, 441
Column B 249
Column C 242–245, 342
Complex Fill 251–256, 462, 526
Complex Turning 251–257
Digitize Run 462
Manual 440
Repeat 331
Ring 297, 462
Run 440, 801
Star 297
Triple Manual 440
Use Motif 518

Transform by Reference Line
dialog 397, 400
Freely tool 399
Numerically tool 397, 400

Transform toolbar
Mirror by Reference Line 402
Mirror Horizontal 402
Mirror Vertical 402
Rotate 399
Rotate Left 45° 399
Rotate Right 45° 399
Skew 401
Transform by Reference Line 

Freely 399
Transform by Reference Line 

Numerically 397, 400
transforming objects

letters on screen 565
mirroring (reference line) 402
rotating (reference line and 

angle) 400
scaling (reference points) 397

Transparent backgrounds, images 690
Trapunto

tool 456
overview 456

Travel
1 Stitch tool 430, 801
by Object tool 74
by Segment tool 430

travel runs 361
Travel toolbar

Travel 1 Stitch 430, 801
Travel by Object 74

Travel by Segment 430
traveling

selecting objects while traveling 74
selecting stitches 427

trims
adding 358
overview 352
Trim tool 359
trims functions 179

Triple Manual tool 440
Triple Run

creating offset objects 305
repeating stitches 207
tool 205, 207

Triple Satin 215
TrueType fonts 637

conversion stitch methods 642
converting complete alphabets 638
converting to embroidery fonts 637

TrueType fonts, converting to 
embroidery 543

TrueView
Options dialog 139
show/hide 138
thread thickness 138

Turning Auto Fabric
Off dialog 264
On dialog 264

Turning Satin Object tool 722
turning stitches

applying fractional spacing 344
applying stitch shortening 344
Column C 245
Contour 498
corner fractions 245
digitizing with Column A 247

turning-off
automatic tie-ins 355
automatic tie-offs 356
automatic trims 357
fractional spacing 344
pull compensation 327

TWAIN scanners 170
Twin Device - Select Sequin dialog 802
twin-sequins

adjusting runs 783
creating runs 780
setting up patterns 781

two-color alphabets 592

U
underlay

Underlay dialog 598
See also Auto Underlay

ungrouping objects 379
Ungroup tool 379, 654

Unlock All tool 380
unlocking objects 380
Update Kerning Settings 

command 594, 595
USB converter 188
USB-capable embroidery machine 188
Use 208
Use Motif tool 518
User Defined Split tool 485
user-refined alphabets 644

V
values

automatic connectors 352
travel runs 361

Vector Fill tool 703
vector graphics

automatic digitizing 702
converting artwork 711
converting to appliqué 735
importing & exporting 707
loading 709
reshaping 712
smoothing 712

vector objects
coloring 704
convert to embroidery 715, 717
creating 703

Vector Outline tool 703
Vectors to Sequins tool 790
View (Design Library) toolbar

Change View 107
Layout 105
Reset Detail Columns 108

View (Manage Designs) toolbar
Design Properties 115

View by Color dialog 80
View Design, Options dialog 139
View Graphics, Options dialog 140
View menu 925
View toolbar

Auto Hoop 902
Auto Start and End 672, 901
Show Appliqué Fabric 741
Show Bitmaps 140, 688, 729
Show Bling 810, 813
Show Functions 761
Show Graphics as Dimmed 140
Show Grid 56, 141
Show Hoop 899, 905–910
Show Needle Points 425, 755
Show Product 76, 291, 675
Show Repeats 83, 713
Show Rulers and Guides 56, 141, 142
Show Stitches 761
Show Vectors 140, 707, 709, 713
Stitch Player 71

viewing
colorways 75
control points 404
information online 8

viewing designs
displaying hidden objects 54
redrawing slowly 71
setting display options 69

Virtual Decoration Quality tool 855

W
Warning dialog 365
warning options 152
Weld tool 419
width, make objects same 397
WiFi network 188
WiFi router 188
WiFi USB Disk Management dialog 196
WiFi USB Setup dialog 192
WiFi USB Stick memory size 196
Wilcom Decoration

File menu 924
window 37

word spacing, changing 549
worksheets, see production worksheets
wreaths

Wreath tool 314
creating 314
kaleidoscope effect 314

X
X and Y coordinates, setting 392
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Z
Zigzag

Zigzag tool 221
using with boring holes 440

zipped designs, viewing in folders 109
Zoom

1-1 tool 64
Zoom Factor dialog 65
Zoom Factor tool 65
Zoom tool 64
to Fit tool 64
to Selected tool 64
Zoom To Hoop tool 905
Zoom to Product tool 291, 675

Zoom toolbar
Zoom 64
Zoom 1-1 64
Zoom Factor 65
Zoom to Fit 64
Zoom To Hoop 905
Zoom to Product 291, 675
Zoom to Selected 64

ZSK File Name dialog 152
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