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READ ME

In this chapter:

The DEVONthink Pro advantage 4

Getting started 5

System requirements 5

Installing, updating, uninstalling 5

Version history 7

License agreement 12

Credits 12

DEVONthink Pro is the paperless office for your

Mac. Use DEVONthink Pro to keep all of your

digital documents

notes

images

multimedia files

chat logs

bookmarks

together in one database. Use DEVONthink Pro

to keep all of this information together so that

you have easy access to it. Synchronize your data

between all your Macs on the local network, via

Dropbox, WebDAV or just any mountable disk.

THE DEVONTHINK PRO
ADVANTAGE

WHY DEVONTHINK PRO?

DEVONthink Pro not only stores documents, it is a

flexible, powerful organizational tool that helps you

edit

analyze

organize

find

and archive

those documents.

INTEGRATED WORKSPACE

Unlike the Finder, DEVONthink Pro provides an

integrated environment with all the tools you need

for working with information. Don't waste time

digging through thousands of files. Let DEVONthink

Pro intelligently assist you. And synchronize your

data between all your Macs via direct connections,

Dropbox, WebDAV, or any mountable disk, e.g., a

USB stick.

As a native Mac application, DEVONthink Pro is

also tightly integrated with OS X. DEVONthink Pro

provides a Dock menu, Services menu commands,

and makes optimal use of the Safari web browser

engine.

WHAT CAN YOU DO WITH IT?

DEVONthink Pro is much more than just a

document database. It is the #1 tool for collecting

and organizing info bits and snippets on the

Mac.Use DEVONthink Pro to:

Create text documents, edit them in full screen

mode using all the tools Mac OS X provides and

cross-reference them with Wiki-style or static

links.

Use the Services menu, the Dock menu, the

Dashboard widgets and the Sorter to clip

information and jot down notes.

Integrate Web content and local documents.

Display all common newsfeed formats and clip

important news directly to your database.

Store frequently used images.

Take advantage of DEVONthink Pro's file indexing

feature to catalog CD/DVD-ROMs without

storing them in the database.

EDITIONS

We offer DEVONthink in multiple editions

optimized for home/semipro and heavy-duty

professional use. You can find a feature comparison

on our web site.

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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GETTING STARTED

DEVONthink Pro is a powerful application that

may require time to fully master. Open the Support

Assistant to read tips, tricks, and tutorials. Install

pre-made templates and scripts that extend

DEVONthink Pro's functionality.

Other helpful resources are our company blog,

where we publish timely news and, sometimes, even

public betas, and our lively user form.

Continue here:

Visit our company blog

Visit our user forum

SYSTEM REQUIREMENTS

Mac with 64-bit CPU, 2 GB of RAM, and OS X

Mavericks 10.9 or later. In addition, we recommend

a broadband Internet connection.

INSTALLING, UPDATING,
UNINSTALLING

Note: The following procedures do not apply

when you have purchased DEVONthink Pro

on the Mac App Store. Installing, updating,

and uninstalling are handled by the App Store

application in this case.

INSTALLING AND UPDATING

Move the DEVONthink Pro application package

to the Applications folder or any preferred

directory. Please note that Mac OS X Services and

the connection to DEVONagent work only for

applications installed into the Applications folder,

and that logout and login or a restart is required

after installation.

To update an existing version of DEVONthink Pro,

simply copy the application package from the disk

image to your Applications folder, replacing the

old version. Your database(s) will not be affected.

http://www.devontechnologies.com/redirect.php?id=blog
http://www.devontechnologies.com/redirect.php?id=forum
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If you purchased DEVONthink Pro in the Mac App

Store you can also download the update from the

DEVONtechnologies website. It will retrieve the

existing receipt and accept it as valid license.

BUYING AN UPGRADE

If would like to upgrade DEVONthink Pro to a

higher edition, you have the following options:

Choose DEVONthink Pro > Check Upgrade Options.

The second option may or may not be available

depending on whether you have purchased

DEVONthink Pro in DEVONtechnologies' online

shop or in the Mac App Store.

UPGRADING TO DEVONTHINK PRO (OFFICE)

When upgrading from DEVONthink Personal

to DEVONthink Pro, the application will copy

your existing DEVONthink Personal database

to your documents folder ('~/Documents/

DEVONthink.dtBase2').

If this fails to occur automatically, do the following:

1) Copy the complete folder "~/Library/Application

Support/DEVONthink 2" to your Desktop, and

2) Rename the folder and add the filename suffix,

".dtBase2" (without quotes). The folder has now

become a DEVONthink Pro database icon, which

you can double-click.

If your old database was created by DEVONthink

Personal 1.x, it will be the folder named

"DEVONthink" at "~/Library/Application Support/".

Follow the instructions as above, but in this case

use the filename suffix ".dtBase" (no quotes, but

case is important). The folder has now become a

DEVONthink Pro 1.x database. From DEVONthink

Pro choose File > Open Database and select the

resulting database file. You will be offered the

opportunity to convert the database to a new

DEVONthink Pro 2.x database. Choose "Accept,"

and you now have a converted DEVONthink Pro 2.x

database.

Note: We don't recommend installing both

DEVONthink Personal and DEVONthink Pro

on the same machine. Among the reasons

why: Both applications use the same Services

menu shortcuts, and Mac OS X would assign

the shortcuts sometimes to DEVONthink

Personal, other times to DEVONthink Pro. And

DEVONagent stores contents in DEVONthink

Pro if it's available, which means contents would

not be stored in DEVONthink Personal.

DOWNGRADING TO DEVONTHINK PERSONAL

If you want to downgrade from DEVONthink Pro

to Personal, copy the database you want to use to

"~/Library/Application Support" and rename it to

"DEVONthink", removing the file name extension

".dtBase2". The database package becomes a

regular folder and will now be used by DEVONthink

Personal.

UNINSTALLING

To remove (uninstall) DEVONthink Pro completely

from your Mac, trash the following files and folders

(~ stands for your Home folder):

DEVONthink Pro

~/Library/Application Support/DEVONthink Pro 2

~/Library/Preferences/com.devon-

technologies.thinkpro.*

All DEVONthink Pro-specific scripts in ~/Library/

Scripts/

All DEVONthink Pro-specific workflows in ~/

Library/Workflows/

All DEVONthink Pro-specific scripts in ~/Library/

PDF Services/

Dashboard widgets

Bookmarklets from your web browser

The reference to the global inbox folder in your

Finder's sidebar

http://www.devontechnologies.com
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VERSION HISTORY

VERSION 2.9.4

Improved (Sync):

Sync store reliability.

Fixed (Sync):

Issue where WebDAV authentication could fail on OS X10.10 (or later) with passwords containing special

characters.

Crash related to sync stores.

VERSION 2.9.3

This maintenance release brings a large number of sync-related reliability improvements and bug fixes. For

example, the sync toolbar buttons indicate unsynced changes, and due to better chunking of static and small

items synchronizing to sync stores requires less bandwidth, less disk space, fewer files, and is up to 3.7 times

faster. Long location labels are truncated in the middle now. In addition, DEVONthink Pro 2.9.3 allows to send

documents via Airmail 3, sorts databases in contextual menus alphanumerically, and provides more data when

dragging items to third-party applications. Sending feedback creates a traditional message in the default email

client again instead of opening a web form.

NEW:

Data > Send by Email and Help > Report Bug support Airmail 3.

'.rst' (ReStructured text) added to list of known plain text extensions.

Improved:

The submenus of contextual menus sort databases now alphanumerically, the global inbox always located at

the top.

Help > Contact sends messages via the default email client again instead of opening a web form.

Drag-and-drop provides more data to third-party applications, e.g. to Tinderbox.

Moving multiple items to another database doesn't cancel the operation in case of a duplicate UUIDs

anymore; the items with duplicate UUIDs are now skipped.

Improved (Sync):

Dot added to Synchronize and Synchronize All toolbar items indicating unsynchronized changes, similar to

DEVONthink To Go.

Long location labels in Preferences > Sync are truncated in the middle now.

Progress indication now includes, if possible, the database name too.

After disabling synchronization of a database, the date of the last synchronization is still displayed.

Reliability of Bonjour connections and Bonjour timeout handling.

Better resolving of Bonjour services; addresses have a higher priority than host name and port again.

Better handling of Bonjour templates, e.g. in case of varying host names.

Bonjour servers are automatically restarted with a different name in case of a conflict.

More aggressive chunking of static and small items in sync stores; requires less bandwidth, less disk space, and

fewer files, and speeds up sync-store-related operations up to 3.7 times.

More precise chunking of items to avoid memory peaks on iOS.

Obsolete files and manifests of sync stores, e.g. incomplete uploads, are deleted right after successfully

completing an upload.

http://airmailapp.com
http://airmailapp.com
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Reliability of creating sync stores.

Reliability of committing downloads from sync stores.

Uploading to sync stores now always checks whether the database contains pending items and cancels the

synchronization in that case.

Dropbox conflict handling.

Timeout and cache handling of WebDAV requests.

Canceling WebDAV requests on OS X 10.10 (or later) and iOS.

Error handling for local sync stores.

Overall performance and memory management.

Fixed:

Issue where editing preferences, e.g. spell checking, weren't applied after toggling Markdown view.

Issue where reloading a modified web archive didn't save the changes.

Issue where the Sorter always created RTFD notes even if the rich text didn't contain any attachments.

Crash of the Sorter after removing a group if the full visibility is disabled in Preferences > Sorter.

Fixed (Sync):

Issue where Bonjour and sync store synchronizations of the same database could happen concurrently on the

server.

Issue where deletions while importing databases could be skipped in case of interrupted commits.

Issue where RTFD documents without attachments, created by the Sorter, weren't readable anymore outside

of DEVONthink for Mac after synchronizing.

Issue where no error was displayed after entering wrong WebDAV credentials on OS X 10.10 (or later) and

iOS.

Issue where trashing non-empty groups did not always successfully delete the group so that empty groups

could remain in the trash (especially on iOS).

Issue where the Activity window wasn't always closed after synchronizing in the background.

Issue where the progress indication while downloading from sync stores wasn't correct.

Crashes related to (unreliable) Bonjour connections.

VERSION 2.9.2

This maintenance release brings several improvements related to synchronization. Pending records can be

found using smart groups and the advanced search and a button to synchronize all databases can be added to

the toolbar. Finder tags are now immediately updated after a sync, self-signed HTTPS certificates for WebDAV

are again accepted, and Bonjour connections are handled smarter. The update also improves the overall sync

performance and reliability.

NEW:

Smart group and advanced search condition Instance is Pending for finding items not yet downloaded by sync.

Synchronize All item that can be added to toolbar.

Improved:

Finder tags of indexed items are immediately set, e.g. after adding tags on iOS.

More reliable uploads to and downloads from sync stores in case of interruptions, e.g. due to an unreliable

network.

Bonjour locations prefer host name and port now. After a failure to open a Bonjour connection, the service is

resolved again.

Canceling of Dropbox requests.
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Multi-threading of sync store operations.

Compatibility to HTTP proxies.

Overall reliability of sync.

Handling of process activity disables system sleep and prevents sudden or automatic app terminations.

Fixed:

Issue where pending records could be moved between databases, breaking the connection to the original sync

locations.

Issue where new WebDAV locations didn't accept invalid HTTPS certificates.

Issue where tags were not added to notes being sent from the Sorter to global inbox.

Issue where server volumes could be mounted twice for local sync stores in rare cases.

Issue where an incorrect file name provided by iOS was used.

Issue where the number of missing entries reported by quick verification of sync stores was usually too high.

Issue where old sync betas where not correctly removed.

VERSION 2.9.1

This maintenance release brings a large number of improvements and bug fixes related to synchronization.

In addition DEVONthink Pro now allows you to select and delete ink annotations in PDF documents and

supports a number of new XML file name extensions. The update enhances drag-and-drop for formatted notes

and makes downloading from sync stores up to 2.5 times faster. The update also improves the overall sync

performance and reliability.

NEW:

Ink annotations in PDF documents can be selected and deleted.

The content of DEVONagent searches (.agentSearch) is now indexed and can be converted to plain text.

.dita, .ditamap, and .ditaval added to known XML extensions.

Hidden preference AdditionalXMLExtensions for specifying additional XML files types.

Hidden preference SyncDebugLog for enabling additional logging.

Improved:

Trying to move an item to a database containing already the same UUID now logs an error.

Free-world variant of DEVONthink Pro no longers uses scripting to add the Sorter to the startup items.

Drag-and-drop support of formatted notes editor.

Revised Bonjour resolving. Fewer timeouts, faster connection building, more reliable.

Bonjour sync locations use the host ID instead of the host name. More reliable e. g. after switching networks.

Bonjour submits errors (e.g. a read-only database) to the remote side, e.g. to DEVONthink To Go 2.

Downloading from sync stores up to 2.5 times faster.

Information about local databases in Preferences, Sync tab.

Databases can't be uploaded anymore to new sync stores in case of pending items to prevent the sync store

from containing only metadata.

Committing of deletions and metadata changes.

Handling of sync locations and templates.

Handling of invalid sync store encryption keys.

Former temporary directories are deleted on startup.

Console logging.

Fixed:

Issue where an empty Activity window wasn't always closed after synchronizing.
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Issue where error messages were inconsistent, e.g. after accessing a sync store with the wrong encryption key.

Issue where failing to finalize a WebDAV template removed the template; it can now be edited again.

Issues where errors while finalizing a sync template could be still displayed after deleting the template.

Issue that caused remote databases of local sync stores still listed in Preferences, Sync tab after unmounting the

volume.

Issue where indexed items located in cloud folders were downloaded endlessly from sync stores if Synchronize

contents of indexed items wasn't disabled.

Issue where indexed items located in cloud folders were marked as pending after downloading the database.

Issue where Bonjour servers remained busy after opening a connection but never receiving any data.

Issue that could cause rare Bonjour-related crashes.

Issue caused by Dropbox sometimes returning original paths, sometimes lower case paths.

Issue where the records cache could cause inefficient commits.

Glitches of progress indicators.

VERSION 2.9

This release brings a completely rewritten synchronization. It replaces the synchronization introduced with

DEVONthink Pro 2.5 with a much more flexible and reliable model. It will also be used to communicate with the

upcoming DEVONthink To Go 2.0. The next-generation sync supports synchronizing databases directly via the

local network, any mounted volume, WebDAV and Dropbox. All communication is encrypted if an encryption

password is provided.

Note: The next-generation sync is NOT backward-compatible. It is necessary to delete existing sync stores

and re-synchronize the databases.

In addition this release adds conversion of .emlx email messages to HTML and formatted notes, better handles

large selections, and improves the thumbnail handling. The update also fixes several bugs and improves

performance and reliability.

Note: Starting with this version DEVONthink Pro requires OS X Mavericks or later.

NEW:

NEXT-GENERATION SYNCHRONIZATION.

Email messages (.emlx) files containing HTML content can be converted to HTML and formatted notes and are

supported by website export. Requires OS X Yosemite or later.

Navigation toolbar item of main windows supports text-only mode.

Added '.ips.beta' to list of known plain text extensions.

Improved:

Handling of selections with thousands of items made up to 2000 times faster.

Renamed template Address Book Card to Business Card and template folder Addresses & Dates to Contacts &

Events.

Renamed Help > Bookmarklets to Help > Extensions & Bookmarklets.

Clipping web pages as rich text or formatted note strips unnecessary headers created by Instapaper's

reformatting.

The default plain text font is now Menlo Regular 11pt.

Thumbnails of very long PDF pages, e.g. captured web pages, are now scaled to width.

Thumbnails of images with opaque alpha channel are stored as JPEG files and use much less space than

before. Speeds up the synchronization and reduces sync store size.

Search syntax is removed before copying search queries to find pasteboard so that Edit > Find > Find Next/

Previous can be used more often immediately.
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Handling of tab stops of plain text views.

User agent compatibility of Download Manager.

Missing indexed files/folders located on unmounted volumes aren't reported anymore by Tools > Verify &

Repair.

AppleScript support.

VoiceOver support.

Parsing of '.DSStore' files.

Handling of background tasks.

Error handling.

Fixed:

Thumbnails of PDF documents, e.g. merged images, sometimes used the wrong size.

Text of .emlx files wasn't indexed and .emlx files couldn't be converted to plain text on OS X Yosemite.

Glitches of token fields in HUD windows.

Glitch of Info panel.

Corrupted '.DS_Store' files could crash DEVONthink Pro.

Memory leaks.

Removed:

Obsolete Scripts > Reminders > Add as To Do to TaskPaper.

VERSION 2.8.11 ... 1.0.1

Skipped.

VERSION 1.0

Initial release.
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LICENSE AGREEMENT

PLEASE READ THIS LICENSE CAREFULLY

BEFORE USING THIS SOFTWARE. BY USING THIS

SOFTWARE, YOU ARE AGREEING TO BE BOUND

BY THE TERMS OF THIS LICENSE AGREEMENT.

IF YOU DO NOT AGREE TO THE TERMS OF

THIS LICENSE, DELETE THE SOFTWARE OR

RETURN THE SOFTWARE AND RELATED

DOCUMENTATION TO DEVONTECHNOLOGIES,

LLC.

1. License: The application and other components

(sound and graphics) accompanying this License,

whether on disk, in read only memory, or on

any other media (the "Software"), and the

related documentation are licensed to you by

DEVONtechnologies. You own the disk on which

the Software is recorded but DEVONtechnologies

and/or DEVONtechnologies' Licensor(s) retain

title to the Software and related documentation.

This License allows you to non-simultaneously use

the Software on multiple computers by the same

person.

2. Restrictions: The Software contains copyrighted

material, trade secrets and other proprietary

material and in order to protect them you may

not decompile, reverse engineer, disassemble

or otherwise reduce the Software to a human-

perceivable form. You may not sub-license, modify,

rent, lease, or create derivative works based upon

the Software in whole or in part. You may not

distribute the Software in any form, including,

but not limited to, electronic information service

distribution, bulletin board distribution, and

magnetic or optical medium distribution.

3. Disclaimer of Warranty on Software: You

expressly acknowledge and agree that use of the

Software is at your sole risk. The Software and

related documentation is provided "AS IS" and

without warranty of any kind.

4. Limitation of Liability: UNDER NO

CIRCUMSTANCES INCLUDING NEGLIGENCE,

SHALL DEVONTECHNOLOGIES BE LIABLE FOR

ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL

DAMAGES THAT RESULT FROM THE USE

OR INABILITY TO USE THE SOFTWARE OR

RELATED DOCUMENTATION. In no event shall

DEVONtechnologies' total liability to you for all

damages, losses and causes of action (whether in

contract, tort (including negligence) or otherwise)

exceed the amount paid by you for the Software.

Apple, Carbon, Classic, Cocoa, ColorSync, Darwin,

Mac OS X, QuickTime, Quartz and all other

registered names are trademarks of their respective

owners.

CREDITS

AMINDETERMINATEPROGRESS

Copyright © 2007 Andreas Mayer. All rights

reserved.

Redistribution and use in source and binary forms,

with or without modification, are permitted

provided that the following conditions are met:

Redistributions of source code must retain the

above copyright notice, this list of conditions and

the following disclaimer.

Redistributions in binary form must reproduce the

above copyright notice, this list of conditions and

the following disclaimer in the documentation

and/or other materials provided with the

distribution.

Neither the name of the copyright holder nor the

names of its contributors may be used to endorse

or promote products derived from this software

without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED. IN

NO EVENT SHALL THE COPYRIGHT OWNER OR

CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,

OR CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS

OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND

ON ANY THEORY OF LIABILITY, WHETHER

mailto:andreas@harmless.de
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IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF

THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

REGEXKITLITE

Copyright © 2008 John Engelhart. All rights

reserved.

Redistribution and use in source and binary forms,

with or without modification, are permitted

provided that the following conditions are met:

Redistributions of source code must retain the

above copyright notice, this list of conditions and

the following disclaimer.

Redistributions in binary form must reproduce the

above copyright notice, this list of conditions and

the following disclaimer in the documentation

and/or other materials provided with the

distribution.

Neither the name of the Zang Industries nor the

names of its contributors may be used to endorse

or promote products derived from this software

without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED. IN

NO EVENT SHALL THE COPYRIGHT OWNER OR

CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,

OR CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS

OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND

ON ANY THEORY OF LIABILITY, WHETHER

IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF

THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

MULTIMARKDOWN

Copyright (c) 2010-2014 Fletcher T. Penney

MultiMarkdown is released under both the GPL and

MIT licenses. You may pick the license that best fits

your needs.

Modifications to remove reliance on Glib2:

Copyright (c) 2011 Daniel Jalkut, licensed

explicitly MIT.

LyX export code (c) 2013-2014 Charles R. Cowan,

licensed under both GPL and MIT licenses.

Portions based on: peg-markdown. Copyright (c)

2008-2011 John MacFarlane. ODF output code

(c) 2011-2013 Fletcher T. Penney. peg-markdown

is released under both the GPL and MIT licenses.

You may pick the license that best fits your needs.

Original Markdown specification by John Gruber.

The GPL: This program is free software; you can

redistribute it and/or modify it under the terms of

the GNU General Public License as published by

the Free Software Foundation; either version 2 of

the License, or (at your option) any later version.

This program is distributed in the hope that it will be

useful, but WITHOUT ANY WARRANTY; without

even the implied warranty of MERCHANTABILITY

or FITNESS FOR A PARTICULAR PURPOSE. See the

GNU General Public License for more details. You

should have received a copy of the GNU General

Public License along with this program; if not, write

to the Free Software Foundation, Inc., 51 Franklin

St, Fifth Floor, Boston, MA 02110-1301 USA

The MIT License: Permission is hereby granted,

free of charge, to any person obtaining a copy of

this software and associated documentation files

(the "Software"), to deal in the Software without

restriction, including without limitation the rights

to use, copy, modify, merge, publish, distribute,

sublicense, and/or sell copies of the Software, and to

permit persons to whom the Software is furnished

to do so, subject to the following conditions:

The above copyright notice and this permission

notice shall be included in all copies or substantial

portions of the Software. THE SOFTWARE IS

PROVIDED "AS IS", WITHOUT WARRANTY OF

ANY KIND, EXPRESS OR IMPLIED, INCLUDING

BUT NOT LIMITED TO THE WARRANTIES OF

MERCHANTABILITY, FITNESS FOR A PARTICULAR

http://daringfireball.net/projects/markdown/
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PURPOSE AND NONINFRINGEMENT. IN NO

EVENT SHALL THE AUTHORS OR COPYRIGHT

HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES

OR OTHER LIABILITY, WHETHER IN AN ACTION

OF CONTRACT, TORT OR OTHERWISE, ARISING

FROM, OUT OF OR IN CONNECTION WITH THE

SOFTWARE OR THE USE OR OTHER DEALINGS IN

THE SOFTWARE.

SPARKLE

Copyright © 2006--2009 Andy Matuschak

Permission is hereby granted, free of charge, to

any person obtaining a copy of this software and

associated documentation files (the "Software"), to

deal in the Software without restriction, including

without limitation the rights to use, copy, modify,

merge, publish, distribute, sublicense, and/or sell

copies of the Software, and to permit persons to

whom the Software is furnished to do so, subject to

the following conditions:

The above copyright notice and this permission

notice shall be included in all copies or substantial

portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT

WARRANTY OF ANY KIND, EXPRESS OR

IMPLIED, INCLUDING BUT NOT LIMITED TO

THE WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL

THE AUTHORS OR COPYRIGHT HOLDERS

BE LIABLE FOR ANY CLAIM, DAMAGES OR

OTHER LIABILITY, WHETHER IN AN ACTION OF

CONTRACT, TORT OR OTHERWISE, ARISING

FROM, OUT OF OR IN CONNECTION WITH THE

SOFTWARE OR THE USE OR OTHER DEALINGS IN

THE SOFTWARE.

VIDEO JS

Copyright © 2010 Zencoder, Inc.

The Video JS player is used according to the LGPL

v3.

http://zencoder.com/
http://www.gnu.org/copyleft/lesser.html
http://www.gnu.org/copyleft/lesser.html
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COMMON TASKS

In this chapter:

Analyze text documents 15

Browse the Internet 15

Capture data from the web 16

Catalog your SD cards or DVDs 17

Catalog your photos and MP3 files 17

Collect text snippets and other valuable data 18

Index files on your hard disk 18

Manage your bookmarks 18

Share project data 19

Read newsfeeds 19

Take notes 20

Write texts and outline projects 20

In this chapter you'll find a number of common

ways you can use DEVONthink Pro for everyday

tasks, from surfing the Internet and making notes to

cataloging photos and archiving emails.

ANALYZE TEXT DOCUMENTS

With its built-in artificial intelligence (AI) functions,

DEVONthink Pro can be used to analyze large

numbers of text documents.

The Concordance function allows you to create a

list of all the words contained in a database, sorted

by frequency and restricted to a given length.

The Search and Similar buttons open drawers that

feature all documents containing words that are

contextually similar to the selected word (these

searches happen almost instantly). A search toolbar

item lets you find any word of interest.

Other functions that help you analyze documents

include the AI-enhanced search function that also

features a list of similar words based on spelling

or contextual similarity. The See Also button lists

documents with a similar content, and the topics

pop-up menu displays the most important words

of a document. Duplicate documents are instantly

marked in blue and bold.

Replicants and cross-links help you create a

network of documents.

Possible uses:

Analyze the complexity and focus of a specific

document collection

Find relationships between documents or snippets

quickly

Clean up large collections of documents

Continue to read here:

Import documents from the file system

Use the See Also & Classify drawer

Use the AI-enhanced Search function

Use the Concordance drawer

BROWSE THE INTERNET

Besides being a knowledge and information

database, DEVONthink Pro acts as a web browser.

This extends the document-based approach to

knowledge to the World Wide Web. Because

DEVONthink Pro is a database manager, its web

browser does not work in a windowed style like

Safari or DEVONagent Pro; rather, it's document-

oriented.
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This enables you to treat web pages the same way

as you treat documents. Whenever you select

a web document (bookmark), DEVONthink Pro

immediately loads and displays its content live

from the Internet in the view/edit pane. You can

then archive the complete page to the database for

offline viewing.

DEVONthink Pro also handles RSS/RDF/Atom news

feeds, either through feed documents or by simply

displaying them via the built-in web browser. Stay

up-to-date with your subject and clip important

information right away.

Possible uses:

Visit frequently used web sites in a convenient

interface

Integrate "live" content from the web with your

other documents

Grab data from web sites and store it in

DEVONthink Pro

Capture and archive complete web pages

Continue to read here:

Capture data from the Web

Create a new URL or HTML document

View "live" and local HTML pages

Integrate news feeds with your data

CAPTURE DATA FROM THE WEB

Increasingly, information is provided not on paper

but directly through Web sites, blogs, online news

sites, Facebook, and user forums. DEVONthink

Pro offers a variety of options for conveniently

capturing data from the Web:

Bookmark: Captures only the address (URL,

uniform resource locator) of the page.

HTML page: Saves the source code of the page to

the database, but images are downloaded from

http://www.facebook.com
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the Web each time the page is displayed in the

database.

Web archive: Saves both the HTML code and all

resources, like images, necessary to display the

page.

Rich text: Grabs selected text/images and

hyperlinks, but avoids saving unwanted areas of

the page to the database. A plain text capture will

not include formatting, images or links.

PDF: 'Freezes' the web page, just like printing to

paper. PDFs from Web pages can be paginated or

non-paginated.

All of these options, except the bookmark, capture

the text content of the page (or a selected area of

it) and hyperlinks if present, and preserve the text

information for searches in DEVONthink Pro.

Note: There are a number of Web sites that

prohibit use of some of the capture options

described above. A secure banking site or

a university portal to journals may direct a

Bookmarklet or script capture option to the

login page, which will be captured instead of

the desired content. A capture option that

requires re-download of the page on such sites

will capture only the login page. The page always

can be selected and captured as rich or plain text.

The viewed page can be captured by "printing" it

as PDF to the database.

Possible uses:

Capture important news in an easily searchable

database

Collect all relevant data for your project in one

place

Collect links to web pages and captured data about

the same subject in one group

Save data from the Web in future-proof formats

such as PDF

Continue to read here:

Capture data using Services

Capture data using scripts

Capture data with Bookmarklets or browser

extensions

Add the global inbox to the Finder's sidebar

'Print' any Web page or document as PDF to your

database

CATALOG YOUR SD CARDS OR
DVDS

By using the Index function, you can use

DEVONthink Pro to set up a catalog for your data

DVDs, SD cards, or other removable volumes.

Create a group for each disk by using the index

function, and organize your disks/groups in any way

you like. When you need a specific file, search for it

in DEVONthink Pro, insert the volume, ⌃ click the

file in DEVONthink Pro, and select Open With to

open the original file on the removable volume.

Possible uses:

Find files even when they're on a removable

volume that is not currently mounted

Create a virtual library for our SD cards and other

media

Integrate static documents with other project-

related data

Continue to read here:

Import or index files

Search your database

Launch the original file of an index item

CATALOG YOUR PHOTOS AND
MP3 FILES

Besides storing text documents and PDF files,

DEVONthink Pro also manages multimedia data

such as photos, illustrations, MP3s or movies.

While not designed to replace iPhoto or iTunes,

DEVONthink Pro can be used as a repository for

images you frequently use or as an interface to

your MP3 library (if you don't like other music

software). If you do not want to import these files,

leave them where they are in the file system. You

can index the files instead and access them from

within DEVONthink Pro See also p. 34ff

Possible uses:

Create a dedicated database for photos only

View your images in full screen mode

Keep project-related images and other documents

together

Play your MP3s from within your work

environment
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Continue to read here:

Import or index files

View files as thumbnails

View images and movies

Search your database

COLLECT TEXT SNIPPETS AND
OTHER VALUABLE DATA

Using Mac OS X's handy Services menu,

DEVONthink Pro is the premiere tool for collecting

and organizing information bits and snippets.

Select any piece of data and capture it to the

currently open database with a keystroke or a quick

visit to the Services menu. All Cocoa applications

such as TextEdit, Safari, or DEVONthink Pro itself--

as well as many new Carbon applications, e.g. the

Finder or Microsoft Office 2004--support this

mechanism. Alternatively, drag text clippings to the

Sorter panel.

DEVONthink Pro automatically sets the title of the

newly created snippet to the first line of text, so

there's a good chance that you won't even need to

rename it. New snippets are always created in the

inbox. Also, DEVONthink Pro can automatically

classify and file the items using its built-in artificial

intelligence.

Possible uses:

Collect recent news from your favorite web sites

Keep important information from any source and

your other project-related documents together

Create an info collection for a specific topic

Continue to read here:

Capture a note quickly using the Services menu

Use the Dock menu

Use the Sorter

Drag text clippings to the Groups panel

INDEX FILES ON YOUR HARD DISK

Besides completely importing documents,

DEVONthink Pro can also index files. When

indexing files, DEVONthink Pro reads the contents

of the file and stores it for internal reference, yet

it always uses the external file for displaying the

actual contents. Use indexing for easily accessing

information stored on removable volumes, creating

a library of all important documents regardless

where they are physically stored, or integrating

files stored elsewhere with your documents in

DEVONthink Pro.

Possible uses:

Access information from all your SD cards in one

place

Create a front-end for your document collection

Integrate static documents with other project-

related data

Continue to read here:

Import or index files

Search your database

Launch the original file of an indexed item

MANAGE YOUR BOOKMARKS

With its integrated, document-based web browser,

DEVONthink Pro can be used as a bookmark

manager. Organize all your bookmarks as bookmark

documents and visit the website simply by

selecting the bookmark in split or three panes view.

DEVONthink Pro loads the page and displays it in

the view/edit pane.



DEVONthink Pro 2.9.4 Documentation, page 19

If you want to open the Web page in your default

browser, simply ⌃ click (right-click) the bookmark

and choose Launch URL from the contextual menu.

Possible uses:

Manage your bookmarks

Keep project-related web pages and other

documents together

Visit frequently used web sites in a convenient

interface

Integrate "live" content from the web with your

other documents

Grab data from web sites and store it in

DEVONthink Pro

Continue to read here:

Create a new bookmark document

View "live" and local HTML pages

Drag URLs to the Groups panel

Drag URLs to the Sorter

Share your bookmarks with others using sync

SHARE PROJECT DATA

With its built-in synchronization DEVONthink Pro

is ideal to manage a shared project workspace. Keep

all your project-related data in an easy to structure

database and share it with your team members. Use

a shared WebDAV volume, your Dropbox, a local file

server, or direct connections to propagate new data

in the team automatically.

Possible uses:

Organize project files, use advanced feature such

as tags and smart groups

Add new data from any team member's computer

or even iOS device running DEVONthink To Go

Integrate "live" data, e.g. web pages or newsfeeds,

with your other documents

Continue to read here:

Set up sync to share data with your team members

Add smart groups to organize data automatically

Add newsfeeds

READ NEWSFEEDS

DEVONthink Pro comes with built-in support for

RSS, RDF, and Atom news feeds, which makes it a

reliable basic news reader. In addition, its integrated

web browser supports news feeds and displays

them like any other web page. Use its document-

oriented structure to organize bookmarks and store

news feeds like Internet-updated smart groups.

Mix live news feeds with static documents, e.g., in

your project materials.

Possible uses:

Read your daily news in a convenient interface

Integrate "live" newsfeeds with your other

documents

Grab interesting information easily and store it in

DEVONthink Pro

Continue to read here:

Create a new bookmark or HTML document

View "live" web pages and news feeds

Create a news feed document
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TAKE NOTES

DEVONthink Pro is perfectly suited for taking notes

and organizing them.

Use DEVONthink Pro's Take Note panel or its Dock

menu to quickly create new notes, write notes using

the advanced text editing capabilities of Mac OS X,

and find a place to file them in your database using

the Classify & See Also button.

Possible uses:

Write down ideas before they vanish

Take quick phone messages

Keep project notes and your other project-related

documents together

Continue to read here:

Create new documents

Create a new note using the Dock menu

Revise notes and documents using the built-in rich

text editor

Organize your data using Classify and See Also

WRITE TEXTS AND OUTLINE
PROJECTS

With its hierarchical group structure, organization,

and navigation functions, as well as its advanced

text editing capabilities based on the Mac OS X text

engine and the full screen mode DEVONthink Pro is

perfectly suited for writing text from notes to whole

books.

Create new documents with just one click, find

related documents, and network them with Wiki-

style or static cross-links. Because you are working

with databases in DEVONthink Pro, you can switch

from one document to another with just one click,

and manage even large projects with ease.

By flagging groups and documents DEVONthink

Pro can also be used as a simple outliner. Unlike

other outliners, DEVONthink Pro uses documents

as items and groups for items that have sub-items.

Use it with the Split view to create an outliner look-

and-feel.

Possible uses:

Write notes, white papers, and letters

Write and organize book chapters

Organize your ideas or projects in outlines

Create a network of information for your projects

or interests

Continue to read here:

Create new documents

Use the built-in rich text editor

Choose between various window layouts to match

your work style

Use the See also & Classify drawer

Use the Concordance drawer



DEVONthink Pro 2.9.4 Documentation, page 21

IN & OUT

In this chapter:

Drag and drop 21

Importing and indexing 21

Services 21

Dock menu 22

Synchronizing 23

Synchronizing with DEVONthink To Go 1.x 25

Extensions and bookmarklets 25

Dashboard widget 27

Sorter 27

Capturing paper 29

Third-party applications 31

DEVONthink Pro is not an island. It integrates with

the rest of your Mac and iOS devices in a variety

of ways to make it easy for you to add data to

DEVONthink Pro.

DRAG AND DROP

The easiest way to add data to DEVONthink Pro,

other than creating the documents directly inside

the application, is to drag files or selected data, e.g.

text, images, etc., into a DEVONthink Pro window or

onto its Dock icon.

Dragging files into a document list imports the file;

dragging text or images creates documents for

them. Dragging files into a rich text document adds

them as attachments to the document. Dragging

data to the Dock icon creates new documents in the

default destination.

Hold the ⌘Command key while dragging to

effectively move the file or folder into the database.

DEVONthink Pro imports the dragged item and

puts the original into the Finder trash. This works

identical to File > Import > Files & Folders with the

option Move originals to trash enabled.

IMPORTING AND INDEXING

You import files with drag-and-drop or using the

File > Import menu item. Imported files are copied

into the database and appear as a document in

DEVONthink Pro's interface.

If you need to keep the files in their original location,

but want to use them inside of DEVONthink Pro,

drag them with ⌘ and ⌥ pressed (like making an

alias in the Finder) or use File > Index. A reference

to the file is inserted in your database and linked

to the original outside DEVONthink Pro. Use File >

Update Indexed Items  to update selected references

when their original has changed. Make sure to keep

the original file in place so that the link between

reference and file stays intact.

When to import and when to index files? Importing

copies the data directly into your database, creating

a self-contained repository that remains intact

whether you back up the database or copy it to a

USB stick. But if you also need to access the files

rom outside the database, e.g. to compile some

source codes, you may want index them instead of

importing.

SERVICES

The DEVONthink Pro > Services menu gives you

access to special commands published either by

other applications, such as TextEdit or Safari, or by

services extensions such as DEVONtechnologies'

WordService or CalcService. Also, DEVONthink Pro

publishes its own services in the Services menu.
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DEVONTHINK PRO SERVICES

DEVONthink Pro installs several services for

copying or summarizing selected text, capturing a

web page, or searching documents in the database.

Add to DEVONthink: Adds selected files,

bookmarks, or images to your database. This

service is also available in the Finder's contextual

manu.

Take Plain/Rich Note: Adds selected text to the

global inbox from any application that support

services (!) as plain or rich text. Taking a rich text

note also copies images and clickable links. If the

source document is a web page or a news feed,

DEVONthink Pro tries to capture the address

of the page or feed as well. This only works with

applications that support this feature, such as

Safari, DEVONagent Pro, or NetNewsWire.

Capture Web Archive: Captures the web

page displayed in the frontmost window of

any WebKit-based browser (such as Safari

or DEVONagent Pro) as a web archive to

DEVONthink Pro's inbox. This menu item is only

shown when available, e.g., when Safari is the

active application.

Append Plain/Rich Note: Adds selected text as

plain or rich text to the last note taken using the

DEVONthink Pro Services menu items.

Lookup: Opens the Search windowin DEVONthink

Pro with the selected text copied as search term.

Summarize: Creates a new note in DEVONthink

Pro's inbox with a summary of the selected text.

DEVONthink Pro uses all documents in the open

database for determining what's important

and what's not. The summarization settings in

the preferences, Editing tab, define whether

the summary shall be based on sentences or

paragraphs.

THE SORTER SERVICES

The Sorter adds another sub-menu to the Services

menu that contains a Send To Inbox command. If

possible, it copies the current selection to the

Sorter's inbox.

Note: After installing DEVONthink Pro you need

to log out, then back in again for new services and

their shortcuts to be recognized. If one or more

DEVONthink Pro Services menu commands do

not carry a shortcut, it may be because another

application grabbed them. Mac OS X will assign

the shortcut if no other application already uses

the same key combination.

DOCK MENU

The Dock menu appears when you click DEVONthink

Pro's icon in the Dock with the ⌃ key pressed, when

you right-click it, or when you left-click it and hold

the mouse button for one second or longer.

Use the Dock menu commands Import and Index

to import or index files. Copy something to the

Clipboard and use New with Clipboard to directly

create a document with the Clipboard contents

anywhere in your open databases. DEVONthink Pro

will try to create a meaningful name for it. Finally,

choose Take Note to open the Take Note panel.

http://www.newsgator.com
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SYNCHRONIZING

DEVONthink Pro is not an island. It allows you to

synchronize your databases over the internet or on

the local network with Macs running DEVONthink

2.9 oder later and DEVONthink To Go 2.0 or later.

The build-in synchronization is highly optimized

for transferring databases securely and fast. Direct

connections between two devices are always

encrypted using AES 256 bit. Sync stores (see

below) are also encrypted using AES 256 bit if you

enter an encryption password (recommended).

We highly discourage simply moving a DEVONthink

database to e.g. a cloud drive (like Dropbox,

iCloud Drive, or OneDrive) and trust the cloud

drive provider's app to do the right thing.

Databases are complex packages and not made for

concurrent access or simple file syncs. The build-in

synchronization uses a container format built for

synchronizing over a variety of channels including

direct connections, local volumes, or internet-based

file services.

Please find a short glossary about sync-related

terminology in the Appendix.

SCENARIOS

Local network (Bonjour): If you only want to

synchronize your databases while all participating

devices are on the same network consider using a

direct connection.

This is much faster than uploading all data to some

server on the internet and downloading it again on

another device. But, when you leave your office and

you haven't synchronized your databases, you'll

need to wait until you come back another day.

Local sync store: For synchronizing only between

Macs you can also use a shared volume, from USB

stick to file server. A sync store (a dedicated folder

on the volume) is used as the (optionally encrypted)

central hub to and from which all participating Macs

synchronize. For this model the volume needs to be

accessible from all Macs during sync time.

iCloud Drive: It is possible to sync between Macs

using iCloud Drive. DEVONthink Pro will create a

local sync store in the iCloud Drive's local folder

and let iCloud manage the actual data transfer. Due

to limitations on iOS this sync mechanism is not

available for synchronizing with DEVONthink To Go

2.

WebDAV: If you run your own WebDAV server, your

ISP offers it as a service (e.g. Deutsche Telekom),

or your have subscribed to an online service such

as CloudMe or box.com, this might be for you.

Your data is stored in encrypted sync stores on the

server. You can keep all your devices in sync at any

time as long as you have internet access.

Dropbox: If you have a Dropbox account you can

use it just like you'd use WebDAV. DEVONthink

Pro creates a private folder for its sync stores

and so keeps its data separate from your photos

and other documents. Of course it does not get

access to anything except its own files. Dropbox and

DEVONtechnologies respect your privacy.

SETTING UP SYNC WITH A SYNC STORE

You set up which databases are synchronized,

how often, and with which locations in Preferences,

Sync tab. The basic workflow for setting up

synchronisation looks like this:

Step 1: Decide if you want to sync automatically,

on a schedule, or manually. Choose the maximum

number of connections and how sync conflicts

are solved. You find the options for this at the

bottom of the Sync preference pane.

Step 2: Add a sync location from a template by

checking its checkbox in the left-hand part of the

pane. Alternatively click the + button to e.g. add

https://en.wikipedia.org/wiki/WebDAV
http://magentacloud.de
http://www.cloudme.com
https://box.com
http://www.dropbox.com
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a local or iCloud Drive sync store. Fill out all the

required details. See also p. 89ff

Step 3: Select the location and check all local

databases that you want to sync using this

location. This uploads the database to the sync

store and so makes it available to all other devices

using the same service and sync store.

To use the databases you have added to a sync store

on other devices, you need to import them on the

other side:

Mac: Set up the exact same sync location with the

same name also on the other Mac. Then follow

the instructions below.

iOS: Set up the exact same sync location with the

same name in DEVONthink To Go. Show the

location's databases and 'switch on' a database to

import it.

Should your database (identified by its unique ID,

NOT its name) already exist, DEVONthink Pro will

ask if you want to merge the remote and the local

copy.

Note: If you are using Dropbox and the Dropbox

app, it is advisable to exclude the DEVONthink

Packet Sync folder inside the Apps folder from

being synchronized with your Mac. This keeps

the Dropbox app from wasting valuable disk

space and bandwidth by re-downloading all

changes you've made to your databases, and

from spamming you with notifications. Click

the Dropbox icon in the menubar, choose

Preferences, switch to the Accounts tab, click

Selective Sync, select the Apps folder, and uncheck

the DEVONthink Packet Sync folder inside of

it. Click Update to confirm your change. If you

change your Dropbox email address, you'll need

to remove and re-add the Dropbox location.

SETTING UP DIRECT CONNECTIONS

For the most part, direct connections are treated

like other sync locations. The main difference is that

for every connection one side acts as the host and

the other side connects as a client. You can connect

to the host from as many devices as you like, e.g., to

use the same research database in a team.

You set up your Mac as potential host or add direct

connections as locations in Preferences, Sync tab.

Set up the host:

Step 1: On the host, click Bonjour Options.

Step 2: Check Enable incoming connections to allow

incoming connections from other computers.

Check Open databases automatically to make

DEVONthink Pro open available databases

automatically when they are requested by the

client for synchronizing.

Step 3: If necessary, change the port number

on which your Mac is listening for incoming

connections. Leave empty to let your Mac decide

(recommended).

Step 4: Enter a password that clients need

to provide to connect to DEVONthink Pro

(mandatory).

Step 5: Click OK.

Set up the client:

Step 1: The host should appear as location

template on the client, in Preferences, Sync tab on

the Mac respectively in Settings > Locations: Edit

Locations > (location name).

Step 2: Add the host like any other location; you'll

need to provide the password entered on the

host in step 4.

Step 3: Done. You can now proceed, e.g., import

the desired database.

IMPORTING A DATABASE FROM REMOTE

To download a database from a sync store or

directly from another Mac or iOS device, you import

it from the sync location.

Step 1: Set up the location containing your

database.

Step 2: Expand Remote the list section if necessary.
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Step 3: Select the remote database you want to

import.

Step 3: Click the  Import icon or choose Import

database in the contextual menu or the  Action

menu below the databases list.

Step 4: Select where to save the database locally,

best in your Documents folder or together with

your other databases.

INDEXED FILES

Indexed files, i.e. documents whose files reside

outside of the database package, are synchronized

to the exact same locations on all computers.

Example: A document's file is located at "~/

Documents/SomeFile.txt" (where "~" represents

your home folder). The file will also appear in the

synchronizing user's "Document" folder on other

Macs.

You can choose to not synchronize the content

of indexed files but only their metadata. If you

are accessing such a metadata-only item and

you are synchronizing via direct connection you

can download the content file on demand. If you

are using a sync store, e.g. on a WebDAV server,

downloading is only possible if the uploading side

synchronizes with Synchronize contents of indexed

items activated. With this option switched off,

indexed files are never deleted from disk too.

TROUBLESHOOTING

If you have problems synchronizing DEVONthink

Pro databases click here. If you experience other

problems not covered in this documentation, please

visit our online forum or contact our support team.

SYNCHRONIZING WITH
DEVONTHINK TO GO 1.X

Note: DEVONthink To Go 2 uses the sync

mechanism described above. Version 1.x,

however, uses its own proprietary sync

mechanism. If you are still using DEVONthink To

Go 1.x, these instructions are for you.

DEVONthink Pro has the ability to synchronize its

databases with DEVONthink To Go, its companion

app for iPhone, iPad, and iPod touch devices.

Synchronizing with the device: DEVONthink Pro

uses a special group named Sync to let you decide

which data you want to share with your iOS device.

The Sync group appears on the top group level of all

databases and has a special icon that makes it stand

out from other groups. To select the items in your

database that you want to take with you on your

device, either move or replicate them into its Sync

group. You replicate items by dragging them with

the ⌘ and ⌥ keys held. In the global inbox there is

no Sync group; it is always synchronized as a whole.

You can add documents as well as whole groups to

the Sync group. Smart groups are not yet supported

and will be ignored during synchronization.

Make sure your device is on the same Wi-Fi

network as this computer. On the device open the

DEVONthink To Go app, tap the sync button on the

app's home screen, and follow the instructions.

Visit the App Store: If you do not yet have

DEVONthink To Go installed on your device, learn

more about it or visit the App Store. If you have

problems synchronizing with DEVONthink To Go

1.x click here.

EXTENSIONS AND
BOOKMARKLETS

DEVONthink Pro provides a sharing extension

(requires OS X Yosemite or later), a web browser

extension, as well as bookmarklets for conveniently

clipping information from other applications into

your DEVONthink Pro database.

Sharing extensions: Let you "share" data with

other applications or web services such

as Twitter and Facebook. Extensions are

mainly intended for the sandboxed App Store

environment where applications can no longer

easily communicate with each other.

Web browser extensions: Add functionality to

your favorite web browser. Usually they appear

as icons in the web browser's toolbar.

Bookmarklets: Special bookmarks that do

not load a saved address, but execute a little

JavaScript application that adds a bookmark

to the current page in your DEVONthink Pro

database or creates a web archive of a page.

http://www.devontechnologies.com/redirect.php?id=forum
http://www.devontechnologies.com/redirect.php?id=contact
http://www.devontechnologies.com/redirect.html?id=buy-dttg
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Basically, bookmarklets use your web browser's

bookmark function for creating handy shortcuts

for application functions.

INSTALLATION

The sharing extension is automatically available

in all applications that support it as soon as

DEVONthink Pro is installed. You may need to

activate it using the More option in the sharing

menu.

Install the Clip to DEVONthink extension for Safari,

Firefox, and Chrome from within DEVONthink Pro

with the menu command DEVONthink Pro > Install

Add-Ons. You may need to activate it from your

browser's preferences or extension settings.

To install bookmarklets, visit our Downoad Extras

web page with your preferred browser. Drag a

bookmarklet from the page to your web browser's

bookmarks, preferably the bookmark bar. You

can organize the bookmarklets like any other

bookmarks, but placing them into the bookmark bar

keeps them handy at all times.

USING THE EXTENSIONS

Regardless whether you use the sharing extension

from an application's  sharing menu, the Clip

to DEVONthink browser extension, or the Clip

to DEVONthink bookmarklet, DEVONthink Pro

presents you with the following window:

The Clip to DEVONthink bookmarklet or extension

is often the best choice as it uses a special panel in

DEVONthink Pro that lets you enter a title along

with a note and tags, and lets you choose in which

format you want to save the clipped data. The note

is either saved as a plain or rich text document,

formatted note, or is, in the case of a bookmark,

HTML document, web archive, or PDF, placed into

the comments field of the created document.

The Clip to DEVONthink panel checks if the web

page address you're going to add already exists

in your open databases. If it does it shows a little

DEVONthink Pro icon next to the destination popup

menu. Clicking the icon reveals the first found item

with this URL. Check Reformat with Instapaper to

reformat the text of the page using Instapaper.

The New Group button creates a new group in the

destination group selected above.

Note: If you purchased DEVONthink Pro in the

App Store, the standard "sharing" dialog window

appears. Click Post to send the clipped data to

DEVONthink Pro.

USING THE BOOKMARKLETS

To use one of the other bookmarklets, load any page

that you wish to archive or clip text from in your

web browser. When the page is fully shown, select

the bookmarklet in your bookmarks bar. Instead of

loading another page as normal bookmarks do, the

bookmarklet adds the selected text or the whole

page as text, bookmark, HTML code, web archive, or

PDF to DEVONthink Pro's default destination.

http://www.devontechnologies.com/redirect.php?id=download-extras
http://www.devontechnologies.com/redirect.php?id=download-extras
https://www.instapaper.com
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DASHBOARD WIDGET

DEVONthink Jot allows you to take notes and send

these to DEVONthink Pro's default destination right

from the Dashboard.

The front of the widget is where you can type your

note's message. Click into the writing area to make

the insertion caret appear. Enter any tags below the

note taking area. Click the Take Note button to save

the note to your database.

You can also flip the widget front to back by clicking

the i button that appears when you move the mouse

into the lower left corner of the widget. The back of

the widget lets you choose your preferred font. This

preference is saved and will be used whenever you

open the widget again. Click Done to flip the widget

back to the front view.

SORTER

The Sorter is a helper application that lets you add

files or selected text or images to your databases

even when DEVONthink Pro is not open. It appears

as a small ⇥ attached to the left, bottom, or right

border of the screen that serves as a drop target for

files and clippings.

Like a sorter in the post office, the DEVONthink Pro

Sorter consists of multiple (drop) boxes. The first

box is always the global inbox; all other boxes you

can connect to any group in any of your databases.

When you drop files or clippings onto a box, the

Sorter files it in the connected group. Should the

database containing the connected group not be

available, e.g., because DEVONthink Pro is not

open, the Sorter stores the dropped data until the

database is opened, and then flushes the contents of

the box.

In addition, you can use the Sorter to quickly add a

note to DEVONthink Pro even when it is not open.

POSITIONING THE PANEL

To position the Sorter panel, drag the tab to any

position along the left, bottom, or right borders

of your desktop or laptop screen, except for the

border where the Dock is located (even when it is

hidden). To open the panel, click the tab; to close it,

click the tab again. Resize the Sorter panel using the

resize gadget in the lower left or lower right corner.

(Note: The location of the resize gadget depends on

whether the Sorter is attached to the left or right

side of the screen.) The size of the boxes stays the

same, but enlarging or reducing the panel size adds

or hides boxes.

Alternatively, you can show the Sorter with a list

instead of square boxes. Use the  and  icons at

the bottom to switch between the two. You can set

different sizes for both modes.
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CONNECTING BOXES

To connect a box to a group, open the desired

database and drag the group from the item list of

a main window to an empty box in the Sorter. The

box is labeled with the group's name, the group's

icon is shown as a ghost image on the background of

the Sorter box, and its tool tip (which appears when

you point at it with the mouse for more than one

second) shows the name of the database containing

the database, as well as its path.

Drag a box by its title to move it to a new position in

the Sorter's box grid; move it out of the Sorter panel

to remove its connection.

Alternatively, use the contextual menu (opens when

you right-click or click with ⌃ held) to open a window

for the connected group in DEVONthink Pro or to

remove the connection. Double-click a box to open

the connected box in DEVONthink Pro.

USING THE PANEL

To add items to a Sorter box, simply drag the file

or clipping to the Sorter's tab. The panel extends

automatically and you can drop the item on

whichever box you choose.

Dragging items to the Sorter copies them. Drag

with ⌘ pressed to move the item; drag with ⌘ and

⌥ pressed to add only a reference of the item to

DEVONthink Pro (index). For URLs dragged from

a browser this creates a bookmark; hold ⌘ and

⌥ to create a web archive instead. Only files can

be moved to the Sorter; folders and clippings are

always copied. For items dragged from DEVONthink

Pro, the Sorter behaves similar to the Groups & Tags

panel.

If the database the box is connected to is not

available, the Sorter preserves the data for you.

Move the mouse horizontally over the box to skim

through the dropped items, just like in iPhoto

"Events". Drag the shown item to the Trash to

remove it. Alternatively, use the contextual menu to

remove it. When a database is open, the Sorter files

the contents of the box automatically and plays a

sound to notify you.

When the database is available, nothing shows up in

the box because the Sorter sends all items directly

to DEVONthink Pro and plays the notification

sound.

ADDING NOTES

Switch between the sorter boxes and the take note

panel by clicking the  icon located at the bottom of

the Sorter panel. Click the   or  icon to switch

back to the Sorter boxes.

On the take note panel, choose the destination

for the new note in the pop-up menu at the top

of the panel. (DEVONthink Pro offers all groups

available as sorter boxes) and enter title, URL, and

your note. You can add tags at the bottom if desired

and choose the desired format. The Sorter uses the

standard font and size set in DEVONthink Pro's

Preferences, Editing pane, for rich text. The text

area also accepts drag-and-drop of plain and rich

text clippings. Click the Save button to save the note.

ACTION MENU

The Action menu located at the bottom of the Sorter

panel offers some handy commands. Use the Action

menu to open the Sorter's Preferences, flush all

boxes (automatically opens DEVONthink Pro and

all databases that are needed), or quit the Sorter.

When the Sorter is closed, use the Preferences or

the Dock menu to show it again.

HOTKEYS

The Take Note and Copy Selection shortcut that

you can set in the Sorter Preferences allow you to

open the Sorter in take note mode or to capture a

selection in another application and save it to the

Sorter's inbox. The latter works in the same way as

the Sorter's Send To Inbox command in the Services

menu.

SHORTCUTS

Command-Option: Creates a web archive instead

of a bookmark when dragging a URL.

Command-M: Minimizes the Sorter panel.

Command-S: Saves the note (in take note mode).
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Escape: Closes the Sorter or clears the quick note

entry field.

TROUBLESHOOTING

Re-appears after log-in: If you have set the Sorter

preferences so that it should not open automatically

when you log-in but it still does so, open the System

Preferences, Users section, Log-in Items tab.

Remove the Sorter manually.

Edit 'Hide' settings: If you accidently told the Sorter

(not to) hide when an application goes to full-screen

mode and now you want to change this behavior,

do the following: First quit the Sorter, e.g., by using

its action menu. Then, open the Terminal application

(located in /Applications/Utilities) and copy the

following line into a new window, followed by the ↩
key:

defaults delete com.devon-
technologies.think-sorter
UserSpecifiedFullScreenApplications

This makes the Sorter forget its hiding settings and

you can set them anew.

CAPTURING PAPER

DEVONthink Pro comes with built-in support for

Image Capture compliant scanners.

To capture paper using an Image Capture compliant

scanner open the Image Capture window using File >

Import > From Scanner or Camera. It is divided into a

sidebar and a main pane, which changes depending

on your selection in the sidebar. The options in the

sidebar are arranged from top to botton according

to a typical scan workflow: Scan, check the scanned

pages, arrange the pages in a document, and save

them to the database.

If you are using a scanner with an automatic

document feeder (ADF), you can also use a Queue

to prepare a pile of sheets for batch processing and

scan them in one go.

DEVICES

Select your connected scanner or camera in the

Devices section of the sidebar to run a scan or

download images. Note: iPhones, iPads, and iPods

are treated like cameras. The main pane shows

the standard capture interface that Apple Image

Capture uses.

Choose the scan destination in the To pop-up

menu. Either send the scan directly to any of your

databases, add them as single files to the Scans &

Images section, or choose any document that you

have created in the Document section.

Scanners: DEVONthink Pro generates an overview

scan of the current page in the scanner, and allows

you to select which parts of the page you want

to capture and set the scan options. Click Scan to

capture the page.

Cameras: DEVONthink Pro shows the available

images. Select the images you want to import, rotate

them if necessary, and click Download or Download

All to download the images to your computer. You

can also delete images from your camera with the

Delete button.

Note: To conveniently scan multiple pages into a

new document, choose PDF or TIFF as file format

check Combine into single document, and enter a

document name as file name. DEVONthink Pro

automatically creates a new empty document

with this name and appends each scanned page

until you either send the document to your

database or enter a new name. When Combine

into single document is checked, DEVONthink Pro

disables the To menu.

http://support.apple.com/kb/ht3669
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SCANS & IMAGES

This is where scans or images downloaded from

your camera appear. Select images to set their

properties, edit (crop, rotate), play downloaded

movies, or delete.

If you do not need to collect multiple pages into a

single document, all you need to do is set the scan's

properties and send it to your database. In the

properties window, choose a destination group (the

global inbox is set by default) and enter title and

tags. You can also choose if you want to save this

scan as an image or PDF document. For PDFs you

can also set the author and subject properties. Then

click the Send To button to directly import this scan.

If you are using a single-sheet flatbed scanner and

want to collect multiple pages into one document,

first create a new document using the Documents

button at the bottom of the sidebar, then drag

the pages to the new document in the Documents

section to manually build the document.

DOCUMENTS

Create empty documents here to which you add

your scanned pages. Right-click or click with

⌃Control held to use the contextual menu for

adding or deleting documents. Alternatively, use the

Documents button at the bottom of the sidebar.

Add pages by dragging them from the Scans & Images

to the document in the sidebar. Rearrange added

pages if desired and set the document properties by

clicking the Properties button. This is similar to single

scans in the Scans & Images section. Use the Sort to

reverse the sort order or shuffle pages, e.g., when

scanning all front pages first, then the back pages.

Choose Sort and Merge Documents to merge two

documents where one contains all the odd pages

and the other all even pages.

Note: You cannot save multi-page documents as

images; therefore, PDF is the only option for the

file type here.

TRASH

This is where you find images that you have deleted

from Scans & Images or Documents. Empty the trash

using the Empty button at the bottom of the window

or right-click or ⌃Control-click images to add them

to an existing or new document using the contextual

menu.

QUEUE

If you are using a document scanner with automatic

document feeder, you can use the queue to add

multiple pages or even multi-page documents to the

feeder and scan them in one go.

Choose your scanner in the pop-up menu above

the list. Then use the Add and Delete buttons to add

or delete steps and rearrange them by dragging.

Edit the fields to set a title or tags, or to change the

document type or destination.

To scan a batch of paper, set the Separator either

to Page Count and the number of pages in the

document or to Blank Page to begin a new document

every time a blank page is encountered.

Before starting the batch run, adjust your scan

settings by clicking the Configure button. Then click

the Start button to start scanning. Finished steps are

marked as "Sent". Click Clear Sent to remove them

from the list.
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THIRD-PARTY APPLICATIONS

DEVONthink Pro offers many standard ways to

integrate with third-party apps including drag-and-

drop of common data formats, copy-and-paste, and

AppleScript. In addition DEVONthink Pro comes

with special arrangements for applications often

used together with it.

Bookends: Choose File > Import > References from

Bookends to import Bookends references as rich

text documents with a back link to the original

item in Bookends.

Evernote: Choose File > Import > Notes from

Evernote to import selected Evernote notebooks.

Created notes are backlinked to their

counterpart in Evernote.

Tinderbox: Copy notes in Tinderbox and choose

Data > New > With Clipboard to create a plain or

rich text copies of the notes in DEVONthink Pro

including backlinks and tags.

Yojimbo: Choose File > Import > Items from Yojimbo

to import selected items in Yojimbo. Items

without URL are be backlinked.

http://www.sonnysoftware.com/
https://www.evernote.com
http://www.eastgate.com/Tinderbox/
http://www.barebones.com/products/yojimbo/
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MENUS

In this chapter:

The Application menu 32

The File menu 34

The Edit menu 37

The Data menu 38

The Format menu 41

The View menu 42

The Go menu 44

The Tools menu 44

The Window menu 45

The Services menu 46

The Scripts menu 46

The Help menu 46

The Dock menu 47

A complete listing of all commands DEVONthink

Pro offers in the menu bar, the global Mac OS X

Services menu, and the handy Dock menu.

THE APPLICATION MENU

The DEVONthink Pro menu is similar to the

application menu in any other Mac OS X application.

It contains commands for displaying the splash

screen, opening the Preferences window, accessing

the Services menu, hiding and showing windows, and,

of course, quitting the application.

ABOUT DEVONTHINK PRO, ...

About DEVONthink Pro: Shows information about

DEVONthink Pro including the version number

and licensing information.

Check for Updates: Checks if updates for

DEVONthink Pro are available. By default,

DEVONthink Pro checks for updates

automatically; you can change the update

settings in the Preferences, Update pane.

Note: When checking for updates no information

is uploaded from your computer to the

DEVONtechnologies server. DEVONthink Pro

only downloads a file listing the most current

versions to your Mac. This option is not available

if you have purchased DEVONthink Pro from

the Mac App Store. In this case, all updates are

handled by the App Store.

INSTALL ADD-ONS

This command installs or reinstalls a number

additional files and scripts.

Note: If you purchased DEVONthink Pro in

the Mac App Store, this menu item may not be

available.
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The following options are available:

Application Scripts: Menu extra scripts extending

third-party applications, e.g., Mozilla Firefox or

NetNewsWire.

DEVONthink Pro Scripts: Menu extra scripts

providing system-wide functions.

DEVONthink Jot Widget: Installs the

DEVONthink Jot dashboard widget.

Safari Extension: The Safari extension Clip to

DEVONthink lets you clip web pages to your

database or add links with notes, similar to the

Clip to DEVONthink bookmarklet.

Google Chrome Extension: Opens the Download

Extras page in Google Chrome from where you

can install the Chrome extension (similar to the

Safari extension). You have to do this manually

and follow Google's rules.

Firefox Extension: Opens the Mozilla Add-Ons

page in Firefox where you can install the Firefox

add-on (similar to the Safari extension). You have

to do this manually and follow Mozilla's rules.

PDF Services: Adds an alias of DEVONthink Pro to

the "PDF Services" folder so that you can "print"

directly from any application to your database.

See also p. 92ff

Folder Action Scripts: Scripts that can be

"attached" to folders and are triggered when you

add new items to that folder. Use them to add

incoming files from a networked scanner or a

folder-based workflow to your database. On Mac

OS X 10.6 or later, these folder action scripts can

be directly used in the Finder.

Apple Mail Rule Scripts: Installs the mail rule

scripts for Apple Mail on OS X 10.8 or later.

Choose them for Execute Script action in Apple

Mail's rule editor.

Global Inbox in Save Dialogs: Inserts DEVONthink

Pro's global inbox into the Finder's sidebar and all

"Save As" dialog windows. Use it to save directly

to the inbox from any application. Note: The

name of the inbox is "Inbox" regardless of your

computer's language preferences.

DEVONthink Sorter Helper: A helper application

that launches the Sorter when you log in.

Check your options and click the Install button

to make DEVONthink Pro install or reinstall the

necessary files and scripts into their repsective

locations. If necessary, this command also launches

the AppleScript Utility so that you can activate the

global scripts menu. See chapter Scripts for more

information about how to use these scripts.

In addition, this command removes obsolete files

such as scripts left over from previous versions.

Options for items already properly installed are

disabled and marked as "installed".

Note: On OS X Yosemite or later some browser

extensions are no longer directly installed

but open the web browser's extension gallery

instead.

PREFERENCES, TRASH, AND CACHE

Preferences: Opens the Preferences.

Empty Trash: Moves the contents of the database

trash to your computer's file system trash.

Empty Cache: Empties the web browser cache.

This frees up space and makes sure that all, when

displaying a web page, all data is freshly loaded

instead of using a cached copy.

Note: If Index-captured items are contained in

the database trash when you use Empty Trash,

the option Also from disk will become available. If

chosen, it will send the externally linked files to

the system trash, too. Caution is advised!

http://www.devontechnologies.com/redirect.php?id=download-extras
http://www.devontechnologies.com/redirect.php?id=download-extras
https://addons.mozilla.org/firefox/addon/clip-to-devonthink/
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PURCHASE, ...

Check Upgrade Options: Opens a web page that

lists the upgrade options available for your copy

of DEVONthink Pro.

Purchase License: Opens the DEVONtechnologies

Online Shop and puts DEVONthink Pro into your

shopping cart. If this copy of DEVONthink Pro

is already licensed, you will be presented with

the choice of buying an upgrade for your existing

license or buying another full license.

Enter License: Use this command to enter your

licence code. Make sure you enter ALL the

details EXACTLY as they appear in the licence

code e-mail. It is best to use copy-and-paste for

transferring name, organization, and licence code

from the email message to the appropriate fields.

Note: Make sure that when you highlight the

information to copy and paste, no spaces before

or after the information are highlighted.

Note: Enter License changes into License and

Purchase License into Purchase License or Upgrade 

as soon as you have entered a valid license code

(and a paid upgrade exists). Available options

depend on whether you have purchased your

copy in DEVONtechnologies' online shop or from

the Mac App Store.

SERVICES

The Services sub-menu gives your access to

special commands published by other Mac OS

X applications such as TextEdit or Safari, or by

services extensions such as our own WordService

or CalcService. Also, DEVONthink Pro publishes

its own services. See also p. 46ff

THE FILE MENU

The File menu contains all commands that deal

directly with files in your volumes, databases, or

files that can be imported, exported, or indexed.

Also, the File menu contains commands for printing

documents.

NEW, OPEN, OPEN RECENT

New Database: Creates a new database. Give it

a name and save it wherever you like in your file

system. DEVONthink Pro will add the file name

extension ".dtBase2" to enable the operating system

to recognize it as a DEVONthink Pro database

package (technically a folder).

Open Database: Opens previously created

databases. You can select multiple databases. If

a database has been saved in version 1.x format,

DEVONthink Pro offers to convert it.

Open Recent: Presents a list of recently used

databases, which gives you quick access to your

frequently used databases. Choose Clear Menu to

remove all items from the menu.

NEW WINDOW

New Window: Opens a new main window for an

open database. (If only one database is open, no

sub-menu is available.) DEVONthink Pro windows

present all documents and groups of a database in a

Finder-like fashion, and are used to access all stored

items. Some views also contain a view/edit pane for

easy viewing and editing of documents.

IMPORT

Import: Imports files or complete folders from

your volumes into the database. You can find a

list of all supported file formats in the appendix.

If not stated differently, data is imported to the

default destination. Finder labels, tags, and Spotlight

comments are honored whenever possible.

The flexible plug-in architecture of DEVONthink

Pro allows other import modules to be added.

DEVONthink Pro comes with the following default

import plug-ins:

Contacts: Imports addresses from the Contacts

application as a sheet, as vcards (.vcf), or as

bookmarks. Previously created groups are

reused. Tip: To import all addresses, select all

addresses in the group "All" and import them.

Address card bookmarks link to the original card

in the Contacts application.

Bookmarks: Imports bookmarks from Camino,

Firefox, Google Chrome, OmniWeb, or Safari as

http://www.devontechnologies.com/redirect.php?id=shop
http://www.devontechnologies.com/redirect.php?id=shop
http://www.caminobrowser.org
http://www.mozilla.org
http://www.google.com/chrome
http://www.omnigroup.com
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bookmarks. Only new bookmarks are imported if

you use this command again.

Notes from Evernote: Imports the notebook

selected in Evernote including names, dates,

and tags. Notes are stored as formatted notes.

Already imported notes are not updated again.

The URL of the imported notes links back to the

original notes in Evernote. This option requires

the Evernote app be installed; it is not available in

the App Store variant.

Items from Yojimbo: Imports selected items from

Yojimbo. Imported items retain name, label, flag,

URL, comments, tags and creation/modification

dates. Items without a URL link back to the

original item in Yojimbo. Yojimbo 4.0 and later is

required; this option is not available in the App

Store variant.

References from Bookends: Imports multiple

references from Bookends into a newly created

group named "Bookends". Already imported

references are updated (requires Bookends

11.3.5 or later). The keywords assigned to a

Bookends reference are added to the Document

Properties of the created rich text document.

Use the optional script Scripts > Tags > Convert

keywords to tags to convert the keywords to tags if

needed.

Website: Opens the Download Manager and

downloads a complete web page/site for

archiving and offline viewing. Make sure the

download options are set correctly, especially the

options that define which links DEVONthink Pro

should follow (if any). All links within the site are

modified so that they point to the downloaded

images or other embedded objects. This ensures

that the page/site can be displayed at any time.

By default, groups created by the Download

Manager are excluded from tagging.

From Scanner or Camera: Imports printed

documents from a connected scanner or camera.

See also p. 29ff

Clip to DEVONthink: Opens the Clip to

DEVONthink panel for quickly clipping copied

texts or web addresses.

EXPORT

This sub-menu allows you to export selected

documents or groups to the file system.

Files and Folders: Exports the selected documents

and recreates the hierarchy you have built in

DEVONthink Pro almost exactly. Metadata

files (".DEVONtech_storage") make sure that no

metadata such as comments, URLs, etc., are lost.

DEVONthink Pro reads these files when importing

and recreates your original data structure. If you

don't need the metadata, you can safely delete the

".DEVONtech_storage" files. Exporting also exports

tags in OS X 10.9 Mavericks and OpenMeta formats

(on OS X Mavericks and earlier).

Document: Exports the currently viewed document.

In addition, the Export sub-menu provides export

methods based on plug-ins. DEVONthink Pro comes

with a number of standard plug-ins for exporting

documents in different formats. Currently the

following plug-ins are included:

as Text: Exports the selected items as one large

plain text file. You can choose the desired

encoding.

as RTF Document: Exports the selected items as

one large rich text file without embedded images,

etc.

as RTFD Document: Exports the selected items

as one large rich text file with embedded images,

etc.

as Word Document: Exports the selected items as

one large Microsoft Word file.

as OPML: Exports the selected items as one OPML

file.

as Website: Exports the selected items as

standalone web site that you can upload to

your web server and share with colleagues.

In the appearing dialog window, choose the

desired template, text encoding, and whether

DEVONthink Pro should convert diacritics and

accented characters to HTML entities or not.

Check Create Index Pages to create "index.html"

pages with cross-links to all included documents.

Markdown and formatted notes are rendered to

HTML, other file types that cannot be displayed

in a web browser, e.g., Pages files, are converted

to PDF if possible. Cross-links are converted

http://www.barebones.com/products/Yojimbo/
http://www.microsoft.com/mac/
http://en.wikipedia.org/wiki/OPML
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correctly. For the export templates are used that

you can modify yourself.

as Template: Saves the selected documents as

a template, which can then be used to quickly

create new documents using Data > New >

With Template. To remove a saved template

or to organize your templates in sub-folders,

visit the folder '~/Library/Application Support/

DEVONthink Pro 2/Templates.noindex' in the

Finder, then create sub-folders, move items,

rename them, or trash them. Export multiple

documents and/or groups at once to create e.g. a

project template.

Database Archive: Creates a clean copy of the

frontmost database and compresses it as a .Zip

archive. Back up the copy to any medium or

server to keep your data safe from hardware or

software failures.

For images exported from a separately opened

document window, DEVONthink Pro lets you

choose the desired file format or image quality.

INDEX, UPDATE INDEXED ITEMS

Index: Adds selected files to your database, but only

as references, not in their entirety. DEVONthink

Pro indexes the contents of the file and uses this for

classification and other content-related functions.

Indexed items show a little arrow after their name.

For unknown file types, this command creates a

bookmark. You can also drag files from the Finder to

DEVONthink Pro; hold down the ⌘ and ⌥ keys to

index them. This is similar to creating an alias in the

Finder.

Indexed groups are excluded from tagging by

default and changes to an indexed document

are immediately reflected in its OpenMeta

metadata (and are so noticable by external

tagging applications). By default DEVONthink Pro

automatically updates selected items when they're

shown, e.g. when you show a group's contents.

Sub-groups that are not visible are not updated

automatically, however.

Note: External indexed files or folders located

in "/System/", "/Library/" or "~/Library/" are

never renamed or deleted to prevent users from

accidentally harming the system.

Update Indexed Items: If you need to be sure

everything is up-to-date use his command. If

nothing is selected, the enclosing group of the

current group is used. It also reads changes made

to the Finder or Spotlight comments of the to-

be-updated files and applies the changes to the

files' counterparts in the database. Finally, this

command removes indexed items that have lost

their external counterpart. It does not affect items

moved manually to the group. Use Update Indexed

Items to keep indexed groups and their originating

folders in sync or to manually update an item that

you have changed directly inside the database

package when DEVONthink Pro was not running.

To create this connection between the item in the

database and the folder or file in the file system,

which is maintained by the Path field in the Info

panel, you have to freshly import/index your folder

of choice.

Select the groups and documents and choose File

> Update Indexed Items to import all files that have

been newly added to the connected folders in the

file system.

Note: The update for groups is one-way only,

from the file system to the database. But when

you rename a document, its file is renamed, too,

and when you change the Spotlight comments of

a document this is reflected in the file system, as

well.

SYNCHRONIZE

Synchronize: Synchronizes the selected database

with all its locations. If the database is not yet set

up for synchronization this command opens the

Preferences, Sync tab.

Download Pending Files: Downloads the files of

selected documents if they are available through

one of the database's locations. Only necessary

of none of the database's locations is set to

synchronize indexed files.



DEVONthink Pro 2.9.4 Documentation, page 37

PROPERTIES

Database Properties: Opens the Database

Properties panel for the selected database (if only

one database is open no sub-menu is available) that

allows you to change properties such as database

name, comments, and username/password.

Close Database: Closes a selected database (if only

one database is open no sub-menu is available). If

multiple databases are open, use Close All to close

them all in one go.

Delete Database: Closes a selected database and

moves it to the Finder trash.

PAGE SETUP, PRINT

Page Setup: Sets your preferred page size.

Print: Prints the selected or front-most document.

THE EDIT MENU

The Edit menu contains all commands and options

relating to editing. You'll find the classic Mac cut/

copy/paste and find/replace commands here, as well

as many more.

UNDO AND REDO

Undo/Redo: Undoes your last action or redoes it.

Undo and Redo work for most actions.

CUT

Cut/Copy/Paste: Do exactly what their names say.

Copy URL: Copies the URL of the selected or

frontmost document to the Clipboard.

Copy Item/Page Link: Copies a URL to the clipboard

that links to the selected document or group or even

to the currently displayed page. Paste this URL into

other documents in other applications to create

a back link to DEVONthink Pro. Hold the ⇧Shift

key to reveal the Copy Page Link option. See also p.

131ff

Paste and Match Style: Pastes text from the

Clipboard into rich text documents, disregarding all

styles from the clipped text, and matching styles in

the current document.

Delete: Deletes the selected piece of text.

Complete: Tries to auto-complete the partial word

before the insertion caret. This standard Mac OS X

function uses the currently active dictionary, which

you can change via the spell check panel (see below).

Select All/Deselect All: Selects or deselects the

complete content of the frontmost document. Hold

the ⇧Shift key to reveal the Deselect All option.

DOCUMENT EDITING

Tags: Shows the Tags bar, if necessary, so that you

can enter your tags immediately.

Split Document: Splits the current document (PDF,

plain or rich text) at the insertion mark position.

PDF Document: Use this sub-menu to insert

blank pages or delete selected pages from a PDF

at the position selected in the PDF sidebar. Add

annotations or switch to a PDF tool: Move, Text

Selection, or Annotation Selection. See also p. 77ff

Sheets: Use this sub-menu to add new rows or

new columns to a selected sheet, and to edit or

delete columns. By pressing ⇧ and ⌘, you can select

multiple columns in a sheet.

Rotate Left/Right: Rotates a selected image or page

left and right.

SUMMARIZE

Summarize: Summarizes the selected piece

of text. Unlike Mac OS X's Summarize service,

this command takes advantage of the built-in

AI of DEVONthink Pro, and uses the complete

"knowledge" contained in the open databases for

improving the results. The better your databases,

the better the results.

FIND

Find: This sub-menu contains commands for

finding and replacing text as well as for bringing

DEVONthink Pro's database search field into focus.

In Database: Brings the search field of the

frontmost window into focus.

Find: Opens the standard panel for finding text

within a document.
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Find Next/Previous: Jumps to the next, or

previous occurence, of the last search term.

Use Selection for Find: Copies the selected piece

of text to the Clipboard or into the search field of

the find panel, if it is opened.

Scroll To Selection: Scrolls the displayed

documents to the current selection.

Spelling and Grammar: Provides the standard Mac

OS X functionality for checking text for spelling or

grammar errors. To choose the language used for

spell checking, or for auto-completion (see above),

open the spell checker panel with Edit > Spelling and

Grammar > Show Spelling and Grammar and choose

your language of choice from the pop-up menu.

Substitutions: Shows the standard Substitutions

preference panel and switch the available options

manually on and off: Smart Copy/Paste, Smart

Quotes, Smart Dashes, Smart Links, Data Detectors,

and Text Replacements. Data Detectors analyze

shown text and make context-sensitive actions

available, e.g., when you hover the cursor over a

phone number or postal address. Mac OS X 10.6

"Snow Leopard" or higher only.

Transformations: Use this sub-menu to change

selected text to all lowercase or uppercase, or to

capitalize every word.

Speech: Starts or stops speaking the selected piece

of text.

Insert: Inserts special characters, the current date

and/or time, or a picture into your text. Note: You

can only embed a picture into a rich text document,

not into a plain text document.

Special Characters: Shows the standard Special

Characters panel for inserting characters that you

cannot enter directly with your keyboard.

THE DATA MENU

The Data menu contains all commands that deal

directly with documents or groups. Here you'll

find commands for creating, labeling, classifying or

group new documents, and more.

NEW

New: Allows you to create new documents directly

from within DEVONthink Pro.

With Clipboard: Creates a new document based

on the contents of the clipboard. Note: Some

applications such as Microsoft Word put data in

multiple formats into the Clipboard. DEVONthink

Pro tries to select the most useful one, however,

in some cases it grabs an image instead of text

(like Microsoft Word). Workaround: Create a text

clipping for the text, or paste it into a TextEdit

window, then copy the text from there.

Plain Text: Creates a new plain text document.

Rich Text: Creates a new rich text document.

Formatted Note: Creates a new formatted note.

HTML Page: Creates a new HTML page. You can

use the built-in Mac OS X WYSIWYG editor to

edit the HTML page or switch to its source code

(from the navigation bar) and edit it directly.

Markdown Text: Creates a new Markdown text

document.

Sheet: Creates a new sheet. Add columns to the

new sheet by using the + button or by pressing

the ↩Return key. Name the columns and sort the

sheets by dragging them with the mouse. Click

OK to create the new sheet.

Bookmark: Creates a new bookmark. Type the

URL you like and name it; DEVONthink Pro

automatically sets the value of its URL field in the

Info panel accordingly. If you don't type in a name,

DEVONthink Pro looks up the page name on the

Internet and sets it automatically for you.

Feed: Creates a new news feed document.

DEVONthink Pro asks for a document name and

the URL of the feed. You can change the URL later

by selecting the feed document and changing the

URL field in the Info panel.

Group: Create a blank group. Appears as Tag if the

new group would be created in the Tags group.

Smart Group: Creates a new smart group, also

known as "saved search". DEVONthink Pro opens

the Smart Group Editor, which lets you define

your search criteria. When saved, the contents

are updated every time you display the smart

group's contents.

http://www.microsoft.com/mac/
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New from Template: In addition to these standard

document types DEVONthink Pro offers pre-

defined and user-defined templates that you can

use to quickly add new documents to your database.

Select any template to add its contents to the

current group.

You can add any document to the list of templates

using File > Export > as Template.

Some of the pre-defined templates are "smart

templates" or "template packages". They consist of

an AppleScript or folders containing files for every

supported language. These take care of choosing

the right template variant for your language, adds

the template to your database, and modifies it, if

necessary. Some smart templates add the current

date, insert the clipboard contents, check if a

needed application is installed, and even access the

Contacts application to fill in your personal details

from your card. See also p. 125ff

Use Open Templates Folder to open the folder

containing the template files in the Finder and More

Templates to install additional templates.

OPEN

Open: Opens the selected document or group in

a separate document window. For groups, this

command opens a second main window rooted to

the selected group.

Open in Tabs: Opens the selected items in a new

tab. You need have more than one item selected for

this command to have an effect.

Open with >: Opens the selected documents in

the application selected from the sub-menu. You

can edit the document in the external application,

DEVONthink Pro automatically synchronizes

the file when it is being saved to disk by the other

application. Choose Other to open the documents

with an application not listed.

LAUNCH, REVEAL, SHOW

Launch URL: Opens the file, folder, or Internet

location indicated by the URL field in the Info Panel.

Unavailable for feed articles if DEVONthink Pro is

already your default news feed reader.

Reveal: Reveals the location of the frontmost

document in either the same main window, if

possible, or by opening a new one.

Show in Finder: Opens a new Finder window for

the folder, including the frontmost or selected

documents. Naturally, this only works for

documents referring to a file in the file system

through the Path field in the Info panel.

SAVE

Save/Save All/Revert To Saved: Use these

commands to save the frontmost document, all

documents, or to restore the frontmost document

to the last saved version.

LABEL AND MARK

Label: Allows you to mark the selected groups or

documents with one of seven labels, just as in the

Finder. You can define the color and the text of the

labels in the Preferences, Colors tab.

Mark: Allows you to mark the item as flagged/

unflagged, locked/unlocked, and read/unread. Items

marked as unread show an unread marker in most

views. See also p. 116ff

DUPLICATE

Duplicate: Creates a duplicate of the selected

items. The name of the new item ends in "copy", and

because their contents are identical both items are

marked with the icon for duplicates (or, depending

on your preferences, show their name in bold and

blue).

Replicate: Creates a replicant for the selected

items. Unlike a duplicate or alias, a replicant is like

a second phone book entry for the same person.

(Definition: Aliases are little files containing a link

to the original file). When you replicate a group or

document in DEVONthink Pro, you end up with two

replicants, not one alias and one original. Both items

have the same name and are marked with the icon

for replicants (or, depending on your preferences,

show their name in red).
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MERGE, TOC, SEND BY EMAIL

Merge: Creates one big document out of several

selected ones. This works for text documents,

images, PDFs, sheets, and multimedia items. All

the original documents are embedded in the

resulting document and all tags are added, too. If the

selection contains only images, PDF, or PostScript

documents, DEVONthink Pro generates a PDF

file; otherwise DEVONthink Pro generates a rich

text document. Document types that cannot be

merged are attached if possible (e.g. PDFs are

added as attachments to a rich text document).

This command can also be used to merge multiple

selected groups/tags; in this case, the first group is

used as the destination.

Create Table of Contents: Creates a rich text

document with links to all selected documents. Use

this command e.g. for creating customized index

pages for the website export.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, Airmail 2, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If the

selected item is an email message, the sender is

automatically inserted as the recipient and the text

of the original message is inserted instead of an

attachment. Notes: Postbox is currently only able

to send one selected file. Unsupported email clients

(e.g. Thunderbird) can only send the plain text of one

selected file.

CAPTURE, CONVERT, THUMBNAILS

Capture: Capture the displayed web page, e.g. from

a bookmark, as a PDF or web archive.

Convert: These commands convert the selected

documents, if possible, to plain or rich text,

formatted note, or HTML. DEVONthink Pro never

replaces the original document with a text version;

instead, it creates a new document containing the

extracted text next to the original item.

Note: Converting a document to a searchable

PDF does not carry over any annotations you

have made to the original document.

Thumbnails: These commands create, remove,

or update the thumbnails or custom icons for the

selected items.

GROUP

Group/Ungroup Items: Creates a new group

containing all the selected items. This is similar to

creating a new group and moving the selected items

into it. This command also works in the See Also &

Classify drawer. Ungroup does exactly the opposite; it

moves all items contained in the selected group one

level up and removes the now empty group.

Auto Group Items: This and the following feature

Auto Classify are some of the intelligent functions

that gave DEVONthink Pro its reputation. It tries to

find similarities between the selected documents

and then group them accordingly. This is most

useful, for example, when trying to create order and

structure out of a few hundred documents randomly

clipped from web sites.

See Also & Classify: Opens or closes the See Also &

Classify drawer of a main window.

Auto Classify: This command analyzes the selected

documents and tries to find the groups where they

would fit best. If a document cannot be classified

with certainty, DEVONthink Pro beeps and lists it in

the Log panel. If DEVONthink Pro finds more than

one fitting group, it creates replicants in all groups

the document fits into. This function works best

with a large database that is structured somewhat

accurately.

Note: If the document you are auto-classifying

has replicants, these are deleted and only the

original document is placed into the new location.

This prevents multiple replicants from being

created when you are, for example, classifying

this document again.

MOVE TO TRASH

Move to Trash/Move All Instances to Trash: Moves

the selected items to the trash. If you have selected

a replicated item, Move All Instances to Trash (hold

the ⌥Option key to reveal) moves this item and all

its replicants to the trash.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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THE FORMAT MENU

The Format menu contains the commands and

options dealing with all aspects of text formatting.

Here you'll find the standard font, alignment,

and ruler commands, as well as very special

DEVONthink Pro commands.

Note: Many commands in this menu only work

with rich text, Markdown, or formatted notes.

Plain text documents do not allow formatting.

(That's why they're called "plain" text.) Some

formatting options are also available for editable

PDFs and web archives.

FONT

Font: This sub-menu is reponsible for controlling

the font and the document background color (rich

text documents only). Open the fonts panel with

Show Fonts, then increase or decrease the font size

of selected text with Bigger and Smaller, adjust the

text styles and the document background color.

Using Copy Font, copy the font formatting of

a selected piece of text or the passage of text

around the insertion caret. You can then apply the

formatting to selected text using Paste Font.

Style: Commands in this sub-menu apply a certain

style, such as italics, bold, or underlined, to selected

text. Also, the commands give you access to some

high-end font control like kerning, baseline shift,

ligatures, and character shape (only applicable to

Asian languages).

The most interesting part here is Styles, which opens

the Mac OS X Styles Editor. You can step through

all the styles used in the current document and

add them to your favorites. Use the pop-up menu

to select a saved style and, if you don't need it any

more, delete it. You can use saved styles from the

ruler (see below).

Note: If you think the user interface for the styles

editor is less-than-wonderful, you're right. But

don't blame us, it's Apple's design :-)

Alignment: Align paragraphs left, right, centered,

or justified. Here, Asian or Arabic users can also

change the direction of writing, if desired.

Ruler: Show the ruler, which shows the tab stops

and contains alignment and styles buttons; copy the

current ruler (line width, indents, tab stops, etc.) and

paste it somewhere else.

Learn more about the ruler and the Styles Editor

here.

HIGHLIGHT

Highlight, Highlight Color: In rich text documents,

editable PDFs, and web archives use Highlight to

highlight a selected piece of text just as you would

using with a colored pen on a piece of paper. To

remove highlighting, select the highlighted piece of

text and choose Highlight again. Use the Highlight

Color sub-menu to choose your favorite highlight

color.

SPACING

Spacing: This command is only available in rich text

documents; the command allows you to adjust the

line spacing of selected text. You can adjust the

line height to an exact value or define a minimum

and maximum height, adjust inter-line spacing, and

define the space before and after a paragraph.

Note: Paragraph spacings are not added to those

of the preceding or following paragraph; instead,

the maximum spacings from both paragraphs are

used to ensure a proper layout.

Link: Makes selected text a link to a URL (for

example, to a web page or to an email address). This

is a one-step command for writing the address into a

rich text document, selecting the address, selecting

Make Link (see below), and then changing the linked

text to anything you want.

List: Creates a bulleted list. Select your prefix, bullet

style, and suffix in the dialog sheet and click OK to

insert your list skeleton. In the list, press ↩ to insert

new items, and press ⇥ and ⇧⇥ to indent/de-indent

items, just as you would in any word processor.

Table: Inserts a new table into a rich text document

and opens the table inspector panel. Use the

table inspector to adjust the number of rows and

columns, cell alignments, cell colors, border widths,

and colors. Also, you can merge and split cells and

create tables within a cell.
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MAKE LINK

Add Link: Makes the selected text clickable and asks

for a destination. Enter any valid URL you want the

text to link to.

Edit Link: Shows an editing sheet where you can

change the URL of the selected link.

Make/Remove Link: Makes selected text clickable,

or removes a link from the current selection. Where

you are taken to when you click the link depends on

the selected text:

If the text was a valid URL, the URL will be the

target of the link. Editing the link text later does

not change the target. Use the Edit Link command

of the contextual menu to edit the link target.

Otherwise, DEVONthink Pro treats the link as a

Wiki-style link. Clicking the Wiki-style link jumps

to a document with exactly the same name as the

linked text (or any document with a Wiki aliasof

that name). If there is no document of that name,

clicking the link creates a new rich text document

named after the linked text and pre-filled by the

template you set in the Preferences, Editing tab.

Make Plain/Rich Text: Converts a rich text

document to plain text and vice versa. Converting a

rich text to plain text removes all formatting, while

converting a plain text document to rich text applies

default rich text font settings to the document.

INVISIBLES

Show Colors: Shows the color panel, e.g., for

changing the foreground color of selected text in

rich text documents.

Show Invisible Characters: Toggles display of

invisible characters such as spaces, tabs, and line

feeds. Shown invisible characters appear in light

gray.

Allow Hypenation: Enables or disables hyphenation

for the current rich text document.

THE VIEW MENU

The View menu contains all the commands for

modifying the way DEVONthink Pro displays groups

and documents.

VIEWS

Using these commands, you switch between

different layouts for main windows:

List

Icons

Columns

Split

Three Panes

Tags

VIEW OPTIONS

Cover Flow: When checked, DEVONthink Pro

displays the contents of selected groups in Cover

Flow style in the view/edit pane in the Split and

Three Panes views. Use it to quickly browse

through multiple documents. You can double-click

the frontmost document to open it in a separate

document window or you can drag it to other areas,

windows, or applications.

Full Screen: Displays either the current document in

a full screen mode optimized for reading and editing,

or the frontmost window in full screen.

Document: Shows the current document in full

screen.

Window: Shows the current window in full screen

(OS X 10.7 Lion or higher only).

To return to the normal view, press ⌘F7 respective

⌃⌘F7 or the EscapeEscape key. You define the width

of the document full screen view as well as plain

text font, background color, and text color in the

preferences, Editing tab.

Quick Look: Opens the Quick Look panel for the

selected items.

Slideshow: Shows the selected items as Quick Look

slideshow. Visible only when you visit the View with

the ⌥ key held.

VIEW LAYOUT

Widescreen: Switches Split, Three Panes, and Tag

views between standard and widescreen layout.

Show/Hide Sidebar: Shows or hides the main

sidebar that lists all open and recent databases,

global smart groups, the global inbox and the trash.
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Show/Hide Details: Switches between displaying

icons only or displaying icons together with detailed

information such as kind, label, size, word count,

creation date, and modification date. Available in all

windows using icon or column views.

Show/Hide Tags: Shows or hides the tag bar.

SORT AND COLUMNS

Sort: Sorts items in ascending or descending

order by various criteria: name, kind, date added,

creation/modification date, URL, path, word

count, flag, label, width x height, duration, location

(enclosing group hierarchy of the item), aliases,

and Spotlight comment. You also can sort items

manually by choosing Unsorted. DEVONthink Pro

remembers sort settings for every group separately

and uses those settings when the group is displayed

in its own main window.

Columns: This sub-menu lists all columns available

in the current view and allows you to show or hide

them individually. Use these options to show exactly

the information you need.

The Flag column shows the state (flagged or

unflagged). Clicking the flag or the empty spot

for the flag toggles the option. Unread items are

marked as read when the "unread" state is clicked.

Both Sort and Columns support a range of metadata

fields next to DEVONthink Pro's own data fields.

EXPAND AND COLLAPSE

Expands and collapses all groups at once.

ZOOM, FULL SCREEN

Actual Size: Depending on the document type, you

can zoom the document to your needs:

Actual Size: Displays the document at actual size,

calculated using the resolution of the screen and

the resolution information of the image or PDF.

All Pixels: Displays the document at a 1:1 ratio so

that one pixel of the image equals one pixel on the

screen (PDFs and images only).

Zoom In/Out: Zooms in or out of the document.

Zoom to Fit: Displays the document so that it

exactly fits either the height or the width of the

window/preview pane (PDFs and images only).

Zoom to Width: Displays the document so that its

width fits the width of the window or view/edit

pane (PDFs and images only).

PDF DISPLAY, TEXT ALTERNATIVE

PDF Display: This sub-menu lets you adjust the way

PDF documents are displayed.

Single Page, Two Pages: Shows a multi-page

document as single pages or two pages facing

each other (as in a magazine).

Continuous Scroll: When checked, shows the

pages of the PDF as one long scroll. When

unchecked, only one page is shown at a time.

Book Mode: When checked, facing pages start

with one single page (the title page), then facing

pages. When unchecked, they start facing.

Page Breaks: When checked, pages are shown

with a shadow around them. When unchecked,

they are "melted together".

Crop Box, Media Box: Crops the page to the crop

or media box. By default, PDF pages are cropped

to the crop box.

Sidebar: Shows or hides the Sidebar.

Text/Best Alternative: Toggles between a graphic

preview of a document, named the Best Alternative,

and a text-only alternative, Text Alternative. For

some document types, e.g., email messages, the

Quick Look preview does not permit you to click

links or copy text; the text alternative allows this.

For Markdown texts these commands switch

between editing and rendered views. Plain text

documents containing Markdown markup can be

shown rendered, too.

TOOLBAR OPTIONS

Hide/Show Toolbar: Hides or shows the toolbar of

the frontmost window.

Customize Toolbar: Lets you configure the toolbar

of the frontmost window.
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THE GO MENU

The Go menu contains all commands for navigating

the hierarchy of your DEVONthink Pro database.

Use these commands to go backwards and forwards

through your documents, or to move back to the top

level of the group hierarchy.

TOP GROUP, ...

Top/Enclosing Group/Selected Group: Goes

back to the top level of the group hierarchy, to the

group enclosing the shown group (if any), or to the

selected group ("hoist"). These commands are only

useful when you have opened a group in a second

main window, so that the "root" of the window is not

the top group of database, or when you are using

DEVONthink Pro in outline mode.

Back/Forward: Moves backwards and forwards

through all documents/web pages you have visited

by following cross-links or Wiki-style links.

First/Previous/Next/Last Document: Navigates

to the first, previous, next, or last document of all

documents in the current group. This is useful when

you have opened a document in a separate window

and want to move to another document in the same

group. It also works in the Three Panes view and in

Search windows.

INSTANCES, HIGHLIGHTS

Previous/Next Instance: Navigates backwards

and forwards through all instances of a replicated

document. Use these commands to find out where

the other instances of a replicated item are.

Alternatively, you can use a smart group to find all

documents that have replicants.

Previous/Next Highlight: Navigates backwards and

forward through all highlighted passages within a

document, regardless of whether these passages

have been highlighted by a search or by manually

using Format > Highlight. Use these commands to

visit all found text passages or highlighted passages

in a document.

Page: Navigates to the page with the entered page

number.

Time: Jumps to the specified time in a movie.

WORKSPACES

Workspaces save the content and positions of all

open windows so that you can restore them later.

This is ideal if you are working with the same set of

windows over and over again. Save these windows

as a workspace and recall them whenever you need

them again.

Add: Saves the currently open windows as a

workspace.

Edit: Opens a window that allows you to edit

saved workspaces. Click on a workspace name to

change it, reorder by dragging, and delete with

the . button.

Update: Updates an existing workspace to the

currently open windows.

Workspaces: Restores to a previously saved

workspace.

THE TOOLS MENU

The Tools menu contains the more sophisticated

tools, such as the advanced search function, the

concordance, the history panel, and the log. It also

contains commands for keeping your database

healthy and for showing the Info and the Groups

panel.

SEARCH TOOLS

Search: Opens the Search window. Using the

search function, you can search your database in a

variety of ways--from searching for a document by

name to a full content search. Using its built-in AI,

DEVONthink Pro also assists you in formulating the

right query.

DEVONagent Pro: Opens DEVONagent Pro,

DEVONtechnologies' smart Internet research

tool. If the current document has a URL attached,

this URL is opened in DEVONagent's built-in web-

browser.

PANELS

Show Info: Opens the Info panel, which shows

basic information about selected items. Since it is a

panel, selecting a new item updates the Info panel

accordingly.
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Show Properties: Opens the document properties

panel. View or edit the properties such as author,

subject, or keywords in the frontmost panel.

Show Groups: Opens the Groups panel. Use this

panel to always have your group list handy, which

makes dragging text clippings or documents from

DEVONthink Pro or other applications to a group

very convenient.

RESEARCH TOOLS

History: Opens the History panel for a selected

database (If only one database is open no sub-

menu is shown.) that lists all documents in the

selected database sorted by modification date. You

can use this panel for quickly finding newly added

documents or searching for documents by age.

Concordance: Opens the Concordance window for

a selected database. (If only one database is open

no sub-menu is shown.) The concordance shows all

words in the database, sorted by frequency. Use it

to analyze accumulated information or to find the

most common words.

DATABASE TOOLS

Like any database, DEVONthink Pro needs a bit of

maintenance from time to time. All commands you'll

need for database maintenance can be found here.

Verify & Repair: Verifies all database structures and

repairs them if necessary. By default, DEVONthink

Pro automatically verifies the database structure

every time you open a database, and advises you to

run this command when it finds significant errors.

Orphaned files found during repair are placed in

a group "Orphaned files" in the top level of the

database.

Backup & Optimize: Creates an internal backup

of the database and then optimizes the database

structure. Optimizing removes unnecessary internal

elements from the database and rebuilds the

internal structure to optimize the performance.

DEVONthink Pro also creates internal backups

on a regular basis depending on the settings in the

Preferences, Backup tab. Internal backups only

back up the index structures in case the index gets

corrupted. Please use an external backup software

to create backups of your complete database

including all documents.

Restore Backup: Restores an internal backup.

Choose the backup you want to restore from the

dialog window and click Open. You can identify

backups by their creation date.

Note: Restoring a backup simply swaps the

current database and the backup. The backup

becomes the active database, the former

database becomes a backup. You'll never lose any

data by using this command.

Rebuild Database: Completely rebuilds the

database by deleting the index and rebuilding it

from scratch. This removes any structural problems.

Depending on the size of your database, this can

take from a few seconds to several hours. You can

rebuild any database including the inbox.

SORTER

Show/Hide Sorter: Shows or hides the Sorter.

Take Note: Opens the Take Note panel that lets

you quickly enter a plain text note and add it to the

default destination.

THE WINDOW MENU

As in any Cocoa application, the Window menu lists

all open windows of the active application and gives

you access to commands for managing them.

WINDOW COMMANDS

Close, Zoom, Minimize: These three commands

resemble the red, yellow, and green buttons of

any window title bar, and consequently close the

window, minimize the window to the Dock, or

maximize the window. No magic here. Hold the key

to change Minimize to Minimize all.

Close, Select Next/Previous Tab: Closes the active

tab or moves the focus to the next or previous tab.

Note: Tabbed browsing needs to be enabled for

these commands to work.
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Bring All to Front: Brings all windows of

DEVONthink Pro to the front. Hold the key to

change Bring All to Front to Arrange in Front.

Window List: Selects any open window from the

menu to bring it to the front.

DOWNLOAD MANAGER

Download Manager: This command opens the

Download Manager panelof DEVONthink Pro.

Using the Download Manager, you can download

files or complete web sites from the Internet and

store them directly in your database.

LOG PANEL

Log: Opens the Log panel. The log lists error

messages and warnings that occurred while

importing new documents. It also opens

automatically when an error occurs. You can save

the log to a text file or clear it.

ACTIVITY PANEL

Activity: Opens the Activity panel. It shows all

running processes and allows you to manually stop

them.

THE SERVICES MENU

The DEVONthink Pro > Services menu allows access

to special commands published either by other

applications, such as TextEdit or Safari, or by

services extensions such as DEVONtechnologies'

WordService or CalcService. Also, DEVONthink Pro

publishes its own services in the Services menu.

See also p. 21ff

THE SCRIPTS MENU

The Scripts menu is located left of the Help menu and

shows a stylized AppleScript "S" symbol instead of a

normal menu title. It contains a collection of useful,

predefined AppleScripts you can use directly from

within DEVONthink Pro.

Some of the scripts work without having selected

a document, while others require you to select the

document you want the script to interact with. In

general, the script will tell you what you have to do

when you select it from the Scripts menu.

Use More Scripts to install additional scripts.

Read more about scripts and the DEVONthink Pro

Scripts menu here.

THE HELP MENU

The Help menu contains commands for opening

the integrated help pages, the support assistant, or

visiting the DEVONtechnologies website.
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DEVONTHINK PRO HELP

These commands open the integrated help pages

that are equal to the document you're reading or

open the release notes. In addition, they direct you

to the bookmarklets installation page

TUTORIALS, SUPPORT ASSISTANT

Support Assistant: Opens the support screen of

the Welcome to DEVONthink Pro assistant where

you can get support, retrieve your license code,

request a trial extension, or update your details in

DEVONtechnologies' customer database. You can

also install additional scripts or templates from the

assistant.

Note: If you purchased DEVONthink Pro from

the Mac App Store, all options dealing with

licenses or upgrades are not available.

Tutorials: Opens the Tips and Tutorials screen of

the Welcome to DEVONthink Pro assistant. The

tutorials help get you started by explaining everyday

DEVONthink Pro tasks in step-by-step detail. This

function requires an Internet connection.

DEVONTECHNOLOGIES

These commands take you directly to the

corresponding pages on the DEVONtechnologies

web site. Visit our home page or the lively user

forum. If you have a question or suggestion, send

feedback directly to our development team.

Hold the ⌥Option key to show the alternative

menu item Report Bug. It creates a new message in

yourdefault email client or Apple Mail containing

the Console log and all related crash logs in a Zip

archive, ready to be sent to DEVONtechnologies'

customer support.

THE DOCK MENU

The Dock menu appears when you click DEVONthink

Pro's icon in the Dock with the ⌃ key pressed, when

you right-click it, or when you left-click it and hold

the mouse button for one second or longer.

DEVONthink Pro's dock icon also displays a badge

with the number of new items, e.g., after adding

new data via the Services menu the bookmarklets, or

scripts. Longer tasks--importing, indexing, running

scripts--show a progress indicator on the dock icon,

too.

For all Mac OS X applications, the Dock menu

provides a selection of the commands of the

application menu.

<Window Name(s)>: Brings any open window of

DEVONthink Pro to the front.

Remove from Dock: Removes DEVONthink Pro

from the Dock. Only available if DEVONthink Pro

was added permanently to the Dock and is not

currectly open.

Open at Login: Adds DEVONthink Pro to your

login items.

Show In Finder: Reveals the DEVONthink Pro

application package in the Finder.

Hide: Hides all windows of DEVONthink Pro.

Quit: Quits DEVONthink Pro.

http://www.devontechnologies.com/redirect.php?id=forum
http://www.devontechnologies.com/redirect.php?id=forum
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Besides these standard commands, DEVONthink

Pro adds a number of its own commands to the Dock

menu to make them easily accessible whenever the

application is running.

Search: Opens the Search window.

Show/Hide Groups & Tags: Shows or hides the

Groups & Tags panel.

Show/Hide Sorter: Shows or hides the Sorter.

Take Note: Opens the Take Note panel.

Clip to DEVONthink: Open the Clip to DEVONthink

panel.
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WINDOWS & PANELS

In this chapter:

Main window 50

Document window 55

Search window 57

Info panel 60

Document Properties 61

Concordance 61

Download Manager 62

History 64

Groups & Tags 64

Take Note 65

Log 65

Activity 65

Preferences 65

Database Properties 66

Assistant 67

DEVONthink Pro uses a number of windows to

present information. These windows are used for

displaying and manipulating groups and documents,

finding information, editing metadata, analyzing

text, and changing the properties of your database.
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MAIN WINDOW

Most of your time working with DEVONthink Pro

will be spent in a main window. Main windows give

you access to your groups and documents, while

also allowing you to view and edit files.

Open a new main window with File > New Window.

DEVONthink Pro also opens a new window when

you open a database; you can set this option by

checking Open New Window in Preferences, General

tab.

The title of the window shows the name of

document or group if one is selected, as well as its

icon. Click-and-drag the icon to move it to another

group or database or to the Finder to export it.

Click the title bar with ⌘ pressed to reveal the

document's location within the database; select an

enclosing group to reveal it.

VIEWS

Different views present your information however

you prefer:

List: Displays groups and documents as a list;

groups can be expanded/collapsed by clicking

the gray triangle in front of their name. Double-

clicking items opens them in separate windows.

Icons: Displays groups and documents as icons.

Double-clicking items opens them in separate

windows. For images, DEVONthink Pro displays

a live thumbnail. Adjust the size of the icons using

the slider located in the upper right corner of the

window, just below the toolbar. Use View > Show/

Hide Details to switch between icons only, and

icons with details in a list.

Columns: Displays groups and documents in

columns along with a preview pane, similar to

iTunes. Selecting a document displays it in the

preview pane; selecting a group shows the items

it contains in a new column. You can double-click

the column resizer to make it fit automatically,

and each column can be sorted individually.

Split: Splits the window into an item list and a

view/edit pane. To switch between a vertical and

horizontal split, use View > Widescreen. The item

lists all groups and documents in the database,

and may contain one or more columns. By default,

it shows only item names. Expand/collapse

groups by clicking the gray triangle.

Three Panes: Resembles the way Apple Mail

displays folders, items, and contents. The pane

on the left displays all groups, the top right pane

displays the documents contained in the selected

group, and the view/edit pane at the lower right

shows the contents of the selected document,

and allows you to edit it if possible. Tip: When you

click the Home button on the toolbar, you can see

the files located in the root of your database.
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Tags: Shows all documents in a database for

selected tags. Select a tag to show all items

carrying this tag; select multiple tags (e.g. by

selecting them with the ⌘ key held) to show

documents carrying all selected tags. Select no

tag to show all items. Delete tags by pressing the

Delete or Backspace key; this moves ordinary tags

to the trash and excludes group tags from tagging.

New documents created in this view are either

created in the group represending the tag or in

the global inbox, and are tagged with the selected

tag. See also p. 121ff

To adjust the size of the different panes, move the

mouse to the divider between two panes until the

mouse pointer changes into a line with two arrows.

Then, click on and drag the divider to adjust the size

of the panes.

SIDEBAR

In the sidebar, which you can show or hide via View >

Show/Hide Sidebar, DEVONthink Pro lists:

 The global inbox

 The trash can

 All open databases

 Recent databases

 Favorites

 Smart groups

 Smart groups (selecting by date ranges)

 Smart groups (selecting by read/unread status)

Use the sidebar to quickly access your open and

recent databases, as well as the  global inbox, your

favorite databases, groups and news feeds, smart

groups, and the  trash. Select an open database to

switch to it or double-click a recently used database

to open it. Read-only databases are marked with a

read-only icon. Items dragged to a database in the

sidebar are placed in that database's inbox. Collapse

or expand sections using the collapse triangles.

Using the contextual menu you can create new

databases, open and close them, move them to the

Finder trash, empty DEVONthink Pro's  trash,

create smart groups, open the Database Properties

panel, and add databases or groups to or remove

them from the Favorites. Databases and groups in

the Favorites are also listed in destination popup

menus.

For the  Inbox, most database-related menu

commands are available, too, such as Tools > History

or Tools > Concordance. An action menu and a +

button give access to commonly used functions.

In addition, you can use drag-and-drop to move

items to the  Inbox or the  trash or add groups

or news feeds to the Favorites. When you select a

group in the Favorites, DEVONthink Pro will show

that group's contents and even open the database

that contains it if necessary. When you drag a smart

group to the sidebar it will be copied to the sidebar;

double-clicking a smart group opens the smart

group editor.

For the  Inbox and the  trash DEVONthink Pro

always shows the number of items contained,

independent from the preferences. The Recent

databases segment does not show databases that

are also designated as a favorite to prevent listing

them twice.

The sidebar's width and visibility is specific for each

database, which allows you to customize the look

and feel of each database.

ITEMS

DEVONthink Pro displays groups and documents,

much as the Finder does. Select items with a single

click, and drag them from one group to another.

You can also drag items to the Finder or other

applications, or drag folders and files from the

Finder to DEVONthink Pro. You can also drag

selected items or clippings such as text and images

from any application to DEVONthink Pro and vice

versa.

Press the ⌘ and ⌥ keys to link to the dragged

item(s) instead of importing them to the database.

For Bookends 11.3.1 or later this adds a formatted

rich text instead of a simple reference.

Single-click items to rename them. Double-click

items to open them in a separate document window

or in their native application (depending on the

document type). For smart groups, double-clicking

them in any view except Icons view opens the Smart

Group Editor. Press the Space bar to preview the item

using Quick Look; close the preview with the close

gadget or press Escape or Space again to close it.
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Colored item names, colored group icons, and

special icons tell you whether an item is a duplicate

or replicant, its read/unread status or what type of

search a smart group uses.

Empty groups are shown in gray.

Duplicates are shown with their name in blue;

replicants are shown in red. See also p. 39ff

Icons of feeds or other unread items show an

"unread" indicator in the State column. See also p.

73ff

Smart groups using dates are shown with a clock

icon; smart groups using the "unread" status are

marked with a unique icon, too.

Regular groups are shown in blue, while groups

also used for tagging are shown in yellow with a

"tag" icon embossed.

In addition, icons indicate whether a item is locked,

has an attached comment or script, or has been

indexed instead of imported. See also p. 119ff

To view or edit the contents of a document or group,

do the following:

List/Icons View: Double-click the group or

document to open it in a separate window. Hold

the ⌘ key as you click if you want to close the

originating window at the same time (hoisting).

This also works in the other views.

Vertical/Horizontal Split/Columns View: Select

the group or document. The view/edit pane

shows the contents of the group or document.

Click the triangle in front of a group to expand it,

then select a document to view or edit.

Three Panes View: Select a group or sub-group,

then select the document you want to view or

edit. DEVONthink Pro shows the group or sub-

groups content in the view/edit pane. Click the

triangle in front of a group to expand it. When you

select multiple groups or news feeds, the upper

right pane shows all documents in all selected

groups in one list, just like in Apple Mail. This does

not work for smart groups.

VIEW/EDIT PANE

The view/edit pane (not visible in icons and list view)

shows the content of the selected document and, if

possible, allows you to edit it. You can edit plain text,

rich text, and HTML pages.

Read more here about the various document types

that you can view or edit in this pane.

INFO BAR

Just below the toolbar you'll find the info bar.

For selected items it shows an icon, the file

name including location, and the kind, size,

and modification date. If you're not sure of the

document type, this is the place to look.

Use the slider located on the right side of the info

bar to adjust the size of icons.

TOOLBAR & SHORTCUTS

The toolbar of DEVONthink Pro main windows

carries many commands for manipulating the way

the application displays information and handles

selected items. Many of the toolbar items are simply

shortcuts for menu commands. Here's a short list of

the available tools:

Please find a list of shortcuts in the appendix. See

also p. 119ff

Navigation: Navigates to the top level of the

database, or one level up. Useful when you have

opened a second main window by double-clicking

a group, and now want to move up the groups

hierarchy in this window. Also shows or hides the

Sidebar

Go To Document: Selects the first/previous/next/

last document. Only available in Three Panes

view or in separate document windows.

View: Switches between the possible views. See

above.

Actions: Provides commands for modifying the

selected documents, similar to the Action menu in

other views. Generally, the Action menu contains

a selection of the commands also available via the

contextual menu.

Scripts: Gives access to the Scripts menu.

Quick Look: Opens the standard Quick Look panel

for the selected items.

Group +: Creates an empty group.

Smart Group +: Creates a new smart group.

Plain/Rich Text +: Creates a blank plain or rich text

document.

Link +: Creates a new link document.
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Sheet +: Creates a new sheet.

New Record: Creates a new record (row) in a

sheet.

Delete Records: Deletes selected records (rows).

New Column: Adds a new column to a sheet.

Delete Columns: Deletes selected columns.

Columns: Opens the columns editor, which allows

you to rename, reorder, add, or delete columns.

Mark Up: Highlights, underlines or strikes through

selected text. This option is available for rich text

documents, editable PDFs, and web archive.

Highlight: Highlights the selected piece of text

with the color selected in Preferences, Colors tab.

Open: Opens the selected documents in separate

document windows.

Open With >: Opens the selected documents in an

external application.

Launch URL: Opens the Internet location stored

in the URL field of the selected documents, e.g., a

web site URL in Safari.

Copy URL: Copies the Internet location stored in

the URL field of the selected document to the

clipboard.

Delete: Moves the selected documents to the

Trash.

Save: Saves all changes to the currently edited

document.

Import, Export: Imports new documents; Exports

the selected documents.

Reveal: Reveals the location of the selected items

in either the same main window, if possible, or by

opening a new one.

Show in Finder: Opens a new Finder window

showing the selected items.

Update: Updates an indexed item. See also p. 36ff

Print: Prints the current or selected documents.

Info: Opens the Info panel.

Group/Ungroup Items: Group creates a new

group and moves all selected documents into it.

Upgroup moves all documents contained in the

selected groups one level up and then deletes the

then-empty group.

Auto Classify: Classifies the selected documents

and moves them into the most appropriate group

if possible.

Find (search field): Lets you search your databases.

Select your search options from the magnifier

pop-up menu, enter your search term, and press

Return. Click the search field's search button

to return to the standard view. The pop-up

menu also lists the last 25 used search terms.

Check Prefix while typing to let DEVONthink Pro

begin to search as you type. The last word of the

term is treated like a prefix ('word*'). Add more

characters to refine and to speed up the search

and press Enter or ↩ to finish the search, or to

search for whole words only. See also p. 57ff

Find: Opens the Search window.

Bigger, Smaller Font: Increases or decreases the

font size.

Subscript, Superscript: Makes selected text

subscipt or superscript.

Ruler: Shows or hides the ruler for rich text.

Fonts: Shows the standard Mac OS X Font panel.

Colors: Shows the standard Mac OS X Colors

panel.

Make Plain/Rich Text: Converts the current text

document to plain or rich text.

Highlighting: Highlights selected text. The pop-up

menu lets you select the highlight color.

Link: Makes selected text a Wiki-style link. If the

text is a URL, the link points to that URL.

Edit Source, Show Page: Toggles between source

and page display of selected HTML documents.

Zoom: Zooms in, out, or to view width, or shows

the document in 1:1.

Full Screen: Shows the selected documents in full

screen mode. Press ⌘F8 to return to windowed

mode.

(Capture) Page: Captures a web page as HTML

code to either the current group or to the inbox.

(Capture) Web Archive: Captures a web page as

web archive to either the current group or to the

inbox.

(Capture) PDF: Captures a web page as a PDF to

either the current group or to the inbox.

(Capture) Note: Captures selected elements of a

web page as a rich text document to either the

current group or to the inbox.

DEVONagent: Opens DEVONagent. If the view/

edit pane or frontmost window displays a web

page, it opens the same URL in DEVONagent.
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Sync: Synchronizes the database with all its

locations. See also p. 23ff

Refresh: Refreshes the selected news feeds.

Backup: Creates an internal backup of the

database and then optimizes the database

structure; same as Tools > Backup & Optimize.

Verify: Verifies the database structure; same as

Tools > Verify & Repair.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, AirMail, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If

the selected item is an email message, the sender

is automatically inserted as the recipient and the

text of the original message is inserted instead of

an attachment. Notes: Postbox is currently only

able to send one selected file. Unsupported email

clients (e.g. Thunderbird) can only send the plain

text of one selected file.

Image Capture: Opens the Image Capture window

for capturing paper documents.

Note: Not all of these commands are always

available. You can customize the toolbar

by selecting View > Customize Toolbar or by

clicking with ⌃ pressed (right-click) the toolbar

background and selecting Customize Toolbar from

the contextual menu.

CONTEXTUAL MENU

The contextual menu (which appears when you

right-click or ⌃ click an item) offers a range of

commands tailored to what you wish do with the

clicked object.

Most of the commands offered by the contextual

menu have counterparts in a main menu, so you'll

recognize them immediately. However, to save

menu bar real estate, DEVONthink Pro gives you

access to some options only via the contextual

menu.

New Window: Opens a new main window.

Open Database: Opens the selected database.

Close Database: Closes the selected database.

Delete Database: Closes the selected databases,

and moves it to the Finder's trash.

Empty Trash: Empties the trash can.

Database Properties: Shows the Database

Properties of the selected database.

Add to Favorites: Adds the selected item to the

favorites.

Remove from Favorites: Removes the selected

item from the favorites.

New Smart Group: Creates a new smart group in

the sidebar.

Edit: Opens the smart group editor (only available

for smart groups).

Delete Smart Group: Removes the selected smart

group from the sidebar.

New: Creates a new document.

Open: Opens a selected document(s) in a new

window.

Open in Tabs: Opens a selected document(s) in a

new tab.

Open With: Opens a selected document(s) with an

external application.

Refresh Feed(s): Manually refreshes the selected

news feeds.

Launch URL: Opens the URLs indicated by the URL

field of the selected documents.

Copy URL: Copies the Internet location indicated

by the URL field of the selected document to the

clipboard.

Copy Item Link: Copies a unique URL refering

the selected item to the clipboard. Paste this

URL into any third-party application to directly

reference an item in your DEVONthink Pro

database. See also p. 131ff

Show in Finder: Reveals the item's file in the

Finder.

Get Info: Opens the Info panel for the items.

Move Into Database: Imports the selected indexed

item (and its children, if necessary) into the

database. Only available for indexed items. Use

this command to consolidate your database.

Move To External Folder: Moves items added

to an indexed group from the database to the

connected folder in the filesystem. Only available

for items in an indexed group.

Exclude from Tagging: Excludes the selected

groups from tagging.

Move To >: Moves the group or document to the

group you select in the sub-menu. Note: Moving

items to another database cannot be undone.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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Replicate To >: Creates a replicant of the group

or document in the group you select in the sub-

menu. Note: Doesn't replicate if a replicate for

the item is already present at the destination.

Duplicate To >: Creates a duplicate of the group

or document in the group you select in the sub-

menu. Note: Copying items to another database

cannot be undone.

Label: Changes the label of the selected items.

Mark: Marks the selected items as flagged/

unflagged, read/unread, locked/unlocked and

shows/hides the state of the items.

Move To Trash/Move All Instances To Trash:

Moves the selected document or all instances

of the selected documents, such as including all

replicants (if any), to the trash. Hold the ⌥Option

key to reveal the Move All Instances To Trash

command.

Thumbnails: Creates, updates, or deletes the

thumbnails for the selected items.

Convert: Converts the selected items to other

document formats.

Group: Creates a new group containing the

selected items. Appears as Tag if the new group

would be created in the Tags group.

Auto Classify: Classifies the selected items and

moves them to the group where they best fit.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, AirMail, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If

the selected item is an email message, the sender

is automatically inserted as the recipient and the

text of the original message is inserted instead of

an attachment. Notes: Postbox is currently only

able to send one selected file. Unsupported email

clients (e.g. Thunderbird) can only send the plain

text of one selected file.

Sort: Sorts the list of items to any available

criterium.

Empty Trash: Empties the trash (only available for

the trash).

In the Tags view, the following commands are

available:

Save Search: Available in the right pane of the Tags

view, this command creates a smart group from

one or multiple selected tags. Use it to select

some tags and to save the search as a smart group

for convenient access.

In the sidebar, the following commands are

available:

New Window: Opens a new window for the

selected database.

New Database: Creates a new database.

Open Database: Opens a selected database.

Show in Finder: Shows the database package in

the Finder.

Close Database: Closes the selected database.

Delete Database: Closes the selected databases,

and moves it to the Finder's trash.

Add to Favorites: Adds the selected database to

the favorites.

Remove from Favorites: Removes the selected

database from the favorites.

Empty Trash: Empties the trash.

Note: For your convenience, DEVONthink Pro

also makes the Services menu, available via the

contextual menu.

DOCUMENT WINDOW

A document window is similar to the view/edit pane

of a main window. You open a document window by

double-clicking a document in any view of a main

window or by choosing Data > Open (or any of its

equivalents in contextual menus).

Depending on the type of information the document

contains, the toolbar of a document window offers

different sets of tools. Most of them are identical

to their counterparts in the DEVONthink Pro main

window toolbar.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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See the Documents chapter for a detailed

description of the various document types.
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SEARCH WINDOW

Search windows allow you to search your database

in various ways, and assist you with intelligent

functions for broadening and adjusting your search

terms.

SEARCH TERM

In the top part of the search window you find

the search term field, as well as the Similar Words

button. To enter a search term and run the query

with the default options, simply type your search

words into the search term field and click the

magnifier button (right of search field). Like in many

other Mac applications, the pop-up menu (behind

the magnifier icon at the left side of the search term

field) gives you access to the last 25 search terms.

DEVONthink Pro uses Boolean operators,

parenthesis, and quotes to allow complexly

structured search terms. Read more about

operators and how to use them to write a search

term in the appendix.

To broaden or adjust your search term, enter a word

and click Similar Words to show a list of all words

in the database that are similar to the entered

word either by spelling or by context. Choose one

or more words (use ⇧ and/or ⌘ to select multiple

words from the list) to use them as search words.

Multiple selected words are combined using the

OR operator (spelling) or AND (context). The term

you've entered will be shown on the top of the

list, so you won't lose it for your search run. This

function uses all open databases for retrieving

similar words.

SEARCH OPTIONS

The left side of the search window gives you even

more control over the way DEVONthink Pro

searches the database. Adjust these options to best

fit your needs.

Search for: Choose exactly what you're looking for

or select All to search all parts of a document:

All: Searches all elements of a document.

Content: Searches the content of a document.

Name: Searches the name of a document.

URL: Searches the URL field of a document.

Comment: Searches the Comment field of a

document.

Metadata: Searches the metadata associated with

a document.
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Comparison: Make DEVONthink Pro treat regular

letters and their counterparts with umlauts or

diacritics equally. Check Fuzzy to make searches

fuzzy (e.g., "Hello" and "Hullo" would both be found).

Note: This option is only applied to words, not to

wildcards.

State: Limits the results based on their status

(flagged/unflagged). Choose Any to find results

regardless of their state.

Unread: Limits the results based on whether they

have been marked as read or unread. Choose Any to

find results regardless of their read status.

Locking: Limits the results based on whether they

are locked or not (on/off). Choose Any to find results

regardless of their locking flag.

Label: Limits the results based on their label.

Choose Any to find results regardless of their label.

Search in: Limits the scope of the search run to all

open databases, a selected database, or a selected

group.

Note: To search for all documents with a given

status, locking state, or label, simply leave the

query field empty and use the above options to

define what you are looking for.

Advanced: This button lets you enter advanced

search criteria in the same way you do for smart

groups. Use this to search for tags, date ranges or

similar limiters. The Reset buttons clears the set

advanced criteria. See also p. 81ff

SEARCH RESULTS

After a successful search run, DEVONthink Pro

lists all found documents below the search term

field, and displays them in a list together with their

relevance score, icon, location in the database,

modification date, document kind, and size. Sort the

list by clicking the column titles; click them again

to reverse the sorting order. Modify the columns

using the contextual menu or View > Columns. Point

the cursor to a result and the appearing tooltip will

show you the full title, location, and other metadata;

click a document title once to rename the document.

Below the list of found documents, DEVONthink

Pro gives you a preview of the documents you select

in the list. If you cannot see the preview area, drag

its handle up from the bottom of the window. Also,

you can do almost everything you could do in any

other DEVONthink Pro window, such as drag a

document to another window (or Finder), or export

the document using File > Export.

See also/Classify and Concordance drawers are

supported, too.

Due to limitations in Mac OS X's PDFKit,

highlighting of occurences of the search term in the

document is not tied to words; thus, DEVONthink

Pro also highlights sub-strings.

SMART GROUPS

When you are satisfied with the search results,

you can save the query as a smart group. Click the

+ button next to the search term field and enter a

name for your new smart group. The new smart

group that searches a specific database is created

in the top level of the database. A smart group that

searches all databases is placed into the sidebar.

TOOLBAR & SHORTCUTS

The toolbar of the search window offers many tools

that are also present in DEVONthink Pro main or

document windows. Here's a short list:

Go: Selects the first/previous/next/last item.

Actions: Provides commands for modifying the

selected documents, similar to the action menu in

other views. Generally, the action menu contains

a selection of the commands also available via the

contextual menu.

Scripts: Gives access to the Scripts menu.

Open: Opens the selected document(s) in separate

document windows.

Open Externally: Opens the selected documents

in an external application.

Launch URL: Opens the Internet location stored in

the URL field of the selected documents, such as a

web site URL in Safari.

Copy URL: Copies the Internet location stored in

the URL field of the selected document to the

clipboard.
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Group: Groups the selected documents in a new

group.

Delete: Moves the selected documents to the

trash.

Export: Exports the selected documents.

Info: Opens the Info panel.

Print: Prints the selected documents.

Zoom: Zooms in, out, to view width, or shows the

document in 1:1.

Full Screen: Shows the selected documents in full

screen mode. Press ⌘F8 to return to windowed

mode.

DEVONagent: Opens DEVONagent Pro. If the

view/edit pane or frontmost window displays a

web page, it opens the same URL in DEVONagent

Pro.

Note: Not all of these commands are always

available. You can customize the toolbar by

selecting View > Customize Toolbar or by ⌃ clicking

(right-clicking) the toolbar background and

selecting Customize Toolbar from the contextual

menu.

Please find a list of shortcuts in the appendix. See

also p. 119ff

CONTEXTUAL MENU

You can manipulate the search results by right-

clicking or clicking them with ⌃ pressed to open the

contextual menu, which offers various additional

commands.

Open: Opens the selected documents in a separate

main window.

Refresh Feed(s): Manually refreshes the selected

news feeds.

Launch URL: Opens the documents or web pages

pointed to by the URL field of the selected

documents.

Copy URL: Copies the Internet location stored in

the URL field of the selected document to the

clipboard.

Reveal: Shows and selects the document group.

Duplicate To >: Duplicates the selected documents

to the group you select from the sub-menu.

Replicate To >: Replicates the selected documents

to the group you select from the sub-menu. Note:

Doesn't replicate if a replicate for the item is

already present at the destination.

Move To >: Moves the selected documents to the

group you select from the sub-menu.

Label >: Changes the label of the selected

documents.

State >: Shows or changes the state of the selected

documents.

Locking >: Locks or unlocks the selected

documents.

Move To Trash/Move All Instances To Trash:

Moves the selected document or all instances

of the selected documents, such as including all

replicants (if any), to the trash. Hold the ⌥Option

key to reveal the Move All Instances To Trash

command.

Group: Creates a new group in the top level of the

database, and moves the selected documents

there.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, AirMail, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If

the selected item is an email message, the sender

is automatically inserted as the recipient and the

text of the original message is inserted instead of

an attachment. Notes: Postbox is currently only

able to send one selected file. Unsupported email

clients (e.g. Thunderbird) can only send the plain

text of one selected file.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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INFO PANEL

The Info panel, just like its counterpart in the

Finder, displays additional information about a

selected document or group, from icon and name to

comments and other metadata.

Open the Info panel using the i icon from the

window toolbar or by selecting Tools > Show Info.

The contents of the Info panel corresponds to the

currently selected object, so you can leave it open

all the time and it will always display the correct

information for the selected document or group.

HEAD ELEMENTS

Icon and Name: Just like in the Finder, the top part

of the panel displays the icon and the name of the

selected object. To change the icon of the document,

select it and paste any image you want over it. To

change the name of the document, use the Name

field below.

Locked: The Locked checkbox indicates that the

object is write-protected. Check the checkbox

to protect documents from being accidentally

modified, or groups and documents from being

accidently deleted. Locked documents or groups are

marked with a padlock.

MAIN ATTRIBUTES

Name: Use this field to change the name of the

object.

Aliases: Enter one or more words here, separated

by semicolons, as alternative targets for Wiki-style

links. Generally, Wiki links refer to the name of

contents, and aliases make this system even more

flexible.

Path: This field contains the path to the file holding

the document's data. It is non-editable. You can click

the @ button to open the references file using the

Finder. In general this is equal to using Data > Open

With and choosing the default application.

URL: Smiliar to the Path field, the URL field is used

to link the document to an Internet address or

anything else that can be reached by a URL. This

field is used primarily by bookmarks, but you can

also use it to connect a document to a web page.

To visit the web page click the @ button next to this

field or select the document and use the contextual

menu command Launch URL.

ATTACHED SCRIPT

Script: This field allows you to attach an AppleScript

script to any item in DEVONthink Pro--documents

as well as groups. The script will be executed every

time you view the item in a Split view or Three

Panes view, as well as when you open it in a separate

document window. Click the Select button to choose

the script to attach.

INFORMATION ELEMENTS

Size: Shows the size of the item. For groups and

news feeds, this field shows the size of all contained

items.

Kind: Shows the selected document type (for

example text, RTF, etc.)

Added: Shows the date when the object was

actually added to the database.

Created, Modified: Shows the (editable) dates when

the object was created and when it was modified the

last time.
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ADDITIONAL INFORMATION

This section lists metadata that has been stored

together with the item. Information shown depends

on the file type as well as the individual document.

ADDITIONAL ELEMENTS

Exclude from ...: These checkboxes allow you to

exclude this item from being used in classification,

see also, search, or tagging. Use this option to

exclude such things as temporary groups from

classification to increase the accuracy of the built-in

artificial intelligence.

Label: Shows the label assigned to this item and lets

you change it.

Tags: Shows the tags assigned to this item. You can

also edit tags here. See also p. 121ff

Location: Shows the location of this item inside the

database.

Instances: Shows how many replicants of this

document or group exist in the database and how

many duplicates DEVONthink Pro has identified.

Click to show a pop-up menu listing all instances

and duplicates and their enclosing groups. Select

any item to reveal it. Point at an item for a second

to make a tooltip appear that shows the item's

location.

Spotlight Comments: Stores other information

you want to attach to your document or group

(similar to the Spotlight comments field in the

Finder). Of course, the Comments field is searchable.

DEVONthink Pro synchronizes the Spotlight

comments in the Finder with this field in the

database.

Note: You can modify the comments of multiple

selected items simultaneously, as long as the

comment of all selected items is either identical

or empty.

DOCUMENT PROPERTIES

The Document Properties panel gives you access to

all metadata stored for a selected document. This

metadata includes, but is not limited to:

Author

Company

Copyright

Title

Subject

Keywords

Comments

Depending on the document type, you can edit or

view these properties. More fields may be available

depending on the document type.

CONCORDANCE

The Concordance window, opened with Tools >

Concordance, gives you a tool for analyzing the

contents of a database.

Use the concordance to analyze your data by:

Rank number (ascending, starting with 1)

Word frequency

Number of groups with items containing a specific

word

Word length

Word weight (relevance, depends on the contents

of the database)
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CONCORDANCE LIST

The concordance list shows all words in the

database, sorted by frequency and other criteria, by

clicking the according column title. Click the column

title again to reverse the sorting order.

You can also filter the list by word length, limiting

it to alphanumeric strings (to omit character/

number combinations) by entering the minimum

and maximum word length at the bottom of the

Concordance window, and by checking/unchecking

the Alphanumeric switch. Click the Update button

at the top of the window to update the list any time

you change parameters.

To find a word in the list, enter it into the search

field at the top of the window. Select any word

and click the Search button at the bottom of the

window to open a drawer showing all documents

that contain this word, sorted by relevance. Click

Similar to show a list of words that are contextually

similar to the selected word.

DRAWERS

You can manipulate the items in the drawer opened

by the Search button in various ways. Drag them

to the item list to move them to another location;

double-click them to open them in a separate

window; or ⌃ click (right-click) them to open

the contextual menu (which shows basically the

same options as the contextual menu for See Also

drawers). Press Space to show a Quick Look preview

for the selected item. To close the drawers, click the

red close button.

FREQUENCY GRAPH

You can switch between the frequency graph and

the concordance list by clicking the Graph and List

buttons in the upper left corner of the concordance

window.

The frequency graph shows a graph of the word

frequency over the rank number of the word (see

above). Change the sorting in the concordance list

to get different results, such as a graph of frequency

over number of groups. You can influence the

graph by limiting the word length or by omitting

alphanumeric strings and clicking the Update button.

DOWNLOAD MANAGER

Window > Download Manager opens DEVONthink

Pro's Download Manager panel. Using the

Download Manager, you can download files or

complete web sites from the Internet, and either

store the information in your database or as files

on your hard drive. Offline archives stored in

DEVONthink Pro are also used when you visit

bookmarks or open a link in a new tab and your

computer is currently offline.

PANEL ELEMENTS

The Download Manager panel consists of:

A list of a items to be downloaded

A status bar at the bottom

A + button for adding items to and a - button for

deleting selected items from the list

A reload button (backwards arrow)

A go/stop button (play/pause icons)

An Action menu (gear icon)

ADDING FILES

To download a web site or any other file, simply

add it to the Download Manager by dragging its

URL to the Download Manager panel. Alternatively,

you can click the + button in the panel and add the

URL manually, as well as a referrer, user name, and

password. If Automatic is checked, DEVONthink Pro

creates a referrer automatically when downloading

whole web sites.
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You can also paste one or more URLs (copied Safari

bookmarks, DEVONthink Pro links, or copied links

from DEVONagent Pro's Download Manager),

or add files to the Download Manager by using

the contextual menu in web and HTML views. ⌥
clicking a link also adds it to the Download Manager.

Note: You can also copy URLs in the Download

Manager to the Clipboard or drag them to

other applications (like the Finder or Safari's

bookmark manager). The Download Manager

also supports URLs for local files (POSIX path, a

"file://localhost/" URL, or a "file:///" URL).

THE ACTION MENU

Most actions are available through the Action menu

or the contextual menu. Click the gear button or ⌃
click an item in the Download Manager panel to

display more commands:

Add: Add another file to the list.

Edit: Edit the parameters of a selected item in the

list.

Retry: Attempts to reload an item that failed to

download.

Remove: Removes the selected items from the list.

Alternatively, you can press the Delete key.

Enable/Disable: Checks or unchecks the selected

items. Only checked items will be downloaded.

Start/Stop Queue: Starts or stops the download

queue. Same as the play/pause buttons at the

bottom of the panel.

Purge Queue: Removes all items from the list that

have been completely downloaded.

Only Added Files to Thumbnail Gallery: Offers

various predefined option sets (see below).

Import Files to Database: Selects which database

the downloaded files shall be stored in. Select

Folder to save them directly to the file system.

Options: Opens the options dialog sheet, which

allows you to specify in detail what to download,

which links to follow, and where to store the

downloaded files (see below).

For your convenience, DEVONthink Pro comes with

predefined option sets that you can directly select

from the action menu.

Only Added Files: Downloads only the files you

have manually added to the Download Manager.

Offline Archive: Downloads the files you have

added to the Download Manager including

embedded images, style sheets, and scripts.

Use this option set to archive/download web

pages with everything necessary to display them

properly. Alternative: Create a web archive.

Subdirectory (Complete): Downloads the files

you have added to the Download Manager

including all embedded or linked files. This option

set follows all links leading to (items in) sub-

directories. For example, use this option set

to download a complete web site for offline

archiving.

Subdirectory (Images & Multimedia): Same as

above, but downloads only linked images, linked

multimedia files including Flash and QuickTime

movies, and embedded images in the item's

directory and all sub-directories. Use this set

to download a complete web site for offline

archiving (without all linked Office documents,

PDFs, etc.)

Thumbnail Gallery: Downloads the files you

have added to the Download Manager including

linked images, embedded images, style sheets,

and scripts. Use this option set to download a

thumbnail gallery including all full-size images

linked to each thumbnail for offline archiving.

Note: Downloaded items are by default excluded

from classification and tagging.

OPTIONS

The options dialog defines which file types the

Download Manager downloads, which links it

follows, and where it stores the files.

Files: Check all file types you want the Download

Manager to download (plain texts, rich texts,

Office documents and PDF files, style sheets and

scripts, images, embedded images, multimedia

files, mark-up language files, etc.) Use the

Follow Links pop-up menu to define how far

DEVONthink Pro should follow links on the

downloaded HTML pages (see below). Check

Overwrite existing to update an existing archive.

Folder: When you choose Download to > Folder in

the action menu of the Download Manager panel,

DEVONthink Pro stores all downloaded items in

the directory you specify. Click Set to choose your
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preferred location. Use this option to use the

integrated Download Manager for downloading

software archives or other files you don't want to

store in your database. Double-click any part of

the location to reveal it in the Finder.

Download: Define how many connections the

Download Manager opens at the same time.

(Choose fewer connections for slower Internet

connection, more for DSL or broadband.)

Also, check Automatically purge queue to have

previously downloaded items automatically

removed from the queue.

The Follow Links options defines how far

DEVONthink Pro follows links on the downloaded

HTML pages. This feature allows you to control

what gets downloaded--only the actual pages or a

complete web site. DEVONthink Pro supports the

following options:

Off: Does not follow any links.

On Same Host: Follows links, but only as long as

they refer to the same web server/web site. Files

on other web servers will not be downloaded.

In Same Directory: Follows links, but only as long

as they refer to items in the same directory as the

downloaded HTML page.

In Subdirectories: Follows links, but only as long

as they refer to items in the same directory as the

downloaded HTML page or its sub-directories.

One Level: Follows all links regardless of where

they point to, but only one level deep. Links on

pages linked to from the original page are not

downloaded.

Two Levels: Follows all links regardless of where

they point to, but only two levels deep. Attention:

This can result in very large downloads!

HISTORY

The History panel, opened using Tools > History, lists

all documents in your database, without the groups

hiearchy (by default sorted by modification date

which reflects content modifications only but not

name or metadata changes).

Sort the list by name, age, or file size by clicking

the column titles (Click again to reverse the sorting

order.), and by any other criterum using View > Sort.

Customize the columns using View > Columns.

Of course, you can use drag-and-drop to move

documents to other windows or to the Finder, and

modify the documents using the commands in the

Data menu or the contextual menu.

Use the History panel to quickly access recently

added documents or to export all documents of a

certain age.

GROUPS & TAGS

The Groups & Tags panel, opened using Tools > Show

Groups & Tags, gives you direct access to all open

databases and their groups including the tags inside

the special Tags group. Use it to drag items directly

to a group or tag or to rearrange groups. You can

also apply menu commands to selected items, e.g.,

Data > Open.

Depending on your Preferences, General tab, the

Groups & Tags panel floats above all other windows,

even in other applications.
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TAKE NOTE

The Take Note panel, opened by hitting a hot key,

from the toolbar, or from the Tools menu, allows

you to quickly enter a note, choose the destination,

and add tags and a URL to the note. If DEVONthink

Pro can get the URL of the frontmost application,

e.g., from Safari, it will also insert that information

automatically into the URL field.

Use the Format pop-up menu (in the panel) to

choose the document format for the new note. Use

the commands in the Format menu (from the menu

bar) to style your note.

The New Group button creates a new group in the

destination group selected above.

Change the hot key for opening the Take Note panel

in the Sorter preferences.

Note: For this function DEVONthink Pro needs to

be running. This may change eventually.

LOG

The Log panel displays warnings and error messages

that occur, when importing files and folders and

performing other actions. The panel shows the

date of the message, the affected file, and a short

information about what happened.

You can save the list to a text file with the Save

button, and clear the log with the Clear button. To

sort the log, click the column title. (Click again to

reverse the sorting order.) Use the contextual menu

or double-click the entry to reveal an affected file in

the Finder.

Uncheck Show log automatically to prevent the log

popping up automatically. You can open the Log

panel at any time using Window > Log.

Right-click or click with ⌃ held to perform additional

commands on log entries via the contextual menu,

e.g., to reveal a logged item or move a logged item

to the trash. Copy information from the log to the

clipboard with Edit > Copy, ⌘C, or the contextual

menu.

ACTIVITY

The Activity panel shows a list of currently running

background processes, e.g., refreshing news feeds,

and downloading PDF documents and web archives

(e.g. via bookmarklets or Clip to DEVONthink. You

can manually stop them to free computer resources

or for other reasons.

Some operations, e.g., verifying a database, show

and hide the Activity panel automatically.

PREFERENCES

The Preferences window, opened using DEVONthink

Pro > Preferences, contains all available options,

which you can modify to adapt DEVONthink Pro to

your personal needs.

Because the preferences are so important, we have

created a separate chapter for them.
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DATABASE PROPERTIES

The Database Properties panel defines preferences

which are directly related to the database and not

to the application in general. Open the properties

panel using File > Database Properties for every open

database including the global inbox.

LOCATION

This section of the properties panel shows the

location of the database package and any additional

options:

Location: Double-click any part of the database

location to reveal it in the Finder.

Create Spotlight Index: Check to make this

database available to Spotlight. Checking this option

lets DEVONthink Pro create a folder in "~/Library/

Cache/Metadata" that Spotlight uses for accessing

the documents in the database. If you ever feel that

this folder is out-of-sync with the database, click

Rebuild to recreate this folder from scratch.

When viewing Spotlight results in a window, make

sure to have the Show all file extensions option in

Finder's Preferences, Advanced tab unchecked. If this

option is checked, the Finder displays the generic

names of the metadata cache files instead of the

name of the referenced document.

Starting with version 2.0.6, DEVONthink Pro adds

information to the Spotlight metadata that makes it

possible to preview many file types directly from the

Spotlight results window. Supported are text and

rich text (RTF and RTFD), image, movie, audio, PDF,

HTML, XML, and web archive files. DEVONthink

Pro needs to be installed on the machine viewing

the Spotlight results. You may need to rebuild the

Spotlight index to activate this function.

Note: Rebuilding the Spotlight index can become

necessary after copying a database from one

computer to another.

Exclude Groups from Tagging: Excludes all groups in

this database from being used as tags. Ordinary tags

can always be added to items using the Tag bar.

STATISTICS

This section displays some basic statistics about

how many documents your database contains, file

sizes, etc.

NAME AND COMMENTS

Name: Enter a name for your database here. It will

appear in the title bar of every main window of this

database.

Note: This does not change the file name for

the database package. You cannot change the

name of or add commments to the database

representing the global inbox.

Comments: Enter your own comments about the

database here, e.g., a project description.

PROTECTION

To prevent other people from opening DEVONthink

Pro and accessing your data, click on the padlock

button to unlock the entry fields, enter a user name

and password, and then click on the padlock button

again to lock your changes and hide the password.

Note: This is a simple password protection.

DEVONthink Pro does not yet provide file

encryption for enhanced security. For better

protection, create an encrypted disk image using

Disk Utility and store your database on that

encrypted volume or disk.



DEVONthink Pro 2.9.4 Documentation, page 67

ASSISTANT

The integrated Assistant combines a welcome screen

with a first launch assistant, tips, web and video

tutorials, installable extras, and a suppport page

that guides you through the available support

options.

WELCOME

This screen welcomes you when you start

DEVONthink Pro for the very first time. It offers:

An introductory screencast

The option to subscribe the free

DEVONtechnologies newsletter, as well as a

number of welcome tips

The tip of the day

The extra of the day

You can access all other screens of the assistant

from here, too.

FIRST LAUNCH ASSISTANT

The first launch assistant opens automatically the

very first time you open DEVONthink Pro, and

guides you through the first steps of using the

application: creating a new database, installing the

add-ons, and adjusting the preferences.

GET SUPPORT

The support screen guides you through the three

common steps for troubleshooting DEVONthink

Pro. In addition, you can have your license

code resent in case you don't have it anymore,

request a trial extension, update your details in

DEVONtechnologies' customer database, or buy an

upgrade or a second license.

TIPS AND TUTORIALS

Here you can find the latest tips and tutorials to

help you squeeze the best out of DEVONthink Pro.

Tutorials can be slideshows describing basic tasks in

DEVONthink Pro or screencasts.

Both tips and tutorials are updated live from

DEVONtechnologies' server so it's a good idea

to check back on a regular basis. The latest tip or

tutorial is also always mentioned on the welcome

screen.
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INSTALL EXTRAS

On the extras screen, DEVONthink Pro lists all

available extras that you can download and install

from DEVONtechnologies' server:

Scripts

Templates

Plugins

Browse the list of extras and install them with the

Install button. The last line of the description shows

where in the Scripts or Templates menu the extra will

show up after installation. Remove installed extras

with the Remove button.

The extras are updated live from

DEVONtechnologies' server so it's a good idea to

check back from time to time. The latest extra is also

always mentioned on the welcome screen.

Note: If one of these categories does not show

up in your copy of DEVONthink Pro, there

might be no extras of this type (yet) available for

DEVONthink Pro.
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DOCUMENTS

In this chapter:

General 69

Plain and rich texts 70

Formatted notes 72

Markdown texts 73

Web pages, HTML pages, feeds 73

Sheets 75

Images and videos 76

PDFs 77

Office documents, email, and others 78

All documents are displayed in DEVONthink Pro in

views. Each view features its own tools, contextual

menu commands, and hidden keyboard shortcuts. In

this chapter, we will look at many of those features.

GENERAL

All documents are displayed within DEVONthink

Pro in views (not to be confused with the different

layouts in main windows, also called views. Each

view (for example, a text or PDF view), has its own

tools, contextual menu commands, and keyboard

shortcuts. Some views, like the text view, also allow

you to edit the document, while others like the PDF

view, only display the selected document.

Currently, DEVONthink Pro features the following

view types:

Plain and RichText

Office and other documents

HTML pages, Web pages, Feeds

Sheets

Images

PDFs

NAVIGATION BAR

At the top of the view/edit pane DEVONthink Pro

shows a navigation bar that gives you access to

some additional tools that deal directly with the

contents of the document. Which tools are available

depends on the type of the document.

 Navigates back to the last visited document

after following a link.

 Navigates back to the next visited document

after going back.

 Reloads the displayed page in a web view. This

item is only visible for document types that

support reload, e.g. bookmarks.

 Shows an action menu with options for opening

the shown page in Safari, copy its address, or

capture the page in a variety of formats.

 Shows the system-wide sharing menu. OS X 10.8

Mountain Lion or later only.

 Locks or unlocks the item.

 Scrolls to the previous highlight, e.g., a search

term occurrence.

 Scrolls to the next highlight, e.g., a search term

occurrence.

 Scrolls to the next page of the displayed

document.

 Scrolls to the previous page of the displayed

document.

 Switches to text-only mode.

 Switches from text-only mode back to the

(standard) preview mode.

 Shows the PDF sidebar containing thumbnails of

all pages.

 Hides the sidebar.

 Opens the Concordance drawer.

 Opens the See also & Classify drawer.

 Shows a list of the most important words of the

document.

 Switches the tag bar on and off.

The text-only mode can be useful for selecting text

in items that are displayed using Quick Look or to

view or edit the source code of an HTML document.

In preview mode DEVONthink Pro uses Quick Look
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to show Pages documents and other filetypes in

their original layout. Select any word from the 

menu to show documents also dealing with this

keyword.

URL: Shows the URL associated with the displayed

item. If a PDF annotation is selected the URL field

shows the associated URL if available. Click to

launch the URL in its default application. Hold

the ⌥ or the ⌘ key to open the URL in a new tab.

Holding Shift-Option or Shift-Command opens the

URL in a new tab and selects it.

Word Count: Shows the number of paragraphs,

words, and characters of the displayed text.

Page Count: Shows the number of pages as well

as the page number of the currently displayed

page. Click the page number in PDF or PostScript

documents and enter a page number to jump

directly to that page.

TAG BAR

The Tag bar, which can be shown or hidden, shows

all tags associated with the document. Click the

tag bar and type to add tags; select a tag and press

the Delete or Backspace key to remove it. See also p.

121ff

When you type the name of a tag, DEVONthink

Pro offers automatic completion. Choose the right

option with the mouse or the arrow keys and press

↩ or Enter to accept it. Press Escape to use whatever

you entered. Auto-completion prefers ordinary tags

(tags represented in the Tags group) over groups

used as tags, and also matches sub-strings. Press ⇥
to enter another tag.

Note: The Tag bar is also visible for multiple

selected documents when all the documents have

the same tags attached. Use it to change the tags

on multiple documents.

TOOLBAR & SHORTCUTS

DEVONthink Pro can display documents in separate

windows when you double-click the documents in a

main window. Depending on the type of document,

the tools in the toolbar can change. Even though not

all tools are always present in the default toolbar

for a particular view, you can easily add them by

choosing View > Customize Toolbar.

Please find a list of shortcuts in the appendix. See

also p. 120ff

PLAIN AND RICH TEXTS

The view for plain and rich text documents is

basically a built-in incarnation of TextEdit, and you

use it in a very similar fashion. Of course, text views

support the Edit > Find commands and all options of

the Format menu.

THE RULER

For rich text documents, DEVONthink Pro supports

the standard ruler that the TextEdit engine of Mac

OS X provides. Show or hide it with Format > Ruler >

Show/Hide Ruler.

The ruler contains the following elements:

Tab Stops: Place tab stops with the mouse, then

remove them by dragging them off the ruler.

Drag new tab stops (left aligned, centered, right

aligned, or decimal aligned) from the repository

at the right side to their desired positions on the

ruler. Use the mouse to adjust the left and right

margins and indent.

Styles: Select a predefined text style from the pop-

up menu. To define your own styles, choose Other

to open the Mac OS X standard style editor. In the

style editor, navigate back and forth through the

styles of your document or the stored favorite

styles. (Use the radio buttons to switch between

document and favorite styles.) Click Select to

select all occurences of text with the displayed

style in the document, click Apply to apply the

style to selected text, or click Done to leave the

style editor. To add a style from your document
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to Favorites, click Add To Favorites; to remove a

favorite, click Remove From Favorites.

Alignment: Align the current paragraph (the one

with the insertion caret inside) left, centered,

justified, or right by clicking the according

alignment buttons in the ruler.

Spacing: Choose the desired spacing for the

current paragraph from the Spacing pop-up

menu. Choose Other to enter values other than

the ones shown.

Lists: Make the current paragraph a list (indented

and with a bullet or numbered) by choosing the

desired list style from the Lists pop-up menu.

Choose Other to define your own list style.

Note: The built-in "mini outliner" is an nice

feature. On any blank line in a rich text document

(doesn't work for plain texts), type ⌥⇥ to create

a bullet point (Mac OS X shows dashes instead

of bullets). Press ↩ for the next item, and so on.

Additional ⌥⇥ will increase the indentation; a

↩ on a blank list line will decrease it. The mini

outliner uses hyphens to indicate list items by

default. Right-click to choose all kinds of list

styles.

ATTACHMENTS

You can attach other documents to rich text

documents simply by dragging them into the text.

Technically the rich text document becomes a .rtfd

package and the dragged file is saved as part of

the package. Drag items into plain texts with

⌘Command and ⌥Option pressed to insert only

their titles.

Use the contextual menu to show an attachment's

content in a Quick Look preview.

Double-click attachments to edit them externally.

Note: Editing attachments requires OS X 10.7

Lion or higher. Also, you cannot attach files to

plain text documents. You need to convert them

to rich text before you can attach other files.

DRAG-AND-DROP

Besides dragging text from and to text documents

you can also drag the following:

Files: Adds the file as an attachment to a rich text

document. Hold ⌘Command and ⌥Option to

insert only a link to the file.

Contact cards: Drag a card from Contacts holding

⌘Command and ⌥Option to insert a link to the

card.

Calendar event: Drag a Calendar event to insert a

short text summary of the event including a link

to Calendar.

TOOLBAR & SHORTCUTS

The document windows toolbar is very similar to the

one in DEVONthink Pro main windows, yet can be

configured separately.

Please find a list of shortcuts in the appendix. See

also p. 120ff

CONTEXTUAL MENU

Add Link: Makes the selected piece of text a

WikiLink. The destination of the WikiLink is a

document with the same name as the selected

text. If no document with that name exists,

clicking the created link creates it using the

template you have set in the Editing Preferences.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Copy Link: Copies a link to the Clipboard (only

available for selected links).

Edit Link: Edits the destination of a selected link.

Highlight: Highlights the selected piece of text

with the color you select in the sub-menu.

Insert Link To: Inserts a link to an item you select

in the sub-menu (only available when no text is

selected).

Insert: Inserts special elements into the text (such

as a page break, the current date or a bullet).

Same as the Insert sub-menu of the Edit menu.

Link To: Makes the selected piece of text a cross-

link and links it directly to the group or document

you select in the sub-menu.

Look Up [word]: Looks the selected text up in Mac

OS X's Dictionary.
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Open Alias: Follows a selected link (only available

for a selected Wiki-style link resolved by an alias).

Aliases are defined for each item separately in

the Info panel.

Open Link in Browser: Opens the selected link in

the default browser or application (only available

for a selected link).

Open Link in New Tab: Opens the selected link in a

new tab.

Quick Look Attachment: Opens a Quick Look

panel for the selected attached link or file (OS X

10.7 Lion or higher).

Remove Link: Makes a selected link simple text.

Search selected phrase: Searches for the selected

text as a phrase.

Search with Google: Opens your default browser

and searches for the selected text in Google.

Search with Spotlight: Searches for the selected

text using Spotlight.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text (needs to be less than

256 characters).

Split Document: Splits the document at the

current insertion mark position.

FORMATTED NOTES

Formatted notes allow to write simple formatted

text including embedded images that can be viewed

on any system with just a web browser. While the

range of formatting options is smaller that that of

rich text they are much more compatible to today's

standards. You can find all available formatting

commands in the Edit and Format menus. By default

formatted notes use the font set in Preferences >

Editing for rich texts and notes.

Technically formatted notes are based on HTML,

the language of the world-wide web. Images are

embedded directly into the HTML code so that

formatted notes are completely self-contained.

The HTML code is also cleaned from unnessessary

tags and an identifying meta tag is inserted that lets

DEVONthink Pro distinguish formatted notes from

normal HTML pages.

TOOLBAR & SHORTCUTS

The document windows toolbar is very similar to the

one in DEVONthink Pro main windows, yet can be

configured separately.

Please find a list of shortcuts in the appendix. See

also p. 120ff

CONTEXTUAL MENU

Add Link: Lets you enter a URL and makes the

selected text a link to it.

Add Tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Edit Link: Edits the destination of a selected link.

Highlight: Highlights the selected piece of text

with the color you select in the sub-menu.

Link To: Makes the selected piece of text a cross-

link and links it directly to the group or document

you select in the sub-menu.

Look Up [word]: Looks the selected text up in Mac

OS X's Dictionary.

Open Link in Browser: Opens the selected link in

your default web browser.

Open Link in New Tab: Opens the selected link in a

new tab.

Remove Link: Makes a selected link simple text.

Search selected phrase: Searches for the selected

text as a phrase.

Search with Google: Opens your default browser

and searches for the selected text in Google.

See [word]: Opens a drawer with documents

related to the selected word.
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See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text (needs to be less than

256 characters).

MARKDOWN TEXTS

Markdown is a simple formatting language invented

by John Gruber. It lets you write articles with very

simple formatting, e.g. headlines, lists, quotes,

links, and emphasis in a very natural way using a

plain text editor and render it to visually pleasing

HTML. Write Markdown-formatted text using

DEVONthink Pro's Markdown view and switch

easily between a plain text editor and the rendered

view using View > Text/Best Alternative or the  and 

icons in the navigation bar.

Learn more about Markdown and its syntax on

Gruber's Markdown pages.

TOOLBAR & SHORTCUTS

The document windows toolbar is very similar to the

one in DEVONthink Pro main windows, yet can be

configured separately.

Please find a list of shortcuts in the appendix. See

also p. 120ff

CONTEXTUAL MENU

In text mode the contextual menu commands are

similar to those of plain text documents. In rendered

mode the following commands are available:

Add Link to Downloads: Adds a link to the

Download Manager panel.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Copy Link: Copies a link to the Clipboard (only

available for selected links).

Look Up [word]: Looks the selected text up in Mac

OS X's Dictionary.

Open Link in Browser: Opens the selected link in

the default browser or application (only available

for a selected link).

Open Link in New Tab: Opens the selected link in a

new tab.

Search with Google: Opens your default browser

and searches for the selected text in Google.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text (needs to be less than

256 characters).

WEB PAGES, HTML PAGES, FEEDS

HTML views display web pages stored in the

database or downloaded "live" from the Internet

by using the Safari web browser engine of Mac OS

X. DEVONthink Pro displays RSS news feeds like

regular web pages. Pages are rendered similar to

Safari or any other WebKit-based browser such as

DEVONagent Pro.

News feeds item (RSS, RDF, Atom) are created in a

database automatically for all items downloaded by

a feed. Feed items are saved either as HTML or as

a bookmark if the item has no content. An internal

http://daringfireball.net/projects/markdown/
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CSS stylesheet is used to style the output. You can

change it in the Preferences. The icon of an unread

feed item in list and split views is shown with a blue

dot.

HTML views support the Edit > Find commands

as well as the See Also & Classify drawer. To edit

the source code of an HTML document, use the

navgiation bar to switch from preview to plain text

mode.

In editable web archives you can use, e.g., the

highlighting commands from the Format menu or add

the Color tool to the toolbar to change text colors.

Editable web archives share many similarities with

formatted notes.

TOOLBAR & SHORTCUTS

Separate HTML or web browser windows feature

a default toolbar set that is more web-like than

text document windows. As with text document

windows, this toolbar can be configured individually.

Naturally, the DEVONthink Pro offers only tools for

HTML views that are useful in a web environment.

Please find a list of shortcuts in the appendix.. See

also p. 120ff

CONTEXTUAL MENU

Add Link: Allows you to enter a URL and makes the

selected text a link to it.

Add Link to Downloads: Adds a link to the

Download Manager panel.

Add Page to Downloads: Adds the page address to

the Download Manager panel.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Back / Forward: Navigates back and forth to

previously visited pages.

Capture Frame: Captures the current frame in the

selected format to either the current group or to

the inbox.

Capture Image: Captures the selected image and

saves it to either the current group or to the

inbox.

Capture Link: Captures the selected link as

bookmark to either the current group or to the

inbox.

Capture Page: Captures the current page in the

selected format to either the current group or to

the inbox.

Capture Rich Text: Captures selected text to

either the current group or to the inbox.

Copy Frame Address: Copies the frame URL to the

Clipboard.

Copy Image Address: Copies the URL of an image

to the Clipboard.

Copy Image: Copies the image to the Clipboard.

Copy Page Address: Copies the page URL to the

Clipboard.

Copy: Copies selected text to the Clipboard.

Highlight: Highlights the selection in a web

archive. Using this command on a selection again

removes the highlighting.

Look up ...: Shows a definition, e.g. from OS X's

Dictionary, for the selected text.

Open ... in New Tab: Opens selected element in a

new tab.

Open Image in PhotoStickies: Opens the image in

PhotoStickies.

Open Link in Browser: Opens a link in your default

web browser.

Open Link in DEVONagent: Opens a link in

DEVONagent Pro.

Open Link in PhotoStickies: Opens a link in

PhotoStickies.

Reload: Reloads the page from the Internet.

Search Selected Phrase: Searches for the selected

text as a phrase.

Search With Google: Searches for the selected

text in Google.

Search with Spotlight: Searches for the selected

text with Spotlight.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set As Thumbnail: Set the document's icon to the

selected image.

Set Name As: Sets the name of the document to

the selected piece of text (needs to be less than

256 characters).

Share: Shared selected text via the available OS X

sharing extensions (OS X Mountain Lion or later).
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Update Bookmark: Updates the URL of this

document to the current one, e.g., after

navigating to a sub-page.

Update Captured Archive: Updates the contents

of a web archive file with the live version on the

Internet (only available in web archives).

For PDF pages more options become available:

Automatically Resize: When checked, the zoom

factor adjusts to the width resp. height of the

browser window.

Next Page, Previous Page: Skims through the

pages forward or backward.

Open with Preview: Opens the PDF in Preview.

Single Page, ...: Displays the PDF as single or

double pages and either page-by-page (use the

Next Page and Previous Page to skim through the

pages forward and backwards) or continously.

Zoom Out, Zoom In, Actual Size: Zooms in or out

of the document, or displays it in its actual size.

For HTML 5 videos the following additional options

are available:

Copy Video Address: Copies the video's URL to

the clipboard.

Download Video: Downloads the video using the

Download Manager.

Mute: Mute or unmutes the video.

Open Video In Tab: Opens the video in a new tab.

Play/Pause: Plays or pauses the video.

Show/Hide Controls: Shows or hides the video

controls.

SHEETS

Sheets contain text in a table and can be used to

store any kind of tabular data from an address book

to parse numbers and descriptions.

Use sheets like any other document. Add new rows

using Data > Sheets > Add Record, delete rows by

selecting them and using Edit > Delete. Alternatively,

use the contextual menu. Click a cell to edit its

content, press the Escape key to stop editing, and

use the Tab or Return keys to navigate from cell to

cell.

Sheets support the Edit > Find commands but

currently no formattings. You can, however, enter

line breaks by typing ⌥↩.

Note: Due to limitation in Mac OS X's Cocoa

memory management, sheets are currently

limited to 32,767 records.

TOOLBAR & SHORTCUTS

Document windows opened for a sheet or record

also feature a tool set specialized for working with

sheets and records. Use tools like New Record, New

Column, or Columns to create new records for the

sheet, add a column, or modify the columns in any

way you like.

Please find a list of shortcuts in the appendix. See

also p. 120ff

CONTEXTUAL MENU

The contextual menu for sheets basically lists the

same commands that are also available through the

main menu.

Cut/Copy/Paste: Cuts, copies, or pastes whole

records in a sheet. Use them, for example, to

duplicate records.

Delete Records/Columns: Deletes the selected

record(s) or column(s).

Edit Columns: Opens the columns editor where

you can create new columns and delete,

rearrange, and rename them.

New Column: Creates a new column in the sheet.

New Record: Creates a new record in the sheet.
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IMAGES AND VIDEOS

DEVONthink Pro uses Mac OS X's core

technologies to display images and videos;

therefore, it makes a very nice image and movie

viewer.

You can scroll larger images using the scroll bars,

the arrow keys, Page Down and Page Up, as well as

the Space and Shift-Space keys. The navigation bar

shows the current play time, clicking the navigation

bar let's you enter a time and jump to that mark.

EDIT PANEL

Double-clicking an imported image opens an edit

panel that allows you to do some basic image

editing. The modified image is saved as losslessly

encoded TIFF file.

Change the exposure.

Set white and black point.

Change gamma, saturation, contrast, and

brightness.

Adjust sharpness.

Adjust sepia effect.

In addition, the panel offers a number of predefined

image effects and lists available metadata contained

in the image file itself.

Images (and PDF pages) can also be rotated using

the Edit > Rotate menu commands, the toolbar, or

the contextual menu.

TOOLBAR

For images and videos, DEVONthink Pro provides

a set of tools that allows you to zoom the picture to

whatever zoom factor you like, or to view the image

in full screen mode. Use Open Externally to open the

image in an external editor. Videos appear with the

standard QuickTime controller.

Note: Editing an image stored internally in the

database with an external editor does not modify

the image data stored in DEVONthink Pro.

CONTEXTUAL MENU

Actual Size: Zooms the image so that it appears

at its real size, calculated from the actual pixels

and the resolution information contained in the

image.

All Pixels: Zooms the image so that one image pixel

equals one pixel on the screen.

Copy Frame Link: Copies a URL linking to the

actual frame of the displayed video.

Copy Image: Copies the current video frame as an

image.

Cut/Copy/Paste: Cuts, copies or pastes the

selected image or video.

Edit: Opens the Edit panel.

Play/Stop: Starts playing the video or stops playing

it.

Rotate Left/Right: Rotate the image left and right.

The image is saved in the lossless TIFF format.

Select/Deselect All: Selects or deselects the video.

Set As Thumbnail: Makes the current frame the

thumbnail of the video (only available when the

video is not playing).

Undo/Redo: Revokes the last action or redoes it.

Zoom In/Out: Zooms in and out of the picture.

Zoom To Fit: Zooms the image so that it fits into

the view/edit pane or the document window.

Zoom To Width: Zooms the image so that it

appears exactly as wide as the view/edit pane or

the document window.
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PDFS

PDF views are similar to image views, but come with

specialized options for viewing PDF documents.

Also, PDF views support the Edit > Find commands.

SIDEBAR

The sidebar shows thumbnails of the pages within

the PDF document. Click a thumbnail, select that

page, and scroll to it; hold the ⇧ or ⌘ keys to select

multiple pages. Reorder pages by dragging a page

to the new position and use Edit > Delete Selected

Page(s) to remove the selected page(s). Use Edit

> Rotate to rotate PDF pages. Contextual menu

commands, e.g., copy and paste, are available, too.

You show and hide the PDF sidebar using the Show/

Hide Sidebar button in the PDF''s navigation bar.

Note: Only real PDF documents are editable;

converted (e.g. EPS, PostScript, or Adobe

Illustrator files), Skim documents (PDF packages),

and PDF previews generated by QuickLook are

not editable.

ANNOTATING PDFS

You can use DEVONthink Pro to annotate PDF

documents. To add or edit annotations, open the

PDF document in a separate window (e.g., by

double-clicking it). You will find all necessary tools in

the toolbar:

Tool: Switch between moving, selecting text, and

selecting elements such as annotation post-it

notes.

Annotate: Select your annotation tool of choice:

ellipsis, rectangle, post-it note, text rectangle,

line, arrow, and link.

To add an annotation, select your annotation tool,

then "draw" it into the page. Double-click the

annotation to open the annotation panel which lets

you fine-tune your annotation. Depending on the

type of annotation, you can change its attributes.

Change the text color in the annotation panel; use

the standard Fonts panel to change the font of a

selected text annotation. Drop other documents,

files from the Finder, or URLs into the URL field to

insert cross-links, paths, or URLs.

To move or delete an annotation, select it with the

"select elements" tool. Position it with the mouse.

Press the Delete key or use Edit > Delete to remove it.

TOOLBAR & SHORTCUTS

Annotate: Provides annotation tools. See also p.

77ff

Tool: Selects the editing mode. See also p. 77ff

Delete Pages: Deletes the selected pages of a PDF

document.

Please find a list of shortcuts in the appendix. See

also p. 120ff

CONTEXTUAL MENU

Actual Size: Zooms the image so that it appears at

its real size, calculated from the actual pixels and

the resolution information contained in the PDF.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).
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Auto Size: Resizes the PDF automatically so that

it always fits the size of the view/edit pane or the

document window.

Continuous Scoll: When checked, DEVONthink

Pro displays the pages of a mutli-page PDF like

one long scroll. If unchecked, it displays the PDF

page by page.

Copy Page Link: Copies a URL to the clipboard

pointing directly to the shown page of the

document.

Delete Annotation: Deletes the selected

annotations.

Highlight: Highlights the selection. Using this

command on a selection again removes the

highlighting.

Link To: Marks the selected text as link and links

it to the item chosen in the sub-menu. This saves

you from having to create a link annotation first

and then select the target in another step.

Open Link in New Tab: Opens the selected link in a

new tab.

Open Link: Opens the selected link.

Previous/Next Page: Jumps to the previous or

next page.

Rotate Left/Right: Rotate the page left and right.

Search selected phrase: Searches for the selected

text as a phrase.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text.

Share: Shared selected text via the available OS X

sharing extensions (OS X Mountain Lion or later)..

Single Page/Two Pages: Displays the PDF either as

one page or as facing pages (like in a magazine).

Zoom In/Out: Zooms in and out of the PDF.

The PDF sidebar also offers commands for working

with single pages:

Copy Page Link: Copies a URL that points directly

to the selected page.

Copy Page Link: Copies a URL to the clipboard,

pointing not only to the document itself but the

actual page.

Cut/Copy/Paste: Cuts, copies, or pastes a PDF

page.

Delete Selected Page: Deletes the selected page.

Insert Blank Page: Inserts a blank page into the

PDF.

Rotate Left/Right: Rotate a selected page left and

right.

Select/Deselect All: Selects or deselects all pages.

Split Document: Splits the PDF at the selection

into two documents.

Undo/Redo: Undo or redo the last action.

OFFICE DOCUMENTS, EMAIL, AND
OTHERS

Documents that DEVONthink Pro cannot render

natively are displayed using QuickLook. But while

you have to press the Space bar in the Finder to open

a QuickLook head-up display, DEVONthink Pro

previews these documents directly in the view/edit

pane like any other document format.

Among others, the following document types are

shown though QuickLook:

iWork documents (Pages, Numbers, Keynote)

Microsoft Office and OpenOffice documents

Mellel files (version 2.6 and higher)

...

For some document formats the preview allows you

to select and copy text, for other formats it doesn't.

If DEVONthink Pro is able to interpret and convert

the document format, you can use the Text View/

Preview button in the navigation bar to switch to a

text view that allows you to select, copy, and drag

text.

http://www.apple.com/iwork/
http://www.microsoft.com/mac/
http://www.openoffice.org
http://www.mellel.com
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Note: The availability and quality of the preview,

as well as the possibility to select and copy

text, depends solely on the source application.

Developers can embed a QuickLook-compatible

preview diectly into the files, or write a preview

plugin and add it to either the source application,

or have you install it separately in ~/Library/

QuickLook. If a document that you want to view

in DEVONthink Pro does not show a QuickLook

preview, please contact the maker of the source

application and ask them to add QuickLook

support.

TOOLBAR

For document previews based on QuickLook,

DEVONthink Pro offers a number of toolbar items,

e.g., for accessing the Scripts menu, moving back and

forth through the other documents contained in the

same group or opening the document in its source

application. Also you can switch to full-screen mode.

Use Data > Open to open the document in a

separate document window instead of in its source

application.
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DRAWERS & SHEETS

In this chapter:

See Also & Classify 80

Concordance 81

Smart group editor 81

DEVONthink Pro uses drawers to display the results

of the Classify and See Also functions that help you

file items and find relationships between items in

the database. Drawers also show concordance lists

of all words contained in a document. The Smart

Group Editor, which appears in a sheet, allows you

to create or modify a smart group (a.k.a. "saved

search").

SEE ALSO & CLASSIFY

The See Also & Classify drawer appears when you

select one (1) document in a main window and then

click the AI button (a small sorcerer's hat) in the

navigation bar at the top of the view/edit pane. This

button is only available in views that have a view/

edit pane.

It is also shown when you use the contextual menu

on selected text to show similar documents, e.g.,

See [word]' or See related text, or when you select a

topic from the topics pop-up menu in the document's

navigation bar.

To close the drawer, click the red close button.

When activated, DEVONthink Pro analyzes the

contents of the selected document and compares

it to all data stored in the database. From this

"knowledge," DEVONthink Pro gives you one or

both of the following lists.

CLASSIFY

The Classify function helps you file documents by

making suggestions based on where you have filed

other documents. The Classify list shows which

groups the selected document would fit into best.

It also lists the location of the group and a graphical

score that shows how sure DEVONthink Pro is

about the suggested placement. The tooltip for any

entry in the list shows the full title and location for

it. This part is only visible when the sorcerer's hat

button is used.

To move the document to one of the suggested

groups, select the group and click Move To.

Alternatively double-click the group. For your

convenience, DEVONthink Pro preselects a single

group, or multiple groups if it is unsure. Drag the file

into any item list to move it, e.g., into a main window.

Use the ⇧ and ⌘ keys to select more than one target.

This generates replicants.

Note: Any replicants of the document being

moved are deleted. The document is only

placed in the new locations, which allows you to

precisely classify the document again without

having to manually clean up old replicants.

SEE ALSO

See Also lists similar documents; thus, it helps

you find information likely dealing with the same

subject. The see-also list shows documents and/or

selected text or topics within documents that are

similar to the selected one (when you have used the

contextual menu items or the document's topics

pop-up menu). Like the classify list, this list shows

the path to the document and a graphical score of



DEVONthink Pro 2.9.4 Documentation, page 81

how sure DEVONthink Pro is about its decision. The

tooltip for any entry in the list shows the full title

and location for it.

To display a document in the drawer, select it. For

your convenience, DEVONthink Pro always lists

the original document at the top of the list. This way

you can easily go back to the original document.

Double-click a document in the drawer to open it in

a separate window; drag it into an item list to move

it.

CONTEXTUAL MENU

Use the contextual menu on groups in the See Also

& Classify drawer for more commands.

Open: Opens the selected item in a separate main

window.

Open in Tabs: Opens the selected item in a new

tab.

Open With: Opens the selected item in an external

application.

Launch URL: Opens the URL in the selected item's

URL field.

Copy URL: Copies the Internet location stored

in the URL field of the selected item to the

clipboard.

Reveal: Shows and selects the selected item.

Show in Finder: Shows the selected item in the

Finder.

Move To: Moves the selected item to the group

you select from the sub-menu.

Replicate To: Replicates the selected item to the

group you select from the sub-menu.

Duplicate To: Duplicates the selected item to the

group you select from the sub-menu.

Label: Changes the label of the selected item.

Mark: Changes the check, lock, and read status of

the selected item.

Move All Instances To Trash: Moves all instances

of the selected item to the trash, including all

replicants (if any).

Group: Creates a new group containing the

selected item(s). Appears as Tag if the new group

would be created in the Tags group.

CONCORDANCE

The Concordance drawer appears when you

click the Concordance button in the document's

navigation bar. It lists all words in that document

similar to the Concordance window. Select one or

multiple words (with the ⇧ and ⌘ keys pressed)

in the drawer to highlight their occurences in the

document.

You can sort the list in the drawer by clicking the

title of the column you want to use for sorting. Click

the column title again to reverse the sorting order.

Double-click any word in the drawer to open the

Search window with this word already filled in.

To close the drawer, click the red close button.

SMART GROUP EDITOR

The Smart Group Editor appears as a sheet when

you either create a new smart group using Data >

New > Smart Group, when you right-click a smart

group and choose Edit from the contextual menu, or

when you double-click a smart group.
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In this sheet you set up a new smart group or edit an

existing one:

Search in: Select where you want this smart group

to search.

List of search predicates: Build your list of search

criteria (in search speak: "predicates") here. See

below.

Ignore Diacritics: Check this to treat letters with

diacritics, e.g., umlauts or accented characters,

the same as their regular counterparts.

Fuzzy: Check this to search "unsharp" terms,

e.g., ignoring simple typos so that instances of

"Merkel" and "Merkle" are both found.

The list of predicates consists of a list of blocks,

each beginning with "All" or "Any", defining whether

all (Boolean AND) or any (Boolean OR) of the

contained predicates need to be true for the

document to be returned as a result. Predicates

themselves consist of the field to search (like

"Content" or "Tag"), and the condition and the data

that needs to be matched.

Note: In most predicates you can use wildcards,

Boolean operators, phrases, and parenthesis, too.

See also p. 128ff

Use the + and - buttons to add more predicates

to your smart group or to delete them. Hold the

⌥ modifier key and click a ... button to create

a "compound predicate," also called "branch".

Predicates can be in/outdented and rearranged via

drag-and-drop.

By adding more lines to a search and choosing

between "All" and "Any" you graphically create

a nested Boolean query with ANDs, ORs, and

parenthesis.

Example: To find all Microsoft Excel files use the

condition Filename ... ends in ... xslx. To find items

created in the last 7 days use the condition Date

created ... is ... Last Week.

PREDEFINED SMART GROUPS

When you create a new database, DEVONthink Pro

adds a number of predefined smart groups for your

convenience:

All Images: Shows all images.

All PDF Documents: Shows all PDF documents.

Duplicates: Lists all duplicates.

Recently Added: Lists all documents added this

week.

To Do: Shows all documents with visible but

unchecked state.

By default, the following smart groups are added to

the sidebar:

Today: Shows all documents added or modified

today.

Yesterday: Shows all documents added yesterday.

Unread: Shows all documents marked as unread.

Note: Smart groups also filtering for date ranges

are shown with a clock icon.
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PREFERENCES

In this chapter:

General 83

Editing 84

Import 85

Sorter 86

Media 86

Colors 87

Web 87

RSS 88

Sync 89

Backup 90

Update 91

The Preferences window, which you open by

selecting Preferences in the application menu,

is the place to go to change global settings for

DEVONthink Pro. In addition to global settings,

databases also have separate settings in their

Database Properties window that you open using

File > Database Properties.

There is also a number of hidden preferences,

intended for customer support, but maybe useful

for you, too. See also p. 132ff

GENERAL

Use the General tab to set the general settings for

the user interface.

APPEARANCE

These options define some parts of the visual

appearance.

Alternating row colors in views: Check to color

every second row in item lists differently.

Display number of items inside groups: Check to

show the number of unread and read documents

contained in a group. Number will appear in

parenthesis after group names. If this option is

unchecked, news feed still show the number of

unread items.

Highlight Internet links in views: Check to show

link documents marked in blue and underlined in

item lists.

Mark duplicates and replicants in color: Check to

highlight duplicates marked in blue and replicants

marked in red in most views. When unchecked

duplicates and replicants are marked with file

property icons.

LABELS

Choose how you would like labels to be shown in

lists.

Classic: Tints the group/document icon (like on

Mac OS 9).

Modern: Puts the group/document name in a

colored bubble (like on older versions of OS X).

Dots: Shows a colored dot in the list (like on OS X

Mavericks).

INTERFACE

These options define some parts of how you interact

with the user interface.

Hide 'Groups & Tags' panel when inactive: Check

to hide the Groups panel in applications other

than DEVONthink Pro.

Open contents after using 'New with Clipboard':

Check to let DEVONthink Pro switch to newly

added items after adding them using Data > New >

With Clipboard or via the Dock menu.
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Always open groups in a new window: When

checked, double-click a group to open it in a

separate window. When unchecked, double-click

the group to make it the new root of the current

window. Use Go > Top Group and Go > Enclosing

Group to go up the groups hierarchy again.

Retain view: When the above option, Always

open groups in a new window, is unchecked, the

actual view settings are maintained when you

navigate the group structure instead of the

group's individual settings being applied.

Enable tabbed browsing: When checked, click

with ⌘ pressed a link in web, PDF or text views

to open it in a new tab. When unchecked or the ⌘
modifier key isn't pressed, documents are opened

in the same view, in the default application or in

new windows.

FONTS

Use List Views Font and Column View Font to set the

font DEVONthink Pro uses for displaying item lists

in list and column views.

Note: Hold the ⌥Option key to restore the

default fonts.

EDITING

The Editing tab defines all options that fine tune

DEVONthink Pro's text editing behavior, from the

ruler units to WikiLink templates to summarization

options.

GENERAL

Display PDF attachments of rich texts: Show the

content of PDFs attached to RTF documents.

Check spelling while typing: Spell check

everything you write all the time.

Check grammar with spelling: Check the grammar

when checking the spelling.

Correct spelling automatically: Correct misspelled

words automatically.

Smart quotes: Use curly quotes instead of simple

English ones.

Smart copy/paste: Insert or remove spaces before

and after cut or pasted text.

Smart links: Detect web addresses and turn them

into clickable links automatically.

Smart dashes: Convert characters, e.g., two

hyphens into a proper dash.

Data detectors: Detect dates, times or addresses

in text, and show possible actions when the

mouse cursor moves over them (Mac OS X 10.6

or later).

Text replacement: Use the system-wide text

replacements when editing text (Mac OS X 10.6

or later).

AUTHOR, RULER UNITS AND FONTS

Author: Enter your name. It will be used as default

for metadata, e.g. for new rich text documents or

PDF annotations.

Ruler Units: Select your personal preference for

ruler units such as centimeters or inches, points

or picas.

Plain/Rich Text Font: Select your preferred fonts

for new plain or rich text documents. Note: By

their nature, plain text documents are always

displayed in the font selected, whereas rich text

documents can be styled any way the author

wants.

FULL SCREEN

Full Screen: Select your preferred font for reading

and editing plain text files in full screen mode.

By their nature, rich text documents are always

displayed using their own styles also in full screen

mode.
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Background: Choose a background color for the

full screen mode. This setting only affects the

background of plain text files and the border

to the left and right of rich text documents. By

their nature, rich text documents bring their own

background color and so don't use the color you

set here.

Text: Choose a text color for the full screen mode.

Width: Choose a width for displaying documents

in full screen mode as a percentage of the screen

width. Use this setting if the presentation in full

screen mode appears too wide on a large screen.

WIKILINKS

WikiLinks: Check Automatic if you want to

make every word that is also the name of

another document or group in the database

automatically link to the document of the

same name (WikiLink). This mechanism can be

restricted to not link to groups, as well as to only

accept meshed words. (For example, words with

a capital letter in the middle like "QuickTime";

this is the classic WikiLink method to distinguish

between regular words and links.) Check Open

new documents in separate windows to open a new

window when you click a WikiLink, instead of

switching to the linked document.

Template: Enter a template text here. This will

be used to create a new document when you

make text a link that does not point to an existing

document yet. You can use various placeholders

to automatically insert text--the current date and

time, for example.

SUMMARIZATION

Select whether you wish DEVONthink Pro to

calculate summaries from sentences or from whole

paragraphs.

IMPORT

Here you decide which file types DEVONthink Pro

imports and how those files will be named in the

database.

FILES

These options define whether DEVONthink Pro

imports files of a given type when you import

folders using File > Import or via drag-and-drop.

<type>: Select all the file types you want

DEVONthink Pro to recognize when importing

folders. DEVONthink Pro always imports every

file you import manually.

Encoding: Choose the default encoding for

plain text documents. Select Automatic to let

DEVONthink Pro choose the best encoding.

Other file types: Check to import files of a type

unknown to DEVONthink Pro. QuickLook and

Spotlight are used to access and display the

contents of the file.

TITLES

Select how you want DEVONthink Pro to name

imported documents: with file name extensions,

without file name extensions, or by using localized

display names (for example, on a German system

the "Applications" folder would appear as

"Programme").
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NEW NOTES

Check Select (and display) automatically to

automatically select and display the last note you

have taken.

DESTINATION

Choose the default destination where data is stored

that's coming in from bookmarklets, DEVONagent

Pro, news feeds, (external) scripts, or services.

Select group: A group selector is shown that lets

you choose the destination. The group selector

appears as a black panel floating on top of all

other windows. It does not bring DEVONthink

Pro to the front. Use it to select the group where

you want to file the items and add tags.

Global inbox: The data is stored in the global inbox.

Inbox of current database: The data is stored in

the inbox of the current active database.

SORTER

The Sorter preference allows you to assign a hotkey

for capturing a selection into the inbox of the Sorter,

as well as a hotkey for taking a new note, showing

the Sorter at login, and starting or quitting the

Sorter manually. See also p. 27ff

AVAILABILITY, HOTKEYS

Check Start Sorter at login to start the Sorter

immediately after you log in. Check Visibility: Full

to make the Sorter tab fully visible, or uncheck it to

make the tab fade when the mouse pointer is moved

off it.

To change the hotkeys for taking a new note or

copying a selection, click the Click to record shortcut

button, then press the hotkey that you want to

use. Press the Escape key to cancel recording a new

shortcut. When the Sorter is not running, this hot

key opens the Take Note panel.

HIDER SORTER IN FULL SCREEN

This lists shows all full screen applications that

Sorter is tracking. Add other applications using the

+ button, and check or uncheck applications to hide

Sorter when the application is going to full screen

mode.

Reset the full screen settings to make DEVONthink

Pro "forget" all remembered applications.

Click Start or Quit to start or quit the Sorter

manually.

MEDIA

In the media preferences, you tell DEVONthink Pro

how to handle multimledia files, images, PDFs and

other documents for which DEVONthink Pro can

create thumbnails.

The following options are available:

Movies: Check Create thumbnails if you want

DEVONthink Pro to create thumbnails for

imported or indexed QuickTime movies. Movie

documents without thumbnails will appear with

a generic icon, while movies with thumbnails

show miniature views of their content. Check

Play automatically to play QuickTime movies
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automatically when you display them, and check

Loop if you want to play the clips in a loop. You

can also choose a background color for viewing

movies.

Images: Check Create thumbnails if you want

DEVONthink Pro to create thumbnails for

imported or indexed images. Check Generate from

actual image to ignore thumbnails embedded

into the image files and let DEVONthink Pro

generate the thumbnails from the actual image.

Choose a background for viewing images using

the standard Mac OS X color chooser, and choose

a default zoom factor.

PDF & PostScript documents: Check Create

thumbnails if you want DEVONthink Pro to create

thumbnails for imported or indexed PDF and

PostScript files. Choose the default display mode

for windowed and full screen modes and set the

background color for viewing PDFs.

Create Thumbnails: Check Web Archives,

Formatted notes, Bookmarks, or Other files if

you want DEVONthink Pro to try to create

thumbnails for these file types.

COLORS

Here you can name and choose the seven label

colors DEVONthink Pro uses to mark documents

and groups, as well as set seven colors you can use

to highlight text.

WEB

The web preferences resembles the settings of most

web browsers. Use these preferences to define how

DEVONthink Pro's displays web documents and

"live" web pages.

WEB CONTENT

These settings define how DEVONthink Pro treats

special web contents:

Enable ...: Check these options to use installed

third-party plug-ins, (such as Flash or RealPlayer

plug-ins), and to run Java applets or JavaScript

scripts contained in, or linked to, a web page.

Block ...: Check Block pop-up windows to block pop-

up windows, which are often advertisements;

check Only automatic JavaScript windows to block

only pop-up windows opened by JavaScript.

Uncheck this option if the web page you're

visiting uses pop-up windows for actual content.

(Some web content management systems do

this.) Check Block zooming to keep web sites

from automatically zooming windows to full size.

Check Block advertisement to block common inline

advertisements provided by some search engines.

Zoom text only: Check to zoom only the text and

uncheck to use Safari 4-style zooming.
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IMAGES

These settings define how DEVONthink Pro

displays graphics in web pages:

Display images when the page opens: Check this

option to diplay web pages with images. Just

remember, if unchecked, you may miss some

information.

Animate images, Loop animation: Check these

options to run web graphics animations and to

run animated graphics in a loop.

ACCEPT COOKIES

Cookies are little text files with information that

web pages store on your computer use to recognize

you as a returning customer, among other things.

While most cookies are harmless, you may want to

control what is being stored on your hard disk.

Always: Accept all cookies.

Never: Don't accept any cookies.

Only from sites you navigate to: Accept cookies,

but only from web sites you navigate to (not from

other sites, such as ad trackers).

Delete cookies on quit: Delete all stored cookies

when you quit DEVONthink Pro.

FONTS

Set the fonts you want to use for displaying web

pages; set separately for variable-width and fixed-

width text.

Note: Hold the ⌥Option key to restore the

default fonts.

STYLE SHEET

You can further control the way DEVONthink Pro

displays web pages by applying a CSS style sheet

that changes the rendering on the fly.

Click Select and choose your style sheet to apply

it to DEVONthink Pro's integrated web browser.

Note: This is for experts since it modifies how all

web pages are displayed and can lead to undesired

effects.

TEXT ENCODING

Select your desired text encoding for displaying web

pages. Automatic tries to choose the best available

encoding. If this does not work for you, choose a

more appropriate text encoding for your language

group.

RSS

DEVONthink Pro comes with built-in RSS

capabilities that enable you to add RSS feeds to your

database and have DEVONthink Pro update them

automatically.

RSS feeds are represented in DEVONthink Pro

like smart groups, which update themselves with

content from the Internet. You create these feeds

with Data > New > Feed and use them like any other

group.

Use the RSS preferences to define how often

DEVONthink Pro checks for new articles, whether

to skip duplicates when updating feeds, when to

remove older articles, and which CSS style sheet

to use for displaying the articles. Unread or locked

articles are never automatically removed. Check

Also unread articles to also remove unread articles

when cleaning up, and check Convert categories to

tags to tag imported articles automatically if the

feed contains categories.

DEVONthink Pro comes with multiple styles

for displaying feed articles. You can use your

own RSS stylesheets by placing them into "~/

Library/Application Support/DEVONthink Pro 2/

StyleSheets".
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SYNC

DEVONthink Pro allows you to keep multiple copies

of your databases on multiple Macs and iOS devices

running DEVONthink To Go 2.0 in sync. Use these

options to control which databases are synced

how often with which locations. Learn more about

synchronization and how to set it up in a separate

part of this documentation.

LOCATIONS

The first column lists all sync locations you have set

up. In addition it lists available direct connections

and templates for quickly setting up new locations.

Active locations are checked, locations not yet set

up are shown in grey.

Check any location to activate it. If it is not yet set

up, DEVONthink Pro will show a sheet requesting

all necessary details. Only a subset of the following

fields is shown, depending on the nature of the sync

location:

URL: The URL of your WebDAV volume including

path to the folder where the sync store is location

or shall be created.

User name: The user name of the service.

Password: The password of the service or set on

the host for a direct connection.

Sync Store Name: The name of the sync store. To

access an already existing sync store make sure to

enter the name correctly.

Encryption password: The password used

to encrypt the sync store with AES 256 bit

encryption.

Synchronize label names & colors: Check if you

want to bidirectionally synchronize label names

and colors using this location.

Synchronize database properties: Check if

you want to bidirectionally synchronize the

database's properties using this location.

Synchronize content of indexed files: Check if

you want to synchronize the content of indexed

files using this location. If you uncheck this option

only the metadata about the document will be

synchronized. In this case the document can only

be downloaded from another device participating

in the sync through a direct connection but not

from the sync store (which only contains the

metadata).

Verify uploaded items: Check to verify all

uploaded items to make sure that they're intact.

Usually only necessary on very instable network

connections or in case you experience troubles

with defective files.

Use the tools below the locations list for more

options:

Add: Click the + icon to add locations not listed by

default, e.g. to create a local sync store.

Remove-: Select a location and click - to remove

the location.

Info: Select a location and click  to show and

change the location properties.

Action: Select a location and click  for further

options including revealing local sync stores in

the Finder, verifying their consistency (hold the

⌥ Option key to verify throroughly), or cleaning

the location.

These commands are also available via the

contextual menu.

Note: You can also add existing local sync stores

(packages with the file name extension .dtCloud)

by dragging them into the locations list,

DEVONthink Pro's Dock icon, or by simply

double-clicking them.

DATABASES

The second column lists all currently open

databases as well as all databases available

remotely in the selected location. Show or hide

remote databases by clicking the Remote list header.
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Check any database that you want to have

synchronized using the selected location. If the

database is also already available through the

location, both versions of the database will be

merged and conflicts solved using the chosen

conflict solving strategy (see below).

Use the tools below the locations list for more

options:

Import: Select a remote database and click  to

download the data of the database and save

it locally. The database will be automatically

configured to sync with this location.

Sync: Select a checked database and click  to

manually sync the database with this location.

Refresh: Refreshes the list of remote databases.

Action: Select a database and click  for further

options including verifying its consistency (hold

the ⌥ Option key to verify throroughly) or clean

the database.

OPTIONS

Change the general sync settings affecting all

locations and databases below the two lists:

Synchronize: Choose if you want to synchronize

automatically, manually, or in fixed intervals.

Max. Connections: Choose the maximum number

of connections DEVONthink Pro should open.

The faster your internet connection the higher

you can usually go. The recommended value is 16.

Conflicts: Choose how to solve the conflict if an

item was changed both locally and remotely. Use

latest document lets the version of the document

'win' which was changed last. Duplicate documents

keeps both versions of the item and lets you deal

with them later.

Note: Dropbox and box.com locations always use

only 8 connections. If you experience problems

with these locations you might want to reduce

the maximum number of connections to 4 or less.

BONJOUR OPTIONS

Click the button Bonjour Options to control if

and how other instances of DEVONthink or

DEVONthink To Go can connect to your Mac. Your

Mac becomes the sync host or sync server, the other

devices the clients.

Enable incoming connections: Check to let other

devices connect to your copy of DEVONthink Pro

and synchronize.

Open databases automatically: Check to open

databases automatically if the connecting side

(client) requests it.

Port: If needed you can change the IP port number

used for incoming connections. Leave empty

to let DEVONthink Pro choose the best port

number for you (recommended).

Password: Set the password necessary to

connect to your instance of DEVONthink Pro

(mandatory). This password is also used for

AES-256-encrypting the connection at all times.

BACKUP

DEVONthink Pro comes with a simple backup

function that backs up the database index on a

regular bases. These options define how often

DEVONthink Pro will back up indexes.

The backup automatically duplicates all important

database files and moves the duplicates into

a folder(s) named "Backup(.x)" within the
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DEVONthink Pro database folder/package. Select

how often you want to have the backup created--

never, daily, weekly, or monthly--and how many

copies of the index your want DEVONthink Pro to

keep. Of course, you can create a backup at any time

using Tools > Backup & Optimize.

These options do NOT backup the whole database

to a secure location; they simply make sure there's

a copy of the index files in case the index get

corrupted. To back up your complete database, use

Time Machine or a third-party backup software.

DEVONthink Pro also comes with a number of

handy scripts that export your database as files and

folders (independent from DEVONthink Pro). See

also p. 94ff

UPDATE

Change the settings in this tab to define when

you want DEVONthink Pro to check for new

versions: never, on startup, daily, weekly, or monthly.

DEVONthink Pro only performs checks for updates

when the computer is connected to the Internet.

Click Check Now to immediately check for a new

version.

Note: Disable the check for new versions

when your network connection is unstable

and you experience long delays when opening

DEVONthink Pro. The Update pane is not

available if you have purchased DEVONthink Pro

from the Mac App Store.
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SCRIPTS

In this chapter:

Introduction 92

Installation 93

Internal scripts 93

Browsers, email, and more 96

Triggered scripts 97

Toolbar scripts 98

Droplets, folder actions, mail rules, PDF

Services 98

More examples 99

Automator 100

DEVONthink Pro comes with a fully loaded

AppleScript dictionary that allows you to automate

almost every aspect of the application. Use the

included add-on scripts and Automator actions to

perform seldom-used, but useful, functions. Or, use

the included scripts and actions as templates for

your own scripts and workflows.

INTRODUCTION

DEVONthink Pro features one of the largest

AppleScript dictionaries of all Mac OS X

applications. These scripts make it possible to

automate nearly every aspect of the application, and

to integrate the application with almost every other

application supporting AppleScript.

EXAMPLE SCRIPTS

To make it easier for you to start with scripting,

we deliver a slew of scripts with DEVONthink Pro

that you can access in the Scripts menu (which

shows a stylized S symbol as its title instead of the

word Scripts). These scripts interact directly with a

selected group or document, or create documents

themselves. In addition, the smart template are

based on AppleScript scripts. All scripts delivered

with DEVONthink Pro are useable in everyday

work, and are not simple example templates that

need to be tinkered with first.

Other ways to use AppleScript for extending

and integrating DEVONthink Pro are triggered

scripts, folder actions, droplets, and PDF Services

scripts. You will find descriptions of the scripts that

come with DEVONthink Pro in the corresponding

sections of this chapter.

INTEGRATING OTHER APPLICATIONS

In addition to the scripts that you use inside

DEVONthink Pro, Mac OS X features a global

scripts menu that gives you access to certain scripts

from any application on your Mac. When activated,

it appears at the right side of the menu bar (along

with other menu extras such as the AirPort signal

strength or the Spotlight icon). It appears with a black

stylized S icon.

Note: By using folders named after applications

inside the "~/Library/Scripts/Applications"

directory, it is also possible to make scripts

application-specific. Such scripts will appear at

the top level of the global script menu when that

application is active in the desktop window. This

removes clutter and shows only scripts that make

sense in the current application.

DEVONthink Pro already comes with a number

of scripts that you can access conveniently from

the global script menu. DEVONthink Pro asks to

install them whenever you update the application,

or you can (re-)install them manually by selecting

DEVONthink Pro > Install Add-ons. They will be

installed in "~/Library/Scripts/Applications/

<TargetApp>" and only apply for the user currently

logged in. Also, they only show up in the script menu

when the application for which they are designed is

the front-most application (the one that currently

populates the menu bar).

To activate the global script menu, do the following:

Open the AppleScript Utility (located in "/

Applications/AppleScript").

Check Show Script Menu in menu bar.
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Uncheck Show Library scripts if you only want to see

the scripts you have installed yourself.

To install your own scripts (such as the scripts that

come with DEVONthink Pro), copy them into the

folder "~/Library/Scripts". You can use sub-folders

to structure them in any way you like.

DEVONTHINK PRO'S DICTIONARY

DEVONthink Pro includes a large dictionary with

commands, objects, and methods you can use for

writing scripts that interact or extend DEVONthink

Pro. To view the dictionary, open the Script Editor

application (by default located in "/Applications/

AppleScript"), select File > Open Dictionary and

choose DEVONthink Pro in the appearing window.

You can also add DEVONthink Pro to your Script

Editor library. Select Window > Library, click the +

button and choose DEVONthink Pro. This way you

keep DEVONthink Pro's dictionary at hand.

TALKING TO DEVONTHINK PRO

In AppleScript you "talk" to programs like

DEVONthink Pro using a "tell" statement, referring

to the application either by its name or its bundle

identifier. This might become incompatible with a

future version of DEVONthink Pro so we strongly

recommend to refer to this application using the ID

"DNtp", like in the following statement:

tell application id "DNtp" [...] end tell

LEARNING APPLESCRIPT

This documentation is not an AppleScript language

guide. Please refer to Apple's AppleScript web

site, other online resources, or introduction and

reference books for more information on the

AppleScript language. Here are some links for you:

The Ultimate Beginner's Guide to AppleScript

AppleScript, the Language of Automation

MacScripter

ScriptWeb

TECsoft Hands-On Trainings

Scripting Matters Trainings

AppleScript for Absolute Starters (free PDF book)

AppleScript: The Missing Manual

AppleScript: The Definitive Guide

INSTALLATION

All add-on scripts that come with DEVONthink Pro

are automatically installed or updated when you

open a new version of DEVONthink Pro for the first

time. You can, however, manually (re-)install them

by choosing DEVONthink Pro > Install Add-ons

The scripts are installed in a number of locations:

Application Scripts: These scripts are installed in

"~/Library/Scripts/Applications/" and can be used

from the global script menu. See also p. 96ff

DEVONthink Pro Scripts: These scripts are

installed in "~/Library/Application Support/

DEVONthink Pro/Scripts" and can be used from

DEVONthink Pro's own script menu. See also p.

93ff

PDF Services Scripts: These scripts are installed in

"~/Library/PDF Services/." They extend the PDF

button in any application's print dialog. See also p.

99ff

INTERNAL SCRIPTS

The internal scripts menu of DEVONthink Pro,

located to the left of the Help menu (in DEVONthink

Pro's menu bar), gives you access to a large number

of pre-made scripts and Automator workflows that

extend DEVONthink Pro with additional, more

specialized commands and functions.

More scripts are available as extras. See also p. 68ff

Of course, you can easily modify all these scripts

using the AppleScript Editor (and the workflows

using Automator) or add your own scripts and

workflows to the menu. They are located in "~/

Library/Application Support/DEVONthink Pro/

Scripts". Open this folder in the Finder with Scripts >

Open Scripts Folder.

Keyboard shortcuts: If you want to add keyboard

shortcuts to scripts in this menu, either use

the System Preferences or add the shortcut

description to the file name of the script in "~/

Library/Application Support/DEVONthink Pro/

Scripts" or "~/Library/Scripts". Example: "eMail

http://www.apple.com/applescript
http://www.apple.com/applescript
http://mac.appstorm.net/how-to/applescript/the-ultimate-beginners-guide-to-applescript/
http://www.macosxautomation.com/applescript/
http://macscripter.net
http://www.scriptweb.org
http://www.tecsoft.com/ascourse.html
http://www.scriptingmatters.com
http://www.devontechnologies.com/redirect.php?id=download-ebook-as4as
http://www.amazon.com/exec/obidos/tg/detail/-/0596008503/qid=1121266897/sr=8-1/ref=pd_bbs_ur_1/002-5709247-5091254?v=glance&s=books&n=507846
http://www.amazon.com/exec/obidos/tg/detail/-/0596005571/qid=1121266897/sr=8-2/ref=pd_bbs_ur_2/002-5709247-5091254?v=glance&s=books&n=507846
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Current URL (Mail)___Cmd-Alt-M.scpt". The naming

convention is three underline characters followed

by the shortcut description. "Cmd" stands for the

⌘Command, "Alt" for the ⌥Option, "Ctrl" for the

⌃Control, and "Shift" for the ⇧Shift keys.

Caching: All scripts in this menu are cached and

therefore their properties are persistent until you

quit and relaunch the application or DEVONthink

Pro automatically updates the menu, e.g. after

adding or removing scripts.

Note: If you have modified the contents of

the script menu and want to go back to the

default set, delete the Scripts folder in "~/

Library/Application Support/DEVONthink

Pro/". DEVONthink Pro will recreate this folder,

including it's content, the next time you launch

the application.

COMMENTS

Assemble: Collects the comments of the selected

documents and creates a new document listing

them.

Speak: Speaks the comments of the selected

documents.

DATA

Convert to Tags: Converts the tag contained in the

comments field to real tags if the comments field

of the selected document contains tags separated

by commas. See also p. 121ff

Move Duplicates to Trash: Moves all duplicates of

the selected document to the trash.

Find & Remove Similar Contents: Finds and

removes similar documents.

Group With Duplicates: Creates a group with

duplicates of the selected documents.

Group With Replicants: Creates a group with

replicants of the selected documents.

DATES

Creation > Modification Date: Sets the

modification date of the selected items to their

creation dates.

Modification > Creation Date: Sets the creation

date of the selected items to their modification

dates.

Touch Creation Date: Sets the creation date and

time of the selected items to the current date and

time.

DOWNLOAD

Images of Page: Adds the images of a displayed

web page to the database.

Linked Images of Page: Adds linked images of a

displayed web page to the database.

Links of Page: Adds links contained on a displayed

web page to the database.

Create Offline Archive: Creates an offline version

of a displayed web page.

EDIT

Count Characters: Counts the characters in the

current selection.

Count Words: Counts the words in the current

selection.

EXECUTE

AppleScript: Executes an AppleScript script.

Perl: Executes a Perl script.

Shell: Executes a shell script.

EXPORT

The following scripts provide some seldom-used

export functions and help you create backups of

your database (for copying them to external media

such as CD-R or JungleDisk).

Listing: Saves a UTF-8 text file containing a text

listing of the names of all contents/groups of the

current database.

Daily Backup Archive: Creates a backup of the

database in "~/Backup". All backups are named

after the current date so that multiple backups

are kept.

To JungleDisk: Exports all items in the database

as a Zip archive and copies the backup archive to

your JungleDisk. Please note that for this script

to work, your JungleDisk needs to be named

"JungleDisk".

http://www.jungledisk.com
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FEEDS

DEVONthink Pro can be used as a news feed reader.

To work with news feeds, use the dedicated feed

document type.

The following scripts demonstrate additional

methods of how DEVONthink Pro can directly

plug into live information sources by the use of

AppleScript.

Apple -- Hot News: Creates an HTML document

with Apple's Hot News.

Nature -- Hubble News: Downloads the latest

Hubble news.

iTMS -- Added Albums: Downloads covers of

albums recently added to the iTunes Music Store.

FORMAT

Body Normal: Formats selected text as "Body

Normal".

Body Small: Formats selected text as "Body Small".

Header Capitalized: Formats selected text as

"Header Capitalized".

Header Normal: Formats selected text as "Header

Normal".

Header Secondary: Formats selected text as

"Header Secondary".

Source: Formats selected text as Source.

Reset Spacing: Resets the line and paragraph

spacing of selected rich text.

IMAGES

Copy Info to Comment: Copies basic image info to

the comment field.

Flip Horizontal / Vertical: Flips the image

horizontally/vertically.

Rotate Left / Right: Rotates the image left/right.

Landscape to Portrait: Rotates only landscape

images to portrait.

Portrait to Landscape: Rotates only portrait

images to landscape.

Scale to 1024 pixels wide: Scales the image to

1,024 pixels wide.

Scale to 1024 pixels: Scales the image to 1,024

pixels.

Scale to 200%: Scales the image to 200 percent.

Scale to 50%: Scales the image to 50 percent.

Note: While these scripts work with PDF

documents it is not advisable to do so. The

functions only act on the first page of a multi-

page PDF; the resulting document will contain

the first page only.

IMPORT

These scripts demonstrate DEVONthink Pro's

ability to import data from various sources,

including web sites.

Astronomy Picture of the Day: Imports the

Astronomy Picture of the Day.

Daily Dilbert: Imports the Daily Dilbert.

Del.icio.us: Imports your del.icio.us bookmarks.

The descriptions are used to name the imported

bookmarks; the notes and the tags are added to

the comments. If the keychain does not contain a

key for del.icio.us, dialogs pop up allowing you to

enter the user name and password.

Man Page: Imports a UNIX manual page as a PDF

document.

Mars Explorer Rover Mission Im.: Imports Mars

Explorer Rover Mission Images.

Perldoc: Imports the documentation of Perl pages,

modules, functions, or programs.

Phone List: Imports all phone numbers from

Contacts.

The following scripts import chatlogs and call logs

from popular instant messaging clients as well as

from your mobile phone:

Adium Chatlogs: Imports all your chatlogs from

the Adium instant messaging client, converts

them to readable HTML, and stores them in

your database. The Contacts applications is used

to resolve instant messaging account names if

possible.

iChat Chatlogs: Imports your iChat chatlogs.

REMINDERS

Add as Event to Calendar: Adds a new event to

Calendar or iCal linking back to the selected item

in DEVONthink Pro.

Add as To Do to iCal: Adds the selected item as a

to-do item to iCal.

Add as To Do to OmniFocus: Adds the selected

item as a to-do item to OmniFocus.

http://del.icio.us
http://www.adiumx.com
http://www.omnigroup.com/products/omnifocus/
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Add as To Do to Reminders: Adds the selected

item as a to-do item to Reminders.

Add as To Do to The Hit List: Adds the selected

item as a to-do item to The Hit List.

Add as To Do to Things: Adds the selected item as

a to-do item to Things.

RENAME

Add Prefix: Adds a prefix to the titles of selected

documents.

Add Suffix: Adds a suffix to the titles of selected

documents.

Append Selected Text: Appends the selected text

to the title of the currently selected item.

Replace Text: Replaces a text passage in the titles

of selected documents.

Selected Text: Sets the title of the currently

selected item to the selected text.

To Subject: Sets the titles of the selected

documents to the subject lines of the email

messages if the selected documents are email

messages.

To Webpage Title: Sets the titles of the selected

documents to the names of the web pages

pointed to by their URL fields.

SHEETS

Even though DEVONthink Pro is not a spreadsheet

application, it does have scripts that implement

basic sum and mean value functionality for sheets.

Add Multiple Records: Adds up to 999 empty

records to a sheet.

Column Sum&Mean Value: Calculates the sum

and average of a table column.

Row Sum&Mean Value: Calculates the sum and

average of a table row.

Check sums in last column: Checks the sums in the

last column on validity.

TOOLBAR

By default this contains no scripts. Add your own

scripts here and also to the toolbar of main and

search windows using View > Customize Toolbar.

THUMBNAILS

Flip Horizontal / Vertical: Flips the thumbnails of

selected documents horizontally/vertically.

Rotate Left / Right: Rotates the thumbnails of

selected documents left/right.

Landscape to Portrait: Rotates only landscape

thumbnails to portrait.

Portrait to Landscape: Rotates only portrait

thumbnails to landscape.

Note: While these scripts work with all image

formats including PDF, they should not be used

for PDF documents. They will only work on the

first page of the PDF and destroy all embedded

metadata.

ABOUT THIS MENU

Shows an information dialog window about the

Scripts menu.

BROWSERS, EMAIL, AND MORE

AppleScript is perfectly suited for integrating

different applications, interchanging information,

and creating workflows. DEVONthink Pro comes

with a number of scripts that copy information

from other applications, like Safari or Mail, to

DEVONthink Pro. You may use these scripts as a

template for connecting DEVONthink Pro to your

own applications.

To install these scripts automatically, select

DEVONthink Pro > Install Add-ons, check Application

Scripts and DEVONthink Pro Scripts, and click Install.

You access them via the global script menu extra.

Note: The application-specific scripts (put into

subfolders of "~/Library/Scripts/Applications")

appear only within the application they were

designed for (see introduction). To see them,

activate their designated application, e.g., by

bringing one of its windows to the front. The

other scripts are located in a submenu named

"DEVONthink Pro".

http://www.potionfactory.com/thehitlist/
http://culturedcode.com/things/
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WEB BROWSERS

These scripts import elements from a displayed

web page in Safari, Google Chrome, Firefox, or

DEVONagent to DEVONthink Pro.

Add abstracts to DEVONthink Pro (DEVONagent

only)

Add linked images to DEVONthink

Add linked images to DEVONthink's downloads

Add links to DEVONthink's downloads

Add tabs to DEVONthink (DEVONagent and

Safari)

Note: Not all of these options are available for all

browsers.

The scripts add the currently displayed page or

image, the selection or the text of the current page,

the linked images of the current thumbnail gallery,

or the links of the current page from your browser

to DEVONthink Pro or its download manager.

EMAIL APPLICATIONS

Note: If you are interested in pro-grade email

archiving, please also look at DEVONthink

Professional Office that comes with far more

advanced email archiving functions than

DEVONthink Professional.

You can drag messages from Apple Mail to

DEVONthink Pro to import them. In addition, you

can use the provided scripts or just transfer selected

text to DEVONthink Pro by using the Services menu.

DEVONthink Pro comes with scripts for Apple Mail,

Microsoft Entourage, and Microsoft Outlook 2011.

DEVONthink Pro provides the following scripts:

Add message(s) to DEVONthink

Add mailbox(es) to DEVONthink

Add attachment(s) to DEVONthink

Add message(s) & attachments to DEVONthink

They are located in the respective subfolder for

their target application and copy selected messages,

mailboxes, attachments, or both messages and

their attachment from Apple Mail, Microsoft

Entourage, or Outlook to the currently open

DEVONthink Pro database. If possible, they set the

creation and modification dates of the imported

messages to the receipt date and the URL field to

the sender's address. The scripts importing message

attachments also add the sender's email address

to the URL field. Both Add mailbox(es) scripts also

recursively import mailboxes inside the selected

mailboxes and rebuild the mailbox hierarchy within

a group named Entourage Mail or Apple Mail in the

currently open DEVONthink Pro database.

Note: Not all scripts are available for all email

applications.

OTHER SCRIPTS

The remaining scripts designed for the script

menu extra allow you to copy selected text to your

database, or to create a link to the front-most

document. They're grouped in the DEVONthink Pro

sub-menu.

Copy Selection: Copies the selected text and

creates a new plain text document in the default

destination.

Link to current document: Indexes the front-

most document (for example, a PowerPoint

presentation or an Excel spreadsheet) and

places the indexed document in the default

destination. This is handy when you are working

on a document and want to quickly place a

reference to it in DEVONthink Pro.

TRIGGERED SCRIPTS

Triggered scripts are AppleScripts that you attach to

an item in DEVONthink Pro (a group or document)

and that are executed each time you display this

item (like selecting it in Split view). Items with

attached triggered scripts show an AppleScript icon

behind their name.

Using triggered scripts, you can bring your items

to life and let them act intelligently on various

parameters. Examples for triggered scripts can be

found in the folder "Extras/Scripts/Triggered" on

the DEVONthink Pro disk image.

http://www.google.com/chrome/
http://www.mozilla.com/firefox/
http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
http://www.microsoft.com/mac
http://www.microsoft.com/mac/outlook
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ATTACHING A TRIGGERED SCRIPT

Besides creating scripts that attach themselves to

an item, you can attach them manually by doing the

following:

Select the document you want to attach a script to.

Open the Info panel ('Tools > Show Info').

Click Select next to the Script field and select the

script to attach.

REMOVING A TRIGGERED SCRIPT

To remove a triggered script from an item, do the

following:

Select the item you want to remove the triggered

script from.

Open the Info panel ('Tools > Show Info').

Select the contents of the Script field and delete it.

TOOLBAR SCRIPTS

You can also write scripts that you add to any

toolbar of a DEVONthink Pro window. This way you

can extend DEVONthink Pro's functionality nearly

endlessly.

To add a toolbar script place the script into the

folder "~/Library/Application Support/DEVONthink

Pro 2/Scripts/Toolbar" (where "~" represents

your home directory). To navigate to this folder

visit the Go menu in the Finder with the ⌥Option

key held which makes the "Library" menu item

visible. Then right- or ⌃Control-click the toolbar of

a DEVONthink Pro window and choose Customize

Toolbar. Drag your script into the toolbar.

DROPLETS, FOLDER ACTIONS,
MAIL RULES, PDF SERVICES

DROPLETS

Droplet are little AppleScript applications that allow

you to run actions based on files or folders dropped

onto them. You can create them easily using the

AppleScript editor; some useful examples come

with DEVONthink Pro on the disk image in "Extras/

Scripts/Droplets". Basically, droplets do what their

name suggests:

Import Droplet: Imports files and folders dropped

onto droplets.

Import Index Droplet: Indexes files and folders

dropped onto it.

Using droplets: Place a droplet anywhere you like

and optionally drag it to the Dock. Then, drag files

and folders onto the droplet icon in the Finder or

the Dock to trigger desired action.

FOLDER ACTIONS

Folder Actions are scripts that you can attach to

folders in the file system and that act on all items

you add to these "hot folders." DEVONthink Pro

comes with three folder action scripts that you can

install using the DEVONthink Pro > Install Add-Ons

menu option:

DEVONthink -- Import: Imports files into your

databases.

DEVONthink -- Import & Delete: Imports files into

your database, and moves the files to the trash

afterwards.

DEVONthink -- Import to selected group: Imports

files to the currently selected group.

DEVONthink -- Index: Adds references to the files

to your database.

DEVONthink -- Index to selected group: Adds

refrences to the files to the currently selected

group.

Attaching a folder action: To attach a folder action

script to a folder, do the following:

Right-click the folder.

Select Attach a Folder Action from the contextual

menu.

Select the folder action script you want to attach

and click Choose.

Manage folder actions: To manage all your folder

actions, right-click a folder and choose Configure

Folder Actions (Mac OS X 10.5) or Services > Folder

Actions Setup (Mac OS X 10.6) from the contextual

menu. Use the Folder Actions Setup utility to see

which folders have scripts attached, and to remove

folder actions from folders.
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MAIL

Using rules in Apple Mail you can automatically

process incoming messages, e.g., move them to

another mailbox or mark them as read. In addition

you can process them with scripts that archive them

or their attachments in your database, etc., (and add

the email address of the sender to the URL field of

the created document). DEVONthink Pro provides

the following scripts:

Mail Rule - Add messages to DEVONthink Pro

Mail Rule - Add attachments to DEVONthink Pro

Mail Rule - File messages & attachments

To use these scripts, do the following:

Open the "Scripts/Mail" folder on the

DEVONthink Pro disk image.

Put the script anywhere on your hard disk.

Create a new rule in the preferences window of

Apple Mail.

Define your criteria.

Add the Execute Script action.

Select the script you want to use.

If you're running OS X 10.8 or later use DEVONthink

Pro > Install Add-Ons to automatically install the

scripts into Apple Mail' mail rule scripts folder. You

can then select them from a pop-up menu when you

add the Execute Script action.

PDF SERVICES

Using PDF Services, you can add your own actions

to the PDF button of the print dialog windows in any

Mac OS X application. DEVONthink Pro adds an

alias of itself to the PDF Services folder.

Installation: To install the PDF Services alias select

DEVONthink Pro > Install Add-ons and check PDF

Services in the dialog window. Then click Install.

Printing to your database: To "print" (save) a

document to DEVONthink Pro as a PDF, open

it in its creator application (this could even be

DEVONthink Pro itself). Then, do the following:

Select File & Print.

In the appearing print dialog window, click the

PDF button at the lower left corner and select

Save PDF to DEVONthink Pro (saves to the default

destination) from the pop-up menu.

Then, select the destination group for the

document, if necessary, and click OK.

Note: This requires an installed printer to work

properly.

MORE EXAMPLES

Some of these scripts do things that have already

been implemented as "real" commands in

DEVONthink Pro; others are functions you will

seldom use. These scripts are intended as examples,

yet all can be of real use.

Create Contacts: Copies all entries of the Contacts

application to DEVONthink Pro, like File > Import

> Addressbook.

Cross-linked Text: Links selected text to currently

visible document. Demonstrates how to

programatically add links to a rich text document.

Export daily backup as files & folders: Exports

all items of the database as files and folders as a

daily backup.

Export to iPod: Exports selected documents as

notes to an attached iPod (3rd Generation or

later), like File > Export > to iPod.

Export to OPML: Exports selected documents as

OPML file, like File > Export > as Outliner Processor

Markup Language.

Fancy Text: Demonstrates some of the rich text

scripting capabilities of DEVONthink Pro.

Import Feed: Demonstrates how you can access

RSS feeds from DEVONthink Pro via AppleScript.

Latest Macintosh News: Downloads the latest

news from a number of RSS feeds and stores

them in the database.

Merge: Merges multiple selected document to one

long document, like Data > Merge.

Move to Done: Moves the selected item(s) to the

group Done in the top level of the database.

Open In PhotoStickies: Opens selected images in

PhotoStickies.

Open In Preview: Opens selected images in

Preview.

Prepare Backup: Creates a backup of the database

at a chosen location (like the Desktop), and makes

it a Zip archive that can be easily copied to an

external medium, an online drive, or a writable

disc.

http://www.devontechnologies.com/redirect.php?id=product-freeapps
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Quick Look: Opens a Quick Look head-up-display

window for the selected item.

Show recommended groups: Shows the groups

recommended by DEVONthink Pro's artificial

intelligence for the selected document.

You can also find more scripts in the Extras area of

the Support Assistant.

AUTOMATOR

DEVONthink Pro also comes with a bundle of

integrated Automator actions that you can use to

create your own workflows.

To see which actions DEVONthink Pro provides,

open a new workflow in Automator and click the

Actions button, then search for DEVONthink Pro

in the Library. Automator then displays all actions

contained in the application. Select any action to

show a short description about what the action

does.

Note: Cannot find the Automator action you need

for your workflow? We're open to suggestions!

OVERVIEW

We have created some workflow examples that

show you how to use Automator and DEVONthink

Pro together. This document explains what the

workflow examples are supposed to do, and how

you can adapt them for your specific use. The

examples presented here are grouped around

common functionality.

FILE MANAGEMENT

Managing files with DEVONthink Pro is one of its

best features. Here are different ways to work with

the information in the database.

Move existing files: You have a folder with files

that you think are in control by DEVONthink Pro,

but you want to move the files in the database to a

different folder (let's say "Archive"). This workflow

will solve this problem for you. For the given files/

directories, it will find all files, and ask the database

if items exist with these paths. For the ones that are

found to exist, move these to a specified folder.

Note: The exact locations have not been defined

in this workflow, that is up to you. DEVONthink

Pro will keep track of the moved files so you don't

have to change anything in the database.

To improve your workflow, specify a specific

database to use by preceding the Filter Items action

with an Open Database action. In general, it's a good

idea to specify the database a workflow has to act

on.

Add and move missing files: Find out what files are

not in the database by changing the value in the

Filter Items to Missing in the previous workflow. Then

the Move Finder Items action places these files in

their rightful place in the folder hierarchy. These

files will be sent to the Add Items to Current Group

action after setting the destination group; this will

index the files into the database.

To improve the workflow, specify a database to

use by preceding the Filter Items action with a

Open Database action. In general, it's a good idea to

specify the database you want a workflow to act on.

Start workday: This workflow is something you'd

start every day when you're ready for work. It is

rather complicated but shows off what you can do.

Let's go through the steps:

Step 1 to 2: We create the "Today: To Do" group in

the example database. This way we can be sure

that the next step has a group to work on.

Step 3: Then we run another workflow: Clean

Today's To Do. Here we completely clean the

contents of the "Today: To Do" group. By the way,

you may want to switch off the confirmation to

delete every record in Step 4 of this workflow, as

long as you don't add items by hand to this group!

Step 4: Here you can specify the different records

throughout the database you're working on.

Step 5: We only get the records not marked as

ready ('unchecked').

Steps 6 to 7: These are replicated to "Today: To

Do" list. This will also open a new window with

the items you want to work on today.

Step 8: Get every record including the ones in sub-

groups.

Step 9: Get the file paths from these records.

Step 10: Open the external files in the Finder.

You're ready to start working!

http://www.devontechnologies.com/redirect.php?id=contact
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End workday: At the end of your day, you'd like to

make sure that the database is updated with the

modified contents of the files you've been working

on. That's the goal of this workflow. It synchronizes

every record in your "Today: To Do" group.

WEB MANAGEMENT

Dealing with the web is where DEVONthink Pro

really shines. Here are a few workflows that will

help you manage the information you're gathering

from the Internet.

Capture Safari Page: Another take on getting

information from Safari. If you save this example

as an application and put it into your Dock, you can

very easily get the information from the current

web page in Safari into your database. This is

because the Add Items to Current Group workflow

will actually download the given URL so that its

contents are available for searching.

Convert URLs to Webarchive: This workflow shows

how you can convert URLs to webarchives. Let's go

through the steps:

Step 1-2: Make sure to select the records

with URLs that you want to replace inside

DEVONthink Pro.

Step 3: We download the URLs in DEVONthink

Pro.

Step 4: We want to use temporary files so we store

them in a variable to refer to them later.

Step 5: Back in DEVONthink Pro, we create a

"Converted Web Pages" group.

Step 6: Here we import the files. Note that we

import them because we regard the documents

as temporary files in Step 3. DEVONthink Pro will

copy the files to the database file folder for its

own safe keeping.

Step 7-8: We retrieve the list of files and send

them to the Finder's Trash.

Gather Information from Safari: The next two

workflows are not great for our bottom line, yet

we've decided to present these helpful hints free of

charge!

The first in the series is a script that gets all the

links (within the domain of the starting page) from

Safari's open web pages and puts them into a special

group called "Temporary Safari Links". For each

entry in this group, you can see its status. The

contents will be indexed (so loading these may take

a while).

Now you can go and do some searching for

information you want. For the records in this group

that match your criteria, you will set the state to

"checked."

Store Information from Safari: The second and last

workflow in this series will clear up the mess we

made. It gathers all the checked records and asks

to move these to a group you specify. (Note that for

this action we specified that the action has to be

shown.)

Also, take a look at Step 8. Here we have to Ignore

Result from Previous Action, because we don't want

you to delete the work that you spend so much time

on! The remaining records in the temporary group

will then be deleted.

Now, why are these two workflows bad for

our bottom line? Because they compete with

DEVONagent Pro. (Although, truth be told,

DEVONagent Pro does a much better job at this

then we can emulate with a couple of Automator

workflows).
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TROUBLESHOOTING
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DEVONthink Pro behaves irrationally 105

DEVONthink Pro was created with robustness in

mind. But any computer hardware or software,

regardless of how carefully developed and built,

can write defective data or destroy files. If you

experience problems with a database, please refer

to the methods below and also look at our FAQ.

PROBLEMS SYNCHRONIZING
DATABASES

The synchronization was designed to run in self-

maintenance mode so there should be little for you

to do to make it work. If, however, it does not work

as expected, please try the following steps before

contacting our user support:

Check your network connections.

Restart your computer.

For WebDAV or Dropbox locations, check the

following:

Check if the service you're trying to connect to is

reachable.

Check that you have entered your user credentials

correctly.

Check that you are connected to the right

WebDAV or Dropbox account.

Check the sync store name and encryption

password.

For direct connections also check the following:

Restart the other Mac or iOS device.

Restart your router.

Check if this computer is connected to the same

WiFi network than the other side.

Check if this computer an the other side are on the

same subnet.

Check that you have entered the same password

that you have set in the other side's Bonjour

options. See also p. 89ff

Check that both sides use the same port number.

Best practise is to leave the field empty and let

DEVONthink Pro choose the port number for

you. See also p. 89ff

Check if the firewall or Little Snitch enables

incoming connections to DEVONthink Pro.

Check if DEVONthink is running on the other Mac

or iOS device and both devices are awake.

Check if the databases you want to synchronize

are open on the other Mac.

PROBLEMS SYNCHRONIZING
WITH DEVONTHINK TO GO 1.X

If you cannot properly synchronize your databases

with DEVONthink To Go 1.x on your device, please

check the following:

Are both the iOS device and the Mac properly

connected to the same Wi-Fi network?

Have you moved, replicated, or copied documents

or groups to the Sync group? Please note that

smart groups are ignored during synchronization.

Have you checked the database in question on the

device on the database selection screen?

If you cannot see your Mac from your iOS device or

the connection is flaky, please try the following:

Create an ad-hoc Wi-Fi network from the Wi-Fi

icon in your Mac's menu bar.

Connect to this network from your iOS device.

Sync.
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If the connection now works as expected, the

problem is related to your router, e.g., to security

measures such as packet filtering.

If you still have problems with synchronizing, please

visit the user forum. If you don't find an answer

to your problem here, click here to contact the

DEVONtechnologies support team.

REPAIRING A DEFECTIVE
DATABASE

DEVONthink Pro databases are packages

containing of your files and the supporting AI-based

index. In rare cases this index can get corrupted or

out-of-sync. But as your files are stored separately,

this is not the end of the world. If your database

starts behaving strangely, or if DEVONthink Pro

finds inconsistencies during start-up, it is time for

some housekeeping.

STEP 1: VERIFY & REPAIR

As a first step, use Tools > Verify & Repair to check

your database's consistency and allow DEVONthink

Pro to take all necessary steps to repair any

discovered problems. If Verify & Repair was able to

repair your database, use Tools > Backup & Optimize

to optimize your database and have DEVONthink

Pro create an internal copy of the index.

If Verify & Repair was not successful or your

problems are not resolved, proceed with the next

step.

STEP 2: RESTORE FROM BACKUP

DEVONthink Pro keeps up to two copies of the

index files in case that the index is damaged beyond

repair. By changing the factory settings, you can

change when and how many internal backups

DEVONthink Pro keeps in the Preferences, Backup

tab.

To restore the index file(s) from a previously

saved internal backup, use Tools > Restore Backup

DEVONthink Pro presents you with a list of all

available backups. Choose the latest one and click

Open. This swaps the current set of index files with

the copy (the current set of index files becomes the

backup, the backup becomes the current set) so

that data is never overwritten. Run Tools > Verify &

Repair to check the consistency of this index version

and if everything is in the right order Tools > Backup

& Optimize to optimize your database and have

DEVONthink Pro create a fresh internal copy of the

good index.

If the backed-up index files are also defective, try

the other backups, if available. If all backups are

broken or corrupted, proceed with the next step.

STEP 3: REBUILD YOUR DATABASE

Since your files and DEVONthink Pro's index are

stored independently within the database package

the index can be rebuilt at any time without you

losing too much metadata. To rebuild the database

from scratch, use Tools > Rebuild Database.

The global inbox database cannot (yet) be rebuilt

using the steps above. Use the following steps to

rebuild the global inbox database manually:

Quit DEVONthink Pro.

Move ~/Library/Application Support/DEVONthink

Pro 2/Inbox.dtBase2 to the Desktop.

Open the moved database by double-clicking on it

Rebuild the global inbox database.

Move everything from the moved database to the

now empty global inbox.

Quit DEVONthink Pro, delete the moved database.

During the rebuild process, the complete index

is re-created; your actual files are not touched.

Any problems that occured during this process are

logged.

Orphaned files: Orphaned files that could not be

imported while repairing are logged and moved to

the folder "Orphans" inside the database package.

To access the contents of the package, show the

database package in the Finder, right-click it, and

choose Show package contents from the contextual

menu. Move the files in the "Orphans" subfolder

to a save location, e.g., the Desktop, or directly re-

import the files by dragging them to DEVONthink

Pro's Dock icon. Please do not change anything here

except for rescuing the orphaned files.

http://www.devontechnologies.com/redirect.html?id=forum-dttg
http://www.devontechnologies.com/redirect.html?id=contact
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STEP 4: TIME MACHINE OR MANUAL RESCUE

If everything above failed, your database is severely

damaged. You have two options now:

Option 1: Restore your database from yourTime

Machine backup or whichever backup medium

you use. If you don't use Time Machine, we

strongly advise you to do so. External hard disks

are cheap, and Time Machine makes backing up

your important files quick and simple.

Option 2: If you do not have a current backup

of your documents, you can rescue your files

manually, but you will lose any group structure.

To manually copy your files from the defective

database, show the database package in the

Finder, right-click it, and choose Show package

contents from the contextual menu. Copy the files

in the "Files" subfolder, which are sorted by kind,

to a save location, e.g., the Desktop. Then create

a new database, re-import the files and recreate

your group structure.

STEP 5: CONTACT SUPPORT

If none of the above steps helped solving the

problems you have with your database, please

contact DEVONtechnologies' support staff with a

precise-as-possible description of your problem.

DEVONTHINK PRO CRASHES
WHEN OPENED

If a database is heavily damaged, it may be that

DEVONthink Pro crashed when starting up or when

opening the database. In this case you cannot use

the built-in mechanisms to recover your data. But

you can revert to an internal backup manually. With

its factory setting, DEVONthink Pro keeps up to two

copies of the index files in case the index is damaged

beyond repair. You can change how many internal

backups DEVONthink Pro keeps in the Preferences,

Backup tab.

To revert to one of the internal backups, quit

DEVONthink Pro and locate the database package

in the Finder. Then do the following:

Select the database in the Finder, and choose

"Show Package Contents" in the contextual menu

Copy (!) the most recent Backup folder to the

desktop

Copy (!) the Files.noindex folder into the copied (!)

Backup folder

Add the file extension .dtBase2 to the Backup

folder

Now you should be able to open the copied Backup

folder as a new database by double-clicking it.

Afterwards, use Tools > Verify & Repair to ensure that

the database is operating properly.

If this solution di not help, please contact

DEVONtechnologies' support staff with a precise-

as-possible description of your problem.

RECOVERING A LOST PASSWORD

If you have protected a database and you have

forgotten your password, do the following to

remove the password protection:

Close DEVONthink Pro

Locate your protected database in the Finder

Right/Control-click it and choose Show Package

Contents

Move the file "Settings.plist" to the Trash

A future version of DEVONthink Pro will feature

industry-strength encryption.

ITEMS KEEP RE-APPEARING IN
THE INBOX

If files keep re-appearing in your global inbox

even though you have deleted or moved them in

DEVONthink Pro, it may be that some files with bad

permissions got locked up in the Inbox folder.

Open the folder "~/Library/Application Support/

DEVONthink Pro 2/Inbox" (where ~ is your user's

home directoy) and delete the files manually. This

should keep them from re-appearing.

http://www.apple.com/macosx/what-is-macosx/time-machine.html
http://www.apple.com/macosx/what-is-macosx/time-machine.html
http://www.devontechnologies.com/redirect.php?id=contact
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=contact
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PROBLEMS IMPORTING FILES

WHY DOES DEVONTHINK PRO NOT RECOGNIZE

MY FILES?

If DEVONthink Pro does not recognize a file, make

sure the file has a proper file name extension.

DEVONthink Pro needs a file name extension

to determine the file type. Add the correct file

name extension to your files (e.g., .txt for plain text

files, .rtf for rich text files, .pdf for PDFs and .doc for

Microsoft Word files) and try again.

WHY DOES DEVONTHINK PRO NOT DISPLAY

MY DOCUMENT CORRECTLY?

If a document is not properly displayed--especially

if it is a proprietary file format such as RagTime

or Mellel--make sure that you either have a Quick

Look plugin installed for this file type or that the

application that created the file is installed on your

Mac (and supports Quick Look). DEVONthink Pro

will be able to display the document if you can

display the file also, e.g., in the Finder by pressing

the Space bar.

WHY DO SOME PDFS APPEAR AS IMAGES AND

ARE NOT SEARCHABLE?

DEVONthink Pro cannot extract the text part of

print- or edit-protected PDFs. When you import

PDFs, you get a log entry that tells you that the file

contains "no text". When you select these PDFs in

DEVONthink Pro, the status bar shows "image"

instead of "PDF+text". A cheap solution for this

problem is Michele Balistreri's PDFKey. It allows

you to print protected PDFs. Use PDFKey to "print"

a PDF file into a new PDF that is both printable and

editable, which allows DEVONthink Pro to extract

the text for searching and classifying.

PROBLEMS USING SERVICES

WHY DO THE SERVICES MENU COMMANDS

SHOW NO SHORTCUTS?

They should; however, the keyboard shortcuts for

Services menu commands are only requested by

the supplying application. Mac OS X assigns these

shortcuts and has ultimate control over which

application or service gets what. If the DEVONthink

Pro Services menu items do not have shortcuts

assigned, it is likely that Mac OS X assigned these

shortcuts to another Services command, or that

they are used by the current active application.

You can manage your Services in System Preferences

> Keyboard > Keyboard Shortcuts > Services.

WHY DO THE SERVICES NOT WORK IN

FIREFOX?

Services work only in Mac OS X applications based

on the so-called Cocoa framework. Examples for

Cocoa applications are Mail, Safari, TextEdit, etc.,

and, of course, all DEVONtechnologies applications.

However, Firefox is a port of a Unix application

not completely based on Cocoa. Therefore, it does

not support Services. Try using Camino instead--a

Cocoa browser based on the Firefox engine.

DEVONTHINK PRO BEHAVES
IRRATIONALLY

No software on this planet is bug-free, and if an

application behaves irrational there is a good chance

that your have just found a bug. But there could also

be another cause: The application package could

have become damaged during an update or through

a bug in a totally unrelated piece of software on

your computer.

STRANGE APPLICATION BEHAVIOR

If something happens like

menus disappearing or silently refusing to do

anything,

windows showing graphical artefacts,

or applications not opening at all or opening with

strange error messages,

please try to trash the application package. Then

empty your web brower's cache, download the

software again, and re-install it. In many cases this

cures the problem.

If this does not help, try deleting DEVONthink Pro's

preferences files located in "~/Library/Preferences"

and starting with "com.devon-technologies.think".

http://pdfkey.com/
http://www.caminobrowser.org/
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STRANGE BEHAVIOR RELATED TO DOCUMENTS

If the strange behavior only happens with a

particular document, it is likely that the document

is damaged, was created in a very old or extremely

new file format that is no longer or not yet properly

supported, or uses a damaged or malfunctioning

Quick Look plugin.

Please file a support ticket and attach the document

in question, packaged as a .zip archive, so that we

check to see if the problem lies with DEVONthink

Pro or if it the file itself.

STRANGE BEHAVIOR OF TABS

With Zooom/2 installed, tabs in tabbed windows

behave stragely, e.g., close when cursor hovers over

the tab. Another effect of Zooom/2 are scrolling

problems in programs such as iTunes. Disabling

Zooom/2 solves the problem.

http://www.devontechnologies.com/redirect.html?id=osticket
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FAQ

In this chapter:

General questions 107

Release schedules, Mac OS X, and Windows 107

Purchasing 108

Mac App Store 109

Your software license 110

Product-related questions 110

Do you have questions regarding our licensing

policy, our products in the Mac App Store, or

specific questions about DEVONthink Pro?

GENERAL QUESTIONS

Do you have any job opportunities? Yes, we may. Please visit our Work @ DEVONtechnologies page for more

information about current open jobs at DEVONtechnologies.

Can I be a beta tester? Maybe. Our beta tester selection process is very deliberate; we try and select our beta

testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can

provide us with feedback quickly and clearly, who use different hardware and software from our other testers,

and who are willing to send us their personal data if it's needed for debugging.

If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask

active participants on the user forums if they can help us test particular features and new products. You can, of

course, simply contact us.

Is the documentation available in my language? The online and PDF documentation is only available in English

at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is cost-

intensive and error-prone so that we have decided to concentrate our resources on developing stable, robust,

and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the

necessary resources.

Where does the name DEVONtechnologies come from? "Devonian (after Devon County, England), the

geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians

appeared on the land, that until then was only inhabited by trees and other plants -- it was the departure into a

new age." Named after the Devonian period, the DEVONtechnology marks the departure into a new age of data

processing.

Note: Ray Troll has even created songs and other art about this extremely important evolution step.

RELEASE SCHEDULES, MAC OS X, AND WINDOWS

When is the next release coming We try not to announce precise timelines or feature lists for future releases,

as we are a small software company with limited development resources; if one of us should happen to get

the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our

intended development schedules.

In planning releases, we try to strike a balance among:

responding to customer requests,

http://www.devontechnologies.com/redirect.html?id=jobs
http://www.devontechnologies.com/redirect.html?id=contact
http://www.trollart.com/
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the needs of our partners,

supporting new operating systems features,

providing consistent features across the product line,

working efficiently within the structure of the code, (similar features often get handled at the same time),

various business needs.

We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's

often impossible to predict the final release date accurately when we start new projects. We try to plan our

releases with a long term perspective so that they ultimately serve the needs of our customers, even if they

don't necessarily get in everyone's favorite feature request every time.

Why are your applications not compatible with my pre-release version of Mac OS X? In the past, we've noted

that compatibility issues with a new major release of the operating system are usually resolved by Apple in the

final stages before its release, and don't require any action on our part. If you are already using a pre-release

version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches

the release candidate status. We will then make all necessary adjustments for making our apps run on the first

official release of the new version of Mac OS X.

Any chance of a Windows versions of your products? We're very commited to Mac OS X and the superior

Cocoa environment. For most of our applications, porting them to Windows would take longer than it would

to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our

products consider running Windows on a Mac.

PURCHASING

Note: If you purchased or plan to purchase DEVONthink Pro in the Mac App Store please click here to learn

more about the differences between our shop and the Mac App Store.

How do I purchase an upgrade? Please use DEVONthink Pro > Check Upgrade Options to find out what you need

to upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONthink Pro

this application might not be upgradable. Please visit the Upgrade Assistant on our web site instead.

What is your policy on software updates? Usually, all minor updates ('dot updates', such as version 1.2 to 1.3)

to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We

charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop

within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on

our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store

click here.

Can I get the bundle discount also later? Bundles are cheaper than multiple single licenses because a bundle

means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please

contact our sales staff if you purchased one of the bundled produts within the last two weeks.

Do you give a discount to students and educators? Yes, we give 25 percent off the regular price of

DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give

volume discounts to institution or faculties. Please visit our Students, Educators and NPOs page.

Do you offer NPO licenses? Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of

charities. Learn more about our NPO program.

Can I use your software on multiple computers? Yes, our license explicitly allows one and the same person to

use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a

laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.

http://www.virtualbox.org
http://www.devontechnologies.com/redirect.html?id=upgrade
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=students
http://www.devontechnologies.com/redirect.html?id=students
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I have no credit card. How can I purchase your software? We are selling currently through the online sales

agent Share*It to keep our administration as lean as possible. If you don't have a credit card, you can also pay via

PayPal or by purchase order, wire transfer, or even cash. See our online shop for more details.

In addition we are also selling some of our products through the Mac App Store. Please open the App Store

application on your Mac to learn more about which payment options Apple offers.

Can I have more time for evaluating your apps? No problem. We happily give out 30 day licenses for evaluation

purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in

DEVONagent Express.

Why haven't I received my license code(s)? If you have purchased your license in our online shop and if there

have been no technical problems on our side, your license codes have been sent out to you immediately after

your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's).

Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support

Assistant to get them resent to you. If this also doesn't work, please contact us and we'll try to get your license

codes to you as quickly as possible.

Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? License codes for legacy versions are no

longer available in our shop but even the latest license codes are always backward-compatible: You can use

a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a

license for the most recent version of the product in our online shop and use it with your legacy software.

MAC APP STORE

How do apps purchased in the Mac App Store differ? The Mac App Store requires so-called "sandboxing" of all

apps. Sandboxing puts the apps into a closed environment and restricts access to e.g. files, networks, printers,

etc. Therefore many apps sold through the Mac App Store have less features than their counterparts available

outside of the Mac App Store.

Do you charge for updates in the Mac App Store? No, updates are generally free in the Mac App Store (and we

don't charge for them outside of the Mac App Store, too).

Why are updates available always later that in your shop? All apps sold through the Mac App Store

are reviewed by Apple before being released. Therefore new versions appear immediately on the

DEVONtechnologies website but have to pass Apple's review before appearing also in the Mac App Store.

Do I get a license code? Apps purchased in the Mac App Store do not come with a license code but are "signed"

directly before downloading for your iTunes account.

Do you offer bundles in the Mac App Store? No, bundles are not supported by the Mac App Store.

How can I upgrade apps purchased in the Mac App Store? By Apple's rigid rules you couldn't. Upgrades are

simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In

some of our apps there may be an upgrade option still available, though. Check the Read Me to see if this is the

case for you.

Can I get a refund? We freely refund licenses purchased in our own shop. For apps purchased in the Mac App

Store we don't have access to the refund mechanism. Please contact Apple's Mac App Store support for a

refund.

http://www.share-it.com
http://www.devontechnologies.com/redirect.html?id=shop
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=legacy
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YOUR SOFTWARE LICENSE

Why does DEVONthink Pro not accept my license code? When you enter your license code and the 'Register'

button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they

appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code

from our email into the appropriate fields of the registration dialogue window. Also, please check if you have

obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will

not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x

license code).

I have lost my license code. How can I retrieve it? Use Help > Support Assistant to open the Support Assistant

which has an option to get your license code resent to you. Alternatively visit the support area on our web site.

Does my license code work also for an older version? Yes, it does. All our license codes are backward-

compatible to legacy versions of the same product and edition.

Why do I have to enter my license code again? You only have to re-enter your license code after a complete

reinstall of your system without a backup of your home folder or when the license code file has been

deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/

Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license

code again.

Why does my DEVONthink Pro 1.x license not work anymore? DEVONthink Pro with version numbers

greater than 1.x are paid upgrades. To use them you may need a new license code. Please use DEVONthink Pro >

Check Upgrade Options to find out what you need to upgrade and how much the upgrade is for you.

Why does your application say that it expired? When we release a public beta of one of our applications, we

remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final

release is, of course, available when this happens.

Please simply visit our Download page, download a newer version that the one you have installed, and replace

your copy with the newer one. FPlease first move the old application to the trash, then move the new one into

its place.

Note: Your license code will, of course, NEVER expire.

PRODUCT-RELATED QUESTIONS

All frequently asked questions specific to DEVONthink Pro are located in the appendix. Please continue

reading on the following pages:

FAQ specific to DEVONthink Pro

Troubleshooting tips and tricks

http://www.devontechnologies.com/redirect.html?id=support
http://www.devontechnologies.com/redirect.html?id=download
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TECHNOLOGY

In this chapter:

General Concept 111

Features 111

Structure 111

Applications 112

All commercial DEVONtechnologies applications

are based on a proprietary AI technology, with

rock-solid database foundation that allow them to

manage large numbers of documents or knowledge

bits while analyzing them almost instantly at the

same time.

GENERAL CONCEPT

DEVONtechnology, on which all

DEVONtechnologies' applications are built, is a new

technology at the very beginning of its development.

DEVONtechnologies constantly improves the

technology and enhances it for more functionality,

efficiency, robustness and flexibility.

Development of the DEVONtechnology is a battle

on two main forefronts of information processing

technology. DEVONtechnologies is working hard

on unifying both the top-down and the bottom-

up AI concepts by imitating high-level functions

and simulating the basic functionality of natural

systems. This leads to highly functional, fast and

efficient AI systems that can be used in a great

variety of information processing contexts, such

as pattern recognition, signal processing and

information storage and retrieval.

FEATURES

The DEVONtechnology is a rock-solid foundation

suitable for a variety of completely independent

applications. Therefore it is ideal for the rapid

development of a huge range of new database-,

signal-processing- and language-analysis-driven

applications. The ability to deal with any kind of

digital data makes it extremely flexible.

The size of DEVONtechnology-based databases

can, depending on the type of data stored,

grow logarithmically and make indexing is

completely unnecessary. Also, applications based

on the DEVONtechnology improve themselves

continuously (the more data they handle, the better

the results), are language-independent and iron out

any irregularities by applying fuzzy logic.

STRUCTURE

The DEVONtechnology consists of a kernel and

several layers. Together they perform all the

underlying computing, from 'simple' data handling

to complex signal processing.

Kernel: The kernel is the foundation for all layers

and applications and is responsible for data

handling, semantic and associative data processing,

signal processing, fast statistic analyses and all

fuzzy algorithms. It has to be as fast, flexible, and

extensible as possible; it is 64-bit aware and uses a

generic, proprietary file format (see above) allowing

it to verify and repair low level data consistency,

featuring logarithmic growth of the database

and logarithmic speed decrease with increasing

database size. The DEVONtechnology kernel is

Unicode-aware, completely language-independent

and self-optimizing and self-organizing.

Layers: The layers form a shell around the kernel

and provide high-level functions for the applications

built on top of them. The database layer, for

example, is used to store and organize data and

supports all kinds of relations (1:n, n:1, n:n),

hierarchies and freeform databases. No indexing or

primary keys are required, strings can be unlimited

in size and it's possible at any time to extend the

range of pre-defined data types (Boolean, character,

float, double, signed, unsigned, string, date, time,



DEVONthink Pro 2.9.4 Documentation, page 112

blob, color, size, and point). Another layer, the XML

layer, makes it easy to handle XML code within the

DEVONtechnology; it has a very small overhead,

compared to DOM parsers or available XML

databases, requires no indexing and supports the

tight integration of other databases (and vice versa).

APPLICATIONS

Some of the most likely applications for the

DEVONtechnology are databases (knowledge

bases, expert systems, search engines, table-of-

content-generators, instant data-mining), intelligent

agents, encryption, compression and archiving.

Other uses for DEVONtechnology may be chat-

bots, context-sensitive help, optical character

recognition (OCR), speech analysis, recognition

and synthesis, staticstics, thesauri and automatic

translations.

In particular, applications dependant on processing

human language, either written or spoken,

benefit from the flexible technology foundation.

So, DEVONtechnologies' main focus in the

development of new applications is in these areas:

databases, 'intelligent' agents, text and speech

analysis, statistics.

Look forward to see a great range of different

applications based on the DEVONtechnology.

A few have already been announced

on the DEVONtechnologies web site:

www.devontechnologies.com.

http://www.devontechnologies.com
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OTHER PRODUCTS

In this chapter:

Overview 113

DEVONthink 113

DEVONagent 113

DEVONsphere 114

DEVONnote 114

Needful Things 114

Besides DEVONthink Pro, DEVONtechnologies

publishes a number of other commercial, shareware,

and freeware applications, and services that you

may be interested in.

OVERVIEW

DEVONtechnologies is focused on developing

innovative applications for finding, storing, and

organizing information. Our main objective is to

make complex yet flexible technology that is both

easy to use and lightning fast.

DEVONthink

DEVONagent

DEVONsphere

DEVONnote

All applications are based on the

DEVONtechnology, a powerful and solid core

unique to DEVONtechnologies. DEVONthink,

DEVONnote, DEVONsphere, and DEVONagent

are only the first of many more DEVONtechnology-

powered applications to come.

Also, we publish useful freeware apps and services

that help you in your everyday work with your Mac.

NEWSLETTER & USER FORUM

Would you like DEVONtechnologies to keep you

informed about updates and new product releases?

Subscribe to the newsletter.

And don't forget to have a look at our very lively

user forum, where users of all skill levels meet to

discuss our applications, talk about our technology,

and exchange tips and tricks for DEVONthink Pro &

Co.

DEVONTHINK

Organize and work with all your documents,

bookmarks, email messages, text files, images, PDFs,

in one place, regardless where they originated.

Quickly capture data without interrupting your

workflow. DEVONthink's unique AI assists you in

getting the most out of your data collection.

Learn more about DEVONthink

Learn more about DEVONthink To Go for iOS

Check your upgrade options if you want to

upgrade to a higher edition

Check your upgrade options if own DEVONnote

and want to upgrade to DEVONthink

DEVONAGENT

DEVONagent Pro helps you search more efficiently

on the web. It searches multiple sources, frees

you from hunting for the really relevant results,

and gives you power tools for your research.

DEVONagent Express and DEVONagent Lite (free)

make searching the web as easy as using Spotlight.

Search Google, Bing, YouTube, Facebook, Twitter,

even the Mac App Store, right from the menu bar.

Learn more about DEVONagent Pro

Learn more about DEVONagent Express

Learn more about DEVONagent Lite

http://www.devontechnologies.com/redirect.php?id=technology
http://www.devontechnologies.com
http://www.devontechnologies.com/redirect.php?id=forum
http://www.devontechnologies.com/redirect.php?id=product-dt
http://www.devontechnologies.com/redirect.php?id=product-dttg
x-devonthink://purchase
x-devonthink://purchase
x-devonnote//purchase
x-devonnote//purchase
http://www.devontechnologies.com/redirect.php?id=product-dapro
http://www.devontechnologies.com/redirect.php?id=product-daexpress
http://www.devontechnologies.com/redirect.php?id=product-dalite
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DEVONSPHERE

Make your Mac smarter: Let DEVONsphere Express

keep track of related emails, articles on the same

subject, and similar web pages. Discover the hidden

connection between seemingly unrelated files.

Learn more about DEVONsphere Express

DEVONNOTE

Your thoughts and ideas are valuable. DEVONnote

keeps them and provides you with unique tools and

artificial intelligence so that you can focus on things

that really matter: creating even more ideas.

Learn more about DEVONnote

Check your upgrade options if you want to

upgrade to DEVONthink

NEEDFUL THINGS

Search files on your hard disk, watch web cams,

create thumbnails, or access all your files and apps

from the menu bar. Reformat paragraphs in your

favorite word processor, do little calculations

anywhere you can type in text, or send text to your

Bluetooth-enabled mobile phone. And all this for

free.

Learn more about our freeware apps

Learn more about our freeware services

http://www.devontechnologies.com/redirect.php?id=product-dsexpress
http://www.devontechnologies.com/redirect.php?id=product-dn
x-devonnote://purchase
x-devonnote://purchase
http://www.devontechnologies.com/redirect.html?id=product-freeapps
http://www.devontechnologies.com/redirect.html?id=product-freeapps
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In the appendices you will find additional

information that helps you getting familiar with

DEVONthink Pro, such as a glossary of commonly

used terms, a listing of the Boolean operators used

in searches, and placeholders used in templates for

yet "targetless" WikiLinks.

GLOSSARY

Become familiar with these terms to get the most

out of working with DEVONthink Pro.

KEYBOARD SYMBOLS

⌘ The Command key, usually next to the Space bar.

⌥ The Option key.

⌃ The Control key (usually labeled with "ctrl").

⇧ The Shift key.

⇥ The Tab key.

↩ The Return key.

INTERFACE ELEMENTS

Contextual Menu: The menu that appears when

you right-click (or ⌃-click) something; the

contextual menu gives you access to frequently

used commands that deal directly with the

clicked object. Read more about the available

contextual menus in the Documents and

Windows chapters.

Item list: A list of items stored in the database.

Items can be documents, groups, or smart groups.

View/Edit Pane: A part of the DEVONthink Pro

main and document windows that lets you view

a document or, when possible, edit it. The view/

edit pane displays the content of your documents

depending on their type. See also p. 52ff

View (1): The layout for a DEVONthink Pro main

window. You can change the layout using the

commands found in the View menu.

View (2): The display for the various document

types inside the the view/edit pane or a document

window. See also p. 69ff

Window: DEVONthink Pro uses three different

types of windows: main, document, and other.

Main windows show lists of items and, in

some views, also the contents of the selected

document, whereas document windows show

documents separately.

DOCUMENTS & GROUPS

Database: A collection of all documents stored in

DEVONthink Pro. You can create and open as

many databases as you like.

Document: A file in the database; for example,

a plain or RTF text, a PDF, or an image

(.jpg, .tiff, .png, etc.). Technically a document is

an entry in a database with text, RTF, or image

content--sometimes simply referred to as

"content".

Default Destination: The default destination

group for incoming data. Set in Preferences,

Import tab.

Group: A collection of documents or other groups

inside the database. Similar to a folder in the file

system. See also p. 38ff

Global Inbox: A special database serving as a

destination for incoming data. The Global Inbox is

always opened when DEVONthink Pro is started

and accessible through the sidebar.
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Inbox: A special group for data coming in to a

database. The inbox can be set as the default

destination in Preferences, Import tab.

News Feed: A news feed is like a web page, but

split into multiple newsbits. A feed reader or web

browser can split the feed "page" into its parts

and show each of them as a separate news item

and/or store it in a local database. DEVONthink

Pro stores feeds in a database and displays them

like a group; contents are updated live from the

Internet as the connected feed changes. Older

news bits are kept, while fresh news bits are

added and marked as unread. When you add

a bookmark that points a feed to a database,

DEVONthink Pro tries to add it as a proper feed

document if possible. DEVONthink Pro can also

be defined as the system's RSS reader in Safari's

Preferences.

Replicant: A document or a group that appears

in more than one place in the database. Unlike

an alias in the file system, a replicant is not a

real document pointing to another file (usually

the original); rather it is a second entry in the

table of contents for the very same document.

Consequently, there is no original; when you

replicate a document you'll end up with two

replicants. See also p. 39ff

Sheet: A collection of records; structured sets of

data, like a spread sheet and presented in a table

view. You can use sheets to store addresses or list

items, etc. See also p. 75ff

Smart group: Not a real group but a "saved search"

that appears like a group. Every time you visit this

smart group, DEVONthink Pro runs the attached

search and displays it as the content of the group.

Create smart groups using the search window or

the smart group editor. DEVONthink Pro creates

a number of pre-defined smart groups when you

create a new database.

Trash: Stores all trashed items until you physically

delete them using DEVONthink Pro > Empty Trash.

TAGS

Tag: A tag is a different visual representation of

a group. All documents contained in a group

that has not been excluded from tagging, get

the group's name "attached" as a tag. Tags

represented by a regular group appear grey in all

tag lists.

Group tag: Tags represented by a regular group.

Ordinary tag: Tags created through the Tag bar

or other means are created in a special top-level

group named "Tags". They are called "ordinary

tags" and appear blue in all tag lists.

ITEM PROPERTIES

Flagged/Unflagged: Items can be checked or

unchecked for your personal use, e.g., for creating

a to-do list, maintaining a shopping list, or writing

a list of project tasks.

Locked/Unlocked: Items can be locked to keep

them from being unintentionally deleted (groups,

documents) or modified (documents).

Read/Unread: Items can be marked read

or unread, which is useful for captured or

automatically downloaded news items or

documents that you want to read later. Both

unread items and groups containing unread items

are shown in bold.

The "flagged" and "locked" properties are indicated

by icons. See also p. 119ff

SYNCHRONIZATION

Sync location: Sync locations are used to keep

your databases on all your devices in sync. They

summarize all information about which databases

to sync through what kind of connection (e.g.

direct connections to DEVONthink on a Mac,

WebDAV, CloudMe, Dropbox etc.) and with

which sync store.

Sync store: Server-based locations, e.g. WebDAV

or Dropbox, can contain multiple "sync stores".

Technically a sync store is a folder on the server

volume. Use multiple sync stores to e.g. sync both

your personal and your business databases at

the same location but keeping them separate

nevertheless. Sync stores can be encrypted and

each sync store at a location can have a different

encryption key.

Direct connection: A sync location that doesn't

store its data on a server but directly connects to

a Mac running DEVONthink or DEVONthink Pro

respectively. When this device is not on the same
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WiFi network or DEVONthink/DEVONthink Pro

is not running the direct connection is disabled

and listed as offline.

Local database: A database that exists on this

device.

Remote database: A database that exists at the

sync location, e.g. on Dropbox, but is not yet

downloaded to this device.

FAQ (PRODUCT-SPECIFIC)

GENERAL

What is the difference between the various editions? While all three editions of DEVONthink, as well as

DEVONnote, share many features, there are some noticible differences. For instance, DEVONthink Pro is able

to deal with more than one database; features tables, forms, and categories; and comes with full AppleScript

support. DEVONthink Pro Office also comes with plugins for pro-grade email archiving, paper capture, and

Web sharing. You can find a complete listing of all differences on the feature comparison page.

Which languages does DEVONthink Pro support? DEVONthink Pro supports multilingual documents and

Unicode and so supports all Asian languages including Chinese, Japanese, and Korean, as well as non-Latin

scripts such as Cyrillic, Hebrew, and Arabic (including writing from right to left). Use Format > Alignment >

Writing Direction to adjust the writing direction.

Note: Asian languages, however, do not use word separators such as white space or punctuation. When

searching, you need to use wildcards. Use ~word or *word* in the search field or search window.

How do I completely uninstall DEVONthink Pro? To completely remove DEVONthink Pro from your Mac, see

the instructions in the Read Me.

DATABASES

Can I use more than one database? Yes, DEVONthink Pro databases are stored in packages instead of a central

folder. You can double-click these packages like regular files to open the database, copy the database over the

local network (LAN) or back up hard drive, or burn them to a CD-R or DVD.

How are my documents stored? DEVONthink Pro stores all documents in a package, a folder that looks like a

file that you can double-click or otherwise manipulate like a regular file in the Finder.

Inside the "Files.noindex" folder the actual documents are stored in sub-folders for their respective type and

further sub-folders that help DEVONthink Pro to quickly locate them. Documents are never altered when

you copied them into the database. The file name of each document is exactly the same as the corresponding

document name that you see in DEVONthink Pro.

In addition, the database package contains a set of ten index files named with the suffix ".dtMeta" as well as a

"Settings.plist" file containing database-specific preferences. Finally, the database package can contain one or

multiple folders named "Backup ...". They contain backups of the index files and are created automatically by

DEVONthink Pro's backup function. They do not contain copies of all actual documents.

How can I move my database to another computer? Your database is a file with the suffix ".dtBase2" and is

probably stored in your Documents folder. It can be copied to that location or to another desired location on

the other computer. If you cannot locate your database, search for it using Spotlight, using the search term

"dtBase2".

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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Note: In general, DEVONthink Pro databases are self-contained, so one can move a database to another

computer, open it and start using it. But if some of the content has been indexed instead of imported, it will

be necessary to also move the externally linked files to the other computer. This must be done in such a

way that the Paths to the external files remain valid. If everything is in your Documents folder on the first

computer, copying the externally linked folders and files to the Documents folder of the second computer

will probably work. Always quit the DEVONthink Pro application before copying or moving a database, as

copying an open database may result in an incomplete or damaged copy.

Can I put my databases on my server? Theoretically, yes. However, as DEVONthink Pro is not yet multi-user

capable, only one copy of DEVONthink Pro can access a database at a time. DEVONthink Pro uses a "lock file"

to keep other copies of the software from accessing the database at the same time. If you use a setup like this,

DO NOT override the warning message or you will create database corruption.

Can I share my DEVONthink database using WebDAV or DropBox? You can, but it is definitely not

recommended as WebDAV servers do not fully support all properties of real hard disks. See below.

Can I synchronize databases between multiple computers? Yes. See also p. 23ff

SYNCHRONIZING

How many licenses do I need? Our software licenses only can be used on Macs (or user accounts) used by you.

If you are synchronizing your data between multiple work places and team members, every team member

needs her or his own license. We offer attractive volume discounts that you can find in our online shop. We do

not offer group or site licenses.

Is everyone using the same global inbox? Yes, everyone synchronizing with the same sync store uses the same

synchronized global inbox. When you synchronize for the first time, new items in the inbox are downloaded

from the sync store and the items in your inbox are transferred to the sync store. The local inboxes in each

database are only shared with persons synchronizing this database.

Can I use my own file server? You can create sync stores on every volume that you can mount. These can be

USB sticks, hard drives, SD cards, or file servers. DEVONthink Pro can use SANs, NAS, AFP, and even SMB

volumes, as well as almost any file system.

How can my Windows-using colleagues take part? Synchronization is designed to keep DEVONthink Pro

databases updated. To share data with people using Windows- or Linux-PCs, consider using web sharing, which

is only available in DEVONthink Pro Office.

How do I restrict access for certain user groups? To restrict access to a database, open its properties and set

a user name and password. Share these credentials only with those people who should have access to this

database. Use a separate database for each group or users that you want to keep separate from other groups.

Can I share my databases as read-only? No, synchronization is by default bi-directional. To share data read-

only on the local network, consider using web sharing, which is only available in DEVONthink Pro Office.

SCANNING & OCR

My scanner is not supported by Mac OS X. Does it support TWAIN? If your scanner does not come with an

Image-Capture-compliant scanner driver, you might want to check if it works with the TWAIN SANE bridge.

http://www.devontechnologies.com/redirect.php?id=shop
http://www.ellert.se/twain-sane/
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ICONOLOGY

Additional icons behind item names, e.g., in main

windows, indicate that the item has been indexed

instead of imported, is locked, has a comment

attached, or is scripted. Groups also serving as tags

show a tag icon. Depending on your preferences,

replicants, duplicates, or replicated duplicates are

indicated with a little grey icon instead of appearing

in color.

 Item is unread

 Item has been flagged See also p. 39ff

 Item is indexed, not imported See also p. 21ff

 Item is locked See also p. 39ff

 Item has a comment See also p. 61ff

 Item has a script attached See also p. 97ff

 Group is a tag, too See also p. 121ff

 Item is a duplicate

 Item has one or more replicant(s)

 Item is a duplicate, but also has one or more

replicant(s)

KEYBOARD SHORTCUTS

Keyboard shortcuts make using DEVONthink

Pro much more efficient. Some of the following

shortcuts are common to most OS X applications;

others are only available in DEVONthink Pro. In

addition, many menu commands have keyboard

shortcuts. These are shown directly in the menu.

Note: You can change the shortcuts for menu

commands in System Preferences > Keyboard >

Keyboard Shortcuts > Application Shortcuts.

WINDOWS

Tab: Cycles focus through all entry areas and fields.

Shift-Tab: Cycles focus through all entry areas and

fields in reverse order.

Control-Tab: Cycles through all panes.

Control-Shift-Tab: Cycles through all panes in

reverse order.

Escape: Cancels processes, closes dialogs or Quick

Look previews, etc., depending on the context.

DOCUMENT LISTS

Navigating items:

Up/Down arrow: Navigates up and down in all

views. Use ⇧ to select multiple entries.

Left/Right arrow: Expands or collapses the

selected groups in Horizontal Split, Vertical Split

or List views, or navigates to previous/next item

in other views.

Option-click (the triangle in front of a group):

Expands or collapses all groups that are

containted within this group as well.

Option-Left/Right arrow: Expands or collapses

the selected groups and all their children in

Horizontal Split, Vertical Split or List views.

Selecting items:

Shift-click: Selects multiple items.

Shift-arrow: Extends the current selection.

Command-click: Adds an item to the selection.

Manipulating items:

Return: Renames documents.

Backspace: Deletes selected items.

Command-drag: Copies items to the drag

destination instead of moving it.

Command-Option-drag: Creates replicants for

the items at the drag destination. Dragging items

from the Finder to DEVONthink Pro with ⌘ and

⌥ pressed indexes the item. Dragging items into

documents with ⌘ and ⌥ held inserts a link to the

item.

Command-Option-drag: Creates bookmarks for

address cards dragged in from Contacts.

Using items:

Option-double click or Command-Shift-O: Opens

selected documents/groups in a new tab or a new

main window (depending on whether tabbed

browsing is active or not) and closes the current

window ("hoist"). Change Always open groups in a

new window in Preferences, General tab to your

personal taste.

Tab: Jumps to the first or next editable column.

Space: Opens the standard Quick Look panel

showing a preview of the selected items.

Option-Space: Opens a full screen Quick Look

slideshow.
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VIEW/EDIT PANE

Home/End: Goes to beginning of, or end of, any

view.

Page up/down: Scrolls one page up and down in

any view.

Space/Shift-Space: Scrolls one page down or up

in non-editable views, e.g., web pages, images, or

PDF documents.

Command-click: Opens the target of a link in a

new tab or separate window.

Command-Option-click (a cross-link or Wiki link):

Positions the insertion caret inside the link for

editing.

Option-click (a word): Looks for the clicked

word in the database, like the contextual menu

command See [word].

TEXT DOCUMENTS, MARKDOWN

Drag, then hold Option: Copies selected text.

Shift-arrow: Extends current selection.

Command-Option-drag: Inserts a cross-link for

groups or documents dropped into a rich text

document. Dragging files or folders from the file

system to a rich text document with ⌘ and ⌥
pressed creates links to them.

Command-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences.

Command-Shift-click: Opens a link in a new tab

and selects it (only if tabbed browsing is switched

on).

Command-Option-click (1): Places the insertion

caret inside the text of a clickable link and opens

the link in a new

Command-Option-click (2): Opens a clicked cross-

link or Wiki-style link in a separate document

window.

Option-drag: Selects text using a rectangular

selection ribbon.

Option-click (1): Lists all contents containing the

clicked word in the See Also drawer (identical to

the See [selected text] in the contextual menu).

Option-click (2): Adds clicked URL to the

Download Manager.

FORMATTED NOTES

Drag, then hold Option: Copies selected text.

Shift-arrow: Extends current selection.

Command-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences.

Command-Shift-click: Opens a link in a new tab

and selects it (only if tabbed browsing is switched

on).

Command-Option-click (1): Places the insertion

caret inside the text of a clickable link.

Command-Option-click (2): Opens a clicked cross-

link or Wiki-style link in a separate document

window.

Option-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences.

HTML PAGES, WEB PAGES, FEEDS

Command-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences. Equals clicking a link with

the third mouse button.

Command-Shift-click: Opens a link in a new tab

and selects it (only if tabbed browsing is switched

on).

Option-click: Adds clicked URL to the Download

Manager panel.

Backspace/Shift-Backspace: Goes backwards and

forwards through the visited web pages.

SHEETS

Return: Moves one cell down for editing.

Shift-Return: Moves one cell up for editing.

Tab: Moves one cell to the right for editing.

Shift-Tab: Moves one cell to the left for editing.

Arrows: Moves the editing selection.

Escape: Stops editing.

PDFS

+: Zooms in.

-: Zooms out.

Command-drag: Scrolls the visible area with the

mouse.
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IMAGES

+: Zooms in.

-: Zooms out.

TAGGING

DEVONthink Pro supports tagging in a way that

makes groups and tags interchangeable. While this

concept may sound a bit strange at first, you will

soon discover why it is a smart way to approach tags

and group and to bring both together.

INTRODUCTION

Technically, tags and groups are identical: both

are simply entries in a table that are somehow

"attached" to an item, usually a group or document.

The difference is that tags are visualized as "labels

attached TO the item while groups are visualized as

groups CONTAINING the item." They are presented

differently, but internally they are the same.

DEVONthink Pro treats groups as tags and tags as

groups. When it shows you the tags associated with

an item, it presents you with a list of all groups that

the item is part of and that have not been excluded

from tagging.

Example: A document is located in the

group "Science > Paleontology > Dinosaurs".

Consequently, its tags are "Science,"

"Paleontology," and "Dinosaurs." Now you create

a sub-group of "Dinosaurs" named "Land-living"

and move the document into the new folder.

Automatically it is now tagged with "Science,"

"Paleontology," "Dinosaurs," and "Land-living."

The same happens when you replicate the

document into multiple groups: It is tagged with the

names of all enclosing groups (not excluded from

tagging) of all its replicants.

When you assign a tag using DEVONthink Pro's

user interface, move a document, or replicate it to

another group, this is what happens:

Assign a tag: The item is replicated to the Tags

group.

Removing a tag: The item's replicate in the Tags

group is deleted.

Adding an item to a group: The group's name and

the names of all groups containing the group

appear as tags attached to the item.

Moving an item: The new group's name and the

names of all groups containing it appear as tags

attached to the item.

Replicating an item: The new group's name and

the names of all groups containing it appear as

tags attached to the item, too.

(Auto-) Classifying an item: This places the item

into a new group and replaces all assigned tags.

Tags represented by a regular group are called

"group tags"; tags created without an existing group

are called "ordinary tags." See also p. 116ff

THE TAGS GROUP

Every DEVONthink Pro database contains a top-

level group named "Tags." It is used whenever

you add a tag to an item, e.g., through the tag bar,

for which a group does not yet exist. In this case,

DEVONthink Pro creates a group for the tag in the

Tags group and places a replicant into it.

When you rename a group here all items associated

with it, (means: that have a replicant here) this

option will show the change.

USING TAGS

To use tags for selecting and finding documents

or browsing tags, DEVONthink Pro offers the

following options:

Tags view: The tags view allows you to browse

your documents by tags. In the tags view, select

a tag to display all items which have this tag

assigned. Choose multiple tags, e.g., by clicking

anothe one with ⌘ held, which shows all items

carrying the selected tags.

Smart groups: Use smart groups to search for

items with given tags.

Wherever tags are shown, "ordinary tags" (tags

created in the special Tag group) appear blue, and

tags that are also regular groups appear grey. Tags,

in the Tag bar also show a pop-up menu when you

click their downward triangle. The menu shows

related tags that can be added to the item, and

reveals tags represented by a group.
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ALIASES AND EXCLUDING FROM TAGGING

DEVONthink Pro also honors aliases added to

groups. You can add "alternative names" to a group

using Info panel and later use these alternative

names as a tag.

Example: In the Info panel of the group

"Dinosaurs" you have added "Dinos" as an alias.

You can now tag items with "Dinos" and they

automatically will be moved or replicated to the

"Dinosaurs" group.

Groups that you don't want to use as tags can be

excluded from tagging. Select the group and open

the Info panel. Check Exclude from … Tagging and the

group's name will no longer be shown as a tag for

items contained in it.

OPENMETA

OpenMeta is an open standard for storing tags

with files in the file system. Using OpenMeta

applications can add tags to files and let other

compliant applications read them.

DEVONthink Pro supports OpenMeta when

importing and exporting files. Files stored in the

database are not tagged in OpenMeta-style, though

assigned tags will be added to the files as soon as

you export them. On OS X Mavericks, Mavericks

tags take precendence over OpenMeta tags. On

OS X Yosemite and later OpenMeta is no longer

supported.

FILE FORMATS

DEVONthink Pro supports a variety of text and

image formats, including plain text, Rich Text Format

(RTF), PDFs, all image formats supported by by Mac

OS X and QuickTime, as well as all file formats for

which a Quick Look preview is available.

TEXT FILES

DEVONthink Pro supports plain text files (as well

as Mac OS 9 SimpleText and Tex-Edit Plus files) in

all encodings supported by Mac OS X, including

Unicode and UTF-8. By default, DEVONthink Pro

automatically recognizes the encoding and the line

endings used by Mac, Windows, and Unix operating

systems.

Extensions: adb, ads, aln, ans, applescript, asciidoc,

bat, bib, bibtex, c, cls, cmd, command, con, cp,

cpp, crash, css, csv, diag, dot, em, embl, erl, err,

f, f70, f90, fasta, for, fpp, ft, gb, genbank, gff, h,

haml, hang, hlp, hpp, hs, hrl, id2xf, inc, ips.beta,

js, lhs, lisp, log, lst, lua, m, markdown, md, mdwn,

mediawiki, mi, mis, ml, mly, mm, mmi, mml, msf,

org, p, pas, pir, pl, pp, py, rb, rc, rst, sass, scm, scpt,

scptd, scriptSuite, scriptTerminology, sdef, seq,

sh, sqc, sql, srt, ss, strings, sty, sw, swift, swiss, tab,

tcl, tex, text, textile, txt, v, vcf, wrl, x, xchatlog, xd,

ychat

HFS type codes: TEXT, ttro, TERO, sEXT,

SimpleText, scpt, osas, APPL (AppleScripts

wrapped in an executable application)

Automatic recognition: DEVONthink Pro also

recognizes plain text file formats defined by

third-party applications.

Note: DEVONthink Pro imports tabulated text

files and vCards, such as .tsv, .csv and .vcf, as

sheets. For BibTeX files, keys are supported and

added to the sheet.

Rich Text Format: For Rich Text Format (RTF) files,

DEVONthink Pro recognizes Mac, Windows, and

ANSI encodings as well as Mac OS X RTF documents

with attachments (RTFD).

Extensions: rtf, rtfd

HFS type codes: RTF

FORMATTED NOTES

Formatted notes are HTML files with a reduced

set of possible tags that can be edited WYSIWYG.

While they share the ".html" file name extension

which allows you to view them using a standard web

browser, formatted notes feature an identifying

meta tag which DEVONthink Pro uses to distinguish

them from regular HTML files.

Extensions: html

http://code.google.com/p/openmeta/
http://code.google.com/p/openmeta/wiki/OpenMetaApplications
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MARKDOWN AND TEXTBUNDLES

DEVONthink Pro supports importing, creating,

editing, and rendering Markdown files.

Extensions: md, mmd, mdwn, mark, mdown,

mdtext, mkdown, textile, markdown

In addition, DEVONthink Pro supports Textbundle

files. Technically Textbundle files are packages,

folders that look like a regular file, containing plain

text files and e.g. additional images linked from

Markdown.

Extensions: textbundle, textpack

OFFICE AND OTHER DOCUMENTS

DEVONthink Pro imports many Office file formats

such as Microsoft Office and OpenDocument

documents, as well as all other file formats for which

Quick Look support is available, e.g. Mellel (version

2.6 and higher) or Scapple files, AppleScript scripts,

or text clippings.

Note: Quick Look is Mac OS X 10.5's mechanism

for displaying a preview of almost any file type.

In the Finder, this function is invoked by pressing

the Space bar. Quick Look requires the maker

of the software that writes the document to

add additional preview information inside the

file (package), or to provide a Quick Look plugin

embedded into the application itself or installed

in a Library folder. If neither DEVONthink Pro

nor the Finder can preview a document format

that you want to use, please contact the maker

of the software and ask it to provide Quick Look

support for its file format.

Due to the nature of Quick Look, the contents of a

document that is displayed using this technology,

e.g., an Apple Pages file, is sometimes not selectable.

Depending on the file format, a plain or rich text

alternative is available for some files, e.g., for email

messages. Where available, use the Text View/

Preview toggle button in the document's navigation

bar to switch back and forth between plain text and

preview modes.

Additional Quick Look plugins can be found on

QLPlugins.com.

EBOOKS

EVERNOTE NOTES

DEVONthink Pro imports Evernote notes and

saves them as formatted notes. Title, creation/

modification date, tags and source URL are retained.

Extensions: enex

CHAT LOGS

DEVONthink Pro understands the text format

of logs generated by Adium, iChat or Yahoo

Messenger. You can import these chats like rich text

files.

Extensions: chat, chatlog, ichat

HFS type codes: YMSG

For Adium and Second Life DEVONthink Pro offers

a number of scripts that directly import chat, SMS,

and phone logs.

PDF, POSTSCRIPT, SKIM

DEVONthink Pro imports and displays Portable

Document Format (PDF) files, Skim PDF packages,

and PostScript files. DEVONthink Pro extracts the

readable text portions of the PDF, making it possible

to search the text of the PDF and to use See Also &

Classify. PostScript files are converted to PDF on-

the-fly.

It is possible to manually convert imported PDFs to

plain text or RTF by using Data > Convert.

Note: It's not yet possible to extract text from

protected PDF files. Protected PDFs are

imported as simple images. However, you can

correctly view the PDF in DEVONthink Pro after

entering the correct password.

BOOKMARKS

Drag or paste Internet addresses from any

Internet application, or Internet location files

from the Finder, to DEVONthink Pro to create

a bookmark documents. DEVONthink Pro is

especially optimized to accept Safari Bookmarks.

http://daringfireball.net/projects/markdown/
http://textbundle.org
http://www.microsoft.com/mac/
http://www.openoffice.org
http://www.mellel.com
http://www.mellel.com
http://www.literatureandlatte.com/scapple.php
http://www.qlplugins.com
http://adium.im
http://www.yahoo.com
http://www.yahoo.com
http://www.adiumx.com
http://www.secondlife.com
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Use bookmarks in DEVONthink Pro to integrate

"live' content from the Internet seamlessly with

local documents.

Extensions: dtLink, ftploc, fileloc, inetloc, mailloc,

newsloc, url, vncloc, webbookmark, webhistory,

webloc

HFS type codes: ilht, ilft, ilfi, ilma, ilnw, ilaf, ilat, ilns,

ilge, ilvn, LINK

HTML AND XML

In addition to the text encodings already listed,

DEVONthink Pro supports the standard HTML

transcriptions for special characters (for example

German umlauts and French accents). HTML can

also be converted to plain text using Data > Convert.

XML files of any kind can also be imported and are

displayed with syntax coloring. Preference property

lists of Mac OS X 10.4 and higher are stored in

a binary format and are converted on-the-fly to

readable XML.

Also, DEVONthink Pro supports Web archives

containing HTML pages, including all necessary

images for displaying them offline.

Extensions: agentSearch, asp, aspx, cgi, cfm, dita,

ditamap, ditaval, dtd, ent, entitlements, htm,

html, idata, jhtml, jsp, mhtml, ompl, ooutline, php,

php3, php4, phtml, plist, rdf, rsd, rss, sdef, sgm,

sgml, shtm, shtml, tbx, wml, xbl, xhtm, xhtml, xml,

xmloutline, xsd, xsl, xslt, webarchive, wsdl

Automatic recognition: DEVONthink Pro also

recognizes HTML and XML file formats defined

by third-party applications.

TABULAR DATA

DEVONthink Pro imports various structured file

formats and stores the contents as sheets (e.g. tab-

separated values, comma-separated values (TSV/

CSV) and iData files).

Extensions: csv, idata, tdf, tsv

Note: Due to a limitation in Mac OS X's Cocoa

memory management, sheets are currently

limited to 32,767 records.

OUTLINER FORMATS

DEVONthink Pro is able to import outliner files

created by OmniOutliner 2.x and other applications

in the OPML (Outlining Processor Mark-up

Language) file format. When importing OPML files,

DEVONthink Pro recreates a group hierarchy.

DEVONthink Pro also exports documents in the

standard OPML format, generating one OPML file

out of multiple groups and documents.

If DEVONthink Pro recognizes an imported OPML

file as a news feed, a new feed document is created

instead of an outline. Feeds can also be exported as

OPML for exchanges with third-party newsreader.

Extensions: .opml

IMAGE FILES

DEVONthink Pro imports all image formats

supported by Mac OS X and QuickTime.

Extensions: bmp, cur, eps, fax, fpix, fpx, gif, icns, ico,

jpeg, jpg, mac, pct, pdf, pict, png, pnt, pntg, psd, qti,

qtif, rgb, sgi, targa, tga, tif, tiff; Mac OS X 10.4 or

QuickTime 7 only: jp2, dng, exr, raw

HFS type codes: 8BPS, BMPf, EPSF, FPix, GIFf,

"ICO ", JPEG, "PDF ", PICT, PNGf, PNTG, "SGI ",

TIFF, TPIC, qtif

Installed applications or services can add

support for other file formats to Mac OS X and to

DEVONthink Pro as well.

Note: PICT files can still be imported, but Mac OS

X 10.5 does no longer display them.

MULTIMEDIA FILES

DEVONthink Pro displays or plays

QuickTimemovies, sounds, Flash movies and

Shockwave animations. To add movies, sounds,

or MP3s to DEVONthink Pro, import them like

any other file into your database. Multimedia files

also can be dragged into a rich text document to

integrate them with text and images.

Extensions: 3g2, 3gp, 3gp2, 3gpp, aac, adts, aif, AIF,

aifc, AIFC, AIFF, aiff, amc, amr, atr, AU, au, avi, bwf,

caf, cdda, cel, dif, dv, dvd, flc, f4v, fli, gsm, kar, m15,

m1a, m1s, m1v, m2a, m2v, m3u, m4a, m4b, m4p,

m4v, m75, mid, midi, mov, MOV, mp2, mp3, MP3,

http://www.idata3.com/
http://www.omnigroup.com
http://en.wikipedia.org/wiki/OPML
http://en.wikipedia.org/wiki/OPML
http://www.apple.com/quicktime
http://www.apple.com/quicktime
http://en.wikipedia.org/wiki/Adobe_Flash
http://en.wikipedia.org/wiki/Adobe_Shockwave
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mp4, mpa, mpeg, mpg, mpm, mpv, mqv, MQV, pls,

qht, qhtm, qt, qtpf, qtz, rtsp, sd2, sdp, sdv, skin,

smf, smi, smil, sml, SND, snd, swa, swf, ulw, ULW,

vfw, wav, WAV

HFS type codes: .SMI, .WAV, 3gp2, 3gpp, adts,

AIFC, AIFF, ALAW, "amc ", "amr ", attr, caff, cdda,

DAVI, DIVX, dvc!, embd, "FLI ", grip, "GSM ",

hmov, "M1A ", "M1V ", Midi, MooV, "Mp3 ", "MP3

", MPEG, "MPG ", MPG2, MPG3, mpg4, MPGa,

MPGA, MPGv, MPGV, MPGx, mxfd, PLAY, qhtm,

rtsp, Sd2f, "sdp ", "sdv ", SMIL, SwaT, SWFL,

ULAW, "VfW ", WAVE

DEVONthink Pro supports QuickTime file types

provided by third-party components.

TEMPLATES

DEVONthink Pro comes with a number of pre-fabricated templates for general use. Use these templates to add

a task list, a quote, or whole group structure for project management to your database.

MANAGING TEMPLATES

Templates are regular files stored in the Finder in the folder "~/Library/Application Support/DEVONthink Pro

2/Templates.noindex". Navigate to this folder in the Finder to manage your templates, rename them, organize

them in sub-folders, or delete them.

More templates are available as extras. See also p. 68ff

PRE-FABRICATED TEMPLATES

DEVONthink Pro comes with the following pre-fabricated templates, which serve as great examples of the

template feature.

General use:

Annotation: Adds an annotation for a selected document. The annotation is placed next to the selected

document (and replicated to all other instances of the document if necessary) and contains a link to the

annotated item. If possible, this template links to the current page of a PDF document. If there is already an

annotation for the selected document, a second one is not created, but the existing annotation is opened.

Note: Adds a new note. If the clipboard contains text, it is automatically inserted; if the clipboard contains an

Internet address (URL), it is added to the note's link list.

Phone Note: Adds a new phone note, automatically inserting the current date and time.

Project: Adds a simple project group structure including an "About this project" document. The smart

template asks for a project name; retrieves your name, department, email address, and phone number from

your contact card; and adds this information to the "About this project" document.

Task List: Adds a simple task list.

Web Browser: Adds an HTML document that allows you to use DEVONthink Pro like a regular web browser.

Open the document, enter an Internet address into the address field, and click the Go button to visit the web

site.

Accounts & Passwords:

Online Account: Adds a document for storing online account details.

Serial Number: Adds a document for storing serial numbers.

Contacts & Events:

Business Card: Adds the card selected in Contacts as a rich text document to your database.



DEVONthink Pro 2.9.4 Documentation, page 126

Calendar Event: Adds a Calendar or iCal event you have copied to the clipboard (!) as a rich text document

to your database. You need to copy the event to the clipboard because Calendar/iCal does not yet provide a

mechanism to retrieve the selected event.

Classifications:

Decimal Filing System: Adds ten groups for the decimal filing system used by man European companies for

filing (scanned) paper documents.

Dewey Decimal Classification: Inserts a group with sub-groups that builds the first levels of the Dewey

Decimal Classification. Use this feature for databases that contain knowledge spanning many subjects.

Library of Congress Classification: Inserts a group with sub-groups that builds the first levels of the Library of

Congress Classification. Use this feature for databases that contain knowledge spanning many subjects.

Education:

Cornell Notes (Pages): Adds an Apple Pages document that allows you to write notes in Cornell style.

Cornell Notes (rich text): Adds a rich text document that allows you to write notes in Cornell style.

Quote (from clipboard): Adds a rich text document for a quotation or citation. The clipboard content is

automatically inserted and, if it's an Internet address (URL), it is automatically made clickable.

Reference (from Bookends): Adds the reference selected in Bookends to your database.

Reference (from Endnote): Adds the reference selected in Endnote to your database.

Reference (from Sente 6): Adds the reference selected in Sente 6 to your database.

Office:

Apple Numbers/Pages document: Adds empty Numbers or Pages.

Microsoft Excel/Word document: Adds empty Excel or Word documents.

OpenOffice Calc/Writer document: Adds empty OpenOffice documents. This smart template checks

whether OpenOffice is installed or not before adding the document.

Registers:

1--31: Adds 31 groups, numbered 1 through 31.

A--Z: Adds 26 groups, named A through Z.

Days of the Week: Adds groups for the days of the week.

Months: Adds groups for the twelve Christian months.

Search:

PubMed: Runs a query in PubMed and adds the resulting documents formatted as rich text documents to your

database.

Smart Groups:

Email ... Videos: Adds smart groups selecting documents of a given kind.

Last ...: Adds smart groups selecting documents modified within a given period.

Large Documents: Adds smart groups selecting documents larger than 5 MB.

PDF (not searchable): Adds smart groups selecting all PDF documents that don't contain machine-readable

text.

Tabs:

Open Bing: Opens the Bing web page in a new tab.

Open Google: Opens the Google web page in a new tab.

Open Location: Asks for a URL and opens it in a new tab.

http://www.bing.com
http://www.google.com
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Toolbar: By default this contains no templates. Add you own templates here and add them also to the toolbar of

main and search windows using View > Customize Toolbar.

TEMPLATE PACKAGES

Besides the more complex smart templates, DEVONthink Pro supports template packages. These are folders

with the file name extension ".dtTemplate" that contain one or multiple folders, one for each supported

language. This way, depending on the system language, you can let DEVONthink Pro import the files in the right

language. Starting with version 2.8.4 template packages that don't need to support multiple languages can also

go without *.lproj subfolders. This further simplifies creating your own templates.

In addition, you can use the following placeholders in your file or folder names of your templates packages, as

well as in contained rich text, plain text, HTML, or XML files. During import they are replaced with actual data.

%time%: The current time

%date%: The current date

%shortDate%: The current date in short format

%longDate%: The current date in long format

%monthname%: The month name of the current date

%weekday%: The week day name of the current date

%day%: The day number of the current date

%month%: The month number of the current date

%year%: The year number of the current date

%username%: The user's name

%fullUsername%: The user's full name

%organization%: The user's organization from Contacts

%emailAddress%: The user's email addresses from Contacts

%host%: The host name

%databaseName%: The database name

%databasePath%: The database's path

%groupName%: The name of the parent group

%topGroupName%: The name of the top group

%clipboard%: The clipboard contents as plain text

%styledClipboard%: The clipboard contents as rich text

%clipboardLink%: The clipboard contents as a clickable rich text link if the clipboard contains a valid URL

SMART TEMPLATES

Most of the prefabricated templates are "smart templates": They are not simple files, but actually AppleScript

packages that are executed when selected in the Data menu. These packages contain script code, as well as the

actual templates that they insert into your database. This has a number of advantages:

The script can choose a localized template for your language; this is also possible using a template package.

The script can add information to the pre-fabricated template, e.g., the current date and time or data from the

Web.

The script can act intelligently on data on the clipboard: If it's a simple text, it adds the text; if it's a URL, it adds

it to a different area of the document and makes it clickable.

The script can check if a certain application is installed, e.g., OpenOffice, before adding a document.
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CREATING SMART TEMPLATES

Smart templates are regular AppleScript scripts or script packages with special extensions to distinguish then

from regular AppleScript scripts:

.templatescript: A normal script; the regular extension would be: ".scpt"

.templatescriptd: A script package; the regular extension would be: ".scptd". Script packages are folders that

appear like a file. They can hold both script code and additional files.

To make your own smart templates, have a look at the prefabricated smart templates:

Step 1: Navigate to "~/Library/Application Support/DEVONthink Pro 2/Templates.noindex" in the Finder and

show its content

Step 2: Make a copy of a template, e.g., of "Note.templatescriptd".

Step 2: Rename the template, replacing the extension ".templatescriptd" with ".scptd". This makes it a regular

script.

Step 3: Double-click this script to edit it in Script Editor.

Step 4: Try out the script by running it in Script Editor.

Step 5: When you're satisfied, close the script and in the Finder rename it so that the file name extension

".scptd" becomes ".templatescriptd" again.

Step 6: Close and open DEVONthink Pro. Your new script should be visible in Data > and ready for you to use.

Each of the prefabricated smart templates demostrate other aspects that show what you can do with them. You

can find more about AppleScript and DEVONthink Pro in the chapter Scripts.

Smart templates, as well as template packages, can be installed via the Finder by double-clicking on them.

WEB SITE EXPORT TEMPLATES

For exporting information as web site, DEVONthink

Pro uses templates available in ~/Library/

Application Support/DEVONthink Pro/Websites/ to

create HTML files from documents. You can choose

the template in the save dialog that appears when

you use File > Export > as Website

In the HTML templates, the following placeholders

can be used:

%databasePlusLocation%

'%comment%

%url%

%tags%

These placeholders will be replaced with actual

information during the export. The placeholders will

only be replaced in documents that are converted

to HTML during export--namely plain text, rich text,

Microsoft Office/OpenOffice documents, scripts,

chat logs, and sheets.

SEARCH OPERATORS

In the toolbar search field you can use standard and extended Boolean operators, parenthesis, and more to fine

tune your search.

The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder, Spotlight, common search

engines as well as common programming languages such as C, C++, Objective-C, Java, and JavaScript. The

complexity of the query is unlimited.
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CASE

All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but

DEVONthink Pro will ignore case in interpreting the query.

PRECEDENCE OF TERMS

Search terms and associated operators will be interpreted from left to right, except as modified by including

portions of the query within parentheses.

WILDCARDS

You can replace parts of words with wildcards matching one, multiple, or a range of characters:

?: Matches exactly one character.

*: Matches none, one, or multiple characters.

[a-b]: Matches one character of the range "a" through "b".

[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.

[^...]: Matches one character that is not contained in the given list or range.

BOOLEAN OPERATORS

The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in

the search query. If no operator is given, DEVONthink Pro infers AND. The available Boolean operators are:

term1 AND term2: Contains term1 AND term2

term1 BUT term2: Contains term1 AND term2

term1 OR term2: Contains term1 OR term2

term1 XOR term2: Contains term1 or term2, but not both

term1 EOR term2: Contains term1 or term2, but not both

NOT term: Does not contain term

"term1": Contains the string of words term1, in exactly this form

Besides the classic Boolean operators, DEVONthink Pro uses a number of operators that usually are found in

high-end databases. Use these operators as a replacement for AND and "quotes" to fine tune your query.

term1 OPT term2: term1 needs to occur, term2 can. If term2 does, the found document ranks higher in the

search results.

term1 NEAR term2: term1 occurs 10 words or less before or after term2

term1 NEAR/n term2: term1 occurs n or less words before or after term2

term1 BEFORE term2: term1 occurs before term2

term1 BEFORE/n term2: term1 occurs n or less words before term2

term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)

term1 NEXT/n term2: term 1 occurs n or less words before term2 (synonym for BEFORE/n)

term1 AFTER term2: term1 occurs after term2

term1 AFTER/n term2: term1 occurs n or less words after term2

~term1: Contains term1, also as part of a word

For convenience, some of these operators can also be abbreviated using commonly used symbols:

AND: &, &&, +

OR: |, ||

XOR: ^, ^^
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NOT: !, -

Note: The symbols above are also used by the Finder and Spotlight for searches. Enter the vertical ruler

character for the OR operator by pressing ⌥7 (e.g. on European keyboards).

Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT) BEFORE/AFTER/

NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without parenthesis are evaluated

from left to right.

WHITE SPACE HANDLING

Words linked by non-white separators (e.g. www.devon-technologies.com or page_id) are treated like phrases

put into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2". Characters

separated by dots are considered to be abbreviations and therefore handled like words separated by hyphens,

e.g., the term t.a.t.u is equal to "t a t u" OR tatu

EXAMPLES

By using any or all of the operators and rules layed out above you can create complex queries that find the exact

information you're looking for. Here are some example queries that show how the operators are used.

Example: Devonian Dinosaurs

This query looks for all documents that contain the words "devonian" and "dinosaurs".

Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro

This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words away from each

other, as well as the word "iMac" (no specific position relative to Steve and Jobs), but not the word "MacBook".

The word "Pro" does not need to occur, but if it does, the document is ranked higher in the list of search results.

Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2 ~effect)

This query looks for documents containing the word "Paracetamol" near (within 10 words) to words either

starting with "effect" (and so also "effects") or "impact". In addition, the document needs to contain the word

"side" or any word starting with "second" located within two words range of any word starting with "effect".

TEMPLATE TAGS FOR WIKI-STYLE LINKS

In DEVONthink Pro you can create new documents by first selecting some text in a rich text document and

then making it a link using the contextual menu. When you then click this link, DEVONthink Pro creates the

new document using a template you set in the Editing Preferences. In this template, can use the tags below to

automatically insert the name of the link, the current date or other information. See also p. 41ff

%@: Name of link

%%: A "%" character

%a: Abbreviated weekday name

%A: Full weekday name

%b: Abbreviated month name

%B: Full month name

%c: Shorthand for "g%X %x," the locale format for date and time

%d: Day of the month as a decimal number (01-31)

%e: Same as %d, but does not print the leading 0 for days 1 through 9

%F: Milliseconds as a decimal number (000-999)
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%H: Hour based on a 24-hour clock as a decimal number (00-23)

%I: Hour based on a 12-hour clock as a decimal number (01-12)

%j: Day of the year as a decimal number (001-366)

%m: Month as a decimal number (01-12)

%M: Minute as a decimal number (00-59)

%p: AM/PM designation for the locale

%S: Second as a decimal number (00-59)

%w: Weekday as a decimal number (0-6), where Sunday is 0

%x: Date using the date representation for the locale, including the time zone

%X: Time using the time representation for the locale

%y: Year without century (00-99)

%Y: Year with century (such as 1990)

%Z: Time zone name (such as Pacific Daylight Time)

%z: Time zone offset in hours and minutes from GMT (HHMM)

ITEM LINKS

DEVONthink Pro provides a URL (uniform resource

locator) for all documents and groups in its

databases. While web URL typically begin with

"http://" or "https://", DEVONthink Pro's URLs take

the form of "x-devonthink-item://" followed by a

long alphanumeric ID.

You get this item link by selecting a document or

group and choosing Edit > Copy Item Link, and you

can use it in any application that supports URLs, e.g.

the notes fields of OmniFocus tasks. For audio and

video documents as well as for PDF pages you can

also get URLs that directly link to a designated time

or page using the contextual menu.

In addition you can manually extend the copied URL

with the following parameters:

page: Directly jumps to the specified page of a

PDF. Usage: page=<integer>.

reveal: Reveals a group instead of opening them.

Usage: reveal=1.

search: Directly jumps to the first occurence of the

search string. Usage: search=<string>.

time: Directly jumps to the specified time in

seconds in a video or audio document. Usage:

time=<float>.

Example:

x-devonthink-item://<groupID>?reveal=1 x-

devonthink-item://<pdfID>?page=5

x-devonthink-item://<textFileID>?search=iPad

%20Pro

x-devonthink-item://<movieID>?time=43.5

The first parameter after the ID is always added

after a questionmark (?), additional ones after an

ampersand (&).

METADATA

DEVONthink Pro stores a large number of metadata

fields internally when importing documents

from the file system, e.g., from PDF, RTF, MP3,

EXIF/IPTC, HTML, and email messages as well as

from all files that deliver metadata through the

Spotlight metadata importer. Here's a partial list of

theoretically supported fields:

General:

Title

Headline

Subject

Creator

Producer

PDF and RTF:

Description

Copyright

Comment

URL

Keywords

Electronic correspondence:

Authors

Author email addresses

https://en.wikipedia.org/wiki/Uniform_Resource_Locator
https://en.wikipedia.org/wiki/Uniform_Resource_Locator
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Recipients

Recipient email dddresses

Email addresses

Electronic publications:

Album

Composer

Contributors

Publishers

Editors

Organizations

HIDDEN PREFERENCES

There are a few settings in DEVONthink Pro that

you cannot set through the Preferences window.

Most of them are intended to facilitate customer

support but they might be interesting for you as

well.

Note: These hidden preferences are not an

official feature and could be changed or removed

with any update.

HOW TO ACCESS THE HIDDEN PREFERENCES

All hidden preferences are simple on/off switches.

You set and unset them using the "defaults"

command in the Terminal. To set preferences via the

Terminal DEVONthink Pro must not be running or it

will overwrite your changes when you close it.

To set a preference using the Terminal, the

command line looks like this:

Terminal:

$ defaults write com.devon-

technologies.thinkpro2

ShouldScaleAttachedImages -bool TRUE

The above command activates the preference with

the key "ShouldScaleAttachedImages". Change

TRUE to FALSE to deactivate it. Use any of the

preferences keys below to activate or deactivate

them.

The preference AdditionalPlainTextExtensions is

best set from the Terminal. As it replaces the list

of additional plain text extensions we recommend

that you read the current list first (empty by default)

before adding your own to the end of the list.

Terminal:

$ defaults read com.devon-

technologies.thinkpro2

AdditionalPlainTextExtensions

2014-07-31 08:25:27.101

defaults[21950:3312262] The domain/default

pair of (/Users/eb/Library/Preferences/

com.devon-technologies.thinkpro2,

AdditionalPlainTextExtensions) does not

exist

$ defaults write com.devon-

technologies.thinkpro2

AdditionalPlainTextExtensions -

string .otl.todotxt

$ defaults read com.devon-

technologies.thinkpro2

AdditionalPlainTextExtensions

.otl.todotxt

AVAILABLE HIDDEN PREFERENCES KEYS

AdditionalPlainTextExtensions: Adds additional

plain text extensions, separated by dots.

AdditionalXMLExtensions: Adds additional XML

file name extensions, separated by dots.

DisableAutomaticUpdatingOfIndexedItems:

Disables automatic updating of indexed items.

DisableBadgeLabel: Disable the badge label on

DEVONthink Pro's Dock icon.

DisableFileSystemEvents: DEVONthink Pro no

longer listens to file system events.

DisableFinderTags: DEVONthink Pro no longer

imports or exports Finder tags.

DisableOpenMeta: OpenMeta tags aren't

exported/set.

EnableApplicationFiles: Applications can be

imported/indexed.

EnableThreadedFeeds: Feeds are downloaded in

threads instead of by a background task.

PlainTextIsMarkdown: Treat all plain text files as

markdown.

RenderMarkdown: Show Markdown documents

rendered by default.

RichNotesWithoutAttachments: Services create

RTF instead of RTFD.

ShouldScaleAttachedImages: Enables image

scaling in RTF documents.

SyncDebugLog: Enabled additional sync logging

for debugging.
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