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READ ME

In this chapter:

The DEVONthink Personal advantage 4

Getting started 5

System requirements 5

Installing, updating, uninstalling 5

Version history 6

License agreement 12

Credits 12

DEVONthink Personal is the paperless office for

your Mac. Use DEVONthink Personal to keep all of

your

digital documents

notes

images

multimedia files

chat logs

bookmarks

together in one database. Use DEVONthink

Personal to keep all of this information together so

that you have easy access to it. Synchronize your

data between all your Macs on the local network, via

Dropbox, WebDAV or just any mountable disk.

THE DEVONTHINK PERSONAL
ADVANTAGE

WHY DEVONTHINK PERSONAL?

DEVONthink Personal not only stores documents, it

is a flexible, powerful organizational tool that helps

you

edit

analyze

organize

find

and archive

those documents.

INTEGRATED WORKSPACE

Unlike the Finder, DEVONthink Personal provides

an integrated environment with all the tools

you need for working with information. Don't

waste time digging through thousands of files. Let

DEVONthink Personal intelligently assist you.

And synchronize your data between all your Macs

via direct connections, Dropbox, WebDAV, or any

mountable disk, e.g., a USB stick.

As a native Mac application, DEVONthink Personal

is also tightly integrated with OS X. DEVONthink

Personal provides a Dock menu, Services menu

commands, and makes optimal use of the Safari web

browser engine.

WHAT CAN YOU DO WITH IT?

DEVONthink Personal is much more than just a

document database. It is the #1 tool for collecting

and organizing info bits and snippets on the

Mac.Use DEVONthink Personal to:

Create text documents, edit them in full screen

mode using all the tools Mac OS X provides and

cross-reference them with Wiki-style or static

links.

Use the Services menu and the Dock menu to clip

information and jot down notes.

Integrate Web content and local documents.

Store frequently used images.

Take advantage of DEVONthink Personal's file

indexing feature to catalog CD/DVD-ROMs

without storing them in the database.

EDITIONS

We offer DEVONthink in multiple editions

optimized for home/semipro and heavy-duty

professional use. You can find a feature comparison

on our web site.

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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GETTING STARTED

DEVONthink Personal is a powerful application that

may require time to fully master. Open the Support

Assistant to read tips, tricks, and tutorials. Install

pre-made templates that extend DEVONthink

Personal's functionality.

Other helpful resources are our company blog,

where we publish timely news and, sometimes, even

public betas, and our lively user form.

Continue here:

Visit our company blog

Visit our user forum

SYSTEM REQUIREMENTS

Mac with 64-bit CPU, 2 GB of RAM, and OS X 10.8.5

or later. In addition, we recommend a broadband

Internet connection. If obtained through the App

Store DEVONthink Personal requires a 64-bit CPU

and OS X Mavericks or later.

INSTALLING, UPDATING,
UNINSTALLING

Note: The following procedures do not apply

when you have purchased DEVONthink Personal

on the Mac App Store. Installing, updating,

and uninstalling are handled by the App Store

application in this case.

INSTALLING AND UPDATING

Move the DEVONthink Personal application

package to the Applications folder or any preferred

directory. Please note that Mac OS X Services and

the connection to DEVONagent work only for

applications installed into the Applications folder,

and that logout and login or a restart is required

after installation.

To update an existing version of DEVONthink

Personal, simply copy the application package

from the disk image to your Applications folder,

replacing the old version. Your database(s) will not

http://www.devontechnologies.com/redirect.php?id=blog
http://www.devontechnologies.com/redirect.php?id=forum
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be affected. If you purchased DEVONthink Personal

in the Mac App Store you can also download the

update from the DEVONtechnologies website. It

will retrieve the existing receipt and accept it as

valid license.

BUYING AN UPGRADE

If would like to upgrade DEVONthink Personal to a

higher edition, you have the following options:

Choose DEVONthink Personal > Check Upgrade

Options.

The second option may or may not be available

depending on whether you have purchased

DEVONthink Personal in DEVONtechnologies'

online shop or in the Mac App Store.

UNINSTALLING

To remove (uninstall) DEVONthink Personal

completely from your Mac, trash the following files

and folders (~ stands for your Home folder):

DEVONthink Personal

~/Library/Application Support/DEVONthink 2

~/Library/Preferences/com.devon-

technologies.think.*

Dashboard widgets

Bookmarklets from your web browser

VERSION HISTORY

VERSION 2.8.10

This maintenance release adds additional commands to the contextual menu of HTML 5 videos and supports

movies sent via the sharing extension. Documents can now also be sent via Airmail 2. Verifying the database

finds and repairs more issues. The update also fixes a number of bugs and glitches.

NEW:

Contextual menu of HTML 5 videos offers additional commands.

Sharing extension supports movies, e.g., from the Photos application.

Send by Email supports Airmail 2.

Improved:

Verifying the database finds and repairs more issues.

Search windows support fullscreen mode.

Better Bookends import after duplicating imported references.

Installing the Safari extension opens the Safari Extensions Gallery on OS X Yosemite or later.

Automatic installation of add-ons skips browser extensions as they should be updated by the browsers.

Useless "x-webdoc://" URLs are ignored when taking notes.

Sparkle framework updated to version 1.14.0.

Overall reliability.

Fixed:

Rebuilding databases didn't retain thumbnails since version 2.8.8.

Text of PDF note annotations couldn't be edited anymore since version 2.8.9.

The tilde character "~" was trimmed from file names after renaming a document.

Wrong selection after expanding an outline item (workaround for a bug in OS X El Capitan).

Glitch of resizing PDF annotations.

Glitch of .nib files caused unnecessary console messages.

http://www.devontechnologies.com
http://airmailapp.com/
http://extensions.apple.com/
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VERSION 2.8.9

This maintenance release supports folder tags when importing, indexing, and exporting. Images can be dropped

into formatted notes, the sharing extension is more compatible, and captured items are named smarter.

Document windows support fullscreen window mode, too (requires OS X El Capitan or later). The update also

fixes a number of bugs and glitches.

NEW:

Importing and indexing support folder tags. Tags of groups are exported and tags of indexed groups are

immediately applied.

Images can be dropped into formatted notes too.

Document windows support fullscreen window mode (OS X El Capitan or later).

Optional "reveal" parameter of x-devonthink-item links can be used to reveal groups.

Improved:

Take Note panel restores unsaved contents after closing or quitting.

Pressing the ⌥Option modifier key changes the Select font buttons to Reset (see Preferences > General and

Preferences > Web) to easily restore the default fonts.

Sharing extension is more compatible, e.g. to Tinderbox 6.4.

Captured images, links, bookmarks, or notes are named smarter.

Rebuilding retains addition date.

Tools > Verify & Repair checks external files in the background.

Templates updated.

Data > Merge logs skipped records.

File permissions of temporary files are corrected after importing.

Error message in case of unmounted volumes is clearer.

Documentation added for item links.

Installation of Firefox extension opens Mozilla Add-Ons page in Firefox.

Overall reliability and performance.

Fixed:

Issue where copying selected rows of table views failed on OS X El Capitan.

Issue where tags entered into the Tags bar weren't always saved.

Issue with Format > Show Invisible Characters being incompatible to rich text documents containing tables.

Issue where the entered name was ignored when adding one file via Add to DEVONthink Personal service.

Issue with PDF highlight annotations in case of rotated pages (workaround for issue in OS X).

Issues with PDF line annotations (workaround for issues in OS X El Capitan).

Issue with reverting documents.

Issue with text templates containing date placeholders in the title failing depending on the system date

format.

Issue where the width of the Activity panel couldn't be increased.

Issue where changing the column font didn't update visible windows.

Issues with the automatic hiding of the Sorter on OS X El Capitan.

Issue that allowed creation of smart groups with invalid parameters.

Issue where scanning as image didn't use the correct file type.

Issue that could slow down or freeze the application when reading damaged .DS_Store files.

Vulnerability in Sparkle framework (used for downloading and installing updates).

Further minor bugs and glitches.

http://www.eastgate.com/Tinderbox/
https://addons.mozilla.org/firefox/addon/clip-to-devonthink/
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Removed:

OpenMeta is no longer used on OS X Yosemite or later.

VERSION 2.8.8

This maintenance release improves Tinderbox integration. It also makes working with PDFs more comfortable

and adds newly created groups immediately to the recent destinations. The update also fixes a number of

issues, some of them related to OS X El Capitan.

Improved:

Better Tinderbox integration. Multiple copied notes can now be pasted to DEVONthink Personal including

backlinks and tags; DEVONthink Personal creates plain or rich notes depending on the pasted contents.

Requires Tinderbox 6.3.2 or later.

Copied or dragged selections of PDF documents include images on OS X El Capitan or later. Converting PDF

documents to rich texts retains images too.

Creating a new group adds the group immediately to the recent destinations.

Activity panel.

VoiceOver support.

Overall reliability and performance.

Fixed (OS X El Capitan):

Issue with dragging multiple email messages to the Sorter.

Issue with unrealiable installation of Clip to DEVONthink.

Issue where Clip to DEVONthink couldn't always capture paginated PDF documents on OS X Yosemite and El

Capitan.

Issue with deadlocks caused by PDF sidebar.

Issue where footers and headers were flipped when printing web views.

Fixed:

Crash of Sorter after deleting a group that has been already deleted in DEVONthink Personal.

Crash when closing DEVONthink Personal after scanning.

Issue of File > Import > From Scanner or Camera where it couldn't find the scanner's functional unit, i.e. flatbed,

sheet feeder.

Issues where the destination property was ignored when creating a document using File > Import > From

Scanner or Camera.

Issue where printed PDF documents weren't automatically rotated.

Issue where smart groups named without alpha-numeric characters couldn't be created.

Issue where corrupted or not supported EXIF comments could bloat the index.

Issue where window titles weren't updated after renaming a database via sync.

Issue where an internal calculation could freeze DEVONthink Personal for some time in case of documents

with thousands of pages.

Issue where inserting an image into an RTF document right after another attachment duplicated the first

attachment instead of inserting the new one.

Issue that created unnecessary Console messages.

Minor bugs and glitches.

http://www.eastgate.com/Tinderbox/
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VERSION 2.8.7

This maintenance release brings important compatibility changes for OS X El Capitan. The synchronization

between Macs and to iOS devices is faster and more reliable. In addition, importing and indexing files is up to

twice as fast as before. Importing notes from Evernote better handles attachments and always imports images.

This update brings many more improvements, too, and fixes bugs and glitches.

Note: Starting with this version DEVONthink Personal requires OS X Mountain Lion 10.8.5.

Changes for OS X El Capitan:

Support for App Transport Security.

Fixed glitches during drag-and-drop on icon views.

Fixed fullscreen document window handling.

Fixed issues with launch and progress panels not showing.

NEW:

Reset Fill Color added to PDF annotations panel.

Improved:

Import from Evernote groups all attachments, cross-links the attachments, and always imports images

regardless how the note was originally created by Evernote.

Synchronization (both Mac/Mac and Mac/iOS) is faster and more reliable.

Importing and indexing is up to twice as fast depending on metadata and filesize. DEVONthink Personal uses

the hidden .DS_Store files instead of AppleScript to read Spotlight comments.

PDF history requires less Go > Back actions.

Videos in web views support fullscreen viewing.

PDF printing support.

Accessibility support of navigation bar.

Rebuilding retains all dates, e.g. to improve synchronization afterwards.

Automatically updated user agent of web views should be more compatible to modern websites (especially on

OS X Yosemite or El Capitan).

Faster creation of Web archives and HTML previews of third-party file formats.

About two times faster sorting by location.

Faster reloading of user interface.

Fullscreen window handling.

Handling of split view of Search windows in widescreen mode.

Handling of filesystem events.

Optimized resolving of aliases.

MultiMarkdown engine updated to version 4 and SkimNotes framework to version 1.3.3.

Memory consumption.

Overall reliability and performance.

Fixed:

Many issues related to synchronization.

Email messages without a subject couldn't be dragged from Apple Mail to DEVONthink Personal.

Up/down arrow keys couldn't be used to navigate the selection when the Quick Look panel is the key window.

Dragging both groups and their subgroups to the Finder created duplicate folders.

Glitches of date columns depending on selected list font.

Issues of preferences of text and background colors of PDF annotations.
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Work around issue of OS X Yosemite's text engine changing the font after e.g. pasting an image into a rich text

document.

Glitch of Activity panel.

Rare reloading issue of windows and views.

"Kind is HTML page" condition of smart groups and advanced searches returned also formatted notes.

It was possible to duplicate or move items with missing files.

Import of Evernote notes containing attached bookmark files (e.g. .webloc).

Optional Scripts > Export > Export to Bookends script.

PDF documents were not always released after closing windows or tabs.

Worked around possible issues of PDFKit framework.

Crash in case of broken workspaces.

Further minor bugs and glitches.

Removed:

32-bit support.

VERSION 2.8.6

This maintenance release brings important compatibility changes for OS X Capitan. It also now supports images

referenced in Markdown documents and imports keywords from Bookends references. Drag Calendar events

into RTF documents to create a back link to the appointment and use the name of the top group in templates.

This update also brings further improvements and fixes a number of other bugs and glitches.

Changes for OS X El Capitan (public beta):

Minor bugfixes for issues with OS X El Capitan.

Improved reliability of background task, especially on OS X El Capitan.

NEW:

Support added for Markdown images referenced via cross-links.

File > Import > References from Bookends converts the keywords of the references to RTF properties.

Alternate menu item Edit > Copy Page Link added.

Name of the top group can now be used via a placeholder in templates.

Improved:

PDF text annotations keep their appearance as long as they're not edited by DEVONthink.

Borders and background color are supported again by PDF text annotations.

Dragging events from Calendar into rich text documents inserts back links (requires OS X Yosemite or later).

Reminder: It's already possible to insert file links or addressbook links by dragging with ⌘Command and

⌥Option held.

Better HTML-to-text conversion, e.g. used by Data > Convert and by indexing.

Enhanced drag-and-drop support.

Items created via Data > New from Template can usually be renamed immediately.

Renamed Set Title As to Set Name As for consistency.

Further minor user interface enhancements.

Title of PDF documents displayed live in web views is now used if available.

Moving groups to external folders retains the creation date of the created folder.

Simple templates honour the option Preferences > Import > Titles > Filename with extension.

Better naming of duplicated documents with a file name extension in their name.
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Installed add-ons are automatically updated after launching a new version; the Install Add-Ons panel does not

appear in this case.

License file moved to Application Support to avoid conflicts with preferences cleaners.

French and German localization.

Memory management.

Overall performance and reliability.

Fixed:

Open Externally toolbar item was enabled if the default application is the Archive Utility.

Highlighting multiple lines in PDF documents sometimes removed existing highlighting.

Rare sync issues.

Sorter issues and crashes.

Scanner issue related to updating the destination of multiple items.

PDFs attached to RTFs were shown on OS X Yosemite even if the option Display PDF attachments of Rich Texts

was disabled.

Beep removed after trying to export an image via File > Export > Document.

Groups could be moved into themselves via the Sorter .

Updating indexed HTML pages or web archives didn't retain the indexed metadata.

Exporting as website didn't always create the required CSS file.

HTML parser could crash DEVONthink Personal in case of invalid HTML code.

Firefox add-on didn't encode URLs with parameters.

RTFDs exported as website were sometimes incorrectly escaped.

Changing the system appearance could crash the application.

Further minor bugs and glitches.

VERSION 2.8.3 ... 1.0.1

Skipped.

VERSION 1.0

Initial release.
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LICENSE AGREEMENT

PLEASE READ THIS LICENSE CAREFULLY

BEFORE USING THIS SOFTWARE. BY USING THIS

SOFTWARE, YOU ARE AGREEING TO BE BOUND

BY THE TERMS OF THIS LICENSE AGREEMENT.

IF YOU DO NOT AGREE TO THE TERMS OF

THIS LICENSE, DELETE THE SOFTWARE OR

RETURN THE SOFTWARE AND RELATED

DOCUMENTATION TO DEVONTECHNOLOGIES,

LLC.

1. License: The application and other components

(sound and graphics) accompanying this License,

whether on disk, in read only memory, or on

any other media (the "Software"), and the

related documentation are licensed to you by

DEVONtechnologies. You own the disk on which

the Software is recorded but DEVONtechnologies

and/or DEVONtechnologies' Licensor(s) retain

title to the Software and related documentation.

This License allows you to non-simultaneously use

the Software on multiple computers by the same

person.

2. Restrictions: The Software contains copyrighted

material, trade secrets and other proprietary

material and in order to protect them you may

not decompile, reverse engineer, disassemble

or otherwise reduce the Software to a human-

perceivable form. You may not sub-license, modify,

rent, lease, or create derivative works based upon

the Software in whole or in part. You may not

distribute the Software in any form, including,

but not limited to, electronic information service

distribution, bulletin board distribution, and

magnetic or optical medium distribution.

3. Disclaimer of Warranty on Software: You

expressly acknowledge and agree that use of the

Software is at your sole risk. The Software and

related documentation is provided "AS IS" and

without warranty of any kind.

4. Limitation of Liability: UNDER NO

CIRCUMSTANCES INCLUDING NEGLIGENCE,

SHALL DEVONTECHNOLOGIES BE LIABLE FOR

ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL

DAMAGES THAT RESULT FROM THE USE

OR INABILITY TO USE THE SOFTWARE OR

RELATED DOCUMENTATION. In no event shall

DEVONtechnologies' total liability to you for all

damages, losses and causes of action (whether in

contract, tort (including negligence) or otherwise)

exceed the amount paid by you for the Software.

Apple, Carbon, Classic, Cocoa, ColorSync, Darwin,

Mac OS X, QuickTime, Quartz and all other

registered names are trademarks of their respective

owners.

CREDITS

AMINDETERMINATEPROGRESS

Copyright © 2007 Andreas Mayer. All rights

reserved.

Redistribution and use in source and binary forms,

with or without modification, are permitted

provided that the following conditions are met:

Redistributions of source code must retain the

above copyright notice, this list of conditions and

the following disclaimer.

Redistributions in binary form must reproduce the

above copyright notice, this list of conditions and

the following disclaimer in the documentation

and/or other materials provided with the

distribution.

Neither the name of the copyright holder nor the

names of its contributors may be used to endorse

or promote products derived from this software

without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED. IN

NO EVENT SHALL THE COPYRIGHT OWNER OR

CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,

OR CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS

OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND

ON ANY THEORY OF LIABILITY, WHETHER

mailto:andreas@harmless.de
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IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF

THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

REGEXKITLITE

Copyright © 2008 John Engelhart. All rights

reserved.

Redistribution and use in source and binary forms,

with or without modification, are permitted

provided that the following conditions are met:

Redistributions of source code must retain the

above copyright notice, this list of conditions and

the following disclaimer.

Redistributions in binary form must reproduce the

above copyright notice, this list of conditions and

the following disclaimer in the documentation

and/or other materials provided with the

distribution.

Neither the name of the Zang Industries nor the

names of its contributors may be used to endorse

or promote products derived from this software

without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED. IN

NO EVENT SHALL THE COPYRIGHT OWNER OR

CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,

OR CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS

OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND

ON ANY THEORY OF LIABILITY, WHETHER

IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF

THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

MULTIMARKDOWN

Copyright (c) 2010-2014 Fletcher T. Penney

MultiMarkdown is released under both the GPL and

MIT licenses. You may pick the license that best fits

your needs.

Modifications to remove reliance on Glib2:

Copyright (c) 2011 Daniel Jalkut, licensed

explicitly MIT.

LyX export code (c) 2013-2014 Charles R. Cowan,

licensed under both GPL and MIT licenses.

Portions based on: peg-markdown. Copyright (c)

2008-2011 John MacFarlane. ODF output code

(c) 2011-2013 Fletcher T. Penney. peg-markdown

is released under both the GPL and MIT licenses.

You may pick the license that best fits your needs.

Original Markdown specification by John Gruber.

The GPL: This program is free software; you can

redistribute it and/or modify it under the terms of

the GNU General Public License as published by

the Free Software Foundation; either version 2 of

the License, or (at your option) any later version.

This program is distributed in the hope that it will be

useful, but WITHOUT ANY WARRANTY; without

even the implied warranty of MERCHANTABILITY

or FITNESS FOR A PARTICULAR PURPOSE. See the

GNU General Public License for more details. You

should have received a copy of the GNU General

Public License along with this program; if not, write

to the Free Software Foundation, Inc., 51 Franklin

St, Fifth Floor, Boston, MA 02110-1301 USA

The MIT License: Permission is hereby granted,

free of charge, to any person obtaining a copy of

this software and associated documentation files

(the "Software"), to deal in the Software without

restriction, including without limitation the rights

to use, copy, modify, merge, publish, distribute,

sublicense, and/or sell copies of the Software, and to

permit persons to whom the Software is furnished

to do so, subject to the following conditions:

The above copyright notice and this permission

notice shall be included in all copies or substantial

portions of the Software. THE SOFTWARE IS

PROVIDED "AS IS", WITHOUT WARRANTY OF

ANY KIND, EXPRESS OR IMPLIED, INCLUDING

BUT NOT LIMITED TO THE WARRANTIES OF

MERCHANTABILITY, FITNESS FOR A PARTICULAR

http://daringfireball.net/projects/markdown/
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PURPOSE AND NONINFRINGEMENT. IN NO

EVENT SHALL THE AUTHORS OR COPYRIGHT

HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES

OR OTHER LIABILITY, WHETHER IN AN ACTION

OF CONTRACT, TORT OR OTHERWISE, ARISING

FROM, OUT OF OR IN CONNECTION WITH THE

SOFTWARE OR THE USE OR OTHER DEALINGS IN

THE SOFTWARE.

SPARKLE

Copyright © 2006--2009 Andy Matuschak

Permission is hereby granted, free of charge, to

any person obtaining a copy of this software and

associated documentation files (the "Software"), to

deal in the Software without restriction, including

without limitation the rights to use, copy, modify,

merge, publish, distribute, sublicense, and/or sell

copies of the Software, and to permit persons to

whom the Software is furnished to do so, subject to

the following conditions:

The above copyright notice and this permission

notice shall be included in all copies or substantial

portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT

WARRANTY OF ANY KIND, EXPRESS OR

IMPLIED, INCLUDING BUT NOT LIMITED TO

THE WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL

THE AUTHORS OR COPYRIGHT HOLDERS

BE LIABLE FOR ANY CLAIM, DAMAGES OR

OTHER LIABILITY, WHETHER IN AN ACTION OF

CONTRACT, TORT OR OTHERWISE, ARISING

FROM, OUT OF OR IN CONNECTION WITH THE

SOFTWARE OR THE USE OR OTHER DEALINGS IN

THE SOFTWARE.

VIDEO JS

Copyright © 2010 Zencoder, Inc.

The Video JS player is used according to the LGPL

v3.

http://zencoder.com/
http://www.gnu.org/copyleft/lesser.html
http://www.gnu.org/copyleft/lesser.html
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COMMON TASKS

In this chapter:

Analyze text documents 15

Browse the Internet 15

Capture data from the web 16

Catalog your Disks, CDs, and DVDs 16

Catalog your photos and MP3 files 17

Collect text snippets and other valuable data 17

Index files on your hard disk 17

Manage your bookmarks 18

Take notes 18

Write texts and outline projects 18

In this chapter you'll find a number of common ways

you can use DEVONthink Personal for everyday

tasks, from surfing the Internet and making notes to

cataloging photos and archiving emails.

ANALYZE TEXT DOCUMENTS

With its built-in artificial intelligence (AI) functions,

DEVONthink Personal can be used to analyze large

numbers of text documents.

Other functions that help you analyze documents

include the AI-enhanced search function that also

features a list of similar words based on spelling

or contextual similarity. The See Also button lists

documents with a similar content, and the topics

pop-up menu displays the most important words

of a document. Duplicate documents are instantly

marked in blue and bold.

Replicants and cross-links help you create a

network of documents.

Possible uses:

Analyze the complexity and focus of a specific

document collection

Find relationships between documents or snippets

quickly

Clean up large collections of documents

Continue to read here:

Import documents from the file system

Use the See Also & Classify drawer

Use the AI-enhanced Search function

BROWSE THE INTERNET

Besides being a knowledge and information

database, DEVONthink Personal acts as a web

browser. This extends the document-based

approach to knowledge to the World Wide Web.

Because DEVONthink Personal is a database

manager, its web browser does not work in a

windowed style like Safari or DEVONagent Pro;

rather, it's document-oriented.

This enables you to treat web pages the same way

as you treat documents. Whenever you select a

web document (bookmark), DEVONthink Personal

immediately loads and displays its content live

from the Internet in the view/edit pane. You can

then archive the complete page to the database for

offline viewing.

Possible uses:

Visit frequently used web sites in a convenient

interface

Integrate "live" content from the web with your

other documents

Grab data from web sites and store it in

DEVONthink Personal

Capture and archive complete web pages

Continue to read here:

Capture data from the Web

Create a new URL or HTML document

View "live" and local HTML pages
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CAPTURE DATA FROM THE WEB

Increasingly, information is provided not on paper

but directly through Web sites, blogs, online news

sites, Facebook, and user forums. DEVONthink

Personal offers a variety of options for conveniently

capturing data from the Web:

Bookmark: Captures only the address (URL,

uniform resource locator) of the page.

HTML page: Saves the source code of the page to

the database, but images are downloaded from

the Web each time the page is displayed in the

database.

Web archive: Saves both the HTML code and all

resources, like images, necessary to display the

page.

Rich text: Grabs selected text/images and

hyperlinks, but avoids saving unwanted areas of

the page to the database. A plain text capture will

not include formatting, images or links.

PDF: 'Freezes' the web page, just like printing to

paper. PDFs from Web pages can be paginated or

non-paginated.

All of these options, except the bookmark, capture

the text content of the page (or a selected area of

it) and hyperlinks if present, and preserve the text

information for searches in DEVONthink Personal.

Note: There are a number of Web sites that

prohibit use of some of the capture options

described above. A secure banking site or

a university portal to journals may direct a

Bookmarklet or script capture option to the

login page, which will be captured instead of

the desired content. A capture option that

requires re-download of the page on such sites

will capture only the login page. The page always

can be selected and captured as rich or plain text.

The viewed page can be captured by "printing" it

as PDF to the database.

Possible uses:

Capture important news in an easily searchable

database

Collect all relevant data for your project in one

place

Collect links to web pages and captured data about

the same subject in one group

Save data from the Web in future-proof formats

such as PDF

Continue to read here:

Capture data using Services

Capture data with Bookmarklets or browser

extensions

Add the global inbox to the Finder's sidebar

'Print' any Web page or document as PDF to your

database

CATALOG YOUR DISKS, CDS, AND
DVDS

By using the Index function, you can use

DEVONthink Personal to set up a catalog for

CD-ROMs or other removable volumes. Create

a group for each disk by using the index function,

and organize your disks/groups in any way you

like. When you need a specific file, search for it in

DEVONthink Personal, insert the volume, ⌃ click the

file in DEVONthink Personal, and select Open With

to open the original file on the removable volume.

Possible uses:

Find files even when they're on a removable

volume that is not currently mounted

Create a virtual library for all your CD-ROMs and

other media

Integrate static documents with other project-

related data

http://www.facebook.com
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Continue to read here:

Import or index files

Search your database

Launch the original file of an index item

CATALOG YOUR PHOTOS AND
MP3 FILES

Besides storing text documents and PDF files,

DEVONthink Personal also manages multimedia

data such as photos, illustrations, MP3s or movies.

While not designed to replace iPhoto or iTunes,

DEVONthink Personal can be used as a repository

for images you frequently use or as an interface

to your MP3 library (if you don't like other music

software). If you do not want to import these files,

leave them where they are in the file system. You

can index the files instead and access them from

within DEVONthink Personal See also p. 31ff

Possible uses:

Create a dedicated database for photos only

View your images in full screen mode

Keep project-related images and other documents

together

Play your MP3s from within your work

environment

Continue to read here:

Import or index files

View files as thumbnails

View images and movies

Search your database

COLLECT TEXT SNIPPETS AND
OTHER VALUABLE DATA

Using Mac OS X's handy Services menu,

DEVONthink Personal is the premiere tool for

collecting and organizing information bits and

snippets.

Select any piece of data and capture it to the

currently open database with a keystroke or a quick

visit to the Services menu. All Cocoa applications

such as TextEdit, Safari, or DEVONthink Personal

itself--as well as many new Carbon applications, e.g.

the Finder or Microsoft Office 2004--support this

mechanism.

DEVONthink Personal automatically sets the

title of the newly created snippet to the first line

of text, so there's a good chance that you won't

even need to rename it. New snippets are always

created in the inbox. Also, DEVONthink Personal

can automatically classify and file the items using its

built-in artificial intelligence.

Possible uses:

Collect recent news from your favorite web sites

Keep important information from any source and

your other project-related documents together

Create an info collection for a specific topic

Continue to read here:

Capture a note quickly using the Services menu

Use the Dock menu

Drag text clippings to the Groups panel

INDEX FILES ON YOUR HARD DISK

Besides completely importing documents,

DEVONthink Personal can also index files. When

indexing files, DEVONthink Personal reads the

contents of the file and stores it for internal

reference, yet it always uses the external file for
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displaying the actual contents. Use indexing for

easily accessing information stored on CD-ROMs,

creating a library of all important documents

regardless where they are physically stored,

or integrating files stored elsewhere with your

documents in DEVONthink Personal.

Possible uses:

Access information from CD-ROMs

Create a front-end for your document collection

Integrate static documents with other project-

related data

Continue to read here:

Import or index files

Search your database

Launch the original file of an indexed item

MANAGE YOUR BOOKMARKS

With its integrated, document-based web browser,

DEVONthink Personal can be used as a bookmark

manager. Organize all your bookmarks as bookmark

documents and visit the website simply by

selecting the bookmark in split or three panes view.

DEVONthink Personal loads the page and displays it

in the view/edit pane.

If you want to open the Web page in your default

browser, simply ⌃ click (right-click) the bookmark

and choose Launch URL from the contextual menu.

Possible uses:

Manage your bookmarks

Keep project-related web pages and other

documents together

Visit frequently used web sites in a convenient

interface

Integrate "live" content from the web with your

other documents

Grab data from web sites and store it in

DEVONthink Personal

Continue to read here:

Create a new bookmark document

View "live" and local HTML pages

Drag URLs to the Groups panel

TAKE NOTES

DEVONthink Personal is perfectly suited for taking

notes and organizing them.

Use DEVONthink Personal's Take Note panel or its

Dock menu to quickly create new notes, write notes

using the advanced text editing capabilities of Mac

OS X, and find a place to file them in your database

using the Classify & See Also button.

Possible uses:

Write down ideas before they vanish

Take quick phone messages

Keep project notes and your other project-related

documents together

Continue to read here:

Create new documents

Create a new note using the Dock menu

Revise notes and documents using the built-in rich

text editor

Organize your data using Classify and See Also

WRITE TEXTS AND OUTLINE
PROJECTS

With its hierarchical group structure, organization,

and navigation functions, as well as its advanced

text editing capabilities based on the Mac OS X text

engine DEVONthink Personal is perfectly suited for

writing text from notes to whole books.

Create new documents with just one click, find

related documents, and network them with Wiki-

style or static cross-links. Because you are working

with databases in DEVONthink Personal, you can

switch from one document to another with just one

click, and manage even large projects with ease.

By flagging groups and documents DEVONthink

Personal can also be used as a simple outliner.

Unlike other outliners, DEVONthink Personal uses

documents as items and groups for items that have

sub-items. Use it with the Split view to create an

outliner look-and-feel.

Possible uses:

Write notes, white papers, and letters

Write and organize book chapters
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Organize your ideas or projects in outlines

Create a network of information for your projects

or interests

Continue to read here:

Create new documents

Use the built-in rich text editor

Choose between various window layouts to match

your work style

Use the See also & Classify drawer
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IN & OUT

In this chapter:

Drag and drop 20

Importing and indexing 20
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Dock menu 21

Synchronizing 21

Extensions and bookmarklets 24

Dashboard widget 25

Sorter 25

Capturing paper 27

DEVONthink Personal is not an island. It integrates

with the rest of your Mac and iOS devices in a

variety of ways to make it easy for you to add data

to DEVONthink Personal.

DRAG AND DROP

The easiest way to add data to DEVONthink

Personal, other than creating the documents

directly inside the application, is to drag files

or selected data, e.g. text, images, etc., into a

DEVONthink Personal window or onto its Dock

icon.

Dragging files into a document list imports the file;

dragging text or images creates documents for

them. Dragging files into a rich text document adds

them as attachments to the document. Dragging

data to the Dock icon creates new documents in the

default destination.

Hold the ⌘Command key while dragging to

effectively move the file or folder into the database.

DEVONthink Personal imports the dragged item

and puts the original into the Finder trash. This

works identical to File > Import > Files & Folders with

the option Move originals to trash enabled.

IMPORTING AND INDEXING

You import files with drag-and-drop or using the

File > Import menu item. Imported files are copied

into the database and appear as a document in

DEVONthink Personal's interface.

If you need to keep the files in their original location,

but want to use them inside of DEVONthink

Personal, drag them with ⌘ and ⌥ pressed (like

making an alias in the Finder) or use File > Index. A

reference to the file is inserted in your database and

linked to the original outside DEVONthink Personal.

Use File > Update Indexed Items  to update selected

references when their original has changed. Make

sure to keep the original file in place so that the link

between reference and file stays intact.

When to import and when to index files? Importing

copies the data directly into your database, creating

a self-contained repository that remains intact

whether you back up the database or copy it to a

USB stick. But if you also need to access the files

rom outside the database, e.g. to compile some

source codes, you may want index them instead of

importing.

SERVICES

The DEVONthink Personal > Services menu gives you

access to special commands published either by

other applications, such as TextEdit or Safari, or by

services extensions such as DEVONtechnologies'

WordService or CalcService. Also, DEVONthink

Personal publishes its own services in the Services

menu.

DEVONTHINK PERSONAL SERVICES

DEVONthink Personal installs several services for

copying or summarizing selected text, capturing a

web page, or searching documents in the database.

Add to DEVONthink: Adds selected files,

bookmarks, or images to your database. This
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service is also available in the Finder's contextual

manu.

Take Plain/Rich Note: Adds selected text to the

global inbox from any application that support

services (!) as plain or rich text. Taking a rich text

note also copies images and clickable links. If

the source document is a web page or a news

feed, DEVONthink Personal tries to capture

the address of the page or feed as well. This

only works with applications that support this

feature, such as Safari, DEVONagent Pro, or

NetNewsWire.

Capture Web Archive: Captures the web

page displayed in the frontmost window of

any WebKit-based browser (such as Safari

or DEVONagent Pro) as a web archive to

DEVONthink Personal's inbox. This menu item is

only shown when available, e.g., when Safari is the

active application.

Append Plain/Rich Note: Adds selected text as

plain or rich text to the last note taken using the

DEVONthink Personal Services menu items.

Lookup: Opens the Search windowin DEVONthink

Personal with the selected text copied as search

term.

Summarize: Creates a new note in DEVONthink

Personal's inbox with a summary of the selected

text. DEVONthink Personal uses all documents

in the open database for determining what's

important and what's not. The summarization

settings in the preferences, Editing tab, define

whether the summary shall be based on

sentences or paragraphs.

THE SORTER SERVICES

The Sorter adds another sub-menu to the Services

menu that contains a Send To Inbox command. If

possible, it copies the current selection to the

Sorter's inbox.

Note: After installing DEVONthink Personal

you need to log out, then back in again for new

services and their shortcuts to be recognized.

If one or more DEVONthink Personal Services

menu commands do not carry a shortcut, it

may be because another application grabbed

them. Mac OS X will assign the shortcut if no

other application already uses the same key

combination.

DOCK MENU

The Dock menu appears when you click DEVONthink

Personal's icon in the Dock with the ⌃ key pressed,

when you right-click it, or when you left-click it and

hold the mouse button for one second or longer.

Use the Dock menu commands Import and Index

to import or index files. Copy something to the

Clipboard and use New with Clipboard to directly

create a document with the Clipboard contents

anywhere in your open databases. DEVONthink

Personal will try to create a meaningful name for

it. Finally, choose Take Note to open the Take Note

panel.

SYNCHRONIZING

Synchronizing keeps multiple copies of a database

updated so that all contain the most recent set

of documents. It makes sure that you can use the

synchronized databases on your office Mac, your

home iMac, or your MacBook Air. It also can be

used to distribute new documents or other changes

among your team members. A future version of

DEVONthink To Go will use the same technology to

automatically receive all changes you make to your

document collection.

You can synchronize your database either directly

from one Mac to another or indirectly using a "sync

store" on a server:

Direct connection between two Macs

Via Dropbox

Via WebDAV

Via any mountable volume, e.g., a file server or a

USB stick

Synchronizing directly is much faster than using

a sync store, but requires both machines to be

connected to your local network, switched on,

and have DEVONthink open at the same time.

On the other hand, using sync store allows you to

synchronize your database(s) at any time and, in the

http://www.newsgator.com
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case of Dropbox, WebDAV, or a file server available

over the Internet, from anywhere in the world. Both

metadata and content in a sync store is encrypted.

IMPORTANT CONCEPTS

Synchronizing: The process of updating two

databases, or one database and a sync store, so

that both copies of the database contain the most

recent versions of your documents.

Encryption: All data in a sync store is always

encrypted using a unique key and, if entered, the

database's password.

Location: Another Mac or service capable to

sychronize a database.

Sync store: A folder containing one or more

databases in a special syncable format; sync

stores can reside on any mountable volume, e.g.,

a hard disk, a file server, or even a USB stick, or on

services such as Dropbox or WebDAV.

Local sync store: A sync store located on a local

drive or file server.

Direct connection: A direct link between two

instances of DEVONthink, usually on two Macs.

Synchronizing through direct connections does

not require sync stores, but requires both devices

to be switched on and running DEVONthink.

Importing a database: Downloading a database

from a sync store to this Mac.

Schedule: A schedule that defines when a database

should be synchronized with the locations

assigned to it.

UUID: Universally unique identifier; a unique ID

that identifies a database even if it has a different

name etc.

Indexed files, i.e. documents whose files reside

outside of the database folder, are synchronized to

the exact same locations on all computers. Example:

A document's file is located at "~/Documents/

SomeFile.txt" (where "~" represents your home

folder). The file will also appear in the synchronizing

user's "Document" folder on other Macs.

SETTING UP A DATABASE FOR SYNCHRONIZING

You set up at which times your database is

synchronized, and with which locations in

Preferences, Sync tab.

Step 1: Choose when you want to sync your

database automatically, or just leave Manually

selected.

Step 2: Check all locations to which you want to

sync your database.

Step 3: Click Sync to start the first synchronization.

If you haven't already set up the location, click the

+ button below the (empty) list of locations. From

the pop-up menu that appears, choose the type of

location and then follow the further instructions on

the screen. Add new local sync store creates a new

sync store on a mounted disk, Add existing local sync

store lets you choose an already existing sync store,

e.g., from a USB stick that you from a colleague. For

WebDAV locations, the the path is the folder within

the WebDAV root directory where you want to keep

the sync store. In most cases, this can be left blank.

Should your database (identified by its unique ID)

already exist in the location, DEVONthink Personal

will ask if you want to merge the two.

Synchronizing requires temporary disk space.

Make sure to have adequate free space available,

especially when importing a database.

Note: If you are using Dropbox and the Dropbox

app, it is advisable to exclude the "DEVONthink"

folder inside the "Apps" folder from being

synchronized with your Mac. This keeps the

Dropbox app from wasting valuable disk space
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re-downloading all changes you've made to

your databases, and from spamming you with

notifications. To do this, click the Dropbox icon in

your menubar, choose Preferences, switch to the

Advanced tab, click Change Settings, and select the

Apps folder, and uncheck the DEVONthink folder

inside of it. Click Update to confirm your change.

If you change your Dropbox email address, you'll

need to remove and re-add the Dropbox location.

SETTING UP DIRECT CONNECTIONS

For the most part, direct connections are treated

like other locations. The main difference is that for

every connection one Mac serves as the host and

the other Mac connects as a client. You can connect

to the host from as many Macs as you like, e.g., to

use the same research database in a team.

You set up your Mac as potential host or add direct

connections as locations in Preferences, Sync tab.

Step 1: On the host, click Incoming Connections.

Step 2: Check Allow other computers on the network

to sync with my databases to allow incoming

connections from other computers.

Step 3: If necessary, change the port number

on which your Mac is listening for incoming

connections. The default port is 10191, but

you can change it to whatever works on your

network.

Step 4: On the client, click the + button below the

list of locations and add a new direct connection.

Step 5: Choose the host in the list (requires

Bonjour to be available on the network) or enter

its IP address or host name. Click UK to add it.

You will need to enter the PIN shown in the host

on the client side in order to permanently pair the

two instances.

Step 6: Done. You can now proceed, e.g., import

the desired database from the host (see below).

IMPORTING A DATABASE FROM A SYNC STORE

If you synchronized a database with a sync store

and want to make it available on another Mac, the

easiest way is to directly get it from the sync store. If

the database is hosted on another Mac to which you

have added a direct connection, you also can import

it from there.

Step 1: Set up the location containing your

database.

Step 2: Click the button Sync with Database.

Step 3: Select a location.

Step 4: Select the database to import;

DEVONthink Personal only shows databases not

yet available on this Mac.

After downloading, DEVONthink Personal will

ask you where you want to save the database

and open the database. An imported database is

automatically also set up for synchronizing with the

location it came from.

SYNCHRONIZING WITH DEVONTHINK TO GO

1.X

Note: DEVONthink To Go 2, planned for release

in 2013, will use the sync mechanism described

above. Version 1.x, however, uses its own

proprietary sync mechanism. The information

below will become obsolete with the release of

version 2.

DEVONthink Personal has the ability to synchronize

its database with DEVONthink To Go, its companion

app for iPhone, iPad, and iPod touch devices.

Synchronizing with the device: DEVONthink

Personal uses a special group named Sync to let you

decide what data you want to share with your iOS

device. The Sync group appears on the top group

level of your database and has a special icon that

makes it stand out from other groups. To select

the items in your database that you want to take

with you on your device, either move or replicate

them into its Sync group. You replicate items by

dragging them with the ⌘ and ⌥ keys held. You can

add documents as well as whole groups to the Sync

group. Smart groups are not yet supported, and will

be ignored during synchronization.

Make sure your device is on the same WiFi network

as this computer. Open the DEVONthink To Go app

on the device, tap the sync button on the app's home

screen, and follow the instructions.
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Visit the App Store: If you do not yet have

DEVONthink To Go installed on your device, learn

more about it or visit the App Store.

TROUBLESHOOTING

If you have problems synchronizing DEVONthink

Personal databases between Macs click here. If you

have problems synchronizing with DEVONthink To

Go 1.x click here.

If you experience other problems not covered in

this documentation, please visit our online forum or

contact our support team.

EXTENSIONS AND
BOOKMARKLETS

DEVONthink Personal provides a sharing extension

(requires OS X Yosemite or later), a web browser

extension, as well as bookmarklets for conveniently

clipping information from other applications into

your DEVONthink Personal database.

Sharing extensions: Let you "share" data with

other applications or web services such

as Twitter and Facebook. Extensions are

mainly intended for the sandboxed App Store

environment where applications can no longer

easily communicate with each other.

Web browser extensions: Add functionality to

your favorite web browser. Usually they appear

as icons in the web browser's toolbar.

Bookmarklets: Special bookmarks that do not load

a saved address, but execute a little JavaScript

application that adds a bookmark to the current

page in your DEVONthink Personal database

or creates a web archive of a page. Basically,

bookmarklets use your web browser's bookmark

function for creating handy shortcuts for

application functions.

INSTALLATION

The sharing extension is automatically available

in all applications that support it as soon as

DEVONthink Personal is installed. You may need

to activate it using the More option in the sharing

menu.

Install the Clip to DEVONthink extension for Safari,

Firefox, and Chrome from within DEVONthink

Personal with the menu command DEVONthink

Personal > Install Add-Ons. You may need to activate

it from your browser's preferences or extension

settings.

To install bookmarklets, visit our Downoad Extras

web page with your preferred browser. Drag a

bookmarklet from the page to your web browser's

bookmarks, preferably the bookmark bar. You

can organize the bookmarklets like any other

bookmarks, but placing them into the bookmark bar

keeps them handy at all times.

USING THE EXTENSIONS

Regardless whether you use the sharing extension

from an application's  sharing menu, the Clip to

DEVONthink browser extension, or the Clip to

DEVONthink bookmarklet, DEVONthink Personal

presents you with the following window:

http://www.devontechnologies.com/redirect.html?id=buy-dttg
http://www.devontechnologies.com/redirect.php?id=forum
http://www.devontechnologies.com/redirect.php?id=contact
http://www.devontechnologies.com/redirect.php?id=download-extras
http://www.devontechnologies.com/redirect.php?id=download-extras
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The Clip to DEVONthink bookmarklet or extension

is often the best choice as it uses a special panel in

DEVONthink Personal that lets you enter a title

along with a note and tags, and lets you choose in

which format you want to save the clipped data. The

note is either saved as a plain or rich text document,

formatted note, or is, in the case of a bookmark,

HTML document, web archive, or PDF, placed into

the comments field of the created document.

The Clip to DEVONthink panel checks if the web

page address you're going to add already exists

in your open databases. If it does it shows a little

DEVONthink Personal icon next to the destination

popup menu. Clicking the icon reveals the first

found item with this URL. Check Reformat with

Instapaper to reformat the text of the page using

Instapaper.

The New Group button creates a new group in the

destination group selected above.

Note: If you purchased DEVONthink Personal

in the App Store, the standard "sharing" dialog

window appears. Click Post to send the clipped

data to DEVONthink Personal.

USING THE BOOKMARKLETS

To use one of the other bookmarklets, load any page

that you wish to archive or clip text from in your

web browser. When the page is fully shown, select

the bookmarklet in your bookmarks bar. Instead of

loading another page as normal bookmarks do, the

bookmarklet adds the selected text or the whole

page as text, bookmark, HTML code, web archive, or

PDF to DEVONthink Personal's default destination.

DASHBOARD WIDGET

DEVONthink Jot allows you to take notes and send

these to DEVONthink Personal's default destination

right from the Dashboard.

The front of the widget is where you can type your

note's message. Click into the writing area to make

the insertion caret appear. Enter any tags below the

note taking area. Click the Take Note button to save

the note to your database.

You can also flip the widget front to back by clicking

the i button that appears when you move the mouse

into the lower left corner of the widget. The back of

the widget lets you choose your preferred font. This

preference is saved and will be used whenever you

open the widget again. Click Done to flip the widget

back to the front view.

SORTER

The Sorter is a helper application that lets you add

files or selected text or images to your databases

even when DEVONthink Personal is not open. It

appears as a small ⇥ attached to the left, bottom,

or right border of the screen that serves as a drop

target for files and clippings.

https://www.instapaper.com
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Like a sorter in the post office, the DEVONthink

Personal Sorter consists of multiple (drop) boxes.

The first box is always the global inbox; all other

boxes you can connect to any group in any of your

databases. When you drop files or clippings onto

a box, the Sorter files it in the connected group.

Should the database containing the connected

group not be available, e.g., because DEVONthink

Personal is not open, the Sorter stores the dropped

data until the database is opened, and then flushes

the contents of the box.

In addition, you can use the Sorter to quickly add a

note to DEVONthink Personal even when it is not

open.

POSITIONING THE PANEL

To position the Sorter panel, drag the tab to any

position along the left, bottom, or right borders

of your desktop or laptop screen, except for the

border where the Dock is located (even when it is

hidden). To open the panel, click the tab; to close it,

click the tab again. Resize the Sorter panel using the

resize gadget in the lower left or lower right corner.

(Note: The location of the resize gadget depends on

whether the Sorter is attached to the left or right

side of the screen.) The size of the boxes stays the

same, but enlarging or reducing the panel size adds

or hides boxes.

Alternatively, you can show the Sorter with a list

instead of square boxes. Use the  and  icons at

the bottom to switch between the two. You can set

different sizes for both modes.

CONNECTING BOXES

To connect a box to a group, open the desired

database and drag the group from the item list of

a main window to an empty box in the Sorter. The

box is labeled with the group's name, the group's

icon is shown as a ghost image on the background of

the Sorter box, and its tool tip (which appears when

you point at it with the mouse for more than one

second) shows the name of the database containing

the database, as well as its path.

Drag a box by its title to move it to a new position in

the Sorter's box grid; move it out of the Sorter panel

to remove its connection.

Alternatively, use the contextual menu (opens when

you right-click or click with ⌃ held) to open a window

for the connected group in DEVONthink Personal

or to remove the connection. Double-click a box to

open the connected box in DEVONthink Personal.

USING THE PANEL

To add items to a Sorter box, simply drag the file

or clipping to the Sorter's tab. The panel extends

automatically and you can drop the item on

whichever box you choose.

Dragging items to the Sorter copies them. Drag

with ⌘ pressed to move the item; drag with ⌘ and

⌥ pressed to add only a reference of the item to

DEVONthink Personal (index). For URLs dragged

from a browser this creates a bookmark; hold ⌘ and

⌥ to create a web archive instead. Only files can

be moved to the Sorter; folders and clippings are

always copied. For items dragged from DEVONthink

Personal, the Sorter behaves similar to the Groups &

Tags panel.

If the database the box is connected to is not

available, the Sorter preserves the data for you.

Move the mouse horizontally over the box to skim

through the dropped items, just like in iPhoto

"Events". Drag the shown item to the Trash to

remove it. Alternatively, use the contextual menu to

remove it. When a database is open, the Sorter files

the contents of the box automatically and plays a

sound to notify you.
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When the database is available, nothing shows up in

the box because the Sorter sends all items directly

to DEVONthink Personal and plays the notification

sound.

ADDING NOTES

Switch between the sorter boxes and the take note

panel by clicking the  icon located at the bottom of

the Sorter panel. Click the   or  icon to switch

back to the Sorter boxes.

On the take note panel, choose the destination

for the new note in the pop-up menu at the top of

the panel. (DEVONthink Personal offers all groups

available as sorter boxes) and enter title, URL,

and your note. You can add tags at the bottom if

desired and choose the desired format. The Sorter

uses the standard font and size set in DEVONthink

Personal's Preferences, Editing pane, for rich text.

The text area also accepts drag-and-drop of plain

and rich text clippings. Click the Save button to save

the note.

ACTION MENU

The Action menu located at the bottom of the

Sorter panel offers some handy commands. Use

the Action menu to open the Sorter's Preferences,

flush all boxes (automatically opens DEVONthink

Personal and all databases that are needed), or

quit the Sorter. When the Sorter is closed, use the

Preferences or the Dock menu to show it again.

HOTKEYS

The Take Note and Copy Selection shortcut that

you can set in the Sorter Preferences allow you to

open the Sorter in take note mode or to capture a

selection in another application and save it to the

Sorter's inbox. The latter works in the same way as

the Sorter's Send To Inbox command in the Services

menu.

SHORTCUTS

Command-Option: Creates a web archive instead

of a bookmark when dragging a URL.

Command-M: Minimizes the Sorter panel.

Command-S: Saves the note (in take note mode).

Escape: Closes the Sorter or clears the quick note

entry field.

TROUBLESHOOTING

Re-appears after log-in: If you have set the Sorter

preferences so that it should not open automatically

when you log-in but it still does so, open the System

Preferences, Users section, Log-in Items tab.

Remove the Sorter manually.

Edit 'Hide' settings: If you accidently told the Sorter

(not to) hide when an application goes to full-screen

mode and now you want to change this behavior,

do the following: First quit the Sorter, e.g., by using

its action menu. Then, open the Terminal application

(located in /Applications/Utilities) and copy the

following line into a new window, followed by the ↩
key:

defaults delete com.devon-
technologies.think-sorter
UserSpecifiedFullScreenApplications

This makes the Sorter forget its hiding settings and

you can set them anew.

CAPTURING PAPER

DEVONthink Personal comes with built-in support

for Image Capture compliant scanners.

To capture paper using an Image Capture compliant

scanner open the Image Capture window using File >

Import > From Scanner or Camera. It is divided into a

sidebar and a main pane, which changes depending

on your selection in the sidebar. The options in the

sidebar are arranged from top to botton according

to a typical scan workflow: Scan, check the scanned

pages, arrange the pages in a document, and save

them to the database.

If you are using a scanner with an automatic

document feeder (ADF), you can also use a Queue

to prepare a pile of sheets for batch processing and

scan them in one go.

http://support.apple.com/kb/ht3669
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DEVICES

Select your connected scanner or camera in the

Devices section of the sidebar to run a scan or

download images. Note: iPhones, iPads, and iPods

are treated like cameras. The main pane shows

the standard capture interface that Apple Image

Capture uses.

Choose the scan destination in the To pop-up

menu. Either send the scan directly to any of your

databases, add them as single files to the Scans &

Images section, or choose any document that you

have created in the Document section.

Scanners: DEVONthink Personal generates an

overview scan of the current page in the scanner,

and allows you to select which parts of the page you

want to capture and set the scan options. Click Scan

to capture the page.

Cameras: DEVONthink Personal shows the

available images. Select the images you want to

import, rotate them if necessary, and click Download

or Download All to download the images to your

computer. You can also delete images from your

camera with the Delete button.

Note: To conveniently scan multiple pages into

a new document, choose PDF or TIFF as file

format check Combine into single document,

and enter a document name as file name.

DEVONthink Personal automatically creates

a new empty document with this name and

appends each scanned page until you either

send the document to your database or enter a

new name. When Combine into single document is

checked, DEVONthink Personal disables the To

menu.

SCANS & IMAGES

This is where scans or images downloaded from

your camera appear. Select images to set their

properties, edit (crop, rotate), play downloaded

movies, or delete.

If you do not need to collect multiple pages into a

single document, all you need to do is set the scan's

properties and send it to your database. In the

properties window, choose a destination group (the

global inbox is set by default) and enter title and

tags. You can also choose if you want to save this

scan as an image or PDF document. For PDFs you

can also set the author and subject properties. Then

click the Send To button to directly import this scan.

If you are using a single-sheet flatbed scanner and

want to collect multiple pages into one document,

first create a new document using the Documents

button at the bottom of the sidebar, then drag

the pages to the new document in the Documents

section to manually build the document.

DOCUMENTS

Create empty documents here to which you add

your scanned pages. Right-click or click with

⌃Control held to use the contextual menu for

adding or deleting documents. Alternatively, use the

Documents button at the bottom of the sidebar.

Add pages by dragging them from the Scans & Images

to the document in the sidebar. Rearrange added

pages if desired and set the document properties by
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clicking the Properties button. This is similar to single

scans in the Scans & Images section. Use the Sort to

reverse the sort order or shuffle pages, e.g., when

scanning all front pages first, then the back pages.

Choose Sort and Merge Documents to merge two

documents where one contains all the odd pages

and the other all even pages.

Note: You cannot save multi-page documents as

images; therefore, PDF is the only option for the

file type here.

TRASH

This is where you find images that you have deleted

from Scans & Images or Documents. Empty the trash

using the Empty button at the bottom of the window

or right-click or ⌃Control-click images to add them

to an existing or new document using the contextual

menu.

QUEUE

If you are using a document scanner with automatic

document feeder, you can use the queue to add

multiple pages or even multi-page documents to the

feeder and scan them in one go.

Choose your scanner in the pop-up menu above

the list. Then use the Add and Delete buttons to add

or delete steps and rearrange them by dragging.

Edit the fields to set a title or tags, or to change the

document type or destination.

To scan a batch of paper, set the Separator either

to Page Count and the number of pages in the

document or to Blank Page to begin a new document

every time a blank page is encountered.

Before starting the batch run, adjust your scan

settings by clicking the Configure button. Then click

the Start button to start scanning. Finished steps are

marked as "Sent". Click Clear Sent to remove them

from the list.
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MENUS

In this chapter:

The Application menu 30

The File menu 31

The Edit menu 33

The Data menu 35

The Format menu 37

The View menu 39

The Go menu 40

The Tools menu 41

The Window menu 42

The Services menu 42

The Help menu 42

The Dock menu 43

A complete listing of all commands DEVONthink

Personal offers in the menu bar, the global Mac OS X

Services menu, and the handy Dock menu.

THE APPLICATION MENU

The DEVONthink Personal menu is similar to the

application menu in any other Mac OS X application.

It contains commands for displaying the splash

screen, opening the Preferences window, accessing

the Services menu, hiding and showing windows, and,

of course, quitting the application.

ABOUT DEVONTHINK PERSONAL, ...

About DEVONthink Personal: Shows information

about DEVONthink Personal including the

version number and licensing information.

Check for Updates: Checks if updates for

DEVONthink Personal are available. By default,

DEVONthink Personal checks for updates

automatically; you can change the update

settings in the Preferences, Update pane.

Note: When checking for updates no information

is uploaded from your computer to the

DEVONtechnologies server. DEVONthink

Personal only downloads a file listing the most

current versions to your Mac. This option is not

available if you have purchased DEVONthink

Personal from the Mac App Store. In this case, all

updates are handled by the App Store.

INSTALL ADD-ONS

This command installs or reinstalls a number

additional files and scripts.

Note: If you purchased DEVONthink Personal in

the Mac App Store, this menu item may not be

available.

The following options are available:

DEVONthink Jot Widget: Installs the

DEVONthink Jot dashboard widget.

Safari Extension: The Safari extension Clip to

DEVONthink lets you clip web pages to your

database or add links with notes, similar to the

Clip to DEVONthink bookmarklet.

Google Chrome Extension: Opens the Download

Extras page in Google Chrome from where you

can install the Chrome extension (similar to the

Safari extension). You have to do this manually

and follow Google's rules.

Firefox Extension: Opens the Mozilla Add-Ons

page in Firefox where you can install the Firefox

add-on (similar to the Safari extension). You have

to do this manually and follow Mozilla's rules.

PDF Services: Adds an alias of DEVONthink

Personal to the "PDF Services" folder so that you

can "print" directly from any application to your

database. See also p. 77ff

DEVONthink Sorter Helper: A helper application

that launches the Sorter when you log in.

Check your options and click the Install button to

make DEVONthink Personal install or reinstall the

necessary files and scripts into their repsective

locations. If necessary, this command also launches

the AppleScript Utility so that you can activate the

global scripts menu. See chapter Scripts for more

information about how to use these scripts.

http://www.devontechnologies.com/redirect.php?id=download-extras
http://www.devontechnologies.com/redirect.php?id=download-extras
https://addons.mozilla.org/firefox/addon/clip-to-devonthink/
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In addition, this command removes obsolete files

such as scripts left over from previous versions.

Options for items already properly installed are

disabled and marked as "installed".

Note: On OS X Yosemite or later some browser

extensions are no longer directly installed

but open the web browser's extension gallery

instead.

PREFERENCES, TRASH, AND CACHE

Preferences: Opens the Preferences.

Empty Trash: Moves the contents of the database

trash to your computer's file system trash.

Empty Cache: Empties the web browser cache.

This frees up space and makes sure that all, when

displaying a web page, all data is freshly loaded

instead of using a cached copy.

Note: If Index-captured items are contained in

the database trash when you use Empty Trash,

the option Also from disk will become available. If

chosen, it will send the externally linked files to

the system trash, too. Caution is advised!

PURCHASE, ...

Check Upgrade Options: Opens a web page that

lists the upgrade options available for your copy

of DEVONthink Personal.

Purchase License: Opens the DEVONtechnologies

Online Shop and puts DEVONthink Personal into

your shopping cart. If this copy of DEVONthink

Personal is already licensed, you will be

presented with the choice of buying an upgrade

for your existing license or buying another full

license.

Enter License: Use this command to enter your

licence code. Make sure you enter ALL the

details EXACTLY as they appear in the licence

code e-mail. It is best to use copy-and-paste for

transferring name, organization, and licence code

from the email message to the appropriate fields.

Note: Make sure that when you highlight the

information to copy and paste, no spaces before

or after the information are highlighted.

Note: Enter License changes into License and

Purchase License into Purchase License or Upgrade 

as soon as you have entered a valid license code

(and a paid upgrade exists). Available options

depend on whether you have purchased your

copy in DEVONtechnologies' online shop or from

the Mac App Store.

SERVICES

The Services sub-menu gives your access to

special commands published by other Mac OS

X applications such as TextEdit or Safari, or by

services extensions such as our own WordService

or CalcService. Also, DEVONthink Personal

publishes its own services. See also p. 42ff

THE FILE MENU

The File menu contains all commands that deal

directly with files in your volumes, databases, or

files that can be imported, exported, or indexed.

Also, the File menu contains commands for printing

documents.

NEW WINDOW

New Window: Opens a new main window for an

open database. (If only one database is open, no sub-

menu is available.) DEVONthink Personal windows

present all documents and groups of a database in a

Finder-like fashion, and are used to access all stored

items. Some views also contain a view/edit pane for

easy viewing and editing of documents.

IMPORT

Import: Imports files or complete folders from

your volumes into the database. You can find a

list of all supported file formats in the appendix.

If not stated differently, data is imported to the

default destination. Finder labels, tags, and Spotlight

comments are honored whenever possible.

http://www.devontechnologies.com/redirect.php?id=shop
http://www.devontechnologies.com/redirect.php?id=shop
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The flexible plug-in architecture of DEVONthink

Personal allows other import modules to be added.

DEVONthink Personal comes with the following

default import plug-ins:

Bookmarks: Imports bookmarks from Camino,

Firefox, Google Chrome, OmniWeb, or Safari as

bookmarks. Only new bookmarks are imported if

you use this command again.

Notes from Evernote: Imports the notebook

selected in Evernote including names, dates,

and tags. Notes are stored as formatted notes.

Already imported notes are not updated again.

The URL of the imported notes links back to the

original notes in Evernote. This option requires

the Evernote app be installed; it is not available in

the App Store variant.

Items from Yojimbo: Imports selected items from

Yojimbo. Imported items retain name, label, flag,

URL, comments, tags and creation/modification

dates. Items without a URL link back to the

original item in Yojimbo. Yojimbo 4.0 and later is

required; this option is not available in the App

Store variant.

References from Bookends: Imports multiple

references from Bookends into a newly created

group named "Bookends". Already imported

references are updated (requires Bookends

11.3.5 or later). The keywords assigned to a

Bookends reference are added to the Document

Properties of the created rich text document.

Use the optional script Scripts > Tags > Convert

keywords to tags to convert the keywords to tags if

needed.

From Scanner or Camera: Imports printed

documents from a connected scanner or camera.

See also p. 27ff

Clip to DEVONthink: Opens the Clip to

DEVONthink panel for quickly clipping copied

texts or web addresses.

EXPORT

This sub-menu allows you to export selected

documents or groups to the file system.

Files and Folders: Exports the selected documents

and recreates the hierarchy you have built in

DEVONthink Personal almost exactly. Metadata

files (".DEVONtech_storage") make sure that

no metadata such as comments, URLs, etc., are

lost. DEVONthink Personal reads these files

when importing and recreates your original data

structure. If you don't need the metadata, you

can safely delete the ".DEVONtech_storage" files.

Exporting also exports tags in OS X 10.9 Mavericks

and OpenMeta formats (on OS X Mavericks and

earlier).

Document: Exports the currently viewed document.

In addition, the Export sub-menu provides export

methods based on plug-ins. DEVONthink Personal

comes with a number of standard plug-ins for

exporting documents in different formats. Currently

the following plug-ins are included:

as Text: Exports the selected items as one large

plain text file. You can choose the desired

encoding.

as RTF Document: Exports the selected items as

one large rich text file without embedded images,

etc.

as RTFD Document: Exports the selected items

as one large rich text file with embedded images,

etc.

as Word Document: Exports the selected items as

one large Microsoft Word file.

as Website: Exports the selected items as

standalone web site that you can upload to

your web server and share with colleagues.

In the appearing dialog window, choose the

desired template, text encoding, and whether

DEVONthink Personal should convert diacritics

and accented characters to HTML entities or not.

Check Create Index Pages to create "index.html"

pages with cross-links to all included documents.

Markdown and formatted notes are rendered to

HTML, other file types that cannot be displayed

in a web browser, e.g., Pages files, are converted

to PDF if possible. Cross-links are converted

correctly. For the export templates are used that

you can modify yourself.

as Template: Saves the selected documents as

a template, which can then be used to quickly

create new documents using Data > New >

With Template. To remove a saved template

or to organize your templates in sub-folders,

visit the folder '~/Library/Application Support/

DEVONthink 2/Templates.noindex' in the Finder,

http://www.caminobrowser.org
http://www.mozilla.org
http://www.google.com/chrome
http://www.omnigroup.com
http://www.barebones.com/products/Yojimbo/
http://www.microsoft.com/mac/
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then create sub-folders, move items, rename

them, or trash them. Export multiple documents

and/or groups at once to create e.g. a project

template.

Database Archive: Creates a clean copy of the

frontmost database and compresses it as a .Zip

archive. Back up the copy to any medium or

server to keep your data safe from hardware or

software failures.

INDEX, UPDATE INDEXED ITEMS

Index: Adds selected files to your database, but only

as references, not in their entirety. DEVONthink

Personal indexes the contents of the file and uses

this for classification and other content-related

functions. Indexed items show a little arrow after

their name. For unknown file types, this command

creates a bookmark. You can also drag files from the

Finder to DEVONthink Personal; hold down the ⌘
and ⌥ keys to index them. This is similar to creating

an alias in the Finder.

Indexed groups are excluded from tagging by

default and changes to an indexed document

are immediately reflected in its OpenMeta

metadata (and are so noticable by external tagging

applications). By default DEVONthink Personal

automatically updates selected items when they're

shown, e.g. when you show a group's contents.

Sub-groups that are not visible are not updated

automatically, however.

Note: External indexed files or folders located

in "/System/", "/Library/" or "~/Library/" are

never renamed or deleted to prevent users from

accidentally harming the system.

Update Indexed Items: If you need to be sure

everything is up-to-date use his command. If

nothing is selected, the enclosing group of the

current group is used. It also reads changes made

to the Finder or Spotlight comments of the to-

be-updated files and applies the changes to the

files' counterparts in the database. Finally, this

command removes indexed items that have lost

their external counterpart. It does not affect items

moved manually to the group. Use Update Indexed

Items to keep indexed groups and their originating

folders in sync or to manually update an item that

you have changed directly inside the database

package when DEVONthink Personal was not

running.

To create this connection between the item in the

database and the folder or file in the file system,

which is maintained by the Path field in the Info

panel, you have to freshly import/index your folder

of choice.

Select the groups and documents and choose File

> Update Indexed Items to import all files that have

been newly added to the connected folders in the

file system.

Note: The update for groups is one-way only,

from the file system to the database. But when

you rename a document, its file is renamed, too,

and when you change the Spotlight comments of

a document this is reflected in the file system, as

well.

SYNCHRONIZE

Synchronize: Synchronizes the selected database

with all designated locations. If the database is not

yet set up for synchronization this command opens

the Preferences, Sync tab.

PROPERTIES

Database Properties: Opens the Database

Properties panel for the selected database (if only

one database is open no sub-menu is available) that

allows you to change properties such as database

name, comments, and username/password.

PAGE SETUP, PRINT

Page Setup: Sets your preferred page size.

Print: Prints the selected or front-most document.

THE EDIT MENU

The Edit menu contains all commands and options

relating to editing. You'll find the classic Mac cut/

copy/paste and find/replace commands here, as well

as many more.
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UNDO AND REDO

Undo/Redo: Undoes your last action or redoes it.

Undo and Redo work for most actions.

CUT

Cut/Copy/Paste: Do exactly what their names say.

Copy URL: Copies the URL of the selected or

frontmost document to the Clipboard.

Copy Item/Page Link: Copies a URL to the clipboard

that links to the selected document or group or even

to the currently displayed page. Paste this URL into

other documents in other applications to create a

back link to DEVONthink Personal. Hold the ⇧Shift

key to reveal the Copy Page Link option. See also p.

105ff

Paste and Match Style: Pastes text from the

Clipboard into rich text documents, disregarding all

styles from the clipped text, and matching styles in

the current document.

Delete: Deletes the selected piece of text.

Complete: Tries to auto-complete the partial word

before the insertion caret. This standard Mac OS X

function uses the currently active dictionary, which

you can change via the spell check panel (see below).

Select All/Deselect All: Selects or deselects the

complete content of the frontmost document. Hold

the ⇧Shift key to reveal the Deselect All option.

DOCUMENT EDITING

Tags: Shows the Tags bar, if necessary, so that you

can enter your tags immediately.

Split Document: Splits the current document (PDF,

plain or rich text) at the insertion mark position.

PDF Document: Use this sub-menu to insert

blank pages or delete selected pages from a PDF

at the position selected in the PDF sidebar. Add

annotations or switch to a PDF tool: Move, Text

Selection, or Annotation Selection. See also p. 64ff

Rotate Left/Right: Rotates a selected image or page

left and right.

SUMMARIZE

Summarize: Summarizes the selected piece of

text. Unlike Mac OS X's Summarize service, this

command takes advantage of the built-in AI of

DEVONthink Personal, and uses the complete

"knowledge" contained in the open databases for

improving the results. The better your databases,

the better the results.

FIND

Find: This sub-menu contains commands for

finding and replacing text as well as for bringing

DEVONthink Personal's database search field into

focus.

In Database: Brings the search field of the

frontmost window into focus.

Find: Opens the standard panel for finding text

within a document.

Find Next/Previous: Jumps to the next, or

previous occurence, of the last search term.

Use Selection for Find: Copies the selected piece

of text to the Clipboard or into the search field of

the find panel, if it is opened.

Scroll To Selection: Scrolls the displayed

documents to the current selection.

Spelling and Grammar: Provides the standard Mac

OS X functionality for checking text for spelling or

grammar errors. To choose the language used for

spell checking, or for auto-completion (see above),

open the spell checker panel with Edit > Spelling and

Grammar > Show Spelling and Grammar and choose

your language of choice from the pop-up menu.

Substitutions: Shows the standard Substitutions

preference panel and switch the available options

manually on and off: Smart Copy/Paste, Smart

Quotes, Smart Dashes, Smart Links, Data Detectors,

and Text Replacements. Data Detectors analyze

shown text and make context-sensitive actions

available, e.g., when you hover the cursor over a

phone number or postal address. Mac OS X 10.6

"Snow Leopard" or higher only.

Transformations: Use this sub-menu to change

selected text to all lowercase or uppercase, or to

capitalize every word.
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Speech: Starts or stops speaking the selected piece

of text.

Insert: Inserts special characters, the current date

and/or time, or a picture into your text. Note: You

can only embed a picture into a rich text document,

not into a plain text document.

Special Characters: Shows the standard Special

Characters panel for inserting characters that you

cannot enter directly with your keyboard.

THE DATA MENU

The Data menu contains all commands that deal

directly with documents or groups. Here you'll

find commands for creating, labeling, classifying or

group new documents, and more.

NEW

New: Allows you to create new documents directly

from within DEVONthink Personal.

With Clipboard: Creates a new document based

on the contents of the Clipboard. Note: Some

applications such as Microsoft Word put data in

multiple formats into the Clipboard. DEVONthink

Personal tries to select the most useful one,

however, in some cases it grabs an image instead

of text (like Microsoft Word). Workaround:

Create a text clipping for the text, or paste it into

a TextEdit window, then copy the text from there.

Plain Text: Creates a new plain text document.

Rich Text: Creates a new rich text document.

Formatted Note: Creates a new formatted note.

HTML Page: Creates a new HTML page.

Markdown Text: Creates a new Markdown text

document.

Bookmark: Creates a new bookmark. Type the

URL you like and name it; DEVONthink Personal

automatically sets the value of its URL field in the

Info panel accordingly. If you don't type in a name,

DEVONthink Personal looks up the page name on

the Internet and sets it automatically for you.

Group: Create a blank group. Appears as Tag if the

new group would be created in the Tags group.

Smart Group: Creates a new smart group, also

known as "saved search". DEVONthink Personal

opens the Smart Group Editor, which lets you

define your search criteria. When saved, the

contents are updated every time you display the

smart group's contents.

New from Template: In addition to these standard

document types DEVONthink Personal offers pre-

defined and user-defined templates that you can

use to quickly add new documents to your database.

Select any template to add its contents to the

current group.

You can add any document to the list of templates

using File > Export > as Template.

Some of the pre-defined templates are "smart

templates" or "template packages". They consist

of folders containing files for every supported

language. These take care of choosing the right

template variant for your language, adds the

template to your database, and modifies it, if

necessary. Some smart templates add the current

date, insert the clipboard contents, check if a

needed application is installed, and even access the

Contacts application to fill in your personal details

from your card. See also p. 99ff

Use Open Templates Folder to open the folder

containing the template files in the Finder and More

Templates to install additional templates.

OPEN

Open: Opens the selected document or group in

a separate document window. For groups, this

command opens a second main window rooted to

the selected group.

Open in Tabs: Opens the selected items in a new

tab. You need have more than one item selected for

this command to have an effect.

Open with >: Opens the selected documents in

the application selected from the sub-menu. You

can edit the document in the external application,

DEVONthink Personal automatically synchronizes

the file when it is being saved to disk by the other

application. If you have quit DEVONthink Personal

in the meantime, use File & Synchronize on the

document to update it. Choose Other to open the

documents with an application not listed.

http://www.microsoft.com/mac/
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LAUNCH, REVEAL, SHOW

Launch URL: Opens the file, folder, or Internet

location indicated by the URL field in the Info

Panel. Unavailable for feed articles if DEVONthink

Personal is already your default news feed reader.

Reveal: Reveals the location of the frontmost

document in either the same main window, if

possible, or by opening a new one.

Show in Finder: Opens a new Finder window for

the folder, including the frontmost or selected

documents. Naturally, this only works for

documents referring to a file in the file system

through the Path field in the Info panel.

SAVE

Save/Save All/Revert To Saved: Use these

commands to save the frontmost document, all

documents, or to restore the frontmost document

to the last saved version.

LABEL AND MARK

Label: Allows you to mark the selected groups or

documents with one of seven labels, just as in the

Finder. You can define the color and the text of the

labels in the Preferences, Colors tab.

Mark: Allows you to mark the item as flagged/

unflagged, locked/unlocked, and read/unread. Items

marked as unread show an unread marker in most

views. See also p. 91ff

DUPLICATE

Duplicate: Creates a duplicate of the selected

items. The name of the new item ends in "copy", and

because their contents are identical both items are

marked with the icon for duplicates (or, depending

on your preferences, show their name in bold and

blue).

Replicate: Creates a replicant for the selected

items. Unlike a duplicate or alias, a replicant is like

a second phone book entry for the same person.

(Definition: Aliases are little files containing a link

to the original file). When you replicate a group or

document in DEVONthink Personal, you end up

with two replicants, not one alias and one original.

Both items have the same name and are marked

with the icon for replicants (or, depending on your

preferences, show their name in red).

MERGE, TOC, SEND BY EMAIL

Merge: Creates one big document out of several

selected ones. This works for text documents,

images, PDFs, sheets, and multimedia items. All

the original documents are embedded in the

resulting document and all tags are added, too. If the

selection contains only images, PDF, or PostScript

documents, DEVONthink Personal generates a PDF

file; otherwise DEVONthink Personal generates a

rich text document. Document types that cannot

be merged are attached if possible (e.g. PDFs are

added as attachments to a rich text document).

This command can also be used to merge multiple

selected groups/tags; in this case, the first group is

used as the destination.

Create Table of Contents: Creates a rich text

document with links to all selected documents. Use

this command e.g. for creating customized index

pages for the website export.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, Airmail 2, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If the

selected item is an email message, the sender is

automatically inserted as the recipient and the text

of the original message is inserted instead of an

attachment. Notes: Postbox is currently only able

to send one selected file. Unsupported email clients

(e.g. Thunderbird) can only send the plain text of one

selected file.

CAPTURE, CONVERT, THUMBNAILS

Capture: Capture the displayed web page, e.g. from

a bookmark, as a PDF or web archive.

Convert: These commands convert the selected

documents, if possible, to plain or rich text,

formatted note, or HTML. DEVONthink Personal

never replaces the original document with a

text version; instead, it creates a new document

containing the extracted text next to the original

item.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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Note: Converting a document to a searchable

PDF does not carry over any annotations you

have made to the original document.

Thumbnails: These commands create, remove,

or update the thumbnails or custom icons for the

selected items.

GROUP

Group/Ungroup Items: Creates a new group

containing all the selected items. This is similar to

creating a new group and moving the selected items

into it. This command also works in the See Also &

Classify drawer. Ungroup does exactly the opposite; it

moves all items contained in the selected group one

level up and removes the now empty group.

See Also & Classify: Opens or closes the See Also &

Classify drawer of a main window.

Auto Classify: This command analyzes the selected

documents and tries to find the groups where they

would fit best. If a document cannot be classified

with certainty, DEVONthink Personal beeps and

lists it in the Log panel. If DEVONthink Personal

finds more than one fitting group, it creates

replicants in all groups the document fits into. This

function works best with a large database that is

structured somewhat accurately.

Note: If the document you are auto-classifying

has replicants, these are deleted and only the

original document is placed into the new location.

This prevents multiple replicants from being

created when you are, for example, classifying

this document again.

MOVE TO TRASH

Move to Trash/Move All Instances to Trash: Moves

the selected items to the trash. If you have selected

a replicated item, Move All Instances to Trash (hold

the ⌥Option key to reveal) moves this item and all

its replicants to the trash.

THE FORMAT MENU

The Format menu contains the commands and

options dealing with all aspects of text formatting.

Here you'll find the standard font, alignment,

and ruler commands, as well as very special

DEVONthink Personal commands.

Note: Many commands in this menu only work

with rich text, Markdown, or formatted notes.

Plain text documents do not allow formatting.

(That's why they're called "plain" text.) Some

formatting options are also available for editable

PDFs and web archives.

FONT

Font: This sub-menu is reponsible for controlling

the font and the document background color (rich

text documents only). Open the fonts panel with

Show Fonts, then increase or decrease the font size

of selected text with Bigger and Smaller, adjust the

text styles and the document background color.

Using Copy Font, copy the font formatting of

a selected piece of text or the passage of text

around the insertion caret. You can then apply the

formatting to selected text using Paste Font.

Style: Commands in this sub-menu apply a certain

style, such as italics, bold, or underlined, to selected

text. Also, the commands give you access to some

high-end font control like kerning, baseline shift,

ligatures, and character shape (only applicable to

Asian languages).

The most interesting part here is Styles, which opens

the Mac OS X Styles Editor. You can step through

all the styles used in the current document and

add them to your favorites. Use the pop-up menu

to select a saved style and, if you don't need it any

more, delete it. You can use saved styles from the

ruler (see below).

Note: If you think the user interface for the styles

editor is less-than-wonderful, you're right. But

don't blame us, it's Apple's design :-)

Alignment: Align paragraphs left, right, centered,

or justified. Here, Asian or Arabic users can also

change the direction of writing, if desired.
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Ruler: Show the ruler, which shows the tab stops

and contains alignment and styles buttons; copy the

current ruler (line width, indents, tab stops, etc.) and

paste it somewhere else.

Learn more about the ruler and the Styles Editor

here.

HIGHLIGHT

Highlight, Highlight Color: In rich text documents,

editable PDFs, and web archives use Highlight to

highlight a selected piece of text just as you would

using with a colored pen on a piece of paper. To

remove highlighting, select the highlighted piece of

text and choose Highlight again. Use the Highlight

Color sub-menu to choose your favorite highlight

color.

SPACING

Spacing: This command is only available in rich text

documents; the command allows you to adjust the

line spacing of selected text. You can adjust the

line height to an exact value or define a minimum

and maximum height, adjust inter-line spacing, and

define the space before and after a paragraph.

Note: Paragraph spacings are not added to those

of the preceding or following paragraph; instead,

the maximum spacings from both paragraphs are

used to ensure a proper layout.

Link: Makes selected text a link to a URL (for

example, to a web page or to an email address). This

is a one-step command for writing the address into a

rich text document, selecting the address, selecting

Make Link (see below), and then changing the linked

text to anything you want.

List: Creates a bulleted list. Select your prefix, bullet

style, and suffix in the dialog sheet and click OK to

insert your list skeleton. In the list, press ↩ to insert

new items, and press ⇥ and ⇧⇥ to indent/de-indent

items, just as you would in any word processor.

Table: Inserts a new table into a rich text document

and opens the table inspector panel. Use the

table inspector to adjust the number of rows and

columns, cell alignments, cell colors, border widths,

and colors. Also, you can merge and split cells and

create tables within a cell.

MAKE LINK

Add Link: Makes the selected text clickable and asks

for a destination. Enter any valid URL you want the

text to link to.

Edit Link: Shows an editing sheet where you can

change the URL of the selected link.

Make/Remove Link: Makes selected text clickable,

or removes a link from the current selection. Where

you are taken to when you click the link depends on

the selected text:

If the text was a valid URL, the URL will be the

target of the link. Editing the link text later does

not change the target. Use the Edit Link command

of the contextual menu to edit the link target.

Otherwise, DEVONthink Personal treats the link

as a Wiki-style link. Clicking the Wiki-style link

jumps to a document with exactly the same name

as the linked text (or any document with a Wiki

aliasof that name). If there is no document of that

name, clicking the link creates a new rich text

document named after the linked text and pre-

filled by the template you set in the Preferences,

Editing tab.

Make Plain/Rich Text: Converts a rich text

document to plain text and vice versa. Converting a

rich text to plain text removes all formatting, while

converting a plain text document to rich text applies

default rich text font settings to the document.

INVISIBLES

Show Colors: Shows the color panel, e.g., for

changing the foreground color of selected text in

rich text documents.

Show Invisible Characters: Toggles display of

invisible characters such as spaces, tabs, and line

feeds. Shown invisible characters appear in light

gray.

Allow Hypenation: Enables or disables hyphenation

for the current rich text document.
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THE VIEW MENU

The View menu contains all the commands for

modifying the way DEVONthink Personal displays

groups and documents.

VIEWS

Using these commands, you switch between

different layouts for main windows:

List

Icons

Columns

Split

Three Panes

Tags

VIEW OPTIONS

Cover Flow: When checked, DEVONthink Personal

displays the contents of selected groups in Cover

Flow style in the view/edit pane in the Split and

Three Panes views. Use it to quickly browse

through multiple documents. You can double-click

the frontmost document to open it in a separate

document window or you can drag it to other areas,

windows, or applications.

Full Screen: Displays either the current document in

a full screen mode optimized for reading and editing,

or the frontmost window in full screen.

Document: Shows the current document in full

screen.

Window: Shows the current window in full screen

(OS X 10.7 Lion or higher only).

To return to the normal view, press ⌘F7 respective

⌃⌘F7 or the EscapeEscape key. You define the width

of the document full screen view as well as plain

text font, background color, and text color in the

preferences, Editing tab.

Quick Look: Opens the Quick Look panel for the

selected items.

Slideshow: Shows the selected items as Quick Look

slideshow. Visible only when you visit the View with

the ⌥ key held.

VIEW LAYOUT

Widescreen: Switches Split, Three Panes, and Tag

views between standard and widescreen layout.

Show/Hide Details: Switches between displaying

icons only or displaying icons together with detailed

information such as kind, label, size, word count,

creation date, and modification date. Available in all

windows using icon or column views.

Show/Hide Tags: Shows or hides the tag bar.

SORT AND COLUMNS

Sort: Sorts items in ascending or descending

order by various criteria: name, kind, date added,

creation/modification date, URL, path, word

count, flag, label, width x height, duration, location

(enclosing group hierarchy of the item), aliases,

and Spotlight comment. You also can sort items

manually by choosing Unsorted. DEVONthink

Personal remembers sort settings for every group

separately and uses those settings when the group

is displayed in its own main window.

Columns: This sub-menu lists all columns available

in the current view and allows you to show or hide

them individually. Use these options to show exactly

the information you need.

The Flag column shows the state (flagged or

unflagged). Clicking the flag or the empty spot

for the flag toggles the option. Unread items are

marked as read when the "unread" state is clicked.

Both Sort and Columns support a range of metadata

fields next to DEVONthink Personal's own data

fields.

EXPAND AND COLLAPSE

Expands and collapses all groups at once.

ZOOM, FULL SCREEN

Actual Size: Depending on the document type, you

can zoom the document to your needs:

Actual Size: Displays the document at actual size,

calculated using the resolution of the screen and

the resolution information of the image or PDF.
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All Pixels: Displays the document at a 1:1 ratio so

that one pixel of the image equals one pixel on the

screen (PDFs and images only).

Zoom In/Out: Zooms in or out of the document.

Zoom to Fit: Displays the document so that it

exactly fits either the height or the width of the

window/preview pane (PDFs and images only).

Zoom to Width: Displays the document so that its

width fits the width of the window or view/edit

pane (PDFs and images only).

PDF DISPLAY, TEXT ALTERNATIVE

PDF Display: This sub-menu lets you adjust the way

PDF documents are displayed.

Single Page, Two Pages: Shows a multi-page

document as single pages or two pages facing

each other (as in a magazine).

Continuous Scroll: When checked, shows the

pages of the PDF as one long scroll. When

unchecked, only one page is shown at a time.

Book Mode: When checked, facing pages start

with one single page (the title page), then facing

pages. When unchecked, they start facing.

Page Breaks: When checked, pages are shown

with a shadow around them. When unchecked,

they are "melted together".

Crop Box, Media Box: Crops the page to the crop

or media box. By default, PDF pages are cropped

to the crop box.

Sidebar: Shows or hides the Sidebar.

Text/Best Alternative: Toggles between a graphic

preview of a document, named the Best Alternative,

and a text-only alternative, Text Alternative. For

some document types, e.g., email messages, the

Quick Look preview does not permit you to click

links or copy text; the text alternative allows this.

For Markdown texts these commands switch

between editing and rendered views. Plain text

documents containing Markdown markup can be

shown rendered, too.

TOOLBAR OPTIONS

Hide/Show Toolbar: Hides or shows the toolbar of

the frontmost window.

Customize Toolbar: Lets you configure the toolbar

of the frontmost window.

THE GO MENU

The Go menu contains all commands for navigating

the hierarchy of your DEVONthink Personal

database. Use these commands to go backwards

and forwards through your documents, or to move

back to the top level of the group hierarchy.

TOP GROUP, ...

Top/Enclosing Group/Selected Group: Goes

back to the top level of the group hierarchy, to the

group enclosing the shown group (if any), or to the

selected group ("hoist"). These commands are only

useful when you have opened a group in a second

main window, so that the "root" of the window is not

the top group of database, or when you are using

DEVONthink Personal in outline mode.

Back/Forward: Moves backwards and forwards

through all documents/web pages you have visited

by following cross-links or Wiki-style links.

First/Previous/Next/Last Document: Navigates

to the first, previous, next, or last document of all

documents in the current group. This is useful when

you have opened a document in a separate window

and want to move to another document in the same

group. It also works in Search windows.

INSTANCES, HIGHLIGHTS

Previous/Next Instance: Navigates backwards

and forwards through all instances of a replicated

document. Use these commands to find out where

the other instances of a replicated item are.

Alternatively, you can use a smart group to find all

documents that have replicants.

Previous/Next Highlight: Navigates backwards and

forward through all highlighted passages within a

document, regardless of whether these passages

have been highlighted by a search or by manually

using Format > Highlight. Use these commands to

visit all found text passages or highlighted passages

in a document.

Page: Navigates to the page with the entered page

number.

Time: Jumps to the specified time in a movie.
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WORKSPACES

Workspaces save the content and positions of all

open windows so that you can restore them later.

This is ideal if you are working with the same set of

windows over and over again. Save these windows

as a workspace and recall them whenever you need

them again.

Add: Saves the currently open windows as a

workspace.

Edit: Opens a window that allows you to edit

saved workspaces. Click on a workspace name to

change it, reorder by dragging, and delete with

the . button.

Update: Updates an existing workspace to the

currently open windows.

Workspaces: Restores to a previously saved

workspace.

THE TOOLS MENU

The Tools menu contains the more sophisticated

tools, such as the advanced search function, the

concordance, the history panel, and the log. It also

contains commands for keeping your database

healthy and for showing the Info and the Groups

panel.

SEARCH TOOLS

Search: Opens the Search window. Using the

search function, you can search your database in

a variety of ways--from searching for a document

by name to a full content search. Using its built-

in AI, DEVONthink Personal also assists you in

formulating the right query.

DEVONagent Pro: Opens DEVONagent Pro,

DEVONtechnologies' smart Internet research

tool. If the current document has a URL attached,

this URL is opened in DEVONagent's built-in web-

browser.

PANELS

Show Info: Opens the Info panel, which shows

basic information about selected items. Since it is a

panel, selecting a new item updates the Info panel

accordingly.

Show Properties: Opens the document properties

panel. View or edit the properties such as author,

subject, or keywords in the frontmost panel.

Show Groups: Opens the Groups panel. Use this

panel to always have your group list handy, which

makes dragging text clippings or documents from

DEVONthink Personal or other applications to a

group very convenient.

RESEARCH TOOLS

History: Opens the History panel for a selected

database (If only one database is open no sub-

menu is shown.) that lists all documents in the

selected database sorted by modification date. You

can use this panel for quickly finding newly added

documents or searching for documents by age.

DATABASE TOOLS

Like any database, DEVONthink Personal needs a

bit of maintenance from time to time. All commands

you'll need for database maintenance can be found

here.

Verify & Repair: Verifies all database structures and

repairs them if necessary. By default, DEVONthink

Personal automatically verifies the database

structure every time you open a database, and

advises you to run this command when it finds

significant errors. Orphaned files found during

repair are placed in a group "Orphaned files" in the

top level of the database.

Backup & Optimize: Creates an internal backup

of the database and then optimizes the database

structure. Optimizing removes unnecessary internal

elements from the database and rebuilds the

internal structure to optimize the performance.

DEVONthink Personal also creates internal backups

on a regular basis depending on the settings in the

Preferences, Backup tab. Internal backups only

back up the index structures in case the index gets

corrupted. Please use an external backup software

to create backups of your complete database

including all documents.
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Restore Backup: Restores an internal backup.

Choose the backup you want to restore from the

dialog window and click Open. You can identify

backups by their creation date.

Note: Restoring a backup simply swaps the

current database and the backup. The backup

becomes the active database, the former

database becomes a backup. You'll never lose any

data by using this command.

Rebuild Database: Completely rebuilds the

database by deleting the index and rebuilding it

from scratch. This removes any structural problems.

Depending on the size of your database, this can

take from a few seconds to several hours. You can

rebuild any database including the inbox.

SORTER

Show/Hide Sorter: Shows or hides the Sorter.

Take Note: Opens the Take Note panel that lets

you quickly enter a plain text note and add it to the

default destination.

THE WINDOW MENU

As in any Cocoa application, the Window menu lists

all open windows of the active application and gives

you access to commands for managing them.

WINDOW COMMANDS

Close, Zoom, Minimize: These three commands

resemble the red, yellow, and green buttons of

any window title bar, and consequently close the

window, minimize the window to the Dock, or

maximize the window. No magic here. Hold the key

to change Minimize to Minimize all.

Close, Select Next/Previous Tab: Closes the active

tab or moves the focus to the next or previous tab.

Note: Tabbed browsing needs to be enabled for

these commands to work.

Bring All to Front: Brings all windows of

DEVONthink Personal to the front. Hold the key to

change Bring All to Front to Arrange in Front.

Window List: Selects any open window from the

menu to bring it to the front.

LOG PANEL

Log: Opens the Log panel. The log lists error

messages and warnings that occurred while

importing new documents. It also opens

automatically when an error occurs. You can save

the log to a text file or clear it.

ACTIVITY PANEL

Activity: Opens the Activity panel. It shows all

running processes and allows you to manually stop

them.

THE SERVICES MENU

The DEVONthink Personal > Services menu allows

access to special commands published either by

other applications, such as TextEdit or Safari, or by

services extensions such as DEVONtechnologies'

WordService or CalcService. Also, DEVONthink

Personal publishes its own services in the Services

menu.

See also p. 20ff

THE HELP MENU

The Help menu contains commands for opening

the integrated help pages, the support assistant, or

visiting the DEVONtechnologies website.

DEVONTHINK PERSONAL HELP

These commands open the integrated help pages

that are equal to the document you're reading or

open the release notes. In addition, they direct you

to the bookmarklets installation page

TUTORIALS, SUPPORT ASSISTANT

Support Assistant: Opens the support screen of the

Welcome to DEVONthink Personal assistant where

you can get support, retrieve your license code,

request a trial extension, or update your details in

DEVONtechnologies' customer database. You can

also install additional scripts or templates from the

assistant.



DEVONthink 2.8.10 Documentation, page 43

Note: If you purchased DEVONthink Personal

from the Mac App Store, all options dealing with

licenses or upgrades are not available.

Tutorials: Opens the Tips and Tutorials screen of

the Welcome to DEVONthink Personal assistant. The

tutorials help get you started by explaining everyday

DEVONthink Personal tasks in step-by-step detail.

This function requires an Internet connection.

DEVONTECHNOLOGIES

These commands take you directly to the

corresponding pages on the DEVONtechnologies

web site. Visit our home page or the lively user

forum. If you have a question or suggestion, send

feedback directly to our development team.

Hold the ⌥Option key to show the alternative

menu item Report Bug. It creates a new message in

yourdefault email client or Apple Mail containing

the Console log and all related crash logs in a Zip

archive, ready to be sent to DEVONtechnologies'

customer support.

THE DOCK MENU

The Dock menu appears when you click DEVONthink

Personal's icon in the Dock with the ⌃ key pressed,

when you right-click it, or when you left-click it and

hold the mouse button for one second or longer.

DEVONthink Personal's dock icon also displays

a badge with the number of new items, e.g.,

after adding new data via the Services menu the

bookmarklets, or scripts. Longer tasks--importing,

indexing, running scripts--show a progress indicator

on the dock icon, too.

For all Mac OS X applications, the Dock menu

provides a selection of the commands of the

application menu.

<Window Name(s)>: Brings any open window of

DEVONthink Personal to the front.

Remove from Dock: Removes DEVONthink

Personal from the Dock. Only available if

DEVONthink Personal was added permanently to

the Dock and is not currectly open.

Open at Login: Adds DEVONthink Personal to

your login items.

Show In Finder: Reveals the DEVONthink

Personal application package in the Finder.

Hide: Hides all windows of DEVONthink Personal.

Quit: Quits DEVONthink Personal.

Besides these standard commands, DEVONthink

Personal adds a number of its own commands to the

Dock menu to make them easily accessible whenever

the application is running.

Search: Opens the Search window.

Show/Hide Groups & Tags: Shows or hides the

Groups & Tags panel.

Show/Hide Sorter: Shows or hides the Sorter.

Take Note: Opens the Take Note panel.

Clip to DEVONthink: Open the Clip to DEVONthink

panel.

http://www.devontechnologies.com/redirect.php?id=forum
http://www.devontechnologies.com/redirect.php?id=forum
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WINDOWS & PANELS

In this chapter:

Main window 45

Document window 49

Search window 50

Info panel 53

Document Properties 54

History 54

Groups & Tags 54

Take Note 54

Log 54

Activity 55

Preferences 55

Database Properties 55

Assistant 56

DEVONthink Personal uses a number of windows

to present information. These windows are used for

displaying and manipulating groups and documents,

finding information, editing metadata, analyzing

text, and changing the properties of your database.
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MAIN WINDOW

Most of your time working with DEVONthink

Personal will be spent in a main window. Main

windows give you access to your groups and

documents, while also allowing you to view and edit

files.

Open a new main window with File > New Window.

DEVONthink Personal also opens a new window

when you open a database; you can set this option

by checking Open New Window in Preferences,

General tab.

The title of the window shows the name of

document or group if one is selected, as well as its

icon. Click-and-drag the icon to move it to another

group or database or to the Finder to export it.

Click the title bar with ⌘ pressed to reveal the

document's location within the database; select an

enclosing group to reveal it.

VIEWS

Different views present your information however

you prefer:

List: Displays groups and documents as a list;

groups can be expanded/collapsed by clicking

the gray triangle in front of their name. Double-

clicking items opens them in separate windows.

Icons: Displays groups and documents as icons.

Double-clicking items opens them in separate

windows. For images, DEVONthink Personal

displays a live thumbnail. Adjust the size of the

icons using the slider located in the upper right

corner of the window, just below the toolbar. Use

View > Show/Hide Details to switch between icons

only, and icons with details in a list.

Columns: Displays groups and documents in

columns along with a preview pane, similar to

iTunes. Selecting a document displays it in the

preview pane; selecting a group shows the items

it contains in a new column. You can double-click

the column resizer to make it fit automatically,

and each column can be sorted individually.

Split: Splits the window into an item list and a

view/edit pane. To switch between a vertical and

horizontal split, use View > Widescreen. The item

lists all groups and documents in the database,

and may contain one or more columns. By default,

it shows only item names. Expand/collapse

groups by clicking the gray triangle.

Three Panes: Resembles the way Apple Mail

displays folders, items, and contents. The pane

on the left displays all groups, the top right pane

displays the documents contained in the selected

group, and the view/edit pane at the lower right

shows the contents of the selected document,

and allows you to edit it if possible. Tip: When you

click the Home button on the toolbar, you can see

the files located in the root of your database.

Tags: Shows all documents in a database for

selected tags. Select a tag to show all items

carrying this tag; select multiple tags (e.g. by

selecting them with the ⌘ key held) to show

documents carrying all selected tags. Select no

tag to show all items. Delete tags by pressing the

Delete or Backspace key; this moves ordinary tags

to the trash and excludes group tags from tagging.

New documents created in this view are either

created in the group represending the tag or in

the global inbox, and are tagged with the selected

tag. See also p. 96ff

To adjust the size of the different panes, move the

mouse to the divider between two panes until the

mouse pointer changes into a line with two arrows.

Then, click on and drag the divider to adjust the size

of the panes.

ITEMS

DEVONthink Personal displays groups and

documents, much as the Finder does. Select items

with a single click, and drag them from one group

to another. You can also drag items to the Finder or

other applications, or drag folders and files from the

Finder to DEVONthink Personal. You can also drag

selected items or clippings such as text and images

from any application to DEVONthink Personal and

vice versa.
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Press the ⌘ and ⌥ keys to link to the dragged

item(s) instead of importing them to the database.

For Bookends 11.3.1 or later this adds a formatted

rich text instead of a simple reference.

Single-click items to rename them. Double-click

items to open them in a separate document window

or in their native application (depending on the

document type). For smart groups, double-clicking

them in any view except Icons view opens the Smart

Group Editor. Press the Space bar to preview the item

using Quick Look; close the preview with the close

gadget or press Escape or Space again to close it.

Colored item names, colored group icons, and

special icons tell you whether an item is a duplicate

or replicant, its read/unread status or what type of

search a smart group uses.

Empty groups are shown in gray.

Duplicates are shown with their name in blue;

replicants are shown in red. See also p. 36ff

Icons of feeds or other unread items show an

"unread" indicator in the State column. See also p.

62ff

Smart groups using dates are shown with a clock

icon; smart groups using the "unread" status are

marked with a unique icon, too.

Regular groups are shown in blue, while groups

also used for tagging are shown in yellow with a

"tag" icon embossed.

In addition, icons indicate whether a item is locked,

has an attached comment or script, or has been

indexed instead of imported. See also p. 94ff

To view or edit the contents of a document or group,

do the following:

List/Icons View: Double-click the group or

document to open it in a separate window. Hold

the ⌘ key as you click if you want to close the

originating window at the same time (hoisting).

This also works in the other views.

Vertical/Horizontal Split/Columns View: Select

the group or document. The view/edit pane

shows the contents of the group or document.

Click the triangle in front of a group to expand it,

then select a document to view or edit.

Three Panes View: Select a group or sub-group,

then select the document you want to view or

edit. DEVONthink Personal shows the group

or sub-groups content in the view/edit pane.

Click the triangle in front of a group to expand it.

When you select multiple groups or news feeds,

the upper right pane shows all documents in all

selected groups in one list, just like in Apple Mail.

This does not work for smart groups.

VIEW/EDIT PANE

The view/edit pane (not visible in icons and list view)

shows the content of the selected document and, if

possible, allows you to edit it. You can edit plain text,

rich text, and HTML pages.

Read more here about the various document types

that you can view or edit in this pane.

INFO BAR

Just below the toolbar you'll find the info bar.

For selected items it shows an icon, the file

name including location, and the kind, size,

and modification date. If you're not sure of the

document type, this is the place to look.

Use the slider located on the right side of the info

bar to adjust the size of icons.

TOOLBAR & SHORTCUTS

The toolbar of DEVONthink Personal main windows

carries many commands for manipulating the way

the application displays information and handles

selected items. Many of the toolbar items are simply

shortcuts for menu commands. Here's a short list of

the available tools:

Please find a list of shortcuts in the appendix. See

also p. 94ff

Navigation: Navigates to the top level of the

database, or one level up. Useful when you have

opened a second main window by double-clicking

a group, and now want to move up the groups

hierarchy in this window.

Go To Document: Selects the first/previous/next/

last document. Only available in Three Panes

view or in separate document windows.

View: Switches between the possible views. See

above.

Actions: Provides commands for modifying the

selected documents, similar to the Action menu in
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other views. Generally, the Action menu contains

a selection of the commands also available via the

contextual menu.

Quick Look: Opens the standard Quick Look panel

for the selected items.

Group +: Creates an empty group.

Smart Group +: Creates a new smart group.

Plain/Rich Text +: Creates a blank plain or rich text

document.

Link +: Creates a new link document.

Mark Up: Highlights, underlines or strikes through

selected text. This option is available for rich text

documents, editable PDFs, and web archive.

Highlight: Highlights the selected piece of text

with the color selected in Preferences, Colors tab.

Open: Opens the selected documents in separate

document windows.

Open With >: Opens the selected documents in an

external application.

Launch URL: Opens the Internet location stored

in the URL field of the selected documents, e.g., a

web site URL in Safari.

Copy URL: Copies the Internet location stored in

the URL field of the selected document to the

clipboard.

Delete: Moves the selected documents to the

Trash.

Save: Saves all changes to the currently edited

document.

Import, Export: Imports new documents; Exports

the selected documents.

Reveal: Reveals the location of the selected items

in either the same main window, if possible, or by

opening a new one.

Show in Finder: Opens a new Finder window

showing the selected items.

Update: Updates an indexed item. See also p. 33ff

Print: Prints the current or selected documents.

Info: Opens the Info panel.

Group/Ungroup Items: Group creates a new

group and moves all selected documents into it.

Upgroup moves all documents contained in the

selected groups one level up and then deletes the

then-empty group.

Auto Classify: Classifies the selected documents

and moves them into the most appropriate group

if possible.

Find (search field): Lets you search your databases.

Select your search options from the magnifier

pop-up menu, enter your search term, and press

Return. Click the search field's search button to

return to the standard view. The pop-up menu

also lists the last 25 used search terms. Check

Prefix while typing to let DEVONthink Personal

begin to search as you type. The last word of the

term is treated like a prefix ('word*'). Add more

characters to refine and to speed up the search

and press Enter or ↩ to finish the search, or to

search for whole words only. See also p. 50ff

Find: Opens the Search window.

Bigger, Smaller Font: Increases or decreases the

font size.

Subscript, Superscript: Makes selected text

subscipt or superscript.

Ruler: Shows or hides the ruler for rich text.

Fonts: Shows the standard Mac OS X Font panel.

Colors: Shows the standard Mac OS X Colors

panel.

Make Plain/Rich Text: Converts the current text

document to plain or rich text.

Highlighting: Highlights selected text. The pop-up

menu lets you select the highlight color.

Link: Makes selected text a Wiki-style link. If the

text is a URL, the link points to that URL.

Edit Source, Show Page: Toggles between source

and page display of selected HTML documents.

Zoom: Zooms in, out, or to view width, or shows

the document in 1:1.

Full Screen: Shows the selected documents in full

screen mode. Press ⌘F8 to return to windowed

mode.

(Capture) Page: Captures a web page as HTML

code to either the current group or to the inbox.

(Capture) Web Archive: Captures a web page as

web archive to either the current group or to the

inbox.

(Capture) PDF: Captures a web page as a PDF to

either the current group or to the inbox.

(Capture) Note: Captures selected elements of a

web page as a rich text document to either the

current group or to the inbox.
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DEVONagent: Opens DEVONagent. If the view/

edit pane or frontmost window displays a web

page, it opens the same URL in DEVONagent.

Refresh: Refreshes the selected news feeds.

Backup: Creates an internal backup of the

database and then optimizes the database

structure; same as Tools > Backup & Optimize.

Verify: Verifies the database structure; same as

Tools > Verify & Repair.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, AirMail, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If

the selected item is an email message, the sender

is automatically inserted as the recipient and the

text of the original message is inserted instead of

an attachment. Notes: Postbox is currently only

able to send one selected file. Unsupported email

clients (e.g. Thunderbird) can only send the plain

text of one selected file.

Image Capture: Opens the Image Capture window

for capturing paper documents.

Take Note: Lets you take a quick note.

Note: Not all of these commands are always

available. You can customize the toolbar

by selecting View > Customize Toolbar or by

clicking with ⌃ pressed (right-click) the toolbar

background and selecting Customize Toolbar from

the contextual menu.

CONTEXTUAL MENU

The contextual menu (which appears when you

right-click or ⌃ click an item) offers a range of

commands tailored to what you wish do with the

clicked object.

Most of the commands offered by the contextual

menu have counterparts in a main menu, so you'll

recognize them immediately. However, to save

menu bar real estate, DEVONthink Personal gives

you access to some options only via the contextual

menu.

New Window: Opens a new main window.

Open Database: Opens the selected database.

Close Database: Closes the selected database.

Delete Database: Closes the selected databases,

and moves it to the Finder's trash.

Empty Trash: Empties the trash can.

Database Properties: Shows the Database

Properties of the selected database.

Add to Favorites: Adds the selected item to the

favorites.

Remove from Favorites: Removes the selected

item from the favorites.

New Smart Group: Creates a new smart group in

the sidebar.

Edit: Opens the smart group editor (only available

for smart groups).

Delete Smart Group: Removes the selected smart

group from the sidebar.

New: Creates a new document.

Open: Opens a selected document(s) in a new

window.

Open in Tabs: Opens a selected document(s) in a

new tab.

Open With: Opens a selected document(s) with an

external application.

Refresh Feed(s): Manually refreshes the selected

news feeds.

Launch URL: Opens the URLs indicated by the URL

field of the selected documents.

Copy URL: Copies the Internet location indicated

by the URL field of the selected document to the

clipboard.

Copy Item Link: Copies a unique URL refering

the selected item to the clipboard. Paste this

URL into any third-party application to directly

reference an item in your DEVONthink Personal

database. See also p. 105ff

Show in Finder: Reveals the item's file in the

Finder.

Get Info: Opens the Info panel for the items.

Move Into Database: Imports the selected indexed

item (and its children, if necessary) into the

database. Only available for indexed items. Use

this command to consolidate your database.

Move To External Folder: Moves items added

to an indexed group from the database to the

connected folder in the filesystem. Only available

for items in an indexed group.

Exclude from Tagging: Excludes the selected

groups from tagging.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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Move To >: Moves the group or document to the

group you select in the sub-menu. Note: Moving

items to another database cannot be undone.

Replicate To >: Creates a replicant of the group

or document in the group you select in the sub-

menu. Note: Doesn't replicate if a replicate for

the item is already present at the destination.

Duplicate To >: Creates a duplicate of the group

or document in the group you select in the sub-

menu. Note: Copying items to another database

cannot be undone.

Label: Changes the label of the selected items.

Mark: Marks the selected items as flagged/

unflagged, read/unread, locked/unlocked and

shows/hides the state of the items.

Move To Trash/Move All Instances To Trash:

Moves the selected document or all instances

of the selected documents, such as including all

replicants (if any), to the trash. Hold the ⌥Option

key to reveal the Move All Instances To Trash

command.

Thumbnails: Creates, updates, or deletes the

thumbnails for the selected items.

Convert: Converts the selected items to other

document formats.

Group: Creates a new group containing the

selected items. Appears as Tag if the new group

would be created in the Tags group.

Auto Classify: Classifies the selected items and

moves them to the group where they best fit.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, AirMail, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If

the selected item is an email message, the sender

is automatically inserted as the recipient and the

text of the original message is inserted instead of

an attachment. Notes: Postbox is currently only

able to send one selected file. Unsupported email

clients (e.g. Thunderbird) can only send the plain

text of one selected file.

Sort: Sorts the list of items to any available

criterium.

Empty Trash: Empties the trash (only available for

the trash).

In the Tags view, the following commands are

available:

Save Search: Available in the right pane of the Tags

view, this command creates a smart group from

one or multiple selected tags. Use it to select

some tags and to save the search as a smart group

for convenient access.

Note: For your convenience, DEVONthink

Personal also makes the Services menu, available

via the contextual menu.

DOCUMENT WINDOW

A document window is similar to the view/edit pane

of a main window. You open a document window by

double-clicking a document in any view of a main

window or by choosing Data > Open (or any of its

equivalents in contextual menus).

Depending on the type of information the document

contains, the toolbar of a document window offers

different sets of tools. Most of them are identical

to their counterparts in the DEVONthink Personal

main window toolbar.

See the Documents chapter for a detailed

description of the various document types.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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SEARCH WINDOW

Search windows allow you to search your database

in various ways, and assist you with intelligent

functions for broadening and adjusting your search

terms.

SEARCH TERM

In the top part of the search window you find

the search term field, as well as the Similar Words

button. To enter a search term and run the query

with the default options, simply type your search

words into the search term field and click the

magnifier button (right of search field). Like in many

other Mac applications, the pop-up menu (behind

the magnifier icon at the left side of the search term

field) gives you access to the last 25 search terms.

DEVONthink Personal uses Boolean operators,

parenthesis, and quotes to allow complexly

structured search terms. Read more about

operators and how to use them to write a search

term in the appendix.

To broaden or adjust your search term, enter a word

and click Similar Words to show a list of all words

in the database that are similar to the entered

word either by spelling or by context. Choose one

or more words (use ⇧ and/or ⌘ to select multiple

words from the list) to use them as search words.

Multiple selected words are combined using the

OR operator (spelling) or AND (context). The term

you've entered will be shown on the top of the

list, so you won't lose it for your search run. This

function uses all open databases for retrieving

similar words.

SEARCH OPTIONS

The left side of the search window gives you even

more control over the way DEVONthink Personal

searches the database. Adjust these options to best

fit your needs.

Search for: Choose exactly what you're looking for

or select All to search all parts of a document:

All: Searches all elements of a document.

Content: Searches the content of a document.

Name: Searches the name of a document.

URL: Searches the URL field of a document.

Comment: Searches the Comment field of a

document.

Metadata: Searches the metadata associated with

a document.

Comparison: Make DEVONthink Personal treat

regular letters and their counterparts with umlauts

or diacritics equally. Check Fuzzy to make searches

fuzzy (e.g., "Hello" and "Hullo" would both be found).

Note: This option is only applied to words, not to

wildcards.

State: Limits the results based on their status

(flagged/unflagged). Choose Any to find results

regardless of their state.

Unread: Limits the results based on whether they

have been marked as read or unread. Choose Any to

find results regardless of their read status.

Locking: Limits the results based on whether they

are locked or not (on/off). Choose Any to find results

regardless of their locking flag.

Label: Limits the results based on their label.

Choose Any to find results regardless of their label.

Search in: Limits the scope of the search run to all

open databases, a selected database, or a selected

group.

Note: To search for all documents with a given

status, locking state, or label, simply leave the

query field empty and use the above options to

define what you are looking for.

Advanced: This button lets you enter advanced

search criteria in the same way you do for smart

groups. Use this to search for tags, date ranges or

similar limiters. The Reset buttons clears the set

advanced criteria. See also p. 68ff

SEARCH RESULTS

After a successful search run, DEVONthink

Personal lists all found documents below the search

term field, and displays them in a list together with

their relevance score, icon, location in the database,
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modification date, document kind, and size. Sort the

list by clicking the column titles; click them again

to reverse the sorting order. Modify the columns

using the contextual menu or View > Columns. Point

the cursor to a result and the appearing tooltip will

show you the full title, location, and other metadata;

click a document title once to rename the document.

Below the list of found documents, DEVONthink

Personal gives you a preview of the documents you

select in the list. If you cannot see the preview area,

drag its handle up from the bottom of the window.

Also, you can do almost everything you could do in

any other DEVONthink Personal window, such as

drag a document to another window (or Finder), or

export the document using File > Export.

See also/Classify drawers are supported, too.

Due to limitations in Mac OS X's PDFKit,

highlighting of occurences of the search term in the

document is not tied to words; thus, DEVONthink

Personal also highlights sub-strings.

SMART GROUPS

When you are satisfied with the search results,

you can save the query as a smart group. Click the

+ button next to the search term field and enter a

name for your new smart group. The new smart

group that searches a specific database is created in

the top level of the database.

TOOLBAR & SHORTCUTS

The toolbar of the search window offers many tools

that are also present in DEVONthink Personal main

or document windows. Here's a short list:

Go: Selects the first/previous/next/last item.

Actions: Provides commands for modifying the

selected documents, similar to the action menu in

other views. Generally, the action menu contains

a selection of the commands also available via the

contextual menu.

Open: Opens the selected document(s) in separate

document windows.

Open Externally: Opens the selected documents

in an external application.

Launch URL: Opens the Internet location stored in

the URL field of the selected documents, such as a

web site URL in Safari.

Copy URL: Copies the Internet location stored in

the URL field of the selected document to the

clipboard.

Group: Groups the selected documents in a new

group.

Delete: Moves the selected documents to the

trash.

Export: Exports the selected documents.

Info: Opens the Info panel.

Print: Prints the selected documents.

Zoom: Zooms in, out, to view width, or shows the

document in 1:1.

Full Screen: Shows the selected documents in full

screen mode. Press ⌘F8 to return to windowed

mode.

DEVONagent: Opens DEVONagent Pro. If the

view/edit pane or frontmost window displays a

web page, it opens the same URL in DEVONagent

Pro.

Note: Not all of these commands are always

available. You can customize the toolbar by

selecting View > Customize Toolbar or by ⌃ clicking

(right-clicking) the toolbar background and

selecting Customize Toolbar from the contextual

menu.

Please find a list of shortcuts in the appendix. See

also p. 94ff

CONTEXTUAL MENU

You can manipulate the search results by right-

clicking or clicking them with ⌃ pressed to open the

contextual menu, which offers various additional

commands.

Open: Opens the selected documents in a separate

main window.

Refresh Feed(s): Manually refreshes the selected

news feeds.

Launch URL: Opens the documents or web pages

pointed to by the URL field of the selected

documents.

Copy URL: Copies the Internet location stored in

the URL field of the selected document to the

clipboard.
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Reveal: Shows and selects the document group.

Duplicate To >: Duplicates the selected documents

to the group you select from the sub-menu.

Replicate To >: Replicates the selected documents

to the group you select from the sub-menu. Note:

Doesn't replicate if a replicate for the item is

already present at the destination.

Move To >: Moves the selected documents to the

group you select from the sub-menu.

Label >: Changes the label of the selected

documents.

State >: Shows or changes the state of the selected

documents.

Locking >: Locks or unlocks the selected

documents.

Move To Trash/Move All Instances To Trash:

Moves the selected document or all instances

of the selected documents, such as including all

replicants (if any), to the trash. Hold the ⌥Option

key to reveal the Move All Instances To Trash

command.

Group: Creates a new group in the top level of the

database, and moves the selected documents

there.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported email

applications are Apple Mail, AirMail, Mailsmith,

Microsoft Outlook, Postbox, and PowerMail. If

the selected item is an email message, the sender

is automatically inserted as the recipient and the

text of the original message is inserted instead of

an attachment. Notes: Postbox is currently only

able to send one selected file. Unsupported email

clients (e.g. Thunderbird) can only send the plain

text of one selected file.

http://airmailapp.com
http://www.barebones.com/products/mailsmith/
http://www.microsoft.com/mac/
http://www.postbox-inc.com/
http://www.ctmdev.com/powermail/
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INFO PANEL

The Info panel, just like its counterpart in the

Finder, displays additional information about a

selected document or group, from icon and name to

comments and other metadata.

Open the Info panel using the i icon from the

window toolbar or by selecting Tools > Show Info.

The contents of the Info panel corresponds to the

currently selected object, so you can leave it open

all the time and it will always display the correct

information for the selected document or group.

HEAD ELEMENTS

Icon and Name: Just like in the Finder, the top part

of the panel displays the icon and the name of the

selected object. To change the icon of the document,

select it and paste any image you want over it. To

change the name of the document, use the Name

field below.

Locked: The Locked checkbox indicates that the

object is write-protected. Check the checkbox

to protect documents from being accidentally

modified, or groups and documents from being

accidently deleted. Locked documents or groups are

marked with a padlock.

MAIN ATTRIBUTES

Name: Use this field to change the name of the

object.

Aliases: Enter one or more words here, separated

by semicolons, as alternative targets for Wiki-style

links. Generally, Wiki links refer to the name of

contents, and aliases make this system even more

flexible.

Path: This field contains the path to the file holding

the document's data. It is non-editable. You can click

the @ button to open the references file using the

Finder. In general this is equal to using Data > Open

With and choosing the default application.

URL: Smiliar to the Path field, the URL field is used

to link the document to an Internet address or

anything else that can be reached by a URL. This

field is used primarily by bookmarks, but you can

also use it to connect a document to a web page.

To visit the web page click the @ button next to this

field or select the document and use the contextual

menu command Launch URL.

INFORMATION ELEMENTS

Size: Shows the size of the item. For groups and

news feeds, this field shows the size of all contained

items.

Kind: Shows the selected document type (for

example text, RTF, etc.)

Added: Shows the date when the object was

actually added to the database.

Created, Modified: Shows the (editable) dates when

the object was created and when it was modified the

last time.

ADDITIONAL INFORMATION

This section lists metadata that has been stored

together with the item. Information shown depends

on the file type as well as the individual document.

ADDITIONAL ELEMENTS

Exclude from ...: These checkboxes allow you to

exclude this item from being used in classification,

see also, search, or tagging. Use this option to

exclude such things as temporary groups from

classification to increase the accuracy of the built-in

artificial intelligence.

Label: Shows the label assigned to this item and lets

you change it.

Tags: Shows the tags assigned to this item. You can

also edit tags here. See also p. 96ff

Location: Shows the location of this item inside the

database.

Instances: Shows how many replicants of this

document or group exist in the database and

how many duplicates DEVONthink Personal has

identified. Click to show a pop-up menu listing all

instances and duplicates and their enclosing groups.

Select any item to reveal it. Point at an item for a

second to make a tooltip appear that shows the

item's location.
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Spotlight Comments: Stores other information

you want to attach to your document or group

(similar to the Spotlight comments field in the

Finder). Of course, the Comments field is searchable.

DEVONthink Personal synchronizes the Spotlight

comments in the Finder with this field in the

database. If this application was purchased in the

App Store, only importing Spotlight comments is

possible.

Note: You can modify the comments of multiple

selected items simultaneously, as long as the

comment of all selected items is either identical

or empty.

DOCUMENT PROPERTIES

The Document Properties panel gives you access to

all metadata stored for a selected document. This

metadata includes, but is not limited to:

Author

Company

Copyright

Title

Subject

Keywords

Comments

Depending on the document type, you can edit or

view these properties. More fields may be available

depending on the document type.

HISTORY

The History panel, opened using Tools > History, lists

all documents in your database, without the groups

hiearchy (by default sorted by modification date

which reflects content modifications only but not

name or metadata changes).

Sort the list by name, age, or file size by clicking

the column titles (Click again to reverse the sorting

order.), and by any other criterum using View > Sort.

Customize the columns using View > Columns.

Of course, you can use drag-and-drop to move

documents to other windows or to the Finder, and

modify the documents using the commands in the

Data menu or the contextual menu.

Use the History panel to quickly access recently

added documents or to export all documents of a

certain age.

GROUPS & TAGS

The Groups & Tags panel, opened using Tools > Show

Groups & Tags, gives you direct access to all open

databases and their groups including the tags inside

the special Tags group. Use it to drag items directly

to a group or tag or to rearrange groups. You can

also apply menu commands to selected items, e.g.,

Data > Open.

Depending on your Preferences, General tab, the

Groups & Tags panel floats above all other windows,

even in other applications.

TAKE NOTE

The Take Note panel, opened by hitting a hot

key, from the toolbar, or from the Tools menu,

allows you to quickly enter a note, choose the

destination, and add tags and a URL to the note.

If DEVONthink Personal can get the URL of the

frontmost application, e.g., from Safari, it will also

insert that information automatically into the URL

field.

Use the Format pop-up menu (in the panel) to

choose the document format for the new note. Use

the commands in the Format menu (from the menu

bar) to style your note.

The New Group button creates a new group in the

destination group selected above.

Change the hot key for opening the Take Note panel

in the Sorter preferences.

Note: For this function DEVONthink Personal

needs to be running. This may change eventually.

LOG

The Log panel displays warnings and error messages

that occur, when importing files and folders and

performing other actions. The panel shows the

date of the message, the affected file, and a short

information about what happened.
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You can save the list to a text file with the Save

button, and clear the log with the Clear button. To

sort the log, click the column title. (Click again to

reverse the sorting order.) Use the contextual menu

or double-click the entry to reveal an affected file in

the Finder.

Uncheck Show log automatically to prevent the log

popping up automatically. You can open the Log

panel at any time using Window > Log.

Right-click or click with ⌃ held to perform additional

commands on log entries via the contextual menu,

e.g., to reveal a logged item or move a logged item

to the trash. Copy information from the log to the

clipboard with Edit > Copy, ⌘C, or the contextual

menu.

ACTIVITY

The Activity panel shows a list of currently running

background processes, e.g., downloading PDF

documents and web archives (e.g. via bookmarklets

or Clip to DEVONthink. You can manually stop them

to free computer resources or for other reasons.

Some operations, e.g., verifying a database, show

and hide the Activity panel automatically.

PREFERENCES

The Preferences window, opened using DEVONthink

Personal > Preferences, contains all available options,

which you can modify to adapt DEVONthink

Personal to your personal needs.

Because the preferences are so important, we have

created a separate chapter for them.

DATABASE PROPERTIES

The Database Properties panel defines preferences

which are directly related to the database and not

to the application in general. Open the properties

panel using File > Database Properties for every open

database including the global inbox.

LOCATION

This section of the properties panel shows the

location of the database package and any additional

options:

Location: Double-click any part of the database

location to reveal it in the Finder.

Create Spotlight Index: Check to make this

database available to Spotlight. Checking this option

lets DEVONthink Personal create a folder in "~/

Library/Cache/Metadata" that Spotlight uses for

accessing the documents in the database. If you ever

feel that this folder is out-of-sync with the database,

click Rebuild to recreate this folder from scratch.

When viewing Spotlight results in a window, make

sure to have the Show all file extensions option in

Finder's Preferences, Advanced tab unchecked. If this

option is checked, the Finder displays the generic

names of the metadata cache files instead of the

name of the referenced document.

Starting with version 2.0.6, DEVONthink Personal

adds information to the Spotlight metadata that

makes it possible to preview many file types directly

from the Spotlight results window. Supported are

text and rich text (RTF and RTFD), image, movie,

audio, PDF, HTML, XML, and web archive files.

DEVONthink Personal needs to be installed on the

machine viewing the Spotlight results. You may

need to rebuild the Spotlight index to activate this

function.

Note: Rebuilding the Spotlight index can become

necessary after copying a database from one

computer to another.

Exclude Groups from Tagging: Excludes all groups in

this database from being used as tags. Ordinary tags

can always be added to items using the Tag bar.

STATISTICS

This section displays some basic statistics about

how many documents your database contains, file

sizes, etc.
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NAME AND COMMENTS

Name: Enter a name for your database here. It will

appear in the title bar of every main window of this

database.

Note: This does not change the file name for

the database package. You cannot change the

name of or add commments to the database

representing the global inbox.

Comments: Enter your own comments about the

database here, e.g., a project description.

PROTECTION

To prevent other people from opening DEVONthink

Personal and accessing your data, click on the

padlock button to unlock the entry fields, enter a

user name and password, and then click on the

padlock button again to lock your changes and hide

the password.

Note: This is a simple password protection.

DEVONthink Personal does not yet provide file

encryption for enhanced security. For better

protection, create an encrypted disk image using

Disk Utility and store your database on that

encrypted volume or disk.

ASSISTANT

The integrated Assistant combines a welcome screen

with tips, web and video tutorials, installable extras,

and a suppport page that guides you through the

available support options.

WELCOME

This screen welcomes you when you start

DEVONthink Personal for the very first time. It

offers:

An introductory screencast

The option to subscribe the free

DEVONtechnologies newsletter, as well as a

number of welcome tips

The tip of the day

The extra of the day

You can access all other screens of the assistant

from here, too.

GET SUPPORT

The support screen guides you through the three

common steps for troubleshooting DEVONthink

Personal. In addition, you can have your license

code resent in case you don't have it anymore,

request a trial extension, update your details in

DEVONtechnologies' customer database, or buy an

upgrade or a second license.
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TIPS AND TUTORIALS

Here you can find the latest tips and tutorials to help

you squeeze the best out of DEVONthink Personal.

Tutorials can be slideshows describing basic tasks in

DEVONthink Personal or screencasts.

Both tips and tutorials are updated live from

DEVONtechnologies' server so it's a good idea

to check back on a regular basis. The latest tip or

tutorial is also always mentioned on the welcome

screen.

INSTALL EXTRAS

On the extras screen, DEVONthink Personal lists all

available extras that you can download and install

from DEVONtechnologies' server:

Scripts

Templates

Plugins

Browse the list of extras and install them with the

Install button. The last line of the description shows

where in the Templates menu the extra will show up

after installation. Remove installed extras with the

Remove button.

The extras are updated live from

DEVONtechnologies' server so it's a good idea to

check back from time to time. The latest extra is also

always mentioned on the welcome screen.

Note: If one of these categories does not show

up in your copy of DEVONthink Personal, there

might be no extras of this type (yet) available for

DEVONthink Personal.
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DOCUMENTS

In this chapter:

General 58

Plain and rich texts 59

Formatted notes 61

Markdown texts 61

Web pages, HTML pages, feeds 62

Images and videos 63

PDFs 64

Office documents, email, and others 65

All documents are displayed in DEVONthink

Personal in views. Each view features its own tools,

contextual menu commands, and hidden keyboard

shortcuts. In this chapter, we will look at many of

those features.

GENERAL

All documents are displayed in DEVONthink

Personal in views (not to be confused with the

different layouts in main windows, also called

views. Each view has its own tools, contextual menu

commands and keyboard shortcuts.

Currently, DEVONthink Personal features the

following view types:

Plain and RichText

Office and other documents

HTML pages, Web pages, Feeds

Images

PDFs

NAVIGATION BAR

At the top of the view/edit pane DEVONthink

Personal shows a navigation bar that gives you

access to some additional tools that deal directly

with the contents of the document. Which tools are

available depends on the type of the document.

 Navigates back to the last visited document

after following a link.

 Navigates back to the next visited document

after going back.

 Reloads the displayed page in a web view. This

item is only visible for document types that

support reload, e.g. bookmarks.

 Shows an action menu with options for opening

the shown page in Safari, copy its address, or

capture the page in a variety of formats.

 Shows the system-wide sharing menu. OS X 10.8

Mountain Lion or later only.

 Locks or unlocks the item.

 Scrolls to the previous highlight, e.g., a search

term occurrence.

 Scrolls to the next highlight, e.g., a search term

occurrence.

 Scrolls to the next page of the displayed

document.

 Scrolls to the previous page of the displayed

document.

 Switches to text-only mode.

 Switches from text-only mode back to the

(standard) preview mode.

 Shows the PDF sidebar containing thumbnails of

all pages.

 Hides the sidebar.

 Opens the See also & Classify drawer.

 Shows a list of the most important words of the

document.

 Switches the tag bar on and off.

The text-only mode can be useful for selecting text

in items that are displayed using Quick Look or to

view or edit the source code of an HTML document.

In preview mode DEVONthink Personal uses Quick

Look to show Pages documents and other filetypes

in their original layout. Select any word from the

 menu to show documents also dealing with this

keyword.

URL: Shows the URL associated with the displayed

item. If a PDF annotation is selected the URL field

shows the associated URL if available. Click to

launch the URL in its default application. Hold

the ⌥ or the ⌘ key to open the URL in a new tab.
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Holding Shift-Option or Shift-Command opens the

URL in a new tab and selects it.

Word Count: Shows the number of paragraphs,

words, and characters of the displayed text.

Page Count: Shows the number of pages as well

as the page number of the currently displayed

page. Click the page number in PDF or PostScript

documents and enter a page number to jump

directly to that page.

TAG BAR

The Tag bar, which can be shown or hidden, shows

all tags associated with the document. Click the

tag bar and type to add tags; select a tag and press

the Delete or Backspace key to remove it. See also p.

96ff

When you type the name of a tag, DEVONthink

Personal offers automatic completion. Choose the

right option with the mouse or the arrow keys and

press ↩ or Enter to accept it. Press Escape to use

whatever you entered. Auto-completion prefers

ordinary tags (tags represented in the Tags group)

over groups used as tags, and also matches sub-

strings. Press ⇥ to enter another tag.

Note: The Tag bar is also visible for multiple

selected documents when all the documents have

the same tags attached. Use it to change the tags

on multiple documents.

TOOLBAR & SHORTCUTS

DEVONthink Personal can display documents

in separate windows when you double-click the

documents in a main window. Depending on the

type of document, the tools in the toolbar can

change. Even though not all tools are always present

in the default toolbar for a particular view, you

can easily add them by choosing View > Customize

Toolbar.

Please find a list of shortcuts in the appendix. See

also p. 95ff

PLAIN AND RICH TEXTS

The view for plain and rich text documents is

basically a built-in incarnation of TextEdit, and you

use it in a very similar fashion. Of course, text views

support the Edit > Find commands and all options of

the Format menu.

THE RULER

For rich text documents, DEVONthink Personal

supports the standard ruler that the TextEdit engine

of Mac OS X provides. Show or hide it with Format >

Ruler > Show/Hide Ruler.

The ruler contains the following elements:

Tab Stops: Place tab stops with the mouse, then

remove them by dragging them off the ruler.

Drag new tab stops (left aligned, centered, right

aligned, or decimal aligned) from the repository

at the right side to their desired positions on the

ruler. Use the mouse to adjust the left and right

margins and indent.

Styles: Select a predefined text style from the pop-

up menu. To define your own styles, choose Other

to open the Mac OS X standard style editor. In the

style editor, navigate back and forth through the

styles of your document or the stored favorite

styles. (Use the radio buttons to switch between

document and favorite styles.) Click Select to

select all occurences of text with the displayed

style in the document, click Apply to apply the

style to selected text, or click Done to leave the

style editor. To add a style from your document

to Favorites, click Add To Favorites; to remove a

favorite, click Remove From Favorites.

Alignment: Align the current paragraph (the one

with the insertion caret inside) left, centered,

justified, or right by clicking the according

alignment buttons in the ruler.

Spacing: Choose the desired spacing for the

current paragraph from the Spacing pop-up

menu. Choose Other to enter values other than

the ones shown.

Lists: Make the current paragraph a list (indented

and with a bullet or numbered) by choosing the

desired list style from the Lists pop-up menu.

Choose Other to define your own list style.
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Note: The built-in "mini outliner" is an nice

feature. On any blank line in a rich text document

(doesn't work for plain texts), type ⌥⇥ to create

a bullet point (Mac OS X shows dashes instead

of bullets). Press ↩ for the next item, and so on.

Additional ⌥⇥ will increase the indentation; a

↩ on a blank list line will decrease it. The mini

outliner uses hyphens to indicate list items by

default. Right-click to choose all kinds of list

styles.

ATTACHMENTS

You can attach other documents to rich text

documents simply by dragging them into the text.

Technically the rich text document becomes a .rtfd

package and the dragged file is saved as part of

the package. Drag items into plain texts with

⌘Command and ⌥Option pressed to insert only

their titles.

Use the contextual menu to show an attachment's

content in a Quick Look preview.

Double-click attachments to edit them externally.

Note: Editing attachments requires OS X 10.7

Lion or higher. Also, you cannot attach files to

plain text documents. You need to convert them

to rich text before you can attach other files.

DRAG-AND-DROP

Besides dragging text from and to text documents

you can also drag the following:

Files: Adds the file as an attachment to a rich text

document. Hold ⌘Command and ⌥Option to

insert only a link to the file.

Contact cards: Drag a card from Contacts holding

⌘Command and ⌥Option to insert a link to the

card.

Calendar event: Drag a Calendar event to insert a

short text summary of the event including a link

to Calendar.

TOOLBAR & SHORTCUTS

The document windows toolbar is very similar to the

one in DEVONthink Personal main windows, yet can

be configured separately.

Please find a list of shortcuts in the appendix. See

also p. 95ff

CONTEXTUAL MENU

Add Link: Makes the selected piece of text a

WikiLink. The destination of the WikiLink is a

document with the same name as the selected

text. If no document with that name exists,

clicking the created link creates it using the

template you have set in the Editing Preferences.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Copy Link: Copies a link to the Clipboard (only

available for selected links).

Edit Link: Edits the destination of a selected link.

Highlight: Highlights the selected piece of text

with the color you select in the sub-menu.

Insert Link To: Inserts a link to an item you select

in the sub-menu (only available when no text is

selected).

Insert: Inserts special elements into the text (such

as a page break, the current date or a bullet).

Same as the Insert sub-menu of the Edit menu.

Link To: Makes the selected piece of text a cross-

link and links it directly to the group or document

you select in the sub-menu.

Look Up [word]: Looks the selected text up in Mac

OS X's Dictionary.

Open Alias: Follows a selected link (only available

for a selected Wiki-style link resolved by an alias).

Aliases are defined for each item separately in

the Info panel.

Open Link in Browser: Opens the selected link in

the default browser or application (only available

for a selected link).

Open Link in New Tab: Opens the selected link in a

new tab.

Quick Look Attachment: Opens a Quick Look

panel for the selected attached link or file (OS X

10.7 Lion or higher).

Remove Link: Makes a selected link simple text.

Search selected phrase: Searches for the selected

text as a phrase.

Search with Google: Opens your default browser

and searches for the selected text in Google.
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Search with Spotlight: Searches for the selected

text using Spotlight.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text (needs to be less than

256 characters).

Split Document: Splits the document at the

current insertion mark position.

FORMATTED NOTES

Formatted notes allow to write simple formatted

text including embedded images that can be viewed

on any system with just a web browser. While the

range of formatting options is smaller that that of

rich text they are much more compatible to today's

standards. You can find all available formatting

commands in the Edit and Format menus. By default

formatted notes use the font set in Preferences >

Editing for rich texts and notes.

Technically formatted notes are based on HTML,

the language of the world-wide web. Images are

embedded directly into the HTML code so that

formatted notes are completely self-contained.

The HTML code is also cleaned from unnessessary

tags and an identifying meta tag is inserted that lets

DEVONthink Personal distinguish formatted notes

from normal HTML pages.

TOOLBAR & SHORTCUTS

The document windows toolbar is very similar to the

one in DEVONthink Personal main windows, yet can

be configured separately.

Please find a list of shortcuts in the appendix. See

also p. 95ff

CONTEXTUAL MENU

Add Link: Lets you enter a URL and makes the

selected text a link to it.

Add Tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Edit Link: Edits the destination of a selected link.

Highlight: Highlights the selected piece of text

with the color you select in the sub-menu.

Link To: Makes the selected piece of text a cross-

link and links it directly to the group or document

you select in the sub-menu.

Look Up [word]: Looks the selected text up in Mac

OS X's Dictionary.

Open Link in Browser: Opens the selected link in

your default web browser.

Open Link in New Tab: Opens the selected link in a

new tab.

Remove Link: Makes a selected link simple text.

Search selected phrase: Searches for the selected

text as a phrase.

Search with Google: Opens your default browser

and searches for the selected text in Google.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text (needs to be less than

256 characters).

MARKDOWN TEXTS

Markdown is a simple formatting language invented

by John Gruber. It lets you write articles with very

simple formatting, e.g. headlines, lists, quotes,

links, and emphasis in a very natural way using a

plain text editor and render it to visually pleasing

HTML. Write Markdown-formatted text using

DEVONthink Personal's Markdown view and switch

easily between a plain text editor and the rendered

view using View > Text/Best Alternative or the  and 

icons in the navigation bar.

Learn more about Markdown and its syntax on

Gruber's Markdown pages.

TOOLBAR & SHORTCUTS

The document windows toolbar is very similar to the

one in DEVONthink Personal main windows, yet can

be configured separately.

http://daringfireball.net/projects/markdown/
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Please find a list of shortcuts in the appendix. See

also p. 95ff

CONTEXTUAL MENU

In text mode the contextual menu commands are

similar to those of plain text documents. In rendered

mode the following commands are available:

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Copy Link: Copies a link to the Clipboard (only

available for selected links).

Look Up [word]: Looks the selected text up in Mac

OS X's Dictionary.

Open Link in Browser: Opens the selected link in

the default browser or application (only available

for a selected link).

Open Link in New Tab: Opens the selected link in a

new tab.

Search with Google: Opens your default browser

and searches for the selected text in Google.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text (needs to be less than

256 characters).

WEB PAGES, HTML PAGES, FEEDS

HTML views display web pages stored in the

database or downloaded "live" from the Internet

by using the Safari web browser engine of Mac OS

X. Pages are rendered similar to Safari or any other

WebKit-based browser such as DEVONagent Pro.

DEVONthink Personal does not display news feeds.

You can find news feeds support in DEVONthink

Pro and higher.

HTML views support the Edit > Find commands

as well as the See Also & Classify drawer. To edit

the source code of an HTML document, use the

navgiation bar to switch from preview to plain text

mode.

In editable web archives you can use, e.g., the

highlighting commands from the Format menu or add

the Color tool to the toolbar to change text colors.

Editable web archives share many similarities with

formatted notes.

TOOLBAR & SHORTCUTS

Separate HTML or web browser windows feature

a default toolbar set that is more web-like than

text document windows. As with text document

windows, this toolbar can be configured individually.

Naturally, the DEVONthink Personal offers only

tools for HTML views that are useful in a web

environment.

Please find a list of shortcuts in the appendix.. See

also p. 95ff

CONTEXTUAL MENU

Add Link: Allows you to enter a URL and makes the

selected text a link to it.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Back / Forward: Navigates back and forth to

previously visited pages.

Capture Frame: Captures the current frame in the

selected format to either the current group or to

the inbox.

Capture Image: Captures the selected image and

saves it to either the current group or to the

inbox.

Capture Link: Captures the selected link as

bookmark to either the current group or to the

inbox.

Capture Page: Captures the current page in the

selected format to either the current group or to

the inbox.

Capture Rich Text: Captures selected text to

either the current group or to the inbox.

Copy Frame Address: Copies the frame URL to the

Clipboard.

Copy Image Address: Copies the URL of an image

to the Clipboard.

Copy Image: Copies the image to the Clipboard.

Copy Page Address: Copies the page URL to the

Clipboard.
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Copy: Copies selected text to the Clipboard.

Highlight: Highlights the selection in a web

archive. Using this command on a selection again

removes the highlighting.

Look up ...: Shows a definition, e.g. from OS X's

Dictionary, for the selected text.

Open ... in New Tab: Opens selected element in a

new tab.

Open Image in PhotoStickies: Opens the image in

PhotoStickies.

Open Link in Browser: Opens a link in your default

web browser.

Open Link in DEVONagent: Opens a link in

DEVONagent Pro.

Open Link in PhotoStickies: Opens a link in

PhotoStickies.

Reload: Reloads the page from the Internet.

Search Selected Phrase: Searches for the selected

text as a phrase.

Search With Google: Searches for the selected

text in Google.

Search with Spotlight: Searches for the selected

text with Spotlight.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set As Thumbnail: Set the document's icon to the

selected image.

Set Name As: Sets the name of the document to

the selected piece of text (needs to be less than

256 characters).

Share: Shared selected text via the available OS X

sharing extensions (OS X Mountain Lion or later).

Update Bookmark: Updates the URL of this

document to the current one, e.g., after

navigating to a sub-page.

Update Captured Archive: Updates the contents

of a web archive file with the live version on the

Internet (only available in web archives).

For PDF pages more options become available:

Automatically Resize: When checked, the zoom

factor adjusts to the width resp. height of the

browser window.

Next Page, Previous Page: Skims through the

pages forward or backward.

Open with Preview: Opens the PDF in Preview.

Single Page, ...: Displays the PDF as single or

double pages and either page-by-page (use the

Next Page and Previous Page to skim through the

pages forward and backwards) or continously.

Zoom Out, Zoom In, Actual Size: Zooms in or out

of the document, or displays it in its actual size.

For HTML 5 videos the following additional options

are available:

Copy Video Address: Copies the video's URL to

the clipboard.

Mute: Mute or unmutes the video.

Open Video In Tab: Opens the video in a new tab.

Play/Pause: Plays or pauses the video.

Show/Hide Controls: Shows or hides the video

controls.

IMAGES AND VIDEOS

DEVONthink Personal uses Mac OS X's core

technologies to display images and videos;

therefore, it makes a very nice image and movie

viewer.

You can scroll larger images using the scroll bars,

the arrow keys, Page Down and Page Up, as well as

the Space and Shift-Space keys. The navigation bar

shows the current play time, clicking the navigation

bar let's you enter a time and jump to that mark.

EDIT PANEL

Double-clicking an imported image opens an edit

panel that allows you to do some basic image

editing. The modified image is saved as losslessly

encoded TIFF file.

Change the exposure.

Set white and black point.

Change gamma, saturation, contrast, and

brightness.

Adjust sharpness.

Adjust sepia effect.

In addition, the panel offers a number of predefined

image effects and lists available metadata contained

in the image file itself.
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Images (and PDF pages) can also be rotated using

the Edit > Rotate menu commands, the toolbar, or

the contextual menu.

TOOLBAR

For images and videos, DEVONthink Personal

provides a set of tools that allows you to zoom the

picture to whatever zoom factor you like, or to view

the image in full screen mode. Use Open Externally to

open the image in an external editor. Videos appear

with the standard QuickTime controller.

Note: Editing an image stored internally in the

database with an external editor does not modify

the image data stored in DEVONthink Personal.

CONTEXTUAL MENU

Actual Size: Zooms the image so that it appears

at its real size, calculated from the actual pixels

and the resolution information contained in the

image.

All Pixels: Zooms the image so that one image pixel

equals one pixel on the screen.

Copy Frame Link: Copies a URL linking to the

actual frame of the displayed video.

Copy Image: Copies the current video frame as an

image.

Cut/Copy/Paste: Cuts, copies or pastes the

selected image or video.

Edit: Opens the Edit panel.

Play/Stop: Starts playing the video or stops playing

it.

Rotate Left/Right: Rotate the image left and right.

The image is saved in the lossless TIFF format.

Select/Deselect All: Selects or deselects the video.

Set As Thumbnail: Makes the current frame the

thumbnail of the video (only available when the

video is not playing).

Undo/Redo: Revokes the last action or redoes it.

Zoom In/Out: Zooms in and out of the picture.

Zoom To Fit: Zooms the image so that it fits into

the view/edit pane or the document window.

Zoom To Width: Zooms the image so that it

appears exactly as wide as the view/edit pane or

the document window.

PDFS

PDF views are similar to image views, but come with

specialized options for viewing PDF documents.

Also, PDF views support the Edit > Find commands.

SIDEBAR

The sidebar shows thumbnails of the pages within

the PDF document. Click a thumbnail, select that

page, and scroll to it; hold the ⇧ or ⌘ keys to select

multiple pages. Reorder pages by dragging a page

to the new position and use Edit > Delete Selected

Page(s) to remove the selected page(s). Use Edit

> Rotate to rotate PDF pages. Contextual menu

commands, e.g., copy and paste, are available, too.

You show and hide the PDF sidebar using the Show/

Hide Sidebar button in the PDF''s navigation bar.

Note: Only real PDF documents are editable;

converted (e.g. EPS, PostScript, or Adobe

Illustrator files), Skim documents (PDF packages),

and PDF previews generated by QuickLook are

not editable.

ANNOTATING PDFS

You can use DEVONthink Personal to annotate

PDF documents. To add or edit annotations, open

the PDF document in a separate window (e.g., by

double-clicking it). You will find all necessary tools in

the toolbar:

Tool: Switch between moving, selecting text, and

selecting elements such as annotation post-it

notes.

Annotate: Select your annotation tool of choice:

ellipsis, rectangle, post-it note, text rectangle,

line, arrow, and link.

To add an annotation, select your annotation tool,

then "draw" it into the page. Double-click the

annotation to open the annotation panel which lets

you fine-tune your annotation. Depending on the

type of annotation, you can change its attributes.

Change the text color in the annotation panel; use

the standard Fonts panel to change the font of a

selected text annotation. Drop other documents,

files from the Finder, or URLs into the URL field to

insert cross-links, paths, or URLs.
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To move or delete an annotation, select it with the

"select elements" tool. Position it with the mouse.

Press the Delete key or use Edit > Delete to remove it.

TOOLBAR & SHORTCUTS

Annotate: Provides annotation tools. See also p.

64ff

Tool: Selects the editing mode. See also p. 64ff

Delete Pages: Deletes the selected pages of a PDF

document.

OCR: Converts the document to a searchable PDF.

Please find a list of shortcuts in the appendix. See

also p. 95ff

CONTEXTUAL MENU

Actual Size: Zooms the image so that it appears at

its real size, calculated from the actual pixels and

the resolution information contained in the PDF.

Add tag [word]: Tags the document with the

selected word (only available if the word is not

already a tag of the document).

Auto Size: Resizes the PDF automatically so that

it always fits the size of the view/edit pane or the

document window.

Continuous Scoll: When checked, DEVONthink

Personal displays the pages of a mutli-page PDF

like one long scroll. If unchecked, it displays the

PDF page by page.

Copy Page Link: Copies a URL to the clipboard

pointing directly to the shown page of the

document.

Delete Annotation: Deletes the selected

annotations.

Highlight: Highlights the selection. Using this

command on a selection again removes the

highlighting.

Link To: Marks the selected text as link and links

it to the item chosen in the sub-menu. This saves

you from having to create a link annotation first

and then select the target in another step.

Open Link in New Tab: Opens the selected link in a

new tab.

Open Link: Opens the selected link.

Previous/Next Page: Jumps to the previous or

next page.

Rotate Left/Right: Rotate the page left and right.

Search selected phrase: Searches for the selected

text as a phrase.

See [word]: Opens a drawer with documents

related to the selected word.

See Related Text: Opens a drawer with documents

related to the selected text passage (only

available when more than one word is selected).

Set Name As: Renames the document according to

the selected piece of text.

Share: Shared selected text via the available OS X

sharing extensions (OS X Mountain Lion or later)..

Single Page/Two Pages: Displays the PDF either as

one page or as facing pages (like in a magazine).

Zoom In/Out: Zooms in and out of the PDF.

The PDF sidebar also offers commands for working

with single pages:

Copy Page Link: Copies a URL that points directly

to the selected page.

Copy Page Link: Copies a URL to the clipboard,

pointing not only to the document itself but the

actual page.

Cut/Copy/Paste: Cuts, copies, or pastes a PDF

page.

Delete Selected Page: Deletes the selected page.

Insert Blank Page: Inserts a blank page into the

PDF.

Rotate Left/Right: Rotate a selected page left and

right.

Select/Deselect All: Selects or deselects all pages.

Split Document: Splits the PDF at the selection

into two documents.

Undo/Redo: Undo or redo the last action.

OFFICE DOCUMENTS, EMAIL, AND
OTHERS

Documents that DEVONthink Personal cannot

render natively are displayed using QuickLook. But

while you have to press the Space bar in the Finder

to open a QuickLook head-up display, DEVONthink

Personal previews these documents directly in the

view/edit pane like any other document format.

Among others, the following document types are

shown though QuickLook:

iWork documents (Pages, Numbers, Keynote)

Microsoft Office and OpenOffice documents

http://www.apple.com/iwork/
http://www.microsoft.com/mac/
http://www.openoffice.org
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Mellel files (version 2.6 and higher)

...

For some document formats the preview allows you

to select and copy text, for other formats it doesn't.

If DEVONthink Personal is able to interpret and

convert the document format, you can use the Text

View/Preview button in the navigation bar to switch

to a text view that allows you to select, copy, and

drag text.

Note: The availability and quality of the preview,

as well as the possibility to select and copy

text, depends solely on the source application.

Developers can embed a QuickLook-compatible

preview diectly into the files, or write a preview

plugin and add it to either the source application,

or have you install it separately in ~/Library/

QuickLook. If a document that you want to

view in DEVONthink Personal does not show a

QuickLook preview, please contact the maker

of the source application and ask them to add

QuickLook support.

TOOLBAR

For document previews based on QuickLook,

DEVONthink Personal offers a number of toolbar

items, e.g., for moving back and forth through the

other documents contained in the same group or

opening the document in its source application.

Use Data > Open to open the document in a

separate document window instead of in its source

application.

http://www.mellel.com
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DRAWERS & SHEETS

In this chapter:

See Also & Classify 67

Smart group editor 68

DEVONthink Personal uses drawers to display the

results of the Classify and See Also functions that

help you file items and find relationships between

items in the database. The Smart Group Editor,

which appears in a sheet, allows you to create or

modify a smart group (a.k.a. "saved search").

SEE ALSO & CLASSIFY

The See Also & Classify drawer appears when you

select one (1) document in a main window and then

click the AI button (a small sorcerer's hat) in the

navigation bar at the top of the view/edit pane. This

button is only available in views that have a view/

edit pane.

It is also shown when you use the contextual menu

on selected text to show similar documents, e.g.,

See [word]' or See related text, or when you select a

topic from the topics pop-up menu in the document's

navigation bar.

To close the drawer, click the red close button.

When activated, DEVONthink Personal analyzes

the contents of the selected document and

compares it to all data stored in the database. From

this "knowledge," DEVONthink Personal gives you

one or both of the following lists.

CLASSIFY

The Classify function helps you file documents by

making suggestions based on where you have filed

other documents. The Classify list shows which

groups the selected document would fit into best.

It also lists the location of the group and a graphical

score that shows how sure DEVONthink Personal

is about the suggested placement. The tooltip for

any entry in the list shows the full title and location

for it. This part is only visible when the sorcerer's hat

button is used.

To move the document to one of the suggested

groups, select the group and click Move To.

Alternatively double-click the group. For your

convenience, DEVONthink Personal preselects a

single group, or multiple groups if it is unsure. Drag

the file into any item list to move it, e.g., into a main

window. Use the ⇧ and ⌘ keys to select more than

one target. This generates replicants.

Note: Any replicants of the document being

moved are deleted. The document is only

placed in the new locations, which allows you to

precisely classify the document again without

having to manually clean up old replicants.

SEE ALSO

See Also lists similar documents; thus, it helps

you find information likely dealing with the same

subject. The see-also list shows documents and/

or selected text or topics within documents that

are similar to the selected one (when you have

used the contextual menu items or the document's

topics pop-up menu). Like the classify list, this list

shows the path to the document and a graphical

score of how sure DEVONthink Personal is about its

decision. The tooltip for any entry in the list shows

the full title and location for it.

To display a document in the drawer, select it. For

your convenience, DEVONthink Personal always

lists the original document at the top of the list. This

way you can easily go back to the original document.

Double-click a document in the drawer to open it in

a separate window; drag it into an item list to move

it.
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CONTEXTUAL MENU

Use the contextual menu on groups in the See Also

& Classify drawer for more commands.

Open: Opens the selected item in a separate main

window.

Open in Tabs: Opens the selected item in a new

tab.

Open With: Opens the selected item in an external

application.

Launch URL: Opens the URL in the selected item's

URL field.

Copy URL: Copies the Internet location stored

in the URL field of the selected item to the

clipboard.

Reveal: Shows and selects the selected item.

Show in Finder: Shows the selected item in the

Finder.

Move To: Moves the selected item to the group

you select from the sub-menu.

Replicate To: Replicates the selected item to the

group you select from the sub-menu.

Duplicate To: Duplicates the selected item to the

group you select from the sub-menu.

Label: Changes the label of the selected item.

Mark: Changes the check, lock, and read status of

the selected item.

Move All Instances To Trash: Moves all instances

of the selected item to the trash, including all

replicants (if any).

Group: Creates a new group containing the

selected item(s). Appears as Tag if the new group

would be created in the Tags group.

SMART GROUP EDITOR

The Smart Group Editor appears as a sheet when

you either create a new smart group using Data >

New > Smart Group, when you right-click a smart

group and choose Edit from the contextual menu, or

when you double-click a smart group.

In this sheet you set up a new smart group or edit an

existing one:

Search in: Select where you want this smart group

to search.

List of search predicates: Build your list of search

criteria (in search speak: "predicates") here. See

below.

Ignore Diacritics: Check this to treat letters with

diacritics, e.g., umlauts or accented characters,

the same as their regular counterparts.

Fuzzy: Check this to search "unsharp" terms,

e.g., ignoring simple typos so that instances of

"Merkel" and "Merkle" are both found.

The list of predicates consists of a list of blocks,

each beginning with "All" or "Any", defining whether

all (Boolean AND) or any (Boolean OR) of the

contained predicates need to be true for the

document to be returned as a result. Predicates

themselves consist of the field to search (like

"Content" or "Tag"), and the condition and the data

that needs to be matched.

Note: In most predicates you can use wildcards,

Boolean operators, phrases, and parenthesis, too.

See also p. 102ff

Use the + and - buttons to add more predicates

to your smart group or to delete them. Hold the

⌥ modifier key and click a ... button to create

a "compound predicate," also called "branch".

Predicates can be in/outdented and rearranged via

drag-and-drop.

By adding more lines to a search and choosing

between "All" and "Any" you graphically create

a nested Boolean query with ANDs, ORs, and

parenthesis.

Example: To find all Microsoft Excel files use the

condition Filename ... ends in ... xslx. To find items

created in the last 7 days use the condition Date

created ... is ... Last Week.

PREDEFINED SMART GROUPS

When you create a new database, DEVONthink

Personal adds a number of predefined smart groups

for your convenience:

All Images: Shows all images.

All PDF Documents: Shows all PDF documents.

Duplicates: Lists all duplicates.

Recently Added: Lists all documents added this

week.
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To Do: Shows all documents with visible but

unchecked state.

Note: Smart groups also filtering for date ranges

are shown with a clock icon.
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PREFERENCES

In this chapter:

General 70

Editing 71

Import 72

Sorter 72

Media 73

Colors 73

Web 73

Sync 74

Backup 76

Update 76

The Preferences window, which you open by

selecting Preferences in the application menu,

is the place to go to change global settings for

DEVONthink Personal. In addition to global

settings, databases also have separate settings in

their Database Properties window that you open

using File > Database Properties.

There is also a number of hidden preferences,

intended for customer support, but maybe useful

for you, too. See also p. 106ff

GENERAL

Use the General tab to set the general settings for

the user interface.

APPEARANCE

These options define some parts of the visual

appearance.

Alternating row colors in views: Check to color

every second row in item lists differently.

Display number of items inside groups: Check to

show the number of unread and read documents

contained in a group. Number will appear in

parenthesis after group names. If this option is

unchecked, news feed still show the number of

unread items.

Highlight Internet links in views: Check to show

link documents marked in blue and underlined in

item lists.

Mark duplicates and replicants in color: Check to

highlight duplicates marked in blue and replicants

marked in red in most views. When unchecked

duplicates and replicants are marked with file

property icons.

LABELS

Choose how you would like labels to be shown in

lists.

Classic: Tints the group/document icon (like on

Mac OS 9).

Modern: Puts the group/document name in a

colored bubble (like on older versions of OS X).

Dots: Shows a colored dot in the list (like on OS X

Mavericks).

INTERFACE

These options define some parts of how you interact

with the user interface.

Hide 'Groups & Tags' panel when inactive: Check

to hide the Groups panel in applications other

than DEVONthink Personal.

Open contents after using 'New with Clipboard':

Check to let DEVONthink Personal switch to

newly added items after adding them using Data >

New > With Clipboard or via the Dock menu.

Always open groups in a new window: When

checked, double-click a group to open it in a

separate window. When unchecked, double-click

the group to make it the new root of the current

window. Use Go > Top Group and Go > Enclosing

Group to go up the groups hierarchy again.

Retain view: When the above option, Always

open groups in a new window, is unchecked, the

actual view settings are maintained when you

navigate the group structure instead of the

group's individual settings being applied.
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Enable tabbed browsing: When checked, click

with ⌘ pressed a link in web, PDF or text views

to open it in a new tab. When unchecked or the ⌘
modifier key isn't pressed, documents are opened

in the same view, in the default application or in

new windows.

FONTS

Use List Views Font and Column View Font to set the

font DEVONthink Personal uses for displaying item

lists in list and column views.

Note: Hold the ⌥Option key to restore the

default fonts.

EDITING

The Editing tab defines all options that fine tune

DEVONthink Personal's text editing behavior,

from the ruler units to WikiLink templates to

summarization options.

GENERAL

Display PDF attachments of rich texts: Show the

content of PDFs attached to RTF documents.

Check spelling while typing: Spell check

everything you write all the time.

Check grammar with spelling: Check the grammar

when checking the spelling.

Correct spelling automatically: Correct misspelled

words automatically.

Smart quotes: Use curly quotes instead of simple

English ones.

Smart copy/paste: Insert or remove spaces before

and after cut or pasted text.

Smart links: Detect web addresses and turn them

into clickable links automatically.

Smart dashes: Convert characters, e.g., two

hyphens into a proper dash.

Data detectors: Detect dates, times or addresses

in text, and show possible actions when the

mouse cursor moves over them (Mac OS X 10.6

or later).

Text replacement: Use the system-wide text

replacements when editing text (Mac OS X 10.6

or later).

AUTHOR, RULER UNITS AND FONTS

Author: Enter your name. It will be used as default

for metadata, e.g. for new rich text documents or

PDF annotations.

Ruler Units: Select your personal preference for

ruler units such as centimeters or inches, points

or picas.

Plain/Rich Text Font: Select your preferred fonts

for new plain or rich text documents. Note: By

their nature, plain text documents are always

displayed in the font selected, whereas rich text

documents can be styled any way the author

wants.

FULL SCREEN

Full Screen: Select your preferred font for reading

and editing plain text files in full screen mode.

By their nature, rich text documents are always

displayed using their own styles also in full screen

mode.

Background: Choose a background color for the

full screen mode. This setting only affects the

background of plain text files and the border

to the left and right of rich text documents. By

their nature, rich text documents bring their own

background color and so don't use the color you

set here.

Text: Choose a text color for the full screen mode.

Width: Choose a width for displaying documents

in full screen mode as a percentage of the screen

width. Use this setting if the presentation in full

screen mode appears too wide on a large screen.

WIKILINKS

WikiLinks: Check Automatic if you want to

make every word that is also the name of

another document or group in the database

automatically link to the document of the

same name (WikiLink). This mechanism can be

restricted to not link to groups, as well as to only

accept meshed words. (For example, words with

a capital letter in the middle like "QuickTime";

this is the classic WikiLink method to distinguish

between regular words and links.) Check Open

new documents in separate windows to open a new
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window when you click a WikiLink, instead of

switching to the linked document.

Template: Enter a template text here. This will

be used to create a new document when you

make text a link that does not point to an existing

document yet. You can use various placeholders

to automatically insert text--the current date and

time, for example.

SUMMARIZATION

Select whether you wish DEVONthink Personal to

calculate summaries from sentences or from whole

paragraphs.

IMPORT

Here you decide which file types DEVONthink

Personal imports and how those files will be named

in the database.

FILES

These options define whether DEVONthink

Personal imports files of a given type when you

import folders using File > Import or via drag-and-

drop.

<type>: Select all the file types you want

DEVONthink Personal to recognize when

importing folders. DEVONthink Personal always

imports every file you import manually.

Encoding: Choose the default encoding for

plain text documents. Select Automatic to let

DEVONthink Personal choose the best encoding.

Other file types: Check to import files of a type

unknown to DEVONthink Personal. QuickLook

and Spotlight are used to access and display the

contents of the file.

TITLES

Select how you want DEVONthink Personal

to name imported documents: with file name

extensions, without file name extensions, or by

using localized display names (for example, on a

German system the "Applications" folder would

appear as "Programme").

NEW NOTES

Check Select (and display) automatically to

automatically select and display the last note you

have taken.

DESTINATION

Choose the default destination where data is stored

that's coming in from bookmarklets, DEVONagent

Pro, news feeds, (external) scripts, or services.

Select group: A group selector is shown that lets

you choose the destination. The group selector

appears as a black panel floating on top of all

other windows. It does not bring DEVONthink

Personal to the front. Use it to select the group

where you want to file the items and add tags.

Global inbox: The data is stored in the global inbox.

SORTER

The Sorter preference allows you to assign a hotkey

for capturing a selection into the inbox of the Sorter,

as well as a hotkey for taking a new note, showing

the Sorter at login, and starting or quitting the

Sorter manually. See also p. 25ff

AVAILABILITY, HOTKEYS

Check Start Sorter at login to start the Sorter

immediately after you log in. Check Visibility: Full

to make the Sorter tab fully visible, or uncheck it to

make the tab fade when the mouse pointer is moved

off it.

To change the hotkeys for taking a new note or

copying a selection, click the Click to record shortcut

button, then press the hotkey that you want to

use. Press the Escape key to cancel recording a new

shortcut. When the Sorter is not running, this hot

key opens the Take Note panel.

HIDER SORTER IN FULL SCREEN

This lists shows all full screen applications that

Sorter is tracking. Add other applications using the

+ button, and check or uncheck applications to hide

Sorter when the application is going to full screen

mode.
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Reset the full screen settings to make DEVONthink

Personal "forget" all remembered applications.

Click Start or Quit to start or quit the Sorter

manually.

MEDIA

In the media preferences, you tell DEVONthink

Personal how to handle multimledia files, images,

PDFs and other documents for which DEVONthink

Personal can create thumbnails.

The following options are available:

Movies: Check Create thumbnails if you want

DEVONthink Personal to create thumbnails for

imported or indexed QuickTime movies. Movie

documents without thumbnails will appear with

a generic icon, while movies with thumbnails

show miniature views of their content. Check

Play automatically to play QuickTime movies

automatically when you display them, and check

Loop if you want to play the clips in a loop. You

can also choose a background color for viewing

movies.

Images: Check Create thumbnails if you want

DEVONthink Personal to create thumbnails for

imported or indexed images. Check Generate from

actual image to ignore thumbnails embedded into

the image files and let DEVONthink Personal

generate the thumbnails from the actual image.

Choose a background for viewing images using

the standard Mac OS X color chooser, and choose

a default zoom factor.

PDF & PostScript documents: Check Create

thumbnails if you want DEVONthink Personal to

create thumbnails for imported or indexed PDF

and PostScript files. Choose the default display

mode for windowed and full screen modes and

set the background color for viewing PDFs.

Create Thumbnails: Check Web Archives,

Formatted notes, Bookmarks, or Other files if you

want DEVONthink Personal to try to create

thumbnails for these file types.

COLORS

Here you can name and choose the seven label

colors DEVONthink Personal uses to mark

documents and groups, as well as set seven colors

you can use to highlight text.

WEB

The web preferences resembles the settings of most

web browsers. Use these preferences to define how

DEVONthink Personal's displays web documents

and "live" web pages.

WEB CONTENT

These settings define how DEVONthink Personal

treats special web contents:

Enable ...: Check these options to use installed

third-party plug-ins, (such as Flash or RealPlayer

plug-ins), and to run Java applets or JavaScript

scripts contained in, or linked to, a web page.

Block ...: Check Block pop-up windows to block pop-

up windows, which are often advertisements;

check Only automatic JavaScript windows to block

only pop-up windows opened by JavaScript.

Uncheck this option if the web page you're

visiting uses pop-up windows for actual content.

(Some web content management systems do

this.) Check Block zooming to keep web sites

from automatically zooming windows to full size.

Check Block advertisement to block common inline

advertisements provided by some search engines.

Zoom text only: Check to zoom only the text and

uncheck to use Safari 4-style zooming.

IMAGES

These settings define how DEVONthink Personal

displays graphics in web pages:

Display images when the page opens: Check this

option to diplay web pages with images. Just

remember, if unchecked, you may miss some

information.

Animate images, Loop animation: Check these

options to run web graphics animations and to

run animated graphics in a loop.
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ACCEPT COOKIES

Cookies are little text files with information that

web pages store on your computer use to recognize

you as a returning customer, among other things.

While most cookies are harmless, you may want to

control what is being stored on your hard disk.

Always: Accept all cookies.

Never: Don't accept any cookies.

Only from sites you navigate to: Accept cookies,

but only from web sites you navigate to (not from

other sites, such as ad trackers).

Delete cookies on quit: Delete all stored cookies

when you quit DEVONthink Personal.

FONTS

Set the fonts you want to use for displaying web

pages; set separately for variable-width and fixed-

width text.

Note: Hold the ⌥Option key to restore the

default fonts.

STYLE SHEET

You can further control the way DEVONthink

Personal displays web pages by applying a CSS style

sheet that changes the rendering on the fly.

Click Select and choose your style sheet to apply it

to DEVONthink Personal's integrated web browser.

Note: This is for experts since it modifies how all

web pages are displayed and can lead to undesired

effects.

TEXT ENCODING

Select your desired text encoding for displaying web

pages. Automatic tries to choose the best available

encoding. If this does not work for you, choose a

more appropriate text encoding for your language

group.

SYNC

DEVONthink Personal allows you to keep multiple

copies of your database on multiple Macs in sync.

Use these options to define which locations are

synced when. Click here to learn more about

synchronization and how to set it up.

SCHEDULE

The first column at which times you want to

synchronize your database. You can choose to

synchronize it:

Manually

Hourly

Daily

Weekly

After opening a database

Before closing a database

For Hourly select the minute of the hour, for Daily

the time, and for Weekly the time and the day of

the week, all Weekdays or the Weekends. Below the

options, DEVONthink Personal shows you when the

database will be next synchronized according to the

chosen schedule.
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LOCATIONS

The second column lists all locations you have

defined. Check all locations that you want to

synchronize your database with. To add new

locations, click the + button below the list and

choose the desired location type from the pop-

up menu. Remove a location by selecting it and

clicking the - button. Use the gear button to modify

an already added location or to clear an existing

location (remove all data in the location). Click the

Sync or Sync Now button to begin synchronizing the

database.

ALLOW ACCESS TO FOLDERS

If you obtained DEVONthink Personal from the App

Store and you want to synchronize indexed items

you have to explicitly give the application access

to external folders holding the indexed items. Click

the Allow Access To Folders button to show a sheet.

Then use the + and - buttons to add and remove

external folders to which DEVONthink Personal's

synchronization shall have access.

INCOMING CONNECTIONS

Click the button Incoming Connections to define

whether other DEVONthink users on your network

can synchronize with your instance of DEVONthink

Personal. In the dialog sheet that appears, check

Allow other computers on the network to sync with my

databases to allow other users access. Enter a port

number on which DEVONthink Personal listens

for incoming connections. If the suggested port

number is already in use, you can choose any other

port number. (Contact your system administrator if

you're unsure.)

The list of authorized clients lists all computers

that have synchronized with your instance of

DEVONthink Personal before. If another user

wants to connect to your machine, DEVONthink

Personal will generate a random PIN on your

screen that the user has to enter on his/her screen.

This ensures that only persons authorized by

you can synchronize with your database. Select a

listed client and click the - button to withdraw the

authorization.

IMPORT DATABASE

Use the Sync with Database button to retrieve a

database from a location. Make sure to add the

location that contains the database in question.

Then click this button, choose the location in

the sheet that appears, and click Next. Select the

database you want to import and click Merge.
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BACKUP

DEVONthink Personal comes with a simple backup

function that backs up the database index on a

regular bases. These options define how often

DEVONthink Personal will back up indexes.

The backup automatically duplicates all important

database files and moves the duplicates into

a folder(s) named "Backup(.x)" within the

DEVONthink Personal database folder/package.

Select how often you want to have the backup

created--never, daily, weekly, or monthly--and how

many copies of the index your want DEVONthink

Personal to keep. Of course, you can create a

backup at any time using Tools > Backup & Optimize.

These options do NOT backup the whole database

to a secure location; they simply make sure there's

a copy of the index files in case the index get

corrupted. To back up your complete database, use

Time Machine or a third-party backup software.

UPDATE

Change the settings in this tab to define when

you want DEVONthink Personal to check for new

versions: never, on startup, daily, weekly, or monthly.

DEVONthink Personal only performs checks for

updates when the computer is connected to the

Internet.

Click Check Now to immediately check for a new

version.

Note: Disable the check for new versions

when your network connection is unstable

and you experience long delays when opening

DEVONthink Personal. The Update pane is not

available if you have purchased DEVONthink

Personal from the Mac App Store.
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SCRIPTS

In this chapter:

Droplets, folder actions, mail rules, PDF

Services 77

Unlike DEVONthink Pro, DEVONthink Personal

does not come with AppleScript abilities.

To conveniently "print" and save documents as PDFs

to your DEVONthink Personal database, simply add

an alias to the DEVONthink Personal application

to the directory "~/Library/PDF Services". This

does not give you the option to choose the name

of the "printed" file, or the destination group, but

creates a PDF of the "printed" document and adds

this to DEVONthink Personal. For full PDF Services

and AppleScript support, please have a look at

DEVONthink Pro.

DROPLETS, FOLDER ACTIONS,
MAIL RULES, PDF SERVICES

PDF SERVICES

Using PDF Services, you can add your own actions

to the PDF button of the print dialog windows in any

Mac OS X application. DEVONthink Personal adds

an alias of itself to the PDF Services folder.

Installation: To install the PDF Services alias select

DEVONthink Personal > Install Add-ons and check PDF

Services in the dialog window. Then click Install.

Printing to your database: To "print" (save) a

document to DEVONthink Personal as a PDF,

open it in its creator application (this could even

be DEVONthink Personal itself). Then, do the

following:

Select File & Print.

In the appearing print dialog window, click the PDF

button at the lower left corner and select Save

PDF to DEVONthink Personal (saves to the default

destination) from the pop-up menu.

Then, select the destination group for the

document, if necessary, and click OK.

Note: This requires an installed printer to work

properly.
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TROUBLESHOOTING

In this chapter:
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Problems synchronizing with DEVONthink To Go

1.x 78
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DEVONthink Personal crashes when opened 80

Recovering a lost password 80

Problems importing files 80

Problems using Services 81

DEVONthink Personal behaves irrationally 81

DEVONthink Personal was created with robustness

in mind. But any computer hardware or software,

regardless of how carefully developed and built,

can write defective data or destroy files. If you

experience problems with a database, please refer

to the methods below and also look at our FAQ.

PROBLEMS SYNCHRONIZING
DATABASES

If synchronizing databases doesn't work as

expected, please check the following list of issues:

THE SYNC PREFERENCE PANE BEHAVES

IRRATIONALLY

Close DEVONthink Personal and try again. it the

behavior persists please contact our support and

describe in detail what happened (a step-by-step

description is preferable), and what you see on

screen.

DROPBOX OR WEBDAV DON'T WORK

Please test if you can connect to Dropbox using

their website or the Dropbox app. If Dropbox is

down, only Dropbox or Amazon can resolve the

issue. If WebDAV isn't working for you, and it's

a service of your company, please contact your

system administrator. If it is a commercial WebDAV

service such as box.com, please contact our support

with a comprehensive description on how the

failure occurred.

DIRECT CONNECTIONS AREN'T WORKING

If direct connections are not working as expected or

are behaving irrationally, please check the following:

Both machines must be awake.

Both machines must be running an edition of

DEVONthink.

Host and client machines have to be on the same

subnet. Machines located on different subnets

(e.g., 192.168.0.3 and 192.168.1.47) can't talk

to each other. You can use VPN, though. Please

contact your system administrator for more

about how to get VPN to work.

The host must allow incoming connections. Open

Preferences, Sync tab, click the button Incoming

Connections, and check if Allow other computers on

the network to sync with my databases is checked.

The clients must use the correct port number set

on the host. Open Preferences, Sync tab, click the

button Incoming Connections, and check the port

number.

If it still doesn't work, please let us know and we'll

get back to you in a timely fashion.

PROBLEMS SYNCHRONIZING
WITH DEVONTHINK TO GO 1.X

If you cannot properly synchronize your database

with DEVONthink To Go 1.x on your device, please

check the following:

Are both the iOS device and the Mac properly

connected to the same Wi-Fi network?

Have you moved, replicated, or copied documents

or groups to the Sync group? Please note that

smart groups are ignored during synchronization.

Have you checked your database on the device on

the database selection screen?

http://www.devontechnologies.com/redirect.php?id=contact
http://www.devontechnologies.com/redirect.php?id=contact
http://www.devontechnologies.com/redirect.php?id=contact
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If you cannot see your Mac from your iOS device or

the connection is flaky, please try the following:

Create an ad-hoc Wi-Fi network from the Wi-Fi

icon in your Mac's menu bar.

Connect to this network from your iOS device.

Sync.

If the connection now works as expected, the

problem is related to your router, e.g., to security

measures such as packet filtering. Version 2.0 of

DEVONthink To Go will use standard data packets

that should also pass your router's security without

any problems.

If you still have problems with synchronizing, please

visit the user forum. If you don't find an answer

to your problem here, click here to contact the

DEVONtechnologies support team.

REPAIRING A DEFECTIVE
DATABASE

DEVONthink Personal databases are packages

containing of your files and the supporting AI-based

index. In rare cases this index can get corrupted or

out-of-sync. But as your files are stored separately,

this is not the end of the world. If your database

starts behaving strangely, or if DEVONthink

Personal finds inconsistencies during start-up, it is

time for some housekeeping.

STEP 1: VERIFY & REPAIR

As a first step, use Tools > Verify & Repair to check

your database's consistency and allow DEVONthink

Personal to take all necessary steps to repair any

discovered problems. If Verify & Repair was able to

repair your database, use Tools > Backup & Optimize

to optimize your database and have DEVONthink

Personal create an internal copy of the index.

If Verify & Repair was not successful or your

problems are not resolved, proceed with the next

step.

STEP 2: RESTORE FROM BACKUP

DEVONthink Personal keeps up to two copies of

the index files in case that the index is damaged

beyond repair. By changing the factory settings, you

can change when and how many internal backups

DEVONthink Personal keeps in the Preferences,

Backup tab.

To restore the index file(s) from a previously

saved internal backup, use Tools > Restore Backup

DEVONthink Personal presents you with a list of all

available backups. Choose the latest one and click

Open. This swaps the current set of index files with

the copy (the current set of index files becomes the

backup, the backup becomes the current set) so

that data is never overwritten. Run Tools > Verify &

Repair to check the consistency of this index version

and if everything is in the right order Tools > Backup

& Optimize to optimize your database and have

DEVONthink Personal create a fresh internal copy

of the good index.

If the backed-up index files are also defective, try

the other backups, if available. If all backups are

broken or corrupted, proceed with the next step.

STEP 3: REBUILD YOUR DATABASE

Since your files and DEVONthink Personal's index

are stored independently within the database folder

the index can be rebuilt at any time without you

losing too much metadata. To rebuild the database

from scratch, use Tools > Rebuild Database.

During the rebuild process, the complete index

is re-created; your actual files are not touched.

Any problems that occured during this process are

logged.

Orphaned files: Orphaned files that could not be

imported while repairing are logged and moved to

the folder "Orphans" inside the database folder.

To rescue the orphaned files, show the folder ~/

Application Support/DEVONthink 2 in the Finder

and move the files in the "Orphans" sub-folder to a

save location, e.g., the Desktop, or directly re-import

them by dragging them to DEVONthink Personal's

Dock icon.

STEP 4: TIME MACHINE OR MANUAL RESCUE

If everything above failed, your database is severely

damaged. You have two options now:

Option 1: Restore your database from yourTime

Machine backup or whichever backup medium

http://www.devontechnologies.com/redirect.html?id=forum-dttg
http://www.devontechnologies.com/redirect.html?id=contact
http://www.apple.com/macosx/what-is-macosx/time-machine.html
http://www.apple.com/macosx/what-is-macosx/time-machine.html
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you use. If you don't use Time Machine, we

strongly advise you to do so. External hard disks

are cheap, and Time Machine makes backing up

your important files quick and simple.

Option 2: If you do not have a current backup

of your documents, you can rescue your files

manually, but you will lose any group structure.

To manually copy your files from the defective

database, show the folder ~/Application Support/

DEVONthink 2 in the Finder. Copy the files in the

"Files" subfolder, which are sorted by kind, to a

save location, e.g., the Desktop. Then create a

new database, re-import the files and recreate

your group structure.

STEP 5: CONTACT SUPPORT

If none of the above steps helped solving the

problems you have with your database, please

contact DEVONtechnologies' support staff with a

precise-as-possible description of your problem.

DEVONTHINK PERSONAL
CRASHES WHEN OPENED

If a database is heavily damaged, it may be that

DEVONthink Personal crashed when starting up or

when opening the database. In this case you cannot

use the built-in mechanisms to recover your data.

But you can revert to an internal backup manually.

With its factory setting, DEVONthink Personal

keeps up to two copies of the index files in case the

index is damaged beyond repair. You can change

how many internal backups DEVONthink Personal

keeps in the Preferences, Backup tab.

To revert to one of the internal backups, quit

DEVONthink Personal, then locate the database

folder (~/Application Support/DEVONthink 2) in

the Finder. Inside you will find one or more folders

named "Backup(.x)". These folders contain copies

of the index files (named "*.dtMeta"). To manually

revert to one of the backups, copy the content of the

backup folder (all ".dtMeta" files) to the top level of

the database folder, replacing the existing, defective

files.

Once you have reverted to one of the backups, try

opening DEVONthink Personal again.

If this solution di not help, please contact

DEVONtechnologies' support staff with a precise-

as-possible description of your problem.

RECOVERING A LOST PASSWORD

If you have protected a database and you have

forgotten your password, do the following to

remove the password protection:

Close DEVONthink Personal

Locate the folder "~/Library/Application Support/

DEVONthink 2/" in the Finder and open it

Move the file "Settings.plist" to the Trash

A future version of DEVONthink Personal will

feature industry-strength encryption.

PROBLEMS IMPORTING FILES

WHY DOES DEVONTHINK PERSONAL NOT

RECOGNIZE MY FILES?

If DEVONthink Personal does not recognize a file,

make sure the file has a proper file name extension.

DEVONthink Personal needs a file name extension

to determine the file type. Add the correct file

name extension to your files (e.g., .txt for plain text

files, .rtf for rich text files, .pdf for PDFs and .doc for

Microsoft Word files) and try again.

WHY DOES DEVONTHINK PERSONAL NOT

DISPLAY MY DOCUMENT CORRECTLY?

If a document is not properly displayed--especially

if it is a proprietary file format such as RagTime

or Mellel--make sure that you either have a Quick

Look plugin installed for this file type or that the

application that created the file is installed on

your Mac (and supports Quick Look). DEVONthink

Personal will be able to display the document if

you can display the file also, e.g., in the Finder by

pressing the Space bar.

http://www.devontechnologies.com/redirect.php?id=contact
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=contact
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WHY DO SOME PDFS APPEAR AS IMAGES AND

ARE NOT SEARCHABLE?

DEVONthink Personal cannot extract the text part

of print- or edit-protected PDFs. When you import

PDFs, you get a log entry that tells you that the file

contains "no text". When you select these PDFs

in DEVONthink Personal, the status bar shows

"image" instead of "PDF+text". A cheap solution

for this problem is Michele Balistreri's PDFKey. It

allows you to print protected PDFs. Use PDFKey

to "print" a PDF file into a new PDF that is both

printable and editable, which allows DEVONthink

Personal to extract the text for searching and

classifying.

PROBLEMS USING SERVICES

WHY DO THE SERVICES MENU COMMANDS

SHOW NO SHORTCUTS?

They should; however, the keyboard shortcuts for

Services menu commands are only requested by

the supplying application. Mac OS X assigns these

shortcuts and has ultimate control over which

application or service gets what. If the DEVONthink

Personal Services menu items do not have shortcuts

assigned, it is likely that Mac OS X assigned these

shortcuts to another Services command, or that

they are used by the current active application.

You can manage your Services in System Preferences

> Keyboard > Keyboard Shortcuts > Services.

WHY DO THE SERVICES NOT WORK IN

FIREFOX?

Services work only in Mac OS X applications based

on the so-called Cocoa framework. Examples for

Cocoa applications are Mail, Safari, TextEdit, etc.,

and, of course, all DEVONtechnologies applications.

However, Firefox is a port of a Unix application

not completely based on Cocoa. Therefore, it does

not support Services. Try using Camino instead--a

Cocoa browser based on the Firefox engine.

DEVONTHINK PERSONAL
BEHAVES IRRATIONALLY

No software on this planet is bug-free, and if an

application behaves irrational there is a good chance

that your have just found a bug. But there could also

be another cause: The application package could

have become damaged during an update or through

a bug in a totally unrelated piece of software on

your computer.

STRANGE APPLICATION BEHAVIOR

If something happens like

menus disappearing or silently refusing to do

anything,

windows showing graphical artefacts,

or applications not opening at all or opening with

strange error messages,

please try to trash the application package. Then

empty your web brower's cache, download the

software again, and re-install it. In many cases this

cures the problem.

If this does not help, try deleting DEVONthink

Personal's preferences files located in "~/Library/

Preferences" and starting with "com.devon-

technologies.think".

STRANGE BEHAVIOR RELATED TO DOCUMENTS

If the strange behavior only happens with a

particular document, it is likely that the document

is damaged, was created in a very old or extremely

new file format that is no longer or not yet properly

supported, or uses a damaged or malfunctioning

Quick Look plugin.

Please file a support ticket and attach the document

in question, packaged as a .zip archive, so that we

check to see if the problem lies with DEVONthink

Personal or if it the file itself.

STRANGE BEHAVIOR OF TABS

With Zooom/2 installed, tabs in tabbed windows

behave stragely, e.g., close when cursor hovers over

the tab. Another effect of Zooom/2 are scrolling

problems in programs such as iTunes. Disabling

Zooom/2 solves the problem.

http://pdfkey.com/
http://www.caminobrowser.org/
http://www.devontechnologies.com/redirect.html?id=osticket
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FAQ
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Do you have questions regarding our licensing

policy, our products in the Mac App Store, or

specific questions about DEVONthink Personal?

GENERAL QUESTIONS

Do you have any job opportunities? Yes, we may. Please visit our Work @ DEVONtechnologies page for more

information about current open jobs at DEVONtechnologies.

Can I be a beta tester? Maybe. Our beta tester selection process is very deliberate; we try and select our beta

testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can

provide us with feedback quickly and clearly, who use different hardware and software from our other testers,

and who are willing to send us their personal data if it's needed for debugging.

If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask

active participants on the user forums if they can help us test particular features and new products. You can, of

course, simply contact us.

Is the documentation available in my language? The online and PDF documentation is only available in English

at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is cost-

intensive and error-prone so that we have decided to concentrate our resources on developing stable, robust,

and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the

necessary resources.

Where does the name DEVONtechnologies come from? "Devonian (after Devon County, England), the

geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians

appeared on the land, that until then was only inhabited by trees and other plants -- it was the departure into a

new age." Named after the Devonian period, the DEVONtechnology marks the departure into a new age of data

processing.

Note: Ray Troll has even created songs and other art about this extremely important evolution step.

RELEASE SCHEDULES, MAC OS X, AND WINDOWS

When is the next release coming We try not to announce precise timelines or feature lists for future releases,

as we are a small software company with limited development resources; if one of us should happen to get

the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our

intended development schedules.

In planning releases, we try to strike a balance among:

responding to customer requests,

http://www.devontechnologies.com/redirect.html?id=jobs
http://www.devontechnologies.com/redirect.html?id=contact
http://www.trollart.com/
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the needs of our partners,

supporting new operating systems features,

providing consistent features across the product line,

working efficiently within the structure of the code, (similar features often get handled at the same time),

various business needs.

We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's

often impossible to predict the final release date accurately when we start new projects. We try to plan our

releases with a long term perspective so that they ultimately serve the needs of our customers, even if they

don't necessarily get in everyone's favorite feature request every time.

Why are your applications not compatible with my pre-release version of Mac OS X? In the past, we've noted

that compatibility issues with a new major release of the operating system are usually resolved by Apple in the

final stages before its release, and don't require any action on our part. If you are already using a pre-release

version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches

the release candidate status. We will then make all necessary adjustments for making our apps run on the first

official release of the new version of Mac OS X.

Any chance of a Windows versions of your products? We're very commited to Mac OS X and the superior

Cocoa environment. For most of our applications, porting them to Windows would take longer than it would

to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our

products consider running Windows on a Mac.

PURCHASING

Note: If you purchased or plan to purchase DEVONthink Personal in the Mac App Store please click here to

learn more about the differences between our shop and the Mac App Store.

How do I purchase an upgrade? Please use DEVONthink Personal > Check Upgrade Options to find out what

you need to upgrade and how much the upgrade is for you. If this option is not available in your copy of

DEVONthink Personal this application might not be upgradable. Please visit the Upgrade Assistant on our web

site instead.

What is your policy on software updates? Usually, all minor updates ('dot updates', such as version 1.2 to 1.3)

to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We

charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop

within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on

our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store

click here.

Can I get the bundle discount also later? Bundles are cheaper than multiple single licenses because a bundle

means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please

contact our sales staff if you purchased one of the bundled produts within the last two weeks.

Do you give a discount to students and educators? Yes, we give 25 percent off the regular price of

DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give

volume discounts to institution or faculties. Please visit our Students, Educators and NPOs page.

Do you offer NPO licenses? Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of

charities. Learn more about our NPO program.

http://www.virtualbox.org
http://www.devontechnologies.com/redirect.html?id=upgrade
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=students
http://www.devontechnologies.com/redirect.html?id=students
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Can I use your software on multiple computers? Yes, our license explicitly allows one and the same person to

use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a

laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.

I have no credit card. How can I purchase your software? We are selling currently through the online sales

agent Share*It to keep our administration as lean as possible. If you don't have a credit card, you can also pay via

PayPal or by purchase order, wire transfer, or even cash. See our online shop for more details.

In addition we are also selling some of our products through the Mac App Store. Please open the App Store

application on your Mac to learn more about which payment options Apple offers.

Can I have more time for evaluating your apps? No problem. We happily give out 30 day licenses for evaluation

purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in

DEVONagent Express.

Why haven't I received my license code(s)? If you have purchased your license in our online shop and if there

have been no technical problems on our side, your license codes have been sent out to you immediately after

your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's).

Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support

Assistant to get them resent to you. If this also doesn't work, please contact us and we'll try to get your license

codes to you as quickly as possible.

Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? License codes for legacy versions are no

longer available in our shop but even the latest license codes are always backward-compatible: You can use

a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a

license for the most recent version of the product in our online shop and use it with your legacy software.

MAC APP STORE

How do apps purchased in the Mac App Store differ? The Mac App Store requires so-called "sandboxing" of all

apps. Sandboxing puts the apps into a closed environment and restricts access to e.g. files, networks, printers,

etc. Therefore many apps sold through the Mac App Store have less features than their counterparts available

outside of the Mac App Store.

Do you charge for updates in the Mac App Store? No, updates are generally free in the Mac App Store (and we

don't charge for them outside of the Mac App Store, too).

Why are updates available always later that in your shop? All apps sold through the Mac App Store

are reviewed by Apple before being released. Therefore new versions appear immediately on the

DEVONtechnologies website but have to pass Apple's review before appearing also in the Mac App Store.

Do I get a license code? Apps purchased in the Mac App Store do not come with a license code but are "signed"

directly before downloading for your iTunes account.

Do you offer bundles in the Mac App Store? No, bundles are not supported by the Mac App Store.

How can I upgrade apps purchased in the Mac App Store? By Apple's rigid rules you couldn't. Upgrades are

simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In

some of our apps there may be an upgrade option still available, though. Check the Read Me to see if this is the

case for you.

http://www.share-it.com
http://www.devontechnologies.com/redirect.html?id=shop
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=legacy
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Can I get a refund? We freely refund licenses purchased in our own shop. For apps purchased in the Mac App

Store we don't have access to the refund mechanism. Please contact Apple's Mac App Store support for a

refund.

YOUR SOFTWARE LICENSE

Why does DEVONthink Personal not accept my license code? When you enter your license code and the

'Register' button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY

as they appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code

from our email into the appropriate fields of the registration dialogue window. Also, please check if you have

obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will

not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x

license code).

I have lost my license code. How can I retrieve it? Use Help > Support Assistant to open the Support Assistant

which has an option to get your license code resent to you. Alternatively visit the support area on our web site.

Does my license code work also for an older version? Yes, it does. All our license codes are backward-

compatible to legacy versions of the same product and edition.

Why do I have to enter my license code again? You only have to re-enter your license code after a complete

reinstall of your system without a backup of your home folder or when the license code file has been

deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/

Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license

code again.

Why does my DEVONthink Personal 1.x license not work anymore? DEVONthink Personal with version

numbers greater than 1.x are paid upgrades. To use them you may need a new license code. Please use

DEVONthink Personal > Check Upgrade Options to find out what you need to upgrade and how much the upgrade

is for you.

Why does your application say that it expired? When we release a public beta of one of our applications, we

remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final

release is, of course, available when this happens.

Please simply visit our Download page, download a newer version that the one you have installed, and replace

your copy with the newer one. FPlease first move the old application to the trash, then move the new one into

its place.

Note: Your license code will, of course, NEVER expire.

PRODUCT-RELATED QUESTIONS

All frequently asked questions specific to DEVONthink Personal are located in the appendix. Please continue

reading on the following pages:

FAQ specific to DEVONthink Personal

Troubleshooting tips and tricks

http://www.devontechnologies.com/redirect.html?id=support
http://www.devontechnologies.com/redirect.html?id=download
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TECHNOLOGY
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All commercial DEVONtechnologies applications

are based on a proprietary AI technology, with

rock-solid database foundation that allow them to

manage large numbers of documents or knowledge

bits while analyzing them almost instantly at the

same time.

GENERAL CONCEPT

DEVONtechnology, on which all

DEVONtechnologies' applications are built, is a new

technology at the very beginning of its development.

DEVONtechnologies constantly improves the

technology and enhances it for more functionality,

efficiency, robustness and flexibility.

Development of the DEVONtechnology is a battle

on two main forefronts of information processing

technology. DEVONtechnologies is working hard

on unifying both the top-down and the bottom-

up AI concepts by imitating high-level functions

and simulating the basic functionality of natural

systems. This leads to highly functional, fast and

efficient AI systems that can be used in a great

variety of information processing contexts, such

as pattern recognition, signal processing and

information storage and retrieval.

FEATURES

The DEVONtechnology is a rock-solid foundation

suitable for a variety of completely independent

applications. Therefore it is ideal for the rapid

development of a huge range of new database-,

signal-processing- and language-analysis-driven

applications. The ability to deal with any kind of

digital data makes it extremely flexible.

The size of DEVONtechnology-based databases

can, depending on the type of data stored,

grow logarithmically and make indexing is

completely unnecessary. Also, applications based

on the DEVONtechnology improve themselves

continuously (the more data they handle, the better

the results), are language-independent and iron out

any irregularities by applying fuzzy logic.

STRUCTURE

The DEVONtechnology consists of a kernel and

several layers. Together they perform all the

underlying computing, from 'simple' data handling

to complex signal processing.

Kernel: The kernel is the foundation for all layers

and applications and is responsible for data

handling, semantic and associative data processing,

signal processing, fast statistic analyses and all

fuzzy algorithms. It has to be as fast, flexible, and

extensible as possible; it is 64-bit aware and uses a

generic, proprietary file format (see above) allowing

it to verify and repair low level data consistency,

featuring logarithmic growth of the database

and logarithmic speed decrease with increasing

database size. The DEVONtechnology kernel is

Unicode-aware, completely language-independent

and self-optimizing and self-organizing.

Layers: The layers form a shell around the kernel

and provide high-level functions for the applications

built on top of them. The database layer, for

example, is used to store and organize data and

supports all kinds of relations (1:n, n:1, n:n),

hierarchies and freeform databases. No indexing or

primary keys are required, strings can be unlimited

in size and it's possible at any time to extend the

range of pre-defined data types (Boolean, character,

float, double, signed, unsigned, string, date, time,
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blob, color, size, and point). Another layer, the XML

layer, makes it easy to handle XML code within the

DEVONtechnology; it has a very small overhead,

compared to DOM parsers or available XML

databases, requires no indexing and supports the

tight integration of other databases (and vice versa).

APPLICATIONS

Some of the most likely applications for the

DEVONtechnology are databases (knowledge

bases, expert systems, search engines, table-of-

content-generators, instant data-mining), intelligent

agents, encryption, compression and archiving.

Other uses for DEVONtechnology may be chat-

bots, context-sensitive help, optical character

recognition (OCR), speech analysis, recognition

and synthesis, staticstics, thesauri and automatic

translations.

In particular, applications dependant on processing

human language, either written or spoken,

benefit from the flexible technology foundation.

So, DEVONtechnologies' main focus in the

development of new applications is in these areas:

databases, 'intelligent' agents, text and speech

analysis, statistics.

Look forward to see a great range of different

applications based on the DEVONtechnology.

A few have already been announced

on the DEVONtechnologies web site:

www.devontechnologies.com.

http://www.devontechnologies.com
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Besides DEVONthink Personal,

DEVONtechnologies publishes a number of other

commercial, shareware, and freeware applications,

and services that you may be interested in.

OVERVIEW

DEVONtechnologies is focused on developing

innovative applications for finding, storing, and

organizing information. Our main objective is to

make complex yet flexible technology that is both

easy to use and lightning fast.

DEVONthink

DEVONagent

DEVONsphere

DEVONnote

All applications are based on the

DEVONtechnology, a powerful and solid core

unique to DEVONtechnologies. DEVONthink,

DEVONnote, DEVONsphere, and DEVONagent

are only the first of many more DEVONtechnology-

powered applications to come.

Also, we publish useful freeware apps and services

that help you in your everyday work with your Mac.

NEWSLETTER & USER FORUM

Would you like DEVONtechnologies to keep you

informed about updates and new product releases?

Subscribe to the newsletter.

And don't forget to have a look at our very lively

user forum, where users of all skill levels meet to

discuss our applications, talk about our technology,

and exchange tips and tricks for DEVONthink

Personal & Co.

DEVONTHINK

Organize and work with all your documents,

bookmarks, email messages, text files, images, PDFs,

in one place, regardless where they originated.

Quickly capture data without interrupting your

workflow. DEVONthink's unique AI assists you in

getting the most out of your data collection.

Learn more about DEVONthink

Learn more about DEVONthink To Go for iOS

Check your upgrade options if you want to

upgrade to a higher edition

Check your upgrade options if own DEVONnote

and want to upgrade to DEVONthink

DEVONAGENT

DEVONagent Pro helps you search more efficiently

on the web. It searches multiple sources, frees

you from hunting for the really relevant results,

and gives you power tools for your research.

DEVONagent Express and DEVONagent Lite (free)

make searching the web as easy as using Spotlight.

Search Google, Bing, YouTube, Facebook, Twitter,

even the Mac App Store, right from the menu bar.

Learn more about DEVONagent Pro

Learn more about DEVONagent Express

Learn more about DEVONagent Lite

http://www.devontechnologies.com/redirect.php?id=technology
http://www.devontechnologies.com
http://www.devontechnologies.com/redirect.php?id=forum
http://www.devontechnologies.com/redirect.php?id=product-dt
http://www.devontechnologies.com/redirect.php?id=product-dttg
x-devonthink://purchase
x-devonthink://purchase
x-devonnote//purchase
x-devonnote//purchase
http://www.devontechnologies.com/redirect.php?id=product-dapro
http://www.devontechnologies.com/redirect.php?id=product-daexpress
http://www.devontechnologies.com/redirect.php?id=product-dalite
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DEVONSPHERE

Make your Mac smarter: Let DEVONsphere Express

keep track of related emails, articles on the same

subject, and similar web pages. Discover the hidden

connection between seemingly unrelated files.

Learn more about DEVONsphere Express

DEVONNOTE

Your thoughts and ideas are valuable. DEVONnote

keeps them and provides you with unique tools and

artificial intelligence so that you can focus on things

that really matter: creating even more ideas.

Learn more about DEVONnote

Check your upgrade options if you want to

upgrade to DEVONthink

NEEDFUL THINGS

Search files on your hard disk, watch web cams,

create thumbnails, or access all your files and apps

from the menu bar. Reformat paragraphs in your

favorite word processor, do little calculations

anywhere you can type in text, or send text to your

Bluetooth-enabled mobile phone. And all this for

free.

Learn more about our freeware apps

Learn more about our freeware services

http://www.devontechnologies.com/redirect.php?id=product-dsexpress
http://www.devontechnologies.com/redirect.php?id=product-dn
x-devonnote://purchase
x-devonnote://purchase
http://www.devontechnologies.com/redirect.html?id=product-freeapps
http://www.devontechnologies.com/redirect.html?id=product-freeapps
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In the appendices you will find additional

information that helps you getting familiar with

DEVONthink Personal, such as a glossary of

commonly used terms, a listing of the Boolean

operators used in searches, and placeholders used

in templates for yet "targetless" WikiLinks.

GLOSSARY

Become familiar with these terms to get the most

out of working with DEVONthink Personal.

KEYBOARD SYMBOLS

⌘ The Command key, usually next to the Space bar.

⌥ The Option key.

⌃ The Control key (usually labeled with "ctrl").

⇧ The Shift key.

⇥ The Tab key.

↩ The Return key.

INTERFACE ELEMENTS

Contextual Menu: The menu that appears when

you right-click (or ⌃-click) something; the

contextual menu gives you access to frequently

used commands that deal directly with the

clicked object. Read more about the available

contextual menus in the Documents and

Windows chapters.

Item list: A list of items stored in the database.

Items can be documents, groups, or smart groups.

View/Edit Pane: A part of the DEVONthink

Personal main and document windows that lets

you view a document or, when possible, edit it.

The view/edit pane displays the content of your

documents depending on their type. See also p.

46ff

View (1): The layout for a DEVONthink Personal

main window. You can change the layout using

the commands found in the View menu.

View (2): The display for the various document

types inside the the view/edit pane or a document

window. See also p. 58ff

Window: DEVONthink Personal uses three

different types of windows: main, document, and

other. Main windows show lists of items and, in

some views, also the contents of the selected

document, whereas document windows show

documents separately.

DOCUMENTS & GROUPS

Database: A collection of all documents stored in

DEVONthink Personal. DEVONthink Personal

only manages one central database.

Document: A file in the database; for example,

a plain or RTF text, a PDF, or an image

(.jpg, .tiff, .png, etc.). Technically a document is

an entry in a database with text, RTF, or image

content--sometimes simply referred to as

"content".

Default Destination: The default destination

group for incoming data. In DEVONthink

Personal this is the special Inbox group.

Group: A collection of documents or other groups

inside the database. Similar to a folder in the file

system. See also p. 35ff

Inbox: A special group for data coming in to a

database.
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News Feed: A news feed is like a web page, but

split into multiple newsbits. A feed reader or web

browser can split the feed "page" into its parts

and show each of them as a separate news item

and/or store it in a local database. DEVONthink

Personal stores feeds in a database and displays

them like a group; contents are updated live

from the Internet as the connected feed changes.

Older news bits are kept, while fresh news bits

are added and marked as unread. When you add

a bookmark that points a feed to a database,

DEVONthink Personal tries to add it as a proper

feed document if possible. DEVONthink Personal

can also be defined as the system's RSS reader in

Safari's Preferences.

Replicant: A document or a group that appears

in more than one place in the database. Unlike

an alias in the file system, a replicant is not a

real document pointing to another file (usually

the original); rather it is a second entry in the

table of contents for the very same document.

Consequently, there is no original; when you

replicate a document you'll end up with two

replicants. See also p. 36ff

Smart group: Not a real group but a "saved search"

that appears like a group. Every time you visit

this smart group, DEVONthink Personal runs the

attached search and displays it as the content of

the group. Create smart groups using the search

window or the smart group editor. DEVONthink

Personal creates a number of pre-defined smart

groups when you create a new database.

Trash: Stores all trashed items until you physically

delete them using DEVONthink Personal > Empty

Trash.

TAGS

Tag: A tag is a different visual representation of

a group. All documents contained in a group

that has not been excluded from tagging, get

the group's name "attached" as a tag. Tags

represented by a regular group appear grey in all

tag lists.

Group tag: Tags represented by a regular group.

Ordinary tag: Tags created through the Tag bar

or other means are created in a special top-level

group named "Tags". They are called "ordinary

tags" and appear blue in all tag lists.

ITEM PROPERTIES

Flagged/Unflagged: Items can be checked or

unchecked for your personal use, e.g., for creating

a to-do list, maintaining a shopping list, or writing

a list of project tasks.

Locked/Unlocked: Items can be locked to keep

them from being unintentionally deleted (groups,

documents) or modified (documents).

Read/Unread: Items can be marked read

or unread, which is useful for captured or

automatically downloaded news items or

documents that you want to read later. Both

unread items and groups containing unread items

are shown in bold.

The "flagged" and "locked" properties are indicated

by icons. See also p. 94ff

FAQ (PRODUCT-SPECIFIC)

GENERAL

What is the difference between the various editions? While all three editions of DEVONthink, as well as

DEVONnote, share many features, there are some noticible differences. For instance, DEVONthink Pro is able

to deal with more than one database; features tables, forms, and categories; and comes with full AppleScript

support. DEVONthink Pro Office also comes with plugins for pro-grade email archiving, paper capture, and

Web sharing. You can find a complete listing of all differences on the feature comparison page.

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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Which languages does DEVONthink Personal support? DEVONthink Personal supports multilingual

documents and Unicode and so supports all Asian languages including Chinese, Japanese, and Korean, as well

as non-Latin scripts such as Cyrillic, Hebrew, and Arabic (including writing from right to left). Use Format >

Alignment > Writing Direction to adjust the writing direction.

Note: Asian languages, however, do not use word separators such as white space or punctuation. When

searching, you need to use wildcards. Use ~word or *word* in the search field or search window.

How do I completely uninstall DEVONthink Personal? To completely remove DEVONthink Personal from your

Mac, see the instructions in the Read Me.

DATABASES

Can I use more than one database? DEVONthink Personal stores all data in a central folder in "~/Library/

Application Support/". To use multiple databases consider upgrading to DEVONthink Pro or higher.

How are my documents stored? DEVONthink Personal stores all documents in sub-folders of '~/Library/

Application Support/DEVONthink 2' where ~ stands for your home folder.

Inside the "Files.noindex" folder the actual documents are stored in sub-folders for their respective type and

further sub-folders that help DEVONthink Personal to quickly locate them. Documents are never altered when

you copied them into the database. The file name of each document is exactly the same as the corresponding

document name that you see in DEVONthink Personal.

In addition, the database folder contains a set of ten index files named with the suffix ".dtMeta" as well as a

"Settings.plist" file containing database-specific preferences. Finally, the database folder can contain one or

multiple folders named "Backup ...". They contain backups of the index files and are created automatically by

DEVONthink Personal's backup function. They do not contain copies of all actual documents.

How can I move my database to another computer? Your database is the folder "~/Library/Application

Support/DEVONthink 2". To move it to another computer, copy it to the same location on the other computer.

Note: In general, DEVONthink Personal databases are self-contained, so one can move a database to

another computer, open it and start using it. But if some of the content has been indexed instead of imported,

it will be necessary to also move the externally linked files to the other computer. This must be done in such

a way that the Paths to the external files remain valid. If everything is in your Documents folder on the first

computer, copying the externally linked folders and files to the Documents folder of the second computer

will probably work. Always quit the DEVONthink Personal application before copying or moving a database,

as copying an open database may result in an incomplete or damaged copy.

Can I share my DEVONthink database using WebDAV or DropBox? You can, but it is definitely not

recommended as WebDAV servers do not fully support all properties of real hard disks. See below.

Can I synchronize databases between multiple computers? Yes. See also p. 21ff

SYNCHRONIZING

How many licenses do I need? Our software licenses only can be used on Macs (or user accounts) used by you.

If you are synchronizing your data between multiple work places and team members, every team member

needs her or his own license. We offer attractive volume discounts that you can find in our online shop. We do

not offer group or site licenses.

Can I use my own file server? You can create sync stores on every volume that you can mount. These can be

USB sticks, hard drives, or file servers. DEVONthink Personal can use SANs, NAS, AFP, and even SMB volumes,

as well as almost any file system.

http://www.devontechnologies.com/redirect.php?id=shop
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How can my Windows-using colleagues take part? Synchronization is designed to keep DEVONthink Personal

databases updated. To share data with people using Windows- or Linux-PCs, consider using web sharing, which

is only available in DEVONthink Pro Office.

How do I restrict access for certain user groups? To restrict access to a database, open its properties and set

a user name and password. Share these credentials only with those people who should have access to this

database. Use a separate database for each group or users that you want to keep separate from other groups.

Can I share my databases as read-only? No, synchronization is by default bi-directional. To share data read-

only on the local network, consider using web sharing, which is only available in DEVONthink Pro Office.

SCANNING & OCR

My scanner is not supported by Mac OS X. Does it support TWAIN? If your scanner does not come with an

Image-Capture-compliant scanner driver, you might want to check if it works with the TWAIN SANE bridge.

http://www.ellert.se/twain-sane/
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ICONOLOGY

Additional icons behind item names, e.g., in main

windows, indicate that the item has been indexed

instead of imported, is locked, has a comment

attached, or is scripted. Groups also serving as tags

show a tag icon. Depending on your preferences,

replicants, duplicates, or replicated duplicates are

indicated with a little grey icon instead of appearing

in color.

 Item is unread

 Item has been flagged See also p. 36ff

 Item is indexed, not imported See also p. 20ff

 Item is locked See also p. 36ff

 Item has a comment See also p. 53ff

 Group is a tag, too See also p. 96ff

 Item is a duplicate

 Item has one or more replicant(s)

 Item is a duplicate, but also has one or more

replicant(s)

KEYBOARD SHORTCUTS

Keyboard shortcuts make using DEVONthink

Personal much more efficient. Some of the following

shortcuts are common to most OS X applications;

others are only available in DEVONthink Personal.

In addition, many menu commands have keyboard

shortcuts. These are shown directly in the menu.

Note: You can change the shortcuts for menu

commands in System Preferences > Keyboard >

Keyboard Shortcuts > Application Shortcuts.

WINDOWS

Tab: Cycles focus through all entry areas and fields.

Shift-Tab: Cycles focus through all entry areas and

fields in reverse order.

Control-Tab: Cycles through all panes.

Control-Shift-Tab: Cycles through all panes in

reverse order.

Escape: Cancels processes, closes dialogs or Quick

Look previews, etc., depending on the context.

DOCUMENT LISTS

Navigating items:

Up/Down arrow: Navigates up and down in all

views. Use ⇧ to select multiple entries.

Left/Right arrow: Expands or collapses the

selected groups in Horizontal Split, Vertical Split

or List views, or navigates to previous/next item

in other views.

Option-click (the triangle in front of a group):

Expands or collapses all groups that are

containted within this group as well.

Option-Left/Right arrow: Expands or collapses

the selected groups and all their children in

Horizontal Split, Vertical Split or List views.

Selecting items:

Shift-click: Selects multiple items.

Shift-arrow: Extends the current selection.

Command-click: Adds an item to the selection.

Manipulating items:

Return: Renames documents.

Backspace: Deletes selected items.

Command-drag: Copies items to the drag

destination instead of moving it.

Command-Option-drag: Creates replicants for

the items at the drag destination. Dragging items

from the Finder to DEVONthink Personal with ⌘
and ⌥ pressed indexes the item. Dragging items

into documents with ⌘ and ⌥ held inserts a link

to the item.

Command-Option-drag: Creates bookmarks for

address cards dragged in from Contacts.

Using items:

Option-double click or Command-Shift-O: Opens

selected documents/groups in a new tab or a new

main window (depending on whether tabbed

browsing is active or not) and closes the current

window ("hoist"). Change Always open groups in a

new window in Preferences, General tab to your

personal taste.

Tab: Jumps to the first or next editable column.

Space: Opens the standard Quick Look panel

showing a preview of the selected items.

Option-Space: Opens a full screen Quick Look

slideshow.
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VIEW/EDIT PANE

Home/End: Goes to beginning of, or end of, any

view.

Page up/down: Scrolls one page up and down in

any view.

Space/Shift-Space: Scrolls one page down or up

in non-editable views, e.g., web pages, images, or

PDF documents.

Command-click: Opens the target of a link in a

new tab or separate window.

Command-Option-click (a cross-link or Wiki link):

Positions the insertion caret inside the link for

editing.

Option-click (a word): Looks for the clicked

word in the database, like the contextual menu

command See [word].

TEXT DOCUMENTS, MARKDOWN

Drag, then hold Option: Copies selected text.

Shift-arrow: Extends current selection.

Command-Option-drag: Inserts a cross-link for

groups or documents dropped into a rich text

document. Dragging files or folders from the file

system to a rich text document with ⌘ and ⌥
pressed creates links to them.

Command-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences.

Command-Shift-click: Opens a link in a new tab

and selects it (only if tabbed browsing is switched

on).

Command-Option-click (1): Places the insertion

caret inside the text of a clickable link and opens

the link in a new

Command-Option-click (2): Opens a clicked cross-

link or Wiki-style link in a separate document

window.

Option-drag: Selects text using a rectangular

selection ribbon.

Option-click (1): Lists all contents containing the

clicked word in the See Also drawer (identical to

the See [selected text] in the contextual menu).

FORMATTED NOTES

Drag, then hold Option: Copies selected text.

Shift-arrow: Extends current selection.

Command-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences.

Command-Shift-click: Opens a link in a new tab

and selects it (only if tabbed browsing is switched

on).

Command-Option-click (1): Places the insertion

caret inside the text of a clickable link.

Command-Option-click (2): Opens a clicked cross-

link or Wiki-style link in a separate document

window.

Option-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences.

HTML PAGES, WEB PAGES, FEEDS

Command-click: Opens clicked URL in the default

browser or application or in a new tab, depending

on your preferences. Equals clicking a link with

the third mouse button.

Command-Shift-click: Opens a link in a new tab

and selects it (only if tabbed browsing is switched

on).

Backspace/Shift-Backspace: Goes backwards and

forwards through the visited web pages.

SHEETS

Return: Moves one cell down for editing.

Shift-Return: Moves one cell up for editing.

Tab: Moves one cell to the right for editing.

Shift-Tab: Moves one cell to the left for editing.

Arrows: Moves the editing selection.

Escape: Stops editing.

PDFS

+: Zooms in.

-: Zooms out.

Command-drag: Scrolls the visible area with the

mouse.

IMAGES

+: Zooms in.

-: Zooms out.
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TAGGING

DEVONthink Personal supports tagging in a way

that makes groups and tags interchangeable. While

this concept may sound a bit strange at first, you will

soon discover why it is a smart way to approach tags

and group and to bring both together.

INTRODUCTION

Technically, tags and groups are identical: both

are simply entries in a table that are somehow

"attached" to an item, usually a group or document.

The difference is that tags are visualized as "labels

attached TO the item while groups are visualized as

groups CONTAINING the item." They are presented

differently, but internally they are the same.

DEVONthink Personal treats groups as tags

and tags as groups. When it shows you the tags

associated with an item, it presents you with a list of

all groups that the item is part of and that have not

been excluded from tagging.

Example: A document is located in the

group "Science > Paleontology > Dinosaurs".

Consequently, its tags are "Science,"

"Paleontology," and "Dinosaurs." Now you create

a sub-group of "Dinosaurs" named "Land-living"

and move the document into the new folder.

Automatically it is now tagged with "Science,"

"Paleontology," "Dinosaurs," and "Land-living."

The same happens when you replicate the

document into multiple groups: It is tagged with the

names of all enclosing groups (not excluded from

tagging) of all its replicants.

When you assign a tag using DEVONthink

Personal's user interface, move a document, or

replicate it to another group, this is what happens:

Assign a tag: The item is replicated to the Tags

group.

Removing a tag: The item's replicate in the Tags

group is deleted.

Adding an item to a group: The group's name and

the names of all groups containing the group

appear as tags attached to the item.

Moving an item: The new group's name and the

names of all groups containing it appear as tags

attached to the item.

Replicating an item: The new group's name and

the names of all groups containing it appear as

tags attached to the item, too.

(Auto-) Classifying an item: This places the item

into a new group and replaces all assigned tags.

Tags represented by a regular group are called

"group tags"; tags created without an existing group

are called "ordinary tags." See also p. 91ff

THE TAGS GROUP

Every DEVONthink Personal database contains a

top-level group named "Tags." It is used whenever

you add a tag to an item, e.g., through the tag bar,

for which a group does not yet exist. In this case,

DEVONthink Personal creates a group for the tag in

the Tags group and places a replicant into it.

When you rename a group here all items associated

with it, (means: that have a replicant here) this

option will show the change.

USING TAGS

To use tags for selecting and finding documents or

browsing tags, DEVONthink Personal offers the

following options:

Tags view: The tags view allows you to browse

your documents by tags. In the tags view, select

a tag to display all items which have this tag

assigned. Choose multiple tags, e.g., by clicking

anothe one with ⌘ held, which shows all items

carrying the selected tags.

Smart groups: Use smart groups to search for

items with given tags.

Wherever tags are shown, "ordinary tags" (tags

created in the special Tag group) appear blue, and

tags that are also regular groups appear grey. Tags,

in the Tag bar also show a pop-up menu when you

click their downward triangle. The menu shows

related tags that can be added to the item, and

reveals tags represented by a group.

ALIASES AND EXCLUDING FROM TAGGING

DEVONthink Personal also honors aliases added to

groups. You can add "alternative names" to a group

using Info panel and later use these alternative

names as a tag.
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Example: In the Info panel of the group

"Dinosaurs" you have added "Dinos" as an alias.

You can now tag items with "Dinos" and they

automatically will be moved or replicated to the

"Dinosaurs" group.

Groups that you don't want to use as tags can be

excluded from tagging. Select the group and open

the Info panel. Check Exclude from … Tagging and the

group's name will no longer be shown as a tag for

items contained in it.

OPENMETA

OpenMeta is an open standard for storing tags

with files in the file system. Using OpenMeta

applications can add tags to files and let other

compliant applications read them.

DEVONthink Personal supports OpenMeta when

importing and exporting files. Files stored in the

database are not tagged in OpenMeta-style, though

assigned tags will be added to the files as soon as

you export them. On OS X Mavericks, Mavericks

tags take precendence over OpenMeta tags. On

OS X Yosemite and later OpenMeta is no longer

supported.

FILE FORMATS

DEVONthink Personal supports a variety of text

and image formats, including plain text, Rich Text

Format (RTF), PDFs, all image formats supported

by by Mac OS X and QuickTime, as well as all file

formats for which a Quick Look preview is available.

TEXT FILES

DEVONthink Personal supports plain text files (as

well as Mac OS 9 SimpleText and Tex-Edit Plus files)

in all encodings supported by Mac OS X, including

Unicode and UTF-8. By default, DEVONthink

Personal automatically recognizes the encoding and

the line endings used by Mac, Windows, and Unix

operating systems.

Extensions: adb, ads, aln, ans, applescript, asciidoc,

bat, bib, bibtex, c, cls, cmd, command, con, cp, cpp,

crash, css, csv, diag, dot, em, embl, erl, err, f, f70,

f90, fasta, for, fpp, ft, gb, genbank, gff, h, haml,

hang, hlp, hpp, hs, hrl, id2xf, inc, js, lhs, lisp, log,

lst, lua, m, markdown, md, mdwn, mediawiki, mi,

mis, ml, mly, mm, mmi, mml, msf, org, p, pas, pir,

pl, pp, py, rb, rc, sass, scm, scpt, scptd, scriptSuite,

scriptTerminology, sdef, seq, sh, sqc, sql, srt, ss,

strings, sty, sw, swift, swiss, tab, tcl, tex, text,

textile, txt, v, vcf, wrl, x, xchatlog, xd, ychat

HFS type codes: TEXT, ttro, TERO, sEXT,

SimpleText, scpt, osas, APPL (AppleScripts

wrapped in an executable application)

Automatic recognition: DEVONthink Personal

also recognizes plain text file formats defined by

third-party applications.

Rich Text Format: For Rich Text Format (RTF) files,

DEVONthink Personal recognizes Mac, Windows,

and ANSI encodings as well as Mac OS X RTF

documents with attachments (RTFD).

Extensions: rtf, rtfd

HFS type codes: RTF

FORMATTED NOTES

Formatted notes are HTML files with a reduced

set of possible tags that can be edited WYSIWYG.

While they share the ".html" file name extension

which allows you to view them using a standard web

browser, formatted notes feature an identifying

meta tag which DEVONthink Personal uses to

distinguish them from regular HTML files.

Extensions: html

MARKDOWN AND TEXTBUNDLES

DEVONthink Personal supports importing, creating,

editing, and rendering Markdown files.

Extensions: md, mmd, mdwn, mark, mdown,

mdtext, mkdown, textile, markdown

In addition, DEVONthink Personal supports

Textbundle files. Technically Textbundle files

are packages, folders that look like a regular file,

containing plain text files and e.g. additional images

linked from Markdown.

Extensions: textbundle, textpack

http://code.google.com/p/openmeta/
http://code.google.com/p/openmeta/wiki/OpenMetaApplications
http://daringfireball.net/projects/markdown/
http://textbundle.org
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OFFICE AND OTHER DOCUMENTS

DEVONthink Personal imports many Office

file formats such as Microsoft Office and

OpenDocument documents, as well as all other file

formats for which Quick Look support is available,

e.g. Mellel (version 2.6 and higher) or Scapple files,

AppleScript scripts, or text clippings.

Note: Quick Look is Mac OS X 10.5's mechanism

for displaying a preview of almost any file type.

In the Finder, this function is invoked by pressing

the Space bar. Quick Look requires the maker

of the software that writes the document to

add additional preview information inside the

file (package), or to provide a Quick Look plugin

embedded into the application itself or installed

in a Library folder. If neither DEVONthink

Personal nor the Finder can preview a document

format that you want to use, please contact the

maker of the software and ask it to provide Quick

Look support for its file format.

Due to the nature of Quick Look, the contents of a

document that is displayed using this technology,

e.g., an Apple Pages file, is sometimes not selectable.

Depending on the file format, a plain or rich text

alternative is available for some files, e.g., for email

messages. Where available, use the Text View/

Preview toggle button in the document's navigation

bar to switch back and forth between plain text and

preview modes.

Additional Quick Look plugins can be found on

QLPlugins.com.

EBOOKS

EVERNOTE NOTES

DEVONthink Personal imports Evernote notes

and saves them as formatted notes. Title, creation/

modification date, tags and source URL are retained.

Extensions: enex

CHAT LOGS

DEVONthink Personal understands the text

format of logs generated by Adium, iChat or Yahoo

Messenger. You can import these chats like rich text

files.

Extensions: chat, chatlog, ichat

HFS type codes: YMSG

PDF, POSTSCRIPT, SKIM

DEVONthink Personal imports and displays

Portable Document Format (PDF) files, Skim

PDF packages, and PostScript files. DEVONthink

Personal extracts the readable text portions of the

PDF, making it possible to search the text of the PDF

and to use See Also & Classify. PostScript files are

converted to PDF on-the-fly.

It is possible to manually convert imported PDFs to

plain text or RTF by using Data > Convert.

Note: It's not yet possible to extract text from

protected PDF files. Protected PDFs are

imported as simple images. However, you can

correctly view the PDF in DEVONthink Personal

after entering the correct password.

BOOKMARKS

Drag or paste Internet addresses from any Internet

application, or Internet location files from the

Finder, to DEVONthink Personal to create a

bookmark documents. DEVONthink Personal is

especially optimized to accept Safari Bookmarks.

Use bookmarks in DEVONthink Personal to

integrate "live' content from the Internet seamlessly

with local documents.

Extensions: dtLink, ftploc, fileloc, inetloc, mailloc,

newsloc, url, vncloc, webbookmark, webhistory,

webloc

HFS type codes: ilht, ilft, ilfi, ilma, ilnw, ilaf, ilat, ilns,

ilge, ilvn, LINK

HTML AND XML

In addition to the text encodings already listed,

DEVONthink Personal supports the standard HTML

transcriptions for special characters (for example

German umlauts and French accents). HTML can

http://www.microsoft.com/mac/
http://www.openoffice.org
http://www.mellel.com
http://www.literatureandlatte.com/scapple.php
http://www.qlplugins.com
http://adium.im
http://www.yahoo.com
http://www.yahoo.com
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also be converted to plain text using Data > Convert.

XML files of any kind can also be imported and are

displayed with syntax coloring. Preference property

lists of Mac OS X 10.4 and higher are stored in

a binary format and are converted on-the-fly to

readable XML.

Also, DEVONthink Personal supports Web archives

containing HTML pages, including all necessary

images for displaying them offline.

Extensions: asp, aspx, cgi, cfm, dtd, ent,

entitlements, htm, html, idata, jhtml, jsp, mhtml,

ompl, ooutline, php, php3, php4, phtml, plist, rdf,

rsd, rss, sdef, sgm, sgml, shtm, shtml, tbx, wml,

xbl, xhtm, xhtml, xml, xmloutline, xsd, xsl, xslt,

webarchive, wsdl

Automatic recognition: DEVONthink Personal

also recognizes HTML and XML file formats

defined by third-party applications.

IMAGE FILES

DEVONthink Personal imports all image formats

supported by Mac OS X and QuickTime.

Extensions: bmp, cur, eps, fax, fpix, fpx, gif, icns, ico,

jpeg, jpg, mac, pct, pdf, pict, png, pnt, pntg, psd, qti,

qtif, rgb, sgi, targa, tga, tif, tiff; Mac OS X 10.4 or

QuickTime 7 only: jp2, dng, exr, raw

HFS type codes: 8BPS, BMPf, EPSF, FPix, GIFf,

"ICO ", JPEG, "PDF ", PICT, PNGf, PNTG, "SGI ",

TIFF, TPIC, qtif

Installed applications or services can add

support for other file formats to Mac OS X and to

DEVONthink Personal as well.

Note: PICT files can still be imported, but Mac OS

X 10.5 does no longer display them.

MULTIMEDIA FILES

DEVONthink Personal displays or plays

QuickTimemovies, sounds, Flash movies and

Shockwave animations. To add movies, sounds, or

MP3s to DEVONthink Personal, import them like

any other file into your database. Multimedia files

also can be dragged into a rich text document to

integrate them with text and images.

Extensions: 3g2, 3gp, 3gp2, 3gpp, aac, adts, aif, AIF,

aifc, AIFC, AIFF, aiff, amc, amr, atr, AU, au, avi, bwf,

caf, cdda, cel, dif, dv, dvd, flc, f4v, fli, gsm, kar, m15,

m1a, m1s, m1v, m2a, m2v, m3u, m4a, m4b, m4p,

m4v, m75, mid, midi, mov, MOV, mp2, mp3, MP3,

mp4, mpa, mpeg, mpg, mpm, mpv, mqv, MQV, pls,

qht, qhtm, qt, qtpf, qtz, rtsp, sd2, sdp, sdv, skin,

smf, smi, smil, sml, SND, snd, swa, swf, ulw, ULW,

vfw, wav, WAV

HFS type codes: .SMI, .WAV, 3gp2, 3gpp, adts,

AIFC, AIFF, ALAW, "amc ", "amr ", attr, caff, cdda,

DAVI, DIVX, dvc!, embd, "FLI ", grip, "GSM ",

hmov, "M1A ", "M1V ", Midi, MooV, "Mp3 ", "MP3

", MPEG, "MPG ", MPG2, MPG3, mpg4, MPGa,

MPGA, MPGv, MPGV, MPGx, mxfd, PLAY, qhtm,

rtsp, Sd2f, "sdp ", "sdv ", SMIL, SwaT, SWFL,

ULAW, "VfW ", WAVE

DEVONthink Personal supports QuickTime file

types provided by third-party components.

TEMPLATES

DEVONthink Personal comes with a number of pre-fabricated templates for general use. Use these templates

to add a task list, a quote, or whole group structure for project management to your database.

MANAGING TEMPLATES

Templates are regular files stored in the Finder in the folder "~/Library/Application Support/DEVONthink 2/

Templates.noindex". Navigate to this folder in the Finder to manage your templates, rename them, organize

them in sub-folders, or delete them.

More templates are available as extras. See also p. 57ff

http://www.apple.com/quicktime
http://www.apple.com/quicktime
http://en.wikipedia.org/wiki/Adobe_Flash
http://en.wikipedia.org/wiki/Adobe_Shockwave
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PRE-FABRICATED TEMPLATES

DEVONthink Personal comes with the following pre-fabricated templates, which serve as great examples of the

template feature.

Note: Not all of the listed templates are available in DEVONthink Personal as DEVONthink Personal does

not support AppleScript. Templates based on simple files or on template packages are available, though.

General use:

Note: Adds a new note. If the clipboard contains text, it is automatically inserted; if the clipboard contains an

Internet address (URL), it is added to the note's link list.

Phone Note: Adds a new phone note, automatically inserting the current date and time.

Task List: Adds a simple task list.

Web Browser: Adds an HTML document that allows you to use DEVONthink Personal like a regular web

browser. Open the document, enter an Internet address into the address field, and click the Go button to visit

the web site.

Accounts & Passwords:

Online Account: Adds a document for storing online account details.

Serial Number: Adds a document for storing serial numbers.

Addresses & Dates:

Address Book Card: Adds the card selected in Contacts as a rich text document to your database.

Calendar Event: Adds a Calendar or iCal event you have copied to the clipboard (!) as a rich text document

to your database. You need to copy the event to the clipboard because Calendar/iCal does not yet provide a

mechanism to retrieve the selected event.

Classifications:

Decimal Filing System: Adds ten groups for the decimal filing system used by man European companies for

filing (scanned) paper documents.

Dewey Decimal Classification: Inserts a group with sub-groups that builds the first levels of the Dewey

Decimal Classification. Use this feature for databases that contain knowledge spanning many subjects.

Library of Congress Classification: Inserts a group with sub-groups that builds the first levels of the Library of

Congress Classification. Use this feature for databases that contain knowledge spanning many subjects.

Education:

Cornell Notes (Pages): Adds an Apple Pages document that allows you to write notes in Cornell style.

Cornell Notes (rich text): Adds a rich text document that allows you to write notes in Cornell style.

Quote (from clipboard): Adds a rich text document for a quotation or citation. The clipboard content is

automatically inserted and, if it's an Internet address (URL), it is automatically made clickable.

Reference (from Bookends): Adds the reference selected in Bookends to your database.

Reference (from Endnote): Adds the reference selected in Endnote to your database.

Reference (from Sente 6): Adds the reference selected in Sente 6 to your database.

Office:

Apple Numbers/Pages document: Adds empty Numbers or Pages.

Microsoft Excel/Word document: Adds empty Excel or Word documents.

OpenOffice Calc/Writer document: Adds empty OpenOffice documents. This smart template checks

whether OpenOffice is installed or not before adding the document.
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Registers:

1--31: Adds 31 groups, numbered 1 through 31.

A--Z: Adds 26 groups, named A through Z.

Days of the Week: Adds groups for the days of the week.

Months: Adds groups for the twelve Christian months.

Search:

PubMed: Runs a query in PubMed and adds the resulting documents formatted as rich text documents to your

database.

Smart Groups:

Images ... Videos: Adds smart groups selecting documents of a given kind.

Last ...: Adds smart groups selecting documents modified within a given period.

Large Documents: Adds smart groups selecting documents larger than 5 MB.

TEMPLATE PACKAGES

Besides the more complex smart templates, DEVONthink Personal supports template packages. These are

folders with the file name extension ".dtTemplate" that contain one or multiple folders, one for each supported

language. This way, depending on the system language, you can let DEVONthink Personal import the files in the

right language. Starting with version 2.8.4 template packages that don't need to support multiple languages can

also go without *.lproj subfolders. This further simplifies creating your own templates.

In addition, you can use the following placeholders in your file or folder names of your templates packages, as

well as in contained rich text, plain text, HTML, or XML files. During import they are replaced with actual data.

%time%: The current time

%date%: The current date

%shortDate%: The current date in short format

%longDate%: The current date in long format

%monthname%: The month name of the current date

%weekday%: The week day name of the current date

%day%: The day number of the current date

%month%: The month number of the current date

%year%: The year number of the current date

%username%: The user's name

%fullUsername%: The user's full name

%organization%: The user's organization from Contacts

%emailAddress%: The user's email addresses from Contacts

%host%: The host name

%databaseName%: The database name

%databasePath%: The database's path

%groupName%: The name of the parent group

%topGroupName%: The name of the top group

%clipboard%: The clipboard contents as plain text

%styledClipboard%: The clipboard contents as rich text

%clipboardLink%: The clipboard contents as a clickable rich text link if the clipboard contains a valid URL
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SMART TEMPLATES

Most of the prefabricated templates are "smart templates": They are not simple files, but actually AppleScript

packages that are executed when selected in the Data menu. These packages contain script code, as well as the

actual templates that they insert into your database. This has a number of advantages:

The script can choose a localized template for your language; this is also possible using a template package.

The script can add information to the pre-fabricated template, e.g., the current date and time or data from the

Web.

The script can act intelligently on data on the clipboard: If it's a simple text, it adds the text; if it's a URL, it adds

it to a different area of the document and makes it clickable.

The script can check if a certain application is installed, e.g., OpenOffice, before adding a document.

WEB SITE EXPORT TEMPLATES

For exporting information as web site, DEVONthink

Personal uses templates available in ~/Library/

Application Support/DEVONthink 2/Websites/ to

create HTML files from documents. You can choose

the template in the save dialog that appears when

you use File > Export > as Website

In the HTML templates, the following placeholders

can be used:

%databasePlusLocation%

'%comment%

%url%

%tags%

These placeholders will be replaced with actual

information during the export. The placeholders will

only be replaced in documents that are converted

to HTML during export--namely plain text, rich text,

Microsoft Office/OpenOffice documents, scripts,

chat logs, and sheets.

SEARCH OPERATORS

In the toolbar search field you can use standard and extended Boolean operators, parenthesis, and more to fine

tune your search.

The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder, Spotlight, common search

engines as well as common programming languages such as C, C++, Objective-C, Java, and JavaScript. The

complexity of the query is unlimited.

CASE

All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but

DEVONthink Personal will ignore case in interpreting the query.

PRECEDENCE OF TERMS

Search terms and associated operators will be interpreted from left to right, except as modified by including

portions of the query within parentheses.

WILDCARDS

You can replace parts of words with wildcards matching one, multiple, or a range of characters:

?: Matches exactly one character.

*: Matches none, one, or multiple characters.
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[a-b]: Matches one character of the range "a" through "b".

[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.

[^...]: Matches one character that is not contained in the given list or range.

BOOLEAN OPERATORS

The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms

in the search query. If no operator is given, DEVONthink Personal infers AND. The available Boolean operators

are:

term1 AND term2: Contains term1 AND term2

term1 BUT term2: Contains term1 AND term2

term1 OR term2: Contains term1 OR term2

term1 XOR term2: Contains term1 or term2, but not both

term1 EOR term2: Contains term1 or term2, but not both

NOT term: Does not contain term

"term1": Contains the string of words term1, in exactly this form

Besides the classic Boolean operators, DEVONthink Personal uses a number of operators that usually are

found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine tune your

query.

term1 OPT term2: term1 needs to occur, term2 can. If term2 does, the found document ranks higher in the

search results.

term1 NEAR term2: term1 occurs 10 words or less before or after term2

term1 NEAR/n term2: term1 occurs n or less words before or after term2

term1 BEFORE term2: term1 occurs before term2

term1 BEFORE/n term2: term1 occurs n or less words before term2

term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)

term1 NEXT/n term2: term 1 occurs n or less words before term2 (synonym for BEFORE/n)

term1 AFTER term2: term1 occurs after term2

term1 AFTER/n term2: term1 occurs n or less words after term2

~term1: Contains term1, also as part of a word

For convenience, some of these operators can also be abbreviated using commonly used symbols:

AND: &, &&, +

OR: |, ||

XOR: ^, ^^

NOT: !, -

Note: The symbols above are also used by the Finder and Spotlight for searches. Enter the vertical ruler

character for the OR operator by pressing ⌥7 (e.g. on European keyboards).

Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT) BEFORE/AFTER/

NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without parenthesis are evaluated

from left to right.
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WHITE SPACE HANDLING

Words linked by non-white separators (e.g. www.devon-technologies.com or page_id) are treated like phrases

put into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2". Characters

separated by dots are considered to be abbreviations and therefore handled like words separated by hyphens,

e.g., the term t.a.t.u is equal to "t a t u" OR tatu

EXAMPLES

By using any or all of the operators and rules layed out above you can create complex queries that find the exact

information you're looking for. Here are some example queries that show how the operators are used.

Example: Devonian Dinosaurs

This query looks for all documents that contain the words "devonian" and "dinosaurs".

Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro

This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words away from each

other, as well as the word "iMac" (no specific position relative to Steve and Jobs), but not the word "MacBook".

The word "Pro" does not need to occur, but if it does, the document is ranked higher in the list of search results.

Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2 ~effect)

This query looks for documents containing the word "Paracetamol" near (within 10 words) to words either

starting with "effect" (and so also "effects") or "impact". In addition, the document needs to contain the word

"side" or any word starting with "second" located within two words range of any word starting with "effect".

TEMPLATE TAGS FOR WIKI-STYLE LINKS

In DEVONthink Personal you can create new documents by first selecting some text in a rich text document

and then making it a link using the contextual menu. When you then click this link, DEVONthink Personal

creates the new document using a template you set in the Editing Preferences. In this template, can use the tags

below to automatically insert the name of the link, the current date or other information. See also p. 37ff

%@: Name of link

%%: A "%" character

%a: Abbreviated weekday name

%A: Full weekday name

%b: Abbreviated month name

%B: Full month name

%c: Shorthand for "g%X %x," the locale format for date and time

%d: Day of the month as a decimal number (01-31)

%e: Same as %d, but does not print the leading 0 for days 1 through 9

%F: Milliseconds as a decimal number (000-999)

%H: Hour based on a 24-hour clock as a decimal number (00-23)

%I: Hour based on a 12-hour clock as a decimal number (01-12)

%j: Day of the year as a decimal number (001-366)

%m: Month as a decimal number (01-12)

%M: Minute as a decimal number (00-59)

%p: AM/PM designation for the locale

%S: Second as a decimal number (00-59)

%w: Weekday as a decimal number (0-6), where Sunday is 0
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%x: Date using the date representation for the locale, including the time zone

%X: Time using the time representation for the locale

%y: Year without century (00-99)

%Y: Year with century (such as 1990)

%Z: Time zone name (such as Pacific Daylight Time)

%z: Time zone offset in hours and minutes from GMT (HHMM)

ITEM LINKS

DEVONthink Personal provides a URL (uniform

resource locator) for all documents and groups in

its databases. While web URL typically begin with

"http://" or "https://", DEVONthink Personal's URLs

take the form of "x-devonthink-item://" followed by

a long alphanumeric ID.

You get this item link by selecting a document or

group and choosing Edit > Copy Item Link, and you

can use it in any application that supports URLs, e.g.

the notes fields of OmniFocus tasks. For audio and

video documents as well as for PDF pages you can

also get URLs that directly link to a designated time

or page using the contextual menu.

In addition you can manually extend the copied URL

with the following parameters:

page: Directly jumps to the specified page of a

PDF. Usage: page=<integer>.

reveal: Reveals a group instead of opening them.

Usage: reveal=1.

search: Directly jumps to the first occurence of the

search string. Usage: search=<string>.

time: Directly jumps to the specified time in

seconds in a video or audio document. Usage:

time=<float>.

Example:

x-devonthink-item://<groupID>?reveal=1 x-

devonthink-item://<pdfID>?page=5

x-devonthink-item://<textFileID>?search=iPad

%20Pro

x-devonthink-item://<movieID>?time=43.5

The first parameter after the ID is always added

after a questionmark (?), additional ones after an

ampersand (&).

METADATA

DEVONthink Personal stores a large number

of metadata fields internally when importing

documents from the file system, e.g., from PDF, RTF,

MP3, EXIF/IPTC, HTML, and email messages as well

as from all files that deliver metadata through the

Spotlight metadata importer. Here's a partial list of

theoretically supported fields:

General:

Title

Headline

Subject

Creator

Producer

PDF and RTF:

Description

Copyright

Comment

URL

Keywords

Electronic correspondence:

Authors

Author email addresses

Recipients

Recipient email dddresses

Email addresses

Electronic publications:

Album

Composer

Contributors

Publishers

Editors

Organizations

https://en.wikipedia.org/wiki/Uniform_Resource_Locator
https://en.wikipedia.org/wiki/Uniform_Resource_Locator
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HIDDEN PREFERENCES

There are a few settings in DEVONthink Personal

that you cannot set through the Preferences window.

Most of them are intended to facilitate customer

support but they might be interesting for you as

well.

Note: These hidden preferences are not an

official feature and could be changed or removed

with any update.

HOW TO ACCESS THE HIDDEN PREFERENCES

All hidden preferences are simple on/off switches.

You set and unset them using the "defaults"

command in the Terminal. To set preferences via

the Terminal DEVONthink Personal must not be

running or it will overwrite your changes when you

close it.

To set a preference using the Terminal, the

command line looks like this:

Terminal:

$ defaults write com.devon-

technologies.thinkpro2

ShouldScaleAttachedImages -bool TRUE

The above command activates the preference with

the key "ShouldScaleAttachedImages". Change

TRUE to FALSE to deactivate it. Use any of the

preferences keys below to activate or deactivate

them.

The preference AdditionalPlainTextExtensions is

best set from the Terminal. As it replaces the list

of additional plain text extensions we recommend

that you read the current list first (empty by default)

before adding your own to the end of the list.

Terminal:

$ defaults read com.devon-

technologies.thinkpro2

AdditionalPlainTextExtensions

2014-07-31 08:25:27.101

defaults[21950:3312262] The domain/default

pair of (/Users/eb/Library/Preferences/

com.devon-technologies.thinkpro2,

AdditionalPlainTextExtensions) does not

exist

$ defaults write com.devon-

technologies.thinkpro2

AdditionalPlainTextExtensions -

string .otl.todotxt

$ defaults read com.devon-

technologies.thinkpro2

AdditionalPlainTextExtensions

.otl.todotxt

AVAILABLE HIDDEN PREFERENCES KEYS

EnableApplicationFiles: Applications can be

imported/indexed.

DisableBadgeLabel: Disable the badge label on

DEVONthink Personal's Dock icon.

DisableOpenMeta: OpenMeta tags aren't

exported/set.

DisableFileSystemEvents: DEVONthink Personal

no longer listens to file system events.

DisableFinderTags: DEVONthink Personal no

longer imports or exports Finder tags.

RichNotesWithoutAttachments: Services create

RTF instead of RTFD.

ShouldScaleAttachedImages: Enables image

scaling in RTF documents.

DisableAutomaticUpdatingOfIndexedItems:

Disables automatic updating of indexed items.

RenderMarkdown: Show Markdown documents

rendered by default.

PlainTextIsMarkdown: Treat all plain text files as

markdown.

AdditionalPlainTextExtensions: Set the list of

additional plain text extensions, separated by

dots.
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