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Read me
Make the dream of the paperless office come true with DEVONthink Pro Office. Use DEVONthink Pro Office to keep all of your
together in one database. Use DEVONthink Pro Office to integrate documents on your hard drive, live content from the Internet, your notes, and your project-related information, all together so that you can search and analyze them. Share your data with colleagues, even when they're using Windows.
The DEVONthink Pro Office advantage
Why DEVONthink Pro Office?
DEVONthink Pro Office not only stores documents, it also facilitates
your documents with a flexible and powerful organization tool.
Integrated workspace
Unlike the Finder, DEVONthink Pro Office provides an integrated environment with all the tools you need for working with information. Don't waste time with digging through thousands of files but let DEVONthink Pro Office intelligently assist you.
As a native Mac application, DEVONthink Pro Office is also tightly integrated with Mac OS X. DEVONthink Pro Office provides a Dock menu, Services menu commands, and makes heavy use of the Safari Web browser engine. Of course, DEVONthink Pro Office runs natively on both PowerPC and Intel processor based Macs.
DEVONthink Pro Office comes with a number of 'paperless office' functions not present in other editions of DEVONthink:
What can you do with it?
DEVONthink Pro Office is much more than just a document database -- and so there is more than just one way to use it. Here are some of them:
Editions
DEVONthink comes in multiple editions optimized for home/semipro and professional, heavy-duty use. You can find a complete list of all the differences on our Web site.
System requirements
Every Apple Mac computer with at least 512 MB of RAM, Mac OS X 10.5 or later. In addition, a broadband Internet connection (256 Kbps or faster) is highly recommended.
For stable functioning it is recommended to keep the total number of elements in all open databases below 300,000 items and 200 to 300 million words. Larger databases could become unreliable due to low memory on current Macs.
Installing, updating, uninstalling
Note: The following procedures do not apply when you have purchased DEVONthink Pro Office on the Mac App Store. Installing, updating, and uninstalling is all handled by the App Store application in this case.
Installing and updating
Just move the DEVONthink Pro Office application package to the Applications folder or any other directory you have access to. Please note that Mac OS X Services and the connection to DEVONagent work only for applications installed into one of the Applications folders, and that logout and login or a restart is required after installation.
To update an existing version of DEVONthink Pro Office, simply copy the application package from the disk image to your Applications folder, replacing the old version. Your database(s) will not be affected.
Upgrading to DEVONthink Pro (Office)
When you are upgrading from DEVONthink Personal to DEVONthink Professional, the application will copy your existing DEVONthink Personal database to your documents folder ('~/Documents/DEVONthink.dtBase2').
If by any chance it doesn't do this automatically, do the following: Copy the complete folder '~/Library/Application Support/DEVONthink 2' to your Desktop. Then, Rename the folder as you wish and add the filename suffix, '.dtBase2' (without quotes). The folder has now become a DEVONthink Pro Office database icon that you can double-click.
If your old database was created by DEVONthink Personal 1.x, it will be the folder named 'DEVONthink' at '~/Library/Application Support/'. Follow the instructions as above, but in this case use the filename suffix '.dtBase' (no quotes, but case is important). The folder has now become a DEVONthink Pro Office 1.x database. From DEVONthink Pro Office choose File > Open Database and select the resulting database file. You will be offered the opportunity to convert the database to a new DEVONthink Pro Office 2.x database. Accept, and you now have a converted DEVONthink Pro Office 2.x database.
Note: It's definitely not recommended to install both DEVONthink Personal and Professional on the same machine. For example, both applications use the same Services menu shortcuts and Mac OS X would assign the shortcuts sometimes to DEVONthink Personal, sometimes to Professional. In addition, DEVONagent stores contents in DEVONthink Professional if it's available, otherwise in DEVONthink Personal.
Downgrading to DEVONthink Personal
If you want to downgrade from DEVONthink Professional to Personal, copy the database you want to use to '~/Library/Application Support' and rename it to 'DEVONthink', removing the file name extension '.dtBase2'. The database package becomes a regular folder and will now be used by DEVONthink Personal.
Uninstalling
To remove (uninstall) DEVONthink Pro Office completely from your Mac, trash the following files and folders (~ stands for your Home folder):
Getting Started
By now you’ve installed DEVONthink Pro Office on your computer and are wondering where to start. You probably downloaded the software because you have lots of digital files, and you want to better organize your information, or you want to search for information across a variety of file types and different file locations. DEVONthink Pro Office can help you do that. But how to start?
This short guide will help familiarize you with the look and feel of DEVONthink Pro Office, advise you on the best way to build your new databases, brief you on DEVONthink Pro Office’s most powerful features, and more.
Familiarizing yourself with DEVONthink Pro Office
Best begin your learning process by shucking some preconceptions about what the application may be like, and how it may work. Instead of thinking about it as a mere Finder replacement, or a Spotlight substitute, think about your life, and how you like to organize things. Do you save important emails, PDFs, or web pages you like for later viewing? These thoughts will help as you start to figure out what you want to add, or not add, to your databases.
The Interface
Most of the time, your ability to effectively use a new piece of software is only as successful as your ability to learn how to use the interface. That is why DEVONthink Pro Office’s developers have created a clean, easy-to-navigate graphical user interface. This intuitive workspace takes the 'where' and 'how' out of using the software, allowing you to concentrate on the DEVONthink Pro Office’s potential.

Unlike applications that are designed to do highly specific things, such as a calendar or personal information management program, DEVONthink Pro Office is a document/information manager that provides open-ended flexibility to the users to create databases that work for them. Our users have a very broad range of purposes for -- and approaches to -- their databases; creating a one-size-fits-all, cookie cutter document and information manager simply wouldn’t work for such diverse users. Neither would deviating from the Mac OS X style; any user of Mail (or any other Apple application) will feel right at home with DEVONthink Pro Office. This is why is we think there is no other Mac application that is as 'open' as DEVONthink Pro Office.
The Main Window: The interface that you'll use most of the time is a view window (main window) looking into all or a portion of an open database. It consists of a toolbar and one or multiple panes that give you access to groups, documents, and their contents. Using the icons in the toolbar you can quickly navigate the contents of your database, switch views, create new groups and documents as well as search your database. The Action menu (a button with a gear icon) lets you perform frequently used actions without searching for the right command in the menu bar.
Note: You can customize the toolbar to your individual needs by using the menu command View > Customize Toolbar.
What panes you see depends on which View you have chosen: the List and Icon views show only groups and documents but not their content, the Split and Three Panes views show groups and documents as well as the content of the selected item. You switch views with either via the toolbar or the View menu.
You can open multiple windows for a database, and switch each one to a different view. The History window offers an additional view on your data, sorted by the date on which each item was actually added to or modified in the database. Finally, the Concordance window gives you access to your documents through a weighted list of all words contained in your database.
Actions: All items (be they documents or groups) can be put into groups, just like as any files or folders can be put in another folder in the Finder. All commands in DEVONthink Pro Office's menus act either on selected groups or selected documents, and the contextual menu, which appears when you ⌃ click (right-click) an item, shows the most important commands tailored to the selected items.
Note: Contextual menus are available almost everywhere in DEVONthink Pro Office. If you are unsure what you can do with an item in the user interface, ⌃ click (right-click) it and see what options the appearing menu offers.
Like the Finder, DEVONthink Pro Office also has an Info panel that shows additional information about any selected item. It allows you to change the icon of the item by pasting a copied picture or icon onto its icon in the Info panel.
Properties: The Database Properties show you more in-depth information about your database as well as give you the possibility to open a database by default. Check Use as Default Database in the Database Properties to open the current database each time you open DEVONthink Pro Office.
Inbox: DEVONthink Pro Office maintains a special, global group, the 'global inbox'. It is shared between all open databases and is even accessible through the Sorter when DEVONthink Pro Office is not running. The inbox is the place where new documents end up, e.g., when dropped onto DEVONthink Pro Office's Dock icon or when created via the Services menu commands.
Terminology
The user interface for DEVONthink Pro Office should be simple. As you get to know the various layout possibilities, there are indeed only four principle elements you should be familiar with:
Learn more about the terminology used in DEVONthink Pro Office in the glossary.
File Types
One final note before you begin to create databases and add content: it is useful to familiarize yourself with the various file types that can be recognized by DEVONthink Pro Office, and as well as the resulting potentials for how you may then edit these files of various file types once their imported/indexed. Take a look at the list of supported file types and editing possibilities.
Building Your Database
The first step in starting your own custom database, is to create a new database with File > New Database. Give your database an easily recognizable name and choose where you want to save your database, e.g. in your Documents directory. With your new database created, you are ready to turn your attention to adding information.
There are two ways of adding files from your hard disk into the database: Import (in which case the supported files are copied into the database), and Index (in which case the database captures text/image information from the externally-linked file if possible, but does not copy the file itself into the database).

To copy files to the database, use, e.g., File > Import > Files & Folders, or drag-and-drop the file you wish to add (to the DEVONthink Pro Office Dock icon, to the Sorter, to the floating Groups panel, or to the groups and documents pane of a view window).
To index to external files, use File > Index, or the equivalent, dragging the file with ⌥ and ⌘ pressed to DEVONthink Pro Office's Dock icon, to the floating Groups panel, or to the groups and documents pane of a view window).
Note: When you choose to index a file contrary to import it, do not delete the indexed external file or your data will be lost.
Similarities between Import and Index
In either mode, Import (copy) or Index (link), DEVONthink Pro Office will capture (in other words: copy) the text of readable file types into the database for searching and analysis. Also, in either mode, DEVONthink Pro Office will ignore unrecognized file types unless the user has checked the Other file types option in Preferences, Import tab.

If the Other file types option is checked, importing copies all file types to the database package and indexing links to the external files. In both cases a blank document is created that links to the actual file on disk; no text is captured, but the contents of the Info panel (document title, comments, etc.) will be searchable. You can keep all files related to your project or research together in your database instead of storing them in multiple places all over your computer. If Mac OS X is able to display a preview of the file using QuickLook, DEVONthink Pro Office displays a preview as well.
Differences between Import and Index
Imported or indexed plain or rich text files are directly editable in the document's text pane. Documents in other formats can be edited in their parent application. Saves changes will be taken over by DEVONthink Pro Office.
Pros and Cons of Using Each
There's nothing wrong with using both Import or Index in the same database. You may decide, for example, to import project files but index chatlogs.
Import results in a more easily portable database (for instance, taking a backup of the database on an external drive or DVD), but yet requires more disk space. Index results in a less easily portable database, but requires less disk space. If you choose to index, keep the external files in your Documents directory. That will make it easier to migrate to another computer later on by moving the complete Documents directory to the new machine.
Adding Your Files
While you may be tempted to dump every file in your hard disk into DEVONthink Pro Office and sort it out later, you’re best off being more selective in what you add (especially as you start). After all, having a large, 'dump it all in' database can contain a lot of files that will do you no practical good (for example, DEVONthink Pro Office can't read your Microsoft Office user profile files), and weeding these files out after-the-fact can be both time-consuming and frustrating.
Here’s a practical example: Your iTunes database runs over 22 gigabytes. There's nothing to be gained by simply copying that into a DEVONthink Pro Office database. Copying the iTunes database into DEVONthink Pro Office would result in a large, inefficient, and slow DEVONthink Pro Office database, and would most definitely cripple DEVONthink Pro Office’s ability to show off its truly amazing abilities to help manage and use the information content in a well-designed manner (much less perform simple search and organizational tasks).
A topical database approach -- where you create multiple databases, with each holding only like information (for example, a bird watching database full of birding articles, birding newsletters, etc., and a separate quantum physics research database with research briefs, emails, etc.) can improve the effectiveness of DEVONthink Pro Office’s artificial intelligence (AI) features. The AI work best within a database that does in fact have contextual relationships among many documents; clogging your new database with everything from A (apple pie recipes) to Z (Zengobi user documents) will only hamper the AI’s ability to work effectively.

Having topical databases will help down the road as well. DEVONthink Pro Office allows you to share your database over the local network or even over the Internet. Imagine having just one database: You decide to share your painstakingly researched academic articles with colleagues, only to find that they’re also able to now access your painstakingly saved financial records and chats with your significant other. Not hard to imagine how that has the potential to be both dangerous and embarrassing! Having multiple, topical databases will allow you to share information quickly and easily. Your friends and colleagues will appreciate the forethought (not to mention any embarrassment they might have incurred stumbling onto your saved chat logs).
Summary: What material do you wish others to see, and why? What material do you not wish others to see, and why? These are important considerations as you design your databases. For several reasons, think about creating more than one database, and to keep your databases relatively topical. It's not difficult to carve out topical areas that don't overlap with multiple databases, and the effort may help you stay more organized.
But no panic if you start with one way of organization and decide later to re-organize your databases. As DEVONthink Pro Office can keep multiple databases open simultaneously, you can easily move documents from one database to the other at any time.
Our Recommendation
Even though we wouldn’t blame you if you eventually think of DEVONthink Pro Office as your life, it is, indeed, a database application. Like all databases, the larger it is, the more memory it will require in order to run quickly. Your computer, no matter how up-to-date and top-of-the-line, has processing, RAM, and disk space limitations.
One way to keep your life, ehrr, databases, running smoothly is to run multiple databases. Not only is it easy to open multiple of them at the same time, but you’ll find that if you 'split' the information on your computer into databases that can be easily categorized (a.k.a. topical databases, see above) you can make DEVONthink Pro Office and your computer perform better (almost instantaneous searching and analyzing information if your computer meets recommended hardware and software specs). Of course, having performance problems with one database is not a problem if you only have a few files in your database. But what about people like a researcher, who has hundreds of gigabytes of files, and who can’t seem to stop adding new information on a daily basis? For people like her, multiple, topical databases are the only way to go.
Case Study: Bill’s Database Farm
Bill DeVille, DEVONtechnologies' Evangelist, is very interested in a number of scientific areas. Bill's main database covers interests in environmental science and technology topics, with related interests in science and technology exchanges with developing nations; even some projects dealing with graduate education in environmental sciences and engineering. There's a broad topical relationship, but the content of the database covers many special disciplines ranging from chemistry, toxicology, statistics, risk assessment, and engineering to economics, legal, regulatory, and policy issues. These disciplines fit together, and information covering all of these topics is necessary in many real-world cases.
As you can imagine from the above description, Bill's main database is a pretty big database, amounting to about 20,000 documents and over 20,000,000 total words. Because there really are relationships knitting together all these scientific, technical, legal, and policy issues, the artificial intelligence features of DEVONthink Pro Office work very well for Bill in researching the database and contextualizing the information.
In addition to his main database, Bill has seven additional databases (so, eight total). For example, he has one database for Apple Newton literature he has accumulated over the years. It's almost as big as his main database, but the topical coverage has no practical relationship to the main database, so Bill keeps the Apple Newton literature in its own domain. If he were to keep the unrelated matters from the Apple Newton database and the main research database in one single database, the result would be a larger, slower database, with poorer performance by the artificial intelligence.
Bill's main database has hovered at about 20,000,000 words for the past couple of years. He often adds topical materials to it that are not related to its main purpose, as mentioned above. If those 'unrelated' topics grow large enough in volume, he spins them off into to a new database. But even with this diligence, the 'core' topics keep growing daily as Bill adds new environmentally related material from the web or other sources.
If you’d like to follow Bill's method, start by creating a database with some collections of files that interest you, and don't be afraid to create other databases that contain 'different' material as your interests -- and main database -- grow. And if you need to search across databases, simply open all of them at the same time. DEVONthink Pro Office searches all of them almost simultaneously.
Very Important: Duplicates and Replicants
One of the things you’re likely to come across as your database grows, are duplicates and replicants. Both groups and documents in DEVONthink Pro Office can be duplicated or replicated.
It is important that you understand how replicants work before you begin making changes to documents, as any changes to a replicant are carried over to all replicants; as you might imagine, this means that you can to do some very powerful (and potentially negative) things with your database’s contents via replicants. Duplicates are also useful in their own way, as you can duplicate contents and modify them without modifying the original document or group. Less powerful than replicants, but no less important in the grand scheme of database organization.
Unleashing DEVONthink Pro Office’s Power
DEVONthink Pro Office comes with a number of features that set it apart from most other, less powerful Mac applications: Artificial intelligence and web sharing, to name a few.
I, Mac
DEVONthink Pro Office incorporates artificial intelligence (AI) features like Classify (which helps you decide where to place new content into the database) and See Also (which suggests other documents that are contextually similar to a viewed document). These features become more and more powerful as a database grows, especially if you have maintained good organization of all previously added content.

Similar to Classify and See Also are Auto Group (DEVONthink Pro Office examines a collection of ungrouped items and creates new groups based on contextual similarities) and Auto Classify (DEVONthink Pro Office classifies and immediately files a document). There is even an AI-powered ranking system built into the Search function.
These artificial intelligence features set the DEVONtechnologies applications apart from other document managers available today. Indeed, these features can even help you look at familiar data in a new way. For example, See Also can often suggest relationships between documents that might not have occurred to you.
Extensions and Automations
DEVONthink Pro Office is one of the most highly scriptable Mac applications. This flexibility allows you to extend the capabilities of DEVONthink Pro Office with scripts and automating many, otherwise tedious, procedures.
Please don't be 'put off' if you don't know how to write scripts. DEVONthink Pro Office can probably let you do everything you wish to do without even using scripts. In fact, the purpose of most scripts is not to add features you’d otherwise miss out on, but rather allow you to automate frequently executed manual operations.

For example, DEVONthink Pro Office provides a convenient script that automates the process of printing as PDF a document from any application that allows printing, and then allows you to choose the location in the database to which the PDF will be sent. In this case one can accomplish the same end result without using the script, but with a bit more time and effort required.
There is an active discussion board on scripting in the User Forum.
A Word about Backups
Your data stored in DEVONthink Pro Office is valuable, so back it up. DEVONthink Pro Office makes it easy. For creating an internal backup, that means a copy of the index files, inside the database, go to Tools > Backup & Optimize. To create a copy of the whole database that you can then save on a server or a DVD-R, use Scripts > Export > Backup Archive. We strongly recommend you get in the habit of triggering backups whenever you have invested substantial time and effort into modifying the database.

For many users, the value of the data is much greater than the value of the computer that hosts it. There are many things that can go wrong. Your notebook computer could be dropped, lost, or stolen. Your hard drive will fail (it's not a matter if it will, but when). A power outage could corrupt the files on your hard drive. For the truly paranoid (remember, paranoia is sometimes justified), how significant would the loss of your database be if your house or office were to burn down? Avoid insomnia and back up frequently.
Note: As events such as house fires and natural disaster frequently prove, valuable data should probably be kept at more than one location. Consider saving a copy of your backed up information at a secure, off-site location such as Dropbox, the JungleDisk, or a bank safe.
Tutorials, screen casts, and more
DEVONthink Pro Office is a powerful application so you will need some time to fully master it. Open the Support Assistant to read tips, tricks, and tutorials, and install pre-made scripts and templates that extend DEVONthink Pro Office's functionality.
Another helpful resource that you should not miss is our President's blog where Eric publishes last-minute news, important information about our software, and sometimes even public betas.
Take your time to learn how to work with the software -- and how you want the software to work. You'll be rewarded with a powerful assistant for all your information organzation needs.
Common Tasks
In this chapter you'll find an number of common ways how you can use DEVONthink Pro Office for your everyday tasks; from surfing the Internet to making notes, to cataloging photos and archiving emails.
Analyze Text Documents
With its built-in artificial intelligence (AI) functions, DEVONthink Pro Office can be used to analyze large amounts of text documents.

The Concordance function allows you to create a list of all words in a database, sorted by its frequency and restricted to a given length. The Search and Similar buttons open drawers that feature all documents containing words that are contextually similar to the selected word (these searches happen almost instantly). A search toolbar item lets you find any word of interest.
Other functions that help you analyze documents include the AI-enhanced search function that also features a list of similar words based on spelling or contextual similarity. The See Also button lists documents with a similar content and the topics pop-up menu displays the most important words of a document. Duplicate documents are instantly marked in blue and bold.
Replicants and cross-links help you create a network of documents.
Possible uses:
Continue to read here:
Archive Your Emails
DEVONthink Pro Office is the repository for emails you want to save.

Its hierarchical groups structure and automatic classification function are perfectly suited to sort in new messages and help you find them again when you need them. DEVONthink Pro Office comes with advanced email archiving functions that transfer selected messages or mailboxes from Apple Mail, Microsoft Entourage, and all email applications using standard Unix mailboxes, e.g., Thunderbird or GNUmail to a DEVONthink Pro Office database. The original structure of the message as well as all attachments are preserved and you can even reply to messages directly from within DEVONthink Pro Office.
Possible uses:
Continue to read here:
Archive Printed Documents
DEVONthink Pro Office is the 'paperless office' solution for the Mac, a central hub for all your documents, paper or electronic.
Using the integrated scanner support you can directly scan documents, make them searchable through OCR (optical character recognition), and file them in a database. Of course, you can also make your already existing scanned documents searchable. If you are the proud owner of a Fujitsu ScanSnap or another compatible document scanner you can even use the fast auto-feeder to conveniently scan batches of sheets in one go.
You are working in a team, use the embedded web server to give your colleagues access to your data with an interactive web interface. Even your Windows-using friends are invited.
Possible uses:
Continue to read here:
Browse the Internet
Besides being a knowledge and information database you can use DEVONthink Pro Office as a web browser. This extends the document-based approach to knowledge to the World Wide Web. Being a database, DEVONthink Pro Office's web browser does not work in a windowed style like Safari or DEVONagent Pro; rather, it's document-oriented.

This enables you to treat web pages the same way as you treat your documents. Whenever you select a web document (bookmark), DEVONthink Pro Office immediately loads and displays its content live from the Internet in the view/edit pane. You can then archive the complete page to the database for offline viewing.
DEVONthink Pro Office also handles RSS/RDF/Atom news feeds, either through feed documents or by simply displaying them via the built-in web browser. Stay up-to-date with your subject and clip important information right away.
Possible uses:
Continue to read here:
Capture Data from the Web

More and more information is provided not on paper but directly through Web sites, from blogs to news sites, Facebook, and user forums. DEVONthink Pro Office offers a variety of options for conveniently capturing data from the Web:
All of these options except the bookmark capture the text content of the page (or a selected area of it), capture hyperlinks if present and preserve the text information for searches in DEVONthink Pro Office.
Note: There are a number of Web sites that one might visit that prohibit use of some of the capture options described above. A secure banking site or a university portal to journals may direct a Bookmarklet or script capture option to the login page, which will be captured instead of the desired content. A capture option that requires re-download of the page on such sites will capture only the login page. Always, the page can be selected and captured as rich or plain text. The viewed page can be captured by 'printing' it as PDF to the database.
Possible uses:
Continue to read here:
Catalog Your Disks, CDs, and DVDs
By using the Index function, you can use DEVONthink Pro Office to set up a catalog for CD-ROMs or other removable volumes. Create a group for each disk by using the index function and organize your disks/groups in any way you like. When you need a specific file, search for it in DEVONthink Pro Office, insert the volume, ⌃ click the file in DEVONthink Pro Office, and select Open With to open the original file on the removable volume.
Possible uses:
Continue to read here:
Catalog Your Photos and MP3 Files
Besides storing text documents and PDF files, DEVONthink Pro Office also manages multimedia data such as photos, illustrations, MP3s, or movies.
While never designed to be an iPhoto or iTunes replacement, DEVONthink Pro Office can also be used as a repository for images you frequently use or as an interface to your MP3 library (if you don't like other music software). If you do not want to import these files but leave them where they are in the file system but access the from within DEVONthink Pro Office, index instead of import them. [Read more...]
Possible uses:
Continue to read here:
Collect Text Snippets and Other Valuable Data
Using Mac OS X's handy Services menu, DEVONthink Pro Office is the premiere tool for collecting and organizing information bits and snippets.

Select any piece of data and capture it to the currently open database with a keystroke or a short visit to the Services menu. All Cocoa applications such as TextEdit, Safari, or DEVONthink Pro Office itself as well as many new Carbon applications, e.g. the Finder or Microsoft Office 2004, support this mechanism. Alternatively drag text clippings to the Sorter panel.
DEVONthink Pro Office automatically sets the title of the newly created snippet to the first line of text, so there's a good chance that you don't even need to rename it. New snippets are always created in the inbox. Also, DEVONthink Pro Office can automatically classify and file them by using its built-in artificial intelligence.
Possible uses:
Continue to read here:
Index Files on Your Hard Disk
Besides completely importing documents, DEVONthink Pro Office can also simply index files. When indexing files, DEVONthink Pro Office reads the contents of the file and stores it for internal reference, yet it always uses the external file for displaying the actual contents. Use indexing for easily accessing information stored in CD-ROMs, creating a library of all important documents regardless where they are physically stored, or for integrating files stored elsewhere with your documents in DEVONthink Pro Office.
Possible uses:
Continue to read here:
Manage Your Bookmarks
With its integrated, document-based web browser, DEVONthink Pro Office can be used as a bookmark manager. Organize all your bookmarks as bookmark documents and visit them simply by selecting them in split or three panes view. DEVONthink Pro Office loads the page and displays it in the view/edit pane.

If you want to open it in your default browser, simply ⌃ click (right-click) the bookmark and choose Launch URL from the contextual menu.
Possible uses:
Continue to read here:
Read Newsfeeds

DEVONthink Pro Office comes with built-in support for RSS, RDF, and Atom news feeds that makes it also a decent news reader. In addition, its integrated web browser supports news feeds and displays them like any other web page. Use its document-oriented structure to organize bookmarks and store news feeds like Internet-updated smart groups.
Mix live news feeds with static documents, e.g. in your project materials.
Possible uses:
Continue to read here:
Take Notes
DEVONthink Pro Office is perfectly suited for taking notes and organizing them.

Use DEVONthink Pro Office's Take Note panel or its Dock menu to quickly create new notes; write them with all the advanced text editing capabilities of Mac OS X and find a place to file them in your database using the Classify & See Also button.
Possible uses:
Continue to read here:
Write Texts and Outline Projects
With its hierarchical group structure, organization, and navigation functions as well as its advanced text editing capabilities based on the Mac OS X text engine and the full screen mode DEVONthink Pro Office is perfectly suited for writing text from notes to whole books.

Create new documents with just one click, find related documents, and network them with Wiki-style or static cross-links. Because in DEVONthink Pro Office you are working with databases, you can switch from one document to another with just one click and manage even large projects with ease.
By flagging groups and documents DEVONthink Pro Office can also be used as a very simple outliner. Unlike other outliners, DEVONthink Pro Office uses documents as items and groups for items that have sub-items. Use it with the Split view to create an outliner look-and-feel.
Possible uses:
Continue to read here:
Menus
A complete listing of all commands DEVONthink Pro Office offers in the menu bar, the global Mac OS X Services menu, and the handy Dock menu.
The Application Menu
The DEVONthink Pro Office menu is similar to the application menu in any other Mac OS X application. It contains commands for displaying the splash screen, opening the Preferences window, accessing the Services menu, hiding and showing windows, and, of course, quitting the application.

About DEVONthink Pro Office, ...
Note: For the check for updates no information is uploaded to the DEVONtechnologies server. DEVONthink Pro Office only downloads a file listing the most current versions to your Mac. This option is not available if you have purchased DEVONthink Pro Office on the Mac App Store. All updates are handled by the App Store application in this case.
This command installs or reinstalls a number additional files and scripts.
Note: If you purchased DEVONthink Pro Office in the Mac App Store this menu item may not be available. To open the Install Add-Ons window, click here [special link, not enabled in ebook] instead.

The following options are available:
Check your options and click the Install button to make DEVONthink Pro Office install or reinstall the necessary files and scripts into their repsective locations. If necessary, this command also launches the AppleScript Utility for you so that you can activate the global scripts menu. See chapter Scripts for more information about how to use these scripts.
In addition, this command removes obsolete files such as scripts left over from previous versions.
Options for items that are already properly installed are disabled and marked as 'installed'.
Note: If Index-captured items are contained in the database trash when you use Empty Trash, the option Also from disk will become available. If chosen, it will send the externally linked files to the system trash, too. Caution is advised!
Note: Enter License changes into License and Purchase License into Purchase License or Upgrade as soon as you have entered a valid license code (and a paid upgrade exists). Depending on whether you have purchased your copy in DEVONtechnologies' online shop or the Mac App Store one or more options may or may not be available.
Services
The File Menu
The File menu contains all commands that deal directly with files in your volumes, databases, or files that can be imported, exported, or indexed. Also, the File menu contains commands for printing documents.
New Database: Creates a new database. Give it a name and save it wherever you like in your file system. DEVONthink Pro Office will add the file name extension '.dtBase2' to enable the operating system to recognize it as a DEVONthink Pro Office database package (technically it's a folder).
Open Database: Opens previously created databases. You can select multiple databases. If a database has been saved in version 1.x format DEVONthink Pro Office offers to convert it to the new format.
Open Recent: Presents a list of recently used databases, which is useful to quickly access your frequently used databases. Choose Clear Menu to remove all items from the menu.
New Window
New Window: Opens a new main window for an open database (if only one database is open no sub-menu is available). DEVONthink Pro Office windows present all documents and groups of a database in a Finder-like fashion, and are used to access all stored items. Some views also contain a view/edit pane for easy viewing and editing of documents.
Import: Imports files or complete folders from your volumes into the database. You can find a list of all supported file formats in the appendix. If not stated differently, data is imported to the default destination. Finder labels are honored when possible.
The flexible plug-in architecture of DEVONthink Pro Office allows other import modules to be added. DEVONthink Pro Office comes with the following default import plug-ins:
Import Site: Opens the Download Manager and downloads a complete web page/site for archiving and offline viewing. Make sure the download options are set correctly, especially the options that define which links DEVONthink Pro Office should follow (if any). All links within the site are modified so that they point to the downloaded images or other embedded objects. This ensures that the page/site can be displayed at any time. Groups created by the Download Manager are excluded from tagging by default.
Export: This sub-menu allows you to export selected documents or groups to the file system. File > Export > Files and Folders will recreate the hierarchy you have built in DEVONthink Pro Office almost exactly; metadata files ('.DEVONtech_storage') make sure that no metadata such as comments, URLs, etc. are lost. DEVONthink Pro Office reads these files when importing and so recreates your original data structure.
Identical to File > Import, the Export sub-menu provides additional export methods based on plug-ins. DEVONthink Pro Office comes with a variety of plug-ins for exporting documents in different formats as standard. Currently the following plug-ins are available:
Index: Adds selected files to your database, but only as references, and not in their entirety. DEVONthink Pro Office indexes the contents of the file and uses this for classification and other content-related functions. Indexed items show a little arrow after their name. For unknown file types, this command creates a bookmark. You can also drag files from the Finder to DEVONthink Pro Office; hold down the ⌘ and keys to index them. This is similar to creating an alias in the Finder. Indexed groups are excluded from tagging by default and changes to an indexed document are immediately reflexted in its OpenMeta metadata (and are so noticable by external tagging applications).
Note: External indexed files or folders located in '/System/', '/Library/' or '~/Library/' are never renamed or deleted so that you cannot accidentally cause harm to the system.
Update Indexed Items: This command updates one or more selected groups or documents with their corresponding folders or files in the file system. If nothing is selected the enclosing group of the current group is used. It also reads changes made to the Finder or Spotlight comments of the to-be-updated files and applies them to their counterparts in the database. Finally, this command removes indexed items that have lost their external counterpart. It does not affect items moved manually to the group. Use Update Indexed Items to keep indexed groups and their originating folders in sync or to manually update an item that you have changed directly inside the database package when DEVONthink Pro Office was not running.
To create this connection between the item in the database and the folder or file in the file system, which is maintained by the Path field in the Info panel, you have to freshly import/index your folder of choice.
Select the groups and documents and choose File > Update Indexed Items to import all files that have been newly added to the connected folders in the file system.
Note: The update for groups is one-way only, from the file system to the database, but: when you rename a document its file is renamed, too, and when you change the Spotlight comments of a document this is reflected in the file system as well.
Database Properties: Opens the Database Properties panel for the selected database (if only one database is open no sub-menu is available) that allows you to change properties such as database name, comments, and username/password. Also, you can tell DEVONthink Pro Office to open this database by default.
Close Database: Closes a selected database (if only one database is open no sub-menu is available).
Page Setup, Print
Page Setup: Sets your preferred page size.
Print: Prints the selected or front-most document.
The Edit Menu
The Edit menu contains all commands and options relating to editing. You'll find the classic Mac cut/copy/paste and find/replace commands here, as well as many more.
Undo and Redo
Undo/Redo: Takes back your last action or redoes it. Undo and Redo work for most actions.
Cut/Copy/Paste: Do exactly what they're supposed to do.
Copy URL: Copies the URL of the selected or front document to the Clipboard.
Copy Item Link: Copies a URL to the Clipboard that links to the selected or front item. This URL can be pasted into other documents in other applications to create a link to the item in DEVONthink Pro Office.
Paste with Current Style: Pastes text from the Clipboard into rich text documents, disregarding all styles from the clipped text. Useful for pasting text from other applications or documents with a style that differs from the target document.
Delete: Deletes the selected piece of text.
Complete: Tries to auto-complete the partial word before the insertion caret. This standard Mac OS X function uses the currently active dictionary, which you can change via the spell check panel (see below).
Select All/Deselect All: Selects or deselects the complete content of the front document.
Document editing
Tags: Shows the Tags bar (if necessary) so that you can enter your tags immediately.
Split Document: Splits the current document (PDF, plain or rich text) at the insertion mark position.
Sheets: Use this sub-menu to add new rows or new columns to a selected sheet, edit, or delete columns. You can select multiple columns in a sheet with ⇧ and ⌘ pressed.
Insert Blank Page: Inserts a blank page into the PDF at the position selected in the sidebar.
Delete Selected Page(s): Deletes the page(s) selected in the sidebar.
Rotate Left/Right: Rotate a selected image or page left and right.
Summarize
Summarize: Summarizes the selected piece of text. Unlike Mac OS X's Summarize service, this command takes advantage of the built-in AI of DEVONthink Pro Office, and uses the complete 'knowledge' contained in the open databases for improving the results. The better your databases, the better the results.
Find: This sub-menu contains commands for finding and replacing text as well as for bringing DEVONthink Pro Office's database search field into focus.
Spelling and Grammar: Provides the standard Mac OS X functionality for checking a text for misspellings or bad grammar. To choose the language used for spell checking, or for auto-completion (see above), open the spell checker panel with Edit > Spelling and Grammar > Show Spelling and Grammar and choose your language of choice from the pop-up menu.
Substitutions: Show the standard Substitutions preference panel and switch the available options manually on and off: Smart Copy/Paste, Smart Quotes, Smart Dashes, Smart Links, Data Detectors, and Text Replacements. Data Detectors analyse shown text and make context-sensitive actions available, e.g. when you hover with the cursor over a phone number or postal address. Mac OS X 10.6 'Snow Leopard' or higher only.
Transformations: Use this sub-menu to make selected text all lowercase, all uppercase, or to capitalize every word.
Speech: Starts or stops speaking the selected piece of text.
Insert: Inserts special characters, the current date, and/or time or a picture into your text. Of course, you can only embed a picture into a rich text document, not into a plain text document.
Special Characters: Shows the standard Special Characters panel for inserting characters that you cannot enter directly with your keyboard.
The Data Menu
The Data menu contains all commands that deal directly with documents or groups. Here you'll find commands for creating new documents, labeling, classifying, or grouping them, and more.
New: This sub-menu allows you to create new documents directly from within DEVONthink Pro Office.
New from Template: In addition to these standard document types DEVONthink Pro Office offers pre-defined and user-defined templates that you can use to quickly add new documents to your database. Select any template to add its contents to the current group.
You can add any document to the list of templates using File > Export > as Template.
Some of the pre-defined templates are so-called 'smart templates' or 'template packages'. They consist of an AppleScript or folders containing files for every supported language that takes care of choosing the right template variant for your language, adds them to your database, and modifies it, if necessary. Some smart templates add the current date, insert the clipboard contents, check if a needed application is installed, or even access your Address Book and fill in your personal details from your card. [Read more...]
Use Open Templates Folder to open the folder containing the template files in the Finder and Update Templates Menu to update this menu when you have added new templates or made changes to the existing ones. Use More Templates to install additional templates.
Open: Opens the selected document or group in a separate document window. For groups, this command opens a second main window rooted to the selected group.
Open in Tabs: Opens the selected items in a new tab. You need have more than one item selected for this command to have an effect.
Open with >: Opens the selected documents in the application you choose from the sub-menu. You can edit the document in the external application, DEVONthink Pro Office automatically synchronizes the file when it is being saved to disk by the other application. If you have quit DEVONthink Pro Office in the meantime, use File & Synchronize on the document to update it.
Launch, Reveal, Show
Launch URL: Opens the file, folder, or Internet location indicated by the URL field in the Info Panel.
Reveal: Reveals the location of the front-most document in either the same main window, if possible, or by opening a new one.
Show in Finder: Opens a new Finder window for the folder, including the front or selected documents. Naturally, this only works for documents referring to a file in the file system through the Path field in the Info panel.
Save
Save/Save All/Revert To Saved: These commands save the front document, save all documents, or restore the front document to the version that was last saved.
Label: This sub-menu allows you to mark the selected groups or documents with one of seven labels, just as in the Finder. You can define the color and the text of the labels in the Preferences, Colors tab.
Mark: This sub-menu allows you to mark the item as flagged/unflagged, locked/unlocked, and read/unread. Items marked as unread show an unread marker in most views. [Read more...]
Duplicate: Creates a duplicate of the selected items. The name of the new item ends in 'copy' and both items are shown in bold and blue because their contents are identical.
Replicate: Creates a replicant for the selected items. Unlike a duplicate or alias, a replicant is like a second phone book entry for the same person (aliases are little files containing a link to the original file). When you replicate a group or document in DEVONthink Pro Office, you end up with two replicants, not one alias and one original. Both items have the same name and are shown in red.
Merge: Creates one big document out of several selected ones. This works not only for text documents, but also for images, PDFs, sheets, and multimedia items. All the original documents are embedded in the resulting document and all tags are added, too. If the selection contains only images, PDF or PostScript documents DEVONthink Pro Office generates a PDF file, otherwise a rich text document. Document types that cannot be merged, e.g., bookmarks, are ignored. This command can also merge multiple selected groups/tags; here the first group is used as the destination.
Thumbnails: These commands create, remove, or update the thumbnails or custom icons for the selected items. Thumbnails for bookmarks can be created if the Bookmarks option in Preferences, Media tab, is enabled.
Convert: These commands convert PDFs, sheets, HTML documents, RTF/RTFD documents, text documents, web archives, and all other documents for which a Spotlight metadata importer is available, to plain or rich text or to HTML. DEVONthink Pro Office never replaces the original document with a text version; instead, it creates a new document containing the extracted text next to the original item. The Convert > To Rich Text option tries to recreate the original layout.
DEVONthink Pro Office can also convert image-only PDFs (e.g. scanned documents) to searchable PDFs by applying optical character recognition (OCR). Choose Convert > to Searchable PDF to create a searchable PDF from an image-only PDF. The copy is placed next to the selected item, if Move to Trash is checked in the Preferences, OCR tab, the original document is moved to the trash when the searchable PDF has been successfully created.
Group/Ungroup Items: Creates a new group containing all the selected items. This is similar to creating a new group and moving the selected items into it. This command also works in the See Also & Classify drawer. Ungroup does exactly the opposite; it moves all items contained in the selected group one level up and removes the then empty group.
Auto Group Items: This and the following feature Auto Classify are some of the intelligent functions that gave DEVONthink Pro Office its name. It tries to find similarities between the selected documents and then group them accordingly. This is most useful, for example, when trying to create some sort of structure out of a few hundred documents that have been randomly clipped from web sites.
See Also & Classify: Opens or closes the See Also & Classify drawer of a main window.
Auto Classify: This command analyzes the selected documents and tries to find the groups where they would fit best. If a document cannot be classified with certainty, DEVONthink Pro Office beeps and lists it in the Log panel. If DEVONthink Pro Office finds more than one fitting group, it creates replicants in all groups the document fits into. This function works best with a large database that is already somewhat accurately structured.
Note: If the document you are auto-classifying has replicants, these are deleted and the document is only placed into the new locations. This prevents multiple replicants from being created when you are, for example, classifying this document again.
Move to Trash
Move to Trash/Move All Instances to Trash: Moves the selected items to the trash. If you have selected a replicated item, Move All Instances to Trash moves this item and all its replicants to the trash.
The Format Menu
The Format menu contains all the commands and options dealing with all aspects of text formatting. Here you'll find the standard font, alignment, and ruler commands, as well as very special DEVONthink Pro Office commands.
Note: Many commands in this menu only work with rich text documents, as plain text documents do not allow formatting (that's why they're called 'plain' text). Some formatting options are also available for editable PDFs and web archives.
Font: This sub-menu is reponsible for controllig the font as well as the document background color (rich text documents only). Open the fonts panel with Show Fonts, then increase or decrase the font size of selected text with Bigger and Smaller, adjust the text styles and the document background color.
Copy the font formatting of a selected piece of text or the passage of text around the insertion caret with Copy Font. You can then apply the formatting to selected text using Paste Font.
Style: The commands in this sub-menu apply a certain style, such as italics, bold, or underlined, to selected text. Also, the commands give you access to some high-end font control like kerning, baseline shift, ligatures, and character shape (only applicable to Asian languages).
The most interesting part here is Styles, which opens the Mac OS X Styles Editor. You can step through all the styles used in the current document and add them to your favorites. Use the pop-up menu to select a saved style and, if you don't need it any more, delete it. You can use saved styles from the ruler (see below).
Note: If you think the user interface for the styles editor is less-than-wonderful, you're right. But don't blame us, it's Apple's design :-)
Alignment: Align paragraphs left, right, centered, or justified. Here, Asian or Arabic users can also change the direction of writing, if necessary.
Ruler: Show the ruler, which shows the tab stops and contains alignment and styles buttons; copy the current ruler (line width, indents, tab stops, etc.) and paste it somewhere else.
Learn more about the ruler and the Styles Editor here.
Highlight, Highlight Color: In rich text documents, editable PDFs, and web archives use Highlight to highlight a selected piece of text as you would do with a colored pen on a piece of paper. To remove highlighting, select the highlighted piece of text and choose Highlight again. Use the Highlight Color sub-menu to choose your favorite highlight color.
Spacing
Spacing: This command is only available in rich text documents; the command allows you to adjust the line spacing of selected text. You can adjust the line height to an exact value or define a minimum and maximum height, adjust inter-line spacing, and define the space before and after a paragraph.
Note: Paragraph spacings are not added to those of the preceding or following paragraph; instead, the maximum spacings from both paragraphs are used to ensure a proper layout.
Link: Makes selected text a link to a URL (for example, to a web page or to an email address). This is a one-step command for writing the address into a rich text document, selecting the address, selecting Make Link (see below), and then changing the linked text to anything you want.
List: Creates a bullet list. Select your prefix, bullet style, and suffix in the dialog sheet and click OK to insert your list skeleton. In the list, press ⏎ to insert new items and press ⇥ and ⇧⇥ to indent/de-indent items just as you would do in any word processor.
Table: Inserts a new table into a rich text document and opens the table inspector panel. Use the table inspector to adjust the number of rows and columns, cell alignments, cell colors, border width, and color. Also, you can merge and split cells and create tables within a cell.
Link: Makes the selected text clickable and asks for a destination. Enter any valid URL you want the text to link to.
Make/Remove Link: Makes selected text clickable, or removes a link from the current selection. Where you are taken to when you click the link depends on the selected text:
Make Plain/Rich Text: Converts a rich text document to plain text and vice versa. Converting a rich text to plain text removes all formatting, converting a plain text document to rich text applies default rich text font settings to the document.
Invisibles
Show Colors: Shows the color panel, e.g., for changing the foreground color of selected text in rich text documents.
Show Invisible Characters: Toggles display of invisible characters such as spaces, tabs, and line feeds. Shown invisible characters appear in light gray.
Allow Hypenation: Enables or disables hyphenation for the current rich text document.
The View Menu
The View menu contains all the commands for modifying the way DEVONthink Pro Office displays groups and documents.
Views
Using these commands, you switch between different layouts for main windows:
Cover Flow: When checked, DEVONthink Pro Office displays the contents of selected groups in Cover Flow style in the view/edit pane in the Split and Three Panes views. Use it to quickly browse visually through multiple documents. You can double-click the front-most document to open it in a separate document window or you can drag it to other areas, windows, or applications.
Full Screen: Displays either the current document in a full screen mode optimized for reading and editing, or the frontmost window in full screen.
To return to the normal view, press ⌘F7 respective ⌃⌘F7 or the ⎋ key. You define the width of the document full screen view as well as plain text font, background color, and text color in the preferences, Editing tab.
View Layout
Widescreen: Switches Split, Three Panes, and Tag views between standard and widescreen layout.
Show/Hide Sidebar: Shows or hides the main sidebar that lists all open and recent databases, global smart group, the global inbox and the trash.
Show/Hide Details: Switches between displaying icons only or displaying icons together with detailed information such as kind, label, size, words, creation date, and modification date. Available in all windows showing an Icon view.
Show/Hide Tags: Shows or hides the tag bar.
Sort: Sorts items in ascending or descending order by various criteria: name, kind, date added, creation/modification date, URL, path, word count, flag, label, width x height, duration, location (enclosing group hierarchy of the item), aliases, and Spotlight comment. Also, you can choose to sort items manually, Unsorted, and to ignore umlauted characters when sorting elements. DEVONthink Pro Office remembers sort settings for every group separately and used when the group is displayed in its own main window.
Columns: This sub-menu lists all columns available in the current view and allows you to show or hide them individually. Use these options to show exactly the information you currently need.
The State column shows the state (flagged or unflagged). Clicking the flag or the empty spot for the flag toggles the flag. Unread items are marked as read when the 'unread' state is clicked.
Both Sort and Columns support a range of metadata fields next to DEVONthink Pro Office's own data fields.
Expand and Collapse
Expand and collapse all groups at once.
Actual Size: Depending on the document type you can zoom the document to your needs:
PDF Display, Text Alternative
PDF Display: This sub-menu lets you adjust the way PDF documents are displayed.
Text Alternative: Toggles between a graphic preview of a document, e.g. generated by Quick Look, named the 'Best Alternative', and a text-only alternative, 'Text Alternative'. For some document types, e.g. email messages, the Quick Look preview does not permit you to click links or copy text; the text alternative allows this.
Hide/Show Toolbar: Hides or shows the toolbar of the front window.
Customize Toolbar: Lets you configure the toolbar of the front window.
The Go Menu
The Go menu contains all commands for navigating the hierarchy of your DEVONthink Pro Office database. Use these commands to go backwards and forwards through your documents, or to move back to the top level of the group hierarchy.
Top Group, ...
Top/Enclosing Group/Selected Group: Goes back to the top level of the group hierarchy, to the group enclosing the shown group (if any), or to the selected group ('hoist'). These commands are only useful when you have opened a group in a second main window, so that the 'root' of the window is not the top group of database, or when you are using DEVONthink Pro Office in outline-style.
Back/Forward: Moves backwards and forwards through all documents/web pages you have visited by following cross-links or Wiki-style links.
First/Previous/Next/Last Document: Navigates to the first, previous, next, or last document of all documents in the current group. Useful when you have opened a document in a separate window and want to move to another document in the same group. Also works in the Three Panes view and in Search windows.
Instances, Highlights
Previous/Next Instance: Navigates backwards and forwards through all instances of a replicated document. Use these commands to find out where the other instances of a replicated item are. Alternatively you can use a smart group to find all documents that have replicants.
Previous/Next Highlight: Navigates backwards and forward through all highlighted passages within a document, regardless of whether these passages have been highlighted by a search run or manually using Format > Highlight. Use these commands to visit all found text passages or highlighted passages in a document.
Page: Navigates to the page with the entered page number.
Workspaces
Workspaces save the content and positions of all open windows so that you can restore them later. This is, e.g., ideal if you are working with the same set of windows over and over again. Save them as a workspace and recall them whenever you need them again.
The Tools Menu
The Tools menu contains the more sophisticated tools, such as the advanced search function, the concordance, the history panel, and the log, as well as commands for keeping your database healthy and for showing the Info and the Groups panel.
Search Tools
Search: Opens the Search window. Using the search function you can search your database in a variety of ways, from searching for a document by name to a full content search. Using its built-in AI, DEVONthink Pro Office also assists you in formulating the right query.
DEVONagent Pro: Opens DEVONagent Pro, DEVONtechnologies' smart Internet research tool. If the current document has a URL attached, this URL is opened in DEVONagent's built-in web-browser.
Panels
Show Info: Opens the Info panel which shows basic information about selected items. As it is a panel, selecting a new item updates the Info panel accordingly.
Show Properties: Opens the document properties panel. View or edit the front-most document's properties such as author, subject, or keywords.
Show Groups: Opens the Groups panel. You can use this panel to always have your group list handy, for example for dragging text clippings or documents from DEVONthink Pro Office or other applications to a group.
History: Opens the History panel for a selected database (if only one database is open no sub-menu is shown) that lists all documents in the selected database sorted by modification date. You can use this panel for quickly finding newly added documents or by their age.
Concordance: Opens the Concordance window for a selected database (if only one database is open no sub-menu is shown). The concordance lists all words in the database sorted by frequency. Use it to analyse your accumulated knowledge or to find the most common words.
Like any database, DEVONthink Pro Office needs a bit of maintenance from time to time. All commands you'll need for database maintenance are to be found here.
Verify & Repair: Verify all database structures and repair them if necessary. Use this whenever you feel it is necessary. By default, DEVONthink Pro Office automatically verifies the database structure every time you open a database, and advises you to run this command when it finds significant errors. Orphaned files found during repair are placed in a group 'Orphaned files' in the top level of the database.
Backup & Optimize: Create an internal backup of the database and then optimize the database structure. Optimizing removes unnecessary internal elements from the database and rebuilds the internal structure to optimize the performance. DEVONthink Pro Office also creates internal backups on a regular basis depending on the settings in the Preferences, Backup tab. Internal backups only back up the index structures in case the index gets corrupted. Please use an external backup software to create backups of your complete database including all documents.
Restore Backup: Restore an internal backup. Choose the backup you want to restore from the dialog window and click Open. You can identify backups by their creation date.
Note: Restoring a backup simply swaps the current database and the backup. The backup becomes the active database, the former database a backup. You'll never lose any data by using this command.
Rebuild Database: Completely rebuild the database by deleting the index and rebuilding it from scratch. This removes any structural problems. Depending on the size of your database, this can take from a few seconds to several hours. You can rebuild any database including the inbox.
Sorter
Shows or hides the Sorter.
Take Note: Opens the Take Note panel that lets you quickly enter a plain text note and add it to the default destination.
The Window Menu
As in any Cocoa application, the Window menu lists all open windows of the active application and gives you access to commands for managing them.
Window commands
Close, Zoom, Minimize: These three commands resemble the red, yellow, and green buttons of any window title bar, and consequently close the window, minimize the window to the Dock, or maximize the window. No magic here. Hold the key to change Minimize to Minimize all.
Close, Select Next/Previous Tab: Closes the active tab or moves the focus to the next or previous tab. Tabbed browsing needs to be enabled for these commands to work.
Bring All to Front: Brings all windows of DEVONthink Pro Office to the front. Hold the key to change Bring All to Front to Arrange in Front.
Window List: Select any open window from the menu to bring it to the front.
Download Manager
Download Manager: This command opens the Download Manager panel of DEVONthink Pro Office. Using the Download Manager, you can download files, or even complete web sites, from the Internet and store them directly in your database.
Log: Opens the Log panel. The log lists error messages and warnings that occurred while importing new documents. It also opens automatically when an error occurs. You can save the log to a text file or clear it.
Activity Panel
Activity: Opens the Activity panel. It shows all running processes and allows you to manually stop them if necessary.
The Services Menu
The DEVONthink Pro Office > Services menu allows access to special commands published either by other Mac OS X applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService. Also, DEVONthink Pro Office publishes its own services in the Services menu.

DEVONthink Pro Office services
DEVONthink Pro Office installs several services for copying selected text, summarizing text, capturing a web page, or looking up documents in the database.
Add to DEVONthink: Adds selected files, bookmarks, or images to your database. This service is e.g. available in the Finder's contextual manu.
Take Plain/Rich Note: Adds selected text from any application that support services (!) as plain or rich text to the global inbox. Taking a rich text note also copies images and clickable links. If the source document is a web page or a news feed, it tries to capture the address of the page or feed as well. This only works with applications that support this, such as Safari, DEVONagent Pro, or NetNewsWire.
Capture Web Archive: Captures the web page displayed in the front-most window of any WebKit-based browser (such as Safari or DEVONagent Pro) as a web archive to DEVONthink Pro Office's inbox. This menu item is only shown when available, e.g., when Safari is the active application.
Append Plain/Rich Note: Adds selected text as plain or rich text to the last note taken using the DEVONthink Pro Office Services menu items.
Lookup: Opens the Search window in DEVONthink Pro Office with the selected text copied as search term.
Summarize: Creates a new note in DEVONthink Pro Office's inbox with a summary of the selected text. DEVONthink Pro Office uses all documents in the open database for determining what's important and what is not. The summarization settings in the preferences, Editing tab, define whether the summary shall be based on sentences or paragraphs.
The Sorter services
The Sorter adds another sub-menu to the Services menu that contains a Send To Inbox command. It copies the current selection to the Sorter's inbox, if possible.
Note: After installing DEVONthink Pro Office you need to log out and then log back in again for new services and their shortcuts to be recognized. If one or more DEVONthink Pro Office Services menu commands do not carry a shortcut, then maybe another application grabbed them. Mac OS X will assign the correct shortcut when no other application claims posession of the same key combination.
The Scripts Menu
The Scripts menu is located left of the Help menu and shows a stylized AppleScript 'S' symbol instead of a normal menu title. It contains a collection of useful, predefined AppleScripts you can use directly from within DEVONthink Pro Office.

Some of the scripts work without having selected a document, while others require you to select the document you want the script to interact with. In general, the script will tell you what you have to do when you select it from the Scripts menu.
Use More Scripts to install additional scripts.
Read more about scripts and the DEVONthink Pro Office Scripts menu here.
The Help Menu
The Help menu contains commands for opening the integrated help pages, the support assistant, or visiting the DEVONtechnologies website.

DEVONthink Pro Office Help
These commands open the integrated help pages that are equal to the document you're just reading or open the release notes. In addition, they direct you to the bookmarklets installation page
Opens the support screen of the Welcome to DEVONthink Pro Office assistant where you can e.g. get support, retrieve your license code, request a trial extension, or update your details in DEVONtechnologies' customer database. You can also install additional scripts or templates from the assistant.
Note: If you have purchased DEVONthink Pro Office on the Mac App Store all options dealing with licenses or upgrades are not available.
DEVONtechnologies
These commands take you directly to the corresponding pages on the DEVONtechnologies web site. Visit our home page or the lively user forum. If you have a question or suggestion, send feedback directly to our development team.
The Dock Menu
The Dock menu appears when you click DEVONthink Pro Office's icon in the Dock with the ⌃ key pressed, or when you right-click it. On Mac OS X 10.5 'Leopard' you can also left-click and hold the mouse button for one second or longer.
DEVONthink Pro Office's dock icon also displays a badge with the number of new items, e.g., after adding new data via the Services menu the bookmarklets, or scripts. Longer tasks, e.g. importing, indexing, or running scripts, show a progress indicator on the dock icon, too.

For all Mac OS X applications, the Dock menu provides a selection of the commands of the application menu.
Besides these standard commands, DEVONthink Pro Office adds a number of its own commands to the Dock menu to make them easily accessible whenever the application is running.
Windows and Panels
DEVONthink Pro Office communicates with you through a number of windows. These windows are used for displaying and manipulating groups and documents, finding information, editing metadata, analyzing text, or changing the properties of your database.
Main Window

Most of the time you spend in DEVONthink Pro Office will be spent in a main window. Like Finder windows, main windows give you access to your groups and documents, while also allowing you to view and edit documents.
Open a new main window with File > New Window. DEVONthink Pro Office also opens a new window when you open a database; do this by checking Open New Window in Preferences, General tab.
The title of the window shows the name of document or group if one is selected as well as its icon. Drag the icon, e.g. to the Finder, to copy the document and click, with ⌘ pressed, the title bar to reveal the document's location within the database. Select an enclosing group to reveal it.
Different views present your information in exactly the way you need:
To adjust the size of the different panes, move the mouse to the divider between two panes until it changes into a line with two arrows. Then, click and drag the divider to adjust the size of the panes.
In the sidebar, which you can show or hide via View > Show/Hide Sidebar, DEVONthink Pro Office lists:
Use the sidebar to quickly access your open and recent databases as well as the
global inbox, your favorite databases, groups and news feeds, smart groups, and the
trash. Select an open database to switch to it, double-click a recently used database to open it. Read-only databases are marked with a read-only icon. Items dragged to a database in the sidebar are placed in that database's inbox. Collapse or expand sections using the collapse triangles.
Using the contextual menu you can create new databases, open and close them, empty the
trash, create smart groups, open the Database Properties panel, and add databases to or remove them from the Favorites. For the
Inbox, most database-related menu commands are available, too, such as Tools > History or Tools > Concordance. An action menu and a + button give access to commonly used functions, too.
In addition you can use drag-and-drop to move items to the
Inbox or the
trash or add groups or news feeds to the Favorites. When you select a group in the Favorites, DEVONthink Pro Office will show that group's contents and even open the database that contains it if necessary. When you drag a smart group to the sidebar it will be copied to the sidebar; double-clicking a smart group opens the smart group editor for it.
For the
Inbox and the
trash DEVONthink Pro Office always shows the number of items contained, independent from the preferences. The Recent databases segment does not show databases that are also a favorite to prevent listing them twice.
The sidebar's width and visibility is specific for each database.
Items
DEVONthink Pro Office displays groups and documents, much as the Finder does. Select items with a single click, drag them with the mouse from one group to another. You can also drag items to the Finder or any other application, or drag folders and files from the Finder to DEVONthink Pro Office. You can also drag clippings such as text and images from any application to DEVONthink Pro Office and vice versa.
Press the ⌘ and ⌥ keys to link to the dragged item(s) instead of importing them to the database. Single-click items to rename them. Double-click items to open them in a separate document window or in the external application that has created it (depending on the document type). For smart groups, double-clicking them in any view except Icons view opens the Smart Group Editor for them. Press the Space bar to preview the item using Quick Look; close the preview with the close gadget or press ⎋ or Space again to close it.
Colored item names, colored group icons, and special icons tell you whether an item is a duplicate or replicant, about its 'unread' status or what type of search a smart group uses.
In addition, icons indicate whether a item is locked, has an attached comment or script, or has been indexed instead of having been imported. [Read more...]
To view or edit the contents of a document or group, do the following:
The view/edit pane (not visible in icons and list view) shows the content of the selected document and allows you to edit it, if possible. You can edit plain text, rich text, and HTML pages.
Read more here about the various document types that you can view or edit in the view/edit pane.
Info Bar
Just below the toolbar you'll find the info bar. For selected items it shows icon, name including location, kind, size, and modification date. If you're not sure of what kind a document is, this is the place to look.
Adjust the size of icons with the slider in the right side of the info bar.
The toolbar of DEVONthink Pro Office main windows carries many commands for manipulating the way the application displays information, as well as for manipulating selected items. Many of these items in the toolbar are simply shortcuts for menu commands. Here's a short list of the available tools:
Note: Not all of these commands are always available. You can customize the toolbar by selecting View > Customize Toolbar or by clicking with ⌃ pressed (right-click) the toolbar background and selecting Customize Toolbar from the contextual menu.
Shortcuts & Modifier Keys
You can use a couple of shortcuts and modifier keys for group and document icons in both the item list and when displaying a group's content in the view/edit pane.
The contextual menu (which appears when you right-click or ⌃ click an item) offers a range of commands tailored to what you wish do with the clicked object (for example, a text passage).
Most of the commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONthink Pro Office gives you access to some options only via the contextual menu.
In the Tags view, the following commands are available:
In the sidebar, the following commands are available:
Note: For your convenience, DEVONthink Pro Office also makes the Services menu, available via the contextual menu.
Document Window
A document window is more or less similar to the view/edit pane of a main window. You open a document window by double-clicking a document in any view of a main window or by choosing Data > Open (or any of its equivalents in contextual menus).

Depending on the type of information the document contains, the toolbar of a document window offers different set of tools. Most of them are identical to their counterparts in the DEVONthink Pro Office main window toolbar.
See the Documents chapter for a detailed description of the various document types.
Search Window

Search windows allow you to search your database in almost every way possible and assist you with intelligent functions for broadening and adjusting your search terms.
In the top part of the search window you find the search term field as well as the Similar Words button. To enter a search term and run the query with the default options, simply type your search words into the search term field and click the magnifier button (right of search field). Like in many other Mac applications, the pop-up menu (behind the magnifier icon at the left side of the search term field) gives you access to the last 25 search terms.
DEVONthink Pro Office uses Boolean operators, parenthesis, and quotes to allow complex structured search terms. Read more about operators and how to use them to write a search term in the appendix.
To broaden or adjust your search words, enter a word and click Similar Words to show a list of all words in the database that are similar to the entered word either by spelling or by context. Choose one or more words (use ⇧ and/or ⌘ to select multiple words from the list) to use them as search words. Multiple selected words are combined using the OR operator (spelling) or AND (context). The word you've entered will be shown on the top of the list, so you won't lose it for your search run. This functions use all open databases for retrieving similar words.
The left side of the search window gives you even more control over the way DEVONthink Pro Office searches the database. Adjust these options to best fit your needs.
Search for: Choose what exactly you're looking for or select All to search all parts of a document:
Comparison: Make DEVONthink Pro Office treat regular letters and their counterparts with umlauts or diacritics equally. Check Fuzzy to make searches fuzzy (e.g. 'Hello' and 'Hullo' would both be found). Note: This option is only applied to words but not to wildcards.
State: Limits the results based on their status (flagged/unflagged). Choose Any to find results regardless of their state.
Unread: Limits the results based on whether they have been marked as read or unread. Choose Any to find results regardless of their read status.
Locking: Limits the results based on whether they are locked or not (on/off). Choose Any to find results regardless of their locking flag.
Label: Limits the results based on their label. Choose Any to find results regardless of their label.
Search in: Limits the scope of the search run to all open databases, a selected database, or a selected group.
Note: To search for all documents with a given status, locking state, or label, simply leave the query field empty and use the above options to define what you are looking for.
Advanced: This button lets you enter advanced search criteria in the same way you do for smart groups. Use this to search e.g. for tags or date ranges. The Reset buttons clears the set advanced criteria. [Read more...]
Search Results
After a successful search run, DEVONthink Pro Office lists all found documents below the search term field, and displays them in a list together with their score (relevance compared to the query), their icon, location in the database, modification date, document kind, and size. Sort the list in any way you want by clicking the column titles, click them again to reverse the sorting order. Modify the shown columns using the contextual menu or View > Columns. Point the cursor to a result and the appearing tooltip will show you the full title, location, and other metadata; click a document title once to rename the document.
Below the list of found documents, DEVONthink Pro Office gives you a preview of the documents you select in the list. If you cannot see the preview area, drag its handle up from the bottom of the window. Also, you can do almost everything you could do in any other DEVONthink Pro Office window, such as drag a document to another window (or Finder), or export them using File > Export.
See also/Classify and Concordance drawers are supported, too.
Due to limitations in Mac OS X's PDFKit, highlighting of occurences of the search term in the document is not tied to words and so also sub-strings are highlighted.
Smart Groups
When you are satisfied with the search results you can save the query including all settings as a smart group. Click the + button next to the search term field and enter a name for your new smart group. The new smart group that searches this database is created in the top level of the database. A smart group that searches all databases is placed into the sidebar.
Toolbar
The toolbar of the search window offers many tools that are also present in DEVONthink Pro Office main or document windows. Here's a short list:
Note: Not all of these commands are always available. You can customize the toolbar by selecting View > Customize Toolbar or by ⌃ clicking (right-clicking) the toolbar background and selecting Customize Toolbar from the contextual menu.
Shortcuts & Modifier Keys
Contextual Menu
You can manipulate the search results by right-clicking or clicking them with ⌃ pressed to open the contextual menu, which offers various additional commands.
Info Panel
The Info panel, just like its counterpart in the Finder, displays additional information about a selected document or group, from icon and name to comments and other metadata.

Open the Info panel using the i icon from the window toolbar or by selecting Tools > Show Info. The contents of the Info panel corresponds to the currently selected object, so you can leave it open all the time and it will always display the correct information for the selected document or group.
Head Elements
Icon and Name: Just like in the Finder, the top part of the panel displays the icon and the name of the selected object. To change the icon of the document, select it and paste any image you want over it. To change the name of the document, use the Name field below.
Locked: The Locked checkbox indicates if the object is write-protected. Check the checkbox to protect the document or group from being accidently modified. Locked documents or groups show a little padlock after their name.
Main Attributes
Name: Use this field to change the name of the object.
Aliases: Enter one or more words here, separated by semicolons, as alternative targets for Wiki-style links. Generally, Wiki links refer to the name of contents and aliases make this system even more flexible.
Path: This field contains the path to the file holding the document's data. It is non-editable. You can click the @ button to open the references file using the Finder. In general this is equal to using Data > Open With and choosing the default application.
URL: Smiliar to the Path field, the URL field is used to link the document to an Internet address or just anything else that can be reached by a URL. This field is used primarily by bookmarks, but you can also use it to connect a document to a web page. To visit the web page click the @ button next to this field or select the document and use the contextual menu command Launch URL.
Attached script
Script: This field allows you to attach an AppleScript script to any item in DEVONthink Pro Office, documents as well as groups. The script will be executed every time you view the item in a Split view or Three Panes view as well as when you open it in a separate document window. Click the Select button to choose the script to attach.
Information elements
Size: Shows the size of the item. For groups and news feeds this field shows the size of all contained items.
Kind: Shows of what kind the selected document is (for example text, RTF, etc.)
Added: Shows the date when the object was actually added to the database.
Created, Modified: Shows the dates when the object was created and when it was modified the last time.
Additional Information
This section lists metadata that has been stored together with the item. What information is shown depends on the file type as well as the individual document.
Exclude from ...: These checkboxes allow you to exclude this item from being used in classification, see also, search, or tagging. Use this to exclude, e.g., temporary groups from classification to increase the accuracy of the built-in artificial intelligence.
Label: Shows the label that this item has been assigned and lets you change it.
Tags: Shows the tags that this item has been assigned. You can also edit tags here. [Read more...]
Location: Shows the location of this item inside the database.
Instances: Shows how many replicants of this document or group exist in the database and how many duplicates DEVONthink Pro Office has identified. Click to show a pop-up menu listing all instances and duplicates and their enclosing groups. Select any item to reveal it.
Spotlight Comments: Stores any other information you want to attach to your document or group, similar to the Spotlight comments field in the Finder. Of course, the Comments field is searchable. DEVONthink Pro Office synchronizes the Spotlight comments in the Finder with this field in the database.
Note: You can modify the comments of multiple selected items at once as long as the comment of all selected items is either identical or empty.
Document Properties
The Document Properties panel gives you access to all metadata stored for a selected document. This metadata includes but may not be limited to:

Depending on the document type you can edit or only view these properties. Also, more fields can be available depending on the document type.
Concordance
The Concordance window, opened with Tools > Concordance, gives you a tool for analyzing the contents of a database.

Use the concordance to analyze your data by:
Concordance List
The concordance list shows a list of all words in the database, sorted by frequency or any other criteria, by clicking the according column title. Click the column title again to reverse the sorting order.
You can also filter the list by word length, limiting it to alphanumeric strings (to omit character/number combinations) by entering the minimum and maximum word length at the bottom of the Concordance window and by checking/unchecking the Alphanumeric switch. Click the Update button at the top of the window to update the list after you have changed some parameters.
To find a word in the list, enter it into the search field at the top of the window. Select any word, and click the Search button at the bottom of the window to open a drawer containing all documents that contain this word, sorted by relevance. Click Similar to show a list of words that are contextually similar to the selected word.
Drawers
You can manipulate the items in the drawer opened by the Search button in various ways. Drag them to the item list to move them to another location, double-click them to open them in a separate window, or ⌃ click (right-click) them to open the contextual menu (which shows basically the same options as the contextual menu for See Also drawers). Press Space to show a Quick Look preview for the selected item. To close the drawers, click the red close button.
Frequency Graph
You can switch between the frequency graph and the concordance list by clicking the Graph and List buttons in the upper left corner of the concordance window.
The frequency graph shows a graph of the word frequency over the rank number of the word (see above). Change the sorting in the concordance list to get different results, such as a graph of frequency over number of groups. You can influence the graph also by limiting the word length or by omitting alphanumeric strings and clicking the Update button.
Download Manager
Window > Download Manager opens DEVONthink Pro Office's Download Manager panel. Using the Download Manager, you can download files or even complete web sites from the Internet and either store them directly in your database or as files on your hard drive.

Panel Elements
The Download Manager panel consists of:
Adding Files
To download a web site or any other file, simply add it to the Download Manager by dragging its URL to the Download Manager panel. Alternatively, you can click the + button in the panel and add the URL yourself as well as a referrer, user name, and password. If Automatic is checked, DEVONthink Pro Office creates a referrer automatically when downloading whole web sites.
You can also paste one or more URLs (for example, copied Safari bookmarks, DEVONthink Pro Office links, or copied links from DEVONagent Pro's Download Manager), or add files to the Download Manager by using the contextual menu in web and HTML views. ⌥ clicking a link also adds it to the Download Manager.
Note: You can also copy URLs in the Download Manager to the Clipboard or drag them to other applications (like the Finder or Safari's bookmark manager). The Download Manager als supports URLs for local files (POSIX path, a 'file://localhost/' URL, or a 'file:///' URL).
The Action Menu
Most actions are available through the Action menu or the contextual menu. Click the gear button or ⌃ click an item in the Download Manager panel to display more commands:
For your convenience, DEVONthink Pro Office comes with predefined option sets that you can directly select from the action menu.
Note: Downloaded items are by default excluded from classification and tagging.
The options dialog defines which file types the Download Manager should download, which links it follows, and where it stores the files.
The Follow Links options defines how far DEVONthink Pro Office follows links on the downloaded HTML pages, and so allows you to control if only the actual pages get downloaded or a complete web site. DEVONthink Pro Office supports the following options:
History
The History panel, opened using Tools > History, lists all documents in your database in one long list, such as without the groups hiearchy (by default sorted by modification date which reflects content modifications only but not name or metadata changes).

Sort the list by name, age, or file size by clicking the column titles (click again to reverse the sorting order), and by any other criterum using View > Sort. Customize the columns using View > Columns.
Of course, you can use drag-and-drop to move documents to other windows or the Finder and modify them using the commands in the Data menu as well as the contextual menu.
Use the History panel to quickly access recently added documents or to export all documents of a certain age.
Groups & Tags
The Groups & Tags panel, opened using Tools > Show Groups & Tags, gives you direct access to all open databases and their groups including the tags inside the special Tags group. Use it, e.g., to drag items directly to a group or tag or to rearrange groups. You can also apply menu commands to selected items, e.g. Data > Open.

Depending on your Preferences, General tab, the Groups & Tags panel floats above all other windows even in other applications.
Take Note
The Take Note panel, opened by hitting a hot key, from the toolbar, or the Tools menu, allows you to quickly enter a note, choose the destination for the note, and add tags and a URL to it. If DEVONthink Pro Office can get the URL of the frontmost application, e.g. from Safari, it will also insert it automatically into the URL field.

Check Rich Text to take a rich text note. Use the Format menu to style your note.
Change the hot key for opening the Take Note panel in the Sorter preferences.
Note: For this function DEVONthink Pro Office needs to be running. This may change eventually.
Log
The Log panel displays warnings and error messages that occur, for example, when importing files and folders. It shows the date of the message, the affected file, and a short information about what happened.

You can save the list to a text file with the Save button, and clear the log with the Clear button. To sort the log, click the according column title (click again to reverse the sorting order). Use the contextual menu or double-click the entry to reveal an affected file in the Finder.
Uncheck Show log automatically to prevent the log popping up automatically. You can open the Log panel at any time using Window > Log.
Right-click or click with ⌃ held to perform additional commands on log entries via the contextual menu, e.g. to reveal a logged item.
Activity
The Activity panel shows a list of currently running background processes, e.g. converting scans to searchable PDFs, refreshing news feeds, and downloading PDF documents and web archives (e.g. via bookmarklets or Clip to DEVONthink. You can manually stop them if necessary, e.g., to free computer resources.
Preferences
The Preferences window, opened using DEVONthink Pro Office > Preferences, contains all available options that you can modify to adapt DEVONthink Pro Office to your personal needs.
Because the preferences are so important, we have created a separate chapter for them.
Database Properties
The Database Properties panel defines preferences which are directly related to the database and not to the application in general. Open the properties panel using File > Database Properties for every open database including the global inbox.

Location
This part of the properties panel shows the location of the database package as well as additional options:
Location: Double-click any part of the database location to reveal it in the Finder.
Use as Default Database: Check to open this database every time you open DEVONthink Pro Office.
Create Spotlight Index: Check to make this database available to Spotlight. Checking this option lets DEVONthink Pro Office create a folder in '~/Library/Cache/Metadata' that Spotlight uses for accessing the documents in the database. If you feel that this folder got out-of-sync with the database, click Rebuild to completely recreate this folder from scratch.
When viewing Spotlight results in a window, make sure to have the Show all file extensions option in Finder's Preferences, Advanced tab unchecked. If this option is checked, the Finder displays the generic names of the metadata cache files instead of the name of the referenced document.
Starting with version 2.0.6 DEVONthink Pro Office adds information to the Spotlight metadata that make it possible to preview many file types directly from the Spotlight results window in the Finder. Supported are text and rich text (RTF and RTFD), image, movie, audio, PDF, HTML, XML, and web archive files. DEVONthink Pro Office needs to be installed on the machine viewing the Spotlight results. You may need to rebuild the Spotlight index for this functionality to become available.
Note: Rebuilding the Spotlight index can be, e.g., necessary after copying a database from one computer to another or after using a third-party utility like DevonSync.
Share Database: Check to make this database searchable and browsable through the web server.
Exclude Groups from Tagging: Excludes all groups in this database from being used as tags. Ordinary tags can always be added to items using the Tag bar.
Statistics
This section displays some basic statistics on how many documents you have stored in your database, how large they are, etc.
Name and Comments
Name: Enter a name for your database here. It will appear in the title bar of every main window for this database.
Note: This does not change the file name for the database package. You cannot change the name of or add commments to the database representing the global inbox.
Comments: Enter your own comments about the database here, e.g. a project description.
Protection
To prevent other people from opening DEVONthink Pro Office and accessing your data, click on the padlock button to unlock the entry fields, enter a user name, and your private password, and then click on the padlock button again to lock your changes and hide the password.
Note: This is a simple password protection. DEVONthink Pro Office does not yet provide file encryption for enhances security. For better protection, create an encrypted disk image using Disk Utility and store your database on it.
Assistant
The integrated Assistant combines a welcome screen with tips, tricks, and tutorials, installable extras, and a suppport page that guides you through the available support options.

Welcome
This screen welcomes you when you start DEVONthink Pro Office for the very first time. It offers:
You can access all other screens of the assistant from here, too.
Get Support
The support screen guides you through the three common steps for troubleshooting DEVONthink Pro Office. In addition you can have your license code resent in case you don't have it anymore, request a trial extension, update your details in DEVONtechnologies' customer database, or buy an upgrade or a second license.
Tips and Tutorials
Here you can always find the latest tips sand tutorials that help you squeeze the best out of DEVONthink Pro Office. Tutorials can be slideshows describing basic tasks in DEVONthink Pro Office or videos (as they become available).
Both tips and tutorials are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest tip or tutorial is also always mentioned on the welcome screen.
On the extras screen DEVONthink Pro Office lists all available extras that you can download and install from DEVONtechnologies' server:

Browse the list of extras and install them with the Install button. The last line of the description shows where in e.g. the Scripts or Templates menu the extra will show up after installation. Remove installed extras with the Remove button.
The extras are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest extra is also always mentioned on the welcome screen.
Note: If one of these categories does not show up in your copy of DEVONthink Pro Office there might be no extras of this type (yet) available for DEVONthink Pro Office.
Documents
All documents are displayed in DEVONthink Pro Office in views. Each view features its own tools, contextual menu commands, and hidden keyboard shortcuts, as explained in this chapter.
General
All documents are displayed within DEVONthink Pro Office in views (not to confuse with the different layouts in main windows, also called views. Each view (for example, a text or PDF view), has its own tools, contextual menu commands, and hidden keyboard shortcuts. Some views, like the text view, also allow you to edit the document, while others like the PDF view, only display the selected document.
Currently, DEVONthink Pro Office features the following view types:
At the top of the view/edit pane DEVONthink Pro Office shows a navigation bar that gives you access to some additional tools that deal directly with the contents of the document. Which tools are available depends on the type of the document.
The text-only mode can be useful to select text in items that are displayed using Quick Look or to view or edit the source code of an HTML document. In preview mode DEVONthink Pro Office uses Quick Look to show e.g. Pages documents in their original layout. Select any word from the
menu to show documents also dealing with this keyword.
The Tag bar, which can be shown or hidden, shows all tags associated with the document. Click the tag bar and type to add tags, select a tag and press the Delete or Backspace key to remove it. [Read more...]
When you type the name of a tag, DEVONthink Pro Office offers automatic completion. Choose the right option with the mouse or the arrow keys and press ⏎ or Enter to accept it. Press ⎋ to use whatever you entered. Auto-completion prefers ordinary tags (tags represented in the Tags group) over groups used as tags. Press ⇥ to enter another tag.
Note: The Tag bar is also visible for multiple selected documents when all documents have the same tags attached. Use it to change the tags for multiple documents.
Toolbar
DEVONthink Pro Office can display documents in separate windows when you double-click the documents in a main window. Depending on the type of document, the tools in the toolbar can change. Even though not all tools are always present in the default toolbar for a particular view, you can easily add them by choosing View > Customize Toolbar.
Shortcuts & Modifier Keys
Besides shortcuts special to one view or another, many shortcuts work the same for all views (and the same as in most other Mac OS X applications).
Plain and rich texts
The view for plain and rich text documents is basically a built-in incarnation of TextEdit, and you use it in a very similar fashion. Of course, text views support the Edit > Find > commands and all options of the Format menu.

The Ruler
For rich text documents, DEVONthink Pro Office supports the standard ruler that the TextEdit engine of Mac OS X provides. Show or hide it with Format > Ruler > Show/Hide Ruler.
The ruler contains the following elements:
Note: A nice feature is a built-in 'mini outliner.' On any blank line in a rich text document (doesn't work for plain texts), type ⌥⇥ to create a bullet-point (Mac OS X shows dashes instead of bullets). Press ⏎ for the next item, and so on. Additional ⌥⇥ will increase the indentation; a ⏎ on a blank list line will decrease it. It uses hyphens to indicate list items by default. Right-click to choose all kinds of list styles.
Attachments
You can attach other documents to rich text documents simply by dragging them into the text. Technically the rich text document becomes a .rtfd package and the dragged file is saved as part of the package.
Note: Editing attachments requires OS X 10.7 Lion or higher. Also, you cannot attach files to plain text documents. You need to convert them to rich text before you can attach other files.
Shortcuts & Modifier Keys
Toolbar
The document windows toolbar is very similar to the one in DEVONthink Pro Office main windows, yet can be configured separately.
HTML pages, web pages, feeds

HTML views display web pages stored in the database or downloaded 'live' from the Internet, by using the Safari web browser engine of Mac OS X. DEVONthink Pro Office displays also RSS news feeds like regular web pages. Pages are rendered similar to Safari or any other WebKit-based browser such as DEVONagent Pro.
News feeds item (RSS, RDF, Atom) are created in a database automatically for all items downloaded by a feed. Feed items are saved either as HTML or as a bookmark if the item has no content. An internal CSS stylesheet is used to style the output. You can change it in the Preferences. The icon of an unread feed item in list and split views is shown with a blue dot instead of a regular icon.
HTML views support the Edit > Find > commands as well as the See Also & Classify drawer. To edit the source code of an HTML document, use the navgiation bar to switch from preview to plain text mode.
In editable web archives you can use, e.g., the highlighting commands from the Format menu or add the Color tool to the toolbar to change text colors.
Shortcuts & Modifier Keys
Separate HTML or web browser windows feature a default toolbar set that is more web-like than text document windows. As with text document windows, this toolbar can be individually configured. Naturally, the DEVONthink Pro Office offers only tools for HTML views that are useful in a web environment.
Contextual Menu
For PDF pages, more options become available:
Sheets

Sheets contain text in a table and can be used to store any kind of tabular data from an address book to part numbers and descriptions.
Use sheets like any other document. Add new rows using Data > Sheets > Add Record, delete rows by selecting them and using Edit > Delete. Alternatively use the contextual menu. Click a cell to edit its content, press the ⎋ key to stop editing, and use the Tab or Return keys to navigate from cell to cell.
Sheets support the Edit > Find > commands but currently no formattings. You can, however, enter line breaks by typing ⌥⏎.
Note: Due to limitation in Mac OS X's Cocoa memory management, sheets are currently limited to 32,767 records.
Toolbar
Document windows opened for a sheet or record also feature a tool set specialized for working with sheets and records. Use tools like New Record, New Column, or Columns to create new records for the sheet, add a column, or modify the columns in any way you like.
Contextual Menu
The contextual menu for sheets basically lists the same commands that are also available through the main menu.
Images and movies

DEVONthink Pro Office uses Mac OS X's core technologies to display images and movies and therefore makes a very nice image and movie viewer.
You can scroll larger images using the scroll bars, the arrow keys as well as the Space and Shift-Space keys.
Edit Panel
Double-clicking an imported image opens an edit panel that allows you to do some basic image editing. The modified image is saved as losslessly encoded TIFF file.
In addition it offers a number of predefined image effects and lists available metadata contained in the image file itself.
Images (and PDF pages) can also be rotated using the Edit > Rotate menu commands, the toolbar, or the contextual menu.
For images and movies, DEVONthink Pro Office provides a set of tools that allows you to zoom the picture to whatever zoom factor you like, or to view the image in full screen mode. Use Open Externally to open the image in an external editor. Movies appear with the standard QuickTime controller.
Note: Editing an image stored internally in the database with an external editor does not modify the image data stored in DEVONthink Pro Office.
PDFs

PDF views are similar to image views, but come with some specialized options for viewing PDF documents. Also, PDF views support the Edit > Find commands.
The sidebar shows thumbnails of a pages of the PDF document. Click a thumbnail select that page and scroll to it; hold the ⇧ or ⌘ keys to select multiple pages. Reorder pages by dragging a page to the new position and use Edit > Delete Selected Page(s) to remove the selected page(s). Use Edit > Rotate to rotate PDF pages. Contextual menu commands are available, too, e.g. copy and paste.
You show and hide the PDF sidebar using the Show/Hide Sidebar button in the PDF''s navigation bar.
Note: Only real PDF documents are editable, converted (e.g. EPS, PostScript, or Adobe Illustrator files), Skim documents (PDF packages), and PDF previews generated by QuickLook are not editable.
You can use DEVONthink Pro Office to annotate PDF documents. To add or edit annotations, open the PDF document in a separate window (e.g. by double-clicking it). In the toolbar you will find all necessary tools:

To add an annotation, select your annotation tool, then 'draw' it into the page. Double-click the annotation to open the annotation panel which lets you fine-tune your annotation. Depending on the type of annotation you can change its attributes. Change the text color in the annotation panel; use the standard Fonts panel to change the font of a selected text annotation.
To move or delete an annotation, select it with the 'select elements' tool. Position it with the mouse. Press the Delete key or use Edit > Delete to remove it.
Shortcuts & Modifier Keys
In addition to the general shortcuts for paging up and down in a PDF document mentioned in the General section, PDF views also offers unique shortcuts.
Toolbar
The Annotate and Tool toolbar items let you quickly annotate PDFs.
Contextual Menu
The PDF sidebar also offers commands for working with single pages:
Office documents, email, and others
Documents that DEVONthink Pro Office cannot render natively are displayed using QuickLook. But while you have to press the Space bar in the Finder to open a QuickLook head-up display, DEVONthink Pro Office previews these documents directly in the view/edit pane like any other document format.

Among others, the following document types are shown though QuickLook:
For some document formats the preview allows you to select and copy text, for other formats it doesn't. If DEVONthink Pro Office is able to interpret and convert the document format you can use the Text View/Preview button in the navigation bar to switch to a text view that allows you to select, copy, and drag text.
Note: The availability and, if available, quality of the preview as well as the possibility to select and copy text depends solely on the source application. Developers can embedded a QuickLook-compatible preview diectly into the files or they can write a preview plugin and add it to either the source application or have you install it separately in ~/Library/QuickLook. If a document that you want to view in DEVONthink Pro Office does not show a QuickLook preview, please contact the maker of the source application and ask them to add QuickLook support.
Toolbar
For document previews based on QuickLook, DEVONthink Pro Office offers a number of toolbar items, e.g. for accessing the Scripts menu, moving back and forth through the other documents contained in the same group or opening the document in its source application. Also you can switch to full screen mode.
Use Data > Open to open the document in a separate document window instead of in its source application.
Drawers and Sheets
DEVONthink Pro Office uses drawers to display the results of the Classify and See Also functions that help you file items or find relationships between items in the database. Drawers also show concordance lists of all words in a document. The Smart Group Editor appears in a sheet and allows you to create or modify a smart group (a.k.a. 'saved search').
See Also & Classify
The See Also & Classify drawer appears when you select exactly one document in a main window and then click the AI button (a small sorcerer's hat) in the navigation bar at the top of the view/edit pane. This button is only available in views that have a view/edit pane.

It is also shown when you use the contextual menu on selected text to show similar documents, e.g. See [word]' or See related text, or when you select a topic from the topics pop-up menu in the document's navigation bar.
To close the drawer, click the red close button.
When activated, DEVONthink Pro Office analyzes the contents of the selected document and compares it to all the data stored in the database. From this 'knowledge', it gives you one or both of the following lists.
The Classify function helps you file documents by making suggesions based on where you have filed other documents. The classify list shows into which groups the selected document would fit best. It also lists the location of the group and a graphical score that shows how sure DEVONthink Pro Office is about its decision. The tooltip for any entry in the list shows the full title and location for it. This part is only visible when the sorcerer's hat button is used.
To move the document to one of the suggested groups, select the group and click Move To. Alternatively double-click the group. For your convenience, DEVONthink Pro Office preselects one or multiple groups if it very sure. Drag the group into any item list to move it, e.g. into a main window. Use the ⇧ and ⌘ keys to select more than one target. This generates replicants.
Note: Any replicants of the document you are moving are deleted. The document is only placed in the new locations which allows you to precisely classify the document again without having to manually clean up the old replicants.
See Also lists similar documents and so help you find information dealing very likely with the same subject than a given one. The see-also list shows documents that are similar to the selected one or to the selected text or topic (when you have used the contextual menu items or the document's topics pop-up menu). Similar to the classify list, this list shows the path to the document and a graphical score of how sure DEVONthink Pro Office is about its decision. The tooltip for any entry in the list shows the full title and location for it.
To display a document in the drawer, select it. For your convenience, DEVONthink Pro Office always lists the original document at the top of the list, so that you can easily go back to the original document. Double-click a document in the drawer to open it in a separate window; drag it into an item list to move it.
Contextual Menu
Use the contextual menu on groups in the See Also & Classify drawer for more commands.
Concordance
The Concordance drawer appears when you click the Concordance button in the document's navigation bar. It lists all words in that document similar to the Concordance window. Select one or multiple words (with the ⇧ and ⌘ keys pressed) in the drawer to highlight their occurences in the document.

You can sort the list in the drawer by clicking the title of the column you want to use for sorting. Click the column title again to reverse the sorting order. If you have changed the contents of the document, click the Update button to update the concordance list. Double-click any word in the drawer to open the Search window with this word already filled in.
To close the drawer, click the red close button.
Smart Group Editor
The Smart Group Editor appears as a sheet when you either create a new smart group using Data > New > Smart Group, when you right-click a smart group and choose Edit from the contextual menu, or when you double-click a smart group.

In this sheet you set up a new smart group or edit an existing one:
The list of predicates consists of a list of blocks, each one beginning with 'All' or 'Any', defining whether all (Boolean AND) or any (Boolean OR) of the contained predicates need to be true for the document to be returned as a result. Predicates themselves consist of the field to search (like: 'Content' or 'Tag'), the condition and the data that needs to be matched.
Note: In most predicates you can use wildcards, Boolean operators, phrases, and parenthesis, too.[Read more...]
Use the + and - buttons to add more predicates to your smart group or to delete them. Hold the ⌥ modifier key and click a ... button to create a 'compound predicate', also called 'branch'. Predicates can be in/outdented and rearranged via drag-and-drop.
By adding more lines to a search and choosing between 'All' and 'Any' you graphically create a nested Boolean query with ANDs, ORs, and parenthesis.
Predefined Smart Groups
When you create a new database, DEVONthink Pro Office adds a number of predefined smart groups for your convenience:
The following smart groups are by default added to the sidebar:
Note: Smart groups also filtering for date ranges are shown with a clock icon.
Preferences
The Preferences window, which you open by selecting Preferences in the application menu, is the place to go to change all global settings for DEVONthink Pro Office. In addition to these settings, databases also have private settings in their Database Properties window that you open using File > Database Properties.
General

Use the General tab to set the general settings for the user interface.
These options define some parts of the visual appearance.
These options define some parts of how you interact with the user interface.
Startup
Choose whether you would like DEVONthink Pro Office to open a fresh main window on startup, open all windows that were open when you quit DEVONthink Pro Office the last time, or do nothing. If Open all windows that were open on quit is selected, DEVONthink Pro Office also opens all databases that were open on quit.
Note: Even when you tell DEVONthink Pro Office to not open a window on startup, it will always open at least one window when you open a database.
Fonts
Use List Views Font and Column View Font to set the font DEVONthink Pro Office uses for displaying item lists in list and column views.
Default Database
You can set a default database that is automatically opened when you start DEVONthink Pro Office. Use the Select button to select any DEVONthink Pro Office database or edit the path manually.
Alternatively, open your favorite database, choose File > Database Properties and check Use as default database.
Editing

The Editing tab defines all options that fine-tune DEVONthink Pro Office's text editing behavior, from the ruler units to WikiLink templates and summarization options.
WikiLinks
Summarization
Select whether you wish DEVONthink Pro Office to calculate summaries from sentences or from whole paragraphs.
Import

Here you decide which file types DEVONthink Pro Office imports and how they will be named in the database.
Files
These options define whether DEVONthink Pro Office imports files of a given type or not when you import folders using File > Import or via drag-and-drop.
Titles
Select how you want DEVONthink Pro Office to name imported documents; with file name extensions, without file name extensions, or by using localized display names (for example, on a German system the 'Applications' folder would appear as 'Programme').
New notes
Check Select (and display) automatically to automatically select and display the last note you have taken.
Choose the default destination in which data coming in from bookmarklets, DEVONagent Pro, news feeds, (external) scripts, and services is stored:
Sorter

The Sorter preference allows you to assign a hotkey for capturing a selection into the inbox of the Sorter as well as a hotkey for taking a new note, show the Sorter at login, and start or quit the Sorter manually. [Read more...]
Availability, Hotkeys
Check Start Sorter at login to start the Sorter immediately after you log in. Check Visibility: Full to make the Sorter tab fully visible or uncheck it to make the tab fade when the mouse pointer does not point at it.
To change the hotkeys for taking a new note or copying a selection, click the Click to record shortcut button, then press the hotkey that you want to use. Press the ⎋ key to cancel recording a new shortcut. When the Sorter is not running, this hot key opens the Take Note panel.
Hider Sorter in Full Screen
This lists shows all fullscreen applications that Sorter is aware of. Add other applications using the + button and check or uncheck apps to make Sorter hide when this application is going to fullscreen mode.
Reset the full screen settings to make DEVONthink Pro Office 'forget' all remembered apps.
Click Start or Quit to start or quit the Sorter manually.
Media

In the media preferences you tell DEVONthink Pro Office how to handle multimledia files, images, PDFs and other documents for which DEVONthink Pro Office can create thumbnails.
The following options are available:
Colors

Here you can name and choose the seven label colors DEVONthink Pro Office uses to mark documents and groups, as well as set seven colors you can use to highlight text.
Web

The web preferences resembles the settings of most web browsers. Use them to define how DEVONthink Pro Office's displays web documents and 'live' web pages.
Web Content
These settings define how DEVONthink Pro Office treats some special web contents:
Images
These settings define how DEVONthink Pro Office displays graphics in web pages:
Accept Cookies
Cookies are little text files with information that web pages store on your computer (for example, to recognize you as a returning customer). While most of them are harmless, you may want to have a bit more control over what is being stored on your hard disk.
Fonts
Set the fonts you want to use for displaying web pages, separately for variable-width and fixed-width text.
You can further control the way DEVONthink Pro Office displays web pages by applying a CSS style sheet that changes the rendering on-the-fly.
Click Select and choose your style sheet to apply it to DEVONthink Pro Office's integrated web browser. Note: This is for experts as it modifies how all web pages are displayed and can lead to undesired effects.
Text Encoding
Select your desired text encoding for displaying web pages. Automatic tries to choose the best available encoding. If this does not work for you, choose a more appropriate text encoding for your language group.
RSS

DEVONthink Pro Office comes with built-in RSS capabilities that enable you to add RSS feeds to your database and have DEVONthink Pro Office update them automatically.
RSS feeds are represented in DEVONthink Pro Office like smart groups that update themselves with content from the Internet. You create them with Data > New > Feed and use them like any other group.
Use the RSS preferences to define how often DEVONthink Pro Office checks for new articles, whether to skip duplicates when updating feeds, when to remove older articles, and which CSS style sheet to use for displaying the articles. Unread or locked articles are never automatically removed. Check Also unread articles to remove also unread articles when cleaning up and check Convert categories to tags to tag imported articles automatically if the feed contains categories.
DEVONthink Pro Office comes with multiple styles for displaying feed articles; the 'Newspaper.css' style is optimized for readability and does not display images. You can use your own RSS stylesheets by placing them into '~/Library/Application Support/DEVONthink Pro 2/StyleSheets'.
Server

DEVONthink Pro Office features a built-in web server that makes sharing your documents on your local area network as well as over the Internet a one-click action. It also comes with an Web-2.0-ish web application that lets your access your database from an Apple iPhone.
As soon as the Web server is started, other users can use a standard Web browser to search your database, view documents, and download them.
Enter all necessary details (see below) and click the Start button to start the Web server to make all documents in every shared database (you switch on sharing in the Database Properties panel) available for searching. If you or others have problems accessing your DEVONthink Pro Office database with a Web browser, click the Log button to check the log for error messages and other information that could be helpful to solve the problem.
Note: When you switch to another database, the server will be automatically switched off for the safety of your data unless you have checked 'Launch on Startup.'
DEVONthink Pro Office shows the name and two URLs for your database at the bottom of the window as soon as the server is started. Use either the Bonjour services list of the Safari Bookmarks view or enter the shown URLs into the address field of your Web browser to access your database. Use the numeric address if the Bonjour does not work for your network.
To learn more about using the web interface, the iPhone web application, as well as making your database available from the 'outside' Internet, please read on here.
Bonjour Name
Enter a distinct name for your computer here that identifies it on your local network using Bonjour. This name will be shown, e.g., in the list of Bonjour services on other Macs on your network. Switch, e.g., to the Bookmarks view in Safari and select Bonjour in the sidebar.
Domain, Port
These settings define the base URL of your database (used for publishing to the Internet) and the TCP/IP port number it uses.
Note:
User, Password
To protect your database with a user name and password, enter a user name and password here. Any user who wants to search your database using a web browser will need to enter these two details before they gain access to your documents.
To automatically start DEVONthink Pro Office's web server as soon as you launch DEVONthink Pro Office, check this checkbox.

Use these options to define how emails are imported and displayed inside DEVONthink Pro Office.
Conversations
Note: These features only work if the email program used maintains references to previous messages in the emails it sends.
Messages
Check Previously imported will become replicants to import previously imported messages again. They will become replicants. When this option is unchecked, DEVONthink Pro Office skips previously imported messages.
Message Content
Note: The email message will be stored decrypted in the database package, so all its contents are available from within DEVONthink Pro Office and to other applications or Spotlight.
Note: The first two options above only modify the display of email messages in the text view. By default, messages are displayed using QuickLook.
OCR

DEVONthink Pro Office contains an optical character recognition (OCR) module that allows you to import scanned documents and make them searchable. These documents are 'read' by the embedded OCR engine and stored as PDF files to the database that contain an additional (invisible) text layer with the recognized, computer-readable text. Use these options to fine-tune the OCR process.
You can import scanned documents, or scan them directly from within DEVONthink Pro Office.
Incoming Scans
Check Convert to searchable PDF to apply OCR (optical character recognition) to PDFs that have been sent in from a known scan software, e.g. ExactScan (full edition), CanoScan ToolBox, and others. The resulting file is a standard PDF with the original image and a computer-readable text layer behind it.
Original Document
Check Move to Trash if you want DEVONthink Pro Office to move the original documents to the trash when they have been successfully imported using OCR. When documents are converted by OCR within the database, the original document is deleted from the database when this option is checked. When files are converted at import, the original document is moved to the Finder's trash when the option is checked. Use this option to prevent your incoming folder for scanned documents or your database from growing cluttered after OCR has produced searchable PDFs.
Check Enter metadata after text recognition to make DEVONthink Pro Office show a metadata entry dialog whenever a PDF is imported using OCR. Use this dialog window to enter the proper document name, the author of the document, and some keywords describing the document. Also, adjust the timestamp of the PDF to the actual date of the paper document. The dialog window is shown when the OCR process for a document has been completed.
When checked, the metadata entry dialog will appear whenever you scan a document or import an image file with OCR. So, if you want to scan/import multiple files in a batch, consider switching this option off.
Note: The information you enter in this dialog will be available to Spotlight and can be changed in the Preview application. The title field will also be used to name the document, the keywords will go into the Comments field, and the creation date will be the creation date of the document in DEVONthink Pro Office. You can access this information in the Document Properties panel.
Additional options:
Languages for OCR
The Languages section of the OCR preferences lets you define the languages of the documents you scan in. DEVONthink Pro Office's OCR engines uses this information to improve the accuracy of the text recognition. DEVONthink Pro Office comes with more than 150 dictionaries of various languages.
Select the languages you intend to scan or import with OCR. Select your primary language using the pop-up menu and add one or more secondary language. Select the languages you want to use on the list on the right right side ('Available') and move them to the left hand side ('Selected') using the right-to-left arrow button. To deactivate a selected secondary language, select it in the list on the left hand side and move it to the right hand side using the left-to-right arrow button. You can select a maximum of four secondary languages.
The primary language and the secondary languages are treated equally.
Backup

DEVONthink Pro Office comes with a simple built-in backup function that backs up the database index on a regular bases. These options define how often DEVONthink Pro Office will back up its index.
The backup automatically duplicates all important database files and moves the duplicates into a folder(s) named 'Backup(.x)' within the DEVONthink Pro Office database folder/package. Select if you want to have the backup created never, daily, weekly, or monthly and how many copies of the index to keep. Of course, you can create a backup at any time using Tools > Backup & Optimize.
These options do NOT backup the whole database to a secure location but simply make sure there's a copy of the index files in case the index get corrupted. To back up your complete database use a third-party backup software or a backup solution such as Time Machine.
DEVONthink Pro Office also comes with a number of handy scripts that export your database as files and folders (and so independent from DEVONthink Pro Office). [Read more...]
Update

Change the settings in this tab to define when you want DEVONthink Pro Office to check for new versions (never, on startup, daily, weekly, or monthly). DEVONthink Pro Office only performs checks for updates when the computer is connected to the Internet.
Click Check Now to immediately check for a new version.
Note: Disable the check for new versions when your network connection is unstable and you experience very long delays when opening DEVONthink Pro Office. The Update pane is not available if you have purchases DEVONthink Pro Office on the Mac App Store.
Email, Scanning, Web Sharing
DEVONthink Pro Office comes with a number of features specifically designed to help you eliminate paper from your home and office life. You can use DEVONthink Pro Office for archiving your email messages, as well as scanning and archiving printed documents (like letters, invoices, recipes, and more).
Archiving Your Email Correspondence
The Mail import function lets you conveniently import email messages or archive even complete mailboxes from your preferred email applications to your DEVONthink Pro Office database.

DEVONthink Pro Office currently supports the following email applications:
The imported email messages are saved in their original file format and are displayed using QuickLook. MailTags metadata is preserved in the comments. In addition the 'read' and 'flagged' status of email messages are transferred from Microsoft Entourage and Microsoft Outlook independently from your settings in Preferences, Email tab.
Note: If you need to transfer email from an application like Outlook or Eudora to Apple Mail, take a look at Hawk Wings. The site has hundreds of tips for Apple Mail, including a list of useful plugins and utilities.
Note: Importing messages from PowerMail only captures messages, no attachments. To archive messages including their attachments export your PowerMail mailboxes as Unix mailboxes and import them into DEVONthink Pro Office using the standard Unix mailbox approach.
Preparations
DEVONthink Pro Office communicates with your email application using either AppleScript or, if you are using Apple Mail, through a special plugin that implements a direct link between Mail and DEVONthink Pro Office. If the plugin is not automatically installed, click here [special link, not enabled in ebook] or select DEVONthink Pro Office > Install Add-Ons to install it.
In addition to speeding up the transfer of emails from Apple Mail to DEVONthink Pro Office, the plugin inserts new menu commands into Mail's menus that allow you to directly archive selected messages or mailboxes to your DEVONthink Pro Office database. Note that when accessing a supported mail application via AppleScript, automatic fetching of new mail is disabled. This does not happen when you use Apple Mail with the DEVONthink Pro Office plugin installed.
Note: We highly recommended you install the Apple Mail plugin, as the AppleScript implementation in Apple Mail is slow. Also, it's not possible to archive complete conversations from Apple Mail without the plugin installed, due to limitations in the AppleScript interface of Mail.
Open the Import Email window from File > Import > Email menu. It is designed to match the main window of most major email applications, with a mailbox list to the left and a list of messages contained in a selected mailbox to the right.
To access the mailboxes and messages stored in your email application, select your email application in the toolbar's Source pop-up menu. DEVONthink Pro Office automatically selects your default email application (DEVONthink Pro Office will only list applications installed on your Mac that it directly supports). If you are using an unsupported mail application that uses Unix mailboxes, like Thunderbird, choose Unix mailbox and locate the mailbox file you want to use.
You can also drop '.mbx' or '.mbox' files onto DEVONthink Pro Office's application icon to import them bypassing this window.
DEVONthink Pro Office then immediately launches your email application and shows the list of available mailboxes. Select any mailbox to show its content and use the triangles in front of the mailbox icon to expand the mailbox and see its sub-mailboxes.
To import a complete mailbox, including messages, select the mailbox in the folder list, and click the Archive Mailbox icon in the toolbar. This imports the complete mailbox including all sub-mailboxes and recreates the mailbox hierarchy by using groups in your DEVONthink Pro Office database. To import one or multiple messages, select them in the list of messages and click the Import icon in the toolbar. The imported messages are placed into the default destination.
Note: While importing mail, your email application is put temporarily offline. It will be switched to online again as soon as the import is done.
Import vs. Archive Mailbox: If you want to archive whole mailboxes including all sub-mailboxes, use the Archive Mailbox icon in the Import Mail window's toolbar. Select the mailbox that you want to archive and click the Archive Mailbox icon in the toolbar. DEVONthink Pro Office imports all new (!) messages of the selected mailbox in all of its sub-mailboxes to the Email group of the current database. This Email group is shared by all mailboxes archived.
Note: If you are using IMAP, you may want to make sure that your email client is keeping a local cache of all messages and that your IMAP mailboxes are fully synchronized to the online server before you import your messages to DEVONthink Pro Office. This will make the import more reliable and faster.
Filter: Change any filter settings on the right-hand side of the window to narrow down the list of messages. The following filters are available:
If you are using Apple Mail, you're one step ahead of those using other mail applications, as the plugin that DEVONthink Pro Office installs for Apple Mail not only directly links DEVONthink Pro Office to the application, but also inserts two very convenient menu commands. These commands allow you to directly import selected messages, or even complete mailboxes, from Apple Mail to DEVONthink Pro Office.
Alternatively you can drag messages directly from Apple Mail to DEVONthink Pro Office.

To import complete mailboxes from Apple Mail to DEVONthink Pro Office, select one or more mailboxes in Apple Mail and choose Mailbox > Add to DEVONthink Pro Office. To import one or more selected messages, choose Message > Add to DEVONthink Pro Office. The imported messages are stored in the inbox.
Note: The Mailbox > Add to DEVONthink Pro Office command does import only the selected mailbox without travelling its sub-mailboxes. To import mailboxes from Apple Mail with travelling all sub-mailboxes as well as preserving the mailbox hierarchy use the Mail Import window.
Replying to Imported Messages
To reply to an archived email message, right-click it and choose Reply. Choose Send by Email to email a selected document.
Note: Some email applications, e.g., Mozilla Thunderbird, do not support AppleScript and so DEVONthink Pro Office cannot properly create a new email with attachment. Instead, it tries to stuff as much information into a URL and send this to the application. But, a URL can only be of limited length, therefore the data has to be trimmed and you will see the message 'This is a summary of the selected record text!' instead of the quoted text in the newly created message.
Toolbar
The toolbar of the Import Mail window contains the following commands:
Capturing Paper Documents
DEVONthink Pro Office comes with built-in support for both document scanners such as the Fujitsu ScanSnap as well as with two modules for flatbet scanners that come with a TWAIN driver compatible to Mac OS X or that use Mac OS X's Image Capture framework.
Scan paper documents that you want to archive using one of the two available modules:
DEVONthink Pro Office will automatically make them searchable by applying optical character recognition (OCR). OCR adds an invisible text layer to the scanned file that is computer-readable and searchable; a layer that is recognized by DEVONthink Pro Office's AI engine.
Note: For best results we recommend scanning at 300 dpi in color and with 100 percent quality.
In addition, DEVONthink Pro Office can import files previously scanned with a third-party application (such as your scanner's capture application), and apply OCR in the process, making the documents' content available electronically. [Read more...]
DEVONthink Pro Office also automatically recognizes the Fujitsu ScanSnap document scanner and, if desired, changes the ScanSnap Manager's preferences so that scanned documents are automatically sent to DEVONthink Pro Office, given the OCR treatment, and imported without any further user interaction. Pair DEVONthink Pro Office with the ScanSnap and you're well on your way towards eliminating paper clutter from your life. [Read more...]
Scanning via Image Capture
Before you can use an Image Capture scanner from within DEVONthink Pro Office, you should check whether the scanner is compatible with Image Capture. Apple provides a list of scanners found compatible to Image Capture starting with Mac OS X 10.6 'Snow Leopard' on their web site.
To check this yourself, do the following:
If this doesn't work with your scanner, check your scanner's documentation, as well as the manufacturer's website. If you can make a scan from the Image Capture application, you will also be able to do so in DEVONthink Pro Office. If you cannot get it to work, please try the TWAIN module. In addition you could try to find an open source SANE driver for it.
Note: Due to deficiencies in Mac OS X's Image Capture, it's not yet possible to access network scanners. We'll post a workaround as soon as we find one.
The Capture window
To open the Capture window, choose File > Import > Scanner > Capture. DEVONthink Pro Office will immediately connect the first available scanner; if it can't, it will ask you to connect to your scanner using Image Capture.

If possible, DEVONthink Pro Office will also do a preview scan and provide you with these options (you can change them later at any time):
Note: It is recommended that you use at least 300 dpi (though 600 dpi is best) and Color Document for best results, especially when using OCR.
Adding pages: To scan a page and add it to the Capture window, click Add page from the Scanner Options dialog sheet. DEVONthink Pro Office scans one page. Then, you can immediately put a new sheet of paper onto the scanner and use the Add Page toolbar button to add the next page. The selected page area will not change.
If Apply OCR was checked in the options, DEVONthink Pro Office will run OCR on every added page. This happens in the background, so you can continue to add new pages in the Capture window while OCR is running.
Reviewing the scanned pages: Click the Toggle Drawer button in the toolbar to open a drawer showing all pages already added to the Capture window. Select any page to display it. Use the zoom level pop-up menu in the lower right corner of the Capture window to zoom into, or out of, the scanned page.
Reordering and deleting pages: You can reorder the pages added to the Capture window before you actually import them by dragging the thumbnail pictures of the pages in the drawer. Click the Revert Page Order button to revert the complete page order (for instance, because you scanned the pages in reverse order, from last to first). Select any page in the drawer to display it and use the Delete Page toolbar icon to remove it from the Capture window.
Storing the document: When you have scanned all pages and have arranged them in the proper order, click the Store toolbar icon to assemble the final PDF document and import it into the database. The document will be placed into the default destination.
Note: To save disk space, the generated searchable PDF is regenerated using the resolution set in the preferences.
The Toolbar
You can customize the Capture window's toolbar to fit your needs. Right-click the toolbar and choose Customize from the contextual menu. You may alternatively choose View > Customize Toolbar. Besides the standard toolbar items, the following tools are available:
Scanning via TWAIN
Preparations
Before you can use your scanner from within DEVONthink Pro Office, make sure that a TWAIN or Image Capture driver is installed for your device. Please consult your scanner's manual on how to install the driver.
The Capture window
To open the Capture window, choose File > Import > Document (from Scanner)... DEVONthink Pro Office will open the embedded ExactScan Capture application and bring it to the front. DEVONthink Pro Office will stay in the background but you can bring it to the front at any time without disturbing the scan process. As soon as ExactScan Capture has been opened, both applications are working independently.

When ExactScan Capture opens, it starts looking for connected scanners. If you have installed more than one scanner driver it presents you with a dialog window that lets you select the scanner that you want to use.
If the scanner can be connected, ExactScan Capture shows its capture window consisting of three areas:
Note: If the capture window does not appear automatically, choose File > New Scan or press ⌘N in ExactScan Capture to open it.
Step 1: Choosing the settings
Before you begin to scan, select the profile that you want to use for your particular scan job. If the four predefined profiles that come with DEVONthink Pro Office don't fit your needs, create your own using the plus sign button below the profile list.

For the selected profile ExactScan Capture shows the assigned settings on the right hand side of the capture window. Switch between the three tabs, Filing, Basic Settings, and Advanced Settings, and check or modify all settings so that they fit your needs.
Filing:
Basic Settings:
Note: It is recommended that you use at least 300 dpi (though 600 dpi is best) and Color Document for best results, especially when using OCR.
Advanced Settings:
Step 2: Creating a preview
When you have selected the profile that you want to use and, if necessary, amended the settings, you should make a preview scan. Click the Preview button to open the preview drawer, then click the New button in the drawer to make ExactScan Capture quickly scan the page in the scanner.
In the preview drawer, use the handles of the rectangle marking the scan area to adjust it to your needs. Use the plus sign, minus sign, and plus-arrow sign buttons to zoom in, zoom out, or zoom to fit.
Step 3: Scanning
If the preview is fine, click the Scan button. ExactScan Capture will scan the page and, if One file per page is not checked on the Filing tab of the selected profile, ask if you want to scan another page or stop scanning and file the document. Add as many pages as you like and then choose Stop to save the scanned document to your database.
Step 4: Saving the scan
When the scan is done, ExactScan Capture will save the completed document to the folder selected on the Filing tab of the profile, then send it to DEVONthink Pro Office. If Edit each filename was checked on the Filing tab, ExactScan Capture will also let you modify the file's name before saving it.
When the file is sent to DEVONthink Pro Office OCR is applied if Convert to searchable PDF is checked in the Preferences. The (searchable) PDF is then saved in the database.
The ExactScan Capture application does not quit automatically as you may want to continue scanning. Simply quit it when you're done capturing using ⌘Q or its Dock menu. It will also quit automatically when you quit DEVONthink Pro Office.
The captured document is filed in the default destination.
Unsupported Scanners
If your scanner isn't supported by ExactScan Capture, don't worry. As long as you are able to scan somehow, for instance, by using the scanner manufacturer's application, there's a way to get your documents into DEVONthink Pro Office.
First, check if your scanner uses one of the following scan applications:
If your software is in the list above, you just need to tell it to send the scanned file to DEVONthink Pro Office (in the HP software this feature is called 'scan destinations'. Most scanner applications allow you to do change this setting (for instance, when opening scanned images automatically in Preview, Adobe Photoshop, or The GIMP). Change the setting so that DEVONthink Pro Office is your application of choice, and scanned documents will open in DEVONthink Pro Office.
As soon as your scanner application sends a scanned file, DEVONthink Pro Office will automatically run optical character recognition on it and then save the file to the default destination. If DEVONthink Pro Office doesn't run OCR automatically, please contact us. We will see if we can add support for your scan software to future versions of DEVONthink Pro Office.
You can, of course, also save the scanned files simply to your hard disk (for instance, to your Desktop), and import them manually with OCR by using File > Import > Images (with OCR).
Note: If there is no driver available for your scanner that is compatible to either ExactScan Capture or Image Capture, you can try to use the TWAIN-SANE Interface, a scanner driver library ported from Linux. It needs some expertise to install and get to work (beginners beware), but it can connect older scanners to the modern Mac OS X world. Please note that DEVONtechnologies does not provide support for the TWAIN-SANE Interface; please contact the author if you need assistance.
Importing existing files with OCR
If you already have an archive of documents that have been scanned without OCR, or if you cannot use the Capture function for whatever reason, you can import image files while applying OCR at the same time.

To import an image file while applying OCR, choose File > Import > Image with OCR. The image will be fed through DEVONthink Pro Office's OCR engine and be imported to the database as a PDF document. If you have checked Set PDF attributes in the OCR preferences, DEVONthink Pro Office will show the metadata entry window when the OCR process is completed (before the file is actually imported to the database). In the file selector, check Move to Trash if you want to move the file to the trash when it has been successfully imported with OCR.
The date of the created document is set to the date of the original file. Thus for archival purposes the searchable document is identical to the original one. The modification date is set to the current date and time to reflect the addition of the searchable text layer.
Using the Fujitsu ScanSnap or ExactScan (full edition)
DEVONthink Pro Office's integration with the Fujitsu ScanSnap as well as ExactCode's ExactScan scan software is nearly seamless.
Note: DEVONthink Pro Office uses a 'light' edition of ExactScan called ExactScan Capture for flatbed and ADF scanning. You can also use the full-featured edition of ExactScan instead following this description.
Whenever you start DEVONthink Pro Office, the application checks to see if the ScanSnap Manager or ExactScan software is installed on your Mac. If it is, DEVONthink Pro Office also checks if DEVONthink Pro Office is the preferred target application for scanned documents. If this isn't the case, the application will ask if it should fix the ScanSnap Manager's or ExactScan's preferences so that all scanned files are sent to DEVONthink Pro Office when the scan is done. DEVONthink Pro Office recognizes where the incoming file comes from and runs OCR on it if necessary.

If you don't want to use DEVONthink Pro Office as the default target for your scans, you can check Never ask me again in the dialog window, and DEVONthink Pro Office will never ask you again if you want to use DEVONthink Pro Office with your scan software.
Reactivating scan software support
If you change your mind and want to re-activate the ScanSnap or ExactScan support, start the Terminal application and execute the appropriate of the following commands (on one line; best use copy/paste as the command is case-sensitive):
defaults remove com.devon-technologies.thinkpro2 "ScanSnapSupport.NeverCheckForPresence"
defaults remove com.devon-technologies.thinkpro2 "ExactScanSupport.NeverCheckForPresence"
You can, of course, also add DEVONthink Pro Office as the default application for scanned documents in the ScanSnap Manager or ExactScan at any time without that special help from DEVONthink Pro Office.
Switching off the Quick Menu option
If activating ScanSnap support does not work, it may be that the so called Quick Menu is still activated in ScanSnap Manager. DEVONthink Pro Office sometimes cannot switch off this option automatically, so you need to do it manually. Check if Use Quick Menu is checked in ScanSnap Manager's Dock menu. If it is checked, uncheck it.
Sharing your database (incl. via iPhone)
DEVONthink Pro Office allows you to give others on the local network access to your database using a standard web browser on any operating system (including Windows and Linux). The embedded web server provides an interactive web interface that allows you to browse and search all open and shared databases, preview documents, and add notes to the inbox. Alternatively it offers a simple search-engine-like search for those users who don't need all the functionality of the full web interface.
Sharing a database
By default, DEVONthink Pro Office does not share any database. To share a database, open it, then show its properties, File > Database Properties, and check Shared Database. Uncheck this property to keep this database from being shared.
To find out the address of your shared database, open Preferences > Server. You can start and stop the web server here and also find your web server's address. When the web server is running you can also find DEVONthink Pro Office in the Bonjour menu of your web browser.
Using the interactive web interface
The interactive web interface imitates the look-and-feel of a standard Mac application in many ways. Contrary to a static web site it only loads once, clicking buttons or links does not reload the whole page but dynamically updates it. When the web interface is loaded, don't use the Back and Forward button of your web browser for navigation but use the buttons the DEVONthink Pro Office provides.

The web interface is divided into four areas which can be individually resized:
When loaded, the sidebar shows a list of all shared databases as well as more information about a selected item. Select a database to show its contents in the items pane and select an item to view it. Double-click groups to open them and use the Home and One Level Up toolbar buttons to go back to the database's home level or to go to the parent folder (if you are not already on the home level). If a group contains more than 50 items, DEVONthink Pro Office displays them on multiple 'pages' and lets you navigate back and forth the pages with the back and forward arrow buttons below the item list.
In addition, the toolbar contains a number of other useful buttons:
Below the toolbar you also find the search field that searches all shared databases. You can use all operators etc. that you can also use from within DEVONthink Pro Office. See also the Search window.
After using the search field or the See Also button, the contents of the items pane is replaced with the search results sorted by relevance. Click the pane's close gadget to return to the last visited group.
Using the search-only web interface
To switch to DEVONthink Pro Office's search-only web interface click the Simple button in the interactive interface; to go back, use the Browse button next to the Search button.
Note: Alternatively you can directly open the search-only web interface by adding "/search" to the URL.

DEVONthink Pro Office's web interface works just like any other search engine you have used. Enter your search words, select your search options, and click Search. The search options resemble those also found in the Search window. You'll receive a ranked list of search results with options to view or download the found documents.
Using the iPhone interface
Accessing your database from an iPhone is similar to connecting to the web interface. However, DEVONthink Pro Office gives you a JavaScript web application ready-made for the iPhone's screen size. It loads faster, transfers less data over the network, and is also optimized for iPhone-like usage like tapping.

To access your database from the iPhone, simply enter your database's address (check in Preferences > Server), with JavaScript switched on, in Safari for Mobile's preferences. You're automatically sent to the iPhone-optimized web app. If, by whatever chance, it does not work, e.g. because you have deactivated JavaScript, add '/iphone' (slash-iphone) to your database's address.
The iPhone web application simulates the look-and-feel of a native iPhone application but through Safari. Tap items and use the Back button to navigate your shared databases, add new notes to the global inbox, and search all databases just like you would do on the Mac.
Note: Due to limitations of the iPhone's hardware and operating system, the web application does not attempt to load files larger than 2 megabytes and does not display certain file types such as iWork files. Files that cannot be displayed of some reason appear greyed out. Also, some files are opened in a second tab which does not work when you have added the web application to your home screen (apps opened from the home screen cannot open a second tab).
Synchronizing with DEVONthink To Go
Alternatively to accessing your databases from your iPhone or iPad through web sharing you can synchronize your databases with DEVONthink To Go and so take them with you without the need to make your Mac available on the Internet. [Read more...]
Accessing your data over the Internet
To access your database from the Internet, you need to make your Mac 'visible' to the outside world. In general, when you a using a DSL or cable modem, you are also using a router. Routers create an intranet that your Mac is connected to and 'route' traffic between the Internet and your personal intranet. Now, you need to create a route from the outside leading to the Mac sharing your database, offering a port on the outside that is directly connected to the port on which DEVONthink Pro Office is publishing.
If everything went well you will be able to access your database using an address like: http://xxx.xxx.xxx.xxx:port, where xxx.xxx.xxx.xxx is your current IP address, not of your Mac but of your router, and port the outside port number leading to your published database.
Using Lighthouse: An easy way to configure port forwarding is to use the shareware utility Lighthouse. With a little luck, Lighthouse automatically finds your router and configures port forwarding for whatever ports you want. It installs as a menu extra and allows you to configure multiple settings for different applications. To set up Lighthouse for DEVONthink Pro Office, follow the instructions that come with Lighthouse. To download Lighthouse and to learn more about how it works and how to set it up for your network, please refer to Lighthouse's homepage.
Port forwarding done manually: The following is only a rough outline of the steps needed to configure port forwarding manually. The precise way to do it varies from router to router. You will need to consult the manual for your router in order to determine exactly how to set things up. To configure port forwarding, follow these steps:
Setting up port forwarding can be tricky, but the difficult part is mainly in determining how to configure your particular router. If you are in doubt, try googling your router's name and combine it with a seach for 'port forwarding' or 'port mapping.'
Widgets, Sorter, Bookmarklets
DEVONthink Pro Office comes with a handy Dashboard widget that allows you to jot down notes and store them in your database. The Sorter is a separate panel docked to the border of your screen that lets you add data to your databases even when DEVONthink Pro Office is not runnning. Bookmarklets make adding interesting web pages from Safari or DEVONagent Pro to DEVONthink Pro Office as easy as pressing a button.
DEVONthink Jot
DEVONthink Jot allows you to take notes and send these to DEVONthink Pro Office's default destination right from the Dashboard.
The front of the widget is where you can type your note's message. Click into the writing area to make the insertion caret appear. Enter your tags below the note taking area, if needed. Click the Take Note button to save the note to your database.

You can also flip the widget by clicking the i button that appears when you move the mouse into the lower left corner of the widget. The back of the widget lets you choose your preferred font. This preference is also saved and will be used whenever you open the widget again. Click Done to flip the widget back to the front.
Sorter
The Sorter is a helper application that lets you add files or selected text or images to your databases even when DEVONthink Pro Office is not open. It shows as a little ⇥ attached to the left, bottom, or right border of the screen that serves as a drop target for files and clippings.

Like a real sorter in your post office, the Sorter consists of multiple (drop) boxes. The first box is always the global inbox, all other boxes you can connect to any group in any of your databases. When you drop files or clippings onto a box, the Sorter files it in the connected group. Should the database containing the connected group not be available, e.g., because DEVONthink Pro Office is not open, the Sorter stores the dropped data until the database is opened and then flushes the contents of the box.
In addition you can use the Sorter to quickly add a note to DEVONthink Pro Office even when it is not open.
Positioning the panel
To position the Sorter panel, drag the tab to any position along the left, bottom, or right borders of any connect screen except for the border where the Dock is located (even when it is hidden; this only applies to the screen that has the Dock). To open the panel, click its tab; to close it, click the tab again. Resize the Sorter panel with the resize gadget in the lower left or lower right corner, depending on whether the Sorter is attached to the left or right side of the screen. The size of the boxes stays the same, enlarging or reducing the panel size adds more boxes or hides them.
Alternatively you can show the Sorter with a list instead of square boxes. Use the
and
icons at the bottom to switch between the two. You can set different sizes for both modes.
Connecting boxes
To connect a box to a group, open the database of choice and drag the group, e.g. from the item list of a main window, to an empty box in the Sorter. The box is labeled with the group's name, the group's icon is shown as a ghost image on the background of the box, and its tooltip (that appears when you point at it with the mouse for more than one second) shows the name of the database containing the database as well as its path.
Drag a box by its title to move it to a new position in the Sorter's box grid; move it out of the Sorter panel to remove its connection.
Alternatively, use the contextual menu (opens when you right-click or click with ⌃ held) to open a window for the connected group in DEVONthink Pro Office or to remove the connection. Double-click a box to open the connected box in DEVONthink Pro Office.
Using the panel
To add items to a Sorter box, simply drag the file or clipping to the Sorter's tab. The panel extends automatically and you can drop the item on the box that you want to use.
Dragging items to the Sorter copies them. Drag with ⌘ pressed to move the item, drag with ⌘ and ⌥ pressed to add only a reference of the item to DEVONthink Pro Office (index). For URLs dragged from a browser this creates a bookmark; hold ⌘ and to create a web archive instead. Only files can be moved to the Sorter, folders and clippings are always copied. For items dragged from DEVONthink Pro Office itself the Sorter behaves similar to the Groups & Tags panel.
If the database the box is connected to is not available, the Sorter preserves the data for you. Move the mouse horizontally over the box to skim through the dropped items, just like in iPhoto 'Events'. Drag the shown item to the Trash to remove it. Alternatively, use the contextual menu to remove it. When the database becomes available, the Sorter files the contents of the box automatically and plays a sound.
When the database is available, nothing shows up in the box but the Sorter sends all items directly to DEVONthink Pro Office and plays a sound.
Switch between the sorter boxes and the take note panel click the
icon located at the bottom of the Sorter panel. Click the
or
icon to switch back to the sorter boxes.
On the take note panel choose the destination for the new note in the pop-up menu at the top of the panel (DEVONthink Pro Office offers all groups also available as sorter boxes) and enter title, URL, and your note. Add tags at the bottom if required. The Sorter uses the standard font and size set in DEVONthink Pro Office's Preferences, Editing pane, for rich text. The text area also accepts drag-and-drop of plain and rich text clippings. Click the Save button to save the note.
Action menu
The Action menu located at the bottom of the Sorter panel offers some commands that can be handy. Use the Action menu to open the Sorter's Preferences, flush all boxes (automatically opens DEVONthink Pro Office and all databases that are needed), or quit the Sorter. When the Sorter is not open, use the Preferences or the Dock menu to show it again.
Hotkeys
The Take Note and Copy Selection shortcut that you can set in the Sorter Preferences allow you to open the Sorter in take note mode or to capture a selection in another application and save it to the Sorter's inbox. The latter works similar to the Sorter's Send To Inbox command in the Services menu.
Shortcuts & Modifier keys
Use the following keyboard shortcuts to use the Sorter efficiently:
Troubleshooting
Re-appears after log-in: If you have set the Sorter in its Preferences that it should not open automatically when you log-in but it still does so, open the System Preferences, Users section, Log-in Items tab. Remove the Sorter manually.
Edit 'Hide' settings: If you accidently told the Sorter (not to) hide when an application goes to full-screen mode and now you want to change this behavior, do the following: First quit the Sorter, e.g. by using its action menu. Then, open the Terminal application (located in /Applications/Utilities) and copy the following line into a new window, followed by the ⏎ key:
defaults delete com.devon-technologies.think-sorter UserSpecifiedFullScreenApplications
This makes the Sorter forget its hiding settings and you can set them anew.
Bookmarklets & Extensions
DEVONthink Pro Office supports bookmarklets. Bookmarklets are special bookmarks that do not load a saved address but execute a little JavaScript application that, for example, adds a bookmark to the current page in your DEVONthink Pro Office database or that creates a web archive of a page. Basically, bookmarklets use your web browser's bookmark function for creating handy shortcuts for application functions.
In addition, the functionality provided by the 'Clip to DEVONthink' bookmarklet is also available as an extension for Safari 5, Firefox, and Google Chrome.
DEVONthink Pro Office supports a number of bookmarklets and browser extensions that you can find on our web site: Click here to open the Download page.
To install a bookmarklet, drag it from the page to your web browser's bookmarks, preferably the bookmark bar. You can organize the bookmarklets like any other bookmarks but placing them into the bookmark bar keeps them handy at all times. To download the Safari 5, Firefox, or Chrome extensions simply use the buttons on the web page, then double-click them in the Finder or use your web brower's extension manager.
Using Bookmarklets
Launch the web browser you have placed bookmarklets into, such as Safari. Next, load any page that you wish to archive or from which you want to clip text. When the page is shown, select the bookmarklet of choice in your bookmarks bar or click the button installed by the extension. Instead of loading another page, as normal bookmarks would do, the bookmarklet or extension will add the selected text or the whole page as note, bookmark, HTML code, web archive, or PDF to the destination you choose in the pop-up menu at the top of the panel.

The Clip to DEVONthink bookmarklet or extension is the most comfortable choice as it calls a special panel in DEVONthink Pro Office that lets you enter a title as well as a note and tags and lets you choose in which format you want to save the clipped data. The note is either saved as a text file or, for a bookmark, HTML document, web archive, or PDF is placed into the comments field of the created document.
Synchronizing
DEVONthink Pro Office has the ability to synchronize its databases with DEVONthink To Go, its companion app for iPhone, iPad, and iPod touche devices. Keep all your important documents literally at your fingertips!
Synchronizing With the Device
DEVONthink Pro Office uses a special group named Sync to let you decide which data you want to share with your iOS device. The Sync group appears on the top group level of all databases and has a special icon that makes it stand out from the other groups.
To select the items in your database that you want to take with you on your device, either move or replicate them into its Sync group. You replicate items e.g. by dragging them with the ⌘ and keys held. In the global inbox there is no Sync group; it is always synchronized as a whole.
You can add documents as well as whole groups to the Sync group. Smart groups are not yet supported and will be ignored during synchronization.
Make sure your device is on the same WiFi network than this computer. On the device open the DEVONthink To Go app. Tap the sync button on the app's home screen and follow the instructions.
If you have problems synchronizing your with device, click here.
Troubleshooting
If you have problems synchronizing your with device, click here.
If you have other problems with using the Sync group or the DEVONthink To Go app, please visit the user forum. Should this not answer your questions or solve your problem, click here to contact the DEVONtechnologies support team.
Visit the App Store
If you do not yet have DEVONthink To Go installed on your device, learn more about it or visit the App Store.
Scripts and Third-party Apps
DEVONthink Pro Office comes with a fully loaded AppleScript dictionary that allows you to automate almost every aspect of the application. Use the included (and useful) add-on scripts and Automator actions to perform seldom-used functions. Or, use the included scripts and actions as templates for your own scripts and workflows.
Introduction
DEVONthink Pro Office features one of the largest AppleScript dictionaries of all Mac OS X applications available. These scripts make it possible to automate nearly every aspect of the application, and to integrate the application with almost every other application supporting AppleScript.
To make it easier for you to start with scripting right away, we deliver a slew of scripts with DEVONthink Pro Office that you can access in the Scripts menu (which shows a stylized S symbol as its title instead of the word Scripts). These scripts interact directly with a selected group or document, or create documents themselves. In addition, the smart template are based on AppleScript scripts. All scripts delivered with DEVONthink Pro Office are also useable in everyday work, and are not simple examples skeletons that need to be tinkered with first.
Other ways to use AppleScript for extending and integrating DEVONthink Pro Office are triggered scripts, folder actions, droplets, and PDF Services scripts. You will find descriptions of the scripts that come with DEVONthink Pro Office in the corresponding sections of this chapter.
Integrating Other Applications
In addition to the scripts that you use inside DEVONthink Pro Office, Mac OS X features a global script menu that allows you to access certain scripts from any application on your Mac, for example your web browser or Apple Mail. When activated, it appears at the right side of the menu bar (like other menu extras such as the AirPort signal strength or the Spotlight icon). It appears with a black stylized S icon.
Note: By using folders named after applications inside the '~/Library/Scripts/Applications' directory, it is also possible to make scripts application-specific. Such scripts will appear at the top level of the global script menu when the application they belong to is frontmost. This removes clutter and shows only scripts that make sense in the current application.
DEVONthink Pro Office already comes with a number of scripts that you can access conveniently from the global script menu. DEVONthink Pro Office asks to install them whenever you update the application, or you can (re-)install them manually by selecting DEVONthink Pro Office > Install Add-ons. They will be installed in '~/Library/Scripts/Applications/<TargetApp>' and only apply for the user currently logged in. Also, they only show up in the script menu when the application for which they are designed is the front-most application (the one that currently populates the menu bar).
To activate the global script menu, do the following:
To install your own scripts (such as the scripts that come with DEVONthink Pro Office), copy them into the folder '~/Library/Scripts'. You can use sub-folders to structure them in any way you like.
DEVONthink Pro Office's Dictionary
DEVONthink Pro Office includes a large dictionary with commands, objects, and methods you can use for writing scripts that interact or extend DEVONthink Pro Office. To view the dictionary, open the Script Editor application (by default located in '/Applications/AppleScript'), select File > Open Dictionary and choose DEVONthink Pro Office in the appearing window.
You can also add DEVONthink Pro Office to your Script Editor library. Select Window > Library, click the + button and choose DEVONthink Pro Office. This way you keep DEVONthink Pro Office's dictionary at hand.
Caching
DEVONthink Pro Office caches pre-compiles and caches scripts as soon as they're called for the very first time. So, when you are modifying a script you need to make sure DEVONthink Pro Office takes notice of the changes. For scripts in the Scripts menu, use the Scripts > Update Scripts Menu command.
Learning AppleScript
This documentation is not an AppleScript language guide. Please refer to Apple's AppleScript web site, other online resources, or introduction and reference books for more information on the AppleScript language. Here are some links for you:
Installation
All add-on scripts that come with DEVONthink Pro Office are automatically installed or updated when you open a new version of DEVONthink Pro Office for the first time. You can, however, manually (re-)install them by choosing DEVONthink Pro Office > Install Add-ons
The scripts are installed in a number of locations:
Internal Scripts
The internal scripts menu of DEVONthink Pro Office, located to the left of the Help menu (in DEVONthink Pro Office's menu bar), gives you access to a large number of pre-made scripts and Automator workflows that extend DEVONthink Pro Office with additional, more specialized commands and functions.
More scripts are available as extras. [Read more...]
Of course, you can easily modify all these scripts using the AppleScript Editor (and the workflows using Automator) or add your own scripts and workflows to the menu. They are located in '~/Library/Application Support/DEVONthink Pro/Scripts'. Open this folder in the Finder with Scripts > Open Scripts Folder.
Note: If you have modified the contents of the script menu and you want to go back to the default set, delete the complete Scripts folder in '~/Library/Application Support/DEVONthink Pro/'. DEVONthink Pro Office will recreate this folder, including it's content the next time you next launch the application.
Note: If you want to add keyboard shortcuts to scripts in this menu, you either use the System Preferences or you simply add the shortcut description to the file name of the script in '~/Library/Application Support/DEVONthink Pro/Scripts' or '~/Library/Scripts'. Example: 'eMail Current URL (Mail)___Cmd-Alt-M.scpt'. The naming convention is three underline characters followed by the shortcut description. 'Cmd' stands for the Command, 'Alt' for the Option, 'Ctrl' for the Control, and 'Shift' for the Shift keys.
Comments
Data
Dates
Download
Edit
Execute
The following scripts provide some seldom-used export functions and help you create backups of your database (for copying them to external media such as CD-R or JungleDisk).
Feeds
DEVONthink Pro Office can be used as a news feed reader. To work with news feeds, use the dedicated feed document type.
The following scripts demonstrate additionally methods how DEVONthink Pro Office can directly plug into live information sources by the use of AppleScript.
Format
Images
Note: While these scripts work also with PDF documents it is not advisable to do so. The functions used only act on the first page of a multi-page PDF and the resulting document will contain the first page only.
These scripts demonstrate DEVONthink Pro Office's ability to import data from various sources, including web sites.
The following scripts import chatlogs and call logs from popular instant messaging clients as well as from your mobile phone:
Rename
Sheets
Even though DEVONthink Pro Office is no spreadsheet application, it does have these scripts that exemplarily implement basic sum and mean value functionality for sheets.
Toolbar
By default this contains no scripts. Add your own scripts here and add them also to the toolbar of main and search windows using View > Customize Toolbar.
Thumbnails
Note: While these scripts work with all image formats including PDF, they should not be used for PDF documents. They will only work on the first page of the PDF and destroy all embedded metadata.
Translate
About this Menu
Shows an information dialog window about the Scripts menu.
Browsers, E-Mail, RSS Readers
AppleScript is perfectly suited for integrating different applications, interchanging information, and creating workflows. DEVONthink Pro Office comes with a number of scripts that copy information from other applications, like Safari or Mail, to DEVONthink Pro Office. You may use these scripts as a template for connecting DEVONthink Pro Office to your own applications.
To install these scripts completely automatically, click here [special link, not enabled in ebook] or select DEVONthink Pro Office > Install Add-ons, check Application Scripts and DEVONthink Pro Scripts, and click Install. You access them via the global script menu extra.
Note: The application-specific scripts (put into sub-folders of "~/Library/Scripts/Applications") appear only within the application they were designed for (see introduction). To see them, activate their designated application, e.g., by bringing one of its windows to the front. The other scripts are located in a sub-menu named "DEVONthink Pro".
DEVONagent, Chrome, OmniWeb, and Safari
These scripts import elements from a displayed web page in Safari, Google Chrome, OmniWeb, Firefox, Camino, or DEVONagent to DEVONthink Pro Office.
Note: Not all of these options are available for all browsers.
The scripts add the currently displayed page or image, the selection or the text of the current page, the linked images of the current thumbnail gallery, or the links of the current page from your browser to DEVONthink Pro Office or its download manager.
Email Applications
Note: DEVONthink Pro Office comes with much advanced email archiving functions. Have a look at them before using these scripts.
Starting with Mac OS X 10.5 Leopard you can drag messages from Apple Mail to DEVONthink Pro Office to import them. In addition you can use the provided scripts or just transfer selected text to DEVONthink Pro Office by using the Services menu. DEVONthink Pro Office comes with scripts for Apple Mail, Microsoft Entourage, and Microsoft Outlook 2011.
These scripts, all named Add message(s) to DEVONthink, Add mailbox(es) to DEVONthink, and Add message(s) & attachments to DEVONthink and located in the respective sub-folder for their target application, copy selected messages, mailboxes, or both messages and their attachment from Apple Mail, Microsoft Entourage, or Outlook to the currently open DEVONthink Pro Office database. If possible, they set the creation and modification dates of the imported messages to the receipt date and the URL field to the sender's address. Both Add mailbox(es) scripts also recursively import mailboxes inside the selected mailboxes and rebuild the mailbox hierarchy within a group named Entourage Mail or Apple Mail in the currently open DEVONthink Pro Office database.
These scripts, namely the script named Add news to DEVONthink, allow you to add selected or flagged news from NetNewsWire and Endo to the currently open DEVONthink Pro Office database. If correctly installed (see above), select any news you want to copy to your database and select the script from the global script menu extra.
Other Scripts
The remaining scripts designed for the script menu extra allow you to copy selected text to your database, or to create a link to the front-most document. They're grouped in the DEVONthink Pro sub-menu.
Triggered Scripts
Triggered scripts are AppleScripts that you attach to an item in DEVONthink Pro Office (a group or document) and that are executed each time you display this item (like selecting it in Split view). Items with attached triggered scripts show an AppleScript icon behind their name.
Using triggered scripts, you can bring your items to life and let them act intelligently on various parameters. Examples for triggered scripts can be found in the folder "Extras/Scripts/Triggered" on the DEVONthink Pro Office disk image.
Attaching a triggered script
Besides creating scripts that attach themselves to an item, you attach them manually by doing the following:
Removing a triggered script
To remove a triggered script from an item, do the following:
Droplets, Finder plugins, PDF Services
Droplets
Droplet are little AppleScript applications that allow you to run actions based on files or folders dropped on them. You can create them easily using the AppleScript editor; some useful examples already come with DEVONthink Pro Office on the disk image in 'Extras/Scripts/Droplets'. Basically, they do what their name suggests:
Using Droplets: Place a droplet anywhere you like and optionally drag it to the Dock. Then, drag the files and folders you want the droplet to act on onto its icon in the Finder or the Dock.
Folder Actions are scripts that you can attach to folders in the file system and that act on all items you add to these 'hot folders'. DEVONthink Pro Office comes with three folder action scripts that you can install using the DEVONthink Pro Office > Install Add-Ons menu option:
Attaching a Folder Action: To attach a folder action script to a folder, do the following:
Manage Folder Actions: To manage all your folder actions, right-click a folder and choose Configure Folder Actions (Mac OS X 10.5) or Services > Folder Actions Setup (Mac OS X 10.6) from the contextual menu. Use the Folder Actions Setup utility to see which folders have scripts attached, and to remove folder actions from folders.
The Mail Rule Action Import script imports all the emails that the mail rule acts on to the currently open database.
To use this script, do the following:
Using PDF Services, you can add your own actions to the PDF button of the print dialog windows in any Mac OS X application. DEVONthink Pro Office adds an alias of itself to the PDF Services folder.
Installation: To install the PDF Services alias select DEVONthink Pro Office > Install Add-ons and check PDF Services in the dialog window. Then click Install.
Printing to your database: To 'print' (save) a document to DEVONthink Pro Office, open it in its creator application (this could even be DEVONthink Pro Office itself). Then, do the following:
Note: This requires an installed printer to work properly.
More Examples
Some of these scripts do things that have already been implemented as 'real' commands in DEVONthink Pro Office', others are functions you will seldom use. All of the scripts are more example than everyday functions, yet all can be of real use.
You can also find more scripts in the Extras area of the Support Assistant. [special link, not enabled in ebook]
Automator
DEVONthink Pro Office also comes with a bundle of integrated Automator actions that you can use to create your own Automator workflows.
To see which actions DEVONthink Pro Office provides, open a new workflow in Automator and click the Actions button, then search for DEVONthink Pro Office in the Library. Automator then displays all actions contained in the application. Select any action to show a short description about what the action does.
Note: Cannot find the Automator action you need for your workflow? We're open to suggestions!
Overview
We have created some workflow examples that show you how to use Automator and DEVONthink Pro Office together. This document explains what the workflow examples are supposed to do, and how you can adapt them for your situation. The examples are presented here are grouped around common functionality.
File Management
Managing files with DEVONthink Pro Office is one of its best features. Here are different ways to work with the information in the database.
Move Existing Files: You have a folder with files that you think are in control by DEVONthink Pro Office, but you want to move the files that are guaranteed to be found in the database to a different folder (let's say 'Archive'). This workflow will solve this problem for you. For the given files/directories, it will find all files, and ask the database if items exist with these paths. For the ones that are found to exist, move these to a specified folder.
Note: The exact locations have not been defined in this workflow, that is up to you. DEVONthink Pro Office will keep track of the moved files, so you don't have to change anything in the database.
To improve your workflow, specify a specific database to use by prepending the Filter Items action with an Open Database action. In general, it's a good idea to specify the database a workflow has to act on.
Add and Move Missing Files: Find out what files are not in the database by changing the value in the Filter Items to Missing in the previous workflow. Then we use the Move Finder Items action to place these files in their rightful place in our folder hierarchy. These files will be sent to the Add Items to Current Group action after setting the destination group, this will index the files into the database.
To improve the workflow, specify a database to use by prepending the Filter Items action with a Open Database action. In general, it's a good idea to specify the database a workflow has to act on.
Start Workday: This workflow is something you'd start every day when you're ready for work. It is rather complicated but really shows off what you can do. Let's go through the steps:
End Workday: At the end of your day, you'd like to make sure that the database is updated with the modified contents of the files you've been working on. That's the goal of this workflow. It synchronizes every record in your 'Today: To Do' group.
Copy Checked Records to iPod Notes: Whenever you feel like showing off to your colleagues that you have the coolest gadgets and software, you can use this workflow to get the text of the finished work in your To Do list and send it to your iPod. The order in which your notes will appear depends on the sort order of the records in the 'Today: To Do' window.
Web Management
Dealing with the web is where DEVONthink Pro Office really shines. Here are a few workflows that help you manage the information you're gathering form the Internet.
Capture Safari Page: Another take on getting information from Safari. If you save this example as an application and put it into your Dock, you can very easily get the information from the current web page in Safari into your database. This is because the Add Items to Current Group workflow will actually download the given URL so that its contents can be made available for searching.
Convert URLs to Webarchive: This workflow shows how you can convert URLs to webarchives. Let's go through the steps:
Gather Information from Safari: The next two workflows are not great for our bottom line, yet we've decided to present these helpful hints free of charge! The first in the series is a script that gets all the links (within the domain of the starting page) from Safari's open web pages and puts these into a special group called 'Temporary Safari Links'. For each entry in this group, you can see its status. The contents will be indexed (so loading these may take a while).
Now you can go and do some searching for information you want. For the records in this group that match your criteria, you will set the state to 'checked'.
Store Information from Safari: The second and last workflow in this series will clear up the mess we made. It gathers all the checked records and asks to move these to a group you specify (note that for this action we specified that the action has to be shown).
Also, take a look at Step 8, here we have to Ignore Result from Previous Action, because we don't want you to delete the work that you spend so much time on! The remaining records in the temporary group will then be deleted.
Now, why are these two workflows bad for our bottom line? Because they compete with DEVONagent Pro. (Although, truth be told, DEVONagent Pro does a much better job at this then we can emulate with a couple of Automator workflows).
Other Workflows
Of course, Automator workflows can also be used to manipulate items in the database.
Set Attributes Recursively: A simple workflow that, when saved as an application, deserves a place in the Scripts menu. It is relatively simple:
Add in Finder: Save this workflow as a Finder plugin; then you can import a file selection from the Finder into a group that you select in an open database. You should remove the first action and name it 'Add to DEVONthink Pro'. Then you will see it in the Finder's contextual menu in More > Automator.
Combine PDF Records: Use this workflow to combine one or mulitple selected PDF documents. As this workflow uses Preview to do its magic, metadata and annotations will be lost.
Compress PDF to 96dpi: Compresses images contained in PDF records to 96dpi, this can be useful if you have scanned documents and want to reduce the file size by optimizing them for on-screen display only.
Open DEVONthink Spotlight Item: Opens the selected DEVONthink items listed by a Spotlight search in the external applications assigned to their type.
AppleScript-based Workflows
Store Safari Selection in Specified Group: This is an example for more advanced scripting users. It uses AppleScript inside an Automator action to achieve a goal that is not possible with the existing actions.
Store DEVONagent Selection in Specified Group: Identical to the previous action in functionality but it uses DEVONagent Pro instead. Note that DEVONagent Pro comes with its own convenient collection of actions that allow you to create sophisticated workflows in combination with DEVONthink Pro Office.
Convert Selection using OCR: Convert selected images stored in DEVONthink Pro Office using the built-in optical character recognition (OCR) into searchable PDFs. Things to look out for in the AppleScript code are the timeout and the possible error codes that can be returned during the conversion.
Troubleshooting
DEVONthink Pro Office was created with robustness in mind. But still, computer hard- and software can write defective data or destory files. If you have troubles with your database, please refer to the methods below and also have a look at our FAQ.
Repairing a defective database
DEVONthink Pro Office databases are packages containing of your files and the supporting AI-based index. In rare cases this index can get corrupted or out-of-sync. But as you files are stored separately this is not the world's end. If your database starts behaving stragely or if DEVONthink Pro Office itself finds inconsistencies when doing its start-up check it is time for some house-keeping.
Step 1: Verify & Repair
As a first step use Tools > Verify & Repair to check your database's consistency and allow DEVONthink Pro Office to take all necessary steps to repair the found problems. If Verify & Repair was able to repair your database, use Tools > Backup & Optimize to optimize your database and have DEVONthink Pro Office create an internal copy of the index.
If Verify & Repair was not successful or your problems are not solved, proceed with the next step.
Step 2: Restore from backup
With its factory setting, DEVONthink Pro Office keeps up to two copies of the index files in case that the index is damaged beyond repair. You can change when and how many internal backups DEVONthink Pro Office keeps in the Preferences, Backup tab.
To restore from a previously saved internal backup (means: a copy of only the index files), use Tools > Restore Backup DEVONthink Pro Office presents you with a list of all available backups. Choose the latest one and click Open. This swaps the current set of index files with the copy (the current set of index files becomes the backup, the backup becomes the current set) so that never any data is overwritten. Run Tools > Verify & Repair to check the consistency of this index version and if everything is in order use Tools > Backup & Optimize to optimize your database and have DEVONthink Pro Office create a fresh internal copy of the good index.
If the backed-up index files are also defective, try the other backups, of available. If all backups are broken, too, proceed with the next step.
Step 3: Rebuild your database
As your files and DEVONthink Pro Office's index are stored independently within the database package the index can be rebuilt an any time without you losing too much metadata. To rebuild the database from scratch use Tools > Rebuild Database.
The global inbox database cannot (yet) be rebuilt using the steps above. Use the following steps to rebuild the global inbox database manually:
During the rebuild process the complete index is re-created. Your actual files are not touched. All problems that occured during this process are logged.
Orphaned files: Orphaned files that could not be imported while repairing are logged and moved to the folder 'Orphans' inside the database package. To access the contents of the package, show the database package in the Finder, right-click it, and choose Show package contents from the contextual menu. Move the files in the 'Orphans' sub-folder to a save location, e.g. the Desktop, or directly re-import them by dragging them to DEVONthink Pro Office's Dock icon. Please do not change anything here except for rescuing the orphaned files.
Step 4: Time Machine or manual rescue
If everything above failed it seems that your database is severely damaged. You have two options now:
Step 5: Contact support
If none of the above steps helped solving the problems you have with your database, please contact DEVONtechnologies' support staff with a precise-as-possible description of your problem.
DEVONthink Pro Office crashes when opened
If a database is heavily damaged it can happen that DEVONthink Pro Office crashed when opening the database or when starting up. In this case you cannot use the build-in mechanisms for recovering your data. But you can go back to one of the internal backups manually. With its factory setting, DEVONthink Pro Office keeps up to two copies of the index files in case that the index is damaged beyond repair. You can change when and how many internal backups DEVONthink Pro Office keeps in the Preferences, Backup tab.
To revert to one of the internal backups, quit DEVONthink Pro Office and locate the database package in the Finder. Then do the following:
Now you should be able to open the copied Backup folder as a new database by double-clicking it. Afterwards use Tools > Verify & Repair to ensure that everything's fine.
If this did not help, please contact DEVONtechnologies' support staff with a precise-as-possible description of your problem.
Recovering a lost password
If you have protected a database and you have forgotten your password, do the following to remove the password protection:
A future version os DEVONthink Pro Office will feature an industry-strength encryption.
Items keep re-appearing in the inbox
If files keep re-appearing in your global inbox even though you definitely have deleted or moved them in DEVONthink Pro Office, it may be that some files with bad permissions got locked up in the Inbox folder.
Open the folder '~/Library/Application Support/DEVONthink Pro 2/Inbox' (where ~ is your user's home directoy) and delete them manually. This should keep them from re-appearing.
Problems importing files
Why does DEVONthink Pro Office not recognize my files?
If DEVONthink Pro Office does not recognize a file make sure it has a proper file name extension. DEVONthink Pro Office needs a file name extension to determine the file type. Add the correct file name extension to your files (e.g., .txt for plain text files, .rtf for rich text files, .pdf for PDFs and .doc for Microsoft Word files. Then try again.
Why does DEVONthink Pro Office not display my document correctly?
If a document is not properly displayed, especially if it is a proprietary file format such as RagTime or Mellel, make sure that you either have a Quick Look plugin installed for this file format or that the application that created it is installed on your Mac (and supports Quick Look). DEVONthink Pro Office will be able to display the document if you can display the file also e.g. in the Finder by pressing the Space bar.
Why do some PDFs appear as images and are not searchable?
DEVONthink Pro Office cannot extract the text part of print- or editing-protected PDFs. When you import them, you get a log entry that tells you that the PDF file contains 'no text'. When you select these documents in DEVONthink Pro Office, the status bar shows 'image' instead of 'PDF+text'. A cheap solution for this problem is Michele Balistreri's PDFKey. It allows you to print protected PDFs. Use PDFKey to 'print' a PDF file into a new PDF that is both printable and editable — and the latter allows DEVONthink Pro Office to extract the text for searching and classifying.
Email import does not work as expected
Dragging a message thread from Apple Mail does not work, the currently selected messages will be imported instead. Also, mailboxes, to-dos, and more than one RSS article will not work. This applies also for dragging to the Sorter.
AppleScript scripts do not work as expected
Running a script inside DEVONthink Pro Office that uses OCR will fail with a timeout. Run the script outside of DEVONthink Pro Office instead.
Problems using Services
Why do the Services menu commands show no shortcuts?
They should, however, the keyboard shortcuts for Services menu commands are only requested by the supplying application; Mac OS X itself assigns them, and therefore has ultimate control over which application or service gets what. If the DEVONthink Pro Office Services menu items do not have shortcuts assigned, it is very likely that Mac OS X gave them to another Services command or that they are used by the application that is currently frontmost.
In Mac OS X 10.6 'Snow Leopard' and later you can manage your Services in System Preferences > Keyboard > Keyboard Shortcuts > Services.
Why do the Services not work in Firefox?
Services work only in Mac OS X applications based on the so-called Cocoa framework. Examples for Cocoa applications are, e.g, Mail, Safari, TextEdit, and, of course, all DEVONtechnologies applications. However, Firefox is a port of a Unix application not completely based on Cocoa. Therefore, it does not support Services. Try using Camino instead, a Cocoa browser based on the Firefox engine.
DEVONthink Pro Office behaves irrationally
There is no software on this planet that has no bugs and if an application behaves irrational there is a good chance that your have just found one. But there also can be another cause: The application package could have become damaged, for example during an update or through a bug in a totally unrelated piece of software on your computer.
Strange Application Behavior
If something happens like the following
please try to trash the application package. Then empty your web brower's cache, download the software in question again, and re-install it. In many cases this cures the problem.
If this does not help try deleting DEVONthink Pro Office's preferences files located in '~/Library/Preferences' and starting with 'com.devon-technologies.think'.
Strange Behavior Related to Documents
If the strange behavior only happens when you deal with one particular document it is likely that the document is damaged, was created in a very old or extremely new file format that is no longer or not yet properly supported, or uses a damaged or malfunctioning Quick Look plugin.
Please file a support ticket and attach the document in question, best packaged as a .zip archive, so that we can have a look at it and check if it is a problem in DEVONthink Pro Office or if it is just the file itself.
Strange Behavior of Tabs
With Zooom/2 installed, tabs in tabbed windows behave stragely, e.g. close by just hovering the cursor over the tab. Another effect of Zooom/2 are scrolling problems in e.g. iTunes. Disabling Zooom/2 solves the problem.
Problems synchronizing with DEVONthink To Go
If you cannot properly synchronize your databases with DEVONthink To Go on your device, please check the following:
If you still have problems with synchronizing, please first consult the Frequently Asked Questions, and visit the user forum. Should this not solve your problem, click here to contact the DEVONtechnologies support team.
FAQ
Do you have questions regarding our licensing policy, our products in the Mac App Store, or specific questions about DEVONthink Pro Office?
General questions
Do you have any job opportunities?
Yes, we may. Please visit our Work @ DEVONtechnologies page for more information about current open jobs at DEVONtechnologies.
Can I be a beta tester?
Maybe. Our beta tester selection process is very deliberate; we try and select our beta testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can provide us with feedback quickly and clearly, who use different hardware and software from our other testers, and who are willing to send us their personal data if it's needed for debugging.
If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask active participants on the user forums if they can help us test particular features and new products. You can, of course, simply contact us.
Is the documentation available in my language?
The online and PDF documentation is only available in English at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is cost-intensive and error-prone so that we have decided to concentrate our resources on developing stable, robust, and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the necessary resources.
Where does the name DEVONtechnologies come from?
"Devonian (after Devon County, England), the geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians appeared on the land, that until then was only inhabited by trees and other plants — it was the departure into a new age." Named after the Devonian period, the DEVONtechnology marks the departure into a new age of data processing.
Note: Ray Troll has even created songs and other art about this extremely important evolution step.
Release schedules, Mac OS X, and Windows
When is the next release coming
We try not to announce precise timelines or feature lists for future releases, as we are a small software company with limited development resources; if one of us should happen to get the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our intended development schedules.
In planning releases, we try to strike a balance among:
We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's often impossible to predict the final release date accurately when we start new projects. We try to plan our releases with a long term perspective so that they ultimately serve the needs of our customers, even if they don't necessarily get in everyone's favorite feature request every time.
Why are your applications not compatible with my pre-release version of Mac OS X?
In the past, we've noted that compatibility issues with a new major release of the operating system are usually resolved by Apple in the final stages before its release, and don't require any action on our part. If you are already using a pre-release version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches the release candidate status. We will then make all necessary adjustments for making our apps run on the first official release of the new version of Mac OS X.
Any chance of a Windows versions of your products?
We're very commited to Mac OS X and the superior Cocoa environment. For most of our applications, porting them to Windows would take longer than it would to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our products consider running Windows on a Mac.
Purchasing
How do I purchase an upgrade?
Please use DEVONthink Pro Office > Check Upgrade Options to find out what you need to upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONthink Pro Office this application might not be upgradable. Please visit the Upgrade Assistant on our web site instead.
What is your policy on software updates?
Usually, all minor updates ('dot updates', such as version 1.2 to 1.3) to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store click here.
Can I get the bundle discount also later?
Bundles are cheaper than multiple single licenses because a bundle means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please contact our sales staff if you purchased one of the bundled produts within the last two weeks.
Do you give a discount to students and educators?
Yes, we give 25 percent off the regular price of DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give volume discounts to institution or faculties. Please visit our Students, Educators and NPOs page.
Do you offer NPO licenses?
Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of charities. Learn more about our NPO program.
Can I use your software on multiple computers?
Yes, our license explicitly allows one and the same person to use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.
I have no credit card. How can I purchase your software?
We are selling currently through the online sales agent Share*It to keep our administration as lean as possible. If you don't have a credit card, you can also pay via PayPal or by purchase order, wire transfer, or even cash. See our online shop for more details.
In addition we are also selling some of our products through the Mac App Store. Please open the App Store application on your Mac to learn more about which payment options Apple offers.
Can I have more time for evaluating your apps?
No problem. We happily give out 30 day licenses for evaluation purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in DEVONagent Express.
Why haven't I received my license code(s)?
If you have purchased your license in our online shop and if there have been no technical problems on our side, your license codes have been sent out to you immediately after your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's). Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support Assistant to get them resent to you. If this also doesn't work, please contact us and we'll try to get your license codes to you as quickly as possible.
Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4?
License codes for legacy versions are no longer available in our shop but even the latest license codes are always backward-compatible: You can use a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a license for the most recent version of the product in our online shop and use it with your legacy software.
Mac App Store
How can I upgrade apps purchased in the Mac App Store?
By Apple's rigid rules you couldn't. Upgrades are simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In some of our apps there may be an upgrade option still available, though. Check the Read Me to see if this is the case for you.
Can I get a refund?
We freely refund licenses purchased in our own shop. For apps purchased in the Mac App Store this is not possible, though, as Apple does not provide a refund and license withdraw mechanism. Sorry.
Your software license
Why does DEVONthink Pro Office not accept my license code?
When you enter your license code and the 'Register' button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code from our email into the appropriate fields of the registration dialogue window. Also, please check if you have obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x license code).
I have lost my license code. How can I retrieve it?
Use Help > Support Assistant to open the Support Assistant which has an option to get your license code resent to you. Alternatively visit the support area on our web site.
Does my license code work also for an older version?
Yes, it does. All our license codes are backward-compatible to legacy versions of the same product and edition.
Why do I have to enter my license code again?
You only have to re-enter your license code after a complete reinstall of your system without a backup of your home folder or when the license code file has been deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license code again.
Why does my DEVONthink Pro Office 1.x license not work anymore?
DEVONthink Pro Office with version numbers greater than 1.x are paid upgrades. To use them you may need a new license code. Please use DEVONthink Pro Office > Check Upgrade Options to find out what you need to upgrade and how much the upgrade is for you.
Why does your application say that it expired?
When we release a public beta of one of our applications, we remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final release is, of course, available when this happens.
Please simply visit our Download page, download a newer version that the one you have installed, and replace your copy with the newer one. FPlease first move the old application to the trash, then move the new one into its place.
Note: Your license code will, of course, NEVER expire.
Product-related questions
Click here to read questions and answers specific to DEVONthink Pro Office.
If you have problems with DEVONthink Pro Office click here to read the troubleshooting instructions and tips.
Technology
All commercial DEVONtechnologies applications are based on a proprietary AI technology, with rock-solid database foundation that allow them to manage large numbers of documents or knowledge bits while analyzing them almost instantly at the same time.
General Concept
DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new technology at the very beginning of its development. DEVONtechnologies constantly improves the technology and enhances it for more functionality, efficiency, robustness and flexibility.
Development of the DEVONtechnology is a battle on two main forefronts of information processing technology. DEVONtechnologies is working hard on unifying both the top-down and the bottom-up AI concepts by imitating high-level functions and simulating the basic functionality of natural systems. This leads to highly functional, fast and efficient AI systems that can be used in a great variety of information processing contexts, such as pattern recognition, signal processing and information storage and retrieval.
Features
The DEVONtechnology is a rock-solid foundation suitable for a variety of completely independent applications. Therefore it is ideal for the rapid development of a huge range of new database-, signal-processing- and language-analysis-driven applications. The ability to deal with any kind of digital data makes it extremely flexible.
The size of DEVONtechnology-based databases can, depending on the type of data stored, grow logarithmically and make indexing is completely unnecessary. Also, applications based on the DEVONtechnology improve themselves continuously (the more data they handle, the better the results), are language-independent and iron out any irregularities by applying fuzzy logic.
Structure
The DEVONtechnology consists of a kernel and several layers. Together they perform all the underlying computing, from 'simple' data handling to complex signal processing.
Kernel: The kernel is the foundation for all layers and applications and is responsible for data handling, semantic and associative data processing, signal processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast, flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary file format (see above) allowing it to verify and repair low level data consistency, featuring logarithmic growth of the database and logarithmic speed decrease with increasing database size. The DEVONtechnology kernel is Unicode-aware, completely language-independent and self-optimizing and self-organizing.
Layers: The layers form a shell around the kernel and provide high-level functions for the applications built on top of them. The database layer, for example, is used to store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies and freeform databases. No indexing or primary keys are required, strings can be unlimited in size and it's possible at any time to extend the range of pre-defined data types (Boolean, character, float, double, signed, unsigned, string, date, time, blob, color, size, and point). Another layer, the XML layer, makes it easy to handle XML code within the DEVONtechnology; it has a very small overhead, compared to DOM parsers or available XML databases, requires no indexing and supports the tight integration of other databases (and vice versa).
Applications
Some of the most likely applications for the DEVONtechnology are databases (knowledge bases, expert systems, search engines, table-of-content-generators, instant data-mining), intelligent agents, encryption, compression and archiving. Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical character recognition (OCR), speech analysis, recognition and synthesis, staticstics, thesauri and automatic translations.
In particular, applications dependant on processing human language, either written or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies' main focus in the development of new applications is in these areas: databases, 'intelligent' agents, text and speech analysis, statistics.
Look forward to see a great range of different applications based on the DEVONtechnology. A few have already been announced on the DEVONtechnologies web site: www.devontechnologies.com.
Other Products
Besides DEVONthink Pro Office, DEVONtechnologies publishes a number of other commercial, shareware, and freeware applications, and services that you may be interested in.
At a Glance
DEVONtechnologies is focused on developing innovative applications for finding, storing, and organizing information. Our main objective is to make complex yet flexible technology that is both easy to use and lightning fast.
All applications are based on the DEVONtechnology, a powerful and solid core unique to DEVONtechnologies. DEVONthink, DEVONnote, and DEVONagent are only the first of many more DEVONtechnology-applications yet to come.
Also, we publish and distribute useful shareware and freeware applications that help you in your everyday work with your Mac.
Newsletter & Forum
Would you like DEVONtechnologies to keep you informed about updates and new product releases? Subscribe to the newsletter.
And don't forget to have a look at our very lively user forum , where users of all skill levels meet to discuss our applications, talk about our technology, and exchange tips and tricks for DEVONthink & Co.
DEVONthink
Make the dream of the paperless office come true with DEVONthink and keep all your text and RTF files, scanned documents, notes, emails, images, chat logs, bookmarks, and multimedia files together in one simple to use database. DEVONthink allows you to integrate both local documents and live content from the Internet, keeping all project- related information stored in one easy-to-access place.
Why DEVONthink?
DEVONthink not only stores documents, it also facilitates editing, analyzing, organizing, finding, and archiving your documents with its flexible work environment, powerful organization tools, and built-in AI architecture.
Integrated Workspace
Unlike Mac OS X's Finder, DEVONthink provides an integrated work environment with all the tools you need for working with information of all kinds, from simple text to PDFs and multimedia files. DEVONthink can intelligently assist you with filing documents, finding similar files, or searching the database, saving you the trouble of having to manually manage thousands of files.
As a native Mac application, DEVONthink is also tightly integrated with the Mac OS X operating system and its frameworks. It provides a dock menu, Services menu commands, and even makes heavy use of the Safari web browser engine and Mac OS X 10.4's advanced PDF library.
A Paperless Life
DEVONthink Pro Office [Read more...] comes with a number of 'paperless office' functions not present in other editions of DEVONthink:
Checking Your Upgrade Options
If would like to buy an upgrade DEVONthink Pro Office to a higher edition, you have the following options:
Depending on whether you have purchased DEVONthink Pro Office in DEVONtechnologies' online shop or in the Mac App Store the second option may or may not be available.
Click here to read more about DEVONthink.
DEVONthink To Go
Your document (literally) at your fingertips. DEVONthink on the Mac keeps your documents organized. But what about when you are away from your keyboard? Put your documents into your pocket with DEVONthink To Go, the DEVONthink and DEVONnote companion for the iPad, iPhone, and iPod touch.
Pocket Your Documents
Browse, view, and search your documents with the touch of your finger. Create new notes or take a picture of important information and convert it to a searchable PDF (requires DEVONthink Pro Office on the Mac). Quickly label documents and flag them for later review. Use the 'read' status to use it for reading the news feeds you archive in DEVONthink on the go.
You decide which databases and which groups and documents to synchronize with your device. DEVONthink To Go connects to its Mac counterpart via WiFi.
At a Glance
Read more more about DEVONthink To Go or visit the App Store.
DEVONagent Pro
DEVONagent Pro helps you search more efficiently on the web. It searches multiple sources, frees you from hunting for the really relevant results, and gives you power tools for your research.
Your personal meta search engine
DEVONagent Pro is not a simple Google interface. It knows how to talk to search engines — and how to squeeze the best out of them.
DEVONagent connects to as many search engines as you want, collects the data, and weeds out the junk that managed to slip through. It also scans your favorite websites and notifies you when it finds something that matches your query. It can even do all of this while you're sleeping; the results will be ready before you pour your first cup of coffee.
Get the good stuff, skip the junk
DEVONagent Pro is all about filtering what you don't want and giving you the best tools to find more of what you really want.
DEVONagent Pro doesn't simply trust the search engines. It filters all returned results again, allowing you to use advanced Boolean operators, proximity operators, and wildcards of unlimited complexity — something no single search engine allows you to do. DEVONagent's "scanners" can even find thumbnail galleries or linked PDF or Office documents for you. When you've found what you're looking but want a little more detail, the unique See Also list contains related pages from elsewhere in the search results, online and even from DEVONthink Pro.
The information you want, the way you want
Every research tasks is different. DEVONagent Pro supports this with many ways to list, read, even explore your data.
View the results as a list or as a smart text summary, and explore them with the topics map. Unread results are marked with a blue dot, just like in Apple Mail, so that you don't miss the one important piece of information you're looking for. Finally, for viewing web pages there's DEVONagent Pro's specialized web browser. Extract images, RSS feeds, links, email addresses, even linked documents with a single click and save them for reference or reuse.
Save your research and come back later
Research is not only about finding, it's about collecting data, sharing it, and using it to create something meaningful.
DEVONagent Pro exports your filtered and trimmed-to-the-max research results in a variety of formats, from a simple list of bookmarks to comprehensive RTF digests and PDF reports. The built-in, searchable archive keeps them for later reference, or you can send your results to DEVONthink. Finally, you can save your search and continue later on, or even share it with others via email.
How DEVONagent Pro can help your research
Click here to read more about DEVONagent.
DEVONagent Express
You love Spotlight but it searches only your Mac? DEVONagent Express combines the ease-of-use and ubiquity of Spotlight with the powerful web search technology of DEVONagent. Just like Spotlight searches your computer DEVONagent Express searches the web and presents the results directly in its menu.
Why DEVONagent Express
Perfect integration
DEVONagent Lite
DEVONagent Lite puts web search to where it belongs: next to Spotlight into your menu bar. Search all major and many specialized search engines and databases with a single click.
Search the web like with spotlight
DEVONagent Lite adds a web search field to your menu bar. Google, Bing, and many more always at your service. Its global keyboard shortcut saves you even that click.
Just click DEVONagent Lite's menu bar icon, or press its keyboard shortcut, and start typing instead of switching to your browser, opening a new window, and clicking the search field first. Hit Return and DEVONagent Lite opens the search results in your default browser.
Use the best engine for the job
Google & Co. are great for general questions but often it's better to ask the right people who really know.
Choose your search engine of choice from the magnifying glass pop-up menu to directly search in developer resources, blogs, dictionaries, directories, discussion lists, legal or medical databases, news, or reference sites such as Wikipedia. Find Facebook profiles, tweets, or images without deviation.
DEVONnote
DEVONnote helps you take notes and keep them organized. It keeps all your ideas, documents, important information, and even your web browser's bookmarks in one single, accessible place. DEVONnote supports you with professional, easy-to-use features, and helps create structure out of chaos with its unique AI functions.
DEVONnote is the most sophisticated notepad application for Mac OS X, and the only one that uses AI (artificial intelligence) instead of relying on you organizing your data completely manually.
Why DEVONnote?
DEVONnote was designed with the typical Mac user in mind-a user who is:
Consequently, DEVONnote comes with a clean, easy-to-use interface that gives you all the tools you need in a familiar Mac-like package. Even the most complex AI functions are just »buttons«, meaning one simple click can send DEVONnote into action, digging through all of your data to find a place for your latest note, or to show you all your ideas and concepts that are similar to the one you've just selected.
Brain Food Included
Of course, creative people don't just 'have thoughts', they often need new inspiration, too. We understand that, and that's the reason why DEVONnote comes with a complete Safari-based web browser and solid, but flexible, bookmark-managing capabilities. With DEVONnote, you can browse your favourite websites, then clip and save the most important information directly to your DEVONnote notebook.
But, of course, life is not just work! Use DEVONnote to watch and organize your favorite webcams, directly within your notepad.
Click here to read more about DEVONnote.
Needful Things
As an alternative to the Finder's find function, EasyFind finds files, folders, or contents in any file without the need for indexing. This is especially useful if you are tired of slow or impossible indexing, outdated or corrupted indices, or if you are just looking for missing features like case sensitive or insensitive search, Boolean operators, wildcards, or searching for phrases. In addition, EasyFind uses multi-threading and is therefore very responsive, even with multiple search processes running. The application provides contextual menus and Mac OS X Services, and displays the location of each item in a separate column for a better overview. EasyFind uses little memory, supports drag-and-drop and the clipboard, and optionally finds invisible items or items within packages.
PhotoStickies puts all your favorite pictures on your desktop, as stickies, floating or even borderless. Sticky pictures may reside on your computer, or on the Internet. PhotoStickies also displays live webcams on your desktop, updates them automatically, and even records them like a VCR.
Key features:
ThumbsUp
ThumbsUp is a simple, drag-and-drop based utility designed to create thumbnail images from batches of pictures. (The application supports all Mac OS X and QuickTime image formats, including PDF documents.) Image size, quality, sharpening, and antialiasing are configurable, and images can be scaled by percentage or limited to a maximum size. With a scaling of 100 percent, ThumbsUp may be used as an ultra-fast, comfortable image converter.
Use ThumbsUp to quickly create thumbnails, e.g., for using on your Web site or for sending by email.
XMenu
XMenu brings back Mac OS 9's Apple menu back from the dead, adding its functionality to Mac OS X. One or more global menus to the right side of the menu bar let you easily access your preferred applications, folders (and subfolders), documents and files Furthermore, there's no explicit need for a configuration (like creating lots of folders and aliases or adding items to user-defined setups)-just activate the menus you like: Applications, Developer Applications, Home, Documents, or User-Defined (like the old Apple menu found in Mac OS 9).
Besides the full-blown freeware applications, DEVONtechnologies also offers a variety of useful services that extend the functionality of Mac OS X's Services menu and that allow Cocoa applications like TextEdit or DEVONthink to open PDFs like simple RTF files. These services include:
Click here to read more about DEVONtechnologies' freeware applications and services.
Appendix
In the appendices you will find additional information that helps you getting familiar with DEVONthink Pro Office such as a glossary of commonly used terms, a listing of the Boolean operators that you can use in searches, and placeholders that you can use in templates for yet "targetless" WikiLinks.
Glossary
Become familiar with these terms to get the most out of working with DEVONthink Pro Office.
Keyboard symbols
Interface elements
The 'flagged' and 'locked' properties are indicated by icons. [Read more...]
FAQ (product-specific)
General
What is the difference between the various editions?
While all three editions of DEVONthink as well as DEVONnote share many features, there are some noticible differences. For instance, DEVONthink Pro is able to deal with more than one database, features tables, forms, and categories, and comes with full AppleScript support; and DEVONthink Pro Office comes with plugins for pro-grade email archiving, paper capture, and Web sharing. You can find a complete listing of all differences on the feature comparison page.
Which languages does DEVONthink Pro Office support?
DEVONthink Pro Office supports multilingual documents and Unicode and so supports all Asian languages including Chinese, Japanese, and Korean, as well as non-Latin scripts such as Cyrillic, Hebrew, and Arabic (including writing from right to left; use Format > Alignment > Writing Direction to adjust the writing direction).
Note: Asian languages, however, do not use word separators such as white space or punctuation. When searching you need to use wildcards. Use ~word or *word* in the search field or search window. The built-in ABBYY OCR engine does not support Asian languages, Arabic, or Hebrew due to licensing restrictions.
How do I completely uninstall DEVONthink Pro Office?
To completely remove DEVONthink Pro Office from your Mac, see the instructions in the Read Me.
Databases
Can I use more than one database?
Yes, DEVONthink Pro Office works with databases stored in packages instead of a central folder. You can double-click these packages like regular files to open the database, copy them over the local network (LAN) or back up hard drive, or burn them to a CD-R or DVD.
How are my documents stored?
DEVONthink Pro Office stores all documents in a package, a folder that looks like a file that you can double-click or otherwise manipulate like a regular file in the Finder.
Inside the 'Files.noindex' folder the actual documents are stored in sub-folders for their respective type and further sub-folders that help DEVONthink Pro Office to quickly locate them. Documents are never altered when you copied them into the database. The file name of each documents is exactly the same as the corresponding document name that you see in DEVONthink Pro Office.
In addition, the database package contains a set of ten index files named with the suffix '.dtMeta' as well as a 'Settings.plist' file containing database-specific preferences. Finally, the database package can contain one or multiple folders named 'Backup.x'. They contain backups of the index files and are created automatically by DEVONthink Pro Office's backup function. They do not contain copies of all actual documents.
How can I move my database to another computer?
Your database is a file with the suffix '.dtBase2' and is probably stored in your Documents folder. It can be copied to that or to another desired location on the other computer. If you cannot locate your database, search for it using Spotlight, e.g. by searching for 'dtBase2'.
Note: In general, databases are self-contained, so all one has to do is move it to another computer, open it and start using it. But if some of the content has been indexed instead of imported, it will be necessary to also move the externally linked files to the other computer in such a way that the Paths to the external files remain valid. If everything is in your Documents folder on the first computer, copying the externally linked folders and files to the Documents folder of the second computer will probably work. Always quit the DEVONthink Pro Office application before copying or moving a database, as copying an open database may result in an incomplete or damaged copy.
Can I put my databases on my server?
Theoretically yes. However, as DEVONthink Pro Office is not yet multi-user capable, only one copy of DEVONthink Pro Office can access a database at a time. DEVONthink Pro Office uses a 'lock file' to keep other copies of the software from accessing the database at the same time. If you use a setup like this, DO NOT override the appearing warning message or you will create database corruption.
Alternatively consider to use Web sharing to give other users on the network access to the shared databases using a standard Web browser.
Can I share my DEVONthink database using WebDAV or DropBox?
You can, but it is definitely not recommended as WebDAV servers do not fully support all properties of real hard disks. See below.
Can I synchronize databases between multiple computers?
We are currently working on a synchronization module that will allow you to sync databases between multiple computers either directly or via file servers or Dropbox. Please check our President's blog for up-to-date information.
In the meantime you can try to use a third-party product called 'DevonSync' made by Wooden Brain that synchronizes DEVONthink databases bi-directionally. DevonSync is not officially supported by us and we do not give any guarantee for your data's safety.
Scanning & OCR
Does DEVONthink Pro Office support the Fujitsu ScanSnap?
Yes, DEVONthink Pro Office comes with an auto-configuration plugin that makes the ScanSnap send all incoming scans directly to your database. OCR makes the scans searchable.
My scanner is not supported by Mac OS X. Does it support TWAIN?
If your scanner does not come with an Image-Capture-compliant scanner driver, please try the built-in ExactScan Capture.
Which OCR engine do you use?
DEVONthink Pro Office is equipped with the latest ABBYY FineReader engine. It converts PDFs and image files to PDFs with an invisible text layer behind the actual image. DEVONthink as well as other applications use this text layer to access the textual information and let you select and copy text. During the conversion the image is re-rendered according to the OCR settings. The ABBYY engine used in DEVONthink Pro Office supports most languages uses latin characters as well as Hebrew; Asian languages and Arabic are not yet supported.
Email archiving
Does DEVONthink Pro Office decrypt GPG encrypted email?
No, unfortunately, it doesn't. GPG is not as nicely integrated into the Apple Mail as it would be necessary for DEVONthink Pro Office to decrypt GPG encrypted messages.
Iconology
Additional icons behind item names, e.g. in main windows, indicate that the item has been indexed instead of imported, is locked, has a comment attached, or is scripted. Groups also serving as tags show, if necessary, a tag icon. Depending in your preferences replicants, duplicates, or replicated duplicates are also indicated with a little grey icon instead of appearing in color.
Tagging
DEVONthink Pro Office supports tagging in a way that makes groups and tags interchangeable. While this concept may sound a bit strange at first you will soon discover why it is a smart way to approach tags and group and to bring both together.
Introduction
Technically, tags and groups are identical: both are simply entries in a table that are somehow 'attached' to an item, usually a group or document. The difference is that tags are visualized as 'labels' attached TO the item while groups are visualized as groups CONTAINING the item. They are presented differently but internally they are the same.
DEVONthink Pro Office treats groups as tags and tags as groups. When it shows you the tags associated with an item it presents you with a list of all groups that the item is part of and that have not been excluded from tagging.
Example: A document is located in the group 'Science > Paleontology > Dinosaurs'. Consequently its tags are 'Science', 'Paleontology', and 'Dinosaurs'. Now you create a sub-group of 'Dinosaurs' named 'Land-living' and move the document into the new folder. Automatically it is now tagged with 'Science', 'Paleontology', 'Dinosaurs', and 'Land-living'.
The same happens when you replicate the document into multiple groups: It is tagged with the names of all enclosing groups (that are not excluded from tagging) of all its replicants.
When you assign a tag using DEVONthink Pro Office's user interface, move a document, or replicate it to another group, this is what happens:
Tags represented by a regular group are called "group tags", tags created without an existing group are called "ordinary tags". [Read more...]
Every DEVONthink Pro Office database contains a top-level group named 'Tags'. It is used whenever you add a tag to an item e.g. through the tag bar, for which not yet a group exists. In this case DEVONthink Pro Office creates a group for the tag in the Tags group and places a replicant into it.
When you rename a group here all items associated with it (means: that have a replicant here) will show this change.
Using Tags
To use tags for selecting documents, finding them, or browsing tags DEVONthink Pro Office offers the following options:
Wherever tags are shown, ordinary tags (tags created in the special Tag group) appear blue, tags that are also regular groups appear grey. Tags, e.g. in the Tag bar, also show a pop-up menu when you click their downward triangle. It shows related tags which can be added to the item, and tags represented by a group can be revealed.
Aliases and Excluding from Tagging
DEVONthink Pro Office also honores aliases added to groups. You can add 'alternative names' to a group in it's Info panel and later use these alternative names as a tag.
Example: In the Info panel of the group 'Dinosaurs' you have added 'Dinos' as an alias. You can now tag items with 'Dinos' and they will automatically moved or replicated to the 'Dinosaurs' group.
Groups that you don't want to use as tags can be excluded from tagging. Select it and open the Info panel. Check Exclude from ... Tagging and the group will no longer be shown as a tag for items contained in it.
OpenMeta
OpenMeta is an open standard for storing tags with files in the file system. Using OpenMeta applications can add tags to files and let other compliant applications read them.
DEVONthink Pro Office supports OpenMeta when importing and exporting files. Files stored in the database are not tagged in OpenMeta-style but assigned tags will be added to the files as soon as you export them.
File Formats
DEVONthink Pro Office supports a variety of text and image formats, including plain text, Rich Text Format (RTF), PDFs, all image formats supported by by Mac OS X and QuickTime as well as all file formats for which a Quick Look preview is available.
Text files
DEVONthink Pro Office supports plain text files (as well as Mac OS 9 SimpleText and Tex-Edit Plus files) in all encodings supported by Mac OS X, including Unicode and UTF-8. By default, DEVONthink Pro Office automatically recognizes the encoding and the line endings used by Mac, Windows, or Unix operating systems.
Note: DEVONthink Pro Office imports tabulated text files and vCards, such as .tsv, .csv and .vcf, as sheets. For BibTeX files, keys are supported and added to the sheet.
Rich Text Format: For Rich Text Format (RTF) files, DEVONthink Pro Office recognizes Mac, Windows, and ANSI encodings as well as Mac OS X RTF documents with attachments (RTFD).
DEVONthink Pro Office imports many Office file formats such as Microsoft Office and OpenDocument documents as well as all other file formats for which Quick Look support is available, e.g. Mellel (version 2.6 and higher) files, AppleScript scripts or text clippings.
Note: Quick Look is Mac OS X 10.5's mechanism for displaying a preview of almost any file type. In the Finder this function is invoked by pressing the Space bar. Quick Look requires the maker of the software that writes the document to add additional preview information inside the file (package) or to provide a Quick Look plugin embedded into the application itself or installed in a Library folder. If neither DEVONthink Pro Office nor the Finder can preview a document format that you want to use, please contact the maker of the software and ask it to provide Quick Look support for its file format.
Due to the nature of Quick Look, the contents of a document that is displayed using this technology, e.g., an Apple Pages file, is sometimes not selectable. Depending on the file format, for some files a plain or rich text alternative is available, e.g., for email messages. Where available use the Text View/Preview toggle button in the document's navigation bar to switch back and forth between plain text and preview modes.
Additional Quick Look plugins can be found e.g. on QLPlugins.com.
DEVONthink Pro Office stores email messages archived from Apple Mail or Microsoft Entourage in the native .eml format and uses Quick Look for displaying them. Drag them from your email application to a main window, the Groups panel, or DEVONthink Pro Office's Dock icon. Alternatively use DEVONthink Pro Office's email archiving tool to copy them from your preferred email application to a database.
Note: When dragging email messages from Microsoft Entourage, DEVONthink Pro Office imports them as rich text documents due to a shortcoming in the drag-and-drop implementation of Entourage. In addition you can only drag one message at a time for the same reason.
Chat logs
DEVONthink Pro Office understands the text format of logs generated by Adium, iChat or Yahoo Messenger. You can import them like rich text files.
For Adium, Second Life, and BluePhone Elite DEVONthink Pro Office offers a number of scripts that directly import all available chat, SMS, and phone logs.
PDF, PostScript, Skim
DEVONthink Pro Office imports and displays Portable Document Format (PDF) files, Skim PDF packages, and PostScript files. DEVONthink Pro Office extracts the readable text portions of the PDF making it possible to search the text of the PDF and to use See Also & Classify. PostScript files are converted to PDF on-the-fly.
It is possible to manually convert imported PDFs to plain text or RTF by using Data > Convert.
Note: It's not yet possible to extract text from protected PDF files. Protected PDFs are imported as simple images. You can correctly view the PDF in DEVONthink Pro Office, though, after entering the correct password.
Bookmarks
Drag or paste Internet addresses from any Internet application, or Internet location files from the Finder, to DEVONthink Pro Office to create a bookmark documents. DEVONthink Pro Office is especially optimized to accept Safari Bookmarks. Use bookmarks in DEVONthink Pro Office to integrate 'live' content from the Internet seamlessly with local documents.
HTML and XML
In addition to the text encodings already listed, DEVONthink Pro Office supports the standard HTML transcriptions for special characters (for example German umlauts and French accents). HTML can also be converted to plain text using Data > Convert. XML files of any kind can also be imported and are displayed with syntax coloring. Preference property lists of Mac OS X 10.4 and higher are stored in a binary format and are converted on-the-fly to readable XML.
Also, DEVONthink Pro Office supports Web archives containing HTML pages including all necessary images for displaying them offline.
DEVONthink Pro Office imports various structured file formats and stores their contents as sheets (e.g. tab-separated values, comma-separated values (TSV/CSV) and iData files).
Note: Due to limitation in Mac OS X's Cocoa memory management, sheets are currently limited to 32,767 records.
Outliner Formats
DEVONthink Pro Office is able to import outliner files created by OmniOutliner 2.x and other applications in the OPML (Outlining Processor Mark-up Language) file format. When importing OPML files, DEVONthink Pro Office recreates a groups hierarchy. DEVONthink Pro Office also exports documents in the standard OPML format generating one OPML file out of multiple groups and documents.
If DEVONthink Pro Office recognizes an imported OPML file as a news feed a new feed document is created instead of an outline. Feeds can also be exported as OPML for exchange with third-party newsreader.
Image Files
DEVONthink Pro Office imports all image formats supported by Mac OS X and QuickTime.
Installed applications or services can add support for other file formats to Mac OS X and therefore to DEVONthink Pro Office as well.
Note: PICT files can still be imported but Mac OS X 10.5 does no longer display them.
Multimedia Files
DEVONthink Pro Office displays or plays QuickTime movies, sounds, Flash movies and Shockwave animations. To add movies, sounds, or MP3s to DEVONthink Pro Office, import them like any other file to your database. Multimedia files can also be dragged into a rich text document to integrate them with text and images.
DEVONthink Pro Office also supports QuickTime file types provided by third-party components.
Templates
DEVONthink Pro Office comes with a number of pre-fabricated templates for general use. Use them to add e.g. a task list, a quote, or whole group structured, e.g. for project management, to your database.
Managing templates
Templates are regular files stored in the Finder in the folder '~/Library/Application Support/DEVONthink Pro 2/Templates.noindex'. Navigate to this folder in the Finder to manage your templates, rename them, organize them in sub-folders, or delete them.
More templates are available as extras. [Read more...]
Pre-fabricated templates
DEVONthink Pro Office comes with the following pre-fabricated templates which can serve as examples of what you can do with the template feature.
General use:
Accounts & Passwords:
Addresses & Dates:
Classifications:
Education:
Office:
Registers:
Search:
Smart Groups:
Tabs:
Toolbar: By default this contains no templates. Add you own templates here and add them also to the toolbar of main and search windows using View > Customize Toolbar.
Besides the more complex smart templates DEVONthink Pro Office supports template packages. They are folders with the file name extension '.dtTemplate' and contain one or multiple folders, one for each supported language. This way you can let DEVONthink Pro Office import the files in the right language depending on the system language.
In addition you can use the following placeholders in your file or folder names of your templates packages as well as in contained rich text, plain text, HTML, or XML files. During import they are replaced with actual data.
Most of the pre-fabricated templates are 'smart templates': They are not simple files but actually AppleScript packages that are executed when you select it the in the Data menu. These packages contain both script code as well as the actual templates that they insert into your database. This has a number of advantages:
Creating smart templates
Smart templates are regular AppleScript scripts or script packages with a special extension to distinguish then from regular AppleScript scripts:
To make your own smart templates have a look at the pre-fabricated smart templates:
Each of the pre-fabricated smart templates demostrate other aspects of what you could do with them. Just have a look at all of them to learn more about how you can create your own smart templates. You can find more about AppleScript and DEVONthink Pro Office in the chapter Scripts.
Smart templates as well as template packages can be double-clicked in the Finder to install them.
Web site export templates
For the export as web site, DEVONthink Pro Office uses templates available in ~/Library/Application Support/DEVONthink Pro/Websites/ to create HTML files from documents. You can choose the template in the save dialog that appears when you use File > Export > as Website
In the HTML templates, the following placeholders can be used:
These placeholders will be replaced with actual information during the export. The placeholders will only be replaced in documents that are converted to HTML during export, namely plain text, rich text, Microsoft Office/OpenOffice documents, scripts, chat logs, and sheets.
Search operators
In the toolbar search field as well as in both the interactive and the simple web interface you can use standard and extended Boolean operators, parenthesis, and more to fine-tune your search.
The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder, Spotlight, common search engines as well as common programming languages such as C, C++, Objective-C, Java, and JavaScript. The complexity of the query is unlimited.
Case
All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but DEVONthink Pro Office will ignore case in interpreting the query.
Precedence of terms
Search terms and associated operators will be interpreted from left to right, except as modified by including portions of the query within parentheses.
Wildcards
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
Boolean operators
The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in the search query. If no operator is given, DEVONthink Pro Office implies AND. The available Boolean operators are:
Beside the classic Boolean operators, DEVONthink Pro Office uses a number of operators that can usually only be found on high-end databases. Use them as a replacement for AND and "quotes" to fine-tune your query.
For convenience, some of these operators can also be abbreviated using commonly used symbols:
Note: The symbols above are also used by the Finder and Mac OS X's Spotlight for searches. Enter the vertical ruler character for the OR operator by pressing ⌥7 (e.g. on European keyboards).
Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT) BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without parenthesis are evaluated from left to right.
Date comparison operators
For comparing dates in smart groups the following operators are available:
White space handling
Words concatenated by non-white separators (e.g. www.devon-technologies.com or page_id) are treated like phrases put into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2". Characters separated by dots are considered to be abbreviations and therefore handled like words separated by hyphens, e.g. the term t.a.t.u is equal to "t a t u" OR tatu
Examples
Using any or all of the operators and rules layed out above you can create complex queries that find exactly what you are looking for. Here are some example queries that show how the operators are used.
Example: Devonian Dinosaurs
This query looks for all documents that contain the words 'devonian' and 'dinosaurs'.
Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro
This query looks for documents that contain the words 'Steve' and 'Jobs' not farther away from each other than ten words as well as the word 'iMac' (no specific position relative to Steve and Jobs) but not the word 'MacBook'. The word 'Pro' does not need to occur but if it does, the document is ranked higher in the list of search results.
Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2 ~effect)
This query looks for documents containing the word 'Paracetamol' near (within ten words) to words either starting with 'effect' (and so also 'effects') or being 'impact'. In addition, the document needs to contain the word 'side' or any word staring with 'second' within two words range from any word starting with 'effect'.
Template tags for Wiki-style links
In DEVONthink Pro Office you can create new documents by first selecting some text in a rich text document and then making it a link using the contextual menu. When you then click this link, DEVONthink Pro Office creates the new document using a template you set in the Editing Preferences. In this template, can use the tags below to automatically insert the name of the link, the current date or other information. [Read more...]
Metadata
DEVONthink Pro Office stores a large number of metadata fields internally when importing documents from the file system, e.g. from PDF, RTF, MP3, EXIF/IPTC, HTML, and email messages as well as from all files that deliver metadata through the Spotlight metadata importer. Here's an (incomplete) list of theoretically supported fields:
General:
PDF and RTF:
Electronic correspondence:
Electronic publications:
Version history
Version 2.3.4
This maintenance release prepares DEVONthink Pro Office for the upcoming sync technology, introduces the new Activity panel, brings interface and usability enhancements, and fixes some minor bugs and glitches. It is recommended for all users of DEVONthink Pro Office.
DEVONthink Pro Office only:
DEVONthink Pro and up:
DEVONthink Personal and up:
All editions:
Version 2.3.3
This release adds an option to quickly trash databases, supports Google Chrome bookmarks, and makes it possible to add templates and scripts to toolbars. In addition the update brings further minor improvements, e.g. support for Adium chatlogs, and bug fixes.
DEVONthink Pro Office only:
DEVONthink Pro and up:
DEVONthink Personal and up:
All editions:
Version 2.3.2
DEVONthink Pro Office only:
DEVONthink Pro and up:
DEVONthink Personal and up:
All editions:
Version 2.3.1
DEVONthink Pro Office only:
DEVONthink Pro and up:
DEVONthink Personal and up:
All editions:
Version 2.3
DEVONthink Pro Office only:
DEVONthink Pro and up:
DEVONthink Personal and up:
All Editions:
Version 2.2.1 — 1.0.1
Skipped.
Version 1.0
Initial release.
License agreement
PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES, LLC.
1. License: The application and other components (sound and graphics) accompanying this License, whether on disk, in read only memory, or on any other media (the “Software”), and the related documentation are licensed to you by DEVONtechnologies. You own the disk on which the Software is recorded but DEVONtechnologies and/or DEVONtechnologies’ Licensor(s) retain title to the Software and related documentation. This License allows you to non-simultaneously use the Software on multiple computers by the same person.
2. Restrictions: The Software contains copyrighted material, trade secrets and other proprietary material and in order to protect them you may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, lease, or create derivative works based upon the Software in whole or in part. You may not distribute the Software in any form, including, but not limited to, electronic information service distribution, bulletin board distribution, and magnetic or optical medium distribution.
3. Disclaimer of Warranty on Software: You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and related documentation is provided “AS IS” and without warranty of any kind.
4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION. In no event shall DEVONtechnologies’ total liability to you for all damages, losses and causes of action (whether in contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.
Apple, Carbon, Classic, Cocoa, ColorSync, Darwin, Mac OS X, QuickTime, Quartz and all other registered names are trademarks of their respective owners.
Credits
ABBBY FineReader Engine
ABBYY FineReader 8.x Engine Copyright © ABBYY Software Ltd. OCR by ABBYY Software House.
AMIndeterminateProgress
Copyright © 2007 Andreas Mayer. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
BWToolkit
Copyright © 2009 Brandon Walkin. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Objective-J and Cappuccino
Copyright © 2008—2009 280 North, Inc. Cappuccino and Objective-J are registered Trademarks of 280 North.
iui
Copyright © iui project group. More information can be found on the project page.
RegexKitLite
Copyright © 2008 John Engelhart. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
NDAlias
Copyright © 2002—2009 Nathan Day. More information can be found on Nathan Day's homepage.
Pantomime
Copyright © 2001—2009 Ludovic Marcotte. More information can be found on the Pantomime homepage.
ShortcutRecorder
Copyright © 2006 Contributors to ShortcutRecorder. More information can be found on the ShortcutRecorder homepage.
Sparkle
Copyright © 2006—2009 Andy Matuschak
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the 'Software'), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED 'AS IS', WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Video JS
Copyright © 2010 Zencoder, Inc.
The Video JS player is used according to the LGPL v3.
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