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Make the dream of the paperless office come true with DEVONthink Pro. Use

DEVONthink Pro to keep all of your

•  digital documents

•  notes

•  images

•  multimedia files

•  chat logs

•  bookmarks
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together in one database. Use DEVONthink Pro to integrate documents on your

hard drive, live content from the Internet, your notes, and your project-related

information, all together so that you can search and analyze them.
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INTRODUCTION

By a long-term DEVONthink power user

From the time Apple introduced the Apple II in 1977 computers have seen dramatic

and constant improvement in every aspect of their capabilities. Tremendous

advances in technology have turned every laptop into the equivalent of a personal

supercomputer; storage is cheap and plentiful, and the Internet is ubiquitous.

While the power of personal computers has dramatically increased, a time traveller

from the late 70s or early 80s would have no difficulty in recognizing the average

Desktop of 2009. Everything has become bigger, better, faster, and prettier, but

the basic metaphors that Apple introduced to the mass market in 1984 have seen

remarkably little change since that time.

WELCOME TO THE 21ST CENTURY

Costs decreased and computing power and drive capacity increased to previously

unimaginable levels. This familiar cycle has repeated itself year after year until

today. A few dozen folders, storing a couple hundred files, have turned into hundreds

of thousands -- or millions -- of digital documents, scattered across bottomless

hard disks. Email has effectively superseded physical mail for most purposes. An

average person's daily workflow involves working with electronic mail, attachments,
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documents, graphics, memos, meeting notes, presentations, address books, web

clippings, receipts, spreadsheets, reference materials, and digital libraries, from

a wide variety of sources -- networked and local -- in both electronic and physical

formats.

The average hard drive contains so much information, it would have taken a

warehouse to store all of it, back in 1984. Rather than the exception, in today's world,

this has become the norm. And it keeps piling up.

The only relatively recent addition to the desktop metaphor, has been Spotlight.

While most of us have an overall concept of where the individual elements of projects

we're actively working on right now, can be located... how do you find something you

worked on last month, or last year? You enter your search query into Spotlight, and it

dutifully returns a near-endless list of file-names.

Even when you do manage to find what you're searching for, an overall perspective

of how that one digital document relates to everything else in your massive

information warehouse, is missing. The constant barrage of data coming at us

becomes overwhelming. Yesterday's tools begin falling apart at the seams under the

onslaught of present-day reality. Organization devolves into information overload.
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DEVONTHINK PRO

DEVONthink acts as a data hub, a central repository for all the documents and

information one works with on a daily basis. Unlike a file manager such as the

Finder, DEVONthink is based on a powerful AI architecture that helps you organize

and navigate your information collection. It assists you with filing documents and

finding relationships between similar content. Master even huge data collections

with a few simple clicks and gain a much broader overview on seemingly disparate

fragments of information. Naturally, you can take all of it with you, and access your

databases anywhere you happen to go; DEVONthink Pro Office is iPhone-friendly.

DEVONtechnologies' unique AI architecture has seen nearly a decade of constant

development, refinement, and evolution. It serves as the foundation for the nearly

completely re-written DEVONthink Pro 2.0, which has been significantly expanded

and enhanced, to cast-off previous limitations imposed by a monolithic database

structure. Version 2.0 is modular, an order of magnitude faster than the 1.x series,

and represents a breakthrough in fully leveraging underlying Leopard technologies

and core frameworks, while seamlessly interoperating with industry-standard

applications and exploiting the benefits of a plethora of bleeding-edge, best-of-breed

programs -- in a variety of disciplines and specialized fields -- which are unique to the

Mac.
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DEVONthink Pro allows you to pull the signal out of an ocean of noise, and creates

elegance, perspective, and order, out of information overload.

Click here to learn more.
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THE DEVONTHINK PRO ADVANTAGE

WHY DEVONTHINK PRO?

DEVONthink Pro not only stores documents, it also facilitates

•  editing

•  analyzing

•  organizing

•  finding

•  and archiving

your documents with a flexible and powerful organization tool.

INTEGRATED WORKSPACE

Unlike the Finder, DEVONthink Pro provides an integrated environment with all the

tools you need for working with information. Don't waste time with digging through

thousands of files but let DEVONthink Pro intelligently assist you.
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As a native Mac application, DEVONthink Pro is also tightly integrated with Mac

OS X. DEVONthink Pro provides a Dock menu,  Services menu  commands, and

makes heavy use of the Safari Web browser engine. Of course, DEVONthink Pro runs

natively on both PowerPC and Intel processor based Macs.

WHAT CAN YOU DO WITH IT?

DEVONthink Pro is much more than just a document database -- and so there is

more than just one way to use it. Here are some of them:

•  Create text documents, edit them in full screen mode using all the tools

Mac OS X provides and cross-reference them with Wiki-style or static

links.

•  DEVONthink Pro is the #1 tool for collecting and organizing info bits

and snippets on the Mac. Use the Services menu,  the Dock menu,  the

Dashboard widgets and the Sorter to clip information and jot down notes.

•  DEVONthink Pro treats URLs like any other document, so you can

integrate Web content and local documents.

•  RSS feeds are the future of how we read news on the screen.

DEVONthink Pro displays all common newsfeed formats and lets you

clip important news directly to your database.

•  DEVONthink Pro makes a perfect repository for images you use

frequently.
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•  With DEVONthink Pro’s ability to index files without storing them in the

database, you can also use it for cataloging CD/DVD-ROMs.

EDITIONS

DEVONthink comes in multiple editions optimized for home/semipro and

professional, heavy-duty use. You can find a complete list of all the differences on our

Web site.

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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RELEASE NOTES

VERSION 2.3.3

This release adds an option to quickly trash databases, supports Google Chrome

bookmarks, and makes it possible to add templates and scripts to toolbars. In

addition the update brings further minor improvements, e.g. support for Adium

chatlogs, and bug fixes.

DEVONthink Pro and up:

•  NEW: Delete Database  option added to contextual menu of sidebar for

moving databases to the Finder's trash.

•  Improved: File > New Database  remembers the last used folder

independently.

•  Improved: News feeds show the number of unread items when Display

number of items inside groups  is switched off.

•  Improved: Add mailbox(es)/message(s) to DEVONthink scripts.

•  Improved: Changing the creation/modification date via AppleScript

updates the timestamps of the file, too.

•  Changed: Contextual menu command Delete renamed to Delete Smart

Group.



DEVONthink PRO 2.3.3 Documentation, page 22

•  Fixed: Moving unsaved documents to other databases did not save

them. Document windows containing the moved items are automatically

updated, not closed.

DEVONthink Personal and up:

•  NEW: Adium chat logs (.chatlog) can be indexed.

•  Improved: Compatibility to Mellel's Spotlight support.

•  Improved: Indexing of OmniOutliner 3 files.

•  Improved: Saving a document updates the creation and modification

dates of imported files, too.

•  Improved: More reliable indexing of webarchives on OS X 10.6 and 10.7

using Safari 5.1.x.

•  Improved: PDF services insert the name of the original document into

the "Name" field of the group selector again.

•  Improved: Lookup service searches immediately.

•  Fixed: Worked around two bugs in OS X 10.7's PDFKit.

•  Fixed: Double-clicking Mathematica notebooks (.nb) opened them in a

new window, not in Mathematica.

All editions:

•  NEW: Contextual menu command Update Bookmark added to web views.

•  NEW: Support for Google Chrome bookmarks.
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•  NEW: Templates and scripts inside the subfolder "Toolbar" can be added

to the toolbar of main and search windows, e.g. to easily create new items

based on templates.

•  Improved: Support Assistant.

•  Improved: English localization.

•  Improved: About and splash panels updated.

•  Fixed: Images couldn't be pasted into the Info panel to change the item's

icon.

•  Fixed: Newly created plain or rich text documents did not have empty

files linked to them.

•  Fixed: Issue of search engine returning too many results in case of

proximity operators followed by multiple other words/operators.

•  Fixed: Grouping items in the Tags view removed them from their former

locations.

•  Fixed: Help > Contact Us did not work if the username contained non-

ASCII characters.

•  Fixed: Position of tag completion popup on additional screens.

•  Fixed: English, French, and German localizations.

•  Fixed: More minor bugs and glitches.
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VERSION 2.3.2

DEVONthink Pro and up:

•  Improved: Scripts for Microsoft Entourage and Outlook.

•  Improved: PDF Services script replaced with application alias.

•  Improved: Automatic recognition of headers of imported sheets.

•  Improved: Automatic sizing of columns of sheets.

•  Improved: "Examples" folder on the disk image renamed to "Triggered".

•  Improved: AppleScript support.

•  Removed: Legacy example scripts on disk image.

DEVONthink Personal and up:

•  Improved: Sorter  placement.

•  Improved: Indexing of OmniOutliner 3 files (.oo3), supports compressed

XML.

•  Improved: File > Update Indexed Items  updates the enclosing group if

there's no selection.

•  Fixed: Various Sorter  bugs and glitches

•  Fixed: Popup of PDF text annotations wasn't automatically opened.

•  Fixed: Multiple tags entered in the Clip to DEVONthink  panel were

concatenated.

•  Fixed: Modified documents were not saved in some rare cases.
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All editions:

•  NEW: Empty groups are displayed in gray.

•  Improved: Adding new tags via the Tags bar.

•  Improved: Links updated for new DEVONtechnologies website.

•  Improved: Internal enhancements.

•  Fixed: Some menu items were not disabled in OS X Lion's fullscreen

mode.

•  Fixed: Support Assistant updated for new DEVONtechnologies website.

•  Fixed: Support Assistant did no longer show tutorials.

•  Fixed: Customization of toolbars did no longer work on OS X 10.5

Leopard.

•  Fixed: Various other minor bugs and glitches.

•  Fixed: French localization.

VERSION 2.3.1

DEVONthink Pro and up:

•  NEW: Scripts  menu supports custom icons.

•  NEW: Added icons to all database-specific sub-menus.

•  NEW: Smarter smart template for EndNote X4.

•  Improved: Importing and indexing of digital business cards (.vcf).

http://www.devontechnologies.com
http://www.devontechnologies.com
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•  Improved: Compatibility of RSS parser to buggy feeds.

•  Fixed: Number of items in global inbox shown in sidebar wasn't always

correct.

•  Fixed: Moving or renaming open databases showed an alert the next time

the database was opened.

•  Fixed: After locking a feed, missing items were not automatically added

to the feed after refreshing.

•  Fixed: Optional group selector after using the Save PDF to DEVONthink

Pro PDF service didn't always contain a field to enter a name.

•  Fixed: Add as To Do to Task Paper  script was missing the German and

French localization.

•  Fixed: Issue causing OS X 10.7 Lion's AppleScript Editor to claim that

several scripts are not editable.

DEVONthink Personal and up:

•  Improved: Indexing of XML files.

•  Improved: Indexing of OmniOutliner 3 files (.oo3), working around an

issue with OmniOutliner 3.10.x.

•  Improved: Reliability of the PDFkit framework.

•  Improved: After entering advanced search settings, a search is

immediately performed.

•  Improved: Toolbar icon of tool for selecting PDF annotations.
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•  Improved: More reliable and faster Spotlight metadata importer plugin.

•  Fixed: Merging images, e.g. scans, didn't retain the original DPI

resolution.

•  Fixed: PDF documents created by Apache FOP Version 1.x are now

imported as read-only as annotating (with DEVONthink Pro or Preview)

or printing them to a new PDF destroys their text information.

•  Fixed: Background process collected too many website previews.

•  Fixed: Thumbnails of webarchives were updated via Quick Look with

poor results after updating them.

•  Fixed: Exceptions caused by OS X's PDFKit framework after dropping

unsupported types on the PDF thumbnail sidebar.

All editions:

•  NEW: Template  menu supports custom icons of folders.

•  Improved: Shortcut for Data > Mark > As Flagged  changed for

compatibility to OS X 10.7 Lion's fullscreen mode.

•  Improved: Window fullscreen mode is restored on app start.

•  Improved: Advertisement filter.

•  Improved: Handling of storage of background processes.

•  Improved: Error logging to system console.

•  Fixed: Several issues with smart tagging.

•  Fixed: Several minor issues with window fullscreen mode.
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•  Fixed: Several issues of tagging fields in head-up display panels.

•  Fixed: Tag completion popup wasn't always constrained to the current

screen on Mac OS X 10.6 Snow Leopard.

•  Fixed: Support Assistant  scrolled back to first page after installing an

extra.

•  Fixed: Capturing from Xcode stores the path of the document instead of

the file URL of the frontmost project.

•  Fixed: Random bug of See Selected Text causing poor results.

•  Fixed: Further minor bugs and glitches.

VERSION 2.3

DEVONthink Pro and up:

•  NEW: Option to import Address Book cards as bookmarks linking to the

cards.

•  Improved: AppleScript support.

•  Fixed: Add as To Do to OmniFocus  script was incompatible to App Store

version of OmniFocus.

DEVONthink Personal and up:

•  NEW: Menu item Go > Go to Page  to go to a page in a PDF document.

http://www.omnigroup.com/products/omnifocus
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•  NEW: "addressbook:" bookmarks are displayed using Quick Look (OS X

10.7 Lion or higher)

•  NEW: ".f4v" added to list of supported QuickTime extensions.

•  Improved: Files skipped while importing, indexing, or synchronizing are

logged.

•  Improved: Page number of PDF documents in navigation bar is now

identical to page labels in the sidebar. Going to a page uses the displayed

numbers/labels and supports, e.g., roman numbers, too.

•  Improved: File > Synchronize renamed to Update Indexed Items.

•  Improved: Slightly reorganized File  menu.

•  Improved: Firefox extension, should be compatible up to Firefox 10.

•  Fixed: Various bugs and glitches affecting the Sorter.

•  Fixed: Redraw glitch of PDF and PostScript documents not displaying

the first page initially (OS X 10.7 Lion).

•  Fixed: Open With button of Quick Look panels did not work (OS X 10.7

Lion or higher).

•  Fixed: Switching from Fit To Window to Fit To Width jumped to the first

page of PDF documents.
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All Editions:

•  NEW: Support for OS X 10.7 Lion's full screen mode; see View > Full

Screen > Window.  The old full screen mode is now available via View >

Full Screen > Document.

•  NEW: Contextual menu item Quick Look Attachment(s) added to preview

links and attached files of rich text documents (OS X 10.7 Lion or

higher).

•  NEW: Double-clicking attachments in rich text documents opens the

actual file, if possible, so that it can be edited externally.

•  NEW: Dragging cards from Address Book with Command and Option

held into a rich text document inserts "addressbook:" links; clicking them

opens the card in Address Book, previewing them via the contextual

menu (OS X 10.7 or higher) is also possible.

•  NEW: Popup menu added to File > Export > As Text  panel to select the

desired text encoding.

•  Improved: Preferences > General > Display number of items inside groups

and sidebar  no longer counts subgroups, only documents.

•  Improved: Advertisement filter (OS X 10.7 Lion or higher).

•  Improved: Exclude Groups from Tagging  is now enabled by default.

•  Improved: Storing fav icons of webpages.

•  Improved: Twitter handling.

•  Improved: Sync Agent plugin, prepared for DEVONthink To Go 1.2.
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•  Improved: Automatic updates are disabled if an unknown framework is

discovered.

•  Improved: Overall performance and reliability.

•  Fixed: Minor bugs and glitches on OS X 10.7 Lion.

•  Fixed: Incompatibility of old full screen mode and the one of OS X 10.7

Lion.

•  Fixed: The beginning of text documents was truncated in full screen

mode if the tabs bar was visible.

•  Fixed: It was possible to duplicate the Mobile Sync group.

•  Fixed: Navigational dots in Support Assistant did not always indicate the

correct page.

•  Fixed: Support Assistant used a font not available on all systems.

•  Fixed: It's no longer possible to quit the application while an update is

installed.

•  Fixed: Rare issue causing wrong alerts while entering a license code

character by character.

VERSION 2.2.1

DEVONthink Pro and up:

•  Improved: Switching between databases via the sidebar restores the last

used selection of the database.
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DEVONthink Personal and up:

•  NEW: Instapaper option added to Clip to DEVONthink panel to apply

Instapaper to PDF documents and web archives.

•  Improved: More reliable capturing of pages that require a login, e.g. the

New York Times.

•  Fixed: Toolbar items Rotate Left/Right didn't rotate all pages selected in

the PDF sidebar.

•  Fixed: Display issue with web archives generated by Apple Mail (OS X

10.7 Lion).

•  Fixed: Crash when converting PDF documents to rich text (OS X 10.7

Lion).

All Editions:

•  NEW: Logged records in the Log panel can be revealed via the contextual

menu.

•  NEW: Internal support for upcoming sync store packages.

•  Improved: Data > Group/Ungroup/Auto Group renamed to Data >

Group/Ungroup/Auto Group Items so that shortcuts can be assigned in

System Preferences.

•  Improved: French localization.

•  Fixed: Various glitches (OS X 10.7 Lion).
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•  Fixed: Some panels were invisible in fullscreen mode of other apps (OS X

10.7 Lion).

•  Fixed: Unnecessary console messages.

•  Fixed: Minor glitches and inconsistencies.

•  Fixed: Import of empty templates, e.g. text files with 0 bytes.

VERSION 2.2

Note: Starting with this version DEVONthink Pro is compatible to OS X

10.7 Lion.

DEVONthink Pro and up:

•  NEW: Scripts for Google Chrome.

•  NEW: Recent destinations include the name of the database for common

groups.

•  Improved: Sub-menu Data > Sheets moved to Edit menu.

•  Improved: Feeds no longer re-add items already deleted by the user.

•  Improved: Some panels and sheets have been slightly revised.

•  Improved: AppleScript and Automator support.

•  Improved: Recent destinations limited to maximum ten destinations.

•  Fixed: Minor issues with global smart groups.

•  Fixed: Minor issues with AppleScript and Automator.

http://www.google.com/chrome/
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•  Fixed: Support for DEVONagent 3.0 was partly broken.

DEVONthink Personal and up:

•  NEW: Firefox extension compatible to Mozilla Firefox 5.0.

•  Improved: Go > Workspaces > Edit allows to rename, reorder, and delete

workspaces.

•  Improved: Shortcuts added to Format menu of Clip to DEVONthink

panel.

•  Improved: Full-screen app handling of the Sorter.

•  Improved: Small icon previews of web archives and bookmarks.

•  Fixed: Workspaces didn't contain panels.

•  Fixed: .zip archive in the database could be unzipped and so create

orphans.

•  Fixed: Editing PDF annotations didn't always immediately show the

changes.

•  Fixed: Sorter disappeared when the Take Note hot key was pressed.

•  Fixed: The Dashboard widget is now updated instead of installed a

second time.

•  Fixed: French localization of services.

All Editions:

•  NEW: Compatible to OS X 10.7 Lion.
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•  NEW: Compatible to the upcoming DEVONagent Pro 3.0.

•  NEW: Send by Email supports Sparrow.

•  NEW: New Edit > Tags command to enter tags immediately.

•  NEW: Smart groups and advanced searches support used-defined dates.

•  NEW: The Dock icon shows a progress indicator for long tasks.

•  NEW: ".xqy" and ".xq" added to plain text file extensions.

•  Improved: See also results for bookmarks and selected text.

•  Improved: Handling of Tab, Return, and Enter keys in various panels and

when entering tags.

•  Improved: Services include the application name and don't use a

submenu on Mac OS X 10.5.8 anymore

•  Improved: Website export retains line spacing for rich text.

•  Improved: Installation of accidentally opened templates can be cancelled.

•  Improved: Full-screen mode more compatible.

•  Improved: Compliance to Mac App Store.

•  Improved: Overall performance and reliability.

•  Fixed: Taking a note with Clip to DEVONthink stored the selection

instead of the entered note.

•  Fixed: Contents created in list and icon views were sometimes opened,

too.

•  Fixed: Destination menu of Take Note and Clip to DEVONthink panels

was not sorted by kind.

http://sparrowmailapp.com
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•  Fixed: Pages templates (.template) were treated as plain text.

•  Fixed: Open Office text documents and templates were listed as "rich

text".

•  Fixed: Minor bugs and glitches.

VERSION 2.1.1

DEVONthink Pro and up:

•  NEW: 'Simple' RSS stylesheet.

•  Improved: Databases in the popup menu of Take Note and Clip to

DEVONthink panels are now sorted like in the Groups & Tags panel or

the group selector.

•  Fixed: Pop-up menu of Take Note and Clip to DEVONthink panels

contained read-only databases.

DEVONthink Personal and up:

•  NEW: Recent destinations available in pop-up menu of Take Note and

Clip to DEVONthink panels.

•  Improved: Sorter can now placed on any screen edge and, in list mode,

scrolls if there are too many boxes to display all of them.
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•  Improved: More reliable indexing of unknown filetypes using Spotlight

mdimporters.

•  Fixed: Clip to DEVONthink was sometimes automatically activated (in

Safari).

•  Fixed: Text selection is now correctly copied into the Note field of Clip to

DEVONthink.

•  Fixed: Dragging images from e.g. Safari created bookmarks instead of

images.

•  Fixed: Sorter could disappear from the screen under certain

circumstances.

•  Fixed: Issues with the Sorter and a second monitor.

•  Fixed: Minor bugs and glitches.

All Editions:

•  Improved: More reliable exception handling.

•  Improved: DEVONthink To Go conduit; better handles packaged file

formats (need re-syncing these items).

•  Improved: Feedback email messages give more details.

•  Fixed: Glitch after splitting documents.

•  Fixed: Import of metadata stored by e.g. third-party download managers

could fail or crash.
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•  Fixed: Preview tooltips of tabs were not hidden after switching to another

application via Command-Tab.

VERSION 2.1

DEVONthink Pro and up:

•  Improved: Annotations  smart template.

•  Improved: Formatting of displayed URLs in Download manager.

•  Improved: Opening databases via the Finder, Dock, or the Recent

Databases  menu is now identical to using the sidebar.

•  Improved: Automatic removal of articles of feeds no longer trashes

currently open articles.

•  Improved: AppleScript support.

•  Fixed: Highlighting of occurrences in PDF/PostScript document of words

selected in the Concordance  drawer.

•  Fixed: German localization of Registers > Months  template.

•  Fixed: Help button of New Sheet/Edit Columns  panels didn't work.

•  Fixed: Several action and contextual menu commands were disabled in

global smart groups.

•  Fixed: Issues with extended attributes of files imported from the Sorter.



DEVONthink PRO 2.3.3 Documentation, page 39

DEVONthink Personal and up:

•  NEW: Rewritten Clip to DEVONthink  bookmarklet. No more browser

incompatibilities, tag completion, full Cocoa user interface. Requires

updated browser extensions and bookmarklets.

•  NEW: Browser extension for Google Chrome; updated extensions for

Safari and Firefox. See also p. 321ff

•  NEW: Improved Sorter (as known from the higher editions). Displays

boxes now also as list, all views can be independently sized, much

improved multi-monitor support, fixed Start Sorter at login preference,

updated note-taking view, and literally dozens of bug fixes.

•  NEW: Workspaces can be created, deleted, and accessed via the Go menu

and restore open databases and windows, order of windows, panels, tabs,

selected tab, and selected items. In addition, view, widescreen, and Cover

Flow of main and search windows as well as settings, string amd results

of search windows, and the visibility of the sidebar of main windows

are restored. Application startup is now based on workspaces, too, and

therefore restores e.g. selection and tabs.

•  NEW: Contextual menu added to Cover Flow.

•  Improved: Scrolling to occurrences in PDF documents.

•  Improved: Tinderbox files ('.tbx') are once again handled like XML files

and editing them does not change the extension.

•  Improved: Support for case-sensitive file systems.
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•  Fixed: Issues with consolidating and deconsolidating.

•  Fixed: Automatic file synchronization was not always active after

opening files externally by double-clicking.

•  Fixed: DEVONjot  Dashboard widget garbled some notes.

•  Fixed: Cover Flow did not support multiple selected toolbar search

results.

•  Fixed: Minor bugs and glitches.

•  Removed: Bookmarklets from the disk image; can be installed via Help >

Bookmarklets.

All Editions:

•  NEW: Rewritten welcome/support assistant with tutorials, tips and

tricks, and easy installation of scripts, templates, and eventually plugins.

•  NEW: Highlighting color can be changed.

•  NEW: Optional Highlight  toolbar item to toggle highlighting of selected

text.

•  NEW: Option to show log automatically (on by default) added to the Log 

panel.

•  NEW: Smart groups and advanced searches support 'Tag is not ...'

conditions.

•  NEW: Placeholder '%groupName%' for templates to insert the name of

the parent group.
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•  NEW: Default shortcuts for Data > Mark > As (Un)Flagged/(Un)Locked.

•  NEW: Support for .textClipping files containing rich text with images or

attachments.

•  NEW: '.org' and '.md' files (e.g. created by Aquamacs) are now recognized

as plain text files.

•  Improved: Highlighting of selection in group selector and Groups & Tags 

panel.

•  Improved: Take Note  panel.

•  Improved: Pasted or dropped data from iWork or Microsoft Office is now

usually captured as RTF(D).

•  Improved: Handling of label names.

•  Improved: Handling of tag completion popup on Mac OS X 10.5.8.

•  Improved: Better and more reliable filename handling.

•  Improved: Metadata import.

•  Improved: Overall performance, stability, and reliability.

•  Improved: Kernel prepared for 64-bit operation.

•  Fixed: Several synchronization issues in DEVONthink To Go conduit.

•  Fixed: Automatic Wiki links at the end of plain or rich texts were also

triggered after clicking behind or below the end of the text.

•  Fixed: Double-clicking on smart groups in icon views doesn't open the

smart group editor anymore.

•  Fixed: Exporting/Renaming doesn't drop invalid extensions anymore.
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•  Fixed: Minor adaptions to the requirements of the Mac App Store.

•  Fixed: Localizations.

•  Fixed: Minor bugs and glitches.

VERSION 2.0.9

DEVONthink Pro and up:

•  NEW: Tools > Rebuild  supports the global inbox, too.

•  NEW: Renaming or moving currently used databases, e.g. in the Finder,

is now supported.

•  NEW: 'deconsolidate' AppleScript command to move an internal record

and its children to the enclosing external folder in the filesystem.

•  Improved: Importing or indexing addresses (vcards and sheets) is more

compatible to addresses created e.g. by Yahoo.

•  Improved: Scripts > Import > Man Page  imports the manual pages now

as PDF documents. Thanks to our user 'Houthakker'!

•  Improved: Support for annotated HTML pages and web archives.

•  Improved: Sorter. Double-clicking boxes opens the group in DEVONthink

Pro, clicking with Control also opens the contextual menu, and the items

in the action menu are indented.

•  Improved: AppleScript and Automator support. See also p. 328ff
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•  Fixed: Accidently backing up to the global inbox folder ('~/Library/

Application Support/DEVONthink Pro 2/Inbox') via the user interface or

AppleScript is no longer possible.

DEVONthink Personal and up:

•  NEW: Move To External Folder action and contextual menu command to

move imported groups and documents to their enclosing, external, and

indexed folder in the filesystem.

•  NEW: Dashboard widget is now installed via DEVONthink Pro > Install

Add-Ons.

•  Improved: Initial sizing of PDF and PostScript windows.

•  Improved: Indexing, searching, and classifying of PDF documents created

by Compart DocBridge.

•  Improved: DEVONthink Pro > Install Add-Ons  panel remembers last

used settings.

•  Improved: Increased maximal width of Groups & Tags panel

•  Improved: Updating of Open With  menu is up to 30 times faster.

•  Improved: 'Add to DEVONthink service', e.g. used by EasyFind 4.7, and

improved support for DEVONagent 3.0.

•  Fixed: Move Into Database action and contextual menu command and

'consolidate' AppleScript command did not always remove empty folders.
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•  Fixed: Going to a page number of PDF and PostScript documents did not

work.

All Editions:

•  NEW: The Take Note  panel automatically inserts the URL from the

frontmost application, e.g. Safari, after opening or activating the panel if

possible and if there's no URL yet.

•  NEW: Preferences > Editing > Text Replacement  to enable text

replacements by default. Mac OS X 10.6 'Snow Leopard' or later.

•  NEW: 'This Quarter' and 'Last Quarter' options added to date predicates

of smart groups and advanced searches. In addition, few minor issues of

date predicates have been fixed and support for customized first day of

week has been added.

•  Improved: Group selector and Groups & Tags  panel display label colors

now too if Preferences > General > Colorize icons with label  is disabled.

•  Improved: Autocompletion of tagging simplifies entering of not yet

existing tags.

•  Improved: Automatic installation supports '/Applications' replaced with

a symbolic link; revised text of alert after launching the application from

the disk image or another unexpected location.

•  Improved: More accurate and faster concordance, see also, classify,

search, and summary.
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•  Improved: Overall performance and stability.

•  Fixed: Various bugs in DEVONthink To Go conduit.

•  Fixed: All windows are now saved before synchronizing instead of saving

only main windows.

•  Fixed: All document windows are refreshed instead of reset after

synchronizing or repairing a database.

•  Fixed: Edited plain text clippings, e.g. created by Firefox, were

unreadable.

•  Fixed: Invalid values in a database's settings could cause case-sensitive

highlighting of occurrences.

•  Fixed: Issue of symbolic link handling of Mac OS X (workaround).

•  Fixed: Issues caused by poor BabylonCM.plugin (workaround).

•  Fixed: Minor bugs and glitches.

VERSION 2.0.7

DEVONthink Pro and up:

•  NEW: Menu extra scripts Add messages to DEVONthink  and Add

mailbox to DEVONthink  for Microsoft Outlook 2011.

•  NEW: Scripts > Import > Del.icio.us  imports notes, too.

•  NEW: Special groups added to the sidebar retain their icon.

http://www.microsoft.com/mac/outlook
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•  Improved: More reliable and faster adding of smart templates using

scripts.

•  Improved: DEVONthink Pro > Install Add-Ons  disables already

installed static components.

•  Improved: Encoding support for Add message(s)/mailbox(es) to

DEVONthink  scripts.

•  Fixed: Scripts > Reminders > Add as To Do to iCal  and Scripts >

Reminders > Add as Event to iCal.

•  Fixed: Scripts > Download > Create Offline Archive.

•  Fixed: The smart template Reference (from Sente 6)  tried to create back

links even when no citation ID was delivered from Sente.

•  Fixed: Emptying the trash did not remove obsolete favorites from the

sidebar.

•  Fixed: Worked around issue of Sorter so that dropping URLs/bookmarks

on the global inbox while pressing the Command-Option modifier keys is

working again.

•  Fixed: Minor bugs and glitches.

DEVONthink Personal and up:

•  NEW: Clicking on the page number in the navigation bar of PDF or

PostSscript documents opens a sheet to enter a new page number.
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•  Improved: Support of File > Synchronize  for indexed folders or files

replaced with symbolic links or aliases.

•  Improved: Handling of PDF sidebar working around issues of the PDFKit

framework.

•  Improved: Naming of captured or dropped HTML snippets, e.g. from

Firefox.

•  Improved: Stricter duplicate detection for email messages.

•  Improved: Help  and DEVONthink Pro  menus slightly rearranged.

•  Improved: Welcome Assistant.

•  Improved: Handling of file system events more reliable.

•  Fixed: Highlighting of occurrences in PDF documents didn't always

support words with diacritics.

•  Fixed: Initial size of PDF windows was sometimes way too small.

•  Fixed: Issue of disabled color pickers of PDF Annotations  panel.

•  Fixed: Unnecessary console messages.

All Editions:

•  NEW: URL field and checkbox to choose the text format added to Take

Note  panel; Format  menu commands to change the style or font are now

supported, too.

•  NEW: Services capture the URL from the frontmost window of Microsoft

Outlook 2011, PowerMail and Postbox.

http://www.microsoft.com/mac/outlook
http://www.microsoft.com/mac/outlook
http://www.ctmdev.com/powermail/
http://www.postbox-inc.com/
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•  NEW: Sending items by email supports also Microsoft Outlook 2011.

•  NEW: Support for the third mouse button in web view, like clicking with

Command held.

•  NEW: Help buttons to all preference panes added.

•  Improved: More smartgroups are evaluated on the fly instead of on

demand.

•  Improved: Handling of search predicates of the same type.

•  Improved: Default name of Sync group changed to Mobile Sync.

•  Improved: French localization.

•  Improved: Overall reliability.

•  Fixed: Sync plugin for DEVONthink To Go did not synchronize more

than 1 KB of text.

•  Fixed: Workaround added for Tinderbox files.

•  Fixed: Fullscreen frame of multiple rich or plain text tabs.

•  Fixed: 'No Selection' display after moving, duplicating, or replicating

search results in three-pane and tags views.

•  Fixed: Closing a tab by clicking on the close button did not always save

changes.

•  Fixed: File > Export > Files & Folders  did not export contents without a

file representation.

•  Fixed: Selecting another document after modifying tags via the tag bar

didn't always update the preview pane.

http://www.microsoft.com/mac/outlook
http://www.eastgate.com/Tinderbox/
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•  Fixed: Closing a modal name/bookmark editor dialog via the title bar

disabled all menus and windows.

•  Fixed: Date columns are no longer automatically resized.

•  Fixed: Possible issue of handling of path extensions.

•  Fixed: Security issues with the Mac OS X firewall by adding code

signatures to the application; improves also the keychain handling.

•  Fixed: Further minor bugs and glitches.

•  Removed: Obsolete code for Mac OS X 10.4.

•  Removed: Some usage of private APIs.

VERSION 2.0.6

DEVONthink Pro and up:

•  NEW: AppleScript property 'sync group'.

•  Improved: Shortcut of Scripts > Rename > Selected Text  changed.

•  Improved: Replicated (e.g. to other groups/feeds) news of feeds are no

longer automatically removed.

•  Improved: Handling of feeds and filesystem events.

•  Improved: More reliable OPML import

•  Fixed: Scripts > Export > Listing...

•  Fixed: Converting a v1 database created an unnecessary Sync  group in

the global inbox.
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•  Fixed: Bug preventing Sente 6 smart template from working.

•  Fixed: Workaround added in case that the system does not handle folders

with extension '.scptd' as packages, e.g. due to damaged launch services

or deinstalling Apple's Script Editor. The Scripts  menu is now always

initialized as expected.

DEVONthink Personal and up:

•  NEW: Text of email messages displayed by Quick Look is selectable on

Mac OS X 10.6 'Snow Leopard' and can be copied/dragged. Edit > Copy/

Select All/Deselect All  is also supported.

•  Improved: Faster reloading of column views.

•  Fixed: Converting RTFD documents to HTML inserted IMG/EMBED

tags for attachments.

All Editions:

•  NEW: Quick Look plugin for Spotlight metadata cache files

(.dn2, .dt2, .dtp2) allows to preview and thumbnail these files in the

Finder, for example Spotlight search results. A rebuild of the Spotlight

index with File > Database Properties  is necessary. Mac OS X 10.6 'Snow

Leopard' only.

•  NEW: URL captured from Google Chrome 7.x retain their URL, e.g. after

using Services, PDF services, or drag-and-drop.

http://www.google.com/chrome
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•  NEW: Yahoo! Messenger '.ychat' files are indexed and displayed as plain

text.

•  NEW: Sync,  Tags and Trash groups can again be renamed.

•  Improved: Pasting URLs into rich text documents retains the former

typing attributes and supports unicode characters.

•  Improved: Renaming selects only the filename but no longer the

extension (if there is one).

•  Improved: Shortcuts in Scripts  and Templates  menus support also F16

through F35.

•  Improved: Tab key can again be used to make the first editable column in

list, split, three-pane, or Tags  views editable.

•  Improved: Used classify destinations are also added to the recent

destinations in Move To, Replicate To, or Duplicate To sub-menus of

contextual or action menus

•  Improved: Detection of duplicates, especially by smart groups, up to 50

times faster.

•  Improved: Optimized reloading of views having a preview pane.

•  Improved: More reliable creation of the Sync  group.

•  Improved: More reliable rebuilding and converting of v1.x databases.

•  Improved: More reliable repairing of databases with orphans.

•  Improved: Misleading 'Initializing & Verifying...' while opening databases

changed to 'Initializing...'.

http://messenger.yahoo.com/
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•  Improved: Error logging while initializing/loading plugins, e.g. the Sync

Agent.bundle.

•  Improved: Internal enhancements for upcoming synchronization.

•  Fixed: Problems with Sync Agent plugin not loading on some machines or

crashing.

•  Fixed: Issues of the updated Shortcut Recorder, used in some preferences.

•  Fixed: 'No selection' issues of toolbar search.

•  Fixed: Endless recursion caused by aliases or symbolic links cannot crash

rebuilding anymore.

•  Fixed: Crash after dragging, e.g., groups into the Tags  bar.

•  Fixed: Deleting a group replicated both inside and outside the Tags group

moved all instances to the trash and emptying the trash killed the tag

afterwards.

•  Fixed: Dragging text from Safari Reader to DEVONthink Pro stored the

wrong URL.

•  Fixed: Column widths of Tags  view were not always persistent.

•  Fixed: A simple 'Unread is on/off' smart group did not list matching

groups/feeds/other smart groups in the left pane of three-pane views.

•  Fixed: Minor bugs of classification

•  Fixed: Sync  group is no longer used for classification.

•  Fixed: Wildcard or fuzzy searching returned too many results in some

cases.
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•  Fixed: Smart groups using 'Kind is not ...' did not always display results

in the upper right pane of three-pane views.

•  Fixed: Entering an invalid license code (e.g. entered manually with typos)

could cause a misleadig alert that the code is for another product, edition,

or version.

•  Fixed: Glitches in the German and French localizations.

•  Fixed: Further minor glitches.

VERSION 2.0.5 � 1.0

Skipped.
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SYSTEM REQUIREMENTS

Every Apple Mac computer with at least 512 MB of RAM, Mac OS X 10.5 or

later. In addition, a broadband Internet connection (256 Kbps or faster) is highly

recommended.

For stable functioning it is recommended to keep the total number of elements in all

open databases below 300,000 items and 200 to 300 million words. Larger databases

could become unreliable due to low memory on current Macs.



DEVONthink PRO 2.3.3 Documentation, page 55

INSTALLING, UPDATING, UNINSTALLING

Note: The following procedures do not apply when you have purchased

DEVONthink Pro on the Mac App Store. Installing, updating, and

uninstalling is all handled by the App Store application in this case.

INSTALLING AND UPDATING

Just move the DEVONthink Pro application package to the Applications folder or

any other directory you have access to. Please note that Mac OS X Services and

the connection to DEVONagent work only for applications installed into one of

the Applications folders, and that logout and login or a restart is required after

installation.

To update an existing version of DEVONthink Pro, simply copy the application

package from the disk image to your Applications folder, replacing the old version.

Your database(s) will not be affected.
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BUYING AN UPGRADE

If would like to buy an upgrade DEVONthink Pro to a higher edition, you have the

following options:

•  Click here to check your upgrade options.

•  Choose DEVONthink Pro > Check Upgrade Options.

Depending on whether you have purchased DEVONthink Pro in DEVONtechnologies'

online shop or in the Mac App Store the second option may or may not be available.

UPGRADING TO DEVONTHINK PRO (OFFICE)

When you are upgrading from DEVONthink Personal to DEVONthink Professional,

the application will copy your existing DEVONthink Personal database to your

documents folder ('~/Documents/DEVONthink.dtBase2').

If by any chance it doesn't do this automatically, do the following: Copy the complete

folder '~/Library/Application Support/DEVONthink 2' to your Desktop. Then, Rename

the folder as you wish and add the filename suffix, '.dtBase2' (without quotes). The

folder has now become a DEVONthink Pro database icon that you can double-click.

x-devonthink://purchase
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If your old database was created by DEVONthink Personal 1.x, it will be the folder

named 'DEVONthink' at '~/Library/Application Support/'. Follow the instructions

as above, but in this case use the filename suffix '.dtBase' (no quotes, but case is

important). The folder has now become a DEVONthink Pro 1.x database. From

DEVONthink Pro choose File > Open Database  and select the resulting database file.

You will be offered the opportunity to convert the database to a new DEVONthink

Pro 2.x database. Accept, and you now have a converted DEVONthink Pro 2.x

database.

Note: It's definitely not recommended to install both DEVONthink

Personal and Professional on the same machine. For example, both

applications use the same Services menu shortcuts and Mac OS X would

assign the shortcuts sometimes to DEVONthink Personal, sometimes to

Professional. In addition, DEVONagent stores contents in DEVONthink

Professional if it's available, otherwise in DEVONthink Personal.

DOWNGRADING TO DEVONTHINK PERSONAL

If you want to downgrade from DEVONthink Professional to Personal, copy the

database you want to use to '~/Library/Application Support' and rename it to

'DEVONthink', removing the file name extension '.dtBase2'. The database package

becomes a regular folder and will now be used by DEVONthink Personal.
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UNINSTALLING

To remove (uninstall) DEVONthink Pro completely from your Mac, trash the

following files and folders (~ stands for your Home folder):

•  DEVONthink Pro

•  ~/Library/Application Support/DEVONthink Pro 2

•  ~/Library/Preferences/com.devon-technologies.thinkpro.*

•  All DEVONthink Pro-specific scripts in ~/Library/Scripts/

•  All DEVONthink Pro-specific workflows in ~/Library/Workflows/

•  All DEVONthink Pro-specific scripts in ~/Library/PDF Services/

•  Dashboard widgets

•  Bookmarklets from your web browser

•  The reference to the global inbox folder in your Finder's sidebar
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CREDITS

AMINDETERMINATEPROGRESS

Copyright © 2007 Andreas Mayer. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are

permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice,

this list of conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in the

documentation and/or other materials provided with the distribution.

•  Neither the name of the copyright holder nor the names of its

contributors may be used to endorse or promote products derived from

this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND

CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,

INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE

ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR

mailto:andreas@harmless.de
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CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT

NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;

LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER

CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF

ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

REGEXKITLITE

Copyright © 2008 John Engelhart. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are

permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice,

this list of conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in the

documentation and/or other materials provided with the distribution.
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•  Neither the name of the Zang Industries nor the names of its

contributors may be used to endorse or promote products derived from

this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND

CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,

INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE

ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR

CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT

NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;

LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER

CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF

ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

SPARKLE

Copyright © 2006—2009 Andy Matuschak
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Permission is hereby granted, free of charge, to any person obtaining a copy of this

software and associated documentation files (the 'Software'), to deal in the Software

without restriction, including without limitation the rights to use, copy, modify,

merge, publish, distribute, sublicense, and/or sell copies of the Software, and to

permit persons to whom the Software is furnished to do so, subject to the following

conditions:

The above copyright notice and this permission notice shall be included in all copies

or substantial portions of the Software.

THE SOFTWARE IS PROVIDED 'AS IS', WITHOUT WARRANTY OF ANY KIND,

EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES

OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT

HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,

WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING

FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR

OTHER DEALINGS IN THE SOFTWARE.

VIDEO JS

Copyright © 2010 Zencoder, Inc.

http://zencoder.com/
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The Video JS player is used according to the LGPL v3.

http://www.gnu.org/copyleft/lesser.html
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LICENSE AGREEMENT

PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE.

BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE

TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE

TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE

SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES,

LLC.

1. License: The application and other components (sound and graphics)

accompanying this License, whether on disk, in read only memory, or on any

other media (the “Software”), and the related documentation are licensed to you

by DEVONtechnologies. You own the disk on which the Software is recorded but

DEVONtechnologies and/or DEVONtechnologies’ Licensor(s) retain title to the

Software and related documentation. This License allows you to non-simultaneously

use the Software on multiple computers by the same person.

2. Restrictions: The Software contains copyrighted material, trade secrets and other

proprietary material and in order to protect them you may not decompile, reverse

engineer, disassemble or otherwise reduce the Software to a human-perceivable form.

You may not sub-license, modify, rent, lease, or create derivative works based upon
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the Software in whole or in part. You may not distribute the Software in any form,

including, but not limited to, electronic information service distribution, bulletin

board distribution, and magnetic or optical medium distribution.

3. Disclaimer of Warranty on Software: You expressly acknowledge and agree

that use of the Software is at your sole risk. The Software and related documentation

is provided “AS IS” and without warranty of any kind.

4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING

NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY

INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT

FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED

DOCUMENTATION. In no event shall DEVONtechnologies’ total liability to you

for all damages, losses and causes of action (whether in contract, tort (including

negligence) or otherwise) exceed the amount paid by you for the Software.

Apple, Carbon, Classic, Cocoa, ColorSync, Darwin, Mac OS X, QuickTime, Quartz and

all other registered names are trademarks of their respective owners.
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GETTING STARTED

Familiarizing yourself with DEVONthink Pro 67

Building Your Database 73

Unleashing DEVONthink Pro’s Power 84

A Word about Backups 89

Tutorials, screen casts, and more 91

By now you’ve installed DEVONthink Pro on your computer and are wondering

where to start. You probably downloaded the software because you have lots of digital

files, and you want to better organize your information, or you want to search for

information across a variety of file types and different file locations. DEVONthink

Pro can help you do that. But how to start?

This short guide will help familiarize you with the look and feel of DEVONthink Pro,

advise you on the best way to build your new databases, brief you on DEVONthink

Pro’s most powerful features, and more.
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FAMILIARIZING YOURSELF WITH DEVONTHINK PRO

Best begin your learning process by shucking some preconceptions about what the

application may be like, and how it may work. Instead of thinking about it as a mere

Finder replacement, or a Spotlight substitute, think about your life, and how you like

to organize things. Do you save important emails, PDFs, or web pages you like for

later viewing? These thoughts will help as you start to figure out what you want to

add, or not add, to your databases.

THE INTERFACE

Most of the time, your ability to effectively use a new piece of software is only as

successful as your ability to learn how to use the interface. That is why DEVONthink

Pro’s developers have created a clean, easy-to-navigate graphical user interface. This

intuitive workspace takes the 'where' and 'how' out of using the software, allowing

you to concentrate on the DEVONthink Pro’s potential.
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Unlike applications that are designed to do highly specific things, such as a calendar

or personal information management program, DEVONthink Pro is a document/

information manager that provides open-ended flexibility to the users to create

databases that work for them. Our users have a very broad range of purposes for --

and approaches to -- their databases; creating a one-size-fits-all, cookie cutter

document and information manager simply wouldn’t work for such diverse users.
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Neither would deviating from the Mac OS X style; any user of Mail (or any other

Apple application) will feel right at home with DEVONthink Pro. This is why is we

think there is no other Mac application that is as 'open' as DEVONthink Pro.

The Main Window: The interface that you'll use most of the time is a view window

(main window) looking into all or a portion of an open database. It consists of a

toolbar and one or multiple panes that give you access to groups, documents, and

their contents. Using the icons in the toolbar you can quickly navigate the contents of

your database, switch views, create new groups and documents as well as search your

database. The Action menu (a button with a gear icon) lets you perform frequently

used actions without searching for the right command in the menu bar.

Note: You can customize the toolbar to your individual needs by using the

menu command View > Customize Toolbar.

What panes you see depends on which View you have chosen: the List and Icon views

show only groups and documents but not their content, the Split and Three Panes

views show groups and documents as well as the content of the selected item. You

switch views with either via the toolbar or the View menu.
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You can open multiple windows for a database, and switch each one to a different

view. The History window offers an additional view on your data, sorted by the date

on which each item was actually added to or modified in the database. Finally, the

Concordance window gives you access to your documents through a weighted list of

all words contained in your database.

Actions: All items (be they documents or groups) can be put into groups, just like

as any files or folders can be put in another folder in the Finder. All commands in

DEVONthink Pro's menus act either on selected groups or selected documents, and

the contextual menu, which appears when you Control click (right-click) an item,

shows the most important commands tailored to the selected items.

Note: Contextual menus are available almost everywhere in

DEVONthink Pro. If you are unsure what you can do with an item in

the user interface, Control click (right-click) it and see what options the

appearing menu offers.

Like the Finder, DEVONthink Pro also has an Info panel that shows additional

information about any selected item. It allows you to change the icon of the item by

pasting a copied picture or icon onto its icon in the Info panel.
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Properties: The Database Properties show you more in-depth information about

your database as well as give you the possibility to open a database by default. Check

Use as Default Database in the Database Properties to open the current database

each time you open DEVONthink Pro.

Inbox: DEVONthink Pro maintains a special, global group, the 'global inbox'. It is

shared between all open databases and is even accessible through the Sorter when

DEVONthink Pro is not running. The inbox is the place where new documents end

up, e.g., when dropped onto DEVONthink Pro's Dock icon or when created via the

Services menu  commands.

TERMINOLOGY

The user interface for DEVONthink Pro should be simple. As you get to know the

various layout possibilities, there are indeed only four principle elements you should

be familiar with:

•  Groups: Like folders in the Finder

•  Documents: Like files; your content, with associated metadata

•  Sheets: A spreadsheet-like variation

•  Replicants: Like aliases in the Finder, but more flexible; no distinction

between original and alias See also p. 73ff



DEVONthink PRO 2.3.3 Documentation, page 72

FILE TYPES

One final note before you begin to create databases and add content: it is useful

to familiarize yourself with the various file types that can be recognized by

DEVONthink Pro, and as well as the resulting potentials for how you may then edit

these files of various file types once their imported/indexed. Take a look at the list of

supported file types and editing possibilities.
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BUILDING YOUR DATABASE

The first step in starting your own custom database, is to create a new database. You

can do this by using File > New Database.  Give your database an easily recognizable

name and choose where you want to save your database, e.g. in your Documents

directory. With your new database created, you are ready to turn your attention to

adding information.

There are two ways of adding files from your hard disk into the database: Import

(in which case the supported files are copied into the database), and Index (in which

case the database captures text/image information from the externally-linked file if

possible, but does not copy the file itself into the database).
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To copy files to the database, use, e.g., File > Import > Files & Folders,  or drag-and-

drop the file you wish to add (to the DEVONthink Pro Dock icon, to the Sorter, to the

floating Groups panel, or to the groups and documents pane of a view window).

To index to external files, use File > Index,  or the equivalent, dragging the file

with Option and Command pressed to DEVONthink Pro's Dock icon, to the floating

Groups panel, or to the groups and documents pane of a view window).

Note: When you choose to index a file contrary to import it, do not delete

the indexed external file or your data will be lost.

SIMILARITIES BETWEEN IMPORT AND INDEX

In either mode, Import (copy) or Index (link), DEVONthink Pro will capture (in

other words: copy) the text of readable file types into the database for searching and

analysis. Also, in either mode, DEVONthink Pro will ignore unrecognized file types

unless the user has checked the Other file types option in Preferences, Import tab.
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If the Other file types option is checked, importing copies all file types to the database

package and indexing links to the external files. In both cases a blank document is

created that links to the actual file on disk; no text is captured, but the contents of

the Info panel (document title, comments, etc.) will be searchable. You can keep all
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files related to your project or research together in your database instead of storing

them in multiple places all over your computer. If Mac OS X is able to display a

preview of the file using QuickLook, DEVONthink Pro displays a preview as well.

DIFFERENCES BETWEEN IMPORT AND INDEX

Imported or indexed plain or rich text files are directly editable in the document's

text pane. Documents in other formats can be edited in their parent application.

Saves changes will be taken over by DEVONthink Pro.

PROS AND CONS OF USING EACH

There's nothing wrong with using both Import or Index in the same database. You

may decide, for example, to import project files but index chatlogs.

Import results in a more easily portable database (for instance, taking a backup of

the database on an external drive or DVD), but yet requires more disk space. Index

results in a less easily portable database, but requires less disk space. If you choose to

index, keep the external files in your Documents directory. That will make it easier to

migrate to another computer later on by moving the complete Documents directory to

the new machine.
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ADDING YOUR FILES

While you may be tempted to dump every file in your hard disk into DEVONthink

Pro and sort it out later, you’re best off being more selective in what you add

(especially as you start). After all, having a large, 'dump it all in' database can

contain a lot of files that will do you no practical good (for example, DEVONthink Pro

can't read your Microsoft Office user profile files), and weeding these files out after-

the-fact can be both time-consuming and frustrating.

Here’s a practical example: Your iTunes database runs over 22 gigabytes. There's

nothing to be gained by simply copying that into a DEVONthink Pro database.

Copying the iTunes database into DEVONthink Pro would result in a large,

inefficient, and slow DEVONthink Pro database, and would most definitely cripple

DEVONthink Pro’s ability to show off its truly amazing abilities to help manage and

use the information content in a well-designed manner (much less perform simple

search and organizational tasks).

A topical database approach -- where you create multiple databases, with each

holding only like information (for example, a bird watching database full of birding

articles, birding newsletters, etc., and a separate quantum physics research database

with research briefs, emails, etc.) can improve the effectiveness of DEVONthink Pro’s

artificial intelligence (AI) features. The AI work best within a database that does
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in fact have contextual relationships among many documents; clogging your new

database with everything from A (apple pie recipes) to Z (Zengobi user documents)

will only hamper the AI’s ability to work effectively.

Having topical databases will help down the road as well. DEVONthink Pro Office

allows you to share your database over the local network or even over the Internet.

Imagine having just one database: You decide to share your painstakingly researched

academic articles with colleagues, only to find that they’re also able to now access

your painstakingly saved financial records and chats with your significant other. Not
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hard to imagine how that has the potential to be both dangerous and embarrassing!

Having multiple, topical databases will allow you to share information quickly and

easily. Your friends and colleagues will appreciate the forethought (not to mention

any embarrassment they might have incurred stumbling onto your saved chat logs).

Summary: What material do you wish others to see, and why? What material do you

not wish others to see, and why? These are important considerations as you design

your databases. For several reasons, think about creating more than one database,

and to keep your databases relatively topical. It's not difficult to carve out topical

areas that don't overlap with multiple databases, and the effort may help you stay

more organized.

But no panic if you start with one way of organization and decide later to re-

organize your databases. As DEVONthink Pro can keep multiple databases open

simultaneously, you can easily move documents from one database to the other at any

time.

OUR RECOMMENDATION

Even though we wouldn’t blame you if you eventually think of DEVONthink Pro as

your life, it is, indeed, a database application. Like all databases, the larger it is, the

more memory it will require in order to run quickly. Your computer, no matter how

up-to-date and top-of-the-line, has processing, RAM, and disk space limitations.
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One way to keep your life, ehrr, databases, running smoothly is to run multiple

databases. Not only is it easy to open multiple of them at the same time, but you’ll

find that if you 'split' the information on your computer into databases that can be

easily categorized (a.k.a. topical databases, see above) you can make DEVONthink

Pro and your computer perform better (almost instantaneous searching and

analyzing information if your computer meets recommended hardware and software

specs). Of course, having performance problems with one database is not a problem if

you only have a few files in your database. But what about people like a researcher,

who has hundreds of gigabytes of files, and who can’t seem to stop adding new

information on a daily basis? For people like her, multiple, topical databases are the

only way to go.

CASE STUDY: BILL�S DATABASE FARM

Bill DeVille, DEVONtechnologies' Evangelist, is very interested in a number of

scientific areas. Bill's main database covers interests in environmental science

and technology topics, with related interests in science and technology exchanges

with developing nations; even some projects dealing with graduate education in

environmental sciences and engineering. There's a broad topical relationship, but

the content of the database covers many special disciplines ranging from chemistry,
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toxicology, statistics, risk assessment, and engineering to economics, legal, regulatory,

and policy issues. These disciplines fit together, and information covering all of these

topics is necessary in many real-world cases.

As you can imagine from the above description, Bill's main database is a pretty big

database, amounting to about 20,000 documents and over 20,000,000 total words.

Because there really are relationships knitting together all these scientific, technical,

legal, and policy issues, the artificial intelligence features of DEVONthink Pro work

very well for Bill in researching the database and contextualizing the information.

In addition to his main database, Bill has seven additional databases (so, eight total).

For example, he has one database for Apple Newton literature he has accumulated

over the years. It's almost as big as his main database, but the topical coverage

has no practical relationship to the main database, so Bill keeps the Apple Newton

literature in its own domain. If he were to keep the unrelated matters from the

Apple Newton database and the main research database in one single database, the

result would be a larger, slower database, with poorer performance by the artificial

intelligence.

Bill's main database has hovered at about 20,000,000 words for the past couple of

years. He often adds topical materials to it that are not related to its main purpose,

as mentioned above. If those 'unrelated' topics grow large enough in volume, he spins
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them off into to a new database. But even with this diligence, the 'core' topics keep

growing daily as Bill adds new environmentally related material from the web or

other sources.

If you’d like to follow Bill's method, start by creating a database with some collections

of files that interest you, and don't be afraid to create other databases that contain

'different' material as your interests -- and main database -- grow. And if you need to

search across databases, simply open all of them at the same time. DEVONthink Pro

searches all of them almost simultaneously.

VERY IMPORTANT: DUPLICATES AND REPLICANTS

One of the things you’re likely to come across as your database grows, are duplicates

and replicants. Both groups and documents in DEVONthink Pro can be duplicated or

replicated.

•  Duplicates are simply two copies of the same document. DEVONthink

Pro automatically recognizes duplicates and shows them in blue.

•  Replicants are items that are filed into more than one place in the

database at the same time. A replicated document exists only once in

the database but it appears in multiple places. DEVONthink Pro shows

replicated items in red.
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It is important that you understand how replicants work before you begin making

changes to documents, as any changes to a replicant are carried over to all replicants;

as you might imagine, this means that you can to do some very powerful (and

potentially negative) things with your database’s contents via replicants. Duplicates

are also useful in their own way, as you can duplicate contents and modify them

without modifying the original document or group. Less powerful than replicants, but

no less important in the grand scheme of database organization.
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UNLEASHING DEVONTHINK PRO�S POWER

DEVONthink Pro comes with a number of features that set it apart from most other,

less powerful Mac applications: Artificial intelligence and web sharing, to name a few.

I, MAC

DEVONthink Pro incorporates artificial intelligence (AI) features like Classify (which

helps you decide where to place new content into the database) and See Also (which

suggests other documents that are contextually similar to a viewed document). These

features become more and more powerful as a database grows, especially if you have

maintained good organization of all previously added content.
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Similar to Classify and See Also are Auto Group (DEVONthink Pro examines

a collection of ungrouped items and creates new groups based on contextual

similarities) and Auto Classify (DEVONthink Pro classifies and immediately files

a document). There is even an AI-powered ranking system built into the Search

function.

These artificial intelligence features set the DEVONtechnologies applications apart

from other document managers available today. Indeed, these features can even

help you look at familiar data in a new way. For example, See Also can often suggest

relationships between documents that might not have occurred to you.

EXTENSIONS AND AUTOMATIONS

DEVONthink Pro is one of the most highly scriptable Mac applications. This

flexibility allows you to extend the capabilities of DEVONthink Pro with scripts and

automating many, otherwise tedious, procedures.

Please don't be 'put off' if you don't know how to write scripts. DEVONthink Pro can

probably let you do everything you wish to do without even using scripts. In fact, the

purpose of most scripts is not to add features you’d otherwise miss out on, but rather

allow you to automate frequently executed manual operations.
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For example, DEVONthink Pro provides a convenient script that automates the

process of printing as PDF a document from any application that allows printing,

and then allows you to choose the location in the database to which the PDF will be

sent. In this case one can accomplish the same end result without using the script,

but with a bit more time and effort required.

There is an active discussion board on scripting in the User Forum.

http://www.devontechnologies.com/redirect.php?id=forum
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See also p. 328ff
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A WORD ABOUT BACKUPS

Your data stored in DEVONthink Pro is valuable, so back it up. DEVONthink Pro

makes it easy. For creating an internal backup, that means a copy of the index files,

inside the database, go to Tools > Backup & Optimize.  To create a copy of the whole

database that you can then save on a server or a DVD-R, use Scripts > Export >

Backup Archive.  We strongly recommend you get in the habit of triggering backups

whenever you have invested substantial time and effort into modifying the database.
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For many users, the value of the data is much greater than the value of the computer

that hosts it. There are many things that can go wrong. Your notebook computer

could be dropped, lost, or stolen. Your hard drive will fail (it's not a matter if it will,

but when). A power outage could corrupt the files on your hard drive. For the truly

paranoid (remember, paranoia is sometimes justified), how significant would the loss

of your database be if your house or office were to burn down? Avoid insomnia and

back up frequently.

Note: As events such as house fires and natural disaster frequently

prove, valuable data should probably be kept at more than one location.

Consider saving a copy of your backed up information at a secure, off-site

location such as Dropbox, the JungleDisk, or a bank safe.

http://www.dropbox.com
http://www.jungledisk.com
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TUTORIALS, SCREEN CASTS, AND MORE

DEVONthink Pro is a powerful application so you will need some time to fully master

it. Open the Support Assistant to read tips, tricks, and tutorials, and install pre-made

scripts and templates that extend DEVONthink Pro's functionality.

Another helpful resource that you should not miss is our President's blog where

Eric publishes last-minute news, important information about our software, and

sometimes even public betas.

Take your time to learn how to work with the software -- and how you want

the software to work. You'll be rewarded with a powerful assistant for all your

information organzation needs.

http://www.devontechnologies.com/redirect.php?id=blog
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COMMON TASKS

Analyze Text Documents 93

Browse the Internet 96

Capture Data from the Web 98

Catalog Your Disks, CDs, and DVDs 100

Catalog Your Photos and MP3 Files 101

Collect Text Snippets and Other Valuable Data 103

Index Files on Your Hard Disk 105

Manage Your Bookmarks 106

Read Newsfeeds 108

Take Notes 110

Write Texts and Outline Projects 112

In this chapter you'll find an number of common ways how you can use DEVONthink

Pro for your everyday tasks; from surfing the Internet to making notes, to cataloging

photos and archiving emails.
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ANALYZE TEXT DOCUMENTS

With its built-in artificial intelligence (AI) functions, DEVONthink Pro can be used to

analyze large amounts of text documents.
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The Concordance function allows you to create a list of all words in a database, sorted

by its frequency and restricted to a given length. The Search and Similar buttons

open drawers that feature all documents containing words that are contextually

similar to the selected word (these searches happen almost instantly). A search

toolbar item lets you find any word of interest.

Other functions that help you analyze documents include the AI-enhanced search

function that also features a list of similar words based on spelling or contextual

similarity. The See Also button lists documents with a similar content and the topics

pop-up menu displays the most important words of a document. Duplicate documents

are instantly marked in blue and bold.

Replicants and cross-links help you create a network of documents.

Possible uses:

•  Analyze the complexity and focus of a given document collection

•  Quickly find relationships between documents or snippets

•  Clean up large document collections

Continue to read here:

•  Import documents from the file system

•  Use the See Also & Classify drawer



DEVONthink PRO 2.3.3 Documentation, page 95

•  Use the AI-enhanced Search function

•  Use the Concordance drawer
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BROWSE THE INTERNET

Besides being a knowledge and information database you can use DEVONthink Pro

as a web browser. This extends the document-based approach to knowledge to the

World Wide Web. Being a database, DEVONthink Pro's web browser does not work in

a windowed style like Safari or DEVONagent Pro; rather, it's document-oriented.
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This enables you to treat web pages the same way as you treat your documents.

Whenever you select a web document (bookmark), DEVONthink Pro immediately

loads and displays its content live from the Internet in the view/edit pane. You can

then archive the complete page to the database for offline viewing.

DEVONthink Pro also handles RSS/RDF/Atom news feeds, either through feed

documents or by simply displaying them via the built-in web browser. Stay up-to-date

with your subject and clip important information right away.

Possible uses:

•  Visit frequently used web sites in a convenient interface

•  Integrate 'live' content from the web with your other documents

•  Easily grab data from web sites and store it in DEVONthink Pro

•  Capture and archive complete web pages

Continue to read here:

•  Capture data from the Web

•  Create a new URL or HTML document

•  View 'live' and local HTML pages

•  Integrate news feeds with your data
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CAPTURE DATA FROM THE WEB

More and more information is provided not on paper but directly through Web sites,

from blogs to news sites, Facebook, and user forums. DEVONthink Pro offers a

variety of options for conveniently capturing data from the Web:

•  Bookmark: The most minimal, capturing only the address (URL, uniform

resource locator) of the page.

•  HTML page: Saves the source code of the page to the database, but

images can only be displayed by downloading from the Web each time the

page is displayed in the database.

•  Web archive: Saves both the HTML code and all resources, like images,

necessary to display the page.

•  Rich text: Capturing selected text/images avoids saving unwanted areas

of the page to the database and will include hyperlinks. A plain text

capture will not include formatting, images or links.

•  PDF: 'Freezes' the web page just like printing to paper. PDFs from Web

pages can be paginated or non-paginated.

All of these options except the bookmark capture the text content of the page (or a

selected area of it), capture hyperlinks if present and preserve the text information

for searches in DEVONthink Pro.

http://www.facebook.com
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Note: There are a number of Web sites that one might visit that prohibit

use of some of the capture options described above. A secure banking

site or a university portal to journals may direct a Bookmarklet or script

capture option to the login page, which will be captured instead of the

desired content. A capture option that requires re-download of the page

on such sites will capture only the login page. Always, the page can

be selected and captured as rich or plain text. The viewed page can be

captured by 'printing' it as PDF to the database.

Possible uses:

•  Capture important news in an easily searchable database

•  Collect all relevant data for your project in one place

•  Collect links to web pages and captured data about the same subject

together in one group

•  Save data from the Web in future-proof formats such as PDF

Continue to read here:

•  Capture data using Services

•  Capture data using scripts

•  Capture data with Bookmarklets or browser extensions

•  Add the global inbox to the Finder's sidebar

•  'Print' any Web page or document as PDF to your database
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CATALOG YOUR DISKS, CDS, AND DVDS

By using the Index function, you can use DEVONthink Pro to set up a catalog for

CD-ROMs or other removable volumes. Create a group for each disk by using the

index function and organize your disks/groups in any way you like. When you need a

specific file, search for it in DEVONthink Pro, insert the volume, Control click the file

in DEVONthink Pro, and select Open With to open the original file on the removable

volume.

Possible uses:

•  Find files even when they're on a removable volume not currently

mounted

•  Create a virtual library for all your CD-ROMs and other media

•  Integrate static documents with other project-related data

Continue to read here:

•  Import or index files

•  Search your database

•  Launch the original file of an index item
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CATALOG YOUR PHOTOS AND MP3 FILES

Besides storing text documents and PDF files, DEVONthink Pro also manages

multimedia data such as photos, illustrations, MP3s, or movies.
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While never designed to be an iPhoto or iTunes replacement, DEVONthink Pro can

also be used as a repository for images you frequently use or as an interface to your

MP3 library (if you don't like other music software). If you do not want to import

these files but leave them where they are in the file system but access the from

within DEVONthink Pro, index instead of import them. See also p. 122ff

Possible uses:

•  Create a dedicated database for photos only

•  View your images in full screen mode

•  Keep project-related images and other documents together

•  Play your MP3s from within your work environment

Continue to read here:

•  Import or index files

•  View your files as thumbnails

•  View images and movies

•  Search your database
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COLLECT TEXT SNIPPETS AND OTHER VALUABLE DATA

Using Mac OS X's handy Services menu,  DEVONthink Pro is the premiere tool for

collecting and organizing information bits and snippets.



DEVONthink PRO 2.3.3 Documentation, page 104

Select any piece of data and capture it to the currently open database with a

keystroke or a short visit to the Services menu. All Cocoa applications such as

TextEdit, Safari, or DEVONthink Pro itself as well as many new Carbon applications,

e.g. the Finder or Microsoft Office 2004, support this mechanism. Alternatively drag

text clippings to the Sorter panel.

DEVONthink Pro automatically sets the title of the newly created snippet to the

first line of text, so there's a good chance that you don't even need to rename it. New

snippets are always created in the inbox. Also, DEVONthink Pro can automatically

classify and file them by using its built-in artificial intelligence.

Possible uses:

•  Collect recent news from your favorite web sites

•  Keep important information from any source and your other project-

related documents together

•  Quickly create an info collection for a specific topic

Continue to read here:

•  Quickly capture a note using the Services menu

•  Use the Dock menu

•  Use the Sorter

•  Drag text clippings to the Groups panel
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INDEX FILES ON YOUR HARD DISK

Besides completely importing documents, DEVONthink Pro can also simply index

files. When indexing files, DEVONthink Pro reads the contents of the file and stores

it for internal reference, yet it always uses the external file for displaying the actual

contents. Use indexing for easily accessing information stored in CD-ROMs, creating

a library of all important documents regardless where they are physically stored, or

for integrating files stored elsewhere with your documents in DEVONthink Pro.

Possible uses:

•  Quickly access information from CD-ROMs

•  Create a front-end for your document collection

•  Integrate static documents with other project-related data

Continue to read here:

•  Import or index files

•  Search your database

•  Launch the original file of an index item
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MANAGE YOUR BOOKMARKS

With its integrated, document-based web browser, DEVONthink Pro can be used as a

bookmark manager. Organize all your bookmarks as bookmark documents and visit

them simply by selecting them in split or three panes view. DEVONthink Pro loads

the page and displays it in the view/edit pane.

If you want to open it in your default browser, simply Control click (right-click) the

bookmark and choose Launch URL from the contextual menu.

Possible uses:

•  Manage your bookmarks

•  Keep project-related web pages and other documents together

•  Visit frequently used web sites in a convenient interface
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•  Integrate 'live' content from the web with your other documents

•  Easily grab data from web sites and store it in DEVONthink Pro

Continue to read here:

•  Create a new bookmark document

•  View 'live' and local HTML pages

•  Drag URLs to the Groups panel

•  Drag URLs to the Sorter
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READ NEWSFEEDS

DEVONthink Pro comes with built-in support for RSS, RDF, and Atom news feeds

that makes it also a decent news reader. In addition, its integrated web browser

supports news feeds and displays them like any other web page. Use its document-

oriented structure to organize bookmarks and store news feeds like Internet-updated

smart groups.

Mix live news feeds with static documents, e.g. in your project materials.
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Possible uses:

•  Read your daily news in a convenient interface

•  Integrate 'live' newsfeeds with your other documents

•  Easily grab interesting information and store it in DEVONthink Pro

Continue to read here:

•  Create a new bookmark or HTML document

•  View 'live' web pages and news feeds

•  Create a news feed document

•  Copy news from your RSS reader to DEVONthink Pro
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TAKE NOTES

DEVONthink Pro is perfectly suited for taking notes and organizing them.

Use DEVONthink Pro's Dock menu  to quickly create new notes; write them with all

the advanced text editing capabilities of Mac OS X and find a place to file them in

your database using the Classify & See Also  button.

Possible uses:

•  Write down ideas before they vanish
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•  Conveniently take phone messages

•  Keep project notes and your other project-related documents together

Continue to read here:

•  Create new documents

•  Quickly create new note using the Dock menu

•  Use the built-in rich text editor

•  Organize your data using Classify and See Also
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WRITE TEXTS AND OUTLINE PROJECTS

With its hierarchical group structure, organization, and navigation functions as well

as its advanced text editing capabilities based on the Mac OS X text engine and the

full screen mode DEVONthink Pro is perfectly suited for writing text from notes to

whole books.
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Create new documents with just one click, find related documents, and network them

with Wiki-style or static cross-links. Because in DEVONthink Pro you are working

with databases, you can switch from one document to another with just one click and

manage even large projects with ease.

By flagging groups and documents DEVONthink Pro can also be used as a very

simple outliner. Unlike other outliners, DEVONthink Pro uses documents as items

and groups for items that have sub-items. Use it with the Split view to create an

outliner look-and-feel.

Possible uses:

•  Write notes, white papers, and letters

•  Write book chapters and organize them

•  Organize your ideas or projects in outlines

•  Create a network of information for your projects or interests

Continue to read here:

•  Create new documents

•  Use the built-in rich text editor

•  Choose between various window layouts to match your work style

•  Use the See also & Classify drawer

•  Use the Concordance drawer



DEVONthink PRO 2.3.3 Documentation, page 114

MENUS

The Application Menu 115

The File Menu 122

The Edit Menu 129

The Data Menu 134

The Format Menu 143

The View Menu 148

The Go Menu 153

The Tools Menu 156

The Window Menu 160

The Services Menu 162

The Scripts Menu 165

The Help Menu 167

The Dock Menu 169

A complete listing of all commands DEVONthink Pro offers in the menu bar, the

global Mac OS X Services menu, and the handy Dock menu.
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THE APPLICATION MENU

The DEVONthink Pro menu is similar to the application menu in any other Mac OS

X application. It contains commands for displaying the splash screen, opening the

Preferences window, accessing the Services menu, hiding and showing windows, and,

of course, quitting the application.
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ABOUT DEVONTHINK PRO, ...

•  About DEVONthink Pro: Shows information about DEVONthink Pro

including the version number and licensing information.

•  Check for Updates: Checks if updates for DEVONthink Pro are available.

By default, DEVONthink Pro checks for updates automatically; change

your update settings in the Preferences, Update  pane.

Note: For the check for updates no information is uploaded to the

DEVONtechnologies server. DEVONthink Pro only downloads a file

listing the most current versions to your Mac. This option is not available

if you have purchased DEVONthink Pro on the Mac App Store. All

updates are handled by the App Store application in this case.

INSTALL ADD-ONS

This command installs or reinstalls a number additional files and scripts.

Note: If you purchased DEVONthink Pro in the Mac App Store this menu

item may not be available. To open the Install Add-Ons window, click

here instead.

x-devonthink://install-add-ons
x-devonthink://install-add-ons
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The following options are available:

•  Application Scripts: Menu extra scripts extending third-party

applications, e.g. Mozilla Firefox or NetNewsWire.
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•  DEVONthink Pro Scripts: Menu extra scripts providing system-wide

functions.

•  Contextual Menu Plugin: A contextual menu plugin that lets you

add selected files, plain text, or rich text from any Cocoa application

supporting the contextual menu to DEVONthink Pro. Due to the changes

in Mac OS X 10.6 'Snow Leopard' this option is not available in Mac OS X

10.6. Use the system services instead.

•  DEVONthink Jot Widget: Installs the DEVONthink Jot dashboard

widget.

•  Safari 5 Extension: The Safari 5 extension 'Clip to DEVONthink' lets you

clip web pages to your database or add links with notes, similar to the

'Clip to DEVONthink' bookmarklet.

•  Google Chrome Extension: Similar to the Safari 5 extension but for

Google Chrome.

•  Firefox Extension: Similar to the Safari 5 extension but for Firefox.

•  PDF Services: Adds an alias of DEVONthink Pro to the 'PDF Services'

folder so that you can 'print' directly from any application to your

database. See also p. 328ff

•  Folder Action Scripts: Scripts that can be 'attached' to folders and that

are triggered when you add new items to that folder. Use them e.g. to add

files incoming from a networked scanner or a folder-based workflow to
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your database. On Mac OS X 10.6 or later these folder action scripts can

be directly used in the Finder.

•  Global Inbox in Save Dialogs: Inserts DEVONthink Pro's global inbox

into the Finder's sidebar and all 'Save As' dialog windows. Use it to save

directly to the inbox from any application. Note: The name of the inbox is

'Inbox' regardless of your computer's language preferences.

•  DEVONthink Sorter Helper: A helper application launching the Sorter

when you log in.

Check your options and click the Install button to make DEVONthink Pro install or

reinstall the necessary files and scripts into their repsective locations. If necessary,

this command also launches the AppleScript Utility for you so that you can activate

the global scripts menu. See chapter Scripts for more information about how to use

these scripts.

In addition, this command removes obsolete files such as scripts left over from

previous versions.

Options for items that are already properly installed are disabled and marked as

'installed'.
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PREFERENCES, TRASH, AND CACHE

•  Preferences: Opens the Preferences.

•  Empty Trash: Moves the contents of the database trash to the computer's

file system trash.

•  Empty Cache: Empties the web browser cache. This frees up space and

makes sure that all data will be freshly loaded when displaying a web

page instead of using a cached copy.

Note: If Index-captured items are contained in the database trash when

you use Empty Trash, the option Also from disk will become available. If

chosen, it will send the externally linked files to the system trash, too.

Caution is advised!

PURCHASE, ...

•  Check Upgrade Options: Opens a web page that lists the upgrade options

available for your copy of DEVONthink Pro.

•  Purchase License: Opens the DEVONtechnologies Online Shop and puts

DEVONthink Pro into your shopping cart. If this copy of DEVONthink

Pro is already licensed you will be presented with the choice of buying an

upgrade for your existing license or buying another full license.

http://www.devontechnologies.com/redirect.php?id=shop
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•  Enter License: Use this command to enter your licence code. Make sure

you enter ALL the details EXACTLY as they appear in the licence code e-

mail. It is best to use copy-and-paste for transferring name, organization,

and licence code from the email message to the appropriate fields.

Note: Enter License changes into License and Purchase License into

Purchase License or Upgrade  as soon as you have entered a valid license

code (and a paid upgrade exists). Depending on whether you have

purchased your copy in DEVONtechnologies' online shop or the Mac App

Store one or more options may or may not be available.

SERVICES

•  The Services sub-menu gives your access to special commands published

by other Mac OS X applications such as TextEdit or Safari, or by

services extensions such as our own WordService or CalcService. Also,

DEVONthink Pro publishes its own services. See also p. 162ff
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THE FILE MENU

The File menu contains all commands that deal directly with files in your volumes,

databases, or files that can be imported, exported, or indexed. Also, the File menu

contains commands for printing documents.

NEW, OPEN, OPEN RECENT

New Database: Creates a new database. Give it a name and save it wherever you

like in your file system. DEVONthink Pro will add the file name extension '.dtBase2'

to enable the operating system to recognize it as a DEVONthink Pro database

package (technically it's a folder).

Open Database: Opens previously created databases. You can select multiple

databases. If a database has been saved in version 1.x format DEVONthink Pro offers

to convert it to the new format.

Open Recent: Presents a list of recently used databases, which is useful to quickly

access your frequently used databases. Choose Clear Menu to remove all items from

the menu.
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NEW WINDOW

New Window: Opens a new main window for an open database (if only one database

is open no sub-menu is available). DEVONthink Pro windows present all documents

and groups of a database in a Finder-like fashion, and are used to access all stored

items. Some views also contain a view/edit pane for easy viewing and editing of

documents.

IMPORT

Import: Imports files or complete folders from your volumes into the database. You

can find a list of all supported file formats in the appendix. If not stated differently,

data is imported to the default destination. Finder labels are honored when possible.

The flexible plug-in architecture of DEVONthink Pro allows other import modules to

be added. DEVONthink Pro comes with the following default import plug-ins:

•  Address Book: Imports addresses from the Mac OS X Address Book as

a sheet, as vcards (.vcf), or as bookmarks. Tip: To import all addresses,

select all addresses in the group 'All' and import them. Address cards

bookmarks link to the original card in the Address Book application.
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•  Bookmarks: Imports bookmarks from Camino, Firefox, Google Chrome, 

OmniWeb, or Safari as bookmarks. Only new bookmarks are imported if

you use this command again.

Import Site: Opens the Download Manager and downloads a complete web page/site

for archiving and offline viewing. Make sure the download options are set correctly,

especially the options that define which links DEVONthink Pro should follow (if any).

All links within the site are modified so that they point to the downloaded images or

other embedded objects. This ensures that the page/site can be displayed at any time.

Groups created by the Download Manager are excluded from tagging by default.

EXPORT

Export: This sub-menu allows you to export selected documents or groups to the file

system. File > Export > Files and Folders will recreate the hierarchy you have built

in DEVONthink Pro almost exactly; metadata files ('.DEVONtech_storage') make

sure that no metadata such as comments, URLs, etc. are lost. DEVONthink Pro reads

these files when importing and so recreates your original data structure.

http://www.caminobrowser.org
http://www.mozilla.org
http://www.google.com/chrome
http://www.omnigroup.com
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Identical to File > Import, the Export sub-menu provides additional export methods

based on plug-ins. DEVONthink Pro comes with a variety of plug-ins for exporting

documents in different formats as standard. Currently the following plug-ins are

available:

•  as OPML: Exports the selected items as one OPML file.

•  as Rich Text (RTF): Exports the selected items as one large rich text file

(without embedded images, etc.)

•  as Rich Text (RTFD): Exports the selected items as one large rich text

file, including embedded images, etc. Technically, the result is a folder

with the .rtfd name extension, which is treated by Mac OS X like a single

file (Apple calls this a 'package').

•  as Text: Exports the selected items as one large plain text file. You can

choose the desired encoding.

•  as Word Document: Exports the selected items as one large Microsoft

Word file.

•  to iPod: Exports the selected items as plain text notes to an attached iPod

(3rd Generation or later, iPod touch and iPhone are not (yet) supported).

•  as Website: Exports the selected items as standalone web site that you

can upload to your web server and share with your colleagues. In the

appearing dialog window, choose the desired template, text encoding,

and whether DEVONthink Pro should convert diacritics and accented

characters to HTML entities or not. File types that cannot be displayed

http://en.wikipedia.org/wiki/OPML
http://www.microsoft.com/mac/
http://www.microsoft.com/mac/
http://www.apple.com/ipod
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in a web browser, e.g. iWork Pages files, are converted to PDF if possible.

For the export, templates that you can modify yourself are used. See also

p. 416ff

•  as Template: Saves the selected document as a template. It can then

be used to quickly create new documents using Data > New > With

Template.  To remove a saved template or to organize your templates in

sub-folders, visit the folder '~/Library/Application Support/DEVONthink

Pro 2/Templates.noindex' in the Finder, then create sub-folders, move

items, rename them, or trash them.

•  Database Archive: Creates a clean copy of the frontmost database and

compresses it as a .Zip archive. Backup the copy to any medium or server

to keep your data safe from hardware or software failures.

INDEX, UPDATE INDEXED ITEMS

Index: Adds selected files to your database, but only as references, and not in

their entirety. DEVONthink Pro indexes the contents of the file and uses this for

classification and other content-related functions. Indexed items show a little arrow

after their name. For unknown file types, this command creates a bookmark. You can

also drag files from the Finder to DEVONthink Pro; hold down the Command and

Option keys to index them. This is similar to creating an alias in the Finder. Indexed
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groups are excluded from tagging by default and changes to an indexed document are

immediately reflexted in its OpenMeta metadata (and are so noticable by external

tagging applications).

Note: External indexed files or folders located in '/System/', '/Library/' or

'~/Library/' are never renamed or deleted so that you cannot accidentally

cause harm to the system.

Update Indexed Items: This command updates one or more selected groups or

documents with their corresponding folders or files in the file system. If nothing is

selected the enclosing group of the current group is used. It also reads changes made

to the Finder or Spotlight comments of the to-be-updated files and applies them to

their counterparts in the database. Finally, this command removes indexed items

that have lost their external counterpart. It does not affect items moved manually to

the group. Use Update Indexed Items to keep indexed groups and their originating

folders in sync or to manually update an item that you have changed directly inside

the database package when DEVONthink Pro was not running.

To create this connection between the item in the database and the folder or file in

the file system, which is maintained by the Path field in the Info panel, you have to

freshly import/index your folder of choice.

Select the groups and documents and choose File > Update Indexed Items to import

all files that have been newly added to the connected folders in the file system.
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Note: The update for groups is one-way only, from the file system to the

database, but: when you rename a document its file is renamed, too, and

when you change the Spotlight comments of a document this is reflected

in the file system as well.

PROPERTIES

Database Properties: Opens the Database Properties panel for the selected

database (if only one database is open no sub-menu is available) that allows you to

change properties such as database name, comments, and username/password. Also,

you can tell DEVONthink Pro to open this database by default.

Close Database: Closes a selected database (if only one database is open no sub-

menu is available).

PAGE SETUP, PRINT

Page Setup: Sets your preferred page size.

Print: Prints the selected or front-most document.
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THE EDIT MENU

The Edit menu contains all commands and options relating to editing. You'll find the

classic Mac cut/copy/paste and find/replace commands here, as well as many more.

UNDO AND REDO

Undo/Redo: Takes back your last action or redoes it. Undo and Redo work for most

actions.

CUT

Cut/Copy/Paste: Do exactly what they're supposed to do.

Copy URL: Copies the URL of the selected or front document to the Clipboard.

Copy Item Link: Copies a URL to the Clipboard that links to the selected or front

item. This URL can be pasted into other documents in other applications to create a

link to the item in DEVONthink Pro.

Paste with Current Style: Pastes text from the Clipboard into rich text documents,

disregarding all styles from the clipped text. Useful for pasting text from other

applications or documents with a style that differs from the target document.
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Delete: Deletes the selected piece of text.

Complete: Tries to auto-complete the partial word before the insertion caret. This

standard Mac OS X function uses the currently active dictionary, which you can

change via the spell check panel (see below).

Select All/Deselect All: Selects or deselects the complete content of the front

document.

DOCUMENT EDITING

Tags: Shows the Tags  bar (if necessary) so that you can enter your tags immediately.

Split Document: Splits the current document (PDF, plain or rich text) at the

insertion mark position.

Sheets: Use this sub-menu to add new rows or new columns to a selected sheet,

edit, or delete columns. You can select multiple columns in a sheet with Shift and

Command pressed.

PAGE EDITING

Insert Blank Page: Inserts a blank page into the PDF at the position selected in the

sidebar.



DEVONthink PRO 2.3.3 Documentation, page 131

Delete Selected Page(s): Deletes the page(s) selected in the sidebar.

Rotate Left/Right: Rotate a selected image or page left and right.

SUMMARIZE

Summarize: Summarizes the selected piece of text. Unlike Mac OS X's Summarize

service, this command takes advantage of the built-in AI of DEVONthink Pro, and

uses the complete 'knowledge' contained in the open databases for improving the

results. The better your databases, the better the results.

FIND

Find: This sub-menu contains commands for finding and replacing text as well as for

bringing DEVONthink Pro's database search field into focus.

•  In Database: Brings the search field of the front window into focus.

•  Find: Open the standard panel for finding text within a document.

•  Find Next/Previous: Jumps to the next, or previous occurence, of the last

search term.

•  Use Selection for Find: Copies the selected piece of text to the find

Clipboard or into the search field of the find panel if it is opened.
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•  Scroll To Selection: Scrolls the displayed documents to the current

selection.

Spelling and Grammar: Provides the standard Mac OS X functionality for checking

a text for misspellings or bad grammar. To choose the language used for spell

checking, or for auto-completion (see above), open the spell checker panel with Edit >

Spelling and Grammar > Show Spelling and Grammar and choose your language of

choice from the pop-up menu.

Substitutions: Show the standard Substitutions preference panel and switch the

available options manually on and off: Smart Copy/Paste, Smart Quotes, Smart

Dashes, Smart Links, Data Detectors, and Text Replacements. Data Detectors

analyse shown text and make context-sensitive actions available, e.g. when you

hover with the cursor over a phone number or postal address. Mac OS X 10.6 'Snow

Leopard' or higher only.

Transformations: Use this sub-menu to make selected text all lowercase, all

uppercase, or to capitalize every word.

Speech: Starts or stops speaking the selected piece of text.

Insert: Inserts special characters, the current date, and/or time or a picture into your

text. Of course, you can only embed a picture into a rich text document, not into a

plain text document.
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Special Characters: Shows the standard Special Characters panel for inserting

characters that you cannot enter directly with your keyboard.
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THE DATA MENU

The Data menu contains all commands that deal directly with documents or groups.

Here you'll find commands for creating new documents, labeling, classifying, or

grouping them, and more.

NEW

New: This sub-menu allows you to create new documents directly from within

DEVONthink Pro.

•  With Clipboard: Creates a new document based on the contents of the

Clipboard. Note: Some applications such as Microsoft Word put data in

multiple formats into the Clipboard; DEVONthink Pro tries to select

the most useful one, however, in some cases, sometimes grabs an image

instead of text (like Microsoft Word). Workaround: Create a text clipping

for the text, or paste it into a TextEdit window, then copy the text from

there.

•  Plain Text: Creates a new plain text document.

•  Rich Text: Creates a new rich text document.

•  Script: Creates a new AppleScript script.

http://www.microsoft.com/mac/
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•  HTML Page: Creates a new HTML page. You can use the built-in Mac OS

X WYSIWYG editor to edit the HTML page or switch to its source code

(from the navigation bar) and edit it directly.

•  XML File: Creates a new XML document.

•  Property List: Creates a new property list (for developers).

•  Bookmark: Creates a new bookmark. Type the URL you like as well

as a name for it; DEVONthink Pro automatically sets the value of its

URL field in the Info panel accordingly. If you don't type in a name

DEVONthink Pro looks up the page name on the Internet and sets it

automatically for you.

•  Feed: Creates a new news feed document. DEVONthink Pro asks for a

document name and the URL of the feed. You can change the URL of

the feed also later by selecting the feed document and changing the URL

field in the Info panel.

•  Group: Create a blank group.

•  Smart Group: Creates a new smart group, also known as 'saved search'.

DEVONthink Pro opens the Smart Group Editor that lets you define

your search criteria. When saved, the contents of the smart group is

updated every time you display its contents.

•  Sheet: Creates a new sheet. Add columns to the new sheet by using the +

button. Name the columns and sort the sheets by dragging them with the

mouse. Click OK to create the new sheet.
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New from Template: In addition to these standard document types DEVONthink

Pro offers pre-defined and user-defined templates that you can use to quickly add

new documents to your database. Select any template to add its contents to the

current group.

You can add any document to the list of templates using File > Export > as Template.

Some of the pre-defined templates are so-called 'smart templates' or 'template

packages'. They consist of an AppleScript or folders containing files for every

supported language that takes care of choosing the right template variant for your

language, adds them to your database, and modifies it, if necessary. Some smart

templates add the current date, insert the clipboard contents, check if a needed

application is installed, or even access your Address Book and fill in your personal

details from your card. See also p. 406ff

Use Open Templates Folder to open the folder containing the template files in the

Finder and Update Templates Menu to update this menu when you have added

new templates or made changes to the existing ones. Use More Templates to install

additional templates.
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OPEN

Open: Opens the selected document or group in a separate document window. For

groups, this command opens a second main window rooted to the selected group.

Open in Tabs: Opens the selected items in a new tab. You need have more than one

item selected for this command to have an effect.

Open with >: Opens the selected documents in the application you choose from

the sub-menu. You can edit the document in the external application, DEVONthink

Pro automatically synchronizes the file when it is being saved to disk by the

other application. If you have quit DEVONthink Pro in the meantime, use File &

Synchronize  on the document to update it.

LAUNCH, REVEAL, SHOW

Launch URL: Opens the file, folder, or Internet location indicated by the URL field

in the Info Panel.

Reveal: Reveals the location of the front-most document in either the same main

window, if possible, or by opening a new one.



DEVONthink PRO 2.3.3 Documentation, page 138

Show in Finder: Opens a new Finder window for the folder, including the front or

selected documents. Naturally, this only works for documents referring to a file in the

file system through the Path field in the Info panel.

SAVE

Save/Save All/Revert To Saved: These commands save the front document, save

all documents, or restore the front document to the version that was last saved.

LABEL AND MARK

Label: This sub-menu allows you to mark the selected groups or documents with

one of seven labels, just as in the Finder. You can define the color and the text of the

labels in the Preferences, Colors tab.

Mark: This sub-menu allows you to mark the item as flagged/unflagged, locked/

unlocked, and read/unread. Items marked as unread show an unread marker in most

views. See also p. 382ff



DEVONthink PRO 2.3.3 Documentation, page 139

DUPLICATE

Duplicate: Creates a duplicate of the selected items. The name of the new item

ends in 'copy' and both items are shown in bold and blue because their contents are

identical.

Replicate: Creates a replicant for the selected items. Unlike a duplicate or alias,

a replicant is like a second phone book entry for the same person (aliases are little

files containing a link to the original file). When you replicate a group or document

in DEVONthink Pro, you end up with two replicants, not one alias and one original.

Both items have the same name and are shown in red.

Merge: Creates one big document out of several selected ones. This works not only

for text documents, but also for images, PDFs, sheets, and multimedia items. All

the original documents are embedded in the resulting document and all tags are

added, too. If the selection contains only images, PDF or PostScript documents

DEVONthink Pro generates a PDF file, otherwise a rich text document. Document

types that cannot be merged, e.g., bookmarks, are ignored. This command can also

merge multiple selected groups/tags; here the first group is used as the destination.
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THUMBNAILS AND CONVERT

Thumbnails: These commands create, remove, or update the thumbnails or

custom icons for the selected items. Thumbnails for bookmarks can be created if the

Bookmarks option in Preferences, Media tab,  is enabled.

Convert: These commands convert PDFs, sheets, HTML documents, RTF/RTFD

documents, text documents, web archives, and all other documents for which

a Spotlight metadata importer is available, to plain or rich text or to HTML.

DEVONthink Pro never replaces the original document with a text version; instead,

it creates a new document containing the extracted text next to the original item. The

Convert > To Rich Text option tries to recreate the original layout.

GROUP

Group/Ungroup Items: Creates a new group containing all the selected items.

This is similar to creating a new group and moving the selected items into it. This

command also works in the See Also & Classify  drawer. Ungroup does exactly the

opposite; it moves all items contained in the selected group one level up and removes

the then empty group.
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Auto Group Items: This and the following feature Auto Classify are some of the

intelligent functions that gave DEVONthink Pro its name. It tries to find similarities

between the selected documents and then group them accordingly. This is most

useful, for example, when trying to create some sort of structure out of a few hundred

documents that have been randomly clipped from web sites.

See Also & Classify: Opens or closes the See Also & Classify drawer  of a main

window.

Auto Classify: This command analyzes the selected documents and tries to find the

groups where they would fit best. If a document cannot be classified with certainty,

DEVONthink Pro beeps and lists it in the Log panel. If DEVONthink Pro finds more

than one fitting group, it creates replicants in all groups the document fits into.

This function works best with a large database that is already somewhat accurately

structured.

Note: If the document you are auto-classifying has replicants, these

are deleted and the document is only placed into the new locations.

This prevents multiple replicants from being created when you are, for

example, classifying this document again.
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MOVE TO TRASH

Move to Trash/Move All Instances to Trash: Moves the selected items to the

trash. If you have selected a replicated item, Move All Instances to Trash moves this

item and all its replicants to the trash.
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THE FORMAT MENU

The Format menu contains all the commands and options dealing with all aspects of

text formatting. Here you'll find the standard font, alignment, and ruler commands,

as well as very special DEVONthink Pro commands.

Note: Many commands in this menu only work with rich text documents,

as plain text documents do not allow formatting (that's why they're called

'plain' text). Some formatting options are also available for editable PDFs

and web archives.

FONT

Font: This sub-menu is reponsible for controllig the font as well as the document

background color (rich text documents only). Open the fonts panel with Show Fonts,

then increase or decrase the font size of selected text with Bigger and Smaller, adjust

the text styles and the document background color.

Copy the font formatting of a selected piece of text or the passage of text around the

insertion caret with Copy Font. You can then apply the formatting to selected text

using Paste Font.
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Style: The commands in this sub-menu apply a certain style, such as italics, bold,

or underlined, to selected text. Also, the commands give you access to some high-

end font control like kerning, baseline shift, ligatures, and character shape (only

applicable to Asian languages).

The most interesting part here is Styles, which opens the Mac OS X Styles Editor. You

can step through all the styles used in the current document and add them to your

favorites. Use the pop-up menu to select a saved style and, if you don't need it any

more, delete it. You can use saved styles from the ruler (see below).

Note: If you think the user interface for the styles editor is less-than-

wonderful, you're right. But don't blame us, it's Apple's design :-)

Alignment: Align paragraphs left, right, centered, or justified. Here, Asian or Arabic

users can also change the direction of writing, if necessary.

Ruler: Show the ruler, which shows the tab stops and contains alignment and styles

buttons; copy the current ruler (line width, indents, tab stops, etc.) and paste it

somewhere else.

Learn more about the ruler and the Styles Editor here.
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HIGHLIGHT

Highlight, Highlight Color: In rich text documents, editable PDFs, and web

archives use Highlight to highlight a selected piece of text as you would do with a

colored pen on a piece of paper. To remove highlighting, select the highlighted piece

of text and choose Highlight again. Use the Highlight Color sub-menu to choose your

favorite highlight color.

SPACING

Spacing: This command is only available in rich text documents; the command

allows you to adjust the line spacing of selected text. You can adjust the line height to

an exact value or define a minimum and maximum height, adjust inter-line spacing,

and define the space before and after a paragraph.

Note: Paragraph spacings are not added to those of the preceding

or following paragraph; instead, the maximum spacings from both

paragraphs are used to ensure a proper layout.

Link: Makes selected text a link to a URL (for example, to a web page or to an

email address). This is a one-step command for writing the address into a rich text

document, selecting the address, selecting Make Link (see below), and then changing

the linked text to anything you want.
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List: Creates a bullet list. Select your prefix, bullet style, and suffix in the dialog

sheet and click OK to insert your list skeleton. In the list, press Return to insert new

items and press Tab and Shift-Tab to indent/de-indent items just as you would do in

any word processor.

Table: Inserts a new table into a rich text document and opens the table inspector

panel. Use the table inspector to adjust the number of rows and columns, cell

alignments, cell colors, border width, and color. Also, you can merge and split cells

and create tables within a cell.

MAKE LINK

Link: Makes the selected text clickable and asks for a destination. Enter any valid

URL you want the text to link to.

Make/Remove Link: Makes selected text clickable, or removes a link from the

current selection. Where you are taken to when you click the link depends on the

selected text:

•  If the text was a valid URL, the URL will be the target of the link.

Editing the link text later does not change the target. Use the Edit Link

command of the contextual menu to edit the link target.
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•  Otherwise, DEVONthink Pro treats the link as a Wiki-style link.

Clicking the Wiki-style link jumps to a document with exactly the same

name as the linked text (or any document with a Wiki alias of that

name). If there is no document of that name, clicking the link creates a

new rich text document named after the linked text and pre-filled with

the template you set in the Preferences, Editing tab.

Make Plain/Rich Text: Converts a rich text document to plain text and vice versa.

Converting a rich text to plain text removes all formatting, converting a plain text

document to rich text applies default rich text font settings to the document.

INVISIBLES

Show Colors: Shows the color panel, e.g., for changing the foreground color of

selected text in rich text documents.

Show Invisible Characters: Toggles display of invisible characters such as spaces,

tabs, and line feeds. Shown invisible characters appear in light gray.

Allow Hypenation: Enables or disables hyphenation for the current rich text

document.
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THE VIEW MENU

The View menu contains all the commands for modifying the way DEVONthink Pro

displays groups and documents.

VIEWS

Using these commands, you switch between different layouts for main windows:

•  List

•  Icons

•  Columns

•  Split

•  Three Panes

•  Tags

VIEW OPTIONS

Cover Flow: When checked, DEVONthink Pro displays the contents of selected

groups in Cover Flow style in the view/edit pane in the Split and Three Panes views.

Use it to quickly browse visually through multiple documents. You can double-click

the front-most document to open it in a separate document window or you can drag it

to other areas, windows, or applications.
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Full Screen: Displays either the current document in a full screen mode optimized

for reading and editing, or the frontmost window in full screen.

•  Document: Shows the current document in full screen.

•  Window: Shows the current window in full screen (OS X 10.7 Lion or

higher only).

To return to the normal view, press Command-F7 respective Control-Command-F or

the Escape key. You define the width of the document full screen view as well as plain

text font, background color, and text color in the preferences, Editing tab.

VIEW LAYOUT

Widescreen: Switches Split, Three Panes, and Tag views between standard and

widescreen layout.

Show/Hide Sidebar: Shows or hides the main sidebar that lists all open and recent

databases, global smart group, the global inbox and the trash.

Show/Hide Details: Switches between displaying icons only or displaying icons

together with detailed information such as kind, label, size, words, creation date, and

modification date. Available in all windows showing an Icon view.

Show/Hide Tags: Shows or hides the tag bar.
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SORT AND COLUMNS

Sort: Sorts items in ascending or descending order by various criteria: name, kind,

date added, creation/modification date, URL, path, word count, flag, label, width

x height, duration, location (enclosing group hierarchy of the item), and Spotlight

comment. Also, you can choose to sort items manually, Unsorted, and to ignore

umlauted characters when sorting elements. DEVONthink Pro remembers sort

settings for every group separately and used when the group is displayed in its own

main window.

Columns: This sub-menu lists all columns available in the current view and

allows you to show or hide them individually. Use these options to show exactly the

information you currently need.

The State column shows the state (flagged or unflagged). Clicking the flag or the

empty spot for the flag toggles the flag. Unread items are marked as read when the

'unread' state is clicked.

Both Sort and Columns support a range of metadata fields next to DEVONthink Pro's

own data fields.

EXPAND AND COLLAPSE

Expand and collapse all groups at once.
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ZOOM, FULL SCREEN

Actual Size: Depending on the document type you can zoom the document to your

needs:

•  Actual Size: Displays the document at its actual size, calculated using

the resolution of the screen and the resolution information of the image

or PDF.

•  All Pixels: Displays the document at a 1:1 ratio so that one pixel of the

image equals one pixel on the screen (PDFs and images only).

•  Zoom In/Out: Zooms in or out of the document.

•  Zoom to Fit: Displays the document so that it exactly fits either the

height or the width of the window/preview pane (PDFs and images only).

•  Zoom to Width: Displays the document to that its width fits the width of

the window or view/edit pane (PDFs and images only).

PDF DISPLAY, TEXT ALTERNATIVE

PDF Display: This sub-menu lets you adjust the way PDF documents are displayed.

•  Single, Facing Pages: Show a multi-page as single pages or facing each

other (as in a magazine).
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•  Continuous: When checked, shows the pages of the PDF as one long

spread. When unchecked, only one page is shown at a time.

•  Book Mode: When checked, facing pages start with one single page (the

title page), then facing pages. When unchecked, they start facing.

•  Page Breaks: When checked, pages are shown with a shadow around

them. When unchecked, they are 'melted together'.

•  Crop Box, Media Box: Crops the page to the crop or media box. By

default, PDF pages are cropped to the crop box.

•  Sidebar: Shows or hides the Sidebar.

Text Alternative: Toggles between a graphic preview of a document, e.g. generated

by Quick Look, named the 'Best Alternative', and a text-only alternative, 'Text

Alternative'. For some document types, e.g. email messages, the Quick Look preview

does not permit you to click links or copy text; the text alternative allows this.

TOOLBAR OPTIONS

Hide/Show Toolbar: Hides or shows the toolbar of the front window.

Customize Toolbar: Lets you configure the toolbar of the front window.
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THE GO MENU

The Go menu contains all commands for navigating the hierarchy of your

DEVONthink Pro database. Use these commands to go backwards and forwards

through your documents, or to move back to the top level of the group hierarchy.

TOP GROUP, ...

Top/Enclosing Group/Selected Group: Goes back to the top level of the group

hierarchy, to the group enclosing the shown group (if any), or to the selected group

('hoist'). These commands are only useful when you have opened a group in a second

main window, so that the 'root' of the window is not the top group of database, or

when you are using DEVONthink Pro in outline-style.

Back/Forward: Moves backwards and forwards through all documents/web pages

you have visited by following cross-links or Wiki-style links.

First/Previous/Next/Last Document: Navigates to the first, previous, next, or

last document of all documents in the current group. Useful when you have opened a

document in a separate window and want to move to another document in the same

group. Also works in the Three Panes view and in Search windows.
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INSTANCES, HIGHLIGHTS

Previous/Next Instance: Navigates backwards and forwards through all instances

of a replicated document. Use these commands to find out where the other instances

of a replicated item are. Alternatively you can use a smart group to find all

documents that have replicants.

Previous/Next Highlight: Navigates backwards and forward through all

highlighted passages within a document, regardless of whether these passages have

been highlighted by a search run or manually using Format > Highlight.  Use these

commands to visit all found text passages or highlighted passages in a document.

Page: Navigates to the page with the entered page number.

WORKSPACES

Workspaces save the content and positions of all open windows so that you can

restore them later. This is, e.g., ideal if you are working with the same set of windows

over and over again. Save them as a workspace and recall them whenever you need

them again.

•  Add: Saves the currently open windows as a workspace.
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•  Edit: Opens a window that allows you to edit saved workspaces. Click on

a workspace name to change it, reorder by dragging, and delete with the .

button.

•  Workspaces: Restores to a previously saved workspace.
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THE TOOLS MENU

The Tools menu contains the more sophisticated tools, such as the advanced search

function, the concordance, the history panel, and the log, as well as commands for

keeping your database healthy and for showing the Info and the Groups panel.

SEARCH TOOLS

Search: Opens the Search window. Using the search function you can search

your database in a variety of ways, from searching for a document by name to a

full content search. Using its built-in AI, DEVONthink Pro also assists you in

formulating the right query.

DEVONagent Pro: Opens DEVONagent Pro, DEVONtechnologies' smart Internet

research tool. If the current document has a URL attached, this URL is opened in

DEVONagent's built-in web-browser.

PANELS

Show Info: Opens the Info panel which shows basic information about selected

items. As it is a panel, selecting a new item updates the Info panel accordingly.
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Show Properties: Opens the document properties panel. View or edit the front-most

document's properties such as author, subject, or keywords.

Show Groups: Opens the Groups panel. You can use this panel to always have

your group list handy, for example for dragging text clippings or documents from

DEVONthink Pro or other applications to a group.

RESEARCH TOOLS

History: Opens the History panel for a selected database (if only one database

is open no sub-menu is shown) that lists all documents in the selected database

sorted by modification date. You can use this panel for quickly finding newly added

documents or by their age.

Concordance: Opens the Concordance window for a selected database (if only one

database is open no sub-menu is shown). The concordance lists all words in the

database sorted by frequency. Use it to analyse your accumulated knowledge or to

find the most common words.

DATABASE TOOLS

Like any database, DEVONthink Pro needs a bit of maintenance from time to time.

All commands you'll need for database maintenance are to be found here.
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Verify & Repair: Verify all database structures and repair them if necessary. Use

this whenever you feel it is necessary. By default, DEVONthink Pro automatically

verifies the database structure every time you open a database, and advises you

to run this command when it finds significant errors. Orphaned files found during

repair are placed in a group 'Orphaned files' in the top level of the database.

Backup & Optimize: Create an internal backup of the database and then optimize

the database structure. Optimizing removes unnecessary internal elements from

the database and rebuilds the internal structure to optimize the performance.

DEVONthink Pro also creates internal backups on a regular basis depending on the

settings in the Preferences, Backup tab. Internal backups only back up the index

structures in case the index gets corrupted. Please use an external backup software

to create backups of your complete database including all documents.

Restore Backup: Restore an internal backup. Choose the backup you want to

restore from the dialog window and click Open. You can identify backups by their

creation date.

Note: Restoring a backup simply swaps the current database and the

backup. The backup becomes the active database, the former database a

backup. You'll never lose any data by using this command.
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Rebuild Database: Completely rebuild the database by deleting the index and

rebuilding it from scratch. This removes any structural problems. Depending on the

size of your database, this can take from a few seconds to several hours. You can

rebuild any database including the inbox.

SORTER

Shows or hides the Sorter.

TAKE NOTE

Take Note: Opens the Take Note panel that lets you quickly enter a plain text note

and add it to the default destination.
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THE WINDOW MENU

As in any Cocoa application, the Window menu lists all open windows of the active

application and gives you access to commands for managing them.

WINDOW COMMANDS

Close, Zoom, Minimize: These three commands resemble the red, yellow, and green

buttons of any window title bar, and consequently close the window, minimize the

window to the Dock, or maximize the window. No magic here. Hold the Option key to

change Minimize to Minimize all.

Close, Select Next/Previous Tab: Closes the active tab or moves the focus to the

next or previous tab. Tabbed browsing needs to be enabled for these commands to

work.

Bring All to Front: Brings all windows of DEVONthink Pro to the front. Hold the

Option key to change Bring All to Front to Arrange in Front.

Window List: Select any open window from the menu to bring it to the front.



DEVONthink PRO 2.3.3 Documentation, page 161

DOWNLOAD MANAGER

Download Manager: This command opens the Download Manager panel of

DEVONthink Pro. Using the Download Manager, you can download files, or even

complete web sites, from the Internet and store them directly in your database.

LOG PANEL

Log: Opens the Log panel. The log lists error messages and warnings that occurred

while importing new documents. It also opens automatically when an error occurs.

You can save the log to a text file or clear it.
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THE SERVICES MENU

The DEVONthink Pro > Services menu allows access to special commands published

either by other Mac OS X applications, such as TextEdit or Safari, or by services

extensions such as DEVONtechnologies' WordService or CalcService. Also,

DEVONthink Pro publishes its own services in the Services menu.
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DEVONTHINK PRO SERVICES

DEVONthink Pro installs several services for copying selected text, summarizing

text, capturing a web page, or looking up documents in the database.

Add to DEVONthink: Adds selected files, bookmarks, or images to your database.

This service is e.g. available in the Finder's contextual manu.

Take Plain/Rich Note: Adds selected text from any application that support

services (!) as plain or rich text to the global inbox. Taking a rich text note also

copies images and clickable links. If the source document is a web page or a news

feed, it tries to capture the address of the page or feed as well. This only works with

applications that support this, such as Safari, DEVONagent Pro, or NetNewsWire.

Capture Web Archive: Captures the web page displayed in the front-most window

of any WebKit-based browser (such as Safari or DEVONagent Pro) as a web archive

to DEVONthink Pro's inbox. This menu item is only shown when available, e.g., when

Safari is the active application.

Append Plain/Rich Note: Adds selected text as plain or rich text to the last note

taken using the DEVONthink Pro Services menu items.

Lookup: Opens the Search window in DEVONthink Pro with the selected text copied

as search term.

http://www.newsgator.com
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Summarize: Creates a new note in DEVONthink Pro's inbox with a summary of

the selected text. DEVONthink Pro uses all documents in the open database for

determining what's important and what is not. The summarization settings in the

preferences, Editing tab, define whether the summary shall be based on sentences or

paragraphs.

THE SORTER SERVICES

The Sorter adds another sub-menu to the Services menu that contains a Send To

Inbox command. It copies the current selection to the Sorter's inbox, if possible.

Note: After installing DEVONthink Pro you need to log out and then log

back in again for new services and their shortcuts to be recognized. If

one or more DEVONthink Pro Services menu commands do not carry a

shortcut, then maybe another application grabbed them. Mac OS X will

assign the correct shortcut when no other application claims posession of

the same key combination.
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THE SCRIPTS MENU

The Scripts menu is located left of the Help menu  and shows a stylized AppleScript

'S' symbol instead of a normal menu title. It contains a collection of useful, predefined

AppleScripts you can use directly from within DEVONthink Pro.

Some of the scripts work without having selected a document, while others require

you to select the document you want the script to interact with. In general, the script

will tell you what you have to do when you select it from the Scripts menu.
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Use More Scripts to install additional scripts.

Read more about scripts and the DEVONthink Pro Scripts menu here.
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THE HELP MENU

The Help menu contains commands for opening the integrated help pages, the

support assistant, or visiting the DEVONtechnologies website.

DEVONTHINK PRO HELP

These commands open the integrated help pages that are equal to the document

you're just reading or open the release notes. In addition, they direct you to the

bookmarklets installation page
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SUPPORT ASSISTANT

Opens the support screen of the Welcome to DEVONthink Pro  assistant where

you can e.g. get support, retrieve your license code, request a trial extension, or

update your details in DEVONtechnologies' customer database. You can also install

additional scripts or templates from the assistant.

Note: If you have purchased DEVONthink Pro on the Mac App Store all

options dealing with licenses or upgrades are not available.

DEVONTECHNOLOGIES

These commands take you directly to the corresponding pages on the

DEVONtechnologies web site. Visit our home page or the lively user forum. If you

have a question or suggestion, send feedback directly to our development team.

http://www.devontechnologies.com/redirect.php?id=forum
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THE DOCK MENU

The Dock menu appears when you click DEVONthink Pro's icon in the Dock with the

Control key pressed, or when you right-click it. On Mac OS X 10.5 'Leopard' you can

also left-click and hold the mouse button for one second or longer.

DEVONthink Pro's dock icon also displays a badge with the number of new items,

e.g., after adding new data via the Services menu  the bookmarklets, or scripts.

Longer tasks, e.g. importing, indexing, or running scripts, show a progress indicator

on the dock icon, too.
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For all Mac OS X applications, the Dock menu provides a selection of the commands

of the application menu.

•  <Window Name(s)>: Brings any open window of DEVONthink Pro to the

front.

•  Remove from Dock: Removes DEVONthink Pro from the Dock. Only

available if DEVONthink Pro was added permanently to the Dock and is

not currectly open.

•  Open at Login: Adds DEVONthink Pro to your login items.

•  Show In Finder: Reveals the DEVONthink Pro application package in

the Finder.

•  Hide: Hides all windows of DEVONthink Pro.

•  Quit: Quits DEVONthink Pro.

Besides these standard commands, DEVONthink Pro adds a number of its own

commands to the Dock menu to make them easily accessible whenever the application

is running.

•  Import: Imports new documents from the file system, same as File >

Import.

•  Index: Indexes files in the file system, same as File > Index.
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•  New With Clipboard >: Creates a new document based on the contents

of the Clipboard. Same as Data > New > With Clipboard.  Choose the

destination database and group from the sub-menu.

•  Take Note: Opens the Take Note panel.

•  Search: Opens the Search window.

•  Show/Hide Groups & Tags: Shows or hides the Groups & Tags  panel.

•  Show/Hide Sorter: Shows or hides the Sorter.
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WINDOWS AND PANELS

Main Window 174

Document Window 194

Search Window 196

Info Panel 205

Document Properties 210

Concordance 211

Download Manager 214

History 221

Groups & Tags 223

Take Note 225

Log 227

Preferences 229

Database Properties 230

Assistant 234
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DEVONthink Pro communicates with you through a number of windows. These

windows are used for displaying and manipulating groups and documents, finding

information, editing metadata, analyzing text, or changing the properties of your

database.
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MAIN WINDOW

Most of the time you spend in DEVONthink Pro will be spent in a main window. Like

Finder windows, main windows give you access to your groups and documents, while

also allowing you to view and edit documents.



DEVONthink PRO 2.3.3 Documentation, page 175

Open a new main window with File > New Window.  DEVONthink Pro also opens a

new window when you open a database; do this by checking Open New Window in

Preferences, General tab.

The title of the window shows the name of document or group if one is selected as

well as its icon. Drag the icon, e.g. to the Finder, to copy the document and click,

with Command pressed, the title bar to reveal the document's location within the

database. Select an enclosing group to reveal it.

VIEWS

Different views present your information in exactly the way you need:

•  List: Displays groups and documents as a list; groups can be expanded/

collapsed by clicking the gray triangle in front of their name. Double-

clicking items opens them in separate windows.

•  Icons: Displays groups and documents as icons. Double-clicking items

opens them in separate windows. For images, DEVONthink Pro displays

a live thumbnail. Adjust the size of the icons using the slider at the

upper right corner of the window, just below the toolbar. Use View >

Show/Hide Details  to switch between icons only and icons with details

in a list.
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•  Columns: Displays groups and documents in columns and with a

preview pane, similar to iTunes. Selecting a document displays it in the

preview pane; selecting a group shows the items it contains in a new

column to the right of it. Double-click the column resizer to make it fit

automatically. Each column can be sorted individually.

•  Split: Splits the window into an item list and a view/edit pane. To switch

between vertical and horizontal split, use View > Widescreen.  The item

lists all groups and documents of the database and can contain one or

more columns. By default, it shows only item names. Expand/collapse

groups by clicking the gray triangle.

•  Three Panes: Resembles the way Apple Mail displays folders, items, and

contents. The pane on the left displays all groups, the top right pane

displays the documents contained in the selected group, and the view/edit

pane to the lower right shows the contents of the selected document and

allows you to edit it if possible. Tip: When you click the Home button the

toolbar, you will see also the files located in the root of your database.

•  Tags: Shows all documents in a database for selected tags. Select a tag

to show all items carrying this tag; select multiple tags (e.g. by selecting

them with the Command key held) to show documents carrying all

selected tags. Select no tag to show all items. Delete tags by pressing

the Delete or Backspace key; this moves ordinary tags to the trash and

excludes group tags from tagging. See also p. 392ff
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To adjust the size of the different panes, move the mouse to the divider between two

panes until it changes into a line with two arrows. Then, click and drag the divider to

adjust the size of the panes.

SIDEBAR

In the sidebar, which you can show or hide via View > Show/Hide Sidebar, 

DEVONthink Pro lists:

•  The global inbox

•  The trash can

•  All open databases

•  Recent databases

•  Favorites

•  Smart groups

Use the sidebar to quickly access your open and recent databases as well as the

global inbox, your favorite databases, groups and news feeds, smart groups, and the

trash. Select an open database to switch to it, double-click a recently used database

to open it. Read-only databases are marked with a read-only icon. Items dragged to

a database in the sidebar are placed in that database's inbox. Collapse or expand

sections using the collapse triangles.
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Using the contextual menu you can create new databases, open and close them,

empty the Trash, create smart groups, open the Database Properties panel, and add

databases to or remove them from the Favorites. For the Inbox, most database-related

menu commands are available, too, such as Tools > History  or Tools > Concordance. 

An action menu and a + button give access to commonly used functions, too.

In addition you can use drag-and-drop to move items to the Inbox or the Trash or

add groups or news feeds to the Favorites. When you select a group in the Favorites,

DEVONthink Pro will show that group's contents and even open the database that

contains it if necessary. When you drag a smart group to the sidebar it will be copied

to the sidebar; double-clicking a smart group opens the smart group editor for it.

For the Inbox and the Trash DEVONthink Pro always shows the number of items

contained, independent from the preferences. The Recent databases segment does not

show databases that are also a favorite to prevent listing them twice.

The sidebar's width and visibility is specific for each database.
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ITEMS

DEVONthink Pro displays groups and documents, much as the Finder does. Select

items with a single click, drag them with the mouse from one group to another. You

can also drag items to the Finder or any other application, or drag folders and files

from the Finder to DEVONthink Pro. You can also drag clippings such as text and

images from any application to DEVONthink Pro and vice versa.

Press the Command and Option keys to link to the dragged item(s) instead of

importing them to the database. Single-click items to rename them. Double-click

items to open them in a separate document window or in the external application

that has created it (depending on the document type). For smart groups, double-

clicking them in any view except Icons view opens the Smart Group Editor  for them.

Press the Space bar to preview the item using Quick Look; close the preview with the

close gadget or press Escape or Space again to close it.

Colored item names, colored group icons, and special icons tell you whether an item

is a duplicate or replicant, about its 'unread' status or what type of search a smart

group uses.

•  Empty groups are shown in gray.

•  Duplicates are shown with their name in blue, replicants are shown in

red. See also p. 134ff
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•  Icons of feeds or other unread items show an 'unread' indicator in the

State column. See also p. 251ff

•  Smart groups using dates are shown with a clock icon, smart groups

using the 'unread' status use a unique icon, too.

•  Regular groups are shown in blue, groups also used for tagging are

shown in yellow with a 'tag' icon embossed.

In addition, icons indicate whether a item is locked, has an attached comment or

script, or has been indexed instead of having been imported. See also p. 391ff

To view or edit the contents of a document or group, do the following:

•  List/Icons View: Double-click the group or document to open it in a

separate window. Hold the Command key as you click to close the

originating window at the same time (hoisting). This also works in the

other views.

•  Vertical/Horizontal Split/Columns View: Select the group or document.

The view/edit pane shows the contents of the group or document. Click

the triangle in front of a group to expand it, then select a document to

view or edit it.

•  Three Panes View: Select a group or sub-group, then select the document

you want to view or edit. DEVONthink Pro shows the group or sub-

groups content in the view/edit pane. Click the triangle in front of a
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group to expand it. When you select multiple groups or news feeds the

upper right pane shows all documents contained in all selected groups in

one list, like in Apple Mail. This does not work for smart groups.

VIEW/EDIT PANE

The view/edit pane (not visible in icons and list view) shows the content of the

selected document and allows you to edit it, if possible. You can edit plain text, rich

text, and HTML pages.

Read more here about the various document types that you can view or edit in the

view/edit pane.

INFO BAR

Just below the toolbar you'll find the info bar. For selected items it shows icon, name

including location, kind, size, and modification date. If you're not sure of what kind a

document is, this is the place to look.

Adjust the size of icons with the slider in the right side of the info bar.
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TOOLBAR

The toolbar of DEVONthink Pro main windows carries many commands for

manipulating the way the application displays information, as well as for

manipulating selected items. Many of these items in the toolbar are simply shortcuts

for menu commands. Here's a short list of the available tools:

•  Navigation: Navigates to the top level of the database, or one level up.

Useful when you have opened a second main window by double-clicking

a group and now want to move up the groups hierarchy in this window.

Also shows or hides the Sidebar

•  Go To Document: Selects the first/previous/next/last document. Only

available in Three Panes view or in separate document windows.

•  View: Switches between the possible views. See above.

•  Actions: Provides some commands for modifying the selected documents,

similar to the Action menu in other views. Generally, the Action menu

contains a selection of the commands also available via the contextual

menu.

•  Scripts: Gives access to the Scripts menu.

•  Quick Look: Opens the standard Quick Look panel for the selected items.

•  Group +: Creates an empty group.

•  Plain/Rich Text +: Creates a blank plain or rich text document.
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•  Link +: Creates a new link document.

•  Sheet +: Creates a new sheet.

•  New Record: Creates a new record (row) in a sheet.

•  Delete Records: Deletes selected records (rows).

•  New Column: Adds a new column to a sheet.

•  Delete Columns: Deletes selected columns.

•  Columns: Opens the columns editor, which allows you to rename, reorder,

add, or delete columns.

•  Mark Up: Highlights selected text, underlines it, or strikes it through.

Available for rich text documents, editable PDFs, and web archive.

•  Highlight: Highlights the selected piece of text with the highlighting

color selected in Preferences, Colors tab.

•  Open: Opens the selected documents in separate document windows.

•  Open With >: Opens the selected documents in an external application.

•  Launch URL: Opens the Internet location stored in the URL field of the

selected documents, for example, a web site URL in Safari.

•  Copy URL: Copies the Internet location stored in the URL field of the

selected document to the clipboard.

•  Delete: Moves the selected documents to the trash.

•  Save: Saves all changes to the currently edited document.
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•  Import, Export: Import imports new documents; Export exports the

selected documents.

•  Reveal: Reveals the location of the selected items in either the same main

window, if possible, or by opening a new one.

•  Show in Finder: Opens a new Finder window showing the selected items.

•  Print: Prints the current or selected documents.

•  Info: Opens the Info panel.

•  Group/Ungroup Items: Group creates a new group and moves all

selected documents into it. Upgroup moves all documents contained in

the selected groups one level up and then deletes the then-empty group.

•  Auto Classify: Classifies the selected documents and moves them into the

most appropriate group if possible.

•  Find (search field): Lets you search your databases. Select your search

options from the magnifier pop-up menu, enter your search term, and

press Return. The pop-up menu also lists the last 25 used search terms.

Check Prefix while typing to let DEVONthink Pro begin to search while

you are still typing. The last word of the term is treated like being a

prefix ('word*'). Add more characters to refine and to speed up the search

and press Enter or Return to finish the search and to search for whole

words only. See also p. 196ff
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•  Find: Opens the Search window.

•  Bigger, Smaller Font: Increases or decreases the font size.

•  Subscript, Superscript: Makes selected text sub- or superscript.

•  Ruler: Shows or hides the ruler for rich text.

•  Fonts: Shows the standard Mac OS X Font panel.

•  Colors: Shows the standard Mac OS X Colors panel.

•  Make Plain/Rich Text: Converts the current text document to plain or

rich text.

•  Highlighting: Highlights selected text. The pop-up menu lets you select

the highlight color.

•  Link: Makes selected text a Wiki-style link. If the text is a URL, the link

will point to that URL.

•  Edit Source, Show Page: Toggles between source and page display of

selected HTML documents.

•  Zoom: Zooms in, zooms out, zooms to view width, or shows the document

in 1:1.

•  Full Screen: Shows the selected documents in full screen mode. Press

Command-F8 to return to windowed mode.

•  (Capture) Page: Captures a web page as HTML code to either the current

group or to the inbox.
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•  (Capture) Web Archive: Captures a web page as web archive to either the

current group or to the inbox.

•  (Capture) PDF: Captures a web page as a PDF to either the current

group or to the inbox.

•  (Capture) Note: Captures selected elements of a web page as a rich text

document to either the current group or to the inbox.

•  DEVONagent: Opens DEVONagent. If the view/edit pane or frontmost

window displays a web page, it opens the same URL in DEVONagent.

•  Backup: Creates an internal backup of the database and then optimizes

the database structure; same as Tools > Backup & Optimize.

•  Verify: Verifies the database structure; same as Tools > Verify & Repair.

•  Send by Email: Creates a new message in the default email application

and adds the selected items as attachments. Supported email

applications are Apple Mail, Sparrow, Microsoft Entourage, PowerMail,

Mailsmith, and Postbox. If the selected item is an email message, the

sender is automatically inserted as the recipient and the text of the

original message is inserted instead of an attachment. Notes: Postbox is

currently only able to send one selected file. Unsupported email clients

(e.g. Thunderbird) can only send the plain text of one selected file.

http://sparrowmailapp.com
http://www.microsoft.com/mac/
http://www.ctmdev.com/powermail/
http://www.barebones.com/products/mailsmith/
http://www.postbox-inc.com/
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Note: Not all of these commands are always available. You can customize

the toolbar by selecting View > Customize Toolbar  or by clicking with

Control pressed (right-click) the toolbar background and selecting

Customize Toolbar from the contextual menu.

SHORTCUTS & MODIFIER KEYS

You can use a couple of shortcuts and modifier keys for group and document icons in

both the item list and when displaying a group's content in the view/edit pane.

•  Tab: Jumps to the first or next editable column.

•  Space: Opens the standard Quick Look panel showing a preview of the

selected items.

•  Command+drag-and-drop: Copies items to the drag destination instead

of moving it.

•  Command-Option+drag-and-drop: Links/replicates items to the drag

destination.

•  Command-Option+drag-and-drop: Creates bookmarks for address cards

dragged in from Address Book.

•  Shift-click: Selects multiple items.

•  Shift-Left/Right/Up/Down Arrow: Extends the current selection.

•  Option-double click or Command-Shift-O: Opens selected documents/

groups in a new tab or a new main window (depending on whether
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tabbed browsing is active or not) and closes the current window ('hoist').

Activate Always open groups in a new window in Preferences, General

tab.

•  Command-click: Opens the target of a link in a new tab or separate

window.

•  Command-Option-click (a cross-link or Wiki link): Positions the insertion

caret inside the link for editing.

•  Option-click (a word): Looks for the clicked word in the database, like the

contextual menu command See [word].

•  Option-click (the triangle in front of a group): Expands or collapses all

groups that are containted within this group as well.

•  Left/Right arrow: Expands or collapses the selected groups in Horizontal

Split, Vertical Split or List views, or navigate to previous/next item in

other views.

•  Option-Left/Right arrow: Expands or collapses the selected groups and

all their children in Horizontal Split, Vertical Split or List views.

•  Control-Tab: Cycles through all panes.

•  Control-Shift-Tab: Cycles through all panes in reverse order.

•  Up/Down arrow: Navigates up and down in all views. Use Shift to select

multiple entries.

•  Space/Shift-Space: Scrolls one page down or up, in non-editable views

(for example, in a locked document).
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•  Return: Renames documents in main windows.

•  Escape: Cancels renaming.

•  Backspace: Deletes selected items.

CONTEXTUAL MENU

The contextual menu (which appears when you right-click or Control click an item)

offers a range of commands tailored to what you wish do with the clicked object (for

example, a text passage).

Most of the commands offered by the contextual menu have counterparts in a main

menu, so you'll recognize them immediately. However, to save menu bar real estate,

DEVONthink Pro gives you access to some options only via the contextual menu.

•  New Window: Opens a new main window.

•  Open Database: Opens the selected database.

•  Close Database: Closes the selected database.

•  Delete Database: Closes the selected databases and moves it to the

Finder's trash.

•  Empty Trash: Empties the trash can.
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•  Database Properties: Shows the Database Properties  of the selected

database.

•  Add to Favorites: Adds the selected item to the favorites.

•  Remove from Favorites: Removes the selected item from the favorites.

•  New Smart Group: Creates a new smart group in the sidebar.

•  Edit: Opens the smart group editor (only available for smart groups).

•  Delete Smart Group: Removes the selected smart group from the sidebar.

•  New: Creates a new document.

•  Open: Opens a selected documents in a new window.

•  Open in Tabs: Opens a selected documents in a new tab.

•  Open With: Opens a selected documents with an external application.

•  Launch URL: Opens the URLs indicated by the URL field of the selected

documents.

•  Copy URL: Copies the Internet location indicated by the URL field of the

selected document to the clipboard.

•  Copy Item Link: Copies a unique URL refering the selected item to the

clipboard. Paste this URL into any third-party application to directly

reference an item in your DEVONthink Pro database.

•  Show in Finder: Reveals the item's file in the Finder.
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•  Move Into Database: Imports the selected indexed item (and its children

if necessary) into the database. Only available for indexed items. Use this

command to consolidate your database.

•  Move To External Folder: Moves previously imported groups and

documents to their enclosing, external, and indexed folder in the

filesystem. Use this command to make all contents of a group indexed

instead of keeping them in the database. Only available for imported

items.

•  Refresh Feed(s): Manually refreshes the selected news feeds.

•  Exclude from Tagging: Excludes the selected groups from tagging.

•  Move To >: Moves the group or document to the group you select in the

sub-menu. Note: Moving items to another database cannot be undone.

•  Replicate To >: Creates a replicant of the group or document in the group

you select in the sub-menu.

•  Duplicate To >: Creates a duplicate of the group or document in the

group you select in the sub-menu. Note: Copying items to another

database cannot be undone.

•  Label: Changes the label of the selected items.

•  Mark: Marks the selected items as flagged/unflagged, read/unread,

locked/unlocked and shows or hides the state of the items.

•  Move to Trash: Moves the selected items to the trash.
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•  Move All Instances to Trash: Moves all instances (including replicants) of

the selected items to the trash.

•  Thumbnails: Creates, updates, or deletes the thumbnails for the selected

items.

•  Convert: Converts the selected items to other document formats.

•  Group: Creates a new group containing the selected items.

•  Auto Classify: Classifies the selected items and moves them to the group

where they best fit into.

•  Send by Email: Creates a new message in the default email application

and adds the selected items as attachments. Supported email

applications are Apple Mail, Sparrow, Microsoft Entourage, PowerMail,

Mailsmith, and Postbox. If the selected item is an email message, the

sender is automatically inserted as the recipient and the text of the

original message is inserted instead of an attachment. Notes: Postbox is

currently only able to send one selected file. Unsupported email clients

(e.g. Thunderbird) can only send the plain text of one selected file.

•  Sort: Sorts the list of items to any available criterium.

•  Empty Trash: Empties the trash (only available for the trash).

http://sparrowmailapp.com
http://www.microsoft.com/mac/
http://www.ctmdev.com/powermail/
http://www.barebones.com/products/mailsmith/
http://www.postbox-inc.com/
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In the Tags view, the following commands are available:

•  Save Search: Available in the right pane of the Tags view this command

creates a smart group from one or multiple selected tags. Use it to select

some tags and save the search as a smart group for convenient access.

In the sidebar, the following commands are available:

•  New Window: Opens a new window for the selected database.

•  New Database: Creates a new database.

•  Open Database: Opens a selected database.

•  Show in Finder: Shows the database package in the Finder.

•  Close Database: Closes the selected database.

•  Delete Database: Closes the selected databases and moves it to the

Finder's trash.

•  Add to Favorites: Adds the selected database to the favorites.

•  Remove from Favorites: Removes the selected database from the

favorites.

•  Empty Trash: Empties the trash.

Note: For your convenience, DEVONthink Pro also makes the Services

menu,  available via the contextual menu.
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DOCUMENT WINDOW

A document window is more or less similar to the view/edit pane of a main window.

You open a document window by double-clicking a document in any view of a main

window or by choosing Data > Open (or any of its equivalents in contextual menus).

Depending on the type of information the document contains, the toolbar of a

document window offers different set of tools. Most of them are identical to their

counterparts in the DEVONthink Pro main window toolbar.
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See the Documents chapter for a detailed description of the various document types.
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SEARCH WINDOW

Search windows allow you to search your database in almost every way possible and

assist you with intelligent functions for broadening and adjusting your search terms.
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SEARCH TERM

In the top part of the search window you find the search term field as well as the

Similar Words button. To enter a search term and run the query with the default

options, simply type your search words into the search term field and click the

magnifier button (right of search field). Like in many other Mac applications, the pop-

up menu (behind the magnifier icon at the left side of the search term field) gives you

access to the last 25 search terms.

DEVONthink Pro uses Boolean operators, parenthesis, and quotes to allow complex

structured search terms. Read more about operators and how to use them to write a

search term in the appendix.

To broaden or adjust your search words, enter a word and click Similar Words to

show a list of all words in the database that are similar to the entered word either by

spelling or by context. Choose one or more words (use Shift and/or Command to select

multiple words from the list) to use them as search words. Multiple selected words

are combined using the OR operator (spelling) or AND (context). The word you've

entered will be shown on the top of the list, so you won't lose it for your search run.

This functions use all open databases for retrieving similar words.
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SEARCH OPTIONS

The left side of the search window gives you even more control over the way

DEVONthink Pro searches the database. Adjust these options to best fit your needs.

Search for: Choose what exactly you're looking for or select All to search all parts of

a document:

•  All: Searches all elements of a document.

•  Content: Searches the content of a document.

•  Name: Searches the name of a document.

•  URL: Searches the URL field of a document.

•  Comment: Searches the Comment field of a document.

•  Metadata: Searches the metadata associated with a document.

Comparison: Make DEVONthink Pro treat regular letters and their counterparts

with umlauts or diacritics equally. Check Fuzzy to make searches fuzzy (e.g. 'Hello'

and 'Hullo' would both be found). Note: This option is only applied to words but not to

wildcards.

State: Limits the results based on their status (flagged/unflagged). Choose Any to

find results regardless of their state.
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Unread: Limits the results based on whether they have been marked as read or

unread. Choose Any to find results regardless of their read status.

Locking: Limits the results based on whether they are locked or not (on/off). Choose

Any to find results regardless of their locking flag.

Label: Limits the results based on their label. Choose Any to find results regardless

of their label.

Search in: Limits the scope of the search run to all open databases, a selected

database, or a selected group.

Note: To search for all documents with a given status, locking state, or

label, simply leave the query field empty and use the above options to

define what you are looking for.

Advanced: This button lets you enter advanced search criteria in the same way you

do for smart groups. Use this to search e.g. for tags or date ranges. The Reset buttons

clears the set advanced criteria. See also p. 282ff
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SEARCH RESULTS

After a successful search run, DEVONthink Pro lists all found documents below the

search term field, and displays them in a list together with their score (relevance

compared to the query), their icon, location in the database, modification date,

document kind, and size. Sort the list in any way you want by clicking the column

titles, click them again to reverse the sorting order. Modify the shown columns

using the contextual menu or View > Columns.  Point the cursor to a result and the

appearing tooltip will show you the full title, location, and other metadata; click a

document title once to rename the document.

Below the list of found documents, DEVONthink Pro gives you a preview of the

documents you select in the list. If you cannot see the preview area, drag its handle

up from the bottom of the window. Also, you can do almost everything you could do in

any other DEVONthink Pro window, such as drag a document to another window (or

Finder), or export them using File > Export.

See also/Classify  and Concordance  drawers are supported, too.

Due to limitations in Mac OS X's PDFKit, highlighting of occurences of the search

term in the document is not tied to words and so also sub-strings are highlighted.
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SMART GROUPS

When you are satisfied with the search results you can save the query including all

settings as a smart group. Click the + button next to the search term field and enter a

name for your new smart group. The new smart group that searches this database is

created in the top level of the database. A smart group that searches all databases is

placed into the sidebar.

TOOLBAR

The toolbar of the search window offers many tools that are also present in

DEVONthink Pro main or document windows. Here's a short list:

•  Go: Selects the first/previous/next/last item.

•  Actions: Provides some commands for modifying the selected documents,

similar to the action menu in other views. Generally, the action menu

contains a selection of the commands also available via the contextual

menu.

•  Scripts: Gives access to the Scripts menu.

•  Open: Opens the selected document(s) in separate document windows.

•  Open Externally: Opens the selected documents in an external

application.



DEVONthink PRO 2.3.3 Documentation, page 202

•  Launch URL: Opens the Internet location stored in the URL field of the

selected documents, such as a web site URL in Safari.

•  Copy URL: Copies the Internet location stored in the URL field of the

selected document to the clipboard.

•  Group: Groups the selected documents in a new group.

•  Delete: Moves the selected documents to the trash.

•  Export: Exports the selected documents.

•  Info: Opens the Info panel.

•  Print: Prints the selected documents.

•  Zoom: Zooms in, zooms out, zooms to view width, or shows the document

in 1:1.

•  Full Screen: Shows the selected documents in full screen mode. Press

Command-F8 to return to windowed mode.

•  DEVONagent: Opens DEVONagent Pro. If the view/edit pane or

frontmost window displays a web page, it opens the same URL in

DEVONagent Pro.

Note: Not all of these commands are always available. You can customize

the toolbar by selecting View > Customize Toolbar  or by Control clicking

(right-clicking) the toolbar background and selecting Customize Toolbar

from the contextual menu.
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SHORTCUTS & MODIFIER KEYS

•  Tab/Shift-Tab: Switch focus between the search field and the search

results.

•  Control-Tab: Cycles through all panes.

•  Control-Shift-Tab: Cycles through all panes in reverse order.

CONTEXTUAL MENU

You can manipulate the search results by right-clicking or clicking them with Control

pressed to open the contextual menu, which offers various additional commands.

•  Open: Opens the selected documents in a separate main window.

•  Launch URL: Opens the documents or web pages pointed to by the URL

field of the selected documents.

•  Copy URL: Copies the Internet location stored in the URL field of the

selected document to the clipboard.

•  Refresh Feed(s): Manually refreshes the selected news feeds.

•  Reveal: Show and select the document group.

•  Duplicate To >: Duplicates the selected documents to the group you select

from the sub-menu.

•  Replicate To >: Replicates the selected documents to the group you select

from the sub-menu.



DEVONthink PRO 2.3.3 Documentation, page 204

•  Move To >: Moves the selected documents to the group you select from

the sub-menu.

•  Label >: Changes the label of the selected documents.

•  State >: Shows or changes the state of the selected documents.

•  Locking >: Locks or unlocks the selected documents.

•  Move All Instances To Trash: Moves all instances of the selected

documents, such as including all replicants (if any), to the trash.

•  Group: Creates a new group in the top level of the database and moves

the selected documents there.

•  Send by Email: Creates a new message in the default email application

and adds the selected items as attachments. Supported email

applications are Apple Mail, Sparrow, Microsoft Entourage, PowerMail,

Mailsmith, and Postbox. If the selected item is an email message, the

sender is automatically inserted as the recipient and the text of the

original message is inserted instead of an attachment. Notes: Postbox is

currently only able to send one selected file. Unsupported email clients

(e.g. Thunderbird) can only send the plain text of one selected file.

http://sparrowmailapp.com
http://www.microsoft.com/mac/
http://www.ctmdev.com/powermail/
http://www.barebones.com/products/mailsmith/
http://www.postbox-inc.com/
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INFO PANEL

The Info panel, just like its counterpart in the Finder, displays additional information

about a selected document or group, from icon and name to comments and other

metadata.
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Open the Info panel using the i icon from the window toolbar or by selecting Tools

> Show Info.  The contents of the Info panel corresponds to the currently selected

object, so you can leave it open all the time and it will always display the correct

information for the selected document or group.

HEAD ELEMENTS

Icon and Name: Just like in the Finder, the top part of the panel displays the icon

and the name of the selected object. To change the icon of the document, select it

and paste any image you want over it. To change the name of the document, use the

Name field below.

Locked: The Locked checkbox indicates if the object is write-protected. Check the

checkbox to protect the document or group from being accidently modified. Locked

documents or groups show a little padlock after their name.

MAIN ATTRIBUTES

Name: Use this field to change the name of the object.

Aliases: Enter one or more words here, separated by semicolons, as alternative

targets for Wiki-style links. Generally, Wiki links refer to the name of contents and

aliases make this system even more flexible.
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Path: This field contains the path to the file holding the document's data. It is non-

editable. You can click the @ button to open the references file using the Finder. In

general this is equal to using Data > Open With  and choosing the default application.

URL: Smiliar to the Path field, the URL field is used to link the document to an

Internet address or just anything else that can be reached by a URL. This field is

used primarily by bookmarks, but you can also use it to connect a document to a web

page. To visit the web page click the @ button next to this field or select the document

and use the contextual menu command Launch URL.

ATTACHED SCRIPT

Script: This field allows you to attach an AppleScript script to any item in

DEVONthink Pro, documents as well as groups. The script will be executed every

time you view the item in a Split view or Three Panes view as well as when you open

it in a separate document window. Click the Select button to choose the script to

attach.

INFORMATION ELEMENTS

Size: Shows the size of the item. For groups and news feeds this field shows the size

of all contained items.
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Kind: Shows of what kind the selected document is (for example text, RTF, etc.)

Added: Shows the date when the object was actually added to the database.

Created, Modified: Shows the dates when the object was created and when it was

modified the last time.

ADDITIONAL INFORMATION

This section lists metadata that has been stored together with the item. What

information is shown depends on the file type as well as the individual document.

ADDITIONAL ELEMENTS

Exclude from ...: These checkboxes allow you to exclude this item from being

used in classification, see also, search, or tagging. Use this to exclude, e.g.,

temporary groups from classification to increase the accuracy of the built-in artificial

intelligence.

Label: Shows the label that this item has been assigned and lets you change it.

Tags: Shows the tags that this item has been assigned. You can also edit tags here.

See also p. 392ff
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Location: Shows the location of this item inside the database.

Instances: Shows how many replicants of this document or group exist in the

database and how many duplicates DEVONthink Pro has identified. Click to show a

pop-up menu listing all instances and duplicates and their enclosing groups. Select

any item to reveal it.

Spotlight Comments: Stores any other information you want to attach to your

document or group, similar to the Spotlight comments field in the Finder. Of course,

the Comments field is searchable. DEVONthink Pro synchronizes the Spotlight

comments in the Finder with this field in the database.

Note: You can modify the comments of multiple selected items at once as

long as the comment of all selected items is either identical or empty.
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DOCUMENT PROPERTIES

The Document Properties panel gives you access to all metadata stored for a selected

document. This metadata includes but may not be limited to:

•  Author

•  Company

•  Copyright

•  Title

•  Subject

•  Keywords

•  Comments

Depending on the document type you can edit or only view these properties. Also,

more fields can be available depending on the document type.
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CONCORDANCE

The Concordance window, opened with Tools > Concordance,  gives you a tool for

analyzing the contents of a database.

Use the concordance to analyze your data by:

•  Rank number (starting with 1, ascending)

•  Word frequency

•  Number of groups containing items containing a word

•  Word length
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•  Word weight (relevance, depends on the contents of the database)

CONCORDANCE LIST

The concordance list shows a list of all words in the database, sorted by frequency or

any other criteria, by clicking the according column title. Click the column title again

to reverse the sorting order.

You can also filter the list by word length, limiting it to alphanumeric strings (to

omit character/number combinations) by entering the minimum and maximum word

length at the bottom of the Concordance window and by checking/unchecking the

Alphanumeric switch. Click the Update button at the top of the window to update the

list after you have changed some parameters.

To find a word in the list, enter it into the search field at the top of the window. Select

any word, and click the Search button at the bottom of the window to open a drawer

containing all documents that contain this word, sorted by relevance. Click Similar to

show a list of words that are contextually similar to the selected word.
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DRAWERS

You can manipulate the items in the drawer opened by the Search button in various

ways. Drag them to the item list to move them to another location, double-click them

to open them in a separate window, or Control click (right-click) them to open the

contextual menu (which shows basically the same options as the contextual menu for

See Also drawers). Press Space to show a Quick Look preview for the selected item.

To close the drawers, click the red close button.

FREQUENCY GRAPH

You can switch between the frequency graph and the concordance list by clicking the

Graph and List buttons in the upper left corner of the concordance window.

The frequency graph shows a graph of the word frequency over the rank number

of the word (see above). Change the sorting in the concordance list to get different

results, such as a graph of frequency over number of groups. You can influence the

graph also by limiting the word length or by omitting alphanumeric strings and

clicking the Update button.
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DOWNLOAD MANAGER

Window > Download Manager  opens DEVONthink Pro's Download Manager panel.

Using the Download Manager, you can download files or even complete web sites

from the Internet and either store them directly in your database or as files on your

hard drive.
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PANEL ELEMENTS

The Download Manager panel consists of:

•  A list of a items to be downloaded

•  A status bar at the bottom

•  A + button for adding items to and a - button for deleting selected items

from the list

•  A reload button (backwards arrow)

•  A go/stop button (play/pause icons)

•  An Action menu (gear icon)

ADDING FILES

To download a web site or any other file, simply add it to the Download Manager by

dragging its URL to the Download Manager panel. Alternatively, you can click the +

button in the panel and add the URL yourself as well as a referrer, user name, and

password. If Automatic is checked, DEVONthink Pro creates a referrer automatically

when downloading whole web sites.
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You can also paste one or more URLs (for example, copied Safari bookmarks,

DEVONthink Pro links, or copied links from DEVONagent Pro's Download Manager),

or add files to the Download Manager by using the contextual menu in web and

HTML views. Option clicking a link also adds it to the Download Manager.

Note: You can also copy URLs in the Download Manager to the Clipboard

or drag them to other applications (like the Finder or Safari's bookmark

manager). The Download Manager als supports URLs for local files

(POSIX path, a 'file://localhost/' URL, or a 'file:///' URL).

THE ACTION MENU

Most actions are available through the Action menu or the contextual menu. Click

the gear button or Control click an item in the Download Manager panel to display

more commands:

•  Add: Add another file to the list.

•  Edit: Edit the parameters of a selected item in the list.

•  Retry: Tries to reload an item that failed to download.

•  Remove: Removes the selected items from the list. Alternatively, you can

press the Delete key.

•  Enable/Disable: Checks or unchecks the selected items. Only checked

items will be downloaded.
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•  Start/Stop Queue: Starts or stops the download queue. Same as the

play/pause buttons at the bottom of the panel.

•  Purge Queue: Removes all items from the list that have been completely

downloaded.

•  Only Added Files to Thumbnail Gallery: Various predefined option sets

(see below).

•  Import Files to Database: Select into which database the downloaded files

shall be stored. Select Folder to save them not in a database but directly

to the file system.

•  Options: Opens the options dialog sheet that allows you to specify in

detail what to download, which links to follow, and where to store the

downloaded files (see below).

For your convenience, DEVONthink Pro comes with predefined option sets that you

can directly select from the action menu.

•  Only Added Files: Downloads only exactly the files you have manually

added to the Download Manager.

•  Offline Archive: Downloads the files you have added to the Download

Manager including embedded images, style sheets, and scripts. Use this

options set to archive/download web pages with everything necessary to

display them properly. Alternative: Create a web archive.
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•  Subdirectory (Complete): Downloads the files you have added to the

Download Manager including all other embedded files or files linked

to them. Also, this option set follows all links leading to (items in) sub-

directories. Use this option set to download, for example, a complete web

site for offline archiving.

•  Subdirectory (Images & Multimedia): Same as above, but downloads only

linked images, linked multimedia files including Flash and QuickTime

movies, and embedded images in the item's directory and all sub-

directories. Use this set to download, for example, a complete web site for

offline archiving (without all linked Office documents, PDFs, etc.)

•  Thumbnail Gallery: Downloads the files you have added to the Download

Manager including linked images, embedded images, style sheets, and

scripts. Use this options set to download, for example, a thumbnail

gallery including all full-size images linked to each thumbnail for offline

archiving.

Note: Downloaded items are by default excluded from classification and

tagging.
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OPTIONS

The options dialog defines which file types the Download Manager should download,

which links it follows, and where it stores the files.

•  Files: Check all file types you want the Download Manager to download

(plain texts, rich texts, Office documents and PDF files, style sheets

and scripts, images, embedded images, multimedia files, mark-up

language files, etc.) With the Follow Links pop-up menu define how far

DEVONthink Pro should follow links on the downloaded HTML pages

(see below). Check Overwrite existing to update an already existing

archive.

•  Folder: When you choose Download to > Folder in the action menu of

the Download Manager panel, DEVONthink Pro stores all downloaded

items in the directory you specify here. Click Set to choose your preferred

location. Use this option to use the integrated Download Manager for

downloading, for example, software archives or other files you don't want

to store in your database. Double-click any part of the location to reveal it

in the Finder.

•  Download: Define how many connections the Download Manager opens

at the same time (fewer connections for slower Internet connection, more

for DSL or broadband). Also, check Automatically purge queue to have

previously downloaded items automatically removed from the queue.
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The Follow Links options defines how far DEVONthink Pro follows links on the

downloaded HTML pages, and so allows you to control if only the actual pages get

downloaded or a complete web site. DEVONthink Pro supports the following options:

•  Off: Do not follow any links.

•  On Same Host: Follows links but only as long as they refer to the same

web server, like the same web site. Files on other web servers will not be

downloaded.

•  In Same Directory: Follows links but only as long as they refer to items in

the same directory as the downloaded HTML page.

•  In Subdirectories: Follows links, but only as long as they refer to items

in the same directory as the downloaded HTML page or in its sub-

directories.

•  One Level: Follow all links regardless where they point to, but only

one level deep. Links on pages linked to from the original page are not

downloaded.

•  Two Levels: Follow all links regardless where they point to, two levels

deep. Attention: This can result in very large downloads!
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HISTORY

The History panel, opened using Tools > History,  lists all documents in your

database in one long list, such as without the groups hiearchy (by default sorted by

modification date which reflects content modifications only but not name or metadata

changes).
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Sort the list by name, age, or file size by clicking the column titles (click again to

reverse the sorting order), and by any other criterum using View > Sort.  Customize

the columns using View > Columns.

Of course, you can use drag-and-drop to move documents to other windows or the

Finder and modify them using the commands in the Data  menu as well as the

contextual menu.

Use the History panel to quickly access recently added documents or to export all

documents of a certain age.
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GROUPS & TAGS

The Groups & Tags panel, opened using Tools > Show Groups & Tags,  gives you

direct access to all open databases and their groups including the tags inside the

special Tags group. Use it, e.g., to drag items directly to a group or tag or to rearrange

groups. You can also apply menu commands to selected items, e.g. Data > Open.
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Depending on your Preferences, General tab, the Groups & Tags panel floats above

all other windows even in other applications.
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TAKE NOTE

The Take Note panel, opened by hitting a hot key, from the toolbar, or the Tools

menu, allows you to quickly enter a note, choose the destination for the note, and

add tags and a URL to it. If DEVONthink Pro can get the URL of the frontmost

application, e.g. from Safari, it will also insert it automatically into the URL field.
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Check Rich Text to take a rich text note. Use the Format  menu to style your note.

Change the hot key for opening the Take Note panel in the Sorter preferences.

Note: For this function DEVONthink Pro needs to be running. This may

change eventually.
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LOG

The Log panel displays warnings and error messages that occur, for example, when

importing files and folders. It shows the date of the message, the affected file, and a

short information about what happened.

You can save the list to a text file with the Save button, and clear the log with the

Clear button. To sort the log, click the according column title (click again to reverse

the sorting order). Use the contextual menu to show an affected file in the Finder.

Uncheck Show log automatically to prevent the log popping up automatically. You can

open the Log panel at any time using Window > Log.
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Right-click or click with Control held to perform additional commands on log entries

via the contextual menu, e.g. to reveal a logged item.
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PREFERENCES

The Preferences window, opened using DEVONthink Pro > Preferences,  contains all

available options that you can modify to adapt DEVONthink Pro to your personal

needs.

Because the preferences are so important, we have created a separate chapter for

them.
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DATABASE PROPERTIES

The Database Properties panel defines preferences which are directly related to the

database and not to the application in general. Open the properties panel using File >

Database Properties  for every open database including the global inbox.

LOCATION

This part of the properties panel shows the location of the database package as well

as additional options:
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Location: Double-click any part of the database location to reveal it in the Finder.

Use as Default Database: Check to open this database every time you open

DEVONthink Pro.

Create Spotlight Index: Check to make this database available to Spotlight.

Checking this option lets DEVONthink Pro create a folder in '~/Library/Cache/

Metadata' that Spotlight uses for accessing the documents in the database. If you feel

that this folder got out-of-sync with the database, click Rebuild to completely recreate

this folder from scratch.

When viewing Spotlight results in a window, make sure to have the Show all file

extensions option in Finder's Preferences, Advanced tab unchecked. If this option is

checked, the Finder displays the generic names of the metadata cache files instead of

the name of the referenced document.

Starting with version 2.0.6 DEVONthink Pro adds information to the Spotlight

metadata that make it possible to preview many file types directly from the Spotlight

results window in the Finder. Supported are text and rich text (RTF and RTFD),

image, movie, audio, PDF, HTML, XML, and web archive files. DEVONthink Pro

needs to be installed on the machine viewing the Spotlight results. You may need to

rebuild the Spotlight index for this functionality to become available.
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Note: Rebuilding the Spotlight index can be, e.g., necessary after copying

a database from one computer to another or after using a third-party

utility like DevonSync.

Exclude Groups from Tagging: Excludes all groups in this database from being

used as tags. Ordinary tags can always be added to items using the Tag bar.

STATISTICS

This section displays some basic statistics on how many documents you have stored

in your database, how large they are, etc.

NAME AND COMMENTS

Name: Enter a name for your database here. It will appear in the title bar of every

main window for this database.

Note: This does not change the file name for the database package.

You cannot change the name of or add commments to the database

representing the global inbox.

Comments: Enter your own comments about the database here, e.g. a project

description.

http://www.woodenbrain.com/index-sw.html
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PROTECTION

To prevent other people from opening DEVONthink Pro and accessing your data,

click on the padlock button to unlock the entry fields, enter a user name, and your

private password, and then click on the padlock button again to lock your changes

and hide the password.

Note: This is a simple password protection. DEVONthink Pro does not

yet provide file encryption for enhances security. For better protection,

create an encrypted disk image using Disk Utility and store your

database on it.
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ASSISTANT

The integrated Assistant combines a welcome screen with tips, tricks, and tutorials,

installable extras, and a suppport page that guides you through the available support

options.
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WELCOME

This screen welcomes you when you start DEVONthink Pro for the very first time. It

offers:

•  An introduction screencast

•  The option to subscribe the free DEVONtechnologies newsletter as well

as a number of welcome tips

•  The tip of the day

•  The extra of the day

You can access all other screens of the assistant from here, too.

GET SUPPORT

The support screen guides you through the three common steps for troubleshooting

DEVONthink Pro. In addition you can have your license code resent in case

you don't have it anymore, request a trial extension, update your details in

DEVONtechnologies' customer database, or buy an upgrade or a second license.
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TIPS AND TUTORIALS

Here you can always find the latest tips sand tutorials that help you squeeze the

best out of DEVONthink Pro. Tutorials can be slideshows describing basic tasks in

DEVONthink Pro or videos (as they become available).

Both tips and tutorials are updated live from DEVONtechnologies' server so it's a

good idea to check back from time to time. The latest tip or tutorial is also always

mentioned on the welcome screen.
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INSTALL EXTRAS

On the extras screen DEVONthink Pro lists all available extras that you can

download and install from DEVONtechnologies' server:

•  Scripts

•  Templates

•  Plugins
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Browse the list of extras and install them with the Install button. The last line of the

description shows where in e.g. the Scripts  or Templates  menu the extra will show

up after installation. Remove installed extras with the Remove button.

The extras are updated live from DEVONtechnologies' server so it's a good idea

to check back from time to time. The latest extra is also always mentioned on the

welcome screen.

Note: If one of these categories does not show up in your copy of

DEVONthink Pro there might be no extras of this type (yet) available for

DEVONthink Pro.
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DOCUMENTS

General 240

Plain and Rich Texts 244

HTML Pages, Web pages, Feeds 251

Sheets 257

Images and Movies 260

PDFs 264

Office Documents, Email, and others 270

All documents are displayed in DEVONthink Pro in views. Each view features its

own tools, contextual menu commands, and hidden keyboard shortcuts, as explained

in this chapter.
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GENERAL

All documents are displayed within DEVONthink Pro in views (not to confuse with

the different layouts in main windows, also called views. Each view (for example,

a text or PDF view), has its own tools, contextual menu commands, and hidden

keyboard shortcuts. Some views, like the text view, also allow you to edit the

document, while others like the PDF view, only display the selected document.

Currently, DEVONthink Pro features the following view types:

•  Plain and RichText

•  Office and other documents

•  HTML pages, Web pages, Feeds

•  Sheets

•  Images

•  PDFs



DEVONthink PRO 2.3.3 Documentation, page 241

NAVIGATION BAR

At the top of the view/edit pane DEVONthink Pro shows a navigation bar that

gives you access to some additional tools that deal directly with the contents of the

document. Which tools are available depends on the type of the document.

•  Previous/Next: Navigates back and forth through visited pages in a web

view.

•  Reload: Reloads the displayed page in a web view.

•  URL: Shows the URL associated with the displayed item. Click to launch

the URL in its default application. Hold the Option or the Command key

to open the URL in a new tab if possible. Holding Shift-Option or Shift-

Command opens the URL in a new tab and selects it.

•  Lock: Locks or unlocks the item.

•  Previous/Next Page: Navigates back and forth the pages of the displayed

document.

•  Word Count: Shows the number of paragraphs, words, and characters of

the displayed text.

•  Page Count: Shows the number of pages as well as the page number

of the currently displayed page. Click the page number in PDF or

PostScript documents and enter a page number to direct jump to that

page.
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•  Text/Preview: Switches between text-only view and preview if available.

The text-only view can be useful to select text in items that are displayed

using QuickLook or to view or edit the source code of an HTML

document.

•  Show/Hide Sidebar: Shows or hides the PDF sidebar containing

thumbnails of all pages.

•  Concordance: Opens the Concordance drawer.

•  See Also/Classify: Opens the See also & Classify drawer.

•  Topics: Shows a list of the most important words of the document as a

pop-up menu. Select any word from the menu to show documents also

dealing with this topic.

TAG BAR

The Tag bar, which can be shown or hidden, shows all tags associated with the

document. Click the tag bar and type to add tags, select a tag and press the Delete or

Backspace key to remove it. See also p. 392ff

When you type the name of a tag, DEVONthink Pro offers automatic completion.

Choose the right option with the mouse or the arrow keys and press Return or Enter

to accept it. Press Escape to use whatever you entered. Auto-completion prefers

ordinary tags (tags represented in the Tags group) over groups used as tags. Press

Tab to enter another tag.
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Note: The Tag bar is also visible for multiple selected documents when

all documents have the same tags attached. Use it to change the tags for

multiple documents.

TOOLBAR

DEVONthink Pro can display documents in separate windows when you double-click

the documents in a main window. Depending on the type of document, the tools in

the toolbar can change. Even though not all tools are always present in the default

toolbar for a particular view, you can easily add them by choosing View > Customize

Toolbar.

SHORTCUTS & MODIFIER KEYS

Besides shortcuts special to one view or another, many shortcuts work the same for

all views (and the same as in most other Mac OS X applications).

•  Control-Tab: Jumps between between panes of split views.

•  Home/End: Go to beginning of, or end of, any view.

•  Page Up/Down: Scroll one page up and down in any view.

•  Space/Shift-Space: Scroll one page up and down in displayed web pages

or main views. Works also in images and PDF documents.
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PLAIN AND RICH TEXTS

The view for plain and rich text documents is basically a built-in incarnation of

TextEdit, and you use it in a very similar fashion. Of course, text views support the

Edit > Find >  commands and all options of the Format  menu.



DEVONthink PRO 2.3.3 Documentation, page 245

THE RULER

For rich text documents, DEVONthink Pro supports the standard ruler that the

TextEdit engine of Mac OS X provides. Show or hide it with Format > Ruler > Show/

Hide Ruler.

The ruler contains the following elements:

•  Tab Stops: Place tab stops with the mouse, then remove them by

dragging them away from the ruler. Drag new tab stops (left aligned,

centered, right aligned, or decimal aligned) from the repository at the

right side to their desired positions. Move the left and right margins as

well as the indent with the mouse.

•  Styles: Select a predefined text style from the pop-up menu. To define

your own styles, choose Other to open the Mac OS X standard style

editor. In the style editor, navigate back and forth through the styles

of your document or the stored favorite styles (use the radio buttons

to switch between document and favorite styles). Click Select to select

all occurences of text with the displayed style in the document, click

Apply to apply the style to selected text or click Done to leave the style

editor. To add a style from your document to the favorites, click Add To

Favorites; to remove a favorite, click Remove From Favorites.
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•  Alignment: Align the current paragraph (the one with the insertion

caret inside) left, centered, justified, or right by clicking the according

alignment buttons in the ruler.

•  Spacing: Choose the desired spacing for the current paragraph from the

Spacing pop-up menu. Choose Other to enter other values than the ones

shown.

•  Lists: Make the current paragraph a list item (indented and with a bullet

or numbered) by choosing the desired list style from the Lists pop-up

menu. Choose Other to define your own list style.

Note: A nice feature is a built-in 'mini outliner.' On any blank line in

a rich text document (doesn't work for plain texts), type Option-Tab to

create a bullet-point (Mac OS X shows dashes instead of bullets). Press

Return for the next item, and so on. Additional Option-Tabs will increase

the indentation; a Return on a blank list line will decrease it. It uses

hyphens to indicate list items by default. Right-click to choose all kinds of

list styles.
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ATTACHMENTS

You can attach other documents to rich text documents simply by dragging them into

the text. Technically the rich text document becomes a .rtfd package and the dragged

file is saved as part of the package.

•  Use the contextual menu to show an attachment's content in a Quick

Look preview.

•  Double-click attachments to edit them externally.

Note: Editing attachments requires OS X 10.7 Lion or higher. Also, you

cannot attach files to plain text documents. You need to convert them to

rich text before you can attach other files.

SHORTCUTS & MODIFIER KEYS

•  Shift-Left/Right/Up/Down Arrow: Extend current selection.

•  Command drag-and-drop: Copy selected text.

•  Command-Option drag-and-drop: Insert a cross-link for groups or

documents dropped into a rich text document. Dragging with Command

and Option pressed files or folders from the file system to a rich text

document creates links to them.
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•  Command-Click: Open clicked URL in the default application (for

example, your default Internet browser) or in a new tab, depending on

your preferences.

•  Command-Shift-Click: Opens a link in a new tab and selects it (only if

tabbed browsing is switched on).

•  Command-Option-Click (1): Places the insertion caret inside the text of a

clickable link.

•  Command-Option-Click (2): Opens a clicked cross-link or Wiki-style link

in a separate document window.

•  Option-Drag: Selects text using a rectangular selection ribbon.

•  Option-Click (1): List all contents containing the clicked word in the See

Also drawer (identical to the See [selected text] in the contextual menu).

•  Option-Click (2): Add clicked URL to the Download Manager.

TOOLBAR

The document windows toolbar is very similar to the one in DEVONthink Pro main

windows, yet can be configured separately.

CONTEXTUAL MENU

•  Search with Spotlight: Searches for the selected text using Spotlight.
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•  Search in Google: Opens you default browser and searches for the

selected text in Google.

•  Quick Look Attachment: Opens a Quick Look panel for the selected

attached link or file (OS X 10.7 Lion or higher).

•  Copy Link: Copies a link as such to the Clipboard (only available for

selected links).

•  Edit Link: Edits the destination of a selected link.

•  Highlight >: Highlights the selected piece of text with the color you select

in the sub-menu.

•  Insert >: Inserts special elements into the text (such as a page break, the

current date or a bullet). Same as the Insert sub-menu of the Edit menu.

•  Insert Link To >: Inserts a link to an item you select in the sub-menu

(only available when no text is selected).

•  Look Up in Dictionary: Looks the selected text up in Mac OS X's

Dictionary.

•  Link To >: Makes the selected piece of text a cross-link and links it

directly to the group or document you select in the sub-menu.

•  Make Link: Makes the selected piece of text a WikiLink. The destination

of the WikiLink is a document with the same name as the selected text.

If no document with that name exists, clicking the created link creates it

using the template you have set in the Editing Preferences.
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•  Open Link: Opens the selected link in the default browser or application

(only available for a selected link).

•  Open Link in New Tab: Opens the selected link in a new tab.

•  Open Alias: Follows a selected link (only available for a selected Wiki-

style link resolved by an alias). Aliases are defined for each item

separately in the Info panel.

•  Remove Link: Makes a selected link simple text.

•  Search selected phrase: Searches for the selected text as a phrase.

•  Set Title As: Renames the document according to the selected piece of

text (needs to be less than 256 characters).

•  Split Document: Splits the document at the current insertion mark

position.

•  Add tag [word]: Tags the document with the selected word (only available

if the word is not already a tag of the document).

•  See [word]: Opens a drawer with documents related to the selected word.

•  See Related Text: Opens a drawer with documents related to the selected

text passage. Only available when more than one word is selected.
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HTML PAGES, WEB PAGES, FEEDS

HTML views display web pages stored in the database or downloaded 'live' from the

Internet, by using the Safari web browser engine of Mac OS X. DEVONthink Pro

displays also RSS news feeds like regular web pages. Pages are rendered similar to

Safari or any other WebKit-based browser such as DEVONagent Pro.
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News feeds item (RSS, RDF, Atom) are created in a database automatically for all

items downloaded by a feed. Feed items are saved either as HTML or as a bookmark

if the item has no content. An internal CSS stylesheet is used to style the output.

You can change it in the Preferences. The icon of an unread feed item in list and split

views is shown with a blue dot instead of a regular icon.

HTML views support the Edit > Find >  commands as well as the See Also & Classify

drawer. To edit the source code of an HTML document, use the navgiation bar to

switch from preview to plain text mode.

In editable web archives you can use, e.g., the highlighting commands from the

Format menu  or add the Color tool to the toolbar to change text colors.

SHORTCUTS & MODIFIER KEYS

•  Command-Click: Open clicked URL in the default application (for

example, your default Internet browser) or in a new tab, depending on

your preferences. Equals clicking a link with the third mouse button.

•  Command-Shift-Click: Opens a link in a new tab and selects it (only if

tabbed browsing is switched on).

•  Option-Click: Add clicked URL to the Download Manager panel.

•  Backspace/Shift-Backspace: Go backwards and forwards through the

visited web pages.
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TOOLBAR

Separate HTML or web browser windows feature a default toolbar set that is more

web-like than text document windows. As with text document windows, this toolbar

can be individually configured. Naturally, the DEVONthink Pro offers only tools for

HTML views that are useful in a web environment.

CONTEXTUAL MENU

•  Reload: Reloads the page from the Internet.

•  Open ... in New Tab: Opens selected element in a new tab.

•  Open Link in Browser: Opens a link in your default web browser.

•  Open Link in DEVONagent: Opens a link in DEVONagent Pro.

•  Open Link in PhotoStickies: Opens a link in PhotoStickies.

•  Capture Link: Adds the selected link to either the current group or to the

inbox.

•  Capture Page: Adds the current page as HTML document to either the

current group or to the inbox.

•  Capture Web Archive: Adds the current page as web archive to either the

current group or to the inbox.

•  Capture Note: Adds the selected text as a new note to either the current

group or to the inbox.
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•  Capture PDF: Adds the current page as PDF to either the current group

or to the inbox.

•  Capture Frame Address: Adds the URL of the current frame to either the

current group or to the inbox.

•  Capture Page Address: Adds the URL of the current page to either the

current group or to the inbox.

•  Add Page to Downloads: Adds the URL of the current page to the

Download Manager.

•  Copy Frame Address: Copies the frame URL to the Clipboard.

•  Copy Image: Copies the image to the Clipboard.

•  Copy Image Address: Copies the URL of an image to the Clipboard.

•  Copy Page Address: Copies the page URL to the Clipboard.

•  Open Image in PhotoStickies: Opens the image in PhotoStickies.

•  Copy: Copies selected text to the Clipboard.

•  Highlight: Highlights the selection in a web archive like with a

felt marker. Using this command on a selection again removes the

highlighting.

•  Set Title As: Sets the name of the document to the selected piece of text

(needs to be less than 256 characters).

•  Search Selected Phrase: Searches for the selected text as a phrase.

•  Add tag [word]: Tags the document with the selected word (only available

if the word is not already a tag of the document).
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•  See [word]: Opens a drawer with documents related to the selected word.

•  See Related Text: Opens a drawer with documents related to the selected

text passage. Only available when more than one word is selected.

•  Update Bookmark: Updates the URL of this document to the current one,

e.g. after navigating to a sub-page.

•  Back / Forward: Navigates back and forth the previously visited pages.

•  Add Link to Downloads: Adds a link to the Download Manager panel.

•  Add Page to Downloads: Adds the page address to the Download

Manager panel.

•  Capture Frame: Captures the HTML code of the frame and saves it to

either the current group or to the inbox.

•  Capture Image: Captures the selected image and saves it to either the

current group or to the inbox.

•  Capture Link: Captures the link and saves it to either the current group

or to the inbox.

•  Capture Note: Captures selected text to either the current group or to the

inbox.

•  Capture Page: Captures the HTML code of the page to either the current

group or to the inbox.

•  Capture Webarchive: Captures the page as a web archive file including

all necessary images for offline viewing and archival to either the current

group or to the inbox.
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•  Update Webarchive: Updates the contents of a web archive file with the

live version on the Internet (only available in web archives).

For PDF pages, more options become available:

•  Open with Preview: Opens the PDF in Preview.

•  Automatically Resize: When checked, the zoom factor adjusts to the width

resp. height of the browser window.

•  Zoom Out, Zoom In, Actual Size: Zooms in or out of the document, or

displays it in its actual size.

•  Single Page, ...: Displays the PDF as single or double pages and either

page by page (use the Next Page and Previous Page to skim through the

pages forward and backwards) or continously.

•  Next Page, Previous Page: Skims through the pages forward or

backwards.
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SHEETS

Sheets contain text in a table and can be used to store any kind of tabular data from

an address book to part numbers and descriptions.



DEVONthink PRO 2.3.3 Documentation, page 258

Use sheets like any other document. Add new rows using Data > Sheets > Add

Record, delete rows by selecting them and using Edit > Delete. Alternatively use the

contextual menu. Click a cell to edit its content, press the Escape key to stop editing,

and use the Tab or Return keys to navigate from cell to cell.

Sheets support the Edit > Find >  commands but currently no formattings. You can,

however, enter line breaks by typing Option-Return.

Note: Due to limitation in Mac OS X's Cocoa memory management,

sheets are currently limited to 32,767 records.

TOOLBAR

Document windows opened for a sheet or record also feature a tool set specialized

for working with sheets and records. Use tools like New Record, New Column, or

Columns to create new records for the sheet, add a column, or modify the columns in

any way you like.

SHORTCUTS & MODIFIER KEYS

•  Return: Moves one cell down for editing.

•  Shift-Return: Moves one cell up for editing.

•  Tab: Moves one cell to the right for editing.
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•  Shift-Tab: Moves one cell to the left for editing.

•  Arrow keys: Moves the editing selection.

•  Escape: Stops editing.

CONTEXTUAL MENU

The contextual menu for sheets basically lists the same commands that are also

available through the main menu.

•  New Record: Creates a new record in the sheet.

•  New Column: Creates a new column in the sheet.

•  Edit Columns: Opens the columns editor where you can create new

columns, delete them, rearrange, and rename them.

•  Cut/Copy/Paste: Cuts, copies, or pastes whole records in a sheet. Use

them, for example, to duplicate records.

•  Delete Records/Columns: Deletes the selected record(s) or column(s).
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IMAGES AND MOVIES

DEVONthink Pro uses Mac OS X's core technologies to display images and movies

and therefore makes a very nice image and movie viewer.

You can scroll larger images using the scroll bars, the arrow keys as well as the Space

and Shift-Space keys.
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EDIT PANEL

Double-clicking an imported image opens an edit panel that allows you to do some

basic image editing. The modified image is saved as losslessly encoded TIFF file.

•  Change the exposure.

•  Set white and black point.

•  Change gamma, saturation, contrast, and brightness.

•  Adjust sharpness.

•  Adjust sepia effect.

In addition it offers a number of predefined image effects and lists available

metadata contained in the image file itself.

Images (and PDF pages) can also be rotated using the Edit > Rotate  menu

commands, the toolbar, or the contextual menu.

TOOLBAR

For images and movies, DEVONthink Pro provides a set of tools that allows you to

zoom the picture to whatever zoom factor you like, or to view the image in full screen

mode. Use Open Externally to open the image in an external editor. Movies appear

with the standard QuickTime controller.
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Note: Editing an image stored internally in the database with an

external editor does not modify the image data stored in DEVONthink

Pro.

CONTEXTUAL MENU

•  Play/Stop: Starts playing the movie or stops playing it.

•  Undo/Redo: Revokes the last action or redoes it.

•  Cut/Copy/Paste: Cuts, copies, or pastes the selected movie.

•  Actual Size: Zooms the image so that it appears as its real size,

calculated from the actual pixels and the resolution information

contained in the image.

•  All Pixels: Zooms the image so that one image pixel equals one pixel on

the screen.

•  Zoom In/Out: Zooms in and out of the picture.

•  Zoom To Fit: Zooms the image so that it completely fits into the view/edit

pane or the document window.

•  Zoom To Width: Zooms the image so that it appears exactly as wide as

the view/edit pane or the document window.

•  Select/Deselect All: Selects or deselects the movie.

•  Set As Thumbnail: Makes the current frame the thumbnail of the movie.

Only available when the movie is not playing.
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•  Rotate Left/Right: Rotate the image left and right. It is saved in the

lossless TIFF format.
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PDFS

PDF views are similar to image views, but come with some specialized options for

viewing PDF documents. Also, PDF views support the Edit > Find  commands.
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SIDEBAR

The sidebar shows thumbnails of a pages of the PDF document. Click a thumbnail

select that page and scroll to it; hold the Shift or Command keys to select multiple

pages. Reorder pages by dragging a page to the new position and use Edit > Delete

Selected Page(s)  to remove the selected page(s). Use Edit > Rotate  to rotate PDF

pages. Contextual menu commands are available, too, e.g. copy and paste.

You show and hide the PDF sidebar using the Show/Hide Sidebar button in the

PDF''s navigation bar.

Note: Only real PDF documents are editable, converted (e.g. EPS,

PostScript, or Adobe Illustrator files), Skim documents (PDF packages),

and PDF previews generated by QuickLook are not editable.

ANNOTATING PDFS

You can use DEVONthink Pro to annotate PDF documents. To add or edit

annotations, open the PDF document in a separate window (e.g. by double-clicking it).

In the toolbar you will find all necessary tools:

•  Tool: Switch between moving, selecting text, and selecting elements such

as annotation post-it notes.
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•  Annotate: Select your annotation tool of choice: Ellipsis, rectangle, post-it

note, text rectangle, and link.
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To add an annotation, select your annotation tool, then 'draw' it into the page.

Double-click the annotation to open the annotation panel which lets you fine-tune

your annotation. Depending on the type of annotation you can change its attributes.

Change the text color in the annotation panel; use the standard Fonts  panel to

change the font of a selected text annotation.

To move or delete an annotation, select it with the 'select elements' tool. Position it

with the mouse. Press the Delete key or use Edit > Delete  to remove it.

SHORTCUTS & MODIFIER KEYS

In addition to the general shortcuts for paging up and down in a PDF document

mentioned in the General section, PDF views also offers unique shortcuts.

•  Command-click: Opens a link in a new tab and selects it (only if tabbed

browsing is switched on).

•  Command-drag: Scrolls the visible area with the mouse (Mac OS X 10.4

and later only).

TOOLBAR

The Annotate and Tool toolbar items let you quickly annotate PDFs.
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CONTEXTUAL MENU

•  Actual Size: Zooms the image so that it appears as its real size,

calculated from the actual pixels and the resolution information

contained in the PDF.

•  Zoom In/Out: Zooms in and out of the PDF.

•  Auto Size: Resizes the PDF automatically so that it always fits the size of

the view/edit pane or the document window.

•  Single Page/Facing Pages: Displays the PDF either as one page or as

facing pages (like in a magazine).

•  Continous: When checked, DEVONthink Pro displays the pages of a

mutli-page PDF like one long roll of paper. If unchecked, it displays the

PDF page by page.

•  Previous/Next Page: Jumps to the previous or next page.

•  Highlight: Highlights the selection like with a felt marker. Using this

command on a selection again removes the highlighting.

•  Set Title As: Renames the document according to the selected piece of

text.

•  Search selected phrase: Searches for the selected text as a phrase.

•  Add tag [word]: Tags the document with the selected word (only available

if the word is not already a tag of the document).

•  See [word]: Opens a drawer with documents related to the selected word.
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•  See Related Text: Opens a drawer with documents related to the selected

text passage. Only available when more than one word is selected.

•  Rotate Left/Right: Rotate the page left and right.

•  Copy Page Link: Copies a URL to the clipboard pointing directly to the

shown page of the document.

•  Open Link: Opens the selected link.

•  Open Link in New Tab: Opens the selected link in a new tab.

•  Delete Annotation: Deletes the selected annotations.

The PDF sidebar also offers commands for working with single pages:

•  Undo/Redo: Un-does or re-does the last action.

•  Cut/Copy/Paste: Cuts, copies, or pastes a PDF page.

•  Copy Page Link: Copies a URL that points directly to the selected page.

•  Split Document: Splits the PDF at the selection into two documents.

•  Insert Blank Page: Insers a blank page into the PDF.

•  Delete Selected Page: Deletes the selected page.

•  Rotate Left/Right: Rotate a selected page left and right.

•  Select/Deselect All: Selects or deselects all pages.

•  Copy Page Link: Copies a URL to the clipboard pointing not only to the

document itself but the actual page.
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OFFICE DOCUMENTS, EMAIL, AND OTHERS

Documents that DEVONthink Pro cannot render natively are displayed using

QuickLook. But while you have to press the Space bar in the Finder to open a

QuickLook head-up display, DEVONthink Pro previews these documents directly in

the view/edit pane like any other document format.
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Among others, the following document types are shown though QuickLook:

•  iWork documents (Pages, Numbers, Keynote)

•  Microsoft Office and OpenOffice documents

•  Mellel files (version 2.6 and higher)

•  ...

For some document formats the preview allows you to select and copy text, for other

formats it doesn't. If DEVONthink Pro is able to interpret and convert the document

format you can use the Text View/Preview button in the navigation bar to switch to a

text view that allows you to select, copy, and drag text.

Note: The availability and, if available, quality of the preview as well

as the possibility to select and copy text depends solely on the source

application. Developers can embedded a QuickLook-compatible preview

diectly into the files or they can write a preview plugin and add it to

either the source application or have you install it separately in ~/

Library/QuickLook. If a document that you want to view in DEVONthink

Pro does not show a QuickLook preview, please contact the maker of the

source application and ask them to add QuickLook support.

http://www.apple.com/iwork/
http://www.microsoft.com/mac/
http://www.openoffice.org
http://www.mellel.com
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TOOLBAR

For document previews based on QuickLook, DEVONthink Pro offers a number of

toolbar items, e.g. for accessing the Scripts menu,  moving back and forth through the

other documents contained in the same group or opening the document in its source

application. Also you can switch to full screen mode.

Use Data > Open  to open the document in a separate document window instead of in

its source application.
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DRAWERS AND SHEETS

See Also & Classify 274

Concordance 279

Smart Group Editor 282

DEVONthink Pro uses drawers to display the results of the Classify and See Also

functions that help you file items or find relationships between items in the database.

Drawers also show concordance lists of all words in a document. The Smart Group

Editor appears in a sheet and allows you to create or modify a smart group (a.k.a.

'saved search').
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SEE ALSO & CLASSIFY

The See Also & Classify drawer appears when you select exactly one document in a

main window and then click the AI button (a small sorcerer's hat) in the navigation

bar at the top of the view/edit pane. This button is only available in views that have a

view/edit pane.
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It is also shown when you use the contextual menu on selected text to show similar

documents, e.g. See [word]' or See related text, or when you select a topic from the

topics pop-up menu in the document's navigation bar.

To close the drawer, click the red close button.

When activated, DEVONthink Pro analyzes the contents of the selected document

and compares it to all the data stored in the database. From this 'knowledge', it gives

you one or both of the following lists.

CLASSIFY

The Classify function helps you file documents by making suggesions based on where

you have filed other documents. The classify list shows into which groups the selected

document would fit best. It also lists the location of the group and a graphical score

that shows how sure DEVONthink Pro is about its decision. The tooltip for any entry

in the list shows the full title and location for it. This part is only visible when the

sorcerer's hat button is used.
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To move the document to one of the suggested groups, select the group and click Move

To. Alternatively double-click the group. For your convenience, DEVONthink Pro

preselects one or multiple groups if it very sure. Drag the group into any item list to

move it, e.g. into a main window. Use the Shift and Command keys to select more

than one target. This generates replicants.

Note: Any replicants of the document you are moving are deleted.

The document is only placed in the new locations which allows you to

precisely classify the document again without having to manually clean

up the old replicants.

SEE ALSO

See Also lists similar documents and so help you find information dealing very likely

with the same subject than a given one. The see-also list shows documents that

are similar to the selected one or to the selected text or topic (when you have used

the contextual menu items or the document's topics pop-up menu). Similar to the

classify list, this list shows the path to the document and a graphical score of how

sure DEVONthink Pro is about its decision. The tooltip for any entry in the list shows

the full title and location for it.
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To display a document in the drawer, select it. For your convenience, DEVONthink

Pro always lists the original document at the top of the list, so that you can easily go

back to the original document. Double-click a document in the drawer to open it in a

separate window; drag it into an item list to move it.

CONTEXTUAL MENU

Use the contextual menu on groups in the See Also & Classify drawer for more

commands.

•  Open: Opens the selected item in a separate main window.

•  Open in Tabs: Opens the selected item in a new tab.

•  Open With: Opens the selected item in an external application.

•  Launch URL: Opens the URL in the selected item's URL field.

•  Copy URL: Copies the Internet location stored in the URL field of the

selected item to the clipboard.

•  Reveal: Shows and selects the selected item.

•  Show in Finder: Shows the selected item in the Finder.

•  Move To: Moves the selected item to the group you select from the sub-

menu.

•  Replicate To: Replicates the selected item to the group you select from

the sub-menu.
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•  Duplicate To: Duplicates the selected item to the group you select from

the sub-menu.

•  Label: Changes the label of the selected item.

•  Mark: Changes the check, lock, and read status of the selected item.

•  Move All Instances To Trash: Moves all instances of the selected item to

the trash, including all replicants (if any).

•  Group: Creates a new group containing the selected item(s).
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CONCORDANCE

The Concordance drawer appears when you click the Concordance button in

the document's navigation bar. It lists all words in that document similar to the

Concordance window. Select one or multiple words (with the Shift and Command

keys pressed) in the drawer to highlight their occurences in the document.
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You can sort the list in the drawer by clicking the title of the column you want to

use for sorting. Click the column title again to reverse the sorting order. If you

have changed the contents of the document, click the Update button to update the

concordance list. Double-click any word in the drawer to open the Search window

with this word already filled in.
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To close the drawer, click the red close button.
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SMART GROUP EDITOR

The Smart Group Editor appears as a sheet when you either create a new smart

group using Data > New > Smart Group,  when you right-click a smart group and

choose Edit from the contextual menu, or when you double-click a smart group.

In this sheet you set up a new smart group or edit an existing one:

•  Search in: Select where you want this smart group to search.

•  List of search predicates: Build your list of search criteria (in search

speak: 'predicates') here. See below.

•  Ignore Diacritics: Check this to treat letters with diacritics, e.g. umlauts

or accented characters, the same as their regular counterparts.
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•  Fuzzy: Check this to search 'unsharp', e.g. ignoring simple typos so that

'Merkel' and 'Merkle' are both found.

The list of predicates consists of a list of blocks, each one beginning with 'All' or 'Any',

defining whether all (Boolean AND) or any (Boolean OR) of the contained predicates

need to be true for the document to be returned as a result. Predicates themselves

consist of the field to search (like: 'Content' or 'Tag'), the condition and the data that

needs to be matched.

Note: In most predicates you can use wildcards, Boolean operators,

phrases, and parenthesis, too.See also p. 417ff

Use the + and - buttons to add more predicates to your smart group or to delete them.

Hold the Option modifier key and click a ... button to create a 'compound predicate',

also called 'branch'. Predicates can be in/outdented and rearranged via drag-and-

drop.

By adding more lines to a search and choosing between 'All' and 'Any' you graphically

create a nested Boolean query with ANDs, ORs, and parenthesis.
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PREDEFINED SMART GROUPS

When you create a new database, DEVONthink Pro adds a number of predefined

smart groups for your convenience:

•  Duplicates: Lists all duplicates.

•  All Images: Shows all images.

•  All PDF Documents: Shows all PDF documents.

•  To Do: Shows all documents with visible but unchecked state.

The following smart groups are by default added to the sidebar:

•  Today: Shows all documents added or modified today.

•  Unread: Shows all documents marked as unread.

•  Yesterday: Shows all documents added yesterday.

Note: Smart groups also filtering for date ranges are shown with a clock

icon.
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PREFERENCES

General 286

Editing 291

Import 295

Sorter 298

Media 300

Colors 302

Web 303

RSS 307

Backup 309

Update 311

The Preferences window, which you open by selecting Preferences in the application

menu,  is the place to go to change all global settings for DEVONthink Pro. In

addition to these settings, databases also have private settings in their Database

Properties window that you open using File > Database Properties.
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GENERAL

Use the General tab to set the general settings for the user interface.
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APPEARANCE

These options define some parts of the visual appearance.

•  Alternating row colors in views: Check to color every second row in item

lists differently.

•  Display number of items inside groups: Check to show the number

of unread and read documents contained in a group in parenthesis

after group names. If this option is unchecked, news feed still show the

number of unread items.

•  Highlight Internet links in views: Check to show link documents in blue

and underlined in item lists.

•  Mark duplicates and replicants in color: Check to highlight duplicates in

blue and replicants in red in most views. When unchecked duplicates and

replicants are marked with file property icons.

•  Colorize icons with label: Check to colorize the icon or thumbnail of

items with the label color (like in Mac OS 9). When unchecked, label are

displayed in the Finder's style.
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INTERFACE

These options define some parts of how you interact with the user interface.

•  Hide 'Groups & Tags' panel when inactive: Check to hide the Groups

panel in applications other than DEVONthink Pro.

•  Open contents after using 'New with Clipboard': Check to let

DEVONthink Pro switch to newly added items after adding them using

Data > New > With Clipboard  or via the Dock menu.

•  Always open groups in a new window: When checked, double-click a

group to open it in a separate window. When unchecked, double-click it to

make the group the new root of the current window. Use Go > Top Group

and Go > Enclosing Group  to go up the groups hierarchy again.

•  Retain view: When the above option, Always open groups in a new

window, is unchecked, this option keeps the actual view settings

when you navigate the group structure instead of applying the group's

individual settings.

•  Enable tabbed browsing: When checked, click with Command pressed a

link in web, PDF or text views to open it in a new tab. When unchecked

or the Command modifier key isn't pressed documents are opened in the

same view, the default application or in new windows.
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STARTUP

Choose whether you would like DEVONthink Pro to open a fresh main window

on startup, open all windows that were open when you quit DEVONthink Pro the

last time, or do nothing. If Open all windows that were open on quit is selected,

DEVONthink Pro also opens all databases that were open on quit.

Note: Even when you tell DEVONthink Pro to not open a window

on startup, it will always open at least one window when you open a

database.

FONTS

Use List Views Font and Column View Font to set the font DEVONthink Pro uses for

displaying item lists in list and column views.

DEFAULT DATABASE

You can set a default database that is automatically opened when you start

DEVONthink Pro. Use the Select button to select any DEVONthink Pro database or

edit the path manually.
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Alternatively, open your favorite database, choose File > Database Properties  and

check Use as default database.
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EDITING

The Editing tab defines all options that fine-tune DEVONthink Pro's text editing

behavior, from the ruler units to WikiLink templates and summarization options.
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GENERAL

•  General: Check Check spelling as you type to have DEVONthink Pro spell

check everything you write all the time. Check Display PDF attachment

of rich texts to show PDFs attached to RTF documents. To use curly

quotes instead of simple ones, check Smart quotes, and to use smart copy/

paste check Smart copy/paste. Check Data detectors to use data detectors

(Mac OS X 10.6 or later) in text and PDF views that detect e.g. addresses

and phone numbers and let you act on them. FInally, Text Replacement

(only available on Mac OS X 10.6 or later) let's you use the system-wide

text replacement by default when editing text.

•  Ruler Units: Select your personal preference for ruler units here, such as

centimeters or inches, or points or picas.

•  Plain/Rich Text Font: Select your preferred fonts for new plain or rich

text documents. Note: By their nature, plain text documents are always

displayed in the font selected here, whereas rich text documents can be

styled any way the author wants.

FULL SCREEN

•  Full Screen: Select your preferred font for reading and editing plain

text files in full screen. By their nature, rich text documents are always

displayed using their own styles also in full screen mode.
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•  Background: Choose a background color for the full screen mode. This

setting only affects the background of plain text files, and the border

to the left and right of rich text documents. By their nature, rich text

documents bring their own background color, and so don't use the color

you set here.

•  Width: Choose a width for displaying documents in full screen mode as a

percentage of the screen width. Use this setting if the presentation in full

screen is too wide for you on a large screen.

WIKILINKS

•  WikiLinks: Check Automatic if you want to make every word that is also

the name of another document or group in the database automatically

link to the document of the same name (WikiLink). This mechanism can

be restricted to not link to groups, as well as to only accept meshed words

(for example, words with a capital letter in the middle like 'QuickTime';

this is the classic WikiLink method to distinguish between regular words

and links). Check Open new documents in separate windows to open a

new window when you click a WikiLink instead of simply switching to

the linked document.

•  Template: Enter a template text here. This will be used to create a new

document when you make text a link that does not point to an existing



DEVONthink PRO 2.3.3 Documentation, page 294

document yet. You can use various placeholders to automatically insert

text, the current date and time, for example.

SUMMARIZATION

Select whether you wish DEVONthink Pro to calculate summaries from sentences or

from whole paragraphs.
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IMPORT

Here you decide which file types DEVONthink Pro imports and how they will be

named in the database.
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FILES

These options define whether DEVONthink Pro imports files of a given type or not

when you import folders using File > Import  or via drag-and-drop.

•  <type>: Select all the file types DEVONthink Pro shall recognize when

importing folders. DEVONthink Pro always imports every file you import

manually.

•  Encoding: Choose the default encoding for plain text documents. Select

Automatic to let DEVONthink Pro choose the best encoding.

•  Other file types: Check to import files of a type unknown to DEVONthink

Pro. QuickLook and Spotlight are used to access and display the contents

of the file.

TITLES

Select how you want DEVONthink Pro to name imported documents; with file name

extensions, without file name extensions, or by using localized display names (for

example, on a German system the 'Applications' folder would appear as 'Programme').
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NEW NOTES

Check Select (and display) automatically to automatically select and display the last

note you have taken.

DESTINATION

Choose the default destination in which data coming in from bookmarklets,

DEVONagent Pro, news feeds, (external) scripts, and services is stored:

•  Select group: A group selector is shown that lets you choose the

destination. The group selector appears as a black panel floating over all

other windows. It does not bring DEVONthink Pro to the front. Use it to

select the group where you want to file the items and add tags.

•  Global inbox: The data is stored in the global inbox.

•  Inbox of current database: The data is stored in the inbox of the current,

frontmost database.
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SORTER

The Sorter preference allows you to assign a hotkey for capturing a selection into the

inbox of the Sorter as well as a hotkey for taking a new note, show the Sorter at login,

and start or quit the Sorter manually. See also p. 314ff
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AVAILABILITY, HOTKEYS

Check Start Sorter at login to start the Sorter immediately after you log in. Check

Visibility: Full to make the Sorter tab fully visible or uncheck it to make the tab fade

when the mouse pointer does not point at it.

To change the hotkeys for taking a new note or copying a selection, click the Click to

record shortcut button, then press the hotkey that you want to use. Press the Escape

key to cancel recording a new shortcut. When the Sorter is not running, this hot key

opens the Take Note  panel.

HIDER SORTER IN FULL SCREEN

This lists shows all fullscreen applications that Sorter is aware of. Add other

applications using the + button and check or uncheck apps to make Sorter hide when

this application is going to fullscreen mode.

Reset the full screen settings to make DEVONthink Pro 'forget' all remembered apps.

Click Start or Quit to start or quit the Sorter manually.
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MEDIA

In the media preferences you tell DEVONthink Pro how to handle multimledia

files, images, PDFs and other documents for which DEVONthink Pro can create

thumbnails.

The following options are available:

•  Movies: Check Create thumbnails if you want DEVONthink Pro to create

thumbnails for imported or indexed QuickTime movies. Movie documents
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without thumbnails will appear with a generic icon, while movies with

thumbnails show miniatures of their content. Check Play automatically

to play QuickTime movies automatically when you display them, and

check Loop if you want to play the clips in a loop. Choose a background

color for viewing movies.

•  Images: Check Create thumbnails if you want DEVONthink Pro to create

thumbnails for imported or indexed images. Choose a background for

viewing images using the standard Mac OS X color chooser.

•  PDF & PostScript documents: Check Create thumbnails if you want

DEVONthink Pro to create thumbnails for imported or indexed PDF and

PostScript files. Choose a background for viewing PDFs.

•  Create Thumbnails: Check Web Archives, Bookmarks, or Other files if you

want DEVONthink Pro to try to create thumbnails for these file types.
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COLORS

Here you can name and choose the seven label colors DEVONthink Pro uses to mark

documents and groups, as well as set seven colors you can use to highlight text.
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WEB

The web preferences resembles the settings of most web browsers. Use them to define

how DEVONthink Pro's displays web documents and 'live' web pages.
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WEB CONTENT

These settings define how DEVONthink Pro treats some special web contents:

•  Enable ...: Check these options to use installed third-party plug-ins, (such

as Flash or RealPlayer plug-ins), run Java applets or JavaScript scripts

contained in, or linked to, a web page.

•  Block ...: Check Block pop-up windows to block pop-up windows which

are often advertisements; check Only automatic JavaScript windows

to block only pop-up windows opened by JavaScript. Uncheck this

option if the web page you're visiting uses pop-up windows for actual

content (some web content management systems do this, for example).

Check Block zooming to keep web sites from automatically zooming

windows to full size, check Block advertisement to block common inline

advertisements provided by some search engines.

•  Zoom text only: Check to zoom only the text and uncheck to use Safari-4-

style zooming.
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IMAGES

These settings define how DEVONthink Pro displays graphics in web pages:

•  Display images when the page opens: Check this option to diplay web

pages with images. Just remember, when unchecked, you may miss some

information.

•  Animate images, Loop animation: Check these options to run web

graphics animations and to run animated graphics in a loop or not.

ACCEPT COOKIES

Cookies are little text files with information that web pages store on your computer

(for example, to recognize you as a returning customer). While most of them are

harmless, you may want to have a bit more control over what is being stored on your

hard disk.

•  Always: Accept all cookies.

•  Never: Don't accept any cookies.

•  Only from sites you navigate to: Accept cookies, but only from web sites

you navigate to (not from other sites, such as ad trackers).

•  Delete cookies on quit: Delete all stored cookies when you quit

DEVONthink Pro.
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FONTS

Set the fonts you want to use for displaying web pages, separately for variable-width

and fixed-width text.

STYLE SHEET

You can further control the way DEVONthink Pro displays web pages by applying a

CSS style sheet that changes the rendering on-the-fly.

Click Select and choose your style sheet to apply it to DEVONthink Pro's integrated

web browser. Note: This is for experts as it modifies how all web pages are displayed

and can lead to undesired effects.

TEXT ENCODING

Select your desired text encoding for displaying web pages. Automatic tries to choose

the best available encoding. If this does not work for you, choose a more appropriate

text encoding for your language group.
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RSS

DEVONthink Pro comes with built-in RSS capabilities that enable you to add RSS

feeds to your database and have DEVONthink Pro update them automatically.

RSS feeds are represented in DEVONthink Pro like smart groups that update

themselves with content from the Internet. You create them with Data > New > Feed 

and use them like any other group.

Use the RSS preferences to define how often DEVONthink Pro checks for new

articles, whether to skip duplicates when updating feeds, when to remove older

articles, and which CSS style sheet to use for displaying the articles. Unread or

locked articles are never automatically removed. Check Also unread articles to

remove also unread articles when cleaning up and check Convert categories to tags to

tag imported articles automatically if the feed contains categories.
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DEVONthink Pro comes with multiple styles for displaying feed articles; the

'Newspaper.css' style is optimized for readability and does not display images.

You can use your own RSS stylesheets by placing them into '~/Library/Application

Support/DEVONthink Pro 2/StyleSheets'.
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BACKUP

DEVONthink Pro comes with a simple built-in backup function that backs up the

database index on a regular bases. These options define how often DEVONthink Pro

will back up its index.

The backup automatically duplicates all important database files and moves the

duplicates into a folder(s) named 'Backup(.x)' within the DEVONthink Pro database

folder/package. Select if you want to have the backup created never, daily, weekly,

or monthly and how many copies of the index to keep. Of course, you can create a

backup at any time using Tools > Backup & Optimize.
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These options do NOT backup the whole database to a secure location but simply

make sure there's a copy of the index files in case the index get corrupted. To back up

your complete database use a third-party backup software or a backup solution such

as Time Machine.

DEVONthink Pro also comes with a number of handy scripts that export your

database as files and folders (and so independent from DEVONthink Pro). See also p.

335ff
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UPDATE

Change the settings in this tab to define when you want DEVONthink Pro to check

for new versions (never, on startup, daily, weekly, or monthly). DEVONthink Pro only

performs checks for updates when the computer is connected to the Internet.

Click Check Now to immediately check for a new version.

Note: Disable the check for new versions when your network connection

is unstable and you experience very long delays when opening

DEVONthink Pro. The Update pane is not available if you have

purchases DEVONthink Pro on the Mac App Store.
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WIDGETS, SORTER, BOOKMARKLETS

DEVONthink Jot 313

Sorter 314

Bookmarklets & Extensions 321

DEVONthink Pro comes with a handy Dashboard widget that allows you to jot

down notes and store them in your database. The Sorter is a separate panel docked

to the border of your screen that lets you add data to your databases even when

DEVONthink Pro is not runnning. Bookmarklets make adding interesting web pages

from Safari or DEVONagent Pro to DEVONthink Pro as easy as pressing a button.
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DEVONTHINK JOT

DEVONthink Jot allows you to take notes and send these to DEVONthink Pro's

default destination right from the Dashboard.

The front of the widget is where you can type your note's message. Click into the

writing area to make the insertion caret appear. Enter your tags below the note

taking area, if needed. Click the Take Note button to save the note to your database.

You can also flip the widget by clicking the i button that appears when you move the

mouse into the lower left corner of the widget. The back of the widget lets you choose

your preferred font. This preference is also saved and will be used whenever you open

the widget again. Click Done to flip the widget back to the front.
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SORTER

The Sorter is a helper application that lets you add files or selected text or images

to your databases even when DEVONthink Pro is not open. It shows as a little tab

attached to the left, bottom, or right border of the screen that serves as a drop target

for files and clippings.
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Like a real sorter in your post office, the Sorter consists of multiple (drop) boxes. The

first box is always the global inbox, all other boxes you can connect to any group in

any of your databases. When you drop files or clippings onto a box, the Sorter files it

in the connected group. Should the database containing the connected group not be

available, e.g., because DEVONthink Pro is not open, the Sorter stores the dropped

data until the database is opened and then flushes the contents of the box.

In addition you can use the Sorter to quickly add a note to DEVONthink Pro even

when it is not open.

POSITIONING THE PANEL

To position the Sorter panel, drag the tab to any position along the left, bottom, or

right borders of any connect screen except for the border where the Dock is located

(even when it is hidden; this only applies to the screen that has the Dock). To open

the panel, click its tab; to close it, click the tab again. Resize the Sorter panel with the

resize gadget in the lower left or lower right corner, depending on whether the Sorter

is attached to the left or right side of the screen. The size of the boxes stays the same,

enlarging or reducing the panel size adds more boxes or hides them.

Alternatively you can show the Sorter with a list instead of square boxes. Use the 

and  icons at the bottom to switch between the two. You can set different sizes for

both modes.
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CONNECTING BOXES

To connect a box to a group, open the database of choice and drag the group, e.g. from

the item list of a main window, to an empty box in the Sorter. The box is labeled with

the group's name, the group's icon is shown as a ghost image on the background of

the box, and its tooltip (that appears when you point at it with the mouse for more

than one second) shows the name of the database containing the database as well as

its path.

Drag a box by its title to move it to a new position in the Sorter's box grid; move it out

of the Sorter panel to remove its connection.

Alternatively, use the contextual menu (opens when you right-click or click with

Control held) to open a window for the connected group in DEVONthink Pro or to

remove the connection. Double-click a box to open the connected box in DEVONthink

Pro.

USING THE PANEL

To add items to a Sorter box, simply drag the file or clipping to the Sorter's tab. The

panel extends automatically and you can drop the item on the box that you want to

use.
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Dragging items to the Sorter copies them. Command-drag to move the item,

Command-Option-drag to add only a reference of the item to DEVONthink Pro

(index). For URLs dragged from a browser this creates a bookmark; hold Command

and Option to create a web archive instead. Only files can be moved to the Sorter,

folders and clippings are always copied. For items dragged from DEVONthink Pro

itself the Sorter behaves similar to the Groups & Tags  panel.

If the database the box is connected to is not available, the Sorter preserves the

data for you. Move the mouse horizontally over the box to skim through the dropped

items, just like in iPhoto 'Events'. Drag the shown item to the Trash to remove it.

Alternatively, use the contextual menu to remove it. When the database becomes

available, the Sorter files the contents of the box automatically and plays a sound.

When the database is available, nothing shows up in the box but the Sorter sends all

items directly to DEVONthink Pro and plays a sound.

ADDING NOTES

Switch between the sorter boxes and the take note panel click the  icon located at

the bottom of the Sorter panel. Click the   or  icon to switch back to the sorter

boxes.
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On the take note panel choose the destination for the new note in the pop-up menu at

the top of the panel (DEVONthink Pro offers all groups also available as sorter boxes)

and enter title, URL, and your note. Add tags at the bottom if required. The Sorter

uses the standard font and size set in DEVONthink Pro's Preferences, Editing pane,

for rich text. The text area also accepts drag-and-drop of plain and rich text clippings.

Click the Save button to save the note.

ACTION MENU

The Action menu located at the bottom of the Sorter panel offers some commands

that can be handy. Use the Action menu to open the Sorter's Preferences, flush all

boxes (automatically opens DEVONthink Pro and all databases that are needed), or

quit the Sorter. When the Sorter is not open, use the Preferences or the Dock menu  to

show it again.

HOTKEYS

The Take Note and Copy Selection shortcut that you can set in the Sorter Preferences

allow you to open the Sorter in take note mode or to capture a selection in another

application and save it to the Sorter's inbox. The latter works similar to the Sorter's

Send To Inbox command in the Services menu.



DEVONthink PRO 2.3.3 Documentation, page 319

SHORTCUTS & MODIFIER KEYS

Use the following keyboard shortcuts to use the Sorter efficiently:

•  Command-Option: Creates a web archive instead of a bookmark when

dragging a URL.

•  Command-M: Minimizes the Sorter panel.

•  Command-S: Saves the note (in take note mode).

TROUBLESHOOTING

Re-appears after log-in: If you have set the Sorter in its Preferences that it

should not open automatically when you log-in but it still does so, open the System

Preferences, Users section, Log-in Items tab. Remove the Sorter manually.

Edit 'Hide' settings: If you accidently told the Sorter (not to) hide when an

application goes to full-screen mode and now you want to change this behavior, do

the following: First quit the Sorter, e.g. by using its action menu. Then, open the

Terminal application (located in /Applications/Utilities) and copy the following line

into a new window, followed by the Return key:

defaults delete com.devon-technologies.think-sorter

UserSpecifiedFullScreenApplications
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This makes the Sorter forget its hiding settings and you can set them anew.
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BOOKMARKLETS & EXTENSIONS

DEVONthink Pro supports bookmarklets. Bookmarklets are special bookmarks

that do not load a saved address but execute a little JavaScript application that, for

example, adds a bookmark to the current page in your DEVONthink Pro database or

that creates a web archive of a page. Basically, bookmarklets use your web browser's

bookmark function for creating handy shortcuts for application functions.

In addition, the functionality provided by the 'Clip to DEVONthink' bookmarklet is

also available as an extension for Safari 5, Firefox, and Google Chrome.

INSTALLATION

DEVONthink Pro supports a number of bookmarklets and browser extensions that

you can find on our web site: Click here to open the Download page.

To install a bookmarklet, drag it from the page to your web browser's bookmarks,

preferably the bookmark bar. You can organize the bookmarklets like any other

bookmarks but placing them into the bookmark bar keeps them handy at all times.

To download the Safari 5, Firefox, or Chrome extensions simply use the buttons

on the web page, then double-click them in the Finder or use your web brower's

extension manager.

http://www.devontechnologies.com/redirect.php?id=download-extras
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USING BOOKMARKLETS

Launch the web browser you have placed bookmarklets into, such as Safari. Next,

load any page that you wish to archive or from which you want to clip text. When

the page is shown, select the bookmarklet of choice in your bookmarks bar or click

the button installed by the extension. Instead of loading another page, as normal

bookmarks would do, the bookmarklet or extension will add the selected text or the

whole page as note, bookmark, HTML code, web archive, or PDF to the destination

you choose in the pop-up menu at the top of the panel.
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The Clip to DEVONthink bookmarklet or extension is the most comfortable choice as

it calls a special panel in DEVONthink Pro that lets you enter a title as well as a note

and tags and lets you choose in which format you want to save the clipped data. The

note is either saved as a text file or, for a bookmark, HTML document, web archive, or

PDF is placed into the comments field of the created document.
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SYNCHRONIZING

Synchronizing With the Device 325

Troubleshooting 326

Visit the App Store 327

DEVONthink Pro has the ability to synchronize its databases with DEVONthink

To Go, its companion app for iPhone, iPad, and iPod touche devices. Keep all your

important documents literally at your fingertips!
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SYNCHRONIZING WITH THE DEVICE

DEVONthink Pro uses a special group named Sync to let you decide which data you

want to share with your iOS device. The Sync group appears on the top group level of

all databases and has a special icon that makes it stand out from the other groups.

To select the items in your database that you want to take with you on your device,

either move or replicate them into its Sync group. You replicate items e.g. by dragging

them with the Command and Option keys held. In the global inbox there is no Sync

group; it is always synchronized as a whole.

You can add documents as well as whole groups to the Sync group. Smart groups are

not yet supported and will be ignored during synchronization.

Make sure your device is on the same WiFi network than this computer. On the

device open the DEVONthink To Go app. Tap the sync button on the app's home

screen and follow the instructions.

If you have problems synchronizing your with device, click here.
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TROUBLESHOOTING

If you have problems synchronizing your with device, click here.

If you have other problems with using the Sync group or the DEVONthink To Go

app, please visit the user forum. Should this not answer your questions or solve your

problem, click here to contact the DEVONtechnologies support team.

http://www.devontechnologies.com/redirect.php?id=forum-dttg
http://www.devontechnologies.com/redirect.php?id=contact.html
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VISIT THE APP STORE

If you do not yet have DEVONthink To Go installed on your device, learn more about

it or visit the App Store.

http://www.devontechnologies.com/redirect.html?id=buy-dttg
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SCRIPTS AND THIRD-PARTY APPS

Introduction 329

Installation 334

Internal Scripts 335

Browsers, E-Mail, RSS Readers 346

Triggered Scripts 350

Droplets, Finder plugins, PDF Services 352

More Examples 356

Automator 358

DEVONthink Pro comes with a fully loaded AppleScript dictionary that allows you to

automate almost every aspect of the application. Use the included (and useful) add-on

scripts and Automator actions to perform seldom-used functions. Or, use the included

scripts and actions as templates for your own scripts and workflows.
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INTRODUCTION

DEVONthink Pro features one of the largest AppleScript dictionaries of all Mac OS

X applications available. These scripts make it possible to automate nearly every

aspect of the application, and to integrate the application with almost every other

application supporting AppleScript.

EXAMPLE SCRIPTS

To make it easier for you to start with scripting right away, we deliver a slew of

scripts with DEVONthink Pro that you can access in the Scripts  menu (which shows

a stylized S symbol as its title instead of the word Scripts). These scripts interact

directly with a selected group or document, or create documents themselves. In

addition, the smart template are based on AppleScript scripts. All scripts delivered

with DEVONthink Pro are also useable in everyday work, and are not simple

examples skeletons that need to be tinkered with first.

Other ways to use AppleScript for extending and integrating DEVONthink Pro are

triggered scripts, folder actions, droplets, and PDF Services scripts. You will find

descriptions of the scripts that come with DEVONthink Pro in the corresponding

sections of this chapter.
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INTEGRATING OTHER APPLICATIONS

In addition to the scripts that you use inside DEVONthink Pro, Mac OS X features a

global script menu that allows you to access certain scripts from any application on

your Mac, for example your web browser or Apple Mail. When activated, it appears

at the right side of the menu bar (like other menu extras such as the AirPort signal

strength or the Spotlight icon). It appears with a black stylized S icon.

Note: By using folders named after applications inside the '~/Library/

Scripts/Applications' directory, it is also possible to make scripts

application-specific. Such scripts will appear at the top level of the global

script menu when the application they belong to is frontmost. This

removes clutter and shows only scripts that make sense in the current

application.

DEVONthink Pro already comes with a number of scripts that you can access

conveniently from the global script menu. DEVONthink Pro asks to install them

whenever you update the application, or you can (re-)install them manually by

selecting DEVONthink Pro > Install Add-ons.  They will be installed in '~/Library/

Scripts/Applications/<TargetApp>' and only apply for the user currently logged in.

Also, they only show up in the script menu when the application for which they are

designed is the front-most application (the one that currently populates the menu

bar).
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To activate the global script menu, do the following:

•  Open the AppleScript Utility (located in '/Applications/AppleScript').

•  Check Show Script Menu in menu bar.

•  Uncheck Show Library scripts if you only want to see the scripts you

have installed yourself.

To install your own scripts (such as the scripts that come with DEVONthink Pro),

copy them into the folder '~/Library/Scripts'. You can use sub-folders to structure

them in any way you like.

DEVONTHINK PRO’S DICTIONARY

DEVONthink Pro includes a large dictionary with commands, objects, and methods

you can use for writing scripts that interact or extend DEVONthink Pro. To view the

dictionary, open the Script Editor application (by default located in '/Applications/

AppleScript'), select File > Open Dictionary and choose DEVONthink Pro in the

appearing window.

You can also add DEVONthink Pro to your Script Editor library. Select Window

> Library, click the + button and choose DEVONthink Pro. This way you keep

DEVONthink Pro's dictionary at hand.



DEVONthink PRO 2.3.3 Documentation, page 332

CACHING

DEVONthink Pro caches pre-compiles and caches scripts as soon as they're called

for the very first time. So, when you are modifying a script you need to make sure

DEVONthink Pro takes notice of the changes. For scripts in the Scripts menu, use

the Scripts > Update Scripts Menu command. For e.g. triggered scripts, restart

DEVONthink Pro.

LEARNING APPLESCRIPT

This documentation is not an AppleScript language guide. Please refer to Apple's

AppleScript web site, other online resources, or introduction and reference books for

more information on the AppleScript language. Here are some links for you:

•  The Ultimate Beginner's Guide to AppleScript

•  AppleScript, the Language of Automation

•  MacScripter

•  ScriptWeb

•  TECsoft Hands-On Trainings

•  Scripting Matters Trainings

•  AppleScript for Absolute Starters (free PDF book)

•  AppleScript: The Missing Manual

http://www.apple.com/applescript
http://www.apple.com/applescript
http://mac.appstorm.net/how-to/applescript/the-ultimate-beginners-guide-to-applescript/
http://www.macosxautomation.com/applescript/
http://macscripter.net
http://www.scriptweb.org
http://www.tecsoft.com/ascourse.html
http://www.scriptingmatters.com
http://www.applescriptsourcebook.com/tips/AS4AS/AS4ASb2.pdf
http://www.amazon.com/exec/obidos/tg/detail/-/0596008503/qid=1121266897/sr=8-1/ref=pd_bbs_ur_1/002-5709247-5091254?v=glance&s=books&n=507846
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•  AppleScript: The Definitive Guide

http://www.amazon.com/exec/obidos/tg/detail/-/0596005571/qid=1121266897/sr=8-2/ref=pd_bbs_ur_2/002-5709247-5091254?v=glance&s=books&n=507846
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INSTALLATION

All add-on scripts that come with DEVONthink Pro are automatically installed or

updated when you open a new version of DEVONthink Pro for the first time. You can,

however, manually (re-)install them by choosing DEVONthink Pro > Install Add-ons

The scripts are installed in a number of locations:

•  Application Scripts: These scripts are installed in '~/Library/Scripts/

Applications/' and can be used from the global script menu. See also p.

346ff

•  DEVONthink Pro Scripts: These scripts are installed in '~/Library/

Application Support/DEVONthink Pro/Scripts' and can be used from

DEVONthink Pro's own script menu. See also p. 335ff

•  PDF Services Scripts: These scripts are installed in '~/Library/PDF

Services/.' They extend the PDF button in any application's print dialog.

See also p. 352ff
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INTERNAL SCRIPTS

The internal scripts menu of DEVONthink Pro, located to the left of the Help menu

(in DEVONthink Pro's menu bar), gives you access to a large number of pre-made

scripts and Automator workflows that extend DEVONthink Pro with additional,

more specialized commands and functions.

More scripts are available as extras. See also p. 234ff

Of course, you can easily modify all these scripts using the AppleScript Editor (and

the workflows using Automator) or add your own scripts and workflows to the menu.

They are located in '~/Library/Application Support/DEVONthink Pro/Scripts'. Open

this folder in the Finder with Scripts > Open Scripts Folder.

Note: If you have modified the contents of the script menu and you want

to go back to the default set, delete the complete Scripts folder in '~/

Library/Application Support/DEVONthink Pro/'. DEVONthink Pro will

recreate this folder, including it's content the next time you next launch

the application.

Note: If you want to add keyboard shortcuts to scripts in this menu,

you either use the System Preferences or you simply add the shortcut

description to the file name of the script in '~/Library/Application

Support/DEVONthink Pro/Scripts' or '~/Library/Scripts'. Example: 'eMail
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Current URL (Mail)___Cmd-Alt-M.scpt'. The naming convention is three

underline characters followed by the shortcut description. 'Cmd' stands

for the Command, 'Alt' for the Option, 'Ctrl' for the Control, and 'Shift' for

the Shift keys.

COMMENTS

•  Assemble: Collects the comments of the selected documents and creates a

new document listing them.

•  Speak: Speaks the comments of the selected documents.

DATA

•  Convert to Tags: Converts the tag contained in the comments fields to

real tags if the comments field of the selected document contains tags

separated by commas. See also p. 392ff

•  Move Duplicates to Trash: Moves all duplicates of the selected document

to the trash.

•  Find & Remove Similar Contents: Finds and removes similar documents.

•  Group With Duplicates: Creates a group with duplicates of the selected

documents.
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•  Group With Replicants: Creates a group with replicants of the selected

documents.

DATES

•  Creation > Modification Date: Sets the modification date of the selected

items to their creation dates.

•  Modification > Creation Date: Sets the creation date of the selected items

to their modification dates.

•  Touch Creation Date: Sets the creation date and time of the selected

items to the current date and time.

DOWNLOAD

•  Images of Page: Adds the images of a displayed web page to the database.

•  Linked Images of Page: Adds linked images of a displayed web page to

the database.

•  Links of Page: Adds links contained on a displayed web page to the

database.

•  Create Offline Archive: Creates an offline version of a displayed web

page.
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EDIT

•  Count Characters: Counts the characters in the current selection.

•  Count Words: Counts the words in the current selection.

EXECUTE

•  AppleScript: Executes an AppleScript script.

•  Perl: Executes a Perl script.

•  Shell: Executes a shell script.

EXPORT

The following scripts provide some seldom-used export functions and help you create

backups of your database (for copying them to external media such as CD-R or

JungleDisk).

•  Listing: Saves a UTF-8 text file containing a text listing of the names of

all contents/groups of the current database.

•  Daily Backup Archive: Creates a backup of the database in '~/Backup'.

All backups are named after the current date so that multiple backups

are kept.
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•  To JungleDisk: Exports all items in the database as a Zip archive and

copies the backup archive to your JungleDisk. Please note that for this

script to work, your JungleDisk needs to be named 'JungleDisk'.

FEEDS

DEVONthink Pro can be used as a news feed reader. To work with news feeds, use

the dedicated feed document type.

The following scripts demonstrate additionally methods how DEVONthink Pro can

directly plug into live information sources by the use of AppleScript.

•  Apple -- Hot News: Creates an HTML document with Apple's Hot News.

•  Apple -- Latest Mac OS X downloads: Creates a group with links to

recommended downloads.

•  Nature -- Hubble News: Downloads the latest Hubble news.

•  iTMS -- Added Albums: Downloads covers of albums recently added to

the iTunes Music Store.

FORMAT

•  Body Normal: Formats selected text as 'Body Normal'.

•  Body Small: Formats selected text as 'Body Small'.

http://www.jungledisk.com
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•  Header Capitalized: Formats selected text as 'Header Capitalized'.

•  Header Normal: Formats selected text as 'Header Normal'.

•  Header Secondary: Formats selected text as 'Header Secondary'.

•  Source: Formats selected text as Source.

•  Reset Spacing: Resets the line and paragraph spacing of selected rich

text.

IMAGES

•  Copy Info to Comment: Copies basic image info to the comment field.

•  Flip Horizontal / Vertical: Flips the image horizontally/vertically.

•  Rotate Left / Right: Rotates the image left/right.

•  Landscape to Portrait: Rotates only landscape images to portrait.

•  Portrait to Landscape: Rotates only portrait images to landscape.

•  Scale to 1024 pixels wide: Scales the image to 1,024 pixels wide.

•  Scale to 1024 pixels: Scales the image to 1,024 pixels.

•  Scale to 200%: Scales the image to 200 percent.

•  Scale to 50%: Scales the image to 50 percent.

Note: While these scripts work also with PDF documents it is not

advisable to do so. The functions used only act on the first page of a

multi-page PDF and the resulting document will contain the first page

only.
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IMPORT

These scripts demonstrate DEVONthink Pro's ability to import data from various

sources, including web sites.

•  Astronomy Picture of the Day: Imports the Astronomy Picture of the Day.

•  Daily Dilbert: Imports the Daily Dilbert.

•  Del.icio.us: Imports your del.icio.us bookmarks. The descriptions are used

to name the imported bookmarks, the notes and the tags are added to the

comments. If the keychain does not contain a key for del.icio.us, dialogs

pop up allowing you to enter the user name and password.

•  EverNote file (.enex): Imports notes exported from EverNote in

EverNote's exchange format (.enex). Notes are stored as HTML files with

formatting; images and attachments are not imported.

•  Man Page: Imports a UNIX manual page as a PDF document.

•  Mars Explorer Rover Mission Im.: Imports Mars Explorer Rover Mission

Images.

•  Perldoc: Imports the documentation of Perl pages, modules, functions, or

programs.

•  Phone List: Imports all phone numbers from Apple Address Book.

•  This week's MacDesktops: Imports this week's MacDesktops.

http://del.icio.us
http://www.evernote.com
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The following scripts import chatlogs and call logs from popular instant messaging

clients as well as from your mobile phone:

•  Adium Chatlogs: Imports all your chatlogs from the Adium instant

messaging client, converts them to readable HTML, and stores them in

your database. The Mac OS X Address Book is used to resolve instant

messaging account names if possible.

•  BluePhoneElite Calls: Imports your mobile phone call logs from

BluePhoneElite 2.

•  BluePhoneElite SMS: Imports your SMS messages from your mobile

phone via BluePhoneElite 2.

•  iChat Chatlogs: Imports your iChat chatlogs.

•  Second Life Chatlogs: Imports your Second Life chatlogs.

REMINDERS

•  Add as Event to iCal: Adds a new event to iCal linking back to the

selected item in DEVONthink Pro.

•  Add as To Do to iCal: Adds the selected item as a to do item to iCal.

•  Add as To Do to OmniFocus: Adds the selected item as a to do item to

OmniFocus.

•  Add as To Do to Task Paper: Adds the selected item as a to do item to

Task Paper.

http://www.adiumx.com
http://www.mirasoftware.com
http://www.mirasoftware.com
http://www.secondlife.com
http://www.omnigroup.com/products/omnifocus/
http://www.hogbaysoftware.com/products/taskpaper
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•  Add as To Do to The Hit List: Adds the selected item as a to do item to

The Hit List.

•  Add as To Do to Things: Adds the selected item as a to do item to Things.

RENAME

•  Add Prefix: Adds a prefix to the titles of selected documents.

•  Add Suffix: Adds a suffix to the titles of selected documents.

•  Append Selected Text: Appends the selected text to the title of the

currently selected item.

•  Replace Text: Replaces a text passage in the titles of selected documents.

•  Selected Text: Sets the title of the currently selected item to the selected

text.

•  To Subject: Sets the titles of the selected documents to the subject lines of

the email messages if the selected documents are email messages.

•  To Webpage Title: Sets the titles of the selected documents to the names

of the web pages pointed to by their URL fields.

http://www.potionfactory.com/thehitlist/
http://culturedcode.com/things/


DEVONthink PRO 2.3.3 Documentation, page 344

SHEETS

Even though DEVONthink Pro is no spreadsheet application, it does have these

scripts that exemplarily implement basic sum and mean value functionality for

sheets.

•  Add Multiple Records: Adds up to 999 empty records to a sheet.

•  Column Sum&Mean Value: Calculates the sum and average of a table

column.

•  Row Sum&Mean Value: Calculates the sum and average of a table row.

•  Check sums in last column: Checks the sums in the last column on

validity.

TOOLBAR

By default this contains no scripts. Add your own scripts here and add them also to

the toolbar of main and search windows using View > Customize Toolbar.

THUMBNAILS

•  Flip Horizontal / Vertical: Flips the thumbnails of selected documents

horizontally/vertically.
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•  Rotate Left / Right: Rotates the thumbnails of selected documents left/

right.

•  Landscape to Portrait: Rotates only landscape thumbnails to portrait.

•  Portrait to Landscape: Rotates only portrait thumbnails to landscape.

Note: While these scripts work with all image formats including PDF,

they should not be used for PDF documents. They will only work on the

first page of the PDF and destroy all embedded metadata.

TRANSLATE

•  English to German: Translates selected text.

•  German to English: Translates selected text.

ABOUT THIS MENU

Shows an information dialog window about the Scripts menu.
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BROWSERS, E-MAIL, RSS READERS

AppleScript is perfectly suited for integrating different applications, interchanging

information, and creating workflows. DEVONthink Pro comes with a number

of scripts that copy information from other applications, like Safari or Mail,

to DEVONthink Pro. You may use these scripts as a template for connecting

DEVONthink Pro to your own applications.

To install these scripts completely automatically, click here or select DEVONthink

Pro > Install Add-ons,  check Application Scripts and DEVONthink Pro Scripts, and

click Install. You access them via the global script menu extra.

Note: The application-specific scripts (put into sub-folders of "~/Library/

Scripts/Applications") appear only within the application they were

designed for (see introduction). To see them, activate their designated

application, e.g., by bringing one of its windows to the front. The other

scripts are located in a sub-menu named "DEVONthink Pro".

DEVONAGENT, CHROME, OMNIWEB, AND SAFARI

These scripts import elements from a displayed web page in Safari, Google Chrome,

OmniWeb, Firefox, Camino, or DEVONagent to DEVONthink Pro.

•  Add abstracts to DEVONthink Pro (DEVONagent only)

x-devonthink://install-add-ons
http://www.google.com/chrome/
http://www.omnigroup.com/applications/omniweb/
http://www.mozilla.com/firefox/
http://www.caminobrowser.org/
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•  Add page to DEVONthink

•  Add linked images to DEVONthink

•  Add linked images to DEVONthink's downloads

•  Add links to DEVONthink

•  Add links to DEVONthink's downloads

•  Add PDF document to DEVONthink

•  Add selection to DEVONthink

•  Add tabs to DEVONthink (DEVONagent only)

•  Add text to DEVONthink

•  Add web document to DEVONthink

Note: Not all of these options are available for all browsers.

The scripts add the currently displayed page or image, the selection or the text of the

current page, the linked images of the current thumbnail gallery, or the links of the

current page from your browser to DEVONthink Pro or its download manager.

EMAIL APPLICATIONS

Note: If you are interested in pro-grade email archiving, please also have

a look at DEVONthink Professional Office that comes with far more

advanced email archiving functions than DEVONthink Professional.

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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Starting with Mac OS X 10.5 Leopard you can drag messages from Apple Mail to

DEVONthink Pro to import them. In addition you can use the provided scripts or just

transfer selected text to DEVONthink Pro by using the Services  menu. DEVONthink

Pro comes with scripts for Apple Mail, Microsoft Entourage, and Microsoft Outlook

2011.

These scripts, all named Add message(s) to DEVONthink' or Add mailbox(es) to

DEVONthink and located in the respective sub-folder for their target application,

copy selected messages or mailboxes from Apple Mail, Microsoft Entourage, or

Outlook to the currently open DEVONthink Pro database. If possible, they set the

creation and modification dates of the imported messages to the receipt date and

the URL field to the sender's address. Both Add mailbox(es) scripts also recursively

import mailboxes inside the selected mailboxes and rebuild the mailbox hierarchy

within a group named 'Entourage Mail' or 'Apple Mail' in the currently open

DEVONthink Pro database.

RSS NEWSREADER

These scripts, namely the script named Add news to DEVONthink, allow you to

add selected or flagged news from NetNewsWire and Endo to the currently open

DEVONthink Pro database. If correctly installed (see above), select any news you

want to copy to your database and select the script from the global script menu extra.

http://www.microsoft.com/mac
http://www.microsoft.com/mac/outlook
http://www.microsoft.com/mac/outlook
http://ranchero.com/netnewswire
http://infinite-sushi.com/software/endo/
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OTHER SCRIPTS

The remaining scripts designed for the script menu extra allow you to copy selected

text to your database, or to create a link to the front-most document. They're grouped

in the DEVONthink Pro sub-menu.

•  Copy Selection: Copies the selected text and creates a new plain text

document in the default destination.

•  Link to current document: Indexes the front-most document (for example,

a PowerPoint presentation or an Excel spreadsheet) and places the

indexed document in the default destination. Handy when you are

working on a document and want to quickly place a reference to it in

DEVONthink Pro.
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TRIGGERED SCRIPTS

Triggered scripts are AppleScripts that you attach to an item in DEVONthink Pro

(a group or document) and that are executed each time you display this item (like

selecting it in Split view). Items with attached triggered scripts show an AppleScript

icon behind their name.

Using triggered scripts, you can bring your items to life and let them act intelligently

on various parameters. Examples for triggered scripts can be found in the folder

"Extras/Scripts/Triggered" on the DEVONthink Pro disk image.

ATTACHING A TRIGGERED SCRIPT

Besides creating scripts that attach themselves to an item, you attach them manually

by doing the following:

•  Select the document you want to attach a script to.

•  Open the Info panel  ('Tools > Show Info').

•  Click Select next to the Script field and select the script to attach.
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REMOVING A TRIGGERED SCRIPT

To remove a triggered script from an item, do the following:

•  Select the item you want to remove the triggered script from.

•  Open the Info panel  ('Tools > Show Info').

•  Select the contents of the Script field and delete it.
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DROPLETS, FINDER PLUGINS, PDF SERVICES

DROPLETS

Droplet are little AppleScript applications that allow you to run actions based on

files or folders dropped on them. You can create them easily using the AppleScript

editor; some useful examples already come with DEVONthink Pro on the disk image

in 'Extras/Scripts/Droplets'. Basically, they do what their name suggests:

•  Import Droplet: Imports files and folders dropped into droplets.

•  Import Index Droplet: Indexes files and folders dropped onto it.

Using Droplets: Place a droplet anywhere you like and optionally drag it to the

Dock. Then, drag the files and folders you want the droplet to act on onto its icon in

the Finder or the Dock.
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FOLDER ACTIONS

Folder Actions are scripts that you can attach to folders in the file system and that

act on all items you add to these 'hot folders'. DEVONthink Pro comes with three

folder action scripts that you can install using the DEVONthink Pro > Install Add-

Ons  menu option:

•  DEVONthink — Import: Imports files into your databases.

•  DEVONthink — Import & Delete: Imports files into your database and

moves the files to the trash afterwards.

•  DEVONthink — Index: Adds references to the files to your database.

Attaching a Folder Action: To attach a folder action script to a folder, do the

following:

•  Right-click the folder.

•  Select Attach a Folder Action from the contextual menu.

•  Select the folder action script you want to attach and click Choose.

Manage Folder Actions: To manage all your folder actions, right-click a folder and

choose Configure Folder Actions (Mac OS X 10.5) or Services > Folder Actions Setup

(Mac OS X 10.6) from the contextual menu. Use the Folder Actions Setup utility to

see which folders have scripts attached, and to remove folder actions from folders.
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MAIL

The Mail Rule Action Import script imports all the emails that the mail rule acts on

to the currently open database.

To use this script, do the following:

•  Open the 'Scripts/Mail' folder on the DEVONthink Pro disk image.

•  Put the script anywhere on your hard disk.

•  Create a new rule in the preferences window of Apple Mail.

•  Define your criteria.

•  Add the Execute Script action.

•  Select the 'Mail Rule Action Import' script.

PDF SERVICES

Using PDF Services, you can add your own actions to the PDF button of the print

dialog windows in any Mac OS X application. DEVONthink Pro adds an alias of itself

to the PDF Services folder.

Installation: To install the PDF Services alias select DEVONthink Pro > Install

Add-ons  and check PDF Services in the dialog window. Then click Install.
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Printing to your database: To 'print' (save) a document to DEVONthink Pro, open

it in its creator application (this could even be DEVONthink Pro itself). Then, do the

following:

•  Select File & Print.

•  In the appearing print dialog window, click the PDF button at the lower

left corner and select Save PDF to DEVONthink Pro (saves to the default

destination) from the pop-up menu.

•  Then, select the destination group for the document, if necessary, and

click OK.

Note: This requires an installed printer to work properly.
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MORE EXAMPLES

Some of these scripts do things that have already been implemented as 'real'

commands in DEVONthink Pro', others are functions you will seldom use. All of the

scripts are more example than everyday functions, yet all can be of real use.

•  Create Contacts: Copies all entries of the Mac OS X Address Book to

DEVONthink Pro, like File > Import > Addressbook.

•  Cross-linked Text: Links selected text to currently visible document.

Demonstrates how to programatically add links to a rich text document.

•  Export daily backup as files & folders: Exports all items of the database

as files and folders as a daily backup.

•  Export to iPod: Exports selected documents as notes to an attached iPod

(3rd Generation or later), like File > Export > to iPod.

•  Export to OPML: Exports selected documents as OPML file, like File >

Export > as Outliner Processor Markup Language.

•  Fancy Text: Demonstrates some of the rich text scripting capabilities of

DEVONthink Pro.

•  Import Feed: Demonstrates how you can access RSS feeds from

DEVONthink Pro via AppleScript.

•  Latest Macintosh News: Downloads the latest news from a number of

RSS feeds and stores them in the database.
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•  Merge: Merges multiple selected document to one long document, like

Data > Merge.

•  Move to Done: Moves the selected item(s) to the group Done in the top

level of the database.

•  Open In PhotoStickies: Opens selected images in PhotoStickies.

•  Open In Preview: Opens selected images in Preview.

•  Prepare Backup: Creates a backup of the database at a chosen location

(like the Desktop), and makes it a Zip archive that can be comfortably

copied to an external medium, an online drive, or a writable disc.

•  Quick Look: Opens a Quick Look head-up-display window for the selected

item.

•  Show recommended groups: Shows the groups recommended by

DEVONthink Pro's artificial intelligence for the selected document.

•  Synchronize: Triggered script that synchronizes the item it is attached to

each time it is viewed. Can be used to keep a group always synced with

its counterpart in the file system.

You can also find more scripts in the Extras area of the Support Assistant.

http://www.devontechnologies.com/redirect.php?id=product-freeapps
x-devonthink://assistant
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AUTOMATOR

DEVONthink Pro also comes with a bundle of integrated Automator actions that you

can use to create your own Automator workflows.

To see which actions DEVONthink Pro provides, open a new workflow in Automator

and click the Actions button, then search for DEVONthink Pro in the Library.

Automator then displays all actions contained in the application. Select any action to

show a short description about what the action does.

Note: Cannot find the Automator action you need for your workflow?

We're open to suggestions!

OVERVIEW

We have created some workflow examples that show you how to use Automator and

DEVONthink Pro together. This document explains what the workflow examples are

supposed to do, and how you can adapt them for your situation. The examples are

presented here are grouped around common functionality.

http://www.devontechnologies.com/redirect.php?id=contact
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FILE MANAGEMENT

Managing files with DEVONthink Pro is one of its best features. Here are different

ways to work with the information in the database.

Move Existing Files: You have a folder with files that you think are in control by

DEVONthink Pro, but you want to move the files that are guaranteed to be found

in the database to a different folder (let's say 'Archive'). This workflow will solve

this problem for you. For the given files/directories, it will find all files, and ask the

database if items exist with these paths. For the ones that are found to exist, move

these to a specified folder.

Note: The exact locations have not been defined in this workflow, that

is up to you. DEVONthink Pro will keep track of the moved files, so you

don't have to change anything in the database.

To improve your workflow, specify a specific database to use by prepending the Filter

Items action with an Open Database action. In general, it's a good idea to specify the

database a workflow has to act on.
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Add and Move Missing Files: Find out what files are not in the database by

changing the value in the Filter Items to Missing in the previous workflow. Then we

use the Move Finder Items action to place these files in their rightful place in our

folder hierarchy. These files will be sent to the Add Items to Current Group action

after setting the destination group, this will index the files into the database.

To improve the workflow, specify a database to use by prepending the Filter Items

action with a Open Database action. In general, it's a good idea to specify the

database a workflow has to act on.

Start Workday: This workflow is something you'd start every day when you're

ready for work. It is rather complicated but really shows off what you can do. Let's go

through the steps:

•  Step 1 to 2: We create the 'Today: To Do' group in the example database.

This way we can be sure that the next step has a group to work on.

•  Step 3: Then we run another workflow: Clean Today's To Do. Here we

completely clean the contents of the 'Today: To Do' group. By the way you

may want to switch off the confirmation to delete every record in Step 4

of this workflow, as long as you don't add items by hand to this group!

•  Step 4: Here you can specify the different records throughout your

database you're working on.
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•  Step 5: We only get the records that we're not marked as ready

('unchecked').

•  Steps 6 to 7: These are replicated to 'Today: To Do' list. This will also

open a new window with the items you want to work on today.

•  Step 8: Get every record including the ones in sub-groups.

•  Step 9: Get the file paths from these records.

•  Step 10: Open the external files in the Finder. You're ready to start

working!

End Workday: At the end of your day, you'd like to make sure that the database is

updated with the modified contents of the files you've been working on. That's the

goal of this workflow. It synchronizes every record in your 'Today: To Do' group.

Copy Checked Records to iPod Notes: Whenever you feel like showing off to your

colleagues that you have the coolest gadgets and software, you can use this workflow

to get the text of the finished work in your To Do list and send it to your iPod. The

order in which your notes will appear depends on the sort order of the records in the

'Today: To Do' window.

WEB MANAGEMENT

Dealing with the web is where DEVONthink Pro really shines. Here are a few

workflows that help you manage the information you're gathering form the Internet.
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Capture Safari Page: Another take on getting information from Safari. If you save

this example as an application and put it into your Dock, you can very easily get the

information from the current web page in Safari into your database. This is because

the Add Items to Current Group workflow will actually download the given URL so

that its contents can be made available for searching.

Convert URLs to Webarchive: This workflow shows how you can convert URLs to

webarchives. Let's go through the steps:

•  Step 1-2: Make sure to select the records with URLs that you want to

replace inside DEVONthink Pro.

•  Step 3: We download the URLs in DEVONthink Pro.

•  Step 4: We want to use temporary files so we store them in a variable to

refer to them later.

•  Step 5: Back in DEVONthink Pro, we create a 'Converted Web Pages'

group.

•  Step 6: Here we import the files. Note that we import them because we

regard the documents as temporary files in Step 3, DEVONthink Pro will

copy the files to the database file folder for its own safe keeping.

•  Step 7-8: We retrieve the list of files and send them to the Finder's Trash.
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Gather Information from Safari: The next two workflows are not great for our

bottom line, yet we've decided to present these helpful hints free of charge! The first

in the series is a script that gets all the links (within the domain of the starting page)

from Safari's open web pages and puts these into a special group called 'Temporary

Safari Links'. For each entry in this group, you can see its status. The contents will be

indexed (so loading these may take a while).

Now you can go and do some searching for information you want. For the records in

this group that match your criteria, you will set the state to 'checked'.

Store Information from Safari: The second and last workflow in this series will

clear up the mess we made. It gathers all the checked records and asks to move these

to a group you specify (note that for this action we specified that the action has to be

shown).

Also, take a look at Step 8, here we have to Ignore Result from Previous Action,

because we don't want you to delete the work that you spend so much time on! The

remaining records in the temporary group will then be deleted.

Now, why are these two workflows bad for our bottom line? Because they compete

with DEVONagent Pro. (Although, truth be told, DEVONagent Pro does a much

better job at this then we can emulate with a couple of Automator workflows).
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OTHER WORKFLOWS

Of course, Automator workflows can also be used to manipulate items in the

database.

Set Attributes Recursively: A simple workflow that, when saved as an application,

deserves a place in the Scripts menu. It is relatively simple:

•  Get the record selection from the DEVONthink Pro.

•  If the selection contains groups, recursively add all records contained in

these.

•  Set the record attributes but make sure to make this visible when

running so you can change different attributes when you run it. This is

especially important when you save the workflow as an application.

Add in Finder: Save this workflow as a Finder plugin; then you can import a file

selection from the Finder into a group that you select in an open database. You

should remove the first action and name it 'Add to DEVONthink Pro'. Then you will

see it in the Finder's contextual menu in More > Automator.

Combine PDF Records: Use this workflow to combine one or mulitple selected PDF

documents. As this workflow uses Preview to do its magic, metadata and annotations

will be lost.
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Compress PDF to 96dpi: Compresses images contained in PDF records to 96dpi,

this can be useful if you have scanned documents and want to reduce the file size by

optimizing them for on-screen display only.

Open DEVONthink Spotlight Item: Opens the selected DEVONthink items listed

by a Spotlight search in the external applications assigned to their type.

APPLESCRIPT-BASED WORKFLOWS

Store Safari Selection in Specified Group: This is an example for more advanced

scripting users. It uses AppleScript inside an Automator action to achieve a goal that

is not possible with the existing actions.

Store DEVONagent Selection in Specified Group: Identical to the previous

action in functionality but it uses DEVONagent Pro instead. Note that DEVONagent

Pro comes with its own convenient collection of actions that allow you to create

sophisticated workflows in combination with DEVONthink Pro.
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TROUBLESHOOTING

Repairing a defective database 367

DEVONthink Pro crashes when opened 371

Recovering a lost password 373

Items keep re-appearing in the inbox 374

Problems importing files 375

Problems using Services 377

DEVONthink Pro behaves irrationally 378

Problems synchronizing with DEVONthink To Go 380

DEVONthink Pro was created with robustness in mind. But still, computer hard-

and software can write defective data or destory files. If you have troubles with your

database, please refer to the methods below and also have a look at our FAQ.
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REPAIRING A DEFECTIVE DATABASE

DEVONthink Pro databases are packages containing of your files and the supporting

AI-based index. In rare cases this index can get corrupted or out-of-sync. But as

you files are stored separately this is not the world's end. If your database starts

behaving stragely or if DEVONthink Pro itself finds inconsistencies when doing its

start-up check it is time for some house-keeping.

STEP 1: VERIFY & REPAIR

As a first step use Tools > Verify & Repair  to check your database's consistency and

allow DEVONthink Pro to take all necessary steps to repair the found problems. If

Verify & Repair was able to repair your database, use Tools > Backup & Optimize 

to optimize your database and have DEVONthink Pro create an internal copy of the

index.

If Verify & Repair was not successful or your problems are not solved, proceed with

the next step.
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STEP 2: RESTORE FROM BACKUP

With its factory setting, DEVONthink Pro keeps up to two copies of the index files in

case that the index is damaged beyond repair. You can change when and how many

internal backups DEVONthink Pro keeps in the Preferences, Backup tab.

To restore from a previously saved internal backup (means: a copy of only the index

files), use Tools > Restore Backup  DEVONthink Pro presents you with a list of all

available backups. Choose the latest one and click Open. This swaps the current set

of index files with the copy (the current set of index files becomes the backup, the

backup becomes the current set) so that never any data is overwritten. Run Tools

> Verify & Repair  to check the consistency of this index version and if everything

is in order use Tools > Backup & Optimize  to optimize your database and have

DEVONthink Pro create a fresh internal copy of the good index.

If the backed-up index files are also defective, try the other backups, of available. If

all backups are broken, too, proceed with the next step.

STEP 3: REBUILD YOUR DATABASE

As your files and DEVONthink Pro's index are stored independently within the

database package the index can be rebuilt an any time without you losing too much

metadata. To rebuild the database from scratch use Tools > Rebuild Database.
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Note:

The global inbox database cannot (yet) be rebuilt using the steps above.

Use the following steps to rebuild the global inbox database manually:

•  Quit DEVONthink Pro.

•  Move ~/Library/Application Support/DEVONthink Pro 2/Inbox.dtBase2

to the Desktop.

•  Open the moved database by double-clicking on it

•  Rebuild it.

•  Move everything from the moved database to the now empty global

inbox.

•  Quit DEVONthink Pro, delete the moved database.

During the rebuild process the complete index is re-created. Your actual files are not

touched. All problems that occured during this process are logged.

Orphaned files: Orphaned files that could not be imported while repairing are

logged and moved to the folder 'Orphans' inside the database package. To access

the contents of the package, show the database package in the Finder, right-click it,

and choose Show package contents from the contextual menu. Move the files in the

'Orphans' sub-folder to a save location, e.g. the Desktop, or directly re-import them by

dragging them to DEVONthink Pro's Dock icon. Please do not change anything here

except for rescuing the orphaned files.
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STEP 4: TIME MACHINE OR MANUAL RESCUE

If everything above failed it seems that your database is severely damaged. You have

two options now:

•  Option 1: Restore your database from your Time Machine backup, your

Jungle Disk, or any other backup medium you use for keeping an up-to-

date backup of your documents. If you don't use Time Machine yet we

strongly advise you to do so. External hard disks are cheap and Time

Machine makes backing up your important files a no-brainer.

•  Option 2: If you do not have a current backup of your documents you

can rescue your files manually but you will lose your group structure. To

manually copy your files from the defective database, show the database

package in the Finder, right-click it, and choose Show package contents

from the contextual menu. Copy the files in the 'Files' sub-folder, which

are sorted by kind, to a save location, e.g. the Desktop. Then create a new

database, re-import them and recreate your group structure.

STEP 5: CONTACT SUPPORT

If none of the above steps helped solving the problems you have with your database,

please contact DEVONtechnologies' support staff with a precise-as-possible

description of your problem.

http://www.apple.com/macosx/what-is-macosx/time-machine.html
http://www.jungledisk.com
http://www.devontechnologies.com/redirect.php?id=contact
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DEVONTHINK PRO CRASHES WHEN OPENED

If a database is heavily damaged it can happen that DEVONthink Pro crashed when

opening the database or when starting up. In this case you cannot use the build-

in mechanisms for recovering your data. But you can go back to one of the internal

backups manually. With its factory setting, DEVONthink Pro keeps up to two copies

of the index files in case that the index is damaged beyond repair. You can change

when and how many internal backups DEVONthink Pro keeps in the Preferences,

Backup tab.

To revert to one of the internal backups, quit DEVONthink Pro and locate the

database package in the Finder. Then do the following:

•  Select the database in the Finder, choose "Show Package Contents" in the

contextual menu

•  Copy (!) the most recent Backup folder to the desktop

•  Copy (!) the Files.noindex folder into the copied (!) Backup folder

•  Add the file extension .dtBase2 to the Backup folder

Now you should be able to open the copied Backup folder as a new database by

double-clicking it. Afterwards use Tools > Verify & Repair  to ensure that everything's

fine.
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If this did not help, please contact DEVONtechnologies' support staff with a precise-

as-possible description of your problem.

http://www.devontechnologies.com/redirect.html?id=contact
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RECOVERING A LOST PASSWORD

If you have protected a database and you have forgotten your password, do the

following to remove the password protection:

•  Close DEVONthink Pro

•  Locate your protected database in the Finder

•  Right/Control-click it and choose Show Package Contents

•  Move the file 'Settings.plist' to the Trash

A future version os DEVONthink Pro will feature an industry-strength encryption.
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ITEMS KEEP RE-APPEARING IN THE INBOX

If files keep re-appearing in your global inbox even though you definitely have

deleted or moved them in DEVONthink Pro, it may be that some files with bad

permissions got locked up in the Inbox folder.

Open the folder '~/Library/Application Support/DEVONthink Pro 2/Inbox' (where ~ is

your user's home directoy) and delete them manually. This should keep them from re-

appearing.
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PROBLEMS IMPORTING FILES

WHY DOES DEVONTHINK PRO NOT RECOGNIZE MY FILES?

If DEVONthink Pro does not recognize a file make sure it has a proper file name

extension. DEVONthink Pro needs a file name extension to determine the file type.

Add the correct file name extension to your files (e.g., .txt for plain text files, .rtf for

rich text files, .pdf for PDFs and .doc for Microsoft Word files. Then try again.

WHY DOES DEVONTHINK PRO NOT DISPLAY MY DOCUMENT CORRECTLY?

If a document is not properly displayed, especially if it is a proprietary file format

such as RagTime or Mellel, make sure that you either have a Quick Look plugin

installed for this file format or that the application that created it is installed on

your Mac (and supports Quick Look). DEVONthink Pro will be able to display the

document if you can display the file also e.g. in the Finder by pressing the Space bar.

WHY DO SOME PDFS APPEAR AS IMAGES AND ARE NOT SEARCHABLE?

DEVONthink Pro cannot extract the text part of print- or editing-protected PDFs.

When you import them, you get a log entry that tells you that the PDF file contains

'no text'. When you select these documents in DEVONthink Pro, the status bar shows
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'image' instead of 'PDF+text'. A cheap solution for this problem is Michele Balistreri's

PDFKey. It allows you to print protected PDFs. Use PDFKey to 'print' a PDF file into

a new PDF that is both printable and editable — and the latter allows DEVONthink

Pro to extract the text for searching and classifying.

http://pdfkey.com/
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PROBLEMS USING SERVICES

WHY DO THE SERVICES MENU COMMANDS SHOW NO SHORTCUTS?

They should, however, the keyboard shortcuts for Services menu commands are only

requested by the supplying application; Mac OS X itself assigns them, and therefore

has ultimate control over which application or service gets what. If the DEVONthink

Pro Services menu items do not have shortcuts assigned, it is very likely that Mac OS

X gave them to another Services command or that they are used by the application

that is currently frontmost.

In Mac OS X 10.6 'Snow Leopard' and later you can manage your Services in System

Preferences > Keyboard > Keyboard Shortcuts > Services.

WHY DO THE SERVICES NOT WORK IN FIREFOX?

Services work only in Mac OS X applications based on the so-called Cocoa framework.

Examples for Cocoa applications are, e.g, Mail, Safari, TextEdit, and, of course, all

DEVONtechnologies applications. However, Firefox is a port of a Unix application not

completely based on Cocoa. Therefore, it does not support Services. Try using Camino

instead, a Cocoa browser based on the Firefox engine.

http://www.caminobrowser.org/
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DEVONTHINK PRO BEHAVES IRRATIONALLY

There is no software on this planet that has no bugs and if an application behaves

irrational there is a good chance that your have just found one. But there also can

be another cause: The application package could have become damaged, for example

during an update or through a bug in a totally unrelated piece of software on your

computer.

STRANGE APPLICATION BEHAVIOR

If something happens like the following

•  menus disappearing or silently refusing to do anything,

•  windows showing graphical artefacts,

•  or applications to opening at all or with strange error messages,

please try to trash the application package. Then empty your web brower's cache,

download the software in question again, and re-install it. In many cases this cures

the problem.

If this does not help try deleting DEVONthink Pro's preferences files located in '~/

Library/Preferences' and starting with 'com.devon-technologies.think'.
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STRANGE BEHAVIOR RELATED TO DOCUMENTS

If the strange behavior only happens when you deal with one particular document

it is likely that the document is damaged, was created in a very old or extremely

new file format that is no longer or not yet properly supported, or uses a damaged or

malfunctioning Quick Look plugin.

Please file a support ticket and attach the document in question, best packaged

as a .zip archive, so that we can have a look at it and check if it is a problem in

DEVONthink Pro or if it is just the file itself.

STRANGE BEHAVIOR OF TABS

With Zooom/2 installed, tabs in tabbed windows behave stragely, e.g. close by just

hovering the cursor over the tab. Another effect of Zooom/2 are scrolling problems in

e.g. iTunes. Disabling Zooom/2 solves the problem.

http://www.devontechnologies.com/redirect.html?id=osticket
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PROBLEMS SYNCHRONIZING WITH DEVONTHINK TO
GO

If you cannot properly synchronize your databases with DEVONthink To Go on your

device, please check the following:

•  Are both device and Mac properly connected to the same WiFi network?

•  Have you moved, replicated, or copied documents or groups to the Sync

group? Note that smart groups are ignored during synchronization.

•  Have you checked the database in question on the device on the database

selection screen?

If you still have problems with synchronizing, please first consult the Frequently

Asked Questions, and visit the user forum. Should this not solve your problem, click

here to contact the DEVONtechnologies support team.

http://www.devontechnologies.com/redirect.html?id=faq-dttg
http://www.devontechnologies.com/redirect.html?id=faq-dttg
http://www.devontechnologies.com/redirect.html?id=forum-dttg
http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=contact
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In the appendices you will find additional information that helps you getting familiar

with DEVONthink Pro such as a glossary of commonly used terms, a listing of the

Boolean operators that you can use in searches, and placeholders that you can use in

templates for yet 'targetless' WikiLinks.
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GLOSSARY

Become familiar with these terms to get the most out of working with DEVONthink

Pro.

INTERFACE ELEMENTS

•  Contextual Menu: The menu that appears when you right-click (or

Control-click) something; the contextual menu gives you access to

frequently used commands that deal directly with the clicked object.

Read more about the available contextual menus in the Documents and

Windows chapters.

•  Item list: A list of items stored in the database. Items can be documents,

groups, or smart groups.

•  View/Edit Pane: A part of the DEVONthink Pro main and document

windows that lets you view a document or, if possible, edit it. The view/

edit pane displays the content of your documents depending on their

type. See also p. 174ff

•  View (1): The layout for a DEVONthink Pro main window. You can

change the layout using the commands found in the View menu.

•  View (2): The display for the various document types inside the the view/

edit pane or a document window. See also p. 239ff
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•  Window: DEVONthink Pro uses three different types of windows: main,

document, and other windows. Main windows show lists of items and,

in some views, also the contents of the selected document, whereas

document windows show documents separately.

DOCUMENTS & GROUPS

•  Database: A collection of all documents stored in DEVONthink Pro. You

can create and open as many databases as you like.

•  Document: A file in the database; for example, a plain or RTF text, a

PDF, or an image. Technically a document is an entry in a database with

text, RTF, or image content. Sometimes referred to as 'content'.

•  Default Destination: The default destination group for incoming data. Set

in Preferences, Import tab.

•  Group: A collection of documents or other groups inside the database.

Similar to a folder in the file system. See also p. 134ff

•  Global Inbox: A special database serving as a destination for incoming

data. Always opened when DEVONthink Pro is started and accessible

through the sidebar.

•  Inbox: A special group for data coming in to a database. The inbox can be

set as the default destination in Preferences, Import tab.
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•  News Feed: A news feed is like a web page but splitted into multiple

newsbits. A feed reader or web browser can split the feed 'page' into its

parts and show each of them as a separate news and/or store it in a local

database. DEVONthink Pro can store feeds in a database and displays

them like a group which contents are updated live from the Internet as

the connected feed changes. Older news bits are kept, new bits are added

and marked as unread. When you add a bookmark that points to a feed

to a database, DEVONthink Pro tries to add it as a proper feed document

if possible. DEVONthink Pro can also be defined as the system's RSS

reader in Safari's Preferences.

•  Replicant: A document or a group that appears in more than one place in

the database. Unlike an alias in the file system, a replicant is not a real

document pointing to another file (usually the original), but only a second

entry in the table of contents for the very same document. Consequently,

there is no original; when you replicate a document you'll end up with

two replicants. See also p. 134ff

•  Sheet: A collection of records, structured sets of data, like a spread sheet

and presented in a table view. You can use records to store, for example,

addresses or list items. See also p. 257ff

•  Smart group: Not a real group but a 'saved search' that appears like a

group. Every time you visit this smart group, DEVONthink Pro runs the

attached search and displays it as the content of the group. Create smart



DEVONthink PRO 2.3.3 Documentation, page 385

groups using the search window or the smart group editor. DEVONthink

Pro creates a number of pre-defined smart groups when you create a new

database.

•  Trash: Stores all trashed items until you finally physically delete them

using DEVONthink Pro > Empty Trash.

TAGS

•  Tag: A tag is a different visual representation of a group. All documents

contained in a group which has not been excluded from tagging, have the

group's name 'attached' as a tag. Tags represented by a regular group

appear grey in all list of tags.

•  Ordinary tag: Tags created e.g. through the Tag bar or other means

are created in a special top-level group named 'Tags'. They are called

'ordinary tags' and in all list of tags they appear blue.

ITEM PROPERTIES

•  Flagged/Unflagged: Items can be checked or unchecked for your

personal use, e.g. for creating a to-do list, for maintaining a shopping list,

or for writing a list of project tasks.
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•  Locked/Unlocked: Items can be locked to keep them from being

unintentionally modified.

•  Read/Unread: Items can be marked read or unread which is useful for

captured or automatically downloaded news items or documents that you

want to read later. Unread items and groups containing unread items are

shown in bold.

The 'flagged' and 'locked' properties are indicated by icons. See also p. 391ff
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FAQ (PRODUCT-SPECIFIC)

GENERAL

What is the difference between the various editions? While all three editions of

DEVONthink as well as DEVONnote share many features, there are some noticible

differences. For instance, DEVONthink Pro is able to deal with more than one

database, features tables, forms, and categories, and comes with full AppleScript

support; and DEVONthink Pro Office comes with plugins for pro-grade email

archiving, paper capture, and Web sharing. You can find a complete listing of all

differences on the feature comparison page.

Which languages does DEVONthink Pro support? DEVONthink Pro supports

multilingual documents and Unicode and so supports all Asian languages including

Chinese, Japanese, and Korean, as well as non-Latin scripts such as Cyrillic, Hebrew,

and Arabic (including writing from right to left; use Format > Alignment > Writing

Direction  to adjust the writing direction).

Note: Asian languages, however, do not use word separators such as

white space or punctuation. When searching you need to use wildcards.

Use ~word or *word* in the search field or search window.

http://www.devontechnologies.com/redirect.php?id=product-dt-comparison
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How do I completely uninstall DEVONthink Pro? To completely remove

DEVONthink Pro from your Mac, see the instructions in the Read Me.

DATABASES

Can I use more than one database? Yes, DEVONthink Pro works with databases

stored in packages instead of a central folder. You can double-click these packages

like regular files to open the database, copy them over the local network (LAN) or

back up hard drive, or burn them to a CD-R or DVD.

How are my documents stored? DEVONthink Pro stores all documents in

a package, a folder that looks like a file that you can double-click or otherwise

manipulate like a regular file in the Finder.

Inside the 'Files.noindex' folder the actual documents are stored in sub-folders for

their respective type and further sub-folders that help DEVONthink Pro to quickly

locate them. Documents are never altered when you copied them into the database.

The file name of each documents is exactly the same as the corresponding document

name that you see in DEVONthink Pro.

In addition, the database package contains a set of ten index files named with

the suffix '.dtMeta' as well as a 'Settings.plist' file containing database-specific

preferences. Finally, the database package can contain one or multiple folders named
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'Backup.x'. They contain backups of the index files and are created automatically

by DEVONthink Pro's backup function. They do not contain copies of all actual

documents.

How can I move my database to another computer? Your database is a file with

the suffix '.dtBase2' and is probably stored in your Documents folder. It can be copied

to that or to another desired location on the other computer. If you cannot locate your

database, search for it using Spotlight, e.g. by searching for 'dtBase2'.

Note: In general, databases are self-contained, so all one has to do is

move it to another computer, open it and start using it. But if some of

the content has been indexed instead of imported, it will be necessary

to also move the externally linked files to the other computer in such a

way that the Paths to the external files remain valid. If everything is

in your Documents folder on the first computer, copying the externally

linked folders and files to the Documents folder of the second computer

will probably work.

Always quit the DEVONthink Pro application before copying or moving

a database, as copying an open database may result in an incomplete or

damaged copy.
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Can I put my databases on my server? Theoretically yes. However, as

DEVONthink Pro is not yet multi-user capable, only one copy of DEVONthink Pro

can access a database at a time. DEVONthink Pro uses a 'lock file' to keep other

copies of the software from accessing the database at the same time. If you use a

setup like this, DO NOT override the appearing warning message or you will create

database corruption.

Can I share my DEVONthink database using WebDAV or DropBox? You can,

but it is definitely not recommended as WebDAV servers do not fully support all

properties of real hard disks. See below.

Can I synchronize databases between multiple computers? We are currently

working on a synchronization module that will allow you to sync databases between

multiple computers either directly or via file servers or Dropbox. Please check our

President's blog for up-to-date information.

In the meantime you can try to use a third-party product called 'DevonSync' made by

Wooden Brain that synchronizes DEVONthink databases bi-directionally. DevonSync

is not officially supported by us and we do not give any guarantee for your data's

safety.

http://www.devontechnologies.com/redirect.html?id=blog
http://www.devontechnologies.com/redirect.html?id=blog
http://www.woodenbrain.com/
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ICONOLOGY

Additional icons behind item names, e.g. in main windows,  indicate that the item

has been indexed instead of imported, is locked, has a comment attached, or is

scripted. Groups also serving as tags show, if necessary, a tag icon. Depending in your

preferences replicants, duplicates, or replicated duplicates are also indicated with a

little grey icon instead of appearing in color.

•  Item has been flagged See also p. 134ff

•  Item is indexed, not imported See also p. 73ff

•  Item is locked See also p. 134ff

•  Item has a comment See also p. 205ff

•  Item has a script attached See also p. 350ff

•  Group is a tag, too See also p. 392ff

•  Item is a duplicate

•  Item has one or more replicant(s)

•  Item is a duplicate but also has one or more replicant(s) See also p. 73ff



DEVONthink PRO 2.3.3 Documentation, page 392

TAGGING

DEVONthink Pro supports tagging in a way that makes groups and tags

interchangeable. While this concept may sound a bit strange at first you will soon

discover why it is a smart way to approach tags and group and to bring both together.

INTRODUCTION

Technically, tags and groups are identical: both are simply entries in a table that are

somehow 'attached' to an item, usually a group or document. The difference is that

tags are visualized as 'labels' attached TO the item while groups are visualized as

groups CONTAINING the item. They are presented differently but internally they

are the same.

DEVONthink Pro treats groups as tags and tags as groups. When it shows you the

tags associated with an item it presents you with a list of all groups that the item is

part of and that have not been excluded from tagging.

Example: A document is located in the group 'Science > Paleontology

> Dinosaurs'. Consequently its tags are 'Science', 'Paleontology', and

'Dinosaurs'. Now you create a sub-group of 'Dinosaurs' named 'Land-

living' and move the document into the new folder. Automatically it is

now tagged with 'Science', 'Paleontology', 'Dinosaurs', and 'Land-living'.
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The same happens when you replicate the document into multiple groups: It is

tagged with the names of all enclosing groups (that are not excluded from tagging) of

all its replicants.

When you assign a tag using DEVONthink Pro's user interface, move a document, or

replicate it to another group, this is what happens:

•  Assign a tag: The item is replicated to the Tags group.

•  Removing a tag: The item's replicate in the Tags group is deleted.

•  Adding an item to a group: The group's name and the names of all groups

containing the group appear as tags attached to the item.

•  Moving an item: The new group's name and the names of all groups

containing it appear as tags attached to the item.

•  Replicating an item: The new group's name and the names of all groups

containing it appear as tags attached to the item, too.

•  (Auto-) Classifying an item: This places the item into a new group and

replaces all assigned tags.
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THE TAGS GROUP

Every DEVONthink Pro database contains a top-level group named 'Tags'. It is used

whenever you add a tag to an item e.g. through the tag bar, for which not yet a group

exists. In this case DEVONthink Pro creates a group for the tag in the Tags group

and places a replicant into it.

When you rename a group here all items associated with it (means: that have a

replicant here) will show this change.

USING TAGS

To use tags for selecting documents, finding them, or browsing tags DEVONthink

Pro offers the following options:

•  Tags view: The tags view allows you to browse your documents by

tags. In the tags view select a tag to display all items which have this

tag assigned. Choose multiple tags, e.g. by clicking anothe one with

Command held, shows all items carrying all selected tags.

•  Smart groups: Use smart groups to search for items with given tags.
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Wherever tags are shown, ordinary tags (tags created in the special Tag group)

appear blue, tags that are also regular groups appear grey. Tags, e.g. in the Tag

bar, also show a pop-up menu when you click their downward triangle. It shows

related tags which can be added to the item, and tags represented by a group can be

revealed.

ALIASES AND EXCLUDING FROM TAGGING

DEVONthink Pro also honores aliases added to groups. You can add 'alternative

names' to a group in it's Info panel and later use these alternative names as a tag.

Example: In the Info panel of the group 'Dinosaurs' you have added

'Dinos' as an alias. You can now tag items with 'Dinos' and they will

automatically moved or replicated to the 'Dinosaurs' group.

Groups that you don't want to use as tags can be excluded from tagging. Select it and

open the Info panel. Check Exclude from ... Tagging and the group will no longer be

shown as a tag for items contained in it.
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OPENMETA

OpenMeta is an open standard for storing tags with files in the file system. Using

OpenMeta applications can add tags to files and let other compliant applications read

them.

DEVONthink Pro supports OpenMeta when importing and exporting files. Files

stored in the database are not tagged in OpenMeta-style but assigned tags will be

added to the files as soon as you export them.

http://code.google.com/p/openmeta/
http://code.google.com/p/openmeta/wiki/OpenMetaApplications
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FILE FORMATS

DEVONthink Pro supports a variety of text and image formats, including plain text,

Rich Text Format (RTF), PDFs, all image formats supported by by Mac OS X and

QuickTime as well as all file formats for which a Quick Look preview is available.

TEXT FILES

DEVONthink Pro supports plain text files (as well as Mac OS 9 SimpleText and

Tex-Edit Plus files) in all encodings supported by Mac OS X, including Unicode and

UTF-8. By default, DEVONthink Pro automatically recognizes the encoding and the

line endings used by Mac, Windows, or Unix operating systems.

•  Extensions: adb, ads, aln, ans, applescript, bat, bib, bibtex, c, cls, cmd,

command, con, cp, cpp, crash, css, csv, dot, em, embl, erl, err, f, f70, f90,

fasta, for, fpp, gb, genbank, gff, h, haml, hlp, hpp, hs, hrl, id2xf, inc,

js, lhs, lisp, log, lst, m, markdown, md, mdwn, mi, mis, ml, mly, mm,

mmi, mml, msf, org, p, pas, pir, pl, pp, py, rb, rc, sass, scm, scpt, scptd,

scriptSuite, scriptTerminology, sdef, seq, sh, sqc, sql, ss, strings, sty, sw,

swiss, tab, tcl, tex, text, textile, txt, v, vcf, wrl, x, xchatlog, xd, ychat

•  HFS type codes: TEXT, ttro, TERO, sEXT, SimpleText, scpt, osas, APPL

(AppleScripts wrapped in an executable application)
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•  Automatic recognition: DEVONthink Pro also recognizes plain text file

formats defined by third-party applications.

Note: DEVONthink Pro imports tabulated text files and vCards, such

as .tsv, .csv and .vcf, as sheets. For BibTeX files, keys are supported and

added to the sheet.

Rich Text Format: For Rich Text Format (RTF) files, DEVONthink Pro recognizes

Mac, Windows, and ANSI encodings as well as Mac OS X RTF documents with

attachments (RTFD).

•  Extensions: rtf, rtfd

•  HFS type codes: RTF

OFFICE AND OTHER DOCUMENTS

DEVONthink Pro imports many Office file formats such as Microsoft Office and

OpenDocument documents as well as all other file formats for which Quick Look

support is available, e.g. Mellel (version 2.6 and higher) files, AppleScript scripts or

text clippings.

Note: Quick Look is Mac OS X 10.5's mechanism for displaying a preview

of almost any file type. In the Finder this function is invoked by pressing

the Space bar. Quick Look requires the maker of the software that

http://www.microsoft.com/mac/
http://www.openoffice.org
http://www.mellel.com
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writes the document to add additional preview information inside the

file (package) or to provide a Quick Look plugin embedded into the

application itself or installed in a Library folder. If neither DEVONthink

Pro nor the Finder can preview a document format that you want to use,

please contact the maker of the software and ask it to provide Quick Look

support for its file format.

Due to the nature of Quick Look, the contents of a document that is displayed using

this technology, e.g., an Apple Pages file, is sometimes not selectable. Depending on

the file format, for some files a plain or rich text alternative is available, e.g., for

email messages. Where available use the Text View/Preview toggle button in the

document's navigation bar to switch back and forth between plain text and preview

modes.

Additional Quick Look plugins can be found e.g. on QLPlugins.com.

CHAT LOGS

DEVONthink Pro understands the text format of logs generated by Adium, iChat or

Yahoo Messenger. You can import them like rich text files.

•  Extensions: chat, chatlog, ichat

•  HFS type codes: YMSG

http://www.qlplugins.com
http://adium.im
http://www.yahoo.com


DEVONthink PRO 2.3.3 Documentation, page 400

For Adium, Second Life, and BluePhone Elite DEVONthink Pro offers a number of

scripts that directly import all available chat, SMS, and phone logs.

PDF, POSTSCRIPT, SKIM

DEVONthink Pro imports and displays Portable Document Format (PDF) files, Skim

PDF packages, and PostScript files. DEVONthink Pro extracts the readable text

portions of the PDF making it possible to search the text of the PDF and to use See

Also & Classify. PostScript files are converted to PDF on-the-fly.

It is possible to manually convert imported PDFs to plain text or RTF by using Data

> Convert.

Note: It's not yet possible to extract text from protected PDF files.

Protected PDFs are imported as simple images. You can correctly

view the PDF in DEVONthink Pro, though, after entering the correct

password.

http://www.adiumx.com
http://www.secondlife.com
http://mirasoftware.com/BPE2/
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BOOKMARKS

Drag or paste Internet addresses from any Internet application, or Internet location

files from the Finder, to DEVONthink Pro to create a bookmark documents.

DEVONthink Pro is especially optimized to accept Safari Bookmarks. Use bookmarks

in DEVONthink Pro to integrate 'live' content from the Internet seamlessly with local

documents.

•  Extensions: dtLink, ftploc, fileloc, inetloc, mailloc, newsloc, url, vncloc,

webloc

•  HFS type codes: ilht, ilft, ilfi, ilma, ilnw, ilaf, ilat, ilns, ilge, ilvn, LINK

HTML AND XML

In addition to the text encodings already listed, DEVONthink Pro supports the

standard HTML transcriptions for special characters (for example German umlauts

and French accents). HTML can also be converted to plain text using Data > Convert. 

XML files of any kind can also be imported and are displayed with syntax coloring.

Preference property lists of Mac OS X 10.4 and higher are stored in a binary format

and are converted on-the-fly to readable XML.
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Also, DEVONthink Pro supports Web archives containing HTML pages including all

necessary images for displaying them offline.

•  Extensions: asp, aspx, cgi, cfm, dtd, ent, htm, html, idata, jhtml, jsp,

mhtml, ompl, ooutline, php, php3, php4, phtml, plist, rdf, rsd, rss, sdef,

sgm, sgml, shtm, shtml, tbx, wml, xbl, xhtm, xhtml, xml, xmloutline, xsl,

xslt, webarchive

•  Automatic recognition: DEVONthink Pro also recognizes HTML and

XML file formats defined by third-party applications.

TABULAR DATA

DEVONthink Pro imports various structured file formats and stores their contents

as sheets (e.g. tab-separated values, comma-separated values (TSV/CSV) and iData

files).

•  Extensions: csv, idata, tdf, tsv

Note: Due to limitation in Mac OS X's Cocoa memory management,

sheets are currently limited to 32,767 records.

http://www.idata3.com/
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OUTLINER FORMATS

DEVONthink Pro is able to import outliner files created by OmniOutliner 2.x

and other applications in the OPML (Outlining Processor Mark-up Language) file

format. When importing OPML files, DEVONthink Pro recreates a groups hierarchy.

DEVONthink Pro also exports documents in the standard OPML format generating

one OPML file out of multiple groups and documents.

If DEVONthink Pro recognizes an imported OPML file as a news feed a new feed

document is created instead of an outline. Feeds can also be exported as OPML for

exchange with third-party newsreader.

•  Extensions: .opml

IMAGE FILES

DEVONthink Pro imports all image formats supported by Mac OS X and QuickTime.

•  Extensions: bmp, cur, eps, fax, fpix, fpx, gif, icns, ico, jpeg, jpg, mac, pct,

pdf, pict, png, pnt, pntg, psd, qti, qtif, rgb, sgi, targa, tga, tif, tiff; Mac OS

X 10.4 or QuickTime 7 only: jp2, dng, exr, raw

•  HFS type codes: 8BPS, BMPf, EPSF, FPix, GIFf, 'ICO ', JPEG, 'PDF ',

PICT, PNGf, PNTG, 'SGI ', TIFF, TPIC, qtif

http://www.omnigroup.com
http://en.wikipedia.org/wiki/OPML
http://www.apple.com/quicktime
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Installed applications or services can add support for other file formats to Mac OS X

and therefore to DEVONthink Pro as well.

Note: PICT files can still be imported but Mac OS X 10.5 does no longer

display them.

MULTIMEDIA FILES

DEVONthink Pro displays or plays QuickTime movies, sounds, Flash movies and

Shockwave animations. To add movies, sounds, or MP3s to DEVONthink Pro, import

them like any other file to your database. Multimedia files can also be dragged into a

rich text document to integrate them with text and images.

•  Extensions: 3g2, 3gp, 3gp2, 3gpp, aac, adts, aif, AIF, aifc, AIFC, AIFF, aiff,

amc, amr, atr, AU, au, avi, bwf, caf, cdda, cel, dif, dv, dvd, flc, f4v, fli, gsm,

kar, m15, m1a, m1s, m1v, m2a, m2v, m3u, m4a, m4b, m4p, m4v, m75,

mid, midi, mov, MOV, mp2, mp3, MP3, mp4, mpa, mpeg, mpg, mpm, mpv,

mqv, MQV, pls, qht, qhtm, qt, qtpf, qtz, rtsp, sd2, sdp, sdv, skin, smf, smi,

smil, sml, SND, snd, swa, swf, ulw, ULW, vfw, wav, WAV

•  HFS type codes: .SMI, .WAV, 3gp2, 3gpp, adts, AIFC, AIFF, ALAW, 'amc ',

'amr ', attr, caff, cdda, DAVI, DIVX, dvc!, embd, 'FLI ', grip, 'GSM ', hmov,

'M1A ', 'M1V ', Midi, MooV, 'Mp3 ', 'MP3 ', MPEG, 'MPG ', MPG2, MPG3,

http://www.apple.com/quicktime
http://en.wikipedia.org/wiki/Adobe_Flash
http://en.wikipedia.org/wiki/Adobe_Shockwave
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mpg4, MPGa, MPGA, MPGv, MPGV, MPGx, mxfd, PLAY, qhtm, rtsp,

Sd2f, 'sdp ', 'sdv ', SMIL, SwaT, SWFL, ULAW, 'VfW ', WAVE

DEVONthink Pro also supports QuickTime file types provided by third-party

components.
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TEMPLATES

DEVONthink Pro comes with a number of pre-fabricated templates for general use.

Use them to add e.g. a task list, a quote, or whole group structured, e.g. for project

management, to your database.

MANAGING TEMPLATES

Templates are regular files stored in the Finder in the folder '~/Library/Application

Support/DEVONthink Pro 2/Templates.noindex'. Navigate to this folder in the Finder

to manage your templates, rename them, organize them in sub-folders, or delete

them.

More templates are available as extras. See also p. 234ff

PRE-FABRICATED TEMPLATES

DEVONthink Pro comes with the following pre-fabricated templates which can serve

as examples of what you can do with the template feature.

General use:

•  Annotation: Adds an annotation for a selected document. The annotation

is put next to the selected document (and is replicated to all other
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instances of the document if necessary) and contains a link to the

annotated item. This template links to the current page of a PDF

document if possible. If there is already an annotation for the selected

document, no second one is created but the existing annotation is opened.

•  Note: Adds a new note. If the clipboard contains text it is automatically

inserted for you; if it contains an Internet address (URL) it is added to

the note's link list.

•  Phone Note: Adds a new phone note. The current date and time is

automatically inserted.

•  Project: Adds a simple project group structure including an 'About this

project' document. The smart template ask for a project name, retrieves

your name, department, email address, and phone number from your

address book card and adds all this information to the 'About this project'

document.

•  Task List: Adds a simple task list.

•  Web Browser: Adds an HTML document that allows you to use

DEVONthink Pro like a regular web browser. Open this document, enter

an Internet address into the address field and click the Go button to visit

the web site.

Accounts & Passwords:

•  Online Account: Adds a document for storing online account details.
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•  Serial Number: Adds a document for storing serial numbers.

Addresses & Dates:

•  Address Book Card: Adds the card selected in Address Book as a rich text

document to your database.

•  iCal Event: Adds an iCal event you have copied to the clipboard (!) as a

rich text document to your database. You need to copy the event to the

clipboard because iCal does not provide a mechanism to retrieve the

selected event.

Classifications:

•  Decimal Filing System: Adds ten groups for the decimal filing system

using in many companies in Germany, Europe, for filing (scanned) paper

documents.

•  Dewey Decimal Classification: Inserts a group with sub-groups that

builds the first levels of the Dewey Decimal Classification. Use it for

databases that contain knowledge spanning many subjects.

•  Library of Congress Classification: Inserts a group with sub-groups that

builds the first levels of the Library of Congress Classification. Use it for

databases that contain knowledge spanning many subjects.
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Education:

•  Cornell Notes (Pages): Adds an Apple Pages document that allows you to

write down notes in Cornell style.

•  Cornell Notes (rich text): Adds a rich text document that allows you to

write down notes in Cornell style.

•  Quote (from clipboard): Adds a rich text document for a quote or citation.

The clipboard content is automatically inserted and if it's an Internet

address (URL) it is automatically made clickable.

•  Reference (from Bookends): Adds the reference selected in Bookends to

your database.

•  Reference (from Endnote): Adds the reference selected in Endnote to your

database.

•  Reference (from Sente 6): Adds the reference selected in Sente 6 to your

database.

Office:

•  Apple Numbers/Pages document: Adds empty Numbers or Pages.

•  Microsoft Excel/Word document: Adds empty Excel or Word documents.

•  OpenOffice Calc/Writer document: Adds empty OpenOffice documents.

This smart template checks whether OpenOffice is installed or not before

adding the document.
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Registers:

•  1—31: Adds 31 groups, numbered 1 through 31.

•  A—Z: Adds 26 groups, named A through Z.

•  Days of the Week: Adds groups for the days of the week.

•  Months: Adds groups for the twelve Christian months.

Search:

•  PubMed: Runs a query in PubMed and adds the resulting documents

formatted as rich text documents to your database.

Smart Groups:

•  Email ... Videos: Adds smart groups selecting documents of a given kind.

•  Last ...: Adds smart groups selecting documents modified within a given

period.

•  Large Documents: Adds a smart group selecting documents larger than 5

MB.

•  PDF (not searchable): Adds a smart group selecting all PDF documents

that don't contain machine-readable text.

Tabs:

•  Open Bing: Opens the Bing web page in a new tab.

http://www.bing.com
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•  Open Google: Opens the Google web page in a new tab.

•  Open Location: Asks for a URL and opens it in a new tab.

Toolbar: By default this contains no templates. Add you own templates here and add

them also to the toolbar of main and search windows using View > Customize Toolbar.

TEMPLATE PACKAGES

Besides the more complex smart templates DEVONthink Pro supports template

packages. They are folders with the file name extension '.dtTemplate' and contain

one or multiple folders, one for each supported language. This way you can let

DEVONthink Pro import the files in the right language depending on the system

language.

In addition you can use the following placeholders in your file or folder names of your

templates packages as well as in contained rich text, plain text, HTML, or XML files.

During import they are replaced with actual data.

•  %time%: The current time

•  %date%: The current date

•  %shortDate%: The current date in short format

•  %longDate%: The current date in long format

•  %monthname%: The month name of the current date

http://www.google.com
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•  %weekday%: The week day name of the current date

•  %day%: The day number of the current date

•  %month%: The month number of the current date

•  %year%: The year number of the current date

•  %username%: The user name

•  %fullUsername%: The user's full name

•  %organization%: The user's organization from Address Book

•  %emailAddress%: The user's email addresses from Address Book

•  %host%: The host name

•  %databaseName%: The database name

•  %databasePath%: The database's path

•  %groupName%: The name of the parent group

•  %clipboard%: The clipboard contents as plain text

•  %styledClipboard%: The clipboard contents as rich text

•  %clipboardLink%: The clipboard contents as clickable rich text link if the

clipboard contains a valid URL
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SMART TEMPLATES

Most of the pre-fabricated templates are 'smart templates': They are not simple files

but actually AppleScript packages that are executed when you select it the in the

Data menu.  These packages contain both script code as well as the actual templates

that they insert into your database. This has a number of advantages:

•  The script can choose a localized template for your language; also

possible using a template package.

•  The script can add information to the pre-fabricated template, for

example the current date and time or data from the Web.

•  The script can act intelligently on data on the clipboard: If it's a simple

text it adds the text, if it's a URL it adds it to a different area of the

document and makes it clickable.

•  The script can check if a certain application is installed, e.g. OpenOffice,

before adding a document for it.

CREATING SMART TEMPLATES

Smart templates are regular AppleScript scripts or script packages with a special

extension to distinguish then from regular AppleScript scripts:

•  .templatescript: A normal script, regular extension would be: '.scpt'
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•  .templatescriptd: A script package, regular extension would be: '.scptd'.

Script packages are folders that appear like a file. They can hold both

script code and additional files.

To make your own smart templates have a look at the pre-fabricated smart

templates:

•  Step 1: Navigate to '~/Library/Application Support/DEVONthink Pro 2/

Templates.noindex' in the Finder and show its content

•  Step 2: Make a copy of a template, e.g. of 'Note.templatescriptd'.

•  Step 2: Rename the template, replacing the extension '.templatescriptd'

with '.scptd'. This makes it a regular script.

•  Step 3: Double-click this script to edit it in Script Editor.

•  Step 4: Try out the script by simply running it in Script Editor.

•  Step 5: When you're satisfied, close the script and in the Finder rename it

so that the file name extension '.scptd' becomes '.templatescriptd' again.

•  Step 6: Close and open DEVONthink Pro again. Your new script should

be visible in Data > New now, ready for you to use

Each of the pre-fabricated smart templates demostrate other aspects of what you

could do with them. Just have a look at all of them to learn more about how you

can create your own smart templates. You can find more about AppleScript and

DEVONthink Pro in the chapter Scripts.
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Smart templates as well as template packages can be double-clicked in the Finder to

install them.
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WEB SITE EXPORT TEMPLATES

For the export as web site, DEVONthink Pro uses templates available in ~/Library/

Application Support/DEVONthink Pro/Websites/ to create HTML files from

documents. You can choose the template in the save dialog that appears when you use

File > Export > as Website

In the HTML templates, the following placeholders can be used:

•  %databasePlusLocation%

•  '%comment%

•  %url%

•  %tags%

These placeholders will be replaced with actual information during the export. The

placeholders will only be replaced in documents that are converted to HTML during

export, namely plain text, rich text, Microsoft Office/OpenOffice documents, scripts,

chat logs, and sheets.
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SEARCH OPERATORS

In the toolbar search field you can use standard and extended Boolean operators,

parenthesis, and more to fine-tune your search.

The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder,

Spotlight, common search engines as well as common programming languages

such as C, C++, Objective-C, Java, and JavaScript. The complexity of the query is

unlimited.

CASE

All terms are case-insensitive. You may, if you wish, use capitalization for proper

names in a query, but DEVONthink Pro will ignore case in interpreting the query.

PRECEDENCE OF TERMS

Search terms and associated operators will be interpreted from left to right, except as

modified by including portions of the query within parentheses.
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WILDCARDS

You can replace parts of words with wildcards matching one, multiple, or a range of

characters:

•  ?: Matches exactly one character.

•  *: Matches none, one, or multiple characters.

•  [a-b]: Matches one character of the range 'a' through 'b'.

•  [abc...] or [a|b|c|...]: Matches one character out of the given list of

characters.

•  [^...]: Matches one character that is not contained in the given list or

range.

BOOLEAN OPERATORS

The operators (often called Boolean operators) are words or symbols that establish

logical rules for the terms in the search query. If no operator is given, DEVONthink

Pro implies AND. The available Boolean operators are:

•  term1 AND term2: Contains term1 AND term2

•  term1 BUT term2: Contains term1 AND term2

•  term1 OR term2: Contains term1 OR term2

•  term1 XOR term2: Contains term1 or term2, but not both
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•  term1 EOR term2: Contains term1 or term2, but not both

•  NOT term: Does not contain term

•  "term1": Contains the string term1, in exactly this form

Beside the classic Boolean operators, DEVONthink Pro uses a number of operators

that can usually only be found on high-end databases. Use them as a replacement for

AND and "quotes" to fine-tune your query.

•  term1 OPT term2: term1 needs to occur, term2 can. If term2 does, the

found document ranks higher in the search results.

•  term1 NEAR term2: term1 occurs 10 words or less before or after term2

•  term1 NEAR/n term2: term1 occurs n or less words before or after term2

•  term1 BEFORE term2: term1 occurs before term2

•  term1 BEFORE/n term2: term1 occurs n or less words before term2

•  term1 NEXT term2: term1 occurs right before term2 (shortcut for

BEFORE/1)

•  term1 NEXT/n term2: term 1 occurs n or less words before term2

(synonym for BEFORE/n)

•  term1 AFTER term2: term1 occurs after term2

•  term1 AFTER/n term2: term1 occurs n or less words after term2

•  ~term1: Contains all words that begin or end with term1 (words

containing term1 as a part of the word; depends on the queried search

engine)
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For convenience, some of these operators can also be abbreviated using commonly

used symbols:

•  AND: &, &&, +

•  OR: |, ||

•  XOR: ^, ^^

•  NOT: !, -

Note: The symbols above are also used by the Finder and Mac OS X's

Spotlight for searches. Enter the vertical ruler character for the OR

operator by pressing Option-7 (e.g. on European keyboards).

Operators are evaluated in the following priority: parenthesis > phrase/hyphens >

(NOT) BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with

same priority but without parenthesis are evaluated from left to right.

DATE COMPARISON OPERATORS

For comparing dates in smart groups the following operators are available:

•  < date: Matches items that were created/edited/viewed before date.

•  <= date: Matches items that were created/edited/viewed before or on

date.

•  >= date: Matches items that were created/edited/viewed after or on date.
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•  > date: Matches items that were created/edited/viewed after date.

WHITE SPACE HANDLING

Words concatenated by non-white separators (e.g. www.devon-technologies.com or

page_id) are treated like phrases put into "quotes". Words separated by hyphens

are handled like word1word2 OR "word1 word2". Characters separated by dots

are considered to be abbreviations and therefore handled like words separated by

hyphens, e.g. the term t.a.t.u is equal to "t a t u" OR tatu

EXAMPLES

Using any or all of the operators and rules layed out above you can create complex

queries that find exactly what you are looking for. Here are some example queries

that show how the operators are used.

Example: Devonian Dinosaurs

This query looks for all documents that contain the words 'devonian' and 'dinosaurs'.

Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro
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This query looks for documents that contain the words 'Steve' and 'Jobs' not farther

away from each other than ten words as well as the word 'iMac' (no specific position

relative to Steve and Jobs) but not the word 'MacBook'. The word 'Pro' does not need

to occur but if it does, the document is ranked higher in the list of search results.

Example: Paracetamol NEAR (~effect OR impact) AND ((side OR

second*) NEAR/2 ~effect)

This query looks for documents containing the word 'Paracetamol' near (within ten

words) to words either starting with 'effect' (and so also 'effects') or being 'impact'.

In addition, the document needs to contain the word 'side' or any word staring with

'second' within two words range from any word starting with 'effect'.
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TEMPLATE TAGS FOR WIKI-STYLE LINKS

In DEVONthink Pro you can create new documents by first selecting some text in a

rich text document and then making it a link using the contextual menu. When you

then click this link, DEVONthink Pro creates the new document using a template

you set in the Editing Preferences. In this template, can use the tags below to

automatically insert the name of the link, the current date or other information. See

also p. 143ff

•  %@: Name of link

•  %%: A '%' character

•  %a: Abbreviated weekday name

•  %A: Full weekday name

•  %b: Abbreviated month name

•  %B: Full month name

•  %c: Shorthand for 'g%X %x,' the locale format for date and time

•  %d: Day of the month as a decimal number (01-31)

•  %e: Same as %d, but does not print the leading 0 for days 1 through 9

•  %F: Milliseconds as a decimal number (000-999)

•  %H: Hour based on a 24-hour clock as a decimal number (00-23)

•  %I: Hour based on a 12-hour clock as a decimal number (01-12)

•  %j: Day of the year as a decimal number (001-366)

•  %m: Month as a decimal number (01-12)
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•  %M: Minute as a decimal number (00-59)

•  %p: AM/PM designation for the locale

•  %S: Second as a decimal number (00-59)

•  %w: Weekday as a decimal number (0-6), where Sunday is 0

•  %x: Date using the date representation for the locale, including the time

zone

•  %X: Time using the time representation for the locale

•  %y: Year without century (00-99)

•  %Y: Year with century (such as 1990)

•  %Z: Time zone name (such as Pacific Daylight Time)

•  %z: Time zone offset in hours and minutes from GMT (HHMM)
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METADATA

DEVONthink Pro stores a large number of metadata fields internally when importing

documents from the file system, e.g. from PDF, RTF, MP3, EXIF/IPTC, HTML, and

email messages as well as from all files that deliver metadata through the Spotlight

metadata importer. Here's an (incomplete) list of theoretically supported fields:

General:

•  Title

•  Headline

•  Subject

•  Creator

•  Producer

PDF and RTF:

•  Description

•  Copyright

•  Comment

•  URL

•  Keywords
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Electronic correspondence:

•  Authors

•  Author email addresses

•  Recipients

•  Recipient email dddresses

•  Email addresses

Electronic publications:

•  Album

•  Composer

•  Contributors

•  Publishers

•  Editors

•  Organizations
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FAQ

General questions 428

Release schedules, Mac OS X, and Windows 430

Purchasing 432

Mac App Store 435

Your software license 436

Product-related questions 438

Do you have questions regarding our licensing policy, our products in the Mac App

Store, or specific questions about DEVONthink Pro?
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GENERAL QUESTIONS

Do you have any job opportunities? Yes, we may. Please visit our Work

@ DEVONtechnologies page for more information about current open jobs at

DEVONtechnologies.

Can I be a beta tester? Maybe. Our beta tester selection process is very deliberate;

we try and select our beta testers carefully so that we're not wasting anybody's time,

yours and ours. We're looking for people who can provide us with feedback quickly

and clearly, who use different hardware and software from our other testers, and who

are willing to send us their personal data if it's needed for debugging.

If you want to be a beta tester, the best way to catch our eye is to be active in our user

forums. We often ask active participants on the user forums if they can help us test

particular features and new products. You can, of course, simply contact us.

Is the documentation available in my language? The online and PDF

documentation is only available in English at the moment. Localizing documentation

and other text-intensive materials to Deutsch, Francais, etc. is cost-intensive and

error-prone so that we have decided to concentrate our resources on developing

stable, robust, and feature-rich software. We will have localizations of the online help

etc. as soon as we feel we have the necessary resources.

http://www.devontechnologies.com/redirect.html?id=jobs
http://www.devontechnologies.com/redirect.html?id=jobs
http://www.devontechnologies.com/redirect.html?id=contact
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Where does the name DEVONtechnologies come from? "Devonian (after Devon

County, England), the geologic period from 410 to 360 million years ago. Also called

the Reptile Age or Age of Fishes. First amphibians appeared on the land, that until

then was only inhabited by trees and other plants — it was the departure into a new

age." Named after the Devonian period, the DEVONtechnology marks the departure

into a new age of data processing.

Note: Ray Troll has even created songs and other art about this

extremely important evolution step.

http://www.trollart.com/
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RELEASE SCHEDULES, MAC OS X, AND WINDOWS

When is the next release coming We try not to announce precise timelines or

feature lists for future releases, as we are a small software company with limited

development resources; if one of us should happen to get the sniffles, or if there are

other outside factors we need to devote our limited time to, it can easily impact our

intended development schedules.

In planning releases, we try to strike a balance among:

•  responding to customer requests,

•  the needs of our partners,

•  supporting new operating systems features,

•  providing consistent features across the product line,

•  working efficiently within the structure of the code, (similar features

often get handled at the same time),

•  various business needs.

We cannot make any assumptions on how those various factors will impact our

daily workflow; in fact, it's often impossible to predict the final release date

accurately when we start new projects. We try to plan our releases with a long term

perspective so that they ultimately serve the needs of our customers, even if they

don't necessarily get in everyone's favorite feature request every time.
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Why are your applications not compatible with my pre-release version of

Mac OS X? In the past, we've noted that compatibility issues with a new major

release of the operating system are usually resolved by Apple in the final stages

before its release, and don't require any action on our part. If you are already using a

pre-release version of Mac OS X, please check if our applications work with a newer

pre-release, or wait until it reaches the release candidate status. We will then make

all necessary adjustments for making our apps run on the first official release of the

new version of Mac OS X.

Any chance of a Windows versions of your products? We're very commited to

Mac OS X and the superior Cocoa environment. For most of our applications, porting

them to Windows would take longer than it would to rewrite them from scratch

on the Mac. If you need to use Windows software but still don't want to miss our

products consider running Windows on a Mac.

http://www.virtualbox.org
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PURCHASING

How do I purchase an upgrade? Please use DEVONthink Pro > Check Upgrade

Options  to find out what you need to upgrade and how much the upgrade is for you.

If this option is not available in your copy of DEVONthink Pro this application might

not be upgradable. Please visit the Upgrade Assistant on our web site instead.

What is your policy on software updates? Usually, all minor updates ('dot

updates', such as version 1.2 to 1.3) to our applications are free and require neither

purchasing an upgrade nor requesting a fresh license code. We charge for major

upgrades, though, such as version 1.x to 2.x. If you purchased your license in our

online shop within a reasonable time frame before a paid upgrade release (between

30 days and 6 months, announced on our website), we will provide you with a free

upgrade. If you purchased this application on the Mac App Store click here.

Can I get the bundle discount also later? Bundles are cheaper than multiple

single licenses because a bundle means less fees for the shop provider. But we grant

the bundle discount under certain circumstances. Please contact our sales staff if you

purchased one of the bundled produts within the last two weeks.

http://www.devontechnologies.com/redirect.html?id=upgrade
http://www.devontechnologies.com/redirect.html?id=contact
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Do you give a discount to students and educators? Yes, we give 25 percent off

the regular price of DEVONthink, DEVONagent, DEVONnote and the Infoworker's

Bundle to students and educators. We also give volume discounts to institution or

faculties. Please visit our Students, Educators and NPOs page.

Do you offer NPO licenses? Yes, we offer free licenses to non-profit organizations

(NPOs) in the sense of charities. Learn more about our NPO program.

Can I use your software on multiple computers? Yes, our license explicitly

allows one and the same person to use our application non-simultaneously on

multiple Macs. So, for example, if you install one of our products on a laptop, your

office Mac, and your home Mac, you may do so as long as you only use one of them at

a time.

I have no credit card. How can I purchase your software? We are selling

currently through the online sales agent Share*It to keep our administration as lean

as possible. If you don't have a credit card, you can also pay via PayPal or by purchase

order, wire transfer, or even cash. See our online shop for more details.

In addition we are also selling some of our products through the Mac App Store.

Please open the App Store application on your Mac to learn more about which

payment options Apple offers.

http://www.devontechnologies.com/redirect.html?id=students
http://www.devontechnologies.com/redirect.html?id=students
http://www.share-it.com
http://www.devontechnologies.com/redirect.html?id=shop
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Can I have more time for evaluating your apps? No problem. We happily give

out 30 day licenses for evaluation purposes. Choose Help > Support Assistant to

request a 30 day trial extension. This option is not available e.g. in DEVONagent

Express.

Why haven't I received my license code(s)? If you have purchased your license

in our online shop and if there have been no technical problems on our side, your

license codes have been sent out to you immediately after your purchase. Sometimes,

however, they get stuck in spam protection filters (either yours or your ISP's). Please,

check your spam protection filter, and if you cannot find the license codes there, use

Help > Support Assistant to get them resent to you. If this also doesn't work, please

contact us and we'll try to get your license codes to you as quickly as possible.

Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? License

codes for legacy versions are no longer available in our shop but even the latest

license codes are always backward-compatible: You can use a version 2.x license code

also for version 1.x of the same product. To use a legacy product simply purchase a

license for the most recent version of the product in our online shop and use it with

your legacy software.

http://www.devontechnologies.com/redirect.html?id=contact
http://www.devontechnologies.com/redirect.html?id=legacy
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MAC APP STORE

How can I upgrade apps purchased in the Mac App Store? By Apple's rigid

rules you couldn't. Upgrades are simply not available on the Mac App Store and

upgrade offers outside of the Mac App Store are not allowed. In some of our apps

there may be an upgrade option still available, though. Check the Read Me to see if

this is the case for you.

Can I get a refund? We freely refund licenses purchased in our own shop. For

apps purchased in the Mac App Store this is not possible, though, as Apple does not

provide a refund and license withdraw mechanism. Sorry.
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YOUR SOFTWARE LICENSE

Why does DEVONthink Pro not accept my license code? When you enter your

license code and the 'Register' button stayes greyed out, try to enter ALL details,

including your name and organisation, EXACTLY as they appear in our e-mail. Best

practice is to copy-and-paste name, organisation (if entered) and license code from

our email into the appropriate fields of the registration dialogue window. Also, please

check if you have obtained the correct code for the correct edition of your software

(e.g., a DEVONthink Pro license code will not work for DEVONthink Pro Office and

vice versa) as well as version (DEVONthink 2.x will not accept a 1.x license code).

I have lost my license code. How can I retrieve it? Use Help > Support Assistant

to open the Support Assistant which has an option to get your license code resent to

you. Alternatively visit the support area on our web site.

Does my license code work also for an older version? Yes, it does. All our

license codes are backward-compatible to legacy versions of the same product and

edition.

Why do I have to enter my license code again? You only have to re-enter your

license code after a complete reinstall of your system without a backup of your home

folder or when the license code file has been deleted, e.g. by a preferences cleaner

http://www.devontechnologies.com/redirect.html?id=support


DEVONthink PRO 2.3.3 Documentation, page 437

app. The license code is stored in a preference file in '~/Library/Preferences' (where

~ is your home folder). As long as this file is intact, you'll NEVER have to enter your

license code again.

Why does my DEVONthink Pro 1.x license not work anymore? DEVONthink

Pro with version numbers greater than 1.x are paid upgrades. To use them you may

need a new license code. Please use DEVONthink Pro > Check Upgrade Options  to

find out what you need to upgrade and how much the upgrade is for you.

Why does your application say that it expired? When we release a public beta

of one of our applications, we remove the usual trial restrictions but make it expire

at the end of the beta period. A new public beta or the final release is, of course,

available when this happens.

Please simply visit our Download page, download a newer version that the one you

have installed, and replace your copy with the newer one. FPlease first move the old

application to the trash, then move the new one into its place.

Note: Your license code will, of course, NEVER expire.

http://www.devontechnologies.com/redirect.html?id=download
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PRODUCT-RELATED QUESTIONS

Click here to read questions and answers specific to DEVONthink Pro.

If you have problems with DEVONthink Pro click here to read the troubleshooting

instructions and tips.
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TECHNOLOGY

General Concept 440

Features 441

Structure 442

Applications 444

All commercial DEVONtechnologies applications are based on a proprietary AI

technology, with rock-solid database foundation that allow them to manage large

numbers of documents or knowledge bits while analyzing them almost instantly at

the same time.



DEVONthink PRO 2.3.3 Documentation, page 440

GENERAL CONCEPT

DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new

technology at the very beginning of its development. DEVONtechnologies constantly

improves the technology and enhances it for more functionality, efficiency, robustness

and flexibility.

Development of the DEVONtechnology is a battle on two main forefronts of

information processing technology. DEVONtechnologies is working hard on unifying

both the top-down and the bottom-up AI concepts by imitating high-level functions

and simulating the basic functionality of natural systems. This leads to highly

functional, fast and efficient AI systems that can be used in a great variety of

information processing contexts, such as pattern recognition, signal processing and

information storage and retrieval.
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FEATURES

The DEVONtechnology is a rock-solid foundation suitable for a variety of completely

independent applications. Therefore it is ideal for the rapid development of a huge

range of new database-, signal-processing- and language-analysis-driven applications.

The ability to deal with any kind of digital data makes it extremely flexible.

The size of DEVONtechnology-based databases can, depending on the type of data

stored, grow logarithmically and make indexing is completely unnecessary. Also,

applications based on the DEVONtechnology improve themselves continuously (the

more data they handle, the better the results), are language-independent and iron

out any irregularities by applying fuzzy logic.
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STRUCTURE

The DEVONtechnology consists of a kernel and several layers. Together they

perform all the underlying computing, from 'simple' data handling to complex signal

processing.

Kernel: The kernel is the foundation for all layers and applications and is

responsible for data handling, semantic and associative data processing, signal

processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast,

flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary

file format (see above) allowing it to verify and repair low level data consistency,

featuring logarithmic growth of the database and logarithmic speed decrease with

increasing database size. The DEVONtechnology kernel is Unicode-aware, completely

language-independent and self-optimizing and self-organizing.

Layers: The layers form a shell around the kernel and provide high-level functions

for the applications built on top of them. The database layer, for example, is used to

store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies

and freeform databases. No indexing or primary keys are required, strings can be

unlimited in size and it's possible at any time to extend the range of pre-defined data

types (Boolean, character, float, double, signed, unsigned, string, date, time, blob,

color, size, and point). Another layer, the XML layer, makes it easy to handle XML
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code within the DEVONtechnology; it has a very small overhead, compared to DOM

parsers or available XML databases, requires no indexing and supports the tight

integration of other databases (and vice versa).
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APPLICATIONS

Some of the most likely applications for the DEVONtechnology are databases

(knowledge bases, expert systems, search engines, table-of-content-generators,

instant data-mining), intelligent agents, encryption, compression and archiving.

Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical

character recognition (OCR), speech analysis, recognition and synthesis, staticstics,

thesauri and automatic translations.

In particular, applications dependant on processing human language, either written

or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies'

main focus in the development of new applications is in these areas: databases,

'intelligent' agents, text and speech analysis, statistics.

Look forward to see a great range of different applications based on the

DEVONtechnology. A few have already been announced on the DEVONtechnologies

web site: www.devontechnologies.com.

http://www.devontechnologies.com
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OTHER PRODUCTS

At a Glance 446

DEVONthink 448

DEVONthink To Go 451

DEVONagent Pro 453

DEVONagent Express 457

DEVONagent Lite 459

DEVONnote 461

Needful Things 463

Besides DEVONthink Pro, DEVONtechnologies publishes a number of other

commercial, shareware, and freeware applications, and services that you may be

interested in.
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AT A GLANCE

DEVONtechnologies is focused on developing innovative applications for finding,

storing, and organizing information. Our main objective is to make complex yet

flexible technology that is both easy to use and lightning fast.

•  DEVONthink

•  DEVONagent

•  DEVONnote

All applications are based on the DEVONtechnology, a powerful and solid core unique

to DEVONtechnologies. DEVONthink, DEVONnote, and DEVONagent are only the

first of many more DEVONtechnology-applications yet to come.

Also, we publish and distribute useful shareware and freeware applications that help

you in your everyday work with your Mac.

•  PhotoStickies

•  Freeware applications and Services

NEWSLETTER & FORUM

Would you like DEVONtechnologies to keep you informed about updates and new

product releases? Subscribe to the newsletter.

http://www.devontechnologies.com
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And don't forget to have a look at our very lively user forum , where users of all skill

levels meet to discuss our applications, talk about our technology, and exchange tips

and tricks for DEVONthink & Co.

http://www.devontechnologies.com/redirect.php?id=forum
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DEVONTHINK

Make the dream of the paperless office come true with DEVONthink and keep

all your text and RTF files, scanned documents, notes, emails, images, chat

logs, bookmarks, and multimedia files together in one simple to use database.

DEVONthink allows you to integrate both local documents and live content from the

Internet, keeping all project- related information stored in one easy-to-access place.

WHY DEVONTHINK?

DEVONthink not only stores documents, it also facilitates editing, analyzing,

organizing, finding, and archiving your documents with its flexible work

environment, powerful organization tools, and built-in AI architecture.

INTEGRATED WORKSPACE

Unlike Mac OS X's Finder, DEVONthink provides an integrated work environment

with all the tools you need for working with information of all kinds, from simple text

to PDFs and multimedia files. DEVONthink can intelligently assist you with filing

documents, finding similar files, or searching the database, saving you the trouble of

having to manually manage thousands of files.
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As a native Mac application, DEVONthink is also tightly integrated with the Mac

OS X operating system and its frameworks. It provides a dock menu, Services menu

commands, and even makes heavy use of the Safari web browser engine and Mac OS

X 10.4's advanced PDF library.

A PAPERLESS LIFE

DEVONthink Pro Office comes with a number of 'paperless office' functions not

present in other editions of DEVONthink:

•  Advanced email archiving

•  Scanner support including optical character recognition and special

support for the Fujitsu ScanSnap

•  Integrated Web server for sharing information with other users

CHECKING YOUR UPGRADE OPTIONS

If would like to buy an upgrade DEVONthink Pro to a higher edition, you have the

following options:

•  Click here to check your upgrade options.

•  Choose DEVONthink Pro > Check Upgrade Options.

x-devonthink://purchase
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Depending on whether you have purchased DEVONthink Pro in DEVONtechnologies'

online shop or in the Mac App Store the second option may or may not be available.

Click here to read more about DEVONthink.

http://www.devontechnologies.com/redirect.html?id=product-dn
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DEVONTHINK TO GO

Your document (literally) at your fingertips. DEVONthink on the Mac keeps your

documents organized. But what about when you are away from your keyboard? Put

your documents into your pocket with DEVONthink To Go, the DEVONthink and

DEVONnote companion for the iPad, iPhone, and iPod touch.

POCKET YOUR DOCUMENTS

Browse, view, and search your documents with the touch of your finger. Create new

notes or take a picture of important information and convert it to a searchable PDF

(requires DEVONthink Pro Office on the Mac). Quickly label documents and flag

them for later review. Use the 'read' status to use it for reading the news feeds you

archive in DEVONthink on the go.

You decide which databases and which groups and documents to synchronize with

your device. DEVONthink To Go connects to its Mac counterpart via WiFi.

AT A GLANCE

•  Take your DEVONthink or DEVONnote databases with you. Use

the 'Sync' group to select only those groups and documents that are

important for you.
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•  Use the global inbox to write down your notes without the need to

immediately decide where to file them. If you use GTD you will know the

idea.

•  Quickly access all recently used items or view them as pins on a map.

DEVONthink To Go stores your current location with every note you

create on the go.

•  Use the fast full text search to find the document you need with just a

few taps. Use the power of SQLite on your mobile device.

•  DEVONthink To Go honors the 'read' status of its Mac counterpart and

can be used as a simple news feed reader.

•  Set a password for your databases on your Mac and keep them from

prying eyes on your iPad or iPhone.

•  Capture data or open documents in third-party app like GoodReader. Add

PDFs, images, or text documents from other apps to your DEVONthink

Inbox.

Read more more about DEVONthink To Go or visit the App Store.

http://www.devontechnologies.com/redirect.php?id=product-dttg
http://www.devontechnologies.com/redirect.php?id=buy-dttg
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DEVONAGENT PRO

DEVONagent Pro helps you search more efficiently on the web. It searches multiple

sources, frees you from hunting for the really relevant results, and gives you power

tools for your research.

•  Filters bad results so you don't have to

•  Shows results the way you want

•  Creates reports in many formats

•  Saves searches so you can continue later

YOUR PERSONAL META SEARCH ENGINE

DEVONagent Pro is not a simple Google interface. It knows how to talk to search

engines — and how to squeeze the best out of them.

DEVONagent connects to as many search engines as you want, collects the data, and

weeds out the junk that managed to slip through. It also scans your favorite websites

and notifies you when it finds something that matches your query. It can even do all

of this while you're sleeping; the results will be ready before you pour your first cup of

coffee.
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GET THE GOOD STUFF, SKIP THE JUNK

DEVONagent Pro is all about filtering what you don't want and giving you the best

tools to find more of what you really want.

DEVONagent Pro doesn't simply trust the search engines. It filters all returned

results again, allowing you to use advanced Boolean operators, proximity operators,

and wildcards of unlimited complexity — something no single search engine allows

you to do. DEVONagent's "scanners" can even find thumbnail galleries or linked PDF

or Office documents for you. When you've found what you're looking but want a little

more detail, the unique See Also list contains related pages from elsewhere in the

search results, online and even from DEVONthink Pro.

THE INFORMATION YOU WANT, THE WAY YOU WANT

Every research tasks is different. DEVONagent Pro supports this with many ways to

list, read, even explore your data.

View the results as a list or as a smart text summary, and explore them with the

topics map. Unread results are marked with a blue dot, just like in Apple Mail, so

that you don't miss the one important piece of information you're looking for. Finally,



DEVONthink PRO 2.3.3 Documentation, page 455

for viewing web pages there's DEVONagent Pro's specialized web browser. Extract

images, RSS feeds, links, email addresses, even linked documents with a single click

and save them for reference or reuse.

SAVE YOUR RESEARCH AND COME BACK LATER

Research is not only about finding, it's about collecting data, sharing it, and using it

to create something meaningful.

DEVONagent Pro exports your filtered and trimmed-to-the-max research results in

a variety of formats, from a simple list of bookmarks to comprehensive RTF digests

and PDF reports. The built-in, searchable archive keeps them for later reference, or

you can send your results to DEVONthink. Finally, you can save your search and

continue later on, or even share it with others via email.

HOW DEVONAGENT PRO CAN HELP YOUR RESEARCH

•  Researchers: Stay up-to-date on your subject with scheduled searches.

Search through specialized online databases, scan important web sites,

and get smart summaries. Extract the key facts using DEVONagent

Pro's research-centric web browser.

•  Students & educators: Find better course materials faster, with

DEVONagent Pro weed out the chaff. Cite references for your papers
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and extract images and lists of links with a single click. Save interesting

results in DEVONagent's archive or in DEVONthink.

•  Journalists: Keep an eye on as many other information sources as you

like and dig deeper into the subject you are writing about. Use the smart

See Also function to learn more about the article you're reading. Save a

search and return to it later if you get interrupted.

•  Lawyers: Search LexisWeb and FindLaw efficiently with advanced

Boolean operations, and use See Also to find related data with a single

click. Export comprehensive reports, or save the results for future

reference in DEVONagent’s archive or in DEVONthink.

•  Power users: Use DEVONagent Pro's specialized and easily automated

browser to find and collect information and file it in DEVONthink. The

object drawer and extensive AppleScript, JavaScript, and Automator

support make it the #1 browser for DEVONthink users and enthusiasts.

Click here to read more about DEVONagent.

http://www.devontechnologies.com/redirect.html?id=product-da
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DEVONAGENT EXPRESS

You love Spotlight but it searches only your Mac? DEVONagent Express combines

the ease-of-use and ubiquity of Spotlight with the powerful web search technology

of DEVONagent. Just like Spotlight searches your computer DEVONagent Express

searches the web and presents the results directly in its menu.

WHY DEVONAGENT EXPRESS

•  Let's you search the web as easy as using Spotlight

•  Shows convenient summaries and preview pictures

•  Express mode gives you results quickly but unfiltered

•  Agent mode does a thorough research, filters advertisements and error

pages, and gives you only really relevant results back

•  Talks to Google, Bing, Yahoo, YouTube, Facebook, Twitter, the App Store,

and more than 80 other general-purpose and specialized search engines

PERFECT INTEGRATION

•  Located directly in the menu bar, always there when you need it

•  You already know how to use it

•  Opens results in your web browser or DEVONagent (if available)
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•  Drag results to other apps, e.g. your favorite bookmark manager, into

documents, or to the Finder

•  Accessible by pressing a hotkey
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DEVONAGENT LITE

DEVONagent Lite puts web search to where it belongs: next to Spotlight into your

menu bar. Search all major and many specialized search engines and databases with

a single click.

•  Web search always at your fingertips

•  All major search engines and many special ones

•  Opens results directly in your web browser

•  Use it free of cost!

SEARCH THE WEB LIKE WITH SPOTLIGHT

DEVONagent Lite adds a web search field to your menu bar. Google, Bing, and many

more always at your service. Its global keyboard shortcut saves you even that click.

Just click DEVONagent Lite's menu bar icon, or press its keyboard shortcut, and

start typing instead of switching to your browser, opening a new window, and clicking

the search field first. Hit Return and DEVONagent Lite opens the search results in

your default browser.
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USE THE BEST ENGINE FOR THE JOB

Google & Co. are great for general questions but often it's better to ask the right

people who really know.

Choose your search engine of choice from the magnifying glass pop-up menu to

directly search in developer resources, blogs, dictionaries, directories, discussion lists,

legal or medical databases, news, or reference sites such as Wikipedia. Find Facebook

profiles, tweets, or images without deviation.
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DEVONNOTE

DEVONnote helps you take notes and keep them organized. It keeps all your ideas,

documents, important information, and even your web browser's bookmarks in one

single, accessible place. DEVONnote supports you with professional, easy-to-use

features, and helps create structure out of chaos with its unique AI functions.

DEVONnote is the most sophisticated notepad application for Mac OS X, and the

only one that uses AI (artificial intelligence) instead of relying on you organizing your

data completely manually.

WHY DEVONNOTE?

DEVONnote was designed with the typical Mac user in mind-a user who is:

•  Creative

•  Savvy (whether at work or at home)

•  Desiring quality software

Consequently, DEVONnote comes with a clean, easy-to-use interface that gives you

all the tools you need in a familiar Mac-like package. Even the most complex AI

functions are just »buttons«, meaning one simple click can send DEVONnote into

action, digging through all of your data to find a place for your latest note, or to show

you all your ideas and concepts that are similar to the one you've just selected.
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BRAIN FOOD INCLUDED

Of course, creative people don't just 'have thoughts', they often need new inspiration,

too. We understand that, and that's the reason why DEVONnote comes with a

complete Safari-based web browser and solid, but flexible, bookmark-managing

capabilities. With DEVONnote, you can browse your favourite websites, then clip and

save the most important information directly to your DEVONnote notebook.

But, of course, life is not just work! Use DEVONnote to watch and organize your

favorite webcams, directly within your notepad.

Click here to read more about DEVONnote.

http://www.devontechnologies.com/redirect.html?id=product-dn
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NEEDFUL THINGS

EASYFIND

As an alternative to the Finder's find function, EasyFind finds files, folders, or

contents in any file without the need for indexing. This is especially useful if you

are tired of slow or impossible indexing, outdated or corrupted indices, or if you are

just looking for missing features like case sensitive or insensitive search, Boolean

operators, wildcards, or searching for phrases. In addition, EasyFind uses multi-

threading and is therefore very responsive, even with multiple search processes

running. The application provides contextual menus and Mac OS X Services,

and displays the location of each item in a separate column for a better overview.

EasyFind uses little memory, supports drag-and-drop and the clipboard, and

optionally finds invisible items or items within packages.

PHOTOSTICKIES

PhotoStickies puts all your favorite pictures on your desktop, as stickies, floating

or even borderless. Sticky pictures may reside on your computer, or on the

Internet. PhotoStickies also displays live webcams on your desktop, updates them

automatically, and even records them like a VCR.
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Key features:

•  Displays all image formats supported by Mac OS X

•  Displays local images, pictures located on the Web or webcams

•  Shows images as stickies or as desktop wallpaper

•  Many live effects, e.g. alpha channels, transparency, color corrections

•  Savable states

•  Internet-based list of new webcams

•  Can run as a menu extra

THUMBSUP

ThumbsUp is a simple, drag-and-drop based utility designed to create thumbnail

images from batches of pictures. (The application supports all Mac OS X and

QuickTime image formats, including PDF documents.) Image size, quality,

sharpening, and antialiasing are configurable, and images can be scaled by

percentage or limited to a maximum size. With a scaling of 100 percent, ThumbsUp

may be used as an ultra-fast, comfortable image converter.

Use ThumbsUp to quickly create thumbnails, e.g., for using on your Web site or for

sending by email.
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XMENU

XMenu brings back Mac OS 9's Apple menu back from the dead, adding its

functionality to Mac OS X. One or more global menus to the right side of the menu

bar let you easily access your preferred applications, folders (and subfolders),

documents and files Furthermore, there's no explicit need for a configuration (like

creating lots of folders and aliases or adding items to user-defined setups)-just

activate the menus you like: Applications, Developer Applications, Home, Documents,

or User-Defined (like the old Apple menu found in Mac OS 9).

FREEWARE SERVICES

Besides the full-blown freeware applications, DEVONtechnologies also offers a

variety of useful services that extend the functionality of Mac OS X's Services menu

and that allow Cocoa applications like TextEdit or DEVONthink to open PDFs like

simple RTF files. These services include:

•  BlueService

•  CalcService

•  PDF2RTFService

•  WordService
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Click here to read more about DEVONtechnologies' freeware applications and

services.

http://www.devontechnologies.com/redirect.html?id=product-freeapps
http://www.devontechnologies.com/redirect.html?id=product-freeapps
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